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Preface 
Cardbox was conceived 25 years ago and it was born in 1982.  It has been used by 
hundreds of thousands of people since then, and many of them have become 
addicts: we can tell when they move from one job to another because their new 
employer has to buy them Cardbox to keep them happy and productive. 

Cardbox 3.0 for Windows, which you are looking at now, is the eighth major version 
of Cardbox.  In our archives we still have the very first concept sketch for the very 
first Cardbox, drawn long before Windows was invented.  That sketch already shows 
some of the distinctive features that have stayed in the Cardbox family throughout its 
life: especially the concept of indexing every word in a field, and of marking which 
words should be indexed and which shouldn’t.  It has been a constant puzzle to us 
why other databases don’t adopt such a simple feature; or, indeed, some of the 
other features we’ve invented, such as tagging (p.93) or batch editing (p.155).  
These things are so obvious and so natural that once you’ve tried them it is very 
difficult ever to live without them again.  We are puzzled why other software 
manufacturers haven’t imitated them, but we’re also grateful: it makes a better 
market for us. 

What is Cardbox?  That’s a difficult question to answer.  You can put information into 
Cardbox, you can search it, you can get it out again.  That makes Cardbox a kind of 
database, but if you say “database” to most people, they think of complexity, 
elaborate programming, and having to spend hours doing data analysis before you 
even start. To use the same name for something like Cardbox, where if you put 
something in, it’s in, and you can see it, and you can find it again – to use the same 
name for something that straightforward seems indecent.  Perhaps the best thing we 
can suggest is to look at Part Six of this book (p.211), where you’ll find many 
examples of Cardbox databases created by us and other people, and you’ll begin to 
understand why for so many users Cardbox becomes a way of life. 

The Cardbox Book 
Why do we call this book a book and not a manual?  Because we’ve seen what’s 
happened to computer manuals.  Once upon a time you could hope to learn your 
way around a product just by reading its manual.  No longer.  Today, manuals are 
mostly detailed lists of commands and step-by-step instructions for performing every 
conceivable operation, without any suggestion of what the basic concepts are, of 
what this product is actually about.  If travel guidebooks resembled these manuals, 
they’d spend all their time teaching you how to use the ticket machines in the railway 
stations and they’d never say anything about what being in a country was really like. 

The difference between a book and a manual is that you only see a manual after 
you’ve bought the software and opened the box, and then it’s too late and you have 



  xiv    Preface  

 

to read it.  A book is something you can take off the shelf and glance through, and if 
you don’t like it, you can put it back.  Making a book is much harder than making a 
manual: a manual doesn’t need to be worth reading; a book has to be. 

The Cardbox Book is designed from the beginning to be a book.  Its aim is to give 
you an understanding of what Cardbox is all about: what it’s useful for, how it works, 
how it thinks.  We reckon that once you’ve got these things under your belt, the 
mere step-by-step details are easy.  Either they’ll be obvious already and you won’t 
have to think about them, or you can press a key and look them up in the Help.  But 
the understanding has to come first, and that’s what this book is for. 

Our goal has been to make something so interesting, and so clear, that you’d buy it 
to read on the train even if you didn’t own a computer.  Perhaps that’s impossible, 
but we’ve had fun trying; and the result is a lot closer to the ideal than any other 
computer book we’ve ever seen. 

Cardbox - Home Edition 
If the thing you’re holding in your hands says “Cardbox Home Edition”, you’re 
looking at a slightly different kind of animal.  This is no longer just a book that tells 
you how to use Cardbox, it actually is Cardbox itself, and you’ll find the software on 
a CDROM at the back of the book, ready to load into your computer. 

As you might expect from its name, the Home Edition of Cardbox has fewer features 
than the Professional Edition, and it costs quite a bit less.  To design the Home 
Edition, we went carefully through the Professional Edition and removed features 
that were relevant only when several people were sharing a database (eg. profiles 
and passwords) or when the user of the database wasn’t the designer of the 
database (eg. validators) or that needed quite a bit of expertise from the database 
designer and quite a lot of support from us (such as macros and programming).  We 
also limited the capacity to 10,000 records per database, which is more than enough 
for practically everyone: we reckon that if you have more than 10,000 friends, or 
10,000 books or CDs, or even 10,000 photographs to index, you should be able to 
afford the Professional Edition.  You can find a precise list of the differences 
between the Home Edition and the Professional Edition on page 13. 

Our aim has been to produce something that isn’t a truncated version of something 
else but is complete in its own right: we hope we’ve succeeded.  We also hope that 
the Home Edition will make Cardbox more infectious.  Cardbox has always spread 
best by personal recommendation, and anything that we can do to encourage that 
process is worth doing.  Tell your friends to try the Home Edition: now that it costs no 
more than a good dinner for two, they have no excuse not to; and if it’s as good as 
you (and we) say it is, they’ll be very grateful. 
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How to read this book 
If you want some inspiration to keep you going, start with Part Six (p.211), which will 
show you some of the things that other people have done with Cardbox and will give 
you ideas for how you might use it yourself.  It’s often easiest to absorb information 
when you have a definite plan in mind. 

But otherwise, this book is meant to be read from beginning to end, starting from the 
basic concepts and carrying on from there: so begin at the beginning, go on till you 
come to the end; then stop. 

Acknowledgements 
At this point in a book it’s usual to see a list of names of all the people the author 
wants to thank.  The trouble with a project that’s lasted more than twenty years is 
that this would be rather a long list and very boring for the reader. 

So – very many thanks to everyone who ought to be thanked (you know who you 
are).  Thanks also to our users, without whom we’d have had a quieter life, but 
whose requests and feedback have made Cardbox into the powerful program you 
see today.  You know who you are, as well. 

Finally, we’d like to thank specifically those people who allowed their databases or 
their stories to be included in this book, including Shaun Seager at Action Technical 
Services; Daniel D’Alessandro; Sonia Elso Galano at INIA, Chile; Augustine Ford; 
Alan Humphries at the Thackray Medical Museum; John Huskisson at Winifred West 
Schools; Paul Smith at the University of Wales, Bangor; Professor Christopher Spry; 
Charles Welling at Atlas Van Stolk; and The Reverend Canon Dr Peter Williams at 
Ecclesall Parish Church.  We also thank all the other Cardbox users who responded 
to our requests for user stories.  The information they gave us was a great help. 
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Introduction 

What is Cardbox? 
Cardbox is a flat-file database program.  It lets you design your own databases, so 
you can make them hold anything – people’s contact details, books, abstracts, 
photographs, biographies, CVs of job applicants, personal records, lists of stolen 
antiques, museum catalogues, contracts and official documentation, confidential 
accident reports, poisoning incidents.  Databases don’t just store textual information: 
they can also contain images (photographs, drawings, scanned documents), and, in 
the Professional Edition, objects (such as spreadsheets or word-processed 
documents).  Throughout this book we’ll give you examples of Cardbox databases 
and stories of how people are using them.  We hope they’ll give you ideas and 
inspiration. 

Cardbox databases can be as small or as large as you like: the limit is 16,000,000 
records for the Professional Edition or 10,000 records for the Home Edition.  The 
records can be as simple or as complex as you like.  You can have a number of 
databases open at the same time.  

You can store your databases on your own computer, or you can share them across 
a network, or even across the Internet.  With the Professional Edition, you can set 
up security so that no-one can access your data without the right password and you 
can set up different levels of security so that some people are allowed to view 
records while others can edit and update them.  The security mechanisms also apply 
to fields within a record: you can stop certain people from altering particular fields or 
even from seeing them at all. 

You don’t need to program Cardbox.  You simply design a format to contain your 
data and then you start entering the data.  When you need to present information in 
another form (summary reports, standard letters, etc) you just create another format.  
At the same time, Cardbox is programmable if you want it to be, through its own 
internal macro system (which uses Microsoft’s VBScript as the programming 
language) or from external programs such as Visual Basic or Microsoft Word. 
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About flat-file databases 
Flat-file databases are simple and straightforward, which prejudices some people 
against them because they think that simple must mean trivial.  With Cardbox, it 
doesn’t. 

You can imagine a flat-file database to be like a card index but easier and quicker to 
search.  Cardbox can index every word in a record for fast retrieval.  With an index 
like that, you can make your searches as elaborate as you like; you can store and 
search millions of records; and you can have many databases open at the same 
time and set up links between them.  Many of Cardbox’s features, such as Batch 
Edit and relational linking, make traditional relational databases unnecessary; and 
some features, such as tagging, are almost impossible to implement in a relational 
model.  Throughout the history of Cardbox we’ve concentrated on keeping the 
concepts clear and simple and putting the sophistication where it should be – under 
the hood, making the simplicity work fast, and as a result we’re constantly surprised 
by the uses that our users put Cardbox to. 

If you come across a relational database snob who looks down on you for using 
Cardbox, don’t be embarrassed.  Experts like relational databases because 
relational databases make more work for experts.  They are complex structures that 
contain interrelated “tables” of distinct entities.  Designing a relational database is 
not a trivial task.  You need to analyse exactly what every data element is and how it 
is being used, and you need to check how these things will interact or might interact 
in the future.  In the hands of an expert, a simple library card index can get 
fragmented into separate tables for author, publisher, edition, and so on, and at the 
end of it all you still won’t be able to search for titles with particular words in them… 
unless the designer goes away and creates another couple of tables.  Something 
that takes half an hour to design in Cardbox can take a week with a relational 
database. 

The history of Cardbox 
The Cardbox for Windows you are reading about now is a distant descendant of the 
very first Cardbox, which was published in 1982.  Cardbox has evolved a long way 
since then, but always with the same team behind it.  Our goals are the same now 
as they were then – simplicity, speed, power – but of course, with computers 1,000 
times faster and disks 10,000 times larger, Cardbox today can provide features that 
were unimaginable twenty years ago. 

Here’s a very brief summary of what has happened to Cardbox since the beginning: 

1980 – The first versions of Cardbox start running, on 8-bit microcomputers running 
CP/M. 
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1982 – The first commercial version of Cardbox is published for us by Caxton 
Software in London. 

1983 – Versions of Cardbox appear for 16-bit computers running MSDOS, including 
the newly released IBM PC.  Portable Cardbox is developed for the 
manufacturers of the world's first portable PC, the Osborne 1.  Cardbox-Plus 
appears. Published directly by us (like all subsequent versions), it has many 
enhanced features and comes in both 8-bit and 16-bit versions. 

1984 – Networking and multi-user versions of Cardbox-Plus are launched. 
Pioneering features include invisible file and record locking and the instant 
mutual update of records between users.  Epson Computer Corporation bundles 
Portable Cardbox-Plus on a ROM chip in the world’s first laptop, the Epson 
PX-8. 

1986 – A lightweight version, called Personal Cardbox-Plus, appears. 

1988 – Version 3 of Cardbox-Plus can be programmed using any programming 
language you want.  We call this technique “coprogramming”; when Microsoft 
reinvent the concept a few years later, they call it “OLE Automation” (later, 
“Windows Automation” or just “Automation”). 

1990 – Version 4 of Cardbox-Plus doubles the maximum record size. Picture 
Cardbox is launched. This is the first non-Windows database to contain built-in 
support for compressed images. 

1991 – Cardbox-Plus for VAX/VMS appears.  

1994 – Cardbox for Windows appears. 

1996 – Version 1.1 of Cardbox for Windows. 

1999 – Version 2.0 of Cardbox for Windows. 

2004 – Version 3.0 of Cardbox for Windows appears.  It includes a completely new 
client-server architecture for networks and the Internet. 

As you can see, we’re in this for the long term.  We engineer our software solidly so 
that it’ll go on working for ever, and whenever we have to expand the database 
format to handle bigger records, or more records, or images and objects, we make 
sure that your old databases stay readable.  If you have a Cardbox database on a 
5¼” floppy disk from the mid-1980s then you may have difficulty finding a computer 
that can read disks of that size; but once you’ve read the disk, Cardbox can convert 
your data to the latest format so that nothing is lost. 
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Cardbox as a software package 

Finding your way through the features 
A software package is a conjuring trick that gives you tens of thousands of man-
hours’ worth of programming for the price of an hour or two’s consultancy.  The trick 
works because enough people have similar enough needs to make the economics 
worthwhile.  Inevitably this means that there are features that you don’t want to 
use – perhaps even features you can’t imagine anyone else wanting.  Don’t worry: 
those unwanted features aren’t a waste.  On the contrary, they are what attracted 
other people to the package, so there were enough of you out there for you all to 
share the cost of development between you; they are what made it cheap enough 
for you all to buy. 

As you read this book, if you come across a feature or a command that you can’t 
imagine you’d want to use, just glance at it, skip over it, and go on to the next thing.  
After a couple of months of using Cardbox you should come back to the book and 
look at the bits you skipped, just in case you’ve discovered the need for something 
that at first sight seemed irrelevant.  But if nothing new jumps out at you on the 
second reading, don’t worry: your own personal “mini-Cardbox” is doing what you 
want it to do and it’s doing it well. 

To help you with the business of deciding what to read, we’ll try to tell you which 
features we think are important (especially if, like batch editing, you may not instantly 
see why they make such a difference) and, equally, we’ll tell you which features are 
very specialised: indispensable to anyone who needs them but of no interest to 
anyone else. 

Going beyond the edge 
An important question about packaged software is what happens at its edges.  You 
may have specialised requirements that aren’t covered by the standard package and 
you may need to go just one step beyond it: what happens then? 

With Cardbox, we’ve done two things about this.  First of all, it’s easy to exchange 
data with other programs: so, for example, if you want to use Cardbox to store the 
data for your corporate accounts, you don’t have to worry that Cardbox isn’t an 
accounting program and that your accounting software isn’t nearly good enough at 
data handling.  You store the data in Cardbox and export them to the other program 
when needed.  That way each program does what it’s best at, and you get the job 
done without having to compromise. 

The other thing that we’ve done at the edges of Cardbox is to make it 
programmable.  We use Microsoft’s VBScript as a programming language (this is a 
cousin of Visual Basic and the VBA programming language used by Microsoft 
Office).  Cardbox has a macro facility that lets you record your actions within 

The macro recorder is a 
feature of the 

Professional Edition.
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Cardbox and play them back later by pressing a single key; but you can also expand 
the scope of the macros to make them into small programs in their own right.  These 
programs have full access to Cardbox data and Cardbox commands.  To take one 
example: if you have a database of people and want to send a bulk fax to some of 
them, customised for each recipient, a short macro can take care of formatting each 
fax and passing it on to your fax program. 

The programmability also works from the outside in: for instance, if you are used to 
writing macros in Microsoft Word then you can easily expand your macros to 
communicate with Cardbox and pick up data from your databases for use in your 
Word document. 

About this book 
Our ambition was to write a computing book that was so interesting, you’d buy it to 
read on the train even if you didn’t have a computer.  Perhaps that’s an impossible 
goal, but we hope that we’ve got a lot closer to it than most computer manuals.   

We start by telling you how to install Cardbox.  After that, we give you a quick 
overview of the basic concepts of Cardbox.  Once you’re familiar with what indexing, 
fields, and formats mean, you’ll find it easy to understand everything else. 

Then we take you through the main functions of Cardbox.  First we describe how to 
use an existing database, then how to enter data, then how to design formats, and 
finally we tell you how to create and design a completely new database.  You may 
feel that we’re doing this backwards but there’s actually some good logic behind all 
this.  The more you know about Cardbox, the more you’ll know about what it can do, 
and the better prepared you’ll be to produce a database design that does the things 
you want it to do.  Cardbox is very flexible about letting you change your design 
even after you’ve started entering data, but still there’s no harm in getting it right first 
time! 

To give you some more inspiration for your database designs, we give you some 
examples of Cardbox databases, most of them adaptations of databases that real 
people are already using.  You may find you can adapt one of these designs to your 
own requirements, but in any case they will give you some useful ideas.  

After the main explanations we take you through other important topics such as 
security, backup and disaster recovery, and we give you a taste of some of the 
advanced features of the Professional Edition, such as what macros are and what 
you can do with them. 
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Getting help 
This book is not the only source of information about Cardbox: there is also a help 
file, which contains separate articles about every command in the whole of Cardbox, 
plus step-by-step guides to specialised topics (for example, importing data from 
Excel spreadsheets).  The help file works like a mini-web site – articles have links to 
other articles – and it also has a table of contents, an index, and a search facility. 

This book and the help file are complementary.  The aim of this book is to tell you 
everything you need to know in order to understand Cardbox, what it does and how 
to make it do what you want.  Once you have that basic understanding, the help file 
gives you detailed information and more of the technical background. 

Commands for opening Help 

F1 = Help 
Wherever you are in Cardbox, you can press the F1 key.  The help file will open and 
show you a page relevant to where you currently are.  If you’re in the middle of a 
command, it will give you help on that command; if you are editing a format, it will tell 
you all about editing formats.  In addition to responding to F1, some command 
windows have a Help button of their own: this does exactly the same as F1. 

The Help menu 
Help > Contents opens the help file’s table of contents. 

Help > Index opens the help file’s index. 

Help > Search lets you search for a word or phrase in the help file. 

Getting help on menu commands 
When you open a menu and move your mouse over the various commands, watch 
what happens to the status bar at the bottom of the Cardbox window.  As you move 
over a command, the status bar will show a brief explanation of what the command 
does.  If you want more information, press F1 while you still have the mouse over 
the command. 

You can do the same sort of thing even if you are using the keyboard rather than the 
mouse.  To highlight a menu command, open the top-level menu with a keystroke 
(for example, Alt + F for the File menu) and then use the up and down arrow keys to 
move through the menu. 
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Why is this menu command disabled? 

If a menu command isn’t available for some reason, Cardbox disables it.  Disabled 
commands still appear in the menu but they are shown in grey.  Commands are 
usually disabled when the particular conditions they require don’t exist: for example, 
a command to delete records will be disabled if there’s nothing available to delete. 

To see why a command is disabled, move the mouse onto it and look at the status 
bar.  If you hold the mouse over the disabled command for a second or so, a larger 
window will pop up and give you a more detailed explanation. 

What the help window contains 
The window that opens onto the help file is quite small to start with but you can 
resize it if you want.  The right-hand side of the window shows a help article and the 
left-hand side shows one of three navigational tabs: Contents, Index, and Search. 

The Contents tab shows the help file’s table of 
contents.  To open a section and see the articles 
it contains, double-click on it, or click once on 
the + sign to its left. 

The Index tab contains an index of key words 
and phrases.  You can double-click on an index 
entry in the list or you can type a keyword and 
press the Display button.  If there are several 
articles indexed under your chosen keyword, 
Help will pop up a list and let you pick the one 
you want. 

The Search tab lets you type in any word or phrase.  Pressing the List Topics button 
will then find all the articles that contain your search text.  

Help Points 
As you read through this book, you’ll see references to “Help Point” and a number.  
Help Points are help file articles that give you more details on something the book is 
talking about: in many cases they also have links to other parts of the help file.  To 
view a help point, use the command Help > Help Points and then type in the number 
of the help point. 

 

References to Help Points 
usually appear in the 

margin.
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Reliability and support 

Reliability 
Car manufacturers used to be too shy to talk about how well their cars behaved in 
crashes because it might suggest to their customers that cars sometimes crashed.  
They got over their shyness in the end, and it’s time that software manufacturers did 
the same. 

There is nothing inevitable about software bugs.  We know we can make perfect 
software if we try (the early versions of Cardbox had no bugs at all), and we want 
our users to get the benefit of our software: we want it to work for them and to work 
well.  Cynics say that a dollar spent on making sure a product works brings less 
return than a dollar spent on convincing people that it does.  We aren’t economists, 
but from our longer-term perspective we can see that a pound spent on proper 
software development produces rewards forever while a pound spent on marketing 
is soon forgotten. 

Here’s what we are doing to make your computer work better for you when you’re 
using Cardbox: 

• We keep your data safe.  We have made the Cardbox database engine a 
separate program from the Cardbox you see on your screen (you don’t notice 
this because the engine starts invisibly whenever it’s needed).  The Cardbox 
engine is a small program, it has a well-defined function, and it doesn’t go 
wrong.  It’s the part of Cardbox that has changed least over the years – and old 
software is the safest software.  Even if something goes wrong with the rest of 
Windows and makes the visible Cardbox program crash, your data will be 
unharmed. 

• If, despite all this, anything ever does go wrong with your data (for instance, if 
there is a power cut just as your computer is writing something to the disk) there 
are functions in Cardbox that let you rebuild your database. 

• We are still aiming for zero bugs, so we take bugs very seriously.  Whenever 
someone reports a problem, we hope it is our fault – because if it’s our fault then 
we can correct it.  But if it turns out that the trouble is caused by a printer driver, 
or an anti-virus program, or Windows itself, we’ll do our best to identify the bug, 
explain it to you, and we’ll reprogram Cardbox to avoid the bug even if it isn’t our 
fault. 

Bugs are rare.  When we looked through our database of users to see who might 
have interesting stories for us, we realised that most of them were people who’d 
installed Cardbox without trouble and never had any need for support after that.  It’s 
very likely that this will be your experience too. 
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Getting support 
The Cardbox web site is the first place to go for support.  It has articles answering 
the commonest questions and it gives you up-to-date information about access to 
mailing lists or forums in which Cardbox users can give each other advice.  It also 
tells you how to get support from us if you need it.  What direct technical support you 
are entitled to depends on which edition of Cardbox you have, whether you’re 
paying a technical support subscription, and so on.  If you have bought your copy of 
Cardbox from a distributor outside the UK, other rules may apply.  See the 
documentation that came with your copy of Cardbox for details, and if you’re still not 
sure, have a look at the web site. 

Reporting problems 
Recently, we praised one of our users for the clarity and completeness of a problem 
report he sent us.  It turned out that this kind of reporting was second nature to him 
because he was a retired test pilot. 

You may not be a test pilot, but here is how to report a problem to us so that we 
don’t have to get straight back to you with a request for more information – which 
would be tedious for us and frustrating for you. 

1. Tell us who you are and what the serial number of your copy of Cardbox is.  This 
not only helps us check your entitlement to technical support but also tells us 
exactly which version of Cardbox you’re using. 

2. Be specific.  What exactly is happening?  If a message appeared, what exactly 
did it say?  If something unexpected happened, what was it and how did it differ 
from what you expected?  “The mailing labels don’t print right” is far less helpful 
than “the second column of labels is ¼” too far to the left”. 

3. Remember that we can’t see what you are doing.  Don’t be afraid to describe 
every detail of what you did: every keystroke and every mouse click. 

4. If something is going wrong, does it go wrong every time you try it?  Or only 
sometimes?  Are you able to give us enough information for us to be able to 
reproduce the problem for ourselves? 

5. Did it start happening recently?  If you installed a new version of Internet 
Explorer last week and your Cardbox screen layout has started to look a little 
strange since then, we have a good idea of where to search for the cause of the 
problem.  (This is not a fictional example: some Windows fonts have bugs in 
them, and Internet Explorer sometimes installs new fonts: in the past we’ve had 
to reprogram Cardbox to work round bugs like that). 

Not every problem that is reported to us is a bug.  In fact, most problems aren’t.  The 
more clearly you report the problem, the better we will be able to explain to you what 
is going on and what you should do to make things happen the way you want. 

http://www.cardbox.com
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Screen shots 
Windows is a graphical environment and if your problem is that “the screen looks 
funny” then a snapshot of what you’re actually seeing is often the best way of telling 
us what is going on. 

To capture the screen 

The first step is to copy the screen display to the Clipboard. 

To capture the whole of the screen – press the Print Screen key.  This copies the 
entire current screen display (except the cursor) to the Clipboard. 

To capture a single window (for example, a command window, or a message, or 
the Cardbox window as a whole) – hold down the Alt key as you press Print 
Screen.  Windows copies the currently active window display to the Clipboard. 

To send us the captured screen 

You have to save your capture to a file and send it as an attachment.  There are 
various ways of doing this and some are better than others.  Try not to paste the 
captured image directly into Outlook because this will store it as a .BMP file (usually 
about 2.2MB in size), which wastes disk space and makes it slow to sent.  Word 
often compresses images when they’re stored as part of a document, so that the 
overall Word document can be very much smaller (in one test, the 2.2MB image was 
reduced to a 90KB document).  Otherwise, you can open Windows Paint, paste the 
image, and use File > Save As to save it as a GIF file (not BMP).  If you have access 
to Adobe Acrobat then you can also paste your screen shots into a document and 
“print” the document to a PDF file. 

Error logs 
Cardbox keeps a log of major events that occur while running it, and if we are trying 
to trace the cause of a recalcitrant problem we may have to ask you to send us the 
error log, or even to turn on additional logging options within Cardbox in order to put 
more information into the log.  If this is necessary, we’ll tell you exactly how to go 
about it, using the command Tools > Options » Log. 

Protect yourself against disaster 
Even when your software is perfectly reliable, your hardware isn’t.  Back up your 
data regularly.  We have a cycle of daily backups onto rewritable CDs and weekly 
backups onto CD-R.  The weekly backups are kept for ever.  Given how small CDs 
are and how cheap they are, there is no excuse for you not to do the same.  When 
your hard disk crashes and your computer needs to be scrapped, you should be 
able to laugh, buy a new computer, copy your backups onto it, and carry on from 
where you left off. 

Windows Paint can be 
found in the Accessories 

section of the Start menu.
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Installing and managing Cardbox 

The different editions of Cardbox 
There are three editions of Cardbox available.   

The Client Edition is available free of charge.  You can download it from our web 
site and use it to access Cardbox databases on the Internet; it can be distributed 
on a CDROM together with Cardbox databases, for the benefit of users who 
haven’t already got Cardbox (see “Distributing Cardbox Databases”, p.20); and 
on a corporate network, the Client Edition can be used to access databases on a 
Cardbox Server. 

The Home Edition is a straightforward version of Cardbox suitable for most single-
user applications.  If you have a CDROM in the back of this book, it’s probably 
the Home Edition. 

The Professional Edition has additional advanced features for use in business or 
where several different people may be using the same databases. 

 

 Client 
Edition 

Home Edition Professional 
Edition 

Databases on 
your own 
computer 

Read-
only 
access. 

Read/write access for 
databases up to 10,000 
records in size; read-only 
access for larger databases. 

Read/write 
access (no size 
limit). 

Databases on a 
Cardbox server 

Read-only or read/write access, depending on what the server 
has been set up to allow. 

Advanced 
features 

Not available. Available. 

Number of 
users per 
Cardbox Server 

Limited to the number specified by the 
Cardbox Server licence. 

Unlimited. 

Read-only access means that you can open a database and view, search, browse, 
and print records.  You cannot add, edit, or delete records; make changes to 
formats; or create a new database. 

Read/write access lets you do everything, including creating and modifying records, 
formats, and databases. 

If you’ve already got 
Cardbox installed and 
you’re not sure which 

edition it is, 
Help > About Cardbox  

will tell you.
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Advanced features 
The following advanced features are part of the Professional Edition only: 

• User profiles with passwords – to control who is allowed to open a database and 
who is allowed to do what with it.  

• Validators – to check the data being entered and reformat, display warnings, and 
enter default values.  

• Data encryption – to keep your database permanently encrypted even while it's 
being used.  

• Macros – to automate common and repetitive tasks.  
• Customisation of the user interface (keyboard shortcuts, menu, and toolbars) – 

to reduce the amount of time needed to train staff.  

What these additional features have in common is that they are either technically 
advanced or not needed when the owner of the database is also the only person 
who uses it, and this is why we have left them out of the Home and Client editions. 

Although the other editions cannot set up these advanced features, they can use 
them.  For example, only the Professional Edition can encrypt a database but any 
edition can open an encrypted database; only the Professional Edition can set up 
user profiles but the other editions will understand them and let you choose which 
profile to use. 

Upgrades 
If you buy the Home Edition but later decide that you need the Professional Edition, 
you can upgrade: see the Cardbox web site for details. 

Installing Cardbox 

Installing from a CDROM 
1. Insert the CD into your computer. 

2. Depending on your Windows configuration, the Cardbox setup program may 
start automatically.  Wait a moment or two to give it time to do this.  If it doesn’t 
start automatically, open the CDROM in Windows Explorer and double-click on 
SETUP.EXE (Windows Explorer may report this program name as simply 
SETUP). 

3. Follow the on-screen instructions. 

Installing from the Internet 
The same page that lets you download the Cardbox program files will also give you 
instructions for installing Cardbox after you’ve downloaded it. 

http://www.cardbox.com

If you already have 
Cardbox 2.0 (or earlier) 

installed on your 
computer, it will not be 

harmed by the  installation 
of Cardbox 3.0.
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Inserting licence details 
During the installation process, the setup program will show a Licence Management 
page that tells you what licence is installed in your copy of Cardbox. 

If you are installing the Client Edition, you’ll see that Setup already has a Client 
licence built in, and you won’t have to do anything more. 

If you are installing the Home or Professional Edition, you’ll have to enter its licence 
details into Setup at this stage.  If you got the software on CDROM, the details will 
be on a label stuck to the CD envelope or on a separate piece of paper.  If you got 
the software by download, you will have received the licence details by email. 

Always make sure that you keep a note of your licence details, because 
you will need them if you ever want to re-install Cardbox. 

To enter the licence, press the Add button in the Licence Management page, and 
then enter all the details exactly in the way you were given them. 

Multi-user licences 
A multi-user licence lets more than one person use it at the same time: for example, 
an 8-user licence allows Cardbox to be used by up to 8 simultaneous users.  The 
licence itself should only be installed once, not 8 times.  There are three ways of 
arranging this: 

Single Cardbox installation – Install Cardbox in a shared directory on your file 
server.  Whoever wants to use Cardbox can then navigate to CARDBOX3.EXE 
(using Windows Explorer) and double-click on it: Cardbox will start and it will set 
up appropriate shortcuts on the user’s computer to make it simple to start 
Cardbox in the future. 

Separate Cardbox installations – Sometimes it is corporate policy to install 
software separately on each PC.  Cardbox can be installed like this but the 
licence itself still needs to be installed centrally.  Decide on a shared directory 
that will hold the licence, and use the Licence Location button (in Setup’s 
licensing page) to point all the separate Cardbox installations to that directory. 

Licence server – If some of the intended users are located remotely and only have 
an Internet connection to your main system, you can install the multi-user licence 
on a Cardbox Server, and individual copies of Cardbox can then “borrow” 
licences as and when they are needed.  See the Cardbox Server documentation 
for more details. 

If some of your users need to be able to use Cardbox even when completely 
disconnected from your corporate network, then can’t use your multi-user licence: 
they need separate individual licences of their own. 
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Changing licence details 
Occasionally you may want to change the Cardbox licence that is stored on your 
computer.  This may happen because you decide to upgrade to a higher edition or 
because you want to install a time-limited evaluation licence on top of your existing 
Cardbox licence.  To manage your Cardbox licences: 

1. Open the Add/Remove Programs control in the Control Panel.  Depending on 
the version of Windows you are using, you open the control panel using Start > 
Settings > Control Panel or Start > Control Panel. 

2. In Windows XP, select “Cardbox 3.0” from the list and press the Change button; 
in other versions of Windows, double-click on “Cardbox 3.0” in the list and then 
press the button marked Manage Licences. 

3. To add a licence, press Add; to change or delete a licence, click on it and press 
Change or Delete. 

Removing Cardbox from your computer 
1. Open the Add/Remove Programs control in the Control Panel.  Depending on 

the version of Windows you are using, you open the control panel using Start > 
Settings > Control Panel or Start > Control Panel. 

2. In Windows XP, select “Cardbox 3.0” from the list and press the Remove button; 
in other versions of Windows, double-click on “Cardbox 3.0” in the list and then 
press the button marked Remove Cardbox. 

Removing Cardbox will never delete any of your database files.  If you want to 
delete them, you should locate them using Windows Explorer and delete them by 
hand. 

Moving Cardbox from one computer to another 
If you have upgraded to a new computer, Help Point 564 describes what files and 
settings to transfer from your old computer to your new one.   

If you’re selling or giving away the old computer, remember to remove Cardbox from 
it first, so that the new owner can’t use your copy of Cardbox. 
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Licensing and the Cardbox Server 
(If you’re not using the Cardbox Server to share databases, you don’t need to read 
this section). 

 

When you share databases between users on a network, you run the Cardbox 
Server.  The Cardbox Server is licensed according to the number of Client Edition 
and Home Edition users who are allowed to connect to it simultaneously.  There is 
no limit to the number of Professional Edition users who can connect to the Cardbox 
Server. 

You thus have two opposite choices.  You can get Professional Edition licences for 
everyone on your network, in which case you can get away with a “zero-user” 
licence for the Cardbox Server itself – or you can give each user the Client Edition of 
Cardbox (which is free) and buy a Cardbox Server licence that can handle your 
maximum expected number of simultaneous users. 

If some users are only intermittently connected to the network server (users of 
laptops, for example), then it all depends on whether they need to be able to update 
their databases even when they aren’t connected.  If they do, they’ll need to have 
the Professional Edition.  If they don’t need to be able to make changes while they’re 
not connected, they can stick to the free Client Edition and you can make sure that 
your Cardbox Server has enough capacity on its licence to be able to serve all the 
laptop users when they do connect to it. 

(You could use the Home Edition to provide local editing capabilities for a laptop 
user, but it’s not necessarily the best solution because you’ll still have to allow for a 
spare licence on the Cardbox Server when that user chooses to connect to it). 

As you can imagine, these simple rules can give rise to a large number of different 
combinations.  If you’re planning a network, have a look at the advice on the 
Cardbox web site, or talk to us or to one of our distributors. 
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Using Cardbox at work and at home 
“I have a computer at work and one at home.  When I take some work home, I want 
to be able to use Cardbox there.  Your licence says Cardbox can only be installed 
on one computer.  But I’m the only person who uses Cardbox, so I don’t see why I 
should get two licences.” 

We agree.  If this is really the situation, we don’t demand that you buy two copies of 
Cardbox because it wouldn’t be reasonable.  The key question is this: when you’re 
using one computer, could someone else be using Cardbox on the other one? 

Can a colleague use your Cardbox at work while you’re using Cardbox at 
home? 
Can your family use your Cardbox at home while you’re using Cardbox at 
work? 

If the answer is “Yes” or “Perhaps”, then we’re talking about two separate Cardbox 
installations and you need to buy two separate copies of Cardbox, one for each 
place. 

If the answer is “No, Cardbox will only ever be used in one place at a time”, then 
we’re effectively talking about a single Cardbox installation that follows you around, 
and the fact that the software is physically stored on two different computers is just a 
convenience to save you repeatedly installing and uninstalling the program.  In this 
case, we’re happy for you to install Cardbox on both computers. 

Dialling in to the office 
Suppose you have a computer at work (not connected to a network) and a computer 
at home, and you’ve got the Professional Edition of Cardbox installed on both, 
obeying the licence restrictions we’ve just described.  You’re one of those people 
who dial in to your work computer when you’re at home.  How do you use Cardbox? 

Home computer as a “dumb terminal” 

Remote access software, such as PCAnywhere, Citrix Metaframe, or Windows 
Terminal Services, lets you turn your home computer into a keyboard-and-screen for 
your office computer: everything you type on your keyboard gets typed into the office 
computer’s keyboard and everything the office computer displays on its screen gets 
displayed on your screen. 

• This is extremely simple to set up.  
• You are using Cardbox on your office computer, so everything is familiar. 

It can be irritating over long periods.  Unless you have a very fast link to the office, 
the screen will behave sluggishly and there can be a noticeable time lag between 
doing something (especially with the mouse) and seeing the result.  

There are many remote 
access software 

packages on the market, 
and we don’t make 

recommendations: it is up 
to you to choose what is 

most suitable for your 
needs.

The concession described 
here applies only to a 

single-user licence, not to 
multi-user licences. For 

advice on how to combine 
home use with the use of 
Cardbox on a network at 
work, see the web site at 

www.cardbox.com. 
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Office computer as a network disk 

Some networking/WAN software gives you an option to view your entire office 
computer as if it were just an extra hard disk drive on your home computer (to save 
explanations, let’s call it drive O:). 

• This is simple to set up. 
• When you want to open a database on your office computer, use File > Open » 

My Computer to open the database file in drive O:. 
• The screen response will be very fast because Cardbox is running on your home 

computer. 
• Searches may be slow because all the disk access has to take place over a 

telephone line to the office. 
• You can’t share databases opened in this way: as long as you have the 

database open, no-one else can open it. 

A Cardbox server on your office computer 

This is a little harder to set up and costs a little more, but it gives by far the best 
performance.  You don’t need remote-access software at all. 

Buy the Cardbox Server and set it up on your office computer.  You don’t need to 
buy any user licences for the Server because your own copy of Cardbox already has 
a licence (remember that we’ve assumed that you already have the Professional 
Edition of Cardbox). 

• When you want to open a database on your office computer, open Cardbox and 
use File > Open » Server to connect to the Cardbox Server in your office and 
open the database there. 

• The screen response will be very fast. 
• Searches will be fast because the Cardbox Server is running on your office 

computer, directly connected to the hard disk where the database is. 

Security 

If you use the Cardbox Server, all your communications are encrypted using 
SSL.  Even if someone intercepted your Internet connection, they would not be able 
to see what you were doing with Cardbox and they would not be able to intercept 
critical information such as passwords. 

If you use one of the other approaches, you are dependent on whatever encryption 
your remote access software might be providing.  This may be secure or it may not 
be secure: you’ll have to talk to the supplier. 
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Distributing Cardbox databases 

Distribution on CDROM 
As long ago as 1987 people were distributing information in the form of Cardbox 
databases, along with a special “read-only” or “electronic publishing” version of 
Cardbox for recipients who didn’t already have the program.  We particularly 
remember Professor Christopher Spry’s “Eosinophils: A Comprehensive Review and 
Guide to the Scientific and Medical Literature”, published by the Oxford University 
Press in 1988, which allowed its purchasers to obtain an annotated bibliography of 
the literature on 3½” floppy disks: it needed nine disks.  Nowadays CDROMs make 
this kind of thing a much less heroic undertaking. 

We allow you to include the Client Edition of Cardbox free of charge on your 
CDROM for anyone who does not already have it.  Various terms and conditions 
apply, principally to protect our copyrights and ensure that you give people the right 
program files.  If you need advice on this, please contact us. 

Distribution over the Internet 
The alternative to physical distribution is to make your data available on a Cardbox 
Server connected to the Internet.  This can be one of your own, or it can be a server 
run by someone whose business it is to host other people’s databases.  In this case, 
people who want to search your databases can download the Client Edition free of 
charge from our Web site. 

If you’re interested in doing this, use Cardbox to look at database.cardbox.net and 
see the databases that are hosted there (the command is File > Open » Server).  
You can also look on the Cardbox web site for more information. 

Distribution via the Web 
You can design formats that let Cardbox output your data as web pages in HTML: a 
page can contain a single record or a whole selection of records.  Using macros, you 
can automate the process of creating these pages so that you can maintain your 
data in Cardbox and make them available to the outside world as a standard Web 
site. 

If you want your site to have a search form that responds to live queries, a number 
of vendors offer “middleware” programs that run on your web server and provide an 
interface between Web browsers and the Cardbox Server.  Our Web site will have 
the latest details. 

See Help Point 519.

http://www.cardbox.com



 

 

Part Two 
Concepts 

The basic concepts of Cardbox. 
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The concepts of Cardbox 
In terms of usability and ease of explanation, the best product we’ve ever seen is the 
screwdriver.  When you use a screwdriver you don’t need an instruction manual.  
You know you can use it to open tins of paint, stir the paint, and also drive in screws 
or take them out again; you also know that you are unlikely to be able to bang in 
nails with it.  You know all this without thinking, because you have an instinctive 
feeling for the way the physical world works and what a slender piece of metal is 
capable of. 

The aim of the Concepts section is to give you the same sort of instinctive feeling 
about what Cardbox can do.  Once you’ve read it, you should have understand what 
Cardbox is and you should know, without thinking, what kind of things it can do and 
what kind of things it can’t.  After that, you’ve done the hardest work and everything 
else is (in a sense) just filling in the details. 
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Databases and records 
A Cardbox database is a collection of records.  It is up to you to decide what those 
records represent.  They can be physical objects, or documents, or people, or 
messages, events or financial transactions.  They can even be chapters in a book 
you’re writing.  If you can make a list of something, you can make database records 
out of it. 

The current selection 
Whenever you are using Cardbox you are always looking at a selection of records, 
and you can always browse through that selection using the record scrollbar or the 
keyboard, one step at a time or in great jumps. 

When you first open a database, Cardbox doesn’t know what you want to see so it 
shows you every record (as a list if the records are small, or one record at a time if 
the records are big).  Whenever you make a search, Cardbox finds the records that 
match your search and makes them into the new “current selection”.  Again you can 
browse through it to see if you’re on the right track, perhaps as a preliminary to 
making an extra search to refine the selection further. 

Most actions – printing, batch editing, data export – work on the current selection, 
but selections are more than a shorthand for “the records that Cardbox has found for 
you”, they are entities in their own right.  When you’ve made a selection you can 
give it a name and store it for later use: you can cancel the search and do another 
one, and come back to your stored selection later on – or you can even combine 
selections together. 

Levels of selection 
Every time you perform a search command, it acts on whatever is in your current 
selection.  This means that if you enter two searches in a row then you’ll only find 
the records that fit them both.  Combining searches in this way is a good way of 
building up complex Boolean searches.  The status bar has a Level indicator that 
shows how many combined searches you’ve made: level 3 means that you’ve 
combined 3 searches, and level 0 means that you haven’t done any searches at all 
and you’re looking at the whole database. 
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Fields 
Fields are subdivisions of records.  You design how records are divided into fields 
when you design your database, and you can add or remove fields later on if the 
design evolves or you change your mind about it: this is very easy and it won’t cause 
any upheaval to the records that you’ve already got in your database. 

In a database of people you might have fields for name, address, telephone number, 
date of last or next contact.  In a database of books you might have fields for author, 
title, publisher, subject, keywords, shelfmark, and so on. 

The thing about fields is that they add meaning to what you put in them.  Think of a 
book: “London” could be the name of the author, or part of the title, or the place of 
publication, or the subject.  By putting “London” into one field rather than another, 
you define what it actually means. 

You could have a database with just one field but it would be pretty specialised.  
We’ll cover database design later on, but basically you use fields to distinguish 
things that 

• have different meanings. 

• need to be searched separately. 

• need to be positioned differently. 

• don’t always need to be visible at the same time. 

Cardbox lets you have up to 4,000 fields, so you really aren’t going to run out of 
them.  Fields can be as short as one character or big enough to hold several pages 
of text. 

The one-field database 
To make a database with one field, just draw a huge field on the screen and then 
type text into each record.  It could be a diary, or a notebook rather like the Memo 
Pad application in your palmtop.  You can search for records, view them, print them 
out: it works.  But pretty soon you’ll want to search on the date the note was made 
on, and that has to be a separate field to distinguish this date from other dates that 
happen to be mentioned in the text.  And perhaps you’ll need a category name as 
well, just like Memo Pad… so that’s three fields in total.  So the one-field database 
was OK to start with, but having two more fields made all the difference. 
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The Extra Text field 
If you think of a Cardbox record as an index card, you can think of Extra Text as a 
sheet of paper stapled to the back of the card.  Extra Text is what it says it is: a lot of 
text (there’s no limit) attached to a Cardbox record.  Some other databases have a 
similar concept, which they call Memo fields. 

Not everyone finds Extra Text useful or even interesting, so if you can’t think of a 
use for Extra Text, don’t bother with it.  But when you do need it, it can be 
invaluable.  It’s flexible and of unlimited length, whereas Cardbox records usually 
have a fixed layout and a fixed height for each field.  Because it’s attached to a 
record you can (at a press of the F6 key) view the Extra Text on its own, or the 
record on its own, or (with Shift + F6) both together; and you can print it separately 
as well, if you want.  The only thing you can’t do with Extra Text is index it, although 
you can still do unindexed searches on it. 

Here’s an example of a database used as a text repository.  Extra Text contains the 
text, and the main record is just a way of finding that content or sorting it into a 
desired order. 

  

One Cardbox user wrote an 
entire reference book in this 
way.  The Extra Text was what 
he was actually writing, while 
the record’s main fields gave 
headings and a sequence 
number: when he wanted to 
move sections around, he just 
changed its number.  At the 
end of the process he sorted 
the database into numerical 
order, printed it out and sent 
the result to the publisher. 
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Formats 
A format is what gives shape to your data.  It is everything you see on the screen 
when you look at a record, except for the actual data.  It covers the way your fields 
are laid out (and which ones appear at all), plus any captions, lines, boxes, and so 
on.  A Cardbox database can have as many formats as you like. 

Put like that, it’s pretty abstract, but the format mechanism is more powerful than it 
sounds and it’s worth getting to know it early in your acquaintance with Cardbox. 

 
Here’s a format that looks like a form to be filled in.  Most databases have a format 
like this to make data entry easier.  The format has plenty of captions and boxes to 
guide you when entering data.    You can have more than one format of this kind if 
circumstances justify it: perhaps a terse format for experts and a long-winded one for 
novices, or specialised ones for different stages in the use of a record.  On the next 
page you can see what this format looks like when you put some data into it. 

 

 
Here’s a format that works as a summary.  This sort of format is useful for printed 
summaries but it’s also very good when searching, because if the records are just 
one line high then you can see a lot of them on the screen at once and get a good 
idea of whether your search is finding the right sort of things. 

Many database programs 
call this sort of format  

a “list view”.
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There’s nothing to stop you using a summary format for data entry as well: this is 
what we do ourselves with our accounting databases, where we have an elaborate 
form that explains everything in detail but we use the one-line version a lot because 
we know what we’re doing and we don’t need all the captions and explanations. 

 
This is what the big format on the previous page looks like when it has some data in 
it.  The multicoloured appearance is because we’ve chosen to use bold red text to 
indicate the words that have been marked for indexing: this is useful when you’re 
entering data, so that you know what’s indexed and what isn’t (note that only the 
surnames of the contact and the sales representative are indexed), but it’s not 
compulsory and you normally wouldn’t use it when designing a format that’s going to 
be printed out. 
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On the right you can see a sheet of address 
labels for a mailing.  The format design is very 
simple, because it only has to tell Cardbox what 
a single label should look like.  When you are 
setting up the printing, you can tell Cardbox what 
size the labels are and how they are laid out on 
the page.  Cardbox has knowledge of many of 
the commonest mailing label layouts, but you 
can easily add new ones if you want.  

On the left is a contact list suitable for inserting 
into a personal organiser.   You can buy special 
paper for this – it has two perforated organiser 
“pages” within each large laser-printable sheet. 

Below, you can see a mail-merged letter that 
pulls in fields from a record.  You can use this 
kind of format for personalised letters, 
individually or in bulk; for filling in the blanks in 
standard forms or contracts; or for emails or 
faxes.  You can have as many different letter 
formats as you like. 

We have made the fields 
blue so you can see 

where the data come 
from. A real letter would 

all be in one colour.
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On the left is an example of a barcoded label produced by a Cardbox format.  A field 
in the record contains the number, and Cardbox draws the barcode automatically.  
You could use this in a library, with each label identifying one book.  The record for 
the book would contain all its bibliographical details, plus its location and loan status.  
Given a suitable barcode reader and a bit of programming, you’d have the core of a 
library automation system. 

 

 
Finally, here is an epic format.  This is the nerve centre of a recruitment agency that 
deals with over 25,000 candidates.  Each record contains a candidate’s details, CV, 
qualifications, references, and a complete history of every conversation, interview, 
and job offer.  The designer has filled the format with pushbuttons for every 
conceivable purpose: making a note of a conversation, planning the date of the next 
contact, dialling a telephone number, offering a job.  This format scrolls through 
many screens, and half a dozen different formats (also activated by pushbuttons) 
zoom in on different stages of the recruitment process.  A vast array of standard 
letters covers CV updating, job offers, and interview results. 

Setting up pushbuttons 
and macros is a feature of 

the Professional Edition.
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Native and alternative formats 
The very first format you create for a Cardbox database is called the native format, 
and it’s special. 

Most formats tell Cardbox where to draw your fields, but before it can even do this, 
Cardbox needs to know something more fundamental – what fields exist? 

The native format answers this question: if a field is in the native format, it exists in 
the database.  If it isn’t, it doesn’t.  Drawing a field in the native format causes it to 
exist in the database.  Deleting a field from the native format destroys the field itself 
and all its data. 

The native format also tells Cardbox more about each field: 

• What it contains (text, images, or objects). 
• How it is to be indexed (every word, nothing at all, or under user control). 
• Its name. 
• A short description. 

Apart from this special role, the native format is a format like any other.  In really 
simple databases the native format may be the only format you need. 

Alternative formats 

Any format other than the native format is called an alternative format.  It can use 
any field that exists in the native format but it doesn’t have to use them all and the 
fields don’t have to be the same size or laid out in the same way.  You can have as 
many alternative formats as you like. 
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Alternate field views 
The normal way of viewing a field is as text.  You type it in, and later on you look at it 
or print it out.  But for fields that represent a restricted set of options, there are more 
graphical approaches that may be easier to use. 

An alternate field view is like a filter that 
inserts itself between the text and what you 
actually see.  Underneath it all, the field still 
contains ordinary text; but on the surface, 
what you see is a set of radio buttons or check boxes, or a drop-down list.   

For data entry this is good because you don’t have to type, you can just click.  
Because the field view does the typing for you, you can be sure that it doesn’t make 
any spelling mistakes. 

Not every format has to have the same view of the field.  It’s often a good idea to 
use an alternate view to make things easier for data entry but switch to ordinary text 
when it comes to summaries or printed reports. 

The labels shown in the alternate views don’t have to be identical to the real text of 
the underlying field.  You can use long explanatory labels (“Business Insurance”, 
“Company Accounts”) in the view but short codes (such as INS and ACC) in the field 
text.  When you display your data in summary form, the short codes will save space. 

• Having labels different from the field text can also be good in a multinational 
context, because you can design formats in English, French, Spanish and so on, 
while still maintaining one consistent set of codes within the actual database. 

 

 

For detailed information 
on how to set up alternate 
field views, see page 192.
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Appearance 
“Appearance” is shorthand for “font and colour and size and boldness and italics and 
underlining and line thickness and background” – in other words, everything that 
makes your text look the way it does. 

Word processors give you infinite control over appearance and they will let you 
make every letter of every word a different colour if you really insist.  Cardbox is less 
generous: appearance is assigned to fields, not to individual characters.  The only 
variation within a field is that you can make indexed words look different from 
unindexed ones, and captions can look different again. 

Appearances are assigned when you design your format.  You can have one 
appearance for the format as a whole, and then, if you want, you can make 
exceptions for particular fields and other format items.  Don’t go overboard on this: a 
screen with every field in a different font will look a terrible mess. 

Whatever the appearance that is stored in the format, you can override it when you 
are viewing it on the screen.  You won’t usually need to do this, but it’s good for 
experimentation and, as one of our programmers discovered, it is useful if you’re 
colour-blind and need to use a colour scheme that everyone else hates. 

For details of how to 
control appearance,  

see page 107.
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Indexing 
To make searching faster, Cardbox creates an index of your database.  That way, 
instead of having to look through every single record to find the ones you’re looking 
for, Cardbox can look at the index and find what you want in a fraction of the time.  
The bigger the database, the bigger the benefit. 

Indexing is something that all databases do to some extent, but here’s how Cardbox 
is different: 

• It can index every word, number, or date in a field. 
• Within a single field, it can let you choose which words (or numbers, or dates) to 

index. 

These are such obvious things to do that we don’t understand why other databases 
don’t do them.  The benefits are clear: you don’t have to twist names round to fit the 
way the computer wants them – “Public, John Q.” – or even “John | Q | Public” in 
three separate fields.  You don’t have to have artificial fields (KEYWORD 1, 
KEYWORD 2, KEYWORD 3) or use sophisticated programming.  You just mark the 
words you want to be indexed, and Cardbox indexes them. 

For each field, you decide the indexing strategy when you design the field; although 
like everything else in Cardbox, you can go back and change your mind afterwards.  
The simplest indexing modes are All, which indexes everything in a field, and None, 
which indexes nothing.  More interesting is Manual, which lets you mark individual 
words for indexing as you type them in (or you can go back and mark or unmark 
them later).  There is also Auto, which is rather like Manual backwards: everything’s 
indexed unless you tell Cardbox not to index it.  

Marking indexed words 
If you tell Cardbox to index everything in a field, or to index nothing, there’s no real 
need for words to look different when they’re marked for indexing.  But if you do 
want to control indexing manually, then it helps if indexed words look different from 
indexed ones.  By default, Cardbox shows you indexed words in red and unindexed 
words in black, but if you don’t like the piebald appearance this gives, you can 
change it.  In printouts in particular, a consistent single colour makes more sense. 

You can turn indexing on and off for a word by tapping the Ctrl key, or by right-
clicking and using the pop-up menu.  You can also use validators to control 
indexing.  Validators look at what you have entered into a field, and make changes 
(such as indexing) based on what they see.  Validators can implement stoplists (lists 
of common words not to be indexed) or they can do the exact opposite, indexing 
certain key words whenever they see them.  They are especially useful if many 
different people are going to be entering records and they have different ideas about 

See page 206.  Setting up 
validators is a feature of 
the Professional Edition.
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what ought to be indexed.  A validator can automate the process of deciding what to 
index and keep the policy consistent. 

Cardbox has two indexes 
There are a couple of problems when it comes to indexing numbers, because 
numbers behave differently from words.  This difference is especially significant 
when you are trying to search on ranges of values (“give me numbers between 30 
and 40”) or when you sort records into alphabetical or numerical order.  It’s easy to 
see the problem with a couple of simple examples.  If you are looking for words 
between ANT and DOG in the alphabet, it’s obvious that BABY fits within the range.  
On the other hand, if you are looking for numbers between 100 and 400, it’s equally 
obvious that 3105 is far outside that range.  In other words: when you compare 
words, you compare one letter at a time, but with numbers, the longer number is 
always bigger than the shorter one. 

Cardbox handles this by having two separate indexes for every field.  The word 
index handles words and is in alphabetical order, and the numeric index handles 
numbers (and dates) and is in numerical order. 
ALBANIA 
ARGENTINA 
ARUBA 
AUSTRALIA 
AUSTRIA 
BARBADOS 
BELARUS 
BELGIUM 
BENIN 
BOTSWANA 
BULGARIA 
CAMEROON 
CANADA 
CAPE VERDE 
CHILE 
CHINA 

1 
2 
3 
8 
2003.0128 
2003.0204 
2003.0207 
2003.0213 
1370434 
1370713 
1370996 
1371370 
1371486 
1372590 
1373771 
1373935 

Cardbox chooses the index automatically when it looks at the term (word, number or 
date) to be indexed.  When you are doing a search, Cardbox looks at the search 
term you’ve entered and deduces which index you want to search. 
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How Cardbox indexes 
When Cardbox starts indexing text, it splits it into terms (words, numbers or dates).  
Terms are separated by spaces, so if you inadvertently type “SMITH,JONES” 
instead of “SMITH, JONES”, it will end up being treated as a single term. 

To decide whether a term is a word or a number, Cardbox looks through it.  If it sees 
any alphabetic characters then it treats the term as a word: this means that 3M and 
3RD both count as words. 

Indexing words 
If the word is a very long one (more than 64 characters long) Cardbox truncates it.  It 
then goes through the word removing all non-alphabetic characters.  It removes any 
accents from the letters and converts them to upper case: it also does useful things 
such as converting the German double-S ‘ß’ to ‘SS’.  This converted upper-case 
word is what actually goes into the index. 

There are a couple of exceptions to the “remove non-alphabetic characters” rule.  
Underlines are treated as if they were a letter of the alphabet, and hyphens are 
treated specially.  Hyphens divide a word, so that every piece of a hyphenated word 
is indexed as if it were a separate word – so ‘fer-de-lance’ is indexed as FER, DE, 
and LANCE – and then the whole word, without hyphens, is indexed again – 
FERDELANCE.  This sounds a little eccentric but it is the best way of ensuring that 
the word can be found and that records containing it can also be sorted into the right 
order. 

For specialised applications, you can change all these indexing rules by setting a 
specific collating sequence for the database.  Collating sequences are an advanced 
feature and are part of the Professional Edition only, although all editions of Cardbox 
will understand and obey a database’s collating sequence if one has been set. 

Indexing numbers 
When Cardbox indexes a number, it ignores non-numeric characters other than 
decimal points, slashes, and hyphens.  Cardbox indexes numbers according to their 
value, which means that 3, 3.0 and 3.00 (etc) are all indexed identically.  When you 
view the database index (for example, when previewing the results of a search you 
plan to make) Cardbox will show you the simplest possible form of the number, 
omitting any trailing zeroes. 

Older versions of Cardbox 
did this differently: see 

Help Point 552.

For more about  
collating sequences,  
see Help Point 533.
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Date formats and Cardbox 
There are many different ways of writing dates.  Even the sequence of the 
components varies: ‘day, month, year’, ‘month, day, year’ and ‘year, month, day’ are 
all used in different parts of the world.  Because Cardbox databases can be 
international, Cardbox cannot deduce the date sequence from the location where 
you’re using it.  Instead, it looks at the way you typed the date: specifically, at the 
character that you used to separate the different parts of the date.  Here is the 19th 
of April 1962: 

Separator Format Example 

/ (slash) day/month/year 19/4/1962 

- (hyphen) month-day-year 4-19-1962 

. (decimal point) year.month.day 1962.4.19 

• The day and the month can be one or two digits long: 04 is the same as 4.  

• Cardbox identifies the date format by looking at the separator, so you cannot 
enter something like 4/19/1962 and expect Cardbox to handle it properly.  

When Cardbox indexes a date, it reshuffles it into a number, in a standard format.  
All the date formats shown in the example above will be indexed as the same 
number, 1962.0419.  This has the advantage that when records are sorted into 
numerical order, this will yield exactly the right date sequence as well.  

As a result of the way that Cardbox indexes dates, when you are previewing an 
indexed search, the preview listing will show all your dates as numbers.  

Years and centuries 
You will have to decide on your own convention for the year.  Either use 2-digit 
years throughout (62) or 4-digit years (1962).  Now that the 20th century is over, you 
may choose to use 2-digit years to save typing (though not for dates of birth, 
obviously!).  But you must be consistent, because Cardbox sees no resemblance at 
all between 04 and 2004 or between 68 (death of the emperor Nero) and 1968 
(death of Martin Luther King). 

Specialised date formats 
If days aren’t interesting to you, you can use dates in ‘month/year’ or ‘month-year’ 
format: Cardbox will assume the day to be zero. 

As well as dates, you can index times, either on their own (‘hour.minute.second’) or 
together with a date.  

If you have the 
Professional Edition, you 

can set up a validator that 
automatically reformats 

the dates you type in.  
See page 206.  

See Help Point 522 for 
details of how these date 

and time formats work.  
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Validators 
Cardbox’s great strength is that you don’t need to declare your text fields as being of 
any particular type.  Once you’ve drawn the field in your format, it will accept 
anything: numbers, dates, codes, long text, single letters.  A field is a field is a field. 

There are times, however, when you do want to restrict what is allowed to be put 
into a field.  This is especially the case when more than one person is responsible 
for editing records, since the more people are involved, the harder it is to trust all of 
them to keep to the same conventions. 

Validators can only be set up by the Professional Edition (its Advanced Features 
manual gives full details of the available validators and how to set them up), but 
once they have been set up, a database with validators can be used by anyone, so 
it’s important for you to know what to expect. 

There are several different kinds of validators but they all behave in a similar way: 
they watch as you are editing a record, and as you move off each field, they check 
that field or make changes to it. 

Validators that check things 
Validators can check that an entry has been made in a particular field; they can 
check the types of terms that have been entered (word, number, date); they can 
control how many of them there are and how long each of them should be; they can 
even restrict entries to certain specific values. 

If there is something wrong with a field, a warning button flashes in the toolbar, and 
if you try to save the record, a warning message pops up and asks you to correct the 
problem. 

Validators that change things 
Validators can automatically index or unindex words for you (thus enforcing stoplists 
or keyword lists) and they can also reformat dates so that the date format is 
consistent throughout the database. 

Validators that type things 
Validators can automatically type text into a field for you.  You can use this to put 
codes in automatically (for example, the user’s initials) or to create datestamps to 
say when a record has been created or edited. 

Only the Professional 
Edition of Cardbox is able 

to set up validators.
Once they’ve been set up, 
any edition can use them.

See “Using Validators”, 
page 152.
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Images 
Not everything you want to store in a database is necessarily text.  There are also 
photographs, drawings, and scanned documents.  Because they have so much in 
common we lump them together in Cardbox as one thing: “images”. 

An image is anything that can be displayed on the screen or printed on a printer.  It 
comes into Cardbox from a camera or a scanner or simply by being imported from 
an image file in any of the standard formats (BMP, JPEG, GIF, TIFF).  Cardbox 
stores images in an image field: you can only have one image field in a format but 
that field can hold as many images as you like, so if you want to scan an 80-page 
document into Cardbox then that’s not a problem. 

The one thing Cardbox can’t do with images is search inside them.  If you want to 
find a picture of a clown with green hair, you can’t expect Cardbox to look inside 
each image to find a likely-looking patch of green.  On the other hand, there’s 
nothing to stop you having a text field that describes in words what the image 
contains and then indexing it.  In that case searching for CLOWN GREEN HAIR will 
probably find what you’re looking for. 

Images can be pretty large lumps of data – a picture takes as much space as ten 
thousand words – so Cardbox compresses them to save disk space.  There are two 
levels of compression, a light one which preserves image quality and a heavier one 
which makes the image look less good but saves a lot of space.  You can choose 
which level to use each time you import an image into Cardbox. 
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Objects 
Not everything you want to store in a database is necessarily text.  We’ve covered 
images already.  Images are just a set of passive pixels, but objects are altogether 
more dynamic.  Here are some examples of objects: 

• Microsoft Word documents. 
• Microsoft Excel spreadsheets. 
• MP3 sound recordings. 
• Video clips. 
• Adobe Photoshop images. 

These things all have one thing in common: they belong to other programs.  
Cardbox doesn’t know what to do with Word documents, Excel spreadsheets, or 
Photoshop images: Word, Excel, and Photoshop do.  The core of OLE is that these 
objects can live inside Cardbox but work where they are understood.  An embedded 
object doesn’t need to exist in an ordinary file, it lives entirely inside the Cardbox 
database. 

Here are a couple of examples: 

• A firm of investment analysts indexes company accounting information.  
Cardbox gives the main information about the company, but the accounts 
themselves are stored in Excel spreadsheets that are embedded in each 
company’s Cardbox record. 

• We maintain a daybook database that contains all our incoming and outgoing 
correspondence.  Incoming letters are scanned into an image field, but we can 
store outgoing letters, as Word documents, in an object field: this means we can 
not only read the letters we write but reuse them in other circumstances.  We 
could even put the daybook on our Internet server and access it from anywhere 
in the world. 

Some warnings 
OLE is a way of linking programs with other programs.  We didn’t write those other 
programs and we can’t guarantee how well they will work with embedded objects.  If 
they don’t work well, it’s not our fault.  Try out the actual software before you embark 
on any big projects. 

An OLE object is useless without a program that understands how to make it work.  
This is an important thing to remember on a network.  You may store an Excel 
spreadsheet inside your Cardbox record, but it if you view it from a computer that 
doesn’t have Excel, you will be able to see the record but you won’t be able to open 
the spreadsheet.  Make sure that everyone who should be able to open your objects 
has software that will let them do so. 

Only the Professional 
Edition of Cardbox is able 

to set up object fields.

OLE is a Microsoft term.  
It stands for “Object Linking 

and Embedding”
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User profiles 
Your copy of Cardbox lets you do anything you like to the databases you create.  
This is only fair, since it’s your copy of Cardbox and your data. 

But as soon as someone else is involved – if you’re using their data or they’re using 
yours – it is better to be a little less trusting.  You may be able to redesign your 
formats, edit records, delete records, and so on, but it doesn’t follow that everyone 
else should be able to do the same.  Moreover, you may have confidential 
information that you only want some people to be able to see, while less privileged 
users only see selected portions of your data. 

The setting up of profiles is an advanced feature of the Professional Edition, but you 
may very well find yourself on the receiving end of a user profile system when you 
open a database that someone else has created, on a network or on the Internet, so 
here is what to expect. 

• A user profile has a name and, optionally, a password. 
• For each field, the profile defines whether you are allowed to edit its contents or 

indeed whether you’re allowed to see it at all. 
• The profile does the same thing for formats, so you may only be allowed to see 

and use a small number of formats.  Even the native format may be invisible to 
you. 

• The profile can control the commands you are allowed to use.  In a public 
database it’ll probably stop you from making any changes at all, and it may even 
stop you from printing anything out.  In a corporate database it may let you add 
records but not edit or delete them, or add and edit records but not edit formats.  
There are a wide range of possibilities, but it is always easy to tell what is 
happening because any commands that you are not allowed to use will be 
disabled in your menus and on your toolbar. 

How all this affects you depends very much on how the database owner has set 
things up.  It is possible to create profiles that don’t need a password, so you may 
not notice anything at all (except that some commands aren’t available) or you may 
find that you’re asked for a password even before you can get into the database. 

If you are more privileged than ordinary users of the database, the database owner 
may give you the name and password of a different user profile: in that case you can 
use the command File > User Profile to switch to the chosen profile.  You’ll normally 
have to enter the password every time you open Cardbox and it tries to reopen the 
database for you, but you can make your workspace remember your passwords for 
you: for how to do this, and the security implications, see page 63. 

Only the Professional 
Edition is able to set up 

user profiles, but any 
edition of Cardbox can 

use them once they have 
been set up.

See “Passwords and User 
Profiles”, p.253.
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Networking 
You can happily spend all your time creating and using your own databases on your 
own computer and not bothering about anyone else.  If that’s the case then you can 
skip the rest of this section; but if you use shared databases on a corporate network 
or public databases on the Internet, read on. 

When someone wants a Cardbox database to be accessible to several people, he 
sets up a copy of the Cardbox Server and tell it what databases to share.  The 
Cardbox Server is a separate product with a separate manual, so we won’t cover it 
further in this book. 

If you look closely at the Open File box, you’ll see that it has two tabs.  The My 
Computer tab lets you open databases on your own computer, and the Server tab 
lets you open databases on other computers: to open a database, you need to know 
the name of the server and the name of the database.  In a corporate network, your 
system administrator will tell you the name of your server (indeed, it may be in your 
list already) and if you’re opening an Internet database, the owner’s web site will tell 
you the server name.  For some more information, see “Opening Databases”, p.57. 

And that’s really all you need to know.  Everything else behaves just as it does when 
you’re using your own databases.  Cardbox coordinates everything.  If someone 
else changes a record and saves it while you’re looking at it, it’ll change on your 
screen as well.  If two people try to edit a record at the same time, Cardbox lets one 
of them do it and tells the other to try again later. 

The Cardbox web site tells you more about the Cardbox Server and how to get hold 
of it.  The Cardbox Server comes with a separate manual that gives you detailed 
information about setting up the server and sharing databases. 
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Unicode 
Here are all the characters that you can type into your computer using the standard 
Windows character set: 

! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = 
> ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 
[ \ ] ^ _ ` a b c d e f g h i j k l m n o p q r s t u v w 
x y z { | } ~ € ‚ ƒ „ … † ‡ ˆ ‰ Š ‹ Œ Ž ‘ ’ “ ” • – — ˜ ™ 
š › œ ž Ÿ   ¡ ¢ £ ¤ ¥ ¦ § ¨ © ª « ¬ - ® ¯ ° ± ² ³ ´ µ ¶ · 
¸ ¹ º » ¼ ½ ¾ ¿ À Á Â Ã Ä Å Æ Ç È É Ê Ë Ì Í Î Ï Ð Ñ Ò Ó Ô 
Õ Ö × Ø Ù Ú Û Ü Ý Þ ß à á â ã ä å æ ç è é ê ë ì í î ï ð ñ 
ò ó ô õ ö ÷ ø ù ú û ü ý þ ÿ  

This is adequate for most Western European languages but not for the rest of the 
world.  The computer industry has designed a new standard, Unicode, to allow you 
to type any character from any language in the world.  Cardbox supports version 3.2 
of Unicode. 

The characters that Cardbox supports 
At present, Cardbox can display characters from any script that is written from left to 
right and is not a “complex” script (complex scripts are ones where the letters 
change shape depending on the adjacent letters in the word, as in the Devanagari 
scripts of India).  Cardbox may have got better at displaying other scripts by the time 
you read this: check Help Point 553 or our web site for details.  Some samples of 
scripts that Cardbox can handle are shown in the margins of this page. 

Displaying and printing Unicode 
Not all fonts contain all characters, and this can be a problem if you use Unicode.  It 
is one thing to be able to type classical Greek and quite another to find a font to see 
it in.  Windows XP contains technology that should help with this – it claims to be 
able to “borrow” missing characters from similar-looking fonts – but you should 
check on the availability of the fonts you need before embarking on a big project.  As 
a simple test, try typing the characters you want into Wordpad: if they come out 
right, then Cardbox will be able to display them too. 

The Arial Unicode MS font, supplied with many Microsoft Office products, includes 
practically all Unicode characters, so if you have font problems it may be worth 
installing it on your system. 

See Help Point 544 for 
how to set up a Cardbox 

database in Unicode.

If you really need Cardbox 
to support a right-to-left or 
complex script, please let 

us know.

For more about fonts, see 
Help Point 545.
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Typing Unicode 
Windows supports many keyboard layouts and allows you to switch dynamically 
between them.  One solution if you have a lot of text to type is to install several 
different layouts and switch from one to the other as necessary.  Obviously the 
labels on your physical keys won’t change, but  your fingers will soon learn the feel  
of (say) a Polish keyboard even when the key labels don’t correspond. 

We have also tried out an add-on product called Tavultesoft Keyman which allows 
you to type in languages that Windows doesn’t support and even to design your own 
keyboard layouts.  This is especially relevant for scholars working with ancient 
languages: you will probably find that someone has already designed a Keyman 
layout for the language you’re interested in. 

You may know that you can access the more exotic Windows characters by typing 
numeric codes: for instance, Alt + 0 2 4 1 for “ñ”.  This isn’t something you’d want to 
spend a long time doing, but it works well for occasional use.  Cardbox lets you do 
the same for Unicode: for instance, Alt + 0 9 6 9 for a lower-case Greek omega.   

The Unicode Standard lists codes for all defined Unicode characters.  Most Unicode 
character tables use hexadecimal notation for the code values.  To save you having 
to do arithmetic, Cardbox lets you use these numbers directly.  If you see a 
character referred to as U+03C9, you can type it into Cardbox by holding down the 
Alt key, typing the decimal point on the numeric keypad, and then typing 3 C 9 
before releasing the Alt key.  After the decimal point and before releasing Alt, you 
can type all the hexadecimal digits without moving your hand from the numeric 
keypad, using the special layout shown on the left. 

Windows 95, 98, and Me 
These versions of Windows have limited Unicode support, and this affects what 
Cardbox can do.  You can use Unicode databases, but Windows can’t display or 
input Unicode in menus and dialog boxes: so, for instance, you can’t enter Unicode 
characters into a search command or have them in validators.  You can, however, 
have Unicode in your database records, and if someone else has designed a format 
that includes Unicode in its text and captions, you’ll be able to use that too. 

The Unicode Consortium: 
http://www.unicode.org

Tavultesoft: 
http://www.tavultesoft.com
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Things you already know about Windows 
Cardbox is a Windows program, so it tries to behave as much as possible like other 
Windows programs.  However, some features of Windows aren’t used very often 
and it’s possible that you may not have come across them recently.  Here, to refresh 
your memory, is a short description of them. 

Multiple selections in list boxes 
List boxes are something you come across every day when using Windows.  Most of 
the time you look at the list and click on the item you want; but some list boxes let 
you select multiple items at once.  This is very useful with Cardbox.  For example, 
you can tell Cardbox to show you a list of possible search terms, and then you can 
choose the ones that you want Cardbox to search for.  Here’s how you can do this 
using the mouse: 

Click on an item to 
select it.  If you 
click on another 
item, this deselects 
the first one. 

   

Ctrl + click on an 
item to select it.  
Other items aren’t 
affected.  If you 
Ctrl + click on a 
selected item, this 
deselects it.    

If you click on an 
item and then 
Shift + click on 
another one, you 
will select all the 
items in between 

   

Shift + click  deselects anything that isn’t in the range you’re selecting.  To preserve 
selections outside the range, use Ctrl + Shift + click instead. 
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Multiple documents in one program window 
When you use Windows Paint to open more than one picture, you get two copies of 
Windows Paint, each of them with one picture.  On the other hand, if you open more 
than one email folder in Eudora, they will all open inside a single enclosing Eudora 
window.  Microsoft Word behaves sometimes one way, sometimes the other way, 
depending on which version you’ve got and how you’ve set it up. 

In Cardbox, each database opens in its own window inside the enclosing Cardbox 
window.  In case you’re not familiar with using windows in this way, here are some 
examples. 

Several database windows visible at a time 
All the databases within a Cardbox workspace are opened inside one Cardbox 
window.  There are two basic ways in which you can lay things out.  You can have 
several database windows visible at once: 

 
In this case each window can be moved and resized in any way you want, and you 
can see several databases at the same time. 

If you have multiple 
workspaces open at 
once, each of them 

works like a separate 
copy of Cardbox,  with 

its own database 
windows inside it.

This example comes 
from the Galpin 

Society, which is 
dedicated to the study 

of old musical 
instruments.  It uses 
Cardbox to manage 

its subscriptions.
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One database window at a time 
If you maximise one of the database windows then it grows to fill the whole Cardbox 
window and the result looks something like this: 

 
This means that you can only see one database window at a time, but on the other 
hand you have enough space to see far more of it. 

People sometimes get confused by the fact that there are two sets of window-control 
tools at the top right-hand corner of the Cardbox window.  The top set (think of it as 
the outer set) minimises, maximises, or closes Cardbox as a whole.  The bottom set 
(the inner set) controls the database window inside Cardbox, and lets you minimise, 
resize or close just that window, leaving the rest of Cardbox unaffected. 

If you have more than one database open in your Cardbox workspace, you can use 
Ctrl + F6 to switch from one database window to the next.  To move through your 
database windows, hold down the Ctrl key, press F6 until you get to the window you 
want, then release Ctrl.  Alternatively, use the Window menu, which lists your 
database windows by name, or use the command Window > Windows. 

This database
indexes trade cards of 

musical instrument 
makers from the 

collection of 
Tony Bingham for a

future illustrated book.
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A look at the Cardbox screen 

The top of a Cardbox window 

 
The title bar: if you have several different workspaces, you can use File > 

Workspace to give each one a different name, in which case the name will 
appear at the top in place of the word “Cardbox”.  If you have a database 
window that is maximised so that it takes up the whole of the Cardbox window, 
its name appears on the title bar as well. 

The menu bar contains all Cardbox’s standard menu commands.  The miniature 
Cardbox logo on the left appears when you have a maximised database window 
and it gives you access to that window’s System menu. 

The toolbar contains buttons for commonly used functions.  If you’re not sure what 
a button does, hold the mouse over it for a moment and a brief description will 
appear.  If you have the Professional Edition then you can add toolbar buttons of 
your own.  If there are too many buttons to fit in the size of your Cardbox 
window, you’ll see a little arrow on the right-hand edge: press it, and the 
remaining buttons will pop up in the form of a menu. 

The bottom of a Cardbox window 

 
The level of selection tells you how many selection commands are currently in 

force: see page 24. 

The browse bar lets you browse through your records: see page 65.  If your 
database has images in it, there will be a second browse bar so you can browse 
through the images attached to each record: see page 69. 

The number of tagged records appears if you’ve tagged any records: for more 
about tags and tagging, see page 93. 

The name of the current format will appear next, if you’re using a format other than 
the native format: see page 27. 

The two status markers have various uses: when something appears here, click on 
the marker to get an explanation of what it means.  In this example, the marker 
is telling you that your link to a remote Cardbox server is encrypted for security. 

For more about 
workspaces, see 

page 61.
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Progress of a long-running command 
Sometimes a command can take a long time: downloading a large database is one 
example.  Cardbox displays a progress bar to tell you what it is doing and give you 
some idea of how far it has got: 

 

If Cardbox knows how much work remains to be done, the blue bar gets gradually 
longer.  If it doesn’t know, a smaller blue bar moves across from left to right. 

To cancel a long-running command, click on the button to the right of the progress 
bar. 

Warning displays within records 
A pattern made of tiny clock-faces tells you that Cardbox is waiting for some data to 
arrive.  This will most often happen when you are connected to a Cardbox Server 
and the link is slow or the server is busy.  You don’t need to do anything.  As soon 
as the data have arrived, the clocks will disappear and you will see the data instead. 

A hatched pattern indicates that the record you are looking at is deleted.  You won’t 
normally see this, because in most cases when a record is deleted Cardbox instantly 
removes it from your selection.  Occasionally this isn’t practicable and you’ll see the 
hatched pattern.  Don’t worry: this doesn’t indicate an error, and the deleted record 
won’t appear in any printouts.  

A cross-hatched pattern indicates that there is something wrong with the record.  
This is very rare: so rare, in fact, that we had to fake an illustration of it because we 
couldn’t get it to happen.  If you see this pattern, you should rebuild the database or 
restore it from a backup: see page 249. 
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How to open and close Cardbox; how to open and close 

databases; browsing; searching; sorting; printing, 

export. 
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Opening and closing Cardbox 

Opening Cardbox 
How you open Cardbox depends on what options you used when you installed it.  
You may have an icon on your desktop, or an entry in the Start menu, or both.  If 
you’re a sophisticated user you may even have set up different Cardbox 
workspaces, again either with their own icon or their own Start menu entry. 

You can also open Cardbox just by double-clicking on a Cardbox database file when 
you see it in Windows Explorer. 

If you really can’t see what else to do, ask Windows to find the file CARDBOX3.EXE, 
and then double-click on it.  If this is the first time that you’ve run Cardbox on your 
computer, it will offer to create a desktop icon and a Start menu entry for you.  

Closing Cardbox 
To close Cardbox, use the command File > Exit or press Alt + F4. 

Shutting down Windows 
You don’t need to close Cardbox before you shut down Windows: it will close itself 
automatically when Windows shuts down. 
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Opening databases 
Before you can do anything with a database, it has to be open in Cardbox.  Exactly 
how you open a database depends on where it is: whether it’s in a file on your 
computer or whether it’s in a shared location (on your LAN or on the Internet) and 
accessible through a Cardbox server. 

Although opening a database is logically the first step, you’ll find yourself doing it 
remarkably rarely.  This is because whenever you close Cardbox and then open it 
again, it remembers exactly what you were doing last time and re-opens all your 
databases for you automatically.  See “Workspaces”, p.61. 

File > Open is the main command that you use for opening databases.  It brings up 
a screen with three tabs: My Computer, Server, and Recently Used. 

File > Recent Databases takes you straight to the Recently Used tab, which shows 
you the 20 databases that you have opened most recently. 

File > 1, File > 2,… take you instantly to one of the four most recently opened 
databases.  If you’d like more than four databases to be listed here, use the 
command Tools > Options » Menus to set a different number. 

Another way of opening a database 
If you double-click on a Cardbox database file (filetype .FIL) in Windows Explorer, 
Cardbox will open the database.  Cardbox doesn’t already have to be running when 
you do this: it’ll start automatically.  

File > Open 
Ctrl + O 
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Open command: My Computer tab 
Use this tab to open a database that’s in a file somewhere on your computer.  The 
My Computer tab looks just like any other Open File box in Windows, so you’ll be 
familiar with it before you start. 

 

• You start by seeing the folder you used last time you opened a database. 

• At the top right-hand corner you’ll see a Recent Folders button.  This lets you 
jump directly to folders you have opened databases in recently. 

• If you have a lot of databases with long names, Windows will spread them out 
and you’ll probably want to make the Open Database window bigger.  To do this, 
drag the resizing handle (at the bottom right-hand corner) outwards. 
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Opening files on a network 
You aren’t confined to files on your own computer: if you’ve got access to shared 
drives on your network, you can use the My Computer tab to open files on those 
drives as well.  But remember that when you open a database using the My 
Computer tab you get exclusive access to it: no-one else can open the database as 
long as you have it open.  To open a database so that several people can use it at 
the same time, you have to use the Server tab. 

This doesn’t restrict your own ability to have several copies of Cardbox open at the 
same time and have the same database open in each of them: it only restricts what 
other people can do while you’ve got the database open. 

• There is one important exception to the rule about the My Computer tab.  If you 
have a database on a networked drive and use Windows Explorer to make both 
the database file (.FIL) and its corresponding format file (.FMT) read-only, then 
any number of people can use the database at the same time.  This is because if 
the files are read-only then Cardbox knows the database can’t change and so it 
is safe for several people to have it open at once.  To make a file read-only in 
Windows Explorer, right-click on it and select “Properties” from the pop-up menu. 
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Open command: Server tab 
Use this tab to open a database that’s accessible through a Cardbox server 
somewhere.  The mechanism is a simplified version of what happens when you 
open a Web page in a Web browser.  For example, what happens when you try to 
open a web page called http://www.cardbox.net/index.htm is that the browser 
locates the computer at www.cardbox.net, connects to the Web server there, then 
asks the Web server to give it index.htm.  With Cardbox, the steps are the same but 
you do them one at a time. 

 
Before you start, you need to know the name of the server you want to access (just 
as you need to know the name of the folder when you open a file on your own 
computer).  You can see a list of servers on the left-hand side: it starts off containing 
just our own public database site, database.cardbox.net, but you can add or remove 
server names as you like, so that your most frequently used servers are just a 
mouse click away.  You probably won’t need to have a very long list: if your 
organisation shares Cardbox databases by keeping them on a central server, that 
server’s name is the only one you’ll need. 
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Picking the server 
Click on the server name in the list, or type the server’s name into the Server box 
and press the View button to connect to it.  At the bottom left, Cardbox will display 
some technical information about the server, or an error message if it can’t connect. 

Picking a file 
Once you’ve connected to a server, you’ll see on the right-hand side a list of the 
databases it is offering.  Click on the database you want and press the Open button; 
or just double-click on the database name in the list. 

A Cardbox server can be set up so that some of its databases aren’t shown in the 
list.  This is sometimes done for security (if you don’t know the database’s name, 
you can’t ask for it) although of course it isn’t a foolproof security precaution all by 
itself.  If you have to open a database that doesn’t appear in the list, ask someone 
what its name is, and type the name into the Databases box, then press the Open 
button. 

Safety levels 
Macros are sequences of Cardbox commands that can be activated by a keystroke 
or by a pushbutton on the screen.  They are very convenient, and some database 
authors take care to provide many macros to simplify your use of their data.  But a 
macro is essentially a mini-program (written in Microsoft’s VBScript) and so if you’re 
opening a database that was created by someone else, you have to protect yourself 
against the possibility that the database author was malicious and wrote macros that 
could harm your computer or reveal sensitive data. 

The default safety level is Untrusted, which allows macros to run but won’t let them 
read or write your hard disk or do other potentially harmful things.  Unless you know 
that a database contains sophisticated macros that need to be more trusted than 
this, there’s no need to alter this safety level.  There is a spectrum of safety levels, 
from Completely Untrusted to Completely Trusted, and you can set safety levels for 
individual databases or for the server as a whole, so that (for example) you can 
make your organisation’s corporate server Completely Trusted but leave all other 
servers Untrusted. 

Open command: Recently Used tab 
Cardbox remembers the last 20 databases you opened, and the Recently Used tab 
lets you open one of them just by double-clicking on it.  You can sort the list into 
order by name, location, or recency of use by clicking on the appropriate heading.  
To remove a confidential or embarrassing database name from the list, click once on 
it and then press the Remove button. 

For more about safety 
levels and trust, see 

Help Point 526.
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Security messages when opening a database 
Cardbox databases can be protected with passwords, and they can even be 
encrypted.  Whether you are able to set these features up depends on the kind of 
Cardbox licence you have, but whatever the licence, you may find yourself using a 
database that has been given this kind of protection, especially if the database is a 
shared one. 

Profile and password 
User profiles give different users different levels of access to the same database.  
When you try to open a database that has user profiles, you’ll see a message asking 
you for a password. 

 
The exact message will vary depending on how the owner of the database has set 
things up.  You may be asked to choose from a list of profiles; on the other hand, 
you may find yourself not being asked for a password at all because a “default 
profile” has been set up that doesn’t require one.  (This is common with databases 
intended for public access: there’s a default profile with no password that lets people 
view the public data but not alter anything, and there are other, password-protected 
profiles that let the administrators do their work). 

For more information, see “User Profiles”, p.41.  

Encryption 
Encrypted databases are much less common than password-protected ones, and 
you may never come across one. 

 

The coloured blob helps 
to protect you against 

typing mistakes: its colour 
changes depending on 

the password you’ve 
entered, so if it looks 

unfamiliar then you’ve got 
something wrong.

There are so few possible 
colours that the coloured 
blobs don’t give anything 
away, even if an enemy 

films the screen while 
you’re typing.



    60  

 

When you try to open an encrypted database, you’ll see a message asking you to 
enter the encryption key.  Without the encryption key, the database is unreadable.   

Remembering passwords and keys 
There is an old saying that people want security as long as they don’t have to do 
anything about it.  This is as true in computing as in any other field.  You may feel 
that you want to protect your data against strangers, but having to type a password 
every time you open your database is just too much work. 

With Cardbox, there is a way round this.  If you password-protect your workspace, 
the workspace will remember your passwords and keys for you, so that you have 
only one password to remember (the workspace password).  If you really want, you 
can even get Windows to remember your workspace password for you, though in 
some versions of Windows this may make things less secure against a determined 
hacker.  See “Workspaces”, p.61. 
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Workspaces 
Open Cardbox, open some databases, do some searches, and close Cardbox.  
When you open Cardbox again, you’ll find yourself back exactly where you were: 
same window sizes, same databases, same selections, same everything.  This is 
because Cardbox has created a workspace file and used it to store everything about 
the state of your session. 

If your use of Cardbox is fairly simple, you can feel mildly pleased about this feature 
and never think about workspaces again; but if you find yourself using Cardbox for 
many different things, then segregating your activities into different workspaces 
makes a lot of sense. 

Creating separate workspaces 
File > Workspace shows you which workspace you’re using at the moment.  To 
create a new workspace, press New and choose a filename and location for the new 
workspace file.  Once you’ve created the new file, set up Cardbox the way you want 
it (open the databases you want, close the databases you don’t want, and so on) 
and then close it.  You now have a separate workspace file, in the location you’ve 
chosen. 

 
To delete a workspace that you don’t want, just use Windows Explorer to find the 
workspace file (its filetype will be .cbw) and delete it. 
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Workspace shortcuts 
You can put shortcuts to Cardbox workspaces into the Windows Start menu or onto 
your desktop.  You can tell Cardbox to create these shortcuts when you’re creating a 
new workspace, or you can do it afterwards using File > Workspace » Shortcuts.  
You can remove shortcuts in the same way. 

Opening a workspace 
If your Start menu has a shortcut for the workspace, use it. 

If you’ve got a shortcut for the workspace on your desktop, use it. 

Otherwise, find the workspace file in Windows Explorer and double-click on it. 

You’re allowed to have several workspaces open at the same time, and you can 
also have the same database open in more than one workspace if that’s what you 
need to do. 

Which workspace am I using? 
If you have several workspaces open at the same time, how can you tell which one 
is which? 

1. You can find out the filename of your current workspace by using File > 
Workspace and seeing what filename it reports. 

2. You can make each workspace give a different title to your main Cardbox 
window.  By default the main window is called “Cardbox”, but you can change 
the title by using File > Workspace » Properties.  If you give the main Cardbox 
window a different title in each workspace – for instance, “Mailing”, “Library”, 
“Accounts” – then the workspaces will look different both on the screen and in 
the Windows task bar, so that you can easily tell them apart. 

Protecting your workspace if you make a mistake 
Suppose that you have a workspace that you use every day, with lots of carefully 
arranged windows in it, and then you accidentally close some of those windows.  If 
you now close Cardbox, your unintentional change will be stored in the workspace. 

There is way round this problem.  If you hold down the Shift key when you close 
Cardbox, the workspace will be left unchanged, in the state it was in when you 
opened Cardbox, and all your mistaken changes will be forgotten.  
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Preset workspaces 
There is another way of making sure that a workspace isn’t unintentionally changed.  
Create the workspace, set it up to be exactly the way you want it, and close 
Cardbox.  Then use Windows Explorer to make the workspace file read-only.  Now 
nothing can change its contents, and the workspace will come back in the same 
state every time it’s opened. 

Password protection 
You can give your workspace a password so that it can’t be opened by someone 
who doesn’t know the password.  This is quite useful anyway, but the best thing 
about it is that the workspace can then remember the passwords of password-
protected user profiles and the encryption keys of any encrypted databases (this 
information is stored in the workspace file in an encrypted format that is unreadable 
without the workspace password).  So instead of having to remember and type a lot 
of codes, you only have to remember the password for the workspace. 

To set up or change the password, use File > Workspace » Password.   

 
If the workspace already has a password, enter it in the box.  Then turn on Enable 
Password Protection if you want to give the workspace a password or turn it off if 
you don’t want password protection.  When you turn on password protection, you’ll 
have to enter the new password twice as a protection against mistyping. 

If you give your workspace a password and you then forget the password, the 
workspace is useless.  There is no way of retrieving the password and you will 
have to delete the whole workspace and start again.  Since workspaces don’t 
contain any of your data, this should only be an inconvenience and not a disaster.   

To make a file read-only, 
right-click on it and pick 

“Properties” from the  
pop-up menu.  The 

filetype of the workspace 
file is .cbw.

If you encrypt a database, 
make sure you keep a 

separate note of the 
encryption key locked 

away somewhere, in case 
you ever have to delete 

the workspace file.
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Getting Windows to remember the workspace password 
If it’s too much bother to remember and type in the workspace password every time 
you open your Cardbox workspace, you can get Windows to remember the 
password for you. 

On Windows 2000 and above (including Windows XP), this uses methods built into 
Windows by Microsoft which tie secret information to the identity of a user.  If you 
choose to remember the workspace password in these versions of Windows: 

• You will be able to open the workspace without being asked for its password.  
• Anyone else using your logon account will be able to open the workspace 

without being asked for its password.  
• Other users who try to use this workspace will be asked for its password.  
• If your logon account becomes inaccessible or has to be deleted and re-created, 

the remembered password may be lost.  In that case you will have to enter the 
workspace password the next time that you open the workspace.  

The storage of the password is only as secure as the relevant Windows security 
systems. We didn’t write them.  We have no reason to believe that Microsoft have 
made any mistakes in their implementation of these systems, but to make your own 
assessment of how secure your password will be, look up “Windows Data 
Protection” on the Microsoft web site. 

On Windows 95, 98, and Me there is no built-in protection of secret data.  We’ve 
done our best to get round this deficiency, but if you choose to remember the 
workspace password in these versions of Windows: 

• Anyone who uses your computer will be able to open the workspace without 
being asked for its password.  

• Anyone who takes a copy of your workspace file and tries to use it on a different 
computer will be asked for the workspace password.  It follows that there is no 
security threat if you make a backup copy of your workspace file and it is then 
stolen.  

• Someone who takes a copy of your workspace file and is also able to spend 
some time at your computer extracting technical information from the Windows 
Registry (and has enough technical expertise to know what to look for) may be 
able, later, to open your workspace file on his own computer without being asked 
for its password.  

• If you have to reinstall Windows then the remembered password may be lost.  In 
that case you will have to enter the password the next time that you open the 
workspace.  

It’s up to you to judge whether this is secure enough for your purposes. 
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Browsing through your records 
When you have a selection of records – whether it’s a selection that results from 
searches you have made or the “Level 0” selection that represents all the records in 
your database – you will want to look through it.  We call this process “browsing”. 

Whenever you look at a Cardbox database, one record is the current record: if you 
tell Cardbox to edit, this is the record that will get edited; if you tell Cardbox to delete 
a record, this is the record that will get deleted.  If the screen is only displaying one 
record, that’s the current one; if the screen is displaying a list of records, Cardbox 
draws a thin black frame round the current record so you can see which one it is.  

Using the browse bar 
If you look on the left-hand side of the status bar at the bottom of the Cardbox 
window, you’ll see what looks like a scroll bar with corrugations.  This is called the 
browse bar.  It tells you which record you’re looking at and how many records there 
are in the current selection. 
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Using the keyboard 

Right arrow 

Down arrow 
Next record. 

Left arrow 

Up arrow 
Previous record. 

Ctrl + Home First record. 

Ctrl + End Last record. 

Ctrl + G A specified record number.  
Cardbox will ask you which record 
number you want. 

Ctrl + Z The record you were on just before 
the last big jump (Ctrl + Home or 
Ctrl + End) or the last search 
command.  

Page Down Go forward 
one page in 
the list. 

Page Up Go back one 
page in the 
list. 

Home The top 
record on 
this page. 

End The bottom 
record on 
this page.  

The vertical browse bar  
If your records are small enough for Cardbox to fit several of them onto a screen (for 
instance, if you’re viewing them as one-line summaries), then it will display an extra 
browse bar on the right-hand side of the screen.  It behaves just like the browse bar 
we’ve already described – except, of course, that it’s vertical. 

Scrolling large records 
If a record is too big for the window you’re viewing it in, you’ll see scroll bars at the 
edges of the window.  You can use the scroll bars to scroll different parts of your 
record into view.  If you have a mouse with a wheel on it, you can roll the mouse 
wheel to scroll the record.  Use the mouse wheel on its own for vertical scrolling, or 
hold down the Shift key as you roll the wheel in order to scroll horizontally. 

Scrolling large fields 
Because Cardbox doesn’t impose built-in limits on the amount of text you can put 
into a field, you can sometimes end up typing more text into a field than the field is 
able to display.  If this happens to you, you can scroll different parts of the field into 
view by moving the mouse onto it and using the mouse wheel, on its own for vertical 
scrolling or with the Shift key for horizontal scrolling.   

If you don’t have a mouse with a wheel, you can move the mouse onto the field, 
depress the left mouse button, and drag in the direction of the text you want to see. 
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Viewing Extra Text 
The Extra Text field is a piece of text that you can optionally attach to each record in 
your database: it resembles the Memo field that some other database programs 
provide.  Cardbox can show you the Extra Text field on its own or together with the 
record it’s attached to. 

Viewing extra text on its own 
Use this command to display extra text; use it again to return to your normal record 
display. 

Viewing extra text together with a record 
Use this command to display the current record together with its extra text.  A 
horizontal bar will separate the two components, and you can use the mouse to drag 
this upwards if you want to see more of the extra text or downwards if you want to 
see more of the main record. 

If you would like to start in this mode as soon as you open a format, turn on “Format 
display starts with extra text visible” in the format properties: see page 204. 

A note for users of older versions of Cardbox 

Since Extra Text was first invented, the keystroke for it has always been F3.  Over 
time, however, F3 has become widely accepted in PC software as “Find” or “Find 
Next”, and so with Cardbox 3.0 we have decided to follow the same convention.  We 
have moved Extra Text to F6 because that is the generally accepted key for “switch 
to the next pane in a multi-pane display”.  We apologize for the confusion to your 
fingers that this will cause at first, but we believe that in this case consistency is 
more important than tradition. 

Opening a new window onto your database 
Sometimes you may want to see the same database in two different windows: to do 
two different searches, or to edit in one window and search in the other.  To open a 
new window onto your database, use Window > New Window. 

Switching from one database window to another 
If you have more than one database open in your Cardbox workspace, you can use 
Ctrl + F6 to switch from one database window to the next.  To move through your 
database windows, hold down the Ctrl key, press F6 until you get to the window you 
want, then release Ctrl.  Alternatively, use the Window menu, which lists your 
database windows by name, or use the command Window > Windows. 

View > Extra Text 
F6 

View > Split Window 
Shift + F6 

For more about opening 
multiple database windows, 

see page 46.

For more about extra text, 
see pages 26 (concepts) 
and 204 (format design).
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Step browsing 
Step browsing is a specialised technique.  It is like a cross between searching and 
browsing. 

Step browsing begins like a search: you choose what to search on (the index, the 
record data, tagged records, etc) and Cardbox finds the matching records.  But once 
it’s found the records, Cardbox doesn’t change your current selection.  Instead, you 
are left in your original selection and you can browse it much as you’d expect, 
except that you are only allowed to land on records that match the search.  
(The best mental image we’ve found is of lily leaves on a pond: a frog crossing the 
pond can only jump to where there is a leaf).  To remind you of the fact that you’re 
browsing differently, the browse bar looks a little different: 

 
To get out of the step browse mode, click on the Cancel button or press the Esc key. 

The point of step browsing is to be able to look at selected records in the context of 
their neighbours.  Some people really need this; most people don’t.  So if you can’t 
see a use for step browsing, don’t bother to think about it. 

Using the browse bar 
To start a step browse using the browse bar, right-click on the record number and a 
menu will pop up, giving you a choice of search types to use for the step browse.  
Once you’ve chosen the search type, the appropriate search command will open: 
see “What you can search for” (p.76) for more details. 

Using the Browse menu 
The Browse menu is a submenu of the Search menu.  Open it with the mouse, or 
with Alt + S followed by B, or even with Alt + B.  If you’re likely to be using the 
Browse menu a lot, you can promote it to the main menu bar, just to the right of the 
Search menu.  To do this, use the command Browse > Promote Menu.  

Browse > Step to Tagged Records starts a step browse that lands only on tagged 
records.  

Browse > Step to Specific Records starts a step browse that lands on records that 
match an index search.  When you use this command, an index search window will 
open so that you can specify the index search: see “Searching the Index” (p.80) for 
more details.  
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Browsing and viewing images 
For Cardbox, an image is anything visual – a photograph, drawing, scanned 
document, or fax.  Images are stored in a special field, the “image field”, which you 
design as part of your format.  You can have only one image field, but that field can 
contain as many images as you like. 

Viewing images 
When you look at a record that has an image field in it, that field will show you the 
image that you’ve stored in the record.  If you have stored several images in a 
record, Cardbox starts by showing you the first one. 

If the image field on the screen is smaller than the image, Cardbox shrinks the 
image to fit inside the field.  With photographs, you can often design the format so 
that the field is big enough for the photograph to be decently visible.  Scanned 
documents, on the other hand, are better viewed on their own in the image window 
rather than as part of a record, because a miniaturised document is too small to 
read.  

Multiple images and the image browse bar 
Towards the middle of the status bar at the bottom of the Cardbox window, you’ll 
see what looks like an ordinary Cardbox browse bar, except that it’s shorter and the 
corrugations are a different shape.  This is the image browse bar.  It tells you which 
image you’re looking at and how many images there are in the current record.  You 
can drag the slider or click on the arrows to move forward and back through the 
images. 

Using the keyboard to browse through images 

Alt + Right arrow 

Alt + Down arrow 
Next image. 

Alt + Left arrow 

Alt + Up arrow 
Previous image. 

Alt + Home First image. 

Alt + End Last image. 

To store images you need 
to create an image field: 

see “Format Design”, 
page 189.
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The image window 
The image window displays an image so that it occupies practically the whole 
screen.  For a normal-sized document, this makes it big enough for you to read the 
document without having to print it out.  The image window lets you zoom in or out 
and browse through images. 

Opening the image window 
View > Images opens the image window.  Alternatively, you can right-click on the 
image field and select “Full Screen” from the pop-up menu. 

Closing the image window 
The same toolbar button that opens the image window will close it and return you to 
your record display.  You can also press F12, or you can right-click anywhere within 
the image window and select “Full Screen” from the pop-up menu. 

Browse bars in the image window 
At the bottom of the image window you’ll see the usual browse bars for browsing 
between images and records.  They work just as usual, but if you are in the habit of 
using the keyboard for browsing, you’ll find that the use of the Alt key is reversed. 

• To browse through images, press the appropriate arrow key without holding 
down Alt. 

• To browse through records, hold down Alt when you press the appropriate arrow 
key. 

Zooming in and out 
The zoom control is at the bottom of the image window. 

To zoom in: click on the large magnifying glass, or hold down the Ctrl key and 
press + (plus) on the numeric keypad. 

To zoom out: click on the small magnifying glass, or hold down the Ctrl key and 
press - (minus) on the numeric keypad. 

If you have a mouse with a wheel, you can use the wheel for zooming: hold down 
the Ctrl key and roll the wheel away from you to zoom out or towards you to zoom in. 

View > Images 
F12 

This difference is because 
you’re more interested in 
images when the image 

window is open and so it 
makes more sense  

not to require Alt for  
image browsing.
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The zoom menu 
For more detailed control of zooming, open the Zoom menu by clicking on the white 
area between the magnifying glass symbols. 

Pixel Count and Image Size 

There are two ways for Cardbox to measure the amount by which an image is being 
zoomed.  In the Pixel Count mode, a zoom factor of 100% means that Cardbox 
displays one pixel on the screen for every pixel in the image.  In the Image Size 
mode, a zoom factor of 100% means that Cardbox makes one inch of the image 
take up one “screen inch” on the screen.  The size of a “screen inch” is something 
that has been decided by the manufacturer of your computer screen: a common 
convention is to have 96 pixels per screen inch, which usually makes a screen inch 
rather more than 2.54 centimetres in size. 

The reason why these two zoom modes are different is that not every image is 
created with the same resolution as your screen: it all depends where the image has 
come from (scanner, camera, fax) and how it has been processed.  If you display a 
200 dots per inch fax image at 100% in Pixel Count mode, it will be twice the size of 
the original document and you will have to zoom out to 50% (or switch to Image Size 
mode).  On the other hand, the software inside some digital cameras make bizarre 
statements about the resolution of the photographs, and if this happens then Pixel 
Count ends up being the most sensible choice.  Try playing with the various 
combinations and see what suits you and your images best. 

Choosing zoom factors 

You can pick your zoom factor from the list that pops up in the zoom menu, or you 
can select “Custom” to type your own.  The available zoom factors depend on the 
capabilities of your display drivers and the version of Windows you are using, but a 
typical range is from 20% (÷5) to 1200% (×12). 

Fit Width will make the image as wide as possible while still fitting inside the width 
of the window: the result may be an image that is too tall for the window and 
needs to be scrolled vertically. 

Fit Height will make the image as tall as possible while still fitting inside the height of 
the window: the result may be an image that is too wide for the window and 
needs to be scrolled sideways. 

Fit In Window will make the image as big as possible while still fitting entirely within 
the window, with no scrolling. 
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Scrolling 
When you are viewing an image that is larger than the available space, you’ll see 
scroll bars next to it.  You can use the scroll bars to scroll a large image, or you can 
simply place the mouse inside the image, hold down the left mouse button, and drag 
the image in the direction you want. 

If you have a mouse with a wheel, you can use the wheel to scroll vertically.  To 
scroll horizontally, hold down the Shift key while you are using the wheel. 

Thumbnail display 
On the left-hand side, the image window can display miniature “thumbnail” versions 
of your images.  You can use these to decide which image you want to look at, if you 
have several images attached to a record.  Thumbnails are more useful for 
photographs than for scanned documents, because at thumbnail size all documents 
look much the same. 

You can turn thumbnail display on and off by clicking on the  button at the 
bottom of the image window, or by pressing the F4 key, or by right-clicking 
anywhere in the image window and selecting “Thumbnails” from the pop-up menu.  
Right-clicking also lets you decide the size of thumbnail you want to see: small, 
medium, or large. 

For some purposes (such as printing) you may want to select specific images.  To 
select or deselect an image, hold down the Ctrl key and click on the thumbnail, or 
(without using Ctrl) click on the top right-hand corner of the thumbnail.  A tick will 
show you which images you have selected. 

More information 
Printing images – page 81. 

Exporting images – page 129. 

Adding images – page 160. 
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Searching the database 

The basic search commands 

Select  
Select looks in the current selection. 

It creates a new selection, retaining only the 
records that match your Select command. 

This is the commonest search command in 
Cardbox. 

Exclude  
Exclude looks in the current selection. 

It creates a new selection, leaving out any records 
that match your Exclude command. 

Exclude is the opposite of Select.  Instead of telling 
Cardbox which records you want, you tell it which 
records you don’t want. 

Once you’ve entered one of these search 
commands and got the records you want, you can 
do whatever you like with them: look through them, 
or edit them, or print them, or pass them to another 
program. 

Building up searches: levels of selection 
When you do a simple search, you’ll see the status bar change from “Level 0” to 
“Level 1”.  This reminds you that you’re looking at the results of a search command 
and not at the whole database. 

What happens if you do a second Select command without undoing the first one?  
Cardbox looks at the current selection (Level 1), picks out the records that match 
your new Select command, and creates a new selection out of them.  In other words 
these two Select commands have combined, and the records you’re left with (at 
Level 2) are just those that match both the Select commands.  

Before you start a simple 
search, always make sure 
that the status bar says 
“Level 0”, which means 
that Cardbox is showing 
you every record in the 
database. (Another way of 
putting this is to say that 
the current selection 
contains all records).  If 
you don’t do this, your 
search commands will go 
towards refining or revising 
the last search that you 
did. 

To get to Level 0, do 
Search > Clear All 
Selections, or hold down 
the Ctrl key and press the 
Undo button on the toolbar:

If you are used to Boolean 
logic, Select is AND, and 

Exclude is AND NOT.
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Commands that expand the current selection 

Include 
Include starts with the current selection. 

It creates a new selection from it, by adding to it every record in the database that 
matches the Include command. 

Select Also 
Select Also starts with the current selection. 

It creates a new selection from it, by adding to it every record from the previous 
selection that matches the Select Also command. 

Select Also seems to do the same sort of job as Include, so why did we put it in? 
Here’s an example that will help to show why. 

Imagine that you run a pet shop and you want to make a list of girls in London 
aged between 8 and 12 who keep rats or snakes as pets.  The first few steps are 
easy.  Start at Level 0, select the sex to get to Level 1, select the age to get to 
Level 2, select the location to get to Level 3.  Select RAT, and you’re at Level 4.  
You might be tempted to include SNAKE at this point, but if you did, you’d get 
absolutely everyone who kept snakes, even 40-year-old Scotsmen.  But if you 
use Select Also, it’ll look back at your Level 3 selection (girls between 8 and 12 
in London), find SNAKE among those, and add them to the Level 4 selection 
you’ve already got (RAT), which gives you exactly what you wanted. 

In this simple example, you could have got away without using either Include or 
Select Also, because Cardbox lets you search for both RAT and SNAKE in one 
single command; but in more complicated cases, where you really do need those 
commands, this example helps to explain the difference between them. 

Undoing search commands 

Undo One Level  
Undo goes back one level of selection: from Level 3 to Level 2, or from Level 1 to 
Level 0.  For basic search commands, this is similar to undoing the last command. 

Clear All Selections 
Clear undoes all selections at once and gets you back to Level 0, where all the 
records in your database are visible and ready to be searched.  You can also use 
the toolbar to do this, by holding down the Ctrl key as you click on the Undo button. 

In terms of Boolean logic, 
Include and Select Also 

both function as OR.

Search > Undo 

Search > Clear 
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Seeing where you are 

History of Selections 
When you’re building up a really complex search, it’s possible to get a little lost.  The 
History command shows you all the search commands that got you where you are 
now.  You can print the list as an audit trail, or copy it to the Clipboard.  If you want, 
you can even make the history pop up automatically every time you do a search. 

Highlight Matches 
This command is part of the View menu, and it represents a mode that you can turn 
on and off.  When you turn “Highlight Matches” on and then enter a search 
command that looks for a word, Cardbox will highlight the word in your record 
display.  This can be helpful if you’ve got a field with a lot of text in it and you want to 
see the word in its proper context. 

One more command… 

Exclude Also 
Exclude Also is almost identical to Exclude.  The only difference is that it modifies 
the result of the last Exclude command instead of creating a new level of selection.  
It’s unlikely that you’ll ever want to use this command: we’ve included it only for 
completeness. 

Search > History 

View > Highlight Matches 
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What you can search for 

Searching the index (p.80) 
The index is what makes Cardbox searches so fast, so searching the index is the 
best and most usual way of searching your database. 

Single words (p.82) LONDON 

Wildcards (p.82) SM?TH* 

Ranges (p.82) E:K 

Single numbers and dates (p.83) 3/8/1923 

Ranges (p.83) 12.5:15 

Phrases (p.83) "RED DOG" 

Lists (p.84) 1370441 1373910 1329990 

Boolean combinations (p.85) HISTORICAL +RESEARCH –INSTITUTE 

Preview lists (p.85) 

 

Searching through record data (p.90) 
Sometimes you do need to search through unindexed text, either because you 
forgot to index something or because it wasn’t worth indexing a field because 
searches in it are so rare.  Data searches are slower, but they’re still quite fast. 
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Tags and tagged searches (p.93) 
As you look through your records, you can mark or “tag” particular ones.  The 
tagged search commands then let you select or exclude the tagged records.  This 
feature is unique to Cardbox, and it’s invaluable for fine-tuning a selection by hand.  

Keeping and combining selections (p.97) 
When you have made a selection, you can save it for later use.  You may never 
need this feature, but it can be good when you want to combine different selections 
together or even if you want other people to review a selection you have made. 

Advanced search commands 
You can also search on record numbers, “Select the 10th to 20th records of the 
current selection” (p.99) and you can combine selections from different windows 
(p.100) as long as they’re windows onto the same database. 
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Relational linking 

 

Relational searching is different from ordinary index searches in two ways. 

Getting the search text 
In an ordinary index search, you tell Cardbox which field to search and you also tell 
it what text to look for. 

In a relational search, you don’t specify the search text directly, but you tell Cardbox 
where to get the search text for itself: it will look in a window that you specify, and in 
a particular field within the current record in that window.  As you can see in the 
illustration above, you can tell Cardbox in detail how to extract search terms from 
your chosen field. 

This is a feature of the 
Professional Edition only.
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Relational links 
Once you’ve made a relational search, it remains “live”.  Using the sample search in 
the illustration: if you switch to the window called “Sledger” and move to a different 
record, the contents of the field IN will be different.  So Cardbox will redo the 
relational search in “Winser” using search terms extracted from the new contents of 
that field. 

This effectively creates a link between the two windows, which lasts until you 
explicitly cancel the search using Search > Undo. 

If you were editing a record in “Sledger”, then much the same thing would happen: 
any changes you made to IN would make the search different and Cardbox would 
redo the search in “Winser” each time.  It would be very inefficient to do this every 
time you pressed a key, so in this case you have to use Window > Update to tell 
Cardbox to redo the relational search. 

You can have more than one relational search active at the same time.  For 
example, suppose that you have one database of houses and another of people 
looking for somewhere to live.  You could make several searches in the Houses 
database, using relational links to different fields in the People database.  If you had 
both databases on the screen at the same time then you could watch the selected 
Houses records change as you moved from one People record to the next; and you 
could edit a People record and make changes to it to see what Houses records were 
found as you changed the search criteria. 

For more about relational linking, including some suggested applications, see Help 
Point 500. 

Window > Update 
F9 
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Searching the index 
Because index searching is the commonest kind of search in Cardbox, there are 
many ways to start an index search.  You can make an index search look at just one 
field, or at all fields. 

Starting a search 

Right-click = Select 
Move the mouse onto a field, click the right-hand mouse button, and you’ll start a 
Select command for just that field.  Or an advanced move: right-click when you’re on 
the record but not on any field, and you’ll start a Select command for all fields at 
once. 

Right-click-and-hold = menu 
Move the mouse onto a field, press the right-hand mouse button, but don’t release it 
for a few moments.  A menu will pop up.  Choose the command you want, and it’ll 
open with the field already chosen for you. 

The Search menu 
Open the search menu (either with the mouse or with Alt+S) and pick the search 
command you want.  Once the search command has opened you’ll need to tell 
Cardbox which field to search, unless you want to search all fields. 

The toolbar 
Select and Exclude are the commonest commands, so they have toolbar buttons of 
their own. 
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Choosing a field to search 
If you used a right-click to start a search command, Cardbox noticed where you 
clicked and so you can skip this section (unless you change your mind about which 
field to search). 

 
You can type the name of the field you want, or you can leave the Field control 
untouched if you want to search all fields. 

You can open the drop-down list by clicking on the arrow, and pick the field you want 
from the list: 

 
Next to the box with the field name you’ll see a hook.  If you click on this, the search 
box will disappear temporarily and you’ll be back looking at your records again.  The 
cursor will have changed into a hook.  Click on the field you want to search, and  
Cardbox will bring back the search box with the name of the field filled in. 
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Things you can search for 

Single words 
To search for a single word, type it into the “Search For” box and press OK.  There is 
nothing else to say about this, except that it’s the commonest search you’ll use. 

Wildcards 
When you type a word into “Search For”, there are two special characters you can 
use as wildcards: 

? matches exactly one character. 

* matches any number of characters. 

This can be useful if you want to capture a number of different spellings, or if you 
aren’t sure if a term was being used in the singular or the plural (HOUSE versus 
HOUSES) or even if you’re lazy and don’t want to type the whole of a long and 
complicated word. 

You can use any number of question marks and asterisks, and also combine them: 
so, for instance, SM?TH* will match SMYTHSON as well as SMITH. 
The question mark ? represents one character, and there must be a character there 
to match it, so MODE? will match MODEM and MODES but not MODE. 

The asterisk * represents zero or more characters.  If it is entered as the only 
search character, it will match any word at all.  For example, you can find records in 
which no alphabetic text has been indexed (in a particular field) by using the Exclude 
command with * in the “Search For” box. 

Ranges of words 
You can put two words separated by a colon into the “Search For” box: 

E:K finds all indexed words beginning with a letter from “E” to “K” inclusive. 

:COB finds all words from the beginning of the index to the last word that starts 
with “COB”. 

XE:  finds all words from the first indexed word that starts with “XE” to the last 
word in the index. 

: finds all indexed words as long as you’ve got the “Which Index” option 
set to “Words”.  If you don’t, Cardbox will assume that you want a 
numeric search.  If you really want to find all indexed words, you’ll find it 
easier to use the asterisk * instead. 

If you’re not sure what 
words your wildcard will 

match, press the Preview 
button and Cardbox will 

show you a list.
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Single numbers and dates 
To search for a single number or date, type it into the “Search For” box and press 
OK.  For details of the date formats that Cardbox understands, see “Date formats 
and Cardbox”, p.37. 

Ranges of numbers and dates 
You can put two numbers (or dates) separated by a colon into the “Search For” box: 

17:32 finds any indexed number between 17 and 32, inclusive. 

14.6: finds any indexed number greater than or equal to 14.6. 

:30000 finds any indexed number less than or equal to 30000. 

: finds all indexed numbers. 

Phrases 
If you put a series of terms (words, numbers, or dates) in quotation marks, Cardbox 
will search for records that contain those terms adjacent to each other and in exactly 
that order.  It will only look at things that are indexed: unindexed text will be ignored. 

"RED DOG" will match BIG RED DOG but not RED BIG DOG. 

You can also search for words that are in a particular order but may have other 
words separating them, by using special search words. 

... (three 
dots) 

will match any number of words.  So "RED ... DOG" will match 
RED DOG, RED BIG DOG and RED BIG FIERCE DOG. 

* (asterisk) will match exactly one word.  So "RED * DOG" will match RED 
BIG DOG and RED LITTLE DOG but not RED DOG or RED BIG 
FIERCE DOG. 

There are more sophisticated options as well: for instance, you can search for two 
words that are not more than a certain distance apart. 

For details, see  
Help Point 510.
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Lists 
You can type several terms (words, numbers, or dates) into the “Search For” box, 
separated by spaces.  What happens depends on the setting of the “Match All” 
option. 

With “Match All” turned off, Cardbox will find records that contain any of the terms 
you have typed: in Boolean terms, this means OR. 

With “Match All” turned on, Cardbox will find only those records that contain all the 
terms you have typed: in Boolean terms, this means AND. 

By default, Cardbox leaves “Match All” turned off when you start a search, so that 
you have to turn it on manually.  You can change this default using Tools > Options 
» Search.  We strongly recommend that you choose your favourite default setting 
early on in your use of Cardbox and then never change it, because there is nothing 
more frustrating than typing a lot of terms into the “Search For” box, pressing OK, 
and then realising that “Match All” was off when it should have been on, or on when 
it should have been off. 

Some more examples: 

  
This is what we do when someone comes back from paying in cheques at the bank.  
We open our Sales Ledger database, right-click on the Invoice Number field, and 
type a command like this one to find all the invoices whose cheques have just been 
paid in.  You can see that the “Search For” box accepts ranges as well as single 
values. 

  
This is something we use when we need to find a user’s record but have nothing 
more than an abbreviated company name to go on.  It’ll find any record where the 
field contains a word beginning with S, a word beginning with V, and a word 
beginning with R, not necessarily in that order. 
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Boolean combinations 
You can have more elaborate combinations of search terms than just “any” (OR) or 
“all” (AND), by using a few extra symbols: 

A plus sign + in front of a term means that that term must occur in any record that 
Cardbox finds: a Boolean AND. 

A minus sign - in front of a term means that that term must not occur in any record 
that Cardbox finds: a Boolean AND NOT.  [If you put this in front of a number, 
leave a space between the minus sign and the number, or Cardbox will think that 
you’re simply talking about a negative number]. 

Parentheses () round a group of terms means that at least one of those terms must 
occur in any record that Cardbox finds: a Boolean OR. 

You can combine these symbols in more or less any way you like.  For example, 
(HISTORY HISTORI*) +(INSTITUTE SOCIETY) would find records that had 
INSTITUTE or SOCIETY in them as long as they also had HISTORY, HISTORIAN, 
HISTORICAL, etc. 

Help Point 532 gives many more details of how these symbols work alone and in 
combination, but don’t worry if you find them obscure or complicated: there is no 
obligation to use them.  You may not be doing this sort of complex search anyway; 
and even if you are, you can always build up your search step by step, using Select, 
Include, and Exclude, if you find that clearer.   

Preview lists 
On the right-hand side of the Search command windows you’ll find two buttons, 
Preview and Preview-and-Count.  They almost do a search, but not quite.  Instead of 
finding records that match your command, the Preview buttons look through the 
index and find the index terms that match, and they present you with a list of them.  
Here are some possible uses: 

• If you’ve put a particularly elaborate wildcard into the “Search For” box, you can 
use Preview to work out if it’ll match anything in the index; and if it does, whether 
it is finding what you want it to find. 

• If you’re not very familiar with the database you’re using, and you aren’t sure 
what values a field can contain, you can leave “Search For” blank, press 
Preview, and get a list of the indexed terms in that field.  Remember to set 
“Which Index” to “Words” or “Numbers/Dates” first, because Cardbox can’t 
guess which index to search if you haven’t typed anything into “Search For” that 
would give it a clue! 
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• If you want to search for only some of the words in the list, use Preview to bring 
up a list of index terms and then click on the ones you want to use in your 
search, to highlight them. 

• When you’ve highlighted all the terms you want, press OK and Cardbox will find 
the matching records.  This is especially useful if you are looking for misspelt or 
inappropriate index terms. 

• If you want to process the list of index terms or pass it on to another program, 
use Preview: next to the list of terms you’ll find buttons for copying the list to the 
Clipboard or saving it to a file. 

 

   
 

Preview and Preview-and-Count are very similar.  Preview is simple-minded: it just 
searches the database index and reports every index term that matches your 
“Search For” request (or all index terms, if you have left “Search For” blank).  
Preview-and-Count is more sophisticated: for each index term it finds in the index, it 
checks to see if any records in the current selection match that term.  If nothing in 
your current selection matches the term, Preview-and-Count ignores it altogether; 
otherwise it reports the term to you and also tells you how many records matched it.  
Because of the extra work it does, Preview-and-Count is often slower; but it gives 
you more focused information.  It is particularly useful when you are looking at a field 
that someone else designed, because you can see at a glance which terms appear 
often and which appear rarely.  

Left: a Preview list.
Right: Preview-and-Count.

For a guide to selecting 
multiple items from a list, 

see “Multiple Selections in 
List Boxes” (p.45).
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Specialised options for index search 

Fuzzy matching 
Sometimes you’re not sure of the spelling of a word that you’re looking for: this is 
especially true of names, but it also applies to words that are spelt differently in 
different countries.  One option is to use wildcards, but they aren’t always the best 
idea because they’re often too powerful.  COLO*R will find COLOR and COLOUR 
but it will also find COLONISER.  And is it STREATFIELD or STREATFEILD?  
Finding a wildcard that matches both of them is a tedious effort.  In cases like this, 
fuzzy matching is the solution. 

In fuzzy matching, Cardbox finds index terms that almost match what you put in the 
“Search For” box.  Effectively, it plays the sort of game that children play when they 
try to transform one word into another, one step at a time.  It keeps the score like 
this: 

Action Score 

Remove a letter 1 

Insert a letter 1 

Replace a letter by another one 1 

What you put into the “Fuzzy Match” box is the maximum score that you are 
prepared to allow: in other words, the maximum difference between the word that 
Cardbox finds in its index and the word that you specified in “Search For”.  

There is one extra refinement: often you’re certain of the first few letters in a word 
and it’s later that doubt sets in.  You can save Cardbox some work by telling it that 
the first few letters aren’t fuzzy and must be matched exactly: that way it won’t have 
to look through so much of the index.  For example, if you put 3+2 in the “Fuzzy 
Match” box, you are telling Cardbox that the first three letters must match exactly 
and the rest of the word is allowed a fuzziness of 2. 
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Here, to continue the game, is a set of words that are only 2 steps apart in a fuzzy 
match: 

 

Search string Matching string Changes that make the strings match 

SMITH SMYTHE 1. Replace I by Y.  2. Add E. 

JONES JOHNS 1. Insert H.  2. Remove E. 

WATSON WATERSON 1. Insert E.  2. Insert R. 

HILLINGS SHILLING 1. Remove S.  2. Insert S. 

• Fuzzy matching doesn’t work with wildcards or ranges or phrases. 
• If you’re in any doubt about what a fuzzy match will find, use the Preview button 

to get a list of matching terms. 
• Fuzziness makes quite big differences very quickly, especially if the words are 

short.  A search with a fuzziness of more than 5 is likely to be so fuzzy that it is 
meaningless. 

Find Unique Terms Only 
If you turn this option on, 

• Cardbox goes through the index, according to the “Search For” specification. 
• For each index term it finds, it counts how many records in your selection match 

that term. 
• If more than one record matches the term, Cardbox ignores it and goes on to the 

next index term. 

Find Unique Terms is a very specialised option.  The only real use we know for it is 
to use it with Exclude to identify index terms that occur more than once in a 
selection, which can be useful if you have a field that is meant to contain something 
distinctive like a serial number.  For more details, see Help Point 565. 
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Searching check box fields 
So far, we’ve been talking about searching fields that are displaying text, because 
they are the commonest kind of field; but it’s also possible to set up your format so 
that fields are displayed as check boxes, radio buttons, or drop-down lists. 

 
If you right-click on this sort of field, Cardbox will list all the possible values in the 
field: 

 
Click on the item or items you want to search for.  Clicking once produces a tick , 
meaning that you want records containing this item; if you click again, you’ll get a 
cross , meaning that you want records that don’t contain this item; if you click once 
more, you’ll get nothing at all, meaning that Cardbox won’t consider this item at all.  
When you’ve chosen what you want to search for, press OK and Cardbox will do the 
search. 

If you prefer to use the standard Search command window, just as you would for a 
field that was displayed as text, press the Text Search button. 

The Match All option appears only when you’re searching a field that is displayed as 
check boxes.  It makes a difference if you have clicked on more than one search 
item. Effectively, it changes the search from a Boolean OR to a Boolean AND: for a 
full explanation, see Help Point 586. 

For more information, 
see “Alternate Field 
Views” on page 32.
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Searching through record data 
In most databases there are fields that you’ll never want to search… and then some 
time later it turns out that “never” really means “very rarely, once in a blue moon”.  
For us, telephone numbers are like that: it would be pointless to index every 
telephone number, but occasionally someone leaves us a really garbled voicemail 
message and the only thing we can understand from it is part of the phone number.  
This is where a data search comes in useful.  Data searches are inherently slower 
than index searches but often the difference isn’t always that noticeable: you can 
expect a data search of a few hundred records to take a fraction of a second. 

Starting a search 

Right-click = Select 
If a field is defined as “Index=None”, so that Cardbox knows that it can’t contain any 
indexed words at all, you can just move the mouse onto a field and click the right-
hand mouse button, and you’ll find yourself in a Data Select command for just that 
field. 

Right-click-and-hold = menu   
Move the mouse onto a field, press the right-hand mouse button, but don’t release it 
for a few moments.  A menu will pop up.  If it has a Data submenu, open it and 
choose one of the commands inside it.  If it hasn’t got a Data submenu, this means 
that the field isn’t indexed and so Cardbox is going to give you a Data search 
anyway. 

The Data menu 
The Data menu is a submenu of the Search menu.  Open it with the mouse, or with 
Alt+S followed by D, or even with Alt+D, and pick the search command you want.  
Once the search command has opened you’ll need to tell Cardbox which field to 
search, unless you want to search all fields. 

If you’re likely to be using the Data menu a lot, you can promote it to the main menu 
bar, just to the right of the Search menu.  To do this, use the command Data > 
Promote Menu.  

Chosen the wrong search? 
If you start an Index search and then realise you want a Data one, there’s no need 
to cancel: just press the Data Search button at the bottom of the Index search box. 
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Choosing a field 
The ways you can choose a field to search are the same for data searches as for 
index searches (see page 81).  There’s just one refinement: when you leave the 
“Field” list blank, telling Cardbox to search all fields, you can decide whether to 
include the Extra Text field in the search or not: 

 

Entering the search text and using wildcards 
In the “Search For” box, type the text that you want Cardbox to look for.  If you want, 
you can use the following wildcard characters: 

The question mark ? matches exactly one character. 

The asterisk * matches any number of characters. 

The space matches one or more spaces. 

You can use any number of these characters, and also combine them: so, for 
instance, SM?TH* will match SMYTHSON as well as SMITH. 

Search options 

Match Entire Field as One Unit 
If this option is turned on, Cardbox will look at the field as one indivisible thing, so 
that your search specification has to match the whole field: for example, searching 
for THE would find records where the field contained “THE” and nothing else, and 
searching for THE* would find records where the entire field started with the three 
letters T, H, E.  When “Match Entire Field as One Unit” is turned on, the asterisk is a 
wildcard that matches any character at all, even a space. 

If this option is turned off, Cardbox will match parts of the field (words or groups of 
words) as well as the field as a whole: for example, searching for THE would find 
records where the field contained the word “THE” somewhere within it but contained 
other words too, and searching for THE* would find records where the field 
contained at least one word starting with T, H, E. 

When “Match Entire Field as One Unit” is turned off, the asterisk matches any 
character except a space.  This is to maintain the concept of searching for words 
within a field.  If you search for B*G then you want to find fields containing the words 
BIG and BORING, but you don’t, as a rule, want to confuse matters by  being given 
THE BUS WAS GOING FAST as well, just because one word started with B and a 
later one finished in the same field happened to finish with G. 
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Match Punctuation 
If this is turned off, Cardbox ignores punctuation marks when matching your search 
text against a record.  If it’s turned on, Cardbox treats punctuation marks just like 
any other letter. 

Match Case 
If this is turned off, Cardbox ignores the case of letters when matching, so that LTD 
will match “Ltd”.  If it’s turned on, there won’t be a match because some of the letters 
are in a different case. 

Match Accents 
If this is turned off, Cardbox ignores accents when matching, so that PECHE will 
match “pêche” and “péché”.  If it’s turned on, there won’t be a match because the 
accents are different. 

An unexpected use of Data search 
Sometimes someone writes to us, quoting a non-existent Cardbox serial number.  
Probably they’ve transposed two digits.   

Fuzzy matching isn’t very useful because it would change digits as well as reshuffle 
them, and anyway it works only on words and not numbers. 

So if the user has said something like 2170031, we successively do Data searches 
on *2*, *1*, *7*, *0*, and *3*.  The result is a collection of serial numbers that 
contain just those digits, and with any luck there won’t be more than a handful of 
them and we can look through and find the likeliest one. 

Changing your mind about indexing 
If you find yourself using Data search frequently in a field only because you hadn’t 
originally marked the field as indexed, you should consider editing the native format 
and changing the indexing mode: see page 190.  Help Point 541 tells you about re-
indexing existing records after you have changed the indexing mode. 
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Tags and tagged searches 
Tags are so simple that it’s hard to explain them.  They’re also so useful that we find 
it hard to understand why every database program doesn’t have them; but so far 
Cardbox is the only one.  If you do any database searching at all, it’s worth reading 
this section to see if tags will make your life easier. 

Let’s start with a definition: 

A tag is a temporary mark that you can make on the record you’re 
looking at.  Tags don’t alter the content of a record, they don’t 
change how the record looks when it’s printed, and if you’re on a 
network, other users of the database won’t be able to see your tags. 

Tagging is easy.  To tag or untag a record, move onto it and press the Tab key; or 
just hold down the Ctrl key and click on the record. 

So what are tags for? 

Just as you can search on indexed words, so you can search on tags. 

And that’s it.  The point of tags is that they form a quick and informal way of fine-
tuning your searches or of putting complex searches together.  Here are a few 
examples. 

Fine-tuning a search 
You’ve been searching a library database and your search has come up with a 
dozen records that match the criteria you entered.  You want to print out the books 
you want, but you can see just from glancing at the list that you only really want 
details of four of them. 

1. Tag the records you want. 

2. Use Tag > Select to select them. 

(Without tags, you would have had to invent elaborate manual searches that found 
just the four records you wanted and left out all the others, which is ridiculous when 
you can see at a glance what you want). 

Tag > Tag Record 
TAB 



    94  

 

Excluding specific records 
Let’s suppose that you’re preparing a big mailing and you’ve selected the records of 
the people you want to write to.  But you’ve talked to one or two of them recently, 
and you don’t want to send the usual standard letter to them because you want to 
write to them personally. 

1. If you want mailing labels as well as standard letters, print out the mailing labels. 

2. Tag the records of the people who should have personal letters. 

3. Use Tag > Exclude to exclude them from the selection. 

4. Print out standard letters for everyone in the new selection. 

5. Use your favourite word processor to write those personal letters. 

(Without tags, you’d have had to design an extra field in your database saying 
“needs a personal letter” or “has been talked to recently”, which means more 
complication and more bureaucracy). 

A shopping basket 
You’re back in the library again.  This time you want to print a single list of all the 
journal articles you’re looking for, in alphabetical order for easy reference; but the 
snag is that each article needs a search of its own, and you’ve got half a dozen 
different articles to search for. 

1. Use Tag > Clear to make sure nothing is tagged. 

2. Search for the first article, and when you’ve found it, tag it.  Use Search > Clear 
to go back to Level 0 for the next search. 

3. Search for the second article, and when you’ve found it, tag it.  Use Search > 
Clear… 

4. If one of your searches gets you several articles and you want to include them 
all, you don’t have to wear yourself out hitting the Tab key: use Tag > Tag Rest 
of Selection instead 

5. When you’ve tagged everything you need, use Tag > Select to select all the 
records you’ve tagged. 

6. If you realise you’ve included some records you didn’t want in the end, untag 
them and then use Tag > Select again so that you only keep the records that still 
have tags. 

7. Sort the selection into sequence and print it out. 



      Tags and tagged searches  95 

 

The details 

The Tag menu 
The Tag menu is a submenu of the Search menu.  Open it with the mouse, or with 
Alt + S followed by T, or even with Alt + T.  If you’re likely to be using the Tag menu 
a lot, you can promote it to the main menu bar, just to the right of the Search menu.  
To do this, use the command Tag > Promote Menu.  

Tagging records 
Tag > Tag/Untag Record tags the current record if it isn’t already tagged.  You can 
also do this by holding down the Ctrl key and clicking on the record. 

Tag > Tag Rest of Selection tags the current record and all the records that follow it 
in the current selection.  If one of those records is already tagged, it stays tagged.  If 
you’ve just entered a search command, you’ll be at the beginning of the current 
selection anyway, which means that this command will tag the whole selection. 

Untagging records 
Tag > Tag/Untag Record untags the current record if it’s already tagged.  All the 
same toolbar buttons and shortcuts apply. 

Tag > Untag Rest of Selection untags the current record and all the records that 
follow it in the current selection. 

Tag > Clear untags all records in the entire database, whether they’re part of the 
current selection or not. 

Searching on tags 
Tag > Select, Tag > Select Also, Tag > Exclude, Tag > Exclude Also and  Tag > 
Include all behave exactly like the indexed search commands of the same name, 
using the “taggedness” of records as the test of whether a record matches the 
search command.  Since there is nothing further for Cardbox to ask you, a Search 
window doesn’t pop up: Cardbox just performs the command at once. 

Tag > Tag Record 
TAB 



    96  

 

Red tags 
You’ll have noticed that the tags that you normally use look black on the screen.  
Red tags are a new feature in Cardbox 3.0.  They’ve appeared because some of our 
users have asked for them; but they are likely to be quite a specialised feature, so if 
you can’t think of an immediate use for red tags, just forget about them. 

Red tags are there so you can tag records in two different ways.  You may be 
looking through a selection and tagging for two different purposes; or you may be 
happily using black tags and then the phone rings and you have to do a new search 
that involves tags as well: using red tags means that you can leave the black tags 
untouched. 

For red tags, use the Tag > Red Tags menu (Alt+T, D).  This has all the usual 
commands for setting tags, removing tags, and doing tagged searches, but they all 
refer to red tags instead of black ones.  There’s also a set of shortcuts for setting 
and removing red tags on a single record: 

• Hold down the Shift key and press Tab. 
• Move onto the record, hold down the Shift key, and press the toolbar 

button. 
• Hold down the Shift key and the Ctrl key together, and click on the record. 

There’s also one extra command that makes all black tags red and all red tags 
black: Tag > Red Tags > Swap Red And Black Tags.  This can be useful if you want 
to put your current (black) tags to one side to deal with an interruption, but don’t 
want the fuss of handling red tags directly. 

Red tags don’t interfere 
with black tags, so a 

record can have 
tags of both colours  

attached to it.



      Kept selections  97 

 

Kept selections 
The idea of kept selections is that sometimes, when you’ve selected some records, 
you want to remember that selection and use it again later, perhaps combining it 
with others.  Kept selections can be a way to identify collections of records on a 
long-term basis without needing to edit the records themselves, but they have less 
elegant uses too.  To take one simple example: if you find yourself working through 
a selection of records and then get interrupted, you can save those records as a 
kept selection and come back to it another time. 

What a kept selection is 
A kept selection is a list of records.  It isn’t the same thing as the records 
themselves, so deleting it won’t do anything at all to the records.  When you first 
create a kept selection you give it a name and you decide whether it is to be private 
or shared. 

• A private kept selection only lasts as long as you have the database open, and if 
you close the database then your private kept selections will evaporate (of 
course the records will be unaffected, because a kept selection is only a list).  If 
you’re sharing a database across a network, no-one else can see your private 
kept selections. 

• A shared kept selection lasts for ever, or until someone explicitly deletes it.  If 
you’re sharing a database across a network, everyone sees the same shared 
kept selections. 

Managing kept selections 

The Keep menu 
The Keep menu is a submenu of the Search menu.  Open it with the mouse, or with 
Alt+S followed by K, or even with Alt+K.  If you’re likely to be using the Keep menu a 
lot, you can promote it to the main menu bar, just to the right of the Search menu.  
To do this, use the command Keep > Promote Menu. 

To create or replace a kept selection 
Keep > Keep This Selection saves the current selection as a kept selection.  You 
can choose the name of the new selection and whether to make it private or shared: 
then press the Save button.  If there was already a selection with the name you 
choose, Cardbox replaces it. 

Earlier versions of 
Cardbox called  

private kept selections 
“temporary” and 

shared kept selections 
“permanent”.
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• If you are using a database across a network, you may not be allowed to create 
shared kept selections: it depends on what the owner of the database has 
decided to let you do. 

• You are allowed to use numeric digits as part of the name of a kept selection: 
indeed, the name can be entirely numeric (“1234”).  Cardbox doesn’t have a 
separate numeric index for the names of kept selections: it just treats a numeric 
digit in the same way it would treat any ordinary letter. 

To add records to a kept selection 
This can be a useful thing to do if you’re building up one big selection from a lot of 
smaller ones (just like the Shopping Basket example of the uses of tagging).  Use 
Keep > Keep This Selection as before, but instead of pressing the Save button, 
press Append to add the currently selected records to the existing kept selection. 

To forget a kept selection 
Keep > Clear Kept makes Cardbox forget a kept selection.  It doesn’t matter what 
records you have selected at the time you use this command.  When you enter the 
command, a window pops up and you can choose the name of the selection to 
forget and whether it’s private or shared.  Remember that if you close a database, 
Cardbox forgets all its private kept selections anyway. 

Using kept selections 
The search commands Keep > Select, Keep > Select Also, Keep > Exclude, Keep > 
Exclude Also and Keep > Include all behave just like their counterparts in an index 
search – except that there are fewer options: for instance, you don’t have to choose 
the field or the type of search.  You can use any of these word searches: 

• Single names 
• Wildcards 
• Ranges 
• Lists 
• Boolean combinations 
• Preview lists 

For details of how these searches work, look them up under “Searching the Index” 
(p.80). 

If you close a 
workspace without 

explicitly closing any 
databases, all its private 

kept selections will 
reappear when you 

open it again.
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Advanced search commands 
These commands are in Cardbox because a few people have needed them, but 
they are quite specialised. 

Searching by record number 
Sometimes you may want to tell Cardbox “Select the first 30 records from the current 
selection”.  Searching by record numbers lets you do this. 

When Cardbox tells you where you are in the current selection: 

 
it’s effectively numbering the records for you: the first record is record 1, the second 
record is record 2, and so on.  These are the numbers that Cardbox lets you do 
searches on.  These numbers aren’t really properties of the records themselves: if 
you make a different selection, record 31 from the old selection may be record 2 in 
the new selection, or it may not appear in the new selection at all.  

How to do a record number search 
To start a record number search, use the command Search > Select or Search > 
Exclude.  Then open the drop-down list at the bottom of the Search window, and 
choose the following option: 

 
Now you can enter one of the following values in the “Search For” box: 

Format Example Matches 

A number 31 Just record 31. 

Number, colon, number 10:20 Records 10 to 20 inclusive. 

Number, colon 100: Record 100 onwards. 

Colon, number :50 Records 1 to 50 inclusive. 
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Combining selections from different windows 
Cardbox lets you open the same database in several windows.  Some people take 
advantage of this feature and use it to do separate searches in both windows.  If you 
do this, and then you want to combine the selections from both windows into one, do 
Window > Merge.  This will bring up a menu that lists the windows that are available: 
choose the window you want.  Window > Merge behaves rather like an Include 
command.  It takes the current selection in the current window and creates a new 
selection consisting of all the records in that selection plus all the records that are in 
the current selection in the window you picked from the menu. 

If you have just one other window on the database, then the menu will only have one 
item; if you haven’t got any other windows open on this database, Window > Merge 
will be disabled. 
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Sorting 
Records in a Cardbox database naturally come in the order in which they were 
added, so that the first record that was put into the database comes first and the one 
that was added most recently comes last; but you can sort the records into any 
sequence you like, view them in their sorted sequence, print them, or write them to a 
file. 

When it is sorting, Cardbox only pays attention to indexed terms: it sorts words in  
alphabetical order, numbers in numerical order, and dates in chronological order.  
Special rules apply to hyphenated words: the rules make Cardbox sort records into 
the sequence you’d naturally expect, but you can see the details at Help Point 517.  

Simple sorting 
Simple sorting is easy to specify and it is quite fast.  It is restricted to just one field, 
and Cardbox only looks at the first indexed term of that field.  This means that if you 
have a field that contains several indexed words, and you do a simple sort on that 
field, the records will be in alphabetical order as far as the first word is concerned, 
but the second and later words will be ignored. 

Using the mouse 
Move the mouse onto a field, press the right-hand mouse button, but don’t release it 
for a few moments.  A menu will pop up.  Choose the Sequence command, and 
Cardbox will do a simple sort on your chosen field, in ascending order. 

If your selection is already sorted, a tick will appear next to the Sequence command 
to remind you of this, and the Sequence command will remove the sequence and 
leave your records in their natural order: you’ll have to do the Sequence command a 
second time, on your newly chosen field, to sort the selection. 
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The Sequence command  
View > Sequence brings up a window that gives you three options: Field, Custom 
Sequence, and No Sequence.  For simple sorting, click on the “Field” radio button: 

 
You can type the name of the field you want to sort on or pick it from the list.  The 
way you choose the field is exactly the same as for the Search command (p.81). 

When you’ve chosen the field, and whether you want to sort it in reverse order, then 
press OK to sort the selection. 

Simple sorting: the detailed rules 
Cardbox has two indexes (p.35), one for words and one for numbers and dates.  
When it is sorting records, Cardbox first looks at the word index, going in 
alphabetical order from A to Z (“words” such as 3COM come before A in the 
alphabet), and then at the number/date index, going in ascending order numerically 
(or chronologically).  Any records that don’t contain any indexed terms at all come at 
the end of the list. 

If two records turn out identical as far as the index is concerned, Cardbox puts them 
in the same order that they occur in the database. 

Custom sequence 
Sorting on a custom sequence is more powerful than simple sorting.  First of all, 
Cardbox will look at every indexed term in a field, not just the first one; and 
secondly, you can give Cardbox a list of fields to sort on, so that if two records are 
identical based on the first field, it will look at the next field in your list to try and 
decide which record comes first.  For instance, if you had a database of addresses, 
you could sort your records according to the country, and then, within each country, 
on the town, and then, within each country and the town, on the name of the person 
or organisation.  You can specify ascending or descending order separately for each 
field in your list. 

Custom sequencing is also different because it has a memory.  Cardbox remembers 
the last few custom sequence commands you did, so that you can pick them from a 
list and you don’t have to specify the whole list of fields all over again. 
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To set up a custom sequence, do View > Sequence and click on the radio button 
marked “Custom Sequence”: 

 

If the sequence you want is one that’s been used recently, you can pick it from the 
list.  Otherwise you’ll have to define it: to do this, press the Define button.  A new 
window will appear so that you can specify the list of fields to be used for the custom 
sequence.  Press F1 if you need help with this window, or see Help Point 587. 

Recalculation 
Looking through the index in order to build up a custom sequence may take a little 
time, and so, to speed things up, Cardbox remembers the result of each custom 
sequence command.  The idea is that the next time you do a custom sequence on 
the same fields, Cardbox can use the remembered result instead of having to scan 
the index again.  This makes things faster.  But if you’ve added or edited some 
records recently, then there’s a chance that those changes have affected the order 
in which some of your records should be sorted, so Cardbox displays a warning: 

 

To make absolutely certain that your sequence is perfectly correct, tell Cardbox to 
recalculate the sequence.  If you know that the changes you made won’t have 
affected the order that the records come in, or if you don’t mind a slightly inaccurate 
sequence, tell Cardbox to go ahead without recalculating.  This will save a little time, 
though it must be said that with smallish databases (up to about 10,000 records) the 
difference in speed won’t be very noticeable. 

Sorting on a custom sequence: the detailed rules 
When it is sorting records on a custom sequence, Cardbox compares records 
according to the first field that you told it to sort on: if they are identical as far as that 
field is concerned (remember that only indexed terms count in the comparison), it 
looks at the next field in your list; if they are identical there as well, it looks at the 
next field, and the next… until it runs out of fields.  If any records that are identical 
according to every field that you specified for the custom sequence, Cardbox leaves 
them in their original database order. 

Within each field, Cardbox looks at both its indexes (p.35).  First of all, it looks at the 
word index, going in alphabetical order from A to Z (“words” such as 3COM come 
before A in the alphabet), and then at the number/date index, going in ascending 
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order numerically (or chronologically).  One big difference from the simple sort: any 
records that don’t contain any indexed terms at all come at the beginning of the list 
instead of the end. 

Single field: simple sorting or custom sequence? 
It is actually quite meaningful to have just one field specified for a custom sequence.  
This is because a simple sort will only look at the first word of a field, while a custom 
sequence will look at every word: thus a custom sequence on a single field will be 
more accurate than a simple sort on the same field. 

  

Simple sorting 
looks at the first 
indexed word of 

the field 

Custom 
sequence looks 

at all the indexed 
words. 
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After sorting 
Once Cardbox has sorted your records, you can view them in the sorted order, or 
print them, or write them to a file. 

If you were looking at the results of a search command when you asked Cardbox to 
perform the sort (that is, if you were not at Level 0), then Cardbox will not forget the 
chosen order until you undo that search command: any search commands that you 
enter within the current one will automatically show their results in the order you 
have chosen. 

If you add a new record while the records are sorted, it will appear at the end of the 
list: to put it in its correct place, you will have to sort again. 

If you edit a record while the records are sorted, it will not change position even if 
the changes you made mean that the record is no longer in the right place (for 
instance, if you have sorted books by subject classification and you change 
GENETICS to PHYLOGENETICS, the record will stay in its old place just before 
GEOLOGY, when it should have moved to just before PHYSICS).  To get the record 
in its correct place, you will have to sort again. 

The Sequence toolbar button will tell you whether you are looking at a 
sorted display: if it looks normal, the display is not sorted; if the button is 
depressed, the display is sorted.  To see what sequence is being used, 
move the mouse over the button and leave it there for a few moments 
without clicking: 

To cancel sorting 
To cancel a sort and revert to the normal sequence of the database, click on the 
Sequence button on the toolbar.  Alternatively, you can use View > Sequence » No 
Sequence. 
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Changing the format 
A format controls how your records appear on the screen.  For all except the 
simplest databases you’ll probably have more than one format: for data entry and 
browsing; for simple summaries; and perhaps even for mail-merging and mailing 
labels. 

View > Change Format lets you switch to a different format.  It will show you a list of 
formats and you can do any of the following: 

• Type the name of the format and press OK. 

• Select the format in the list.  You’ll see a description of the format at the bottom 
of the window (assuming that whoever designed the format gave it a 
description).  To use this format, press OK. 

• Double-click on the name of the format in the list. 

The native format doesn’t have a name.  You can pick it from the list of formats, or 
you can type a space into the Format Name box that is expecting a format name: 
this will blank out whatever name was already there.  Thus the quick keyboard 
shortcut for switching to the native format is Ctrl + F, Space, Enter. 

If user profiles have been set up for this database, your user profile may include a 
default format, which is the one that the designer of the user profile thinks you’ll be 
using most often.  In that case you’ll see an extra button labelled “My Main Format”, 
and pressing the button will take you straight to that format. 

View > Change Format 
Ctrl + F 
 
(Ctrl + F works only 
when you are viewing 
records, not when you 
are editing them) 
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Changing the appearance 
By “appearance” Cardbox means the fonts, sizes, colours, backgrounds and line 
thicknesses that are used to display or print your data.  The basic appearance is 
something that you set up when you design each format (if you can’t be bothered 
with this, Cardbox uses some reasonable defaults), but you can override the 
appearance at any time by using the command View > Appearance.  You can also 
override the appearance for printing only (for instance, removing background 
colours).  The command for this is File > Printer Settings » Appearance. 

In addition to all this, you can give specific appearances to individual items within a 
format: perhaps a heading in large letters, or a field with a bright red background.  
You do this while editing the format, with the command Edit > Item Properties » 
Appearance. 

The View > Appearance command changes the appearance.  If you enter it while 
editing a format, the new appearance will become part of the format; if you enter it 
while viewing or editing records, it’ll apply until the next time you change formats. 

• If you change the appearance while viewing or editing records and then want to 
get back to the appearance defined in the format, use View > Change Format to 
reload the format. 

• If you change the appearance while viewing or editing records and then want to 
store it as part of the current format, just edit the format with Edit > Format > Edit 
and then save it. 

Kinds of text 
A record can contain the following kinds of text: 

Normal – unindexed data. 

Indexed – indexed data. 

Extra Text – data in the Extra Text field (which is never indexed). 

Captions – anything else, including field captions, static text items, and the parts of 
a merge block that aren’t derived from a field. 

Each of these kinds of text can have its own font, size, colour, and settings for Bold, 
Underline, and Italic.  They don’t all have to be different, and it’s often best to make 
them all be the same – when printing, for instance.  But on the screen, it’s quite 
useful to have indexed text looking different because it helps to know what’s indexed 
and what isn’t; and if you’re creating a summary report with all the captions at the 
top of their respective columns, making the captions bold can help to separate them 
visually from the actual record data. 

View > Appearance 
Ctrl + A 
 
(Ctrl + A works only 
when you are viewing 
records, not editing 
them) 
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You can set up different background colours for the different kinds of text.  These 
are interpreted as follows: 

Normal – the background colour of each field. 

Indexed – not used. 

Extra Text – the background colour of the Extra Text field. 

Captions – the background colour of the format as a whole. 

Lines and boxes 
You can control the thickness of the lines used to draw lines and boxes in the 
format.  Lines and boxes are drawn in the Captions text colour. 

Grid spacing 
This setting applies to the format as a whole: it is quite specialised and you can 
usually ignore it.  When you design a format in Cardbox, you draw it on a grid of 
rows and columns, and Cardbox takes the size of each row and column from the 
sizes of the fonts you are using in the format.  This makes it easy for you to change 
font sizes because the whole format automatically re-sizes itself to match the new 
font.  The Grid Spacing slider lets you influence how wide the columns should be. 

For more technical 
information, see Help 

Point 572.
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The Appearance window 

 
At the top left-hand corner of the Appearance window, you’ll see a schematized 
picture of how text would look with the settings you have chosen.  To change the 
appearance for a particular kind of text, you can pick it from the item list or click on it 
in the picture. 

The Preview button updates the main record display to correspond to the changes 
you have made, so that you see what the new appearance will look like with a real 
record.  The changes you make aren’t fully applied until you press OK: if you press 
Cancel, Cardbox will discard your changes and the display will revert to its original 
state. 

When you are setting the colour, Cardbox will pop up a list of commonly used 
colours.  If you don’t see the colour you want among them, select the rainbow colour 
at the bottom of the list, and a Windows control will open and let you create any 
colour you like. 
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An overview of printing 
Printing in Cardbox is very simple. 

1. Select the records you want: see “Searching”, p.76. 

2. If you want to print them in a different format, use View > Format to select that 
format: see “Formats”, p.106. 

3. If you want the records to be in a particular sequence, select that sequence: see 
“Sorting”, p.101. 

4. Use File > Print to print the records. 

Printing one record 
Sometimes you may want to print just one record.  This quite often happens when 
you are printing a form letter.  In that case, it’s even easier: 

1. View the record you want in the format you want. 

2. Use File > Print and press the button marked “Print One Record”. 

Other options 
Behind the scenes, there are a lot of options you can set when you are printing, 
including the paper size, layout, margins and fonts.  Most of the time it’s enough to 
set these options once and store them as part of your format.  For details of what 
options are available and what they do, see “Printer Settings”, p.115. 
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The Print command 

 

Choosing what to print 
You can print all the records you have selected, or you can go part of the way into 
the selection and print everything from the current record onwards.  (You can also 
print just the current record, by pressing the  “Print 1 Record” button). 

If your records have an Extra Text field, you can print the record without Extra Text, 
or Extra Text on its own, or the record including Extra Text. 

Faster printing 
Some printers are quite slow at printing graphics.  If you have image fields in your 
database, you can tell Cardbox to save time by not printing them; and if you have 
graphic elements in your formats (pictures, letterheads, logos, etc) you have the 
option of telling Cardbox not to print them. 

File > Print 
Ctrl + P 
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The print job ID (optional)  
It is possible to design your format to include a “print job ID” (see “Merge Blocks”, 
page 196).  If you have done this, then whatever you type into the ID box here will 
be printed as the print job ID. 

• Not many people use this feature, but if you regularly make searches and print 
them out, then including a unique ID at the top or bottom of the page can help 
remind you what the search was or who you did it for. 

Checking your design 
If you want to make quite sure that the printout looks the way you want it and that 
you’ve got the right records in the right format, you have several options. 

• You can press “Print 1 Record” and see what just one record looks like. 

• You can turn on “Pause Between Pages” and then press OK.  After printing each 
page, Cardbox will wait for you to tell it whether to carry on with the next page. 

• You can press “Preview” to get the screen to display a preview of the printed 
page: see page 114. 

Choosing a different printer or paper 
The Print command tells you which printer you’re currently using.  If you want to use 
a different printer or size of paper, press “Settings” and you’ll be in Printer Settings: 
see page 115. 

Errors and warnings 
Errors and warnings appear at the bottom of the Print command window, with a 
bright yellow background so that you can’t miss them.  If you want to know what a 
particular message means, press the F1 key and look at the on-line help, which 
gives an explanation of each possible message. 

Warning: Declared record width exceeds available space 
This is the commonest warning message.  On modern computers the screen 
(viewed at its most natural resolution) is wider than the paper.  A screen 1024 pixels 
wide represents about 10.6 inches, and a sheet of A4 paper is about 8.2 inches 
wide: so if you design a nice wide format on the screen, it’ll be too wide to print.  
Cardbox lets you print despite the warning, because it’s sometimes easiest to have 
a piece of paper in front of you to help you see what’s going on; but of course the 
bits of the format that stick out beyond the edge of the paper won’t be visible. 

Previous versions of 
Cardbox would not let 
you print if the format 

was too wide.
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Here are some things you can do about this: 

• Switch to a format that is narrower and better suited for printing. 

• Edit the current format to make it fit: Cardbox can show you the width of the 
printable area while you’re editing the format. 

• Switch to a smaller font, which will make the format narrower. 

• Press “Settings” to tell Cardbox to print in landscape format.  A sheet of A4 is 
11½ inches long, so landscape format should deal with any format that fits on 
your screen without scrolling… unless your screen is an extra large one. 

• If you can’t understand why there isn’t enough width, press “Settings” and then 
open the Page Width tab.  You’ll see a report that takes you step by step 
through the logic that Cardbox used when it was working out how well the 
format would fit on the paper: there is an example on p.118. 

Printing images 
When you print a record that contains an image field, the image field will be printed 
along with everything else, unless you specifically tell Cardbox not to print any 
images (“Faster printing”, p.81).  But you can also print images on their own, without 
the record.  This is useful if you have large images such as scanned documents, or 
more than one image in a record. 

While viewing a record, you can print an image by right-clicking on the image field 
and selecting “Print” from the pop-up menu. 

While you are in the image window, you can print an image by clicking on the 
Print button in the toolbar,  or pressing Ctrl + P, or right-clicking anywhere in the 
image window and then selecting “Print” from the pop-up menu. 

Printing options 
You can choose to print all images, just the current image, or all images that you 
selected by clicking on their thumbnails. 

Cardbox prints one image on each page, and shrinks large images so that they fit 
inside the paper.  It will automatically rotate an image before printing it if this will 
make it fit better. 

 

Ctrl + P 
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The Print Preview command 
The Print Preview command lets you see how the printed output will look.  You can 
look at the preview in two ways: either the whole page can be shrunk to fit your 
screen, or you can see a part of the printed page at its full size. 

• A coloured margin shows you the parts of the paper that cannot be printed.  
Most printers, especially laser printers, can’t print closer than ¼” (7mm) to the 
edge of the paper. 

• Images aren’t shown in the preview: instead, you get a box of the exact size that 
the image will be when printed. 

• If you’re previewing a sheet of mailing labels, you can move the mouse over 
each label and Cardbox will highlight the exact area occupied by that label. 

Accuracy of preview 
Your printer can print 300, 600, or even 1200 dots per inch.  Your screen typically 
works at 96 dots per inch.  You can see the difference between printed output and 
the screen display in this sample: 

 

This difference can make the previewed output look a little strange.  Let’s take an 
example.  Suppose you’re using 10-point type.  On a 600-dots-per-inch printer, this 
will be 83 pixels high.  On the screen, that equates to 13.3 pixels on the screen – 
and since you can’t have a fraction of a pixel, Windows has to choose either a 13-
pixel-high font for the preview, which will be slightly too small, or a 14-pixel one, 
which will be quite a bit too large.  Either way, the words will end up the wrong 
height, and the wrong width as well, either too short or too long. 

Cardbox makes up for this by positioning the start of every word exactly where it 
would be when the page is printed, but this means that the words may end up 
jostling each other or having wide gaps between them.  Don’t worry: the preview is 
only meant to give you an idea of the final layout, and it’ll all come out right when it’s 
printed. 

File > Print Preview 
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The Printer Settings command 
The Printer Settings command controls the settings that Cardbox will use when 
printing.  It is accessible directly as a menu command, or you can call it up from 
within the File > Print command by pressing the “Settings” button. 

Cardbox remembers your printer settings until you change to a different format.  To 
make printer settings permanent, use File > Printer Settings while you are editing a 
format: the settings will then be stored as part of the format. 

The Printer Settings command has five tabs: 

1. Printer and Paper selects the printer, the size of paper or labels, and the paper 
source: if your printer has specific settings of its own that you want to adjust, 
you can do this here. 

2. Text Margins says how much space to leave between your records and the edge 
of the paper. 

3. Records deals with the way records are laid out on the paper: how many records 
per page, the space to leave between records, etc. 

4. Appearance overrides the appearance you have given to your format on the 
screen. 

5. Page Width tells you exactly how Cardbox has calculated the width of your 
records relative to the width of your paper. 

Units of measurement 
Throughout Printer Settings, you can measure in inches, millimetres, or characters 
and lines.  You’ll see a control called “Unit” at the bottom of every tab: whatever unit 
you choose, Cardbox will display measurements using that unit. 

If you type a number into a box that asks you for a measurement – for example “Top 
Margin” in the Margins tab – Cardbox will interpret it using whatever unit is currently 
selected: so typing 0.5 will mean 0.5 inches, 0.5 millimetres, or 0.5 lines, depending 
on the current unit.  If you don’t want to change the current unit but you do want to 
use a different unit for a particular measurement, specify the unit you want directly, 
by typing a letter after the number: for example, 0.5i means half an inch. 

• You can change units as often as you like: this won’t alter any measurements 
you have already entered. 

• If you choose to measure in characters and lines, Cardbox uses the character 
width or line height of whatever font you are currently using.   

c Characters 

i Inches 

" Inches 

l Lines 

m Millimetres 

File > Printer Settings 
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Printer and Paper 
It is almost always best to use the default Windows printer, especially if you are 
designing a format that will be used on a network, because then Cardbox can use 
each computer’s default printer, which is usually the nearest or most convenient 
one.  But if you do want to insist on a specific printer (perhaps one that can print in 
colour) then turn off “Always Use the Default Windows Printer” and pick the printer 
from the list.  If there are any specific features that need setting for this printer – for 
instance, the print quality – then the “Properties” button will take you to the printer’s 
own Properties window, where you can set these features. 

The list of paper sizes shows all sizes of paper that Windows has reported as being 
available for this printer.  For more details of paper sizes and how to select and 
define label formats, see “Paper and Labels” on page 119. 

This tab also lets you choose the source of the paper (if your printer can feed paper 
from more than one tray) and whether you want to print in Portrait (upright) or 
Landscape (horizontal) format. 

Text Margins 
This tab tells Cardbox how much blank space there should be between your records 
and the edge of the paper. 

Most printers can’t print right up to the edge of the paper: this applies to many inkjet 
printers and almost all laser printers.  If you specify a margin that’s closer to the 
edge than your printer can print, Cardbox will automatically widen that margin for 
you, so there’s no need to read your printer’s manual to find out what the real 
margins should be.  Just tell Cardbox the margin you really want and it will get as 
close to it as your printer’s limitations allow. 

Records 
This tab is a mixture of settings related to the way that records are laid out on the 
page. 

Variable text width – the Extra Text field doesn’t have a built-in width of its own, 
and you can also design merge blocks so that they grow in width according to 
the available space.  When you’re printing, you can choose to make these items 
no wider than the format design itself, or you can tell them to occupy the whole 
width of the paper.  The second option is usually the best. 

Omit blank lines at the end of records – it’s quite common to have a record 
design where the last field occupies a lot of space but doesn’t always have very 
much text in it.  You then have a choice of making every record  the same size 
(so that records without much text have a lot of blank space) or of omitting the 
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blank lines at the end of each record so that the records fit tightly together but 
are irregularly spaced (because they vary in the amount of text they have). 

Translate underlines into spaces – some people use underline characters like any 
other letter: this is part of some (old-fashioned) indexing strategies for indexing a 
phrase as a single word.  These people then have the choice of keeping those 
underlines in the printout (so that HYDROGEN_BALLOON appears as 
HYDROGEN_BALLOON) or translating them into spaces to make the text look 
more natural (HYDROGEN BALLOON).  If you don’t use underlines in the 
middle of words, don’t worry about this option. 

1 record per page (or label) – start a new page (or mailing label) every time you 
start a new record. 

Gap between records – if you’re not printing one record per page, you can specify 
how much blank space Cardbox should leave between one record and the next. 

Try not to split records across pages (or labels) – start a new page (or mailing 
label) if the whole of the record won’t fit in the current one. 

Truncate record at end of page (or label) – we don’t really recommend using this.  
When printing mailing labels, some people like to make sure that an 
exceptionally long address won’t spread onto two labels, and this option is 
designed for them. We feel far happier if the long address spreads over two 
labels, because then someone will notice and either stick both labels on the 
same package or edit the record to make it shorter.  This option only appears if 
you have chosen “1 record per page (or label)”.  

Copies of each record – sometimes you may want to print more than one copy of 
each record: this applies to mailing labels especially.  This option only appears if 
you have chosen “1 record per page (label)”. 

Print labels across the page, then down – if you have a sheet of mailing labels 3 
labels wide and 8 labels deep, there are two ways you can print them: down the 
first column, then down the second column, then down the third column; or 
across the first row, across the second row, and so on.  To use the latter 
method, turn this option on. 
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Appearance 
Normally, you use the command View > Appearance to set the fonts, font sizes, and 
colours that you want to use, and these apply to both the screen and the printer.  
Cardbox does, however, give you the option of setting up an appearance specifically 
for printed output, by using the Appearance tab.  This can be useful if you use a lot 
of solid background colours in your screen design and you want them all to come 
out white when you print.  You are also able to select fonts for printing that are 
different from the ones you use on the screen, but we don’t recommend this 
because it can get really confusing if you decide to change fonts later on. 

Page Width 
The Page Width tab is for information only.  It takes you through Cardbox’s 
calculations step by step, and it’s especially useful if Cardbox is warning you that 
your layout is too wide for the paper.  Here is an example:  

Printer resolution is 600 pixels per inch. 
Left margin is 6mm (required by the printer). 
Right margin is 6mm (required by the printer). 

Paper width is 210mm, so width available for printing = 198mm (=4677 pixels). 

 
You are using the printer font News Gothic MT 8. 
Character width: average 33 pixels, maximum 99 pixels. 
Your chosen width: 48 pixels (=2mm). 
So, width available for printing = 97 columns. 

You have designed your format to be 127 columns wide. 
 

For why we don’t 
recommend this, see 

Help Point 559.
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Paper sizes and label types 
The Printer & Paper page of the Printer Settings command lets you select the paper 
size or label type you want. 

Paper sizes 
Printer & Paper contains a list of paper sizes for you to choose from.  Windows 
reports this list to Cardbox, so it should be accurate for your printer.   

Labels 
Labels typically come in sheets in either A4 or US Letter size.  Cardbox thinks of 
labels as very small pieces of paper (such as 64mm × 34mm) and all your formatting 
is done inside that paper size.  Then, when the time comes to print, Cardbox uses 
what it knows about the label layout to print the text for each label in the right place 
on the sheet. 

For all this to work, Cardbox needs to know how the labels are laid out.  It has a 
built-in set of definitions for the commonest label types – essentially, those for which 
the manufacturers publish the specifications – but it is easy to define your own. 

We talk a lot about mailing labels, but exactly the same principles apply to sheets of 
“print-your-own” business cards and even to the special Filofax paper that is sold for 
use in laser printers. 

Picking a label type from the list 
After you’ve used a particular label type once, you’ll find it in Cardbox’s list of paper 
sizes, and you can pick it directly from there.  Labels are listed just after the sheet 
size they belong to: for example, Avery L7160 is 2½”×1½” labels in an A4 sheet 
(three labels across, seven labels down), so you’ll find it below “A4” in the list. 

Adding a label type to the list 
The first time you use a label type, it won’t be in the list.  Select the paper size that 
corresponds to the size of the sheet the labels come in, then press the button 
marked Manage Label Types.  Choose “Define New Label Type” from the menu that 
pops up, select “Use Standard Label Type”, and pick the type you want from the list.   

• If the list is empty, check that you’ve chosen the right paper size. 

• If you can’t see the label type you want in the list, you’ll have to define it for 
yourself. 

To add extra paper 
sizes to the list, see 

Help Point 503.

For continuous rolls 
of labels, see Help 

Point 504.
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Defining your own label type 
In the Paper Size list, choose the paper size that corresponds to the size of the 
sheet of labels.  This is important: if you get it wrong, all your measurements will go 
wrong.  Then press the button marked Manage Label Types, choose “Define New 
Label Type” from the menu that pops up, and choose “Define Custom Label Type” 
from the resulting command window and then press OK. 

 

Get a ruler and a sheet of labels, and start measuring.  Here is what the various 
settings mean: 

Labels across the page The number of labels in each row. 

Left offset The gap between the left-hand edge of the sheet and the 
left-hand edge of the first label. 

Label width The width of each label. 

Gap across The gap between the right-hand edge of one label and the 
left-hand edge of the next. 

Labels down the page The number of labels in each column. 

Top offset The gap between the top edge of the sheet and the top of 
the first label. 

Label height The height of each label. 

Gap down The gap between the bottom of one label and the top of the 
next. 
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• Cardbox is fairly intelligent.  If you leave a measurement blank or type the word 
“auto”, it will guess or calculate what you mean..  Suppose that you say there 
are three labels across the page and there is a left offset of 6mm.  Cardbox will 
guess that the sheet is symmetrical, insert a 6mm gap on the right-hand side, 
and then calculate the width of each label as one third of the remaining space.  
Cardbox displays its guesses next to each “auto” box, so you can see for 
yourself if the results are sensible. 

• Always keep the sheet upright (ie. in portrait format) when you measure it, even 
if you’re planning to print on it in landscape format eventually. 

• Often some of these measurements are zero: for instance, if each label is next to 
the one below it, “Gap Down” is 0. 

• Remember that you can use both inches and millimetres: see “Units of 
Measurement”, p.115. 

• If you really can’t make the figures add up and match what your ruler is telling 
you, check that you’re using the right paper size.  If you’ve told Cardbox that the 
sheet is A4 and it’s actually 10”×8½”, you’ll never get the sums to work.  
Cancel, pick the right paper size from the list, and try again. 

Checking your layout 
To check your label design quickly without using up any labels, use the button 
marked Print Sample Page.  The sample will show the exact area taken up by each 
label in your design.  Print it onto a plain sheet of paper, then hold the paper up to 
the light on top of a sheet of labels and make sure that it all matches. 

Laser printers and margins 
Laser printers can’t usually print right up to the edge of the paper (some inkjet 
printers share the same limitation), so try to choose labels that don’t go right up to 
the edge of the sheet.  The trouble with labels that do this is that you risk losing the 
¼” or 7mm (or whatever your printer’s limitation is) from every label, and while that 
isn’t much space to lose from a whole large sheet of paper, it’s a lot to lose from a 
small label.  But if you really have to use labels that go all the way to the edge then 
Cardbox will do its best to make sense of the situation. 

Other printer settings to use with labels 
In the “Records” tab of the Printer Settings command, you’ll probably want to turn on 
“1 record per label” so that each record starts on a new label.  “Truncate record at 
end of label” and “Print labels across the page, then down” are also relevant: see 
page 117.  

See Help Point 527.
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Multi-column printing 
The mailing label mechanism also provides a simple way of printing text in more 
than one column. 

For example, to print in two columns, design a fake label type that has two labels 
across the page with a suitable gap between the “labels”, and one label down the 
page.  You can then print on plain paper and the printing will come out in two 
columns. 
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Export and communication 
You can do a lot with Cardbox – you can search, browse, view records and print 
them – but sometimes you may need to get other programs involved.  You may want 
to use a word processor to produce mail-merged output; you may want to get your 
data into a spreadsheet or into another database; you may want to write your own 
program to process or analyse your records; or you may want to send faxes and 
emails from Cardbox.  This section gives you a guided tour of the things you can do.  
If you read it, you should have a good idea of what is possible, and the Help Points 
will show you where to get more information. 

Using the Clipboard 
People sometimes forget it because it seems so simple, but the Clipboard is a good 
and reliable way of getting data from one program to another.  To get some text from 
Cardbox to another program, highlight the text in Cardbox, use Edit > Copy 
(Ctrl + C), and then paste it into the other program (most programs use Ctrl + V).  
You can copy images as well: right-click on the image field and pick “Copy” from the 
pop-up menu.  See also “Copying an image to the Clipboard”, p.129. 

Copying all fields 
Edit > Copy Record (Ctrl + Shift + C) copies a whole record to the Clipboard at once.  
If you paste this into another program, you’ll see the text of all your fields together.  
This may mean that you get a lot more text than you want, but selective deletion 
after you’ve pasted the text can be less work than repeated copy-and-paste.  Try 
this feature: if you decide you don’t like it, you don’t have to use it. 

Dynamic Data Exchange (DDE)  
DDE has been around for a long time, as its snappy 1980s name suggests.  
Microsoft are a bit embarrassed about it because it’s so old, but the thing about old 
software is that it works.  By now there aren’t that many programs that don’t support 
DDE, and because it’s old, they all support it in the same way and you’re unlikely to 
have any unpleasant surprises. 

The main way that people use DDE with Cardbox is for a sort of instant one-record 
mail-merge.  Of course Cardbox can do mail-merging by itself without any need for a 
word processor, but sometimes people want some special features that they find 
easier to get in a word processing program.  If you want to send out a hundred form 
letters, there are other ways of transferring data to the word processor; but when 
you want to send just one, DDE can be the answer. 
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For example, if you’re using Microsoft Word, you can set up DDE links by copying 
fields from Cardbox and pasting them into Word with Edit > Paste Special » Paste 
Link.  What you get in your Word document is then a live link to the Cardbox field: 
the document will reflect the contents of whatever Cardbox record you’re viewing at 
the time.  Printing a mail-merged document using Word is then just a matter of 
making sure Cardbox is showing the record you want to print, opening the Word 
document you’ve created, and printing it.  See Help Point 521. 

Exporting data to files 
You can output selected records to a file for another program to read.  First select 
the records you want to write out, and then use File > Export.  This command gives 
you various file formats to choose from, and lets you set any other appropriate 
options, such as a list of the fields that you want to export.  You can export the 
whole of your current selection, or just the current record onwards.  The online help 
for file export is very detailed, so if you need more information on anything, just 
hit F1. 

Comma-separated format (CSV)  

 
Also sometimes known as comma-delimited format, this has become a de facto 
standard on PCs, and most programs that can import data can do so in this format.  
In particular, Word can use comma-separated files for mail-merging and other 
Microsoft programs can import them, including Access, Excel and Outlook.  Most 

See Help Point 524.
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programs that use address lists can read them in from comma-separated files: these 
include email programs and the Palm Desktop.  Cardbox can import CSV files as 
well, but it’s not a good idea to use them for Cardbox-to-Cardbox transfer because 
CSV files don’t contain any information about which words are indexed. 

XML 

 
XML (Extensible Markup Language) is designed to make it easy for structured data 
to be shared between different programs.  XML isn’t a file format in itself but a 
standard way of constructing file formats.  The idea is that if all formats share XML 
as a basis then it will be possible to translate any format into any other format 
automatically.  Web browsers will be able to open any XML document and display it 
by using a “stylesheet” (written in XSL, a language based on XML).  One XML-
based format can be translated into another XML-based format by using XSLT 
(another language based on XML), and so on. 

Cardbox can output data in XML, and there is an XML Schema on our web site that 
should enable any XML-aware application to read the results.  In addition, you can 
write your own XSLT transform that turns Cardbox’s XML into another XML-based 
language (although writing XSLT is not a trivial task) 

In practice XML is a lot less fully developed than its prophets claim, and many 
applications that claim to “support XML” actually only support their own restricted 
subset of XML.  We won’t name names here, because software is developing the 
whole time and what was true when this manual was written may not be true by the 
time it’s printed.  Our summary is that XML is potentially a very good thing, but that 
you should check carefully that any particular use of XML to transfer data from one 
program to another will actually work. 

See Help Point 523.
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Cardbox External format 

 
Cardbox External format is a format we defined ourselves, so other packages won’t 
read it “out of the box”.  But as you can see, it’s a very simple format, so if you want 
to write your own programs to process data exported from Cardbox, External format 
may be a good choice. 

Cardbox Internal format 
This is another format that we have defined.  Unlike Cardbox External format, it 
contains full information about which words are indexed, and it can also contain 
images and objects if you want.  Cardbox Internal format is good if you want to 
transfer records from one Cardbox database to another without loss of information 
(as long as the native formats of both databases are identical), and although it’s less 
simple than Cardbox External format, it’s still possible to write programs that read 
and write it. 

Print-to-disk 
This isn’t so much a file format as a way of constructing file formats.  The idea is that 
if you are faced with a program that wants to import data in a way that doesn’t match 
any of the standard formats, you create a Cardbox format that makes your records 
look exactly right when you view them on the screen.  Then you “print” the records, 
not to the printer but to a file.  Because Cardbox has so many ways of laying out 
fields and merge blocks, you have a lot of freedom in the output you create.  

See Help Point 520.

See Help Point 528.

See Help Point 530.
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Communicating with programs directly 
Exporting data from Cardbox and reading them into another program is reliable and 
(once you’ve set it up) quite fast, but it still seems a bit circuitous.  Cardbox’s macro 
language is built on Microsoft’s VBScript, and this means that it can talk directly to 
other programs.  The possibilities are endless but we’ve worked out some of the 
commoner examples for you. 

Email 
You may want to  

• Send a single email to a recipient whose address you’ve picked up from a 
Cardbox field. 

• Send the same email to a whole list of recipients. 

• Use a Cardbox format to create a personalised email for each recipient. 

Help Point 529 tells you how to do this, using Outlook, Outlook Express, Eudora, 
and MAPI-compatible email programs, or directly through an SMTP server.  In every 
case except SMTP, Cardbox just puts the generated emails into your program’s 
Outbox, and your program is then responsible for the actual transmission. 

Fax 
You may want to  

• Send a single fax to a recipient whose number you’ve picked up from a Cardbox 
field. 

• Send the same fax  to a whole list of recipients. 

• Use a Cardbox format to create a personalised fax for each recipient. 

Help Point 512 tells you how to do this, using WinFax Pro or using the fax engine 
built into Windows XP.  Cardbox just creates the faxes and your fax software will 
then transmit them automatically. 

Telephone dialling 
Help Point 562 tells you how to write a macro that dials a telephone number picked 
up from a Cardbox field. 

Only the 
Professional Edition 

of Cardbox can record 
and edit macros, 

but all editions can 
use them.
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Retrieving Cardbox data into other programs 
If a program you are using has its own macro language (for example, VBA in 
Microsoft Word), you can write a macro in that language to do searches in Cardbox 
databases and retrieve the results.  The possibilities are limited by your 
programming competence and your imagination.  Virtually every aspect of Cardbox 
can be controlled in this way, and you can add and edit records as well as retrieving 
them. 

Creating Web pages from Cardbox 
To create a Web page from Cardbox, design a Cardbox format that contains the 
necessary HTML code together with field references that translate their contents into 
HTML, and then use File > Export » Print-to-Disk to output the result to a file.  You 
can create an HTML page from a single Cardbox record, or you can create it from a 
whole selection of records – for example, to make a summary report. 

• An alternative strategy is to output the records in XML and either translate the 
result automatically into HTML or let XML-aware browsers view the page 
directly.  Help Point 525 gives details. 

See Help Point 531.

See Help Point 519.
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Exporting images 
Before you export an image, use the image browse bar (p.69) or the image 
thumbnail to select the image you want. 

Copying an image to the Clipboard 
While viewing a record, you can copy an image to the Clipboard by right-clicking 

on the image field and selecting “Copy” from the pop-up menu. 

While you are in the image window, you can copy an image to the Clipboard by 
clicking on the toolbar button, or pressing Ctrl + C, or right-clicking anywhere in 
the image window and selecting “Copy” from the pop-up menu. 

Writing an image to a file 
You can write an image to a file and then open it using an image-editing program 
such as Microsoft Paint or Adobe Photoshop.  Cardbox writes images in the 
standard Windows .BMP format, which all programs can read. 

While viewing a record, you can write an image to a file by right-clicking on the 
image field and selecting “Save As” from the pop-up menu. 

While you are in the image window, you can write an image to a file by clicking on 
the toolbar button, or pressing Ctrl + W, or right-clicking anywhere in the image 
window and selecting “Save As” from the pop-up menu. 

Exporting multiple images 
There is no simple way of exporting several images at a time, but it is possible to 
write a macro to do it, giving each image its own filename.  This can be useful if you 
need to transfer a large number of images to another program. 

Ctrl + C 

Ctrl + W 

Help Point 598 gives 
an example for the 

Professional Edition.
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Totalling 
If your records contain numerical information, you may find yourself wanting to 
calculate totals.  To get the total of all numbers in a given field for all records in the 
current selection: 

1. Move the mouse onto the field you want to total 

2. Hold down the right mouse button until a menu pops up. 

3. From the pop-up menu, select Total. 

Cardbox will show you the total for the selected field.  You can copy this total to the 
Clipboard by pressing Copy. 

  



 

 

Part Four 
Editing 

How to add, import, edit and delete records; detailed 

editing commands; spelling checks and validation; 

batch editing; scanning and importing images; 

deduplication. 

 



 

 

How to lose all your data in two easy steps 

 
1. Don’t back up your files. 

2. Wait for your computer to fail. 

 

One day there will be a bang and your computer will 
suddenly stop working.  Or it won’t start when you switch it 
on.  Or it will tell you that you have to erase everything and 
reinstall Windows.  Your only protection is to make regular 
backups.  See “Backup and Disaster Recovery”, p. 249. 
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Adding records 
For a database to be worth searching, it has to have some records in it.  There are 
two ways of getting records into a Cardbox database: you can type them in, one at a 
time, or you can import them in bulk from another file, program, or database.  

Adding records by hand 

Adding a blank record 
Edit > New Record creates a new, blank record for you to type into.  When you have 
finished, use File > Save, and the record will become part of the database.  The new 
record will appear at the end of the current selection: if you want to get back to 
where you were before you added the record, press Ctrl + Z. 

As far as Cardbox is concerned, typing into a blank record is just like editing an 
existing one, except that the record is blank to start with: all the editing commands 
are the same.  For details of how to enter and edit text in a record, see “All about 
Editing”, p.140. 

Adding a record based on an existing one 
Some databases are very repetitive and you often find yourself wanting to add a 
new record that’s almost identical to one that is already there.  For example, in a 
library you may have to index Volume 105 of the Journal of Hellenic Studies when 
you already have a record for Volume 104; or in a bought ledger application there 
may be regular payments that happen every month. 

To create a new record that resembles an existing one, go to the existing record and 
use Edit > Duplicate Record.  This creates a new record just like Edit > New Record 
but instead of being blank, the record contains exactly the same data as the current 
record when you issued the Duplicate command.  Now you can make any changes 
that you need and then use File > Save.  The new record will become part of the 
database, and the original record will be left unchanged. 

Edit > New Record 
Ctrl + N 

File > Save 
Ctrl + S 

Edit > Duplicate 
Ctrl + D 

File > Save 
Ctrl + S 
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An alternative method of duplicating a record 
If there are only a few fields that you want to carry over from the original record to 
the new one, Edit > Duplicate Record can be overkill: whatever time you save by not 
having to retype the fields, you lose by having to erase all the fields you don’t want.  
In this case, there’s an alternative.  Before you create the new record, move onto the 
one whose contents you want, and do Edit > Copy Record.  Nothing will appear to 
happen, but actually the whole of the current record will have been copied into the 
Windows clipboard. 

Now use Edit > New Record to create a blank record, and start filling the record in 
as usual.  Whenever you come to a field that you want to be identical to the original 
record, use Edit > Paste.  When the clipboard was filled using Edit > Copy Record, 
Paste is little more intelligent than usual: it looks at which field you’re in, and pastes 
the original contents of that particular field.  So, for example, if you use Paste in a 
field called ADDRESS, then you’ll get the text from the original ADDRESS field; if 
you use it in a field called KEYWORDS, you’ll get the text from the original 
KEYWORDS. 

The traditional Windows alternative 
In Windows, the traditional way of creating a document based on another one has 
been to edit the document and then to use File > Save As to save your changes in a 
new file.  The same thing applies to images and to other things that you can open 
and edit in Windows.  Accordingly, Cardbox supports this as well: you can edit a 
record, and then, by using File > Save As New instead of File > Save, you can save 
the changed record as a new record in the database, leaving the original record 
untouched. 

This works perfectly from the computer’s point of view, but we strongly recommend 
that you don’t use it, because you are a human being.  If you’re anything like us then 
you won’t always remember, when you get to the point of saving a record, whether 
you’re meant to use Save or Save As New; and if your fingers are anything like ours, 
they’ll sometimes type the Save command for you before you have time to think, so 
that you risk having your original record overwritten instead of creating a new one.  
To avoid such mistakes, please get into the habit of using Duplicate Record! 

Edit > Copy Record 
Ctrl + Shift + C 

Edit > New Record 
Ctrl + N 
 
Edit > Paste 
Ctrl + V 

Edit > Edit Record 
Ctrl + E 

File > Save As New 



      Adding records  135 

 

Adding records from elsewhere 
If the data that you want to put into Cardbox already exist somewhere on your 
computer, it seems rather a waste to have to type them all in by hand, so Cardbox 
gives you a number of ways of importing records in bulk.  Here is a summary of the 
available methods. 

Importing records from a file 
Cardbox can import records from files written in several different formats, of which 
the most useful one is Comma-Separated (CSV).  Almost any program that handles 
data will be able to export files in this format: for example, Microsoft Outlook can 
export your contact lists and your email folders.  The general pattern for data 
transfer is: 

1. Tell the other program to export its data to a file whose name and location you 
choose. 

2. In Cardbox, use File > Import > From File to import the data and create new 
Cardbox records. 

Importing records from a database 
Cardbox can import records directly from some other databases without needing 
anything to be exported: the command is File > Import > From Database.  The 
requirement is that the other database should be accessible through the ODBC or 
OLE DB interfaces.  Microsoft Excel makes its spreadsheets accessible in this form, 
and so does Microsoft Access.  

Importing records from a Cardbox window 
Sometimes you may want to copy records from one Cardbox database to another.  
Here is how to do this: 

1. Open the database you want to copy from (the “source”) and the database you 
want to copy to (the “destination”). 

2. In the source window, select the records that you want to copy. 

3. In the destination window, use the command File > Import > From Cardbox 
Window. 

For more about 
importing from ODBC 

and Excel, see 
Help Point 535.

File > Import 

For full details of the 
available file formats 

and options, see 
Help Point 534.

You can control which 
fields get transferred: 

see Help Point 536.
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Editing records 

Double-click = Edit 
The simplest way to make changes to an existing record is to double-click on it.  This 
not only starts you editing but also gets you to the exact position where you clicked 
the mouse.  But you can also use Edit > Edit Record to edit the current record: this 
starts editing and positions you at the beginning of the first field. 

For details of how you can enter and edit text in a record once you’ve started editing 
it, see “All about Editing”, p.140. 

Saving your changes 
File > Save stops editing and saves any changes that you have made. 

Not saving your changes 
File > Quit Without Saving stops editing and discards any changes that you have 
made.  The toolbar button behaves a little differently from the menu command, 
because it asks you for confirmation: this is because it’s possible to click the wrong 
toolbar button by mistake, and Cardbox doesn’t want to discard all your hard work 
without being sure that this is what you really want it to do. 

Saving your changes as a new record 
This stops editing.  It saves the record, with all the changes you have made, as a 
new record.  The original record (the one that you started editing) is left unchanged.  
The Save As command is the traditional Windows method for creating a modified 
duplicate, but we strongly recommend that you use Edit > Duplicate Record instead: 
for the reasons, see “The Traditional Windows Alternative”, p.134. 

Edit > Edit Record 
Ctrl + E 

File > Save 
Ctrl + S 

File > Save as New 
 

File > Quit 
Ctrl + Q 
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Editing a batch of records 
Very often you will find that you need to make similar changes to a whole batch of 
records: for example, in a mailing list, you may want to update a “date last sent” field 
after you’ve sent a mailing.  Batch editing is a unique feature of Cardbox that lets 
you do this sort of thing easily.  Once you’ve got used to it, you’ll find batch editing 
indispensable. 

The Edit > Batch > Edit command starts you editing the current record; but unlike 
the ordinary Edit Record command, it also starts recording all the editing actions that 
you take.  When you save the record, Cardbox will go to the next record and play 
back all the actions it’s recorded.  A special control pops up that lets you decide how 
the batch edit works: you can tell Cardbox to pause after each record, so that you 
can decide when you want it to stop editing; or you can tell Cardbox to go straight 
ahead and edit the whole of the current selection automatically without pausing. 

The editing actions can be as simple or as complicated as you like: you can index a 
word, or you can erase a field and replace its contents, or you can do some major 
reshuffling of data.  For some examples of what you can do with batch editing, and 
what you have to bear in mind when planning it, see “Batch Editing”, p.155. 

Edit > Batch > Edit 
Ctrl + B 
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Deleting records 

Deleting a single record 
To delete a single record, use the command Edit > Delete Record.  There are no 
toolbar buttons or keyboard shortcuts for this command because we don’t want to 
make it easy to delete records by accident. 

Most of the time, the deleted record will 
disappear completely, and if you’re 
viewing a list of records then the other 
records will move up to compensate.  
Occasionally it isn’t possible for Cardbox 
to do this and the record will remain on 
your screen but with the data replaced by 
shading: this is not an error, and the 
shaded record won’t appear in any 
printouts.  For one example of how this 
can happen, see Help Point 506. 

Deleting many records at once 
Start by selecting the records you want to delete.  Have a look through the selection 
to make quite sure that you have really selected the right records.  Go back to the 
first record and do Edit > Batch > Delete. 

• Cardbox will display a warning to remind you of how many records you are about 
to delete. 

• This command deletes all records from the current record to the end of the 
selection, so if you’re not on the first record when you use it, some records won’t 
be deleted. 

If you delete a record by mistake 
If you do Edit > Delete Record by mistake, do Edit > Undo Deletion at once and the 
record will come back.  Cardbox only remembers the most recent deletion, so if you 
delete two records by mistake, you’ll only be able to recover the most recently 
deleted one. 

Edit > Delete Record 

Edit > Batch > Delete 

Edit > Undo Deletion 
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• Edit > Undo Deletion doesn’t work at all if you have deleted a batch of records 
with Edit > Batch > Delete. 

• If you mistakenly delete more than one record, or if you only notice the deletion 
some time later, then all you can do is enter the record data all over again. 

Disaster recovery 

If you have made a lot of mistaken deletions, then you can still rescue yourself if 
you’ve been good at keeping regular backups and you have a backup copy of your 
database that contains the missing records.  In that case you open the backup and 
the current database simultaneously, find those records in the backup and copy 
them from there.  

For a detailed 
example, see Help 

Point 508.
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All about editing 
When you’re entering and editing text, Cardbox behaves just like any other Windows 
program: you see a flashing cursor (a vertical line) and anything you type goes 
where the cursor is.   

You can also select a block of text.  Selected text appears highlighted, and if you 
type something, it will replace the selected text. 

Indexing 
One thing that makes Cardbox different from other Windows programs is indexing: it 
lets you mark individual words in a field as needing to be indexed for fast retrieval.  
You set the indexing mode for each field when you design the database format.  
Two of the modes affect how you edit: “Manual” allows you to index individual words, 
and “Auto” indexes everything automatically but lets you remove the indexing from 
individual words.  You can turn indexing on and off like this: 

Keyboard: Make sure the cursor is on the word (this is always true while you’re 
typing the word; if you’re going back to alter the indexing on a previously typed 
word, simply move the cursor onto it).  Tap the Ctrl key.  (Don’t hold it down, just 
press it and release it quickly). 

• If Windows has been set up in “Accessibility” mode to allow someone with a 
disability to use it, you may find that tapping the Ctrl key doesn’t do anything 
(Windows stores the Ctrl keystroke and applies it to the next letter you type).  In 
that case, use Ctrl + I to turn indexing on and off. 

Mouse: Right-click on the word.  A menu will pop up: select “Indexed” from the 
menu. 

  

If you have selected a block of text, then the indexing or unindexing will apply to all 
words in the block. 

Words will look different when you index them, depending on the current 
appearance.  Red is often used to indicate indexing, but you can use any other 
colour (the example above uses blue).  When you design a format for use in printing, 
you’ll probably choose to make indexed words look identical to unindexed ones. 

Edit > Index On/Off 
Ctrl, or Ctrl + I 

See “Appearance”, p. 33.
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Moving the cursor between fields 
The easiest way to move onto a field is to click on it with the mouse.  Since you are 
mostly using the keyboard when you edit text, it may be more convenient to keep 
your fingers on the keys, so there are several keyboard commands you can use: 

Tab Move to the next field. 

Shift + Tab Move to the previous field. 

Ctrl + G To a specific field (a list of fields will pop up). 

F6 To and from the Extra Text field. 

 “Next field” and “previous field” don’t refer to the physical screen layout, but to the 
sequence of fields that you defined when you designed the format of the database: 
see “Sequence of fields”, p.205.  

Moving the cursor within a field 
Again, clicking with the mouse will always get you where you want to go, but there 
are many keyboard commands that you can use instead.  They are useful for 
precise positioning and essential when you are setting up a batch edit. 

Left or right arrow One character to the left or right. 

Ctrl + Left, Ctrl + Right One word to the left or right. 

Up or down arrow Up or down one line. 

Ctrl + Up, Ctrl + Down Back or forward one paragraph. 

Home To the beginning of the line. 

End To the end of the line. 

Ctrl + Home To the beginning of the whole field. 

Ctrl + End To the end of the whole field. 

Ctrl + F To specific text: see “Finding Text”, p.145. 
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Selecting text 
If you want to delete or replace a whole block of text, move it, copy it to the 
Clipboard, or even index or unindex it, you’ll need to select it first.  Cardbox handles 
selection in the same way as any other Windows program.  It’s a simple two-step 
process: 

1. Move to the start of the text you want to select. 

2. Hold down the Shift key and move to the end of the text you want to select. 

The same rule applies regardless of the way you choose to move the cursor.  You 
can hold down the Shift key and click with the mouse; or you can hold down the Shift 
key and use the arrow keys to extend or shorten the area of selected text.  

Keyboard shortcuts 

You can also select a whole field at once with Edit > Select All.  This is especially 
useful if you want to replace the entire contents of the field. 

Mouse shortcuts 

To select a range of text, move to one end of the range, depress the left mouse 
button, move to the other end of the range, and release the mouse button.  If you 
don’t get the ending point exactly right, you can adjust it by holding down the 
Shift key and clicking where you really want the end to be. 

To select a word, double-click on it. 

To select a line, hold down the Ctrl key and click anywhere in the line. 

Deselecting text 
To cancel a selection, click outside the selected area or press one of the arrow keys. 

Edit > Select All 
Ctrl + A 
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Typing and editing 

Lines and paragraphs 
When you are typing an address, press Enter (“the Return key”) at the end of each 
line, so that the next line starts at the left-hand edge of the field. 

When you are typing continuous text, the field behaves like a miniature word-
processed document, which means that if you type more text than will fit on one line, 
it will word-wrap onto the next.  When you want to end a paragraph and start a new 
line at the left-hand edge, press Enter. 

Insert mode and Overwrite mode 
By default, Cardbox works in Insert mode: this means that when you type a 
character, it is inserted at the cursor position and anything that was to the 
right of the cursor moves one place to the right to make room for it.  Because most 
Windows programs behave like this, you will probably find it the natural mode to use. 

If you press the Insert key, Cardbox switches into Overwrite mode.  In 
Overwrite mode, anything you type replaces what is already there instead of 
pushing it to the right.  To get back into Insert mode, just press the Insert key again. 

Deleting errors 

Backspace Deletes the character to the left of the cursor (usually this is the last 
character you typed). 

Ctrl + Backspace Deletes the whole word to the left of the cursor. 

Delete Deletes the character to the right of the cursor. 

Ctrl + Delete Deletes the word to the right of the cursor. 

Undoing changes 
Edit > Undo undoes the last change you made. 

Edit > Undo All undoes all changes in the current field and restores it to the state it 
was in when you started editing. 

File > Quit Without Saving undoes all changes in the whole record and cancels the 
edit. 

Edit > Undo 
Ctrl + Z 

Edit > Undo All 
Ctrl + Shift + Z 
File > Quit 
Ctrl + Q 

Lines and paragraphs are 
only relevant if your field is 
more than one line high in 

the format design.

You can see whether 
you’re in Insert or 

Overwrite mode by looking 
at the Cardbox status bar.
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Pasting and importing text 
Edit > Paste inserts text that you have previously copied to the Clipboard from 
Cardbox or another program.  The Paste command also appears in the menu that 
you get when you right-click on your field. 
• If you copied text to the Clipboard using Cardbox’s command Edit > Copy 

Record (Ctrl + Shift + C), then the Paste command will paste only the text that 
came from the same field as the field you’re currently in. 

To insert text from a text file, use Edit > Insert Object.  The text can be in plain text 
(.TXT) or Rich Text (.RTF) format. 

Pick lists 
If the mouse pointer has some small parallel lines in its top right-hand corner, then 
this means that there is a pick list defined for the current field.  A pick list lets you 
insert words by clicking the mouse and selecting them from a list instead of typing 
them.  To use a pick list, right-click in the field that contains the pick list, and select 
the item you want from the menu that pops up.  If the list is long and you can’t see 
the item you want, select “Pick…” from the bottom of the menu, and you’ll get a 
scrollable list of all available items.  If you want to cancel the whole operation, just 
click somewhere else on the screen. 

Keyboard: Pop up the pick list by pressing F4, then use the up and down arrow 
keys to select the item you want, and press Enter (Return) to insert it.  To cancel 
the operation without inserting a word, press Esc. 

Moving and copying text 
You can move text within a field, or into a different field or record, or even into a 
different Windows program. 

First, select the text that you want to move or copy: see “Selecting Text”, p.142. 

Using the Clipboard 
To copy the selected text to the Clipboard, use Edit > Copy, or right-click in the 
selected area and choose Copy from the menu that pops up. 

To copy the selected text to the Clipboard and delete it from its original position, use 
Edit > Cut, or right-click in the selected area and choose Cut from the pop-up menu. 

Now move to where you want the copied text to go, and use Edit > Paste.  See 
“Pasting and Importing Text”, p.144. 

Edit > Paste 
Ctrl + V 

Edit > Insert Object 

Pick lists are 
designed when you 

set up a format.  See 
“Pick Lists”, p.209.

Edit > Copy 
Ctrl + C 

Edit > Cut 
Ctrl + X 
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Using drag-and-drop 
Dragging and dropping is a more direct way of moving or copying text, but it 
demands precision with the mouse, and if you are trying to move text from one 
program to another, you may find that not all programs support drag-and-drop 
properly. 

To move a block of text from one place to another: 

1. Move the mouse into the selected block of text. 

2. Depress the left mouse button and hold it down. 

3. Move (drag) the mouse to where you want the text to go. 

4. Release the left mouse button. 

If the mouse pointer appears as a circle with a bar through it, the mouse is on 
something that won’t accept dragged and dropped text. 

To copy a block of text from one place to another – that is, to put text in the new 
position but leave the original text intact – do exactly what you would do when 
moving it, but hold down the Ctrl key throughout.  

Finding text 
To search for a piece of text, use the command Edit > Find: 

 
The Find command finds the text that you specify, or tells you that it can’t be found.  
It can look in the current field or in all fields.  It selects (highlights) the text that it 
finds, so that you can replace it simply by typing, if that is what you want to do.  If 
you don’t want to replace the text, deselect it by clicking somewhere else or pressing 
the left or right arrow key.  

To search for another occurrence of the text, press F3. When the search gets to the 
end of the field (or of the record) it’ll start again from the beginning: the field name 
on the status bar will flash to tell you that this has happened. 

Edit > Find 
Ctrl + F 

Edit > Find Next 
F3 

This command has 
many options and 
features.  For full 

details of what they all 
do, press F1 when the 

command is open.
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Finding and replacing text 
To search for and replace a piece of text, use the command Edit > Replace: 

 
To replace all occurrences of a word or fragment of text, fill in “Find What” and 
“Replace With” and then press Replace All. 

To look at each occurrence and decide if you want to replace it, press Find instead 
of Replace All.  Cardbox will then show you what it has found and let you decide 
whether to ignore this occurrence (Skip) or replace it (Replace). 

Edit > Replace 
Ctrl + H 

This command has 
many options and 
features.  For full 

details of what they all 
do, press F1 when the 

command is open.
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Spelling checker 
Cardbox has a built-in spelling checker.  You can ask it to check the spelling of a 
particular field, or you can activate it so that it watches what you type and highlights 
possible spelling mistakes as they happen. 

• You can control what dictionaries Cardbox should use for checking your spelling, 
and where it should store your own private “user dictionary”.  See “Spelling and 
Spelling Dictionaries” (p.149). 

Automatic spelling check 
When you design your format, you can make Cardbox check the spelling of certain 
fields automatically: see “Automatic Spelling Check”, p.204.  Even if you haven’t 
done this, you can turn on the automatic spelling check with Tools > Highlight 
Dubious Spellings (you can use the same command to turn off the 
automatic spelling check if you find it distracting).  The Cardbox 
status bar will show you whether the automatic spelling check it 
turned on: look for a a vertical red zigzag next to the field name.  

When the automatic spelling check is on, Cardbox will put a 
red zigzag under any words that seem doubtful: you can 
see an example on the left.  You can then correct the 
spelling yourself, or you can right-click to pop up a menu 
(shown on the right).  This will try to offer you replacement 
spellings and it will also let you ignore the word on this 
occasion, ignore the word for the rest of the Cardbox 
session, or add the word to your private spelling dictionary 
so that it will always be considered as correct.  Sometimes 
the menu has good suggestions, sometimes not: it depends 
on the word and on the misspelling. 

Manual spelling check 
You can also make Cardbox check spelling on request, with the command Tools > 
Check Spelling.  If you have selected some text, Cardbox checks the selected text.  
If you haven’t selected any text, Cardbox checks from the cursor to the end of the 
field (unless you’re already at the end of the field, in which case it checks the whole 
field). 

Tools > Highlight  
Dubious Spellings

Shift + F7 

Tools > Check Spelling 
F7 
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If there are no spelling mistakes, Cardbox displays a tick to tell you that the 
spelling check has finished.  The tick fades away after a couple of seconds, 
but you don’t have to wait for it to disappear: if you move the mouse or 
press a key, the tick will vanish at once. 

If there are some possible spelling mistakes, Cardbox will report them: 

  
At the top, you can see the word in question, with some of the text on either side of it 
to give you an idea of the context.  Lower down, you will see a list of suggested 
replacements.  How good the suggestions are depends very much on the word and 
how it was misspelt. 

To ignore this word 
If you know that the word is correct, you can press Skip to look for the next spelling 
error. 

If you press Ignore All, Cardbox will store the word in its “Ignore All” list.  This means 
that the word will never be flagged as a dubious spelling again until you close 
Cardbox and re-start it. 
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To add this word to the user dictionary 
If you press Add to Dictionary, Cardbox will add the word to your user dictionary so 
that it will always be considered correct in the future.  If you make a mistake and add 
a word to the dictionary that turns out not to be correct, you can always use the 
command Tools, Edit Spelling Dictionary to remove the word from the dictionary. 

To correct this word 
If you can see the correct spelling in the list of suggestions, simply double-click on it; 
or click once and then press Change. 

If you press Change All instead of Change, Cardbox will change all occurrences of 
the current misspelling, not just the one that it was currently showing you. 

If you can’t see the correct spelling in the list, type it into the “Change To” box and 
then press Change or Change All. 

Spelling and spelling dictionaries 
We haven’t written Cardbox’s spelling checker ourselves.  Instead, we are using the 
Sentry Spelling Checker from Wintertree Software, which has a good reputation and 
is used by many other software products.  Many language dictionaries are available 
for this spelling checker.  At the time this manual was written, only the English 
dictionary was supplied with Cardbox. 

Main dictionary 
Use Tools > Options » Spelling to tell Cardbox which main language dictionary to 
use.  If you want to override this choice for a particular database, edit the native 
format and do Edit > Format Properties » Spelling. 

Quality of dictionaries 

Nothing in computing is perfect, and this applies particularly to spelling dictionaries.  
If you find words are being accepted that should not be accepted (in English, this 
applies especially to words that are spelt differently on different sides of the Atlantic), 
please let us know so that we can correct the dictionary in later releases of Cardbox. 

For the latest 
information about 

dictionary availability, 
see Help Point 507.
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User dictionary 
When the spelling checker comes across a word it doesn’t recognise, you may 
decide that this is a valid word and press Add To Dictionary to add it to your own 
user dictionary: this will make Cardbox treat the word as being correctly spelt from 
now on. 

You can control the location of the user dictionary.  It can be associated with a 
specific database or a group of databases, or it can be stored on your computer and 
applied to every database you use.   

Editing the user dictionary 
To make changes to the spelling dictionary, use Tools > Edit Spelling Dictionary. 

 
You’ll see a list of the words that are in the dictionary, and also a list of the words for 
which you chose Ignore All during a spelling check., because you may want to copy 
some of these into the dictionary. 

To copy a word from Ignore All to the dictionary – click on it and then press 
Store; or just double-click. 

To add a new word to the dictionary – type it in the User Dictionary box and then 
press Add. 

To edit a word in the dictionary – click on it and press Edit; or double-click.  The 
word will appear in the User Dictionary box and you can then edit it. When you 
have finished editing, press Save. 

Help Point 558 tells 
you how to specify the 

location of the user 
dictionary.
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To remove a word from the dictionary – click on it and press Delete.  If you have 
several words to remove, you can make things quicker by highlighting them all 
and then pressing Delete. 

Capitalisation 
If a word in the user dictionary is in lower-case, like “toggo”, then Cardbox will treat 
any capitalisation as being correct (so it will accept “Toggo” as well).   

If a word in the user dictionary starts with a capital letter, like “Sion”, then Cardbox 
will only accept that word with a capital letter (so it will report “sion” as a wrong 
spelling). 
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Using validators 
Validators watch over the data you enter.  They are set up as part of the design of 
the database format.  Validators can: 
• Check what you have entered. 
• Make changes to what you enter. 
• Enter text automatically. 

The Advanced Features manual which comes with the Professional Edition of 
Cardbox gives full details of the available kinds of validators and how to set them up.  
Here we concentrate on telling you how validators affect the way you edit records. 

Validators that check the text you enter 
Most validators exist to check the validity of what you put into a field.  Typically, they 
do nothing until you have moved out of a field and then they check it, but you can 
ask for a validation to happen at any time by doing Edit > Show Errors.  When you 
save a record, Cardbox validates all changed fields for you. 

You can validate all fields, whether or not they have been changed, by using Edit > 
Validate All. 

The error warning 
If Cardbox has found something wrong in the field you’ve just left, the validation 
toolbar button changes colour and flashes.  You can ignore this and carry on typing, 
or you can press the button to ask Cardbox to display the validation error box. 

When you come to save, Cardbox will check your record and it will display the 
validation error box if it has found anything wrong.  

Only the Professional 
Edition of Cardbox is able 

to set up validators: see 
page 206.

Once they’ve been set up, 
any edition can use them.

Edit > Show Errors 
F2 

Edit > Validate All 
Shift + F2 
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The validation error box 
The validation error box is where Cardbox lists all your validators and any errors 
they have found.  At the top you will see a list of the validators, with a symbol next to 
each one to tell you its status.  In the picture, the validator for field CO has reported 
an error and the validator for field OS hasn’t. 

 This validator has no errors to report.. 

 This validator is reporting an error: you are not allowed to override it. 

 This validator is reporting an error: you are allowed to override it. 

 This validator reported an error but you have overridden it. 

 This validator has not been used because you have not made any changes to 
the field.  If you want to check all fields, press Check All. 

To see why a validator is complaining, click on its entry in the list.  You’ll see a 
description of what the validator is looking for, and below that, under “Terms”, you 
will see the term the validator is complaining about.  The arrows on either side of 
“Terms” let you go back and forward through the field. 

Overriding an error 
Some validators can be overridden.  A good example is a validator that has a list of 
valid words and checks your field against its list.  It may warn you that a word you 
have entered is not in the list but you may know that that particular word is actually 
correct and isn’t really a misprint at all: in that case, just turn on the Override check 
box underneath the validator description.   

You decide which validators can be overridden and which ones can’t when you 
design the format for your database.  If the validator was designed not to be over-
ridden, the Override check box will be disabled. 

When you are saving a record, the error box will have one more button, marked 
“Save Record”.  You can use this to make Cardbox save the record at once: it’s 
effectively the same as saying Override for every validator. 
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Correcting an error 
If you can easily see what was wrong with the term your validator is complaining 
about, you can edit it directly in the Terms box.  If you want to index or unindex the 
term, use the Index checkbox just beneath it. 

If you prefer to edit your record directly, press Go To Record or Close, and you’ll be 
taken to the place in the record where the error has been detected.  The difference 
between the two buttons is that Go To Record leaves the error box visible on the 
screen and Close closes it. 

Validators that change the text you have entered 
Validators can be set up to unindex certain words (“stoplists”) or to index them 
(keyword lists).  Either way, the process is completely automatic and you don’t need 
to do anything about it: it happens when you move out of a field you’ve been editing 
or when you save a record. 

Validators can also be set up to put dates into a standard format.  There are many 
variants of this, but to take one example, you might find that when you type “4/5/6” a 
validator will turn it into “04/05/2006”.  Just like the indexing validators, these 
validators only work when you move out of an edited field. 

Validators that enter text automatically 
These validators fill in fields for you.  Depending on how they have been set up, they 
may automatically fill in a field or they may wait for you to move into the field and out 
of it again before they do anything.  They may replace any text that you have 
entered, or they may confine themselves to filling in fields that you have left blank.  
The text that these validators “type” into your fields can be fixed text or it can include 
things like your identity (your user name or your initials) or the date and time. 

You don’t need to do anything about validators of this kind – just don’t be surprised if 
something about your record changes automatically. 
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Batch editing 
Batch editing is ordinary editing, done automatically.  Cardbox watches you edit a 
record, and then repeats exactly what you did, step by step, on subsequent records.  
This is a powerful feature, and as far as we know it’s unique to Cardbox: so when 
you find yourself with several records to edit, take a moment to think whether batch 
editing will make your task faster.  

Setting up a batch edit 
First, select the records that you want to edit and make sure you’re on the first of 
them.  Then use the command Edit > Batch > Edit to start the batch edit. 

Now you can edit the first record.  There are a couple of things to remember while 
you are doing this. 

• When it gets to the later records in your selection, Cardbox will repeat all your 
keystrokes exactly, and all your commands. 

• You can’t use the mouse, except to move to the start of a field (or to select a 
command from the menu or the toolbar). 

Check boxes and radio buttons 
If you have fields that are displayed as check boxes, radio buttons, or drop-down 
lists, then you can use the mouse on them even when you’re setting up a batch edit. 

Moving the cursor within a field 
When you aren’t batch editing, you can use any method you like to move within a 
field.  When you’re setting up a batch edit, you have to use the keyboard.  In 
addition, you also have to give some thought to strategy so that whatever you do 
with the first record will do the right thing in the other records too. 

Edit > Batch > Edit 
Ctrl + B 
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Here’s an example.  The record on the left is the one that you can see when you are 
setting up the batch edit; the record on the right is one that appears later on in the 
selection. 

 
Suppose that you want to add the note "Approved by RPB 14/4/92." to the end of the 
existing text: that is, you want the records to end up looking like this: 

 
Here is the right way to do this: 

1. Move the cursor into the field. 

2. Use Ctrl + End to move the cursor to the end of the field. 

3. Type a space, followed by the note. 

If you’re not very familiar with the keystrokes for moving the cursor, you might be 
tempted to use the arrow keys because they’re easy to remember.  Suppose that 
you pressed the Down arrow 3 times and the Right arrow 9 times.  In the first record, 
that would get you exactly where you wanted to be, but look at the second record: 
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You told Cardbox to move down 3 lines and across by 9 characters, and this was 
exactly what it did.  The first field didn’t have much text, so your cursor movements 
got you to the end; but in the longer field, the same movements didn’t take you far 
enough.  In this case the solution is to use Ctrl + End to move to the end of the field. 

Try to imagine, as you edit the first record, what effect your keystrokes would have 
on a record that looks different from it.  If you’re in any doubt, get Cardbox to do the 
first few records one at a time, so that you can see if the result looks reasonable. 

Replacing field contents 
Here’s another pitfall.  You have selected records for a mailing, and you have done 
the mailing, and now you want to fill a “Date mailed” field with the date.  You start 
the batch edit, you see that “Date mailed” is empty, so you just type 29/2/2004.  You 
let the batch edit go ahead, but because some of the later records in the selection 
already had a date in them, they end up with things like 29/2/20047/1/2004 in the 
“Date mailed” field.   

The moral of the story is that you should never assume that a field will always be 
empty.  In this case it is easy enough to arm yourself against non-blank fields: just 
press Ctrl + A before typing the new text: this will select the entire contents of the 
field (if there are any), and so the text you type will replace the selected text and you 
won’t get these strange-looking hybrid dates. 

Indexing 
When you’re editing a record, the command you usually use for indexing is Ctrl (or 
Ctrl + I), and this toggles the state of indexing: if a word wasn’t indexed, it is indexed; 
if it was indexed, it is unindexed.  If that is what you want, fine; but it’s not a very 
common thing to need: usually what you really want to do is to ensure that 
something definitely is indexed.  The problem with using Ctrl in a batch edit is that if 
a word is already indexed in one of the later records that you can’t see, Ctrl will have 
the unfortunate effect of unindexing the indexed word: not what you want at all! 

This is why the Edit menu contains the command Edit > Index On.  This command is 
superfluous when you’re editing by hand, but when you’re setting up a batch edit it’s 
a lifesaver.  If a word isn’t indexed, the command will index it; if a word is already 
indexed, the command will do nothing. 

And if you want to make sure that something’s definitely unindexed?  That’s easy 
too: use Edit > Index On to make sure that it’s indexed, and then Ctrl to unindex it. 

You can find a list of 
cursor movement  

keys on page 141.

Edit > Index On 
Ctrl + Shift + I 
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Performing the batch edit 
When you’ve edited your first record, use File > Save or Ctrl + S to save it. 

 

Press Batch (or type B) to edit the whole of the rest of the selection using the same 
keystrokes that Cardbox has just recorded.  Display (or D) does the same thing 
except that it displays each record after it has been edited. 

If you’re feeling cautious, you can go more slowly.  Press Next (or type N).  Cardbox 
will edit the record and present you with another message: 

 

Have a look at the edited record.  If you like what you see, press Save (or type S) 
and Cardbox will save the record and offer you the choice of “Next / Batch / Display / 
Quit” again.  You can alternate Save and Next until you’re sure that the editing is 
working the way you want it, and then press Batch to let Cardbox edit the rest of the 
selection fast. 

If you realise that some more editing needs to be done, press Edit (or type E): any 
editing you do now will be added to the keystrokes that Cardbox has already 
memorised. 

If you want to leave this record untouched and go on to the next one, press Skip (or 
type K).  Cardbox will abandon the changes it has made to this record and move 
forward to edit the next record in the selection. 
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If you want to abandon the batch edit altogether, press Quit (or type Q).  Cardbox 
will abandon the changes it has made to this record and stop the batch edit. 

Batch editing a handful of records 
The official use of batch editing is to edit the whole of a selection, or the whole of it 
starting from a certain point.  Officially, if you want to edit a few records in the middle 
of a selection, you should select them and then batch edit the whole of that smaller 
selection. 

For small selections, there is a good and lazy alternative using step-by-step batch 
editing.  Suppose you want to edit four consecutive records in an identical way.  
Move onto the first one and set up the batch edit. Save the record, then type N for 
Next, S for Save, N, S, N, S (you’ll now have edited four records and Cardbox will be 
asking you if you want to move on to the fifth), and then Q for Quit to terminate the 
batch edit.  Once you get the hang of it, this is simple and very fast, and the only 
danger is that your fingers could run away with themselves and repeat the “N, S” 
sequence too many times. 
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Adding images 
When you’re adding a new record that has an image field, or editing an existing one, 
you can add new images to it.  There are three steps involved: 

1. Get the image into Cardbox. 

2. Tell Cardbox how to preprocess it – for instance, by rotating or resizing it.  This 
step is optional. 

3. Tell Cardbox whether the image is a picture or a document and how you want it 
to be compressed.  This step is often automatic. 

Getting the image into Cardbox 
To start with, you have to be editing a record:  – either an existing record or a newly 
created one. 

Importing from an existing image file 
• You may have some image files that have been saved by other programs or sent 

to you as attachments.    
• Many fax-to-email gateways send you your faxes as files attached to an email.   
• Some photographic processors give you your pictures as files on a CDROM as 

well as giving you prints.   
• Some digital cameras store pictures in removable memory that you can then 

plug into your computer, and when you plug the memory card or stick into your 
computer, it appears to Windows as a folder, with each photograph being a 
separate file. 

While editing a record, you can read an image from a file by selecting the image 
field and using Edit > Insert Object, or by right-clicking on it and selecting “Load 
From File” from the pop-up menu. 

While you are in the image window, you can read an image from a file by clicking 
on the toolbar button, or pressing Ctrl + R, or right-clicking anywhere in the 
image window and selecting “Load From File” from the pop-up menu. 

You’ll see a conventional Windows “Open File” box.  Navigate to the file you want, 
and either double-click on it or select it and then press the Open button.  Cardbox 
can read files in JPEG, GIF, TIFF, BMP, and Kodak PhotoCD formats. 

To store images you need 
to create an image field: 

see “Format Design”, 
page 189.
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Pasting an image from the Clipboard 
While editing a record, you can paste an image from the Clipboard by selecting the 

image field and using Edit > Paste, or by right-clicking on it and selecting “Paste” 
from the pop-up menu. 

While you are in the image window, you can paste an image from the Clipboard 
by clicking on the toolbar button, or pressing Ctrl + V, or right-clicking anywhere 
in the image window and selecting “Paste” from the pop-up menu. 

The Paste command is enabled only when there is an image in the Clipboard. 

Using a scanner 
Cardbox can receive images from any scanner that uses the industry-standard 
TWAIN interface. 

While editing a record, you can scan an image by right-clicking on the image field 
and selecting “Scan” from the pop-up menu. 

While you are in the image window, you can scan an image by clicking on the 
toolbar button, or pressing Ctrl + N, or right-clicking anywhere in the image 
window and selecting “Scan” from the pop-up menu. 

 

Source If you have more than one TWAIN device (for example, a scanner and 
a camera), then choose which one you want to use. 

Scan As This option helps Cardbox to negotiate the correct scanning mode and 
resolution with the scanner. 

Picture is a continuous-tone image such as a photograph. 

Document is a printed or handwritten document, or a line drawing. 

Compressed Document tells Cardbox that this document will be 
stored in Compressed format (see p.140).  If Cardbox knows this at the 
time that the document is scanned, it can choose the most appropriate 
settings.  

Monochrome Set this option if you want the scanner to ignore any colour when 
scanning the image. 
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Using a scanner: Quick Scan 
If you press the Quick Scan button, the scanner will start at once.  It will scan one 
page, and then you will be returned to the Scan Image window.  You can then 
change the paper and press Quick Scan again, or you can press Close to return to 
Cardbox. 

With Quick Scan, Cardbox sets scanning resolutions of 200dpi for documents and 
150dpi for images.  These settings are sufficient for normal purposes.  If you want to 
use a different resolution, use Scan instead of Quick Scan; or you can change 
Cardbox’s built-in Quick Scan settings by holding down the Shift key as you press 
the Quick Scan button. 

Using a scanner: Scan 
The Scan button gives you access to the full facilities of your scanner.  When you 
press it, the scanner’s own dialog box pops up.  Typically this will let you set a wide 
range of options, such as the following: 

• Size and location of the scan area. 
• Resolution. 
• Sharpness. 
• Colour adjustment. 
• Automatic sheet feeding. 

We can’t show you what the scanner’s dialog box will look like because it varies from 
one model of scanner to the next, and we can’t even tell you what features it will 
include.  You will have to read the scanner’s documentation, or just try it and see. 

If you use the Scan button, then scanners with automatic document feed will scan a 
whole batch of documents before returning you to Cardbox (but this, too, depends 
on exactly how the scanner’s manufacturers have written their TWAIN software). 

Using a camera 
If your camera has removable storage in the form of a card or other device, you may 
be able to take the storage unit out of your camera and plug it into your computer.  
In this case, it will appear to Windows as a folder containing files, and you can 
import images from those files just as if they were on your hard disk. 

The commonest alternative is that you can connect your camera to your computer 
through a USB or FireWire connection, and that you’ll have a TWAIN interface for 
the camera.  In that case, follow the instructions for using a scanner.  Quick Scan 



      Adding images  163 

 

will often take a photograph there and then, while Scan is likelier to allow the 
importing of photographs that the camera has already taken.  There are some 
exceptions, though.  One very early Kodak camera responds to TWAIN and shows 
you the pictures the camera has taken but it doesn’t allow you to send them to your 
program through TWAIN: instead, you have to save them to your computer’s hard 
disk and then import them from there.  We suspect that Kodak, and camera 
manufacturers generally, have learnt more about user interfaces since then. 

Preprocessing the image 
Preprocessing is entirely optional and most of the time you won’t need it.  To 
preprocess an image, first get it into Cardbox, then right-click on it in the image 
window and select “Preprocess” from the pop-up menu. 

Rotate 
Most scanners assume that everything they scan is in portrait format – that is, taller 
than it is wide – so that if you scan a document that’s in landscape format, it’ll 
appear sideways on the screen.  The same sort of thing can happen with cameras, 
but the other way round: they naturally take photographs in landscape format, so if 
you turn your camera sideways to do portrait format, the picture will appear 
sideways when it gets into your computer. 

Sideways images are tiring to look at, so Cardbox lets you rotate an image after it 
has received it but before storing it in your database.  That way you can make sure 
that everything is upright when it’s stored. 

If you use the same rotation setting often, you can tell Cardbox to save it as a 
default: that setting will then be applied to all images of the same type unless you 
override it.  To save the rotation setting, select “Save These Settings” from the 
Preprocess popup menu. 

Compressing and storing the image 
To keep your database a reasonable size, Cardbox has to compress the images it 
contains.  Cardbox uses different strategies when storing pictures and documents.   

Pictures are continuous-tone images.  For these, the most appropriate compression 
method is JPEG. 

Documents are images with lines, or with large areas of solid colour.  Cardbox uses 
its own compression method, which yields very good quality.   

Two of the menu options, 
Override Resolution and 

Override Size, are very 
specialised: see Help 

Point 554.
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In many cases, Cardbox can decide automatically whether a particular image is a 
picture or a document.  For example, a JPEG file is always a picture and a GIF file 
can always be compressed as a document.  You can also tell Cardbox the image 
type by right-clicking on the image window and selecting Picture or Document from 
the pop-up menu.  You don’t have to do this very often, because Cardbox 
remembers the last Picture or Document setting separately for each file type and for 
each source of scanned images. 

Checking your options 
The image window shows the effect of the options you have set: this is because it 
shows the image after processing, not before.  At the right-hand edge of the status 
bar you’ll see the storage size needed by the current image.  So it’s easy to 
experiment with different settings and see how they affect quality and storage 
requirements. 

If you say Picture for a document or Document for a photograph, it’s not the end of 
the world.  The image quality may be less good, or the image may take more 
storage, but that is all: and you can check these things by looking at the image 
window.  Altogether, disasters are unlikely! 

The Store Compressed option 
In the pop-up menu that you get when you right-click on the image window, you’ll 
see an option saying “Store Compressed”.  For pictures, this simply reduces the 
storage requirement by reducing the quality of the JPEG compression. 

For documents, Store Compressed is more radical.  The image quality will be 
reduced, but for normal typescript the result will still be readable and the storage can 
be really tiny (we’ve found around 26KB for a sheet of typed A4).  Store 
Compressed for documents isn’t a setting to use if you want the result to look 
beautiful, but for archival purposes it can be entirely adequate.   

Do try out Store Compressed before you decide on a policy of using it.  Look out for 
very thin lines, which can sometimes disappear.  Store Compressed works 
differently for colour and monochrome scanned documents, so if you find it too 
radical when you try it on monochrome documents, try a colour scan instead, in case 
that looks better.  
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Monochrome Document scans, actual size.  

Above left, with Store Compressed; above right, without Store Compressed.  In this case, the 
whole A4 document (of which only a part can be seen here) took 50KB with Store Compressed 

and 100KB without it.  Below right, an enlarged detail showing the difference in quality.  

Note: you can always get higher quality scans if you need them, just by increasing the resolution in dots per inch. 
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Rearranging and deleting images 

Rearranging images 
If you’ve got several images attached to a record, you can rearrange the order they 
come in if you open the Thumbnail view (see “Thumbnails”, p.72).  Click on the 
thumbnail that you want to move, and drag it to where you want it to go.  A small 
arrow will show you where the image is going to end up: when the arrow is in the 
right place, release the mouse button. 

Deleting images 
While editing a record, you can delete an image by right-clicking on the image field 

and selecting “Delete” from the pop-up menu. 

While you are in the image window, you can delete an image by clicking on the 
toolbar button, or pressing the Delete key, or right-clicking anywhere in the 
image window and selecting “Delete” from the pop-up menu. 

When you’ve deleted an image, it appears as a big red cross until you save the 
record.  You can undelete an image before you save the record, by repeating 
exactly the same instructions as for deletion.  Once you’ve saved a record, any 
images that you deleted in it are lost forever. 

Editing images 
Cardbox doesn’t allow you to edit images directly.  To edit an image, you have to 
export it to a file, edit the file using an image editing program such as Microsoft Paint 
or Adobe Photoshop, and then import the edited file; or you could achieve the same 
sort of transfer by copying and pasting via the Clipboard. 

For more guidance, see 
Help Point 514.
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Deduplication 
If you are running something like a mailing list it is easy to end up with duplicate 
records, especially if several people are contributing to the list or parts of it have 
come from different sources.  This irritates the recipient (you have probably been on 
the receiving end of this yourself) and it wastes resources whenever you do a 
mailing. 

Tools > Deduplicate allows you to identify real or potential duplicates so that you can 
then go through those records, inspect them, and remove any that you do not want. 

What the Deduplicate command does 
Cardbox goes through your current selection of records and tries to see if any 
records appear similar.  For each group of similar records that it finds, Cardbox tags 
every record in the group with a red tag, and it tags all records except the first with a 
black tag as well.  This gives you a choice: you can use red tags to select all groups 
of similar records, or you can use black tags to select all potential duplicates and 
delete  them. 

Cardbox cannot compare every record to every other, because that would take too 
long (on a 45,000-record database, it would mean over a thousand million 
comparisons).  Instead, it looks at records that are close to one another in the 
current sequence.  For this reason, you would normally sort records into sequence 
before you try to deduplicate them. 

How to deduplicate a database 
1. Decide what fields you will use to define whether two records are duplicates of 

each other.  For example, in a contacts database, you might decide to use the 
person's name but not the date of last contact.  

2. Use View > Sequence to sort the database into order using those fields.  The 
aim of this exercise is to make a sequence in which similar records are close 
together.  If you are sorting on just one field, you will probably get better results if 
you create a custom sequence using just that field, rather than using a simple 
single-field sort: this is because the custom sequence will look at every indexed 
word in the field rather than just the first one.  

3. Use Tools > Deduplicate and tell Cardbox which fields to look at. 

4. Cardbox will select the records that appear to be duplicates of each other. 

Only the Professional 
Edition of Cardbox can do 

deduplication.

For more about black and 
red tags, see “Tags and 

Tagging”, p.93.
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5. If you are confident that all the duplicates really are duplicates, just use Tag > 
Select to select the black-tagged records, followed by Edit > Batch > Delete to 
delete them. 

6. If you are not quite sure if everything that Cardbox has found really is a duplicate 
(for example, if you have been comparing records by name, and two different 
people might genuinely have the same name), then browse through the records 
and tag or untag them as appropriate before selecting and deleting the tagged 
records. 

Specifying the deduplication 

 
On the right is a list of the fields that Cardbox will use when comparing records.  To 
add a field to the list, select it in Available Fields and press Add; or just double-click 
on it.  The order in which the fields appear in the list doesn’t matter. 

You can set options that control how Cardbox compares two records according to a 
particular field.  To do this, click on the field in Fields To Compare.  The Fuzziness 
option says how closely two records have to resemble each other before they are 
considered identical: 0 means there must be an exact match on this field, while (for 
example) 2 means that there can be two characters’ difference between the text in 
this field and the records will still be considered identical. 

For more about fuzziness, 
see “Fuzzy Matching”, 

p.87.
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The Number of Adjacent Records setting controls how many neighbouring records 
Cardbox will look at when checking for duplicates.  A higher number will make the 
deduplication slower but will be better at finding duplicate records even if they are far 
apart in the sorted sequence. 





 

 

Part Five 
Creation 

How to create a new database; what formats contain; 

how to create and edit formats. 

 



 

 

 

Ecclesall Parish Church uses Cardbox extensively.  This database follows 
parishioners through birth, marriage and death, it notes who needs help and who can 

offer support.  This is its native format. Colour coding indicates the fields that only 
certain people are allowed to modify.  Extensive use is made of macros to make 

operations easier.  Scrolling allows you to move to different parts of the format, and 
alternative formats exist to give more restricted, compact views, as well as for a very 
wide range of standard letters.  Using macros, the database has also been adapted to 

store and calculate financial information relating to giving, recoverable tax, etc. 
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How to create a database 
Now that you know how to use a Cardbox database, the only remaining thing is to 
explain how to create one. 

To create a database, you have to do three things: 

Create an empty database file – you have to decide what it should be called and 
where it should be stored. 

Define the native format – this will tell Cardbox what fields exist and how to lay 
them out on the screen.  Format definition is covered in detail starting on page 
177. 

Enter the data – type records in by hand, or read them in bulk from a file or from 
another database. 

Sometimes you may want to create a database that is identical in layout to one you 
already have.  In that case, you can copy the native format, or copy all formats, 
without having to design them all over again by hand: see page 175. 

Creating an empty database file 
You can create a database on your own computer, or in a shared location (on your 
LAN or on the Internet) by using a Cardbox server. 

To create a database on your own computer, you need the Home or Professional 
Edition of Cardbox: the Client Edition can’t create databases on your computer. 

To create a database on a Cardbox server, any edition of Cardbox will work, but you 
need the permission of the server’s administrator, who may also assign the name of 
the database for you. 
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Creating a database on your own computer 
Use File > New Database and select the My Computer tab.  This looks just like any 
other Save File box in Windows. 

 

• You start by seeing the folder you used last time you opened a database. 

• At the top right-hand corner you’ll see a Recent Folders button.  This lets you 
jump directly to folders you have opened databases in recently. 

• The list of files that you see is a list of files that already exist, so you should 
choose a filename that does not already appear on the list. 

Choose a filename that will remind you what the database is, and take care to 
choose an appropriate folder to put it in.  How you organize your folders is up to you, 
but there is nothing more irritating than creating a file and then forgetting where you 
have put it. 
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The files used by a Cardbox database 
Each Cardbox database lives in two files. 

The format file (filetype .FMT) contains the definitions of all the formats that you 
have created for this database. 

The database file (filetype .FIL) contains all the actual data. 

If you need to copy a database from one location to another, copy both files.  If you 
need to back it up, back up both files.  If you need to rename it, rename both files.  If 
you need to delete it, delete both files. 

Creating a database that looks like another database 
Sometimes you may want to create a database that has all the same formats as a 
database you already have, either because you really want it to have an identical 
structure or because it’s easier to modify the existing formats than to design 
everything from scratch.  To do this: 

1. Make a copy of the format file.  You probably already know how to copy files 
using Windows Explorer, but in case it isn’t something you do very often, we find 
that the easiest way is to select the file, press Ctrl + C to copy it to the Clipboard, 
then move to the destination folder and press Ctrl + V to paste the file.  The 
destination folder can be the same as the original folder: in that case, Windows 
will give the copy a new name: for instance, MyDatabase.FMT could become 
Copy Of MyDatabase.FMT. 

2. Rename the copy if necessary, so that its name will remind you which database 
this is.  Renaming files can be done with Windows Explorer in several different 
ways.  One of the most reliable is to right-click on the file and select Rename 
from the pop-up menu. 

3. In Cardbox, use File > New Database » My Computer, locate the new copy you 
have just made, and double-click on it (or select it and press the Save button).  
Cardbox will see that the format file already exists and will create a 
corresponding database file. 

Creating databases on a network 
You aren’t confined to files on your own computer: if you’ve got access to shared 
drives on your network, you can use the My Computer tab to create files on those 
drives as well.  But remember that when you open a database using the My 
Computer tab you get exclusive access to it and no-one else can open the database 
as long as you have it open.  To create a database so that several people can use it 
at the same time, you have to use the Server tab. 

Before copying a 
format file, make sure 

the database isn’t 
currently open in 

Cardbox.



    176  

 

Creating a database on a Cardbox server 
A database that resides on a Cardbox server can be opened by many people at the 
same time. 

To create a database on a Cardbox server, you need to have the permission of the 
administrator of that server, and in most cases the administrator will need to choose 
the name of the database for you.  Use the command File > New Database » 
Server, pick the server you want to use, and either pick the appropriate filename 
from the list on the right or type the filename you have been told to type. 

For more details about the process of connecting to a server and picking a file, see 
“Open command: Server tab” on page 57. 

The Networking and 
Security manual 

describes how to set 
up new databases on 

a Cardbox server.
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About formats 
A format is what gives a Cardbox record its structure.  When you see a record on the 
screen, the record data determine the content of what you see but the format 
determines its shape.  Data without a format are like a body without bones: 
shapeless and not much use. 

The simplest possible database would have just one format that you used equally for 
data entry, searching, and record display.  Sometimes this is all you need.  For 
example, our password database (where we store all the user names and 
passwords to get us into various web sites) is only ever going to be used in one way, 
so it only really needs one format.  Most databases need more formats than this: a 
spacious one for data entry, with plenty of prompts to give guidance to whoever is 
putting the data in; a more austere one for searches; a one-line format for 
summaries; and formats for creating mailing labels and mail-merged letters.  There 
is no practical limit to how many formats you can have in a database. 

The native format 
The first format you create for a database is called the native format.  It works like 
any other format, but in addition it defines the structure of the database as a whole: 
to create a field in the database, you create it in the native format. 

The things a format can contain 
When you start designing a new format you are faced with a big blank screen.  The 
things you can place on this screen are: 

• Fields. 
• Merge blocks. 
• Fixed text. 
• Lines and boxes. 
• Graphics. 
• Pushbuttons. 
• Headings and footings. 
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Fields (p.189)  
A field holds data.  It is the fundamental unit of a Cardbox database. 

A field can be as big or as small as you like: just one character, or many lines long.  
The size of a field on the screen does not limit the amount of text that the field can 
contain, but for most purposes it is better to have some reasonable relationship 
between the two, because scrolling within a field can be awkward. 

To find out what fields exist in a database, Cardbox looks in the native format, so 
although a field doesn’t need to occur in every single format in the database (some 
formats may not even have any fields at all) every field must always occur in the 
native format. 
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Merge blocks (p.195)  
A merge block contains text mixed with field references.  When Cardbox comes to 
display or print a merge block, it fills in the field references with the actual contents 
of the field and word-wraps the result as if it were a single piece of continuous text.  
You can put the whole of a standard letter into a single merge block; at the other 
extreme, you can have a merge block that contains nothing but field references, to 
join fields together to make a suitable address for a mailing label.  Even a merge 
block containing a single field has its uses, because merge blocks can grow and 
shrink according to the text they contain while fields have a fixed size and position 
on the screen. 

As well as field references, a merge block can contain several other kinds of data, 
including the page number, the record number within the current selection, and the 
date. 

 

 

 

E. Childers, War and the Arme Blanche, (Edward Arnold, London, 1910). 

Merge blocks can 
also control the 

appearance of the 
fields they use: here, 

by adding italics.

This merge block 
pulls together the text 
of two fields to display 

a candidate’s name.
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Fixed text (p.199)  
Fixed text in a format is just text: it has no meaning as far as Cardbox is concerned.  
Cardbox displays or prints it in the location you specify, and that’s all. 

Fixed text is useful for headings, hints and reminders. 

Lines and boxes (p.201)  
Lines and boxes can make a format easier to read and understand, collecting 
groups of related items together or acting as separators.  Lines and boxes are the 
same thing as far as Cardbox is concerned: if you draw along a row or a column, 
you get a line; if you draw diagonally, you get a box. 

 

 

Fixed text and lines 
will appear identically 
in every record.  This 

format is used for 
data entry.  Other 

formats in this 
database, used for 

searches and reports, 
save space by 

not including 
fixed text or lines.
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Graphics (p.202)  
A graphic has no meaning as far as Cardbox is concerned.  When Cardbox displays 
or prints your records, it will include your graphic in the place you drew it in the 
format.  Because they have no function, graphics are never essential; but they are 
useful: 

• To include logos or symbols. 
• To reproduce a letterheading. 
• To provide a background picture for the format. 

 

Pushbuttons (p.203)  
Pushbuttons perform an action when you click on them with the mouse.  The action 
can be a macro or a separate program command. 

 

 

The position of this 
pushbutton makes it 
clear that clicking on 

the button will do 
something to the 

adjacent fields.

Here is a logo that 
can be used at the top 

of a mail-merged 
letter.
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Headings and footings (p.188)  
Headings and footings aren’t separate items as such, they are simply distinct parts 
of the format design screen, and they can contain any format element except a field.  
You can have headings and footings for each page, and you can also have 
continuation headings and footings that appear only if a record has to be split across 
pages.  Headings and footings normally apply to printed output only, but you can set 
a format property to make Cardbox show the page heading at the top of your screen 
display. 

Format properties (p.204) 
There are various facts about a format that don’t correspond exactly to a visual item 
on the format design screen: Cardbox refers to these as the format properties.  They 
include 

• The Extra Text field. 
• The order in which fields are visited when you are editing a record and press the 

Tab key to move to the next field. 
• Whether Cardbox should join consecutive records to make the whole page into a 

ruled form. 
• What dictionaries to use for spelling checks, and which fields to check 

automatically. 
• The appearance of the format: see “Appearance”, p.107. 
• The printer settings: see “Printer Settings”, p.115. 
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Edit > Format > Duplicate 
Ctrl + Shift + D 

How to edit or create a format 

Creating a blank format 
Edit > Format > New creates a new, blank format as a basis for your design.  When 
you have finished designing the format, use File > Save to save it: Cardbox will ask 
you for a name to give to the new format. 

Creating a new format based on an existing one 
You will often find yourself wanting to create a format that is almost identical to one 
that’s already there, especially if you regularly create standard letters for mail-
merging. To create a new format that resembles an existing one, select the existing 
format with View > Change Format and then do Edit > Format > Duplicate.  This 
creates a new format; but instead of being blank, the format is identical to the one 
you were just looking at.  Now you can make any changes that you need and then 
use File > Save.  Cardbox will ask you for a name to give to the new format, and the 
original format will be left unchanged. 

Copying a format from one database to another 
Sometimes people maintain similar but separate databases and they want to copy a 
format from one database to another.  This isn’t quite as simple as it sounds 
because there’s no guarantee that the field names you gave to one database are the 
same as the field names you gave to the other one, but Cardbox can overcome 
these difficulties. 

Editing an existing format 
To edit the format that you are currently using to view records, do Edit > Format > 
Edit. 

If you want to edit a different format, use View > Change Format to switch to it 
before you start editing.   

When you’ve finished editing the format, use File > Save to save your changes. 

Cancelling an edit 
If you don’t like the changes you’ve made, use File > Quit Without Saving to discard 
them and leave the original format untouched. 

Edit > Format > New 
Ctrl + Shift + N 

File > Save 
Ctrl + S 

File > Save 
Ctrl + S 

For more about 
copying formats, see 

Help Point 589.

Edit > Format > Edit 
Ctrl + Shift + E 

File > Save 
Ctrl + S 

File > Quit 
Ctrl + Q 
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View > Actual Size 

View > ×1½ 
View > ×2 

View > ÷2 
View > ÷1½ 

The format design screen 
When you start editing a format, Cardbox will display the format design screen.  This 
has a grid on which you can position the various format items, and vertical and 
horizontal rulers to control the format width, position of headings, etc. 

Zooming in and out 
Because editing a format involves a lot of precise movement, you may want to zoom 
in on the display (enlarge it) so you can see and manipulate things more clearly.  
Conversely, if you have a large format and want to see what it looks like as a whole, 
you may want to zoom out and get a reduced view that fits on the screen. 

To zoom in with the keyboard, hold down Ctrl and press + (plus) on the numeric 
keypad.  With a wheel mouse, hold down Ctrl and roll the mouse wheel towards 
you. 

To zoom out with the keyboard, hold down Ctrl and press - (minus) on the numeric 
keypad.  With a wheel mouse, hold down Ctrl and roll the mouse wheel away 
from you. 

To unzoom the format, use View > Actual Size. 

Scrolling 
If the format design is too large for the window, you’ll see scroll bars.  You can use 
the scroll bars to scroll to the area of the design that interests you, but you have a 
couple of alternatives that may be more convenient: 

You can scroll vertically by dragging the vertical ruler up and down.  If you have a 
wheel mouse, you can also scroll vertically by rolling the mouse wheel. 

You can scroll horizontally by dragging the horizontal ruler sideways.  If you have 
a wheel mouse, you can also scroll horizontally by holding down Shift and rolling 
the mouse wheel. 
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Selecting items 
Before you can manipulate a format item you need to select it.  The simplest thing is 
to click on the item you want to select.  If you want to select more than one item, 
there are two ways of doing this: 

• Click on the first item you want to select and then hold down the Ctrl key as you 
click on each of the others.  If you select an item by mistake, you can Ctrl + click 
on it again to deselect it. 

• Click on the format background and hold the mouse button down.  As you drag 
the mouse diagonally, a rectangle will appear: when you release the mouse, any 
format item that is inside the rectangle (or intersects it) will be selected. 

If you want to select all items, use Edit > Select All. 

To deselect all items, click on the format background.  

Moving items 
To move a selected item (or items), move the mouse onto it, press the mouse 
button, and keep it pressed as you drag the mouse in the direction you want to go.  
You’ll see the items moving.  When you have got to where you want to go, release 
the mouse button. 

For precise control of movement, you can use the keyboard: the arrow keys will 
move your selected item(s) one row or column at a time. 

Resizing items 
Select the item you want to resize (you can only resize one item at a time).  Move 
the mouse onto one of the square “sizing handles” at the edge of the item, and drag 
it in the direction you want. 

For precise control, you can use the keyboard: if you hold down the Shift key, the 
arrow keys will enlarge or shrink the selected item. 

You can’t resize fixed text, because its size is calculated automatically from the text 
it contains. 
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Deleting items 
To delete items from your design, select them and then press the Delete key. 

What happens when a field is deleted 

If you delete a field in an alternative format, the field disappears from that format.  If 
you delete a field in the native format then that effectively deletes the field from the 
database.  This is a dramatic step, so Cardbox maintains the field as a half-alive 
“ghost” until you definitely decide to purge it for ever.  Ghost fields can be re-created 
with little or no data loss. 

Undoing a change 
To undo the last change that you made to the format design, use Edit > Undo.  
Cardbox remembers quite a few changes, so you can use this command several 
times in a row.  If find that you’ve undone too much, use Edit > Redo to restore the 
changes you didn’t mean to undo. 

Overlapping items 
Format items shouldn’t overlap because Cardbox won’t know which of them to draw: 
it won’t be a disaster if you include them in your format but the result will look 
strange.  In the format design, overlapping areas are shown by red-and-white 
diagonal stripes.  If you don’t notice the overlap, Cardbox will warn you about it 
when you save the format. 

The printable area 
If you are designing a format to be used for printing, it helps to see on the screen 
how much space you have available.  Most paper is narrower than most screens, 
and mailing labels are of course much smaller than the screen. 

Cardbox shows you how big the printable area is compared to your format design, 
with a subtle orange-and-white dotted line.  This shouldn’t irritate or confuse you 
while you’re designing your format, but if it does then you can use View > Printable 
Area to turn it off. 

The size of the printable area depends on the fonts you are using and also on your 
printer settings: see “Appearance” (p.107) and “Printer Settings” (p.115). 

For more about the 
fate of deleted fields, 
see Help Point 538.

Edit > Undo 
Ctrl + Z 
Edit > Redo 
Ctrl + Y 
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Format width 
On the horizontal ruler, the red markers show the width of your format design, and in 
the design screen, the area between those markers is shown in a darker blue.  If you 
put format items outside the current width, Cardbox will automatically increase the 
width when you save the format, but it won’t automatically reduce the width if you 
delete format items. 

You can widen or narrow a format by dragging the right-hand red marker across 
(move the mouse onto the marker, let the cursor change shape, then drag).  If you’re 
only planning to use a format on the screen then its width isn’t very important; but if 
you’re printing, Cardbox will check that the format fits inside the area that’s available 
on the paper.  If you’re faced with a format that’s too wide (and you don’t want to do 
something drastic about it, like reducing the font size or printing in landscape format) 
then you can use the red marker to make it narrower – of course, you’ll have to 
move any format items that stick out beyond the new position of the marker as well, 
or Cardbox will just widen the format for you all over again when you save it! 

You can also make the format wider by dragging the left-hand red marker instead of 
the right-hand one.  This is sometimes useful, because it moves the edge of the 
format without moving any format items and therefore has the effect of giving you 
some blank columns on the left of the format – which can be less work than 
selecting all the format items and dragging them to the right. 

Format height 
On the vertical ruler, you’ll see numbers counting from 1, showing the height of your 
current format design and the row number of each row within it.  If you click on the 
numbered area it will turn white: if you then move your mouse to the thick border just 
above the number 1 or just below the last number, the mouse pointer will change 
shape, and you can depress the mouse button and drag the thick border up or down 
in order to change the height of the format.  If you drag upwards from the top, you’ll 
get blank lines at the top of the format; if you drag downwards from the bottom, you’ll 
get blank lines at the bottom. 

If you have format items sticking out beyond the numbered area, Cardbox will 
automatically make the format taller when you save it; but it is sometimes useful to 
set the height yourself, by hand – for instance, if you want to have blank lines before 
or after your data. 
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Headings and footings 
There are four kinds of headings and footings.  The single-letter codes are the way 
that these areas are identified in the vertical ruler. 

H The page heading appears at the top of each printed page.  If you turn on 
Screen Also Shows Page Headings (in Edit > Format Properties » General), 
then the page heading will also appear at the top of the screen, assuming that 
the display window is tall enough to accommodate a list of records and not just 
one record. 

F The page footing appears at the bottom of each printed page. 

f If a record is split between two pages, the continuation footing appears at the 
bottom of the first page, just above the page footing (if any)… 

h … and the continuation heading appears at the top of the second page, just 
below the page heading (if any). 

To insert a heading or footing 
Use the command Insert > Headings/Footings and pick the kind of heading or 
footing you want to create.  You’ll see that the vertical ruler now contains a new row, 
numbered with a prefix letter: for instance, H1 for the page heading. 

You can now put format items into the new area.  You can use any format item 
except a field: this is because the headings and footings aren’t usually displayed as 
part of the record, and it would be rather difficult for Cardbox to let you type into 
something that doesn’t exist on the screen!  If you really want to include field data in 
a heading or footing, use a merge block.  Merge blocks are also the way that you 
insert special data such as page numbers. 

To resize a heading or footing 
Click on the relevant area in the vertical ruler (H for a page heading, F for a page 
footing, etc) and it will turn white.  The thick border at the top or bottom of the white 
area now works as a resizing border.  Move the mouse onto the border and the 
mouse pointer will change to a double headed arrow.  Press the mouse button and 
drag the border up or down, and the size of the area will change.  Drag the borders 
outwards (top border up or bottom border down) to enlarge the area, inwards to 
reduce it. 
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Fields 

Inserting a field in the native format 
Inserting a field into the native format effectively creates it in the database.   

1. When you use the Insert > Field command, the mouse cursor turns into a hollow 
square.  Move the mouse to where you want your new field to start, press the 
mouse button, hold it down, move the mouse to where you want the field to end, 
and release the mouse button.  Most people drag from the top left to the bottom 
right of the field, but there is no rule about this: as long as you go from one place 
to another on the screen, Cardbox will draw a rectangle for you and make the 
field that shape and size. 

2. Once you’ve released the mouse button, the field will appear on the screen and 
Cardbox will ask you what name you want to give it.  Field names appear 
whenever Cardbox shows you a list of fields (for searching, sorting, etc), and you 
can type a field name whenever Cardbox asks you for a field – for instance, 
when  you are doing a search.  Something short but meaningful is generally a 
good choice.  You can always change the name later if you want. 

3. Cardbox then takes you straight to the Item Properties command so that you can 
set up other attributes of the field such as its indexing mode and its description. 

If you have previously deleted some fields, Cardbox reacts slightly differently when 
you ask it to insert a new field: it lists the deleted fields, so that you can choose to 
reinstate one of them or to create an entirely new field.  

Inserting a field in an alternative (non-native) format 
You can only insert fields into an alternative format if they already exist in the native 
format.  When you use Insert > Field, Cardbox shows you a list of fields that you’re 
not already using in this alternative format, and you can choose which one you want 
to insert.  Drawing the field on the screen is then the same as in the native format. 

Setting field properties 
If you want to set or change the properties of a field, double-click on it.  Alternatively, 
select it and then use Edit > Item Properties (or press Enter). 

Name and description (native format only) 

The field name is the name you use when referring to the field, for example when 
searching and sorting.  The description appears next to the name whenever 
Cardbox shows you a list of fields, so you can use it to make the field more 
understandable or give a short explanation of what it should contain.  It’s perfectly 

Insert > Field 
Ctrl + F 

The Extra Text field is 
created differently, 

and you don’t need to 
draw it on the screen: 

see page 204.

For more about 
deleted fields, see 

Help Point 538.
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safe to change either of them even after you’ve put data into your database: 
Cardbox won’t get confused and all commands and all formats will refer to the field 
under its new name. 

Field type (native format only)  

Most fields are text fields, but you can also have one image field in your database 
and as many object fields as you like (object fields can only be created by the 
Professional Edition).  You should only set the type when you are first creating a 
field.  Cardbox does permit you to change the field type after creation, but this is 
something you should never do in practice. 

If you find that you are not allowed to set the field type to Image, this is because an 
image field already exists in the database.  If you can’t see it around, the image field 
may have been deleted but still be hanging around in a ghostly form.  

Indexing mode (native format only)  

Cardbox can index any number of words, numbers or dates in any field (we’ll use 
“term” as an abbreviation for “word, number or date”).  Cardbox has four ways of 
deciding what terms are to be indexed in a given field: 

All – Cardbox indexes everything. 

None – Cardbox indexes nothing. 

Manual – Cardbox doesn’t index anything to start with, but you can manually tell it to 
index any term you want: see “Indexing” in the Editing section (p.140). 

Automatic – Cardbox indexes everything to start with, but you can manually tell it 
not to index certain terms. 

You can change the indexing mode even after you’ve started putting data into your 
database, but the changes won’t automatically affect your existing records.  

If you have Manual or Automatic indexing, you can also use validators to do some 
intelligent indexing for you: for instance, you can set up a validator to index all dates 
but leave words and numbers alone.  See “Validators” (p.206). 

Caption 

Most fields need some sort of explanation or you won’t know what they mean when 
you look at the screen or at a printout.  Captions are one way of providing this 
explanation.  A field caption appears as part of the field, and if you redraw a field or 
move it around, the caption goes with it.   

There are a few cases where a field caption is not a good idea and fixed text is 
better: see “Fixed Text” (p.199) for an explanation. 

See Help Point 540 
for why we have to 

allow you to change 
the field type after 

creation.

For more about 
deleted fields, see 

Help Point 538.

For how to re-index 
existing records, see 

Help Point 541.
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Highlight dubious spellings 

Cardbox has a spelling checker which can underline words that seem not to be 
correctly spelt.  You can turn this on and off while you’re editing a record, but if you 
know that you’re always going to want this feature in a particular field, set the 
Highlight Dubious Spellings option.  This saves you constantly having to press 
Shift + F7 to turn the underlining on. 

View 

The normal way of viewing a field is as text: what you type is what you see.  For 
some fields that represent restricted options, there are more graphical approaches 
that may be easier to use.  The View option lets you choose between radio buttons, 
check boxes, and drop-down lists.  Once you’ve chosen one of these views, the Set 
button will let you specify what options should be available.  See “Alternate Field 
Views” (p.192). 

Appearance 

You can give a field its own appearance independently of the appearance of the 
format as a whole.  For appearances and how to alter them, see “Appearance” 
(p.107).  If you give an appearance to an individual field, it won’t change if you later 
change the appearance of the format as a whole (it will remain unchanged unless 
you edit the format and change it explicitly).  Also, if you give a field a font much 
larger than the font for the format as a whole, the format’s grid layout won’t be 
altered, but the field may end up taking up more than one row of the grid. 

Validation 

Validators can do a number of useful things: 

• Enter default data automatically. 
• Check your data for validity. 
• Automatically index or unindex certain terms. 
• Reformat dates so that they all use the same standard format. 

For full details, see “Validators” (p.206). 

Only the Professional 
Edition of Cardbox 

can set up validators, 
but all editions can 

use them once they 
have been set up.
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Alternate field views 
As well as displaying fields on the screen as text, you can display them as radio 
buttons, check boxes, and drop-down lists.  These views are appropriate if there are 
relatively few possible values for a field, and they can save space and help with data 
validation by restricting what a user can enter into the field. 

Underneath the alternate view, the field is still a perfectly ordinary Cardbox text field.  
The view reflects the contents of the field, and when you select an option using the 
view, Cardbox changes the field text to correspond with your change.  The 
advantage of doing things in this way is that you can use different views in different 
formats.  You might find, for instance, that radio buttons are best for data entry but 
would waste a lot of space in a printed report. 

Radio buttons 
Radio buttons are used when there are relatively few options and only one of them 
should be chosen.  When you click on a radio button, Cardbox erases the text of the 
underlying field completely and replaces it with the text that belongs to the radio 
button. 

Check boxes 
Check boxes let you choose one option, or more than one, or none at all.  For 
example, a recruitment database could use check boxes for applicants’ principal 
language skills. 

Cardbox’s behaviour with check boxes is more sophisticated than with radio buttons.  
When you turn a check box on, its corresponding text is added to the field; when you 
turn it off, the text belonging to the check box is removed but everything else is left 
untouched. 

Drop-down lists 
Drop-down lists are logically just the same as radio buttons, but they save screen 
space because only the chosen option is visible until you click on the drop-down list.  
The choice between radio buttons and drop-down lists is a matter of taste: radio 
buttons show every option all the time but they need more room; drop-down lists 
don’t show every option until you open the list, but they are more compact. 
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Specifying the available options 
Before it can display radio buttons, check boxes, or a drop-down list, Cardbox needs 
to know what the available options are.  You set the options by pressing the Set 
button in the Field Properties window (Edit > Item Properties » General). 

The simplest choice is to type a list of the possible options: 

English French Spanish Latin Italian Greek 

With a definition like this, when you click on a check box labelled “English” to turn it 
on, Cardbox will put English into the field (or, if you are turning off the check box, 
Cardbox will find English in the field and remove it). 

• The sequence in which the options appear in your specification controls the 
sequence in which they will appear on the screen.  It has no other meaning, so 
you can change the sequence later on without affecting your existing data. 

Sometimes you may want your field to contain text that isn’t exactly the same as 
what appears on the screen.  For example, suppose you have radio buttons defined 
like this: 

C=Cheque B=Bank_transfer CC=Credit_card S=Standing_order 

Now, if you click on the radio button marked “Bank transfer”, the contents of the field 
will be replaced with the letter B.  This kind of approach is very useful if you want to 
have some formats in which the field appears as pure text (summary reports, for 
example) where a code will take up much less room than a descriptive phrase. 

• You will see that there is an underline character between Bank and transfer.  
This is so that Cardbox knows that this is a single phrase, and that “transfer” is 
not intended to be a separate item. 

• This technique is also useful if you change your mind about the name of an 
option.  You can preserve your original data intact and just change the way the 
option is labelled on the screen. 

You can use the same technique to create different formats for speakers of different 
languages.  If your list says something like 

Spanish=español English=inglés French=francés  

then the check boxes will appear in Spanish (and with the Spanish language listed 
first) but the actual text in the fields will still be in English. 
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Layout of radio buttons and check boxes 
When you tell Cardbox what options to use for radio buttons and check boxes, you 
can also tell it how to lay them out on the screen. 

Packed layout fits as many items as 
possible into each line. 

 

Table layout arranges the items so that 
they line up neatly in columns.  This is more 
readable but can take up more space.  

List layout puts one item on each line. 

 

Adding and removing options 
You can add or reshuffle options at any time without affecting the data you have 
already entered.  Deleting an option when you are already using it in records is a 
little more complicated, but essentially nothing will happen to your existing data until 
you edit and save a record that contains that option.  Help Point 501 tells you what 
will happen in that case. 

Adding and removing alternate field views 
You can remove an alternate field view at any time, and the field will thereafter 
appear as plain text.  You can add an alternate field view whenever you like: for the 
effect that this will have on existing data, see Help Point 502. 
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Merge blocks 

Inserting a merge block 
1. The mouse cursor turns into a hollow square.  Move the mouse to where you 

want the merge block to start, press the mouse button, hold it down, move the 
mouse to where you want the merge block to end, and release the mouse 
button.  Cardbox will draw a rectangle for you and make the merge block that 
shape and size. 

2. Once you’ve released the mouse button, the merge block will appear on the 
screen and Cardbox will take you straight to the Item Properties command so 
that you can set up other attributes of the merge block, including the text it 
contains. 

Editing the text of a merge block 
The easiest way of editing the text of a merge block is to do it in Item Properties (see 
below), but you can also edit the text directly within the format design window.  To 
do this, use one of the following methods: 

• Select the merge block and then do Edit > Edit Text Directly (Ctrl + E). 
• Right-click on it and select Edit Text Directly from the menu that pops up. 
• Hold down the Alt key and double-click on the merge block. 

When you’ve edited the text, click outside the merge block to confirm the changes; if 
you don’t like what you’ve done, click outside the merge block and then do Edit > 
Undo (Ctrl + Z) to undo the changes. 

Insert > Merge Block 
Ctrl + M 

Exactly the same 
technique can be 

used to edit fixed text.  
Fixed text in formats 

is described on 
page 199.
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Setting merge block properties 
To set or change the properties of a merge block, double-click on it.  Alternatively, 
select it and then use Edit > Item Properties (or press Enter). 

The merge text 

The text of a merge block is just ordinary text and it can be as long or as short as 
you like: a single line (automatically word-wrapped as necessary) or multiple lines or 
paragraphs.  You can add references to fields and other data by pressing the Insert 
button while you are editing the text, and they will appear in the text as special 
codes: 

A field.  {fieldname} 

The Extra Text field. {**} 

The page number. {*Page} 

The record number within the current selection. {*Record} 

The number of records in the current selection. {*Records} 

The date or time (Cardbox lets you choose your own format for this). {*Date} 

The print job ID, useful for customising printed reports: see p.112. {ID} 

In addition to these, you can type the following codes yourself: 

{+B} Start bold text. 

{-B} End bold text. 

{+I}, {-I} Start / end italic text. 

{+U}, {-U} Start / end underlined text. 

{{} The open curly bracket “{”. 

{}} The closed curly bracket “}”. 

Finally, you can insert codes to make the merge block present itself in HTML or 
XML: these are useful if you want Cardbox to create web pages directly.  

Align 

You can make Cardbox left-justify, right-justify or centre the text in a merge block.  
You can’t mix the different kinds of justification in one merge block but you can have 
several different merge blocks in a format, each with its own layout. 

For HTML and XML 
output, see 

Help Point 518.
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Automatic height 

By its nature, a merge block may have widely varying amounts of text, and so you 
will often want to let it grow or shrink as necessary to accommodate its contents.  If 
you want to do this, turn on Automatic Height.  Cardbox is fairly intelligent when you 
do this: if you have other items in your format that are located below your Automatic 
Height merge block, Cardbox will push them down (or pull them up) to fit with the 
change in the size of the merge block. 

If you browse through records with Automatic Height set, you’ll notice that they 
change greatly in shape depending on the data that they contain.  This has two 
consequences for Cardbox: the first is that if a format has an Automatic Height 
merge block, Cardbox will only ever display one record per screen even if the 
records are short and you’d expect there to be room for more than one.  The other 
consequence is that because Automatic Height makes the layout so variable, 
formats with Automatic Height merge blocks don’t allow you to edit records: editing 
something that is constantly changing shape would be confusing for both you and 
Cardbox. 

Automatic width 

A merge block is normally as wide as you draw it.  If you set Automatic Width, the 
merge block can grow (if there’s nothing in the way) to be as wide as the format or 
even, when you’re printing, as wide as the paper. 

Start on new page 

If you are printing out a really long format then it may spread over several pages.  If 
you specifically want a new page to start in a particular place, incorporate a merge 
block with Start On New Page turned on.  The merge block can contain text, but it 
doesn’t have to: its presence alone will ensure that a new page is started. 

Omit spaces after an empty field 

This option controls how the merge block text “closes up” after a field that contains 
no text.  For an illustration, see Help Point 599. 

Omit text if all fields are blank 

If you turn this option on, and none of the fields mentioned in the merge block have 
any text in them, Cardbox will omit the merge block altogether.  This is useful if you 
are mail-merging continuous text.  For instance, if you were making a standard letter 
for mail-merging and you had a merge block saying “Please contact {CONTACT} for 
details of this offer”, and the CONTACT field happened to be blank, you wouldn’t 
want the sentence to say “Please contact  for details of this offer”. 

This is useful for 
multi-page output: for 

example, an invoice 
with a covering letter.
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Pack multi-line fields into one paragraph 

If you turn this option on, a multi-line field (such as an address) has all its new-line 
markers turned into spaces so that it becomes one long line.  If you’re producing a 
summary that contains addresses, this can be a good thing; but note that Cardbox 
isn’t very clever and doesn’t insert commas or anything else between the 
concatenated lines of the address. 

View 

The normal way of viewing a merge block is as text, but you can also get it displayed 
as a bar code, using one of a number of standard conventions.  Available bar code 
formats include Code 39, EAN-13, UPC, and the Royal Mail code.  For more details, 
use the online help: select the format you want from the View list, press the Set 
button to set options, and then press the F1 key. 

Appearance 

You can give a merge block its own appearance independently of the appearance of 
the format as a whole.  For appearances and how to alter them, see “Appearance” 
(p.107).  For general rules and caveats relating to individual per-item appearances in 
format design, see page 191. 
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Fixed text 
Fixed text is text that appears identically in every record irrespective of any data the 
record may contain.  It is the equivalent, on the computer, of having a pre-printed 
form or index card. 

Fixed text is useful for headings, reminders, instructions, and it can sometimes be a 
good substitute for field captions. 

Fixed text versus field captions 
A field caption is part of the field and if you move the field then the caption moves 
too.  This makes format design easier, but it also has a couple of potential problems.  
The first problem is that the caption is exactly as long as it needs to be, so that if you 
have several fields, one below the other, the captions will start in the same place but 
they won’t finish in the same place, so the actual field data will start in different 
places on each line.  This can look messy. 

The second problem with field captions being part of the field is that if you have a 
multi-line field then the caption takes up part of the first line.  If the field is a solid 
mass of text, this doesn’t matter too much; but if the field is made of separate lines 
(like an address) if looks odd to have the first line of the field data pushed to the right 
by the caption while the remaining lines all start at the left-hand edge. 

The remedy for both problems is the same: don’t have field captions, but align the 
fields the way you want and then place separate text items next to them.  If you have 
to move a field later, you’ll have to move its text with it; but you may find that the 
improved appearance is worth the inconvenience. 

• Fixed text is only ever one line long: if you want something larger, use a merge 
block without any field references instead. 
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Inserting fixed text 
The mouse cursor turns into a hollow square.  Move the mouse to where you want 
the fixed text to start, and click once.  Cardbox will take you straight to the Item 
Properties command so that you can type the text. 

You can also edit fixed text directly on the screen: see page 195. 

Setting fixed text properties 
If you want to set or change the properties of fixed text, double-click on it.  
Alternatively, select it and then use Edit > Item Properties (or press Enter). 

Text 

Type the text you want.  The fixed text item will automatically adjust itself to the size 
of the text you type. 

Align 

You can make Cardbox left-justify, right-justify or centre a fixed text item.  The effect 
is fairly subtle, but it means (respectively) that the left-hand edge, the right-hand 
edge, or the centre of the item will be exactly aligned on a grid column. 

Appearance 

You can give a fixed text item its own appearance independently of the appearance 
of the format as a whole.  For appearances and how to alter them, see 
“Appearance” (p.107).  For general rules and caveats relating to individual per-item 
appearances in format design, see page 191. 

Insert > Fixed Text 
Ctrl + T 
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Lines and boxes 
Lines and boxes have no meaning for Cardbox: they are like the rulings on a pre-
printed form.  You can use boxes to tie related items together, or lines to separate 
different regions of your format. 

Inserting lines and boxes 
The mouse cursor turns into a hollow square.  Move the mouse to where you want 
the line or box to start, press the mouse button, hold it down, move the mouse to 
where you want the line or box to end, and release the mouse button.  If you start 
and end in the same row, you’ll get a horizontal line; if you start and end in the same 
column, you’ll get a vertical line.  If you start and end in different rows and columns, 
you’ll get a box. 

The line or box will appear as soon as you release the mouse buttons.  Unlike with 
other items, Cardbox doesn’t automatically open the Item Properties command for 
you: this is because the properties of lines and boxes are pretty specialised and 
won’t be of interest to most people. 

Setting line or box properties 
To set or change the properties of a line or box, double-click on it.  Alternatively, 
select it and then use Edit > Item Properties (or press Enter). 

Extend vertical lines 

This is a very specialised property used when you are creating ruled forms: see Help 
Point 561. 

Appearance 

You can give a line or box its own colour and line thickness independently of the 
appearance of the format as a whole.  For appearances and how to alter them, see 
“Appearance” (p.107).  For general rules and caveats relating to individual per-item 
appearances in format design, see page 191. 

Insert > Line / Box 
Ctrl + L 



    202  

 

Graphics 

Inserting a graphic 
1. The mouse cursor turns into a hollow square.  Move the mouse to where you 

want the graphic to start, press the mouse button, hold it down, move the mouse 
to where you want the graphic to end, and release the mouse button.  Cardbox 
will draw a rectangle for you and make the graphic that shape and size. 

2. Once you’ve released the mouse button, a blank graphic will appear on the 
screen and Cardbox will take you straight to the Item Properties command so 
that you can read a graphic image from a file or paste it in from the Clipboard. 

Setting graphic item properties 
To set or change the properties of a graphic, double-click on it.  Alternatively, select 
it and then use Edit > Item Properties (or press Enter). 

To put a new image into this graphic item, press the Read button to import the 
image from a file, or press the Paste button to paste it in from the Clipboard. 

Display mode 

Foreground – the graphic is displayed like any other format item.  If “Transparent” is 
also set, the graphic will let any coloured background show through. 

Background – the graphic is displayed behind all other format items: any format 
item that is drawn on top of the graphic will cover part of it up. 

Format items normally have a solid background, so that if you put a field on top of a 
background graphic, the field will appear as a solid rectangle.  You can change this 
if you want, by changing the field’s appearance: you will see a checkerboard pattern 
among the available background colours, and this gives the field a transparent 
background so that only the text will be visible on top of the graphic. 

Image size 

The graphic image that you are using will probably not be the same size as the 
space available for it.  This option tells Cardbox what to do about this: keep the 
original size, or stretch the graphic to fit the space. 

Store in compressed format 

Leave this option turned on because it makes the format smaller and faster to load.  
Only turn this option off if you want to keep compatibility with Cardbox 2.0, which 
doesn’t understand compressed graphic items. 

Insert > Graphic 
Ctrl + G 
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Pushbuttons 

Inserting a pushbutton 
1. The mouse cursor turns into a hollow square.  Move the mouse to where you 

want the pushbutton to start, press the mouse button, hold it down, move the 
mouse to where you want the pushbutton to end, and release the mouse button.  
Cardbox will draw a rectangle for you and make the pushbutton that shape and 
size. 

2. Once you’ve released the mouse button, a blank pushbutton will appear on the 
screen and Cardbox will take you straight to the Item Properties command so 
that you can set the properties of the new item, including what should happen 
when the button is pressed. 

Setting pushbutton properties 
To set or change the properties of a pushbutton, double-click on it.  Alternatively, 
select it and then use Edit > Item Properties (or press Enter). 

To put a new image into this pushbutton, press the Read button to import the image 
from a file, or press the Paste button to paste it in from the Clipboard. 

Enable button when… 

You can choose whether the button should be usable when you are viewing records; 
when you are editing records; or both.  This is because some actions only make 
sense when editing (or when not editing).  When you are not editing a record, any 
editing-only buttons will appear grey and won’t work. 

Description 

Any description you insert here will be displayed if you hold the mouse over the 
button: Microsoft call these things ToolTips. 

Image size, Store in compressed format 

These options have the same meaning that they do for graphics. 

Action when the button is pressed 

The button can play a macro, run a Windows program, or send a DDE command to 
a program that understands and is waiting for DDE commands.  For more 
information on any of these options, press F1 and see the online help. 

Insert > Pushbutton 
Ctrl + B 
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Format properties 
As well as the various items that you can place within a format layout, there are 
some properties that apply to the format as a whole.  To set these, double-click 
anywhere where there isn’t a format item.  Alternatively, use the command Edit > 
Format Properties. 

General 

Page headings 

Normally the page headings or footings you specify will not appear on the screen but 
only when you print your records.  If you turn on Screen Also Shows Page 
Headings, page headings will appear on the screen: this will happen as long as the 
window is tall enough for more than one record to be displayed.  For more about 
headings and footings, see page 188. 

Extra Text field 

The Extra Text field is attached to a record but not part of the main record display.  
Pressing F6 will switch between the main record and the extra text.  Extra Text is 
useful for unstructured text associated with the record, but not everyone needs it: if 
you can’t think of a use for it, ignore its existence. 

To make the Extra Text visible, turn on Format Contains Extra Text.  To make 
Cardbox automatically show Extra Text just below the main record when you first 
use this format, turn on Format Display Starts With Extra Text Visible. 

As with any other field, you can’t put Extra Text into a format unless it already exists 
in the native format.  If the native format doesn’t contain Extra Text, the Extra Text 
options will be greyed out and disabled in any alternative format. 

Description 

Whatever you type into this box will be shown in the View > Change Format window 
when you click on the name of this format.  Of course you should try to make the 
format’s function self-evident from its name; but in case it isn’t, try to describe its 
characteristics or purpose briefly here, for the benefit of someone who isn’t sure 
what the format is for.  In a few months’ time, that someone may be you. 

Spelling 
This tab lets you choose which fields will automatically underline misspelt words: you 
can turn this feature on and off by pressing Shift + F7 while you are editing a record, 
but it makes life easier if Cardbox starts out in the mode you want. 

This tab also lets you choose which dictionaries Cardbox should use when it checks 
spelling: for details, see “Spelling and Spelling Dictionaries” (p.149). 

You can also set this 
mode in the Field 
Properties box for 

each individual field.
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Field sequence 
When you are editing a record, pressing the Tab key takes you to the next field.  The 
Field Sequence tab lets you define the order in which the fields will be visited.  To 
move a field to a different place in the list, select it and then press the up or down 
arrow buttons below the field list.  You can move several fields by selecting them all 
(with Ctrl + click) before pressing the arrows. 

The Field Sequence tab also lists field descriptions, so it can be a convenient way 
for you to review them all and change any that you don’t like: simply select a field 
and then retype its description in the box below. 

Overlapping boxes 
This tab controls a specialised feature that is used for producing ruled forms.  For full 
information, see Help Point 561. 

Appearance 
This tab controls the appearance of the format as a whole.  See “Appearance”, on 
page 107. 
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Validators 
Validators are things you attach to fields when you design the native format.  When 
someone adds or edits a record and changes the contents of a field, its validators 
wake up and look at the changed text.  There are various kinds of validators: some 
check the field to make sure it is correct (in other words, they validate it); others 
make modifications to it (indexing, unindexing, or reformatting dates); and there are 
even validators that replace the field text altogether, which is useful for things like 
timestamping. 

Validators typically wake up when the user moves off a field or saves the record, but 
it is also possible to activate them manually: see “Using Validators”, p.152. 

How to add and modify validators 
You must already be editing the native format.  Double-click on a field, or select it 
and then use Edit > Item Properties. 

Then select the Validation tab. 

To add a validator – press Add and select the validator you want from the menu 
that pops up.  The new validator will appear in the list, and the bottom half of the 
Validation tab will let you edit it. 

To modify an existing validator – select it from the list, and use the bottom half of 
the Validation tab to make the changes you want. 

To delete a validator – select it from the list and press Delete (this is the Delete 
button in the Validation tab, not the Delete key on the keyboard). 

Moving validators around in the list 
You don’t often have more than one validator attached to a field, and if you do, it 
usually doesn’t matter which order they come in.  But if you have several validators 
making changes to a field, then the order they are in may make a difference.  To 
change the position of a validator in the list, select it and then use the up and down 
arrow buttons (just below the list) to move the validator up and down in the list. 

Validators can only be 
set up by the 

Professional Edition 
of Cardbox.
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Editing a validator 
The bottom half of the Validation tab lets you set all the options for the currently 
selected validator.  Every type of validator has its own options. 

Cardbox also displays a confirmation of what you have specified, in a panel next to 
the Validation tab.  This is how the validator will look to the user if it pops up 
because an error has been detected. 

  

Getting more information about validators 
The list below tells you about all the available validators and gives you a brief 
description of each one.  For more detailed information on a particular validator or 
on the validation process in general, press the F1 key to see the online help.  This 
will tell you how each validator works and exactly what all the options mean. 

Validators that check what is in a field 
If one of these validators detects something wrong, it pops up a warning when the 
user tries to save the record.  When you design the validator, you can choose 
whether it is possible to ignore this warning. 

Check words 
Any words that occur in the field must match your specification.  The specification 
can be one of the following: 

A list of valid words that you type directly into the validator.  As well as individual 
words, this list can contain wildcards (as in searching) and ranges in the form 
from:to. 

A separate text file outside Cardbox.  Having the list in a separate file may make it 
easier to change, especially if you are using a separate program to create the 
list. 

Another Cardbox database.  The validator looks up each word in the other 
database and treats it as valid if it is in that database’s index (in a field whose 
name you specify). 

This can look at 
indexed words only, 
or unindexed words 

only, or all words.
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Check numbers 
Any numbers that occur in the field must match your specification.  The way the 
specifications work is the same as for words.  

Check dates 
Any dates that occur in the field must match your specification and conform to a 
specified format.  The way the specifications work is the same as for words.  

Disallow specific types 
The field must not contain terms of a specified type (word, number, or date). 

Unique terms 
Any indexed terms in the field must not already exist in the database’s index.  This is 
useful for things like serial numbers or reference numbers. 

Non-unique terms 
Each indexed term in the field must already exist in the database’s index.  If the field 
is meant to contain specific codes, this is a quick and informal way of checking for 
typing mistakes. 

Length of terms 
Each term entered in the field must be of a certain length, or its length must be 
within a specified range. 

Number of terms 
The field must contain a given number of terms, or the number of terms must fall 
within a range.  You can specify separate limits for words, numbers, and dates.  

Length of field  
The field as a whole must be restricted to a certain length. 

Validators that change what is in a field 

Change case 
This validator changes the capitalisation of text: all capitals, all lower-case, or capital 
letters at the start of words, or capital letters at the start of sentences.  

Indexed only, 
or unindexed only, 

or all numbers.

Indexed only, 
or unindexed only, 

or all dates.

Indexed only, 
or unindexed only, 

or all terms.

Indexed only, 
or unindexed only, 

or all terms.

Indexed only, 
or unindexed only, 

or all terms.

This can look at 
indexed words only, 
or unindexed words 

only, or all words.
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Reformat a date 
This validator changes all dates into a format that you specify.  For example, you 
can choose the order in which the day, month and year appear, and two-digit or 
four-digit years. 

Index terms  
This validator indexes particular terms.  You specify which terms should be indexed 
in the same way as you do in the Check Words, Check Numbers and Check Dates 
validators. 

Unindex terms  
This validator unindexes particular terms.  This is often called a "stoplist". 

Validators that replace what is in a field 

Default entry 
This validator overwrites the field with text that you specify.  It is useful for a number 
of purposes.  It can fill in a field with a default value (for example, a country code) 
that the user can then override manually if required.  It can insert the user’s initials or 
the date and time, either when the record is created or every time it is changed.  

Automatic numbering 
This validator puts a unique number into the field when you save it.  You can control 
the format of the number and the starting point of the numbering. 

You can use Tools > Automatic Numbering to specify where the numbering should 
start.  Cardbox assigns the number when saving the record: this is to avoid 
complications on a network if several people start adding records at once.  You can 
prevent this validator from inserting an automatic number simply by typing 
something into the field before saving the record. 

Validators and pick lists 
A pick list allows the user to enter words by picking them from a menu or a list 
instead of typing them.  This can save time and it can be less error-prone than 
typing. 

Cardbox automatically creates pick lists from certain validators.  The validators it 
uses are Check Words, Check Numbers, Check Dates and Index Terms.  Only 
individual terms make it into the pick list: wildcards and ranges don’t. 

For how pick lists 
work while 

editing a record, 
see “Pick Lists”, 

p.144.





 

 

Part Six 
Inspiration 

A gallery of Cardbox databases; some exercises to help 

you get started; things to think of when planning a 

Cardbox database. 

 



 

 

 
A blank screen waiting for you to design your database.
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Planning your database design 
Cardbox is powerful and it’s quick and easy to learn.  By now, you know fairly well 
how to search Cardbox databases and add records to them, and you even know 
how to design a database – in theory.  But it’s one thing knowing how to use a tool 
and quite another thing to know what to use it for.  That’s what this chapter is all 
about. 

Gallery – We start with a gallery of examples of what other people are using 
Cardbox for.  Even if you have a pretty good idea of what you want to do with 
Cardbox, it’s worth looking through this section, because you may find yourself 
getting some new ideas.  You don’t use your word processor for just one 
purpose, so why restrict yourself to just one use of Cardbox? 

Exercises and samples – These are some databases that you can create for 
yourself with step-by-step instructions from us (but we also give you the final 
result, if you really haven’t got time for this).  The databases themselves can be 
useful as a basis for your own designs, and in any case they’ll give you some 
solid practice and make it easier for you to make a good design first time.  

Strategy – Finally we give you some hints on strategy.  These will be especially 
useful if you’ve used other databases before, because you may need to unlearn 
some bad habits. 

Growing a database 
It’s often best to start with a really simple database design and have another look at 
it when you have been using it for a while – perhaps after you’ve added 100 records, 
perhaps after you’ve been using the database for a few months.  When you do that 
sort of audit you’ll find new uses for your data and you’ll probably find that you need 
to add a few new fields to help with those uses.  Since Cardbox makes it so easy to 
add fields when you need to, this isn’t at all a difficult process, and your database 
design will end up gradually growing and evolving to suit your needs. 

So if an example seems too simple for you, don’t worry: you can always create a 
design and grow it to fit your needs.  And if an example seems unnecessarily 
complex, don’t worry either: in your own design, you can prune away the parts you 
don’t need. 
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Personal uses of Cardbox 
The division between personal and business uses of Cardbox is a bit artificial but it’s 
still useful.  We think of a “personal” use as being something that you might use for 
yourself, while a “business” use is more appropriate for groups of people; but since 
there’s no real distinction between the two, there’s no reason for you not to adapt 
one of our “business” examples for your own personal use or expand a “personal” 
example to cover a whole company. 

Addresses and contacts 
This is one of the commonest uses of Cardbox, and we even give you two exercises 
(with accompanying sample formats) that create address books for you – see pages 
234 and 235. 

Because you design the format yourself, you can easily include whatever extra 
information you want.  You can slant your database towards being a simple address 
list that you print out for your own use (it saves the worry of losing an address book 
if you know you can print it out again) or you can make it more sophisticated, so that 
it can print mailing labels for a mailshot, or categorize your contacts (for example, 
“printable” friends who get printed in your paper address list and “reference” contacts 
who have to be looked up on the computer).  Here are a few other ideas: 

When you’re going on holiday, select the friends you might want to send 
postcards to and print them out in a very compact, small-print format.  Tagging 
(p.93) is an excellent way to identify exactly the people you want to list. 

At Christmas, have a couple of fields to record who you’re sending cards to and, 
just as important, who you have sent cards to, so that you know what’s 
happening when you look at the database again next year.  You can also design 
a mailing label format so that you don’t have to write the addresses by hand.  

If you use a Palm, you can use Cardbox to store your address list but then export it 
to the Palm Desktop application from where it gets synchronized to your Palm.  
This can work with other palmtops, of course, whether they’re PalmOS-based or 
PocketPC-based; and it can also work very well if you have a company-wide 
database, since the address list only has to be maintained once.  

You can divide your contacts into “printable” ones, who get printed in your 
address lists, and “reference” ones who have to be looked up on the computer.  
That way you save paper but don’t lose anyone. 

If you have a field for email addresses, you can set it up so that a single click on 
your friend’s address will open a blank email, ready to be sent, in your email 
program. 



      Personal uses of Cardbox  215 

 

Collections and inventories 

CD collections 
You can keep a straightforward record of each CD you have in your collection 
classifying information according to title; composer; studio, etc. 

 

You can build on this by having a bigger field that holds the track listing for each CD.  
If you index this, then you will be able to search easily on tracks as well as whole 
CDs. 

One Cardbox user has a large database of tracks that he uses to create playlists for 
a radio programme.  He then archives the playlists, so that it’s easy to look up what 
was played in the past, and he also uses Cardbox to create a Web page with the 
most recent playlist for everyone to see. 
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Book collections 
This is a classic use of Cardbox: the first ever (8-bit) edition of Cardbox, in 1982, had 
a Books database as its main sample.  Here, in honour of that edition, is the very 
first record: 

 

Here, from the 21st century, is another example, developed by an historian.  You’ll 
note that the price has been included.  This is so that if her house burns down, the 
insurance company can receive a complete list of the books and how much they will 
cost to replace. 

 

A logical extension of a database like this would be to add a shelfmark so that you 
can see where each book is.  Of course, this requires quite an investment in time 
and effort, because the database will have to be edited every time a book is re-
shelved: perhaps this would be more suitable for an academic library with a librarian, 
rather than a personal working library. 
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One final visit to books, this time from the point of view of a business.  The Electric 
Chariot is a Web-based motoring bookshop that was active in the early days of the 
Internet.  A customised program built the actual Web pages, but the core of the data 
was stored in Cardbox: 

 

Insurance inventories 
Once you have become convinced of the necessity of giving evidence to insurers, 
there is no need to stop at printed books.  Any artefact is worth recording, and with 
digital cameras being so cheap, there is no reason not to photograph everything 
while you’re about it: 
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Recipes 
When we heard that a prominent Oxford philosopher was a keen user of Cardbox 
we thought we could dazzle everyone by raising the intellectual tone of this book.  
However, Oxford philosophers turn out to have human interests too; and he is not 
the only one.  The following example comes from an agricultural institute in Chile 
whose main “business” databases are bibliographies related to crop management 
and animal husbandry: 

 

One of the glories of Cardbox is how infectious it is: you start using it for one main 
purpose and then you discover others, and still others… 

Bibliographies 
One of the most irritating tasks that any academic researcher faces is maintaining a 
list of references.  It’s irritating because it’s a distraction from the main job but it still 
has to be done right.  There is nothing that terrifies a Ph.D student more than finding 
an absolutely crucial quotation in the finished thesis but having no idea at all where it 
came from. 

 

Cardbox is so flexible that you can create one database of books and articles and 
divide them into primary and secondary sources and then create an alphabetical list 
that can then be read into a word processing package and edited further. 
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Abstracts 
Researchers also use Cardbox to keep databases of abstracts. There are two main 
approaches.  One is to store everything in the main record, and have a big field for 
the abstract with the keywords indexed; the other (shown here) is to have all the 
reference information in the main record and the abstract itself in the Extra Text 
field. 

 

You can view the abstract together with the main record (as here) or in a screen on 
its own.  There is nothing to stop you building on this further: for example, by adding 
a field that gives your own opinion of the article. 

Quite a few researchers download abstracts from online databases such as Medline, 
because many of them allow the export of data in a form very close to Cardbox’s 
External file transfer format. 

Passwords 
People who live online rapidly realise that they are accumulating an uncontrollable 
number of different identities for different sites and services.  Unless you use the 
same user name and password for everything (a very dangerous thing to do from 
the point of view of security) you end up with total chaos.  A simple Cardbox 
database with just a handful of fields will solve the problem: 
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You’ll have to protect your password database, of course.  In some cases you may 
be able to rely on physical security, by controlling access to your computer and 
taking great care of any backups you make.  Otherwise you can encrypt your 
database if you have the Professional Edition of Cardbox.  Failing that, you’ll have to 
see what encryption and security features are built into your copy of Windows. 

Photographs 
Cardbox is perfect for cataloguing and storing photographs – either direct digital 
snaps or scans of printed photographs.  One Cardbox user (most of whose 
databases are for trade statistics, journal ordering, library lending, and other serious 
purposes) also has a personal copy of Cardbox at home, and reports: 

“Taking advantage of the beautiful weather we are having today I have been 
photographing some of the plants in my garden in order to have real live photos 
in my plant database, trying to eliminate those scanned from the labels that 
came with the plants… 

“As for my own photos, I have a macro that imports them from a Photo CD and 
another one that automates writing out any combination of photos in the correct 
order to a folder that already contains Slide Show files.  The macro finishes by 
opening Roxio CD Creator.  Now I don't mind when people ask me for copies of 
my photos and it won't be a chore to load them in the first place.  My cousins will 
be pleased”. 

Obviously you need the Professional Edition to use Cardbox macros to do all this 
work; but it shows what can be done with macros even by someone who is not a 
professional programmer and has never written a program before. 

The exercise on page 238 shows you how to create your own database of photo-
graphs using Cardbox. 



      Personal uses of Cardbox  221 

 

Daybook 
If you have a scanner then you can implement a daybook using Cardbox. A daybook 
acts as a central file for all the correspondence you receive.  You can categorise the 
letters and give them keywords for indexing and retrieval.  The original paper can be 
stored in a box file somewhere, in case you ever need it as proof of something; but 
for ordinary use the Cardbox database will be far easier to search in, and you can 
always print out a copy of anything that you need. 

 

This is such a useful application of Cardbox that we give you an exercise that 
creates a simple daybook for you: see page 237.  You can store your important legal 
documents like this as well – leases and share certificates – so that you have a 
backup copy in case anything is ever lost or destroyed. 

Other uses 
Here are a few other personal uses of Cardbox that we’ve heard of.  There are sure 
to be many more: 

Bird watching Trainspotting Family history Christmas cards 

Concert 
programmes 

Photographs Videos & DVDs Newspaper 
cuttings 

Remember that there’s no hard-and-fast distinction between personal and business 
uses of Cardbox, so even if you’re an individual who’s using Cardbox, carry on 
reading: there may be something in the Business section that inspires you. 
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Business uses of Cardbox 
There are as many different business uses of Cardbox as there are businesses.  
There’s no way we can illustrate all of the possible applications of Cardbox, so we’ll 
concentrate on some of the commonest ones.  If none of them is an absolutely 
perfect fit, you can easily design your own. 

Customer relationship management 
At the simplest level, Cardbox can be used to maintain a database of names and 
addresses. Mailing labels can then be created for mail shots. However, many of our 
users have built more sophisticated customer relationship management applications 
using Cardbox.  We’ve heard of databases of almost a million records, with 
customers categorized by their fields of interest and their assigned sales staff.  Here, 
on a less epic scale, is the sample Contacts database that we distribute with 
Cardbox: 

 

This database design contains enough information to identify who added the 
customer; what the customer’s interests are; who is responsible for ongoing relation-
ships; when the last contact was and when the next contact should be.  The 
“Contacts History” field can contain a narrative of contacts so far, and because 
Cardbox lets you index as many words as you like, you can index the date of each 
successive contact and thus answer, very simply, questions such as “who did Gary 
talk to in the last week of October”? 
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Obvious additions to this database include an email address, which can be used for 
direct contact or (using the Professional Edition) can be used with macros to send 
bulk emails – just as the fax number can be used to send bulk faxes. 

Invoices 
Cardbox is not an accountancy package.  Nevertheless, it is often used for invoicing 
and account management, because most of what gets classified as “accountancy” is 
in fact database management, and Cardbox is such a flexible database. 

 

There are two main ways in which you can use Cardbox for things like invoices.  
One is to keep all the necessary information in the Cardbox database and then use 
mail-merging to generate the actual printed invoice.  The other way is what we have 
shown here, where the invoice itself is stored in a separate word-processing file and 
Cardbox simply does all the indexing and summarising.  Here are some of the 
questions that can be answered by a Cardbox database of this kind: 

• Have we dealt with these people before?  What is their payment history? 
• When was invoice 99999 issued? What was it for? Has it been paid? 
• Which invoices were issued last February? 
• Which invoices have not been paid for over 30 days? 
• What is our total turnover in the last VAT quarter? 
• How much of our revenue has been paid by cheque and how much by credit 

card?  Of the credit card revenue, how much was paid directly and how much 
through our web site? 

You can set up macros that will open the text of an invoice by clicking on a button 
next to the record; and you can perform processes including the checking of bank 
statements either manually or by running a suitable macro. 

Finally, you can export the data from Cardbox and produce a report suitable for 
passing to your accountants. 

To calculate a total for all 
records in the current 

selection: hold down the 
right mouse button over 

your chosen field, and 
when the menu appears, 

select “Total”.
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Time-critical situations 
Because its search engine is so fast, Cardbox is used for telephone help lines and 
support centres. 

 

For example, Cardbox is used at a chemical plant: when an accident occurs, 
Cardbox is used to identify the type of accident, to look up the first measures to 
control the situation, which people must be contacted, the severity of the alert and 
the probable risks.  The user tells us 

“Cardbox is excellent in situations where seconds count”. 

A poisons information bureau has used Cardbox to collate poisoning reports from 
doctors and the general public: collating the resulting information has led to such 
simple risk-reducing actions as changing the shape of the bottles used for surgical 
spirit (denatured alcohol) as well as discoveries that can lead to better focused 
public education: for example, that among teenagers poisoned by plant substances, 
there are significant sex-linked differences in the type of substance encountered. 

Airline safety managers use Cardbox to record and exchange data on safety-related 
incidents on a confidential and anonymous basis as part of their quality assurance 
process. 

Girls: morning glory seeds.
Boys: magic mushrooms.
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Membership databases 
The Galpin Society’s membership system is an excellent example of several 
Cardbox databases being used together.  The main database lists members and the 
ways of contacting them, their current membership status and the publications they 
have received.  An auxiliary database identifies all payments on a member’s 
account. 

 

This application makes extensive use of relational linking: when you move from one 
record to the next in the main database, the Payments and Subscription windows 
update themselves to match the new record. 

You can read all about 
relational linking in  

Help Point 500.
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Actors and casting 
A casting director had a problem.  He needed to cast actors for a play, but the 
market leading database of actors was virtually unusable.  Not only did it demand 
that searches be put into a rigid and inflexible search form: it was also then 
incredibly slow in its searching.  (To be fair, we should say that several years have 
passed and we are sure that the publishers have now greatly improved their 
offering).  So we converted the main Actors database into Cardbox for him. 

 

The 9,800 actors could now be searched instantly (the database, with pictures, was 
only 97MB), and the user could assess at once how many actors remained and 
whether he was making his search too vague or too specific.  “Contact sheets” of 
photographs could be printed out so that the production company could compare 
pictures of 24 actors at a time.  Extra Text was used for the CVs, which could vary 
widely in length. 

“Before Cardbox, we were peering through a keyhole and we never knew what 
we might be missing.  With the Cardbox database, we had the whole landscape 
in front of us and we could select, assess, and compare actors as much as we 
wanted.  For the first time we were in full control of the casting process”. 
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Scientific research 
Numerous research agencies use Cardbox. For example, Bangor University 
undertook some research into Indian crop cultivars.  

“We chose Cardbox for its simplicity and user-friendliness and because its use is 
very intuitive. Development practitioners in KRIBHCO and other organisations 
who are not information specialists will be involved in keeping the database 
updated and will answer queries.  A day's training programme is usually 
sufficient to enable users to design new databases and formats, conduct 
complex searches and print out records.  The database is being distributed on 
CD-ROM with an automatic installation procedure”. 

 

Academics are experts in their own discipline but not usually computer experts.  
With Cardbox it’s easy for them to set up databases that can be searched by other 
academics who are active in the same field, without having to get any computer 
departments involved.  
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Security 
Many police forces and defence services worldwide use Cardbox.  Department 
stores have used Cardbox to record details of shoplifters, which are then shared 
among local shops.  Here are some other security applications we’ve heard about: 

Accident investigations 
Aliens register 
Burglar alarms 
Child abuse 
Crime pattern analysis 

Domestic violence 
Emergency control room 
Evidence gathering 
Fraud investigation 
Keyholders 

Research into stop and 
search policies 

Security passes 
Stolen art and antiques 
Stolen vehicles 

Law 
Apart from the obvious uses in criminal cases, legal firms also use Cardbox to 
maintain their case records, libraries, and registers of wills, codicils and deeds.   

One of the barristers who use Cardbox maintains a record of work done in relation to 
every case, indexed by the client's name, a case reference number, and the date 
any work was done.  

“Setting up a record for each case enables me, with minimal effort, to keep an 
eye on progress with current work, and provides me with easy access to a 
wealth of information about completed cases. For example, I can easily check 
how many pieces of work have been done for each client, the expert witnesses I 
have worked with, the judge I appeared before, and when I last did a case 
concerning a specific area of law. It also tracks payments for each case, as a 
cross-check on the central Chambers system.” 

Medicine 
Apart from the academic uses of Cardbox in medical research, it has wider uses in 
hospitals and medical practices.  Here are some of them: 

Clinical audits 
Court cases needing expert witness 

declarations 
Drug registration 

Kidney transplant databases  
Patient records 
Publishing health information 
Sexual health 

The security features we have built into Cardbox are particularly important in a 
medical context.  One British hospital takes privacy a step further: the Cardbox 
database used for the psychiatric records of its own staff exists on only one 
computer, and that computer is kept in a locked room and deliberately not 
connected to the rest of the hospital’s network. 
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Museums 

Acquisitions 
Not the least problem facing museums that build massive archives is tracking the 
source of the items in their collections.  Here is the Cardbox solution, which makes it 
easy to search for particular classes of material, identify what each collection 
contains, and even contact the original donors if necessary. 
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Catalogues 
Museums are increasingly building online catalogues of their collections, and some 
of them are already accessible across the Internet using Cardbox. 

De Atlas Van Stolk (“the Van Stolk Collection”) is an important Dutch collection of 
historical prints and drawings.  The collection is housed by the Rotterdam Historical 
Museum, which maintains several databases including one of political cartoons and 
one of prints and drawings.  These contain full accession details and scanned 
images of the items in the collection: 

 

The Thackray Medical Museum does the same thing with one of its collections: see 
page 2 for an illustration. 

Administration 
The Rotterdam Historical Museum reports that apart from maintaining large image 
databases, Cardbox is also being used by the librarian for the library catalogue, the 
secretary to record correspondence, and the curators whenever they are setting up 
a new exhibition.  Once you start using Cardbox there is no reason ever to stop! 

Help Point 579 lists 
Cardbox databases that 

are publicly available 
across the Internet.

www.hmr.rotterdam.nl 
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Libraries 
You’ve already seen some uses of Cardbox that fit well in libraries – books (p.216) 
and other collections (p.230) – but of course there is a lot more to libraries than just 
catalogues.  Here are a few of the other things that librarians use Cardbox for: 

• Circulation 
• Inter-library loans  
• Orders and payments 
• Photocopies and copyright restriction management 
• Periodicals management 

Below, you’ll see a sample record from a periodicals management database that lets 
the librarian keep track of subscription status and whether all the required issues of 
a periodical have arrived.  It generates automatic claims for missing issues, which 
was formerly an onerous part of the librarian’s work. 

The Cardbox user who sent us this example has also set up other databases and 
tied them together with a macro that daily checks all databases for late orders, late 
loans, missing periodical issues etc, and generates for each staff member a list of 
their outstanding queries. 
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Cardbox for everything 
Once people get Cardbox for one purpose, they find more and more uses for it.  
Here is an extreme example.  Winifred West Schools Ltd is an Australian company 
that runs three educational facilities in New South Wales.  John Huskisson is the 
Property Manager responsible for all buildings, grounds and related infrastructure.  
He first came across Cardbox when he used it in the British Army to run the 
subscriptions database for an in-house newsletter. 

Here is a summary of the Cardbox databases that are being used to help run this 
organisation: 

Jobs – property management: a record of all maintenance jobs done since 1996.  
About 26,000 records. 

Indent – an online database of job requests.  Accessed by all staff across three 
campuses: records are then transferred to Jobs and allocated to work teams. 

Phonebook – corporate address, phone, email, and Web directory. 

Phonecalls – record of all external phone calls made.  Downloaded from the 
exchange as a text file, converted by WordPerfect and then loaded into Cardbox.  
Calculates cost of calls and prints bills using information from Authority Codes. 

Authority Codes – PIN numbers for the phone system and security system.  
Checks for duplicate PINs, generates issue letters to notify PINs to users. 

Stored Calls – archive of all calls made from the exchange (about 500,000 records). 

Paint – register of all colours used in all buildings, including paint codes and 
formulae and where the paint was applied. 

Chemicals – register of all chemicals held, with macros to calculate gross holdings. 

Keys – register of the current master key system (1,500 records). 

Meters – list of all gas, water and electricity meters. 

Email – allocates usernames and passwords to all new students and staff, and 
issues notification letters accordingly. 

School Reports – teacher entry formats and final report formats for the primary 
school. 

Trees – register of all trees on the campus: condition, work required, etc. 

Work Done Album – photographic records of all work done (eg. underground 
computer network cabling), linked to Autosketch plans. 

Warranties – register of purchases with warranty details and photographs.  

Frensham: secondary girls’ 
boarding school catering for 

300 girls.

 www.frensham.nsw.edu.au

Gib Gate: co-ed primary 
school catering for about 250 

from preschool to year 6.

 www.gibgate.nsw.edu.au

Sturt: craft centre educating to 
tertiary level and including a 

shop and café.

www.sturt.nsw.au  
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Other business uses of Cardbox 
Advertisers’ details 
Aerial images 
Alumni 
Architectural references 
Artists 
Assets registers 
Building maintenance 

records 
Burial registers 
Calibration records 
Car pass management 
Careers information 
Catalogues 
Civil engineering data 
Classic cars 
Client callouts 
Competitor research 
Computer equipment 

register 
Computer maintenance 

records 
Concert programmes 
Desiderata lists 
Disaster reduction training 
Drawing records 
Economic development 

data 
Faults reporting 
Financial services tracking 
Fleet records 
Glossaries 
Health and safety data 
Heirlooms 
Hire records 
Hotel guest cards 

Housing benefit case 
management 

Information databases 
Inventories 
Job sheets 
Legislation databases 
Local history records 
Local information 
Local business support 

databases 
Logging hardware and 

software faults 
Logistics 
Mailing lists 
Maintenance records 
Manufacturing data 
Map collections 
Meetings data 
Motorway structures 
Music 
Nature conservation 

information 
Newspaper archives 
Object catalogues 
Order tracking 
Passenger lists 
Patent databases 
Personnel management 
Photographs 
Pictures 
Planning decisions analysis 
Plant databases 
Population data 
Prize winners 
Production analysis records 

Project management  
Property database 
Property management 
Purchase ordering system 
Quality control 
Questionnaire analysis 
References 
Regimental associations  
Safety checks data 
Sales control and 

forecasting 
Service records 
Ships information 
Skills database 
Slides and negatives 
Song files 
Sports club player statistics 
Staff phone directory 
Statistics 
Student registers 
Subscription records 
Supplier indexes 
Telephone directories 
Telephone information for 

the disabled 
Theses collection 
Trade union membership 
Train journeys 
Training records 
Translators data 
Truck specifications 
Vacancy database 
Vehicle registrations 
Vocabulary database 
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Exercises and samples 
Now that you’ve seen what Cardbox can do (and perhaps been inspired to use it for 
more than the original purposes you had in mind), you’re practically ready to design 
databases for yourself. 

Designing databases isn’t something that most people do very often, and a design, 
once it’s been done, needs to last a long time, so to get you used to this kind of 
thinking we’ve created some exercises for you to follow.  Each exercise takes a 
simple and useful database design and takes you through the steps of creating it.  
We’ve taken to give you a lot of explanation of exactly why you’re doing what you’re 
doing.  We hate those so-called manuals that say nothing but “click here, press this 
button” for page after page without ever telling you what it all means and what it’s all 
for.  We don’t plan to make the same mistake. 

Quite apart from giving you some more expertise, the database designs we’ve 
chosen are useful in their own right and you may find that you can build on them to 
create exactly the design you want. 

All these exercises, with their accompanying explanations, are pretty long, so we’ve 
put them into Help Points, where you can read them easily or print them out.  What 
we’ll do here, on paper, is sell the exercises to you: we’ll tell you why each one is 
useful, what it’ll teach you, and what the resulting database will be like. 

We do recommend that you go through each of these exercises because they give 
you practical experience of building a new format; but if you really don’t have the 
time, we give you the database files that would result from each exercise, either on 
the CDROM or as a download. 

The instant address book 
At the back of your Filofax (or some other brand of personal organiser) you probably 
have a large collection of addresses.  This is quick and easy to maintain but it’s also 
vulnerable: there are therapists who make a living counselling people who lose their 
Filofaxes and feel they’ve lost their lives along with them. 

This database is the quickest and simplest address database imaginable.  Its sole 
purpose is to let you look up addresses (and phone numbers, and email addresses) 
quickly, and to let you print these addresses out onto Filofax-sized paper so you can 
put them into the back of your personal organiser.  The good thing about doing this 
on a computer is that you can back it up, so that losing your address book or even 
your whole computer doesn’t mean losing your life. 

Having the database in electronic form has other advantages, too.  You can classify 
some people as “Reference only”, so that you don’t waste paper on them but you 
don’t lose touch either.  And you can print out selective lists to take with you when 
you go on holiday. 

You can find this exercise 
at Help Point 610.

Help Point 600 tells you 
how to get the database 

files for each exercise.
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Here is a sample record in the native format of the database.  It has only five fields: 

 

Name – the person’s name, with the surname indexed.  This makes it easy to 
search for people by name and also makes it possible to sort the records quickly 
into alphabetical order.  If you ever need to search for a first name, you can use 
a Data search to find it. 

Phone numbers – one field containing all the person’s phone numbers.  There is no 
need to have different fields for the different numbers because you’ll never want 
to see them separately. 

Email address – this can be cut-and-pasted into an email application. 

Address – this is simply written as continuous text, because this database isn’t 
designed for creating mailing labels or mail-merged letters. 

Class – this can be used for classifying addresses to make selective lists easier.  
For instance, you can use “Ref” to designate addresses that shouldn’t be printed 
out, so that your printed address list can be concise and your computer address 
list can be complete: this is perfect for friends you’re not really interested in 
contacting but don’t want to lose touch with altogether.  You can have as many 
codes in this field as you like, for different kinds of classification. 

As well as the native format, there’s an alternative format that you can use to print 
out pages ready for insertion into your personal organiser: you can see an example 
on the left.  The print doesn’t have to be this small: it’s something you decide when 
you design the format. 

Help Point 610 takes you through every step of designing this database and 
describes various enhancements: for instance, you can set up the format so that 
clicking on the email address will open a new email to the person concerned. 

The intelligent address book 
This database is a bit more work to set up but it does more for you.  It is more work 
because it has more fields, but the reward of having those extra fields is that it can 
understand your data a little better.  As well as viewing records on the screen, you 
can make mailing labels from them or create standard letters.  You can categorize 
people not just by their names but by their location.  This can be the core of a 
contacts database for personal or business use, and you can expand it with extra 
fields, to perform more and more sophisticated selections.  

You can find this exercise 
at Help Point 620.
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Here is a sample record: 

 

Name – the person’s name, with the surname indexed. 

Address – the address.  We’ve made this four lines long: if you come across an 
address that’s longer, type it in anyway, because Cardbox doesn’t limit the 
length of text that you put into a field, and it’ll all be visible when you print things 
like mailing labels.  If you often have long addresses, just make the Address field 
longer.  We’ve chosen to index just the name of the town, since that’s what 
likeliest to be used for searching, but you can make your own rules. 

Tel, Fax, Mobile – these are all separate fields, so you can decide which of them to 
include in any particular native format.  If you have the Professional Edition and 
the appropriate software, you can also connect the telephone number to a phone 
dialler or use the fax number to send automated faxes. 

Email – this has the special caption “mailto:”.  Cardbox recognises this caption and 
turns it into a clickable item: when you click on it, your email program will open 
with a blank email to the person concerned.  

Web address – here, the caption is “http://”.  When you click on this, your web 
browser will open the person’s web page (if the person has a web page: 
Galahad doesn’t).  

Once you have the data in your database, you can easily display your records as a 
summary (above left), or as mailing labels (see left), or indeed in any other format 
you need.  
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Adding extra fields to the address book 
You can add fields to this design if you want to do more sophisticated things with 
your data.  This exercise gives you one example: adding a couple of fields to control 
the sending of Christmas cards.  We’ve chosen Christmas cards as an example 
because they’re a chore that most people can relate to; but of course selective 
mailings are an important part of almost any commercial activity. 

Simple document management 
This database stores all your incoming correspondence so that you don’t have to 
wade through piles of paper when you want to find a letter or document.  The key to 
this exercise is that you scan the letters you receive into your Cardbox database, 
and you use Cardbox fields to assign categories and keywords so that you can find 
the documents again.  You can read the documents on the screen or you can print 
them out. 

Most of the time you won’t need to look at the paper originals ever again, but if you 
do want to keep some of them (they may be official documents that prove something 
important), that’s easy too.  You give each document a number when you put it into 
Cardbox, and then you can put all the pieces of paper you want to keep into a single 
binder, in numerical order.  When the binder gets full you just start another binder. 

You can see a picture of this database on page 221.  There are six fields apart from 
the scanned document: 

Date – so you can select correspondence by date or sort it into chronological order. 

Number – a reference number.  If you have the Professional Edition then Cardbox 
can assign numbers for you automatically.  You use the numbers if you need to 
look up the paper original of something you’ve scanned. 

To/From – whether it’s something you’ve sent or something you’ve received. 

Name – this can be the name of the person or the name of the organisation.  If you 
want to store both pieces of information, you can create an extra field. 

Category – this is a drop-down list of possible classifications.  Making it a drop-
down list saves you having to type the name and also makes certain that you 
only ever use one of the pre-defined classifications.  If you decide you want an 
extra one, you can easily edit the native format to add it to the list. 

Description – we’ve made this very brief because its only job is to tell you whether 
it’s worthwhile pressing F12 to look at the document.  There is nothing to stop 
you making the field longer, and even indexing to make it quickly searchable. 

If you work from multiple locations then you can take this whole project one step 
further: put the database on a Cardbox Server and make it accessible across the 
Internet, and you can read all your papers wherever you happen to be.  If you have 

You can find this exercise 
at Help Point 630.

This supplementary 
exercise is at 

Help Point 621.
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a personal assistant, you could even get your PA to do all the scanning for you, so 
that reading the day’s letters simply means starting Cardbox and having a look at 
what’s been added to your database. 

Even if you haven’t got a scanner it’s still worth going through this exercise, because 
Cardbox is still an excellent way of classifying and finding papers even if you have to 
open a physical file to read the original documents.  In this case you’d probably 
make the Description field longer, so you can be quite sure that the document is the 
one you want before you dig it out. 

A photograph album 
If you have prints, you can use a scanner to scan them in to Cardbox: in that case 
the image in Cardbox is only a scan of the original print, and you should keep the 
originals filed away because they will be of better quality.  If your photographs are 
from a digital camera, PDA or mobile phone, you’ll be able to import them directly 
into Cardbox, probably without loss of quality if they are in JPEG format. 

You can index your photographs, number the frames, and add keywords and dates. 

You can search for and select photographs.  You can print individual ones at full size 
or you can tag the ones you are interested in and print them out as a contact sheet.  
If you want to have reprints made for your friends, you can administer this easily by 
having an extra field to hold the friends’ initials. 

Other visual things can be handled in the same way.  You could take photographs of 
your most treasured possessions so as to be able to give them to the police or your 
insurers if anything happens. 

 

You can find this exercise 
at Help Point 640.
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Bibliographies 
This exercise takes you through the process of creating a simple bibliographical 
database that can handle both books and articles from journals.  You can use this to 
print search lists that you can take to the library with you; you can add your own 
comments to each reference; and you can print out bibliographies in the right format 
for inclusion in a paper or a thesis. 

 

Here is what the various fields are and what they mean: 

Title, Author – the title and author of the work. 

Publisher, Where, When – the publisher and the place and date of publication.  
These fields only apply to books, so we’ve given them a different background 
colour to distinguish them from the others.  Cardbox lets you give any element in 
a format a different appearance from the others, and this can be useful to help 
you navigate through filling in a big form. 

Journal, Details – the name of the journal and the exact volume, date and pages 
involved.  These fields don’t apply to books, so again we’ve given them a 
different colour. 

Library, Shelfmark – finding the things you want to read is a time-consuming part of 
academic research, and these fields help to organise it and make sure that you 
don’t waste time by losing references. 

Keywords – how thorough you want to be about developing a set of keywords and 
applying them consistently depends on the kind of project you are doing and 
how you are approaching it.  We’ve given you one smallish Keywords field, but 
of course the size of the field is up to you, and you can add other fields if you 
like.  The keywords don’t need to appear on any printed bibliography: they are 
for your use only. 

You can find this exercise 
at Help Point 650.
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Book/Article/Other – note that this is just a single Cardbox field, displayed as a set 
of radio buttons to make it clear what the options are and to make sure you only 
choose one of them.  This field is searchable, so you can search or print out just 
one kind of material if you choose. 

Primary/Secondary – serious research often requires you to distinguish between 
primary and secondary sources.  If you don’t need this field then you can leave it 
out of the design. 

Extra text – although we haven’t printed it here, this is a good place to use the Extra 
Text field.  You can use it to contain your comments on the contents or even the 
usefulness of the book or article, and you can view each record on its own or 
together with its Extra Text. 

Alternative formats 
Alternative formats come into their own in this database.  You have alternative 
formats for printing out bibliographies of books and of articles; a summary format to 
take to a library; and a one-line format that is useful when you want to view a lot of 
records at once while searching.  Help Point 650 describes how to create all these 
and how to use them. 
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Thinking about fields 
As you can see from the examples, a lot of the effort in designing a Cardbox 
database goes into deciding how to divide a record into fields.  Although it’s easy to 
add and delete fields even after you’ve created a database and started putting 
records into it, it’s better to get things more or less right from the start. 

Human fields and computer fields 
This is an aspect of field design that you ought to consider when you are setting up 
your own database.  We might call some fields in a database “human” fields, 
because their function is to tell you something, and as far as the computer is 
concerned they are just a piece of text to be displayed or printed in the right location.  
A good example would be the Instant Address Book exercise (p.234) where the 
address and the phone numbers are both just intended to be looked at or printed out 
in a list.  The addresses aren’t in a suitable format for turning into a mailing label and 
the phone numbers can’t be used to make phone calls or send faxes automatically 
at the press of a button.  But then that’s not what this database was meant for, and 
the extreme simplicity of the fields makes it much easier to enter data into them.  
You don’t have to be consistent about the way you type area codes, or whether you 
always put the name of the town into the address. 

On the other hand, the Intelligent Address Book exercise (p.235) arranges the 
address in lines, so that it will work in a mailing label, and it keeps phone numbers 
and fax numbers separate, one field for each, so that it’s easy for an autodialler or a 
bulk fax macro to find them.  You can think of these fields as “computer” fields.  It’s 
more effort filling them in because you have to be more aware of what goes where; 
but the benefit is that many more automatic processes become possible. 

The same sort of thing applies to dates.  You can write dates in many different 
formats, and a human being can understand more of them than a computer can.  If a 
date is just for your own information, you can write it as “25 March” one moment, 
then as “25/3/2004”, then as “25\03\04”.  But if this is a field you’ll want to search or 
sort on, you should impose a discipline right from the beginning, choosing a date 
format that the computer can understand, and sticking to it.  The trade-off is the 
same as before: you need to put more work in at the beginning, but the resulting 
automation saves a lot of work later on. 
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When to split fields 
In a database of contacts, there is nothing to stop you having a single name-and-
address field several lines long.  It will work: you will be able to search for words and 
you will be able to print mailing labels and standard letters. 

So when should you split a big field into two? There are three main reasons: 

Presentation – Suppose that you want to print a summary that just lists people’s 
names.  With your big name-and-address field, you can’t: it’s all or nothing.  But 
if you split the big field into two, one field for the name and one for the address, 
you can easily include the name in the report and leave out the address. 

Searching – If you search for “Kent”, are you looking for Clark Kent or for the county 
of Kent?  If they’re all in the same field, there’s no way for Cardbox to know 
which is which, and it’ll have to deliver you all the Kents and let you sort them 
out.  So there’s another reason for separating name and address. 

Sorting – If you want to sort the records into alphabetical order, the first question is 
“alphabetical order of what?”.  If the name and address are in the same field 
then Cardbox will always see the name first, and will sort on that.  Splitting them 
means that you can sort on the address if you want. (This is tied up with indexing 
policy: we assume that you’ll be indexing the surname of the person and the 
name of the town).  Moving to an international context, you might need to sort by 
country first, and then location within the country, and then by name.  In that 
case you’d better have a separate field for the country. 

It’s never too late 
What if you’ve been building a database with a single big name-and-address field 
and then decide that you want to split the field into a name and an address? 

The easiest way of converting your existing data is to use a Batch Edit.  After you’ve 
created a separate field for the name, go to the first record you want to convert, do 
Edit > Batch > Edit, and then cut and paste the first line of your big field into the new 
name field.  Cardbox will then repeat the same actions for every record in the current 
selection. 
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When not to split fields 

The form disease 
The form disease is something you catch from filling in too many official forms or 
using the Web too much.  It results in format designs that look like this: 

Mr John Q. Public III 

There’s hardly ever a good reason for doing this.  More primitive databases need to 
have the surname in a separate field to make it easier to search and sort, but 
Cardbox lets you index any word you like, so the more sensible solution is to have a 
single field for the name and then index just the surname.   

Sometimes the excuse for using lots of tiny fields is that you’re trying to use the data 
to create a salutation for use at the start of a letter: the idea is that you’d use all 
fields when you wanted to print the person’s full name and just fields 1 and 4 when 
you wanted to say “Dear Mr Public”.  This is good in theory but it never really works.  
Problem names include Sir Percy Blakeney  (Sir Percy), Lee Kuan Yew (Mr Lee), 
and Salvador Dalí Domenech (Mr Dalí).  If you really want personal salutations, have 
one field for the name and one for “Dear”, and fill in both fields yourself: a human 
being can handle the subtleties much better than a computer. 

The line disease 
The line disease is something you catch from using database programs that can’t 
cope with fields more than one line long.  So you get 

ADDRESS LINE 1 Chadwick House 

ADDRESS LINE 2 Cley-next-the-Sea 

ADDRESS LINE 3 near Holt 

ADDRESS LINE 4 Norfolk 

ADDRESS LINE 5  

instead of having a single field for the whole address.  This makes form design more 
complicated and it makes editing more difficult: if you need to insert an extra line at 
the beginning of the address, you’ll have to move line 4 to line 5, line 3 to line 4, and 
so on, instead of just typing a new line.  Worst of all, it also makes searching more 
difficult because if you’re searching for a word in the address, you won’t know which 
line it’s in, and you’ll have to search each of the five separate fields. 

Make the address into one big multi-line field and you’ll save yourself a lot of trouble. 
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The keyword problem 
This is also caught from other database programs.  If you need to have keywords for 
a book or an abstract, and you’re using a program that indexes fields but not the 
words within fields, then you have to create several keyword fields so that an item 
with multiple keywords can be properly indexed.  You have to guess what the 
maximum likely number of keywords is, and provide that many fields.  Once again, 
this makes searching a nightmare. 

Cardbox can index as many words as you like within a single field, so you should 
create one keyword field and put all your keywords into it. 

The check box problem 
This is yet another problem that comes from experience from other databases.  
Suppose that you are running a recruitment database and you want to indicate the 
skills that each candidate has.  With a traditional database the only way to do this 
searchably is to have a single Boolean (Yes/No) field for every possible skill.  This 
uses up a lot of screen space and a lot of space in the data file, and whenever a 
new skill needs to be added the database format needs to be redesigned. 

If you are used to that kind of database, do not replicate its behaviour in Cardbox!  It 
is far simpler to have a single “Skills” field and to fill it with check boxes.  Each check 
box has a corresponding keyword in the field: for example, you could set it up so 
that if you clicked on the check box marked “Japanese”, the word “Japanese” would 
be added to or removed from the field, and if you clicked on the check box marked 
“Latvian”, the word “Latvian” would be added or removed.  There is no limit on the 
number of words you can have, and index, in a field, so there is no limit on the 
number of check boxes either.  The word in the field doesn’t have to be the same as 
the word on the check box: some recruitment agencies use numeric codes to 
indicate skills, while still keeping readable text on the check boxes. 

We used skills as an example, but the problem is quite a common one.  Whenever 
you have a number of attributes that either are or are not present, consider 
combining them all into a single field, where the presence of a keyword indicates 
that the attribute applies and its absence means that it doesn’t. 

When to break these rules 
If you’re regularly transferring data backwards and forwards between Cardbox and a 
less flexible program, you may feel that you want to adopt the other product’s field 
layout, however irrational it may be.  If that’s what you need to do, then do it: it isn’t 
the most advantageous way of using Cardbox, but it’ll still work.  This is the best way 
of doing things, for example, if you have a central contacts database in Cardbox and 
want to transfer data into something like the Palm Address Book, whose fields have 
been decided by Palm and can never be altered. 

Help Point 622 gives an 
example of output to the 

Palm Address Book.
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If the only difference between Cardbox and your other programs is the use of multi-
line fields such as addresses, you don’t have to compromise your Cardbox design.  
You will almost certainly be using comma-separated (CSV) format to transfer data 
between the programs, and Cardbox can automatically split a multi-line field into 
separate CSV “fields” on output from Cardbox to CSV and join them back together 
on input. 

Auxiliary fields 
It can be a useful technique in Cardbox to create a field just to help you with data 
manipulation or sorting.  The field will duplicate information that you’ve already got in 
your database, but in a subtly different format.   

Here’s an example: 

Most English-speaking telephone directories treat the prefix “Mc” as being the same 
as “Mac” when sorting names into alphabetical order – so that McHugh comes 
before Mackenzie, and they both come before Mbeki.  Cardbox, like all computer 
programs, compares words letter by letter, so if you want to have this kind of sorting, 
how do you get Cardbox to do it? 

The answer is to create an extra field (let’s call it field S) that contains the surname 
modified so as to sort in the right order.  In this case, you’d copy the surname into 
field S, then you select all the names beginning with “Mc” and do a batch edit, 
editing field S to change “Mc” into “Mac” but leaving the original name field 
unchanged.  Thus McHugh would be “McHugh” in the name field but “MacHugh” in 
field S.  If you then tell Cardbox to sort records into sequence using field S, the 
records will come out in the order you want.  Field S would have no other use: you 
wouldn’t use it for searching and you’d never include it in any printed output. 

You could extend this principle to handle other lexicographical conventions: if your 
sorting rules demand that “De Wiart” should come after “Dewey”, you could further 
edit field S to remove all spaces.  And rather than rely on batch editing, you could 
create a macro that was used during data entry (activated by a pushbutton) to read 
the real surname and turn it into a properly reformatted name in field S. 

That was a very specific example, and you may never be involved in that degree of 
sophistication; but remember that it costs nothing to create a field in Cardbox and 
the mere existence of an extra field doesn’t make the database any bigger, and be 
aware of auxiliary fields as a possible solution when you’re trying to process the 
same data in several different ways. 

Help Point 623 describes 
the splitting and rejoining 

of fields.
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Narrative fields 
Often, you’ll want to include some history in your fields.  A barrister’s database can 
be updated with details of the progress of each case; a recruiter’s or negotiator’s 
database may have a narrative of who contacted whom when, and what was said. 

 

Cardbox’s indexing makes it easy to do this in a big long field.  You can index all the 
relevant dates, as well as any other words that you might want to search for later on.  
The example in the picture puts all the notes together in one paragraph, but you can 
equally well have each entry on a separate line.  You can arrange have the entries 
with the oldest one first (as here), or you can always add new entries at the 
beginning so that you see the most recent one first. 

This field also uses validators to put all dates into a standard format and index them: 
this saves time and thought during data entry. 



 

 

Part Seven 
Safety and Security 

Backup and disaster recovery; passwords and user 

profiles; encryption. 
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Backup and disaster recovery 
Computer systems are fallible.  Sooner or later something will go wrong.  Examples 
of what can go wrong include hardware failures (your hard disk becoming 
unreadable, your computer crashing, a power failure), software failures (Windows 
corrupting your files or simply crashing) and operator error (deleting your most 
important database by mistake). 

You should take frequent backup copies of your data so that you can restore your 
databases if anything does go wrong.  If you have recent backups and something 
catastrophic happens to your computer you can laugh, go out, and buy another 
computer. 

With the cheapness and capacity of modern backup media – you can get ten blank 
CD-Rs for the cost of a sandwich – there is no excuse for not backing up often.  We 
back up to CD-RW daily and to CD-R twice a week; and we keep the CD-R backups 
forever.  You should plan a similar strategy. 

We cannot give you detailed instructions for making a backup because this depends 
on your system, your hardware, and your software.  We can, however, tell you which 
files need to be backed up and where they are located. 

Before you back up 
You should make sure that all your copies of Cardbox are closed before you do a 
backup, or at least that all the copies of Cardbox that use a particular database are 
closed before you back up that database.  If you don’t do this, the backup may fail, 
or it may omit data that are stored in memory but have not yet been written out to 
the disk. 

What files you need to back up 

Databases 
Each Cardbox database occupies two files.  The format file (filetype .fmt) contains all 
the format definitions for the database; the database file (filetype .fil) contains all 
your actual data.  These files always live together in the same directory or folder.  If 
you’re not sure of the location of a particular database, switch to a Cardbox window 
that contains it and use Window > Properties to find out. 
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Environment and settings 
Workspaces, macros and spelling dictionaries are all stored in separate files, and in 
order to back them up you will need to know where they are. 

Workspace files (filetype .cbw) – these store information about your workspaces, 
including the names of all the databases that are open and the current selection 
within each one.  Losing a workspace file is not disastrous but it is inconvenient.  
To back up a workspace file you need to know its location: if you’re not sure of 
this, use File > Workspace to find out. 

Macros (filetype .cbs) – if you use macros, each macro will be stored in a separate 
file.  The location of a macro file depends on the macro’s association: General 
and Workspace macros are stored in fixed locations (use Tools > Options » 
Macros); Related Databases macros are stored in the same directory as the 
relevant database; and macros specific to a single database are stored in a 
directory whose name is derived from the database name, so that (for instance) 
the macros for mydata.fil are stored in a directory called mydata.fil.cbs.  

User spelling dictionaries (filetype .tlx) – these files store the words that you have 
decided should be valid even though they do not exist in Cardbox’s standard 
spelling dictionaries.  The user dictionaries have filenames starting with ud.  
User dictionaries for a database are stored in the same directory as macros for 
that database; more general user dictionaries are stored in the same directory as 
general macros, but this can be overridden by Tools > Options » Spelling. 

Registry settings 
Following the requirements of Microsoft Windows, many Cardbox settings are stored 
in the Windows Registry.  If your backup schedule includes regular Registry 
backups, there is no need to do anything special.  However, many backup software 
packages do not contain provisions for backing up the Registry, and in any case the 
whole Registry may be inconveniently large. 

Tools > Management > Save Cardbox Registry Settings will save all the Registry 
settings for Cardbox to a file of your choice, which you can then back up.  The file 
will have the filetype .reg, and you will be able to restore your settings simply by 
double-clicking on the file in Windows Explorer. 
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Disaster recovery 
If a database file becomes corrupted, you may find that your searches don’t find the 
records you expect, or that you get error messages, or that some records are 
displayed as a pattern of cross-hatching.  In this case, if it is not reasonable or 
possible to go back to a backup copy, use Tools > Management > Rebuild > 
Database.  This command will scan the database, identify all the recoverable 
records, and build a new database containing just those records. 

If a format file becomes corrupted, you may find that some formats are not 
retrievable.  If you can’t go back to a backup copy, use Tools > Management > 
Rebuild > Format File.  This will create a new format file containing just the formats 
that are retrievable. 

If you lose your format file altogether, Tools > Management > Rebuild > Format File 
will scan through the database and create a native format that allows you to see the 
data in your records.  This format will require a lot of editing before it’s much use 
(you will need to give the fields meaningful names and rearrange their layout based 
on your knowledge of the data) but at least your data will not all have been lost. 

Dealing with an old backup 
If you don’t back up very often, you can be faced with a dilemma if something goes 
wrong.  You may be faced with a week-old or month-old backup file on the one 
hand, and, on the other hand, a corrupted database file that contains the work that 
has been done in the past week or month.  Help Point 573 tells you how to deal with 
this situation (it involves a lot of tedious manual work but is better than having to 
type everything in again), but it is far better to avoid the problem by being rigorous 
about backups. 

Backing up databases on the Cardbox Server 
Databases on a Cardbox server can be shared among many users and it isn’t 
always easy to be sure that no-one is going to use a database when you want to 
back it up.  In addition, the server may be storing its files somewhere where you 
have no direct access to them. 

The separate documentation for the Cardbox Server describes how to tell the Server 
to make a copy of the database file so that it can be backed up; but in some cases 
you won’t have the necessary administrative access to the Server (even though you 
may own the database), and so Cardbox provides a simple alternative. 

The command Tools > Management > Download lets you download a copy of a 
database or format file from a Cardbox server to your computer.  Once you have 
done this, you can back up the file from your computer in the usual way.  
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After you’ve downloaded a file and backed up the downloaded copy, leave the 
downloaded copy on your computer.  The next time that you do a download, the 
Download command will be able to compare your copy of the file with the server’s 
copy and just download the changes: this will make the whole download process a 
lot faster. 

• It is a good idea to give the downloaded copy of your database a different name 
from the name it has on the server: this will help to protect you from opening the 
downloaded copy by accident when you meant to open the real database. 

Things that don’t harm Cardbox databases 
If you are using a database on a Cardbox server and not on your own computer, 
nothing that goes wrong with your computer can affect the database.  If your 
computer crashes, the Cardbox server will simply note that you are not connected 
any more and will carry on as usual. 

If you are using a database on your own computer, and your Cardbox program 
(cardbox3.exe) crashes, your data will probably be safe as long as Windows doesn’t 
collapse as well and bring your whole computer down with it.  This is because all the 
actual database access is done by the Cardbox Engine cbox3eng.exe, which is a 
separate program that runs invisibly in the background, has no direct contact with 
you and therefore usually doesn’t crash. 

Although we cannot exclude the possibility that some bugs remain in Cardbox, the 
biggest potential cause of database corruption is system crashes and power failures, 
where some data don’t get written safely to the hard disk.  If you do suffer a power 
failure while adding or editing records in a Cardbox database, we recommend that 
you do Tools > Management > Rebuild > Database just to be on the safe side. 
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Passwords and user profiles 
Normally, if you tell Cardbox to open a database, it opens it.   

Most of the time this is perfectly satisfactory because either you are the only one 
with access to your computer or you trust the other people who also have access to 
it.  But in a corporate environment, and especially if databases are being shared 
across a network, you may want to set up password protection and you may even 
want to give different classes of users different degrees of access: for instance, to 
allow some people to make changes while others can only search the database and 
not modify it. 

Cardbox gives you this kind of access control by means of user profiles.  A user 
profile defines what the user is allowed to do – what fields and formats are visible 
and what commands are allowed.  User profiles are protected by means of 
passwords, so you can control who has access to your database by controlling who 
gets which profile name and password.  Here are a few sample schemes to give you 
an idea of how the whole thing works: 

Simple password protection – one single profile, permitted to do anything, 
protected by a password. 

Data publishing – two profiles.  One, password-protected, is permitted to do 
anything.  The other, without a password, is restricted to read-only access and 
cannot see certain administrative fields.  The second profile can also be made 
the “default profile”, which means that Cardbox will automatically use it when the 
database is opened. 

Online data publishing with subscriptions – a master profile, password-
protected, for use by the publisher.  One password-protected profile for each 
subscriber, specifying what he is allowed to see.  If the subscription isn’t paid, 
you delete the relevant user’s profile. 

Internal corporate database – a profile for administrators, a profile for normal 
users, a profile for managers, each with its own password and permissions. 

If a database has user profiles, then Cardbox will ask each user for a profile name 
and password on opening the database.  There are a couple of exceptions: you can 
designate one profile as the default profile, which means that Cardbox will choose it 
automatically; and you can also create profiles that don’t have a password.  If you 
have a default profile without a password, Cardbox won’t ask the user for anything 
on opening the database but will go straight in to using the default profile. 

Once a database is open, the user can change from one profile to another at any 
time, by using File > User Profile. 

Only the Professional 
Edition is able to set up 

user profiles, but any 
edition of Cardbox can 

use them once they have 
been set up.

For a simpler subscription 
publishing scheme, see 

Help Point 585.

See “User Profiles” on 
page 41 for a full 

description of how  
profiles work from the 

user’s point of view.
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What a user profile contains 
Each user profile has a name and a password.  The password is optional.  The 
profile can be visible or invisible: invisible profiles don’t appear in the list that 
Cardbox shows when opening a database or in File > User Profile.  One profile can 
be designated as the default profile: Cardbox automatically chooses this when a 
database is opened for the first time. 

For each field, the profile specifies whether the field is read/write (full access), read-
only (the user can view the field but not make changes) or invisible (the user can’t 
see the field’s contents or do searches on the field). 

For each format, the profile specifies whether the format is read/write, read-only, or 
invisible.  It can also specify the default format for the profile: this is the format that 
will be used when the database is opened using this profile. 

The profile also specifies whether the user is allowed to perform certain actions, 
including adding records, editing records, deleting records and editing formats.  Help 
Point 516 has a full list of the actions that can be controlled by a user profile. 

The very first profile to be created for a database is called the master profile, and we 
sometimes call its password the master password.  The master profile is the only 
one that can be used for certain highly sensitive operations, such as setting up user 
profiles or encrypting databases. 

How to set up user profiles 
Tools > Management > User Profiles lets you manage user profiles.  If you have 
already set up user profiles for this database, the command will ask you for the 
master password; if you haven’t, it will ask for the access code for this copy of 
Cardbox.  Cardbox has to be cautious at this point to prevent an unauthorised 
person from preventing access to your data. 

 
If this is the first time you are setting up user profiles, Cardbox will ask you for the 
password of the master profile.  The master password is important: you should write 
down a copy of it and keep it in a secure place. 

See “Restricted 
Operations”, p. 256.
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Cardbox asks for the password twice.  The first time, you can see the password on 
the screen as you type it, so that you can make sure that you are typing what you 
think you are typing.  The second time, the password appears as a row of asterisks.  
If you don’t type the password exactly the same way each time, Cardbox will reject 
the password. 

 
You will see a window with a list of available profiles on the left.  If you select one of 
these profiles, the right-hand side will show you the details of the profile. 

To add a new profile – press New. 

To delete a profile – select it in the list and press Delete. 

To modify a profile – select it in a list and then modify its details on the right-hand 
side. 

When you have finished making changes – press OK. 

For detailed instructions, 
press F1 while the 

Manage User Profiles 
window is open.
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Security of user profiles 
If your databases are only being accessed through Cardbox, user profiles are 
secure: as secure as the passwords you choose. 

If a disk or CD containing your database files is stolen, the thief may conceivably be 
able to see your data even if they are protected by profiles.  This is because a 
profile-protected database is not encrypted, which means that programming 
techniques such as taking a hexadecimal dump of a file would reveal readable data.  
The data would not necessarily have much meaning in that form, but with a certain 
degree of hacking expertise, a copy of Cardbox for conducting experiments, and 
quite a lot of patience, a thief might be able to remove the password protection from 
a database.  We have never heard of this being done, but if you want your files to be 
absolutely secure even if they are stolen, you should encrypt them. 

What happens if you lose a password 
Profile passwords cannot be recovered if they are lost, but the holder of the master 
password can use Tools > Management > User Profiles to assign a new password 
to the profile. 

If you lose a master password then we can help.  You will have to contact us for the 
exact details, but normally we will need both your database file and your format file, 
we will need evidence that you really are the owner of the data, and we will charge 
you quite a lot of money for resetting the master password. 

To avoid all this trouble, write down your master password and keep it in a safe 
place. 

Restricted operations 
Setting up user profiles and encrypting a database are powerful tools and in the 
wrong hands they could be dangerous: imagine if a disgruntled colleague could stop 
by your computer and password-protect your databases without your permission.  
Cardbox provides two kinds of protection against this.  If user profiles have been set 
up for the database, then only the owner of the master profile can perform a 
restricted operation. 

If user profiles haven’t been set up, then Cardbox asks for an “access code”.  The 
access code is a number computed from the serial number of your copy of Cardbox.  
We give out access codes only to registered users of Cardbox.  You can ask for an 
access code when you register, or you can ask for it later on when you decide that 
you want to use encryption or user profiles.  
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Encryption 
For complete security, you can encrypt your database.  An encrypted database 
cannot be read by anyone who does not have the key. 

What encryption protects you against 
If someone steals your backups, or makes a copy of your database files, he will not 
be able to read your database unless he has somehow also got hold of your 
encryption key.  The database remains permanently encrypted even while you have 
it open: Cardbox simply decrypts portions of it after it has read them from the disk 
and before it makes any use of the data it has read.  The reverse process happens 
when Cardbox has to write to your database file: it encrypts the data just before they 
are written to the disk. 

If someone stops by your desk at lunchtime and copies your database files to a hard 
disk in his pocket, you are safe.  If someone steals your backup CDROMs, you are 
safe. 

An attacker with sophisticated technical skills who has direct access to your 
computer may be able to install a program that subverts its operation and sees the 
data that you are retrieving: this is not a trivial task and the considerable investment 
required would only be justified in cases of high-level industrial espionage or criminal 
investigation.  If a forensic expert removes your computer’s hard disk for analysis 
then he may be able to see odd decrypted fragments that Windows has written to 
temporary work areas on the disk.  A complete database cannot be retrieved in this 
way but it is conceivable that enough fragments might be present to give a clue as to 
the nature of the data on your computer. 

Only the database file is encrypted: the format file is not.  The format file contains no 
data records but it does contain all the formats you are using: so, for example, if you 
are running an extortion business and use formats to create standard letters to your 
victims, those will not be encrypted and will be physically readable (although setting 
up user profiles would offer you limited protection: see page 41). 

Encryption and the law 
In some countries it is illegal to encrypt data.  Other countries have restrictions on 
the use of encrypted data.  In the United Kingdom it is a criminal offence to fail to 
reveal an encryption key when ordered to do so, and it is also a crime to reveal that 
you have been asked for a key. 

Only the Professional 
Edition of Cardbox can 

set up encryption, but all 
editions can use 

encrypted databases.

It is your responsibility to 
make sure that your 

actions with Cardbox are 
legal, and this includes 

the use of encryption. We 
cannot give you any 

advice on the legality of 
encryption where you are, 

and you should consult 
your legal advisers.
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Key management 
When you encrypt a database, you give Cardbox a key.  A key is a string of between 
8 and 60 characters chosen by you.  Cardbox does not store the key, so you will 
have to enter it every time you open the database. 

An encrypted database cannot be read by anyone who does not have the key.  If 
you encrypt your database and then forget the key that you used to encrypt it, it will 
be unreadable and no-one will be able to get your data back for you. 

You should keep the key secret, but you should also keep it safe, because losing the 
key effectively means losing your data.  Write down your encryption key on a piece 
of paper and put that piece of paper in a safe place – with your lawyers, or at the 
bank, or with a trusted friend.  That way you are protected if you forget the key, and 
if you suffer an accident then your data will not be lost forever. 

Choosing a key 
An encryption key should be something that is not easily guessed by someone else.  
The ideal would be a completely random sequence of letters and numbers.  The 
worst encryption key is a word that occurs in a dictionary, or a common name, or a 
name that is closely associated with you.  Use unorthodox spellings, or strange 
capitalisations, or combinations of letters and numbers.  How paranoid you are 
about this depends on the risk you are protecting yourself against: if you are worried 
about someone typing guessed encryption keys into Cardbox, you can be more 
relaxed about keys than if you are worried about someone taking a copy of your 
database and running a search program that tests thousands of possible keys every 
second. 

Making Cardbox remember the encryption key 
If you are using a password-protected Cardbox workspace (File > Workspace can 
set this up) then whenever Cardbox asks you for an encryption key, it will offer to 
remember the key for you in the future.  Those keys will then be stored in an 
encrypted state in the workspace file, so security will not be compromised as long as 
your workspace password isn’t easily guessed. 

In addition, there is a utility program called keykeep.exe in the same folder as the 
main Cardbox program file cardbox3.exe.  If you put a shortcut to keykeep.exe in 
your Startup folder, so that it runs every time you run Windows, you will only ever be 
asked for an encryption key once: the key will then be remembered until you shut 
down your computer.  This means that if you are away from your computer for a 
moment, someone can come along and open any database that you have already 
opened today; but if this is not a problem for you then this utility can save you some 
typing. 

See “Workspaces”, p.61.
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How to encrypt a database 
The command Tools > Management > Encryption » Encrypt lets you encrypt a 
database.  This command is restricted, and to use it you must have the master 
password for the database or the access code for your copy of Cardbox.  This 
restriction is because encryption is a potentially destructive operation: if an enemy 
opened your database, encrypted it and then threw away the key, your data would 
be lost forever. 

The Encryption command asks you twice for the encryption key you want to use.  
The first time, the key will appear on the screen as you type it, so that you can see 
that you’ve typed it right.  The second time, the key will appear as a row of asterisks.  
You have to type the key identically both times or Cardbox will reject it. 

Once you’ve entered the key twice, Cardbox will encrypt the database.  The 
encryption process is designed to keep your data safe, so if your computer crashes 
half way through the encryption you will either have a fully encrypted database or 
one that isn’t encrypted at all: either way, you will still be able to read your data. 

Changing encryption keys 
Some security experts recommend that you change your encryption keys often 
(others prefer hard-to-guess keys that are kept unchanged for a long time).  To re-
encrypt your database using a different key, use Tools > Management > Encryption 
» Change.  Cardbox will ask you for the master password or the access code and it 
will also ask you for the encryption key that is currently in use: this is to prevent a 
malicious person from changing the key when you are away from your computer. 

Decrypting a database 
If you decide that you no longer want to keep your data encrypted, use Tools > 
Management > Encryption » Remove.  Cardbox will ask you for the master 
password or the access code and it will also ask you for the encryption key that is 
currently in use. 

 

See “Restricted 
Operations”, p.256.
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Macro facilities in Cardbox 
A macro is a sequence of Cardbox actions that you can store and then execute with 
a single command.  We call this “playing” the macro. 

Macros are part of the Professional Edition of Cardbox and they are a large part of 
what makes that edition so powerful; but if you have the Client or Home Edition, you 
can still open a database that has had macros set up for it and you can still play the 
macros it contains. 

What macros can do 
The simplest kind of macro is nothing but a sequence of recorded actions, and you 
create it by turning the macro recorder on, doing something with Cardbox, then 
stopping the macro recorder and saving the result for future use.  When you play the 
macro, it repeats your original actions exactly.  This sort of macro can save you time 
with tasks that you perform often – for instance, sorting records into sequence, 
switching to a different format, and printing.  It can be useful in exactly the opposite 
situation too: something that you do so rarely that you always forget how to do it 
from one occasion to the next. 

Macros and programming 
Cardbox stores its macros in VBScript, a programming language developed by 
Microsoft.  This means that each macro is essentially a “mini-program”, and it can do 
a lot more than just blindly repeat a sequence of actions that you’ve recorded into it.  
You can edit your macros to make them more intelligent – they can loop through a 
collection of records, they can perform calculations, they can pick up text from a field 
and use it in a command. 

Taking this one step further, you don’t need to record a macro at all: you can create 
it from scratch in Cardbox’s macro editor.  Your macros can interact with other 
programs, not just Cardbox: all major Windows applications have a programming 
interface that is accessible through VBScript, and so do many parts of Windows 
itself.  Your macros can open web pages, send emails, send faxes, open and modify 
Word documents… you are limited only by your imagination and by the abilities of 
the applications that your macros talk to. 

Cardbox also lets you do the same thing in reverse: for example, Microsoft Office 
macros can talk to Cardbox and do searches in its databases – see page 267. 
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How to play a macro 
The simplest way of playing a macro is to press the Play button on the toolbar.  
Cardbox will show you a list of all the available macros and you can pick the one you 
want.  If you’re using the Professional Edition, the list will have two pages, called 
Play and Manage.  Choose Play to get the simple, all-in-one list: Manage is more 
useful when you are editing macros. 

To play a macro, double-click on it; or click once and then press the Play button. 

If you want to see the text of a macro to make sure it’s the right one before you play 
it, right-click on the macro’s name and select View from the menu that pops up. 

Toolbar buttons 
It’s possible to design extra buttons into the Cardbox toolbar, and these buttons can 
play a designated macro directly.  The command for setting up toolbar buttons is 
Tools > Toolbar, and it’s covered in detail in the Macros and Programming manual. 

Format buttons 
Similarly, macro pushbuttons can be built into a format design.  You can put any 
picture you like into the buttons, and you can put them wherever seems most 
sensible: next to the field they refer to, or along one edge of the format.  You can 
read more about designing pushbuttons into a format on page 203. 

Keystrokes 
A macro can be associated with a keystroke, so that pressing the key plays the 
macro.  Most keystrokes can be used, from simple ones like F7 to complicated ones 
like Ctrl + Shift + T.  The command for setting up keystrokes is Tools > Keyboard, 
and again the Macros and Programming manual gives all the details. 

Menu items 
There is an extra menu, called Special, that appears on the main Cardbox menu bar 
between the Tools and Window menus, and you can put menu commands into this 
to play specific macros.  This is a useful place to put macros that aren’t used often 
enough to justify having a pushbutton or a keystroke of their own.  The command for 
setting up the Special menu is Tools > Special Menu. 

Tools > Play 
F5 

The Special menu won’t 
appear on the screen 

unless it has some 
macros in it.
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What happens when you play a macro 
The progress bar at the bottom of the screen shows that you’re running the macro. 

 

The blue box moves steadily from left to right because Cardbox can’t tell in advance 
how long your macro is going to take.  If it’s appropriately programmed, a macro can 
display a more informative status bar (one that grows steadily to indicate how far the 
macro has got) and it can also display different text in the progress bar. 

While a macro is running, you can’t do anything else.  You can stop the macro by 
clicking on the red cross next to the progress bar or by pressing the Stop button in 
the toolbar. 

Pausing a macro 
You can pause a macro by pressing the Pause button in the toolbar.  Once the 
macro is paused, you can enter Cardbox commands if you want.  The Pause button 
will stay depressed and it will flash to show that the macro is paused. 

You can continue a paused macro by pressing the Pause button again, or you can 
stop it by pressing the Stop button. 

Macros that pause themselves 
A macro can choose to pause – for example, so that you can tag some records to be 
used in the next stage of its operations.  If the macro just pauses, you’ll see this by 
the flashing of the Pause button; but the macro may also display a message so that 
you can work out why it’s paused. 

 

As well as using the buttons, you can press F5 to continue the macro or Esc to 
cancel it. 



    266  

 

Where macros are stored 
There are four places where macros can be stored, depending on what the macros 
do and when they need to be accessible. 

Database macros are stored with the database and they aren’t visible when you’re 
in any other database.  If a macro contains commands that make sense only in 
one database, it should be stored as a database macro. 

Related Databases macros refer to a group of databases, not just one database.  
They are quite an advanced feature: see Help Point 571 for an explanation. 

Workspace macros are associated with one particular workspace and aren’t visible 
when you use a different workspace. 

General macros are visible whenever you use this copy of Cardbox. 

Similar classifications apply to the shortcut methods of playing macros – toolbar 
buttons, keystrokes, and the Special menu – so that the shortcuts can offer only 
those macros that are actually usable in the current context. 

Macros and safety 
If you are opening a database that was created by someone else, and using the 
macros inside it, you have to consider the possibility that the database author was 
malicious and wrote macros that could harm your computer or reveal sensitive data. 

When you open a database on a Cardbox server, you can specify its safety level.  
This tells Cardbox whether it is allowed to run macros from this database, and what 
those macros are allowed to do.   

The default safety level is Untrusted, which allows macros to run but won’t let them 
read or write your hard disk or do other potentially harmful things.  Unless you know 
that a database contains sophisticated macros that need to be more trusted than 
this, there’s no need to alter this safety level.  There is a spectrum of safety levels, 
from Completely Untrusted to Completely Trusted, and you can set safety levels for 
individual databases or for the server as a whole, so that (for example) you can 
make your organisation’s corporate server Completely Trusted but leave all other 
servers Untrusted. 

For more about safety 
levels and trust, see 

Help Point 526.
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Programming Cardbox from the outside 
VBScript is the language that Cardbox records macros in, but it is not the only 
language that you can use to drive Cardbox. 

If you are used to some other language, such as Visual Basic, then you can use this 
to start Cardbox and communicate with it, send it commands, search a database, 
retrieve or modify records, and so on.  You can use any language that can drive 
programs through an Automation (ActiveX) interface. 

If you use Microsoft Office, you can write Office macros in VBA, and these can also 
communicate with Cardbox in the same way.  Whether you use an Office VBA 
macro to send commands to Cardbox or a Cardbox VBScript macro to send 
commands to Office is largely a matter of taste.  Do you want the user to start the 
resulting macro from within Cardbox or Office?  Do you prefer the development 
environment of VBA in Office, which includes a full debugger, or of VBScript in 
Cardbox, which just lets you edit and play macros? 

Windows itself has a scripting interface, accessible through the Windows Scripting 
Host (“WSH”).  Using WSH, you can write a macro in VBScript and give it a filetype 
.vbs: then double-clicking on the file within Windows will run the macro.  typically, 
this kind of macro would start Cardbox, perform some actions with it, and close 
Cardbox again.  Note, however, that some Windows installations disable WSH 
because it can control anything in Windows, which makes it a security risk. 

Finding out more 
The Macros and Programming manual is the main source of information about 
macros.  It explains all the commands used for recording, editing, and managing 
macros, and how to set up toolbar buttons, keyboard shortcuts, and the Special 
menu.  It also describes all the commands that a macro can use.  This manual 
comes as part of the Professional Edition of Cardbox. 

Help > Macros and Programming gives you a large amount of reference information.  
It assumes a knowledge of VBScript, but also lists some published books that will 
help you learn the language. 

VBA (“Visual Basic for 
Applications”) is closely 
related to Visual Basic 

and to VBScript (“Visual 
Basic Scripting Edition”).
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Requirements 

Operating system 
Microsoft Windows 95 or later (Windows 98, Windows Me). 

Microsoft Windows NT 4.0 or later (including Windows 2000, Windows XP,…). 

Memory 
32MB RAM. 

Disk space 
12MB for the Cardbox program files. 

Capacity 
Number of records per database: 16,000,000 (or 10,000 for the Home Edition). 

Size of database file: 1TB (1,024GB) unless the operating system imposes a lower 
limit (for example, Windows 95, 98, Me restrict files to 2GB in size). 

Number of fields per record: 4,096. 

Size of fields: no practical limit. 

Number of images per record: no practical limit. 

Compatibility with other programs 
Cardbox can import and export data in CSV (comma-separated variables) format. 

Cardbox can import data from many databases using the OLE DB interface. 

Cardbox can export data in XML. 

Cardbox can share data using DDE and COM / ActiveX / Automation. 

Compatibility with previous versions of Cardbox 
Installing Cardbox 3.0 does not harm an existing installation of Cardbox 2.0 or 
earlier. 

Cardbox 3.0 can directly open databases from all previous versions of Cardbox for 
Windows, from Cardbox-Plus for DOS (version 3 and above), Personal Cardbox-
Plus, and Picture Cardbox.  Data from all other members of the Cardbox family can 
be exported from the original Cardbox program and imported into Cardbox 3.0. 
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User interface 
Some menus have been rearranged: for example, the contents of File > Utilities 
have been moved to Tools or Tools > Management. 

Some keyboard shortcuts have been reassigned to conform to emerging Windows 
conventions.  The most noticeable change is that F3 for Extra Text has been 
changed to F6, but there are others: for example, Ctrl + A while editing now selects 
all the text in a field instead of opening View > Appearance. 

Macros 
The old Cardbox-specific macro language has been superseded by VBScript, and all 
your existing macros will need to be re-recorded or rewritten. 

Networking 
Previous versions of Cardbox shared databases by directly opening the database 
files, with access being synchronized by the CARDBOX.SHR control file and by 
.LOK files for each database.  Cardbox 3.0 uses the Cardbox Server for multi-user 
access: this is more efficient and much better for data integrity.  Because, in this 
case, the Cardbox Server requires exclusive access to the database files that it 
opens, you can’t have a mixture of Cardbox 2.0 and Cardbox 3.0 / Cardbox Server 
users opening the same database at the same time: once you have decided to 
convert your network users to Cardbox 3.0, you need to convert them all. 

An advantage of the use of the Cardbox Server is that it is no longer necessary to 
give shared read/write access to any control files or data files, which makes network 
management much easier. 

Database files 
The database file format is essentially the same.  The one exception is with image 
and object files, where you need to rebuild the database in Cardbox 3.0 (using Tools 
> Management > Rebuild) before you can add or make changes to the image or 
object content. 

If you use Cardbox 3.0 to perform ordinary database operations on a Cardbox 2.0 
database (adding, editing, and deleting records), the database will remain 
compatible with Cardbox 2.0; however, if you rebuild the database using Cardbox 
3.0, Cardbox 2.0 will no longer be able to use it. 
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New features in Cardbox 3.0 

Searching 
You can enter a complete Boolean search (with "And", "Or" and "Not" functions) in a 
single command.  You can search for whole phrases at once, or for words in a given 
sequence, or for two words within a certain distance of each other. 

Sorting 
The "custom sequence" feature (for multi-field sorting) has been expanded.  Instead 
of just one custom sequence, you can have as many as you like. 

Document and image processing 
Cardbox's image handling has been completely revised to keep track of advances in 
scanner and display technology, and a new Image window replaces the old "full-
screen" image mode.  The image compression options have been simplified so that 
you only have to specify the image type (document or photograph) and whether you 
want standard or high compression.  You can rotate or resize images before storing 
them.  If you have a digital camera or a sheet-fed scanner then you can import 
multiple images using a single Cardbox command.  A zoom control lets you view 
images at any scale.  Images can be moved easily from one database to another, or 
accessed by external programs. 

Spelling checker 
A new high-quality spelling checker has been built in to Cardbox.  You can hit a key 
to check spelling in any field, or you can tell Cardbox to underline misspelt words: a 
simple right-click will offer you alternative spellings. 

Drop-down lists 
People who display Cardbox fields as radio buttons and check boxes have often 
asked us if we can do drop-down lists as well.  Now we have.  In addition, actions on 
all of these field types can now be recorded as part of a Batch Edit, and searches on 
them have been simplified. 

Workspaces 
Workspaces are an evolution of the Sessions feature which we introduced in 
Cardbox 2.0.  You can have as many workspaces as you like, listed in the Windows 
Start menu, to keep your projects organised but separate.  Whenever you open a 
workspace it remembers what databases you had open last time and the exact state 
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of your browsing and searches.  Unlike Sessions, you can have several workspaces 
open at a time.  Databases are not restricted: if you need to, you can have the same 
database open in several workspaces. 

User interface 
When Cardbox for Windows first came out, the Windows boom was just beginning.  
We have watched how Windows conventions have evolved and we have observed 
how people actually use Cardbox.  Here are some of the results of our research: 

Menus have been rearranged to make them more intuitive and renamed to conform 
to current Windows practices: for example, "Tools, Options" replaces "File, 
Utilities, Configure Cardbox". 

Right-clicking the mouse calls up context-sensitive menus both when searching 
and when editing. 

Carefully designed Wizards take you through inherently complex operations such 
as file import. 

The format design process has been revised and simplified at the same time as 
making it more powerful. 

Keyboard shortcuts have been reassigned to match other Windows programs. 

Customisation 
You can now customise the toolbar (adding or rearranging buttons) as well as 
reassigning keystrokes and adding menu items.  You can apply customisations to 
your computer as a whole or to individual projects, databases, and formats, so that 
(for example) a toolbar button is only visible in the database to which it applies. 

Windows integration 
Cardbox 3.0 is a fully 32-bit program, which means an end to the bugs that crept in 
to Windows XP's support for 16-bit programs (especially where long filenames were 
concerned).  Cardbox also uses the Windows Registry for its configuration settings, 
which also allows system administrators control the extent to which Cardbox users 
are allowed to reconfigure their program.  Cardbox supports Windows Automation, 
which means that any scripting language that you use to control Windows can 
control Cardbox as well. 

Web and email 
Any link with a http:// prefix is automatically underlined and you can open a web 
page just by clicking on its link.  Any link with a mailto: prefix is also underlined and 
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you can create a blank email by clicking on the link.  The underlining does not 
appear in printed output. 

In addition, you can design macros that send an email to a whole batch of recipients 
or you can pass a list of email addresses to a separate email program such as 
Outlook. 

The Internet 
The new client/server model means that Cardbox works just as well across the 
Internet as it does on a local area network.  You can view Cardbox databases that 
other people have chosen to make public.  You can publish your own databases, 
free of charge or for payment.  You can optionally use an Internet connection to 
allow your users to access their databases when they are travelling.   

Security 
All network connections are encrypted using the industry standard OpenSSL with 
Diffie-Hellman key exchange.   

Cardbox optionally allows you to encrypt your databases.  Cardbox 3.0 uses the 
new international standard algorithm AES for data encryption. 

File import and export 
New file import and export wizards make it easy to transfer data into and out of 
Cardbox, and add the following features: 

• Direct import from databases or spreadsheets using OLE DB or ODBC. 
• Simplified import from comma-separated (CSV) files. 
• Export to HTML to create web pages. 
• Import and export using XML, the new standard for data markup and transfer. 
• Data conversion using XSLT. 

Tools 
The new Deduplicate command lets you identify possible duplicate records in your 
database. 

The Repair function has been replaced by a new Rebuild command, which 
preserves more information (such as kept selections) and in most cases allows other 
network users to access a database even while it is being rebuilt. 

Commands are provided for making backups of a Cardbox database while people 
are still using it.  This is vital in a large network or when 24-hour availability is 
required. 
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Macros 
The old macro language, which recorded all commands as sequences of keystrokes, 
has been discarded.  In its place comes Microsoft's Visual Basic Scripting Edition 
(VBScript), a powerful and versatile programming language that can drive not just 
Cardbox but all other major Windows applications. 

Macro organisation has been rethought so that it works seamlessly on a network.  
Macros can be general (applicable whenever Cardbox is running) or specific to a 
user, a workspace or a database.  The Macro Recorder records your actions as a 
macro, and you can use the Macro Editor to change details or add advanced 
features. 

Macros can be activated through the Play Macro command or by keystrokes, 
pushbuttons, special menu entries, or toolbar buttons. 

Programming 
Cardbox can be driven by any language that uses ActiveX or Windows Automation, 
including Visual Basic, VBA, C++, Java, and Javascript.  For example, a VBA macro 
within Microsoft Office can send commands to Cardbox to make searches or retrieve 
data.  It is also possible to run Cardbox on a web server and access the data 
through Active Server Pages. 

Unicode 
Unicode is a worldwide standard for character encoding.  It is essential if you are 
using anything other than normal Western European characters: Greek, Russian, or 
unusual accented letters from the Latin alphabet.  Cardbox 3.0 handles most left-to-
right languages; it does not yet handle languages that are written from right to left. 
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A page reference in italics indicates that the page refers to a Help Point.  To read a Help Point, open 
Cardbox and use the command Help > Help Points. 

 

A 
Accented letters, 43 

indexing, 36 
Access control. See User profiles 
Adding 

fields to formats, 189 
images to records, 160 
records to database, 133 

Alignment 
fixed text, 200 
merge blocks, 196 

All. See Indexing modes 
Alternate field views, 32, 192 
Alternative formats, 31 

selecting, 106 
Appearance, 33, 107, 118, 191 

grid spacing, 108 
Autodialling, 127 
Automatic. See Indexing modes 
Automatic numbering of records, 209 
Automation 

batch editing, 137, 155 
macros, 263 
programming, 267 

B 
Background colours. See Appearance 
Backup files, 249 
Bar codes, 30, 198 
Batch deletion, 138 
Batch editing, 137, 155 
BMP file format, 39 
Bold characters. See Appearance 
Boolean searches, 85 

by combining search commands, 73 
in a single command, 85 

Borders. See Format design (lines and boxes) 

Browse bar, 48, 65 
Browse menu, 68 
Browsing 

images, 69 
records, 65 
step browsing, 68 

C 
Calculations, 130 
Cameras, 162 
Captions, 190 
Cardbox 

editions, 13 
history, 4 
Home Edition, xiv 

Cardbox window, 46, 48 
Change Format command, 106 
Character sets, 43 
Check boxes, 32, 192 

searching on, 89 
Checking spelling, 147 
Clear all selections, 74 
Clipboard operations, 123 
Closing Cardbox, 53 
Collating sequences, 36 
Colours. See Appearance 
Columns, printing in, 122 
Combining selections, 98, 100 
Comma-separated format. See CSV file format 
Communications, 127 
Compatibility with earlier versions, 67, 269 
Compression of images, 163 
Copying 

formats, 183 
records, 123 
text, 144 

Creating 
databases, 173 
formats, 183 
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records, 133 
CSV file format, 124 
Custom sequence, 102 

D 
Data menu, 90 
Data searches, 90 
Data transfer, 123 

clipboard, 123 
comma-separated format (CSV), 124 
DDE, 123 
Excel, 135 
export, 123 
external format, 126 
HTML output, 128, 196 
images, 129 
import, 135 
internal format, 126 
mail-merge, 124 
print-to-disk, 126 
web pages, 128, 196 
XML output, 125, 128, 196 

Database windows, 46, 67 
Databases 

creating, 173 
opening, 54 
publishing, 20 
rebuilding, 251 
recently used, 58 

Dates 
indexing, 37 
reformatting, 209 
searching, 83 

Datestamping. See Default Entry validator 
DDE, 123 
Deduplication, 167 
Default Entry validator, 209 
Deleted fields 

purging, 190 
Deleted fields, 189 
Deleted records 

markers, 49, 138 
undoing deletion, 138 

Deleting 
fields, 186, 190 
format items, 186 
images, 166 
records, 138 

Dictionaries (spelling), 149 
Digital cameras, 162 
Disaster recovery, 249 
DMP file format, 126 
Documents, scanned. See Images 
Downloading from server, 251 
Drop-down lists, 32, 192 

searching on, 89 
Duplicate records, removing, 167 
Duplicating 

database windows, 67 
databases, 175 
formats, 183 
records, 133 

Dynamic data exchange. See DDE 

E 
Editing formats, 183 
Editing records, 136, 140 

batch editing, 137, 155 
Email, 127 
Encryption, 59, 257 
Error displays, 49 
Error messages, validation, 152 
Error reporting, 11 
Excel, 135 
Exclude. See Search commands 
Exporting data and images. See Data transfer 
External file format, 126 
Extra text, 26, 204 

viewing, 67 

F 
Fax, 127 
Fields, 25, 178 

alternate field views, 192 
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calculating totals, 130 
changing index mode, 190 
changing type, 190 
deleting, 186, 190 
extra text, 26 
in alternative formats, 189 
inserting into formats, 189 
multi-line, 245 
planning format design, 241 
purging deleted fields, 190 
sequence when editing, 205 

FIL file type, 175 
Finding and replacing text, 145 
Finding records. See Searching 
Fixed text in formats, 180, 199 
FMT file type, 175 
Fonts. See Appearance 
Footings, 182, 188 
Foreign language fonts, 43 
Format design, 177, 184 

alternate field views, 192 
appearance, 107, 191 
deleting items, 186 
extra text, 204 
fields, 189 
fixed text, 200 
format properties, 182, 204 
graphic items, 202 
headings and footings, 188 
height, 187 
lines and boxes, 201 
merge blocks, 195 
moving items, 185 
overlapping items, 186 
per-item appearance, 107 
planning, 213, 241 
printable area, 186 
pushbuttons, 203 
resizing items, 185 
ruled forms, 201 
rulers, 187 
selecting items, 185 
undoing changes, 186 
width, 187 

zooming, 184 
Format files 

copying, 175 
rebuilding, 251 

Formats, 27, 177 
changing, 106 
copying, 183 
creating, 183 
duplicating, 183 
editing, 183 
native and alternative, 31 
selecting, 106 

Fuzzy matching, 87 

G 
GIF file format, 39 
Graphic items in formats, 181, 202 
Grid spacing, 108 

H 
Headings, 182, 188 
Help, 8 
Help points, 9 
History of selections, 75 
Home Edition, xiv, 13 
HTML output, 128, 196 
http: prefix, 236 
Hyperlinks, 236 
Hyphenated words 

sorting, 101 

I 
Image window, 70 
Images, 39, 69 

adding, 160 
browsing, 69 
compression, 163 
deleting, 166 
editing, 166 
exporting, 129 
image window, 70 
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pasting, 161 
preprocessing, 163 
printing, 113 
reading from a file, 160 
rearranging, 166 
scanning, 161 
thumbnails, 72 
viewing, 69 

Importing data and images. See Data transfer 
Include. See Search commands 
Indexing, 34 

changing the index mode, 92, 190 
date and time, 37 
numbers, 36 
while editing, 140 
words, 36 

Indexing modes, 34, 190 
Installing Cardbox, 13 
Internal (DMP) file format, 126 
Italic characters. See Appearance 

J 
JPEG file format, 39 
Justification 

fixed text, 200 
merge blocks, 196 

K 
Keep menu, 97 
Kept selections, 97 

L 

Labels, 119, 236 
Letters, standard. See Mail-merge 
Levels of selection, 24 
Licensing, 13 

and the Cardbox Server, 17 
home and office use, 18 
multi-user licences, 15 

Lines and boxes in formats, 180, 201 
List boxes, multiple-selection, 45 

Log files, 12 

M 

Macros, 250, 263 
pausing, 265 
playing, 264 
safety, 58, 266 
storing, 266 

Mailing labels, 119, 236 
Mail-merge, 29, 124 
mailto: prefix, 236 
Manual. See Indexing modes 
Matching terms, highlighting, 75 
Measurement units in printing, 115 
Merge blocks, 179, 195 
Moving text, 144 
Multi-column printing, 122 
Multi-field sorting. See Custom sequence 
Multiple document interface (MDI), 46 
Multiple images, 69 
Multi-user operation. See Networking 

N 
Native formats, 31 
Networking, 42 
None. See Indexing modes 
Numbering records, 209 
Numbers 

indexing, 36 
searching, 83 

O 
OLE Objects, 40 
Opening a database, 54 
Opening Cardbox, 53 
Option buttons. See Radio buttons 
Overlapping boxes, 205 
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P 
Palm, 214, 244 
Paper sizes, 119 
Passwords. See User profiles 

workspaces, 63 
Pauses in macros, 265 
PDAs, 214, 244 
Phone dialling, 127 
Photographs. See Images 
Phrase search, 83 
Pick lists, 144, 209 
Previewing printed output, 114 
Previewing searches, 85 
Print command, 111 
Printable area, 186 
Printer settings, 115 
Printing, 110 

appearance of records, 107, 118 
images, 113 
labels, 119 
mailing labels, 119 
margins, 116, 121 
measurement units, 115 
multiple columns, 122 
page orientation, 116 
page width, 118 
paper sizes, 119 
preview, 114 
print job ID, 112 
printer settings, 115 
record layout, 116 
records, 110 

Problem reports, 11 
Programming, 263, 267 
Publishing databases, 20 
Purging deleted fields, 186 
Pushbuttons, 181, 203 

R 

Radio buttons, 32, 192 
searching on, 89 

Range searches, 82 

Rebuilding 
database, 251 
format file, 251 

Record numbers, searching on, 99 
Records 

appearance, 107 
automatic numbering, 209 
browsing, 65 
creating, 133 
deleted record markers, 138 
deleting, 138 
duplicating, 133 
editing, 136 
saving, 136 
sorting, 101 
step to specific, 68 
tagging, 95 
undoing deletion, 138 

Red tags, 96 
Registry settings 

backup, 250 
Reinstallation, 16 
Relational searching and linking, 78 
Repairing. See Rebuilding 
Replace text. See Finding and replacing text 
Reporting problems, 11 
Ruled forms, 201, 205 
Rulers (format design), 187 

S 
Safety levels, 58, 266 
Scanning images, 161 
Screen shots, 12 
Scrolling, 66, 72, 184 
Search and replace text. See Finding and 

replacing text 
Search commands, 73 
Searching, 73, 76 

Boolean search, 73, 85 
check boxes, 89 
choosing a field, 81, 91 
combining selections, 98, 100 
commands, 73 
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data searches, 90 
dates, 83 
drop-down lists, 89 
fuzzy matching, 87 
highlight matching terms, 75 
history of selections, 75 
index searches, 80 
kept selections, 97 
levels of selection, 24, 73 
multiple search terms, 84 
numbers, 83 
phrases, 83 
preview, 85 
radio buttons, 89 
ranges, 82 
record numbers, 99 
relational, 78 
tagged records, 93 
types of search, 76 
undo one search level, 74 
unindexed data, 90 
unique terms, 88 
wildcards, 82, 91 
words, 82 

Security. See Encryption. See User profiles 
workspaces, 63 

Select. See Search commands 
Selecting text when editing, 142 
Selections, 24 

combining selections, 98, 100 
Sequence 

fields in a format, 205 
records. See Sorting records 

Sessions. See Workspaces 
Sorting records, 101 

cancelling sequence, 105 
custom sequence, 102 
multiple fields, 102 
one field, 101 
recalculating sequence, 103 

Spelling checker, 147, 191, 204 
Split window. See Extra text 
Status bar, 48 
Step browsing, 68 

Support, 11 

T 
Tag menu, 95 
Tags, 93 

red, 96 
step to records, 68 

Technical support, 11 
Telephone dialling, 127 
Thumbnail images, 72 
TIFF file format, 39 
Time, indexing, 37 
Timestamping. See Default Entry validator 
Toolbar, 48 
Totalling contents of a field, 130 

U 
Underlined characters. See Appearance 
Undo one search level, 74 
Undoing changes 

in format design, 186 
in records, 143 
record deletion, 138 

Unicode, 43 
Unindexed data searches, 90 
Unique terms, 88 
Units of measurement in printing, 115 
User dictionaries (spelling), 149 
User profiles, 41, 59, 253 

V 

Validators, 38, 152, 191, 206 
VBScript, 263 
Viewing 

extra text, 67 
images, 69 
records, 65 
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W 
Warning displays, 49 
Web pages, 128 
Wildcards, 82, 91 
Workspaces, 61 

passwords, 63 

X 
XML output, 125, 128, 196 

Z 
Zooming 

format design, 184 
images, 70 
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If your copy of this book contains a CDROM with Cardbox on it, this is the licence 
agreement that applies. 

Limited Use Software Licence Agreement 
This is Cardbox Software Limited's (“Cardbox Software”) Limited Use Software 

Licence Agreement (“the Agreement”), which will govern your use of the 
software product (“the Software”) contained in the attached CDROM. You 
confirm your acceptance of the Agreement by breaking the seal of the CDROM 
envelope. 

The copyright and all rights to the Software and its documentation (including this 
book) and other related materials are the sole and exclusive property of Cardbox 
Software. By accepting this Agreement, you do not become the owner of the 
Software, but you acquire the rights to use the Software in accordance with the 
Agreement. You agree to apply your best efforts to protect the Software from 
unauthorised use and illegal reproduction or distribution. 

You may only use the Software on a single computer, on its temporary replacement, 
or on a subsequent computer. If you wish to use the Software on more than one 
computer, you must purchase an additional copy of the Software for each 
additional computer. You may, however, install the Software for your own 
personal use on two computers (for example, one at work and one at home) as 
long as you are able to ensure that no-one can use one of these installations 
while you are using the other. You may not either temporarily or permanently 
transfer or sub-license your rights to use the Software under this Agreement 
without the prior written consent of Cardbox Software. 

You may not use the Software in contravention of the laws that apply where you are 
using it: for example, you may not use data encryption in a country where data 
encryption is illegal. it is your responsibility to determine what uses of the 
Software are or are not legal in your locality. 

The enclosed CDROM is identified by an original Cardbox for Windows label.  Use 
this to install the Software on your computer.  You are entitled to make such 
security or back-up copies of the Software as may be reasonably necessary, and 
you agree to treat these on the same terms that apply to the original Software 
under this Agreement and to destroy all such copies in the event of termination 
of the Agreement. 

You may terminate this Agreement at any time by giving written notice to Cardbox 
Software and destroying all copies of the Software in your possession. 



 Licence Agreement  283 

 

 

Limited Warranty 
The Software is supplied encoded on computer media (CDROM). Should the 

CDROM prove to be faulty, a free replacement may be obtained provided that 
the defective CDROM is returned within three months of purchase. Such free 
replacement is available only for original media bearing the original label. 

The Software is supplied fully tested in accordance with the specifications implied in 
the User Manual, but in the event of any reproducible errors being detected 
under normal operating conditions, and the Software being modified to correct 
them, registered users will be entitled to a replacement of the defective 
Software. For users who have a current and unexpired technical support 
subscription, this replacement will be free of charge. 

Technical support is provided by electronic mail and through the World Wide Web.  
For the current terms, pricing, and availability of technical support (whether per-
incident or by subscription), see the Cardbox web site at www.cardbox.com. 

Apart from the Limited Warranty given above, no warranty is given or implied as to 
the performance of the Software on any particular computer or its fitness for any 
particular purpose, and you agree that neither Cardbox Software nor its 
Licensees shall be held liable for any direct, incidental or consequential 
damages or losses arising from the use of the Software. The liability of Cardbox 
Software or its authorised Licensees will in no circumstances exceed the price 
that you actually paid for the licence to use the software. 

In the event of any dispute arising about the interpretation and enforcement of this 
Agreement, the governing laws will be the laws of England. 

User Registration  
You are strongly urged to register your copy of Cardbox, either as part of the 

installation process or subsequently (see Help Point 567 for instructions).  Users 
who are not registered have no access to support services or to any future 
revisions or updates.  Your registration details will be kept confidential and will 
not be disclosed to third parties. 

  


