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1. Preparation and Installation 

This chapter should be read before the software is installed. It contains important 

information about the installation and the necessary requirements. Please note that 

releases with differing features are possible among the third party product versions 

specified. 

1.1 System Requirements 

The following are the requirements for the use of this software: 

File Server 

▪ Processor: Pentium 500-processor or higher. 

▪ Memory (RAM): Minimum: 256 MB. 

▪ Around 600 MB hard drive space is required for a typical cRM installation. 

▪ Operating System: An MS Windows supported network is required on the server, 

such as Windows XP - 8, Windows Server 2003 - 2012, Novell, Linux/Samba. 

▪ The reference projects provided require the support of long file names in the project 

directory. 

Supported Database Servers 

▪ Microsoft SQL Server 2005 - 2012. Information regarding the configuration and 

system requirements can be taken from the relevant Microsoft sources (e.g. 

microsoft.com/sql). 

You will find an overview of the differences between Express Edition and the other 

Editions for SQL Server 2008 R2 here: 

http://msdn.microsoft.com/en-us/library/cc645993%28v=sql.105%29.aspx 

▪ PostgreSQL 8.3 - 9.2 Open Source Database System. Information regarding the 

configuration can be taken from the relevant PostgreSQL sources (e.g. 

www.postgresql.org). 

▪ Minimum requirement for server-side "field changes" and the "Monitor dataset" 

function: Microsoft SQL Server 2005 or PostgreSQL 8.4. The name of the user who 

made the change is only available in versions PostgreSQL 9 and later. 

WebAccess  

Server 

▪ Windows (Web) Server 2003 - 2012, Windows 7 - 8. 

▪ Requires Microsoft Internet Information Services (IIS) 6 – 8. 

▪ 1 GB hard drive space 

http://www.microsoft.com/sql
http://msdn.microsoft.com/en-us/library/cc645993%28v=sql.105%29.aspx
http://www.postgresql.org/
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▪ Requires .NET Framework 3.5 SP1 

▪ Requires printer driver. 

▪ Minimum requirements, if the server is running on another server and related to the 

complexity of the combit reference solution and up to 10 concurrent users: 

▪ Processor: Dual Core Processor, 2 Ghz 

▪ Memory: 1 GB of RAM + 20 MB of RAM per concurrent user. 

▪ We recommend that if the server is running on another server and related to the 

complexity of the combit Reference Solution and up to 30 simultaneous users: 

▪ Processor: Quad Core Processor, at least 2 GHz 

▪ Memory: 2 GB of RAM + 50 MB of RAM per concurrent user. 

Access to the WebAccess 

▪ Supported Browser1: Chrome 26, Internet Explorer 8 – 10, Firefox 20, Safari 5. 

▪ Active components (ActiveX/Flash) are not required. 

▪ JavaScript and (session-) cookies must be enabled. 

▪ Supported Smartphones/Tables/Operating systems:  

▪ Apple iPhone and iPad (iOS 5.1 – 6.1) 

▪ Android Smartphones and Tablets (Android 2.3.3 – 4.2.2) 

▪ Windows Phone (7.1, 7.5) 

▪ Blackberry (Blackberry OS 7 – 10) 

▪ Every operating system where before mentioned browsers are available. 

Windows Client 

▪ Processor type: Pentium III-compatible processor or higher  

▪ Processor speed: Minimum: 1 MHz, Recommended: 2 GHz or more 

▪ Memory (RAM): Minimum: 512 MB, Recommended: 1 GB or more 

▪ Operating System: Microsoft Windows XP - 8. 

▪ Screen resolution 1024 x 768 or higher. 

▪ We recommend a color depth of 24 bit or higher for the display. 

▪ Microsoft Internet Explorer 8.  

▪ Windows Installer Version 3. 

                                                                 

1 The version number of the latest browser version can change frequently. combit tries to provide the required 

changes for new versions, so that the latest version is supported, however combit does not assure that. 
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▪ The Workflow Designer requires the .NET Framework 3.5 SP1. 

Microsoft Office 

▪ Microsoft Office Version 2000-2013 (32bit Edition). 

▪ Direct export to/import from Excel requires Microsoft Excel. Due to its functional 

limitations, Excel Starter 2010 is not supported. Alternatively, use import/export via 

ODBC or export via List & Label (via "Output > Mail merge". 

▪ Import of a single record or export via script to Word Starter 2010 or Excel Starter 

2010 is only supported by Office Starter 2010 via the cl ipboard due its limited 

functionality. 

External appointment and task planners 

▪ For Tobit David: Requires Tobit David.10 - David.fx12. 

▪ For Microsoft Outlook: Requires Microsoft Outlook 2000-2013. 

▪ For IBM Lotus Notes: Requires IBM Lotus Notes Version 7. 

Message archiving 

▪ Outlook AddIn: Requires MS Outlook Version 2000-2013 (32bit Edition). 

▪ David AddIn: Requires Tobit David.10 - David.fx12. 

▪ Thunderbird AddIn: Requires Thunderbird Version 172. 

Route planner and phone/online directory interface 

▪ A list of supported directories can be found under Settings > Phone & Online 

Directories / Route Planning on the "Directory" or "Route planner" tab. 

Note: Since structures and addresses of websites can change very quickly, it is 

possible that websites and services will become inaccessible without warning.  

Document management system (DMS) interface 

Generally all DMS connections support adding existing documents as well as documents 

that were created by the document management. The added documents can also be 

removed/deleted from the DMS. Changing/editing (Check-in/Check-out) is supported. 

Please note the specialties of each connection and the information under "Document 

management" in chapter "Configuration of views". 

                                                                 

2   Due to the versioning strategy of the Mozilla Foundation the version number of the latest Thunderbird version 

can change frequently. combit tries to provide the required changes for new versions, so that the latest 

Thunderbird version is supported, however combit does not assure that. 
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▪ DocuWare: DocuWare version 4.6 - 5.1 is required.  

Specialties: If DocuWare version 4.6 and 5.0 are installed in parallel, the newer 

version is always used. If DocuWare 5.0/5.1 has not yet been started and has been 

started from the cRM by a document action, a message from the DocuWare Viewer 

may appear when documents are archived in DocuWare. To suppress this message, 

use the preload settings in the DocuWare Viewer. For more information, see the 

TecDoc chapter "Preload Settings" in the DocuWare. 

▪ ELO: ELOprofessional 7/2011 or ELOoffice 6 - 9 is required. 

Specialties: It will always be tried to create the defined document archive path, so 

that the Archive structure can be created per formular/function during archiving. 

Indexing can also be configured in the document management. 

▪ windream: windream version 4.5 is required.  

Specialties: The windream DMS server that is currently active is always used. Assign 

a drive letter in the windream server settings for the alias windream settings. 

▪ easyEnterprise.x 

Specialties: Indexing must necessarily configured in the document management. 

▪ SharePoint: Microsoft SharePoint 2010-2013 is required.  

Specialties: The Microsoft SharePoint 2010 runtime modules require Windows 7 - 8, 

Windows Server 2008 R2 - 2012, Windows Vista. Windows XP is not supported 

officially by Microsoft, nevertheless it worked well in our tests. 

As soon as SharePoint is selected as the document management system in the 

cRM's project properties, the cRM automatically recognizes if the Microsoft 

SharePoint 2010 runtime modules are installed on the client when the project is 

loaded and provides the user an opportunity to install these if they are missing. The 

installation module is from Microsoft and requires an interactive confirmation of an 

license agreement by the user. The automatic distribution of the MSI installation 

module in networks can be done in the usual way for Windows networks. You find 

the installation modules (SPClient_x86.msi / SPClient_x64.msi) in the cRM installation 

folder. Alternatively they can be downloaded from the Microsoft website. 

When a document stored in SharePoint is retrieved, edited and stored again in 

SharePoint by the cRM, the libary's versioning is implicitly supported. 

Digital signatures interface 

▪ OpenLimit CC Sign 

▪ secrypt digiseal office and secrypt digiseal server 2 

▪ e.siqia esiCAPI 
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Skype interface 

Skype version 3.1 - 5.1 is required. 

Unicode Characters 

The following functions do not support foreign characters if they are not supported by 

Windows: address pick-up, connection to telephone directory and route planner, sending 

mail via simple MAPI, LDAP servers, path and filename for eml-files in the mailviewer.  

For more information about Unicode, see "Unicode" in chapter "Configuration of projects". 

1.2 Architecture 

Windows Client 

The combit Relationship Manager (cRM) has a classic Client-Server (2-tier) architecture. 

The cRM itself is a so-called 'fat client'. 

For the database connection, OLEDB is used to connect to MSSQL and libpq is used for 

PostgreSQL. The settings for these connectors define the supported network protocols 

(e.g. TCP/IP), needed ports and - if applicable - the encryption of the connection. The data 

is administered on the database server. The installation files are normally stored on a file 

server that can be accessed by all clients or on the database server itself.  

cRM WebAccess 

The cRM WebAccess allows data access from the Internet using a Web browser. The 

architecture provides a web-based system before construction can lie with the presenta-

on logic, business logic and database on different servers. The database server must not 

be accessible from the Internet. Communication takes place exclusively via Web 

Services, which provides the relevant information and services on the Internet. 

1.3 Server Installation 

Before starting the installation, you should consider the following points: 

▪ Administrator rights are required for the installation. The installation must be carried 

out with the installation program.  

▪ The program files can either be installed under any accessible UNC path (variant a) or 

locally (variant b). 
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▪ For the client installation run the program "client.exe" from the cRM program 

directory. 

▪ For a single seat or notebook installation, proceed the same way as in a server 

installation. 

Starting the cRM installation program 

1. Close all currently running applications. Disable any antivirus programs during the 

installation. 

2. Please note the database-specific information under "Microsoft SQL Server 

Installation" and "PostgreSQL Server installation". 

3. Insert the cRM DVD into the DVD drive and follow the instructions in the installation 

program. If you have the "Autorun" function activated, setup will begin automatically. 

Alternatively, double-click the setup.exe file. 

4. Database server: Specify whether you want to use an existing database server for 

cRM.  

▪ Yes: In the next step, choose the database system, database server and enter 

the respective database administrator login information. The system database 

and the sample databases will then be created on the server. When using 

Windows authentication, the current Windows user must be set up in the MS 

SQL server. For more information about Windows authentication, see "MS-SQL 

Server login method". 

▪ No: You have several options in the following step: 

▪ Install a new instance of Microsoft SQL Server 2008 R2 Express : This option 

results, even with (unknowingly) existing MSSQL instances, to a smooth 
installation and is therefore recommended. 

MS SQL / 

PostgreSQL

cRM data

variant b

or notebook-installation

database serverfile server

program group

(option)

scripting engine

program filesprogram files

variant a

Installation cRM program files
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 A new SQLExpress instance "COMBIT" with user "sa" and password 

"cmbtPW1!" will be installed. This password should be changed immediately 

after the installation. 

In case of the cRM setup downloaded from the internet, the SQL Server 

Express setup will be downloaded from the combit.net website afterwards. 

Therefore the machine where the cRM setup is executed requires an internet 

connection for this specific installation option. The DVD already contains the 

SQL Server 2008 R2 Express setup in German and English. 

If the cRM setup is executed in German and the Windows language format is 

German (incl. subtypes Austria/Liechtenstein/Luxembourg/Switzerland) the 

German version of the SQL Server 2008 R2 Express will be installed, 

otherwise the English version. 

▪ Use an existing instance of PostgreSQL on this computer : The installation of 

cRM can only be installed on existing installations of PostgreSQL. Therefore, 

first download PostgreSQL. Then, restart the cRM setup and choose "Yes" in 

the dialogue to use the existing PostgreSQL database server. 

▪ I don’t know: If you choose this option, a recommended new Microsoft SQL 

Server Express instance will be installed (see above). 

5. Serial number and product key for the base license: The relevant information, please 

refer to your license certificate. 

6. Serial number and product key for the extended license: If you do not want to enter 

an extended license, leave the boxes empty. 

7. Installation directory: As installation directory you should use an empty directory (on 

any server) that can be accessed by workstations and supports long fi le names. 

8. Install options: Select the install options in the following dialogs. These options will 

only apply to the computer the setup is performed on; these options are therefore 

not relevant for an installation directly on the server.  

9. Select word processor: Select the word processor used so that the Transfer 

Template can be set up. 

10. Database Configuration: Enter the username and password with which all cRM 

clients will access the database server. This user is automatically created by the 

installation assistant.   

11. After installation is complete, start the program "client.exe" from the appropriate 

client in the cRM directory. If you carry out a single workstation or notebook 

installation, the client installation is not necessary. 
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Assigning rights in the network 

You have to give permissions for the different users to be able access the cRM files from 

their network software. 

To give away user rights in the network, it makes sense to manage the projects and 

views of cRM in a separate sub-directory. For this, the users must be given extensive 

rights. If you have separated the projects from the other files, you only have to give the 

rights to the project directory and not the program directory. 

▪ A user you should, for example, be given the rights "RWCMF", i.e. "Read", "Write", 

"Create", "Modify" and "File Scan", for the project directory. 

▪ You can set exactly what rights are given to the user for each individual directory. 

▪ Every user should have the "File Scan" right for the whole of the cRM directory. 

Setting up the users 

 To set up the users in cRM, start the program and choose F i le  > Options > User 

Administration . The user "Administrator" is already present. 

Important! For security reasons, you must give the "Administrator" user a password 

because it has already been given all available rights.  

Microsoft SQL Server Installation 

MS-SQL Server login method 

Generally, MS-SQL Server as well as Windows Authentication are supported.  

Windows Authentication: This authentication method provides the highest level of 

security and uses Windows user accounts for login to the SQL Server as well. The 

account can thus be transferred to the SQL server in a much more secure manner. The 

disadvantage with this method is that you can then no longer access the SQL server via 

the Internet on the default port 1433. Through the authentication, further ports are 

required that might need to be activated, which is something that network administrators 

do not like to do. This is why external access in this case should occur via the terminal 

server.  

SQL Authentication: The recommended login method is the MS-SQL Server 

authentication which enables external access; the cRM setup creates a new (definable) 

MS-SQL Server user that can be used for login. This user is automatically given the 

necessary access rights to the combit_cRM_System and the combit_* project databases. 

If the MS-SQL server at hand only supports Windows Authentication for login, the 

following possibilities exist:  
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▪ In SQL Server under server properties (Properties > Security) select the option "SQL 

Server and Windows authentication Mode" as the server authentication. This way, 

the setup can automatically carry out all of the previously mentioned required 

settings. 

▪ Create the respective Windows user in SQL Server (Security folder) manually and 

grant the necessary access rights (db_datareader; db_datawriter) to the combit 

databases (combit_cRM_System and combit_*). 

▪ Either one also allows the MS-SQL Server authentication by setting this in the 

Enterprise Manager server properties (Properties > Security) (recommended!) This 

way, all previously mentioned settings will be made automatically by the setup. 

▪ The various Windows users can be set up in the MS-SQL Server and the appropriate 

access rights (db_datareader; db_datawriter) can be given for the combit databases 

(combit_cRM_System and combit_*). 

Network access with SQL Server Express Edition 

Normally SQL Server Express Edition only permits local client connections. For the cRM 

client to be able to connect with the SQL server (the database), it must be ensured that 

the Microsoft SQL server has been configured for remote connections. Otherwise, the 

client will receive the following message when starting cRM: "SQL Server does not exist 

or access denied". 

PostgreSQL Server installation 

Please read through the following notes carefully. 

General  Notes 

▪ Generally, the cRM installation can only attach to existing PostgreSQL versions. 

Therefore, first download PostgreSQL and install it. Documentation on installation 

and administration can be found under www.postgresql.org/docs/. Please also note 

the information in our Knowledgebase under www.combit.net/de/support/kb in 

"Administration tools for PostgreSQL" and "Replication solutions for PostgreSQL". 

▪ PostgreSQL does not support Windows Authentication. For PostgreSQL Server 

authentication, the cRM setup creates a new (definable) server user which can be 

used for login. This user is automatically given the necessary access rights to the 

combit_cRM_System and the combit_* project database by the setup. 

▪ Client access is carried out through the library libpq, which is made accessible to the 

clients centrally through the cRM server setup in the cRM installation directory. 

▪ For most solutions included, an activedblink module is required. 

▪ For client access, it is necessary to activate the option Accept connections on al l  

addresses, not just localhost in the Initialize database cluster dialog. If you did not 

http://www.postgresql.org/docs/books/
http://www.combit.net/de/support/kb
http://www.combit.net/page674.aspx?action=display&articleid=KBAD001080
http://www.combit.net/page674.aspx?action=display&articleid=KBAD001175


Preparation and Installation 

24 

activate this option during the PostgreSQL installation, you have to re -install 

PostgreSQL and activate it. 

Additionally, the IP addresses of the clients must be entered in the file 

\Postgres\Data\pg_hba.conf. This can be done in the following way: 

# PostgreSQL Client Authentication Configuration File 

# =================================================== 

# 

# This file controls: which hosts are allowed to connect, how clients 

# are authenticated, which PostgreSQL user names they can use, which 

# databases they can access. Records take one of these forms: 

## 

# TYPE DATABASE  USER    CIDR-ADDRESS     METHOD 

host  all     all     192.168.178.2/32   trust 

host  all     all     192.168.178.3/32   trust 

host  all     all     192.168.178.4/32   trust 

(…) 

Default port 

Please note that the default port 5432 is required for the PostgreSQL database server 

(not a possible helper installation). 

Datatype 'money' 

Please refrain from using the datatype 'money' for table columns. Please use 'numeric' 

instead. The datatype 'money' cannot be processed by the combit Relationship Manager 

and is also not recommended for useby PostgreSQL. 

Phonetic search 

To be able to use the phonetic search with the PostgreSQL database system, the support 

for phonetic search ("SOUNDEX") has to be activated during the installation of 

PostgreSQL (activated per default from version 8.3 and above).  

1.4 Client installation 

The client setup makes installation easy in large networks.  

Note: If you carry out a single workstation or notebook installation, client installation is 

not necessary. 

▪ Run the program "ClientSetup.exe" from the cRM program directory (depends on 

where the program files of cRM were installed in the server setup) and follow the 

instructions. 
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▪ Partial administrator rights are required for the installation. These can be confirmed in 

a dialog. 

▪ In the section "Ready for Installing" you can use the option "Define these settings as 

default for new clients" to define that the setup defaults will be used as the default 

for the wizard from now on. The settings will then be stored in the file "client.config" 

in the same directory. 

▪ By using the option "Don't apply these settings to this system" you can create the 

global configuration without applying it to the current system. That makes sense if 

you want to preconfigure the client settings on the server. 

▪ The client installation can be started with the parameter /quiet for an unattended 

installation through the administrator (RunOnce etc.). The settings will be 

automatically applied according to the file "client.config" in the same directory. 

▪ The user "Administrator" will be set for the first login. 

▪ The client installation can be executed anytime to change the settings. 

Copying program files locally 

In networks with low bandwidth the startup time of the application can be improved by 

copying the program files locally onto the client. If this option is activated, the program 

files of cRM (and the sub-directory "data") will be copied locally onto the client, so that 

cRM can use the local program files to start. 

For the cRM trial version this option is not available. 

We recommend this option only for networks with low bandwidth (e.g. dial -up 

connections), in order to speed up the starting time of the application. 

The work required of the administrator is increased in this way, because service packs no 

longer only need to be installed centrally. This option is therefore only suitable for 

experienced users. When a new service pack is installed on the server, the client 

installation must be started again. With the "Repair" option, the client will then be 

updated with any new program files from the server. Alternatively, the service pack can 

be installed directly on the client. 

1.5 Choosing a database connection 

If the client installation was not carried out, the database connection information of the 

server setup is used automatically. 

 To change or manually create the database connection, select F i le  > Options > 

Database Login. 

 Select the Database system. 
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 Under Database server , enter the instance name of the database server on which 

you have run the server setup.  

 Enter the login information for the database server: 

▪ Enter the database server user name that you had set up by the cRM setup 

(standard: "combit"). This is not the cRM login information!  

▪ When using the MS SQL Server you can also login through Windows 

Authentication. In this case, the Windows users must be set up in the MS SQL 

Server. 

▪ For more information about Windows authentification, see "MS SQL Server login 

method". 

1.6 Update installation 

combit strives to maximize backward compatibility. As the cRM is an extremely open, 

flexible and customizable product, it may not be possible to test any individual 

customization in advance, so we generally recommend to test your own scripts or other 

automation before the first productive use by generating test data. 

Update Server installation 

1. How to back up your data: 

▪ Backup the system database (combit_cRM_System) and the project database 
(e.g. combit_ *) directly in the database system.  

▪ Backup the cRM installation directory (e.g. C:\Program Files\combit\cRM). 

▪ Backup the entire project directory including input form definitions, scripts, 

transfer templates, global export/import templates, print templates (e.g. 

C:\ProgramFiles\combit\cRM\Solutions\). 
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▪ Backup the individual user settings and possibly user-defined templates in the 

application data directory (e.g. C:\Users\<User-

name>\AppData\Roaming\combit\cRM). 

2. Start the installation of the new version and follow the prompts. 

3. Install the new version in the same folder as the old version. 

Pay attention to the following notes: 

▪ An existing system database (combit_cRM_System) is recognized by the installation 

program and is automatically converted. Your user settings remain unchanged. The 

tables will be converted to Unicode (only necessary in MS SQL) and extended by 

some fields. 

▪ The last opened project database at this workstation (e.g. combit_ *) is recognized by 

the installation program and is automatically converted. By converting the fields from 

the schedule and task management are converted to Unicode (only necessary in MS 

SQL), a function to fuzzy e-mail search, and - if used in the solution - the views of the 

user management are created.  

Your data tables remain unchanged (in MS SQL your data will not automatically be 

converted to Unicode). 

Only MS SQL: Provided further project databases are available, when you open the 

database the dialog "The internal structure of the database has to be adjusted" will be 

displayed. In this case follow the instructions of the application, to carry out the 

structure adjustment. 

To carry out the structure adjustment, the stored procedure "cmbt_sp_Conter2NChar" 

is created and used. The cRM database user (e.g. "combit") requires "View Definition" 

rights to view this stored procedure, since otherwise the dialog "The internal 

structure of the database has to be adjusted" will always be displayed. This can be 

done e.g. through the query analyzer by running 

use <name of the database> 

GO 

GRANT VIEW DEFINITION ON [dbo].[cmbt_sp_Convert2NChar] TO [combit] 

GO 

▪ With the cRM5/6/7, changed/reset user passwords cannot be read by older cRM 

versions! 

▪ You have the opportunity to transfer your appointments and tasks from the time 

manager of cRM 2004 into the appointment and task management. To start the 

transfer, select "Migration time manager" in the cRM program group. This item is only 

available after an update installation and in German language only. 
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Update Client installation 

The client setup does not need to be run again on the workstations. This is only 

necessary when new functions are to be installed on a workstation or program files were 

installed locally. 

In this case, first remove any existing client installation through the control panel and run 

the client setup of the new version from the cRM installation directory again, where you 

can then activate any new functions. 

Update WebAccess 

Uninstall the old WebAccess installation via the Control Panel and then install the new 

version. For more information, see "WebAccess installation". 

1.7 Uninstall 

Uninstall server 

Start the uninstallation of the server installation from the control panel of the server. Then 

select the entry 'combit Relationship Manager 7'. After confirmation prompt, you can 

choose whether Solutions and personal settings should be stored. Then all components 

of the combit Relationship Manager be removed. Please note that the Microsoft SQL 

Server or PostgreSQL server used is not uninstalled. 

Uninstall client 

Select the 'combit Relationship Manager 7 - uninstall client' program group entry. After 

confirming the language setting the program guides you through the uninstallation of all 

components in the combit Relationship Manager client to be removed. 

1.8 WebAccess installation 

In this chapter you will find information on setting up the web server and creating a 

Solution for accessing the cRM via browser (cRM WebAccess). 

Note: This function requires either the Professional or Enterprise Edition. 

Notes: 

▪ In the IIS manager in "Web Service Extensions" the extension "ASP.NET v*" must be 

allowed. 

▪ The SSL encryption is supported. Please note: All of the content sent over SSL is not 

cached. The encryption of request and response means extra load on the server. 
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Encrypted content is greater than the original content and thus requires more 

bandwidth. 

▪ Also a port other than the default http port is supported. 

▪ To open a project by WebAccess the corresponding user-right "Open project per 

WebAccess" is required. 

▪ Please note that Auto Logs with "Prompt" active are NOT triggered in WebAccess. 

▪ Remark fields with text content greater than 4 MB can only be displayed but not 

changed or saved. 

▪ After the changes, you should empty the browser-cache and possibly also empty the 

cache in IIS (Open Internet Information Manager -> Select Application Pools -> Stop 

and restart). 

Features WebAccess 

Following features of the Windows client are supported: List view, Form view (limited), 

applying quick find, find, sort, stored filter expressions, output of labels/lists/cards, 

creating new/edit/delete records. 

WebAccess installation 

The WebAccess setup is running on the server that is accessible from the Internet.  

▪ Before performing the installation, ensure that the system requirements are met, ie 

Microsoft Internet Information Services (IIS) are installed and the. NET Framework is 

added as a feature. 

In case of a first configuration, configure the Microsoft Windows Server 2008 R2 as 

follows:  

1. Select the entry "Add Roles" 

2. Select the server role "Web Server (IIS)" 

3. Select the required role services for "ASP.NET" 

4. Select the entry "Add Features" 

5. Activate the feature "NET Framework 3.5.1" 

▪ The installation requires administrator privileges for the user. Select the entry "Run as 

Administrator" from the context menu. 

▪ Start the "combit.WebAccess_x64.exe" (64bit) or "combit.WebAccess_x86.exe" (32bit) 

from the cRM program directory and follow the instructions. 

▪ WebAccess must be installed to the wwwroot directory of the Microsoft Internet 

Information Services (IIS) (default location: C:\inetpub\wwwroot\cRM.WebAccess\). 
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▪ The files of the converted solution have to be copied to this directory after the 

installation. To convert the solution, see the chapter titled "Create a solution for 

WebAccess". 

▪  At the end of the installation, the server must be restarted. 

Access of cRM WebAccess on a solution 

If the cRM WebAccess wants to access a Solution on a different server, you have to 

define in IIS that the WebAccess runs with another user account. Follow these steps: 

▪ It requires a user that has access to the share with the Solution. So either a domain 

user or a user on both servers with the same name and password. 

▪ Add the user on the Web server to the local group "IIS_IUSRS". 

▪ In the IIS Manager, select the appropriate application pool in the "Application Pools" 

and under "Advanced Settings" determine the identity. For domain users "domain \ 

user", for local users only "username". 

▪ Input password 

Create a solution for WebAccess 

A solution can be created with an assistant for access per WebAccess and WebAccess 

Mobile. WebAccess Mobile is an optimized version for usage with Smartphones (iPhone, 

Android, Blackberry, Windows Phone) and Tablets (e.g. iPad). The user can decide 

between the classic and the mobile version in the login dialog. 

1. Start the cRM and open the project to be converted.  

2. Choose "Project > Make available for WebAccess.  

3. Select the directory where all generated files should be saved. In this path, a 

subfolder is created automatically with the project name.  

You can select if the solution should be created for WebAccess only, for WebAccess 

Mobile only or for both. For WebAccess Mobile the configuration can optionally be 

created on the basis of the last deployment or a saved configuration. 

4. A consistency check for the cRM project directory is performed afterwards. This 

result can be exported via the appropriate button. 

The following errors can occur: 

▪ A view can not be adopted if it has no field of type "Record ID". 

▪ Where a column layout has not been defined as a project default for a view or a 

container, the column layout must be defined manually or automatically created 

(depending on the setting) by the wizard. 
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▪ A project default column layout generates these in the cRM WindowsClient, by 

clicking the right mouse button on the column title (of a list or a container) and 

selecting Set as Project Default for Al l  Users  from the settings context menu. 

▪ A view can not be adopted if no input template (file extension .dli) exists (eg, 

database views which are only created for internal calculations). 

5. Then select those views that should be available in WebAccess. All views visible in 

the "Marked" area are converted. 

6. Choose settings for compiling the list views: 

▪ Automatically take existing column configurations of list views and containers: If 

this option is activated, existing column configurations are automatically taken. 

Enter a maximum number of columns to be taken. To optimize the speed only 

required columns should be included. We recommend to choose no more than 
10 columns. 

▪ Automatically proceed and do not wait for confirmation if fields are found: 

Views will automatically be created if a column configuration is found. 

▪ Automatically make a field selection if a column configuration is not available : 

When this option is enabled, automatically the defined number of columns is 

taken. We recommend to choose no more than 10 columns. 

▪ With the option "Only take fields on the first level (no relations)" only non-

relational fields are selected. 

▪ With the option "Ignore appearance and editability condition for buttons" buttons 

can be provided in WebAccess even if there are appearance or editability 

conditions for these buttons. 

7. The list views are created: During the conversion, you can see the converted view 

respectively the converted container (relation) above the progress bar. 

If the column configuration is not created automatically, you define which columns 

are displayed in this dialog. Use the arrow buttons to move those columns to the 

area "Show" which should be displayed in the list view for this view/this container. 

8. The input forms are created: During the conversion, you can see the currently 

converted view above the progress bar. Please close any possibly opened input form 

designer before this process. Start the process by clicking the button "Next >". 

9. After completion of the conversion, the dialog displays those controls that are not 

acceptable because they are not supported by the WebAccess. This result can be 

exported via the appropriate button. 

Please note that amongst others the following functions are not supported in 

WebAccess: 
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▪ Buttons of type "Execute Script File", "Execute Script Code," "Execute Workflow", 
"Predefined function", "Container.Document". 

▪ Formulas (and by that appearance conditions, content links, editability 

conditions, program calls and input validations) 

▪ Display formattings, groupings 

▪ Embedded graphics that are stored directly in the input form. 

Note: The file icon of embedded documents and graphics can be customized. To 

do this, create an according PNG image and save it in the following path: 

~/images/FileTypes/<File extension>.png 

10. If you also would like to provide a solution for WebAccess Mobile, select the mobile 

views to convert in the next dialog. All views visible in the right area will be 

converted and are available in the WebAccess Mobile project navigation then. 

11. Define the fields that should be displayed in the list and detail views of the 

corresponding view. Define at least 1 field each. 

You can switch between the views by using the buttons "Next view / previous view". 

2 lines can be defined for the list view. Select the fields that should be displayed in 

each line by using the button. Fields of the internal field type Unknown, Boolean, 

Picture, Icon, Embedded Picture and Code are not supported. 

Hint: The later record sort order in the list view is defined by the first sort order in 

the corresponding view in the Windows client. 

The detail view can display different objects that can be inserted with the button 

"New": 

▪ Heading: To define single sections (e.g. Master Data, Communication). 

▪ Fields: Can be renamed after they were added. Fields of the internal field type 

Unknown and Code are not supported. 

▪ Relations: You can generate an entry that allows switching to the linked view 

(e.g. Contact Persons, Activities, Sales Opportunities). 

12. You can now create the mobile list and detail views. 

13. To create the configuration file, first configure the database in the dialog from the 

perspective of the later server, on which the cRM.WebAccess should be operated. 

The Windows authentication is not supported. You can skip this step i f you already 

have created a valid project file (project.cfg). 
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14. To create the configuration file, then configure the path to the cRM project file 

(*.crm) of the cRM Windows installation from the perspective of the later server, on 

which the cRM.WebAccess should be operated. 

This may be a network share or a local copy, ie the cRM project file (*.crm) can also 

be copied locally on the server on which the cRM.WebAccess should be operated. 

Then, however, make sure that there is always the current version available. 

The same goes for the path to the print templates. It can also be a network share or 

a local copy. Also make sure that that there are always the latest versions of the print 

templates available. 

15. After completion of the conversion, you will find the project file (project.cfg) as well 

as the two directories DataSchemas and Views in the defined target path. In 

directory "Views" all input forms with the corresponding pictures are stored, in 

directory "DataSchemas" all list view configurations. 

This generated folders and files can be copied directly to the server or uploaded via 

FTP to a server. The correct target directory is the directory "cRM.WebAccess" of the 

WebAccess installation (see chapter "WebAccess installation"). 

If you upload them via FTP, define the corresponding FTP settings in the following 

dialog. If your firewall is blocking FTP access, you must allow the access. If the 

upload process will not start immediately, click again on the "Upload" button. 

1.9 License & License extension 

Select F i le > Help > About to display license information, edition and the serial number 

of the product. In addition to a purchase license, a rental license and test license are also 

available. 

To extend the scope of the license or change the edition, select "L icense Upgrade" in this 

text box or in the cRM application group. You can also release a cancelled rental license 

or a test version in the login dialog by clicking on the corresponding button. The license 

wizard can also started from the cRM program directory; it is called using the parameter: 

crmship6.exe/license. 

All licenses are for concurrent users. In other words, you can create as many users as 

you like, though only the number of licensed users have access at the same time. 

▪ If one or more cRM instances are running on a workstation with the same cRM user 

name (login), then these instances are jointly using exactly one cRM license. 

▪ If one or more cRM instances are running on a workstation with different cRM user 

names (login), then these instances use one cRM license for each different cRM 

login. 

▪ Each terminal server session is treated as one workstation. 
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▪ Rental licenses have a specified period of validity or can be terminated. 

▪ To check the validity of the rental license, you must perform a validity check at 

regular intervals. To do that, the work station must have an Internet connection 

through which you can connect to the combit Website. Then the basic and possible 

existing extension license serial numbers are transferred to our server. As long as 

their validity is confirmed, another check will not be necessary again until the month 

after next. 

▪ If a validity check is required, a message is displayed in the login dialog and in the 

taskbar notification area for all members of the Administrators group far enough in 

advance of the expiration date that the license must be checked within the next 

several days.  

In the login dialog and under F i le > Help > About , there is a "Validity Check" button 

for this.  

For automations this validity check can also be executed with a command line. 

/silent_rent:<ServerName>;<User>;<Password> 

<ServerName>: Database server on which the rental license is installed 

<User>: User with which the database server is accessed 

<Password>: User's password 

The check using the command line can also be started by a client. If there is an error, 

you will receive an error message. 

▪ If the validity check has not taken place after one week, all users receive a reminder 

of the necessary validity check in the login dialog. It also shows after how many days 

a validity check must be performed. There is a "Validity Check" button for this in the 

login dialog. After the specified days have gone by, the application can not be started 

until the validity check has been executed. 

1.10 Online registration 

It is recommended that you register your copy of combit Relationship Manager online. 

When you register your product, your serial number is saved in the combit database and 

you will be given access to special software offers as well as being informed of all 

upgrades or updates of your product in good time. 

 Click F i le  > Help > Onl ine -Registration . 

 Follow the online instructions and fill out the electronic form. 

1.11 Check for updates 

It is recommended always to have the newest available service pack installed. You can 

check whether a service pack or a new main version is available via F i le > Help > Online 
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Update Check. An automatic check for updates can be activated under Settings >. The 

service pack can be run on any computer that the client installation was performed on. 

1.12 Migration from combit address manager 

If you have worked with the combit address manager until now, the migration wizard will 

help you transfer as much information from your existing databases to the cRM as 

possible. 

Note: Please note that the migration wizard is only available in German and that the 

migration is only possible for a MS SQL Server, and not for PostgreSQL. You can, 

however, migrate the address manager database to MS SQL and then migrate this 

database to PostgreSQL using tools from third party sources. If you operate SQL 

Server 2008 to 2012, you will need the SQL Server 2005 Backwards Compatability 

package. Otherwise the error message "SQL DMO object not found" is displayed. The 

installation package can be found in the cRM program directory. 

The fol lowing transfer options exist:  

▪ Greatest possible transfer of data. Document and contact containers are transferred 

into relationally linked tables. The relational links are automatically set up in cRM. The 

previous field types are carried over into cRM-compatible field types. 

▪ Transfer of the existing input form. Documents and contact containers are turned 

into new table objects. For the according views, new input forms are created 

automatically. As far as possible, the address manager functions from buttons are 

automatically turned into the corresponding cRM functions. 

▪ Existing code field descriptions are entered into the new project. Function definitions 

for transfer templates, single print templates, single e-mails and programs of the 

selected user are also transferred. Existing sort orders can also partly be transferred 

in one step. 

▪ The fields that are transferred as numbers RECORDID and GROUPID are replaced in 

the input form through corresponding conversion formulas. A control should 

especially be carried for personally made formulas. 

▪ Reference containers cannot automatically be transformed or migrated into a 

relation, since they can also be database spanning. In this case, the contents of the 

reference container are transferred to a comment field. 

Please note that a double migration is not supported, meaning that a migration into an 

existing database only makes sense if it is two different address manager databases 
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(dbf files) or if such a database is to be integrated into an existing cRM database. You 

might migrate each separately and use the cRM project import afterwards. 

 

Starting the migration operation  

 Start the migration wizard using the file "am2crm.exe" from the cRM program 

directory on the server. Select the command Date i  > Migrieren. 

 Enter the previous address manager directory (generally the correct one is already 

suggested), as well as the user whose configuration should be used as a template. If 

there is no address manager directory on the current system anymore, just copy the 

address manager data directory with the databases from your previous address 

manager directory and enter the path to it here. 

 Then choose the desired database and input form. 

 Now choose the corresponding database server from the list. 

 Enter the existing database or, respectively, enter a new name for it. Please note that 

neither databases nor tables with the same name as the dbf-file or a container field 

may exist. Numbers may not be the first character. 

 Lastly, enter a file name for the new project file. You also have the opportunity to 

migrate further address manager databases into an existing project file. To do this, 

choose the option "Bestehende Projektdatei erweitern" . Note while doing this, that 

field descriptions are not allowed to occur more than once. If another field called 

"Documents" exists in a different database, for instance, it must be renamed first. 

 Start the migration operation with "Weiter", and it will run automatically. 
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2. Getting started 

In the following section you will find an overview of the user interface and the various 

settings that are available. 

2.1 User interface 

The user interface has various elements and windows: 

 

Gestures are supported in various places, e.g. input form (swipe left/right), list 

view/container (swipe up/down), report view (swipe up/down, Zoom). 

2.2 Ribbon 

The Ribbon contains tabs that can be clicked to get to the commands. The commands 

are sorted in groups as they will be used. 

Note: The classic menu and toolbars are available alternatively. You can change that in 

the general options (File > Options > General > User Interface). Further information 

about the assignment of menu commands to the commands in the Ribbon can be 

found under "Ribbon and Toolbars" in the appendix. 
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General 

Frequently used commands are available quickly; less frequently used commands are 

less highlighted in the Ribbon. 

▪ The view menu contains all view specific commands. 

 

▪ File menu: The F i le  menu contains all user specific configurations and global 

commands for use with the project. 

 

Context Sensitive Ribbons 

Several other commands will only be displayed as a reaction to an executed action, when 

you probably will need them: 

▪ Edit: When you edit records the tab Edit will be displayed. The tab contains the 

commands you need to work with records. 
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▪ Manual F i l ter: When you compose a manual filter the tab Manual Filter will be 

displayed. 

  

▪ Report: When you display a report the tab Report will be displayed.  

  

▪ Appointment: When you select an appointment the tab Appointment will be 

displayed.  

  

Minimizing the Ribbon 

The Ribbon can be minimized to get more space on the screen. 

 Click on the small arrow in the top right of the Ribbon. 

 You can quickly minimize the Ribbon by double clicking the name of the active tab. 

Double click again on the tab to restore the Ribbon. 

You can use the Ribbon when it is minimized by clicking on the desired tab first and then 

on the desired option or command. 

2.3 Navigation 

Navigation offers you a centralised method of navigation and easy access to different 

areas. 

You can turn large buttons into small buttons which can be displayed in a single row of 

symbols at the bottom edge of the navigation area. To do this, click on the bar at the top 

edge of the buttons and drag the separator up or down as soon as the cursor has 

changed into a double-headed arrow. 
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▪ Info Center, appointments/tasks, calls. These 

internal views can be hidden completely. Further 

information can be found under "User interface" in 

the chapter "General configuration". 

▪ Views: The arrangement of the views can be 

configured under F i le > Information > Navigation 

structure . Further information can be found under 

"Navigation structure" in chapter "Configuration of 

projects". 

▪ Favorites: Here you can add commonly used 

records to folders of favourites. Further 

information can be found under "Favorites" in 

chapter "Entering and editing data". 

▪ History: References to the recently viewed 

records are saved here. Further information can be 

found under "History" in chapter "Entering and 

editing data". 

▪ Instant reports. 

▪ Filter. 

▪ Active user: Here you can see the users who are 

currently logged in. 

2.4 Info Center 

The Info Center is a central HTML-based view that can be used as a general information 

gateway. To open the Info Center, click the item in the navigation or select Window > 

Info Center. Internet Explorer version 6 or above is required to display the Info Center. 

The path to this HTML file can be defined under F i le  > Information  > Properties > 

Settings. Further information can be found in chapter "Configuration of projects". 
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2.5 Customizing the user interface 

You can change certain elements of the user interface to better fit your working style. 

Customizing program windows 

These customizations are independent of the views that are open. 

Display of windows 

▪ To show/hide the navigation, select Windows > Navigation. 

▪ To show/hide the window displaying dupes, select Windows > Dupes. 

▪ The tabs can be placed at the top, bottom, left or right through the context menu. 

▪ To change the display order of the views, drag the corresponding tab to the desired 

location by holding the left mouse button.  

▪ Through Windows> Close All you can close all windows. 

▪ Through Windows> windows, all open views are shown. You can select which view 

to bring to the front here. 

Auto Hide  

The global windows navigation and dupes can be hidden automatically in the 

background, so you can use the entire main window. Click in the title of the window on 

the button "Auto Hide".  

 

If you liked to let the window indicate again, move the mouse over the appropriate 

switching surface at the lefthand side of the main window. 

Docking and Floating 

The global windows navigation and dupes can be integrated alternatively into the 

interface or like independent dialogues be opened, so that they float as individual 

windows freely.  

Select the title of the window and shift them with further pressed mouse to any place, in 

order to put it down there. Over a rectangle framework one represents, to which place 

and with which size the window was put down. Alternatively you can pull the window 

also on the represented arrows, around which windows at the right, left , to lower or top 

margin (condition for system: a higher depth of shade than 256 colors).  

If you pull the window to another place, it is not docked and freely adjustable (floating).  
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Customizing the list view and container view  

The list view and the containers can be customized for each user. Even with containers 

of the same relation, it is possible to individually set the layout, column title, sort order 

and filter for each container. 

Right-click on the column title and select Settings > Layout and Columns.  

 

 

Configuring columns 

In the "Columns" tab, you can define which columns are visible in the list view or 
container. To mark several columns at once, hold down the CTRL key while making your 
selections. Through the two buttons in the middle, the fields can be transferred into the 
opposing list. 
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By default, only the columns contained in the view are displayed and no fields of 

relationally linked views.  

In addition, the column arrangement can be configured through the arrow buttons. 

Column arrangement can also be carried out directly with the mouse by clicking a 

selected column title again with the left mouse button and dragging it. 

By clicking on the "View formatting" button, the formatting can be specified for the 

selected field. 

The column settings (title, width, formatting, etc.) are not saved if the column is hidden 

(exception: the column has been explicitly set to "not editable"). 

Configuring the appearance 

In the "Appearance " tab, you can configure the various display options of list and 

container views. 

 

In the "Colors" area you can make various changes to color settings.  

▪ The option "Like Windows" uses the same color scheme and theme as 

Windows. 
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▪ In the "Customized" mode, you can select the type of row for which you wish to 

change the color, and then click on the "Edit" button. 

▪ With the sliding controller "Zebra pattern " you can define the intensity of the zebra 

pattern and with the "Color" button, you can define the color of the zebra pattern. 

▪ In the "Display" area, you can set font attributes, display effects and the line height of 

the data lines.  

Note: To enable word wrapping in a list with several lines, the internal field type 

"long character" is required. 

Horizontal scrolling 

In the "Options" tab, you can set how horizontal scrolling is to be carried out.  

▪ For horizontal scrolling, choose between column-by-column, distance in pixels or 

scroll distance in percentage of the visible frame. A scroll distance of 50% means 

that half a visible frame will be scrolled. 

▪ The option "Beep" informs you when you reach the record limit, or if you are trying to 

edit a field directly in the overview list or container for which you have no write 

permission. 

Definition of the column properties  

To change the individual column properties, right-click on the column title and select 

Settings > Column Properties . In the following dialog, you can change the name of the 

field displayed within it to that of your choice. 

 

With the button "Set column titles automatically" you have the following options, in order 
to change all column titles in a step or cancel changes: 
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▪ Truncate All Column Titles to Resp. Field Name (e.g. "Company") 

▪ Truncate All Column Titles to Resp. Relation Alias + Field Name (e.g. Company. 

Company) 

▪ Reset All Column Titles to Resp. Complete Field Name (e.g. CompanyID. 

Companies.ID.Company) 

Columns can also be marked as (not) editable. This way only certain columns can be 

released for direct editing in the overview list/container. 

Saving the layout of a list/container view for all users  

Changes to the layout are only saved for you personally. If other users wish to have the 

same layout, the configuration can be saved for the entire project and thereby for all 

users. 

 Right-click on the column title and select Settings > Set as Project Default for Al l  

Users. All the layout settings of the list/container view are saved in the file 

<viewname>.vlc in the project directory. For containers, the current filter setting of 

the associated combobox is also saved.  

 All users who load the project in question will now receive the settings you chose, as 

soon as the corresponding view is re-opened. 

 If a user changes the configuration again at a later date (and does not save for the 

entire project), the changes are saved in the registry and are used again from there. 

This means the newest configuration is always loaded. If, however, you wish to 

revert to the configuration saved for the whole project, you can do this by selecting 

Settings > Reset to Project Default . 

Customizing ribbon 

Customizing the ribbon can basically be done like in other Office products, therefore the 

following description is kept relatively simple. 

Commands 

 Right click on a group in a tab > Customize . 

 Select the tab in the right area "Main Tabs". 

 Select an existing tab in the option field over the left column.  

 Select the desired command and add it to the desired group with a click on Add. 

 Sort commands: Drag the commands and drop them onto the desired position in the 

Ribbon. 

 Remove commands: Select the command and click Remove. 
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Tabs and Groups 

You can insert frequently used commands within a user defined group into a standard or 

user defined tab. 

 Right click on a group in a tab > Customize . 

 Select New Tab to create a new user defined tab with an empty user defined group 

under the selected tab. 

 Rename tab: Select and click Rename. 

 Sort tabs: Drag the tab and drop it onto the desired position in the Ribbon or move it 

with the Arrow Up/Down buttons on the right, groups cannot be moved. 

 Remove tab, group: Select the tab or group and click Remove. A tab and a group will 

be deleted with all their content. 

 Hide tabs: Uncheck the checkbox of a tab by clicking it. To show them again check 

the checkbox again with another click. 

Reset, Import and Export Ribbon 

 By using the option Reset you can undo all changes in the Ribbon quickly. With 

Import/Export  you can transfer your individual settings to or from other installations. 

2.6 Sources of help 

Apart from this manual, various sources of help are available to you: 

▪ You can reach the Knowledge Base, the forums, the support area and the online 

support using F i le> Help> Support . 
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▪ Select F i le> Help> help for the online help. With F1 you can access context-

sensitive online help. 

▪ You can find additional information in PDF format in the directory "Docu" of the 

program-installation. 

▪ combit tip wizard: The combit tip wizard provides context-sensitive information in the 

notification area of the task bar through a pop-up window. This information may, for 

example, be about an existing product movie. Start the program through the program 

group or through F i le > Options > General  and activate the option "Start combit 

H ints". 



Entering and editing data 

48 

3. Entering and editing data 

cRM supports the entry of Unicode characters. Unicode (also known as UCS, UTF-8, 

ISO10646) is an international standard with which over the long term each character in all 

known writing cultures and character systems can be mapped and processed.  

3.1 Opening views 

A view refers to a way of "looking at" a database table or a database view. The views of a 

project can be linked together relationally. The overview list and input form input form are 

different ways of displaying the data in a view. To open a view, click the required view in 

the project navigation. As this is a relational database, you can open multiple views at the 

same time. 

By clicking on a view or on a container entry, you switch to an already opened view as 

long as it is not in change mode. In the views context menu of the project navigation, you 

also have the option "Open in New Window".  

3.2 Displaying the records 

You can display records in a list or individually as forms. A report view and a web view 

are also available. 

Use the arrow buttons at the bottom of the view to switch between records in the actual 

sort (display the first, previous, next or last record in the view). 

 

An alphabetic filter as a toolbar is also provided for rapid navigation. This filters according 

to the selected letter using the current sorting. The current filter is always used, unless it 

is already an alphabetic filter; then the previous filter is used. 

 

List view 

In the list view, all the records are shown in a clear table. This makes it possible to gain a 
quick overview of the records. 

▪ Starting to type in the list view will trigger the quick search dialog. 
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▪ To scroll from record to record, several arrow buttons are available to you on the 

right side of the window. With these, you can jump to the next record, to the next 

page or right to the start or end of the list.  

▪ If you want to look at a complete record, you can switch between the overview list 

and the detail view with the "plus/minus" buttons in the bottom right corner of the 

view.  

▪ Records can be displayed as a group. Right click on the column title and select Sort 

Order > Group Single  or Group Multiple . The records will then be displayed as a 

group corresponding to the selected sort order. When Group Single  is selected only 

the first sort order criteria will be considered. 

 

Input form view 

In the input form view, all information is grouped by subject. You can enter data into a 

record here. With the input form designer, you can design the input form of any view. 

Further information can be found in chapter "Input form designer". 

Web View 

In the Web View you have the option to display websites or your own HTML pages. You 
can set a different page for each view. The website to be displayed is set in the view 

configuration. Further information can be found under "General" in chapter "Configuration 
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of views". 

Report View 

In the Report view you can display a report preview. Use the buttons on the toolbar, you 

can scroll through the records here, if you chose current record as Data. The window 

contains a tool bar on the various functions of the preview can be controlled.  

 

3.3 Creating a new record 
 Select Start > New. The input form of the current view shows a record with empty 

fields, in which you can now enter the new data. 

 Using the <Return> or <Tab> keys you can move to the next field. 

3.4 Editing a record 

You can edit records in the input form view, list view and containers. 

In the input form view 

 Click on the field that you want to edit to enter the edit mode. 

 Enter the new data and save the changes afterwards with Edit > Save. 
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 If you are in the input form view in edit mode and have made a change to a field that 

you wish to undo, select the function Edit > Undo. With Edit > Cancel  all field-

changes in the record are discarded. 

 With Edit > Cut you can quickly remove marked text in a field. 

 Edit > Copy copies marked text into the clipboard. With Edit > Paste  you can then 

paste the text back into another field. 

 Using the <Return> or <Tab> keys you can move to the next field. 

In the list view and containers 

 Click on the field that you want to edit to enter the edit mode. 

 After closing the input field by clicking another location, the changes to the record 

are immediately saved. This can also be triggered by an appointment reminder or an 

incoming call. The events "Record is being saved" and "Record has been saved" are 

not triggered. 

 

▪ If a field of type "Memo field" is longer than 256 characters, it cannot be edited 

directly.  

▪ If the list is sorted by the field being edited, the record will not automatically be 
re-sorted. 

▪ An input rule defined in the input form is ignored if editing directly in the 
overview list. 

▪ The special functions of certain fields (e.g. combobox selection list, icon 

selection list) are not available when editing in the overview list. 

▪ The editing conditions are defined by the normal field rights. A field-specific 

editing limitation defined in the input form is ignored. 

 With Edit > Cut you can quickly remove marked text in a field. 

 Edit > Copy copies marked text into the clipboard. With Edit > Paste  you can then 

paste the text back into another field. 

Duplicating records 

If you want to create a record that differs only slightly from another, you can save lots of 

a time by duplicating the existing record. To do this, select Start > New > Dupl icate . 

Then, you simply have to mark the fields that you wish to be duplicated and confirm with 

OK. 
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Note, however, that no relations or any existing 1:1 and 1:N records are copied with it 

and in the field selection dialog, only the fields that can be copied are displayed. This 

means that any fields that are currently being occupied or calculated are not shown. 

Deleting records 

 With Start > Delete  you can delete the current record. 

 With Start > Delete  Al l  you can delete all records. If you have not set a filter in 

advance, all records in this view will be deleted. 

Working simultaneously 

Locking behavior is how the database behaves when several users are editing the same 

record at once. If, by chance, a colleague is in the same record as you are and is also 

making changes to it, the question arises whose changes should be accepted. 

In this case, a dialog will open automatically in which the changes made by yourself and 

the other users are listed. 

 Now select the field contents that are to be used. 

 With the "…"-button you will enter another dialog in which you can change your input 

manually, for the situation in which neither entry is correct. In this way, you can use a 

combination of both entries. 

3.5 Relationally linked records 

You can connect records in any way. For example, you can assign a contact to a 

company and different activities or projects.  

▪ Relation 1:1: Clear assignment of two records. 

Example: Every activity is assigned exactly to one contact, which means you connect 

an activity to a contact. 

▪ Relation 1:N: Assignment of multiple records to one record. 

Example: Each contact can be assigned to any number of activities, which means 

you connect multiple activities to one contact. 

Relation N:M: Multiple records can be assigned to one single record. Since the 

records are clearly connected to another record (1:1), by using this relation, by 

double-clicking you can jump directly from one container to this record. By selecting 

a 1:N relation, the link view will automatically open, even if you double -click on a field 

in the target view. 

Example: Each contact can be assigned to any number of projects. The projects 

should also be able to be assigned to multiple contacts. Therefore, you need a link 
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view where the assignment of contact and project is saved. If you select an N:M 

relation for both 1:N relations, you can for example jump directly to the connected 

project by double-clicking the project name in the project container of the contact 

view. 

Information regarding the configuration of relations can be found under "Relations" in the 

chapter "Configuration of views". 

1:1 relationally linked records 

To link a contact to a company for example, click on "Link to a company" at the top right 

of the "Contacts" view in the reference project "Medium" which is included.

 
 

▪ All records from the linked view, which are available to be linked, are displayed in a 

list. Select the record by double-clicking it. There is a search tool in the selection list. 

To search simply type in the word you wish to search for. It is not necessary to call 

up the search function. The field set in "Find Text" will be searched automatically. 

▪ By right-clicking this button, the link can be removed again. 

▪ During selection, for those records displayed in the list, a filter can be created which 

sets the records to be displayed. Current field contents can be used as comparative 

values. "Button" in chapter "Scripts and programming reference".  

Assignment of multiple records to one record (containers) 

All 1:n relationally linked records (e.g. contacts, activities, documents) are displayed in 

containers. If a new record is created through the container in the linked view, the new 

record will automatically be relationally linked with the active record. There are buttons 

available for many of the functions in the container’s context menu. 

▪ By double-clicking an item or by right-clicking an item and selecting "Edit", the 

associated record will be displayed and can be edited.  

▪ When right-clicking an item, various field-type-specific menu items are available (e.g. 

dial number, send e-mail, new document, open document with associated 

application, edit) 

▪ By right-clicking an item and selecting "Delete", you can delete linked records.  
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▪ By right-clicking in the container and selecting "New", you can create new records in 

a linked view. The created record is automatically relationally linked to the active 

record.  

▪ The fields can be edited directly. After closing the input field by clicking another 

location, the changes to the record are saved immediately. If a field of the 

"Characters long" type is longer than 256 characters, it cannot be edited directly.  

Please note: if the list is sorted by the field being edited, the record will not be re -

sorted automatically. 

▪ If a field with multiple lines can not be displayed completely, a tooltip with extensive 

content is displayed for the selected lines. 

▪ The records in the container can be filtered by a combobox. Further information can 

be found under "Button" in the chapter "Scripts and programming reference".  

Assignment in link view (N:M relation) 

All N:M relationally linked records (e.g. projects, products) are also displayed in 

containers. The linking of the two records is carried out in a link view (e.g. 

ProjectAssignment). 

Example: To assign a contact person to a project, in the "Contacts" view, right-click the 

project container and select "New" in the context menu. A new record will be 

automatically created in the link view "Project Assignment" and assigned to that person. 
Select the project by clicking the "Select project" button.  

 

▪ By double-clicking an item in the link view (e.g. comment), the link view (e.g. 

ProjectAssignment) is displayed. By double-clicking an item in the target view (e.g. 

project name) the linked record is displayed directly in the target view (e.g. project A 

in the "Projects" view) 

▪ When you right-click an item, various field-type-specific menu items are available 

(e.g. dial telephone number, send e-mail, new document, open document with linked 

application) 

▪ By right-clicking an item and selecting "Delete", you can delete linked records. A 

button is also available for this function. 

▪ By right-clicking in this container and selecting "New", you can create new records in 

a linked view. The record created is automatically linked with the active record. A 

button is also available for this function. 
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3.6 Sorting records 

With this function, you can define different sort orders or view criteria that are then 

available to you to order the records. The records can also be displayed unsorted. 

 To change the sort order of the list view or of a container, left-click on the column 

title.  

 To change the sort order of the input form view, select the required sort criteria in 

the Direct Find/Filter-Group. 

 

 With the adjacent buttons, you can set whether the sort order is to be "Ascending" or 

"Descending".  

Define a new sort order 

To define a sort order, all fields in the current view and all fields from views linked with a 

direct 1:1 relation are available. 

 Select Settings > Sort Orders. 

 

 With "New" a new search criterion is created. Firstly, give it a suitable name and then 

select the field by which the data is to be sorted. By clicking the "Direction" column, 

you can set whether to sort in ascending or descending order. 

 If you wish to create a criterion that covers several fields, you can add further fields 

with the "New" button. 

Example: If you have several contacts within one firm, it is sensible to create a sort 

order for the COMPANY and NAME fields (in that order). The sort order will then go 
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by the firm name first. If the firm name is the same, the sort order will go by the 

contact name. 

 

 After confirming with "OK", you are taken back to the dialog with the overview of 

search criteria.  

 If you end the dialog by clicking "OK", the selected sorting will be activated. 

Note: Sorting order applies to all users. To create it, the right to "Change configuration 

of the project" is required.  

3.7 History 

References to the last viewed, edited or newly created records are saved here. This user-

specific list of records is displayed in the navigation window.  

Alongside the record, the associated view and the time of recording is stored for every 

entry. Double-click the required record to display it. When you point at an item with the 

cursor, the reason for its presence is displayed (new record, edited, length of stay). 

The period after which a record is automatically added to the history can be set. The 

references are also deleted automatically after a certain time when the program is 

started. 

▪ Both values can be set under F i le  > Options > General  > History . Further 

information regarding the configuration can be found under "Settings" in chapter 

"General configuration". 

▪ The history log is activated individually for every view in the view configuration on the 

"General" tab. 

▪ The field contents of the "Record" column are defined in the view configuration on 

the "Record Reference" tab through the formula in the "Subject/Comment" field. 
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Further information regarding the configuration can be found under " Record 

reference" in chapter "Configuration of views". 

3.8 Favorites 

If you work on certain records often, you can add a link to these records to your list of 

Favorites, so that they can be displayed quickly and easily in the future. This allocation is 

saved specifically for the user over all views for every project. To open one of the 

Favorites, double-click on the corresponding item in the list of Favorites or right-click the 

item and select "Go to Record" from the context menu.  

 

Adding Favorites 

 Go to the record that you wish to add to your list of 

Favorites.  

 Select Start > Reference > Add to favorites.  

 If desired, enter a name for the record and then 

press RETURN.  

Organizing Favorites 

When your list of favorites starts to grow, you can 

create folders to keep it organized. The structure can 

be adapted freely and new hierarchies can be added as 

desired through the context menu. The items can be 

arranged by drag & drop and can be named as required. 

 Right-click on the list of favourites and select "New 

Folder". Enter a name for the folder and press 

RETURN.  

 You can move the records and folders in the list 

with drag & drop. 

 Through the context menu, you can also delete, 

rename and copy favourites and folders. 

3.9 Categorizations with codes 

Within a view, you can separate the individual records further by category. For this, you 

can use special fields for code attributes. These are special list fields. Each of these 

items stands for a particular category or an attribute of the corresponding record. With 

these categorizations it is possible to create filters with the desired selection groups 

quickly. 
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Because of the large number of possible categories and the clear layout of the lists, code 

fields can especially be recommended when you are working with many different 

attributes / categories. They also help to prevent the spread of inconsistent notation. 

When the code attributes are activated for the addresses, you only have to set the code 

attribute you want to select when creating a filter later on. 

▪ The code attributes can also be created or deleted for a whole selection when re -

organizing the records. Assuming you have a small, manageable set of addresses 

and want to keep them in a single file. The code attributes are a way of  

differentiating between supplier addresses and customer addresses, classify events, 

(trade fair A, trade fair B) or other categorizations 

▪ (Reference customer for product A, reference customer for product B). 

Note: When defining the codes, you should make sure that you leave some codes 

empty between the groups, so that these can be used in the future to expand without 

having to restructure. 

If you have created a code field you can assign defined code attributes when entering 

data. For example for products, mailing information, etc. filters or selections can later be 

created according to these attributes. 

 

To assign codes, you must do the following: 

 Click in the relevant code field. The previously defined attributes are displayed 

automatically. Codes that have been chosen already are colored. 

 Now, simply select the codes you wish to assign by clicking on them. 

Tip: If you wish to assign new code attributes to a whole selection of records, or wish 

to edit them, you can do this through Data > Modify . More information about this can 

be found in the chapter "Data organization". 
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3.10 Supporting automatisms 

Using various automatisms, you can make data entry and changes to records even faster. 

Some of the following functions have to be configured in advance, but doing so will 

certainly save time in the future. 

Some of the automatisms, such as content links, comboboxes, autotext and dupe control 

have already been described in the chapter "Know how! – Considerations", and so will not 

be discussed here further. 

Efficient data entry 

Data entry and the maintenance of the addresses are an extremely important aspect of 

work. It should be undertaken carefully. Just think about how often you normally have to 

type addresses and how much time you would save by avoiding having to type out an 

address only once. 

Regardless of whether you prefer using the mouse or the keyboard for the operation of 

the interface: When entering an address you should definitely move from field to field 

(e.g. from firm1 to firm2) using the keyboard (using the RETURN or ENTER key). Enter the 

contents of each field and complete the entry by pressing RETURN to move to the next 

field. If a field needs to be left empty, simply press RETURN again. The intelligent layout 

order of the fields pays off here considerably. 

Content links 

As mentioned in the example, a content link can fill in one or more associated fields 

using the contents of another field. 

Content links are available for the field types "Edit Control", "Combobox" and "Checkbox". 

They are not limited to a link between two fields; a field can be assigned many content 

links. They also have the ability to link several fields after another, i.e. field1 -> field2 -> 

field3 etc. 

Content links are useful for the form of address, like in the previous example. For this, 

you define a content link from the field "Salutation" to the field "SalutationLetter" and set 

up an "If-Then" content link.  

▪ If title = "empty", then form of address = "Dear Sir/Madam". 

▪ If title = "Mrs", then form of address = "Dear Mrs". 

▪ If you now enter "Mrs" as the title, the corresponding form of address is entered in 

the corresponding field. 

You can create as many of these links as necessary. They are defined in the input form 

designer. Further information regarding this can be found in the corresponding chapter. 
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Working with comboboxes  

Comboboxes are particularly useful for fields for which there are usually only a set of 

possible entries. One example for this would be titles ("Mr.", "Mrs.", e tc.), which are kept 

in their own field. 

If the combobox contains editable text, an automatic completion mechanism helps to 

speed up data entry. While you are typing, the first "fitting" item in the combobox is 

searched for and can be chosen with the "arrow down" key. If you have not yet started 

entering text, but the cursor is in the field, you can access the selection dialog with 

"ALT"+"Arrow -Down" 

Information regarding the definition of comboboxes can be found in the chapter "Scripts 

and programming reference". 

Working with field-specific text blocks (autotext) 

With these, the largest amount of typing work can be saved. For any recurring item 

entries you define an automatic text block. This autotext can also contain formu las, e.g. 

for the automatic entry of username and date in a comment field. During data entry, if 

you enter the respective key the autotext will be filled in automatically. 

During data entry, your typing is thereby limited to a few keys. Not only tiresome typing 

is saved by this method though. With autotext entries, any typos can be automatically 

corrected! Further information regarding this can be found in the chapter "Scripts and 

programming reference". 

Note: Especially in network operation, conventions about which fields are used and 

how certain contents are expressed word for word are indispensable so that searching 

and extracting addresses does not become a chore and all users have a chance of 

finding a record quickly. 

Auto log 

With this function, you can let entries to different fields be made automatically, e.g. 

about a successful transfer, an e-mail or an appointment. More information regarding this 

can be found in the chapter "Configuration of views". 

Dupe check 

While entering data, you can already let this check for double items. A description of how 

you can set this function can be found in the chapter "Configuration of views". Through 

F i l ter > Dupe  Check you can find double items at a later point. 

Over time, you will discover more and more ways of saving time while working with your 

data. 
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ZIP/Area code directory 

A database is available for several countries (D, CH, AT, USA), including postcodes and 

area codes (if available) are stored. If you make an input into a field of type "Zip code", 

"City" or "Phone" and then move on with the <Return> or <Tab> key, the other inputs 

into the fields of type "Zip code", "City" or "Phone" are made automatically. 

 

 Enter "78462" in the field for the ZIP code.  

 As soon as you jump to the next field, "Konstanz" as the city and with content links 

the according area code "07531" will be entered. 

As well as the zip code directory, a road and post office box directory is included. In this 

directory, the zip codes are itemized by city and street. Zip codes for the post office 

boxes are also included. The street directory applies itself in many different places 

because of content links, e.g. 

 As soon as you have entered the country and zip code, the city is automatically 

entered. If you now move to the street field but do not enter anything and skip to the 

next field, the street directory will open automatically and display the streets 

belonging to the city. 

 Even if you only enter the city name but no zip code and no street, the street 

directory will open automatically as you move through the fields. 

 Now, you simply have to select the relevant street and it is used in the record, if 

necessary the zip code too. 

Important: These content links are contained in the reference project so you can use 

them in your own projects. 
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You can also use your own databases as a directory as long as they are the same file 

format (dBase) and have the same field development as the EN-Directory provided with 

it.  

Internet connectivity 

You have the option of opening internet addresses directly. The web browser can be 

started directly with the URL from an "Internet" field via the context menu item "Cal l Web 

Browser". The program uses the default browser installed on your system.  

Further information regarding field types can be found in the chapter "Configuration of 

views". 

Running external programs 

There are different ways of running other programs, either through a function definition 

or through a link with a field in the input form. 

Using a function definition: With this method, you can run other programs independently 

from individual fields. More information regarding this can be found in the chapter 

"Configuration of views". 

Using a link in the input form: You can run different programs from every field and pass 

on any parameter, such as the field contents. In this way, for example, word processing 

can be started with a particular document or a particular graphics program. Information 

about creating links like this can be found in the chapter "Input form designer". 

3.11 Data entry with address pick-up 

With this function, you can transfer an address straight from the clipboard and let the 

data be entered into the relevant fields of a new record. You can easily transfer 

addresses from the internet, an e-mail or a text file (e.g. one produced by your scanner) 

into a new record. The address pick-up recognizes the individual address parts and sorts 

them correctly. Insofar as an email address is copied and it already exists in the record, a 

new record will not be created, but rather the existing data will be updated, only if the 

field has no content. 

Transfer addresses 

 If you have an e-mail with an address that you wish to transfer, copy the address into 

the clipboard.  

 If you would like to copy the contents of a vCard, simply double-click it. 
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Note: This function is only possible if the *.vcf file extension is connected to 

cRM. Make this setting when carrying out the work station installation 

(client.exe). 

 If Cl ipboard monitoring is activated, address pick-up will now notify you of a possible 

address. 

 

 Now press the previously defined hotkey or select "Transfer to combit Relationship 

Manager" (or the desired view, if several targets are defined) from the address pick-

up menu. 

 In the following window, you can edit the transfer if required. With drag & drop, you 

can transfer the pieces of the original text to the fields. 

 After clicking on "Apply" a new record will be created, as long as no other record 

could be identified by e-mail address. The different data will be entered into the 

correct fields because of their allocation. 

Tip: If you wish to transfer an address from Microsoft Internet Explorer, address pick -up 

will save you the step with the clipboard. You only have to mark address data in 

Internet Explorer and then open the context menu with the right mouse button. From 

here, simply select "address pick-up: Transfer to combit Relationship Manager" and you 

will move straight to the "Edit address before transferring to combit Relationship 

Manager" dialog. 

Configuring the address pick-up 

 Start the address pick-up under F i le > Help > Tools. Alternatively, address pick-up 

can also be started automatically with the cRM. Further information can be found in 

the chapter "General configuration". 

 Then right-click on the address pick-up icon in the notification area of the Windows 

taskbar and select "Settings". 

▪ Create a new transfer target with the button "New". First set the target program, 

in this case cRM. Now configure the project and view. 
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▪ Select the button "Edit", if you wish to edit an already existing transfer target. 

 In the following dialog, enter first a username, any passwords, the required project 

and the target view. Then allocate the fields. 

 

 With the "Automatic" button, you can let fields be allocated automatically. If you 

activate "Search record by e -mai l  address (i f possible )" , the e-mail address is 

searched for in the target view. If it is not found a new record is not created, but 

instead the current one is completed with the new data. 

Back in the configuration dialog, you can extend the list of transfer targets in the same 

way as required. 

 To define a hotkey for a transfer target, click the "Hotkey" column in the 

corresponding row and enter the desired shortcut. 

 In the "Settings" tab, set the required telephone number format that is to be used in 

the transfer. You can also set whether address pick-up is to be added to the Startup 

folder. 

 If you tick the "Cl ipboard monitoring" option, address pick-up will later notify you with 

a speech bubble if a text item in the clipboard is recognized as an address. 
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3.12 Referencing a record 

With this function, you can send a colleague or other cRM user a so-called "Reference". 

With a reference, your colleagues can reach the corresponding record with a simple 

mouse click.  

 Select Start > Reference > Send To. 

 The dialog for a new e-mail is opened automatically. If you made a formula for the 

subject when configuring the view, this will already be entered. 

 

 You now only have to enter the recipient and any message you wish to send. 

 The recipient can then move directly to the relevant record by double -clicking the 

attached file. 

Note: For the recipient to be able to reach the record, he/she must have access to the 

respective view. 

Save a record reference 

If you wish to keep a reference for later use, you can save it: 

 Select Start > Reference > Save As. 

  Enter the path where the reference file is to be saved. Later, simply double -click the 

file to move straight to the record. 

If you do not wish to save the reference, but want to store it temporarily, you can do 

this using the clipboard. To do this, select the command Start > Reference > Copy to 

Clipboard. 
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3.13 Merging records 

With the function Start > Extended > Merge Records it is possible to merge two records 

into one. The active record is the primary record in this process, in  which the result is 

saved. The secondary record can then be automatically deleted.  

Merging records 

 Select Start > Extended > Merge records and then choose the record, which is to 

be merged with the active record.  

 In the "Merge records" dialog, the field contents from the primary and secondary 

records are displayed. In the final column, the field contents of the resulting record 

are shown. The field contents of the primary record are used as default.  

 With the button "Switch the primary record with the secondary record" the records 

can be swapped. All changes made so far are lost and the merging rules are carried 

out again.  

 With the "Filter" button, you can hide the fields for which the contents in the primary 

and secondary record are identical. 

 

Transfer entire content 

 With the button "Use the whole  primary record as result"  or "Use the whole  

secondary record as result " the entire content of one record can be used in the 

result.  
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Using individual field contents 

For differing field contents (conflicts), you decide which contents are to be used in the 

resulting record. Fields for which you do not have write permission are marked grey.  

 To transfer a single field content of the primary record into the resulting record, 

double-click the corresponding conflict in the primary column or click the "Use the 

fie ld of the primary record as result " button. 

 To transfer a single field content of the secondary record into the resulting record, 

double-click on the corresponding conflict in the secondary column or click the "Use 

the fie ld of the secondary record as result"  button. 

When individual field contents are used in the resulting record, the origin is shown by 

color: 

▪ Blue: Field content from primary record 

▪ Green: Field content from secondary record 

 With the "Memo" and "Code" field types, you can open a special transfer dialog by 

double-clicking the field. In this dialog, you can edit the resulting field directly. 

 Embedded documents and embedded files cannot be displayed. 

Starting the merger 

With the "OK" button, you start the merging of the records. The process is done 

according to the merging options. 

Please note that the merger of the records cannot be undone and that the records cannot 

be restored in the case of an error. If an error occurs, you can see a log file  in the dialog 

window afterwards. This log file contains information regarding the affected records, for 

which the error occurred. These records can then be manually edited. 

Merging options 

Through the "Settings" button in the "Merge records" dialog, you can define the project-

specific merging options. When you confirm this dialog, all changes are lost and the 

merging options are carried out again.  

Rules 

Define the rules for comment fields, code fields and other fields. 

Memo fields 

▪ Discard secondary record: Only the field contents from the primary record are 

used in the resulting record. 

▪ Append to field content: The comment field contents of the secondary record is 

attached to the field contents of the primary record. 
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Additionally, with the option "Attach from fi rst difference on " it is possible to 

ensure identical starting text is not duplicated. When merging, the contents are 

compared and the contents of the secondary record are attached to the primary 

record from the first difference found.  

▪ Replace fie ld content: Only the field contents from the secondary record are 

used in the resulting record. 

 

Code fields 

▪ Discard secondary record: Only the field contents from the primary record are 

used in the resulting record. 

▪ Merge any set attribute of primary and secondary record: All code entries of 

both code fields are used in the resulting record. 

▪ Merge only commonly set attributes: Only code entries set in both code fields 
are used in the resulting record.  

Other fields 

▪ By default, the field contents of the primary record are used in the resulting 

record. With the option "F i ll empty primary record fields with secondary record " 

any empty fields in the primary record are filled with the contents of the 
secondary record.  

▪ The option "Show different field contents as conflict" is available for all field 

types. With this option, a row is highlighted red in the case of differing field 
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contents (conflicts). This highlight is removed when field content is chosen for 
the resulting record. 

Relations 

Define the actions to be carried out when merging for 1:N and N:M relations.  

The following actions are available: 

▪ Cancel: The relationally linked records of the secondary record are not used in the 

resulting record. 

▪ Apply: The relationally linked records of the secondary record are used in the 

resulting record.  

▪ Transfer and ignore dupes: The relationally linked records of the secondary record 

are used in the resulting record. Duplicate relationally linked records are deleted.  

When a relationally linked record is a duplicate, i.e. which field contents identify a 

record most clearly, can be defined for each relation through the "..." button.  

▪ With the "New" button, you will begin a new row. First select the desired Field to 
check, e.g. "DateTime". 

▪ Set the field length up to which similarity is to be checked. For fields of type 

"Characters Long" only the first 250 characters can be checked. 

▪ With Ignore if empty you can set whether this field is to be ignored if it is empty.  
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Deleting 

Define how the secondary record is to be deleted after the merger. One option is to also 

delete any relationally linked records, e.g. any contact records linked to a person record.  

Please note: if the options "Delete secondary record " and "Also de lete  re lations " are 

activated, only the first layer of the 1:N/N:M relations of the secondary record are 

deleted. To delete all linked records, we recommend you activate "cascaded deleting and 

updating" in your database system. 

Alternatively, the secondary record can be marked as deleted by making an entry in a 

certain field. This would be possible if the user has no record deletion rights. 

Extended 

Define whether a log entry is to be made after the merger. For this, give a field name and 

log entry. If you are making the log entry in a comment field, activate the option "Append 

to field content" to add the log entry to the existing field contents. 

3.14 Watch record 

Notes: This function requires the Professional or Enterprise Edition. 

In case multiple solutions use the same database, only one solution may use this 

function. Otherwise, errors will occur. 

Via Start > Watch Record you can monitor individual records. When changes are made to 

this record by another user (or in relational connections as long as this option was 

activated), you will be informed about it in the navigation view under "Watch results". 

You can also click the "Viewed" checkbox so that the entry is removed from the list. There 

are further deletion options available via the context menu. (Delete all entries; Delete all 

entries related to this record.). 

The list is a container, which means that you can configure the column layout by right -

clicking the column layout. The view can be configured according to date modified, user 

who made the modification and reason for modification.  

Example: If for example a service request is made or a line of credit is exceeded, a 

notification is sent automatically to the responsible customer service representative.  

The requirement is the activation of this function in the view. Further information  can be 

found in the chapter "Configuration of views" under "General". 

The notification options can be configured for each individual user in the user 

administration: 
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▪ Email notification: When changes are made an email is sent to the user’s email 

address. 

▪ A user’s own changes can be ignored and thus they will only be notified about other 

users’ changes. 

More information can be found in the chapter "User and rights management" under 

"Application rights and user settings". 

3.15 Modify field contents 

With the function Data > Modify, you can not only append, but also edit or replace 

existing field contents. If you do not wish to append all the records in the view, you 

should run a filter first to select the required records. 

 Select Data > Modify. Now choose the field from the field list whose contents you 

wish to change. 

 

▪ If you have selected a code field, the codes contained are listed and "Delete" and 

"Set" are available as options. 

▪ If you have selected a logical field, you can simply "Overwrite Content" and enter True 

(set) or False (not set) as text. 

▪ If you have selected a combo box, you can also select the respective entries from a 

combo box. 

▪ With a date field, you can simply "Overwrite content".  

▪ If you select a field, from which a 1:1 relation evolves, you can select a certain 

foreign key value by simply clicking on a button. 

▪ For all other fields, you specify the field content or the formula that is to be 

appended to or overwritten in the "Text" field 

Note: Please note that the data format of the selected field and the entered text must 

match. You can only append or replace a numerical field with numbers. 
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Example for Modify by formula: Assuming, you have imported data, where name and 

firstname are in the same field, but you want to transfer the first name into a separate 

field. 

 Create a filter with the mentioned addresses and choose Data > Modify. 

 Choose the field "Firstname" from the list and open the formula wizard. 

 To transfer everything from the left of the combined name to the first space 

character into to the field "Firstname", use following formula: 

«LEFT$(NAME,if(StrPos(NAME,"") >= 0,StrPos(NAME,""),LEN(NAME))) » 

 After the confirmation of the formula with OK, choose the option "Overwrite content" 

and start the process with "Execute". The first names will be entered in the field "First 

name".  

 Now they only have to be deleted from the field "Name". Therefore, in the second 

pass select the field "Name" and enter the following expression in the formula 

wizard: 

«if(StrPos(NAME,"") >= 0,LTRIM$(MID$(NAME, StrPos(NAME,"")+1)),"")» 

 Choose again the option "Overwrite  content"  and start the process. 

Note: Whether modification is being performed by the server or by the client 

depends on the input. When the modification is to be done server-side (e.g. due 

to no usage of formulas) then the database server will perform the entire process. 

3.16 Appending records relationally 

With this function, a new record is automatically created and linked in the relationally 

linked view (e.g. activities) for every record in the active view according to the defined 

field list.  

After a marketing activity, for example, (e.g. mailing product sport leaflet 07) you can 

append the item "Mail product 05/2011" to the activity container for all records in the 

active filter. 

Note: Relational appending can be carried out directly from the server when using 

MSSQL, as long as no List & Label formulas (variables) are being used that refer to the 

records themselves. 

Appending records relationally 

 Select Data > Append Relational ly .  
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 Select the relational view in which the new records are to be created. You have all 

defined 1:N and N:M relations available. The relation alias is displayed in brackets. 

 In the field list, you can define the field contents of the new records through the 

"New" button. To do this, select the field of the linked view in the "F ie ld" column and 

write either text or a formula (e.g. the date) in the "Formula" column. 

With the "Formula" button, you open the formula wizard, which supports, for 

example, the function AskString$() to allow a user input. As long as the formula uses 

variables of a record, this user input will be offered for every record, otherwise only 

once. 

If the result of a formula is empty (""), the field is ignored completely so that any 

default values of the database server can take over. 

 

 To begin the process, click on "Execute ". A new record is automatically created and 

linked in the relationally linked view (e.g. documents, contacts) for every record in 

the active view according to the defined field list. 

Templates for relational appending 

All settings for relational appending can be saved as a template so that they can be used 

again or made available to other users. This is done in a similar way to saving filter 

expressions. 

 Click the "Save " button. 

 In the dialog that opens, you can set whether the saved filter is to be available to all 

users or just yourself. 

 In the "Description" column, enter some descriptive text. You can then set a name 

that can be used for access by script. Confirm the entry with the "OK" button. 

 Click the "Load" button to change the template. 
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 Through Settings > Relational Appending you can always open the template library 

to change the description or name. 

 Through Data > Append Relationally > Execute template you can open the template 

library and run the selected template. 

3.17 Address enrichment 

With some telephone CDs that directly support being accessed externally, there is the 

option to "enrich" several records in one step. As long as the CD supports this mode, the 

tab "Address enrichment" is available in the configuration. Here you can set which 

telephone fields should be enriched, and can set certain search options. 

Under Data > Data Enrichment you can start the enrichment. Depending on the 

importance of your data it is often worth using the enrichment only on a filter of the 

records that contain no telephone numbers. The enrichment process is logged in the file 

enrich.txt in the directory C:\Documents and Settings\<User>\Application Data\cRM. 

In addition, an auto log can be activated under the view properties that might be capable 

of tracking changes in a comments field for each record. More about this can be found in 

the chapter "Configuration of views". 
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4. Searching for records 

The search function is a filter, since only the records being searched are displayed at the 

end. To create a target group (e.g. for a mailing), we recommend using the filter options 

under "Filtering" instead of the search function. More information on filtering can be 

found in the chapter "Filtering records". 

4.1 Search in views 

You can reach the different search options via Start > Find. Searching is also possible by 

entering the search term in the search toolbar. ). A full text search is carried out in all 

character fields. 

Normal search 

The normal search uses the "begins with" principle. This means you do not have to enter 

the entire search term that is to be found in the field (or fields). 

 Select Start > F ind. 
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 Now select the fields in which you wish to search from the field overview. You also 

have the option to search in several fields at once. 

Tip: In the context menu of the field that you wish to search through, click on the 

"Find" option. You can carry out a normal search even faster like this, because the 

corresponding field will already be selected in the search dialog and the current 

field content will be entered as the search criteria (the only exception being fields of 

the "Characters long" type). 

 Under "Search Criteria" enter the term you are searching, under "Options" select 

"normal". 

 If you want to search case sensitive , simply tick the corresponding option. 

Note: To use this option, case sensitive searching must be set up in the database 

server configuration. 

 The records with the search term will be displayed once the search has finished (and 

only those records!). You can tell that you are in search result mode from the  

symbol at the bottom right of the view window. 

Example: You want to search for the company "Sunshine Agency" and just enter 

"Sunshine" (as you don't know the exact name). As the company belongs to a bigger 

group of companies, you are not sure if the searched term exists in the field 

Company, Company2 or Company3. So you will find all records of this company, 

independent from "Agency", "Ltd." or "SA".  

Search options 

▪ Contains Search: To find data for which the search term does not exactly match the 

search field, or the beginning does not match, use the search option "Contains".  

▪ Provided that you know exactly what you are searching for, there is the option to use 

the "exact" search option instead of the "normal" option. This means you have to 

enter the entire search term – in our previous example, this would be "Sunshine 

Agency". Note, however, that exact search is not possible in fields of the "comment" 

type. 

▪ Wildcard search: To find data in which the search term does not correspond exactly 

with the search field, or the start does not match, use the wildcard option. Wildcards 

are the symbols "*" and "?" that stand for unknown characters. With these, you will 

find what you need even if you do not know exactly what is in the search field in the 

record you are looking for. 
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Example: The field "Company" contains "Weberei Seitenmann und Sohn". However 

you only know the name "Seitenmann", not the exact Company name and want to 

search only for this name. 

▪ Phonetic search: With this search mode, you can search for the sound of a term, 

rather than its actual spelling. If, for instance, you only know that the person you are 

looking for sounds like "Meier" but do not know if they are spelled with an "ei", "ai" or 

"ay", you can enter the name with "ei" or "ai". The search results will contain all 

variants of the name, i.e. "Meier", "Maier" and "Mayer". 

Note: The conditions for the phonetic search are not set up in cRM, but through your 

database system. To be able to use the phonetic search with the PostgreSQL 

database system, phonetic search support ("SOUNDEX") must be activated during 

installation. 

Refining the search 

The option "Combine with current filte r"  in the search dialog can be used when you have 

already carried out a search and want to refine the results with another search term. If 

this option is not selected, the previous search is discarded and the new search will 

encompass all records. 

Example: You have found several records of the company "Sunshine Agency", but you 

need only the ones of the sales department. Execute another search, this time on the 

field "Department" with the content "sales" and choose the option "Combine with current 
fi l te r". 

Quick Find 

This type of search works like a normal search, and gives the user a faster and even 

easier searching process. So that you don’t have to select the required fields from the list 

every time a search is run, you can set up which fields you will search most frequently. 

All fields of the active view and all fields of those views directly linked through a 1:1 

relation are available to you. 

 Select Start > Quick F ind. In the list view, simply beginning to type will trigger the 

Quick Find dialog. 

 To carry out a quick search, select the field you wish to search. In the search criteria, 

enter the search term. 

 The variants "normal", "wildcard" or "phonetic" are still available to you in the search 

options. Further information regarding these can be found in the previous sections. 
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 If required, you can set whether the search is to be case sensitive and whether a 

previously run filter is to be used as a basis for the search using the corresponding 

checkboxes. 

 

 As in the normal search, the records with the search term will be displayed after the 

search process has finished. If multiple results then it switch to list view, if the 

checkbox of the option is activated. 

 With the new-button you can add further Quick Find fields at any time. The first ten 

fields of this list can then be accessed with the shortcuts Alt-1 to Alt-0. More than 

around 10 fields should probably not be added, since the main point of the quick 

search is to avoid selecting fields from a long list. 

Note: The quick find fields apply to all users. The right for this must be set under "Edit 

project settings".  

Search for phone number or e-mail 

A fuzzy search for an e-mail address finds e-mail addresses using a gradual expansion of 

the search strategy. Once matches have been found, the search is stopped with this 

step. 

1. The e-mail address (e.g., maier@combit.de) being searched for will be found exactly 

that way. 
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2. Finds e-mail addresses with other top-level domains (.com, .de, .net, etc.) are found, 

such as maier@combit.com. 

3. Finds all e-mail addresses for which the part of the address before the @ character 

sound phonetically similar, also with other top-level domains, such as 

meier@combit.com.  

4. Finds all e-mail addresses with the same domain as long as it is not a domain of an 

e-mail provider (gmail, t-online, etc.), such as info@combit.de. 

5. Finds all e-mail addresses with the same domain as long as it is not a domain of an 

e-mail provider (gmail, t-online, etc.), incl. other top-level domains, such as 

schmidt@combit.net. 

A fuzzy search for a telephone number also finds numbers of telephone extensions since 

it is cut off up to 4 places from the right in order to find a match. A search for the 

telephone number 07531 906010 also finds, for example, 07531 906020 and 07531 

90601234. 

 
 

 Start > Special  F ind opens the corresponding search dialog. 

 Select the search type and enter the search criteria. 

 Enter exceptions for a fuzzy match search or general e-mail domains by clicking the 

"..." button. 

4.2 Searching in relations 

In the selection list for 1:1 relations there is also a search option, so that you can link 

contacts, companies and projects quickly and easily. 
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By clicking on the button (e.g. link with firm) you open the overview list of the records 

that can be allocated. 

 First select the desired field from the list of searchable fields, e.g. Firm.  

 Now you must only type in the words to be searched (no need to type into a search 

field), which are displayed while typing in the bottom left corner of the window. 

 The relevant field is then searched for the word and the filtered records are displayed 

in the overview list.  

  To go back to the complete list, click on the button "Restore last fi l te r" . 

 If you should require a more complex search or filter, the dialogs for quick and 

normal search are, of course, also available. More information about these at the 

start of this chapter. 

4.3 Global Search 

With the global search (Project navigation: Window > Toolbar > Global Search) you can 

search field contents in all views (in the order of navigation). A full text search is carried 

out in all character fields. The search is not case-sensitive. 

 

Individual views can be excluded from the search; the option "Exclude from global 

search" on the "General" tab of the "View configuration".  

The search results are displayed in an extra window (usually at the bottom of the screen). 

By double-clicking, you can jump directly to the record.  

 
The search is completed in a specific period for each view and contains a max imum of 
200 results in the default setting. The search criteria can be configured to some extent. 
More information can be found in the document "cRM_Config_EN.pdf". 
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4.4 Find and replace 

With this function, you have a way of replacing certain field contents. Since this function 

is a global operation, you must first create a selection of the records in which the 

changes are to be made. 

 

If you did not use a filter beforehand, the changes would be made to all records in the 

view. 

 Select Start > Replace and in the following window, select the field from the field list 

whose contents you wish to change. 

 In the line "Search for", enter the text that you want to replace. In the example, this is 

the firm name. 

 In the field "Replace with", enter the text that you want to have instead. If the current 

text is to be deleted and is not to be replaced with anything, simply leave the field 

empty. The text will just be removed.  

 Under "Options" you can set whether the search is to be case sensitive, and whether 

the replacement process is to be confirmed for every record as a precaution. 

Note: To use this option, case sensitive searching must be set up in the database 

server configuration. Depending on the database system being used, it can be turned 

on up to field level. 

 After starting the process with "Execute", the entered text is searched and is 

replaced with the new text. 

Note: The replacement takes place on the server and on the client, depending on the 

input. In the server replacement, the database server performs the entire process.  
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4.5 Search in Social Media and Online Directories 

You can conduct a search in multiple online directories based on the current record. A 

variety of social media directories are supported for this, e.g. XING, Facebook. 

 Select Start > In Directories > Find Record in Online Directories and Social  Media . 

 In the "Online Directories Search" dialog, you determine or confirm the search fields 

and directories. The given search fields however are only considered if the selected 

online directory does support them. 

 The results will be displayed in the browser. 

Note: Since structures and addresses of websites can change very quickly, it is 

possible that websites and services will become inaccessible without warning.  

4.6 Search in phone directory 

You can import data from telephone CDs into your view and exchange data through an 

interface. Many different phone directories are supported. With this you can search 

directly in online telephone and trade directories (please read the note) and transfer data 

from up-to-date telephone CDs to amend or correct your contacts list. 

With this you can transfer data directly from the current phone directories or you can 

amend or correct your existing contacts. In case of a telephone CD the telephone CD 

must be in the CD-ROM drive and the CD must be installed before-hand. 

Configuring the phone directory interface  

 Open Settings > Directories+RoutePlanners.  

 In the "Phone Directory" tab first select the telephone directory that you wish to use 

from the top field. 

▪ Also enter a path to the corresponding executable. This control might be 

deactivated for some directories. The program will establish the necessary 
connection itself in this case. 

▪ Depending on which directory you have chosen, you are given the relevant 

information about the search options available for this directory (e.g. whether 

search is only by firm/name or can also be by industry) and any possible 

particularities. 

 In the "F ie lds" tab you are given a list with the possible search and target fields and 

the fields in your view linked with them.  

 As standard, all fields with the same name are linked. If you wish to change this: in 

the row being changed, click twice in the database field column and the list with all 

available fields in your view opens from which you can select another. 
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Searching in phone directories  

 Select the command Start > In Directories > Find Record in Phone Directory . The 

media, whose interface you should already have configured, is automatically 

accessed. 

 You now have the choice between two variants: either you carry out the search 

based on the current record, or you select the manual transfer. 

Find current record 

Before the phone directory is started, you are shown a dialog for setting the search 

parameter, i.e. "Company", "Name", "City" etc. If you mark all parameters, only those 

supported by the selected phone directory are respected. 

 The phone directory now searches for the data of the record you are currently in. If 

no matching data is found you are shown a corresponding notification. If the record 

is found, it is displayed. 

 For some telephone CDs the transfer window opens immediately, for others only 

after double-clicking the search result. You have the choice between transferring or 

creating new. 

▪ In the first case, you can overwrite or amend the record that you are currently in. 

If you choose the second option, a completely new record is created. With the 
CDs from Switzerland you can even transfer several records. 

Transfer manually 

Here, you can start a search for firms, names or telephone numbers as desired, 

corresponding to the options offered by the CD. The application will lead you through the 

search, which of course will always be a little different. With some telephone CDs, a 

wizard is available to you that explain what to do step by step. 

The search results are displayed in a list and the "Transfer from CD" window opens (in 

some cases after double-clicking a result) here too. You can again select between 

transferring or creating new as described above. 

Note: With some telephone CDs for which multiple transfers are possible; the manual 

creation of new records from the telephone CD interface is not possible. In this case, 

you would have to export the data from the application yourself. 

Please note the so-called Robinson entries in the Swiss telephone CDs, which are 

marked with a star. These Robinson addresses do not wish to receive adverts. You, as 

user, are responsible for correctly following the terms of the individual telephone CDs. 
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Note: Since structures and addresses of websites can change very quickly, it is 

possible that websites and services will become inaccessible without warning.  

4.7 Route Planning and Directions 

With Start > Route Planning you have the option of using a route planner to plan routes 

or visualize addresses.  

Tip: If you use Microsoft MapPoint, you can visualize data on a map. More information 

can be found in the chapter "Visualization of data". 

Configuration 

 With Settings > Directories+RoutePlanners you can select which route planner to 

use on the "Route Planner" tab. Take note of the different particularities and limits of 

the various route planners.  

 On the tab "Home Address", set an address to be used as the start address for Route 

Planning.  

 In the "F ie lds" tab you are given a list with the possible search and target fields and 

the fields in your view linked with them.  

 

As standard, all fields with the same name are linked. If you wish to change this: 

in the row being changed, click twice in the database field column and the list 

with all available fields in your view opens from which you can select another. 
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Route Planning to the active record 

If you want to plan a route to the active address: 

 Select Start > Route Planning > Get Directions to Current Record .  

 In the following dialog select "Get Directions" to start the Route Planning with the 

configured route planner to the address in the active record. With the button 

"Settings", the settings for the start address and the route planner can be changed. 

Route Planning with waypoints 

You also have the option of planning a route with several waypoints, i.e. a route for 

several addresses (i.e. when using Microsoft MapPoint®). 

 To set waypoints, navigate to the corresponding records and select Start > Route 

Planning > Set Current Record as Starting  Point / Stopover / Endpoint .  

When a waypoint is created without a starting point existing, this automatically 

becomes the starting point. If a starting point is set afterwards, the previous start 

point automatically becomes an arrival point. Generally, start and arrival points should 

be set before waypoints. 

 The status bar gives information about the placing of these points with 

corresponding icons. 

 

 With Start > Route Planning > Remove Al l  Waypoints  all placed waypoints can be 

deleted. 

 

 After you have chosen all waypoints, select Start > Route Planning > Get directions 

to Current Record. In the following dialog you can  

▪ change the order of the waypoints with arrow buttons 

▪ add the saved start address with the "Home address" button 
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▪ delete a waypoint from the list with the "Delete" button 

 Select "Get directions" to start the configured route planner for the Route Planning to 

the address of the active record. 

 With the button "Configuration" the settings for the base address and the route 

planner can be changed. The changes in the base address do not have an effect on 

those already added. 

 Select "Show points" to show only the waypoints in the route planner. 
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5. Filtering Records (Selection) 

A filter creates a selection of records, i.e. the view after running the filter contains only 

the records that correspond to your chosen criteria. You then have the option to edit the 

filtered records or to use them further in some other application. The records can, for 

example, be printed (as labels, lists, file cards, mail merge) or to amend them with code 

attributes, categorizations or documents. They can also be exported completely, etc. 

The search function is also a type of filter, since the result only shows the records being 

searched for. The difference is that the search has fewer selection options and that you 

cannot save the search results. 

 You can tell that a filter is active if there is a symbol in the status bar. The numerical 

display "filtered records / total records of view" shows the number of records currently in 

the filter. 

Under F i l ter you can find the different available filter options: 

▪ General: Very flexible method to filter records.  

▪ QBE (Query by Example): You fill in the normal input form. 

▪ Free SQL query: This makes such queries possible as "Filter all records for which no 

record is connected with attribute X."  

▪ Ful l  text search: Filter according to the contents in many different fields. 

▪ Dupes: Filter duplicate records. 

▪ Manual F i l ter: Select individual records for which there are no common attributes. 

A global stored filter can also be activated directly from the toolbar: 

 

If you wish to undo the filter selection and want to use the whole database, select F i l ter 

> Undo F i l ter . All selection criteria will be deleted and all records will once again be 

available. 

5.1 General Filter 

 The general filter is a very flexible method to filter records that can, for example, be used 

to find a certain postcode area, a particular buzzword or other shared characteristics. You 

can access all fields and can combine the field criteria freely. 
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Creating a simple filter 

 Select F i l ter > General  F i l ter or Start > General  F i l ter. 

 In the list "F ie lds" click on the field that contains the attribute you wish to search. 

Using the symbols, you see the respective field type (character, numeric, date, 

Boolean, key field, embedded file). 

 From the list "Expressions" select the desired operator. The available expressions are 

displayed. 

Example: If you only want to search for a sub-string, choose the expression 

"contains". If the field contains only one attribute, choose "equal  to". 

 In the field "Value" enter the attribute you are searching for. If case sensitivity is 

active, you can use this too. 

 

Note: The option "Case sensitive " is not available for fields of type "Character 

long" and can only be used if it has been set in the database server configuration. 

 For these conditions to be used in the filter expression, now click on "Add" and then 

on "Execute". 

Example: You want to filter all records which are located in the city "Konstanz":  

 From the list of fields you choose "CITY" 

 As expression you choose "equal to" 
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 The value would be "Konstanz" 

Example: You want to filter all records whose field "Note" contains "enthusiastic": 

 From the list of fields you choose "Note" 

 As expression you choose "contains" 

 The value would be "enthusiastic" 

Tip: If you wish to filter an already created selection, select the option "Include current 

f i l ter". 

Creating a filter with combined conditions 

If you want to set a filter with various conditions, you have to combine these condit ions 

with logical  operators: 

▪ AND: Both conditions apply (Intersection). 

▪ NOT: Is used if a particular condition absolutely does not apply (Complement). 

▪ OR: Either condition 1 or condition2 or both should apply (Union). 

If you want to create such a selection, first define a condition and use the corresponding 

operator before every other condition. With the arrow buttons above the input control 

you can undo or redo changes. 
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Example: You search for all customers, who either work in the management or in the 
personnel department. However only these who are not coming from retail sales. 

 Choose the field "Department", as expression "contains" and as value "personnel 

department".  

 Press "Add" and then press "OR". 

 Keep "Department" selected and change its value to "management". Again press 

"Add".  

 Now choose the operator "AND", followed by "NOT". 

 Now you select the field "BusinessSector", change its expression to "equal to", 

change its value to "retail sales" and press "Add". 

 Now you have to insert parenthesis in the filter expression, to make clear the order 

of the execution. When using the operators OR and AND you always should place 

them around the expression "A OR B", respective before the AND. In this case place 

the opening parenthesis to the start and the closing parenthesis after "management". 

 Then press "Execute". 

 

Example for a l inked fi l ter with Z IP -codes: You want to get all records from your 
addresses in Germany, whose ZIP-code area lies between 70000 and 89999. 

 As field "ZIP", as expression "greater/equal", as value "70000". 

 As operator you choose "AND". 

 As field "ZIP", as expression "less/equal", as value "89999". 

 As operator you choose "AND". 

 As field "COUNTRY", as expression "equal", as value "D". 

Example for the  "AND before OR"-Rule: 

 NAME = "Smith" AND COUNTRY = "A" OR CITY = "B"  

means, that all records will be filtered, whose name is "Smith" AND whose city is "A". 

Furthermore all records will be selected; whose city is "B", completely independent 

from the name. 

 NAME = "Smith" AND (COUNTRY = "A" OR CITY = "B") 

means that all records will be filtered whose name is "Smith" and which either lie in 

the country "A" or in the city "B", 

Note: Always pay attention to the sequence of the operators. With AND and OR links 

the sequence is important because the rule "AND before OR" applies. 
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Filter with relationally linked views 

You can also set a filter that runs on multiple relationally linked views. 

In principle, the same procedure is followed as described when creating linked 

conditions. In the list of views select the appropriate view before setting any conditions 

(only then will the associated fields be displayed). 

If you have already defined a condition and then change the view for the second 

condition, the filter expression of the first condition will no longer be directly visible to 

you. Only the expression for the current view is displayed in the window. You can tell that 

a condition has been set for another view because it will be shown in bold in the list. 

Full text filter for document content 

If the database system supports the respective full text indices and the internal field type 

of the document field is "embedded file", you can also filter by document contents (also 

fuzzy). 

 

Adding the login name to the filter 

You also have the option to add the login name of the current user to the filter conditions. 

To use this variable, click on the arrow button next to the "Value" field and select "User 

Login Name". 

With this variable you can, for example, save a filter expression in which the account 

manager field is searched for a particular user. It is not necessary to add the name of the 
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attendant into the filter conditions – by using the variable, the filter automatically finds the 

login name of the current user. 

Frequency statistics 

You can have a frequency statistic displayed for each field. This allows target groups to 

recognized each other more quickly and work together more effectively. The frequencies 

are displayed in absolute terms and as a percentage. 1:1 relational fields are taken into 

consideration as much as possible. Date functions are not taken into consideration. 

If you want to perform a frequency analysis, click on the Statistics button next to the 

"Value" field.  

 

Creating a filter with user input: AskString$() 

You can also create filter expressions that require interactive user input (AskString$).  
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This is useful if very similar filters are used often in which only the comparative value 

changes. If you wish to create a filter with a query, click on the button field next to the 

"Value" field and select "Prompt User Input". You can then enter some text to request the 

information and a suggested value. 

 

Load recently used filter 

With the 'Load recently used filter' button, the last nine recently used filter expressions 

are available, even if these were not saved by the user directly. The recently used filter 

expressions are user-specific and view-specific.  

5.2 Free SQL Query 

The function "Free SQL query" gives experts the option to run a direct SQL query. You can 

enter the SQL query directly in the following way. 

 Start the free SQL query with F i l ter > Free SQL Query  

 Enter the SQL query. In the SELECT part of the query the primary key column of the 

table must be selected that underlies the current view (e.g. "Companies"."ID"). 
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▪ In the query, you may also use some "pseudo variables" (e.g. «cRM.User. 

LoginName») and AskString$ (further information can be found under "Creating a 

filter with user input: AskString$()"). 

▪ Using Load/Save the filter can be saved and loaded in the same way as general 

filters. 

▪ With the ‘Load recently used SQL query’ button. the 9 recently used filter 

expressions are available, even if not explicitly saved by the user. The last used 

filter expressions are user- and view-specific. 

▪ With Load/Save, the filter can be saved and loaded just as with the general filter. 

Example: All companies without contact 

select "Companies"."ID" 

from "Companies" 

where not exists 

(select "ID" from "Contacts" where "Companies"."ID" = 

"Contacts"."CompanyID") 

Example: All contacts with activities in 2012, but no activities in 2013 

select "Contacts"."ID" 

from "Contacts" 

where 

exists 

( 

  select "Activities"."ContactID" 

  from "Activities" 

  where datepart(year, "Activities"."DateTime") = 2012 and 

"Activities"."ContactID"="Contacts"."ID" 

) 

and NOT exists 

( 

  select "Activities"."ContactID" 

  from "Activities" 

  where datepart(year, "Activities"."DateTime") = 2013 and 

"Activities"."ContactID"="Contacts"."ID" 

) 

Note: A saved general filter can also be loaded into the dialog. A saved free SQL query 

cannot, however, be loaded as a general filter. Free SQL queries do not respect field 

rights or record rights of relationally linked views. Therefore, the availability of free SQL 

queries can be limited to specific users. In the rights administration, the rights "Edit 
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direct SQL query" and "Edit filter expressions directly"  are available for this. Further 

information regarding this can be found in the chapter "Limits when working with field 

rights". 

5.3 Saving a filter 

 If you wish to use a filter again at a later date, you can save it after creating the 

expression using the button "Save". 

 Decide whether the saved filter will be available to all users or just yourself. Global 

filters are also available in the "Filter" toolbar. Whether you switch to the list view 

when this is executed depends on the corresponding setting in the "General Filter" 

dialog.  

 In the "Description" column, enter a descriptive text.  

▪ Activate the checkbox in the "Container filter" column if this filter is also to be 

available for filtering a container. Further information can be found under 

"Filtering containers". 

▪ Activate "In Navigation" if the filter should also be available for quick global 

access in the "Navigation" window. 

▪ Optionally, you can also set a name that can be used for access by script or 

workflow.  

 Confirm the changes by pressing "OK". 

Note: All saved filter expressions for views that are no longer available will be 

discarded when the project file is saved. 

 Saved filter expressions can be run directly via F i lter > Execute  F i l ter Expression . 

 If you already have made a selection and would like to use a further filter, activate 

the "Current Filter as a basis" option as well.  

 To make changes to a saved filter expression, select Settings > Filter Expressions. 

Select the desired filter and click on "Edit". 

 The saved filter expressions can also be loaded in the General Filter dialog in order to 

add additional conditions for example. To do so, in the General F i l ter dialog click on 

the "Load" button. 

Note: A saved free SQL query cannot be loaded in the General  F i l ter dialog.  
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5.4 QBE-Filter (Query by Example) 

The "QBE" function is a particularly easy way of running a filter. With this, you simply fill in 

your normal input form. QBE filters can also be combined with other filters. 

Every entry counts as a filter condition. 

 Start the QBE filter with F i l ter > Query By Example.  

 In each field, enter the required filter. Correct spelling is important here. 

▪ The options "Case sensitive" and "Combine with current filter" are available.  

▪ If you enter several search terms into different fields, these will automatically be 

linked with AND. The fields can be in different tabs. 

▪ Select the desired search modes "normal", "exact", "wildcard" and "phonetic" or 

"contains" are also available in the QBE filter. 

▪ Code field entries (e.g. categories), check boxes (e.g. credit rating OK) and 1:1 

relationally linked fields (e.g. Sector1) can also be selected. 

Example: All company records with the city "Konstanz" and code "Fair invitation". 

▪ Enter "Konstanz" in the field "City". 

▪ Choose the code "Fair invitation" in the "Options" tab.  

▪ Select the "normal" filter mode and execute the filter with the button "OK". 

▪ All records that contain the city "Konstanz" and also contain the code "Fair invitation" 

will automatically be searched for. 

5.5 Full text search 

With the full text search you can search for specific information in a record, of which you 

are not completely sure in which field it can be found. 

 Select F i lter > Full Text Query and then enter in which fields of the view you wish to 

search.  

 Enter the search term in the search criteria and run the filter with "OK". In the case of 

numerical or date fields, you must enter the searched numbers or date. 

 A full text search can also be attached to another filter. To do this, activate "Include 

current fi l te r".  

5.6 Filter duplicate items (dupes) 

You have the option to filter the database for possible double items. This can be sensible 

after importing records, for example. 
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 To start the dupe filter, select F i l ter > Dupe  Check. All duplicate records are 

displayed in the filter created. 

 When the filter has run, you can look through the selected records and individually 

delete the ones no longer needed. 

 Alternatively, you can merge two records into one with the Start > Extended > 

Merge Records function. The active record becomes the primary record in which the 

results are saved. The secondary record can be deleted automatically afterwards. 

Further information regarding merging can be found under "Merging records" in the 

chapter "Entering and editing data". 

The fields to compare for the dupe check, i.e. the fields that make a record the most 

distinctive, can be set in the properties of the view. There, the online dupe check for the 

corresponding view can be activated so that a check is already being done during data 

entry to see if the record already exists. Further information regarding the configuration 

can be found under "Dupe check" in chapter "Configuration of views". 

5.7 Last filter 

There are various ways of reusing filters: 

 Use the filter library under F i l ter > Execute F i l ter Expression . 

 To reverse all filters select F i l ter > Last Filte r . You will run all filters that were carried 

out again in reverse order until no more are available. 

5.8 Invert filter 

Select F i lter > Invert fi l te r to reverse the selection of records, i.e. all filtered records are 

removed from the filter, while all records not contained in the filter are added.  

Note that fields with no content (NULL value) are not automatically included in the 

inverted filter and will therefore not appear in the filter automatically. 

5.9 Transfer to phone manager 

Select Data > Transfer Filter to phone manager to transfer all records in the active filter 

to the call list.  

5.10 Filtering all records of a relationally linked view 

The function "Last Filter" can also be used to select all records of a relationally linked view 

that are assigned to the current record. With this you can, for example, select all 

addresses assigned to a project in order to send a mail merge to them. 
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 In a view, double-click an entry in a relational container, e.g. in the view "Projects" 

double-click an item in the table "Participants" 

 The record will be displayed in a separate view. At this time, a filter is automatically 

added to all the records previously shown in the container. 

 Select this filter with F i l ter > Last F i l ter .  

 All records are selected that were originally shown in the container. 

5.11 Manual filter 

A manual filter allows the selection of single records for which there is no common 

attribute. Single records are explicitly included in or excluded from the manual filter with 

a checkbox in the first column of the list view. All functions are available through a Filter 

> Manual. 

 

 Select F i l ter > Compose  

 The first column of the list view with checkboxes for the compilation of the manual 

filter is displayed.  

 Using the checkboxes, select the records that are to be explicitly included or 

excluded from the filter. This checkbox has three different states for the labelling of 

the records: 

 Record is explicitly included in the manual filter. When the manual filter is run, 

this record is definitely displayed. 

 

 Record is ignored by the manual filter. Whether the record is displayed depends 

on the "normal" filter.  

 Record is explicitly excluded from the manual filter. When the manual filter is 

run, the record will definitely not be displayed.  
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 Optional select F i l ter > General  for a general filter. 

 Select F i l ter > Apply  to run the manual filter. 

If a filter already exists, you have the option of combining it with the manual filter. 

The records in the existing filter will be expanded with those records you ticked. All 

records that were explicitly excluded will not be in the filter. 

 The number of included/excluded records in the manual filter is displayed in the 

view’s toolbar. Whether or not the manual filter is active can be seen from the 

corresponding icon. 

 

 To cancel a manual filter, select F i lter > Cancel Selection . If the filter was combined 

with an existing filter, this will become active again.  

 If you wish to completely remove the filter, select F i l ter > Undo F i l ter. All selection 

criteria will be deleted and all records will become available again.  

 Select F i lter > Record Selection > Save Manual Fi l ter to save the compilation. With 

Load Manual F i l ter  the compilation can be recalled. 

Note: A field of the type "Record ID" must be exist and the manually 

included/excluded data records value may not be contained in this field a NULL. 

 Select F i lter > Save Current Filter as Manual F i l ter to save all of the records in the 

current filter as a record selection for a manual filter. This way a filter can be direct ly 

restored via F i l ter > Manual > Load Manual F i l ter . 

Example: You want to get all company-records from Germany, ZIP-Code-area 7 and 

additionally the record "Smith Real Estate" from the UK. 

 Select F i l ter > Compose  

 Check the record "Smith Real Estate". The Record is explicitly included in the manual 

filter. When the manual filter is run, this record is definitely displayed. 

 Select F i l ter > General  
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 As field "ZIP", as expression "begins with", as value "7". 

 As operator you choose "AND". 

 As field "COUNTRY", as expression "equal to", as value "DE". 

 Execute the general filter with the button "Execute". 

 Select F i l ter > Apply to run the manual filter. 

 Choose "Yes" in the dialog "Do you want to combine the manual filter with the current 

filter" to combine the two filters. 

5.12 Filtering containers 

A user-specific filtering option is also available for containers. Using the combobox, 

select the desired filter in order to display only the records that correspond to the criteria 

required. All saved filters of the linked view, for which the option "Container filter" is 

activated in the "Filter Library", are available. The activated filter remains active until it is 

changed. 

Information regarding configuration can also be found under "Button" in the chapter "Input 

form designer". 

 

5.13 Particularities 

SQL databases generally work based on queries and are therefore set-oriented and not 

position-oriented. This means that a particular record cannot be navigated to or updated 

without running a query that hits it exactly.  

Various field changes only become visible in the input form through this query (e.g. 

through trigger functions, time change stamps, calculated fields, field changes to this 

record by other users in the record etc.). The query is respresented visually in the status 

bar by 1/n (without the filter icon). 

For this reason, when scrolling between records, changes by other users in the network 

only become visible after a query (e.g. with refresh (F5), changing and saving a record, 

filtering). 
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6. Appointment and task management 

This internal view allows the management of appointments, tasks and resources. This 

view is opened via the navigation, Window > Appointments and Tasks or 

Appointments/Tasks > Appointments and Tasks. 

Another option is to use external scheduling such as Outlook. More information can be 

found in the chapter "Link to external task and appointment manager". 

 

6.1 Scheduling appointments and tasks 

Appointments are activities scheduled in your calendar to which other contacts are 

invited or for which resources are reserved. You can schedule reoccurring appointments, 

display appointments according to day, week or month and set reminders for 

appointments.  

Tasks are considered long-term occurrences. As opposed to an appointment, a task 

entails a start date  as wel l  as due date  and a status is indicated.  
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Creating appointment or task 

You have different options for creating tasks/appointments: 

▪ Right-click in the calendar in the "Appointment/Tasks" view and select "New 

Appointment" or "New Task" in the context menu, or select this function under 
"Record". 

▪ In any view, select Appointment > New Appointment/New Task for Record if 

the appointment or task should be connected to this record. 

Appointments/tasks that are created in this way can be displayed via 

Appointment > Show appointments for record. 

 Enter a description in the subject field. The last 20 entries are available to choose 

from. 

 

 Subject: Short note (up to 140 characters), that can be displayed with the 

appointment. Your last 20 key words entered are available in the selection. 

 With: If the appointment was made directly from a record, the contact information is 

displayed here. The last 20 entries are also available.  

 Location: Entries regarding the premises or location. 

 Categories: You can mark appointments and tasks using symbols, which allows for 

convenient detection and management of appointments / tasks. A category is 

assigned on the appropriate button. If no appropriate category listed, you can create 
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them on Settings> Categories. Choose from many standard symbols and designate 

them with a meaningful name for you. 

 Private: Private appointments can only be seen by the "owner" of the appointment. 

 Select any other options you want. 

 In the tab "Appointment" activate the option "Recurring", if a recurring event is being 

entered such as a birthday, weekly discussions etc. After activation, a dialog with 

various options will become available.  

▪ Set the recurrence pattern. Depending on whether you select daily, weekly, 

monthly or annually, different options will become available in the right-hand 
area of the recurrence pattern. 

▪ Recurring appointments are only shown once in the appointment list. 

 Under Attendee  you can select whether the appointment is for you (default) or for 

other users. Please note that any later changes to the appointments of other users 

are only possible if you have the corresponding user administration rights. You have 

also the ability to create appointments for resources such as hardware, vehicles, 

classrooms or similar. These resources are defined under Settings > Resources. 

 

Of course, you can also filter out the resource appointments. Instead of selecting a 

user, select the desired resource in the filter list. In this way you can quickly see, for 

example, for which appointments the classroom has already been occupied. 

 Under References you can link the appointment with other records such as projects 

or other contacts. 

 

 In the "Actions" tab, you can link an appointment with various actions. In doing so, 

you select whether an action should automatically or manually be started when the 

reminder is launched. Whether or not you can give other users actions depends on 

your rights in the system administration. 
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▪ Perform phone call: In this way, phone calls can be planned ahead. If you set up 

the appointment directly from the context menu of a telephone or mobile phone 

field (under "Schedule  Phone Cal l " ) the corresponding telephone number is 

automatically entered and you can start the telephone call directly with 
"Execute" when the appointment starts. 

▪ Send message via SMS: This action allows you to send an SMS message in 

connection with an appointment. The number is already entered here too, as 

long as you set up the appointment through the mobile phone field. Here, you 

also have the option of whether the SMS is to be sent automatically or manually 
through the reminder dialog. 

▪ Send an e-mail notification: If you wish to send a reminder of an appointment by 

e-mail, use this action. If the appointment is created from an e-mail field, the 

e-mail address will be used automatically. If you activate "Automatic", the e -mail 

will be sent completely automatically. 

▪  Execute (open) fi le /document:  When an appointment occurs, a relevant 

document can open. Programs can also be started automatically – for example 

to run data backup overnight. If you activate "Manually in reminder dialog" , the 
file would only open after being manually started in the reminder dialog. 

Control of appointment conflicts 

When creating or changing single appointments, an automatic check is started for 

whether the selected user already has appointments at this time. The result of the check 

displays the first conflict found. 

Only single appointments are checked for this. The user must also have the rights to view 

the appointments of other users. This check can be activated through Settings > 

Options.  
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Reminders 

If you have activated the reminder function for an appointment or task, you will be shown 

a reminder list at the relevant time. 

 

 Select "Go to record" to display the linked record. 

 Select "Delete " to delete the appointment. 

 Select "Close" to delete the appointment reminder. The actual appointment will not 

be deleted.  

 If an appointment was linked with an action, you can carry out the action with a click 

on the "Execute" button. 

 To move the reminder to a later time, set the desired time interval and click on 

"Snooze". The actual appointment will not be moved, just the reminder. If necessary, 

you can also move several appointments/tasks at the same time. 

Example: You want a report to be completed on Tuesday at 16.00 and therefore you 

let remind yourself at 10.00 a.m. in order to start on time. Unfortunately you got 
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interrupted by a long phone call, why you want to get reminded again not until 11.00. 

To do this, click "Snooze by 1 hour". 

 If you wish to move the appointment, not the reminder, select "Defer" (not possible 

for recurring appointments). If an appointment has already passed, the time interval 

for the rescheduling is calculated from the present time. 

Example: You had an appointment on Monday, 15.00, but couldn't keep it as you 

were ill. On Tuesday morning, 9.00, you get the according reminder and click "Defer 

by 1 hour". Based on the current time, the appointment will be set to 10.00 today. 

 Reminders are not given for finished tasks just as existing reminders will be 

deleted/reset. 

Edit an appointment or task 

To edit an appointment or task, double-click the corresponding entry in the active view or 

the reminder. Now, you can edit any options that were set at time of creation as desired. 

 In the day or week view, you can edit an appointment by drag & drop. Select an 

appointment and click on the bottom edge of the field. By dragging downwards, you 

can make the appointment longer. By clicking the top edge, you can move it. 

 In the context menu, the most important commands for editing are available. 

 With the button "Go to Record" (only when a link to a record exists) you can jump 

directly to the corresponding record. 

 If you want to delegate an appointment to a colleague – for example to your stand-in 

- select Appointment > Delegate . 

 Some of the fields in the appointment and task list can be edited directly. 

Outputting appointments and tasks 

If you wish to output appointments or tasks, select "Output" then the desired format. You 

can define how the lists and file cards should look under Settings > Print > F i le  Cards. 

More information can be found in the additional documentation "List & Label –Designer 

Manual" 

6.2 Navigation in the calendar 

Changing the number of days displayed 

In the day view or week view the separating line between the right and left areas can be 

moved as desired. Depending on the width of the right-hand area and the monitor, one or 

two months will be displayed in the top-right. 

▪ Select "Day View", "Working week view", "Week View", "Month View" or "Appointment-

/Taskl ist" from the toolbar.  
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▪ To sort the appointment or task list by certain criteria, left-click on the corresponding 

column title. 

▪ For every appointment some symbols are displayed that give more information: 

Sort appointments and tasks 

If you have not yet configured any sort criteria, select Settings > Sort Orders > 

Appointments or Tasks. 

 With "New" create a new sort criterion . First give it a sensible name and then select 

the field from the list by which to sort. By clicking the "Direction" column you can set 

whether the sort order is to be ascending or descending. 

 If you wish to sort by several fields you can add more fields with the "New" button. 

 After pressing "OK" you will be taken back to the dialog with the overview of the sort 

criteria. If you now simply wish to save the changed configuration, leave the dialog 

with "OK". If you want to activate a sort order immediately, select it and then press 

"OK + Activate". 

 Now you simply have to select the desired sort criteria from the list. 

 With the adjacent buttons you can set if the sort order is to be ascending or 

descending. Ascending means that the list starts at the top with A, descending 

means it starts with Z. 

Filters 

There are various ways of filtering appointments and tasks. The activated filters remain 

active until they are changed (exception: extended filters). 

 

▪ Filter by user and resource : In the filter bar you can set whose appointments are to 

be displayed in the left selection list. Via Extended you can also select multiple users 

or resources.  

▪ Filter by appointment options: In the central selection list further filter options are 

available: All Appointments, Appointments Today, Appointments Tomorrow, Active 

Appointments, Recurring Appointments, Private Appointments 

▪ Filter for task options: Through the right-hand selection list you can display All tasks, 

Uncompleted tasks, Overdue tasks. Due by today, this week, this month, Priority 1, 

2, 3-5. 
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▪ With Advanced more selection options are available in both selection lists. Mark the 

desired filter conditions or enter the desired text. 

▪ The individual conditions are linked with AND for the evaluation. 

▪ You can also search for an empty field, e.g. all appointments without a subject. In 

this case leave the subject field empty and just mark the checkbox. 

▪  The checkboxes have three different states: 

 Condition is set 

 Condition is not set 

 Condition is ignored 

Example: If you want the condition "Private" to be irrelevant with your filter, choose 

the state "ignore". But if you want to apply a filter, in which no private appointments 

shall be included at all, then choose the state "not set".  

▪ With the option "Reminder", you filter all appointments for which the option 

"Reminder" is set. Please note that with recurring appointments, the "Reminder" 

option remains set even if the last reminder has been closed.  

▪ With the option "Active", you filter all appointments for which there is a reminder. A 

recurring appointment loses its "Active" status only when the last reminder has been 

closed. 

6.3 Configuration  

Under Settings > Options in the appointment and task management, you have the option 

to change, amongst others, the following settings: 

▪ Force reminder window to foreground: The reminder dialog will always push into the 

foreground, regardless of the application you are currently using. 

▪ Show week numbers in calendar navigation: The week numbers will be displayed in 

the calendar overview. 

▪ Automatically add the filter user as attendee for new appointments/tasks: When a 

new appointment is created and a user filter is set, the user that has been filte red out 

will automatically be added. If more than one user has been filtered out, this option is 

ignored and the user currently logged in is added. 

▪ Control of appointment confl icts: When creating or changing single appointments, 

an automatic check is started for whether the selected user already has 

appointments at this time. This check can also be activated when moving 

appointments. When selecting several users, this process can take a while 

depending on the number of existing records. 
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▪ Defaults for appointments / tasks: Enter the suggested value for the reminder 

function. You can also set by how many minutes / hours an appointment should be 

rescheduled as standard.  

▪ In the "User" area, the Colors for different users can be made. This is especially 

useful if you wish to display the appointments for all users. 

▪ Under Day / week view you can define how long your workday is in the display. 

Under "t ime scale " you can change the view to fit your needs, e.g. set the weekdays 

as Monday to Friday for work use or Monday to Sunday for private use. You can also 

define the time allocation in a workday, as well as the colors. 

Under Settings > Resources you can define resources such as hardware, vehicles, 

classrooms etc. as well as users. You can add as many resources as you wish and each 

name can contain up to 20 characters. 

Under Settings > Categories, you can define the categories for appointments/tasks. You 

can create as many categories as desired; the respective name can contain up to 30 

characters. 

6.4 Export / Import 

Appointments and tasks can be exported and imported using the schedule data 

exchange format "iCalendar" (iCal or ics). This why it is possible to use calendar 

information together in multiple applications, to transfer it from the Internet or to send it 

to other people. 

 Select Start > Import or drag an iCalendar file via Drag & Drop to the view of the 

schedule. If you can create appointments and tasks for other users, you can through 

a dialog specify for which user the appointments and tasks are to be created. The 

appointments and tasks will be added to the existing ones. 

Notes: cRM does not support all options and functions of other schedule 

applications. In Outlook 2010/2007, appointments are exported into the iCalendar 

format via F i le  > Save under . No tasks can be imported in Outlook.  

 Select Start > Export to export all of the appointments and tasks in the current filter 

into a file. Through a dialog, you determine whether appointments and/or tasks are 

to be exported. 

6.5 Link to external task and appointment manager 

As an alternative to the integrated task and appointment manager, you can use external 

programs for this purpose. This can be configured per user by choosing F ile > Options > 
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General  > Appointments &  Tasks. For the supported programs refer to the System 

Requirements. 

Also you can activate the monitoring of reminders on startup. If this option is deactivated, 

the reminder dialog will only be displayed after opening the appointment and task 

management. 

If an external task manager like Outlook has been chosen, all task and appointment 

related menu commands are diverted to the corresponding Outlook dialogs and functions 

automatically. Thus, if you choose New Appointment to record, Outlook's dialog for 

creating a new appointment will be opened.  

T ip: Import additional address data (street, city, telephone number etc.) in the subject of 

your appointment. This information will then be available to you in your iPhone, Android 

or Blackberry after synchronizing appointments. This way, you can do without an address 

synchronization, if you only need the address and communication data of the current 

appointments. 

In the memo text for this appointment, a reference to the record for which you created 

the appointment is stored. Just double click the reference to navigate to the 

corresponding record. 

Tip: When you make this double-click the first time, you may be asked whether you 

want to save or open this element. Remove the tick next to "Always ask before opening 

files of this type" and select "Open".  

If all appointments/tasks for the current record are to be displayed, a custom dialog is 

opened. The user can open a single appointment by double clicking the required 

task/appointment in this dialog. 

Note: Please note that not all functions of the integrated task manager are available in 

external programs. For example, when displaying all appointments for the current 

record, only the current users records will be displayed. 

Hints on using Outlook as appointment manager 

When displaying all appointments for the current record, not all properties of the 

tasks/appointments are displayed in the list. Double click the required element to see all 

properties. 
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Hints on using Tobit David as appointment manager 

▪ New tasks and appointments are saved with default values at creation. If you want to 

discard the task or appointment it is not sufficient to just close the window without 

saving. You need to delete the element explicitly in the corresponding archive. 

▪ When displaying all appointments for the current record, not all properties of the 

tasks/appointments are displayed in the list. Double click the required element to see 

all properties 

▪ The menu commands Task List, Appointment List and Show Appointments / Tasks  

simply change to the current view in David InfoCenter. It is not possible to explicitly 

force a task or appointment overview. 

Hints on using IBM Lotus Notes as task and appointment manager 

▪ The link is based on the standard Mail data base of Lotus Notes. 

▪ The following standard Views of Lotus Notes is used: Calendar ($Calendar), ToDo 

($ToDo). For dates the form "Appointment" is used and for tasks the form "task". 

▪ New tasks and appointments are set and stored with initial values. If the date or the 

task is to be rejected, then is sufficient simple closing of the window (without 

memory) not, but the element must be deleted explicitly in the appropriate View 

(Calendar/ToDo). 

▪ The creation of recurring appointments is not possible with the standard form. 

Hints on using scripts 

Scripts that add records in cRM will NOT automatically add records in Outlook or David - 

cRM's OLE interface will continue to work on the internal task management. In the script, 

you may use the property cRM.TimeManagerType to query, which appointment 

management is currently active. (see programming reference Object Model (COM)) 
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7. Activities and Document management 

Documents and contacts can be managed in the same view. For more information on 

configuration see the "Document management" in chapter "Configuration of views". 

 

7.1 Working with activities and documents  
▪ By double-clicking an item in the document container (except double-clicking in a 

document field!) or by right-clicking an item and selecting "Edit", the associated 

record of the "Documents" view is displayed and can be edited.  

▪ You can open a document in the container directly by double-clicking it. 

▪ When right-clicking the document field (in the record of the documents view or 

directly in the document container), various functions are available to you in the 

context menu: 

▪ Edit Document with Associated Application: Opens the linked/embedded 

document in the linked application (e.g. Word, Excel) for direct editing. 

▪ Directly access the functions of the linked application, e.g. Microsoft Word-

Document > Print.  

▪ Delete: Deletes the linked record, including the embedded document. If you delete a 

record with a linked document of the "File link" or "DMS document" type, the linked 

document is not automatically deleted. This must be done manually. 

▪ The assignment occurs automatically or through drag & drop, i.e. you drag the 

relevant document into the document field with the mouse. 

▪ When right-clicking in this container, new records and documents can be created 

and linked with the active record directly. 

▪ When creating documents, you can use document templates.  

▪ If the functions "Edit" or "New" are available in the explorer context menu of an 

embedded file or DMS document, do not use these functions! Changes to the 

document are ignored by cRM.  
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7.2 Create a new document 

All documents linked to a view are displayed in containers. If a record is created in the 

linked view through the container, it is automatically relationally l inked with the active 

record. Buttons are also available for many functions in the container’s context menu. 

 By right-clicking in this container and selecting New Document > Create via 

document management a new document can be created using a document 

template. 

 Select the required document type from the following dialog. The list corresponds to 

the previously defined document type. Further information regarding document 

types can be found under "Document management" in chapter "Configuration of 

views". 

 

 The corresponding program opens with the allotted template. Also, a new record is 

automatically created in the "Documents" or "Activities" view according to the rules 

you have set for new documents or activities. 

 Create the document and save it in the corresponding application (e.g. in Word) 

 Then save the new record. 

7.3 Insert an existing document 

Through drag & drop 

 Drag the document (e.g. from the explorer or Outlook/Exchange) into the document 

container. The document is stored according to the field type. 

 If you hold the CTRL key while dragging, a copy of the document is created and a 

shortcut to this copy is entered in the document field (for the "File link" field type). 

The name of the copy follows the rules defined in the document management. The 

target directory is the one set for the first document type with the same ending. If no 
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file with this ending exists, the copy is created in the target directory for the "*" file 

type. 

Note: If you insert an existing document in a "DMS document" or "Embedded file" field, 

the original file is not automatically deleted. You should carry out this deletion 

manually to avoid duplicate files being stored.  

By context menu 

 Right-click in the document container and select New Document > Existing file from 

the context menu. Select the required document. 

 Alternatively, create a new record in the "Documents" or "Activities" view. Then right-

click in the document field and select Insert Document from the context menu. You 

must of course then link this record with a person or firm.  

Scanning in a document 

You can scan in documents directly from a scanner (TWAIN) connected to a workstation. 

The documents are created according to the document management rules (name 

assignment, save location). 

 

 Right-click in the document container and select Documents > Read from Scanner 

from the context menu. 
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 Select "As single  images" if only scanning one page. Select "As document" if you 

wish to scan in several pages and want these put together as a document with 

several pages. 

 Select the format. The scanned document will be saved in this format. Depending on 

the chosen format, further document information can be given (title, description, 

etc.) 

Note: For this file format, a document type must be created in the file 

management or at least the entry "Other Document" with file ending "*". 

 Select the desired scanner and click Scan to start the process. 

 After the scanning process is finished, save the document with the "Save" button.  

7.4 Archiving messages from eMail-Client 

In Microsoft Outlook, Mozilla Thunderbird and Tobit David, you can use an add-on to 

archive messages (e-mails or, Tobit David, also faxes and SMS) in a view (e.g., in the 

"Activities" view) and assign them to a record (e.g., in the "Contacts" view).  

You can also allow the associated record to be displayed. 

 

The Archive and Display functions can be accessed via buttons and via the menu "combit 

Relationship Manager". Multiple messages can also be processed at the same time. 

Archive message and Show address 

Record search in cRM is started via Show address and Archive message using the e-mail 

address or fax/SMS number of the recipient/sender. It looks for a match in all of the 

available e-mail fields or telephone and cell phone fields in the Search view.  

If one or more matches have been found, the message is archived in the Archive view 

and the appropriate records are displayed in the Search view.  

In Outlook, the email is marked with the date and time after being stored. 

If no match has been found, a corresponding message is displayed. You can also have a 

log file displayed which gives information as to why the message could not be assigned 

(e.g., "No matching record could be found").  
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Requirements 

▪ For the supported versions of Microsoft Outlook, Tobit David and Mozilla 

Thunderbird refer to the System Requirements. 

▪ A working 1:N relation between the search view (e.g. contacts) and the Archive view 

(e.g. activities). 

▪ In the document management of the Archive view (right-click on View, then select 

Properties > Document Management) a document type for the e-mail archiving must 

be configured, for the file extensions "msg" (Outlook) or "eml" (Thunderbird, David). 

Settings 

 Open the configuration dialog via Settings. 

 General  tab: Enter the login data and select the project for which the message 

assignment is to be activated. You can also have the log file displayed by clicking on 

the corresponding button. In Outlook, this can also be opened via the log file item. 

 Search and archiving tab: Here you select in which view the record is shown and in 

which view the message is to be stored. If no match has been found, an alternative 

Search and archive view can be configured. 

The target field for document archive is automatically selected. For this, the fields are 

searched in the following order: "DMS document", "Embedded file", "File link". The 

first field found is used as the target field. 

You also define the field defaults of the new record in the Archive view by clicking on 

the corresponding button. 

In the "Fields" area, you specify which log entry is to be made in which field. The 

respective fields of the target view are available for this. 

You specify the auto-log text in the "Formula" column. Formulas give you access to 

data fields and additional information, which could also be used for the entry. By 

clicking the "Formula editor" button, you get help from a wizard.  

For this, specific message variables are available: 

▪ Message. Sender 

▪ Message.Subject 

▪ Message.Body 

▪ Message.CC_Recipient: Contains a list of the SMTP-CC recipient of the 

message. The list is separated by semicolons and each SMTP-CC recipient is 

enclosed in single quotation marks. 

▪ Message.Recipient: Contains a list of the SMTP recipient of the message. The 

list is separated by semicolons and each SMTP recipient is enclosed in single 
quotation marks, e.g. '<SMTP1>';'>SMTP2>' 
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▪ Message.ReceivedOn: Conversion into a character field via the function 

"Date$(Message.ReceiptDate,"%02d.%02m.%04y %02H:%02i:%02s")". 

▪ Message.Direction: ""=unknown, 1=incoming, 2=outgoing. 

▪ Message.Type: ""=unknown, 1=e-mail, 2=fax, 3=SMS. 

 Options tab: Here you will find the various options for the message archive: 

▪ General 

▪ Archive messages without user interaction: Suppresses the confirmation 

dialog when archiving. 

▪ Display record/records after successful archiving: If a filter is active in the 

Search view, a new view is opened for the display. 

▪ Try to archive messages to CC recipients also: This option is only evaluated 

for sent messages. 

▪ Archiving options: 

▪ Archive message only when a record is clearly found: This ensures that the 

message is only archived if a clear match has been found. If no match or 

multiple matches have been found, the message is not archived. A 

corresponding entry is created in the log file. 

▪ Archive message for all data records found. 

▪ If more than one data record is found, manually select the record: If multiple 

matches have been found, the desired record can be selected via a dialog. A 

selection may not be made more than once. 

▪ Message selection (is only supported by Tobit David): Successfully archived 

messages can be provided with a selection in David. Select the desired 

selection from the list, e.g. "Archive". 

▪ Addresses + Phone numbers tab: You will find different options for news 
archiving: 

▪ Personal e-mail addresses: Enter your own e-mail addresses here so that a 

differentiation can be made between sent and received e-mails during the 

search. The use of wild cards "*" and "?" is supported. So you can include for 

example all of your company’s own email addresses in the search/archiving. 

▪ Email addresses to be ignored: Enter those email addresses that should be 

filtered during archiving/search. The use of wild cards "*" and "?" is supported. 

So you can ignore for example all of your company’s own email addresses in 

the search/archiving. 

▪ Internal text message and fax numbers (is only supported by Tobit David): 

Enter your own numbers here so that a differentiation can be made between 

sent and received SMS and faxes during the search. Pay attention to the 

different number formats. 
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(De-)Activating the Outlook Add-In 

You can (de)activate the Outlook Add-In directly in the Outlook settings.  

▪ In the Outlook 2010/2013-Options switch direct to the "Add-Ins" area. In the 

combobox select the "COM Add-Ins" item and click on the "Go" button.  

▪ In Outlook 2000/XP/2003, select Tools > Options and go to the "Other" tab. Activate  

the button Advanced Options in the dialog that opens and press the button COM 

Add-Ins. In Outlook 2007 select Tools > Trust Center . In the combobox select the 

"COM Add-Ins" item and click on the "Go" button.  

All available Add-Ins are displayed. Activate, deactivate or delete the entry "combit 

Re lationship Manager Outlook AddIn"  and confirm with OK. 

If the Add-In with the name "combit Relationship Manager Outlook AddIn"  is not in the 

list, you can add it with the button Add. The Add-In module file cuoc04.dll can be found in 

the cRM installation directory. 

Note: Restart Outlook after this process. 

 (De-)Activating the Thunderbird Add-On 

You (de-)activate the Thunderbird add-on directly via the Thunderbird settings.  

In Thunderbird, select Extras > Add-ons. Now all available expansions are displayed. 

Select the entry "combit Relationship Manager Thunderbird Add-on" and select the button 

"Deactivate" or "Uninstall". 

If the add-on with the name "combit Relationship Manager Thunderbird Add-on" does not 

appear in the list, add it by clicking on the button Instal l . You will find the add-on file 

cRMTBAddOn@combit.net.xpi  in the cRM installation directory. 

Note: Restart Thunderbird after this process. 

To display the buttons in Thunderbird, select View > Toolbars > Customize.  You can 

then position the buttons via drag & drop.  

(De-)Activating the David Add-On 

If you want to de-(activate) the David add-on, re-install the application again (e.g. via 

System Control > Software > Change applications) and (de-)activate the "David add-on" 

option in the installation dialog.  

To display the buttons and menu items, unzip the file "cmbtTICAddIn.zip" from the cRM 

installation directory into the David directory "David\Code\scripts" on the David server. In 
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the "scripts" directory, there are then a subdirectory "combit" with the file "cmbtAddIn.vbs" 

and a subfolder "cRM". 

In the David user settings in the David.Administrator, activate the option "Individual 

Scripts" and enter the path for the script file, "combit/cmbtAddIn.vbs". Additional 

information on the use of scripts in David can also be found in the script documentation 

in the David server script directory.  
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8. Telephoning and call list 

Note: Requirement for phoning is a supported phone interface and / or a 

corresponding telephone. We recommend using TAPI.  

For the phone functions to be used properly, the creation of special phone fields is 

necessary. More on this under "Configuration of views". 

The phone manager offers the following CTI (Computer Integrated Telephony) functions: 

▪ Automatic dialing 

▪ Compilation of call lists 

▪ Quick-calling these lists ("Powerdialing") 

▪ Printing telephone lists 

▪ Number recognition for incoming calls 

▪ Logging unanswered calls 

▪ Sending of SMS messages 

8.1 Functions of the phone manager 

Dialing directly from a field 

 Select Start > Dial and select a number or right-click the phone field and select "Dial". 

 The number you stored in a "Telephone" or "Mobile Phone" field is dialed 

automatically. 

Dialing from the call list  

The phone manager allows the compilation of a telephone to-do list, i.e. an overview of 

records that should be called in the near future. With this you can - for example if the line 

is engaged – carry on working in this view without having to find the person to call again 

later. 
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To call someone 

 To call someone from the call list, double-click the required entry in the list, or select 

the command "Cal l " from its context menu. The number is dialed automatically. 

 A dialog also opens in which you have the option of making a conversation log . As 

well as the call duration, date and time, your own notes about the call are logged. 

 You can set in what form and field the data is stored in the configuration of the cRM 

auto protocol. 

 

Phone list informations  

▪ In the "I/O" column, you can tell whether the call is a logged incoming call (arrow) or a 

number dialed by you (no arrow).  

▪ The telephone number corresponds to the number of the TELEPHONE field from 

which the calling partner was transferred to the phone manager. 

▪ In the "Info" column, identifying information about the calling partner is displayed. 

You can set which information is to be used for this in the configuration. 

▪ The following variables are displayed as the Status: 

▪ ready: the current connection is ready to be dialed 
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▪ Aborted: the dialing process was cancelled but can be restarted at any time 

▪ Connection established: the number has been successfully dialed. The entry 

can be removed from the list or can be saved for later calls. 

Phone list functions 

The phone manager allows the direct jump from an entry in the phone list to the 

corresponding record in the view, for example to look up information about the person 

being called or to make a note about the conversation. 

▪ With Start > Pause  you can interrupt a dialing process at any time. The entry will be 

given the status "Aborted" but can be dialed again at any time. 

▪ With Start > Next the entry following the current entry is automatically dialed. You 

are then given the option to delete the current entry again (because the call is 

completed) or to send it to the end of the list (because it should be called again later, 

e.g. because the line is currently engaged). 

▪ With Start > Move Item you can send the current entry to the end of the list. 

▪ With Start > Delete  Item you can delete the current entry from the list. 

▪ With the command Start > Switch to Application (context menu: "F ind Record") you 

can move from an entry in the phone manager straight to the corresponding record. 

The required view will be opened for this. 

Printing the phone list  

You can print the phone list with all attempted calls to the output medium of your choice 

from the output menu. Printing directly, print preview or various file formats are available. 

The list can be configured in the List & Label Designer, which can be accessed under F i le  

> Options > L ist of Cal ls Print Template . 

Manual dialing  

Aside from the numbers in the phone list, you can also dial any other number manually. 

Run the command Start > Manual  and enter the desired number. With the button "Dial " 

you start the dialing process.  

Call simulation  

With F i le > Options > Simulate Incoming Cal l  you can simulate an incoming call to test 

the automatic number recognition (after it has been set up). For this, enter a phone 

number without any spaces. 
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Transfer phone numbers to the phone manager  

There are two ways of transferring entries from a view to the phone manager: individually 

or as a filter. 

 To transfer single entries, right-click in a phone-field in the view and select "To phone 

manager" from the context menu.  

 To transfer an entire filter to the phone manager, first create the desired filter and 

then select the command Data > Transfer F i l ter to phone manager. 

Powerdialing 

Powerdialing is the dialing of a whole list of calls (in this case all calls on the call list), as 

opposed to a single call with which you only complete one call from the list at a time. 

This function is often needed for telemarketing or in call centers.  

 To use the function, you should first create the required filter of the call partners and 

transfer this to the phone manager. After this, start dialing the first call partner with 

Start > Powerdial ing. 

 All calls marked as "successful" are moved to the end of the list so that the next call 

to be made is at the top of the list. 

 The same dialog as when dialing in the phone list opens, you can enter notes about 

the current call as usual and then transfer them to the record. 

 If the call is finished and you want to call the next person, click on the "Next Cal l " 

button. Otherwise, you can close the Powerdialing dialog with "Close" to continue it 

another time if you wish. The function is automatically ended when no more 

outstanding calls are in the phone list. 

8.2 Configure the phone manager 

Activate phone manager on startup 

 Select F i le > Options > General  and in the "Te lephony" tab, click on "Settings".  
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 To make the phone manager start at the same time as the program, activate the 

relevant option here. 

Configure interface 

Note: Every time the configuration dialog is being invoked, the dialing unit is being 

newly initialized. It is therefore not possible to check the current settings. If you have 

accidentally opened the configuration, leave the dialog with "Cancel ". To change 

something in the current configuration, select F i le  > Options > Dial  Device  in the 

phone manager. 

First, select the dialing unit. The most common and recommended dialing interface is 

TAPI. The corresponding drivers are included with most telephones. Otherwise, please 

refer to the manufacturer for a driver. 
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With TAPI, the system is automatically checked for the availability of these in terfaces. If 

they are not available, they cannot be selected in the configuration dialog. To be able to 

configure a deactivated interface here, it must first be installed. 

You can also call directly through Skype. For this, you need Skype running with onli ne 

status. When you first start you need to allow access to the "cuph13.ovl" on Skype. 

TAPI (Windows Telephony API)  

TAPI supports dialing from a telephone field as well as number recognition. Requirement 

is at least one installed TAPI device in the operating system, which is normally a phone, 

but can also be an ISDN card with TAPI drivers. These devices are installed under Control 

Panel > Phone and Modem Options  in your operating system or with the drivers 

belonging to the modem / phone. 

Setting up a dialing unit 

If the dialing unit can be communicated with, one or more windows are displayed for 

configuration. The settings depend on the dialing unit type and can therefore not be 

described in detail. Please follow the instructions on-screen and look at the dialing unit’s 

documentation if necessary. 

Configuring the telephone 

Select F i le > Options > Telephony System  for settings, if your device is connected to a 

telephony system: 
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▪ Specific device recognition if necessary. 

▪ Recognition of internal numbers: you can assign internal numbers a prefix to identify 

them explicity as internal numbers (e.g. "-"). 

▪ Maximal length of internal numbers: numbers that have as many or fewer digits than 

the given number are assumed to be internal (e.g. when no 0 is dialed to get an 

outside line when this is normally necessary). 

▪ Prefix to get an outside line, if necessary. 

▪ Prefix for an internal number, if necessary. 

▪ Options for incoming calls: 

▪ Suppress internal calls or prepend number by telephony system ID if available.  

▪ Telephony system adds prefix for external calls. 

▪ Telephony system suppresses the area code for local calls. 

Configure a log function 

You have the option to let calls be logged automatically. More about this can be found in 

chapter "Configuration of views". 

8.3 Search for records on incoming calls 

Please note that number recognition can only work if the phone manager is active and 

number recognition is turned on. 

Setting up number recognition and logging 

 To activate number recognition, select F i le > Information > Properties > Settings 

and then activate both views for which number recognition is to be activated in the 

"Telephony" area. The view selected under "1" is searched through by the view 

selected in "2".  
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 Select F i le > Options > Incoming Call Detection  in the phone manager ribbon and 

activate the option "Identification of incoming cal ls" . 

 
 

 Logging incoming calls: If you cannot accept a call because you are not at your 

workstation, the phone manager tries to log it. Requirement for this is the 

transmission of the caller’s number, e.g. with an ISDN phone. The incoming number, 

the date and the time are recorded. If you wish, you can also deactivate this function. 
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Search for a number 

If you receive a call for which the number is being transmitted, the phone manager asks if 

the number should be searched for in the configured views. You can add a sound alert to 

this event. 

If you select YES, the configured views, that is, the contained phone and mobile phone 

fields are searched for matching entries. If the number is not found, cRM reduces the 

number automatically from behind to try and find other records of the firm. 

Tip: By using a sort order on all phone fields, the search speed can normally be 

increased. Alternatively, you can create an index of these fields directly in the server. 

8.4 Sending an SMS 

You have the option of sending SMS messages directly from a record. To do this, right-

click in a field of type "Mobile Phone" and select "Send SMS" from the context menu. 

Requirement for this is a dialing unit with TAPI driver that allows a data connection. 

These requirements are fulfilled by modems and also many ISDN devices. If in doubt, 

contact the manufacturer of your telephone whether data connections under TAPI are 

supported. 

Configuration 

If you have not made any settings yet, you can also choose one of the default settings 

(for modem or ISDN use). A corresponding selection dialog is started. 

 Select "Sending of SMS Messages" in the Settings; you will reach a dialog in which 

you can make the following settings: 

 Click on the "New" button to make a new entry.  

 Under Provider, enter which mobile phone operator the settings apply to. 

 Under Number Prefix  you can select all the prefixes, separated by commas, that are 

reserved for the selected operator (e.g. 0170, 0171, 0175 for the T -Mobile network). 

The SMSC Number is the dial-in number to the SMS centre of the operator. The 

number can be found out from the operator if it is not preconfigured. 

Some mobile phone operators support the transmission of a (numerical!) sender 

identification, i.e. you can give a sender number that should appear on the receiver’s 

display. 

 Which protocol (UCP/TAP) is used by your mobile phone operator should be found 

out directly from the operator. 
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Note: combit cannot take any responsibility for the dial-in numbers, especially 

regarding their availability. The mobile phone operators are responsible for these. A 

successful delivery notification is also no guarantee that the message has reached the 

recipient, it simply means that the message was successfully transferred to the SMSC, 

as is normal when sending SMS messages from a mobile phone. 

Sending SMS messages in the network  

If you only have a modem connected to one computer in your network, you can use it as 

a central server for the sending of SMS messages. 

Requirement for this is that both computers, client and server, are in the same 

workgroup. If in doubt, ask your network administrator. 

In the client, click on the button "Se lect" to select the server. In this case, the settings for 

the provider are inconsequential, since the configuration of the server is used. 

Logging the sending of SMS messages  

A log about the last calling attempt is automatically created. If you are sending the SMS 

message from your own computer, you can see the log with the "Details" button in the 

sending dialog. 

The same information can also be found in the file "sms.log" in the user sub-directory of 

the sender. When problems occur with the sending of SMS messages, you should first 

look if this information can provide a possible cause. 



E-mail 

130 

9. E-mail 

You can send single and multiple e-mails directly from cRM. For this, you have the choice 

between different formats and mail services. For multiple or standard e-mails, you can 

create e-mail templates and as well as being logged, sent e-mails can also be stored in 

the document container automatically. 

9.1 Technical requirements 

The technical requirements for sending e-mail are dependent on the format you choose 

for the e-mail. You have the choice between text and HTML formats. With the HTML 

format, you have the option of formatting the e-mail contents, for example. 

To send e-mails in text format, three services are available:  

▪ Simple MAPI: the standard interface for most e-mail programs (such as Thunderbird, 

Lotus Notes, David etc.). The e-mails will be sent through your e-mail program. 

▪ Extended MAPI: this service uses an advanced functionality of the interface with 

Outlook 2000-2013. With this, e-mails can be sent through Outlook without the user 

having to confirm the sending of every e-mail.  

▪ SMTP: When sending with SMTP, the e-mails are not sent through an e-mail 

program, but directly through an SMTP server.  

To send e-mails in HTML format two services are available:  

▪ Extended MAPI (Outlook 2000-2013 only): (see above) 

▪ SMTP (see above) 

Further information regarding the configuration of e-mail services can be found under 

"General configuration" in chapter "Configuring the sending of mail".  

9.2 Sending e-mail 

Note: To be able to mail directly from the context menu of a field, it must be set up in 

the view as an e-mail field. See also chapter "Configuration of views". 

Single e-mail 

There are various methods of sending a single e-mail: 

 From "e-mail" fields, an e-mail can be sent directly through the MAPI mail client (e.g. 

Outlook) by selecting the context menu item "Send e-mail" or optionally through an e-

mail template.  
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Further information regarding field types can be found in chapter "Configuration of 

views". 

▪ When sending through e-mail templates, the e-mail can be logged and 

automatically stored in the document container 

▪ When sending directly through the MAPI-standard client, the new e-mail dialog 

of your e-mail client opens and the address in the e-mail field is automatically 

used as the recipient. The sending of this e-mail is not logged and the e-mail 

cannot be stored in the document container automatically. 

To use direct sending, select F i le > Options > General  > Sending Mai l  and 

activate the option "Use MAPI Client for e-mails via context menu ". For further 

information, see chapter "General configuration". 

 Select Start > Send E-mai l  or Output > Send E-mai l . The dialog for a new e-mail  

opens. Enter the text or open an existing e-mail template. Further information about 

e-mail templates can be found in the next section.  

The sending of these e-mails can be logged, and the e-mail can be stored automatically 

in the document container. Further information can be found in chapter "Configuration of 

views".  

Multiple e-mail 

To send multiple e-mails, you must first create a filter. If a selection is not made, the e -

mail will be sent to all records in the view. Information regarding creating fil ters can be 

found in chapter "Filtering Records (Selection)". 

 Select Output > Send Multiple E-mail. The new e-mail dialog opens. Enter the text or 

open an e-mail template under F i le  > Open. Further information about e-mail 

templates can be found in the next section.  

 Start e-mailing under Start > Send.  

 The first e-mail address that isn’t empty is found from the given recipient fields and 

the e-mails are transferred to your default e-mail client or your SMTP server. Records 

for which no e-mail address could be found are listed at the end of the sending 

process. The sending of the e-mail can be logged and the e-mail can be 

automatically stored in the document container. Further information can be found in 

chapter "Configuration of views".  

For serial e-mails, it can be specified that the mail process is adhered to after a adjustable 

number of e-mails are sent and is not continued until after the specified wait time. For 

more information, see "Configuring the sending of mail" in chapter "General 

configuration". 



E-mail 

132 

9.3 Working with e-mail templates or standard e-mails 

For multiple e-mails (Campaigns, Newsletter) or recurring standard e-mails, it makes 

sense to create a template in advance in the e-mail editor. 

 Select Settings > E-mai ls to open the dialog.  

 

 Via F i le > Open, you can open an existing template, modify and finally save it via F i le 

> Save  or Save As. 

 The dialog contains three tabs where you can switch between the editing mode, the 

real-time preview and direct source code editing (HTML). 

 In the preview, you can browse through the filtered records with the arrow buttons. 

The entire setup of the e-mail, including subject, text, field variables, formatting (HTML e-

mails) and any attachments, is contained in the template. When saved, templates can be 
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used as often as needed. They work in a very similar way to document templates in your 

word processor. 

Creating e-mail templates 

You can make the following settings: 

▪ Format: In the "Format" ribbon, click on "Text" or "HTML". When you select the HTML 

format, additional formatting options are available to you, which will be described 

below.  

▪ Description: Enter a short description. This description is available as the variable 

"Action.TemplateDescription" in auto logs. Further information can be found in 

chapter "Configuration of views". 

▪ Sender: Here you can write an individual sender address. 

▪ You have three options: 

▪ Multiple recipients in separate mails (personalized): You can enter up to three 

To fields that contain e-mail addresses. If the first field contains no address, the 

other two fields are checked for their contents and the e-mail is sent to the 

addresses in them. Records that do not contain an e-mail address are listed 
after the mailing has taken place.  

▪ Multiple recipients in a single mail (not personalized): In the selection box 

above, you can also set that the multiple e-mail is to be sent to a distribution list 
by BCC. 

▪ One single recipient: You can enter the email-address in the To field. 

▪ CC: Additional recipients can be manually entered here. 

Note: Email addresses may include '<' and '>' as well, e.g. "Peter Ross 

<ross@combit.net>". 

▪ e-mai l  text: In the text field, enter the text and variables, such as the title and name 

of the recipient. Select Start > F ie lds, to insert field variables or functions such as 

date, time, calculations and conditions. By inserting fields in an e -mail template you 

can make your e-mails more personal and therefore more appealing. 

Example: ««Rtrim$(SalutationLetter +" "+Name)»», 

Further information about this can be found in the "List & Label Designer" 

documentation. In addition, you can also insert fields in the "Subject" field. 

▪ Add attachments: Links can be added to attachments via Start > Attachment or by 

right-clicking in the window "File". Since the template only contains the link to a file, 

this file must be found in the specified path at the time of the sending.  
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You can select any file via the context menu entry "New File". You can access the 

Formula Wizard via the entry "New Formula". These way attachments, for example, 

depending on the records can be omitted or attachments can be saved by using the 

cRM variable cRM.Project.Path relative to the project directory. . 

Links can be edited by double-clicking on an entry. The file link is removed from the 

template by selecting Delete in the context menu. 

Note: The template only contains a reference to the file, not the file itself. At the time 

of sending, the file for the required attachment must therefore still be under the 

directory given in the template. 

Options (text e-mail only) 

Under F i le > Options you will open a dialog in which the following settings are available: 

▪ "Transform German Umlauts before sending" changes the sometimes problematic 

German umlauts: "ä" becomes "ae", "ü" becomes "ue" etc.  

▪ "Encrypt mail text before sending" encrypts the mail text before sending it . Enter the 

desired password after activation. 

Formatting options of an HTML e-mail 

If you have "HTML" activated in the "Format" ribbon, the following formatting options are 

available to you: 

▪ Style: Various format templates are available. These are pre-set headings for 

example. 

▪ Characters: You can set the font, whether the font is bold or italic, right/left/center 

aligned etc. You can also insert bullets or change indentions in your e -mail. 

▪ Background: A certain background color can be set for an HTML e-mail. 

▪ Insert table: Select Start > Table , to insert a table in your e-mail text. Through the 

dialog that follows, you can define how many columns and rows the table has and 

what color it should be. After creating the table, further options are available where 

you can add, merge or delete rows and columns.  

▪ Insert picture: To add a picture to an e-mail, select Start > Picture . In the dialog that 

opens, select the required file. The picture file must be available at the time of 

sending as it is only inserted in the e-mail at that time.  

▪ Insert hyperlink: To insert a hyperlink, select Start > Hyperl ink. In the dialog that 

opens, you can define the link and set the desired type (http, mailto, etc.) 
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Import of an HTML e-mail into the template 

If you have already formatted an HTML e-mail in another editor, it is not necessary to edit 

the e-mail again. With File > Import you can insert an existing HTML file into the e -mail 

template, or accordingly, the editor. 

Hint for experts: The mail template is a text file into which HTML could be coded 

directly with an editor. To use this option, you should be fairly competent with the 

subject, because the template could in some cases not be loadable. 

9.4 Automatic e-mail archiving 

You have the option of archiving e-mails in the document management after sending 

them. The archived e-mails can be opened at any time and this allows for complete 

storage of all sent e-mails. The description of the necessary configuration can be found in 

the section "Document management" in the chapter "Configuration of views". 

9.5 Email Autopilot 

The Email Autopilot runs on a server and monitors an inbox constantly. It can start a 

workflow that is triggered by a certain subject line. With this, for example, internet/e-mail 

queries can be automatically analyzed and synchronized with records, or entries in 

records can be made automatically. If no associated record is found, a new record can be 

created. More information can be found under "E-mail autopilot" in the chapter 

"Workflows and Events". 
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10. Output of data 

When outputting data, you have various options: 

▪ Single transfer of data with a transfer template into another application (e.g. Word). 

This output is suitable for individual letters, for example, since the printing contents 

can be changed in the corresponding application (e.g. Word) before printing. For 

further information, see chapter "Single transfer to other programs".  

▪ If these documents are to be automatically stored and managed in the document 

container, configure this single data transfer in the document management. For 

further information, see chapter "Activities and Document management". 

▪ Another option is the direct output through print templates. For this, print templates 

are used, which can be adapted in the integrated List & Label designer. This output is 

especially suitable for standardized outputs such as standard letters, mail merge 

letters, address labels, name signs, lists and reports. For this output, the contents 

cannot be changed after the selection of the print template (exception: interactive 

user input through the AskString$() field function). 

▪ The output can occur on the printer as well as other formats such as PDF, Excel, RTF 

and HTML. . For further information, see chapter "Output with print templates". 

▪ If you want to create mail merge letters in a word processor (e.g. Word), you can find 

further information in chapter "Printing a mail merge letter with the word processor". 

The direct output through print templates is generally quicker.  

▪ If you wish to export data to another application for further processing, you can find 

further information in chapter "Import, export and synchronization". 

▪ With the statistics function, you can analyze field contents statistically. For further 

information, see chapter "Statistics functions". 

▪ With instant reports you can archive print templates combined with filters and 

display them in the navigation for quick access. More information can be found in the 

chapter "Instant Reports". 

10.1 Single transfer to other programs 

You can transfer the field contents of the active record into another application (e.g. 

Word) using a single transfer with help from a transfer form. This transfer is useful for 

individual letter, since you can adapt the print contents before printing in the 

corresponding program (e.g. Word). 

It is also possible to transfer fixed text (e.g. return address), formatting, format templates, 

conditions and functions. The target program is started automatically. 
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Further information on the configuration of transfer templates can be found under 

"Configuring transfer templates" in chapter "General configuration".  

 

If you already have a transfer form set up, you can run it in the following way: 

 Select Output > Transfer to Word Processor or click on the corresponding button to 

transfer the active record (e.g. to Word, Excel or into the clipboard).  

 The active record is inserted at the insertion marker or at specific bookmarks in the 

target application. 

▪ If the target application is already open, the data is inserted into the currently 

active document. Otherwise, a new document is opened. 

▪ If a document template is set in the transfer form, all data is inserted into this 

template. 

 The currently active transfer form is run. A transfer form can be activated under 

Settings > Transfer Templates > Select .  

Normally, you will find the transfer forms (file ending *xfx) in the "Transfer forms" 

folder in the project directory. The activated transfer form remains active until you 

select a different transfer form. The workload for a single transfer is therefore 

reduced to a single click of the mouse.  

Transfer forms can also be run through a user defined button. Further information 

can be found under "Function definitions" in chapter "Configuration of views" 

10.2 Output with print templates 

Print templates, which can be edited in the integrated List & Label Designer, are used for 

the direct output of data. 

Information regarding the configuration of print templates can be found under 

"Customizing print templates" in chapter "General configuration". 

This output is especially suitable for standardized outputs such as standard letters, mail 

merge letters, address labels, name cards, lists and reports. For this output, the contents 

cannot be changed after the selection of the print template (exception: interactive user 

input through the AskString$() field function). 

actual record

transfer template document

field contents
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Single and multiple printing is always differentiated. For the single print (e.g. a standard 

letter) the output is always the data of the active record. For a multiple print (e.g. address 

list), the output is the data in the currently active filter. For this reason, you should filter 

the records before a multiple print, since all records in the open view will otherwise be 

printed. 

In the following sections, only multiple prints are considered. Single prints work in the 

same way. 

Note: Single and mail merge letters can be created and printed directly in your word 

processor. Direct printing is, however, generally quicker. More complex conditions 

such as the automatic decision between PO box and home address can be set up 

more easily in cRM than in the word processor. The advantages of the word processor 

are the more comprehensive formatting options.  

Output of labels 

With Output > Print you can print the active address onto a label or envelope (Treat 

envelopes as large labels). 

 Select Output > Print > Print Single  Label  

 Choose the print template for the label (file ending *.lbl). Print templates can be 

found in the "Print templates" folder in the project directory.  

 Define the print settings (see chapter "Output - Settings") and place labels in your 

printer. 

 Click on "Start". 

With Output > Multiple  Print you can print labels for all records in the current filter. If no 

filter is active, labels are printed for all the records. The output sequence of the records is 

the same as the current sort order. 

 Create a filter with F i l ter 

 Select Output > Multiple  Print > Print Labels 

 Choose a print template for the label. Print templates can normally be found in the 

"Print templates" folder in the project directory.  

 Define the print settings (see chapter "Output - Settings") and place labels in your 

printer. 

 Click on "Start". 



Output with print templates 

139 

Output of lists and reports 

With Output > Print  you can print a report for the active record (e.g. print-out of company 

details, including all contacts, or the print-out of a person’s details, including all contact 

entries).  

 Select Output > Print > Print L ist (Report) for Record 

 Select the print template for the list (file ending *.lst). Print templates can normally 

be found in the "Print templates" folder in the project directory.  

 Define the print settings (see chapter "Output - Settings"). 

 Click on "Start". 

With Output > Multiple  Print  you can print out all records in the active filter as a list (e.g. 

list of companies, including all contacts, or a complaints list). If no filter is active, all 

records are printed. The order of the output of the records corresponds to the active sort 

order.  

 Create a filter with F i l ter. 

 Select Output > Multiple  Print > Print L ists/Reports 

 Select the print template for the list. Print templates can normally be found in the 

"Print templates" folder in the project directory.  

 Define the print settings (see chapter "Output - Settings"). 

 Click on "Start". 

Output of file cards 

A record’s important information is normally printed on a file card (e.g. information on a 

person, including the comment field). This is useful for field workers, who have all 

relevant customer information available with this. 

 Select Output > Print > Print Single  Card 

 Choose the print template for the file card (file ending *.crd). Print templates can 

normally be found in the "Print templates" folder in the project directory. 

 Define the print settings (see chapter "Output - Settings"). 

 Click on "Start". 

Under Output > Multiple Print  you can print a file card for all records in the active filter. If 

no filter is active, all records are printed. The print order corresponds to the currently 

active sort order.  

 Create a filter with F i l ter. 

 Select Output > Multiple  Print > Print Cards 
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 Choose a print template for the file card. Print templates can normally be found in 

the "Print templates" folder in the project directory. 

 Define the print settings (see chapter "Output - Settings"). 

 Click on "Start". 

Output of single and mail merge letters 

Single and mail merge letters can be printed directly or through your word processor. The 

direct print is quicker and more complex conditions such as the automatic decision 

between PO box and home address can be more easily set up than in the word 

processor. 

The direct print is therefore especially suitable for standardized outputs such as standard 

and mail merge letters, since the contents cannot generally be changed after the 

selection of the print template (exception: interactive user input with the AskString$ () 

field function). 

The advantage of the word processor lies mainly the more extensive formatting options 

and the option of reworking individual letters. Further information can be found in chapter 

"Printing a mail merge letter with the word processor". 

Through the menu item Output > Print Letter you can print a standard letter for the active 

record (e.g. product information, catalogue request). 

 Select Output > Print Letter 

 Choose the print template for the single letter (file ending *.crd). Print templates can 

normally be found in the "Print templates" folder in the project directory. 

 Define the print settings (see chapter "Output - Settings"). 

 Click on "Start". 

Through Output > Print Multiple Letters you can print a mail merge letter for all records 

in the active filter. If no filter is active, all records are printed. The print order of the 

records corresponds to the currently active sort order.  

 Create a filter with F i l ter. 

 Select Output > Print Multiple  Letters 

 Choose the print template for the mail merge letter. Print templates can normally be 

found in the "Print templates" folder in the project directory.  

 Define the print settings (see chapter "Output - Settings"). 

 Click on "Start". 
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Output - Settings 

If you select a print template with Output > Print / Multiple Print or Output > Print Letter 

/ Print Multiple  Letters, the dialog for the output settings is generally displayed. 

 

You have various options to choose from: 

▪ A printer is already set in the print template. With the "Change " button, you can 

choose a different printer.  

If you have defined multiple layouts, you can choose for every layout a different 

printer and under "Copies" enter the number of copies to be printed.  
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▪ Under "Direct to" you can select the output format (e.g. preview, printer, Excel). 

Please take into account the range of options available for formatting that are 

accessible for the menu option "Option", e.g. the number of Excel rows and columns 

can be limited to a required number using the option "Exclusive data export from 

table objects". 

▪ With the "Preview" option, you can view and check the real data on the screen before 

sending it to the printer.  

▪ If you turn on the option "Save options permanently", the newly selected printer will 

become the default for this print template. 

▪ Under "F irst Page  " you can set with which page the print starts.  

▪ In the "Pages" option, you can set a specific page range for the print, separated with 

commas if necessary (e.g. 1, 3-4, 10-). 

▪ Under "Copies" enter the number of copies to be printed.  

▪ Start printing with the "Start" button.  

▪ With labels, you have another setting called "Start position ". With the "Select" button, 

you can set the starting position of the print on the first page of labels, so that pages 

that have already been started can be used. The selected starting position is 

displayed in the field "Start position". 

Printing with the preview 

All print outputs can be examined with real data in a preview window on the screen. 



Output with print templates 

143 

 

In this way, you can check the layout of a print without having to waste paper. The output 

on the screen is exactly as it would appear in real print (WYSIWYG). After the layout 

check you can start the print directly from the preview window without having to run the 

print command again. 

 After selecting the print template, select "Preview" under "Direct to…" in the print 

dialog. 

 In the preview window, the single print pages are displayed with the real data. The 

unprintable edges of a page are hatched. 

 On the left side of the preview window the various print pages are shown as 

thumbnails. This enables you to quickly navigate between the pages of the 

document by clicking them. 

 The "Copies" set in the print options is not respected in the preview. This only 

becomes relevant in the actual print. 

 The preview window contains a toolbar with which the various functions of the 

preview can be controlled. 

▪ The selection of the current page can be controlled with the arrow keys or the 

list. 
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▪ The zoom selection list, the magnifying glasses and the 1:1 tool can be used to 

change the zoom setting, with which you can make finer details clear. You can 

also zoom in on details by dragging over them with the left mouse button in the 
preview window. 

▪ With the print buttons you can individually print the current page in the preview 

or print the entire document (copies are not respected in the preview). If you 
right-click on the print button, the printer selection dialog will be displayed. 

▪ With Send to the current preview file (file extension .LL) can be sent to other 

people by e-mail. They can view the preview, print it, or send it themselves. In 

this way, a preview file can be passed around a workgroup without it having to 

be printed on paper.  

▪ With Exit Preview you can leave the preview window and return to your 

application. 

Output to other formats (PDF, RTF, Excel, ...) 

Print outputs can also be output into other file formats. For this, select the corresponding 

output medium in the print options dialog. Please note that the layout may not always be 

transferred 1:1 depending of the format, since some have specific limits regarding the 

conversion. 

If you have chosen a format other than printer or preview, for example when saving in the 

preview mode, select "Save As" in the following dialog and enter a name for the file being 

created in the "F i le  name" field. 

In addition, you have the option of displaying the file directly in the corresponding 

program or to send it by e-mail. Activate the corresponding options if required. 

 With the option "After saving, open the file in the registered appl ica tion" you can 

open the file directly in the relevant program (e.g. Excel) after creating it. 

 With the option "Send exported file  by emai l " you can send the file directly by mail.  

 With the option "Digital ly sign created fi le " you can digitally sign the file. Further 

information can be found in chapter "Signing documents digitally". 

Output as PDF 

The PDF export module creates document in portable document format. This format can 

be displayed independent of platform with the freely available Adobe Reader®. In the 

print options dialog, various settings are available for the PDF format: document 

information, JPEG generation, resolution and page options, etc. 



Printing a mail merge letter with the word processor 

145 

Output as Word 

The Microsoft Word export format creates DOCX files that are compatible with Microsoft 

Office 2007 and higher. Tables will be exported on continuous pages to support later 

editing. 

Output as Excel file 

The Excel output module creates documents in Microsoft Excel format. In the print 

options dialog, various settings are available for the Excel format. To reduce the number 

of columns and rows to the necessary amount, activate "Only data from table  object(s)"  

on the "Output" tab. 

Signing documents digitally 

Many conventional processes require by law because of the written form a signature, for 

example, with the documentation of declarations or for electronically transmitted invoices 

if they may be subject to deductions in accordance with the Value Added Tax Act. The 

digital signature can also be used for preparation and submission of bids, contracts of all 

types, accounting-related sales reports or for any other exchange of sensitive 

information. 

In order to be able to sign documents, you need signing software. You can find the 

products that are supported under "System Requirements" in chapter "Preparation and 

Installation". 

 Install the signature software and configure the interface between signature 

software and the cRM.  

 In the cRM select the desired print template via Output > Single letter/Mail merge 

letter > Direct or Output > Single print/Multiple print > Label/Card/List. 

 During output, you can specify the output format using the various setting options. 

The PDF format (the TIFF and TXT formats are also possible) is especially well suited 

for digital signatures.  

 In the following "Save As" dialog, select the location to save to and enter a name for 

the file to be created in the field "File name". 

 In the same dialog window, activate the option "Digitally sign created files " then click 

on Save. 

 The document is created and digitally signed at the same time by the signature 

software. 

10.3 Printing a mail merge letter with the word processor 

Single and mail merge letters can be created and printed directly or through your word 

processor. The direct print is quicker and more complex conditions such as the automatic 
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decision between PO box and home addresses can be set up more easily than in the 

word processor. 

Further information about direct printing can be found in chapter "Output of single and 

mail merge letters". 

The advantage of the word processor lies in the more extensive formatting options and 

the change to rework letters individually. 

For a mail merge letter in a word processor, you differentiate between the main 

document i.e. the actual letter text, and the data source, i.e. the individual addresses. 

Both together create the mail merge. In the word processor the data from the data 

source is automatically inserted into the main document. More about the creation of mail 

merge documents can be found in the documentation of your word processor. 

The data source with the desired records for the mail merge creation can be created 

directly. The created data source then simply has to be connected with the main 

document in the word processor and the mail merge is complete. 

To create a data source for the multiple record print, proceed as following: 

 Create an extract with the records to be printed. 

 Select Output > Multiple  Letter via Word Processor 

 In the export wizard, create a new export format (e.g. in Word format) 

▪ If you wish to edit or create a new export format, select "Next" 

▪ If you want to run the export template, select "Execute". 

 If you selected "Next" in the previous dialog, you can customize the export format. 

The address lines can be changed or added as desired and additional fields can also 

be added. Further information regarding editing and saving export templates can be 

found under "Export of records". 

▪ Only the fields selected here are later available in the word processor as 
multiple record print fields. 

 In the following dialog, enter a name and target directory for the data source file. 

Take note of the file name and target directory. If you wish to connect the data 

source file with the main document, you must enter the file name and directory of 

the data source file. It is therefore important to remember this information. 

 The data source file is created e.g. as file with the extension *.DOC. 

 Open the word processor (e.g. Word) and create the mail merge letter. As data 

source, select the data source file just created (e.g. Addresses.doc). 

 Insert the multiple print fields into the document. Please find out any further 

information about the creation of mail merge letters from the documentation of your 

word processor.  
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10.4 Instant Reports 

Note: This function requires the Professional or Enterprise Edition. 

With instant reports you can store print templates combined with filters and display them 

in the navigation for quick access.  

Display instant reports 

Select Output > Report  to open a report from the report library. Alternatively, you can do 

so via the "Navigation" window.  

The report will be displayed in the Report window. Via the buttons on the "Navigation" 

toolbar, you can browse through the records if the current record was selected as the 

data basis. 

Via view properties, you can also set a default report for this button. More information on 

this can be found in the chapter "Configuration of views" under "General". 

Configure instant reports 

 Select Settings > Instant reports 

 If you want to create a new instant report, select "New". 

 Decide whether the instant report should be available to all users.  

 Select the print template you want to use and enter a description. 

 Decide which data should serve as the basis of the report, the current record, the 

currently active filter or a certain filter that be defined via the button. 

 You can also choose a specific name that can be used for script or workflow access.  

With the Checkbox "Display in Navigation", you can make the report available for quick 

access in the "Navigation" window. 



Output of data 

148 

 

10.5 Statistics functions 

With this function you can easily statistically evaluate the contents of single fields. You 

can let character and numerical fields be counted for which contents are most common. 

In character fields, combinations of two fields can be considered. 

Display statistics 

 Select Output > Statistics to open the statistics library. 

In this dialog, statistical analyses can be saved specifically for the user or for all users 

of the project. 

 Select the desired statistic. 

 Click on the "Execute " button.  

▪ You are given the results as a table and in the required charts.  

▪ When selecting the print option, the preview is started in List & Label, from 
where you can start the output on a printer or the sending by e-mail. 

If a print template is selected for the statistic, the display will be in accordance 
with this template. 
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Creating statistics 

 If you want to create a new statistical analysis, select the "New" button. 

 In the dialog that opens, you can set whether the saved statistic is to be available to 

all users or just yourself. 

 Confirm the input with "OK". 

 In the following charts dialog, you can set the conditions for the statistics, such as 

the data source (i.e. the desired field), the calculation type and even the form of 

display. As soon as you have chosen the data, you will be shown a preview of the 

end result. 

Note: More information regarding the creating of a chart can be found in the 

documentation of "List & Label Designer". 

 After confirming the stated conditions you click on OK, upon which the statistics 

template is added to the list of statistical evaluations. A statistic that has been saved 

can be recalled from this list at any time, or edited if required. 

▪ In the "Statistic" field, you can set a name. With the "Settings" button, you can 

change the statistic’s settings.  

▪ In the "Print template" field, you can define a print template for the statistic. 
Using the buttons, you can directly create, select and edit it.  

▪ In the "Description" field, you can write a detailed description.  
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10.6 Visualization of data 

When using Microsoft MapPoint, you have the option of viewing your records on a map, 

for annual sales by zip code. You can then transfer the content of a database field to 

MapPoint. 

 On the "Fields" tab, link the "Add-On" field with the data field that you want to 

visualize (e.g. with the sales field). Currently, only fields that are available directly in 

the view (no 1:1 fields) are supported. If you do not select a field, the records are 

counted (field content "1"). 

 Create a filter over all records that are to be visualized and select F ind > Route 

Planning > Set al l  records in the fi l ter as waypoints.  

 After you have selected all of the waypoints, select F ind > Route Planning > Route 

Planning.  

 

 In the dialog "Route Planning", select Show waypoints to transfer the waypoints to 

Microsoft MapPoint. 

 In Microsoft MapPoint, you can adjust the display of the data via Data > Data 

Assignment Wizard. Additional information can be found in the MapPoint 

documentation. 
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11. Fax 

11.1 General information on faxing 

You have the option of sending single and multiple faxes directly from the program 

without much effort.The currently loaded record serves as the data source for single 

faxes. With multiple faxes, the current filter of the database is used.  

Note: Requirement for faxing is that a fax program is installed and the PC 

is equipped with a fax modem (or is connected to a faxserver). Under Windows 7 / 8 

the "Windows Fax and Scan"  is included, which include all the necessary functions 

to send and receive faxes. For more information see http://windows.microsoft.com/en-

us/windows7/Set-up-your-computer-to-send-and-receive-faxes. Alternatively you can 

choose a separate fax program. 

11.2 Faxing with List & Label templates 

You can fax directly with List & Label templates. 

 To send a fax, first go to the record of the person to whom the fax is to be sent. 

Now, select Output > Print Letter and choose the saved template. The output dialog 

opens and as long as your fax driver is correctly installed, under "Direct to" the item 

"Fax Device (Fax)"  is shown. Click on the "Start" button to send the fax. 

 To send a multiple fax, first select the desired recipient group with the filter 

functions. Now proceed in the same way as described when sending a single fax, 

and the fax will be sent to all records in the active filter. The only difference is that 

you have to select Output > Print Multiple  Letters. 

Customizing the fax template 

When faxing directly from the software, you do the following: 

First you must create an appropriate fax template. You do not have to create this from 

scratch, however, but can adapt the included standard template to your needs. 

 To configure this standard fax template, click on Settings > Card/Letters. Now select 

the file "Contacts – Windows Fax template.crd" from the "PrintTemplates" sub 

directory. 

 The template is opened in the List & Label Designer. Now, you can make any desired 

changed, such as changing the text, etc. 

 When sending a fax, additional information is required to be able to address the fax, 

i.e. at least the fax number must be placed in the document as information. These 

fax variables are defined directly in the properties window of the project. The 

http://windows.microsoft.com/en-us/windows7/Set-up-your-computer-to-send-and-receive-faxes
http://windows.microsoft.com/en-us/windows7/Set-up-your-computer-to-send-and-receive-faxes
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properties window of the project is displayed when no objects are selected in the 

work area. 

 

Note: There are more possibilities for sending faxes, such as with title macros (macros 

that react to particular window titles, such that of a fax program) or through David 

from Tobit. Further information regarding this can be found in the support area of 

www.combit.net. 

htt://en.combit.net/support.aspx
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12. Import, export and synchronization 

With these functions you can import data or datasets, export to other programs or run 

synchronization. To simplify the procedures, a wizard is available for each that supports 

you even with complex field assignments. 

The following options are available: 

 Import of data, e.g. from other databases, text files, Excel files etc. The data is 

turned into new records using a field assignment you define.  

 Export of data, e.g. pass data to other applications, create Excel files, create mail 

merge data sources, etc. 

 Synchronization of data, with this, as opposed to the import, a possibly existing 

record is searched and synchronized or, if it is not found, is imported. This allows 

you to undertake data synchronization. The different forms of synchronization are 

described here: 

▪ Synchronization with applications, databases, text files, Excel files, Outlook 

contacts etc. A database (or cRM view) acts as source and normally remains 

unchanged. 

▪ Synchronization with Outlook contacts. The synchronization is carried out in the 

form of an export with an automatic import afterwards. 

▪ Synchronization with smartphones through Outlook or import/export. 

12.1 Replication 

For the synchronization of databases use the replication mechanisms provided in the 

database system. 

Example: A sales representative is taking a part of the central database on his travel. 

While he is visiting the customers, he is working with the data, is correcting addresses 

and is entering new notes. In the headquarters it also will meanwhile be worked with the 
data. After the return of the sales representative, both databases should be synchronized. 

In this way, a freely configurable and powerful synchronization is possible. For more 

information about replication with MS SQL Server, see our Knowledge Base at 

http://support.combit.net/ in the article "Replikation mit SQL Server" (german only) and 

the documentation of the database system used. 

Please note: When replicating, the synchronization of the project configuration 

settings is not supported (e.g. activated code field entries, new code field entries, 

navigation structure, project filter). 
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12.2 Importing Flat data structure 

With Data > Import, you can only import individual tables, so you have to link the records 

after the import again. To link records after the import, we recommend the following 

procedure: 

1. Delete all possibly existing constraints in the database system which an import could 

fail (e.g. if one record in the view "Activities" must be linked with a record from the 

view "Contacts", this is not possible at the time of import). 

6. Import the data in the respective views. The field through which the records are 

clearly linked should be imported in the fields "Z_Import_PK" and "Z_Import_FK". 

7. Setting the key field in the database system with a query.  

8. Backup the previously deleted Constraints. 

Example-Query: 

update "Contacts" 

set "CompanyID" = (select distinct "Companies"."ID" FROM "Companies"  

where "Contacts"."Z_Import_FK" = "Companies"."Z_Import_PK")  

where "Contacts"."Z_Import_FK" IS NOT NULL AND LEN(RTRIM("Contacts"."Z_Import_FK"))> 0 

AND ("Contacts"."CompanyID" IS NULL OR LEN(RTRIM("Contacts"."CompanyID"))= 0)  

12.3 Import of records 

With Data > Import, you can import external and internal files. The database or file from 

which the records are imported (=source file) remains unchanged. 

Since the fields of the source file do not necessarily correspond to those in the target file, 

the fields that are linked must be defined when importing. The links between the fields in 

source and target database can be made automatically or manually. The format set in the 

wizard can be saved, and it will then be available under "User Defined Formats"  and can 

be run instantly. 

Format selection 

 Select Data > Import to start the import wizard. Numerous different text and 

database formats can be imported. You can find these formats listed in the import 

wizard. 



Import of records 

155 

 

▪ With Data sources (ODBC) you can import from data sources for which an 
ODBC driver is installed (e.g. Oracle, Sybase SQL, cobra Adress PLUS). 

▪ Access import through configuration of the ODBC interface. 

▪ When importing text files (fixed or variable column widths) the import wizard 

tries to auto-recognize the format (column and row separators as well as single 

columns) from the defined data source, with which the definition of an import 

format of text data is usually simplified considerably. 

▪ The import of address manager databases serves to join together different 

databases with different database structures into one file. If the structure is the 
same, the function Data > Import with Synchronization  can be used. 

▪ Phone CDs: In the next window you are given advice how to export data from 

the corresponding application, since exporting data first is necessary to be able 

to import them into cRM. If you have already carried out the export, you can 

confirm with "Next", otherwise you now open the phone directory application. 

Here you search for and select the desired data and export them according to 

the instructions of the import wizard before starting the import. 

 Select the desired import format or the application and confirm with "Next >".  
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Tip: If you run a format of your own creation, you can use it immediately (button 

"Execute"). Otherwise, the wizard enables you to change the definition retrospectively 

or to save it under a new name. 

Select a data source 

 In the following dialog, select the source database. With most formats, you will be 

shown a preview of the contents. 

 

Special case: import format Excel 

If you choose the Excel format, another dialog is opened. In this dialog, you can select 

the Excel file and, if necessary, the data range: 

 Select the Excel file with the button "Browse". As standard, the data range is found 

automatically, i.e. all columns are read in for which there is an item in the first row. 

 With the button "Settings" you can set the data range to be read in yourself. To do 

this, activate the option "Define data expl ici t ly"  and enter the Excel coordinates. 

If you activate the option "F irst line contains data" , the field contents of the first row 

are not used as descriptions but are imported as data. In this case, the columns are 

given the titles (A, B, C…). 
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Special case: import format ODBC and Access 

If you select the format ODBC or Access, another dialog is opened. In this dialog, the 

ODBC data source must be set up in several steps. 

 To add a new data source, select ODBC Admin. 

 

 In the dialog "ODBC Data Source Administrator ", select "Add" to add a new data 

source. 
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 Select the corresponding driver, e.g. Microsoft Access Driver. 

 

 In the following dialog select the data source; for an Access database, this is done 

with the "Se lect" button. Also, enter a data source name and description. Confirm the 

selection with OK and confirm the dialog "ODBC Data Source Administrator"  with OK 

too. 
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 Back in the "Se lect Data Source" dialog click on the button "Refresh". In the list of 

databases, the newly added data source is now listed, in this example the Access 

database "persons" and in the right-hand window the table "persons" contained in it. 

 

 Select the data source. In some cases a username and a password are required. If 

you have not set any, simply confirm the dialog with OK. 

Field assignment 

Since the fields in the data source do not necessarily correspond to the fields in the 

target, a field assignment must be defined in the next dialog. The assignments between 

the fields in the source and the target can be made automatically or manually. 

 Usually you can let the wizard do most of the work in the first step: with the button 

"Automatic assignment" the wizard will try to link the fields of the source and target 

file based on the field names. Already existing assignments are not overwritten. 

Fields for which no corresponding fields were found can be assigned manually 

afterwards. Of course, you can also change undesired assignments. 
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 In various field types (number, character, date etc.) the auto-assignment uses 

conversion formulas – please check the formulas to make sure they make sense in 

your situation. 

For all (still empty) fields in your database into which you want to import values, you must 

now carry out the following steps: 

 Select the row with the desired target field and click on the corresponding column 

"Source field or formula" . Now you can select a field of the source database directly. 

 Alternatively you can open the formula wizard with the item second from top "Edit 

formula". With the formula wizard you can define fixed text, conditions, field links or 

parts of field contents as contents. Examples of this are street and house number, 

which are often stored separately. 

 

Note that assignments between fields of different types are possible, but do not always 

deliver the desired result. An assignment between a comment field and a numerical field 

makes little sense. This applies especially to the "Character", "Numerical", "Comment", 

"Documents", "Contacts", "References" and "Date" types. If you select the auto link, the 

different field types will be converted if possible. 
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If the target field is shorter than the source field, the excessive  characters are cut off. 

This applies to decimal places in numerical fields too and the numbers are not rounded! 

You can, if necessary, address this with a formula. 

In the data filter at the bottom you can enter a formula with which the records to be 

imported can be limited – only the records that meet the conditions are imported. If the 

formula field is empty, all records from the source database will be imported. 

Name allocation for the format 

Formatting set in the wizard can be saved and will then be available to run instantly under 

"User defined formats". In the following dialog you can set a name for it. If the template 

should not be saved, simply leave the name field empty. 

Templates are also useful if they only fit the involved databases approximately. Generally, 

it is less effort to adapt an existing template than to set all links again. 

The templates are saved in the respective application data directory, i.e. they can only be 

selected and run by the respective creator under "User defined formats" . Global 

templates can be found under "User defined formats > Global ". 

Starting the import 

In the following dialog you are given a summary. If you confirm this, the import will start. 

You reach this page directly if you select one of your own formats from the "User defined 

formats" in the format selection (on the first page of the wizard) and press "Execute". 

As long as records with the same contents are present in the source and target database, 

these are not overwritten but added. It is therefore possible that duplicate entries will 

exist after the import. We recommend a dupe check to be run afterwards (see chapter 

"Filter duplicate items (dupes)") or to read in the data by synchronization. 

12.4 Export of records 

With Data > Export you can export records to another file format or application. If an 

extract is active, only the records in the extract are exported. If no extract is active, all 

records are exported. 

Format selection 

Select Data > Export to start the export wizard. Numerous different text and database 

formats can be exported.  
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You will see these formats listed in the export wizard, among which are the following 

options: 

▪ Direct export to Excel, Word, Outlook, OpenOffice, XML… 

▪ With Datasources (ODBC) the export to data sources for which an ODBC driver is 

installed is possible (e.g. SQL Server, Oracle, Sybase SQL, Access). 

▪ When exporting text files (fixed or variable column widths) you can define the format 

(which columns as well as column and row separators) yourself. 

▪ Pre-defined text formats for the export to shipping software, such as EASY LOG, UPS 

OnLine WorldShip etc. 

Select the desired export format or the application and confirm with "Next >".  

Special case: text file 

Under "Text" you have the possibility of exporting your data in a universally useable text 

format. If you select this format, several dialogs will follow in which you can set up the 

format of the text file very flexibly. The following parameters are configurable: columns 

separators, column frames, row separators, date format (field sequence and separators), 

decimal point (or comma), character set (ANSI, ASCII, Unicode or HTML 3.2), with or 

without header. 
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Field selection and field linking 

In the same way as when importing, the fields that are linked must be defined for export 

too, since the fields of the source file do not necessarily correspond to those in the target 

file. The links between the fields in source and target database can be made 

automatically or manually. 

 

With the buttons in the top section of the dialog, you can change the column sequence, 

delete columns that are not being exported, edit columns, append new columns (not for 

Outlook export) and can open the formula wizard, with which you can define a formula 

expression (e.g. to connect fields such as first name and surname). For multiple selection 

hold the Shift-button pressed. 

Note: Fields with lengths of up to 32kB are exported from the source database. 

Comment and code fields 

Please note that fields of type "Characters long" (memo fields) can only be sensibly 

exported to a database format or a user-defined format with column framing AND 

column separators. The reason for this is that comment fields contain line breaks (word 
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wrapping). These breaks are used as separators between records in many formats (text 

formats and many mail merge files). If a comment field is exported with line breaks, the 

export file will be brought into disarray by these breaks. 

Code fields are saved in a character field using a sequence of "0"s and "1"s. The number 

of storable entries is set by the physical field length of the character field. They can also 

be exported in this form. For example, a "1" in 10 th place stands for the information: code 

no. 10 is active. 

For the export of code fields you may choose to activate the option "Code description for 

print and export" (F ile > Information > Properties  > Settings). In this case, the code 

descriptions (e.g. "Xmas Card") will be exported and printed instead of the code number 

(e.g. "0010101"). 

Name allocation for the format 

Formatting set in the wizard can be saved and will then be available to run instantly under 

"User defined formats". In the following dialog you can set a name for it. If the template 

should not be saved, simply leave the name field empty. 

Templates are also useful if they only fit the involved databases approximately. Generally, 

it is less effort to adapt an existing template than to set all links again. 

The templates are saved in the respective user directory, i.e. they can only be selected 

and run by the respective creator under "User defined formats". Global templates can be 

found under "User defined formats > Global " . 

Select target file 

In the following dialog, enter into which file or database the data is to be exported. 

Special case: Excel 

If you wish to export data into an Excel file, select the "Browse" button here. 

 In the next dialog, select the "Open" button. 

 In the "Save As" dialog, either select an existing Excel file or enter a new Excel file 

name in the "File Name" field (e.g. "persons"). 

 In the "Select Data source" dialog, enter a name for the worksheet in the "Worksheet" 

field into which the data is to be exported (e.g. "Table1"). If you have selected an 

existing Excel file, all available workbooks are displayed and you can select the one 

you want by double-clicking it. 
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Save the target file in the template 

Afterwards, you can choose whether this file name should be saved with the template or 

whether a selection dialog for the name of the export file should always appear. 

Starting the export 

In the following dialog you are given a summary. If you confirm this, the export will begin. 

As soon as it is finished you will be given a confirmation of successful completion. You 

will reach this page directly if you select one of your own formats in "User defined 

formats" in the format selection (on the first page of the wizard) and click the "'Execute" 

button. Global templates can be found under "User defined formats > Global " . 

12.5 Synchronization of records 

The synchronization function is useful for avoiding dupes when importing data from 

external sources (e.g. from an Excel file). 

For synchronization of cRM SQL Server databases see chapter "Replication". 

Synchronization of data 

In doing so, the address data as well as the appointments and tasks are synchronized. 

Further information about this subject can be found in the documentation of the 

database system being used. Also, take note of any limitations of the various SQL Server 

editions. 

Requirements for the synchronization through cRM  

Because the changes made during data synchronization cannot be undone, you should 

always make a backup of the database  first! 
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The items in the used fields should have the same type of notation. For example, the 

street notation should be the same throughout, not "Edisonstr.", "Edisonstreet" or "Edison 

Street" depending on who entered the information. If necessary, all users should be given 

a company-wide policy for the notation in addresses. 

When synchronizing databases in cRM, the current view acts as target (="Master-

Database"), into which the results of the synchronization can be transferred. The other 

data source (="Slave -Database") acts as source and generally remains unchanged. The 

active view is therefore brought up-to-date with the synchronization of the Slave -

Database . 

Selecting the format and data source 

Select Data > Import with Synchronization  in the corresponding view to start the 

synchronization wizard. The synchronization can be carried out with numerous different 

text and database formats. You will see the formats listed in the synchronization wizard. 

Select the desired synchronization format or application and confirm with "Next".  

Tip: The synchronization with Outlook contacts can be carried out as a complete 

synchronization. The addresses are synchronized in the procedure. To do this, select 

the synchronization format Outlook > Outlook -Contacts. You may have to confirm a 

security alert ("An external application is trying to access your address book"). 

The synchronization wizard is identical to the import wizard in many dialogs. You should 

therefore read the section on importing since this is a requirement for synchronization. 

Allocating the key fields 

The key fields, which must first be defined, are decisive for the synchronization. Which 

record in the source corresponds to which record in the main database must be set. The 

key fields are for this purpose. When selecting the key fields, you should make sure to 

select the correct fields. Respective of the task, you should only select those fields that 

clearly identify a record when combined. 
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Tip: In any case you should check the uniqueness of your key fields by running a dupe 

check in the main database (F i l ter > Dupes) with the key fields. If dupes are found in 

these ways that are actually not dupes, your key is not unique. In this case you must 

either change the affected records or the key so that the key is unique! 

In most cases you have to rely on a combination of 2 or more fields to uniquely identify a 

record. Good candidates for this are fields like firm, name, customer number and street. 

When selecting the key fields you should also make sure that the main and secondary 

databases do not vary in these fields, including how they are written. Otherwise, 

corresponding records will, of course, not be assigned correctly. 

A key made of the fields FIRM, NAME and TELEPHONE is risky, for example. The phone 

number is a good key field because it can uniquely identify a person well. However, 

telephone numbers change often. 

Example: You have chosen COMPANY, NAME and PHONE as key fields. With your 4000 

records you have one where the phone number has changed: Mr. Smith from combit 

GmbH now has the phone number 07731/906010 instead of 07731/906020. If you 

synchronize the database with the database of the headquarters, a new record for Mr. 
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Smith, combit GmbH, phone number 07731/906020 will be created, as the key fields 

differ. The record for Mr. Smith, combit GmbH, phone number 07731/906010 remains 

unchanged, as the synchronization on the basis of the key fields in the main -database 
has not found the same record in the source. 

With the "New" button you can add further key fields. The order is not important because 

all key fields must match regarding the number of characters specified in "Length". The 
wizard tries to find the fitting field in the secondary database as soon as a new key field 

is entered. 

Field assignments 

In the same way as when importing, the fields that are assigned must be defined for 

synchronization too, since the fields of the source file do not necessarily correspond to 

those in the target. The assignments between the fields in source and target can be 

made automatically or manually. 

The field assignments dialog here has one more column than that when importing: the 

synchronization rule. You can set the synchronization rule for every synchronization field. 

To do this, select the corresponding field from the list and select the synchronization 

rule. 

 

The following synchronization rules are available: 
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▪ Rule.SlaveDB_if_not_empty : If differences between the main and secondary 

database are found for the field, the contents in the secondary database 

automatically overwrite those in the main database. The only exception: if the field in 

the secondary database is empty, that of the main database is not cleared. 

▪ Rule.SlaveDB: If differences between the main and secondary database are found for 

the field, the contents in the secondary database automatically overwrite those in the 

main database. 

▪ Rule.MasterDB: No field changes (essentially a blank rule setting). 

▪ Rule.Additive : Changes found in the secondary database are automatically added to 

the field in the main database (appended). The contents of the target field will remain 

intact. The data can only be appended if there is still space in the target field. This 

option therefore is particularly useful for comment fields. In fields that are 

synchronized with this rule, you should avoid deleting or inserting new passages in 

the field – appending new text, however, is allowed! When synchronizing, both 

contents in the main and secondary databases are compared. From the first 

difference found (that would be the place where you deleted something) the 

contents of the secondary database are added to the main database so that all 

entries after such a modification would then be duplicated. 

▪ Rule.Prompt: When there are differences between the field contents you can decide 

in a dialog which contents to keep (and modify the result if necessary). 

▪ Rule.Prompt_if_not_emtpy: Same as "Rule .Prompt", except empty source fields are 

ignored. 

▪ Formula: You can also define formulas for the synchronization rules (this is the 

reason why Rule .MasterDB exists, if you were wondering) 

Example: "Rule.SlaveDB_if_not_empty" as formula 

"if(len(atrim$(COMPANY)) = 0, Rule.MasterDB, Rule.SlaveDB)" 

Example: Decision on the basis of field length, the longer field "overwrites" the 

shorter one. 

"if(len(atrim$(MasterDB.NOTE)) > len(atrim$(NOTE)), Rule.MasterDB, Rule.SlaveDB)"  

The data filter under the dialog refers to the data in the secondary database and so only 

the records that correspond to the filter conditions are synchronized. If the filter 

expression is empty, all records are synchronized. 

Note: If your main database contains relations based on RECORDID and GROUPID, 

these fields must be linked with a field of the same status otherwise you will be 
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shown a corresponding warning that hierarchical information is being lost in the 

import of new records. 

Select fields to be displayed 

In the following dialog you can select the fields that are to be displayed during this 

synchronization process, when the synchronization rule "Rule.Prompt" takes effect. These 

are shown to the user for orientation while synchronization is taking place. It is usually 

most sensible to select the key fields. To be able to keep an overview, about three fields 

are ideal. 

Inserting new records 

In the following dialog, you can decide whether records that exist in the secondary 

database but not in the main one should be transferred to the main database without 

query, or whether the transfer should be confirmed manually for each record. 

Synchronization type (only Outlook synchronization) 

The following dialog only appears for Outlook and allows you to set whether a full 

synchronization, i.e. an import with subsequent export, should be carried out. 

If you activate the option "Execution must be confirmed by user", the execution of an 

automatic synchronization must also be confirmed – this makes a statistic run possible 

(see later in this chapter). 

Field allocation for re-export (only Outlook synchronization) 

If the export was permitted in the previous dialog, the usual field allocation dialog 

appears, but this time the other way round: the secondary database has the target fields! 

Take particular note of the data filter: it works on the fields of the main database and 

describes which records are to be re-exported. 

Name allocation for the format 

Formatting set in the wizard can be saved and will then be available to run instantly under 

"User defined formats". In the following dialog you can set a name for it. If the template 

should not be saved, simply leave the name field empty. 

Templates are also useful if they only fit the involved databases approximately. Generally, 

it is less effort to adapt an existing template than to set all links again. 

The templates are saved in the respective application data directory, i.e. they can only be 

selected and run by the respective creator under "User defined formats" . Global 

templates can be found under "User defined formats > Global " . 
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Starting the synchronization and statistic run 

In the following dialog you are given a summary. If you confirm this, the synchronization 

will begin. You will reach this page directly if you select one of your own formats in "User 

defined formats" in the format selection (on the first page of the wizard) and click the 

"Execute" button. 

You can check the accuracy of your entries first with a statistic run. With the button 

"Statistic" you can test the synchronization before starting for real. As a result, you will 

receive a test report with the number of changes and differences. 

A statistic run is highly recommended for controlling the selected key. With the number 

of differences found you can consider whether the result is plausible for your databases. 

 

Database synchronization with manual selection 

If you have chosen manual selection as a synchronization rule for some of the fields 

(Rule .Prompt or Rule .Prompt_if_not_emtpy ), differences are displayed in a dialog. 

 Adjacent to the each field with the field contents from the main and secondary 

database you will find a button "-> Result". With this you can transfer the contents of 

the field to the "Result" field. As default, the contents from the main database are 
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taken. You can also edit the result here, i.e. make amendments, change or delete 

something. 

 Confirm the result with OK to continue the synchronization. "Cancel" ends the entire 

synchronization! 
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13. Configuration of projects 

A project is based on a database and a project directory with a project file (file extension 

crm) and view files (for every view there is an input file and an overview list file).  

13.1 General  
▪ To open a project, select F i le  > Open.  

▪ Select a project file (file extension .crm). 

▪ Open the solution center and select a reference project. 

▪ Project information is available to you as cRM project variables in the form of print 

templates, transfer form and input forms (more information can be found under 

"Using the formula editor" in the chapter "General configuration". 

▪ If you want to save a project under a different name, select F i le  > Save as. 

▪ To start a new project, select F i le  > New. 

▪ The structure of the database tables of the basic SQL database must correspond to 

the structure of the views. 

▪ Via F i le > Information > Reorganize , all of the configuration files belonging to the 

project are released from old, no long necessary entries. This accelerates the 

opening of the views. 

Please note: When replicating, the synchronization of the project configuration 

settings is not supported (e.g. activated code field entries, new code field entries, 

navigation structure, project filter). 

13.2 Separate data sets 

The cRM supports a mandatory oriented data storage that means you can manage 

multiple mandates, e.g. customers or company departments, without giving them an 

insight of each other's data. According to the requirements different scenarios are 

possible: 

1. Completely separated data 

▪ Separated solutions with shared database: Mandator assignment by field and 

access control by project and record rights. 

▪ Completely separated customer data by separared solutions with different 

tables in the same database. Lookup tables like "DirectionTypes" etc. can be 

shared. 

2. Shared customer data 
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▪ Separated solutions with shared database: Mandator assignment by field and 
access control by project and record rights. 

▪ A shared solution with shared database and every mandator only sees "his" 

customer data: A project with selection of the mandator after login. The 

selection of the mandator is done by dialog (Script with variable 

"cRM.Project.Session.Client"). This variable then can be used in the record 
rights. 

Example: Setting the variable via dialog in event "Project has been opened"  

sClient = InputBox("Please enter mandator name", "Mandant Login", "") 

cRM.CurrentProject.SetSessionProperty "Client", sClient 

3. Please note the following restrictions: 

▪ Record references (e.g. Appointments & Tasks, reference by e-mail etc.) only 

work if the cRM project where the reference has been created is open. 

▪ The call detection is always executed for the current project. 

▪ The desired project has to be defined in an eMail Autopilot script. 

▪ Only one project can be configured in eMailClient-Add-In and LDAP-Server. 

▪ If records of "other" mandators are hidden by using record rights, these records 

can't be "seen". 

13.3 Project Restore 

To restore a shipped project or to attach it to a new server, proceed as follows: 

1. You find zip archive with all necessary files in the project directory, e.g. Medium.zip 

for our sample project "Medium". Unzip it into the desired directory. 

2. Create a new and empty database by using a database configuration tool (e.g. 

Microsoft Management Studio or pgAdmin of PostgreSQL). To do so right-click on 

"Databases" in the Object Explorer of the SQL Server and select "New database" from 

the context menu. Enter a new name in the field "Database name" that is not used 

yet, e.g. "cRM_Medium". 

3. MS SQL: Open the SQL database file (e.g. cRM_Solution_Medium.sql) from the 

project directory. The first line contains the name of the new database, e.g. "USE 

cRM_Medium;" this line of course has match the name of database you just created, 

edit the name if necessary. Click "Execute" afterwards. 

PostgresQL: Right-click on the new database and select "Restore". Open the Backup 

database file (e.g. cRM_Solution_Medium.backup) from the project directory. Click 

"OK" afterwards. 
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13.4 Solution Distribution 

Using the cRM Project Distribution Assistant, you can distribute cRM projects (the SQL 

database, the cRM project file and the input form definitions). The application for project 

distribution (cRMShip6.exe) can be found in the cRM application directory or select File > 

Help > Tools > Solution Distribution. 

 Select Distribute project  to create a zip file (including the SQL database, the cRM 

project file and the input form definitions). To do this, enter the login data of the SQL 

server, the project file (file extension *.crm) and the name of the zip file in the 

subsequent dialog. 

 Select Restore project to save the selected project (zip file with project and database 

with file extension *.bak) in the desired directory and to attach the database to the 

database server. 

13.5 Copy Project 

Select F i le > Save As if you would like to save your project under a different name. The 

project file, input form definitions and column configurations will be saved in the selected 

directory. 

To copy the database you need a database configuration tool (e.g. Microsoft 

Management Studio or pgAdmin of PostgreSQL). 

 To copy an existing database you first have to create a backup file by right -clicking 

the desired database in the Object Explorer of MSSMS and select "Tasks > Backup" 

from the context menu. Check the options and start the creation of the backup file. 

 To restore a database under a new name right-click "Databases" in the MSSMS and 

select "Restore database" from the context menu. Enter a database name not yet 

used in the field "Into database", e.g. "combit_MyCompany". 

Attention! If the selected database name is already in use, the existing database 

will be replaced! 

 Select your backup under "From database" or "From media". Make sure that the 

checkbox "Restore" is activated. 

Note: You can also exchange data directly with the SQL Server import/export 

assistant of the SQL Server Management Studio. Expand "Databases", right-click a 

database, go to "Tasks" and click "Import data" or "Export data". With the assistant 

you can create target database and target tables as well. However if you have 

copy multiple databases, tables or other database objects, use the assistant for 

copying databases instead. 
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 To assign the copied database to the copied project afterwards, select F i le  > 

Information > Properties . 

 Please note: A new project ID is not created when selecting "Save As", that means 

that all rights and configuration settings made in the copied project still apply for this 

project. Changes automatically affect all other projects with this ID. If this isn't 

desired, you should create a new ID. 

 To create a new ID for the copied project proceed as follows: 

▪ Create a new project by F i le  > New. 

▪ Open the project configuration by F i le  > Information  > Properties. 

▪ Copy the project ID from the ID field. 

▪ Open the cRM project file (file extension *.crm in the project directory) with an 

editor and change the ID manually: 
<item name="ID">a6609731da5f4d168a537a6f8f0dec50</item> 

<item name="Name">Large</item> 

<item name="Description">Large, Version: 7.000</item> 

<item name="DBName">combit_Large</item> 

13.6 Create new Project 

To create a new project select F i le  > New. 

 Enter a name for the new project. It will be displayed in the title bar of the program 

window. 

 Select the SQL database in the "Project Settings" dialog. 

▪ To select a new and empty database, you have to create one before. To create 

one you need a database configuration tool (e.g. Microsoft SQL Server 

Management Studio or pgAdmin of PostgreSQL). To create a new database 

right-click on "Databases" in the Object Explorer of the SQL Server and select 

"New database" from the context menu. Enter a new name in the field "Database 

name" that is not used yet, e.g. "combit_MyCompany". 

▪ To copy an existing database you also need a database configuration tool. 

Further information about copying a database can be found in paragraph "Copy 

Project" in this chapter. 

 In the following dialog (MS SQL Server only) you can select how to proceed: 

▪ Predefine views automatically based on the existing structure of the database: 

For all existing database tables views are created and possible constraints are 

converted to relations. This function is of use if you transfer the database of 

another application. 
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▪ Transfer views from another project. Starts the assistant for the project import. 

See the next paragraph. 

▪ Create views manually. 

13.7 Project import 

Go to F i le > Information  > Project Import to import views, instant reports, filters, sort 

orders, input forms, events and so on from another project. Certain corrections might be 

necessary, e.g. creating relations in the linked views or several settings on the database 

server (constraints, special indices etc.). 

 

 Select the project file from which elements should be imported. 

 Select the elements that you would like to import by using the checkboxes in the left 

window. 

▪ You can collapse the views to select if certain configuration settings should be 
imported. 

▪ If a view is already present in your project, the following options are available: 

▪ Add new fields (also physically) to view, meaning that the table structure is 

extended. 

▪ Do not transfer view properties. 

▪ Do not transfer view at all. 
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▪ If you select a view with 1:N linked views, you can select these linked views 
automatically as well. 

13.8 Project properties 

The project configuration can be opened under F i le  > Information  > Properties.  

Properties 

Select the "Properties" tab for the database configuration. The project properties are 

generally saved in the combit Relationship Manager project file (file ending *.crm). 

 

▪ In the Database  field, select the database on which the project should be based. 

▪ In the Name field, the name of the project is set.  

▪ The ID of the project will be created automatically. 

▪ In the Description you can enter any information you feel is relevant. If you work with 

several projects, this is a way of telling the difference between them.  

▪ Create views of the user management: By clicking this button, database views that 

refer to the cRM user management are generated in the database Views that are 

based on these database views are also created in the current project. These views 

can only be used in read-only mode to define, for example, relationships of 

customers to cRM users or to print out users and their rights. On the database server 

side, you must have the right to generate database views on the database. 

Note: Under PostgreSQL, the database views have access to the combit system 

database via DBLINK. 
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Settings 

Select the "Settings" tab for further project configuration. 

▪ If the option Code description for print and export  is activated, the descriptions are 

output in clear text, such as "Christmas card" during printing and text export. If the 

option is not selected, the code number will be output instead of the description, for 

example "0010101". 

▪ In addition, here you can later set for which views contained in the project the Cal l  

detection  should be active. 

▪ In the section Document management system  (DMS) you have the option of 

managing the files of the document manager in cRM through a DMS. With this, the 

files are saved as references in a file archived in the DMS. Select the corresponding 

Document Management System. Requirements see " System Requirements". Further 

information regarding connection, see "Document management" in chapter 

"Configuration of views". 

 
 

▪ Info center: In the Info center field, you can set the path to a central info view, which 

serves as an information gateway.  

This can be an HTML page or an internet/intranet page. Enter the path with the 

formula editor, e.g. «cRM.Project.Path + "\InfoCenter\index.html"» or 

http://intranet.combit.net. With this, you have access to the user and project 

variables to display different pages depending on the field contents. 

http://intranet.combit.net/
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Access to the cRM application object occurs within a script using the 

windows.external object. You can now work with all cRM OLE objects as with 

normal scripts.  

Set ocRM = window.external 

Tip: To save information in the HTML view or to store it over several HTML pages, 

the methods SetUserProperty() and GetUserProperty() are available in the cRM 

project object. With these, values can be persistently stored and loaded. 

13.9 Navigation structure 

You can keep the views list organized by creating folders and copying views. The 

structure can be adapted freely and new hierarchies can be inserted through the context 

menu as required. The items can be arranged by drag & drop and named freely. Empty 

folders (due to missing rights for the contained views) won't be displayed. 

This arrangement is saved for all users for each project. The configuration occurs in a 

separate dialog. Select F i le > Information > Navigations Structure . Various buttons and 

functions in the context menu are available for the configuration of the list:  

 

▪ Create new folder: To create hierarchies, you 

can create folders. Enter a name for the folder 

and then press RETURN. 

▪ You can move the views and folder around the 

list by drag & drop. 

▪ Rename folder: Rename a folder. Views cannot 

be renamed. 

▪ Copy: Duplicate views and folders (including 

views). 

▪ Delete: Remove folders and views from the 

list. 

▪ Reset: All changes to the navigation view are 

reverted.  
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13.10 Company master data 

With F i le > Information > Company Master Data basic company master data can be 

stored, such as company name, company address, VAT-ID and logo. This information is 

made available as variables and can be placed in letters or mail merge templates, for 

example.  

13.11 Database structure 

The database structure can be defined with a database configuration tool or directly 

under F i le > Information > Database Structure . You can create, edit and delete tables 

and fields. The internal field type is then defined in the view configuration.  

Note: To change the database structure, the active user must have the corresponding 

rights. For further information regarding the database user, see also "Choosing a 

database connection" in chapter "Preparation and Installation".  

A database configuration tool (e.g. Enterprise Manager, MSDE Manager, pgAdmin) is 

only necessary for advanced functions, such as the definition of constraints, changes 

to primary keys or the rearrangement of the field order. 

Create Database table 

Select F i le > Information > Database Structure  to open the dialog for the configuration 

of the database structure.   

 

 Select the "New" button next to the database table  input field, to create a new 

database table on the database server.  

 Select the "Delete" button to remove a database table. 

Note: If a database table is created directly using a database configuration tool, it is 

necessary to restart cRM so that the table can be selected in the view configuration. 

Database fields 

Select F i le > Information > Database Structure  to open the dialog for the configuration 

of the database structure. Alternatively, open this dialog for a specific database table by 



Configuration of projects 

182 

right-clicking on the corresponding view and selecting Table  structure  in the context 

menu. 

 

 In the F ie lds table, select the "New" button to create a new field. 

 With the "Delete " button, you can remove fields from the database table.  

 Click in a field to edit the field properties.  

▪ The Field name can be used to refer to and identify a field. A field name can only 
be given once per table.  

Note: Physical field names in tables may only contain alphanumerical 

characters, i.e. 'a'...'z', 'A'...'Z', '0'...'9', umlauts and '_'. Numbers may not be the 

first character.  

▪ The SQL Field type sets what type of data is allowed to be saved in the field. 

The exact meaning of each data type can be found in the documentation of your 
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database system. A description of the most important data types can be found 
under "Data types" in chapter "Appendix". 

▪ The Field size (if available) sets the maximum number of characters that can be 

saved in the field. 

▪ For numerical fields, the Precision property sets the maximum number of 

significant figures and Decimals sets the maximum number of decimal places.  

Example: The number 123,45 has the precision 5 and 2 decimals. 

▪ NULL values allowed: If this option is activated, a field does not require input. 

Please note that you can only deactivate this option if there are no NULL values 

entered in this field yet.  

▪ Key field: Only one (primary) key field can be defined in each table. The option 

can only be applied to a field if no key field has been defined in the table yet. To 

change an existing key field, you need a database configuration tool (e.g. 
Microsoft SQL Management Studio, pgAdmin). 

Note: Create a primary key field for every table. We recommend the field type 

"uniqueidentifier" (MSSQL) or "Character" of length 36 (PostgreSQL). In the view 

configuration, give this field the type "Record ID". 

Unicode 

To be able to store UNICODE characters in cRM fields, it is mandatory when using the 

Microsoft SQL Server that the character fields in the database are of type nchar, nvarchar 

or ntext. Otherwise the database server possibly converts characters that can't be 

displayed with the standard codepage of the database silently into other characters that 

can be displayed, which can lead to unwanted results. Possibly not all Windows fonts 

can display all UNICODE characters, so the corresponding "Windows Language Packs" 

must be installed to extend the standard fonts by the characters in the particular 

language.  

When records are output as PDF then the "Font embedding" option should be set to "Use 

CID fonts" in the PDF output media properties and stored permanently to the print 

template. This will possibly lead to larger PDF file sizes, however ensures that possible 

special characters can also be displayed correctly in the PDF. This setting is the default 

for all new print templates. 
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14. Configuration of views 

A view is how you "look at" a database table or a database view. The fields contained 

within can be assigned extended functionalities. Views can be relationally linked. The list 

view, input form view and web view are different ways of displaying the data of a view. 

 To create a new view, right-click in the navigation and select "New", select F i le  > 

Information > Create New View  or copy an existing view. To copy a view, right-click 

the corresponding view in the navigation and select "Copy" from the context menu. 

 Save changes to views with F i le  > Save . 

 With Delete  in the context-menu you can remove views. Existing relations become 

invalid.  

14.1 View Configuration 

Every view has its own configuration dialog in which the following settings can be 

changed: 

▪ Set field type internally 

▪ Define relations 

▪ Define codes of the list fields 

▪ Activate and configure dupe check 

▪ Configure function definitions for buttons 

▪ Automatic number allocation (automatic counters) 

▪ Activate and configure auto logs 

▪ Set up document management 

▪ Configure record references 

▪ General settings for display, web view and history 

To open the dialog for the view configuration, right-click on the corresponding view in the 

navigation and select "Properties" in the context menu. 

14.2 View name and Database table/view 

In the view configuration dialog that opens, set a name that is unique within the project 

for this view. The maximum length is 30 characters. Only alphanumeric characters, i.e. 

'a'...'z', 'A'...'Z', '0'...'9', umlauts and '_' can be used in view names. Numbers cannot start the 

name. 
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Then select the database table or database view, which is to serve as the basis for the 

view. Views can also be assigned a symbol, which will be shown in the navigation and in 

the tabs. 

 

Further information of defining a database table can be found under "Database structure" 

in chapter "Configuration of projects". 

Note: If a database table is created directly through a database configuration tool, 

cRM must be restarted before this table can be selected in the view configuration. 

14.3 Fields 

Under the "F ields" tab, all available fields for this view are listed. Here you have the ability 

to set the F ie ld al ias and the Internal  f ie ld type . 
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Create New, Change and Delete Fields 

By using the corresponding buttons you can open the dialog for editing the database 

structure. 

 Select the button New above the table F ie lds to create a new field. 

 With Delete  you can remove fields from the database table. 

 Click into a field to edit the field properties. 

Further information can be found under "Database structure" in the chapter "Configuration 

of projects". 

Field alias 

For each field, a field alias can be issued so the name displayed in the user interface and 

in the dialogs can be differentiated from physical field names.  

This is particularly practical with an international, jointly used database if the physical field 

name e.g. has been defined in English. Then a German field alias can be entered in the 

view configuration of the German project. Additional information on the language of the 

user interface can be found in chapter "General configuration". 

By clicking on the button "Set all field aliases to the respective field names ", you can set 

all field aliases to the respective field names, delete all field aliases or import/export them 

in one step. 

Internal field type 

Every field type has special properties that, for example, decide the contents of the 

context menu. They should therefore be defined appropriately. After the selection of the 

field and a double-click in the column "Internal Type", the selection list opens. Choose the 

required type there. 

The most important field types: 

▪ Character: Any character string that can contains letters, numbers and special 

characters. If the contents are simple text entries or numbers where the sort order 

and comparison operations are unimportant, e.g. if none of the other field types 

apply. 

▪ Numeric: If the contents are just numbers, which should be treated as numbers in 

sort orders or comparison operations. 

▪ Date: If the contents are pure date values to be used in sort orders or comparison 

operations. They are marked with a calendar button in the input form. A click with the 

left mouse button opens a calendar, a click with the right inserts today’s date. 
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▪ DateTime: If the contents are just dates and times, that are to be used in sort orders 

or comparison operations, e.g. so-called "time stamp". 

▪ Characters long: If the contents are detailed notes, unstructured contact protocols or 

other comments. Any character strings that can contain letters, numbers and special 

characters.  

▪ Code: Code attributes, i.e. deposited criteria or so-called "Keywords" that can be 

prearranged for a record for classification. 999 characters max. length. For fields that 

are larger, code is not offered as a field type. 

▪ Picture: If the contents are graphics that are to be displayed or printed in cRM. 

Supported image formats: JPG, PCD, WMF, BMP, DIB, RLE, PCX, TIF. Content is 

Path and file name of a graphics file. 

▪  Embedded Picture: Any image files, e.g. pictures, charts can be stored directly in 

the database system and can be displayed in the input form automatically. 

▪ Telephone: Same as Character. Telephone fields allow automatic phone dialing. 

▪  Mobile Phone: Same as Character. MobilePhone fields allow automatic phone 

dialing and the sending of SMS messages. 

▪ Country: Same as Character. Allows the display of country flags in the list view when 

using the two-character country codes of ISO 3166 (ALPHA-2). A list of country codes 

is available here: http://www.iso.org/iso/en/prods-services/iso3166ma/02iso-3166-

code-lists/index.html. 

Country flags are also displayed when using the IATA country codes, the 

international car country codes and the internationally written country names. 

In the input form, the written name can be displayed in a static field with the 

«GetInfoFromCountry(Land)» formula 

▪ Auto Number: Same as Character. Allows the automatic allocation of consecutive 

numbers.  

▪ E-mai l: Same as Character, but also allows the automatic transfer of e-mail 

addresses. 

▪ Internet: Same as Character, but allows navigation to internet addresses.  

▪ Boolean: Checkboxes with only the states TRUE/FALSE.  

▪ Fi le  L ink: Same as Character. Allows the automatic and manual allocation of 

documents. These are saved as references to the original file in the file system. 

Note: physical field length must be able to accommodate path and file name! 

▪ Embedded F i le: Any (binary) files, e.g. documents, pictures, charts can be stored 

directly in the database system.  

http://www.iso.org/iso/en/prods-services/iso3166ma/02iso-3166-code-lists/index.html
http://www.iso.org/iso/en/prods-services/iso3166ma/02iso-3166-code-lists/index.html
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▪ DMS Document: Same as Character. Allows the automatic and manual allocation of 

documents that are saved in a supported document management system (DMS). 

These are then saved as references to the DMS. 

▪ Document Reference (FM): Same as Character. Allows the intake of references to 

combit factura manager documents. Supports the opening of these documents by 

double-click in the browse view and container. The references must have the format 

"fmw://<Account Name>/<Document Type>/<Document No>", permitted values 

for <Document Type> are "AN", "AU", "RE", "LI" or "BE" (Quotation, Contract, Invoice, 

Delivery receipt, Order). 

▪ Creation User: cRM user that created the record. cRM user names can be up to 20 

characters. This should be respected when setting the field length. 

▪ Modification User: cRM user that last made changes to the record. cRM user names 

can be up to 20 characters. This should be respected when setting the field length. 

▪ Creation Date: Date on which the record was made. Set automatically by cRM. 

▪ Modification Date: Date on which changes were last made to the record. Set 

automatically by cRM. 

▪ Record ID: This is a globally unique ID. This field type should be allocated in every 

view! A new record can otherwise not be displayed after the first save because it 

cannot be found in the table/view. This can only be allocated once within  a view and 

typically also serves as primary key field. The contents are set automatically by cRM 

(not the database system). To use record references or to undertake a Windows CR 

synchronization, this field type is essential. 

Tip: To optimize operating speed, use explicit indexes from your database system for 

the primary key field (more information can be found in the chapter "Optimization of 

the " in the appendix and in the documentation of your database system). 

▪ Globally Unique ID: This is a field that can store a globally unique ID. This field type 

can be assigned more than once in a view and generally serves as foreign key in 

relations. The content is neither set by cRM, nor the database system. 

Tip: To optimize operating speed, use explicit indexes from your database system for 

the foreign key field (more information can be found in the chapter "Optimization of 

the " in the appendix). 
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14.4 Relations 

Relations are connections between two views. These relations can be defined in the 

configuration dialog of both view properties. With this, you can create any structure or 

connection you require. For example, you can assign a company different contacts.  

Defining relations 

Define relations in the Relations tab. In the input designer, the buttons "Select record" 

and "Go to" are available for 1:1 relations as well as the corresponding containers to 

display the connected records for 1:N relations.  

When designing the database, consider that the cRM can resolve up to 2 relation 

levels. If you therefore define multiple nested 1:N relations, e.g. in the form Projects > 

Facilities > ElectricMeter > MeterReading, you can't access a field (e.g. 

"ProjectNumber") of the view "Projects" from the view "MeterReading". Only a field of 

the view "Facilities" would be accessible. If you would like to display the project 

number in the view "MeterReading" you can implement that with e.g. views, triggers or 

continuous links and field presets in the input form. 

Please note the information found under "Optimization of the operating speed" in the 

"Appendix". 
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 With the "New" button, you can create a new relation.  

 By clicking in the F ie ld name column, first select the link field of the current view.  

▪ With a 1:1 relation, usually, select the foreign key field (internal field type "Global 

unique ID"). Takes the primary key of another record. 

▪ With a 1:N relation, usually, select the primary key fie ld (internal field type 

"Record ID"). The content is set automatically by cRM. 

 Then select the Relation type. The following relations are supported: 

▪ Relation 1:1: unique assignment of two records. 

 

Example: Every activity is allocated one contact. Assign the foreign key field of 

the Activities view (ContactID) with the primary field of the contacts view (ID). 

▪ Relation 1:N: Different records can be assigned to a record. 

 

Example: Several activities are assigned to the contact. Assign the primary field 

of the contacts view (ID) with the foreign key field of the Activities view 

(ContactID). 

▪ Relation N:M: A person is assigned to a project, and several other people are 

assigned to the project at the same time.  

 

Example: A person is assigned to a project, and several other people are 

assigned to the project at the same time. In this case you need a "link view", 

which in this case is called "ProjectAssignment". 

 Select the target view. 

 Select the corresponding link field of the target view.  

Contacts Activities

1:1

ID 

(Record ID)
ID 

(Record ID)

ContactID

(Global Unique ID)

Contacts Activities

ID 

(Record ID)
ID 

(Record ID)

ContactID

(Global Unique ID)

1:N

Contacts ProjectAssignment

1:N (N:M)

1:1
1:1

ID 

(Record ID)

ID 

(Record ID)

ContactID

(Global Unique ID)

ProjectID

(Global Unique ID)

ID 

(Record ID)

Projects

(N:M)

1:N (N:M)
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Important! Only fields of the same physical data type and same size can be 

linked. This applies generally to all relation types. 

▪ With a 1:1 relation, usually, select the primary key field (internal field type 
"Record ID"). The content are set automatically by cRM. 

▪ With a 1:N relation, usually, select the foreign key field (internal field type 

"Globally unique ID"). Takes the primary key of another record. 

 An alias name can be set for every relation. This relation alias is used in many 

dialogs, e.g. in the "Filter General" as the name for the relation.  

 Place the objects in the Input Form Designer: 

▪ So that the 1:N-linked records can be displayed, place a container in the input 

form. 

▪ In 1:1-relations the records can be linked with buttons of the type "Select 

Relational Record" and "Goto record" in the input form. Set the parameter for the 

link in the properties. 

▪ So that the field contents of a 1:1-linked record (e.g. name, surname) can be 

displayed, you can create a "fixed text" field in the input form of the "Contacts" 

view. 

Tip: In fields of 1:1 relationally linked views you have the option of placing an input 

field rather than a text field in the form. In the view, however, nothing can be 

entered into this field. The placing of an input field has the advantage that it has a 

context menu (as opposed to the text field). If, for example, you wished to display a 

telephone number from another view in such a field, the menu command "Dial" 

would be available to you. 

Cascaded deleting and updating 

This plays a role if you have linked data, such as addresses and contacts. If an address is 

deleted, the contacts associated with this address should usually also be deleted. 

Cascaded updating is necessary if, for example, the ID of a contact type is changed in the 

"ContactTypes" view. This ID should of course be changed in all relationally referenced 

contact items of the view "Contacts". 

For cascaded deleting and updating to be carried out, you need SQL constraints. 

Constraints must be defined for the relations between tables through the database 

system. Detailed information can be found in your database system’s documentation. 
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14.5 Defining codes 

On the Codes tab, set the different attributes for a previously defined code field.  

 

If, for example, you have set in the field types that the field "Category" should be a code 

field, then you must enter the different marketing-categories here that you want available 

in the input form later. 

 Select the Code field. 

 Click any row to enter the desired text. 

Tip: If you have a code field that contains different groups of codes, it is 

recommendable to leave a few numbers free between the groups. For example, enter 

codes for products from 1-6 and enter the status of the customer from 16-24. Leave 

plenty of numbers free after these codes too as a reserve. 

 

14.6 Dupe check 

On the Dupes tab, you set the comparison fields for the dupe check and can activate the 

onl ine dupe check for the corresponding view. 
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Note: A record is only recognized as a dupe when the contents of all fields of the dupe 

configuration match (Exception: The option "Ignore if empty" for the online dupe 

check). 

 With the "New" button you will start a new row. First select the desired F ie ld to 

check, for example "Name". 

 Set the field length up to which the check for equality should run. For fields with 

physical type "Characters long" at most the first 250 characters can be considered. 

 Set whether the dupe check should also be carried out phonetic. This option allows a 

check based on the sound of a word. This can be useful for fields such as "Name". 

 With ignore if empty you can set whether this field should specifically be ignored if it 

is empty. This option is only relevant for the online dupe check, not for the dupe filter 

under F i l ter > Dupe  Check. 

When the option Activate online dupe check for this view is activated, a check is 
undertaken when new data is being entered for whether the record is already in the 

database.  
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14.7 Function definitions 

Here you can assign certain variable names to programs, transfer templates, print 

templates and e-mail templates. With these variable names you can then create links 

with buttons you define. In this way you can simplify many everyday work sequences and 

save lots of time. 

Example: When printing labels, you sure often use the same templates. Thanks to 

function definitions, you can avoid calling the dialog and the selection of the desired print 

template. Instead, you reduce this cycle with a keyboard-macro to a single mouse click or 

keystroke. 

Or just imagine you often transfer single addresses  as well in fax forms as in letters or 

documents. Before executing the transfer, you would have to activate the adequate 

transfer template every time. With the help of the function definitions you define a 

transfer template for this purpose, which you then can activate directly through a toolbar 
button or a function button. 

 In the selection box, select which kind of function definition you wish to set – the 

allocation of a single print template, an e-mail template, a program or a transfer 

template.  

 By clicking the desired row and the "Open" button, you open the selection dialog for 

the required file. Now enter the path and name of the form, template or program. 

 To connect an assigned function with a button, go into the input form designer. 

Further information can be found in the corresponding chapter. 

14.8 Automatic numbering 

Under the Auto No. tab you can precisely define the automatic assignment of a 

consecutive number, such as a customer number. When creating a new record, this 

number is automatically entered into a certain field. 

Global and view specific counter configuration 

Global counters are available in cRM. These are numeric values which are incremented 

from the given initial value by the indicated increment. These counters are not view 

specific, which enables a common customer counter to be used in different views (e.g. if 

prospective customers and customers are divided into different views, but share the 

same customer number range). 

Within a view you can use these global counters in formulas wherever you want to 

display the customer number or e.g. also in letter templates. Use the formula editor to 

create such formulas. Example: P«Cstr$(counter,"%.0f")» 
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This results in the (numeric global) counter value preceded by a "P" . Since the counter 

value is numeric, its value has to be converted to a string before concatenation (Cstr$). In 

a (fictitious) view "prospective customers" the customer number could begin with a "P" 

(=prospective customer), in a (fictitious) view "customer" with a "C" (=customer). 

Configuring a global counter 

This counter can be used in different views. 

 Select F i le  > Information  > Auto Counter.  

 
 

 In the dialog "Automatic counter settings" you can create a new global counter using 

the "New" button. Enter a name, starting value, current value and step size of the 

counter (increment).  

With the step size, you define which number is to be given next in each case. In the 

case of a customer number, the step change "1" is usual, so after 1000 would come 

1001. 

 Within a view, these global counters can now be recalled. 

Creating view-specific automatic counters 

The view-specific numbers are configured on the "Auto No." tab of the view configuration. 

 All fields of internal field type "Auto number" are automatically available in the "Field 

Name" column. 

 At the appropriate field name, click in the "Counter" column and select the global 

counter. If no global counter has been defined, you can reach the configuration 

dialog of the global counters directly with the "Edit counter settings" button (see 

above). 

 If required, you can also define a new formula for this with the formula-button. The 

formula editor will provide assistance. Further information regarding the formula 

wizard can be found in the List & Label Designer documentation. 
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From now on, the customer number is automatically entered in the input form for every 

new record. If you create a new record but then cancel the process (and don’t save), the 

customer number that was generated is not assigned to the next record, but is 

effectively missed out. If you do not want to assign a customer number to a record, you 

can delete it from the field. That number will also not be re-assigned, but missed out. 

In addition, there is the option of setting up a script for the allocation on a customer 

number. With this, the generation of the number could be semi-automatic, for example, 

so that you can decide for each record whether it gets a customer number or not. 

Necessary rights assignment 

To increment the counter for the "Automatic Number" field type, a stored procedure with 

the name "cmbt_sp_increment_counter" (MS SQL) or "cmbt_sp_increment_counter_pg" 

(PostgreSQL) is used.  

MS SQL only: The cRM database user requires EXEC rights to access this stored 

procedure. This has already been done through the installation program in the reference 

project. Afterwards, this can be done through the query analyzer by running 

 use <database name> 

 go 
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 grant EXECUTE on cmbt_sp_increment_counter to "<cRMUser>" 

 go 

If the stored procedure is not available, the incrementation occurs on the client’s side 

(where it can very occasionally occur that a number is created twice). The stored 

procedure is – if not available – installed when creating a new automatic counter (F i le  > 

Information > Auto Counter). For this, CREATE PROCEDURE rights for the active cRM 

user are required!  

14.9 Auto log 

With this function you can automatically log a variety of processes. Available are the 

transfer of a record to another application, print, e-mail, saving, export, enrichment, 

appointment and call processes. 

 With the "New" button, you create a new auto-protocol.  

 Click in the "Action" column to select the process to be logged. The actions Data 

transfer, Print, E-mail, Save, Export, Enrich, Appointment and Phone call are 

available. 

▪ An auto log is only executed for output on printer, PDF, RTF, XPS and TTY. 

Printing e.g. on the preview therefore does not execute an auto log. 

▪ The multiple print of a list also does not execute an auto log due to the lack of 

personalization. 

▪ When printing/exporting multiple times within the report view the auto log is 

only executed once. 

▪ No auto logs are executed for detail reports of a Drilldown report. Only for the 

main report. 

 In the column "Target View", select in which view the entry is to be made.  

Note: If you select a different view from the current one, a new record is always 

created in this view (e.g. a contact entry in the "Contacts" view). 

 To activate the auto log, activate the checkbox "Active ". 

 If you also activate "Prompt", you have the option of deciding from situation to 

situation, whether an entry is made. After completing the corresponding activity you 

will be asked whether it should be logged. 

If you have activated the auto log for the sending of e-mails, you should deactivate 

the "Prompt" option before sending multiple e-mails. Otherwise you will have to 

confirm every single e-mail. 
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 In the "F ields" area you set which log entry should be made in which field. The fields 

of the target view are available to choose from. 

Tip: if you select the target view "Contacts" in the included reference project, the log 

fields "Direction" and "Type" are available. These fields are relationally linked with the 

views "DirectionTypes" and "ContactTypes". The meanings of the field contents 

should therefore be taken from the corresponding views (e.g. Type 2 = e-mail). 

 In the "Formula" column you can set the auto log text. With formulas you have 

access to data fields and additional information that can also be used for the entry. 

With the "Formula" button a wizard will open to provide assistance. 

If the formula returns an empty string ("") as a result during auto-protocol, the 

corresponding field will not be written. 

 Depending on the action, specific action variables are available: 

▪ e-mail, print, export: <Action.Template> returns the description of the 
template. 

▪ Transfer: <Action.Template> returns the description of the transfer template. 

▪ Phone call: number of attempted calls, date, duration, first info, info, last info, 

note, number, status. The <Action.Status> variable has the following values 
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and associated meanings: 3 = "Phone call unsuccessful, engaged", 5 = "Phone 
call unsuccessful, hung up", 6 = "Phone call unsuccessful, call not accepted" 

8 = "Phone call unsuccessful, other error", otherwise: "Phone call successful". 

14.10 Document management 

With the document management, you can assign any number of documents to a record, 

which are then displayed in a container with information such as author, contents, etc. 

When creating documents, you can use document templates. 

In the configuration of the document management, you can set how documents are 

saved (field type, save directory, file name), which document templates are available for 

new documents and which field contents are to be transferred into new documents. 

▪ The configuration of the document management is only worthwhile in views where 

documents are stored. 

▪ In the view in which the documents are to be stored, a field of type F i le  L ink, 

Embedded F i le  or DMS Document must be present. 

▪ In the Document Management  tab, different document types can be defined. 

Document types are templates upon which newly created documents are based.  

Type of document storage (field types) 

To be able to use the document management, create a document field under "Fields" in 

the view configuration. Consider in advance how the documents in the document 

management are to be stored. You have 3 options: 

▪ Fi le  L ink: In the document management, only references to files should be saved, 

not the files (documents) themselves. For this, create a field with the field type "File 

Link". The Physical Field type is character (e.g. varchar, field length 255). 

▪ Embedded F i le : The files should be embedded directly into the database. With this, 

you not only simplify replication and data backups, but also enable full text indexing 

through the database system. With this, the document contents can be accessed 

directly by SQL query. For this, create a field of type "Embedded File". The Physical 

Field type is binary long (e.g. image, bytea). 

▪ DMS Document: References to documents should be archived in a document 

management system (DMS). Working with DMS documents is the same as previous 

file references. As opposed to normal file references, these references point to the 

document archived in the DMS. Select the internal field type "DMS Dokument" for the 

document field. The Physical Field type is character (e.g. varchar, field length 255). 

Configure the field links for the document information (see below). Select the DMS in 

the project settings. Further information can be found under "Settings" in chapter 

"Configuration of projects". In the user management, set the user-specific DMS log-in 
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information. Further information can be found in chapter "User and rights 

management". 

Note! If you configure several document fields, the priority sequence is "DMS 

document" - > "Embedded File" > "File Link". The mixed use of several fields can lead 

to problems, in particular with the file path. It is only one reference field possible (File 

Link or DMS Document). 

Connect a DMS (Document Management System) 

If the files are managed in a document management system (DMS), the following 

settings are required: 

1. Select DMS: Select the DMS for the active project in the project settings under 'File 

> Information > Properties > Settings > Document Management System'. For 

information on the supported DMS, see the chapter "Preparation and Installation". 

2. Deposit DMS login information: Enter the login information (username and 

password) for the selected DMS in the project settings under "File > Options > DMS 

Login" for the currently logged in user. You can also set the login information directly 

in the user administration. For more information, see the chapter "User and rights 

management" 

3. Define a field of type 'DMS Document': Open the view configuration of the 

document view (e.g. 'Activities') and switch to the tab 'Fields'. Select a field from the 

external field type "Character" and define the internal field type "DMS Document". In 

this field the path of the archive is stored, so a field size of at least 255 should be 

defined for this field. 

4. Configure document info: The document information contained in documents such 

as modification date, title or subject can be viewed in the input form. For this, you 

must have defined the appropriate fields in your view, to be able to store this 

information. On the tab "Document Info" in the view configuration, you can define the 

link between document property and field (see the section "Document information"). 

5. Specify the archive path: On the tab "Document Management" in the view 

configuration you define the desired archive path in the DMS in the fie ld "File Path" 

for each document type (see the following section). 

6. Defined indexing: For certain DMS indexing is available. In the tab "Document 

Management" in the view properties you can define the available fields for every 

document type by using the button "DMS Indexing" (if supported). For information on 

the supported DMS, see the chapter "Preparation and Installation". 
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Create document type 

Changing settings for the document management is only worthwhile in views in which 

documents are to be stored. 

Consider a few points regarding the document management first, for example which 

documents you want to save under which path or what templates you want to use for 

new documents. Which information should be transferred to a new document, etc. 

Also note that a document type is set not only by the file type, but also by its use. DOC 

files, for example, can be used for letters as well as faxes. Since settings for these are 

still different, it makes sense to make two different document types for letters and faxes. 

 Click on "New" to make settings for a new document type. Give the document type a 

Description . This name is displayed in a selection dialog when creating new 

documents. 

 

 Now set the File Extension, such as DOCX, XLSX or MSG.  

Tip: Create an "Other documents" document type with file ending "*" so that all 

documents with any file name can be stored.  

 In Template  select the file template using the folder button. In this document 

template are contained, for example, company logo, return address details etc. 
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Further information regarding file templates and bookmarks can be found under 

"Configuring transfer templates" in chapter "General configuration". 

 In Path select the location where the documents are to be saved using the folder 

button.  

▪ With embedded files, the Archive path does not apply. 

▪ With DMS documents the storage archive is set here. 

▪ If the save directory does not exist, it is created. With this, a hierarchical storage 

structure can be created using a save directory formula, e.g. so that all 

documents are saved in the directory with the relevant customer number of the 
record. 

 In the next field, enter the path of the Transfer template if required. You need this if 

information from fields of the view is to be transferred directly into the document, 

e.g. address, name, scanned-in signature, etc. 

Note: The transfer form may not contain any additional document templates, 

because the document template is already set in the Template-field! 

Further information about transfer forms can be found under "Configuring transfer 

templates" in chapter "General configuration". 

 In the field "f i le name" you can now assign a formula for the automatic allocation of a 

file name when creating a new document. With the help of the formula wizard you 

can define these rules. With the arrow button you can set the default. 

The variable "ParentRecordDescription" is used in the default settings. It contains the 

evaluated file reference subject formula to the active record of the currently active 

parent view. The parent view is the view from which a new document is created 

through a container (e.g. "Peoples"). 

Since the document container can be available in several different views (e.g. 

"Peoples" and "Firms") and when configuring the formula it is important to make sure 

that the fields used are available in all parent views, a meaningful name can be 

created with this variable. 

 If you wish to change something later, select the document type in the list. You can 

now make changes, delete the document type or change the sequence using the 

arrows. 

 When adding a document, a new record is always created. With the option Open 

record for editing when adding document you can set by field-type F i le Link whether 

this record should be opened, or whether the record should be created silently in the 

background. 
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 If you activate the option Create new file without user interaction , the file is saved 

directly in the defined folder and is opened for editing. If you wish to manually select 

the save location of a new file when it is created, deactivate this option. 

 You also define the field defaults of the new record in the Archive view by clicking on 

the corresponding button. 

 

In the "Fields" area, you specify which entry is to be made in which field. The 

respective fields of the target view are available for this. You specify the auto-text in 

the "Formula" column. Formulas give you access to data fields and additional 

information, which could also be used for the entry. By clicking the "Formula editor" 

button, you get help from a wizard.  

For the direction of the document a specific message variable "Action.Direction" are 

available: ""=unknown, 1=incoming, 2=outgoing. 

Tip: In the included reference project, the fields "Direction" and "Type" are relationally 

linked with the views "DirectionTypes" and "ContactTypes". The meanings of the field 

contents should therefore be taken from the corresponding views (e.g. Type 2 = 

e-mail). 

Automatic e-mail archiving 

You have the option of activating the automatic archiving of e -mails. All e-mails that are 

send directly through cRM are then automatically archived in the document 

management. 

Requirements: 

 In the view from which you send your e-mails, in the view configuration under the 

"General " tab, select the target view for the automatic e-mail storage, e.g. the 

"Documents" view.   
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 In the view in which the documents are stored, in the view configuration under the 

"Document Management" tab, a document type with the extension "eml" must be 

defined. 

See also "Archiving messages from eMail-Client" in chapter "Activities and Document 

management". 

14.11 Document information 

You can link the document information (title, author, etc.) with database fields in the 

"Document Info " tab.  

▪ Linking of file type or file name is mandatory with the "Embedded file" field type. 

▪ The document information is automatically read and stored in the appropriate fields 

when the file is embedded. With this, you also have the option of filtering these 

fields. 

▪ With the F i le  Reference  field type, the document information is automatically read 

and displayed, so no links are necessary.  
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14.12 Record reference 

With a record reference, it is possible to navigate directly to a certain record. There are 

various ways of using this function. 

 

General 

▪ Using Start > Reference > Send to  send a record reference to another cRM user by 

e-mail. The recipient must only double-click the reference and the corresponding 

view and record are loaded immediately.  

▪ If you wish to create a reference for your own use, you can save it under Start > 

Reference > Save as or Copy to Cl ipboard. 

▪ In the "History" window, references to the most recently viewed and edited records 

are recorded.  

▪ In the "Favorites" window of the navigation, references to commonly used records 

can be saved.  

To make settings for record references, select the corresponding tab and do the 

following: 

 Set the F i lename, if necessary with the help of the formula editor. For this, you have 

access to the formula editor and the default settings. 

 Create a Comment/Subject. For this, you have access to the formula editor. 
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▪ If you send a reference by e-mail with Start > Reference > Send to  this entry 
will be used in the subject line. 

▪ This entry is displayed in the "Record" column in the History.  

 

Linking to appointments & tasks and phone calls (phone manager) 

With the formula editor, you can set here which contents are displayed in the fields 

"With", "Subject" or "Info" when creating an appointment, a task or launching a phone call 

via the phone manager. 

14.13 General 

On the General  tab, various functions are available to you. 

▪ Adjust the size of the Input form: 

▪ Resize window to size of input form: In this case the window size is fitted to the 

size of the input form. 

▪ Resize input form to size  of window: This option has the effect that the input 

form is always adjusted to the window size you give. That means even if you 

make the window smaller, you will always have the entire input area visible. 

▪ No Scal ing: The input form always appears in the size set in the input form 

designer. 

▪ Select the Color of the tab. To make the interface more clear, different colors can be 

assigned to the Tab of each view. Clicking the row, you can select the color or type 

directly the RGB-format. 

▪ E-mai l: You have the option of letting sent e-mails be stored in the document 

management. Further information can be found under "Automatic e-mail archiving" in 

chapter " Configuration of views". 

▪ Webview: For every view you can store a web page or own HTML page. The display 

will take place with View > Web. Enter the URL of the web page (e.g. 

www.combit.net or <cRM.Project.Path>\webview\index.htm) or use the formulas to 

display different pages depending on the record.  

Note: The websites will be displayed in an Internet Explorer control. It internally 

runs in the com-patibility resulting in possible differences/restrictions especially 

with displaying CSS compared to the standalone Internet Explorer application. 

▪ Report View: You can define a default report for each view. To display choose View> 

report. Define the report template and choose the data (current record or the active 

filter). 
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▪ Record Watch: This option allows users to watch records. When changes are made 

to this record by another user (or in relational connections as long as this option was 

activated), you will be informed about it in the navigation view under "Watch results". 

You can specify whether this also relational field changes to be monitored. For more 

information, see "Watch record" in chapter "Entering and editing data". 

▪ Activate H istory: The most recently viewed or edited records are displayed 

specifically to the user in the history. A history log can be activated here. Further 

information can be found under "Configure history" in chapter "General configuration".  

▪ You can also set a "Family name". You need this to connect certain views as a group. 

The maximum length is 30 characters. 

Example: You send a reference to a record of the view "Addresses_Management" to 

a colleague. This colleague however can't open this view as he doesn't have access, 

but he could open another view, the view "Addresses_Normal", which indeed differs, 

however contains the same records. If these views were assigned to the same 

family, the cRM will automatically open this view from the same family for your 

colleague. 
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15. General configuration 

In the following section you will be given an overview of further general configuration 

possibilities and the creation of transfer templates. 

15.1 Settings for the program start 

Select F i le  > Options > General  > Settings. 

 

▪ Start combit H ints: The combit tip wizard provides context-sensitive information in 

the notification area of the task bar through a pop-up window. Further information 

can be found under "Sources of help" in chapter "Getting started".  

▪ Start combit address pick-up: With this function, you can transfer an address straight 

from the clipboard and let the data be entered into the relevant fields of a new 

record. Further information can be found under " 

▪ Data entry with address pick-up" in chapter "Entering and editing data".  

▪ Synchronize clock with database server : This function requires the corresponding 

Windows user rights. 

▪ Restore last opened views: Opening the last views can be prevented to speed up the 

program start. 

▪ Open info center at start : This option opens the info center when the program is 

started. 

▪ Check for new version : Requires internet connection. 
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15.2 User Interface 

Select F i le  > Options > General  > User Interface . 

 

▪ Language: Select the language of the user interface. By doing so, the user interface 

(e.g. menu items, dialogs, messages, manuals, online helps etc.) is completely 

localized. The provided standard solution is available both in English and in German 

(combit_cRM_Solution*_EN and combit_cRM_Solution*_DE) which are based on the 

same database. You can open the desired one by executing File > Open. 

Note: Individually customized toolbars and menu layouts will be reset when you 

change the language, as their texts (menu items and tooltips) are language 

dependent. Instances of add-ins, conduits and the address pickup which are 

already running will have to be restarted. 

 If you prefer a mixed-language solution (German and English at the same time for 

different clients), we recommend to use two solutions (within separate project 

directories) which are based on the same database. Thus they can have localized 

view names, formulas, filter expressions, statistics and code attributes etc. As field 

names use the field alias, for the physical name in the database table however, a 

common, shared naming must be found. 

▪ Reactivate  messages: The program supports you in many activities with notices 

containing hints and tips. You always have the option of deactivating each notice for 

the future. If you wish to reactivate all notices, select F i le > Options > General  > 

Settings and press the button "Reactivate  messages". 

▪ Minimize window when closing to the info area of the task bar:  When this option is 

activated, the application is not ended when "Close" is selected in the title bar, but is 
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minimized as a symbol in the notification area of the taskbar. With Right cl ick > 

Show the program window can be displayed again. Select F i le  > Exit if you wish to 

close the application completely.  

If you deactivate this option, you will no longer be reminded of upcoming 

appointments and tasks after closing the program window. 

Note: If an already running instance of cRM is found when starting the program, 

the user is asked if he/she would rather switch to this. This avoids unwanted 

multiple instances if the minimized cRM was overlooked in the taskbar. This 

check is not undertaken if the SHIFT key is held down while starting the program. 

▪ Add internal views to the navigation: The navigation is expanded with the internal 

views (info center, appointments/tasks, calls).  

▪ Recycle view windows automatically: By double-clicking a view in the navigation, an 

already open view is not opened again. 

▪ Always show total record count in status bar: The continuous determination of the 

total number of records in the status bar can be disabled. This reduces the load on 

the database server, especially when record rights activated, but also with many 

parallel users. 

▪ Use standard window scrol l  bar in container/l ist v iew  

▪ Open new tabs left  if you are used to that from other applications. 

▪ Use ribbon instead of menu and toolbars. 

▪ Maximum number of open view windows: in order to avoid that too many views are 

open which leads to performance degradation. 

15.3 Configuring the sending of mail 

To be able to use the sending of mail through cRM, you must first make the 

corresponding settings. These settings are also used when sending mail through the 

export, print and preview dialogs. Select F i le > Options > General  > Sending Mai l . 

Mail service 

Mail service unformatted e-mails (text) 

Here you can set through which mail service these e-mails are to be sent. 

▪ The standard interface for most e-mail clients is "Simple MAPI". 

▪ "Extended MAPI"  (only Outlook 2000/XP/2003/2007) uses an extended functionality 

of the interface. With this it is possible to send e-mails despite security limitations in 

Outlook without every e-mail having to be confirmed manually by the user for 

protection against automated virus distribution.  
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▪ When sending through "SMTP" the e-mails are not sent through the e-mail program, 

but directly from the software. Communication with the SMTP server is undertaken 

directly. 

Mail service formatted e-mails (HTML) 

▪ Extended MAPI (Outlook 2000/XP/2003/2007 only): (see above) 

▪ SMTP (see above) 

 

Configuring SMTP 

 With the button "SMTP settings" you will open the mail setting dialog. 

 In the "SMTP-Server" tab, enter the URL or IP address of your SMTP server. 

 In the SMTP user options, enter your usual user and sender data. Usually you can 

transfer the data from the corresponding configuration dialogs of your e -mail 

program. 

 If you have set the option "POP3 authentication required"  under SMTP server, you 

must enter the data for the POP3 server and the corresponding POP3 user data in 

the last two tabs. 

Option "Mail per context menu by" 

You can send e-mails to the corresponding address using the context menu of the "e-

mail" field types. You have the following options: 

▪ MAPI mail client: e-mails are always sent through your default MAPI client (e.g. 

Outlook). 

▪ Integrated mail editor: Use the mail templates (see "Working with e-mail templates or 

standard e-mails" in chapter "E-mail". 
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▪ Mail client registered to 'mailto': as "MAPI mail client, but the CRM window continues 

to use and Outlook automatically uses the default template (with signature, etc.). 

Option "E-Mail client is Mozilla/Thunderbird" 

When using Mozilla/Thunderbird as MAPI client, you can access various optimization 

options for the text transfer by e-mail. 

Wait time of serial e-mails 

For serial e-mails, it can be specified that the mail process is adhered to after a adjustable 

number of e-mails are sent and is not continued until after the specified wait time. This 

may be useful for mail-SPAM blockers, have only a limited number of submitted emails 

per unit time permit, to bypass or to relieve the local mail infrastructure at regular 

intervals. 

15.4 Configure history 

The most recently viewed or edited records are displayed user-specifically in the history. 

Further information can be found under "History" in chapter "Entering and editing data".  

The history is activated in each view’s configuration on the "General" tab. 

 

 To configure, select F i le  > Options > General  > History. 

 Select the time duration for which a record is to be kept in the history.  

▪ Older records are removed from the history when the program is started. 

▪ For 0 days, the history is only recorded for the current session. When the 

program is started again, the history will be empty.  

▪ For 1 day, today’s and yesterday’s records are displayed. 
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▪ For 2 days, today’s, yesterday’s and the day before yesterday’s records are 

displayed, etc. 

 The length of stay sets the time after which the record is automatically recorded in 

the history. (0 to turn this off).  

 With the button "de lete  history " the history can be deleted. The changes become 

visible when the dialog is closed. 

15.5 Sound 

To configure the audio signals, select F i le > Options > Sounds. In this dialog, you can 

assign sounds to program events (e.g. "Reminder" or "Dupe Found").  

15.6 Using the formula editor 

Fixed text, variables, formulas and functions can all be inserted and combined via the 

same dialog. This dialog contains an assistant who supports you in selecting the correct 

syntax, provides explanations, and help. 

Note: This is only a small introduction to this subject. More detailed information can 

be found in the additional documentation List & Label Designer. All options and 

functions are described in detail there. 

Inserting variables 

The variables are placeholders which will later be filled from the application when 

configuring projects. The value type "String" (Text), "Number", "Date", "Boolean" (logical 

values), "Drawing", "RTF" and "Barcode" is important as soon as you want to use variables 

as parameters in functions, because usually only certain value types can be used as 

parameters. You can, for example, only multiply a numeric value with a numeric value and 

not with a picture. 

The "Variables and Functions" card contains a list of the variables which are available for 

the current object, including the data type in the form of an icon in front of the variable 

and the available functions.  

Double-click (or use drag & drop) on the variable you'd like to transfer to the editing line. 

The required variable is then transferred to the editing line with the correct syntax. 

cRM-Variables 

There are special cRM-variables available, for example, general information about the 

project or the user. You can find the variables and fields in the CRM sub-folder in the list 

of variables. 



General configuration 

214 

 

cRM.Application: application-variables 

▪ cRM.Appl ication.Path : cRM-Application Path. 

▪ cRM.Application.UILanguageID : Current interface language. Possible values are 7 

(German), 9 (English). 

cRM.Project: project-variables 

▪ cRM.Project.Company: Contains all the variables of the company master data. 

▪ cRM.Project.Database : Name of the database on which the project is based. 

▪ cRM.Project.DatabaseSystem : Current database system. Possible values are: 3 

(Microsoft SQL Server), 10 (PostgreSQL). 

▪ cRM.Project.Description : Project Description. 

▪ cRM.Project.F i le : Projectfile Path (*.crm). 

▪ cRM.Project.Name : Project name. 

▪ cRM.Project.Path : Project Path. 

▪ cRM.Project.Session.Cl ient : Value can be set for each session per client, eg via a 

query dialog. This variable could be used e.g. for record rights. 

▪ cRM.User: User Master Data. 

Only in print templates: 

▪ cRM.View.DBTable : Name of the database table on which the view is based. 

▪ cRM.View.Family:Family name of the view. 

▪ cRM.View.Name: View name. 

Only in the input form designer: 

▪ cRM.AppDir: cRM-Application directory. 

▪ cRM.FormMode: Current Status of the input form. Possible values are: 0 (Not in edit 

mode), 1 (Edit mode), 2 (input form designer), 3 (Edit mode after creation of a 

record). 
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▪ cRM.InEditMode: Current status of the edit mode. Possible values are True or False. 

▪ cRM.PrjDir: Project directory. 

Inserting functions 

With the help of the formula wizard you can insert functions into the row currently being 

edited. With these functions, string (text), number and date manipulations can be made. 

On the corresponding tab, you are shown a list of the available functions. On the left, the 

function names are displayed and in brackets the number and value type of the 

arguments of the function. On the right is the type of the return value (result) of the 

function. 

Double-click the desired function to insert it. Amend the arguments as necessary. These 

can either be variables or manually entered values. Within functions, special rules apply 

for the notation, which are described in the section "Advice on syntax rules" later in this 

chapter. 

Note: Since calculations in transfer templates are more of an exception, all variables 

are automatically converted to the value type "String" (Text). If you need to calculate 

with "Date" or "Number" values, you must first convert these to the required value type 

with the corresponding functions. 

More information on the available functions can be found in the List & Label Designer 

documentation in the "Functions" chapter. Following special  cRM-functions can´t be 

found in the List & Label Designer documentation: 

▪ GetCreditCardType$(): retrieves the credit card type, e.g. VISA. 

▪ GetFieldFromAddress(): Retrieves further information on provided address (given as 

Country Code, Street/POBox and City), e.g. AREACODE, CANONICALCODE, CITY, 

STREET, ZIP or ZIPPOBOX to open the PO Box directory. 

Example: «GetFieldFromAddress (Country,Street,City,"ZIP")». 

▪ GetFieldFromZIP(): Retrieves further information on provided ZIP (given as Country 

Code and ZIP), e.g. AREACODE, CANONICALCODE, CITY, US-STATE or ZIP). 

Example: «GetFieldFromZIP (Country,ZIP,"CITY")». 

▪ GetInfoFromCountry(): Retrieves further information on provided country code, e.g. 

the country name. 

Example: GetInfoFromCountry(Country). 

▪ EURO.GetCurrencyCode$()/EURO.GetCurrencyName$()/EURO.GetDecimals()/EURO.

GetISONames$(): Returns the code, the localized name, the number of decimals ort 

he ISO name of the currency (given as ISO name, standard name or currency code). 
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▪ EURO.IBAN$()/EURO.IPI$ (): Calculate IBAN and IPI-Text. 

▪ EURO.Verify.IBAN$()/EURO.Verify.VAT$(): Checks IBAN or tax ID for validity.. 

Inserting conditions 

In the "Cond()" tab, you can insert any "IF-THEN-ELSE" conditions into the row of the 

transfer template currently being edited. This is done in a simple dialog. 

 In the first input field, enter the desired condition expression. This expression must 

be logical, i.e. the output must be either TRUE or FALSE. This is the "IF" argument of 

the condition. 

 In the second input field, enter what is to be written during the transfer if the 

expression in the "IF" argument is TRUE. This is the "THEN" argument of the 

condition. 

 In the third input field, set what is to be written during the transfer if the expression 

in the "IF" argument is FALSE. This is the "ELSE" argument of the condition. 

In the expressions for the IF, THEN and ELSE arguments of the condition you can use any 

variables, functions or operators by entering them by hand or inserting them using the 

buttons. If nothing is to be written for an argument, simply enter two quotation marks 

into the corresponding "THEN" or "ELSE" argument. Within the conditions there are 

special rules for the notation, which are described next. 

Example: Let's say that in the view's field COUNTRY the country indicator ("D", "CH", "A", 

etc.) is saved. When transferring into a letter head, the country should be written out 

under the city – however only if there is no "D" in the field COUNTRY. 

Note: For links, the rules described in the chapter "Operators" of the List & Label 

documentation apply. Comparative values entered manually must always be written 

inside quotation marks. A pair of quotation marks with a space between them stand 

for a space. 

Advice on syntax rules 

Double angle brackets (« ») 

Within expressions, i.e. conditions and functions, special rules for notation apply. Such 

expressions must always be written in double angle brackets (« »). Please note that only 

one pair of double angle brackets may occur per expression, even if this expression 

contains several conditions or functions. 
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Variables in expressions 

Outside of expressions, variables are written in angle brackets (<VARIABLE>), within 

expressions they are written without (VARIABLE). 

Expressions and fixed text 

Text entered manually must always be contained in quotation marks when within an 

expression ("TEXT"). 

▪ If you wish to use fixed text together with variables, text and variable must always be 

connected with the link operator "+". 

Example: «"FIXED TEXT "+VARIABLE»  

▪ Outside of expressions, no inverted commas or operators are necessary. 

Example: FIXED TEXT <VARIABLE>  

Expressions and breaks, dates, tabulators and special characters 

Breaks or date information may not occur within expressions, i.e. within double angle 

brackets (« »). 

▪ With the "L inefeed" button on the "Text" tab, you can insert any number of breaks into 

the row currently being edited. Breaks are shown by the "<¶>" symbol. Each of 

these breaks triggers a text wrapping break. 

▪ In the "Date" tab you can insert the current date into a row with a double -click. 

▪ By inserting the control character «Chr$ (9)» you can create a tabulator. 

Example: Name: «Chr$ (9)» <Salutation> <Firstname> <Name> 

▪ By inserting the control character «Chr$ (149)» you can create a point or any other 

desired special characters. To do this, enter the ANSI code of the character into the 

brackets.  

Example: <COMPANY> «Chr$ (149)» <STREET> «Chr$ (149)» <ZIP> <CITY> 

15.7 Configuring transfer templates 

You can transfer data into another program using a transfer template (e.g. Word). This 

output is suitable for individual letters, for example, so you can edit the contents in the 

corresponding program before printing. 

If these documents are to be stored and managed automatically in the document 

container, configure the transfer template with a document template in the document 

management. For further information, see chapter "Activities and Document 

management". 



General configuration 

218 

In transfer templates, you can set which fields of an individual record are to be 

transferred to which target program and in what way. Also, you have the option of 

transferring fixed text, such as a return address, and formatting as well as reacting to 

certain field contents using conditions and functions. The target program can be started 

automatically. 

 A transfer template is activated under Settings > Transfer Templates > Select .  

 To carry out a single transfer using the active transfer template, select Output > 

Transfer Record. 

To create or change a transfer template, proceed in the following way:  

 Select Settings > Transfer Templates > Edit . 

 

 The last selected transfer template is opened.  

 If you want to edit an existing transfer template, open it with F i le  > Open. Transfer 

templates always have the file ending *.XFX. In the "TransferTemplates" folder, you 

will find various examples that you can adapt to your needs.  

 If you want to create a new transfer template, select F i le  > New. 
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General settings 

 Enter a description for the transfer template. This description is available to you as 

the variable <Action.Template> for automatic logs. 

 Select the target program for the transfer. When selecting the program it is very 

important to choose the correct version. Using the button "Se lect application path" to 

program can be started if it was not found.  

If you cannot find the required program in the list, you can use the target program 

"Clipboard". The data can then be manually inserted into almost any Windows 

program.  

 For a transfer to Word or Excel, you can select a document template for the target 

program in the "Document Template" field. 

▪ To place the fields in certain places in Word or Excel documents, these 

templates can contain bookmarks. These bookmarks are then assigned to 

individual transfer lines. For further information regarding bookmarks, see the 
"Bookmark" section.  

▪ Only the user templates of Word and Excel are available in the combobox. 

Alternatively, a template from the workgroup directory can be set. To do this, 

simply write the file name in the field. A template is automatically searched for 

in the workgroup templates directory when the template entered cannot be 
found in the user template directory. 

▪ Alternatively, the complete document path can be entered (e.g. 

F:\Template\standardletter.dot). 

▪ When you create a transfer template for a document type of the document 

management, do not select a document template here. This is set directly in the 

configuration of the document type in the document management (see chapter 
"Configuration of views"). 

Transfer lines 

The dialog contains a listbox in which the individual lines of the transfer template are 

displayed, as well as various options. If you create a new transfer template, this listbox is 

empty at first. 

Transfer templates are built up line for line. Every line is automatically ended with a line 

break. Every line can contain fields, fixed text and functions. Several fields or text objects 

can be in each line. The individual lines of a transfer template are displayed one below 

the other in the listbox of the transfer template dialog. 

 Click on the "New" button to insert a line. In the context menu, select "Text". The new 

line will be inserted before the highlight, i.e. the selected line is pushed downwards. 
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If you wish to use a macro command instead of text, select "ExecuteMacro" here and 

enter the associated macro name. 

 If you wish to remove an existing line again, select the respective line and click on 

"Delete  se lected l ine " .  

 To fill an empty line or to change a line’s existing contents, double -click on the 

corresponding line. You will open the dialog for editing lines and here you can either 

enter fixed text (such as your return address) and/or the required variables. 

 

Example: on the "Variables and Functions"  tab double-click on the variable 

SALUTATION. Since this line is to contain several variables, enter a space with your 

keyboard. Then select the second variable F IRSTNAME. In the same way, insert the 

third variable NAME. To differentiate from normal text, which can be entered with the 

keyboard, variables are contained in angle brackets "< >". 

Further information about the formula editor can be found under "Using the formula 

editor". 

 Continue in the same way with the other transfer lines. 
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Line properties 

In the left area you can assign properties to every transfer line. 

 

Blank optimization 

With space optimization you can remove undesired spaces (leading, enclosed and 

leftover spaces) from rows in transfer templates. 

Consider a situation in which you are printing a line with the variables <SALUTATION> 

<FIRSTNAME> <NAME> in a letterhead where the individual variables are separated by 

spaces. 

If a record does not have a title, this variable will remain empty, but the space that 

follows it is printed. First name and surname will be indented by a space (leading space). 

Assuming the variable "FIRSTNAME" were empty, there would then be two spaces 

between "SALUTATION" and "NAME", which does not look professional in print. If all 

three variables were empty, the two spaces would still stand (leftover spaces). This line 

would not be empty and would therefore not be automatically suppressed. 

With space optimization any repeated enclosed spaces are automatically turned into a 

single space. 

Non-removable 

This option is not active by default, therefore spaces are not normally printed. Activate 

this option if you wish to output a space, e.g. between town and country.  

Manual linefeed 

When this option is activated, a row is not ended by a word wrap. Instead, it is ended 

with a manual line break. Any existing paragraph formatting will be overwritten. 

No carriage return 

When this option is activated, a row is not ended by a word wrap. Any existing paragraph 

formatting remains intact. 

You can also place all information to be transferred in one row of the transfer template. 

Wherever a line break should occur, simply insert a break. Alternatively you can use 

bookmarks, that can be entered directly, to mark places in the target document where 

information is to be inserted. 
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Bookmark 

A bookmark marks a position in an Excel or Word document that you set and name. With 

a bookmark you can, for example, mark the place where the letterhead or the date is to 

be placed. It is enough simply to locate the first row of a bookmark (e.g. the field "Firm"). 

The following rows are automatically hung on the end. 

If you have set a document template for the target program, and this template contains 

bookmarks, these will be available in the list and can be assigned to the rows. 

 

If you insert a bookmark in a positioning frame, for example to transfer the address fields 

into a positioning frame, it is extremely important that the paragraph in Word, in which 

the positioning frame is located, is formatted through a style sheet (normal formatting is 

not sufficient!). This defined style sheet (e.g. "Address field") can then be assigned to all 

transfer lines, which are to be transferred into this positioning frame. 

 To insert a bookmark into Word, click on the place where you wish to inse rt it, then 

click on Bookmark in the Insert menu. Enter a name for the bookmark and click on 

Add. 

To display bookmarks in Word 2007-2013 select Word Options > Advanced > Show 

document content and activate the option "Show bookmarks"; in Word 2000-2003 

select Tools > Options > View and activate the option "Bookmarks". The bookmarks 

are then shown as grey, vertical lines. In the dialog "Insert bookmark" you can see 

which bookmark has which name if you sort the list by location. 

 Save the document and leave Word/Excel open in the background. 



Configuring transfer templates 

223 

 These bookmarks are now available in the "Bookmark" combobox in the "Line 

properties" area of the transfer template, and can be assigned to the lines. 

 

Please note that you may only assign bookmarks that are also defined in  the 

document template. If you assign a bookmark that is not defined in the target 

document, you will be shown the error message "The requested member of the 

collection does not exist". 

Tip: Bookmarks are also displayed in the "Bookmark" selection list if a Word or Excel 

document with bookmarks is simply opened in the background (without explicit 

selection as document template). This procedure offers itself if you are creating a 

document as a template for the document management because you cannot select 

a document template in the transfer template while doing this. 

 To insert a bookmark in Excel, select Insert > Name > Define . You also have the 

option of directly setting the sheet, row and column.  

 

Further options 

In the lower area of the dialog there are general options available depending on the target 

program. 
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Insert automatically 

The option "Insert automatical ly"  has the effect that the data to be transferred is 

automatically transferred to the target program. If the option is turned off, the data wil l at 

first remain in the clipboard and have to be inserted into the target program manually. 

Auto-show window 

The option "Auto-show window" had the effect that the window of the target program will 

automatically move to the front after the transfer. 

Save file 

With "Save fi le " you can set whether the file in the target program should be saved after 

being created. In the formula wizard you can set how the name of the file is to be 

generated (e.g. with the start of the firm name). 

Define as document fields 

In the selection list you can define "Document fields". The selected fields are available as 

bookmarks in Word (field name Ref) and can be inserted into a document template there. 

Once a bookmark has been defined through the document field, it can easily be read out 

with a REF field. Proceed in the following way: 

 In the transfer template, select all fields that are to be transferred to Word as 

document fields. 

▪ Click on a field to select it. 

▪ To select several fields, hold the Ctrl key. 

▪ To deselect active fields, hold the Ctrl key and click a selected field. 

▪ Field descriptions may not contain points. 

 Open your document template in Word and insert the field function {Ref 

<Document field>} in the corresponding places. 

Example: Activate the document field "AccountMngr". Insert the field function {Ref 

AccountMngr} in Word. At this position, the content of the field "AccountMngr" will 

be displayed. 

 The transferred document fields must be refreshed in the document after the 

transfer. To do this, select all with Ctrl+A and then press the F9 key. 

Fonts 

These options apply mostly to Word. You have the option of formatting every row of the 

transfer template. To do this, select the desired font and font size or – even easier – 

select a style sheet from the list.  
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▪ If you do not specify a format, the default font of the target document is used. 

▪ You can enter style sheets, fonts and font sizes directly into the dialog field. 

▪ Please note that you may only set style sheets that are also defined in the document 

template. If you set a style sheet in the transfer template that is not defined in the 

target document, you will receive an error message during the transfer. 

15.8 Customizing print templates 

 Print templates are used for the direct output of data. These can be edited in the 

integrated List & Label designer. 

This output is especially suitable for standardized outputs such as standard letters, mail 

merge letters, address labels, name cards, lists and reports. Information regarding output 

with print templates can be found under "Output with print templates" in chapter "Output 

of data". 

Note: This is only a small introduction to this subject. More detailed information about 

creating output templates can be found in the additional documentation List & Label 

Designer. All options and functions are described in detail there. 

General 

To create or edit a print template, proceed in the following way: 

 Select Settings > Print Templates and then select the desired output form: label, file 

card, list or direct single/mail merge letter. 

 If you want to customize an existing template, select it. 

Tip: Various examples of templates are included in the package, which you can 

adjust to your needs. 

 If you wish to create a new template, enter a name for it in the file name field and 

select "Open". The different output formats have different file extensions: lbl (label), 

crd (file card, letter), lst (list). 

 

 The List & Label Designer is opened and you can make the desired changes to the 

template. 
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Page layout 

If you create a new template, the project wizard will open after the above steps for the 

creation of a new print template. This will lead you through the required settings step by 

step. If you have used an existing file as a template, select Project > Page Setup for the 

composition of the page layout. 

 
For multi-page projects it can be sensible to define different layout setting (page size, 

orientation). In the field "Active Design Area" of the project properties define the visible 
area within the working area of the Designer. 

▪ A new area can be defined over the new-button and then define its corresponding 

properties. A "condition" has to be defined when the Layout setting is used e.g. 

"Page()=1" when it should be used only for page 1. The first area will be used for 

valid for the set conditions.  

▪ The default-region "Standard layout" is always the last region and the condition is set 

to True.  

The format of the region, that includes the condition "Lastpage()", should not vary 

from the page layout which will be used when the condition Lastpage() is not 

true. This is due to List & Label not knowing at the start of a page if it is intended 

to be the last page, hence cannot select a region with the condition Lastpage() is 

true. Only after completing the page the printer can be assigned to this region. 
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Should the page size or orientation change, this can lead to a scale change or 

data being cut off. 

▪ Printer settings and page size: By setting the properties it is possible to define for 

the region the printer settings, paper size, orientation, copies, duplex, sort and paper 

bin (e.g. first page on paper with company header, following pages on standard 

paper. 

▪ Force  Paper Size : If no printer definition file exists and this option is set, the paper 

format selected during design will be forced during print out. Prerequisite is that the 

respective format or a "user defined" format is supported by the printer. If not, the 

next size up will be selected. 

▪ Size Adjustment: Sets whether the page will be fit if printed to a different printer or if 

the scale should be kept. 

▪ Use Physical Page and not only the printable  area : If this option is set the whole 

physical page is available as workspace, including non-printable margins. Some label 

page layouts require this, as the first label starts right at the top left edge instead of 

at a specific distance. The unprintable margins are shown shaded in the full -page 

preview. This means that objects can also be placed in the margins which will be cut 

off during the print. If objects are placed on page edges you still should take notice 

of the unprintable area. 

▪ User specific printer settings: If printer-specific options, e.g. printer, duplex mode, 

paper trays, etc. are set for a print template, these are saved in a separate file, which 

has the same name as the print template but has a "p" at the end of the file ending. 

This is the so-called "P file" (e.g. "Addresses.lsp"). By default, this P file is saved in the 

local application data directory (e.g. C:\Documents and Settings\<User 

name>\Application Data\combit\cRM). 

If, however, a P file exists for the print template in the (usually central) directory and 

this is newer than the local P file, the central P file is copied and used. In this way, 

printer-specific settings can be saved centrally. To do this, the administrator copies 

their local P file into the central print template directory. The P file is automatically 

distributed to the clients be means of its newer date. 

Export Media 

In the tab "Export Media" you can mark one of the target formats to be printed later.  

There are two buttons: 

 Select the format in the list and click on the options button 

 You can select a target format as default for the later print 
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Templates 

A previously or manually defined label format can be loaded in the tab "Templates" in the 

page layout for labels. 

Using Pre-Defined Label Formats 

You can select from a range of pre-defined label formats in the "Templates" register in the 

page setup for labels. Now you won't have to figure out the size of a particular label and 

how many labels are on one page. 

 Confirm the selected layout with OK. The chosen format will be displayed in the 

workspace.  

Defining Your Own Label Formats 

It is also possible to define your own label layout if the one you require is not available. 

Use the following values for the property "Layout Definition": 

Offset: The offset provides the horizontal and/or vertical distance of the top left -hand 

label to the edge of the workspace (depending on the "physical page size switch, this is 

relative to the paper edge or the printable area edge). 

The top left corner of the workspace always begins on the screen display with the 

coordinate 0/0, independent of the selected page size and offset. The effects of the 

offset can however be seen in the full-page preview or when you print. 

Setting the Size: This provides the size (horizontal = width / vertical = height) of the label 

in inch or mm. 

Setting the Distance: This option defines the distance from one label to the next (the 

space between two labels). For labels with only one column, only the vertical distance 

needs to be entered. 

Setting the Number: This option defines the number of labels per page. (horizontal value 

= number of columns per page, vertical value = numbers of lines per page) 

You can check the layout by selecting Options > Preview > Page Preview . 

Store user defined Label formats in the Label template list 

To save user defined label you can use the file "cmll1400.inf". 

Composition of a Label (all units are in 1/1000 mm): 

<A> <B>,<C> = <D> <E>,<F>, <G> <H>,<I>, <J> <K> 

A: product code, B: product description, C: product size, D: label size (width), E: label 

size (height), F: space size between labels horizontally, G: space size between labels 
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vertically, H: number of labels per column, I: number of labels per row, J: margin size 

left, right, K: margin size top, bottom 

E.g. 3420 Universal Labels, 70 x 16,9mm = 70000, 16900, 0, 0, 3, 17, 0, 4850  

Defining Print Order 

In addition to the printer and paper format, in a label project you can also define the print 

order of the labels on a label sheet. Labels are normally printed in lines from top left to 

bottom right. With partly used sheets of labels you may have already used the first line of 

labels, for example, which could cause the sheet to lose its stability at the top. Some 

printers have problems taking such sheets and react with a paper jam. 

Here you have the option of printing sheets of labels from the bottom up. In this way the 

top line of labels will be printed last and the sheet remains stable, even when the critical 

area on the sheet is reached. 

Note: Detailed information regarding the creation of print templates can be found in 

the List & Label Designer documentation.  

Including Projects 

When often using similar projects, it is practical not to design repeating elements over 

and over again, but to include other existing projects in your current projects.  
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This way e.g. a letter head can easily be included. In addition, changes just need to be 

edited in one place, if e.g. the design needs to be adapted. A change of address has to 

be made only in one single project instead of different projects. 

Using Project > Include  you can include existing projects in current projects. 

The objects of these included projects will be visible, but are locked against editing. Also 

included are sum and user variables of the original project. Please notice not to generate 

duplicate identifiers when designing, e.g. including an existing project that is using a sum 

variable which is already used within the current project. The sequence in which the 

projects are included can be defined here as well. 

Working with User Variables 

To avoid having to re-enter formulas  that are required often, it is possible to store them 

in user variables. These are effectively formula building blocks. User variables are labeled 

with @<Name> (e.g. @User01). These are defined in Project > User Variables . 

 

Customize a label 

 If you have created a new label using the project wizard, the necessary objects are 

already placed on the workspace.  

 To place further objects, select the appropriate tool from the toolbar on the left, e.g. 

"Text". Drag open a text object in the workspace (appears as a rectangular frame). 

 Double-click the text object you created. In the following dialog, click on the "New" 

button to create a new line in the label. Define all the individual lines of the label. 
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 The rows of the labe l  should, for example, contain the variables of the address. In 

the formula editor, select the desired variable and click on "Insert" to transfer it to the 

row. It is even faster if you double-click the variable. Confirm the row with OK. In this 

way you can build up the desired label as in the example above. 

 You can also format every row by clicking it and then setting the desired font, 

alignment and other properties in the right-hand area. If you have inserted empty 

rows, you must turn on the property "Inerasable " for them. Otherwise, these empty 

rows are automatically suppressed when printing. 

 Confirm the definition with OK. Save the label definition with F i le  > Save  and close 

the List & Label Designer with F i le  > Exit . 

Note: Detailed information regarding the creation of print templates can be found in 

the List & Label Designer documentation.  

Customizing single/mail merge letters 

Single/mail merge letters (file ending *.crd) are no different in construction than complex 

labels. For this reason, only the differences are discussed here. 

 The individual parts (address, sender, logo and text) are placed on the workspace as 

objects just as with labels. 

 Double-click on the object "Formatted Text" to enter the actual text. You can also 

copy this from an existing letter in your word processor. 
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The output of many-sided letters is also possible. Proceed as follows:  

 Right-click and select Assign a layer. Choose the "First Page" layer and click OK. So 

the address, return address, return address logo and date objects are assigned to 

the "First Page" layer. In this way, they will only be output on the first page.  

 Option 1: (see included template "Direct standard letter template.crd"): So that the 

letter text starts at the top of the page on the next side, a dummy rectangle is placed 

as an object and is linked vertically (Relative to end/inverse) with the text. This 

dummy rectangle begins where the letter text is meant to start on the next page. The 

height of the dummy rectangle sets the value by which the text is to be moved up 

and increased in size on the following pages. 
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 Option 2: So that the letter text starts at the top of the page on the next side, the 

position (top, height) of the "Formatted Text" object is set with a condition that 

pushes the text field up and increases it in height on the following pages. Note that 

the condition can be lost if the object size is changed. 
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Note: Detailed information regarding the creation of print templates can be found in 

the List & Label Designer documentation.  

Customizing file cards 

File cards (file ending *.crd) are no different in construction that complex labels. For this 

reason, only the differences are discussed here. 

 File cards tend to contain more text objects. To make the alignment of field 

descriptions and field contents easier, it is best to build up a file card so that one text 

object only contains the description and an adjacent one contains the related 

contents. 

 With the contents, you should give all the rows of the text object the "Inerasable " 

property. Otherwise the contents may move relative to the field description if some 

fields are empty. 

 If you want to output values of logical fields (checkboxes), use a formula with a 

condition. 

Example: «Cond(<FieldName> = true, "Yes", "No")» 

 If you want to print comment fields onto the file cards, with long comments it can 

happen that the text does not have enough space. You can change the page layout 

here, so that you use a whole A4 page per file card. You can then enlarge the text 

object by dragging it. If this is still not enough – a lot of text does fit into a comment 

field – you can continue the comment field on a new page. To do this, right-click in 

the text object and select "Properties". Activate the option "Page Break True". 

Please note that on every new page that is started for the comment field, the other 

text objects on the file card are repeated. If this is not desired, you can define 

different page layouts for the first and following pages with various display layers 

and object links. An example of this can be found in the included print template  

examples. 

Note: Detailed information regarding the creation of print templates can be found in 

the List & Label Designer documentation.  

Customizing a list or report 

Lists and reports are no different in construction than file cards with a report container, 

which can contain tables charts. For this reason, only the differences to file cards are 

discussed here. 
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General 

To create or edit a list, proceed as follows: 

 Start the list wizard with Settings > L ists/Reports.  

 Select the 1:N re lations here that should be available in the print template. By 

clicking, transfer them to the "Used" list. 

▪ In the normal case, the fields of the view are only made available to the table 

object as List & Label fields. By activating the option "Define fields of main view 

as variables" they are made available to other objects as List & Label variables 

(e.g. for use in text objects). 

▪ Normally tables are issued only if records are available. With the option "Output 

empty tables" tables are always printed (eg the header). 

 

Working with the report structure 

In the "Report Structure" tool window, all elements and sub-elements of a report structure 

are displayed, with their object type and data source [relation name, sort name], in the 

order that they will later be printed (workflow).  
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To insert the report container select Objects > Insert > Report Container . 

Tables, charts and crosstabs can be inserted in any order, also as sub-elements of tables. 

In this way, sub-reports with almost any relation between tables can be defined. 

To edit the report structure, a toolbar is available. Table, chart and crosstab objects are 

inserted into the project using buttons in this toolbar. Using the buttons in the tool 

window, you can also attach a new sub element, delete, cut, copy, paste elements and 

change the sequence of the elements of the same hierarchical level  

Inserting a new element 

 Select the button "Add an element" or "Add a sub-element". 

 In the following dialog, choose the object type that you want to insert into the report 

container: Table, Crosstab or Chart. 

 In the following dialog, choose the Source Table Path. 
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In the "Choose Source Table Path" dialog all available tables are displayed 

hierarchically, i.e. you will find the respective relationally linked tables under the 

tables. 

"Free content" can also be selected as the data source, provided this is supported by 

the application. This means that data lines with fixed content or variables can be 

created and thus e.g. texts, letters, images or barcodes can be integrated into the 

"Report Script". 

 

 If you create a new template, the dialog "Pre-selection of fields for a line definition" 

will open after the above step. Select the columns for the last table. 

Customizing table contents 

A table is made up of different row types, which can be defined independently of one -

another. There are headers, data lines, footers, group headers and group footers. 

 

▪ Headers are normally used as titles for table rows. 

▪ Data rows contain the formatting of the actual table rows containing the data that are 

meant to be displayed in the table. 
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▪ Footers are displayed at the very end of the table and can contain conclusive 

information regarding the data shown above them. 

▪ Group headers and footers are for the structuring of the data rows by using "sub 

headers" and "sub footers". 

All row types can be defined independently of one-another. Therefore, the rows of a 

header can look different from the data rows or footer. 

Different row layouts or definitions can be set for each individual row type. Using special 

display conditions, different row definitions can be activated as required. 

All row definitions are defined in the same way and consist of columns that can be 

individually edited and formatted. 

 In the table contents dialog, the individual row types with their different row 

definitions and individual column arrangements can be edited. 

 There is a tab for every type of row to set the different row definitions and columns 

of each row. 

 When you double-click a row, the formula editor opens to edit the row. 

 If no rows of this type have been defined yet, you will be asked whether you want to 

use an existing row definition from another row type. 

Sort order 

The sort order of a table can be explicity set in the table properties. To display the table 

properties, select the table in the Report Structure  tool window. Then select a sort order 

in the "Sort order" field. All sort orders of the active view are available.  

 

This makes sense, for example, when you are using groups so that the records are 

sorted according to the group. If you do not define a sort order, the current sort  order of 

the active view is used. 

Note: Further information regarding the table object and regarding the creation of lists 

can be found in the additional documentation "List & Label Designer".  
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15.9 Groupware 

There are several connections to groupware applications. 

Microsoft Outlook XP and above 

Integration of CRM via the LDAP protocol. For more information, see the chapter "combit 

LDAP server" 

Alternatively to the integrated scheduling and task management, the Outlook Calendar 

could be activated. This is done under the F i le > Options > General> Appointment and  

Tasks. 

The direct by e-mail via the menu "Output" will be dispatched via Outlook, if you select 

the "Extended MAPI" option as the mail service in  F i le > Options > General> Sending 

Mai l . 

You have the option of e-mails from an Outlook folder, a record in the CRM assigned. 

Further information about this topic, see "Archiving messages from eMail-Client" in the 

section "Activities and Document management" 

Tobit David 8 and above 

The views of the CRM can be used as contacts in the client David are imbedded. The 

records are then in a so-called archives displayed. About the buttons in the preview 

window, you can now directly eg Send an e-mail.  

Alternatively to the integrated scheduling and task management, the David-calendar-

enabled. This is done under F i le  > Options > General > Appointment and Tasks. 

The direct by e-mail via the menu "Output" will be dispatched on David, if you select the 

mail service "SMTP" and the David server in F i le > Options > General> Sending Mai l . 

You can e-mail from a David-archive a record in the CRM assigned. Further information 

about this topic, see "Archiving messages from " in the chapter "Activities and Document 

management". 

15.10 combit LDAP server 

The combit LDAP server gives you access to the cRM views from anywhere in the world. 

The files can be accessed over the internet / intranet or locally. All that is required is an 

LDAP client which is available in every Microsoft Windows version. With  the LDAP 

protocol, you can also access your data from a Linux system, for example. 



General configuration 

240 

Note: When first starting the LDAP server, the view "Addresses" is preconfigured. You 

therefore only have to start the server with Commands > Start Server  and can then 

access your data in your view directly from a client. 

General settings 

With a click on F i le > Settings a dialog opens in which you can choose the basic settings 

for the LDAP server. 

Port: Search requests are anticipated on the port set here. As standard, the LDAP port 

according to RFC 2255 is set to 389. For this reason changing the port is not 

recommended. 

Status: The status sets to what mode the LDAP server should be switched being started. 

There are three different modes: 

▪ Started: The server waits for search requests after starting 

▪ Paused: The server opens to defined port but does not yet permit search requests. 

This mode is advantageous if you want to reserve the port immediately but do not 

want to allow any reach requests. 

▪ Stopped: No port is opened. Search requests cannot be processed. 

Start LDAP Server on windows start:  If this option is set, the LDAP server is started 

whenever the operating system is started. This feature makes life easier for the user 

because the LDAP server does not need to be manually started again after the system is 

turned on. 

Search 

In the "F ind" tab you can set the corresponding options. 

Connections: Here you can enter the maximum number of connections allowed with the 

server at the same time. If the number is exceeded, the client will receive a 

corresponding error message. Please note that an excessively large number can cause 

performance problems. You should therefore, depending on the available resources, not 

allow more than 10 connections. 

Data Source: If this option is activated, you can enter a standard data source in the lower 

option fields. This is used if the client does not specify an application when searching. 

Please note that only the applications installed on your system are available. 

If all settings have been conducted, you can end the dialog with OK. Any changes are 

only active after the server is restarted. 
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Configuration of the server 

Adding view 

So that the LDAP server can access the views of the combit Relationship Manager, these 

must first be configured. To do this, click the item Data Source > Add. The following 

dialog opens: 

 Please first enter your user data with which you log into cRM. 

By clicking the "Open" button, you can select a project. If the user data was entered 

correctly, the available views are listed in the combobox. The combit LDAP server 

attempts to link the LDAP attributes with fields in the corresponding view 

automatically. Fields for which no equivalent is found can be linked manually 

afterwards. Of course, you can also change undesired links retrospectively. 

The following database fields are automatically linked as long as they are available in the 

view: 

 

LDAP attribute combit Relationship Manager field 

OBJECTCLASS Department 

CN Name 

SN Name 

NSCPAIMSCREENNAME Name 

GIVENNAME F irstname 

STREET Street 

MAIL Email 

C Country 

O Company 

HOMEPHONE Telephone 

FAX Fax 

L City 

TELEPHONENUMBER Telephone2 

MOBILE MobilePhone 

OU Department 

XMOZILLASECONDEMAIL Email2 

DISPLAYNAME Name 
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DISPLAY-NAME Name 

Editing and deleting views 

Configured views can be edited retrospectively under the menu item Data Source > Edit. 

This is necessary, for example, if the links of the fields with the LDAP attributes have to 

be changed or new attributes must be accepted. 

If you wish to delete a view that has been configured, highlight the desired view and 

select the menu item Data Source > Delete . Please note that when you delete a view, 

any search being carried out on that view cannot be completed and this can cause errors 

on the client. 

Edit LDAP Attributes 

 With the button "New" you have the option of defining new attributes if the 

predefined attributes do not suffice.  

▪ In the top field you have to enter the LDAP attribute.  

▪ In the bottom field you can enter a description for this attribute. This can help to 

understand the rather arbitrary attribute name at a later date. 

▪ After entering a new attribute and description, end the dialog with OK. The 

newly created attribute is added to the list and can be linked with a field. 

 With the button "Settings" already configured attributes can be changed. In the 

associated dialog you can also set the description for the attribute. 

 With "Delete" you can remove existing attributes from the list. Please note that the 

attributes „CN", „SN" and „OBJECTCLASS" are necessary for correct data exchange. 

For that reason these cannot be deleted and have to be assigned to a field. 

 By activating the option "Authentication (logon) without specified login information 

shall use server authentication." you can set that searches may be made in this data 

source without the client explicitly logging in. If a client does log in with a username, 

this is used. 

 The option "Define view as standard for combit Re lationship Manager"  sets the 

specified data source as the standard. If the client does not specify a data source, 

this is used. 

If all entries have been made correctly, end the dialog with OK. The data source added 

will be shown in the tree view of the main window. 

Setting server actions 

In the toolbar in the main window you can set the status of the LDAP application: 

▪ Start: Starts the server and waits for queries. 
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▪ Pause: Switches the server to "pause". Active connections to LDAP clients are 

upheld, but no new ones are accepted 

▪ Stop: Ends all connections and frees the port. 

Starting a query from an LDAP client 

If the server is started and all settings have been completed, a query can be started from 

any LDAP client. For the server to be able to interpret the inputs correctly, the following 

format must be adhered to: 

LDAP://<servername>/<Base>???<Filter> 

In the following, the parameters and the according functions  are listed: 

▪ Servername: Attempts to create a connection to this LDAP server (normally the IP 

address of the LDAP server). 

▪ Base: Here the basic information is provided. The base information is used for every 

further search of the connection. Arguments are separated by commas. 

▪ app: Sets which application is to be started. Value: cRM (combit Relationship 

Manager). 

▪ project: A project that is configured on the server (e.g. cRM_Solution_EN.crm). 

▪ view: A view that is configured on the server (e.g. Addresses). 

▪ uid: When entering the UID (UniqueIdentifier) the record with this ID is searched and 

returned. This field is linked with the primary key of cRM. 

▪ Fi l ter: With this, the actual records are queried. A filter expression could have the 

following format: 

Example 1 : (|(surname=Mustermann)(mail=mustermann@combit.net))  

For this filter the LDAP server would return all records that have the name 

"Mustermann" and/or the e-mail address "mustermann@combit.net". 

 

Example 2 :LDAP://localhost/app=cRM,project=cRM_Solution_EN.crm,view=Addre 

sses???c=*D* 

This URL would start a search query on the local computer in the view "Addresses" of 

the project "cRM_Solution_EN.crm" and would return all records which have set the 

country to "D". 

If you do not know the complete name of the person being searched, the combit LDAP 

server offers a wildcard search. 

mailto:mail=mustermann@combit.net)
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Wildcard Effect 

* Stands for a character string in a word of any length. Example: 

"*bit" stands for all character strings that contain "bit". 

? Stands for any character in a word. Example: 

"M?ier" stands for: All words with 5 characters starting with "M" and 

ending with "ier". 

"M??er" stands for: All words with 5 characters starting with "M" and 

ending with "er". 

Setting up an address book in Outlook 

Microsoft Outlook XP-2013 gives you the option of searching for address data in a LDAP 

directory. This is useful because with the help of the combit LDAP server, direct access 

by Outlook to the views of the combit Relationship Manager is made possible. If you 

wish to have the LDAP server available as a data source in the Outlook address book, 

follow this procedure: 

 Go to the dialog Tools > E-Mai l  Accounts or Tools Account Settings. 

 Microsoft Outlook XP/2003: Select the item "Add a new directory or address book" 

and confirm with "Next". Microsoft Outlook 2007-2013: Select the tab "Address 

Books" and select "New". 

 In the following dialog, select the item "Internet Directory Service (LDAP)" and again, 

click on "Next". 

 Now enter the name or IP address of the combit LDAP server. Optionally, you can 

log in with user data. To change further settings, click on the button "More Settings". 

 In this dialog please enter the server name and if necessary, a different port. 

 In the field Search base you can enter a base. This is used when searching in the 

address book. Close the configuration. After restarting Outlook, the combit LDAP 

server is available in the address book. 
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16. Workflows and Events 

Note: Some of these functions require the Professional or Enterprise Edition. 

A workflow is a process (process, sequence of operations) that consists of individual 

activities. One must distinguish between client-side and server-side workflows.  

The individual activities are defined in the workflow designer or as a script. A script i s 

series of commands, which are run are carried out sequentially when run. More 

information can be found in the chapter "Scripts and programming reference". 

Some events also support Workflow files, meaning that the individual activities can be 

defined with the Workflow-Designer. More information on the graphic creation of a 

workflow can be found in the chapter "Workflow Designer" 

Clientside workflows are started by a button, or something that is entered or an event.  

Example: You start the sending of a newsletter with a button that sends it to a contact as 
an email or as a letter depending on the communication preference set.  

Server-side workflows are monitored by the workflow server and started by an event. 

Example: If a desired status does not stop, an activity is set into motion. For example, if a 

customer claim is not processed over a certain period, the responsible staff member 

receives a message. If a field change is made, for example a notification on the status of 
a service order, the customer is automatically notified.  

The automatic processing of emails and the start of a workflow via script can occur via 

the Email Autopilot. If you receive a message with a certain subject, the email will 

automatically be processed according to your specifications. More information can be 

found under "E-mail autopilot". 

Example: Automatically process newsletters sign-ups at a website. The registration 

details are compared to a possibly existing record, otherwise a new record is created. 

The verification of the email address (double opt-in) is also managed via the Email 

Autopilot.  

16.1 Workflow Server 

Servers-side workflows are monitored and started from the Workflow Server. The 

Workflow Server is an instance of the cRM that is started with the user "Workflow". 

Ideally, this instance runs on one server, an additional user license is not required for this 

instance. 
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 Select File > Help > Tools and start the Workflow Server. 

 Select the project file. 

 Via the button "Email Settings", you can configure the SMTP settings for sending 

email if you use workflows/scripts that send email notifications. 

 

 Via the corresponding button, open the event manager.  

 Select the desired view or project in the left view navigation area. 

 Via the button "New", you create a new event. 

 Select the type of event.  

▪ "Field change" and "Time limit exceeded" are available as server-side events.  

▪ Scripts and workflows should not involve any interaction with the user. 

 After you have defined the event, close the event manager. 

 In the dialog "Workflow Server", save the project to apply the changes. 

 Start/Stop the Workflow Server by using the respective buttons. The running 

Workflow Server checks for changes of the configured fields every 60 seconds. 

 If the user "Workflow" is linked with a Windows login (e.g. the server's user account), 

it starts without user interaction. That is useful if the Workflow-Server is contained in 

the Autostart group.  

Note: Normal logins/sessions that do not respond for more than 10 minutes will 

automatically be cleaned up. That does not apply to a "Workflow" session. It won't be 
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cleaned up as for all members of the group "Administrators" a hint will be displayed 

that an error occurred with the Workflow Server. After restarting the Workflow-Server 

the hint will be removed. 

16.2 Event Manager 

The event manager makes it possible to react to different events with automatic actions. 

For this you can save scripts for each of the events offered here.  

 

To define an event: 

 Select F i le  > Information > Events to open the Event Management. 

▪ Project-specific events can be: 

▪ Project has been opened, Project is being closed 

▪ Inbound call, Incoming call has been searched 

▪ Menu command has been executed, Hide menu command 

▪ View-specific events events can be: 
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▪ View has been opened, View is being closed 

▪ Record has been saved, Record is being saved 

▪ Record is being merged, Record has been merged 

▪ Field change, Timeout 

▪ Menu command has been executed, Hide menu command 

▪ Appointments and Tasks-specific events can be:  

▪ Appointment has been saved, Task has been saved 

▪ Menu command has been executed, Hide menu command 

 Link the event with the existing script file with the action "Script F i le " or embed the 

script into the project with the action "Script Direct". 

Event "Field Change" 

With the event "Field change" you can watch certain fields and execute a workflow/script 

when the content is changed. 

Example: If the status of a service order is changing from "open" to "done", a notification 

e-mail is automatically sent to the customer. 

If multiple solutions share the same (data-)database maximal one solution can use the 

event "Field change". Otherwise malfunctions will occur. 

 Select the field(s) to watch by the button "Select fields". 

 

 If a field change is detected the defined script is executed.  

Note: If in the above example a notification e-mail should only be send when the 

status changes from "open" to "done", it has to be defined in the script! 

Event "Timeout" 

.If a desired status is not reached, a script can be executed with the "Timeout" event. 
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Example: If for example a customer complaint is staying unprocessed, the team leader is 

receiving a message. The status "unprocessed" results from the field "Status", meaning 

that you define a filter "Status<>unprocessed" here. 

 Select the field to watch from the select list. Fields of type Date or Time are 

available. 

 Enter at which timeout the actions of the selected script/workflow should be 

executed. It can be specified in minutes, hours, days, months or years. 

 

 Define a filter in the "General Filter" or "Free SQL Query" dialog by the button "Select 

data". With this filter you define which criteria shouldn't be met. 

Example: The status "unprocessed" results from the field "Status", meaning that you 

define a filter "Status<>unprocessed" here. 

Attention! The action will be executed for all records that match the filter and the 

defined timeout. That means that in the filter or script/workflow it has to be 

considered if the action should only apply to certain records (e.g. for records of a 

certain date or later). 

 If a timeout is detected the defined script is executed.  

The event is executed once per record. Therefore for each record it is stored when 

the event has happened in the system database. 

Events in Scripts 

For the completed scripts, a new object "Event" is available, which gives information 

about the current event. It has the following properties: 

▪ Project: contains the project object that the event is regarding 

▪ View: contains the view object that the event is regarding (if available for the event) 

▪ Data: contains any additional information about the event. 

Example: Event 'Record is being saved' of the view Companies to show a message 
window to the user, stating that he has only rights to read the current record. 
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Dim oEvent 

Set oEvent = WScript.Event 

Dim DoCancel 

DoCancel = false 

Dim Value 

Value = oEvent.Record1.GetContentsByName("ABC") 

If(Value = "A") Then 

 DoCancel = True 

MsgBox "You only have read rights for this record!", vbInformation, 

"combit Relationship Manager" 

End If 

oEvent.Cancel = DoCancel 

Limits of these event scripts: 

▪ The right "Run Scripts" is not effective so any application logic configured with event 

scripts will always be carried out. 

▪ There is no status display (animation) in the status bar. 

▪ All events for views that no longer exist are deleted when saving the project file. 

Further information in the OLE additional documentation. 

Important: For complicated scripts (with long running time) it is recommended to use 

asynchronous scripts for the events because otherwise cRM will be blocked for too 

long. Excepted are the events "Project is being closed" and "View is being closed", for 

these a synchronous script must be used. Generally for asynchronous scripts you 

must remember that the user can continue working during the process (and can 

change the active record, for example). This can lead to unexpected effects! 

16.3 E-mail autopilot 

Note: This function requires the Professional or Enterprise Edition.  

The E-mail Autopilot runs as an application or a service on a server and watches your 

inbox. It can start a workflow that will be triggered by an e-mail with a certain subject. 

You can realize e.g. a bounce management, a double-opt-in process for newsletter 

registration or automatic processing of internet/e-mail queries or orders from an online 

shop. 

The E-mail Autopilot starts a script, triggered by an e-mail with a certain subject. 

Concerning the licensing the E-mail Autopilot will be handled as one workstation, 
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meaning that if on one workstation one or more program instances are running with the 

same user name (login), they use exactly one user license together. 

The E-mail Autopilot periodically checks a defined e-mail account for new messages. If a 

message with the desired subject exists, a script defined for this subject will be executed 

to process the e-mail. All required objects as the current project and the current mail are 

available in the script. 

Start the e-mail autopilot 

Select F i le  > Help > Tools and start the e-mail autopilot.  

 

▪ Through the "Action" menu or the corresponding buttons, the check can be started, 

ended or paused. The current script status can be seen in the status bar. 

▪ The program window provides information about statistics (edited, deleted and 

forwarded e-mails), the status (next cycle, start) and the script outputs. 

▪ You can also start the E-mail Autopilot as a service. To create the service enter the 

following command in the command prompt (cmd.exe) as an Administrator: 

sc create eMailAutopilot binPath= "<Path to the application>\cuep04.exe"  

DisplayName= "combit eMailAutopilot" 

Now the service can be started and ended in the Windows services. Possible error 

message will be listed in the EventLog. 
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Attention: The configuration must be setup with the same user and computer under 

which the service is running. Otherwise the E-mail Autopilot cannot locate the 

configuration file in the standard directory 

(C:\Users\<User>\AppData\Roaming\combit\cRM). 

E-mail autopilot settings 

The settings can be found under Settings > Settings. 

General 

▪ Program start: Define the status when the program is started (started, not started, 

paused) and whether the e-mail autopilot starts with Windows.  

▪ Scan-settings: Define the waiting time in minutes before the e-mail account is 

checked again.  

▪ Logging: Enter the directory of a log file if you activate the logging of activities. 

Mail service 

Select the mail service (Simple MAPI, Extended MAPI, POP3/SMTP, IMAP/SMTP) of the 

e-mail account to be checked for messages.  
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▪ When using Simple MAPI and Extended MAPI you can enter the log-in details of the 

user profile to be used (user name, password).  

▪ When using POP3/SMTP or IMAP/SMTP enter the user information (user name, 

password) and server data (URL or IP address of the POP3-/IMAP- and SMTP server) 

under "Configure". Usually, you can copy this data from the configuration dialog of 

your e-mail program.  

▪ When using IMAP/SMTP, Simple MAPI or Extended MAPI, you can also set whether 

all messages in the inbox or only unread messages are to be searched. 

E-mail subject 

Define for which e-mail subject the autopilot is to search for in the inbox. An e -mail 

forwarding address and a script file can be defined for each subject. With the checkbox, 

the search for each e-mail subject can be activated.  

With the "New" button, the subject search can be configured: 

 Enter the e-mail subject for which the e-mail autopilot is to search in the inbox. 

Under Mode, the different search mechanisms are available:  

▪ Identical: The subject must be exactly the same as the entry. Not case sensitive. 
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Example: If the subject of the eMail in the inbox is "Re: Newsletter 5", you have 

to specify following subject to search: " Re: Newsletter 5". 

▪ Wildcard: You can use wildcards in the definition of the e-mail subject: "*" (any 

number of characters) and "?" (one character). 

Example: If the subject of the eMail in the inbox is "Re: Newsletter 5", you have 

to specify for example following subject to search: "*Newsletter*". 

▪ Regular expression: The recognition is carried out through text analysis of the e-

mail subject with the help of regular expressions.  

Example: If the subject of the eMail in the inbox is "Re: Newsletter 5", you have 

to specify for example following subject to search: "(AW)|(Re)\: Newsletter [0-

9]+" 

 Define the action that is to be carried out when an e-mail with the subject defined 

above is found.  

▪ Select the script that is to be run. 

▪ In the "Forward to" field, an e-mail address can be given, to which the e-mail is 

forwarded after processing. The forwarding is initiated in the script.  

Script objects 

When starting the script, a mail object is made available with which each e -mail can be 

accessed. With this, it is possible to analyze the e-mail. Further information can be found 

in the programming reference Object model (COM). You can define more applications to 

be available as objects in the scripts with the "New" button (e.g. combit Relationship 

Manager). The objects can be activated with the checkbox. 

With this, it would be possible to access cRM to create a new record or amend field 

contents, for example. When you select "other application" the type (ProgID) can be 

defined. The script objects defined here are primarily for improved performance when 

editing several e-mails, since the defined object is only added once and is transferred 

every time the script is run. With combit Relationship Manager and address manager 

type, the application object is available. The sample script "eMailAutopilot.vbs" stores an 

email recognized by the Email Autopilot as an .eml file in the "Activities" view. 

Encryption 

In the "Password" field, a password can be entered with which received e -mails can be 

decoded. This is relevant when you are sending address information over the internet 

and must encrypt for data protection reasons. Further information can be found under 

"Options (text e-mail only)" in this chapter. 
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17. Workflow Designer 

With the help of the integrated Workflow Designers, sequential (corresponding to a 

normal flow diagram) workflows in progress can be created visually. For System 

Requirements refer to chapter "Preparation and Installation". 

Note: This function requires the Professional or Enterprise Edition. 
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A workflow is a predefined sequence of activities. The objective here is a possible 

(partial) automation of the execution, such as a reading out of the telephone number of 

the current record and start a call. 

The subsequent activity is ideally determined by the output of each of the preceding 

activities. Repetitions (loops) or branches (if/then) can also be executed. 

 To create a new workflow, select Settings > Workflows > New.  

 To open an existing workflow, select Settings > Workflows > Edit. 

 A workflow can be started via Settings > Workflows > Execute , Start > Script &  

Workflows > Execute Workflow, an event, a button of the type "Execute  workflow" 

or a content link. 

Workflows are technically based on the workflow foundation of the Microsoft .NET 

framework. Through this standard, other workflow foundation activities can also be 

integrated in cRM workflows and cRM activities can also be incorporated in external 

workflows (as long as they are also based on the workflow foundation). cRM workflows 

can also be created in the Microsoft Visual Studio 2008 (with the exception of the 

Express Edition) and tested (incl. debugging). 

17.1 cRM activities 

An activity is the smallest execution unit in a workflow. This activity has certain 

properties. 

In the Workflow Designer, the activities are available in the tool window "Activities". 

These activities perform a certain  action in the cRM. The way they behave is determing 

by the setting of the properties. Through the graphic visualization of the sequence, the 

way the workflow functions is quickly visible.  
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You may select from the following activities among others: Archive document, Dial, 

Update view, Print records, Export records, Filter, For each record, Undo filter, Import 

records, Read field content, Delete record, New record, New relational record, Open 

view, Close view, Write field content, Send e-mail, Save record, If Else, Show message 

dialog. A detailed description of all activities and their properties can be found in the 

additional workflow documentation in the document directory.  

The system.* activities are Microsoft-specific activities. For more information, see section 

"System activities". 

The first activity of a workflow 

A workflow can work with those records that are visible in an open view. After the start, 

use the activity OpenView and then create a filter with the activity F i l ter. 

Alternatively, a workflow can also be created with visibly opening a view. Use the activi ty 

CreateRecordSet . If neither of the two activities is used, the workflow works with the 

current record. 

Insert activities 

Activities can be moved from the activity list and inserted in the work area by drag & 

drop.  

 Select the desired activity and drag it to the work area while pressing the left mouse 

key. 

 Release the mouse key once the activity is positioned at the desired location. Valid 

insert positions are indicated by a green picture. 

 An activity can also be moved by drag & drop. 
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 To delete an activity, select "Delete" in the respective context menu. 

Properties of an activity 

In the tool window Properties, the properties of the individual activities are shown. When 

an activity is selected, the global properties of the workflow can be defined. Be low the 

list, there is an area in which a descriptive text is shown for each property selected. 

The sorting of the list is set by clicking on the buttons "By category" or "Alphabetically". If 

you are sorting by category, each category contains properties that can be combined 

back into groups. Categories and property groups can be opened and closed for a better 

overview.  

The properties are different for each activity. However, there are many features that are 

common to all activities. These properties are now described here. A detailed description 

of all activities and their properties can be found in the additional workflow 

documentation in the document directory. 

 

The general properties are found under the heading "Activ i ty ": 

▪ Name: If you add a new activity to the work area, the activity name is set as the 

name in the properties list (e.g. "Filter"). However, if you have a larger number of the 

same types of objects in your project, these names can quickly become confusing. 

Therefore, you have the option of giving activities a new, meaningful name via the 

properties list (e.g."FilterNewsletterSubscribers"). The name must be unique within 

the workflow. 

If the name of an activity is changed, existing connections to subsequent 

activities may, in some cases, become invalid. You can recognize this by the red 

validity error symbol. These connections must then be reset. 

▪ Type: Enter the basic type of the activity. This information is only needed for system 

activities. 
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▪ Activated: Specify if the activity is enabled or not. If an activity is not enabled it will 

not participate in the execution and validation. This function is the particularly useful 

if certain activities are to be deactivated for testing purposes. 

▪ Description: You can enter a description of the activity here.  

Under the heading "(Input) Parameter", configure the necessary parameter of the activity, 

e.g. a filter expression with the activity "Filter".  

With some activities, the existing heading "Result" contains corresponding results of the 

respective activity, e.g. a readout of field content for the activity "Read field content". This 

result can then be passed on to a subsequent activity. 

The (input) property of an activity can be the result of a previous activity.  

Connect property to a fixed value 

Modified properties appear in bold. To change a property, click in the values column. For 

fixed, predefined values, the value is input via a combo box.  

With some properties, a connection dialog is available. You can reach it by selecting the 

property group and clicking on the button "...". In the lower part of the dialog, the value 

can be selected by clicking on another button "...". For database fields, you enter the 

physical field names here. 
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The placeholders %PRJDIR% (cRM project directory), %APPDIR% (cRM installation 

directory), %USERDIR% (Windows user directory) and %TEMPDIR% (local Windows 

temp directory) are supported. 

Example: Print the current record using a print template 

 In the Workflow Designer, select F i le  > New. 

 Drag the activity PrintRecord onto the work area. Release the mouse key once the 

activity is positioned on the link from Start to End. 

 In the tool window "Properties", select a print template (e.g. with the file extension 

*.crd) suitable for the view for the property "Print template". The connection dialog 

for this is available by clicking on the button "...". In the lower part of the dialog, you 

reach a file selection dialog by clicking on another button "...". 

 Enter the value "PDF" for the property "Output medium" so that a PDF file is created 

as a result. By clicking on the button "...", a selection dialog with all available print 

destinations is provided by clicking on another button "..." in the connection dialog. 

 In order for the PDF file to be created, enter a file name incl. file extension and 

directory path for the property "Output file". 

 Start the workflow in the view via Start > Script & Workflows > Execute Workflow. 

Connect property to the result of a previous activity 

A result of an activity can be transferred to a subsequent activity, the property of an 

activity can result from the result of a previous activity.  

When adding or changing an activity, you usually try to make a correct, automatic link 

between the result and value of a parameter. However, the links can also be made 

manually. Proceed as follows: 

 Select the respective property in the property list and open the connection dialog by 

clicking on the button "...".  
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 Select the value of the corresponding previous activity in the treeview in the upper 

part of the dialog. 

Example: Select the telephone number of the current record 

 In the Workflow Designer, select F i le  > New. 

 Drag the activity ReadFie ldContent  onto the work area.  

 In the tool window "Properties", enter the field names of the telephone number, e.g. 

"Phone", for the property "Field name". The value that is read out is automatically 

written in the property "Value". 

 Drag the activity Dial  onto the link below the activity ReadFie ldContent. 

 In the tool window "Properties", enter the value (the result) of the previous activity 

"ReadFieldName" for the property "Number". Open the connection dialog by clicking 

on the button "...". In the upper area of the dialog, open the treeview and select the 

property "Value" of the activity "ReadFieldContent".  

 Start the workflow in the view via Start > Script & Workflows > Execute Workflow. 

17.2 cRM Workflow 

The workflow is saved as an .XML file. If conditions are made, they will be saved in a 

.RULES file with the same name. 
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Properties of the workflow 

The properties of the workflow are displayed in the tool window Properties if no activity 

is selected. Below the list, there is an area in which a description text is shown for each 

selected property. 

The following properties are available: 

▪ Name: Give the workflow a new meaningful name. This name will also be displayed 

in the properties dialogs. 

▪ Activated: Specify whether the workflow is activated. If it is not activated, it will not 

be executed. 

▪ Basic class: Specifies the basic class of the workflow. This can not be changed. 

▪ Description: Description for the workflow.  

▪ Session: This information is necessary to be able to access the COM object. No 

changes can be made at this point. 

 

▪ Variables: You can define global variables that are available in the overall workflow. 

These global variables can be used to "temporarily park" values that change and are 

to be used in the workflow later. To connect these workflow variables to the result of 

an activity, click directly on the yellow database symbol in the properties list. 

Validity check 

The Workflow Designer tries to check the validity and marks errors and missing values 

with a red circle with an exclamation mark to the corresponding activity. However, no 

syntax check is performed, in other words the correct spelling or the existence of a field 

name, for example, is not checked. 
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The validity errors are also displayed with the respective property in the form of a red call -

up character in addition to the yellow database symbol in the properties list. 

 

Workflow with loops and branches 

The activities ForEachRecord and CustomIfElse  are available for branches and loops. 

If you add the activity ForEachRecord to the workflow, all activities within this activity are 

repeated for all records in the current record selection. 

If you add the activity CustomIfElse  to the workflow, a normal if-then branch is created. 

For each branch, a container "IfThenBranch" is automatically inserted, in which the 

activities to be executed for this case are positioned.  

Any number of branches can be added at the same level. This is done by right-clicking on 

the CustomIfElse activity and selection of "Add branch" in the context menu. The clarity in 

the Designer is improved if you use the function "Collapse" in the context menu. 

The first branch the condition of which is met is executed. If an "empty branch" (without a 

completed operator) is present, it is executed if no other branch has been executed. 
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If you select an IfThenBranch, you can define the condition for this branch in the 

properties list. By clicking on the button "...", a selection dialog with all available operators 

is provided by clicking on another button "..." in the connection dialog. 

Enter the reference value directly in the properties list or select it via the connection 

dialog as well, as long as it is a result of a previous activity. 

 

Example: Send a letter or an e-mail for each record depending on field content 

 In the Workflow Designer, select F i le  > New. 

 Drag the activity CreateRecordSet  onto the work area.  
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 In the properties, select the view name, e.g. "Persons". By clicking on the button "...", 

a selection dialog with all available views is provided by clicking on another button 

"..." in the connection dialog. 

 Drag the activity ForEachRecord onto the link below the activity CreateRecordSet. 

The activity OpenCurrentRecord is automatically created. 

 Drag the activity ReadFie ldContent  onto the link below the activity 

OpenCurrentRecord.  

 In the properties, enter the field names with content to be read out, e.g. 

"ComPreference". 

 Drag the activity CustomIfElse onto the link below the activity ReadFieldContent. An 

if/then branch is automatically created. 

 In the properties of the left IfThenGeneral branch, you then specify the condition, i.e. 

you select "is equal to" as the operator and "e-mail" as the value. 

 Drag the activity SendEmail  into this branch. 

 For the activity SendEmail  , select a mail template (with the file extension *.mtpx) 

that is suitable for the view as an "E-mail template" property. By clicking on the 

button "...", a file selection dialog is provided by clicking on another button "..." in the 

connection dialog. 

 In the properties of the left IfThenGeneral branch, you then specify the condition, i.e. 

you select "is equal to" as the operator and "Letter" as the value. 

 Drag the activity PrintRecord into this branch. 

 For the activity PrintRecord , select a print template (e.g. with the file extension *.crd) 

that is suitable for the view as a "Print template" property. By clicking on the button 

"...", a file selection dialog is provided by clicking on another button "..." in the 

connection dialog. 

17.3 System activities 

The system activities System.FaultHandler, System.IfElse, System.Policy, 

System.Sequence, System.Suspend, System.Terminate, System.Throw uad 

System.While are specific activities in the workflow foundation of the Microsoft .NET 

framework. They are necessary for special workflow functions. 

Workflow with the universal rule editor 

With the activity System.Pol icy (universal rule editor), extremely complex workflows can 

be created because they can be defined directly in the rule editor.  

An individual rule (from which any number can be summarized in one set of rules) always 

arises from the parts If, Then and Else. This rule is saved as a .rules file. 
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Complex conditions and instructions can be entered in the input fields. The properties of 

activities can be queried and set. You can query the value of a global variable using the 

command "this.GetWorkflowVariableValue ("<Variable name>") and change the value 

using the command "this.SetWorkflowVariableValue ("<Variable name>").  

The rule-based processing of the workflow foundation is very comprehensive. For 

advanced options (forward processing, repeat rule execution, etc.), you should here refer 

to the literature on the subject and the messages found on the Internet for the keyword 

"Policy activity". 

Ending workflow in a controlled manner 

With the activity System.Terminate , a workflow can be ended at any point in a controlled 

manner. A message text can be displayed. This makes it possible to end the workflow by 

achieving a certain state. Naturally, it can also be achieved with activities in the fault 

handler, however the corresponding entries in the fault handler view must also be made.  

Fault handling 

An activity System.FaultHandler  can be assigned to the total workflow and each 

sequential block of activities. This is not a normal activity. It is more like a workflow fault 

view, i.e. you can define activities if there is a fault, e.g. display a message dialog. 

Since each sequential block of activities can be assign its own fault handler activity (and 

not only to the overall workflow), it is possible to implement hierarchical fault handling. In 

certain situations, a complete break in the current workflow instance when there is an 

exception is not necessary or desired. After the fault handler's activity has trapped the 

affected exception, the workflow execution can then be continued with the following 

activity.  

For the fault handling, proceed as follows: 

 Create an activity block with the activity SequenceActivi ty .  

 Open a fault handling dialog by right-clicking on an activity block and selecting 

"Display fault handler ". 

Tip: To create a fault handling for the entire workflow, open the fault handling dialog 

by right-clicking on the green start symbol. 
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 Drag the activity System.FaultHandler in the activity FaultHandlersActivi ty  onto the 

text "Place FaultHandlerActivi ty here ". 

 

 Under the property "FaultType", select the exception which is to be reacted to here. 

Clicking on the button "..." takes you to a dialog in which all available standard .NET 

exceptions are available. For cRM activities, always select 

System.ArgumentNul lExce ption in the assembly mscorlib. 
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 The activity that is to be carried out in the case of a fault is still missing. Drag the 

desired activity (e.g. ShowMessageWindow) in the activity faultHandlerActivi ty  onto 

the text "Place activities here". 

 

 The type of the fault is fixed by the System.ArgumentNul lException . However, the 

fault message can be read out by connecting to this FaultActivity and thus be issued, 

e.g into a message window. 

 

 If necessary, drag an additional activity System.FaultHandler  in the activity 

faultHandlersActivity  into the white input field. By clicking on the blue arrow buttons 

you can switch between the different fault handler activities. 
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This fault view serves as a container for any number of Fault Handler activities. Each 

of these fault handler activities is responsible for handling exactly one exception and 

can accept any number of other activities. These activities are executed when the 

corresponding exception appears in the workflow. You must make sure that this 

processing takes place in a completely asynchronous manner. For advanced 

workflow, there is, among other things, the option of letting multiple branches be 

executed simultaneously. Then it would be possible that multiple exceptions could 

occur at the same time, which would then also handled at the same time. 

 By right-clicking on the activity block and selecting "Display sequence", you go back 

to the Workflow view. 

 

Example: Show message window when field content empty 

 In the Workflow Designer, select F i le  > New. 

 Drag the activity SequenceActivi ty  onto the work area to create an activity block.  

 Drag the activity ReadFieldContent  in the activity SequenceActivi ty  onto the text 

"Place activities here".  

 In the tool window "Properties", enter the field names of the telephone number, e.g. 

"Phone", for the property "Field name". The value that is read out is automatically 

written in the property "Value". 

 Drag the activity Dial  onto the link below the activity ReadFie ldContent. 

 In the tool window "Properties", enter the value (the result) of the previous activity 

"ReadFieldName" for the property "Telephone number". Open the connection dialog 

by clicking on the button "...". In the upper area of the dialog, open the treeview and 

select the property "Value" of the activity "ReadFieldContent".  
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 Open a fault handling view by right-clicking on an activity block and selecting "Display 

fault handler ". 

 Drag the activity System.FaultHandler in the activity FaultHandlersActivi ty  onto the 

text "Place Activi t ies here ". Under the property "FaultType", select the exception 

which is to be reacted to here. Clicking on the button "..." takes you to a dialog in 

which all available standard .NET exceptions are available. Select the exception 

System.ArgumentNul lException  from the assembly mscorlib. 

 The activity that is to be carried out in the case of a fault is still missing. Drag the 

activity ShowMessageWindow in the activity faultHandlerActivity onto the text "Place 

activities here", and enter a message text, e.g. "No telephone number available". 

 Open the Workflow view by right-clicking on the activity block and selecting "Display 

sequence". 

Run fault handling in a controlled manner 

There may be cases where you want to branch out into this sort of fault handling routine. 

For example, an external query within an activity has not provided the desired result and 

the workflow can there not be executed further at that point. For this, there is the activity 

System.Throw. This allows the entry of the exception type to be triggered, as with the 

activity described above, System.FaultHandler . 



Support for scripting functionalities 

271 

18. Scripts and programming reference 

A powerful object model is available to you, which allows access to the views, telephony, 

appointment management and much more. With the help of scripts you can activate this 

object model and with it automate many routine procedures. 

Note: A detailed description of the properties and methods of the object model can be 

found in the program group of the cRM under "Programming reference". This 

additional information also includes some application examples for scripts. 

Even special functions that are not already built-in can be easily integrated like this. 

Scripts can also communicate with other programs and use their functionality as long as 

they offer the correct interface. 

Note: A script is a series of instructions that are undertaken sequentially when the 

script is run. The instructions are from the "Vocabulary" of a particular script language. 

This instruction set defines which possibilities are offered by the language and how a 

script must be composed.  

Scripts are generally not very large and can produce impressive results with few 

commands. An average script may have around 20 to 40 lines of instructions. This is one 

reason why script languages are usually very easy to learn. 

Although very similar on the surface, there are many important differences between 

scripts and executable programs. 

Scripts are not capable of running on their own but always require an environment to run 

in. These hosts are responsible for managing the scripts and often extend the 

possibilities of the language in the form of additional objects. 

In our case, cRM is the host; an extension is made through its object model. Another 

important difference is the missing possibility of implementing dialogs yourself. For this, 

external objects are required. 

18.1 Support for scripting functionalities  

The possibilities of the scripting technology are very far-reaching and their description 

could easily fill its own book. We therefore hope you understand that we cannot offer a 

description of the script languages. Books on these can be bought from many large 

specialist publishers. 
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Microsoft offers a detailed reference on VBScript and Jscript in the internet: 

http://msdn.microsoft.com/scripting. Individual questions can be exchanged on one of 

the many Microsoft newsgroups (news://msnews.microsoft.com). 

Of course we want to help and support you with your questions and requests to allow 

you to use our product to its full potential, however we hope for your understanding 

that we can only respond to questions about the object model. We cannot help with 

models of other products or the script languages themselves. 

18.2 Supported script languages  

 Basically, all script languages of theWindows Scripting Host are supported. The most 

common are VBScript and JScript, which are offered directly by the producer Microsoft. 

There are other types too, such as Python. The selection of the language is made with 

the file extension, e.g. "vbs" for VBScript and "js" for JScript 

Note: VBScript and JScript are usually already installed on your system. If not or if 

other languages shall be used, they must be taken from the respective manufacturers 

and installed on the system according to their instructions. 

18.3 Integration of scripts 

The integration of scripts using buttons is possible (Script direct, Script file, Function 

definitions) within the input form, using the command Start > Scripts &  Workflows > 

Execute  Workflow or by using events. 

A description of how the scripts are placed there can be found in the associated chapters 

in this manual. You can decide whether the script is entered directly or whether you wish 

to write it in the form of an external text file. Especially for larger scripts, the latter is a 

better choice since this makes re-using it in another situation easier. 

18.4 Script extension 

These script extensions only apply to internal scripts, i.e. to scripts that are run using 

buttons within the input form through the command Start > Scripts &  Workflows > 

Execute  Workflow or through events. 

Embedding scripts within scripts 

For commonly used functions, it makes sense to store these in a central location so that 

any necessary changes affect all scripts based on them. For this, the embedding of 

scripts is supported with a special instruction of the following form: 

http://msdn.microsoft.com/scripting
news://msnews.microsoft.com/
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<!--#include file="c:\scripts\include.vbs"--> 

The instruction is replaced by the contents of the stated file. To avoid possible syntax 

errors, it is recommended to place the instruction on its own line. 

Note: All scripts embedded in this way must use the same script language as the 

main script. A mixture of several languages is not possible and leads to syntax errors. 

If you have saved your scripts within the program directory, you can use the %APPDIR% 

variable rather than stating an actual directory:  

<!--#include file="%APPDIR%\include.vbs"-->  

Tip: The variable %APPDIR% is also available in other parts that support scripts, e.g. the 

input form, the function definitions and within the toolbars. 

%APPDIR% can be used as a placeholder that is replaced by the path of the application 

by the program, e.g. C:\Program Files\combit\cRM\. 

%PRJDIR% is replaced by the path of the project in the same way. 

Synchronous and asynchronous scripts  

Since the areas of application of scripts are extremely varied, two different types are 

available. 

Synchronous scripts  

A synchronous script stops the host until it has been worked through completely. If, 

however, you carry out longer operations within a script, you cannot work with the 

program for the entire time. 

Synchronous scripts are therefore useful for processes that are in context to the work 

currently being undertaken, such as the automation of several smaller routine procedures 

like a filter with a subsequent export. Every script that is not marked differently is 

automatically a synchronous script. 

Asynchronous scripts  

This type of script is run in parallel to the host, so you can work with it at the same time. 

For this, a so-called "Thread" is opened. In this way, the host is not blocked while the 

script is being executed. 

We recommend the use of asynchronous scripts for longer-lasting scripts that are not 

directly in context with the work being undertaken, such as the control of another 

application. 
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For a script to be carried out asynchronously, it must contain the following instruction in 

the first line: 

<!--#pragma asynchronous-->  

 (Longer) asynchronous scripts should take care of being able to be interrupted and for 

this they should regularly check the value of the terminate property. Further information 

regarding this can be found with the help function in the object reference. 

Scripts and the edit mode 

If a script is to be started on the click of a button in the input form without a save 

request, the following instruction must be contained in it: 

<!--#pragma keepeditmode--> 

In this way the save request is suppressed and you stay in the edit mode. 

Encryption of scripts 

If a script contains the command 

<!--#pragma encrypted--> 

it is encrypted from this point until the end.  

Select Tools > Scripts > Encrypt to encrypt the script code from this line onwards. With 

this, part of the script can remain editable so that certain parameters or variables can be 

changed but the rest of the script is protected.  

User rights  

There are user rights that set whether a user may run scripts. More about this can be 

found in the chapter "System management". 

External access  

With the exception of the WScript object, the range of functions of the object model is 

available outside cRM scripts too. For example, you can code an application that takes 

your files from cRM and edits them in some way, then replaces them in the same 

location. 

For access you require only one instance of the application object. The so-called ProgID 

of the application object is called "cRM.Application". More about this can be found in the 

additional object model information mentioned previously. 

The instancing is generally done with a CreateObject command (Late Binding). The 

available options as well as the exact syntax depend on the programming language used. 

Corresponding advice can be found in the respective documentation. 
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19. Input form designer 

With the input form designer you have the possibility of designing the input form of the 

views. You can create a completely unique software interface based on your 

requirements and preferences. 

Every input form can be made up of up to 19 consecutive tabs. Each tab  has a strip with 

which it can be brought to the front (the first 9 also with ALT-1-9). The desired fields, 

buttons, etc. can be distributed between the various tabs as required. 

Note: Input forms are always saved with the file extension .DLI. For every view, there 

is one DLI file. These are stored in the same directory as the project file. 

19.1 Editing input forms 

In the following section you will find a description of how you can edit input forms or 

create them from scratch, and insert the desired fields and buttons. If you are not familiar 

with the input form designer, we recommend you read this chapter before designing an 

input form. 

Open the input form designer with Settings > Input Form .  

▪ For new input forms the suggested size for the tabs is based on the screen area 

available to the main window at the time. For this reason it is recommended to go to 

full-screen mode when you run the input form designer. 

▪ Customize an input form: Usually it is easier to customize an existing input form from 

another view, rather than create a new one from scratch. To do this, go to the 

command Input Form in the input form designer. Now decide whether you want to 

adopt the entire input form, or only certain field functionalities. Then select the form 

file you wish to adopt. 

▪ Saving an input form after editing: With Input Form > Save  you can save the form 

after making changes.  

▪ If you wish to leave the input form designer, select Input Form > Exit. 

About Settings > Input Form > Input Form WebAccess you can customize 

a special input mask for the WebAccess. 

19.2 Workspace and tools 

The window of the input form designer is divided into different sections, whose functions 

will be explained later. 
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▪ Customize the interface: First, we would like to show how you can customize the 

interface of the input form designer regarding the size and position of the various 

sections, so you can keep a good overview of proceedings. You can place the tool 

windows (tabs, field selection, sort order) as well as the toolbar anywhere in the 

input form designer and thereby also set the size of your workspace. 

By clicking and holding the title bar of a window you can move it freely. The window 

can be "docked" again by releasing it in the desired place at the edge. Where and in 

what size the window is placed or docked can be seen from the grey frame you are 

shown as long as you are holding the window with the mouse button. You can move 

the toolbars in the same way by picking them up in the dotted area and releasing 

them in the desired location. If you place two windows in the same place, these will 

simply be docked together and will take up less space. With the tabs at the bottom 

edge of the window you can switch between them. 

 

▪ Workspace: The workspace is the area of the input form designer in which you 

create the input form. It always displays one tab of the input form. The tab currently 

being edited can be seen in the tab overview. If you are creating an input form from 

scratch, the workspace will at first be empty. 

▪ Tabs: All defined tabs are listed here. By clicking on them in the list, the selected tab 

will be shown in the workspace. Here you can also make various settings for the 

tabs. The page "(Dialog)" has a special position. With this you can influence the 

general size of the individual tab pages. Additionally, you can place objects (fields or 

buttons) outside of the actual tabs. 
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▪ Select Fields: In this list you can select the type of object that is to be inserted into a 

tab. For every object type the different insertion options are listed in the specific 

selection, e.g. database fields or functions. The selection is made easily by drag & 

drop, and the field of the function then simply has to be placed in the desired 

location on the tab. 

▪ Input Order: All fields inserted in the workspace are listed here in the tab-order and 

can also be edited from here. By clicking a listed field, this is automatically 

highlighted in the workspace in the corresponding tab. 

▪ The status bar: In the status bar you are given information about the current position 

of the cursor or the currently selected object (field). In the left part of the status bar, 

the position of the cursor is displayed in "dialog units" rather than "pixels". The value 

in front of the comma is the distance from the left edge of the workspace and the 

value after the comma is the distance from the top edge of the workspace. 

In the right section of the status bar you will find further information regarding the 

selected objects. From left to right you will find the object type, object name, object 

coordinates and object size. If several objects are selected, you will be shown the 

number of selected objects as well as the coordinates and the size of the frame that 

surrounds the objects. 

19.3 Tabs 

Use several tabs to keep a better overview of your input form. You can create a tab for 

master data and e.g. one for sales and one for contacts.  

The Main tabbed pages are managed in the tool window "Tabs". Each main tab can also 

contain objects of the type "Tabbed pages". 

All fields and buttons, whose functions are to be independent of the individual tabs (e.g. 

the master data) can be positioned outside of the tabs (entry "(Input form)" in the tool 

window "Tabs"). Objects of the type "Tab" can also be positioned outside of the main 

tabs. 

Define Main tab 

Before you define the individual tabs for the input form and fill these with fields, you 

should decide on the general layout (size and position of the tabs of the input form on the 

screen). The screen area available for the input form corresponds to the workspace 

available in the input form designer. 

Generally it is recommended to make the general page size as large as possible, because 

the individual tabs will have more space for the database fields. To conclude that the 

maximum size is always the ideal would be wrong in most cases, however. There should 

normally be space for various buttons or fields in the input form next to the tabs.  
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Note: If you doubleklick the entry "(Input form)" in the "Tabs" window, you will access 

the general layout settings. 

 

The page template generally starts at the top-left of the 

workspace. To change its size or position, click 

anywhere in the page template to select it. With the 

selection frame you can set the size and position of the 

page template. 

▪ Move tab: The created tabs appear in a certain 

order in the input form. This order corresponds to 

the sequence in the tab overview. To move a tab to 

another position within the sequence, click on the 

corresponding tab In the tab overview and move it 

to the desired location with the two arrows in the 

same window. 

▪ Create new tab: By clicking the symbol "Add new 

page" in the tab overview, you can create a new 

tab. With this, a new, empty page is added to the 

end of the tab list. Newly created pages at first 

carry the name "Page" and a consecutive number. 

The new tab inherits the properties of the selected 

page or the previous tab. 

▪ Delete tab: Click the tab in the tab overview and then press the "Delete" button. After 

confirming a dialog, the tab will be deleted from the input form. 

▪ Move tab: The created tabs appear in a certain order in the input form. This order 

corresponds to the sequence in the tab overview. To move a tab to another position 

within the sequence, click on the corresponding tab In the tab overview and move it 

to the desired location with the two arrows in the same window. 

▪ Position tabs on tabs: In order to position tabs on main tabs or multiple tabs next to 

one another in the input form, use the object "Tab". For more information, see section 

"Specific object properties". 

Tab properties 

Click the tab in the tab overview and then press the "Properties" button or double -click on 

the Tab Color of the corresponding tab in the tab overview to open the properties dialog. 
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▪ In the "Tab" area, enter a name for the tab.  

▪ If this tab is empty, no tab is displayed, e.g. when the view only consists of one 
tab. 

▪ When you enter a "+" as the first character, this tab and the following tabs are 

brought forward by a layer. 

With this, the amount of space on the tabs is reduced. So that the available 

space is displayed, you must close the input form designer and open it again. 

▪ To make the interface more clear, different colors and icons can be assigned to 

the strips of each tab.  

▪ With clicking the combobox "Color", you can set the color. 

▪ In the "Icon" field, various pictures are available. With the "fixed file" item, you 

can select an image file. 

▪ Also you can change the background. You have different possibilities: 

▪ Insert or embed a picture. 

▪ Select the intensity (doesn't work with all file types). 
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▪ Placement indicates, where the picture is to be placed: On input form page 

stretched, fill input form page (tile picture if necessary), left/right and/or 

above/down. 

▪ Filling: You can select a gradient with up to three colours or select the system 

standard. 

▪ Appearance condition: You can specify a condition for the visibility of a tab. This can 

be used, for example, to display a whole group of fields only to certain users or only 

if a field within a record has a certain value. 

19.4 Inserting fields and buttons 

In the input form designer, objects always have a rectangular shape and are enclosed by 

a frame with which their size and position can be changed. This frame represents the 

space that the object takes up in the workspace and therefore the maximum size to 

which the contents of an object can expand. 

Objects may overlap completely or partially, and the overlapped object may be covered. 

Object defaults 

For every object type you can set certain default settings that become active when 

inserting such an object. By selecting appropriate default settings you can save time 

when inserting and configuring objects. 

For the object settings, there are three hierarchical levels: 

Leve l  1  - G lobal  font setting: Applies to all objects in all tabs. Only font settings are 

possible for global default (Level 1) because all objects do not have the same color or 

appearance properties. The global font setting can be selected with the command 

Settings > Default Font .  

Level 2- Object type-specific settings: Applies to all objects of a certain type. The defaults 

for the individual object types (Level 2) can be set in one and the same dialog. This dialog 

can be opened with the command Object > Defaults . For every object type a tab is 

available. To change the default settings for a certain object type, click on the desired 

tab. Click through the tabs in which you wish to change settings. The input form designer 

remembers all changes you make. The changes affect all newly inserted objects as well 

as existing objects that are not locked or manually changed. 

Lebel 3 - Object settings: Applies only to the one, currently selected object (Edit > Edit 

Object) 

The global font setting (Level 1) and the object type-specific settings (Level 2) are 

defaults, while the object settings (Level 3) can only be set retrospectively for existing 

objects. If you make settings on the different levels, the settings for the higher level 
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always apply (1 > 2 > 3). With the button "Defaults" You can revert the settings of a level 

(e.g. Level 2) back to the value of the next highest level (e.g. Level 1).  

 

Default settings as style sheets 

Levels 1 and 2 can be used as style sheets. As long as you have not set individual 

properties for objects on level 3, you can easily change the properties of all objects in 

retrospect by making the corresponding default settings on levels 1 and 2. 

To use this possibility efficiently, it is recommended that you consider the following first: 

▪ What font options are generally to be used for objects? These font options should 

then be set as default for level 1 under Settings > Default Font .  

▪ Which settings should be used for the majority of the various object types? These 

settings should then be made under Object > Defaults for every object type.  

Individual settings that only apply to single objects only need to be, and should only be 

made where a single object deviates from these defaults. If you later decide that you 

want all text objects to use a different font after all, you do not have to individually 

change the properties of all the text objects. It suffices, in this case, to change the font 

for text objects generally under Object > Defaults and all text objects will automatically 

be given the new font. 
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Locking settings 

It is not always desirable to change all objects if you change something in the default 

settings retrospectively. For this reason it is possible to lock the properties of individual 

objects to stop them being affected. To do this, select the objects whose properties you 

wish to lock. Then select the command Object > Lock Properties. You now have the 

choice of locking font or color settings (or both). 

Inserting objects 

There are two processes in which objects can be inserted. Either by using the menu 

Object > Insert , the toolbar or by drag & drop (recommended). 

Inserting objects with drag & drop follows this procedure: 

 Select the desired object type. The mouse pointer will change to a crosshair. 

 Place the crosshair on the point at which a corner of the object should be placed. It 

is best to use the left upper corner of the planned object. Depress the left mouse 

button and pull – while keeping the mouse button depressed – to the opposite 

corner of the planned object. If you started in the upper left corner, pull the crosshair 

to the lower right corner of the planned object. A dashed frame will appear which 

represents the size that the object will assume upon release of the left mouse 

button. 

 Release the mouse button when the object (dashed frame) has the desired size. 

 Afterwards set the desired properties for the inserted field. 

Edit objects 

▪ If you have selected more than one object you can arrange the selected objects 

relatively to each other, align them according to their size and change the properties 

they have in common. 

▪ Up to 10 changes can be undone in the input form designer with the command Edit 

> Undo. The changes relate to a single tab, which means each tab has its own undo 

function. If you have undone an action without meaning to, you can revert to the 

previous state with the command Edit > Redo.  

▪ Deleting objects: Select the objects you wish to delete and then choose Edit > 

Delete, or press the DEL key. All selected objects are deleted. 

▪ The clipboard is also available to you in the input form designer for the editing of 

objects. With the clipboard you can cut objects, copy them and paste them again. In 

this way objects can be moved from one tab to another. The exchange of objects 

between different input forms is also made possible. The corresponding commands 

for using the clipboard (cut, copy, paste) can be found in the Edit menu. 
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Selecting objects 

To select a single object, use one of the following procedures: 

▪ Click on the object with the mouse. The object selected is that whose edge is 

closest to the cursor. To edit its properties directly, right-click the object. 

▪ In the "Input Order" window, click on the corresponding object. With a double-click 

you will open the "Properties" dialog for this object.  

▪ While holding the left mouse button, drag the cursor over the object you wish to 

select. A thin frame will appear while doing this. Release the mouse button when the 

object to be selected is completely enclosed by the frame. Objects that are only 

partly enclosed and not selected. 

▪ To select multiple objects at once, hold the SHIFT key and click the objects to be 

selected one after the other. Altrnatively drag over the objects to be selected with 

the mouse. All objects that are completely enclosed by the selection frame will be 

selected. Objects that are only partly enclosed are not. 

Select the command Object > Select  for more options: 

▪ To select all objects on the workspace at once, use the command Select Al l .  

▪ Select Invert Se lection . "Invert" means that all objects that were previously not 

selected are now selected, and all those that were selected are now not. 

▪ Select the option "Next Object" or "Previous Object" . Alternatively you can use the 

PLUS key (for next) or the MINUS key (for previous) on the number pad. Repeat these 

steps until the desired object is selected. The order in which the objects were 

created is important for this menu item: Select the menu item Next Object  or press 

the PLUS key on the number pad to select the object that was created after the 

currently selected object (see also the section "Display order" later in this chapter). 

This menu item is useful if an object is so close to another that it is difficult to select 

with the mouse. 

Position and Size 

You can move each selected object or change its size. If you select multiple objects, you 

can change them all as if a single object were selected. 

▪ Changing the size with the mouse: Select the object. If you position the mouse on 

the frame, you can change the size by pulling the frame inwards or outwards, as 

indicated by the arrows, while holding down the left mouse button. You must 

position the mouse in one corner of the frame in order to change the size both 

horizontally and vertically. 

▪ Moving: Select the object. Hold down the mouse button and drag the object to the 

position that you want. You can also move the selected object with the ARROW keys 

on the keyboard. The press of a key moves the object by one dialog unit in the 
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direction of the arrow. If you hold the SHIFT key while using the ARROW keys, the 

objects can be moved by 10 dialog units at once. 

▪ Changing the size and moving with the dialog: You can also change the size and 

position of an object by a position dialog. You can enter values precisely here. Select 

the object and choose "Position and Size" in the context menu. 

Aligning objects 

With the menu command Object > Arrange > Al ign  or the toolbar you can align objects 

with each other. At least two objects must be selected so that the menu item is available. 

 

▪ Left, right, top and bottom: The selected objects are aligned by the corresponding 

edge. The object standing out most of those selected is the one to which the others 

are aligned. 

▪ Size adaption: The selected objects are resized either horizontally or vertically to 

match in size. The largest object is that to which to others are resized. If you want to 

leave the objects’ size unchanged in one dimension, select the option "Unchanged".  

Using the guide grid 

You have the option of placing a grid with guidelines on the workspace. Objects can then 

only be placed along these lines. 

 Select the command Settings > Grid > Setup. A dialog appears in which the desired 

gap between the gridlines can be set. The horizontal and vertical grid gaps can be 

set independently or can be set to the same size with the "Synchronous" option.  

 With the option "Active " you can activate and deactivate the guide grid. In the active 

state objects can only be positioned along the invisible guidelines in the workspace. 

In the inactive state, objects can be positioned anywhere without the grid being lost. 

The guide grid can be turned on or off with the command Settings > Grid > active .  

Input order 

The order in which the objects were placed on the workspace decides the order in which 

the cursor moves through the fields of the input form when you press TAB or  ENTER 

during data entry. 

The input order also plays an important role when objects partially or completely overlap. 

Objects that come earlier in the order are in the background. Objects that come later in 

the order are in the foreground and can cover up other objects. 

You can change the display order manually at any time:  
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 Select Object > Arrange > Input Order  or the corresponding button in the toolbar. 

All objects on the current workspace are shown as rectangular frames with a 

number. These numbers represent the current position of the objects in the display 

order. 

 Click the objects in the order in which they should be displayed. The first object that 

you click on will be given position 1 in the display order, the second will be given 

position 2 etc. 

 Save the order by selecting Object > Arrange > Input Order  for a second time, or by 

clicking somewhere outside the fields in the workspace. If you have clicked all the 

objects in a tab, the order is saved automatically. 

 

19.5 Shared object properties  

The properties can be reached by double-clicking the object or select Properties in the 

context menu of the object. It will open a multifunctional editing dialog that is built up 

differently depending on the object type.  

The tabs "Program", "Tooltip", "Autotext", "Cont. L ink" and "Input val idation" that are 

available for several objects, are discussed in this section. 
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Preset 

In the Preset tab you can set a certain value that is automatically entered when a new 

record is created. Enter the desired input. If, for example, you mostly had retailers in your 

customer file, you could set that "Retailer" is entered under "Category" in every new 

record. In this way you can often save yourself from having to type a common input. 

Display format of input fields 

A formatting dialog is available for all input fields, comboboxes and static text. The 

formatting is applied to the result of the entire expression. 

 Open the dialog with the "Formatting" button on the "Properties" tab. 

 

 With the format editor, you can set the format for numbers, currency, dates, time, 

percentages and angles. The system settings are used by default.  

Tip: If you only want to format certain areas of an expression by field link (e.g. for text 

and numbers within an expression), use the functions Date$() and FStr$() in the 

formula dialog.  

Appearance Condition 

Under Appearance Condition you can use the formula wizard to define the conditions for 

visibility or whether the object can be edited. If you wanted that COMPANY2 can only be 
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edited if COMPANY1 has contents, then enter COMPANY1<>"" under "Editabi l i ty 

condition" of the COMPANY2 properties. 

Tooltips 

For some objects, you have the option of defining tooltips. As soon as you move over the 

corresponding field with the cursor, a note will appear with a text you defined. 

The comment contained within is meant to help with data entry so that you instantly 

know which input variations are possible or in what form something should be entered. 

Even if several people work with the view, everyone will know from the tooltip how a 

field is to be edited, because the tips can be defined specifically for the view. In this way, 

it is made easier to keep the view consistent. 

Appearance 

Under Appearance  you can select a background color as well as the font and the font 

color for the object. With the button "Default" you can use one of the options set under 

Object > Defaults. With "3D-Text" you can set the display type. If the option "l ike dialog" is 

turned on, the background of the object will take on the color of the tab. (In this case you 

can set a special background color.) 

Autotext 

With the "Autotext" function, you can define text blocks for every input field. If you enter a 

key, the respective autotext is automatically entered. During data entry, your typing can 

be limited to a few keys. 

Tip: Autotext can also contain formulas. With these, you have many options to automate 

the data entry, e.g. for the automatic entry of username and date in the comments field. 

Autotext can also be used for automatic typo correction: enter a usual typo as the key (if 

you even make mistakes…) and as text for the text block, enter the correct spelling. 

To set autotext, carry out the following steps: 

 In the window Autotext you will find a double list with Replace/With items in which 

the defined text blocks are displayed. The cursor automatically jumps to the 

"Replace" input field under the list, in which you first enter the key for the text block.  

 Next, enter the text block in the "With" input field, which is to be inserted 

automatically when the key is entered. If you want to enter a formula, click on the 

corresponding button to the right of the input field. 

If you select an item in the autotext list (e.g. by clicking it), the corresponding item is 

displayed in the input fields, where it can be edited retrospectively. 
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You can place your items in certain positions in the list with drag & drop, for example to 

sort the list alphabetically. 

 

Note: Please note that during data entry the autotext function only becomes effective 

when a space is entered after the key or the cursor is moved to another field. 

Setting content links 

Content links can be defined for all input fields, comboboxes and checkboxes of a view. 

With a contents link certain contents can be assigned automatically to one or more input 

fields (the so-called target fields) depending on the input in the source field 

In this way you can, for example, decide that whenever "Mr" is written in the 

SALUTATION field, the entry "Dear Mr." is made in the field SALUTATIONLETTER. 

Or that whenever "C" is written in the CATEGORY field, the entry "Car Dealerships" is 

entered in the SECTOR field. You are not limited to a link between two fields, you also 

have the option of giving a field several content links. 



Shared object properties 

289 

 First you should choose a target field, by clicking the "New" button and making your 

selection. Alternatively, you can also proceed as follows: 

▪ The entrys "Execute Script File", "Execute Script Code", "Execute Workflow" are 

also available.  

▪ With "Delete  content l ink"  you can remove a field from the list again. 

 Now you have the choice between the following options: 

▪ "Copy source content directly"  has the effect that every input into the source 
field is automatically entered into the target field.  

▪ You also have the option of defin ing a formula with the help of the formula 

wizard.  

▪ The option "Transform selective  expressions"  allows the input of any desired 

text in the target field, depending on certain entries in the source field. The "i f-

then" links are defined in the corresponding input fields. As soon as a new link is 

entered, the cursor jumps to the "if " field automatically. In the "then" field you 

also have the option of defining a formula. 

To tick a checkbox (logical field) by content link, let a "T" (TRUE) be entered. To 

untick it, an "F" (FALSE). 

 Options for setting content links: 

With the option "No content link if target field is not empty" you can decide whether the 

linked item is only to be inserted in the target field if it is empty (option on), or whether 

the item already there is to be overwritten (option off). 

Note: Please note that content links only become effective during data entry when the 

source field is left! Also, only as many characters can be inserted into the target field 

as allowed by the defined field length. If the target field for a linked item is too short, 

the item is cut off. 

 

Tip: To calculate values there is a "computed column" in SQL Server. You define the 

property "ComputedColumnSpecification" with a formula (e.g. [Kilometer End] – 

[Kilometer Start]) in the corresponding column in MSSQL Management Studio. The 

column then becomes a virtual column, the values in it will update when columns 

change that are in it. Avoid dividing by 0, for example by Value1 / nullif(Value2, 0). 

Input Validation  

Here you can define a rule for validating the input for a field and set the corresponding 

notification message that appears if the input was invalid. 
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To define a validity condition, carry out the following steps: 

 First you should decide whether the correct input should be forced or whether only a 

notification should appear for an invalid entry. 

 With the button "New" you will reach the list with the conditions and notifications. 

The cursor will automatically jump to the "Val idity condition"  field, which can be 

defined with the help of the formula wizard. In the field underneath, you can now set 

the notification message that appears if the validity condition was not satisfied by 

the input. 

Note: Please note that the definitions do not provide 100% protection, and are only 

input aids. For some special functions, such as drag & drop, search + replace or even 

the virtual user, these checks are partly ineffective. 

Example: To force the correct input of an e-mail address. 

StrPos(EMAIL,".")<>-1 and StrPos(EMAIL,"@")<>-1 and Len(EMAIL)>=5  



Shared object properties 

291 

For the notification, if this validity condition is not valid, you could enter "e -mail address is 

not valid!", for example.  

You will get the most consistent form as possible for the input. In the notification, you 

also could already tell how the correct entry should look like, that there has to be an "@", 

as well as at least one point and five characters.  

Run external program 

You can link fields of the input form with external programs. These external programs, for 

example a spreadsheet or a graphics program can then be run directly from the 

corresponding field by right-click the field and select Run External  Program  from the 

context menu. 

Setting up the run external program function: 

 With objects, for which a program link is possible, you can find a "Program" tab in the 

dialog that opens. Here you can set up a program to be run by selecting the desired 

external program and the parameter to be transferred. 

 In the input field "Program name" you can enter the path and program names of the 

desired program or can select it with the "Se lect fi le " button.  

 In the input field "Program parameter " you can transfer parameters to the external 

program, for example to start the program with a certain document. With the 

parameter "%s" you can set that the field contents are to be transferred as a 

parameter. This is useful, for example, if you store a path and file name in the field, 

so the file is automatically loaded when the program is run. 

With the parameter "%env(<var>)" you can transfer the contents of an environment 

variable as a parameter too. "<var>" stands for the name of the environment 

variable. (More about environment variables can be found in your operating system 

manual).  

Aside from these two parameters, you can enter all other parameters permitted for 

the program being run in the input field "Program parameter". 

 Allow program start by fi le  extension:  If this option is turned on, the associated 

program is ascertained from the document type (e.g. .XLS). An entry under "Program 

name" is no longer necessary because path, filename and type are automatically 

ascertained from the field contents. An entry under "Program parameter" is also no 

longer necessary. In this way, different files and applications can be run from one 

field (e.g. text, spreadsheets and pictures, etc.) 

An automatic link can only work if the application has correctly entered the 

associated filename extension in the system. 
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19.6 Object settings 

The tabs "Program", "Tooltip", "Autotext", "Cont. L ink" and "Input val idation" that are 

available for several objects, are discussed in more detail in the previous section. 

The command Arrange  in the context menu allows the movement of objects into the 

back or foreground. Foreground means the top layer, which will definitely be visible, 

background means the bottom layer. 

The following object types are available 

▪ Static text: for description of fields in the input form 

▪ Input field: Standard field for data entry. Can contain autotext, content links and 

external program run commands. 

▪ Combobox: for providing fields with a set of possible entries (e.g. titles such as Mr., 

Mrs. etc.). 

▪ Listbox: to display CODE fields. 

▪ Checkbox: to display logical fields. 

▪ Graphic: to display graphics 

▪ Group: to group fields with frames or background surfaces (with or without text). 

▪ Tabs: to display multiple tabs. 

▪ Container: to display information from relationally linked views, such as from 

documents, contacts, references etc. 

▪ Button: modifiable button that can be assigned a large variety of functions, etc. 

19.7 Specific object properties 

The tabs "Autotext", "Cont. Link", "Program", "Input validation" and "Preset" are discussed in 

closer detail before the individual object descriptions. 

Regardless of the type of object, in the preview field in the lower area of the properties 

window, the currently selected settings are displayed. 

Static text 

Text objects contain text, which is displayed later in the input form and cannot be 

changed. 

▪ All fields in your view are available for this object type in the field selection. 

▪ The option "Static text" has a special importance here. This option does not 

correspond to a field in the view, but allows you to place your own text on the 

workspace. Fixed text is useful for describing fields and other objects in the input 

form, or for requests and tips for the user. 
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▪ Infront of the data field Company, the static text "Company" should be written. To do 

this, place the "Company" text infront of the Company input field as a static-text 

object in the input form. 

Properties 

If the field has been inserted via an entry "<Field name>" from the field selection, the 

text is determined by the respective field content and can not be changed. However, on 

the tab "Text" you can specify whether the current field content (e.g. "combit Software 

GmbH") or the field alias or field name (if the field alias is empty) is displayed (for 

example, "Company"). 

 

If the field has been inserted via the entry "(f ixed text) or formula" from the field selection, 

you have the option of defining a static text or a formula with the help of the formula 

wizard. 
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In the tab Properties by marking "Left", "Centered" or "Right", you can set the alignment of 

the text. You can also set whether word wrapping is allowed in this dialog; with the 

function "3D-Frame" you can influence the appearance. 

Input field 

Input field objects are the traditional objects in input forms. With input field objects, you 

set the area in which the field contents of your view are displayed and edited.  

Properties 

In the Properties you have the same settings "Left", "Centered" and "Right" with which you 

can set the alignment, and by marking the option "Word wrap" you can allow this 

function. The spell check can also be activated (requires Windows 8). 
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The option "Make uppercase" automatically turns the contents of a field into capital 

letters. With "SHift correction" you can compensate for the common typing errors that 

occur from holding the shift key for too long and making the first two letters capitals 

instead of just the first. If the option is turned on, the second letter of every entered word 

is automatically made lower case even if it was upper case intentionally. This only 

happens if the third letter is not also in upper case. 

Combobox 

Combobox objects allow you to assign lists of pre-defined contents to fields. These 

objects consist of an input line with a button on the right-hand side. Underneath the input 

line, a dotted frame represents the area to be available for the drop-down list of pre-

defined contents. The width of the drop-down list is adapted to the width of the 

contents. 

Important: When inserting combobox objects, you should always ensure that at least 

one row, but preferably several rows of space exist under the input line for the drop-
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down list. The area for the combobox object underneath the input line can, of course, 

cross over other objects. 

 

▪ With combobox objects you could, for example, pre-define the contents "Mrs", "Mr", 

"Miss", etc. for the TITLE field. Instead of having to type in these contents in the input 

form repeatedly later, you can select them quickly from a list with the mouse or 

keyboard. 

▪ With an automatic completion mechanism, the first similar item in the combobox is 

searched while you type. It can be selected by pressing the arrow down button. For 

combobox objects, all fields of the active view are available in the field selection, 

with the exception of the internal fields. 

Properties 

▪ In the Properties tab, with the option "Sorted l ist" you can control whether the listed 

items are to appear in alphabetical order. 

▪ With the function "Extended Interface" the combobox can also be opened with the 

arrow keys (and not just the mouse). 
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▪ Also, the option "Text editable" can be activated, with which you can set whether you 

can only select the predefined contents (option off), or whether you can make 

manual entries (option on). 

▪ More about the "Tooltip" tab can be found later in this chapter. 

In the Entries tab you will find a list of predefined inputs for the object. For a newly 

created object, this list is empty at first. 

▪ With the button "New" a new, empty item is added above the active item. The cursor 

automatically jumps to the input field under the list in which you can enter the 

desired text for the item. 

▪ With the button "Copy" you can add a copy of the current item on the end of the list. 

This function is useful if you want several items with only slight differences. 

▪ With the button "Delete" selected items can be removed from the list. Lastly, you can 

move your items to different positions in the list with the arrows or by drag & drop. 

▪ With the button "Bulb" items can be given a display condition: only if the formula 

returns the value "true" will the item be displayed in the list. With this, many selection 

lists can be made considerably more overlookable and inconsistent selections can be 

reduced. 

Otherwise, the same settings are available for combobox objects as for the previously 

described input field objects. 

Listbox  

List box objects are for the display of "Code" fields. The set or available codes appear in a 

vertical list with a scrollbar. When pre-selecting the list box object, only the "Code" fields 

in the active view are available. 

Properties 

In the Properties tab, you can use the option "only se lected i tems" to set whether all 

available code attributes are to be listed in the listbox display (option off), or whether only 

the code attributes active for the record are to be displayed (option on). If the record is 

being edited, all code attributes will always be displayed.  

With the option "Ignore empty" you can set whether only the code attributes are 

displayed to which a description has been assigned. Empty code attributes without 

description are not displayed. This option also applies when the record is being edited. 

With the option "Sorted" you can let the different code attributes be listed alphabetically. 

In the Preset tab you can select the attributes that should be activated for a new record 

automatically, e.g. "Christmas Card". 
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Checkbox  

With the checkbox object, you can place logical fields (check boxes) in the input form. In 

the field selection, all "Logical" fields are available. You can choose the name for the 

checkbox freely. 

Properties 

In the field "Text" you can enter a descriptive text, which will however only be displayed 

completely if the control is large enough. 

In the Tooltip tab you can set a text that is displayed as soon as you move the cursor over 

the corresponding field. 

Under Cont. L ink you have the option of linking the field with one or more fields to let 

their content change automatically. You can also set a value as default that is used when 

creating a new record. For checkboxes, there are two options: either the field is checked 

which corresponds to the field content "T" (TRUE) or it is not checked, which corresponds 

to the field content "F" (FALSE) or "" (empty). Knowing this you can also (re)set 

checkboxes via contents link. 
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Picture  

Picture objects represent the area in which an image can be displayed. A variety of image 

formats can be displayed. For the picture object, all image fields in the active view, as 

well as the option "(fixed file) " are available in the field selection. 

Properties 

In the Properties tab, you can open a selection dialog with the "Se lect file " button and set 

the desired picture file, if you have inserted the graphics object as "f ixed fi le ". Many 

formats can be used for this. 

If a field of your view was placed as a picture object, however, the picture will be defined 

by the field's content and cannot be selected here. With the option "Keep proportions" 

you can set that the original proportions of width to height of the picture remain 

constant. If the option "Keep proportions" is turned off, the inserted picture will adjust to 

fit the aspect ratio of the picture object. 

In the Program tab you can set which program is opened from this object (field) with the 

"Program" button. This function can only be selected if the picture was inserted as a field. 

If it was places as a "f ixed file ", the function is hidden. Further information about running 

external programs can be found later in this chapter. 

Grouping  

Grouping or group objects consist of a rectangular frame or area, which can contain text 

in the top-left corner. They have the main purpose of visually grouping associated fields 

in the input form. Grouping objects can also be used as background surfaces onto which 

other objects are placed. In the field selection, all fields in the active view are available for 

the grouping object. 

When working with grouping objects, the display order is important (see "Display order" 

later in this chapter). In the display order, the grouping object should always be placed 

before objects on top of it, i.e. it should be inserted first. Otherwise, it will not be in the 

background and will cover up objects contained in it! The grouping object may not be 

placed around or behind the file cards object. 

Properties 

In the Text tab, in the "Groupbox text" field you can enter a label for the frame. The 

display always starts at the top left corner of the frame and runs along the top edge. 

After this, the text is cut off. 

In the Frame tab you can set the frame type or the background of the group object. This 

option is available to you if the groupbox text is empty. 
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Tabs 

Both the input form and the main tabs can contain multiple tabs. This way data can be 

arranged in an even clearer manner.  

 

You create, copy, delete and move the main tabs via the tool window "Tabs". All 

additional tabs can be positioned via the object "Tab". How to position a tab object:  

 

 Select the object type "Tab" in the toolbar. The cursor 

turns into a cross.  

 With the cursor, show the point at which the left upper 

corner of the tab is to begin. 

 Press the left mouse button and drag -- while pressing 

the mouse button -- the cursor to the diagonally opposite 

corner of the planned object.  

 Release the mouse button once the object (the dashed 

border) has reached the desired size. This tab is therefore 

also displayed in the tool window "Tabs". 

 The properties can be defined by double-clicking on the 

respective tab. The dialog corresponds with the main 

tabs. 

Web-Element 

The Web-Element embeds an Internet Explorer window in the input form. You can 

display web pages with it. These can be local or in the internet, the URL can also be 

dynamically created via formula depending on record and user. With Web-Elements 

online content like weather information, maps, social media content and many more can 

be integrated into the input form for example. Furthermore script generated content (e.g. 

report charts as graphic) can be displayed like ActiveX objects embedded in a HTML 

page are displayed in the input form. 

Enter the address of the web page to be displayed in the field "URL". By using the 

formula wizard you can dynamically create that URL. Note that you probably have to 
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adjust the security settings in the Internet Explorer options if you want to use active 

content in web pages, e.g. by adding the URL to the "secure sites". 

The webpage can also be loaded dynamically via script (e.g. by a button). For script 

access (WebElements object) an unique ID is generated for each Web-Element which is 

displayed in the content dialog. Further information can be found in the SDK 

documentation in chapter "Web-Elements". 

Also the tab "Properties" offers multiple options. 

Note: The websites will be displayed in an Internet Explorer control. It internally runs in 

the com-patibility resulting in possible differences/restrictions especially with 

displaying CSS compared to the standalone Internet Explorer application. 

Container 

Containers are special list fields for displaying records from 1:N-relational linked views, 
e.g. a container in the contacts view, which shows all of the records assigned in the 
"Activities" view. 

For a container to be available to you, you must first have defined at least one 1:N or N:M 

relation for this view. Through "Contents", select the variable to be assigned to the object. 

The link fields are listed for which a 1:N relation has already been defined. Further 

information regarding the definition of relations can be found under "Relations" in chapter 

"Configuration of views". 

 

 The easiest and at the same time most efficient way to insert containers is by drag & 

drop from the variable list. Simply select the desired variable and drag it to an empty 

section of the work area. You define the properties via the context menu. 

 By clicking on the button "Filter, a combo box can be positioned over the container to 

filter the records in the container. For more information, see section "Button". 

 You can place the same container a maximum of two times on different tabs. It is 

not possible to place it on the input form (basic) and a tab at the same time. 
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Button 

Buttons can be linked with almost any function. In the field selection for the button object 

type you can see a selection of the available functions that can be linked with a user -

defined button. In the field selection for the button object, all functions for which a 

button is available are displayed. 

▪ Buttons for the creation, editing and filtering of relationally linked records. 

▪ Buttons for (in the view defined) function definitions. 

▪ Buttons for running a script. 

▪ Buttons for running a workflow. 

▪ Many menu functions are available in the forlders "Edit", "Find", "Organize", "Output", 

"Record", "Schedule", "Settings", "Tools", "View". 

▪ With the buttons "Delete", "Edit", "Filter", "New" of the "Container" category and 

"Append existing", "Append new" and "Scanning" of the "Container.Document" 

category, the corresponding container context menu functions for a container can be 

carried out.  

With the "Filter" button, a combobox can be placed over a container to filter the 

records in it.  

Properties 

On the Properties tab, various functions are available: 

▪ The button text can be set as desired. 

▪ Optionally, you can set whether a right-click on the button is also allowed and 

whether this has a particular effect when running a script through the button. 

▪ In the "Bitmap" list, you can select the desired bitmap from a large selection, which is 

to be displayed on the button. With the "f ixed file " item, you can select an image file.  

For buttons for the allocation and display of relational records 

With the button "Go to Relational Record" you can go to the corresponding 1:1 relational 

record. With the button "Select Relational Record" you can allocate a relational record. For 

both buttons, select the corresponding 1:1 relation in the "Parameter" field on the 

Properties tab.  

Buttons of type "Select Relational Record" display all records that are available for the 

relation to the linked view in a selection list. The corresponding record is selected with a 

double-click. 

A filter that defines the displayed records can be defined for the records displayed in the 

selection list. Current field contents can be accessed for comparing. The filter for the 

selection list is selected in the button "Advanced" on the tab "Extended". The definition of 
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the filter expression can be made with a General Filter or a Free SQL Query. The filter is 

activated by the checkbox "Apply filter on records to be displayed". 

 

Buttons for function definitions 

For buttons of the type "Predefined function print single", "Predefined function single e-

mail", " Predefined function program" and "Predefined function data transfer", select the 

defined function definition in the "Parameter" field. The function definition is defined on 

the "Function Definitions" tab in the view configuration.  

Further information can be found under "Function definitions" in chapter "Configuration of 

views". 

Link a script 

If you want to run a script with a button, select "Script File" or "Script Direct " from the list 

of available functions. 

When you select Script F i le , you can choose a script file in the properties dialog. When 

you select Script Direct  you can enter the script text directly. Further information can be 

found in chapter "Scripts and programming reference". 
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Link a Workflow 

If you want to run a workflow with a button, select "Execute Workflow " from the list of 

available buttons. Further information can be found in chapter "Workflow Designer". 

Buttons for container-functions 

In the folder "Container" the corresponding container context menu functions are 

available. For all buttons, select the corresponding 1:1 relation in the "Parameter" field on 

the Properties tab.  

▪ With the container buttons "Edit", "Delete" and "New", the corresponding container 

context menu functions can be carried out. For the buttons "Edit" and "Delete", a 

corresponding container on the tab is essential, since a relational record must be 

selected for these actions. 

▪ With the "Filter" button, a combobox can be placed over a container to filter the 

records in it.  

 

All saved filters in the linked view, for which the option "Container Filter" is activated 

in the "Filter Library", are available in this combobox. The activated filter remains in 

use until it is changed. 

▪ With the buttons "Append existing", "Append new" and "Scanning" of the 

"Container.Document" category, the corresponding container context menu functions 

for a container with a document field can be carried out.  

For buttons with the "Append new" function, the dialog for the selection of the 

document type will be opened. A document template can optionally be linked with 

the button. In this way, a document corresponding to the configuration of the 

document management can be created without further query.  

The document template is selected under the "Advanced" button on the "Extended" 

tab. With the option "Always create a document of the following type", all document 

types configured in the document management are available.  
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20. User and rights management 

With the menu item F i le > Options > User Administration  you will reach the user and 

rights management. These settings are generally controlled by the system administrator.  

Enter the different users here and define their individual rights. 

User management is available in read-only mode in the form of virtual views. This way all 

of the users set up can be used as records directly within the project, e.g. to be able to 

assign a cRM user as a support person to each customer. You create these virtual views 

by clicking on a button in the dialog F i le > Information  > Properties. More information 

can be found in the chapter "Configuration of projects". 

 

20.1 User management 

In the left-hand area, the existing users and groups are displayed. To simplify 

management, you can create groups and assign users to those groups. In this way, you 
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do not need to define the rights for every user individually. You can save time by defining 

the rights for several users at once. 

Users and groups 

The users and groups are edited using the following buttons: 

▪ With the "New" buttons, you can create a new user or group. With the "Delete" button 

the selected user or group can be deleted.  

▪ With the "Copy" button, you can duplicate a user or group, e.g. when several users or 

groups have similar rights.  

Note: The "Administrator" user is a pre-defined account with all access rights. The 

"Administrators" group is the same. Neither accounts can be deleted, their names 

cannot be changed and their rights cannot be limited. It is therefore very 

important that you assign a password to the "Administrator" account. 

▪ By clicking on the button "Transfer rights from user/group ", rights can be taken over 

by users or groups from other users and groups. In a dialog, you can explicitly 

specify which rights are to be taken over from whom. 

Active Directory Connection  

With the Active Directory connection, you can import users from the Active Directory or 

synchronize the user administration with the Active Directory of a domain server.  

The domains of the current user are automatically recognized and cannot be changed. 

Note: This function requires the Enterprise Edition 

 Click on the "Active Directory Connection" button 

 Choose between the following options: 

▪ Import users from the Active Directory : A standard Windows dialog to select a 

user will open. 

▪ Synchronize the user administration with the Acti ve  Directory . Starts the 
synchronization according to the settings. 

▪ Configure Active  Directory synchronization : 

Identification of cRM users in Active Directory 

▪ By "Windows Login" field: the Windows login name is used to determine 

whether the user exists or not. This option cannot be changed. 

▪ Define whether the cRM users in the Active Directory should be identified 
based on the cRM 'Login Name' when the 'Windows Login' is not found.  
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▪ Synchronize users from following Active Directory groups: Only new users 

from the selected group will be added to the cRM. 

Actions in the cRM user administration. 

 

▪ Automatically create cRM users based on Active Directory: Is this option is 

set, a user who was found in Active Directory but is not yet available in 
cRM, newly created. 

▪ Assign following standard groups thereby: If a new user to set, it is 
automatically added to the selected groups. 

▪ Update cRM user master data based on Active Directory: If a cRM user is 

found in the Active Directory, the user master data will be updated with 
the data from the Active Directory. 

Already defined cRM user master data won't be overwritten with empty 

data from the Active Directory. 

If an existing cRM user is (de)activated in the Active Directory during the 

synchronization, he will be (de)activated in the cRM as well. 
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Users that do not exist in the cRM user administration and whose account 

is deactivated in the Active Directory will be ignored during the 

synchronization and won't be transferred to the cRM user administration. 

Following users are excluded from the synchronization: Guest (and 

German "Gast"), krbtgt (Kerberos Service Account). 

▪ The Active Directory does not disable / delete existing cRM users: If this 

option is set, it is checked whether the cRM users in Active Directory is 

present. Should he not be found, it is possible to delete the user cRM 

either on or off. 

Memberships 

When you select a group, all users currently assigned to that group are displayed in the 

"Memberships" tab. When you select a user, all groups to which the user is assigned are 

displayed on the "Memberships" tab. 

To assign a user to a group, click on the "New" button. Select the user from the list of all 

available users. To assign a user to a group, click on the "New" button. Select the group(s) 

from the list of all available user groups. 

User master data / user login 

After selecting a user, the user login and master data (e.g. name, department, telephone 

number, e-mail) can be saved under the "Master Data" tab. These are also available as 

variables when printing.  

In the field Signature  you can place an image file. With the "Open" button, select the path 

of the file or enter the path directly.  

▪ Login name: Enter the name for the user login and an active directory 

synchronisation. This cannot be changed later. 

▪ Account deactivated: This option prevents the user from logging in to the cRM. 

▪ A password for the login can be set by clicking on the button "Password". The 

password can be changed by the users themselves under the menu item Settings > 

Change User Password.  

▪ When using a DMS you can set the DMS login information with the button "DMS". 

The users can change the information themselves (also under Settings > DMS Login 

Information). 

▪ This login information does not apply to windream. When using windream, the 

current Windows user must be a member of the windream user group. 

▪ If you activate the option "login automatically", cRM will start without any further 

interaction if the current Windows user can be linked to a cRM user. 
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To avoid an automatic login, hold the shift key while starting the program to force the 

login dialog to open. 

 

Group master data 

After selecting a group, you can set a name and description for the group in the "Master 

Data" tab. 

All group names to which a user belongs are available in the group variable 

<cRM.User.Groups>. The group names are placed in single quotes and are separated by 

commas. In this way, a group-specific web view or group-specific input and display fields 

can be created. 

Example: «if(StrPos(cRM.User.Groups,"'Sales'")<>-1, ... , ...)». The simple quotation marks 

should be part of the formula to be able to differ clearly between "Sales" from "Sales2". 

20.2 Rights management 

The rights management split into project-spanning, project-specific, view specific, record-

specific and field-specific rights. These rights can be set for every user individually or for 

several users at once through groups. 
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Definition of rights 

 Select a user or group. 

 Select the view for view rights, record rights and field rights. If you select the top 

entry "Multiselection", you can define the rights for multiple views in one step. 

 

 Select the right to be defined. By clicking in the right-hand column and then clicking 

the arrow on the right-hand side, you can open the selection dialog. Choose between 

"Yes", "No" and "See Groups".  

When defining group rights, the option "See Groups" is not available.  

 

 By right-clicking, all rights can be set at once through the context menu.  

database
field rightsrecord rightsview rightsproject rightsgeneral rights
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 If you have selected "See Groups", the right that results from the user’s group 

membership is displayed. 

Note: If you wish to assign the rights through the groups and do not wish to assign 

them to each user individually, you must take care that a user belongs to at least one 

group. If this is not the case, each right will have the setting "No" automatically. 

If a user is a member of several groups, their rights from all groups are added together. 

Example: The user is listed in the group "Marketing" as well as in the group 

"Administrators". With the group "Marketing" he wouldn't have the right to create a new 

project, however he would have as a member of the group "Administrators". In this case, 

the user gets the right and it doesn't matter that he actually wouldn't have it as a member 
of the group "Marketing. 

Any individual user rights "Yes/No" always take priority over group rights.  

Example: The group "Marketing" generally is allowed to set appointments for other users. 

If a member of this group doesn't explicitly have the right in his individual user settings, 

then he is not allowed to, despite his group membership.  

Application rights and user settings  

On the "General " tab, you can set the application-wide rights, i.e. the project-spanning 

rights of a user. Amongst these are the rights to create a new project or the creation of 

appointments for co-workers. These are rights that do not depend on any particular view 

but apply all the time. 

If a user creates a new project, all project-specific rights are given to that user 

automatically. The user does have to be able to change the project, after all. 

Whether other users can access this project depends on if they either: 

▪ Are a member of the "Administrators" group. 

▪ Have been given the general right "Work with unknown project" . In this case, it is an 

"unknown" project, since no rights will yet have been assigned to the user in it. 

▪ Have already been given explicit rights for this project by the administrator. 
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These requirements also apply for the view-specific rights. 

Additionally, in the user management, notification options for monitoring of records can 

be configured: 

 

▪ Email notification: If the "Record Watch" function is active for a record, an email will 

be sent to the selected email address when a change is made. An instance of the 

cRM Workflow Servers must be running for this function to work. More information 

on the Workflow Server can be found in the chapter "Workflows and Events".  

▪ Some changes can be ignored. If you select "Notify", you will be notified about your 

own changes (e.g. by a script).  

More information can be found in the chapter "Watch record" under "Entering and editing 

data". 

Project rights 

On the "Project" tab, you can see the project-specific rights of the currently active project, 

such as changing the configuration of the project.  

▪ Edit project settings: This right is required:  

▪ to access F i le  > Information > Properties . 

▪ to save filters/statistics/quick search fields/sort orders for all users. 
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▪ to save the configuration of list/container view for all users. 

▪ To make a filter expression available for all users. 

▪ Default right for new view: This right sets the default for view rights if a view has not 

yet had its rights defined explicitly. Please note that this is not the actual right, but 

the value that is used for all view rights as default. 

Example: You create a new view, but the user rights for this view weren't set yet. In 

this case the described default right comes to use. If you have set a "Yes" for a user, 

then he does have all rights for this view – that means for all view rights a "Yes" is 

automatically preset. However you have set "See Groups" for the "Default right for 

new view" for an user, then all his rights for a new view will be set to "See Groups". In 

this case the rights settings take place, which are defined for his/her groups. 

View rights 

On the "Views" tab you can see an overview of the view-specific rights. Amongst these 

are the editing of records, the creation of e-mail templates, import, export, etc. 

▪ Select the view for view rights. If you select the top entry "Multiselection", you can 

define the rights for multiple views in one step. 

▪ Default right "Read" or "Write" for new fields: Set default values for field rights, if 

rights for a certain field were not det explicitly. 

Record rights 

On the "Records" tab, you have the option of defining rights specific to records. For 

example, you can define a filter for a whole group of users, so that those users can only 

see a certain set of records in a view. 

Note: The activation of record rights will generally require additional resources on the 

database server. This could cause a decrease in performance. The reason for this is 

that the complexity of the queries is increased with activated record rights.  

 Select the view for view rights. If you select the top entry "Multiselection", you can 

define the rights for multiple views in one step. 

 For a group record filter select "Group specific", for a user record filter select "User 

specific" or "See groups". 

 By clicking the formula-button you will reach the dialog for defining a filter. Set up 

the desired selection here. Further information regarding this in chapter "Filtering 

Records (Selection)". 

▪ Try to use filters that are as simple as possible. 

▪ Avoid filters with relations. 
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▪ If the record rights are derived from groups, avoid group memberships to 

multiple groups with record rights. 

▪ Only activate the record rights for the views in which they are truly necessary. 

L imits: The general filter and free SQL queries do not respect record rights of 

relationally linked views, thus in theory with corresponding WHERE queries, records 

without access rights could be "guessed". The relationally linked records are of course 

not displayed. If these are critical records, the rights "Edit direct SQL query" and "Edit 

filter expressions directly" can be taken away from the user. Saved SQL queries and 

filtering generally are still possible, but no query can be created with which the 

relationally linked records can be "guessed". 

Field rights 

On the "F ie lds" tab, you have the option of assigning rights specific to fields. You can 

define, for example, that a user (or a group) can only see certain fields in a view, or only 

has editing rights for certain fields. 

 Select the view for view rights. If you select the top entry "Multiselection", you can 

define the rights for multiple views in one step. 

 Generally, fields rights are turned on with "f ield rights active ". This is independent of 

whether settings have been changed in the field list underneath. If you select the 

setting "See Groups" and the user belongs to a group for which field rights are 

inactive, this user will have viewing and editing rights for all fields. 

 Editing rights and viewing rights can be activated separately. To change the settings 

"Read" and "Write " checkboxes with three different states are available: 

 Field right is set, e.g. viewing rights 

 Field right is not set, e.g. no viewing rights 

 Field right see groups 

Particularities when working with field rights 

▪ If new fields are added or are re-named (and have not yet been configured), then the 

settings "Default right "Read" for new fields" or "Default right "Write" for new fields" on 

the "Views" tab apply. 

▪ If no viewing rights exist for a field, an empty content (NULL) is returned. This should 

be noted especially for statistics, printing, L&L formulas (auto log, find & replace, 

modify, etc.)! 

▪ If no viewing rights exist for a field, the field is write -protected in the input form in 

the filter mode QBE and a search is not possible. In the general filter mode, the field 

is not available. 
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▪ If no editing rights exist for a field, it is write-protected in the input form.  

▪ The situation in which a field has editing rights but no viewing rights is fairly unlikely, 

but dangerous. It would be possible to overwrite contents that you cannot see. For 

this reason a warning will appear if this setting is made. A possible use of this 

combination: an auto-protocol creates relational records, but some of the fields in 

them may not be seen by the user. 

Limits when working with field rights 

▪ Sort orders do not respect viewing rights, i.e. you can sort by columns whose 

contents cannot be seen. 

▪ The phone number recognition does not respect field rights, but this is not relevant 

in practice for incoming calls because the number is already being displayed. 

▪ The general filter and free SQL queries do not respect field rights, i.e. in theory, with 

a corresponding WHERE query it would be possible to "guess" field contents without 

viewing rights. The field contents are of course not displayed. If these are critical 

records, the rights "Edit direct SQL query" and "Edit filter expressions directly"  can be 

taken away from the user. "Predefined SQL queries"  and filtering generally are still  

possible, but no query can be created with which the field contents can be 

"guessed". 

▪ If no editing rights exist for the field in which an auto-protocol is to write, or if the 

option "Append" was selected but not viewing rights exist for the field, the auto-

protocol is not created and an error message is displayed. This error message can be 

avoided e.g. with a condition in a formula an empty content is created for this field. 

This can be done with a formula, which only creates an entry if the user is a member 

of a certain group (e.g. users): 

«Cond(Contains (cRM.User.Groups,"'Users '"), Action.TemplateDescription,"")» 
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21. Appendix 

21.1 Support 

You can reach the knowledgebase, support area and check for updates through the 

menu F i le  > Help > Support. Advice about the support concept can be found in the 

internet under www.support.combit.net. 

21.2 Overview of Configuration files/data 

All information on this topic, see the document "cRM_Config_EN.pdf" in the cRM 

installation directory "Docu". 

21.3 Optimization of the operating speed 

All information on this can be found in the Knowledgebase article (german only) 

"Performance-Optimierung cRM6" at www.combit.net/de/support/kb. 

21.4 Data backup 

As your data is vital for your business we strongly recommend a daily backup. If your 

data is being modified more frequently you should back it up even several times a day. 

Consider (besides other) in particular the following data: 

▪ Setup the database backup directly in the database system (the system database 

"combit_cRM_System" and - if you use the provided standard solution - the database 

"combit_*").  

▪ Backup the entire project directory (including input form definitions, scripts, transfer 

templates, global export/import templates, print templates). e.g.: C:\Program 

Files\combit\cRM\Solutions\combit_*. 

▪ Backup the individual user settings and possibly user-defined templates in the 

application data directory. e.g.: C:\Users\<Username>\AppData\Roaming\combit\ 

cRM. 

▪ Backup all other files, which are not stored in the project directory. 

▪ We additionally recommend a regular complete backup of the whole system (server 

and clients). 

Please note the fact that the preceding information is only an example and has to be 

seen in the context of your own backup strategy. 

http://www.support.combit.net/
http://www.combit.net/de/support/kb/search.asp?article=KBAD001235
http://www.combit.net/de/support/kb
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21.5 Ribbon and toolbars 

Here you will find an overview of the main menu functions in the ribbon and the 

corresponding position in the toolbar. 

Position in toolbar to position in ribbon 

Project 
Comma nd in Toolba r  Comma nd in R ibbon  

File > New File > New 

File > Open > File File > Open > Open 

File > Open > Solution-Center File > Open > Solution Center 

File > Save File > Save 

File > Save as File > Save As 

File > Reorganize File > Information > Reorganize 

File > Provide for WebAccess File > Information > Provide for WebAccess 

File > Exit File > Exit 

Views > New Context Menu on view in Project window > New 

Views > Open Start > Open > View > Go to > View or Context Menu on view in 

Project window > Open 
Views > Properties Settings > View > Properties or Context Menu on view in Project 

window > Properties 
Views > Delete Context Menu on view in Project window > Delete 

Views > Info Center Window > Switch to > Info Center 

Views > Appointments & Tasks Window > Switch to > Appointments and Tasks 

Views > Calls Window > Switch to > Calls 

Windows > Toolbars > Toolbar Project No equivalent 

Windows > Toolbars > Status Bar Windows > Show > Status Bar 

Windows > Toolbars > Customize No equivalent 

Windows > Navigation Windows > Show > Navigation Area 

Windows > Dupes Windows > Show > Dupes 

Windows > Global Search Result Windows > Show > Search Results 

Windows > Tabs No equivalent 

Windows > Cascade No equivalent 

Windows > Tile Horizontally No equivalent 

Windows > Arrange Icons No equivalent 

Windows > Close All Windows > Window > Close All 

Windows > Windows Windows > Window > Switch Window 



Ribbon and toolbars 

319 

Settings > General File > Options > General 

Settings > Project > Properties File > Information > Properties 

Settings > Project > Events File > Information > Events 

Settings > Project > Navigation Structure File > Information > Navigation Structure 

Settings > Project > Company Master Data File > Information > Company Master Data 

Settings > Project > Import File > Information > Project Import 

Settings > Sounds File > Options > Sounds 

Settings > Database > Database Connection File > Options > Database Login 

Settings > Database > Database Structure File > Information > Database Structure 

Settings > Administration > Users File > Options > User Administration 

Settings > Administration > Auto Counter File > Information > Auto Counter 

Settings > Change User Password File > Options > Change Password 

Settings > DMS Login Information File > Options > DMS Login 

? > Help Topics File > Help 

? > Contact File > Help > Contact 

? > Online Registration File > Help > Online Registration 

? > Online Support > Knowledgebase File > Help > Support > Knowledgebase 

? > Online Support > Forums File > Help > Support > Forums 

? > Online Support > Support Area File > Help > Support > Support Area 

? > Online Support > Check for Updates (Internet) File > Help > Online Update Check 

? > Online Support > Participate in Online Session File > Help > Support > Participate in Online Session 

? > Tools > address pick-up File > Help > Tools > address pick-up 

? > Tools > E-Mail Autopilot File > Help > Tools > E-Mail Autopilot 

? > Tools > LDAP Server File > Help > Tools > LDAP Server 

? > Tools > Workflow Server File > Help > Tools > Workflow Server 

? > Tools > License Upgrade File > Help > Tools > License Upgrade 

? > Tools > Solution Distribution File > Help > Tools > Solution Distribution 

? > Tools > Debug Tool File > Help > Tools > Debug Tool 

? > About File > Help > Info About combit Relationship Manager 

Views 
Comma nd in Toolba r  Comma nd in R ibbon  

Record  > New Start > Record  > New 

Record  > Edit Start > Record  > Edit 

Record  > Edit in New Window Start > Record  > Edit > Edit in New Window 
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Record  > Save Changes Context > Save 

Record  > Save and Close View Changes Context > Save & Close 

Record  > Discard Changes Changes Context > Cancel 

Record  > Delete Start > Record > Delete 

Record  > Delete All Start > Record > Delete > Delete All 

Record  > Duplicate Start > Record  > New > Duplicate 

Record  > Merge Start > Record > Extended > Merge Records 

Record  > Go To > First Go To > First Record 

Record  > Go To > Next Go To > Previous Record 

Record  > Go To > Previous Go To > Next Record 

Record  > Go To > Last Go To > Last Record 

Record  > Reference > Send To Start > Record > Reference > Send To 

Record  > Reference > Save as Start > Record > Reference > Save as 

Record  > Reference > Copy to Clipboard Start > Record > Reference > Copy to Clipboard 

Record  > Reference > Add to Favorites Start > Record > Reference > Add to Favourites 

Record  > Watch Start > Record > Extended > Watch Record 

Record  > Dial Start > Actions > Dial 

Record  > Send E-mail Start > Actions > Send E-mail 

Edit > Undo Changes Context > Undo 

Edit > Cut Changes Context > Cut 

Edit > Copy Changes Context > Copy 

Edit > Paste Changes Context > Paste 

Find > Quickfind Start > Find > Quick Find 

Find > Find Start > Find > Find 

Find > Phone Number or E-mail Start > Find > Special Find 

Find > Current Record in Online Directories Start > Find > In Directories > Find Record in Online Directories 
and Social Media 

Find > Phone Directory > Find Current Record Start > Find > In Directories > Find Record in Phone Directory 

Find > Phone Directory > Transfer Manually Start > Find > In Directories > Manual Transfer from a Phone 
Directory 

Find > Route Planning > Set Current Record as 

Starting Point 

Start > Actions > Route Planning > Set Current Record as 

Starting Point 
Find > Route Planning > Set Current Record as 
Stopover 

Start > Actions > Route Planning > Set Current Record as 
Stopover 

Find > Route Planning > Set Current Record as 
Endpoint 

Start > Actions > Route Planning > Set Current Record as 
Endpoint 

Find > Route Planning > Set All Records in Filter 
as Waypoints 

Start > Actions > Route Planning > Set All Records in Filter as 
Waypoints 

Find > Route Planning > Remove All Waypoints Start > Actions > Route Planning > Remove All Waypoints 
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Find > Route Planning > Route Planning Start > Actions > Route Planning > Route Planning 

Find > Route Planning > Get Directions to Current 
Record 

Start > Actions > Route Planning > Get Directions to Current 
Record 

Find > Replace Start > Find > Replace 

Filter > General Start > Filter > Create Filter or Filter > Compose > General Filter 

Filter > Full Text Query Filter > Compose > Full Text Query 

Filter > Query by Example Filter > Compose > Query By Example 

Filter > Free SQL Query Filter > Compose > Free SQL Query 

Filter > Manual > Compose Filter> Manually > Compose 

Filter > Manual > Apply/Cancel Filter> Manually > Apply 

Filter > Manual > Include Record Filter> Manually > Include Record 

Filter > Manual > Exclude Record Filter> Manually > Exclude Record 

Filter > Manual > Include All Records Filter> Manually > Include All 

Filter > Manual > Exclude All Records Filter> Manually > Exclude All 

Filter > Manual > Load Record Selection Filter> Manually > Record Selection > Load Manual Filter 

Filter > Manual > Save Record Selection Filter> Manually > Record Selection > Save Manual Filter 

Filter > Manual > Cancel Record Selection Filter> Manually > Cancel Selection 

Filter > Dupes Filter > Compose > Dupe Check 

Filter > Execute Filter Expression Filter > Compose > Execute Filter Expression 

Filter > Manage Filter Expressions Settings > Manage > Filter Expressions 

Filter > Last Filter Start > Filter > Active Last Filter or Filter > Compose > Last Filter 

Filter > Undo Filter Filter > Compose > Undo Filter 

Filter > Invert Filter Filter > Compose > Invert Filter 

Filter > Transfer Filter to phone manager Data > Transfer > Transfer Filter to phone manager 

Filter > Save Filter as Manual Filter Filter > Manually > Record Selection > Save Current Filter as 
Manual Filter 

Organize > Sort Orders Settings > Manage > Sort Orders 

Organize > Import Data > External Data > Import 

Organize > Export Data > External Data > Export 

Organize > Synchronize Data > External Data > Import With Synchronization 

Organize > Enrich Records From Phone Directory Data > Edit > Data Enrichment 

Organize > Modify Data > Edit > Modify 

Organize > Append Relationally > General Data > Edit > Append Relationally > General 

Organize > Append Relationally > Execute 

Template 

Data > Edit > Append Relationally > Execute Template 

Organize > Append Relationally > Mange 
Templates 

Settings > Templates > Relational Appending 

Output > Transfer Record Output > Current Record > Transfer to Word Processor 
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Output > Single E-mail Output > Current Record > Send E-mail 

Output > Single Letter > Direct Output > Current Record > Print Letter 

Output > Single Letter > Word Processor Output > Current Record > Transfer to Word Processor 

Output > Single Print > General Output > Current Record > Print 

Output > Single Print > Label Output > Current Record > Print Single Label 

Output > Single Print > Card Output > Current Record > Print Single Card 

Output > Single Print > List Output > Current Record > Print List (Report) for Record 

Output > Multiple E-mail Output > All Records > Send Multiple E-mail 

Output > Mail Merge Letter > Direct Output > All Records > Print Multiple Letters 

Output > Mail Merge Letter > Word Processor Output > All Records > Multiple Letter via Word Processor 

Output > Multiple Print > General Output > All Records > Multiple Print 

Output > Multiple Print > Labels Output > All Records > Multiple Print > Print Labels 

Output > Multiple Print > Cards Output > All Records > Multiple Print > Print Cards 

Output > Multiple Print > List Output > All Records > Multiple Print > Print Lists/Reports 

Output > Statistics Output > Analysis > Statistics 

Output > Instant Report Output > Analysis > Instant Report 

Schedule > New Appointment for Record Appointments/Tasks > New > Appointment for Record 

Schedule > Show Appointment for Record Appointments/Tasks > New > Task for Record 

Schedule > Appointment List Appointments/Tasks > Show > Appointment for Record 

Schedule > New Task for Record Appointments/Tasks > Show > Task for Record 

Schedule > Show Tasks for Record Appointments/Tasks > Show > Appointment List 

Schedule > Task List Appointments/Tasks > Show > Task List 

Schedule > Show Appointments / Tasks Appointments/Tasks > Switch to > Appointsments and Tasks 

View > List View Start > Show > View > List View 

View > Input Form Start > Show > View > Input Form 

View > Web Start > Show > View > Web 

View > Report Start > Show > View > Report 

View > Toolbars > Standard No equivalent 

View > Toolbars > Clipboard No equivalent 

View > Toolbars > Find No equivalent 

View > Toolbars > Navigation No equivalent 

View > Toolbars > Sort Order No equivalent 

View > Toolbars > Filter No equivalent 

View > Toolbars > Manual Filter No equivalent 
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View > Toolbars > Route Planning No equivalent 

View > Toolbars > Alphabetical Filter No equivalent 

View > Toolbars > Status Bar Window > Show > Status Bar 

View > Toolbars > Customize Window > Customize > Ribbon 

View > Swtich to > Open View Window > Switch to > View 

View > Swtich to > Info Center Window > Switch to > Info Center 

View > Swtich to > Appointments and Tasks Window > Switch to > Appointments and Tasks 

View > Swtich to > Calls Window > Switch to > Calls 

View > Refresh Window > View > Refresh 

Tools > Script > Execute Start > Actions > Scripts & Workflows > Execute Script or 
Settings > Manage > Scripts > Execute 

Tools > Script > Edit Settings > Manage > Scripts > Edit 

Tools > Script > New Settings > Manage > Scripts > New 

Tools > Script > Encrypt Settings > Manage > Scripts > Encrypt 

Tools > Workflow > Execute Start > Actions > Scripts & Workflows > Execute Workflow or 
Settings > Manage > Workflows > Execute 

Tools > Workflow > Edit Settings > Manage > Workflows > Edit 

Tools > Workflow > New Settings > Manage > Workflows > New 

Tools > nn. Application / Script / Workflow Start > Actions > Scripts & Workflows > nn. Application / Script / 

Workflow 
Settings > View Settings > View > Properties 

Settings > Input Form Settings > View > Input Form 

Settings > Input Form WebAccess Settings > View > Input Form > Input Form Webaccess 

Settings > Transfer Template > Select Settings > Templates > Transfer Templates > Select 

Settings > Transfer Template > Edit Settings > Templates > Transfer Templates > Edit 

Settings > E-mail Template Settings > Templates > E-mails 

Settings > Phone & Online Directories / Route 
Planning 

Settings > Manage > Directories + Route Planners 

Settings > Print > Labels Settings > Templates > Labels 

Settings > Print > Cards Settings > Templates > Cards/Letters 

Settings > Print > Lists Settings > Templates > Lists/Reports 

Settings > Print > Direct Letters / Mail Merge Settings > Templates > Direct Single/Multiple Letters 

Settings > Instant Reports Settings > Manage > Instant Reports 

Appointments/Tasks 
Comma nd in Toolba r  Comma nd in R ibbon  

Record > New Appointment Start > New > Appointment 

Record > New Task Start > New > Appointment 
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Record > Edit Appointment > Edit > Edit 

Record > Delegate Appointment > Edit > Delegate 

Record > Delete Appointment > Edit > Delete 

Record > Delete All > Appointments Start > Data > Delete > Delete All Appointments 

Record > Delete All > Tasks Start > Data > Delete > Delete All Tasks 

Record > Go to Record Start > Go to > Record 

Filter > Users Start > Filter > User 

Filter > Appointments Start > Filter > Appointments 

Filter > Tasks Start > Filter > Tasks 

Organize > Sort Orders for Appointments Settings > Settings > Sort Orders > Appointments 

Organize > Sort Orders for Tasks Settings > Settings > Sort Orders > Tasks 

Organize > Import Start > Data > Import 

Organize > Export Start > Data > Export 

Output > Appointment List Output > Output > Lists > Appointments 

Output > Tasks List Output > Output > Lists > Tasks 

Output > Appointment Cards Output > Output > Cards > Appointments 

Output > Task Cards Output > Output > Cards > Tasks 

Output > Calendar View Output > Output > Calendar 

View > Day View Start > View > Day 

View > Working Week View Start > View > Working Week 

View > Week View Start > View > Week 

View > Month View Start > View > Month 

View > Appointment List Start > View > Appointment List 

View > Task List Start > View > Tasks 

View > Toolbars > Default No equivalent 

View > Toolbars > Navigation No equivalent 

View > Toolbars > Filter No equivalent 

View > Toolbars > Status Bar No equivalent 

View > Refresh Window > View > Refresh 

View > Go to Today Start > Go to > Today 

Settings > General Settings > Settings > Options 

Settings > Resources Settings > Settings > Resources 

Settings > Categories Settings > Settings > Categories 

Settings > Print > Lists > Appointments Settings > Print Templates > Lists > Appointments 



Ribbon and toolbars 

325 

Settings > Print > Lists > Tasks Settings > Print Templates > Lists > Tasks 

Settings > Print > File Cards > Appointments Settings > Print Templates > Cards > Appointments 

Settings > Print > File Cards > Tasks Settings > Print Templates > Cards > Tasks 

Settings > Print > Calendar View Settings > Print Templates > Calendar 

phone manager 
Comma nd in Toolba r  Comma nd in R ibbon 

File > Exit File > Exit 

Edit > Delete Item Start > Edit > Delete Item 

Edit > Move Item Start > Edit > Move Item 

Edit > Delete All Items Start > Edit > Delete Item > Delete All Items 

Edit > Switch to Application Start > Edit > Switch to Application 

Edit > Add Log to Record Start > Edit > Add Log to Record 

View > Standard No equivalent 

Dial > Dial Start > Dial > Dial 

Dial > Pause Start > Dial > Pause 

Dial > Next Start > Dial > Next 

Dial > Manual Start > Dial > Manual 

Dial > Powerdialing Start > Dial > Powerdialing 

Output > List of Calls Start > Output > List of Calls 

Tools > Simulate Incoming Call File > Options > General > Simulate Incoming Call 

Tools > Activate Network Functionality File > Options > General > Activate Network Functionality 

Settings > Dial Device File > Options > General > Dial Device 

Settings > Telephony System File > Options > General > Telephony System 

Settings > Dial Device Properties File > Options > General > Dial Device Properties 

Settings > Incoming Call Detection File > Options > General > Incoming Call Detection 

Settings > Sounds File > Options > Sounds 

Settings > Sending of SMS Messages File > Options > General > Sending of SMS Messages 

Settings > List of Calls Print Template File > Options > General > List of Calls Print Template 

? > Help File > Help 

? > About No equivalent 

eMail 
Comma nd in Toolba r  Comma nd in R ibbon  

File > New File > New 

File > Open File > Open 
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File > Save File > Save 

File > Save As File > Save As 

File > Import File > Import 

File > Send Start > Message > Send 

File > Exit File > Exit 

Paste > Attachment > File Start > Paste > Attachment > File 

Paste > Attachment > Formular Start > Paste > Attachment > Formular 

Paste > Fields Start > Paste > Fields 

Paste > Table > New Table Start > Paste > Table > New Table 

Paste > Table > Insert Row Start > Paste > Table > Insert Row 

Paste > Table > Insert Column Start > Paste > Table > Insert Column 

Paste > Table > Insert Cell Start > Paste > Table > Insert Cell 

Paste > Table > Delete Row Start > Paste > Table > Delete Row 

Paste > Table > Delete Column Start > Paste > Table > Delete Column 

Paste > Table > Delete Cell Start > Paste > Table > Delete Cell 

Paste > Table > Link Cells Start > Paste > Table > Link Cells 

Paste > Table > Split Cells Start > Paste > Table > Split Cells 

Paste > Picture Start > Paste > Picture 

Paste > Hyperlink Start > Paste > Hyperlink 

Format > Style Start > Text Formatting > Style 

Format > Character > Font Start > Text Formatting > Font 

Format > Character > Bold Start > Text Formatting > Bold 

Format > Character > Italic Start > Text Formatting > Italic 

Format > Character > Underlined Start > Text Formatting > Underlined 

Format > Character > Left Start > Text Formatting > Left 

Format > Character > Centered Start > Text Formatting > Centered 

Format > Character > Right Start > Text Formatting > Right 

Format > Character > Numbering Start > Text Formatting > Numbering 

Format > Character > Bullet Character Start > Text Formatting > Bullet Character 

Format > Character > Decrease Indent Start > Text Formatting > Decrease Indent 

Format > Character > Increase Indent Start > Text Formatting > Increase Indent 

Format > Background Start > Text Formatting > Background 

Format > Text Start > Format > Text 

Format > HTML Start > Format > HTML 
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Settings > E-mail Settings File > Options 

? > Help File > Help 

Position in the ribbon (alphabetically) to position in toolbar 

Project 

Comma nd in R ibbon  Comma nd in Toolba r  
Context Menu on view in Project window > Delete Views > Delete 

Context Menu on view in Project window > New Views > New 

File > Exit File > Exit 

File > Help ? > Help Topics 

File > Help > Contact ? > Contact 

File > Help > Info About combit Relationship 
Manager 

? > About 

File > Help > Online Registration ? > Online Registration 

File > Help > Online Update Check ? > Online Support > Check for Updates (Internet) 

File > Help > Support > Forums ? > Online Support > Forums 

File > Help > Support > Knowledgebase ? > Online Support > Knowledgebase 

File > Help > Support > Participate in Online 
Session 

? > Online Support > Participate in Online Session 

File > Help > Support > Support Area ? > Online Support > Support Area 

File > Help > Tools > address pick-up ? > Tools > address pick-up 

File > Help > Tools > Debug Tool ? > Tools > Debug Tool 

File > Help > Tools > E-Mail Autopilot ? > Tools > E-Mail Autopilot 

File > Help > Tools > LDAP Server ? > Tools > LDAP Server 

File > Help > Tools > License Upgrade ? > Tools > License Upgrade 

File > Help > Tools > Solution Distribution ? > Tools > Solution Distribution 

File > Help > Tools > Workflow Server ? > Tools > Workflow Server 

File > Information > Auto Counter Settings > Administration > Auto Counter 

File > Information > Company Master Data Settings > Project > Company Master Data 

File > Information > Database Structure Settings > Database > Database Structure 

File > Information > Events Settings > Project > Events 

File > Information > Navigation Structure Settings > Project > Navigation Structure 

File > Information > Project Import Settings > Project > Import 

File > Information > Properties Settings > Project > Properties 

File > Information > Provide for WebAccess File > Provide for WebAccess 

File > Information > Reorganize File > Reorganize 
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File > New File > New 

File > Open > Open File > Open > File 

File > Open > Solution Center File > Open > Solution-Center 

File > Options > Change Password Settings > Change User Password 

File > Options > Database Login Settings > Database > Database Connection 

File > Options > DMS Login Settings > DMS Login Information 

File > Options > General Settings > General 

File > Options > Sounds Settings > Sounds 

File > Options > User Administration Settings > Administration > Users 

File > Save File > Save 

File > Save As File > Save as 

Settings > View > Properties or Context Menu on 
view in Project window > Properties 

Views > Properties 

Start > Open > View > Go to > View or Context 
Menu on view in Project window > Open 

Views > Open 

Window > Switch to > Appointments and Tasks Views > Appointments & Tasks 

Window > Switch to > Calls Views > Calls 

Window > Switch to > Info Center Views > Info Center 

Windows > Show > Dupes Windows > Dupes 

Windows > Show > Navigation Area Windows > Navigation 

Windows > Show > Search Results Windows > Global Search Result 

Windows > Show > Status Bar Windows > Toolbars > Status Bar 

Windows > Window > Close All Windows > Close All 

Windows > Window > Switch Window Windows > Windows 

Views 

Comma nd in R ibbon Comma nd in Toolba r  
Appointments/Tasks > New > Appointment for 
Record 

Schedule > New Appointment for Record 

Appointments/Tasks > New > Task for Record Schedule > Show Appointment for Record 

Appointments/Tasks > Show > Appointment for 

Record 

Schedule > Appointment List 

Appointments/Tasks > Show > Appointment List Schedule > Show Tasks for Record 

Appointments/Tasks > Show > Task for Record Schedule > New Task for Record 

Appointments/Tasks > Show > Task List Schedule > Task List 

Appointments/Tasks > Switch to > 
Appointsments and Tasks 

Schedule > Show Appointments / Tasks 

Changes Context > Cancel Record  > Discard Changes 

Changes Context > Copy Edit > Copy 



Ribbon and toolbars 

329 

Changes Context > Cut Edit > Cut 

Changes Context > Paste Edit > Paste 

Changes Context > Save Record  > Save 

Changes Context > Save & Close Record  > Save and Close View 

Changes Context > Undo Edit > Undo 

Data > Edit > Append Relationally > Execute 
Template 

Organize > Append Relationally > Execute Template 

Data > Edit > Append Relationally > General Organize > Append Relationally > General 

Data > Edit > Data Enrichment Organize > Enrich Records From Phone Directory 

Data > Edit > Modify Organize > Modify 

Data > External Data > Export Organize > Export 

Data > External Data > Import Organize > Import 

Data > External Data > Import With 
Synchronization 

Organize > Synchronize 

Data > Transfer > Transfer Filter to phone 

manager 

Filter > Transfer Filter to phone manager 

Filter > Compose > Dupe Check Filter > Dupes 

Filter > Compose > Execute Filter Expression Filter > Execute Filter Expression 

Filter > Compose > Free SQL Query Filter > Free SQL Query 

Filter > Compose > Full Text Query Filter > Full Text Query 

Filter > Compose > Invert Filter Filter > Invert Filter 

Filter > Compose > Query By Example Filter > Query by Example 

Filter > Compose > Undo Filter Filter > Undo Filter 

Filter > Manually > Record Selection > Save 
Current Filter as Manual Filter 

Filter > Save Filter as Manual Filter 

Filter> Manually > Apply Filter > Manual > Apply/Cancel 

Filter> Manually > Cancel Selection Filter > Manual > Cancel Record Selection 

Filter> Manually > Compose Filter > Manual > Compose 

Filter> Manually > Exclude All Filter > Manual > Exclude All Records 

Filter> Manually > Exclude Record Filter > Manual > Exclude Record 

Filter> Manually > Include All Filter > Manual > Include All Records 

Filter> Manually > Include Record Filter > Manual > Include Record 

Filter> Manually > Record Selection > Load 
Manual Filter 

Filter > Manual > Load Record Selection 

Filter> Manually > Record Selection > Save 
Manual Filter 

Filter > Manual > Save Record Selection 

Go To > First Record Record  > Go To > First 

Go To > Last Record Record  > Go To > Last 

Go To > Next Record Record  > Go To > Previous 
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Go To > Previous Record Record  > Go To > Next 

Output > All Records > Multiple Letter via Word 
Processor 

Output > Mail Merge Letter > Word Processor 

Output > All Records > Multiple Print Output > Multiple Print > General 

Output > All Records > Multiple Print > Print 
Cards 

Output > Multiple Print > Cards 

Output > All Records > Multiple Print > Print 

Labels 

Output > Multiple Print > Labels 

Output > All Records > Multiple Print > Print 
Lists/Reports 

Output > Multiple Print > List 

Output > All Records > Print Multiple Letters Output > Mail Merge Letter > Direct 

Output > All Records > Send Multiple E-mail Output > Multiple E-mail 

Output > Analysis > Instant Report Output > Instant Report 

Output > Analysis > Statistics Output > Statistics 

Output > Current Record > Print Output > Single Print > General 

Output > Current Record > Print Letter Output > Single Letter > Direct 

Output > Current Record > Print List (Report) for 
Record 

Output > Single Print > List 

Output > Current Record > Print Single Card Output > Single Print > Card 

Output > Current Record > Print Single Label Output > Single Print > Label 

Output > Current Record > Send E-mail Output > Single E-mail 

Output > Current Record > Transfer to Word 
Processor 

Output > Transfer Record 

Output > Current Record > Transfer to Word 
Processor 

Output > Single Letter > Word Processor 

Settings > Manage > Directories + Route 

Planners 

Settings > Phone & Online Directories / Route Planning 

Settings > Manage > Filter Expressions Filter > Manage Filter Expressions 

Settings > Manage > Instant Reports Settings > Instant Reports 

Settings > Manage > Scripts > Edit Tools > Script > Edit 

Settings > Manage > Scripts > Encrypt Tools > Script > Encrypt 

Settings > Manage > Scripts > New Tools > Script > New 

Settings > Manage > Sort Orders Organize > Sort Orders 

Settings > Manage > Workflows > Edit Tools > Workflow > Edit 

Settings > Manage > Workflows > New Tools > Workflow > New 

Settings > Templates > Cards/Letters Settings > Print > Cards 

Settings > Templates > Direct Single/Multiple 
Letters 

Settings > Print > Direct Letters / Mail Merge 

Settings > Templates > E-mails Settings > E-mail Template 

Settings > Templates > Labels Settings > Print > Labels 

Settings > Templates > Lists/Reports Settings > Print > Lists 

Settings > Templates > Relational Appending Organize > Append Relationally > Mange Templates 
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Settings > Templates > Transfer Templates > Edit Settings > Transfer Template > Edit 

Settings > Templates > Transfer Templates > 
Select 

Settings > Transfer Template > Select 

Settings > View > Input Form Settings > Input Form 

Settings > View > Input Form > Input Form 
Webaccess 

Settings > Input Form WebAccess 

Settings > View > Properties Settings > View 

Start > Actions > Dial Record  > Dial 

Start > Actions > Route Planning > Get Directions 

to Current Record 

Find > Route Planning > Get Directions to Current Record 

Start > Actions > Route Planning > Remove All 
Waypoints 

Find > Route Planning > Remove All Waypoints 

Start > Actions > Route Planning > Route 
Planning 

Find > Route Planning > Route Planning 

Start > Actions > Route Planning > Set All 
Records in Filter as Waypoints 

Find > Route Planning > Set All Records in Filter as Waypoints 

Start > Actions > Route Planning > Set Current 
Record as Endpoint 

Find > Route Planning > Set Current Record as Endpoint 

Start > Actions > Route Planning > Set Current 

Record as Starting Point 

Find > Route Planning > Set Current Record as Starting Point 

Start > Actions > Route Planning > Set Current 
Record as Stopover 

Find > Route Planning > Set Current Record as Stopover 

Start > Actions > Scripts & Workflows > nn. 
Application / Script / Workflow 

Tools > nn. Application / Script / Workflow 

Start > Actions > Scripts & Workflows > Execute 

Script or Settings > Manage > Scripts > Execute 

Tools > Script > Execute 

Start > Actions > Scripts & Workflows > Execute 
Workflow or Settings > Manage > Workflows > 
Execute 

Tools > Workflow > Execute 

Start > Actions > Send E-mail Record  > Send E-mail 

Start > Filter > Active Last Filter or Filter > 

Compose > Last Filter 

Filter > Last Filter 

Start > Filter > Create Filter or Filter > Compose 
> General Filter 

Filter > General 

Start > Find > Find Find > Find 

Start > Find > In Directories > Find Record in 
Online Directories and Social Media 

Find > Current Record in Online Directories 

Start > Find > In Directories > Find Record in 
Phone Directory 

Find > Phone Directory > Find Current Record 

Start > Find > In Directories > Manual Transfer 
from a Phone Directory 

Find > Phone Directory > Transfer Manually 

Start > Find > Quick Find Find > Quickfind 

Start > Find > Replace Find > Replace 

Start > Find > Special Find Find > Phone Number or E-mail 

Start > Record  > Edit Record  > Edit 

Start > Record  > Edit > Edit in New Window Record  > Edit in New Window 

Start > Record  > New Record  > New 

Start > Record  > New > Duplicate Record  > Duplicate 

Start > Record > Delete Record  > Delete 
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Start > Record > Delete > Delete All Record  > Delete All 

Start > Record > Extended > Merge Records Record  > Merge 

Start > Record > Extended > Watch Record Record  > Watch 

Start > Record > Reference > Add to Favourites Record  > Reference > Add to Favorites 

Start > Record > Reference > Copy to Clipboard Record  > Reference > Copy to Clipboard 

Start > Record > Reference > Save as Record  > Reference > Save as 

Start > Record > Reference > Send To Record  > Reference > Send To 

Start > Show > View > Input Form View > Input Form 

Start > Show > View > List View View > List View 

Start > Show > View > Report View > Report 

Start > Show > View > Web View > Web 

Window > Customize > Ribbon View > Toolbars > Customize 

Window > Show > Status Bar View > Toolbars > Status Bar 

Window > Switch to > Appointments and Tasks View > Swtich to > Appointments and Tasks 

Window > Switch to > Calls View > Swtich to > Calls 

Window > Switch to > Info Center View > Swtich to > Info Center 

Window > Switch to > View View > Swtich to > Open View 

Window > View > Refresh View > Refresh 

Appointments/Tasks 

Comma nd in R ibbon Comma nd in Toolba r  
Appointment > Edit > Delegate Record > Delegate 

Appointment > Edit > Delete Record > Delete 

Appointment > Edit > Edit Record > Edit 

Output > Output > Calendar Output > Calendar View 

Output > Output > Cards > Appointments Output > Appointment Cards 

Output > Output > Cards > Tasks Output > Task Cards 

Output > Output > Lists > Appointments Output > Appointment List 

Output > Output > Lists > Tasks Output > Tasks List 

Settings > Print Templates > Calendar Settings > Print > Calendar View 

Settings > Print Templates > Cards > 
Appointments 

Settings > Print > File Cards > Appointments 

Settings > Print Templates > Cards > Tasks Settings > Print > File Cards > Tasks 

Settings > Print Templates > Lists > 
Appointments 

Settings > Print > Lists > Appointments 

Settings > Print Templates > Lists > Tasks Settings > Print > Lists > Tasks 

Settings > Settings > Categories Settings > Categories 



Ribbon and toolbars 

333 

Settings > Settings > Options Settings > General 

Settings > Settings > Resources Settings > Resources 

Settings > Settings > Sort Orders > 
Appointments 

Organize > Sort Orders for Appointments 

Settings > Settings > Sort Orders > Tasks Organize > Sort Orders for Tasks 

Start > Data > Delete > Delete All Appointments Record > Delete All > Appointments 

Start > Data > Delete > Delete All Tasks Record > Delete All > Tasks 

Start > Data > Export Organize > Export 

Start > Data > Import Organize > Import 

Start > Filter > Appointments Filter > Appointments 

Start > Filter > Tasks Filter > Tasks 

Start > Filter > User Filter > Users 

Start > Go to > Record Record > Go to Record 

Start > Go to > Today View > Go to Today 

Start > New > Appointment Record > New Appointment 

Start > New > Appointment Record > New Task 

Start > View > Appointment List View > Appointment List 

Start > View > Day View > Day View 

Start > View > Month View > Month View 

Start > View > Tasks View > Task List 

Start > View > Week View > Week View 

Start > View > Working Week View > Working Week View 

Window > View > Refresh View > Refresh 

Appointment > Edit > Delegate Record > Delegate 

Appointment > Edit > Delete Record > Delete 

Appointment > Edit > Edit Record > Edit 

Output > Output > Calendar Output > Calendar View 

phone manager 

Comma nd in R ibbon  Comma nd in Toolba r  

File > Exit File > Exit 

File > Help ? > Help 

File > Options > General > Activate Network 
Functionality 

Tools > Activate Network Functionality 

File > Options > General > Dial Device Settings > Dial Device 

File > Options > General > Dial Device Properties Settings > Dial Device Properties 

File > Options > General > Incoming Call 
Detection 

Settings > Incoming Call Detection 
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File > Options > General > List of Calls Print 
Template 

Settings > List of Calls Print Template 

File > Options > General > Sending of SMS 
Messages 

Settings > Sending of SMS Messages 

File > Options > General > Simulate Incoming Call Tools > Simulate Incoming Call 

File > Options > General > Telephony System Settings > Telephony System 

File > Options > Sounds Settings > Sounds 

Start > Dial > Dial Dial > Dial 

Start > Dial > Manual Dial > Manual 

Start > Dial > Next Dial > Next 

Start > Dial > Pause Dial > Pause 

Start > Dial > Powerdialing Dial > Powerdialing 

Start > Edit > Add Log to Record Edit > Add Log to Record 

Start > Edit > Delete Item Edit > Delete Item 

Start > Edit > Delete Item > Delete All Items Edit > Delete All Items 

Start > Edit > Move Item Edit > Move Item 

Start > Edit > Switch to Application Edit > Switch to Application 

Start > Output > List of Calls Output > List of Calls 

eMail 

Comma nd in R ibbon  Comma nd in Toolba r  
File > Exit File > Exit 

File > Help ? > Help 

File > Import File > Import 

File > New File > New 

File > Open File > Open 

File > Options Settings > E-mail Settings 

File > Save File > Save 

File > Save As File > Save As 

Start > Format > HTML Format > HTML 

Start > Format > Text Format > Text 

Start > Message > Send File > Send 

Start > Paste > Attachment > File Paste > Attachment > File 

Start > Paste > Attachment > Formular Paste > Attachment > Formular 

Start > Paste > Fields Paste > Fields 

Start > Paste > Hyperlink Paste > Hyperlink 

Start > Paste > Picture Paste > Picture 
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Start > Paste > Table > Delete Cell Paste > Table > Delete Cell 

Start > Paste > Table > Delete Column Paste > Table > Delete Column 

Start > Paste > Table > Delete Row Paste > Table > Delete Row 

Start > Paste > Table > Insert Cell Paste > Table > Insert Cell 

Start > Paste > Table > Insert Column Paste > Table > Insert Column 

Start > Paste > Table > Insert Row Paste > Table > Insert Row 

Start > Paste > Table > Link Cells Paste > Table > Link Cells 

Start > Paste > Table > New Table Paste > Table > New Table 

Start > Paste > Table > Split Cells Paste > Table > Split Cells 

Start > Text Formatting > Background Format > Background 

Start > Text Formatting > Bold Format > Character > Bold 

Start > Text Formatting > Bullet Character Format > Character > Bullet Character 

Start > Text Formatting > Centered Format > Character > Centered 

Start > Text Formatting > Decrease Indent Format > Character > Decrease Indent 

Start > Text Formatting > Font Format > Character > Font 

Start > Text Formatting > Increase Indent Format > Character > Increase Indent 

Start > Text Formatting > Italic Format > Character > Italic 

Start > Text Formatting > Left Format > Character > Left 

Start > Text Formatting > Numbering Format > Character > Numbering 

Start > Text Formatting > Right Format > Character > Right 

Start > Text Formatting > Style Format > Style 

Start > Text Formatting > Underlined Format > Character > Underlined 

21.6 Data types 

This chapter describes the most important data types in PostgreSQL and MS SQL. This 

information is provided without any guarantees of being correct.  

Advice for the selection of a numerical data type: 

▪ For whole numbers, the "int" type is the most common choice, since it provides the 

best balance between range, memory size and efficiency. The "smallint" type is 

normally only used when storage space is limited. The "bigint" type should only be 

used when the "int" range is not sufficient, since the latter is faster. 

▪ The "numeric" type can be recommended for saving monetary values and other 

values where accuracy is required. The "numeric" type is very slow in comparison to 

the floating point types. The "money" type is outdated. 
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Category Data type  

MS SQL 

Data type  

PostgreSQL 

Description  

Date/time timestamp, 

datetime 

timestamp Date and time 

  date Date 

  time Time with time zone 

digits bigint int8, bigint Integers from -2^63 to 2^63-1 

 int int, int4, integer Integers from -2^31 to 2^31-1  

 smallint int2, smallint Integers from -2^15 to 2^15-1 

 tinyint  Intergers from 0 – 255 

 bit  Integers with values 1 or 0 -> 

logical field 

 decimal, numeric  Numerical data with set 

accuracy and decimal places 

from -10^38+1 to 10^38-1 

  decimal, numeric Floating point number with user-

defined precision and exact 

saving. 

 float  Numerical data with un-fixed 

accuracy (Float) from -

1.79*10^308 to 1.79*10^308 

  float8, double 

precision 

Floating point number with 15 

decimal place precision and 

validity range from -10^308 to 

10^308 

 real  Numerical data with non-fixed 

accuracy (float) from -

3.40*10^38 to 3.40*10^38 

  real, float4 Floating point number with 6 



Data types 

337 

Category Data type  

MS SQL 

Data type  

PostgreSQL  

Description  

decimal place precision and 

validity range from -10^37 to 

10^37 

characters char  Character data of fixed length 

with a maximum length of 8000 

characters. 

  char, character Character data of fixed length 

with a maximum length of 

10485760 characters. 

 varchar  Character data of variable length 

with up to 8000 characters. 

  varchar, 

character varying 

Character data of variable length 

with up to 10485760 characters. 

 text text Character data of variable length 

with up to 2^31-1 characters. 

 nchar  Unicode data of fixed length 

with a maximum length of 4000 

characters.  

 nvarchar  Unicode data of variable length 

with a maximum length of 4000 

characters.  

 ntext  Unicode data of variable length 

with a maximum length of 

2^30-1 characters. 

special binary bytea Binary data of fixed length with 

a maximum length of 8000 

bytes. 

 varbinary  Binary data of variable length 

with a maximum length of 8000 
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Category Data type  

MS SQL 

Data type  

PostgreSQL 

Description  

bytes.  

 image  Image data. 

 sql_variant  Can be used in functions and 

supports values and other data 

types.  

 uniqueidentifier  A globally unique identifier 

(GUID)  

  bool, boolean True or false (or unknown if 

NULL)  
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22. Index 

%  

%APPDIR% .......................................... 273 

%PRJDIR% ........................................... 273 

@ 

@User .................................................... 230 

A  

Active Directory.................................... 307 

Activity management .......................... 112 

Add to systray ...................................... 209 

Add-on 

David add-on .................................... 115 

Thunderbird add-on......................... 115 

Address enrichment ...............................74 

address manager ....................................35 

address pick-up .......................................62 

Address visualization........................... 150 

Addresses 

Transfer ................................................62 

Alphabetic Filter ......................................48 

Android ............................................16, 110 

Access ..................................................30 

Appending................................................72 

Appointments and tasks..................... 101 

Calendar overview ........................... 106 

Configuration.................................... 108 

Control of conflicts.......................... 104 

Dayview............................................. 106 

Defer .................................................. 106 

Delegate ............................................ 106 

Edit ..................................................... 106 

Export ................................................ 109 

Filters ................................................. 107 

iCalendar ........................................... 109 

Import ................................................ 109 

Lotus Notes ...................................... 109 

Monthview ........................................ 106 

Outlook .............................................. 109 

Print .................................................... 106 

Private appointments ...................... 103 

Reminders......................................... 105 

Snooze ............................................... 105 

Sort order .......................................... 107 

Tobit David Client............................. 109 

Weekview.......................................... 106 

Area code directory ............................... 61 

Asynchronous scripts.......................... 273 

Audio signals......................................... 213 

Auto Hide................................................. 41 

Auto log .......................................... 60, 197 

Automatic counters ............................. 195 

Automatic login .................................... 309 

Automatic numbering.......................... 194 

Automatisms........................................... 59 

Activity management ...................... 112 

Auto Log ............................................ 197 

Content link....................................... 288 

Customer number............................ 194 

Document management ................ 199 

E-mail archiving ................................ 203 

Function definitions......................... 194 

P.O. box directory .............................. 61 

Run external program ....................... 62 

Scripting ............................................ 271 

Telephony.......................................... 120 

Workflow Designer.......................... 255 

Workflows ......................................... 245 

ZIP codes............................................. 61 

Autopilot ................................................ 250 

Autotext .......................................... 60, 287 

B  

Backup ................................................... 317 

Base address .......................................... 84 

Blackberry....................................... 16, 110 
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Access.................................................. 30 

Bookmark...............................................222 

Buttons ...................................................302 

C  

Calculating in fields ..............................289 

Campaigns....................................132, 211 

Cascaded deleting................................191 

Change position...........................283, 284 

Charts ............................................148, 149 

Check for updates .................................. 34 

Checkboxes ...........................................298 

Choosing ..................................... See Filter 

Client.exe ................................................. 24 

Codes 

Defining..............................................192 

combit tip wizard .................................... 47 

Comboboxes .................................. 60, 295 

Company master data .........................181 

Configuration 

Appointments and tasks .................108 

Clock...................................................208 

Column titles ....................................... 44 

container .............................................. 42 

Create fields ......................................181 

Create table .......................................181 

Database structure ..........................181 

Document management.................199 

Field alias ...........................................186 

Field types ................................181, 186 

File cards ...........................................234 

Function definitions .........................194 

General...............................................209 

Input form..........................................275 

list view ................................................ 42 

Lists ....................................................234 

Numbering.........................................194 

Projects ..............................................173 

Record reference .............................206 

Ribbon .................................................. 45 

Sending mail .....................................210 

SMTP ................................................. 211 

Symbol in taskbar ............................ 209 

System management...................... 306 

Telephony ......................................... 123 

Transfer record ................................ 136 

Transfer template ............................ 136 

View ................................................... 184 

Webview ........................................... 206 

Configuration files................................ 317 

Connection 

Active Directory ............................... 307 

SocialMedia .........................................82 

Considerations ........................................57 

Constraints ............................................ 191 

Container ............................................... 301 

Column titles .......................................44 

Configuration.......................................42 

Filter .......................................... 100, 147 

Formatting ...........................................43 

Saving the layout ................................45 

Container filter................................95, 100 

Content link........................................... 288 

Conversation log .................................. 121 

Counters ................................................ 195 

Create indexes.........................................55 

Create tables......................................... 181 

cRMShip ................................................ 175 

cRM-Variables ...................................... 213 

CTI ...................................... See Telephony 

Customer number................................ 194 

Customize 

File cards........................................... 234 

Labels ................................................ 230 

Lists.................................................... 234 

Print templates................................. 225 

Reports.............................................. 234 

D  

Data backup.......................................... 317 

Data entry.................................................59 

Data output ..............................See Output 
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Data source........................................... 145 

Data transfer 

Address data .......................................62 

Telephone CDs ...................................83 

Data types ............................................. 335 

Database 

Attach database ............................... 175 

Data types......................................... 335 

Database Servers 

Microsoft SQL Server ........................15 

PostgreSQL .........................................15 

David 

Appointments and tasks ................ 109 

Groupware ........................................ 239 

Message archive ............................. 115 

Dialing unit ............................................ 124 

Digital signture ........................................18 

Digitally sign ................................ 144, 145 

Directions ..................See Route planning 

Docking and Floating .............................41 

Document Info ..................................... 204 

Document management .................... 112 

Assigning documents..................... 113 

Configuration.................................... 199 

Create new document .................... 113 

David message archive .................. 115 

DMS Document ............................... 199 

Document types .............................. 201 

Drag & Drop ...................................... 113 

Embedded File ................................. 199 

File Link ............................................. 199 

Opening documents ....................... 112 

Scanning in a document ................ 114 

Document Management System 

DocuWare ............................................18 

Login information ............................ 309 

System Requirements .......................17 

windream ....................................18, 309 

Document types .................................. 201 

Dokumenten Management System 

easyEnterprise ....................................18 

ELOoffice ............................................ 18 

ELOprofessional................................. 18 

SharePoint........................................... 18 

Drag & Drop........................................... 113 

Dupe check ............................................. 60 

Configuration .................................... 192 

Online dupe check........................... 192 

Dupes ....................................................... 96 

E 

Edit table structure .............................. 181 

Edition ...................................................... 33 

eMail 

Newsletter................................ 132, 211 

E-mail...................................................... 130 

Automatic archiving......................... 203 

Autopilot ............................................ 250 

Configuration .................................... 210 

David e-mail archive ........................ 115 

Direct via context menu.................. 211 

Extended MAPI ....................... 130, 210 

Formatting options .......................... 134 

HTML ........................................ 130, 134 

MAPI interface.................................. 130 

Sending.............................................. 130 

Single e-mail ..................................... 130 

SMTP.................................................. 130 

Templates ................................ 132, 211 

Text e-mails....................................... 130 

Thunderbird e-mail archive............. 115 

Embedded File...................................... 199 

Envelopes .............................................. 138 

Evaluations ............................................ 148 

Events for scripts ................................. 247 

Excel format .......................................... 145 

Export ............................................ 153, 161 

Appointments ................................... 109 

Expressions 

to record .............................................. 65 

Extended MAPI............................ 130, 210 

Extract ..........................................See Filter 
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F 

Facebook connection ............................ 82 

Favorites................................................... 57 

Fax...........................................................151 

David fax archive ..............................115 

Fax template .....................................151 

Field Change..........................................248 

Field types .............................................186 

Field workers / Branches.....................165 

Fields 

Calculate ............................................289 

Calculations .......................................289 

Create .................................................181 

Field alias ...........................................186 

Field lenght........................................183 

Field properties.................................181 

Field rights.........................................315 

Field types .........................................186 

Key Field ............................................183 

Unicode..............................................183 

File cards 

Customize..........................................234 

Printing ...............................................139 

Filter .......................................................... 87 

Alphabetic Filter.................................. 48 

AskString ............................................. 92 

Container ...........................................100 

document content ............................. 91 

Double entries .................................... 96 

Dupes ................................................... 96 

Entire Table ......................................... 97 

Free SQL query................................... 93 

Frequency statistics........................... 92 

Full text query ..................................... 96 

General................................................. 87 

Invert..................................................... 97 

Last filter .............................................. 97 

Last Filter ............................................. 93 

Linked conditions ............................... 89 

Load...................................................... 95 

Manual filter ........................................ 98 

Operators .............................................89 

Particularities.................................... 100 

Query by Example (QBE)...................96 

Recently used Filter ...........................93 

Relational .............................................91 

Save ......................................................95 

Transfer to phone manager ..............97 

Undo .....................................................87 

User query ...........................................92 

Find............................................................75 

Find and replace .................................81 

In phone directories ...........................83 

Normal find ..........................................75 

Phonetic find .......................................77 

Quick find.............................................77 

Refining ................................................77 

Route planning....................................84 

Wildcard ...............................................76 

Format.................................................... 286 

Formatting................................................43 

Formula wizard ..................................... 215 

Formulas................................................ 230 
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