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CHAPTER

ONE

Introduction

Vivant - from the French Tableau Vivant: “A scene presented on stage by costumed actors who remain
silent and motionless as if in a picture.”

- The American Heritage c© Dictionary of the English Language

As suggested by the definition above, Vivant initially appears to be a silent and motionless picture;
however, it is actually live and interactive. Like VIDA, Vivant is a communication tool, developed to
enable easy and broad sharing of chemical information. Vivant is designed to communicate the output
of VIDA or AFITT (via state files) in a Microsoft PowerPoint R© presentation or web page.
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CHAPTER

TWO

Installation

2.1 Platform Notes

Vivant is only supported on the Microsoft Windows XP and Windows Vista platforms. It provides both
an ActiveX control for use in PowerPoint 2000/2003/2007 and Internet Explorer as well as a Netscape
LiveConnect plugin for use in Mozilla Firefox.

2.2 Installing

The Vivant installer is a simple Windows executable. Follow the instructions below to complete the
installation processs:

1. Double click on the installer icon. This will start the installer and will present a screen indicating
that this will install Vivant. Click Next.

2. Specify the desired install path. The default and preferred path is C:\OpenEye\Vivant\1.1.
Click Next.

3. Select which components to install. The default behavior is to install all components. Click Next
to perform the default installation unless you are an expert user and have a specific component you
do not wish to install. See Section 2.3 for more details.

4. Confirm the Start menu installation location. The default location is OpenEye\Vivant 1.1.
Click Next.

5. Select whether to install for all users or just for the current user. Installing for all users requires
administrator permissions. Click Next.

6. Verify your settings and click Install.

7. The installer will begin copying files.

8. Click Finish.
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2.3. Details 3

2.3 Details

As noted in Section 2.2 (step 3), the Vivant installer allows the user to select which components to install.
The listed components are all optional, but are highly recommended. The default Vivant installation
includes all of the following components:

• Vivant Examples - Example PowerPoint presentation as well as an example webpage.

• Vivant Documentation - The Vivant documentation (this manual).

• PowerPoint Menu Add-In - Adds an OpenEye menu to the PowerPoint application which greatly
enhances the use of Vivant in PowerPoint. It is highly recommended to install this component,
although it is not strictly required.

• Firefox / Mozilla Plugin - Enables Vivant support in Firefox.



CHAPTER

THREE

State Files As Vivant Input

Every Vivant instance is associated with a state file. State files can be generated by VIDA or AFITT,
and contain all the information necessary to recreate the original session. Vivant loads a state file and
allows navigation between fixed views in that state called “bookmarks.” A bookmark captures the current
view of the scene, including which molecules, grids and surfaces were visible, their rendering styles, the
perspective of the camera and numerous other pieces of information associated with the view. Vivant can
browse through these bookmarks much like a PowerPoint browses through slides.

Since Vivant is primarily a viewing tool, many changes (such as atom color or style) require the use of
VIDA or AFITT. VIDA can be launched directly from Vivant through the Vivant menu (see Section 6.3).
Changes made in VIDA can be sent back to Vivant (see Section 6.5).

Since the last viewpoint in a state saved from VIDA or AFITT may not have been captured in a bookmark,
it is automatically stored in a bookmark named “Start” (or “Start (2)” if a “Start” boolmark already
exists). This bookmark can be deleted in the “Organize Bookmarks” dialog if desired (see Section 6.4.2).
This functionality can be disabled in the preferences dialog (see Section 4.5.3).
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CHAPTER

FOUR

Using Vivant with Powerpoint

Once installed, a Vivant instance can be embedded into a Microsoft PowerPoint presentation to make a
slide interactive. A single Vivant instance can display multiple different views as generated by VIDA.
Once the instance has been added to the slide, it can be dragged and resized like any other PowerPoint
element. However, Vivant instances, like all other ActiveX controls, will always obscure any other
PowerPoint elements they intersect with when in slide show mode.

4.1 Adding Vivant to PowerPoint 2000 and 2003

Adding Vivant can be accomplished through the OpenEye menu (generated by the PowerPoint Add-In as
was discussed in Section 2.3). This is a three step process, as seen in Figure 4.1 and described in detail
below.

1. In the OpenEye menu, there is an Insert Vivant instance... menu option. In PowerPoint 2000, it
will insert an empty Vivant instace. In PowerPoint 2003, selecting it will prompt the user to choose
a state file. Choose one and click Ok. If the desired state file is not yet present, simply click Cancel
and continue.

2. Position the Vivant instance at the desired location on the slide.

3. Start the slide show to begin interaction. In PowerPoint 2000, select Open State from the Vivant
menu to load a state file.

4.2 Adding Vivant to PowerPoint 2000 and 2003 - without the
PowerPoint Add-In

If the PowerPoint Menu Add-in was not installed, an alternative mechanism does exist for adding a
Vivant instance:
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6 Chapter 4. Using Vivant with Powerpoint

Figure 4.1: Adding Vivant to a PowerPoint slideshow

1. Under the Insert menu, click Object. If the Object entry is not there, the Insert menu should be
expandable via an arrow at the bottom. Click the arrow to show all options.

2. Click the Object entry. This will bring up a dialog with a list containing various insertable objects
in alphabetical order.

3. Select Vivant class. It should be listed near the bottom.

4. Click Ok.

5. Position the Vivant instance at the desired location on the slide.

6. Start the slide show to begin interaction.
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4.3 Adding Vivant to PowerPoint 2007

Figure 4.2: Adding Vivant to a PowerPoint slideshow

1. Under the Add-In tab, click the OpenEye menu. In the OpenEye menu, click Insert Vivant in-
stance... menu option. Selecting it will prompt the user to choose a state file. Choose one and
click Ok. If the desired state file is not yet present, simply click Cancel and continue.

2. Position the Vivant instance at the desired location on the slide.

3. Start the slide show to begin interaction.

4.4 Adding Vivant to PowerPoint 2007 - without the PowerPoint
Add-In

If the PowerPoint Menu Add-in was not installed, all ActiveX controls, including Vivant, can be found
in the Developer tab. To enable this tab:

1. Click the circular PowerPoint button in the upper left corner.

2. Select PowerPoint Options.
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3. Check Show Developer tab in the Ribbon.

4. Click Ok.

To insert Vivant from the Developer ribbon:

1. Click the Developer tab above the Ribbon.

2. In the Controls section, click the More Controls button (a wrench and hammer crossed).

3. Scroll down and select Vivant Class.

4. Click Ok.

5. Click on the slide to insert the Vivant instance

6. Position the Vivant instance at the desired location on the slide.

7. Start the slide show to begin interaction.

4.5 Interacting with Vivant in PowerPoint

4.5.1 Interacting and State Files

A Vivant instance is not interactive when in PowerPoint’s design mode. The slide can be layed out there,
but in order to interact with Vivant, the presentation must be in slide show mode (keyboard shortcut key
F5).

All Vivant states are saved within the PowerPoint presentation file itself. Because of this, external state
files do not need to kept or passed around with the presentation.

4.5.2 The OpenEye Menu

As previously mentioned, PowerPoint also has an OpenEye menu that is installed by the PowerPoint
Add-In. It contains several useful functions to interact with Vivant and PowerPoint:

• Insert Vivant Instance... - Selecting this option inserts a new Vivant instance into the presentation
as described in the previous sections.

• Convert all Vivant instances to slides and images - This option converts all Vivant instances to
static images and creating new slides to handle multiple bookmarks. This option can be useful for
sharing presentations with people who do not have Vivant.
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• Reset all Vivant instances to first bookmark - This option will cause each Vivant instance in the
current presentation to load the first bookmark when it is first viewed. This is useful for resetting
a presentation back to a starting state.

• Edit Preferences - This option displays a dialog that allows customization of how keys interact
with Vivant and PowerPoint during a slide show, and changing of addional properties.

• Reactivate Vivant Instances - Occasionally when opening a presentation, Powerpoint will display
a dialog saying that certain controls in your presentation can’t be activated. This reactivates them.

• Display > Update Previews on All Slides - When displaying the slideshow on a different monitor
or projector, the previews may not match the image to be displayed during the slideshow. Selecting
this updates all the previews in the current presentation.

• Display > Update Previews for Current Slide - The same as above, but only updates the preview
image for a single slide.

• Display > Detect Slideshow Display - This option detects the dimensions of the current slideshow
display so that previews and images can be properly generated.
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4.5.3 The Vivant Preferences Dialog

Figure 4.3: The Preferences dialog

The Up/Down, Left/Right and Page Up/Page Down keys can all be set to one of three options: advance
PowerPoint to the next slide, advance to the next bookmark or the next slide (if already on the last
bookmark), or ignore. These settings are shared among all instances of Vivant. These settings are not
saved in the presentation, so if the presentation is moved to a new computer, the settings may differ.

The Bookmark Font Size and Data Font Size options control the size of the text displayed on screen.
Changing these here will affect all FUTURE instances of Vivant. These properties can also be set in
each Vivant instance separately by right clicking on the Vivant instance, selecting Properties and then
changing the value in the sidebar.

Finally, the Automatically Add Start Bookmark option controls whether Vivant adds the ”Start” bookmark
when returning from VIDA as described in Section 6.5.



CHAPTER

FIVE

Using Vivant in a Browser

Figure 5.1: Vivant in Internet Explorer

Vivant can also be embedded in a web page and viewed in Internet Explorer or Firefox. However, given
the nature of a web page and its limitations, changes to a scene in Vivant are NOT saved, unlike in
PowerPoint. Changes made by one user will not be seen by other users or by the same user the next time
they visit that page. The only way to permanently change what is seen is to replace the associated state
file.
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12 Chapter 5. Using Vivant in a Browser

5.1 Creating a web page

A Vivant instance can be embedded into a web page with the following bit of code:

<object type=’application/vivant’ name=’Vivant1’ width=500 height=500>
<Param Name=StateFile VALUE=’[full path to state file]’>
</object>
<Script>
Vivant1 .setStateFile (’[full path to state file]’ )
</Script>

Please note that “[full path to state file]” must be an absolute path to a web
page or a local file (e.g. C:/OpenEye/Vivant/1.1/demo/state.oes or
http://website.com/statefiles/statefile.oes).

In addition, a state file can be opened in Internet Explorer and in Firefox by using File > Open menu
option and it will display it fullscreen in the browser window.
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SIX

Interacting with Vivant

6.1 Using The Mouse

An active Vivant instance, whether in a slide show or a web page, is interactive and can be manipulated
with the mouse.

Vivant has a very similar mouse map as VIDA, however Vivant does not allow selection or provide a
right click popup menu. The details of the mouse map can be found in Table 6.1.

Table 6.1: Vivant Mouse Map
Function Mouse Buttons and/or Keyboard Modifiers
Zoom Wheel

XY motion while holding Middle button
XY motion while holding Left+Right buttons

Rotate XY motion while holding Left button
Rotate around Z axis XY motion while holding Left button and Alt
Translate in XY plane XY motion while holding Left button and Shift
Translate in Z plane Wheel and Alt

XY motion while holding Left button and Alt+Shift
Change clipping plane Wheel and Control+Shift
Change far clipping plane (if enabled) Wheel and Alt+Control
Change near clipping plane (if enabled) Wheel and Alt+Shift
Text Scale Wheel and Control
Adjust contour level Wheel and Shift
Show labels XY motion and Control
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14 Chapter 6. Interacting with Vivant

Figure 6.1: Vivant in a PowerPoint slide show

6.2 2D Depictions

Depending on the state file, Vivant may display a 2D depiction of the active object if it is a small
molecule. Visibility of the 2D depiction is strictly a property of the state file and can be controlled
in VIDA.

6.3 The Vivant Icon and Menu

A Vivant icon appears in the lower right hand corner of each instance. If it is greyed-out, the Vivant
instance is not currently active. Clicking on Vivant will make it interactive (only in slide show mode if
in PowerPoint). Once active, clicking on the Vivant icon brings up the Vivant menu. The Vivant menu
allows the user to load and save state files, set and organize bookmarks, and clear the scene.

The Vivant menu has the following entries:

• Open State - Prompts and loads a new state file.

• Open in VIDA - Loads the state in VIDA (if available) for editing. Clicking on the “Return To
Vivant” button in VIDA allows the changes to be saved back to Vivant (see Section 6.5), if in
PowerPoint.
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• Save State - Saves the current state to disk.

• Clear All - Clears all data from the current Vivant instance.

• Add Bookmark - Saves the current view as a bookmark.

• Replace Bookmark - Replaces the selected bookmark with the current view.

• Load Bookmark - Loads the selected bookmark as the current view.

• Animated - Controls whether browsing to bookmarks is animated.

• Set Animation Time - Controls the transition time in milliseconds from the current state to a book-
mark. Specifying 0 tells Vivant to auto-calculate the best time based on the distance between the
scenes.

• Organize Bookmarks - Opens a dialog for reordering and deletion of bookmarks.

• Show Bookmark Widget - Displays or hides the bookmark display.

• View Output Dialog - Displays a dialog containing any warning or error messages generated by
Vivant

• Stereo > Hardware Stereo - Toggles hardware stereo (Experimental)

• Stereo > Cross-eyed Stereo - Toggles cross-eyed stereo

• Stereo > Wall-eyed Stereo - Toggles wall-eyed stereo

• Stereo > Disable Stereo - Disables stereo

• Stereo > Recheck Hardware stereo - Checks for the presence of hardware stereo (Experimental)

• About - Displays a dialog with information about the current version and license.

6.4 Bookmarks

The Bookmark Widget is centered at the bottom of the Vivant window. If your state file does not have
any bookmarks, the Bookmark Widget may be hidden. It can be manually shown by choosing ”Show
Bookmark Widget” from the Vivant Menu.

6.4.1 Navigating with the Bookmark Widget

The Bookmark Widget is the central navigation point for a given Vivant instance. There are numbers
displayed along the top indicating each of the available bookmarks. At the bottom of the widget is a
the description of the last bookmark that was loaded. Clicking on any of the numbers causes Vivant
to navigate to that bookmark. If there are too many bookmarks to fit into the width of the Bookmark
Widget, arrows will show up on the left and right as needed to scroll the view.
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6.4.2 Managing Bookmarks

Figure 6.2: The “Organize Bookmarks” dialog

Bookmarks can be added, deleted, and overwritten directly from their respective entries in the Vivant
menu. Additionally, selecting “Organize Bookmarks” from the Vivant menu will bring up a dialog which
allows the user to reorder the bookmarks as well as delete and rename them.
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6.5 Interacting with VIDA

Figure 6.3: Editing a Vivant state in VIDA

As previously mentioned, only a few small changes to state files may be made inside of Vivant. Instead,
most changes must be made in VIDA or AFITT. To facilitate editing, VIDA can be launched directly
from Vivant. Selecting “Open in VIDA” from the Vivant menu will launch a new instance of VIDA
starting with the current state of Vivant.

The “Return to Vivant” button (see Figure 6.3) saves the state back to Vivant and closes the VIDA
instance. Since the last view in VIDA may not have been saved in a bookmark, a new bookmark is
added named “Start.” It can easily be deleted using the Organize Bookmarks dialog (see Section 6.4.2)
if desired. This behavior can also be disabled in the Preferences dialog (See Section 4.5.3).



APPENDIX

A

Vivant 1.1 Release Notes

New Features

• Vivant can now be used in Microsoft Powerpoint 2000. Due to limitations of PowerPoint 2000,
however, a file dialog will not appear after inserting a Vivant instance. Instead, start the slideshow
and from the Vivant Menu, select ”Open State...”.

• Vivant can now be installed for a single user without administrator permissions. Select ”Install for
the current user only” during installation.

• The preview image displayed in PowerPoint should more accurately reflect the 3D display in the
PowerPoint slideshow.

• The font size used in the bookmark and data display widgets can now be adjusted in the preferences
dialog. Go to the OpenEye menu and select ”Edit Preferences...”.

• Automatic addition of ”Start” bookmark can now be disabled in the preferences dialog. This
functionality was undesired by some users, and can now be disabled.

• Hardware stereo is now available in an experimental form. Stereo has been tested on a few plat-
forms and has been found to work; however, this feature is still considered experimental for this
release.

• Full window display is now supported in both Internet Explorer and Firefox. To use, simply drag
a state file to browser, or load one from the File > Open menu item and Vivant should display it in
the full window or tab.

• The images generated when converting from Vivant instances should more closely resemble the
3D image in the PowerPoint slideshow.

Bugs:

• Fixed a bug where background color was not properly set according to the individual bookmarks.

• The position of the data display is now properly saved in state. To change the position, move the
data display in Vivant, and then replace the bookmark.

• Fixed a bug where sphere monitors created in VIDA could be lost in Vivant.
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• Fixed a bug where loading states with grids from AFITT could cause crashes.
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