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Introduction 
 

This document is to enable the end user to use RouteFinder to 

run GIS functions available in EMS modules.  Although 

currently RouteFinder GIS is mainly used within in 

Admissions and Transfers and Transport modules some 

functions, such as geocode an address, can be done on any 

student or base within relevant modules. 

 

The aim of this document is not to give a definitive step by step 

user guide to all the functions that use GIS; its purpose is to 

define installation and setup and to give a quick resume of the 

functions that can be used with GIS. 

 

Throughout this document reference to a ‘Superuser’ means a 

user whose setup includes MapInfo or ArcGIS, RouteFinder 

and an EMS Link licence.  All reference to ‘user’ means those 

whose setup is simply the EMS Link with access to relevant 

network files.
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Installation 
 

This installation guide assumes that MapInfo Professional is 

already installed on the computer. This software has to be pre-

installed before continuing with installation. 

 

When the RouteFinder disk is inserted into the CD-ROM drive 

the installation should start. If not, double click on the 

executable “Setup.exe” from the file explorer window. 

 

 

This is the first screen displayed 

once the install starts. 

 

 

Click “Next” to continue 

 

 

 

You will have to accept the licence 

agreement in order for the 

installation to proceed. 

 

Click “Next” to continue 

 

On this screen you should select 

the directory in which to install the 

software. Unless you have a reason 

to change this then just accept the 

default directory as this will make 

upgrades easier to apply. 

Click “Next” to continue 
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On this screen you have to install 

the basic files and you can choose 

to select sample networks. 

 

Click “Next” to continue 

 

 

Select the Menu folder to use. 

Again unless you have reason to 

change it please accept the default. 

 

Click “Next” to continue 

 

 

Finally, a summary screen is 

displayed and if everything is OK 

then press “install” to continue. 

 

 

 

When the installation is complete 

this screen is displayed. 

 

The next step is to install the 

licence file. 

 

 

You will have been sent – probably by email – a file called 

Routefinder.lic. This file is also supplied on the CD of the 

EMS Link Software. Please copy this file into the same 

directory that was specified for the installation. This will 

activate RouteFinder. 
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Installing ONE GIS Link 

The next task is to install the EMS link. This will be located in 

the EMS directory on your RouteFinder CD. 

 

Double click the “setup.exe” in this directory to start the 

installation. A blue screen will appear with “RouteFinder EMS 

Link Setup” and the following dialogs will be displayed:- 

 

 

This is the Welcome Screen 

please click “OK” to 

continue 

 

 

 

On this screen you should 

select the directory in 

which to install the 

software. To use this link 

on more than one machine 

you should have a common 

network point between all the computers. 

 

To continue click the large button with the picture of the 

computer on it. 

 

Next you select the menu folder to 

use. Again unless you have reason 

to change it please accept the 

default. 

 

Click “Continue” to complete the 

installation. 
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Installing the Map Viewer 

The next task is to install the Map Viewer. This will be located 

in the MiViewer or the MoViewer directories on your 

RouteFinder CD. 

 

Double click the “setup.exe” in this directory to start the 

installation. A blue screen will appear with “EMS 

MiMapVeiwer Setup” and the following dialogs will be 

displayed:- 

 

 

This is the Welcome Screen 

please click “OK” to continue 

 

 

 

On this screen you should 

select the directory in which 

to install the software.  

 

 

 

To continue click the large button with the picture of the 

computer on it. 

 

Next you select the menu folder to 

use. Again unless you have reason 

to change it please accept the 

default. 

 

 

Click “Continue” to complete the 

installation. 
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You also need to run the MapX setup.exe from the MapX 

directory under MiViewer folder on your installation CD 

 

You will need to put in the OS copyright statement into the 

miviewer.ini file.  

 

OSCOPYRIGHT= (put copyright statement here) 

 

The year is automatically appended to this statement and does 

not need to be added. 

 

If you are installing the viewer on by itself then you will need 

to make some edits to some INI files. 

 

Edits to the EMS.INI file add the following lines:- 

 

For MapInfo 

 

[GIS] 

Product=RouteFinder GIS MapInfo 

GISViewer=c:\ Program Files \MiViewer\MiViewer.exe 

MapsDir=<Directory to network files> 

GISDir=C:\ems-gis\temp 

 

For ArcGIS 

 

[GIS] 

Product=RouteFinder GIS ArcView 

GISViewer=c:\ Program Files \MoViewer\MoViewer.exe 

MapsDir=<Directory to network files> 

GISDir=C:\ems-gis\temp 

 

You will also need to ensure the C:\ems-gis\temp directory 

exists on the local PC. 
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Starting RouteFinder in MapInfo 

 

Once RouteFinder has been installed you can start MapInfo. 

 

When in MapInfo go to Tools > Tool Manager and you will see 

a window like this:- 

 

 
 

Scroll down until you see the RouteFinder entry (the version 

number may be different) 

 

Click on the “Loaded” tickbox. (You should not autoload 

RouteFinder as this may affect the workspace will set up later) 

 

When you click OK you will see RouteFinder added to the 

main menu bar.
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Starting RouteFinder in ArcGIS 
 

Once RouteFinder has been installed you can start ArcMap. 

 

When in ArcGIS go to Tools > Customize and you will see the 

following screen:- 

 

 

 

 

  

 

 

 

 

 

 

 

 

Click on the “Add From file…” button you will get this 

dialog:-  
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Click on “Files of Type” and change it to ActiveX 

Controls(*.ocx) 

 

Next change the folder to look in to the folder where installed 

RouteFinder for ArcGIS. This is usually C:\Program 

Files\RouteFinder3_ArcGIS. 

 

Click on RouteFinder.ocx and Click OK. 

 

After a short time you should see a screen like this:- 

 

 

 

This dialog can take a few 

minute to appear. 

 

 

 

 

 

You can now Scroll down in the toolbars list and click on the 

RouteFinder tickbox. 

 

The Toolbar for RouteFinder will then appear in ArcMap. 
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Creating a Network 
 

You will need to create a network before the set up of the link 

can be completed. 

 

Please refer to the RouteFinder help file for more information 

on how to create the network. 

 

Many different sources of network can be used with 

RouteFinder. The network has to be topologically correct in 

order for routing to take place. 

 

Examples of this type of network would be:- 

 

Ordnance Survey Meridian2 

Ordnance Survey ITN data  with Urban Paths (Free translator 

available) 

Navteq Street Data 

Teleatlas Street Data 

 

If you have any questions on the data that can be used with 

RouteFinder then please get in touch with the Capita Helpdesk. 

 

This link can handle multimodal networks – that is it uses the 

same network for walking as for driving. By changing the 

attribute of a road you can define such things as speed, one 

way streets, whether it is suitable for walking and/or suitable 

for driving. 

 

If using ITN data please make sure you do not use the 

“turn.bin” file. You can rename the file or delete it. 
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The attributes are defined as below:- 

 

0-31: Defines road class. These have no predefined meaning 

but are used to classify motorways, ‘A’ roads, ‘B’ roads, dual 

carriageways, urban and rural type roads.  

 

Add 32 if the link should not allow mode 1 

Add 64 If the link should not allow mode 2 

Add 512 if it is a one-way street, which can be travelled in the 

digitised direction.  

Add 1024 if it is a one-way street, which may not be travelled 

in the digitised direction.  

Add 2048 if a link is part of a roundabout. 

 

To define a multi modal network you need to change the 

settings in the CapitaEMS.ini file.  

 

SWDMode is the mode to use for walking distances 

DRVMode is the mode to use for driving. 

 

Using these to establish safe walking routes on a network: 

 

1. To define ‘unsafe’ (therefore unavailable) walking 
routes: you select motorways and dual carriageways 

and any other unsafe roads and add 32 to the attribute.  

 

2. To define ‘unsafe’ (therefore unavailable) driving routes: 

you select pathways and alleyways and any other unsafe 

roads and add 64 to the attribute.  

  

SWDmode=1              DrvMode = 2 

This means in calculating a shortest walking route it will 

not use those roads marked 32 above. 
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The MapInfo Workspace and Geoset 
The MapInfo Workspace is a file that tells MapInfo which 

tables to load and how to display them. You may have 

corporate workspaces but it is recommended that you have 

your own for EMS Link as some changes are made to the file 

by the set up program. 

 

One very important part of the workspace is that it must 

contain the table that was used to create the network.  

If you do not include this table the program will fail. 

 

N.B do not save the workspace with RouteFinder active as 

this will cause errors in the Workspace when you next try to 

use it 

 

For users with just ONE GIS  Link you will need to use the 

accompanying viewer supplied with Capita ONE then you will 

need to install it from the CD supplied by Capita.  

 

In order for the viewer to pick up a network you will need to 

create a geoset. This is similar to the workspace created earlier. 

You will start geoset manager which can be found at 

C:\Program Files\Mapinfo\MapX 5.0\GeosetManager50.exe 

 

Please refer to the help file if you need help to use this tool. 

 

There is a tool in MapInfo Professional called “MapX Geoset 

Utility” it is loaded by using Tools > Tool Manager. 

 

Please note you have to save the Geoset into the same folder 

as the workspace and it must be called “ems.gst” 
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The MXD and Basemaps.ini File 
 

The MXD is a file that tells ArcMAP which tables to load and 

how to display them. You may have corporate MXD’s but we 

suggest that you have your own one for this link. 

 

One very important part of the MXD is that it must contain the 

table that was used to create the network. If you do not include 

this table the program will fail. 

 

If you plan to use the free viewer then this will need to be 

installed from the CD as well. 

 

In order for the viewer to pick up map files you will need to 

create a basemaps.ini. This is similar to the MXD created 

earlier except is not as comprehensive.  

 

There are 3 Types of layer that can be defined; Vector, Raster, 

and TEXT. 

 

The INI file defines the location of the SHP files or raster tiles 

and the zoom levels at which they are displayed. 

 

The first entry is the LAYERS entry. This defines the number 

of layers to load in the INI file. 

 

Next comes the layer definitions:- 

 

LAYERn= Full path and name of the file to load (In double 

quotes eg ."C:\maps\ArcGisSample\Roads_polyline" 

 

LAYERTYPEn=  This is either “VECTOR”, “RASTER” or 

“TEXT” 
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N.B For “VECTOR” and “TEXT” layers you should not 

include the “SHP” extension in the “LAYERn” line. For 

“RASTER” you should include the extension of the raster file 

eg “BMP” or “TIF” 

 

 

MINSCALEn= The lowest scale at which to display the layer 

 

MAXSCALEn= The highest scale at which to display the 

layer. 

 

 

These entries are then repeated depending on the number of 

files required to be loaded. 

 

TEXT layers are special layers and need to have the following 

fields defined. 

 

TEXTSTRING – this is the field containing the string to be 

displayed 

 

ROTATION – the angle to display the label 

 

TEXTSIZE – the relative size of the text label. 

 

The actual field names are set in the moviewer.ini file.
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Completing the Set-up 
 

The next step is to start the link. You can do this by selecting 

Start > Programs > Higher Mapping Solutions > RFCapita 

(assuming you have accepted the default installation) 

 

You will probably get the following message:- 

 

 

 

 

 

Click OK to continue and then the RFCapita Form should be 

displayed. 

 

 

 

 

 

 

 

 

Double click this 
symbol to minimise 

to the task bar 

Status messages 
are displayed here 

Superuser map last 
route button 

End Program 

Cancel current 

DDE Call 
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Click on the menu item File > Set up and the Capita – 

RouteFinder Setup form will be displayed 

 

The purpose of this 

form is to locate all the 

files necessary for the 

set up of the link. As 

long as you can find the 

files requested then the 

link should set itself up. 

 

In order to locate the 

files you can click on 

the  buttons at the 

end of the text boxes.  

 

 

 

 

 

 

You will then be presented with a file search dialog:- 

 

 

Use this dialog to find the 

requested file or directory in 

the title bar. 
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The files to find are listed below:- 

 

EMS.INI 

 

This file is usually located in the root directory of the EMS 

folder. You may need to ask your EMS administrator to locate 

the file for you. This file is updated by this program to enable 

the GIS functionality within EMS. 

 

Locate MapInfow.exe or ArcMap.exe and Workspace or 

MXD 

 

You will need to find the mapinfow.exe on your local drive or 

on your network. This link will work with versions 4.12 and 

above of MapInfo Professional and version 8 and 9 of ArcGIS. 

 

The MapInfo workspace to find will be the same workspace 

that you set up earlier. It is important that this workspace is 

used as this link will add a line of code to the file. You only 

need to find this file if this is a Superuser set up. 

 

RouteFinder.mbx 

 

The default location will be filled in automatically but if you 

have installed into a different location then you will need to 

change this setting. You only need to find this file if this is a 

Superuser set up. 

 

Road Network Directory 

 

This will be the directory that contains the network table and 

RouteFinder files that were created (when you created the 

network) earlier. 
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Maximum Distance to Link 

This is specified if you want to ignore points that are greater 

than the specified distance from the network. This may be used 

in rural situations where the student’s dwelling could be some 

distance from the nearest road. 
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Add Off Road Distance 

 

You also have the option to add the distance from the point 

specified by the EMS system to the nearest point on the 

network. This is explained by the two pictures below:- 

 

In the first image the dynamic segmentation goes to the nearest 

point on the network. In the second image the route includes 

the nearest point on the network to the point defined by the 

Capita EMS system 
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Managing the Network 

Introduction 

The distance values calculated and their ‘fit for purpose’ are 

dependent upon the underlying network of roads and footpaths 

and their attributes.  The Local Authority is responsible for 

their definition and maintenance.  Capita and Higher Mapping 

Solutions cannot be responsible for this function. 

 

One of the advantages of RouteFinder is that you are able to 

change the network to add in new roads or your own pathways. 

When this is done you must obey certain rules in order to 

maintain topology. You should be familiar with the GIS and 

editing data tables before trying this. 

 

Topology is simply that the link must be split at the junctions. 

Before continuing you must ensure the RouteFinder network is 

closed. To do this go to RouteFinder > Network > Close 

Network. 

 

In this picture we have a road where we want to add a path:- 

 

To do this we need to split the road 

at the point indicated by the 

arrowhead. For this we have 

supplied a free internet utility 

called Splitline_Eng.mbx (MapInfo 

only). This will be located on the 

Link software CD. 
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(MapInfo only) 

Use Tools > Run Mapbasic Program and then navigate to the 

location of the MBX. When it is active you will see a new tool 

added to MapInfo Professional. It looks like this:- 

 

  

 

 

 

 

When you click on the set up button you will see this form.  

It is best to work with the 

network table in editable 

mode. This is set via layer 

control in the GIS software. 

 

 

 When the road line is then clicked 

with the “selected point” you will 

see the line split in two. You are now 

ready to draw the path starting at the 

new location. (Hint: pressing the “s” 

key in MapInfo activates the “snap” 

mode. This indicates clearly where 

the line will start from.) 

The set up button 
Split line at 

selected point 

Split line at 

selected node 
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Using the Polyline drawing tool trace 

the new path and then double click to 

finish. 

 

 

 

 

 

You should now see the new line 

added. You can add as many links as 

needed maintaining the topology in 

this fashion. 

 

 

 

 

You should ensure that if you are adding a road between two 

roads, then make sure both end of the road connect correctly to 

the network 

 

When the new link is digitised you should then add the 

attributes for this link. The easiest way to do this is to use the 

information tool in Mapinfo – click on the new link and then 

type in the new data in the information window. 

 

Click the save button for go to File > Save table to make sure 

all you hard work is safe! 

 

Once you have finished editing and adding the attributes for the 

new line you should recompile the network before trying to use 

it through EMS. 
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Using the Link 
 

There is no further set up necessary. EMS should now know 

that GIS is to be used. If EMS has been running during this 

installation then you will need to restart EMS for it to detect 

the presence of the GIS system. 

 

When requests are made by EMS the link will handle the 

requests and decide if the GIS is needed or if it can handle the 

request by itself. 

 

If you try to use a Superuser function in a user mode you will 

see this message:- 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 



RouteFinder ONE GIS Link 

Page 29 of 67  

Geocode an Address 
 

In order to geocode an address you will need to be on the 

Student | Student Details tab or Base | Sites tab within one of 

the modules of EMS. An example of this screen is shown 

below:- 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When the ‘House’ button is pressed you are presented with the 

following EMS Address Manager form:- 

 

 

 

 

In order to 

place the 

point on 

the map 

you press 

the 

“Position” 

button 

The ‘House’ button 

activates EMS 
Address Manager to 

access the 

geocoding option 
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If the EMS Link is not currently active then this dialog will be 

displayed:- 

 

 

 

 

You must click “Yes” for the process to continue  

This will then start the link and send the command by loading 

the maps and start RouteFinder. If the record already has 

coordinates then the map will be centred on this location. If no 

coordinates exist then the map will be opened at its default 

location.  The default location is the position defined by the 

Geoset in MapInfo viewer or the extents of the map in ArcGis 

Viewer. 
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The following buttons are added to the bar above the map 

 

 

 

 

 

 

 

 

 

NB. The exit button will be greyed out to stop you exiting 

without pressing one of these buttons

This button moves 
the point around the 

map. Click once to 

move the point. This button accepts 
the changes and 

sends the new 

position back to 
EMS. 

This abandons 
the call and 

returns to EMS 
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’Generate Schools Map’ Routine 
 

In order to use the RouteFinder EMS Link certain files need to 

be set up in order for the link to run in normal mode. You will 

need to have geocoded all your bases before you can run this 

option.  This function can ONLY be carried out by the 

Superuser. 

 

Any time a school is added, deleted or re-positioned you will 

need to re-run this routine. 

 

The ‘Schools Map’ option is found in Tools | Routines within 

Admissions & Transfers and Transport modules and against 

any Base in Bases and Population Forecasting modules. 

Selecting this option displays the following form:- 

 

 

 

 

 

 

 

 

 

 

 

 

 

If the link is not currently active then this dialog will be 

displayed:- 

 

 

 

 

This button sets 

up the files for 

the link 
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You must click “Yes” for the process to continue 

 

This will then start the link and send the command. The link 

will start and because this operation requires the Superuser 

function it will start the GIS software.  

 

If you want to load existing catchments it can be done at this 

stage. You will see this message:- 

 

 

 

 

 

 

 

If you click “Yes” then you 

need to select the folder 

containing the catchments to 

use. 

 

 

 

 

 

Next you will get a dialog asking if you want to create dummy 

catchments 
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These catchments are created for any base that does not have a 

catchment already. They are 1 Km diamond shapes that can 

then be editing in the GIS program. 

 

 

The files will then be set up. When the process had completed 

you may see this message:- 

 

 

If you want to see the file then click 

“Yes” and it will be display the list 

of schools which are not geocoded. 

 

 

 

 

Add geocodes to the listed schools and run ‘Generate’ again.   

When all schools have been processed correctly you will see 

this message and EMS should become active again. 

 

 

 

 

 

 

 

For ArcGIS there is also an EMS tool available to upload the 

catchments files and this can be found on the CD in a folder 

called CatchmentConversion 

 

The structure of the catchment tables is also defined in the 

appendices of this document
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Batch Routines 
 

The link will also process a whole transfer group, or sub group 

within it, at once. Within Admissions & Transfers Tools | 

Routines | GIS Batch Process will display the following form: 

 

 

 

 

 

 

 

 

 

 

 

 

 

All GIS Routines can be run in user mode. 

 

To run any of the routines on this tab first select the transfer 

group, then sub group if using Offer Scheme. Then select the 

batch GIS Routine required. 

 

Using GIS you will normally select the “Shortest Walking 

Distance” option although GIS can be used to generate the 

direct distance also. 

 

When you have selected your option you click the 

“Preprocess” button. The progress bar is displayed and then a 

short report is shown at the bottom of the form. 
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If you have records in the error log then you should review 

them using the “Error Log” button and then, using relevant 

EMS tabs / functions correct the errors before continuing.   

Likely issues are that the student or Base address is not 

geocoded. 

 

If necessary use Preprocess again to check that all now have 

geocodes.  Once you are happy with the selection and are ready 

to proceed, click the “Process” button. 

 

You may see a progress bar like this (if there are more than 5 

records):-  

 

 

 

 

If errors are found with the batch process then you will see the 

following dialog box:- 

 

 

 

 

 

If you click “Yes” the processing results are displayed.  
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The file opens in Notepad and shows all the Error records 

found. The second column in this file is the student ID. Here is 

an example report:- 

 
 

 

 

 

The error codes can be:- 

Start Point is too far away from the network 

End Point is too far away from the network 

Not route between points 

 

For all of those student’s processed the new values are read 

into the database.  Having corrected those with errors you can 

run the process again for unprocessed preferences. 

 

Your can also do Batch Transport assessment by using the tab 

at the bottom of the screen. 

Error on this 

record Error Code 

Student ID 
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Run an Assessment 
 

This functionality is shared between Admissions & Transfers 

and Transport.  It is located against a student.   

 

Ensuring that the student and base addresses are geocoded and 

the schools maps have been run you can create an assessment 

for a student to a nominated base. The tab is shown below:- 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When the “Calculate” button is pressed another screen is 

presented to you. 

 

 

 

 

 

 

 

 

 

Select the required option from the gate drop down box 

This button 
activates the screen 

to generate a GIS 

route. 
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Next you press “Calculate” and the route is generated. If the 

link is not active you will be prompted to start it. You must 

press “Yes” in order for this function to work. 

 

If assessment route distances already exist then you will be 

prompted to overwrite these values. 

 

 

 

 

 

 

 

 

 

The values are then placed into the correct boxes on the form 

and the nearest school should be displayed. 
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Run a School Search 

 

This functionality is shared between Admissions & Transfers 

and Transport.  It is located against a student.   

 

Ensuring that the student and base addresses are geocoded and 

the schools maps have been run you can create a school search. 

The tab is shown below:- 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When you press the calculate button the 5 nearest schools are 

located. It is possible that less than 5 schools will be returned 

and this is usually due to validations within EMS. 

 

Both shortest walking and direct distance are returned. If you 

are using catchment checking then each one is checked and 

displayed in the “In Catchment” column. You can sort the 

results by clicking the “Routed Dist (mi)”, Driving 

Distance(mi) or “Direct Dist (mi)” labels on the form. 
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If you just want direct distance then you need to add the 

following line to the capitaems.ini file:- 

 

SCHOOLSEARCHMETHOD=DIRECT 

 

Then both the routed distance and then direct distance columns 

will have the same value. 

 

 

 

 

 

 

 

 

 

 

 

 

 

You can also set up the number of schools to return by 

changing the following INI file setting:- 

 

NUMSCHOOLSTOFIND=10 

 

Simply change this setting to the desired number of schools 

you want to be returned.

Shortest Walking Distance Result Direct Distance Result 
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Bus Route Display 
 

This option is available in the Transport Module against a 

Route.  Having chosen a route the Route Map tab will display 

as follows: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The result is displayed and then you have 

a choice to view the route 

 

 

 

 

 

The map will have 

large blue circles to 

represent the stops. 

 

 

 

 

 

Click on Edit 

Route to 

display the  
geocoded 

stops on the 

route. 
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If a route has not been generated then it will be calculated and a 

route generated. If a route has been calculated and the order of 

the stops have been changed or stops have been added or 

removed then the route is regenerated. 

 

 

If you are a Superuser you can access additional functionality 

within RouteFinder: 

• using the ‘travelling salesman’ options within 

RouteFinder to find the total distance of the route 

• specify such things as use the order specified by EMS 

(points already optimised) 

• define start and end points and get RouteFinder to 

optimise the points in between.  

 

Please see RouteFinder help file for more information on this 

function. 
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Population Forecasting 
 

This option is available in the population forecasting Module. 

It will help to give an estimate for students in a catchment area 

for a date in the future. You should refer to the EMS 

documentation for instructions on setting up the data for this 

function. It is also absolutely necessary for you to upload your 

school catchment data for primary and secondary schools. 

Please see the section on the “Generate Schools” function for 

instructions for uploading your catchments. 

 

When you have started the population forecasting module you 

need to go to Tools > Catchment stats and you will see the 

following screen:- 

 

 
 

After entering a target census date and clicking on “Detail” you 

may get the following message:- 
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You must click on “Yes”. The link will show “Calculating 

Catchment Stats” and you will see a progress indicating the 

progress of the calculation. 

 

Once this completed you can click on the catchment Stats tab 

and you will see a result screen like the one below:- 

 

 
 

You should then refer back to the EMS documentation for 

further information on how you use this data. 
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Possible Network Errors 
 

Below is shown some examples on networks, which are NOT 

correct, but all look correct unless you check out the details: 

 

Example 1: Missing snap at an intersection 
This means the network doesn't connect and the movement to / 

from the disconnected section, isn't possible. In the example 

below, the gap is just 1 meter and can't be seen at normal zoom 

levels. 
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Example 2: Split at overpass / underpass 
This means a lot of impossible turn movements are suddenly 

made possible. This is a typical problem with TIGER data. 

 

 
 

Example 3: Doesn't split/break at intersections 
This means turns are not possible at most intersections. 
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Example 4: Double digitization with two street names. 

 

Not a really big problem, but the result of a route calculation 

may include one of the two streets in a more or less random 

fashion. 
 

 

 
Example 5: Multi sectioned Polylines 
Polylines with more than 1 section are ignored. They will not 

be part of any route. 
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Known Issues 
Version 1 – 14

th
 June 2005. 

Version 2 – 15
th
 December 2005 

Version 2.5 – 30
th
 October 2006 

EMS Version 3.25 

Issue 1 - The Free Viewer does not display 
the route. 

 

Symptoms 

 

Some times within EMS when “View Route” is selected EMS 

comes back with the message:- 

 

 

 

 

 

 

The actual file it refers to will change but the general message 

is the same 

 

Status 

 

This was fixed in version 3.21 of EMS 
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Issue 2 – The assessment calculation seems 
to run twice 

 

Symptoms 

 

When asking for a route assessment some time this dialog 

appears twice:- 

 

 

 

 

 

 

Status 

 

This is fixed in version 3.21 of EMS 
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Issue 3 – EMS appears to stop running the 
GIS routines 

 

Symptoms 

 

When requesting any GIS function the system fails to respond. 

 

Status 

 

This normally happens when you have requested a GIS 

function such as “position an address” or “display bus route” 

and you do not press one of these buttons in the Superuser 

mode:- 

 

 

Close the systems down and restart EMS. 
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Issue 4 – Problem when using gates on 
schools. 

 

Symptoms 

 

When you run an assessment you may get the following 

message:- 

 

 
 

 

Status 

 

This happens when gates have been defines with decimal 

points. If you set all gates to have “00” after the decimal point 

the system will work. 
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Issue 5 – Assessment Route does not display 
after calculation 

 

Symptoms 

 

When running an assessment calculation and you have entered 

a start date and clicked save. You click on “Show Route” but 

then you get the following message:- 

 

 

 

 

 

 

 

Status 

 

This affects the MapInfo version for the link with EMS 3.25. 

Higher Mapping Solutions and Capita are currently 

investigating the problem.
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Appendices 
 

The EMS viewer Application 

 

The EMS Map viewer is a free runtime distribution for use 

with EMS. You do not need the EMS link to be able to view 

data. However there is no point having the viewer if you do not 

have the EMS link in place somewhere within your 

organisation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When the map is displayed you have the following functions 

available:- 
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 Activate the tools by clicking on the icon. Then in the 

map you can click to zoom in or you can click and hold the 

mouse button and draw a rectangle around the area you are 

interested in seeing. The map will then zoom in to that 

location. 

 

 Activate the tools by clicking on the icon. Then in the map 

you can click to zoom out  

 

 Activate the tools by clicking on the icon. You can then 

click and hold the mouse button down. You will be able to 

move the map in much the same way you might move a paper 

map on a desk. 

 

 Activate the tools by clicking on the icon. You will then 

get the printer selection box. 

 

 

You can then select 

the printer and 

when you press Ok 

it is sent to the 

printer. You can 

only print A4 sized 

copies of maps. 
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 This is the Zoom to route button. When this button is 

clicked the map will automatically resize to contain the 

calculated route. 

 

 These buttons will zoom in and out by a set amount from the 

centre of the map 

 

This button will close the viewer. 

 

You will need to put in the OS copyright statement into the 

miviewer.ini file.  

 

OSCOPYRIGHT= (put copyright statement here) 

 

The year is automatically appended to this statement and does 

not need to be added. 

 

If you are installing the link on its own then you will need to 

make some edits to some ini files. 

 

Edits to the EMS.INI file add the following lines:- 

 

For MapInfo 

 

[GIS] 

Product=RouteFinder GIS MapInfo 

GISViewer=c:\ Program Files \MiViewer\MiViewer.exe 

MapsDir=<Directory to network files> 

GISDir=C:\ems-gis\temp 
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For ArcGIS 

 

[GIS] 

Product=RouteFinder GIS ArcView 

GISViewer=c:\ Program Files \MoViewer\MoViewer.exe 

MapsDir=<Directory to network files> 

GISDir=C:\ems-gis\temp 

 

You will also need to ensure the C:\ems-gis\temp directory 

exists on the local PC.
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Using Catchments with Capita EMS Link. 
 

If you do not have catchments at the moment you can digitise 

them in the GIS of your choice. You need to create 5 separate 

tables and they will need to be called “Catchments_1”, 

“Catchments_2” etc. 

 

These GIS Base Types are linked to DfES Categories within 

EMS: 

GIS Base Type DfES Category 

Nursery • NUR  

Primary • PRI  

• INF  

• MIP (Middle School deemed Primary) 

• JUN 

Secondary • SEC  

• SES (Secondary School with Sixth Form) 

• MIS (Middle School deemed Secondary) 

Further Education • FE  

Special • SP  

• PRU 

 

Each file should only have two columns and they need to be 

formatted as follows: 

 

Column Name  Data Format 
School_ID   Integer 

Name    Character (100) 

 

Some manipulation will probably be necessary on each 

catchment file.    
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The values held in the name column do not affect the import.  

There is no requirement for this column to even contain any 

data, however the column header name must be present 

 

 

Catchments_1 = Nursery Schools 

Catchments_2 = Primary Schools 

Catchments_3 = Secondary Schools 

Catchments_4 = FE Establishments 

Catchments_5 = Special Schools 

 

Each base needs to have its own catchment, even if more than 

one base share the same catchment. If you do not have a 

catchment for a base then they will be created as a part of the 

generate process. 

 

For MapInfo the catchments can be uploaded via the “Generate 

Schools” routine. Please refer to this section of the manual for 

more information. 

 

In order to use catchment checking you should edit the 

CAPITAEMS.INI file and make sure there is a line that says 

 

CHECKCATCHMENT=1 

.  
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Diagram of Implementation 

 

EMS

RouteFinder Installed on 

local machine

Link program installed 

on the network

Road 

network and 

maps

To Network

To Network

Nomal user 

Machines

Super User 

Machine

Server

 
The EMS link program should be installed at a network point 

so all machines can access it at once.  This is because the 

generate schools function produces files that all the normal 

users need to access. 

 

RouteFinder (Superuser mode) has to be install on a local disk 

 

All the maps and road network should be accessed from a 

server 
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Setting up the EMS link on Citrix. 

 

It is now possible to set up the link in a Citrix environment by 

ensuring each user has some specific settings and some manual 

edits to the EMS.ini and miViewer.ini or moViewer.ini. 

 

You still have a licence restriction when using Citrix and it is 

up to each local authority to ensure they do not violate   

 

The key thing to do is to make sure there is an area on a disk 

available that is unique to each user. This should then be 

mapped as a drive. 

 

For example (it can be any drive mapping) let us say we set it 

to U:\EMS-GIS\TEMP where U:\ is a specific area to the user. 

This means if we look at the diagram below if Client PC 1 tries 

to view a route and writes files to U:\EMS-GIS\TEMP and at 

the same time Client PC 2 and Client PC 3 try to view a route 

at the same time and also write to U:\EMS-GIS\TEMP then the 

files will not overwrite each other. 
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Other than this the link should be set up as normal as if setting 

up on a client machine. 

 

All Citrix clients will need to run the EMS link in their own 

memory space. This will enable the DDE conversations to take 

place. 

 

Next we need to edit the EMS.INI file. 

 

In the [GIS] Section make the following change:- 

 

GISDir=U:\EMS-GIS\TEMP 

 

Next you should edit the moViewer (for ArcGIS) or miViewer  

(for MapInfo) INI file. This can be found in the location you 

installed the viewer application. 

 

Open the appropriate INI file and then in the [Setup] section 

you should set the following parameter:- 

 

VIEWER= U:\EMS-GIS\TEMP 

 

This should now enable the EMS link and the viewer to operate 

over Citrix. 
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Quick checklist 

 

You can use this list to quickly check you have completed all 

the necessary steps. See the manual for a more detailed 

explanation. 

 

Install RouteFinder (See Page 6) 

 

Install Capita Link (See Page 9) 

 Set up Superuser 

 Set up normal users 

 

Create Network (See Page 10) 

 Assign Attributes 

  Different road classes 

  One way streets 

  Multi Modal attributes 

 Run Network create function 

 

Create Workspace / MXD (See Page 12) 

Create geoset for viewer / INI file for ArcGIS (See 

Page 13) 

 

Generate Schools (See Page 27) 

 

 

 

Once all these steps are completed the link should be able to be 

used on all the machines.  
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Troubleshooting 

Superuser functions stop working 

This is normally because the INI file has changed or you have 

recompiled the network or changed the workspace file. 

 

To fix this simply start the link manually Start > Programs > 

Higher Mapping Solutions > RFCapita 

 

On the form that is now displayed click File > Set up 

 

Fill in the boxes again and the functions should be restored 

New digitised route does not work 

This can be more complicated to work out. You should make 

sure you new added link should obey the rules set out in the 

network editing chapter. 

 

It is possible for the RouteFinder settings to be changed when 

the road network file gets re-created. You should check while 

running RouteFinder in MapInfo or ArcGIS that the shortest 

path is selected in the route options if you are doing the 

shortest walking route.   

The MapInfo Workspace keeps prompting for 
Route.tab RouteLabels.tab etc. 

This happens because you have changed your workspace and 

then saved it while RouteFinder is active. You will have to 

recreate your workspace and ensure RouteFinder is closed 

when you save it. 
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When the system does not perform as expected then you can 

report the error to Capita ONE support. They may ask you to 

generate the Log files as well as screen shots. 

 

To produce the log files please follow this process 

 

1) Locate the EMS.INI file your system uses. 

 

2) In the EMS.ini file find the [GIS] section and see where the 

Commandline is pointing 

 

For instance:- 

 

commandline=M:\Capita\ONEGISlink\RFCapita.exe 

 

3) Find the folder where the ONE GIS Link is installed. 

 

4) Open the capitaems.ini file and turn logging by setting it = 1 

Eg. LOGGING=1 

 

5) Then run the process that is causing a problem. 

 

This will create a file called “RFcapita.txt and this will be in 

the same folder as the capitaems.ini file. Send this file along 

with the viewcmd.txt (from the ems-gis\temp folder) to Capita 

ONE support. 

 

6) Then set logging back to 0 in the Capitaems.ini file, 

otherwise all calculations will be much slower.  
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If the Map Viewer is generating an error then generate the 

RFCapita.txt as above but also generate the log file for the 

viewer by following this process. 

 

1) Locate the EMS.INI file your system uses. 

 

2) In the EMS.ini file find the [GIS] section and see where the 

GISViewer is pointing 

 

For instance:- 

 

GISViewer=M:\ Capita\MiViewer\MiViewer.exe 

 

3) Find the folder where the map viewer is installed. 

 

4) Open the miViewer.ini and moViewer.ini file and turn 

logging by setting it = 1 

 

Eg. LOGGING=1 

 

5) Then run the process that is causing a problem. 

 

This will create a file called “viewer.log” and this will be in the 

same folder as the viewer EXE file. Send this log file along 

with the viewcmd.txt (from the ems-gis\temp folder) to Capita 

ONE support. 

 

6) Then set logging back to 0 in the INI file, otherwise all 

mapping operations will be much slower.  
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Glossary 
Some of the common phrases and words are listed here.   

 

Geocodes The easting and northing values 

which are the Ordnance Survey 

grid references for a point on a 

map 

 

GIS Geographical Information System 

 

Superuser The person who has access to the 

complete installation from their 

PC i.e. MapInfo or ArcGIS, 

RouteFinder and EMS Link 

 

User EMS Link with access to the 

Superuser created maps on the 

network. 

 

Workspace A collection of MapInfo tables 

put in one view to form a map 

base. 

 

Geoset A different version of the above 

file used in the MapInfo version 

of the viewer 

 

MXD A collection of ERSI Map files 

put in one view to form a map 

base 

 

 


