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UC Processor

USER MANUAL

Easy-to-use Processing Unit 
for 
Pitch & Roll Measurement
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Notes:
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General Information

Legal Notice
Information furnished is believed to be accurate and reliable. However, CORRSYS-DATRON assumes
no responsibility for the consequences of use of such information nor for any infringement of patents
or other rights of third parties which may result from its use. No license is granted by implication or
otherwise under any patent or patent rights of CORRSYS-DATRON. Specifications mentioned in this
publication are subject to change without notice and do not represent a commitment on the part of
CORRSYS-DATRON. This publication supersedes and replaces all information previously supplied.

All brand names are trademarks of their respective holders.

Copyright
©Copyright 2008, CORRSYS-DATRON

Revision
D107-50-01-01E   08/08

Contact
International Headquarters:
CORRSYS-DATRON Sensorsysteme GmbH
Charlotte-Bamberg-Str. 12
35578 Wetzlar / Germany
Phone: ++49 (6441) 9282-0
Hotline: ++49 (6441) 9282-82
Fax: ++49 (6441) 9282-17
E-mail: sales@corrsys-datron.com
URL: www.corrsys-datron.com

North American Headquarters:
CORRSYS-DATRON Sensorsystems, Inc.
21654 Melrose Avenue, Building 16
Southfield, MI 48075 / USA
Phone: ++1 (248) 204-0850
Toll-free: ++1 (800) 832-0732
Fax: ++1 (248) 204-0864
E-mail: USA-sales@corrsys-datron.com
URL: www.corrsys-datron.com

China Headquarters:
CORRSYS-DATRON Sensorsysteme GmbH, China Office
Room 708, JinTianDi International Mansion, 
No. 998 RenMin Road, Shanghai (200021), P.R.China
Tel.: ++86-21-63114144
Fax: ++86-21-63114154
E-mail: Xiaoying.Li@corrsys-datron.com.cn
URL: www.corrsys-datron.com.cn
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Safety Instructions
Please read carefully before operating the equipment.

CORRSYS-DATRON is not responsible for damage that may occur when this system is used in
any way other than that for which it is intended.

To assure safe and proper operation, all supplied equipment, components and/or accessories must be
carefully transported and stored, as well as professionally installed and operated. Careful maintenance
and usage in full accordance with operating instructions is imperative.

CORRSYS-DATRON equipment should be installed and operated only by qualified persons who are
familiar with devices of this type.

Local regulations may not permit the operation of motor vehicles on public highways while the
equipment is mounted on the exterior of the vehicle.

• Use the equipment only for intended applications. Improper application is not advised.

• Do not modify or change the equipment or its accessories in any way.

• Improper use or mounting of the equipment may affect the safety of the vehicle and/or occupants.

• The equipment must not be mounted and/or operated in any way that may compromise vehicle or 
and/or occupant safety.

• Equipment must be mounted firmly and securely.

• Use only original equipment, components and/or accessories included in the scope of delivery!
• Do not mount equipment, components and/or accessories near heat sources (e.g. exhaust).

• Do not use defective or damaged equipment, components and/or accessories .

• Always note correct pin assignments and operating voltages when connecting equipment to
power supplies, data acquisition/evaluation systems, and/or any other applicable system or
component. Equipment may be damaged if not properly connected and/or operated.

• For additional information, please call the CORRSYS-DATRON Hotline: ++49 (6441) 9282-82
or email: hotline@corrsys-datron.com.

• Caution: Laser radiation is emitted from this aperture!
Do not stare into beam!
Laser class 3R according to DIN EN 60825-1:2001-11
Laser Power: < 5 mW, wave length: 660 nm (red)

Danger

Warning

• Use caution when exchanging sensor lamps – lamps are extremely hot, and may cause injury.
• Do not look into sensor lamps – lamps are extremely bright, and may cause eye injury.
• Sensor head can become very hot and may cause injury if power has been applied to the

sensor for extended periods of time. This is especially true if the sensor is used in hot
environmental conditions.

• Sensor and/or sensor components may be damaged if power is applied for extended
periods, especially in hot environmental conditions.

• To avoid damage to the sensor lens, please do only clean it with a micro-fiber cloth.

• Disconnect power from the sensor if the vehicle is stationary for extended periods.
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Easy-to-use
Processing Unit
for 
Pitch & Roll Measurement

UC Processor
1. Overview

The CAN-based UC Processor is compatible with all CORRSYS-DATRON Height
Sensors that are used for Pitch & Roll measurement, and also enables quick 
connection of a CORREVIT® S-350 2-Axis Optical Sensor with Gyro to deliver simul-
taneous slip angle measurement from the vehicle center of gravity.

Information acquired by the sensors is calculated and transmitted via the UC
Processor to a data acquisition system,  providing complete pitch and roll measure-
ment in an easy-to-use system. An optional display enables viewing of all measured
data online.

Art. No. 
UC-Box 15918
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Application
The CORRSYS-DATRON UC Processor Unit is designed for application in dynamic
vehicle tests, which require precise measurement of the following parameters:

• Pitch and Roll measurement
• Slip angle measurement
• Roll rate
• Pitch rate

Features

• Converts height signals from CORRSYS-DATRON HF-xxxC Sensors to pitch and roll
angle.

• Provides the option to connect a CORREVIT® S-350 2-Axis Optical Sensor, which
can be used with the Pitch & Roll System for additional slip-angle measurement.

• UC Processor profile is designed to mount directly to a CORREVIT® S-350 2-Axis
Sensor Electronics for easy handling

• Wide power input range from 10V ... 30V DC

• Supports Motorola and Intel formats

• Termination resistor switchable via CORRSYS-DATRON Software

• Easy set-up via CORRSYS-DATRON Software

• No separate power supply required for the connected HF Sensors 

• Incorporated zero-set button for fast and easy zero setting of the UC Processor

• LED indicators for CAN activity, power, and reverse polarity

• Optional display for online visualization of all output signals
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2. Extent of Delivery

Standard Extent of delivery for Art.no. 15918

1. (1) 16134   UC processor
2. (1) 10398   Power cable, 2m B-coded, 4P Banana, #K001-140-12-2
3. (4) 16135   CAN Adapter 1m for HF signal cable, #K072-182-20-1
4. (1) 13947   Connection cable USB 2m, 4P Binder, #K041-14N-20-2

5. (1) 10380   CAN connection cable, #699122

6. (1) _____   UC Processor configuration tool

7. (1) _____   Transport case

Optional: HF-xxxC Sensors and Mounting-Equipment with transport case

Mounting plate
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3. Typical Technical Data

3.1 Specifications

Input voltage: 10V ... 30V DC

Sensor inputs: HF1: CAN input for HF-xxxC Sensor
HF2: CAN input for HF-xxxC Sensor
HF3: CAN input for HF-xxxC Sensor
HF4: CAN input for HF-xxxC Sensor
S-350: CAN input for S-350 Sensor

CAN inputs for Sensors: CAN V2.0B

CAN output: CAN V2.0B
user-specific configuration possible

All CAN Outputs are protected against 
overvoltage and short circuit

PC-Interface: USB 2.0 full speed

Indication LED for: CAN Bus busy indication
Power supply connected indication
Reverse polarity indication

Update rate: 250 Hz

Temperature range:
Operation: - 25 ... 50° C
Storage: - 40 ... 85° C
Rel. humidity: 5 ... 80% non condensing

Dimensions (l x w x h): 180 x 125 x 65 mm

Weight: 745 g

Shock: 50 g half-sine, 6 ms
Vibration: 10 g, 10 ... 150 Hz

Connection for optional display (for online visualization of all output signals)

HF-Sensor power supply via UC Processor
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3.2 Pin Assignments

ATTENTION!
All views are of the front of the connector.

USB  4 pin Binder female,
Pin 1: D+
Pin 2: D-
Pin 3: DGND
Pin 4: Switch

3

2 4

1

Display  9 pin Sub-D,  female
Pin 1: n.c. Pin 6: n.c.
Pin 2: CAN_Low Pin 7: CAN_High
Pin 3: n.c. Pin 8: +UB
Pin 4: n.c. Pin 9: GND
Pin 5: n.c.

Pin 1: n.c. Pin 6: n.c.
Pin 2: CAN_Low Pin 7: CAN_High
Pin 3: n.c. Pin 8: n.c.
Pin 4: n.c. Pin 9: GND
Pin 5: +UB

CAN Out 9 pin Sub-D,  female
Pin 1: n.c. Pin 6: n.c.
Pin 2: CAN_Low Pin 7: CAN_High
Pin 3: n.c. Pin 8: n.c.
Pin 4: n.c. Pin 9: n.c.
Pin 5: n.c.

6

1 9

5

HF1 - HF4 Inputs 
9 pin Sub-D male,

Pin 1: n.c. Pin 6: n.c.
Pin 2: CAN_Low Pin 7: CAN_High
Pin 3: n.c. Pin 8: n.c.
Pin 4: n.c. Pin 9: n.c.
Pin 5: n.c.

S-350 Input 
9 pin Sub-D male,

6

1 9

5

Power  4 pin Binder male,
Pin 1: +UB
Pin 2: +UB
Pin 3: GND
Pin 4: GND

4

2 1

3



User Manual UC Processor

© 2008 CORRSYS-DATRON Sensorsysteme GmbH, Wetzlar D107-50-01-01E   08/08 11

4. Set-up and Connection

optional display

notebook / PC power supply

data acquisition HF-xxxC Sensors S-350 Sensor / Gyro

4.1 Mounting Options

UC Processor

Mounting plate

Sensor Electronics
for use with a 
CORREVIT S-350 Sensor

For use with an additional S-350 Sensor
it is possible to mount both electronic 
devices together and use a frame to
mount the modules in the vehicle. It is
easier then to stabilize the individual 
electronics in the vehicle and avoid
damages to electronics and vehicle by
falling around during the measurement.

Mount the sensors at the vehicle as described in the individual sensor manuals. 

Make sure that all height sensor mounting positions at the vehicle fit to the chosen "Sensor Location" at
"Config" in the UC Processor configuration software (page 26, Config). Measure all dimensions between
the sensors very accurately. This will increase the accuracy of the measurement. 
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Project window of the UC Processor configuration tool CAN Input Messages

S-350 Sensor Electronics 
with connected Gyro

Details in Chapter 5,
Software Description,
page 26ff

It is not mandatory to connect Height Sensor 1 to connector HF1 of the UC Processor, Height Sensor 2
to connector HF2 and so on. It is one CAN-Bus for HF-Sensors and you can connect any HF-Sensor to
any HF-connector. If there is also a S-350 sensor connected to the UC Processor, make sure that it is 
plugged into its own CAN-Bus, labeled S-350.

Very important are the different CAN-Identifiers for the individual sensors. Make sure that the CAN-ID
of the HF-Sensor mounted on vehicle position H1, is the same as in the software register Inputs of
the H1 sensor settings. Also take care about this for all other sensors.

4.2 Connecting the Sensors

For the connection of additional analog and digital sensors to the S-350 electronics please refer to the
Sensor Hardware User Manual (Vol. I) of the S-350 Sensor.
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5. Software Description
The UC Processor configuration tool will allow you to change the settings of the incoming sensor 
signals, the creation of a user defined CAN output structure and will also generate the CAN DBC file 
for you.
In this tool, you will also have the ability to specify the mounting position of the HF Sensors on the 
vehicle. This will allow for verification that the measurements between the mounted sensors will provide
accurate pitch and roll.

5.1 Quick Start Tutorial and Overview

5.1.1 Install UC Processor configuration tool

Fig. 5-01

Fig. 5-02

Begin the installation of the UC Processor
configuration software by double clicking
on the following file.

All necessary program attributes will be installed. A USB driver can also be added during the installation. 

NOTE: Please make sure, that you have administrative rights on your PC for the installation of the USB
driver.

Please note that without the USB driver, the UC Processor configuration software can not communicate
with the UC Processor.

After initializing the executable setup file,
the following window will appear:

Clicking on the "Next" button will bring
you to the next phase of installation.
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On this Page, the user can set the path
and the directory, where the program
files will be installed.

Click “Next” to continue.

Fig. 5-03

Fig. 5-04

The checkbox will allow you to choose
the software parts, which you will need
for the usage of the ucBox.

The ucBox Configuration utility contains
all files for the configuration utility.

The USB driver must be installed for the
communication with the UC Processor. If
this driver is already installed on your
PC, it is not necessary to choose this
option.

Fig. 5-05

After pressing the "Next" button the fol-
lowing page will open and here you can
set the program manager group.
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Fig. 5-06

Now, the installation will start by clicking
the"Next" button.

The next screen will show the installation
progress:

Fig. 5-07

Fig. 5-08

After the installation, the following window
will appear:

The installation of the UC Processor
configuration tool is finished.
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5.1.2 Installation of USB Driver

The installation package also includes the Driver for the USB port. This driver is a preinstalled version.
This means, that the installation of the driver will be finished after the UC Processor is connected to the
PC.

Fig. 5-09

Fig. 5-10

Fig. 5-11

Fig. 5-12

*Windows* 2000, Windows* XP Professional and Windows* 
Explorer are registered trademarks of the Microsoft Corp.

After the successful installation, the
following screen will appear:

The following Windows* screen will
inform you, that you are installing a 
driver that has not passed the
Windows* Logo testing to verify its
compatibility with Windows XP*.

Note: This message only appears
when using Windows XP*.

Please confirm this screen by clicking
at the "Continue Anyway" button.The
screen will prompt the user twice
Please also confirm the second screen
by clicking "Continue Anyway".

By clicking the Browse button, you can
choose the location, where the driver
will be installed.

Choosing the Install button will start
the installation of the driver.

After a successful installation, the following
window will appear:
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After the UC Processor is connected to the
PC and the box is powered on, Windows*
will detect the new Hardware. The
"Hardware Wizard" will start and will guide
you through the next steps.

For the installation, it is not necessary to
connect to the Windows* Update Center.
So please choose the "No, not this time"
checkbox and continue the installation by
clicking on the "Next" button.

Fig. 5-13

Fig.5-14

*Windows* 2000, Windows* XP Professional and Windows*
Explorer are registered trademarks of the Microsoft Corp.

Due to the preinstalled driver, it is not
necessary to choose a specific location.
Make sure, that the "Install the software
automatically (Recommended)" checkbox
is set and continue with the installation.

5.1.3 Connect the UC Processor to the PC via USB connection
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Fig. 5-15

The USB Device driver installation starts
and the following window appears:

Fig. 5-16

If Windows XP* is installed, the test
to verify the driver compatibility with
Windows XP* starts:

Please confirm this message by clicking
at the "Continue Anyway" button.

Fig. 5-17

After successful installation, the 
following message will appear:

*Windows* 2000, Windows* XP Professional and Windows*
Explorer are registered trademarks of the Microsoft Corp.
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Due to the preinstalled driver, it is not
necessary to choose a specific location.
Make sure, that the "Install the software
automatically (Recommended)" chek-
kbox is set and continue with the installa-
tion.

Fig. 5-18

Now the USB to UART Bridge
Controller driver installation starts and
the following window appears:

For the installation, it is not necessary
to connect to the Windows* Update
Center. So please choose the "No, not
this time" checkbox and continue the
installation by clicking on the "Next"
button.

Fig. 5-19

The USB to UART Bridge Controller
installation starts and the following 
window appears:

Fig. 5-20
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Fig. 5-21

If Windows XP is installed, the test to
verify the drivers compatibility with
Windows XP starts:

Please confirm this message by
clicking at the "Continue Anyway" 
button.

Fig. 5-22

Now, the installation is completed.

5.1.4 Start the software
After installing the UC Processor configuration tool, start the program by clicking on the program icon
or by accessing the program via Windows* Explorer*.
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5.1.5 Select the interface

Select Device>Settings, then select the
port the UC Processor is connected to.
Baud rate and other port parameters are
automatically set by the program.

Fig. 5-23

Fig. 5-24

Choose the CORRSYS-DATRON USB to
UART Bridge controller. The port is only
visible, when a UC Processor is powered
and connected.

5.1.6 Connect a UC Processor
Connect the UC Processor to the selected interface.

5.1.7 Backup the sensor settings

Fig. 5-25

Fig. 5-26

1. Select File>Rescan bus. 
Sensor settings will appear in the
Project Window.

To proceed, click OK, then check all
sensor connections and confirm that
the sensor is supported.

2. Select File>Save As

3. Select a directory into which the file
will be saved.

4. Name the file and select "Save".

5. Saved sensor settings are now avai-
lable to be written back to the UC
Processor.

The UC Processor configuration settings
have the extension ".ucb"
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5.2 Menu Selection and Navigation

5.2.1 Main Program Window
Upon opening the UC Processor configuration tool, the Main Program Window will display:

- Menu Bar
- Device Tree
- Messages
- Tool Bar
- Status Bar

Fig.5-27

Fig. 5-28

5.2.2 Project Window
The Project Window opens automatically when a UC Processor is read or when a project file is 
opened. Here, all selectable UC Processor settings are displayed within the tree sections.
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5.2.3 Menu Bar
The Menu Bar includes: File / View / Device / Help 

Fig. 5-29

Fig. 5-30

Fig. 5-31

Menu item View:

The View Menu includes commands used to View options
available in the Program Window:

Select View>DeviceTree to view the Device Tree.
Select View>Messages to view the Message box.
Select View>Toolbar to view the Toolbar.
Select View>Status Bar to view the Status Bar.

Menu item File:

New: to open a new, empty window, select File>New. 

Open (Ctrl+O): to open a saved *.ucb file, select File>Open
and locate the directory in which the desired file is saved.
From there, double-click the *.ucb file to be opened or select
the file and click the Open button.

Save (Ctrl+S): select File>Save to save the current configura-
tion. If no file name has been previously assigned to the pro-
ject, the Save Tests As... process will be executed.

Save as: select File>Save As... to save the current configura-
tion. The file extension .*.ucb is automatically appended to the
new filename. For example, if you name a file Config1, the file
will be saved as Config1.ucb.

Add Device: If no UC Processor is connected to the PC, you
can create your configuration offline and you can store the
configuration later on into the UC Processor.

Rescan bus: If a UC Processor is connected to the PC, this
function will allow to read out the actual configuration of the
UC Processor.

Exit: select File>Exit to close the program.
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Menu item Device:

Save to UC Processor: The current configuration
will be written into the UC Processor. This step is
necessary, otherwise all your settings will have no
effect.

Bios Update: This function will be used for an 
update of the BIOS part of the UC Processor firm-
ware. CORRSYS-DATRON will inform you, when 
an update is necessary.

Firmware Update: This function will be used for an
update of the firmware part of the UC Processor firm-
ware. CORRSYS-DATRON will inform you, when an
update is necessary.

Settings: The USB port of the UC Processor will
generate a virtual com port on your PC. Here, you
can choose the correct COM port. The following
example will help you to find the correct virtual COM
port.

Fig. 5-32

Fig. 5-33



5.3 How to configure the UC Processor

Connect the UC Processor via USB cable to your PC, power up the processor.
Choose the correct virtual Com port and start the Rescan bus function of the file menu.

The following window will appear:

Clicking on the ucPitch checkbox will expand the tree.

The main page includes an online display. This display can be used by the user to check the function of
each connected HF Sensor. Push the Start button for the measurement. 
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Fig. 5-34

Fig. 5-35
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This page will allow you to choose the mounting position
and you can enter the mechanical dimensions between
the sensors and different sensor locations.

Please use the drop down menu for choosing the sensor
location. Different mountings are possible. Verify, that the
sensor position at the vehicle is similar to the setting of
the HF sensor inputs.

Due to the mounting tolerances or the weight balance of the car, there is a function called
"Calibration Offset". 

Before starting the test drive, the user can set the pitch and roll angle to zero by performing a 
calibration offset. When the vehicle is ready for the test drive, often the pitch and roll angle is not
zero.

The user can easily correct this, by pushing the black switch at the UC Processor housing or by 
sending a CAN Message to the UC Processor, or by pressing the “Calibrate!” button in the ucPitch
menu.
The offset values will be stored into the box until the offset calibration is performed a second time.
Pushing the Clear button in the UC Processor configuration tool will set the offset value to zero.

Fig. 5-36a

Fig. 5-36b

Config
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CAN Config
On this  page, you can set some CAN specific settings like Baud rate, output rate or CAN termination.

For pitch and roll rate, there is a filter setting. The filter is necessary to minimize noise on the 
output signals, it is recommended to apply a moderate filter due to the high sampling rate and high
speed processing time of 4ms.

Inputs
On the input page, the CAN signals of the connected sensors can be configured. On the main input
page, you will have an overview over the used CAN Frames and its identifiers.

Fig. 5-38

Fig. 5-37

(continues on next page)



Inputs (continued from previous page)

H1 to H4 are predefined signals and reserved for the Sensors. The settings
of the CAN signals can be set manually or by reading a CAN dbc file.
Calibrate is a predefined frame.
The user can send a message which will do the offset correction of the
Height, Pitch and Roll signals.
By choosing the Load from CANdb button, you can load the CAN signal
information from a CAN dbc file.
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Fig.5-39b

Fig. 5-39b

The following window will open.   

Push the "Add CAN db" button and you can open
a dbc from a specific location. In this example, the
dbc-file for a S-350 Sensor is opened.

(continues on next page)
Fig. 5-41

To add an additional CAN signal, click the right mouse button on the
Inputs tree.

Fig. 5-40
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Inputs (continued from previous page)

Now you can choose the signal you want to
import into the UC Processor by double clicking
on the signal or selecting the signal and pressing
the OK button.

Fig. 5-44

Fig. 5-43

Fig 5-42

The following window will appear. You will have the
option to modify the signal name and you can 
choose the CAN bus line, where the sensor is con-
nected to.

After pressing the OK button, the signal is generated and will be displayed in the tree. Of course, you
can edit the CAN settings afterwards, e.g. Identifier.

Signals can be removed by a right click on the signal you want to delete. A context menu will open. By
choosing the Remove function, the signal will be deleted.
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Outputs
On the output page, the user can create CAN output frames. The frames Height, Calib and Pitch are
predefined frames.
The user can also create additional frames or can modify existing frames.

Do not forget to save the configuration into the UC Processor by the "Save to UC Processor" 
function of the “Device” menu.

Fig. 5-45a

Fig. 5-45b

Additional frames can be created
by clicking the right mouse button
on the Output page in the tree. A
context box (Fig. 37b) will open and
you can press add for a new frame.



User Manual UC Processor

© 2008 CORRSYS-DATRON Sensorsysteme GmbH, Wetzlar D107-50-01-01E   08/08 32

You can set the name of the Frame and all necessary CAN settings.

After creating a new frame, you can add the signals into the frame. On the page you can change the
frame settings and you can define which signals should be in the output frame.
The signal could be added by clicking at the drop down menu. You can manually change the position of
the signal in the frame.
When all settings are configured, the user can create a CAN dbc file for the current UC Processor 
settings using the “Save CANdb file...” button (refer to Fig. 5-45a, page 30). 
This generated UC Processor dbc can be opened directly into the data acquisition.

Fig. 5-46



5.3 BIOS and Firmware Update

The Software structure of the UC Processor is based on a BIOS and a Firmware section.

The BIOS section is responsible for the basic microcontroller settings and for the complete communica-
tion. The firmware section includes all functions for the calculation of pitch and roll.

Due to the continuous development of CDS products, an Update of BIOS or Firmware may be necessa-
ry.

5.3.1 BIOS Update
Connect the UC Processor via USB to the PC. 

NOTE: DO NOT POWER ON THE UC PROCESSOR
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Fig. 5-47

Fig. 5-48

After pressing Start, the BIOS will be 
programmed.

Choose the COM Port and browse for the
location of the bios file (extension .img). The
BIOS is included into the directory where
the configuration tool was installed into.
Make sure that the Erase all checkbox is
set.

Open the UC Processor configuration tool and choose the
BIOS Update function of the Device menu.

On the sensor faceplate, there is a small
hole. Behind the hole (see Fig. 5-49a),
there is a small switch. Please use a small
screw driver or something similar for
pushing this hidden switch.
Press the switch and power on the UC
Processor. The switch must be depressed
during power on.

Fig. 5-49bFig. 5-49a

After a successful update, disconnect the power for 5 seconds.
Power on the UC Processor. The UC Processor is ready for the firmware update now.
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5.3.2 Firmware Update

Fig. 5-50

Fig. 5-51

Choose the location of the firmware file
(extension .fwm). The Firmware is included
into the directory where the configuration tool
was installed in. Press Start, and the firmware
update will begin.

Open the UC Processor configuration tool
and choose the Firmware Update function
of the Device menu

After the installation of BIOS and firmware,
you must do the basic configuration of the
UC Processor. To complete the update pro-
cedure, do the following steps:

- Start the UC Processor configuration tool.
- Choose Add Device from the File menu

Fig.5-52

Fig.5-53

A context menu will open. Please choose the UC
Processor Pitch and roll algorithm and press ok.

Fig. 5-54

Save the complete configuration by the Save to ucBox
function of the Device menu.

Now the update is completed.
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6. Troubleshooting
When troubleshooting the UC Processor begin by checking the 
following:

Cables and power supply
• Check all connections to determine that each is complete and that the system is connected to

a power supply that provides voltage output within the specified range.
• Check to determine that the correct cables have been used for all connections.
• The following problems can be caused by incorrect or incomplete cable connections and/or

connection to incorrect power supply voltage:
- Output signals are not available to data acquisition and/or connected PC.
- A sensor will not go out of standstill mode with vehicle motion. 
- Sensor signals missing
- Error on CAN line

Status LED’s on sensor electronic boxes
• If all connections are correct and no faults are present, the "PWR" (power) LED on the sensor elec-

tronic will be illuminated orange. If the "PWR" LED is red, a fault is indicated. 
• Blue LED on: CAN communication between sensors and UC Processor is established.

Sensors
For details please refer to the Sensor Hardware User Manuals (Vol. I) of HF-xxxC* Sensors and/or S-
350 Sensor.

*Note: Each HF-xxxC Sensor needs a separate identifier.

Please alway check the baud rate of processor and sensor.

Operating range
If the sensor is mounted out of the recommended height range (standoff distance), it may not go out
of standstill mode with vehicle motion, and no measurement signals will be output. Check and correct
mounting as necessary.

Sensor lens
The sensor lens (located on the underside of the sensor housing) may occasionally become dirty,
preventing proper operation. Check and clean the sensor lens regularly.


