NI Vision

NI Vision Builder for Automated Inspection Tutorial

August 2009 ¢ NATIONAL
373379F-01 " INSTRUMENTS



Worldwide Technical Support and Product Information

ni.com

National Instruments Corporate Headquarters
11500 North Mopac Expressway  Austin, Texas 78759-3504 USA Tel: 512 683 0100

Worldwide Offices

Australia 1800 300 800, Austria 43 662 457990-0, Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599,

Canada 800 433 3488, China 86 21 5050 9800, Czech Republic 420 224 235 774, Denmark 45 45 76 26 00,
Finland 358 (0) 9 725 72511, France 01 57 66 24 24, Germany 49 89 7413130, India 91 80 41190000,

Israel 972 3 6393737, Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400,

Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710, Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466,
New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60, Poland 48 22 328 90 10, Portugal 351 210 311 210,
Russia 7 495 783 6851, Singapore 1800 226 5886, Slovenia 386 3 425 42 00, South Africa 27 0 11 805 8197,
Spain 34 91 640 0085, Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151, Taiwan 886 02 2377 2222,
Thailand 662 278 6777, Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545

For further support information, refer to the Technical Support and Professional Services appendix. To comment
on National Instruments documentation, refer to the National Instruments Web site at ni . com/info and enter

the info code feedback.

© 2002-2009 National Instruments Corporation. All rights reserved.



Important Information

Warranty

The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects
in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National
Instruments will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives
notice of such defects during the warranty period. National Instruments does not warrant that the operation of the software shall be
uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before any
equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are covered by
warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical accuracy. In
the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent editions of this document
without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected. In no event shall National
Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL
INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR DAMAGES RESULTING
FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of
the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including negligence. Any action against
National Instruments must be brought within one year after the cause of action accrues. National Instruments shall not be liable for any delay in
performance due to causes beyond its reasonable control. The warranty provided herein does not cover damages, defects, malfunctions, or service
failures caused by owner’s failure to follow the National Instruments installation, operation, or maintenance instructions; owner’s modification of the
product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third parties, or other events outside
reasonable control.

Copyright

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying,
recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National
Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other
intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only
to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

Trademarks

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the Terms of Use section
on ni.com/legal for more information about National Instruments trademarks.

Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Members of the National Instruments Alliance Partner Program are business entities independent from National Instruments and have no agency,
partnership, or joint-venture relationship with National Instruments.

Patents

For patents covering National Instruments products/technology, refer to the appropriate location: Help»Patents in your software,
the patents. txt file on your media, or the National Instruments Patent Notice at ni .com/patents.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS

(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF
RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN
ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT
INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE
IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY,
COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS
AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND HARDWARE
COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL DEVICES,
TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR MISUSES, OR
ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE HEREAFTER
COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD CREATE A RISK OF
HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD NOT BE RELIANT SOLELY
UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID DAMAGE, INJURY, OR DEATH,
THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO PROTECT AGAINST SYSTEM FAILURES,
INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS. BECAUSE EACH END-USER SYSTEM IS
CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING PLATFORMS AND BECAUSE A USER OR APPLICATION
DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT
EVALUATED OR CONTEMPLATED BY NATIONAL INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY
RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER
NATIONAL INSTRUMENTS PRODUCTS ARE INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT
LIMITATION, THE APPROPRIATE DESIGN, PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.



Contents

About This Manual

COMNVEITIONS .oeeieeiivieeeeeiieeeeeeeeiteeeeeeetteeeeeeesaeeeeeeesaaeeessessaeeeseeesseseeessesrsesesansraeesessanaes Xi
Related DOCUMENTATION. ........ccieiiriieeieiiieie e ettt et e eeetee e e e eetareeeeeeaareeeeeeraaaeeeeeens Xii

Pagrt |
Vision Builder Al Basics

Chapter 1
Introduction to Vision Builder Al

Vision Builder AI Configuration Interface.............cccooceeeieiininiinininiicceee 1-4
Elements of the Configuration Interface ...........ccccceceecveeiniiniiicninicncienne 1-5
Inspection State DIagram ...........cccocevieiirieiiiniiiienieceee e 1-6

Vision Builder Al Inspection Interface............cooocveeeeieciiniinincciinenceeneceneeeeee 1-8

Running an INSPECHION ......cc.eouieiiriiiiiiiiiecciceeeee et 1-9
Configuration INterface .............coccevieiiiiiiiniiiiicce e 1-9
Inspection INLETTACE .......cocueiriiiiiiiiii e 1-11

Chapter 2
Checking for the Presence of a Part

Creating a New INSPECTION........eiuiiiiriiriiiieteierteie ettt s 2-1
Acquiring InsSpection IMages .......cccecuereeriinirieniieneeeetee et 2-1
Defining a Feature on which to Base a Coordinate System .........c..cooceveevverieneeneneenne. 2-2
Setting a Coordinate SYSTEIM .......evueeiiririerieeietieitente ettt sttt st e e sbe e saeeaaens 2-5
Checking for the Cap Using Measure INtensity.........ceceveererenienenienenieeseeee e 2-6
Setting the INSPeCction STAtUS.......cc.eeouiiiieiierieieeee ettt s 2-8
Testing the INSPECLION ......eeuiiiiiiiieiei ettt s 2-8
Saving the INSPECTION ......c.ceuiriririirtiietetetetet ettt sttt 2-9

Chapter 3
Inspecting Objects for Correct Measurements

Creating a NeW INSPECHION........eeviiriiiiierie ettt ettt s e s 3-1
Acquiring and Calibrating Inspection Images ...........ccoeeerieriiienieniieenieeieeee e 3-1
Locating Features t0 MEASUTIE.........c.eeruierieiiieriienieeitente et esiee sttt esitesreebeeseaesbeenbees 3-4
Measuring Parts Of the GasKet........c.covveriiiiieiiiiieieseceese et 3-7
Setting the INSPECtioN STALUS .......ceceirriierieriiiieerterie ettt sttt e st see b esaeesaeeens 3-8
Testing the INSPECTION .....ecviiiieeiieiie ettt ettt e st ebee e 3-8
SaVINgG the INSPECLION ....eeeuviiiiiiieeiieite ettt ettt ettt ae st eesbesabeebeesabeenbeens 3-9

© National Instruments Corporation v NI Vision Builder for Automated Inspection Tutorial



Contents

Chapter 4
Inspecting for Multiple Correct Instances of an Object

NI Vision Builder for Automated Inspection Tutorial vi ni.com

Creating a New INSPECHION .........ccuiviiiiiiiiiiiiicicieciceeeereeeee e 4-1
Acquiring Inspection IMages........cccveerieriieiniinieiiienieee et 4-1
Defining a Feature on which to Base a Coordinate System ............cccceceeieceenineenncnen. 4-2
Setting @ Coordinate SYSEIM ......cc.ceceevuirieriirienieiiereieee ettt eaneneas 4-3
Measuring the Separation between CONNECLOrS .........c.ccecveriercienieieniieieniereseeeeseene 4-3
Inspecting the Fuse Conductor ...........cccoieiiirieiiinieniinicieneeeseereeete e 4-5
Making Logical PASS/FAIL DECISIONS ......ccceruieruirienieniieienieienecteeeereeeeesee e saees 4-8
Setting the INSPECtion STATUS ......cc.ceceeriiriiriirierieieereeee e 4-10
Testing the INSPECHION........c..cccviiiiiiiriieieiieie ettt s 4-10
SavINg the INSPECION ....evviiiiiiiiiiiieiie ettt ettt e st b e s 4-11
Chapter 5
Inspecting an Object that Spans Two Image Frames
Creating a New INSPECTION ....ccueeiiriiriiiiiiiniieie ittt st 5-1
Acquiring Inspection Images from Two Cameras.........ccccecveveevieneeienennienenneneneennens 5-2
Acquiring and Calibrating the Image of the Left Edge.........cccccooeniniencnnes 5-2
Acquiring and Calibrating the Image of the Right Edge .........ccccceveneeeenneees 5-5
Locating the Right Edge of the Part ...........ccccooiiiiiiiiiiniiiiceecee s 5-7
SWItChiNg IMAZES .....eveeuiiiiiiiiieieeieee ettt ettt sttt sbe s 5-9
Locating the Left Edge of the Part ..........cccocooiiiiiiniiiiniccceeceee s 5-9
Calculating the Width of the Part ............cccoiiiiiiiiniiceceeeeeeis 5-11
Setting Calculator Step Inputs and OULPULS .......ccceeruerverierienenieneeieneeieene 5-11
Adding Operators and CONSLANES .........cecuereerierieerienienieneeieneeee et sieesee e 5-13
Connecting the Equation Elements ..........ccccooeierieiinieniniieniniencececneene 5-14
Making Logical PASS/FAIL Decisions with the Calculator Step.................. 5-16
Setting the INSPECtion STATUS ......cc.eeieriiriiririirie ettt 5-17
Testing the INSPECTION.....ccc.eiiiiiiiiiiiiieeie ettt e 5-18
Saving the INSPECION ....cccueiiiiiiiiiiiiiie ettt st e 5-18
Chapter 6
Branching and Decision Making
Creating a New INSPECTION ....oeviiriiiiiieiiiiieesteete ettt sttt ebeesaee s s 6-1
Creating the Inspection State Diagrami.........cccceevcieriieniieniieeniienieeeecre e 6-1
Acquiring InSpection IMaZES........ccoveerieriiiiniinieiie ettt st st 6-6
Checking for a Spray Bottle in the Tmage .........ccocevvierieeiiiinieiiieiceeeeeeeeeee e 6-6
Checking for the Cap Using the Caliper..........ccceevuiriiierieriiieniienieeieesiieereesiee e 6-8
Setting the INSPECLION STALUS ...cc.eeviirriierieeiierieete ettt ettt et e s e sbeesaeesreeneee s 6-9
Creating Custom Overlays for INSPeCtion .........cccceveirrieerieriiienienieerie e 6-9



Contents

Configuring State TranSTtONS .....cev.veritierieeiieiie ettt ettt ettt e st esaeesaeeebeesabeeneees 6-11
Testing the INSPECTION .....ecuviiiiieiiieiie ettt ettt st e bee e 6-13
SavINg the INSPECLION .....eeviiiiiiieeiieie ettt sttt et st esbesbeebeesaseeaeens 6-14
Chapter 7
Looping and Variables
Creating a NeW INSPECHION........coviiiiiiiiirie ittt et 7-1
Creating the Inspection State Diagram .........ccocueeveeriiiiniieniieniienieeecee e 7-1
Creating @ Variable .......c.oovuiiiiiiiiii ettt 7-5
Acquiring InSpection IMAaZES ........cocueeruiiriiiiiiiiierie ettt 7-6
FInding Pin EAZES ......eeeueiiiiiiieieeieeeeeete ettt sttt et e 7-6
Initializing the Variable ...........coocoiiiiiiiiiiiii ettt 7-7
INdeXing MEASUTEIMENLS ......eeiuvieiiiiieiiteeieentte ettt sttt ettt et et et e st e sateesbeesabesaseas 7-8
Setting a CoOTdinate SYSIEIM.......eevuiiiiiiriienitiiieeritenite ettt ettt e st e bt e st sbe e bt e saeeens 7-8
ChecKking the PIN Gap .....coceoviiiiiiiiieiiieeee ettt ettt et 7-9
Updating the Variable ..........oouooiiiiiiiieieeneeee ettt 7-10
Identifying Failed PinsS.........coccoviiiiiiiiiiiiii ettt 7-10
Setting the INSPECtioN STALUS .......cevuiiriiiriieriiiieeterte ettt sttt st e eas 7-11
Displaying the Current InSpection Image ..........cccceevveevieniiiiienienieeieeseesie e 7-11
Configuring State TranSTtONS ......cc.viirtierieriierite ettt ettt e e eeees 7-12
Testing the INSPECTION .....ecuviiitiiiiiiiie ettt sttt 7-13
Saving the INSPECLION .....ccveiiiiiiieiiiete ettt ettt ettt e b e sabeeaee s 7-14
Parr Il
Using Vision Builder Al
with Remote Targets
Chapter 8
Acquiring an Image with the NI 17xx Smart Camera
HATAWAT®.....coueiiiiiiiiiiiect ettt ettt st s st nae e 8-1
Connecting the Lens and Lighting.........ccccvevieiiiiiiiniiiiecieseeeeec et 8-2
LAGRENG «.eeiiieiieee et ettt ettt ettt s st 8-2
Connect the Power Supply and I/O.......coceeviiiiiiiiiiiiiieeeeeeteee et 8-3
POWET ONLY ..ottt sttt e eaeees 8-3
Power with Additional I/O ..........ccccoviiieeiiieiii et 8-4
Connecting to the Development COMPULET ........cceereiriieenieriieenienieeniiesreeieesereeneeesnnes 8-6
Firewall Configuration ..........cceecueerieerienieeniienieeiteste et 8-6
Direct CONNECHON. ......cieiiiieieiiieeciiieeeiee et e et e e et e e e eteeesbaeeevbeeeseseessseeseseaanes 8-7
INEtWOTK CONNECHION........eeeeiiieeiiieeiieeeeiee et e et e eereeesbaeeebeeeeeaeesaaeesnrseaenns 8-8
Subnet ConSiderations............cccueeeieuieeeriieeenieeesieeeereeeereeeereeesereeeens 8-9
Configuring the TP AdAIeSS .....ccueevieiriierieiiiereeiteree ettt ettt bee e 8-9
© National Instruments Corporation vii NI Vision Builder for Automated Inspection Tutorial



Contents

Installing Software on the NI Smart Camera ..........ccccveevveeiiierieeniienieneenieeieesiee s 8-11
ACqQUITING AN TMAZE ....eovvieiiiiiieiie ettt ettt ettt st et esae e sbeenaeesanes 8-11
SaVINg the INSPECION ...eevviiiiiiiieieeiie ettt ettt ettt sttt e sbeesaaeeareens 8-12
Triggered ACQUISTHONS ...ecveiiiieriieiieetierte et et sttt este st e et esbeebeesateebeesseesaneesaesanes 8-12
Connecting the Trigger Signal .........ccceevverieriieeiieeniinieeeese e 8-12
Configuring the ACQUISIHION.....c.eirieriierriierie ettt 8-13
ACQUITING TMAZES ..vveenveereiieiieniieeieeriteeteenieesteesteesstesseesseesseesseesssesnsessseessses 8-14
Preventing an AcquiSition TIMEOUL.......ccc.eevieriieriiienieeieeieerte ettt eee e 8-14
Creating the Inspection State Diagram ..........cceeceevieerieniieenieniienieesie e 8-14

Chapter 9
Acquiring an Image with the NI CVS-1450 Compact Vision System

HATAWATE ..ot s s e 9-1
Connecting a Camera and MONILOT...........cccoocieriiieriinieieneeieee e 9-2
Connecting a POWETr SUPPLY ......cocuiriiiiiiiiiiiieieeeceeeeeee e 9-3

Connecting to a Third-Party Power Supply .......ccccoceeviniiiiniiiiniciicienens 9-4
Connecting to @ NEIWOTK.....c.c.ccveiiiiiiiiiiieiiiceecceee e 9-5

Subnet Considerations...........ccoieeeruireererieienieieeeereeeeee e re e eneiees 9-5
Connecting to a Development COMPULET ........cc.cecverririienierieienieieneeeeieeeese e 9-5
Configuring an IP Address .........coeeieriiiiiniinieniiceeeeeeeeeeeeee e 9-7
Installing Software to the NI CVS-1450 DevVicCe........ccccocvecuirienreneiiinieieeeeneneeneeaeen 9-8
AcqUIring an IMAZE .......cceouieiiiiiiiiieieet ettt s 9-8
Saving the INSPECHION ......ccuieiiriiiiiiiiieceeeet ettt 9-9

Chapter 10
Performing a Triggered Acquisition Using the NI CVS-1450 Compact
Vision System

HAIAWATE ..ottt s s 10-2
Connecting the HAardWare ...........c.ccooeieiieniniininicntee ettt 10-2

Connecting the Trigger Signal .........ccoceeviiriineniiiiinineeeeeee e 10-3
Creating a New INSPECTION .....ccueeiiriiiiiiiiiiieitereeitet ettt ettt 10-5
Configuring the Trig@er SiZNal ........ccccevviiriiiiniiieieeeeteeere et 10-5
Resetting the I/O.....c..oiiiiiiiiiiieetee ettt et 10-6
Acquiring InSpection IMages.........ccccevireeriiriiniiiinieeeeeecee et 10-7
Saving the INSPECTION ...c..eeuiriiiriiiiiiiiiere ettt ettt sttt 10-8
Testing the ACQUISTEION. ....cc.eiiiiirieteetieteete ettt st 10-8
Preventing an Acquisition TIMEOUL.......cc..ccuirieriirierienieieneeieeetet et 10-9

Creating the Inspection State Diagram ..........coccecceveevieninniinennenennenenieene 10-9

NI Vision Builder for Automated Inspection Tutorial viii ni.com



Chapter 11
Inspection Selection

Connect to @ Remote Target ........c..ooccevieieriiiiiiiieiee e
Installing Examples on the Remote Target.........c.ccocevveinieniienieneennne.
Opening an INSPECtion .........coceecueviieiiniriienieeteeeeeceeee e
Adding a Communication Device............cccccreevinieieninicninieneeeeeee
Configuring TCP/IP COMMUNICAtION .......eouieririieiieeeiieieneeee ettt ennes
Mapping I/O Values to INSPECLIONS ........ccceouirieriiriiniinieiineee e
Running the INSPeCction .........c..coceeviiriiiiiiiiiniiieeee et

Generating TCP Commands and Testing the Inspection

Appendix A
Technical Support and Professional Services

Glossary

Contents

© National Instruments Corporation ix NI Vision Builder for Automated Inspection Tutorial



About This Manual

Conventions

This manual contains many techniques for using NI Vision Builder for
Automated Inspection (Vision Builder Al) to solve visual inspection tasks
including inspection, gauging, part presence, guidance, and counting.

Follow the instructions in this manual to familiarize yourself with the
Vision Builder AI and perform common inspection tasks.

»

> @

bold

italic

monospace

The following conventions appear in this manual:

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.
This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to
avoid injury, data loss, or a system crash.

Bold text denotes items that you must select or click in the software, such
as menu items and dialog box options. Bold text also denotes parameter
names.

Italic text denotes variables, emphasis, a cross-reference, or an introduction
to a key concept. Italic text also denotes text that is a placeholder for a word
or value that you must supply.

Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames, and extensions.

© National Instruments Corporation Xi NI Vision Builder for Automated Inspection Tutorial



About This Manual

Related Documentation

The following documents contain information that you might find helpful
as you read this manual:

NI Vision Builder for Automated Inspection Readme—Contains
information about the minimum system requirements, installation
instructions, device support, and known issues for NI Vision Builder
for Automated Inspection. The NI Vision Builder for Automated
Inspection Readme is available at Start»All Programs»National
Instruments» Vision Builder AI»Documentation.

NI Vision Builder for Automated Inspection:

Configuration Help—Contains information about using the Vision
Builder AI Configuration interface to create a machine vision
application. NI Vision Builder for Automated Inspection:
Configuration Help is available by selecting Help»Online Help from
the Vision Builder AI Configuration interface.

NI Vision Builder for Automated Inspection:

Inspection Help—Contains information about running applications
created using Vision Builder Al in the Vision Builder Al Inspection
Interface. NI Vision Builder for Automated Inspection:

Inspection Help is available by selecting Help»Online Help from the
Vision Builder Al Inspection interface.

NI Developer Zone—Visit ni . com/ zone for the latest example
programs, tutorials, technical presentations, and a community area
where you can share ideas, questions, and source code with developers
around the world.

NI 17xx Smart Camera User Manual—Describes the electrical and
mechanical aspects of the NI 17xx smart camera, troubleshooting
guidelines, and information about the LEDs, DIP switches, and
connectors on the NI 17xx.

NI CVS-1450 Series User Manual—Describes the electrical and
mechanical aspects of the NI CVS-1450 Series, troubleshooting
guidelines, and information about the LEDs, DIP switches, and

connectors on the CVS-1450 device.

NI EVS-1464 User Manual—Describes the electrical and mechanical
aspects of the NI EVS-1464 embedded vision system, troubleshooting
guidelines, and information about the LEDs, DIP switches, and
connectors on the EVS-1464 device.

NI Vision Builder for Automated Inspection Tutorial Xii ni.com
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NI Vision I/O Terminal Block and Prototyping Accessory User
Guide—Describes the features of the NI Vision I/O Terminal Block
and Prototyping Accessory, what you need to get started, and the
installation and operation of the device.

NI Smart Camera 1/0O Accessory User Guide—Describes the features
of the NI Smart Camera I/O Accessory, what you need to get started,
and the installation and operation of the device.

Xiii NI Vision Builder for Automated Inspection Tutorial



Part |

Vision Builder Al Basics

This section provides a series of lessons designed to introduce you to the
Vision Builder for Automated Inspection (Vision Builder AI) environment
and describe how to perform many common machine vision tasks using
Vision Builder Al

Part 1, Vision Builder Al Basics, contains the following chapters:

© National Instruments Corporation

Chapter 1, Introduction to Vision Builder Al, introduces the Vision
Builder Al environment and describes how to run an inspection.

Chapter 2, Checking for the Presence of a Part, introduces the Match
Pattern, Measure Intensity, and Set Coordinate System steps.
Follow the instructions in this chapter to create an inspection that
checks for the presence of a spray bottle cap regardless of the bottle
position in the inspection images.

Chapter 3, Inspecting Objects for Correct Measurements, introduces
image calibration, and the Detect Objects and Geometry steps.
Follow the instructions in this chapter to create an inspection that
measures the distance between holes in a gasket to verify that the
gasket conforms to manufacturing specifications.

Chapter 4, Inspecting for Multiple Correct Instances of an Object,
introduces the Find Straight Edge, Caliper, and Decision Making
steps. Follow the instructions in this chapter to create an inspection
that measures the distance between the blade connectors of a fuse and
checks the integrity of the fuse conductor regardless of the fuse
position or whether the fuse is inverted.

Chapter 5, Inspecting an Object that Spans Two Image Frames,
introduces the Select Image and Calculator steps. Follow the
instructions in this chapter to create an inspection that measures
the width of a wooden plank that spans two images.

-1 NI Vision Builder for Automated Inspection Tutorial
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Vision Builder Al Basics

Chapter 6, Branching and Decision Making, introduces the inspection
state diagram and the Custom Overlay step. Follow the instructions in
this chapter to create an inspection that checks the image for the
presence of a spray bottle and, if a bottle is present, transitions to
another state to determine if the bottle has a cap. If there is no spray
bottle present in the image, the inspection moves on to the next image.

Chapter 7, Looping and Variables, uses the inspection state diagram to
implement a looping inspection and introduces the Set Variable and
Index Measurements steps. Follow the instructions in this chapter to
create an inspection that inspects images of electronic components to
determine if the distance between pins on the component is within a
predetermined range. If the pin is too close or too far away from an
adjacent pin, then the inspection fails. The inspection does not need to
check every pin on the microchip before failing the inspection. The
inspection fails at the first failed pin.

NI Vision Builder for Automated Inspection Tutorial -2 ni.com



Introduction to Vision Builder Al

This chapter introduces the Vision Builder Al environment and describes
how to run an inspection.

Figures 1-1 and 1-2 show general instructions for creating a Vision Builder
Al inspection. Figure 1-1 describes the basic steps for designing a Vision
Builder Al inspection. The Add Inspection Steps module of Figure 1-1 is
expanded in Figure 1-2.

© National Instruments Corporation 1-1 NI Vision Builder for Automated Inspection Tutorial
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Introduction to Vision Builder Al

Start

Open Vision Builder Al
Configuration interface

v

Add step to acquire an image
of the parts under inspection

Do you

want to make
measurements in
real-world units?

Create or select a spatial
calibration from the Calibration
tab of the acquisition step

Do the parts
appear in different
locations from image
to image?

No

o

Add step from Locate Features
palette to locate the part
in the image

—>

Add Set Coordinate System step
to create a coordinate system

based on the part location

\ 4

Add Inspection steps

Do you
want to create
intermediate measurements
based on the results of
previous steps?

Yes

I }Refer to Figure 1-2 for details.

Add Calculator step

Do you
want to customize
the inspection
decision?

Yes

No [ ¢

Add Logic Calculator step
or Calculator step

v

Add Set Inspection Status step I

Do you
want to send
measurements to
an external
device?

Yes

No

o

Add one of the
Communication steps

4

Save inspection

Figure 1-1. Instructions for Creating a Basic Vision Builder Al Inspection
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Does the
image need to be
enhanced?

Yes

Add Vision Assistant
or
Filter Image step

What type of
inspection do you need
to perform?

% S
= c c o
© o @ L
[s] (3% =
L 82 5

& S

A 4 v \4
Add step from Add step from Add step from

Locate Features Check for Presence Identify Parts
palette palette palette

Do you
want to measure
distances between
object edges?

v

Add steps from

Locate Features
palette

Add Caliper step

\ 4

Add Geometry
step

P —

Do you want

Yes

to add another
step?

Figure 1-2. Adding Inspection Steps to a Vision Builder Al Inspection
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Vision Builder Al Configuration Interface

Vision Builder AI has two modes of operation: Configuration and
Inspection. Use the Configuration interface to configure and test your
inspection. Use the Inspection interface to deploy the software and perform
online or offline visual inspection.

Complete the following instructions to open the Vision Builder Al
Configuration interface.

1. Select Start»All Programs»National Instruments»Vision Builder
Al to launch the Vision Builder AI Welcome screen.

2. Click Configure Inspection.
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Elements of the Configuration Interface

Figure 1-3 shows the Vision Builder AI Configuration interface. The
Configuration interface contains four areas: Main window, Overview
window, Inspection Steps palette, and State Configuration window.

Chapter 1

Introduction to Vision Builder Al
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Figure 1-3. Vision Builder Al Configuration Interface
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e Main window—Displays the image being processed, property pages
for some inspection steps, or the state diagram for the inspection. Use
the Main window to define regions of interest in an image, configure
step parameters for some steps, and create/modify the state diagram for
an inspection.

e Overview window—Displays a thumbnail view of either the current
inspection image or the state diagram for the inspection.

* Inspection Steps palette—Lists and describes the steps that you use
to create your inspection. When you click on most steps, the palette
transforms into the property page for the step.

* State Configuration window—Displays the list of steps in the
currently selected state in the inspection.

Inspection State Diagram

Vision Builder Al uses a state diagram to define inspections with unique
states and transitions that govern the execution flow of the inspection.
Simple inspections can be defined using the single-state default inspection,
shown in Figure 1-4.

Skart

default

/In_spect

defaul

End

Figure 1-4. Default Inspection State Diagram
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More complex inspections can be created by adding additional states and
transitions to the default state diagram. Figure 1-5 shows an example of an
inspection that uses the state diagram to perform branching and looping in
the inspection.

Skart

default
Acquire Image & Find Fin Edges
default

Repeat For Mext Pin

Wrong # Pins

End

Figure 1-5. Example of a Vision Builder Al Inspection State Diagram

Within a state diagram, each state can lead to one or multiple states or can
end the inspection cycle. Each state diagram relies on in-state calculations
or user input to determine the next state to execute. Vision Builder Al
executes the state diagram continuously from the Start point to the

End point.

Each state in an inspection is intended to contain a discrete set of inspection
steps. To access the steps contained in a state, select the state on the

state diagram. The steps present in the state will appear in the State
Configuration window. The currently selected state is highlighted on the
state diagram.

Chapter 6, Branching and Decision Making, and Chapter 7, Looping and
Variables, provide examples of using the state diagram.
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Vision Builder Al Inspection Interface

As mentioned in the Vision Builder AI Configuration Interface section of
this chapter, use the Vision Builder Al built-in Inspection Interface to
deploy and run an inspection. Figure 1-6 shows the built-in Inspection
interface, which has three main areas: the Results panel, the Inspection
Statistics panel, and the Display window.

% NI Vision Builder Al - Inspection - Tutorial 3 - Decision Making.vhai E]@
Inspection  View Options  Help
=
s »|e BR8N
~
ield (%) [ 63.24
#Pass 129
[ pass
#Fail 75 . Fail
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[ active O
N e
Idle 1.9
Partsfs [ 17.39
~
6404480 1% Distribution of processing time
Display Al Images Enabled. for the last 100 inspection states
1, B0~
Inspection Statss | Steps | Result | Measure | Comment [ % e
&
Inspect Acquire Fuse PASSN Image 04.jpg . c
I tigs _
Locats Fuse Left Edge |PASS. | Distance = 41,85 " otatus| 5 40
Set Coordinate System |PASS S 20—
Measurs Separation  |PASS. | Distance = 154,33 pix H o
Match Conductor 1 PASS | # Matches =1 PASS| -4 0 0 0 ! 0 !
Match Conductor 2 [N # Matches =0 Too Few matches found | no00 ;Uuiss‘:g'gmeﬁg) 0600
A |

® ®

1 Results Panel

3 Inspection Statistics Panel

2 Display Window

NI Vision Builder for Automated Inspection Tutorial

Figure 1-6. Vision Builder Al Built-in Inspection Interface

Results panel—Lists the steps in the inspection by name. For each

inspection step, Vision Builder displays the step type, result (PASS or
FAIL), measurement made, and a comment explaining the reason of a
FAIL. Inspection Status shows the result of the complete inspection.

Display window—Displays the part under inspection.

ni.com
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* Inspection Statistics panel—Contains three indicators that display
the yield (ratio between PASS and FAIL), active versus idle time, and
processing time of the inspection.

Running an Inspection

Vision Builder Al allows you to run inspections from both the
Configuration and Inspection interfaces. The following sections describe
the options for running an inspection in Vision Builder Al

Configuration Interface

Run an inspection from the Configuration interface during development to
test and debug inspections. The Highlight Execution, Pause, and Single

Step options are useful for debugging inspections. Table 1-1 lists the run

options available for the Configuration interface:

Table 1-1. Configuration Interface Run Modes

Button Name Description
Run Inspection Once Runs the inspection through one iteration of
=1 the state diagram.
Run Inspection in Loop Runs the inspection continuously.
=
Run Inspection Until Failure Runs the inspection until the Inspection
=i Status variable has a value of FAIL.

Run Inspection Multiple Times

Runs the inspection a specified number of
times. This option is available only from the
Operate menu.

Stop Inspection

Stops the inspection.

Highlight Execution

Highlights the inspection execution when
you run the inspection. If the Highlight
Execution button appears yellow, execution
highlighting is enabled.

Pause

Pauses or resumes execution of the
inspection. If the Pause button appears red,
execution is paused.

© National Instruments Corporation 1-9
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Table 1-1. Configuration Interface Run Modes (Continued)

Button Name Description
Single Step Steps through the inspection. Single Step is
ba only available when the Pause button is
pressed.
Use Previous Image Uses the previous inspection image the next
=q time the inspection executes.”
Use Current Image Uses the current inspection image the next
%) time the inspection executes.”
Use Next Image Uses the next inspection image the next time
b the inspection executes.”
= Select Next Image Specifies the inspection image to process the
IxxT next time the inspection executes."
* This button applies only to inspections that either contain a Simulate Acquisition step, or have Smart Camera Emulator,
Embedded Vision System Emulator, or Compact Vision System Emulator selected as the Execution Target.
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Chapter 1 Introduction to Vision Builder Al

After an inspection is configured, use the Inspection interface to run the
inspection and/or deploy your system. Complete the following instructions
to run an inspection from the Inspection interface:

@ Tip If the Vision Builder AI Configuration interface is already open, select File»Switch
to Inspection Interface to open the current inspection in the Inspection interface.

© National Instruments Corporation

Select Start»All Programs»National Instruments» Vision Builder
Al to launch the Vision Builder AI Welcome screen.

Click Inspect Product.
Open an inspection.

Click the Start Inspection button. Vision Builder Al begins running
the inspection and updating the three areas of the Inspection interface
with the most recent inspection data.

By default, Vision Builder Al displays all the inspection images in the
Display window. You can change the display settings in the View
menu to view only images that fail or to have no display. You also can
change the magnification of the displayed images in the Options
menu.

Notice the performance data displayed in the Inspection Statistics
panel. This data can help you determine how efficiently your
inspection is running. Based on this data, you can make adjustments to
improve the inspection speed.

Click the Stop Inspection button to stop the inspection.
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Checking for the Presence

of a Part

This chapter introduces the Match Pattern, Measure Intensity, and Set

Coordinate System steps. Follow the instructions in this chapter to create
an inspection that checks for the presence of a spray bottle cap regardless
of the bottle position in the inspection images.

@ Note Launch Vision Builder Al if it is not open. Refer to the Vision Builder Al
Configuration Interface section of Chapter 1, Introduction to Vision Builder Al,
for more information.

Creating a New Inspection

Select File»xNew. Vision Builder Al opens a new, blank inspection.

Acquiring Inspection Images

In the Inspection Steps palette, the Acquire Images tab contains several
acquisition steps you can use to acquire images from many different types
of cameras. The tab also contains a Simulate Acquisition step, which
simulates image acquisition by loading images from file. The Select Image
step enables you to switch to a previously acquired image that you need to
process later in the inspection.

For simplicity, this tutorial instructs you to use the Simulate A cquisition
step. However, in your real-world inspection, use one of the other image
acquisition steps to acquire images of the object under inspection.

Complete the following instructions to configure a Simulate Acquisition
step that simulates acquiring images of spray bottles.

1. In the Inspection Steps palette, select the Acquire Images tab.

2. Click the Simulate Acquisition step. The property page for the step
opens.

3. In the Step Name control, enter Acquire Spray Bottle.
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4. Click the Browse button. The Select an Image File dialog box opens.

Navigate to <Vision Builder AI>\DemoImg\Tutorial 1, where
<Vision Builder AI> is the location where Vision Builder Al is
installed.

6. Select the first image, Image 01.jpg, and click Open.

7. Make sure the Cycle Through Folder Images control is enabled so
that Vision Builder Al loads a different simulation image from the
folder each time the step is run.

8. Enable the Cache Images control if you want to load all of the images
into memory when the inspection opens. By default, each image is
loaded individually when the step executes.

9. Click OK to add the step to the inspection.

Defining a Feature on which to Base a
Coordinate System

In a machine vision inspection, you typically limit your inspection and
processing to a region of interest (ROI) rather than the entire image for the
following reasons:

* To improve your inspection results by avoiding extraneous objects

* To increase inspection speed

To limit the inspection area, the parts of the object you are interested in
must always be inside the ROI you define.

If the object under inspection is fixtured and always appears at the same
location and orientation in the images you need to process, defining an ROI
is straightforward. However, if the object under inspection appears shifted
or rotated within the images, the regions of interest need to shift and rotate
with the object under inspection.

For the regions of interest to move in relation to the object, you need to set
a coordinate system relative to a significant and original feature of the

object under inspection. Choose a feature that is always in the field of view
of the camera despite the different locations that the objects may appear in
from image to image. Also, make sure the feature is not affected by major
defects that could drastically modify the visual appearance of the feature.
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Complete the following instructions to configure a Match Pattern step that
locates a bottle feature on which you can base a coordinate system.

1. In the Inspection Steps palette, select the Locate Features tab.

9 2. Click the Match Pattern step. The NI Vision Template Editor opens.
=

3. Draw arectangle around the base of the sprayer, as shown in
Figure 2-1. This region becomes the pattern matching template.

% NI Vision Template Editor - Select Template Region

ﬁ.ﬁ

&aa

640x480 1.05¥ 8-hit image 191 (621,22)

|<< Previous| ’ Mext == ] | Finish | ’ Cancel ] ’ Help

Figure 2-1. Creating a Template Pattern

4. Click Next.
Click Finish to accept the template.

On the Main tab, enter Locate Sprayer Base in the Step Name
control.
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The green ROI specifies the area of the image in which Vision Builder Al
tries to locate the template. Assuming that the bottles are fixtured in such a
way that they can move only horizontally within the field of view, you can
limit the ROI so that it surrounds only the area of the image that may
contain a template match during inspection.

7. Redraw or decrease the default green ROI so that it surrounds only the
lower portion of the image, as shown in Figure 2-2.

ﬁ.ﬁ

Locate Sprayer Base

Figure 2-2. Limiting the Search Region

8.  On the Template tab, drag the red crosshair mark in the template
image to the left edge of the sprayer base, as shown in Figure 2-3. This
changes the focal point of the template.

9. The focal point indicates the part of the template that you want to
return as the match location. By default, the focal point is the center of
the template. You can modify the focal point by moving the red
crosshair or by specifying a Match Offset. Later in this inspection,
you use the match location as the origin of a coordinate system.

NI Vision Builder for Automated Inspection Tutorial 2-4 ni.com



Chapter 2 Checking for the Presence of a Part

Main  Template | Settings | Limits |

Template Image .
Template Size
Widkh: 214
Height: g

Makch Offset
% | .33 &
i 20 3

£

Mews Template
Edit Template

Step Status  PASS |

1 Focal Point

Figure 2-3. Adjusting the Focal Point of the Template

10. On the Settings tab, set Number of Matches to Find to 1.

11. On the Limits tab, enable the Minimum Number of Matches control,
and set the value to 1.

12. Click OK to add the step to the inspection.

Setting a Coordinate System

Complete the following instructions to configure a Set Coordinate System
step based on the Match Pattern step you configured.

1. In the Inspection Steps palette, select the Locate Features tab.

2. Click the Set Coordinate System step. The property page for the step
—1—‘ opens.
3. On the Main tab, enter Coordinate System in the Step Name
control.
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" 4.
e

On the Settings tab, select Horizontal and Vertical Motion from the
Mode control because the bottles appear shifted but not rotated from
one image to another.

Notice the Origin list. Match [1], the match location of the previous
Locate Sprayer Base step, is the default origin of the coordinate
system because it is the only location point created by previous steps
in the inspection.

Click OK to add the step to the inspection.

Checking for the Cap Using Measure Intensity

The image of the spray bottle was acquired using a backlight. The cap
appears dark on the bright background. Complete the following
instructions to configure a Measure Intensity step to check for the
presence of a spray bottle cap.

1.

W

In the Inspection Steps palette, select the Check for Presence tab.

Click the Measure Intensity step. The property page for the step
opens.

On the Main tab, enter Check Cap Presence in the Step Name
control.

Enable the Reposition Region of Interest control.

Enabling this control allows you to link the regions of interest specified
in this step to a previously defined coordinate system so that

Vision Builder Al can adjust the location and orientation of the ROI
from image to image relative to the specified coordinate system.

The Reference Coordinate System list shows all the previously
defined coordinate systems. Coordinate System is the default
reference coordinate system because it is the only Set Coordinate
System step in the current inspection.

Notice that the Measure Intensity step supports a variety of different tools
that enable you to draw different shaped regions of interest, such as a point,
line, broken line, freehand line, rectangle, ellipse, annulus, polygon, and
freehand region. These tools are available in the main menu bar.

] 5.

Using the default Rectangle Tool, hold down the <Ctrl> key, and draw
three regions of interest that enclose edges of the cap, as shown in
Figure 2-4. Pressing the <Ctrl> key enables you to draw multiple
regions of interest for the step.

NI Vision Builder for Automated Inspection Tutorial 2-6 ni.com



Chapter 2 Checking for the Presence of a Part

Check Cap Presence

© National Instruments Corporation

Figure 2-4. Defining Regions in Which to Measure Intensity

Click the Limits tab.

At the bottom of the tabbed page, Vision Builder Al returns the
intensity statistics of the pixels inside the regions of interest. Pixel
intensities can range from 0—255, where 0 equals black and 255 equals
white.

The Minimum Intensity value at the bottom of the page returns the

lowest pixel value inside the regions of interest. The backlit edges of
the plastic cap appear in silhouette as dark pixels (which have low pixel
intensities) on a bright background (which has high pixel intensities).

Therefore, when the cap is present, the minimum intensity for the
regions is low. When the cap is not present, the minimum intensity for
the regions is high because the regions contain only bright background
pixels.

Enable the Minimum Intensity control. Set the Maximum value
to 50.00.

Click OK to add the step to the inspection.
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Click the Run State Once button located in the State Configuration
window.

Vision Builder Al loads the next image, Image 02.jpg, from the
<Vision Builder AI>\DemoImg\Tutorial 1 folder and runs the
previous inspection steps in the state on the new image.

Notice that the bottle appears closer to the left edge of the image.
Vision Builder Al repositions the regions of interest based on the new
location of the bottle. The Step Status for the image is PASS because
the presence of the cap inside the regions of interest causes the
Minimum Intensity value to fall within the limits you set.

Setting the Inspection Status

Complete the following instructions to add a Set Inspection Status step to
determine whether the inspection passes or fails.

1.
2.

4.

In the Inspection Steps palette, select the Use Additional Tools tab.

Click the Set Inspection Status step. The property page for the step
opens.

In the Inspection Status control, select the FAIL if any previous step
fails option.

Click OK to add the step to the inspection.

Testing the Inspection

=1

Test the remaining images in the Tutorial 1 folder to make sure the
inspection returns the correct results. Click the Run Inspection Once
button to test the remaining images. Table 2-1 displays the expected results
for each image.

Table 2-1. Expected Results for the Spray Bottle Inspection

Image Name Inspection Status Explanation
Image 03.jpg PASS Cap is present.
Image 04.jpg PASS Cap is present.
Image 05.3pg FAIL Cap is missing.

NI Vision Builder for Automated Inspection Tutorial
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Saving the Inspection

Complete the following instructions to save the example inspection.

1. Select File»Save or click the Save button on the toolbar.

i

2. Navigate to the location where you want to save the inspection.
3. In the File Name control, enter Tutorial 1.vbai.
4

Click Save to save the inspection.

@ Tip Select File»Inspection Properties to add a short description or comments about the
inspection.
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Inspecting Objects for Correct
Measurements

This chapter introduces image calibration, and the Detect Objects and
Geometry steps. Follow the instructions in this chapter to create an
inspection that measures the distance between holes in a gasket to verify
that the gasket conforms to manufacturing specifications.

@ Note Launch Vision Builder Al if it is not open. Refer to the Vision Builder Al
Configuration Interface section of Chapter 1, Introduction to Vision Builder Al,
for more information.

Creating a New Inspection

Select File»xNew. Vision Builder Al opens a new, blank inspection.

Acquiring and Calibrating Inspection Images

For simplicity, this tutorial instructs you to use the Simulate Acquisition
step. However, in your real-world inspection, use one of the other image
acquisition steps to acquire images of the object under inspection.

Complete the following instructions to configure a Simulate Acquisition
step that simulates acquiring images of gaskets.

1.
2.

© National Instruments Corporation

In the Inspection Steps palette, select the Acquire Images tab.

Click the Simulate Acquisition step. The property page for the step
opens.

In the Step Name control, enter Acquire Gasket.
Click the Browse button. The Select an Image File dialog box opens.

Navigate to <Vision Builder AI>\DemoImg\Tutorial 2, where
<Vision Builder AI> isthe location where Vision Builder Al is
installed.

Select the first image, Tmage 01.3jpg, and click Open.
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7.

Make sure the Cycle Through Folder Images control is enabled so
that Vision Builder Al loads a different simulation image from the
folder each time the step is run.

By default, Vision Builder Al returns measurements in pixel units. If you
want the inspection to return measurements in real-world units, you need to
map pixel units to real-world units through a process called spatial
calibration.

9.
10.
11.

Click the Calibration tab.

Click Create Calibration to launch the calibration wizard.

In the Calibration Name control, enter Gasket Calibration.
Click Next.

For this example, assume that the camera that acquired the inspection
images is perpendicular to the image plane and lens distortion is negligible.
Based on these assumptions, you can use Simple Calibration to calibrate
your images. Simple Calibration transforms a pixel coordinate to a
real-world coordinate through scaling in the x (horizontal) and y (vertical)
directions.

12.
13.
14.

15.
16.

Select the Simple Calibration option, and click Next.
Make sure Use Current Image is selected, and click Next.

Make sure Pixel Type is set to Square because the camera that
acquired the images for this exercise has square pixels.

Click Next.

In the Specify the Pixel Ratio step, carefully click the 0 mm and
50 mm markings on the ruler at the bottom of the image, as shown in
Figure 3-1.

@ Tip You may need to use the zoom buttons below the image to accurately click the ruler
markings. After zooming in, scroll down to see the ruler at the bottom of the image.
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Figure 3-1. Specifying the Pixel Ratio

17. In the Correspondence Image - Real World control, enter 50 for the
value, and select millimeter for the Unit.

18. Click Next.

In the Set Calibration Axis step, you can define the origin and angle of the
calibration axis anywhere in the image. By default, the top, left pixel in the
image is the calibration axis origin, and the horizontal axis of the image is
the calibration axis angle. Use the default calibration axis settings for this
exercise.

@ Tip In some applications, you may want to measure between a fixed reference feature on
the part and other features in the image. Setting the origin of the calibration axis to the
location of the reference feature simplifies making measurements because the starting
point for the measurements becomes 0.

19. Click OK to learn the calibration information and exit the calibration
wizard.

20. Click OK to add the step to the inspection.
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Vision Builder Al saves the calibration in the following locations:

¢ Windows XP/2000—cC : \Documents and Settings\All Users\
Application Data\National Instruments\Vision
Builder AI\Calibration

¢  Windows Vista—C: \ProgramData\National Instruments\
Vision Builder AI\Calibration

@ Tip You can apply the learned calibration to all images acquired with the same camera at
the same resolution.

Locating Features to Measure

Complete the following instructions to configure a Detect Objects step that
finds small holes in the gasket.

1. In the Inspection Steps palette, select the Check for Presence tab.

Ol 2. Click the Detect Objects step. The property page for the step opens.

[#3 3. Inthe Step Name control, enter Detect Small Holes.
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4. Using the default Rectangle Tool, draw a region of interest (ROI)
around the entire gasket, as shown in Figure 3-2.

etect Small Hole

Figure 3-2. Defining the ROI

5. In the Threshold tab, select the Bright Objects option for the Look
For control.

Notice that the blue shading highlights all bright pixels—pixels with
high intensity values that fall within the Threshold Range—in the
ROI. Vision Builder Al groups contiguous highlighted pixels into
objects, which are depicted by red bounding rectangles.
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6. Click the Settings tab.
The step locates four objects, which are listed in Table 3-1. Depending
on the location of the user-defined points in the Calibrate Image step
you previously configured, the values for the Size (mm?) may differ
slightly from the values shown in Table 3-1.
Table 3-1. Sizes of Gasket Holes
Object Number Size (pix?) Size (mm?)

1 1,807 61.97

2 13,351 457.85

3 40,816 1,399.71

4 1,780 61.04

Object 1 and Object 4 are the small holes of interest in this step. The
following steps describe how to use the Minimum Object Size and
Maximum Object Size controls of the Detect Objects step to eliminate
objects of no interest based on their size.

7.

10.

Enable the Minimum Object Size and Maximum Object Size
controls.

Based on the information in Table 3-1, the small holes have sizes of
61.97 mm? and 61.04 mm?2.

Set Minimum Object Size to 50 and Maximum Object Size to 70.

In the Limits tab, enable the Minimum Number of Objects and
Maximum Number of Objects controls. Set their values to 2.

Click OK to add the step to the inspection.

Complete the following instructions to find the large hole in the gasket.

1.

Right-click the Detect Small Holes step in the State Configuration
window, and select Copy.

Right-click the Detect Small Holes step again.

Select Paste. A copy of the Detect Small Holes step is placed after the
original step.

Double-click the Detect Small Holes copy or click the Edit Step
button to launch the property page of the step for editing.

In the Step Name control, enter Detect Large Hole.
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Select the Settings tab.

Based on the information in Table 3-1, the large hole has a size of
1399.71 mm?.

Set Minimum Object Size to 1300 and Maximum Object Size
to 1450.

In the Limits tab, enable the Minimum Number of Objects and
Maximum Number of Objects controls. Set their values to 1.

Click OK to add the step to the inspection.

Measuring Parts of the Gasket

Complete the following instructions to measure the distance from the top
small hole to the large hole to inspect whether the distance meets

specifications.
@ Note Vision Builder Al returns the centers of mass for the holes as their locations.
1. In the Inspection Steps palette, select the Measure Features tab.
. 2. Click the Geometry step. The property page for the step opens.
—=
3. In the Step Name control, enter Check Top Distance.
4. In the Geometric Feature control, select the Distance measurement.
s
5. Select points 1 and 3 by clicking the points in the image or selecting
the points from the Available Points list.
6. In the Limits tab, enable the Minimum Distance control and set it
to 32. Enable the Maximum Distance control and set it to 35.
7. Click OK to add the step to the inspection.

Complete the following instructions to measure the distance from the large
hole to the bottom small hole to inspect whether the distance meets

specifications.

1. Right-click the Top Distance step in the State Configuration window,
and select Copy.

2. Right-click the Top Distance step again.

3. Select Paste. A copy of the Top Distance step is placed after the
original step.

4. Double-click the Top Distance copy or click the Edit Step button to
launch the property page of the step for editing.

5. In the Step Name control, enter Check Bottom Distance.

© National Instruments Corporation
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Chapter 3

Inspecting Objects for Correct Measurements

0.

In the Geometric Feature control, select the Distance measurement.

From the Available Points list, select 2 and 3, which correspond to the
bottom small hole and large hole, respectively.

In the Limits tab, enable the Minimum Distance control and set it
to 38. Enable the Maximum Distance control and set it to 40.

Click OK to add the step to the inspection.

Setting the Inspection Status

Complete the following instructions to add a Set Inspection Status step to
determine whether the inspection passes or fails.

1.
2.

4.

In the Inspection Steps palette, select the Use Additional Tools tab.

Click the Set Inspection Status step. The property page for the step
opens.

In the Inspection Status control, select the FAIL if any previous step
fails option.

Click OK to add the step to the inspection.

Testing the Inspection

=1

Test the inspection to make sure it returns the results you expect. Click the
Run Inspection Once button to run the inspection on each of the test
images. Table 3-2 lists the test images, the inspection status to expect for
each image, and an explanation of the status.

Table 3-2. Expected Results for the Gasket Inspection

Image Name Inspection Status Explanation
Image 01.jpg PASS All steps passed.
Image 02.3pg PASS All steps passed.
Image 03.jpg PASS All steps passed.
Image 04.jpg FAIL The Top Distance step failed because the distance
between the holes is too small.
Image 05.3pg FAIL The Detect Small Holes step failed because the

bottom hole is missing. The missing hole also caused
the Bottom Distance step to fail.
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Saving the Inspection

Complete the following instructions to save the example inspection.

1. Select File»Save or click the Save button on the toolbar.

i

2. Navigate to the location where you want to save the inspection.
3. In the File Name control, enter Tutorial 2.vbai.
4

Click Save to save the inspection.

@ Tip Select File»Inspection Properties to add a short description or comments about the
inspection.
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Inspecting for Multiple Correct
Instances of an Object

This chapter introduces the Find Straight Edge, Caliper, and Decision
Making steps. Follow the instructions in this chapter to create an
inspection that measures the distance between the blade connectors of a
fuse and checks the integrity of the fuse conductor regardless of the fuse
position or whether the fuse is inverted.

@ Note Launch Vision Builder Al if it is not open. Refer to the Vision Builder Al
Configuration Interface section of Chapter 1, Introduction to Vision Builder Al,
for more information.

Creating a New Inspection

Select File»xNew. Vision Builder Al opens a new, blank inspection.

Acquiring Inspection Images

For simplicity, this tutorial instructs you to use the Simulate Acquisition
step. However, in your real-world inspection, use one of the other image
acquisition steps to acquire images of the object under inspection.

Complete the following instructions to configure a Simulate Acquisition
step that simulates acquiring images of fuses.

1.
P 2.
=

3.

6.

© National Instruments Corporation

In the Inspection Steps palette, select the Acquire Images tab.

Click the Simulate Acquisition step. The property page for the step
opens.

In the Step Name control, enter Acquire Fuse.
Click the Browse button. The Select an Image File dialog box opens.

Navigate to <Vision Builder AI>\DemoImg\Tutorial 3, where
<Vision Builder AI> isthe location where Vision Builder Al is
installed.

Select the first image, Tmage 01.3jpg, and click Open.
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Chapter 4 Inspecting for Multiple Correct Instances of an Object

7. Make sure the Cycle Through Folder Images control is enabled so
that Vision Builder Al loads a different simulation image from the
folder each time the step is run.

8. Click OK to add the step to the inspection.

Defining a Feature on which to Base a Coordinate
System

The fuses can appear shifted horizontally and slightly rotated from one
inspection image to another. Complete the following instructions to
configure a Find Straight Edge step that finds the left edge of the fuse so
that regions of interest in subsequent steps can shift with the fuse.

1. In the Inspection Steps palette, select the Locate Features tab.

i 2. Click the Find Straight Edge step. The property page for the step
opens.

3. In the Step Name control, enter Locate Fuse Left Edge.

4. Draw a region of interest (ROI) across the left edge of the fuse,
as shown in Figure 4-1.

Locaks Fuse Lafk

Figure 4-1. Finding a Straight Edge

NI Vision Builder for Automated Inspection Tutorial 4-2 ni.com



Chapter 4 Inspecting for Multiple Correct Instances of an Object

Notice that the ROI contains blue search lines. The step searches along
the search lines for sharp transitions in pixel intensities, which usually
represent object edges. The step fits a straight line through the
individual detected edge points of each search line to determine the left
edge of the fuse.

5. Click OK to add the step to the inspection.

Setting a Coordinate System

Complete the following instructions to configure a Set Coordinate System
step based on the Find Straight Edge step you configured.

1. In the Inspection Steps palette, select the Locate Features tab.

2. Click the Set Coordinate System step. The property page for the step
—I—~ opens.
3. In the Main tab, enter Set Coordinate System in the Step Name
control.
1_4_. 4. Inthe Settings tab, select Horizontal Motion from the Mode control.
Notice the Origin list. Point 1, the first point of the straight line

detected by the Locate Fuse Left Edge step, is the default origin of the
coordinate system. In this exercise, the location of the origin does not
affect the measurement you need to make. Therefore, use the default
origin.

5. Click OK to add the step to the inspection.

Measuring the Separation between Connectors

Complete the following instructions to configure a Caliper step that
measures the distance between the blade connectors of the fuse.

1. In the Inspection Steps palette, select the Measure Features tab.

| 2. Click the Caliper step. The property page for the step opens.

3. Inthe Main tab, enter Measure Separation in the Step Name
control.

4. Enable the Reposition Region of Interest control.
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5. Draw an ROI across the blade connectors, as shown in Figure 4-2.

Figure 4-2. Measuring the Distance Between Two Edges

x 6. Inthe Settings tab, select the Process named Vertical Min Caliper to
= change the direction and orientation of the caliper search lines.

7. In the Limits tab, enable the Minimum Distance control and set the
value to 150. Enable the Maximum Distance control and set the value
to 160.

8. Click OK to add the step to the inspection.

NI Vision Builder for Automated Inspection Tutorial 4-4 ni.com



Chapter 4 Inspecting for Multiple Correct Instances of an Object

Inspecting the Fuse Conductor

Complete the following instructions to configure Match Pattern steps that
inspect the integrity of the fuse conductor.

1. In the Inspection Steps palette, select the Locate Features tab.

9 2. Click the Match Pattern step. The NI Vision Template Editor opens.
e

3. Draw an ROI around the conductor, as shown in Figure 4-3. This
region becomes the pattern matching template.

% NI ¥ision Template Editor - Select Template Region

640x480 1.05X B-hit image 255 (592,166) >

|<< Previous| [ MNext == ] | Finish | [ Cancel ] [ Help

Figure 4-3. Creating a Template Pattern

4. Click Next.
Click Finish to accept the template.

On the Main tab, enter Match Conductor 1 inthe Step Name
control.

7. Make sure the Reposition Region of Interest control is enabled.
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8.

Redraw or decrease the default green ROI so that it surrounds an area
slightly larger than the template, as shown in Figure 4-4.

=1

10.

11.

12.

13.
14.

Figure 4-4. Limiting the Search Region

In the Settings tab, set Number of Matches to Find to 1.
Enable the Search for Rotated Patterns control.

Set the Angle Range +/— (degrees) control to 10 to enable the step to
locate the best match possible within +10° of the learned template
angle.

In the Limits tab, enable the Minimum Number of Matches control
and set the value to 1.

Click OK to add the step to the inspection.

Click the Run Inspection Once button twice so that Tmage 03.jpg
becomes the active image.

@ Note The name of the active image is displayed in the Acquire Fuse step in the State
Configuration window.
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A fuse may be inverted when Vision Builder Al acquires an image of the
fuse. This inversion causes the conductor to look different than the
template, shown in Figure 4-5a. To prevent a good but inverted fuse from
failing inspection, you need to learn a pattern matching template for the
inverted instances of the conductor as well, shown in Figure 4-5b.

15.
16.

17.

18.
19.
20.

21.

22.

23.

24.

25.
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Figure 4-5. Valid Templates for the Conductor

In the Inspection Steps palette, select the Locate Features tab.

Click the Match Pattern step. The Select a template in the image
dialog box opens.

Draw an ROI around the conductor, similar to the region you drew in
step 3.

Click OK to learn the inverted template.
In the Step Name control, enter Match Conductor 2.

Set the Region of Interest control to Match Conductor 1. This
configures the Match Conductor 2 step to use the same ROI that you
previously defined for the Match Conductor 1 step.

In the Settings tab, set Number of Matches to Find to 1.
Enable the Search for Rotated Patterns control.

Set the Angle Range +/- (degrees) control to 10 to enable the step to
locate the best match possible within +10° of the learned template
angle.

In the Limits tab, enable the Minimum Number of Matches control
and set the value to 1.

Click OK to add the step to the inspection.
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Making Logical PASS/FAIL Decisions

In the previous lessons, the inspection would fail if any of the steps in the
inspection failed. In this lesson, because the conductor under inspection can
match only one of the patterns you specified, one of the Match Pattern
steps always fails. If you were to set the Inspection Status to fail if any of
the steps in the inspection fail, the entire inspection will always fail because
one of the Match Pattern steps always fails.

Using the Logic Calculator step, you can create a Boolean result that is
based on the results of the previous inspection steps. The Set Inspection
Status step can use this Boolean result to determine the Inspection Status.

Complete the following instructions to configure a Logic Calculator step
that causes the inspection to pass when the conductor matches either the
template in Match Conductor 1 or Match Conductor 2, and when the
Measure Separation step passes.

1. In the Inspection Steps palette, select the Use Additional Tools tab.

o 2. Click the Logic Calculator step. The property page opens in the Main
window.

In the Step Name control, enter Decide Pass/Fail.

4. In the First Operand frame, set Source to Measure Separation.
Set Measure to Step Status.

Current Value displays the value of the measurement based on the
current image.

5. Make sure Second Operand is set to Constant, and Constant is set
to True.

6. Click Add to add this expression to the Expression table.

In the First Operand frame, set Source to Match Conductor 1.
Set Measure to Step Status.

8. Make sure Second Operand is set to Constant, and Constant is set
to True.

9. Click Add to add this expression to the Expression table.

Notice the default binary operator AND in the last column of the
Expression table.

10. In the First Operand frame, set Source to Match Conductor 2.
Set Measure to Step Status.

11. Make sure Second Operand is set to Constant and Constant is set
to True.
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12.
13.

14.

15.

Chapter 4 Inspecting for Multiple Correct Instances of an Object

Click Add to add this expression to the Expression table.

Select the second expression in the Expression table, and click
AND/OR to change the binary operator to OR.

Hold down the <Shift> key, and select the second and third expressions
in the Expression table.

Click () to group the expressions.

The Logic Calculator property page should resemble Figure 4-6.

Step Mame | Decide Pass/Fail
Operands
First Operand Second Operand
Siource Makch Conductor 2 |4 &) Constant True |
Dperakor
Measure Step Status v = w| O source
Current Walue:  Pass Resulk Measure
TRLE Current Yalue:
—
Expression
{ | First Operand MCT | Operator | Second Operand )] Result | ARNDYOR d AMDIOR
Measure Separation - Step Statu: = TRLE True AN
{  Match Conducter 1 - Step Status TRUE ey - Megate
IMakch Conduckor 2 - Step Status = TRLE 1 True
Adl
Logic Result  TRUES
Maode
() Step passes inspection when Logic Result is TRUE. Step Status
() Step passes inspection if the Expression can be evaluated {i.e. all necessary results PASS '
are available). The Logic Result is logged as a boolean measurement that can be used
in future skeps.

16.
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Figure 4-6. Logic Calculator Property Page

Click OK to add the step to the inspection.
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Inspecting for Multiple Correct Instances of an Object

Setting the Inspection Status

Complete the following instructions to configure Vision Builder Al to pass
the inspection when the Logic Calculator step passes, regardless of the

results of individual steps in the inspection.

1. In the Inspection Steps palette, select the Use Additional Tools tab.

opens.

In the Step Name control enter Set Inspection Status.

4. In the Inspection Status control select the Equals specified

2. Click the Set Inspection Status step. The property page for the step
e

measurement option, and select Decide Pass/Fail - Step Status for

the value.

Make sure the Update Number of Parts Inspected control is enabled.

6. Click OK to add the step to the inspection.

Testing the Inspection

Test the inspection to make sure it returns the results you expect. Click the

Run Inspection Once button to test the remaining images. Table 4-1 lists

=1

the test images, the inspection status to expect for each image, and an
explanation of the status.

Table 4-1. Expected Results for the Fuse Inspection

Image Name Inspection Status Explanation

Image 0l.jpg PASS All steps pass but one Match Pattern step.

Image 02.3pg PASS All steps pass but one Match Pattern step.

Image 03.jpg PASS All steps pass but one Match Pattern step.

Image 04.3jpg PASS All steps pass but one Match Pattern step.

Image 05.jpg PASS All steps pass but one Match Pattern step.

Image 06.jpg FAIL The Measure Separation step fails because
the blade connectors are too close together.

Image 07.Jpg FAIL Both Match Pattern steps fail because the
conductor is blown.

Image 08.jpg FAIL Both Match Pattern steps fail because the
conductor is melted.

NI Vision Builder for Automated Inspection Tutorial
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Chapter 4 Inspecting for Multiple Correct Instances of an Object

Saving the Inspection

Complete the following instructions to save the example inspection.

H 1. Select File»Save or click the Save button on the toolbar.

2. Navigate to the location where you want to save the inspection.
3. In the File Name control, enter Tutorial 3.vbai.
4

Click Save to save the inspection.

@ Tip Select File»Inspection Properties to add a short description or comments about the
inspection.
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Inspecting an Object that Spans
Two Image Frames

This chapter introduces the Select Image and Calculator steps.

Assume that you need to measure the width of a wide wooden plank with
high accuracy. The only cameras available for the application have low
pixel resolutions.

To measure the width of a plank, you need to locate its left and right edges.
If you were to set up the imaging system so both edges of a plank fit within
an available camera’s field of view, the resulting image detail would be too
low to yield accurate measurements. Because the required image detail
exceeds the pixel resolution capability of a single camera, two cameras per
plank are needed—one camera to acquire an image of the left edge and one
camera to acquire an image of the right edge.

Follow the instructions in this chapter to create an inspection that measures
the width of a wooden plank that spans two images.

@ Note Launch Vision Builder Al if it is not open. Refer to the Vision Builder Al
Configuration Interface section of Chapter 1, Introduction to Vision Builder Al,
for more information.

Creating a New Inspection

Select File»xNew. Vision Builder Al opens a new, blank inspection.
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Acquiring Inspection Images from Two Cameras

For simplicity, this tutorial instructs you to use the Simulate Acquisition
step. However, in your real-world inspection, use one of the other image
acquisition steps to acquire images of the object under inspection.

Acquiring and Calibrating the Image of the Left Edge

Complete the following instructions to configure Simulate Acquisition
steps that simulate acquiring an image of the left section of the wooden
plank and calibrating the image.

1.
2.

0.

10.

11.

In the Inspection Steps palette, select the Acquire Images tab.

Click the Simulate Acquisition step. The property page for the step
opens.

In the Step Name control, enter Acquire Plank (Left).
Click the Browse button. The Select an Image File dialog box opens.

Navigate to <Vision Builder AI>\DemoImg\Tutorial 4 Left,
where <Vision Builder AI> is the location where Vision Builder
Al is installed.

Select the first image, Image 01.Jjpg, and click Open.

Make sure the Cycle Through Folder Images control is enabled so
that Vision Builder Al loads a different simulation image from the
folder each time the step is run.

Click the Calibration tab.
Click Create Calibration to launch the calibration wizard.

In the Calibration Name control, enter Plank Calibration
(Left).

Click Next.

For this example, assume that the camera that acquired the inspection
images is perpendicular to the image plane and lens distortion is negligible.
Based on these assumptions, you can use Simple Calibration to calibrate
your images. Simple Calibration transforms a pixel coordinate to a
real-world coordinate through scaling in the x (horizontal) and y (vertical)
directions.

12.
13.
14.

Select the Simple Calibration option, and click Next.
Make sure Use Current Image is selected, and click Next.

Make sure Pixel Type is set to Square because the camera that
acquired the images for this exercise has square pixels.
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15. Click Next.

16. In the Specify the Pixel Ratio step, carefully click the 1 cm and 5 cm
markings on the ruler at the bottom of the image, as shown in
Figure 5-1.

@ Tip  You may need to use the zoom buttons below the image to accurately click the ruler
markings. After zooming in, scroll down to see the ruler at the bottom of the image.

a Calibration Wizard w
h] Step 4 - Specify the Pixel Ratio

Seleck 2 points by either clicking in the image, or
double-clicking in the list, and enter the distance
between the points in real-world unit,

Paints
/ 1- User Defined Pairk 1 m
4 2- User Defined Point 2

Faint 1 Paink 2

¥ 69,000 ¥ 401,000
W 340,000 W 340,000

Correspondence Image - Real World

Length | 332,00 |pixels <->|4 @|

v |
£40x490 1% 228 (51,449) 3 | (2]

2|plax (o ) [omn ) (o]

Figure 5-1. Defining the Pixel to Real-World Ratio

17. In the Correspondence Image - Real World control, enter 4 for the
value, and select centimeter for the Unit.

18. Click Next.
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19. In the Set Calibration Axis step, click the 1 cm marking to define it as
the origin of the calibration axis. Draw a line horizontally and to the
right along the edge of the ruler to define the angle of the calibration
axis, as shown in Figure 5-2.

‘@ Calibration Wizard m
B8] step 5 - Set Calibration Axis

Select the Origin of the Calibration Axis, and the angle
of the ¥ axis, relative to the harizontal. You can draw
a line in the image to specify the Origin and X Axis
Angle.

Calibration Axis

Axis Origin

oo 8] ¥
¥ Axis Angle degrees

Axis Reference o 4
j I—ox

1 ST

III‘IIII Hlli]llfiﬂcim I||I'IIII|IIH1HIIIIIIIlH

1 2 S T
Ga0naB0 16 220 (140,413 (%] I | (2]

ﬁ") ﬁ 91:'0‘ ’ OF ] ’ Cancel ] ’ Help ]

Figure 5-2. Defining the Origin and Angle of the Calibration Axis

20. Set the Axis Reference control to Direct.

21. Click OK to learn the calibration information and exit the calibration
wizard.

22. Click OK to add the step to the inspection.
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Acquiring and Calibrating the Image of the Right Edge

This section simulates acquiring an image of the right section of the
wooden plank. Because the simulated acquisition represents a second
camera, you cannot reuse the calibration that you created for the first
camera.

Complete the following instructions to configure Simulate Acquisition
steps that simulate acquiring an image of the right section of the wooden
plank and calibrating the image.

1.
2.

9.

10.

11.

In the Inspection Steps palette, select the Acquire Images tab.

Click the Simulate Acquisition step. The property page for the step
opens.

In the Step Name control, enter Acquire Plank (Right).
Click the Browse button. The Select an Image File dialog box opens.

Navigate to <Vision Builder AI>\DemoImg\Tutorial 4
Right, where <Vision Builder AI> is the location where Vision
Builder Al is installed.

Select the first image, Tmage 01.3jpg, and click Open.

Make sure the Cycle Through Folder Images control is enabled so
that Vision Builder Al loads a different simulation image from the
folder each time the step is run.

Click the Calibration tab.
Click Create Calibration to launch the calibration wizard.

In the Calibration Name control, enter Plank Calibration
(Right).

Click Next.

Again, assume that the camera that acquired the inspection images is
perpendicular to the image plane and lens distortion is negligible.

12.
13.
14.

15.
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Select the Simple Calibration option, and click Next.
Make sure Use Current Image is selected, and click Next.

Make sure Pixel Type is set to Square because the camera that
acquired the images for this exercise has square pixels.

Click Next.
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16. In the Specify the Pixel Ratio step, carefully click the 38 cm and
42 cm markings on the ruler at the bottom of the image, as shown in
Figure 5-3.

@ Tip You may need to use the zoom buttons below the image to accurately click the ruler
markings. After zooming in, scroll down to see the ruler at the bottom of the image.

a Calibration Wizard m
[ﬂ Step 4 - Specify the Pixel Ratio

Select 2 points by either clicking in the image, or
double-clicking in the list, and enter the distance
between the points in real-world unit,

Paints

& 1-User Defined Paint 1 M
4 2-User Defined Paink 2

f]
Paint 1 Paint 2

®o 62,000 i 394,000
Wi 346,000 Wi 346,000

Correspondence Image - Real World

A . 2
IIIIIII IIII|I|II IIIII[III ll||||||| IIII|I|II R e —

Gd0ndBl 1% 131 (270,580 [ I |
ﬁ') ﬁ an ’ OF ] ’ Cancel ] ’ Help ]

Figure 5-3. Defining the Pixel to Real-World Ratio

38 39 40 41 42
B

17. In the Correspondence Image - Real World control, enter 4 for the
value, and select centimeter for the Unit.

18. Click Next.
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19. In the Set Calibration Axis step, click the 38 cm marking to define it
as the origin of the calibration axis. Draw a line horizontally and to the
right along the edge of the ruler to define the angle of the calibration
axis, as shown in Figure 5-4.

@ Calibration Wizard m
[ Step 5 - Set Calibration Axis

Seleck the Crigin of the Calibration Axis, and the angle
of the ¥ axis, relative to the horizontal, ¥ou can draw
a line in the image ko specify the Crigin and X Axis
Angle.

Calibration Axis

Axis Origin

>< ’
¥ Axis Angle degrees

Axis Reference  al 4%
j T—bx

=
(3]
3

||[|||| I ||n£':.f:c:m1|un'nn||u|'|||||||||'|||

1
e 4D 41 42

#loam o) Comer ) Lo

Figure 5-4. Defining the Origin and Angle of the Calibration Axis

20. Set the Axis Reference control to Direct.

21. Click OK to learn the calibration information and exit the calibration
wizard.

22. Click OK to add the step to the inspection.

Locating the Right Edge of the Part

Complete the following instructions to configure a Find Edges step that
locates the right edge of the part.

1. In the Inspection Steps palette, select the Locate Features tab.

@ 2. Click the Find Edges step. The property page for the step opens.

3. Inthe Step Name control, enter Find Right Edge.
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4. Draw aline across the right edge of the part going from right to left, as
shown in Figure 5-5.

@ Tip Pressing the <Shift> key while drawing a line constrains the line tool to only draw
horizontal or vertical lines.

5. Click the Settings tab.
6. In the Look for control, select First Edge.
7. In the Edge Polarity control, select Bright to Dark Only.

Find Right Edge

IIIIIII Illl‘llﬂ ﬂlll[lli Illllllll IIIi‘IIII IIIIIIIII IIII‘HII IIIIIiIII

38 39 40 41 42 43 44 4

Figure 5-5. Finding the Right Edge of the Plank

Notice the red square on the search line. The step searches along the
search line for a sharp transition in pixel intensities, which usually
represents an object edge. The red square marks the location of the
right edge of the part.

8. Click OK to add the step to the inspection.
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Switching Images

Now that you have configured the inspection to locate the right edge of the
wooden plank, you need to switch to the image of the left side of the plank.
Complete the following instructions to configure a Select Image step that
makes the image of the left side of the plank active for processing.

1.

= 2.
W 3.
4.

In the Inspection Steps palette, select the Acquire Images tab.
Click the Select Image step. The property page for the step opens.
In the Step Name control, enter Switch to Left Side.

In the Image Selection list, select Acquire Plank (Left). The image
of the left side of the part appears in the Main window.

Click OK to add the step to the inspection.

Locating the Left Edge of the Part

Complete the following instructions to configure a Find Edges step that
locates the left edge of the part.

1.

2
3.
4

e

© National Instruments Corporation

In the Inspection Steps palette, select the Locate Features tab.
Click the Find Edges step. The property page for the step opens.
In the Step Name control, enter Find Left Edge.

Hold down the <Shift> key and draw a line across the left edge of the
part going from left to right, as shown in Figure 5-6.

Click the Settings tab.
In the Look for control, select First Edge.
In the Edge Polarity control, select Bright to Dark Only.
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Find Left Edge

1 2 -3 4 '6 6 .

Figure 5-6. Finding the Left Edge of the Plank

The step searches along the search line and marks the location of the
left edge with a red square.

8. Click OK to add the step to the inspection.
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Calculating the Width of the Part

Now that you have located the right edge of the part in one image and

the left edge of the part in another image, you need to combine the
measurements from the two images to determine the width of the part. Use
the Calculator step to combine the two measurements and compute the
width.

Refer to the following equations as you configure the step.
Right (LC) = Right (RC) + (Origin R — Origin L) (5-1)
Part Width = Right (LC) — Left (LC) 5-2)

where Right (LC) = The x position of the right edge in the calibration
axis of the left edge.

Right (RC) = The x position of the right edge in the calibration
axis of the right edge. This corresponds to the calibrated
x position result of the Find Right Edge step.

Origin R = The x position of the origin in the calibration axis of
the right edge.

Origin L = The x position of the origin in the calibration axis of
the left edge.

Left (LC) = The x position of the left edge in the calibration axis
of the left edge. This corresponds to the calibrated x position
result of the Find Left Edge step.

Setting Calculator Step Inputs and Outputs

Complete the following instructions to configure a Calculator step to
select the input measurements from the previous Find Right Edge and
Find Left Edge steps, and create output results for the calculated values.

1. In the Inspection Steps palette, select the Use Additional Tools tab.
2. Click the Calculator step. The Calculator Setup Wizard opens.

i

]
B

b

0]

3. Click Next to proceed with the wizard.

Notice the Input Measurements list. The list contains all of the
measurable data from each of the previous steps in the inspection.
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4. Select the following measurements from the Input Measurements
list:
* Find Right Edge»Edge [1].X Position (Calibrated)
*  Find Left Edge»Edge [1].X Position (Calibrated)
Click Next.

6. Click Add New Output Result. A new output appears in the Qutput
Results list.

7. Inthe Name control, enter Part wWidth. This output will contain the
results of Equation 5-2.

Make sure Type is set to Numeric.
9. Click Add New Output Result again.

10. In the Name control, enter Right (LC). This output will contain the
results of Equation 5-1.

11. Make sure Type is set to Numeric.
12. Click Finish to close the Calculator Setup Wizard.

The Main window now displays a diagram with the measurement inputs
and result outputs you specified in the Calculator Setup Wizard, as shown
in Figure 5-7. The diagram also contains a default Boolean result named
Step Result. You can connect the result of a computation to Step Result,
which changes the status of the Calculator step to the result of the
computation. Refer to the Making Logical PASS/FAIL Decisions with the
Calculator Step section of this chapter for more information about Step

Result.
Find Right Edge - Edge [1].% Position (Calibrated) Step Result
T
TF
Find Left Edge - Edge [1].% Position {Calibrated) Part width
fzap L1230
Right (L)
[i123]

Figure 5-7. Calculator Diagram Elements

Notice that the inputs and outputs are framed with color and have codes at the
bottom of their frames. These colors and codes visually group inputs and
outputs into their respective data types—numerics, Booleans, or strings.
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13. To simplify the process of connecting the diagram elements later in
this chapter, arrange the elements into the configuration shown in
Figure 5-8 by dragging them to their new positions.

Find Right Edge - Edge |1 |.% Pasition (Calibrated)

Right (LC)
eeEdo [
= {12z

Find Left Edge - Edge [1]. Position (Calibrated) Part Width
""" Bi.2s]

Step Resulk

IQI
TF

Figure 5-8. Arranging Diagram Elements

Adding Operators and Constants

Earlier in this chapter, you used the Calibration Wizard to set calibration
axis origins for the right and left sides of the part. These origins are the only
elements of Equations 5-1 and 5-2 not yet represented in the Calculator
diagram: (Origin R and Origin L).

In step 19 of the Acquiring and Calibrating the Image of the Right Edge
section of this chapter, you set the origin of the right side to the 38 cm
marking of the imaged ruler. In step 19 of the Acquiring and Calibrating
the Image of the Left Edge section of this chapter, you set the origin of the
left side to the 1 cm marking of the imaged ruler. Therefore,

(Origin R - Origin L) =38 — 1 =37.

The distance between the calibration axis origins is a constant value. Add a
constant with the value 37 to the Calculator diagram.

1. In the Functions palette, click Numeric.

=y
L]
L

w

2. Click the Num Const operator. Click inside the Calculator diagram
below the Find Right Edge - Edge [1].X Position (Calibrated) input
measurement to place the numeric constant on the Calculator diagram.

123 3. Double-click the numeric constant and type 37 to set the value of the
constant.
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|> 4. Click the Add operator in the Functions palette. Click inside the
Calculator diagram to the right of the Find Right Edge - Edge [1].X
Position (Calibrated) input measurement.

@ Tip Place the Add operator close enough to the Find Right Edge - Edge [1].X Position
(Calibrated) input so that the Calculator step automatically connects the two elements
with a wire.

5. Click the Show Help Window button on the Main tab of the
Calculator step to launch the Help window, or click the Help button
in the Calculator diagram toolbar. When you move your cursor over
certain elements within the Calculator diagram, information about that
item shows in the Help window.

6. Place your cursor over the Add operator. Notice in the Help window
that the operator has an x input terminal, y input terminal, and
x+y output terminal.

|> 7. Click the Subtract operator in the Functions palette. Click inside the
Calculator diagram to the right of the Find Left Edge - Edge [1].X
Position (Calibrated) input measurement.

Your Calculator diagram should look similar to the diagram shown in

Figure 5-9.
Find Right Edge - Ed 1].% Positi Calibraked
ind Rigl ge ge | 1].% Position {Calibraked) Right (LC)
2] | B
; ]
= |> I
Find Left Edge - Edge [1].% Pasition (Calibrabed) Part Width
_____ =]

Step Resulk

II
TF

Figure 5-9. Unconnected Diagram Elements

Connecting the Equation Elements

Complete the following instructions to wire the diagram elements together
such that they form Equation 5-1: Right (LC) = Right (RC) + (37).

1. Place your cursor on the small, triangular terminal located on the right
side of the numeric constant. The cursor changes into a Wiring tool.
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Use the Wiring tool to click the terminal and release the mouse. As you
move the cursor across the Calculator diagram, the Calculator step
draws a wire between the terminal and the Wiring tool as though the
wire were unwinding from a spool.

Without holding down the mouse button, move the cursor to the y input
terminal of the Add operator. The y input terminal blinks. Use the
Wiring tool to click the y input terminal and complete the connection.

Click the output terminal of the Add operator, and connect it to the
input terminal of Right (L.C).

Tip If you do not terminate a wire correctly, the wire is broken and appears as a dashed
black line with a red X in the middle. Click Remove Broken Wires in the Main tab to
remove broken wires.

Complete the following instructions to wire the diagram elements together
such that they form Equation 5-2: Part Width = Right (LC) — Left (LC).

1.

Place the cursor on the wire that connects the Add operator to
Right (LC). The cursor changes into the Wiring tool.

Click the wire, and connect it to the x input terminal of the Subtract
operator.

Click the Find Left Edge - Edge [1].X Position (Calibrated) output
terminal, and connect it to the y input terminal of the Subtract
operator.

Click the output terminal of the Subtract operator, and connect it to
the input terminal of Part Width.

Your connected Calculator diagram should look similar to the diagram
shown in Figure 5-10.

Find Right Edge - Edge |1 ].x Pasition (Calibrated)

e e
' o 123
37 i

Right (LC)

Step Resulk

lEBI
TF
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Figure 5-10. Connected Elements of Calculator Diagram
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5.
6.

In the Calculator step property page, click the Measurements tab.

Click Compute Results to see the results of the calculation thus far.

Making Logical PASS/FAIL Decisions with the Calculator Step

Now that you have a created a diagram to measure the width of the part,
you need a way to verify that the width meets manufacturing specifications.
Complete the following instructions to add diagram elements that compare
the measured width to minimum and maximum width tolerances and
decide whether the plank passes inspection.

1.

¥ 2.
E>[;=‘:-> 3.

® N W

10.
11.
12.

13.

14.
15.
16.
17.

18.

19.

Click the up arrow in the Functions palette to return to the main palette.
Select the Comparison palette.

Click the Less? operator in the Comparison palette. Click inside the
Calculator diagram below Part Width.

Connect the wire between Subtract and Part Width to the x input of
the Less? operator.

Click the up arrow in the Functions palette to return to the main palette.
Select the Numeric palette.
Click the Num Const operator in the Numeric palette.

Click close enough to the y input of Less? to automatically wire the
numeric constant and y input together.

Type 40.5 to set the maximum width a plank can be to pass the
inspection.

Click the up arrow in the Functions palette to return to the main palette.
Select the Comparison palette.

Click the Greater? operator. Click inside the Calculator diagram
below the Less? operator.

Connect the wire between Subtract and Part Width to the x input of
the Greater? operator.

Click the up arrow in the Functions palette to return to the main palette.
Select the Numeric palette.
Click the Num Const operator.

Click close enough to the y input of Greater? to automatically wire the
numeric constant and y input together.

Type 39.5 to set the minimum width a plank can be to pass the
inspection.

Click the up arrow in the Functions palette to return to the main palette.
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Select the Boolean palette.

Click the And operator. Click close enough to the left side of Step
Result to wire the two elements together.

Connect the Less? output to the x input of And.
Connect the Greater? output to the y input of And.

Your completed Calculator diagram should look similar to the diagram
shown in Figure 5-11.

Find Right Edge - Edge |1 ].x Pasition (Calibrated)
ey |
: > 123
37 &

Find Left Edge - Edge [1].x Position (Calibrated)

g

Right (LC)

I> ..... . Step Result
0.5

TF

24.
25.
26.

Figure 5-11. Calculator Diagram with Decision-Making Abilities

In the Calculator step property page, click the Limits tab.
Enable the Step Result is True checkbox.
Click OK to add the step to the inspection.

Setting the Inspection Status

Complete the following instructions to add a Set Inspection Status step to
determine whether the inspection passes or fails.

1.

= 2.

© National Instruments Corporation

In the Inspection Steps palette, select the Use Additional Tools tab.

Click the Set Inspection Status step. The property page for the step
opens.

In the Inspection Status control, Select the FAIL if any previous
step fails option.

Click OK to add the step to the inspection.
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Testing the Inspection

Test the inspection to make sure it returns the results you expect. Click the
Run Inspection Once button to test the remaining images. Table 5-1 lists
the test images, the inspection status to expect for each image, and an
explanation of the status.

=1

@ Note Results may vary slightly based on the accuracy of the calibration and the edge
detection location.

Table 5-1. Expected Results for the Plank Inspection

Image Name Part Width Inspection Status
Image 01.jpg 40.00 cm PASS
Image 02.jpg 40.16 cm PASS
Image 03.jpg 40.28 cm PASS
Image 04.jpg 39.27 cm (too short) FAIL
Image 05.jpg 40.90 cm (too long) FAIL

Saving the Inspection

Complete the following instructions to save the example inspection.

H 1. Select File»Save or click the Save button on the toolbar.

2. Navigate to the location where you want to save the inspection.
3. In the File Name control, enter Tutorial 4.vbai.
4

Click Save to save the inspection.

(&)

Tip Select File»Inspection Properties to add a short description or comments about the
inspection.
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This chapter introduces the inspection state diagram and the Custom
Overlay step. Follow the instructions in this chapter to create an inspection
that checks the image for the presence of a spray bottle and, if a bottle is
present, transitions to another state to determine if the bottle has a cap. If
there is no spray bottle present in the image, the inspection moves on to the
next image.

@ Note Launch Vision Builder Al if it is not open. Refer to the Vision Builder Al

Configuration Interface section of Chapter 1, Introduction to Vision Builder Al,
for more information.

Creating a New Inspection

Select File»New to load a new, blank Vision Builder Al inspection.

Creating the Inspection State Diagram

The configurable process model in Vision Builder Al is represented by a
state diagram. Complete the following instructions to create a state diagram
to define the inspection.

£ 7] 1. Click the Toggle Main Window View button on the toolbar to bring
4] the state diagram to the Main window.
Start
default
Inspect
default
End

Figure 6-1. Default Inspection State Diagram
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2. Double-click the Inspect state to launch the Edit State Name dialog
box.

3. Inthe State Name control, enter Check Part Presence, and
click OK.

4. Right-click an open area on the state diagram and select Create New
State to add a new state to the inspection, as shown in Figure 6-2. The
Edit State Name dialog box opens.

Start

defaul

Chedk Part Presgnce
Create Mew State
default Create Mew End Point

End Import Inspection

Figure 6-2. Creating a New Inspection State

5. In the State Name control, enter Inspect Part.
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Create two more states named Fail Part and Pass Part. The state
diagram should now resemble the state diagram shown in Figure 6-3.

Start

default

Chegk Part Presgnce

defaul

End

@ default
I/F;il Part defaulk @;5 Part default

Figure 6-3. Adding New States to the Inspection

Next, you will create transitions between the various inspection states.
Notice that every state has a default transition. You can also create
additional transitions between states based on measurement results or
variable values.

@ Note The default transition occurs if the transition requirements for other possible
transitions are not met.

10.
11.

© National Instruments Corporation

Click the arrow of the Check Part Presence default transition and drag
it back to the Check Part Presence state. This creates a loop that will
run the steps in the Check Part Presence State until a part is detected.

Click the End point and drag it to the bottom of the state diagram.

Click the Inspect Part default transition and drag it to the Fail Part
state.

Click the Fail Part default transition and drag it to the End point.
Click the Pass Part default transition and drag it to the End point.
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The state diagram should now resemble the state diagram shown in
Figure 6-4.

Skart

default

default
Chetk Part Presgnce

@;s Part

default

I/Ha_il Part:

default

End

Figure 6-4. Configuring the Default Transitions
12. Right-click the Check Part Presence state and select Create New
Transition.

13. Click the Inspect Part state to create a transition between the Check
Part Presence and Inspect Parts states, as shown in Figure 6-5.

+

Chetk Part Presgnce

default

Transition 1

nspeck Par

defaul

Figure 6-5. Creating a New Transition

You can change the shape of the transition by dragging the anchor
point at the center of the transition. You can move the location of the
transition label by clicking the label and dragging it to the new
location.
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@ Tip When drawing a transition, click once on the state diagram to set the anchor point for
S the transition. The anchor point allows you to draw an arc instead of a straight line to
represent the transition.

14. Double-click the transition to launch the Edit Transition dialog box,
which is used to configure the transition.

15. In the Transition Name control, enter Part Detected, and
click OK.

16. Create another transition named Part OK between the Inspect Part
and Pass Part states.

The state diagram should now resemble the state diagram shown in
Figure 6-6.

Skark

default
default

Chetk Part Presgnce

Part Detected

End

Figure 6-6. Completed State Diagram for the Inspection

Note You can remove a state or transition from the inspection by selecting the object you
want to remove and pressing the <Delete> key.

&

Note You cannot rename or remove the default transition of a state.

&

Each state in an inspection is intended to contain a separate set of inspection
steps. To access the functions in a state, click the state in the state diagram.
The currently selected state is highlighted in blue on the state diagram.
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Acquiring Inspection Images

For simplicity, this tutorial instructs you to use the Simulate Acquisition
step. However, in your real-world inspection, use one of the other image
acquisition steps to acquire images of the object under inspection.

Complete the following instructions to configure a Simulate Acquisition
step that simulates acquiring images of spray bottles.

- 1. On the state diagram, click the Check Part Presence state.
Check Part Presence . .
2. In the Inspection Steps palette, select the Acquire Images tab.
] 3. Click the Simulate Acquisition step. The property page for the step
2 opens.
@ Note When the property page for an inspection step opens, if the state diagram is

displayed in the Main window, the state diagram switches from the Main window to the
Overview window to allow you to use the current inspection image to configure the step.

4.

9.

In the Step Name control, enter Acquire Image.
Click the Browse button. The Select an Image File dialog box opens.

Navigate to <Vision Builder AI>\DemoImg\Tutorial 5, where
<Vision Builder AI> is the location where Vision Builder Al is
installed.

Select an image containing the entire spray bottle, such as
Image 00480.jpg, and click Open.

Make sure the Cycle Through Folder Images control is enabled so
that Vision Builder Al loads a different simulation image from the
folder each time the step is run.

Click OK to add the step to the inspection.

Checking for a Spray Bottle in the Image

B

Complete the following instructions to configure a Match Pattern step to
check for the presence of a spray bottle in the image.

1.
2.
3.

In the Inspection Steps palette, select the Locate Features tab.
Click the Match Pattern step. The NI Vision Template Editor opens.

Draw a region of interest (ROI) around the bottom left edge of the
bottle. This region becomes the pattern matching template.

Click Next.
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Click Finish to accept the template.
On the Main tab, enter Locate Bottle in the Step Name control.

Adjust the default green ROI so that it only surrounds the area of the
image that could contain the bottom left edge of a spray bottle,
as shown in Figure 6-7.

Locate Bottle

Figure 6-7. Adjusting the Search Region

On the Settings tab, set the Number of Matches to Find control to 1.

9.  On the Limits tab, enable the Minimum Number of Matches control,
and set the value to 1.

10. Click OK to add the step to the inspection.
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Checking for the Cap Using the Caliper

You can check for the presence of the cap on a spray bottle by using the
Caliper step to find two edges where the cap is supposed to be and
measuring the distance between them. Complete the following instructions
to configure a Caliper step to check for the presence of the spray bottle cap.

N L.

AR e

In the Overview window, click the Inspect Part state on the state
diagram.

In the Inspection Steps palette, select the Measure Features tab.
Click the Caliper step. The property page for the step opens.
In the Step Name control, enter Check Cap Presence.

Draw an ROI around the area in the image where a cap should appear,
as shown in Figure 6-8.

Check, Cap Presence

e

Figure 6-8. Checking for Cap Presence
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6. On the Settings tab, select the Process named Horizontal Max
Caliper to change the direction and orientation of the caliper search
lines.

7. Setthe Gap control to 10, Edge Strength to 40, and Smoothing to 12
to ensure that the step correctly detects the edges of the cap.

8. On the Limits tab, enable the Minimum Distance control, and set the
value to 140.

9. Enable the Maximum Distance control, and set the value to 160.

10. Click OK to add the step to the inspection.

Setting the Inspection Status

Complete the following instructions to add a Set Inspection Status step to
determine whether the inspection passes or fails.

1. In the Inspection Steps palette, click the Use Additional Tools tab.

2. Click the Set Inspection Status step. The property page for the step
opens.

3. Inthe Inspection Status control, select the FAIL if any previous step
fails option.

4. Click OK to add the step to the inspection.

Creating Custom Overlays for Inspection

¢

An

Use the Custom Overlay step to create custom overlays that display
whether the inspection passed or failed.

Complete the following steps to create an overlay to display when the
inspection fails.

1. Inthe Overview window, click the Fail Part state on the state diagram.
2. In the Inspection Steps palette, select the Use Additional Tools tab.

3. Click the Custom Overlay step. The property page for the step opens.
4. In the Step Name control, enter Overlay Results.
5

On the Custom Overlay tab, select the Text tool and click a point in
the image near the bottom of the spray nozzle of the bottle.

o

In the Text Control, enter Missing Cap!.

Click the Text Properties button. The Text Properties dialog box
opens.
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10.

11.
12.

In the Desired Font control, select User-Specified Font.
Specify a Font Name and Size to use for the overlay.

In the Horizontal Alignment control, select Center. This centers the
text around the point you selected using the Text tool.

Click OK to save the Text Properties settings and close the dialog box.
Click OK to add the step to the inspection.

Next, you need to create an overlay to display if the inspection passes.
Complete the following steps to create an overlay to display when the
inspection passes.

- 1.

A

a

10.
. Click the Text Properties button. The Text Properties dialog box

12.
13.
14.
15.
16.

In the Overview window, click the Pass Part state on the state
diagram.

In the Inspection Steps palette, select the Use Additional Tools tab.
Click the Custom Overlay step. The property page for the step opens.
In the Step Name control, enter Overlay Results.

On the Custom Overlay tab, select the Rectangle tool and draw a
rectangle in the upper-left corner of the image.

Click the Stroke control, and select black.
Click the Fill control, and select a bright green color.

On the Custom Overlay tab, select the Text tool, and click a point just
below the center of the rectangle overlay.

In the Text control, enter Part OK.

Click the Text color control, and select black.

appears.
In the Desired Font control, select User-Specified Font.

Specify a Font Name and Size to use for the overlay.

In the Horizontal Alignment control, select Center.

Click OK to save the Text Properties settings and close the dialog box.
Click OK to add the step to the inspection.
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Figure 6-9 shows the overlays for both Pass and Fail images.

PART OK

Figure 6-9. Creating Custom Overlays for Images that Pass and Fail

Configuring State Transitions

Once you have configured all of the states in the inspection and created
transitions between the states, you need to define the conditions that trigger
a transition between inspection states. Complete the following instructions
to define the transitions between inspection states.

£ 7 1. Click the Toggle Main Window View button to display the state
& diagram in the Main window.

2. Double-click the Part Detected transition to launch the Edit
Transition dialog box, which is used to configure the transition.
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3. In the Edit Transition dialog box, modify the controls to transition
when Locate Bottle - # Matches is Equal to 1, as shown in
Figure 6-10.

E' Edit Transition

Transition Mame
Part Detecked

Transition will be activated when the following condition is met

Measurement | Locake Boktle - # Matches ]

i Equal v ko |1.00

kbl

Current Walue: 0

Ok l l Cancel

Figure 6-10. Configuring the Part Detected Transition

4. Click OK to close the Edit Transition dialog box.

5. Double-click the Part OK transition. The Edit Transition dialog box
opens.
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6. In the Edit Transition dialog box, modify the controls to transition
when Check Cap Presence - Step Status is Pass, as shown in

Figure 6-11.

@ Edit Transition

Transition Mame
Part Gk

is (%) Pass
) Fail

Current Yalue:  Fail

Transition will be activated when the following condition is met

Measurement | Check Cap Presence - Step Status

o4 l ’ Cancel

Figure 6-11. Configuring the Part OK Transition

7. Click OK to close the Edit Transition dialog box.

Testing the Inspection

=1
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Test the images in the Tutorial 5 folder to make sure the inspection
returns the correct results. Click the Run Inspection Once button to test
the remaining images. Table 6-1 displays the expected results for each

image.

Table 6-1. Expected Results for the State Diagram Branching Inspection

Image Name

Inspection Status

Explanation

Image 00480.jpg PASS Cap is present.
Image 01710.3pg PASS Cap is present

Image 03450.7jpg FAIL Cap is missing.
Image 04200.3pg PASS Cap is present.

6-13
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Saving the Inspection

Complete the following instructions to save the example inspection.

H 1. Select File»Save or click the Save button on the toolbar.
: 2. Navigate to the location where you want to save the inspection.
3. In the File Name control, enter Tutorial 5.vbai.
4. Click Save to save the inspection.
@ Tip Select File»Inspection Properties to add a short description or comments about the

inspection.
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Looping and Variables

This chapter uses the inspection state diagram to implement a looping
inspection and introduces the Set Variable and Index Measurements
steps. Follow the instructions in this chapter to create an inspection that
inspects images of electronic components to determine if the distance
between pins on the component is within a predetermined range. If the pin
is too close or too far away from an adjacent pin, then the inspection fails.
The inspection does not need to check every pin on the microchip before
failing the inspection. The inspection fails at the first failed pin.

@ Note Launch Vision Builder Al if it is not open. Refer to the Vision Builder Al

Configuration Interface section of Chapter 1, Introduction to Vision Builder Al,
for more information.

Creating a New Inspection

Select File»New to load a new, blank Vision Builder Al inspection.

Creating the Inspection State Diagram

Complete the following instructions to create a state diagram to define the

inspection.
g 1. Click the Toggle Main Window View button on the toolbar to bring
] the inspection state diagram to the Main window.

2. Double-click the Inspect state to launch the Edit State Name dialog
box.

3. Inthe State Name control, enter Acquire Image & Find Pin
Edges.
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4. Right-click an open area on the state diagram and select Create New
State to add a new state to the inspection, as shown in Figure 7-1. The
Edit State Name dialog box opens.

Skark

default

Acguire Image & Find Pin Edges

Create Mew State
defsult Create Mew End Paint

End

Impork Inspection

Figure 7-1. Creating a New Inspection State

In the State Name control, enter Check Pin Gap.

6. Create two more states named Fail Inspection and Pass
Inspection. The state diagram should now resemble the state
diagram shown in Figure 7-2.

Start

defaulk

Acquire Image & Find Fin Edges

default

End

@ default

il Inspectiofy 1 default P@ default

Figure 7-2. Adding New States to the Inspection
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Next, you will define transitions between the various inspection states.
Notice that every state has a default transition. You can also create
additional transitions between states based on measurement results or
variable values.

@ Note The default transition occurs if the transition requirements for other possible
transitions are not met.

7. Click the Acquire Image & Find Pin Edges default transition and drag
it to the Check Pin Gap state.

Click the End point and drag it to the bottom of the state diagram.

Click the Check Pin Gap state default transition and drag it to the Pass
Inspection state.

10. Click the Fail Inspection default transition and drag it to the End point.
11. Click the Pass Inspection default transition and drag it to the End
point.

The state diagram should now resemble the state diagram shown in
Figure 7-3.

Start

defaulk

acquire Image & Find Pin Edges

default default

End

Figure 7-3. Configuring the Default Transitions

12. Right-click the Acquire Image & Find Pin Edges state and select
Create New Transition.
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13. Click the Fail Inspection state to create a transition between the
Acquire Image & Find Pin Edges state and the Fail Inspection state,
as shown in Figure 7-4.

Acquire IMage & Find Fin Edges

default

Figure 7-4. Creating a New Transition

You can change the shape of the transition by dragging the anchor
point at the center of the transition. You can move the location of the
transition label by clicking the label and dragging it to the new
location.

@ Tip When drawing a transition, click once on the state diagram to set the anchor point for
the transition. The anchor point allows you to draw an arc instead of a straight line to
represent the transition.

14. Double-click the transition to launch the Edit Transition dialog box.
15. In the Transition Name control, enter Wwrong # Pins, and click OK.

16. Create a transition from the Check Pin Gap state that loops back to the
Check Pin Gap state named Repeat for Next Pin.

17. Create a transition named Failed between the Check Pin Gap and
Fail Inspection states.
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The state diagram should now resemble the state diagram shown in
Figure 7-5.

Wrong # Pins

Acquire Iage & Find Fin Edges

default

Jheck Pin Gap

Skark

default

Repeat for Mext Pin

Figure 7-5. Completed State Diagram for the Inspection

Creating a Variable

Since the same inspection needs to be performed on each set of pins,
creating a loop in the inspection eliminates the need to configure separate
steps to inspect each set of pins. Use the Variable Manager to configure a
variable to keep track of the number of times the loop executes.

1.
2.

Select Tools»Variable Manager to launch the Variable Manager.

On the Inspection Variables tab of the Variable Manager, click Add to

© National Instruments Corporation 7-5

launch the Add Inspection Variable dialog box.
In the Name control, enter Counter.

In the Type control, select Numeric.

In the Initial Value control, enter 1.

Click OK to create the variable.

Click OK to close the Variable Manager.

N o kW
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Acquiring Inspection Images

For simplicity, this tutorial instructs you to use the Simulate Acquisition
step. However, in your real-world inspection, use one of the other image
acquisition steps to acquire images of the object under inspection.

Complete the following instructions to configure a Simulate Acquisition
step that simulates acquiring images of the pins on electronic components.

N 1.
licquire Image & Find Pin Edges

d
e

On the state diagram, select the Acquire Image & Find Pin Edges
state.

In the Inspection Steps palette, select the Acquire Images tab.

Click the Simulate Acquisition step. The property page for the step
opens.

@ Note When the property page for an inspection step opens, if the state diagram is
displayed in the Main window, the state diagram switches from the Main window to the
Overview window to allow you to use the current inspection image to configure the step.

4.

In the Step Name control, enter Acquire Pins.
Click the Browse button. The Select an Image File dialog box opens.

Navigate to <vVision Builder AI>\DemoImg\Tutorial 6, where
<Vision Builder AI> is the location where Vision Builder Al is
installed.

Select image 01.jpg, and click Open.

Make sure the Cycle Through Folder Images control is enabled so
that Vision Builder Al loads a different simulation image from the
folder each time the step is run.

Click OK to add the step to the inspection.

Finding Pin Edges

Complete the following instructions to configure a Find Edges step to find
the edges of the pins and determine if the microchip has the correct number

of pins.

1. In the Inspection Steps palette, select the Locate Features tab.

2. Click the Find Edges step. The property page for the step opens.
@.} 3. Inthe Step Name control, enter Find Pin Edges.
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Hold down the <Shift> key and draw a line from left to right across the
width of the image where the pins are located, as shown in Figure 7-6.

Figure 7-6. Locating the Edges of the Pins of a Microchip

In the Look for control, select All Edges.
In the Edge Polarity control, select Bright to Dark Only.

On the Limits tab, enable the Minimum Number of Edges control
and set the value to 7.

Enable the Maximum Number of Edges control and set the value
to 7.

Click OK to add the step to the inspection.

Initializing the Variable

Use the Set Variable step to set the value of user-defined variables.
Complete the following instructions to configure a Set Variable step to
initialize the Counter variable.

1.

e 2.

© National Instruments Corporation

In the Inspection Steps palette, select the Use Additional Tools tab.

Click the Set Variable step. The property page for the step opens in
the Main window.

In the Step Name control, enter Tnitialize Counter.
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4. In the Operation control, select the Set to Constant option and enter
1 for the value.

5. Click OK to add the step to the inspection.

Indexing Measurements

Complete the following instructions to configure an Index Measurements
step to select the x and y position of the ith edge found by the Find Pin
Edges step in the Acquire Image & Find Pin Edges state, where i is the
value of the Counter variable.

N 1. Inthe Overview window, click the Check Pin Gap state on the state
ICheck Pin Gap diagram.

2. In the Inspection Steps palette, select the Use Additional Tools tab.

0 3. Click the Index Measurements step. The property page for the step
opens.

4. In the Step Name control, enter Get Edge Position.

In the Measurements control, select Edge [i].X Position and
Edge [i].Y Position.

6. In the Index control, select Inspection Variable - Counter from the
drop-down listbox.

7. Click OK to add the step to the inspection.
In the Updating the Variable section of this tutorial, you will set the
Counter variable to increment by one each time the Check Pin Gap state is

run. This ensures that a different set of pins is inspected each time the Index
Measurements step is run.

Setting a Coordinate System

Complete the following instructions to configure a Set Coordinate System
step based on the Find Pin Edges step you configured.

1. In the Inspection Steps palette, select the Locate Features tab.

2. Click the Set Coordinate System step. The property page for the step
l—‘ opens.
4-4_’ 3. On the Settings tab, in the Mode control, select Horizontal Motion
1 because the pins may shift horizontally from one image to another.

4. Click OK to add the step to the inspection.
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Checking the Pin Gap

Complete the following instructions to measure the gap between two pins
and determine if it is within a certain range.

1.

L I

In the Inspection Steps palette, select the Measure Features tab.
Click the Caliper step. The property page for the step opens.
In the Step Name control, enter Measure Gap.

Enable the Reposition Region of Interest control and verify that Set
Coordinate System is selected for the Reference Coordinate System
control.

Draw an ROI over the gap between the first two pins, as shown in
Figure 7-7.

© National Instruments Corporation

Figure 7-7. Measuring the Distance Between Pins

In the Settings tab, select the Process named Horizontal Max
Caliper to change the direction and orientation of the caliper search
lines.

On the Limits tab, enable the Minimum Distance control and set the
value to 30.00. Enable the Maximum Distance control and set the
value to 46.00.

Click OK to add the step to the inspection.
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Updating the Variable

After you have measured the gap between two pins, you must increment the
Counter variable so that the next time the state is executed the next set of
pins is inspected. Complete the following instructions to use a Set Variable
step to increment the value of the Counter variable.

1.
2.

In the Inspection Steps palette, select the Use Additional Tools tab.

Click the Set Variable step. The property page for the step opens in
the Main window.

In the Step Name control, enter Update Counter.
In the Operation control, select the Increment option.

Click OK to add the step to the inspection.

Identifying Failed Pins

¢

o]

Complete the following instructions to create an overlay to identify a failed
pin using the Custom Overlay step.

1.

Cal

9.

In the Inspection Steps palette, select the Use Additional Tools tab.
Click the Custom Overlay step. The property page for the step opens.
In the Step Name control, enter Overlay Failed Gap.

On the Custom Overlay tab, select the Indicator tool and draw a
small indicator on the image.

In the Top Left Point control, select Get Edge Position - Edge [i].
This aligns the top left point of the indicator overlay with the ith edge
found by the Get Edge Position step.

In the X Offset control, enter 35. In the Y Offset control, enter 28.
This positions the indicator overlay over the gap between two pins.

In the Value control, select Measure Gap - Step Status to set the
indicator overlay to display the Step Status for the Measure Gap step
in the inspection.

Delete the text in the True Text control since the overlay is only
displayed if the inspection fails. Set the Fill to transparent.

In the False Text control, enter FAIL. Set the Fill to red.

10. Click OK to add the step to the inspection.
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Setting the Inspection Status

N

Fail Inspection

Pass Inspection

Complete the following instructions to set the Inspection Status for the
inspection.

1.

et

® =N n ok

10.

11.
12.
13.
14.

In the Overview Window, click the Fail Inspection state on the state
diagram.

In the Inspection Steps palette, select the Use Additional Tools tab.

Click the Set Inspection Status step. The property page for the step
opens.

In the Step Name control, enter Set Inspection Status.
In the Inspection Status control, select the FAIL option.
Enable the Update Number of Parts Inspected checkbox.
Click OK to add the step to the inspection.

In the Overview Window, click the Pass Inspection state on the state
diagram.

In the Inspection Steps palette, select the Use Additional Tools tab.

Click the Set Inspection Status step. The property page for the step
opens.

In the Step Name control, enter Set Inspection Status.
In the Inspection Status control, select the PASS option.
Enable the Update Number of Parts Inspected checkbox.
Click OK to add the step to the inspection.

Displaying the Current Inspection Image

N

Fail Inspection

=

Complete the following instructions to use a Display Image step to display
the current inspection image.

1.

AU
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In the Overview Window, click the Fail Inspection state on the state
diagram.

In the Inspection Steps palette, select the Use Additional Tools tab.
Click the Display Image step. The property page for the step opens.
In the Step Name control, enter Display Image.

In the Display Images control, select the Always option.

Click OK to add the step to the inspection.
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N

Pass Inspection

7. In the Overview window, click the Pass Inspection state on the state
diagram.

In the Inspection Steps palette, select the Use Additional Tools tab.
9. Click the Display Image step. The property page for the step opens.
10. In the Step Name control, enter Display Image.
11. In the Display Images control, select the Always option.
12. Click OK to add the step to the inspection.

Configuring State Transitions

After you have created the state diagram and configured all of the steps in
the inspection, you must specify when you want transitions from one state
to another state to occur. Complete the following sets of instructions to
configure the transitions for the inspection.

If an image has an incorrect number of pins, the inspection should
transition to the Fail Inspection state. Complete the following instructions
to define the Wrong # Pins transition.

1. Click the Toggle Main Window View button on the toolbar to bring
the inspection state diagram to the Main window.

2. Double-click the Wrong # Pins transition on the state diagram to
launch the Edit Transition dialog box.

3. In the Edit Transition dialog box, modify the controls to transition
when Find Pin Edges - Step Status is Fail.

4. Click OK to close the dialog box.

Since the same inspection needs to be performed on each set of pins on the
electronic component, the Repeat for Next Pin transition creates a loop in
the inspection that eliminates the need to configure separate steps to inspect
each set of pins. Complete the following instructions to configure the
Repeat for Next Pin transition.

1. Double-click the Repeat for Next Pin transition.

2. In the Edit Transition dialog box, modify the controls to transition
when Get Edge Position - Remaining Objects is Greater than 1.

3. Click OK to close the dialog box.
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The final transition that must be defined for the inspection is the transition
between the Check Pin Gap and Fail Inspection states that occurs when the
pins on the component fail inspection. Complete the following instructions
to configure the Failed transition.

1. Double-click the Failed transition.

2. In the Edit Transition dialog box, modify the controls to transition
when Measure Gap - Step Status is Fail.

3. Click OK to close the dialog box.

Testing the Inspection

Test the images in the Tutorial 6 folder to make sure the inspection

returns the correct results. Click the Run Inspection Once button to test

=1 the remaining images. Table 7-1 displays the expected results for each
image.

Table 7-1. Expected Results for the State Diagram Looping Inspection

Image Name Inspection Status Explanation

Image 01.jpg PASS All pins are present and
straight.

Image 02.3jpg PASS All pins are present and
straight.

Image 03.3jpg PASS All pins are present and
straight.

Image 04.7jpg FAIL Third pin is bent.

Image 05.jpg PASS All pins are present and
straight.

Image 06.3pg FAIL Fifth pin is bent.

Image 07.3Jpg PASS All pins are present and
straight.

Image 08.3jpg FAIL Seventh pin is bent.

© National Instruments Corporation 7-13 NI Vision Builder for Automated Inspection Tutorial



Chapter 7 Looping and Variables

Saving the Inspection

Complete the following instructions to save the example inspection.

H 1. Select File»Save or click the Save button on the toolbar.
i 2. Navigate to the location where you want to save the inspection.
3. In the File Name control, enter Tutorial 6.vbai.
4. Click Save to save the inspection.
@ Tip Select File»Inspection Properties to add a short description or comments about the

inspection.
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Part I

Using Vision Builder Al
with Remote Targets

This section provides lessons about using Vision Builder AI with NI Vision
remote targets, such as NI 17xx Smart Cameras or NI CVS-1450 Series
Compact Vision Systems.

NI Smart Cameras combine an image sensor and a high-performance
processor to return inspection results instead of images. While a typical
industrial camera acquires and transmits images through a standard camera
bus for processing on another device, the smart camera performs both
acquisition and processing operations directly on the smart camera.

NICVS-1450 Series devices are easy-to-use, distributed, real-time imaging
systems that acquire, process, and display images from external IEEE 1394
cameras conforming to the IIDC 1394-based Digital Camera Specification,
Version 1.30.

An Ethernet connection between the remote target and a development
computer allows you to display measurement results and status information
and to configure the remote target settings. When configured, the remote
target can run applications without a connection to the development
computer.
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Part I1, Using Vision Builder AI with Remote Targets, contains the
following chapters:

Chapter 8, Acquiring an Image with the NI 17xx Smart Camera,
introduces using Vision Builder AI with the NI Smart Camera to
perform a basic image acquisition.

Chapter 9, Acquiring an Image with the NI CVS-1450 Compact Vision
System, introduces using Vision Builder Al with the NI CVS-1450
Series Compact Vision System to perform a basic image acquisition.

Chapter 10, Performing a Triggered Acquisition Using the

NI CVS-1450 Compact Vision System, introduces using Vision Builder
Al and the NI CVS-1450 Series Compact Vision System to perform a
triggered image acquisition.

Chapter 11, Inspection Selection, introduces using Vision Builder Al
running on a remote target to switch between multiple inspections
based on an I/O result.
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Acquiring an Image with the
NI 17xx Smart Camera

This chapter introduces using Vision Builder AI with the NI 17xx Smart
Camera to perform a basic image acquisition. Follow the instructions in this
chapter to learn how to connect and configure the smart camera to acquire
an image using Vision Builder AL

Refer to the NI 17xx Smart Camera User Manual for additional
information about specific features and specifications of the smart camera.
Select Start»All Programs»National Instruments» Vision»
Documentation»NI-IMAQ to access the NI 17xx Smart Camera User
Manual after configuring the smart camera using the procedures described
in this chapter.

Hardware

The following hardware is necessary to complete this lesson.
U NI 17xx Smart Camera

U 5-position lighting connector (additional/replacement plugs for use
with the lighting connector are available from NI, part number
780260-01)

U One or two CAT 5 10/100Base-TX or CAT 5e or CAT 6 1000Base-T
Ethernet cables. One Ethernet cable is required to connect the smart
camera directly to the development computer. Two Ethernet cables are
required to connect the smart camera to the development computer
through a network.

@ Note A CAT 5e or CAT 6 1000Base-T Ethernet cable is required to achieve maximum
1,000 Mbps (Gigabit) Ethernet performance. CAT Se and CAT 6 Ethernet cables adhere to
higher electrical standards required for Gigabit Ethernet communication. CAT 5 cables are
not guaranteed to meet the necessary electrical requirements. While CAT 5 cables may
appear to work in some installations at 1,000 Mbps, CAT 5 cables are likely to cause
increased bit errors resulting in degraded or unreliable network performance.
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L One of the following power supply options:

A Caution Use the smart camera only with a 24 VDC, UL listed, limited power source (LPS)
supply. The power supply will bear the UL listed mark, LPS. The power supply must also
meet any safety and compliance requirements for the country of use.

— NI desktop power supply (part number 780237-01) and power
supply cord. Refer to ni . com for the power supply cord part
number specific to your region and ordering information.

— Any 24 VDC, +20%/-15% (IEC 1311) power supply and one of
the following cable options for connecting to the power supply
and I/0.

*  15-pin D-SUB pigtail cable, 5 m (part number 197818-05)

e 15-pin D-SUB to 15-pin D-SUB cable, 2 m (part number
197817-02) or 5 m (part number 197817-05), and a 15-pin
D-SUB terminal block

U Standard C-mount lens
U Development computer running Windows Vista/XP/2000

To complete the Triggered Acquisitions section of this lesson the following
additional hardware is necessary.

U Trigger source such as a proximity sensor or other device to generate
a trigger signal.

Connecting the Lens and Lighting

Complete the following steps to connect a standard C-mount lens and
external lighting accessories to the NI Smart Camera.

1. Remove the lens cover from the smart camera.

2. Gently align the threads on the base of the lens with the threads on the
sensor opening, and twist clockwise until the lens is secure.

The lens is now attached to the smart camera.

Lighting

The NI Smart Camera offers two options for controlling a light—a Direct
Drive internal lighting controller, or 5 V TTL or 24 V external strobe
generation for use with a third-party lighting controller. Refer to the

NI 17xx Smart Camera User Manual for information about using the smart
camera with a light.
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@ Note The Direct Drive lighting controller is not available on NI 1722 smart cameras.
NI 1722 smart cameras support only 5 V TTL or 24 V external strobe generation.

Connect the Power Supply and 1/0

To connect a power supply to the NI Smart Camera, complete the steps
listed in one of the following sections. Refer to the Power Only section to
connect the NI desktop power supply directly to the smart camera with no
additional I/O. Refer to the Power with Additional I/0 section to connect a
third-party power supply or if your application requires I/O, such as a
trigger signal.

A Caution Use the smart camera only with a 24 VDC, UL listed, limited power source (LPS)
supply. The power supply will bear the UL listed mark, LPS. The power supply must also
meet any safety and compliance requirements for the country of use.

Power Only

Refer to Figure 1 while completing the following steps to connect the NI
desktop power supply to the NI Smart Camera with no additional I/O.

1 NI Smart Camera 2 Power Supply

Figure 8-1. Connecting the NI Smart Camera to the NI Desktop Power Supply

1. Connect and secure the 15-pin D-SUB connector on the NI desktop
power supply to the POWER-I/O connector on the smart camera.

Plug the power supply power cord into the power supply.
3. Plug the power supply into an outlet.
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When power is first applied to the smart camera, the POWER LED flashes
red for one second while internal systems power up. The POWER LED
then lights green when power is correctly wired to the smart camera.

Power with Additional 1/0

National Instruments provides the following two cable options for
connecting a third-party power supply and I/O to the NI Smart Camera.

e Terminal block with a 15-pin D-SUB connector, such as the NI Smart
Camera I/O Accessory, and a 15-pin D-SUB to 15-pin D-SUB cable

* 15-pin D-SUB pigtail cable
Refer to Figure 2 while completing the following steps to connect a

third-party power supply and I/O to the smart camera using either a
terminal block or the pigtail cable.

1 NI Smart Camera 3 Optional Terminal Block
2 15-Pin D-SUB to 15-Pin D-SUB Cable 4 Power Supply

Figure 8-2. Connecting the NI Smart Camera to a Third-Party Power Supply
1. Connect and secure the 15-pin D-SUB connector on your cable to the
POWER-1/O connector on the smart camera.

2. If you are using a terminal block, connect the cable to the terminal
block.

3. Connect the +24 V signal from the cable or terminal block to the
corresponding signal on the power supply.
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Table 3 shows the pin locations for the POWER-I/O connector and
lists the signal names and pin numbers. The table also lists wire colors
for the National Instruments 15-pin D-SUB pigtail cable. Cables from
another vendor may have different wire colors.

Table 8-1. NI Smart Camera POWER-1/0 Connector Signal Descriptions

Connector Diagram Signal Name Pin Number Wire Color
+24V 5 Red
COM 15 Black
RS_232TXD 10 Pink
RS_232RXD 14 Black/White
Trigln+ 2 Brown
Isoln(0)+
Isoln(1)+ 8 Orange
» 15 (COM) I;{giig}_ 12 Light Green
6 ©©©©©©©© 10 IsoIn(1)-
(Llecooa]
1 ——"5 (+24V) Is0Out(0)+ 6 Yellow
IsoOut(0)— 1 Green
IsoOut(1)+ 11 Light Blue
IsoOut(1)— 7 Gray
PhaseA+ 3 Blue
PhaseA— 13 Brown/White
PhaseB+ 9 Purple
PhaseB— 4 White
4. Connect the COM signal from the cable or terminal block to the
corresponding signal on the power supply.
5. Connect any additional I/O signals necessary for your application to
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the appropriate signal on the cable or terminal block. Refer to Table 3

for pin information.

If necessary, connect the power cord to the power supply.

Plug the power supply into an outlet.

8-5
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When power is first applied to the smart camera, the POWER LED flashes
red for one second while internal systems power up. The POWER LED
then lights green when power is correctly wired to the smart camera.

Connecting to the Development Computer

The NI Smart Camera can connect to the development computer directly or
through a network using an Ethernet cable. The smart camera provides
automatic MDI/MDI-X correction, so you can use either a standard
Ethernet cable or a crossover Ethernet cable to connect to the development
computer. If the development computer is configured on a network, you
must configure the smart camera on the same network subnet as the
development computer to connect through the network.

A Caution To prevent data loss and to maintain the integrity of your Ethernet installation,
do not use a cable longer than 100 m. National Instruments recommends using a shielded
twisted pair Ethernet cable for maximum signal integrity.

Firewall Configuration

If your firewall is controlled remotely or you are unsure about configuring
the firewall, contact your network administrator. Refer to Appendix B,
Troubleshooting, of the NI 17xx Smart Camera User Manual to
troubleshoot network configuration issues.
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Direct Connection

To connect the NI Smart Camera directly to the development computer,
refer to Figure 8-3 and complete the following steps.

1 Connecting an Ethernet Cable to Port 1 on the NI Smart Camera
2 Connecting an Ethernet Cable to an Ethernet Port on the Development Computer

Figure 8-3. Connecting the NI Smart Camera Directly to the Development Computer

1. Use an Ethernet cable to connect from the Ethernet port on the
development computer to Ethernet port 1 on the smart camera.

2. Configure the network card on the development computer to use a
static IP address. Refer to your network card documentation for
information about configuring a static IP address.

The smart camera is now connected directly to the development computer.
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Network Connection

To connect the NI Smart Camera to the development computer through a
network, refer to Figure 8-4 and complete the following steps.

1 Connecting an Ethernet Cable to Port 1 on the NI Smart Camera
2 Ethernet Hub or Other Network Port
3 Connecting an Ethernet Cable to an Ethernet Port on the Development Computer

Figure 8-4. Connecting the NI Smart Camera Through a Network

1. Verify that the development computer is connected to the network and
powered on.

2. Using an Ethernet cable, connect from an Ethernet hub or other
network port to Ethernet port 1 on the smart camera.

3. Using another Ethernet cable, connect from the Ethernet hub or other
network port to the Ethernet port on the development computer.

The smart camera is now connected to the development computer through
a network.
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Subnet Considerations

To configure the NI Smart Camera, it must reside on the same subnet as the
development computer. Once the smart camera is configured, other subnets
can be used to access it.

To use the smart camera on a subnet other than the one on which the
development computer resides, first connect and configure the smart
camera on the same subnet as the development computer. Next, physically
move the smart camera to the other subnet. Contact your network
administrator for assistance in setting up the development computer and
smart camera on the same subnet.

Configuring the IP Address

Complete the following steps to configure an IP address for the NI Smart
Camera.

1. Launch Vision Builder Al

2. Onthe Vision Builder Al startup screen, expand the Execution Target
listbox, and click Select Network Target.
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% NI ¥ision Builder Al - Welcome M=

ni.com/vision

Configure Inspection

Vision Builder

for Automated Inspection

Help

Exit:

Inspect Product ]

Execution Target | This Computer [v]

DS_

Select Metwark Targe, ..

J/ This Computer

Smark Camera Emulator
Carmpact Yision Sysken Emulator
Embedded Vision System Emulatar

Figure 8-5. Vision Builder Al Welcome Screen

3. Inthe Select Remote Target dialog box, select the smart camera with a
MAC address that corresponds to the MAC address on the label of the
smart camera you want to configure.

Refer to the Subnet Considerations section of this document and
Appendix B, Troubleshooting, of the NI 17xx Smart Camera User
Manual for information about subnets and troubleshooting smart
camera configuration issues.

4. Click Configure. The Remote Target Configuration Wizard launches
in a new window.

5. Inthe Name field, enter a name for the smart camera. Use the
Description field to enter any additional information or a brief
description of the smart camera.

Device names are limited to 31 characters with no spaces or special
characters, except hyphens. The first and last characters must be
alphanumeric.

6. Click Next.
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If the network is configured to issue IP addresses using DHCP, select
Obtain IP address from DHCP server. Otherwise, configure the

IP address manually by selecting Edit the IP settings and clicking
Suggest Values.

If you want to prevent other users from configuring the smart camera,
select Enable Password and click Set Password to set up password
protection for the smart camera.

Click Next.

Installing Software on the NI Smart Camera

Complete the following steps to install software from the development
computer to the NI Smart Camera.

1.

In the Remote Target Configuration Wizard, enable the Update
Target Software checkbox.

Click the Browse button next to the Software Image to Install on the
Target control.

Navigate to the Vision Builder Al software image you want to use, and
click OK. Software images provided by National Instruments are
installed to the <vision Builder AI>\RT Images directory, where
<Vision Builder AI> is the location where Vision Builder Al is
installed.

Click OK to apply the IP configuration settings and download
software to the smart camera.

Click OK to close the Remote Target Configuration Successful dialog
box.

Acquiring an Image

Complete the following steps to acquire an image using Vision Builder Al

1.
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In the Select Remote Target dialog box, select your configured
NI Smart Camera, and click OK.

On the Vision Builder AI Welcome screen, click Configure
Inspection.

In the Inspection Steps palette, select the Acquire Images tab.

Click the Acquire Image (Smart Camera) step. The property page
for the step opens.
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7.

Click the Acquire Single Image button to acquire a single image, or
click the Acquire Continuous Images button to acquire continuous
images.

Use the controls on the Main, Trigger, Lighting, and Advanced tabs
to configure any additional settings necessary for your application.

Click OK to add the step to the inspection.

The smart camera is now configured and acquiring images. Use Vision
Builder Al to add and configure additional inspection steps to create your
application.

Saving the Inspection

Complete the following instructions to save the inspection.

H 1.

Select File»Save or click the Save button on the toolbar.

2. In the Inspection Name control, enter a name for the inspection.
3. Click Save to save the inspection.
@ Tip Select File»Inspection Properties to add a short description or comments about the

inspection.

Triggered Acquisitions

To configure the NI Smart Camera for a triggered acquisition, complete the
steps listed in the following sections.

Connecting the Trigger Signal

Complete the following steps to connect a trigger signal to the NI Smart

Camera.
1. Close Vision Builder Al.
2. Disconnect the 15-pin D-SUB connector from the POWER-1/O

connector on the smart camera.

Connect the TrigIln(0)+ and TrigIn(0)- signals from the POWER-1/O
connector on the smart camera to the trigger output signal you want to
use on the trigger source. Refer to Table 8-1 for pinout information and
signal descriptions for the POWER-I/O connector. Refer to the

NI 17xx Smart Camera User Manual for specific information about
connecting to an the isolated input trigger signal on the smart camera.
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Connect the COM signal from the POWER-I/O connector on the smart
camera to the common or ground signal on the trigger source.

Connect the 15-pin D-SUB connector from your cable to the
POWER-I/O connector on the smart camera.

Configuring the Acquisition

Complete the following steps to configure an Acquire Image (Smart
Camera) step for a triggered acquisition.

1.
2.

10.

11.

12.
13.

14.
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Launch Vision Builder Al

In the Select Remote Target dialog box, select your configured
NI Smart Camera, and click OK.

On the Vision Builder AT Welcome screen, click Configure
Inspection.

In the Inspection Steps palette, select the Acquire Images tab.

Click the Acquire Image (Smart Camera) step. The property page
for the step opens.

In the Step Name control, enter Acquire Image.
On the Trigger tab, enable the Triggered Acquisition checkbox.

In the Trigger Polarity control, specify whether to begin the
acquisition on the rising or falling edge of the trigger signal.

In the Exposure Delay and Delay Units controls, specify the amount
of time the smart camera waits after a trigger signal is received before
it acquires an image.

In the Trigger Timeout control, specify the amount of time the smart
camera waits to receive a trigger before the acquisition times out.

Use the controls on the Main, Trigger, Lighting and Advanced tabs to
configure any additional settings necessary for your application.

Click OK to add the step to the inspection.

Add and configure additional inspection steps to complete your
application.

Save the inspection.
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Acquiring images

Complete the following steps to test your trigger configuration and acquire
images.

1. Select File»Switch to Inspection Interface to launch the Inspection
Interface.

2. Click the Start Inspection button to run the inspection.

3. Click the Stop Inspection button to stop the inspection.

If the triggered acquisition is configured correctly, an image is acquired
only when the NI Smart Camera receives a trigger signal. If the smart
camera does not receive a trigger signal before the specified trigger
Timeout elapses, the smart camera returns a timeout error.

Preventing an Acquisition Timeout

While testing the acquisition, you may have noticed that sometimes the
Acquire Image (Smart Camera) step status changes from Pass to Fail.
This behavior occurs when the acquisition step does not receive a trigger
within the Timeout period specified on the property page of the acquisition
step. If a timeout occurs, any processing steps in the inspection that occur
after the acquisition step will also fail because there is no image available
to process.

Ideally you would set the acquisition step Timeout to an infinite value to
ensure that a timeout never occurs. However, since Vision Builder Al
allows only finite values for the timeout period, you must use another
method to achieve the desired behavior. Instead of setting an infinite
timeout, you can use the inspection state diagram to configure Vision
Builder Al to only run the image processing steps in an inspection when an
image has been acquired.

Creating the Inspection State Diagram

Complete the following instructions to implement the behavior of an
infinite timeout in Vision Builder Al

1. Select File»Switch to Configuration Interface to switch to the Vision
Builder AI Configuration Interface.

2. Click the Toggle Main Window View button on the toolbar to bring
the inspection state diagram to the Main window.

NI Vision Builder for Automated Inspection Tutorial 8-14 ni.com



Chapter 8 Acquiring an Image with the NI 17xx Smart Camera

Right-click an open area on the state diagram and select Create New
State to add a new state to the inspection, as shown in Figure 8-6. The
Edit State Name dialog box opens.

Skark
default
I/F\;quire %Create Mew State
Create New End Point
default
Import Inspection
End

4.

Figure 8-6. Creating a New Inspection State

In the State Name control, enter Inspect.

Next, you will define transitions between the inspection states. Notice that
every state has a default transition. You can also create additional
transitions between states based on measurement results or variable values.

@ Note The default transition occurs when the transition requirements for other possible
transitions are not met.

5.

Click the Acquire state default transition and drag it so that the
transition loops back to the Acquire state.

6. Click the Inspect state default transition and drag it to the End point.
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The state diagram should now resemble the state diagram shown in
Figure 8-7.

Skark

default

@ default

Gﬂ_spect

default

End

Figure 8-7. Configuring the Default Transitions

7. Right-click the Acquire state and select Create New Transition.

8. Click the Inspect state to create a transition between the Acquire state
and the Inspect state.

9. Double-click the transition to launch the Edit Transition dialog box.
10. In the Transition Name control, enter Image Acquired.

11. In the Measurement control, configure the transition to occur when
Acquire Image - Timeout is False.

12. Click OK to close the dialog box.
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The state diagram should now resemble the state diagram shown in
Figure 8-8.

Skark

default

/A;quire

Image Acquired

/In—spect

default

default

End

Figure 8-8. Completed State Diagram for the Inspection

13. Add and configure additional steps in the Inspect state to complete
your application.

14. Save the Inspection.

15. Switch to the Inspection Interface and run the inspection.

When you run the inspection, notice that when a timeout occurs, the
inspection simply loops back to the Acquire state and resumes waiting for
a trigger. A timeout no longer affects the rest of the steps in the inspection.

@ Tip Set the Acquire Image (Smart Camera) step Acquisition Mode to Immediate to
prevent the inspection from missing triggers that may occur when the inspection transitions
between states.
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Acquiring an Image with the
NI CVS-1450 Compact Vision

System

This chapter introduces using Vision Builder AI with an NI CVS-1450
Series Compact Vision System to perform a basic image acquisition.

Follow the instructions in this chapter to learn how to connect and
configure an NI CVS-1450 device to acquire an image using Vision
Builder AL

Hardware

The following hardware is necessary to complete this lesson.

Q

Q
Q
Q

© National Instruments Corporation

NI CVS-1450 Series Compact Vision System
Development computer running Windows Vista/XP/2000
DCAM-compliant IEEE 1394 camera

IEEE 1394 jackscrew-to-latch cable (part number 778796-01) or any
standard IEEE 1394 cable. You can use a 4-pin to 6-pin converter cable
with cameras that have their own external power supply and do not
require power from the IEEE 1394 bus

NI desktop power supply (part number 778794-01) or any
24 VDC +£10%, 50 W power supply

—  Power supply cord—Connects the NI desktop power supply to an
outlet. Refer toni . com for the part number specific to your region
and ordering information

—  4-position power connector—Required if you do not use the
NI desktop power supply

Two 10 m standard CAT 5 10/100Base-T Ethernet cables
(part number 189174-10)

9-1 NI Vision Builder for Automated Inspection Tutorial



Chapter 9 Acquiring an Image with the NI CVS-1450 Compact Vision System

Connecting a Camera and Monitor

Before connecting a camera and monitor to the NI CVS-1450 device, make
sure that all NI CVS-1450 device DIP switches are in the OFF position.

To connect an IEEE 1394 camera and a monitor to the NI CVS-1450
device, refer to Figure 9-1 while completing the following steps:

1. Connect the VGA cable from the monitor to the VGA port on the
NI CVS-1450 device.

2. Plug the IEEE 1394 cable into one of the IEEE 1394a ports on the
NI CVS-1450 device. Plug the other end of the cable into the
IEEE 1394 port on the camera.

If your camera requires an external power supply, connect it to the
camera, and verify that the camera is powered on.

@ Note To maintain signal integrity, the IEEE 1394 cable length must be no longer
than 4.5 m.

3. Plug in and power on the monitor.

1 VGA Cable 2 |EEE 1394 Cable

Figure 9-1. Basic Hardware Setup
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Connecting a Power Supply

This section describes how to connect the NI desktop power supply.
For instructions on how to connect a separate main supply, refer to the
Connecting to a Third-Party Power Supply section.

Caution Do not connect the NI CVS-1450 device main power to a source other than
24 VDC +10%. Do not connect the NI CVS-1450 device isolated power to a source less
than 5 VDC or greater than 30 VDC. Doing so could damage the NI CVS-1450 device.

To connect power to the NI CVS-1450 device, refer to Figure 9-2 while

completing the following steps:

1. Plug the 4-position connector from the power supply into the power
receptacle on the NI CVS-1450 device.

2. Plug the power cord into the power supply.

3. Plug the power cord into an outlet.

The NI CVS-1450 device ships with a factory-installed startup program
that, when the NI CVS-1450 device is connected to a camera and powered
on, acquires images and displays them on the monitor.

If the images from the camera display on the monitor, continue to the
Connecting to a Network section. If the images from the camera are not
displayed on the monitor, refer to the NI CVS-1450 Series User Manual for
troubleshooting information.

To Outlet

1 4-Position Power Connector 2 NI Desktop Power Supply 3 Power Supply Cord (to Outlet)

Figure 9-2. Wiring Power to the NI CVS-1450 Device
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Connecting to a Third-Party Power Supply

If you use a power supply other than the NI desktop power supply, follow
the instructions in this section to connect power to the NI CVS-1450
device.

@ Note If you are not using the NI desktop power supply, use 0.75 mm?, 18 AWG ferrules
according to manufacturer specifications to terminate the wires leading to the 4-position
power connector, as shown in Figure 9-3. Ferrules are available from Phoenix Contact
(part number 3200519).

OAC

|1 4-Position Power Connector 2 Ferrule 3 Power Supply Wires

Figure 9-3. Wiring a Third-Party Power Supply to the 4-Position Power Connector

Caution Do not connect the NI CVS-1450 device main power to a source other than
24 VDC +10%. Do not connect the NI CVS-1450 device isolated power to a source less
than 5 VDC or greater than 30 VDC. Doing so could damage the NI CVS-1450 device.

The NI CVS-1450 device ships with a 4-position power connector that
plugs directly into the power input connector on the NI CVS-1450 device.
To wire power to the 4-position connector, complete the following steps:

1. Wire the voltage output of the 24 VDC +10% power supply to the main
voltage input, labeled V, on the 4-position connector.

2.  Wire the common-mode signal (ground) output of the power supply
to the common-mode signal input, labeled C, on the 4-position
connector.

If you are using a separate power supply for the NI CVS-1450 device
isolated outputs, connect the voltage output on the power supply to

the isolated power (V) on the 4-position connector. Connect the
common-mode signal on the power supply to the isolated common-mode
signal (C;,,) on the connector.
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@ Note If you do not require a separate power supply for the NI CVS-1450 device isolated
outputs, you can daisy-chain the V to the V;, and the C to the C;, on the connector.

For information about grounding the NI CVS-1450 device chassis to earth
ground, refer to the NI CVS-1450 Series User Manual.

Connecting to a Network

Use a standard CAT 5 or CAT 6 Ethernet cable to connect the
NI CVS-1450 device to a network.

If the development computer is already configured on a network, you must
configure the NI CVS-1450 device on the same network. If the
development computer is not connected to a network, you can connect the
development computer and the NI CVS-1450 device directly using a CAT 5
or CAT 6 Ethernet crossover cable.

A Caution To prevent data loss and to maintain the integrity of your Ethernet installation,
do not use a cable longer than 100 m. If you are using a 100 Mbps Ethernet, National
Instruments recommends using a CAT 5 or CAT 6 shielded twisted-pair Ethernet cable.

Subnet Considerations

To configure the NI CVS-1450 device, it must reside on the same subnet as
the development computer. Once the NI CVS-1450 device is configured,
other subnets can access and use it.

To use the NI CVS-1450 device on a subnet other than the one on which
the development computer resides, first connect and configure the

NI CVS-1450 device on the same subnet as the development computer.
Next, physically move the NI CVS-1450 device to the other subnet and
reassign an IP address. Contact your network administrator for assistance
in setting up the development computer and NI CVS-1450 device on the
same subnet.

Connecting to a Development Computer

The development computer communicates with the NI CVS-1450 device
over an Ethernet connection. Use a standard Ethernet cable to connect from
the network port to the NI CVS-1450 device.

@ Note If you are not connecting through a network, use an Ethernet crossover cable to
connect the NI CVS-1450 device directly to the development computer.
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To connect the NI CVS-1450 device to the development computer, refer to
Figure 9-4 while completing the following steps:

1. Verify that the development computer is connected to the network and
is powered on.

2. Using a standard Ethernet cable, connect from the network port to the
Ethernet port on the NI CVS-1450 device.

3. Using a standard Ethernet cable, connect from the network port to the
Ethernet port on the development computer.

1 Standard Ethernet Cable Connecting from the NI CVS-1450 Device to an Ethernet Hub
2 Standard Ethernet Cable Connecting from an Ethernet Hub to the Development Computer
3 Ethernet Hub or Other Network Port

Figure 9-4. Ethernet Connection
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Configuring an IP Address

Complete the following steps to assign an IP address to the NI CVS-1450
device.

1. Launch Vision Builder Al

2. On the Vision Builder AI Welcome screen, shown in Figure 9-5,
expand the Execution Target listbox, and select Select Network
Target.

% NI Vision Builder Al - Welcome M= |

ni.com/vision

Configure Inspection

Vision Builder

for Automated Inspection

Inspect Product

Exit

l
l
o]
l

Execution Target | This Computer [x]
Select Netwark Target. ..

 This Computer

Smart Camnera Ennulakor
Compact Yision Systerm Emulakor
Embedded vision System Emulator

Figure 9-5. Vision Builder Al Welcome Screen

3. Inthe Select Remote Target dialog box, select the NI CVS-1450 device
with a MAC address that corresponds to the MAC address on the label
of the NI CVS-1450 device you want to configure.

4. Click Configure. The Remote Target Configuration Wizard launches
in a new window.
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In the Name field, enter a name for the device. Use the Description
field to enter any additional information or a brief description of the
device.

Device names are limited to 31 characters with no spaces or special
characters, except hyphens. The first and last characters must be
alphanumeric.

Click Next.

If the Network is configured to issue IP addresses using DHCP, select
Obtain IP Address for DHCP Server.

Otherwise, set the IP address manually by selecting Edit IP Settings,
Suggest Values, and OK.

Click Next.

Installing Software to the NI CVS-1450 Device

Once you have configured the NI CVS-1450 device on the network, you
must install software from the host computer to the NI CVS-1450 device.
Complete the following instructions to install software to the NI CVS-1450

device.

1. Enable the Update Target Software checkbox.

2. Click the Browse button next to the Software Image to Install on the
Target control. The Open dialog box opens.

3. Navigate to the Vision Builder Al software image you want to use, and
click OK.

4. Click OK to install the software on the NI CVS-1450 device.

Acquiring an Image

1334

Complete the following instructions to acquire an image in Vision Builder
Al using the NI CVS-1450 device.

1.
2.

Launch Vision Builder Al.

On the Vision Builder AI Welcome screen, expand the Execution
Target listbox, and select Select Network Target.

Select the NI CVS-1450 device you configured, and click OK.

On the Vision Builder AT Welcome screen, click Configure
Inspection to launch the Configuration Interface.
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5.  On the Acquire Images tab of the Inspection Steps palette, click the
Acquire Image (IEEE 1394) step. The property page for the step
opens.

6. Click the Acquire Single Image button to acquire a single image, or
click the Acquire Continuous Images button to acquire continuous
images.

7. Click OK to add the step to the inspection.

Now that you have configured an acquisition from the NI CVS-1450
device, you may continue to develop the inspection by adding additional
steps from the Inspection Steps palette.

Saving the Inspection

Complete the following instructions to save the inspection.

1. Select File»Save or click the Save button on the toolbar.

3

2. In the Inspection Name control, enter a name for the inspection.

3. Click Save to save the inspection.

@ Tip Select File»Inspection Properties to add a short description or comments about the
inspection.
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Performing a Triggered
Acquisition Using the
NI CVS-1450 Compact Vision

System

This chapter introduces using the NI CVS-1450 Series Compact Vision
System and Vision Builder Al to perform a triggered image acquisition.

The following signal names are used throughout this chapter to describe the
I/0 signals used in a triggered acquisition. The actual name of the signal
will depend on your camera and system configuration.

Table 10-1. 1/0 Signal Descriptions

Signal Name

Description

Available Signals

Camera Trigger In

Input on the camera that
receives an external trigger

Camera-specific, refer to your
camera documentation

CVS Trigger Out Output on the NI CVS-1450 TRIG 1
device that generates a trigger | TRIG 2
to the camera TTL OUTPUT 1
TTL OUTPUT 2
TTL OUTPUT 3
TTL OUTPUT 4
CVS Trigger In Input on the NI CVS-1450 TRIG 0
device that receives a signal TTL INPUT 0
from an external device, such TTL INPUT 1
as a proximity sensor ISO INPUT 5
ISO INPUT 8
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Hardware

The following hardware is necessary to complete this lesson.

a

a
a
a

NI CVS-1450 Series Compact Vision System
Development computer running Windows Vista/XP/2000
DCAM-compliant IEEE 1394 camera

IEEE 1394 jackscrew-to-latch cable (part number 778796-01) or any
standard IEEE 1394 cable. You can use a 4-pin to 6-pin converter cable
with cameras that have their own external power supply and do not
require power from the IEEE 1394 bus

NI desktop power supply (part number 778794-01) or any
24 VDC +10%, 50 W power supply

—  Power supply cord—Connects the NI desktop power supply to an
outlet. Refer toni . comfor the part number specific to your region
and ordering information

— 4-position power connector—Required if you do not use the
NI desktop power supply

Two 10 m standard CAT 5 10/100Base-T Ethernet cables
(part number 189174-10)

Recommended—NI Vision I/O Terminal Block and Prototyping
Accessory (part number 779166-01)

Connecting the Hardware

Before you complete the instructions in the following sections, complete
the instructions described in Chapter 9, Acquiring an Image with the

NI CVS-1450 Compact Vision System, to connect the power supply and
camera to the NI CVS-1450 device, and connect the NI CVS-1450 device
to a development computer.
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Connecting the Trigger Signal

The following instructions use the NI Vision I/O Terminal Block and
Prototyping Accessory for easy connection to the I/O signals on the

NI CVS-1450 device. You may also choose to connect trigger signals from
the camera directly to the NI CVS-1450 device. Refer to the NI Vision I/O
Terminal Block and Prototyping Accessory User Guide for more
information about the NI Vision I/O Accessory.

Complete the following instructions to connect a trigger signal from the
NI CVS-1450 device to the camera.

1.
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Connect the NI Vision I/O Accessory to the digital I[/O connector on
the NI CVS-1450 device using the I/O cable that came with the
NI Vision I/O Accessory.

Refer to your camera documentation to determine which signal on the
camera I/O connector to use for the trigger input signal. For the
purpose of this lesson, this signal is called Camera Trigger In.

Refer to the NI CVS-1450 Series User Manual to determine which
signal on the 44-pin connector to use to generate the trigger signal. For
the purpose of this lesson, this signal is called CVS Trigger Out.

If necessary, connect the camera ground to the TTL GND connection
on the NI Vision I/O Accessory.

Connect the Camera Trigger In signal from the camera to the terminal
on the NI Vision I/O Accessory that corresponds to the CVS Trigger
Out signal.
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Figure 10-1 illustrates the front panel of the NI Vision I/O Accessory.
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Figure 10-1. NI Vision I/0 Accessory Front Panel
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Creating a New Inspection

Complete the following instructions to launch Vision Builder AI and target
the NI CVS-1450 device.

1.
2.

Launch Vision Builder Al

On the Vision Builder AI Welcome screen, expand the Execution
Target listbox, and select Select Network Target.

Select the NI CVS-1450 device you configured, and click OK.

On the Vision Builder AI Welcome screen, click Configure
Inspection to launch the Configuration Interface.

Configuring the Trigger Signal

Complete the following instructions to configure an Generate Pulse
(NI-IMAQ I/O) step to generate a signal from an NI CVS-1450 device to
trigger the camera acquisition.

1.
g
A
2.
3.
L
s
9.
10.
11.
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Click the Toggle Main Window View button on the toolbar to bring
the inspection state diagram to the Main window.

Select View»View Complete Inspection Setup to display additional
inspection setup options.

On the left side of the state diagram, click Setup to configure the
Inspection Setup state.

In the Inspection Steps palette, select the Communicate tab.

Click the Generate Pulse (NI-IMAQ I/O) step. The property page for
the step opens.

In the Step Name control, enter Start Trigger Pulse.

In the Pulse Settings table, select the CVS Trigger Out line on the
NI CVS-1450 device to use to generate the trigger signal for the
camera.

Set the Action for the I/0O line to Start Pulse Generation.
Specify the Polarity of the generated pulse.

If necessary, modify the value of the Delay and Width controls to fit
your application.

In the Continuous Pulse Settings controls, specify a Triggered Pulse
that pulses every time CVS Trigger In detects a Rising Edge.

CVS Trigger In is the I/O input line on the NI CVS-1450 device you
want to use to detect when a trigger occurs.
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The Generate Pulse (NI-IMAQ I/0) property page should resemble
Figure 10-2.
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Figure 10-2. Configuring the Acquisition Trigger Signal

You can configure a single Generate Pulse (NI-IMAQ 1/0) step to
generate pulses on multiple output lines. For example, you can use a single
input signal to trigger both a camera and a light source. To configure pulse
generation on multiple output lines, simply select and configure each
output line from the Pulse Settings table, shown in Figure 10-2.

12. Click OK to add the step to your inspection.

Resetting the 1/0

Once you have configured the signal to trigger an acquisition, it is
important to also stop the trigger signal and reset the /O when the
inspection is closed. This process is known as inspection cleanup. If you do
not reset the I/O when you are finished with an inspection, the I/O settings
will persist for future inspections until either the I/O settings are changed
programmatically, or Vision Builder Al is closed.
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Complete the following steps to stop the trigger signal once the inspection
closes.

1. Click the Toggle Main Window View button on the toolbar to bring
the inspection state diagram to the Main window.

2. On the left side of the state diagram, click Cleanup to configure the
Inspection Cleanup state.

In the Inspection Steps palette, select the Communicate tab.

4. Click the Generate Pulse (NI-IMAQ I/O) step. The property page for
the step opens.

In the Step Name control, enter Stop Trigger Pulse.

In the Pulse Settings table, select the CVS Trigger Out line used in the
Setup state to generate the trigger signal for the camera.

7.  Set the Action for the I/O line to Stop Pulse Generation.
Click OK to add the step to your inspection.

Acquiring Inspection Images

1334

Complete the following instructions to configure an Acquire Image
(IEEE 1394) step to acquire images when a trigger pulse is received from
the NI CVS-1450 device.

1. Click the Toggle Main Window View button on the toolbar to bring
the complete inspection setup to the Main window.

2. Click State Diagram to view the state diagram for the inspection in the
Main window.

3. Double-click the Inspect state to launch the Edit State Name dialog
box.

In the State Name control, enter Acquire, and click OK.
In the Inspection Steps palette, select the Acquire Images tab.

6. Click the Acquire Image (IEEE 1394) step. The property page for the
step opens.

7. In the Step Name control, enter Acquire Image.
Select the camera to use for the acquisition from the Devices list.
9. On the Trigger tab, enable the Triggered Acquisition control.

10. In the Trigger Timeout control, specify the amount of time the
camera waits to receive a trigger before the acquisition times out.
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11. In the Polarity control, specify whether to begin the acquisition on the

rising or falling edge of the trigger signal.

@ Note Not all IEEE 1394 cameras support the ability to set the trigger polarity. Check the
camera documentation to determine which polarity options the camera supports.

12. Click OK to add the step to the inspection.

Saving the Inspection

Before you can run an inspection on the NI CVS-1450 device, you must
save the inspection. Saving the inspection downloads the inspection from
the host computer to the internal memory of the NI CVS-1450 device so the
inspection can be run. Complete the following steps to save the inspection
to the NI CVS-1450 device.

H 1. Select File»Save or click the Save button on the toolbar.
i 2. In the Inspection Name control, enter a name for the inspection.
3. Click Save to save the inspection.
@ Tip Select File»Inspection Properties to add a short description or comments about the

inspection.

Testing the Acquisition

Complete the following steps to test the trigger configuration and make
sure you can successfully acquire images.

1.

On the NI Vision I/O Accessory, ensure that the Demo Mode switch
in ON. The orange LED will be lit when the NI Vision I/O Accessory
is in Demo mode.

In Vision Builder Al, select File»Switch to Inspection Interface to
switch to the Vision Builder Al Inspection Interface.

Click the Start Inspection button to run the inspection.

On the NI Vision I/O Accessory, press the push-button switch
corresponding to the CVS Trigger In input signal you specified to
detect when a trigger occurs.

For example, if the trigger signal in the Inspection Setup state is set to
generate every time TTL Input 0 on the NI CVS-1450 device detects a
rising edge, then press the Trigger TTL In 0 switch on the NI Vision
I/O Accessory.
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The acquired image is displayed on the external monitor connected to
the NI CVS-1450 device. To view the image for within the Vision
Builder Al Inspection Interface, select one of the options from the
View menu.

5. Press the switch repeatedly to acquire multiple images. Vary the speed
that you press the switch and notice that an image is acquired only
when you press the switch.

) 6. Click the Stop Inspection button to stop the inspection.

Preventing an Acquisition Timeout

While testing the acquisition, you may have noticed that sometimes the
Acquire Image (IEEE 1394) step status changes from Pass to Fail
between presses of the NI Vision I/O Accessory trigger switch. This
behavior occurs when the acquisition step does not receive a trigger from
the NI CVS-1450 device within the Trigger Timeout period specified on
the property page of the acquisition step. If a timeout occurs, any
processing steps in the inspection that occur after the acquisition step will
also fail because there is no image available to process.

Ideally you would set the acquisition step Trigger Timeout to an infinite
value to ensure that a timeout never occurs. However, since Vision Builder
Al allows only finite values for the timeout period, you must use another
method to achieve the desired behavior. Instead of setting an infinite
timeout, you can use the inspection state diagram to configure Vision
Builder Al to only run the image processing steps in an inspection when an
image has been acquired.

Creating the Inspection State Diagram

Complete the following instructions to implement the behavior of an
infinite timeout in Vision Builder Al.

1. Select File»Switch to Configuration Interface to switch to the Vision
Builder AI Configuration Interface.

2. Click the Toggle Main Window View button on the toolbar to bring
the inspection state diagram to the Main window.
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3. Right-click an open area on the state diagram and select Create New
State to add a new state to the inspection, as shown in Figure 10-3. The
Edit State Name dialog box opens.

Stark
default
f/n“-;EIUif'B %Create Iews State
Create Mew End Point
default
Import Inspeckion
End

Figure 10-3. Creating a New Inspection State
4. In the State Name control, enter Inspect.

Next, you will define transitions between the inspection states. Notice that
every state has a default transition. You can also create additional
transitions between states based on measurement results or variable values.

E Note The default transition occurs when the transition requirements for other possible
transitions are not met.

5. Click the Acquire state default transition and drag it so that the
transition loops back to the Acquire state.

6. Click the Inspect state default transition and drag it to the End point.
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The state diagram should now resemble the state diagram shown in
Figure 10-4.

Start

def aulk

I/F'.;quire default

I/In—spect

defaulk

End

Figure 10-4. Configuring the Default Transitions

7. Right-click the Acquire state and select Create New Transition.

Click the Inspect state to create a transition between the Acquire state
and the Inspect state.

9. Double-click the transition to launch the Edit Transition dialog box.
10. In the Transition Name control, enter Image Acquired.

11. In the Measurement control, configure the transition to occur when
Acquire Image - Timeout is False.

12. Click OK to close the dialog box.
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The state diagram should now resemble the state diagram shown in

Figure 10-5.

Skart

defaulk

I/P.;quire

Image Acquired

Gspect

defaulk

default

End

Figure 10-5. Completed State Diagram for the Inspection

13. Add and configure additional steps in the Inspect state to complete

your application.

14. Save the Inspection.

15. Switch to the Inspection Interface and run the inspection.

When you run the inspection, notice that when a timeout occurs, the

inspection simply loops back to the Acquire state and resumes waiting for
a trigger. A timeout no longer affects the rest of the steps in the inspection.

@ Tip Set the Acquire Image (IEEE 1394) step Acquisition Mode to Immediate to

prevent the inspection from missing triggers that may occur when the inspection transitions

between states.
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Inspection Selection

This chapter introduces the inspection selection feature in Vision

Builder Al Inspection selection allows you to automatically select which
inspection you want to run based on the value of an I/O line or the result of
a communication step. Follow the instructions in this chapter to create an
inspection that reads a string sent by a host computer, using TCP/IP
communication, to determine which inspection to run on a remote target.

Connect to a Remote Target

Complete the following instructions to launch Vision Builder Al and
connect to a remote target.

1. Launch Vision Builder Al

2. On the Vision Builder AI Welcome screen, expand the Execution
Target listbox, and select Select Network Target.

3. Select the remote target you want to use, and click OK.

@ Tip Record the IP address of the remote target you selected. You will need the IP address
later in this lesson to send TCP/IP commands to the target.

4. On the Welcome screen, click Configure Inspection to launch the
Configuration Interface.

Installing Examples on the Remote Target

Complete the following instructions to verify that the correct example
inspections are installed on the remote target before proceeding to the next
section.

1. Select Target»Add/Retrieve Inspections to launch the Inspection
Manager.

2. In the Remote Device section of the Inspection Manager, verify that
Tutorial - 1 Coordinate System.vbai and Tutorial -
6 State Diagram Looping.vbai are listed.
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If either of these inspections are missing, complete the following
instructions to copy the inspections from the development computer to
the remote target.

a. Inthe This Computer section of the Inspection Manager, navigate
to the <Vision Builder AI>/Examples directory, where
<Vision Builder AI> isthe location where Vision Builder Al
is installed.

b. Select Tutorial - 1 Coordinate System.vbai, and click Copy.

c. Select Tutorial - 6 State Diagram Looping.vbai, and
click Copy.

The Inspection Manager dialog box should resemble Figure 11-1.

% Inspection Manager
This Computer !
Look in: CYProgram Files\Mational Instrumentsivision | s Remote Device: €4S - 10.0,6,15
[ Eve Dropper Inspection, vbai A Tutorial 1 - Coordinake System.vbai ~
[0 Floppy Disk Inspection, vbai Tutorial & - State Diagram Looping.vbai
[ Gears Inspection.vbai
[ Label Inspection.vbai
[ Measuring Cup Inspection.vbai
O il Filter Inspection.vbai
[ Soap Bottle Inspection, vbai
[ Spray Bottle Inspection. vbai
[0 Tutarial 1 - Coordinate System, vbai
[ Tutorial 2 - Image Calibration and Gauging. vbai
[ Tutarial 3 - Dedision Making vbai
O Tutorial 4 - Two Cameras Inspection, vbai
[ Tutarial S - State Diagram Branching, vbai
[0 Tutarial & - State Diagram Looping, vbai
- -
Inspection Mame: Tutarial 1 - Coordinate Swskem. vbai Description
This inspection checks For the presence of a cap on a spray bottle ”
Location:  Z:YProgram Files\Mational InskrumentstYision Builder AT using an intensity measurement and a coordinate system that is based
3.51Examples on pattern matching,
Created:  Monday, September 23, 2002 - 9:14:26 PM
Modified:  Monday, October 22, 2007 - 3:39:36 PM hd
Figure 11-1. Copying Inspections to a Remote Target
3. Click Done to close the Inspection Manager dialog box.
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Opening an Inspection

Complete the following steps to open an inspection on the remote target.

S 1. Select File»Open, or click the Open button on the toolbar.

2. Select Tutorial 1 - Coordinate System.vbai.

3. Click OK to open the inspection.

Adding a Communication Device

Complete the following instructions to define a TCP/IP communication
device and add the device to Vision Builder Al

1. Select Tools»Communication Device Manager from the Vision
Builder Al toolbar to launch the Communication Device Manager.

2. Click New Device to launch the New Communication Device dialog
box.

In the Device Name control, enter Desktop PC.
4. 1In the Protocol control, select TCP/IP.

5. In the Port control, enter the communication port you want to use to
listen for communication.

@ Tip Record the port number you selected. You will need the port number later in this
lesson to send TCP/IP commands to the remote target.

Click OK to add the device to Vision Builder Al.

In the Communication Device Manager dialog box, click the TCP/IP
Server Start Server button.

8. Click OK to close the dialog box.

Configuring TCP/IP Communication

Complete the following instructions to configure a TCP I/O step to receive
information from a TCP device.

£ 1. Click the Toggle Main Window View button on the toolbar to bring
& the inspection state diagram to the Main window.

2. Select View»View Complete Inspection Setup to display additional
inspection configuration options.
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3.
[j 4,
Select
Inspection
TCH 5.
6.
7.
9.
10.
11.

On the left side of the state diagram, click Select Inspection to
configure the Select Inspection state.

In the Inspection Steps palette, select the Communicate tab.

Click the TCP I/O Step. The property page for the step opens in the
Main window.

In the Step Name control, enter Receive TCP Data.
Click the Wait for String command button.

In the Wait for String dialog box, set the Fixed Number of Bytes
option for the Wait For control to 1.

In the Timeout control, enter 0. For this lesson, inspection selection
values are retrieved from a buffer to determine the current inspection,
$0 no timeout is necessary. If your inspections require additional time
to receive the inspection selection data, specify a larger Timeout
value.

Click OK to save the command settings and close the dialog box.

Click OK to add the step to the Select Inspection state

Mapping 1/0 Values to Inspections

After you configure the step to receive signals from an external TCP
device, you must map each possible value for the signal to a Vision Builder
Al inspection. Complete the following instructions to configure a Select
Inspection step and map the I/O signal values to Vision Builder Al

inspections.
1. In the Inspection Steps palette, select the Use Additional Tools tab.
= 2. Click the Select Inspection step. The property page for the step opens
st in the Main window.
3. In the Select Inspection Source control, verify that Receive TCP
Data - String # 0 is selected.
4. Click Add to add an I/O signal value to the Inspections table.
In the Value control, enter 1.
6. In the Inspection control, select Tutorial 1 - Coordinate
System.vbai.
7. Click Add to add another value to the Inspections table.
8. In the Value control, enter 2.
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9. In the Inspection control, select Tutorial 6 - State Diagram
Looping.vbai.

10. Select the Enable Inspection Selection checkbox. The property page
should now resemble the property page shown in Figure 11-2.

11. Click OK to add the step to the Select Inspection state.

Select Inspection Source

Receive TCP Data - String #0 -
Inspections
Use Valuz Inspection -
1 Tutorial 1 - Coordinate Syskem
2 Tukarial & - State Diagram Looping Delete

Saork

Select Inspection Settings
Walue Inspection
z Tukarial & - State Diagram Looping w

(&) Normal Display
() Codes Display

Enable Inspection Selection

Figure 11-2. Configuring the Select Inspection Step

Running the Inspection

Complete the following instructions to switch Vision Builder Al from
Configuration mode to Inspection mode and begin running an inspection.

@ Inspection Selection Jl

1. Select File»Switch to Inspection Interface. Notice that the
Inspection Selection button is now available on the toolbar.

b 2. Click the Start Inspection button to begin running the inspection.

Note If inspection images are not displayed when the inspection is running, select View»
Display All Images to view the inspection images.
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Generating TCP Commands and Testing the Inspection

Complete the following instructions to send TCP commands to Vision
Builder AI and change the active inspection.

1. Navigate to the <Vision Builder AI> directory on the development
computer, and double-click Vision Builder Ethernet
Terminal . exe to launch the Vision Builder Ethernet terminal.

2. Inthe Connect To dialog box, enter the IP address and Port Number
of the remote target you used to configure the inspection selection.

Click OK.

4. Inthe Vision Builder Ethernet Terminal, enter 2. Notice how the active
inspection in the Vision Builder Al Inspection Interface changes from
Tutorial - 1 Coordinate System.vbai to Tutorial -

6 State Diagram Looping.vbai.

5. Inthe Vision Builder Ethernet Terminal, enter 1. Notice how the active
inspection changes back to Tutorial - 1 Coordinate
System.vbai.

To disable inspection selection while an inspection is running, click the
Inspection Selection button on the toolbar.
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Technical Support and
Professional Services

Visit the following sections of the award-winning National Instruments
Web site at ni . com for technical support and professional services:

© National Instruments Corporation

Support—Technical support at ni . com/support includes the
following resources:

Self-Help Technical Resources—For answers and solutions,
visit ni . com/support for software drivers and updates,

a searchable KnowledgeBase, product manuals, step-by-step
troubleshooting wizards, thousands of example programs,
tutorials, application notes, instrument drivers, and so on.
Registered users also receive access to the NI Discussion Forums
at ni.com/forums. NI Applications Engineers make sure every
question submitted online receives an answer.

Standard Service Program Membership—This program
entitles members to direct access to NI Applications Engineers
via phone and email for one-to-one technical support as well as
exclusive access to on demand training modules via the Services
Resource Center. NI offers complementary membership for a full
year after purchase, after which you may renew to continue your
benefits.

For information about other technical support options in your
area, visit ni.com/services, or contact your local office at
ni.com/contact.

Training and Certification—Visit ni . com/training for
self-paced training, eLearning virtual classrooms, interactive CDs,
and Certification program information. You also can register for
instructor-led, hands-on courses at locations around the world.

System Integration—If you have time constraints, limited in-house
technical resources, or other project challenges, National Instruments
Alliance Partner members can help. To learn more, call your local
NI office or visit ni.com/alliance.
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If you searched ni . com and could not find the answers you need, contact
your local office or NI corporate headquarters. Phone numbers for our
worldwide offices are listed at the front of this manual. You also can visit
the Worldwide Offices section of ni . com/niglobal to access the branch
office Web sites, which provide up-to-date contact information, support
phone numbers, email addresses, and current events.



Glossary

C

coordinate system A reference location (origin) and angle in an image that ROIs can relate to
when positional and angular adjustments of the ROI are necessary.
A coordinate system is depicted by two lines representing the orientation
and direction of its two axes.

D

data type A format for information. Acceptable data types for most functions are
numeric, array, and string.

F

field of view The area of inspection that the camera can acquire as an image.

focal point The pixel location in a pattern matching template whose coordinates are
returned as the location of a match in the inspection image.

inspection A vision inspection application created in and run from Vision Builder Al
that can perform inline or offline visual inspections.

intensity The gray-level value of a pixel in a grayscale image.

match score A number ranging from 0 to 1,000 that indicates how closely an area of an
acquired image matches the template image. A match score of 1,000
indicates a perfect match. A match score of 0 indicates no match.

object A connected region or grouping of pixels in an image in which all pixels
have intensity levels in the same range.
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P

pattern matching

pixel

R

resolution

ROI

S

spatial calibration

state

state diagram

step

T

template

transition

The technique used to quickly locate a grayscale template within a
grayscale image.

Picture element—The smallest division that makes up a digital image.
For measurement tasks, optimum pixel dimensions are square (aspect ratio
of 1:1, or the width equal to the height).

The number of rows and columns of pixels. An image composed of m rows
and n columns has a resolution of m x n.

Region of Interest—An area of the image that is graphically selected from
a window displaying the image. This area can be used to focus further
processing.

Assigning physical dimensions to the area of a pixel in an image.

A particular set of steps that execute under certain conditions during an
inspection.

A graphical representation of a finite state machine.

A component of a Vision Builder Al inspection that performs a specific
visual inspection task or supporting tasks, such as decision making and
serial communication.

Pattern that you are trying to match in an image using the Match Pattern,
Match Color Pattern, Geometric Matching, or Detect Defects steps. A
template can be a region selected from an image or it can be an entire
image.

Event that causes the inspection to move from one state to another.
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