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CCOOMMMMOONN  RREEAADDEERR  QQUUEESSTTIIOONNSS  

Are my protectedpdf documents compatible with the iPad? 

Subject Line: Compatibility with the iPad 

I understand you are wanting to view protectedpdf documents on your iPad. We are waiting for Apple to 
support embedded JavaScript within Preview. Many PDF viewers now support this aspect of the PDF 
standard (e.g. Adobe Reader, Foxit Reader, Nitro PDF) and we rely on it to implement various aspects 
of our products. 

Unfortunately at this time you will not be able to use any handheld device to unlock and view 
protectedpdf files. 

Are my protectedpdf documents compatible with eReaders? 

Subject Line: Compatibility with the Barnes & Noble Nook, Amazon Kindle and Sony eReader 

Portable readers, have proprietary software rather than Adobe Reader which is required, and therefore 
are unable to process protectedpdf documents.  If the device does have Adobe Reader, it’s not the full 
version and therefore does not have full Acrobat JavaScript support, which is required to process our 
document unlocks. 

If the reader is receiving the message: "This document requires global security policy to be disabled." 
What do I do? 

This error can occur in Adobe Reader Acrobat version 8.0 or later. To correct the problem, please do 
the following: 

 Open Adobe Reader/Acrobat.  

 Select Edit > Preferences from the menu.  

 Select the JavaScript section.  

 Ensure that "Enable global security policy" is unchecked.  

 Click OK.  

 Re-open your PDF. 

The reader has received both error message 005 and 064 resulting in the document closing. These 
errors are a result of the reader not disabling the global security policy. The reader will need to follow 
these steps before opening the document again: 

 Open Adobe Reader/Acrobat.  
 Select Edit > Preferences from the menu.  
 Select the JavaScript section.  
 Ensure that "Enable global security policy" is unchecked.  
 Click OK.  
 Re-open your PDF. 

Receiving the message: "Your security settings don't allow access to the protectedpdf server. You 
must allow access to the server.” (Message code: 057) 

This usually indicates that the site for the protectedpdf server has been added to the set of disallowed 
sites for Adobe. Below are instructions for resolving this problem in Adobe Reader / Acrobat version 8 
(other versions may use slightly different terminology). 

 Open up Reader / Acrobat 
 Select Edit > Preferences from the menu 
 In the dialogue that comes up, choose Trust Manager on the left 
 In the middle box on the right (Internet Access from PDF files outside the web browser), select 

Change Settings 
 In the box labeled My Web Sites, check to see if protectedpdf.com is listed 
 If so, select it, then select Allow Access from the bottom of the screen 
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Receiving the message: "Invalid credentials." 

This error occurs when your login and password are not recognized. Please verify that you entered the 
correct login and password and try again. If this problem persists, contact the publisher for further 
support. 

Receiving a message saying the file is corrupt or damaged. 

This problem normally occurs when viewing PDFs with older versions of Adobe Acrobat/Reader. 
Please ensure you are viewing your PDF with Adobe Reader/Acrobat version 6.0 or later. You can 
check your version by opening Adobe, and selecting Help > About Adobe Reader/Acrobat. 

When I start typing my login credentials into a protectedpdf document, I receive an informational 
popup stating that "Adobe Reader does not save the data that you enter into the form fields. ..." 

Protectedpdf requires that you enter your login credentials in order to unlock the document. You can 
just click on "OK" to continue. You can also check the "Do not show this message again" option to 
avoid future warnings. 

Why do I need to have an Internet connection in order to unlock my protectedpdf document? 

In order to verify that your are the intended recipient of the document, you need to be online to unlock 
the document. Some documents are then allowed to be viewed offline for a time that has been 
predetermined by your publisher. During offline access, you will no longer need and Internet 
connection. 

I have dial-up, will this work for protectedpdf? 

Yes, dial-up Internet connections are fast and effective when working with protectedpdf documents. 

What information is transmitted when I unlock a protectedpdf document? 

Your login credentials and the documents id are securely transmitted to a protectedpdf server in order 
to verify that you are the intended recipient of the document and that your credentials are valid. These 
credentials are encrypted to protected them during transmission. 

Does protectedpdf store a cookie? 

Yes, in order to identify your computer amongst other computers, protectedpdf does store an Adobe 
Acrobat cookie which only contains a random key. This cookie behaves similarly to Internet browser 
cookies but are stored and managed separately from your Internet browser cookies. 

I am having problems unlocking a protectedpdf document, what should I do? 

Ensure that you are currently online with either a dial-up or high-speed connection. 

Ensure that you have Adobe Acrobat 6.01 or later. The exact version of an Adobe Acrobat product is 
displayed in the popup that opens when choosing the "About ..." item in the "Help" menu of the Adobe 
Acrobat product. If you have an earlier version, you can obtain the latest Adobe Acrobat Reader for free 
at Adobe's web site: http://www.adobe.com/ . 

Ensure that you have enabled Acrobat JavaScript in your Adobe Acrobat product. This setting is 
enabled by default in the factory configuration. To enabled Adobe JavaScript, launch your Adobe 
Acrobat product and select "Preferences" from the "Edit" menu item. Choose the "JavaScript" item in 
the preferences popup and place a check in the "Enable Acrobat JavaScript" option. 

If you have a software firewall program on your computer, such as Windows Firewall, ZoneAlarm, 
Norton or McAfee Personal Firewall, then you need to allow your Adobe Acrobat product to 
communicate with the Internet in order for your document to unlock. If you are not sure how to do this 
then please contact your software firewall vendor for instructions. 

If you have successfully performed all of the above steps are still not able to unlock your protectedpdf 
document then you should try unlocking the document from a different computer to confirm that the 
problem is not related to your computer. 

http://www.adobe.com/
http://www.adobe.com/
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EERRRROORR  SSCCRREEEENN  SSHHOOTTSS  

This is a very generic error but often is the result of incompatible version of Adobe/Acrobat or a security issue: 

 

The following errors are a result of the global security policy setting in Adobe/Acrobat: 

 

 

This is error is a result of Reader/Acrobat not being used, the Reader/Acrobat version is corrupted, or an 

incompatible version of FOXIT, or incompatible version of Reader/Acrobat 
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This is a result of the communication being blocked within Adobe/Acrobat in the Adobe Trust Manager: 

 

This is the first of 2 pop-ups that the reader will see when unlocking their document. The firs warning lets the 

reader know they are communicating with the protectedpdf server. They must click allow. 

 

This is the second of 2 pop-ups that the reader will see when unlocking their document. The second warning 

lets the reader know that the protectedpdf server is sending a response back. They must click allow. 
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The following errors are a result of a Proxy Server or Firewall: 

 

 

 



7 | P a g e  

 

This message tells the reader that they can not save a version of the PDF that remembers their username and 

password. The reader will always be required to submit their username and password. This occurs when 

offline days have not been granted. 

 

This message tells the reader that they can not save a version of the PDF that remembers their username and 

password. The reader will always be required to submit their username and password. This occurs when 

offline days have not been granted. 

This is a result of the enhanced security setting in Adobe/Acrobat but should only occur in older installed 

versions of our application: 

 

Please note: This can easily be fixed if you do run into it so let us know.
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SSUUPPPPOORRTTIINNGG  DDOOCCUUMMEENNTTSS  TTOO  PPRROOVVIIDDEE  YYOOUURR  RREEAADDEERRSS  

 
 
The following pages are instructions for a few of the common issues your 
readers may experience. Please feel free to use these for your own FAQs 
or to send to readers as needed. They are here for you to use however 
you see fit.  
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IINNSSTTRRUUCCTTIIOONNSS  TTOO  PPRROOVVIIDDEE  RREEAADDEERRSS  WWIITTHH  TTHHEEIIRR  11SSTT  PPDDFF  

There is no software required to view this secure PDF, all that is required is Adobe Reader or Acrobat 

Pro  6.0.1 or higher. Download a free copy of Adobe Reader here  http://get.adobe.com/reader/. 

When you open the PDF, you will be prompted for your Username and Password. Once you have 

entered the login information, you will have access to the entire PDF document. The PDF <insert 

info such as printing restrictions, computer limits, expiration date, and remember credential 

details>. 

Your computer system will automatically connect to the PDF Protection server to authenticate the 

username and password you have entered.  If your computer system is blocked from running this 

action you must contact your IT department for technical support.  

Instructions for configuring the Global Object Security Policy in Adobe:  

 Open Adobe Reader 

 From the menu bar, select Edit  

 Select Preferences from the list 

 On the left-hand sidebar, select JavaScript 

 Make sure the "Enable global object security policy" option is unchecked 

 Click the OK button  

 Close Adobe 

 Re-open the document 

Please Note: The Global Object Security settings should be changed before opening the 
document for the 1st time. If the document has been set to not prompt and close 
then the setting does not need to be disabled. 

Instructions for Un-locking your documents: 

1. Open the PDF, enter the username and password you were provided.  

2. Two security warnings will come up, the 1st is to inform you that you will be communicating 

with our server and the 2nd informs you that our server is sending a response back 

3. You must click "Allow" on both warnings 

4. Check the box "Remember my action for this site" if you want to always allow the 

communications for this site  

http://get.adobe.com/reader/
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BBAASSIICC  IINNSSTTRRUUCCTTIIOONNSS  FFOORR  YYOOUURR  RREEAADDEERRSS 

Your computer system will automatically connect to the PDF Protection server to authenticate the 

username and password you have entered.  If your computer system is blocked from running this 

action you must contact your IT department for technical support.  

Instructions for configuring the Global Object Security Policy in Adobe:  

 Open Adobe Reader 

 From the menu bar, select Edit  

 Select Preferences from the list 

 On the left-hand sidebar, select JavaScript 

 Make sure the "Enable global object security policy" option is unchecked 

 Click the OK button  

 Close Adobe 

 Re-open the document 

Please Note: The Global Object Security settings must be changed before opening the 
document for the 1st time 

Instructions for Un-locking your documents: 

1. Open the PDF, enter the username and password you were provided.  

 

2. Two security warnings will come up, the 1st is to inform you that you will be communicating 

with our server and the 2nd informs you that our server is sending a response back 
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3. You must click "Allow" on both warnings 

Warning #1 Image: 

 

Warning #2 Image: 

 

4. Check the box "Remember my action for this site" if you want to always allow the 

communications for this site  
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PPRROOXXYY  SSEERRVVEERRSS,,  FFIIRREEWWAALLLLSS,,  AADDOOBBEE  TTRRUUSSTT  MMAANNAAGGEERR  AANNDD  PPRROOTTEECCTTEEDDPPDDFF 

Who we are: 

Protectedpdf is a digital rights management (DRM) solution for PDF documents that does not require the 
installation of a plug-in or additional software -- it works directly with the capabilities of Adobe Reader. 
Protectedpdf is a dynamic DRM solution. That is, the rights that a user has to a particular document are not 
embedded in the document itself, but can vary over time.  

How it works: 

In order to provide this functionality, a protectedpdf document must communicate to the protectedpdf server. 
The protectedpdf server stores the rights information that defines which individuals have access to a given 
document. The communication from the document to the protectedpdf server uses the HTTP protocol over 
either port 80 or port 443 (depending on system configuration).  

Why proxy servers affect the process: 

This style of communication works seamlessly in most environments. However, prior to Version 9 (for Adobe 
Reader) and Version 8 (for Adobe Acrobat), Adobe's software was not designed to deal with proxy servers. In 
these scenarios, when the protectedpdf document attempts to contact the protectedpdf server its 
communications are blocked. When it is unable to contact the server, for security reasons the document 
cannot be unlocked.  
 
In order for protectedpdf documents to function correctly when using older versions of Adobe Reader/Acrobat, 
the proxy server must be configured to allow direct communication with the DNS address 
http://protectedpdf.com/  on ports 80/443. 

How to check for a proxy server: 

1. Open Internet Explorer (not Firefox or any other browser).  
2. Select "Tools" from the menu bar.  
3. Select "Internet options."  
4. Select the Connections tab.  
5. Click the "LAN Settings" button (near the bottom)  
6. Check to see if the "use a proxy server..." tick box is selected. 

Proxy Server Required Configuration Changes: 

1. The proxy MUST allow direct communication 
2. With the DNS address https://protectedpdf.com/ or http://protectedpdf.com/ 
3. On ports 80/443 

Firewall Required Configuration Changes: 

1. Remove any blocks in Norton or other firewall software for https://protectedpdf.com/ or 
http://protectedpdf.com/ 

2. The firewall MUST allow communication with https://protectedpdf.com/ or http://protectedpdf.com/ 

Adobe/Acrobat Trust Manager Configuration Changes: 

1. Open Adobe/Acrobat 
2. Select “Edit” 
3. Select “Preferences” 
4. Select “Trust Manager” 
5. Select “Change Settings” 
6. Remove any blocks in for http://protectedpdf.com/ 
7. Allow communication with http://protectedpdf.com/ 

 

http://documents.concrete.org/
https://ppdf.phoenix.edu/
http://ppdf.phoenix.edu/
https://ppdf.phoenix.edu/
http://ppdf.phoenix.edu/
https://ppdf.phoenix.edu/
http://ppdf.phoenix.edu/
http://ppdf.phoenix.edu/
http://ppdf.phoenix.edu/
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DDOOCCUUMMEENNTT  GGUUIIDDEELLIINNEESS  FFOORR  MMAACC  UUSSEERRSS  

 

1. How to Check Your OS Version (Mac) 

 Click on the Blue Apple and then click on About This Mac 

2. Download and install the appropriate Adobe Reader for your operating system   

 Go to http://get.adobe.com/reader/otherversions/  

3. Set the default PDF viewer to Adobe Reader   

 Find any PDF document that you have on your computer, click on the document Name & click Get Info 

 
 In the window that pops up, click the arrow next to Open With: if it's not already open 

 
 Then from the drop-down menu where it says "Preview", choose Adobe Reader 

 Change the default to Acrobat Reader for all PDFs by clicking on "Change All" 

 

The Drop Down Menu 

will show Adobe Reader 

after it is installed in Step 

2 

To view a PDF document you MUST use Adobe Reader for Mac. Mac Preview will NOT work. Mac Preview is the default PDF viewer. 

 

http://get.adobe.com/reader/otherversions/
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DDIISSAABBLLIINNGG  TTHHEE  GGLLOOBBAALL  OOBBJJEECCTT  SSEECCUURRIITTYY  OONN  AA  MMAACC  

1. Open Adobe Reader and click on Adobe Reader in top tool bar 

 
2. Click Preferences in drop down menu 

 
3. Select “JavaScript” in the left hand categories menu 

4. Un-click “Enable global object security policy” and press “OK” 
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WWIINNDDOOWWSS  GGLLOOBBAALL  OOBBJJEECCTT  SSEECCUURRIITTYY  PPOOLLIICCYY  IINNFFOORRMMAATTIIOONN  

In the JavaScript section of Acrobat preferences, there is a new check box called Enable Global Object 

Security Policy (select Edit > Preferences > JavaScript). 

When this preference is checked (the default), each time a global property is written, the origin that set it is 

remembered. Thereafter, only origins that match can access the variable. For files, this means that only the file 

that set the variable can access it. For documents from URLs, it means that only the host that set it can access 

the variable.  

When not checked, documents from different origins can access the variable, which was the behavior in 

versions prior to Acrobat Reader 8. 

DDIISSAABBLLIINNGG  TTHHEE  GGLLOOBBAALL  OOBBJJEECCTT  SSEECCUURRIITTYY  PPOOLLIICCYY  

To disable the global object security policy, follow these steps: 

 Open Adobe Reader 

 From the menu bar, select Edit > Preferences 

 On the left-hand sidebar, select JavaScript 

 Make sure the "Enable global object security policy" option is unchecked 

 Click the OK button  

 Close Adobe 

 Re-open the document 
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AADDOOBBEE  JJAAVVAASSCCRRIIPPTT  CCOOOOKKIIEE  FFIILLEESS  AANNDD  PPRROOTTEECCTTEEDDPPDDFF  

When a reader opens and unlocks a protectedpdf document we assign a computer ID that is placed in the 

Adobe JavaScript cookie. This cookie lives in the same location that Adobe is installed which is typically the C: 

drive. Due to where the cookie lives this directly affects where the document should reside. Whenever a reader 

receives a file they should save a copy of the file to the hard drive of the computer they will be using. 

The following list is the common ways documents are sent and when opened from any of these locations a 

new computer id will be assigned every time: 

 Flash drive 

 Email attachment 

 CD/DVD 

 Link to a website 

The reader must save a copy of the file to the hard drive once they receive it to avoid multiple computer ids’ 

being assigned. 

When multiple computer id’s are assigned the readers will use up their designated computer limit. 

The file can be saved to network drives, servers, cloud based servers, or virtual drives but these locations will 

cause multiple computer ids to be assigned and computer limits to be exceeded. The file should be saved to 

the C: drive as the permanent location.  
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CCLLEEAARRIINNGG  JJAAVVAASSCCRRIIPPTT  CCOOOOKKIIEESS  ((XXPP,,  VVIISSTTAA,,  &&  MMAACCSS))  

WWIINNDDOOWWSS  XXPP - follow these steps to clear the JavaScript cookies: 

1. Close all instances of Adobe currently open 
2. Select Start and open My Computer 
3. Click on Tools 
4. Select Folder Options 
5. Select the View tab 
6. Select Show hidden files and folders 
7. Click on your C: drive 
8. Open Documents and Settings 
9. Open your <windows user> folder 
10. Open Application Data folder 
11. Open Adobe folder 
12. Open Acrobat folder 
13. Open your <acro version> folder 
14. Open the JavaScripts folder 
15. Delete both the glob.js & glob.settings.js files inside the folder 

 

WWIINNDDOOWWSS  VVIISSTTAA - follow these steps to clear the JavaScript cookies: 

Please Note: changing your view may be required; to change the view: go to Organize, layout, show 
menu bar; to show hidden files and folders: go to folder options, show hidden files and 
folders 

1. Close all instances of Adobe currently open 
2. Select Start 
3. Open My Computer 
4. Click on your C: drive 
5. Open the Users folder 
6. Open your <windows user> folder 
7. Open the AppData folder 
8. Open the Roaming folder 
9. Open the Adobe folder 
10. Open the Acrobat folder 
11. Open your <acro version> folder 
12. Open the JavaScripts folder 
13. Delete both the glob.js & glob.settings.js files inside the JavaScripts folder 

 

MMAACC  OOSSXX  &&  LLEEOOPPAARRDD - follow these steps to clear the JavaScript cookies: 

1. Close all instances of Adobe currently open 
2. Load up Finder 
3. Under Places select your <Mac user> on the left navigation panel 
4. Open the library 
5. Open the Acrobat User Data 
6. Open the <acro version> 
7. Open the _x86 
8. Open the JavaScripts 
9. Delete both the glob.js & glob.settings.js files inside the JavaScripts folder 

 

 

 


