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1 Introduction 

1.1 Overview 

The DEMO9S12XEP100 Demonstration board has been designed for the evaluation, 
demonstration and the debugging of the Freescale MC9S12XEP100 microcontroller.  
The DEMO9S12XEP100 can be used as a standalone application, or via its built-in USB-to-
BDM bridge, or together the Freescale Student Learning Kit (Freescale code: MCUSLK) 
through three external 40-pin I/O female header connectors. 

1.2 Package Contents 

The DEMO9S12XEP100 package includes the following items: 
 
� The DEMO9S12XEP100 evaluation board; 
� A USB cable; 
� A LIN cable; 
� The SofTec Microsystems “System Software” CD-ROM; 
� The CodeWarrior Development Studio Special Edition CD-ROM; 
� A Quick Start Guide sheet; 
� This user’s manual. 

1.3 Supported Devices 

The DEMO9S12XEP100 Demonstration Board supports the following devices: 

 
� MC9S12XEP100. 

1.4 Recommended Reading 

� Freescale S12X microcontroller-specific datasheets; 
� DEMO9S12XEP100 Schematic. 
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2 Hardware Features 

2.1 Demonstration Board Features 

The DEMO9S12XEP100 board features: 
 
� A MC9S12XEP100 microcontroller (in 112-Pin LQFP package, already programmed 

with a demo application); 
� Two clock sources: 
 

o A 4 MHz crystal; 
o A provision for an external clock module. 
 

� A 12 V DC power supply input connector; 
� Power input selection jumper for selecting the input voltage source: 
 

o 12 V DC input connector; 
o USB connector. 

 
� A built-in USB-to-BDM circuitry which allows the host PC to communicate with the 

microcontroller through a standard USB interface. USB 2.0 is fully supported. When 
using an external in-circuit debugger (via the “BDM” connector), the USB-to-BDM 
circuitry must be bypassed by removing the BKGD and  RESET# jumpers. 

� A Reset push-button connected to the MCU Reset pin.  
� A series of inputs: 
 

o Two push-buttons, together with jumpers to connect/disconnect them to/from the 
microcontroller; 

o Four DIP-switches, together with jumpers to connect/disconnect them to/from the 
microcontroller; 

o A potentiometer, together with a jumper to connect/disconnect it to/from the 
microcontroller; 

o A photocell, together with a jumper to connect/disconnect it to/from the 
microcontroller. 

 
� Four high-efficiency (low-current) LEDs together with jumpers to connect/disconnect 

them to/from the microcontroller; 
� An RS-232 channel connected to the microcontroller’s SCI serial communication 

interface; 
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Hardware Features 

� Two LIN connectors sharing one LIN transceiver, together with jumpers for 
configuration; 

� One CAN connector with high-speed CAN transceiver, together with jumpers for 
configuration. 

 

 

 

The DEMO9S12XEP100 Demonstration Board 
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3 Software Setup 

3.1 Overview 

i 
 

Note: before connecting the Demonstration Board to the PC, it is 
recommended that you install all of the required software first (see 
below), so that the appropriate USB driver will be automatically found by 
Windows when you connect the Demonstration Board. 

 
The Demonstration Board requires that both CodeWarrior Development Studio Special Edition 
and SofTec Microsystems Additional Components be installed in the host PC. 
 

i 
 

Note: CodeWarrior Development Studio for HCS12(X) must be installed 
first. 

3.2 Host System Requirements 

The Demonstration Board is controlled by CodeWarrior Development Studio. The following 
hardware and software are required to run the CodeWarrior user interface together with the 
Demonstration Board: 
 

� A 200-MHz (or higher) PC compatible system running Windows 98, Windows 2000 or 
Windows XP; 

� 128 MB of available system RAM plus 1 GB of available hard disk space; 
� A USB port; 
� CD-ROM drive for installation. 

3.3 Installing CodeWarrior Development Studio 

To install the CodeWarrior Development Studio Special Edition, insert the CodeWarrior CD-
ROM into your computer’s CD-ROM drive. A startup window will automatically appear. Follow 
the on-screen instructions. 
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3.4 Installing SofTec Microsystems Additional 
Components 

The SofTec Microsystems Additional Components install all of the other required components 
to your hard drive. These components include: 

 
� The Demonstration Board’s USB driver; 
� The software plug-in for CodeWarrior; 
� Examples; 
� Demonstration Board’s user’s manual; 
� Demonstration Board’s schematic; 
� Additional documentation. 

 
To install the SofTec Microsystems Additional Components, insert the SofTec Microsystems 
“System Software” CD-ROM into your computer’s CD-ROM drive. A startup window will 
automatically appear. Choose “Install Instrument Software” from the main menu. A list of 
available software will appear. Click on the “Additional Components” option. Follow the on-
screen instructions. 
 

i 
 

Note: to install the Additional Components on Windows 2000 or Windows 
XP, you must log in as Administrator. 
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4 Hardware Setup 

4.1 First Connection 

The Demonstration Board is connected to a host PC through a USB port. Connection steps 
are listed below in the recommended flow order: 
 
1. Install all the required system software as described in the previous section. 
2. Make sure the “POWER SEL” jumper is in the “USB” position. 
3. Insert one end of the USB cable into a free USB port. 
4. Insert the other end of the USB cable into the USB connector on the Demonstration 

Board. 
5. The first time the Demonstration Board is connected to the PC, Windows recognizes the 

instrument and starts the “Found New Hardware Wizard” procedure, asking you to 
specify the driver to use for the instrument. On Windows XP (SP2) the following dialog 
box will appear. 

 

 
 

Select the “No, not this time” option and click the “Next >” button. 
6. The following dialog box will appear. 
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Click the “Next >” button. 
7. Depending on your Windows settings, the following warning may appear. 
 

 
 

i 
 

Note: this warning is related to the fact that the USB driver used by 
the Demonstration Board is not digitally signed by Microsoft, and 
Windows considers it to be potentially malfunctioning or dangerous 
for the system. However, you can safely ignore the warning, since 
every kind of compatibility/security test has been carried out by 
SofTec Microsystems. 

 
Click the “Continue Anyway” button. 

8. Windows will install the driver files to your system. At the end of the installation, the 
following dialog box will appear. 
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Click the “Finish” button to exit from the “Found New Hardware Wizard” procedure. 
9. The Demonstration Board’s USB driver is now installed on your system. 

4.2 Power Supply 

The Demonstration Board can be powered in three ways: 
 
� 12 V DC input connector; 
� USB connector; 
� I/O header connector. 
 
The “POWER SEL” jumper allows you to power the board through either the 12 V DC input 
connector or the USB connector. 
When using the I/O header connector, its pin 1 is connected to the VDD line of the carrier 
board through the “VAUX ENA” jumper.
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5 Operating Modes 

5.1 Overview 

The Demonstration Board can work in two modes: “standalone” mode and “host” mode. 

5.2 Standalone Mode 

In standalone mode, no PC connection is required. The microcontroller is factory programmed 
with a sample application. 
To run the built-in example: 
 
1. Ensure that the “OSC SEL” jumper selects the “CRYSTAL” position. 
2. Ensure that the “XCLKS#=0” jumper is not inserted. 
3. Ensure that all of the light sensor “ENA” jumper is inserted. 
4. Ensure that all of the “LED ENA” jumpers are inserted. 
5. Ensure that the two push-button “ENA” jumpers are inserted. 
6. Ensure that the two “RS-232 ENA” jumpers are inserted. 
7. Ensure that the “POWER SEL” jumper selects the “UNREG” position. 
8. Power on the Demonstration Board through the 12 V DC plug-in power supply. 
9. The green “POWER” LED on the board should turn on. 
10. Press the “PP0” push-button. Rotate the potentiometer. Its value will be shown on the 

LEDs. 
11. Press the "PP1" push-button. The output of the light sensor will be displayed on the 

LEDs. 
12. The value of the potentiometer or the light sensor is also sent to the RS-232 port (baud 

rate = 9600, data bits = 8, parity = N, stop bits = 1). 

5.3 Host Mode 

In host mode the program execution is controlled by the host PC through the “USB” connector. 
You can use the PC to debug the application by, for example, executing the program step by 
step and watching how the microcontroller registers vary, using the provided CodeWarrior 
Development Studio. 
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i 
 

Note: all MCUs in the S12X family contain a single-wire background 
debug interface which supports in-circuit programming of on-chip non-
volatile memory. This system does not interfere with normal application 
resources. It does not use any user memory or locations in the memory 
map. The Background Debug Module (BDM) uses a single-wire 
communication interface (via the BKGD line) to allow non-intrusive access 
to target system memory and registers. 

 
To work in host mode (using the built-in USB to BDM interface): 
 
� Make sure that both the “RESET#” and “BKGD” jumpers are inserted. 
� Make sure that the “POWER SEL” jumper is in the “USB” position. 
� Connect the host PC to the board through the provided USB cable. 
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6 Application Tutorial 

6.1 Overview 

This section will provide a step-by-step guide on how to launch your first project and get 
started with the CodeWarrior for HCS12(X) user interface. 

6.2 Step-by-Step Tutorial 

The sample application is the same as the one described in the “Standalone Mode” section 
above. 
 
1. Ensure that the Demonstration Board is connected to the PC (via the USB cable) and 

that the board is powered on. 
2. Make sure that all of the Demonstration Board jumpers are set to their factory position 

(see chapter “7.1 Jumpers” for details). 
3. Start CodeWarrior for HCS12(X) Development Studio by selecting it in the Windows 

Start menu. 
4. From the CodeWarrior main menu, choose “File > Open” and choose the “\Program 

Files\Freescale\CodeWarrior for HC12 V4.5\(CodeWarrior 
Examples)\HCS12X\Evaluation Board 
Examples\DEMO9S12XEP100\C\Demo\Demo.mcp” file. 

5. Click “Open”. The Project window will open. 
6. The C code of this example is contained in the “main.c” file. Double click on it to open 

it. 
7. From the main menu, choose “Project > Debug”. This will compile the source code, 

generate an executable file and download it to the demo board. 
8. A new debugger environment will open. From the main menu, choose “Run > 

Start/Continue”. The program will be executed in real-time. 
9. From the main menu, choose “Run > Halt”. The program execution will stop. The next 

instruction to be executed is highlighted in the Source window. 
10. From the main menu, choose “Run > Single Step”. The instruction highlighted in the 

Source window will be executed, and the program execution will be stopped immediately 
after. 

11. From the main menu, choose “Run > Start/Continue”. The application will restart from 
where it was previously stopped. 

  
Congratulations! You have successfully completed this tutorial! You can continue to 
experiment with the CodeWarrior user interface and discover by yourself its potentialities. For 
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an in-depth guide of all of the user interface features, select “Help > CodeWarrior Help” from 
CodeWarrior Development Studio’s main menu.
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7 Summary of Jumper and Connector 
Settings 

7.1 Jumpers 

Name Reference Description/Pinout 

J104 
 

   VAUX ENABLE 
 
Installed: Power the demonstration board 

through the VDD line of the carrier 
board (connects the pin 1 of the J101 
connector to the VDD line of the 
demonstration board) (default) 

Not Installed: The demonstration board is not powered 
by the carrier board. 

J105 
 

XCLKS#=0

CLOCK 

1

CRYSTAL 

 

  

OSC SELECTION 
 
1-2 (“XCLKS#=0”): When inserted, selects full-swing Pierce 

oscillator or external clock; when 
removed, selects a loop-controlled Pierce 
oscillator (default) 

2-3 (“CLOCK”): Clock oscillator selected 
4-5 (“CRYSTAL”): Crystal oscillator selected (default) 

J202 
 

RESET#

BKGD 

1

 

BDM ENABLE 
 
All installed: The USB to BDM interface is enabled 

(default) 
Not Installed: The USB to BDM interface is disabled 

J302 
 

RX 

TX 

1

 

RS-232 ENABLE 
 
All installed: The microcontroller’s PS0/RXD0 and 

PS1/TXD0 lines are routed to the RS-
232 transceiver (default) 

Not Installed: The RS-232 transceiver is not connected 
to the microcontroller 

J305 
 

ENA 

RX 

1

TX 

 

  

LIN ENABLE 
 
All installed: The microcontroller’s PS2/RXD1, 

PS3/TXD1 and PS7/SS0# lines are 
routed to the LIN transceiver (default) 

Not Installed: The LIN transceiver is not connected to 
the microcontroller 
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Name Reference Description/Pinout 

J401 
 

   VDD CAN ENABLE 
 
Installed: Powers the CAN transceiver with the 

VDD voltage (default) 
Not Installed: CAN transceiver not powered 

J402 
 

TX 1

RX 

EN 

ERR# 

STB# 

 

CAN ENABLE 
 
All Installed: The CAN transceiver is connected to 

the microcontroller (default) 
Not Installed: The CAN transceiver is not connected to 

the microcontroller 

J502 
 

1

2

3

 

 

  

POWER SELECTION 
 
1-2 (“UNREG”): The power supply is taken from the 

power supply connector (J501) 
2-3 (“USB”): The power supply is taken from the 

USB connector (default) 

J503 
 

   PUSH-BUTTON “PP0” ENABLE 
 
Installed: The “PP0” push-button is connected 

to the microcontroller’s PP0 line 
(default) 

Not Installed: The “PP0” push-button is not connected 
to the microcontroller 

J504 
 

   PUSH-BUTTON “PP1” ENABLE 
 
Installed: The “PP1” push-button is connected 

to the microcontroller’s PP1 line 
(default) 

Not Installed: The “PP1” push-button is not connected 
to the microcontroller 

J505 
 

   POTENTIOMETER ENABLE 
 
Installed: The “PAD00” potentiometer is 

connected to the microcontroller’s 
PAD00 line (default) 

Not Installed: The “PAD00” potentiometer is not 
connected to the microcontroller 

J506 
 

 PHOTO RESISTOR ENABLE 
 
Installed: The photoresistor network is 

connected to the microcontroller’s 
PAD01 analog input (default) 

Not Installed: The photoresistor network is not 
connected to the microcontroller 
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Name Reference Description/Pinout 

J507 
 

1  

 

DIP-SWITCH ENABLE 
 
Installed: The DIP-switches are connected to 

PB[3..0] ports of the microcontroller 
(default) 

Not Installed: The DIP-switches are not connected to 
the microcontroller 

J508 
 

1  

 

LED ENABLE 
 
Installed: The LEDs are connected to PA[3..0] 

ports of the microcontroller (default) 
Not Installed: The LEDs are not connected to the 

microcontroller 
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7.2 Connectors 

Name Reference Description/Pinout 

J101 
 

1

14 

16 

18 

20 

22 

24 

26 

28 

3

5

7

9

11

13

15

17

19

21

23

25

27

2 

4 

6 

8 

10 

12 

30 

32 

34 

36 

38 

40 

29

31

33

35

37

39  

40-Pin I/O Female Header Connector 1 
 
1. VDD  (5.0 V) 
2. PE1 
3. GND 
4. RESET# 
5. PS1 
6. BKGD 
7. PS0 
8. PP7 
9. PP0 
10. PAD07 
11. PP1 
12. PAD06 
13. PT0 
14. PAD05 
15. PT1 
16. PAD04 
17. PM4 
18. PAD03 
19. PM2 
20. PAD02 
21. PM5 
22. PAD01 
23. PM3 
24. PAD00 
25. PA7 
26. PJ6 
27. PA6 
28. PJ7 
29. PA5 
30. PP2 
31. PA4 
32. PP3 
33. PA3 
34. PP4 
35. PA2 
36. PP5 
37. PA1 
38. PS2 
39. PA0 
40. PS3 
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Name Reference Description/Pinout 

J102 
 

1

14 

16 

18 

20 

22 

24 

26 

28 

3

5

7

9

11

13

15

17

19

21

23

25

27

2 

4 

6 

8 

10 

12 

30 

32 

34 

36 

38 

40 

29

31

33

35

37

39  

40-Pin I/O Female Header Connector 2 
 
1. PB0 
2. PM0 
3. PB1 
4. PM1 
5. PB2 
6. PT2 
7. PB3 
8. PT3 
9. PB4 
10. PK0 
11. PB5 
12. PK1 
13. PB6 
14. PK2 
15. PB7 
16. PK3 
17. PT4 
18. PK4 
19. PT5 
20. PK5 
21. PT6 
22. PK7 
23. PT7 
24. PAD08 
25. PE7 
26. PAD09 
27. PE6 
28. PAD10 
29. PE5 
30. PAD11 
31. PE4 
32. PAD12 
33. PE3 
34. PAD13 
35. PE2 
36. PAD14 
37. GND 
38. PAD15 
39. PE0 
40. PP6 
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Name Reference Description/Pinout 

J103 
 

1

14 

16 

18 

20 

22 

24 

26 

28 

3

5

7

9

11

13

15

17

19

21

23

25

27

2 

4 

6 

8 

10 

12 

30 

32 

34 

36 

38 

40 

29

31

33

35

37

39  

40-Pin I/O Female Header Connector 3 
 
1. PS4 
2. GND 
3. PS5 
4. GND 
5. PS6 
6. GND 
7. PS7 
8. GND 
9. PM6 
10. GND 
11. PM7 
12. GND 
13. PH0 
14. GND 
15. PH1 
16. GND 
17. PH2 
18. GND 
19. PH3 
20. GND 
21. PH4 
22. GND 
23. PH5 
24. GND 
25. PH6 
26. GND 
27. PH7 
28. GND 
29. PJ0 
30. GND 
31. PJ1 
32. GND 
33. PJ6 
34. GND 
35. GND 
36. GND 
37. GND 
38. GND 
39. GND 
40. GND 
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Name Reference Description/Pinout 

J106  

1 2

3

5

4 

6 

 

 

BDM Connector (Not Populated) 
 
1. BKGD 
2. GND 
3. N.C. 
4. RESET/VPP 
5. N.C. 
6. VDD 

J201 

 

USB Connector 
 
1. 5 V DC USB Bus Power Supply Line 
2. USB D- 
3. USB D+ 
4. GND 

J301 

 

69 
5 1  

RS-232 Connector 
 
1. Connected to pins 4 and 6 
2. TX 
3. RX 
4. Connected to pins 1 and 6 
5. GND 
6. Connected to pins 1 and 4 
7. Connected to transceiver for testing purposes 
8. Connected to transceiver for testing purposes 
9. Connected to transceiver for testing purposes 

J303, 
J304 

1  

LIN Connectors 
 
1. GND 
2. GND 
3. 12 V – LIN Bus Power Supply 
4. LIN – LIN Signal 

J403 1

 

CAN Connector 
 
1. CANH 
2. CANL 
3. GND 
4. N.C. 

J501 
1 2

 

 

12 V DC Power Supply Input Connector 
 
1. 12 V DC 
2. Ground 
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8 Troubleshooting 

8.1 USB Driver Problems 

If you connected the Demonstration Board to the PC before installing the SofTec 
Microsystems Additional Components, the Demonstration Board’s USB driver may not have 
been correctly installed on your system. Unplugging and replugging the USB cable is of no 
use, since Windows has marked the device as “disabled”. As a consequence, the PC cannot 
communicate with the Demonstration Board. 
To restore the USB driver (provided the SofTec Microsystems Additional Components have 
been installed), perform the following steps under Windows XP: 
 
1. Connect the Demonstration Board to the PC. 
2. Open the Control Panel (Start > Settings > Control Panel). 
3. Open  the “System” options. 
4. Select the “Hardware” tab. 
5. Click the “Device Manager” button. 
6. The “uDART In-Circuit Debugger” device will be shown with an exclamation mark next 

to it. Double click on this device. 
7. In the “General” tab, click the “Reinstall Driver” button. Follow the on-screen 

instructions. 

8.2 Communication Problems between the PC and the 
Demo Board 

1. Make sure that both the “BKGD” and “RESET#” jumpers are inserted. 
2. Make sure that the “POWER SEL” jumper selects the appropriate power source 

(typically “USB” when the board is connected to the PC). 
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