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a  WARNING a
Thank you for purchasing automation equipment from Automationdirect.com™, doing business as,
AutomationDirect. We want your new automation equipment to operate safely. Anyone who installs
or uses this equipment should read this publication (and any other relevant publications) before
installing or operating the equipment.

To minimize the risk of potential safety problems, you should follow all applicable local and national
codes that regulate the installation and operation of your equipment. These codes vary from area to
area and usually change with time. It is your responsibility to determine which codes should be
followed, and to verify that the equipment, installation, and operation is in compliance with the latest
revision of these codes.

At a minimum, you should follow all applicable sections of the National Fire Code, National Electrical
Code, and the codes of the National Electrical Manufacturer's Association (NEMA). There may be
local regulatory or government offices that can also help determine which codes and standards are
necessary for safe installation and operation.

Equipment damage or serious injury to personnel can result from the failure to follow all applicable
codes and standards. We do not guarantee the products described in this publication are suitable for
your particular application, nor do we assume any responsibility for your product design,
installation, or operation.

Our products are not fault-tolerant and are not designed, manufactured or intended for use or resale as
on-line control equipment in hazardous environments requiring fail-safe performance, such as in the
operation of nuclear facilities, aircraft navigation or communication systems, air traffic control, direct
life support machines, or weapons systems, in which the failure of the product could lead directly to
death, personal injury, or severe physical or environmental damage ("High Risk Activities").
AutomationDirect specifically disclaims any expressed or implied warranty of fitness for High Risk Activities.

For additional warranty and safety information, see the Terms and Conditions section of our catalog. If
you have any questions concerning the installation or operation of this equipment, or if you need
additional information, please call us at 770-844-4200.

This publication is based on information that was available at the time it was printed. At
AutomationDirect we constantly strive to improve our products and services, so we reserve the right to
make changes to the products and/or publications at any time without notice and without any
obligation. This publication may also discuss features that may not be available in certain revisions of
the product.

Trademarks
This publication may contain references to products produced and/or offered by other companies.
The product and company names may be trademarked and are the sole property of their respective
owners. AutomationDirect disclaims any proprietary interest in the marks and names of others.

Copyright 2004, Automationdirect.com™ Incorporated, All Rights Reserved
No part of this manual shall be copied, reproduced, or transmitted in any way without the prior,
written consent of Automationdirect.com™ Incorporated. AutomationDirect retains the exclusive
rights to all information included in this document.
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a  AVERTISSEMENT a
Nous vous remercions d'avoir acheté l'équipement d'automatisation de Automationdirect.comMC. Nous
tenons à ce que votre nouvel équipement d'automatisation fonctionne en toute sécurité. Toute personne qui
installe ou utilise cet équipement doit lire la présente publication (et toutes les autres publications pertinentes)
avant de l'installer ou de l'utiliser.

Afin de réduire au minimum le risque d'éventuels problèmes de sécurité, vous devez respecter tous les codes
locaux et nationaux applicables régissant l'installation et le fonctionnement de votre équipement. Ces codes
diffèrent d'une région à l'autre et, habituellement, évoluent au fil du temps. Il vous incombe de déterminer les
codes à respecter et de vous assurer que l'équipement, l'installation et le fonctionnement sont conformes aux
exigences de la version la plus récente de ces codes.

Vous devez, à tout le moins, respecter toutes les sections applicables du Code national de prévention des
incendies, du Code national de l'électricité et des codes de la National Electrical Manufacturer's Association
(NEMA). Des organismes de réglementation ou des services gouvernementaux locaux peuvent également vous
aider à déterminer les codes ainsi que les normes à respecter pour assurer une installation et un
fonctionnement sûrs. 

L'omission de respecter la totalité des codes et des normes applicables peut entraîner des dommages à
l'équipement ou causer de graves blessures au personnel. Nous ne garantissons pas que les produits décrits
dans cette publication conviennent à votre application particulière et nous n'assumons aucune responsabilité à
l'égard de la conception, de l'installation ou du fonctionnement de votre produit.

Nos produits ne sont pas insensibles aux défaillances et ne sont ni conçus ni fabriqués pour l'utilisation ou la
revente en tant qu'équipement de commande en ligne dans des environnements dangereux nécessitant une
sécurité absolue, par exemple, l'exploitation d'installations nucléaires, les systèmes de navigation aérienne ou
de communication, le contrôle de la circulation aérienne, les équipements de survie ou les systèmes d'armes,
pour lesquels la défaillance du produit peut provoquer la mort, des blessures corporelles ou de graves
dommages matériels ou environnementaux («activités à risque élevé»). La société Automationdirect.comMC
nie toute garantie expresse ou implicite d'aptitude à l'emploi en ce qui a trait aux activités à risque élevé.

Pour des renseignements additionnels touchant la garantie et la sécurité, veuillez consulter la section Modalités
et conditions de notre documentation. Si vous avez des questions au sujet de l'installation ou du
fonctionnement de cet équipement, ou encore si vous avez besoin de renseignements supplémentaires,
n'hésitez pas à nous téléphoner au 770-844-4200.

Cette publication s'appuie sur l'information qui était disponible au moment de l'impression. À la société
Automationdirect.com, nous nous efforçons constamment d'améliorer nos produits et services. C'est
pourquoi nous nous réservons le droit d'apporter des modifications aux produits ou aux publications en tout
temps, sans préavis ni quelque obligation que ce soit. La présente publication peut aussi porter sur des
caractéristiques susceptibles de ne pas être offertes dans certaines versions révisées du produit.

Marques de commerce
La présente publication peut contenir des références à des produits fabriqués ou offerts par d'autres
entreprises. Les désignations des produits et des entreprises peuvent être des marques de commerce et
appartiennent exclusivement à leurs propriétaires respectifs. Automationdirect.comMC nie tout intérêt dans
les autres marques et désignations.

Copyright 2004, Automationdirect.com™ Incorporated, Tous droits réservés
Nulle partie de ce manuel ne doit être copiée, reproduite ou transmise de quelque façon que ce soit sans le
consentement préalable écrit de la société Automationdirect.com™ Incorporated. Automationdirect.com™
conserve les droits exclusifs à l'égard de tous les renseignements contenus dans le présent document.
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a  ADVERTENCIA a
Gracias por comprar equipo de automatización de Automationdirect.com™. Deseamos que su nuevo
equipo de automatización opere de manera segura. Cualquier persona que instale o use este equipo debe
leer esta publicación (y cualquier otra publicación pertinente) antes de instalar u operar el equipo.

Para reducir al mínimo el riesgo debido a problemas de seguridad, debe seguir todos los códigos de
seguridad locales o nacionales aplicables  que regulan la instalación y operación de su equipo. Estos códigos
varian de área en área y usualmente cambian con el tiempo. Es su responsabilidad  determinar cuales
códigos deben ser seguidos y verificar que el equipo, instalación y operación estén en cumplimiento con la
revisión mas reciente de estos códigos.

Como mínimo, debe seguir las secciones aplicables del Código Nacional de Incendio, Código Nacional
Eléctrico, y los códigos de (NEMA) la Asociación Nacional de Fabricantes Eléctricos  de E.E.U.U.. Puede
haber oficinas de normas locales o del gobierno que pueden ayudar a determinar cuales códigos y normas
son necesarios para una instalación e operación segura.

Si no se siguen todos los códigos y normas aplicables, puede resultar en daños al equipo o lesiones serias a
personas.  No garantizamos los productos descritos en esta publicación para ser adecuados para su
aplicación en particular, ni asumimos ninguna responsabilidad por el diseño de su producto, la instalación
u operación.

Nuestros productos no son tolerantes a fallas y no han sido diseñados, fabricados o intencionados para uso
o reventa como equipo de control en línea en ambientes  peligrosos que requieren una ejecución sin fallas,
tales como operación en instalaciones nucleares, sistemas de navegación aérea, o de comunicación, control
de trafico aéreo,  máquinas de soporte de vida o sistemas de armamentos en las cuales la falla del producto
puede resultar directamente en muerte, heridas personales, o daños físicos o ambientales severos
("Actividades de Alto Riesgo").  Automationdirect.com™ específicamente rechaza cualquier garantía ya
sea expresada o implicada para actividades de alto riesgo.

Para información adicional acerca de garantía e información de seguridad, vea la sección de Términos y
Condiciones de nuestro catalogo.  Si tiene alguna pregunta sobre instalación u operación de este equipo, o
si necesita información adicional, por favor llámenos al  número 770-844-4200 en Estados Unidos.

Esta publicación está basada en la información disponible al momento de impresión.  En
Automationdirect.com™ nos esforzamos constantemente para mejorar nuestros productos y servicios, así
que nos reservamos el derecho de hacer cambios al producto y/o a las publicaciones en cualquier momento
sin notificación  y sin ninguna obligación.  Esta publicación también puede discutir características que no
estén disponibles en ciertas revisiones del producto.

Marcas Registradas
Esta publicación puede contener referencias a productos producidos y/u ofrecidos por otras
compañías.  Los nombres de las compañías y productos pueden tener marcas registradas y son
propiedad única de sus respectivos dueños.  Automationdirect.com™, renuncia cualquier
interés propietario en las marcas y nombres de otros.

Propiedad Literaria 2004, Automationdirect.com™ Incorporated
Todos los derechos reservados

No se permite copiar, reproducir, o transmitir de ninguna forma ninguna parte de este manual sin previo
consentimiento por escrito de Automationdirect.comTM Incorprated.  Automationdirect.comTM retiene
los derechos exclusivos a toda la información incluida en este documento. Los usuarios de este equipo
pueden copiar este documento  solamente para instalar, configurar y mantener el equipo correspondiente.
Puede ser usado también para propósitos de educación en institutos de enseñanza.
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AUTOMATIONDIRECT.COM END USER LICENSE
AGREEMENT AND LIMITED WARRANTY

The software accompanying this license agreement (the Software)
is the property of AutomationDirect.com, or its suppliers, and is
protected by United States and International Copyright laws and
International treaty provisions.  No ownership rights are granted
by this Agreement or possession of the Software.  Therefore, you
must treat the Licensed Software like any other copyrighted
material (e.g., a book or musical recording), except that you may
make a single copy for backup or archival purposes.  Your rights
and obligations in its use are described as follows:

1. You may use and display this software on a single computer.

2. You may make one copy of the software for archival purposes or
you may copy the software onto your hard disk and hold the original
for archival purposes.

3. You may not modify or attempt to reverse engineer the software, or
make any attempt to change or even examine the source code of the
software.

4. You may transfer the software to another computer using the
utilities provided.  However, the software must be used on only a
single computer at one time.

5. You may not give or distribute copies of the software or written
materials associated with the software to others.

6. You may not sub-license, sell, or lease the software to any person or
business.

Return Policy

The original licensee of the software can return it within thirty
(30) days of purchase.  Please call us for a Return Material
Authorization Number.

Limited Warranty

AutomationDirect.com does not warrant that the Software will
be error free, that it will satisfy your planned applications or that
all defects in the Software can be corrected. 
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If  AutomationDirect.com provides information or assistance
regarding the use of the Software or otherwise,
AutomationDirect.com is not assuming the role of engineering
consultant.  AutomationDirect.com disclaims responsibility for
any errors or omissions arising in connection with engineering in
which its Software or such information or assistance is used.

The foregoing is the sole and exclusive warranty offered by
AutomationDirect.com.

AutomationDirect.com disclaims all other warranties, express or
implied, including but not limited to the implied warranties of
merchantability and fitness for a particular purpose, with regard
to the licensed software and all accompanying materials.

In no event shall AutomationDirect.com be liable for incidental
or consequential damages, including lost profit, lost savings, lost
opportunities, or other incidental or consequential damages
arising out of the use or inability to use the licensed software,
even if AutomationDirect.com has been advised of the possibility
of such damages.

AutomationDirect.com's entire liability shall be, at
AutomationDirect.com's option, either (a) return of the price
paid for the Software (or component), or (b) repair or
replacement of the Software (or component) that does not meet
AutomationDirect.com's Limited Warranty and which is
returned to AutomationDirect.com within the warranty period.
This shall be the sole and exclusive obligation of
AutomationDirect.com and your sole and exclusive remedy with
respect to any such failure.  The Limited Warranty is void if
failure of the Software (or component) has resulted from
accident, abuse or misapplication.

Trademarks

Microsoft® and Microsoft Excel® are registered trademarks,
Windows™ is a trademark of Microsoft Corporation.
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1.0 Introduction
DataLynx provides an easy and inexpensive way to collect
data from your PLCs. The DataLynx Server stores the
information it gathers onto your PC into either a comma or
tab delimited text file(s). These files can be created on a
daily, monthly or yearly basis. The data can be opened in
Excel, NotePad or a program of your choice. At this point,
you can save the files or print the data.

DataLynx  is unique in that it uses a phone line and modems
compared to more expensive ethernet lines. It is ideal for
long distances where the location is not easily accessible and
not economical to visit the PLC and retrieve data.

System Requirements

Hardware Required 

Pentium II with 128 megabytes of ram and 10 megabytes of 
hard disk space free

PLC which supports Modbus serial

Modems for PLC and PC

Software Required 

The Server can run on Windows NT (SP5 or higher), 
2000 or XP 

The Monitor can run on Windows 98, NT, 2000 or XP
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2.0 Installation of DataLynx 

Before you start, ensure that the PLC(s) and Server/Monitor
computer(s) are connected to the network.

Decide what type of installation you want:

1. Server and Monitor on Same Computer
a. May be the only option if only one computer is available.
b. If hosting the Server and Monitor on different computers, users

may install both the Server and Monitor on the Server for quick
installing and configuring.

2. Server and Monitor on Different Computers
a. Ideal when the physical location of the Server is not easily

accessible.
b. Must note the IP Address or name of the Server.

DataLynx  software is available on the AutomationDirect
Product Showcase CD. To install DataLynx, insert the
AutomationDirect CD into your PC’s CD drive. The CD
should start automatically and open the installation window
shown below.

Note:
If the AutomationDirect CD
does not start automatically, go
to your WindowsTM START
button, select RUN, and type:

E:\setup.exe

Change the letter “E” to
correspond to the letter for
your CD drive. Then click on
“OK,” and the program will
start.

Click on “DataLynx.” 
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Read and make sure you understand the license agreement.

To start the installer program, click “Next.”
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After reading and understanding the license agreement,
check the "Yes, I agree with the terms of this license
agreement" option, and click “Next.”

The next screen contains important readme information
that may be pertinent to you. After reading the “Readme”
information, click the “Next” button.
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Next, a prompt for the setup type will appear.  There are
three types: Monitor, Server, and Server and Monitor.  If a
type in the list is selected, a description of the type will
appear on the right hand side labeled "Description."
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After it is determined which type of setup is wanted, click
“Next,” and a prompt to save the DataLynx files will appear.
By default the files will save into c:\Program
Files\DataLynx\, but the location of the DataLynx files can
be changed by clicking on the “Browse…”  button.

After the location of the files has been determined, click
“Next,” and a prompt for the program group will appear.
By default, the program group is DataLynx, but the program
group may be changed by entering it in the text box.
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Click “Next,” and a prompt will appear to start the
installation process.  It is possible to click the “Back” button
and review the installation settings before  committing to
the install.  When satisfied with the installation settings,
click the “Next” button.
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After clicking the “Next” button, a progress meter will
appear indicating install progress.

The installation can always be stopped by clicking the
“Cancel” button.

After the install is complete, a notification will appear to
confirm that installation has been successful. Click "Finish"
to exit the DataLynx  installer.
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3.0 Registration
Registration Instructions:

• Ensure that the Server is running.
• Start the Monitor and connect to the Server.
• Go to Help -> Registration: 

With your browser go to the following web site:
http://www.bizwaredirect.com/datalynxregistration.aspx
and paste the registration key into the Key: field in the
web form.  Also enter the serial number, which is located
on the back of the CD cover, and the order number.

In the registration window, copy the registration key by
selecting the key, pressing the right mouse button and
selecting “Copy.”
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Click the "Create Registration" button.  If the
information has been entered correctly, the assigned key
will appear:

Copy the assigned key and paste into the DataLynx
Monitor Registration screen by pressing the right mouse
button and selecting “Paste.”

• Click the "Register" button.
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• Click "OK"

A success message and the registration window will show
registration status: 
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4.0 Modem Connectivity
To ensure successful communication, at least two modems
are required. One modem is needed for the PLC, and one
modem is needed for the PC. Each PLC brand typically has
a different set of requirements and procedures. Generally, an
ideal modem would support parity and a baud rate of at
least 56K to ensure fast and reliable connections. Please refer
to the PLC’s documentation on configuring modem
connectivity with the PLC.

Modbus Serial must be supported on the PLC. When
configuring DataLynx on what addresses to read, please take
care in converting the modbus address into the PLC’s native
memory addressing scheme.

4.1 Testing Modem Configuration
To aid in configuring and troubleshooting the modem
connections, use Hyperterminal and manually connect to
the PLC’s modem from the PC’s modem. The PLC does
NOT need to be connected to the modem. This test
confirms that the modems can communicate with each
other. To run the test, complete the following steps:

1. Start Hyperterminal by going to Start->Program Files-
>Accessories->Communications->Hyperterminal

2. In Hyperterminal, the user will be prompted for a session
name, enter the desired session name, e.g. “Test Modem.”

3. Next, the user will be prompted for the connection settings -
select the PC modem’s COM Port and configure the necessary
settings.

4. Click “OK.”

5. To confirm that the modem is working, enter “AT.” An “OK”
message should appear from Hyperterminal.
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6. If  the “OK “ appears, test the dialing by entering
ATDTYYYY where YYYY is the phone number.

a. Ex: ATDT2555678 to dial 255-5678

7. Depending on the modem connection and the phone line, it
may take a few minutes before receiving feedback.

a. If successful,  “Connected XXXXX bps,,” where 
XXXXX is the baud rate, should appear.

b. If not successful, an error like one of the following will
be received: “BUSY,” “NO DIALTONE,” “NO   
CARRIER,” etc.

4.2 Example Setup for
AutomationDirect PLCs

The information below illustrates the configuration used for
testing DataLynx:

PLC: DL05

Modem for PLC: MDM-TEL Modem

See the MDM-TEL setup wizard for configuration 
information.

Modem for PC: Toshiba Software Modem

DL05 PLC configured with the following:

1. Port 2 Setup
a. Modbus Serial
b. Parity = 0 (zero)

2. Modem Connected to Port 2



14

DataLynx User Manual

5.0 DataLynx PLC

5.1 Server

Overview 

The DataLynx Server's primary function involves dialing up
to PLC(s) and recording the data into text files in the format
specified by the user.

The format of the text file is set with the DataLynx Monitor.
For more information on configuring the Server with the
Monitor, refer to the Monitor section. 

5.1.1 Installing Service
The DataLynx Server needs to be installed and run in order
to run without user intervention.  Doing so is a simple
process. Go to: Start Button -> Program Files -> DataLynx -
> DataLynx Server
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This window should appear
showing “Status” as
Installed, Stopped.

Note: This does not start the
DataLynx Server. To start the
Server, refer to the Running
Service section.

Click the "Install" button.
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5.1.2 Running Service
If you do not already have the DataLynx Server Window
open, go to: Start Button -> Program Files -> DataLynx ->
DataLynx Server 

This window will appear
assuming DataLynx is not
installed. Click the
"Start/Continue" button.

Note: It may take a couple of
minutes for the Server to start
running.
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5.1.3 Pausing 
Pausing forces the Server to stop polling for PLC input. This
can be useful when configuring the Server because it will
prevent irrelevant data from being stored.

If you do not already have the DataLynx Server Window
open, go to: Start Button -> Program Files -> DataLynx ->
DataLynx Server

This window will appear -
Assuming Running
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Click the "Pause (Stop
Listening)" button, and
this window should
appear

Note: This does not stop
the DataLynx Server. To
stop the Server refer to the
Stopping section

5.1.4 Stopping 
Stopping the DataLynx Server completely stops the
program, instead of stopping polling. This feature is useful
because the Server must stop before you can uninstall it. 

If you do not already have the DataLynx Server Window
open, go to: Start Button -> Program Files -> DataLynx ->
DataLynx Server 
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In the DataLynx Server
Window, click the "Stop"
button, and this window
should appear.

5.1.5 Diagnosing 
Diagnosing the DataLynx Server allows the user to
troubleshoot and view real-time events. 

If the DataLynx Server Window is not open, go to: Start
Button -> Program Files -> DataLynx -> DataLynx Server
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In the DataLynx Server Window, go to the menu: 

File->Error Log

The Diagnostics Window below should appear.
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5.1.6 Uninstalling 
For troubleshooting reasons, it is a good idea to uninstall the
Server entirely.  

To open the DataLynx Server Window, go to:   Start Button
-> Program Files -> DataLynx -> DataLynx Server

Click on the "Uninstall"
button, and this window
should appear.
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5.2 Monitor

Overview

The DataLynx Monitor allows the user to configure the
DataLynx Server and retrieve its data files over the network.
Also, the DataLynx Monitor permits the user to
troubleshoot. Below is the main screen and the explanations
of each field:

Server Address: Field where one enters the address of the
DataLynx Server

Last Update: Denotes the most recent PLC input time

Status: Displays the Server's locked and listening state

Modem(s): Displays list of currently configured modems on
the Server as well as each modem’s status

Note: Modems only lists the last update. Check the date to verify if
you are receiving information when expected.

Messages: Displays updates from the Server as well as from
the Monitor itself
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5.2.1 Configuring

Note: The Server must be connected in order to configure the
Server.

A list of modems, if any, configured for the Server will
appear.

Go to the menu:
Options -> Configure
Server
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To add a modem, click on the "Add" button, and  a Modem
Configuration screen like the following will appear.

Below is an explanation of each of the Modem’s
Configuration Window's fields:

Alias: Optionally, a more descriptive name for the modem,
e.g., “My PC's Modem”

COM Port: The port the modem will use 

Baud Rate: The speed that the modem will connect at

Parity: Parity that the modem will use; “none” is the default
parity and is preferred for most modems.

# Retries: Number of times DataLynx will try to read data
before it reports an error
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Below is an explanation of each of the Phone Number’s
Configuration fields:

Phone Number: The phone number DataLynx is to dial

Data Directory: Where the data files will be stored

Alias: Optional, a more descriptive name of the phone
number, e.g., “Plant One in Atlanta”

Use Alias in Filename: Configures DataLynx to use the alias
in the data logged file name

New Data file Cycle: Configures DataLynx’s new file
creation cycle

Field Separation: Configures either tab or comma to be
used in separating individual fields

Log Phone Number: Configures DataLynx to log the phone
number in the data file

Log Alias: Configures DataLynx to log the alias in the data
file

Display header for fields: Configures DataLynx to log the
headers in the first line of the data file

Log Timestamp in Data Files: Configures DataLynx to log
the date and time in the data file

Example Filename: Illustrates an example file name given
the current configuration

Archiving and Deleting:

Archive Files Cycle: Configures DataLynx to archive
monthly/yearly. Archives by zipping files into a zip file.

Archived Files Directory: Where the zipped files will be stored

Delete Files Cycle: How often DataLynx will delete the files

Modbus: Station #- the station # configured in the PLC
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Diagnostics: One-Dial Test: Allows the user to perform a
trial dial up and poll to confirm that the configuration will
work

Poll Interval:

Timed Interval: allows the user to specify the poll to occur at
specific timed intervals

Note: If you have multiple phone numbers, each poll will dial each
of the phone numbers at the poll interval.  In contrast, if each
phone number had an individual poll interval, there eventually
would be a conflict in poll times.

Day Interval: Allows the user to specify the poll to occur at
certain days and times

Fields: User-entered fields that DataLynx will request when
polling
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5.2.2 Modifying a Modem

To modify a modem, go to menu: 

Options-> Configure Server

A list of modems, if any, configured for the Server will
appear:
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Click on the "Modify/View" button, and a Modem
Configuration screen will appear with the PLC data. 

The Modem Configuration window below is an example:

Once finished making changes, click the "OK" button or
"Cancel" to discard your changes.
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5.2.3 Deleting

To delete modems, go
to menu:  Options-
>Configure Server

A list of modems, if any, configured for the Server will
appear:

Select the modem to delete and click the "Delete" button.
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5.2.4 Duplicating
A modem listing may be created and duplicated. This
duplicating option is a great time-saving feature for those
with many modems with similar configurations.  

To duplicate a modem
listing, go to menu:
Options ->Configure
Server

A list of modems, if any, configured for the Server will
appear.

Click the "Duplicate" button, and a window will appear
asking for COM Port, Alias , Baud Rate, Parity, and #
Retries. Enter the necessary information and click “OK” to
save changes, otherwise click “Cancel” to discard changes.
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5.2.5 Connecting
Connecting to a DataLynx Server is important because it
allows the user to configure the DataLynx Server and
retrieve its data files. 

In the main screen portion labeled Server Address: enter the
Address.

Then press the "Connect" button.   If the connection has
been made, the "Connect" button text will become
"Disconnect."
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5.2.6 Hiding
Hiding is a convenient feature for temporarily placing the
Monitor out of view for later access. To hide the Monitor,
go to the menu: File->Hide

Notice that the DataLynx icon
appears on the task bar:

Conversely, the application may be restored by right clicking
on the icon and selecting the "Restore" item:
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5.2.7 Backing Up and Restoring

Backing Up
Backing up the configuration allows the user to safely restore
all changes in the event of a hardware failure. To back up the
configuration, go to the menu: Tools->Backup
Configuration

You will be prompted for a filename. Click "Save" and note
where you saved the file for a possible future restoration.

Restoring
To restore the configuration, go to the menu: Tools->
Restore Configuration The following window should
appear.

You will be prompted for a filename. Click "Open" and the
Server/Monitor should be restored to its original state.
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5.2.8 Polling
The DataLynx  Server maintains "polling" and "not polling"
states for PLC input.  The user may change the polling state
from the Monitor as well as from the Server program.

Changing the polling state can be useful when in the process
of installing new PLCs or changing the PLC configuration
to prevent the Server from receiving irrelevant data.

Click on the "Start Polling" button (If the button states
"Stop Polling" that means the Server is already listening).

To Make the Server Stop Polling, click on the “Stop
Polling” button.

If successful, the status  should now read "Polling Modems."

If successful the status should now read "Not Polling
Modems."
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5.2.9 Locking / Unlocking
Locking/Unlocking is a useful feature for preventing
unwanted modem configurations and Server polling state
changes.  Steps to lock/unlock are below:

Click the "Lock"
button.

A screen will appear
asking for the lock
code.

Enter the lock code, and Click "OK." If successful, the
status section should now display a locked status:

Warning: If you forget/lose the lock code  you will NOT be able to
unlock the Server.

Conversely, to unlock the Server, click the "Unlock" button,
enter the code, and Click "OK.”
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5.2.10 Reporting
Reporting is one of the most useful features of the Monitor.
The user may view or save files generated by the Server over
a network without having physical access to the Server.

To view a report, go to menu:
Tools -> Report

A report screen like the following dialog box should
appear:



37

DataLynx User Manual

Select the desired PLC data you wish to view in the
modem/phone number list:

Now select a file in the File(s) list and click either the
"Open,” "Open With..." or the "Save" button. There is a
difference between the "Open" and "Open With...."
buttons. "Open" uses the default application to open the
file. "Open With..." prompts you for the application in
which to open the file.

Note: If you open the current log file outside of DataLynx (Example:
log file straight from Excel), it will lock the file and not allow
DataLynx to store data.
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6.0 Troubleshooting / Miscellaneous

Cannot Connect to Server 

Double check the Server Address - it may not be correct. 

Verify that the Server and Monitor computers are online
and can access network facilities such as e-mail and Internet. 

Ensure that cables are connected. 

Verify that computers can access the Internet by going to a
test web site such as www.yahoo.com.

Invalid COM Port Error

Confirm that the COM Port # is correct for the modem.

Poll Keeps Failing (Error Reading Data) 

Confirm that modbus serial is enabled on the PLC.

Confirm that modem is properly configured to
communicate with the PLC.

Poll Is Not Occurring at Specific Intervals

Because the dialing and polling usually takes more than one
minute, the timed intervals may not occur at the correct
time. Try extending the poll intervals to ensure that they
will occur on more reliable intervals.




