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1: Introduction 

Welcome!  
Welcome to the new release of the IDEXX Cornerstone* 8.1 
Practice Management System. This release includes a 
number of user-requested enhancements, ease-of-use 
improvements and new functionality to help grow your 
practice.  

New Features in Cornerstone 8.1 

• Vital Signs – Staff can now record vital signs and access them throughout Cornerstone in all areas 
where patient weight has traditionally been displayed. This allows you to review all historical vital 
signs in one location and easily identify changes in a patient’s health through comparative trending 
and graphing. 

• Signatures on Estimates – Helping you move toward a paper-light practice, Cornerstone 8.1 allows 
clients to view an on-screen estimate and electronically sign the estimate using a supported 
signature capture device or tablet PC. 

• Payment Solutions – Offering a simple and secure solution for integrated credit card processing, 
Cornerstone 8.1 works with a third-party payment processing software provider to process credit 
and debit card transactions through an Internet connection. 

• Laboratory Features – Several new laboratory features improve the way you view and manage 
results and requests in Cornerstone—generate or schedule laboratory call backs on the Daily 
Planner’s new Diagnostics tab, and save time by viewing a single IDEXX Lab Report that includes all 
results for a laboratory request. Cornerstone 8.1 also includes support for the IDEXX ProCyte Dx* 
Hematology Analyzer.  

• Imaging Enhancements – Cornerstone 8.1 helps increase integration within the practice, allowing 
practitioners to manage multiple modalities and centrally store all patient imaging information, such 
as ultrasound and digital dental. The release also introduces an improved radiology log based on 
AAHA standards. 

• System Support – Cornerstone 8.1 supports the Windows® 7 Professional 64 bit and Windows 
Server® 2008 R2 Standard and Enterprise operating systems. 

• Other Features – Additional enhancements include the ability to void a medical note; print a 
practice logo on estimates, invoices and statements; include pet pictures on IDEXX Reminder 
Service cards; and more. 
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Getting Started 
To help ensure a smooth transition to your new IDEXX Cornerstone 8.1 Practice Management System, 
we recommend using the following resources in the order listed below.  

1 Release Implementation Plan 
Get started by reviewing a checklist of all pre-installation tasks 
to help you prepare for and take advantage of the new 
features in this release. 

2 IDEXX Cornerstone 8.1 Highlights 
This overview presentation walks you through the new 
features and enhancements in Cornerstone 8.1, highlighting 
improvements for everyone on your team. 

3 What’s New View detailed information on setting up and using the new 
features and functionality in this release. 

4 
 
Installation Guide (this document) 
 

Review hardware/operating system guidelines and follow the 
recommended steps for installation. 

5 
 
Release Implementation Plan 
 

Reference this plan once again to review post-installation 
tasks, including security setup and defaults configuration. 

 
These resources are available on the Cornerstone Resource CD, which is included in your Cornerstone 
8.1 installation/upgrade package. To locate these resources on the CD, go to the Upgrading 
Cornerstone area, then select the appropriate “upgrade path” for your practice.  
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2: Hardware and Operating System Guidelines 

For optimal Cornerstone performance, please ensure that your system meets the recommended 
specifications provided in this chapter. This will ensure the best possible operating speed and level of 
efficiency when using the Cornerstone Practice Management System. 

Note: Cornerstone software may function when using a computer with less than the recommended 
specifications. If concerned that your current system may not operate at expected levels of performance, 
please contact IDEXX Cornerstone Support at 1-800-695-2877. 

General Recommendations 

Business Class Computers, 
Printers and Peripherals 

IDEXX recommends business class computers, printers and peripherals to 
ensure the best performance, reliability and warranty. Business class devices 
are available from manufacturers like Dell™ and include components, 
configuration options and a warranty designed to meet the needs of a 
demanding business environment. 

Network 

IDEXX recommends computers and switches capable of Gigabit speed with 
a wired connection. (A wired connection will always provide a faster and 
more stable Cornerstone experience.) A wireless connection should be used 
only for mobile computers. 

Antivirus (Malware Protection) 

IDEXX recommends antivirus software that does not use a software firewall 
(or offers the option of turning off the software firewall). For security 
purposes, IDEXX recommends a hardware firewall (included with most 
routers) instead of a software firewall. 

Monitor Resolution 
IDEXX recommends 1024×768 or 1280×800 resolution for optimal viewing 
of the Cornerstone software. 

Cornerstone Backup Verification 
Assistant 

The Cornerstone Backup Verification Assistant requires one of the following 
types of backup software: Backup4all, Backup Exec™, Backup MyPC™, PC 
Backup, TapeWare® or IDEXX VetVault* Backup Solution. 

Windows 98 and Windows NT 

Cornerstone software will not install on a computer that uses Windows® 98 or 
Windows® NT operating systems. If your practice still uses Windows 98 or 
Windows NT, please call 1-800-283-8386, option 2, to discuss your upgrade 
options. 

Windows Vista Business 32 bit 
and Ultimate 32 bit 

Windows Vista® requires Cornerstone 7.6 or later for workstations and 
Cornerstone 8.0 or later for peer-to-peer servers. 

Windows 7 Professional 64 bit 
and Windows Server 2008 R2 

Windows® 7 and Windows Server® 2008 R2 require Cornerstone 8.0 Service 
Pack 2 or later. 
Note: Some compatibility issues have been identified for using certain third-
party applications and devices with these operating systems. PDF 
documents detailing these issues are available on the Specifications & 
Hardware tab at idexx.com/cornerstonespecifications. 

http://www.idexx.com/cornerstonespecifications�
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Hardware and Operating System Recommendations 

Peer-to-Peer Servers and Stand-Alone Computers 

Peer-to-Peer Servers allow up to 6 thick-client workstations and run a non-server operating system. 

Operating System 
° Windows XP Professional 

° Windows 7 Professional 64 bit 

Processor Multi-core Intel® processor or AMD processor† 

Hard Drive 250 GB 

Memory 2 GB 

Backup Device 
° DVD-RW 

° Removable Disk Drive (RD1000) 

° IDEXX VetVault 

† Excluding Intel® Celeron® and AMD Sempron™ processors 

 

Dedicated Servers 

Dedicated Servers allow for 7 or more workstations and run a server operating system. A Dedicated 
Server should not be used as a Cornerstone workstation. 

Operating System 
° Windows Server 2003 

° Windows Server 2008 R2 Standard/Enterprise 

Processor Multi-core Intel Xeon or AMD Opteron 

Hard Drive 250 GB‡ 

Memory 4 GB§ 

Backup Device 
° Tape Backup (LTO) 

° Removable Disk Drive (RD1000) 

° IDEXX VetVault 

‡ Servers that will be storing digital images may require more hard drive and backup space depending on usage. 

§ Servers that will be running Remote Desktop Services (formerly known as Terminal Services) may require more 
memory depending on usage and the number of thin-client workstations. 
 

Thick-Client Workstations (Including Laptop and Tablet Computers) 

Thick-clients are workstations that run Cornerstone locally. 

Operating System 
° Windows XP Professional 

° Windows 7 Professional 64 bit 

Processor Multi-core Intel processor or AMD processor†† 

Hard Drive 60 GB 

Memory 2 GB 

†† Excluding Intel Celeron and AMD Sempron processors 
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Thin-Client Workstations  

Thin-clients, also known as terminals, are workstations that run Cornerstone on the server using a 
Remote Desktop Connection. Thin-clients are not recommended for viewing digital images. 

Operating System 
° Windows XP Embedded or Windows XP Home 

° Windows 7 Home Premium 

Processor Intel Celeron, Intel Atom™ or AMD Sempron 

Memory 512 MB 

 

Tip: For updates on Cornerstone system recommendations, go to 
idexx.com/cornerstonespecifications and select the Specifications & Hardware tab. 

 

Evaluating Your Current System Configuration 
If you are using a Dell computer system, we provide access to Dell’s online tool to quickly analyze your 
system and help you determine if your system meets the hardware requirements for this release of 
Cornerstone software.  

To use this tool, look for the Dell System Analyzer link located within the Evaluating your system 
configuration section on the Specifications & Hardware tab at idexx.com/cornerstonespecifications. 

Tracking Your Hardware and Software Performance 
The IDEXX Monitor* Cornerstone* Dashboard report tracks hardware and software performance to help 
practices ensure that Cornerstone operates smoothly and efficiently. The Cornerstone Dashboard report 
is a free monthly report available to IDEXX Cornerstone users who have enabled the data services 
agreement in Cornerstone (on the Tools menu, select Data Services Agreement). 

To register for the IDEXX Monitor Cornerstone Dashboard report or for more information, call  
1-888-557-6517. 

 

http://www.idexx.com/cornerstonespecifications�
http://www.idexx.com/cornerstonespecifications�
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3: Pre-Installation Information 

Installation Notes 
• Installation may take from several minutes to over an hour, depending on your computer 

configuration, database size and current Cornerstone version. 

• If you are upgrading from an older version prior to Cornerstone 5.6, call IDEXX Cornerstone 
Support (1-800-695-2877) to receive alternate upgrade instructions. 

• If you are using the Mobile Computing module, see “6: Installation for the Mobile Computing 
Module” on page 19 in this guide. 

• Note that End of Day processing may take longer than usual the first time it is run following the 
installation of your new release of Cornerstone software. 

Laboratory 

• If your practice uses the IDEXX SmartLink* In-House Laboratory module, you must shut down the 
IDEXX VetLab* Station and all other connected analyzers before installation. 

• On the IDEXX VetLab Station 3.10 and above, in the Practice Management tab’s Transmit Results 
area, select the On (Transmit result records and report) option. This will set the IDEXX VetLab 
Station to transmit both result records and their associated IDEXX Lab Report to the Cornerstone 
software. (See the Cornerstone 8.1 What’s New document for more information.) 

• For practices that use the following in-house laboratory devices with a serial connection, follow the 
applicable steps before installation: 
(These instructions do not apply to practices that have the IDEXX VetLab Station with IDEXX 
SmartLink technology.)  

° IDEXX LaserCyte* Hematology Analyzer – Close Vetcom32 on the Cornerstone Lab 
workstation (CTRL+ALT+DELETE to start Task Manager > Processes tab > select 
Vetcom32.exe > click End Process). 

° IDEXX VetTest* Chemistry Analyzer – Close Vetcom32 on the Cornerstone Lab workstation 
(CTRL+ALT+DELETE to start Task Manager > Processes tab > select Vetcom32.exe > click 
End Process). 

° Abaxis® VetScan® Analyzer – Close Vsccom32 on the Cornerstone Lab workstation 
(CTRL+ALT+DELETE to start Task Manager > Processes tab > select Vsccom32.exe > click 
End Process). 

Imaging 

• If your practice has the IDEXX Computed/Digital Radiography module, please do the following on 
the workstation that is connected directly to your IDEXX Digital Imaging System: 

1. Open the lib folder within your Cornerstone directory (e.g., C:\Cstone\lib). 

2. Make a copy of the CaptureWorkflow.properties file. (Right-click the file, select Copy, then go 
to your Windows desktop, right-click and select Paste.) 

• The ability to create patient CDs, archive images to a CD or export cases to CD (Diagnostic Imaging 
module only) requires Microsoft .NET Framework 3.5 Service Pack 1, which is available in Windows® 
XP Service Pack 2 or Windows Server® 2003 Service Pack 2 or later operating systems. 

If necessary, Windows XP and Windows Server 2003 can be upgraded to the latest service pack 
through Windows Update. With the latest Windows service pack installed, you can then download 
Microsoft .NET Framework 3.5 Service Pack 1 (also available at idexx.com/microsoftnet). 

http://www.microsoft.com/downloads/en/details.aspx?familyid=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en�
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Disabling the Windows Firewall 
Before installation, verify that the Windows Firewall has been disabled. 

Notes:  

• A hardware firewall (router) is recommended in place of a software firewall. 

• The following instructions assume the Windows Start menu and Control Panel are set to Classic 
View/Small Icons mode. 

To disable the Windows Firewall in Windows XP: 

1. Click Start > Settings > Control Panel. 

2. Double-click Windows Firewall. 

3. Select Off (not recommended). 

4. Click OK and close the Control Panel. 

5. Disable any other firewall software. 

To disable the Windows Firewall in Windows Vista: 

1. Click Start > Settings > Control Panel. 

2. Double-click Windows Firewall. 

3. Click Change Settings. 

4. In the Windows Firewall Settings window, click Off (not recommended) and click OK. 

5. Close the Windows Firewall window and close the Control Panel. 

6. Disable any other firewall software. 

To disable the Windows Firewall in Windows 7 and Windows Server 2008 R2: 

1. Click Start > Control Panel and then click Windows Firewall. 

2. Click Turn Windows Firewall on or off. 

3. In the Home or Work (Private) network location settings section and/or the Domain network location 
settings section, click Turn Off Windows Firewall (not recommended). 

Note: If the options are grayed out, ensure that Turn Off Windows Firewall (not recommended) is 
selected and continue to the next section. 

4. Click OK. 

5. Close the Windows Firewall window and close the Control Panel. 

6. Disable any other firewall software. 

Disabling User Account Control 
For Windows Vista, Windows 7 and Windows Server 2008 R2 operating systems, before installation, 
verify that User Account Control has been disabled. 

Note: The following instructions assume the Windows Start menu and Control Panel are set to Classic 
View/Small Icons mode. 

To disable User Account Control in Windows Vista: 

1. Click Start > Settings > Control Panel. 

2. Double-click User Accounts. 

3. Click Turn User Account Control on or off. 



3: Pre-Installation Information 

Cornerstone 8.1 Installation Guide                    8 

4. Click Continue at the User Account Control prompt. 

5. Uncheck Use User Account Control (UAC) to help protect your computer. 

6. Click OK and restart the computer. 

To disable User Account Control in Windows 7 and Windows Server 2008 R2: 

1. Click Start > Control Panel and then click User Accounts. 

2. Click Change User Account Control settings. 

3. Slide the adjustment bar to Never notify. 

4. Click Yes at the User Account Control prompt. 

5. Click OK and click Yes! Restart the computer; otherwise, restart the computer manually. 

Changing to Install Mode (Windows 2000 Server and Windows Server 2008 R2) 
In Microsoft® Windows Server® operating systems, install mode is used to install applications and 
software, and execute mode is used to run those applications and software. If you are installing on 
Windows 2000 Server or Windows Server 2008 R2, you must change to install mode before installing 
Cornerstone 8.1. 

To change to install mode for Windows 2000 Server and Windows Server 2008 R2 
installations: 

1. Click Start > Run. 

2. Type change user /install. (Note: There is one space between “user” and “/”.) 

3. Click OK. 

Steps to Take Before You Begin the Installation 
1. Review the Cornerstone 8.1 Release Implementation Plan (on the Cornerstone Resource CD) for 

important steps that should be taken before installing Cornerstone 8.1. 

2. If you are upgrading from Cornerstone 7.6 and you plan to install on a Windows Vista workstation, 
you need to uninstall the Cornerstone PDF Printer prior to installing Cornerstone 8.1. To uninstall, go 
to Control Panel (in Classic View) > Programs and Features > select the Cornerstone PDF 
Printer and click the Uninstall/Change button. 

3. If you are using the Mobile Computing module, bring in and synchronize your mobile computers. 
(See “6: Installation for the Mobile Computing Module” on page 19 in this guide for more 
information.) 

4. Run End of Day processing and perform your backup. 

5. Close any programs that are open, including Cornerstone, on all computers. 

6. Close the Cornerstone database engine on the server by right-clicking on the SQL  icon in the 
notification area on your taskbar and selecting Exit. 

Note: To verify the database is closed (in the event the icon is not present), press 
CTRL+ALT+DELETE and then click Task Manager. On the Processes tab, select the dbsrv7.exe 
process in the list (for a stand-alone system, select dbeng7.exe), click End Process, and then click 
Yes. 

A message may appear stating that one or more connections are open and verifying that you wish 
to close the database anyway. If you have verified that Cornerstone has been closed on all 
computers, click Yes. 
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4: Installation on a Server or Stand-Alone Computer 

Installing Cornerstone 8.1  
The steps in this section apply to the following installation environments: 

• Server 

• Remote Desktop Services/Terminal Services server 

• Stand-alone computer 

If you have more than one computer on your Cornerstone network, install Cornerstone 8.1 on the server 
first. See “5: Installation on Workstations” starting on page 14 for information on the proper installation 
procedures for Cornerstone workstations. 

1. Insert the IDEXX Cornerstone CD in the CD-ROM drive. If a CD-ROM drive is not available or is not 
currently functioning, Cornerstone can be installed across the network by running the setup.exe file 
from a shared network folder. 

If the CD does not automatically start, click the Start button and select Run. Type the letter of the 
CD-ROM drive followed by :\setup.exe (e.g., d:\setup.exe) and click OK to open the install program. 

2. An Install IDEXX Cornerstone message asks whether you want to install Cornerstone now. Click Yes. 

The Extract Cornerstone Setup window appears and displays its progress while extracting the 
Cornerstone installation files.  

3. When the Welcome window appears, click Next. 

4. Click I accept the terms of the license agreement to accept the software license agreement, and 
then click Next. 

5. On the Activation Key – Edit Data window, do one of the following: 

• For upgrades: If you are upgrading from a prior version of Cornerstone, the Clinic ID and Key will 
be filled in automatically. Click Next. 

• For new installations or installations with a new key: If Cornerstone has never been installed on 
this computer before, type your Clinic ID and Key and click Next. 

 
Activation Key – Edit Data window 
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6. If you are installing a multi-computer system, the Setup Type window appears. On the Setup Type 
window, do one of the following: 

• For upgrades: If you are upgrading from a prior version of Cornerstone, the installation type will 
be selected for you automatically. Leave this selection at its auto-detected setting and click 
Next. 

• For new installations: If Cornerstone has never been installed on this computer, select the 
appropriate installation type and click Next. 

 
Setup Type window 

7. If you have purchased the Central/Remote module, the Setup Type Central window appears. On the 
Setup Type Central window, select the appropriate Central/Remote installation type and click Next. 

 
Setup Type Central window (appears only for Central/Remote users) 
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8. If the IDEXX SmartService* Solutions tool has not been installed with a previous installation of 
Cornerstone, the IDEXX SmartService License Agreement window appears. (IDEXX SmartService is 
an Internet-based service and support solution that provides automatic download and notification of 
Cornerstone service packs.) Read the license agreement, and then click Yes to accept the terms of 
the agreement and install IDEXX SmartService. 

A message states that the Cornerstone database will be backed up. 

9. Click OK. 

A message states that the backup was successful. 

10. Click OK. 

The Select Features window appears. 

11. On the Select Features window, scroll through the list of Cornerstone feature modules and ensure 
that the appropriate modules are selected (the Cornerstone modules you have purchased are 
automatically selected). We do not recommend deselecting any module. 

 
Select Features window for Cornerstone module installation 

Note: If you are using Central/Remote, you must click the associated check boxes on the Select 
Features window. The Central/Remote features are not selected automatically based on the 
modules you have purchased. 

12. Click Next. 

The Start Copying Files window appears. 

13. Click Next. 

Note: If a Windows File Protection message displays, click Cancel to avoid restoring the original 
versions of the files, and then click Yes. These files will not affect stability; the files have been tested 
by IDEXX and are actually newer versions. 

Installation begins. A window displays the installation progress.  
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14. If you have purchased the IDEXX Diagnostic Imaging module, a message appears asking if you 
want to install DICOM® services. Do one of the following: 

• If you currently use DICOM services or plan to do so in the future, click Yes. 

• If you do not use DICOM services, click No. 

15. If you are installing on a server or Remote Desktop Services/Terminal Services server, a message 
appears to remind you that the Cornerstone database must be updated after you restart the 
computer. Click OK. 

16. On the Setup Complete window, click Yes, I want to restart my computer now and then click 
Finish to restart your computer. 

Note: If you have a Remote Desktop Services/Terminal Services server, you will have to restart 
manually. 

17. After restarting your computer, proceed to the “Updating Your Database” section that follows to 
update your database.  

Updating Your Database 
Note: For installations on Windows Vista, Windows 7 or Windows Server 2008 R2, User Account Control 
(UAC) must be disabled during the update of the database. The update will not start with UAC enabled. 
See the “Disabling User Account Control” section on page 7 for steps to disable UAC.  

1. After completing the Cornerstone 8.1 installation and restarting your computer, log on to the server, 
Remote Desktop Services/Terminal Services server, or stand-alone computer as usual. 

2. If you are installing on a Remote Desktop Services/Terminal Services server and you do not see the 
SQL  icon in the notification area on your taskbar, start the database manually by double-clicking 
the Cornerstone Database Server icon on your desktop. 

3. Double-click the Cornerstone icon on the desktop or select Start > Programs > Cornerstone > 
Cornerstone to start Cornerstone. 

The following message appears: The executable version (8.1.xx) and the database version do not 
match. Do you want the database brought up to date?  

4. Click Yes. 

The Cornerstone Update window appears. All of the feature modules you installed are checked.  

Note: If your practice uses the IDEXX SmartLink In-House Laboratory module, you must shut down 
the IDEXX VetLab Station and all other connected analyzers at this time to avoid errors while the 
database update program is running. 

Note: If your images are being stored in a location other than your server, that workstation must be 
logged into Windows at this time (before updating the database) to avoid altering your Cornerstone 
default image location. 

5. Click OK to start the database update process. 

Note: Before the database update can begin, Cornerstone must first validate the directories 
required by Cornerstone. If any validation issues are encountered, a Cornerstone directory validation 
window appears. Review the information provided and then click Close and perform the suggested 
troubleshooting tasks. Click Update if you have completed the troubleshooting tasks and you are 
ready to update the Cornerstone database. If you need additional troubleshooting help, please 
contact IDEXX Cornerstone Support at 1-800-695-2877. 
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6. During the database update, the update program checks to verify the location of multiple folders. If 
the update detects any changes, you will be prompted multiple times to update the location. Click 
Yes at each prompt. 

7. During the database update, the update program checks to verify the type of backup software 
installed on your server or stand-alone system.  

• If the update program locates one of the supported backup software packages, select the 
appropriate backup software and click OK. 

• If your practice uses other backup software, the software will continue to operate normally (your 
backup procedure will not change). Click OK to continue with the update. 

Note: For more information about the Backup Verification Assistant, see the Cornerstone 
Administrator’s Manual on the Resource CD.  

8. When the database update is complete, click OK. 

Note: The first time a staff member logs into Cornerstone after loading Cornerstone 8.1, the Physical 
Exam Upload window may prompt you to specify the name your practice uses for each of the given 
species. (If your practice has already established species links, this window does not appear.) 

9. In Cornerstone, a Cornerstone Administrator will need to adjust security settings for your practice so 
that staff members can access the new features. See the Cornerstone 8.1 Release Implementation 
Plan on the Resource CD for a listing of these security settings. 
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5: Installation on Workstations 

The steps in this section apply to the following installation environments: 

• New Cornerstone workstations (Cornerstone has not been installed on this workstation before) 

• Upgrades from Cornerstone 7.5 and prior versions 

• Upgrades from Cornerstone 7.6 or 8.0 

The process for upgrading from Cornerstone version 7.6 or 8.0 begins on this page. The installation 
process for first-time installations or upgrading from 7.5 and prior versions begins on page 15. 

Upgrades from Cornerstone 7.6 or 8.0 
Starting with Cornerstone version 7.6, when you installed Cornerstone manually on the server and 
workstations, the Install from Server service was automatically loaded on each machine. That installation 
put the service in place for future installations so that any future versions/updates/service packs need to 
be installed only on the server.  

Notes on Install from Server: 

• The Install from Server service applies to version upgrades only (full release upgrades, minor version 
updates and service packs). It does not apply to new workstation installations of Cornerstone. New 
installations must be installed from CD or installed manually (by running the setup.exe file) from a 
shared network folder. 

• The activation key will be acquired automatically from the server. 

• On each workstation, the service will use the same install folder location that was used for previous 
Cornerstone installations on that workstation. 

Installing on Workstations Using Install from Server 

Note: Before performing Install from Server updates, we recommend that you disable screen savers on 
all workstations to ensure that the updates can install without interruption. 

1. Ensure that Cornerstone 8.1 has been installed on the server and that the Cornerstone database 
has been updated on the server.  

2. On the workstation, double-click the Cornerstone icon on the desktop or select Start > Programs 
> Cornerstone > Cornerstone to launch Cornerstone. 

The following message appears: The Cornerstone server is running a more recent version of 
Foundation than this computer. An update was found on the server. Do you wish to install it now? 

3. Click Yes. Cornerstone closes and the new version is installed automatically from the server (you do 
not need to click through the usual installation wizard screens).  

Note: If you click No when asked if you wish to install the update, Cornerstone closes. Cornerstone 
will not run on the workstation until the system detects that the workstation version matches the 
server version. 

4. When the installation is complete, restart the workstation. 
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Installing on Workstations from a Shared Network Folder 

If you have problems installing on workstations using the Install from Server service (because of firewall 
or security issues, etc.), Cornerstone can be installed on the workstations across the network from a 
shared network folder. 

1. Ensure that Cornerstone 8.1 has been installed on the server and that the Cornerstone database 
has been updated on the server. 

2. On the workstation, browse to the \\server\cstoneshare\install\release shared network folder and 

double-click the setup.exe  icon. 

Note: If your server name is something other than server, replace the word server with your server 
name. To check the server name: On the server desktop or Start menu, right-click the My 
Computer icon and select Properties. The server name can be found on the Computer Name tab, 
listed after Full computer name.)   

3. Follow the prompts to install on the workstation.   

4. When the installation is complete, restart the workstation. 

New Workstations OR Upgrades from Cornerstone 7.5 and Prior Versions  
1. Insert the IDEXX Cornerstone CD in the CD-ROM drive. If a CD-ROM drive isn’t available or is not 

currently functioning, Cornerstone can be installed across the network by running the setup.exe file 
from a shared network folder. 

If the CD does not automatically start, click the Start button and select Run. Type the letter of the 
CD-ROM drive followed by :\setup.exe (e.g., d:\setup.exe) and click OK to open the install program. 

Note: The Cornerstone 8.1 installation loads the Install from Server service on your system. For any 
future upgrades/updates/service packs installed after the initial 8.1 installation, the Install from Server 
service will automatically load the update files to the connected workstations. This will allow your 
practice to install and maintain your Cornerstone software practice-wide without requiring an 
administrator to log into each workstation and manually install from CD. 

An Install IDEXX Cornerstone message asks whether you want to install Cornerstone now. 

2. Click Yes. 

The Extract Cornerstone Setup window appears and displays its progress while extracting the 
Cornerstone installation files.  

3. When the Welcome window appears, click Next. 

4. Click I accept the terms of the license agreement to accept the software license agreement, and 
then click Next. 

5. On the Activation Key – Edit Data window, do one of the following: 

• For upgrades: If you are upgrading from a prior version of Cornerstone, the Clinic ID and Key will 
be filled in automatically. Click Next. 

• For new installations or installations with a new key: If Cornerstone has never been installed on 
this computer before, type your Clinic ID and Key and click Next. 

Note: If you do not know the Clinic ID or Key, you can acquire it from the server. To access this 
information, log into Cornerstone on the server, then go to Help > About IDEXX Cornerstone and 
click the More button. 
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Activation Key – Edit Data window 

6. On the Setup Type window, if not already selected, select the Workstation installation type and click 
Next.  

 
Setup Type window 
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7. If you have purchased the Central/Remote module, the Setup Type Central window appears. On the 
Setup Type Central window, select the Workstation installation type and click Next. 

 
Setup Type Central window (appears only for Central/Remote users) 

The Select Features window appears. 

8. On the Select Features window, scroll through the list of Cornerstone feature modules and ensure 
that the appropriate modules are selected (the Cornerstone modules you have purchased are 
automatically selected). We do not recommend deselecting any module. 

 
Select Features window for Cornerstone module installation 

Note: If you are using Central/Remote, you must click the associated check boxes on the Select 
Features window. The Central/Remote features are not selected automatically based on the 
modules you have purchased. 

9. Click Next. 

10. The Start Copying Files window appears. Click Next. 
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Note: If a Windows File Protection message is displayed, click Cancel to the restoration of the 
original versions of these files and then click Yes that you are sure. These files will not affect stability; 
the files have been tested by IDEXX and are actually newer versions. 

Installation begins. A window displays the installation progress.  

11. On the Setup Complete window, click Yes, I want to restart my computer now and then click 
Finish to restart your computer. 
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6: Installation for the Mobile Computing Module 

Installing Cornerstone 8.1 for the Mobile Computing Module 
If you are using the Mobile Computing module, use the following instructions to install Cornerstone 8.1. 

Note: See the Cornerstone User’s Manual for additional information on using the Mobile Computing 
module. 

1. Bring all mobile computers into the practice. (If you cannot bring all mobile computers into the 
practice at the same time, see the “If You Cannot Bring Each Laptop/Tablet into the Practice” 
section that follows.) 

2. Synchronize each mobile computer.  

3. Remove each mobile computer from the Mobile Computing List by selecting Undo mobile 
computer.  

4. At your practice, install Cornerstone 8.1 on your server and workstations according to the steps in 
the “4: Installation on a Server or Stand-Alone Computer” and “5: Installation on Workstations” 
chapters in this guide. 

5. Install Cornerstone 8.1 on each laptop/tablet according to the steps in the “5: Installation on 
Workstations” chapter starting on page 14 in this guide. 

6. Start Cornerstone on each laptop/tablet and create the mobile computer. (See the “Using the Mobile 
Computing Module” chapter in the Cornerstone User’s Manual for information on creating a mobile 
computer in Cornerstone.) 

If You Cannot Bring Each Laptop/Tablet into the Practice 

We strongly encourage you to bring all of the mobile computers into the practice at the same time to 
perform the Cornerstone 8.1 installation.  

WARNING: If you do not bring in all mobile computers to be synchronized at the time of updating, you 
will be at risk of data loss on the mobile computers that were not present at the time of the update. 

If it is not possible to bring all mobile computers into the practice at the same time, follow these 
instructions: 

1. Bring in as many of your mobile computers as possible and follow the instructions in the previous 
“Installing Cornerstone 8.1 for the Mobile Computing Module” section. 

2. As you are able, bring your other mobile computers into the practice for updating.  

You will need to update your mobile database before synchronizing: 

a. On each mobile computer that has not yet been updated, install Cornerstone 8.1 according to 
the steps in the “5: Installation on Workstations” chapter starting on page 14 in this guide. 

b. After installation, start Cornerstone on the mobile computer. An alert will appear, informing you 
that your database needs to be updated. Click Yes to update the database. (If the update is not 
performed, Cornerstone will not function on this mobile computer and you will not be able to 
synchronize with the server.) 
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3. Synchronize the mobile computer with the server.  

4. For any mobile computer that is not synchronized with the server before Cornerstone 8.1 is installed 
on the server, the first time you sync after installing 8.1 on the mobile computer, you will see a 
duplicate client error for EMR_CLT and a duplicate patient error for EMR_PAT. To solve this 
problem, do the following: 

a. In order to complete the synchronization, enter a new patient ID and a new client ID (you will 
need to delete these IDs in the next step, so you may want to write them down for easy 
reference).  

b. Log into Cornerstone on the server and delete the new patient ID and client ID (using Lists > 
Patient and Lists > Client). Note that the patient ID must be deleted first, as you cannot delete 
a client ID that has a patient ID associated with it.  

Note: Do not delete the EMR_CLT or EMR_PAT IDs from the mobile computer or the server. 
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