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INTRODUCTION 
The LC880 is a fully programmable logic and timing controller for coordinating and synchronizing lab equipment 
and physical experiments. LC880 provides clocks, counters, triggers, and many other useful functions, with 10 ns 
resolution and 100 ps accuracy. 

As you are well aware, controlling and synchronizing your experimental equipment are often the most tedious tasks 
you’ll face in the lab. Experimenters regularly build their own controls from scratch or piece together systems from 
the limited offerings on the market. The LC880 simplifies your control setup, so you can go about the business of 
gathering data, and making knowledge. 

The LC880 consists of two components: Trigger software and the LC880 experiment controller. Trigger lets you 
design and run experiments from a simple graphical interface. The LC880 controller provides the connections and 
control for your experimental devices.  

Parts List 
Your LC880 package should include the following items: 

1. the LC880 controller 

2. AC power cable 

3. Trigger software installation CD 

4. 9-pin RS232 cable 

5. User’s manual 

If any parts are missing or damaged please contact LabSmith support. 

Specifications 
Trigger software will run on any PC-compatible computer running Microsoft® Windows® 95, 98, Me, NT, 2000 or 
XP.  Drivers for National Instruments’® LabView® software are also available for download.  See 
http://www.labsmith.com for more information. 

The LC880 includes eight TTL-compatible inputs and eight TTL-compatible outputs. Voltages in the range 2.5 – 5 
V are TTL “highs” and voltages in the range 0.0 – 0.2 V are TTL “lows.” Intermediate voltages should not be 
present on inputs and outputs except during transitions. The inputs and outputs are protected against connection to 
115 VAC. When disconnected the inputs are read as TTL “highs.”  

The LC880 can be connected to/ disconnected from the PC at any time without damage to either unit. This ability 
allows you to program to LC880 at your computer, then to take the unit to the experiment area for stand-alone use.  

Basic Functions 
The LC880 provides eight functional channels, or internal signal paths.  

At any time, each channel can be assigned one of eight timing modes. Timing modes include clocks, counters, 
delayed triggers, etc. You can set various properties for each timing mode— for example, the delay length on a 
Delayed Trigger. All modes are aligned to a precise, 100 MHz internal clock or an external clock, allowing 
resolution down to 10 ns. 

Each channel also includes logic settings which specify the conditions that will trigger the channel. A channel can be 
triggered by any logical combination of signals from the eight inputs and/or the outputs of other channels.  

The timing properties and logic that you set up in Trigger can be transferred and stored in the memory of the LC880. 
You can store up to 64 variations of these properties in settings profiles in the LC880. You can then switch between 
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settings profiles to switch experiments, compare different timing scenarios, or simulate different real world 
conditions. 

All settings and settings profiles for a particular experiment can be stored as an experiment file on your computer. 
Experiment files bear a .trg extension. 

How You’ll Use the LC880 
In most cases, you’ll use the LC880 as follows: 

1. Using the Trigger software, open an existing experiment file, or create a new file. 

2. In Trigger (or LabView®), program the properties and logic for each channel and for the experiment as a 
whole. 

3. Send the properties and logic to the LC880’s memory. 

4. Test your program by simulating triggers and examining the outputs using the LC880’s channel LEDs, an 
oscilloscope or other diagnostic tool.  

5. Store variations of the channel properties in one of the 64 settings profiles in the LC880.  

6. Plug your experimental equipment to the LC880. 

7. Run the experiment, using the LC880 by itself or leaving it tethered to the PC. Switch between settings profiles 
during the experiment to handle or simulate various timing conditions. 

Installing Trigger Software 
Insert the Trigger Software disk in the CD-ROM drive and execute the setup.exe file. 

Setting Up the LC880 
1. Plug the power cable from the back of the unit into a 110–250 VAC power outlet.  

2. Connect the 9-pin cable to the back of the LC880 and to a free serial port on your PC.  

3. Press the Power button on the front of the LC880.  

4. From your computer, run Trigger.exe to launch the Trigger software. 

5. From within Trigger, select View>Options>Com Port. The Serial Communications screen will open. 

 

6. Select the port to which the LC880 is connected. The LC880 will automatically detect the baud rate, which is 
typically set to 38400. If the RS232 cable running to your LC880 is greater than 30m long, you may need to 
lower the baud rate to achieve reliable communication. 
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Getting Help 
This guide is your main source for information on operating the LC880 and Trigger software. The guide is also 
available in an Adobe® Acrobat® Portable Document Format (pdf) file for electronic viewing.  

While running Trigger, press F1 to view this document on-line. Or, press SHIFT-F1, then select a button or menu 
option to view help topics for a particular feature. 

The LabSmith web site (www.labsmith.com) also includes helpful applications notes and other technical information 
to help you use the LC880. 

If you are unable to find the information you need, please contact our technical support team at (925) 292-5161, or e-
mail us at info@labsmith.com. 

 

If you need to contact support, please let us know the version of software you are using. To determine the software 
version number, select “About Trigger” from the Help menu. 
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OVERVIEW OF LC880 CONTROLS 
The LC880 is the control unit and interface for your experimental equipment. You will program it using the Trigger 
software. Once you’ve designed, tested and downloaded your program, you can control the LC880 from the 
computer, or you can run it in stand-alone mode.  

Indicators and controls on the LC880 front panel will help you run your experiments. You’ll learn all about these 
functions in the Experimenting section later. For now, we’ll give you a short tour of the inputs, outputs and controls 
so you can work with the unit while you learn to use the Trigger software. 

Back Panel Inputs and Outputs 

 

The back panel includes the following connectors: 

- an internally-fused jack for a standard 110–250 VAC power cord 

- a 9-pin RS232 jack to connect to the Comm port of your PC 

- eight BNC channel input jacks (in1–in8), normally-high (5 Volts) 

- eight BNC channel output jacks (outA–outH), normally low (0 Volts) 

- a BNC input jack for an external clock source. 

The inputs and outputs will accept any device into that sends or receives TTL-compatible signals. 

Channel Inputs Clock Input 

Channel Outputs 

110-220 VAC 
Input 

RS232 PC Input 
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Front Panel Controls 

 

 The LC880 front panel controls begin with the Power button and Power LED in the upper left corner. When you 
first press the Power button, the LED will flash green and red while the system runs its initial diagnostics.  It will 
then glow a steady color .  When it glows a steady green, the front panel is unlocked and accepting button pushes.  
When it glows red, the front panel is locked.  When the front panel is locked, even the power switch is deactivated, 
providing security against accidental mis-setting or tampering.  

The channel LEDs offer useful information about the state of each channel. A green light typically indicates that the 
channel is ready to receive a trigger. A red light typically indicates that the channel is in the process of triggering. 
When a channel indicator is off, the channel is disabled (see Running Experiments: Enable/Disable Channels). Some 
useful exceptions will be discussed in the Timing modes section below. 

The All Channel LED shows the status for all channels. A green LED indicates that the LC880 will respond to 
external inputs and that external outputs are active.  A red LED indicates that the LC880 will not respond to external 
inputs and that outputs are in a fixed and frozen logical state.. 

The Channel and Function Buttons work as pairs— you will select one of each to perform any function. In the base 
state, all buttons glow dimly, indicating that they’re ready for your instruction. Once you press a channel or function 
button, only the available options will be illuminated. 

 

Power Switch Channel LEDs 

Power LED Channel Buttons 

Function Buttons 
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TRIGGER SOFTWARE INTERFACE 
Trigger has been designed exclusively for setup and control of the LC880. You’ll use Trigger to set the timing 
properties and logic for each of the eight channels and to set up overall properties for the experiment. 

Main Screen 
When you run Trigger, you’ll be greeted by the Main screen:  

 

From this screen you’ll control or access all of Trigger’s functions. Most Trigger functions can be accessed in two 
ways by selecting an option from a pull-down menu or by pressing a button on the Main screen.  

1. Menu options: 

The File menu lets you open, close and save experiment files. Trigger files bear a .trg suffix. 

The Edit Menu lets you cut, copy and paste text as you edit your program. 

The View menu lets you set up the Trigger interface. Choose to display or hide the tool bars and status bar, 
select the font used in Trigger, and set up communications with the LC880. 

 The Channel menu lets you open the screens for “General Settings” and for each of the eight channels. 

 The Program menu includes options for communicating with the LC880. You can send logic, send 
properties, reset all channels, or enable/ disable the LC880’s inputs and outputs. 

2. The buttons are as follows: 
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The General Settings button  opens the General Settings screen.  

 The Channel buttons open the Settings screens for all channels. 

 

1. The Program button  updates the LC880 with all current settings. 

2. The Reset button  resets all channels of the LC880. Retriggering Counters and delay settings will be 
reset as well. 

3. The Main window panel shows a text summary of all of the settings that have been entered. This summary 
may be printed for review and documentation purposes. The text is not freely editable and must be modified 
through the dialogs. Double clicking on selected parts of the summary opens the dialog needed to edit the 
text.  

At any time, the LC880 control bar can be hidden or displayed by clicking View>LC880. 

 

General Settings 
The “General Settings” screen lets you control functions that affect all channels of the LC880. To reach this screen, 
click the “General Settings” button, or choose “General” from the Channel menu. 

Disable/Enable I/O 

On occasion you will need to abort an experiment or quickly place all outputs to your equipment in a “safe” state.  

Each of the tabs of the General Settings screen includes buttons that let you “disable” and “enable” all inputs and 
outputs to the LC880. With I/O disabled, input signals are ignored. Each output will be held at either a logic low or 
logic high, depending upon its channel properties. We’ll refer to the “safe” voltage that a channel produces when 
disabled as the “quiescent state” (see Channel Properties: Quiescent States).  

To restore channels functions, click the “Enable I/O” button.  These functions are nonvolatile: the enabled and 
disabled state are restored on power cycle. 

You can also disable or enable inputs and outpus from the LC880 front panel (see Experimenting: Disable/Enable 
All). 

 Lock/Unlock Panel 

You may lock or unlock the front panel buttons using the “Lock Panel” and “Unlock Panel” buttons.  This ability 
comes in handy for example in embedded control applications where the LC880 should function only in stand-alone 
or computer-controlled modes.  When the panel is locked, the LED next to the power button glows a steady red and 
all buttons are dark.  When the panel is unlocked, this LED glows green and front-panel buttons are illuminated. 

Like the enable/disable IO functions, these settings are nonvolatile and are restored on power up.  Because the power 
button is disabled, the LC880 must be disconnected from AC power to turn it off, if the front panel is locked. 
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Time base settings 

 

Each pair of channels of the LC880 can independently utilize one of four different time bases so you can control and 
measure events that occur a few nanoseconds apart, or a few hundred seconds apart.  

In “100” MHz time base mode (the default) , the LC880 aligns signals to an internal 100 MHz clock, for timing 
resolution of 10 ns. Use this “hi-res.” mode when the events of your experiment occur in rapid succession 
(milliseconds or less). 

“100/64” MHz time base mode allows the LC880 to control events that occur over longer time periods (milliseconds 
to minutes).  This mode is called “low-res.” mode in the following documentation. 

In “Ext.” time base mode, the channels use an external clock input for the time base.  This input must be TTL-level 
between 1 and 100 MHz applied to the external clock input on the back of the LC880.  This allows multiple LC880s 
to be synchronized to the same time base, high-precision external time bases to be used, or variable-frequency time 
bases to be used.  This time base cannot be produced by a channel using the time base as an input!  

“Ext./64” time base mode divides the frequency of the signal applied to the external clock input before using it as a 
time base.   

If the external clock is being used as a time base, the frequency entered into the edit box is used to calculate the 
timing settings.  For example, if this setting is 10% higher than actual, the channels using this time base will be 10% 
long on delays and durations. 
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CHANNEL PROPERTIES 

Channel Properties Screen 
Each channel has a Settings screen in which you’ll select the timing mode, set the timing properties, and establish the 
logic that will determine when the channel will trigger. 

To open the Settings screen for a channel, select the channel from the Channel menu, or click a channel button (A – 
H) on the Main screen.  You can open more than one channel screen at a time. 

  

 

Channel properties are organized by tabs. The tabs that are relevant for a particular timing mode appear 
automatically when that timing mode is selected. For convenience, all settings are retained and saved, including 
those for timing modes that are not currently selected. 

Three additional buttons appear next to the tabs: 

- Disable temporarily disables the channel. The channel remains fixed in its quiescent state (see Quiescent 
States below). The front panel LED for that channel will be unlit. (See Running Experiments: Channel 
LEDs)  This disable function is volatile: all channels are re-enabled on power up. 

- Enable restores channel functions following a temporary disable. The front panel LED for that channel will 
glow to indicate the channel's status.  

- Reset reinitializes the internal trigger counters and sweep timing for the current channel.  This function can 
be called simultaneously for all channels by pressing the “Reset” button on the main tool bar. 

- Force Trigger lets you simulate a valid input signal for the channel (see Channel Properties: Logic for 
more). This button, which is only available with functions that can be triggered, is useful both for 
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troubleshooting your channel settings and implementing software control of experiments. You can also force 
trigger a channel from the LC880 front panel (See Running Experiments: Force Trigger). 

Quiescent States 
When you disable a channel, its input will not change the output. The “quiescent state” of a channel is the setting of 
its output when the channel is disabled. You can set each channel’s quiescent state to be a TTL high (3.5–5 V) or 
low (0–0.2 V) to provide a safe signal to the output device if you need to abort an experiment or stops its progress.  

The method for setting the quiescent state depends on the timing mode. Most modes include an “Invert Output” 
option which sets the output normally High.  

Timing Modes 
In this section we’ll begin to use the various LC880 timing modes. Each channel can be configured to operate in one 
of eight modes:  

- Fixed output 

- Output=Input  (Passive Mode) 

- Delayed Pulse After Trigger 

- Clocked Pulse Stream 

- Validated Trigger Input (Noise Suppression) 

- Dynamically Delayed Pulse 

-  Counter/Timer 

- Toggled Output.  

When a timing mode is selected, the relevant property tabs will be displayed.  

             

 NOTE: All timing property tabs include a space for Notes. These notes are saved 
and appear in the Main Screen program summary area. It is good practice to 
document your settings extensively. As with all programming, good documentation 
will simplify the process of creating, debugging and running your experiments. 

              

For each timing mode you’ll be able to set up a simple example to view the output of the channel. 

To set up for the experiments below:  

1. Make sure that the LC880 is connected to the PC.  

2. Plug a normally open push-button trigger switch into Input 1. The button will represent our triggering “event.” 

3. Open Channel A’s Setting screen, and select the “Delayed pulse after trigger” timing mode (you’ll learn about 
Delayed Trigger mode shortly).  

4. Select the “Logic” tab. Enter the logical phrase:  

inA = not in1;  

Then click OK. With this logic, Channel A will trigger when you depress the trigger button.  (You’ll learn all 
about Logic below). 

5. Now transfer the logic to the LC880 by clicking the “Set All Channels” button   . 

6. Plug an oscilloscope to Output A to observe the channel output. Remember, the output voltage will vary from 
0 to 5 V. 
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“Apply” versus “Program All Channels” 

Each properties screen includes an “Apply” button which, when clicked, will send the current timing properties to 
the channel on the LC880. 

             

 NOTE: If you change a channel’s properties, closing the Settings screen will have 
the same effect as clicking “Apply.” Clicking the “OK” button will also have 
the same effect.  

             

Logic settings are sent and saved in the LC880, but any changes are not implemented on the LC880 until you click 

“Set All Channels” button on the Main screen  or choose Program>Program All Channels. 

“Program All Channels” is the same as clicking “Apply” for all channels and then instructing the LC880 to update its 
logic programming. 

The “Cancel” button cancels any edits made since the last time the “Apply” button was clicked and closes the dialog 
window. 

Fixed Output Mode 

 

In this mode, the channel output remains in the selected state (Low or High), regardless of the input.  

The front panel LED for the channel will glow green when the output is Low or red when the output is high. 

To try fixed output mode:  
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On the “Properties” tab of Channel A, choose “Fixed Output” from the pop-up. Choose “Low” or “High” as the 
output state, then click “Apply” to save the settings. At Output A, the signal will remain a steady TTL logic low or 
high, depending on your selection. 

Passive Mode (Output = Input) 

 

In passive mode, the output signal equals the input signal or its logical inverse. 

The front panel LED for the channel will glow green when the output is Low or red when the output is high. 

To try passive mode: 

On Channel A’s Settings screen, select the “Output=Input” timing mode. In the Function box, choose 
“Output=Input,” then Click “Apply” to save the settings.  

When the trigger button is not depressed (i.e., the input signal is low), the signal at Output A will be a TTL low. 
Now, depress the trigger button at Input 1— the signal at Output A will go high.  

If you select “Output=!Input (invert), the channel output will remain high until you depress the trigger. 
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Clocked Pulse Stream Mode 

 

In clock mode, the output of the channel is a steady stream of pulses. You control the pulse duration and the time 
between pulses. The input to a clock channel does not affect its output. 

The front panel LED for a clock channel will glow green when the output is low or red when the output is high.  

            

 NOTE: For a high-frequency clock the LED will alternate between red and green 
so quickly that it will appear as a continuous pale green, yellow, or orange light. 
            

As mentioned earlier, the LC880 can operate in two clock modes: hi-resolution and low-resolution (see General 
Settings: Clock). In hi-res mode, the clock pulse and duration can range from 0.64 µs to 52.4 ms in increments of 
160 ns. In low-res mode, pulse and duration can range from 30.1 µs to 3.35 s in increments of 10.24 µs.  Trigger 
automatically rounds entries to the nearest allowed setting.   

To set the pulse duration, select the timing units (seconds, microseconds, milliseconds or nanoseconds) from the 
pop-up, then enter the duration in the “Clock high duration” box.  

To set the time between pulses, select the units, then enter the duration in the “Clock low duration” box. 

A clock’s quiescent state is normally low (See Channel Properties: Quiescent States). Check the “Inverted output” 
box if the quiescent state for the channel should be high instead. 

            

 NOTE: In the normal clock state, a high input turns the clock on and a low input 
turns it off. If the “Inverted output” box is checked, a low input turns the clock on 
and a high input turns it off. 
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To try Clock mode: 

1. On the General Settings screen, select “100/64” (low-resolution mode) for Channels A and B. 

2. On Channel A’s Properties tab, choose “Clock” as the mode, select an “on” duration of 100 ms and an “off” 
duration of 500 ms. Click “Apply” to save the settings.  

The signal at Output A will go high every 500 ms and will remain high for 100 ms each time. 

To test faster clock settings, select “Full” (high-resolution) mode under General Settings, then set duration and delay 
times of less than 52 ms. 

Delayed Pulse After Trigger Mode 

Upon receiving an input signal, a delayed trigger waits a specified delay time, then sends a pulse to the channel 
output. This mode has several property tabs.  

Delay  

 

On the Delay tab you’ll specify: 

Delay after trigger The delay between a valid trigger and an output signal 

Duration of pulse The duration of the output signal 

Until Reset The output will remain high after a valid trigger, until the channel is reset 

Inverted Output Check the box to set the output high until a valid trigger. 

The range of settings you can use with the delayed trigger depend upon the current timing mode: 
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 100 (high res mode) 100/64 (low res mode) 

Delay range 20 ns to 21.47 s 1.28 µs to 1374 s 

Duration range  7.7 µs to 21.47 s.  493 µs to 1374 s 

Delay / Duration 
resolution  

10 ns 640 ns 

Triggering 

 

 

This tab lets you control how the channel will trigger:  

Normal  The channel can retrigger an unlimited number of times 

Skip N triggers  The channel triggers only after the specified number of input pulses (between 0 and 
2,147,483,647).  

Retrigger N times  Limits the number of retriggers allowed between resets (between 0 and 2,147,483,647). 
To allow a channel to be triggered again after reaching the limit, press the “Reset” 
button on the LC880 or choose Program>Reset Channels in Trigger. 

Trigger on rising input  Sets the channel to be edge triggered. In other words, an input signal that stays high 
triggers the channel only once.  

Trigger on input high  Allows the channel to be repeatedly triggered while an input is high. This setting could 
be used for generating a low-precision gated clock, for example. However, the latency 
time between retriggers is indeterminate (typically around 10 µs) so a clock made this 
way is not suitable for applications requiring high precision.  
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Alert host computer  Sends a “ping” to the PC upon completion of the trigger cycle.  
following trigger 

 

Sweep 

 

 

To facilitate time-delay scanning experiments, the delay of the pulse relative to the trigger can be “swept” or 
incremented by a specified value each time the channel is triggered. The sweep value must be positive. The 
increment resolution is 5 ns. However, the actual delay is rounded to the nearest 10 ns at full internal clock. For 
example if the increment is set to 5 ns, the actual delay is incremented by 10 ns every second trigger event.  

The front panel LED for the delayed trigger will glow green until an input signal is detected. The LED will be unlit 
for the delay time and will glow red for the duration time.  What happens next depends upon the channel settings: 

 

Retriggering 
enabled? 

Edge 
triggered? 

the channel LED…  

no yes or no remains red (no more triggers accepted) 

yes no glows green (waiting for next trigger) 

yes yes is off; glows green once input goes low 

To try the delayed pulse mode: 

Under General Properties, choose 100/64 (low resolution) clock mode for Channels A and B.  

1. In Channel A’s properties screen, select “Delayed Trigger.”  
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2. On the Delay tab, enter a delay of 1 s and duration of 500 ms.  

3. On the Triggering tab choose “Retrigger N Times” and set N=0. Choose “Input high (level trigger),” then 
click “Apply” to save the settings. 

4. Click the trigger pushbutton. One second after you push it, the output of Channel A will go high for 500 ms.  

5. The channel LED remains red, indicating it is not ready to trigger. Push the button again. You’ll see that you 
cannot retrigger the channel. Click the “Reset” button on the LC880— the LED glows green and you can 
once again trigger the channel. 

6. On the Triggering tab, choose “Retrigger N times,” set N=5, then click “Apply.” Depress and hold the trigger 
button. As long as the trigger is depressed (i.e., the input signal is high) the channel will continue to trigger 
until the limit is reached. 

7. Again on the Triggering tab, select “Rising Input (Edge Trigger)” then click “Apply.” Depress and hold the 
trigger button. The channel will trigger only once, no matter how long you hold the button. Release the 
button and depress it again, and the channel will be triggered once more (switch bounce may produce 
triggers when the button is released). 

8. On the Delay tab, check “Inverted output,” then click “Apply.” The output will be the inverse of that 
described in Step 4. 

9. On the Sweep tab, set the sweep to 0.5 s per trigger, and on the Delay tab select Normal. Click “Apply.” The 
time delay before the output pulse will increase with each trigger. 

Validated Trigger Input Mode (Noise Suppression) 

 

The noise suppression function eliminates false triggers due to noise on the input signal by requiring the signal to 
remain high (or low) for a specified duration. If the signal drops out during that period, the output will remain low 
and the channel will look for the next input signal. Once an input signal is deemed “valid,” a pulse of user-specified 
duration will be sent to the channel output.  
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Unlike an analog filter which “smears” the signal edge, this noise suppression function digitally blocks false triggers, 
retaining the sharp edges on the real trigger signal. 

As with Delayed Pulse After Trigger mode, you have additional controls over the channel.  

On the Validate tab, choose: 

Minimum duration The minimum length of an input pulse that will trigger the channel 

Duration of pulse The duration of the output signal 

Until Reset The output will remain high after a valid trigger, until the channel is reset 

Inverted Output Check the box to set the output high until a valid trigger. 

 

On the Triggering tab choose: 

Normal  The channel can retrigger an unlimited number of times 

Skip N triggers  The channel triggers only after the specified number of valid input pulses (between 0 and 
2,147,483,647).  

Retrigger N times  Limits the number of retriggers allowed between resets (between 0 and 2,147,483,647). 
To allow a channel to be triggered again after reaching the limit, press the “Reset” button 
on the LC880 or choose Program>Reset Channels in Trigger. 

Trigger on input high  Allows the channel to be repeatedly triggered while an input is high.  

Trigger on rising input  Sets the channel to be edge triggered (i.e., an input signal that stays high will only trigger 
the channel once).  

 

The front panel LED for the noise suppression channel will glow green until an input signal is detected. It will then 
glow red until the duration period has elapsed. At this point, the LED will respond as follows: 

 

Retriggering 
enabled? 

Edge 
trigger? 

LED 

no yes or no remains red (no more triggers accepted) 

yes no glows green (waiting for next trigger) 

yes yes is off; glows green when trigger goes low 

To try validated trigger mode: 

1. On the General Settings screen, select 100/64 (low-resolution) mode for Channels A and B. 

2. In Channel A’s properties, select “Validated Trigger Input” mode.  

3. On the Validate tab, enter a “Minimum duration” and “Duration of output pulse” of 1 second each.  

4. On the Triggering tab, select “Retrigger N times,” and set N=50. Click “Apply” to save the settings. 

5. Now, depress the trigger button. If you hold the button down for more than one second (the minimum 
duration), the output of Channel A will go high. If you release the button before one second elapses, the 
output will remain low, and the channel will wait for another input pulse.  
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Counter/Timer Mode 

 

The counter/timer mode determines the time delay between two separate input signals with 10-ns resolution and 
reports it back to the PC. You can view the counter output in the Properties tab.  

Use the channel’s logic to select the input signals that will be compared by the counter (see Channel Properties: 
Logic below). For example, if the logic reads “in1 and in2;” the counter will determine the time delay between a 
pulse at Input 1 and the next pulse from Input 2. 

Normally, the counter will report a value each time a pair of pulses is measured. To retain the current measurement, 
check the “Hold measurement” button; the counter will not update the delay display until this button is cleared. 

             

 NOTE: To switch from counter mode, first click the Disable button and ensure the 
channel LED is unlit, indicating that the channel is disabled. This will help you 
avoid unexpected behaviors when the counter is transmitting measurements 
rapidly (e.g., >1000 measurements per second).  

             

            

 NOTE: When you first run the LC880, channels that are configured as counters 
are initially disabled and must be enabled either by clicking the “Enable” button 
on the channel’s Properties screen, or by using the front panel (See 
Experimenting: Disable/Enable Channels below). 
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The front panel LED for the counter will be green until the first trigger, red until the second trigger and off while 
the count data is reported and the channel waits for the input to return low. 

The output of a channel in counter mode is always high. 

To try the counter/timer mode: 

One good way to see the counter in action is to have it compare the outputs of two clock channels. The counter will 
measure the difference between the successive pulses of the two channels. 

1. On the General Settings, select Full (high resolution) clock mode. 

Channels B and C will be our clocks. We’ll use odd delay and duration values for the clocks so that the 
difference between pulses will be obvious. 

2. On Channel B’s properties tab, select Clock mode. Enter a delay of 54 ms and a duration of 79 ms. Click 
“Apply.” 

3. On Channel C’s properties tab, select Clock mode. Enter a delay of 87 ms and duration of 85 ms. Click “Apply.” 

4. On Channel A’s Logic tab, enter: inA = outB and outC;   (You’ll learn more about channel logic in the Logic 
section below). 

5. On Channel A’s Properties tab, select Counter mode, with milliseconds as the units. Click “Apply.” 

6. Lastly, click “Send Logic” on the Main screen to update the new logic for Channel A. 

The time difference measurements should now appear, in rapid succession, in the “Last Measured Period” box on 
Channel A.  

            

 NOTE: The LC880 may be measuring time differences faster than it can display 
them all on the monitor! 
            

Now, check “Hold measurement.” Note that the displayed measurement does not change. Un-check “Hold 
Measurement”, then check “Hold measurement” again to freeze another measurement. 
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Dynamically-Delayed Pulse Mode 

The dynamic delay is the LC880’s piece de resistance. First, it measures the time difference between two pulses, like 
a counter. Next, it scales that difference by a user-defined factor. It subtracts an offset value, waits the duration of the 
dynamically calculated delay, then sends a pulse to the channel output.  

            

 NOTE: The dynamic delay is particularly useful for ballistics or gas dynamics 
experiments, in which the velocity of a projectile or wave must be calculated 
and used to time the triggering of an experimental device. 
            

The Dynamically Delayed pulse includes several properties tabs. 

Scaling 

 

 

In the calculation of the delay, the measured delay between two pulses is scaled by a factor of 2N, where –16 < N < 
16, or N/16, where 0< N < 256. The former scaling is faster and a scaling of 1:1 is fastest. Scaling can typically be 
done at rates > 50 kHz. 

The maximum delay between input pulses is 52 ms in hi-res mode (100 MHz) and 3.3 s in low-res mode (100/64).  
The maximum delay resulting from the scaling and offset calculations is respectively 21.47 s and 1374 s in hi-res and 
low-res modes.  Negative calculated delays work correctly only in acausal universes. 
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Delay 

 

 

Added Delay Set an offset value to subtract from the scaled delay length. This is useful when 
accounting for camera shutters or other lag times in experimental equipment. The offset 
value can be positive (shortens the delay time) or negative (lengthens the delay time) and 
the resolution is set by the time base (e.g., 10 ns).  

Duration of pulse The duration of the output signal 

Until Reset The output will remain high after a valid trigger, until the channel is reset 

Inverted Output Check the box to set the output high until a valid trigger. The duration of the pulse and 
other properties are the same as for the delayed trigger.  

Triggering 

The triggering options are the same as those for Delayed Pulse After Triggering mode: 

Normal  The channel can retrigger an unlimited number of times 

Skip N triggers  The channel triggers only after the specified number of input pulses (between 0 and 
2,147,483,647).  

Retrigger N times  Limits the number of retriggers allowed between resets (between 0 and 2,147,483,647). 
To allow a channel to be triggered again after reaching the limit, press the “Reset” 
button on the LC880 or choose Program>Reset Channels in Trigger. 

Trigger on rising input  Sets the channel to be edge triggered. In other words, an input signal that stays high 
triggers the channel only once.  

Trigger on input high  This option is not used in this mode. 
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Alert host computer  Sends a “ping” to the PC upon completion of the trigger cycle.  
following trigger 

 

The front panel LED for a dynamically-delayed trigger will remain green until a valid input signal is detected. 
When an input signal is detected, the LED will glow red until the output signal is sent. At this point the LED will 
return to green if retriggering is allowed, or it will glow red to indicate that no more input signals will be accepted. 

To try the dynamically-delayed pulse mode: 

You can simulate the experiment above, using the trigger button to represent Sensor 1, and a delayed trigger in 
Channel B to represent the signal from Sensor 2. Connect your oscilloscope to the Output C to view the results. 

1. On the General Settings screen, select 100/64 (low-resolution) mode for Channels C and D (and optionally for 
Channels A and B).. 

2. On Channel A’s Properties tab, select “Output=Input” mode.  

3. On Channel A’s Logic tab, enter: inA = not in1; 

4. On Channel B’s Properties window, select “Delayed Trigger” mode, with a delay and duration of 100 ms each. 
Setup for edge triggering and allow retriggering. 

5. On Channel B’s Logic tab, enter: inB = outA; This logic will cause the delayed trigger to pulse 100 ms after a 
signal from Channel A. 

6. On Channel C’s Properties window, select “Dynamically Delayed Pulse” mode. Set up for scaling by 2N, where 
N = 1, and set the Added Delay to – 200 ? s and the duration to 100 ms. Allow unlimited retriggering. 

7. Since you’ve made changes to multiple channels, go to the Main screen and click the “Set All Channels” button.. 
All of your changes will now be stored in the LC880. 

Now the test is ready. Depress and hold the trigger button. Output A will transition high, causing the delayed trigger 
in Channel B to begin its count. When Channel B sends its output pulse, the dynamic delay in Channel C will 
calculate the time difference (100 ms), multiply it by 32/16, and subtract the 200 µs offset. 199.8 ms after receiving 
the signal from Channel B, Channel C will send a 100 ms output pulse. 
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Toggled Output Mode 

This mode toggles its output state upon every input pulse. It functions like a flip-flop and is useful for a variety of 
logical and control purposes. The minimum input-pulse state duration is 10 ns and the edge-to-toggle delay is < 20 
ns. 

 

The only user settings for this mode are the initial state, which may be either low or high. 

The front panel LED for the channel will glow green when the output is low or red when the output is high. 

 

Logic 
A channel’s logic determines the combination of signals that will trigger the channel. Signals from the eight inputs, 
and outputs from the other channels, can be combined to trigger any channel. The “Logic” properties tab lets you set 
the triggering criteria for a channel. This tab only appears for timing modes which can respond to logic. 
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To set up a channel’s logic, open the channel’s Settings screen, then click the “Logic” tab. Type the logical statement 
in the large white box.  

A typical logical statement may read:  

inB = not in2; 

This statement means, “Trigger Channel B when the signal at input 2 turns low (drops below 0.2 Volts).” Once 
triggered, the channel will function according to its timing properties (see below).  

You can employ compound arguments in logical statements, such as: 

inB = not outC and in2; 

This statement means, “Trigger Channel B when the output of Channel C is low while Input 2 is high.” 

Here’s an example that’s more complicated still: 

inB = (in1 or in2) and (outC or outD); 

Here, Channel B requires a signal from Inputs 1 or 2, combined with a signal from Channels C or D, in order to 
trigger. 

The following rules apply to logical statements: 

- Logic is case-sensitive. Use lowercase and capital letters as in the samples above. 

- Spaces matter. Use spaces per the samples above. 

- If a logical statement consists of more than one line, each line should end in a carriage return. 

- The last line of a statement must end in a semicolon.  

- Multiline comments should begin with /* and end with */. Single line comments can be started with //. 
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- Many symbols can be written in “shorthand” to speed up the process of writing logic. For example, “not in1” 
can be written “!in1”. Refer to the list below for other shorthand characters. 

The following symbols can be used in logical statements: 
 Symbol Shorthand 
 not ! 
 and & 
 or | (vertical line) 
 xor # 
 HIGH none 
 LOW none 
 ( ) none 
 ; none 

Predefined Variables 

To speed logic coding we’ve predefined a number of Predefined variables:  

- inA— inH: the input of channels A through H. These signals only appear internally at the input of the timing 
channel; they are not connected to the rear BNCs. These symbols can only be on the left-hand side of an 
assignment (=), for example inA = outB; is valid, but inA = inB; is not. 

- in1— in8: inputs 1 through 8 from the rear BNC connectors. 

- outA— outG: outputs of channels A through G that appear at the rear BNC connectors. 

            

 NOTE: The output of channel H is not internally connected to the logic 
processor. It cannot be used in logic statements unless it is externally connected 
to another channel input.  
            

- LOW, FALSE: trigger input always low.  

- HIGH, TRUE: trigger input always high. 

To view the variable names that are recognized by Trigger, click “Predefines” on the “Logic” tab. The following 
dialog box opens. 
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Double click a variable to copy it to your Logic statement. You can also select the variable then click “OK.” 

Global Variables  

Logical statements that are used repeatedly in your experiment can be stored as “global variables.” With global 
variables, complex logic is easier to read and debug. 

Say that several channels in your experiment need to be triggered by the same event. For example, Channels F, G 
and H must trigger when: 

(in1 or in2) and (outC or outD). 

Rather than typing that logic each time, you may define it as a variable: 

event1 = (in1 or in2) and (outC or outD); 

Now you can use “event1” in the logic for Channels F, G and H: 

inF = event1; 

To view the global variables, click the “Globals” button on the “Logic” tab. The “Globals” screen will open: 

 

 To create a new global variable, type the variable’s name followed by its definition. In this example we’ve defined 
variables named “arm” and “fire.” Be sure to end your definition with a semicolon. Click “Apply” to save the 
variable. 

Parsing 

When you have completed a logical statement, click “Apply” or “OK.” Trigger will check the statement for 
syntactical and logical errors and will report any mistakes to you by line number. 

Sending Logic 

When you alter channel logic you must transfer the changes to the LC880 to implement it.  
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To transfer logic to the LC880, click the “Set All Channels” button  , or choose Program>Program All 
Channels.  

While the logic is transferring, the Power LED on the LC880 will turn red. Logic transferring typically takes only a 
second, though it may take slightly longer for complex programs.  

After the transfer, the logic settings reside in the LC880, even if you turn the unit off or disconnect it from the PC. 

 



33 

RUNNING EXPERIMENTS 
Once you’ve created a program you’re ready to set up and perform your experiment. 

Storing and Recalling Experiment Files 
As mentioned earlier, an experiment file is a document which resides on your PC, containing all of the logic, 
properties, and settings profiles for a particular experiment. Experiment files bear the .trg extension. 

To save an experiment, choose “Save As” from the File menu. Name the file, then store it on your hard drive in an 
accessible place. 

To reuse an experiment file, choose File>Open, and locate the file. When you click “OK,” the file’s settings will 
appear in Trigger. Click “Send Properties,” then click “Send Logic” to download the settings to the LC880. You can 
also choose “Program All Channels” and “Program Logic” from the Program menu. 

To print a text summary of the settings in the current experiment, choose File>Print. 

Front Panel Controls and Indicators 
The front panel of the LC880 is designed to help you run experiments without computer control. This functionality 
allows you to program the unit at a workstation, then to move the unit to the experimental environment. 

Channel LEDs 

As mentioned earlier, the LEDs for each channel provide information on each channel’s status: 

a) A green light on a channel typically indicates that the channel is waiting for an input trigger.  

When a channel is in Fixed Output, Clock Pulse, Output=Input or Toggled timing modes, the green light 
indicates that the output is currently LOW for that channel. 

b) A red light typically indicates that the channel is in the process of triggering.  

When a channel is in Fixed Output, Clock Pulse, Output=Input or Toggled timing modes, the red light 
indicates that the output is currently HIGH for that channel. 

c) When a channel indicator is steadily off, the channel is disabled (see Enable/Disable Channels below).  
The channel indicator also turns off during delays and while waiting for the input to return low for an 
edge trigger. 

             

 NOTE: Channel LEDs provide important information about the channels, but an 
oscilloscope remains a useful tool for diagnosing channel outputs, particularly for 
high-speed experiments.  
            

ALL Channel LED 

The All Channel LED shows the overall status of the channels.  

A green LED indicates that the external inputs and ouputs are enabled and functioning normally 

A red LED indicates that the external inputs and outputs are frozen.  (See Running Experiments: Disable/ Enable 
channels below). 
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Selecting a Channel from the Front Panel 
Each front panel function requires that you select a channel (or ALL channels) and a function.  

To select a channel, click the channel button. The channel LED will glow brightly, as will the available Function 
buttons. The ALL channels button will function similarly to select all channels.  You can now perform one of the 
front panel functions on that channel. 

 In the image below, the F channel button has just been pressed. The buttons for the four available functions (Enable, 
Disable, Trigger and Reset) glow yellow. 

 

 

Performing a Front Panel Function 
Front panel functions can be accessed in one of two ways: 

- select a channel (or ALL channels), then choose a function 

- select a function, then choose a channel (or ALL channels). 

There is no significant difference between these two approaches.  

In the image below, the Enable button has just been pushed.  The channel buttons and the ALL channel button are lit. 
Pressing one of these buttons will now enable the channel(s). 
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Enable/Disable ALL 

Occasionally you’ll need to abort an experiment in progress, due to equipment problems, etc. The quickest way to 
shut down an experiment is to disable the inputs and outputs of the LC880. To do so, click the “Disable” button, then 
click a particular channel button, or the ALL channels button. The inputs and outputs for all channels will be 
immediately frozen.   

Following a Disable command, you can re-enable the inputs and outputs by clicking the “Enable” button, then 
clicking a channel button or the ALL channels button.  

Enable/Disable Channel 

It is sometimes convenient to disable or suspend a channel temporarily.  The Enable/Disable channel functions 
provide this capability from the front panel.  The channel disable function is volatile: channels will be re-enabled on 
power up.  To disable a channel in a non-volatile way, set the timing mode to “Fixed,” or disable the input by setting 
the logic to “LOW,” etc. 

You can also disable a channel, or all channels, from within Trigger (see Trigger Software Interface: General 
Settings: Disable/Enable Channels).  

Trigger a Channel 

This function lets you simulate an input trigger on a channel, regardless of the channel’s logic settings. This is a 
useful way to initiate a timing sequence without actually performing the live experiment. You can also trigger a 
channel from within the Trigger software (See Channel Properties: Force Trigger above). 

             

 NOTE: You cannot trigger ALL channels, only individual channels.  
            

Reset  

The Reset button returns the selected channel or ALL channels to the last programmed settings. It resets and 
reinitializes retriggering counters and reinitializes the delay of any channels that are undergoing a delay sweep. 
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Store/Recall Settings Profiles 
As you know, you can store 64 different “Settings Profiles” in the LC880. A Settings profile includes properties, 
variables, and logic for each of the eight channels. Storing Settings profiles lets you switch between settings while 
running an experiment, to test different timing criteria, initial conditions, etc., without re-plugging or reprogramming. 

Settings profiles are enumerated AA, AB… , BA, BB…  HH, and they are accessible by pressing those buttons. 

To store the current settings in a Settings profiles: 

1. Click the Store button 

2. Click the two-letter combination for the Settings profile. 

Similarly, to recall a stored Settings profile: 

1. Click the Recall button 

2. Click the two-letter combination for the Settings profile. 

You can recover these settings even after the unit has been turned off or disconnected. The most recently used setting 
is automatically loaded when the LC880 is powered up.  If you attempt to recall an invalid setting, the power LED 
flashes red and the system retains its previous setting. 

To recall a setting profile from within Trigger: 

1. Click the “Recall Setting… ” from the Program menu. 

2. Click on or type in the desired setting (case insensitive). 

3. Click “Recall.” 

 

To store a setting profile from within Trigger: 

1. Click the “Store Setting… ” from the Program menu. 

2. Click on or type in the desired setting (case insensitive). 

3. Click “Store.” 
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To Our Valued Customers 

Most Current User’s Manual and Trigger Control Software: 

To obtain the most up-to-date version of this user’s manual and the Trigger Control Software, please 
refer to our website at: 

http://www.labsmith.com 

Corrections to this user’s manual and Trigger Control Software: 

Please contact us at support@labsmith.com to report any information that is missing or errors in the 
user’s manual or Trigger Control Software. 

Sample files and Application Notes: 

Sample files, application notes and other technical information are available on our website.  To 
request sample files specific to your application, please contact support@labsmith.com. 


