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Introduction to Translators

Maya Translators
In addition to the translators provided in plug-in format with Maya (IGES, FBX,
DXF, Alias wire, OpenFlight, and so on), Maya also supports a range of
translation formats through the Autodesk DirectConnect plug-in.

For more information, see the Autodesk DirectConnect Help option in the Help
menu of Maya.

Updates to the certain Maya translator plug-ins may be available. See the
Autodesk support pages for Maya.
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FBX file translator

FBX file translator
The Autodesk® FBX® translator plug-in allows Autodesk® Maya® to read and
write the latest version of FBX files. FBX allows all types of data to be packaged
into one file format that can be used by most of today's 3D authoring software.
With FBX, you don't have to worry about which supported software application
the data came from, or how you are going to convert it. FBX acts as an
interchange hub between most 3D software, regardless of software vendor or
computer platform.

This lets you exchange complex data between Maya, Autodesk® MotionBuilder®,
Autodesk® 3ds Max®, and Autodesk® Mudbox® while preserving the data’s
overall behavior, making it easier to integrate all these products into a single
pipeline. For example, with FBX you can exchange animation data and character
rigs between Maya and MotionBuilder, or point data between Maya and new
versions of MotionBuilder and 3ds Max.

The FBX plug-in is installed automatically with Maya, and is loaded by default
on startup. If you have previously unloaded this plug-in, you can load it by
doing the following:

1 Select Window > Settings/Preferences > Plug-in Manager.

2 Click the Load button for fbxmaya.mll.
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NOTE

Development of the FBX plug-in is an ongoing process in order to provide you
with seamless interoperability between all FBX-supporting products. The support
for Maya functions and features is ever-growing and improving.

You should therefore check for the latest version of the FBX plug-in from the
Autodesk website (www.autodesk.com/fbx) or by clicking the Check for web updates
button in the FBX Importer or Exporter windows. The Maya FBX Plug-in is available
for free download.

FBX plug-in documentation

For more information on the version of FBX installed with Maya, select Help
> Autodesk FBX Help from Maya’s main menu.

Importing into or exporting from Maya to FBX

In the Autodesk FBX Help, refer to sections Exporting from Maya to an FBX
file and Importing FBX files into Maya for instructions on how to import or
export .fbx files into or from Maya.

Limitations of FBX

When importing files into and exporting files from Maya, limitations may
apply. Visit the Autodesk FBX Help for the most updated list of limitations,
as well as the list of new functionalities that are supported in the latest version.

FBX Mel Scripting Commands

The following is a list of FBX Mel commands. For more detail on what these
commands do, see the Maya FBX plug-in documentation.

FBXExport -f

FBXExportAnimationOnly -v

FBXExportApplyConstantKeyReducer -v

FBXExportAxisConversionMethod

Add FBX_Root node

FBXExportBakeComplexAnimation -v

FBXExportBakeComplexEnd -v

FBXExportBakeComplexStart -v
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FBXExportBakeComplexStep -v

FBXExportCacheFile –v

FBXExportCameras -v

FBXExportCharacter -v

FBXExportColladaFrameRate

FBXExportColladaSingleMatrix

FBXExportColladaTriangulate

FBXExportConstraints -v

FBXExportConvert2Tif –v

FBXExportDxfTriangulate

FBXExportDxfDeformation

FBXExportEdgeSmoothing –v

FBXExportEmbeddedTextures -v

FBXExportFileVersion

FBXExportHardEdges -v

FBXExportInAscii -v

FBXExportLights -v

FBXExportQuaternion -v

FBXExportQuickSelectSetAsCache –q

FBXExportQuickSelectSetAsCache –v

FBXExportScaleFactor

FBXExportShapes -v

FBXExportSkins -v

FBXExportUpAxis

FBXImport -f [filename] -t

FBXImportAxisConversionEnable –v

FBXImportCacheFile –v

FBXImportCameras -v

FBXImportCharacter -v
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FBXImportConstraints -v

FBXImportConvertDeformingNullsToJoint -v

FBXImportDxfWeldVertice

FBXImportDxfReferenceNode

FBXImportDxfObjectDerivation

FBXImportEdgeSmoothing –v

FBXImportFillTimeline

FBXImportHardEdges -v

FBXImportLights -v

FBXImportMergeBackNullPivots -v

FBXImportMergeAnimationLayers -v

FBXImportMode -v

FBXImportOverrideNormalsLock -v

FBXImportProtectDrivenKeys -v

FBXImportQuaternion -v

FBXImportResamplingRateSource -v

FBXImportScaleFactorEnable

FBXImportScaleFactor

FBXImportSetMayaFrameRate -v

FBXImportSetLockedAttribute -v

FBXImportShapes -v

FBXImportSkins -v

FBXImportUpAxis

FBXConvertUnitString

FBXGetTakeComment

FBXGetTakeCount

FBXGetTakeIndex

FBXGetTakeLocalTimeSpan

FBXGetTakeName
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FBXGetTakeReferenceTimeSpan

FBXLoadExportPresetFile -f

FBXLoadImportPresetFile -f

FBXRead -f

FBXResetImport

FBXResetExport

FBXResamplingRate -v
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IGES Translator plug-in

IGES Translator plug-in
Overview of IGES Translator plug-in

The IGES file translator plug-in extends Maya to help address the needs of those
customers familiar with files in the IGES format. This data translator is capable
of both reading existing IGES files into Maya and exporting files from Maya to
the IGES format.

Install IGES translator

This translator is installed with Maya.

Import/Export IGES files

To load the IGES file translator

1 Open Maya and select Window > Settings/Preferences > Plug-in Manager.

2 Click the loaded button for the IGES file translator.

To import a IGES file

■ Select File > Import and select the IGES file you want to open from the file
browser selection.

To export an IGES file

■ Select File > Export All (or File > Export Selection), and select IGESExport
from File type drop-down list.
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IGES import options

To access these options, the IGES translator plug-in must be loaded, and you
must change the File Type drop-down box to IGES.

Default Trim Curves Select Parameter Space trimming (curves defined in the
parameter space of the surface) or World Space trimming (curves defined in
world space of the model). The default is to use parameter space trimming.

IGES Trim Flag. In IGES a trimmed surface can specify its preferred trimming
method, either world space or parameter space. Choosing this option tells
Maya to use whatever method is preferred in the file.

Scale Factor Scales all imported geometry by a common factor. This allows
very large scenes to be viewed more easily.

NOTE IGES files often contain geometry that is very large. In order to view this
geometry properly, the Scale Factor can be used to scale it down. Otherwise, in
the viewing window, select View > Frame All to frame your selection, and if the
geometry does not appear, it is beyond the camera's rear clipping plane. Select
View > Camera Attribute Editor and set the “Far Clip Plane” to a value sufficiently
large such that the geometry is visible.

Level Mapping Controls whether layers from a IGES file are imported. The
default is to always import layers.

IGES export options

To access these options, the IGES translator plug-in must be loaded, and you
must change the File Type drop-down box to IGES.

Scale Factor Determines the factor by which the resulting geometry in the
IGES file is scaled upon export (default: 1.0000).

Known Issues

■ If there is IGES created geometry in the scene then the plugin cannot be
unloaded. Delete all data and unload plugin.

■ The 500 Series (BREP) entities are unsupported.

IGES entity support
IGES entities supported in Maya

IGES EntityFormType
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circular arc0100

composite curve0102

conic arc0-3104

copious data1106

copious data2106

copious data11106

copious data12106

closed area63106

plane0*108*

plane1108

line0110

parametric curve0112

parametric surface0114

ruled surface0-1118

surface of revolution0120

tabulated cylinder0122

transformation matrix0124

rational b-spline curve0-5126

rational b-spline surface0-9128

offset curve0130

offset surface0140

boundary entity0141
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curve on surface0142

bounded surface0143

trimmed surface0144

subfigure definition0308

associativity instance7,9402

property - definition levels1406

singular subfigure instance0408

name15406
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StudioImport Plug-in and
Translator

StudioImport
StudioImport is a translator for Alias® Studio® wire files (previously known as
Alias wire files).

NOTE Alias® StudioTools® v10 and later (Autodesk AliasStudio) uses a different file
format for its wire files. This file format should cause no change in your everyday
use of StudioTools because the file provides all of the same capabilities as the old
wire file. This new file format is compatible with new releases of StudioTools, so you
won't need a translator to use Version 10 files in future releases.

To load the StudioImport file Translator

1 Start Maya and select Window > Settings/Preferences > Plug-in Manager.

2 Click the loaded check box for the StudioImport plug-in.

To open a Studio wire file

■ Select File > Open Scene and select the Studio wire file you want to open
from the file browser selection.

StudioImport conversion issues

The following are known issues for StudioImport conversion.

■ Studio SID data is not supported in the StudioImport plug-in.

4
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■ Any paint data is not translated into Maya. SID shapes translate as Maya
surfaces.

■ Poly sets lose texture coordinates on translation to Maya.

■ Area and Linear lights are not transferred correctly.

■ DOF camera settings are different in Maya after translation.

■ When Maya renders (or raytraces) light fog on a light with a colored texture
channel, the fog receives that texture, whereas in Studio it does not.
Importing Studio files with lights that have colored texture channels can
cause confusing results because the default sampling rate is 1. Try using
20 to 30 samples.

■ Ortho Cameras are not fully supported in StudioImport. Change Include
cameras to false for import, or adjust the translation of ortho cameras
manually after import.

■ No refraction jitter in Maya renders after import from StudioImport.

■ Only the simplest forms of Environment fog are translated correctly.

■ Working with shells from Studio can cause problems with light linking
and rendering. Unstitch in Studio before importing wire file into Maya.
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Export plug-ins

MayaToAlias export plug-in
MayaToAlias is a Maya plug-in for Windows® 32-bit that uses OpenMaya API
to get the scene information from Maya, and then exports it using OpenModel
to one of the following, depending on which export file format is chosen:

■ a wire file (version 9.7.3)

■ IGES file

MayaToAlias exports the following from Maya to wire files:

■ transform nodes

■ hierarchy

■ instanced objects

■ NURBS curves

■ NURBS surfaces

■ trimmed surfaces

■ meshes

■ cameras

MayaToAlias exports the following from Maya to IGES format:

■ transform nodes

■ instanced objects (become copied objects in IGES)
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■ NURBS curves

■ NURBS surfaces

■ trimmed surfaces

■ meshes

To load the MayaToAlias plug-in

1 Open Maya and select Window > Settings/Preferences > Plug-in Manager.

2 Click the loaded check box for the MayaToAlias plug-in.

Now you can export Maya content to wire or IGES format through the
usual export mechanism.

To export a Maya file to FBX or IGES

1 Select File > Export All or File > Export Selection.

2 Select a file name and file type, and then click Export All or Export
Selection.

FBX and IGESexport are options in the File Type pull-down menu.

Troubleshooting

■ If you get an error message when using MayatoAlias of the form “Creating
surface fails - node [nodename], it is because Studio Tools and Maya have
different requirements for a valid NURBS surface. Valid NURBS surfaces in
Maya may not be valid in Studio Tools, hence they are not created. Usually
the problem can be fixed by changing Open to Periodic in either U or V
direction (this can be done by using the Edit NURBS > Open/Close Surfaces
tool. Ensure that the Surface direction is set correctly by opening the option
box).

■ If you want to export a Maya mesh to a wire file and this mesh contains
a face which has hole(s) in it, you need to triangulate this face first.

Wavefront (OBJ) export plug-in
The objExport plug-in lets you export Maya polygon data to the Wavefront
OBJ ASCII file format. It successfully converts:

■ Maya texture coordinate and vertex normal information.
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■ Maya renderable set information into material names.

■ Maya component set information into groups.

For details on exporting to OBJ format, see Basic Tools.

NOTE objExport does not export OBJ formatted curves, surfaces, smoothing
groups, or point group materials. It also does not support NURBS. Use the
MayaToAlias plug-in for scenes that contain NURBS surfaces.

NOTE Autodesk provides the source code for the objExport plug-in as part of the
Maya Developer’s Toolkit. Ensure that you have installed the Toolkit, and you can
find the source code in .../files/devkit/plug-ins/objExport.cpp.

To load the objExport plug-in

1 Open Maya and select Window > Settings/Preferences > Plug-in Manager.

2 Click the loaded check box for the objExport plug-in.

To export a file in OBJ format

1 Select File > Export All or File > Export Selection.

2 Selectf OBJexport as the file type and then click Export.

RenderMan (RIB) export plug-in
The ribExport plug-in adds the new file format RIBexport to the File > Export
All options menu. This lets you export scenes created in Maya to the RIB
(Pixar® RenderMan®) format.

NOTE This plug-in only supports the Export All file access mode. RIB file import
is not supported.

NOTE This plug-in is supported on 32-bit Windows and 64-bit Linux only.

The ribExport plug-in supports ambient, directional, point, and spot lights.
Simple non-textured shaders are supported, although only the shader color
is exported. All other shading attributes are ignored. Phong and Blinn shaders
are exported as “plastic”; Lambert shaders are exported as “matte.” Per-face
shading groups are not supported; only shading groups that are assigned to
objects or object instances are exported.
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When exporting Maya scenes into RIB, note that the # character is a special
formatting character in RenderMan image names. To include a real # character
in a RenderMan image name, you must use “##”. (See section 4.1.10 of the
RenderMan user manual for information on formatting.)

The image name constructed by the ribExport plug-in includes the contents
of the “imageName” attribute of the renderable cameras. If you want to include
the special RenderMan formatting characters in an image, the imageName
attribute is the place those characters should be placed.

NOTE Autodesk provides source code for the ribExport plug-in as part of the Maya
Developer’s Toolkit. If you install the Toolkit, you can find the source code in
.../files/devkit/plug-ins/ribExport.cpp.

To load the ribExport plug-in

1 Open Maya and select Window > Settings/Preferences > Plug-in Manager.

2 Click the loaded check box for the ribExport plug-in.

To export a file in RIB format

1 Select File > Export All.

2 In the Files of type field, select RIBexport as the file type and then click
Export All.

RIBexport Options
Single File Output If Yes, all frames is written to a single .rib file. If No, all
frames are written to separate .rib files.

Extension Padding If the Single File Output option is off, this option specifies
whether the RIB file extensions is padded with 0’s.

Geometry Motion Blur Specifies if geometry motion blur information is
written to the RIB file.

Pixel Samples Specifies the number of samples taken for each pixel. This
value is used for both the X and Y directions.
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Maya OpenFlight
Importer/Exporter

Overview of OpenFlight
The OpenFlight® file translator plug-in provides extended functionality to Maya
to help address the needs of the Visual Simulation customer. This is done by
providing a data translator to read the currently existing OpenFlight databases
into Maya. Accompanying the OpenFlight database importer is an OpenFlight
Exporter. Functionality that was found to be missing from Maya was added in
the form of new node types that can be created and edited from within the
Maya modeling environment.

OpenFlight is installed with Maya.

Import/export OpenFlight files
To load the OpenFlight file Translator

1 Open Maya and select Window > Settings/Preferences > Plug-in Manager.

2 Click the loaded check box for the Open/Flight plug-in, fltTranslator.

OpenFlight is a 3D file format. The file importer/exporter is an OpenMaya
plug-in. Any of the Beads that can be imported into Maya can also be exported
(see Supported OpenFlight Beads on page 32).

The exported file contains a subset of the imported data. External file or texture
references point to the referenced files in their current directories. Should it be
necessary to move an exported file to a location that does not allow access to

6

19



the original file references, these referenced files can be copied into the same
directory as the target OpenFlight file and the references read correctly.

To open an OpenFlight file

■ Select File > Open Scene and select the OpenFlight file you want to open
from the file browser selection.

To export an OpenFlight file

■ Select File > Export All (or File > Export Selection), and select OpenFlight
from File type drop-down list.

Version compatibility

You can read (import) versions from 14.2 up to 15.7, but only export 15.7
files.

User Interface
OpenFlight Menu

An OpenFlight menu is added to the main window when the OpenFlight
plug-in is installed. The menu contains the following menu items:

■ OpenFlight > Create Light Points on page 20

■ OpenFlight > Create Lights on Curve on page 21

■ OpenFlight > Edit Light Point Colors on page 21

■ OpenFlight > Edit Light Point Normals on page 22

OpenFlight > Create Light Points
Invokes the fltLightPoints command to create a new set of light points in the
scene.

OpenFlight > Create Light Points > 
Number of Light Points Sets the number of light points.

Distance Between Light Points Set the distance between light points.
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Light type Select one of Omnidirectional, Unidirectional, or Bidirectional.

Light Normal Only active when the light type is unidirectional or
bidirectional. Set the light normal.

Light Color Set the light color.

NOTE The light colors only appear in shaded mode. Turn on Smooth Shading to
see the colors.

OpenFlight > Create Lights on Curve
Invokes the fltLightsOnCurve script to create light points along a selected
curve.

OpenFlight > Create Lights on Curve > 
Number of Light Points Sets the number of light points.

Light type Select one of Omnidirectional, Unidirectional, or Bidirectional.

Light Color Set the light color.

NOTE The light colors only appear in shaded mode. Turn on Smooth Shading to
see the colors.

OpenFlight > Edit Light Point Colors
Used to change the color of selected light points.

To change the color of selected light points

1 Select the light points to modify.

2 From the OpenFlight menu, select Edit Light Point Colors.

The Light Point Color Editor appears.

3 Select the color to apply to these light points in the color slider.

4 Press the Apply (or Apply and Close) buttons to apply the color to the
selected light points.

This dialog box works with light points selected in object mode and with light
points selected in component mode.
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OpenFlight > Edit Light Point Normals
Allows you to change the normal of any selected light points.

To change the normal of any selected light points

1 Select the light points to modify.

2 From the OpenFlight menu, select Edit Light Point Normals.

The Light Point Normal Editor appears.

3 Enter the value of the new normal to apply to these light points.

4 Press the Apply (or Apply and Close) to apply set the normal of the
selected light points.

This dialog box works with light points selected in object mode and with light
points selected in component mode.

OpenFlight workflow considerations
The following are workflow issues you should consider when working with
OpenFlight files in Maya.

When importing files

OpenFlight models are built with a Z-up axis up orientation. When a model
is read into Maya using File > Open Scene, the default orientation in Maya is
repositioned so that Z is the up vector (normally Maya’s Y axis is oriented as
the up vector).

When files are read into Maya using File > Import, the orientation is not
affected by the import. You must correctly orient the imported data yourself.

When exporting files

Here are some of the limitations to consider when exporting an OpenFlight
file from Maya:

■ Models are always exported in color RGB mode.

■ The units are always meters.

■ No animation can be exported.

■ No cameras can be exported.
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■ The exporter only supports a single texture map per face. Layered textures
results in only the first texture being exported.

■ 2D and 3D procedural textures are not exported.

■ Many Maya rendering parameters have no direct equivalent in OpenFlight.

■ Degree of Freedom Beads are only created when Limits are set on a Maya
group/transformation node.

■ No transformations on externally referenced nodes are saved out to
OpenFlight format. To transform a referenced file from within the current
scene, the DAG root objects in the referenced file should be grouped, and
any transformations should be applied to the group node.

Shading Models

Flat Shading

OpenFlight objects have a flat shading flag, which specifies whether the object
is to be drawn with flat shading or Gouraud (smooth) shading. This flag is
now connected with the "Smooth Shading" attribute of polygons in Maya (as
found in the Render Stats tab of the Attribute Editor for the shape).

While OpenFlight supports the flat shading flag at the object level as well as
at the face level, Maya only supports the flag at the object level. Thus, the flat
shading flag of any object imported into Maya must be set identically for the
object and all its faces.

Illumination

The illumination flag of OpenFlight objects specifies whether the object is to
be illuminated by nearby lights or whether it is exclusively self-illuminating.

When importing a self-illuminating object, the following attributes of the
corresponding Maya object are turned off: "Casts Shadows", "Receive Shadows",
"Visible in Reflections" and "Visible in Refractions". When the imported object
is not self-illuminating, all these attributes are turned on.

When exporting a Maya object to OpenFlight, the self-illumination flag is set
if and only if the "Receive Shadows" attribute of the Maya object is turned off.

When using Switch Nodes

Support has been added to Maya for OpenFlight Switch nodes. Switch nodes
allow for an array of visibility masks to be applied to a group transform node.
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Each child node’s visibility is represented by one bit in the visibility mask.
(Current implementation only supports up to 32 children.)

The switch node is implemented as a helper node that is applied to a group
transform node and can be viewed and selected through the Hypergraph. The
currently selected mask can be modified through the Attribute Editor associated
with the switch node.

Switch Nodes are created automatically when an OpenFlight database with
Switch Nodes is read into Maya. They may also be created using the fltSwitch
command from within the Maya modeling environment.

Switch node attributes

FlagsDefaultTypeName Long (Short)

R0Tint32outputVis (out)

RWSK0Tint32curMask (in)

RWS0Tint32maskWidth (mkw)

RWS0Tint32numMasks (nmk)

ARWS0Tint32masks (mks)

fltSwitch Command
Synopsis FltSwitch [flags]

Return Value [string[]] (object name or node name on create)

Description This command is used to create, edit or query Switch Nodes from
within Maya.

Flags -p (c) The parent group transform node.

-cm (eq) Set or query the current switch node mask.

-n (ceq) The name of the node to be operated on.

-am (e) Append a mask based on the current object selection.

-em (e) Edit the currently active mask based on the current object selection.

-dm (e) Delete the current mask.
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Example

// Create a Switch node

fltSwitch -n sw1;

// After some geometry has been added under sw1, masks maybe cre

ated by selecting the geometry to be visible under the switch for

the mask and and then using the fltSwitch command as follows.

fltSwitch -e -am -n sw1;

// Setting the current mask to the desired switch will enable that

mask.

fltSwitch -e -cm 0 -n sw1;

When using Light Points

Support has been added to Maya for OpenFlight Light Points. Light Points
allow for an array of lights to be created that have no render properties.

They can be imported & exported into OpenFlight files, with the following
restrictions

Import

■ Modeling lights are not supported

■ OpenFlight Infinite lights are imported into Maya as directional lights

■ OpenFlight Local lights are imported into Maya as ambient lights

■ OpenFlight Spot lights are imported into Maya as spot lights

Export

■ Directional lights are exported as infinite lights

■ Ambient lights are exported as local lights

■ Spot lights are exported as spot lights

■ Light types not supported by OpenFlight (area lights, point lights) are
exported as infinite lights

■ Modeling lights are not supported

NOTE

■ One light palette is created for each light source

■ The orientation of the light palette is always Yaw = 0, Pitch = 0
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Light Points are implemented as a shape in Maya. They are created
automatically when an OpenFlight database with Light Points is read into
Maya. Additionally, Light Points can be created from within Maya using the
OpenFlight menu commands or the MEL command, fltLightPoints.

Each LightPointShape can contain any number of Light Points. By selecting
a LightPointShape and opening its Attribute Editor, all Light Points attributes
are available. Many of these attributes have no visible effect within Maya but
can still be edited, saved, and exported.

Light Point attributes

FlagsDefaultTypeName Long (Short)

RWS0double3LightPointsMin
(lpmn)

RWS0double3LightPointsMax (lp-
mx)

RWS0Tint16SurfaceMaterial-
Code (smc)

RWS0Tint16FeatureId (fid)

RWS0Tint32BackColor (bc)

RWS0EnumDisplayMode (dm)

RWS0FloatIntensity (ity)

RWS0FloatBackIntensity (bit)

RWS0FloatMinimumDefocus
(mndf)

RWS0FloatMaximumDefocus
(mxdf)

RWS0Tint32FadingMode (fm)

RWS0Tint32FogPunchMode
(fpm)
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RWS0Tint32DirectionalMode
(drm)

RWS0Tint32RangeMode (rm)

RWS0FloatMinimumPixelSize
(mnps)

RWS0FloatMaximumPixelSize
(mxps)

RWS0FloatActualSize (aps)

RWS0FloatTransparentFal-
loffPixelSize (tfps)

RWS0FloatTransparentFalloffEx-
ponent (tfe)

RWS0FloatTransparentFalloffS-
calar (tfs)

RWS0FloatTransparentFal-
loffClamp (tfc)

RWS0FloatFogScalar (fs)

RWS0FloatSizeDifferen-
ceThreshold (sdt)

RWS0EnumDirectionalType
(drt)

RWS0FloatHorizontalLo-
beAngle (hla)

RWS0FloatVerticalLobeAngle
(vla)

RWS0FloatDirectionalFallofEx-
ponent (dfe)
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RWS0FloatDirectionalAmbi-
entIntensity (dai)

RWS0FloatAnimationPeriod
(ap)

RWS0FloatAnimation-
PhaseDelay (apd)

RWS0FloatAnimationEnabled-
Period (aep)

RWS0FloatSignificance (sig)

RWS0Tint32Calligraphic (call)

RWS0Tint32Flags (flgs)

RWS0FloatXanimRotateAxis
(xra)

RWS0FloatYanimRotateAxis
(yra)

RWS0FloatZanimRotateAxis
(zra)

ARWS0Double3LightColors (lc)

ARWS0Double3LightNormals (ln)

RW00x58000014InputLightPoints
(ilp)

RS00x58000014OutputLightPoints
(olp)

ARS00x58000014WorldLightPoints
(wlp)

RWS00x58000014CachedLightPoints
(clp)
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RWSKfalseBooleanDisplayNormals (dn)

RWSKfalseBooleanDisplayLobe (dl)

Light point functionality has been extended to display the effects of several
more attributes of light point shapes:

■ Light Directionality > Type

■ Light Directionality > Front Intensity

■ Light Directionality > Ambient Intensity

■ Light Directionality > Back Intensity

■ Lobe Angle > Horizontal

■ Lobe Angle > Vertical

■ Lobe Angle > Roll

■ Display > Normals

■ Display > Lobe

Both Display > Normals and Display > Lobe have no Creator equivalent. They
are used to control the visibility of the normal and lobe of light points as you
develop your scene inside of Maya. Note that you cannot display lobes of
omni-directional lights.

Currently the back color only displays as red regardless of the actual value set.
This default color does respond to the back and ambient intensities to enable
more sophisticated simulation.

fltLightPoints Command
Synopsis fltLightPoints [flags]

Return Value [string[]] (object name or node name)

Description This command is used to create Light Points from within Maya.

Flags -d (c) The distance between light points.

-c (c) The number of light points to be created.

-n (c) The node name to be created.

-p (c) The parent group transform node.
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-nt (c) If specified, then no parent transform is created. In this case a parent
must also be specified with the –p flag.

-clr (ce) The RGB color value to be applied to all created light points. Each
value should be in the range from 0.0 - 1.0. In edit mode if no light points
are selected then the light point shape name must be specified using -n.

-nml (ce) The Normal to be applied to all created light points. In edit mode
if no light points are selected then the light point shape name must be specified
using -n.

dt (ce) Type must be one of: "OMNIDIRECTIONAL", "UNIDIRECTIONAL", or
"BIDIRECTIONAL". By default, light points are omnidirectional.

-dnml (ce) Enable or Disable the display of normals (true/false

Example

// Create 3 light points spaced 0.5 UI units apart

fltLightPoints –c 3 –d 0.5/

/ this creates a light point string with 5 light points and visible

normals

fltLightPoints -c 5 -dnml true;

// this makes the normals of the selected light points string in

visible and

// changes the light type to be Unidirectional.

fltLightPoints -e -dnml false -dt UNIDIRECTIONAL;

fltLightsOnCurve Script
Synopsis fltLightsOnCurve [arguments]

Return Value None

Description This script uses an existing curve and creates a given number of
Light Points using the currently selected curve as a placement guide. The Light
Points are evenly spaced along the curve.

Note—The curve is used for construction purposes only and is modified by
this script.

To use this script

1 Create a curve to use as a placement guide for the Light Points.

2 Select the curve and then execute the script.
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Example

// Create 3 Red Light Points equally spaced along the selected

curve

fltLightsOnCurve 3 1.0 0.0 0.0;

Arguments Arg1 An integer that specifies the number of Light points to be
created.

Arg2 A float that specifies the Red component of the assigned color for the
Light Points (0.0 – 1.0)

Arg3 A float that specifies the Green component of the assigned color for the
Light Points (0.0 – 1.0)

Arg4 A float that specifies the Blue component of the assigned color for the
Light Points (0.0 – 1.0)

Degree Of Freedom (DOF) Nodes

All transform nodes in Maya can represent DOF nodes. They each have limit
information available and by default work within their own co-ordinate space.

To create a DOF from a Maya transform node

■ Set a limit on a group transform node from the Attribute Editor.

Level Of Detail (LOD) Nodes

Maya’s LOD nodes work slightly differently from the OpenFlight LOD nodes.
To simulate the behavior of OpenFlight LOD nodes, all children of an
OpenFlight LOD node are grouped together under a single group transform
node that is controlled by the LOD node. A null transform node can also be
inserted before and/or after the controlled LOD node to satisfy Maya’s switch
in/switch out requirements.

NOTE Deleting these nodes cause the LOD to behave incorrectly.

Maya’s LODs are also tied to a particular camera. When importing an
OpenFlight file, a camera named fltLOD is created. To activate the LOD
behavior, you must use this camera. If new LOD nodes are created from within
Maya, they should likewise be associated with the LOD camera.
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Supported OpenFlight Beads
The following table provides comparisons between OpenFlight and Maya.

Maya equivalent/commentOpenFlight Beads

Control Records

Instanced geometryInstance Definition

Instance group nodeInstance Reference

Changes move up to the previous parent
in the DAG

POP

Creates a child under the current parentPUSH

Unsupported Control Records

Extension

See PUSH SubfacePOP Subface

Maya cannot support hierarchy on co-
planer surfaces. Instead the next face to be

PUSH Subface

created is offset by 1 mm in the direction
of the normal.

Reserved for MultiGenPop Attribute

Reserved for MultiGenPush Attribute

Primary Records

Maya transforms are used to represent
DOF’s. See OpenFlight workflow consider-
ations on page 22 for more information.

Degree-of-Freedom Record

File reference to another OpenFlight data-
base.

EXTERNAL REFERENCE

Shape node for a face. Faces are part of a
polymesh within Maya.

FACE
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Group transform node.GROUP

Header record for an OpenFlight file. Sets
orientation, field of view, etc. Sets the ap-
propriate orientation and UI units.

HEADER

Level of detail group node.Level-of-Detail

A Light.Light Source

A special node type associated with the
OpenFlight translator. See When using
Light Points on page 25” for more details.

Light Point

Transform node.OBJECT

A special node type associated with the
OpenFlight translator. See “Switch Nodes”

SWITCH

under “Work Flow Considerations” for
more details.

Unsupported Primary Records

Allows for the modeling of databases
without Z information

Binary Separating Plane

B-spline, Cardinal, also known as Catmull-
Rom, and Bezier.

Curve

Continuously Adaptive Terrain Skin. A tri-
angle mesh for high fidelity, real-time
viewing.

CAT

Clip Region

User defined node information.Extension Node

Poly mesh. (This is not widely supported
and may not be available in the first re-
lease)

MESH
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Works in conjunction with LOD node to
morph geometry depending on the dis-
tance from the camera.

Morph Vertex List

Road Segment

Road Construction

Road Path

Sound emitter positionSound

Text

Ancillary Records

Not a node but simply a continuation of a
vertex list. Records are limited to 64K in
size.

Continuation

A node name greater than 7 characters to
be applied to the previously read node.

LONG ID

Maya node names do not have this restric-
tion so the name is applied directly to the
node.

Multiple instances of the current transform
node.

REPLICATE

Transform matrix to be applied to the cur-
rent transform node.

TRANSFORMATION MATRIX

Unsupported Ancillary Records

Bounding Volume

CAT Data Header

CAT Data Key

CAT Data Face

3rd party support.Extension Attribute
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Local Vertex Pool

MESH PRIMITIVE

Allows support for up to 8 textures per
vertex (May not be in first release).

MultiTexture

(Pointer to a file that contains grid eleva-
tion data)

Road Zone

Follows Vertex List and contains texture
layer information.

UV List

(Only used for light point faces).Vector

Palette Records

A collection of color entries. Maya does
not use a color palette. Each vertex holds
the corresponding RGB color.

Color Palette

Lights are DAG node entries in Maya.LIGHT PALETTE

Material become Shaders within Maya. See
Texture Palette

MATERIAL PALETTE

Textures are applied to shaders within
Maya. Shaders have an associated shading

TEXTURE PALETTE

group that all nodes using this texture are
connected to.

Implemented as Cameras in Maya. (See
Known Issues on page 36.)

Eyepoint and Trackplane Palette

Light Source Palette

Vertices are part of a polymesh in Maya.VERTEX PALETTE

See Vertex Palette.VERTEX LIST

Followed by vertex data.Vertex Palette Header

Polymesh vertex data.Vertex with Color
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Polymesh vertex data.Vertex with Color and Normal

Polymesh vertex data.Vertex with Color, Normal and UV

Polymesh vertex data.Vertex with Normal and UV

Unsupported Palette Records

Key Table

Linkage Palette

Maya has only 1 line style.Line Style Palette

Name Table

Sound Palette

Texture Mapping

Known Issues
The following outlines the known issues in OpenFlight Version 1.1.

■ It is not possible to change the Maya display color of a unidirectional or
bi-directional light. This color always defaults to red. It is expected that
future releases will have the ability to map back colors to RGB display.

■ UI-based tools are missing to support Switch nodes, and LODs.

■ The only export type supported is OpenFlight 15.7.

■ OpenFlight geometry will only accept textures assigned to the color
channel.

■ Light Sources cannot be exported. Currently, a single ambient light is
always exported.

■ An attempt is made to map Eye Points to Cameras in Maya; however, the
mapping appears incorrect in some cases. Eye points are not exported from
Maya.

■ Track Planes are not supported.
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■ The only way to freeze a DOFs co-ordinates from within Maya is to export
the scene as an OpenFlight file and then read it back in.

■ Articulations on group nodes are not supported.

■ Maya’s LODs need to be extended to better handle the flexibility of the
OpenFlight LODs.

■ If you perform a Freeze Transformations on a translated Light Point, Maya
versions older than 4.0.3 will crash. This can be fixed by updating to Maya
4.0.3 or higher.

■ File textures may only be applied to the color attribute of a Maya shader.
Textures applied to other attributes are ignored.

■ Normals on faces are ignored on import. Maya regenerates the normals
based on the vertex ordering. However, edge settings are preserved.
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