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1. Preface

1.1. Intended Audience

This sites user manual doc is intended to contributor user of FLEXCUBE Direct Banking. Contributor users have
privileges to create new assets and modify existing assets.

1.2. Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

1.3. Access to OFSS Support

https://flexsupp.oracle.com/

1.4. Structure

This document is divided into the following sections: Overview (a brief introduction), Prerequisites, creation of content
creation of pages, ATM branch location configuration steps and configuration for mobile devices.
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http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc
https://flexsupp.oracle.com/GSTOOLSSL/ENG/login_non.htm

1.5. Related Information Sources

For more information on Oracle FLEXCUBE Direct Banking Release 12.0.2.0 sites module, refer to the following
documents:

e Oracle FLEXCUBE Direct Banking Sites Developer Guide,

e Oracle FLEXCUBE Direct Banking Sites Installation Guide.doc
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2. Overview

FLEXCUBE Direct Banking Sites help customers in rapidly rolling out their online banking portals

= FLEXCUBE Sites offers a comprehensive extensible content model which will help a bank build web content
(termed “Assets”) effectively and rapidly

=  The content model helps in building the following “Asset Types”

—  Product Catalogs

Offers

—  Service Catalogs

— FLEXCUBE Direct Banking Widgets

—  Promotions/Recommendations

- Images

— General Content (Articles/Quick Links/Navigation Links etc...)

— ATM and Branch locater
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3. Pre-Requisites

Oracle Webcenter Sites 11.0.8.0.0 should have been installed along with the FC Sites Content Model
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4. Creation of content

As mentioned earlier, FLEXCUBE Direct Banking Sites helps in building content and assemble pages to rapidly
rollout an online portal

This section will demonstrate on how to build content from the various asset model already pre-configured with
FLEXCUBE Direct Banking Sites

3.1 Product Creation

Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials "fwadmin/xceladmin®
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ORACLE WebCenter Sites Version: 11gR1

Secure User Login

Username fevadmin

ORACLE’

Password sssssINee

Forgot password?

LOGIN

[T Remember me

Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on the Contributor icon
on the top-left corner of the screen

Contributor Icon

fwadmin FCWEM_v0.4 @ m

The contributor interface screen is displayed. This is the main workspace for any content contributor
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Content Edit View

¥
A o]
1%
ﬁ Bookmarks (0) 9 | Assignments (0) 4 9
= smarttists (0) + 9 & checkouts (0) “+ 9

Click on Content -> New -> New Product. This will display a sequence of screens that will be required to create a
New Product

Screen 1 -> Enter a name and choose FCWEM-Product from the list of Product Definitions. Click on Continue

m

-

Product

Name:

*Product Definition:

— choose 2 definition — L

-- choose a definition -
FCWEM-Product
FCWEM-ProductApplicationChecklist
FCWEM-ProductApplicationChecklists
FCWEM-ProductApplicationStep
FCWEM-ProductApplicationSteps
FCWEM-ProductComparison
FCWEM-ProductEligibility
FCWEM-ProductExtras
FCWEM-ProductFeatures
FCWEM-ProductOverview
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Screen 2 -> The list of attributes that make up the Product Definition are shown. Enter Values of the attributes one

after the other and click on the "Save" icon.
Product Definition:

*Name: Test Product

*Product Sub Category: v IR5

Card Branding: ~ IR%:

Card Tier: v IR5s

*Product Name:

Product Headline;

Product Short Description:

Any sample product can be viewed to see the kind of details that go into the creation of the product. Click on Search -
> Find Product -> Global Bank Max Savings Account

B ©» mnvai

Content Metadata

Product Definition: Global Bank Max Savings Account

*Name:  Global Bank Max Savings Account
Template:
Product Sub Category:  Savings Accounts
W *Product Name:  Max Savings Account
Product Headline:  Maximize your savings with our Max Savings Account

Product Short Description:

Global Bank MAX Savings Account

We want you to get the most out of your money and save for your future. The best way to do this is to

open a Global Bank Savings Account.

Take advantage of the following features:

® Debit Card

* Internet Banking
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5. Offers Creation

Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials "fwadmin/xceladmin”

ORACLE" WebCenter Sites Version: 11gR1

Secure User Login

Username fwradrnin

ORACLE

Password [IITTYYIT)

Forgot password?

LOGIN
s/

[C] Remember me
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Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on the Contributor icon
on the top-left corner of the screen

Contributor Icon

fwadmin  FOWEM_v0.4

The contributor interface screen is displayed. This is the main workspace for any content contributor

Content

4 Bookmarks (0) + (L] Assignments (0) 4+ 9

m

E| SmartLists (0) 9 ¥ Checkouts (0) 9

Click on Content -> New -> New Offer. This will display a sequence of screens that will be required to create a New
Offer
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Content Marketing Metadata
Offer:
*Name:
*0ffer Sub Category: 4
*0ffer Name:
*0ffer Image:

*0ffer Headline:

*0ffer Short Description:

*0ffer Link Text:

Any sample offer can be viewed to see the kind of details that go into the creation of the offer. Click on Search ->
Find offer -> Visa Platinum Credit Card Movie Buff Offer
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Offer: Visa Platinum Credit Card Movie Buff Offer - All

*Name: Visa Platinum Credit Card Movie Buff Offer - Al
*0Offer Sub Category: Credit Cards +1
*Offer Name: Visa Platinum Credit Card Movie Buff Offer
*0ffer Image:

Visa Platinum Mavie Buff Credit Card (Offer) - Banner

*0Offer Headline: Visa Platinum Credit Card Movie Buff Offer
*Offer Short Description: Visa Platinum Credit Card Movie Buff Offer
*Offer Link Text: Know More

Offer Information Text:
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6. Services Catalog Creation

Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials "fwadmin/xceladmin"

ORACLE" WebCenter Sites Version: 11gR1

Secure User Login

Username fwradrnin

ORACLE

Password SessNIRNS

Forgot password?

LOGIN
)

[C] Remember me

Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on the Contributor icon
on the top-left corner of the screen

.| Contributor Icon
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fwadmin FCWEM_v0.4

The contributor interface screen is displayed. This is the main workspace for any content contributor

Content Edit View ¥
A o
*
ﬂ Bookmarks (D) 9 || Assignments (0) 9
/2| smartLists (0) 9 ¥ Checkouts (0) 9

Click on Content -> New -> New Service Catalog. This will display a sequence of screens that will be required to
create a New Service Catalog
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New Service Cat... x

Content Marketing Metadata

Service Catalog Definition:

*Name:

*Service Sub Category: I

Service Name:

Service Headline:

Service Short Description:

Any sample offer can be viewed to see the kind of details that go into the creation of the offer. Click on Search ->
Find Service Catalog -> Wealth Services
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Bl » nvi

Content Marketing Metadata

Service Catalog Definition: Wealth Services

*Name: Wealth Services

*Service Sub Category: Wealth Management 4
Service Name: Wealth Services
Service Headline: Wealth Services

Service Short Description:
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7. FCDB Widgets

Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials "fwadmin/xceladmin”

ORACLE WebCenter Sites Version: 11gR1

Secure User Login

Username fevadmin

ORACLE’

Password sssssINee

Forgot password?

LOGIN

[T Remember me
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Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on the Contributor icon
on the top-left corner of the screen

Contributor Icon

fwadmin  FOWEM_v0.4

The contributor interface screen is displayed. This is the main workspace for any content contributor

Content

4 Bookmarks (0) + (L] Assignments (0) 4+ 9

m

E| SmartLists (0) 9 ¥ Checkouts (0) 9

Click on Content -> New -> New FCDB Widget. This will display a sequence of screens that will be required to create
a New FCDB Widget

2 User Manual Oracle FLEXCUBE Direct Banking Sites



Content Marketing Metadata
FCDB Widget:
*Name:
Template: — choose disply style —
*Widget Parent Definition: ~ IS

*FCDB Widgat Nama:

*FCDB Widget Description:

Field Device ID:

Field Lang ID:

Field Request ID:

Cinld CarFinm THe

Any sample FCDB Widget can be viewed to see the kind of details that go into the creation of the offer. Click on
Search -> Find FCDB Widget -> FCDB Notifications Widget
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FCDB Widget: FCDB-NotificationsWidget

*Name: FCDB-NotificationsWidget
Template: FCWEMTEMPLATES-FCDBNotifications Template
*Widget Parent Definition: FCDB-RPCParentWidget M
*FCDB Widget Name: Motifications
*FCDB Widget Description: Notifications
Field Device ID:
Field Lang ID:

Field Request 1D:
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3.5 Promotions/Recommendations

Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials "fwadmin/xceladmin”

ORACLE WebCenter Sites Version: 11gR1

Secure User Login

Username fevadmin

ORACLE’

Password sssssINee

Forgot password?

LOGIN

[T Remember me

Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on the Contributor icon
on the top-left corner of the screen

Contributor Icon

fwadmin  FCWEM_v0.4 [J

The contributor interface screen is displayed. This is the main workspace for any content contributor
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Content Edit View v

A o]
1%

ﬁ Bookmarks (0) 9 I;‘ Assignments (0) ¥ 9

= smarttists (0) + 9 & checkouts (0) 9

Click on Content -> New -> New Recommendation. This will display a sequence of screens that will be required to
create a New Recommendation

Hew Recommen... = %

Recommendation

Name + Type } Options + Build + Selection F Sort

*Name: TestReco
Description:
Subtype: (no subtype)
Start Date:
End Date:
Mode: © List

©® Recommendation

6 User Manual Oracle FLEXCUBE Direct Banking Sites



o pr———

Recommendation: TestReco

* Name Type » Options * Build * Selection » Sort

Recommendation Type: ) Related Items (defined on asset forms)
@ Static Lists (optionally by segment)

Dynamic Lists (generated by an element)

Recommendation: TestReco
* Name * Type Options ¥ Build ¥ Selection FSort

Options: ) Bring back chidren of returned assets.

@ Do not bring back children of returned assets.

Promotions can override this recommendation.

@ Promotions cannot override this recommendation.

@ This recommendation applies to all asset types.
This recommendation applies to the following asset types:

Attribute Editor 2 -
Blog Asset (M
Blog Asset Definition

Blog Attribute “
Blog Authar

Blog Author Category

Blog Author Category Definition
Blog Author Definition

Blog Category

Blog Category Definition - -

Remowve
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Static Lists:  New Static List: = <Select Segment=

=
Il Segment: PERSONAL

Item Name In Segment Confidence OQut of Segment Confidence

Mo ittems specified

Hint: Drag ttems from the tree or docked search in to the drop zone.:

Static Lists:  If No Segments Apply:

Ttem Name Confidence

Mo itemns specified

Hint: Drag items from the tree or docked search in to the drop zone.:

The drop-zones are content placeholders. Any kind of content created in the previous steps can be dragged and
dropped to this zone
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Any sample Recommendation can be viewed to see the kind of details that go into the creation of the offer. Click on
Search -> Find Recommendation -> FCWEM-GenY-Recommendation

Bl nva

Recommendation: FCWEM-GenY-Recommendation

*Name: FCWEM-GenY-Recommend:
Description: Gen ¥ Recommendation
Subtype: (no subtype)
Start Date:
K
End Date:
I _
Mode: @ List

@ Recommendation

Options: Does not bring back children of returned assets.

Promnotions cannot override this recommendation.

This recommendation applies to all asset types.

e statcLis
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3.6 Images

Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials "fwadmin/xceladmin”

ORACLE" WebCenter Sites Version: 11gR1

Secure User Login

Username fwradrnin

ORACLE

Password [TITTYYIT]

Forgot password?

LOGIN
=

[C] Remember me

Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on the Contributor icon
on the top-left corner of the screen

Contributor Icon

fwadmin  FCWEM_v0.4 @ m

The contributor interface screen is displayed. This is the main workspace for any content contributor
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Content Edit View v

A o]
1%

ﬂ Bookmarks (0) 9 I;‘ Assignments (0) ¥ 9

= smarttists (0) + 9 & checkouts (0) 9

Click on Content -> New -> New Image. This will display a sequence of screens that will be required to create a New
Image

“ New Image x
Content Marketing Metadata

Any image for the solution:

*Name:
Template: - choose display style -
*Image Sub Category: v IR 2

*Image Description:

Image: Browse

Image Alt Text:

Caption for the image:

Image Height:
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Any sample Image can be viewed to see the kind of details that go into the creation of the Image. Click on Search ->
Find Image -> Mobile Services Offer - Thumbnail Image

Bl » nvai

Content Metadata

Any image for the solution: Mobile Services Offer - Thumbnail Image

*Name:  Mobile Services Offer - Thumbnail Image

Template:

*Image Description:

Image:

Image Alt Text:  Mobie Services Offer

Caption for the image:  Mobie Services Offer
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3.7 General Content

Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials "fwadmin/xceladmin”

ORACLE WebCenter Sites Version: 11gR1

Secure User Login

Username fevadmin

ORACLE’

Password sssssINee

Forgot password?

LOGIN

[T Remember me

Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on the Contributor icon
on the top-left corner of the screen

Contributor Icon

fwadmin  FCWEM_v0.4 @ m

The contributor interface screen is displayed. This is the main workspace for any content contributor
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Content Edit View

T
PS o
L%s
Bookmarks (D) 9 | Assignments (D) 9
(W]
JiZ| smartLists (0) L " ] ¥ Checkouts (0) 9
v ==

Click on Content -> New -> New Content. This will display a sequence of screens that will be required to create a

New Content

14
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-

Content Marketing Metadata
Announcement:
*Name:
Template: — choose display style —
*Content Sub Category: ~ IS
*Content Title:
Headline:

Content URL Link:

Content Short Description:

Any sample Content can be viewed to see the kind of details that go into the creation of the Image. Click on Search -
> Find Content -> Product Announcement - Cash Retraction

B - MV i

Content Metadata

Announcement: Product Announcement - Cash Retraction

*Mame:  Product Announcement - Cash Retraction
Template:
Content Sub Category: Announcements
*Content Title:  Cash Retraction Facility
Headline:
Content URL Link: #

Content Short Description: Cash Retraction Facility has been disabled on all Global Bank ATMs

Content Description:

Content Thumbnail:
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8. Creation of Pages

Once the content has been created, pages have to be setup.

Page Creation

Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials "fwadmin/xceladmin®

ORACLE" WebCenter Sites Version: 11gR1

Secure User Login

Username fwradrnin

ORACLE

Password LTIy

Forgot password?

LOGIN
—

[C] Remember me
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Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on the Contributor icon
on the top-left corner of the screen

Contributor Icon

fwadmin FCWEM_v0.4

The contributor interface screen is displayed. This is the main workspace for any content contributor

Content Edit View v
A o)
13
ﬁ Bookmarks (0) RPN " ] || Assignments (0) i+ 9
= smarttists (0) 9 & checkouts (0) + 9
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Click on Content -> New -> New Page

-~

Page

Hame:

*Page Definition: — choose a definition —
-- choose a definition -

FCWEMPageDef(2)-BusSegLP

FCWEMFPageDef(3)-BusSeglLP

FCWEMPageDef-BusSegLP

g FCWEMPageDef-CustSeqglLP

FCWEMFageDef-Home

E FCWEMFageDef-ProdCatLP
FCWEMPageDef-ProdLP
FCWEMPageDef-ProdSubCatLP
FW_ArchiveBlogs
FW_AuthorBlogs
FW_RecentBlogs
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FLEXCUBE Sites offers OOTB a set of Page Definitions which can be utilized by the bank to create new pages.
Alternatively, it is very easy for a bank to create their own Page Definitiona

In our case, we will choose to create a Business Segment Landing Page. Choose FCWEMPageDef-BusSegLP

Hew Page * x
Content Metadata

Business Segment Landing Page Definition:

*Name:

Template: FCWEMTEMPLATES-BusSeglayout-1

. *Ppage Title:

& *Casual Visitor Page Attribute:

Navigation Links:

FCDB Widget:
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Enter the set of attributes as mentioned and click on the "Save" icon. You can also choose the "Web" mode to have a
visual representation of the page as you continue editing it

Any sample Page can be viewed to see the kind of details that go into the creation of the Image. Click on Search ->
Find Page -> Personal Banking

Bl »» mv i

Content Metadata

Business Segment Landing Page Definition: Personal Banking

*Name: Personal Banking
Template: FCWEMTEMPLATES-BusSeglayout-1
*Page Title: Personal
*Casual Visitor Page Attribute: PERSONAL

Navigation Links:

Contact Us - Mavigation Link

Security Center - Navigation Link
Ways to Bank - Navigation Link

Logout - Navigation Link
FCDB Widget: FCDB-LoginWidget

Showcase Recommendations: FCWEM-PersonalShowCase-Recommendation
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At any time, to preview your changes, click on View -> Preview in New Window. A new browser window will open up
which shows the changes of your page

e
1351275817142 e

gg,% Contact Us Security Center Ways to Bank Logout
GLOBAL Bank
Corporate Weaith About Us

Get upto 5% cash-back with our new °
Visa Gold Credit Card

Login

Internet Banking

Interational Debit Card 2 Wheeler Loan

Enjoy upto Rs 2500 Bonus Reward Earn cashback and rewards on all Your wait for a Bike ends here. Your

pointson your first spent with Futura purchases along with entertainment. ridemade easy for just Rs 50 per day

Credit Card. Apply online in just 2 steps. Business Banking
Security Online

Apply Apply Apply New User? Get UseriD

Forgot Password?

L o cnle \Gtemn D sllatin Do ord Opinion Poll v
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9. New ATM or Branch locater configuration steps

Locater Asset

Locater asset family provides the functionality to the user to locate ATM or Branch on map. To mark a new
location on you need to first create a Locater Parent which specifies the country in which ATM is located. All ATM and
Branch are located in same country have the same Locater Parent.

Creating New Locater Parent Assets

Login in FlexCube Sites in contributor mode.

Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials "fwadmin/xceladmin”
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ORACLE WebCenter Sites Version: 11gR1

Secure User Login

Username fevadmin

ORACLE’

Password sssssINee

Forgot password?

LOGIN

[T Remember me

Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on the Contributor icon
on the top-left corner of the screen

Contributor Icon

fwadmin  FCWEM_v0.4 @ E

The contributor interface screen is displayed. This is the main workspace for any content contributor
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Content View

4 Bookmarks (0) + (L] Assignments (0) ¢+ 9

m

SmartLists (0) + 9 & Checkouts (0) + 9

Go to Content -> New ->New FCWEM_Locater Parent

i}uil g Lﬁl fwadmn rveos 9

= onte d o
Hew 3 . . -
Mew Blog Asset MNews cos_install Newr cos_user_id New Offer -
_—
“WEM v0.4 Site New Blog Author News cos_listed_ent New cos_user_link New Offer Parent "
[L) Flaced Pages New Blog Author C... New cos_poll MNew FCDB Widget New Page
= H Hon Authenticated Users) (N Approve 3
B[] Home (Hon Authenticated Usess) (e PP New Blog Category New cos_rating_feed New FCDB Widget ... New Product
(=) [I=] Persenal Banking
. 7] savings Accounts. New Collection New cos_rating_rec... Newr FCWEM Locater Mew Product Parent
= Access Permissions E
€3] D Current Accounts Mew Content News cos_review_fa MNew FCWEM Locat. New Promotion
(® [iF] Loans Bookmark New Locater Parent
i MNew Content Parent New cos_review_re New Fee-Rate o
@ [=] cards
@ [] corporate New cos_blob New cos_site New Fees-Rates Par... Mew Recommendat..
Locat
[ Locater Mew cos_category MNews cos_st_locator Newr History Attribute MNew Segment
- [iE] Weatth
. [I] Regular Savings Account New cos_category_ New cos_st_value New History Definiti Mew Service Catalog |
& [i=] Home (Segmented Authenticated Use New cos_comment... MNews cos_topic Newr Image New Service Catalo...
[=] Accounts
l# [i=] salary Accounts rEgEE PETSOTE
*.. [1=] Wax Savings Account
| Unplaced Pages - *Casual Visitor Page Attribute: PERSONAL

[ AboutUSTestPace P
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Following screen will appear

ORACLE WebCenter Sites Content

FCWEM_v0.4 Site m

(= [ Placed Pages

fwadmin  FCWEM_v0.4 n

Search g

= Ifl Home (Mon Authenticated Users) (Ne G Marketing Metadata
@ [i=] Personal Banking
i [i7] savings Accounts

=] Current Accounts Locater_Country:

[=] Loans.
[ cards
[i=] corporate “Hame:
i =] Locater
... =] Weatth Template: — choose display style -

[=] Regular Savings Account

[=] Home (Seomented Authenticated Use
[=] Accounts
[=] salary Accounts

Country:

- [7] Max Savings Account Country Location:

|[ Search ]

(= (B8 Unplaced Pages
i [iF] AboutUSTestPage 4
L [i| Copy OF Savings Accounts_S5015... -

Fill the form according the table

Name

Name of the asset

Country

Country name in which ATM / Branch is located

Country Location

This column contains longitude and latitude of
geographical location of country. To get this column
value (longitude and attitude) name of location. You can
also put longitude and attitude direct in given text box.

Atfter filling country name and in text box click search button. Following screen appears
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FCWEM_v0.4 Site
(= ([l Placed Pages. —
) [=] Home (Non Authenticated Users) (Ne

Savings Accounts
N Locater_Country:

*Name: ‘Mumha»GoregaonATM b4 |
Template: |— choose display style -
Regular Savings Account
H Se ted Authenticated U:
T Country:  nda x|
Accounts
Salary Accounts
Max Savings Account Country Location: |22,87944,84,587831 |m
= [ Unplaced Pages : N
i AboutUSTestPage

i Copy Of Savings Accounts_S5015.

| > - et

[ ———————— Map data ©2012 MapLink - TErTs of Use
-
Content Tree

PRSI

To adjust the longitude and latitude on map click on red mark on the map and drag to desired location.

Jountry Location: [20.593684.75.96285] [ Search |

After proving the value of all required field to Save the asset and close the tab go In the menu bar, select Content >
Save & Close.
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Creating New Locater Assets

Go to Content -> New ->New FCWEM_Locater

Following window will appear

3
I New Article
MNew Article Category
Mew Blog Asset
Approve »

Mew Blog Author

MNew Blog Author C...

. | Access Permissions
1 MNew Blog Category

Mew FCDB Widget

MNew FCDB Widget ..

MNew FCWEM Locater

New Offer

New Offer Parent

I MNew Page

New FCWFM Lo Moy Product
Mew FCWEM Locater
Mew History Attrbute Flew Product Parent

MNew History Definiti...

Mew Product Parent0

New Segment
MNew Service Catalog
Mew Service Catalo...

MNew Site Visitor

MNew Site Visitor Att...

Mew Site Visitor Def...

Bookmark
MNew Collection MNew Image MNew Productd MNew Site Visitor Par..
Mew Content Mew Image Category Mew Promotion MNew Visitor Attrbute
Mew Content Parent Mew Image Parent Mew Query
MNew Content Query MNew Imagel New Recommendati..
Template: FCWEMTEMPLATES-BusSeglayout-1
*Casual Visitor Page Attribute: PERSONAL

*Page Title: Personal

Navigation Links:

Security Center - Navigation Link

Help - Navigation Link

Ways to Bank - Navigation Link
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After click on FCWEM_Locater following content form will appear.

Bl B

Content Marketing Metadata URL

Locater:

*Name:

Tags:

Template: - choose display style —

*Locater_Country: ~ RS

*Locater Type: ATM

*State:

*City:

*Location:

*Locater Description:

pulas i ol
Mongolia
e '

&
South Korea
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To fill the contributor form please refer the below table

Name

Name of the asset

Locater_Country

Select the country name from parent asset.

Locater Type Select Locater type from drop down acceptable values is
ATM and Branch.

State Enter state where ATM/Branch is located.

Location This text box contains the longitude and attitude of

geographical location where ATM/Branch is located. To
fill this column value you can enter longitude and latitude
value directly or enter the location name and click on
search batten.

Locater Descriptor

This column contains description of ATM/Branch.

To find longitude and latitude of location of ATM/Branch enter the name of location and click on search button.
Following screen will appear. You can adjust longitude and latitude location by dragging click on red marker on

desired location.

City:

Location: [18. 156952.73.295701

Locater Description:

(ﬂ‘)'@gle

|

N

Chiplun
Map Gate £2012 Google - Terms of, Use
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To add the Locater Description click in text box. Following screen will appear. You can format your content using
CKEditor. This description wills we displayed for this ATM/Branch when user hover mouse over this location on map.

€

Content

Locats

Marketing

City:

Location:

Descriptiony

Metadata

18.156952,73.295701

E] Source [E G G A A
“ B mHe @& (|
B I U= X x* i 7=

Global Bank
ATM Branch Locater

body div

ik,

Configuring default location when page load

9
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To configure default location of map when locater page load follow these steps.

Login to contributor interface and open LocateUs page in edit mode.

(@ Oracle WebCenter Sites 11gR1 - Mozilla Firefox - =
File Edit View History Bookmarks Tools Help

| Oracle WebCenter Sites 11gR1 x | @ Oracle FLEXCUBE Sites - v1.0 x Oracle WebCenter Sites 11gR1 x | + ‘

e & 10.184.132.138:6080/ cs/wem/fatwire/home S o

Ple & =

admin. rovecos 13 (R

ORACLE" WebCenter Sites Content Edit View

a Personal Banking X New FCWEM Locater J
L B » Bnmv “
[ Defaut

= [ placed pages
i [i] Accounts
«+) [] Salary Accounts

Content Metadata URL

)]
@ 7] Home (Segmented Autnenticated Use | T CWEM-Locaterp:
) 1] Home (Non Authenticated Users) (Ne
(= [ Unplaced Pages
[i7] careers *Name: Lomatels
[=] Fw_archiveBlogs
[=] FW_AuthorBlogs
[7] LocateUs Tags:
[i=] Privacy
[=] sharenolders
7] Stemap Template: FCWEMTEMPLATES-ATMBranchLocater

m

*Page Title: Locate Us

Navigation Links:

Help - Navigation Link

Security Center - Navigation Link

‘Ways to Bank - Navigation Link

Locate Us

*MSG for ATM search Error: No ATM found for specified search criteria

Content Tree

*Branch Error Msg: Mo Branch found for specified search criteria
My Work

Marketing Tree *Zoom level of Ma

Gl sl
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To fill the contributor form of LocateUs page please refer the below table

Column Name

Column Value

Name Name of the asset(No need to change if you are
changing default map load values)
Page Title Title of page. Title field also defines the name of link on

personal page.

MSG for ATM search Error

Message to user when user search criteria did not match
to any available ATM

MSG for Branch search Error:

Message to user when user search criteria did not match
to any available Branch

Map Default Focus Location

This text box contains the longitude and attitude of
geographical location where ATM/Branch is located. To
fill this column value you can enter longitude and latitude
value directly or enter the location name and click on
search batten.

Zoom level of Map

Specifies the zoom level of map.

11
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10. Viewing Content on Mobile Devices

Overview
FlexCube Site provides set of devices which allows user to see preview content on different devices like iPhones,

iPads, Android Phone, Android Tablets, and Desktop etc. To view the content in a particular device follow following
steps.

Viewing Content on Mobile Devices

Login in FlexCube Sites in contributor mode.

Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials "fwadmin/xceladmin”
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ORACLE WebCenter Sites Version: 11gR1

Secure User Login

Username fevadmin

ORACLE’

Password sssssINee

Forgot password?

LOGIN

[T Remember me

Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on the Contributor icon
on the top-left corner of the screen

Contributor Icon

N ey J

Open a page to be viewed.
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wadminrovenes 8

ORACLE" WebCenter Sites Content

a

Personal Banking

FCWEM_v0.4 Site ﬂ—" V. M B0o v jj 7

(i Defautt
(= {4 placed pages

7 Content Metadata URL
[i=] Accounts

(# [i7] salary Accounts

i~| Home (Segmented Authenticated Use
~| Gen-Y Page (New)

| Middle Aged Page (New)

Business Segment Landing Page Definition: Personal Banking

*Name: Personal Banking

|#~] savings Accounts

[7~] current Accounts Tags:

’ Template: FCWEMTEMPLATES-BusSeglayout-1

@ (E Unplaced Pages ‘[ *Casual Visitor Page Attribute: PERSONAL
4
| *Page Title: Personal
Navigation Links: Help - Navigation Link

Security Center - Navigatl

Ways to Bank - Navig:
< [ ] »
—~ Locate Us
Content Tree FCDB Widget: FCDB-LoginWidget
My Work

L. SETSE
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Select multi-device preview as shown below:

b & Ld i oeos 3

ORACLE" WebCenter Sites Content

Personal Banking

FCWEM_v0.4 Site ﬂ 2 i m v 0 é

(i Defautt

= |&l placed pages Content Metadata URL ‘ Multi-Device Preview ‘
Arcnunts —_—

On top-right corner select the desired device:

Content

Personal Banking

Multi-Device Preview . :
Nokia Symbian Phones

iPhones

iPads

Android Tablets

Android Phones

Windows Phones

£ Windows Tablets

s BlackBerry10 Phones
i won

Nokia Symbian Phones
Desktop
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So according the size of the device, the content will be displayed either in mobile or desktop view, as show below:

REEERCS IR Android Tablets -

£

T
T e
© wusieosn
7 comae
e pta 20 oft with our Visa Platmum

Buft Credit Cand

Kindle Fire HD Nexus 10

Working Summary:

The display of the content in either view (mobile, desktop) depends on the width of the device rendering it. If the width
of the device is less than 767px the mobile view is rendered while device width with greater than 767px gives desktop
view.

This is done by using responsive css which gets the window’s resize function and renders following divs :

<div class="container hidden-phone">
All content under this div will be rendered for desktop view

</div>

<div class="container visible-phone'">
All content under this dev will be rendered for mobile view

</div>
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11. Pretty URL

Login as the administrator for FLEXCUBE Direct Banking Sites using the credentials "fwadmin/xceladmin”

ORACLE WebCenter Sites Version: 11gR1

Secure User Login

Username fwadmin

ORACLE’

Password sssssINee

Forgot password?

LOGIN

[C] remember me
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Once logged in, choose the site FCWEM_v0.4 on the top-right corner of the screen and click on the Contributor icon
on the top-left corner of the screen

Contributor Icon

fwadmin FCWEM_v0.4

The contributor interface screen is displayed. This is the main workspace for any content contributor

Content Edit View ¥
A o
*
ﬂ Bookmarks (D) 9 || Assignments (0) 9
/2| smartLists (0) 9 ¥ Checkouts (0) 9
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Select the asset for which you want to change the url. Here we are going to modify url of personal page

Open Personal page in edit mode. Following screen will appear

Bl » B MoV G

2%

Content Metadata URL
Jse

Business Segment Landing Page Definition: Personal Banking

Ne

URL:

o

Host: http://10.184.132.138:6080/ cs/fowem

o

Device Group: Desktop

o

Template: | FCWEMTEMPLATES-BusSeglayout-1

o

Wrapper: FW_BlogWrapper

Action Auto Generated Status Info
Change Status | Delete MNo @ URL: /Personal.hitml

200 View More

I Change Status | Delete Mo @ URL: /Blogs

200 View More

Enter the URL value which you want to for this page. In this example we want to make personal page as Home in url.

So make URL attribute value Home.
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Select relative(*/”) host value from dropdown.
Select Device Group from drop down for which you wants to create pretty url.
Select template and Wrapper used for rendering page from drop down and click on add button.

New url for this page get added in the url list. Save asset.

WL eorisonins .

Bl » B Hiov G

Content Metadata URL
se

URL:

Ne

Host: /

o

Device Group: Desktop

<

Template: FCWEMTEMPLATES-BusSeglayout-1

<

Wrapper: FW_BlogWrapper

| “

<

Action Auto Generated Status Info
Change Status | Delete No @ URL: /Personal.html

200 View More

Change Status | Delete No @ URL: /Blogs
200 View More

Change Status | Delete No @ URL: /Home

I 200 View More

Preview the page in new window. Now url is contain page name as Home.
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File Edit View History Bookmarks Tools Help

—
T Qe Siboeddes Ol !M.zxcussssm-vm x +[ a o

(%) 10.180.57.187:8070/ cs/fcwem/Home -)\ B - Google P A ¥
g¥ Help Security Center Ways to Bank Locate Us

GLOBAL Bank
o

Get upto 5% cash-back with our new °
Visa Gold Credit Card

Login

Internet Banking
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