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Preface

This manual describes the main functionality delivered by the CATIA Teamcenter
Interface (CMI RII) and includes the creation, storage, modification, and management of
CATIA models and assembly structures in the Teamcenter PDM system.

About this Manual

This manual is intended for end users of the CATIA Teamcenter Interface. It assumes that
the reader is familiar with the CATIA application and with Teamcenter Rich Client.

—
Related Documents

The following manuals contain information about installation, usage and customization of
the CATIA Teamcenter Interface:

Manual Title Version

CATIA Teamcenter Interface RIl Installation Manual 2.0

CATIA Teamcenter Interface RIl User Manual 2.0
|

Organization
This manual contains the following chapters:

Chapter 1 provides basic information about the CATIA Teamcenter Interface and
describes some features of this application interface.

Chapter 2 describes how to start CATIA within the Teamcenter environment and also how
to enable the CMI functionality within CATIA V5.

Chapter 3 introduces the CMI RII Application with a general explanation and then by
listing its functions. The goal of this chapter is to make the user familiar with this
component. The CMI RIl Application functions will be explained in subsequent chapters.

Chapter 4 describes how to handle CATIA relevant data in Teamcenter.
Chapter 5 explains how to work with CATIA V5.

Glossary contains the CATIA Teamcenter Interface terminology.
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—
Conventions Used in this Manual

This font

tem 1-2>ltem 2

Is used for document titles and emphasis.

Is used to identify a menu path to reach a specific function.

This icon is used to identify Teamcenter related sections and actions.

This icon is used to identify CATIA V5 related sections and actions.

Your Comments are Welcome

Please feel free to tell us your opinion; we are always interested in improving our
publications. Mail your comments to:

T-Systems Enterprise Services GmbH
Solution Center PLM

Fasanenweg 5

70771 Leinfelden-Echterdingen
Germany

E-mail: cmi_support@t-systems.com
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CHAPTER 1

Overview

This chapter provides basic information about the CATIA Teamcenter Interface and lists
some features of this application interface.

—
Introducing CMI (CATIA Teamcenter Interface)

The CATIA Teamcenter Interface (CMI RIl) was developed by T-Systems as a high-end
integration between the CAD system CATIA V5 and the PDM system Teamcenter. With
this interface it is possible to manage CATIA V4 and CATIA V5 models and assemblies in
Teamcenter and CATIA V5.

CATIA V5 uses assemblies similar to Teamcenter. CMI makes a bidirectional mapping
between the Teamcenter structure and the CATIA V5 structure. So users have the full
functionality of Teamcenter and CATIA V5.

|

CMI Rl joins the advantages of CAD with PDM
The CATIA Teamcenter Interface combines the CAD Excellency of CATIA with the power
of the PDM system Teamcenter. It provides the user with a more sophisticated way of

working with CATIA by allowing the management of product structures and multiple level
assembly structures within the PDM system.

The CATIA Teamcenter Interface (CMI RII) permits:
= Integration of CATIA data in workflow (e.g. release control);

= Management of CATIA data in vaults, without knowledge about the underlying file
system;

= Updating concurrent engineering processes by different users;
= Distribution of CATIA data in a network;

= Simultaneous management of CATIA data and structures;

=  Construction of part structures within Teamcenter;

= Modification of the position of the structures;

= Search for CATIA data by different attributes.
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CMI Architecture

The following figure explains the architectural basics of the CATIA Teamcenter Interface
(CMI RII).

CMI RII Application in Teamcenter CATIA V5 with CMI RII
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Figure 1: CATIA Teamcenter Interface architecture

The user can expand an assembly within the CMI RII Application and send this assembly
to CATIA V5. After changing geometries and/or positions in CATIA the user can update
the assembly in Teamcenter.
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CHAPTER 2

Getting Started

This chapter describes how to start CATIA within the Teamcenter environment and also
how to enable the CMI functionality within CATIA V5.

Assumptions

Some assumptions, for a better understanding of the descriptions and examples:
n CATIA V5 should display the CMI toolbar:

L5 B EAERALBT 5

UNIX:
Start CATIA V5 with the command cmicatstart.sh

Windows:

Make sure you have set up the right environment (refer to Installation and
Administration Guide). Launch CATIA V5 with the command:

CNEXT.exe -env CatiaCMIEnv -direnv "C:\<path to the CMIEnv>"

|

Starting Applications
Before working with CMI Rl it is necessary to start the Teamcenter Rich Client, the
Teamcenter user interface, and the CATIA V5.

For information on starting Teamcenter Rich Client see the Teamcenter Help Library —
Getting Started with Teamcenter provided by Siemens PLM.

For information on starting the CATIA User Interface see the CATIA Solutions User’s
Guide.

Enabling the CMl toolbar in CATIA V5

m In CATIA V5, select the menu View>Toolbars>CMI.

A - If the CMI toolbar is not in the list of toolbars, a problem with the installation may _
- have occurred. In this case, contact the administrator. Information about this kind of :
: problem can be found in the Installation Manual. i
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CHAPTER 3

The CMI RIl Application

This chapter introduces the CMI RII Application with a general explanation and then by
listing its functions. The goal of this chapter is to make the user familiar with this
component. The CMI RIl Application functions will be explained in subsequent chapters.

What is the CMI Rll Application?

The CMI RII Application is a Teamcenter application used to interactively prepare an
assembly structure for sending to CATIA and to provide several manipulation facilities for
the CMI commands found in CATIA. The entire data interchange between Teamcenter
and CATIA is achieved via the CMI RIl Application.

CMI RII defines some new dataset types in Teamcenter that can be used to manage
CATIA V5 files (CATPart, model, cgr, CATProduct, and CATDrawing). The management
of CATIA V5 files is described in Chapter 5.

A, T
Q The CMI RII application has to be started in Teamcenter before you can call the

g) - functions of CMI RII.

o

To start the CMI RIl application use the standard Teamcenter start mechanism as shown
in Figure 2.

JRI=TE
Fle Edt Window Help
IEa [ & i | % TEAMCENTER

e

search 2 Getting Started 53 =0

Erter tem IDtose. [ -

- Quick Links - o0

B Home » @ Teamcenter 8

My Wiarklist >

&My Saved Searches 5 Welcome to Tearncenter 8 - Opering your world to shared data and enabling communication across your
@ty Links » orgarization,

q LI To begin, you can:

» Open Items

» History - Search for data to begin your work

o o e — - Start an application in the navigation bar on the left
- Select a link from below

~ IWantTo.. om0

We hope you enjoy your experience with Teamcenter, We look forward to serving your data
management needs.

Find a part and begin my wark: [Enter Item ID ta search 8-

Open My Teamcenter or Worklist

f‘i Getting Started L
_(CM!RII ] View Edit a product structure

y Teamcenter (T.-\ Wigwr / Edit my company's classification data

Structure Manager
& % 7 g »

LoadingGetting Started... |0

Figure 2: Teamcenter Rich Client start window
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A window with the CMI RII application will appear after logging in in the PDM system

Teamcenter (see Figure 3).

EPCMIRI - Teamcenter &

File Edt Tools Window Help

@7 CMIRIT ¢ o 07) - Engineering/Designer  [IMC-516457144] )

Search A cmen 3

(Rl =Rl Rl TEAMCENTER

=18ix]

[engine - Hame | Item 1d | Revision | Occurrence Name |

= Quicklinks (o

LBHome »
iy worklist »
|2 My Saved Searches %
ety Links »

» Open Items
b History
» Favorites Organize

» IWant To.. Customize

|:2 Getting Started
& cmian
My Teamcenter
Structure Manager
& ¥ Flg i » ‘ ez
e I X% g AWM =] 0

Figure 3: CMI Rl application window

I
The CMI Rl application Menu

Below the CMI RII application menu items will be described.

File Edit Tools Window Help
IEESIRE | R

Figure 4: CMI RIl application menu items

Menu item File
|Fi|e Edit Tools ‘Window Help

Close

&y Exi

Figure 5: CMI Rl application menu ‘File’

The menu item File 2>Close will close the CMI RII application.

The menu item File 2EXxit will exit the Rich Client application.

Menu item Edit

File | Edit Tools Window Help

E‘ User Setting...

£ Options. ..

Figure 6: CMI RIl application menu ‘Edit’

The menu item Edit>User Setting ... will open the User Setting dialog of the Rich Client

application.
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The menu item Edit2>Options ... will open the Preferences dialog of the Rich Client
application.

The CMI RII preferences show the CMI RIl options (see Figure 7).

= Send Drawings To CATIA
Checked if drawings (CATDrawing) should be sent to CATIA.

= Transfer CGR files To CATIA
- No No CGR are sent to CATIA
- Only.CGR Only CGR are sent to CATIA
- CGR + geometry CGR and geometry files are sent to CATIA

= Work with CATIA Version
-V5 work with CATIA V5
-V4 work with CATIA V4
=
= Send Drawings To CATIA =
[~ send drawings to CATIA?

Transfer CGR files To CATIA

T Tem Revision

[ CheckinjCheckOut
T 1dentifier

] Calendar

L[] Stark OF week
... Default Base Calendar
] Mulki-Site Collaboration
i w[Jops

L LeTIpsm

Mo
= Only CGR
£ CGR + geometry

“Work. with CATIA Version
[l
va

QK |

Apply I Cancel |

Figure 7: The CMI Rl application options dialog

Menu item Tools

Fie Edit | Tacls tindow Help
&1 Send Tao Catia
E Temp To Catia
= Insert To Cakia
£K] Cancel Catia Ackion
[ Clear Workbench

Figure 8: CMI Rl application menu ‘Tools’

The menu item Tools =2 Send To Catia starts the Read To Catia Action and will read the
CMI RII application content to the CATIA.

The menu item Tools=> Temp To Catia starts the Add Temp To CATIA Action and will
read the temporary added items to the CATIA. This menu item is only usable if the Add
Temp action is started from the CATIA.

The menu item Tools 2Insert To Catia starts the Insert To CATIA Action and will read the
queried items to the CATIA. This menu item is only usable if the Insert from Teamcenter
action is started from the CATIA.

The menu item Tools >Cancel Catia Action cancels actions which are started from CATIA.
(e.g. SaveAs and AddTemp). This menu item is only usable if an action is started from the
CATIA (e.g. SaveAs and AddTemp).

The menu item Tools=>Clear Workbench Action removes all Items from the CMI RII
Application window.
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Menu item Window

Fil= Edit TDDISlWindDw Help

J B # T B CpenPerspective *
Show Wigw k

Save Perspective As, ..
Reset Perspective
Close Perspeckive

Preferences. .,

v Mavigation Pane

v Toolbar

Figure 9: CMI RIl application menu ‘Window’

The menu item Window includes the standard menu items provided by the Teamcenter
Rich Client application.

Menu item Help

File Edit Tools ‘Window | Help

| E & & K | @ curent Application F1
@_} Help Library Chrl+F1
About

Software Lpdates L

Figure 10: CMI Rl application menu ‘Help’

The menu item Help points to the standard application Help provided by the Teamcenter
Rich Client Application.

The menu item Help 2About opens the About dialog.
The About dialog informs about the actual CMI Rl application (see Figure 11).

I

; CMIRII - The Teamcenter CATIA Integration (Yersion 2.0.0)

CMI RII manages CAD product struckures and connects CATIA WS with Teamcenter.

Mare info nore

JRE Version: 1.5.0_11
WM Awailable Memary: 532.81Mb

WM Free Memary: 408.11Mb ¥

Host Mame: wp-scplmtestdll
Log File: CADOCUME~ 12007 \LOCALS 1\ Templtoserver exel 6484b30, syslog
Journal File: CHDOCUME~ 1 bc2007LOCALS~1 1 Templtoserver . exe 16484080, 0l

SI EMENS Copyright @ 2008, 2009 by T-Systems Enterprise Services GmbH. All rights reserved,
CATIA Is & registered trademark of Dassault Systémes.
Teamcenter is a registered trademark of Siemens PLM Software.

Plug-in Details | Configuration Details |
Figure 11: CMI Rl application About dialog.
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I
Pop-Up menus of CMI Rl tems

If you select an Item and drop it into, or Send it to the CMI Rl application, a BOMLine will
be created dynamically. ltems which will be handled as geometry items are represented

by *3, structure elements are represented by S you select a Drawing dataset and
drop it into, or Send it to the CMI RIl application a dataset is shown in the CMI Rl

application. The Drawing dataset is represented by 'ﬁ

Items in the CMI Rll application

On the Item objects displayed in the CMI RIl application window there are the following

functions available:

EPCMIRII - Teamcenter § =101
Fie Edt Tools Window Help
falizfalal= e TEAMCENTER
Search el 1 =8
[Engine - Mame | Itern 1d | Revision | Occurrence Name |
s [ (53] 000006]4
- QuickLinks  Cugtomize ¥ &3 ooone
-F
& Home » -7 ConnectionRodiA; Sing A ConnectionRod, 1
QMV “worklist » o~ [F % Crankshaftfa; L (v Send To M| oA Crankshaft.1
¢ » - ey
[ my 5_sved Searches [ & CrankBolta; 1 ¥ Bpand A CrarkBolt. 1
S by Links » i [7 % CrankshaftLef o] A CrankshaftLeft, 1
<pand Below
L[ % CrankshaftRic i A CrankshaftRight. 1
" R Expand Below..
» Dpen Items =-- 7 % FixedParts(a;1 (vi A FixedParts, 1
DT 8 CylinderBlock! Callapse Below A CylinderBlack. 1
istory : —
(- [7 % RackfA;L (viet &2 Remove From Window A Rack.1
L Gy Organize o fycaseldil off pihiight in Catia A Case.l
vk x:;ScrewM.l £ Prapertis... A Screw. L
P IWant To.  ccromize Wy Screwiag ) refrosh A Strew.2
oW g Screwpeg S A Strew.d
L?) Getting started R Serewpa; L Serew a Serew.4
5% % PistonCompletefa; 1 (view)  PistonCompleke a PistonComplete. 1
& cirn o Pistanga; 1 Piston a Pistan. 1
- P pistonBoltassmfi; | (view)  PistonBaltAssm a PistonBoltassm. 1
My Teamcenter 1 [¥] 2y PistonBolt/a; L PistonBol: A PistonBalt. 1
7 % RetainingRingia; 1 Retairingfin a RetainingRing.
Structure Manager F ol o 9 ) 9% o 9 ) 9 ) g
2 7 % RetainingRingia; 1 RetairingRing a RetainingRing.2
G % Flg > ‘ Q
Ready X% FBEGE o

Figure 12: Context menu on a BOMLine in the CMI RIl application

~ Q’ : The Remove from Window command is only available on top level elements.

Single selection (CMI RII) Description

Send To Sends the selected object to another Teamcenter
application.

Expand Expands the object one level.

Expand Below Expands the object multiple levels.

Expand Below... Expands the object multiple levels, a dialog will be
displayed where the level number can be defined.

Collapse Below Collapses all children.

Remove from Window Removes the selected object from the CMI RII
application window.

Highlight in Catia Highlights the selected objects in CATIA.

Properties... Displays the Teamcenter properties dialog.

Refresh Refreshes the selected object from the database.

Models in the CMI Rl application

On the Dataset (CATDrawing) objects displayed in the CMI RII application window there
are the following functions available:
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File Edt Tools Window Help

Ralz=d=N

CMIRIT (1

Search

TEAMCENTER

|Engme -
~ Quick Links Custarmize
BHome »
KMy warklist >

| & My Saved Searches 3
Sty Links »

» Open Items

» History

» Favorites Organize
P IWantTo.. e

;?} Getting Started

&7 o

My Teamcenter

Structure Manager
& ¥ E g

Ready

5.

o

It Id Revisian Occurrence Name
% )
W % = Remave from Window ectiorRod A ConnectionRod. 1
7 % 3% Highlight in Catia kshaft A Crankshaft.1
- l:'_sf Praperties.., kBolt A CrankBolt.1
- |3 Refresh kshaftLeft A CrankShaftLeft.1
-, #kshaftRigh A CrankShaftRight. 1
I % FixedPartsia; 1 tviswr) FixedParts A FixedParts, 1
o F % CylinderBlock/a;1 ylinderBlack A ylinderBlock.1
= Rackif;1 {view) Rack A Rack. 1
b [ % Casefiit Case A Case.l
b [ % Sarewfa;t Screw A Screw 1
e[ Screwfagl Screw n Screw.2
e[ Screwfagl Screw n Screw.3
e [F 8 Screwfagl Screw n Screw.4
¥ % PistonComplete(a;1 (view) PistonComplets ) PistonComplete, 1
7 Pistonj;1 Pistan a Fistan. 1
-7 % PistonBoltssm/a; 1 tview)  PistanBaltAssm A PistonBaltassm. 1
- % PistonBalt/a; 1 Pistangelt a Pistongalt.
[V & Retainingring/a;1 RetainingRing B RetainingRing.
IV % RetainingRingié; 1 RetainingRing A RetainingRing.2

| al=|

X% Q| D0

Figure 13: Context menu on a Dataset in the CMI RIl application

Single selection (CMI RII)

Description

Remove from Window

Highlight in Catia

Properties...
Refresh

Removes the selected object from the CMI RII
application window.

Highlights the selected objects in CATIA.
Displays the Teamcenter properties dialog.
Refreshes the selected object from the database.

10

CMI RIl User Manual



Enhancements in the
PSE Application

This section introduces the enhancements in the PSE Application by listing its functions.

CMI RIl Menu bar in the PSE Application
The PSE application menu is enhanced by a new CMI — RIl Menu Item (Figure 14).

File Edit “iew CMI-RII Tools ‘Window Help

Figure 14: PSE application with CMI RIl menu

Menu item CMI-RI
The Menu item CMI — RIl Menu (Figure 15) contains two commands to send data to
CATIA.

File Edit Wiew | CMI-RII Tools ‘Window Help
£ Send Tao Catia
&5 Send DMU Ta Catia

Figure 15: PSE menu ‘CMI - RIF

CMI—RII-> Send To Catia
The menu item CMI — RII-> Send To Catia will send the expanded PSE content to CATIA.

“i-) The Send To Catia command will send the content of the current active PSE
t_,f application window to CATIA. Only expanded structures will be sent to CATIA.
Unexpanded structures will not be sent to CATIA.

3P structure Manager - Teamcenter 8 =101 x|

File Edit  Wiew - Tools window  Help
Im & TEAMCENTER
= R 3 e 5 Caia FRIED|[ > 2D L I THNRALA LM

~ Structure Manager (tc

Search (7] structure Manager £3 -0
=
IE"G‘ne T || Enginef;1 (view) - Latest Working - Date - “Now" O & w
v QuickLinks oo EOMLine ahsol e Transfrma
B rome » % Engine/A; L (view) 10000100001 ..,
Sty Werkist > ©% Connectionfodja;1 0.583790834025839 ... ConnectionRod. 1
QMV ot tes 9 % Crankshaftia;l (view)  1.06606442343407¢-... Crankshaft.1
' Saved dsarches Lo CrarkBoltjn; L 0.097987757967220.,. CrankBolt,1
7 My Lirks »

B CrankShaftleftiail  -1.10957972944471e... Crankshaftleft.1
4 CrarkshaftRightys; 1

CrankShaftRight. 1
~ Open Items PP

Engine/f;1 (view)

- History

LVJ Getting Started
,( CMIRIT
My Teamcenter
Structure Manager
TR SIS T ——

Ready PR e

Figure 16: PSE Application with Send To Catia command
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Only the expanded structures from the example structure in Figure 16 will be sent to
CATIA. The selected items FixedParts and PistonComplete are not expanded and the
substructures of these items are not sent to CATIA.

CMI—RII->Send DMU To Catia

The menu item CMI — RII=>Send DMU To Catia will send the DMU ‘marked’ PSE content
to CATIA.

&) The Send DMU To Catia command will send the checked content (checkboxes are

4 presented by the viewer functionality) of the current active PSE application window
to CATIA. Only checked structures will be sent to CATIA. Unchecked structures will
not be sent to CATIA.

&P 5tructure Manager - Teamcenter 8 =101 x|

File Edit View | cMI-RII Graphics Tools Window Help

TEAMCENTER

qEAU MO PH

Search [#] Structure Manager 53 =0
IEngme M ‘Englr\eﬂA;l(v\ew)-Latestwovkmg-Date-"Now” | iz %
~ Quicklinks ¢y cromize S, Supersedure | attachments
EHome » [7 % “. Enginefa;1 (view) @) variants o Viewer | ) Referencers
My Warklist 5 [ & ) ConnectionRod/#;1  ConnectionRod. 1 =3
3 B %4 Crankshaft/a1 (vi... Crankshaft,1 E"-‘ XEaE oo ‘?ITY' [
|2 My Saved Searches 5 L
@ iy ke » S ) CrankBolfa;l  CrankBok.d
71 % ¥ Crankshaftleft... CrankShaftLeft,1
J2 % 0 CrankshaftRig... CrankshaftRight.1
~ Open Items =2 1 yiee FixedParts 1
% Enginedi1 (view) [ %7 CylinderBlackya; 1 CylinderBlock.1
=[] 4, Rack/8;1 (view) Rack.1
Sl Casefiil Caseld
w7 W0 Serewfail Serew.1
~ History co 7] 00 Screwfail Screw.Z
T Screwfasl Screw.3
& Getting Started LT screwial Sorew.d
B[ % %, FistorComplete/a;... PistonCamplete. 1
’( CMIRII [T 0 Pistanya 1 Piston, 1
=[] % “, FistonBoltassm... PistorBoltAssm. 1
My Teamcenter L[] %0 PistonBolt/. . PistorEalt. 1
= L7 2 RetainingR. .. RetainingRing. 1
Chicbimelanadey %70 RekainingR... RetainingRing 2

PR (S T —

Ready IX%d WO | _J0

Figure 17: PSE Application with Send DMU To Catia command

Only the checked items from the example structure in Figure 17 will be sent to CATIA. The
unchecked structures FixedParts and PistonComplete will not be sent to CATIA.
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Enhancements in the
My Teamcenter Application

This section introduces the enhancements in the My Teamcenter Application by listing its
functions.

CMI RIl Menu bar in the My Teamcenter Application

The My Teamcenter application menu is enhanced by a new CMI — RIl Menu Item (Figure
18).

File Edit Wiew CMI-RII Translation Tools SWindow Help

Figure 18: My Teamcenter application with CMI RIl menu
Menu item CMI—- Rl

The Menu item CMI — RIl Menu (Figure 19) contains a command to send data to CATIA.

File Edit Miew | CMI - RII Translation Tools Window  Help
£ Send Tao Catia

Figure 19: My Teamcenter menu ‘CMI - RIP.

CMI—-RII-> Send To Catia

The menu item CMI — RII>Send To Catia will send the selected My Teamcenter objects

EPMy Teamcenter - Teamcenter 8 Py ] 4|
File Edi View s Window Help
s E I
|6 [ & B =i RIESIESN SN TEAMCENTER
Search Ciloonoosia 52 - 21 T B[* summary 52 [ Details| o viewer | ' mmpact Analysis| 2 WRreview| = O
Enter Ttem ID to seard | [£Y - C = e Loy T
s by
LTI —— 8 ooer ]53 000006/A e—
B Home % ~ Properties - A
My Worklist »
Edmy projects Ed Object: [noonoe/a
ity Links » ._
[\ My Saved Searches % Hame: [g00006]a =l J
~ Open Items —I ]
4 Dataset... (3) Descrption: =
4 Dataset... (2) =
4\ Dataset... (1)

Hoi

Owner: 8 £c2007 (tc2007) W

& Getting Started GroupID: % Endineering ¥
f CMI RIT Last Modifying User: ) £c2007 (kc2007) ¥

My Teamcenter Checked Out: |7
Structure Manager Checked OUEBY: (] Mo value

& % g » |

[
Ready

o
X% ey e

Figure 20: My Teamcenter application

&

The Send To Catia command will send the selected objects (see Figure 20) of the

current active My Teamcenter application window to CATIA. Only CATDrawings are
supported now.

CMI RII User Manual
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CHAPTER 4

CATIA relevant Objects in
Teamcenter

This chapter describes how to handle CATIA relevant data in Teamcenter.

Predefined Object Structure

The CATIA Teamcenter Interface (CMI RII) uses the following predefined object structure

Il
Fil. Edit View CMI-RIl Translstion Tools Window Help
= o > e
[RlEBE(x [®9R@ 3 8 |a TEAMCENTER
E %" My Teamcenter @ -
Search 0 surimary I3[ Detalls | 7o viewer | ™ Impact analysis| 2 T Preview
Q=B EmY A <
(= ) Tremn01 & It
> em001/A
e a8 /
B3 Ttem001 -view ~ Properties =
(=t % Itemooia;1
[ Teemon1ja Obiect: [Tremontfa
5{7 Ttem001 fA-view =
il rremont. 14 Hame: [Tremoo1fa = y
&l remantja E =
» Open Items ) rremont. 14 —
) ¥ 5 Vi Description: [Tremant i =] el
Al
»Fa £ |l
_ oo | Reference | Name [ ez [ remate | Tyee Last Modfied | volume |
e |CaTProduct [ttema01.CATPraduct | 15 Kb| [tmanFile: 30-Jul-2009 1256 volumel |
2
Open mpart. .. Expart.., J;‘Q‘i‘
Ready XWFhBEG R o

Figure 21: Predefined CATProduct object structure

An Item Revision has a Dataset attached of the type CMIStructure. The Dataset has
exactly one Named Reference of the type CATProduct. This will be loaded to CATIA as a

CATProduct.
'~ If no Dataset is attached to the Item Revision, a new Product is created in CATIA
Q :with the Read operation.
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IDMy Teamcenter - Teamcenter & . oy ] S
File Edit Visw CMI-RII Translstion Tools Window Help
o -
Jx\a\EuJIXHs%JJEH\:*‘J‘w TEAMCENTER
My Teamcenter ( | i g
Search Summary 32 5 Dekails | a=- Viewer | %/ Impact Analysis | 2
Tremo01 - I dy b f T
¥ QuickLinks ¢ onze | B0 TeemO0n & [tem001/A Summary
[ Temant
&3 Hame » {3 TtemD0L-view ~ Properties ~a=
My Worklist » Bl Teem00ifaL
[y Projects » [ temantia Obiect: [Tremontfa
@y Links » of7 Ttemon1jA-view
[& My Saved Searches ® 8 remont. /A Wame: [Tremno1jA = A
& &l emontia B =
» Open Items ® ﬁltemum ua =
[ vinw Description: [1remnntia =] Sel
[ S Named References x| E
»ra £ ®=
— oo | Reference | Name | see [ Remte [ Type Last Modfied | volme |
fe [CaTProduct [ItemO01.CATProduct | 15Kb| [ImanfFile: 30-1ul-2009 12:56  |volumel |
&
Open Import., .. Expart.,. X =
;I_I
Ready IR FHEG S 0

Figure 22: Predefined CATPart object structure

An Item Revision has a Dataset attached of the type CMI3DGeo. The Dataset has exactly
one Named Reference of the type CATPart. This will be loaded to CATIA as a CATPart.

- If an empty Dataset of the type CMI3DGeo is attached to the ltem Revision, a new

A,
Q - CATPart is created in CATIA with the Read operation.
1. "Named References of the tvne CMIRDGeon can handle references af the tvne mode/ -

~‘model is used for V4 CATIA model files.

‘cgr’ is used for light geometry representation files.

Working with Structures

A structure is made of one or more items.

An item can contain other items.

Creating an ltem

)

Flle>New->ltem...

: Named References of the type CMI3DGeo can handle references of the type model
-and cgr which will be loaded in CATIA with the Read operation. ~

In a Teamcenter Rich Client (e.g. My Teamcenter or PSE application) select:

The Item creation wizard is started and guides you through the Item Creation Process.

Searching for ltems

&

button

In a Teamcenter Rich Client (e.g. My Teamcenter application) press the @

In the Search window use the Predefined Search for Items. The result is displayed in the

My Teamcenter application.

Creating a Structure

To create or modify a structure in Teamcenter use the PSE application.

16
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The figure below shows an example assembly with expanded items in the PSE application

browser.

Figure 23: Example of an expanded assembly in Teamcenter PSE application

Example Structure for CMI

The following instructions describe step by step how to create an example assembly

8P 5tructure Manager - Teamcenter &

File Edit View CWMI-RI Tocls Window Help

|B &3 n(x | (e >ew @M FDE

&

“ Structure Manager

Search [ Structure Manager £3

~=1olx|

|3 TEAMCENTER

IEnterItam]D to searcl -

Engine/;1 (view) - Latest Working - Date - "Now"

%555 My Teamcenter

r“ CMIRTT B

% PistorBoltAssmiA;1 (... PistonBoltdssm
% PistonBoltfa; 1 PistonBolt
% RetainingRing/A;1  RetainingRing
% RetainingRingfa; 1 RetainingRing

Structure Manager

&% Fgn >

=L e ey

¥ Quicklinks — cypomize EQMLine | Item Id | occurrence Hame |
& EnginefA; 1 (visw) Engine
g:jmjnmls[ :z ~ % ConnectionRod/&; 1 ConnectionRod ConnectiorRod, L
[ % Crankshaftia; 1 (view) Crankshaft Crankshaft.1
[ my Saved Searches LB CrankBolia; 1 CrankBolt CrankBolt.1
Py s » % Crankshaftleft/d;l  CrankhaftLeft Crankshaftleft.
% CrankshaftRight/a;1  CrankshaftRight CrankshaftRight.1
~ Open Items % FixedPartsff;1 (visw) FixedParts FixedParts,1
% Engineia; 1 (view) : % CylinderBlockfa; L CylinderBlock CylinderBlack. 1
B Rackja; 1 {view) Rack Rack.1
% Caselmt Case Case.l
- Serewfa; 1 Sarew Serew. 1
~ History - My Screvwia; 1 Screv Screw 2
% Iremaodia A Screwiag1 Screw Screw.3
% Screviagl Screwv Screw. 4
) Getting Started B % PistonCampletefa;1 (view) PistanCamplete PistonCompiete. 1
= 4 Piston/a; 1 Pistan Piston, 1

FistonBoltAssm, 1
FistonBol:, 1
RetairingRing. 1
RetairingRing.2

Ready

X% WO E| Do

structure which can then be loaded into the CATIA session:

&

&

Start the PSE application in Teamcenter Rich Client (Figure 24).

Search (7] Structure Manager £3

2P structure Manager - Teamcenter 8

File Edit Wiew CMI-RII Tools iwindow Help
Im G| %] x
[m RO 2= &l

ED|EL & O8N AA N

=101

TEAMCENTER
L]

| ttemMame

Occurrence Name:

~ Open Ttems
5 000100/4;1-Table

- History

Q Getting Started

; CMIRII

1%} My Teamcenter

Structure Manager

Ge@e 0

[oo0ro0 | Ha structure - Latest working - Date - "Now’”
v Quicklinks oo BOM Line

{dHome »

G My Worklst »

[ty Saved Searches %

G My Links »

11 I

Ready

X% WO E| D0

Figure 24: Empty Teamcenter PSE application

Create a new item named “Table” with File=>New-=>Item...
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Il
File Edt View CMI-RII Tools Window Help
=
IR R xdm|x . i TEAMCENTER
R &= 2l R(EFO( Y BIHFTRIAKCr N
& Structure Manager i
Search [ Structure Manager £3 =8
I000100 7 || 000100j4;1-Table - Latest Working - Date - "Now'" O & ow
¥ Quicklinks e EOM Line Ttem Mame Oceurrence Hame
3 n

BB Home » > i

Sy Worklist »

|24 My Saved Searches 3

Gy Links »

~ Dpen Items

% 000100/8;1-Table

~ History

o:'} Getting Started

; CMI RIT

{55 My Teamcenter

Structure Manager

% B o> ||NeE Hdl |
Ready X FREge| Jo

Figure 25: PSE application with “Table”

Select the “Table” and create a new item named “Plate” with File>New-=>Item...

e Select the “Table” and create a new item named “Leg” with File->New->Item...

P structure Manager - Teamcenter & =] 5|

File Edit View CMI-RI Tools window Help
m |2 &0 o TEAMCENTER
[ RS | = | ®| %l TR TRRAN DM

< Structure Manager (

Search [7] *Structurs Manager 53
|nnmnn -

v QuickLinks  tomize

&3 Horme: %
gy worklist »
[ &My Saved Searches 3
iy Links »

Occurrence Name

% 000101/#;1-Plate Plate
% 000102)4;1-Leg Leg

~ Open Items
5 000100/%,; 1-Table (view)

~ History

?) Getting Started

; CMIRIT

%3y My Teamcenter

Structure Manager

s Tedn || HeEEe— =
Ready Y I IR

Figure 26: PSE application with “Table”, “Plate”, and “Leg”

8) Select the “Plate”, right Click>Send To->My Teamcenter.
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$PMy Teamcenter - Teamcenter 8 - ol x|

File Edit View CMI-RII Translation Tools ‘Vindow Help

[l & Dmix [» 9 &SR 85 |Q TEAMCENTER

search * Summary 82 ] Details | @ Viewer | " Impact Analysis | 2| T Preview
Enter Ttem 1D ko searc| - S g &y T
¥ Quick tinks ¢y oz #, 000101-Plate summary
[ voo1ot
&3 Home bd % 000101 /4;1-Plate ~ Properties ~ Actions
My Worklist »
My Projects > Obect: [900101-Plate
@1y Links » [i= Copy
|24 My Seved Searches % Name: [Plate =
(5], Save
» Open Items =
Description: = .
» History L
» Favorites o %
- Owner: 8 tceo0r (erony) v
ISR Sa— T e .
N . B oootonja Group 10 B Enaneerng ¥
u Getting Started 5 view % Enanesring
)_f CMI RIT Last Modifying User:  § rc2007 (vezo07) w
{5} My Teamcenter Checkedout: [
Structure Manager Checked Out By: (%) Mo Value
& ®Eg 0> o | ]
Ready XS EmREeg | _Jo

Figure 27: My Teamcenter application with “Plate”

Select the Iltem Revision “xxxxx/A;1 — Plate” and use the command
File->New—->Dataset to create a new dataset of type CMI3DGeo to define a
geometry.

Use the More... button on the left side to select the type CMI3DGeo.

The CMICatiaV5 Tool is set automatically.

&

Press the OK button to continue.

EPNew Dataset x|
ahe
2
Mame: [ao0101/4 i
Descripkion:
Tool Used: ICMICatia'u'S vI
Impork: I -
Mare.. . [~ Cpen Cn Create
K Apply Cancel |

Figure 28: New Dataset dialog

Repeat the same procedure for the “Leg” item and switch to the PSE application.

&

Select the “Leg” of the “Table” in the PSE application and copy the item with
Edit>Copy.

Select the “Table” item and paste the “Leg” item three times with Edit->Paste.

\
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Flle Edit ¥iew CMI-RI Tools window Help

A= XD n|x

“ Structure Manager

P structure Manager - Teamcenter 8 _1of x|

[ e =@ 4R FD P TR ONEAN PN

TEAMCENTER

~ Dpen Items

5 000100/4;1-Table (view)

~ History

@2. Getting Started

f CMIRI

{11}, My Teamcenter

Structure Manager

PPN I T —T

Search (7] structure Managsr £3 -0

000100 = [ :
| a 000100/#; 1-Table (visw) - Latest Working - Date - "Now O # o«
v QuickLinks  ¢oromize ECM Line Ttem Name Occurrence Name
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My Worklist »

|2, My Saved Searches %

By Links » % o0010218;1-eq Leq

% 000102/A;1-Leg Leg

Ready

X RERGE_1

Figure 29: My Teamcenter application with complete “Table”

Check that CATIA is started with installed CMI RII.

Select the “Table” in the PSE application and
right Click->Send To->CMI RIL.

Select the “Table” in the CMI RIl application and right Click>Expand Below.

File Edit Tools window Help

=l A=

CMIRII (tc

Search

TEAMCENTER

IEnter Ttem ID to searcl - Name Item Id
~ Quick Links Customize ¢ % 000102/4;1-Leg 00102
B Home » [ % 000102/4;1-Leg 000102
Gty wiorklist » [ % 0001024 1-Leg 000102
[A1My Saved Searches » [ % 000102/4;1-Leg 000102
@y Links » [ % 000101 /A 1-Plate o101

» Dpen Items

» History
} Favorites Organize
» IWant To.. Customize

l?‘) Getting Started

f CMIRTI

ii5; My Teamcenter

Structure Manager

&% Fgn >

Revision Occurrence Hame

> r P b b

| — |

Ready

JOX g BEG2|

Figure 30: CMI RIl application with complete “Table”

' CATIA.

Use the Tools=>Send To Catia command to send the content to CATIA.
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Figure 31: CATIA V5 with loaded “Table”

Updating a Structure
Complete construction in CATIA and press the Update button in CATIA V5.

The files in CATIA and the metadata are updated to Teamcenter.

[$]CATIA ¥5 - [000100.CATProduct]

Bl bk b wew It Took oo anshee 21}

| - = i ]
LedafansEBg eRBE. v i M1 mformation

ItemPevision Item 00010074;1-Table updated. -
(CMIStructure Dataset 000100/A created,
’7CMI Operation Status

(CMIStructure Dataset 000100f4 attached to Ttem 000100/4;1-Table.
(CMIStructure object 000100/ checked out.
o Update Finished

-

File 000100, CATProduct for Dataset 000100/4 uploaded.

 eAAB PR

Nes@gayese o 0 BS8s sFead’s 2,
I EE]

Select an object o a command

Figure 32: CATIA V5 with updated “Table”

E') Change the visible attributes in the CMI RIl application and check the values for
o Occurrence name and Matrices. Both attributes are filled with the current CATIA

data.
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Figure 33: CMI RIl application with complete “Table”

&

| 2PMy Teamcenter - Teamcenter 8

File Edit View CWI-RII Translston Tools Window Help

[BlEbn|x |seda

Select the “Plate” and right Click->Send To>My Teamcenter
Verify that the dataset and a named reference are added.
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Figure 34: “Table” item in My Teamcenter

Highlighting an ltem in CATIA

In cases where you have loaded an assembly structure to CATIA as described in the
steps above, it may be useful to find the corresponding model in the CATIA session of an

item displayed within the CMI RII application.

For this purpose, it is possible to highlight CATIA models in CATIA using the currently

selected item in the CMI RIl application.

&

In the CMI RII application, select the item you want to be highlighted in the CATIA
session and choose the Highlight in Catia option in the Pop-Up menu.
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Figure 35: Highlight Pop-Up menu in CMI RIl application

CATIA comes to the foreground with the selected CATIA model highlighted.

[#]caTIA vS - [000100.CATPraduct] =] 4
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Figure 36: Highlighted item in CATIA V5
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CHAPTER S

Working with CATIA V5

Introduction
This chapter describes the CMI interface between CATIA V5 and Teamcenter. Typical
tasks discussed are loading items/structures/drawings stored in Teamcenter into CATIA
V5 and creating/updating parts and drawings in Teamcenter. One of the main
subsections deals with creating and saving CATIA V4 models.

|

Product Structure CATIA V5 vs. Teamcenter

Product structures in Teamcenter correspond well to product structures found in CATIA
V5. The following graphic illustrates the product structure in Teamcenter and CATIA V5.

o
s

Bl st Ele Edt Wew Inset Toos Ml Anabes  Window Help ]

sl L RSB SERS LR AAE S

TEAMCENTER Jr:g

bx b

<

L= gl

wooioz A wonioz 1

B Home » 00010z A 0001022 @
Sty workdst » oo A ooz [
[Pty saved Seaches wootoe » oot Hl
@ity tinks » 00001 A oooto1.1 N
» Openitems =
» History (g7

....... o2
» Favrit Orgarize e
[T ST g
D) Gettingstrted %

g

5 My Teamcent ter

J

e

TETEE a0 s88LEE0 e  He BA0 aHenARL 2.,
[

Ll 7 X . P ¥R G 2| _ 1| Selectanobjctor aconmond

Figure 37: Product Structure in Teamcenter and CATIA V5

I
CMI Toolbar

The following figure shows the toolbars of the CATIA V5 CMI module. Descriptions of the
toolbar and the command icons follow below.
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| Read from Teamcenter |

| Update Teamcenter |

| Synchronize Teamcenter |

| SaveAs in Teamcenter |

Highlight in Teamcenter

=
= 5

Restore Session

Save Session

Use CATIA Catalog from Teamcenter

Reconnect with Teamcenter

Get original geometry from Teamcenter

AddTemp from Teamcenter

Insert from Teamcenter

Figure 38: CMI Toolbar in CATIA V5

With the CMI toolbar it is possible to read files from the CMI RIl application in Teamcenter.
You can then modify the geometry in your CATIA V5 session. The modifications can be
updated in Teamcenter via the ‘Update Teamcenter’ or the ‘Synchronize Teamcenter’

button in CATIA V5.

The icon ‘Highlight in Teamcenter’ is only active if you are working with a product

structure.

You can get the Teamcenter information of the CATParts, CATProducts, CATDrawings,
and CATIA V4 Models with the CMI Info button if you loaded the product structure with

CMI to CATIA V5.

The other commands will be described in more detail later in this chapter.

I
CATDrawings in CMI Rll application in Teamcenter

CATIA V5 will read all expanded assemblies, single CATDrawings from the Teamcenter

CMI RII application.

The following figure shows a CATDrawing in the CMI RII application:
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Figure 39: CMI RIl application with a CATDrawing dataset

When you have transferred a CATDrawing from Teamcenter to CATIA V5 via the CMI RII
application, the drawing will be displayed in CATIA V5 in a new window.

CMI for CATIA V5 also supports CATIA V4 models and CATIA V5 Drawing files
(CATDrawings). CATDrawings may be included in assembly structures in Teamcenter,
however in CATIA V5 they will be displayed in separate windows as shown in the figure
below.

All normal CMI functions (Read, Update, Create and Save As) may be used with
CATDrawings and CATParts within CATIA V5.

[$]CATIA V5 - [CMI - 000100] =1Oj x|
B tart  Fle  Edt  View Insert Tool CMI Window  Help == x|
A AARIERE L4582 O B o
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| I| | s
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F"_} — N =—THEN a1 ! &
Crel T e
| a ! | : | : B
[ ) S o o R N 1
m_ 0
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L1 g;g
|l [ o[
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Figure 40: Drawing Workbench for Read, Update,
Create or Save As CATDrawing

CMI toolbar: Read From Workbench

£
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With the ‘Read from Workbench’ button in the CMI Toolbar the content of the CMI RII
application in Teamcenter may be read into CATIA V5. The CMI RII application may
contain CATDrawings, and assembly structures.

If you want to send one or more assemblies, CATParts or CATDrawings to CATIA follow
these instructions:

Drag and drop, Send To drawings (CMI2DGeo datasets) or assemblies (items) into
CMI RIL.

Expand or Deexpand the assemblies in the CMI RII application. Only those items
that are shown in the CMI RII application will be opened in CATIA.

Read Teamcenter CATIA items with Read From Workbench icon ’E .

Every top-level item in the CMI RIl application will be opened in a separate browser
in CATIA V5.

If the PSE application is the current active application in the Teamcenter Rich Client
: the PSE content will be read to CATIA instead of the content of the CMI RII
- application.

CMl toolbar: Update Teamcenter

ﬁ.

&

B

This command updates geometry and position information in Teamcenter.

Modify the content in CATIA.

All files in the assembly and the position information (transformation matrix) which
have been modified in CATIA will be updated in Teamcenter.

Write the modifications back with Update Teamcenter icon

The success (green icon) and more detailed information (Figure 41) are then displayed to
the user.

CMI Warnings | ....... |

ItemRevision kem 000100)4A; 1-Table updated. -
CMIStructure Dataset 000100/A created,

CMIStructure Datasst 000100/4 attached ko Thern 000100/4; 1-Table,
CMIStructure object 00010004 checked out.

File 000100, 2ATProduct for Datasst 00010074 uploaded. ;I

—CMI Operation Status

o Update finished

Clase I

Figure 41: Dialog Window for Update Teamcenter

28

CMI RIl User Manual



CMl toolbar: Synchronization in Teamcenter

@

This command updates Teamcenter with any changes made to your CATIA V5 product
structure. The changes that will be reflected in Teamcenter include:

= any geometry and position information changes,

= the creation of any new CATParts/cgr/models and CATProducts that have been
added to your product structure,

= the creation of any new CATPart/cgr/model and CATProduct instances,

= the removal of CATProducts and CATPart/cgr/model instances from the product
structure.

The changes made to the product structure since the last Read/Update/Synchronize are
presented in the form of a list of operations to be performed in Teamcenter.

Modify your product structure in CATIA by adding a new CATPart/CGR, adding a new
CATProduct, removing a product or by changing the geometry of a CATPart.

Write the modifications back to Teamcenter with the Synchronization in Teamcenter

icon ﬁ .

The following dialog will appear, showing which changes need to be written to
Teamcenter:

=T
Elgtst  Fle Edit  View Inset  Tools  CMI Anslyze  Window  Help =131x|
| L LB ELBEBELDE LEM 4

4

4

Brepel sl gl

Ix

[CMI Synchronize Teamcenter =1

Le] tion Li

Part Mumber
R 1 2
000103 TableDecoration CATPrO Link. ...
000100 Table CATProdurt Update [ Link ... ¥

Ediit POM-Part catenory... | i | synchronize | Close | J

utput window

Single step made

Figure 42: The Synchronize Teamcenter dialog

The dialog's Operation column shows which procedures need to be performed in
Teamcenter for each object and may be a combination of the following:

Update The file and positional changes of any children will be updated in
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&

&

&

&

Teamcenter.

Create

The object will be created in Teamcenter. The object is completely
new and not already in Teamcenter.

Link Child At least one new parent-child relation will be created in Teamcenter.

This reflects the addition of a child product in CATIA.

Drop Child At least one parent-child relation will be deleted in Teamcenter. This

reflects the deletion of a child product of the object in CATIA.

The column Execute shows whether the operation will be executed or not. If there is any
reason why the operation cannot be executed, then the reasons will be shown in the
Result column.

If new geometry files are to be created in Teamcenter the default is BOM Type. This
will become an item and a dataset in Teamcenter.

With the Edit PDM-Part category button the category can be changed to No BOM
Type in the Edit new PDM-Part category dialog (see Figure 43). This file will become
a dataset in Teamcenter and will be attached to the parent item.

Edit new PDM-Part categor: e

PartMumber |ng|34

PDM-Part category |NEpsroee Type

I apply to all new PDM-Parts

<Previous| [exk = | [9]4 |
Figure 43: Edit PDM-Part category dialog

If the Synchronize button is pressed, the list of executable operations is worked
through in the order shown on the screen.

The results from Teamcenter are shown in the Output Window below the list.

The Update operation:

CATIA File objects will be updated in Teamcenter. No user interaction is necessary.

The Create operation:

CATIA File objects will be created in Teamcenter and the following steps will be
completed:

a Teamcenter item will be created.
The created item is also linked to the users Newstuff Folder.

a dataset will be created under the item

the file will be imported in the dataset as Named Reference with the correct
type (CMI3DGeo or CMIStructure).

The Link Child operation:

This may only appear as an operation for CATProduct objects, as CATParts
cannot contain sub-products. In Teamcenter any new children will be added
to the Teamcenter item of the parent object by creating a new BOM Line.

The Drop Child operation:

This may only appear as an operation for CATProduct objects as CATParts

cannot contain sub-products. In Teamcenter any child CATProducts deleted
from the CATIA product structure will be detached from the Teamcenter item
of the parent object by removing the BOM Line.

After every operation the success or failure will be registered in the result column of
the dialog. If an operation fails the output window will provide you with the cause of
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the failure.

[3]cATIA ¥5 - [000100.CATProduct] =10l x|

] stat  Fle  Edit  Vew Insert Tools CMI  @nalyze  Window  Help 1= x|

 LLB S ASBELT T HLM S

2
@
(0]
Operation List
Mext Op | Part WNumber Momenclature Categor Operation Execute | Result
000104 Wase CATPart (BOM) Create v Succeeded
000103 TableDecoration CATProduct Create fLink ... Y Succeeded

000100 Table CATProduct Update j Link ... ¥ Succeeded

Edft PDM-Part category. . o | Synchronize | _Closs | J
utput window: =
< 000104 CATPart (BOM): Create > f’

Ttem Ttem 000104/A; 1-Yase created,

CMI3DGen Dataset DOD104/A created.

CMI3DGeD ohject 000104/A checked out.,

File 000104, CATPart for Dataset 000104/4 uploaded, |

Single step mode

Figure 44: The Synchronization in Teamcenter dialog with success

CMl toolbar: SaveAs in Teamcenter

@

With this command a CATPart or CATDrawing currently set active in CATIA V5 can
replace another file in Teamcenter. A CATPart or CATDrawing selected in Teamcenter
and then dropped into CMI RIl will be overwritten by the contents of the CATPart or
CATDrawing in CATIA memory.

Design or load your CATPart or CATDrawing in a separate window in CATIA.

In CATIA V5 select the Save As in Teamcenter icon dﬁ .

Drag and drop or Send an item into the CMI RII application in Teamcenter.

&

In order to ‘Save As in Teamcenter’ with a CATDrawing, drag the ‘new’ CATDrawing
dataset to be overwritten into the CMI RII application in Teamcenter. The
CATDrawing active in CATIA V5 will then overwrite its content.

In Order to ‘Save As in Teamcenter’ with a CATPart, drag the ‘new’ item to be
overwritten into the CMIRII application in Teamcenter. The CATPart active in CATIA
V5 will then overwrite its content.

!~ Please take care when you ‘Save As’ a CATPart which is used in a CATProduct-a :
Q :reference to the CATPart is stored within the parent CATProduct. Make sure that the :
:new CATPart is compatible. i
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CMl toolbar Highlight in Workbench
>4

If you want to highlight CATParts, CATProducts, and CATIA V4 models in the CMI RII
application triggered by CATIA V5 perform the following steps.

In CATIA V5 select the CATIA objects you want to highlight in the CMI RII

application and choose the Highlight in Workbench icon from the CATIA CMI
toolbar.
Now the items are selected in the CMI RII application.

&

I
CMl toolbar: Get original geometry from Teamcenter

F

=

The ‘Get original geometry from Teamcenter’ command retrieves geometry files (CATPart
or CATIA V4 model) from Teamcenter if the geometry files are not yet loaded in CATIA

V5.

A CATProduct, CATPart or CATIA V4 Model has to be selected in the product

structure.
!~ iThe function is used in context of huge product structures in CATIA to getthe -
Q - original geometry file from Teamcenter if the Do not activate default shapes on open

- option is set in the CATIA Product visualization settings (see Figure 45).
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Figure 45: Do not activate default shapes on open option in CATIA V5

CMl toolbar: Add Temp

.

The ‘AddTemp’ command allows the user to visualize a temporary structure together with
the working one.

For example, if the user is making a design of a car and wants to see if the luggage boot
is big enough, he can load a suitcase as a temporary structure by doing the following
(supposing that the car structure is already loaded):

In CATIA V5, go to Tools>Options—-> Compatibility (Tab: “CMI”) and make sure
that the option “Use one temporary product window...” is checked.

Read an assembly (here the car assembly) into CATIA using the CMI toolbar Read

command.

Drop the assembly or model you want to add temporarily to CATIA (the suitcase)
into the CMI RII application. Expand it as necessary. Click Tools>Temp To Catia in

the menu or press the Temp to Catia icon & in the CMI RIl toolbar. Changes or
expands you make to other assembly structures in the CMI RIl application will not be
sent to CATIA.

CATIA comes to the foreground with both the original and temporarily added

444

In CATIA V5 select the AddTemp from Teamcenter icon

&

structures loaded in the same window — here the car and the suitcase structure.

It will not be possible to make any changes to the temporarily added (suitcase)
structure.

The temporarily added part/structure is removed from the CMI RII application after
you sent it to CATIA.

A EAII Part Numbers and File Names in the temporarily added structure are prefixed :
Q -with “TMP#_", where “#” is a counter in CATIA V5, beginning with 1. Every AddTemp:
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: Limitation:
- CATProducts are not transferred to CATIA, the products will be represented by
- “CATIA Components”. Only position information from Teamcenter is processed.

Visualize multiple revisions of an Assembly using Add Temp

E}

Add Temp in CATIA V5 can be used to load different versions (revisions) of an assembly
or model at the same time. In order to make this possible, the Part Numbers and File
Names of the temporarily added assembly are prefixed with “TMP# _".

In CATIA V5, go to Tools>Options—> Compatibility (Tab: “CMI”) and make sure
that the option “Use one temporary product window...” is checked.

Read revision B of your assembly as described in CMI toolbar Read from
Workbench.

You will find that it is opened in CATIA underneath a product tagged “CMI
Workbench”.

In CATIA V5 select the Add Temp from Teamcenter icon % :

Find and expand Revision A of your assembly (drop it in the CMI RII application
window and use the Expand Below command in Teamcenter). Click Tools>Temp

To Catia in the menu or press the Temp to Catia icon £ in the CMI Rl toolbar.
Changes or expands you make to other assembly structures in the Workbench will
not be sent to CATIA.

Revision A and B of your assembly are opened in the same Window in CATIA V5.
You can overlay and position the assemblies relative to each other for comparison.

CMI toolbar: Insert from Teamcenter

&

=

The ‘Insert from Teamcenter command allows the user to load a CMI structure under a
selected product.

Read an assembly into CATIA V5 using the CMI toolbar Read from Workbench
command.

Select a product to be the root of the inserted structure.

In CATIA V5 select the Insert from Teamcenter icon 'I-—i

Drop the assembly-structure you want to use in CATIA V5 in the CMI RII application
window. Expand it as necessary. Click Tools>Insert To Catia in the menu or press
the Insert To Catia icon < in the CMI Rl toolbar. Changes or expands you make to
other assembly structures in the Workbench will not be sent to CATIA.

CATIA comes to the foreground with the selected product and the used structure.

The dropped part/structure is removed from the CMI RIl application window after you
sent it to CATIA.
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Via Synchronize you can save the new Use-Relation in Teamcenter.

CMl toolbar: Local Save and Restore

% % Using Save Local the content of the CATIA V5 session can be stored locally.

This snapshot of the session will persist even when CATIA V5 is closed.

% % When the session is restored with Restore Local, you can continue your work
as if you had just used Read from Teamcenter, i.e. you can perform Updates.

The Restore Local command is only available when the CATIA is empty —i.e. no
documents are open — to avoid conflicts.

A éWith Save/Restore Local you can avoid reading large assemblies from Teamcenter :
Q - repeatedly. However, the status of the data in Teamcenter may change if you keep
- your local snapshot for a long time. It may get “stale”.

The following restrictions apply:
= Only one saved session is maintained at a time.

= The session can only be saved when the data is up to date. l.e. there are no files in a
modified state, and no new files.

=  The save/restore session does not restore files that were not loaded from the PDM
system.

CMl toolbar: Reconnect with Teamcenter

&

CMI recognizes files that have been loaded into CATIA V5 through the CMI RII application
window. Since it knows that they are from Teamcenter, it can update them there.

Other files, that you load with e g. File>Open, it will not know. They will be regarded by
Synchronize as new files, and it will create new Teamcenter objects for them.

If you open a product structure from disk that contains files that are already in
Teamcenter, you can use Reconnect with Teamcenter to make CMI Rl recognize these
files. It will recognize products if the part number is correct, and CATPart/model files
based upon their filename. If the CATPart is a BOM CATPart (Component) in Teamcenter,
the part number must also match.
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CMIReconnectDialog 2lx|

Skatus | TC file access | Partnumber | Instancename | Parent Partnumber | Type | Filename |A
¥ CMI-Unknown  Read Write® Engine_Assm Engine_fssm CATProduct Engine_Assm. CATProduct

¥ CMI-Unknown  Read Write® FixedParts_fissm FixedParts_Assm.1 Engine_Assmm CATProduct FixedParts_Assm, CATProduck

'.,[" CMI-Unknown  Read Write® CylinderBlock CylinderBlock, 1 FixedParts_assm CATProduct CylinderBlock, CATProduct o
¥ cMI-Unknown  Read write® Zylinderblock. 2 CylinderBlock CATPart 01_gylinderblock. CATPart

¥ cMI-Unknown  Read Write® Rack_Assm Feack_assm. 1 FixedParts_assm CATProduct Rack_fssm, CATProduct

v CMI-Refere,.. Read Write Rack Assembly Rack.1 Rack_Assm CATProduck Rack, CATProduct

w CMI-Instance  Read Write Chassis Jdmap Chassis, 1 Rack Assembly Fdmap Chassis, 3dmap

w CMI-Instance  Read Write hassis CATShape Chassis. 2 Rack Assembly CATShape Chassis. CATShape

E CMI-Unknown  Read Write® Screw Screw, 1 Rack_assm CATProduck Screw, CATProduct

'.,[" CMI-Unknown  Read Write® Schraube, 1 Screw CATPart 10_Schraube, CATPart ;I
Select unknown | Reconnect selected |

| @ cancel

Figure 46: Reconnect dialog

There are three possible states:

CMI-Unknown: CMI does not know this item at all. It would be created as a new part in
Teamcenter.

CMI-Reference: CMI knows this item is in Teamcenter. But it appears that in
Teamcenter there is no instance known by the same instance name under the same
parent item. Maybe it was deleted or is new. It would be created as a new part instance in
Teamcenter.

CMI-Instance: CMI knows this instance is in Teamcenter. It can be updated in
Teamcenter.

An asterisk (*) signifies that the Reconnect Dialog recognized the item, but it is not yet
reconnected. Items are actually reconnected when you close the dialog with OK. Click
Cancel to keep them as unknown, e.g. if you want to save them as new Teamcenter

objects.
'~ Reconnect does not create anything in Teamcenter or updates any files. Use
Q : Synchronize to update data.

Load a CATProduct into CATIA V5 using File>Open.

In CATIA V5 select the Reconnect with Teamcenter icon ‘@' .
In the CMI Reconnect Dialog, click Select unknown. In this case, all lines will be
‘?' selected. Click Reconnect selected. If any items are recognized in Teamcenter, they
will change their status. To reconnect these items, close the dialog with OK. Click
Cancel to leave the dialog without reconnecting the items.

- Reconnected items that are writeable in Teamcenter will be in the “modified” state,
‘?' to be able to update them in Teamcenter.

Use Synchronize to create the unknown/new data and to update the reconnected

files.
>~ Tif you want to keep individual items as new, unselect them before you click ;
Q : Reconnect selected.
CMl toolbar: CMI Manage Catalogs

2

This command is described in section Manage Catalogs on page 40.
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CMi toolbar: CMI Info

A

This command displays the information from Teamcenter for CATParts, CGRs,
CATProducts, CATDrawings and CATIA V4 Models.

The More ... button displays attributes of the correspondent Teamcenter-objects. The
range of attributes can be customized.

[+]caTia vs - [000100.CATPraduct] ] o |m] 53

] st Fle  Edit  View Insert  Took  CMI  Anslyze  Window  Help == x|
| < 2%
L8 6YA5Es

[Product Properties

Single Object | Multple Cbjects |

[~ Catia attributes

[Exchiange map file name:
C\CMI_SMAPY 000103, CATProduct
[ Changed in Catia

[~ Teamcenter attributes

O ratt read only

[IFie read only

I File attarhable
Partrumber:  [300L03
Instancename: [oo0103,1
Revision: A

Nomenclaturs: [TableDecaration

Mare attributs information

| et

e : oy n__é
n

Attribute Name [ attribute value

Current 1D 000103 =
Current Mame TableDecoration J J —
Current Revisian a + i

Date Created 31-1u-2009 10:16 % EE ¢BRUL caria
ExCO - Explore Checked Out C =

Group ID Engineering Al&l
jul 000103

Is Modifiable

¥
em 000103-TableDeroration
TtemRevision Master 000103/8 =l

Close I

Figure 47: Information dialog window for CATProduct with “More Attributes”

Select the CATPart, CATProduct, CATDrawing or CATIA V4 Model.

In CATIA V5 select the CMI Info icon ﬁ . The appropriate dialog info window

appears.
N Q' ~ You can also select multiple CATIA items. Information will be displayed in a table
:view.
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Figure 48: CMI Information for multiple items

I
Handling of CATDrawings

CATDrawings can be included in your assembly structures in Teamcenter. All the usual
functions (Read, Update, Create and Save As) are supported for CATDrawings in CATIA
V5 via the CMI Toolbar.

CATDrawings may be created for single models or for assemblies. There are however
several caveats when working with CATDrawings and CMI, depending on the context of
the CATDrawing.

Creating a CATDrawing From a Single Model

M

When creating a CATDrawing for a CATPart, send the CATPart item from Teamcenter to
CATIA V5, and then create the CATDrawing. This method will preserve the context of the
CATDrawing - irrespective of whether the CATPart is later loaded into CATIA singly or as
part of an assembly. If you later make changes to the CATPart, and you wish the
CATDrawing to update and reflect the changes, you must load both the CATPart and the
CATDrawing in CATIA V5 using CMI before you update the CATDrawing.

Drag and drop the CATPart item on the CMI RII application or use SendTo->CMI RII
with the CATPart ltem.

Select Tools>Send To Catia or use the Send To Catia icon &1 in the CMI RII
toolbar.

Create the CATDrawing with the usual CATIA V5 functions.

Select the Synchronize in Teamcenter icon ﬁ

Creating a CATDrawing From a Product Structure

38

CMI RIl User Manual



Drag and drop the assembly into the CMI RIl application.

&

Select Tools>Send To Catia or use the Send To Catia icon &1 in the CMI RII
toolbar.

Create the CATDrawing with the usual CATIA V5 functions.

Select the Synchronize in Teamcenter icon ﬁ

I
Handling of cgr and model files

CATIA V5 cgr files and CATIA V4 Model files are managed as representation of an
embedded component in the product structure. It is not possible to modify such a
representation directly. It is only possible to use the Save As function of CATIA V5 to
create a new cgr or model file of a loaded CATPart or CATProduct. To update the
representation you have to replace the original representation by the new representation.

- Load an assembly which uses a cgr or model in the product structure. And use the
i right Click->Representations>Manage Representations ... command (Figure 49).

=I0i
e

EJ ctat  File  Edt  Wew Insert Tools CMI  Analyze  Window  Help

LAY SABALTE L

k=3

o

—————

=

Type | Default | Activated Associate...
004669 c\CMIZMAPIO04660.model  model  yes yes Remove
Replace...
Renams. ..

I
Activate | Deactivate | _set as nefault | close |

NEE8 290 X P’ B85
elect representations [ o @Il

Figure 49: Manage Representation dialog of CATIA V5

Use the “Replace” function to use the cgr or model file with a new representation.
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Manage Representations 2 x|

Associate. . I
Remowve I
Reelace. . I
Rename... I

Activate I Deactivate I Set As Defaulk I Close I

Figure 50: Manage Representation dialog of CATIA V5 with new model file

_ Use the CMI Update or Synchronize functionality to update the new cgr or model file
\?' in Teamcenter.

A - During the CMI Update/Synchronize process CMI replaces the original
‘representation file in the exchange directory by the new representation file and :
- changes the “Source” path of the representation back to its original value. Then the :
: new representation file (which has the name of the old file) is updated in ‘
: Teamcenter.

To use this function you need write access to the cgr or model data item in
- Teamcenter. Although the cgr or model is represented in an embedded component
- of a higher CATProduct you need no write access to the CATProduct.

!~ Restrictions:
Q ‘- There must be only one representation in one component.
- The “Name” of the representation must not change.

Catalog Management

CMI can also manage catalog files in Teamcenter. Teamcenter compatible catalogs
reference files and items that are actually stored in Teamcenter. If the user opens or
inserts a file from the catalog, CMI retrieves the corresponding data from Teamcenter and
starts the defined catalog function (see section

Update or Create Catalog for function details) with the retrieved file(s).

Manage Catalogs
'~ The Manage Catalogs icon is enabled when you have a CATProduct active. It 'a'|ié§/{fs"
Q “ to retrieve catalogs from Teamcenter for browsing.

: After starting the Manage Catalogs command the select catalog dialog will be
‘?' opened in CATIA.
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Select Catalog for browsing i |

CatalogDocurment 1
infodba_catalagl
jzeng_catslo

sdeS225_Catalog

Refresh List from Teamcenter l Cpen Cﬁog far Brawsing |

Figure 51: Select catalog for browsing dialog

: Pick from the list of catalogs available in Teamcenter and select the Open Catalog
‘? for Browsing button. The catalog will be opened in a CATIA Catalog browser.

Catalog Browser:c:, CMIZMAP' Bolts.catalog 21l

Current: Type 1 j g

| 3

Filter:l ﬁ | Table == i Launch i
-

1 004457

2 004455

3 004453 i

4 004451

5 004449 =l

@ oK & Cancel

Figure 52: Bolt Catalog opened in CATIA

: Double click an end chapter to open the item from Teamcenter. CMI RII will load the
‘? required files from Teamcenter if needed.

- - The administrator needs to set CMT ENABLE CMICATALOGREADCMD=ON in the
Q - CATIA environment in order to enable the Read Catalog function.

The Read Catalog icon is enabled when you have a CATProduct active. It allows
- you to retrieve catalogs from Teamcenter for editing.

_ After starting the Read Catalog command the Select Catalog dialog will be opened
‘ in CATIA. Read Catalog allows to retrieve CATCatalogs from Teamcenter for editing.
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select Catalog for editing x|

CatalogDocument 1
izeng_catalo:

5de5225_Catalog

Refresh List from Teamcenter I Open Catalog for Edting I
Close I
.

Figure 53: Select Catalog for editing dialog

: Pick from the list of catalogs available in Teamcenter and select the Open Catalog
‘? for Editing button. The catalog document will be opened in a CATIA catalog editor.

o) x|

jﬁ|0|

Description Defi

i CATPark
Mare: | 004457 o TPart
Reference | Keyword values I Preview
Type: Document
File name:| A\ CMIXMAP 004457  CATPart
Select
Select docurment I
Seleck Preview
Select external Feature p—
—— PRNET, i
Select document in sessian
@ oK I w Cancel I
I -

Figure 54: Edit catalog in CATIA

_ Use the Select document in session button to build the catalog from parts or files
‘? that were opened from Teamcenter via CMI.

Update or Create Catalog
!~ The administrator needs to set CMI ENABLE CMICATALOGUPDCRECMD=ON in the
Q - CATIA environment in order to enable the Update or Create Catalog function. The

- Update or Create Catalog icon is enabled when you have a catalog active.
. Update or Create Catalog allows saving new or updated catalogs in Teamcenter. It
‘? will manage the necessary keyword attributes so that the items contained in the
catalog can be retrieved from the Teamcenter database instead of the local file
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system.

: After starting the Update or Create Catalog command the catalog document is
‘? analyzed and the following dialog is shown.

CMI - Synchronize Catalog 2x|
Catalog Filename: Catalog Mame:
| ExampleCatalog.catalog | ExampleCatalog. catalog
[arne | Tvpe | Skakus
20080208 Madell Cpen Updated by CMI
20080207 _Modell Cpen as copy Loaded by CMI
20080225_Modell Cpen Mat known by CMI
LDF_A Instantiate Created by CMI
Edit selected ... | Synchronize |
Clase I
" -

Figure 55: Synchronize Catalog dialog

: For new catalogs that were not already opened from Teamcenter, the user can
‘?' change the file name which should be used in Teamcenter.

A “The type can be Open, Open as copy, and Instantiate. These types describe the
Q _way in which the items will be handled when the catalog is used with the Manage
: Catalogs command.
; e Open
Open the referenced object in CATIA so that the existing Teamcenter item
is used (e.g. standard part).
e Open as copy
Open the referenced object in CATIA so that it will be recognized as a new
item in Teamcenter (e.g. templates).
o Instantiate

A !

Instantiate is used for Features and Power copies which will be instantiated

in the active document.
The Status Field can be Loaded by CMI, Updated by CMI, Not known by CMI,
:and Created by CMI
e Loaded by CMI
The item is from Teamcenter and already was in the catalog at load time.
o Updated by CMI
The item is from Teamcenter but the type was changed.
e Not Known by CMI
The item is not from Teamcenter.
o Created by CMI

: After pressing the Synchronize icon CMI will check all entries and if there are
\?' unknown entries, the user must confirm, that he will continue.
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™I x|

i Ak lzast one catalog endchapter is not compatible with CML
Do wou want ko continue with the Sync operation?

Figure 56: Confirmation dialog for unknown entries in the synchronize catalog
command

A : This indicates that there is an item referenced in the catalog, that is not managed by :

Y “ Teamcenter.

8) Next the catalog is registered or updated in Teamcenter.
i Figure 57 is shown when the Synchronize command ends successfully.

CMI - Synchronize Catalog e
Catalog Filenarme: atalog Marme:
ExampleCatalog. catalog |ExampleCatang.catang
Marne I Type I Status
20080208 _Madell Qpen Updated by CMI
20080207 _Madell Cpen as copy Loaded by ML
20080225 _Madell Cpen Mok known by CMI
LUDF_f Instantiate Created by CMI
Edit selected .., i Synchronize i
Operation succeeded in Teamcenter, o

Close I

Figure 57: Synchronize Catalog with success
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I
Support of CATIA V5 Released Cache

CMI supports the use of cgr files in the released cache of CATIA V5. For this purpose the
cgr files of CATIA models are stored in Teamcenter. During To CATIA these cgr files are
copied to the released cache instead of the CATIA models to the exchange map. In
CATIA V5 the cgr files are loaded in visualization mode.

i@') Use Edit>Options to set the CMI RIl preferences.

=

Set “Transfer CGR-File to CATIA V5" to “Only CGR” or “CGR + geometry”

Use Tools->Options to set the preferences in CATIA V5.
Set “Work with the Cache System” to “On” and set the path to the released cache.

“Check timestamps” must be “On”.

T Options Cache Management | CorManagement | ENOVIAvpm | Modes Customization | ProductStructure |Pr [ »
7= B General Cache Activation
I 8 Display S Work with the cache system
o
EE Compatiiity Cache Location
[2# Paramekers an Measure Fefto thelocal2ne oy ocments and Setings Augalocal 7] |15
L7 Devices and virtual Realty P e e e [R—— E
Il irfrastructure
|- 51 Product Structure
Configure...
-8 material Library
Cache Si
I G Catalag Editor o
5 Check Maximum size
I phota Studio Maximum size G M8
2% Real Time Rendering
|- & part Infrastructure Tt
T Check timestamps
=" DELMIA Infrastructure
) [ GMT timestamp format
%30 Annatations Infrastiucture
L B Collaboration Infrastructure
Mechanical Design
Shaps
Analysis & Simulation
AEC Plant
Machining
-4 igital Mackup
@ ok | @cancel
- 9 o | S

Figure 58: Tools> Options dialog in CATIA

A These are the necessary preconditions to copy a CGR-file:
Q : e  Work with the cache system in CATIA V5 is enabled.
: e The released cache is set and exists. :
e The CATIA V5 configuration-variable CMI_USERELEASEDCACHE is set to :
“ON". 1
e The CMI RII preference “Transfer CGR-File to CATIA V5" is set to “Only
CGR” or “CGR + geometry”.

If the CATIA V5 configuration variable CMT SAVEADDITIONALCGR=ON is set, CMI
‘?' RII stores a cgr file in Teamcenter whenever a CATPart is created/updated.

Optional commands

In the following section, optional commands are described which must be enabled by the
administrator.
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Update Position

a
“E
!~ Toenable this function the administrator has to set the CATIA V5 environment
Q :CMI_ENABLE CMIUPDATEPOSITIONCMD=ON.
: This function updates only the transformation matrices in Teamcenter. The
: CATProduct and CATPart files are not updated. :
Update Parts
B
- To get this function the administrator has to set the CATIA V5 environment f
Q :CMI_ENABLE CMIUPDATEPARTCMD=ON. '
“This , function updates all modified CATPart files in Teamcenter. Transformations and
- CATProduct files are not updated.
Restore Positions
&
!~ Toenable this function the administrator has to set the CATIA V5 environment
Q :CMI_RESTORE_ POSITION=ON.
: This function restores the positions to their original state loaded from Teamcenter.
Choose Update Position
L LA

: To get this function the administrator has to set the CATIA V5 environment
{CMI ENABLE UPDATEPOSITIONDIALOG=ON.

‘ This function is available for normal “Update” and the “Update Position” command

Choose Update Dptions

2=

Model Update Matrix Update |

Part Number Parent Instance Mame

0015?9 . ooorsz
es o01s79 Screw.d ooo7Ez
Yes 000790 Connectionf.odModel. 1 001593
Toggle update state I
@ oK I W Cancel I
[~ -

Figure 59: Choose Matrix To Update dialog

_ If you have changed some positions in the CATIA session this function allows you
\?' to select the matrices to be updated. If you select a line in the dialog the

corresponding instance will be highlighted in the CATIA structure tree
e Yes - Matrix will be updated in Teamcenter
No -> Matrix will stay unchanged in Teamcenter
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To change the state you can double click a line or select the line and press the
Toggle keep state button.

A - To get this function the administrator has to set the CATIA V5 environment
:CMI_ENABLE UPD MODELSELECT DIALOG=ON.
- This function is available for normal Update and the Update Parts command.

Choose Update Options = 2 x|
Model Update | Matrix Update
Update | Fart Mumber | File Mame |
‘es 000776 000776, CATPark
001575, CATPark
‘es 001577 001577 . CATPark
‘es 001583 001583, CATPark
Yes 001585 001585, CATPark
Yes 001559 001559, CATPark
‘es 001593 001993, CATPark
Yes 001595 001595, CATPark
es 001597 001597, CATPark
es oo1s99 001599, CATPark
Toggle update state I
@ oK I ' Cancel I
-

Figure 60: Choose Model To Update dialog

If you have changed some geometries in the CATIA session this function allows you
‘?' to select the models to be updated.
e Yes - Model will be updated in Teamcenter
e No - Model will stay unchanged in Teamcenter
To change the state you can double click a line or select the line and press the
Toggle keep state button.
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Glossary

Administrator
Person, who configures the system, inserts users, manages user permissions and
maintains the database.

Browser
Window that displays icons representing objects.

Checkin
Action that takes from the users the right to update a work item.

Check Out
Action that gives the user the exclusive right to update a work item. Checking out an item
creates a copy of the work item in the specified work location.

Configuration Context
An attribute that determines which Item Revision should be displayed (for example, only
the last revisions).

Dialog Window
Window in which the user enters information.

Field
Component of a dialog window in which the user can enter text.

Generic Workbench
Set of components such as windows, dynamic items and information items, used in
Teamcenter integration products.

Icon
Graphical representation of an object.

List View
Style of browser window in which objects are viewed as small icons in a list with attribute
values in columns.

Object
An item or relationship.

Palette

Any group of CATIA functions created for specific requirements.
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Plot File

Pop-Up Menu

Register

Tree View

Vault

File in a specified format that can be plotted or opened in a viewing tool and represents a
2D view of a model.

The menu that appears when the user points an icon and holds the right mouse button
pressed.

To search the database for objects that match specific criteria.

To make a file or directory known as an object maintained in the Teamcenter database.

Style of browser window in which objects are displayed as relationships in horizontal
branches.

Secure place for storing information. To access the data confined in a vault it is necessary
to check out or revise the data.
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