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SHIPCONSTRUCTOR LICENSE AGREEMENT

BEFORE PROCEEDING WITH THE INSTALLATION, YOU MUST ACCEPT THE TERMS OF 
THIS AGREEMENT. INDICATE YOUR ACCEPTANCE OR REJECTION OF THIS 
AGREEMENT BY CLICKING ON THE APPROPRIATE BUTTON. IF YOU CLICK ON 
“REJECT,” INSTALLATION WILL ABORT.

1. License Grant.  ShipConstructor Software Inc., #304 – 3960 Quadra Street, 
Victoria, B.C. Canada, V8X 4A3 (DBA SSI) grants to the person accepting this 
Agreement (the “Licensee”) a non-exclusive, non-transferable right to use (the 
“License”) in object code form those program modules, application programming 
interface (“API”), any other materials provided by SSI under this Agreement, and all 
upgrades, revisions, fixes, updates or enhancements to any of the foregoing 
(“Licensed Materials”) specified in the Licensee’s purchase order or request 
(“Invoice”) solely on the software and hardware listed in the Licensed Materials 
manual (“System Configuration”).  

2. Academic Institutions/Trial Versions.

A. In the event that the Licensee qualifies as an academic institution user in 
accordance with SSI’s specifications (an “Academic Licensee”), the Academic 
Licensee and its faculty, employees and students may use the Licensed Materials 
for the singular purpose of either teaching, training users or undertaking 
research provided that the Licensed Materials, and all copies of the Licensed 
Materials, remain at all times at the Academic Licensee’s premises and the 
Licensed Materials are used for no other purpose than that set forth above. The 
above restrictions are in addition to the restrictions on use set out in Section 5 
below.

B. In the event that the Licensee receives a trial version of the Licensed Materials 
for evaluation purposes, the terms and conditions of this Agreement, excluding 
Sections 15-19, shall continue to apply subject to the following provisions:

(a)    the License pursuant to Section 1 above shall terminate at the end of 
the specified trial period;

(b)    the Licensee shall return the Hardware Key to SSI immediately upon 
expiry of the specified trial period and in any event within 28 days of 
the expiry of the specified trial period;

(c)    in the event that the Licensee does not return the Hardware Key in 
accordance with Section 2B.(b) above, SSI shall be entitled to invoice 
the Licensee for and the Licensee shall pay for the costs of the 
Hardware Key plus all shipping and handling expenses and SSI 
administrative charges; and
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(d)    in the event that the Licensee elects to and does acquire a License, the 
terms and conditions of this Agreement, excluding Section 2B herein, 
shall continue on and apply.

3. Ownership.  All rights, title and interests in and to the Licensed Materials and related 
documentation shall remain the sole property of SSI.  Licensee shall not remove or 
alter any proprietary rights notices on the Licensed Materials and the 
documentation, and shall reproduce such notices on any copies that it makes.  
Licensee shall be liable for the security of the Licensed Materials and the 
documentation in its possession.

4. Expertise Required.  Licensee is responsible for evaluating whether the Licensed 
Materials meets Licensee’s requirements, and for operating the Licensed Materials 
and the results obtained.  The Licensed Materials are intended for ship modeling and 
construction purposes only, and must be used by a person who has expertise and 
knowledge in this field. The Licensed Materials requires independent confirmation of 
the reliability and accuracy of all designs, drawings and other Licensed Materials 
output. An SSI representative may be made available under a separate consulting 
agreement, at the Licensee’s request to provide training and consultation on the 
operation or integration of licensed materials.

5. Limitations on Use.  

Licensee shall:

(a)    not make more copies of the Licensed Materials than are necessary for the 
Licensee’s installation of the Licensed Materials and shall only create 
backup copies for archival or emergency restart purposes;

(b)    maintain a log of the number of and location of all originals and copies of 
the Licensed Materials;

(c)    include SSI’s copyright, trademark and proprietary notices on any 
complete or partial copies of the Licensed Materials in the same form and 
location as the notice on any original work;

(d)    not attempt to defeat any copy protection;

(e)    not modify, any documentation, including any user manuals;

(f)    not modify, translate, reverse engineer, decompile or disassemble the 
Licensed Materials;

(g)    not sublicense, transfer, assign, sell, loan, rent or lease the Licensed 
Materials other than as permitted in this Agreement;

(h)    use the Licensed Materials for its own internal use only;

(i)    not permit any third party to use the Licensed Materials; and



#363338
2013-07

(j)    thoroughly test any and all custom interfaces in accordance with general 
engineering principles.

6. Delivery and Installation.  All Licensed Materials will be delivered in an electronic 
format by media or method as SSI may elect and will be sent to the Licensee’s 
designated email address or shipping address as specified in the Invoice.  Licensee 
agrees to be responsible for installation of the Licensed Materials.

7. Term of License.  The License term commences on the delivery of the Licensed 
Materials to the Licensee, and, subject to Section 2B above, is either perpetual if so 
requested on the Order, or on a month to month rental or lease basis. If Licensee 
chooses a lease option the license converts to a perpetual term on Licensee’s 
payment of the balance of the perpetual License fee (prior monthly payments 
receiving 80% credit).  All Licenses are subject to termination in accordance with 
this Agreement.

8. System Configuration.  Operation of the Licensed Materials requires use of the 
specified System Configuration, which Licensee shall acquire and implement.  SSI 
shall not be responsible for any operational problems caused by the System 
Configuration.

9. Security.  The Licensed Materials includes security elements which support the 
detection of unauthorized use or copying of the software and which may (a)report 
such unauthorized use or copying to the Licensee, and (b)if applicable based on 
Licensee’s configuration, may report back specific user information such as User 
name and email address.

10.Hardware Keys.  Licensed Materials use requires “Hardware Keys” supplied by SSI, 
which can be used only at the site(s) authorized by SSI.  In the event of a failure of 
the Licensee’s System Configuration, the Licensee may upon advising SSI use the 
Hardware Keys and Licensed Materials on another system and/or location.

11.License Fees.  Licensee shall pay to SSI the License fees applicable for the Licensed 
Materials as set out in and in accordance with SSI’s Invoice.  

12.Services.  Support services after the Warranty Period (as defined in Section 15 
below) are provided by SSI under the terms of the SSI Subscription Agreement.  
Installation, consulting, training and implementation services, if requested by the 
Licensee, shall be provided by separate agreement and at an additional charge.



#363338
2013-07

13.Taxes.  All amounts payable by Licensee to SSI are exclusive of all commodity taxes, 
including but not limited to applicable sales, use, value added, custom duties, excise 
taxes and other similar government charges, all of which will be paid by Licensee.  If 
Licensee is required by law to withhold any taxes, then Licensee shall pay SSI a 
gross amount of money such that the net amount received by SSI after deducting or 
withholding the required taxes is equal to the amount of the fee originally charged 
by SSI.

14.Interest Charges.  If any amount payable under this Agreement is not paid within 30 
days of becoming due, SSI shall have the right to impose a charge of 2% per month 
(24% annually) on the unpaid balance of the amount, from the due date until the 
date of receipt of all amounts in arrears including interest.

15.Purchase Orders.  Any purchase order (an “Order”) delivered by Licensee shall at 
all times be deemed to incorporate this Agreement by reference and shall be subject 
to the applicable provisions of this Agreement.  Any provisions of an Order shall not 
apply and shall not be binding upon SSI unless they relate to information which was 
requested by SSI.  In the event of a conflict or an inconsistency between the 
provisions of an Order and the terms and conditions of this Agreement, this 
Agreement shall govern and supersede to the extent of such conflict or 
inconsistency.

16.Limited Warranty.  SSI warrants that during a period of 90 days from the date of 
delivery of the Licensed Materials to Licensee (the “Warranty Period”), the 
Licensed Materials will perform substantially in accordance with the Licensed 
Materials documentation specifications, when used in accordance with this 
Agreement on a properly operating System Configuration.  SSI’s sole obligation 
under this Warranty, and Licensee’s exclusive remedy, shall be to use reasonable 
commercial efforts to correct Errors (a bug, defect or other problem incurred by a 
user in operating the Software that prevents the Software from performing in a 
manner consistent with the applicable specifications set out in the User Manual) that 
the Licensee identifies to SSI through fixes or workarounds free of charge.  If SSI 
determines that it is unable to make the Licensed Materials perform substantially as 
warranted, Licensee may terminate the License and receive a refund of a portion of the 
License Fees paid to date.

17.WARRANTY EXCLUSIONS.  THE LIMITED WARRANTY CONTAINED IN SECTION 15 IS 
IN LIEU OF ALL OTHER WARRANTIES, EXPRESS OR IMPLIED.  ALL OTHER 
CONDITIONS, WARRANTIES, AND REPRESENTATIONS, EITHER EXPRESS OR 
IMPLIED, ARE EXCLUDED, INCLUDING BUT NOT LIMITED TO CONDITIONS, 
REPRESENTATIONS AND WARRANTIES RELATING TO MERCHANTABILITY AND 
FITNESS FOR A PARTICULAR PURPOSE.  SSI DOES NOT WARRANT THAT THE 
LICENSED MATERIALS ARE COMPLETELY ERROR FREE OR THAT ITS OPERATION WILL 
BE CONTINUOUS AND UNINTERRUPTED. 
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18.Maintenance Services.  Licensee may elect, to obtain maintenance, support and 
upgrade services from SSI in accordance with and subject to the terms of SSI’s 
standard Subscription Agreement.

19.Loss of Data.  SSI shall not be responsible for any loss of or damage to files or data 
caused by the Licensed Materials, or be required to restore or rebuild files or data.  
Licensee shall implementing adequate backup procedures to avoid any loss of files 
and data.

20.Modifications. SSI may, from time to time, provide the Licensee with revisions to 
the Licensed Materials (the “Revised Licensed Materials”).  The Licensee shall test 
any external applications using the revised API before implementing the new 
version. While it is SSI’s intention that the Revised Licensed Materials shall be 
backward-compatible with the immediately prior version of the Licensed Materials, 
SSI does not guarantee or warrant that this shall be so, and SSI shall have no 
liability whatsoever to the Licensee for any failure of the Revised Licensed Materials 
to be backward compatible with any prior version of the Licensed Materials.  
Modifications requested by the Licensee shall be subject to prior written agreement 
as to scope and fees payable.  Ownership of all Licensed Materials modifications 
shall vest in SSI.  SSI does not warrant, guarantee or otherwise commit to 
supporting Licensed Materials that has been superseded by Revised Licensed 
Materials.

21.Confidential Information.  Each party will not use the confidential information of the 
other party for any purpose except for the purpose described in this Agreement, and 
shall not disclose it to any other person except on a confidential basis to its 
employees and representatives who have a need-to-know the confidential 
information for such purposes.  This Section 23 shall not apply to confidential 
information which (a) is or has become readily available to the public in the same 
form other than by an act or omission of the receiving party, (b) was lawfully 
obtained in the same form by the receiving party from a third party not under an 
obligation of confidence to the disclosing party, (c) was in the receiving party’s 
possession in the same and material form prior to its receipt from the disclosing 
party and did not otherwise originate from the disclosing party, or (d) is required to 
be disclosed by operation of law.
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22. Audit Rights. Upon reasonable notice by SSI, which shall be delivered on no more 
than an (annual?) basis, Licensee shall provide a signed statement verifying its 
compliance with the terms of this Agreement. SSI shall also have the right, upon 
reasonable notice and no more than on an annual basis, to inspect Licensee’s 
facilities to verify Licensee’s compliance with such terms. Any such inspection or 
audit shall be conducted either by SSI or by representatives authorized by SSI to 
complete the inspection. If such inspections or audits disclose that the Licensee has 
installed, accessed or permitted access to the Licensed Materials in a manner that is 
not permitted under this Agreement, then Licensee shall be liable to pay for any 
unpaid license fees as well as the reasonable costs of the audit.

23.Termination.  This Agreement may be terminated by either party, immediately by 
written notice, if the other party commits a breach of any material provision of this 
Agreement, including a failure to make payment when due, and fails to correct or 
rectify such breach within 30 days of receipt of the notice requesting it to do so.  
SSI shall be entitled to place time-lock devices and other disabling features in the 
Licensed Materials that become effective in the event that the Licensee has failed to 
comply with its payment obligations hereunder and as set out in SSI Invoices.

24.Effect of Termination.  Upon termination of this Agreement Licensee shall 
immediately cease using the Licensed Materials, and within 14 days of termination 
return all Hardware Keys to SSI.

25.CONSEQUENTIAL DAMAGES.  IN NO EVENT SHALL SSI BE LIABLE FOR ANY LOSS 
OF DATA OR PROFITS, ECONOMIC LOSS OR SPECIAL, INDIRECT, INCIDENTAL, 
CONSEQUENTIAL OR PUNITIVE DAMAGES WITH RESPECT TO THIS AGREEMENT 
OR THE LICENSED MATERIALS, HOWEVER CAUSED, EVEN IF SSI HAD OR SHOULD 
HAVE HAD ANY KNOWLEDGE OF THE POSSIBILITY OF SUCH DAMAGES.

26.DAMAGES LIMITATION.  THE MAXIMUM LIABILITY OF SSI FOR ALL CLAIMS AND 
DAMAGES OF ANY KIND, WHETHER FOR FUNDAMENTAL BREACH OR ANY OTHER 
CAUSE UNDER THIS AGREEMENT, SHALL BE LIMITED IN THE AGGREGATE TO THE 
TOTAL OF ALL FEES PAID BY LICENSEE.

27.LIMITATION OF NON-APPLICABILITY.  IN SOME JURISDICTIONS THE EXCLUSION 
OR LIMITATION OF WARRANTIES OR LIABILITY MAY NOT BE APPLICABLE, AND IN 
SUCH JURISDICTIONS SSI HEREBY LIMITS ITS LIABILITY TO THE FULLEST EXTENT 
PERMITTED BY LAW.
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28.Applicable Law.  This Agreement shall be subject to and construed in accordance 
with the laws of the Province of British Columbia, Canada, excluding its conflict of 
laws rules and the application of the UN Convention on Contracts for the 
International Sale of Goods.

29.References.  SSI shall be allowed to incorporate Licensee’s name in SSI’s customer 
reference list and to use it for marketing.

30.Dispute.  If any dispute arises under this Agreement, a good faith attempt to resolve 
the dispute will be made by senior management of both parties at a mutually 
agreeable site and time.  If the parties are unable to reach agreement within 30 
days after a request for such meeting, the dispute shall be referred to arbitration in 
English, before one arbitrator in Victoria, British Columbia, Canada, in accordance 
with the Commercial Arbitration Act of the British Columbia. 

31.Entire Agreement.  This Agreement contains the entire agreement between the 
parties and shall supersede all prior discussions and agreements between the parties 
regarding its subject matter.

32.Amendment.  Any amendment of this Agreement must be in writing and signed by 
duly authorized representatives of the parties.

33.Waiver.  The waiver by any party of a breach by the other party of this Agreement 
shall not be construed as a waiver by such party of any succeeding breach by the 
other party of the same or another provision.

34.Assignments.  Licensee may not assign or transfer the License or Licensee’s rights or 
obligations under this Agreement without SSI’s prior written consent, and any such 
assignment or transfer without consent shall be null and void. A transfer of all or 
substantially all of the voting stock of the Licensee shall constitute a transfer for 
these purposes and shall be subject to SSI’s prior written consent.

35.Successors and Assigns.  This Agreement will bind and enure to the benefit of the 
parties and their respective successors and permitted assigns.

36.Severability.  In the event that any provision of this Agreement is declared invalid, 
illegal or unenforceable by a court having jurisdiction, then the remaining provisions 
shall continue in full force and effect.

37.Force Majeure.  Except as related to Licensee’s obligation to make payments to SSI, 
neither party shall be liable for delays or non-performance if such delays or non-
performance are beyond such party's reasonable control.  A delayed party shall 
promptly notify the other party in writing stating the cause of the delay and its 
expected duration and shall use commercially reasonable efforts to remedy a delay 
or non-performance as soon as reasonably possible.
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38.Survival.  The provisions of Sections 3, 5, 11, 13, 14, 17 and 20-30 shall survive the 
expiry or termination of this Agreement.

39.Language.  It is the express will of the parties that this Agreement and related 
documents have been prepared in English.  C’est la volonté expresse des parties que 
la présente Convention ainsi que les documents qui s’y rattachent soient rédiges en 
anglais.
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Introduction
NC-Pyros generates NC code from CAD DXF files for computer controlled burning tables with plasma arc cutting, gas 
cutting, laser cutting, and other manufacturing applications.

NC-Pyros is designed to run in Windows 7 (both 32- and 64-bit).

A new user can produce reliable NC code within the first ten minutes of using NC-Pyros. The program has features to 
catch user errors and automatically compensate for common CAD drawing deficiencies.

NC-Pyros offers the following main features:

• Converts DXF CAD drawings to reliable NC code for 2D tables.

• Many automatic error correction features to save time and money.

• Automatic and manual path generation.

• Automatic and manual data correction methods.

• Intuitive, easy-to-learn GUI.

NC-Pyros Features
NC-Pyros has the following main features:

• Reads DXF formatted files and converts these to NC code for burning machines.

• Automatically deletes all duplicate entities (that is, identical lines or arcs).

• Lets you set the lead-in and lead-out length independently. You can create NC code with no leads, lead-ins only, or 
lead-ins and lead-outs.

• Lets you set a snap tolerance. Snap tolerance is used to ensure that the path will continue even if small gaps exist 
between entities.

• Optimizes the complete path automatically from the DXF file, or you can manually determine the order of 
processing. The shapes on each layer are processed from the bottom-left corner to the upper-right corner.

• An automatic lead collision function detects collisions of leads with any other shapes.

• Lets you set the start of a shape at any position.

• Shapes can be tabbed so that they remain fixed to the plate.

• Circles or arcs that cross over the horizontal or vertical axis can be automatically processed in several arc 
instructions.

• Calibration marks can be inserted to detect slips in the machine or movement of the plate during the burning 
process.

• Lets you delete shapes or reverse the direction of cut on the shapes.

• Lets you edit leads to change the length or orientation.

• Text can be marked.

• You can inspect the path in detail by simulating the path step-by-step or at a variable speed. The generated NC code 
is shown as the path is simulated.

• The optimized path can be output to plotters and printers at any scale.

• NC-Pyros calculates the area of the processed parts, minus any holes.
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• You can produce text marking from regular text strings in the drawing.

• You can produce text marking using BUGE.

• You have full manual control over the order of processing.

• A backplot function is available to convert code back to geometry.

• Reference information handling and collision testing with plate edge and clamping.

• Single step simulation with generated code display.

• Automatic return-to-origin option.

• Data consistency check for incremental programming.

• Arc or linear lead-ins and lead-outs.

• Linear lead-ins and lead-outs tangential to the shape.

• Layer for cutting without kerf for common cuts or slots.

• Positioning of processed parts using margin to shift parts on a plate.

• Error detection file to show the location of errors that may require you to investigate further.

• Separating process entities by color.

• Code description for each NC code.

• Mark using rapid travel speed.

• Generate marking path only.

• Support for inserting dwells, program stops, or comments anywhere in the path.

• Support for spline-fitted polylines and ellipses.

What’s New
• Support for MG Global controller.

• Support for Matthews Inkjet controller.

• User setting for controller code folder so a multiuser environment can share the same controller files and you can 
limit the available controller files without removing the preset files.

• Additional options for inkjet text marking.

• Mark Order settings allow the ability to mark text before lines.

• Improved shape ordering option to reduce fast travel distance significantly.

• Multipass bevel support (maximum three passes).

• Variable bevel support(one pass).

Installation
See Install ShipConstructor in the Installation Guide.

Licensing
Licensing for NC-Pyros uses a lock. The lock is a small device that plugs into your computer’s USB port. The locks store 
specific information that the individual ShipConstructor software modules look up at different times. Your lock can be re-
programmed to enable new versions and additional software options.
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ShipConstructor Lock

Configurations

Standalone Computer
If you have a standalone system, all you need to do is attach the dongle to the USB port of your computer.

Network License Server

Note: This configuration requires a network lock.

On the Server Computer
See the Project Management manual for how to set up the network license server.

On the Client Computers

To configure NC-Pyros to connect to the network license server

1. Start NC-Pyros.

2. Run Help > Licensing. The Licensing window appears.
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3. Click License Servers… to bring up the Network License Settings. Change <Local Computer> to Server (where Server
is the name or IP address of your network license server computer). You can change the name in the list by double-
clicking the name.

If you have a configuration where you have both local and network licenses. Click New and add Server.
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<Local Computer> is actually IP address 127.0.0.1. Do not change the port setting unless instructed to. If you 
remove all computers from the list, <Local Computer> is added automatically.

4. Click OK to return to the Licensing window. 

5. Click Acquire to obtain a license

Technical Support
ShipConstructor Software Inc. offers all customers free technical support for the first 90 days after purchase. Additional 
support is available through our maintenance and support program. In some cases our staff will offer to investigate the 
problem with your data file. In this case, we advise that you compress the data file (for example with WinZip) and e-mail it 
to us. We will investigate the problem and forward a solution to you.

Office hours: 7:00 am – 5:00 pm Pacific Time

Toll-free: 1-888-210-7420

Phone: 1-250-479-3638

Fax: 1-250-479-0868

E-mail: support@ShipConstructor.com

Web: www.ShipConstructor.com

Tutorial
This chapter provides a number of hands-on examples to get you familiar with the procedures involved in some of the 
different kinds of NC code generation.

Operation Basics
You can use NC-Pyros as an integrated module with ShipConstructor or as a standalone program.

Integrated With ShipConstructor
In the integrated operation mode, NC-Pyros is linked to the ShipConstructor database of the project you will be working 
on. Many settings, such as directory location for the nested DXF files and colors to determine cutting operation, will be 

mailto:support@ShipConstructor.com
http://www.shipconstructor.com/
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configured by the ShipConstructor database file of that project. NC-Pyros updates the database with parameters 
calculated during the NC coding process. These include cutting length, the NC coding date, and the operator's name.

Standalone
Use this mode when converting DXF files to NC code that are not generated by the ShipConstructor nesting function. You 
will generally convert many nested DXF files to NC code during the time it takes to complete the project. You might be 
processing dozens of nests over a period of days or weeks. Some nests might be recalled because of last minute 
changes. Planning ahead can save you a lot of time and aggravation. Follow this procedure:

• Create a new folder for the project.

• Move all DXF nest files into the new directory.

• Open a DXF file and set up the preferences according to the requirements of the job. The preference settings will be 
saved in the current folder. The next time you work on any file in this folder, NC-Pyros will remember the settings that 
you last used.

• Produce one small NC code file and double check that it works on your machine.

• In general, there are two different procedures for processing the CAD drawing into reliable NC code:

• Fully automatic NC code optimization.

• Manual optimization of the NC code.

NC Code Generation Steps
The following steps are recommended for generating NC code:

• Open the DXF file.

• Optimize the path automatically or connect the entities into shapes and then connect the shapes manually.

• Check the path for lead collisions.

• Simulate the generated path.

• Save the NC code.

• Overlay the optimized cutting path in the DXF output file (DXO) over the original nest and verify the path.

Default Processing and Error Correction Overview
NC-Pyros performs a number of default processing checks when reading or optimizing a path.

When reading the DXF file, NC-Pyros performs the following procedures:

• All entities on unspecified layer names (or colors) are ignored.

• Text on the TEXT layer is converted to marking using the character definitions in the CHAR.DAT file (see Editable 
TEXT Character Set (page 50) in the Appendix).

• The entities are shifted appropriately if the nest positioning option is used.

• The entities found are written to temporary files.

When optimizing a complete path, the following procedures are performed:

• Duplicate entities are removed automatically.

• All elements within the set snap tolerance are connected to shapes. A closed shape is a shape that has the same 
start and end location. That is, it encloses an area completely in one direction (clockwise or counter clockwise). Two 
entities are considered to be connected if the end points are within the specified snap tolerance. Two entities are 
connected if the end points fall within a circle with a radius of the snap tolerance. One of the entities is then 
automatically corrected to close the gap.

• Entities below the Erase Elements < value are deleted.

• The angles between all elements are checked to detect errors if the path reverses on itself. (This is a common error if 
stray elements have been left behind in the CAD drawing.)
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• Lead-ins and lead-outs are automatically generated as specified and checked for the possibility that the leads 
intersect with the shape.

• All shapes are sorted to produce an optimized processing order.

• The fast travel connectors are generated automatically.

• The total length of each processing type (marking and cutting) is calculated.

• The total area of the processed parts is calculated.

• The processing is on a layer-by-layer basis when using Generation > Generate Complete Path. The order of 
processing is:

1. Entities on the MARKING, Bevel Mark and TEXT layer

2. Entities on the BUGE layer

3. Entities on the NOKERF layer

4. Entities on the INSET layer

5. Entities on the INSIDE layer

6. Entities on the OUTSIDE layer

• The entities are only connected to shapes. Leads are created as specified when using Generation > Generate Shapes
to generate shapes only. Use Manual Edit > Connect Shapes to connect all shapes in the desired order to a complete 
path.

Marking
Shapes on the MARKING, BEVEL MARK, TEXT, and BUGE layers are processed with the scribing unit. All other shapes are 
processed with the torch specified in the Preferences. 

Shapes on the MARKING layer have no specific direction. The rule is that scribing starts at the end of the marking shape 
that is closest to the X=0, Y=0 location. The next marking shape is processed from the end that is closest to the current 
scriber location.

Cutting
The shapes on all cutting layers are processed from the lower left to the upper right. Closed shapes on all cutting layers 
have a defined processing direction. Shapes on the INSET layer and shapes on the OUTSIDE layer are processed in a 
clockwise direction, while shapes on the INSIDE layer are processed in a counterclockwise direction. This results in the 
kerf always being to the left of the path. The direction of closed shapes is automatically determined by NC-Pyros and 
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corrected if required. Shapes on the NOKERF layer are processed without regard to direction and without leads. Open 
shapes should only exist on the MARK layer and in some instances on the OUTSIDE layer. Open shapes on the outside 
layer can be used to cut off an unused part of a partially used stock plate. 

Leads
Leads are automatically placed at the lower-left corner of each shape. Leads consist of a lead-in and a lead-out. The 
opening angle between the lead-in and the lead-out is 60 degrees for non-tangential leads. The lead-in and lead-out each 
form an angle of 30 degrees for non-tangential leads. The leads always point in the direction of the kerf.

Kerf offsets the torch to one side of the path line by half the width of the cut. The controller typically handles this 
offsetting. This ensures that the finished part will have the specified dimensions. For through holes, the kerf has to be on 
the inside of the hole; for outside shapes the kerf has to be on the outside of the shape.

Generating NC Code without Leads
In this example we will create and optimize a path for a short example nest of the file DEMOSHRT.DXF. During the 
operation you will learn about the main functions of NC-Pyros. We will open the file, automatically optimize the path, and
perform a simulation and open-shapes checking before we save the NC code.

To generate NC code without leads

1. Start NC-Pyros if it is not running by double-clicking the NC-Pyros icon or selecting it from the Start Menu.

2. Select File > Open DXF or click .

3. Browse for the NC-Pyros Demo project directory (default is C:\Program Files\ShipConstructor2009\NCDemo) and 
select the file DEMOSHRT.DXF. Since you have just started NC-Pyros, no preferences are loaded yet. The Load 
Settings window lets you select preferences to load.
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4. Select the preference file NCPYWIN.PRF and click OK. The preference file has been set up previously and contains 
some typical values.

5. The file is loaded and the geometry appears on the screen. A time bar at the bottom of the screen shows the 
progress of the loading operation. Also, the number of found entities on each layer is updated in the information 
window. Each entity on the screen has a direction arrow indicating its processing direction.

6. Select Generation > Generate Complete Path from the menu or click . During path generation, time bars indicate 
the progress of the operations. After completion, the entire path is displayed. The connectors between the shapes 
are drawn in light gray and the leads appear in cyan (greenish-blue). Notice that the number of entities listed in the 
information windows has been significantly reduced. Single entities have been connected to shapes. The number of 
shapes on each layer is now listed. The length of all processes and the area of the processed parts are also listed in 
the information window.

7. Select View > Simulate or click . The simulation window will appear at the bottom of the screen.

8. Click Go. Watch how the path is drawn part by part.

9. Move the Speed Slider to adjust the simulation speed.

10. Select OK when the window notifies you of the end of the simulation. You can now scroll up and down through the 
code window to view the generated code. 

11. Click the Cancel button when you are done.

12. Select File > Save NC Code or click . The file is written to disk with the same name as the DXF file but with the 
.CNC extension (DEMOSHRT.CNC).

Automatic Lead Collision Check
Using the same file, we will generate a path with long lead-ins and lead-outs to demonstrate how to fix lead collision 
problems.
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1. Select File > Preferences or click . Make sure the lead-in length and lead-out lengths for inside and outside lead 
types are set to 2.0. Click Save.

2. Select Generation > Generate Complete Path or click . A message appears asking if you want to continue and lose 
changes.

3. Click OK. All shapes now have very long leads indicated by green lines at the bottom left corner of each shape.

4. Select Check > Check Lead Collision or click . To check every possible case, each lead has to be checked for a 
collision with all other entities. For example, the program has to check approximately 600,000 potential collisions 
for a nest with 101 shapes and 30 entities per shape. Once a collision has been detected, the program automatically 
zooms into the specified area. The lead colliding with another entity is highlighted in yellow in the center of the 
screen.
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5. The first collision is detected with the plate edge. You can put clamping on the No Process layer to indicate areas 
where the collision is located. The screen shows a floating toolbar that lets you edit the lead to avoid the collision.

How to Edit the Lead
The figure below shows the floating toolbar with the buttons to edit the leads. Place the cursor over any of the buttons 
and wait a second to see plain text tool tips on the function of the button.

Setting the Start of Shapes
By default, NC-Pyros sets the start of each shape at the lower-left corner. Sometimes starting here is not appropriate for 
your shape. The lower inside cut on the large right shape has a very sharp corner at the lower left and the leads are not in 
good position there.
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1. Select View > Zoom, click or using the mouse wheel to zoom into the shape as shown in the figure.

2. Select Manual Edit > Set Start of Shape.

Hold down the Shift key and click near the middle of the vertical line on the left of this shape. Watch how the leads 
are now generated at the new position and automatically connected with fast travel. If you did not hold down the 
shift key, the start point would be located at the start of the element you selected.
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If you do not hold down the Shift key then the start of shape will be placed at the nearest segment end.

3. Select Manual Edit > Set Start of Shape to switch this function off. Most functions on the Manual Edit menu remain 
on until selected again or you press the Escape key. A check mark to the left of the menu item indicates that a 
function is active.

Tabbing Shapes
Tabbing keeps the parts in the nested plate. This is important if you want to ship the processed nest from one place to 
another.

To tab some of the outside parts

1. To prepare for this function select File > Preferences.

2. Switch to the Processing tab.

3. For this example, set the Tab Length value to 3.0 to create large, clearly visible tabs.
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To insert tabs into some of the shapes

1. Select Manual Edit > Insert Tabs. This switches the Insert Tab function on until Manual Edit > Insert Tabs is selected 
again. See the lower right window for the state of the function.

2. Click on some of the outside cuts and watch how tabs are inserted. Leads are generated automatically and the 
shapes are connected by fast travel. The leads are generated at 90° angles. You can undo the last tab you inserted 
by clicking the undo button.

3. Select Manual Edit > Insert Tabs to switch this function off. Most functions on the Manual Edit menu remain on until 
selected again or you press the Escape key. A check mark to the left of the menu item indicates that a function is 
active.

Reversing Shapes
Note: This procedure should only be used when you have open shapes or for marking when there is no kerf used. In 
the case of open shapes, NC-Pyros cannot detect the proper direction of processing.

1. Select Manual Edit > Reverse Shapes. Pick any shape on the marking layer (white color) and see the arrows 
indicating the cutting or marking direction and the connectors change. 

2. Select Manual Edit > Reverse Shapes again to turn this function off.

Placing Calibration Marks
Calibration marks are a very important quality assurance tool. The operator can immediately detect problems by 
checking the calibration marks after or during the processing. This feature saves times and money by preventing parts 
that do not fit during assembly.
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1. Select Calibration > At Layer Changes or click .

2. Click anywhere in the display window and watch how the program places the calibration marks and automatically 
connects them to fast travel.

3. Select Calibration > Move Calibrations then click on or near the calibrations.

4. Move the mouse until you have reached a suitable position. Then press the left mouse button to place the 
calibrations there.

Demo 1 -- Snap Tolerance Problems
1. Select File > Open DXF and open the file DEMO1.DXF.

2. Select File > Preferences, click the Input Filter tab, and set the Snap Tolerance to 0.0.

3. Select Generation > Generate Complete Path or click . The area calculation function will display a warning 
message that there is an open shape that the area could not be calculated for.

4. Select View > Simulate. A new window appears at the bottom of the screen. 

5. Click Go and watch closely to see how the path is drawn. Many shapes are not closed and the fast travel connectors 
are all over the place. Obviously, many of the entities belonging to the same shape have small gaps between them, 
even though they were drawn using object snap end on in AutoCAD.

6. Select OK when the window notifies you of the end of the simulation. Click Cancel when you are done.

We will correct this problem now by setting a sensible Snap Tolerance. Minute errors in the drawing can be tolerated. 
Quite often the error is really only a floating point rounding or a drafting error too small to see.

7. Select File > Preferences and click the Input Filter. Set the Snap Tolerance to 0.1.
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8. Select Generation > Generate Complete Path to optimize the path again.

9. Select View > Simulate again.

10. Click Go and watch closely how the path is drawn. Now NC-Pyros connects all elements to the intended shapes and 
there are no open shapes.

11. Click OK when the window notifies you of the end of the simulation. Click Cancel when you are done.

Demo 2 -- Nest Positioning and Open Shapes
Often it is more economical to have several nests on the same drawing. You can keep all nests for one construction block 
in one drawing or keep nests of the same plate thickness on the same drawing. The result is that the parts on the nest 
are not in the appropriate location. You can customize NC-Pyros to move the nest into the desired position. In this 
example we will first load the file without re-positioning it, and then we will position the nest as desired.

1. Select File > Preferences.

2. Select the Input Filter tab. Make sure Nest Positioning is set to None.
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3. Select File > Open DXF and open the file DEMO2.DXF. Note the minimum values for the geometry are negative.

4. Select File > Preferences.

5. Select the Input Filter tab and set the Nest Positioning to Processing layers with Offset X set to 6.0 and Offset Y set 
to 6.0. This will shift all the geometry so that the minimum X and Y values are 6.0. Click Save.

6. Select File > Open DXF and open the file DEMO2.DXF. Note the minimum values in the status bar at the bottom of 
the screen for the geometry are both 6.0 inches now.
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Open shapes are indications that the result will not be the desired one. Open shape errors are caused by forgotten
elements or elements placed on the wrong layer. The next demo shows an error from an element hidden from view. It is a 
straight line that is hidden behind a longer straight line.

1. Select the Input Filter tab and set the Snap Tolerance to 0.1.

2. Select File > Open DXF and open the file DEMO2.DXF again.

3. Select Generation > Generate Complete Path to optimize the path. The Area Calculation function will display a 
warning message stating that there is an open shape that the area could not be calculated for.

4. Select Check > Check Open Shapes. An open shape is reported. This nest has a very common error. It has a short 
line segment that hides behind a longer line. The program automatically scans the path for open shapes and zooms 
into the area of the open shape. The open shape is highlighted in yellow.

5. Obviously this line was generated by mistake in the CAD program. Click Yes to delete the shape. The path is 
automatically updated.

Tip: You should always Check Open Shapes before saving an NC code file.

Demo 3 -- Lead Collisions
Lead collisions can ruin parts and therefore must be detected before cutting the plate. Material, time, and money will be 
wasted if the collisions go undetected. NC-Pyros can detect collisions between the leads and shapes.

1. Select File > Open DXF and open the file DEMO3.DXF.

2. Select File > Preferences, click the Input Filter tab, and set the Snap Tolerance to 0.2. On the Leads tab, set both 
Lead Lengths to 0.6.

3. Select Generation > Generate Complete Path to optimize the path.



Tutorial

19

4. Select Check > Check Lead Collision to check lead collisions. Whenever NC-Pyros finds a lead collision, the program 
zooms into the drawing. The center of the screen displays a lead in yellow, indicating the collision with the element 
of the shape next to it. You can now change the leads using the Lead Edit toolbar.

Tip: You should always Check Lead Collision before saving an NC code file.

Demo 4 -- A Complex Nest
Demo 4 is a complex nest with a lot of marking information. It demonstrates the complexity of nests that NC-Pyros can 
handle. This nest has one of the common errors described in the previous demos. During editing in the CAD program, a 
portion of one shape was duplicated and left behind. This is why it is invisible to the user in the CAD drawing.
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1. Select File > Open DXF and select the file DEMO4.DXF.

2. Select Generation > Generate Complete Path. The path is optimized. The connecting and sorting of the marking 
information may take a long time. There are over 1,500 entities on this layer alone. 

Linking with ShipConstructor Projects

Preparing ShipConstructor for NC Processing
NC-Pyros can be run in a mode that will link it to a ShipConstructor project. In this mode NC-Pyros will update the cut 
length, mark length, and fast travel length for all nests as they are processed. NC-Pyros will also assign the nest to the NC 
Machine used to generate code. The update occurs when the NC code file is saved. The following example requires the 
full ShipConstructor suite to be installed.

1. Open a DXF file the in the <project folder>\Nests\NC where <project folder> is the ShipConstructor project folder.
The Load Settings window appears.

2. If you have a preference file already there then select it and click Edit. Otherwise click New. This will open the 
Preferences window.

3. Select the Preferences > ShipConstructor tab.

4. Click Use Database.

5. The ShipConstructor Register Project window appears for you to log in to the database. 
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6. You may see a message.

7. Click Yes to ensure the color settings in the Layer tab match the settings in ShipConstructor.

8. Click Save to save the preference file.

9. The nest is loaded and shown on the screen.

10. Start ShipConstructor.

11. Login to the same project.

12. Start Manager.

13. Select Structure > Stock Catalog.

14. Click on the Plate icon in the left tree pane.

15. The right pane displays all plate stock and several settings for each stock. Each stock has separate settings for NC 
machine specific properties, such as CutFeed, Bridge Width, Pierce Time, and more. In this example, all plate stocks 
will be cut on the same NC machine called BURNY5.

To create new NC machines or modify existing ones

1. Select Structure > Plates > NC Machines. We will create a new machine called ESAB.

2. Click New.

3. Enter data as shown for the ESAB machine. Click Close.
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4. In the stock library window (if it is not on your screen, open the window again by selecting Structure > Stock Catalog
then select Plates) select the PL12 stock and click (…) button in the <Edit> cell under NC Machine.

5. Enable the new ESAB machine for this stock. Enter the values as shown. Click OK.

6. Now use NC-Pyros to process any PL12 plate. NC-Pyros will estimate the processing time using the new values for 
the ESAB machine.

After processing a nest with NC-Pyros, you should open the nest drawing and update the nest with the data now 
added by NC-Pyros. This will update the keywords for many variables:

• Cut Feed Rate

• Cutting Length

• Fast Travel Rate

• Fast Travel Length

• Machine Name

• Mark Feed Rate

• Mark Travel Length

• NC Process Date

• NC Process Operator

Backplotting an NC Code File
NC-Pyros can load NC code files and save them as DXF output files. NC-Pyros places all cutting geometry on the OUTSIDE
layer, all marking on the MARK layer, and fast travel connection on the NCPYROSCONNECT layer. NC-Pyros will compare 
the NC code of the post-processor selected in Preferences to the NC code in the CNC file. 

To backplot an NC code file

1. Select the correct post-processor in the Preferences. This has to be the same post-processor that the NC code file 
was generated with, or one that simulates the same code that is present in the file that you want to backplot.

2. If no unit type (millimeters or inches) is specified in the NC code file, make sure the Units are set correctly in the 
Preferences.
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3. If no code format (incremental or absolute) is specified in the NC code file, make sure the Code Format is set 
correctly in the Preferences.

4. Select File > Backplot NC-Code and select the NC code file. You can then save the geometry as a DXF output file 
(DXO).

This concludes the tutorial.

Operation Procedures

How NC-Pyros Organizes CAD Geometry
Entities are the lowest level of geometric information.

If you use CAD blocks to group your drawing data, explode them just before you write the DXF file and then use the undo
command to restore the grouped state.

Leads are short straight lines at the start and end of a shape. They are used to avoid piercing directly on the edge of a 
part. NC-Pyros places leads automatically at the appropriate location of a shape. The cutting cycle starts at the beginning 
of the lead-in and terminates at the end of the lead-out, ensuring that a “dirty” cut does not ruin the edges of the shapes.

Connectors are straight lines that connect the shapes with each other. Between cutting and marking, the burner head 
travels along connectors at high speed (fast travel). Connectors can be automatically created by NC-Pyros, or you can 
create them manually by picking the parts in the order that you need.

Shapes consist of a number of connected entities. Shapes can be closed (the end of the last entity connects with the start 
of the first entity) or open. Closed shapes can be checked for direction of travel (clockwise or counterclockwise). Open 
shapes cannot be checked for direction. It is the operator’s responsibility to check the direction manually and reverse it if 
necessary. (See Kerf below)

Layers are logical levels in a CAD drawing. Layers contain entities. NC-Pyros assigns a meaning to each layer. The 
following default layer names are recognized by NC-Pyros. You can change the default layer names to suit your needs.

• MARK shapes are marked on the plate with a scribing unit.

• INSET shapes are OUTSIDE shapes cut from the waste inside through holes.

• INSIDE shapes are cut with the kerf towards the inside of the path. This layer is used for through holes.

• OUTSIDE shapes are cut with the kerf set towards the outside of the closed shapes.

• TEXT layer strings are marked on the plate with a scribing unit. TEXT is automatically converted to lines using an
internal character generator.

• BUGE layer allows a machine to use its optional BUGE character generator or inkjet printer to automatically create 
the character marking.

• REFERENCE layer shapes are used to show plate edges, clamping information or text showing nest names. No 
processing occurs for reference shapes. However, lead collision checks are performed.

• NOKERF layer shapes are cut without any kerf.

• BEVELMARK bevel strings are marked on the plate with a scribing unit. BEVELMARK text objects are automatically 
converted to lines using an internal character generator.

• BEVELANGLE layer gathers variable and constant bevel angle text objects. The XDATA on the text objects determines 
the bevel cutting angles.

• BEVELSTANDARD layer gathers standard bevel angle text objects used to define bevel angles from standards. 

• REMNANTCUTLINE layer gathers lines used to define the nest’s remnant cutlines.

Objects on other layers are not recognized.
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Nest Preparation within a CAD Program

General Information
NC-Pyros converts DXF files to NC instructions for 2D computer controlled cutting machines such as plasma arc, gas 
burning, laser cutting, wood router, and others. You can use any CAD program that can export the drawing in DXF format 
that supports layers. The CAD drawing has to meet certain specifications to be able to be processed. The operations 
described here are specific for using NC-Pyros together with AutoCAD but are essentially the same for any other CAD 
program that can export DXF files. 

1. Prepare the CAD drawings for all parts.

2. Nest the parts in a single drawing. This can often be done manually using the CAD program or by a third-party 
nesting program.

3. Explode all blocks that you have in your drawings.

4. Export the drawing as a DXF file.

5. Use NC-Pyros to convert the DXF drawing to NC code.

Drawing Entities
NC-Pyros supports the following drawing entities:

• lines

• polylines (consisting of straight lines and arcs)

• lightweight polylines

• arcs

• circles

• ellipses and elliptical arcs

• text and Mtext

• splines

Complex entities that are not made from straight lines or arcs are converted by NC-Pyros to lines.

Entities do not have to meet exactly at their end points. NC-Pyros processes a user-defined Snap Tolerance to close the 
gaps. However, it is advisable to use OSNAP End when drawing entities in AutoCAD to ensure that there are no gaps 
between the elements of a drawing. 

Layers
Each entity has to conform to the layer and color conventions in NC-Pyros for NC-Pyros to determine which process 
(marking or inside or outside cutting) to use. NC-Pyros needs to separate the different processing it performs (marking, 
inside cut, outside cut, and so on). To accomplish this, NC-Pyros needs to have the entities on different layers or as 
different colors. These settings are controlled on the Layers tab in Preferences.
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When using different layers to differentiate processes, it is best to generate a template drawing and use it for each nest 
drawing. For example, you can use a template drawing with the following layers created: MARK, BUGE, TEXT, INSET,
INSIDE, OUTSIDE, PLATE, NOKERF, NOPROCESS, BEVELMARK, BEVELANGLE, BEVELSTANDARD, and REMNANTCUTLINE. It 
is good practice to use a color-by-layer entity property setting when not using nest drawings from ShipConstructor. Using 
color-by-layer, you can determine visually if all entities are on the appropriate layers. Now you can start the nesting.

Nesting
You can use ShipConstructor, a third-party nesting program, or nest the parts manually using any CAD program. Someone
skilled with CAD can nest the parts efficiently using AutoCAD alone. The manual procedure is often economical if the 
parts are complex and when many different parts of greatly different complexity have to be nested, as is often the case 
for shipbuilding.

Open a new drawing for the nest. Place one or more rectangles on the REFERENCE layer that indicates the size of your 
stock plates. Insert all blocked parts randomly on the drawing. Use your CAD system to nest the parts, starting with the 
largest ones, using the move and rotate commands. You may want to place some parts in through holes, such as small 
brackets. All entities with outside cuts within a through hole have to be changed to the INSET layer. They cannot contain 
any inside cuts.

The resulting drawing contains all the required information to produce the NC code for the number of parts to be cut from 
one plate.

Note: Before exporting the drawing to a DXF file, explode all blocks. It is advisable to turn off or freeze all layers that 
are not required for NC processing. You can save disk space and time by writing just the selected objects to the DXF 
file. 

You can now use NC-Pyros to create NC code for the nested drawing.

Managing Preferences
NC-Pyros stores its preferences in the directory of the nest drawing DXF file. You can create many different preference 
files to accommodate different settings. You may need different preference files if you use different controllers or if the 
settings change for different plate thickness.

Error Checking While Loading a DXF File
NC-Pyros runs a number of tests while loading a DXF file:
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• The total dimensions of the nested drawing are calculated. A special warning message appears if negative values 
are encountered. Some controllers do not accept negative absolute values. 

• NC-Pyros searches the complete data bases of the drawing elements and checks if duplicate entities are present. 
These are quite commonly created during the design process and are unknown to the designer. Any duplicate 
elements are automatically removed from the database.

• Circles and arcs are split at quadrant lines if specified in Preferences.

Error Checking While Generating Shapes
Some error checks are run when segments are organized into shapes.

• AutoCAD sometimes places large arcs into a polyline if curve fitting was used. NC-Pyros will replace large arcs with 
radii larger than the Maximum Arc value set in Preferences with a series or straight lines. A warning message 
informs you of this fact and advises you to double check the resulting path with the DXF drawing file. This can easily 
be done by loading the optimized path over a copy of the nested parts drawing.

• Bevel Angles conform to the limits of the thickness of the plate.

Adding Bevel Cuts
Adding bevel cuts can be achieved by using nests from ShipConstructor that contain bevel information or by manually 
adding the bevel to the nest DXF.

Constant Bevel Convention
If the nest DXF is not generated by ShipConstructor, Angles can be added as TEXT objects on the no process layer. The 
beveled section of the cut needs to have ‘0’ TEXT objects on the midpoints surrounding the beveled section. For 
ShipConstructor generated nest DXF, bevel angles data should be changed in ShipConstructor and regenerate from the 
nest DWG.

Beveled shape as seen in DXF

NC-Pyros will fill the same angle in between segments that contain bevel text. Ensure that the same angle is specified at 
each end of the edge or else unpredictable angles will be in between. Ensure that ‘0’ text items immediately surround the 
segment or that other bevel angles are specified to stop the bevel cutting at the end of the beveled edge.
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Top edge is beveled

The TEXT object needs to be at the midpoint of the line or arc segment to be recognized as a bevel angle. Center 
alignment or left alignment is allowed. For center alignment the alignment point needs to be at the midpoint of the 
segment. For bevel cutting a circle the text needs to be at any point on the edge of the circle.

Center aligned text at midpoint

When you have a beveled shape the near edge and the bottom edge of the plate are in different places if you are looking 
straight down at it. 

NC-Pyros allows you to specify in the controller code file which edge you are specifying for the shapes. If the geometry 
represents the top (or mark) side of the plate as it lays on the NC machine, then the >BEVEL_GEOMETRY_PLANE code 
should be set to PLATE_TOP.
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Solid line is used in PLATE_TOP case

Sign convention for bevel angles

Sign convention for bevel angles

For X, Y and K bevel cuts you specify those using the following abbreviation convention.

Left (or bottom) Angle – ‘LA’

Right (or top) Angle – ‘RA’

Left Height – ‘LH’

Right Height – ‘RH’
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The following X bevel would be LA45LH8RA45RH8.

The following Y bevel would be RA20RH5.

Appendix

Features
This section explains the individual menu commands.

The user interface consists of several bars and windows:

• Title bar
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• Menu bar

• Toolbar

• Display window

• Information window

During the execution of NC-Pyros, windows also present you with information.

Title Bar
The narrow bar at the top of the screen displays the name of the current file.

File Menu

The File menu contains the following functions:

Open DXF
Open DXF opens a DXF file. The DXF file contains the nest for the NC code generation. The DXF file is read and interpreted 
using the settings in Preferences. The DXF file has to conform to the NC-Pyros standards to be read successfully.

Open NCY
Open NCY opens a file that has been saved in NC-Pyros format. Use this function to read back a previous partially or fully 
optimized and saved NCY file. This function is useful when you have to make further changes to a nest or if you just have 
to change the post-processor for a different controller. The NCY file is a snapshot of the geometry at the moment when 
you saved the NC code if you used the Save All menu.

Backplot NC Code
Backplot NC Code opens an NC code file for backplotting. This function lets you load an NC code file and convert it back 
to geometry. 
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Backplot Kerf Check
Backplot Kerf Check generates a view of an NC code file for kerf checking. You can run this command after you have 
used the Generate Complete Path function and saved the file by choosing Save NC Code.

Save NC Code
Save NC Code saves the complete path as an NC code file (path must be complete). NC-Pyros also saves a file with the 
extension .CNS. This text file contains some pertinent information about the processed data file, such as the lengths of 
marking and cutting and the area of the process parts.

Save NCY
Use Save NCY to save geometry in a special NC-Pyros format. Use this function to save the current state of manual or 
automatic optimization. You can use this file later if you have to use a different controller without having to optimize and 
test the path again. You can now open the NCY file at a later date and save the NC code for any post-processor.

Save As DXF/O File
Save As DXF/O File saves the geometry as a DXF file format. This file can be overlaid onto the CAD drawing to check the 
path generation. The entities are stored on layers that are preceded by NCPYROS to distinguish them from the original 
entities.

Save All
Save All saves as an NC code file, NCY file, and DXO file with the same filename (with the appropriate file extensions). 
This feature is provided so that when you want to save the NC code, NCY, and DXF formats you can provide a filename 
and all three formats will be saved with the same filename but their appropriate file extensions.

Print
Select Print to print the current display to a Windows plotter or printer.

Print Setup
Printer Setup sets the printer options. This invokes the standard Windows printer setup window.
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Preferences
Use Preferences to select the settings for reading DXF files and processing and writing NC code files.

The Preferences window is a tabbed window; you can click at the appropriate tab at the top to select a specific part of the 
Preferences window.

General Tab
The General tab controls the general settings for the NC-code generation. It contains the following settings:

Burner Type – Select the Burner Type by clicking Plasma or Gas. 

Units – Select the Units by clicking Millimeters or Inches.

Code Format – Select the Code Format by clicking Absolute or Incremental.

Return To Origin – Check this box if you want the machine to return to the origin after processing the last command. 
Uncheck this box if you want the machine to stop after processing the last entity.

Line Numbers – Check this box if you want to have the line numbers in the G code file. This function does not apply to 
ESSI-code.

Rotate Code 90° CW – Check this box if you want to have the output NC code rotated 90° clockwise about the origin.

Generate Statistics File (CNS) – Check this box if you want to gather statistics on lengths of mark and cut. Uncheck this 
option if this information is not required and just clutters the folder with unused files.

Controller Code Folder – The folder containing the ECD and GCD controller code files. Change this if you want to specify a 
shared network location. You can also limit the controller files to only the ones you use.

Post Processor – Select the controller file that represents your controller from the Controller Code Folder. NC-Pyros comes 
with several preconfigured post-processor files. You can use these files, modify any one of them, or generate your files. 
The .ECD extension is for the ESSI format, and .GCD is for the G code format. See the Custom Controller Files for detailed 
information of the available post-processors.

Layers Tab
The Layers tab contains the following settings:
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Load – Check boxes allow layers or colors to be ignored when opening the DXF file.

BY LAYER – When this is checked, the entities are separated by the different layers.

BY COLOR – When this is checked, the entities are separated by the different colors. The colors are shown along with the 
AutoCAD color number. You can change a color by clicking on the colored button. The Select Color window appears.

Marking – All entities on the Marking layer are used to produce code for the marking unit of the machine.

Buge Marking – All entities on the BUGE layer are used to produce code for the BUGE marking unit of the machine.

Text Marking – All entities on the TEXT layer are used to produce code for the marking unit of the machine. Text strings in 
the DXF are converted to marking information using the information in the CHAR.DAT file described in Editable TEXT 
Character Set (page 50). Make sure you select the appropriate size in the Preferences > Processing tab.

Inset Cut – All entities on the INSET layer are used to produce code for the cutting unit of the machine for outside cuts. 
These entities are usually positioned on through holes.

Inside Cut – All entities on the INSIDE layer are used to produce code for the cutting unit of the machine for inside cuts.

Outside Cut – All entities on the OUTSIDE layer are used to produce code for the cutting unit of the machine for outside 
cuts.

Reference – All entities on the REFERENCE layer are used for reference and interference (lead collision) checking. No 
code is produced for entities of this layer.

No Kerf – All entities on the NOKERF layer are used to produce code for the cutting unit of the machine for cuts that have
no kerf applied.
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Bevel Mark – All entities on the Marking layer are used to produce code for the marking unit of the machine. Text strings 
in the DXF are converted to marking information using the information in the CHAR.DAT file described in Editable TEXT 
Character Set (page 50). Make sure you select the appropriate size in the Preferences > Processing tab.

Bevel Angle – All entities on the BEVEL ANGLE layer are used to produce code for the cutting unit of the machine for 
variable and none-standard constant bevel cuts. 

Bevel Standard – All entities on the BEVEL STANDARD layer are used to produce code for the cutting unit of the machine 
for standard constant bevel cuts.

Remnant Cutline – All entities on this layer are used to define the cutline for the various remnants on the nest. If there 
are no entities on this layer, then NC-Pyros will detect remnant cutlines by searching for open paths.

Skip Text – Allows TEXT entities on the marking layer to be filtered out while loading the DXF file. When the box is 
checked, no TEXT entities on the marking layer will be loaded.

Sync Colors with ShipConstructor – Synchronizes the layers to read Nest DXFs from the linked ShipConstructor project.

Input Filter Tab
Input Filter settings are used during reading and translating a DXF file. The tab contains the following settings:

Maximum Radius – The maximum radius the burner can handle. Check your controller’s documentation for this value. If 
the radius of an arc exceeds this limit, NC-Pyros changes the arc to lines that the burner can handle.

Chord Tolerance – When arcs need to be converted to lines because the maximum radius is exceeded, the Chord 
Tolerance specifies the maximum distance a line can be from the original arc.

Split Arcs at Quadrants – Splits the arc processing at quadrant lines. Some older controllers cannot handle an arc 
command if the arc crosses a quadrant line (0, 90, 180, and 270 degree lines). NC-Pyros can automatically split the arcs 
into a series of arcs ending and starting at the quadrant lines. For example, a circle will consist of 4 arcs of 90 degrees 
each.

Erase Elements < – The maximum length of the short elements that will be erased during Generate Complete Path and 
Generate Shapes. Enter an appropriate value. Many controllers cannot process elements below a certain length and will 
stop or create erratic results. 

Snap Tolerance – The length of the gap between elements of a shape that NC-Pyros will jump or connect into a single 
shape. This compensates for lines not actually joined in the original DXF files. Snap tolerance should be GREATER THAN
or EQUAL TO the length set in Erase Elements <. NC-Pyros automatically adjusts two elements to the same meeting point. 
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The program automatically determines which element has to be adjusted to close the gap causing the least change in 
the path. 

Note: Ensure that this value is larger than the value for Erase Elements <.

Rotate Geometry – The angle in degrees to rotate the geometry counterclockwise.

Convert Lines to Arc – Will enable the analysis of the geometry to determine when adjacent straight segments can be 
converted to an arc. This can improve the quality of the cut when the machine stalls at each point creating a cupping 
effect.

Arc Convert Tolerance – The maximum error that will be introduced when line segments are converted to a arc.

Text Size – The height of any text entities that are loaded. Set the Text Size to 0 to use the entity’s text height in the DXF 
file.

Convert Units from inches to mm – Scales the geometry during the open DXF process.

Nest Positioning – NC-Pyros can automatically move the geometry to achieve a certain position of the nest on the plate 
independent of the nest position within the CAD drawing:

• Select None if you want to process the nest exactly as it is specified in the CAD drawing.

• Select Processing layers and enter a margin value. All geometry is moved in the X and Y direction in such a way that 
the total minimum X and Y values of all processing layers (INSIDE, INSET, OUTSIDE, MARK TEXT, and BUGE) are 
offset distance from the X and Y axes. This can be used if you have more than one nest on one drawing and do not 
want to move each drawing to the origin to ensure proper processing. 

• Select Plate layer to origin to move the geometry so that the minimum X and Y value REFERENCE layer (plate edge) 
is positioned at the origin (0, 0).

• Offset – The amount to shift the geometry away from the origin.

Origin Position – When nest positioning is used, this setting determines where the origin for the nest will be located.

Processing Tab
Processing settings are used during post-processing when generating the NC code.
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Tab Length – The length of a tab that can be inserted to keep parts connected to the plate. Tabs must be entered 
manually using the Manual Edit > Insert Tab menu. 

Note: You cannot set the start of shapes after inserting tabs. If you want to start cutting a shape with tabs at a certain 
position, make sure that you insert the first tab where you want the cutter to start. 

Calibration Size – The size of the calibration marks.

Min. Arc Length – This setting is used to replace short arcs with straight-line segments. During trimming operations in 
CAD you can end up with arcs that are very short. Some controllers cannot calculate the kerf for those arcs and produce 
erratic results. Enter a value that your controller can handle.

File Extension – The default file extension for loading and storing NC code files (.CNC is the default). Enter a different 
extension if you like.

DXO Arrow Size – Determines the length of the arrow lines in the DXF > DXO output file. A value of 0.0 suppresses the 
arrow generation altogether.

Sim Speed Factor – This allows you to adjust the range of speeds of the simulation. The smaller the number, the slower 
the speed.

Cutting Direction – Determines the direction of the shapes for inside and outside cuts. Typically, users cut outside cuts 
clockwise and inside cuts counterclockwise.

Path Optimization – Determines which is the next shape to travel to when calculating the path.

• Y Movement (Default) – Shapes are ordered in vertical columns and the next shape is the one above or below.

• Next Closest – The next closest start position is the next shape traveled to.

Autorun backplot kerf check – This is a diagnostic tool. When it is checked, it will run a backplot kerf check after the CNC 
file is saved. 

Start of Shape – Determines the start position of a shape:
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• Lower-Left – The start position is located at the closest node point to the lower-left corner of the plate.

• Near Edge – The start position is located so that the side of the shape closest to the edge is cut first.

• Upper-Right – The start position is located at the closest node point to the upper-right corner of the plate. This option 
is helpful when a part is unsupported when it is being cut.

Order – Determines the processing order of the shapes:

• By Process – All mark shapes are processed first, then inset shapes are processed, then inside shapes, and last 
outside shapes are processed.

• By Part – Each shape in a part is processed before processing another part. A shape is part of a part if it is inside the 
outside geometry.

• Mark First, Cut By Part – All marking is done and then the cutting is done on a by-part basis (insert, then inside, and
then outside).

• Buge Separate from Mark – Only for controllers that support buge marking. The buge is processed after marking is 
complete. When unchecked, the buge marking and regular marking are intermixed.

Mark Order – Determines the processing order of the marks and text marks. Only applicable when buge text or inkjet text
marking:

• Mixed – Mark shapes are processed in one batch and not separated into lines and text.

• Buge(Text) then Lines – All text marking is done before the first mark line.

• Lines then Buge(Text) – All the mark lines are processed before the first text mark.

Mark using rapid – Allows the marking process to travel at the fast feed rate. Marking is performed at the slow feed rate 
if this is unchecked.

No spaces in code – Removes spaces in the NC code. Some controllers require no spaces in the NC code. This feature can 
also reduce the size of the code file.

Add code description – Adds description text at the end of each NC code in the NC code file or the code window during 
simulation. Use this feature only for checking code. 

Warning: Do not have this checked for code to be sent to the controller.

Leads Tab
The Leads settings are used to modify the type and length of the lead-ins and lead-outs.
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Outside Lead Type – Determines the shape of the leads on outside cuts

• Line Always – Creates leads that are lines of the specified length.

• Arc Always – Creates leads that are quarter circular arcs of the specified radius.

• Arc on Arc, Line on Line – Creates arc leads that lead to arcs of circles and line leads that lead to lines.

Lead In Length/Radius – After the shapes are generated leads can be added to the start of the shapes. A line (or arc) 
is added if the length is larger than 0.

Lead Out Length/Radius – After the shapes are generated, leads can be added to the end of the shapes. A line (or 
arc) is added if the length is larger than 0.

Inside Lead Type – Determines the shape of the leads on inside cuts

Lead In 2 Length – A second lead-in that precedes the lead-in. This cut can only be a straight line cut and is sometimes 
required by specific controllers that require a straight cut first.

Overcut Length – Adds elements to the end of the shape so the end of cutting a shape goes past the start of the shape by 
the specified amount. You can undercut the shape by setting Overcut Length to a negative value.

Overcut Inside Only – Applies the undercut or overcut (Overcut Length) to inside cuts only.

Lead Line tangential to shape – Sets the line leads to lead in or out at an angle tangent to the shape.

Use Lead In Feedrate – Sets the feed rate for the LEADIN_FEED controller code on the lead-in element of a shape.

Inkjet Text Marking – Offers control of the path during inkjet text marking. These settings are only in effect when the 
controller is set to be inkjet. All the following values are combined into one movement code.
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Lead In Length (LI) = Length before the text. This is determined by inkjet marker specifications. 

Lead Out Length (LO) = The Length to extend past the calculated end 

Movement % of Text Size (M%) = A scaling factor to adjust how wide a character is when marking compared to the 
height. This allows adjustment of the movement for marking based on the number of characters to print.

ShipConstructor Tab
The ShipConstructor settings are used to link NC-Pyros to a ShipConstructor project database. The link to the 
ShipConstructor database allows NC-Pyros to update the database with processing lengths so ShipConstructor can 
estimate the time of the nest.

Use Database – This check box tells NC-Pyros to output the results to the database.

Project Database – The filename of the ShipConstructor project database.

Current user – The name of the user that is logged as performing the NC processing.

Login – Lets you change the current user. A password may be required to log on.

Bevel Tab
The Bevel tab settings are used for bevel cutting operations.
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Enable Bevel – Activates NC-Pyros to insert code for bevel angles.

Bevel Corner Type – When the bevel angle changes at a corner, a corner routine is added to produce a clean corner. NC-
Pyros provides two types of corner routines.

• Triangular – Adds the following path.

• Circular(Convex) – Adds the following path.
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Circular(Concave) – Adds the following path.

Extend Length – The length to extend away from a shape when a corner routine is inserted.

Insert Loop Threshold Angle – The angle that determines when a corner routine is inserted. A triangular corner routine is 
inserted at any enclosing angle between two elements that is less than the threshold angle.

Extend Out Length (A) – The length extended past the edge of the part when a corner loop is inserted.

Extend In Length (B) – The length to lead in to the part during a corner loop. This must be the same as Extend Out Length 
when using the Circular bevel corner type.

Height Sensor On Length (HS1) – The distance from the start of cutting the part when the Height sensor is enabled. This 
only applies to a when cutting from a beveled cut to a vertical cut. The ESAB recommended value for this is the thickness 
of the plate.

Height Sensor Off Length (HS2) – The distance before the end of cutting the part (and before starting a corner loop) when 
the Height sensor is turned off. The ESAB recommended value is 75mm.

Enable Height Sensor for non-bevel – Inserts the height sensor on and off codes into the cutting when enabled. Before the 
end of the shape is reached the path is broken at the HS2 length to turn off the height sensor.

Head Rotate Length (RL) – The distance from the start of the lead-in to rotate the tangential controller when the first cut 
is a bevel cut. This length cannot be larger than the lead-in length on the Leads page. For vertical cuts the rotate 
tangential controller is not added.

Corner Loop Bevel Text Size – The size of the bevel text that is shown for the bevel loop elements.

Lead out not beveled – Option to turn off the bevel cutting at the end of the shape just before the lead-out is cut. This is 
required by specific controllers that set the bevel angle back to vertical at this time.

Highlight Beveled Cuts using bevel colors – Enable the highlighting of the edges with beveling using the bevel colors in 
View > Colors…. When a nest is first opened, only the edges that have an associated bevel text are colored. When the 
shapes are generated, every segment that is bevel cut is given a bevel text and colored the bevel color (if bevel 
highlighting is on).
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Load Preferences
Loads a specific preference file as the current settings.

Open Manager
Starts ShipConstructor Manager and loads the project database set in the preferences. If the preferences are not linked 
with ShipConstructor, this function does nothing.

View Menu

The View menu contains the following functions:

Zoom
Zoom magnifies a selected area. Select the area by dragging a zoom window enclosing the area to magnify (the hot key
for this function is Z).

You can also zoom dynamically by scrolling the mouse wheel.

Pan
Pan moves the drawing about the screen (hot key P). You can also pan by holding down the middle mouse button

Zoom All
Zoom All displays the entire drawing on the screen (hot key A).

Zoom In
Zoom In magnifies the view by two (hot key +).

Zoom Out
Zoom Out decreases the size of objects in the view by two (hot key -).

Simulate
Simulate draws the path slowly. The following window appears at the bottom of the screen.

• Speed slider – Changes the speed the path is traveled.
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• Step – Click this button to process the path one step at a time.

• Go – Click this button to start the simulation at the set speed.

• Cancel – Cancels or ends the simulation.

• Insert – Click this button to insert a comment, dwell, or program stop at the current position in the path.

A scroll window displays the executed NC code. You can click Step any time and then scroll up and down the NC 
code. Also at the end of the simulation, a window asks you if you want to quit the simulation. Click OK to keep the 
NC code scroll window on the screen to let you inspect the code. Click Cancel to finish the simulation when you are 
done.

Inserting Code

If you want to insert custom code at some point in the path, Step until you reach the point you want to insert the code.

Comment – Inserts the given text in the NC code. NC-Pyros will attempt to use the IGNORE_ON and IGNORE_OFF codes 
on the lines before and after the inserted text. If ignore codes are used on the same line as the comment, you must 
include that code in the given text.

Dwell – Inserts a dwell code at the insertion point. The dwell time is set in the controller code file.

Stop – Inserts a program stop for possibly removing a part from the table or a tool change.

Info Bar
Horizontal – Displays the information window along the bottom.

Vertical – Displays the information window on the left side.

See Information Window (page 50).

Colors
Allows you to change the display colors of objects that are read from the DXF file. The display colors of the elements are 
located on the Layers tab of Preferences.
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To change a color, click on the button of the entity you want to change. The Select Color window appears. The colors are 
numbered similarly to AutoCAD. You can change a color by clicking on the new color or changing the color number.

Generation Menu

This menu contains the following functions:

Generate Complete Path
Generate Complete Path – Generates a path and optimizes the nest completely. This function invokes the following 
procedures:

• Erases duplicate entities.

• Removes short elements as specified in Preferences.

• Connects entities to shapes using the snap tolerance set in Preferences.

• Sorts shapes.

• Optimizes shapes on the marking layer.

• Generates lead-ins and lead-outs for all cutting shapes using the values set in Preferences.

• Generates the fast travel connectors.

• Calculates the number of shapes on each layer.

• Calculates marking and cutting lengths.

• Calculates the area of the processed shapes.

Generate Shapes
Generate Shapes removes short elements and connects entities into shapes on each layer. Use this function to connect 
the entities to shapes but not to sort or connect them to a complete path. You have to use Manual Edit > Manually 
Connect Shapes to select the order of processing. This function invokes the following procedures:
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• Erases duplicate entities.

• Removes short elements.

• Connects all elements into shapes on each layer.

• Calculates the number of shapes on each layer.

• Calculates marking and cutting lengths.

• Calculates the area of the processed shapes.

Generate Marking Path
Generate Marking Path removes short elements and connects entities into shapes on each layer. Use this function to 
connect the entities to shapes and connect the path for the marking shapes. You have to use Manual Edit > Manually 
Connect Shapes to set the path of cut shapes.

Check Menu
The Check menu contains the following functions:

Check Open Shapes
Check Open Shapes finds open shapes, zooms into them, and offers them for deletion. Often single CAD entities are 
forgotten and left behind. These usually result in small open shapes consisting of just a few CAD entities. Deleting them is 
the correct option in most cases.

Check Lead Collision
Check Lead Collision finds and corrects all lead collisions with other shapes. The program checks each lead with every 
other shape. If a collision occurs, the program highlights the lead at fault and zooms into it. The Lead Edit floating toolbar
offers lead editing capabilities to avoid the collision.
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Manual Edit Menu

The Manual Edit menu contains the following functions:

Set Start of Shapes
Set Start of Shapes changes the point at which the cutting of a part begins. The process has four steps:

• Finds the selected point on the shape and moves the start of the shape to that point.

• Moves the lead-in and the lead-out (if there are any) to the new position.

• Redraws the path with new connectors.

• Updates fast travel length in the information window at the bottom of the screen.

To move the start of a shape to the start of an element in a shape, hold down the Shift key and select the element you 
want to cut first. To move the start of a shape to the end of an element in a shape, hold down the Ctrl key and select the
element you want to cut first.

Delete Shapes
Delete Shapes removes open or unwanted shapes. The process has five steps:

• Highlights the shape you have selected.

• Presents you with a window where you must accept the deletion.

• Deletes the shape if you selected Yes.

• Redraws the path and recalculates the path lengths.

• Updates the information in the window at the bottom of the screen.

Reverse Shapes
Reverse Shapes reverses the cutting direction of shapes so that the kerf is on the correct side.

Insert Tabs
Insert Tabs lets you manually place tabs anywhere on the shapes. Select the position where you want to tab the cutting 
path by clicking with the cursor. You can undo the last inserted tab by clicking the Undo button on the floating toolbar. 
This menu item invokes the following functions:

• Checks the preferences settings for tab length.

• Inserts a tab at the specified location in the cutting path.

• Generates a lead-in and a lead-out if necessary.

• Redraws the new path and recalculates the path length.

• Updates path lengths in the information window at the bottom of the screen.
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Change Leads
Change Leads lets you rotate, lengthen, or shorten any lead-in or lead-out. Select the lead you want to edit by clicking on 
it with the mouse. A toolbar pops up with buttons that allow you to shorten, lengthen, and rotate the lead. Click Confirm
to accept the changes or Cancel to cancel the changes. (See How to Edit the Lead (page 11) for details.)

Manually Connect Shapes
Manually Connect Shapes lets you manually select the cutting order of the shapes on each layer. This menu item invokes 
the following procedure:

• Starts with a connector at the origin, coordinate (0, 0).

• Draws the connectors to each shape as you select it.

• Notifies you when the path is complete.

• Calculates path length and updates the information window.

During the Manually Connect Shapes function, a floating toolbar with two buttons appears on the screen. 
The left button with the sun symbol draws all connected shapes in yellow color and leaves the rest in their original colors. 
This lets you easily identify the unprocessed shapes. The right button is the Undo button. It lets you step back through 
your manual connections to make corrections.

Note: You must use Path > Generate Shapes first to connect all entities to connected shapes. 

Manually Connect and Set Start
Manually Connect and Set Start lets you manually select the cutting order of the shapes while you also set the start of the 
shape. This menu item invokes the following procedure:

• Starts with a connector at the origin, coordinate (0, 0).

• Draws the connectors to each shape as you select it and moves lead-in and lead-out position to the picked point on 
the shape.

• Notifies you when the path is complete.

• Calculates path length and updates the information window.

During the Manually Connect and Set Start function, a floating toolbar with two buttons is displayed on the 
screen. The left button with the sun symbol draws all connected shapes in yellow color and leaves the rest in their original 
colors. This lets you easily identify the unprocessed shapes. The right button is the Undo button. It lets you step back 
through your manual connections to make corrections.

Note: You must use Path > Generate Shapes first to connect all entities to connected shapes. 

Reroute Fast Travel
Reroute Fast Travel changes the course of the burner head during fast travel. You can use this function to prevent the 
head from traveling over previously cut parts. The part may have tilted up, and the torch head can be damaged if it 
collides with the part.

• Click on the connector at the position where you want to break it.

• Move the mouse to alter the connector.

• Accept the point by pressing the left mouse button.

The path length is automatically updated in the information window at the bottom of the screen.
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Insert Bevel Corner Loop
Insert Bevel Corner Loop inserts a bevel corner loop at the corner closest to the pick point. This function can only be 
applied to a shape that contains bevel cuts and after the path is generated. The bevel loop provides a path for the torch to 
perform its head transition and provide a clean cut at the corner. A sample bevel loop is shown below. NC-Pyros will 
automatically insert bevel loops determined by the bevel settings in Preferences.

Remove Bevel Corner Loop
Remove Bevel Corner Loop removes a bevel corner loop. Choose this function after picking anywhere in the bevel loop 
path. This function lets you remove bevel loops that are not desired. 

Calibration Menu

The Calibration menu contains the following items:

Marks At Layer Changes
At Layer Changes inserts calibration marks before and after processing a layer. Each calibration mark consists of a cross 
with a horizontal and a vertical line marked before the start of the layer processing and a diagonal cross marked on top 
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of the first cross drawn after the processing for this layer is finished. One set of crosses is drawn for each layer. Each 
calibration mark for the subsequent layers is offset in the X direction.

Mark Before Picked Shape
Before Picked Shape inserts a calibration mark before the shape that you select. Each calibration mark consists of a 
cross with a horizontal and a vertical line marked before the start of the shape processing and a diagonal cross marked 
on top of the first cross drawn after the processing for this shape is finished. One set of crosses is drawn for each selected 
shape. Each calibration mark for the subsequent shapes is offset in the X direction.

Remove All Calibration Marks
This menu item removes all the calibration marks created.

Move Calibrations
Move Calibrations moves all the calibration marks to a position that you select.

Toolbar

Each button represents a shortcut to a menu item. No new functions are implemented here. A tool tip (a text message 
that describes the function of the button) appears if you rest the cursor over a button for a short time. The toolbar 
contains the following buttons:

File > Open DXF opens a DXF file.

File > Open NCY opens a file that has been saved in NC-Pyros format.

File > Save NCY saves the geometry in a special NC-Pyros format.

File > Save NC-Code saves the complete path as an NC code file.

File > Save As DXF/O File saves the cutting path as a DXF formatted file.

File > Save All saves as an NC code file, NCY file, and DXO file with the same filename and different extensions.

File > Print prints what is displayed on the screen.

File > Preferences sets the preferences.

View > Zoom In magnifies the display.

View > Zoom Out zooms out by a factor of two.

View > Zoom lets you select the area to be displayed (hot key Z).

View > Zoom All displays the entire drawing on the screen (hot key A).

View > Simulate draws the path at different speeds.

Generation > Generate Complete Path automatically generates a complete path.

Generation > Generate Shapes connects entities into shapes on each layer.

Generation > Generate Marking Path automatically generates a path for all marking.

Check > Check Open Shapes highlights open shapes for manual editing.

Check > Check Lead Collision finds all lead collisions with other shapes.

Calibration > At Layer Changes inserts the calibration marks between processing layers.

Calibration > Before Picked Shapes inserts the calibration marks before the shape.
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Main Display Window
The large center window displays the geometry of the path. Colors are used to distinguish between the different functions 
of the geometric entities. The DXF object colors can be changed on the Layers tab in Preferences, and the NC-Pyros 
generated objects can be changed in View > Colors.

Information Window
The information window can be displayed either at the bottom or at the left side of the screen. Use the View menu items 
to set up the position of this window.

In either the bottom or left side of the screen the same information is displayed. The following items are listed:

• The number of elements found on each layer.

• The length of the path for each kind of travel.

• The area of the processed parts.

• The end position of the cutter after processing all parts.

• The X and Y position of the cursor.

• The path completion state. 

Editable TEXT Character Set
Character Description
NC-Pyros allows users to create and edit their own custom TEXT characters. 

The following characters are provided in the CHAR.DAT file:

a-z, A-Z, 0-9~`!@#$%^&*()-_=+\|[]{};:'"<>/?.,

The character set can be extended to include any characters.
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The following example shows how a character is represented in the CHAR.DAT file. 

Sample from CHAR.DAT for the character A:

>A

0.00 0.00

0.30 1.00

0.60 0.00

-1.0 -1.0

0.10 0.30

0.50 0.30

-2.0 -2.0

The character following the > is the character for which the following geometry instruction will be used. Each ASCII line 
after the character represents an X-Y coordinate. Adjacent coordinates are connected by a line in the direction from the 
first coordinate to the second. There are two special coordinates:

• -1.0 -1.0 indicates a break in the marking path description, such as when the horizontal stroke in the letter A is 
finished .

• -2.0 -2.0 indicates the end of the character drawing.

Multiple-Pass Bevel Cuts
You can now create X, K and Y-bevels using a single-torch cutting machine to perform multiple cut passes. Previously, you 
could only create bevels using a three-torch cutting machine.
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Example of a Y-Bevel

To enable multiple-pass bevel cuts on a NC Machine select Multipass under Bevel Capability in ShipConstructor > 
Manager.

Variable Bevel Cut
You can now create variable bevel cut on straight or arc edges. For a straight edge cut, cutting angle will change evenly 
on the tool path. For an arc edge cut, cutting angle will evenly change on the tool path and perpendicular to the tangent 
of the tool path.  For a single-torch cutting machine, variable bevel cutting function support single cut only, multiple cuts 
will be supported in future versions.
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NC-Pyros Controller File
If you have set up any multiple-pass bevels in ShipConstructor, then you must add the following lines to your controller 
code file:

----------------
>TORCH_CONFIG
1_TORCH_MULTI_PASS
----------------

Only nested parts that have at least one multiple-pass bevel will be processed as a multiple-pass part. All other parts will 
be processed as single-pass parts.

You can specify the order of the passes using the BEVEL_PASS_ORDER controller code. There are many other controller 
codes to configure when cutting using multiple passes. Contact ShipConstructor Software for further details.

Customizable Controller Code Files
There are generally two different code formats used for NC burning machines: G-Code and ESSI-code. Even though both 
codes are standardized, controllers from different manufacturers use slightly different codes to execute certain functions. 

Several aspects should be considered and discussed with the operator of the NC burning machine before producing NC 
code. There are a wide variety of NC controllers fitted to burning machines. NC burning machines from the same 
manufacturer can be fitted with different controllers. Some controllers understand only one programming language;
others can use two or more languages or dialects of the same language.

NC-Pyros supports G-Code and ESSI format. NC-Pyros uses a controller code file for every type of controller to handle the 
variations. You can modify an existing file or make your own controller files to support any controller. Use a text editor like 
Wordpad or Notepad to change the individual codes in a controller file. Just select the code that you want to change and 
type in a new value for the specific code.
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The following example controller files are included with NC-Pyros

Controller Type Sample Controller Data Filename

ALLEN-BRADLEY Allen-Bradley.gcd

ANCA anca.gcd

BURNY burny.ecd, burny.gcd

burny3.ecd

burny5.ecd, burny5.gcd

burny10.gcd

BYSTRONIC bystronic.gcd

ESAB esab.ecd, esab.gcd, ESAB Vision55.ecd, ESAB Vision55 
inkjet line mark.ecd

FANUC 15M fanuc15m.gcd

Kinetic Kinetic Touchcut6.gcd

KOIKE koike.gcd

L-TEC 2000 ltec2000.gcd

LINDE CM100 lndcm100.gcd

MESSER GRIESHEIM messer.ecd

mg.gcd

Messer Intermediate for input into OmniBEVEL Messer Intermediate Omnibevel.ecd

MICROPATH micropth.gcd

Trivers CuttingEdge III Trivers CuttingEdge III.gcd

Union Carbide UCNC-7/8 ucnc78a.gcd (for absolute programming)

ucnc78i.gcd (for incremental programming)
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When developing a new controller, or modifying an existing one, it is good practice to open a file that represents your 
needs most closely and to save it under a different name. Make sure to use the extension .ECD for ESSI based controllers 
and .GCD for G-Code based controllers.

IMPORTANT NOTE: The controllers provided with NC-Pyros are provided as examples only. While these working controllers 
were developed for specific clients and applications, in most cases customized development and testing is required when 
modifying or developing a new controller. Please contact ShipConstructor regarding the development and testing of new 
controllers.

Each controller function has a separate section in the controller file. Each section starts with a key word of that function.
The key word is always preceded by a > character. The next lines contain the code required to execute that function. You 
can place the code for the function into one or more lines. The end of the code for the function is indicated by a line with 
several dashes.

>BURNER_OFF
08
66
----------------

Example for changing a function code:

1. Open the Notepad program from the program manager and open the file BURNY.ECD. Save the file immediately as 
MYBURNY.ECD.

2. A -1 in the code file indicates that this controller does not use any code for a specific function. The -1 after 
START_OF_RECORD indicates that this controller does not have a code for the start of a record. Suppose you require 
a percent sign (%) sign to mark the start a record.

3. Highlight the old code, -1, and type in the new correct code, in this case %.

4. Save the file.
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5. Return to NC-Pyros and select MYBURN.ECD in the Preferences window.

6. Open DEMOSHRT.DXF, optimize it, and save it as CNC.

7. Open the file DEMOSHRT.DXF with Wordpad. It lists a % at the beginning of the file.

8. Conversely, to stop a code from being generated, just change its code value to -1.

Warning: Do not remove any function codes from the original file. Use the -1 code to disable code generation.

Tip: Use separate lines for generating multiple code. Each code that is generated should appear on a separate 
line. There is no limit to the number of lines of code that can follow a code name (see below).

Tip: Keep the original controller data files intact. Whenever you customize a controller data file, save it under 
another name with the same extension. The names of the project or steel cutter make good filenames (for 
example, SHIPCON.ECD). The file will still appear in the Preferences Post Processor list.

Tip: Make sure to keep the same extensions -- .ECD for ESSI and .GCD for G-CODE.

Tip: Since different Preferences data files are kept in the directory of each project, you must be sure that the 
custom controller filename is still selected in the Preferences window after you change projects.

General Controller Codes
CONTROLLER_TYPE -- This section is used to distinguish between G-Code and ESSI controllers. Do not to alter this string 
manually.

MILLIMETERS_PRECISION -- NC-Pyros always programs G-Code with decimal values for the coordinates. Controllers 
usually require a different number of digits after the decimal point depending on the units used. For G-Code, you will find 
that three digits are usually used for inches and two digits for millimeters. Some controllers are tolerant and accept any 
number of digits. For ESSI code, you will find that accuracy is usually 1/100th of an inch for inch units (2 digits of 
precision) and 1/10th of a mm for millimeters (1 digit of precision).

INCHES_PRECISION -- See MILLIMETERS_PRECISION.

COORDINATE_MULTIPLIER –- Some controller codes have been multiplied to represent fractions as whole numbers. This 
setting lets you specify a multiplication factor for every coordinate.

ESSI_DECIMAL – Indicates that the ESSI format is not whole numbers but decimal numbers. Possible values: YES, NO. 
Default is No. 

START_OF_RECORD -- Start block for the controller. This code can be the code that a controller needs to know the start of 
a program, or the code that the tape reader needs in order to know where the NC program starts. The tape reader will 
usually stop at this position and wait for the operator. No line numbers are added for these lines.

Special keywords can be inserted into the START_OF_RECORD code that will be replaced when the CNC file is generated.

$FILENAME - Is replaced by the filename of the CNC output file.
$DATETIME - Is replaced by the date / time.
$DATE – Is replaces by the date
$TIME – Is replaced by the current time
$PLATEWIDTH - Is replaced by the width of the rectangle on the plate layer.
$PLATELENGTH - Is replaced by the length of the rectangle on the plate layer.
$PLATETHICKNESS - Is replaced by the thickness of the plate used for the nest in 
ShipConstructor.
$EXTENTX - Is replaced by the width of the processed geometry.
$EXTENTY - Is replaced by the length of the processed geometry.
$PROMPT - Is replaced by what the user enters. The comment between the double quotes is shown 
to the user. The value between the square brackets is the default value shown. Example: 
($PROMPT "Enter Grade/Lot/Line/Shot"[AAM*102P*P100*M-M])

AFTER_START_OF_RECORD –- Similar to START_OF_RECORD except line numbers will be included before each line if line 
numbering is turned on.

PRE_PROCESSING –- Any code to insert after the units and absolute/incremental codes are output. This section can also 
contain keywords.
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LINE_NUMBER_START -- This is the number used to start from when Line Numbers is turned on. For example, if this is set 
to 5, the first line number used will be N5. This may be necessary because lines in the START_OF_RECORD are not 
prefixed with line numbers.

END_OF_RECORD -- End block to tell the controller or tape reader (or both) that the end of the program has been reached.

AFTER_END_OF_RECORD -- Codes that you want at the end of the program by do not want line numbers in front of.

RAPID_LINE -- The code used for a rapid line travel. Only G-Code controllers use this function. The code precedes the X-
and Y-coordinate values in the same line.

CONTROLLED_LINE -- The code used for a controlled feed line travel. Only G-Code controllers use this function. The code 
precedes the X- and Y-coordinate values in the same line.

CW_ARC -- The code used for clockwise arcs. Used by G-Code controllers only.

CCW_ARC -- The code used for counter-clockwise arcs. Used by G-Code controllers only.

KERF_ON_LEFT -- The code used to offset the torch to the left of the cutting path.

KERF_ON_RIGHT -- The code used to offset the torch to the right of the cutting path.

KERF_OFF -- The code used to cancel the torch offset.

FAST_FEED -- The code used to tell the controller to travel at fast feed rate. This can be an F code such as F100, which 
could mean 100 inches per minute, or, as for UCNC78, an R for rapid. This code is added as the last value to the line 
movement code. For example, G01 X=1.0 Y=2.0 R.

SLOW_FEED -- The code used to tell the controller to travel at slow feed rate. This can be an F code such as F10, which 
could mean 10 inches per minute. This code is added as the last value to the line movement code. For example, G01 
X=1.0 Y=2.0 F10.

LEADIN_FEED -- The code to tell the controller the speed when the lead-in is cutting. Typically this is F### for G-Code 
controllers.

PRELEADIN_FEED -- The code to tell the controller the speed when the pre-lead-in is cutting. Typically this is F### for G-
Code controllers.

WARN_FOR_LEADIN_FEED -- Option to turn off the warning about lead-in length is less than 15mm when the 
LEADIN_FEED is specified. The message is shown by default specifically for the Japanese market. Possible values: YES, 
NO. Default is YES.

TRACK_SPEED -- variable will prevent the same feedrate from being output as in:

TRACK_SPEED = YES
G01X1Y1 F123
G01X2Y-1
G01X3Y-2

TRACK_SPEED = NO
G01X1Y1 F123
G01X2Y-1 F123
G01X3Y-2 F123

INCHES_UNITS -- The code to tell the controller that all units are in inches.

MILLIMETERS_UNITS -- The code to tell the controller that all units are in millimeters.

ABSOLUTE_FORMAT -- The code to tell the controller that all coordinates are given in absolute values from the origin.

INCREMENTAL_FORMAT -- The code to tell the controller that all coordinates are given in relative values from the current 
position.

BURNER_PLASMA_ON -- The code to tell the controller to use the plasma tool and turn it on.

BURNER_PLASMA_OFF -- The code to tell the controller to turn the plasma tool off.

BURNER_GAS_ON -- The code to tell the controller to use the gas tool and turn it on.

BURNER_GAS_OFF -- The code to tell the controller to turn the gas tool off.

MARK_ON -- The code to tell the controller to turn the marking head on. This can be punching, spray paint, inking, or zinc 
powder marking.

MARK_OFF -- The code to tell the controller to turn the marking head off.

MARKOFFSET_ON -- The code to tell the controller to offset the tool head for the marking head.
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MARKOFFSET_OFF -- The code to tell the controller to turn the marking head offset off.

RAPID_ON -- The code to tell the controller to use fast travel for all further movements. Used for ESSI only.

RAPID_OFF -- The code to tell the controller to use regular slow feed rate travel for all further movements. Used for ESSI 
only.

DWELL -- The code to tell the controller to dwell. Include dwell time if necessary.

IGNORE_ON -- The code to tell the controller to start ignoring some lines.

IGNORE_OFF -- The code to tell the controller to stop ignoring the code.

ARC_DIMENSION_TYPE -- The format for specifying arcs. Normally IJ defines the center of the arc; however, some 
controllers use R for radius (values can be IJ_FORMAT or RADIUS_FORMAT). Not using this setting defaults arc types to 
IJ_FORMAT. For G-code only.

ARC_ABS_INCR -- Determines if the controller outputs an arc’s IJ center point in absolute coordinates or incrementally 
from the start point. (Values can be -1 for absolute or INCREMENTAL for incremental). For G-code only.

CNC_FILE_FORMAT -- Used to output CNC files in binary or UNIX format (without LINEFEED character added to end of line 
character). Set to BINARY for binary format, otherwise set to -1.

PROGRAM_STOP -- The code to tell the controller to stop processing.

SIGN_IJ -- Adds a + sign to the I and J codes for positive values.

CUT_CODE_AFTER_MOVE -- With this flagged as YES, the code to start cutting is placed at the end of the movement line. 
Currently this is limited to the Bystronic controller.

FIRST_CUT -- This code is inserted before the first cut code.

FIRST_MARK -- This code is inserted before the first mark code.

CUT_SETUP -- This code is inserted before the cutting code. This is typically only inserted at the very start of cutting. But if 
marking is inserted between cuts then the cut setup code is inserted before the second cut.

LINE_MARK_SETUP -- This code is inserted before marking to be able to configure the marking process. This is typically 
only inserted at the very start of marking. But if cutting is inserted between marks then the mark setup code is inserted 
before the second mark.

Bevel Specific
TORCH_CONFIG -- If you have set up any multiple-pass bevels in ShipConstructor, add this item to your controller code file 
and set to 1_TORCH_MULTI_PASS. Only nested parts that have at least one multiple-pass bevel will be processed as a 
multiple-pass part. All other parts will be processed as single-pass parts.

BEVEL_ANGLE_ON -- The code to tell the controller to rotate the bevel torch.

BEVEL_ANGLE_NEXT -- The code to tell the controller to rotate at the end of the segment (variable bevel cutting).

BEVEL_ANGLE_OFF -- The code to tell the controller to rotate the bevel torch to vertical.

PLATE_THICKNESS -- The code for specifying the thickness of the plate for determining bevel cut.

TANGENTIAL_CONTROL_ON -- The code to tell the controller to turn on the tangential control.

TANGENTIAL_CONTROL_OFF -- The code to tell the controller to turn off the tangential control.

TANGENTIAL_RETAIN -- Tells the controller to rotate to the next segment.

TANGENTIAL_TURN -- Tells the controller to rotate to the segment after the next one (look ahead). This is used in the 
corner loops.

HEIGHT_CONTROL_NO_WAIT_ON -- The code to tell the controller to turn on height control without the wait period.

HEIGHT_CONTROL_NO_WAIT_OFF -- The code to tell the controller to retain the current height.

HEIGHT_CONTROL_NO_WAIT_ON_AFTER_LEADIN -- A YES value indicates that the HEIGHT_CONTROL_NO_WAIT_ON code
will be placed after the lead in when appropriate: A NO value means the HEIGHT_CONTROL_NO_WAIT_ON code will be 
placed before the bevel code. The default value is NO.

BURNER_HEIGHT_CONTROL_WITH_FOOT -- Code for lowering the height sensor.
BURNER_HEIGHT_CONTROL_WITH_PLASMA_ARC -- Code for raising the height sensor.

AUTOMATIC_HEIGHT_CONTROL_ON -- The code to tell the controller to turn on automatic height control.

AUTOMATIC_HEIGHT_CONTROL_OFF -- The code to tell the controller to turn off automatic height control.
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BEVEL_TORCH_ON -- The code to tell the controller to turn the bevel torch on with a single head controller.

BEVEL_TORCH_OFF -- The code to tell the controller to turn the bevel torch off with a single head controller.

BEVEL_CHAMFER_HEIGHT – The code to specify the height of the nose on a chamfer cut with a single head controller.

LEFT_BURNER_ON – code to tell the controller to turn on the left burner of a multi-head controller.

LEFT_BURNER_OFF -- code to tell the controller to turn off the left burner of a multi-head controller.

LEFT_BURNER_UP -- code to tell the controller to raise the left burner of a multi-head controller.

BEVEL_ANGLE_ON_LEFT -- code to tell the controller the angle of the left burner of a multi-head controller.

BEVEL_CHAMFER_HEIGHT_LEFT -- The code to specify the height of the left burner of a multi-head controller.

RIGHT_BURNER_ON -- code to tell the controller to turn on the right burner of a multi-head controller.

RIGHT_BURNER_OFF -- code to tell the controller to turn off the right burner of a multi-head controller.

RIGHT_BURNER_UP -- code to tell the controller to raise the right burner of a multi-head controller.

BEVEL_ANGLE_ON_RIGHT -- code to tell the controller the angle of the right burner of a multi-head controller.

BEVEL_CHAMFER_HEIGHT_RIGHT -- The code to specify the height of the nose on a chamfer cut.

BEVEL_ANGLE_AFTER_ANGLE -- The code directly after the calculated bevel angle. This can be the ignore off code for 
controllers that encapsulate the bevel angle specification in ignore code.

BEVEL_ANGLE_PLUS_SIGN -- A YES value indicates that the angle code will be +45: A NO value angle code would be 45.
The default value is YES.

BEVEL_SIGN_CONVENTION -- The way to specify what the controller cuts when a positive bevel angle is input and what is 
cut when a negative angle is input. This setting applies to bevel angle codes and not bevel angles that are only values.

NEGATE_BOTTOM -- negates angle code values that are on the bottom side of the plate

NEGATE_TOP -- negates angle code values that are on the top side of the plate

NEGATE_NONE -- angles are left with their original sign as set up in ShipConstructor.

KERF_VALUE_PREFIX -- Code to prefix the kerf code when the kerf is required to change when the bevel angle changes. 
The value for the kerf is taken from the BEVEL_ANGLE_TABLE. 

FEED_RATE_PREFIX -- Code to prefix the feedrate code when the feedrate is required to change when the bevel angle 
changes. The value for the feedrate is taken from the BEVEL_ANGLE_TABLE.

KERF_CODE_CHANGE_POSITION -- Option to determine the position in the code where the kerf code for bevel cutting is 
inserted.

BEFORE_BEVEL_ANGLE –- The kerf code is placed before the bevel angle code.

AFTER_BEVEL_ANGLE -- The kerf code is placed after the bevel angle code

FEED_RATE_POSITION -- Option to determine the position in the code where the bevel cutting feedrate is inserted.

BEFORE_BEVEL_ANGLE -- the feedrate code is plate before the bevel angle

AFTER_BEVEL_ANGLE -- the feedrate code is plate before the bevel angle

BEVEL_ANGLE_POSITION -- Option to determine the position in the code where the bevel angle is inserted.

BEVEL_ANGLE_BEFORE_MOVEMENT -- The bevel angle is placed on the line before the movement of the beveled 
segment. This is the default.

BEVEL_ANGLE_AFTER_MOVEMENT -- The bevel angle is placed at the end of the first movement code of the 
beveled segment.

BEVEL_ANGLE_POSITIVE –- Some controllers do not use + and – to denote the sign of the bevel angle. This was added to 
support the KOIKE style of S1 for positive angles and S2 for negative angles.

BEVEL_ANGLE_NEGATIVE -- Some controllers do not use + and – to denote the sign of the bevel angle. This was added to 
support the KOIKE style of S1 for positive angles and S2 for negative angles.

BEVEL_OFFSET_PATH –- A Flag to indicate if the geometry is offset to account for a height in bevel cutting.  Possible 
values: YES, NO. The default value is NO.

BEVEL_TORCH_PIVOT_POINT -- A flag to indicate where the pivot point for the torch is located. This setting affects the 
offsetting on the path when BEVEL_OFFSET_PATH is YES. Possible values:
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PLATE_TOP –- Pivot point of the bevel head is at the height of the top side of the plate as it lies on the table.

PLATE_BOTTOM -- Pivot point of the bevel head is at the height of the bottom side of the plate as it lies on the 
table.

BEVEL_GEOMETRY_PLANE -- A flag to indicate where the geometry plane for the path is located. The geometry loaded 
into NC-Pyros and includes bevel cuts, the top side of the plate and the bottom side of the plate will have different paths. 
This setting indicates which side the geometry represents. This setting affects the offsetting on the path when 
BEVEL_OFFSET_PATH is YES. Possible values:

PLATE_TOP –- The geometry is the top side of the plate as it lies on the table.

PLATE_BOTTOM -- The geometry is the bottom side of the plate as it lies on the table.

BEVEL_LOOP_FEED -– Code to indicate the feedrate when in the bevel loop. Typically this is a slower rate to allow the 
bevel head to rotate.

Z_HEAD_ROTATION_ANGLE -– This code is the prefix for specifying the rotation about the Z-axis. This is only required for 
bevel cutting and controllers that do not automatically look ahead. This is typically referred to as the ‘C’ value.

BEVEL_ANGLE_INCREMENTAL -– A flag to indicate if the bevel angle in the code is a relative angle from the current angle 
position or an absolute angle. Possible values: INCREMENTAL, ABSOLUTE. The default value is ABSOLUTE.

BEVEL_PASS_ORDER -– A setting to indicate the order of the passes of a multi-pass bevel cut. An example would be 
BOTTOM_VERTICAL_TOP means:

Possible values: TOP_VERTICAL_BOTTOM, TOP_BOTTOM_VERTICAL, BOTTOM_TOP_VERTICAL, BOTTOM_VERTICAL_TOP, 
VERTICAL_BOTTOM_TOP, VERTICAL_TOP_BOTTOM. Default is BOTTOM_VERTICAL_TOP.

BEVEL_ANGLE_TABLE -– A table of bevel angles and the associated kerf values and feedrates. Each plate thickness is 
separated into separate sections. The section is started with a <THICKNESS>=platethickness line. Each angle row in the 
table is constructed of a semi-colon delimited line.

Each data row consists of:

desired bevel angle(number); bevel angle fed to machine(number); feedrate(number);kerf value(number);kerf code(string)

eg.
<THICKNESS>=6
-45;-45;4595;0.15;D4
0;0;6500;0.138;D3
45;45;4595;0.15;D4

Desired bevel angle -– The angle input in ShipConstructor. This must be a number.

Bevel angle fed to machine – on some controllers this value differs from the desired bevel angle depending on the shape 
of the flame and the angle of the torch to the plate. This must be a number.

Feedrate –- A number indicating the speed of the machine when cutting this angle. This number is combined with the 
FEED_RATE_PREFIX when placed in the code. This must be a number.

Kerf value –- The value of the kerf applied when cutting this bevel angle. This must be a number.

Kerf code –- The code to insert for this bevel angle. If this is value is left out then the kerf value is inserted. Some 
controllers use a ‘D’ code to represent kerf and this is intended to be used for that.

MESSER_INTERMEDIATE –- With this set to YES code is generated for the OmniBEVEL program from Messer. This should 
only be used with the Messer Intermediate Omnibevel.ECD code file. Possible values: YES, NO.

BEVEL_ANGLE_DECIMAL_PLACES –- an integer value of the number of decimal places to show when the bevel angle 
code is output (eg.  Value 0 results in 22.5 output as 23). The default is 0.
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BEVEL_ANGLE_DECIMAL_SHIFT –- an integer value of the number of times to shift the decimal point to the left for the 
bevel angle (eg.  Value 1 results in 22.5 output as 225). The default is 0.

BEVEL_HEIGHT_DECIMAL_PLACES -– an integer value of the number of decimal places to show when the bevel height 
code is output (eg.  Value 2 results in 0.375 output as 0.38). The default is 0.

BEVEL_HEIGHT_DECIMAL_SHIFT -– an integer value of the number of times to shift the decimal point to the left for the 
bevel height (eg.  Value 2 results in 0.375 output as 37.5). The default is 0.

Buge/Inkjet Specific
MARKER_TYPE – Possible settings:

INKJET - special inkjet marking codes are used.

INLINE – Mark text for Kinetic plasma marker L3[Ss][Rr][Aa][Hh][Ww] (s – size, r – rotation, a alignment, h – line 
height spacing, w - wrap width).

BUGE – For buge marking (Similar to DEFAULT without the parentheses).

DEFAULT – Creates Buge text output with parentheses around the text.

BUGE_TEXT -- The code to tell the controller to turn the BUGE text generator on.

BUGE_HEIGHT -- The code to tell the controller the size of the BUGE text.

BUGE_HEIGHT_PRECISION -– The precision in digits of the BUGE text height.

BUGE_TEXT_PREFIX -– The code that comes before the text that is marked. Sometimes text is surrounded by the ignore 
codes.

BUGE_TEXT_POSTFIX -- The code that comes after the text that is marked. Sometimes text is surrounded by the ignore 
codes.

BUGE_ENDSTRING -- The code that directly follows a marked buge string to indicate the end of the string

BUGE_ALLOWED_CHARACTERS -- The characters that can be used in a BUGE character string for the controller.

BUGE_STRING_ANGLE -- The code to tell the controller the orientation of the BUGE text.

BUGE_ANGLE_SIGNIFICANT_DIGITS -– The number of digits for the angle numbers (45.2 degrees would be 1)

BUGE_ANGLE_PRECISION -- The precision in digits of the BUGE text angle.

BUGE_START_ANGLE -- The angle, in degrees, from the horizontal (0 degrees in the X, Y coordinate system) to the angle 
that the controller knows as 0 degrees.

BUGE_AFTER_ANGLE -– The code that comes after the angle value. Intended to be used for the case where the ignore off 
code needs to be added after the angle for inkjet.

BUGE_OFF -- The code to tell the controller to stop generating BUGE characters.

TEXT_MARK_SETUP -– This code is inserted before text marking to be able to configure the text marking process. Some 
controllers that have inkjet printers require the inkjet marker to be selected and configured before marking. This is 
typically only inserted at the very start of text marking. But if line marking or cutting is inserted between text marks then 
the text mark setup code is inserted before the second text mark.

TEXT_ANGLE_ZERO_ONLY – Indicates that the angle of text markings is always 0 degrees.

Inkjet Specific
INKJET_MOVE_TEXTLENGTH -– If the INKJET is enabled, this setting controls whether there is a movement code insert. 
Possible values: YES, NO. 

INKJET_ROTATE_DWELL -– Tells the inkjet controller to dwell after the rotate.

INKJET_VERTICAL_ALIGNMENT -– If the INKJET is enabled, this setting controls whether a movement is added to align the 
print head with the center of the text or the bottom of the text. Possible values: BOTTOM, MIDDLE.

INKJET_TEXT_SIZE_FILTER -- A list of bounds to determine the specified text height code for an inkjet marker. Values are 
delimited by the ';' character.

LowerBound (number) ; Upperbound (number) ; InkjectTextSizeCode (string); InkjetTextSize (number)

NC-Pyros will search the list of conditions with the following logic:
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LowerBound <= TextSize < UpperBound  - When this condition is true, the text size code that corresponds is used. If no 
conditions are met then the Text Size code will be blank.

Sample
>INKJET_TEXT_SIZE_FILTER
0;7;T1;7
7;9;T2;9
9;12;T3;12  
12;14;T4;14  
14;500;T5;16

TEXT_ANGLE_LIMIT_TO_180 –- limits the text angle between 0 and 180 degrees. If the angle is greater than 180 degrees 
then the INKJET_TEXT_MIRROR code is inserted.

INKJET_TEXT_MIRROR –- The code that is inserted when the text angle is limited to 180 degrees and the angel is over 
180 degrees.

INKJET_MARK_ON –- A code to specify to the inkjet marker to start marking. This code appears directly before the 
movement of the head.

TEXTMARKER_PRETEXT – A code that directly precedes the text in text marking and is on the same line

ENABLE_HEIGHT_SENSOR_FOR_TEXT – Will enable the insertion of the height adjustment no wait on and off codes when 
text marking it taking place. Possible values: YES, NO.

TANGENTIAL_TURN_BEFORE_LEADIN – Inserts the tangential turn code before the lead-in movement code. Possible 
values: YES, NO.

START_SHAPE_WITH_HEIGHT_CONTROL – Controls the type of code inserted when a shape is started. Before this option 
was added height control with foot was inserted. Possible values: PLASMA_ARC, FOOT

BEVEL_ANGLE_NEGATE – Changes the sign of the bevel angle from positive to negative and vice-versa. Possible values: 
YES, NO.

TANGENTIAL_CONTROL_POSITION – Controls where the tangential control on code is inserted. Possible values: 
AFTER_KERF, DEFAULT

How to Interface with Messer OmniBevel
NC-Pyros provides and interface with Messer OmniBevel. Here's how it works:

1. Export the nest from ShipConstructor to NC-Pyros.

2. Process the nest in NC-Pyros using a special controller code file (Messer Intermediate Omnibevel.ecd).

3. Output a LOS file from NC-Pyros. This is a CNC file with special bevel encoding.

4. Import the LOS file into OmniBevel. This gets the part information into OmniBevel.

5. Some processing and checking work are required in OmniBevel. The processing path is setup in OmniBevel.

6. Save the CNC file for the machine.
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