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Help & Training from MPI Support 
 
Questions or comments about MPI’s products and services?  Log on to our website at: 

 
http://www.markovprocesses.com 

 
MPI User Name & Password 
 
Your MPI user name and password are both your MPI serial number, provided to you separately by MPI 
upon registration. In future, these may be found by selecting Help-> About in the main menu. Please 
remember both your user name and password are case-sensitive. 
 
Support 
 
E-mail 
 
If you have any questions or concerns, please e-mail our support team at 
support@markovprocesses.com. A support specialist will be in touch with you shortly to help answer your 
questions. You may also include files/attachments in your e-mail, and everything you send to this address 
is considered confidential. 
 
MPI Forums 
 
Our user forums are great repositories of general questions users have already asked (and answered.) 
You can log in to them at: http://www.markovprocesses.com/phorum/index.php. 
 
Phone 
 
908-608-1558 
 
MPI’s Support lines are available Monday through Friday from 9 AM to 6 PM Eastern US time. MPI’s US 
office is closed on US market holidays; during this period, there is generally a limited number of non-US 
staff dedicated to answering client inquiries. 
 
Manual and Help Menu 
 
The mpi Stylus Pro user manual and help menu may be found through the “Help” menu in the application. 
 
Training 
 
To see a calendar of our complementary web trainings, please visit our website at: 
 

http://www.markovprocesses.com 
 
You may register for any course by e-mailing us at training@markovprocesses.com. You may also 
contact us at this address if you would like to discuss other training options. 
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Section 1 
Installation Instructions 
 
This document will help step you through the process of installing and updating mpi Stylus Pro. Choosing 
the correct installation option for mpi Stylus Pro is crucial to quickly and efficiently getting your team up 
and running in the software.  
 
There are two types of installation for mpi Stylus Pro: 
 

1. Local Installation: the application is installed directly on one or more specific computers and all 
files created/stored in an installation are specific to the computer/drive. This is the typical option 
for small user groups or users who do not need to share studies/data with other users of the 
application. In the case of local installations, each user must: 

a. Install the application 
b. Update their own data 
c. Update the software as needed 
d. Back up files as needed 

 
Installing and Accessing mpi Stylus Pro Directly From the Network 
 
It is also possible to install mpi Stylus Pro on a network drive as if it were a “local” installation, 
with all users accessing the .exe file on the network drive, all files stored there, etc. However, this 
has some disadvantages that should not be ignored. For example, users may access the same 
files and save/overwrite one another’s work. It is highly recommended that users adopt either the 
traditional local installation or the network/workstation approach. 

 
2. Network/Workstation Installation: Individual configuration settings are put in place to allow access 

to shared network folders and private local drive folders. For this configuration setting, the 
network connection must be available for the user to launch/run mpi Stylus Pro. This is the typical 
option for users who need to share studies/data with other team members. 

 
Migrating a Local Installation to a Network Installation 
 
If you are interested in migrating your local installation to a network/workstation setup, please see 
the instructions on page 13. This applies only to existing installations; new users should continue 
with the information below. 

 
To provide better insight into which installation option is appropriate for you, please consider the table 
below:  
 

 Local Network/Workstation 
Application installation Individual PC Both PC and Network 
Data Updates Done individually by each user Done by one user and linked 

to by PCs 
Performance Speed Fastest access to files/data Will depend on location of file 

being accessed 
Study Sharing Difficult; requires sending files 

to other users 
Depends upon local or 
network location of file; users 
may have access to some 
files but not others 

File Security High; only the individual user 
has access 

High for individual, low for 
network 

Backup Concerns Data can be lost if computer is 
not backed up 

Backup must be maintained 
for both network and PCs 
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Important Note for Installations 

 
In order to install mpi Stylus Pro on your PC and/or network, you must have appropriate read/write access 
to the drives in question. If you do not, this must be resolved with your IT department internally; MPI is 
unable to resolve read/write issues, network problems, etc. 
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Section 2 
Local Installation Instructions 
 
To install mpi Stylus Pro on a PC (hard drive): 
 
1.  Start the installation wizard by executing (double-clicking) the installation file provided in 

the Welcome Package. In the first screen select the “Local” option: 
 

 
 
 
2.  Specify the location (including drive letter) for the Stylus folder that will be created. The 

recommended default is C:\Stylus\. 
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3.  Individual databases (data folders where your personal studies/files will reside) are created on 
each user’s PC. If you feel you do not need one or more listed default databases, you may 
uncheck them at this time. It is recommended that you install all databases at this step. 

 

 
 
4. Click the ‘Install’ button to install mpi Stylus Pro. This may take a few minutes. 
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5. Once you see the final screen below, click ‘Finish.’ The final step will be to locate your mpi  
Stylus Pro license file (which will have been provided to you by MPI) and to save it directly 
to your root Stylus folder (for example, to C:\Stylus\). Once this is completed, you may launch 
mpi Stylus Pro. Please keep in mind that you must now proceed to the Update Procedures 
portion of installation, detailed on page 15 of this document. 
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Section 3 
Network/Workstation Installation Instructions 
 
To install mpi Stylus Pro on a network, there will be two stages to the software install. First you will install 
it at the network location, and then on individual workstations. 
 
Network Install 
 
1.  Start the installation wizard by executing (double-clicking) the installation file provided in 

the Welcome Package. In the first screen select the “Server” option: 
 

 
 
2. Specify the location on the server (including drive letter) for the Stylus folder that will be 

created. Once this is completed, please proceed to step 3 of the Local Installation 
instructions (page 6) and follow the steps from there. 

3. Now, it will be important to install and update all databases on the network copy of Stylus 
in order to avoid having to do this for each installation. This will be necessary if the ‘Copy’ 
option will be used for the stylus.ini file in the workstation install. For the ‘Link’ option, databases 
may be installed at any time. 

4. Once the installation is complete, proceed to the Workstation Install below and complete 
the install for each computer that will use mpi Stylus Pro. 
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Workstation Install 
 
Once the network version has been installed, you may proceed to install the application on each 
workstation. To perform a workstation installation: 
 
1. Start the installation wizard by executing (double-clicking) the installation file provided in 

the Welcome Package. In the first screen, select the “Workstation” option and click ‘Next’. 
 

 
 

 
 
 

2. The next screen will ask to choose one of two options: Copy or Link. Click ‘Next” after you 
make your selection. 
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Link 
 

The Link option is our recommendation for all network/workstation installations. When you link the 
local .ini configuration file to the network’s .ini file, you have the ability to add databases to the 
network so that all users may automatically access them. This means that databases may be 
added or removed at the network level and all user installations will reflect these changes. 
 
Copy 
 
When the Copy option is selected, the configuration file from the network is copied to the local 
computer at the time of the initial install. This means that any changes made to the network’s .ini 
file after the initial install will not be reflected on a user’s computer unless the network .ini file is 
again copied to the individual PC. In cases where the Copy option is used, the user is responsible 
for updating databases. Before selecting the Copy option, it is recommended that all databases 
on the server be downloaded and configured to minimize the need for additional manual changes 
at the workstation level. 

 

 
 
3.  Specify the Stylus folder location on the server (1) and local workstation (2). Make sure to 

include the appropriate drive letter. 
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4. In addition to shared databases located on the server and accessible by other users, individual 

databases (data folders where your personal studies will reside) may be created on each user’s 
workstation. Uncheck any boxes for folders you do not need and click ‘Next’ to complete 
the installation. 
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5. Click ‘Install’ to begin the Installation process. This may take a few minutes. 
 

 
 
 

 
 
 
6. Once the installation has finished, click ‘Finish’ to close the wizard. You may now proceed 

with downloading and updating your data (page 15). 
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Migrating a Local Installation to a Network Installation 
 
These steps will help users who wish to migrate a local installation to a network/workstation setup. The 
optimal way to accomplish this is to have individual Stylus.ini files on each workstation. To do this: 
 

1. Create a network installation if you do not already have one. 
2. Copy the network .ini file to: C:\Stylus\stylus.ini on each individual PC. 
3. If you do not have a shortcut to mpi Stylus Pro on your desktop, create one at this time. 
4. Right-click on the shortcut to the network installation and select ‘Properties.’ 
5. Click the ‘Shortcut’ tab. 
6. In the ‘Target’ field, type in: N:\Stylus\stylus32.exe -I C:\Stylus\stylus.ini keeping in mind 

that “N” should be replaced with whatever your network drive letter is, and “C” may need to 
be replaced if another letter is used for your local drive. Please ask your IT team for details if 
you are unsure. 

7. Click the OK button to accept the changes. Now, when you use this shortcut to start mpi 
Stylus Pro, it will use the local .ini file to record any changes to the mpi Configurator settings. 
You can also create local study or template databases and configure them appropriately 
without having them shared on the network. 

 

 
 

8. In the interests of efficiency, you will still want to make sure your databases are configured to 
the appropriate network. Please open mpi Stylus Pro and go to File-> Configure. 
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9. Click on the Linked Database List field and select N:\Stylus\stylus.ini (shared 
configuration.) Please note that in the event of conflicting database IDs (i.e., a database on 
the local installation and a database on the network both have ID XYZ), the local .ini file’s 
database will be used. 

10. Remove all shared databases from the “local” configuration (i.e., databases from Manager 
Series, Index Series, etc.) 
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Section 4 
Update Procedures 
 
There are two types of updates available for mpi Stylus Pro: updates for the application and updates for 
the underlying data. In both cases, always make sure to close mpi Stylus Pro before fully running an 
update. Our mpi Updater tool has a built-in option to close the application before running updates. 
 
mpi Stylus Pro Software Updates 
 
MPI regularly updates our software to introduce new features, verify and fix bugs, etc. It is strongly 
recommended that all users periodically update mpi Stylus Pro in order to avail themselves of the most 
powerful, stable version of the application available. Updates are available at the following link: 
 

http://www.markovprocesses.com/securedata/updates/updates.htm 
 
When prompted to type in your user name and password, use your mpi Stylus Pro license number for 
both fields (it is case-sensitive.) The License number, build date and package subscription information 
can be found under Help-> About in the application. 
 
Database Updates 
 
No databases are included/updated in the Stylus installation file or in application updates, so once the 
application is installed it is still necessary to download and update any databases to which your firm 
subscribes. The frequency with which these should be updated will relate to the data frequency (i.e., 
monthly, daily, etc.) The complete update schedule may be found at: 
 

http://markovprocesses.com/securedata/updates/MPI_DatabaseUpdateReference.pdf 
 
mpi Updater (Tools-> mpi Updater) 
 
To update your data through the application using the mpi Updater tool, please refer to Chapter 9 (Helpful 
Stylus Tools) in the mpi Stylus Pro User Manual. Please note that security settings at some companies 
may include firewalls that prevent the mpi Updater from working properly. In these cases, the web site 
update approach should be used instead. 
 
Updating via the MPI Web Site 
 
You may update your data (one database at a time) through the MPI web site. Due to security settings at 
some companies, this may be the only update option as some firewalls prevent the mpi Updater Tool 
from working properly. 
 
You may also wish to examine the possibility of automating your web updates. Information may be found 
at:  
 

http://www.markovprocesses.com/securedata/updates/mpi_Web_Updater_Batch_Mode.pdf 
 

To update specific databases via our web site: 
 
1. Go to our web site at http://www.markovprocesses.com and select Support-> Updates. 
 
2. Identify the database you wish to update and click the link to download or run the 

associated .msi file.  
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3. If you are installing data for a Local installation, please select “Update Data” and click 
‘Next’. If you are installing data for a Network/Workstation installation, please select 
“Update Configuration Settings” and click ‘Next’. 

 
Local Installation 

 
 

Network/Workstation Installation 

 
 

6. Once the update runs, click ‘Finish’ to close the wizard. You may now open mpi Stylus Pro 
and use your updated data. 
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