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Getting Started 

System Requirements 

What are the System Requirements for eValid? 

• Windows NT/2000/XP 
• Latest Microsoft Service Packs (Windows & I.E.) 
• Internet Explorer 5.5 or later 
• At least 64 MB Available RAM 

Do I need to have I.E. installed?  

Yes, eValid requires the presence of at least Internet Explorer 5.5 as eValid makes 
use of the libraries contained within I.E.  

Architecture 

What is important about eValid?  

The advantages of using eValid are:  

• Testing the web page from a browser 
• Point and Click Recording. All user interaction is recorded in the script. 
• Script Language. eValid scripts are recorded in a simple command based 

format and is easily viewable in a text editor. 
• Full Featured Suite 

What are the useful facts to be informed about when using eValid?  

Useful facts to apply when using eValid is:  

1. Functional Testing 
2. Load Testing 
3. Performance Testing 
4. Site Analysis 

Installation 

How do I install eValid?  

Follow the steps outlined below in order to successfully install eValid:  

1. Double Click on the eValid installer (eValid40.exe) if you have downloaded 
the program from our website or, insert the eValid CD in your CD ROM 
drive and double click the eValid install icon.  

2. The “Welcome to the Install Shield Wizard for eValid” page is displayed. 
Click “Next” to proceed.  

3. Carefully review the “eValid – SOFTWARE PRODUCT LICENSE 
AGREEMENT”. Click on “Yes” if you agree to the terms and conditions of 
the license.  

4. Select a directory where eValid will be installed. The default setting will 
install eValid in “C:\Program Files\Software Research”. Click “Browse” to 
install in another location.  
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5. Choose the appropriate options for your eValid installation. Click “Next”.  
6. As soon as eValid completes the installation, review the installation results. 

Click “Next”.  
7. Click “Finish”.  

GUI Basics 

How do I start recording a test?  

To start recording a test, follow these simple steps:  

1. Click on the red button on the upper right hand side of eValid -or- Access 
the eValid menu (Record > Start Recording).  
-or- 
 By pressing F4 to start recording. 

2. You will be prompted to enter a name for the test you are about to create. 
3. Perform a series of actions in the site you are testing. 
4. Stop recording by pressing the Stop button on the upper right hand side of 

eValid.  
-or- 
Press F4 to stop recording. 

How do I play back my script?  

To start playing back a test, follow these simple steps:  

1. Press the play button on the upper right hand side of eValid  
-or- 
Access the eValid Menu (Playback > Start Playback).  
-or- 
Press the F6 key.  

Preferences 

How do I access the eValid Preferences?  

Use one of two ways to open the eValid Preferences:  

1. Press Ctrl + F2. 
2. Click on the Settings Menu, and choose the appropriate preferences 

desired. 

How do I access and control the cache manager?  

Use one of two ways to open the eValid Cache Manager:  

1. Press F2. 
2. Click on the Settings Menu, and choose the Cache Manager. 

Can I save different sets of preferences?  

You can save a specific set of option from the eValid Profile Manager. Follow the 
steps below in order to save your settings to a profile.  

Can I save different sets of preferences?  
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You can save a specific set of option from the eValid Profile Manager. Follow the 
steps below in order to save your settings to a profile.  

1. Select the options that you want to be included in the profile. 
2. Click on Profiles 
3. Click Save Profile. 
4. Enter a unique name for the profile you are creating. 
5. Click on ‘Ok’ 
6. Click on ‘Apply/Save' 

Files 

What are evs/evl files?  

1. An evs file is the test that is produced from the recording. 
2. An evl file is a Load Test that is created from the original script file (*.evs) 

Where did I save the script I recorded?  

By default, the script is saved under the eValid Project directory unless otherwise 
specified in the preferences.  

What other files are produced by eValid?  

Other files produced by eValid are the Event Log, Error Log, Performance Log, and 
the Timing Log  

User Manual 

Where do I find the eValid User Manual?  

The eValid User Manual can be accessed through eValid by clicking "Help > 
Documentation > User Manual".  

Is there a local copy of the eValid User Manual?  

As eValid continually evolves, we are also continually updating the user manual to 
reflect changes made in the product making it unsuitable to include local copies.  

Is there a hardcopy version of the manual?  

A PDF Document of the Online User Manual is available for downloading.  

Getting Help 

How do I reach Technical Support?  

You can reach eValid Technical Support by sending us email at support@soft.com 
or by giving us a call at 1-800-942-SOFT. If you’re having trouble with a script or a 
recording simply send us a copy of the script and our Technical Support Staff will be 
glad to help you out.  

Do I have to pay for Technical Support?  
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Users doing an EVAL of eValid are entitled to free Technical Support. However, 
users who use REVENUE keys must be subscribed to maintenance support to avail 
of Technical Support.  

License Key Issues 

I get an error saying "Unable to locate evalid.lic. Identify license file to process?” 
How do I resolve this?  

Make sure that your license key is in the proper directory as well as the eValid 
executable.  

I get an invalid, corrupted, or expired license message. How can I resolve this?  

Make sure that your license is still valid by opening it in a text editor and checking 
the expiration date. Do not alter anything in the license file as the key is encrypted.  

For support with you current license, send us email at licenses@e-valid.com  

My license file seems to be valid but I still keep on getting the invalid, corrupted or 
expired message. What else can I do?  

If you had a previous installation of eValid and had it installed in a different location 
other than the default location, follow these simple steps to correct this issue:  

1. Locate the win.ini file in your windows directory. 
2. Open the file using a text editor. 
3. Look for the eValid entry: 

[eValid] 
LicenseFile=%PATH% 
LicenseCheck1=%VALUE% 
LicenseCheck2=%VALUE% 

4. Remove the current path and the values of the eValid3 license file 
properties. 

5. Save the win.ini file 
6. Run eValid 

eValid Usage Issues 

Can I use eValid as a regular browser?  

Yes, eValid can be used normally as a browser.  

Can I use eValid with other versions of Windows?  

As a full featured test enabled web browser, we have only tested eValid with 
Windows NT/2000/XP. We cannot guarantee accurate results or proper operation 
from running eValid in operating systems not mentioned above.  
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Functional Testing 

Basic Concepts 

What is Regression Testing?  

Regression Testing is a retesting of a software system that has been modified to 
ensure that any defect that has been fixed and that no other previously working 
functions have failed as a result of changes made within the software.  

How Is Regression Testing Performed?  

Regression testing is performed after a developer has attempted to fix a recognized 
problem or has modified the source code to a program that may have introduced 
errors. It is a means of Quality Control to ensure that the added code complies with 
the software requirements.  

How is the eValid script recorded?  

An eValid script is created by recording the series of interactions that the user 
performs as commands that are appended to an ASCII text file.  

Will I be able to edit the script commands easily?  

Yes, the recorded script commands can be easily edited in a text editor or in the 
eValid script dialog box.  

How does eValid report errors during playback?  

Errors that occur during playback are reported through a Playback Data Dialog, 
which launches the appropriate log files, which contains the error report.  

How are the reports displayed?  

The reports are displayed in ASCII, html, or graphical formats.  

What is the level of detail of the reports?  

eValid can produce simple log, standard logs, or detailed logs. The level of detail 
the log file produce can be set in the eValid preferences.  

Recording 

How do I view the script I am recording?  

Use one of two ways to view a script:  

1. Press Ctrl + Alt + S 
-or- 

2. Click Window > Script Window 
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Can I edit the script while I am in record mode?  

Yes, the script can be edited or altered during recording.  

How do I record sub-windows?  

Sub-windows can be recorded using the normal recording functions of eValid or by 
turning on the Application Mode Recording feature of eValid. In some cases 
however, there are certain options needed to be set in order to produce the correct 
recording.  

Are there any special settings to record sub windows?  

When recording sub-windows, turning on the absolute mode recording features is 
also necessary at times in order be able to record within the sub-window.  

Advanced Recording 

What is a Modal Dialog?  

A modal dialog puts the user in a state of being able to work only inside the dialog 
box. It temporarily suspends all other actions in an application. It forces the user to 
dismiss the modal dialog by creating choices for the user to select in order to 
proceed with a specific action. Most often, Modal Dialogs are added to confirm a 
change that the user will be making.  

How do I record clicking a Modal Dialog?  

Modal Dialog interaction can be recorded by adding special commands from the 
eValid. The commands are located in the script window, "Insert > Modal Dialog 
Commands" and can be inserted during recording or during edit mode.  

How do I record Applets?  

Applets can be recorded by the use of the Advanced Recording features in eValid, 
which contain the controls for applet recording.  

How do I record Applications?  

You can turn on Application Mode Recording using one of two ways:  

1. Turn on Application Mode Recording (F12). 
-or- 

2. Click " Record > Advanced Recording > Application Mode" 

Validation 

 What is a Validate Command? 
 

During recording the tester can note (validate) certain features of pages that are automatically 
checked during playback. Validation modes include text, images, checksums of image parts, 
page properties, etc. 

What are the different validation modes of eValid?  
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The different validation modes of eValid are:  

• Validate Document Properties. 
• Validate Selected Text, Image, and Table Cell. 
• Validate All Images, Applets, Element ID's, Body Te 
• Validate & Save Window Face, Window 
• Validate & Synchronize Screen Rectangle, Text String 
• Validate Clipboard Text 

What should I not validate?  

Objects in a page that change constantly are not recommended to be validated as it 
will cause an error/warning to be displayed in the log files.  

 

Playback 

What are the different playback modes available to eValid?  

eValid can be run in Single Step, Synthesized, or Run Multiple mode.  

How important is the wait multiplier in a playback  

Controls the speed of playback. Normally, the intervals you record are played back 
exactly as you recorded them. the wait multiplier multiplies the recorded delays by 
any number you choose. Entering a wait multiplier of 0 results in a script without 
delays.  

How can I change the wait multiplier?  

The wait multiplier can be changed through the preferences ("Settings > 
Record/Play Preferences")  

Preferences 

What is available in the preferences?  

The eValid preferences contain the following options to change eValid's settings:  

• Record Mode 
• Playback 
• Load Test 
• Log Management 

.  

Advanced Preferences 

What is available in the advanced preferences?  

The Advanced Preferences contain the options:  
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• Absolute Events 
• Applet Recording 
• Keyboard Recording 
• Window Save & Validation 
• Synchronization Options. 

Log Files 

How do I select which log file I want produced?  

Options in eValid can be set to produce only the relevant log files for the test. 
Follow these simple steps to change the options in the log management area of the 
preferences:  

1. Click on Settings > Record/Play Preferences > Project/Log Management 
-or- 
Press Ctrl + F2 to access the eValid Preferences 

2. Under Project/Log Management, check or uncheck the logs that you want 
eValid to produce/hide. 

How can I view the logs as HTML files?  

Follow these steps to view the log files as HTML.  

1. Bring up the log dialog window. 
2. Click View >  HTML Table  

-or- 
Press Ctrl + Alt + H  
-or- 
Click on the "View Data as HTML Table" button in the log dialog screen. 

How can I view the logs graphically?  

Follow these steps to view the logs as graphs.  

1. Bring up the log dialog window. 
2. Click View > Graph (Single or Multiple)  

-or- 
Press Ctrl + G (for Single)  
-or- 
Press Ctrl + Alt + G (for Multiple)  
-or- 
Click on the "Graph One"  
-or- 
"Graph All" button in the log dialog screen. 

Test Data Generation 

What is Data Synthesis?  

eValid data synthesis playback mode allows a single parameterized script to play 
back many instances with parametric values selected from a simple user-assigned 
value table  

How is data generated using data synthesis?  
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Data Synthesis playback retrieves data from a simple line by line table  

What is eV.Generate?  

eV.Generate is a utility that creates eValid script files based on placing either 
sequentially or randomly chosen selection values from a user supplied table into a 
script file  

How does eV.Generate differ from Data Synthesis?  

In Data Synthesis, data choices are specifically deterministic and constrained, vs. 
all combinations or random selections ran from eV.Generate.  

Charts 

 What types of charts are produced from playback of a script? 
 

A user has the option to display chart information from the most current run alone or from past multiple runs. 
Follow these simple steps to view the charts generated: 

 
1. Click on Window > Graph (Single) 

-or- 
2. Click on Window > Graph (All Logged) 

-or- 
3. Click on Window > Log > Load Test Graphs (For Load Test) 

 
 Are there charts for each type of Log produced by eValid? 
 

Yes, each log file produces a chart illustrating the data gathered for a specific chart. 
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