
Reform To Email                                                                                         
 

 

                                                                

12/07/2009 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Reform To Email                                                                                         
 

 

                                                                

Table of Contents 

Using Email Features .......................................................................................................3 

System Requirements .....................................................................................................3 

Hardware Requirements .................................................................................................3 

Installation ......................................................................................................................4 

Plugin Registration and Licensing ....................................................................................4 

Email Server Types ..........................................................................................................5 

Reform Email Monitor Service.........................................................................................5 

Setting up your First Email Enabled Form ........................................................................7 

Descriptions of Setup Wizard Fields .............................................................................. 22 

Descriptions of Designer Email Fields ............................................................................ 22 

Maintenance................................................................................................................. 23 

Troubleshooting ............................................................................................................ 24 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 



Reform To Email  3 
 

 

                                                                

Using Email Features  
Reform can send emails by communicating with email servers. Emails can contain text, 

html, or attachments.  Combining Reform with an email server allows the delivery of 

documents processed by Reform to various recipients.  By sending the information via 

email, paper costs are reduced and delivery and response delays are decreased. 

 

System Requirements 

• Reform 12 Enterprise or Reform 12 PDC 

• Reform Email Plugin 

• For Evaluation and Demonstration: Windows XP, Windows 2003 Server, 

Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are 

Supported) 

• For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit 

Operating Systems are Supported) 

• Microsoft .NET Framework 3.5 (this will be automatically installed if the installer 

does not find it on the system) 

• Microsoft SQL Server (SQL Server Express will be automatically installed by the 

Email installer if it is not present on the current system) 

 

All required Reform software downloads can be found at www.fabsoft.com >> 

Downloads section. 

Hardware Requirements 

• Production System Recommendation (These suggestions are only estimations. 

High load environments may require multiple servers, or additional hardware.) 

1. Pentium 4 Processor 

2. 4 GB RAM 

3. HDD Space 100 GB (Redundancy recommended) 

4. Battery Backup (UPS) 

5. Dedicated server, no other software products except for virus and 

security programs. 

• Minimum System Requirements for demonstration purposes only 

1. Pentium 4 Processor 

2. 2 GB RAM 

3. HDD Space 30 GB 

 

Hardware specifications depend greatly on the workload and throughput that is 

required.  Higher end processors and greater amounts of memory will increase the 

amount of information and data that Reform can process thus improving overall system 

throughput.  For load balancing or failover, multiple servers can also be used. (Note: A 

license for Reform and each plug-in is required for each server running the software.) 

http://www.fabsoft.com/
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Before obtaining the server that you plan on utilizing for Reform, please check the plug-

ins’ user manuals for System Requirements as well as they may require additional 

hardware.  For production systems, we also recommend redundant hard drives utilizing 

the mirroring features of RAID (Redundant Array of Independent Disks) to minimize data 

loss and expedite system recovery in the event of a hardware failure.  Battery backups 

are also suggested to maintain system uptime and reliability in case of power failures.     

 

Installation 
To install the Email plug-in to your existing Reform 12 installation, download and run the 

Email installation executable. 

 

 
 

The installer will launch. There is no pre-configuration required to install the plug-in, so 

click Next and the process will begin. If SQL Server Express is not installed on your 

system, it will be automatically installed. This typically takes between 10-20 minutes 

between downloading the application and installing it. If the Microsoft .NET Framework 

3.5 is not already installed on your system, it will be automatically downloaded and 

installed.  After the installation is complete, click Finish. The Email plug-in is now 

installed. 

 

The default installation directory for Reform 12 and its plugins is C:\Program 

Files\Reform…\.  If you have changed the path during the Reform installation routine, 

or if you are using a 64 bit operating system, please refer to the appropriate path 

instead of the default one referenced throughout this documentation.  

 

 

Plugin Registration and Licensing 

When evaluating Reform 12, the plugins will also be in an evaluation mode for that 

period of time.  Once Reform has been purchased and licensed, the required plugins 

must also be licensed in order to continue functioning correctly.    

 

Please see the “Reform 12 Licensing and Registration” section of the Reform 12 User 

Manual for more information on how to license Reform 12 Plug-ins.  After the license is 

entered, the Reform Spooler will need to be restarted to refresh the licenses. More 

information regarding the Reform Spooler Service can be found in the Reform 12 User 

Manual. 
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Email Server Types 

The Reform Email plugin integrates with multiple email server types.  It currently has the 

ability to communicate seamlessly with SMTP, Exchange 2003, Exchange 2007 and 

Exchange 2010.  When configuring your email workflow using the Workflow Designer, 

you will be given the option of choosing the email server type you would like to 

configure.  Depending on which type is chosen, you will be prompted for different 

required and optional email server settings.   

 

 

Reform Email Monitor Service 
The RM_Email_Monitor service is installed by the Email installation routine.  This service 

monitors a database table that is populated by the Email send to script in order send 

emails.  Using this method, a record is kept of all sent emails.  Also, emails can be resent 

automatically if they failed to be sent at the email server. 

 

IMPORTANT: The RM_Email_Monitor Service must have local administrative privileges 

in order to function correctly (Cannot be run as Local System or Network Service).  To 

change the service logon account, go to Start > Programs > Control Panel > 

Administrative Tools > Services.  Right click on RM_Email_Monitor and select 

Properties. 

 

 
 

Navigate to the Log On tab.  Here, you will need to set the local administrative service 

logon account. 
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Select the “This account:” option.  You can manually enter the account credentials or 

use the Browse… button to search for one.  Once you have entered the correct 

credentials, click OK to save your changes.  If the service is already running, it will need 

to be restarted by stopping and starting the service.  If the service is not started, please 

start the service after configuring an administrative logon service account. 
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Setting up your First Email Enabled Form 

Setting up a new or existing form to connect to an email server and send emails is a 

simple process that utilizes the Workflow Designer, a form creation and configuration 

tool. The setup will allow you to set static (unchanging) values for various fields (such as 

the subject line, message body, recipients, etc), or you can use text objects mapped in 

the text layer to dynamically change values. 

 

To start the tutorial, the Reform Designer must be opened.  To open it, go to 

Start>Programs>Reform…>Designer. 

1. For the example, we will be creating a new form with an existing template. Go to 

File>New>New. Select the Email.FTM template and click OK. 

 

 
 

2. When it asks if you would like to open a text file for designing, select No. 

 

3. Next, go to File>Save to save your form. Name it Email.FOM. 

 

4. You can now close the Reform Designer since we have a form which we will be used 

with the Workflow Designer to route the document. 

 

*Now that we have our form, we can begin to configure the desired Email workflow 

using the Workflow Designer.  First, the Workflow Designer must be started.   

5. To open it, go to Start>Programs>Reform…> Workflow Designer. 

6. Once open, we must go to File > New… 



Reform To Email  8 
 

 

                                                                

 

7. Select “Document Automation” and click Ok. 

 
8. You will now notice that your Inputs, Processes and Outputs have been populated by 

the various plug-ins you have installed (Email being one of the Outputs) 
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9. We can now start adding the necessary components to the workflow.  First, drag 

and drop a Form and File object onto the workflow by clicking and holding your 

mouse on Form and File and then moving your mouse over to the workflow and 

releasing the mouse button.  

 

*You will be prompted with a dialog to describe the input. 

 

10. Enter a description for the object you just added.  This is done by typing in the 

provided box.  Type “Email Demo” and click Finish. This will take you back to your 

workflow. 
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11. Now we are ready to configure the “Email” form and input file.  To do so, right click 

on the newly added object and select “Configuration…” or simply double-click it. 

 

12. You are now presented with the Input Setup window.  First, we want to select the 

TextFile or data stream that our form will be using.  To do so, you can simply begin 

typing in the box, or you can browse to find it.  We want to select the Email.out file 

which is located in the \Reform\Backups directory.  Click the small folder icon to 

bring up a window which will let us choose that file.  Select the file and click Open.   

 



Reform To Email  11 
 

 

                                                                

13. After choosing the text file, you are taken back to the Input Setup page so that you 

can now select a form.  Click the small folder icon to bring up a window which will 

let us choose the desired Email.FOM form file.  Select the FOM file and click Open.  

 
 

14. Now that you have both your Input Text File and Reform Form selected, the setup 

of “Form and File” is complete.  You can quickly double check that the correct files 

are selected and then click Finish.  
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15. You will also be prompted to add a page-break field to the forms.  At this point, we 

want to select No. 

 

16. To finish the Email workflow, we want to add an Email Output.  We use the same 

drag and drop procedure as with the “Form and File” (see step 9).  Take your 

mouse and drag the Email object from under Output onto the workflow 

somewhere below your Input.  Once you release your mouse, you will be prompted 

to describe Email.  Type “Email” in the box and then click Finish. 

 

 

17. Once you click Finish, you are taken back to your workflow.  Your Email will have a 

Red Caption because it is not yet configured. To configure Email, you must first 

connect the “Form and File” object titled “Email Demo”.  To do so, first select the 

“Add Connector” button from the menu bar.  Next, drag your mouse from the 

small “x” underneath “Email Demo” to the small “x” above “Email” as pictured 

below. When the connection is complete, the connecter will turn black (if red, 

connection has not been made correctly, try again) and the “Email Demo” caption 

will turn green. 
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18. You will be prompted to configure Email upon completing the connection.  Click 

Yes.  If you click No, you can also double click on the Email object or rightclick on 

the object and select “Configuration…” at a later time.  This configuration will step 

you through all the settings necessary for Email to work with your email server. The 

first piece of information is the file type you want your email attachment to be.  

Select “PDF File” and click Next. 

 

 
 

19. You are then prompted for the Email Server Type.  Using the drop down box, you 

can choose which email server type you will be using to send out emails .  

Depending on the type that you select, you may be given different email server 

options.  For demonstration purposes, we will be selecting SMTP.  Click Next once 

you have selected your Email Server Type. 
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20. For the example, we will be using data that is already present on the print stream. 

Some of the information you will need to enter will be dynamically populated 

directly from objects mapped on the text layer. The following screen will ask you to 

enter the address of your Email Server. Since this is a static value, you can manually 

enter your Email server information. Click Finish. 
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21. You are now prompted for the Email Server Domain.  This is an optional setting but 

should be entered if required for your environment.  For the demonstration, we will 

skip it.  Click the Skip button to continue. 

 

 
22. The next screen will ask you for the Email User Name. If your Email server requires 

authentication, enter the username now and click Next. If it does not require 

authentication, click Skip. 
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23. The next screen will ask for the Email Password. Again, if your Email server requires 

authentication, enter the password here and click Next. If it does not, you can click 

Skip. 

 

24. The following screen asks for the email address that the email will be sent from. 

Here we would like to use data that is available in the data stream instead of a 

static value.  To do so, we first must click the “Click here to select variable 

information” button.  
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*Note-After doing so, we see that a list will appear with the different fields that you can 

choose for your variable data.  If you want to go back to static input mode, you can do 

so by clicking the appropriate button for static information and then typing it in. 

 

25. Now we want to use ContactPersonEmail as our “Email From” value.  Select 

ContactPersonEmail from the list. You will have to scroll down to see it. Click Next. 

 
26. The next screen will ask for the email address that the email should be sent to. Enter 

an email address that you can check (Ex. your own personal email address). Click 

Next. 
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27. Next, it will ask you to enter email addresses for Carbon Copies. Click the Skip 

button. 

 

28. Next, it will ask you to enter email addresses for Blind Carbon Copies. Click the Skip 

button. 

 

29. Next, it will ask you to enter the Return Email Address. Click the Skip button. 

 

 

30. Next, it will ask for the email Subject. Select the object Remark. To select an object, 

first click “Click here to select variable data” and then the object list will be shown.  

You will have to scroll down to see Remark. Click Next. 

 

 
 

31. Next, it will ask for the file name of the attachment. Enter the value EmailBill. Click 

Next. 
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32. The last screen will ask for the message body of the email. We want to select the 

object BillingNote.  To select an object, first click “Click here to select variable data” 

and then the object list will be shown. Select BillingNote from the list.  Click Finish. 
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33. You have completed configuring your simple Email workflow.  Your 2 objects 

(“Email Demo” and “Email”) should both be green meaning they have been 

successfully configured and the workflow is ready to be created. 

 
 

34. To make all the appropriate forms and changes, we must execute the workflow.  

This is done by clicking the “Execute” button  on the menu bar.   After 

execution, you will be notified of the configuration that has taken place.  Click OK. 

 

 

 

35. You can now close the Workflow Designer.  When prompted, you may save your 

workflow so that you can go back to reconfigure it at a later time. Your form has 

been saved in your default forms directory.  A backup of your original Email.FOM 

file has been copied to the “Workflow Designer Original Forms” folder in your 

forms directory.  Any permanent form changes should be made to this original 

form as it is used throughout the form configuration process as a template.  If any 

updates or changes are made to this template, you must execute the workflow 

again for your changes to appear in the forms. 
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36. To test out your settings and make sure that emails can be sent, first we should open 

the form with the Reform Designer.  Navigate to your Forms directory and double 

click on Email.FOM.  When asked to open the associated TextFile, click Yes.  

 

37. Verify that the special fields exist on the right hand side of your form.  Then go to 

File>Print. Reform will use the information on the objects that were just added to 

your form to process and send the email. 

 

 
 

The email should be sent to whichever address you entered for the EmailTo during the 

configuration with the Workflow Designer. The time it takes for the email to be sent will 

vary depending on the speed and workload of the email server you are using. If you do 

not receive an email after a minute or two, verify that the RM_Email_Monitor service is 

running and has the correct service logon account.  For more information about the 

service, please see the Reform Email Monitor Service section. If the service is running 

and you’re still not receiving emails please refer to the Troubleshooting section of this 

manual.  This concludes the basic setting up and sending of an email. To experiment 

with more advanced options such as carbon copies and blind carbon copies, read on to 

the next section to learn about different fields and how you can work with them to 

perform more advanced email operations. 
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Descriptions of Setup Wizard Fields 
The setup wizard can be run by going to File>Page Setup, and then by clicking the Setup 

button in the bottom of the window under Send To Devices.  You can also access this 

setup by using the Workflow Designer to reconfigure the objects you just added. 

• Email Server – This is the name or IP address of the email server that emails will 

be sent from. 

• Email User Name – If your email server requires authentication, the user name 

to authenticate with is entered here. 

• Email User Password – If your email server requires authentication, the 

password to authenticate with is entered here. 

• Email From – When a user receives an email, this is who the email will appear to 

have been sent from. 

• Email To – The email address that the email will be sent to. If you are entering 

multiple email addresses, separate them with commas. For example: 

user1@fabsoft.com, user2@fabsoft.com, user3@fabsoft.com.  

• Email CC – In this field, one or several email addresses may be entered to have 

the email carbon-copied to different email addresses. Email BCC – Same functionality as 

Email CC, except this will blind carbon copy everyone on the list. Separate multiple email 

addresses with a comma. 

• Return Email – Specifies the return address when a user replies to an email they 

received from the Reform Email plug-in.  

• Subject – Specifies the subject of the email that will be sent out by the Email 

Plug-in. 

• File Name – Sets the file name of the email attachment. 

• Notes – The message body of the email. 

 

Descriptions of Designer Email Fields 

The following is a list of available email fields. These fields are found under the Special 

Fields menu. 

1. EmailTo: This field is used to capture the email address of the recipient. This 

can be used on the Text Layer or on the Design Layer. When used on the Text 

Layer, it will use the email address that this object highlights. When used on 

the Design Layer, you can supply a static email address, or, use the Company 

Look-up option to fill in the email address.  Please see the Reform Manual for 

more information about Lookups.  

 

EmailTo object on the Text Layer 

 
 

mailto:user1@fabsoft.com
mailto:user2@fabsoft.com
mailto:user3@fabsoft.com
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(EmailTo objects on the Design Layer will show up as special fields with red 

text) 

  

2. EmailFrom: This field is used to supply a specific sender’s email address. This 

object can be used on both Text and Designer Layers. 

3. Subject: This field is used to supply a subject for the email. 

4. Notes: This field is used to include any information that you may want to add 

to the body of the email. 

5. Company Lookup: This field is used to find an email address and other 

information in the Lookup Database. This field can be used on the Text or 

Design Layer. If the EmailTo field is empty, Reform will use the Lookup 

Database to find the email address. If you wish to use only the Lookup 

Database, place the EmailTo field in the Design Layer and remove the text 

information in the object. 

System Specific Fields: Some systems have fields that will need to be added manually. 

To add the fields manually, add a Design/Linked Text Object to the appropriate layer 

and rename the text object accordingly. For more information on the system specific 

field, please refer to the email system’s respective section. 

 

Maintenance 

There are certain directories and SQL tables that need to be monitored for growth along 

with the Email plugin for Reform 12.  As a system processes more and more jobs, the 

size of these directories and SQL tables can grow very quickly.  Overall system 

performance can be affected by the large amounts of space that the files may take up.  

Also, there exists a 4GB database limit if using the Microsoft SQL Server Express 2005 

supplied with this installation. Obsolete files/database entries should be deleted 

according to your needs and file retention specifications.  It is recommended to monitor 

the following directories and SQL tables for growth: 

 

Directories: 

C:\Program Files\Reform…\Backups 

C:\Program Files\Reform…\Spooler\ImageQueue 

C:\Program Files\Reform…\Plugins\Email \Attachments 

 

SQL Tables: 

Reform_Email_Status 

Reform_Email_Trans 
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Troubleshooting 
Q: The SMTP server cannot be reached. 

A: The first thing that you should do if you are not receiving emails is test to see if the 

SMTP server is functioning properly and can be reached from the Reform server. Telnet, 

which may not be installed by default on all systems, can be used to verify connectivity. 

If installed, go to Start>Run, enter cmd, and press OK. In the command prompt, type: 

 

telnet <your smtp server here> 25 

Example: telnet mail.yourcompany.com 25 

 

and press Enter. You should see a connection established message in the command 

prompt, similar to the one below: 

 

 
 

If you cannot connect to your SMTP server on port 25 (the default SMTP port), then the 

server is not reachable from the Reform server, and as such, the email will not be able 

to be sent. 

 

 

Q: The SMTP server is rejecting my authentication username/password. 

A: Be sure that you entered the username and password correctly in the setup wizard. 

To do this, open up your form in the Designer, go to File>Page Setup, and click the Setup 

button under Send-To Devices. Step through the prompts of the setup wizard and check 

to make sure the values are correct for authentication. 

 

Q: Where can I view the Exchange 2003 webmail interface? 

A: The URL is http://<EMAILSERVERNAME>/Exchange/.  This will prompt you for a 

username and password. You can also try 

http://<EMAILSERVERNAME>/Exchange/<USERNAME or USERALIAS>/ 

 



Reform To Email  25 
 

 

                                                                

Q: Nothing is happening after the form is processed. How can I determine the cause of 

an issue? 

A: Check the Event Log for errors related to Reform or the Reform Email Service.  The 

Event Log can be access by going to Control Panel > Administrative Tools > Event Log.   

This will usually give you a good idea about why the emails might be failing.   

 

Note: If the error below occurs, Go to Control Panel > Administrative Tools > Services 

and try using a different account to run the ReformEmailService, such as your windows 

local administrator account.  To change the log on information, right click on 

ReformEmailService>Properties>Log On tab and type in the account you want to use. 

Click Ok and restart the service. 

 

 
 

Q: Emails are not being received; no authentication is required on my SMTP server. 

A: Check the relay settings on your SMTP server to ensure the Reform server has the 

appropriate permissions.  Also make sure that any fire/anti-virus software is disabled. 
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