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Host PC Minimum Requirements 
                          -100% IBM compatible 
                          -233 MHz processor       
                          -128MB RAM 
                          -100 MB hard disk space 
                          -CDROM or DVD drive 
                          -web access to always on email account 
                          -modem with access to analog phone line 
                          -Windows XP operating system 

Complete these Steps in order!! 
1. Connect components via Serial Cable 
2. Configure S3A Unit 
3. Configure Host PC 
4. Installation 
5. Using the S3A 

S3Analyzer Minimum Requirements 
                          -110 VAC 
                          -analog phone line for remote monitoring 



Product Description 
 
By incorporating the S3Analyzer (S3A) into an elevator installation, you will be able to perform advanced diagnostics and 
monitoring of the elevator. 
 
The S3A is an intelligent, versatile, remote fault finder with diagnostic capability. Each S3A has 16 inputs that can be con-
nected to an elevator controller at specific points that correspond to known signals. These known signals, read by the 
S3A, can be nearly anything from Car Start to a Safety String signal. These signals can be compared to one another by 
creating rules. When a rule is violated, you can be notified via email. 
 
The S3A connects to a dedicated standard analog telephone line. The S3A will initiate a call to any host PC location via 
an analog telephone line and will notify the software on the host PC of any user defined occurrences. 
 
The host PC running the S3A software will readily receive any S3A data calls. The software contains several windows to 
display relevant information, including which remote unit is calling or has called in and why they called. You may also view 
live data coming from the remote S3A unit in an easy to read, constantly updating and scalable graph, or oscilloscope. 
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NOTE: You must program each S3A you intend to install PRIOR to installation! 

NOTE: The S3A system must be connected to an ANALOG phone line for Remote Monitor-
ing! 
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Glossary 
 

Throughout this manual we will use terms that may not be familiar to you. The following is a list of 
these terms and their definitions: 
 
S3A Remote Unit - this is the black metal box that that you will install in the control room near the desired controller. The 
Remote Unit will receive signals from the controller. 
 
STF (Signal Treatment File) - a configuration of known/defined inputs and sequence definitions for analyzing these inputs. 
Wurtec supplies multiple STFs for select control systems. 
 
Sequence Definition - a sequence definition is a comparison of signals through time. There is a beginning and an end 
and depending on how you setup your sequence the unit can notify on an incomplete or complete sequence. The se-
quence can define how something should occur every time and checks that it does so or a sequence can define what 
should never occur. 
 
Input - signals that are attached to the S3A at any of its sixteen inputs. These inputs are selected for appropriate se-
quences or an input can be a simple counter that is not part of any sequence. 
 
State - states are the status of a signal. The status can be either high (on) or low (off), or as stated in binary: 0=low, 
1=high. 
 
Communications Event Window - displays information on communications between the PC and the S3A 
 
System Event Window - displays information about actions performed by the PC software 
 
ID EEPROM - contains information on the identity of each S3A, including its name, password and associated phone num-
ber 
 
Host PC - abbreviation for Personal Computer. The S3A requires a PC to run the software and to communicate with it 
(see PC requirements on front cover). The Host PC must have an analog modem, be connected to an analog phone line 
and have an always on internet connection to receive/send emails. 
 
RTI (Real Time Interrupt) - This is a timing feature of the processor that allows for timing measurements. One RTI = 4.6 
milliseconds.  
 
MON (Minimum On Time) - a timing parameter used to set the minimum time a signal must be on to be considered valid 
 
MOF (Minimum Off Time) - a timing parameter used to set the minimum time a signal must be off to be considered valid 
 
Cycle Count Threshold - the number of times an input must change from low too high before you will be notified. This 
option is good for monitoring cycle counts for usage based maintenance. 
 
Site Name - the name (alpha-numeric) used for where the S3A unit will be installed, normally a building or customer 
name. For example, “Wurtec” or “EngBldg”. This name is limited to 9 characters. 
 
Unit Name - the name (alpha-numeric) used for S3A unit, normally specific to the elevator/escalator that the S3A is con-
nected to. For example, “6200 Brent Drive” or “escalator#4”. This name is limited to 31 characters. 
 
Unit Number - the unique number (numeric) used for identifying the S3A unit. The Unit Number is used throughout this 
manual for programming various functions and must be 5 digits. 
 
CalledInEvents folder - notifications (like Clock Reset) and/or emailed attachments containing time stamped information 
 
Events folder - contains events manually saved while in Live On mode 
 
Email folder - when email notifications are pending they reside in the Outgoing folder; after they are sent a copy resides 
in the Sent folder 
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When you first open the loaded S3A PC software, two windows open up within the main window. 
These are the Communications Event Window and the System Event Window. All activity will 
happen within these windows. See image above. 
 
The gray box at the top of the main window displays current information about the state of the sys-
tem. The top line, “Input/Sequence File”, indicates what Signal Treatment File is currently loaded in 
the host PC software. The second line, “Connection State”, tells the user how the host PC software 
will attempt to contact a remote S3A unit once a command is selected, or if there isn’t a connection. 
The third line, “Live State”, tells the user whether or not the host PC software is currently accepting 
live data from the remote S3A unit. The bottom line, “S3A Unit Name”, indicates the name of any cur-
rently connected remote S3A unit, once a “Dial remote S3A Unit” command has been issued. 

Before setting up your S3A, make sure the software program is loaded onto your PC and running. 
 
The S3A Software CD should automatically load when inserted into the CD slot of your host PC. If it 
does not then you will have to load the software manually. To do this insert the CD into the host PC 
CD drive slot. Open Windows Explorer and access the CD drive. Then simply double click the S3A 
setup “.exe” icon. 
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S3A UNIT CONFIGURATION—Getting Started 



STEP 1 

Connect the S3A to the PC with the supplied Serial Cable. Next connect the power cord into the S3A 
and plug into a 110VAC source. See Figures 1A and B. 

FIGURE 1A FIGURE 1B 

NOTE: Make sure power is being supplied to the S3A by looking at the power light. It should be lit 
bright red. If the Serial Cable is connected but not the Power Cable, the light may be dimly lit. 

CONNECT CABLES 
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S3A UNIT CONFIGURATION 

 
Now connect the remote S3A unit to a computer and begin! 

When power is supplied to the S3A, it will immediately try to call into the Host PC through the modem. 
You should see the message in Figure 1C. 

FIGURE 1C 



FIGURE 2E 

FIGURE 2D 

FIGURE 2C 

STEP 2 

Click Communications→Direct Connect To S3A. This sets the S3A software to communicate 
through the serial cable to the computer you are using to perform the setup. See Figure 2A. 
 
Click Action→Read S3A Clock. See Figure 2B. This verifies the connection is established. You 
should see the time displayed in military style. You will see a default time from the S3A and may not 
be accurate. 
 
If you do not see the time displayed, check that your connections are made properly and the Serial 
Cable is connected to the correct port in the PC by clicking Communications→Choose Direct 
Connect Serial Port. See Figure 2C. 
 
To determine which comm port is needed, right-click “My Computer” on your desktop and click 
“Properties”. Next click the “Hardware” tab then the “Device Manager” button. See Figure 2D. From 
the list of hardware click “Ports” to find the designated port number. See Figure 2E. 

FIGURE 2A 

CONNECT THE SOFTWARE 

FIGURE 2B 

S3A UNIT CONFIGURATION 
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STEP 3 

Click File→Open S3A Input/Sequence File. 
Choose an .STF file from the selection dialog box that matches your elevator controller. See Figures 
3A and 3B. If none match, proceed to page 22 Creating A New .STF File. 

FIGURE 3A 

Open an STF 

FIGURE 3B 

Highlight and click OK. You will see a response in the System Event Window indicating “Inputs 
Loaded OK” and several sequence loaded responses. You may need to scroll up to see this 
message. See Figure 3C. 

S3A UNIT CONFIGURATION 

NOTE: Since many controllers are modified per job, and because you may wish to monitor different 
inputs, these prewritten STFs may not be perfect for you but they can be modified to suit your needs 
and/or coincide with your controller. If you need to modify our STFs or wish to create a new one, pro-
ceed to CREATING A NEW .STF FILE on page 22.  
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FIGURE 3C 



STEP 4 Updating the ID EEPROM 

Click Action→Update S3A ID EEPROM. See Figure 4A. 
 
Create a unique .NLF file name (we recommend using the Unit Number) and click Open. See Figure 
4B. 
This will cause a dialog box to appear titled S3 Analyzer Configuration Dialog. This is where you 
will uniquely identify your S3A. See Figure 4C. For your convenience there is a S3A DATA CHART 
at the end of this manual for entering all the information for each of your S3A units. 

FIGURE 4C 

FIGURE 4B 

S3A UNIT CONFIGURATION 

FIGURE 4A 

NOTE: The grayed fields are not accessible.  
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NOTE: If you don’t create an ID EEPROM you won’t be able to save sequence or event infor-
mation at a later time. 



STEP 5 

In the Site Name field, we recommend assigning a name for the building or complex where the re-
mote S3A unit will be installed. For example, “Wurtec”. Abbreviate when necessary. 
 
In the Unit Name field, assign a name for the remote S3A unit. For example, “6200 Brent-esc#4”. 
See Figure 5. 

Identifying Your S3A 

FIGURE 5 

S3A UNIT CONFIGURATION 

In the Unit Number field enter the number used for naming the NLF in the previous step. This must 
be a five (5) digit number not starting with zero (0). The Unit Number will be used repeatedly to set 
up the S3A throughout this manual and is the unique number used to initially identify the S3A when it 
calls into the Host PC. 
 
NOTE: Notice the character limits for each field! 

NOTE: Enter the information in these fields onto the “S3A DATA CHART” in the appendix 
section of this manual and keep for your records! 
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STEP 6 

The next field is for a Password containing up to 15 characters of your choice. By choosing to enter a 
password, the password will be require to change information. For your convenience there is an S3A 
DATA CHART at the end of this manual for entering all of the information for each of your S3A units. 
NOTE: Entering a password is not necessary. See Figure 6. 

FIGURE 6 

Password 

S3A UNIT CONFIGURATION 

NOTE: Enter the information in this field onto the “S3A DATA CHART” in the appendix sec-
tion of this manual and keep for your records! 

STEP 7 

In the Host Phone Number field, you will enter the modem phone number of the Host PC this re-
mote S3A unit will call. Pauses can be entered by using a comma (,). Each comma is 2-3 seconds 
long. For example, if the unit needs to dial a 9 to get an outside line, you would enter 
“9,4195551212”. See Figure 7. 

Host Phone Number 

FIGURE 7 

NOTE: Do not change the information in the field named “Modem Initialization 
String”! 

DO NOT CHANGE! 

10 



S3A UNIT CONFIGURATION 

Notice the check box titled “Send Notification On Standby Mode Change.” By enabling this fea-
ture, you have the option to send an email notification every time the Standby button is pushed. See 
Figure 8. 
 
To setup the email for this notification proceed to Creating Email Notifications on page 16, Step 1.  

STEP 8 

The Standby Mode On Time feature allows authorized personnel or mechanics working on the 
equipment to put the unit in standby mode so that the unit does not report any unnecessary errors 
that may be generated during normal maintenance. 
 
The Standby Mode can be activated or deactivated by pushing the button on the side of the remote 
unit or remotely with the software by clicking Action→Set S3A Standby Mode. When activated the 
red light on the side of the S3A box will blink. 
 
You may change the length of time the unit remains in Standby Mode by entering the number of 
SECONDS, not hours, in the field. Once the time has expired the unit will automatically switch out of 
Standby Mode. The default amount of time is 10800 seconds (3 hours). See Figure 8. 

Standby Mode On Time 

NOTE: Enter the information in these fields onto the “S3A DATA CHART” in the appendix 
section of this manual and keep for your records! 

After completing these tasks, a box will appear 
stating you must reset for system changes to take 
effect. Click OK. See Figure 9B. 

FIGURE 9A 

FIGURE 9B 
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STEP 9 Send Notification Check Box 

Click OK. A box will appear asking to load system 
information into S3A unit EEPROM. Click Yes. 
See Figure 9A. 

FIGURE 8 



S3A UNIT CONFIGURATION 

Click OK then click Action→Reset S3A Unit.  
 
Next click Action→Set S3A Clock, then Action→Read S3A Clock. The time displayed in the Com-
munications Event Window will reflect the time on your computer. 

Click Action→Update S3A Input/Sequence. See Figure 10A. 

FIGURE 10A 

STEP 10 Load an STF into the S3A 

When the update has been successful, a pop-up box will appear reminding you that you need to reset 
the S3A for the changes to take effect. See Figure 10B. 

FIGURE 10B 
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NOTE: The next section will address entering phone numbers for the Remote S3A Unit. The 
S3A DOES NOT need to be connected via analog telephone line in order for use. You can 
connect a laptop to the S3A using the supplied serial cable AT THE JOBSITE and all infor-
mation will be saved to the hard drive for your later review. In this respect the S3A will serve 
as a fault finder. 



S3A UNIT CONFIGURATION 

STEP 11 

In order to access a remote S3A you must choose the desired S3A phone number. Each S3A will 
have a designated phone number needed to gain remote access through an analog modem and 
phone line. All S3A phone numbers are kept in a dialog window titled S3Analyzer Phone List Man-
ager.  
 
Click Edit→S3A Phone Numbers. See Figure 11A. 

Enter Remote S3A Unit Phone Number(s) 

FIGURE 11A 

You will see the dialog box below. See Figure 11B. Click Add. 

FIGURE 11B 
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S3A UNIT CONFIGURATION 

Clicking Add will make the Phone Record Editor dialog box appear. See Figure 11C. 

FIGURE 11C 

REFER TO FIGURE 11D FOR THE STEPS BELOW! 
Unit Name 
Enter the name of your remote S3A unit in the Unit Name (from page 9, Step 5) field. 
 
Phone,,,Unit Number 
Enter the phone number of the remote S3A in the “Phone,,,Unit Number” field. If the host PC needs 
to dial a 9 to get an outside line enter “9” and a comma followed by the phone number for the S3A. 
Commas are used to insert 2-second pauses. 
 
Following the S3A’s phone number is the Unit Number with three commas in between. You may 
need more or less commas depending on your phone system. Commas are used to insert 2-second 
pauses which allows the S3A time to pick up. 
 
When sharing a line with two or more S3Analyzers make sure the Unit Number entered in this field 
matches the Unit Number entered on page 9, Step 5. 
 
Password 
If you chose previously (page 10, Step 6) to use a password, enter it in the Password field. These 
two passwords must match exactly. 
 
Notes 
Finally, enter a message into the Notes field to further identify the unit. 
 
Click OK when finished. 

FIGURE 11D 
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S3A UNIT CONFIGURATION 

STEP 12 Enter Remote S3A Unit Phone Number(s) 

Now you will see the phone number for the remote S3A entered in the Phone List Manager window. 
To add additional S3A phone numbers simply click the Add button. To choose the unit you want to 
communicate with, highlight and click OK. See Figure 12. 
 
There are Edit and Delete buttons that will edit or delete the highlighted information. 

FIGURE 12 

The remote S3A unit has now been configured to your controller! 
 
The next section, S3A HOST PC SET-UP, will explain the more complex features of 
the S3 Analyzer. 
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STEP 1 

When the remote S3A unit detects a user defined occurrence in any of the sequences chosen during 
page 7, Step 3, the software will send a user defined message describing the error to any e-mail ad-
dress(es). You can have all notifications from a particular S3A sent to one email address or you can 
have only specific faults sent to an address. 
 
NOTE: This email feature will also work with many cell phone text messaging services, as long 
as you follow that carrier’s procedures for text messages originating from an email. Informa-
tion detailing how emails can be converted to text messages can normally be found on your 
cell phone provider’s website. 

Creating E-mail/Text Message Notifications 

FIGURE 1A 

Click Edit→Email Notifications. See Figure 1A.  

FIGURE 1B 

S3A HOST PC SET-UP 

The Email Notification Administrator box appears. See Figure 1B. This is where the emails you 
have set up will be listed. With the three buttons in the upper left you can add, edit or delete email 
notifications. 
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FIGURE 2A 

S3A HOST PC SET-UP 

STEP 2 

Click the Add button and a box titled Email Notification Record Edit will appear. See Figure 2A.  
 
Unit Number 
Enter the S3A Unit Number, from page 9, Step 5, into the Unit Number field. For example: 00001. 
 
NOTE: Only one (1) Unit Number can be entered at a time in this field. 
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Sequence/Input ID 
At this point you need to decide what type of email notification you would like to receive. The software 
will recognize six (6) suffixes entered into the Sequence/Input ID field. They are: 
 
           Sequence_Incomplete - prompts an email when a sequence is found incomplete 
 
           Sequence_Complete - prompts an email when a sequence is found complete 
 
           Input_Count - prompts an email when an input’s start count threshold is exceeded 
 
           Clock_Reset - prompts an email when an S3A unit’s clock has been reset 
 
           Standby_On - prompts an email when the standby condition has changed from off to on 
 
           Standby_Off - prompts an email when the standby condition has changed from on to off 
 
Words in BOLD MUST be entered EXACTLY for the software to send an email prompt. Enter the 
sequence or input of your choice in front of the top three suffixes, replacing the words in italic. See 
Figure 2B on page 18 for an example using all six email suffixes. 



ADVANCED SET-UP S3A HOST PC SET-UP 

Enter the desired Sequence ID into the Sequence/Input ID field. See Figure 2C. 
 
You can find the Sequence ID you are looking for by clicking Edit→S3A Sequence Definitions. The 
Sequence Manager dialog box will appear. See Figure 2D. This will show all available sequences 
for the STF chosen earlier. For this example we will enter the power sequence “MCE-T-pwr”. 
 
Another option is to enter an input definition ID to receive an email notification when a cycle count is 
exceeded. See Step 3, page 24 for more details on Cycle Counts. 
 
NOTE: Only one (1) Sequence/Input ID can be entered at a time. 

FIGURE 2C FIGURE 2D 
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FIGURE 2B 



S3A HOST PC SET-UP 

Enter the To and From persons/places and email addresses into their respective fields.  
 
The From Email Address is the designated email address of the host PC you are using with the re-
mote S3A unit. See Figure 3. 
 
NOTE: Only ONE “To:” and “From:” address can be entered at a time in this field! 

FIGURE 3 

STEP 3 
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ADVANCED SET-UP S3A HOST PC SET-UP 

To locate information needed for the fields discussed in this step you will have to access the email ac-
count of the Host PC. 
 
            To locate this information click Tools→Accounts in your default email program. Highlight your 

email account and click Properties. This will bring up the Email Properties window. Click the 
various tabs to find the information for these fields. If these steps do not work you will need to 
contact your Internet Provider or Network Administrator. 

 
Enter your email system’s user name into the User Name field.  
 
Enter your email password into the Email Password field.  
 
Enter the Smtp Port number for the outgoing server.  

STEP 4 

The remaining fields, Subject and EMail Message, are similar to common email programs. 
 
Enter the subject in the Subject field. 
 
Enter the message to be sent in the Email Message field. 
 
Refer to Figure 4 for an example. 
            
When finished click OK. 

STEP 5 

FIGURE 4 
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STEP 6 

S3A HOST PC SET-UP 

Once back to the Email Notification Administrator box, make sure to enter your email server name 
into the Outgoing Server field at the bottom of the box. If this is not entered correctly, the email WILL 
NOT be delivered. 
 
           To find your Email Server Name, click Tools→Accounts in your default email program. 

Highlight your email account and click Properties. This will bring up the Email Properties 
window. Click the Servers tab and look for Outgoing Mail Server name. If these steps do not 
work you will need to contact your Internet Provider or Network Administrator. 

 
To email the message to multiple addresses, simply click ADD and duplicate the information with the 
addition of the new address. Create an entry for each person that you want to be notified via email in 
the Email Notification Record Edit box. See Figure 6. 

FIGURE 6 

Last, choose the authentication needed in the Authentication drop-down. We suggest trying LOGIN 
first however, you may have to check your account settings or contact your internet provider if this 
does not work. 
 
When you are finished adding, editing, or deleting email notifications, click OK. 
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S3A HOST PC SET-UP 

Click  File→New. 
This clears any currently defined input and/or sequence definition records loaded on the computer 
but does not affect any information located at an S3A. 

FIGURE 1 

CREATING A NEW .STF FILE 

Input Definitions 

If you found an .STF file that matched your controller in Step 3 on page 7, skip this section and pro-
ceed to page 34, S3A INSTALLATION. 
 
If you did not find an STF file that matches your controller, you will need to create one. The .STF file 
is composed of Input Definition(s) and Sequence Definition(s). A Sequence Definition is composed of 
Input Definitions and states over time. First, we will demonstrate how to create Input Definitions and 
then how to create Sequence Definitions. 

STEP 1 
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STEP 2 

S3A HOST PC SET-UP 

Click  Edit→S3A Input Definitions. See Figure 2A. 
A box titled Input and Event Definition Editor will appear. Use the Previous and Next buttons in the 
lower right corner to navigate through the 16 available inputs. See Figure 2B. 
 
We recommend giving these inputs names that are easily recognizable. For example, if the power 
signal is on the 2 terminal on the controller, then name the input 2-pwr. 

FIGURE 2A 

FIGURE 2B 
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STEP 3 

S3A HOST PC SET-UP 

The Inputs Available at the top of the box displays how many inputs are available. Just below, the 
active input number is displayed which will change as you click the Previous and Next buttons. 
 
The two available fields, Minimum On Time (RTI) and Minimum Off Time (RTI), should not be altered 
without a thorough understanding of how they work. Changing these times could dramatically af-
fect the performance of your S3A. 

FIGURE 3 

The last field to enter is Cycle Count threshold. This is the number of times an input changes from a 
low state to a high state before you may be notified. If you choose to be notified, enter the number 
you desire and click the button at the bottom “Notify when event count threshold is exceeded.” 
When the threshold is reached an email will be sent. If you do not click the button, you will not be 
emailed but will instead have a notification displayed in the System Event Window. 
 
Repeat the above steps for all required inputs by clicking Next. Click OK when all inputs have been 
completed. 
 
In the Save As dialog box, name the .STF file your inputs will appear under. Typically this will be 
your controller name. Click Save. 
 
You have now completed defining your inputs. Next you will define your sequences. 

NOTE: One (1) RTI = 4.6 milliseconds 
             Ten (10) RTI = 46 milliseconds 
 
A higher RTI number = more de-bounce 
time. 
 
A lower RTI number = less de-bounce 
time. 
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Click for notifications! 



S3A HOST PC SET-UP 

STEP 1 

FIGURE 1 

At S1, 18-saf (safety string) goes low while 2-pwr (power) stays high. If you click the S1 box to highlight it, you 
would see that there is no Maximum Time (RTI) allowed specified. This means that at S0 (state zero) the ana-
lyzer will indefinitely wait for the safety string to go low. Keep in mind that when you highlight a state, the RTI 
figure is for the timing parameters of the preceding state. For example, when you highlight S2 the 100 RTI 
means that if 18-saf doesn’t return high within .46 seconds the S3A will prompt the host PC to create a safety 
notification. 
 
At S2, 18-saf has 100 RTI (.46 seconds) to return high before the sequence fails to complete and the S3A initi-
ates a call to the Host PC for notification of a safety string fault. Using a maximum time on the last state here is 
important for de-bouncing signals. If you enter a number that is less than needed, you may get false-positives, 
meaning the S3A notifies of a non-existent fault. We recommend 100 RTI as a starting point for most control-
lers. 
 
When you click OK you will be returned to the dialog box of Figure 2, page 26. Here, select the sequence you 
just defined and click the Save button. After saving, click the File menu item and select either Save or Save 
As to save the Input/Sequence File you just created. If you alter an existing Input/Sequence File for a special 
case, it is recommended that you select the Save As option and rename so not to overwrite a pre-existing file. 

CREATING SEQUENCE DEFINITIONS 
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The following is an example to better illustrate how inputs and states create sequence definitions.  
 
A Sequence Definition is a comparison of signals through time. There is a beginning and an end and depend-
ing on how you setup your sequence the unit can notify on an incomplete or complete sequence. The se-
quence can define how something should occur every time and checks that it does so or a sequence can de-
fine what should never occur. 
 
Figure 1 is a look at the MCE-T-saf sequence used for comparing the safety circuit to the power circuit. 2-pwr 
is monitoring the power to the elevator and 18-saf is monitoring the safety string. In order for the S3A to begin 
evaluating this sequence both the power and the safety string signal must be high. If the power is low while the 
safety string is high at state zero (S0) the sequence will not be evaluated because the YELLOW line means it 
must match to begin evaluating. Put another way, if both inputs are not high the rule will continue to monitor 
them until they are both high. If the lines were GREEN in S0, and 2-pwr was high but 18-saf was low, it may 
be seen as a fault by the S3A. It will continue to monitor S0 until S0 becomes true (matches the sequence). 

RULES OF THUMB 
S0 Yellow = Don’t start looking for S1 unless S0 

is TRUE! 
 

S0 = Rule starting condition. 

If you need further guidance after reviewing this example, please call technical support at 800-837-
1066. 



S3A HOST PC SET-UP 

STEP 2 

Click  Edit→S3A Sequence Definitions. 
This will bring up a dialog box titled Sequence Manager. See Figure 2. The window should be 
blank. 

FIGURE 2 

Sequence Definitions 

Once you have read and understand the example on the previous page, start creating your se-
quence definition by following the steps beginning below. 
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STEP 3 

Click the New button and a dialog box titled Sequence Editor will appear. This is where you will be  
creating rules for the S3A unit to follow and selecting inputs that will be compared to each other. See 
Figure 3. 
 
On the left-hand side is a window titled Input Selection that lists the inputs you just defined in the 
previous steps. Double-clicking any of these inputs will add them to the Sequence Logic Map in the 
center. Ultimately, you will build a relationship of inputs and states over time. 

FIGURE 3 

S3A HOST PC SET-UP 

NOTE: If at any time during the configuration power is lost or interrupted, you will not lose your infor-
mation. Click Action→Retrieve S3A Configuration and continue where you left. 
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FIGURE 5 

S3A HOST PC SET-UP 

STEP 4 

FIGURE 4 
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Figure 4 demonstrates double-clicking “2-pwr” then “18-saf”. If you need additional inputs for the 
sequence definition (“rule”) you are creating, simply double-click another input. Be careful with the 
number of inputs you include per rule because it will get much more complicated to manage. We 
recommend breaking up a large sequence definition into multiple, smaller definitions. 

STEP 5 
Figure 5 demonstrates clicking “Add State” three times. If you need additional states for the 
sequence definition (“rule”) you are creating, simply double-click “ADD STATE”. Be careful with the 
number of states you include because it will get much more complicated to manage. We recommend 
breaking up a large sequence definition into multiple, smaller definitions. 



FIGURE 7 

STEP 6 

Remember that the S3A is only monitoring whether the inputs are open (low) or closed (high). 
Clicking above or below the red lines at each junction of an input and state will move them up or 
down to indicate a high, low or transitioning state. See Figure 6. 
 
The key to creating a successful sequence definition is to know what each input is doing compared to 
the other(s).  

FIGURE 6 

NOTE: If no line appears, click in center of box. 

S3A HOST PC SET-UP 

29 

STEP 7 

In the figure below, 2-pwr stays high while 18-saf starts high and goes low for a period of time then 
goes high again. To define how long 18-saf can drop low, click on S2 to highlight the box. The field to 
the right titled “Timing Parameters For The Preceeding State” is then activated. Enter a number 
that equals the maximum length of time 18-saf can go low without violating the rule. In this case the 
maximum time is 100 RTI (100 x .0046s(1 RTI) = .46s). 



30 

S3A HOST PC SET-UP 

FIGURE 8 

STEP 8 

Just above the “Timing Parameters for Preceeding State” field are two buttons that control 
notifications. By clicking on one or both you control whether a notification is sent to the software when 
a sequence is found complete or incomplete by the S3A unit. See Figure 8. 
 
When a sequence definition is complete it means that the signal monitored from the inputs matched 
what was programmed. When a sequence defintion is incomplete it means the signal monitored from 
the inputs did not match (broke the rule) what was programmed. 

STEP 9 

You can further define a sequence by moving the cursor over the line representing the input and 
RIGHT-CLICKING your mouse. Right-clicking on the line scrolls through the colors YELLOW, RED 
and GREEN. See Figure 9. 

FIGURE 9 

NOTE: If you do not click on either one of the choices above, the S3A will not prompt the host 
PC to create emails when a complete or incomplete condition is met. 



Green = the state is required 
Red = the state is ignored 
Yellow = state must match or else abort 
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S3A HOST PC SET-UP 

NOTE: We recommend that all inputs at state zero (S0) be set to YELLOW, otherwise you may 
receive notifications when there are no faults.  

STEP 10 

Green defines what the inputs should be doing and yellow defines the starting condition of those 
inputs before the S3A starts to monitor the rule. Another way to say this is a green line means that 
the signal state is required before moving to next state and a yellow line means that the signal state 
doesn’t have to match. If it doesn’t, it resets to S0. If it does, it will continue to the next state. See 
Figure 9. 
 
The red line, or MOMENTARY line, signifies an ignored state for that input and will evaluate as “don’t 
care”. In other words, a red line means that we don’t care what state that particular input is in. This is 
typically used when we need an input for a sequence definition, but the input does not factor into the 
rule until later states. 

STEP 11 

When you are finished defining the sequence, you must give it a name that describes what it will be 
monitoring. In Figure 11 the sequence was named “Safety_MCE-T.” 

FIGURE 11 
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STEP 12 

The last step in defining the sequence is deciding if, when 
viewing a notification, you want to view a portion of time 
before and/or after the event that caused the notification. If 
you want to save a snapshot around this event, click the 
button “Log Associated Events” and two fields appear for 
you to enter the number of seconds you would like recorded 
pre- and post-sequence. See Figure 12. We recommend no 
more than 10 seconds before and 5 seconds after. 
 
This snapshot of time before and after a recorded event will 
be emailed as an attachment. That attachment can be opened 
within the S3A software. You can view the information either 
in the Communications Event Window or in the Graph. 
 
For how to access the information in an attachment once an 
email is received, please refer to page 35 Opening Email 
Data Files in the User Commands section. 

FIGURE 12 

STEP 13 

Click OK when finished. The Sequence Manager window will appear with the new sequence in the 
Current Sequence Definitions field. To save the new sequence, highlight the name and click Save. If 
you are creating multiple sequences, create them FIRST then save them individually. See Figure 
13A. 
 
Each time you click Save, a reminder will pop up saying that you just saved the sequence. Click OK. 
See Figure 13B. 

FIGURE 13A FIGURE 13B 



S3A HOST PC SET-UP 

STEP 14 

Notice in Figure 14 that there are two fields labeled Current Sequence Definitions and Disabled 
Sequence Definitions and two corresponding buttons below. If after loading or opening sequences 
you would like to disable one or more sequence, you can do this by highlighting the desired sequence 
and clicking “Disable.” See Figure 14A. 
 
The chosen sequence will then be disabled and can be seen in the Disabled Sequence Definitions 
field. To enable a sequence, simply highlight the desired sequence and click “Enable.” See Figure 
14B. 
 
A scenario where this could be useful is if, despite the sequence definition being valid and correct, 
you would like to suspend receiving email notifications for a period of time. Once this period is over 
you could then enable the sequence definition. 

FIGURE 14A FIGURE 14B 

STEP 15 

Click OK and a Save As window will appear. Rename the new sequence definition if needed and 
click Save. See Figure 15. 
Once you have completely defined the Sequence Definition and clicked the Save button, refer to 
Step 3, page 7 Open an STF. 
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FIGURE 15 



S3A INSTALLATION 

RECOMMENDATIONS: 
• Analog phone line (if remote monitoring) 

• Mount high and dry with provided fasteners 

• Use 18 gauge/300V twisted/shielded cable per input block 

• Needs 110V power source and we recommend a battery back-up 

 

CONNECTIONS: 
• Input Connections 

• Wurtec has provided jumpers (shorting blocks) that can be installed on your unit (please re-

fer to p. 38 for a circuit board schematic) 

• if the jumpers are across the two pins, you are in the low voltage mode (12-50V AC/DC) 

• by removing the jumpers you are in the high voltage mode (50-250V AC/DC) 

• when making your connections the commons should be negative and inputs positive (DC 

only). Each set of 4 inputs has its own common. If signals do not share a common, they 

should be separated into their own bank of inputs on the S3A. 

• Telephone Line Connections (TELCO) 

• your analog telephone line should be connected at the TELCO terminal block (center two 

pins labeled “ring” and “tip”) 

• ”car tip and ring” terminals are for Wurtec’s S3 Communicator Emergency ADA Telephone to 

allow line sharing 

• ”box tip and ring” terminals allow you to “daisy chain” (2) S3A's per telephone line 

• Power Connections 

• plug Wurtec provided power supply into power jack on S3A 

• red LED power light will illuminate 

• on the circuit board “run” LED will blink green 

• S3A unit will attempt to contact Host PC to synchronize the time clock 

• NOTE: M2 LED indicates transmission of data 
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S3A USER COMMANDS 

The commands included in the Diagnostic drop down menu give you the ability to display data 
received by the remote S3A unit and interpreted by the S3A software on the host PC. 
 
Live On 
           -shows changes in state of all inputs and date/time stamps each change 
           -use this to view the live output from a system in the Communications Event Window or the     
           Oscilloscope 
           -events as well as sequences that are complete or incomplete will be displayed in the 
           Communications Event Window 
 
Live Off 
           -turns Live mode off 
           -doing this allows you to view historical data 
 
Historical 
           -for a complete description see page 37 
 
Oscilloscope ON/OFF 
           -turning this on lets you see in a oscilloscope environment the events occuring on the chosen 

system 
           -for a complete description of this function see page 38 

The following section is a description of S3A commands and their uses. 

DIAGNOSTIC COMMANDS 
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S3A USER COMMANDS 

Live Event Log 
           -displays the time of the last 500 events and the state of all 16 inputs when the event 

occurred; this list is lost when a reset is performed 
 
Live Event Count Threshold Log 
           -stores and lists events that have reached their defined count threshold 
 
List Sequence Notification Queue 
           -stores a time and date stamped list of the last 40 sequence notifications sent 
 
List Current Event Counts 
           -this represents the count of an input that experienced a low-to-high transition as a number; 

shows current state in brackets (0-off or 1-on) 
 
List Notification Log 
           -lists last 510 times the remote S3A unit reported to the host PC including the date, time and 

type of notification 
 
List S3A System Commands Log 
           -view a list of last 510 commands executed by the remote S3A unit 
 
List Event Count Log 
           -lists hourly event counts for last 30 days including date and time stamp 

HISTORICAL 



Using this oscilloscope you can view live events or past events. Refer to Figure A for the following 
descriptions. 
 
1. The X1 and X2 numbers in brackets ([  ]) represents the point in time of the cursors (see #5) in the 

viewing area. They display the date and time in military style. 
2. The Delta X number displays the amount time between the two cursors. 
3. The “GRID OFF” box in the upper right corner adds or removes vertical lines in the graph area to 

visually aid reading the green input lines. These lines are a dark red color. 
4. The events are displayed in the central black graph area as solid green lines. 
5. The two (2) vertical dashed lines are cursors. By clicking and dragging each cursor to a specific 

event transition, you can find the exact time that input’s state changed. 
6. This box represents the amount of time per division shown in the graph area. A division is 

represented between the dark red vertical lines. 
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S3A USER COMMANDS 

FIGURE A 

GRAPH ON/OFF 

1 3 

4 

5 

2 1 

5 

6 

NOTE: A button is highlighted when it appears depressed. 
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S3A USER COMMANDS 

FIGURE B 

GRAPH ON/OFF 

8 

7 

9 
10 11 12 

NOTE: A button is highlighted when it appears depressed. 

7. On the right side are drop downs that contain all 16 of the inputs of the controller. You can view 
one (1) or up to sixteen (16) at a time. The default number displayed is six. 

8. The “PAUSE” button pauses or resumes the live data being displayed in the graph area. Although 
data may still be streaming, the display will stop updating at the point you click “PAUSE” until you 
click ”PAUSE” again. Currently Figure B displays the oscilloscope in “PAUSE” mode. 

9. With the graph in “PAUSED” mode, a “ZOOM” box to the of right the 10sec/div box is visible. 
Click this and the graph area will zoom to the amount of time represented between the two 
cursors. 

10.When highlighted, “INPUTS” will allow you to increase or decrease the numbers of inputs displyed 
in the graph area. To change the number of inputs displayed, click “INPUTS” to highlight then click 
the “+” or “-” button. 

11.When highlighted, “TIME/DIV” will allow you to increase or decrease the amount of time per 
division shown in the graph area. To change the amount of time per division displayed, click 
“TIME/DIV” to highlight then click the “+” or “-” button. 

12.When highlighted, clicking the “MOVE X1 X2” button will lock the two cursors together in their cur-
rent position. This will allow you to move both to compare durations from an input with other in-
puts. To cancel this feature click “MOVE X1 X2” again. 
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S3A USER COMMANDS 

Cancel Current Operation 
           -stops current read process 
 
Update S3A ID EEPROM 
           -allows you to configure individual remote S3A units 
 
Update S3A Input/Sequence 
           -allows you to update your input and sequence definitions on the remote S3A unit 

microprocesssor 
 
Set S3A Clock 
           -sets remote S3A unit clock to match host PC clock 
 
Read S3A Clock 
           -read current time of remote S3A unit clock 
 
Set S3A Standby Mode 
           -this allows maintenance to be performed without remote unit sending notifications for the 

selected amount of time 
 
Retrieve S3A Configuration 
           -this lists remote S3A unit ID, input definitions and sequence definitions and loads the files into 

the PC 
 
Return Firmware Version 
           -this will download the current STF loaded on the S3A Unit you are calling into 
 
Reset S3A Unit 
           -resets information in volatile memory 
 
Check and Reset Notification Log 
           -lists notification log and resets information contained 
 
Retrieve Tagged Sequence Events 
           -this will look for similar sequences that have been tagged 

ACTION COMMANDS Clicking ACTION pauses the current read process. 
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Direct Connect to S3A Unit 
           -using the supplied serial cable connect the host PC to the remote S3A unit 
 
Set PC to auto-answer 
           -initialize the PC’s modem to auto-answer calls from S3A units 
 
Dial remote S3A Unit 
           -navigate list to call and connect a remote S3A unit; will open S3Analyzer Phone List 

Manager. You can also access this function under Edit→S3A Phone Numbers. 
 
Hang up Modem 
           -terminate a modem session and reinitialize the modem to auto-answer 
 
Choose Modem Serial Port 
           -select the PC comm port that hosts the modem 
 
Choose Direct Connect Serial Port 
           -select the PC serial port that will be used to communicate with the remote S3A unit via direct 

connection 

COMMUNICATION COMMANDS 
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HELP MENU 

About S3 Analyzer 
           -displays the software version currently loaded on the computer 
 
S3A Manual 
           -opens a PDF copy of the instruction manual 
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USING THE S3A 

SAVING INFORMATION 

When connected locally through a serial cable and collecting live information on a controller, the 
FIRST thing to do when returning to the jobsite is to SAVE the information. This ensures that you 
will be able to review it at a later time. If you don’t create an ID EEPROM you won’t be able to save 
sequence or event information at a later time. 
 
First, click File→Save Sequence / Event Data File. See Figure 1. The Save S3A Event File 
appears with the date and time stamp as the name to be associated with the file. See Figure 2. Click 
Save.  

FIGURE 1B FIGURE 1A 

Events 

Sequences Log 
When connected locally through a serial cable and collecting live information on a controller, a log of 
sequences that have been found complete or incomplete is created automatically in the S3Analyzer 
folder on your hard drive. See Figure 2A. 
A list of information contained within this file is seen in Figure 2B. 

FIGURE 2A FIGURE 2B 



USING THE S3A 

You must create a new folder named “Sequences logs” to store these files. See Figure 2C and 
Figure 2D. 
FIGURE 2C FIGURE 2D 

Next, move the Sequences file to the Sequences Logs folder. See Figure 2E. 
 
Finally, rename the file to identify which specific controller this log was generated against. See Figure 
2F. 

FIGURE 2E FIGURE 2F 

Remember to repeat the steps above each time you monitor a controller, otherwise you won’t be 
able to identify which sequence logs came from which controller. The information folders within the 
S3Analyzer folder should look similar to Figure 2G. 

FIGURE 2G 
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OPENING INFORMATION FILES 

If you have defined a Sequence Definition to include a snapshot of events (see page 32, Step 12), 
you will receive an email notification that includes an attachment that can be opened in the S3A 
software. You can view the attachment information either in the Communications Event Window or in 
the Oscilloscope only if the S3A software is loaded onto your computer. 
 
First, right click the attached file and save it to the “Called In Events” folder on your C:\drive (hard 
drive). See Figure 1A. Then go back to the S3A program and click “Open Sequence/Event Data 
File”. Automatically, the “Called In Events” window will be displayed allowing you to choose the file 
you want to open. See Figure 1B. 
 
NOTE: Make sure the Live State is Off. If Live State is On, a warning message will appear telling you 
to turn Live Off. 
 
NOTE: When connected locally through a serial cable you will not receive these attachments. 
 
Once the events have been opened and you can see them in the Communications Event window, 
click Diagnostic→Oscilloscope ON/OFF. The events will then be displayed in the Oscilloscope. 

USING THE S3A 
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Saved Information 

Emailed Attachments 

To view the events saved to the computer hard drive, simply click File→Open Sequence / Event 
File. See Figure 1A. 
 
Choose the Events folder and double-click the desired file. See Figure 1B. Once the events have 
been opened and you can see them in the Communications Event window, click 
Diagnostic→Oscilloscope ON/OFF. The events will then be displayed in the Oscilloscope. 

FIGURE 1A FIGURE 1B 



FIGURE 1A FIGURE 1B 

To see which emails remain or have been sent from the host PC, access the C:\drive, click the 
“email” folder and open the “outgoing” or “sent” folders. See Figure 1C. 

FIGURE 1C 
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USING THE S3A 

CONNECTING MULTIPLE WURTEC PRODUCTS 

Ring Tip/ 
TELCO Box Tip 

Ring Tip/ 
TELCO 

Outside 
Telephone 

Line 
Note: The number of S3Analyzers that can 
share a line is limited to the amount of cur-
rent in your outside phone line. 

Wurtec Inc. recommends the following physical 
connections when sharing a line with multiple 
S3Analyzers. Refer to Figure 1. 

Note: This scenario will not work when con-
necting to S3A #1 with a serial cable. 

FIGURE 1 

There are two scenarios that Wurtec approves of when more than one S3 communication product 
shares an incoming telephone line. 

1. Connecting 2 S3Analyzers 



ACCESSING INSTALLED S3A UNITS 

Once a previously installed S3A unit is accessed either directly or remotely, the configuration used 
will automatically be loaded into the software on your computer. See Figure 1A. 
 
Next, click Action→Check and Reset Notification Log. This downloads any notifications that have 
been stored in the unit and resets (synchronizes) the clock of the unit to the computer that is con-
nected to it. See Figure 1B. 

FIGURE 1A FIGURE 1B 
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Ring Tip/ 
TELCO Box Tip 

Ring Tip/ 
TELCO 

Outside 
Telephone 

Line 

Note: The S3A can lineshare with building powered version of the S3Communicator only. 

Wurtec Inc. recommends the following physical connections when sharing a line with an S3Analyzer 
and one or more S3Communicators. Refer to Figure 2. 

Note: This scenario will not work when connecting to S3A #1 with a serial cable. 

FIGURE 2 

2. Connecting 1 S3Analyzer and S3Communicator(s) 

Ring Tip/ 
TELCO EXT 

Note: Refer to circuit board diagram for S3Analyzer on page 47. For circuit board diagram of 
S3Communicator, refer to the instruction manual that came with the emergency phone. 

Note: The new S3Communicator will be available in early 2007! 

Ring Tip/ 
TELCO EXT 

USING THE S3A 
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APPENDIX 

ON-BOARD STORAGE CAPACITY SPECIFICATIONS 
 
Ram Storage (Volatile Temporary Storage Area) 
-Input Events—500 
-Event Count Threshold Events—100 
-Sequence events—50 
 
FLASH Storage (Non-volatile Permanent Storage Area) 
-Start Counts—453 records (each record is a time and current count of each input) 
-System Events—510 records (events) 
-Notification Events—510 records (unit will store 510 notifications before the oldest is overwritten) 
-Sequence Definitions—40 (maximum) 
 
 
ELECTRICAL SPECIFICATIONS 
 
Our engineers recommend that 18-gauge/300V wire be used for connections made from the S3A to 
the device being monitored. You will have to verify connections at both ends and will need to set 
jumpers for high (50-220V) or low (12-50V) range accordingly. 
 
Logic Inputs 1-16: 

Input Impedance: HIGH = 200K Ohms; LOW = 36K Ohms 
 
Power Supply: 
 

 
 
Telco: 
The S3Analyzer’s modem has a Part 68 approved and UL 1950/CSA C22.2 950 listed PSTN inter-
face and meets 1500V AC RMS isolation and provides 2122V peak surge protection. The S3Ana-
lyzer’s modem satisfies U.S. FCC Part 68 and DOT CSA CS-03 Part I Canadian requirements. The 
following specifications are the specifications of the modem and are for one S3A connected only. 

 Min Max  

Input 12 250 VAC or VDC 

 Min Max  

Input 6 12 VDC 
Current 240 500 mA @ 12 volts DC 
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Required FCC Notification: 
Type of Service 
The S3 Analyzer is designed to be used on standard device telephone lines. Connection to telephone-company-provided coin service 
(central office implemented systems) is prohibited. Connection to party lines service is subject to state tariffs. 
 
Changes in Attestation Procedure for Plugs and Jacks 
Wurtec Inc. attests that the network interface plugs or jacks used on this equipment comply with and will continue to comply with the 
mechanical requirements specified in Part 58, subpart F, specifically the dimensions, tolerances and metallic plating requirements. The 
compliance of these connectors will be assured by purchase specifications and incoming inspection. Documentation of such specifica-
tions and/ or inspections will be provided to the FCC within 30 days of their request for the same. 
 
Telephone Company Procedures 
The goal of the telephone company is to provide you with the best service it can. In order to do this, it may occasionally be necessary 
for them to make changes in their equipment, operations or procedures. If theses changes might affect your service or the operation of 
your equipment, the telephone company will give you notice, in writing, to allow you to make any changes necessary to maintain un-
interrupted service. In certain circumstances, it may be necessary for the telephone company to request information from you concern-
ing the equipment, which you have connected to your telephone line. Upon request of the telephone company, provide the FCC regis-
tration number and the ringer equivalence number (REN); both of these items are listed on the equipment label. The sum of all of the 
REN’s on your telephone lines should be less than five in order to assure proper service from the telephone company. In some cases, a 
sum of five may not be useable on given line. Consult your telephone provider. 
 
If Problems Arise  
If any of your telephone equipment is not operating properly, you should immediately remove it from your telephone line, as it may 
cause harm to the telephone network. If the telephone company notes a problem, they may temporarily discontinue service. When 
practical, they will notify you in advance of this disconnection. If advance notice is not feasible, you will be notified as soon as possi-
ble. When you are notified, you will be given the opportunity to correct the problem and informed of your right to file a complaint 
with the FCC. Contact your local telephone service provider if you have any questions about your phone line. In the event repairs are 
ever needed on the S3 Analyzer, Wurtec Inc. or an authorized representative of Wurtec Inc should perform them. For information con-
tact: Wurtec Inc., 6200 Brent Dr. Toledo OH 43611 / 800-837-1066.  

Parameter Minimum Typical Maximum Units Comments 

Off Hook Impedance 20   Ohms  

Trans Hybrid Loss  25  dB 600 Ohm, RXA, TXA 

Ring Voltage Loop 110V  250V Vpp On 48VDC line voltage 
for sustained periods 

Line Loop Current (Off 
hook) 

 20 100 mA  

Return Loss @ 1000Hz  15  dB 600 Ohm 

Ring Frequencies  40  Hz  

Transmit Power  -9.5  dB  
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