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About RiskyProject Enterprise 

RiskyProject is a project risk management software. RiskyProject can be configured as 
standalone desktop software, which saves files to the set of files for each project, and enterprise 
software, which saves data in the database. As the same installation packages is used for desktop 
and enterprise software, switching from one version to another is fast and easy.  You can switch 
from one configuration to another two configurations using the RiskyProject user interface. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Microsoft 
Project 

Oracle 
Primavera 

Safran 
Project 

Other 
Scheduling 
Software 

 

RiskyProject 
Professional 

 

RiskyProject 
Lite 

Enterprise 
Configuration 

Standalone 
desktop 
configuration 

RiskyProject 
Database 

 

RiskyProject Files 
(*ALM) 

Export 
Import 

Optional 



RiskyProject Administrator’s Guide 

 

3 

 

What do I need to install RiskyProject Enterprise 
To install RiskyProject Enterprise you need to have: 

1. RiskyProject Professional installation file: 

 RiskyProjectSetup.msi (for x64 version of the software) or 
 RiskyProjectSetup32.msi (for 32-bit version of the software) 

2. License file (RiskyProject.lic) 

License file includes the following information: 

 Number of users 
 Type of users: concurrent or named. If users are concurrent, only limited number of 

users can be logged on to the enterprise system at the same time. If users are named, only 
limited number of user names can entered to the system. 

 Duration of the license.  
By default (without license files) number of users is 1 and license duration is 1 month. 

3. Access to the database. At a present moment, RiskyProject works only with SQL Server or 
SQL Server Express. RiskyProject supports SQL Server 2005 and higher. SQL Server 
Express can be downloaded free of charge: http://www.microsoft.com/en-
us/sqlserver/editions/2012-editions/express.aspx 

4. RiskyProject Lite installation file (optional): 

 RiskyProjectLiteSetup.msi (for x64 version of the software) or 

 RiskyProjecLitetSetup32.msi (for 32-bit version of the software) 

RiskyProject Lite can be an Enterprise system client; however, you will require RiskyProject 
professional to configure and manage the system 
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Step 1: Install RiskyProject Professional 
Use the RiskyProject Professional installation file to install RiskyProject Enterprise. 

 RiskyProjectSetup.msi (for x64 version of the software) or 

 RiskyProjectSetup32.msi (for 32-bit version of the software) 

Step 2: Configure Access to a Remote Database 
The RiskyProject database must be accessible by RiskyProject clients (RiskyProject Professional 
or RiskyProject Lite), which are installed on computers on a network.  

Firewall systems help prevent unauthorized access to computer resources. If a firewall is turned 
on but not correctly configured, attempts to connect to SQL Server might be blocked. 

For more information how to configure a firewall please visit: http://msdn.microsoft.com/en-
ca/library/cc646023.aspx. 

For each Windows user or group on your network that will be running RiskyProject Enterprise, 
you must use SQL Server Management Studio to create: 

1. SQL Server Logins for all your users or groups, and  

2. Once you have installed the RiskyProject Enterprise database (Step 3), users in the 
RiskyProject Enterprise database with memberships in the db_datareader and db_datawriter 
roles. 
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Step 3: Install RiskyProject Database 
1. From RiskyProject directory (e.g. C:\Program Files\Intaver\RiskyProject 6.0) launch 

RiskyProjectDB.exe. 

 

Locate database script file. By default, 
this script is located in the same 
directory and is named: 
RiskyProject.sql 

The database name 
must be unique 

Click here to install 
database 
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2. Select the database you want to connect to:  

 

3. Specify data link properties. In Enter the initial catalog to use don’t select anything. 

 

4. Click OK. RiskyProject database will be created. 
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Step 4: Setup connection to database 
1. Launch RiskyProject Professional 

2. Select Enterprise Client (requires database) 

3. Configure database connection: follow the same steps you use to connect to the database 
as you did in step 3. In Enter the initial catalog to use don’t select database you just 
created. 

4. Enter user name sa. Do not enter any password. This user name will be used if there no 
any users user in the database.  

Step 5: Enable number of users, type of user licenses, and license 
duration 

Number of users, type of user licenses (concurrent or named users) and license duration is coming 
from license file, such as RiskyProject.lic. If this file is not available, default number of users will 
be 1, license duration will be 30 days. 

 

 If you use concurrent user type, RiskyProject will control how many users can logon to 
the database at the same time. 

 If you use named user type, RiskyProject will control how many user names can be 
available. 

You may switch type of users, number of users, and license duration at any time. To do you 
would need new RiskyProject license file (RiskyProject.lic). You may enable this file using File-
> Users -> Users tab.
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Step 6: Create the Administrator User 
The next step in the process will create a system administrator. 

To create the system administrator:  

1. Click Next. The User Profile dialog box opens. 

2. Enter information for the first user. Only the User Name is required. The initial user is 
always given the administrators role. 

Select license file 
which is supplied by 
Intaver Institute 
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3. Click OK. 

4. You will be prompted to provide a password. Enter password for the first user. Next time 
when you logon to the RiskyProject, use would use this user name and password; user name 
sa will not be valid anymore. 

5. Click OK. 
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About User Management 
In RiskyProject enterprise, user management  is based on users, roles, and permissions. Each 
individual who accesses the system, should be assigned a user logon credentials which are 
defined in the User Administration panel. Users can be assigned one of three roles: Administrator, 
Manager, or User. 

About Roles 
RiskyProject Enterprise has 3 defined roles that can be assigned to users: Administrator, 
Manager, and User.  

Administrator: Administrator full access to RiskyProject 

Manager: Manager may have full access to RiskyProject except managing users and change user 
permissions. Manager’s permissions can be limited by administrator. 

User: User cannot manager users, modify portfolio settings, and delete projects. In addition, 
administrator can limit user’s permissions. 

Create a New User 

Once you have created the Administration role, you can create a new user.  

To create a new user: 

1. Click the Users tab. 

2. In the User Name column, click in an empty role and type in the user name. 

3. Select a role for the user. 
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4. Right-click on the user and click User Profile. The User Profile for the new user opens. 

5. Add user information as required. 

6. In the Permissions group, select the permissions that you want to grant to the user. 

7. Click OK to save the user profile. 
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About Project Permissions 
You can control access to projects using project permission. Project permissions either allow or 
deny users access to projects in your Portfolio. If you give access to a user (Manager or User), 
they will have complete access to the specified project(s) given the permissions they have been 
granted. User project permissions granted to a program (summary project) overwrite project 
permissions to all of its projects. 

Adding Project Permissions to a user 

You must be an administrator to add or modify project permissions.  

To add project permissions to a user: 

1. From the File menu, click Users. The User Management panel opens. 

2. Click the Project Permissions tab. 

3. On the Project Name pane on the left, select the project to which you want to provide or 
modify permissions. On the right is a table of name users in the system.  

4. From the list on the right, select the check box associated with the users to which you want to 
grant permission to the selected project. You can deny user access by clearing the check 
boxes.  

5. Click OK or switch to another tab. 
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Project permission tab is not shown if database does not have any projects. It usually occur if you 
just created a database. 

 

About the Logon History  
The Logon History allows the Administrator to view the entire logon history of all the system 
users. The history includes: 

 User Name 

 Role 

 Logon Time 

 Log off Time 

 Computer ID; computer ID is shown in RiskyProject About dialog (question mark at the 
right upper corner of RiskyProject window) 

 Number of users currently logged on 

 Number of rolling months that logon history will be kept. 

To access logon history: 

1. From the File menu, click Users. The User Management panel opens. 

2. Click the Logon History tab. 

Delete all open sessions 

As an administrator, you can remove logon sessions that are currently open from the list. In can 
be useful if the user “killed” the application without properly existing it. If you use concurrent 
user licensing model, it would limit number of concurrent sessions: users may not be able to 
logon to RiskyProject. 

To delete open sessions, click Delete all open sessions. 

Set the number of months logon records are kept 

Depending on the number of users you have, you may want to keep the history to a manageable 
size.  

To set this period, type in the number of months in the months box and click OK. 

Delete sessions from the list: 

1. Select the sessions you want to delete. 

2. Click the Delete selected sessions button. 

Updating RiskyProject Enterprise License 
You may update RiskyProject Enterprise license information: 

 type of users (concurrent or named users) 
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 maximum number of users 

 license duration  

You would need get RiskyProject license file (RiskyProject.lic) from Intaver Institute Inc. Only 
Administrator may update license information. 

To update RiskyProject Enterprise license information: 

3. From the File menu, click Users. The User Management panel opens. 

4. Click the Users tab. 

5. Click on Browse and locate new RiskyProject.lic file.  

6. Click OK or switch to another tab. 

Switching Between Enterprise and Standalone Desktop 
Configurations 

You may switch between Enterprise and Standalone desktop configurations of RiskyProject and 
vice versa at any moment. To do it use Update RiskyProject License button at Tools pane of the 
toolbar. 

 

1. If you switch from Enterprise configuration to standalone desktop configuration you must 
a license of RiskyProject standalone on your computer. If Enterprise configuration is saved in 
the database, Standalone license is saved in the Windows registry. You would need a license 
number, provided by Intaver Institute Inc. 

2. If you switch from standalone desktop configuration to enterprise configuration, you need to 
define database connection properties as it was described in Chapter 2: RiskyProject 
Enterprise Installation. 

3. If you are in Enterprise mode, you may want to connect to different database. Click on 
Update RiskyProject License and select Enterprise: update database parameters. You 
will be prompted to define database connection properties. 

 

1. You may switch from Enterprise configuration to standalone desktop configuration by 
clicking on Start regular desktop license (no database) with RiskyProject Enterprise 
logon dialog.  

2. If database connection is not available and you current configuration is enterprise, you 
will be prompted to define database connection properties. 

3. Your database connection properties and saved in the system registry: 

Computer\HKEY_CURRENT_USER\Software\Intaver\RiskyProject Pro x.x 
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If this registry entry deleted or update, you may be prompted to define database 
connection properties again. 
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Other RiskyProject Configuration Steps 
RiskyProject configuration consists of the following steps: 

1. Configure users using File->Users… 

2. Define enterprise options using Project->Options, such calendar options, calculation options, 
default risk options, and others 

3. Format Risk Matrix using Risks->Format Risk Matrix 

4. Define risk properties using Risks-> Define Risk Properties 

5. Define risk categories using Risks-> Risk Categories 

6. Customize reports using:  

Risks ->Risk Report -> Customize... 

Report->Statistics Report->Customize…  

Report->Task Report->Customize…  

Report->Report: All Risks->Customize… 

All steps except for user configuration are described in RiskyProject User Manual.  

For enterprise configuration all these settings and options are saved in the database. These 
settings are common for all projects within a portfolio. The exception is Project Options. Project 
Options and portfolio options can be different. Once project is created and imported, it is possible 
to define individual options for each project using Schedule->Options. However the system 
administrator may deny user the ability to define options for individual projects using setting on 
Project->Option. 

 

Resources and calendars are defined on the project level and cannot be automatically shared 
within a portfolio. 
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