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Introduction

Topics

The following topics are covered in this chapter:

Assumptions  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     T-6

Before you begin .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     T-8
Example designs .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     T-8
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Assumptions

We assume that you are familiar with the use of your operating system. 

We also assume that you have a working knowledge of VHDL and/or Verilog. Although ModelSim is an excellent tool to use 
while learning HDL concepts and practices, this document is not written to support that goal. 
delSim Designer Tutorial
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Where to find our documentation

ModelSim documentation is available from our website at www.model.com/support or in the following formats and locations:

Document Format How to get it

ModelSim Installation & 
Licensing Guide

paper shipped with ModelSim

PDF select Help > Documentation; also available from the Support 
page of our web site: www.model.com

ModelSim Quick Guide 
(command and feature 
q

paper shipped with ModelSim
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uick-reference) PDF select Help > Documentation, also available from the Support 
page of our web site: www.model.com

odelSim Tutorial PDF, HTML select Help > Documentation; also available from the Support 
page of our web site: www.model.com

odelSim User’s Manual PDF, HTML select Help > Documentation

odelSim Command 
eference

PDF, HTML select Help > Documentation

odelSim GUI & Editor 
eference

PDF, HTML select Help > Documentation

ommand Help ASCII type help [command name] at the prompt in the Transcript pane

rror message help ASCII type verror <msgNum> at the Transcript or shell prompt

cl Man Pages (Tcl 
anual)

HTML select Help > Tcl Man Pages, or find contents.htm in 
\modeltech\docs\tcl_help_html

echnotes HTML select Technotes dropdown on www.model.com/support

http://www.model.com/support
http://www.model.com/products/release.asp
http://www.model.com/products/release.asp
http://www.model.com/products/release.asp
http://www.model.com/support/documentation/BOOK/sdk_um.pdf
http://www.model.com/support
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Before you begin

Preparation for some of the lessons leaves certain details up to you. You will decide the best way to create directories, copy files, 
and execute programs within your operating system. (When you are operating the simulator within ModelSim’s GUI, the interface 
is consistent for all platforms.)

Example designs

ModelSim comes with Verilog and VHDL versions of the designs used in these lessons. This allows you to do the tutorial 
regardless of which license type you have. Though we have tried to minimize the differences between the Verilog and VHDL 
versions, we could not do so in all cases. In cases where the designs differ (e.g., line numbers or syntax), you will find language-
specific instructions. Follow the instructions that are appropriate for the language that you are using.
delSim Designer Tutorial
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Lesson 1 - ModelSim Designer overview

Topics

The following topics are covered in this chapter:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-10

Basic ModelSim Designer flow  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-11

Set vendor tools and default language     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-12
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Create a project  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-13
Create design units   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-13
Create a testbench    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-13

ulate the design   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-14

nthesize the design.     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-15

ce and route the design     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-16

n post place and route simulation .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-17
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Introduction

ModelSim Designer is a design creation, simulation, and debugging tool for VHDL, Verilog, and mixed-language designs. 

Th

Re

Mo
delSim Designer Tutorial

is lesson provides a brief overview of the ModelSim Designer environment and the basic Designer flow.

lated reading

delSim User’s Manual, Chapter 2 - Getting started with ModelSim Designer  (UM-1) 
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Basic ModelSim Designer flow

The following diagram shows the six basic steps for working with ModelSim Designer.

Set vendor tools and default 
language

Create the design
Simulate the design

Synthesize the design

Place and route the 
design

Run post place and 
route simulation
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Set vendor tools and default language

The first time you start ModelSim Designer, it prompts you to set an FPGA Vendor, Synthesis tool, and default language. It also 
scans your system to see if it can find existing vendor tools. If it finds any, it sets the FPGA Vendor and Synthesis tool to match. 

On g 
To  a 
pe
delSim Designer Tutorial

ce you click OK, ModelSim compiles the specified vendor libraries. You can compile additional libraries later on by selectin
ols > FPGA Library Compiler. ModelSim Designer gives you the option of setting different target vendor technologies on
r design unit basis.
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Create the design

ModelSim Designer includes graphical and textual editors to facilitate design creation. These editors include:

•  Block diagram editor

•  State machine editor

•  Text editor

•  Waveform editor for stimulus creation

Creating a design includes three main steps:

1 Create a project

2

3

C

Pr a, 
us
inf

C

Yo

C

Yo w 
or 
Create design units

Create a testbench

reate a project

ojects serve as containers for all the design files and information associated with your design. Projects may include design dat
er data such as project documentation, downstream data for external tools, and compiler and simulation configuration 
ormation.

reate design units

u can use any of the editors to begin building your design or you can import design elements from external libraries.

reate a testbench

u’ll often want to create a testbench to exercise your design. You can write a testbench from scratch using the Source windo
you can create a graphical testbench by using the waveform editor.
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Simulate the design

When you have created all the design units and a testbench, you compile the design and then load the top-level into the simulator. 
You can drive the simulation from the Main window or directly from the block diagram or state machine editors.

If you get the results you expect, your next step is typically to synthesize the design. If you don’t get the results you expect, you 
can use ModelSim’s suite of debugging tools to troubleshoot and correct the design.
delSim Designer Tutorial
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Synthesize the design

ModelSim Designer interfaces smoothly with a variety of downstream synthesis tools. ModelSim compiled the necessary vendor 
libraries when you first invoked the tool, so in many cases you can just select the top-level of the design, click the synthesis 
button...

...configure the synthesis tool...

...a
nd then click OK to invoke the synthesis tool in batch mode. 
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Place and route the design

Place and route works similarly to synthesis in ModelSim Designer. Select the top-level of the design, click the Place and Route 
icon...

...adjust settings if necessary...

...a

Th
delSim Designer Tutorial

nd then click OK to run place and route.

e post place and route netlist and the SDF file are both linked into the project automatically.
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Run post place and route simulation

With the place and route finished, you can run a gate-level simulation with timing. All of the required files are in place in the 
project so just click the simulate icon to load the design. Again, you can use ModelSim’s debugging tools to investigate any 
problems.
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Lesson 2 - Working with ModelSim Designer

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-20
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-20

Starting up Designer  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-21

Navigating the ModelSim interface  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-23

Managing designs with the Design tab   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-27
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mulating the design      .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-30

eating projects and importing files      .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-33

sson wrap-up   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-35
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troduction

 this lesson we will introduce you to the primary components of the ModelSim 
signer interface. You will do the following:

• Open an existing project and browse the design in the Workspace Design 
tab

• Open existing block diagrams, state machines, and HDL text files from 
the Design tab

• Load a design with the Start Simulation dialog

• Add waves to the wave window and run the design

 later lessons you will practice using some of the individual tools such as the 
ck diagram editor and Dataflow window.

elated reading

odelSim User’s Manual, Chapter 3 - Projects and design management  (UM-23) 
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2b

2c
tarting up Designer

Start ModelSim Designer.

a Use the ModelSim Designer icon in Windows.

If you see a Welcome window appear, click Close.

Specify your vendor tools and default language.

The first time you invoke ModelSim Designer, you are prompted to identify 
your vendor tools and which libraries you want to compile (Figure 1). 

a Select your FPGA vendor.

b Select your Synthesis tool.

c Select the language. 

d Select the libraries you want to compile. Use your mouse and the <Ctrl> 
or <Shift> keys to select from the listed libraries.

At this point ModelSim Designer compiles the selected vendor libraries. 
This may take some time.

Figure 1: The Tool Set Up dialo
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By default ModelSim displays a Welcome dialog upon invocation that is 
similar to the one shown in Figure 2. 

Click Close.

odelSim Designer requires that you have a project open. Consequently, it will 
ays open a project upon start-up. The first time you invoke the tool, it will open 
 example uart project that ships with the product. In subsequent invocations, it 
ll re-open whichever project was open when you last exited the tool.

suming that you are invoking the tool for the first time or that you have never 
ened another project, you should see the uart project in the Design tab (Figure 
. If you don’t see this project, open it by clicking in the Design tab and selecting 
le > Open. The project is located at <install_dir>/examples/<language>/
rt.hdp where <language> is VHDL or Verilog (the examples in this section use 
 VHDL version).

Figure 2: The Welcome dialog

Figure 3: The uart project
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"Multiple document interface (MDI) frame" (GR-23) in 

er Main window

MDI frameript
the ModelSim GUI & Editor Reference for more 
information.
avigating the ModelSim interface

e window you are now looking at is called the ModelSim Main window. It is 
mposed of a number of "panes" and sub-windows that display various types of 
ormation about your design, simulation, or debugging session. You can also 
cess other tools from the Main window that display in stand-alone windows 
g., block diagram editor, Dataflow window, List window).

e following table describes some of the key parts of the Main window.

Window/pane Description

Workspace This pane comprises multiple tabs that contain various 
sorts of information about the current project or 
design. Once a design is loaded, additional tabs will 
appear. See "Workspace" (GR-21) in the ModelSim 
GUI & Editor Reference for more information.

Transcript The Transcript pane provides a command-line 
interface and serves as an activity log including status 
and error messages. See "Transcript" (GR-22) in the 
ModelSim GUI & Editor Reference for more 
information.

MDI frame The Multiple Document Interface (MDI) frame holds 
windows for which there can be multiple instances. 
These include Source editor windows, Wave 
windows, and Memory content windows. See 

Figure 4: The ModelSim Design

Workspace Transc
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d Click the dock icon on the Transcript.

e Click the close button on the Workspace.

f Select View > Workspace to re-open the Workspace.
24 Lesson 2 - Working with ModelSim Designer 

re are a few important points to keep in mind about the ModelSim interface:

indows/panes can be resized, moved, zoomed, undocked, etc. and the changes 
are persistent

You have a number of options for re-sizing, re-positioning, undocking/
redocking, and generally modifying the physical characteristics of windows 
and panes. When you exit ModelSim, the current layout is saved so that it 
appears the same the next time you invoke the tool. See "Main window" (GR-

20) in the ModelSim GUI & Editor Reference for more information.

Menus are context sensitive

The menu items that are available and how certain menu items behave depend 
on which pane or window is active. For example, if the Design tab in the 
Workspace is active, and you choose Edit from the menu bar, the Clear 
command is disabled. However, if you click in the Transcript pane and 
choose Edit, the Clear command is enabled. The active pane is denoted by a 
blue title bar.

t us try a few things.

Zoom and undock panes.

a Click the zoom icon on the Workspace (Figure 5).

The pane fills the entirety of the Main window (Figure 6).

b Click the unzoom icon the Workspace.

c Click the undock icon on the Transcript.

The Transcript becomes a stand-alone window.

Figure 5: Pane control icons 

Figure 6: Zoomed Workspace p

Zoom Un
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d Hover your mouse pointer on the border between two panes so it 

e Main window
becomes a double-headed arrow.

e Click-and-drag left and right or up and down to resize the pane.

f Select Window > Initial Layout.
Move and resize panes.

a Hover your mouse pointer on top of the Transcript title bar so it becomes 
a four-headed arrow.

b Click and drag the Transcript up and to the right until you see a gray 
outline on the right-hand side of the MDI frame.

When you let go of the mouse button, the Transcript is moved and the 
MDI frame and Workspace panes shift to the left (Figure 7).

c Select Window > Initial Layout.

The layout returns to its original setting.

Important: Moving panes can get confusing, and you may not always 
obtain the results you expect. The general rule is as follows: any pane 
can be split vertically or horizontally, multiple times. The best plan is 
to play around a bit, watch the gray outlines, and see what happens 
when you drop panes in various places. 

You won’t have to do this very often. Once you have a layout you like, 
it will be saved when you exit ModelSim.

Selecting Window > Initial Layout is the easiest way to rectify an 
undesired layout.

Figure 7: Panes rearranged in th
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Notice that the Open dialog filters to show project files.
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e Now click in the MDI frame and select File > Open.

Notice that the Open dialog filters to show HDL file types instead.
26 Lesson 2 - Working with ModelSim Designer 

View stand-alone windows.

a Select View > Debug Windows > List.

The List window displays results from a simulation run in tabular format. 
See "List window" (GR-113) in the ModelSim GUI & Editor Reference for 
more information.

b Select View > Debug Windows > Dataflow.

The Dataflow window allows you to explore the physical connectivity of 
your design. See "Dataflow window" (GR-98) in the ModelSim GUI & 
Editor Reference for more information.

c Close the List and Dataflow windows.

Observe context sensitivity of menu commands.

a Click anywhere in the Design tab of the Workspace.

b Select the Edit menu and notice that the Clear command is disabled.

c Click in the Transcript and select Edit > Clear. 

This command applies to the Transcript pane but not the Workspace 
pane.

d Click back in the Design tab of the Workspace and select File > Open.

Note: Many of the options listed under Debug Windows display only 
when a simulation is loaded.
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anaging designs with the Design tab

e Design tab serves as the central access point for all objects in your design. 
is includes design units and their different views (graphical, textual), 
pporting design data (SDF files, etc.), and other related files (e.g., 
cumentation, scripts, etc.).

e Design tab is organized hierarchically. When you expand items, you see 
ferent views of the design unit.

e icons in the Design tab communicate a variety of information. For more 
tails see "Design tab icon descriptions" (UM-33) in the ModelSim User’s Manual.

Open different views.

a Expand the uart_top component so you can see all of the views (Figure 
8).

b Double-click uart_top/struct.bd to open a block diagram view (Figure 9).

c From the block diagram editor, select File > Close Window.

Figure 8: Different views of uart

Figure 9: A block diagram view
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d Double-click uart_top/symbol.sb to open a symbol and interface view 
(Figure 10).

e Click the Interface tab.

f Select File > Close Window.

If ModelSim prompts you to save changes, click No.

g Double-click uart_top_struct.vhd (or uart_top_struct.v if you are using 
the Verilog version of the design) to open the HDL generated from the 
block diagram (Figure 11). The file opens in a Source editor in the MDI 
frame of the Main window.

Figure 10: A symbol view of uar

Figure 11: An HDL view of uar
1e
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View Side Data pane.

a Right-click in the Design tab and select Show Side Data (Figure 12). 
Increase the size of the Workspace if necessary.

The Side Data pane includes three categories of information:

Side Data category Description

Design Data non-HDL files that are required for the 
design (e.g., substitute synthesized design 
unit, SDF files, etc.)

User Data any design-related files that you want to 
collect in one spot (e.g., scripts, design 
documentation, etc.)

Downstream Data files that are required for specific 
downstream tools

Figure 12: Side Data for the UA
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imulating the design

 simulate the sample UART design, we will load the top level which is uart_tb.

Load the design.

a Right-click uart_tb and select Flow > Simulate (Figure 13).

ModelSim automatically compiles any source files that haven’t already 
been compiled or that have changed since the last simulation. Once all 
files are compiled, ModelSim opens the Start Simulation dialog.

The Start Simulation dialog already has the correct design unit specified. 
The dialog appears in case there are other settings you need to modify to 
run the simulation. See "Start Simulation dialog" (GR-58) in the 
ModelSim GUI & Editor Reference for more details on this dialog.

b Click OK.

Figure 13: Simulating the top le
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2  the current region to a Wave window

e MDI frame
Add items to a Wave window.

a In the Sim tab of the Workspace, right-click uart_tb and select Add > 
Add to Wave (Figure 14).

This adds objects from the current region to a Wave window that is 
displayed in the Main window MDI frame (Figure 15).

Figure 14: Adding objects from

Figure 15: A Wave window in th
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Run the simulation

a Click in the Transcript pane.

b Type run 1000 and press enter.

Waves draw in the Wave window (Figure 16).

You will explore additional features of the Wave window in a later 
lesson.

Quit the simulation.

a Select Simulate > End Simulation. Click Yes.

Figure 16: Waveforms in the W
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Verilog: Select counter.v and tcounter.v and click Add.

d Click Next.

e Select work under the Libraries list and click Next.

f Click Finish.
reating projects and importing files

 this exercise you will create a new project and then import some existing HDL 
es.

Create the new project.

a Select File > New > Project.

b Enter the following in the New Project dialog (Figure 17):

• Type example for the Project Name.

• Enter any suitable path.

• Type work for the Default Library.

c Click OK.

The Design tab in the Workspace shows the new project and library.

Import example files.

a Select File > Import > HDL.

This starts the HDL Import Wizard. 

b Make sure Specify HDL files is selected in the first dialog and click 
Next. 

c Click the Browse button and navigate to <install_dir>/examples> 
(Figure 18).

VHDL: Select counter.vhd and tcounter.vhd and click Add. 

Figure 17: Creating a new proje

Figure 18: HDL Import Wizard
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A counter and its testbench appear in the Design tab (Figure 19). Figure 19: Counter and testben
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is concludes this lesson. At this point you are ready to explore the design editor 
d debugging tools that comprise ModelSim Designer. 

sign editor lessons

sson 3 - Creating block diagrams

sson 4 - Creating state diagrams

bugging tool lessons

sson 5 - Viewing simulations in the Wave window

sson 6 - Viewing and initializing memories

sson 7 - Simulating with Code Coverage
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Lesson 3 - Creating block diagrams

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-38
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-38

Creating a new project    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-39

Creating a new block diagram    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-40
Adding blocks    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-41
Adding ports and signals      .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-42

Ed

Ad

Ad

Le
Adding a bundle and a global connector      .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-43
Saving the block diagram    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-44

iting block and signal names  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-45

ding an embedded HDL text view     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-48

ding a panel    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-50

sson wrap-up   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-51



T-

Mo

In

In
em

R

M
to 

iagram
delSim Designer Tutorial
38 Lesson 3 - Creating block diagrams 

troduction

 this lesson you will create part of a simple timer using block diagrams, 
bedded text views, and state machines.

elated reading

odelSim Graphical Interface and Editor Reference – Chapter 2 - Introduction 
graphical editors and Chapter 4 - Block diagram editor.

Figure 20: A completed block d
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 library in the Workspace pane
reating a new project

r this lesson you will create a new project.

Start ModelSim if necessary.

a Use the ModelSim icon in Windows.

If the Welcome to ModelSim dialog appears, click Close.

Create a new project.

a Select File > New > Project.

b In the New Project dialog, type GraphTutor for the Project Name and 
Default Library (Figure 21).

c Click OK.

The Design tab in the Workspace pane show the new project and library 
(Figure 22).

Figure 21: Creating the GraphT

Figure 22: The new project and
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shown as <TBD>/<TBD>/<TBD> but the internal variables are converted to 
show the library, design unit and view name when you save the diagram.

a Click twice on <company name> in the title block to display a popup edit 
box and replace the default text by the name of your company.

b Click twice on <enter diagram title here> and enter a title such as "Top 
Level Timer Block Diagram".

c Click twice on <enter comments here> and enter "Created by <your 
name> on <date>".

d With the title block selected, select File > Save Title Block and click Yes 
to confirm.
40 Lesson 3 - Creating block diagrams 

reating a new block diagram

Use the File Creation wizard to create a new block diagram.

a In the Workspace under the GraphTutor library, double-click the New 
icon.

This opens the File Creation Wizard (Figure 23).

b Select the appropriate language if necessary.

c Double-click Block Diagram under Graphical Views.

This opens a new block diagram editor window (Figure 24).

d Click the View All button  to view the entire diagram.

The block diagram is a blank sheet except for a background grid, a 
package list (with the standard IEEE libraries std_logic_1164 and 
std_logic_arith) and empty text fields with labels for Declarations, Ports 
and Diagram Signals. 

The diagram also shows page boundaries for the default printer and a 
copy of the default title block.

Edit the title block.

A title block is automatically added to all new diagrams if the Add Title 
Blocks in new diagrams option is set in your diagram preferences. 

The title block incorporates internal variables which automatically enter the 
current project name, your login name, and the current date. Internal variables 

Figure 23: The File Creation W

Figure 24: A new block diagram
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unique on the diagram and is used as a label in the generated HDL.

 the diagram

s added to the diagram
The blocks (U_0 and U_1) will be used to define a child state machine and 
block diagram views. The embedded blocks (eb1 and eb2) will be defined by 
concurrent assignment statements on the top level block diagram.
dding blocks

Use the  button (or select Add > Block) to add two blocks on the diagram 
(Figure 25).

Notice that the blocks are added with the default library <library>, the 
default name <block> and unique instance names (U_0 and U_1).

Use the  button to add two embedded blocks on your block diagram 
(Figure 26).

Notice that the embedded blocks are added with unique default names (eb1 
and eb2) and numbers (1 and 2).

The view describing a block must be saved as a uniquely named design unit 
in a library directory. However, the view describing an embedded block is 
saved as part of the parent block diagram and does not impose hierarchy when 
HDL is generated for your design. The name of an embedded block must be 

Note: The Add Block command normally auto-repeats until you select 
another command or terminate the repeating command by using the 
right mouse button or <Esc> key. However, you can change the 
behavior of the toolbar buttons by setting the Activate once only 
preference in the General tab of the Main Settings dialog box. 

You can also use the <Ctrl> key with any toolbar button to toggle the 
repeat mode. For example, when Remain active is set, <Ctrl> + the Add 
Block button adds a single block.

Figure 25: Two blocks added to

Figure 26: Two embedded block
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b Add a signal from block U_0 to the embedded block eb2 and another 
signal from a point on sig2 terminating on the embedded block eb2.

c Add a signal from the embedded block eb2 terminating in space on the 
right side of your diagram. Notice that an output port is added when you 
double-click at the end of the last signal and its declaration is added to 
the list of ports on the diagram.

d Choose Bus with Port and use the  button to add a bus from a 
source on the left side of your diagram with its destination on the upper 

elements such as the signal name using the left mouse button. 
42 Lesson 3 - Creating block diagrams 

dding ports and signals

u can use the buttons shown at the right to add signal and bus nets on a block 
gram (Figure 27).

gnals or buses can be added between any existing connectable items on the 
gram or left unconnected by double-clicking to terminate the net with an open 

t connector. However, you can use the  pulldown on the buttons to change the 
fault setting and terminate with a default port or ripper. Notice that the toolbar 
tton changes to show the current setting.

hen the  or  button is selected, a port is automatically added at an 
connected source or destination end point. When the  button is selected, 
ipper is used if the end point is over an existing bus or bundle.

Add several ports and signals.

a Choose Signal with Port and use the  button to connect three 
signals originating from the block on the left (instance U_0 in the picture) 
to the block on the right (instance U_1) and one signal returning from 
U_1 to U_0. 

The signals are added with unique names (sig0, sig1, sig2 and sig3) and 
the default type std_logic. Notice how the full declarations for these 
diagram signals are automatically added to the list of Declarations on the 
diagram.

Note: Allow one or more grid lines between each port or signal. 
You can resize objects by selecting a block or embedded block and 

Figure 27: Toolbar buttons for 

Add a signal

Add a signal with

Add a bus

Add a bus with a p

Add a bus with a r
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signals are automatically included in the bundle with their names listed under 
the bundle name.

Add the global connector.

a Use the  button to add a global connector on your diagram below the 
bundle.

b Use the  button to add a signal between the global connector and 
a default input port. This will be a clock signal which is implicitly 
connected to every block on the diagram.
embedded block eb1. A default input port is automatically created at the 
beginning of the bus.

e Add another bus starting from this bus and terminating on instance U_0. 
Notice how both bus segments have the same default name dbus0. The 
full declaration showing the default bus type and bounds 
std_logic_vector(15 DOWNTO 0) is added to the list of ports.

f Add a bus (dbus1) from eb1 to U_1. This internal diagram signal is 
shown with the default bounds (15:0) shown (in abbreviated format) on 
the net. 

g Then add two buses (dbus2 and dbus3) from U_1 terminated with default 
output ports on the right of the diagram.

Your diagram should look similar to the one shown in Figure 28.

dding a bundle and a global connector

Add the bundle.

a Use the  button to add three signals on the left side of your 
diagram. Notice that a default input port is created at the source of each 
signal but a dangling net connector is drawn when you double-click at the 
end of each signal.

b Select the three signals (by dragging a selection box around them with 
the mouse) and use the  button to connect a bundle containing 
these signals to block instance U_0 as shown in Figure 29. 

Notice that the bundle has the default name bundle0 and the three selected 

Figure 28: The block diagram w

Figure 29: A bundle and a globa
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be recognized and cannot be reopened.

View the saved design unit.

a Switch to the Main window and view the Design tab of the Workspace. 

b Expand the Timer component.

The Timer component has two views–the block diagram view and a 
symbol view (Figure 31). Symbol views are created automatically when 
you save a block diagram.
44 Lesson 3 - Creating block diagrams 

ving the block diagram

tice the asterisk (*) character in the header of the block diagram editor window. 
is indicates that the diagram has been edited since it was last saved.

Save the diagram.

a Click the  button. 

The Save As dialog box allows you to choose from the currently mapped 
libraries and specify the design unit and design unit view names (Figure 
30).

b Select GraphTutor under Library. 

c Type Timer for the Design Unit name.

d Click OK.

The view name and file extension when you save graphical diagrams defaults 
as follows:

If you omit the suffix, it is added automatically. 

The default leaf names can be changed by setting preferences. However, you 

struct.bd block diagram

fsm.sm state diagram

symbol.sb symbol

Figure 30: Saving the block diag

Figure 31: The Timer compone
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Diagram.

b Select Edit > Object Properties.

Notice that the port declarations are listed at the top of the dialog box and 
the other internal diagram signals at the bottom (Figure 33). Input ports 
are listed before the output ports, otherwise the declarations are listed in 
alphanumeric order.

You can choose one or more existing declarations in the dialog box and 
enter new values for any of the declaration fields. For example, click 
dbus1, dbus2 and dbus3 while holding the <Ctrl> key, then enter a new 
index constraint with bounds 3 DOWNTO 0 (3:0 for Vector Bounds in 
Verilog) to update all three buses while all other fields remain AS_IS.
diting block and signal names

u now have a completed top-level block diagram for the Timer design. 
wever, the blocks and signals have default names.

Edit block names directly on the diagram.

a Click on the text <block> in the lower block on the left (instance U_0 in 
the picture) and notice the small handles which indicate that the text 
object is selected. Click again and notice that the text is now highlighted 
and can be directly overwritten. 

If you click again, the cursor changes to an I-beam which allows you to 
move the cursor in the text and edit individual characters. Enter the new 
name Control and click outside the text to complete the edit. 

b Repeat this procedure to change the name of block instance U_1 to 
Counter, embedded block eb1 to DtoB, and embedded block eb2 to OR1 
(Figure 32).

Edit signal names via a dialog.

Direct text editing can also be used to edit the signal and bus names. 
Alternatively, you can use a dialog box that allows you to edit the properties 
for a selected object. By default, edits to signal and bus nets are applied only 
to the connected nets but you can choose to apply the changes to the entire 
diagram or to propagate changes to all occurrences of the net in the hierarchy 
of the design.

a Select Diagram > Signals > Scope for Changes > Entire Net in 

Figure 32: Editing block and sym

Figure 33: The Object Propertie
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All occurrences of each signal name (including the bundle contents) 
should be automatically updated on the diagram when you confirm the 
dialog box. If any nets are not updated, check that you have set the scope 
for changes to Entire Net in Diagram as described on the previous page.

sig0
sig1
sig2
sig3
sig4

clear
load
hold
zero
beep

std_logic
std_logic
std_logic
std_logic
std_logic

(none)
(none)
(none)
(none)
(none)

(none)
(none)
(none)
(none)
(none)
46 Lesson 3 - Creating block diagrams 

c Click Apply to accept the changes.

Notice that all occurrences on the diagram are updated including the 
declarations list, signals, buses, and bundle contents and that the lists of 
port and signal declarations are sorted alphanumerically when the 
changes are applied to the diagram.

d Use the dialog box to update the port and signal declarations as shown in 
the following tables. For Verilog designs, use a type of wire for all ports 
and signals:

Ports:

Diagram Signals:

Old Name New Name Type Constraint Bounds

dbus0
sig6
sig7
sig8
sig9
dbus2
dbus3
sig5

d
start
stop
reset
clk
low
high
alarm

std_logic_vector
std_logic
std_logic
std_logic
std_logic
std_logic_vector
std_logic_vector
std_logic

index
(none)
(none)
(none)
(none)
index
index
(none)

9 DOWNTO 0
(none)
(none)
(none)
(none)
3 DOWNTO 0
3 DOWNTO 0
(none)

Old Name New Name Type Constraint Bounds
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e Select the bundle name and use direct text editing or the Bundles tab of 
the Object Properties dialog box to change the bundle name to 
control_bundle.

Your block diagram should look similar to the one shown in Figure 34.

Save the diagram.

a Click the  button. 

You have previously saved the diagram so you are not prompted for 
library and design unit names. However, you have changed the signal 
names connected to input and output ports and the diagram will be 
inconsistent with the symbol that was automatically created by the 
previous save. You are prompted whether to update the symbol.

b Click Yes to confirm the save.

You are prompted whether to update instances of the component where 
used. For this tutorial, the Timer is a newly created component and is not 
used elsewhere.

c Click No.

Figure 34: Block diagram with u



T-

Mo

A

In
blo

1

2

The modified HDL text is checked for syntax errors and applied to the 

ed View dialog

in the Object Properties dialog
delSim Designer Tutorial

diagram.
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dding an embedded HDL text view

 this section you will enter HDL code to define the functionality of the OR1 
ck on the diagram.

Open a new view for the OR1 block.

a Right-click the OR1 block and select Open > New View (Figure 35).

b Leave the type of view set to Text and then click OK.

An embedded HDL text view containing default text is displayed on the 
block diagram adjacent to the embedded block.

Modify the HDL code.

a Select the text, re-display the Object Properties dialog box if necessary 
(using the  button), and choose the Text tab. 

b Check Resize to fit text. 

c Modify the VHDL code so it reads as follows (Figure 36):

-- OR1 2
alarm <= hold OR beep;

If you are working in Verilog, the code will look like this:

// OR1 2
assign alarm = hold | beep;

d Click OK.

Figure 35: The Create Embedd

Figure 36: Adding VHDL code 
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Modify the block shape.

The functional blocks on the diagram are shown by default as simple 
rectangular shapes. However, it is sometimes useful to use logic notation 
when a block has a specific logical function. For example, in this block 
diagram, the OR1 embedded block represents a logical OR function. 

a Right-click the OR1 block and select Shape > Autoshapes.

b Select Or in the dialog and click OK.

c Right-click the OR1 block and select Object Properties.

d On the Embedded Blocks tab, uncheck Show Ports when connected to 
hide the port arrow heads.

e Click OK.

The OR1 embedded block should now look similar to the one shown in 
Figure 37.

Figure 37: The modified OR blo
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dding a panel

panel can be useful to outline areas of a diagram. For example, you can use a 
nel to outline a view used for simulation or animation.

Click the  button 

Click and drag a panel that encloses the graphical objects on your diagram. 
The panel is added with the default name Panel0.

Click the  button to save your work.

Your block diagram should look similar to the one shown in Figure 38.

Figure 38: The updated block d
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is concludes this lesson. In the next lesson, you will create a state diagram to 
fine the Control block.
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Lesson 4 - Creating state diagrams

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-54
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-54

Creating a state machine .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-55
Adding states and transitions     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-56

Editing the states and transitions .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-58
Editing the transitions    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-60
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eating a hierarchical state machine     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-62

iting state machine properties .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-66

mulate the control block    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-69

sson wrap-up   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-70
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troduction

 this lesson you will create a graphical state machine to describe the Control 
ck in the block diagram you created in the last lesson. You must complete 
apter Lesson 3 - Creating block diagrams to proceed with this lesson.

elated reading

odelSim Graphical Interface and Editor Reference – Chapter 2 - Introduction 
graphical editors, Chapter 7 - State machines, and Chapter 8 - State diagram 
itor
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you just finished the previous lesson, you should already have the block diagram 
en. If not, open the GraphTutor project if necessary and open the Timer block 
gram by double-clicking it in the Design tab of the Workspace.

Use the Open Down wizard to create a new state diagram.

a Right-click the Control block and select Open As > New View.

This opens the Open Down Create New View wizard (Figure 39).

b Select State Diagram and click Next.

The library and design unit fields are dimmed because they are copied 
automatically from the library and design unit of the parent diagram. The 
view name defaults to fsm.sm for a state machine (Figure 40).

c Click Finish.

A new state diagram GraphTutor/Control/fsm [csm] is created as a child view 
of the Control block. 

Note that a default state machine name csm is appended to the design unit and 
view names in the diagram title. Do not change this name.

Figure 39: The Open Down Cre

Figure 40: Second page of the w
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transition arc. The priorities are initially assigned in the order that you add the 

 diagram

itions 
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transitions but can be re-assigned later if necessary.

If you add a transition in the wrong direction, you can easily change its 
direction by selecting Diagram > Reverse Direction.

Note that a popup description (known as an object tip) is displayed when the 
arrow or hand cursor is stationary over an object. In particular, when the 
cursor is over a transition, the source state and the destination state are named 
even if the states are outside the current window.
56 Lesson 4 - Creating state diagrams 

e state diagram is a blank sheet with page boundaries set for the default printer 
igure 41).

you are working with VHDL, the diagram includes text objects for the default 
DL package list and labels for global actions, concurrent statements, 
hitecture declarations, signals status, process declarations and state register 
tements.

you are working with Verilog, the diagram includes text objects for the default 
mpiler directives list and labels for global actions, concurrent statements, 
dule declarations, signals status and state register statements.

dding states and transitions

Click the  button and add five states on your state diagram. The states are 
added with default names s0, s1, s2, s3 and s4. 

Notice that the first state you add is assumed to be the start state and is drawn 
in green with a double outline. The other states are drawn in cyan with a single 
outline.

Click the  button to add transitions between the states as shown in Figure 
42.

The transitions are added with default conditions which will be edited later in 
this tutorial.

Notice that when you add more than one transition leaving a state, the 
transition priority is indicated by a priority number associated with the 

Figure 41: The blank child state

Figure 42: New states and trans
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ng the Control block and state machine view
Click the  button to save the state diagram.

Switch to the Design tab in the Workspace.

The Design tab was updated to display the Control design unit.

The Control design unit is shown as a block in the Design tab because its 
interface is defined by the connections on its parent block diagram. The Timer 
design unit is shown as a component because it has no parent block diagram 
and its interface is defined by a symbol.

If you expand the Control design unit, you will see that it contains a State 
Diagram view (Figure 43).

Figure 43: The Design tab showi
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diting the states and transitions

Edit the state names and actions.

a Switch back to the State Diagram.

b Select the start state (s0 in Figure 42 on page page T-56) and click the 
 button to display the States tab of the State Machine Object 

Properties dialog box (Figure 44).

The States tab allows you to enter a name and actions text for one or more 
selected states on a state diagram. You can also change the visibility of 
state actions and change the state to a start state or a hierarchical state 
(when a single state is selected).

Figure 44: The Object Properti
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Style Actions

IF hold<='1';
clear<='1';
beep<='0';

IF (no actions)

IF hold<='1';

IF hold<='1';

IF hold<='1';
load<='1';

Style Actions

IF hold = 1;
clear = 1;
load = 0;

IF (no actions)

IF hold = 1;
clear = 0;
load = 0;

IF hold = 1;
clear = 0;
load = 0;

IF hold = 1;
clear = 0;
load = 1;
s3 load_t

s4 load_u
Edit the remaining state names and actions.

Use the dialog and the table of state names and actions at the right to edit the 
states on the diagram.

The Expression Builder dialog box is automatically displayed when you start 
to enter the actions. The expression builder can be used to choose from lists 
of the available port or local signal names, operators, and example values. 

The Expression Builder dialog box can be explicitly displayed at any time by 
selecting Edit > Expression Builder.

The syntax for state actions is automatically checked and any errors reported 
on entry. VHDL and Verilog statements must be terminated by a semicolon 
(;) character. Line breaks and spaces can be used for clarity and will be 
preserved on the diagram.

You can also edit the state name or actions by direct text editing on the 
diagram or copy a state and paste its state actions into another state by 
choosing Paste Special > Paste State Actions from the popup menu.

State names and actions for VH

State names and actions for Ver

Old Name New Name

s0 flush

s1 count

s2 getkey

s3 load_t

s4 load_u

Old Name New Name

s0 flush

s1 count

s2 getkey
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stop='1'

stop='1'

start='1'

d/=NOUGHTS

d/=NOUGHTS

(none)

d/=NOUGHTS

Priority Condition

1 stop

3 stop

1 start

2 d!=NOUGHTS

flush load_u 1 d!=NOUGHTS

1 (none)

1 d!=NOUGHTS
delSim Designer Tutorial

load_u load_t

load_t getkey
60 Lesson 4 - Creating state diagrams 

iting the transitions

Edit the flush state transitions.

a Select the two transitions entering the state flush by dragging the cursor 
across them. 

b Click the  button to display the Transitions tab of the State Machine 
Object Properties dialog box. 

c Replace the default condition by the new condition stop='1' (stop in 
Verilog) and click Apply to add this condition to both of the selected 
transitions. 

Edit the rest of the transitions.

Use the tables at the right to edit the remaining transitions. Use the table that 
matches the language you are using.

Click the  button to save the state diagram.

Note: The NOUGHTS text string is the name of a constant which will 
be declared as a state machine property later in this tutorial.

Transitions for VHDL

Transitions for Verilog

Origin Destination P

count flush 1

getkey flush 3

getkey count 1

getkey load_u 2

flush load_u 1

load_u load_t 1

load_t getkey 1

Origin Destination

count flush

getkey flush

getkey count

getkey load_u
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Yo
ur state machine should now look similar to the one shown below.
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copy of the state at the cursor position.

c Repeat this procedure to add two more states on the diagram. This 
method for adding objects can be useful when you want to add an object 
with the same or similar properties and attributes to an existing object.

d Use the  button to add a new exit point and the  button to connect 
transitions between the states as shown in Figure 46.

Note: You can add route points by clicking at several points 
between states to create a smooth arc as shown in the picture 
between states s2 and s3.
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reating a hierarchical state machine

 this exercise we will create a child state machine that defines the functionality 
 the count state.

Create the child state diagram.

a Select the count state and select Diagram > Change To > Hierarchical 
State 

The count state is redrawn as a hierarchical state with a triple outline and 
darker fill color.

b Double-click the count hierarchical state to create the new hierarchical 
child state diagram. 

A new child state diagram is opened as a tabbed window initialized with 
a default state s0 connected to an entry point and exit point by transitions 
with default conditions (Figure 45).

Notice that the name of the hierarchical state count is included in the 
window title: GraphTutor/Control/fsm [csm/count]. This convention 
shows that the child diagram is a partial view of the parent diagram.

Add states and transitions to the diagram.

a Select the exit point and select Diagram > Change to > State. 

b While the new state is selected, drag with the right mouse button and 
release the mouse button with the ghosted state to the left and below the 
first state. Use the Copy Here option from the popup menu to make a 

Figure 45: The new child state d

Figure 46: States and transition
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Style Actions

IF hold<='1';

IF hold<='1';
clear<='1';
beep<='1';

IF (none)

IF hold<='1';

IF hold<='1';
clear<='1';

Style Actions

IF hold = 1;
clear = 0;
load = 0;

IF hold = 1;
clear = 1;
load = 0;
beep = 1;

IF hold = 0;
clear = 0;
load = 0;

IF hold = 1;
clear = 0;
load = 0;

IF hold = 1;
clear = 1;
load = 0;
s2 counting

s3 suspended

s4 end_count
Edit the states.

a Use the State tab of the Object Properties dialog and the tables at the right 
to edit the states.

State names and actions for VH

State names and actions for Ver

Old Name New Name

s0 standby

s1 alarm

s2 counting

s3 suspended

s4 end_count

Old Name New Name

s0 standby

s1 alarm
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State Priority Condition Actions

1 stop='0' (none)

2 stop='1' (none)

1 zero='1' (none)

2 start='1' (none)

1 zero='1' (none)

1 stop='1' (none)

1 (none) (none)

1 (none) (none)

State Priority Condition Actions

1 ~stop (none)

2 stop (none)

1 zero (none)

standby counting 2 start (none)

1 zero (none)

1 stop (none)

1 (none) (none)

1 (none) (none)
delSim Designer Tutorial

standby alarm

alarm end_count

entry point standby

end_count exit point
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Edit the transitions.

a Use the Transitions tab of the Object Properties dialog and the tables at 
the right to edit the transitions. 

Transitions for VHDL

Transitions for Verilog

Origin State Destination 

suspended counting

counting suspended

counting alarm

standby counting

standby alarm

alarm end_count

entry point standby

end_count exit point

Origin State Destination 

suspended counting

counting suspended

counting alarm
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Your diagram should look similar to the one shown below.

Click the  button to save the state diagram.

Although it is displayed in a separate tab, a child hierarchical diagram is a 
partial view of a state machine and the parent and child diagrams are saved as 
a single design unit view (GraphTutor/Control/fsm.sm).
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Constant NOUGHTS : std_logic_vector := "0000000000";

3

us
delSim Designer Tutorial

Verilog: Select the Module Declarations tab and enter the following 
declaration for the 10-bit constant NOUGHTS in the free-format entry 
box:

parameter NOUGHTS = 10’b0;

Edit signal status.

b Select the Signals Status tab. 

c Change signal beep status to Registered (Figure 47).

Notice that the Reset value field is automatically updated to ‘0’.
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diting state machine properties

ere are a number of properties associated with a state machine that can be edited 
ing the State Machine Properties dialog box. 

Hide unneeded labels.

a Click the csm tab to move back to the parent state machine.

b Select Diagram > State Machine Properties.

This dialog is described in detail under "Setting state machine properties" 
(GR-472) in the ModelSim Designer GUI & Interface Reference.

c Select the Statement Blocks tab and uncheck Visible for Global 
Actions, Concurrent Statements, and State Register Statements.

There are no global actions, concurrent statements, or state register 
statements required in this design, so you are hiding the labels for these 
objects on the state diagram.

d If you are using VHDL, select the Process Declarations tab and uncheck 
Visible. 

There are no process declarations required in this design.

Define the NOUGHTS constant.

a VHDL: Select the Architecture Declarations tab and enter the 
following declaration for the 10-bit constant NOUGHTS in the free-
format entry box:

Figure 47: Changing signal stat
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The dialog box also allows you to change the suffix or prefix used for 
internal registered or clocked signal names. For this tutorial, suffixes are 
used with the default values _int and _cld.

Edit HDL generation properties.

a Select the Generation tab (Figure 48).

b Set the following for Clock:

• Name – clk

• Edge – Falling

c Set the following for Reset:

• Mode – Asynchronous

• Name – reset

• Level – High

d Click OK.

The constant declaration is added below the Architecture Declarations 
(Module Declarations in the case of Verilog) label on the state diagram 
and will be included as architecture declarations (module declarations in 
the case of Verilog) when HDL is generated for the state machine. The 
signals status is displayed as well.

Figure 48: The HDL Generation
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Click the  button to save the state diagram.

Your state machine should now look similar to the one shown in Figure 49.

Figure 49: The finished state dia
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imulate the control block

en though the block diagram isn’t complete (you won’t define the counter block 
this exercise), you can still simulate the control block for demonstration 
rposes.

Load the control block.

a From the state diagram editor, select Simulation > Start.

b Select Yes when prompted to enable data capture and show animation.

ModelSim compiles and loads the control block. Notice too that a 
number of new toolbar buttons for controlling the simulation show up at 
the bottom of the state diagram editor window. The function of these 
buttons is defined in detail in Chapter 9 - Simulator cross-probing and 
state diagram animation in the ModelSim Designer GUI & Interface 
Reference.
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esson wrap-up

is concludes this lesson. Before continuing we need to close the simulation we 
t started.

From the Main window, select Simulate > End Simulation. Click Yes.
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Lesson 5 - Viewing simulations in the Wave window

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-72
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-72

Loading a project and design.     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-73

Adding objects to the Wave window.     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-74

Using cursors in the Wave window  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-76
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Working with multiple cursors  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-77

ving the window format    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-79

sson wrap-up   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-80
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troduction

e Wave window allows you to view the results of your simulation as HDL 
veforms and their values.

e Wave window is divided into a number of window panes (Figure 50). All 
ndow panes in the Wave window can be resized by clicking and dragging the 
r between any two panes.

elated reading

odelSim GUI Reference – "Wave window" (GR-169) 

odelSim User’s Manual – Chapter 8 - WLF files (datasets) and virtuals  (UM-

7)

Figure 50: The Wave window a

pathname value

cursor name cursor valu
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r the examples in this lesson, we have used the project named example that you 
ated in Lesson 2 - Working with ModelSim Designer.

If you just finished the previous lesson, ModelSim should already be running. 
If not, start ModelSim.

a Type vsim at a UNIX shell prompt or use the ModelSim icon in 
Windows.

If the Welcome to ModelSim dialog appears, click Close.

Load the project.

a Click somewhere in the Design tab of the Workspace.

b Select File > Open and open example.hdp.

This project file is located in the directory you specified in "Creating 
projects and importing files" (T-33) in Lesson 2 - Working with ModelSim 
Designer.

Load the design.

a Click the ’+’ icon next to the work library.

b Right click test_counter and select Flow > Simulate.

c Click OK to load the testbench.

ModelSim loads the design and adds sim and Files tabs to the 
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ModelSim adds the objects for that instance to the Wave window.

c Drag a signal from the Objects pane to the Wave window.

d In the Wave window, select Edit > Select All and then Edit > Delete.

Add objects using a command.

a Type add wave * at the VSIM> prompt.

ModelSim adds all objects from the current region.

b Run the simulation for awhile so you can see waveforms.
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dding objects to the Wave window

odelSim offers several methods for adding objects to the Wave window. In this 
ercise, you will try different methods.

Add objects from the Objects pane.

a Select an item in the Objects pane of the Main window, right-click, and 
then select Add to Wave > Signals in Region.

ModelSim adds several signals to the Wave window.

Undock the Wave window.

By default ModelSim opens Wave windows as a tab in the MDI frame of the 
Main window. You can change the default via the Preferences dialog (Tools 
> Edit Preferences). See "ModelSim GUI preferences" (GR-546) in the 
ModelSim GUI & Interface Reference for more information.

a Click the undock icon on the Wave pane (Figure 51).

The Wave pane becomes a standalone, un-docked window.

Add objects using drag-and-drop.

You can drag an object to the Wave window from many other windows and 
panes (e.g., Workspace, Objects, and Locals).

a In the Wave window, select Edit > Select All and then Edit > Delete.

b Drag an instance from the sim tab of the Main window to the Wave 

Figure 51: A Wave window doc
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f Select View > Zoom > Zoom Full.

mouse pointer

 mouse pointer
1b

1e
ooming the waveform display

oming lets you change the display range in the waveform pane. There are 
merous methods for zooming the display.

Zoom the display using various techniques.

a Click the Zoom Mode icon on the Wave window toolbar.

b In the waveform pane, click and drag down and to the right. 

You should see blue vertical lines and numbers defining an area to zoom 
in (Figure 52).

c Select View > Zoom > Zoom Last.

The waveform pane returns to the previous display range.

d Click the Zoom In 2x icon a few times.

e In the waveform pane, click and drag up and to the right. 

You should see a blue line and numbers defining an area to zoom out 
(Figure 53).

Figure 52: Zooming in with the 

Figure 53: Zooming out with the
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The cursor "snaps" to the transition. Cursors "snap" to a waveform edge 

le cursor in the Wave window

1e
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if you click or drag a cursor to within ten pixels of a waveform edge. You 
can set the snap distance in the Window Preferences dialog (select Tools 
> Window Preferences). 

e In the cursor pane, drag the cursor to the right of a transition (Figure 54).

The cursor doesn’t snap to a transition if you drag in the cursor pane. 
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sing cursors in the Wave window

rsors mark simulation time in the Wave window. When ModelSim first draws 
 Wave window, it places one cursor at time zero. Clicking anywhere in the 
veform pane brings that cursor to the mouse location.

u can also add additional cursors; name, lock, and delete cursors; use cursors 
measure time intervals; and use cursors to find transitions.

orking with a single cursor

Position the cursor by clicking and dragging.

a Click the Select Mode icon on the Wave window toolbar.

b Click anywhere in the waveform pane.

A cursor is inserted at the time where you clicked (Figure 54).

c Drag the cursor and observe the value pane.

The signal values change as you move the cursor. This is perhaps the 
easiest way to examine the value of a signal at a particular time.

d In the waveform pane, drag the cursor to the right of a transition with the 
mouse positioned over a waveform. 

Figure 54: Working with a sing
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1 Add a second cursor.

t between two cursors

1d
a Click the Add Cursor icon on the Wave window toolbar.

b Right-click the name of the new cursor and delete the text.

c Type B and press Enter.

d Drag cursor B and watch the interval measurement change dynamically 
(Figure 56).
Rename the cursor.

a Right-click "Cursor 1" in the cursor name pane, and select and delete the 
text (Figure 55).

b Type A and press Enter.

The cursor name changes to "A".

Jump the cursor to the next or previous transition.

a Click signal count in the pathname pane.

a Click the Find Next Transition icon on the Wave window toolbar.

The cursor jumps to the next transition on the currently selected signal.

b Click the Find Previous Transition icon on the Wave window toolbar.

The cursor jumps to the previous transition on the currently selected 
signal.

orking with multiple cursors

Figure 55: Renaming a cursor

Figure 56: Interval measuremen

2a
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Lock cursor B.

a Right-click cursor B in the cursor pane and select Lock B.

The cursor color changes to red and you can no longer drag the cursor 
(Figure 57).

Delete cursor B.

a Right-click cursor B and select Delete B.

Figure 57: A locked cursor in th
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aving the window format

you close the Wave window, any configurations you made to the window (e.g., 
nals added, cursors set, etc.) are discarded. However, you can use the Save 
rmat command to capture the current Wave window display and signal 
eferences to a DO file. You open the DO file later to recreate the Wave window 
 it appeared when the file was created. 

rmat files are design-specific; use them only with the design you were 
ulating when they were created.

Save a format file.

a Select File > Save > Format.

b Leave the file name set to wave.do and click Save.

c Close the Wave window.

Load a format file.

a In the Main window, select View > Debug Windows > Wave.

All signals and cursor(s) that you had set are gone.

b In the Wave window, select File > Open > Format.

c Select wave.do and click Open.

ModelSim restores the window to its previous state.

d Close the Wave window when you are finished by selecting File > Close.
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esson wrap-up

is concludes this lesson. Before continuing we need to end the current 
ulation.

Select Simulate > End Simulation. Click Yes.
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Lesson 6 - Viewing and initializing memories

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-82
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-82

Compiling and loading the design    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-83

Viewing a memory    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-84
Navigating within the memory  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-86
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troduction

 this lesson you will learn how to view and initialize memories in ModelSim. 
odelSim defines and lists as memories any of the following:

• reg, wire, and std_logic arrays

• Integer arrays

• Single dimensional arrays of VHDL enumerated types other than 
std_logic

esign files for this lesson

e ModelSim installation comes with Verilog and VHDL versions of the 
ample design. The files are located in the following directories:

rilog – <install_dir>/modeltech/examples/memory/verilog

DL – <install_dir>/modeltech/examples/memory/vhdl

is lesson uses the Verilog version for the exercises. If you have a VHDL 
ense, use the VHDL version instead.

elated reading

odelSim GUI & Editor Reference – "Memory windows" (GR-131)

odelSim Command Reference – mem display (CR-140), mem load (CR-143), 
em save (CR-146), radix (CR-175) commands
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a On the Design tab, click the ’+’ icon next to the memory library.

b Right click ram_tb and select Flow > Simulate.

c Click OK.
ompiling and loading the design

Start ModelSim if necessary.

If the Welcome to ModelSim dialog appears, click Close.

Create a new project.

a Select File > New > Project.

b Enter the following in the New Project dialog:

• Type memory for the Project Name.

• Enter any suitable path.

• Type memory for the Default Library.

c Click OK.

Import files.

a Select File > Import > HDL.

b Browse to one of the directories described under "Design files for this 
lesson" (T-82) on the previous page.

c Click Remove All if necessary to remove any files listed from a previous 
import. 

d Import all of the HDL files.

Load the design.
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iewing a memory

emories can be viewed via the ModelSim GUI.

Open a Memory instance.

a Select View > Debug Windows > Memory.

The Memories tab opens in the Workspace pane (Figure 58) and lists the 
memories in the current design context (ram_tb) with the range, depth, 
and width of each memory.

b VHDL: The radix for enumerated types is Symbolic. To change the radix 
to binary for the purposes of this lesson, type the following command at 
the vsim prompt:
VSIM> radix bin

c Double-click the /ram_tb/spram1/mem instance in the memories list to 
view its contents. A mem tab is created in the MDI frame to display the 
memory contents. The data are all X (0 in VHDL) since you have not yet 
simulated the design. The first column (blue hex characters) lists the 
addresses (Figure 59), and the remaining columns show the data values.

d In the Memories tab of the Workspace, double-click instance 
/ram_tb/spram2/mem. 

This creates a new tab in the MDI frame called mem(1) that contains the 
addresses and data for the spram2 instance. Each time you double-click 
a new memory instance in the Workspace, a new tab is created for that 
instance in the MDI frame.

Figure 58: Viewing the memori

Figure 59: The mem tab in the M
/ram_tb/spram1/mem
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Simulate the design.

a Click the run -all icon in the Main window.

b Click the mem tab of the MDI frame to bring the 
/ram_tb/spram1/mem instance to the foreground (Figure 60).

VHDL: 
In the Transcript pane, you will see NUMERIC_STD warnings that can be 
ignored and an assertion failure that is functioning to stop the simulation. The 
simulation itself has not failed.

Let’s change the address radix and the number of words per line for instance 
/ram_tb/spram1/mem.

a Right-click anywhere in the mem tab and select Properties. 

The Properties dialog box opens (Figure 61).

b For the Address Radix, select Decimal.

c Select Words per line and type 1 in the field.

d Click OK.

You can see the results of the settings in Figure 62.

Figure 60: Memory display upd

Figure 61: Changing the addres
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avigating within the memory

u can navigate to specific memory address locations, or to locations containing 
rticular data patterns. First, you will go to a specific address.

Use Goto to find a specific address.

a Right-click anywhere in address column and select Goto (Figure 63).

The Goto dialog box opens in the data pane.

b Type 30 in the dialog box.

c Click OK.

The requested address appears in the top line of the window. 

Figure 62: Memory window: ne

Figure 63: The Goto dialog box
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Edit the address location directly.

To quickly move to a particular address, do the following:

a Double click any address in the address column.

b Enter any desired address. (Figure 64)

c Press <Enter> on your keyboard.

The pane scrolls to that address.

Now, let’s find a particular data entry.

a Right-click anywhere in the data column and select Find.

The Find in dialog box opens (Figure 65).

b Type 11111010 in the Find data: field and click Find Next.

The data scrolls to the first occurrence of that address. Click Find Next 
a few more times to search through the list.

c Click Close to close the dialog box.

Figure 64: Edit the address dire

Figure 65: Find in: searching fo
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c In the Properties dialog, set the Address Radix to Decimal and the Data 

 box  
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Radix to Binary. Click OK to accept the changes and close the dialog.

d Select File > Save to bring up the Save Memory dialog box. 

e Specify a Start address of 0 and End address of 250.

f For Address Radix select Decimal, and for Data Radix select Binary.

g Click No addresses to create a memory pattern that you can use to 
relocate somewhere else in the memory, or in another memory.

h Enter the file name as reloc.mem, then click OK to save the memory 
contents and close the dialog.

You will use this file for initialization in the next section.

1e
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aving memory contents to a file

u can save memory contents to a file that can be loaded at some later point in 
ulation. 

Save a memory pattern from the /ram_tb/spram1/mem instance to a file.

a Make sure /ram_tb/spram1/mem is open and selected in the MDI frame.

b Select File > Save to bring up the Save Memory dialog box (Figure 66).

c For the Address Radix, select Decimal.

d For the Data Radix, select Binary.

e Type data_mem.mem into the Filename field.

f Click OK.

You can view the saved file in any editor.

emory pattern files can be saved as relocatable files, simply by leaving out the 
dress information. Relocatable memory files can be loaded anywhere in a 
mory because no addresses are specified.

Save a relocatable memory pattern file. 

a Select the mem(1) tab in the MDI pane to see the data for the /ram_tb/
spram2/mem instance.

b Right-click in the mem(1) tab to open a popup menu and select 
Properties.

Figure 66: Save Memory dialog

1c 1d
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itializing a memory

 ModelSim, it is possible to initialize a memory using one of three methods: 
m a saved memory file, from a fill pattern, or from both.

rst, let’s initialize a memory from a file only. You will use one you saved 
eviously, data_mem.mem. 

View instance /ram_tb/spram3/mem.

a Double-click the /ram_tb/spram3/mem instance in the Memories tab. 
This will open a new tab – mem(2) – in the MDI frame to display the 
contents of /ram_tb/spram3/mem. Scan these contents so you can 
identify changes once the initialization is complete.

b Right-click and select Properties to bring up the Properties dialog. 

c Change the Address Radix to Decimal and click OK.

Initialize spram3 from a file.

a Right-click anywhere in the data column and select Load to bring up the 
Load Memory dialog box (Figure 67).

The default Load Type is File Only.

b Type data_mem.mem in the Filename field.

c Click OK.

The addresses in instance /ram_tb/spram3/mem are updated with the data 
from data_mem.mem (Figure 68).

Figure 67: Load Memory dialog

Figure 68: Initialized memory fr
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w, before you leave this section, go ahead and clear the instances already being 
wed. 

Right-click somewhere in the mem(2) pane and select Close All.
90 Lesson 6 - Viewing and initializing memories 

 this next step, you will experiment with loading from both a file and a fill 
ttern. You will initialize spram3 with the 250 addresses of data you saved 
eviously into the relocatable file reloc.mem. You will also initialize 50 
ditional address entries with a fill pattern.

Load the /ram_tb/spram3/mem instance with a relocatable memory pattern 
(reloc.mem) and a fill pattern.

a Right-click in the data column of the mem(2) tab and select Load to 
bring up the Load Memory dialog box (Figure 69).

b For Load Type, select Both File and Data.

c For Address Range, select Addresses and enter 0 as the Start address and 
300 as the End address. 

This means that you will be loading the file from 0 to 300. However, the 
reloc.mem file contains only 251 addresses of data. Addresses 251 to 300 
will be loaded with the fill data you specify next.

d For File Load, enter reloc.mem in the Filename field.

e For Data Load, select a Fill Type of Increment.

f In the Fill Data field, set the seed value of 0 for the incrementing data.

g Click OK.

h View the data near address 250 by double-clicking on any address in the 
Address column and entering 250. 

u can see the specified range of addresses overwritten with the new data. Also, 
u can see the incrementing data beginning at address 251 (Figure 70).

Figure 69: Loading a relocatabl

Figure 70: Overwritten values i

3b
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Figure 73: Random contents of 
teractive debugging commands

e memory panes can also be used interactively for a variety of debugging 
rposes. The features described in this section are useful for this purpose. 

Open a memory instance and change its display characteristics.

a Double-click instance /ram_tb/dpram1/mem in the Memories tab.

b Right-click in the mem tab and select Properties. 

c Change the Data Radix to Hexadecimal.

d Select Words per line and enter 2.

e Click OK.

Initialize a range of memory addresses from a fill pattern.

a Right-click in the data column of the mem tab and select Change to open 
the Change Memory dialog (Figure 72).

b Click the Addresses radio button and enter the start address as 
0x00000006 and the end address as 0x00000009. The "0x" hex notation 
is optional.

c Select Random as the Fill Type.

d Enter 0 as the Fill Data, setting the seed for the Random pattern.

e Click OK.

The data in the specified range are replaced with a generated random fill 

Figure 71: Original memory con

Figure 72: Changing memory co
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Figure 76: Changed contents fo
92 Lesson 6 - Viewing and initializing memories 

Change contents by highlighting.

You can also change data by highlighting them in the Address Data pane.

a Highlight the data for the addresses 0x0000000c:0x0000000e, as shown 
in Figure 74.

b Right-click the highlighted data and select Change.

This brings up the Change dialog box (Figure 75). Note that the 
Addresses field is already populated with the range you highlighted.

c Select Value as the Fill Type.

d Enter the data values into the Fill Data field as follow: 34 35 36

e Click OK.

The data in the address locations change to the values you entered (Figure 
76).

Edit data in place.

To edit only one value at a time, do the following:

a Double click any value in the Data column.

b Enter the desired value and press <Enter>. 

c When you are finished editing all values, press the <Enter> key on your 
keyboard to exit the editing mode.

If you needed to cancel the edit function, press the <Esc> key on your 
keyboard.

Figure 74: Changing contents b

Figure 75: Entering data to cha
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is concludes this lesson. Before continuing we need to end the current 
ulation.

Select Simulate > End Simulation. Click Yes.
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Lesson 7 - Simulating with Code Coverage 

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-96
Design files for this lesson   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-96
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-96

Compiling the design.     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-97

Loading and running the design  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-98

Vi

Vi

Vi

Ex

Cr

Le
ewing statistics in the Main window   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-100

ewing statistics in the Source window.     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-102

ewing toggle statistics in the Objects pane     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-104

cluding lines and files from coverage statistics    .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-105

eating Code Coverage reports .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-105

sson wrap-up   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-107

Note: The functionality described in this tutorial requires a coverage license feature in 
your ModelSim license file. Please contact your Mentor Graphics sales representative if 
you currently do not have such a feature.
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troduction

odelSim Code Coverage gives you graphical and report file feedback on which 
ecutable statements, branches, conditions, and expressions in your source code 
ve been executed. It also measures bits of logic that have been toggled during 
ecution. 

esign files for this lesson

e sample design for this lesson consists of a finite state machine which controls 
ehavioral memory. The testbench test_sm provides stimulus. 

e ModelSim installation comes with Verilog and VHDL versions of this design. 
e files are located in the following directories:

rilog – <install_dir>/modeltech/examples/coverage/verilog

DL – <install_dir>/modeltech/examples/coverage/vhdl

is lesson uses the Verilog version in the examples. If you have a VHDL license, 
e the VHDL version instead. When necessary, we distinguish between the 
rilog and VHDL versions of the design.

elated reading

odelSim User’s Manual – Chapter 12 - Measuring code coverage  (UM-239)
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d Import all of the HDL files.

Enable coverage statistics.

a Select Compile > Compile Options and move to the Coverage tab.

b Select Statement, Branch, Condition, and 0/1 Toggle coverage statistics 
(Figure 77).

c Click OK.
ompiling the design

abling Code Coverage is a two step process–first, you compile the files and 
ntify which coverage statistics you want; second, you load the design and tell 

odelSim to produce those statistics.

Start ModelSim if necessary.

If the Welcome to ModelSim dialog appears, click Close.

Create a new project.

a Select File > New > Project.

b Enter the following in the New Project dialog:

• Type coverage for the Project Name.

• Enter any suitable path.

• Type coverage for the Default Library.

c Click OK.

Import files.

a Select File > Import > HDL.

b Browse to one of the directories described under "Design files for this 
lesson" (T-96) on the previous page.

c Click Remove All if necessary to remove any files listed from a previous 

Figure 77: Selecting coverage ty
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de Coverage > Current Exclusions to display that pane.

Current Exclusions

Lists all files and lines that are excluded from coverage statistics (see 
"Excluding lines and files from coverage statistics" (T-105) for more 
information).

ese panes can be re-sized, rearranged, and "undocked" to make the data more 
sily viewable. To resize a pane, click-and-drag on the top or bottom border. To 
ve a pane, click-and-drag on the double-line to the right of the pane name. To 

dock a pane you can select it then drag it out of the Main window, or you can 
98 Lesson 7 - Simulating with Code Coverage 

oading and running the design

Load the design.

a On the Design tab, click the ’+’ icon next to the coverage library.

b Right click test_sm and select Flow > Simulate.

c Click the Others tab and check Enable Code Coverage.

d Click OK.

Run the simulation

e Type run 1 ms at the VSIM> prompt.

hen you load a design with Code Coverage enabled, ModelSim adds several 
lumns to the Files and sim tabs in the Workspace (Figure 78). ModelSim also 
plays three Code Coverage panes in the Main window (Figure 79):

Missed Coverage

Displays the selected file’s un-executed statements, branches, conditions, and 
expressions and signals that have not toggled.

Instance Coverage

Displays statement, branch, condition, expression and toggle coverage 
statistics for each instance in a flat, non-hierarchical view.

Details

Shows details of missed coverage such as truth tables or toggle details.

Figure 78: Coverage columns in

Figure 79: Coverage panes
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ck the Dock/Undock Pane button in the header bar (top right). To redock the 
ne, click the Dock/Undock Pane button again.

e will look at these panes more closely in the next exercise. For complete details 
 each pane, see "Code coverage panes" (GR-86).
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iewing statistics in the Main window

t’s take a look at the data in these various panes.

View statistics in the Workspace pane.

a Select the sim tab in the Workspace and scroll to the right.

Coverage statistics are shown for each object in the design. 

b Select the Files tab in the Workspace and scroll to the right. 

Each file in the design shows summary statistics for statements, 
branches, conditions, and expressions. 

c Click the right-mouse button on any column name and select an object 
from the list (Figure 80).

Whichever column you selected is hidden. To redisplay the column, 
right-click again and select that column name. The status of which 
columns are displayed or hidden is persistent between invocations of 
ModelSim.

View statistics in the Missed Coverage pane.

a Select different files from the Files tab of the Workspace.

The Missed Coverage pane updates to show statistics for the selected file 
(Figure 81).

b Select any entry in the Statement tab to display that line in the Source 
window.

Figure 80: Right click a column

Figure 81: Statement statistics i
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View statistics in the Details pane.

a Select the Toggle tab in the Missed Coverage pane. 

If the Toggle tab isn’t visible, you can do one of two things: 1) widen the 
pane by clicking-and-dragging on the pane border; 2) if your mouse has 
a middle button, click-and-drag the tabs with the middle mouse button.

b Select any object in the Toggle tab to see details in the Details pane 
(Figure 82).

View instance coverage statistics.

The Instance Coverage pane displays coverage statistics for each instance in 
a flat, non-hierarchical view (Figure 83). Select any instance in the Instance 
Coverage pane to see its source code displayed in the Source window.

Figure 82: Details pane showing

Figure 83: The Instance Covera
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a conditional statement has not been executed
102 Lesson 7 - Simulating with Code Coverage 

iewing statistics in the Source window

 the previous section you saw that the Source window and the Main window 
verage panes are linked. You can select objects in the Main window panes to 
w the underlying source code in the Source window. Furthermore, the Source 
ndow contains statistics of its own.

View coverage statistics for test_sm in the Source window.

a Make sure test_sm is selected in the sim tab of the Workspace.

b In the Statement tab of the Missed Coverage pane, expand test_sm.v if 
necessary and select any line (Figure 84).

The Source window opens in the MDI frame with the line you selected 
highlighted (Figure 85).

c Switch to the Source window.

The table below describes the various icons.

Icon Description

green checkmark indicates a statement that has been executed

red X indicates that a statement in that line has not been 
executed (zero hits)

green E indicates a line that has been excluded from code 
coverage statistics

Figure 84: Selecting a line in the

Figure 85: Coverage statistics in
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own by hovering the mouse pointer
Vie

d Hover your mouse pointer over a line of code with a green checkmark.

The icons change to numbers that indicate how many times the 
statements and branches in that line were executed (Figure 86). In this 
case line 24 was executed 1562 times. 

e Select Tools > Code Coverage > Show coverage numbers.

The icons are replaced by execution counts on every line. An ellipsis (...) 
is displayed whenever there are multiple statements on the line. Hover 
the mouse pointer over a statement to see the count for that statement.

f Select Tools > Code Coverage > Hide coverage numbers to return to 
icon display.

Figure 86: Coverage numbers sh
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iewing toggle statistics in the Objects
ane

ggle coverage counts each time a logic node transitions from one state to 
other. Earlier in the lesson you enabled two-state toggle coverage (0 -> 1 and 1-
) with the -cover t argument. Alternatively, you can enable six-state toggle 

verage using the -cover x argument. See "Toggle coverage" (UM-249) for more 
ormation.

View toggle data in the Objects pane of the Main window.

a Select test_sm in the sim tab of the Main window.

b If the Objects pane isn’t open already, select View > Debug Windows > 
Objects.

c Scroll to the right and you will see the various toggle coverage columns 
(Figure 87).

The blank columns show data when you have extended toggle coverage 
enabled.

Figure 87: Toggle coverage colu
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xcluding lines and files from coverage 
tatistics

odelSim allows you to exclude lines and files from code coverage statistics. You 
n set exclusions with the GUI, with a text file called an "exclusion filter file", or 
th "pragmas" in your source code. Pragmas are statements that instruct 
odelSim to not collect statistics for the bracketed code. See "Excluding objects 
m coverage" (UM-253) for more details on exclusion filter files and pragmas.

Exclude a line via the Missed Coverage pane.

a Right click a line in the Missed Coverage pane and select Exclude 
Selection. (You can also exclude the selection for the current instance 
only by selecting Exclude Selection For Instance <inst_name>.)

Exclude an entire file.

a In the Files tab of the Workspace, locate sm.v (or sm.vhd if you are using 
the VHDL example).

b Right-click the file name and select Coverage > Exclude Selected File 
(Figure 88).

The file is added to the Current Exclusions pane. 

Cancel the exclusion of sm.v.

a Right-click sm.v in the Current Exclusions pane and select Cancel 
Selected Exclusions.

Figure 88: Excluding an entire f
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b Type notepad cover.txt at the VSIM> prompt to view the report.

c Close Notepad when you are done reviewing the report.
106 Lesson 7 - Simulating with Code Coverage 

reating Code Coverage reports

u can create reports on the coverage statistics using either the menus or by 
tering commands in the Transcript pane. The reports are output to a text file 
ardless of which method you use.

 create coverage reports via the menus, do one of the following: 

select Tools > Code Coverage > Reports from the Main window menu

right-click any object in the sim or Files tab of the Workspace and select Code 
Coverage > Coverage Reports

ight-click any object in the Instance Coverage pane and select Code coverage 
reports from the context menu

Create a report on all instances.

a Select Tools > Coverage > Reports from the Main window toolbar.

This opens the Coverage Report dialog (Figure 89). 

b Make sure Report on all instances and No Filtering are selected and 
then click OK.

ModelSim creates a file report.txt in the current directory and displays 
the report in Notepad.

c Close Notepad when you are done looking at the report.

Create a summary report on all design files from the Transcript pane.

Figure 89: The Coverage Repor
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is concludes this lesson. Before continuing we need to end the current 
ulation.

Type quit -sim at the VSIM> prompt.
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End-User License Agreement

IMPORTANT - USE OF THIS SOFTWARE IS SUBJECT TO LICENSE RESTRICTIONS.
CAREFULLY READ THIS LICENSE AGREEMENT BEFORE USING THE SOFTWARE.

This license is a legal “Agreement” concerning the use of Software between you, the end user, either individually or
as an authorized representative of the company acquiring the license, and Mentor Graphics Corporation and Mentor
Graphics (Ireland) Limited acting directly or through their subsidiaries or authorized distributors (collectively
“Mentor Graphics”). USE OF SOFTWARE INDICATES YOUR COMPLETE AND UNCONDITIONAL
ACCEPTANCE OF THE TERMS AND CONDITIONS SET FORTH IN THIS AGREEMENT. If you do not agree
to these terms and conditions, promptly return, or, if received electronically, certify destruction of Software and all
accompanying items within five days after receipt of Software and receive a full refund of any license fee paid.

END-USER LICENSE AGREEMENT

1.

2.

3.
GRANT OF LICENSE. The software programs you are installing, downloading, or have acquired with this Agreement,
including any updates, modifications, revisions, copies, documentation and design data (“Software”) are copyrighted,
trade secret and confidential information of Mentor Graphics or its licensors who maintain exclusive title to all Software
and retain all rights not expressly granted by this Agreement. Mentor Graphics grants to you, subject to payment of
appropriate license fees, a nontransferable, nonexclusive license to use Software solely: (a) in machine-readable, object-
code form; (b) for your internal business purposes; and (c) on the computer hardware or at the site for which an applicable
license fee is paid, or as authorized by Mentor Graphics. A site is restricted to a one-half mile (800 meter) radius. Mentor
Graphics’ standard policies and programs, which vary depending on Software, license fees paid or service plan purchased,
apply to the following and are subject to change: (a) relocation of Software; (b) use of Software, which may be limited, for
example, to execution of a single session by a single user on the authorized hardware or for a restricted period of time
(such limitations may be communicated and technically implemented through the use of authorization codes or similar
devices); (c)  support services provided, including eligibility to receive telephone support, updates, modifications, and
revisions. Current standard policies and programs are available upon request.

ESD SOFTWARE. If you purchased a license to use embedded software development (“ESD”) Software, Mentor
Graphics grants to you a nontransferable, nonexclusive license to reproduce and distribute executable files created using
ESD compilers, including the ESD run-time libraries distributed with ESD C and C++ compiler Software that are linked
into a composite program as an integral part of your compiled computer program, provided that you distribute these files
only in conjunction with your compiled computer program. Mentor Graphics does NOT grant you any right to duplicate or
incorporate copies of Mentor Graphics' real-time operating systems or other ESD Software, except those explicitly
granted in this section, into your products without first signing a separate agreement with Mentor Graphics for such
purpose.

BETA CODE. Portions or all of certain Software may contain code for experimental testing and evaluation (“Beta
Code”), which may not be used without Mentor Graphics’ explicit authorization. Upon Mentor Graphics’ authorization,
Mentor Graphics grants to you a temporary, nontransferable, nonexclusive license for experimental use to test and
evaluate the Beta Code without charge for a limited period of time specified by Mentor Graphics. This grant and your use
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of the Beta Code shall not be construed as marketing or offering to sell a license to the Beta Code, which Mentor Graphics may
choose not to release commercially in any form. If Mentor Graphics authorizes you to use the Beta Code, you agree to evaluate
and test the Beta Code under normal conditions as directed by Mentor Graphics. You will contact Mentor Graphics periodically
during your use of the Beta Code to discuss any malfunctions or suggested improvements. Upon completion of your evaluation
and testing, you will send to Mentor Graphics a written evaluation of the Beta Code, including its strengths, weaknesses and
recommended improvements. You agree that any written evaluations and all inventions, product improvements, modifications or
developments that Mentor Graphics conceived or made during or subsequent to this Agreement, including those based partly or
wholly on your feedback, will be the exclusive property of Mentor Graphics. Mentor Graphics will have exclusive rights, title
and interest in all such property. The provisions of this subsection shall survive termination or expiration of this Agreement.

4. RESTRICTIONS ON USE. You may copy Software only as reasonably necessary to support the authorized use. Each copy
must include all notices and legends embedded in Software and affixed to its medium and container as received from Mentor
Graphics. All copies shall remain the property of Mentor Graphics or its licensors. You shall maintain a record of the number

ecords
r than
ll take
es not
lity as
in any
ent or
ritten
entor

 in the

n your
of this

5.

orm to
re will
0 days
hics in
ject to
OUR
RICE
T OF

WISE
T TO:
T NO
delSim Designer Tutorial

and primary location of all copies of Software, including copies merged with other software, and shall make those r
available to Mentor Graphics upon request. You shall not make Software available in any form to any person othe
employees and contractors, excluding Mentor Graphics' competitors, whose job performance requires access. You sha
appropriate action to protect the confidentiality of Software and ensure that any person permitted access to Software do
disclose it or use it except as permitted by this Agreement. Except as otherwise permitted for purposes of interoperabi
specified by applicable and mandatory local law, you shall not reverse-assemble, reverse-compile, reverse-engineer or 
way derive from Software any source code. You may not sublicense, assign or otherwise transfer Software, this Agreem
the rights under it, whether by operation of law or otherwise (“attempted transfer”), without Mentor Graphics’ prior w
consent and payment of Mentor Graphics’ then-current applicable transfer charges. Any attempted transfer without M
Graphics' prior written consent shall be a material breach of this Agreement and may, at Mentor Graphics' option, result
immediate termination of the Agreement and licenses granted under this Agreement. 

The terms of this Agreement, including without limitation, the licensing and assignment provisions shall be binding upo
heirs, successors in interest and assigns. The provisions of this section 4 shall survive the termination or expiration 
Agreement.

LIMITED WARRANTY.

5.1. Mentor Graphics warrants that during the warranty period Software, when properly installed, will substantially conf
the functional specifications set forth in the applicable user manual. Mentor Graphics does not warrant that Softwa
meet your requirements or that operation of Software will be uninterrupted or error free. The warranty period is 9
starting on the 15th day after delivery or upon installation, whichever first occurs. You must notify Mentor Grap
writing of any nonconformity within the warranty period. This warranty shall not be valid if Software has been sub
misuse, unauthorized modification or installation. MENTOR GRAPHICS' ENTIRE LIABILITY AND Y
EXCLUSIVE REMEDY SHALL BE, AT MENTOR GRAPHICS' OPTION, EITHER (A) REFUND OF THE P
PAID UPON RETURN OF SOFTWARE TO MENTOR GRAPHICS OR (B) MODIFICATION OR REPLACEMEN
SOFTWARE THAT DOES NOT MEET THIS LIMITED WARRANTY, PROVIDED YOU HAVE OTHER
COMPLIED WITH THIS AGREEMENT. MENTOR GRAPHICS MAKES NO WARRANTIES WITH RESPEC
(A) SERVICES; (B) SOFTWARE WHICH IS LICENSED TO YOU FOR A LIMITED TERM OR LICENSED A
COST; OR (C) EXPERIMENTAL BETA CODE; ALL OF WHICH ARE PROVIDED “AS IS.”



 T-111

ModelSim Designer Tutorial

5.2. THE WARRANTIES SET FORTH IN THIS SECTION 5 ARE EXCLUSIVE. NEITHER MENTOR GRAPHICS
NOR ITS LICENSORS MAKE ANY OTHER WARRANTIES, EXPRESS, IMPLIED OR STATUTORY, WITH
RESPECT TO SOFTWARE OR OTHER MATERIAL PROVIDED UNDER THIS AGREEMENT. MENTOR
GRAPHICS AND ITS LICENSORS SPECIFICALLY DISCLAIM ALL IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT OF
INTELLECTUAL PROPERTY.

6. LIMITATION OF LIABILITY. EXCEPT WHERE THIS EXCLUSION OR RESTRICTION OF LIABILITY
WOULD BE VOID OR INEFFECTIVE UNDER APPLICABLE LAW, IN NO EVENT SHALL MENTOR GRAPHICS
OR ITS LICENSORS BE LIABLE FOR INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES
(INCLUDING LOST PROFITS OR SAVINGS) WHETHER BASED ON CONTRACT, TORT OR ANY OTHER
LEGAL THEORY, EVEN IF MENTOR GRAPHICS OR ITS LICENSORS HAVE BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES. IN NO EVENT SHALL MENTOR GRAPHICS' OR ITS LICENSORS'
LIABILITY UNDER THIS AGREEMENT EXCEED THE AMOUNT PAID BY YOU FOR THE SOFTWARE OR
SERVICE GIVING RISE TO THE CLAIM. IN THE CASE WHERE NO AMOUNT WAS PAID, MENTOR

7.

8.

9.
GRAPHICS AND ITS LICENSORS SHALL HAVE NO LIABILITY FOR ANY DAMAGES WHATSOEVER.

LIFE ENDANGERING ACTIVITIES. NEITHER MENTOR GRAPHICS NOR ITS LICENSORS SHALL BE
LIABLE FOR ANY DAMAGES RESULTING FROM OR IN CONNECTION WITH THE USE OF SOFTWARE IN
ANY APPLICATION WHERE THE FAILURE OR INACCURACY OF THE SOFTWARE MIGHT RESULT IN
DEATH OR PERSONAL INJURY. 

INDEMNIFICATION.  YOU AGREE TO INDEMNIFY AND HOLD HARMLESS MENTOR GRAPHICS AND ITS
LICENSORS FROM ANY CLAIMS, LOSS, COST, DAMAGE, EXPENSE, OR LIABILITY, INCLUDING
ATTORNEYS' FEES, ARISING OUT OF OR IN CONNECTION WITH YOUR USE OF SOFTWARE AS
DESCRIBED IN SECTION 7.

INFRINGEMENT.

9.1. Mentor Graphics will defend or settle, at its option and expense, any action brought against you alleging that
Software infringes a patent or copyright or misappropriates a trade secret in the United States, Canada, Japan, or
member state of the European Patent Office. Mentor Graphics will pay any costs and damages finally awarded
against you that are attributable to the infringement action. You understand and agree that as conditions to Mentor
Graphics' obligations under this section you must: (a) notify Mentor Graphics promptly in writing of the action;
(b) provide Mentor Graphics all reasonable information and assistance to defend or settle the action; and (c) grant
Mentor Graphics sole authority and control of the defense or settlement of the action.

9.2. If an infringement claim is made, Mentor Graphics may, at its option and expense: (a) replace or modify Software so
that it becomes noninfringing; (b) procure for you the right to continue using Software; or (c) require the return of
Software and refund to you any license fee paid, less a reasonable allowance for use.

9.3. Mentor Graphics has no liability to you if infringement is based upon:  (a) the combination of Software with any
product not furnished by Mentor Graphics; (b) the modification of Software other than by Mentor Graphics; (c) the
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use of other than a current unaltered release of Software; (d) the use of Software as part of an infringing process; (e) a
product that you make, use or sell; (f) any Beta Code contained in Software; (g) any Software provided by Mentor Graphics’
licensors who do not provide such indemnification to Mentor Graphics’ customers; or (h) infringement by you that is
deemed willful.  In the case of (h) you shall reimburse Mentor Graphics for its attorney fees and other costs related to the
action upon a final judgment.

9.4. THIS SECTION 9 STATES THE ENTIRE LIABILITY OF MENTOR GRAPHICS AND ITS LICENSORS AND YOUR
SOLE AND EXCLUSIVE REMEDY WITH RESPECT TO ANY ALLEGED PATENT OR COPYRIGHT
INFRINGEMENT OR TRADE SECRET MISAPPROPRIATION BY ANY SOFTWARE LICENSED UNDER THIS
AGREEMENT.

10. TERM. This Agreement remains effective until expiration or termination. This Agreement will immediately terminate upon
notice if you exceed the scope of license granted or otherwise fail to comply with the provisions of Sections 1, 2, or 4.  For any
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other material breach under this Agreement, Mentor Graphics may terminate this Agreement upon 30 days written notice
are in material breach and fail to cure such breach within the 30-day notice period.  If Software was provided for limite
use, this Agreement will automatically expire at the end of the authorized term. Upon any termination or expiration, you a
cease all use of Software and return it to Mentor Graphics or certify deletion and destruction of Software, including all cop
Mentor Graphics’ reasonable satisfaction.

. EXPORT. Software is subject to regulation by local laws and United States government agencies, which prohibit exp
diversion of certain products, information about the products, and direct products of the products to certain countries and 
persons. You agree that you will not export any Software or direct product of Software in any manner without first obtain
necessary approval from appropriate local and United States government agencies.

. RESTRICTED RIGHTS NOTICE. Software was developed entirely at private expense and is commercial computer so
provided with RESTRICTED RIGHTS. Use, duplication or disclosure by the U.S. Government or a U.S. Gover
subcontractor is subject to the restrictions set forth in the license agreement under which Software was obtained pursu
DFARS 227.7202-3(a) or as set forth in subparagraphs (c)(1) and (2) of the Commercial Computer Software - Restricted 
clause at FAR 52.227-19, as applicable. Contractor/manufacturer is Mentor Graphics Corporation, 8005 SW Boeckman
Wilsonville, Oregon 97070-7777 USA.

. THIRD PARTY BENEFICIARY. For any Software under this Agreement licensed by Mentor Graphics from Micro
other licensors, Microsoft or the applicable licensor is a third party beneficiary of this Agreement with the right to enfo
obligations set forth herein.

. AUDIT RIGHTS.  With reasonable prior notice, Mentor Graphics shall have the right to audit during your normal bu
hours all records and accounts as may contain information regarding your compliance with the terms of this Agreement. M
Graphics shall keep in confidence all information gained as a result of any audit.  Mentor Graphics shall only use or d
such information as necessary to enforce its rights under this Agreement.

. CONTROLLING LAW AND JURISDICTION. THIS AGREEMENT SHALL BE GOVERNED BY AND CONST
UNDER THE LAWS OF THE STATE OF OREGON, USA, IF YOU ARE LOCATED IN NORTH OR SOUTH AME
AND THE LAWS OF IRELAND IF YOU ARE LOCATED OUTSIDE OF NORTH AND SOUTH AMERICA. All di
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arising out of or in relation to this Agreement shall be submitted to the exclusive jurisdiction of Dublin, Ireland when the
laws of Ireland apply, or Wilsonville, Oregon when the laws of Oregon apply. This section shall not restrict Mentor
Graphics’ right to bring an action against you in the jurisdiction where your place of business is located.  The United
Nations Convention on Contracts for the International Sale of Goods does not apply to this Agreement.

16. SEVERABILITY. If any provision of this Agreement is held by a court of competent jurisdiction to be void, invalid,
unenforceable or illegal, such provision shall be severed from this Agreement and the remaining provisions will remain in
full force and effect.

17. PAYMENT TERMS AND MISCELLANEOUS.  You will pay amounts invoiced, in the currency specified on the
applicable invoice, within 30 days from the date of such invoice. This Agreement contains the parties' entire
understanding relating to its subject matter and supersedes all prior or contemporaneous agreements, including but not
limited to any purchase order terms and conditions, except valid license agreements related to the subject matter of this
Agreement (which are physically signed by you and an authorized agent of Mentor Graphics) either referenced in the
purchase order or otherwise governing this subject matter. This Agreement may only be modified in writing by authorized

representatives of the parties. Waiver of terms or excuse of breach must be in writing and shall not constitute subsequent
consent, waiver or excuse. The prevailing party in any legal action regarding the subject matter of this Agreement shall be
entitled to recover, in addition to other relief, reasonable attorneys' fees and expenses.

Rev. 040401, Part Number 221417
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