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LICENSE AGREEMENT FOR SMART STRESS ISO  
(WITH INTERFACE TO I-SKETCH BUT NOT TO OTHER CAD SYSTEMS) 

 

LICENSOR: Nor-Par Online A/S 
Nordstrandveien 76 
N-1164 Oslo 
Norway 

ACCEPTANCE OF TERMS OF AGREEMENT BY THE USER 
YOU SHOULD CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS BEFORE USING THIS 
PACKAGE. USING THIS PACKAGE INDICATES YOUR ACCEPTANCE OF THESE TERMS AND CONDITIONS. 

The enclosed proprietary encoded materials, hereinafter referred to as the Licensed Program(s), are the property of 
Nor-Par Online AS and are provided to you under the terms and conditions of this License Agreement.  You assume 
responsibility for the selection of the appropriate Licensed Program(s) to achieve the intended results, and for the 
installation, use and results obtained from the selected Licensed Program(s). 

LICENSE GRANT 

In return for the payment of the license fee associated with the acquisition of the Licensed Program(s) from Nor-Par 
Online AS, Nor-Par Online AS hereby grants you the following non-exclusive rights with regard to the Licensed 
Program(s): 

 Use of the Licensed Program(s) on more than one machine.  Under no circumstance is the 
Licensed Program to be executed without either a Nor-Par Online AS dongle (hardware key) or 
system authorization code. 

You agree to reproduce and include the copyright notice as it appears on the Licensed Program(s) on any copy, 
modification or merged portion of the Licensed Program(s). 

THIS LICENSE DOES NOT CONVEY ANY RIGHT TO USE, COPY, MODIFY OR TRANSFER THE LICENSED 
PROGRAM(S) OR ANY COPY, MODIFICATION OR MERGED PORTION THEREOF, IN WHOLE OR IN PART, 
EXCEPT AS EXPRESSLY PROVIDED IN THIS LICENSE AGREEMENT. 

TERM 

This License Agreement is effective upon acceptance and use of the Licensed Program(s) until terminated in 
accordance with the terms of this License Agreement.  You may terminate the License Agreement at any time by 
returning the Licensed Program(s) together with all copies, modifications, and merged portions thereof in any form.  
This License Agreement will also terminate upon conditions set forth elsewhere in this Agreement or automatically in 
the event you fail to comply with any term or condition of this License Agreement.  You hereby agree upon such 
termination to return the Licensed Program(s) together with all copies, modifications and merged portions thereof in 
any form. 

LIMITED WARRANTY 

The Licensed Program(s), i.e. the tangible proprietary software, is provided "AS IS" WITHOUT WARRANTY OF 
ANY KIND, EITHER EXPRESSED OR IMPLIED, AND EXPLICITLY EXCLUDING ANY IMPLIED WARRANTIES OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.  The entire risk as to the quality and 
performance of the Licensed Program(s) is with you. 

Some jurisdictions do not allow the exclusion of limited warranties, and, in those jurisdictions the above exclusions 
may not apply.  This Limited Warranty gives you specific legal rights, and you may also have other rights which vary 
from one jurisdiction to another. In this case a special agreement needs to be signed before start using this page. 

Nor-Par Online AS does not warrant that the functions contained in the Licensed Program(s) will meet your 
requirements or that the operation of the program will be uninterrupted or error free. 

Nor-Par Online AS does warrant, however, that the diskette(s), i.e. the tangible physical medium on which the 
Licensed Program(s) is furnished, to be free from defects in materials and workmanship under normal use for a 
period of ninety (90) days from the date of delivery to you as evidenced by a copy of your receipt. 

Nor-Par Online AS warrants that any program errors will be fixed by Nor-Par Online AS, at Nor-Par Online AS' 
expense, as soon as possible after the problem is reported and verified.  However, only those customers current on 
their update/maintenance contracts are eligible to receive the corrected version of the program. 

ENTIRE AGREEMENT 

This written Agreement constitutes the entire agreement between the parties concerning the Licensed Program(s).  
No agent, distributor, salesman or other person acting or representing themselves to act on behalf of Nor-Par Online 
AS has the authority to modify or supplement the limited warranty contained herein, nor any of the other specific 
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provisions of this Agreement, and no such modifications or supplements shall be effective unless agreed to in writing 
by an officer of Nor-Par Online AS having authority to act on behalf of Nor-Par Online AS in this regard. 

 

LIMITATIONS OF REMEDIES 

Nor-Par Online AS’ entire liability and your exclusive remedy shall be: 

 a) The replacement is limited to 90 days guarantee period of any diskette not meeting Nor-Par 
Online AS’ "Limited Warranty" as defined herein and which is returned to Nor-Par Online AS or an 
authorized Nor-Par Online AS dealer with copy of your receipt, or 

 b) If Nor-Par Online AS or the dealer is unable to deliver a replacement diskette which is free of 
defects in materials or workmanship in the guarantee period of 90 days from paying the first 
perpetual license fee, you may terminate this License Agreement by returning the Licensed 
Program(s) and associated documentation and you will be refunded all monies paid to Nor-Par 
Online AS or Nor-Par Online AS’s dealer depending who you have paid the first perpetual license 
fee to acquire the Licensed Program(s). 

IN NO EVENT WILL NOR-PAR ONLINE AS BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY LOST 
PROFITS, LOST SAVINGS, AND OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF 
THE USE OR INABILITY TO USE THE LICENSED PROGRAM(S) EVEN IF NOR-PAR ONLINE AS OR AN 
AUTHORIZED Nor-Par Online AS DEALER HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, 
OR FOR ANY CLAIM BY ANY OTHER PARTY. 

SOME JURISDICTIONS DO NOT PERMIT LIMITATION OR EXCLUSION OF LIABILITY FOR 
INCIDENTAL AND CONSEQUENTIAL DAMAGES SO THAT THE ABOVE LIMITATION AND 
EXCLUSION MAY NOT APPLY IN THOSE JURISDICTIONS. 
 
GENERAL 

The initial license fee includes (90) ninety days of support, maintenance, and enhancements to the program.  After 
the first (90) ninety days term, such updates and support are optional at the then current update fee. 

Questions concerning this License Agreement and all notices required herein shall be made by contacting Nor-Par 
Online AS in writing at Nor-Par Online AS, Nordstrandveien 76, 1164 Oslo, Norway, by telephone, +47 22 28 69 00, 
or by Fax, +47 22 28 69 81. 

DISCLAIMER: Smart Stress Iso, © Nor-Par Online A/S, 2002-2007, all rights reserved. 

 

NOTE:  

1. This Smart Stress Iso license requires a valid TRIFLEX Windows license 
2. This Smart Stress Iso license requires a valid I-SKETCH*) license 
3. Interfaces to 3-D CAD systems are covered under a separate agreement\ 

 
Misuse of 1 + 2 + 3 will not permit using Smart Stress Iso and is a violation of this contract. 

 
This proprietary software is the property of Nor-Par Online AS and is provided to the user pursuant to a Nor-Par 
Online AS program license agreement containing restrictions on its use.  It may not be copied or distributed in any 
form or medium, disclosed to third parties, or used in any manner except as expressly permitted by the Nor-Par 
Online AS program license agreement. 

THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR 
IMPLIED.  NEITHER NOR-PAR ONLINE AS NOR ITS AUTHORIZED REPRESENTATIVES SHALL HAVE ANY 
LIABILITY TO THE USER IN EXCESS OF THE TOTAL AMOUNT PAID TO NOR-PAR ONLINE AS UNDER THE 
NOR-PAR ONLINE AS PROGRAM LICENSE AGREEMENT FOR THIS SOFTWARE.  IN NO EVENT WILL NOR-
PAR ONLINE AS BE LIABLE TO THE USER FOR ANY LOST PROFITS OR OTHER INCIDENTAL OR 
CONSEQUENTIAL DAMAGES ARISING OUT OF USE OR INABILITY TO USE THE SOFTWARE EVEN IF NOR-
PAR ONLINE AS HAS BEEN ADVISED AS TO THE POSSIBILITY OF SUCH DAMAGES.  IT IS THE USERS 
RESPONSIBILITY TO VERIFY THE RESULTS OF THE PROGRAM. 

*) OWNERSHIP and MARKETING NOTE:  

Programs I-SKETCH, I-CONVERT and I-EXPORT are owned by Alias Ltd, and are exclusively marketed 
by Intergraph Corporation. You can only license the aforementioned programs from Intergraph Corp. 
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Copyright notice 
 
 
 
 
This publication is the integral part of the Smart Stress Iso software. It cannot be copied or distributed 
by any form or medium or disclosed to third parties. The user of Smart Stress Iso is allowed to print 
out one copy of the manual per copy of licensed software. 
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1 Foreword 
 
Note: Programs I-SKETCH, I-CONVERT and I-EXPORT mentioned throughout this User Manual 
are exclusively marketed and supported by Intergraph Corporation. ISOGEN as mentioned in 
this publication can be sub-licensed by various 3-D CAD program vendors. 
 
The best way to get familiar with Smart Stress Iso is to: 
 
Be familiar with TRIFLEX Windows (if you do not have the license of the software, ask Nor-Par a.s for 
Test Agreement) 
Be familiar with I-SKETCH (You can only take a license of this program from Intergraph Corp.) 
If you have sufficient experience with both TRIFLEX and I-SKETCH, read this User Manual and start 
using Smart Stress Iso. In case you don’t have the Smart Stress Iso program, ask Nor-Par a.s for Test 
Agreement 
In case you experience problems, you can contact Nor-Par a.s Technical Support 
support@norpar.com (worldwide) or Authorized Dealer of Nor-Par Online A/S. 
 
 

2 Technical Background 

2.1 The purpose of Smart Stress Iso 
 
The major feature of I-SKETCH is automatic creation of isometric drawings. These are generated in 
Alias’ ISOGEN, a vital part of I-SKETCH. ISOGEN uses so called Piping Component File (PCF) to 
transfer of Pipeline content and configuration information from I-SKETCH to ISOGEN. 
 
The first functionality of Smart Stress Iso is to automatically transfer full pipeline’s geometry and the 
physical data to file format that TRIFLEX can understand and import.  
 
In the next step, the user does stress analysis in TRIFLEX. This analysis results such as stress 
values, forces and moments become available. 
 
The second functionality of Smart Stress Iso is automatic modification of the original PCF file, so it is 
being expanded by node number information from TRIFLEX. As an option PCF file can be expanded 
by bend displacements (beyond the cut-off, user definable value) and support functions. 
 
In the next step, the user generates Stress isometric drawing with I-SKETCH/ISOGEN. The newly 
generated drawing includes balloons with TRIFLEX node numbers and boxed bend displacements 
and support functions. 
 
The third functionality of Smart Stress Iso is to prepare a Stress Table. Stress Table contains 
information about stresses, forces & moment, displacements and support/anchor definitions. The 
Stress Table is placed automatically onto the Stress isometric drawing. 
 

2.2 Who and how operates the Smart Stress Iso 
 
You have to fully understand who and how works with the Smart Stress Iso. In the project work, piping 
models are created by CAD operators of systems such as PDS, PDMS, AutoPlant, or Plant-4D. Each 
of these systems can generate PCF (or IDF) files during the isometric generation with ISOGEN or 
IsoDraft. The PCF or IDF files are then passed to Stress Analysis department.  
 
The Smart Stress Iso is operated solely by the Stress Analyst.  
 
The Stress Analyst opens the PCF or IDF file obtained from the CAD department with I-SKETCH to 
get the isometric sketch, and does Isometric Generation in I-SKETCH to create the PCF file 
compatible with Smart Stress Iso. Alternatively, the Stress Analyst can create the isometric sketch 
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directly with I-SKETCH, and then generate the compatible PCF during the Isometric Generation in I-
SKETCH. 
 
The Stress Analyst then uses Smart Stress Iso to convert the PCF into the TRIFLEX-compatible IN 
file, which is subsequently opened in TRIFLEX. The Stress Analyst does stress analysis. At this 
moment, the Stress Analyst analyses the flexibility of the piping network and proposes 
modifications to the piping network. He/she selects the pipe support locations and functions 
as well. 
 
When the proposed changes to the network geometry as well as locations and functions of pipe 
supports are known, the Stress Analyst modifies the network geometry and inserts the supports into 
the original isometric sketch in I-SKETCH. Then, he/she repeats actions described under the point (2) 
above to ensure the proposed changes take the desired effect. If they do not, new decisions are 
taken, and the actions from point (3) are repeated until the objective is met. 
 
If there is a need to modify the piping network geometry or add any components to the piping network, 
these changes must be done in I-SKETCH. You are NOT allowed to modify the network’s geometry or 
insert/delete any components directly in TRIFLEX, or this will lead to unpredicted and somewhat fatal 
results. 
 
If the network’s geometry and components are modified in I-SKETCH, the introduced changes will 
appear in TRIFLEX after the conversion as described in the point (2) above. 
 
You ARE allowed to change the functions of the piping supports in TRIFLEX. 
 
Once the actions from point (3) have been finished, the Stress Analyst converts the final 
TRIFLEX file back to I-SKETCH’ PCF using Smart Stress Iso. The Stress Table is created by 
Smart Stress Iso as well. 
Both final I-SKETCH PCF file and the Stress Table are used to generate Stress Isometric 
Drawings with I-SKETCH. The Stress Isometrics are passed to the CAD department, where CAD 
operators introduce the changes to piping network’s geometry and component changes into 
the CAD piping model. 
 
The procedure as described above is called Smart Stress Iso generation 
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2.3 The data flow between I-SKETCH (CAD) and TRIFLEX (Pipe Stress Analysis) 
 
The diagram below shows how converted data are exchanged between various programs.  
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3 Installation 

3.1 Software requirements 
Smart Stress Iso works under Windows NT 4.0 (SP6 minimum), or Windows 2000 Professional (SP2 
minimum) and under Windows XP. We do not support Windows 98 or Windows Millennium. 
 
The following software is required to operate Smart Stress Iso: 

- I-SKETCH 2.3.4 Build 5 or newer  
- TRIFLEX 2.5.3 or newer 
- Microsoft Excel 97 or 2000 or XP or 2003 
- AutoCAD 2000 or newer 

3.2 Installing Smart Stress Iso 
 
1. If your Windows locale is not set to English, go to Start -> Settings -> Regional Options 

(Regional Settings) in Windows. Go to Number tab and set the Decimal Symbol to be point 
“.” instead of comma “,”. This is critical. With Windows NT4.0, 2000 Pro and XP, the setting 
of the Decimal Symbol needs to be done for each Windows user who intends to run Smart 
Stress Iso. 
 
Note: If you by chance forget performing this action, you will be reminded about it at the start of 
Smart Stress Iso application: 
 

 
 

2. You have to have Administrator rights to install Smart Stress Iso.  
 

3. If your PC has the Auto-Play feature for CDs on, the installation will start automatically. Otherwise, 
double click the icon of SETUP.EXE in the main folder of Smart Stress Iso distribution CD 
 
First, the setup program will prepare itself, and it will take a couple to several seconds. Afterwards, 
the first dialog of the Setup program will appear. Click the Next button 
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4. Read and accept the License Agreement, then click Next: 

 
 
 

5. This dialog is very important: 

 
 
Here, you decide whether the program shall be installed for all people who can use your PC, or 
only privately for you. Make your choice and click the Next button. 
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6. You can now make up your mind about the location of Smart Stress Iso. If you click the Change  
button, you will be able to modify the location of the program’s folder. When you are ready to do 
the installation, click the Next button in the screen below: 
 

  
 

7. Custom Setup dialog pops up. 
 

 
 
Here, you can choose extra options to be installed with Smart Stress Iso. If this is the first time 
installation, do not change anything, just click Next. 
 
On update of the existing installation of Smart Stress Iso it is up to you to install the Support and 
Sample files. This will not overwrite any files you have customized. 
 
Click Next to continue. 
 
8. Click the Install button in the next dialog to complete the installation. After the installation has 

completed, you will see: 
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9. If the Install Sentinel Driver option was selected, you will be taken to Sentinel Driver Installation, 
see next section. 
 

3.3 Installing Sentinel Driver 
 
Smart Stress Iso is protected by Sentinel SuperPro key to be attached to the parallel (printer) port of 
your PC: 
 

 
 
The key for Smart Stress Iso can be chained together with I-SKETCH and TRIFLEX keys, and the 
order does not matter. 
 
Unless any other of your existing applications already uses Sentinel SuperPro, you have to 
install the Sentinel Driver that we have provided. Do it only once. While updating Smart Stress 
Iso with never versions, you will never have to install the Sentinel Driver again. 
 
Using Windows Explorer, navigate to folder \Program Files\Smart Stress Iso\KeyDriver. Start the 
application “SSD5411-32bit.exe”. This will start Sentinel System Driver Setup. 
 

7 



Click Next button in the following screen: 
 

 
 
Select this option in next screen and click Next button: 

 
 
Select this option and click Next button: 

 
 
Note: If you have any USB-type Sentinel key belonging to another application, remove such a key 
from the USB port now. (Most probably, you don’t have any keys of this type, but we have to warn you 
just in case.) 
 
Click Next button, and in the last dialog that will appear, click Finish button. Restart your PC if 
instructed so by the installation program. 
 
Remember to attach your Sentinel SuperPro key to the printer port before you want to start 
working with Smart Stress Iso 

3.4 Configuration tasks 
 
The next four steps are very important: 

3.4.1 Running the Smart Stress Iso for the first time  
The Administrator who has installed Smart Stress Iso must start and exit 
the program once. This will record the file locations of I-SKETCH, 
TRIFLEX and AutoCAD to the “stressgen.ini” file. Only after doing this, 
normal (“limited rights”) Windows user can run Smart Stress Iso. 

3.4.2 Preparing I-SKETCH for use with Smart Stress Iso 
 

You will need to “teach” I-SKETCH creating Stress isometric drawings. 

1. Start I-SKETCH  from Start  Programs  Alias Isometrics  I-SKETCH v2 
menu. 
 
Let us assume you are using the default SampleProj isometric directory. In case you use another 
isometric directory in I-SKETCH, do your actions similarly to what will be described here. 
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2. Highlight SampleProject project in the Project Manager list and either click  “Create New 
Style Directory” button in toolbar, or right click the SampleProject name, then select New  Style 
from pop-up menu. 
 

3. In the Style Name field, enter STRESS 
 

 
 
Ensure you have also chosen Check from Template Styles and AutoCAD DXF as Output Format 
in the same dialog box, the click OK. Do not exit Project Manager yet. 
 

4. Now, very carefully perform these actions using Windows Explorer or another file manager: 
 

• Locate subfolder I-SKETCH in the folder where you installed Smart Stress Iso to, e.g., 
C:\Program Files\Smart Stress Iso 

 
• Locate the folder STRESS in your Isometric Directory\Project folder, e.g., 

C:\SampleProj\SampleProject 
 

• Copy files STRESS.OPL, STRESS.DXF from Smart Stress Iso I-SKETCH subfolder to the 
I-SKETCH STRESS subfolder of your project 

 
• Copy file TABLE.DWG from Smart Stress Iso I-SKETCH subfolder to the 

STRESS\Drawings subfolder of your I-SKETCH project.  
 
Make no mistake, double check what you have done. 

 
5. Go back to I-SKETCH Project Manager. Highlight the STRESS style name in the tree: 

 

 
 

Then click Drawing Control  tab in the dialog. You will see the default setting for the 
style as inherited from the CHECK style: 
 

 
 

6. Do the following actions: 
 

• Click the Options File field, and then click the Browse button at the bottom of the dialog. 
Navigate to and select the STRESS.OPL file 
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• Click the Drawing Frame field, and then click the Browse button. Select STRESS.DXF 
• Click the Apply button at very bottom of the dialog. 
• Exit Project Manager 

 
Note: You can go back to Project Manager later for customization. Specifically, clicking the Options 
File field and then clicking the Edit button will launch Options Editor that will allow you precise 
customizing of your Stress Isometric Drawing. You do not need to do this now. 
 

3.4.3 Configuring I-SKETCH 
 
I-SKETCH should use AutoCAD 2000 as the Drawing Viewer, otherwise you will not see the Stress 
Table in generated Stress Isometrics. 
 
1. Start I-SKETCH 

 
2. Select Settings  Viewer Settings from menu. 

 
3. Click “User Defined drawing viewer” and then click “Browse for executable” button 

 
4. Locate file acad.exe in your AutoCAD folder, and select the file. Close the View Settings dialog in 

I-Sketch. 
 
From now on, I-SKETCH will use AutoCAD to display Isometric Drawings 
 

5. Exit I-SKETCH 

3.4.4 Configuring the Drawing Frame 
 
The drawing frame in Smart Stress Iso is not only the visual object for your Stress Isometric Drawings. 
It also includes a link to the Stress Table via AutoCAD file TABLE.DWG. This is how it works: 
 

• After I-SKETCH has generated the Stress Isometric, it opens file STRESS.DXF 
• STRESS.DXF opens as an external reference AutoCAD file TABLE.DWG 
• TABLE.DWG opens STRESS.XLS (which is the physical Stress Table) as an OLE link 

 
Therefore, you must ensure that STRESS.DXF can find TABLE.DWG, and the TABLE.DWG is able to 
find STRESS.XLS 
 
Do these actions: 
 
1. Start AutoCAD and open file C:\SampleProj\SampleProject\STRESS\Drawings\table.dwg 
 

You should see a message box reading “Update linked OLE objects?”. Click No. 
 
Highlight the table in the drawing. Then, use Edit  OLE Links from AutoCAD menu. 
 
To ensure that the drawing is looking for the right reference Excel file, click Change Source button.  
 
If you have any doubt, navigate to file stress.xls that can be found in \Program Files\Smart 
Stress Iso on the disk you have installed to. Ensure that the field Item Name in the dialog 
reads STRESS ISO!R2C2:R45C31 
 
After selecting the stress.xls file and entering STRESS ISO!R2C2:R45C31 in the Item Name field 
(if necessary), click Open in the Change Source dialog, then click Close in the Links dialog of 
AutoCAD. Save the file. 
 

2. Start AutoCAD and open C:\SampleProj\SampleProject\STRESS\stress.dxf as a DXF file. 
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You should see a message box reading “Update linked OLE objects?”. Click No. The Stress 
Table should be visible. 
 
If you by any reason cannot see the Stress table in the drawing, use Insert  Reference from 
AutoCAD menu and insert file C:\SampleProj\SampleProject\STRESS\table.dwg. Place the table 
that appears in the top right corner of the frame. Save file stress.dxf. 

 
Note: Performing action 1 above is necessary in case your Stress Table stress.xls is not at the 
default location C:\Program Files\Smart Stress Iso. In most situations, you will not need to perform 
action 2 above. 
 
This concludes the installation and configuration procedures. 
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4 PCF file generation in I-SKETCH 
 
Whenever you need to get the universal PCF file that is used in throughout Smart Stress Iso, you have 
to generate an Isometric Drawing. 
 
This is how you do it: 
 
1. Start I-SKETCH 

 
2. Use File  Open menu to open file. Try the file LP100.iso you can find in the 

\Program Files\Smart Stress Iso\Samples folder 
 
Pipeline Properties dialog will show up. Click OK 
 
Click OK in a message box informing you about loading Spec. 
 

 
 

3. Right click anywhere in empty space of the drawing and click Generate Drawing option from pop-
up menu. You can type [Ctrl-G] instead. A dialog appears. 

 

 
 
Accept options as above (use CHECK) style and click OK. If you now click View Drawing, the 
Check Isometric will open in AutoCAD. 
 
However, you do not even need to view the drawing. Simply click OK. The drawing generation 
action has created a PCF file (namely Lp100.pcf) that with default I-SKETCH installation can be 
find in C:\SampleProj\SampleProject\INPUTS folder. The file is all we want for Smart Stress 
Iso.  
 
Now you know how to create universal PCF files we will often refer to. 
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5 Working with Smart Stress Iso - Overview 
 
This chapter contains a detailed description on how to work with Smart Stress Iso. This chapter covers 
handling of PCF files generated from sketches made directly in I-SKETCH based on ANSI material 
catalog. Unless you import piping files from a 3-D CAD system such as PDS, PDMS, AutoPlant or 
Plant-4D, or use DIN material catalogs, you should follow the rules described in this chapter. If your 
primary interest is working with files from the CAD systems, proceed to chapter 6 "Working with Smart 
Stress Iso with drawings created in 3-D CAD systems". 
 
 
When the Smart Stress Iso is started for the first time from the Start  Programs  Nor-Par Online 

 Smart Stress Iso, the following window appears: 
 

 
 

This window consists of: 
− The title bar at the top 
− The menu bar below the title bar 
− The information area in the central part 
− The Conversion Mode buttons and the progress indicator at the bottom 

 
The title bar displays the current version of the software. Please refer to this version whenever 
contacting the technical support. 
 
The menu bar contains menus. The message area displays the list of parameters required for data 
conversion and their values/status. The status bar displays the Smart Stress Iso active/inactive 
calculation options and the conversion status. 

5.1 Menu bar 
The following menus are available from the menu bar: 
− File 

Contains option for selection of various file required for chosen option of data conversion 
− Edit 

Enables selection of various parameters required for data conversion 
− View 

Contains options to view some input/output files generated by Smart Stress Iso application 
− Run 

Starts data conversion (available only when all required parameters for selected conversion type 
are set). Also allows starting I-SKETCH and TRIFLEX right from the application 

− Help 
Currently displays copyright information 
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Let us traverse the menus the way you would do it while working with the program fro the first time. 
This is not necessarily the left to right order. 

5.2 Smart Stress Iso saves your input time 
 
Please remember that Smart Stress Iso stores all selections you have made, and the most of actions 
you will do from now on are done once. Next time you open the program you will only have to minor 
selections such as selecting one file and pushing a button. This feature saves a lot of your time. 

5.3 Setup options 

5.3.1 Edit  Environment Parameters menu 
 
This menu option gives you the chance to select the folder where you would like to store the TRIFLEX 
Keyword Files (.IN) that you get as the result of I-SKETCH to TRIFLEX conversion. By default, the 
folder is automatically set to the TRIFLEX Windows Samples folder. We recommend that you enter 
the path to your INPUTS folder in the I-SKETCH project, e.g., 
C:\SampleProj\SampleProject\INPUTS folder. I-SKETCH stores PCF files to the INPUTS folder 
when generating an Isometric Drawing, so it is logical to make Smart Stress Iso to store converted IN 
files to the same folder, too. 
 
Please then use the Edit  Environment Parameters menu and enter the right path to the I-SKETCH 
INPUTS folder of your project. (This is only our recommendation, not the required action.) 
 

 
 

The other parameters you can find in the dialog are detected automatically by Smart Stress Iso. 
 
Click Accept to close the dialog. You will notice that the “IN files target path” in the information area 
has changed to your selection. 
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5.3.2 Edit  Application Parameters menu 
 
This menu opens a dialog that gives you critical options related to how Smart Stress Iso will behave. 
 

 
 
Nominal \ Outside Diameter input to TRIFLEX 
 
In most of countries, pipe size is defined by Nominal Diameter. However, in some countries or 
industries, Outside Diameter specification is appropriate. Therefore, it is up to you to select the 
preferred definition of pipe size to be used later in TRIFLEX. Default is Nominal Diameter. 
 
Materials \ Wall Thickness based on 
 
If you work with standard ANSI based I-SKETCH material catalogs, use “I-SKETCH DEF files” option 
here. It will extract Material and Wall Thickness information from I-SKETCH DEF files. 
 
In case you work with any catalogs where the description is not organized the standard way, Smart 
Stress Iso cannot extract the Material or Wall Thickness info completely automatically. In such case, 
use the “Piping Spec files” option and make use of Spec Builder later. If you do not work with 3-D CAD 
systems, only select “Piping Spec files” in the option described now. When time comes, Spec Builder 
will launch automatically as described in section 6.5 “STEP 2: Running the conversion to TRIFLEX 
with semi-automatic Piping Spec generation” 
 
Default is “I-SKETCH DEF files”. 
 
Support indications on Isometric 
 
If this option is checked, pipe supports will be displayed in the final Stress Isometric drawing. The 
default option is No. 
 
Displacements on Isometrics 
 
You can instruct Smart Stress Iso to display displacements values at bends in the final Stress 
Isometric drawings. In most of situations, you would like to only see displacements larger than some 
limit value. If you want to see bend displacement values, check the option. Enter the value (cut-off 
value) above which the displacement should be shown. Use millimeters or inches depending on your 
engineering unit system. 
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Default is do not display bend displacements. If you choose this option, the default cut-off value will 
be zero, that is, displacements will be shown at all bends. 
 
Click Accept to close the dialog. 
 

5.4 Conversion Mode buttons 
 
The buttons at the bottom of Smart Stress Iso window serve to select Conversion Mode: 
 

 
 
The buttons act accordingly to some logic: 
 
• If the selections you have made are not sufficient, the buttons will be inactive. 
• If you have made right selections, the buttons can be “pushed” to switch the desired conversion 

mode on or off 
 

5.4.1 PCF -> TRIFLEX mode (Mode 1) 
 
This conversion mode converts PCF file you get from I-SKETCH and converts it to TRIFLEX 
compatible IN file. This is the primary and most used of conversion modes. This mode is always 
active. 
 

5.4.2 TRIFLEX node no - > PCF mode (Mode 2) 
 
After you have opened the IN file in TRIFLEX, made stress analysis there and introduced the 
preferred changes to the piping network layout in I-SKETCH, you will repeat the PCF -> TRIFLEX 
mode 1 to perform final analysis and inspection of your work. 
 
When that has been finished, you will like to insert the TRILFLEX node (point) numbers into the PCF 
file, so it later can be used for Stress Isometric generation. 
 
This happens in Mode 2. 

5.4.3 Stress Table Generation mode (Mode 3) 
 
You will typically generate the Stress Table only after final analysis of the piping network in TRIFLEX, 
that is, after the desired modifications have been entered to I-SKETCH. 
 
It is therefore recommended to combine Mode 2 and 3.  

5.5 File menu 
 
The File menu consists of several options used to open files taking part in the data conversion 
process. The contents of the menu depends on the way 
 
Option File  Open PCF… 
 
This is the most used of the File options. Opening a PCF file will activate further conversion 
possibilities.  
Click the option, navigate to and select file LP100.PCF that can be found by default in the 
C:\SampleProj\SampleProject\INPUTS folder. 
 
The information area reads in blue now the name of the file you have just selected: 
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Note: If you work with Imperial units, we expect your default I-SKETCH project has been set up 
properly for the Imperial system of units, too. Folder \Program Files\Smart Stress Iso\Samples 
contains an Imperial file LP100ENG.PCF you can use for self-training with Smart Stress Iso as well. 
 
Option File  Connect to Database… 
 
Since by default we will work with standard I-SKETCH DEF files based on ANSI, you have to connect 
to the file ANSI.DB that translates material and schedule information between I-SKETCH and 
TRIFLEX.  
 
Select the option from menu, navigate to and open file \Program Files\Smart Stress Iso\ANSI.DB 
 
The information area tells you all selections have been made: 
 

 
 

5.6 PCF -> TRIFLEX conversion 
 
You can notice that the Run menu has become active. To run the conversion from PCF to TRIFLEX, 
either: 
 

• Select Run  Conversion, or 
• Press [F5] key 

 
When you do it, the progress indicator will quickly flash and the conversion has finished. 
 

5.7 Working with TRIFLEX  

5.7.1 Opening the IN file in TRIFLEX 
 
To open the converted IN file in TRIFLEX, do this: 
 
1. Start TRIFLEX Windows. (You can do it from Run  TRIFLEX menu of Smart Stress Iso) 
2. Use the Utilities  Import Files TRIFLEX Keyword from menu 
3. Navigate to file LP100.IN that you can find in folder, e.g., C:\SampleProj\SampleProject\INPUTS 

(see point 5.3.1 above) and select it 
4. TRIFLEX will display the network converted from I-SKETCH 
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5. Remember to save the TRIFLEX job by File  Save As menu option 
 
Before you run TRIFLEX analysis, you have to specify: 

• Piping Compliance Code 
• Case data (only data for one load-case are imported, by default T+P+W) 

 
And you typically define: 

• Support function, preliminary displacements 
• Anchor definition, preliminary movements 
• Flange loading data etc. 

 

5.7.2 Modification Engineering in TRIFLEX and I-SKETCH 
 
The results of first stress analysis can be not satisfactory, so you the Stress Analyst will, among 
others: 
 

• Reconsider piping geometry 
• Apply piping supports 
• Define support functions 
• Replace the piping components 

 
All these actions are normal work to get the piping network to match the Piping Code requirements. 
 
As TRIFLEX user, you are accustomed to do all these modifications in TRIFLEX.  
 
So far, so good. 
 
If you however want to get the maximum benefit of Smart Stress Iso, be aware of one fact: The 
changes to components and geometry as well as new piping supports will not go automatically to 
I-SKETCH. 
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Therefore, when your Stress Analysis is complete, please enter your final modifications related to 
geometry, components and supports in I-SKETCH drawing. You do not need to run subsequent 
conversion from I-SKETCH to TRIFLEX, but you may do so for completeness. 
 

5.8 Stress Isometric generation 
 
To prepare a Stress Isometric drawing, do these actions: 
 

5.8.1 Prepare isoOUT file in TRIFLEX 
 
Once the TRIFLEX job has been saved and analysis has been run: 
 
1. Use “Utilities  Export Files  isoOUT File” menu in TRIFLEX 
2. Give the file you are saving a meaningful name, e.g., LP100(.iOUT) and save it to a convenient 

location (you can save the file to the INPUTS folder for simplicity.) 
 

5.8.2 Run conversions in Mode 2 and 3 in Smart Stress Iso 
 
1. In Smart Stress Iso, “push” the Conversion mode buttons so all three are depressed: 
 

 
 

You will notice that Smart Stress Iso needs a name of an iOUT file now: 
 

 
 
2. Select File  Open OUT from menu in Smart Stress Iso. Navigate to the LP100.iOUT file you 

have just created and select it. The information area is all blue now: 
 

 
 

3. Press [F5] key or select Run  Conversion from menu 
 

Now, conversion takes a while what can be seen in the progress indicator. 
 
 

5.8.3 Generate Stress Isometric in I-SKETCH 
 
1. Start I-SKETCH (You can do it from Run I-SKETCH menu in Smart Stress Iso.) Ensure no 

drawing is opened there 
2. Select File  Import from menu in I-SKETCH 
3. Locate file LP100TR.pcf in the INPUTS folder of the I-SKETCH project and select it. 
 

19 



Conversion option 2 creates a PCF file based on original file name, but with TR appended to 
indicate that is the file with TRIFLEX node numbers included. 

 
4. “PipeLine Properties” dialog appears. You can see that the Pipeline Reference now is 

LP100-STRESS_ISO to indicate the origin of the pipeline. You can change this name. Click OK 
 

5. Right click in empty workspace in I-SKETCH and select Generate Drawing from pop-up menu or 
press [Ctrl_G] 
 

6. Select STRESS as Isometric Drawing Style now: 
 

 
 
Click OK. 

 
7. Click View Drawing button. AutoCAD will start. 

 
8. Answer Yes to the question “Update OLE links?” 
 
You can see the view of the drawing in the next page. 
 
Note: Depending on your I-SKETCH drawing size and complexity, the drawing might have been split 
into several drawing. Refer to Page 9 and read how to open Options Editor of I-SKETCH to adjust the 
properties of the generated drawing. For example, Option 14 controls the paper size, and Option 34 
does scaling of the pipeline area. 
 

5.8.4 Bend displacements on the drawing 
 
If you have chosen the Bend Displacement option in Edit  Application parameters, the drawing might 
include labels like shown in this sample picture: 
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Sample Stress Isometric drawing 
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5.9 Other menus 
 

5.9.1 View menu 
 
The View menu allows you to browse through various files. The files you are allowed to view depend 
on selected program options. 
 
With the drawings based on I-SKETCH DEF files you can view: 
 

• Conversion log file. Complete progress of conversion is documented here 
• Error log. If Smart Stress Iso finds your PCF file includes information that is unacceptable for 

TRIFLEX, you will get a notification message. Details of the error will be stored to the Error 
Log 

• DB file. This is the file that maps I-SKETCH material and schedule definitions onto the 
TRIFLEX system 

• I-SKETCH DEF file. The I-SKETCH definitions of the material 
• INSUL file. The file that maps insulation information onto TRIFLEX system 

 
Note: the DB file, DEF file and INSUL file are customizable. 
 

5.9.2 Run menu 
 
The Run menu includes these options: 
 

• Run conversion F5. You have tried it before to run sample conversions. You can press [F5] on 
your keyboard instead of using the menu option 

• TRIFLEX Ctrl+T. To start TRIFLEX from Smart Stress Iso. You can press [Ctrl-T] instead 
• I-SKETCH Ctrl+I. To Start I-SKETCH right from Smart Stress Iso  
• AutoCAD Ctrl+A. To run AutoCAD from Smart Stress Iso interface. 
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6 Working with Smart Stress Iso with drawings created in 3-D CAD systems 
 
I-SKETCH allows you to import piping files that come from ISOGEN used in 3-D CAD systems such as 
PDS, AutoPlant or Plant-4D. 
 
PDS uses ISOGEN and creates IDF files during isometric generation 
PDMS uses IsoDraft and creates IDF files during isometric generation 
AutoPlant uses Personal ISOGEN and creates PCF files during isometric generation 
Plant-4D uses Personal ISOGEN and creates PCF files during isometric generation 
 
The IDF or PCF files from the CAD systems mentioned above could be imported to I-SKETCH and 
later used with Smart Stress Iso. 
 

6.1 CAD Piping File Import and Piping Specs in I-SKETCH 
 
The IDF or PCF files that come from 3-D CAD systems can be imported to I-SKETCH by File -> Import 
option. What happens during IDF or PCF import to I-SKETCH is: 
 

1. A mini piping catalog and specification that includes only components found in the IDF or PCF 
is automatically created by I-SKETCH 

2. The piping network is displayed in I-SKETCH and it is saved as the .ISO sketch file 
3. When you have generated an isometric drawing in I-SKETCH, a new PCF that is compliant 

with Smart Stress Iso will be created in the INPUTS folder of the current I-SKETCH Project 
 
The PCF file created in point 3 above can be safely used for transferring data to TRIFLEX (Smart 
Stress Iso Conversion Option 1). It is also possible to add balloons with TRIFLEX node numbers to the 
PCF file (Smart Stress Iso Conversion Option 2). It is even possible to transfer the TRIFLEX data to 
the Stress Table (Smart Stress Iso Conversion Option 3) and generate Stress Isometrics. 
 
You can do practices related to handling CAD files in Smart Stress Iso either with provided "PDMS 
Interface.idf" file, or you can try your own IDF/PCF files from aforementioned CAD systems. 
 
I-CONVERT 
 
As said before, IDF/PCF file that comes from a CAD system is enough for Smart Stress Iso. However, 
the Stress Analyst normally needs to modify the piping network he/she has got from the piping 
department, and this may require adding new components such as pipe supports to the I-SKETCH 
drawing. I-SKETCH allows adding new components to a drawing only when appropriate Catalog and 
Spec exist in the system. 
 
The best way of creating I-SKETCH Catalogs and Specs that match the CAD project is using 
I-CONVERT, which is a part of I-SKETCH Enterprise license or which can be licensed separately. 
 
I-CONVERT is able to create proper Catalog and Specs directly from PDS, PDMS and AutoPlant. 
Catalog and Specs for other CAD programs such as Plant-4D can be done by running I-CONVERT 
with a collection of PCF files that belong to the CAD project and merging the data into unified set of 
Catalogs and Specs. We will not describe details of I-CONVERT here, as you will not need 
I-CONVERT for Smart Stress Iso practices. 
 

6.2 Material and Wall Thickness Information in Smart Stress Iso 
 
It is critical that Smart Stress Iso can recognize the material and wall thickness for components found 
in the PCF file that originates from CAD file import to I-SKETCH. This information is required to feed 
TRIFLEX with required information. 
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The PCF files that originate from IDF/PCF CAD files typically miss organized material and wall 
thickness info. The CAD files often keep this information in unformatted description fields, or this 
information is not stored in the CAD file at all (only the Piping Spec name may be available in the CAD 
file.) 
 
Smart Stress Iso comes with nifty tool that lets the user help the program organize the material/wall 
thickness information in easy semi-automated way. The tool will store this information automatically in 
the form of Smart Stress Iso Piping Specs. 
 

6.3 Work flow in Smart Stress Iso involving Piping Specs 
 
STEP 1: Importing the CAD file into I-SKETCH and generating the PCF
STEP 2: Running the conversion to TRIFLEX with semi-automatic Piping Spec generation
STEP 3: Perform Stress Analysis in TRIFLEX and save the iOUT file
STEP 4: Transfer the data from TRIFLEX to the Stress Table
STEP 5: Generate the Stress Isometric in Smart Stress Iso
 

6.4 STEP 1: Importing the CAD file into I-SKETCH and generating the PCF 
 

1. Start I-SKETCH. 
 
NOTE: You will be working in your current I-SKETCH project. The units of measure used in 
Smart Stress Iso will depend on units in which the I-SKETCH project has been set up 
 

2. Select File -> Import from menu in I-SKETCH. Select sample file "PDMS Interface.idf" that 
was installed in \Program Files\Smart Stress Iso\Samples folder. This is an IDF file that came 
from PDMS' IsoDraft module 

3. PipeLine Properties dialog appears. Depending on the settings of the I-SKETCH project, you 
will have the chance to make more or less choices. The information that has been extracted 
from the IDF file is, i.a., the Pipeline Reference (pipeline number). In our example: 
 

  
 
Click OK. The imported drawing appears in I-SKETCH: 
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4. You can inspect the drawing. For example, right-clicking on a flange lets you to select Item 
Code or Properties from a pop-up menu. Most of the 2" flanges here have this Item Code: 

 

 
 
Looking at the properties of the 2" blind flange you will see that: 
 
Piping Spec is: 01CS01 
Description is:  FLANGE BLIND ASME B16.5 150LB RF ASTM A105N 
 
The main 10" pipe: 
Item code: AAPA200VV-G 
Piping Spec: 01CS01 
Description: PIPE BEVEL ENDS SMLS SCH40 ASTM A106 GR.B 

 
You can also right click in empty drawing area to select Pipeline Header from pop-up menu. 

 
Right click in empty drawing area and select Generate Drawing from pop-up menu. You can select 
any Isometric  Style for iso generation: 

 
 
Click OK. 
 
After the isometric drawing has been generated, you can view it in AutoCAD as defined in I-SKETCH.  
 
NOTE: There can be more than one drawing generated. However, I-SKETCH always creates only one 
PCF file per a pipeline or a pipeline system. 
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6.5 STEP 2: Running the conversion to TRIFLEX with semi-automatic Piping Spec 
generation 

6.5.1 Actions 1 - 5 
 

1. Go back to Smart Stress Iso. Select File -> Open PCF from main menu. Open file 

 "10_-PM-10007-01CS01.pcf" that was generated in folder 

\Your_Isometric_Directory\Your_Project\INPUTS folder of your I-SKETCH environment.  

For default I-SKETCH installation it is \SampleProj\SampleProject\INPUTS folder.  

 

2. Select Edit -> Environment Parameters. Enter preferred path to the folder you would like to 
store your TRIFLEX files. The default is your TRIFLEX Samples folder: 
 

 
 
You might want to enter another convenient folder, for example  
 

 
 
  to store the TRIFLEX files together with I-SKETCH PCF files 
 

3. Ensure only this Conversion Mode button has been depressed: 
 

 
 

4. Select Edit -> Application Parameters. Select these options and click Accept button: 
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5. Click the Run  Conversion in main menu or press [F5]. Since the components of the PCF file 
is missing information about Material and Wall Thickness (the Piping Spec has not been 
created yet), the Spec Builder dialog starts automatically. 
 

 
 

6.5.2 The Spec Builder 
 
The Spec Builder works accordingly to the following scheme: 
 

• Each unique component found in the PCF file is identified by Item Code 
• Component diameters are determined 
• The Material Selection group serves to assign TRIFLEX material to the Item Code. The PCF 

Material list displays pre-defined material names and maps them onto TRIFLEX material. if 
your material is missing from the PCF Material list it is enough to select TRIFLEX material 
for given Item Code from the "TRIFLEX Material' list 

• "Ripple" button in the Material Selection group allows assigning the same TRIFLEX material 
to all components found in the PCF file. 
 
NOTE: Typically your material is different for different components, e.g., CS A234 for Tees 
and ASTM A105 for Flanges. However, both A234 and A105 are treated by TRIFLEX as Low 
Carbon Steel (code LS). In other words, components belonging to the same Piping Spec often 
are made of the same "base material". In such situation, clicking the Ripple button in the 
Material Selection group will apply the same "base material" to whole piping network, which 
saves data entry. 
 

• The Wallthickness Selection group serves to assign wall thickness to given Item Code. The 
selecting a schedule from Schedule list will automatically display wall thickness for given 
schedule. If the schedule for the component is missing from the Schedule list, it is 
enough to enter the wall thickness value in the Wallthickness field 
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• Rippling (automatic applying of) wall thickness is more sophisticated than rippling material. 
Typically, Piping Spec uses one Schedule for one nominal diameter. When the nominal 
diameter changes, different schedule is often applied. Therefore, there is a variety of wall 
thickness rippling options: 
 
Ripple Schedule or Ripple Wall thickness - you can propagate either the selected Schedule or 
entered wall thickness over the piping network. If you ripple the selected Schedule, wall 
thickness will be calculated for different sizes. 
 
Ripple stops if different size. You can instruct the Spec Builder to ripple over the whole piping 
network defined by the PCF file, or stop propagating data (e.g., wall thickness values) at the 
point when piping diameter changes. 
 

• PCF description field displays the Description field for given Item Code. Information from this 
field may help you to identify the material and schedule/wall thickness of given Item Code 

• The navigation control  allows you to move between components 
without the need of clicking the Accept button. The Accept button can be clicked at any time or 
when you have completed defining all components. 

• After clicking Accept button when all components have Material and Wall Thickness 
information, Smart Stress Iso will create own Piping Spec. The Piping Spec file has the 
following name [Specification name].txt ad it is stored in the Smart Stress Iso folder. 

• Next time you convert another PCF file that is of the same Piping Spec, the Spec Builder may 
not appear at all, provided all components are already in the Piping Spec file. Otherwise you 
will be asked to define Material and Wall Thickness for undefined components. 

 
As you may see, the PCF Material and Schedule lists may not include the actual names used in your 
project. It is possible to expand the lists with more info by editing files "materials.txt" and 
"schedules.txt" prior to running the conversion. The procedure to edit these files is given in sections 
7.3 and 7.4 of the "Customization" chapter. 
 
Note: For DIN, it is no use to use the Schedule list at all. For example, if your component is defined as 
having 2.0 mm wall thickness, simply enter 2.0 in the Wallthickness field: 
 

 
 
Note: If you specify wall thickness directly and you wish to ripple it, ensure you are rippling Wall 
Thickness, not the Schedule. 
 

6.5.3 Spec Builder practice 
 

The Spec Builder should be opened at the first component of the sample file, which is 
ELBOW, Item Code AAEA200VV, size 10" (cf. picture on page 6). As you can see in the PCF 
Description field, the elbow is made of A234 steel, and it is Schedule 40. 
 
Click  button in the navigation control to go to the next component: Inspect it and proceed to 
learn about all 13 unique components found in the PCF file. You will discover that all 
components are made of Low Carbon Steel (A105N, A106, A234…). Therefore, you can 
assign the same TRIFLEX material to all components. 
 
Click the  button to go back to the first component. Make this selection in the dialog: 
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NOTE: You know that the Low Carbon Steel code in TRIFLEX is LS. You even do not need to 
select the PCF Material from the list. It is enough to select LS from the TRIFLEX Material list. 
The PCF Material list has been made for your convenience only. 
 
Click the Ripple button in the Material Selection group now. You will see the message 
that the material has been rippled till the last component. When you now navigate through the 
components, you will see that all of them got the TRIFLEX Material LS, which was your 
intention. 
 
Navigating through the components, you can see that they have different schedules. However, 
three first 10" components are of Schedule 40. Go back to the first record and make these 
selections: 
 

 
 
Click the Ripple button in this section now. You will see this message: 

 
 
Click OK and move to the fourth component now. For this component (SOCKOLET SW 
3000LB ASTM A105N) select SCH XXS from the Schedule list.  
 
Move to the fifth component. Assign SCH 160 for this component and proceed to the sixth 
one. 
 
Assign SCH 40S to the 6th component which is ELBOW. 
 
Move to the 7th component (PIPE). Components 7 - 13 have Schedule 160. Enter this for the 
7th component: 
 

 
 
Note: You want to ripple the Schedule (not wall thickness), so you can uncheck the "Ripple 
stops if different size" checkbox. The SCH 160 will be applied to the end of the network, and 
proper wall thickness will be calculated for each component. 
 
Click Ripple in this section. Spec Builder will produce this message: 
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At this moment, all information has been entered. Click Accept button. 
 
The Spec Builder disappears. 
 

6.5.4 Run conversion 
 
Press [F5] or select Run  Conversion again. The conversion occurs almost instantly. 
 
As the result: 
 

• Smart Stress Iso Piping Spec "01CS01.txt" has been created in the program folder 
• File "10_-PM-10007-01CS01.IN", the input file to TRIFLEX has been created based 

on the PCF geometry and technical data 
 
If you were to convert more PCF files, Spec Builder would not ask you again for the material you had 
already defined. 

6.6 STEP 3: Perform Stress Analysis in TRIFLEX and save the iOUT file 
2. Start TRIFLEX from the menu Start > TRIFLEX. Save the job as "10_-PM-10007-

01CS01.DTA" with the File > Save As… menu of TRIFLEX. You are free to select the folder. It 
is the best to save the TRIFLEX job to the same folder as defined in Setup -> Environment 
Parameters (see STEP2, point 2.) 
 

3. Use the menu Utilities > Import Files > TRIFLEX Keyword to open the file "10_-PM-10007-
01CS01.IN" that Smart Stress Iso generated in the previous step. 
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When the data have been imported the imported pipeline is displayed:  
 

 
 

Inspect the input data in TRIFLEX and add missing information such as:  
• Case data (only data for one load-case are imported, by default T+P+W) 
• Piping Compliance Code 
• Support function, preliminary displacements 
• Anchor definition, preliminary movements 
• Flange Loading data etc. 

 
Note: Smart Stress Iso sets up the system of units in TRIFLEX based on I-SKETCH system of 
units. If I-SKETCH project has been set up entirely in English units, the TRIFLEX job will be 
set up in English units, too. If the length units in I-SKETCH have been Metric, the units in 
TRIFLEX will be Metric. This unit conversion is applied automatically, and it does not matter 
what were the original CAD units of measure; the data in TRIFLEX will be correct regardless 
of the system of units. 
 
Note: Enter the process data and ripple them from node 10 (Anchor) in TRIFLEX. We suggest 
setting the pressure to 600 kN/m2 gauge (or e.g, 90 psig) and the temperature to 200 °C (or 
e.g., to 400 F) 
 

4. Run Stress Analysis in TRIFLEX 
 

5. Save the TRIFLEX job. 
 

6. Export iOUT file from the menu Utilities > Export Files > iso OUT file. It is recommended 
that this file is created in the same folder as the IN file, and at best it be the folder that 
contains the original PCF file of I-SKETCH. Give the file name "10_-PM-10007-01CS01.iOut" 

 
7. Close TRIFLEX and return to Smart Stress Iso 
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CRITICAL NOTE: Your stress analysis may result in the need of modifying the piping network 
geometry to meet Code Compliance. If you modify the piping model in TRIFLEX, do not proceed 
to STEP 4, since the modified TRIFLEX model is not compatible with the original PCF file 
anymore. 
 
In such situation, go back to I-SKETCH, modify the geometry there, and repeat drawing 
generation there. Then transfer data to TRIFLEX and make validation analysis in TRIFLEX 
again.  
 
NOTE SPECIFIC TO FILES ORIGINATING IN 3-D CAD SYSTEMS: 
 
If you need to modify the piping model in I-SKETCH by adding new components, you need to 
have a valid I-SKETCH Catalog and Specs. The best way to make full I-SKETCH Catalog and 
Specs matching the 3-D CAD project is to use I-CONVERT application from Alias Ltd. 

6.7 STEP 4: Transfer the data from TRIFLEX to the Stress Table 
 

1. In Smart Stress Iso, depress all three Conversion Mode buttons: 
 

 : 
 

 
2. Use the File > Open OUT… menu in Smart Stress Iso to open iOUT file (in our example, the 

file "10_-PM-10007-01CS01.iOUT" 
 

3. Adjust some parameters for this conversion via the menu Edit > Application Parameters….. 
 

 
 

Note: Be careful to enter the cut-off value in proper units. The value as shown above is in 
millimeters. 

 
4. Click Run  Conversion menu or press [F5] key to perform the conversion.  
 
NOTE The conversion may take some time, as placing data into Excel spreadsheet is time-
consuming activity. (Be sure that STRESS.XLS is closed when you start conversion.) The 
conversion progress and result are reported in the fourth field of the Status Bar. 

 
Results: 

• As the result of the Conversion Mode 2, a modified file  
"10_-PM-10007-01CS01TR.PCF" has been created. This file has the same 
information as the original PCF file, but balloons with TRIFLEX node numbers have 
been added to the file. Bend displacements and support functions have been 
transferred to PCF file as well. 
 
NOTE Attribute PIPELINE-REFERENCE is modified by adding suffix STRESS_ISO to 
line number, so the line number becomes "10_-PM-10007-01CS01-STRESS ISO" in 
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our example. This is to avoid potential side effects if the original pipeline number were 
retained. 

• Thanks to Conversion Mode 3, TRIFLEX output data have been transferred to the 
following worksheets in STRESS.XLS Excel file: 

MAX VALUES 
ANCHORS 
SUPPORTS 
PCF DATA 
SPRING 

• LOG or ERR file is created in Smart Stress Iso folder. The LOG file documents all 
actions performed during conversion. ERR file contains diagnostic messages in case 
conversion fails. Both LOG and ERR files can be used for diagnostic purposes. 

• The Stress Table in the worksheet STRESS ISO (linked with Table.DWG) shows 
TRIFLEX output data selected to this table.  

 
NOTE The default stress table has been made as an example that can be customized 
to meet company standards. 

6.8 STEP 5: Generate the Stress Isometric in Smart Stress Iso 
 

1. If I-SKETCH is not running at the moment, start it via the menu Start > I-SKETCH in Smart 
Stress Iso. If you have not closed I-SKETCH in STEP 1, use the File -> Close menu in I-
SKETCH to prepare for the next job 
 

2. Use the File -> Import menu to open the modified PCF file into I-SKETCH (in our example it 
will be "10_-PM-10007-01CS01TR.PCF"). The piping will appear in I-SKETCH after you have 
clicked OK in the PipeLine properties dialog of I-SKETCH 
 

3. Right-click in empty space of the drawing and select "Generate Drawing" from pop-up menu. 
Make these setting before you click OK: 
 

 
 

4. After clicking OK wait until "Drawing Generated"" dialog appears. Select the drawing of your 
interest and click View drawing. AutoCAD will start with the Stress Isometric opened. 
AutoCAD will upfront display the "Update Linked OLE Objects?". Click Yes. 

 
Note: The Stress Table will appear under AutoCAD only. Do not attempt to use the default 
DXF viewer of I-SKETCH (the Volo Viewer) to see the Stress Iso. 
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Have a look at a portion of generated Stress Isometric(s) in greater detail: 
 

 
 
You can see the balloons defining the locations of TRIFLEX nodes there. Also, support functions are 
displayed. 
 
The sample Stress Table looks like this one: 
 

 
 

Note: Actual values will depend on how you have set up your Stress Analysis in TRIFLEX. 
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You can compare these data with the TRIFLEX analysis data. For example, compare 
"FORCES AND MOMENTS ON SUPPORTS" of the Stress Table with the "Restraints Forces 
and Moments" report of TRIFLEX: 
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7 Customization 
 
Smart Stress Iso performs PCF conversion for pipeline system created in I-SKETCH based on ANSI 
related material classes. If you have customized I-SKETCH material classes (specs) then you may 
want to edit related file ANSI.DB 
 
(If you use DIN material, you will be best off with using Piping Specs and Spec Builder as described in 
Chapter 6.) 

  
You can as well extract data about insulation for only one sample Insulation Specification, named 
SAMPLE. If you need more Insulation Specifications you have to modify INSULCLASS.TXT file. The 
structure of this file is described below. 

7.1 ANSI.DB; file required for material and wall-thickness extraction 
 
This file contains 2 main sections: 

- MATERIAL 
- WALLTHICKNESS 

 
The first is material section. It begins by a line: 
 
[MATERIALS] 
 
followed by a line, which is a list of material fields (separated by coma) in ANSI.DEF file: 
 
PipeSpec;Material;FittingMaterial 
 
I-SKETCH-TRIFLEX conversion tool will look for these fields in component description definitions in 
ANS.DEF file (see ELBOW example in chapter 3.2). Then the correct material in actual descriptions in 
attribute DESCRIPTION in PCF file is found (in the ELBOW example it is FRG CS A234 WPB). 
 
Remaining lines in section MATERIAL contain I-SKETCH materials associated with TRIFLEX material 
code, so in the ELBOW example it is: 
 
FRG CS A234 WPB;LS 
 
So finally in TRIFLEX Keyword File material LS will be used for respective components 
 
The second section begins by a line: 
 
[WALLTHICKNESS] 
 
followed by a line, which is a list of wall thickness fields (separated by coma) in ANSI.DEF file: 
 
Thickness 
 
Smart Stress Iso will look for these fields (in this case it is only one field) in component description 
definitions in ANS.DEF file (see ELBOW example in chapter 3.2). Then the correct schedule name in 
actual descriptions in attribute DESCRIPTION in PCF file is found (in the ELBOW example it is  
SCH WT). 
 
The next lines are lists of: 

- Metric Nominal Sizes 
- Imperial Nominal Sizes (in the same order as for metric nominal diameters) 
- Metric Outside Diameters (in the same order as for metric nominal diameters) 
- Imperial Outside Diameters (in the same order as for imperial nominal diameters) 
- Schedule names with listing of assigned metric or imperial wallthicknesess to sizes in order as 

for Metric/Imperial Nominal Sizes 
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All data are separated by semicolon from each other. The second field in each line is used to 
recognize if data are in Metric or Imperial units. You can name freely Schedules but the names have 
to correspond to those used by I-SKETCH.  
 
Diameters;M;20;25;32;40;50;65;80;100;125;150;200;250;300;350;400;450;500;550;600;700;750 
Diameters;E;0.75;1.0;1.25;1.5;2.0;2.5;3.0;4.0;5.0;6.0;8.0;10.0;12.0;14.0;16.0;18.0;20.0;.. 
ODiameters;M;26.9;33.4;42.4;48.3;60.3;73.0;88.9;114.3;139.7;168.3;219.1;273.1;323.9;355.6;.. 
ODiameters;E;1.05;1.315;1.62;1.9;2.375;2.875;3.5;4.5;5.563;6.625;8.625;10.75;12.75;14.0;... 
STD WT;M;2.87;3.38;3.56;3.68;3.91;5.16;5.49;6.02;6.55;7.11;8.18;9.27;9.52;9.52;9.52;9.52;... 
STD WT;E;0.113;0.133;nil;0.145;0.154;0.203;0.216;0.237;0.258;0.28;0.322;0.365;0.375;0.375;... 
X-STG;M;3.91;4.55;4.85;5.08;5.54;7.01;7.62;8.56;9.53;10.97;12.7;12.7;12.7;12.7;12.7;12.7;.. 
X-STG;E;0.154;0.179;nil;0.2;0.218;0.276;0.3;0.337;0.375;0.432;0.5;0.5;0.5;0.5;0.5;0.5;0.5;.. 
SCH 20;M;nil;nil;nil;nil;nil;nil;nil;nil;nil;6.35;6.35;6.35;7.93;7.93;7.93;9.52;9.52;9.52;.. 
SCH 20;E;nil;nil;nil;nil;nil;nil;nil;nil;nil;nil;0.25;0.25;0.25;0.312;0.312;0.312;0.375;.. 
SCH 30;M;nil;nil;nil;nil;nil;nil;nil;nil;nil;7.04;7.8;8.38;9.25;9.52;11.13;12.7;12.7;14.27;.. 
SCH 30;E;nil;nil;nil;nil;nil;nil;nil;nil;nil;nil;0.277;0.307;0.33;0.375;0.375;0.438;0.5;nil;.. 
SCH 10S;M;2.11;2.78;2.78;2.78;2.78;3.05;3.05;3.05;3.4;3.4;3.76;4.19;4.57;4.76;4.76;4.76;.. 
SCH 10S;E;0.083;0.109;0.109;0.109;0.109;0.12;0.12;0.12;0.134;0.134;0.148;0.165;0.18;0.188;.. 
SCH 40S;M;2.87;3.38;3.56;3.68;3.91;5.16;5.49;6.02;6.55;7.11;8.18;9.27;9.52;nil;nil;nil;nil;.. 
SCH 40S;E;0.113;0.133;nil;0.145;0.154;0.203;0.216;0.237;0.258;0.28;0.322;0.365;0.375;nil;.. 
 
For example: an elbow in PCF file may be defined by: 
 
ELBOW 
    END-POINT          0.0000       -960.3200    -1047.6000 4.0000 
    END-POINT          0.0000       -1112.7200   -1200.0000 4.0000 
    CENTRE-POINT       0.0000       -960.3200    -1200.0000 
    SKEY               ELBW 
    ANGLE              9000 
    ITEM-CODE          EEL90CFSTD-LBW 
    FABRICATION-ITEM  
    UNIQUE-COMPONENT-IDENTIFIER 479C9999-DBF6-11D4-9BA2-B6A0DCEC9224 
    INSULATION-ON  
 
and 
 
ITEM-CODE EEL90CFSTD-LBW 
    DESCRIPTION ELBOW, 90 DEG, FRG CS A234 WPB, STD WT, LR, BW 
 

- the schedule name is the fourth filed in DESCRIPTION: STD WT 
- the imperial size (see Header information) is 4.000 (last number in END-POINT attribute) 
- 4.0 inch is the 8th field in Diameters, Imperial (“E”) 
- 8th field in Metric Odiameters (units for conversion are selected based on the field  

UNITS-CO-ORDS data in PCF header) is 114.3  
- 8th field in SCH WT, Metric is 6.02 

 
You may add data to each section to extend its functionality. You can delete the file provided with 
Smart Stress Iso application and create a completely new file with the same structure. 

7.2 INSULCLASS.TXT; file required for insulation data extraction 
 
This file contains data required to assign: 

- TRIFLEX insulation material code 
- Insulation thickness 

to each component of the Pipeline described in PCF file, based on the attribute INSULATION-SPEC. 
Each insulation specification is defined in a block, which has the following structure: 
 
[SAMPLE]  - insulation specification name in square brackets 
20;0.75;30;1;MW - field 
25;1;30;1;MW  - field 
. 
. 
. 
750;30;100;4;MW - field 
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[END]   - line which terminates the definition 
 
For each diameter you have to add a line which includes 5 fields: 

- metric nominal size 
- imperial nominal size 
- insulation thickness in mm 
- insulation thickness in inch 
- TRIFLEX insulation material code 

7.3 Customizing the "materials.txt" map file 
 
When you wish the user had easy Material selections for your imported 3-D CAD drawings in Smart 
Stress Iso Spec Builder, you can define names of all materials found in your 3-D CAD Piping Specs 
and relate them to TRIFLEX materials. 
 
This is the structure of the "materials.txt" file found in the Smart Stress Iso folder: 
 
CAD material name;TRIFLEX material name 
 
To easily open the "materials.txt" file, you need to select first Setup -> Application Parameters and 
click the "Material \ Wallthickness based on Piping Spec files". Then click View -> View Materials file 
in Smart Stress Iso menu. 
 
A part of the default "materials.txt" looks like this one: 
 
WP304L SS A403;AS 
WP316 SS A403;AS 
WP316L SS A403;AS 
WP321 SS A403;AS 
 
Let's assume you need to add two new materials with these literal names: 
 
ASTM A234 
5 Cr Ni 1810 DIN 
 
The ASTM A234 steel is Low Carbon Steel that has the code LS in TRIFLEX. 
The 5 Cr Ni 1810 DIN steel is treated as Austenitic Steel (AS) in TRIFLEX 
 
To add this material so the user can select precisely these names in Spec Builder, add these two lines 
anywhere in the "materials.txt" file : 
 
ASTM A234;LS 
5 Cr Ni 1810 DIN;AS 
 
Save the file and exit Smart Stress Iso. Next time you start the program and make a conversion based 
on Piping Spec files and the Spec Builder detects it needs to appear, you will see in the Spec Builder: 
 

 
 

17 



Selecting this material will provide the right TRIFLEX material: 
 

 

7.4 Customizing the "schedules.txt" map file 
 
Similarly to customizing the Materials used in Piping Spec based conversion of PCF files (see 
previous section, you can customize the "schedules.txt" file that relates the name of the Schedule and 
Nominal Diameter to wall thickness used by TRIFLEX. 
 
To easily open the "schedules.txt" file, you need to select first Setup -> Application Parameters and 
click the "Material \ Wallthickness based on Piping Spec files". Then click View -> View Schedules 
file in Smart Stress Iso menu. 
 
The structure of the Schedules file is the following: 
The first two lines list nominal diameters, in Metric then English units 
Diameters;M;NomDiam1; NomDiam2;….; NomDiamN 
Diameters;E; NomDiam1; NomDiam2;….; NomDiamN 
 
Next two lines define matching Outside Diameters in both Metric and English units 
ODiameters;M;OD1;OD2;…;ODn 
ODiameters;E;OD1;OD2;…;Odn 
 
Then data records follow. For each Schedule there are two lines: first one defines wall thickness for all 
diameters expressed in milllimeters, and the second one does the same using inches. 
 
Schedule name;M;Wthick1;Wthick2;…;WthickN 
Schedule name;E;Wthick1;Wthick2;…;WthickN 
 
You are free to add mode Nominal and Outside diameters, as well as to add more Schedules. 
 
Note: For DIN, it is no use to customize the Schedules file. For example, if your component is defined 
as having 2.0 mm wall thickness, it is simpler to just enter 2.0 in this field of the Spec Builder than 
customize the Schedules file: 
 

 
 
Note: If you specify wall thickness directly and you wish to ripple it, ensure you are rippling Wall 
Thickness, not the Schedule. 
 

7.5 Customizing stress isometrics 
You can customize: 
− Stress Isometric Drawing Frame 
− Stress Table layout 

7.5.1 Stress Isometric Drawing Frame 
You can adjust both STRESS.DXF and TABLE.DWG changing layout of the stress isometric. The only 
requirements are as follows: 

18 



− STRESS.DXF has to be saved in DXF for AutoCAD rel.12. This requirement explains why the 
reference to another drawing is required as STRESS.DXF for AutoCAD 12 doesn’t save the 
information about OLE pasted and linked objects 

− When you paste the new Stress Table to AutoCAD please remember to paste it as a linked object. 
Then any change done in STRESS.XLS is shown automatically on isometric in AutoCAD. 

7.5.2 Stress Table layout 
The reason to introduce stress data to stress isometric through Excel spreadsheet is to give you as 
much as possible flexibility in selecting data you want to show in your Stress Table and in creating 
your own Stress Table layout for this data. You should know Excel basics to do it. 
You have to remember that: 
− data in Worksheets SPRING, SUPPORTS, ANCHORS, MAX VALUES and PCF DATA are lost 

always when you start Conversion Mode 3 
− don’t rename or delete any of existing Worksheets in STRESS.XLS.  
− you can add also any necessary Macro to your table to automate placing additional data in your 

STRESS TABLE 
− when you change the layout you have to adjust TABLE.DWG 
− to increase amount of data transferred automatically from I-SKETCH to Stress Table you are 

advised to use PCF job Attributes (see Section 9.2) as much as possible. You can extend the 
number of Attributes to 100. 
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8 Known problems 
 

1. If conversion of your file is interrupted by error message about data mismatch, then it is very 
likely that comma “,” is used as a decimal separator in your system. Please change it to dot “.” 

 
2. The current release of Smart Stress Iso doesn’t convert the following ISOGEN piping 

components: 
• CROSS 
• CROSS-SET-ON 
• CROSS-STUB 
• VALVE-4WAY  
• INSTRUMENT-4WAY 
• Y-PIECE 
• VALVE-MULTIWAY 
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9 PCF structure 
 
This chapter is for advanced users. It describes the structure of the Alias’ PCF file used in Smart 
Stress conversions. 
 
PCF is a text file, which you can open in any text editor. It is structured into 5 sections: 
 

9.1 Basic Header Information 
In general it contains information about units that are to be used in the data associated with the 
piping component definitions. In the example file LP100.PCF this section consists of the first 6 
lines: 

 
ISOGEN-FILES            ISOGEN.FLS 
UNITS-BORE              INCH 
UNITS-CO-ORDS           MM 
UNITS-BOLT-LENGTH       MM 
UNITS-BOLT-DIA          INCH 
UNITS-WEIGHT            KGS 
  
 In the current version of Smart Stress Iso you can use: 

- INCH or MM for UNITS-BORE 
- INCH or MM for UNITS-CO-ORDS 
- LB or KGS for UNITS-WEIGHT 
- Data associated with ISOGEN-FILES, UNITS-BOLT-LENGTH and UNITS-BOLT-DIA 

are not used 
 

9.2 Pipeline Header Information 
This section begins from the attribute PIPELINE-REFERENCE and contains various number of 
entries. Each entry is described in one line, which starts in the column number 5. In general all 
data in this section applies to all Pipeline components. This section is terminated by the first 
Component Identifier (starts in the column position one). In the file LP100.PCF it is as follows: 
 

PIPELINE-REFERENCE      LP100 
    REVISION            1 
    PROJECT-IDENTIFIER  P-500 
    AREA                AR-1 
    PIPING-SPEC         CS150 
    NOMINAL-RATING      150# 
    PIPELINE-TYPE       W 
    DATE-DMY            06/01/2001 
    INSULATION-SPEC     SAMPLE 
    PAINTING-SPEC       PNT-1 
    PIPELINE-TEMP       200C 
    SPECIFIC-GRAVITY    1 
    SPOOL-PREFIX        SPL- 
    ATTRIBUTE0          C:\SampleProj\SampleProject\PIPES\LP100.iso 
    ATTRIBUTE1          10 % 
    ATTRIBUTE2          T-50 
    ATTRIBUTE4          PROCESS 502 
    ATTRIBUTE5          AR-100 
    ATTRIBUTE6          56-902 
    ATTRIBUTE7          TSR 
    ATTRIBUTE8          HJM 
    ATTRIBUTE9          WAL 
    ATTRIBUTE10         SPECIALITY  OILS 
    ATTRIBUTE11         10 % 
    ATTRIBUTE12         YES 
    ATTRIBUTE13         C-51 
    ATTRIBUTE14         T-28 
    ATTRIBUTE15         F-56 
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    ATTRIBUTE16         P-25 
    ATTRIBUTE17         1300 
    START-CO-ORDS       0.0000       0.0000       0.0000 
 

Data associated with the following attributes are used by the current version of Smart Stress 
Iso: 

- line number from PIPELINE-REFERENCE 
- project name from PROJECT-IDENTIFIER 
- area name from AREA 
- rating from NOMINAL-RATING 
- name of insulation specification from INSULATION-SPEC (used to extract insulation material 

code and thickness from INSULCLASS.TXT; see also 7.2) 
- specific gravity from SPECIFIC-GRAVITY 
- name of I-SKETCH problem from ATTRIBUTE0 

 

9.3 Pipeline Components and Connection Information 
This section contains specific data of each piping component in the Pipeline. Each component 
is described in a data block, commencing from the Component Identifier (always begins in 
column position one), followed by location, size, end-connection and specific physical attributes 
(always starts in column position 5). In the file LP100.PCF it is as follows: 
 

GASKET 
    END-POINT          0.0000       0.0000       0.0000 4.0000 
    END-POINT          0.0000       -1.5700      0.0000 4.0000 
    ITEM-CODE          GCA150-RG2 
    ERECTION-ITEM  
    UNIQUE-COMPONENT-IDENTIFIER 479C99B8-DBF6-11D4-9BA2-B6A0DCEC9224 
FLANGE 
    END-POINT          0.0000       -1.5700      0.0000 4.0000 
    END-POINT          0.0000       -7.9200      0.0000 4.0000 
    SKEY               FLSO 
    ITEM-CODE          FCD150-SOR 
    FABRICATION-ITEM  
    UNIQUE-COMPONENT-IDENTIFIER 479C99C2-DBF6-11D4-9BA2-B6A0DCEC9224 
    INSULATION-ON  
PIPE 
. 
. 
. 
. 
PIPE 
    END-POINT          -1002.7935   -820.0328    600.0000 2.0000 
    END-POINT          -1002.7935   -1320.0328   600.0000 2.0000 
    ITEM-CODE          PA5BSTD 
    FABRICATION-ITEM  
    UNIQUE-COMPONENT-IDENTIFIER 479C99FA-DBF6-11D4-9BA2-B6A0DCEC9224 

 
Data associated with the following attributes are used by the current version of Smart Stress 
Iso: 

- coordinates from END-POINT, BRANCH1-POINT, CENTRE-POINT 
- size, end-connection from END-POINT 
- INSULATION-ON means that component is insulated 
- weight from WEIGHT 
- elbow data from ANGLE, ELBOW-RADIUS 
- support data from  DIRECTION 

9.4 Material Item Codes 
This sections contains description for each component described in the Pipeline Components 
and Connection Information section. This section begins from the MATERIALS identifier, 
followed by 2 lines per description blocks.  
 

MATERIALS 
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ITEM-CODE PA5BSTD 
    DESCRIPTION PIPE, CS API 5L SML, GRD B, STD WT 
ITEM-CODE EEL90CFSTD-LBW 
    DESCRIPTION ELBOW, 90 DEG, FRG CS A234 WPB, STD WT, LR, BW 
. 
. 
ITEM-CODE VVGCF150-FLO 
    DESCRIPTION VALVE, GLOBE, CS ASTM A234, 150#, FL, OS&Y 
ITEM-CODE VVGCF150-FLO 
    DESCRIPTION VALVE, GLOBE, CS ASTM A234, 150#, FL, OS&Y 
ITEM-CODE GCA150-RG2 
    DESCRIPTION GASKET, CAF, 150#, RING, 1/16 IN 
. 
. 
. 
ITEM-CODE PSL 
    DESCRIPTION SUPPORT TO SITE STANDARDS. SEE LIST OF SPECIAL ITEMS. NS2 INCH 
 

In PCF created by I-SKETCH, only DESCRIPTION attribute in MATERIALS section contains 
data about material and wall-thickness. Smart Stress Iso extracts these data based on the 
structure of the DESCRIPTION attribute. This structure is defined in I-SKETCH *.DEF files. 
ANSI based components use ANSI.DEF file, which is in …\MATERIALS V2\ANSI\ folder.  
For example the following block of data defines description for ELBOW: 
 

[Elbow*] 
E 
ElbowType;2 
Angle;2 
FittingMaterial;2 
2*Class:Thickness;4 
Radius;1 
EndType;2 

 
So you know that in DESCRIPTION: 
 

ELBOW, 90 DEG, FRG CS A234 WPB, STD WT, LR, BW 
 

material is the third field: FRG CS A234 WPB and schedule is the forth one: STD WT 
These data have to be converted into TRIFLEX material code and actual wall-thickness. 
Both data required for extraction and conversion of material and wall-thickness are defined in 
the file ANSI.DB. More information about this file you can find in the chapter 7.1. 
 

 
This concludes the Smart Stress Iso User Manual. 
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