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Chapter 10  NextOffice Base

NextOffice Base is the database application in NextOffice. You can create new database or
connect to different kinds of existing databases. Besides, you can also manage tables, queries,
forms and reports in database files. (Fig. 10-1)

Fig. 10-1

Database is used for storage of large amount of information. Its specially designed structure can
help to manage, update and retrieve information quickly. Structures Query Language (SQL) is a
standard query language used in database for management and accessing information. It can be
used in many different types of database systems.

Database Wizard
Select menu “File” → “New” → “Database” to pop-up the
“Database Wizard” (Fig. 10-2). You can follow the guideline
and steps of the wizard to setup database file easily.

The detailed steps for the wizard are as follows:

Fig. 10-2                      

NextOffice  User Manual 10-1



Chapter 10 NextOffice Base      NextOffice

Create New Database

Database wizard can be used to create a new database.

1. First activate the “Database Wizard”.

2. Under step “1. Select database”, select “Create a new database” and then click “Next”.(Fig.
10-3)

3. Under step “2. Save and proceed” (Fig. 10-4), you can choose to register the database in
NextOffice. Registered database can be used in other applications of NextOffice. Finally
click “Finish”.

4. Select the path and enter the name for the database files. Click “Save” to complete the
process.

Fig. 10-3 Fig. 10-4

Connect to Existing Database
NextOffice provides many different interfaces for connecting databases, such as ODBC, MS
Access, JDBC, spreadsheet documents, text files, dBase, address book, etc.
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Set up ODBC Connection
In Windows, the most commonly used interface is ODBC. To use ODBC interface, you have to
first install the driver provided by database manufacturer. And then do the required configuration
in Windows.

Taking MySQL as an example. You have to install the “MySQL ODBC Driver”, then:

1. Click the start menu and choose “Control Panel” to pop-up the “Control Panel” dialog box
(Fig. 10-5). Then double click on the “Administrative Tools” icon.

2. Double click on “Data Sources (ODBC)” icon. (Fig. 10-6)

Fig. 10-5 Fig. 10-6

3. Select the “User DSN” tab, and then click “Add”. (Fig. 10-7). Select “MySQL” as the driver.
(Fig. 10-8)

Fig. 10-7
Fig. 10-8

NextOffice  User Manual 10-3



Chapter 10 NextOffice Base      NextOffice

4. Enter the following information and then click <OK>. (Fig. 10-9)

Fig. 10-9

Using “Database Wizard” setup the connection:

1. Activate “Database Wizard”.

2. Under step “1. Select database” (Fig. 10-10), select “Connect to an existing database”. Also
select “ODBC” for “Database type”, click “Next”.

3. Under step “2. Set up ODBC connection” (Fig. 10-11), click “Browse” to pick up the
ODBC database you wish to connect. Then click “Next”.

Fig. 10-10 Fig. 10-11
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4. Under step “3. Set up user authentication” (Fig. 10-12), enter the “User name”. If you do not
create new user, you can enter the default user “root”. You are recommended to check the
“Password required” check box for security issue.

5. To test the connection, press the “Test Connection” button in the bottom right corner. When
it is successfully established, click “Next”. (Fig. 10-13)

Fig. 10-12

Fig. 10-13

6. Under step “4. Save and proceed” (Fig. 10-14), click “Finished” to save the database file.

Fig. 10-14

Set up MS Access Connection
It is easy to connect to MS Access. You have to first activate the “Database Wizard”:

1. Under step “1. Select database” (Fig. 10-15), select “Connect to an existing database”. Select
“Microsoft Access” for “Database type”, click “Next”.

2. Under step “2. Set up Microsoft Access connection” (Fig. 10-16), click “Browse” to pick up
the Access file (*.mdb). Then click “Next”.
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Fig. 10-15 Fig. 10-16

3. Under step “3. Save and proceed”, click “Finished” to save the database file. (Fig. 10-17)

Fig. 10-17

Set up JDBC Connection
In NextOffice Base, you are able to connect to JDBC database.

You have to first download the required jar files and settings in NextOffice.

1. Select menu “Tools” → “Options” → “NextOffice” → “Java”. (Fig. 10-18)

2. Click on “Class Path” to pop-up “Class Path” dialog box (Fig. 10-19). Click “Add Archive”
for single jar file or click “Add Folder” for the path of jar files. 
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Fig. 10-18
Fig. 10-19

3. You have to restart NextOffice so the new or modified values can take effect (Fig. 10-20).
You have to close all the NextOffice applications, including the “Quickstarter” on the
bottom right hand corner.

Fig. 10-20

After setting up JDBC driver, you can now activate the “Database Wizard”:

1. Under step “1. Select database” (Fig. 10-21), select “Connect to a existing database” and
select “JDBC” for “Database type”. Then click “Next”.

2. Under step “2. Set up JDBC connection” (Fig. 10-22), enter “Datasource URL” and “JDBC
driver class”.

Fig. 10-21 Fig. 10-22

3. You can click on the “Test Class” button to carry out the JDBC driver test. If the driver is
successfully loaded, click “Next”. (Fig. 10-23)
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4. Under step “3. Set up user authentication” (Fig. 10-24), enter the “User name”. You are
recommended to check the “Password required” check box for security issues.

Fig. 10-23

Fig. 10-24

5. To test the connection, press the “Test Connection” button in the bottom right corner. When
it is successfully established, click “Next”. (Fig. 10-25)

6. Under step “4. Save and proceed” (Fig. 10-26), click “Finished” to save the database file.

Fig. 10-25

Fig. 10-26

Set up dBase Connection
dBase treats the whole folder as a whole. One single DBF file represents one single table. dBase
is easy to setup and manage, but is not a suitable format for large database.

1. Activate “Database Wizard”.

2. Under step “1. Select database” (Fig. 10-27), select “Connect to a existing database” and
select “dBASE” for “Database type”. Then click “Next”.
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3. Under step “2. Set up dBASE connection” (Fig. 10-28), click “Browse” to pick up the path
of the dBase database. Then click “Next”.

Fig. 10-27 Fig. 10-28

4. Under step “3. Save and proceed” (Fig. 10-29), click “Finished” to save the database file.

Fig. 10-29

Set up Spreadsheet Connection
NextOffice spreadsheet documents or MS Excel files can also set up as database. One single
worksheet represents one single table.

1. Activate “Database Wizard”.

2. Under step “1. Select database” (Fig. 10-30), select “Connect to a existing database” and
select “Spreadsheet” for “Database type”. Then click “Next”.
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3. Under step “2. Set up Spreadsheet connection” (Fig. 10-31), click “Browse” to pick up the
spreadsheet file. If the file is password-protected, you have to check the “Password
required” check box. Click “Next”.

Fig. 10-30 Fig. 10-31

4. Under step “3. Set up user authentication” (Fig. 10-32), you can test the connection by
pressing the “Test Connection” button in the bottom right corner. When it is successfully
established, click “Next”.

5. Under step “4. Save and proceed” (Fig. 10-33), click “Finished” to save the database file.

Fig. 10-32 Fig. 10-33

Set up Text File Connection
In a text file database, data is stored in formatted text file, where each record comprises a row.
The data fields are divided by separators such as “;” or “:”. Similar as dBASE database, the
folder is treated as a whole. One single text file represents one single table.
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1. Activate “Database Wizard”

2. Under step “1. Select database” (Fig. 10-34), select “Connect to a existing database” and
select “Text” for “Database type”. Then click “Next”.

3. Under step “2. Set up a connection to text files” (Fig. 10-35), click “Browse” to pick up the
path of the text files database. Then click “Next”.

Fig. 10-34 Fig. 10-35

4. You are also required to specify the type of files, and select the field separator, text
separator, decimal separator and thousands separator. After that, click “Next”.

5. Under step “3. Save and proceed” (Fig. 10-36), click “Finished” to save the database file.

Fig. 10-36

Set up Address Book Connection
You can use the “Address Book Data Source Wizard” to connect the address book in Windows:
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1. Select menu “File” → “Wizard” → “Address Data Source” to pop-up “Address Book Data
Source Wizard”. (Fig. 10-37)

2. First, select the type of your address book. For example, select “Windows system address
book” for “Outlook Express”, select “Outlook address book” for “Outlook”, select
“Mozilla/Netscape” for “Mozilla/Netscape”, etc. Then click “Next”. (Fig. 10-38)

Fig. 10-37

Fig. 10-38

3. Click “Browse” to pick up the location and enter the name of the database file. Finally, click
“Finished”. (Fig. 10-39)

Fig. 10-39

Notes: Address book database is read-only. You are not allowed to modify the address record.

Database Objects
There are four database objects included in Base. Each object has its own functions and features.

Table

For a newly created database, you must first create table for it.
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Create Table in Design View

For example, create an address book with fields “Name”, “Telephone”, “Address” and
“Birthday”:

1. Click “Create Table in Design View” under “Task” to pop-up the “Table Design” dialog
box. (Fig. 10-40)

2. Enter “Field Name” and select the appropriate “Field Type” (Fig. 10-41). For example,
select “Text [varchar]” for “Name” field and select “Date [date]” for “Birthday” field.

Fig. 10-40 Fig. 10-41

3. You can further configure the field in “Field Properties”. Guidelines for each field property
are shown on the right. (Fig. 10-42)

4. Each table must have primary key. To define, for example, “Name” as primary key, you
have right click on “Name” and choose “Primary Key” (Fig. 10-43). Then, A small key will
appear next to “Name”.

Fig. 10-42 Fig. 10-43
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5. Click the “Save” icon and enter the table name to save the table design. (Fig. 10-44)

Fig. 10-44

Edit Table Design
You can modify the table design at any time:

1. Right click on the table name and choose “Edit”. (Fig. 10-45)

2. Right click on the left of the “Field Name”. You can select “Delete” to delete the field, or
select “Insert Rows” to insert new field. (Fig. 10-46)

Fig. 10-45 Fig. 10-46

3. For example, insert a new field “Mobile”. So select “Insert Rows” and then enter “Mobile”
for the “Field Name” and select “Decimal [decimal]” as the “Field Type”. (Fig. 10-47)

Fig. 10-47

4. Finally, click the “Save” icon.
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Notes: NextOffice Base only provides limited table design functions. You are allowed to add or
delete field, but not allowed to modify the field settings.

Index
Index can help to increase the speed of query. You are recommended to create index for fields
frequently used in query. To navigate index settings, you can select menu “Tools” → “Index
Design” in the “Table Design” dialog box. (Fig. 10-48)

An index called “PRIMARY” is automatically created for primary key. You can also create your
own index by clicking on the “New Index” icon. (Fig. 10-49)

Fig.10-48
Fig.10-49

Use Wizard to Create Table

You can make use of wizard to create table.

1. Click on the “Use Wizard to Create Table” under “Task” to pop-up “Table Wizard”. (Fig.
10-50)

2. Under step “1. Select fields” (Fig. 10-51), you can pick up suitable tables and fields from
category “Business” or “Personal”. For example, to create an address book, you can select
sample table “Addresses” under category “Personal”. Click “>”, “>>”, “<” or “<<” button to
select desired fields. Then click “Next”.

Fig. 10-50
Fig. 10-51
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3. Under step “2. Set types and formats” (Fig. 10-52), you can further configure the “Field
information” such as “Field Type”, “Entry Required”, “Length”, etc. Then click “Next”.

4. Under step “3. Set primary key” (Fig. 10-53), check the “Create a primary key” check box
to set up primary key. You can choose “Automatically add a primary key” or “Use an
existing field as a primary key”. Then click “Next”.

Fig. 10-52 Fig. 10-53

5. Finally enter the table name. (Fig. 10-54)

Fig. 10-54

Query
Query can display some specified data records, or just display some required fields. If required, it
can also sort the data records. A query can contain more than one table.

Create Query in Design View

For example, create a query to display all the leave record of employee:
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1. Click on “Query” under “Database”, and then click on “Create Query in Design View”
under “Task” to pop-up the “Query Design” dialog box. (Fig. 10-55)

2. In the “Query Design” dialog box, select the required tables in “Add table” dialog box, for
example, “employee” and “leavehistory”. Then click “Close” to close the “Add Table”
dialog box. (Fig. 10-56)

Fig. 10-55 Fig. 10-56

3. If there are data relations between a field in one table and a field in another table, you have
to define the relations in the query. Select menu “Insert” → “New Relation” (Fig. 10-57) to
pop-up “Join Properties” dialog box. In our example, “Fields involved” are the “EMP_NO”
fields in both tables (Fig. 10-58). Alternatively, you can use the mouse to drag from
“EMP_NO” field in “employee” to “EMP_NO” field in “leavehistory”.

Fig. 10-57
Fig. 10-58

4. Enter the field information for the query.
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The detailed description for all fields:
Field : Field used in the query.
Alias : Display name for field. It can be different from the original field name.
Table : Table of the particular field.
Sort : Sorting method used in query, can be “ascending” or “descending”.
Visible : Display the field in the query or not.
Function : Function used in query, e.g. “Count”, “Max”, “Min”, etc.
Criterion : Criterion of query. If more than one criterion, enter it in “Or”.

5. Click the “Run Query” icon on the Tool Bar. The query result will display on the top of the
“Query Design” dialog box. (Fig. 10-59)

6. Select menu “View” → “Preview” to close the query result. Click the “Save” icon and enter
query name to save the query. (Fig. 10-60)

Fig. 10-59

Fig. 10-60

Use Wizard to Create Query
We still apply the leave record example here:

1. Click “User Wizard to Create Query” under “Task” to pop-up “Query Wizard” dialog box.
(Fig. 10-61)

2. Under step “1. Field selection”, select the desired tables and fields for the query. In this case,
select fields “FIRST_NAME” and “LAST_NAME” from table “employee”, and fields
“START_DATE” and “END_DATE” from table “leavehistory”. Then click “Next” (Fig. 10-
62)

Fig. 10-61

Fig. 10-62
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3. Under step “2. Sorting order”, select the sorting order. Then click “Next”. (Fig. 10-63)

4. Under step “3. Search conditions”, select the search conditions such as “is equal to”, “is
smaller than”, ..., “like”. Then click “Next”. (Fig. 10-64)

Fig. 10-63 Fig. 10-64

5. Under step “7. Aliases”, enter the display name of each field. It can be different from the
original one. Then, click “Next”. (Fig. 10-65)

6. Under step “8. Overview”, check the overall settings. If it is OK, click “Finish”. (Fig. 10-66)

Fig. 10-65 Fig. 10-66

Create Query in SQL View

If you know the syntax of SQL, you can enter SQL command directory to create query.

1. Click “Create Query in SQL View” under “Task” to pop-up “Query Design” dialog box.
(Fig. 10-67)

2. Enter the SQL command in the dialog box. (Fig. 10-68)
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Fig. 10-67
Fig. 10-68

3. Click the “Run Query” icon to show the
query result. (Fig. 10-69)

Fig. 10-69                            

4. Select menu “View” → “Preview” to close the query result. Click the “Save” icon on the
Tool Bar to save the query.

Notes: You can switch between “Design View” and “SQL View” by clicking on the icon
“Switch Design View On/Off”.

Form
Form provides an alternative presentation for data entries. It can ease the process to input new or
edit data using a form.

Create Form in Design View

Click “Form” under “Database” and then click “Create
Form in Design View” under “Task” to open a blank
document (Fig. 10-70). You can insert desired form items
like labels or push buttons.

Fig. 10-70                   
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Use Wizard to Create Form

You can use “Form Wizard” to create form:

1. Click “Use Wizard to Create Form” under “Task” to pop-up “Form Wizard”. (Fig. 10-71)

2. Under step “1. Field selection” (Fig. 10-72), select required “Tables or queries”. Click the
button “>”, “>>”, “<” or “<<” to pick the desired fields under “Available fields”. Then click
“Next”.

Fig. 10-71

Fig. 10-72

3. Under step “2. Set up a subform” (Fig. 10-73), you can “Add Subform”. A subform is a form
that is inserted in another form. If not required to add subform, the “Form Wizard” will jump
to step 5. Click “Next”.

4. Under step “3. Add subform fields” (Fig. 10-74), select required “Tables or queries”. Click
the button “>”, “>>”, “<” or “<<” to pick the desired fields under “Available fields”. Then
click “Next”.

Fig. 10-73 Fig. 10-74
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5. Under step “4. Get joined fields” (Fig. 10-75), select the joined fields in tables. Then, click
“Next”. 

6. Under step “5. Arrange controls” (Fig. 10-76), select the arrangement for the main form and
subform. The result is shown on the background document. Click “Next”.

Fig. 10-75
Fig. 10-76

7. Under step “6. Set data entry” (Fig. 10-77), select the data entry mode. It can be “used for
entering new data only”, “Do not allow modification”, “Do not allow deletion” or “Do not
allow addition”. Then click “Next”.

8. Under step “7. Apply styles” (Fig. 10-78), select the style of your form. Similar to step 5,
you can preview the result on the background document. Click “Next”.

Fig. 10-77
Fig. 10-78
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9. Finally under step “8. Set name” (Fig. 10-79), enter the name for the form and click
“Finish”.

Fig. 10-79

Using Form
You can find the “Navigation Tool Bar” at the bottom of a form. It can help to insert, modify,
delete and manage data entries. (Fig. 10-80)

Fig. 10-80

1. Select Record

You can enter the number of records in the “Absolute Record” field on the left most. Or you
can click the icon “First Record”, “Previous Record”, “Next Record” and “Last Record” for
specified record to display.
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First Record

Previous Record

Next Record

Last Record

1. Insert record

Click the “New Record” icon to open a blank form. After entering, click the “Save Record”
icon to save the newly added record.

New Record

3. Modify record

First, move to the data record you wish to change. Enter new information in the fields and
click the “Save Record” icon to save the modification.

Save Record

4. Delete Record

First move to the data record you wish to delete. Click the “Delete Record” icon and choose
<Yes> to confirm the deletion.

Delete Record

5. Search, Filter and Sort Record

You can click the “Find Record” icon for searching, click the “AutoFilter” for filtering, and
click “Sort Ascending”, “Sort Descending” or “Sort” icon for sorting.
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Find Record

AutoFilter

Sort Ascending, Sort Descending

Sort

6. Form-Based Filters

If there are more than one filter criteria, you can make use of “Form-Based Filters”. For
example, filter out data entries with “EMP_NO>10100” or “FIRST_NAME='Terry'”.

1. Click the “Form-Based Filters” icon to open a blank form. You will find that the icons on
Tool Bar change as well.

Form-Based Filters

2. Enter the filter criteria here. In our example, enter “>10100” in “EMP_NO” field and
“'Terry'” in “FIRST_NAME” field. (Fig. 10-81)

3. Click the “Filter Navigation” icon to pop-up the “Filter Navigator”. Since the two criteria are
connected by “or”, you have to drag one of them under “Or”. (Fig. 10-82)

Form Navigation

Fig. 10-81
Fig. 10-82

4. Finally click the “Apply Form-Based Filter”.

Apply Form-Based Filter
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7. Data source as Table

Click the “Data source as Table” icon to display all the data records in table format on the
top.

Data source as Table

Report
Use Wizard to Create Form
Using “Report Wizard” can create form easily:

1. Click the “Use Wizard to Create Form” under “Task” to pop-up the “Report Wizard”. (Fig.
10-83)

2. Under step “1. Field selection” (Fig. 10-84), select required “Tables or queries” and click the
button “>”, “>>”, “<” or “<<” to pick the fields under “Available fields”. Click “Next”.

Fig. 10-83

Fig. 10-84

3. Under step “2. Labeling fields” (Fig. 10-85), enter display name of fields and click “Next”.

4. Under step “3. Grouping” (Fig. 10-86), add grouping level and then click “Next”.

Fig. 10-85 Fig. 10-86
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5. Under step “4. Sort Options” (Fig. 10-87), select the sorting options for the report. Then
click “Next”.

6. Under step “5. Choose Layout” (Fig. 10-88), select the “Layout of data”, “Layout of headers
and footers” and “Orientation”. The result is shown on the background document. Click
“Next”.

Fig. 10-87 Fig. 10-88

7. Under step “6. Save report” (Fig. 10-89), enter the “Title of report” and select from “Static
report” or “Dynamic report”. Finally click “Finish”.

Fig. 10-89

Using Database in other Applications

Register Database
To register new database or edit the registered database, select menu “Tools” → “Options” →
“NextOffice Base” → “Databases”. (Fig. 10-90)

You can click the “New” icon to register new database (Fig. 10-91), click the “Delele” icon to
cancel the registration or click the “Edit” icon to edit registered database.
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Fig. 10-90

Fig. 10-91

Activate and Browse Data Sources
You can activate the data sources tool in NextOffice by selecting menu “View” → “Data
Sources” (Fig. 10-92), or clicking the “Data Sources” icon on the Tool Bar. (Fig. 10-93)

Fig. 10-92

Fig. 10-93

On the left you can see the “Data Source Explorer”. All the registered databases are listed here.
Click the “+” sign to display more options. If you select a table or query, the contents of the table
or query will be shown on the right (Fig. 10-94). You can also input new data record here. Right
click on the database name and choose “Edit Data Base File” will open that particular database
file.

Fig. 10-94
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Table Data bar
At the top margin is the “Table Data bar” (Fig. 10-95). It consists of searching, sorting and
filtering tools for you to select your desired data records.

Fig. 10-95

Find Record Sort Filter

Find record
Click the “Find Record” icon on the bar to pop-up the “Record Search” dialog box (Fig. 10-96).
The “Record Search” dialog box contains “Search for”, “Where to search” and “Settings”.

Fig. 10-96

Under “Search for”, you can enter the searching target. It can be a text, NULL or not NULL.

Under “Where to search”, you can select to search all fields or a particular field.

Under “Settings”, you can select more options like “Match case”, “Search backwards”, “From
top”, etc.
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Sort
Select the field you wish to sort. Then click the “Sort Ascending” and “Sort Descending” icon on
the bar for rapid sorting.

If there is more than one field required sorting, you can click the “Sort” icon to pop-up the “Sort
Order” dialog box. You can select up to three sorting criteria in the dialog box. (Fig. 10-97)

Fig. 10-97

Filter
Filter includes “AutoFilter” and “Default Filter”.

Using “AutoFilter” is simple. You just have to select the field you wish to filter and click the
“AutoFilter” icon on the bar.

“Default Filter” allows you to enter at most three filtering criteria. Click the “Default Filter” icon
to pop-up “Default Filter” dialog box. After entering the filtering criteria then click the <OK>
button. (Fig. 10-98)

Fig. 10-98

Click the “Remove Filter/Sort” icon to delete filter and click the “Apply Filter” icon to activate
or close the filter.
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Insert Data Source

Text Document
To insert data source entries in Text Document:

1. Activate the data source tool and select the desired table or query.

2. If required, sort or filter the data records. (Fig. 10-99)

3. Pick the data records you wish to insert in text document. If more than one record, you can
press the “Ctrl” key to select more. Or you can click the gray rectangle on the top left corner
to select all records.

4. Drag the records to the text document to pop-up the “Insert Database Columns” dialog box.
(Fig. 10-100)

Fig. 10-99

Fig. 10-100

5. In the dialog box, you can select to insert data as “Table”, “Fields” or “Text”. Click the “>”,
“>>”, “<” or “<<” button to pick the fields you wish to insert. Finally click “Finish”. (Fig.
10-101)

Fig. 10-101
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If you drag the field name to the text document, a form letter field will be inserted.

Spreadsheet
To insert data source entries in Text Document:

1. Activate the data source tool and select the desired table or query.

2. If required, sort or filter the data records. (Fig. 10-102)

3. Pick the data records you wish to insert in text document. If more than one record, you can
press the “Ctrl” key to select more. Or you can click the gray rectangle on the top left corner
to select all records.

4. Drag the data records to spreadsheet. (Fig. 10-103)

Fig. 10-102 Fig. 10-103

If you drag the field name to the spreadsheet, a form label and text box will be inserted.

Mail Merge
You can make use of the mail merge function to a large number of new documents:

1. Move the mouse cursor to the position you wish to insert data field. Then select menu
“Insert” → “Fields” → “Other” to pop-up the “Fields” dialog box. (Fig. 10-104)

2. Select the “Database” tab, and click on “Mail merge fields” on the left. You can click the
“+” sign on the right to display more options to choose. Select your desired database and
table, and then the field you wish to insert. Click “Insert” to insert and then click “Close” to
close the dialog box. (Fig. 10-105)
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Fig. 10-104

Fig. 10-105

3. The inserted field will now be shown in the document. Select menu “File” → “Print” to pop-
up a dialog box with message “Do you want to print a form letter?” (Fig. 10-106). Click
<Yes>.

4. “Mail Merge” dialog box will then appear (Fig. 10-107). You can select the particular data
records you wish to print or select “All” to print out all records. Finally click <OK> to print
out the form letter documents.

Fig. 10-106

Fig. 10-107
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