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Chapter 1 -  Introduction

ABOUT THIS MANUAL
This manual covers the installation and use of MSAT, the Fairlight monitor system 
and automated testing application for DREAM. The DREAM products are a range 
of digital recording, editing and mixing systems for use in a professional audio pro-
duction environment. MSAT is used by Fairlight support personnel, test engineers 
and software developers for use in troubleshooting, fault diagnosis and system de-
velopment. MSAT can also be used by third-party software developers working with 
the Fairlight RAPID remote application programming interface for DREAM.

This manual details the installation process for MSAT, basic use of the software and 
includes a complete scripting reference.

INSTALLING MSAT
MSAT is included with DREAM software releases for DREAM Station and 
DREAM Console. The DREAM software installation places MSAT in the follow-
ing directory: C:\projects\mixers\msat\.

MSAT is included with Plug-Ins Manager 5. Once PIM5 has been installed a short-
cut to MSAT is located in the Windows START menu under Programs>Fairlight 
ESP>Tools folder.

MSAT is also included in the RAPID software development kit. This includes a cut-
down DREAM software installation which includes the major software compo-
nents: FMC, MSAT, ConsCon, the RAPID software libraries plus the RAPID and 
MSAT documentation. The RAPID SDK places all the software components in the 
a directory structure similar to the DREAM software releases. 

To install the RAPID SDK run the RAPIDSDK1_0.exe self extracting archive.

MSAT is copied to the following directory: C:\projects\mixers\msat\.

MSAT VERSION
To ensure that you are running a current version of MSAT check the version 
number by right clicking the filename in Windows Explorer and selecting Proper-
ties. Select the Version tab to display the file version. The version number is divid-
ed into four segments which indicate from left to right: major version number; 
minor version number; build number; and a reserved number.
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Chapter 2 -  Using MSAT

MSAT OVERVIEW
MSAT is a monitor system and automated testing application for use in trouble-
shooting, fault diagnosis and system development. MSAT.exe is located in the 
C:\projects\mixers\msat\. In a standard DREAM installation there is a short-cut to 
MSAT on the Windows desktop. 

MSAT displays a scrolling list of parameter, system and general messages generated 
by FMC or Plug-Ins Manager. Messages can also be recorded to a log file for future 
reference. MSAT also provides a script playback system for automated testing and a 
parameter monitor panel for displaying and controlling individual mixer parame-
ters.

RUNNING MSAT
MSAT communicates with the mixer application, FMC, or with Plug-Ins Manager 
5, via TCP/IP. MSAT may be run on the mixer PC, SSM, or another PC running 
Windows 2000 and connected via an ethernet network. Multiple instances of 
MSAT may be run on the same machine, each utilising a separate communications 
channel with its respective host application (i.e. FMC or PIM 5).

To start MSAT click on the short-cut on the Windows desktop or click on the Start 
menu and select Run. Type C:\projects\mixers\msat\ msat. MSAT should be started 
before starting FMC, as FMC initialises a number of important system functions at 
start-up only. Once the mixer application FMC is running, hold down the Alt key 
and press the Tab key to switch to MSAT or the Windows desktop.

Figure 1: The MSAT Monitor System and Automated Testing Application

Make sure the Toolbar and Status Bar is displayed by selecting Toolbar and Status 
Bar from the View menu.

Toolbar

Status Bar
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CONNECTING TO FMC OR PIM 5

Figure 2: RAPID/MSAT Set-up for Satellite Systems

Figure 3: RAPID/MSAT Set-up for Station or Console Systems

Figure 4: MSAT/PIM/FMC Set-up for Station or Console Systems
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MSAT communicates with FMC or PIM 5 via TCP/IP and must be correctly con-
figured as described below. When MSAT is successfully connected to FMC the On-
line indicator is displayed at the right of the status bar at the bottom of the MSAT 
window. When no connection has been made, the Offline indicator is displayed. 
The Tx/Rx indicators show a tally of the packets sent between MSAT and FMC or 
PIM 5.

Running MSAT on Local Machine
To run MSAT on the same machine as FMC or PIM 5 it is necessary to modify the 
FMC or PIM 5 command line and set the MSAT Host Name from the MSAT File 
Menu.

MSAT Host Name
Open the File menu in MSAT and select host name... 

Type local in the Host Name dialog box. Restart 
MSAT

FMC Command Line
Use the -c command line option when starting FMC. FMC is started by executing 
the DREAM.bat file. Edit the DREAM.bat file which is located in the 
C:\projects\mixers\ directory. 

On a working DREAM system the DREAM.bat file will display the following op-
tion at the top of the file:

set  MSAT_IPADDRESS=LOCAL

Edit this line, if necessary, making sure that LOCAL is entered in upper case.

On a development system based on the RAPID SDK, DREAM.bat will only con-
tain a simple command line.

A typical command line will look like this: 

C:\projects\mixers\fmc\fmc -d -e -s2 -c. 

Make sure you remove the -p option which is only applicable for remote MSAT 
connection.

PIM 5 Command Line
Click on the Start menu and select Programs>Fairlight ESP>Tools and right 
click on MSAT and select Properties from the context menu. Select the Shortcut 
tab and click in the Target: text box. Add the -c command line switch to the end 
of the target command line. Add the -hlocalhost command line switch to the 
end of the target command line.
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Running MSAT on a Remote Machine
To run MSAT on a network connected machine, first verify that the two machines 
are correctly configured. You will need to know the IP address of both machines. 
Note, that the two machines must be on the same subnet. Use the Ping utility from 
a command line window to ensure both machines are communicating. For more in-
formation on Windows networking, refer to the Windows Help system.

MSAT Host Name
Open the File menu in MSAT and select host name... 

Type the IP address of the machine run-
ning FMC in the Host Name dialog box. Restart 
MSAT

FMC Command Line
Use the -p command line option when starting FMC. FMC is started by executing 
the DREAM.bat file. Edit the DREAM.bat file which is located in the 
C:\projects\mixers\ directory. 

On a working DREAM system the DREAM.bat file will display the following op-
tion at the top of the file:

set  MSAT_IPADDRESS=1.1.1.11

Edit this line as shown above replacing the IP address with the address of the ma-
chine running MSAT.

On a development system based on the RAPID SDK, DREAM.bat will only con-
tain a simple command line.

A typical command line will look like this: 

C:\projects\mixers\fmc\fmc -p1.1.1.11 -d -e -s2. 

Make sure you remove the -c option which is described above. Replace the IP ad-
dress with the address of the machine running MSAT. Do not insert a space before 
the number.

PIM 5 Command Line
Click on the Start menu and select Programs>Fairlight ESP>Tools and right 
click on MSAT and select Properties from the context menu. Select the Shortcut 
tab and click in the Target: text box. Add the -c command line switch to the end 
of the target command line. Add the -h=www.xxx.yyy.zzz command line 
switch to the end of the target command line, replace www.xxx.yyy.zzz with the 
IP address of the machine running MSAT.
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Running Multiple MSATs
Multiple instances of MSAT may be run on the same machine or network, each uti-
lising a separate communications channel with its respective host application (i.e. 
FMC or PIM 5). The channel number of each instance of MSAT is displayed in the 
MSAT window title bar. Each instance writes to a separate log file whose file name 
is appended with the channel number.

The channel number must be specified in the -c command line argument of MSAT, 
FMC and PIM as described below.

MSAT Command Line
Make a copy of the shortcut you are using to run MSAT. Right click on the shortcut 
and select Properties from the context menu. Select the Shortcut tab and click in 
the Target: text box. Add the -c# command line switch to the end of the target 
command line. Replace # with the channel number (e.g. \\MSAT.exe -c0). The 
default channel number is 0. Select the General tab and change the name of the 
shortcut to MSAT/FMC or similar.

Edit the copy of the shortcut and add a -c1 command line switch to specify channel 
1. Change the name of this shortcut to MSAT/PIM.

FMC Command Line
Edit the DREAM.bat file which is located in the C:\projects\mixers\ directory.

On a working DREAM system the DREAM.bat file will display the following op-
tion at the top of the file:

set  MSAT_CHANNEL=0

Edit this line as shown above replacing the channel number specified in the MSAT 
command line.

On a development system based on the RAPID SDK, DREAM.bat will only con-
tain a simple command line.

A typical command line will look like this: 

C:\projects\mixers\fmc\fmc -p1.1.1.11 -d -e -s2 -c0. 

Add the -c0 option to the end of the line, replacing the channel number specified 
in the MSAT command line.

PIM 5 Command Line
Click on the Start menu and select Programs>Fairlight ESP>Tools and right 
click on MSAT and select Properties from the context menu. Select the Shortcut 
tab and click in the Target: text box. Add the -c=1 command line switch to the 
end of the target command line, replacing the channel number specified in the 
MSAT command line. Add the -h=www.xxx.yyy.zzz command line switch to 
the end of the target command line, replace www.xxx.yyy.zzz with the IP ad-
dress of the machine running MSAT.
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MESSAGE MONITORING AND LOGGING
MSAT allows the a range of parameter, system and general messages generated by 
FMC to be displayed and recorded in a log file. This feature allows third-party RAP-
ID developers to verify the operation of their remote control applications. It also 
provides useful information for fault finding and general testing of DREAM sys-
tems.

FMC messages are displayed in the main message window.

Monitor Start/Stop
Click the start or stop buttons to start or stop monitoring FMC messages. 
Alternatively press the Space bar to quickly toggle message monitoring on 

or off.

Monitor Message Masks
Click the Message Mask buttons to enable the display of general mes-
sages, system messages, or parameter messages.

General Messages
General messages include a range of optional de-bug messages that can be generated 
by FMC. To enable de-bug messages from FMC hold down the Shift key and press 
Pause/Break on the PC keyboard to display the De-bug Switch dialog box. Enter 
the debug switch value at the bottom of the dialog box. De-bug switch values for 
each switch are defined in the dialog box when the switch is selected from the drop-
down list.

System Messages
System messages include messages relating to the operating system, including file 
and memory management events. System messages also include events generated by 
MSAT associated with script playback.

All Parameter Messages
Parameter messages are generated whenever a parameter value changes. Parameter 
changes may be caused by physical actions on the control surface, script replay, or 
remote control via a RAPID application.

Tester Messages
Tester messages include the control change events associated with the replay of au-
tomated scripts.

Clear MSAT Display
Click the Clear Window button to clear the message display.

Log File
MSAT records all messages to a log file located at C:\Projects\Mixers\MSAT\MSAT-
log.txt. The file can be viewed with the Notepad text editor, but cannot be viewed 
while MSAT is running. To view the log file while MSAT is running, use the save-
as function described below. If running multiple MSATs on the same machine, the 
log file name will be appended with the channel number.

Log File Message Masks
Click the Log File Message Mask buttons to enable the recording 
of general messages, system messages, parameter messages or Test-
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er messages as described above.

Log File Functions
Tool bar buttons are available to clear the log file, save a copy of the log 
file to another name, and insert a text comment in the log file.

MSAT PARAMETER MONITOR
Each Parameter Monitor provides on-screen control and display of four pa-
rameters. Select the signal path or module from the top list box. Select the 

Module or path number from the second list box. Finally select the parameter type 
from the bottom list box. Refer to the RAPID reference document for details on all 
parameters and modules in the DREAM system. Note that the parameter names 
displayed in the MSAT Parameter Monitor do not include the R_ prefix that is used 
when calling RAPID functions.

Use the slider to adjust the parameter in real time, or enter a value in the field below 
the slider and click Set to transmit the parameter to the mixer.

The Parameter Monitor will also display changes made to mixer parameters via the 
control surface in real time.

Figure 5: MSAT Parameter Monitor Window
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AUTOMATED TEST SCRIPTS 
Test scripts are used in the production environment for quality control and may also 
be useful during field servicing or general or regression testing.

MSAT supports automated test script recording and playback. Scripts may be re-
corded from actions made on the control surface. Scripts may also be written with 
a text editor. Refer to “MSAT Script Syntax” on page 3-2 for details of the scripting 
commands.

Recording Scripts
To record a new script, click on the button with 
the red circle. Enter a new file name for the script 

in the New Test Script dialog box. By default, local scripts are saved to the 
C:\Projects\Mixers\MSAT\Scripts\ directory. To change the local directory select Di-
rectory Path (local) from the File menu. Use the controls on the console surface 
to perform the functions you wish to record. Click the square symbol to stop record-
ing.

Insert Pause
Click the button with yellow bars to inset a Pause command in the script. When 
played back, the script will pause when the command is played back and wait for 
the play button to be pressed.

Execute Script
Click on the script button to insert a call to execute another script within the script 
which is currently being recording. Select the script from the dialog box and click 
the Open button. This feature provides a method of creating playlists of several 
scripts. It is important to avoid recursive scripts that call each other indefinitely.

Insert Comment
Click the note button to insert a comment into the script.

Set/Get/Test Parameter
Logical tests may be performed within scripts. Use the Set Par button to display 
the GET, SET, TEST PAR Statement dialog box.

Select the module type, module index and parameter name from the drop-down 
lists at the left. Select the action type with the radio buttons in the middle of the 
dialog box. Enter a value or choose the variable name at the right and click Add to 
add the line to the script.

The GET command reads the specified parameter and stores it in one of the five 
internal variables. These can later be used in a logical comparison with the TEST 
command.

The SET command can be used to set a parameter to a fixed value entered in the 
value field or to a value previously stored in one of the five internal variables.

The TEST command can be used to perform a logical comparison on the selected 
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parameter. The parameter can be tested against a fixed value entered in the value 
field or a value previously stored in one of the five internal variables.

The logical operators are GT - greater than, GTE - greater then or equal, EQ - equal, 
LTE - less than or equal, LT - less than, NE - not equal. If the result of the operation 
is false, the script will record an error. The script system can be set to Exit On Error 
or ignore errors. See “Exit On Error” on page 2-11.

Time Filter
When a script is recorded, the time delays between physical actions is recorded and 
inserted into the script file. The time filter button minimises the WAIT times be-
tween recorded commands to 250 milliseconds in order to optimise script playback.

Playing Scripts
To play back a previously recorded 
script, click the drop down list box to 

select the script name.

Scripts are be located in either the Global script repository on the in-house Fairlight 
LAN, or in a local directory. Click the Glb button to select files from the Global 
script repository, this feature is only for in-house applications. 

Local scripts are saved in C:\Projects\Mixers\MSAT\Scripts\. This directory may be 
changed to any other directory. In the File menu select Directory Path (local). En-
ter a path in the dialogue box and click OK. 

Click the button with green arrow to the left of the drop down list to start script 
playback. Click the button with the yellow bars to pause playback. When paused, 
click the button with the footstep to step through the script one line at a time. Click 
the button with the black square to stop playback.

Script messages are played back and sent to FMC. WAIT messages record or simulate 
the real-time delay between performing actions on the control surface.

Play List Script Picker
To enable a list of scripts to be played back in sequence, MSAT includes the 
script picker interface. First select the source directory for scripts by clicking the 

Glb button or changing the local directory path by selecting Directory Path (local) 
from the File menu.
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Click the script picker button to display the script picker window:

The left hand panel displays available scripts. Click in the check boxes to select the 
scripts to add to the play list. Click the Add Items button to move the selected 
items into the play list in the right hand panel.

Double click on a script name in the play list to start playback of that script.

Select a script in the play list and click Remove Item to remove the script from the 
play list. Use the Move Items Up/Down buttons to change the order of the play 
items in the play list.

Click Save Playlist and enter a name for the list to save the play list for future use. 
Play lists may be added to a play list. Be careful not to make recursive lists.

Play Mode
The script picker play mode options control play list execution.

Single mode plays the selected script and stops when it reaches the end of the script.

All mode plays through all the scripts in the play list and stops when it reaches the 
end of the last script in the list.

Repeat mode plays through all the scripts in the play list then returns to the top of 
the list and plays continuously.

Random mode continuously plays scripts from the list in a random order.

Play Indicator
Press the Play button to start playback of the scripts in the play list. The play indi-
cator displays the current playback status: Play, Pause or Stop. The indicator will 
show if a script has come to a PAUSE command or if playback has stopped.

Exit On Error
The Exit On Error check box causes the playlist to stop when a TEST_PAR or 
TEST_VIEW command returns false. When not checked MSAT continues to play 
past the error.
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Chapter 3 -  MSAT Script Syntax

GENERAL
A script file is an ASCII text file, typically written using an editor such as Windows 
Notepad. Alternatively, the script may be entered interactively using the MSAT 
script recording features described in “Recording Scripts” on page 2-9. This text file 
contains a number of instructions, each instruction placed on a separate line.

Instructions exists for setting, accessing and testing mixer parameters, as well as con-
trolling the flow of the script, using loops and simple IF statements. Other instruc-
tions allow for simple calculations, with assignments and basic math functions.

The scripts are normally executed at a speed of approximately 15 milliseconds per 
instruction, but the execution can be delayed additionally using the WAIT instruc-
tion.

The script files reside in \Projects\MIXERS\Msat\Scripts or in the local directory 
specified under the File menu, and must use the extension “.TXT”.

OPERANDS
The following types of operands are available:

• MODULE_TYPE: module types as defined in the RAPID Reference Manual.

• PARAMETER: parameter name as defined in the RAPID Reference Manual.

• CONTROL_ID: name of a control-surface element as defined in the “DeskC-
trlViewDefs.h” code module. These operands are for internal testing purposes 
only, not for use in RAPID applications.

• VIEW_ID: name of a control-surface display element as defined in the “DeskC-
trlViewDefs.h” code module. These operands are for internal testing purposes 
only, not for use in RAPID applications.

• CONSTANT: integer value, specified in either decimal or hexadecimal (prefix 
by $) notation.

• LC1 to LC5: Loop counters, with the outermost loop using LC1, the next using 
LC2 ect.

• V1 to V5: Variables 1 to 5.

COMMENTS
Blank lines are allowed. 

All lines starting with # are treated as comments, and are ignored.
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PARAMETER ACCESS INSTRUCTIONS
SET_PAR, module_type, module_index, parameter_id, new_value

This instruction will cause the selected parameter in the mixer to take the 
new_value. The module_index and parameter_id will typically be constants as de-
fined in the MPD document.

READ_PAR, module_type, module_index, parameter_id, variable

This instruction reads the value of the parameter from the mixer, and places it in the 
specified variable.

TEST_PAR, module_type, module_index, parameter_id, condition, value

Where condition is GT, GTE, EQ, LTE, LT, or NEQ.

This instruction is used to verify that the mixer has corresponded correctly to the 
proceeding instructions. The specified parameter from the mixer is tested against a 
value, and the execution of the script is stopped if the test is false.

CHANGE_CONTROL, control_id, new_value

This instruction will cause the selected control surface parameter to take the 
new_value. The control_id will typically be constants as defined in the “DeskC-
trlViewDefs.h”.

READ_VIEW, view_id, variable

This instruction reads the value of the view-element from the mixer, and places it in 
the specified variable.

TEST_VIEW, view_id, condition, value

Where condition is GT, GTE, EQ, LTE, LT, or NEQ.

This instruction is used to verify that the mixer has corresponded correctly to the 
proceeding instructions. The specified view-element from the mixer is tested against 
a value, and the execution of the script is stopped if the test is false.

FAST

Changes the default execution speed to approx 5 mS between instructions.

SLOW

Resets the default execution speed to approx 25 mS between instructions.
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MATH INSTRUCTIONS
The five local variables can be assigned values by reading either a mixer parameter, 
or by reading the state of a view element. Additionally, they can be preset using the 
ASSIGN command:

ASSIGN, variable, {MODULE_TYPE | PARAMETER | CONSTANT | control_id | 
view_id | LCx | Vx}

Basic math is supported, using the same variable to supply both destination and one 
of the source arguments, with the second argument being any of the possible oper-
ands:

ADD, variable, operand

SUB, variable, operand 

MUL, variable, operand

DIV, variable, operand

MOD, variable, operand

AND, variable, operand

OR, variable, operand

XOR, variable, operand
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PROGRAM CONTROL INSTRUCTIONS
LOOP, start_value, end_value, step_value

All instructions from the LOOP statement down to the next ENDLOOP are re-
peated until

end_value is reached or exceeded. 

Note, that the end_value is only calculated once, at the entry to the loop.

Also note, that the step_value is added to the loop counter at the end of the loop.

Finally, please note that the loop is not entered, if the start_value is equal to or ex-
ceeds the end value.

The equivalent ‘C’ code is as follows:

LC1 = start_value;

while (step_value > 0 ? LC1 < end_value : LC1 > end_value)

{

…

…

…

LC1 += step_value;

}

Due to this implementation, the loop construct can be used as a simple IF state-
ment.

ENDLOOP

Used in conjunction with LOOP – see above.
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MISCELLANEOUS INSTRUCTIONS
WAIT, delay_in_milliseconds

Stalls execution for an amount of time.

EXECUTE_SCRIPT, filename

Calls and executes a script. Include the full pathname. Avoid recursive scripts.
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