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Welcome 
I-MarkTM Help System 

 

FAQ's & Troubleshooting 
Access a comprehensive set of questions, answers, 
and troubleshooting solutions. 

 

Using the Help System 
Learn about the features of this Help System 

 

Additional Resources 
View additional sources of help. 

 
Rev 2.0.02242011 
 
 

FAQ's & Troubleshooting 
Quick list of all the main help topics. Click on link below to 
view help information for that category. 
 
For items not listed please use the search feature. 
 
 

 
Basic vs Advanced Mode 
Creating A Workspace 
Creating a Layout 
Mapping A controller 
Assigning a Layout 
Marking a Layout 
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Date and Shift Codes 
Counters 
2D Code Sizing 
Serial Specification 
I/O Mark Start and Complete 
E-Stop Suggested Configurations 
Waypoint Setup for Custom Tool Path 
I/O Setup and Configuration 
Multiple Axis Configuration 
Warning Messages When Saving Files 
Error Messages 
Demos 
Desktop Map 
Layout Window 
Machine Window 
Orb Menu 
Home Ribbon 
Marking Ribbon 
View Ribbon 
Help Ribbon 
Layout Ribbon 
Marking Machine Ribbon 
Entity tool Box 
Navigation Window 
Marking Window 
Marking Order Window 
Manual Window 
Simulator Window 
Output Window 
Quick Access Tool Bar 
Bottom Status Tool Bar 
Create New Layout  
Open Layout 
Save Layout 
Save All 
Undo  
Redo 
Manage Marking Machines 
Connect to Marking Machine 
Disconnect From Marking Machine 
Refresh Network 
Download to All 
Select Active Machine 
Select Active Layout to Mark 
Mark Layout 
Pen Enable 
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Pen Disable 
View Zoom 
View Settings 
Support - About 
Graphic 
Line 
Text 
Date Codes 
Data Matrix 
Waypoint 
Set output 
Wait input 
Dwell Time 
Copy 
Cut 
Paste 
Delete 
Assign to Machine 
Global Printing Speed 
Open Marking Machine 
Synchronization - download 
Synchronization - upload 
Synchronization - clock 
Assign Layout 
Remove Layout 
Configure - Layouts 
Configure - Counters 
Configure - Shifts 
Configure - Date/Text 
Configure - I/O 
Pen 
Unmap From Workspace 
Machine Window - Status 
Machine window - Activity 
Machine Window - Properties 
Machine Window - Files 
Machine Window - Diagnostics 
Machine Window - Dynamic 
System Log 
In the normal course of using the software, questions may arise regarding 
procedures, system messages, and error conditions. I-Mark Software provides 
several methods of obtaining answers to your questions. 
 
For information about Columbia Marking Tools products, visit the Columbia 
Marking Tools  Web site at: www.columbiamt.com 
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• Visit the I-Mark Software Online Web site. The I-Mark Online Web site 
provides a direct link to latest internal research database, downloads, 
and numerous support services. This service is available only with a 
current Support Agreement or Client Care Plan and to I-Mark business 
partners. First year is included free with purchase of I-Mark system. Have 
Serial Number and Company Name ready to validate access. 

• Access video demonstrations by selecting Demos on the Help Menu 
Ribbon. 

• Technical bulletins and download program updates are available through 
the I-Mark Software E-News.  

 
Note Program updates are available exclusively through the internet. 
 
For more information about I-Mark Software's fee-based customer support 
services, contact Columbia Marking Tools.  

Using the Help System 
Using the Help System 

Access the Help system when you want quick references for software 
commands, detailed information and entry samples for fields, flowcharts for 
complex concepts, and FAQ's and Troubleshooting information. The following 
topics provide information on the different ways you can access and use the Help 
system, as well as ways to easily print a grouping of related Help topics. 
 
Using the Help Menu 

F1 Help for a Field 
Print a  the Complete Help PDF 
(warning quite lengthy) 
Adobe Acrobat reader required 

Help Menu Ribbon 
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Welcome 

From the I-Mark Desktop, select Help menu tab across the top of the screen. 
There are three main items on the help menu:  

1. About page which gives information about the software release you are 
using 

2. Access to the Help File 
3. Live video Demos. Help Topics 

Using the Help System 

Access the Help system when you want quick references for software 
commands, detailed information and entry samples for fields, flowcharts for 
complex concepts, and FAQ's and Troubleshooting information. The following 
topics provide information on the different ways you can access and use the Help 
system, as well as ways to easily print a grouping of related Help topics. 
 
Using the Help Menu 
F1 Help for a Field 

Print a  the Complete Help PDF 
(warning quite lengthy) 
Adobe Acrobat reader required 

Demos 

this icon is located in the Help Menu Ribbon. Selecting this command will 
access a complete list of demonstrations included with the Intelli-Mark software.  
 
How to Create/Open Workspace The Intelli-Mark program layout. The windows 
and navigation may be configured different for different users, applications, or 
systems. 
How to Create/Open Layout Marking legend displaying position and style of all 
the entities to be marked. 
Add Text Data Matrix to Layout 
Change Text Size 
Change Text Font  
Change Entity Alignment 
Change Entity Orientation 
Make Entity into a Radius 

F1 Help for a Field 

Press F1 at any field in the software to access Help for that field. The field-level 
Help topic that appears contains information for all fields for the task. 
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Getting Started 
Quick Start Guide 
 
A) Components : Each of CMT's systems comes with a marking head, controller, 
and required cables. For bench-top or turn-key stations these components are 
pre-assembled.  
   
B) Installing Software: Software must be installed on PC running windows (I-Mark 
is not compatible with Vista 64). For bench-top or turnkey stations an integrated 
PC is included in the machine and this step is not required.  
 
C) Connecting the Machine: Marking units require mounting of the head and 
controller. Turn-key systems require connecting to electrical and possibly an an 
supply. 
 
D) Turning on the system: From the basic bench-top to the mark and read station 
with accessories. 
 
E) Getting Started: The required elements of creating and running a marking 
program. 
 
 

Basic versus Advanced mode may be selected on the Start Page or from 
the Orb Menu.  
 
Basic mode is streamlined with the basic marking functions and is quicker to set-
up Stand-Alone marking machines. Basic mode has only one workspace. CMT 
recommends Advanced Mode for integrators to maximize the I/O and 
communication capabilities of the I-Mark controllers. Basic Model will connect 
with all machines on the network. Advanced mode allows for selection of which 
machines to connect to. 
 
Start Page buttons: 
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Even if the Start Page is closed, a use may still change the mode through the 
Orb Menu. 
 
Orb Menu Selection: 
 

 
 
Selection window is opened to change user mode: 
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Create a Workspace 

Creating a new workspace The Intelli-Mark program layout. The windows 
and navigation may be configured different for different users, applications, or 
systems. is only an option in advanced mode. 
 
Only through the workspace may the user limit the machines that the software 
will try to locate. 
 
In basic mode, all machines on the network are shown in the Navigation window. 
 
 
 
 
The by creating different workspaces the operator may select which machines on 
the network will be accessed. 

Mapping a Controller 
Type topic text Data Matrix here. 

Assign Layout to Marking Machine 

This icon is located in the Marking Machine Ribbon. This ribbon is visible 
once a marking machine   has been selected in the navigation window, and is 
opened in the Main Work Area. 
 
While a number of marking machines may be opened, the selected machine will 
be the associated with the name on the Marking Machine Menu Ribbon Tab. In 
addition, this system will be highlighted and opened in the Main Work Area.    
 
A drop down menu will appear and display all additional layouts from the PC 
available to be assigned to the machine. 
 

• The layout Marking legend displaying position and style of all the entities 
to be marked. must reside in the I-Mark data   directory located: 
...Program Files\I_Mark_x_x_x  (where the small "x"s are the version 
numbers).  

• The layout must have the same marking machine type as the marking 
machine selected. 
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If a required layout does not appear check the layouts location on the PC, and 
the marking machine type assigned to it. 
 
In addition to the Assign Layout icon, I-Mark software also allows for a "drag and 
drop" method to assign layout to marking machines. This is done by using the 
navigation window. Click on the layout required and "drag" to the marking 
machine. 
 

If this symbols continues to appear when you drag layout over marking 
machine, check to make sure that the layout machine type matches the marking 
machine type of the desired machine. 
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Navigating Through the Software 
Navigate Through Software 
Type topic text Data Matrix here. 

Software Layout 
Orb Menu: Drop down menu is visible when mouse goes over orb Intellimark 
symbol in the upper left hand corner of the main window. 
Main Top Icons - Icons and commands accessible on the top of the Intelli-Mark 
screen 
 
Main command ribbons are shown when the name tab is clicked with mouse. 
Home Ribbon  
Layout Ribbon 
Marking Ribbon 
View Ribbon 
Help Ribbon 
Entity Ribbon 
 
Entity Boxes: are opened through the icon ribbons 
Entity Toolbox 
Navigation 
Marking Order 
Properties 
 
Use your mouse to hover over different parts of this image to identify them. 
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Keyboard and Button Navigations 
List of Keystroke commands 

Delete 

is located in the Marking Order Window and 
 

is located to the far right of the Layout Menu Ribbon. 
 
Both icons perform the same command. This command will delete all the 
currently selected entities in the opened layout Marking legend displaying 
position and style of all the entities to be marked.. These selected entities are 
outlined by a blue line   in the Main Work Area, or highlighted in the Marking 
Order   Window.  
 
In addition, hitting the delete key on the keyboard will perform the same task. 
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Context Menus 
On any Toolbar the following options are displayed when the right button of the 
mouse is clicked. 
 
Add to Quick Access Toolbar: This adds the icon that the mouse is hovering over 
to the Quick Access Toolbar with the Save Layout Marking legend displaying 
position and style of all the entities to be marked., Undo, and Redo buttons. 
 
Show Quick Access Toolbar Below/Above the Ribbon: This puts the Quick 
Access Toolbar above or below the icon ribbon. 
 
Minimize Ribbon:  The ribbon will not display until the top command is clicked, 
and will disappear when the mouse is clicked outside of the ribbon area. 
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Using the Desktop 
Using the Desktop 
Type topic text Data Matrix here. 

What is a Workspace? 

A Workspace The Intelli-Mark program layout. The windows and 
navigation may be configured different for different users, applications, or 
systems. is a collection of Layouts, files and settings which create associations to 
the controllers they're assigned to.  A good example of this would be to consider 
a large manufacturing plant.  Within this plant are different groups of machining 
cells dedicated to one type of part.  Within these cells would be one or more I-
Mark Controllers including their marking Layouts, Graphics, Fonts and any of the 
specific Settings of these controllers.  The Workspace provides us with a way to 
organize these items into a group to be better managed and monitored by a 
computer or person.   
 
Assume that you are an engineer who is in charge of one of these machining 
cells.  Although there are multiple cells throughout the plant each with their own 
group of I-Mark machines, you wouldn't necessarily want to monitor or modify 
one of these other groups.  The Workspace file would allow you to map the 
controllers pertaining to your cell to your Workspace.  Once you open the I-Mark 
software and open up this Workspace file, you would be shown only the 
controllers belonging to it and their contents.  This makes for a much cleaner 
organization method and makes managing multiple controllers a breeze. 
 
 

Menu Ribbon 
Type topic text Data Matrix here. 

Entity Toolbox 
Tool Box 

Type topic text Data Matrix here. 
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Graphic Element 

Type topic text Data Matrix here. 

Line Element 

Type topic text Data Matrix here. 

Text Element 

Type topic text Data Matrix here. 

Data Matrix 

Type topic text Data Matrix here. 

Waypoint 

The waypoint   icon is located in the Layout Ribbon. This Ribbon menu is 
only available if a layout Marking legend displaying position and style of all the 
entities to be marked. is active in the center work area.  
 
Clicking on this icon will create a new waypoint in the open layout. The new 
waypoint will be created in the x-y position   of the last entity in the layout and 
after the last entity in the Marking Order Window.  
 
The properties   of this waypoint are shown the Properties Window when the 
entity is selected.  
 

the use of a series of waypoints is a nice way to assure that critical path 
points may be entered in to the marking legend. Most common use of this feature 
is for part relief and other obstructions.  
 
 
 
 

Set Output 

Type topic text Data Matrix here. 

Wait Input 
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The Wait for Input icon is located in two places in the Intelli-Mark software, 
one is on the Layout Ribbon and one is in the Entity Toolbox . 
 

ut that do not 
roduce a mark. These include: Waypoints, Outputs, Inputs, and Dwell Time. 

The "Wait Input " entity is a non-printing Entities within the layo
p
object, and will pause until the required I/O operation is completed.  
 
Once the Wait Input entity is selected on the opened layout the configuration 
ssociated with it may be changed. These variables may be changed in the 

avigator 

a
Properties Window 
 
 

N

The navigator icon. 
 
This icon is lo boncated in the View Rib . This icon will turn show/hide the 

avigation   Window.    

 here. 

ta Matrix here. 

 Matrix here. 

N

Marking order 
Type topic text Data Matrix

Properties 
Type topic text Da

Output Tab 
Type topic text Data
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Menu 
Menu Ribbon 
Type topic text Data Matrix here. 

Main top 
Main top 

Type topic text Data Matrix here. 

Intelli-Mark Start Orb Menu 

I-Mark Start Orb Menu 

A mouse click on the start Orb Intellimark symbol in the upper left hand corner of 
the main window. will show the following icons. 
 

 

New Workspace 
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A workspace is a definition of the machine parameters and the Global I-Mark 
Environment. Examples of some parameters are: 
 

• What Machines are available to mark with (mapped) 
• Global Machine Settings 
• Global Counter Settings 
• Global I/O configuration 

 
By creating a new workspace the system will search for any machines that are 
connected to your computer or network and allow you to connect to them. Once 
connected you can begin to edit their properties. you can create new workspace 
in two different ways: 
 
                                                                                                                                 
            
1.) Select New Workspace from the ORB menu 
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Menu 

 
 
 
2.) Select Advanced or Basic mode from the Start Page 
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Open Workspace 

Opens and existing workspace and all of the configured settings saved in that 
Workspace. You can open a work space by selecting Open Workspace from the 
ORB Menu. 
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Menu 

 

Save Workspace 

Save Workspace allows you to save any changes that you have made to an 
existing workspace. you can Save your workspace by selecting Save Workspace 
from the ORB menu. 
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Save Workspace As 

Save Workspace As allows you to save a given workspace to a different Name. 
you can Save Workspace As  by selecting it from the ORB menu. 
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Create New Layout 

This icon is located in two places; the Orb Menu and the Home Menu 
Ribbon. This command will create a blank layout in the current workspace.  
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This file is not automatically created nor saved. The filename on the tab in 
the Main Work Area will be followed by an asterisk if the file has note been saved 
in its current state. 
 

When the file is saved the file is located in the data directory under the 
Intelli-Mark program files. The extension name is .ctml 

Open Layout 

Type topic text Data Matrix here. 

Save Layout 

Type topic text Data Matrix here. 

Save Layout As 

Type topic text Data Matrix here. 

Change User Mode 

Change User Mode icon is located as the bottom menu option in the drop 
down Orb Menu. 
 
I-Mark software allows for different access levels based on user knowledge and 
responsibility. 
 
The standard software has two modes Basic and Advanced. 
 
Custom software settings may restrict some of the advanced software settings. 
The software may be restricted for single machine use, or may be limited in I/O 
protocols and 2D functionality. 
 
In addition, advanced software applications may have different access levels to 
ensure that marking legends and settings are not changed inadvertently. And 
may even be customized to allows access to certain machines on the network 
and not others, depending on responsibility. 

Options 

Type topic text Data Matrix here. 
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Exit 

Type topic text Data Matrix here. 

Save All 

Type topic text Data Matrix here. 

Undo 

Type topic text Data Matrix here. 

Redo 

Type topic text Data Matrix here. 

Home Menu Ribbon 
Home Menu Ribbon 

Type topic text Data Matrix here. 

Save All 

Type topic text Data Matrix here. 

Undo 

Type topic text Data Matrix here. 

Redo 

Type topic text Data Matrix here. 

Manage Marking Machines 

Type topic text Data Matrix here. 

Disconnect from Network 

If you wish to disconnect your computer from the network, the best way to 
accomplish this is to first Save your workspace The Intelli-Mark program layout. 
The windows and navigation may be configured different for different users, 
applications, or systems. and then perform a Download to All.  This will ensure 
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that any changes made during your session connected to the network will be 
saved both within the workspace and on the controller(s) themselves.  Finally 
press the Disconnect from Marking Machine(s) button found on the Home tab. 
 Once you have done these steps in succession, you can either close the I-Mark 
application or unplug your computer from the network on which you were 
working. 

Synchronizing 

Type topic text Data Matrix here. 

Layout Menu Ribbon 
Layout Menu Ribbon 

Type topic text Data Matrix here. 

Start Marking 

Type topic text Data Matrix here. 

Graphic Element 

Type topic text Data Matrix here. 

Line Element 

Type topic text Data Matrix here. 

Text Element 

Type topic text Data Matrix here. 

Data Matrix 

Type topic text Data Matrix here. 

Waypoint 

The waypoint   icon is located in the Layout Ribbon. This Ribbon menu is 
only available if a layout Marking legend displaying position and style of all the 
entities to be marked. is active in the center work area.  
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Clicking on this icon will create a new waypoint in the open layout. The new 
waypoint will be created in the x-y position   of the last entity in the layout and 
after the last entity in the Marking Order Window.  
 
The properties   of this waypoint are shown the Properties Window when the 
entity is selected.  
 

the use of a series of waypoints is a nice way to assure that critical path 
points may be entered in to the marking legend. Most common use of this feature 
is for part relief and other obstructions.  
 
 
 
 

Set Output 

Type topic text Data Matrix here. 

Wait Input 

The Wait for Input icon is located in two places in the Intelli-Mark software, 
one is on the Layout Ribbon and one is in the Entity Toolbox . 
 
The "Wait Input " entity is a non-printing Entities within the layout that do not 
produce a mark. These include: Waypoints, Outputs, Inputs, and Dwell Time. 
object, and will pause until the required I/O operation is completed.  
 
Once the Wait Input entity is selected on the opened layout the configuration 
associated with it may be changed. These variables may be changed in the 
Properties Window 
 
 

Dwell Time 

The dwell time icon is located in two places in the Intelli-Mark software, 
one is on the Layout Ribbon and one is in the Entity Toolbox . 
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The "Dwell Time" entity is a non-printing object, and will input a pause into the 
marking operation. This is used as parts are moved, measurement/camera 
operations occur, or fixture and guarding motions complete. 
 
Once the Dwell Time entity is selected on the opened layout the time value 
associated with it may be changed. This value is in milliseconds. 
 
1 equals 1ms 
1000 equals 1 second 
 

Copy 

The icon is located on the far left side of the Layout Menu Ribbon. The 
Layout Menu Ribbon is only available if a layout is open in the Main Work Area. 
When selected this command copies all the currently selected entities to the 
clipboard.  
 
After using the copy command, using the paste command will create a duplicate 
set of entities. Multiple sets of entities may be created by continued use of the 
paste command. 

Cut 

The icon is located on the far left side of the Layout Menu Ribbon. The 
Layout Menu Ribbon is only available if a layout is open in the Main Work Area. 
When selected this command cuts all the currently selected entities and copies 
them to the clipboard. 
 
After using the cut command, using the paste command will create a new set of 
entities. Multiple sets of entities may be created by continued use of the paste 
command. 

Paste 

This icon is located on the far right of the Layout Menu Ribbon. Using this 
command will place into the currently opened layout the entities that have been 
copied into the clipboard.  

Delete 
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is located in the Marking Order Window and 
 

is located to the far right of the Layout Menu Ribbon. 
 
Both icons perform the same command. This command will delete all the 
currently selected entities in the opened layout Marking legend displaying 
position and style of all the entities to be marked.. These selected entities are 
outlined by a blue line   in the Main Work Area, or highlighted in the Marking 
Order   Window.  
 
In addition, hitting the delete key on the keyboard will perform the same task. 

Marking Ribbon Menu 
Marking Ribbon Menu 

 
 

Connect to Marking Machines 
 

Disconnect from Marking Machines 
 

Select Layout 
 

Mark Layout 

Connect to Marking Machines 
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This icon is located in the Marking Menu Ribbon. When selected it will list 
the Intelli-Mark controllers/marking systems that are available on the network. 
 
If no systems are available, check the following issues: 

1. Is the computer that I-Mark is running on connected to the network? 
2. Are the Marking Systems connected to the Network? 
3. Are the Marking Systems on? 
4. Have the Marking Systems been properly configured/mapped? 

Disconnect from Marking Machine(s) 

This function can be found on the Home Ribbon Menu. When clicked, I-Mark will release 
it's connection with the Mapped Controllers within your Workspace. 

Select Active Layout 

This icon is located in the Marking Ribbon Menu. Select a layout Marking 
legend displaying position and style of all the entities to be marked. from the list 
of layout on the marking machine  . the highlighted layout will be run when the 
marking machine is next cycled. 
 
this command is followed by the Mark Layout icon or  

Start Marking 

Type topic text Data Matrix here. 

View Menu Ribbon 
View Menu Ribbon 

 
 
The View Menu Ribbon is shown when the view tab is selected. All of the icons 
on this menu effect the look of the workspace.  
 
First Group on left hand side of Ribbon controls the Zoom   
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Zoom In 
 

Actual 
 

Zoom Out 
 

Fit   to Screen 
 
Second Group in the middle of the ribbon controls the Look: 
 
Grid Lines  : Check box for on. Internal grid lines go through the layout Marking 
legend displaying position and style of all the entities to be marked. area. Grid 
lines are shown every inch, or 5 millimeters. 
 
Rulers  : Check box for on. Rulers run along the top and left of the layout screen. 
They display inches or Millimeters depending on the units  . 
 
Axis Labels: Check Box for on. Specifies X,Y axis and motion   type (linear, 
rotational), and Units. 
 
Home Position  : Check Box for on. Home position is labeled with two 
intersecting green lines with arrows. 
 
Units: English or Metric. Select system through drop down menu. If In is shown 
the units are in Inches. If MM is shown the units are in millimeters. 
 
The Third group on the right hand side of the ribbon controls seven other 
windows 
 

Toolbox 
 

Properties 
 

Navigator 
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Marking Order 
 

Manual 
 

Simulator 
 

Output 

Display Settings - Zoom Features 

The Zoom features are controlled through four icons on the far left of the View 
Menu Ribbon. 
 

The in icon will zoom in to a smaller area of the layout file on the screen.  
 

The Actual icon will reflect the actual size of the mark. If used with pen 
options it will help determine how close lines and character will be on the final 
product. 
 

The out icon will zoom out to show more of the layout file on the screen 
 

The Fit icon will automatically display the entire marking field in the Main 
Work Area. 

Display Settings - Grid/Rulers 

34 



Menu 

Center portion of the View Menu Ribbon 
 
Grid Lines : Check box for on. Internal grid lines go through the layout area. Grid 
lines are shown every inch, or 5 millimeters. 
 
Rulers : Check box for on. Rulers run along the top and left of the layout screen. 
They display inches or Millimeters depending on the units . 
 
Axis Labels: Check Box for on. Specifies X,Y axis and motion type (linear, 
rotational), and Units. 
 
Home Position : Check Box for on. Home position is labeled with two intersecting 
green lines with arrows. 
 
Units: English or Metric. Select system through drop down menu. If In is shown 
the units are in Inches. If MM is shown the units are in millimeters. 
 

Tool Box 

Type topic text Data Matrix here. 

Properties 

Type topic text Data Matrix here. 

Navigator 

The navigator icon. 
 
This icon is located in the View Ribbon. This icon will turn show/hide the 
Navigation   Window.    

Marking order 
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Type topic text Data Matrix here. 

Manual Mode 

Type topic text Data Matrix here. 

Simulation Mode 

Type topic text Data Matrix here. 

Output Settings 

Type topic text Data Matrix here. 

Help Menu Ribbon 
Help Menu Ribbon 

 
 
From the I-Mark Desktop, select Help menu tab across the top of the screen. 
There are three main items on the help menu:  

1. About page which gives information about the software release you are 
using 

2. Access to the Help File 
3. Live video Demos. Help Topics 

This icon is located in the Help Menu Ribbon, and opens a window 
containing the information about the software. 
 
Included on the page is the address and contact information for the servicing 
center: 
 
I-Mark 
27430 Luckino Dr 
Chesterfield MI 48047 
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586.949.8400 
586.949.8401 fax 
 
info@marking-machines.net 
 
There is also a link to the website, www.marking-machines.net.  This site 
includes all the latest upgrades and FAQ's. The I-Mark Online Web site provides 
a direct link to latest internal research database, downloads, and numerous 
support services. This service is available only with a current Support Agreement 
or Client Care Plan and to I-Mark business partners. First year is included free 
with purchase of I-Mark system. 
 
In addition, the version and release of the software is also noted. Please provide 
this information with all requests. 

Using the Help System 

Access the Help system when you want quick references for software 
commands, detailed information and entry samples for fields, flowcharts for 
complex concepts, and FAQ's and Troubleshooting information. The following 
topics provide information on the different ways you can access and use the Help 
system, as well as ways to easily print a grouping of related Help topics. 
 
Using the Help Menu 

F1 Help for a Field 
Print a  the Complete Help PDF 
(warning quite lengthy) 
Adobe Acrobat reader required 

Demos 

this icon is located in the Help Menu Ribbon. Selecting this command will 
access a complete list of demonstrations included with the Intelli-Mark software.  
 
How to Create/Open Workspace The Intelli-Mark program layout. The windows 
and navigation may be configured different for different users, applications, or 
systems. 
How to Create/Open Layout Marking legend displaying position and style of all 
the entities to be marked. 
Add Text Data Matrix to Layout 
Change Text Size 
Change Text Font  
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Change Entity Alignment 
Change Entity Orientation 
Make Entity into a Radius 

Marking Machine Menu Ribbon 
Open Marking Machine 

Type topic text Data Matrix here. 

Controller Download 

This icon is located in the Marking Machine Menu Ribbon. This ribbon is 
only available when a marking machine   is opened in the Main Work Area. When 
selected this command will update all the layouts assigned to the controller with 
the most recent saved layouts on the PC.  
 
While a number of marking machines may be opened, the selected machine will 
be the associated with the name on the Marking Machine Menu Ribbon Tab. In 
addition, this system will be highlighted and opened in the Main Work Area.    
 
Files on the controller may also be updated by dragging and dropping in the 
Navigation Window.  
 
In addition, a layout Marking legend displaying position and style of all the 
entities to be marked. file on the controller may be edited directly in the controller. 
This is accomplished by double clicking on the layout file associated with the 
marking machine in the Navigation Window. 
 

Warning messages will occur about the revision of a layout file, if the 
Marking System is selected to run and contains an earlier version of a layout file 
of an assigned layout file than the file resident on the marking System. 

Controller Upload 

This icon is located in the Marking Machine Menu Ribbon. This ribbon is 
only available when a marking machine   is opened in the Main Work Area. When 
selected this command will upload all the layouts that reside on the controller to 
the PC.  
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While a number of marking machines may be opened, the selected machine will 
be the associated with the name on the Marking Machine Menu Ribbon Tab. In 
addition, this system will be highlighted and opened in the Main Work Area.    
 
Files on the controller may also be updated by dragging and dropping in the 
Navigation Window.  
 
In addition, a layout Marking legend displaying position and style of all the 
entities to be marked. file on the controller may be edited directly in the controller. 
This is accomplished by double clicking on the layout file associated with the 
marking machine in the Navigation Window. 
 

Warning messages will occur about the revision of a layout file, if the 
Marking System is selected to run and contains an earlier version of a layout file 
of an assigned layout file than the file resident on the marking System. 

Controller Clock 

This icon is located on the Marking Machine Menu Ribbon. This ribbon is 
visible once a marking machine   has been selected in the navigation window, 
and is opened in the Main Work Area. When selected this command will 
synchronize the clock on the selected marking machine to match the PC clock. 
 
While a number of marking machines may be opened, the selected machine will 
be the associated with the name on the Marking Machine Menu Ribbon Tab. In 
addition, this system will be highlighted and opened in the Main Work Area.    

Assign Layout to Marking Machine 

This icon is located in the Marking Machine Ribbon. This ribbon is visible 
once a marking machine   has been selected in the navigation window, and is 
opened in the Main Work Area. 
 
While a number of marking machines may be opened, the selected machine will 
be the associated with the name on the Marking Machine Menu Ribbon Tab. In 
addition, this system will be highlighted and opened in the Main Work Area.    
 
A drop down menu will appear and display all additional layouts from the PC 
available to be assigned to the machine. 
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• The layout Marking legend displaying position and style of all the entities 
to be marked. must reside in the I-Mark data   directory located: 
...Program Files\I_Mark_x_x_x  (where the small "x"s are the version 
numbers).  

• The layout must have the same marking machine type as the marking 
machine selected. 

If a required layout does not appear check the layouts location on the PC, and 
the marking machine type assigned to it. 
 
In addition to the Assign Layout icon, I-Mark software also allows for a "drag and 
drop" method to assign layout to marking machines. This is done by using the 
navigation window. Click on the layout required and "drag" to the marking 
machine. 
 

If this symbols continues to appear when you drag layout over marking 
machine, check to make sure that the layout machine type matches the marking 
machine type of the desired machine. 
 
 
 
 
 
 

Remove Layout from Controller 

Type topic text Data Matrix here. 

Layouts 

Layouts are the files associates with the marking programs. They contain 
both marking and non-marking entities. These files may be managed through the 
Intelli-Mark software via a PC. They may be resident on either or both the PC 
and the Marking Machines.  
 

These files are not automatically created nor saved. The filename on the 
Main Work Area tab will be followed by an asterisk if the file has note been saved 
in its current state. 
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When the file is saved the file is located in the data   directory under the 
Intelli-Mark program files. The extension name is .ctml 

Counter Configuration 

This counter configuration icon is located on the Marking Machine Menu 
Ribbon. This ribbon is only available when a marking machine   is opened and 
selected in the Main Work Area.  
 
While a number of marking machines may be opened, the selected machine will 
be the associated with the name on the Marking Machine Menu Ribbon Tab. In 
addition, this system will be highlighted and opened in the Main Work Area.    
 
When selected the following configuration widow appears. 
 

 
 
Counter List: List of counters in the marking machine. 
 
Increment: Value the counter changes each time the machine is cycled. 
 
Final: the value at which the counter will stop. 
 
Reset: The number which the counter will reset to 
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Reset Condition:If set to NONE, the counter will not reset. If set to FINAL, the 
counter will reset when it reaches the final value. If set to DAILY, the counter will 
reset at the end of each day. If set to  END OF SHIFT, the counter will reset at 
the end of each shift. This command is paired with the Shift configuration.  
 
When INPUT is select as a reset condition additional fields will display. 
 
Input: Requires a I/O number form 1 through 7, and relates to the I/O position   in 
the Controller. 
 
Input Level: This option is specified as either low or high.  
 

 
 
Additional information about the counters in the marking machine is located on 
the Status & Control Tab of the marking machine in the Main Work Area. 
 

Currently the standard counter does NOT have the functionality for 
counting down, having negative values, or numeric type other than integers. 

Shifts 

Type topic text Data Matrix here. 

Date 

Type topic text Data Matrix here. 
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I/O Mapping 

 
If you are unable to find the answer to your I-Mark questions in the standard 
product documentation or online, phone support is available at the following 
locations: 
 
 
 

 
 

Enable-disable 

Type topic text Data Matrix here. 

Remove Marking Machine 

Type topic text Data Matrix here. 
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Advanced Topics 
Date & Shift codes 
Counters 
Serial Specifications 
I/O Mark Start and Complete 
E-Stop Suggested Configuration 
Waypoint Setup for Custom Tool Path 
I/O Setup and Configuration 
Multiple Axis Setup 
Warning Messages When Saving Files 
Error Messages 
 
 

Date & Shift Codes 
There are three elements to completely program the date and shift codes. 
 
1) Is to program the date and shift codes in a dynamic text entity. This involves 
creating a text entity and properly denoting the codes for the date/time features 
required. 
 
2) Is to configure the shifts in the marking machine. This involves selecting a 
marking machine and creating an array of shifts. 
 
3) Is to configure the date and time for the marking machines. This involves 
selecting a marking machine and editing the Months, Days, AM/PM and/or Time 
Zone information.   

Counter Configuration 

This counter configuration icon is located on the Marking Machine Menu 
Ribbon. This ribbon is only available when a marking machine   is opened and 
selected in the Main Work Area.  
 
While a number of marking machines may be opened, the selected machine will 
be the associated with the name on the Marking Machine Menu Ribbon Tab. In 
addition, this system will be highlighted and opened in the Main Work Area.    
 
When selected the following configuration widow appears. 
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Counter List: List of counters in the marking machine. 
 
Increment: Value the counter changes each time the machine is cycled. 
 
Final: the value at which the counter will stop. 
 
Reset: The number which the counter will reset to 
 
Reset Condition:If set to NONE, the counter will not reset. If set to FINAL, the 
counter will reset when it reaches the final value. If set to DAILY, the counter will 
reset at the end of each day. If set to  END OF SHIFT, the counter will reset at 
the end of each shift. This command is paired with the Shift configuration.  
 
When INPUT is select as a reset condition additional fields will display. 
 
Input: Requires a I/O number form 1 through 7, and relates to the I/O position   in 
the Controller. 
 
Input Level: This option is specified as either low or high.  
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Additional information about the counters in the marking machine is located on 
the Status & Control Tab of the marking machine in the Main Work Area. 
 

Currently the standard counter does NOT have the functionality for 
counting down, having negative values, or numeric type other than integers. 

E-Stop Suggested Configuration 
Type topic text Data Matrix here. 

Waypoint Setup for Custom Tool Path 
Type topic text Data Matrix here. 

I/O Setup and Configuration 
The following are the suggested integration and timing sequences for the 1) 
Standard Operation, 2) Operation with Fault/E-Stop Recovery, and 3)  Operation 
with Serial Data String 
 

 
 
1) Standard Operation 
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2) Operation with Fault/E-Stop Recovery 
 

 
 
3) Operation with Serial Data String 
 

 

Multiple Axis Setup 
Type topic text Data Matrix here. 

Warning Messages When Saving Files 
Type topic text Data Matrix here. 

Error Messages 
Error Messages 
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Type topic text Data Matrix here. 

Error 100 

Type topic text Data Matrix here. 

I-Mark Axis Fault Codes 

Type topic text Data Matrix here. 
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Glossary 
B 

Basic Mode:  

D 
Data:  
Dimensions:  
Dwell:  
Dwell Timer:  
Dynamic: Text or data Matrix marking entities. These entities may change from 

mark to mark. 

E 
Entity Toolbox: Window that contain all the entities that may be put into a 

marking layout: Static, Dynamic, and Non-Printing 

F 
Fit:  
Font:  

G 
Graphic:  
Grid Lines:  

H 
Home: Home position is defined as the maximum X and the Zero Y. This is the 

position that the marker is defaulted to start each cycle from. 

L 
Layout: Marking legend displaying position and style of all the entities to be 

marked. 
Line:  
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M 
Manual:  
Marking Machine:  
Marking Order:  
Motion:  

N 
Navigation:  
Non-Printing: Entities within the layout that do not produce a mark. These 

include: Waypoints, Outputs, Inputs, and Dwell Time. 

O 
Orb: Intellimark symbol in the upper left hand corner of the main window. 

P 
Pen:  
Position:  
Properties:  

R 
Rulers:  

S 
Set Output:  
Simulation:  
Static: Entities that do not change. These inlcude lines, and graphics. 

T 
Text: Data Matrix 

U 
Units:  

W 
Wait Input:  
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Waypoint:  
Workspace: The Intelli-Mark program layout. The windows and navigation may 

be configured different for different users, applications, or systems. 

Z 
Zoom:  
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