
Image Cropping, Resizing, and Saving in JPEG Format 

 
This part of the tutorial 
will introduce you to the 
Gimp's user interface 
and show you how to 
open an image, resize it, 
crop it and save it as a 
JPEG, which are common 
operations when 
preparing images to be 
used on a website. 
 
 
 
 
 
 
 
 
 

 

 

Getting Started 

 
Start the Gimp by selecting "Gimp 2" from the "Programs" list in the 
Start menu. When the Gimp starts up, it presents you with a "tip of 
the day." Read this if you want to, and then close the window: 
    

 
 



When the Gimp starts up, there are two windows open. One of these 
is a toolbar that contains icons for a number of tools used in 
working with images, tools for selecting colors, and also a group of 
options for the currently selected tool. The other window contains 
different panes for working with layers, channels, and paths at the 
top, and panes for working with brushes, patterns, and gradients at 
the bottom. 
 
Here is the 
toolbar window 
and the layers, 
channels, and 
paths window: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Here is the brush, pattern, 
and gradient selection area: 
 
 

 

 
 

 

 



 

Opening Files and Setting Magnification 

 
The first thing we're going to do now is open an image file to work 
with. We'll go to the "File" menu on the toolbar and choose "Open": 
 

 
 
Use the dialog box that pops up to navigate to the file that you 
want to open: 
    

 
 
The picture that I've opened is much too big to view on the screen 
with these other windows, so I'm going to resize the window and 



then change the magnification that the image is shown at. 
 
The initial window: 
    

 
 
The window after 
resizing.  Note that the 
image no longer fits in 
the window: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



After resizing the window, choose "Zoom to Fit Window" from the 
"View" menu, and the image will be resized to fit the window. We 
haven't changed the actual size of the image, but have simply 
changed our view of it so that we can see it all at once: 
 

    

 

Cropping Images 

 
The next thing I'm going to do is crop this extra white space out 
from around the image. One method for doing this is to select the 
"crop" tool in the toolbar, select an area with the mouse, and click 
"crop" on the pop-up, which crops the image to the selected area: 
    

 
 
If you want to remove a large amount of a single color around the 
edges, you can also crop the image by going to the "Image" menu 



and choosing "Transform," and then "Autocrop." In this example, 
I've used autocrop to remove the solid white area around this 
image: 
 
Choosing "Autocrop": 
 

 
 
The autocropped image: 
 

 



Resizing Images 

 
Now we'll resize the image. 
Under the "Image" menu, 
we'll choose "Scale Image": 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Enter a new width. For this image, 
I'm going to choose 250 pixels. 
The small chain to the right of the 
width and height signifies that 
the ratio of height to width will 
remain fixed: when we change 
the width, the height will change 
to remain in proportion: 
 

 

 
 



Next, we'll go down to "Resolution" and change the resolution to 72 
pixels per inch on the x axis, and again because the values for 
resolution in the x and y dimensions has been linked, y will change 
too. 72 pixels per inch is a common resolution to work at when you 
are preparing an image for on-screen display (as opposed to print, 
where you would probably want to use a higher resolution than 
that): 
 

 
 
Click "OK," and the image will resize: 
 

 



Now the image looks very tiny because the zoom is still where we 
left it before, so let's zoom to see it in full size: under the "View" 
menu, choose "Zoom," then "100%": 
 

 
 
The result: 
 

 



 

 

Saving in JPEG Format 

 
Now let's save the image as a JPEG, which would be appropriate for 
use on a website. Under the "File" menu on the image, choose "Save 
as," then use the dialog box that pops up to indicate where you 
want to save it: 
 
 
 

 
 
 
 
 
 
 
You can choose the file type you want to save as in the pull down 
menu in the lower right-hand corner. You can also choose to 
determine file type "By Extension," which means if we change the 
extension from ".tiff" to ".jpg," then the image will automatically be 



saved as a JPEG. I'm going to name this file "little_wilber.jpg" and 
click "OK." 
    

 
 
Next, the "Save as JPEG " options window will open. In this window 
we can choose among different options for saving the file:    

 
 



If we click the box labeled "Preview in image window," we'll be able 
to see the effects of the settings that we're using on the image. As 
we slide the "Quality" slider, you can see what the image will look 
like after it's saved. 
 
Our image looks pretty bad at a quality setting of 0.03: 
    

 
 
What we're trying to do here is find a good tradeoff between size 
and quality. It looks pretty good set at "80," so we'll go with that. 
For now, we'll just leave the other settings on the page in their 
default settings: 
    

 
 
Now we'll click "OK," and we've succeeded in resizing, cropping, and 
making a jpeg from this image. 
 

 



 

 

Working with Text and Layers 

 
In this section of the tutorial, you will learn how to add text to your 
images and start working with layers. 
 
 
 

 

 

 

 

 

Adding Text 

 
Let's begin by adding text to an image. To keep things 
interesting, I've chosen a new image to work with for this 
section. The first thing to do is to select the text tool, 
which is represented in the toolbar by a capital "T": 
 
 



Once we select this tool, the options for the tool open in the lower 
part of the toolbar, and we can use these controls to choose the 
font, the font size, and the color: 
 

 
 
Let's choose a color for our text. Clicking the color button produces 
a color selection pop-up, which gives you several methods for 
choosing color. We'll go with the default one for now and select a 
nice yellow: 
 
The color button: 
 

 
 
 
 
 



The color choosing window:  
 

 
 
Choosing a yellow: 
 

 
 



Now, if we click in the image, 
the Gimp Text Editor appears 
in a pop-up window: 
 
 
 
 
 
 
 
 
 
 
 
 
If you type in the box, the same 
text appears on the image. If the 
text you type goes over the edge 
of the image, that's okay 
because you can change its 
position later: 
 
 

 

 

 

Layers 

 
We'll close the text editor and look 
over here at the "Layers" list. You 
can see that when we added the 
text to the image, a new layer was 
automatically created. 
 
     
 
 
 
 



Layers give you the ability to work 
independently with different elements 
in the image that can be on top of one 
another. For example, we can move the 
background text without disturbing 
other parts of the image. To move the 
text, select the "move layers" tool in the toolbar and click and drag 
on the text. When you drag the text layer, the background image 
does not move: 
 

 

 

Making a New Layer 

 
Now we'll add another layer. Go to the "Layer" menu on the image 
and choose "New Layer": 
 

 
 
A pop-up window appears which gives us some choices. We'll name 
the new layer "Red Fill." The layer's size was automatically set at the 
width and height of the image, and we're going to leave it that way. 



Finally, we'll leave the fill type as 
"Transparent" and close the window 
by clicking "OK": 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
You can see in the layers list 
that a new layer has been 
created: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Now we'll fill the new layer with a red color. Select the 
foreground color by clicking on this area in the middle 
portion of the toolbar: 
 
 
 



We get the same interface to select color that we had earlier when 
selecting the text color, and we'll use this to choose a red: 
 

 
 
 
 
If we take the fill tool, which looks like a paint bucket pouring, 
select it, and then click on the image, the image becomes 
completely filled with red: 
 

   



Layer Stacking Order 

 
You can see in the layers list that the "Red Fill" layer is above the 
other two layers: 

 
 
We can move it down in the stacking order so that it is beneath the 
text we entered earlier. We'll select the red fill layer by clicking it, 
and then lower it by clicking this down arrow button, and now the 
text is above the red layer: 

 
 
When you're working you can also hide layers by clicking on the eye 
that's next to each one: 

 



 

Layer Opacity 

 
Another thing you can do is change the opacity of layers. When I 
select the red fill layer and drag the "Opacity" slider below 100, the 
underlying image can be seen though it: 
 

 

 
The result of dragging the opacity slider: 
 

 
 
The background image appears beneath a red haze, the semi-
transparent "Red Fill" layer. 
 



Saving Images with Layers 

 
Now we're going to save our progress. When you save a file that has 
mutiple layers, you need to save it as a Gimp file, which preserves 
all of the layer information. Gimp files use the three-letter 
extension ".xcf." 
 
Go to the "File" menu on our image, choose "Save as": 
 

 
 
We're going to name the file "aaron.xcf." Under "Determine File 
Type," we can choose "By Extension," and because the filename we 
chose ended with ".xcf," it will automatically be saved as a Gimp 
image. Alternately, we can select "XCF (GIMP) " in the list in the pull-
down menu: 
 

 
 
Finally, we'll click "OK" to save the image. 



Selections 

 
In this section of the tutorial, you will learn to use the Gimp's 
selection tools. 
 

     

 

Rectangular Selection 

 
You can use the Gimp's selection tools to select areas within layers 
to work on. For example, if we select the "Red Fill" layer, choose the 
rectangular selection tool, 
 

 
 
click and drag inside the image, 
 

 
 



and then choose "Cut" from the "Edit" menu. 
 

 
 
The area that we selected has the red fill cut out of it: 
 

 
 
Note that cutting did not affect the background layer underneath, 
just the selected layer. 

 

Elliptical Selection 

 
If we select the background layer, choose 
the elliptical selection tool, 
 
 
 
 



click and drag in the image, 
 

 
 
and choose "Cut," 
 

 
 
the area selected will be cut out of the background photograph: 
 

 

 



Lasso Selection and Inversion 

 
With the lasso tool, we can select freeform areas. In this case, I've 
used the lasso tool to draw a rough outline of the person in the 
image: 
 

      
 
 
If we go to the "Select" menu and choose "Invert,"  

 

 
 
 
 
 
 
 
 
 



the area selected changes to everything that was not selected 
previously. Now, everything outside of the outline of the person is 
selected: 

 

 

Selection and the Paintbrush 

 
The paintbrush tool is used to paint onto the image: 

 
 
Let's choose the paintbrush tool and select a color just as we did 
when working with the fill tool, and then choose a brush from the 
brush selection area: 

 
 
 



When we click and drag on the image, the paintbrush only paints 
within the selected area: 

 
 
You can remove any selection outlines by going to the "Select" 
menu and choosing "None": 
 

 

 

Selection by Color 

 
The Gimp also provides tools to automatically select areas based on 
color. 
 
The "magic wand" tool selects continuous regions of color: 
 

 



 
If we choose the magic wand and then click in the blue paintbrush 
marks, the blue area gets selected: 
 

 
 
 
 
You can adjust the tolerance for what color counts as part of the 
area to be selected by working with the "Threshold" slider: 
 

 
 
 
Higher numbers allow more variation in color. This can be useful, 
for example, when you're trying to select an area with a feathered 
edge like the blue brush strokes. If we remove our earlier selection 
and then click in the blue area with a higher threshold setting, more 



of the fuzzy edge of the paintbrush stroke will be captured: 

 
 
In fact, the selection has gone beyond the brushstrokes, indicating 
that we should probably try again with a lower threshold setting if 
the brush strokes were what we were trying to 
select. 
 
This tool allows you to select all areas in the 
picture that fall within a certain range of 
color: 
 
 
 
When we click on a 
gray area, for 
example, all areas 
throught the layer 
that match it in color 
are selected (in this 
example the red 
layer is hidden for 
clarity).  Notice that 
the selection has not 
been restricted to 
one continuous area, 
as in the case of the "magic wand" tool, and many separate areas of 
the image are selected at once. 



Filters 

 
This section of the tutorial will briefly introduce you to filters. 
 
The Gimp includes a large number of filters that allow you to 
transform the images that you're working on in different ways. 
These filters are located in the image window, under the "Filters" 
menu. 
     
 

 
 
 
 
 
 
 
Let's say, for example, that we want to sharpen the background 
picture in this image. The first thing to do is to make sure that that 
layer is selected in the layers pane. Then we'll go back to the image 



window, go to the "Filters" menu, then the "Enhance" submenu, and 
choose "Sharpen." 

 
 
When we choose "Sharpen," a 
popup appears that has a small 
preview window and a slider that we 
can use to set the level of 
sharpness we want to have applied 
to my picture. We can adjust the 
slider until the image in the preview 
window looks the way we want it, 
and then click "OK" to have the 
effect applied to the image. 
 



 
 
The Gimp includes a very large number of filters that allow you to 
do many different things with images, so it's really worth taking the 
time to explore them on your own. 

For More Information 

 
If you'd like to get more information about using the Gimp, a good 
place to start is the Gimp website at www.gimp.org: 
 
    

 
 



By following the link to "Documentation," you'll find a list of links to 
the Gimp user manual in various languages: 
    

 
     
 
By following the link to "Tutorials," you're given 
a large number of tutorials that show you 
different things you can do with the Gimp that 
are divided into different levels of expertise 
and also different areas of interest: 
 
 
    

 
 
 
 
 


