Addendum
Vector Xpression 3.1

Features Covered in this Document:

Interactivity with Vector PathBlazer™ 2.0
Saving Data in MAGE-ML Format
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Introduction

Vector Xpression™ is a comprehensive program for storing, managing, and analyzing gene
expression data from microarrays and other technologies. It includes:

e Database tools for managing thousands of gene expression data points.

e Tools for combining, comparing, and analyzing the data from multiple expression
experiments

e Filtering and clustering algorithms for comparative analysis

e Graphical tools for visualizing patterns of gene expression

This addendum documents the new features and functionality of Vector Xpression 3.1 software. It is
intended as a supplement to the Vector Xpression 3.0 User’s Manual.

Features Covered in this Document

The new features and functionality of Vector Xpression 3.1 covered in this addendum are:

e Interactivity with Vector PathBlazer™ 2.0
e Saving data in MAGE-ML file format

Additional Documentation

This addendum assumes knowledge of the basic features and functions of Vector Xpression. For
additional software documentation, see the following (available on the Web at www.informaxinc.com):

e Vector Xpression 3.0 User’s Manual

e Vector Xpression 3.0 Installation and Licensing Guide
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Interactivity with Vector PathBlazer 2.0

Vector Xpression 3.1 contains new tools for exporting gene expression data directly into Vector
PathBlazer 2.0 for further analysis and searching Vector PathBlazer for gene information. This
section describes these tools and functionality.

Vector PathBlazer 2.0 also includes tools for directly accessing expression data in Vector Xpression.
See the Vector PathBlazer User’'s Manual for more information.

Overview of Vector PathBlazer 2.0

Vector PathBlazer is software for analyzing biological pathways and molecular interactions. It can be
used to collect, store, and manage data from public and proprietary sources, and includes a variety of
tools for creating and analyzing pathway models from that data. The software has the following main
features:

e A database, which stores the information about the pathway components (molecules, enzymes,
reactions, products, etc.)

o A Database Explorer for viewing and managing the database components, and

e A Viewer, which can be used to construct and display pathway topologies graphically from the
database components.

You can store gene expression data in a Vector PathBlazer database and display and analyze it in
the context of a pathway using the software. Gene expression data from Vector Xpression 3.1 can be
exported directly into PathBlazer for this type of analysis.

For more information on Vector PathBlazer, see the Vector PathBlazer User’s Manual.

Creating a Vector PathBlazer Template

To export gene expression data from a Vector Xpression database into Vector PathBlazer, you must
first map the gene data in Vector Xpression to PathBlazer using a mapping template. The template
links the fields and values for the genes in a Vector Xpression database to the corresponding
components in a PathBlazer database. The mapping template is saved in the PathBlazer database,
and can be used to transfer data from all Vector Xpression files that include the mapped information
(e.g., multiple experiments using the same genes).

To create a mapping template (see also Figure 1):

1. In the Vector Xpression Database Explorer, select Expression Genes from the drop-down
list of Tables in the Explorer, and then select the gene(s) that you want to map, or

In the Vector Xpression Viewer, display an experiment, expression run, or run project
containing the genes that you want to map. You may also display a list of the genes in a
given experiment, expression run, or run project and then select the gene(s) from the list that
you want to map.

2. Go to the Tools menu and select Create Template in PathBlazer. This will open the Create
PathBlazer Template Wizard.
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Figure 1.  Creating a PathBlazer Template

3. Click on the Browse button to locate and select the PathBlazer database in which you want
to create the mapping template. Then click on Next.

4.

Now specify the settings and name for the mapping template that you are creating. In the
Mapping Options section of the dialog box, specify how you want to link the selected genes
in Vector Xpression to the appropriate components in the PathBlazer database. Select from
the following options:

Gene Name—The gene name in Vector Xpression matches the name or synonyms of
the component in PathBlazer.

Alternative Name—The alternative gene name in Vector Xpression (from the Alternative
Name column in the Vector Xpression database) matches the name or synonyms of the
component in PathBlazer.

Foreign Key—The gene in Vector Xpression has a value in a user-defined column that
can be linked to the PathBlazer component through a crosslinked external database. For
example, if a PathBlazer component is crosslinked to the Biomolecular Interaction
Network Database (BIND) via an accession number, and that accession number is
entered in a user-defined field of a gene in the Vector Xpression database, you can
create a foreign key linkage in the template. If you select the Foreign Key option:

4.1.Select the external database from the PathBlazer Crosslink Database Name drop-
down list. This list includes all the external databases with crosslinks to the selected
PathBlazer database.

4.2.Select a column name in the Vector Xpression database from the Expression UDF
Name drop-down list that contains the linking values to the external database.
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5.

Type a name for the new template in the Template Name field. To replace or add the current
information to an existing PathBlazer template, select the existing template name from the
Template Name drop-down list.

Click on Next. If you selected an existing template, you will be prompted to replace or amend
it.

The template will be created, and the current data in Vector Xpression that can be mapped using the
template will be transferred to PathBlazer. This may take a few minutes if you are mapping a large
number of genes.

You can now use the template for other experiments, expression runs, etc. involving the same genes.

Exporting Expression Data to PathBlazer

After you have created a mapping template for a set of genes (see page 2), you can export
expression data for those genes from Vector Xpression to Vector PathBlazer.

To export expression data (see also Figure 2):

1.

In the Vector Xpression Viewer, load an experiment, expression run, or run project containing
the genes that you want to export. You may also display a list of the genes in a given
experiment, expression run, or run project and then select the gene(s) in that list that you
want to export.

Go to the Tools menu and select Send Expression Data to PathBlazer. If you have
selected genes from a list, you will be prompted to export all the listed genes or only the
selected genes.

The Save Experiment(s) to PathBlazer Database dialog will open. In the dialog, select the
mapping template that you want to use for the export operation from the Use Template drop-
down list.

Select the PathBlazer database that you want to export the data to from the PathBlazer
Database drop-down list.

Click on Save to complete the operation. The gene data will be exported and the Vector
PathBlazer application and database will open.

Save Experiment({s) to PathBlazer database [ x|
Experiments:
DeRisi [up-regulated] ;I
=]
Tools  Window  Help Use template:
Export Expression Matrix, .. IYEES[ Mapping j
Export Gene List ko Excel..,
Send Expression Data to PathBlazer PathBlazer database:
Find Components in PathElazer Browese... |
Create template in PathBlazer
Save I Cancel | Help |
Import Genes List,,.

Figure 2.  Exporting Expression Data to PathBlazer.
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Searching the PathBlazer Database

After you have created a mapping template for a set of genes (see page 2), you can search the
components in a Vector PathBlazer 2.0 database for those genes.

To search the PathBlazer Database (see also Figure 3):

1.

In the Vector Xpression Database Explorer, select Expression Genes from the drop-down
list of Tables in the Explorer, and then select the gene(s) that you want to search for, or

In the Vector Xpression Viewer, display an experiment, expression run, or run project
containing the genes that you want to search for. You may also display a list of the genes in a
given experiment, expression run, or run project and then select the gene(s) in that list that
you want to search for.

Go to the Tools menu and select Find Components in PathBlazer. If you have selected
genes from a list, you will be prompted to search for all the listed genes or only the selected
genes.

The Search Genes in PathBlazer Database dialog will open and the selected genes will be
listed. In the dialog, select the mapping template that you want to use for the search
operation from the Use Template drop-down list.

Select the PathBlazer database that you want to search from the PathBlazer Database drop-
down list.

Click on Search. The PathBlazer application will open, and your search request will be
transferred to the PathBlazer search engine. The PathBlazer search engine includes prompts
for further defining the scope of your search. See the Vector PathBlazer User’s Manual for
more information on performing searches in PathBlazer.

Search Genes in PathBlazer database [ =]
Genes:
YLR377C |
KR0S
("EROB5:
ITLR17 4%/
WCROTOC
TALOS4C
TR
J
Tools ‘Window  Help Use template:
Export Expression Matrix. .. IYeast tdapping j
Expart Gene List ko Excel...
Send Expression Data ko PathElazer . Pt de s
Find Components in PathBlazer k C:\Documents and Setlingshlser\PathBlazer demo db.mdbl Browse... |
Create template in PathElazer
Search I Cancel | Help |
Import Genes List...

Figure 3.  Searching the PathBlazer Database from Vector Xpression.
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Saving Data in MAGE-ML File Format

Microarray Gene Expression Markup Language (MAGE-ML) is a language designed to describe and
communicate information about microarray-based experiments. MAGE-ML is based on XML and can
describe microarray designs, microarray manufacturing information, microarray experiment setup and
procedures, gene expression data, and data analysis results. MAGE_ML has been derived from the
Microarray Gene Expression Object Model (MAGE-OM), which was developed and described using
the Unified Modeling Language (UML)—a standard for describing object models.

Vector Xpression 3.1 can save raw expression data in MAGE-ML format. With your raw data file open
in the Vector Xpression Viewer, go to the File menu and select Save Copy > Save in MAGE-ML
Format.

The file will be saved with an .xml extension. For an example of a file saved in MAGE-ML format, see
Figure 4.

(% UltraEdit-32 - [d:\Documents and Settings'kgroch’Desktop',DeRisi_9.xml] =100 x|
["JFie Edt Search Project Wiew Format Column Macro Advanced Window Help —18] x|

DEdH R A4 WHET ' CRE=T8nafMPal0600% 52N

DeRigi_9. «ml |

i
Fiter: | Refiesh || | koxml -version="1.0" encoding="UTF-8" - standalone="no"2>q g
=————|| < !DOCTYPE- MAGE-ML - SYSTEMN- "MAGE-HL. dvd">1

Open Files | <nacE-uL- tdent i ier="TVeN: Rawbaza: 17 nawe="DeRisi_a">q

nFies <!==-Copyright- (C)-InforMax, - Invitrogen-Life-Technologies, -2003-—->9

- -<PropertySets_assnlisc>q
-+« <HameValueType - name="Version" -walue="3.1"- type="Vector - ¥pression"/>1
-+ - r<NameValueType- name="Date™ -value="2004-01-21T14:30: 562" - type="Vector - Xpression"/>q
--</Property3ets assnlist>J
++<BioMaterial package>
+<Compound_assnlist>q
++ s <Compound- identifier="IVGH: COMP: 1" - name="%.0-hour"/>q
------ <Compound-identifier="IVGH:COMP:2" - name="Yeast -Fool"/>1
=</ Compound assnlist>q
-+ --<BioMaterial assnlist>q
------ <Biofource-identifier="IVCGN:BioSource:2" -nawe="Veast- (9.0 -hxr) ">q
-------- <MaterialType assn>q
---------- <OntologyEntry-category="HaterialType"-value="Tizsue"/>q
-------- </MaterialType_assn>q
- </BioSource:q
*<BioSource:identifier="IVGN:BioSource: 1" name="YeastFool">q
-+ <MaterialType_assn>9

e <OntologyEntry-category="HaterialType"” -valus="Tissue"/>q
-------- </MaterialType_assn>T
------ </BioZource>q
------ <BioZample-identifier="IVCGN:BioSamwple: 2" -nawe="Veast- (9.0 -hx) ">q
-------- <MaterialType assn>q
---------- <OntologyEntry-category="HaterialType" value="Target"/>q
r</MaterialType_assn>J
Treatments_assnlistsq
<Treatment:identifier="IVGN:Treatment:-1"+name="Unspecified”>q
- -<hetion assneq

e 2OntologyEntry-category="Action” -valus="Unspecified"/>q
------------ </hction assn>q
------------ <hetionMeasurement_assn>T
-------------- «Measurement - value="0.00000"/ >
------------ </ hetionMeasurement assn>d
r-<FourceBioMateriallMeasurements assnlist>J
- -<BioNaterialleasurement>q

d:\Documents and Setting:

--<BioMaterial assnref>q
+++ e <BioSource ref-identifier="IVGN:BioSource:2"/>q

i - ’;I | ;ﬁ'

[For Help, press Fi [Lr 1, Col. 1, C pos | [Mod: 1j21j2004 2:31:10FM  [File Size: 22336842 [ns 4

Figure 4. Example of a file saved in MAGE-ML format.
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Additional Information

Technical Support

Visit www.informaxinc.com for user guides, installation guides, FAQs, technical bulletins, and other
information about Vector Xpression software.

For additional technical support:
E-mail:

United States: techsupport@informaxinc.com

Europe: techsupporteurope@informaxinc.com

Phone:

United States: 240-379-4240
Toll-free U.S.: 800-357-3114
Europe: +44 186 5784591

Copyright Notice

Copyright 2003 InforMax, Inc. All rights reserved. The unauthorized disclosure, copying, or altering of
this document, whether in hardcopy, personal computer diskette format, through any electronic
medium or otherwise, is strictly prohibited. While every effort has been made to ensure the accuracy
of this publication, InforMax, Inc. assumes no liability for error or omission from use of the information
contained herein.



