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1. Introduction 

1.1. Overview 

This Product Update contains information on the modifications of the Test Packs 
supported on the 8100 Mobile Device Test System from the version 4.4.0 to version 
4.5.0. 

The Test Packs supported on the 8100 Mobile Device Test System v4.5.0 are: 

• CDMA - LTE Mobility v1.4 

• Data Retry - LTE v1.3.1 

• Data Throughput - LTE v1.5 

• RF Performance - LTE v1.5 

• UMTS - LTE Mobility v1.0 

• Stress Test - LTE Suite v2.0 

NOTE: This release should not be used by AT&T AVLs. AT&T has only validated the 
RA 4.4.0 (Dec.) release.  
For AT&T AVLs, use the new suites (v2.0 or higher) which include Band 2 and 5 
tests. These suites should be used in combination with the RA 4.4.0 (Dec) release.  
If AT&T LTE Data throughput tests are run with the RA 4.5.0 release, there can be 
some deviance in performance from the official validated version (RA 4.4.0). 

8100 Mobile Device Test System - Radio Access: LTE v4.5.0 consists of the software 
components listed in the table below. 

Software Version 

8100-B Series Platform 1.1.79.0 

8100-B 100 Platform 1.5.350 

Platform Setup Guides 1.0.2 

AirAccess C2K 4.30.009 

AirAccess WCDMA HS 4.42.104 

AT4 Log Generator COM Interface 1.6.0.12 

AT4 Logging Framework Runtime 1.6.1.4 

CDMA 8960 Driver 3.3.0.17 

CDMA - LTE Mobility 1.4.74  

CS8 Development Library 1.1.17 

Custom Report Engine 1.1.17 

Data Retry - LTE 1.3.157 

Data Throughput - LTE 1.5.272 
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Software Version 

Development Library Services 1.50.143 

E2010S Driver 2.9.0603 

CS8 Interactive Tester 1.50.022 

Intrig Data monitor 1.2.14 

RF Performance - LTE 1.5.370 

Spirent AT Control (installed on Client 
Laptop) 

1.5.25 

Spirent Data Client (installed on the 
Controller PC, Client Laptop, and 
Application Server) 

1.12.213 

Spirent EPC Software 10.0.0.48.paw.19.tsu 

Spirent WCE-IAPI 3.51.034 

Spreadsheet Report Engine 1.5.67 

SR5500 TestKit 3.51.002 

TCU2 Driver 1.0.16 

Test Manager 2.5.319 

UMTS - LTE Mobility 1.0.6.1 

Universal DM V2 4.7.1 

1.2. New Features 

1.2.1. CDMA - LTE Mobility 

The following features have been added to the CDMA - LTE Mobility Test Packs: 

• Supports verifying UE Capability Information message in the VZW LTE-CDMA InterRAT 
Operations and VZW LTE-CDMA InterRAT Operations for SVD Test Plans. 

• Supports enhancement for MPSR cases. 

• Supports password protection for VZW suites. 

• Supports locking of VZW suites. 

• Supports SR5500 with Static Mode. 

• Supports "QrxLevMin" configuration through a test case parameter. 

• Supports ping-only in downlink direction. 

• Supports calling pre-registration shell command after reset. 

• Supports the update for the VZW LTE-CDMA InterRAT Operations Test Plan from v6.0 
to v9.0. 

• Supports the update for the VZW LTE-CDMA InterRAT Operations for SVD cases. 
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1.2.2. Data Retry - LTE 

There are no new features included in this release of the Data Retry - LTE Test Packs. 

1.2.3. Data Throughput - LTE 

The following new features are included in this release of the Data Throughput - LTE Test 
Packs: 

• Support for Variable Reference Channel Tests. 

• Support for ETU 300 Fading Profile. 

• Support for Advanced P/F Criteria based on the UE Category. 

• Support for Custom/Adaptive UDP Blaster Rate. 

• Support for TM4/TM6 CQI Reporting. 

• Support for Suites Password Protection. 

• Support for TM1 SIMO. 

1.2.4. RF Performance - LTE 

The following new features are included in this release of the RF Performance - LTE Test 
Packs (refer to the user manual for details): 

• Optimizations have been implemented to reduce test time execution by 40%. Test 
Manager includes built-in intelligence to combine and execute similar tests without 
tearing down the LTE attach between tests. 

• Supports the additional E-UTRA operating bands given in the table below. 

E-UTRA 
Operating 
Band 

Uplink (UL) operating band 
BS receive 
UE transmit 

Downlink (DL) operating band 
BS transmit  
UE receive 

Duplex 
Mode 

FUL_low – FUL_high FDL_low – FDL_high 

24 1626.5 MHz – 1660.5 MHz 1525 MHz – 1559 MHz FDD 

25 1850 MHz – 1915 MHz 1930 MHz – 1995 MHz FDD 

26 814 MHz – 849 MHz 859 MHz – 894MHz FDD 

• Supports the E-UTRA channel bandwidths given in the table below. 

E-UTRA Band/Channel Bandwidth  

E-UTRA Band 1.4 MHz 3 MHz 5 MHz 10 MHz 15 MHz 20 MHz 

24 Yes Yes Yes Yes Yes Yes 

25 Yes Yes Yes Yes Yes Yes 

26 Yes Yes Yes Yes Yes Yes 
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• SVLTE test cases have been updated to comply with the Verizon Wireless 
Compliance Test Plan: Conformance and Performance for Simultaneous Circuit 
Switched Voice and Packet Data Capable LTE Multi-Mode Devices, version 4.0, 
issued: June 2011. 

• The following SVLTE test cases as specified in the Verizon Wireless Compliance Test 
Plan: Conformance and Performance for Simultaneous Circuit Switched Voice and 
Packet Data Capable LTE Multi-Mode Devices, version 4.0, issued: June 2011 are 
now supported. 

Test 
Number 

Test Name Test Pack  Additional 
Required 
Instruments 

2.1 LTE Performance in the Presence of a 1xRTT 
Voice Call 

  

2.1.2 LTE RF Output Power Back-off Conformance 
Test 

TP-RF-SVLTE-TP1  
 

Agilent 8960 

• The following test cases as specified in the Verizon Wireless Compliance Test Plan, 
LTE 3GPP Band 13 Supplementary RF Conformance, version 10.0, issued: June 2011 
are now supported. 

Test 
Number 

Test Name Test Pack  Additional 
Required 
Instruments 

2 Transmitter Tests   

2.8 Configured Output Power TP1  

1.2.5. UMTS - LTE Mobility 

There are no new features for UMTS - LTE Mobility Test Packs in this release. 

1.2.6. Stress Test - LTE Suite 

• Base on CS8 Development Library UI. 

• Supports VZW Compliance Test Plan LTE Device - Network Interaction Stress test 
V2.0. 
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1.3. Maintenance Updates 

1.3.1. CDMA - LTE Mobility 

There are no maintenance updates for CDMA - LTE Mobility Test Packs in this release. 

1.3.2. Data Retry - LTE 

The following maintenance updates have been added to the Data Retry - LTE Test Packs: 

• Fix AMF value retrieval defect. 

• Fix attach messages not shown on chart defect. 

1.3.3. Data Throughput - LTE 

The following maintenance updates have been added to the Data Throughput - LTE Test 
Packs: 

• Test Manager Event window results enhancement. 

• Advanced Channel Models enhancement. 

• Advanced Channel Models enhancement. 

• LTE Data Throughput Recovery enhancement. 

• Multiple PDNs Support enhancement. 

1.3.4. RF Performance - LTE 

The following maintenance updates have been added to the RF Performance - LTE Test 
Packs: 

• Failures seen with "VZW Supplementary RF Conformance 2.4 Spurious Emissions 
Band UE Coexistence" and "VZW Supplementary RF Conformance 2.9 Spurious 
Emissions Band UE Coexistence" have been addressed with this release of LTE RF by 
introducing an external filter between the spectrum analyzer and the SR8068 TCU. 
These external filters will be automatically shipped to the existing customers.  

• The occasional throughput failures seen with Receiver Sensitivity and Receiver 
Blocking tests due to incorrect calculation of “FER” due to a timing issue have been 
addressed. 

1.3.5. UMTS - LTE Mobility 

No maintenance updates have been added to the UMTS - LTE Mobility Test Packs. 
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1.4. Known Issues 

The following issues are applicable to all Test Packs on the 8100 Mobile Device Test 
System v4.5.0: 

• There is an issue with removing the test data cards and test phones from Dell 
Latitude E6500/E6510/E6520 Client Laptops connected through the PCMCIA slot or 
USB. If the client laptop model is a Dell Latitude E6500/E6510. Refer to Section 3.1 
for details. 

• There is a potential conflict that can occur if the device installs a Network Interface 
driver. Refer to Section 3.2 for details. 

• Attempting to abort calibration causes Test Manager to freeze. Refer to Section 3.3 
for details. 

• The log file format of the OTA messages has changed; therefore OTA messages 
collected with v4.3.1 cannot be decoded for viewing. 

• Installation of Microsoft Security Essentials enables Microsoft Update. Microsoft 
Update must be disabled. This applies to the Controller PC, Client Laptop, and the 
Applications Server. Refer to Section 0 for details. 

• Errors may be encountered if you do not update every module. If this is occurs, 
uninstall and then reinstall all of the modules. 

• Platform Files created using previous releases are not automatically upgraded 
correctly in this release. Delete all previously created Platform Files and generate 
new Platform Files prior to executing any test cases. Refer to Section 0 for details. 

• Bandwidths 1.4M, 3M, 15M and 20MHz are enabled, but have not been fully tested 
due to UE availability.  

• Band classes 1, 2, 3, 5, 7, 10, 12, 14, 20, 24, 25, 26, and 27 are enabled, but have 
not been fully tested due to UE availability. 

1.4.1. CDMA - LTE Mobility 

The following issues are applicable to the CDMA - LTE Mobility Test Packs: 

• In the IOT test cases that test the LTE/eHRPD handover by using FTP to perform 
transfer verification; if the UE takes more than one minute to finish the handover, the 
existing FTP transfer is terminated. A new FTP transfer is then used to verify FTP 
transmission after the handover. 

• Sometimes an exception occurs when eAA stops call processing. 

1.4.2. Data Retry - LTE 

There are no known issues specifically applicable to the Data Retry - LTE Test Packs. 
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1.4.3. Data Throughput - LTE 

The following issues are applicable to version 1.40 the Data Throughput LTE Test Packs: 

• For FTP over IPv6 at maximum throughput rates greater than 25Mbps, you must use a 
client laptop running Windows 7 and an Application Server running Windows Server 
2008. 

• The Advanced Channel Model test requires the E2010 to be calibrated for 1dB 
tolerance limits. Call Spirent Customer Service for details. 

• If the COM port of the UE is locked, unplug and reconnect the UE. 

• When a system is cabled with SR5500M, we recommend that you use a Dedicated 
Mode platform configuration to achieve maximum RSTP range across all band 
classes. 

• For the MIMO Correlation Matrix Alpha and Beta, only the following combination is 
fully verified: Alpha = 0, Beta = 0.5 and Alpha = 0.3, Beta = 0.5 

• For Verizon Wireless Band 13 Data Throughput Tests 3.1.2.3, Radio link failure is 
observed with QualComm Chipset. 

• For Verizon Wireless Band 13 Data Throughput Tests 
3.4.2.6/3.1.2.6/3.9.2.1/3.9.2.2/3.6.2.1, Data Freeze is observed occasionally with 
the LG Chipset. The test case may not fail because DT recovery algorithm may recover 
it, depending on when the Data Freeze happened (at the beginning or at the middle 
of transfer). 

• For Verizon Wireless Band 13 Data Throughput Tests 3.8.2.1, Throughput 
inconsistency is observed between transfers. 

• For Verizon Wireless Band 13 Data Throughput Test Cases, 1%-5% UL BLER is 
occasionally observed. 

• For Transmission Mode 3, with the variable reference channel feature, Code Word 2 
uses the default Imcs configured in test case parameters. The reported CQI from the 
UE is not used to decide the Imcs for CW2. 

1.4.4. RF Performance - LTE 

The following issues are applicable to the RF Performance – LTE Test Packs: 

• Microsoft Windows 7 is not supported on the Controller PC. 

• LTE RF test cases will not run properly if the UE is permitted to acquire an IP address 
when it is connected to the Controller PC for UE automation. In this case, the Internet 
Protocol feature of the UE network interface must be disabled. Refer to Section 3.6 
on page 48 for details. 
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1.4.5. UMTS - LTE Mobility 

The following issues are applicable to the UMTS – LTE Mobility Test Packs: 

• IOT was performed with the only device available (Sierra Wireless U313 data card). 
Interoperability with other devices is not known. 

• A new component from the Global Installer DVD (UE AT Interface for CS8) must be 
installed when upgrading the UMTS - LTE Mobility module to this release. You can 
select this component for installation under the Instruments tab, as shown in Figure 
1-1. 

 
Figure 1-1: Global Installer – Instruments Tab 

• Note that the Global Installer software may not correctly detect that the UE AT 
Interface for CS8 SW is installed. This is due to a naming convention mismatch.  
If you encounter this issue, use the Windows Control Panel to confirm that the correct 
software applications are installed. 

1.4.6. Stress Test - LTE Suite 

The following issues are applicable to the Stress Test - LTE Suite: 

• Sometimes an exception occurs when test case configures AA C2K parameters.  

• Sometimes an exception occurs when test case configures SR5500 parameters. 



2. System Upgrade Instructions 

2.1. Overview 

The following sections contain the steps necessary to install the LTE Test Packs and the 
necessary supporting software components on an existing system. 

NOTE: LTE Performance – LTE Module users should not install 8100 LTE Radio 
Access v4.50. Doing so will result in a incompatibility between the existing RF 
Performance – LTE Module v1.5.370 installation and the newer CS8 Interactive 
Tester (formerly known as eAirAccess) v1.50.022.  
The RF Performance – LTE Module and CS8 Interactive Tester compatibility issue will 
be resolved in a subsequent v4.51 8100 LTE Radio Access release. This release is 
scheduled for mid-July. 

These steps include: 

• Downloading and unzipping the Software Update Package from the Customer 
Support website. 

• Using the Global Installer application. 

• Updating the Controller PC. 

• Updating the Client Laptop. 

• Updating the Application Server. 

• Updating the EPC Server. 

• Updating the E2010S. 

• Updating the Cisco 1811/2600 Router Configuration. 

• Updating the Dell 6248 Switch Configuration. 

• Updating the Agilent ESG. 

• Updating the Agilent EXA/MXA Spectrum Analyzer. 

• Installing new System Cables. 

2.2. Downloading/Unzipping the Software Update 

To download/unzip the software update: 

1. Log in to the Spirent Customer Service Center website at http://support.spirent.com 
using the e-mail address and password assigned to you by Spirent. 

2. Select Download Software Updates>Wireless>8100 Radio Access – LTE Testing 
(Version 4.4.0)>Download to download the latest release. 
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3. Locate the downloaded file in Windows Explorer. 

4. Right-click the file and select Extract All from the menu, as shown in Figure 2-1. 

 
Figure 2-1: Extract All Files 

5. Use the Extraction Wizard to extract the files to a known location, as shown in Figure 
2-2.  

NOTE: We recommend that you extract the zipped package files to a portable USB 
device. These files are needed to update multiple computers on the system. 
 
The location of these files will be referred to as <8100 – LTE 4.4.0 Installer Root> 
throughout the remainder of this document. 

 
Figure 2-2: Using the Extraction Wizard 
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2.3. Using the Global Installer Application 

This section provides information on how to use the Global Installer. This application 
allows you to update different computers in the system using a convenient user-
interface. 

To run the Global Installer application: 

1. Navigate to the <8100 – LTE 4.4.0 Installer Root> folder. 

2. Run the setup.exe file. 
The 8100 Mobile Device Test System Installer window displays, as shown in Figure 
2-3. 

NOTE: The version numbers shown in following Global Installer figures may not 
reflect the current software version numbers.  
For the correct version numbers, refer to the table on page 1. 

 
Figure 2-3: 8100 Mobile Device Test System Installer Window 

The Global Installer application organizes the software components into separate tabs, 
shown in Figure 2-3. The icon next to each component indicates which components have 
been detected as installed on the system.  
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The following list describes the different icons used in the Global Installer: 

 The software is not installed. 

 A different version of the software is already installed. 

 The software is selected for install (also displays on the Install List). 

 The correct version of the software is already installed. 

To install software components using the Global Installer application: 

1. To mark a software component for installation, select the component.  
The icon changes to a green checkmark and the component is added to the Install 
List. 

2. Add additional components as necessary.  
You can add components from different tabs prior to starting the installation. 

NOTE: In some cases, the order of installation is important. Follow the instructions 
in the sections below regarding installation order. 

3. Click the Installation toolbar button  to begin the installation. The progress of the 
install displays on the left pane. When complete, a Summary window displays. 
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2.4. Upgrading the Controller PC 

Connect the device containing the unzipped installer to the Controller PC. 

2.4.1. Preparing For The Update 

1. Ensure that the following applications are not running: 

a. Test Stand Sequence Editor 

b. eAirAccess 

c. AirAccess C2K 

d. AirAccess WCDMA-HS 

e. Intrig IDM 

f. Universal DM V2 

g.  Spirent Data Client 

2. Save the existing security passwords. 

a. Start Test Manager and select Help>About>Passwords.  

b. Click the Export button and use the file browser to export the passwords to 
passwords.csv. 

c. Close Test Manager. 

2.4.2. Updating Intrig Data Monitor 

1. Uninstall any previous versions of IDM by selecting Start> Add or Remove Programs. 

2. Navigate to the <8100 – LTE 4.4.0 Installer Root>\eAirAccess\Controller PC\IDM 
folder. 

3. Execute idm-x.x.x.exe and accept the defaults. 

4. Modify the registry entries after IDM is installed: 

a. Select Start>Run. Type regedit and press Enter.  
Windows 7 Users: Type regedit in the Search field and press Enter. 

b. If the User Account Control window displays, click Yes to proceed. 

c. Expand HKEY_LOCAL_MACHINE\SOFTWARE\Intrig. Right-click the IDM folder 
and select Permissions. 

d. Select the Users account and under Permissions, select Allow for the Full Control 
option, as shown in Figure 2-4. 
Click Apply and then OK. 
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Figure 2-4: IDM Permissions Window 

2.4.3. Updating Components - Global Installer 

For details on how to use the Global Installer application, refer to Section 2.3. 

To update components in the Global Installer: 

1. If the correct version of Test Manager is not installed, select the Test Manager 
component. 

2. Click the Installation toolbar button  to begin the installation. 

3. Navigate through all the tabs from left to right and select any components that are 
indicated to be out of date or missing.  

NOTE: There are now two versions of the E2010S Driver. Select both for installation. 

4. Click the Installation toolbar button  to begin all installations. 

5. Restart the Controller PC. 

2.4.4. Installing Logging Framework 

1. Uninstall any previous versions of Logging Framework components. 

a. Stop the Logging Framework by selecting Start>All Programs>AT4 
Wireless>Logging Framework Runtime>Stop Logging Framework. 

b. An Information window displays verifying that Logging Framework has been 
stopped, as shown in Figure 2-5. 
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Figure 2-5: Logging Framework Information Window 

c. From the Control Panel, select Add or Remove Programs and remove the 
following components: 

i. AT4 Wireless Logging Generator COM Interface 

ii. AT4 Wireless Dissectors 

d. Uninstall LogAgent by selecting Start>All Programs>AT4 Wireless>Logging 
Agent>Uninstall. 

2. Install the Logging Framework: 

a. Navigate to the <8100 – LTE 4.4.0 Installer Root>\eAirAccess\Controller 
PC\Logging Framework folder. 

b. Execute Logging Framework Runtime Setup.exe and accept the defaults. 

c. Execute AT4 Wireless Dissectors Setup.exe file and accept the defaults. 
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2.4.5. Completing Test Manager Configuration 

2.4.5.1 Updating Test Manager Passwords and User Files 

1. Start Test Manager and select Help>About>Passwords.  

2. Select and open the passwords.csv file exported in Section 2.4.1 on page 13. 

NOTE: Contact your local Spirent Sales Manager if new or additional passwords are 
required for the updated features. 

3. Delete all older platform files.  
In Test Manager, select File>Open>Platform File. 

4. Create a new platform file. 
In Test Manager, select File>New>Platform File. Refer to Section 0 for details on 
creating Platform Files. 

5. Update all UE Files from previous versions. 
In Test Manager, select File>Open>UE File and save the old UE Files again. 

6. Update all Session Files from previous versions. 
In Test Manager, select File>Open>Session File and save the old Session Files again. 

7. Run a System Calibration for the B-Series platform and/or the B-100 platform. 

8. Close Test Manager. 

2.4.6. Completing CS8 Interactive Tester Configuration 

1. Launch CS8 Interactive Tester by double-clicking the desktop icon. 

2. Select Help>Enter Password. 
The Password window displays, as shown in Figure 2-6. 

3. Enter the appropriate password and click OK. 
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Figure 2-6: Entering the CS8 Interactive Tester Password 

4. Close the CS8 Interactive Tester. 

2.4.7. Completing AirAccess C2K Installation 

NOTE: Follow these instructions only if C2K instruments are included in your 
system. 

1. Launch AirAccess C2K by double-clicking the desktop icon. 

2. Select Help>Enter Application Password. The Application Password window 
displays, as shown in Figure 2-7. 

3. Enter the appropriate password and click OK. 

 
Figure 2-7: Entering the AirAccess C2K Password 

4. Select File>Install Instrument Firmware. 
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5. The SR3452, SR3462, and SR3600 Instrument windows display, as shown in the 
following figures. 

 
Figure 2-8: SR3452 Instrument Window 

 
Figure 2-9: SR3462 Instrument Window 

 
Figure 2-10: SR3600 Instrument Window 
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6. Wait for the installation to complete.  
A window may display prompting you to turn the instrument off and power it on 
again. Follow the instructions to restart the instrument and close the window. 

7. Close AirAccess C2K. 

2.4.8. Installing Microsoft VC++ 2010 Runtime Libraries 

1. Insert the 8100 Utilities DVD in the DVD-ROM drive. 

2. On the desktop, select My Computer and double-click the DVD-ROM icon. 

3. Navigate to the Microsoft Visual C++ 2010 Redistributable Package folder. Run the 
vcredist_x86.exe file to initiate the install. 

4. In the License Term Agreement window, select I have read and accept the license 
and click Install. 

5. In the Installation is Complete window, click Finish. 

2.4.9. Installing .NET Framework 3.5 SP1 and .NET Framework 4.0  

1. If .NET 3.5 SP1 Framework is already installed, you can omit steps 2-5and go directly 
to step 6. 

2. Insert the 8100 Utilities DVD in the DVD-ROM drive. 

3. On the desktop, select My Computer and double-click on the DVD-ROM icon. 

4. Navigate to the Microsoft .NET Framework\3.5 folder. Run the dotnetfx35.exe file to 
initiate the install. 

5. In the Installation is Complete window, click Finish. 

6. If .NET 4.0 Framework is already installed, you can omit steps 7-10. 

7. Insert the 8100 Utilities DVD in the DVD-ROM drive. 

8. On the desktop, select My Computer and double-click on the DVD-ROM icon. 

9. Navigate to the Microsoft .NET Framework\4.0 folder. Run the 
dotNetFx40_Full_x86_x64.exe file to initiate the install. 

10. In the Installation is Complete window, click Finish. 

2.5. Upgrading the Client Laptop 

Connect the device containing the unzipped installer to the Client Laptop. 
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2.5.1. Updating Spirent AT Control 

To update Spirent AT Control: 

1. Select Start>Control Panel>Add/Remove Programs. 

2. Uninstall the Spirent AT Control application. 

3. Navigate to the <8100 – LTE 4.4.0 Installer Root>\eAirAccess\Controller PC\Spirent AT 
Control folder. 

4. Execute setup.exe and accept the defaults. 

2.5.2. Updating Spirent Data Client 

For details on how to use the Global Installer application, refer to Section 2.3 on page 
11. 

To update Spirent Data Client: 

1. Start the Global Installer application. 

2. If the correct version of Spirent Data Client is not installed, select the Spirent Data 
Client component. 

3. Click the Installation toolbar button  to begin the installation. 

4. Restart the Client Laptop. 

2.6. Upgrading the Application Server 

To update the Application Server: 

1. Connect the device containing the unzipped installer to the Application Server. 

2. From the Controller PC, use Remote Desktop to login to the Application Server at 
192.168.0.70. 

2.6.1. Updating Spirent Data Client 

For details on how to use the Global Installer application, refer to Section 2.3 on page 
11. 

1. Start the Global Installer application. 

2. If the correct version of Spirent Data Client is not installed, select the Spirent Data 
Client component. 

3. Click the Installation toolbar button  to begin the installation. 
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4. Exit the Global Installer application. 

2.6.2. Updating Xlight IPv6 FTP Server Configuration 

1. Double click the Xlight FTP Server icon from the desktop as shown in Figure 2-11. 

 
Figure 2-11: Xlight IPv6 FTP Icon 

2. The Duplicated Process window shown in Figure 2-12 displays. Click Yes to proceed. 

 
Figure 2-12: Duplicated Process Warning Window 

3. Select the fd00:0:20:1::4 IPv6 server and click the Modify Virtual Server 
Configuration button, as shown in Figure 2-13. 

 
Figure 2-13: Modify Virtual Server Configuration Button 

4. Under the General tab, change the "Maximum idle time" parameter to 120 and select 
the Enable the anti-idle scheme option, as shown in Figure 2-14. 
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Figure 2-14: Enable Anti-idle Scheme Option 

5. Click OK to close all Xlight windows. 
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2.7. Updating the EPC Server 

NOTE: If the steps in Section 2.4.7 have been completed, you can skip this section. 

1. From the Controller PC, navigate to C:\Program Files\Spirent 
Communications\SR3600\x.x.x, as shown in Figure 2-15.  
If there is more than one folder, open the most recent. 

 
Figure 2-15: SR3600 Folder 

2. Execute the SR3600.exe file.  

3. In the Upgrade window, select Instrument>Install Firmware Update as shown in 
Figure 2-16. 

 
Figure 2-16: Opening the Firmware Update 
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4. In the Open window, navigate to  
C:\Program Files\Spirent Communications\eAirAccess. 

5. Select the .tsu file and click the Open button, as shown in Figure 2-17. 

NOTE: The version number reflected in the filename shown in Figure 2-17 may not 
reflect the current software version number.  
For the correct version number, refer to the table on page 1. 

 
Figure 2-17: Opening the .tsu File 

6. Wait for the update to complete (this will take several minutes), as shown in Figure 
2-18. 

 
Figure 2-18: Update Status 

7. Close the SR3600 tool. 

  



8100 Mobile Device Test System – LTE: Product Update | 25 

 

2.8. Updating the E2010S 

NOTE: This procedure needs to be performed if you are upgrading from the 8100 
v4.4 release. 

2.8.1. Uninstalling Previous E2010S Software 

1. Uninstalling the Spirent E2010 Manager: 

a. Open Windows Task Manager by right-clicking the clock in the lower right corner 
of the Windows System Tray and selecting Task Manager from the menu. 

b. Under the Process tab run the E2010Manager.exe file and click the End Process 
button. 

c. Close Windows Task Manager. 

d. Open the Windows Control Panel. Uninstall E2010 Manager. 

e. Close the Windows Control Panel. 

2. Uninstalling the Logging Framework: 

a. Select Start>Programs>AT4 Wireless>Logging Framework Runtime>Stop 
Logging Framework.  

b. Select Start>Programs>AT4 Wireless>Logging Framework Runtime>Uninstall. 

c. Wait for the software to be uninstalled. This should also uninstall the Logging 
Framework COM Driver. 

3. Uninstalling the Layer 3 Components: 

a. Open Windows Control Panel. Uninstall L3 Components Installer.  

b. Close the Windows Task Manager. 

2.8.2. Updating the MCH Firmware 

1. Insert the USB device where the unzipped install package is stored on the E2010S. 
Navigate to the <8100 – LTE 4.5.0 Installer Root> folder and copy the CS8 Interactive 
Tester folder to the E2010S Desktop. Remove the USB device from the E2010S. 

2. Navigate to the CS8 Interactive Tester folder. In the CS8 Interactive Tester\E2010 
Embedded PC\MCH\bin folder, select all four files and copy them to the 
C:\TFTPExchange folder on the E2010. 

3. In the <CS8 Interactive Tester>\E2010 Embedded PC\MCH\ folder, copy the Updater 
folder to the E2010 Desktop. 

4. Run the SolarWinds TFTP Server by selecting Start>All Programs>SolarWinds TFTP 
Server>TFTP Server. 
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Figure 2-19: SolarWinds TFTP Server Window 

5. From the TFTP Server menu, select File>Configure. 

 
Figure 2-20: Configuration Window 

6. Under the General tab, click the Browse button. 
The Browse for Folder window displays, as shown in Figure 2-21. 

 
Figure 2-21: General Tab — Browse for Folder 

7. Select the TFTPExchange folder and click the OK button. 
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Figure 2-22: TFTPExchange Folder 

8. Verify that the TFTP Server Root Directory is now set to C:\TFTPExchanges, as shown 
in Figure 2-22. 

9. Under the Status section, click the Start button. 

10. Verify that the TFTP Server starts successfully, as shown in Figure 2-23. 

 
Figure 2-23: TFTP Server Status 

11. Open the Command Prompt by selecting Start>Run, and typing cmd. 

12. At the Command Prompt, type cd "C:\Documents and 
Settings\superuser\Desktop\Updater" and press Enter.  
Be sure to type the quotations. 

13. Now type updateMchFw -f mch_fw211.bin and press Enter.  
Wait a few minutes for the script to run and return to the prompt.  
The Command Prompt window and SolarWinds Server Output window should display 
as shown in Figure 2-24 and Figure 2-25. 
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Figure 2-24: Command Prompt Window 

 
Figure 2-25: SolarWinds TFTP Server Window 

14. Telnet to the MCH by double-clicking the Putty icon on the desktop.  
The PuTTY Configuration window displays, as shown in Figure 2-26.  

15. Select MCH Telnet and click the Load button.  
Click the Open button to open the MCH Telnet prompt. 

 
Figure 2-26: PuTTY Configuration Window 
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16. You should see the nat> prompt in the MCH Telnet window, as shown in Figure 2-27.  
Type diag under the nat> prompt. Under the DIAG (RET=0/0x0): prompt, type 7 and 
press Enter. 

 
Figure 2-27: MCH Telnet Window – nat> Prompt 

17. At the SRIO (RET=0/0x0): prompt, type 12 then press Enter.  
At the Enter Switch Number (RET=0/0x0): prompt, type 0 then press Enter.  
At the [IP:FILENAME]: prompt, type 10.168.0.1:srio0_v10_pe.bin, then press Enter. 
You should see "srio_write_prom: programming 112 bytes ..... - done", as shown in 
Figure 2-28. 

 
Figure 2-28: MCH Telnet Window - [IP:FILENAME] Prompt 

18. Under the SRIO (RET=0/0x0): prompt, type 12 then press Enter. At the Enter Switch 
Number (RET=0/0x0): prompt, type 1 then press Enter. At the [IP:FILENAME]: prompt, 
type 10.168.0.1:srio1_v10_pe.bin, then press Enter. You should see 
"srio_write_prom: programming 208 bytes ... - done", as shown in Figure 2-29. 
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Figure 2-29: MCH Telnet Window 

19. At the SRIO (RET=0/0x0): prompt, type q. At the DIAG (RET=0/0x0): prompt, type q, 
as shown in Figure 2-30. 

 
Figure 2-30: MCH Telnet Window - DIAG (RET=0/0x0): Prompt 

20. The TFTP Server window should display all of the transfers, as in the window below. 

 
Figure 2-31: TFTP Server Window - Transfers 

21. Select File>Configure from the TFTP Server menu. Click the Stop button. 



8100 Mobile Device Test System – LTE: Product Update | 31 

 

 
Figure 2-32: SolarWinds TFTP Server Window 

22. Verify that the server has been stopped, as shown in Figure 2-33. 

 
Figure 2-33: Verifying the Server is Stopped 

23. Delete the Update folder from the Desktop. 

2.8.3. RACK.ini File Copy 

In the <CS8 Interactive Tester>\E2010 Embedded PC\RACK folder, copy the RACK.ini file 
to the C:\AT4Wireless\E2010\HWSet\ folder on the E2010. 
If the unit is single cell, copy the RACK.ini file from the SingleCell subfolder. If the unit is 
dual cell, copy the RACK.ini file from the DualCell subfolder. 

2.8.4. Installing AT4 E2010 Manager Software 

1. In the <CS8 Interactive Tester>\ E2010 Embedded PC\AT4 E2010 Manager folder, run 
the E2010 Manager Setup.exe file to install the software. 
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2. For each installer window, select the default values and click Next until the 
installation is complete. 

3. On the Completing the E2010 Manager Setup Wizard window, select the Start E2010 
Manager Service & E2010 Control Panel option, and click Finish, as shown in 
Figure 2-34. 

 
Figure 2-34: E2010 Manager Setup Wizard Window 

4. When complete, the E2010 Control Panel displays, as shown in Figure 2-35. 

 
Figure 2-35: E2010 Control Panel Window 

2.8.5. Installing E2010 Software 

1. From the E2010 Control Panel, click the Versions button.  
The Installed Versions window displays, as shown in Figure 2-36. 
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Figure 2-36: Installed Versions Window 

2. Click the Download button. Navigate to the <CS8 Interactive Tester>\E2010 
Embedded PC\LTE E2010 Core folder. Select the LTE E2010 Software Package 
v3.0.5.2.exe file and click Open, as shown in Figure 2-37. 

 
Figure 2-37: E2010 Software File 

3. In the Installed Versions window, select 3.0.5.2 and click the Activate button, as 
shown in Figure 2-38. 

 
Figure 2-38: Installed Versions Window - 3.0.5.2 
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4. The E2010 Control Panel window displays.  
The status of the activation displays at the bottom of the window, as shown in Figure 
2-39. This process will take between 10 and 15 minutes. 

 
Figure 2-39: E2010 Control Panel Window 

5. When the process is complete, the following windows may display. Click OK to 
continue. 

 
Figure 2-40: Error Window - Calibration Data 

 
Figure 2-41: Error Window - CalAgentLauncher Icon 

6. In the Command window, verify that it matches with the highlighted areas in Figure 
2-42. Note that for a single cell unit, you will not see the FPGA message for Cell B. 



8100 Mobile Device Test System – LTE: Product Update | 35 

 

 
Figure 2-42: Command Prompt Window 

7. If the calibration update failed, the window in Figure 2-43 may display. If the 
message from Figure 2-42 matched, disregard this error. Otherwise, repeat the 
activation process. 

 
Figure 2-43: Failed Calibration Update 

8. If there was an error generating the calibration data, regenerate the data by right-
clicking the Ladybug icon in the System Tray and select Generate from the menu. 
This may take a few minutes. When the generation process is complete, the Ladybug 
looking icon should be green. If it is blue, wait a bit longer, as the process is still 
running. If it is orange or red, generate the data again. You may need to do this a few 
times before you get a green result. 

 
Figure 2-44: Regenerating Calibration Data 

9. Power-down the E2010 and power it up again. When the E2010 boots, the E2010 
Control Panel should automatically display. Verify that it matches the highlighted 
items in Figure 2-45. Allow a few minutes for all the components to boot up. Note 
that Single Cell units have only one HWSetA. 
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Figure 2-45: E2010 Control Panel - Hardware Sets 

2.8.6. Installing the Logging Framework 

1. In the <CS8 Interactive Tester>\E2010 Embedded PC\Logging Framework folder, run 
the Logging Framework Runtime Setup EmbeddedPC1.exe file to install the 
Logging Framework Runtime. Note: If this is the second E2010 in a two E2010 unit 
setup, run the Logging Framework Runtime Setup EmbeddedPC2.exe file instead. 

2. In the Welcome to the Logging Framework Runtime Setup Wizard window, click Next. 

3. In the License Agreement window, select the I accept the terms option and click 
Next. 

4. In the Choose Components window, make sure all components are selected and 
click Install. 

5. In Completing the Logging Runtime Setup Wizard window, click Finish. 

6. If this is a single E2010 system, or the first E2010 in a multi-E2010 system, run the 
NetCfg_Master.reg file located in the 
C:\AT4Wireless\LoggingFramework\E2010_LOG_FMW_RTE\Misc\scripts folder. If this 
is the second E2010 in a multi-E2010 system, run the NetCfg_Slave.reg file located 
in the same folder. 

2.8.7. Installing the Dissectors 

1. In the <CS8 Interactive Tester>\E2010 Embedded PC\Logging Framework folder, run 
the AT4 wireless Dissectors Setup.exe file to install the AT4 dissectors. 

2. In the Welcome to the AT4 Wireless Dissectors Setup Wizard window, click Next. 
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3. In the License Agreement window, select the I accept the terms option and click 
Next. 

4. In the Choose Components window, make sure all components are selected and 
click Install. 

5. In the Completing the AT4 Wireless Dissectors window, click Finish. 

2.8.8. Installing Layer 3 Software 

In the <CS8 Interactive Tester>\E2010 Embedded PC\Layer 3 Components folder, run the 
setup.exe installation file. The installation starts automatically. Accept all default 
options. 

2.8.9. Installing E2010Manager Software 

1. In the <CS8 Interactive Tester>\E2010 Embedded PC\E2010Manager folder, run the 
Setup.exe installation file. The installation starts automatically. When you are 
prompted to select a install destination folder, make sure to use the default path: 
C:\Program Files\Spirent Communications\E2010Manager. 

2. After installing the E2010Manager, press the power button on the front of E2010S to 
perform a hard reboot. 

3. When the box reboots, E2010Manager should run automatically. Verify that it is 
running using Task Manager. If the software is not running, start E2010Manager 
manually by selecting C:\Program Files\Spirent Communications\E2010 
Manager\E2010Manager.exe. 

2.8.10. Configuring the E2010 IP Address 

1. Select Control Panel>Network Connections. Right-click Local Area Connection 2 and 
select Properties from the menu. 

2. Under the General tab, select Internet Protocol (TCP/IP) and click the Properties 
button, as shown in Figure 2-46. 
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Figure 2-46: Local Area Connection 2 Properties Window 

3. Configure the IP Address settings as shown in Figure 2-47. Note that if this is the 
second E2010 unit in a two E2010 configuration, you must set the IP address to 
192.168.0.190 instead. 

 
Figure 2-47: IP Address Settings 

4. Click the Advanced button. In the Advanced TCP/IP Settings window, click the Add 
button, as shown in Figure 2-48. 
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Figure 2-48: Advanced TCP/IP Settings Window 

5. In the TCP/IP Address window, enter 192.168.0.183 for the IP address and 
255.255.255.0 for the Subnet mask as shown in Figure 2-49. Note that if this is the 
second E2010 unit in a two E2010 configuration, you must set the IP address to 
192.168.0.193 instead. 

 
Figure 2-49: TCP/IP Address Window 

6. Click OK to close the Advanced TCP/IP Settings window. 

7. Click OK to save the Internet Protocol Properties settings. 

8. Click OK to save the Local Area Connection 2 Properties settings. 

2.8.11. Editing UdpServerLoggingConfig.xml 

1. Under My Computer, navigate to: 
C:\AT4Wireless\LTE_E2010\SW_LTE_E2010_3_0_5_2\xWinArea\Tools\UdpServ
er\, as shown in Figure 2-50.  
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Figure 2-50: UdpServer Folder 

2. Right-click the UdpServerLoggingConfig.xml file and select Edit with Notepad ++ 
from the menu. 

3. In the Notepad window, under the line marked <pcIpAddress>, enter 192.168.0.35 
for the IP address, as shown in Figure 2-51. 

 
Figure 2-51: Notepad – Editing the IP Address 

4. Save the document by selecting File>Save. 

5. Close Notepad and Windows Explorer. 
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2.8.12. Ethernet Cable for Dual Cell E2010S 

A new Ethernet cable is required to support L1 logging for the second cell of the E2010S. 

Connect the supplied Ethernet cable from the AUX 2 port of the E2010S to port 35x of the 
Dell 6248 switch. Refer to the B200 Setup Guide for connection guidelines. 

2.8.13. Trigger Cable for Dual Cell E2010S 

A new trigger cable is required on systems containing the dual cell E2010S. 

Connect the supplied BNC trigger cable from the E2010S Cell A TRIG 2 port to Cell B TRIG 
2 port. Refer to the B200 Setup Guide for connection guidelines.



3. Known Issues - Details 

3.1. Dell Latitude E6500/E6510/E6520 Client Laptop Issue 

NOTE: If you have any other Client Laptop model, you can skip this chapter. 

There is an issue with removing the test data cards and test phones from Dell Latitude 
E6500/E6510/E6520 Client Laptops connected via the PCMCIA slot or USB. The issue 
prevents the device from being used (after removed) until the client laptop is rebooted. 

To avoid having to reboot the Client Laptop after removing a test device:  

1. Before removing a device plugged into the PCMCIA slot or connected via the USB 
port, stop the device properly by selecting the Safely Remove Hardware icon from 
the System Tray, as shown in Figure 3-1. 

 
Figure 3-1: Safely Remove Hardware Icon 

2. Select the desired test device to safely remove it from the Client Laptop. 

3.2. UE Drivers that Install a Network Interface 

There is a potential conflict during data call setup, when both the Network Interface and 
Dial-Up Modem are enabled on the client laptop.  

To avoid this conflict, we recommend that you disable the Network Interface if the 
TestDrive Data Connection (Dial-Up Modem) is the targeted interface for the session, as 
shown in the Figures below. If the Network Interface is not disabled, data call setups 
could fail with a RasDial exception. 
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Figure 3-2: Network Connections Window – Disabling the Network Interface 

 
Figure 3-3: Network Connections Window – Successfully Disabled Network Interface  

3.3. Unable to Abort Calibration 

In the Calibration Wizard, clicking the Abort button freezes TestManager in a non-
working state. You must re-launch TestManager to continue. 
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3.4. Disabling Microsoft Update 

After installing Microsoft Security Essentials, Microsoft Update is enabled by default. 
Microsoft Update must be disabled on 8100 systems.  

3.4.1. Windows XP and Windows Server 2003 

Perform the following steps on each of the following PCs included in your system: 

• Windows XP Controller PC 

• Windows XP Client Laptop 

• Windows Server 2003 Applications Server 

To disable Microsoft Update: 

1. Select Start>Control Panel>Performance and Maintenance>System.  
The System Properties window displays. 

2. Under the Automatic Updates tab, select the Turn off Automatic Updates option, as 
shown in Figure 3-4. 

 
Figure 3-4: System Properties Window – Automatic Updates Tab 

3. Click OK to save the changes and exit the window. 
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3.4.2. Windows 7 

Perform the following steps on each of the following PCs included in your system: 

• Windows 7 Controller PC 

• Windows 7 Client Laptop 

1. Select Start>Control Panel>System and Security>Windows Update>Change 
Settings. The Windows Update – Change Settings window displays. 

2. Under the Important Updates section, select Never check for updates, as shown in 
Figure 3-5. 

 
Figure 3-5: Windows Update – Change Settings 

3. Click OK to save the changes and exit the window. 

4. If a “Windows update is turned off. Click to turn on.” message displays on the 
desktop, ignore it.  
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3.4.3. Windows Server 2008 

If you are running Windows Server 2008 on the Applications Server, perform the 
following steps. 

1. Select Start>Control Panel>System and Maintenance>Windows Update>Change 
Settings.  
The Change Settings window displays. 

2. Under the Important Updates section, select Never check for updates, as shown in 
Figure 3-6. 

 
Figure 3-6: Windows Update – Change Settings 

3. Click OK to save the changes and exit the window. 

4. If a “Windows update is turned off. Click to turn on.” message displays on the 
desktop, ignore it. 
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3.5. Creating a New Platform File 

Platform Files created using previous releases do not automatically upgrade correctly 
with this release. Follow the instructions below to create a new Platform File for your test 
system.  

1. In Test Manager, select File>New>Platform File as shown in Figure 3-7. 
The B-Series Platform file opens. 

 
Figure 3-7: Platform File Menu Item 

2. Under Available Instruments, enable all configured instruments. 

3. Under Network Configuration, configure the available network options for the 
specific module to be tested. 

4. Under PDN Gateway, enter FD00:0:20:1:0:0:1:3 for the IPv6 address, as shown in 
Figure 3-8. 

5. Under SR8078 Test Configuration Unit, select the LTE Mode Configuration file 
applicable to the test theme. 

 
Figure 3-8: Setting Platform File Parameters 

6. If you are running the LTE RF Performance Module, select the B100 tab in the new 
Platform File. 
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7. Configure the SR8048 Test Configuration options for the system, as shown in Figure 
3-9. 

 
Figure 3-9: SR8048 Test Configuration Options 

8. If you are running C2K SVLTE, configure the Agilent 8960 options in the Platform File. 

9. When all options have been configured, save the Platform File by selecting File>Save 
in Test Manager. 

10. When executing the tests, ensure that all test cases reference the Platform File you 
have just created.  

3.6. Disabling Internet Protocol on the UE Network Connection 

When running the LTE RF test cases, the UE is connected to the Controller PC for 
automation control. LTE UEs often establish an IP address automatically when connected 
to the USB port on the PC.  

This can cause stability issues while running LTE RF test cases. To prevent this from 
occurring, perform the following steps to disable internet protocol on the UE network 
connection. 

1. From the Control Panel, select Network Connections and locate the UE Local Area 
Connection, as shown in Figure 3-10.  

 
Figure 3-10: Network Connections Window 
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2. Right-click Local Area Connection and select Properties from the menu.  
The Local Area Connection Properties window displays, as shown in Figure 3-11. 

3. Deselect the Internet Protocol (TCP/IP) option, as shown in Figure 3-11. 

 
Figure 3-11: Local Area Connection Properties Window 

NOTE: The Spirent Controller PC is shipped with two IP addresses: 192.168.0.35 
and 192.168.0.5. We strongly recommend that you do not add any other IP 
addresses, especially on a different subnet. 
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