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1 Introducing Review 

1.1 Starting Review 

Start Review by selecting Start>Programs>AVEVA>VANTAGE Plant Design 
Review 6.2>   

Exercise:  

Start Review now. You should see the main VANTAGE Plant Design Review 
window. The remainder of this chapter assumes that you have this screen 
display in front of you as you read. 

 

1.2 The Main Review Window 

The Review window and a typical selection of its different panels are 
illustrated overleaf. 

The view manipulation panels are described in Chapter 3. 
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The Menu Bar and Toolbar – see section 1.3 

The Observer View – 
see Chapter 5. 

The Explorer – see 
section 2.2 

The 
Camera 
Control 
panel – see 
section   
4.1. 

The Visual 
Properties 
panel – see 
section   4.3
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1.3 The Menu Bar and the Toolbars 

All of Review’s functions can be accessed from the menu bar: 

 

Each of the menu bar options will be explained in detail later in this 
User Guide. 

Note:  the exact content of the Edit and Tools pull-down menus will vary 
according to which of the Observer View (see Chapter 5) or 
other Camera Views (see Chapter 6) is active. 

You will begin access to many of Review’s functions by clicking on one of 
the buttons in the Standard Toolbar: 

 

The way in which the view manipulation features of Review work is 
controlled from the Navigation Toolbar: 

 

The function of each of the buttons on the two toolbars is explained in 
detail later in this User Guide, but in summary: 

1.3.1 The Standard Toolbar 

 Open Loads a Review model file into Review. Other 
Review file types can also be loaded, see Chapter 2. 

 Save Saves a Review settings file. See Chapter 14. 

 Explorer 
Brings up the Explorer form, which provides a 
hierarchical view of the PDMS elements imported in 
the model file. See section 2.2 

 Search Enables you to search for elements within the model 
files currently loaded into Review – see section 4.4. 

 Camera Definition 
Allows you to define the view by entering explicit 
positions and directions or by manipulating the line 
of sight interactively. See section 4.1 for details. 

 Keyplan View Allows you to define the view by manipulating small-
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scale plan and elevation views of the model. See 
Chapter 6 for details. 

 Material Definition 

Allows you to assign a material to each displayed 
element, and give the material properties such as 
shininess, smoothness and texture. See Chapter 8  
for details. 

 Lighting 

Allows you to control the lighting applied to the 
view by specifying the positions, colours and 
intensities of the light sources. See Chapter 10 for 
details. 

 Groups 
Allows you to link displayed elements together into 
groups, so that you can manipulate them 
collectively. See Chapter 12 for details. 

 Path Editing 
Allows you to define and an animation path, An 
animation can then be played along the path – see 
section 4.5. 

 Animation Allows you to define an animation by setting up a 
progressive sequence of views. 

 Visual Properties Allows you to view or change the material properties 
of a selected element – see section 4.3. 

 Applications 

Brings up the Review Applications form, enabling you 
to type in command syntax or perform queries. If 
your system has been customised by the addition of 
company-specific Review applications, this button 
gives you access to the menus and forms designed to 
control those applications. For details of how to 
proceed, refer to any relevant documentation 
produced when such applications were written. 

 
Advanced Picking 

Mode 

Allows multiple selections to be made in the 
Observer View (with Ctrl held down). See section 11.1 
for details, 

1.3.2 The Navigation Toolbar 

 
Walkthrough 

Mode 

Rotate and Pan operations take place relative 
to the observer as he ‘walks around the 
model’. See section 5.1.2 for details. 

 
Fixed Focus 

Mode 
Rotate operations take place about a fixed 
focal point. See section 5.1.6 for details. 
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Flythrough 

Mode 
Allows the user to fly around the model. See 
section 5.1 for details. 

 Classic Mode 
Rotate, Pan and Zoom operations operate as 
in Review version 6.1 and version 5.3. See 
Appendix A for details. 

 Slider Controls the speed of walk and zoom 
operations. 
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2 Importing a Model File for Viewing 

Review data is generated from a PDMS database and is called a model 
file. The model file contains: 

• The design model geometry; that is, the dimensions and locations of all 
primitives which make up the design. 

• The logical design hierarchy; that is, the family tree showing the 
owner-member relationships between named design elements. 

The released software includes three sample model files, atest.rvm, 
stab.rvm, and allsrp.rvm (as well as man.rvm, the ‘scale man’) which you 
may load in order to practise using Review. You will probably recognise 
these models if you have attended a PDMS basic training course. 

2.1 Loading a Model File into Review 

 

To load or import a model file  into Review from any accessible 
source directory, first click the Open button on the toolbar. An Open 
Review Files form will be displayed: 
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The Open Review Files form is a standard Windows Open dialog box and functions in the 
same way. The following file types can be imported: 

Review model file (.rvm) A standard model file, exported 
from PDMS. 

Review status file (.rvs) A binary file which holds display 
configuration settings from one 
Review session.  

Review file (.rvm, .rvs) (Both .rvm and .rvs files will be 
listed in the file browser.) 

Exercise:  
Import the file atest.rvm from your Review installation. 
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2.2 The Explorer 

  
The Explorer provides a hierarchical view of the PDMS elements 
imported in the model file. 

Click on the expansion box (  ) to expand a hierarchy (box changes to  ), 
click on the ‘minus sign’ to close up the hierarchy. 

The Explorer operates in a way very similar to that of the Windows 
explorer, although the shortcut menu options are different: 

 

Dynamic Focus On 
Moves the camera to the selected element, with dynamic 
movement, and looks at it. The dynamic movement will 
animate the camera from the start position to the end 
position. 

Focus On 
Moves the camera to the selected element and looks at it. 

Look At 
Re-orients the camera to look towards the identified 
element but with no movement of the camera. 

Move Close To 
Moves the camera to a short distance away from the 
identified element and looking at it. Unlike Focus On 
commands this operation does not attempt to fit the item in 
into the graphics window. 
Copy 
Captures the associated element name, which can then be 
used when defining ‘look towards’ views, clip volumes, 
groups etc. See later in this User Guide. 
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Multiple items can be selected in the tree as long as they are siblings of each 
other. Multiple selections are created using the standard Windows Ctrl for adding 
to a selection and  for a range selection when selecting elements.
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3 The Observer, the Cameras and the Model 

The content of the displayed view depends upon four key factors: 

• The location of the observer (you) or camera positions. 

• The location of the design model. 

• The orientation of the design model with respect to the viewer. 

• The angle of view of the observer or camera lens. 

3.1 The View Pyramid 
The view of the model which you see in the Observer View window 
depends on the settings of a number of view geometry parameters which 
together constitute a view pyramid, thus: 

 

Rotation 
about 
model 

Rotation 
about eye 
point 

Observer's 
eye pont (or 
from point) 

Display 
area 

(shaded)

Angle of view 

Through 
point (or 
To point) 

Line of sight
Roll about 
line of sight 

Zoom view 
along line of 

sight

 

4 The key features of the view pyramid are as follows: 

• The observer’s eye point (or from point) is the point in model space 
from which the view is being observed. It may be anywhere outside or 
inside the physical design model. 
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• The model’s through point (or to point or centre of interest) is the 
point in model space which coincides with the centre of the display 
area. 

• The line of sight, which is the line through the eye point and the 
through point, is the axis along which the view is looking. 

• The angle of view is the angle subtended at the eye point by the 
vertical side of the display area. 

4 When the view is to be changed, the view geometry may be specified in 
the following ways: 

• The eye point is specified by its 3D coordinates in the model’s axis 
system. 

(The eye point may also be derived from a specified through point and 
line of sight, but this is much less common.) 

• The through point may either be specified by its 3D coordinates in 
the model’s axis system or it may be derived from a specified line of 
sight. 

• The line of sight may either be specified as a direction (expressed as 
bearing plus elevation components) from the eye point or it may be 
derived from a specified through point. 

• The angle of view may either be specified directly as an angle or it 
may be derived from a specified display area. 

4 Manipulation of the view may take place in the following ways: 

• Rotation of the view may take place either about the observer’s eye 
point or about the model’s through point.  

• Roll of the view corresponds to rotation of the view pyramid about the 
line of sight. 

• Zooming of the view corresponds to movement of the observer’s eye 
point backwards or forwards along the line of sight, thus changing the 
distance between the eye point and the model, with the angle of view 
kept constant. This changes the amount of the model which fits into 
the effective display area without changing the perspective angle. 
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• Field of view changes correspond to a narrowing or widening of the 
view angle with the distance between the through point and the eye 
point kept constant. This changes the amount of the model which fits 
into the effective display area by changing the perspective angle (like 
changing the focal length of a camera lens). 

Review allows you to define eight different views at any one time, 
identified by reference to an observer or to any of seven numbered 
cameras. 

• The observer view offers the maximum scope for customisation 
and manipulation of the view, and it is this view which you will 
use for most complex operations such as measurement and 
labelling. 

• The camera views offer a more limited range of viewing options, 
restricted primarily to differences of viewpoint, but you can switch 
quickly between them without having to redefine the view 
pyramid parameters each time. 

By default, the view you see displayed is set up for the observer.  

For details of how the Camera View options are used, refer to the 
corresponding descriptions for the Observer View throughout this guide. 
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4 The View Panels 

Having entered Review and loaded a model file (see Chapter 2), a typical 
main Review window would appear as shown below: 

 

A set of view panels may be displayed within the main window, being 
accessed from the View pull-down menu. The picture at the start of 
Chapter 1 shows a main window with three panes. 
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4.1 Controlling the View 

 
 

 

  
 

The Camera Control form allows you to define the view by entering 
explicit positions and directions or by manipulating the line of sight 
interactively. Any changes made are immediately visible within the 
Observer View. 

Camera Setting Form: allows you to define view settings for the Observer or 
for any of seven cameras. Make the appropriate selection from the pull-
down menu or use the wheel on your mouse (if present) to scroll through 
the menu. 

Current Mode: allows you to select the current viewing mode (see section 
5.1 for details of each of the modes). 

Notice how the Camera Settings panel expands appropriately according to 
the camera setting/viewing mode selected. 
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4.1.1 The Camera Settings Panel 

 

This panel enables you to change the settings for the selected camera. 
Walkthrough, Flythrough and Fixed Focus display navigation modes 
share the same settings. Classic navigation mode has some extra 
settings.  

The appearance of the panel for Walkthrough, Flythrough and Fixed 
Focus modes can be seen above.  

Display Camera, when selected, gives a colour-shaded observer view. 
Wireframe View gives a wireframe observer view.  

The Step Speed slider allows you to set the speed for step movements in 
the view such as from panning or the W,S,A and D keys. 

When in Classic navigation mode, the following settings are available: 
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About Eye sets the camera to rotate about the eye; About Model sets the 
camera to rotate about the model. The Camera Movement options are: 

• Continuous – sets continuous mode for mouse-controlled rotates 
and zooms (the view changes continuously for as long as you hold 
down the mouse button). 

• Single Step – sets single step mode for mouse-controlled rotates 
and zooms (the view changes only when you release the mouse 
button).  

• Step - sets step mode for mouse-controlled rotates and zooms (the 
view changes continuously for as long as you hold down the mouse 
button). 

(Continuous mode and Step mode are very similar; see section A.1.1 
(Secondary Manipulation Mode) for more detail on the above 
options.) 

The Step Size slider sets the speed for step size movements such as 
zoom and pan. 

4.1.2 The Camera Position Panel 

 

This panel enables you to set the position of the camera and the through 
point. Enter the required values in the text boxes and press Enter to 
observe the effect on the display. Clicking on East, North, Up changes them 
to West, South, Down respectively. 
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4.1.3 The Camera Manipulation Panel 

 

This panel enables you to set the camera orientation and field of view. 

4 The Bearing Control 

This is shown as a ‘compass dial’ with North (not marked) at the top: 

 
The current horizontal bearing is shown by the position of the radial line 
(the ‘compass needle’), and in figures (degrees). The view direction is 
from the centre of the dial looking outwards along the line. 

To change the bearing, drag the compass needle round to the required 
setting with the left-hand mouse button held down. Release the mouse 
button to fix the direction. 

VANTAGE Plant Design Review Version 6.2 4-5 
User Guide 



The View Panels 

4 The Elevation Control 

This is shown as a semi-circular dial: 

  
The current vertical elevation is shown by the position of the radial line, 
and in figures (degrees). The view direction is from the centre of the dial 
looking outwards along the line. 

To change the elevation, drag the radial line round to the required 
setting with the left-hand mouse button held down. Release the mouse 
button to fix the direction. 

4 The  Field of View Control 

This is shown as an included angle: 

 
The current angle of view is shown by the angle between the solid lines 
and in figures (degrees). This angle is that subtended at the eye point by 
the vertical side of the displayed area of the model. (The angle between 
the dotted lines approximates to the natural viewing angle of the human 
eye.) 

To change the angle of view, and hence the field of view, drag the lines 
closer together or further apart with the left-hand mouse button held 
down. Release the mouse button to fix the angle. 

Note: Reducing the angle of view will effectively magnify the display 
(like increasing the focal length of a camera lens while keeping 
the camera-to-subject distance constant). This is not the same as 
moving the observer closer to the model, since the latter keeps 
the angle of view constant. The difference is illustrated, in a 
slightly different context, in section 3.1. 
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4 The Roll Control 

This is shown as a cross-section of a schematic aircraft: 

  
The current angle of roll in the vertical plane is shown by the angle of the 
aeroplane’s tail fin (0 = tail fin at the top, as illustrated), and in figures 
(degrees). 

To change the angle of roll, drag the aeroplane’s tail fin round to the 
required setting with the left-hand mouse button held down. Release the 
mouse button to fix the direction. 

4.2 Grouping Displayed Elements 
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The Groups form allows you to link displayed elements together into 
logical groups, so that you can then manipulate them collectively. 

Working with groups is fully described in Chapter 12. 

4.3 Setting Visual Properties 

 

 
(In the illustration above right, an item has been selected in the Observer 
view.) 

The Visual Properties form allows you to view or change the material 
properties of a selected element. Any changes made on the Visual 
Properties form will be immediately shown in the Observer View. Single or 
multiple selections made in the currently active window will be tracked 
and, where possible, the properties for those elements will be displayed. 

4.3.1 Tracking Selected Elements 

The Visual Properties form will show the properties for elements selected 
in the currently active window. Windows tracked by the panel are the 
Explorer, the Observer View and the Search results list (see section 4.4.3) 

Some of these windows allow for multiple selections. When a multiple 
selection is active and all the elements in the selection have the same 
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value for one of the properties then that value will be displayed in the 
window. Where there is a multiple selection with differing properties 
then the Visual Properties will be shown as mixed and you will be allowed 
to set the selection. 

For example: 

Multiple selections with common visual properties: 

 

Multiple selections with non-matching visual properties 
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4.3.2  Setting Visual Properties 

If the Material Type is the same for all elements in the selection then the 
material name will be shown on the form along with a primitive rendered 
with that material type (as shown in the diagrams above). If the material 
type is not the same for all elements in the selection then the form will 
show the text No Common Material and there will be no preview primitive 
shown.  

To change the material of the entire selection click on Change Material…. 
This will bring up the Change Material form as shown below. 

 

(See section 8.3 for more details of this form.) 

Click on the required material to select it or type in the name of an 
element to select the material of that element, then click Apply.  

4.3.3 Applying a Material 

The Material Painter provides a way to apply the material of the currently 
selected item to other elements. Clicking on Material Painter… will change 

the pointer to a ‘paintbrush’ (  ), able to paint elements in the Observer 
View with the current material. 

To apply the material to an owner of the selected element, use the mouse 
to bring up the shortcut menu on element. This will display a list of 
owners for the item under the mouse to paint to. See below for an 
example: 
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The material will be painted to the element under the mouse when the 
mouse button is released. On mouse down the item will be highlighted. 
Moving the mouse around while the mouse button is down will change 
the item to be painted to the item under the mouse. This is particularly 
useful if you missed the item to be painted when the mouse button was 
pressed. Moving the mouse with the button still down will allow for the 
correct item to be painted.  

The pointer will remain as a paintbrush until Esc is pressed, Material 
Painter… is selected again or Cancel Format Painter is selected from the 
shortcut menu. 

Note: The Material Painter will use the setting of the Graphical 
Selection: preference on the Preferences form 
(Tools>Options>Preferences…) to determine which element to 
paint to when the mouse is clicked. For example with this 
preference set to Normal clicking on box BOX1 of /EQUI1 will 
paint the material to the box. When this preference is set to Pick 
Significant Element clicking on this box will paint the material to 
equipment EQUI1.  
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4.3.4 Selecting a Preview Primitive 

You can change the primitive shape used to preview the current 
material. Clicking on Preview Primitive… will cycle through sphere, cube, 
circular pyramid and hemisphere shapes. 

4.4 Searching the Model 

 

 
The Search form enables you to search for an element name within the 
model files currently loaded into Review. Searches can be run against 
part of the element name by using wildcards. The search can be further 
refined by searching on the element’s material type, visibility and auto-
tagging setting. 

For example, with the settings shown below, when Search is clicked the 
search will be run to find all elements with ‘1502’ anywhere in their 
name and a material type set to ‘Material02’ and that are translucent. 

4-12 VANTAGE Plant Design Review Version 6.2 
User Guide 



The View Panels 

  

4.4.1 Searching on Element Names 

The search can be run against all or part of the element name, which 
may include wildcards. Two wildcard characters are available; the 
asterisk (*) and the question mark (?). 

The * wildcard will match 0 or many characters to the * in the search, for 
example EQUI*101 would return results such as EQUIPMENT-101, EQUI101 
and EQUI-101. 

The ? wildcard character will match any character to the one character 
represented by the wildcard. For example EQUI?101 would return EQUI-
101 as a result but not EQUIPMENT-101 or EQUI101. 

If no wildcard characters are used then Review will search for any name 
containing the supplied text at any point in the name. This is the 
equivalent of a * wildcard at both the beginning and end of the search 
text. For example, entering EQUI in the name field would find any name 
with the text EQUI anywhere in the name.  

If no text is entered the search will be governed by the settings of the 
material type/visibility/auto-tagging criteria. 

To search only elements that have ‘significant’ names select Only search 
significant elements. Significant element names come from the text to the 
right of the first / in (full) element name. For example in BOX 1 OF 
/VESS1, /VESS1 is the significant name.  
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4.4.2 Searching on Display Properties 

It is also possible to further refine the search by searching on the display 
properties of the elements.  

The With material type: list allows you to choose a material to search on. 
Selecting a material from this list will further refine the search by only 
searching for elements with that material type. Any material will search 
for an element regardless of material type.  

The With visibility set to:  list allows you to choose a visibility setting to 
search on. Selecting a visibility setting from this list will further refine 
the search by only searching for elements with that visibility setting. Any 
visibility will search for an element regardless of material type.  

The With auto-tagging:  list allows you to choose an auto-tagging setting 
to search on. Selecting an auto-tagging setting from this list will further 
refine the search by only searching for elements with that auto-tagging 
setting. Any auto-tagging will search for an element regardless of material 
type.  

(See section 11.2 for details of auto-tagging.) 

4.4.3 Search results 

The results of the search will be displayed in the Search results list at the 
bottom of the form. It is possible to select elements on this list and act on 
them using the following shortcut menu: 

 

Focus On As Dynamic Focus On, but with no animated 
movement. 

Dynamic Focus On The observer ‘walks in’ to the object under 
the pointer until the object fits in the extent 
of the view. Gives an animated movement 
of the camera from the start position to the 
end position. 
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Look At 
Re-orients the camera to look towards the 
identified element, but with no movement 
of the camera 

Move Close To 

Moves the camera a short distance away 
from the identified element. Unlike the 
‘Focus On’ operations, this operation does 
not attempt to fit the item into the observer 
view. 

Copy 

Captures the associated element name, 
which can then be used when defining ‘look 
towards’ views, clip volumes, groups etc. 
See later in this User Guide. 

Locate in Tree 
Highlights the item in the Explorer window. 
(If the Explorer window is not present, this 
operation will bring it up.) 

Multiple selections can be made from the list using the normal Windows 
Shift, Control selection features. For multiple selections in the list only 
Copy will be available on the menu. 

The Visual Properties form (see section 4.1) will show the visual 
properties for elements selected in the Search results list. 
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4.5 Defining an Animation 

The Animation Control form allows you to define and play back an 
animation by setting up a progressive sequence of views. An animation 
requires an animation path to be defined first – see section 4.6. 

 
 

 

 

 

See Chapter 13 for a full description of setting up and playing 
animations. 

4-16 VANTAGE Plant Design Review Version 6.2 
User Guide 



The View Panels 

4.6 Creating and Editing Animation Paths 

The Path Editing form allows you to define and an animation path, 
objects such as cameras, groups or lights can then be animated along the 
paths. – see section 4.5. 

 
 

 
 

See Chapter 13 for a full description of setting up and playing 
animations. 
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4.7 Manipulating the View Panels 

The View Panels themselves incorporate standard Windows 
manipulation features: 

Clicking the Close button (  ) at the top right-hand corner will remove 
the view pane. Clicking the Auto Hide (  ) button will cause the panel to 
disappear whenever the pointer is moved into the graphical view. For 
example, for the Explorer, moving the pointer over the button at top left 

 
would cause the Explorer to reappear. 
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5 Manipulating the Observer View 

This chapter describes the principal ways of manipulating the graphical 
view of the model displayed in the Observer View window. These are: 

• By using the mouse buttons, where the observed effect is governed 
by the position of the pointer within the screen area. 

• By using the keyboard, where the arrow keys and numeric keypad 
keys change the view in specific ways. 

• From within the view definition forms. These allow you to enter 
explicit instructions for setting the required view or to manipulate the 
view by using controls on the forms. 

• By selecting an option from the Edit>Look submenu option 

• By constraining movement to a sequence of fixed directions by setting 
a specific walk path. 

Note:  some of the menu bar options presented in this chapter will only 
be visible if the Observer View is made active (by clicking in it). 

5.1 The Navigation Toolbar 

 
The Navigation toolbar controls the way in which the view manipulation 
features of Review work. Most navigation operations can be performed 
using the mouse or keyboard, as detailed below. 

The four buttons on the left select Walkthrough mode, Fixed Focus mode, 
Flythrough mode and Classic mode (see below). 

 Walkthrough mode (see section 5.1.2) is intended for use with 
‘walkthroughs’. All movement is relative to the observer, who can only 
move in the horizontal plane. 

 Fixed Focus mode (see section 5.1.6) is used to fix the ‘focus point’. 
All movement is relative to the pointer position. The user can rotate 
around the focus point and move closer and further from it. Fixed focus 
mode is best used in conjunction with the shortcut menu (see section 5.2) 
for quick snapping to elements. 
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 Flythrough mode is similar to Walkthrough mode, except that 
movement of the observer is not restricted to the horizontal plane. 

 In Classic mode, view manipulation operates as it did with Review 
version 6.1 or earlier. See Appendix A for details. 

 The slider controls the speed at which 
zoom and walkthrough operations take place. Move the slider control 
to the right to increase the speed. The speed is displayed to the right of 
the slider control. 

5.1.1 Common Mouse Operations 

 

(Click) In all modes, clicking the right-hand mouse button 
with the pointer over an object causes the shortcut menu 
to appear. See section 5.2. 

 

(Drag) In all modes, pressing and holding down the left-
hand mouse button causes the name and model coordinates 
of the element under the pointer to appear in the status 
line. 

5.1.2  Walkthrough/Flythrough Mode – Mouse Operations 

 

(Click) The view centres on the object under the pointer 

 

(Drag) The model is rotated about the observer 

 

The observer ‘walks’ forward and backwards along his line 
of sight 
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(Drag) The observer ‘pans’ in the direction of pointer 
movement, the camera view changes accordingly. The 
amount the camera is panned is proportional to the 
distance moved by the mouse from the ‘button down’ 
position during the drag. 

An option on the Preferences form 
(Tools>Options>Preferences) enables the pan directions to 
be inverted: 

 

5.1.3  Walkthrough/Flythrough Mode – More on Rotating using 
the Mouse 

Walkthrough mode enables rotation about the eye point. The amount to 
rotate the camera is defined by the distance travelled by the mouse 
during the drag operation. The camera rotates in the direction the mouse 
travels. Diagonal drags result in a compound rotation about the two axis 
(e.g. up and right). 
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Rotate up about eye Rotate diagonally up 
and right  

Amount to rotate 
proportional to 
distance travelled from 
button down position 
during drag 

Rotate right about eye 

Button down 
position 

 

Note:  An option on the Preferences form (Tools>Options>Preferences) 
 enables the axis direction for up/down rotations to be inverted: 
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5.1.4  Walkthrough Mode – More on Walking 

Walking forwards and backwards in Walkthrough mode is constrained to 
the horizontal plane, giving an intuitive way of navigating around the 
model. The direction to move is taken from the direction of the camera 
transposed onto the horizontal plane.  

Look direction

Step right 

Walk direction 
in horizontal 
plane 
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5.1.5  Walkthrough/Flythrough Mode – Keyboard Operations 

Key Navigation Action 

W Walk forwards 

S Walk backwards 

A Step left 

D Step right 

R Step up 

F Step down 

 
Pan up 

 
Pan down 

 Pan left 

 Pan right 

Numpad 2 Rotate down about eye 

Numpad 8 Rotate up about eye 

Numpad 4 Rotate right about eye 

Numpad 6 Rotate left about eye 

Numpad 5 Walk forwards 

Numpad 9 Walk forwards 

Numpad 3 Walk backwards 

 Slow down movement 

Ctrl Speed up movement 
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5.1.6  Fixed Focus Mode – Mouse Operations 

 

(Click) Centres the view on the pointer position 

 

(Drag) The model is rotated about the pointer position. 

 

The observer moves closer to/further away from the model, 
along his line of sight. 

 

(Drag) The observer ‘walks’ in the direction of pointer 
movement, the camera view changes accordingly. The 
amount the camera is panned is proportional to the 
distance moved by the mouse from the ‘button down’ 
position during the drag. 

An option on the Preferences form enables the pan 
directions to be inverted. (See section 5.1.2.) 
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5.1.7  Fixed Focus Mode – Keyboard Operations 

Key Navigation Action 

W Move closer to focus 

S Move away from focus 

A Step left 

D Step right 

R Step up 

F Step down 

 
Pan up 

 
Pan down 

 Pan left 

 Pan right 

Numpad 8 Rotate up about model 

Numpad 2 Rotate down about model 

Numpad 4 Rotate right about model 

Numpad 6 Rotate left about model 

Numpad 5 Move closer to focus 

Numpad 9 Move closer to focus 

Numpad 3 Move away from focus 

 Slow down movement 

Ctrl Speed up movement 

5.1.8  Fixed Focus Mode – More about Rotation 

Rotates in Fixed Focus mode work in a similar way to rotates in 
Walkthrough mode, except that unlike in Walkthrough mode there are 
no diagonal rotations. The size of the angle of rotation is proportional to 
the amount the mouse moves with the middle button pressed. 

In Fixed Focus mode movements left and right with the mouse affect the 
bearing and movements up and down will affect the elevation. The 
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direction of rotation is determined by the initial direction of the mouse 
drag. For those familiar with PDMS, rotations in Fixed Focus mode work 
in the same way as rotations in PDMS. 

5.2 Direct Manipulation Using the Shortcut Menu1 

 

A number of options for moving the observer are available from the 
shortcut menu (the right-hand mouse button menu) with the pointer 
over an object in the observer view. In all operations the observer’s 
looking direction remains unchanged. 

Stand on Surface 
Moves the camera to a fixed height (the 
height of an average person) above the 
pointer position.  

Focus On Moves the camera to the selected element 
and looks at it. 

Dynamic Focus On 

Moves the camera to the selected element, 
with dynamic movement, and looks at it. 
The dynamic movement will animate the 
camera from the start position to the end 
position. 

Look At 
Re-orients the camera to look towards the 
identified element, but with no movement 
of the camera 

Move Close To Moves the camera a short distance away 
from the identified element. Unlike the 

                                            
1 There are additional shortcut menu options in Classic mode, see 
Appendix A. 
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‘Focus On’ operations, this operation does 
not attempt to fit the item into the observer 
view. 

Locate in Tree 
Highlights the item in the Explorer window. 
(If the Explorer window is not present, this 
operation will bring it up.) 

Copy 

Captures the associated element name, 
which can then be used when defining ‘look 
towards’ views, clip volumes, groups etc. 
See later in this User Guide. 

Select 

Gives a submenu enabling the significant 
elements above the selected element in the 
hierarchy to be selected. A Clear Selection 
option also becomes available if there is a 
graphical selection 

Cancel Cancels the menu and performs no action 

Note that the Focus On, Dynamic Focus On and Look At shortcut menu 
options are also available from the Explorer view – see section 2.2. 

5.3 Direct Manipulation Using the Keyboard - General 

You can change the observed view by pressing specific keys on your 
keyboard. The precise effect depends mainly on the following things: 

• The type of change (Zoom, Rotate or Pan) depends on which key you 
press. 

• The extent of the change depends on the current increment settings 
for displacement and rotational movements.  

The effects of the individual keys are as shown in the following diagram: 
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All movements initiated by key presses are independent of the pointer 
position within the graphical view and always give Step mode changes; 
that is, each key press moves the view by a full increment (unless 
reduced by a factor of 10 by holding down the  (shift) key, or increased 
by a factor of 10 by holding down the Ctrl key). If you hold down a key, 
the view is redrawn at the screen’s redraw rate until the key is released. 

The following constraints apply: 

• If Num Lock is on then numeric keypad keys 4 and 6 rotate the model 
about the observer in Walkthrough mode, or rotate the model about 
its centre in Fixed Focus mode. 

Exercise:  

Set Step mode and observe the effect of pressing each of the model-
manipulation keys in turn. 

Try holding down first the  (shift) key and then the Ctrl key while 
pressing each of the model-manipulation keys and note the change in the 
rate of movement of the view in each case. 

Try pressing different pairs of keys simultaneously to produce composite 
movements; for example, pan + zoom, rotate + zoom, pan + rotate. Press 
pairs of ‘opposite’ keys, such as pan left + pan right or zoom in + zoom 
out, and note that the effects cancel out to leave the view stationary. 

Experiment by using the model-manipulation keys in each of the other 
modes (Single Step, Continuous and Spin). Change between eye 
movement and model movement and observe the different effects. 
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5.4 Other View Manipulation Facilities – all Modes 

5.4.1 Spinning the Model 

In Spin mode (selected from Tools>Options>Mode>Spin )the view rotates 
continuously, even after you have released the mouse button, until you 
specifically pause it or stop it. 

To stop a ‘spinning’ model, select Tools>Options>Mode>Spin>Stop. 

To pause a ‘spinning’ model, press and hold down the right-hand mouse 
button anywhere in the Observer View. 

5.4.2 Setting Translational and Rotational Increments 

The maximum amount by which the view can change for each zoom, 
rotate or pan operation is determined by the current translational and 
rotational increment settings. By default, the translational increment is 
1000 mm and the rotational increment is 10 degrees. 

To change either or both of the increment settings, select 
Tools>Options>Preferences… from the menu bar. The Preferences form 
shows the current settings, which you can change in the usual way. 
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5.5 Manipulation Using Menu Options 

The Edit>Look option with the Observer View selected allows you to give 
explicit instructions, either directly or via resulting forms, for setting the 
various view parameters. The effects of the associated submenu options 
are as follows: 

4 Look>From> 

These settings enable you to set the eye point to a specific location while 
retaining the current through point.  

Look>From>Camera> sets the eye point to that which is currently defined 
for the observer or a chosen camera number. 

Look>From>Name… displays the Look From form which allows you to 
specify the name of an element whose origin is to define the new eye 
point. 

Look>From>Group… displays a scrollable list within the Look From Group 
form of all currently defined groups, including the scale man. Select the 
group whose origin is to define the new eye point. 

Look>From>Model Centre moves the eye point to the geometric centre of 
the model. (If the through point is at the model centre, the eye point and 
through point will become coincident and the line of sight will be set to 
look South.) 

Look>From>Model Origin moves the eye point to the model’s origin. 

4 Look>Towards> 

These settings enable you to set the through point to a specific location 
while retaining the current eye point. This is equivalent to rotation of the 
model about the eye. 

Look>Towards>Camera> sets the through point to that which is currently 
defined for the observer or a chosen camera number. 

Look>Towards>Name… displays a Look At form which allows you to 
specify the name of an element whose origin is to define the new through 
point. Enter the name of the element in the text box. (Tip: Pick the 
element in the display using the left-hand mouse button and paste its 
name into the text box using the middle mouse button.) The list options 
on the Look At form are as follows: 

Do Not Move will just change the view direction. 
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Snap Move will zoom in on the element immediately so that it fills the 
Observer View window. 
Dynamic Move will zoom in on the element by steps until it fills the 
Observer View window. The step size is determined by the current 
translational increment. A maximum of 15 steps will be taken. 

Look>Towards>Group… displays a scrollable list within the Look Towards 
Group form of all currently defined groups including the scale man. 
Select the group whose origin is to define the new through point. 

Look>Towards>Model Centre moves the through point to the geometric 
centre of the model (which is usually the default setting). 

Look>Towards>Model Origin moves the through point to the model’s 
origin. 

4 Look>As> 

These options reset both the eye point and the through point for the 
Observer View to those which are currently defined for the specified 
camera view. Thus Look>As>Camera Two changes the Observer View so 
that it shows exactly the same view as the Camera View for Camera Two. 
(This is a convenient way to store a set of view parameters for later 
recall.) 

4 Look>Window> 

Both of the Look>Window> submenu options prompt you to define a 
region of interest by dragging a resizable window to the required position 
and size within the Observer View display. The cross at the centre of the 
window determines the new through point and the size of the window 
determines the new angle of view (field of view). Both options effectively 
zoom the view in (they cannot be used to zoom out, since the defining 
window cannot be made larger than the current Observer View area). 

 
Look>Window>By Position effectively moves the eye point closer to the 
new through point while keeping the angle of view constant, as shown by 
the      view pyramid in Figure 5-1. 

Look>Window>By Angle changes the angle of view without moving the eye 
point, as shown by the      view pyramid in Figure 5-1  
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Initial view pyramid
Window>By position
Window>By angle
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D

AB = Initial view area
CD = Windowed view area

DD
T E1

E2

E2

T  = Through point (assumed unchanged)
E1 = Initial eye point
E2 = Window>By position eye point
E3 = Window>By angle eye point
E1 = E3

a1a2 a3

a1 = Initial angle of view
a2 = Window>By position angle of view
a3 = Window>By angle angle of view
a1 = a2

Line of sight
(assumed unchanged)

D

 

Figure 5-1 The effects of the Look>Window> options (cross-sections of view 
pyramids) 

4 Look>Direction> 

The effects of the Look>Direction> options depend on whether you are 
currently in Eye or Model rotation mode (as set from the Camera 
Definition form). 

If you are in Model rotation mode, Look>Direction>East (say) is equivalent 
to setting the Bearing to East. 

If you are in Eye rotation mode, Look>Direction>East changes the line of 
sight so that you look towards East from the current eye point. 

4 Look>ISO> 

The effects of the Look>ISO> options depend on whether you are 
currently in Eye or Model rotation mode (as set from the Camera 
Definition form). 

These options behave in the same way as the Look>Direction> options, 
except that the view direction is changed to that defined for the specified 
isometric quadrant. These directions shown in Figure 5-2. 
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ISO Four
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ISO Two

ISO Three
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N-E-D quadrant
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S-E-D quadrant
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S-W-D quadrant

looks towards
N-W-D quadrant  

Figure 5-2 The Isometric Viewing Directions 

Iso 3 view 

 

4 Look>Reset 

Look>Reset resets the view to a default display of the whole model. This 
default view will override that which may have been defined by any 
previously loaded status file (see Chapter 14 for details of status files). 

Exercise:  
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Try the effects of each of the Edit>Look options in turn. (You will probably 
not yet have defined any groups, but you should be able to use the scale 
man as a reference for the Edit>Look>From>Group and 
Edit>Look>Towards>Group options for this exercise.) 

Use Tools>Options>Observer to switch between Eye and Model rotation 
modes where these affect the way in which the Look commands behave. 

You may find it easiest to see the differences between the effects of the 
various Look options if you use Edit>Look>Reset to return you to a 
common starting point between each part of the exercise. 
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6 The Keyplan View 

This chapter describes how to use the Keyplan View. Some of the concepts 
involved here are described in later chapters; you may wish to refer back 
to this chapter as you encounter them. 

 

The Keyplan View is displayed when you click the Keyplan View 
button on the toolbar or when you select View>Keyplan View from 
the menu bar. While you are learning how to use the Keyplan, 
you may want to enlarge the window. 

 

 

6.1 The Keyplan Control Buttons 

The Keyplan View window displays small-scale plan and elevation views 
of the model, and contains a row of toggle buttons down its left-hand 

VANTAGE Plant Design Review Version 6.2 6-1 
User Guide 



The Keyplan View 

side. The settings of these buttons, each of which may be set to On 
(yellow) or Off (blue), determine what you see in the Keyplan displays 
and how the model view will change as the Keyplan is manipulated. 

The effects of the Keyplan control buttons, listed in top-to-bottom order, 
are as follows: 

6.1.1 The Zoom   Button  

You can toggle the Keyplan Zoom button to show + or -. When the button 
is set to +, moving the pointer into one of the Keyplan view windows and 
clicking the middle mouse button will zoom in. When the button is set to 
-, moving the pointer into one of the Keyplan view windows and clicking 
the middle mouse button will zoom out.  

The Zoom button is an exception to the On/Off convention: repeated 
selection of the button toggles its setting between Zoom In and Zoom Out 
modes. 

6.1.2 The Continuously Update Graphics Button  

The Continuously Update Graphics button determines how the Observer an 
Camera View display is updated as you move any of the Keyplan control 
points (observer’s eye point, model through point, etc.). 

When the Continuously Update Graphics button is selected, the display is 
updated continuously so that the display immediately follows your 
manipulations. 

When the Continuously Update Graphics button is unselected, the display 
is updated only when you release the mouse button. 

The Continuously Update Graphics function is used for camera, light and 
group manipulations. 

6.1.3 The Camera Button  

When the Camera button is selected the current active camera position 
(the eye point  ), the centre of interest of the model (the through point 

 ), and the line connecting them (the line of sight) are drawn on the 
Keyplan. 

To drag the eye point to a new position, position the tip of the pointer at 
the centre of the eye’s surface, thus   . To drag the through point to a 
new position, position the tip of the pointer at the centre of the circle, 
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thus  . To pan the line of sight, position the tip of the pointer on the 
line. 

When the Camera button is unselected, the viewing positions are not 
drawn. 

6.1.4 The Light Button  

When the Light button is selected, the current active light position or 
direction (according to the type of light) is drawn on the Keyplan so that 
you can manipulate it. 

Different types of light are shown as follows: 

Infinite light   

Local light    

Spot light    

To drag the active light to a new position, position the tip of the pointer 
at the centre of the circle, thus   . 

When the Lighting control button is Off, the light position is not drawn. 

6.1.5 The Path Button  

When the Path button is selected, the current active animation path (if 
any) is drawn on the Keyplan for reference. 

When the Path button is unselected, the animation path is not drawn. 

See Chapter 13 for details of setting up animation paths. 

6.1.6 The Clip Select Button   

When the Clip Select button is selected, a clip volume marker is drawn on 
the Keyplan, thus . If this marker is dragged within the Keyplan, any 
defined clip volumes will be highlighted as the marker passes through 
them. 

To drag the clip volume marker to a new position, drag it with the 
pointer with the left-hand mouse button held down. 

When the Clip Select button is unselected, the clip volume marker is not 
drawn. 
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Note: The clip volume markers in the plan and elevation views must 
both be within a clip volume for it to be highlighted. 

With Clip Select selected, releasing the mouse button after manipulating 
the clip volume marker puts the current clip volume name into the paste 
buffer, so that you can paste the name into a relevant form by using the 
middle mouse button. See section 9.4 for more details of defining clip 
volume. 

6.1.7 The Edit Clip Button  

When the Edit Clip control button is selected, the currently selected clip 
volume is drawn on the Keyplan. You can edit the size of the clip volume 
by dragging its sides or corners to the required positions. You can move 
the whole clip volume, without changing its dimensions, by positioning 
the pointer at the centre of its outline box and dragging it in the 
required direction (if the clip volume is named, the bottom left-hand 
point of the name text corresponds to the required centre point). 

If there is no current clip volume, you can define one by dragging the 
outline to the required positions. 

When the Edit Clip control button is unselected, the clip volume is not 
drawn. 

See section 9.4.2 for further details of defining a clip volume from the 
keyplan view. 

6.1.8 The Group Origin Button     

When the Group Origin button is selected, the axes of the current active 
group are drawn. You can move the group’s origin by dragging the axes 
to the required position in either Keyplan view. See section 6.2.1 for 
more on selecting the active Keyplan group. 

To drag the origin of the active group to a new position, position the tip of 

the pointer at the origin of the displayed axes, thus . 

When the Group Origin button is unselected, the group position cannot be 
manipulated from the Keyplan view. 

6.1.9 The Group Bearing/Elevation Button      

When the Group Bearing/Elevation control button is selected, you can 
change the bearing and/or elevation of the current active group by 
dragging the control points in the appropriate Keyplan view. To change 
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the bearing, manipulate the points in the plan view; to change the 
elevation, manipulate the points in the elevation view. 

To drag the bearing or elevation of the active group to a new direction, 
position the tip of the pointer at the arrowhead on the displayed axes in 

the relevant view, thus   . 

When the Group Bearing/Elevation control button is Off, the group bearing 
and elevation cannot be manipulated from the Keyplan view. 

6.1.10 The Group Roll Button       

When the Group Roll button is selected, you can change the angle of roll 
of the current active group by dragging the control points in either 
Keyplan view. 

To drag the active group to a new roll angle, position the tip of the 
pointer at the arrowhead on the displayed axes in the relevant view, thus  

. 

When the Group Roll button is unselected, the angle of roll of the group 
cannot be manipulated from the Keyplan view. 

6.2 Keyplan Control – the Keyplan View Panels 

6.2.1 The Keyplan Elements Panel 

 

Show Camera performs the same functions as the Camera button, see 
section 6.1.3. The affected camera can be selected from the option list to 
the right. 
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Show Light performs the same functions as the Lighting button, see section 
6.1.4. The affected light can be selected from the option list to the right. 

Show Path performs the same functions as the Path button, see section 
6.1.5. The required path, and the group to be moved along it, can be 
selected from the option list to the right. 

Continuously Update Graphics performs the same functions as the 
Continuously Update Graphics button, see section 6.1.2.  

6.2.2 The View Direction Panel 

 

Clicking on one of the Look options changes the keyplan viewing direction 
as appropriate, Clicking Reset will reset the view to its starting setting. 

6.2.3 The Clipping Panel 

 

If a clip volume has been defined (see section 7.6) the options on this 
panel may be used to display the full or clipped model within the keyplan 
view. 
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6.3 Manipulating the Keyplan View Contents 

Limited control of the content of the keyplan view is available from the 
Edit>Make All menu, as follows.  
 
Visible Makes the view contents visible (after they have 

been made invisible, see below.) 
Invisible Makes the view contents invisible. 
Translucent Makes the view contents translucent (Observer View 

only). 
Wireframe Makes the view contents display in wireframe 

(Observer View only). 
AutoTag Tag displayed items (Observer View only). 
UnAutoTag Remove tags from displayed items (Observer View 

only). 
Change Materials… Use Change Material (All) form to change material 

of all displayed items. 
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7 Defining Some General View Settings 

This chapter describes the options which affect the general appearance of 
the graphical view. These options include: 

• Whether the model display is colour-shaded or wireframe.  

• Whether the model is drawn at all. 

• What colour is used for the background. 

• Whether the model atmosphere is clear or foggy, or whether a scenic 
backdrop is used. 

• Autotagging. 

• Shadowing. 

• Texture mapping. 

7.1 Selecting Colour-Shaded or Wireframe Images 

Select Wireframe View in the Camera Settings panel of the Camera Control 
form, Alternatively, select Edit>Wireframe> - ‘toggles’ the display between 
wireframe and shaded. 
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7.2 Displaying or Hiding the View 

By default, those parts of the model which have been selected for display 
(by using the add list, clip volume, etc.) are drawn in the Observer View 
window. You can switch off this display temporarily by clearing the 
Display Camera checkbox in the Camera Settings panel of the Camera 
Control form. 

7.3 Controlling the Image Quality 

You can define the display resolution for each type of viewer. 

To control one or more aspects of the image quality, select Edit>Image 
Quality. The Image Quality form will be displayed. 

Use the Imaging parameters for option list to specify the view which you 
wish to change (observer or a camera), then set the required resolution 
levels as described in the following subsections. 

Use the Static detail level and Dynamic detail level option lists to choose the 
level of detail to be displayed for static and dynamic views. Performance 
will be improved if a detail level of Low or Medium is selected, especially 
for dynamic views. 

You can select two realistic backdrops (in addition to the current 
background colour) by selecting from the Camera Backdrop option list. 
These backdrops are large but finite: if you zoom out a very long way 
from the model, you will see the edge of the backdrop. 

Horizon Height allows you to set the height of the horizon above (or below) 
the observer’s line of sight through the model origin. Only has any effect 
in ‘backdrop’ views. The default measurement units in Review are mm, 
so large values (of the order of 104) need to be entered before any effect 
will be observed. 

7.3.1 Switching Wireframe, Autotagging, Texturing and Shadows 

There are option buttons on the Image Quality form which control whether 
the model is displayed as a wireframe or colour-shaded view, and 
whether autotagging, textures and shadows are shown. 
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4 Wireframe 

You can set wireframe representation independently for static and 
dynamic modes by using the Wireframe boxes. Note that selecting 
Edit>Wireframe will also give a wireframe display. 

• If you set Wireframe for static displays, the model will always be 
displayed as a wireframe model. 

• If you set Wireframe for dynamic displays, the display will change to 
wireframe while you are changing the view interactively. This is a 
faster way of working than maintaining a colour-shaded view while 
the display is being repeatedly updated. When you release the mouse 
button, the display will change back to colour-shaded. 

4 Autotagging 

Autotags will only be displayed if the Autotagging option is switched on. 
If you switch autotagging off for dynamic views, changing the view will 
be faster. 

4 Texturing 

Textures will only be displayed in the model if the Texturing option is 
switched on. If you switch textures off for dynamic views, changing the 
view will be faster.   

4 Shadows 

Shadows will only be displayed if the Shadows option is switched on. If 
you switch shadows off for dynamic views, changing the view will be 
faster. 

7.4 Adding Fog Effects 

To simulate the appearance of the design model in foggy conditions, 
select Edit>Fog>Enabled. The appearance of the background will change 
immediately, but you must set the fog parameters as follows before the 
effect of the fog on the appearance of the model takes effect.  

To change the colour and density of the fog, select Edit>Fog>Fog Colour...  

The Define Fog Colour (Observer) form will appear, enabling you to set the 
density and colour of the fog. A fog density of 0% will not obscure the 
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model display at all, a density of 100% will obscure it completely. The 
default colour of the fog is grey. To change the fog colour click Choose… . 

The Windows Color dialog box will be displayed. Use the Windows colour 
chooser to create the required effect. Note that the effect of the fog on the 
appearance of parts of the model increases with the distance from the 
observer. The current colour is shown in the sample panel at the right-
hand side of the form. 

To remove the fog effect from the display, select Edit>Fog>Enabled again. 
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7.5 Setting Background Colours 

By default, all background colours are set to black. You can specify a 
different background colour for each view by selecting Edit>Background 
Colour. A Define Camera Background Colour form will be displayed. 

Use the Background colour of option list to specify the view (observer or a 
camera), then click Choose… and use the Windows colour chooser to 
define the background colour. Click OK to set the chosen colour. 

Note that you can select two realistic backdrops by selecting from the 
Camera Backdrop pull-down list on the Image Quality form. These 
backdrops are large but finite: if you zoom out a very long way from the 
model, you will see the edge of the backdrop. 

7.6 Displaying Selected Parts of the Model 

The Import Model Data form is displayed when you select File>Open 
Selection>Model File… to import a model file to Review. It contains the 
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Model File Members list showing the design hierarchy of the model and 
the Addlist, which shows the design elements which will be displayed in 
the Observer View window. 

If the model file contains a previously-saved Addlist, you will be given the 
option of using this to define the content of the current Addlist. 

Use the form as follows: 

1. Use the Browse… button and select a model file to load members 
from.  

2. Use the ‘explorer view’ in the Model File Members list to select the 
elements you wish to add to the Addlist. Do this by clicking the 
checkbox adjacent to the required element. Then click Add to add the 
selected elements to the Addlist. 

3. To remove elements from the Addlist, should you make a mistake or 
change your mind, select the elements in the Addlist and click 
Remove. 

Alternatively, to empty the Addlist completely, click Remove All. 

4. Repeat Steps 1 and 2 until the Addlist contains all of the design 
elements which you wish to display. 

5. When the Addlist shows all the elements to be displayed, click OK. The 
selected parts of the model will appear in the Observer View window.  

7.6.1 Using Clip Volumes 

You can restrict the display model so that it includes only elements 
which are wholly inside or outside a predefined 3D box known as a clip 
volume. Defining clip volumes is described in section 9. If clip volumes 
have been defined, you can apply them to the model file as it is loaded, so 
that only those elements which will appear in the clip display are read in. 
Type the name of the clip volume in the Clip Against text box or use the 
Select Clip Volume button to select from a list of available choices before 
you click the OK button.  

7.6.2 Miscellaneous Facilities 

Check Names checks for duplicate names in the Addlist, Report on File 
saves a report to file listing duplicate names and other errors. 

To save your new Addlist select Save Addlist to File. The Addlist you have 
created can then be reloaded the next time you use Review. 
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Exercise:  

Add and remove elements of the Atest model to and from the Addlist.  

Use the Import Model Data form to add the whole of the Atest model to the 
display, with name checking in force, and leave it there for future 
exercises. 
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8 Defining Materials 

Every element in a model can have a Review material applied to it. For 
each material, you can set a colour and properties such as shininess and 
smoothness. You can have any number of materials, each with a unique 
name. You can also apply textures to materials to represent, for 
example, brick walls or grids. See Chapter 17. 

There are no default materials supplied with Review, although you will 
see some materials defined when you open the Materials Palette form. 
These will correspond to colour numbers in the model, if you have one 
loaded, and the Scale Man. 

 

Materials are created, edited, copied and deleted by clicking the 
Material Definition button on the toolbar (or select View>Material 
Definition). 

  

VANTAGE Plant Design Review Version 6.2 8-1 
User Guide 



Defining Materials 

8.1 The Materials Palette Form 

 

The Materials Palette form shows the properties of the current material, 
which is the material you are editing; by default, this will be the first 
material in Review’s list of materials. You can change the current 
material as much as you like until you obtain the effect you want. Then 
you must save the material definition by clicking Apply Changes. 

If you have created a new material, it will be added to the materials list 
so that you can apply it to the model. When you edit an existing material, 
saving it will apply the changes to the existing material in the materials 
list and in the model. 
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The Materials Definition panel contains the following elements: 

• A primitive (by default, a sphere) representing the current material. 

To rotate this primitive, place the pointer over it and move the mouse 
while holding down the middle mouse button (the speed of the pointer 
affects the speed of rotation). 

• The Material Painter provides a way to apply the material of the 
currently selected item to other elements. Clicking on Material Painter… 

will change the pointer to a ‘paintbrush’ (  ), able to paint elements 
in the Observer View with the current material. 

• You can change the primitive shape used to preview the current 
material. Clicking on Preview Primitive… will cycle through sphere, cube, 
circular pyramid and hemisphere shapes. 

• The Change Colour… control which brings up the Windows Color dialog 
box, enabling you to set the colour of the material 

The Select material of: text box (at the top of the Materials Palette form) 
allows you to either type the name of an element into this box, or pick 
the element in the graphics area (using the left mouse button as usual), 
and paste it into the text box. Click Select Material Of and the 
information on the form will be updated to show the properties of the 
current material. 

If you have changed the properties of the current material but not saved 
it, and you want to return to the stored definition, click Discard Changes. 
If you dismiss the form and then display it again, it will be the same as 
when it was dismissed. 

8.2 Creating Materials 

To create a new material, click New Material…. The New Material text box 
will appear in which to enter the name of the new material. Material 
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names must be unique: if you enter a name that exists already you will 
see a message telling you that you must choose another name. Names 
can contain spaces. Click OK form to create the material.  

At this stage the new material will be the current material. It will be 
black, with default surface properties. Set the colour using the Change 
Colour… control. 

8.3 Editing Materials 

To edit an existing material, first select the material in one of the 
following ways: 

• Select an element in the model and paste its name into the Select 
material of: text box. A primitive with the selected material will appear 
within the Material Definition pane.  

• Select an alternative material by clicking on its icon within the 
display at the top of the Materials Palette form. The information within 
the Materials Definition panel will be updated to show the selected 
material.  

By default, all existing materials are displayed as spheres. The colours 
and other properties, including textures, are shown. Note that the sphere 
showing the current material looks as if it is on a button which has been 
pressed, and the name of the selected material is shown in the title bar of 
the Materials Palette form.  

Note: You can change the material applied to selected elements by 
selecting Edit>Make Drawlist>Change Materials… on the Drawlist 
form (see Chapter 9).  

As an alternative to the spherical icons, the material list can be 
displayed as a scrolling list of material names. To switch to this type of 
display, click  at the top of the Materials Palette form. If you have many 
materials defined, and you know which ones you want, it is quicker to 
use the scrolling list. Click  to return to the icon display. 

Note that if you open the Materials Palette form with no model loaded, the 
only colours you will see are those used to display the Scale Man, and 
any new materials you have created.  
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8.4 Setting Material Properties 

Material colours are set from the Color form. To set other material 
properties, select the Material Properties pane: 

 

  The slider bars are as follows: 

Specular:  The brightness of the highlight. 

Rough-Smooth: The spread of the highlight. 

Plastic-Metal: The colour of the highlight. Plastic materials 
have a highlight coloured by the incident light 
(usually white); metallic material highlights are 
determined by their base colour. 

Ambient:  The contribution of ambient light to the 
material brightness. 

Opaque-Transparent: The opacity (transparency) of the material. 
 

The effect of moving the sliders is shown immediately on the preview 
primitive in the Materials Definition pane. Discard Changes at the top of 
the Materials Palette form will return the sliders to the values they had 
when the form was displayed. If you dismiss the panel and then 
redisplay it, the sliders will be the same as when the form was dismissed.  

If you are defining a new material, the default settings of the surface 
properties are displayed. 
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8.5 Textures 

Textures can be applied to materials, starting from the Texture 
Properties pane: 

 

The use of textures is described fully in Chapter 17. 
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9 Controlling How Much of the Model is 
Drawn 

This chapter explains how to specify which parts of the complete design 
model are to be included in the graphical display. The principal ways of 
doing this are: 

• By editing the drawlist which identifies the specific elements which 
are available for display. 

• By defining a 3D volume (a clip volume) such that only elements 
which are wholly inside or outside that volume (you can specify which) 
are drawn. 

9.1 The DrawList Form 

When you first loaded your design data into Review, you used the Import 
Model Data form to specify which design elements were to be shown in the 
Observer View graphical window. You can use a very similar form the 
DrawList form, to modify the contents of the display at any time. 

To access the DrawList form, select View>Drawlist. 

To add elements to the current drawlist, carry out the following steps: 

1. In the Explorer view, select an element you wish to add to the drawlist 
and select Copy from the shortcut menu. 

2. With the pointer in the main list area of the DrawList form, select 
Paste from the shortcut menu. 

3. To remove elements from the DrawList, should you make a mistake or 
change your mind, select the redundant elements in the DrawList 
(using the  (shift) and Ctrl keys in the normal Windows-compliant 
way) and select the required Edit>Remove> option from the DrawList 
form’s pulldown menu. 

Repeat Steps 1 to 3 until the DrawList contains all of the required 
elements. 

Edit>Delete Drawlist removes the specified elements from the display 
permanently; in effect, it removes them from the Addlist of the Model 
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Data, so that they are no longer available for displaying. You can only 
restore these elements to the displayed model by reloading the data from 
the source files. 

9.2 Changing the Display of Drawlist Selections 

When the DrawList shows those elements whose display characteristics 
you want to change, use the Edit options from the DrawList form’s menu 
bar to change their appearance thus: 

Edit>Make Drawlist>Visible adds the specified elements back into the 
display (assuming that they are currently invisible). 

Edit>Make Drawlist>Invisible removes the specified elements from the 
display. 

Edit>Make Drawlist>Translucent causes all the specified elements to be 
shown in a translucent state, so that objects behind them can be seen as 
well. 

Edit>Make Drawlist>Wireframe displays the specified elements in 
wireframe format, regardless of the currently defined Camera View 
representation. 

Edit>Make Drawlist AutoTag displays autotagging names ‘stencilled’ onto 
the specified elements (autotags appear on boxes and cylinders only). 
Edit>Make Drawlist UnAutoTag removes the autotag names. 

Edit>Make Drawlist>Change Materials… gives the Change Material (Drawlist) 
form, enabling you to change the material used to display the Drawlist 
members. See Chapter 8. 

9.3 Shortcut Menus on DrawList Members 

The following shortcut menu is available over items in the DrawList 
form: 
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Dynamic Focus 
On 

Dynamically moves the camera near to the selected 
item and orients the camera such that the item is in 
the centre of the View. 

Focus On As above, but without dynamic movement. 

Look At Re-orients the camera to look towards the identified 
element but with no movement of the camera. 

Move Close To 

Moves the camera to a short distance away from the 
identified element and looking at it. Unlike Focus On 
commands this operation does not attempt to fit the 
item in into the graphics window. 

Copy Copies the name of the selected item(s) to the 
clipboard. 

Paste Pastes the selected items into the list from the 
clipboard. 

Remove Removes the selected items from the list. 

Locate In Tree Locates the item in the Explorer window and makes 
it the active selected item in the Tree View. 

 

9.4 Defining a Clip Volume 

A clip volume (or limits box) defines a 3D rectangular volume within 
the model space, such that objects may be selected according to whether 
or not they fall partially or wholly within that volume. 

A clip volume is defined in terms of the spatial coordinates of two 
diagonally opposed corners. You may set up such a volume definition in 
one of the following ways: 

9.4.1 Defining Specific Clip Volume Coordinates 

1. Select Edit>Clip Volume>Edit… from the DrawList menu bar to display a 
Clip Volume Definition form. 

• To define a new clip volume, select Edit>New from the Clip Volume 
Definition menu. 

• To modify an existing clip volume, select Edit>Open from the Clip 
Volume Definition menu and then select, from the displayed list, the 
name of the clip volume to be edited. 
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The Current Clip Volume heading on the form shows the name of the 
current clip volume, or it shows *No Current Clip Volume* if you are 
creating a new clip volume. 

2. Define two diagonally opposed corners for the clip volume by entering 
specific coordinates in the two sets of text boxes, using the option 
buttons to toggle between North/South, East/West and Up/Down as 
necessary. (Alternatively use the pick and past facility to define the 
clip volume using elements selected from the observer view.) 

3. Select Edit>Save As to name and store a new clip volume definition (or 
to copy an existing one), or select Edit>Save to update the definition of 
an existing clip volume. 

9.4.2 Defining a Clip Volume on the Keyplan View 

You can define a clip volume graphically by picking points in a Keyplan 
View window. (This is often more convenient than calculating and 
entering specific coordinates.) 

1. Select Edit>Clip Volume>Edit… from the DrawList form to display a Clip 
Volume Definition form. 

2. Open a Keyplan View window (if not already open) by clicking the  
button in the toolbar. 

3. Select the  button. 

(If the button is already selected, deselect it and select it again.) 

4. The default size and position for a clip volume are such that the 
volume just encloses the whole of the content of the first model file 
read in. To change the dimensions of the current clip volume (whose 
outline is drawn in the Keyplan), drag its sides to the required 
locations in a plan or elevation view. To change the position of the 
current clip volume without changing its dimensions, position the 
pointer inside the clip volume and drag it to the required location. 

5. Note that as you edit the clip volume outline on the Keyplan, its 
defining coordinates are updated automatically on the Clip Volume 
Definition form. 

6. Select Edit>Save As… to name a new clip volume (or copy an existing 
one), or select Edit>Save to update the definition of an existing clip 
volume. Note that these options store the definitions internally for the 
duration of your current Review session only. They do not save the 
definitions in an external file. To list the names of all currently 
defined clip volumes, select Edit>Open. 
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To delete the current clip volume, select Edit>Delete from the Clip Volume 
Control form’s menu. 

9.5 Using a Clip Volume 

Having defined one or more clip volumes, you may then use them to 
remove selected parts of the design model from the display. Do this as 
follows: 

1. Use the Edit>ClipVolume>Clip> menu options on the DrawList menu to 
specify how the Observer View display is to be affected by one of the 
clip volumes. The choices available for clipping the displayed model 
are as follows: 

Outside and Section…  
This cancels the effects of any current clipping and then removes 
from the display all elements which are wholly outside the selected 
clip volume. Items intersected by the clip volume are sectioned and 
capped.  

Outside… 
 Only those elements which are wholly or partially inside the clip 
volume remain displayed. 

Inside… 
 Only those elements which are wholly outside the clip volume 
remain displayed. 

Local Inside… 
This leaves the effects of any existing clipping in force and then 
removes from the display all elements which are wholly or partially 
inside the selected clip volume. This allows you to remove separate 
parts of the design model in a progressive manner, effectively 
‘nibbling away’ unwanted parts of the display one by one. 

From Model files… 
This deletes all current model file data and then partially reloads the 
original files such that only those elements which are wholly or 
partially inside the current clip volume are reloaded. (Use this option 
with caution: use Clip Outside instead if you are likely to want to 
restore the full display in your current Review session without 
reloading the model file.) 

2. The use of any Clip Volume>Clip> option will display a form containing 
a list of all currently defined clip volumes. From the list, select the 
clip volume which you wish to use. 
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Alternatively, select the   button in the Keyplan View window and 
pick the required clip volume using the left-hand mouse button. 
Paste its name into the text box on the Select Clip Volume form by 
using the middle mouse button. 

9.6 Restoring a Clipped Display 

To remove all clip volume effects, thus restoring the full design model 
display, select Edit>Clip Volume>Undo Clipping from the DrawList menu. 

Note: This applies only to displays which have been clipped using the 
Edit>Clip Volume>Clip>Outside, Inside or Local Inside options. 
Displays clipped using the Edit>Clip>From Model Files option may 
be restored only by reloading the original data files. 
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10 Adjusting the Light Sources 

The model can be illuminated by any combination of ambient light and 
up to seven individual light sources. This chapter explains how to adjust 
the positions, colours and intensities of the light sources, and whether 
the lights cast shadows. 

 

To control the model lighting, click the Lighting button on the 
toolbar (or select View>Lighting Control). This will display a Light 
Definition form which allows you to set the characteristics of each 
light source. 

 

10.1 Setting the Type of Illumination 

Use the two option lists near the top of the form to select the light you 
wish to modify (Ambient, or Light 1 to 7) and the ‘type’ of light you wish 

to apply. Note that the  button switches the light on and off. 

Ambient light represents a non-directional light source illuminating the 
whole model. This affects all surfaces equally, irrespective of their 
positions. You can switch ambient light on and off, but you cannot 
change its properties. 

All the other lights can be set to the following types: 

• Infinite, Directional wrt Viewer gives a parallel directional light whose 
position is fixed relative to the observer’s eye point (like a light held by 
the observer). This is the default type for all lights. Both types of 
infinite light can cast shadows. 

• Infinite, Directional wrt Model gives a parallel directional light whose 
position is fixed relative to that of the model (like the sun). Both types 
of infinite lights can cast shadows. 

• Local lights represent omnidirectional light sources, usually positioned 
within the model (like an unshielded light bulb fixed to part of the 
model’s structure). These provide local illumination of surfaces which 
are orientated towards the position of the light source and have fixed 
positions with respect to the model. 
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• Spot Light gives a cone of light from a given position along a given 
direction.  

Each light source is defined in terms of its intensity, its colour, and its 
direction (for a parallel source at infinity) or its position (for a local point 
source). 

10.1.1 Setting the Intensity and Colour 

For all lights except Ambient, use the option list near the top right-hand 
corner of the form to specify the type of illumination for the current light. 

Use the Intensity sliding scale and the Choose… button (to give the 
Windows Colour form) to set the overall intensity and the colour mix for 
the current light. The chosen colour will appear in the box adjacent to the 
Choose… button. 

10.1.2 Setting the Direction or Position 

Click the Edit Position button on the Light Definition form. This will 
display a Light Position form. 

Use the Positioning option list to select the light whose position you wish 
to modify. (This need not be the same as that selected on the Light 
Definition form and is not, of course, applicable to Ambient light.) Having 
set the required options, Apply the form. If you select a light which has 
been defined as Infinite, only the Direction controls on the form will be 
available to you; if you select a light which has been defined as Local, 
only the Position Light At controls will be available. 

4 Setting the Direction of an Infinite Light Source 

To set the direction of a parallel light, either type your required settings 
directly into the Bearing and Elevation text boxes, or use the 
corresponding graphical controls. 

When setting the direction of an Infinite, Directional wrt Model light, the 
bearing and elevation settings define the absolute direction of that light. 

When setting the direction of an Infinite, Directional wrt Viewer light, the 
bearing and elevation settings are defined relative to a viewer looking 
North. This principle also applies when manipulating Infinite, Directional 
wrt Viewer lights in the Keyplan views. The default direction for Infinite, 
Directional wrt Viewer lights is for them to shine from behind the 
viewer’s right shoulder. 

10-2 VANTAGE Plant Design Review Version 6.2 
User Guide 



Adjusting the Light Sources 

4 Setting the Position of a Local Light Source 

To set the position of a local point source at the origin of an element in 
the display, enter the name of the element in the Position Light At text 
box. As an alternative, you may position the currently selected light 
source (the active light) by using the Keyplan View window. To do so, set 

the Lighting control button (  ) in the Keyplan to On and then drag the 
displayed light source to the required position. The position of the 
current light is shown in the Keyplan thus: . 

4 Setting the Properties of a Spot Light 

To set the direction and position of a spot light, either type the settings 
directly into the Bearing and Elevation text boxes, or use the adjacent 
controls. 

The Spread option controls the light cone angle. The smaller the angle 
the narrower the cone of light. 

The Exponent option controls how the light intensity falls off from the 
centre of the light cone to the outer surface of the cone. The minimum 
value is 0, which gives a gradual fall-off in intensity; the maximum value 
is 1, which gives a sharp fall-off in intensity.  

Exercise:  

(Tip: The easiest way to check the current settings is to switch each light 
on in turn, with all others off, and observe the effect on the displayed 
model as you change the light parameters.) 

Use the Light Definition form to set up white light for Ambient and at 
least one of each of the other types. For example, set Light 1 to be 
Infinite, Directional wrt Viewer; set Light 2 to be Infinite, Directional 
wrt Model; and set Light 3 to be Local. 

Switch on each light source in turn (with all others off) and, for each non-
ambient light, adjust its position or direction (as appropriate) using the 
Light Position form so that it clearly illuminates the model. Observe the 
effect on the illumination of the Observer View as you rotate the model. 

Now switch on different combinations of light sources and again observe 
the effects on the Observer View model. If you wish, try changing the 
colour of one or more lights. 

Finally, use the Keyplan View, with the Lighting control button On, to 
move the local light(s). Select the Continuously Update Graphics button ( 
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 ), so that you can see the effect of moving the light source as you do 
so. 

 

10.2 Shadows 

The Shadowing option list on the Light Definition form is used to specify 
that an infinite light will cast shadows. The Shadowing option cannot be 
used for local or spot lights.  

The most efficient use of shadows is a static shadow from a light fixed 
with respect to the model. Unfortunately a static shadow cannot reflect 
the effect of shadows from moving groups; in this case dynamic shadows 
should be used. 

The larger the Observer View window, the better the shadow resolution; 
but the resolution of shadows is limited and poor results are sometimes 
inevitable. The larger the Observer View window, the longer the time 
taken to draw the shadow. 

To obtain the best possible performance and resolution of shadows, these 
guidelines should be followed: 

• Use static shadows. 

• Put the Observer View into Fullscreen mode (select Tools>Options>Full 
Screen), so that the shadow is created at the maximum possible 
resolution. 

• Leave Fullscreen mode and resize the Observer View to a smaller size. 
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11 Identifying Objects in the Model 

This chapter tells you how you can identify the various objects which 
make up the displayed design model. It also explains how to carry out 
some related functions. It covers the following aspects: 

• Identifying primitives or components by picking them with the mouse 
pointer. 

• Tagging and autotagging primitives or components with 
automatically generated identifiers. 

• Labelling primitives or components with user-defined texts. 

• Deriving the distances between two points (which may be either the 
origins of specified elements or specified points of the model’s 
surfaces). 

11.1 Picking Objects with the Mouse Pointer 

To identify any object which is visible in the Observer View, position the 
pointer within the object and press the left-hand mouse button. The 
name and model coordinates of the object will be displayed in the status 
for as long as you keep the button depressed.  

To identify several objects in turn, keep the button depressed while 
moving the pointer from one object to another. When you release the 
mouse button, the name of the currently selected element is copied to the 
paste buffer; you can then paste it into any text box by using the middle 
mouse button.  To specify how names of picked elements are to be 
represented, select Tools>Options>Preferences and, on the resulting 
Preferences form, Selection tab set Graphical Selection to Normal or Pick 
Significant Element.  

• Normal mode stores the full name of the element down to primitive 
level; for example, BOX 1 OF /VESS1. 

• Significant Element mode stores the name only down to significant 
element level (that is, down to the first / in the name text); for 
example, /VESS1. 
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In advanced picking mode (click on the  icon on the toolbar), 
holding down the Ctrl key allows multiple objects to be displayed in the 
Observer View. When this mode it active an element will remain 
highlighted when it is selected.  

Using the Ctrl key when in advanced picking mode will add the following 
to the shortcut menu: 

 

Add to Selection displays a pop-up menu containing the owners of the 
element under the mouse. This allows for any of the owners of the item 
under the mouse to be added to the selection. Clear Selection clears any 
selected elements. It is also possible to clear the selection by clicking on 
blank space, away from any model elements.  

11.2 Tagging and Autotagging Objects 

The tagging and autotagging functions allow you to show an object’s 
name against it in the display. This lets you identify a component within 
the plant model easily, without having to pick it using the pointer. 

The distinction between the two facilities lies in the way the name text 
appears in the views: 

• Tagging shows the naming text in a rectangular frame which is 
positioned near the object. This text always appears orthogonal to the 
view direction as you manipulate the model. If the selected object has 
not been named, the lowest named element directly above it in the 
database hierarchy will be used to define the tag text. 

• Autotagging (which applies only to box and cylinder primitives) 
shows the name as though it were stencilled onto the side of the 
element. If the element is large enough, the name repeats along its 
length so that it is always visible even when you can see only part of 
the object in the view. Only the significant part of the full PDMS 
name, i.e. the text after the first / character, is shown. 

11.2.1 Tagging 

To add a tag to an object: 

1. Select Tools>Options>Tag to display a Tag Element form. 
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2. In the Name… text box, enter the name of the object to be tagged. The 
easiest way to do this is usually by using the pick-and-paste 
technique. 

3. Click the Tag button. 

To remove a tag from an object: 

1. Select Tools>Options>Tag to display a Tag  Element form. 

2. Click the Remove button to display a Remove Tag form which 
includes a list of all currently tagged elements. 

3. Select the elements whose tags are to be removed and click the 
Remove button. 

Use the Show All Tags check box to toggle between showing and hiding all 
current tags. 

11.2.2 Autotagging 

To add autotagging to one or more objects:  

1. Use the Edit>Make All>Autotag menu to set autotagging on. 

2. Select Tools>Options>Preferences menu to display a Preferences 
form. 
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3. On the Camera Display tab, set the Maximum font height, Minimum 
font height and Repeat spacing (for repeating the name along the 
length of the object) in the current units of measurement. The 
actual font height used is derived automatically from the 
dimensions of the object on which it is displayed; if this would 
exceed the maximum setting, the height is scaled down to that 
maximum; if it would be less than the minimum setting, the 
autotagging text will not appear on that object. If you set the Repeat 
spacing to less than the length of the naming text (eg to zero), the 
name will repeat with one character space between each string. 

4. The two option buttons control which surfaces of the primitive the 
name is shown on. Horizontal Tagging (the default) adds the name to 
the sides of boxes and to two diagonally opposed sides of cylinders. 
Horizontal and Vertical Tagging also shows the name on the top and 
bottom of boxes and on the other two sides of cylinders. 

5. Click Apply to display the autotagging names on the selected items. 

To remove autotagging from all objects, use Edit>Make All>UnAutotag 
menu. 

11.3 Labeling Objects 

The labelling function allows you to attach a line of descriptive text to an 
object in the display. 

To add a label to an object: 

1. Select Tools>Options>Label… to display a Label Element form. 

2. In the Name text box, enter the name of the object to be labelled. 
The easiest way to do this is usually by using the pick-and-paste 
technique. 

3. In the Label text box, enter the descriptive text which is to be 
displayed next to the object. 

4. Click the Label button. 

To remove a label from an object: 

1. Select Tools>Options>Label to display a Label Element form. 

2. Click the Remove button to display a Remove Label form which 
includes a list of all currently labelled elements and their associated 
labelling texts. 

3. Select the elements whose labels are to be removed and click the 
Remove button. 
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To see a list of all currently labelled objects, together with their 
associated labelling texts, click the Report… button to show the Report On 
Labels form. 

Use the Show all labels check box to toggle between showing and hiding 
all current labels. 

11.4 Measuring Distances in the Displayed Model 

You can show the calculated distance between two points in the 
displayed model in either of two ways: 

• As the distance between the origins of two specified elements. 

• As the distance between two selected points on the model’s surfaces 
(which may be on different elements or on the surface of a single 
element). 

11.4.1 Distances Between Origins of Elements 

This option allows you to specify any two elements and calculate the 
distance between their origins. 

1. Select Tools>Measure>Origin to Origin. 

2. In the From… and To… text boxes on the resulting form, enter the 
names of  the objects whose separation is to be calculated. The 
easiest way to do this is usually by using the pick-and-paste 
technique. 

3. Click the Measure button to carry out the calculation. 

Both the direct origin-to-origin distance and the horizontal projection of 
this distance (horizontal true distance) will be shown on the form. The 
form will also show the displacement of the second origin (the To entry) 
relative to the coordinates of the first origin (the From entry). 

If the Show Measure Rod box is checked, the line of measurement and the 
associated data will be shown on the Observer View display. To remove 
this from the display, uncheck Show Measure Rod. 

Note: Only the most recent measurement will be shown on the display 
at any time. 

11.4.2 Distances Between Points on Surfaces 

This option allows you to pick any two points on the surfaces of objects in 
the Observer View and calculate the distance between them. These points 
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may be on the surfaces of different objects, or you can pick two different 
points on the surface of a single object. 

1. Select Tools>Measure>Surface to Surface. 

2. To initiate a new measurement, click the Measure button. 

3. When prompted, use the left-hand mouse button to pick the two 
points whose separation is to be calculated. The calculation will be 
carried out as soon as you have picked the second point. 

Note that you cannot pick a point in free space; both points must lie 
on the surfaces of elements within the model. For maximum 
accuracy, use the Pan/Rotate/Zoom functions to display a close-up 
view of each part of the model in which you wish to pick a point. 

Both the direct point-to-point distance and the horizontal projection of 
this distance (horizontal true distance) will be shown on the form. The 
form will also show the displacement of the second point relative to the 
coordinates of the first point. 

If the Show Measure Rod box is checked, the line of measurement and the 
associated data will be shown on the Observer View display. To remove 
this from the display, uncheck Show Measure Rod. 

Note: Only the most recent measurement will be shown on the display 
at any time. 
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12 Working with Groups (Including the Scale 
Man) 

This chapter explains how you can link displayed elements together into 
logical groups, so that you can manipulate them collectively. It covers 
the following aspects: 

• Defining a group in terms of its constituent elements. 

• Manipulating a group as a composite entity. 

• Checking for clashes between a moving group and other objects 
within the model. 

• Using the Scale Man (a special predefined group). 

• Defining and positioning signboards carrying text and/or graphical 
images in the display. 

The principal use of the group function is to allow you to move a 
collection of elements together as part of an animation sequence, as 
explained in Chapter 13. 

12.1 Using the Groups Form 

 

All group definition and manipulation functions are controlled via 
the Groups form. To display this, click on the Groups button in the 
toolbar or select View>Groups.  
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12.2 Defining and Positioning a Group 

12.2.1 Defining the Group’s Constituent Items 

 

A group may contain any number of objects in the design model, from a 
single primitive up to the whole model. To create a new group, click New 
Group… in the top-most panel of the Groups form, enter the name of the 
group in the resulting Name Group text box and click OK. 

To populate the group, click Pick Contents from Observer… in the Contents 
panel of the Groups form and click on objects in the Observer View that 
you wish to add to the group (the pointer will change to a ‘hand’ symbol ( 

 ). Click Pick Contents from Observer… again when you have finished. 

When in this mode the shortcut menu for elements in the Observer View 
will contain the following extra entries: 
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Add to Group displays a popup menu containing the owners of the item 
under the mouse. This allows for owning elements to be added to the list.  

Exit Group Add exits from the Pick Contents from Observer mode. 

Alternatively, select the elements in the Explorer view that you wish to 
group, Copy the elements (shortcut menu) in the Explorer window and 
Paste them (shortcut menu) into the Contents panel of the Groups form. 
(Note that standard Windows selection techniques can be used here to 
add several elements into the group contents list with a single paste 
operation.) 

Note:  When the Scaleman group is selected the Contents panel is not 
visible. This is because it is not possible to modify the contents of 
this group.  

To modify an existing group, click on the required group in the top panel 
of the Groups form. Add new members to the group as explained above, 
or remove members from the group by selecting the member to be 
removed and clicking on Remove Selected.  

The name of an existing group may be changed by clicking on the 
required group in the top panel of the Groups form and selecting Rename 
from the shortcut menu. 

Focus on Group moves the Observer View to the group and orients the 
camera to look at it. 

12.2.2 Storing the Group Definition 

Before you carry out any manipulation of a new group, you must store its 
definition so that it becomes available in the selection lists of the 
relevant forms. To do so, click on the required group in the top panel of 
the Groups form, click on Save As…, name the group in the resulting Save 
Group text box and click OK. Note that these options store the definitions 
internally for the duration of your current Review session only. They do 
not save the definitions in an external file.  
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12.2.3 Positioning the Group 

4 Defining the Group Origin 

 

Using the Group Settings panel of the Groups form, enter the coordinates 
of the point which is to be treated as the origin in the North/South, 
East/West and Up/Down text boxes. Alternatively, enter the name of an 
element whose origin corresponds to the required point in the As Element 
text box. (Tip: Remember the pick-and-paste technique using the left-
hand and middle mouse buttons; an element name can also be pasted at 
this point after it has been copied from its selection in the Explorer.)  

4 Positioning the Group Origin 
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Using the Position panel of the Groups form, enter the coordinates of the 
point to which you wish to move the origin in the North/South, East/West 
and Up/Down text boxes. Alternatively, enter the name of an element 
whose origin corresponds with the required point in the Position Group At: 
text box. Pressing Enter at this point will cause the group to move in the 
Observer View. Click Reset Position to reset the group position to the group 
origin. 

12.2.4 Listing and Removing Group Definitions 

All groups defined for the current session will be displayed within the top 
panel of the Groups form. To delete a group, click on the group in the top 
panel of the Groups form and click Delete Group. 

Note: You should not try to delete the Scaleman definition. 
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12.3 Manipulating a Group 

 

You can manipulate a group, as a single entity by using graphical 
controls on the Manipulation panel of the Groups form, by using the 
locator handle, or by using the Keyplan View. 

12.3.1 Manipulation Using Graphical Controls 

The rotational movement controls (for changing the Bearing, Elevation and 
angle of Roll) operate in the same way as those for manipulating the 
Observer View.  

The translational movement controls (for changing the position of the 
group’s origin) are similar to the Pan controls used for manipulating the 
Observer View, but include two additional arrow controls to move the 
origin Forwards or Backwards: 
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The arrowed regions behave in similar ways to the corresponding screen 
regions used for panning the Observer View thus: 

• The direction of movement depends on which arrow-box the pointer 
is in. 

• In Continuous mode (Classic view manipulation mode only), the extent 
of movement depends on the position of the pointer within the arrow-
box: the closer it is to the tip of the arrow head, the larger each 
translational step. The maximum step size corresponds to the current 
translational increment for groups: you can change this, if necessary, 
by first entering the required value in the Movement Increments text 
box of the Group Settings pane. 

If Continuously Update Graphics is selected, movement of the group will be 
shown continuously as you use the controls. If Continuously Update Graphics 
is not selected, movement will only occur when you release the mouse 
button. 

If Step Increments is selected, translational movements using the arrow 
controls will move the group’s origin by the amount defined by the 
current translational increment for groups. If Step Increments is left 
clear, movement is in Continuous mode and is proportional to the position 
of the pointer along the arrow’s axis. 

Note: To modify the extent of each rotational or translational increment 
temporarily, hold down the  (shift) key to reduce the increment 
by a factor of 10 (giving a finer control) or hold down the Ctrl key 
to increase the increment by a factor of 10 (giving a coarser 
control). 

12.3.2 Manipulation Using the Locator Handles 

 

(In the Group Settings pane.)In this manipulation mode, a group can be 
moved or rotated dynamically by dragging with the mouse pointer. The 
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Locator Handles are displayed, at the group origin, by selecting Enable 
Graphical Modification on the Group Settings panel on the Groups form.  

 

12.3.3 Moving a group along a straight line 

1.  Press and hold down the left- or right-hand mouse button on a linear 
movement handle. 

2.  With the mouse button still held down, move the pointer in the 
direction of the movement handle. The group will follow the 
movement of the pointer. 

Graphical feedback will be given, showing the distance moved. The 
movement will be in increments, as defined from the Manipulation 
Increments (Translation) text box of the Item Manipulation panel of the 
Preferences form. 

The original position of the locator handle will also be marked. See 
below. 
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Locator handle reduces to linear
drag handle with arrowhead

Original position of element

Feedback on distance moved

 

At any point during the drag pressing Esc will cancel the action and 
return the group to its position before the drag was initiated.  

When the locator handle is active the group will be highlighted in wire 
frame and the locator handle will be displayed at the origin of the group. 
An example of this can be seen below.  

 

A shortcut menu is available on the linear movement handle prior to a 
drag. The Move Handle options enable the drag handle to be moved. 
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Enter Value… Brings up the Locator Handle – Enter Value 
form which enables you to enter an explicit 
distance to move the group in the direction of 
the handle. 

Set 3D Position… Brings up the Locator Handle – Enter Value 
form which enables you to move the group to 
an explicit position. Clicking Preview… will 
move the group as specified. Clicking Ok will 
confirm the move. 

Set Increments Brings up the preferences form which 
enables you to set the movement and rotation 
increments for the Locator Handle 

Move Handle 
>Enter Value… 

Brings up the Locator Handle – Enter Value 
form which enables you to enter an explicit 
distance to move the handle in the handle 
direction. 

Move Handle 
>Set 3D 

Position… 

Brings up the Locator Handle – Enter Value 
form which enables you to move the handle 
to an explicit position. Clicking Preview… will 
move the handle as specified. Clicking Ok will 
confirm the move. 

Move Handle 
>To Group Origin 

Resets the handle position to the group 
origin. 

Cancel Cancels the shortcut menu. 

A further shortcut menu is available on the linear movement handle 
during a drag: 

 
 

Move Here Moves the group by the amount specified by the drag 
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Cancel Cancels the shortcut menu. 

12.3.4 Moving a group in a plane 

1.  Press and hold down the left- or right-hand mouse button on a planar 
movement handle. 

2.  With the mouse button still held down, move the pointer as required. 
The group will follow the movement of the pointer, constrained to be 
within the selected plane. 

Graphical feedback will be given in the form of a triangle, displayed on 
the current constraint plane between the original position of the handle 
and the current position. The relative movement distances are shown on 
the sides of the triangle. All values are shown in the current selected 
units. The Locator Handle changes to a simpler version of the full handle 
to show the plane of movement as shown below. 

Locator handle reduces to the planar handle
and two linear drag handles in the drag plane

Original position
of element

Feedback on distance moved

 

A shortcut menu is available on the planar movement handle prior to a 
drag. The Move Handle options enable the drag handle to be moved. 
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Enter Values… Brings up the Locator Handle – Enter Value form 
which enables you to enter explicit distances to 
move the group along the selected plane. 

Set 3D Position… Brings up the Locator Handle – Enter Value form 
which enables you to move the group to an 
explicit position. Clicking Preview… will move 
the group as specified. Clicking Ok will confirm 
the move. 

Set Increments Brings up the preferences form which enables 
you to set the movement and rotation 
increments for the Locator Handle 

Move Handle 
>Enter Values… 

Brings up the Locator Handle – Enter Value form 
which enables you to enter explicit distance to 
move the handle along the selected plane. 

Move Handle 
>Set 3D Position… 

Brings up the Locator Handle – Enter Value form 
which enables you to move the handle to an 
explicit position. Clicking Preview… will move 
the handle as specified. Clicking Ok will confirm 
the move. 

Move Handle 
>To Group Origin 

Resets the handle position to the group origin. 

Cancel Cancels the shortcut menu. 

A further shortcut menu is available on the planar movement handle 
during a drag: 

 

Move Here Moves the group by the amount specified by the drag 

Cancel Cancels the shortcut menu. 

12.3.5 Rotating a group about a selected axis 

1. Press and hold down the left- or right-hand mouse button on a 
rotation handle. 

2. With the mouse button still held down, move the pointer along the arc 
of the rotation handle. The group will follow the movement of the 
pointer. 
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Graphical feedback will be given, showing the angular displacement. The 
original orientation of the locator handle will also be marked. 

 

 

As the mouse moves over a rotation handle, the pointer changes to the 
rotation drag symbol, and half of the rotation handle arc changes to show 
two arrows. 

A shortcut menu is available on the rotation handle prior to a rotate. The 
Rotate Handle options enable the drag handle to be rotated. 
 

 

Enter Value… Brings up the Locator Handle – Enter Value 
form which enables you to enter an explicit 
angle to move the group through. 

Rotate Handle 
>Enter Value… 

Brings up the Locator Handle – Enter Value 
form which enables you to enter an explicit 
angle to move the handle through. 

Rotate Handle 
>To World 

Aligns the locator handle with the World 
axis. Useful when, for example, it is 
necessary to move the group up but the local 
orientation of the handle does not have a 
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handle pointing directly up. 

Rotation Handle 
>To Group Orientation 

Aligns the locator handle with the 
orientation of the group. 

Set Increments Brings up the preferences form which 
enables you to set the movement and 
rotation increments for the Locator Handle 

Cancel Cancels the shortcut menu. 

A further shortcut menu is available on the rotation handle during a 
drag: 

 

Rotate Here Rotates the group by the angle specified by the 
drag 

Cancel Cancels the shortcut menu. 

12.3.6 Moving the Handles using the ‘h’ key 

Rather than use the ‘explicit’ movement facilities contained in the handle 
shortcut menus, the handles can be moved ‘freehand’ by using the ‘h’ key. 

Press and hold down the ‘h’ key while starting either a drag move or a 
drag rotate of the handle. Once the move is initiated it is not necessary to 
keep the ‘h’ key pressed. The drag can then carry on as normal and the 
handle will move while the group remains stationary. Once the drag is 
completed by releasing the mouse the handle move will be committed. 
Subsequent drags with the locator handle will affect the group as normal 
unless the ‘h’ key is pressed.  

12.3.7 Resetting the Position and Orientation of a Group 

Selecting another group in the Select Group form will set the locator 
handle to the origin and orientation of the selected group with no offsets.  

Moving the group via the Group Control form will reset the position and 
orientation of the locator handle to that of the group.  

Resetting the position of the group will reset the position and orientation 
of the locator handle to that of the group.  
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Setting the origin of the group will reset the position and orientation of 
the group and set the position and orientation of the locator handle to the 
origin and orientation of the group.   

12.3.8 Varying Group Manipulation Graphical Performance 

Options are available on the Preferences form 
(Tools>Options>Preferences) for varying the graphical performance when 
working with graphical manipulation of groups. 

 

Enable Overlay Planes defines that overlay planes will be available for use 
by Review. (Greyed out if no there is no overlay plane facility.) 

Enable High Performance Locator Handle, if selected, the Locator Handle 
will be drawn in black and white, or in the overlay planes if they are 
enabled (see above).  

If Enable Dynamic Clashing is selected and Clash Detection mode is on 
(see section 12.4), then clashes will be shown dynamically (by a wireline 
red box) as the group is moved. 

Draw Clash Highlighting On Top determines whether the red line feedback 
for clashing is always drawn on top of the model or if it is drawn to fit 
round the clashing elements. 

Draw Selection Highlighting On Top. When selected, all the lines that 
highlight an element will be drawn on top of all other model elements, so 
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the lines are visible all the time. When unselected, the highlighting lines 
are drawn in the model space, so other geometry can obscure them. 

12.3.9 Manipulation Using the Keyplan View 

You may control all rotational and translational movements of the 
current active group from within the Keyplan View. The type of movement 
which you can carry out is determined by which of the Keyplan’s Group 
Control buttons is set to On. These buttons, identified by a G symbol, are 
mutually exclusive, so that you must switch the current selection Off 
before you can switch a different one On. Their functions are as follows: 

• To reposition the group’s origin, select the  button. The current 
origin will be shown by a set of three axial arrows in each view. Drag 
the origin to the required position. 

• To change the group’s bearing and/or elevation, select the  button. 
The current orientation will be shown by axial arrows in both Keyplan 
views. To change the bearing, drag the ‘arrowed’ axis to the required 
direction in the plan view. To change the elevation, drag the ‘arrowed’ 
axis to the required direction in the elevation view. 

• To change the group’s angle of roll, select the  button. The current 
angle will be shown by axial arrows. Drag the axes to rotate the group 
to the required angle. 

Exercise:  

Create a group comprising several adjacent objects in the displayed 
model and store its definition with any name you choose. List the 
available groups and note that both your newly named group and the 
default scale man group are shown. 

Move your group within the model, using both the graphical controls on 
the Groups form and the Keyplan facilities. Change, in turn, the group’s 
origin, bearing, elevation and angle of roll. 

 

12.4 Clash Detection 

As you move a group within the design model, Review can show you each 
object which the group touches during its motion. This facility is useful, 
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for example, to check that there is sufficient clearance to remove a piece 
of equipment from its normal location for maintenance. 

For the purposes of checking whether or not a clash occurs, each group is 
assumed to occupy the whole of an enclosing rectangular limits box. The 
individual outlines of the objects within the group are ignored, thus 
tending towards a fail-safe mode of clash detection. 

To switch clash detection on or off, select Enable Clashing on the Group 
Settings panel of the Groups form.. When clash detection is selected , and 
a yellow box is drawn round the group to indicate its limits box. 

When clash detection is switched on, each object which is touched by a 
moving group is highlighted in red in the Observer View display. If the 
group is moving continuously and is clashing, then the highlighting 
flashes. 

12.5 The Scale Man 

The scale man is a special group of primitives representing a model of a 
man holding a 2 metre pole to give an indication of scale. The scale man 
definition is supplied as part of the standard program and is always 
available from the main menu. 

12.5.1 Displaying the Scale Man 

If the man does not appear in the display, select 
Tools>Scaleman>Make>Opaque and ensure that the man’s position lies 
within the displayed view. 

12.5.2 Moving the Scale Man 

You can position and move the scale man within the model by using any 
of the group manipulation options. To access the appropriate controls, 
select Tools>Scaleman>. The man’s axes are such that the Forwards, 
Backwards, Up, Down, Left, and Right translations behave exactly as 
you would expect if you imagine yourself in the man’s position. 

By default, the scale man is normally the current active group. If, 
however, the Groups form is being displayed and the current active group 
is not the scale man, you can make the scale man the current active 
group simply by clicking on it in the group window. 
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The Groups form will then operate on the scale man. 

To return the scale man to his default position at any time, select 
Tools>Scaleman>Reset Position. 

To position the scale man at the observer’s eye point and set his 
orientation to that of the observer, select Tools>Scaleman>Set>Man To 
Observer. 

To change the observer’s position and orientation to those of the scale 
man, select Tools>Scaleman>Set>Observer To Man. This automatically 
sets the rotation mode to Eye and aligns the view direction with the scale 
man’s forward axis, so that the Observer View shows what the man is 
seeing. 

To position the scale man at the origin of an element, select 
Tools>Scaleman>Position At… and enter the element name on the form. 

To position the scale man on a surface, select Tools>Scaleman>Position 
On Surface and pick a position on an element using the left mouse button. 

12.5.3 Connecting the Scale Man and the Observer 

You can connect the position and orientation of the scale man to those of 
the observer, and vice versa, such that moving one moves the other 
automatically. The menu options for doing so, and their effects, are as 
follows: 

Tools>Scaleman>Connect>Man To Observer 

This causes the scale man to follow the observer whenever the Observer 
View is changed. All displayed graphical views will be updated to show 
the movement of the scale man through the model (which may slow the 
performance, since more views may need to be redrawn than in the 
unconnected state). 

You can still move the scale man independently, without changing the 
observer’s position, but if you then move the observer the scale man will 
be reset automatically to the new observer position. 

Tools>Scaleman>Connect>Observer To Man 
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This causes the observer to follow the scale man whenever the latter is 
moved, so that the Observer View always shows what the scale man is 
seeing. 

These menu options operate as toggles, so that consecutive selections 
connect and disconnect the scale man and the observer. A marker 
against each menu option indicates when the connected state is in force. 

The two methods of interconnecting the scale man and the observer 
operate independently, so that you can have either or both in operation 
at any time. 

12.6 Adding Signboards to the Display 

A signboard is a rectangular object, which can show any user-defined 
text or image on its surface, which you can add to the displayed model. 
You can position and orientate the signboard explicitly, or you can 
position it at the surface of an existing object in the model. 

12.6.1 Creating a Signboard at an Explicit Position 

1. First, pick an object in the Observer View at which you wish to 
position the signboard. Alternatively, select the object in the Explorer. 

2. Select Tools>Signboard>Create At… from the main menu bar. You will 
see a New Signboard form on which you must enter a name to identify 
the new signboard. When you OK this form, you will see Position 
Signboard At… form.  

3. On the Position Signboard At… form, enter the coordinates of the 
centre of the signboard. To derive this data from an existing object, 
pick-and-paste the object name into the text box near the top of the 
form and then OK the form.  

4. Use the Signboard Definition form to define the text and background 
for the signboard. 

12.6.2 Creating a Signboard at the Surface of an Existing Object 

1. Select Tools>Signboard>Create On Surface. When prompted, pick a 
point on the surface at which you want to position the centre of the 
new signboard (the signboard will actually be positioned slightly in 
front of the picked surface, so that it is displayed clearly). 
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2. You will see a New Signboard form on which you must enter a name to 
identify the new signboard. When you OK this form, you will see a 
Signboard Definition form. 

3. Use the Signboard Definition form to define the text and background 
for the signboard. 

 

12.6.3 Defining a Signboard’s Appearance 

A signboard can include any user-defined text as its foreground and any 
predefined material (which can include a graphical image) as its 
background. To define these, select Tools>Signboard>Edit. You will see a 
Signboard Definition form whose title bar also shows the name of the 
current signboard (use the Edit>Open option to edit a different signboard 
if required). 

1. Enter the signboard dimensions in the Width and Height text boxes. 

2. In the Text area, type any text which is to be displayed on the 
signboard. To enter multi-line text, press Return at the end of each 
line; multi-line text always has centred justification. 
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3. Use the Choose… button to change the text colour as required, using 
the Windows Color form.  

4. To change the signboard background, select Edit>Background>Set 
Material from the Signboard Definition menu. Pick the required 
material from those displayed on the resulting form. The overall effect 
of the current text and background is shown in the graphical area 
near the top left of the Signboard Definition form If you do not set a 
background material (or if you use the Background>Remove Material 
option), the text will appear to float in space or, more usefully, will 
appear to be printed onto the surface of any object immediately 
behind the signboard. 

5. To apply the form’s settings to the current signboard in the displayed 
model, select Edit>Save. All data relating to the signboard is stored as 
a group. 

12.6.4 Moving a Signboard 

Since a signboard, with its associated text and background material, 
behaves as a group, you manipulate the signboard like any other group. 
To reposition or reorientate a signboard, select Tools>Signboard>Edit  to 
show the Signboard Definition form, then use the Position menu options on 
the latter form to move the current signboard. The choices are as follows: 

Edit>Position>Manipulation shows a Signboard Manipulation form which 
includes the same controls as those used to manipulate the scale man. 
Because you will often want to move a signboard by small amounts only, 
the step increment for moving a signboard is set independently of the 
global increment used for other manipulations. To change the step size 
for signboards, check the Step box. The maximum step size corresponds 
to the current translational increment for groups: you can change this, if 
necessary, by first selecting Edit>Increments from the menu on the Group 
Control form.  

Position>Position At shows the Signboard Position form, enabling you to 
position the Signboard by typing in coordinates or by using the pick and 
paste facility. 

Position>Position On Surface prompts you to pick a point on a surface 
where you want the centre of the signboard to be. 

12.6.5 Editing a Signboard 

Select Edit>Open from the pull-down menu on the Signboard Definition 
form to display an Open Signboard form listing all currently defined 
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signboards. Select a signboard from the list and click OK to show its 
current data in the Signboard Definition form. 

Edit the settings for the selected signboard’s foreground text, background 
material, position and orientation, as required. 

To save the new settings under the same signboard name, thereby 
updating the signboard definition, select Edit>Save. 

To save the new settings under a new signboard name, thereby creating 
a new signboard based on the existing one, select Edit>Save As and enter 
the new name. 

12.6.6 Deleting a Signboard 

To delete an existing signboard, select Edit>Open from the pull-down 
menu on the Signboard Definition form, if necessary, to make it the 
current signboard, then select Edit>Delete to delete it.  
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13 Setting Up Animated Display Sequences 

This chapter explains how you can create a sequence of views by moving 
the observer (or a light or a group) progressively along a predefined path. 
You can then play back this sequence to create an animation which 
shows the effects of this movement. 

The steps to create an animated sequence are: 

1.  Define the object or group which is to be moved in a specific 
animation sequence. See Chapter 1 for details of working with groups. 

2.  Define one or more paths along which an animated object may be 
moved. 

3.  Play back the view sequence which would be generated as each 
specified object moves along its animation path, such that the 
Observer and Camera Views display the effect of the animation. 
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13.1 Defining a New Animation Path 

You define an animation path by specifying two or more points which 
correspond to the start and finish of the path and as many intermediate 
points as are needed to fix its shape. The actual path along which the 
animated object will move is interpolated between these points either 
linearly (giving a sudden change of direction at each point) or as a 
spline (giving a smooth transition from one section of the path to the 
next). 

As the animation path is defined, it is displayed in the Observer View – 
see below for an example: 

 

The animation path is drawn as a blue line through the view with the 
waypoints drawn as light blue squares. It is possible to click on a point to 
select it. The currently selected point will have its point number and time 
displayed. The ‘look to’ point will be displayed with a yellow cross and the 
look direction of the waypoint will be displayed in yellow. 

The Path Editing family of forms allows you to define and an animation 
path, An animation can then be played along the path – see section 
13.3. 
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To create a new animation path, click New Path… and enter the name of 
the path in the resulting New Path text box. 
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13.1.1 Defining a Path – Initial Settings 

Before you start to define a path through the model, carry out the 
following steps: 

1. Create a new path by clicking the New Path… link and providing a 
name for the path.  

2. Bring up the Path Settings panel on the Path Editing form. 

 

3. If you wish the animation path to be shown in the Observer View as 
you define it, select the Show Path in Observer check box. Selecting Show 
Waypoint Grid causes the Path Details panel to be displayed, giving the 
co-ordinates (and other attributes) of each waypoint to be displayed as 
it is created. Selection of waypoints in both the Observer View and the 
Path Details form is then synchronised so a point selected in the 
Observer View will be selected in the Path Details form and vice versa. 

Show Preview Camera shows the Animation Preview window, which shows 
the view from the currently selected animation waypoint – see section 
13.2.1  

Show Advanced Waypoint Creation form displays a form that contains 
advanced controls for creating waypoints – see section 13.1.4. 

13.1.2 Defining a Path Using the Observer View 

Animation waypoints can be inserted directly into the Observer View. To 
define such a path, carry out the following steps. 
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1. Begin by specifying the initial walkpath settings as detailed in section 
13.1.1. Ensure that the Show Path in Observer check box is selected. This 
setting enables the animation path to be shown in the Observer View. 

2. Manipulate the Observer View until the displayed view is as you want it to 
appear at the start of the animation sequence. 

 

3. Click Waypoint Placer… on the Waypoint Creation pane. To use the waypoint 
placer click an element surface in the Observer View to place an animation 
waypoint. The point will appear in the Observer View (as a blue triangle) 
as if a camera is placed at “person height” above the point on the surface 
clicked on. This allows for a quick definition of a walkpath by clicking on 
the points where the observer is to stand. 

Note: When using the waypoint placer to define an animation walkpath 
the look-to direction for waypoints will be kept updated to ensure that the 
camera is always looking along the path. Once the path is defined use the 
Locator handle to adjust the viewing direction at any of the waypoints. 

4. The definition of the point will be copied into the Path Details panel and the 
form will change automatically to allow you to define the next waypoint. 
The view through the camera at this point is shown in the Animation 
Preview window. 
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5. Repeat the preceding steps to define Point 2 at Time 1 second, and so 
on until you reach the end of the path. (Note: The term ‘second’ is 
used here to specify relative times only.) 

Alternatively, use the Track Position of Item options to specify whether you 
wish to attach the path definition point to the active Camera, Group or 
Light. It is sensible, but not essential, to define the path using the object 
which will be moved along it during the animation sequence. (See also 
section 13.2.6.) 

To change explicitly an entry in the Path Details table, double-click on the 
entry. All normal Windows facilities can then be applied to the content of 
the entry. Double-clicking on a Path entry allows you to select Spline or 
Linear, depending on the type of transition which you want from the 
current point to the next.  

Notes: Each Spline/Linear option applies from the current point to the 
next. If you change this smoothing mode at an intermediate 
point, the apparent direction of motion of the observer will 
change sharply at that point during the animation. 

 When adding waypoints to the path with a set velocity the 
calculations for the timing of waypoints on tight corners will 
attempt to keep a smooth pace round the corner. For example, 
while cornering on a landing on a flight of stairs. It is possible to 
adjust the cornering speed by increasing or decreasing the 
velocity. 

 If the speed around a corner is too fast or too slow it is  possible to 
adjust the speed of the cornering. In the Path Velocity pane select 
the range of waypoints for the corner and try different velocities 
over these points until the speed seems right. Note that it is also 
possible to play back the animation over only these points in the 
Animation Controls path – see section 13.3. This makes it easier to 
check the speed of the corner. 

13.1.3 Saving an Animation Path 

When you have completely defined the animation path, use the Apply 
Changes option in the top panel of the Path Editing form to name it and 
store it. 

Note that these options store the path definition internally for the 
duration of your current Review session only; they do not save the 
definition in an external file. To save the definition to an external 
text file, click Export Points to File… on the Path Settings pane. See also 
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Chapter 14, which tells you how to save animation path data in status 
files. 

13.1.4 Advanced Waypoint Creation 

 

Waypoint Number 

This section of the form is used to identify the number that the waypoint 
will be given. Waypoints can be inserted Before, After or can even Replace 
a given waypoint on the path.  
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Waypoint Time Settings 

The time settings that the waypoint will be inserted with are specified 
here. There are three ways to define the time: 

Fixed Interval – sets the time to be a fixed value from the time of the 
previous waypoint.  

Maintain velocity of – calculates the time setting of the waypoint using the 
specified velocity 

Midway between Points – this option is used for inserting waypoints in-
between two other waypoints. The time will be midway between the 
times of the previous and next waypoints.  

Waypoint Position 

Once the time setting is chosen the final thing to do is define the 
position. As with the Waypoint Creation panel on the Path Editing form 
there are different ways to do this.  

Waypoint Placer 

First there is the Waypoint Placer. This works in the same way as the 
waypoint placer from the Path Editing form. An extra feature for the 
advanced form is the ability to specify the height of the waypoint above 
the identified surface.  

Track the Position Of: 

As with the Path Editing Waypoint Creation pane, it is possible to define 
the waypoint position to be the same as a Camera, Group or Light. To do 
this: 

1. Select the Track the Position Of checkbox.  

2. Select the appropriate Camera, Group or Light. 

Once the Camera, Group or Light is in the desired position click on Insert 
Waypoint… to insert the point.  

Note:  When tracking an item the Position: and Orientation: panels  give 
feedback on where the point will be inserted. 

Enter Position Manually 

It is also possible to define an explicit position. To do this: 

1. Deselect the Track the Position Of checkbox. 

2. Expand the Position panel and enter the East, North and Up values 
of the point 

3. Expand the Orientation panel and enter the orientation as either a 
Bearing, Elevation, Roll or by using a Look At Centre position.  
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4. Click on the Insert Waypoint… link.  
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Path Representation 

It is also possible to define whether the point is entered as a spline or 
linear path. Use the With path representation: option lists to  specify a  Spline 
or Linear path for the position and look to position. 

13.2 Editing an Animation Path 

To edit an existing path, select the path icon from the display at the top 
of the Path Editing form. Carry out one or more of the following editing 
operations and then save the modified path definition. 

13.2.1 Manipulating a Waypoint 

To enable graphical modification of waypoints, by select the Allow 
Graphical Modification within the Path Settings panel of the Path Editing 
form. The locator handle will appear on the selected waypoint. The 
locator handle will be oriented to meet the current orientation of the 
waypoint. See the illustration below for an example. 

 

The locator handle can be used to reposition or reorientate the point, in a 
similar way to manipulation of Groups. See section 12.3.2 for details. 

To aid the visualisation of editing points, particularly when editing an 
animation path relating to a camera, the Animation Preview window will 
show the view through the camera at that point. An example of a view in 
the this window can be seen below. 
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The view in the Animation Preview window will update automatically 
when the locator handle moves or rotates the waypoint. 

Note:  If the Enable High Performance Locator Handle checkbox on the  
Preferences form (see section 12.3.8) is clear then the view will 
only update at the end of the drag with the locator handle. This 
setting is preferable for lower spec machines running large 
models. 

Further actions can be carried out on individual waypoints using the 
Actions for Point pane: 

 

Selecting a point in the Path Details panel and then clicking Focus on Point 
moves the Observer View near to the waypoint and orients the camera 
such that the waypoint is in the centre of the Observer View.  
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Selecting an item from the lists under Snap Item to Waypoint: and then 
selecting the appropriate option will change the position and orientation 
of the identified object to that of the waypoint. 

13.2.2 Deleting a Waypoint 

Select the waypoint you wish to delete in the Path Details pane, then click 
Delete Point in the Actions for Point pane. 

Alternatively, select the required waypoint in the Observer View and 
select Delete Waypoint from the shortcut menu on the point. 

13.2.3 Inserting an Additional Point 

 

To insert an additional point, select the point in the Path Details panel (or 
from the Insert After Point list in the Waypoint Creation pane) after which 
you wish to insert the new point. Click on Insert Waypoint. A new point 
will be inserted at a position derived from the Track Position of Item 
settings. The co-ordinates of the point can them be adjusted by double-
clicking on the Path Details table entries, and entering new values as 
required. 
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Alternatively, to insert an additional point via the Observer View, proceed 
as follows: 

1. In the Observer View, click in the path (the light blue line) where the 
new point is to be inserted. 

2. From the shortcut menu, select Insert Waypoint. The new waypoint 
will be inserted. If Allow Graphical Modification is selected in the Path 
Settings pane, the locator handle will be displayed on the new point to 
allow the point to be manipulated as desired. 

13.2.4 Shortcut Menus on Waypoints 

The following shortcut menu is available over animation waypoints in 
the Observer View: 

 

Focus on 
Waypoint 

Moves the camera near to the waypoint and orients 
the camera such that the waypoint is in the centre of 
the View. 

Delete Waypoint Deletes the waypoint. 
 

The following shortcut menu is available over animation waypoints in 
the Path Details grid: 

 

Dynamic Focus 
on Waypoint 

Dynamically moves the camera near to the waypoint 
and orients the camera such that the waypoint is in 
the centre of the View. 

Focus on 
Waypoint 

As above, but without dynamic movement. 
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Look at Waypoint Re-orients the camera to look towards the identified 
element but with no movement of the camera. 

Delete Deletes the waypoint. 

Bearing, 
Elevation, Roll 

Sets the grid to display orientation in terms of 
bearing, elevation and roll 

Look at Centre Sets the grid to display orientation in terms of Look 
position.  

 

13.2.5 Adjusting the Path Velocity 

 

The animation speed between any two points can be adjusted using the 
Set Path Velocity controls. Select the two points between which you wish 
to adjust the speed and click Perform Adjustment. The speed between 
subsequent points will remain at its current setting, and so the 
cumulative animation Time at each point will be adjusted accordingly. 
(The effect of this can be seen in the Path Details pane.) 

The animation time between a set of waypoints can be adjusted using the 
Shuffle Waypoint Times controls. To shuffle the times by a given time 
offset select the start waypoint along with the required offset from the 
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lists and click Perform Adjustment. This will shuffle the specified waypoint 
and all subsequent waypoints by the specified time offset. Note positive 
or negative values can be entered to increase or reduce (respectively) the 
animation times between the points. 

13.2.6 Specifying Object-Path Animation Pairs 

During the animation sequence, specified objects will be moved along 
predefined paths and the displayed views will be updated to show the 
effects as this movement takes place. Any valid type of object may be 
moved along any specified path, each object-path combination 
constituting an animation pair. More than one object may share a 
common animation path. 

The animated object may be any of the following: 

• The observer 

• Any group (including the scale man) 

• Any light source except ambient (particularly effective when this is a 
local light) 

To specify which objects are to be moved during the animation sequence, 
select from the Track Position of Item controls on the Waypoint Creation 
pane.. Select the item to be animated from the displayed list of objects 
and the path along which it is to be moved from the displayed list of 
currently defined paths. (Tip: Although a path may be associated with 
any camera, group or light, you will usually find it most useful if you 
define each path by using the appropriate object with which it is to be 
associated as an animation pair.) 

When you run an animation sequence, all animation pairs listed in the 
Animation Status form will be actioned simultaneously. 
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13.3 Running an Animation Sequence 

The Animation Control form allows you to play back a sequence of 
animation points along a previously defined path – see section 13.2. 

 
 

 
 

 
To run an animation sequence, first select from the top panel of the 
Animation Control form the object (Observer, Group or Light) that you wish 
to move along the path.  Clicking Add Group or Add Light allows you to 
select from a list of groups or lights. Having selected the object to move, 
clicking in the Along Path cell will produce a list of paths for you to select 
from. 
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13.3.1 Playback Options 

 

An animation sequence will be played ‘forwards’ and from the start of the 
animation to the end, unless you change these settings from the Play 
Backwards and Play between a time range controls.  

When you run an animation sequence, the animated objects will be 
moved along the defined paths and the views will be updated a 
predetermined number of times between each point on the path. By 
default, the view is updated 25 times between each pair of points so that, 
if the time interval between points is 1 second, the effective replay speed 
is 25 frames per second. 

 

Note: Although all animation times in Review are indicated in seconds, 
the actual animation rate depends on the conditions under which the 
replay sequence takes place (particularly upon the speed with which the 
display can be redrawn on your workstation). You should regard these 
timings only as relative values rather than as actual elapsed times. 
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 Normally, the video will be played as quickly and as smoothly as 
possible, regardless of the waypoint time settings. If you wish to 
play the video using the preset waypoint timing settings, select 
Realtime playback in Observer in which case the total animation 
time will be exactly that defined for the path. 

To change the number of view updates between each pair of points on the 
path, enter the required framerate in the fps text box. 

13.3.2 Running the Animation 

 

Use the following controls to stop and start the animation sequence as 
required: 

 runs the complete sequence once, from one end of the path to the 
other. 

 runs the sequence repeatedly, so that when the animated object 
reaches one end of the path it jumps to the other end and starts again. 

 stops the animation and displays the current frame. Click Play > to 
continue from the point at which you paused. 

 moves the display sequence on to the next frame when in Pause mode. 
This allows you to step through the sequence frame by frame for a 
detailed observation of particular parts of the model. 

 returns to the start or end of the animation sequence, depending on 
whether you are in Forward or Backward playing mode. 

 records the animation to AVI file or bitmap frames (see section 
13.3.5). 
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13.3.3 Showing Clashes 

To carry out continuous clash detection throughout the animated display, 
select the Enable Clashing check box on the Playback Options pane. 

All clashes encountered by animated groups during their progression 
along their paths will be shown by highlighting the clashing items. (This 
is equivalent to switching clashing on temporarily for every group; but 
note that groups are not clash-checked against each other.) 

13.3.4 A Shortcut for Starting and Stopping Animations 

To run an animation sequence without opening any animation forms, 
simply press the F5 function key while the pointer is in the Observer View 
window The animation sequence will use the animation path which is 
currently selected in the Path Editing form and will run using the current 
settings from the Animation Control form. (You must, of course, have 
previously defined at least one animation pair.) 

To pause the animation, press the F5 key again. Repeated use of this key 
will stop and start the animation alternately. 

To stop the animation completely, press the Esc key. 
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13.3.5 Recording an Animation Sequence to a Set of Files 

 

The Recording Options panel provides settings to use when recording 
animations. Options include whether to save to AVI file, bitmap frames 
or both, what screen size to use and the compression settings.  

Saving to AVI file 
To save to a digital AVI file select Save to AVI file and enter the name of 
the file in the text box. When the  button is pressed on the Animation 
Controls panel Review will start recording the animation direct to the 
AVI file.  

To specify the compression to use in the AVI select a compression codec 
from the Compression option at the bottom of the form. The options in 
this list reflect the codecs installed on the computer running Review. If 
the codec has properties that can be set the Properties… link will be 
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available; clicking on this link will display the property page for the 
codec.  

Saving the Individual Frames 
It is also possible to output the animation as a set of bitmap files 
containing each frame. To do this select Save Frame Images and specify a 
name prefix in the Frame image prefix text box. Also choose a file format 
type from the file extension drop down menu. Frames will be saved with 
names (for example) ‘Frame0001.bmp’, ‘Frame0002.bmp’ etc.  

Specifying the Frame Size 
The Frame Size section of the panel allows for setting of the resolution of 
the animation in pixels. It is possible to select a custom size or choose one 
of three pre-set image sizes (PAL, NTSC and Fullscreen).  

Oversampling 

Oversampling enables a higher level of detail to be used when creating 
the animation. Select the Enable Oversampling checkbox to produce high-
fidelity animations.   

 
 Exercise:  

Open the Path Editing form and define a new animation path through the 
displayed model. (Use the Group → Scaleman option and use Spline mode 
for all points.) Set three points first, and then insert a fourth point 
between the first two. Note how the point numbers and times are set 
automatically. Add more points to the path if you wish and then store the 
path definition as, say, Path 1 (note that names may include spaces). 

Use the Add Group option on the Animation Control form to add the scale 
man to Path 1. Ensure that the scale man is made visible in the Observer 
View (Tools>Scaleman>Make>Opaque). 

Open the Animation Controls panel and click . Notice how the display 
shows the progression of the scale man along your defined path. Pause 
the playback (  ) button)and select Play Backwards in the Playback 
Options pane. Click   again. Use the  /  buttons to look at two or 
three individual frames. Notice how the animation path is displayed 
when you pause the playback. 

Run the sequence again with Enable Clashing selected and watch what 
happens if the scale man (who now has his own limits box) hits the 
model. 
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Now dismiss/close the Animation Control and Path Editing forms and run 
the animation sequence again by using the F5 key, pausing the 
animation once or twice during its duration. 
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14 Widescreen Review 

 

Introduction 
 

A widescreen facility is provided which allows two or three sessions of 
Review to be linked together to present an image with a wide field of 
view (e.g. 120º). This facility allows Review to be used in Virtual Reality 
Theatres running two or three networked of a similar type. Typically the 
images would be projected onto a screen and may be passed through 
special video processing equipment to seamlessly blend the edges of the 
images together. 

14.1 Setting Up 

The required geometry of the views in each of the Review sessions 
changes with the system used to display the widescreen image. For 
example, the screen may be curved or a single flat surface. They 
geometry of the projector system and the screen(s) must be considered 
and any video edge blending equipment would require the images at the 
blended edges to overlap. 

 

The control of the geometry of each of the Review sessions in widescreen 
mode is provided through environment variables which directly or 
indirectly determine such parameters as view direction, field of view, 
skew of view and view overlap. These environment variables are set by 
the special scripts that will need to be customised for each widescreen 
setup. There may be extra help in setting these variables in the scripts 
themselves but some of the variables and their effects are briefly 
described below. Whatever the setup, one of the Review sessions is in 
control: the Master. If running three Review processes, then the Master 
is the one providing the centre image and the Slaves are on the left and 
right. All user navigation is achieved through interaction with the 
Master, which controls the Left and Right Slaves. In widescreen mode 
the views in the left and right Slaves can either share the view direction 
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with the master and be skewed from the Master’s or can each have a 
separate view direction rotated outwards from the Master’s. 

14.2 Environment Variables 

 

RVR_WIDESCREEN_MODE 

If this variable is set the Review jumps straight into widescreen mode. 
This is best left unset until a working setup has been arrived at. 

 

RVR_WIDESCREEN_CHANNEL id 

Where id is master, left or right for the Master, left and right Slaves 
respectively. 

 

RVR_WIDESCREEN_MASTER_HOST hostname 

Where hostname is the host name of the computer on which the master 
will be running. 

 

RVR_WIDESCREEN_NUMBER_SLAVES 1 or 2 

Informs the Master of the number of Slaves that will be connecting to it 

 

RVR_FRAMERATE fps 

Sets Review’s default animation frame rate to fps 

 

RVR_WIDESCREEN_MASTER_FOV fovº 

Where fovº is the master field of view as indicated in the figure for single 
view direction configurations below 

 

RVR_WIDESCREEN_OUTER_FOV fovº 

Where fovº is the outer field of view as indicated in the figure for single 
view direction configurations below 

 

RVR_WIDESCREEN_INNER_FOV fovº 
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Where fovº is the inner field of view as indicated in the figure for single 
view direction configurations below 

 

RVR_WIDESCREEN_SCREEN_OVERLAP overlap 

overlap at the abutting edges [0.0, 1.0] 

 

RVR_WIDESCREEN_ROTATE_VIEWS 

If this variable is set the following variables are used to set the fields of 
view and the view rotations for the Master and the Slaves; (the outer, 
inner and master fields of view are ignored). See the figure for separate 
view direction configurations below 

 

RVR_WIDESCREEN_HORIZFOV fovº 

Where fovº is the field of view as indicated in the figure for separate view 
direction configurations below 

 

RVR_WIDESCREEN_VIEWROTATION rotationº 

Where rotation is the view rotation for the separate view direction 
configurations – see below. 
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14.3 Running Review in Widescreen Mode 

 

There are three major scripts for running Review in widescreen mode: 
WDMASTER, WDLEFT and WDRIGHT and they use another script 
WDENV for setting up their common environment variables. Command 
line arguments normally given to Review can be given to these scripts. 

 

The golden rule for running Review in widescreen mode is that the 
Master MUST be running in widescreen mode before the Slaves. If the 
variable RVR_WIDESCREEN_CHANNEL is set, then a Widescreen 
entry is added to the Options pull-down menu of the Observer View. 
Remember that if the variable RVR_WIDESCREEN_MODE is set then 
Review goes straight into widescreen mode. It is suggested that this is 
left unset and that the Widescreen Mode menu option be used to put 
each of the Master and Slaves into widescreen mode. 

 

Once all the review Master and Slaves are up and running then the 
Master should be put into widescreen mode first, followed by the Slaves. 
The observer view on the Master will not be refreshed until the Slaves 
synchronise with the Master. If a Slave is put into widescreen mode 
before the Master then it will never synchronise and the Review 
processes will have to be restarted. 
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The Master can drop out of widescreen mode if the Esc (escape) key is 
pressed in the Master’s Observer View. By using the menu option as 
before, the Master can be put back into Widescreen mode and the Slaves 
will re-synchronise. 

 

Once the Slaves have been put into widescreen mode, they cannot be 
removed from this mode until the Master session has been terminated. 

 

It should be obvious that each of the Master and Slaves should load the 
same model and status files, although some interesting effects can be 
achieved with minor status file modifications; (by altering the drawing 
representation in a Slave to wire-frame for example). 

 

The frame rate in widescreen mode will be affected by the speed of the 
network and the performance of the graphics cards on the Master and 
Slaves. The graphics cards in the host computers should be as 
comparable as possible. 

 

Note that Review animations may be run in the Master (but that groups 
will not be animated in the Slaves) and that Voyager may also be used 
when Review is in widescreen mode (linked with the Master). 

14.4 Quad Buffer Stereo and Widescreen 

If you have NVIDIA Quadro FX3000G graphics cards in your Master and 
Slaves and suitable stereo hardware, quad buffer stereo can be used in 
conjunction with widescreen mode. Each machine will need to be 
correctly configured to allow quad-buffer stereo (See section 15). 

14.4.1 Hardware Setup 

Daisy chain the graphics cards together using a standard CAT5 patch 
cable plugged into the external RJ45 connector. You can connect any of 
the two RJ45 connectors located on the graphics card bracket; each 
connector automatically configures itself as an input or output after all 
the connections are made. A flashing green LED indicates an input and a 
flashing yellow LED indicates an output. 
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Designate one of the cards (most probably the Master) to be the server 
device: Open the Windows Display Properties control panel and click 
Settings > Advanced to navigate to the NVIDIA graphics display 
properties page. Click the Frame Synchronization tree item from the 
slide-out try. Check the “Treat this system as Server” checkbox. 

 

The other two cards need to be designated as clients. Follow the same 
dialog as above on the Slaves, check the “Treat this system as Client” 
checkbox. It is essential that the Refresh rate selected on this screen is 
the same on all the machines in use. 

 

When starting Review, ensure -qstereo is specified on the command line, 
and ensure you enter Stereo mode from the Observer > Options menu 
before entering widescreen mode on the Master and the Slaves. 
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15 Quad Buffer Stereo 

In order to view stereoscopic images with review, you will need a 
graphics card that supports quad buffer stereo and display hardware 
that can decode such images. To enable stereo mode, ensure Quad Buffer 
Stereo is enabled on your graphics card. When starting Review -qstereo 
must be specified on the command line. To switch to stereoscopic mode, 
select “Options > Stereo > On” from the Observer view menu. 

 

To change the distance between the effective eye points from which the 
stereoscopic image is derived, thereby changing the apparent depth of 
the 3D effect, select “Options > Stereo > Separation” and enter the 
required separation distance in the displayed form. 

 

To revert to non-stereoscopic mode, select “Options > Stereo > Off” from 
the Observer view menu. 

16 Saving Review Settings to Files 

Review provides facilities for exporting some or all of its settings to the 
following types of data file: 

• A status file is a binary file which holds display configuration settings 
from one Review session.  

• A textual report file is an ASCII file which holds the same display 
configuration settings as a binary status file, but in a user-readable 
format.  

You can also save the content of the Observer View display as a picture 
file. This is a bit-mapped image file, in the default format for your 
workstation, which you can load into any suitable graphics program for 
modification and/or printing. 
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16.1 Creating a Review Data File 

To save any of your current Review settings to a data file, click the Save 
button on the toolbar. An Export Review Status File form will be displayed. 

 Create the required type of file as follows: 

1. The Export Review Status File form uses the standard Windows Save 
dialog box. Navigate to the directory which is to contain the data file. 

2. Select an existing data file from the list if you wish to overwrite it, or 
enter a new file name in the File name: text box. 

3. If you wish to add text to, or modify, the file note associated with the 
data file (so that the note may be read back when a binary status file 
is reloaded, or included in the header of an ASCII file), click the Edit 
File Note button on the Export Status Data form (File>Save Selection…) 
and enter your text on the displayed form. 

4. Ensure that the Save as type option list is set to the type of data file 
which you wish to create, namely Review Status File or Textual Report.  

5. To save all available data in the format applicable to the specified 
type of file, select Save All Data on the Export Status Data form and 
click OK. 

6. To save selected data only, select File>Save Selection… from the main 
menu bar. The Export Status Data form will be, allowing you to specify 
which aspects of the current Review configuration you wish to save in 
the file. 

Use the Export Status Data form as follows: 

7. For each of the following item types, you may select which ones are to 
be saved: 

Cameras  (Observer, Camera One, , Camera Seven) 
Lights  (Ambient, Light One, , Light Seven) 
Materials  (material definitions) 
Paths  (animation paths) 
Animations  (the current animation status combinations of 
   animated object and path) 
Groups  (Scaleman plus any user-defined groups) 
Clip Volumes (any user-defined clip volumes) 

Select the relevant type of item from the list and then click Select to 
see a list of available items of that type. Highlight the ones which are 
to be saved in the status or report file. 

16-8 VANTAGE Plant Design Review Version 6.2 
User Guide 



Saving Review Settings to Files 

8. Check one or more of the Labels, Tags, Preferences, Keyplan State, 
Material Changes, Visibility Changes, Autotagging Changes and 
Signboards check boxes if you wish to save the corresponding data. 
(Any options for which there is no data available for saving will be 
‘greyed out’.) 

9. Click OK to create a status or report file containing the specified 
settings. 

16.2 Reloading a Status File 

You load a status file by using the Import Status Data form (select 
File>Open Selection>Status File…). Configuration settings thus loaded will 
be applied immediately to the current session. 

If you load more than one status file in a single Review session, the 
resulting configuration will be a composite of the settings in each file. 
You might, for example, save all camera settings in one status file, all 
lighting settings in another status file, and so on. If you load a status file 
which includes settings which conflict with those already loaded from an 
earlier file, you will be asked if you want the new settings to overwrite 
the old ones for some types (clip volumes, groups, paths and animations), 
while for other types (such as materials) the old settings will be 
overwritten automatically. 

16.3 Saving a Picture File 

You can save the content of the current Observer View as a bit-mapped 
image file in the default graphics format of your workstation. Such a file 
will contain data defining the whole of the displayed model image, but 
will exclude the borders (title bar, menu bar etc.) of the Observer View 
window. To create a picture file: 

1. Select Tools>Options>Picture File from the main menu bar. A Save  
Picture File form will be displayed. 

2. Navigate to the directory in which you wish to save the file and enter 
the file name in the File name text box. 

3. To save the content of the Observer View at its currently displayed 
size, set the option list to Save Observer View. 
To save the content of the Observer View at the maximum possible 
size, set the option list to Save fullscreen.  
To produce a better quality picture when plotted, use one of the 
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options Save 2X fullscreen or Save 4X fullscreen. These options 
effectively save the content of the Observer View at a greater 
resolution than the screen resolution, giving finer grained plots. 

4. Click OK to create the file. 
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17 Texture Mapping 

Bitmap images can be wrapped onto surfaces to produce a realistic 
appearance. For example, a picture of bricks applied to a flat upright box 
would represent a brick wall. You can use the texture images supplied 
with your hardware, or you can create your own using the texture 
creation utility on your hardware.  

The larger the texture image, the better defined it will be when viewed 
closely. However, large texture images use valuable memory and reduce 
performance, so textures should be kept as small as possible. Texture 
images larger than 512 x 512 pixels will be scaled down automatically 
when read into Review.  
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17.1 Creating Textured Materials 

To create a textured material, select Load Texture… from the Texture 
Properties panel on the Materials Palette form. The Open Image File form 
will be displayed. Navigate to the required image file, and the image will 
be displayed within the Texture Properties panel  

17.2 Using Greyscale Images 

It is recommended that you should use a grey-scale image to improve 
performance and give lower memory requirements. For example, use a 
grey-scale image of a brick wall applied over a brown-red base colour to 
approximate red brick. If the file you have selected is grey-scale anyway, 
the Load As Greyscale check box on the Open Image File form will be 
selected automatically. If you have chosen a coloured image, select Load 
As Greyscale yourself. When you click OK, the image is tiled onto the 
image on the Texture Properties pane. If you have loaded a coloured 
image, you will see that the texture image colour is modulated by the 
base colour: to see the original texture colour use a base colour of white.  

17.3 Controlling the Size and Shape of a Tile 

The primitives shown on the Materials Definition form have a major 
dimensions of 1 metre, that is: 

 a box 1m x 1m x1m 
 a sphere with diameter 1m 
 a cylinder with height  and diameter 1m 
 a dish (hemisphere) with diameter 1m 
 a cone with height and base diameter 1m 

By default, when a texture image is tiled onto a primitive, it is 1 metre 
(39 inches) wide. The height of the tile (that is, a single texture image) is 
proportional to the height of the original image. The tile width and 
height (in millimetres) are shown in the text boxes on the Texture 
Properties pane.  

Having loaded a texture file, you can change the tile size and shape using 
the  Width and Height text boxes on the Texture Properties pane. Note that 
if the Keep Tile Shape box is selected, changing either the Width or Height 
will change the other dimension automatically; if the Keep Tile Shape box 
is clear, the tile will be distorted.  
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17.4 Controlling How Tiles are Positioned and Repeated 

 

The Advanced Texture Properties panel on the Materials Palette form allows 
you to control how tiles are placed on the primitive. 

There are two tiling directions: Horizontal and Vertical. If you use a box 
primitive, by default the texture will be tiled onto the primitive with the 
bottom left corner of the pattern at a bottom-left corner of the box. 
Because both the default width of the pattern and the side of the box are 
1 metre, the pattern will exactly map in the horizontal direction. 
Assuming the height is not 1 metre, the pattern will be repeated (or 
truncated) so that it covers the height of the box. 

The Offset is given as a fraction of the dimension of the tile. For example, 
if you set an offset of 0.5 in the horizontal direction, the bottom left 
corner of the tile will be positioned in the middle of the bottom edge of 
the box.  

By default, texture images are tiled over the entire surface of a primitive. 
You can switch off texture tiling in the horizontal and/or vertical 
directions, so that only one tile appears in the given direction, using the 
buttons to the left of the horizontal and vertical text boxes. Note that if 
you are using a texture as a decal, you can use an alpha mask and the 
stick-on option, see below. 

The texture may also be rotated about its origin (lower left corner) 
through a given angle (in degrees). 
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17.5 Applying Textures to the Model 

Note that textures are only shown on the model if the Texturing box on 
the Image Quality form (Edit>Image Quality) is selected. 

Exercise:  

Using the box primitive, load a texture. Size the tile and switch pattern 
repeating off so that a single pattern is mapped onto the centre of each 
face of the box. 

 

17.6 Switching Textures On and Off 

You can switch texture display on or off by selecting Draw Texture on the 
Texture Properties panel of the Material Palette form. Note that this only 
affects whether the texture is shown: it remains a part of the material 
definition. If you switch the texture off and then save the material, the 
texture will not be displayed in the model, but switching the texture on 
again will show it. 

17.7 Removing Textures 

You can remove a texture from a material by selecting Remove Texture 
from the Properties panel of the Material Palette form. This will delete the 
texture from the current material definition. You can recover the texture 
by clicking Discard before you save the material, but once you have 
removed the texture and saved the material the texture is lost.  

17.7.1 Specular Textures 

Using a primitive with curved surfaces, for example a cylinder, load a 
texture and then see the effect of increasing the Specular parameter on 
the Material Properties pane. In general, the parameter will have little 
effect: to increase the shininess of a textured material, select the Specular 
Texture check box on the Texture Properties pane.  

Note that adding specular textures will slightly decrease performance. 
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17.8 Environment Map 

The Environment Map check box on the Texture Properties panel is used to 
create the effect of reflections from a very shiny surface. Load a suitable 
texture, for example an image of a scene, and use the cylinder primitive. 
Set the Specular slider to maximum on the Material Properties pane. 

17.9 Advanced Textures  

You can add an alpha mask to a texture before you load it by checking 
the Generate Alpha Mask button on the Load Texture Image form. Note that 
some texture images are defined with an alpha mask. An alpha mask is 
used to make part of the texture transparent. Normally, the top-left 
colour in the texture image will be made transparent. Wherever this 
colour appears in the texture image, the alpha mask will make the colour 
transparent when the texture is applied to a primitive.  

If you check the Invert Generated Masks box on the Load Texture Image 
form, all pixels with the same colour as the top-left pixel will be visible 
and all other colours invisible.  

A texture with a mask can be used in three different modes, as selected 
from the Alpha Mode option list on the Advanced Texture Properties panel 
of the Materials Palette form: 

• By Ignoring the mask, the texture will behave as any other.  

• The Cut out option will make the underlying primitive invisible where 
the mask is not set.  

• The Stick on option allows the underlying material colour to show 
where the mask is not set. 

The Cut out option can be used to put holes in surfaces to represent 
gratings etc.; the Stick on option can be used to stick a texture image as a 
decal onto a surface. 

17.10 Examples of Simulating Real Materials 

There are a number of texture image libraries available commercially. 
Note that the effects on the screen will be very much better than those 
shown in the manual. 

VANTAGE Plant Design Review Version 6.2 17-5 
User Guide 



Texture Mapping 

4 Creating a Material That Looks Like Shiny Wood 

1. Set a suitable material colour. 

2. Load a texture that looks like wood. 

3. Change the tile size if you want to control the grain size. 

4. Increase the shininess and smoothness, and check the Specular 
Texture box on the Texture Properties panel of the Materials Palette 
form. 

 

Figure 14-1 A shiny wood effect 

4 Creating a Material That Looks Like a Grid 

1. Load a texture that looks like a grid. 

2. Select the Generate Alpha Mask check box and the Invert Generated 
Masks box on the Open Image File form. 

3. Set the Alpha Mode option list selection on the Advanced Texture 
Properties panel of the Materials Palette form to Cut out. 
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4 Creating a Material That Looks Like Chromium Plate 

Load a texture that represents a scene, or one that has a mixture of 
colours. Increase the shininess and smoothness, and check the 
Environment Map button on the Texture Properties panel of the Materials 
Palette form. 

 

Figure 14-2 A chromium plate effect 

17.11 Using Old Model and Status Files 

When a Review 3 model file is read into a later version of Review, the 
later version will create a material for each Review 3 material reference 
number found. Each material will be given a name of the form 
Materialnn where nn is the number of the Review 3 material. For 
example, Review 3 material 7 will be created as Material07.  

Old status files that reference numbered materials will cause materials 
to be created in later versions of Review if they do not already exist, alter 
their properties according to the data in the status files, and apply them 
to the model according to the material changes in the status file. Thus all 
pre-Review 6 model and status files should produce a model 
indistinguishable from the model as loaded into Review 3 or later visions. 
This not true the other way round 

The Review applications interface will cause materials to be created and 
altered in a similar manner.
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18 The Data Viewer 

The Data Viewer provides a way of viewing PDMS attribute data for 
Review model elements. The attribute data must have created using the 
reporting facilities in PDMS, and must exist as a text (.txt) file. 

Using the Data Viewer it is possible to navigate to elements in Review or 
set their material representation. An example of using the Data Viewer 
would be to colour code elements in Review to reflect build status. 

Data Viewer is an example of a “plug-in” (or “add-in”). The add-in facility 
provides a mechanism whereby users can create their own sub-
applications to add to Review. 
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18.1 Using the Data Viewer 

 

18.1.1 Loading and Displaying Attribute Data 

 

To load attribute data into the Data Viewer either type the required 
filename into the Data File: text box or Browse… to the file using the 
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standard Windows Open dialog box. To import the data, click Load Data 
From File.  

Once the data has been imported there are two ways to display the data, 
using the check boxes at the base of the Settings pane: 

• Show all Entries displays all the imported data. The data will appear in 
a table similar to: 

 

• Filter by Review Selection only shows the data for elements that have 
been selected in Review. This will track the selection in the currently 
active window in Review and show any data that has been imported 
for those elements. For example (if the EQUI elements shown in the 
above list are selected from the Explorer in Review): 
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18.1.2 Setting Material Properties 

 

The Materials panel can be used to set the material properties of elements 
selected in the DataViewer list. 

There are three materials set up initially, with Orange, Green and Blue 
colours. Use the Change Colour… links to bring up the standard Windows 
Color dialog box to choose a different colour.  

To set the material for elements first select them in the attribute grid, 
then click on the appropriate Set Material link.  

Note:  To select elements in the attribute grid you must select the whole 
row containing that element. To do this click on the row header 
on the left of the grid. It is possible to select multiple rows by 
using the   or Ctrl keys in the normal Windows convention.  

When applying materials to elements it may be necessary to remove any 
highlighting that has been applied. This is possible using the Freeze 
Current Materials and Reset All Material links. Freeze Current Materials saves 
the current state of material properties for all elements in the Review 
model. Once a material state has been set, the Reset All Materials link will 
roll back the material properties to this saved state. 

It is also possible to set the visibility of selected items by selecting from 
the Set Visibility list. 
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18.1.3 Navigating To Elements 

 
It is possible to use the Data Viewer to locate elements in the Observer 
View. In the Navigation panel there are three links that work as follows: 

• Focus on Element – moves the camera to the identified element and 
looks at it. 

• Dynamic Focus on Element – as above but with dynamic movement. 

• Look to Element – looks to the element but does not move the camera.  

As with setting materials, these operations will work with the selected 
element in the attribute grid. 
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19 Command Line Options When Starting 
Review 

Your system administrator has probably set up a Windows ‘shortcut’ 
which enables you to enter Review simply by double-clicking on its icon. 
You can however start Review from the command line in an MS-DOS 
Prompt window. Starting from the directory where the Review program 
files have been loaded, you would type: 

Review.bat  - to set up the system configuration 

Review   - to start Review (by running Review.exe). 

You can add one or more arguments to the start-up command line to load 
such files automatically. You can also load and apply a clip file at start 
up, such that only those parts of the model file which comply with the 
clip specifications are actually loaded. 

You can, further, start Review in ‘imperial measurement’ mode, such 
that all input and output dimensions shown on the forms are in feet and 
inches rather than in the default millimetre units. 

The command line arguments which you can use have the following 
functions: 

-m  model_file(s) Loads the specified model files in the order in 
   which they are listed. 
-s  status_file(s) Loads the specified status files in the order in 
   which they are listed. 
-c  clip_file  Loads the specified textual clip file  
-d  screen_setup_file Loads the specified screen setup file  
-imperial  type  Specifies imperial measurement mode, where 
    type determines the format and precision for 
    displayed dimensions  
-credit png_file  Loads the specified PNG-format graphics file 
   and displays the image on the Review screen  
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For example  

Review –m models\atest.rvm -imperial 2 

Loads the atest.rvm model file with dimensions to be shown in feet and 
inches, rounded to the nearest ½ inch. 

19.1 Loading Model, Status and Clip Files 

If you use the -m, -s and -c arguments to load model, status and clip files, 
respectively, Review will carry out the following operations on start up: 

1. The clip file specified by the -c option will be loaded first. Any clip 
volumes defined within this file will be shown when the clip 
definitions are listed and will be available for use as soon as you enter 
Review. 

2. The model files specified will be loaded in the order in which they 
follow the -m option. If a clip file has been loaded, only those parts of 
the models which comply with the definition of the first clip volume 
within that file will be loaded. When you load more than one model 
file in this way, checks are not made for duplication of element 
names.  

3. The status files specified will be loaded in the order in which they 
follow the -s option and the configurations defined by them will be 
applied to the displayed model. If any part of the configuration 
conflicts with a preceding status file, you will be asked if the later 
data is to overwrite the earlier. 

Note: The files specified by these arguments are always loaded and 
actioned in the order -c -m -s, as shown by the above numbered 
steps, regardless of the order in which they occur in the command 
line.  
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19.2 Editing a Textual Clip File 

The format for a textual clip file, to be loaded using the -c  command line 
argument when you run Review, is as follows: 

CLIP     Identifies file as a clip file. 
m n     File revision numbers (currently m=n=1). 
ClipVolumeName1  Name of first clip volume. 
minimum Z  maximum Z Limits for first clip volume; all in metres. 

 
minimum Y  maximum Y Z, Y and X limits must be minimum X 
     maximum X specified in this order. 

  
ClipVolumeName2  Name of second clip volume (if any). 

 
minimum Z  maximum Z  
minimum Y  maximum Y Limits for second clip volume. 
minimum X  maximum X 

Repeat sequence for each clip volume, as many times as necessary. You 
can create and/or edit such a clip file using any text editor. 

Note: +Z = Up  -Z = Down 
+Y = North -Y = South 
+X = East -X = West 

19.3 Loading a Screen Setup File 

If you have saved a screen setup file from an earlier Review session you 
can start Review such that it automatically configures its initial screen 
as defined by that file. To do so, include the -d screen_setup_file 
argument in your Review start-up command line. 

19.4 Specifying Imperial Units for Dimensions 

To start Review in ‘imperial measurement’ mode, so that all dimensions 
on the forms are in feet and inches rather than in the default millimetre 
units, use the command line argument 

- imperial type 

where type determines the format and precision for displayed 
dimensions. 
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The options available for type are as follows: 

decimal or 0   - Dimensions will be shown with decimal values  
    for inches; for example, 3’ 6.75. 

2, 4, 8, 16, 32 or 64 - Dimensions will be shown with fractional inches, 
  rounded to a precision of 1/2, 1/4, 1/64 inch, 
 respectively; for example, 3’6.3/4 

Thus, the command: 

review -imperial 32 

will start Review in such a way that all dimensions will be shown in feet 
and inches, rounded to the nearest 1/32 inch. 

The following dimensional formats are acceptable for entering data while 
in imperial measurement mode: 

F F’ F’I 

F’I.n/d F’I.fff 

I” 

I. I.n/d n/d .n/d I.fff .fff 

Where 

F = feet 

I = inches 

n/d = fractional inches 

fff  = decimal inches 

All inches may be followed by an optional ” symbol (except for I” where it 
is mandatory). 

All formats may be preceded by a - sign (for negative values).
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20 Running Linked Review Sessions 

20.1 Requirements for Running Linked Sessions 

(Note:  The information in this section gives a background summary 
only. The system should have been set up in a suitable 
configuration by your System Administrator before you begin, so 
ignore this section if you simply want to join an existing linked 
session workgroup.) 

The obvious requirement is that all workstations which are to take part 
in the linked sessions must be networked together so that they can share 
data using a suitable communications protocol. The protocol used by 
Review is TCP (Transmission Control Protocol). The schematic 
configuration is as follows: 

 

The process requires a broker daemon to be running on a nominated host 
on the network. This can be one of the workstations to be used to run 
Review (either as the host or as a satellite), or any other accessible 
workstation. This broker will control all Review traffic within the 
workgroup. It will record all changes to the model view, as received from 
the master workstation, in a state change table and will send the current 
data to any satellite workstation which requests it. There may be many 
brokers running on a single host, each with a different port number and 
each representing a different workgroup. 
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20.1.1 Starting up a Broker Daemon 

1. cd to the review.exe directory 

2. rsrbroker -p port_number 

For example, 

rsrbroker -p 2112 

Note:  You must select a port number which will not conflict with any 
existing processes. Contact your System Administrator in this 
regard.  

Once the broker daemon is running, the first Review session to connect 
to the workgroup becomes the host session by default. All other sessions 
which connect will be satellite sessions. The host session can relinquish 
its status in favour of one of the satellite sessions at any time, and any 
session can disconnect from the workgroup at any time. 

All sessions must be loaded with the same model and status files to 
ensure compatibility between them. 

20.2 Connecting to a Linked Session Workgroup 

Before you link your current Review session into a workgroup, first check 
that the conditions summarised in Section 20.1 have been established. 

• If your session will be the first to connect to the workgroup, you will 
become the host session. The model data currently loaded into your 
session will determine what data subsequent satellite sessions must 
have loaded. 

• If another session is already connected, you will become a satellite 
session. Check that you have loaded the model and status files 
appropriate to the workgroup. 

To set up the link, select Tools>Options>Voyager Session from the main 
menu. You will see a Voyager Session form: 
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Enter the name of the Host (that is, the workstation on which the broker 
daemon is running) and the number of the Port via which it is accessible 
on the network (your System Administrator can give you these details). 
Click Connect to make the link. 

20.3 Working in a Linked Session 

If you are running the host session, all changes which you make to the 
Observer View settings will be shown automatically in each of the  
connected satellite sessions whenever they do a graphical refresh. If you 
are running a satellite session, your Observer View parameters will be 
derived automatically from those currently defined by the host session. 

To highlight an item from the host session, so that you can refer to it 
unambiguously, hold down the Shift key while picking the object using 
the left-hand mouse button. 

To relinquish host status, perhaps temporarily so that a satellite user 
can, say, highlight an object from their workstation, click the Resign As 
Host Session button (this is greyed out if you are in a satellite session). 
You will see a Select New Host Session form listing all satellite sessions in 
the current workgroup; select the one which is to take over as the host. 
The change will be confirmed by a message in the new host session. In a 
truly interactive workgroup, host status may be switched frequently 
between workstations, so that each user can contribute changes to the 
view in turn. 

20.4 Disconnecting from a Linked Session 

To disconnect from a linked session, click the Disconnect button. If you 
are running the host session, the satellite session with the longest 
established connection will take over as host by default. If you want to 
designate a specific satellite session to take over as the host, use the 
Resign as Host Session button (see Section 20.3) before you disconnect. 

If you are running a satellite session, disconnection is the only option 
available to you. 

In either case, disconnection only breaks the link to the workgroup. It 
does not affect your current Review session on your local workstation. 
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21 PDMS Design Export utility 

21.1 Copying Model Data from PDMS to Review 

 

The PDMS Design Export utility extracts from the PDMS Design 
database the relevant data for the primitives which will make up the 
display, including the Design hierarchy, and stores it in an intermediate 
file (a model file) for use by Review. 

For full details of the Export utility, see the Introducing the Export Utility 
topic in the Design online help. 
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21.2 Command Line Options 

The EXPORT command for use in PDMS Design in described in full in 
Chapter 4 of the VANTAGE PDMS DESIGN Reference Manual, Part 4. 
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22 Creating an Add-in for Review 6.2 
22.1 Introduction 

This section captures the User specification for creating add-ins for 
Review 6.2. Creating an Add-in control requires a basic understanding of 
developing .NET Winforms User Controls using the Visual Studio .NET 
development environment. It also requires a basic understanding of 
implementing interfaces in classes, although this will be covered in this 
document.  

22.2 Creating an Add-in Project 
First create a project for the Add-In control. In this example the user 
control will be written in C# but it is possible to write a user control 
using any of the .NET languages. In the Visual Studio.NET development 
environment select File>New>Project… from the application main menu. 
This should bring up the ‘New Project’ dialog as seen below. Select 
‘Visual C# Projects’ from the ‘Project Types‘ field and select ‘Windows 
Control Library’ from the ‘Templates’ field. Enter a name for the project 
and a location to create the project in and click on OK.  
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This should create a project with a Winforms User Control in. Next give 
the User Control a name (in this example the User Control will be named 
‘MyAddIn’).  

22.3 Developing the Add-In 
22.3.1 Adding a reference to Review 

First add a reference to the ReviewAPI.dll. To do this Select ‘Project>Add 
Reference…’ from the application main menu and browse for 
ReviewAPI.dll from the Review 6.2 Install directory.  

 

 
This should add a reference to ReviewApi to the project references.  
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22.3.2 Developing the User Control as an Add-in 
View the code for the User Control. Then add the following line to the 
‘using’ statements for the user control.  

using Aveva.VPD.ReviewApi; 

To create an Add-in the project must contain a class that implements the 
IAddin interface defined in ReviewApi.dll. In this example this interface 
will be implemented in the MyAddin class.  To do this add IAddin to the 
list of base interfaces for MyAddin.  

Note: In Visual Studio.NET the development environment can add stubs 
for the members of the IAddin interface. This can be done by pressing 
TAB when prompted after adding IAddin to the list of base interfaces. 
The prompt can be seen in the picture below. 

 

 
Otherwise populate the members of the IAddin interface into MyAddin 
manually.  

When the Add-in runs it will be passed an IReview Interface. This is the 
main interface to Review API and will be used for such things as 
material creation and navigation. Create a member of type IReview to 
store the interface in as shown below.  
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When Review loads the Add-ins it will call ‘Start’ on each one and pass in 
its’ own IReview interface. Store this interface in the member created 
above.  

 
Next fill in the AddinName property to return a name for the Add-in. 
This is the name that will appear on the Review ‘Addins’ menu and on 
the form title for the window containing the Add-in.  

 
Every Add-in must pass a user control to Review. This is the control that 
will be displayed in the Add-in window and provides the main user 
interface to the Add-in.  

Note: It is possible to have the User Control defined in a separate class to 
the one that implements the IAddin interface. In this example however 
the IAddin interface is implemented in the User Control as this is the 
simplest way.   

Review will query the Add-in for the User Control that provides the GUI. 
Return the user control in the ‘get’ part of the ‘Control’ property.  
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This example will keep with the default return values provided for the 
‘Description’ and ‘Priority’ properties. There will also be no extra 
functionality added to the ‘Stop’ function.  

22.3.3 Responding to Review Selection changes 
Review Add-ins can subscribe to an event that will be fired whenever the 
active selection changes in Review. The active selection is the selection in 
the currently active Review window. Review windows that fire active 
selection change events are: Explorer, camera windows, search results, 
drawlist.  

To subscribe to active selection change events first create a member to 
handle the event. The event handler should have the same signature as 
the one shown below.  

 
Next subscribe to the selection change event using this function to handle 
the event. This can be done via the static 
SubscribeForSelectionChangedEvent method on the 
ReviewActiveSelection class. The ReviewActiveSelection 
class provides access to the active selection through static methods.  

 
In the ActiveSelectionChanged function we can add some code to 
handle the selection change. In this example the name of the first 
element of the selection will be pasted into a text label on the user 
control.  

Create a label on the user control with the name elementNameLabel. 
Now, in the ActiveSelectionChange function set the text of the label 
to the name of the first entry in the active selection set. 
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The Selection member of ReviewActiveSelection is an ArrayList 
containing the names of the selected elements.  

22.4 Using the Review API 
Using the Review API it is possible to create materials, associate 
materials with elements in the Review model, change the display state of 
elements in the model and navigate to elements.  

This example will demonstrate creating a material with colour and 
applying that material to the selected element in Review. It will also 
demonstrate navigating to the selected element.  

22.4.1 Creating a Material 
To create or query material info via the Review API use the 
MaterialInfo class defined in the ReviewAPI.dll.  

First add a MaterialInfo member to the MyAddin class.  Also, create a 
name for the material.  

 
Next, in the Start function create a new material using the following: 

 
In this example the material is set up with red colour and values for 
ambient, metalness, specular, smoothness and transparency set to 0. 

Next, check to see if a material with name “Red Material” already exists. 
If not create it then set it with the material information created above.  
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22.4.2 Applying the Material 
To apply the material to the selected element; first add a button to the 
User Control named setMaterialButton and add an event handler for 
the ‘click’ event. In this event handler use the SetElementMaterial 
function to apply the red material to the element name in the label 

 

22.4.3 Navigating to the Selected Element 
To apply the material to the selected element; first add a button to the 
User Control named lookToElementButton and add an event handler 
for the ‘click’ event. In this event handler use the LookAtElement 
function to look at the element.  

 
This will look to the selected element in the observer window with snap 
move and highlighting.  

22.5 Using the Add-in in Review 
When this project is built it will create a DLL named ‘MyAddin.dll’. Copy 
this DLL into the ‘Addins’ directory below the Review install directory. 
When Review runs it will pick up this Add-in and the name ‘My Addin’ 
will appear under the main menu ‘Addins’ menu. Clicking on this menu 
item will display the Add-in.  

When elements are selected in Review, for example in the Explorer 
window, their names will appear in the label elementNameLabel.  
Clicking on the button setMaterialButton will paint the element red. 
Clicking on the button lookToElementButton will navigate the 
observer to look at the element.  

22.6 Configuring which Add-ins that are loaded in Review 
It is possible to specify which Add-ins are loaded into Review when it 
runs. This is done by using a configuration file called ‘Addins.xml’. In this 
file list the Add-in DLLs that will be loaded into Review when it runs. 
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Add the paths to the Add-in DLLs relative to the Review install 
directory, then place the Addins.xml file in the same directory as 
Review.exe. When Review runs it will look for the file ‘Addins.xml’ if it 
finds this file it will only load those DLLs specified in this file. If it does 
not find and Addins.xml file it will load all Add-ins that are in the Addins 
directory. 

Below is an example of the contents of an Addins.xml file which specifies 
two Add-ins to load: DataViewer.dll and MyAddin.dll.  

 

<?xml version="1.0" encoding="utf-8" ?>  

<ArrayOfString 
xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
 <string>Addins\DataViewer.dll</string> 

 <string>Addins\MyAddin.dll</string> 

</ArrayOfString> 
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22.7 IReview Members 
 

Member Description 

CreateMaterial Creates a material with the supplied name in Review.  

Argument Type Description 

material String The name of the material to create. 

 

Member Description 

FreezeMaterials Freezes the current state of material association to 
elements in the model. This creates a snapshot of the 
current element-material association that can be rolled-
back to with a call to ResetMaterials()  

 

Member Description 

ResetMaterials Resets the element-material association to the state at the 
last call of FreezeMaterials(). If FreezeMaterials() has not 
been called then this will roll all elements back to the 
materials defined in the model file.  

 

Member Description 

GetAllMaterials Returns an ArrayList of String objects containing the 
names of all materials currently defined in Review.  

 

Member Description 

GetBackgroundColour Returns a Color object that defines the background 
colour to use for Add-in user controls. This helps Add-in 
controls fit in with the visual style of Review.  

 

Member Description 

GetMaterialExists Returns a bool that defines if a material with the supplied 
name already exists in Review.  

Argument Type Description 

material String The name of the material to query. 
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Member Description 

GetMaterialInfo Gets information about a given material.  

Argument Type Description 

material String The name of the material to query. 

Info MaterialInfo A MaterialInfo object that will receive the 
material information 

 

Member Description 

GetMaterialVisibility Returns a VisibilityType that defines the visibility of the 
material  

Argument Type Description 

material String The name of the material to query. 

 

Member Description 

LookAtElement Sets a camera to look at an element in the model.  

Argument Type Description 

camera Aveva.VPD.ReviewApi.CameraType The camera to use, can 
be the Observer window 
or one of the other 7 
cameras 

element String The name of the 
element to look at 

lookMethod Aveva.VPD.ReviewApi.LookType The type of move 
method. Can be snap, 
dynamic or no move.  

highlight bool Defines if the element 
should be highlighted 
after the move.  

 

Member Description 

RefreshAll Refreshes the Review displays.   

 

Member Description 
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SetAllElementVisibility Sets the visible state of all elements in the model  

Argument Type Description 

visibility Aveva.VPD.ReviewApi.VisibilityType The visibility 
type to set on 
all elements in 
the model. 

 

Member Description 

SetElementMaterial Sets material type for a list of elements  

Argument Type Description 

element ArrayList An ArrayList of String objects containing the 
names of element  to apply the material to 

material String The name of the material to apply to the 
elements.  

 

Member Description 

SetElementMaterial Sets material type for a single element  

Argument Type Description 

element String The name of element  to apply the material to 

material String The name of the material to apply to the 
element.  

 

Member Description 

SetElementVisibility Sets visibility type for a list of elements  

Argument Type Description 

element ArrayList An ArrayList of 
String objects 
containing the 
names of element  
to apply the 
material to 

visibility Aveva.VPD.ReviewApi.VisibilityType The visibility type 
to apply to the 
elements.  
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Member Description 

SetElementVisibility Sets visibility type for a single element  

Argument Type Description 

element String The name of 
element  to apply 
the material to 

visibility Aveva.VPD.ReviewApi.VisibilityType The visibility type 
to apply to the 
element.  

 

Member Description 

SetMaterialInfo Sets information for a given material.  

Argument Type Description 

material String The name of the material to query. 

Info MaterialInfo A MaterialInfo containing the information on 
the material to be set.  

 

Member Description 

SetMaterialVisibili
ty 

Sets the visibility type for a given material.   

Argument Type Description 

material String The name of the material to query. 

visibility Aveva.VPD.ReviewApi.Visibil
ityType 

The visibility type to apply to the 
material.  
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22.8 IAddin Members 
 

Member Description 

Start This function will be called by Review to indicate to the Add-in 
that it can start processing calls to Review. Review will also 
pass the Add-in an IReview interface to make calls to.   

Argument Type Description 

review Aveva.VPD.ReviewApi.IReview The interface to Review to 
make calls to.  

   

Member Description 

Stop This function will be called by Review to indicate that it must 
stop making calls to the Review Interface.   

 

Member Description 

AddinName 
[get] 

The name of the Add-in that will be used to identify it in the 
Review GUI. This name will be added to the Addin menu list 
so the Add-in can be displayed and hidden. This name will also 
appear in the title bar of the window containing the Add-in 
control.     

 

Member Description 

Control [get] Returns the User Control that will be displayed in the Add-in 
window. This User Control will provide the main GUI for the 
Add-in 

 

Member Description 

Description 
[get] 

A description of the Add-in 

 

Member Description 

Priority [get] Unused in this version of Review 
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22.9 Other ReviewAPI Classes 
 

MaterialInfo 

The MaterialInfo class is used to define the visual properties of Review 
materials. The MaterialInfo class contains the following members: 

Member Type Description 

Red System.Int32 The red value of the colour of the material in the 
range 0-100 

Green System.Int32 The green value of the colour of the material in 
the range 0-100 

Blue System.Int32 The blue value of the colour of the material in the 
range 0-100 

Ambient System.Int32 The ambient reflectivity of the material in the 
range 0-100 

Specular System.Int32 The specular reflectivity of the material in the 
range 0-100 

Metalness System.Int32 Defines the amount of plastic-metal in the 
material. This is defined in the range 0-100 with 
0 being plastic and 100 being metal.  

Smoothness System.Int32 Defines how smooth the material is. This is 
defined in the range 0-100 with 0 being rough and 
100 being smooth. 

Transparency System.Int32 Defines how transparent the material is. This is 
defined in the range 0-100 with 0 being opaque 
and 100 being transparent. 

  

ReviewActiveSelection 

The ReviewActiveSelection class provides access to the list of selected 
elements in Review. Using this class an Add-in can query or set the list of 
selected elements and subscribe to an event that is fired when the 
selection changes. The ReviewActiveSelection class contains the following 
members: 

 

Member Description 

SelectionChange
d 

Sets the selection and fires an event to all subscribers that the 
selection has changed.  
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Argument Type Description 

sender System.Object The object that is setting the selection.  

selection System.Collections.Arra
yList 

An ArrayList of String objects containing 
the names of the selected elements.  

 

Member Description 

SubscribeForSel
ectionChangedE
vent 

Subscribes to the event that is fired when the active selection 
changes. In Review 6.2 the selection changed event is triggered by 
selection changes in the Explorer, Observer view, Camera views and 
the Search Results window.  

Argument Type Description 

e ReviewActiveSelection.S
electionChangedEvent 

The function to act as an event handler for 
the selection changed event.  
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Appendix A  View Manipulation in Review 
version 6.2 

Note:  the facilities detailed here are only those which are exclusive to 
Classic mode. See section 5.4 for other facilities available in 
Classic mode. 

A.1 Direct Manipulation Using the Mouse 

You can change the view by pressing the middle mouse button. The 
effect depends on the following: 

• The type of change depends on the current primary mode (Zoom, 
Rotate or Pan)  

A.1.1 Setting the Manipulation Mode 

4 Primary Manipulation Mode 

You can set the primary mode for manipulation to Zoom, Rotate or Pan. 
The currently selected mode determines how the model view changes 
when you click or hold down the middle mouse button. 

Set the primary mode by holding down the right-hand mouse button 
to display a small pull-down menu showing the options Zoom, Rotate and 
Pan. Release the button when the required mode is highlighted. 

4 Secondary Manipulation Mode 

Having set the primary mode, the way in which the view responds to 
operation of the middle mouse button is qualified by the secondary mode 
setting. This may be Single Step, Step, Continuous or Spin. To set the 
secondary mode, choose the required setting from the Options>Mode> 
menu. Note that you may set the Spin direction to Clockwise or 
Anticlockwise. 

In Single Step mode the view changes only when you release the mouse 
button (giving one move per press of the button). The extent of each step 
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change is equal to the current increment settings (see Section 0). 

In Step mode the view changes continuously for as long as you hold down 
the mouse button (although you can still execute a single step change by 
clicking the button quickly). The extent of the change for each interval of 
the movement is equal to the current increment settings (see Section 0). 

In Continuous mode the view changes continuously for as long as you 
hold down the mouse button (although you can still execute a single step 
change by clicking the button quickly). The extent of the change for each 
interval of the movement, up to a maximum determined by the current 
increment settings, is determined by the position of the pointer on the 
screen, as explained in Section A.1.3. This gives you finer control over 
the movements than Step mode. 

In Spin mode the view rotates continuously (overriding the primary 
mode) even after you have released the mouse button, until you 
specifically pause it or stop it. The incremental change during spinning is 
the current rotational increment (see Section 0). 

To stop a ‘spinning’ model, select Tools>Options>Mode>Spin>Stop. 

A.1.2 Setting the Centre of Rotation 

The orientation of the line of sight is defined in terms of its bearing 
(rotation about a vertical axis) and its elevation (rotation about a 
horizontal axis). These axes may intersect each other either at the 
observer’s eye point or at the model’s through point, so that the effect of 
view manipulations may be actioned in either of two ways: 

• As though the model remains stationary and the observer’s eye point 
moves 

• As though the observer’s eye point remains stationary and the model 
moves 

To set the required centre of rotation, use the Tools>Options>Observer> 
menu to choose the point (Eye or Model) about which the line of sight is to 
rotate. 

Alternatively, the Preferences form may be used 
(Tools>Options>Preferences…). 
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A.1.3 Controlling the View Using the Mouse 

4 The Display Centre and Inactive Area 

Manipulating the view using the mouse depends on the position of the 
pointer in the graphics window. There is an inactive region in the centre 
of the display. 

4 Zooming In and Out 

Set the primary mode to Zoom by selecting Zoom from the menu 
displayed when you press the right-hand mouse button with the pointer 
in the graphics area. The effect of pressing the middle mouse button 
depends on the position of the pointer in the graphics area: 

No zoom effect

Zoom in

Zoom out

model appears larger

model appears smaller
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In continuous mode, the extent of each zoom operation depends on how far the 
pointer is from the screen centre. The further it is from the centre, the greater 
the effect. The maximum change (when the pointer is at the top or bottom of the 
screen) corresponds to a movement of the eye point along the line of sight by the 
current translational increment. 

Exercise:  
Zoom in and out of your displayed view by different amounts. Notice how 
the pointer changes shape when the middle mouse button is pressed; the 
shape depends on which band of the screen the pointer is in. 

Try the different effects of using single step, step and continuous modes. 

Try using different Range Variation settings and notice how the model 
flips under some circumstances as you zoom the eye point through the 
through point. 

 

4 Rotating the View 

Set the primary mode to Rotate by selecting Rotate from the menu 
displayed when you press the right-hand mouse button with the pointer 
in the graphics area. The effect of pressing the middle mouse button 
depends on the position of the pointer in the graphics area: 

 

   Elevation 

 
 rota 

(no rotation)       
Bearing 

   
 

 

In continuous mode, the extent of each rotate operation depends on how 
far the pointer is from the screen centre. The further it is from the 
centre, the greater the effect. The maximum change (when the pointer is 
at the edge of the screen) corresponds to a movement of the line of sight 
by the current rotational increment. 

Exercise:  

Try the effects of rotating your line of sight by different amounts in all 
directions. Notice how the pointer changes shape when the middle mouse 
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button is pressed; the shape depends on which area of the screen the 
pointer is in. 

Try using single step, step and continuous secondary modes, and 
changing between eye movement and model movement, to see the 
different effects. 

Start the model spinning continuously by selecting 
Tools>Options>Mode>Spin>Clockwise.  

 

4 Panning the View 

Set the primary mode to Pan by selecting Pan from the menu displayed 
when you press the right-hand mouse button with the pointer in the 
graphics area. The effect of pressing the middle mouse button depends on 
the position of the pointer in the graphics area: 

 

   

 
 rota 

(no panning)  

   

 

In continuous mode, the extent of each pan operation depends on how far 
the pointer is from the screen centre. The further it is from the centre, 
the greater the effect. The maximum change (when the pointer is at the 
edge of the screen) corresponds to a movement of the line of sight by the 
current translational increment 

Exercise:  

Try the effects of panning your displayed view by different amounts in all 
directions. Notice how the pointer changes shape when the middle mouse 
button is pressed; the shape depends on which area of the screen the 
pointer is in. 

Try using single step, step and continuous secondary modes to see the 
different effects. 

 
 

Note:  If you have a ‘wheel mouse’, then the wheel can be used to 
perform zooming and ‘vertical’ pan and rotate operations. 
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A.2 Setting a Constrained Walk Path  

A walk path is a fixed straight line which you define from your current 
eye point to a specific point within the displayed model. The effect of the 
walk path is relevant only when you use the zoom function to change the 
view. In such a case, the use of a walk path constrains movement of the 
eye point relative to the fixed straight line in one of the following ways: 

• When in Eye mode, zooming moves the eye point along the defined 
walk path itself. The eye point cannot be moved off the walk path. 

• When in Model mode, you can rotate the line of sight so as to move the 
eye point off the defined walk path; subsequent zooming then moves 
the eye point along a line through its new starting point and parallel 
to the defined walk path. 

Walk paths are of most use in Eye mode, which gives the effect of an 
observer moving along, say, a walkway and being able to look in any 
direction while doing so. Only this mode will be considered further.  

To define a walk path, select Tools>Options>Walkpath>Towards> with the 
Observer View selected and define a point within the displayed view in 
either of the following ways: 

Centre defines the walk path as the line through the current eye point 
and the centre of the screen display (i.e. the current through point). 

>Name… defines the walk path as the line through the current eye point 
and the origin of a named element. Enter the required element name in 
the displayed text box.  

When you define a walk path in this way, you automatically enter 
Walkpath mode. To remove the walkpath constraints and return to 
normal manipulation of the view, select Tools>Options>Walkpath>Clear. 

Exercise:  

Set up your Observer View display so that the atest model is 
approximately centred in the view and looking North. 

Ensure that you are in Continuous : Zoom : Eye mode and use the zoom 
function to move towards and away from the displayed model once or 
twice. 

Now select Tools>Options>Walkpath>Towards>Name and enter the name 
of an element well away from the centre of the current display (say the 
top of the tall column) and Apply the Define Walkpath Towards form. 
Select Tools>Options>Walkpath>Clear to leave Walkpath mode. 
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