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TNHost Terminal Emulator

You can work on a TN3270 or TN5250–based system from your local
PC by using the TNHOST terminal emulator. The emulator lets you
connect to IBM mainframes (TN3270–based) or IBM AS/400 sys-
tems (TN5250–based). This chapter will help you to get started using
the emulator to create a connection to a system, execute commands,
and run applications on the system.

Refer to the TNHOST online help for more information about the
application and specific functions.

What is TNHOST Terminal Emulator?

TNHOST is an emulation and communications package for IBM and
IBM–compatible personal computers running Microsoft Windows 95,
NT, and 3.x. The software duplicates virtually all functions of the
TN5250, TN3270, TN3278, and TN3279 terminals, allowing you to
work on the host system from your PC.

You can use TNHOST to:

• Launch up to 26 TNHOST sessions for concurrent access to
multiple hosts.

• Remap your keyboard using drag–and–drop for simple and
flexible assignment of keyboard functions.

• Send (upload) and receive (download) files.

• Create profiles to automate the logon to frequently used systems.

• Change the layout of the TNHOST Window to suit your 
preferences.

• Resize the window and have fonts resize automatically.

• Change fonts on the fly. Includes 31 crystal–clear bitmap fonts
for all resolutions and includes True Type fonts.
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• Print host files to a printer connected to your PC

• Call TNHOST from EHLLAPI and Visual Basic programs

System Requirements

TNHOST requires the following system resources:

• An Intel 386, 486, or Pentium processor

• Windows 95, Windows NT, Windows 3.1, Windows 3.11, or
Windows for Workgroups 3.11 operating system

• A TCP/IP protocol stack. Supported stacks include those from
Microsoft  (Windows 95 and Windows NT) and Ipswitch
(Windows 95 and Windows 3.x).

Installing TNHOST

The TNHOST distribution kit contains four disks. To install
TNHOST:

1. Install a Windows TCP/IP stack on your system.

2. Insert disk 1 of the TNHOST distribution into a drive.

3. Do one of the following:

– For Windows 95 and NT 4.x, click the Start button, select
Run, and then enter the diskette path followed by install.exe.
For example:

a:install.exe

– For Windows 3.x and NT 3.x, select Run from the File menu,
and then enter the diskette path followed by install.exe. For

example:

a:install.exe
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4. Follow the on–screen instructions to install TNHOST.

5. The installation asks you to select the TNHOST version to
install. The recommended version for your system is preselected.

6. The installation asks you to enter the destination directory for the
TNHOST files. The default directory is: 
   C:\Program Files\TNHOST32

7. The installation asks you to enter a name for the Windows pro-
gram group that it will create. The default name is TNHOST.

8. The installation will prompt you to insert each distribution disk.
Insert the appropriate disk in drive A:\  and click OK  when
prompted.

The installation program installs the files and creates a shortcut
for TNHOST in Windows 95 systems or a program group in
Windows 3.x systems.

Starting TNHOST and Connecting to a Host

This section describes how to start TNHOST and how to create a
connection to a remote TN3270 or TN5250 host system.

To start TNHOST:

• In Windows 95 and NT 4.x, click the Start button and select 
Programs–>TNHOST–>TN3270 and TN5250.

• In Windows 3.x and NT 3.x, open the TNHOST folder and
double–click the TN3270 and TN5250 icon.

The Open New Session dialog box appears.

Starting TNHOST
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To create a connection to a host, you create a new session or use an
existing Session Profile. The Session Profile tells the local system the
name of the host system, and its platform or host type. You can create
up to 26 concurrent sessions. 

To connect to a host:

1. In the IP Host/Gateway field, enter the gateway name, host
name, or IP address; or choose a host from the list box.

The list box displays host names and gateways for those hosts
listed in the TCP/IP host table. See your system administrator for
information on the available hosts.

2. Select the terminal type for this session.

Select 3270 if you will be accessing an IBM mainframe system.
Select 5250 if you will be accessing an IBM AS/400 computer.

3. Select the model for this terminal type.

3270 Models:

3278 Models 2 through 5 are typically monochrome
terminals with very limited functionality.

3279 Models 2 through 5 are color capable versions
of the 3278.

3279–Ex-
tAttr

Models 2 through 5 with Extended Attribute
support are the most powerful version of the
3270 series and capable of sophisticated display.

Sessions

Creating a New
Host Connection
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5250 Models:

Model 2 Model 2 is a 24 line by 80 column terminal.
This is the most popular model used to connect
to AS/400s.

Model 5 Models 5 is a 27 line by 132 column terminal.

4. Enter the TCP/IP Port number to which you want to connect.

The default telnet port number is 23.

5. Click Connect to connect to the host.

TNHOST makes the requested connection and displays the main
window, which prompts for your login information.

6. Enter your login name for the host system and press Return.
Then enter your password for the login account and press Return.

TNHOST now establishes a user session on the host system. In
the main window, you will see a message that identifies the oper-
ating system type for the host system, followed by a command
line prompt, for example:

Operating System ...
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TNHOST lets you save the session configuration in a session profile.
The next time you want to connect to the same system, you can
double–click on the profile name (in the Open New Session dialog
box) to create a session. You can also single–click on the profile
name, change any of the connect options, and then press Connect.

To save the session configuration as a profile:

1. From the Options menu, select Edit Session Profile. The Session
Profile dialog box appears.

2. In the Category list box, make sure 3270 or 5250 is selected
(highlighted).

The options that appear will vary depending on whether you are
connected to a 3270 or 5250 host.

3. Choose the session options you want to use.

You can select any of the other categories in the Session Profile
dialog box to change setting and further customize the session
profile. See the online help for information about the options in
each category.

4. Click the Save... button. The Save Profile dialog box appears.

Using a Profile to
Connect to a Host
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5. Enter a Profile name.

The profile name DEFAULT is used to set the session template
when creating a new session. Thus, if you save options to the
name DEFAULT, it will affect all sessions you create dynamical-
ly using New Session from the File menu. 

6. Optionally, select any of the save options:

Click the Save Window Layout check box to save the session
font and window position.

Click Create Shortcut for Profile to also create an icon in the
program group from which you can start the session.

Click HLLAPI Short Name  to assign the short name required to
use any of the EHLLAPI, HLLAPI, or WinHLLAPI services.

7. Click Save to save the session information to the profile name.

TNHOST stores all its profiles and options in a single file called
tnhost.ini in your Windows directory.

TNHOST lets you create up to 26 concurrent sessions. After connect-
ing to a host, you can dynamically create a new session either to the
same host system or to another host. With the Windows multitasking
capabilities, you can start an operation in one Window and switch to
another one while the first completes.

SInce all terminal session windows are “top–level” windows, you can
open, close, and create icons for each window independently.

Connecting to
Multiple Hosts
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To delete a session, press Ctrl–B from any active window; TNHOST
will prompt you to confirm the deletion of that session. Note: You
should first log out or exit your host operating system to make sure
that your session gets properly terminated.

When a session is deleted, the window will move to the next active
session if there is one. If no other sessions are active, the program
will terminate and you will return to the Program Manager or your
desktop viewer.

To switch between active sessions, you can:  

• From the Window menu, choose the session name.

• Click the left mouse button in any part of another TNHOST ter-
minal window.

• Press Ctrl+N to access the next session.

Unlike other applications, TNHOST does not use a Multiple Docu-
ment Interface (MDI), therefore each window can occupy space on
your desktop. You can minimize one window and work among other
desktop windows.

To exit the TNHOST program, do one of the following:

• From the File menu, select Close Session.  Then, in the pop–up
dialog that appears, click Terminate to exit.

• In the toolbar, click on Close Session. Then, in the pop–up dia-
log that appears, click on Terminate to exit.

• Press Ctrl+Q, then click Yes in the pop–up dialog to exit.

TNHOST disconnects from the host system and then closes all termi-
nal windows. It is preferable to log off active sessions before exiting
TNHOST.

Deleting Sessions

Changing
Sessions

Exiting TNHOST
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If the network link terminates abnormally, a pop up window will indi-
cate that a network error has occurred and that the session is termi-
nated. If you have more than one session active, TNHOST will dis-
play the name of the session that was terminated. The error window
will stay active until you press escape (Esc). Abnormal termination
may be due to problems with the network or because the TNHOST
host is no longer available. When this happens, you must recreate
your sessions manually by pressing Ctrl–A. 

If the session that was terminated was the only terminal window, then
TNHOST is closed and you are returned to the Program Manager.

If the host system or host server is unavailable, then a “PROG505”
will appear in the Operator Information Area. When the system
comes back up, your session will be restarted automatically. In this
situation, the link to the gateway is still active and the gateway can
request the host to restart a session.

A session error will always occur if you terminate the host session by
logging off your host system. Most host TCP/IP products do not auto-
matically re–create the virtual terminal session and TNHOST will
display this error box.

However, you can select the Upon Disconnect from Host–>Restart
Session option (in the General category of Session Profile options) to
automatically recreate a session to a host when the host terminates the
session. This makes a telnet 3270 session work like a real 3270
device.

To re–create a session to the same host, press Ctrl–A and the default
IP address for the host should appear in the dialog box.

Unlike for the DOS version of TN3270, configuration parameters are
not required in the Windows environment.

Session Errors
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Using the TNHOST Window

The TNHOST main window (shown below) displays many standard
Microsoft Windows features such as scrollbars, maximize/minimize
buttons, a toolbar.

The menu bar lists common Windows features such as File and Edit
commands and also contains emulator–specific features, such as
Transfer, Fonts, and Options. To view descriptions of each menu
item, choose Contents from the Help menu, then click on Menus.

All host communications scroll through the window as they are 
received.

The Toolbar contains buttons for the most used functions in
TNHOST. You can click on a button to activate the function. Place
the cursor on the button (do not click) to pop up a description of the
button’s function. 

The toolbar is completely customizable. You can change the toolbar
button assignments to represent any command or Quick–Key. See the
“Using Options to Customize TNHOST” section in this chapter for
more information.

Main Window
Components

Toolbar
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When you complete a successful login to the host system, the
TNHOST screen is in emulation mode. In emulation mode, you will
see the command prompt for the host system. From the command
prompt, you can run host applications, and execute commands.

The 25th line of the display is dedicated as the Operator Information
Area, or OIA. The OIA displays information about the status of the
current session. 

Within the OIA, the following indicators may occur:

X–SYSTEM Keyboard Locked

Warns that the keyboard is locked. You must press the Reset key be-
fore any other operation can take place. This indicator is always on
after you press an action key such as Enter or a PF key. The host
system will usually unlock the keyboard automatically.

Insert

Insert Mode. Shows that Insert Mode is toggled on. You can reset by
pressing the Insert key again, the Reset key, or any AID generating
keys. (AID or attention generating keys are: Enter, PA1, PA2, PA3,
Clear, and PF1 to PF24)

Sess–1

Session Name. Column 20 in the OIA is the session long name. This
is an 8 character name identifying which session you are currently
viewing. You can change this string can by using the “name” com-
mand in the profile. The default values are from “Sess–1” to
“Sess–5”.

DOC

Entry Assist Enabled. Shows that the Entry Assist feature is enabled.

ß

Word Wrap Enabled. Shows that the Entry Assist Word Wrap feature
is enabled.

Emulation Mode

Operator 
Information Area
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PROGxxx

A severe error has occurred in the 3270 or 5250 data stream. Consult
the IBM 3270 or 5250 manual or 3x74 manual for a description of
error codes (e.g. PROG505 means that the host is unavailable.).

Alt

Alternate character set selected. This indicator appears when the al-
ternate character set select key is pressed to enter an ALA character.

1.2.3.4

IP Host. The last field in the OIA is the IP address of the host to
which the session is connected.

TNHOST provides help using the standard Windows Help engine.
TNHOST provides context sensitive help in all dialogs by pressing
F1 or the Help button. While in the main terminal window, you can
get help by selecting the Help menu option.

If Windows cannot locate the help file, check that is either in the
same directory as the TNHOST program file or in the Windows pro-
gram directory.

Help
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Setting Up and Using the Keyboard and Mouse

The TNHOST emulator maps the keyboard on your PC to the default
key settings on a TNHOST terminal. This mapping lets you use ap-
plications on hosts that require TNHOST function keys.   

To view the default key mapping, from the Help menu choose 
Keyboard Map.

TNHOST also supports the ALA character set for use with NOTIS
and DOBIS Library systems. See the ALA support section in this
chapter for more information.

You can fully redefine the keyboard to a layout of your choice. The
following sections describe the keyboard and mouse functions.

To change the keyboard layout:

1. From the Options menu, select Terminal Settings–>Keyboard
Mapping. The Keyboard Mapper dialog box appears.

2. To change a key mapping, first press the key button that you
want to redefine. The display area in the bottom left hand side
will display the current key mappings for the various key states.

3. To assign a function to a key combination, select the key com-
bination (Normal, Shift, Control, or Control+Shift).

Creating a Key
Mapping
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4. Select the Function Type you want to assign to the key combina-
tion. Click the Help button to find a description of each function
type.

The Functions list box contains the functions available in the
selected Function Type category.

5. To assign a new function to a key combination, select the func-
tion or character in the list box, and then click Set. The new
value will appear beside the key combination name.

To reset a key (all states) to its default value, select the key and
then click the Default button. To clear an entry to a null value,
select the key combination and then click the Clear Entry  but-
ton.

6. When you have completed your changes, click OK  to save the
changes only for the current session, or click Save to save the
changes to a profile.

It is assumed that all alphanumeric keys produce the standard alpha-
numeric values.

To reset the entire keyboard back to the default setting, click the 
Reset All button, then click Yes in the pop–up dialog box to confirm.

To view the current key assignments, that is, if you want to know
what key performs a given action, click the List Assigned Functions
button. The Current Keyboard Template dialog box appears and
shows all current key definitions.
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To print the current keyboard template, click the Print... button. This
will format the current keyboard template and print it on the printer
of your choice. You can change the font used to print the text.

Although the mouse is not required with TNHOST, it is a very impor-
tant tool to facilitate many day to day functions. For example, click-
ing the left mouse button anywhere on the screen will move the cur-
sor to that location.

The mouse provides drag–and–drop capabilities through which you
can perform edit functions (such as move, copy, paste, and cut) on the
text displayed on the emulator screen.

To: Do this:

Select a block of
text

Press the left mouse button at the begin-
ning of the text to select, then drag the
mouse to the end of the text block. The
block of text is highlighted.

Drag–and–drop
text

Select the text, then press and hold the left
mouse button with the pointer inside the
highlighted text, drag the text to a new
location and release the mouse button.

Copy text Select the text, then press and hold
Ctrl+left mouse button with the pointer
inside the highlighted text, drag the text to
a new location, release the mouse button
then the Ctrl key.

Cut text to the
Clipboard

Select the text and press Ctrl+X.

Copy text to the
Clipboard

Select the text and press Ctrl+C.

Paste text from the
Clipboard

Move the cursor to any location on the
screen and press Ctrl+V.

Copy the screen to
the Clipboard

Press Ctrl+Numpad 5 (Numpad 5 is the
’5’ key in the keypad area. The NumLock
must be off for this combination), then
press Ctrl+C.

You can select the text highlighting method by choosing Edit Session
Profile from the Options menu. In the Cursor category in the Ses-
sion Profile dialog box, you can select between a reverse highlight
block or a rubber–band style selector box for the mouse select mode.

Using the Mouse
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The default mouse actions are:

Mouse button Action

Click left button Move the cursor to the pointer location

Click right button Move the cursor to the pointer location
and press the Enter key. This is very useful
for applications that use pull–down menus,
such as Rice MAIL.

Click and drag left
button

Highlight a block of text to delete, move,
or copy to another location on the screen
or clipboard

Double–click left
button

Activate hotspot feature. If the text at the
pointer location corresponds to any hot-
spot text, the hotspot action is performed.

Shift+click left
button

Perform Clear key action

Shift+click right
button

Perform Enter key action

Ctrl+click left 
button

Perform PA1 key action

Ctrl+click right
button

Perform PA2 key action

Shift+Ctrl+click
left button

Bring up Track Menu

Shift+Ctrl+click
right button

Bring up Track Menu

You can permanently change the mouse actions by selecting Edit
Session Profile from the Options menu. In the Session Profile dialog
box, select the Mouse category. In this category, you can change all
mouse features except for the left mouse button which is reserved for
pointing and selecting text. 

Default Mouse
Actions

Changing the
Mouse Actions
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To change a mouse action:

1. Select the mouse button combination (in the topmost list box)
that you wish to change.

2. Select a Function Type to view the available functions in the list
box. Click Help to find a description of each function type.

3. Select one of the mouse functions in the Function box (bottom
list box), and then click Set.

Click Reset to reset the mouse option to its default value.

4. When you have completed your changes, click OK  to save the
changes only for the current session or click Save Options... to
save the options permanently to a profile.

If Auto Save is enabled, then the options are automatically saved
to the current profile when you click OK .
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Automating Common Tasks

TNHOST provides the following features for automating common
tasks. Many of these features are designed to work together to let you
fully automate your session.

• Quick–Keys

Save sequences of keystrokes and commands that you frequently
use to Quick–Keys. Quick–Keys can be used in hotspots and
poppads to easily execute a sequence of commands, and can be
mapped to keys on the keyboard. You can also automatically
execute Quick–Keys when TNHOST connects to a host.

• Macros

Record tasks that you perform on the host or write macros using
the TNHOST Basic editor. Macros can be run from the Macro
menu, used in hotspots and poppads, and mapped to keys on the
keyboard. You can also automatically execute macros when
TNHOST connects to a host.

• Hotspots

Designate text strings on the host screen as hotspots that auto-
matically execute functions. You can set up hotspots to automati-
cally type action keys, editing keys, or characters and execute
system commands. macros, and Quick–Keys.

• Poppads

Store frequently used functions on a floating pop–up toolbar,
called a poppad. You can set up poppads to automatically type
action keys, editing keys, or characters and execute system com-
mands, macros, and Quick–Keys.

The following sections describe how to set up and use these automa-
tion features. These features, in combination with the ability to con-
figure your mouse, keyboard, and the toolbar, allow you to automate
most TNHOST tasks. The TNHOST help system also provides exam-
ples of each feature.
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A Quick–Key is simply a sequence of keystrokes that can be easily
referenced and assigned to a key. Quick–Keys allow you to automate
repetitive tasks. 

Quick–Keys can contain two types of objects:

• Quoted strings –– ASCII strings surrounded by double quotes.

• Functions ––  one of the functions displayed in the list box.

To create, edit, and delete Quick–Keys, you use the Quick–Key
Editor.

To create a new Quick–Key:

1. From the Options menu, select Terminal Settings–>Quick–Key
Editor . The Quick–Key Editor dialog box appears.

2. In the Quick–Key Name text box, enter the Quick–Key name .

3. In the Assigned Quick–Key String text box, enter a string.

A Quick–Key can be up to 254 bytes long and contain an unlim-
ited number of strings and commands. All words must be sepa-
rated by a space. For example, you must have a space between
system commands and quoted strings. You should always sur-
round text in double–quotes.

Creating/Using
Quick–Keys
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To add functions to the Assigned Quick–Key String edit box,
select a Function Type, then click on the function you want to
add in the Functions list box, then click the Append Function
button. The program will append the function name and add a
space if necessary. Click the Help button to find a description of
each function type.

4. Click the Set button to save the Quick–Key.

You can create as many Quick–Keys as you want. Note that
Quick–Keys are system–wide and are not stored in session pro-
files.

You can run Quick–Keys from the Quick–Key dialog box or run them
automatically at startup. However, Quick–Keys are usually used in
combination with other TNHOST features like hotspots and poppads.

To assign a Quick–Key to a hotspot or poppad, or map it to a key-
board button:

• In the Define Hotspots, Configure Poppad, or Keyboard Map-
ping dialog box, select the Quick–Keys option in the Function
Type list and select the Quick–Key you want to assign from from
the Function list.

To run a Quick–Key from the Quick–Key Editor dialog box:

• Select Edit Session Profile from the Options menu, then select
the General category in the Session Profile dialog box. Type the
Quick–Key name in the Auto Start Quick–Key box. Note that
you must save the current session to a session profile in order to
have the Quick–Key run at startup.

You can use macros in TNHOST to perform a sequence of tasks.
Macros are versatile; you can run macros directly from the Macro
menu, assign them to hotspots or poppads, and run them automatical-
ly when you connect to a host. 

Creating/Using
Macros
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There are two ways you can create macros in TNHOST:

• Use the macro recording feature to record keystrokes you press
on the host.

• Use the TNHOST’s Basic Editor

To record a macro:

1. In the Macro menu, select Start Recording.

2. Perform the steps you want to record. (Note that the macro re-
cording feature only record what you type; it does not record
mouse actions.)

You can select Pause Recording from the Macro menu to tem-
porarily stop recording your actions; recording will start again
when you select Resume Recording from the Macro menu.

3. Select Stop Recording from the Macro menu to stop recording
the macro. You will be prompted for a filename in which to store
the macro. The extension .wwb is recommended.

You can edit the macro at any time using the TNHOST Basic Editor;
you can access the editor by selecting Edit  from the Macro menu.

To create a macro using the TNHOST Basic Editor:

Note:

The TNHOST Basic Editor is compatible with Visual
Basic. For help with the Basic Editor and the Basic lan-
guage, select Editor Help or Language Help from the
Basic Editor’s Help menu.

1. From the Macro menu, select Edit . The TNHOST Basic Editor
appears.

2. Type the text for your macro.

3. From the Basic Editor’s File menu, select Save to save the
macro; the extension .wwb is recommended.

You can then run the macro from the Macro menu, or run it auto-
matically on startup.
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To run a macro:

• Select Run from the Macro menu and enter the filename of the
macro you want to run. Click Open to run the macro. You can
stop the macro by selecting Stop from the Macro menu. To re-
sume running the macro, select Continue from the Macro menu.

To automatically run a macro on startup:

• Select Edit Session Profile from the Options menu, then select
the General category in the Session Profile dialog box. Type the
macro name in the Auto Start Quick–Key box. Be sure to specify
the full pathname of the macro (for example: c:\hc\bin\mylogin.wwb).
Note that you must save the current session to a session profile in
order to have the macro run at startup.

You can use the hotspots feature to perform actions by clicking on
text on the host session screen. For example, many electronic mail
packages have the PF key legend at the bottom of the screen. The
format is usually something like: “PF2:Read, PF3:End”. If you
double–click the left mouse button on any point of the “PF2” text,
TNHOST will press PF2 automatically. 

Note that hotspots will not be displayed on the screen unless you have
checked the Show Hotspots option in the Display category of the
Session Profile dialog box.

You can assign system commands, action keys, editing keys, Quick–
Keys, characters, or macros to a hotspot. Hotspot text strings must be
one word with no intervening blanks. Any valid ASCII character can
appear in the text string.

TNHOST automatically recognizes the following text strings as hot-
spots (n represents any digit):

Program Function Keys: PFn,  PFnn,  Fn,  n, nn

Program Attention Keys: PAn  An

For example, the following strings would automatically be recog-
nized as hotspots: PF1, PF2, F1, F12, 1, 12, PA1, PA2, A1

Hotspots
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The text strings must be delimited on the left side with a blank, null
character, or field attribute. For example, if you have defined the text
string PF2 as a hotspot, PF2: would be recognized as a valid hotspot,
but xPF2 would not, since it is not delimited by a blank. The right
delimiter can be any non–numeric character.

To add new hotspots, from the Options menu, select Terminal
Settings–>Hotspots. The Hotspots dialog box appears. 

To add a new hotspot:

1. In the Hotspot Text box, enter the text you want to use as the
hotspot text.

2. If necessary, specify a termination character in the Hotspot Ter-
mination Characters box. A termination character is a character
that follows a hotspot; the hotspot text must be followed by one
of the characters in this box in order for it to be recognized as a
hotspot. For example, if Exit!  is located on the screen and you
want the word Exit  to be a hotspot, you would have to specify an
exclamation mark as a termination character.

3. Select the Function Type to view the available functions in the
Function list box. Click Help to find a description of each func-
tion type.

4. In the Function box, select the function you want to assign to the
hotspot. Descriptions of the functions will appear in the Descrip-
tion box as you scroll through the functions.

Creating/Using
Hotspots
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5. Click the Set button to map the function to the hotspot text.

The new combination will be added to the Hotspot Text com-
bination box and the selected action will appear in the Hotspot
Action box.

6. When you have finished making changes, click the Close button.

All Hotspot entries and options are automatically saved to a
global profile. They are saved in the file tnhost.ini in your Win-
dows directory. You do not need to save your user profile to save
the hotspot entries.

There is no limit to the amount of hotspot entries that you can add.

The option Case Sensitive is a system–wide feature. Checking this
option will affect all hotspot entries currently defined. A check in this
box indicates case sensitivity is turned on.

To delete a hotspot definition, select the hotspot text in the list box
and click the Delete button.

To view hotspots, check the Show Hotspots item in the Display cate-
gory of the Session Profile options. This will display the hotspot texts
as black text on a gray background.

Poppads are floating toolbars that display buttons that you can click
to automate frequently typed text or functions. TNHOST includes a
default poppad containing many frequently used keys. 

You can also create your own custom poppads that contain buttons
that perform actions you specify. You can set up poppads to automati-
cally type action keys, editing keys, or characters, and execute system
commands, macros, and Quick–Keys. For instance, you could create
a poppad that contains buttons that automatically type your library
card and phone number (along with the Enter key), for use on a li-
brary system that requires this information to verify your identity.

Items in the poppad are tiled from left to right and then down, as you
write English text. Once you load the poppad, you can drag the bor-
der to resize it to the size you desire. You can display up to 5 different
poppads concurrently.

Creating/Using
Poppads
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To create a poppad:

1. In the Options menu, select Terminal Settings–>Poppad. The
Configure Poppad dialog box appears.

2. Delete any of the buttons you do not want to have on your new
poppad by clicking on the button name in the list at the top of the
screen and clicking the Delete key.

3. You can now create a new button by typing the text you want to
appear on the button in the Button Text box. Beware that the
longer the text, the larger the buttons will be. All of the buttons
in the poppad are the size of the largest button.

4. Select the Function Type to view the available functions in the
Function list box. Click Help to find a description of each func-
tion type.

5. In the Function box, select the function you want to associate
with this poppad button.

6. Click Add to add the the poppad button.

The button will be added to the end of the list. You can use the
Move Up or Move Down buttons to reposition it. You can add as
many buttons as you want to this poppad.

7. Click Save to save the new poppad. The Save Profile dialog box
appears and prompts you to name the poppad profile. You can
specify a new name for the profile, or specify the name of an
existing profile to save this poppad over an existing profile. Click
OK  to save the poppad.

Note:

Poppad profiles are not related to profiles that you create
in the Session Profile dialog box, or by selecting Save
Options from the Options menu. Any poppad you create
can be used when you’re connected to any profile.
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To change a poppad:

1. In the Configure Poppad dialog box, click Load and specify the
name of the poppad you want to change.

2. Click on the poppad button you want to change.

The button text and function for the button appear in the Button
Text and Function boxes.

3. Change the text or function as desired and click Change.

To reposition the button on the poppad, use the Move Up and
Move Down buttons.

To delete a button, click on Delete.

4. Click Save to save your changes. The Save Profile dialog box
appears. Select the name of the profile and click OK .

To display and use a poppad:

1. In the View menu, select Poppad.

2. Select one of the options: To load the default poppad, click
Default; to load a custom poppad, click Custom, enter the name
of the poppad, and then click OK .

You can click on poppad buttons to activate the associated func-
tions.

You can move and resize the window using the standard Win-
dows functions.

You can open several poppads at once. Any poppads you display
will stay open until you close them, regardless of which host you
are connected to. You can close a poppad by double–clicking the
upper left corner of the poppad.
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Printing Host Files

There are three print utilities that you can use to print host files to
your a printer connected to your local PC:

• PCPRINT utility

• TPRINT utility

• TNPRINT PrintExplorer

PCPRINT Utility

The PCPRINT utility, found on many host systems, is a program that
runs on your host system that will allow you to print files from your
host system to your PC printer. It is identical to downloading the file
and then printing the file but it does it in one step. The PCPRINT
syntax is listed below.

PCPRINT for CMS

For CMS, PCPRINT uses the following syntax:

PCPRINT fn ft  [fm] [(  [LPT1/LPT2/LPT3] [CC/NOCC] [FF] [BIN]

PCPRINT for MUSIC

For MUSIC, PCPRINT uses the following syntax:

PCPRINT filename   [[LPT1/LPT2/LPT3] [CC/NOCC] [FF] [BIN]

PCPRINT for TSO

For TSO, PCPRINT uses the following syntax:

PCPRINT datasetname   [[LPT1/LPT2/LPT3] [CC/NOCC] [FF]
[BIN]

You can use the following options with the print command:

CC

Direct PCPRINT to use the first column of every line as the carriage
control character

Command Line
Options
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NOCC

Direct PCPRINT to not use the first column as the carriage control
column. On CMS, TNHOST automatically enables the CC option for
LISTING file types.

FF

Direct PCPRINT to add a form feed at the end of the print job.

BIN

Direct PCPRINT to download the file in binary mode. By default, an
EBCDIC to ASCII conversion is performed but with the BIN option,
the data is sent directly to the printer.

You can configure the output of PCPRINT jobs by using the options
in the PC Print Category of the Session Profile dialog box.

TPRINT Utility

TPRINT is another printing utility that uses 2048 byte blocks.
PCPRINT is more efficient than TPRINT and should always be used
if you have the choice.

TNHOST supports Yale’s TPRINT facility by supporting the 7171
transparent data stream commands. In transparent mode, the program
will support the VT100 Printer On/Off escape codes to direct trans-
parent output to the logical printer port 1. TNHOST does support the
4994 inquiry command and will respond with a VT100 terminal type.

TNPRINT PrintExplorer

The PrintExplorer is a TNHOST print utility that lets you print host
files using your local system’s Windows 95 or NT printer setup.

To display the PrintExplorer main window:

• In Windows 95 and NT 4.x, click the Start button and select
Programs–>TNHOST–>TN PRINT.

• In Windows 3.x and NT 3.x, open the TNHOST folder and
double–click the TN PRINT  icon.

Refer to the TNPRINT PrintExplorer’s help system for information
on how to set up and print host files.
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Transferring Files 

You can transfer files between your personal computer and the
TNHOST host. The emulator includes an ASCII file transfer plus
four popular protocols for error free file transfer:

You can receive files on your PC from a TNHOST host as follows:

1. Click the Download button; or, from the Transfer menu, select
Receive (download).

The Download a File dialog box appears.

2. Enter the name of the file on your PC to which you will transfer
a host file.

3. Enter the name of the host file to transfer.

4. In the Host System list box, select the host operating system
from which you are downloading files.

Select one of the operating system choices: CMS, TSO/MUSIC,
CICS. This option must be selected for other options to work
properly.

5. Enter any transfer options that you want to use.

Each option is described at the end of this procedure.

Receiving (down-
loading) Files
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6. Click the Start button to transfer the file.

When the file transfer is completed, you will hear two “beeps.”

You can use the following download options:

Disk

Download a file to your disk. The file can be on your local disk or
any networked volume accessible to your machine.

Clipboard

Download the host file directly to your clipboard. The file is place in
the clipboard in CF_TEXT format.

You can use the following general option:

ASCII

Translates the file from EBCDIC (IBM Host character set) to ASCII
while downloading the file. This option is normally required when
transferring text files.

CRLF

Translates records on the host file system to CR–LF ( carriage return–
linefeed) end of line characters. This option is normally required
when transferring text files.

APPEND

Append the file to the existing file on the host.

This edit field allows you to enter other operating system specific
options which are not directly supported by the dialog box options.
The options must be entered in the appropriate operating system for-
mat. No editing is performed on these parameters; they are appended
directly to the file transfer command.

Download to 
Options

General Options

Extra File Transfer
Options



 31Using TNHOST

TNHOST Terminal Emulator

You can send file from your PC to a TNHOST host as follows:

1. Click the Upload button; or, from the Transfer menu, select
Send (upload).

The Upload a File dialog box appears. 

2. Enter the name of the file.

3. Enter the name of the host file.

4. In the Host System text box, select the host operating system to
which you are uploading files.

Select one of the operating system choices: CMS, TSO/MUSIC,
CICS. This option must be selected for other options to work
properly.

5. Enter any transfer options that you want to use.

Each option is described at the end of this procedure.

6. Click the Start button to transfer the file.

When the file transfer is completed, you will hear two “beeps.”

Sending (upload-
ing) Files
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You can use the following upload options:

Disk

Download a file to your disk. The file can be on your local disk or
any networked volume accessible to your machine.

Clipboard

Download the host file directly to your clipboard. The file is place in
the clipboard in CF_TEXT format.

You can use the following general option:

ASCII

Translates the file from ASCII to EBCDIC (IBM Host character set)
while uploading the file. This option is normally required when trans-
ferring text files.

CRLF

Translates CR–LF ( carriage return–linefeed) end of line characters to
records on the host file system. This option is normally required
when transferring text files.

APPEND

Appends the file to the existing file on the host.

You can use the following record format options:

Default

Lets the host portion of the file transfer use the default record format.

Fixed

Upload the file to a Fixed Record format file.

Variable

Upload the file to a Variable Record format file. Use this option if
you are transferring a binary file (i.e. program file, such as .EXE,
.COM, .DLL) and you want to preserve the exact file size.

Upload to Options

General Options

Record Format
Options
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Undefined

Upload the file to an Undefined Record format. This option is valid
for the MVS operating system only.

You can use the following file format options:

LRECL

Enter the logical record size for the file that will be created on the
host.

BLKSIZE

Enter the block size for the file that will be created on the host. This
option is valid for the MVS operating system only.

This edit field allows you to enter other operating system specific
options which are not directly supported by the dialog box options.
The options must be entered in the appropriate operating system for-
mat. No editing is performed on these parameters; they are appended
directly to the file transfer command.

Using Entry Assist Mode

TNHOST’s Entry Assist function enhances the ability to create and
edit text material such as memos, letters, reports, and lists. Unlike
real 3270 or 5250 terminals, TNHOST does not require support from
IBM host editors or the IBM host system.

Since TNHOST was designed for a PC, its implementation of Entry
Assist is a superset of the standard IBM Entry Assist. When Entry
Assist is enabled, the following extensions are available:

• Word wrap

• Columnar tabbing

• Audible end–of–line signal (Bell)

• Cursor position display

• Definable home position

File Format 
Options

Extra File Transfer
Options
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TNHOST provides cursor word positioning, word delete, and tab to
end–of–line functions without requiring Entry Assist to be enabled.

Unlike other emulators, the Word Wrap feature can work within pre-
set margins, or can automatically use the field width as the left and
right margins. This allows you to easily use Word Wrap from system
to system, without constantly setting margins.

You can set the values for the margins, tabs, and bell margin options
as follows:

1. Click the Edit Session Profile button; or, from the Options
menu, select Edit Session Profile. The Session Profile dialog
box appears.

2. Select the Entry Assist category.

3. Select or enter values for any options you want to use. The fol-
lowing table describes each option.

4. When you have selected options, click OK .

You can choose any of the following options:

Entry Assist Enabled

When checked, enables Entry Assist mode for data entry on the 3270
screen. TNHOST will use the margins and parameters defined in this
dialog.

Word wrap enabled

When checked, enables word wrap, if Entry Assist Enabled is
checked.

Margins

Enter column numbers to specify the left, right, and bell margins. The
bell margin is where a bell will sound when the cursor passes the col-
umn.

Tab Stops

Enter a column number and press the Set button to add a horizontal
tab stop. To Clear an entry, first select the entry, then press the Clear
button. To clear all tab stops, press the Clear All button.

Setting Entry
Assist Options
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To enable Entry Assist for the current session, enter Ctrl+E from any
3270 or 5250 session. Any of the word wrap, margin, or column set-
tings that you specified in the Entry Assist Category of the Prefer-
ences dialog box are now enabled.

The DOC indicator appears in the message area (OIA) at the bottom
of the screen. A cursor position indicator is also shown.

To interactively change the margins, tabs, or bell margin, select
Entry Assist Category in the Preferences dialog and make the
changes.

Using Options to Customize TNHOST

TNHOST allows you to set each option independently for each termi-
nal session. This allows you to customize each session and save the
options to a profile.

To change the session options, display the Session Profile dialog box
by selecting the Edit Session Profile... from the Options menu or by
clicking on the Edit Session Profile button. 

The Category list box allows you to choose which category of op-
tions you wish to change. When you select a new category, the dialog
options will change to reflect options for this category.

Use the mouse or keyboard to toggle or change any of the options in
the dialog box. Click Help in the Session Profile dialog box to dis-
play a description of each option in the Category.

Enabling Entry 
Assist
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The Session Option Categories include the following:

3270 Category

Sets options for 3270 sessions.

5250 Category

Sets options for 5250 sessions.

ALA Category

Sets the ALA options. See the “ALA Support” section in this chapter
for more information.

Colors Category

Changes the colors assigned to 3270 or 5250 field types.

Color Palette Category

Changes the color mix for the base 16 colors that are available.

Cursor Category

Specifies options for the TNHOST cursor.

Display Category

Specifies options that affect editing and display capabilities in 3270
and 5250 sessions.

Entry Assist Category

Specifies the Entry Assist options. See the “Using Entry Assist” sec-
tion in this chapter for more information.

External Programs Category

Sets the names of the external utility programs used in TNHOST.

File Transfer Category

Specifies the file transfer options.

Font Category

Specifies font preferences for TNHOST sessions.

General Category

Sets general options for the TNHOST sessions.
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Host Category

Sets options used for the session hostname.

Keyboard Category

Specifies which keyboard profile should be used for the current ses-
sion and profile.

Mouse Category

Specifies the mouse options. See the “Changing the Mouse Actions”
section in this chapter for more information.

PCPRINT Category

Controls how 7171 and PCPRINT passthru printing is handled.

Print Category

Specifies options used when printing a screen using the Print–Screen
command or menu option.

Save Category

Configures options for Save Screen to Disk and Capture commands.

Toolbar Category

Configures the toolbar to perform the actions you choose.

Window Title Category

Specifies the Window title.

Translate Tables Category

Edits the ASCII/EBCDIC translate tables that are used for characters
in TNHOST.

With TNHOST, you can save all of the session tailored options such
as Session Profile, Entry Assist, Colors, Mouse, and ALA Options
into a profile. When you create a session, you can use the information
from the profile to tailor the session.

There are two types of profiles: user defined profiles and the default
profile.

Saving Options
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User defined profiles are those that you create yourself and save to
disk. When you create a new session, you can still override the IP
host/gateway name, terminal type, and terminal features in the Create
Session dialog.

The second type is the default profile. When creating a session,
TNHOST uses the profile called DEFAULT to set the session charac-
teristics. You can tailor this profile to your liking by making the
changing the required preferences and then saving them to a profile
called DEFAULT.

ALA Support

One of TNHOST’s most powerful features is its ability to display the
ALA character set for use with the NOTIS and DOBIS Library Sys-
tems. TNHOST fully supports the ALA character set as defined by
ANSI standard Z39.47.

TNHOST achieves this support easily by providing two True Type
fonts that contain the complete ALA character set. This allows it to
display any 3270 or 5250 panel containing a mixture of EBCDIC and
ALA characters at any screen size. The design also allows the screens
to be printed to any Windows supported printer.

The workstation program currently supports up to 3 diacritics per
base character (which can be a plain EBCDIC character or ALA stan-
dalone character). This enables it to support languages such as Thai
or Vietnamese.

To enable ALA support, check the Enable ALA Support entry in the
dialog ALA options from the Options menu. The support will be en-
abled only if the ALA fonts are installed in your Windows system. To
verify this, check the Fonts dialog from the Control Panel and see if
the fonts ALA Courier New (True Type)  and ALA Lucida Sans
TypeWriter (True Type)  are present. If they are not, then reinstall
the software from the installation disk so that the fonts are properly
installed.

With the fonts installed and ALA enabled, your PC will now be able
to display the ALA characters. You can now access NOTIS or DO-
BIS and try to display panels with ALA characters.
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If the screens do not appear to contain any ALA characters, then it is
most probable that your access methods to CICS are not properly
setup to enable ALA support. Check with your NOTIS/DOBIS or
CICS system administrator.

TNHOST supports independent input and output modes. You can
instruct the emulator to display diacritic sequences in superimposed
mode. For example, the German word “für” is display as “für”. In
Side–by–Side mode, the word is displayed as “f¨ur”. For data entry,
Superimposed can be though of as a “Compose” mode whereas Side–
by–Side is a normal data entry mode.

To allow easy input of ALA characters, TNHOST supports an alter-
nate keyboard map to access the full ALA character set. This map is
nearly identical to the 3163 keyboard and TN3270 for DOS. This will
make it easy for you to convert to TN3270.

However, if you prefer to change the keyboard, you can do so by
pressing the Keyboard Mapping button. This will bring you into the
Keyboard Mapping editor where you can assign any system function
to a key combination. See the Keyboard Mapping section in this
chapter for more information.

To access the alternate keyboard map, you must assign a key to be the
alternate keyboard select function in the main keyboard layout.

TNHOST does not have a key assigned to the function ALA–Alter-
nate–Input by default. This means that until you assign a key, you
will not be able to access the default ALA alternate keyboard. To as-
sign a key to this function, select the Keyboard Mapping... option
from the Options menu. Then press the button with the key that you
want to assign the ALA–Alternate–Input function and press Set. Then
select the ALA–Alternate–Input from the list box and press OK.

Both the NOTIS and DOBIS systems implement support for ALA by
using the ’holes’ in the EBCDIC character set for the ALA character
set. Although this is an efficient method, it precludes use of any alter-
nate character set, basically anything but the plain US English code
page.

NOTIS and DOBIS
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The main difference between NOTIS and DOBIS from the worksta-
tion’s point of view is that the ALA character set use different EB-
CDIC code points. For example, the beta character “ß” (ALA code
point 0x3E) has an EBCDIC value of 0xFB for NOTIS but has an
EBCDIC value of 0xAB for DOBIS.

To change the internal support for DOBIS, you must add the follow-
ing line to the [System.Settings] section in the tnhost.ini file.

[System.Settings]
...leave current options...
Host ALA System = DOBIS

EHLLAPI

 TNHOST supports the EHLLAPI standard interface mechanism.
This interface allows other Windows programs to communicate and
control the emulator.

The ACS3EHAP.DLL included with TNHOST provides support
identical to the Attachmate EHLLAPI. Since most vendor products
support multiple EHLLAPI DLLs, always choose the Attachmate
EHLLAPI entry since TNHOST emulates the functionality of that
one.

The acs3ehap.dll file must be in your path so that it can be loaded by
Windows when you run your client application.

Before you can use the EHLLAPI interface, you must set the Profile
Name Association. TNHOST needs to know what EHLLAPI Short
Name is associated with what profile. With this association, the EHL-
LAPI DLL can load the emulator and start sessions automatically.

To set a short name, select the short name letter, select the profile,
and press the “<< Set <<“ button. To clear a mapping, select the letter
and press the “>> Clear >>“ button. When you have completed your
changes, press OK to save the settings to disk.

If you wish to develop EHLLAPI applications, we suggest you order
the EHLLAPI development kit from Attachmate. This part comes
with a complete reference for EHLLAPI and some sample programs.
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It is not recommended to unload TNHOST before unloading the
EHLLAPI client application. This will cause your system to crash
since EHLLAPI will be attempting to communicate with a non–exis-
tent program.

A few EHLLAPI calls are not supported. Support will be added in a
future release. They are:

50 Start Keystroke Intercept
51 Get Key
52 Post Intercept Status
53 Stop Keystroke Intercept

Special Profile Options

There are a number of system tuning parameters which you can
manually insert in the tnhost.ini in the Windows directory. These pa-
rameters allow certain default characteristics to be modified.

System wide changes can be made by adding/changing an entry in the
[System.Settings] section of the tnhost.ini file. The following options
are available:

Printer Font

Allows you to change the default printer font used to print the key-
board template from Times New Roman to any True Type font of
your choice. Example:

[System.Settings]
Printer Font = Arial

ALA Host System

Allows you to change the ALA host system type from NOTIS to DO-
BIS. Example:
[System.Settings]
ALA Host System = DOBIS

System–wide
Changes
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Max Winsock Receive Size

Allows you to change the default receive size issued to the Winsock
TCP/IP stack. By default, TNHOST uses a 20,000 byte block to re-
ceive data. You can lower this value to solve problems in low
memory situations. Example:

[System.Settings]
Max Winsock Receive Size = 4096

Prompt on Close Windows

Allows you to change the behavior of TNHOST when you either
double–click or select the Close option from the System menu. By
default, the program will close the window without prompting you to
confirm exit. To force the program to prompt on close, add the fol-
lowing line to the System.Settings section:

[System.Settings]
Prompt On Close = On

Large Toolbar

By default, TNHOST use fairly small icons which are easily readable
up to 800x600 resolution. However, at 1024x768 and higher, the
icons get somewhat small. To use the larger set of icons in the tool-
bar, add the following line to the System.Settings section:

[System.Settings]
Large Toolbar = On

Raw Print Screens

By default, the Print–Raw–LPTx functions add a formfeed character
to the end of the print screen job. To disable the formfeed, add the
following line to the System.Settings section:

[System.Settings]
Print Raw Formfeed = Off

Modify Tracing File

By default, the tracing file is created in the root of the current drive as
tnhost.trc. To change the location and name of trace file, add the fol-
lowing line to the System.Settings section:
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[System.Settings]
Trace Filename=F:\TESTPATH\FILE

You can change the host language after installation by changing the
language name in the [System.Language] section. The valid language
names are:  USEnglish, UKEnglish, Swedish, AustrianGerman,
CanadianFrench, and Norwegian. Example:

[System.Language]
Language = Swedish

You can change the following session parameters:

Terminal Name Override

You can override the default mechanism used to negotiate the telnet
terminal type. By default, TNHOST will always try to create the most
’intelligent’ device (using the options specified) and will work its
way down a list to negotiate the telnet terminal type. For example, if
EABs are enabled and a 3279 Model 3 is selected, the system will
first send the terminal type “IBM–3279–3–E”, next “IBM–3279–3”,
and finally “IBM–3278–3”.

If you want to override the name with any completely arbitrary
names, insert the list of names in the “Terminal Name Override” key
and the program will use the names from left to right. Using regular
telnet conventions, the system will always use the last name in the list
as the final terminal type.

The key “Terminal Name Override” should be added to a profile sec-
tion. The sample below uses the profile name VMCMS. Example:

[VMCMS]
...options currently defined...
Terminal Name Override = BIGTERM  SMALLTERM
 NVT

In this example, the system will first send the terminal name BIG-
TERM. If the host refuses this name, then it will send SMALLTERM.
If the host refuses this name, then it will default to NVT.

Host Language
Support

Session Options
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