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Typographic Conventions

We use the following formatting to indicate special elements in this manual:

•	 User Interface Elements: This formatting is used for all user interface elements of 
MxControlCenter: Click on the PTZ Views button.

•	 Values in Selection Boxes: If you are expected to select values in selection boxes, 
these values are formatted as in this example: ... and highlight Unlimited in the 
selection box.

•	 User Input: Input in text entry boxes is formatted as in this example: Double-click 
the camera name and enter the desired name (for example, Back Entrance).

•	 Keys on the Computer Keyboard: The following format is used if you are expected 
to press any keys on the keyboard: Press the Hash key (#) to reset the zoom settings.

•	 File Names: If the text refers to file and folder (directory) names, they are format-
ted as in this example: Double-click the MxControlCenter.msi file to install it.

•	 Cross References: The following formatting is used when referring to other sections 
in this manual: For more information on this topic, see Section 3.2 Backing Up And 
Restoring Settings.

•	 Web Links: Hyperlinks in the text are formatted as follows: For additional information, 
see our www.mobotix.com website.

•	 Explanations: They are presented as follows: 

An image series includes all the images (or the entire video sequence) that have 
been saved for an event (alarm). In addition, ...

•	 Examples: They are presented as follows: 

http://192.168.1.182:8001/?fullscreen=1
(minimizes MxControlCenter to the taskbar)

Manuals For MOBOTIX Products

All MOBOTIX products have corresponding manuals that you can download as *.pdf files 
at www.mobotix.com under Support > Manuals:

•	 Camera Manual Part 1: This camera manual  is different for each camera model 
and describes the specific features for mounting and operating the camera model 
in question.

•	 Camera Software Manual Part 2: This software manual  describes the software 
features of the browser-based user interface for all MOBOTIX cameras.
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Notes On MOBOTIX Hardware Products

• RoHS Declaration: The products of MOBOTIX AG are in full compliance with Art. 5 of 
the German Electrical and Electronic Equipment Act and the E.U. Directive 2002/95/
EC on the Restriction of the Use of Certain Hazardous Substances in Electrical and 
Electronic Equipment (RoHS) as far as they are subject to these regulations. (You 
can fi nd the RoHS Declaration of www.mobotix.com under www.mobotix.com/
eng_US/Support/Spec-Sheets.)

• Disposal: Electrical and electronic products contain many reusable materials. For 
this reason, we would ask that you dispose of MOBOTIX products at the end of their 
service life in accordance with all legal requirements and regulations (or deposit 
these products at a municipal collection center).

MOBOTIX products may not be disposed of with household waste!

If the product contains a battery, please dispose of the battery separately (the corre-
sponding product manuals contain specifi c directions if the product contains a battery).

Disclaimer

MOBOTIX AG does not assume any responsibility for damage resulting from improper use 
or failure to comply with the manuals or the applicable rules and regulations. Our General 
Terms and Conditions apply. You can download the current version of the General Terms 
and Conditions on our website at www.mobotix.com.

Copyright

All rights reserved. MOBOTIX, MxControlCenter, MxEasy, ExtIO and CamIO are interna-
tionally protected trademarks of MOBOTIX AG. Microsoft, Windows, Windows Server and 
the Windows logo are registered trademarks of Microsoft Corporation. Apple, the Apple 
logo, Macintosh, OS X and Bonjour are trademarks of Apple Inc. Linux is a trademark of 
Linus Torvalds. All other brand names mentioned herein may be trademarks or registered 
trademarks of the respective owners.

Copyright © 1999-2009 MOBOTIX AG, Langmeil, Germany.

Information subject to change without notice!
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1  CONCEPT

1.1 What Is MxControlCenter?

MOBOTIX MxControlCenter is a free application that provides the ideal multifunctional 
solution for all your security needs. MxControlCenter allows you to easily connect MOBOTIX 
cameras and third-party cameras to a video security system. It provides a very simple 
method for adding new cameras to a system and viewing the live images they capture. 
A wide variety of viewing options is also available for displaying images from one or 
more cameras.

As a professional video management system, MxControlCenter also acts as a tool for 
handling video and audio data in IP networks. It not only lets you view the images from 
a connected camera in real time, you can also edit them. Note that editing in this context 
means that both the camera and MxControlCenter are capable of manipulating displayed 
images using a number of functions. For example, you can zoom in on one of the images 
supplied by the camera to get a closer look at an area of possible interest or adjust the 
brightness of an image without changing the image settings of the camera.

Furthermore MxControlCenter provides you with the ability to subsequently view and 
search alarm images that have been recorded externally on a fi le server or internally in 
the cameras. A camera alarm, for example, triggered by the camera's motion detection, 
can initiate a specifi c action at the control center. Such actions may include bringing the 
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current live images from the alarm-triggering camera to the foreground and having an 
acoustic signal emitted over the viewer's computer.

In addition to these features, MxControlCenter also allows you to independently display 
and store the alarms of all monitoring cameras. The program can therefore be used 
to perform a subsequent analysis of events that have been recorded within the visual 
range of multiple cameras. Sequencing these image recordings can help you trace the 
events surrounding a burglary, for example. Using the integrated export list, you can then 
combine the video and audio data recorded by one or more cameras into a clip that can 
be exported as an *.avi fi le for further analysis.

This is just one of the many MxControlCenter features that are explained in this manual 
in a clear and concise manner. The following section contains examples of how to use 
MOBOTIX cameras in conjunction with MxControlCenter.

1.2  Application examples

Examples of how to use MxControlCenter are provided in the following sections.

1.2.1 example: Installing And Starting Up A Small Video Monitoring System

The director of a small automobile museum asks an in-house technician to install a surveil-
lance camera to monitor an area of valuable exhibits during opening hours. The in-house 
technician has very little experience with confi guring computers and networks. Yet once 
the technician connects the camera to the existing Ethernet network, and installs and 
runs MxControlCenter on the director's computer, they are able to carry out the necessary 
confi gurations without any diffi  culty. The camera is detected automatically on the network 
under its own name and is quickly confi gured in a few easy steps. Even the director's wish 
for after-hours surveillance of the exhibit rooms and notifi cation of the night watchman 
in the event of any irregularities now appears as a manageable task to the technician.

1.2.2  example: Live Monitoring Of A Parking Garage

MOBOTIX cameras are used to monitor a three-level parking garage. During opening 
hours, a security guard in the parking garage's control room uses MxControlCenter to 
monitor the parking levels in real time. The live monitoring feature is set up to include a 
predefi ned view (a layout) of each parking level based on all the camera images of that 
parking level. MxControlCenter automatically cycles through the parking level views at 
preset intervals (the layout sequencer feature).
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1.2.3 example: Live Monitoring Of Spectators In A Soccer Stadium

To obtain the best images from the MOBOTIX cameras installed at the various ticket 
counters, entrances, and exits of the soccer stadium, the system administrator creates a 
layout beforehand that is specifi cally adapted to the situation at hand.  To that end the 
system administrator positions the individual cameras on a layout of the stadium accord-
ing to their location. Before a game begins, MxControlCenter is launched by security 
personnel in the control center and it automatically displays the right layout for each 
workstation. The head of security can watch live images of the ticket counters and entrances 
before the game, switch to the cameras inside the stadium during the game, and then 
monitor the exits after the game. In critical situations, the security personnel can open an 
alarm plan specifi cally set up for each camera, which lists the radio call frequencies for 
the responsible guard in the area of the camera.

1.2.4 example: Live Monitoring Inside A Train Station

The platforms of a train station are to be monitored with MOBOTIX cameras. Four cam-
eras are installed on each platform for that purpose. Life monitoring is carried out using 
MxControlCenter. A grid layout for each platform is created in the program based on 
the live camera images of that platform (see Section 3.2.1, Grid Layouts). The program 
interface is confi gured so that security personnel can only access the buttons for switching 
layout views (see Section 2.9.2, Customizing The User Interface). It is also confi gured to 
provide visual notifi cation in the image when a connection error occurs or the maximum 
permitted latency time between image creation and display is exceeded (see Section 5.4, 
The “Remote Control” Tab).
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1.2.5 example: Monitoring An Isolated Parking Lot With An Alarm System 
Linked To The Main Offi  ce Of A Security Company

An auto dealership installs MOBOTIX cameras in isolated parking lots where vehicles 
have been damaged repeatedly in the past. A technician defi nes a display layout for each 
parking lot with the cameras that are installed there. Each camera is confi gured to detect 
any movement near the fence surrounding the parking lots.

The infrared sensors  of the night cameras also trigger an alarm when heat is detected. If a 
camera detects a movement, a network message sent from the camera to MxControlCenter 
automatically opens the layout of the relevant parking lot in the main offi  ce of the employed 
security company. An alarm sound is simultaneously emitted until it is acknowledged 
by a staff  member. After acknowledging the alarm, the staff  member can initiate the 
necessary measures.

1.2.6 example: Review Of Images And Alarms After A Burglary Occurred In An 
Offi  ce Building

In addition to live monitoring of the main entrance by the receptionist during regular offi  ce 
hours, the MOBOTIX cameras installed on the fl oors, the staircases, and the parking lots 
in front of and behind the building are confi gured to detect and alert of any movement 
or changes in brightness at night. Furthermore, the manager will receive an e-mail every 
time a camera triggers an alarm.
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Once notifi ed, the manager can search through the video recordings of the cameras in 
the morning without exposing himself or herself to any danger. The route taken by the 
burglar from the parking lot to the actual break-in in the server room can be plotted. A 

"video" can be compiled using these recordings and show the entire burglary up to the 
point when, for example, a stolen computer and printer are loaded into the trunk, includ-
ing the license plate number of that vehicle. It can thus provide valuable evidence for 
further criminal investigation.
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2 GeTTInG STARTeD
This chapter describes the main tasks of MxControlCenter and how to perform them. 
Chapter 3, Advanced Features off ers a more detailed description of the individual features 
while also discussing advanced features that go beyond "normal" installations.

2.1    Installation

If you have an MxControlCenter installation CD, insert it into the DVD drive of your computer.

If you do not have the installation CD or would just like to install an update, you can down-
load the latest Windows installer from the MOBOTIX website as an *.msi fi le and install 
it manually. The latest versions are available at www.mobotix.com under Support > 
Software Downloads > MxControlCenter.

If you insert the installation CD, the installation process will start automatically and you 
will be guided through the necessary steps. If you have downloaded the latest Windows 
installer, double-click the *.msi fi le to initiate the installation process.

The Installer (currently only available in English) copies the application fi les to your computer 
and then creates the designated shortcuts (Desktop, Start Menu, etc.) during the installation 
process. If you have any older program versions installed, the Installer will automatically 
update them without changing your existing confi gurations.
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Caution

MxControlCenter will attempt to fi nd all MOBOTIX cameras in the physically connected 
network (i.e., every MOBOTIX cameras with a factory IP address of 10.x.x.x). Make 
sure that the fi rewall settings on your computer do not block network traffi  c with 
MxControlCenter. If MOBOTIX cameras are found, MxControlCenter. can automati-
cally reconfi gure them so that they are available on your computer.

If you do not have permission to modify these settings on your computer, contact 
your system administrator for assistance.

For detailed information on the automatic camera search feature and manual con-
fi guration, refer to Section 2.2.2, Finding MOBOTIX Cameras.

2.2      Finding And Confi guring Video Sources

Video sources not only refer to MOBOTIX cameras, but also to third-party IP cameras, fi le 
server paths, MxPEG clips and analog cameras connected via MxServer (for example, 
analog dome cameras). Video sources unrelated to MOBOTIX cameras are not found 
automatically and need to be added manually.

2.2.1 Connecting MOBOTIX Cameras

MxControlCenter provides you with a convenient tool for starting up and confi guring new 
MOBOTIX cameras. You do not need extensive network knowledge to properly connect 
your camera. Simply connect the camera to either the Poe switch or the network Power 
Adapter as shown in the fi gures below.

PoE Switch
10/100 MBps

Network (TCP/IP)

10.3.0.199

Installation with PoE switch
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A PoE switch or the MOBOTIX Network Power Adapter provides the power supply and 
network connection to your MOBOTIX camera over an Ethernet cable:

Now make sure that your computer is connected to the same PoE switch or the Network 
Power Adapter (the computer/power connection). When the camera is ready for use, the 
top LeD glows and the two red LeDs blink for the M12 and D12  models and the green 
LeD glows and the red LeD blinks for the M22M and D22M models.

More information on starting up your camera can be found in the respective camera manual.

2.2.2    Finding MOBOTIX Cameras

Launch MxControlCenter after successful installation (see Section 2.1, Installation) by double-
clicking the shortcut that was created by the Installer on your Desktop or the executable 
MxCC.exe fi le in the installation directory.

When MxControlCenter is launched for the fi rst time, the Add Cameras - Search and 
Select dialog box opens and the application automatically searches for MOBOTIX cam-
eras in the local network. To perform a camera search at a later stage, select Camera > 
Add from the menu.

Switch
10/100 Mbps

Network (TCP/IP)

10.3.0.200

Installation with MOBOTIX 
Network Power Adapter



16/152  MxControlCenter Manual:  Getting Started

 © MOBOTIX AG  •  Security-Vision-Systems  •  Made in Germany

 www.mobotix.com  •  sales@mobotix.com  

If your MOBOTIX camera is properly connected, it should appear together with the exist-
ing video sources in the following list:

Detected Cameras Are Located In A Diff erent Subnet

The symbols in the fi rst column and the legend in the dialog box indicate whether you 
can access a particular camera directly from MxControlCenter. Note that you can access 
any camera designated by the green OK symbol. Cameras designated by the yellow 
Diff erent Subnet symbol are located in a diff erent subnet. This usually applies to new 
cameras or cameras that have been reset to their factory settings.

Note

MxControlCenter fi nds all MOBOTIX cameras provided that both your computer and 
the cameras are located in the same physical network .

A physical network includes all devices that access a shared Ethernet network (for 
example, using switches) without having routers that segment the individual portions of 
the network. The actual transmission method (cable, wi-fi , etc.) is irrelevant in this regard.

Select the cameras that you would like to display in a Layout (a view with cameras) and 
click Add selected cameras.
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The Add cameras dialog box now appears. You can choose to either create a new layout 
with the cameras that have been found or simply add those cameras to MxControlCenter.

If some of the selected cameras are in diff erent subnets, MxControlCenter displays the 
following dialog box:

Click Yes to reconfi gure the cameras for the subnet of your computer.

Reconfi guring Cameras In A Diff erent Subnet

In most networks, a DHCP server will automatically assign the IP addresses for network 
devices so that you can apply the default settings in the Confi gure camera dialog box 
(Get IP address automatically). If you would like all cameras to obtain IP addresses 
automatically, select the Apply to all selected cameras checkbox.

If the IP addresses for devices on the 
network are permanently assigned, 
ask your network administrator 
for the appropriate IP addresses 
for the cameras. Once you have 
that information, enter the correct 
IP address and subnet mask for 
each camera in the Use this IP 
address group.

Make sure that the Save confi guration 
permanently on camera checkbox 
is selected so that the cameras 
can be found at the designated 
IP address when you restart your 
computer. Then click OK.

Now wait until MxControlCenter has modifi ed the network settings of the cameras and 
restarted the computer. The status of the reconfi gured cameras changes from Diff erent 
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subnet (blue symbol) to OK. Close the Add Cameras- Search and Select dialog box by 
clicking OK.

Note

You can open the Confi gure Camera dialog box for any video source by right-clicking 
the specifi c video source you want to confi gure in the Add Cameras - Search and 
Select dialog box and selecting Confi gure network from the pop-up menu.

2.2.3   Adding Video Sources Manually

In addition to MOBOTIX cameras that are found automatically, you can also manually add 
video sources to the list of video sources in MxControlCenter.

• Camera: Here, you can enter the known IP address or DNS name of a MOBOTIX 
camera or a third-party IP camera if it was not found by the automatic search feature.

• MxPeG Clip: Adds an MxPEG video clip previously recorded by a MOBOTIX camera 
as a video source.

• Recording Path: Adds the path of an external fi le server where a MOBOTIX camera 
has recorded audio/video data. The videos or snapshots recorded at that location 
can now be played back using the Player or Video Search in MxControlCenter.

2.2.4       Using Video Sources In MxControlCenter

You can now use the list to select the video sources that you would like to display and 
manage in MxControlCenter..

Camera Preview

If you select one camera with the status OK, MxControlCenter 
automatically displays the live images from that camera in 
the preview window. If you are using CTrL-click to select 
several cameras, the image from the camera selected last is 
shown in the preview window. This feature makes it easier 
for you to identify the cameras that you would like to use.

Entrance
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editing The Video Source List

Right-click this list to open a pop-up menu from which you 
can select all video sources or cancel the selection. You 
can also use this method to remove from the list some or 
all of the video sources that you would not like to display 
or manage in MxControlCenter.

If you have cancelled the camera confi guration process 
or need a password that diff ers from the camera's factory 
default password, you can also confi gure the camera from the pop-up menu at a later 
date and enter the user name and password required for reconfi guration at that time.

Adding Selected Video Sources In A new Layout

Click OK to add the selected cameras in MxControlCenter. 
If you select the Generate new grid for selected cameras 
option in the Add Cameras dialog box, MxControlCenter 
will automatically create a grid layout that displays all 
selected video sources in equal-sized windows.

Otherwise the selected video sources will only be added to 
MxControlCenter and can later be used to create layouts.

A layout can show multiple video sources (cameras, fi le server paths, MxPEG clips, 
etc.) either in a grid or in front of a background. A video source can be displayed in a 
background layout as a video window or a symbol. Layouts can be saved, renamed 
and arranged hierarchically.
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2.3   User Interface And Operation

The main window of MxControlCenter appears after you select the fi rst video sources 
(MOBOTIX cameras, recording paths, MxPEG clips, etc.). This section introduces you to 
the basic elements of the application.

2.3.1  elements Of The Main Window

After the video sources have been automatically defi ned during initial installation, 
MxControlCenter opens the main window, which is divided into the following sections:

The standard view of MxControlCenter is primarily intended for users who work with the 
features set up for camera viewing and alarms.

Sections Of The Main Window

• Menu Bar: From the menu bar you can switch between views, open additional 
dialog boxes and even execute all the features assigned to the various toolbar 
buttons described below.

• Alarm List: This panel shows the alarm images of the cameras that the user normally 
needs to acknowledge by clicking the appropriate title bar (red). Double-clicking an 

Menu bar Alarm list Toolbar
Display panel with a layout for 

displaying the cameras

“Layouts” panel

“Player” panel

“PTZ” panel

Status bar Sidebar Date/time of the
current camera
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alarm image opens the Video Search dialog box where you can view the alarms and 
then compile them for later analysis (also for a camera-wide analysis).

• Toolbar: The toolbar contains buttons for important features. To see what a particular 
button does, simply place your mouse pointer over it and read the tooltip that appears. 
The toolbar can be confi gured to quickly switch between layouts (the Layout buttons 
in toolbar checkbox) or appear at the bottom of the main window (the Show toolbar 
at bottom checkbox) in Tools > Settings > General.

• Display Panel: This panel shows the cameras of the currently selected layout. The 
current camera appears with a yellow frame and is the "active camera" whose time 
and date are indicated in the status bar in the bottom right-hand corner. Besides the 
standard camera windows, which contain the live images of a specifi c camera, you 
can also defi ne player and focus windows in a layout for displaying the recorded 
images of one or more cameras.

• Status Bar: MxControlCenter uses the status bar to display specifi c runtime information.

• Sidebar: The sidebar contains diff erent information depending on the context. Normally 
it displays the information relating to available layouts or the controls for the active 
camera in the current layout. If the Layout Manager is active, only the panels you 
need to use will be shown (see Section 2.3.2, Layout Manager).

Sidebar Panels

• Layouts: This sidebar panel contains a hierarchical list of all the existing layouts of 
an MxControlCenter installation. With the Layout Sequencer (see Section 2.4.5, Using 
The Sequencer Features), you can set MxControlCenter to automatically cycle through 
the displayed layouts at a defi ned interval. For each layout you can defi ne separate 
video sources that can be displayed in either a grid or background layout:

• Player: This sidebar panel controls the playback of recorded video sequences or 
images.  Synchronized playback based on the time of the recording is available for 
either the current camera only or all the cameras of a grid layout.

• PTZ Control: This panel is used to control the pan/tilt features (PTZ = Pan/Tilt/Zoom) 
of a camera and is visible at all times. It may also contain other features depending 
on which camera and lens you are using. If the current camera can use vPTZ features 

Grid layout Background layout with camera icons
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(the virtual pan, tilt and zoom features of a MOBOTIX Q22M, for example), then this 
panel will be expanded accordingly

For more information on the various elements of the main window, see Section 3.1, 
MxControlCenter Controls.

2.3.2    Layout Manager

The Layout Manager provides features for creating and managing layouts in the sidebar. 
These features, however, are typically only used to set up an MxControlCenter installation. 
To activate or deactivate the Layout Manager, click the adjacent button in the toolbar.

Caution

Activating the Layout Manager does not open an extra window. Instead, the main 
window of MxControlCenter switches to a special view that contains all the features 
necessary for creating and editing layouts.

A layout can show multiple video sources (cameras, fi le server paths, MxPEG clips, 
etc.) either in a grid or in front of a background. A video source can be displayed in a 
background layout as a video window or a symbol. Layouts can be saved, renamed 
and arranged hierarchically.
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When activated, the Layout Manager off ers three other panels for creating and editing 
layouts:

• Layouts: Here, you can create, rename and move new 
layouts to form hierarchical structures. This panel shows 
grid and background layouts with diff erent symbols.

• Cameras and Devices: This panel displays the video 
sources that have already been added to MxControlCenter. 
You can drag and drop the video sources into a grid 
box or onto a background image.

• Grid/Background Images: In this panel you can select 
or add grid or background images for the current layout, 
depending on the layout type. These images will then be 
used to display the video sources. You can also create 
your own grids (the edit grid button) in addition to the 
predefi ned grids and the Auto grid (see below).

Auto grid is a special grid where the display panel is automatically split into smaller 
sections to show the various video sources.

More information on editing layouts is available in Section 2.4.3, Creating Layouts.

2.3.3   Alarm List

The alarm list contains the alarms of the MOBOTIX cameras defi ned 
in a layout, provided that alarm recording has been enabled on those 
cameras and the alarm list has been activated in MxControlCenter 
(Tools > Options > Alarm List).

If new alarms are detected, MxControlCenter adds the alarm image 
of the triggering camera to the top of the alarm list and changes 
the title bar to red. This alarm can now be acknowledged by click-
ing the title bar of the alarm window (title bar changes to blue).

      Unacknowledged alarm

      Unacknowledged alarm from selected camera

      Acknowledged alarm

      Acknowledged alarm from selected camera
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If the alarm list contains unacknowledged alarms, the alarm box in the upper right-hand 
corner will remain red. If all the alarms are acknowledged, the alarm box changes to 
green as depicted in the fi gure.

Besides the cameras in the current layout, other cameras can also send alarm mes-
sages to MxControlCenter by transmitting a network message to the computer running 
MxControlCenter.

More information on this and other alarm list features can be found in Section 2.5, Alarm 
Management.

2.3.4    Camera Confi guration

To change the confi guration of the connected cameras, open the Camera Confi guration 
dialog box in MxControlCenter by clicking Change the camera settings from MxCC or 
choosing Video Source > Properties > Confi gure from the menu.

The Camera Confi guration dialog box contains the following sections:

• Overview: This section of the dialog box lists all MOBOTIX cameras along with their 
most important settings and also includes an additional preview window for the cur-
rently selected camera. If login data that diff ers from the default login data (admin 
user, meinsm password) is required, you can use the pop-up menu (right-click) to 
authenticate yourself for the selected camera. From the same pop-up menu you can 
also open a dialog box with additional information on this camera.

• Image Settings: You can view and modify the main image settings for the selected 
camera in this section.



25/152Finding And Confi guring Video Sources

 © MOBOTIX AG  •  Security-Vision-Systems  •  Made in Germany

 www.mobotix.com  •  sales@mobotix.com  

• exposure: The exposure windows are one of the most important camera tools for 
creating properly exposed images. In this section you can select diff erent exposure 
windows or customize them based on your requirements (move, change size, etc.).

• Recording: You can control the camera's recording features in this section of the 
dialog box by activating the recording feature and the camera sensors that are set 
to trigger an alarm. You can also use this panel to defi ne which fi les the camera will 
save (full or live image) and where the alarms will be saved (internally, on an SD/
CF card, or on a fi le server).

Note

All changes made in the Camera Confi guration dialog box will take eff ect imme-
diately and can be checked in the preview image. When leaving this section, this 
dialog box will prompt you to save any unsaved changes to the permanent fl ash 
memory of the camera.

For more information on working with the Camera Confi guration dialog box, see Section 4, 
Confi guring MOBOTIX Cameras.

2.3.5   Update Assistant

MOBOTIX off ers software updates that contain new features and enhancements for its 
cameras on a regular basis. You can easily transfer new software to all selected cameras 
with the Update Assistant.
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Besides automatically updating the camera software, the Update Assistant also saves the 
current confi guration of the cameras so that it can be restored on some or all of the cameras.

Furthermore the automatic search feature for new cameras and the way detected cameras 
are organized into various camera lists also provide a number of additional options for 
managing large-scale installations.

To launch the Update Assistant, open the Tools > Assistants > Update camera software 
menu.

For more information on the update assistant, see Section 4.6, Updating The Camera 
Software.

2.3.6      Program Settings

You can edit the program options of MxControlCenter and the options of the cameras 
connected to MxControlCenter in the Tools > Options dialog box.

The dialog box contains the following tabs:

• General: You can defi ne the various program options that aff ect the display and 
operation of MxControlCenter on this tab. In addition to the security settings for 
MxControlCenter (administrator and user passwords), you can also defi ne a global 
camera user and corresponding password to simplify access to the cameras.
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• Alarm List: Here, you can defi ne the alarm list options that aff ect the alarm list itself 
(size, save as a separate fi le, auto acknowledge). You can also use this tab to specify 
the sounds that can be used to signal new alarms.

• Remote Control: The options on this tab determine whether and how MxControlCenter 
responds to network messages that are sent to the designated port of the MxControlCenter 
computer.

• <Camera Tabs>: Each of these tabs shows the name and IP address of a specifi c 
camera and allows you to defi ne options of that camera. Besides a special user 
name and password, you can also defi ne how MxControlCenter can access the 
images recorded by the camera, which instruction fi le is linked to this camera, and 
which preferred layout the camera will use.

For more information on this dialog box and the various program options, refer to Chapter 5, 
MxControlCenter Options.

2.4 Live Monitoring With  Numerous Cameras

2.4.1  Monitoring In Predefi ned Layouts

Your monitoring requirements can be met using only a few cameras in a single layout. 
However for more complex monitoring tasks, a single layout will not suffi  ce.

If you are using a large number of cameras, you would ideally have a customized view of 
the currently displayed camera images in diff erent sizes (CIF, VGA, etc.) and an option to 
toggle between various views so that the numerous cameras can be assigned to various 
views depending on their location.
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Predefi ned grid layouts are available for this purpose and can be generated and edited 
provided you have enabled the Layout Manager (see Section 2.4.3, Creating Layouts 
and the following sections).

Display Windows For Layouts

For live monitoring, diff erent types of dis-
play windows that can be used in a grid or 
background layout are available. The size of 
all windows used to display a live stream is 
limited to 2560 x 960 pixels (double MEGA) 
for grid layouts and 640 x 480 pixels (VGA) 
for background layouts.

• Live: These "standard windows" show 
the current live video stream of a cam-
era,- normally at the full frame rate. In 
grid layouts, these windows can have a maximum size of 2560 x 960 pixels (double 
MEGA resolution). For display purposes, the single images from the live stream are 
scaled to match the size of the display window.

Note

A high camera resolution increases both the bandwidth required to retrieve 
the live stream as well as the load imposed on the MxControlCenter computer 
for decoding and displaying the data.

The live windows are typically used in monitoring scenarios such as the ones described 
in Example: Live Monitoring of a Parking Garage given in Section 1.2.2, Example: Live 
Monitoring Of A Parking Garage.

• Preview: A "reduced" live stream with low resolution and frame rate can be retrieved 
from the camera with this display window. This is particularly well-suited for remote 
applications with low network bandwidth.

• Sequencer Window: This window is not assigned to one specifi c camera, but rather 
switches between the cameras at preset time intervals. The sequencer window is 
very eff ective when used in conjunction with status icons, particularly in background 
layouts. For example, you can create an overview layout using the building fl oor 
plan and status icons as "placeholders" for the individual cameras together with a 
sequencer window in the middle of the layout.

• Focus Window: This window is not tied to a specifi c camera and only displays the 
live video stream of the camera whose status icon is selected using the mouse.

The layouts and display windows that are best suited for live monitoring depend on a 
variety of factors such as the:

• Number of monitoring cameras
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• Bandwidth of the monitoring network

• Number and workfl ow of the security personnel

2.4.2     Monitoring The Camera Connection

While running, MxControlCenter automatically checks whether the cameras integrated 
into the system are accessible. If the connection to a camera is lost, MxControlCenter will 
display an error message in the relevant camera window.

The options for this feature can be found in both sections of the General tab in the Tools 
> Options dialog box:

• Sound for errors/Connection errors: MxControlCenter can play back either a stan-
dard sound or an audio fi le of your choosing (*.wav) if a connection error occurs.

• error Display for Connection errors: This option displays an error message or a 
graphics fi le you specify in the image of the missing video source.

• error Display on Latency Timeout: If the latency between image capture and the 
camera display exceeds the value specifi ed here, MxControlCenter can display an 
appropriate error message or a graphics fi le you choose in the image of the video 
source in question.

More information on this topic can be found in Section 5.2, The “General” Tab.
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2.4.3    Creating Layouts

You can proceed as described in Section 2.2, Finding And 
Confi guring Video Sources to automatically create layouts 
for diff erent video sources (MOBOTIX cameras, fi le server 
paths, MxPEG clips and third-party network cameras). If 
you want more customized layouts, you will need to use 
the Layout Manager.

Click the Layout Manager button on the MxControlCenter 
control panel. The sidebar now contains the three panels, 
Layouts, Video sources and Grid or Background images, 
that were described in Section 2.3.2, Layout Manager.

2.4.4 Procedure

• Right-click the empty space in the Layout panel and 
select new Layout from the pop-up menu.

• Choose whether you would like to create a background 
layout  (for site plans, fl oor plans, etc.) or a grid layout 
(display window only).

• Select an image (*.jpg, *.bmp or *.gif) for a background layout or a grid for a 
grid layout:

Auto grid is a special grid where the display panel is automatically split into smaller 
sections to show the various video sources. 

The auto grid has a square or rectangular structure: Display windows are automati-
cally added until the next larger square or rectangle of windows appears when 
adding cameras. In the case of rectangles, the rows always contain more display 
windows than the columns.

• Click OK to close the dialog box. MxControlCenter creates the new layout and labels 
it with the appropriate symbol.

• You can now rename the new layout by double-clicking the name or right-clicking 
the relevant command from the pop-up menu.
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• If you would like to create a hierarchical layout structure, move and reorder the 
layouts based on your requirements.

Additional editing Options For Grid Layouts

• Moving Display Windows: You can switch display window locations by simply mov-
ing one window to another one.

• Adding Video Sources: These video sources are moved from the Video Sources 
panel of the sidebar to the display fi eld you choose. They will replace any video 
sources that may already exist in that fi eld.

• Right-Clicking a Display Window: Opens a pop-up menu with additional commands 
for editing or deleting video sources, for example.

Additional editing Options For Background Layouts

• Moving Display Windows: Display windows can be arranged any way you want. If 
you want to switch display window locations, simply move one window to another 
one. Note that the windows will automatically be resized if they are near the window 
frame or other display windows.

• Adding Video Sources: These video sources are moved from the Cameras and 
Devices panel of the sidebar to any location you choose.

• Displaying as Icons: Video sources can be displayed for overview plans as icons 
that indicate the viewing direction, number of objects, their bandwidth and the status 
of the cameras:

Double-clicking an icon shows the corresponding camera in a separate display window.

• Right-Clicking a Display Window or Icon: Opens a pop-up menu with additional 
commands for, among other things, editing or deleting video sources.

• Right-Clicking an empty Space: Opens a pop-up menu that allows you to insert 
an additional element.

For more information on working with layouts, see Section 3.2, Editing Layouts.

2.4.5    Using The Sequencer Features

Since MOBOTIX cameras are also able to use low-bandwidth connections to transfer 
low-quality preview images, MxControlCenter off ers the ideal means for establishing a 
remote control center.

Camera OK, 
detected

Camera OK,
not detected

No connection to 
camera
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Sequencer Of MxControlCenter

The functions of the integrated sequencers for automatically cycling through the defi ned 
cameras or layouts and the hierarchically structured layouts support these features since 
they allow for the eff ective display of connected video sources.

Some network connections do not have suffi  cient bandwidth to display the live stream 
from multiple cameras at the same time. Nevertheless, you would still like to see, at least 
sequentially, the images of all cameras. The sequencer features are provided for this 
purpose and work on two levels:

• The layout sequencer switches between the layouts of the current confi guration at 
specifi ed intervals.

• The camera sequencer switches between the specifi ed cameras within a grid layout 
and displays the images they capture at their maximum size in the display panel.

• You can defi ne a sequencer window inside a layout that cycles through the individual 
cameras of the layout.

2.4.6    Using The vPTZ Features

The M12D, D12, V12, M22M, D22M and Q22M models 
of MOBOTIX cameras and software versions 3.4.5 or 
higher now include enhanced virtual PTZ features. 
These features allow you to use a mouse or joystick to 
zoom in on images from the selected video source and 
"virtually" move the enlarged image section within the 
entire image sensor area.
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The Q22M camera merits special attention in this regard: A spherical image of the environ-
ment is captured by the 180° lens of the camera. By selecting the appropriate live image 
mode of the camera (see below), this image can be corrected for distortion by the camera 
itself and then saved and displayed in MxControlCenter in its corrected form. Alternatively, 
the camera can simply save the complete distorted image and send it to MxControlCenter. 
In this case MxControlCenter can subsequently correct the images for distortion. For more 
information on this topic, see Section 3.1.4, The “PTZ Controls” Sidebar Panel.

Note that the views and features available for use will vary depending on where the Q22M 
is installed (on the wall or the ceiling). If this particular cam-
era model is selected in the layout, the PTZ Controls panel 
will be expanded so that you can specify the installation 
type and set the North direction of Q22M.

Using The Virtual PTZ Features

To control the vPTZ features, the sidebar contains a number of control elements that you 
can operate with a mouse and that function just like a joystick:

• Turning the Joystick or Using the Slider Bar +/-: Adjusts the 
zoom setting of the selected video source.

• Tilting the Joystick: Rotates or pans the image in the direction 
you choose until you return the joystick to its home position.

Make sure that the lock icon in the PTZ features sidebar panel is 
unlocked or else the features of the virtual joystick will be blocked.

You can use the mouse the execute certain vPTZ features by simply clicking the position 
you would like in the image and scrolling the mouse wheel to zoom in and out.

The numeric fi eld at the bottom of the sidebar is used to save frequently used positions 
(a longer click saves a position, while a 
shorter click opens it). The 1x Zoom and 
Center pan buttons are used to reset 
the image position while the buttons in 
the Auto mode panel control the automatic 
camera movements as if you were con-
trolling a PTZ camera mechanically.
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  Correct Distortion In MxControlCenter Or The MOBOTIX Camera?

These two drop-down lists defi ne how work is allocated between 
the camera and MxControlCenter when processing images:

• Camera Live Image: Controls image generation on the 
camera itself (the display modes off ered by this camera 
model are always available for selection).

• MxCC Display: Allows you to set MxControlCenter to 
either accept the images in their original form or apply 
distortion correction to the images.

These two settings are all you need to have the camera deliver and save full images while 
MxControlCenter displays the distortion-corrected area and adds the zoom feature in the 
live image. This feature can be set separately for each camera in the layout.

2.5   Alarm Management

2.5.1   Preparing MxControlCenter

If an event occurs (a MOBOTIX camera detects movement or any changes), the camera 
can notify you by triggering an alarm. The type of event detection and the method of the 
resulting alarm can be confi gured in a number of diff erent ways. For example, you can 
confi gure a MOBOTIX camera to send an e-mail if the ambient temperature falls below 
a specifi c value. A detailed description of all the alarm methods can be found in the 
MOBOTIX Software Manual.

Once armed, a MOBOTIX camera in its default confi guration will detect any motion within 
a defi ned area of the displayed image and highlight such motion by adding a red border 
around the image.
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This alarm can be sent to MxControlCenter in multiple ways:

• Camera Alarm Messages: Alarms are "streamed" together with the relevant live 
images to MxControlCenter, which can then use this image data to obtain the neces-
sary information about the triggering event.

• Remote Control by Cameras: A MOBOTIX camera can also send this alarm to 
MxControlCenter as a network message (notifi cation in the network based on the 
IP protocol).

The fi rst type of alarm can only be transferred if the live image in the current view or layout 
is also displayed. A network message, however, can be received at any time, even if the 
sending IP camera is defi ned in a layout that is not currently being displayed. 

Confi guring How network Messages Are Received

To be able to receive these messages, the Camera IP notify only port needs to be enabled 
in the Remote Control tab of the Options dialog box and needs to match the port when 
confi gured for the MxCC Alarm transfer profi le on the camera (Admin Menu > Transfer 
Profi les > IP notify Profi les in the browser interface of the camera).

Now a specifi c view will be activated whenever this camera sends an alarm that needs 
to be defi ned. To do so, open the Layout editor  and specify the last defi ned preferred 
layout. Alternatively, you can specify the preferred layout in the camera tab of the Options 
dialog box.

The preferred layout of a camera determines which layout will be used to display this 
camera when a network message is sent to the MxControlCenter computer. You can 
thus have cameras displayed immediately ("connected") if they are not currently being 
displayed.

  Activating The Alarm List

First activate the alarm list in the Options  dialog box 
(the Alarm list tab). MxControlCenter will now archive all 
incoming alarms in a list in chronological order. When an 
IP camera sends a network message, MxControlCenter 
can now switch to the preferred layout defi ned for this 
specifi c camera, if necessary.

More visualization options are off ered by the Alarm window 
(described in the previous section as a special grid element of a layout) and Player window.

Ultimately, however, having an alarm visualized by a computer program like MxControlCenter 
is not enough. There is usually a human being present at the end of the alarm chain and 
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they should respond appropriately when an alarm goes off . Once proper measures have 
been initiated, the user can then acknowledge the alarm so that the "alarm" visualization 
can be cancelled.

2.5.2      Preparing The Cameras

A MOBOTIX camera needs to be properly confi gured before it is able to detect an event, 
trigger an alarm and then send that alarm to MxControlCenter where it is visualized.

Launch your browser and enter the IP address of the camera, or select the camera you 
would like to confi gure in the current view of MxControlCenter and then click the Open 
browser button. Follow the paths through the menu structure of the page for the indi-
vidual items.

Showing An Alarm Message In The Data Stream Of A Displayed Live Image

• General Activation (Setup Menu > event Control > General event Settings): Check 
whether camera activation is enabled .

• Video Motion Window (Setup Menu > event Control > event Settings > events): 
The video motion window (VM) needs to be activated and its coordinates defi ned.

Proceed as follows to send an alarm to MxControlCenter as a network message:

• Transfer Profi le (Admin Menu > Transfer Profi les > IP notify Profi les): Use a profi le 
called MxCC Alarm:  simple. The target address of this profi le needs to contain 
the IP address of your local computer and the port number used by MxControlCenter to 
receive network messages (see Section 3.5, Remote Control Using Network Messages).

• Activate Messages (Setup Menu > event Control > Messaging > General Settings): 
The message profi le should be activated.

• IP notify (Setup Menu > event Control > Messaging > Actions): The selection for 
a network message (IP) needs to be set to MxCC Alarm. 

To grant the required permissions for MxControlCenter:

• Assign Permissions (Admin Menu > Group Access Control Lists and Admin Menu > 
Users and Passwords): The MxCC permission should be enabled for the group who 
are authenticated by MxControlCenter as their members.



37/152Alarm Management

 © MOBOTIX AG  •  Security-Vision-Systems  •  Made in Germany

 www.mobotix.com  •  sales@mobotix.com  

2.5.3   Alarm Display

As previously mentioned, there are a number of ways 
to respond to an alarm message. The easiest form of 
visualization is provided by the camera itself when it 
displays the current live image with a red border. This 
"momentary" visualization does not last very long, which 
is why MxControlCenter can save all alarms in the alarm 
list for subsequent viewing.

Choose Tools > Options from the menu and then activate 
the list in the Alarm List tab to activate the alarm list. If 
you have confi gured everything properly, any motion in 
front of the camera in the current view should cause the 
fi rst alarm image to appear in the alarm list. Additional 
options for sending visual or audio alarms can be found 
in Section 3.3, Alarm Processing.

In addition to the alarm list, special window elements in a view can be defi ned to display 
alarms:

• An alarm window within a view displays the live image from the camera that actually 
reported the last alarm (graphic).

• A player window is not tied to one specifi c camera. It shows the saved alarms from 
any camera that you select from the alarm list. The saved alarms are not displayed 
in a list, but rather as a video from a video recorder. You therefore have the option 
to fast forward or rewind through the alarms and the recorded image sequences of 
each alarm (graphic). For more information on these search options, see Section 2.6, 
Video Searches And Export Features.

To defi ne an alarm or player window in a view, you fi rst need to activate the Layout 
Manager and then defi ne the element you want to use in the Defi ne Grid element dialog 
box (for more information, see Section 3.2.1, Grid Layouts).

If the alarm-triggering camera is not shown in the current view, note that we have already 
confi gured the camera to send a network message to MxControlCenter (see Section 2.5.2, 
Preparing The Cameras).
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2.5.4   Alarm Acknowledgement

MxControlCenter is able to record and display alarms from an IP camera, the next step is 
to determine how these alarms can be acknowledged by security personnel or, in other 
words, human beings who are actually sitting in front of the computer and are required 
to respond appropriately.

The easiest way to acknowledge an alarm is to just 
click the red bar above the alarm image. This also 
stops the acoustic signals, which can be confi gured, if 
necessary. For example, you can set the alarms to be 
acknowledged automatically if displaying them is no 
longer relevant after a preset time elapses.

In critical situations, you can use an instruction fi le to give security personnel instructions 
on how to respond to an alarm. This instruction fi le, which can be a text message, an 
image or a video clip, can be defi ned in the relevant camera tab of the Options dialog 
box. You can open this fi le by selecting the Show alarm instructions of selected camera 
icon.
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2.6     Video Searches And export Features

As you have already seen, there are a number of ways to archive live images from an IP 
camera. You can use these recordings in a comprehensive video search whether this occurs 
as a continuous recording or as an event-controlled recording - with MxControlCenter.

   Image Recording, event Recording, Continuous Recording

MOBOTIX cameras provide three modes for recording video data. These modes can be 
set for each camera on the Recording tab of the Camera Confi guration dialog box:

• Snapshot Recording: Saves the individual *.jpg images without audio as an image 
series based on pre-alarm images, the alarm image itself and post-alarm images.

• event Recording: Saves an alarm as an MxPEG clip with the audio channel of the 
camera (optional).

• Continuous Recording: Saves continuous video and audio data as MxPEG clips where 
the recording frame rate is reduced and can be increased automatically when an 
event occurs. This continuous recording mode is only available if you have a suffi  cient 
amount of storage capacity (on an SD/CF card or fi le server).

More information on the recording modes off ered by MOBOTIX cameras can be found in 
Chapter 8 Recording of the Software Manual.

2.6.1    Switching Display Windows In Player Mode

Displaying the event images recorded by a camera in 
Player mode off ers the easiest way to search through 
video data. To do so, fi rst click the live image of a 
specifi c camera and then select the Toggle Player 
mode button or right-click the relevant command 
from the pop-up menu.

If any alarms from this camera are present, the buttons 
in the Player panel of the sidebar become available 
and you can view the recorded video sequences 
using the playback, fast forward and rewind buttons. 
In addition to these controls, you can also access the buttons that appear at the bottom 
edge of the display window when you place your mouse pointer over this sidebar panel.

An image series includes all the images (or the entire video sequence) that have been 
saved for an event (alarm). This normally includes the video data including any audio data 
that has been recorded before, during (the "event image") and after the event occurs.

You can play back either the entire image series or only the event images:

• Play Back entire Image Series: These Player buttons allow you to play back all 
recorded images either individually or consecutively.

• Play Back event Images Only: These Player buttons are used to show the event 
image only and are indicated by a red lightning bolt.



40/152  MxControlCenter Manual:  Getting Started

 © MOBOTIX AG  •  Security-Vision-Systems  •  Made in Germany

 www.mobotix.com  •  sales@mobotix.com  

Simultaneous Playback Of All Cameras

The All button in the Player sidebar panel switches all display windows to Player mode 
and activates the Player buttons. Playback starts simultaneously for all video sources 
regardless of when the recording was made.

Time Synchronized Playback Of All Cameras

You can access the options off ered by the Synch. Mode list in the Player sidebar panel for 
the time-synchronized playback of recorded sequences from all displayed video sources. 
Playback can be started at the specifi ed time if this list is compiled in Real Time or at 
Reduced Speed.

Enter the date and time and then click the Goto button to set all cameras to the correct 
time. Now click the Playback button and all the images will be played back according to 
the setting in the Synch. Mode drop-down list:

• Real Time: All video sequences are played back in real time. If the images cannot 
be transferred fast enough, MxControlCenter will skip individual images.

• Reduced Speed: Playback is performed at a slightly reduced speed, if necessary, 
and even image synchronization is somewhat more fl exible. This method also allows 
for smooth playback of all recorded images if the data for a real-time display cannot 
be read fast enough (for example, due to low network bandwidth).

Quick event Search

Select a display window in Player mode. The slider 
bar in the Player sidebar panel provides a quick 
and intuitive way to search through events.

You can specify any date within the recorded video 
sequences to fi nd sequences as quickly as possible. 
Click Search to jump to the next event based on 
the specifi ed time.
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exporting Video Sequences

Right-click the Player sidebar panel and 
enter the start and end positions to defi ne 
an export range. The range you selected 
now appears in green.

If you click the export button, the export 
list will open and the selected time range will be added as a new entry at the end of the 
list. This procedure can be repeated as often as needed to add other interesting video 
sequences to the export list.

More information on this topic can be found in Section 2.6.4, Export List And Data Export.

2.6.2   Defi ning Player Windows

In contrast to a display window in Player mode, a player window is a special layout 
element that displays the last event image of any video source that was selected from 
the alarm list.

You fi rst need to activate the Layout Manager to defi ne a player window.

Defi ning Player Windows In A Grid Layout

• If there is no empty display fi eld available, select a diff erent grid that can display 
more fi elds on the existing display area.

• Right-click an empty fi eld and select Edit from the pop-up menu.

• Select the Player window item from the element type list and click OK.

Defi ning Player Windows In A Background Layout

• Right-click an empty area and select Insert from the pop-up menu.

• Select the Player window item from the element type list and specify the particular 
size you would like to use.

• Click OK to close the dialog box.

• Move the new window to a suitable position.
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Right-click the element in question while the Layout Manager is enabled and select Edit 
from the pop-up menu to modify the properties of a player window at a later time.

Deactivate the Layout Manager to save the settings of the current layout.
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2.6.3   Using Video Search

If you have defi ned an external recording target (fi le server) for the relevant video source 
or the MOBOTIX camera has an SD/CF card, large amounts of data will be saved for an 
extended period depending on the memory storage capacity.

A more comprehensive search option that is not limited to a single camera like the basic 
player window is provided by the Video Search dialog box, which appears when you click 
Open event Search.

The Search dialog box can be used to browse through the recordings from all the cameras 
defi ned in the current view. In the Cameras tab, select the camera whose recordings you 
would like to browse through. MxControlCenter now shows you all recorded events in 
chronological order in the Events tab.

The vertical slider bar next to the events list provides a visual indication of the time range 
during the entire recording period in which events are displayed in the list. By selecting 
an event in the list, the image associated with that event is displayed in the area of the 
player window that was described in the previous section.
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If you have identifi ed an event as relevant, the time of the event can be defi ned as the 
Reference time , which is used to automatically display the time diff erence from the other 
events during the search.

Filtering events

If you would like to search for special event types 
(for example, motion detection only), you can 
defi ne an event fi lter. To do so, click Set event 
fi lter and activate the events you would like to 
fi lter.

This button is only relevant for searching and 
playing back continuous recordings:

• If the button is enabled (yellow), the 
event list will only show "real events" 
(VM, UC, IR, etc.).

• If the button is disabled (crossed out), the 
events list will also include the "pseudo 
events" of the continuous recording, which means the images that are generated 
every minute at the beginning of a new recording sequence will be displayed.

More information on the video search options can be found in Section 3.4, Video Searches 
And Export Features.

Printing event Images

Click Print current and post-processed image to print the currently displayed event image. 
MxControlCenter now shows a print preview of the currently displayed image. If this image 
has been corrected by post-processing, the original, non-processed image will be added 
as well.

You can also print event images as *.pdf fi les using the integrated PDF export feature for 
easy sending and archiving of printouts.

2.6.4    export List And Data export

Click export or Add to export list to open the export dialog box or add previously selected 
events or time ranges to the export list. Select an event from the events list and click Add 
to export list to add the individual event. To defi ne a time range, set the Player to the exact 
time you would like and then specify the start time by selecting Set start position from 
the pop-up menu for the Player panel. After searching for the last scene to be exported, 
select Set end position from the pop-up menu to defi ne the end time.
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Note

The time range defi ned in this manner can include any number of events. If an explicit 
time range for the export has not been defi ned, the entire time range is automatically 
added to the export list dialog box here as well.

export List

You can compile all the video sequences that you would like to export in the export list. 
These particular sequences are added by defi ning a time range (right-click > Set start 
position/end position) and then incorporating this range into the export list.

Adding Video Sequences To The export List

The following options are available for this purpose:

• The "Player" Sidebar Panel: Defi ne an export range (right-click > Set start position/
end position) and then click export.

• The "Video Search" Dialog Box: Defi ne an export range (right-click the slider bar > 
Set start position/end position) and then click Add to export list.

Video sequences can be added multiple 
times and even if the export list is closed. 
Click export in the Video Search dialog 
box or select  Recording > export from 
the menu to display the list.
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editing The export List

If the export list is open, you can select items individually or in groups (sHIFT-CLICk) and 
then move them with the mouse or delete them with the DeLeTe key

Data export

MxControlCenter provides a number of diff erent formats for exporting recorded video and 
audio data. Choose a format from the export as selection box in the export list:

• AVI File: This format can be displayed on all standard video players and not only 
contains the video data, but also the audio data of the video source (if included in 
the recording).

• MxPeG Clip: This format can be integrated and played back in MxControlCenter as 
a video source. This format also includes the audio data of the video sources in the 
export (if included in the recording).

• File Server Structure: This format can also be integrated and played back in 
MxControlCenter as a video source. It also contains the audio channel of the video 
sources (if it was included in the recording).

Exporting as an *.avi fi le or an MxPEG clip activates the 
Settings button, which can be used to open the export 
Format Options dialog box. From this dialog you can 
defi ne the options for the export (for example, maximum 
fi le size).



47/152Alarm Management

 © MOBOTIX AG  •  Security-Vision-Systems  •  Made in Germany

 www.mobotix.com  •  sales@mobotix.com  

2.7  Video Processing

2.7.1  Image Post-Processing

MxControlCenter normally displays all live video images and the images of an archived 
recording in their original unedited form. This also applies to live images from integrated 
third-party cameras and analog cameras in particular (see Section 2.8.2, Controlling PTZ 
Cameras And Mechanical Pan/Tilt Heads).

You are certainly familiar with the term "post-processing" in 
digital photography, which in this case refers to the software-
based methods off ered by MxControlCenter for the subsequent 
"improvement" of images. In the standard camera view, select 
the camera whose image display you would like to optimize 
and then click the arrow to the right of the Switch image post-
processing on/off  > Options button.

You can adjust the settings for saturation, brightness, backlight and 
sharpness in the Post-processing panel of the Image Processing 
dialog box. By clicking the Switch image post-processing on/
off  button in the main view, you can quickly switch back and 
forth between viewing the original image from the camera and 
the improved, post-processed image.

This type of post-processing also off ers a useful tool for viewing 
low-quality archived images at a later date for search purposes, 
for example. This is why you will fi nd the same controls for adjusting saturation, bright-
ness, backlight and sharpness in the Video Search dialog box (see Section 2.6, Video 
Searches And Export Features).

More information on this topic can be found in Section 3.9, Image Post-Processing.

2.7.2  Image Distortion Correction

In addition to the options described in Section 2.4.6, Using The vPTZ Features for correct-
ing the distortion of currently displayed images in the PTZ Control sidebar panel, the 
Image Processing dialog box can also be used to control how image distortion is cor-
rected. To open this dialog box, click Switch image processing on/off .

The automatic distortion correction features of MxControlCenter are used to fi x the distorted 
view caused by the wide-angle lenses of the cameras. Although the lens is specifi ed for 
some camera models (Q22M, for example), for older camera 
models you need to clearly indicate which lens is being used 
and how the camera is installed in the Image Processing 
dialog box. The results of distortion correction are immediately 
visible as it straightens any vanishing lines that were crooked 
due to distortion.
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A perfect example of where this distortion correction feature can be used is in a ceiling-
mounted Q22M camera whose 180° lens captures "spherical" images.

2.8   Control Center And Management Features

2.8.1  Integrating Third-Party Digital/Analog Cameras

MxControlCenter is the ideal solution when used in conjunction with MOBOTIX cameras. 
Note, however, that you can easily connect the network cameras or even analog cam-
eras of third-party manufacturers to a MxControlCenter video management system also.

Displaying Live Images

Adding third-party IP cameras to the system is extremely easy and is done using the 
previously described Add Cameras: Search and Select dialog box. Select the manufac-
turer type and enter the IP address and access data as usual.

Integrating analog cameras requires an intermediary step in which the analog video data 
is converted to a digital format that is compatible with MxControlCenter (MxPEG or M-JPEG).

MOBOTIX
IP camera

Third party
IP PTZ camera

MOBOTIX
IP camera
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This task is performed by MOBOTIX MxServer, a dedicated Windows computer that has a 
frame grabber card connected to the analog cameras and provides the digitalized analog 
signals as an M-JPeG data stream just like an IP camera in an IP network. This means the 
analog camera is integrated in MxControlCenter via the IP address of MOBOTIX MxServer. 
The cameras connected to the frame grabber card, which accepts up to four cameras, 
are normally accessed via port numbers 81 to 84. Analog cameras are integrated accord-
ingly using the Add Camera dialog box (see Section 3.10.5, Using Analog Cameras In ).

Analog Camera
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Archiving Live Images

Section 2.3.4, Camera Confi guration explained how MOBOTIX cameras can archive your 
image data not only in their internal memory, but also on a computer (fi le server). The 
task of archiving image data in the same format as MOBOTIX IP cameras is performed 
by MOBOTIX MxServer on its local hard drive. MxServer does this for both the image 
data of third-party digital IP cameras and the digitalized image data of analog cameras.

You now need to open the Options dialog box (Camera tab, Camera access) of MxControlCenter 
and select the fi le server path where MOBOTIX MxServer will save the digitized data of 
analog cameras. This integrated system of third-party digital/analog cameras and MOBOTIX 
cameras can now access the same archiving system for subsequent video analysis. The 
result is the seamless integration of older analog technology into the IP-based digital system.

More information on how to start up and confi gure MOBOTIX MxServer can be found in 
the documentation at www.mobotix.com (Support > Manuals).

2.8.2      Controlling PTZ Cameras And Mechanical Pan/Tilt Heads

The fi xed lenses of MOBOTIX cameras are unrivaled in situations where robustness and 
weather resistance are essential due to the intentional elimination of mechanical parts. 
If camera mobility is required, a mechanical pan/tilt head can be used in conjunction with 
a suitable MOBOTIX outdoor camera. This camera is mounted on the pan/tilt head and 
controls it via the serial interface. The type of pan/tilt head for this particular camera needs 
to be selected in MxControlCenter so that you can control the camera using your mouse 
or joystick (Tools > Options > <Camera tab>).

If a third-party IP camera with a mechanical PTZ feature is integrated into the system, the 
pan, tilt and zoom features are automatically enabled. No further settings are necessary.

Even analog cameras with pan/tilt heads can be controlled through integration with MOBOTIX 
MxServer. To do so, the camera needs to be connected to the frame grabber card and its 
control cable needs to be connected to the serial interface of MOBOTIX MxServer. MOBOTIX 
MxServer translates the control commands for the analog camera type you are using.

The mechanical PTZ actions for both pan/tilt heads, as well as connected PTZ dome 
cameras, are controlled in the same manner as the virtual (digital) PTZ actions of MOBOTIX 
cameras are controlled. For the control features, you can use either a Megatron joystick 
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or the control elements located in the PTZ Control sidebar panel (see Section 2.4.6, Using 
The vPTZ Features).

2.9   Confi guring MxControlCenter

The issue of software support is critical if you are using MxControlCenter in an environment 
with a large number of cameras. This section shows how you can run MxControlCenter on 
diff erent computers using the same confi guration, for example. It also explains how to unify 
the confi guration of the cameras and how the camera software is updated automatically.

2.9.1    Modifying, Saving And Loading Program Options

The program options can be set in the Tools > Options dialog box as described in Section 2.3.6, 
Program Settings. You can save MxControlCenter settings, save them under a diff erent 
name and reload them with the Tools > Program Settings command.

The Tools > Program Settings > export environment command allows you to save a 
complete work environment and all included program fi les (the Complete ... option) for 
transfer to another computer.

2.9.2    Customizing The User Interface

Since the requirements of an MxControlCenter installation can vary widely, there are 
many options available for customizing the user interface. They will be briefl y described 
in this section.

Caution

These settings are selected from the View menu. Note that if one of these options 
removes all the menu and toolbars in the application, you can always return to 
the "normal" view by disabling the View > Display area only command from the 
pop-up menu (right-click).

Hiding Program Bars

The commands provided in the View menu allow you to selectively hide the menu bar, 
toolbar, status bar, alarm list and sidebar and hence increase the size of the display area.

Hiding Controls In The Display Area

If you would like to hide all the controls of MxControlCenter, select View > Display area 
only.  This maximizes the display area of the video sources within the application window.

Press the esC key or disable View > Display area only from the pop-up menu (right-click) 
to leave this view mode.
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Switching Layouts In The Toolbar

Perform the following steps to create this view:

• Tools > Options > General: Set Layout buttons in toolbar to 7.

• View: Select Display area only.

• Pop-up menu: Enable View > Alarm List.

• Pop-up menu: Enable View > Toolbar.

You can now switch the layouts using the buttons at the top of the application while the 
alarm list shows the triggered alarms.

If you prefer to have the toolbar appear at the bottom of the display area, select the Show 
toolbar at bottom option in the Tools > Options > General dialog box.

2.9.3   Managing MxControlCenter Confi gurations

Carrying out the same confi guration on all systems represents a signifi cant time and cost 
factor for any administrator who is responsible for installing software on numerous worksta-
tion systems. Usually this task requires performing a large number of identical and recurring 
steps for each workstation. This task is now handled by MxControlCenter, which is able to 
save the complete confi guration along with all executable fi les to a single folder, without 
having the default settings and activation keys hidden in some system folder. The entire 
environment can now be "transported" without any installation or confi guration hassles.

You no longer even have to copy this folder if a global folder is specifi ed for MxControlCenter. 
If this confi guration folder is saved on a fi le server and linked to the individual MxControlCenter 
installations, it will defi ne all settings (available views, alarm list settings, etc.) on each 
workstation.

To create the confi guration folder, the administrator simply needs to confi gure MxControlCenter 
based on his or her wishes and then save the confi guration to a shared folder on the 
server. All you need to do is link to the global folder (Tools > Options > General > Set 
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global order) on the workstation where MxControlCenter is launched. Additional con-
fi guration steps such as searching and connecting video sources or creating layouts are 
no longer necessary. Now restart the application and MxControlCenter will automatically 
apply the settings that the administrator defi ned on his or her personal workstation.

However the global settings may not be modifi ed on the individual workstations for this 
particular feature of the global folder to be eff ective. This is done by setting up the user and 
rights management (see Section 3.7, Users And Passwords) so that only the administrator 
is allowed to modify password-protected settings such creating and editing layouts while 
the user is only allowed to access the various views.

2.9.4   editing Camera Confi gurations

The Camera Confi guration dialog box in MxControlCenter is used to confi gure MOBOTIX 
cameras and other IP cameras, it allows you to adjust the most common camera settings 
in just a few steps. This includes, for example, enabling general arming, confi guring video 
recording, changing image settings, etc. Chapter 4, Confi guring MOBOTIX Cameras pro-
vides a detailed description of the various options for confi guring cameras.

2.9.5   Managing Camera Confi gurations

MxControlCenter provides the Update Assistant to help you manage camera confi gura-
tions and fi rmware updates. To access the Assistant, click Tools > Assistants > Update 
camera software.

As you may have noticed, MOBOTIX cameras off er a variety of features that, in some 
cases, require a signifi cant amount of confi guration work. For example, setting up a 
detailed time schedule to activate a camera outside of regular business hours may not 
be very diffi  cult. However, if you have to do this for many diff erent cameras, it becomes 
a very time-consuming task.
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Such tasks are greatly simplifi ed by the Update Assistant since it can save camera con-
fi gurations and then distribute them to other cameras.

To do so, select your "pre-confi gured" camera from the camera list and click Save Settings. 
The saved confi guration fi le now contains all the information you need to confi gure one 
or more cameras with the same settings.

Select the cameras you want to confi gure and then click Upload Settings. In the following 
dialog box you can select a previously saved confi guration fi le and then specify which 
settings you want to upload to the fi rst camera.
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In our example, you would save all confi guration sections with the exception of network 
settings. These settings were selected, which means they are protected and not replaced.

If you replace a camera with a diff erent model or add one or more new cameras to the 
installation, then these cameras can be confi gured just as easily.
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Notes
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3	 Advanced Features

3.1	 MxControlCenter Controls

3.1.1	 Buttons On The Toolbar

•	 Toggle Layout Manager: The Layout Manager allows you to create new grid layouts 
and background layouts or modify and expand your existing layouts.

If the Layout Manager is active, video sources can be selected from the sidebar and 
added to a layout. The grid of a layout or the background image can also be modified.

For more information on the Layout Manager, see Section 3.1.2, The “Layouts” Sidebar 
Panel.

•	 Activate layout or camera sequencer: The drop-marker menu button here allows 
you to activate either the Layout sequencer or the Camera sequencer.

If the Layout sequencer is activated, MxControlCenter will automatically switch to 
the next layout in the Layouts list in the sidebar of MxControlCenter after a specified 
time interval.

If the Camera sequencer is activated, MxControlCenter will automatically switch to 
the next camera in the active grid layout after a specified time interval. The Camera 
sequencer is only available for grid layouts.

Notes

•	 You can preset the global sequencer time for all cameras by clicking Tools 
> Options > General > Sequencer time.

•	 You can specify the sequencer time for each individual camera by clicking 
Tools > Options > <Camera tab> > Camera time.

•	 Toggle Player Mode: Click this button to switch the active display window of a 
camera (shown by a yellow frame) from live image mode to Player mode. The Player 
mode allows you to view and play back the recorded image and event sequences 
of a specific camera. When the sidebar is visible, the Player panel is displayed.

For more information on the Player panel, see Section 3.1.3, The “Player” Sidebar Panel.

•	 Open Event Search: This button opens the Video Search dialog box, which allows 
you to view event sequences from all of the cameras. In addition, this allows you to 
visually edit the images and to correct any distortion (Post-processing).

For more information on the event search, see Section 3.4, Video Searches And 
Export Features. For more information on image post-processing (for live or recorded 
images), see Section 3.9, Image Post-Processing.

•	 Show/Hide Alarm List: Click this button to show or hide the alarm list that contains 
the event images of all of the cameras in a particular layout and the cameras that 
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are switched on by network messages. To activate the alarm list feature, click Tools 
> Options > Alarm List. For more information, see Section 3.3, Alarm Processing.

•	 Create a Grid Layout from all Cameras in the Layout: Click this button and all the 
window areas contained in a background layout will automatically be displayed in 
a grid layout. It will not cause the background layout to change.

•	 Open Extra Window: This button shows the live image of the active camera in a 
separate window. This is useful in instances where, for example, the active window 
is in Player mode, yet you would like to view the camera simultaneously in real time.

•	 Change the Scaling of the Camera Windows: The drop-marker menu button here 
allows you to specify the scaling of a layout window. The following options are avail-
able:

•	 Layout decides

•	 Full screen: Maximizes the current camera image

•	 Fit display area: Increases the size of current camera image

•	 All windows half size

•	 All windows double size

Note

The All windows half size and All windows double size options are not avail-
able for background layouts.

•	 Toggle Full Live Image Mode: The Full live image mode makes the entire sensor 
image of a camera visible at all times. This applies in particular to MOBOTIX hemi-
spherical Q cameras, which usually show a portion of the entire sensor image with 
distortion correction enabled. You can view the entire image without distortion cor-
rection with this button. In other camera models, the Full live image mode button 
is always active unless you zoom in on the image.

•	 Switch Image Post-Processing On/Off: Image post-processing can be used to sub-
sequently enhance how live images or event sequences are displayed. You can 
adjust the settings for saturation, brightness, backlight and sharpness. Click this 
button to activate or deactivate the post-processing features. With the drop-marker 
menu button here, you can open the dialog box that contains the settings for image 
processing.

•	 Copy Current Image to the Desktop: Click this button to immediately save the image 
that is currently displayed in the active window of a layout (yellow frame) to the 
Desktop (as a *.bmp file).

•	 Copy Current Image to Alarm List: Click this button to save the image that is currently 
displayed in the active window of a layout to the alarm list. If the Open list on new 
alarm option in Tools > Options > Alarm List is active, the alarm list will be displayed 
automatically.



59/152MxControlCenter Controls

© MOBOTIX AG  •  Security-Vision-Systems  •  Made in Germany

www.mobotix.com  •  sales@mobotix.com

•	 Print Current Image: This button displays a print preview of the image that is currently 
visible (the original image is also printed if the image has been changed using the 
post-processing functions). You can print the image or save it as a *.pdf file from this 
dialog box.

•	 Show Alarm Instructions of Selected Camera: Use this button to show the alarm 
instructions for the selected camera in a separate window. You can assign the alarm 
instruction file in Tools > Options > <Camera tab> > Layout and display options.

•	 Activate the Preferred Layout of the Selected Camera: Use this button to show the 
preferred layout for the selected camera. You can assign the preferred layout in Tools 
> Options > <Camera tab> > Layout and display options.

•	 Show/Hide a Reference Image of the Selected Camera: Select this button to view 
the reference image assigned to a camera. You can also do this by clicking the M 
icon (memory) in the title bar of the image window. A background layout needs to 
be active for the Reference image button to work.

•	 Enable Audio for the Selected Camera: This button activates the selected camera's 
audio that is transmitted from its microphone to the computer. Note that the camera 
microphone needs to be activated in Admin Menu > Loudspeaker and Microphone.

•	 Activate Announcement to Camera: Click this button to activate the announcement 
feature of the active camera. You can now make an announcement over the camera 
loudspeaker using the microphone that is connected to the MxControlCenter com-
puter. Note that the camera loudspeaker needs to be activated in Admin Menu > 
Loudspeaker and Microphone.

•	 Turn Light On/Off via Camera: Click this button to permanently activate switching 
output 1 of the selected camera. Click this button to switch the light on or off (using 
MOBOTIX ExtIO, CamIO or a relay).

•	 Open the Door via the Selected Camera: This button also activates switching out-
put 1 of the selected camera, but only for a preset time. A door opener can be 
activated in this manner, for example.

•	 Cancel/Restart the Connection to the Selected Camera: You can either cancel or 
restart the connection to the active camera with this button. This is useful when, for 
example, a camera occasionally causes a lot of network traffic but is not needed at 
the moment. The message Offline appears in the display window of the active 
camera.

•	 Change the Camera Settings from MxCC: Click this button to open the Camera 
Configuration dialog box where you can change the selected settings of one or 
more MOBOTIX cameras or synchronize them with each other. This applies, for 
example, to enabling features ranging from arming and recording, to image and 
exposure settings, and recording, recording path (external server, SD/CF card, etc.) 
and events.

•	 Open the Camera in a Web Browser: This button opens the active camera in a 
window of your default web browser.

•	 Show Camera Information in the Web Browser: This button opens the information 
(Admin Menu > Camera Status) of the active camera in your default web browser.



60/152 MxControlCenter Manual: Advanced Features

© MOBOTIX AG  •  Security-Vision-Systems  •  Made in Germany

www.mobotix.com  •  sales@mobotix.com

3.1.2	 The "Layouts" Sidebar Panel

In the Layouts sidebar panel you can select, create, modify, delete or rename grid layouts 
and background layouts. To access these features, you first need to activate the Layout 
Manager by clicking the Toggle Layout Manager button in the toolbar or the Layout > 
Edit... command from the pop-up menu). Use the mouse to click on the desired layout or 
use the arrow keys on the keyboard. To view the Layout panel, the sidebar needs to be 
visible (Right-click > View > Side bar > Show).

•	 Back/Forward: These buttons and the corresponding lists work like Internet browser 
buttons, enabling you to navigate through established layouts.

•	 New Layout: The New Layout command opens the Create New Layout dialog box. 
In this dialog box you can select the type of layout you would like to create (back-
ground or grid layout). You can also select the background image for a background 
layout or the grid type for a grid layout. For additional information on this topic, see 
Section 3.2Editing Layouts.

•	 Quit Layout Manager: You can deactivate the Layout Manager by selecting this 
command or the Toggle Layout Manager button in the toolbar. MxControlCenter 
will then return to its normal display mode.

•	 Add Cameras: This command opens the Add Cameras dialog box in which all 
available MOBOTIX cameras and other video sources can be viewed, added to 
the camera list in the sidebar and used in MxControlCenter layouts. For additional 
information on this topic, see Section 3.2, Editing Layouts.

•	 Define as Start Layout: You can define any layout as the start layout with this command. 
A start layout is represented by green text in the layout list. MxControlCenter always 
displays this layout when you launch the program. Note that the Start Layout option 
in Tools > Options > General > On startup needs to be activated for this to occur.

If the Return to Start Layout after ... sec. option is activated (Tools > Options > 
General), this start layout will also be activated automatically after the specified 
time period. For additional information on this topic, see Section  3.2.3Additional 
Options for Editing Layouts.

•	 Cut, copy, paste, duplicate, delete or rename layout: You can use the the associ-
ated copy and paste features with layouts using these commands.
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Hierarchical Features

Layouts can be grouped hierarchically in the layout list. This can be done by moving an 
item in the list with your mouse or using the commands from the pop-up menu.

•	 Up, Down: These menu commands move the selected layout up or down. You can 
also perform these functions directly by moving the items in the list with your mouse.

•	 Up One Folder: This menu command moves the selected layout up one folder in 
the hierarchy (to the left in the list display).

Section 3.2 describes how to edit a layout and the content it displays.

3.1.3	 The "Player" Sidebar Panel

You can view and play back the recorded 
image and event sequences of a camera 
in Player mode. To activate the Player 
mode, either click the Toggle Player mode 
button from the toolbar, right-click the 
Player mode command from the pop-
up menu of an image window or click 
the Player title bar in the sidebar panel.

Note

To view the Player panel, the sidebar needs to be visible (Right-click > View > 
Sidebar > Show). The Player panel will be disabled if no camera window is active, 
i.e., the active camera window is not in Player mode.

Buttons for Playing Back Event Sequences

•	 Play Events Only - Backwards: Plays back the images of all event sequences quickly 
and in reverse order. Click the button again to stop playback.

•	 Previous Frame: Click this button to show the previous image of an event sequence.

•	 Play: Plays back the event sequences including all images. Click the button again 
to stop playback.

•	 Next Frame: Click this button to show the next image of an event sequence.
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•	 Fast Forward: Fast-forwards through the images of all event sequences. Click the 
button again to stop playback.

Buttons for Playing Back Event Images

•	 Jump to Beginning: Click this button to display the first saved image.

•	 Rewind: Plays back the event images in reverse order. Click the button again to stop 
playback.

•	 Previous Event: Click this button to display the previous event image.

•	 Next Event: Click this button to show the next event image.

•	 Play Events Only - Forwards: Plays back the event images in chronological order. 
Click the button again to stop playback.

•	 Jump to End: Click this button to display the last saved image.

Time-Synchronized Playback

The Player panel in the sidebar also 
allows you to play back synchronized 
video from several cameras in a layout 
simultaneously. Synchronous playback 
applies to all the display windows of 
a layout that are currently in Player 
mode. You can switch the display 
windows to Player mode by clicking 
the Toggle Player mode button in the toolbar for individual windows or the All button in 
the Player panel for all the windows of a layout at once.

Making a selection from the Synch. Mode drop-down list opens a dialog box for setting 
the start time. Enter a start time and click Goto to set all Player windows to that time.

Note

If one of the selected cameras did not make any recordings at that time, the time 
of the closest available recording will appear in the image. 
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Now use the buttons in the Player panel to control playback.

The two selectable synchronization modes work as follows:

•	 Real time: Click this option to enable real-time synchronized playback in all display 
windows selected for this purpose. Note that MxControlCenter needs to be able to 
load all necessary data fast enough to allow real-time synchronized playback. If, 
for example, a large number of recordings are loaded from the same file server 
or via the individual cameras and played back synchronously, this option may not 
function properly.

Caution

If the data cannot be read fast enough to ensure real-time playback, some of 
the images will be ignored in the display. This may cause "jumps" in scenes 
involving motion. In this case, selecting the option Reduced Speed will dramati-
cally improve performance (see next point).

•	 Reduced speed: In this mode, synchronized playback is performed at a slightly 
reduced speed for instances where ‑ data cannot be read fast enough ‑ to allow 
real-time playback. Moreover, instead of forcing synchronicity, this mode allows a lag 
time of up to 600 milliseconds between the cameras. Thanks to these two features, 
you can perform "near-synchronized" playback of substantially more cameras with 
zero image loss. Given a standard system configuration, for example, you are now 
able to synchronously play back the data recorded by 16 cameras in a layout over 
a period of ten minutes and with a lag time of less than two seconds.
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Display, Time Selection and Search elements

• The Date and Time of the First, 
Last and Currently Displayed 
Image: This section displays the 
time of the fi rst and last recorded 
images and the time of the cur-
rently displayed image.

• Slider Bar: The slider bar allows you to quickly navigate to a specifi c time in the 
recorded video sequence.

• Search Fields for Date and Time and the Search Button: Enter a date and time and 
click the Search button to display the next available video sequence.

export Feature

• export Button: You can set 
the current time as the start 
or end position from the 
pop-up menu of the slider 
bar. Clicking the export but-
ton opens the "Export" dia-
log box and adds the selected time range to the export list automatically.

More information on the export features is available in Section 2.6.4 Export List and 
Data Export.
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3.1.4	 The "PTZ Controls" Sidebar Panel

PTZ Controls allow you to zoom and select an 
area from a camera live image or recorded event 
sequences. They only include features used either 
directly by the camera in the live image or sub-
sequently by MxControlCenter. The subsequent 
use of these features by MxControlCenter can 
also apply to both the live image as well as the 
recorded images or video sequences.

The existing features are especially relevant for 
Q24M camera models that have a 180° lens. These 
cameras produce extremely distorted spherical 
"full images" that are capable of depicting the 
entire interior of a room, for example.
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A number of options are now available for processing these kinds of images:

•	 Full - Camera provides full image for live streaming and recording: The camera 
sends the full image to MxControlCenter in a video stream. Here, it is saved in its 
original unedited form.

In MxControlCenter you also have the option to correct the spherical image for display 
purposes, which involves removing all distortion and applying vPTZ actions (virtual 
pan/tilt/zoom actions). This can be done for both the live display and recorded data.

Since all image information is available in the recorded full image itself, you can 
subsequently access any specific area of the image when performing a search.

Full image of the camera(live 
streaming and recording)

Area of the live image subsequently cor-
rected by MxControlCenter
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•	 Area Corrected - In-Camera Distortion Correction for Live Streaming and Recording: 
The camera is also capable of correcting the full image for distortion on its own and 
sending the corrected image to MxControlCenter in a video stream. Either a zoomed-in 
area or a specific summary view (Surround, Panorama, Double Panorama, Panorama/
Focus) generated from the full image can be sent to MxControlCenter from here. The 
corrected image of the live view will also be saved accordingly.

In this case MxControlCenter displays both the live stream and the recorded data 

without changes. 

The Surround view displays the full image of the entire image sensor of Q24M as a 
quad view with four virtual cameras (North, East, South, West-abbreviated NESW). You 
must set the North direction. The directions of the other virtual cameras (East, South 
and West) are set automatically (they are determined by rotating an additional 90° 
clockwise for each direction).

“Surround” view with 
north/east/south/west 
views as generated by the 
camera(live streaming and 
recording)
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•	 In-Camera Distortion Correction for Live Streaming and Recording as a Full Image: 
In this case, MxControlCenter displays the live stream without changes, but automati-
cally performs distortion correction when displaying the recorded data.

Here, you can also subsequently access any specific area of the image when per-
forming a search.

Corrected area of the camera live 
image (zoomed and panned)

Corrected area of the recording 
(zoomed and panned)

Recorded full image
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Important

1.	 The underlying full image needs to at least have a MEGA resolution (1280 x 960) 
or, better yet, a QXGA resolution (2048 x 1536) for subsequent image distortion 
correction by MxControlCenter. Otherwise subsequent distortion correction will 
not result in satisfactory image quality. This applies both to the live display and 
the recorded data.

2.	 The same views are supported as with in-camera distortion correction if 
subsequent distortion correction is performed by MxControlCenter:

•	 Area corrected

•	 Surround view

•	 Panorama view

•	 Double Panorama view

•	 Panorama/Focus view

Advantages and Disadvantages of Each Method

1.	 Camera Provides Full Image and Distortion Correction in MxControlCenter

Advantages:

•	 Higher frame rate since no additional load is imposed on the camera's processor 
by complex image distortion correction.

•	 All image information is included in the recording and then available for sub-
sequent searches

Disadvantages:

•	 High data rate is required for live streaming since the camera needs to send at 
least MEGA images to MxControlCenter

•	 High data rate when reading recorded videos in MEGA/QXGA resolution.

•	 Higher load on the MxControlCenter computer due to image distortion correction

2.	 In-Camera Distortion Correction (Live Streaming and Recording)

Advantages:

•	 Lower data rate for live streaming and reading the recordings since they can be 
saved in smaller formats (VGA, SVGA).

•	 Subsequent distortion correction means no additional load on the MxControlCenter 
computer
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Disadvantages:

•	 Image distortion correction imposes additional load on the camera's processor 
and leads to a lower frame rate.

•	 Important segments of the recording where an event occurs may be missing in 
the case of live PTZ actions.

•	 The complete set of image information is no longer available for the Video Search 
feature.

3.	 In-Camera Distortion Correction for Live Streaming and Recording as a Full Image

Advantages:

•	 Subsequent distortion correction means no additional load on the computer 
running MxControlCenter for the live display

•	 All image information is included in the recording and then available for sub-
sequent searches.

•	 High data rate not required to run the live display.

Disadvantages:

•	 Image distortion correction and full image storage impose an additional load on 
the camera's processor and lead to a lower frame rate

•	 High data rate when reading recorded videos in MEGA/QXGA resolution.

The best method for you depends on your specific needs and circumstances.

You can activate the virtual pan/tilt func-
tion controller by right-clicking the PTZ 
Controls command from the pop-up 
menu or clicking the PTZ Controls title 
bar in the sidebar.
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Note

To view the PTZ Controls panel, the sidebar needs to be visible (Right-click > View 
> Sidebar > Show). Whether the camera window is set to live image display or 
Player mode determines which sections of PTZ Controls are active. Whether or not 
a particular section is activated also depends on which MOBOTIX camera is being 
used. For example, the Left, Right and NESW Auto Move features are only available 
for the MOBOTIX Q models.

•	 Camera Live Image: You can use this drop-down list to choose the display mode of a 
MOBOTIX camera in the selected display window. The display modes you can choose 
from are the same as the display mode options provided in the quick control of the 
camera live view in a browser window (for more information, refer to the MOBOTIX 
software manual and the MOBOTIX Q24M camera manual).

•	 MxCC Display: The PTZ features of MxControlCenter can be selected from this drop-
down list. They have the same appearance as the display modes of the camera live 
image, but differ from the PTZ features applied directly to the camera insofar that 
MxControlCenter PTZ features can always be applied to a complete camera full 
image (with all the information of the 180° hemispheric image) after being recorded.

Note

You should set the camera to its maximum resolution (a QXGA resolution of 
2048 x 1536 pixels in the case of a MOBOTIX Q camera, for example) to obtain 
the best image quality when using MxControlCenter PTZ features. Note, however, 
that this will reduce the frame rate.

•	 Virtual Joystick, Zoom: This control simulates the behavior of a real joystick. Moving 
the virtual joystick to the left or right pans the image horizontally in the display win-
dow, while moving it up or down tilts the image. You can either turn the ring or drag 
the slider bar to zoom in or out of the image in the display window.

•	 1x Zoom: This button resets the zoom factor of PTZ Controls to a factor of 1, which 
returns the display to its normal setting.

•	 Center Pan: This button centers an image area that has been modified using PTZ 
features. This will not affect any zoom factor that may have been set.

•	 Auto Move: The Auto Move buttons can be used to move a MOBOTIX camera to the 
next saved position/zoom level (the Views 1-15 and Jump NESW buttons) or auto-
matically pan the image area to the left or right (the Pan Left and Pan Right buttons). 
Only Q24M models support this feature.

Live image modes 
for Q24M models

PTZ features of 
MxControlCenter
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•	 Positions: Each of the 16 position buttons can be used to save and open a specific 
position, image area and zoom level of a camera view. Click the corresponding 
button for three seconds to save a specified camera view. Click the corresponding 
button briefly to access a saved position.

Positions can be defined and then accessed in the following cases:

•	 Live PTZ in MOBOTIX cameras

•	 Pan/tilt heads that can be controlled via MOBOTIX cameras

•	 Lock icon: MOBOTIX Q24M cameras support special "MultiViews" such as Surround, 
Panorama, Double Panorama, and Panorama/Focus. These views are automatically 
defined after camera installation based on the "North direction" setting and can no 
longer be modified by vPTZ actions. The "vPTZ lock" on these views is indicated by 
the lock icon. However, you can also unlock these views by clicking the icon and then 
adjusting them according to the current scene using vPTZ commands. Click the icon 
again to re-lock the views to prevent any inadvertent changes by vPTZ commands.

Note

The lock status applies separately for the individual multi-views mentioned above.
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3.2	 Editing Layouts

This section describes the advanced features for creating and managing grid and back-
ground layouts. The basic procedure for creating a layout has already been described in 
Section 2.4.3 Creating Layouts.

3.2.1	 Grid Layouts

Display windows are shown without a background for grid layouts. This layout type 
is specifically suited to display systems in which the the display of the video sources is 
located in the foreground.

Positioning Video Sources

1.	 Activate the Layout Manager by click-
ing its icon in the toolbar.

2.	 Select the layout that you would like to 
edit (for example, Main entrance) or 
create a new grid layout (see Section 
2.4.3 Creating Layouts).

3.	 Select a grid type in the bottom section 
of the Layout Manager (for example, 
CIF/CIF/CIF/CIF as listed in the panel).

4.	 Confirm the system prompt. The display 
panel of MxControlCenter displays 
the selected grid.

5.	 Drag a camera or video source from 
the sidebar to a grid display window 
in the display panel. Cameras or video 
sources already placed in the layout can 
be moved to another display window 
using the drag and drop feature. The 
two fields will switch their positions 
as soon as you release the mouse 
button.

6.	 Double-click the name of the layout 
in the sidebar and enter a name for 
the layout.

7.	 Quit the Layout Manager by clicking 
Toggle Layout Manager in the toolbar 
or the Quit Layout Manager command from the pop-up menu. The layout will 
be saved automatically.
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Removing Grid Elements

The content of a grid display window can be removed 
by clicking Empty from the pop-up menu (right-click the 
display window). You can assign a video source (or a dif-
ferent element type) to the now empty display window. If 
you click Delete, the entire display window will be deleted 
and the next grid elements will move up.

Configuring The Display Window In A Grid Layout

You can configure the element type of a display window in the Configure element dialog 
box (Right-click > Edit or Configure). Additional configuration options are provided depend-
ing on which element type you select. The maximum size of a display window is 2560 x 960 
pixels (see the section Creating New Grids below).

•	 Empty: Select this option to delete an element that has already been assigned 
to the display window. The window itself will remain in the layout and will not be 
deleted permanently. The element type you would like to use can now be assigned 
at a later date.

This option is also useful if a window's position is already defined in a layout even if 
the MOBOTIX camera (or other video source) to be displayed will only be available 
in the network at a later time.
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Display Window - Elements With Permanently Assigned Video Sources

•	 Live: Choose this element type and the live image of the camera or video source 
selected from the drop-down list will appear in the display window. In addition, you 
can select the size of the display window.

•	 Preview: Choose this element type and the preview image of the camera or video 
source selected from the drop-down list will appear in the display window. In addi-
tion, you can select the size of the display window.

A preview window requires significantly fewer resources and causes less network 
traffic compared to a live window. This element type is particularly effective when 
your network has limited bandwidth and you are displaying many different video 
sources in the layout.

You also have the option to select the image sensor, the maximum frame rate and 
the resolution of the preview image of the MOBOTIX camera.

•	 Video Clip: This element type can be used to load a previously recorded MxPEG 
video clip in the display window where it is automatically set to continuous playback. 
It can also be used for alarm list files. In addition, you can select the size of the 
display window.

•	 Player: Select this element type to display the camera or video source of the display 
window selected from the drop-down list in Player mode. You can now play back 
the recorded image and event sequences of the selected camera or video source in 
the Player sidebar panel. In addition, you can select the size of the display window.

•	 File Server Path: This element type can be used to display video sequences that 
have been recorded on an external file server by a camera. You can also play back 
the sequences in the Playersidebar panel. In addition, you can select the size of 
the display window.

Display Windows - Elements With Variable Video Sources

•	 Player Window: Select this element type and the event sequences of the camera 
or video source for which an alarm was triggered most recently will be displayed 
automatically. Only one player window can be defined for each layout. A player 
window will show the relevant event by clicking an image from the alarm list. Player 
windows in background layouts are indicated by a gray title bar.

•	 Alarm Window: Select this element type and the live image of the camera or video 
source for which an alarm was triggered most recently will be displayed automati-
cally. By clicking the display window (or acknowledging the alarm if the alarm list is 
active), the alarm window will be cleared until a new alarm occurs. Note that you 
also need to activate the Alarm List feature under Tools > Options > Alarm List. Only 
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one alarm window can be defined for each layout. Alarm windows in background 
layouts are indicated by a gray title bar.

•	 Sequencer Window: This element type is used to display the content of all the display 
windows contained in the layout in alternating order. For example, you can create a 
layout in which the display of a camera's live image alternates in a large window.

You can define a global time interval for the sequencer window under Tools > Options 
> General > Sequencer time. You can also define a custom interval for each camera 
in the Sequencer time field located on the respective camera's tab in the same 
dialog box.

Click Configuration to open the Sequencer Configuration dialog box in which you 
can manage the order of display and the sequencer times for all cameras or video 
sources contained in the layout. Sequencer windows in background layouts are 
indicated by a gray title bar.
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Creating New Grids

To create a new grid, make sure the Layout Manager is activated, then click Edit Grids... 
in the sidebar of the Grids panel. The available space will be divided up according to the 
width of the display panel (the maximum width is 2560 x 960 pixels).

Grid Single Elements

•	 u	 80 x 60 pixels	 tiny element

•	 s	 160 x 120 pixels	 small element

•	 m	 320 x 240 pixels	 medium-sized element (CIF)

•	 l	 640 x 480 pixels	 large element (VGA)

•	 h	 1280 x 960 pixels	huge element (MEGA)

Grid Double Elements

•	 du	 160 x 60 pixels	 tiny double element

•	 ds	 320 x 120 pixels	 small double element

•	 dm	 640 x 240 pixels	 medium-sized double element (CIF)

•	 dl	 1280 x 480 pixels	large double element (VGA)

•	 dh	 2560 x 960 pixels	huge double element (MEGA)
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Procedure

1.	 Select a layout that you would like to modify, duplicate an existing layout (the Duplicate 
button), or create a new layout (the New button).

2.	 Define the width of the layout. Layout width can be based on the available screen 
resolution, for example (1920, 2560, ... pixel width). The total width of the layout in 
pixels is determined and displayed according to the specified number of columns 
(layout width in pixels = x columns times 160 pixels). It is always a whole number 
and a multiple of 160 pixels.

3.	 Create the layout by entering the abbreviation of the grid element you would like 
to use in the text box. The preview window shows the resulting layout.

Note that MxControlCenter will initially place an element in the row to the right 
whenever possible, provided that enough space is available in the layout. If this is 
not the case, the element will be placed in the next row with sufficient space. This 
means that large elements may be placed in a new row at times, while small ele-
ments are added to any unused areas at the top of the layout.

Note

The grid element abbreviations can be separated from each other by a space, 
comma or line break.

4.	 Make sure the resulting layout meets your specifications and save it by clicking Save.

The new layout is now available in the Grids sidebar panel.
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3.2.2	 Background Layouts

Unlike grid layouts (see Section 3.2.1), background layouts allow you to freely arrange 
the video sources on top of a background image. You also have the option of displaying 
individual MOBOTIX cameras as symbols on top of the background image. These symbols 
display the viewing direction and lenses of the cameras as well as the camera's status: 
Detected, Not detected, and Connection error. Double-click the symbol to display the live 
image of the camera in a separate window.

Positioning Video Sources

1.	 Activate the Layout Manager by clicking 
the symbol in the toolbar.

2.	 Select the layout that you would like to 
edit (for example, Overview) or create 
a new background layout (see Section 
2.4.3 Creating Layouts).

3.	 Select a background image (*.jpg, 
*.bmp, *.gif) in the bottom panel 
of the Layout Manager (for example, 
Parking lot view). Click Add Image to add 
additional image files to the Background 
images panel.

4.	 Confirm the system prompt. The display 
panel of MxControlCenter displays the 
selected background image.

5.	 Using drag and drop, move a camera 
or video source from the sidebar to any 
position you like in the display window. 
Cameras or video sources already placed 
in the layout can be moved to any other 
position in the display area. If a display 
window is moved onto another display 
window, both windows will switch their 
positions as soon as you release the 
mouse button.

6.	 Double-click the name of the layout in the sidebar and enter a name for the layout.

7.	 Quit the Layout Manager by clicking Toggle Layout Manager in the toolbar or 
the Quit Layout Manager command from the pop-up menu. The layout will be 
saved automatically.
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Configuring The Display Window In A Background Layout

You can configure the element type of a display window in the Configure element dialog 
box (Right-click > Edit or Add). Additional configuration options are available depending 
on which element type you select.
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Besides the elements described above in Section 3.2.1 Grid Layouts, a number of additional 
elements are available for background layouts:

• Status Icon: You can use this element type to create an icon that visually represents 
the viewing directions and image angles of one or two image sensors and also 
indicates the surveillance status of the camera using diff erent colors, i.e. whether an 
MxControlCenter computer is displaying the live image of the camera or video source 
in question.

Now when you click a status icon in the layout, the live image of a camera or video 
source will automatically be displayed in the assigned focus window (see the Focus 
window element type below in this section). Status icons are only available for 
background layouts.

Note

Additional functions are also available with MxStatus, a stand-alone application 
that monitors the status of all cameras connected to MxControlCenter. MxStatus 
is included in the MxControlCenter installation and can be loaded on any 
computer by double-clicking the MxStatus.exe fi le in the MxControlCenter 
application directory. If multiple instances of MxControlCenter are running in 
the network and registered in MxStatus, MxStatus can also provide informa-
tion on whether a camera is accessible and whether it is being monitored by 
an instance of MxControlCenter. This information is displayed using diff erent 
colors. The IP address and port of the MxStatus computer must be specifi ed 
in the General tab on the Tools > Options dialog box for all relevant instances 
of MxControlCenter. For more information, see Section 5.2 The "General" Tab, 
error Display for Connection errors and error Display on Latency Timeout.

Camera 
OK,detected

Camera OK,not 
detected

No connection to 
camera
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•	 Focus Window: By clicking a status icon created in the layout, the live image from the 
camera or video source that was specifically assigned to that icon will be displayed in 
the defined focus window. More than one focus window can be created per layout. 
Select the focus window you would like to define. Now click a status icon and it will 
be assigned to that focus window. Focus windows are identified by a pink title bar. 

•	 "Close Windows" Button: With this option you can add a button to the layout that, 
when clicked, closes all free-movable live image windows. Movable live image win-
dows are automatically opened when you double-click any display window that has 
an assigned camera or video source.

Right-click the button to display the pop-up menu. Here, you can select the back-
ground color of the button.

•	 "Configure Sequencer" Button: With this option you can add a button to the layout 
that, when clicked, opens the Sequencer 
configurationdialog box. This dialog box 
provides a convenient way to configure 
the order of display and the sequencer 
times for all the cameras or video sources 
contained in the layout.

Right-click the button to display the pop-up 
menu. Here, you can select the background 
color of the button.

•	 "Layout" Button: With this option you can 
add a button to the layout that, when clicked, 
opens the layout that was last selected and 
defined in the drop-down list. The name 
of the layout is automatically written on 
the button.

Camera Window Options in the Background View

Various features are available in the title bar as icons in the display windows of the back-
ground view (for example, the Live element type):
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•	 Show Alarm Instructions of Selected Camera: An instruction file can be created for 
each camera. Click this button in the toolbar or the icon in the title bar to open up 
this file in a separate display window. The instruction file can contain floor plans or 
essential information for alarm procedures.

•	 Activate the Preferred Layout of the Selected Camera: A preferred layout can be 
defined for each camera. Click this button in the toolbar or the icon in the title bar to 
activate a display window. MxControlCenter switches to this layout when the follow-
ing events occur:

•	 An alarm is detected in the live video stream of a camera, which means a 
camera has detected an event. The alarm list feature needs to be enabled in 
Tools > Options > Alarm List for this to work. For more information, see Section 
2.5 Alarm Management.

•	 A network message from the camera or a video source is received. For more 
information, see Section 2.5 Alarm Management.

•	 Click Activate the preferred layout of the selected camera in the toolbar or the 
appropriate icon in the title bar of any display window.

•	 Show/Hide a Reference Image of the Selected Camera: You can save the current 
live image for each camera as a reference image. Click this button in the toolbar or 
the icon in the title bar of a display window to display the reference image in a 
separate window. This allows you to compare it with the current camera image. This 
provides an easy way for you to determine changes in the positions of objects, 
vehicles, containers, etc.

3.2.3	 Additional Options For Editing Layouts

Defining A Start Layout

You can define the layout that is selected in the list as the start layout in the pop-up menu 
of the Layouts sidebar panel (Right-click > Define as start layout). MxControlCenter will 
now display this layout automatically when the program is launched. An activated start 
layout can be identified by the green text. You can also define a time interval at which 
MxControlCenter automatically switches to the defined start layout under Tools > Options > 
General > Return to Start Layout after. This helps to ensure that the scene you would like to 
monitor is displayed automatically, even if a different layout was selected in the meantime.

Defining An Instruction File

In order to define an instruction file for a camera, open the Camera tab for the particular 
camera under Tools > Options and select the desired Instruction file.
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Defining A Preferred Layout

In order to define a preferred layout for a camera, open the Camera tab for the particular 
camera under Tools > Options and select the desired Preferred/alarm layout.

Defining A Reference Image

In order to save the current live image as a reference image, make sure that the Layout 
Manager is activated, right-click the desired camera and select Define reference image 
for camera from the pop-up menu.

3.3	 Alarm Processing

MOBOTIX Cameras and MxControlCenter Working Together 

True to the decentralized approach of 
MOBOTIX systems, MxControlCenter 
cannot trigger any primary alarms 
(events) on its own. This is the job of 
the MOBOTIX cameras. The cam-
eras record the event internally (on 
an integrated SD/CF card) and, if 
desired, to an external file server. 
MxControlCenter captures the alerts, 
displays them, and, if necessary, 
calls attention to the situation using 
appropriate audiovisual means.

The full range of MxControlCenter features can only be used if the MOBOTIX cameras 
are properly configured and the alarm list in MxControlCenter is enabled in the Options 
dialog box (see Section 2.5 Alarm Management).

The alarm processing features of MxControlCenter, in turn, provide various ways for dis-
playing the alarms and alarm notifications.

MxControlCenter Alarm Detection

If a camera triggers an alarm (event), MxControlCenter has two methods for detecting it:

•	 Alarm Notification via Live Stream of Camera: The camera is armed and records 
the alarms on its own, either in its internal or external video storage (on a file server). 
MxControlCenter only detects the alarms if the camera is displayed in the current 
layout in a live or preview window and is supplying images.

•	 Camera Network Message: The camera communicates with MxControlCenter via a 
network message. MxControlCenter detects the alarms from all cameras that send 
network messages to the computer running MxControlCenter. This method ensures 
that alarms are detected from cameras, even if the corresponding camera is not 

MOBOTIX
IP camera

Event recognized

Processing event
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displayed in the current layout. This method of alarm detection should always be 
preferred when dealing with security applications.

For more information on confi guring the remote control features for MOBOTIX cameras 
and MxControlCenter, see Section 3.5 Remote Control Using Network Messages.

Refer to the table below for a summary of the options available for both alarm methods:

Response Live Stream 
Alarm

network Message 
Alarm

Display alarm image in alarm list X X

Play back audio fi le on the MxControlCenter com-
puter

X X

Fill alarm window with live images of last alarm 
triggering camera

X X

Activate preferred/alarm layout - X

Maximize a minimized MxControlCenter (from the 
taskbar) and display on the screen

- X

Bring all offl  ine cameras in the preferred/alarm 
layout online and restore MxControlCenter to the 
top, if necessary

- X

Caution

For installations with high security requirements, you should defi nitely set up remote 
control using network messages as this provides the most reliable method of alerting.  
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3.3.1   Alarm List

Activating the Alarm List

The alarm list is not activated when you launch MxControlCenter 
for the fi rst time. To activate the alarm list, click Tools > Options 
> Alarm List  (tab) and then click the Activated checkbox. After 
activating the alarm list, alarms from the recording cameras in 
the current layout and alarms from cameras that send network 
messages to the MxControlCenter computer are displayed in the 
alarm list. These alarms will also be saved in the alarm list, even if 
it is no longer visible after clicking Show/Hide Alarm List.

All alarm methods use the acknowledgement feature of the alarm list, i.e. the audiovisual 
alarm features described below are repeated until all alarms have been acknowledged 
by clicking the title bars of the alarm images.

Visual Alarm Methods

The visual alarm methods are displayed as soon as the alarm list is activated (Options > 
Alarm List > Activated). Make sure that the displayed cameras are confi gured to trigger 
alarms.

• Camera Windows: Flash on alarm

• Live and Preview Windows in Grid Layout: The frame of the camera window fl ashes red.

• Live and Preview Window in Background Layout: The camera title bar fl ashes red.

• Alarm Window (If Defi ned in the Layout): Shows live images from the alarm camera 
inside a fl ashing red frame

• Mouse-Over Images: The title bar fl ashes red.

• Alarm List Icon: Flashes red

• Status Bar of the Alarm List: Red if an alarm is unacknowledged, otherwise green

• Title Bars of the Alarm Images or Alarm entries: Unacknowledged alarms are 
shown in red, acknowledged alarms in blue.

Acoustic Signal Features

If the alarm list has been activated, you can also choose sounds in the Options > Alarm 
List  dialog box. These sounds will be played by MxControlCenter over the audio system of 
the computer in the event of an alarm. You can choose between using a standard sound 
(beep) or a custom audio fi le (*.wav). Likewise, you can defi ne the frequency with which the 
acoustic signal is repeated and when the sound will stop after acknowledging an alarm.



87/152Alarm Processing

 © MOBOTIX AG  •  Security-Vision-Systems  •  Made in Germany

 www.mobotix.com  •  sales@mobotix.com  

Display Options for the Alarm List

The following display options are provided for the alarm list:

• Hides the images in the alarm list

• Shows the images in the alarm list (pre-set)

• Enlarges the alarm list images

• Enables the fi lter features of the alarm list (see next point)

Alarm list fi lter features

The buttons of the fi lter feature show the following states:

• no Filter: Incoming alarms are displayed from all cameras in the layout as well as 
those alarms from the cameras that control MxControlCenter remotely using network 
messages (see Section 3.5 Remote Control Using Network Messages).

• Camera Filter: Shows only alarms from cameras selected in the display panel (yel-
low frame); all other incoming camera alarms are stored in the alarm list, but are 
not displayed.

• Temporary Camera Filter: Shows only images from the selected camera (yellow 
border). New incoming alarms from other cameras will disable the fi lter feature.

3.3.2   Displaying Stored Alarms

MxControlCenter displays the alarms either in the alarm list (in chronological order) or 
inside a player window.

The Alarm List Display

The alarm list always receives all alarms triggered by all live cameras in the current layout. 
Furthermore, the camera alarms that the MxControlCenter computer receives via network 
messages are also displayed. The alarm list images are recorded in a ring buff er in the 
computer. The maximum size of of the ring buff er can be set in the Options dialog box 
(see Section 5.3 The "Alarm List" Tab).

Every image in the alarm list is shown with the alarm time, camera name and the elapsed 
time since the alarm in the title bar in the colors listed below:

For additional information on this topic, see Section 2.5.4 Acknowledging Alarms.

Unacknowledged alarm

Unacknowledged alarm from selected camera

Acknowledged alarm

Acknowledged alarm from selected camera
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Acknowledging Alarms

MxControlCenter provides an Acknowledgement Feature that can be used to ensure that 
all alarms are checked and processed.

You can acknowledge an alarm by clicking the red title bar, which then switches to blue 
(yellow if it is the selected camera in the display area).

Once all alarms have been acknowledged, the status fi eld of the alarm list changes from 
red to green. If an alarm window is defi ned for this layout, the window is cleared and will 
only be activated again when a camera triggers a new alarm.

Timed Automatic Acknowledgements

In the Options > Alarm List dialog box, you can defi ne a time period after which the alarms 
will be automatically acknowledged.

For more information on the alarm list options (for example, alarm list size, alarm list fi le, 
sounds, etc.), see Section 5.3 The "Alarm List" Tab.

Unacknowledged alarm Acknowledged alarm
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3.4	 Video Searches And Export Features

MxControlCenter offers a convenient way of finding specific events to help you determine, 
for example, what the camera located at the rear entrance recorded last Saturday after-
noon (the Open Event Search button in the toolbar).

The Video Search User Interface

The user interface of the Video Search dialog box is divided into the following sections:

•	 Storyboard: Visual display for searching for events visually

•	 "Camera" and "Events" Tabs: Quickly browse and find events during a given time period

•	 Event Display:Shows an event in the Player and includes the option to perform 
subsequent image processing (virtual PTZ and distortion correction)

•	 Image Improvement: Subsequent adjustment of saturation, brightness, backlight 
and sharpness of the currently displayed image

•	 Reference Time: Determines the time difference to a specific event

•	 Search time: Search for events beginning at a specific time
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Storyboard

The storyboard shows the recorded events in chronological order 
from left to right, similar to the individual frames of a movie. 
Use the arrow keys to quickly scroll backwards or forwards. 
The currently selected event has a yellow frame. The current 
event is shown with the date, time, and the event type (yellow 
highlighting).

The "Camera" And "Events" Tabs

Use the Cameras tab to select the camera 
containing the event list you would like 
to review. The Events tab contains all 
stored events from this camera listed 
by time, date, and event type.

The slider bar lets you quickly find the 
desired time period between the start 
and end times of the recording. The 
arrow keys allow to you scroll from 
event to event in one-event steps. The 
alarm image of the event selected here 
is automatically shown in the storyboard 
and also enlarged in the event view window.

Event View

The event view window displays the 
individual alarm images of the event 
selected from the storyboard or the 
Events tab. Use the Player buttons to 
scan or play back the event images (see Section 2.6.2 Defining Player Windows for more 
information on Player controls). Besides being able to search for a position within an 
alarm clip, you can also use the slider bar to view the time for the currently displayed 
image within the recording.

Image Improvement

If the quality of the alarm image is not adequate due to noise or other factors, you can 
use the image improvement slider bars to adjust the saturation, brightness, backlight 
and sharpness of images.

Besides general image improvement, you can also apply the PTZ features (pan, tilt, zoom) 
to the camera image (see Section 2.7.1 Image Post-Processing). You need to enter the type 
of lens for the camera and the mounting position of the camera (ceiling or wall) for the PTZ 
features to work properly. These settings can be defined in the corresponding camera tab.
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Reference Time

An important factor to take into account 
when switching between cameras is 
the time difference between a reference 
event and another event. A reference 
time needs to be defined for this pur-
pose by clicking Set reference time to time of the current image. A reference time can 
be set at a specific event in the event list or even at a single frame of an alarm clip for 
greater precision. If you select another event now, its time difference to the reference time 
will be automatically calculated and displayed. In the process, you can switch to any of 
the events listed for the different cameras. The event that is closest in time to the reference 
time is automatically highlighted.

You can define a new reference time with the same button. If you select Set reference 
time automatically to current image time, the reference time will be synchronized with 
the current time of the image in the Player window. Click Unlock reference time to delete 
the reference time.

If the reference time is no longer visible in Events, click Jump to reference event to go 
back to the reference event. When viewing individual alarm images in Player mode, you 
can adjust the reference time to match the Player time by clicking Set reference time 
automatically to current image time as often as you need.

Search Area

To search for a certain event (or all 
events) that occurred on or after a 
specific time, enter a date and time 
in the Search time field and click Search. MxControlCenter selects the event in Events 
that comes closest to the specified time.

Exporting Recorded Data

The options for exporting recorded data have already been described in Section 2.6.4 
Export List and Data Export.
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3.5    Remote Control Using network Messages

With the remote control features (Tools > Options > Remote Control), MOBOTIX cameras 
(and other network devices) can cause MxControlCenter and other MOBOTIX cameras 
to perform certain functions. This is done using network messages (TCP/IP messages), 
which a MOBOTIX camera (or another network device) sends to a predefi ned port of the 
computer running MxControlCenter.

network messages enable an alarm to be triggered if certain events occur on a camera 
without displaying the live video stream from that camera in MxControlCenter.

This way, a MOBOTIX camera can, for example, activate the appropriate preferred layout 
assigned to it in MxControlCenter (Activation with Preferred Layout) and restore minimized 
MxControlCenter application windows (Windows toolbar). You can continue to record alarm 
and live images, activate cameras in a layout, open new windows with the camera live 
image, and even defi ne complete layouts in a camera network message and then set 
them up in MxControlCenter. For this to work properly, the camera that sends the network 
messages may not be included in the currently displayed layout in  MxControlCenter.

• Camera IP notify Only Port: If this option is enabled, the preferred/alarm layout 
selected in the camera's tab will be activated in MxControlCenter once the relevant 
network message has been received. In this case, this activates the IP notify profi le 
MxCC Alarm: simple for a MOBOTIX camera (see the section on Creating a 
Network Profi le on the MOBOTIX Camera below).

• General Remote Control and Camera IP notify: If this option is enabled, advanced 
remote control commands can be sent to the computer or MxControlCenter. You 
can furthermore defi ne a sound or audio fi le that will be emitted when a network 
message is received.

Section 5.4 The "Remote Control" Tab contains information on the available parameters 
of a network message for remote control of MxControlCenter.
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Notes

•	 Ports 31666 and 31667 are used in the following examples. Make sure the 
ports you are using are not also in use by other services in the network and 
that these ports can be accessed by your computer and, in particular, are not 
blocked by a firewall. Makes sure that you always use ports with numbers 
greater than 1023 and lower than 65535. For more information, refer to the 
article on "TCP and UDP port numbers" aten.wikipedia.org.

•	 After setting up the ports, the Windows Firewall normally asks whether it should 
continue to block the MxControlCenter application. Click Do not block so that 
the necessary remote control ports can be opened. This usually requires you 
to have administrator privileges on the computer. If you are using a different 
firewall program, you may have to manually release the ports or configure 
the firewall accordingly.

Configuration Example

The following example shows you how to set up MxControlCenter and a camera so that 
the camera sends a network message to the MxControlCenter computer when a particular 
event occurs. When the computer receives this network message, it automatically loads 
the preferred layout assigned to the camera. This layout contains the view assigned to 
the camera that has triggered the alarm and sent the message.

Activating The Remote Control In MxControlCenter

•	 Activate the Camera IP Notify only port option (Tools > Options > Remote Control). 
Enter the desired port (for example, 31667) and the IP address of the remote control-
ling MOBOTIX camera (for example, 172.168.0.100).

Defining The Preferred Layout For Cameras

•	 Define the preferred layout for the remote controlling camera (Tools > Options > Camera 
tab; for more information, see Section 3.2.3 Additional Options for Editing Layouts).
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Creating A Network Profile On The MOBOTIX Camera

•	 Enter the IP address of the computer on which MxControlCenter is activated (Windows: 
Start > Run > cmd, ipconfig command).

•	 Open the remote controlling MOBOTIX camera in a browser window.

•	 In this case, this activates the IP notify profile MxCC Alarm: simple with the set-
tings described below (Admin Menu > IP Notify Profiles).

•	 Save this configuration (click Set and then Close).

Activating Camera Events And Configuring Messages

•	 Open the remote controlling MOBOTIX camera in a browser window.

•	 Create a message (Setup Menu > Messages) with the settings shown below for the 
desired event, for example, VM ‑ Video Motion Detection.

•	 In order to be able to test the message later, activate the event UC‑ User Click.

•	 Save this configuration (click Set and then Close).

•	 Also make sure to enable Arming for the camera (Setup Menu > General Event 
Settings) and the User Click event (Setup Menu > Event Settings).
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Testing The Remote Control

•	 Minimize MxControlCenter to an icon in the Windows taskbar.

•	 Open the live view of the MOBOTIX camera in a browser window.

•	 Click the  UC Event button on the user interface of the camera.

The network message will now be sent to the MxControlCenter computerand the applica-
tion window should appear on the screen on top and display the alarm-triggering camera 
in your preferred/alarm layout.

3.6	 Saving The Configuration Of MxControlCenter Cameras

Changes to the configuration can generally only be made by MxControlCenter users with 
admin access rights (provided an admin password is assigned; see Section 3.7.1 Access 
Levels of MxControlCenter).

The storage location of the current settings is displayed at the bottom of the Options 
dialog box.

3.6.1	 Global And Local Folders

Both global and local folders are used to store the configuration data of MxControlCenter. 
The global folder is intended to store a shared configuration for multiple users (only 
administrators can change this configuration). The global folder needs to first be specified 
in the General tab on the Options dialog box.

Local folders can be created by the administrator to store special settings. This configu-
ration data is not stored in a central location, but in the folder of the currently running 
MxCC.exe application. This approach allows you to create special configurations by 
copying MxControlCenter to different folders (user-defined folders, for example) and then 
launching the application from one of these folders. After setup is complete, you can store 
the configuration in a local folder when quitting MxControlCenter.

3.6.2	 Storing The Program Settings

You can store the current configuration settings by selecting one of the following menu items:

•	 Tools > Program settings > Save (overwrites the current configuration file)

•	 Tools > Program settings > Save as...

•	 Tools > Program settings > Export environment...
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Both of these menu items open the Save Configuration dialog box.

•	 The Configuration only (INI file) option allows you to store the current configuration 
in any existing or new *.ini file.

•	 The Configuration und resources (...) option is used to save both the configuration 
file (MxCC.ini) and all the resources used in the configuration (background images, 
instruction files, audio files, MxPEG clips, etc.) to a selected target directory. In this 
target directory, a new *.ini file in which all the resources are linked using rela-
tive file paths and thus available in the individual layouts for display will be created.

You can use this option to export the configuration and all necessary data to a new 
directory for later use there.

•	 The Complete package (configuration, ...) option performs the same actions as the 
Configuration and resources (...) option, but adds all necessary MxControlCenter 
program files to the data that is copied to the target directory.

With this option, for example, you can perform a complete export of MxPEG clips, 
including those in the program itself, to a CD or USB storage device. Because an*.
ini file is also created in the target directory, you can now launch MxControlCenter 
directly from that location to play back the MxPEG clips.

Demo installations can also be copied to other computers in this manner without 
any problem.

Caution

If you have defined a global folder, MxControlCenter only uses the configuration 
stored in that folder if there is no configuration (*.ini file) stored in the installation 
directory of MxControlCenter (the directory in which the MxCC.exe file is located.
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3.7	 Users And Passwords

3.7.1	 Access Levels Of MxControlCenter

The three access levels of  MxControlCenter (no login for guests, admin for administra-
tors, user for normal users) will be activated once the appropriate passwords are set in 
MxControlCenter. If no passwords are specified, the administrator privileges will be 
applied automatically.

The following table lists the individual functions that can be performed by the three access 
groups:

Function Guest User Admin

Switch layouts X  X  X

View live videos X  X  X

View instruction files X  X  X

Print image X  X  X

View reference image X  X  X

Acknowledge alarm X  X  X

Quit MxControlCenter -  X  X

Play recordings -  X  X

Event Search -  X  X

Change camera settings -  X  X

Edit layouts -  -  X

Change program settings -  -  X

Show/hide program elements -  -  X

3.7.2	 Activating Password Protection In MxControlCenter

Follow the steps below if you would like to protect MxControlCenter and specific cameras 
from unauthorized access:

•	 Open the Options dialog box (Tools > Program settings in the menu) and enter the 
Admin password in the General tab in order to prevent unauthorized access to the 
Admin level (table in Section 3.7.1).
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•	 In the same tab, enter the user password in order to prevent unauthorized access 
to the User access level (table in Section 3.7.1).

There is no password assigned for users in the Guest user level. This user level is automati-
cally activated when the program is launched. Guest users may only use the functions 
described in the table in Section 3.7.1 in the Guest column.

Note

In order to strictly limit access to the MxControlCenter installation, make sure to hide 
all menus, sidebars and toolbars that must be hidden via the View menu.

For these settings to be applied, you need to quit the program and the changes to 
the program settings need to be written to the *.ini file.

3.8	 Security Considerations

You should follow the measures outlined below to avoid security problems.

3.8.1	 General Thoughts On Network Security

•	 Certain MxControlCenter features (remote control, for example) require additional 
ports to be open on a Windows computer. Make sure the Windows computer running 
MxControlCenter is behind a firewall.

•	 Some anti-virus scanners check all data streams that enter the computer. As a result, 
an anti-virus scanner may identify the video/audio data received in the MxControlCenter 
camera as malicious code and block it accordingly. If the corresponding mechanisms 
of the anti-virus scanner are deactivated, the anti-virus protection of the computer 
is incomplete. For this reason, it should not be used to surf the Internet or to receive 
e-mails.

3.8.2	 Restricting Public Access

You can improve the security of the entire system by disabling public access on all cameras 
and setting up a dedicated user for MxControlCenter on each camera.

3.8.3	 Camera Settings (In The Browser)

•	 Always use MOBOTIX cameras with software version 2.2.2.x or higher.

•	 Make sure the cameras cannot be accessed by unauthorized users by blocking public 
access in Admin Menu > Users and Passwords (in the browser).

•	 Create a new group (for example, MxCC) with the MxControlCenter privilege in 
Admin Menu > Group Access Control Lists.
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•	 Create a new user (for example, MxCC) for the MxCC group in Admin Menu > Users 
and Passwords. Enter this user and the appropriate password to access the cameras 
from MxControlCenter.

3.8.4	 Settings In MxControlCenter

•	 After testing the ports, you should replace the * entry in the Allowed IPs field of the 
Options > Remote Control dialog box in MxControlCenter with the IP addresses of 
cameras that are allowed to send messages to MxControlCenter (use commas to 
separate multiple addresses). Network messages from unlisted IP addresses will 
now be rejected.

•	 In the same dialog box, make sure the Accept only valid commands option in the 
Camera IP Notify only port section is activated.

•	 Do not use the same ports, user names, passwords or other entries that appear in 
this manual as your settings.

•	 Create a dedicated user to access MOBOTIX cameras (see Section 3.8.3 Camera 
Settings (in the browser)).

Caution

A computer running MxControlCenter with open ports should never have a direct 
connection to the Internet. Make sure that the computer is adequately protected by 
an appropriate hardware firewall (normally in a router).

The Windows firewall on this computer does not provide effective protection and 
cannot replace a hardware firewall.
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3.9	 Image Post-Processing

3.9.1	 Overview

The Image Post-Processing features can be used to improve and correct images from 
MxControlCenter. This includes correcting the saturation, brightness, backlight and sharp-
ness of an image.

The post-processing features do not depend on the type (IP or analog) or model of the 
camera. Furthermore these features can be applied to any video source within an image 
window, which means not only live streams, but also previously recorded video data:

•	 Camera Live Images/Live Streams

•	 Saved MxPEG Clip Files

•	 Recorded Video Streams from a File Server

•	 Snapshots/Still Images

Enhanced images can be printed directly from MxControlCenter and/or saved as a file. 
The recorded image and video sequences themselves are not changed since the post-
processing features only affect how they are displayed in MxControlCenter.

The image post-processing is configured for the current display window (yellow frame). 
Select a MOBOTIX camera and click the arrow to the right next to the Switch image post-
processing on/off button and then click Settings (in the menu under Camera >MxCC 
display mode > Settings) in order to configure the image post-processing (see Section 
3.9.2 Configuring Image Post-Processing).

Once you have configured the image post-processing, you can activate or deactivate this 
function using the Switch image post-processing on/off button (see Section 3.9.3 Activating/
Deactivating the Image Post-Processing).
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3.9.2	 Configuring Image Post-Processing

Select a display window with a MOBOTIX camera (live or recorded) 
and click the arrow to the right next to the Switch image post-
processing on/off button and then click Settings  (in the menu 
under Camera > MxCC display mode > Settings).

The Image Processing panel has two different areas: The upper area, 
PTZ, controls the settings of the virtual PTZ features of MxControlCenter 
(Section 2.7.2 Distortion Correction) and image post-processing is 
configured in thePost-Processing area. Select the desired camera 
and activate the Post-Processing checkbox (this panel can be used 
for multiple cameras one after another). When you move the slider 
bars, the changes will be made immediately in the active display 
window:

•	 Saturation: The slider bar changes the saturation (the inten-
sity of the colors) in the active image window.

•	 Brightness: The slider bar changes the brightness in the active 
display window, making the image lighter or darker as desired.

•	 Backlight: The slider bar changes the backlight in the active display window, increas-
ing or decreasing it.

•	 Sharpness: This slider bar sharpens the image in the active display window. This 
allows you to subsequently improve the appearance of dull image sequences, for 
example.

•	 Reset: This button resets all post-processing settings to their factory default values.

Note

Post-processing is prohibited on video or image sequences intended for use in legal 
proceedings. For this reason, the printouts made with active post-processing will 
include both the original image and the edited image.

3.9.3	 Activating/Deactivating Image Post-Processing

Click Switch image post-processing on/off  in the toolbar to activate or deactivate image 
post-processing for the active display window (yellow frame). In addition, this button shows 
the status of post-processing for the active display window (the post-processing is active 
when the button is clicked).
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3.10	 Third-Party Cameras With PTZ Controls And Pan/Tilt Heads

3.10.1	 Overview

Besides MOBOTIX cameras, you can also connect third-party IP or analog cameras (for 
example, Axis IP cameras, Bosch AutoDome, Siemens SpeedDome) to MxControlCenter. 
For more information, see Section 2.8.1 Integrating Third-Party Digital/Analog Cameras.

Some camera models feature motorized pan/tilt units and zoom lenses that can be con-
trolled from within MxControlCenter using a joystick or the PTZ Controls sidebar panel. 
If a MOBOTIX camera is mounted on a pan/tilt head and configured accordingly, its pan 
and tilt features can also be controlled from an MxControlCenter computer.

3.10.2	Connecting Third-Party IP And Analog Cameras

To connect and display a camera in MxControlCenter, enter the IP address (or DNS name), 
port number and login data (user name and password).

Open the menu Camera  > Add and click Camera to display the Add Video Source 
dialog box:

An additional computer is required to integrate analog  cameras from third-party manufac-
turers on the MOBOTIX MxServer software. MxServer can digitalize up to four connected 
cameras using a frame grabber card and make them available for MxControlCenter 
(see Section 3.10.5 Using Analog Cameras with MxServer).

•	 IP cameras can be added by specifying the type (Axis, Merit LILIN, etc.) and IP address.

•	 Analog cameras (Bosch AutoDome, Siemens SpeedDome) can be integrated by 
selecting the type, the MxServer channel and entering the IP address of the MxServer 
computer. The port number shows which of the analog cameras connected to the 
MxServer are to be used.

For more information on connecting analog cameras, configuring MxServer and storing the 
video streams of IP and analog cameras from third-party manufacturers using MxServer, 
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see the documentation regarding MOBOTIX MxServer at www.mobotix.com. For an 
overview of MxServer, see Section 3.10.5 Using Analog Cameras with MxServer.

3.10.3	Activating Integrated PTZ Units And Pan/Tilt Heads

The control options of the integrated mechanical pan, tilt and zoom features of the cam-
era and the external pan/tilt heads can be activated and deactivated in the MxControlCenter 
dialog box (in the menu Tools > Options) on the tab of the individual camera in the PTZ/
Rotor Control area:

Defining A Type For The PTZ/Rotor Control

•	 No Pan/Tilt Head

Use this type under the following circumstances:

•	 vPTZ control of MOBOTIX cameras

•	 vPTZ control of Axis IP cameras with vPTZ features

•	 PTZ control of connected IP dome cameras (Axis, Sony, Panasonic, Toshiba, 
Merit LILIN)

•	 PTZ control of analog dome cameras connected to an MxServer computer

•	 All Other Selectable Protocols

These are specific protocols used to control the individual mechanical pan/tilt heads 
via the installed MOBOTIX camera (Videotronic, Provitek, VPT 42, etc.).

3.10.4	Using MOBOTIX Cameras With Pan/Tilt Heads

MOBOTIX cameras (currently M12 and D12 models only) can be connected to the motor-
ized pan/tilt heads via the D-SUB 15HD connector. Now you can use the user interface 
(soft keys) of the camera to pan and tilt the camera.

An overview of the necessary steps for configuring a MOBOTIX camera in conjunction with 
a motorized pan/tilt head is provided below. More detailed information on the connection 
and control commands can be found in the documentation of the respective pan/tilt head.

Pan/Tilt Heads Currently Supported By MOBOTIX

•	 Provitek, Provitek PT2, Provitek PT3

•	 Videotronic SN-15AH (modified by MOBOTIX)

•	 VPT 42 (RS232/RS485 configuration with VT protocol)
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Assembly And Activation Of Pan/Tilt Head

•	 Attach the MOBOTIX camera to the mounting bracket on the pan/tilt head.

•	 Connect the supplied control cable of the pan/tilt head to the D-SUB 15HD connector 
of the MOBOTIX camera.

•	 Connect the pan/tilt head and camera to the power supply.

•	 Configure the serial interface of the MOBOTIX camera (Admin Menu > Configure 
Serial Interface; see figure below).

•	 Save the configuration to the permanent flash memory of the MOBOTIX camera 
(Admin Menu > Save) and reboot the MOBOTIX camera.

Once you have completed these steps, the pan and tilt features of the pan/tilt head will 
be available for the camera in MxControlCenter .
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Creating And Configuring Camera Soft Keys For Controlling The Pan/Tilt Head

If you would like to control the pan/tilt head using the user interface of the MOBOTIX 
camera, we recommend configuring the soft keys and the associated soft key definitions 
(Admin Menu > Soft Keys in the browser interface of the MOBOTIX camera). The control 
commands are included in the documentation of your pan/tilt head.

Note

These settings are not necessary if you would like to control the pan and tilt features 
using only MxControlCenter with a joystick.

•	 Configure the soft key definitions for moving the pan/tilt head (Up, Down, Left, Right, 
Stop; Admin Menu > Soft Keys).

•	 Configure the soft key definitions for saving and moving to individual pan/tilt head 
positions via soft keys (Preset X, Save Preset X; Admin Menu > Soft Keys). Because 
the positions are saved in the pan/tilt head itself (see Section 3.10.4 Using MOBOTIX 
Cameras with Pan/Tilt Heads), the maximum number of available positions depends 
on the pan/tilt head model you are using (for example, 32 with a Provitek PT3).

•	 Create the soft keys for moving the pan/tilt head and for saving and moving to the 
pan/tilt head positions. Information on creating soft keys is provided in Section 4.9 
Configuring Soft Keys in the software manual.
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Configuring Time-Controlled Positioning Of The Pan/Tilt Head

With the time control feature of the MOBOTIX camera, you can move to the predefined 
pan/tilt head positions at specific times. For this purpose the time control feature of the 
camera is used in conjunction with network messages, which the camera uses to send 
HTTP requests to itself. The MOBOTIX camera assumes remote control of its pan/tilt head 
independently, so to speak.

The following steps are required to set up this functionality:

•	 Define the pan/tilt head positions you would like to use and then save them (Save 
Preset X buttons; see previous section).

•	 Set up a user with permission to access HTTP API commands (for example, user name: 
rotor, password: rotor). This is necessary because the camera uses authentication 
to execute HTTP requests that are sent itself for security reasons, which means the 
login data of an authorized user is required (user name and password) .
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•	 Create a network message profile for moving to each pan/tilt head position. The 
camera sends an HTTP request to itself. This executes the rcontrol program with 
the following instruction for controlling the pan/tilt head via RS232:

action=putrs232&rs232outtext=<Rotorkopf-Steuersequenz>

The necessary control commands are outlined in the documentation of your pan/tilt 
head. More information on MOBOTIX HTTP requests can be found in the camera's 
online help under HTTP API  and in Section 11.5.4 Executing Camera Actions and 
Features (rcontrol) in the software manual.

•	 Now set up time-controlled tasks that execute the relevant network message profile 
at the specific times you enter and move the pan/tilt head to the desired position 
(for example, position 1 at even-numbered minutes and position 2 at odd-numbered 
minutes in the figure below):

•	 Parallel to this, images can now be recorded automatically along with the regular 
event (every ten seconds) or with the time control feature in combination with the 
time-controlled event (one image each minute, for example).

3.10.5	Using Analog Cameras In MxServer

MOBOTIX MxServer allows the integration of analog surveillance cameras into an IP network. 
MxServer consists of a Windows computer with a frame grabber card (IDS FalconQuattro 
PCI) and the MOBOTIX MxServer software.

Integration into an IP network means that the analog cameras connected to MxServer can 
be accessed the same way as network cameras (using an IP address). You can display an 
image from the analog camera in a browser, in MxControlCenter or in any other applica-
tion that can access HTTP servers and display M-JPEG streams.

The video cable of the analog camera is connected to the port of the frame grabber card 
in the computer while the control cable of the camera is connected to the serial interface 
of the computer (RS232/RS485). MxServer ensures that the relevant channel of the frame 
grabber card is mapped to a network port (for example, 80, 81, ...).
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You can also control the motorized pan, tilt and zoom features integrated into the ana-
log cameras of MxControlCenter using a joystick. Live streams of the cameras can be 
recorded on a file server.

Live video streaming is used as a bridge between the video stream supplied by the analog 
camera and Windows computers with MxControlCenter. MxServer reads the video frames 
digitalized by the frame grabber card and then converts the bitmap data into *.jpg images 
(or M-JPEG streams). These images are then transferred to the requesting clients over the 
network (computers with MxControlCenter). The resolution of the transferred images/
steams can be configured with MxServer (768 x 576, 640 x 480 VGA, 320 x 240 CIF).

The maximum number of simultaneously requesting clients depends on the performance 
of the Windows computers running MxServer and the available bandwidth of the network 
connection.

Regardless of that, the digitalized video frames can be recorded by MxServer on the file 
server (continuous recording) and then searched and played back in MxControlCenter. 
MxControlCenter directly accesses the data recorded on the server for that purpose. 

Prerequisites For Use Of Analog Cameras With MxServer:

•	 Computer (minimum: Pentium IV with 512 MB RAM)

•	 Windows operating system: XP, 2000 or 2003 Server

•	 Installed and configured IDS FalconQuattro PCI frame grabber card

•	 MOBOTIX MxServer

•	 Installed Video for Windows driver (automatically installed with MxServer)

•	 Analog surveillance camera (Bosch AutoDome, Siemens SpeedDome) connected to 
the frame grabber card and a serial interface of the computer

•	 MxControlCenter on a client computer with proper configuration for the relevant 
analog camera for controlling the pan, tilt and zoom features
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Notes

•	 The FalconQuattro frame grabber card has four inputs (channels), but only two 
analog cameras can be connected to it. When using two cameras with the 
same frame grabber card, the frame rate is limited to 12.5 frames per second 
for each camera.

•	 You can also install more than one frame grabber card in a computer. However 
we advise against this as only low frame rates would be possible.

•	 We recommend using multiple computers with a FalconQuattro card installed 
on each and two connected analog cameras at most for large installations. If 
a high frame rate is required (more than 12.5 fps), each analog camera should 
be connected to a separate computer.

Detailed information on connecting analog cameras and configuring MxServer can 
be found in the supplied documentation at www.mobotix.com.
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Notes
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4    COnFIGURInG MOBOTIX CAMeRAS

4.1   The "Camera Confi guration" Dialog Box

The Camera Confi guration (the Change the camera settings from MxCC button in the 
toolbar or Camera > Properties > Confi gure...) dialog box provides an overview of selected 
settings of all the MOBOTIX cameras that are connected to MxControlCenter. In addition, 
the settings for an individual camera or for several cameras can be changed all at once.

• Section 4.2, The “Overview” Tab: Displays information for all cameras defi ned in 
MxControlCenter in a table.

• Section 4.3, The “Image Settings” Tab: Allows you to adjust the values for saturation, 
brightness, backlight and sharpness of selected cameras.

• Section 4.4, The “exposure” Tab: This tab allows you to adjust the exposure options 
of the selected cameras.

• Section 4.5, The „Recording“ Tab:

The camera selection list is shared by all areas and includes a window for previewing 
the camera's live image. Further functions can be accessed using the following buttons 
under the live image window:

• Click to Reload the Current Confi guration for the Selected Video Sources: Use 
this button to reload the confi guration data of selected cameras. This function may 
be useful when, for example, the camera settings can also be changed by other 
users.

• Click to Force a Reboot of the Selected Video Source: Use this button to reboot 
selected cameras.

• Click to show/hide the preview image of the selected video source: Use this but-
ton to activate or deactivate the live image preview of the selected camera in the 
preview window. This function may be useful when, for example, displaying the live 
image takes up too much time due to a slow network connection.

• Click to See a Snapshot/Live Image of the Selected Video Source Only: Use this 
button to retrieve the current live image from the selected camera once and to 
display it in the preview window. This allows the camera to be identifi ed, yet prevent-
ing the preview image from being constantly updated and, as a consequence, con-
siderably reduces the network load.

The settings of the selected cameras are automatically loaded and displayed in the dialog 
box. This dialog box will notify you if the individual settings of several selected cameras 
are diff erent. You can transfer the settings to a camera by clicking OK or Apply. However, 
this will only transfer data if the settings for the relevant camera have also changed.
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The settings on the Image Settings and Recording screens can be applied to several 
selected cameras all at once. This allows you, for example, to conveniently confi gure an 
event recording for all cameras on one computer in one step.
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4.2     The "Overview" Tab

This section contains a list of selected camera settings. They include the arming and 
recording statuses, the activated events, the type of event recording (snapshot, events or 
continuous recording), and the storage location (external fi le server, internal SD card, 
internal fl ash memory, etc.).

Many settings can be modifi ed using the pop-up menu. The pop-up menu also off ers you 
the option of switching to the appropriate area for more detailed settings (for example, 
Recording).

Clicking OK or Apply sends the modifi ed settings to the camera, where they are stored 
permanently.
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For more information on the available camera settings (user interface in the browser), 
see the software manual:

• Arming: Setup Menu > General event Settings > Arming: For more information, 
see Section 7.5 Arming in the software manual.

• Recording: Setup Menu > Recording > Arming: For more information, see Chapter 
8 Recording in the software manual.

• Events: Setup Menu > event Settings. For more information, see Section 7.6 Events 
in the software manual.

• Mode: Setup Menu > Recording > Recording (ReC). For more information, see 
Section 8.2 Recording Modes in the software manual.

• Server: Admin Menu > Storage on external File Server / Flash Device. For more 
information, see Section 8.3 Recording Modes in the software manual.

4.3     The "Image Settings" Tab

This screen allows you to adjust the settings that determine the quality of the camera 
image (saturation, brightness, sharpness, backlight, resolution, JPEG quality, etc.). The 
image settings can be applied to several selected cameras all at once.

If the Apply changes immediately checkbox is activated, the changes are immediately 
stored in the camera, are immediately visible in the preview image of the dialog box and 
in the live image, and are also available after rebooting.

If this checkbox is not activated, the changes are fi rst sent to the camera, where they are 
also stored once you have clicked the Apply button.
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If the selected camera is a MOBOTIX Dual Model with two image sensors, you can con-
fi gure the settings for each image sensor individually. The image sensor in question can 
be selected from the selection list.

Caution

Make sure that you have selected the desired image sensor again before closing 
the dialog box.

For more information on the available camera settings (user interface in the browser), 
see the software manual:

• S/B/B/S: Saturation, Brightness, Backlight, Sharpness.

Setup Menu > Color Settings, Setup Menu > exposure Settings and Setup Menu > 
General Image Settings. For more information, see Section 5.5 Image Controls and 
Section 5.7 Exposure Settings in the software manual.

• Camera Sensor: Sensor selection (only possible with dual lens models).

Setup Menu > General Image Settings. For more information, see Chapter 5 Basic 
Camera Confi guration of the software manual.

• Format: Resolution, JPEG Quality, Transfer Rate (frames per second), Mode (image 
quality).

Setup Menu > General Image Settings and Setup Menu > Image Settings. For 
more information, see Section 5.5 Image Controls and Section 5.7 Exposure Settings 
in the software manual.

• Image Settings: Night Improvement, White Balance, Noise Suppress, Automatic Contrast.

Setup Menu > exposure Settings, Setup Menu > Color Settings and Setup Menu > 
General Image Settings. For more information, see Section 5.5 Image Controls and 
Section 5.7 Exposure Settings in the software manual.

• exposure Settings: Exposure Program.

Setup Menu > exposure Settings. For more information, see Section 5.7 Exposure 
Settings in the software manual.

If you want to edit further settings beyond the confi guration options that are available here, 
MOBOTIX cameras allow you to make advanced changes directly using your browser 
(Setup Menu > Image Control).
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4.4     The "exposure" Tab

The exposure screen of the camera confi guration allows you to adjust the exposure 
windows of the selected MOBOTIX camera.

exposure windows enable MOBOTIX cameras to determine the optimal exposure for 
the images. You can use the camera's pre-defi ned exposure windows or you can defi ne 
custom exposure windows.

exclusion Windows defi ne the sections that should be excluded when determining 
the correct exposure (for example, bright sources of light in the camera's image area).

exposure Weighting defi nes how the exposure windows are assessed in relation to the 
area outside of the exposure windows (100% = use exposure windows only).

The exposure windows are normally displayed in a frame with a thin border. Clicking this 
frame causes the border to be displayed in bold ("activated") and the coordinates of the 
frame are displayed in the Frame Details group.

editing exposure And exclusion Windows

• Changing the Size of a Window: Move the mouse over the frame of the window, 
which can then be edited, as indicated by the cursor.

• Moving a Window: If you move the mouse over a window, the cursor will change 
and you will be able to move the window anywhere you like.

• Deleting a Window: Click the small "x" in the top right-hand corner of the frame to 
delete the window. Activated frames (bold) can be deleted by pressing the DeLeTe 
key.

Exposure Window “Quarter” (Default)
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Adding exposure And exclusion Windows

• Adding an exposure Window: Use the mouse to draw a green frame within the 
camera's image area.

• Adding an exclusion Window: Use the mouse to draw a new green frame in the 
image area (the new frame is automatically active) and click the Exclude checkbox 
in the Frame Details group. The active frame is now displayed in red.

Other Options

• Show Frame: These options allow you to defi ne if and when the exposure and 
exclusion window frames are shown in the camera's image area.

4.5     The "Recording" Tab

This tab allows you to confi gure the settings for Recording, which in turn determine how 
image data is archived.

A recording can be activated with the recording switch and you can choose the recording 
mode. When particular events are detected by the camera, you can activate a record-
ing with a particular frame rate and pre- and post-alarm times (Time Before and Time 
After). In addition to confi guring the camera for internal recordings, the camera can also 
be confi gured to archive image data on a local PC or another computer of your choice.

notes And explanations On The Groups

• Recording: Arming status for recording.
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• Mode: Recording Mode, Snapshot/Events/Continuous.

• Frame Rate: Frames per second for continuous recording.

• Audio: You can record audio for event recording and continuous recording when 
recording in MxPEG format.

• Full Image Recording: The cameras always store the full image using this fea-
ture, regardless of the live image stream that is being displayed. This ensures that the 
recording always contains the full image, even though the operator may have used 
the vPTZ features to zoom into the image in order to examine a specifi c detail. This 
applies particularly to the Q24M models, which rely strongly on the vPTZ features in 
the live image. This means that you can use the vPTZ features to pan, tilt and zoom 
the live image while the camera is recording full images at 1 fps in MEGA or QXGA 
resolution. Thanks to the advanced distortion correction features of MxControlCenter 
and MxEasy, you can still play back and examine the recorded full images of Q22M 
cameras normally, that is, without distortion. To use this feature, activate the Full 
Image Recording option under Camera Confi guration > Recording. This dialog 
box also allows you to set the desired resolution, in addition to other parameters.

Please pay attention to the following:

• You should use at least MEGA format (ideally QXGA) if you are using Full Image 
Recording on MOBOTIX cameras in the Q series. The applications need high 
resolution to deliver satisfactory image quality when viewing the recorded images 
in MxControlCenter or MxEasy.

• As the processing power of the camera is limited, full image recording reduces 
the attainable data rate of the live image stream, which may drop by about 10 
to 30 percent. It is therefore recommended to reduce the frame rate for storage 
as much as possible, so as to minimize the eff ects on the live image stream.

• Snapshot Recording Mode: You can pack snapshots into one clip fi le to improve fi le 
server performance in Recording Mode. To do so, activate the Pack Story checkbox.

• Start Trigger: Cameras can be set up to start a recording if an event is detected. 
This event can increase the frame rate of the recording for a short period of time for 
snapshot or continuous recording.

• Frame Rate: Frames per second during the recording of the event.

• Time Before: Period of time for recording before the event takes place, including 
the specifi ed frame rate.

• Time After: Period of time for recording after the event takes place, including the 
specifi ed frame rate.

• external Recording: The camera can be confi gured to use an external storage device 
for recording image data. You can make detailed settings in the external Recording 
dialog box. Click Setup...  to display this dialog box.
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external Recording

In order to confi gure a MOBOTIX camera 
to record data to an external server, you 
need to enter the IP address of the server, 
the share name of the folder, and the user 
name and password of an authorized 
user. If you want to record to a local PC, 
you can share the folder and create an 
authorized user with the external Recording 
dialog box. MxControlCenter confi gures 
your computer as required.

Once you have confi gured the external stor-
age device for recordings and transferred 
the confi guration data to the camera (by 
clicking OK or Apply), the program may 
ask you to restart the camera in order to 
apply the settings.

• Target Computer: In order to share a folder on your local computer, use your local IP 
address (it will be entered automatically). To use a diff erent server, you need to enter 
the fi le system and IP address for this fi le server manually. If you want the camera 
to record to the expansion slot on the camera itself (USB stick, CF card), you do not 
have to enter an IP address or authorization information.

• Shared Folder: You need to enter the required information depending on the fi le 
server you choose. To record to a local computer, you can either select a pre-existing 
shared folder and user name or create a new shared folder and user name, if needed.

• Quota: The external recording can be limited according to three criteria: Maximum 
storage size in MB (Max. storage size), maximum number of days to keep (Max. 
age), and maximum number of events (Max. sequences).

• Details: When recording to a local computer, the Details area indicates any potential 
problems. For example, if you have entered an incorrect password for a user name, 
this is displayed in this area.
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MOBOTIX cameras off er advanced confi guration options for external storage devices for 
recordings. These options can be accessed directly using the browser:

• Open your browser and enter the IP address of the camera.

• Arming (Setup Menu > Recording > General Settings).

• Storage on External File Server (Admin Menu > Storage on external File Server / 
Flash Device).

4.6     Updating The Camera Software

MOBOTIX cameras are always delivered with the latest version of the required software 
to guarantee that your camera runs stably and functions properly. Nevertheless, it may 
be necessary to update the camera software from time to time, as this not only corrects 
software bugs, but also adds new features to the camera.

4.6.1  Preparing The Software Update

As a MOBOTIX camera owner, you are entitled to free software updates for your camera. 
Go to www.mobotix.com under Support > Software Downloads to download 
the latest software version. Download the correct *.mpl fi le for your camera to a specifi c 
location on your computer's hard drive.

The Update Assistant (Tools > Assistants > Update camera software) lists all cameras 
you defi ned in MxControlCenter. Note that you can only update cameras with the status 
OK in MxControlCenter.
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Connect To Camera

If a camera is listed with the status Access denied, you fi rst need to enter a valid user 
name with admin level access rights along with the corresponding password for proper 
authentication. To do this, click Connect to Camera and enter the user name and password 
for this camera in the next dialog box (Connection Settings).

Rebooting

Click Reboot at any time to restart the selected cameras for testing purposes, for example, 
for testing the confi guration of the camera after a power failure.

4.6.2  Updating System Software

Select the cameras whose software you would like to update and click Upload Software. 
Now open the *.mpl fi le you downloaded earlier. This fi le contains the update image 
for the selected cameras. Then click OK.

The software update now starts automatically. MxControlCenter displays the update prog-
ress for each camera in the Progress column. After loading the update image fi le, each 
camera has to unpack the image to the permanent memory, after which each camera 
will automatically reboot.

Caution

Do not close MxControlCenter during the software update process. Avoid power 
failures or disruptions to the network connection to the cameras.
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4.7    Saving And Importing Camera Confi gurations

The Update Assistant automatically saves the confi guration fi les for each camera. You 
can also use the Save Settings button at any time to simultaneously save the confi gura-
tions of several selected cameras. You can reload any valid confi guration to the selected 
cameras using the Upload Settings button. On the one hand, you can use this feature to 
correct a faulty confi guration fi le of a camera and to restore it to a defi ned and tested 
confi guration. On the other hand, this feature provides an easy method for copying the 
confi guration from one camera and applying it to another, making it convenient to man-
age several diff erent cameras.

Log Window

While the camera software is being updated, the individual steps are displayed in the 
Update Log window, which may be helpful for MOBOTIX support in case of problems, for 
example. If the log is not shown at the bottom of the dialog box, it can be displayed using 
the View > Update Log menu command.
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5       MXCOnTROLCenTeR OPTIOnS

5.1 Overview

You can access the MxControlCenter options under Tools > Options.... Open this dialog 
box to edit the basic settings of MxControlCenter and confi gure all the MOBOTIX cameras 
or video sources in the selected layout.

• General: This tab provides the general settings for MxControlCenter such as the 
admin and user passwords for MxControlCenter, global user names and passwords 
for the MOBOTIX cameras, the default behavior when launching and minimizing the 
application, and the default behavior when detecting general errors and connection 
errors with cameras.

More information on this topic can be found in Section 5.2, The “General” Tab.

• Alarm List: This tab includes a checkbox for activating the alarm list and other set-
tings for the alarm list features of MxControlCenter such as the size of the alarm list, 
alarm sound notifi cation, etc.

More information on this topic can be found in Section 5.3, The “Alarm List” Tab.

• Remote Control: This tab includes a checkbox for activating the remote control and 
other settings for the remote control features of MxControlCenter by MOBOTIX cameras. 
This tab's options also controls MxControlCenter behavior when receiving network 
messages (TCP/IP messages) sent by MOBOTIX cameras to the MxControlCenter 
computer.

More information on this topic can be found inSection 5.4, The “Remote Control” Tab.

• <Camera Tabs>: These tabs (each assigned with the name and IP address of the 
camera) include specifi c settings for each MOBOTIX camera defi ned in MxControlCenter. 
For example, individual user data for the respective camera or the type of pan/tilt 
head connected to the camera can be entered here.

More information on this topic can be found in Section 5.5, Camera Tabs.
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5.2	 The "General" Tab

•	 Admin password: Enter the administrator password for MxControlCenter in this 
field. Once a password has been set, users are prompted to enter this password to 
access the admin level. Enter a time in the Auto logout field to determine the length 
of time after which the user will need to enter the password again to open a certain 
feature. More information on this topic can be found in Section 3.7.1, Access Levels 
Of MxControlCenter.

•	 User Password: Enter the user password for MxControlCenter in this field. Once a 
password has been set, users are prompted to enter this password to access the 
user level. More information on this topic can be found in Section 3.7.1, Access Levels 
Of MxControlCenter.

•	 Auto Logout: After the time set in this field has elapsed, MxControlCenter automati-
cally logs out any user. When this occurs, users will need to enter the password 
again to access the corresponding features. You can set the auto logout time from 
1 to 3,600 seconds (one hour).

•	 Global Camera User Name and Global Camera Password: MxControlCenter can 
only access a MOBOTIX camera once a user name and password have been set for 
the corresponding access level for that camera (for more information, see Section 
5.4.1 User, User Groups, Passwords, Supervisor Mode in the software manual). This 
field allows standard user data to be set in MxControlCenter that are automatically 
used for MOBOTIX cameras where the fields Camera user name and Camera 
password  on the corresponding tab are empty. This option is very useful if, for 
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example, several cameras in one MxControlCenter installation or in one layout all 
have the same user name and password.

•	 Proxy: Make sure that this option is activated if a proxy server prevents direct access 
to the MOBOTIX camera. The IP address and the port of the proxy server need to be 
entered in the corresponding fields.

•	 File Server Path: MxControlCenter can access the stored image and video sequences 
either via the camera or directly from the file server on which the camera has stored 
the data. Enter the standard path to the file server in this field. This path is automatically 
used for all MOBOTIX cameras, provided the File server path field on the correspond-
ing tab is empty. Use this option if several cameras of a MxControlCenter installation 
or layout have been configured to use the same file server path.

Note

Retrieving images from a file server offers additional advantages as it is faster 
than retrieving images via the MOBOTIX camera and is also independent of 
the camera itself. This approach thus significantly reduces the network load 
and does not put any strain on the camera, since it is not involved in provid-
ing any files. Therefore, the performance of the MOBOTIX camera's processor 
is not compromised and is always available for other tasks. However, if the 
images are retrieved using the camera, you only need to enter the camera 
user name and the corresponding password to access that camera when 
configuring MxControlCenter.

Caution

When retrieving the images and video sequences from a file server, make 
sure that the shared folders have been properly configured (read rights for 
the computer and the user running MxControlCenter). For more information, 
see Section 8.3.4 Recording on a Windows Computer in the software manual.

Make sure that the computer has access to the shared folders before MxControlCenter 
attempts to access the stored image and video sequences.  MxControlCenter 
should not establish the connection itself. Note that MxControlCenter will not 
alert you if the connection fails for any reason.
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•	 During Minimize (Taskbar): This option allows you to set the behavior of MxControlCenter 
if the application has been minimized to the task bar:

•	 Stop all: This option allows you to interrupt the retrieval of the image and video 
sequences when MxControlCenter is minimized. Once the MxControlCenter win-
dow has been restored from the taskbar, you need to click the respective button 
in the toolbar to manually restart each individual display window.

•	 Pause: This option allows you to pause the retrieval of the image and video 
sequences when MxControlCenter is minimized. Once the MxControlCenter 
window has been restored from the taskbar, retrieval is automatically resumed.

•	 Continue decoding: This option allows you to continue retrieving image and video 
sequences when MxControlCenter is minimized.

Note

Note that MxControlCenter will be restored automatically when the applica-
tion receives a valid camnotify or ip command (for more information, see 
Section 5.4, The “Remote Control” Tab).

Caution

If MxControlCenter is minimized, the alarm list is only updated by the cameras 
that send network messages with the commands camnotify and ip to the 
MxControlCenter computer . While the application is minimized, incoming alarm 
images from cameras included in the current layout that do contain network 
messages are not included in the alarm list!

•	 Sequencer Time: This field allows setting a standard interval for the Sequencer 
mode. This interval is automatically used for MOBOTIX cameras unless a different 
interval has been set in the Sequencer time field on an individual camera tab in 
MxControlCenter. When in Sequencer Mode, each camera will stay visible for the 
duration entered in this field unless ‑ a specific sequencer time has been defined for 
that camera. ‑ If this is the case, the individual sequencer time will be used.

•	 On Top After: After the interval in this field has elapsed, MxControlCenter automati-
cally restores itself on top of all other application windows.

This is a convenient option to use when other applications are running alongside 
MxControlCenter and may be covering the MxControlCenter window.

•	
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•	 Return to Start Layout after: The value entered in this field determines the duration 
before the layout manager automatically activates the specified start layout.

This is a convenient option whenever you need to switch frequently between different 
layouts and would like MxControlCenter to automatically return to a certain layout.

•	 Sound on Error: Use this option to play back an audio file over the computer speak-
ers (or the default output device). When this option is activated, the selected device 
plays back either the standard system sound (Beep) or a selected audio file (*.wav) 
available on the computer (the File option) if an internal system error occurs.

•	 Sound on Lost Camera: Using this option, you can select whether an acoustic signal 
is played back over the computer speakers (or the standard playback device). When 
this option is activated, the selected device plays back either the standard system 
sound (Beep) or a selected audio file (*.wav) (File) on the computer if a connection 
error occurs in one of the MOBOTIX cameras in the layout.

•	 Error Display for Connection Errors: Using this option, you can select whether a 
connection error detected during the live display of a camera is visualized in the 
display window. You can select either a standard error message (Error message) or 
a graphics file (*.jpg) (Graphic). You can select the vertical percentage (in Y direction) 
of the display window to be covered by the graphic for graphics files.

•	 Error Display on Latency Timeout: Use this option to select either a standard error 
message (Error message) or a graphics file (*.jpg) (Graphic) to be shown in the 
display window if the latency time of a camera is too long. In this context, "latency 
time" means the time difference between the point at which an image is generated 
by the camera and the point at which it is displayed in MxControlCenter.

•	 You can select the vertical percentage (in Y direction) of the display window to 
be covered by the graphic for graphics files.

•	 In this area, you can also set the maximum latency time to use by changing the 
value for Maximum latency time (in ms).

•	 In addition, you can set the value for Maximum overdue time (in ms).

This value is exceeded when the value for Maximum latency time is exceeded by 
the Maximum overdue time. This error is reset when the Maximum latency time 
returns to a value below the set parameter for the Maximum overdue time.

Caution

When using the latency time options, make sure that the system time of the 
camera and the system time of the MxControlCenter computer are precisely 
synchronized. You need to use a time server (and, if necessary, the correspond-
ing Windows software) to ensure that they are synchronized.
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• Set Global Folder: Use this fi eld to preset a global folder for storing the MxControlCenter 
confi guration fi les. You can establish a standard confi guration for multiple users of 
MxControlCenter on diff erent computers when using this folder as a global folder 
for all MxControlCenter computers. You can also choose a shared folder on a fi le 
server on the network.

Note

For more information on which folder MxControlCenter accesses fi rst when 
loading a confi guration, see Section 3.6.1, Global And Local Folders.

• On Startup: Use this option to change the startup behavior of MxControlCenter. 
For example, MxControlCenter can automatically launch with the specifi ed startup 
layout, the layout opened at the time the program was last closed (the Last layout 
option), the Layout Sequencer, or minimized to the taskbar (the Minimized option).

• Mouse-Over: This option allows you to control the behavior of MxControlCenter 
when the mouse pointer is positioned over a camera image. For example, if you 
would like to show a full resolution live image from the MOBOTIX camera, select the 
On radio button. If you would like to see the standard MultiView layout, select the 
By MultiView radio button. At least one MultiView view needs to be confi gured on 
the camera in order to use this option. Activating the Small area checkbox will hide 
the mouse-over window if the mouse pointer leaves the small area in the middle 
of the camera window in the layout. Otherwise, the mouse-over window remains 
open until the mouse pointer leaves the area of the mouse-over window. Select the 
Off  radio button to disable this feature.

• Show Toolbar at Bottom: Use this option to display the toolbar at the bottom of the 
display area instead of at the top.

• Layout Buttons in Toolbar: Instead of displaying the buttons for executing the various 
actions as described above, the toolbar contains only buttons with the names of the 
layouts in the confi guration when this feature is activated. 

In the next text fi eld, you can specify how many of the layout buttons you want to 
be displayed in the toolbar. These buttons (a maximum of 10) are automatically 
assigned layouts from the layout list, with the layout names being displayed on the 
buttons. The position in the layout list corresponds to the position of the button in 
the toolbar from the left to right (so the fi rst layout in the layout list can be activated 
via the button on the far left of the toolbar).

This setting can be used, for example, for pure live surveillance applications in which 
the users of the system are only required to switch between layouts with diff erent 
live cameras without performing any additional functions.

• Full Screen Mode: Enable this option to maximize MxControlCenter without displaying 
any title bars or window frames. Deactivate the View > Display area only option in 
the pop-up menu (right-click) or press esC on the computer keyboard to return to the 
default view. Note that no soft key bars are shown in Full screen mode.
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•	 Use White Grid: Enable this option to display the camera windows with a thin 
white border in a grid layout. This provides a better overview of multiple cameras 
in small windows.

•	 Synchronize Clips on Start: Use this option to synchronize all MxPEG clips by time 
upon playback in MxControlCenter. This option corresponds to synchronized playback 
in local recorder mode.

•	 Demo Mode: This option activates the Demo mode of MxControlCenter. In Demo 
mode, MxControlCenter automatically displays typical actions for all cameras in 
the current layout.

•	 On Double Click: This option controls the behavior of MxControlCenter when you 
double-click a camera image. Double-clicking can switch between the right and the 
left lens of the MOBOTIX camera (Change Lens) or can open a live window (Open 
Live Window). Select Do nothing to disable this feature.

•	 Always on Top: Enable this option to always display the MxControlCenter window on 
top of all other applications. This option can be used to guarantee that MxControlCenter 
is never covered by other application windows.

•	 Reduce Frame Rate (CPU Usage): If you have set a percentage value for the CPU 
usage in this field, MxControlCenter automatically reduces the frame rate of the 
live cameras if this value is exceeded in order to adjust the CPU usage accordingly.

•	 Use Camera Layout Settings: The camera settings are saved along with the 
MxControlCenter settings. When MxControlCenter is launched again, the current 
settings of the cameras are compared to the settings stored in MxControlCenter. 
If the camera settings deviate from the stored settings, you can choose either the 
MxControlCenter settings (Always) or the camera settings (Never). The third option 
(Ask) displays a dialog box when the application is launched. Here, the user can 
select one of the two options.
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5.3	 The "Alarm List" Tab

Enabled

•	 This checkbox activates the alarm list feature. When it is activated, MxControlCenter 
stores the alarm images and video sequences of the MOBOTIX cameras in the com-
puter's RAM. In addition, MxControlCenter can store the alarm images in an alarm 
list file. This means that MxControlCenter can display the stored alarm images even 
after closing and restarting the application.

General

•	 Size: You can set the maximum amount of RAM reserved for the alarm list from the 
drop-down list here. If the value specified here is exceeded, the oldest alarms are 
automatically deleted to make room for new alarms.

•	 Alarm List File: Enter a file name for the alarm list in this field. After closing MxControlCenter, 
the alarm list will also be available the next time MxControlCenter is launched. If 
this field is empty, the alarm list is deleted when MxControlCenter is closed. The 
maximum file size for the alarm list file is also determined by the setting from Size.

•	 Open List on New Alarm: If this checkbox is enabled, MxControlCenter automatically 
shows the alarm list when detecting a new alarm.

This feature is very useful in cases where alarms are rare. In these cases, the entire 
display area of MxControlCenter can be used to display the live camera images. 
When MxControlCenter detects an alarm, it will show the alarm list shown with the 
new alarm highlighted in red.
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•	 Auto Acknowledge Alarms after: Enabling this option prompts MxControlCenter to 
automatically acknowledge the alarms after one is detected and the specified time 
has elapsed. You can set this time from 1 minute to 24 hours.

Sound On New Alarm

•	 Activated: Enabling this option prompts MxControlCenter to play back an acoustic 
signal over the computer speakers (or the default output device) when an alarm is 
detected.

•	 Sound: Select either the standard system sound (the Beep radio button) or specify an 
audio file (*.wav) on the computer (the File radio button). MxControlCenter will play 
back this acoustic signal over the computer speakers (or the default output device) 
when an alarm is detected.

•	 Sound Deadtime: Enabling this option prevents further acoustic signals from being 
played back for this period of time after a sound for this alarm is emitted for the first time.

Repeat Sound

•	 Off / Every ... Sec.: Use this option to prompt MxControlCenter to repeat the selected 
acoustic signal at regular intervals according to the value entered in the sec. field 
until the alarm is acknowledged in the alarm list.

•	 ... Until Acknowledged by Clicking: Select one of the radio buttons (any alarm, 
last alarm or every alarm ) to specify which alarm image(s) need to be clicked to 
acknowledge and end the repetition of the acoustic signal.

•	 Repeat Sound for Max. ... Seconds without New Alarm: Use this option to set the 
maximum time during which MxControlCenter repeats the acoustic signal.

Example: When setting this option to twelve seconds and the sound repetition to 
three seconds, for example, MxControlCenter will repeat the sound every three 
seconds for a total of five times: once upon detecting the alarm and after that, 
every three seconds for the next twelve seconds.
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5.4	 The "Remote Control" Tab

Section 3.3, Alarm Processing described how a MOBOTIX camera can send network mes-
sages to MxControlCenter triggering certain alarm responses.

In addition to receiving network messages from a camera, MxControlCenter can also receive 
network messages from other programs. These programs can send defined commands 
as network messages, with which MxControlCenter can then be "remote controlled" to 
a certain extent. This allows you, for example, to change the current layout from another 
application while MxControlCenter is running or to switch a specific camera within the 
current layout into the full image view. Network messages can also play back audio files 
on the MxControlCenter computer or reactivate a minimized MxControlCenter.

The Remote Control tab includes three areas for setting the necessary parameters: 
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5.4.1	 General Remote Control And Camera IP Notify

This area allows you to configure MxControlCenter to receive any network messages. 
Network messages can be received both from other applications to control MxControlCenter 
remotely and from specific cameras for alarms.

Elements Of The "General Remote Control And Camera IP Notify" Area

•	 Port Activated (To Listen for TCP/IP Messages): Enabling this option prompts 
MxControlCenter to monitor the specified port for incoming network messages. The 
sender may use all available commands.

•	 Port: You must enter the port to be monitored by MxControlCenter for network mes-
sages here. If this field is empty, the remote control feature will not work.

•	 Allowed IPs: Enter the IP addresses of the cameras (or other network devices) that 
are allowed to send network messages to MxControlCenter. If the field is empty 
(or contains the entry *), MxControlCenter accepts network messages from every 
IP address. Therefore, for security reasons, you should always enter the relevant IP 
addresses immediately after completing the test or setup phase.

•	 Sound: Use this option to select whether an acoustic signal is played back over the 
computer speakers. When this option is activated and MxControlCenter detects a 
network message, the selected device plays back either the standard system sound 
(Beep) or a selected audio file (*.wav) on the computer (File).

Syntax Of Network Messages Sent To MxControlCenter

http://<IP MxCC Computer>:<Port>/?<Parameter 1>=<Value 1>&<Pa
rameter 2>=<Value 2>...&<Parameter n>=<Value n>

Examples:

http://192.168.1.182:8001/?fullscreen=1(minimizes MxControlCenter to 
the taskbar)

http://192.168.1.182:8001/?fullscreen=0(restores the MxControlCenter 
application window and displays it on top of other applications)

Note

The following link in the address bar of a browser prompts the MxControlCenter 
computer to generate a list of the supported parameters and their functions:

http://<IP MxCC Computer>:<Port>/?

Example: http://192.168.1.182:8001/?
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Caution

Make sure that in the General remote control and Camera IP Notify group you 
enter a Port, otherwise the remote control feature will not work.

If necessary, you can contact MOBOTIX support for more information on the supported 
remote control features.

5.4.2	 Camera IP Notify Only Port

In this area, you can set MxControlCenter so that only certain network messages are 
processed:

•	 Network messages from an MxCC Alarm: simple or an MxCC Alarm: acknowl-
edge required type of MOBOTIX camera

•	 Network messages from a MOBOTIX camera with the camnotify parameter 
(....?camnotify=<IP address>,  ....?camnotify=ownip)

These Messages Lead To The Following Actions:

•	 Activation of MxControlCenter, if it was minimized

•	 Entry of the corresponding images in the alarm list (see below)

•	 Loading of the preferred layout, if it was defined for the camera

Elements Of The "Camera IP Notify Only Port" Area

•	 Port Activated (To Listen for TCP/IP Messages): Enable this option to have MxControlCenter 
to monitor the specified port and the allowed IP addresses only for network messages 
containing the camnotify command.

•	 Port: Enter the port to be monitored by MxControlCenter for network messages.

•	 Allowed IPs: Enter the IP addresses of the cameras (or other network devices) that 
are allowed to send network messages to MxControlCenter. If the field is empty 
(or contains the entry *), MxControlCenter accepts network messages from every 
IP address. Therefore, for security reasons, you should always enter the relevant IP 
addresses immediately after completing the test or setup phase.

•	 Accept Valid Commands Only: If this option is enabled,MxControlCenter only 
processes a network message if it contains the command camnotify=ownip, 
camnotify=<IP address> or is sent by MxCC Alarm. If this option is disabled, 
MxControlCenter interprets every network message as a camnotify command, 
regardless of its content.
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Notes

•	 If remote control has been activated, ,MxControlCenter will automatically display 
the preferred alarm layout selected on the Camera tab (after confirmation) as 
soon as it receives a network message with the camnotify command from 
the corresponding MOBOTIX camera.

•	 Makes sure that you always use ports that are greater than 1023 and lower 
than 65535. Avoid the use of registered ports between 1024 and 49151. 
For more information, refer to the article on "TCP and UDP port numbers" at 
en.wikipedia.org.

Caution

Make sure that in the Camera IP Notify only port  group you enter a Port, otherwise 
the remote control feature will not work.

5.4.3	 Camera IP Notify Options

The following options are available for the processing of network messages with the 
camnotify command:

Elements Of The "Camera IP Notify Options" Area

•	 Capture Event Image: MxControlCenter captures the last alarm image (event image) 
from the MOBOTIX camera and adds it to the alarm list. If none of the three options 
are checked (Capture event image, Capture pre and post event images, Capture 
live image) the alarm image (event image) will be used and automatically added 
to the alarm list (default setting).

•	 Capture Pre and Post Event Images: MxControlCenter captures the first pre-alarm 
image and the first post-alarm image from the camera and adds them to the alarm list.

•	 Capture Live Image: MxControlCenter captures the current live images from a MOBOTIX 
camera and adds them to the alarm list.

•	 Automatic Replies to Sender for ... Sec.: Enable this option to have MxControlCenter 
send regular network messages (one every second for the specified time period) 
back to the IP address of the camera that sent the message.

This is a convenient option for MOBOTIX cameras that are linked via a dial-out ISDN 
connection, for example. After sending a network message to MxControlCenter, 
the MOBOTIX camera usually closes the ISDN connection it has established for this 
purpose. It would not be possible for MxControlCenter to contact the camera to 
retrieve the last camera alarm image after having received the network message. 
Therefore, activating this option ensures that the ISDN connection remains open for 
the duration of the specified time period.
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•	 Open Live Window: If this option is activated, MxControlCenter retrieves the current 
live image from a MOBOTIX camera and displays it in a new window.

Last Commands Received

This field lists the most recent network messages received by MxControlCenter. The list 
provides a mechanism for conveniently monitoring and analyzing the messages and for 
localizing the sources of errors.

5.5	 Camera Tabs

5.5.1	 Camera Access

•	 Camera User Name and Camera Password: Before MxControlCenter can access a 
MOBOTIX camera, you need to set up a user on the camera with the corresponding 
access rights (Admin Menu > Users and Passwords / Access Control Lists)). These 
fields allow you to enter the specified user name and password.

•	 Get Player Images: MxControlCenter can retrieve the stored images and video 
sequences either from the MOBOTIX camera itself (the Via camera radio button) 
or directly from the file server on which the camera has stored the images (the File 
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server path radio button). If the MOBOTIX cameras store their video data on the local 
computer, you can also enter the corresponding path here (Camera file server path).

When retrieving the images and video sequences from a file server, make sure that 
the shared folders have been properly configured (read rights for the computer and 
the user running MxControlCenter.

Caution

Make sure that the computer has access to the shared folders before MxControlCenter 
attempts to access the images and video sequences. MxControlCenter should 
not establish the connection itself. Note that MxControlCenter will not alert you 
if the connection fails for any reason.

5.5.2	 Layout And Display Options

•	 Instruction File: The file entered here (*.txt, *.html, etc.) appears with the con-
nected program and is displayed in a separate window by clicking the Activate the 
preferred layout of the selected camera button in the toolbar or the appropriate 
icon in the title bar of any display window.

•	 Preferred/Alarm Layout: The MxControlCenter layout in this list is automatically 
displayed whenever MxControlCenter receives a valid network message from the 
corresponding MOBOTIX camera and the camera remote control has been activated 
in MxControlCenter (the General remote control and Camera IP Notify group or 
Camera IP Notify only port group).

Note

The only requirement is that the camera is on the MxControlCenter camera 
list. It is not necessary that the camera is visible in the current MxControlCenter 
layout or included in the current layout at all. 

•	 Local Recorder Size: Every MOBOTIX camera in the current layout automatically 
writes the live images it sends to MxControlCenter to a local buffer on the computer. 
The buffer works like an automatic live image recorder and is called "local recorder" 
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in MxControlCenter. The buffer size (i.e., the size of the local recorder) can be preset 
in this list. As this feature is currently being redesigned, this setting has no effect.

•	 Sequencer Time: Enter an individual sequencer interval for the corresponding camera 
here. This interval has priority over a global sequencer time on the General tab. In 
Sequencer Mode, the camera image remains visible for the time interval entered 
here and cameras without an individual sequencer value are shown for the period 
specified in the global setting.

•	 Display Strategy: Use this option to change the latency time between the point at 
which the live image is captured by the MOBOTIX camera and the point at which it is 
displayed in the MxControlCenter. The Minimum delay option shows the live image 
stream from the cameras in MxControlCenter as quickly as possible. When using the 
Smooth display option, MxControlCenter. always places two live image frames from 
the MOBOTIX camera in a temporary buffer so that the live image stream displayed 
in MxControlCenter is as smooth as possible (this avoids jittering due to temporary 
increases in the network load).

•	 Use Better Rendering: MxControlCenter always scales the camera images as quickly 
as possible. Use this option if the computer's CPU has sufficient power to use opti-
mized algorithms for scaling and displaying the images (activated). Note that this 
option approximately doubles the CPU load.

This feature can also be automatically deactivated at high frame rates. If the only 
with low frame rates option is activated, the images will only be optimized at low 
frame rates. At high frame rates, this feature is automatically deactivated.
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5.5.3 PTZ/Rotor Control

If the MOBOTIX camera is installed on a pan/tilt head, the camera can be 
panned and tilted using the mouse or a joystick connected to the computer.

• Type: The following pan/tilt heads are supported in MxControlCenter:

• Videotronic SN-15AH

• Provitek

• Provitek PT 2

• Provitek PT 3

• VPT 42

• MxProtocol: This proprietary MOBOTIX protocol is used for controlling analog pan/
tilt cameras that are connected to a computer running MxServer.

• Sensitivity: Use the settings of this list to change the behavior and the speed of a 
pan/tilt head in relation to the movement with a mouse or a joystick. This option is 
available for the Videotronic, Provitek and VPT 42 pan/tilt heads.

The joystick model and the skills of each individual user have an infl uence on the 
ideal sensitivity. Therefore, we recommend conducting a fi eld test to determine the 
best setting.

• Invert X / y Direction: The displayed image, or even the camera, can be moved to 
the right by moving the joystick to the right, depending on the operator. Use these 
options to invert horizontal (X direction) and vertical (Y direction) movements. 

• Fast patch: Use this option to control the pan/tilt head faster and more precisely. 
This option is only available for the Videotronic, Provitek and VPT 42 pan/tilt heads.

Caution

The Fast patch  option requires a camera software version that has been 
modifi ed by a patch from MOBOTIX.

Do not activate the Fast patch unless this patch has been installed on the 
corresponding MOBOTIX camera. The MxControlCenter controls for a pan/tilt 
head do not work with the normal, unmodifi ed camera software if the Fast 
patch option has been activated. Additional information on this feature is avail-
able from our technical support team (www.mobotix.com under Support).
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•	 Save Changed Images Settings Permanently in Camera: If you change the cam-
era's settings for the live image views in MxControlCenter, this option allows you 
to automatically save these changes in the MOBOTIX camera (Save Always), or 
they are not automatically saved (Save Never). This applies above all to virtual PTZ 
features, which allow you to zoom in to the live image and to pan/tilt it. The third 
option (Ask User) displays a dialog box that asks you whether the changes should 
be permanently saved in the camera.
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A	 MOBOTIX Glossary
ActiveX

Control element on Windows computers which may also be used in other programs 
(including Windows Internet Explorer) to run special tasks. The MxPEG ActiveX control 
element allows video and audio data from MOBOTIX cameras to be displayed in other 
applications (including Internet Explorer).

Arming 
This refers to the process of activating an alarm system so that events trigger the appro-
priate alarms. Traditional alarm systems can be armed using a key switch or by entering 
a code on a keyboard. MOBOTIX cameras can be armed using a “software switch.”

Auto Grid 
Automatically generated grid used for displaying the live images from all cameras.

Bonjour 
(French for “hello”) is a technology developed by Apple based on the Zeroconf protocol, 
which is a method to automatically recognize network services on IP networks. For 
example, you can find a printer or a network camera on the local network without 
knowing the exact IP address of the device you are looking for.

CamIO 
MOBOTIX signal module that the camera uses to directly operate lamps, sirens and 
access controls, as well as external audio components (speakers and microphones).

CCTV 
Abbreviation for Closed-Circuit Television. A television system in which the analog video 
signal is transmitted to monitor within one particular environment only (for example, a 
building). The term CCTV is often used for video surveillance systems.

CF Card 
Abbreviation for Compact Flash Card. An ultra-compact, digital (random-access) 
memory medium based on flash memory modules and well-known as an image 
storage medium for digital cameras.

CIF, 2CIF, 4CIF (in accordance with PAL TV standard) 
Common Intermediate Format. Corresponds to 1/4 TV image with 288 rows and 352 
pixels (0.1 megapixel). 2CIF (1/2 TV image) has the same small number of rows (288), 
but 704 pixels (0.2 megapixel). 4CIF corresponds to the image quality of a traditional 
TV image with 576 rows and 704 pixels (0.4 megapixel).

CMOS Sensor 
Abbreviation for Complementary Metal-Oxide Semiconductor Sensor. Sensor for energy-
efficient digitalization of image information. CMOS sensors are used as image sensors 
in digital cameras.

DevKit 
Camera installation kit with independent image sensors based on MOBOTIX M12 or 
M22 cameras, intended for concealed installation in other devices.

mailto:sales@mobotix.com
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DHCP 
Abbreviation for Dynamic Host Configuration Protocol. Allows a server to automa-
tically assign devices in the network with the appropriate configuration (including 
the IP address, DNS server and gateway), as opposed to fixed IP addresses on the 
individual network devices.

DNS 
Abbreviation for Domain Name Service. Allows the domain names of servers on the 
Internet (e.g. www.mobotix.com) to be linked (“resolved”) to their corresponding IP 
addresses (e.g. 212.89.150.84).

Dome Camera 
Most often refers to cameras with a round and compact design. The lens can be freely 
positioned and is protected by a transparent dome-shaped plastic housing.

DSL 
Abbreviation for Digital Subscriber Line. Denotes a fast Internet connection capable of 
providing bandwidth of up to 16 Mbps for a typical household.

DualDome 
Dome camera with two lenses and image sensors such as the MOBOTIX D12D. These 
lenses can deliver wide-angle and telephoto images independently of one another.

DVR 
Abbreviation for Digital Video Recorder.

DynDNS 
Abbreviation for Dynamic DNS (or DDNS, Dynamic Domain Name Service). Similar to 
DNS, this links domain names (e.g. mydomain.com) with IP addresses, whereby the 
IP addresses may change at any time. This service provides a convenient method to 
access your MOBOTIX cameras from home or work if the camera internet connection 
is not through a router which assigns a fixed IP address, but instead over a DSL 
connection with a dynamically assigned IP address from the provider. A well-known 
provider of this (free) service is www.dyndns.org.

Ethernet
The most common technology for communication within a wired network. It facilitates 
data exchange between all devices (computers, printers, IP cameras, etc.) connected 
to a local area network (LAN).

Events 
An event refers to a situation when something happens or changes. In terms of video 
surveillance, this means a change in the status of an area that is being monitored. This 
can be movement of a person, a change in brightness, a drop in ambient temperature, 
the detection of a noise via a microphone, an electrical signal at a signal input, the 
manual operation of a button, etc.
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ExtIO 
MOBOTIX signal module that the camera uses to directly operate lamps, sirens and 
door openers as well as external audio components (speakers and microphones).

Fixdome 
Camera without moving parts in a dome-shaped housing.

Flash Memory 
See CF Card.

fps 
Abbreviation for frames per second. See Frame Rate.

Frame Rate 
The frame rate specifies how many frames per second (fps) are generated and sent 
by the camera. The human eye perceives movement as a fluid video sequence when 
more than 12 images per second are produced.

HDTV 
Abbreviation for High Definition TV.

HiRes 
Abbreviation for High Resolution. Refers to high-resolution images (above 1 megapixel).

Image Compression 
Image compression reduces the file size of an image. This is particularly important 
when transferring and saving files.

Image Processing 
Digital image processing. The goal is to correct errors made during image generation 
(caused by overexposure, underexposure, blurring, weak contrast, image noise, etc.) 
in order to create a “better” image.

IP Network 
Data network based on the Internet protocol (TCP/IP).

IP Telephone 
See VoIP.

JPEG
Abbreviation for Joint Photographic Experts Group, responsible for the development 
of the JPEG standard method for image compression. JPEG is the most common lossy 
image format for photos on the Internet. Loss in image quality is barely noticeable at 
compression rates between 99% and 60%.

Latency 
Time interval elapsed between when an image is captured by a camera and when 
that same image is displayed on the monitor.

mailto:sales@mobotix.com
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Layout 
Describes the layout of video sources on a screen site of the MxControlCenter. When 
displaying the images from network cameras, the layout determines the positions and 
resolutions of the images displayed on the monitor. In addition to the actual video images, 
you can also incorporate graphic elements such as the location of the cameras, etc.

LED 
Abbreviation for Light Emitting Diode. An electronic semiconductor component, built 
in to MOBOTIX cameras and add-on modules, which emits light when current flows 
through the component in the correct direction.

Linux 
Free and open source operating system; serves as the operating system for all MOBOTIX 
cameras.

Megapixel 
Images that are 1 million pixels. Larger formats of images can be displayed as a 
multiple of this, for example, 3 Megapixel is equal to 3 million pixels.

MonoDome 
Dome camera with one lens.

Motion Detection 
Action of sensing a movement within a particular area. MOBOTIX cameras use algo-
rithmic methods to detect changes from image to image in predefined areas, while 
taking into account preset conditions. If a camera detects a movement, it signals an 
event and triggers an alarm.

Motion JPEG, or M-JPEG, 
is a video compression method where each individual image is compressed separately 
as a JPEG image. Unlike MPEG, the quality of M-JPEG recordings is not dependent on 
movement within the image.

MPEG 
Motion Pictures Expert Group. Standard for compressing and saving image and video 
data, resulting in quality loss. Originally created for playing entertainment content on 
PCs, MPEG concentrates on displaying still image material and compromises the quality 
of moving image material in order to increase the transmission speed.

MxControlCenter
MOBOTIX video management software for professional control of mid-sized and large 
camera networks.

MxEasy
MOBOTIX video management software for small and compact camera networks of 
up to 16 cameras.

MxPEG
MOBOTIX-developed protocol for compression and storage of image and video data 
with minimal network load and high image quality. The MxPEG ActiveX control com-
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ponent allows video and audio data from MOBOTIX cameras to be displayed in other 
applications (including Internet Explorer). To date, MxPEG remains the ONLY protocol 
specifically designed for security applications

NAS 
Abbreviation for Network Attached Storage. A storage system connected via an Ethernet 
cable. All network devices (cameras) have access to this storage system.

Network 
Group of computers that are connected via various cables and share access to data 
and devices such as printers and network cameras.

PIR 
Passive Infrared Sensor for motion detection.

PoE 
Power over Ethernet. A technology for supplying network-ready devices (such as net-
work cameras) with power via the Ethernet data cable.

PTZ 
Abbreviation for Pan/Tilt/Zoom. Refers to the movement of a video camera to the left 
and right, up and down, and to the camera’s ability to enlarge an image.

Quad Display 
Layout in which the images from four cameras are displayed in one window.

Resolution
Indicates the number of pixels used to produce an image. The more pixels an image 
has, the greater the detail when the image is enlarged. The resolution is expressed as 
either the number of pixel columns times pixel rows, or as a total number of pixels. A 
VGA image has 640 columns and 480 rows (640 x 480 pixels), which equals 307,200 
pixels, or approximately 0.3 megapixel.

RoHS 
This abbreviation stands for the Restriction of Hazardous Substances Directive and 
refers to EC Directive 2002/95/EC, which prohibits the use of certain hazardous sub-
stances when manufacturing products and components. The goal of this directive is 
to prevent these substances from harming the environment when the products are 
disposed of later.

Router 
Network device that connects multiple networks with one another. The router creates 
the physical connection between the devices in different networks (like a hub), ana-
lyzes the relevant data packets and forwards („routes“) these packets to the correct 
target network.

SD Card / MicroSD card 
SD Memory Card (Secure Digital Memory Card). A digital storage medium based on 
flash storage modules such as USB sticks.
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Search 
Monitoring of recordings, searching for a particular event.

Sequencer 
Feature that automatically switches the camera displayed in the main window after 
a specific time delay.

SIP 
Session Initiation Protocol. Network protocol for setting up, controlling and termina-
ting a communication connection via a computer network. SIP is frequently used in 
conjunction with IP telephony.

Signal Input/Signal Output 
Coupling an alarm triggering device (for example a fire alarm system or a network 
camera) to a control center or another type of transmitter (for example, a telephone 
or IP network). A typical signal input/output scenario in video surveillance progresses 
as follows: an event triggers an alarm that then displays, for example the video image 
from the network camera that triggered the alarm on the monitor at a control center.

Snapshot 
Photograph of a situation created spontaneously and directly with a mouse click or 
other such event directed by the user.

Switch 
Hardware used to connect multiple network devices (computers, cameras, printers, 
etc.) within a network. A PoE switch can also supply the cameras with power over 
an Ethernet cable.

UPS 
Uninterruptible Power Supply. Refers to devices that continue to supply power in the 
event of a sudden power failure. These devices usually operate using a battery. UPS 
is installed on the power lines of devices and systems in order to protect them in the 
event of a power failure.

VoIP 
Voice over Internet Protocol. Telephony using computer networks.

Wizard
Refers to a software component that helps the user install or set up a particular 
program and that guides the user through the configuration process by means of 
simple questions.

WLAN 
Wireless Local Area Network. Used to provide Internet connections without the need 
for cables.
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Access Levels
MxControlCenter  95

Acknowledge
Alarm  38

Activating
Alarm List  35
Image Post-Processing  100
Integrated PTZ Units  102
Pan/Tilt Heads  102

Adding
Video Sources (manually)  18

Alarm
Acknowledge  38
Display  37

Alarm list
MxControlCenter  85

Alarm List
Activating  35
Dialog Box „Options“  130
MxControlCenter  23

Alarm management  34

Alarm Processing  83

Analog Cameras
Connecting Third-Party  101
MxServer  106
Using in MxServer  106

Assembly
Pan/Tilt Head  103

Auto grid. See Auto grid

B

Background Layouts  78

C

Camera
Dialog Box „Options“  136

Camera configuration
Dialog Box  24

Camera Configuration
Dialog Box  111
The „Exposure“ Tab  116
The „Image Settings“ Tab  114
The „Overview“ Tab  113
The „Recording“ Tab  117

Camera Configurations
Editing  53
Managing  53
Saving  122

Camera Connection
Monitoring  29

Camera IP Notify
Options  135

Cameras
Preparing  36

Cameras (third-party)
Integrating  48

Configuring
Image Post-Processing  100
MOBOTIX Cameras  111
MxControlCenter  51
Video Sources  14

Connection
Monitoring  29

Continuous Recording  39

Control Center
Features  48

Correct Distortion
Video images  34

Creating
Layout  30
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Data Export  44

Deactivating
Image Post-Processing  100

Defining
Instruction File  82
Player Window  41
Preferred Layout  83
Reference Image  83
Start Layout  82

Dialog box
Camera configuration  24
Update Assistant  25
Video Searches  39

Dialog Box
Camera Configuration  111

Digitizer  107

Display
Alarm  37

Displaying
Stored Alarms  86

Display windows
Player Mode  39

E

Editing
Layouts  72
Layouts, Additional Options  82

Event Recording  39

Examples
Application examples  8
Remote control with network messa-

ges  92

Export Features  39, 88

Export List  44

Exposure
„Camera Configuration“ Dialog Box  116

F

Features
Control Center  48

Finding
MOBOTIX Cameras  15
Video Sources  14

Folders
Global  94
Local  94

Frame grabber  107

G

General
Dialog Box „Options“  124

Global Folders  94

Grid Layouts  72

I

Image
Distortion correction  47
Post-processing  47
Recording  39

Image Post-Processing
Activating  100
Configuring  100
Deactivating  100
Overview  99

Image Settings
„Camera Configuration“ Dialog Box  114

Importing
Camera Configurations  122

Installation
MxControlCenter  13

Instruction File
Defining  82

IP Cameras
Connecting Third-Party  101
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Layout Manager
MxControlCenter  22

Layouts  27
Additional Options for Editing  82
Background  78
Creating  30
Editing  72
Grid  72
The Sidebar Panel  60

Local Folders  94

M

Management features. See Control 
center

Managing
Camera Configurations  53
MxControlCenter Configurations  52

MOBOTIX Cameras
Configuring  111
Define Soft Keys  104
Finding  15
Preparing  36
Supported Pan/Tilt Heads  102
Updating Software  120
Using in MxControlCenter  18

Monitoring
Camera Connection  29
Connection  29
Numerous Cameras  27

MxControlCenter
About network messages remotely  91
Access Levels  95
Activating Password Protection  96
Alarm list  85
Alarm List  23
Concept  7
Configuring  51
Customizing User Interface  51
Elements of the main window  20
Installation  13

Integrating Video Sources  18
Layout Manager  22
Managing Configurations  52
Options  123
Prepare alarm  34
Program settings  26, 51
Program Settings  123
Security Considerations  97
Security Settings  97
Settings  26
Toolbar  57
User Interface  20

MxServer  106
Prerequisites  107

N

Network Security  97

O

Options
Camera IP Notify  135
<Camera Tabs>  136
Dialog Box  123
Modifying, Saving, Loading  51
MxControlCenter  26, 123
The „Alarm List“ Tab  130
The „General“ Tab  124
The „Remote Control“ Tab  132

Overview
„Camera Configuration“ Dialog Box  113

P

Pan/Tilt Head
Assembly  103

Pan/Tilt Heads
Activating  102
Controlling  50
Supported by MOBOTIX  102
Third-Party Cameras  101
Using  102
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Password Protection
MxControlCenter  96

Passwords  95

Player
The Sidebar Panel  61

Player Mode  39

Player Window
Defining  41

Port
Camera IP Notify  132, 134

Post-Processing  99

Preferred Layout
Defining  83

Prepare alarm
MxControlCenter  34

Preparing
Cameras  36
MOBOTIX-Cameras  36

Program Settings
MxControlCenter  26, 51, 123
Saving in MxControlCenter  94

Protecting Cameras  97

PTZ Cameras
Controlling  50

PTZ Controls
The Sidebar Panel  64
Third-Party Cameras  101

PTZ Units
Activating  102

R

Recording
„Camera Configuration“ Dialog Box  117

Reference Image
Defining  83

Remote Control
Dialog Box „Options“  132
Example  92

MxControlCenter with Network 
Messages  91

Restricting Access on Cameras  97

S

Saving
Camera Configurations  122
Configuration of MxControlCenter  94

Security
MxControlCenter  97
Network Security  97
Restricting Public Access on Cameras  97

Sequencer
Using  31

Sidebar Panel
The „Layouts“  60
The „Player“  61
The „PTZ Controls“  64

Soft Keys
Defining On MOBOTIX Cameras  104

Software Update
MOBOTIX Cameras  120
Perform Update  121
Preparing MOBOTIX Cameras  120

Start Layout
Defining  82

Stored Alarms
Displaying  86

Switching Display Windows in Player 
Mode  39

T

Tab
Alarm List (Options)  130
Camera  136
Exposure  116
General (Options)  124
Image Settings  114
Overview  113
Recording  117
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Remote Control (Options)  132

Third-Party Cameras
Pan/Tilt Heads  101
PTZ Controls  101

Toolbar
MxControlCenter  57

U

Update Assistant
Dialog box  25

Updating
MOBOTIX Camera Software  120

User Interface
Customizing by MxControlCenter  51
MxControlCenter  20

Users  95

Using
MOBOTIX-Cameras in 

MxControlCenter  18
MOBOTIX Cameras with Pan/Tilt 

Heads  102
Pan/Tilt Heads  50
PTZ Cameras  50
Sequencer Features  31
Video Search  43
Video Sources in MxControlCenter  18
vPTZ Features  32

V

Video Images
Correct distortion  34

Video Processing  47

Video Search
Dialog box  39
Using  43

Video Searches  88

Video Sources
Adding Manually  18
Configuring  14
Finding  14

Integrating in MxControlCenter  18
Using in MxControlCenter  18

Virtual PTZ Features
Using  32

vPTZ Features. See Virtual PTZ features
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MOBOTIX - The HiRes Video Company

To demonstrate our con� dence in the quality of our products, 
MOBOTIX cameras were used to capture all the images that 

appear in this manual.

Manufacturer Executive Board

MOBOTIX AG Dr. Ralf Hinkel

Kaiserstrasse

67722 Langmeil, Germany Registration O�  ce: Kaiserslautern Local Court

Germany Registration Number: HRB 3724

Tel: +49 6302 9816-0 Tax Code: 19/650/0812/1

Fax: +49 6302 9816-190 Tax O�  ce: Kaiserslautern, Germany

http://www.mobotix.com VAT ID:

sales@mobotix.com DE202203501

You can � nd the latest version of this document at www.mobotix.com under Support.

Technical speci� cations subject to change without notice!
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The HiRes Video Company

EN MxCC 2.0: Manual

HiRes  

3 Megapixel
2048 x 1536

Software zoom

Skyline

Format free
Each image format

freely definable

30 Frames/s
VGA (640 x 480)

30 F/s Mega

Virtual PTZ
Digital pan, tilt,

zoom

Backlight
Safe using CMOS

 without mechanical iris

Internal DVR
Internal via SD card, 
external via Network 

Win/Lin/Mac  

Recording
via Network on PC 

up to 1 Terabyte

Microphone & speaker

Audio
bi-directional via IP,
variable framerates

SIP-Client with video 

IP Telephony
Alarm notify,

cam remote control 

VideoMotion
Multiple windows

precision pixel-based

 

-22°F ... +140°F

Weatherproof
- 30° ... +60°C, IP65,

no heating necessary

 IEEE 802.3af  

PoE
Network power
even in winter 

Robust
No moving parts

fiber glass housing

MxCC/MxEasy

Licence free
Video-Management-

Software 

EN
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HiRes Video Innovations

The German company MOBOTIX AG is known as the leading pioneer in network camera technology and its 

decentralized concept has made high-resolution video systems cost effi  cient.

MOBOTIX AG  •  D-67722 Langmeil • Tel: +49-6302-9816-103 • Fax: +49-6302-9816-190 •  sales@mobotix.com 

Professionelles IP Video-Management

Free software download: www.mobotix.de > Support > Software-Downloads
Current PDF File: www.mobotix.de > Support > ManualsV 
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