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Introduction 

The present document includes both PRIMORIS – Reviewer’s Paper Assignment

In the User Manual you will find a step by step guide about how to execute one main task which is 
the papers assignment to reviewers. 

 User and Reference 
Manuals. 

 

The User Manual is intended to guide you in a step by step tour along the main functionalities 
normally used to accomplish these two tasks quickly and easily. 

In the Reference Manual you will find a detailed description of each page and functionality provided 
by PRIMORIS. 

The Reference Manual is primary intended to allow the Chair to check if some required functionality 
is available, where it may be found and how to use the provided functionality to achieve the task. 

 

 

INSTICC hope you will find these manuals useful to help you with your task, nevertheless, we would 
very much appreciate if you could send us your feedback about these manuals and about the 
PRIMORIS web system itself directly to secretariat@insticc.org so that we can consider them in 
future updates and revisions. 

mailto:secretariat@insticc.org�
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Conventions and Notation 

Notice that, throughout all these manuals, some described functionalities, buttons or tabs may not 
be available depending on the phase you are dealing with. 

Chapters of both manuals as well as figures along both manuals are enumerated sequentially along 
one single list, in order to simplify your browsing and referencing. 

NOTE: The following sections are intended to help you reading 
the manuals in a clear and straightforward way. You do not 

need to read them in order to achieve your tasks but they may 
help you browsing the manuals. 

In The User Manual 

Main tasks, the ones that may require several steps in order to be achieved, are numbered as shown 
in Figure 1. 

1 Example of Main Task enumeration 

Figure 1 

Sub tasks are numbered as shown in Figure 2 and makes sense only inside the Main Task. 

1.1 Example of Sub task enumeration 

Figure 2 

All steps required to achieve all the tasks are sequentially numbered in one single numbered list 
throughout all the User Manual and aligned left, as shown in Figure 3, so that your eyes may follow it 
without bothering with ‘NOTE’s and explanations. 

1 First step 
2. Second step 
3. Third Step. 

Figure 3 

Explanations are right aligned and marked as a ‘NOTE’ as shown in Figure 4 so that you may disregard 
them if you just want to follow the steps.  

NOTE: This is an explanation about where you are or what are 
you doing. 

Figure 4 

Relevant Explanations that should be clearly noticed are left aligned and marked as a ‘RELEVANT 
NOTE’ as shown in Figure 5 so that you see them even if you just want to follow the steps.  



9 | P a g e  
 

RELEVANT NOTE: This is a relevant note about the 
steps that should be executed. 

Figure 5 

In The Reference Manual 

The content of PRIMORIS Main pages, those that aggregate several functionalities are enumerated as 
shown in Figure 1. 

The content of secondary pages, tabs and separators are numbered as shown in Figure 2. 

Explanations are right aligned and marked as ‘NOTE’, as shown in Figure 4 so that you may disregard 
them if you just want to find some relevant topic or keyword. 

Relevant Explanations that should be clearly noticed are left aligned and marked as a ‘RELEVANT 
NOTE’ as shown in Figure 5. 
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User Manual 
 

In this User Manual you will find a step by step guidance on how to execute the reviewer’s paper 
assignment procedure. 
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1 Start Window  

1. Double click the shortcut to Reviewer’s Paper Assignment
Figure 1.1

 in your desktop and you will 
view a window ( ). 

 

Figure 1.1 PRIMORIS – RPA Welcome window. 
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2 Online Work Mode 

2.1 Logging in 

1. Type your username and password using the ‘Work Online’ frame. 
2. Press the ‘Login’ button to validate your credentials and go to your private area (Figure 

2.3). 

 

Figure 2.1 PRIMORIS – RPA

If the username or password are incorrect, an error message box will be shown (

 Welcome window. 

Figure 2.2). 
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Figure 2.2 Login Information – Invalid user or Password. 

 

2.2 Load Event 

After a successfully login you can access your user roles.  

 

Figure 2.3 Online Mode – Roles. 
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When selecting one of the available roles it will be shown in the event dropdown list the related and 
available events for the selected role. 

 

Figure 2.4 Online Mode – Roles & Events. 

After selecting the role and the desired event you can press the ‘Load Event’ button. 

NOTE: You will be asked to save the selected event. 

In case of future work with this event you won’t need to 
download it again. 
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Figure 2.5 Online Mode – Save Information. 
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3 Offline Work Mode 

3.1 Choose Event 

Press the ‘Choose File’ button to choose an event file in your computer. 
 

 

Figure 3.1 Offline Mode – Start Window. 

After pressing ‘Choose File’ button you will be asked to ‘Open’ the file. 

NOTE: You can only choose Zipped files (*.zip) 
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Figure 3.2 Offline Mode – Choose File. 

After choosing the file, a message in red will be presented (Figure 3.3), related to the 
selected file. This appears so that you might choose another file in case selecting a wrong 
one. 

 

 

Figure 3.3 Offline Mode – Chosen File. 

3.2 Load Event 

To load an event press the ‘Load Event’ button (Figure 3.4). And you will be redirected to the 
Automatic Distribution window. 
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Figure 3.4 Offline Mode – Load Event. 
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4 Automatic Distribution 

This window is divided in three different areas:  

• Automatic Papers Assignment – where you can read information about the working 
event and adjust the parameters to a new Automatic Distribution; 

• Exclusively Automatic Distribution – where you can start a new Automatic 
Distribution and proceed to Manual Reviews Distribution; 

• Ignore Automatic Distribution and do Manual Distribution – where you can proceed 
to Manual Distribution without taking into consideration the Automatic Distribution 
and its parameters. 

In this window you can adjust the parameters to start a new automatic distribution (see section 10). 

 

Figure 4.1 Distribution Window. 
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4.1 Do the Automatic Distribution 

To start a new automatic distribution you can press the ‘Start Distribution’ button. 

 

Figure 4.2 Distribution Window – Start Distribution. 

After the distribution is done the ‘Manual Reviews Distribution’ will be available as well as the 
information results of the distribution. 

 

Figure 4.3 Distribution Window – Distribution Information. 



21 | P a g e  
 

4.2 Do the Manual Distribution after the Automatic Distribution 

If you are satisfied with the results obtained from the automatic distribution you can press the 
‘Manual Reviews Distribution’ button (Figure 4.4) to proceed to manual distribution (Figure 4.5). 

NOTE: If you are not satisfied with the results obtained from 
the automatic distribution you can adjust the parameters and 

run the automatic distribution once again by press ‘Start 
Distribution’ button. 

 

Figure 4.4 Distribution Window – Start Manual Distribution. 
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Figure 4.5 Manual Distribution – Start Window. 

4.3 Do Manual Distribution without Automatic Distribution 

If you are not satisfied with the results obtained from the automatic distribution or haven’t made 
one, you can press the ‘Exclusively Manual Distribution’, better as in Figure 4.6. 

NOTE: Pressing ‘Exclusively Manual Distribution’ button will 
disregard any automatic distribution done, and all the 

assignments must be done by hand. 
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Figure 4.6 Distribution Window – Exclusively Manual Distribution. 

Pressing the ‘Exclusively Manual Distribution’ button will lead you to Manual Distribution window 
(Figure 4.7). 

 

Figure 4.7 Manual Distribution – Start Window. 
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5 Manual Distribution 

5.1 Assign a Paper Manually 

To manually assign a paper to a reviewer you must press the intersection checkbox (Figure 5.1). 
When a paper is assigned to a reviewer the checkbox will be validated and its color will change 
according to the specification of the assignment, this is, whether it’s been done manually or 
automatically. The respective counters will be incremented. 

NOTE: The assignment of a reviewer to a paper, works in the 
same way. 

 

Figure 5.1 Manual Distribution – Paper Assignment 

When you make an assignment and the maximum number of reviews defined by the reviewer is 
reached, you will get a message asking you to confirm the assignment (Figure 5.2). Pressing ‘Yes’, will 
be assign the paper, otherwise the paper won’t be assigned. 

 

Figure 5.2 Automatic Distribution – Maximum Assignments Reached. 
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5.2 Unassign a Paper Manually 

If you wish to unassign a paper to a reviewer you must, again, press the intersection checkbox. The 
color will change and the respective counters will decrement. 

5.3 Filters 

You can apply filters to the assignments grid. These filters are applied to papers and/or reviewers. 

It is possible to filter papers from zero to more than four reviews, by areas or topics and by match 
percentage. Reviewers can be filtered by no reviews, with reviews or maximum reviews reached. 

 

Figure 5.3 Paper and Reviewer Filters 

 

 

 

 

 

5.3.1 Reviewer Filters 

In this example we will filter the assignment grid by reviewers. 
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Figure 5.4 Manual Distribution – General Board. 

We will select the ‘With Assigned Reviews’ checkbox (Figure 5.5). 

 

Figure 5.5 Manual Distribution – With Reviews 

Note that the assignment grid will be refreshed and will only show reviewers with at least one 
assigned paper (Figure 5.6). 
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Figure 5.6 Manual Distribution – Filter Applied 

5.3.2 Paper Filters 

In this example we will filter the assignment grid by papers. 

 

Figure 5.7 Manual Distribution – Topic Selection 

 

We will select the topic ‘Visual Data Analysis and Knowledge Discovery’ checkbox  (Figure 5.8). 
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Figure 5.8 Manual Distribution – Topic Selected 

 

 

 

Note that the assignment grid will be refreshed (Figure 5.9), and will only show papers filtered by 
the ‘Visual Data Analysis and Knowledge Discovery’ topic. 

NOTE: Different events will have different topics or areas. 

 

 

Figure 5.9 Manual Distribution – Filter Applied 
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5.3.2.1 Match Paper Filter 

In this example we will filter the assignment grid by the related match between papers and 
reviewers. 

 

Figure 5.10 Manual Distribution – Define Match 

First, we must select a paper, and in this case we have selected the paper number 24. Once selected 
we will use the 55 % match to reduce our information at the grid. With this option we will get only 
the reviewers whose topics match by at least of the paper’s topics 55 % of match (Figure 5.11). 

 

Figure 5.11 Manual Distribution – Match Applied 
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5.3.2.2 Match Reviewer Filter 

In this example we will filter the assignment grid by the related match between papers and 
reviewers. 

 

Figure 5.12 Manual Distribution – Define Match 

First, we must select a reviewer, and in this case we have selected the reviewer Adrian Rusu. Once 
selected we will use the 30 % match to reduce our information at the grid. With this option we will 
get only the papers whose topics match by at least of the reviewer’s topics 30 % of match (Figure 
5.13). 

 

Figure 5.13 Manual Distribution Match Applied 

5.4 Paper & Reviewer Information 

Everything in the Manual Distribution window is supported by the use of tooltips so that you can 
have as much information as possible. 

5.4.1 Details 

If you want information about a specific reviewer or paper, press the respectably row / column and 
the paper information frame or reviewer information frame will be updated. 
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By selecting a paper you will be able to access information such, Number, Title, Keywords, Authors, 
Topics, Abstract and Top 5 Reviewer Match Suggestion. 

By selecting a reviewer you will be able to access information such as, Name, Country, Email, Areas, 
Topics, Top 5 Paper Match Suggestion. 

 

Figure 5.14 Manual Distribution – Paper and Reviewer Information 

 

 

 

 

 

5.4.2 Tooltips 

On mouse-over on a reviewer you will see a tooltip showing information such as Name, Areas, 
Topics and Country (Figure 5.15). 
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Figure 5.15 Manual Distribution – Reviewer Tooltip 

If you place the mouse over the ‘#R’ column you will get a tooltip with the current reviewers for the 
related paper (Figure 5.16). 

NOTE: Current reviewers for a paper are related to an 
assignment. Assignments can result from a previous 

distribution, by an automatic distribution or even by hand 
distribution. 

 

Figure 5.16 Manual Distribution – Paper Information 
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On mouse-over on a paper you will see a tooltip showing information such as Title, Authors, Topics 
and Country (Figure 5.17). 

 

Figure 5.17 Manual Distribution – Paper Tooltip 

 

5.5 Windows Dock & Float 

It is possible to arrange the layout as you want. All frames will enter the floating mode if you double-
click them at the title bar. It is possible then to resize them, hide them, but won’t be able to close 
them (Figure 5.18). 



34 | P a g e  
 

 

Figure 5.18 Manual Distribution – Floating Windows 

To auto rearrange the layout at the default position, you can press the ‘Redock All’ button (Figure 
5.19) located at the bottom of the main window. All frames will then be rearranged to its default 
position (Figure 5.20). 

 

Figure 5.19 Manual Distribution – Redock All 
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Figure 5.20 Manual Distribution - Redocked 
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5.6 Automatic Redistribution 

Whether you got to the Manual Distribution window by the use of an Automatic Distribution or 
exclusively by Manual Distribution you will be able to make an Automatic Redistribution. 

Automatic Redistribution is accessible through the ‘Redistribute – Automatic Redistribution’ menu 
(Figure 5.21). 

NOTE: The Automatic Redistribution option will keep 
previously assignments. 

 

Figure 5.21 Manual Distribution – Automatic Redistribution 

When pressing Automatic Redistribution you will get a window (Figure 5.22). 

 

Figure 5.22 Automatic Redistribution 
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To start a new automatic redistribution press the ‘Start Distribution’ button and set the necessary 
parameters at the left side of the window (Reviews Number, Minimal Match, Extra Reviews, Paper 
Type) (Figure 5.23). 

 

Figure 5.23 Automatic Redistribution – Start Distribution 

 

The system will then provide you with the distribution results (Figure 5.24). 

 

Figure 5.24 Automatic Redistribution – Distribution Results 

If you are satisfied with the presented results you can press the ‘Manual Reviews Distribution’ 
button. Otherwise, you can simply close the window and you will return to the Manual Distribution 
window (Figure 5.26). 



38 | P a g e  
 

 

Figure 5.25 Automatic Redistribution – Manual Reviews Distribution 

 

Figure 5.26 Automatic Redistribution – Manual Distribution 
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5.7 Paper Search 

At the Manual Distribution window you are able to search for papers. The ‘Search’ paper button will 
search for papers which have Title or Topics related to the input content, similar to the one in Figure 
5.27. 

 

Figure 5.27 Manual Distribution – Search Paper 

Has you can notice on Figure 5.28, the assignments grid was updated with the above search. 

 

Figure 5.28 Manual Distribution – Search Paper Result 
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To clear the search previously made, you must press the ‘Clear’ button. The assignments grid will be 
updated. 

 

Figure 5.29 Manual Distribution – Clear Search Paper 

 

 

 

 

 

 

 

 

 

 

 

5.8 Reviewer Search 

At the Manual Distribution window you are able to search for reviewers. The ‘Search’ paper button 
will search for reviewers which have Name or Topics related to the input content (Figure 5.30). 
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Figure 5.30 Manual Distribution – Reviewer Search 

To clear the search previously made, you must press the ‘Clear’ button. The assignments grid will be 
updated. 

 

Figure 5.31 Manual Distribution – Clear Reviewer Search 

5.9 Notifications 

By activating the ‘Notifications’ checkbox you will enable desktop alerts. Desktop alerts will help 
you on getting more information about what you see. 
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Figure 5.32 Manual Distribution – Notifications 

When the notifications are enabled, and if you select the papers ‘#R’ column you will get a desktop 
alert (Figure 5.33). 

 

Figure 5.33 Manual Distribution – Notification Current Reviewers 

If you click on a paper you will get the Top 5 Reviewer Suggestion desktop alert (Figure 5.34). 
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Figure 5.34 Manual Distribution – Notifications – Top5 Reviewer Suggestion 

If you click on a reviewer you will get the Top 5 Reviewer Suggestion and Current Papers desktop 
alerts (Figure 5.35). 
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Figure 5.35 Manual Distribution – Notifications – Reviewer 

5.10 Menu Notifications 

If you want information about Notifications you must press the Help menu and select Notifications 
(Figure 5.36). You will then get an information message (Figure 5.37). 
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Figure 5.36 Manual Distribution – Help Notifications 

 

Figure 5.37 Manual Distribution –  Notifications 

5.11 Menu Color Information 

The ‘Help -> Color Information’ menu allows you to change table colors. 
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Figure 5.38 Color Information menu 

 

Figure 5.39 Color Information menu 

This window has all the information about the different colors used on the table, and allows you to 
change any color. To do so, you must click on the dropdown list near the color and select the new 
color. 

For more information you can see the Reference Manual where this option is detailed (Figure 11.4). 
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Figure 5.40 Table Color Changes 

 

Figure 5.41 Color Changes Successfully Applied 
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5.12 Menu Assignment 

 

Figure 5.42 Assignment Validation menu 

The ‘Validation -> Assignment’ menu redirects you to Assignment Validation window (Figure 6.1). 
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6 Assignment Validation 

In this window you can validate paper assignments. 

 

Figure 6.1 Assignment Validation window 

6.1 Temporary All 

 

Figure 6.2 Temporary All option 
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You can use this option if you wish to validate all assignments ‘Temporarily’. You may save your work 
(see section 6.3) and then re-use later (see section 3.2) to validate an assignment or unassign it. 
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6.2 Validate All 

 

To validate all the assignments made in the Manual Distribution window you must press the 
‘Validate All’ checkbox. 

 

Figure 6.3 Validate All option 
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6.3 Save Current Work 

 

Figure 6.4 Save Current Work menu 

After you choose ‘File -> Save Current Work’ menu, a save file dialog will show and allow you to save 
your work. 

 

Figure 6.5 Save File Dialog 
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Figure 6.6 Directory save file information 

Once your work is saved, the system will shows a message window with the directory where the 
work was saved. 

6.4 Return to Manual Distribution 

 

Figure 6.7 Return to Manual Distribution menu 

If you choose ‘File -> Return to Manual Distribution’ menu, it will redirects you to Manual 
Distribution window (Figure 4.7). 
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6.5 Export to Database 

This menu allows you to export your assignments to PRIMORIS database. 

 

Figure 6.8 Export menu 

After you choose ‘Export to Database -> Export’ menu, it will show you an authentication form. As a 
safety mechanism, authentication is required to export your work to the database. 

 

Figure 6.9 Authentication form 

In this form you can type your username and password to login in application.  

NOTE: If you login at the beginning of the application, you 
won’t need to do it again. In this case the ‘Login’ button is 

disabled and the ‘Submit File’ button is enabled. 
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Figure 6.10 Successfully Login and Submit File option enabled 

After a successfully login, the ‘Login ’is disabled and the ‘Submit File’ button is enabled. Then you can 
submit your work.  

 

Figure 6.11 Information message to save your work 

NOTE: Before submit your work it is required to you save your 
work to your personal computer in case that you want to 

submit it later. 
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6.6 Save Assignments for later Submission 

This menu allows you to save your work for a later submission. It will only save the validated 
assignments, ready to be exported to the database (see section 2.3). 

 

Figure 6.12 Save Assignments for later Submission menu 
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After choosing ‘Submit -> Save Assignments for later Submission’ menu, it will show a save file 
dialog allowing you to save your work. 

 

Figure 6.13 Save File Dialog 

 

Once your work is saved, a window will show with the directory information about where your work 
has been saved to. 

 

Figure 6.14 Directory save file information 
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Reference Manual 
 

In this Reference Manual a description of every active item such as buttons, menus, or filters on each 
Primoris – Reviewer’s Paper Assignment

 

 page is given in order to allow the Chair to check if some 
required functionality is available, where it may be found and how to use the provided functionality 
to achieve the task. 
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7 Start Window  

 

Figure 7.1 PRIMORIS - RPA

This window represents the welcome window of the 

 Welcome window. 

Reviewer’s Papers Assignments

In the frame ‘Work Offline’ there are two elements: 

, which is 
divided by two frames: Work Offline and Work Online. 

1. The ‘Choose File’ button: allows the user to choose a file with information about an 
event from his personal computer. 

2. The ‘Load Event’ button: allows the user to load the information in the selected event. 
Note: this button is enabled after the event chooses. 

In the frame ‘Work Online’ there are two elements: 

1. The ‘Username’ and ‘Password’ boxes: the user fills them with their credentials to login 
into the system. 

2. The ‘Login’ button: used to verify the user’s credentials and access to the online work 
mode. 
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8 Online Work Mode 

After a successfully login the user can access his user roles.  

 

Figure 8.1 Online Work Mode window  

This window contains two dropdown lists, one contains the roles that correspond to the user and 
other with a list of events associated to the role selected.  

NOTE: the list of events can be changed by choosing another 
role. 

The ‘Download’ button allows the user to load the information about the selected event. 

NOTE: The user will be asked to save the selected event. In 
case of future work with this event you won’t need to 

download it again. 

 

 



61 | P a g e  
 

9 Offline Work Mode 

 

Figure 9.1 Offline Work Mode 

 

The ‘Choose File’ button opens a window to choose a file. 

NOTE: The user can only choose Zipped files (*.zip) 

 

Figure 9.2 Open a Local File 
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Figure 9.3 Loading an Event 

The ‘Load Event’ button redirects to the Automatic Distribution window (Figure 10.1). 
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10 Automatic Distribution 

 

Figure 10.1 Automatic Distribution window 

This window represents the Automatic Distribution window, which contains several elements: 

1. The information in red contains information about the event loaded:  
a. Number of total papers loaded, which can be of regular or position type; 

i. Number of regular papers loaded; 
ii. Number of position papers loaded; 

b. Number of reviewers loaded; 
c. Number of papers previously distributed and the number of reviewers that 

corresponded to them; 
d. Number of the previously distributions; 

2. The ‘Reviews Number’ label: allows the user to choose a minimal number of reviews for 
each paper; 

3. The ‘Minimal Match (%)’ label: allows the user to choose a minimal percentage match 
between papers and reviewers; 

4. The ‘Extra Reviews’ label: allows the user to choose a number extra of reviews to assign 
to each reviewer; 

5. The ‘Paper Type’ radio buttons: allow the user to choose which kind of papers will be 
used in the distribution: Regular, Position or both; 

6. The ‘Start Distribution’ button: allows the user to do an automatic distribution based on 
the chosen values in ‘Reviews Number’, ‘Minimal Match (%)’ and ‘Extra Reviews’ labels 
and ‘Paper Type’ radio buttons. 

7. The ‘Manual Distribution’ button: allows the user to do a manual distribution based on 
the results of the ‘Start Distribution’ button.  
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NOTE: this button is only enabled after ‘Start Distribution’ 
success. 

8. The ‘Exclusively Manual Distribution’ button: allows the user to do a manual distribution 
without the results of the ‘Start Distribution’ button. 
  

 

Figure 10.2 Information after automatic paper assignment 

After the distribution, it appears some information in red about it: 

1. The ‘Reviews Assigned’: represents the global number of distributed papers; 
2. The ‘Papers used’: represents the number of papers that have been used; 
3. The ‘Reviewers used’: represents the number of reviewers who has been used in the 

distribution; 
4. The ‘Papers Assigned below minimum Revisions’: represents the number of papers who 

has been distributed below the minimal reviews number; 
5. The ‘Unassigned Papers’: represents the number of papers without any review assigned; 
6. The ‘Unassigned Reviewers’: represents the number of reviewers without any review 

assigned; 
7. The ‘Effectiveness’: represents the distribution effectiveness; 
8. The ‘Time Elapsed’: represents the time taken to distribute the papers to the reviewers. 
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Figure 10.3 Manual Distribution choose 

After choosing the ‘Manual Distribution’ it will appear the Manual Distribution window based on 
the results of the ‘Start Distribution’ button. 

 

Figure 10.4 Manual Distribution window with Automatic Assignment results 
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Figure 10.5 Exclusively Manual Distribution 

After choosing the ‘Exclusively Manual Distribution’ button, will appear the Manual Distribution 
window without the results of the ‘Start Distribution’ button. 

 

Figure 10.6 Manual Distribution window without Automatic Assignment results 
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11 Manual Distribution 

 

Figure 11.1 Manual Distribution window 

This window represents the Manual Distribution window, which contains several elements: 

1. The ‘Assignments’ panel: contains a table with the reviewers’ name (columns) and with 
the papers’ number (lines). In addition, this table contains the reviews’ number for each 
paper, and for each reviewer the number of current revisions and maximum reviews. 
This table contains other relevant information such as: 

a. Checkboxes with colors representing the preference level; 
b. Percentage match between paper and reviewer; 
c. Tooltip with: 

i. Paper details  
ii. Reviewer details 

iii. Current Reviewers of each paper 
iv. Validation type, preference match and exact match 

NOTE: To do a manual assignment, the user should click on a 
checkbox that the paper is assigned to the reviewer.  

2. The ‘Paper Information’ panel: contains the details of the paper; 
3. The ‘Reviewer Information’ panel: contains the details of the reviewer; 
4. The ‘Paper Filters’ panel: contains the search paper filters with some options: 

a. Paper Search 
i. The ‘Search Paper’ label: allows the user to enter the text to be 

searched; 
ii. The ‘Search’ button: allows the user to perform the search; 
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iii. The ‘Clear’ button: allows the user to clear the paper search; 
b. ‘Topics’: corresponds to the filters based on the papers’ topics;  

NOTE: if the paper has areas, the filters will be based on the 
papers’ areas. 

c. ‘Number Reviews Assigned’: corresponds to filters based on the number of 
review for each paper, namely zero, one, two, three, four and four or more: 

i. The ‘0’ checkbox: allows refreshing the table with the papers with zero 
reviews; 

ii. The ‘1’ checkbox: allows refreshing the table with the papers with one 
review; 

iii. The ‘2’ checkbox: allows refreshing the table with the papers with two 
reviews; 

iv. The ‘3’ checkbox: allows refreshing the table with the papers with three 
reviews; 

v. The ‘4’ checkbox: allows refreshing the table with the papers with four 
reviews; 

vi. The ‘4+’ checkbox: allows refreshing the table with the papers with four 
or more reviews. 

d. The match label contains two elements: 
i. ‘% Match’ label: allows the user to enter a percentage match to be used 

in the match filter; 
ii. ‘Apply Match’ checkbox: allows the user to do a match filter on a paper;  

NOTE: to do this filter it is necessary to click on a paper 
number. 

5. The ‘Reviewer Filters’ panel: contains the search reviewer filters with the following 
options: 

a. ‘Area’ corresponds to filters based on the reviewers’ areas;  

NOTE: if the reviewer hasn’t areas, the filters will be based on 
the reviewers’ topics. 

b. ‘Reviews Assigned’ corresponds to filters based on the number of revisions of 
each reviewer, namely No Reviews, With Reviews or Max Reviews Reached: 

i. The ‘No Reviews’ checkbox: allows refreshing the table with the 
reviewers with no reviews; 

ii. The ‘With Assigned Reviews’ checkbox: allows refreshing the table with 
the reviewers with reviews between zero and their max revisions 
number; 

iii. The ‘Max Reviews Reached’ checkbox: allows refreshing the table with 
the reviewers who has been their max revisions number. 

c. Reviewer Search 
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i. The ‘Search Paper’ label: allows the user to enter the text to be 
searched; 

ii. The ‘Search’ button: allows the user to perform the search;  
iii. The ‘Clear’ button: allows the user to clear the reviewer search; 

d. The match label contains two elements: 
i. ‘% Match’ label: allows the user to enter a percentage match to be used 

in the match filter; 
ii. ‘Apply Match’ checkbox: allows the user to do a match filter on a paper;  

NOTE 1: to do this filter it is necessary to click on a reviewer 
name. 

 

NOTE 2: the user can apply paper filters and reviewer filters 
together. 

 
6. The ‘Redistribute -> Automatic Redistribution’ menu: allows the user to perform an 

automatic redistribution 
7. The ‘Validation -> Assignment’ menu: allows the user to validate the distribution. 
8. The ‘Options -> Change Table Colors’ menu: allows the user to change the table colors. 
9. The ‘Help’ menu: contains two submenus: 

a.  ‘Notifications’ menu: shows the information about notifications option to the 
user; 

10. The ‘Save Work’ menu: allows to save the current work 
11. The ‘Notifications’ checkbox: allows to enabled or disabled desktop alerts 

a. If the user clicks on a paper number, a notification appears with a top 5 
reviewers ordered by preferential match 

b.  If the user clicks on the paper reviews, a notification appears with the current 
reviewers assigned 

c. If the user clicks on a reviewer name, a notifications appears with a top 5 papers 
ordered by preferential match and current papers assigned 

12. The ‘Redock All’ button: allows to return to the original panels’. 
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Figure 11.2 Automatic Redistribution window 

This is the ‘Automatic Redistribution” window. Which has the same information as the ‘Automatic 
Distribution’ superior panel (see Figure 10.1). 

 

 

Figure 11.3 Color Information menu  

After choosing the ‘Help -> Color Information’ menu, will appear a window with the information 
regarding the table colors. This window contains the following elements: 

1. The ‘Enabled Checkboxes at the grid’ group: corresponds to the colors of the enabled 
checkboxes. Has three distribution types: 
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a. Paper Pre-Distributed 
b. Paper Assigned Automatically 
c. Paper Assigned through Hand Distribution 

2. The ‘Remain Colors -> Disabled Checkboxes at the grid’ group: corresponds to the colors 
of the disabled checkboxes based on the reviewers’ preference. Has four preference 
levels: 

a. ‘Doesn’t wish to review the paper’ 
b. ‘Reviewer may review the paper’ 
c. ‘Reviewer has a preference for the paper’ 
d. ‘Reviewer wants to review the paper’ 

3. The ‘Percentage Colors’ group: corresponds to three levels of preference match. 
a. ‘% Match > 50%’ 
b. ‘% Match > 10% and % Match <= 50%’ 
c. ‘% Match < 10%’ 

NOTE: next to each color there is a dropdown list that allows 
the user to change the color that he wants (Figures Figure 11.4, 

Figure 11.5 and Figure 11.6 ). 

4. The ‘Confirm Changes’ button: allows the user to confirm the color changes. 
5. The ‘Default Colors’ button: allows the user to restore the default table colors. 

 

Figure 11.4 Table Color Changes 

If you click on a dropdown list, you will see a palette of all available colors. 
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Figure 11.5 Color Changes successfully applied  

After doing color changes the system will inform the user. 

 

Figure 11.6 Manual Distribution window with color changes 

The assignments table is then refreshed accordingly.  
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12 Assignment Validation 

 

Figure 12.1 Assignment Validation window 

 

After choosing the ‘Validation -> Assignment’ menu in Manual Distribution window, will appear the 
‘Assignment Validation’ window. This window has a table with two principal columns:  

1. ‘Distribution Information’ column, has two sub-columns with information about: 
a. Paper number 
b. Reviewer name 

NOTE: if the user moves the mouse to a paper number, it will 
show a tooltip with the paper details. If the mouse is moved 

over a reviewer name, it will show a tooltip with the reviewer 
details. 

 
2. ‘Assignment Validation’ column, has four sub-columns with information about: 

a. Distribution Type: ‘Auto’ or ‘Manual’; 
b. Three validation types 

i. The ‘Yes’ checkbox: allows the user to validate the selected Assignment 
ii. The ‘No’ checkbox: allows the user to invalidate the selected Assignment 

iii. The ‘Temp’ checkbox: allows the user to set the paper temporally to the 
selected reviewer 

At the bottom there are 2 checkboxes: 
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1. The ‘Temporary All’ checkbox: allows the user to set all papers as temporally assigned; 
2.  The ‘Validate All’ checkbox: allows the user to validate all Assignments. 

And two menus: 

1. The ‘File’ menu, with two sub-menus: 
a. The ‘Save Current Work’ menu: allows the user to save to file all changes; 
b. The ‘Return to Manual Distribution’ menu: allows the user to return to Manual 

Distribution window (Figure 11.1). 
2.  The ‘Submit’ menu, with two sub-menus: 

a. The ‘Submit Validated Assignments’ menu: allows the user to submit the event 
to the PRIMORIS database; 

b. The ‘Save Assignments for later Submission’ menu: allows the user to save the 
current work, to a file, for later submission (Figure 8.3). 

 

Figure 12.2 Save Original File with changes 

After choosing the ‘File -> Save Current Work’ menu, will appear a window that allows saving the 
event to the user personal computer. After having the work successfully saved, a notification will 
appear.  
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Figure 12.3 Export to Database menu 

 

Figure 12.4 Authentication window 

In the ‘Export to Database -> Export’ menu, an authentication window will appear. 

 

 

Figure 12.5 Submit Event option 
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After a successful login, the ‘Submit File’ button is enabled and the ‘Login’ button is disabled. 

NOTE: if the user is already authenticated, then it will not be 
necessary to do it again. In this case the ‘Submit File’ button is 

enabled and the ‘Login’ button is disabled. 

 

Figure 12.6 Save Assignments for Later Submission option 

After choosing the ‘Export to Database -> Save Assignments for later Submission’ menu, the user 
can save the event for later submission (Figure 8.3). 
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13 Known Issues 

 

13.1 Multiple Reviewers Selection 

 

Reviewers can be selected by the clicking on their names with any of the mouse buttons (Figure 
13.1).  

 

Figure 13.1 Multiple Reviewer Selection – Issue Demonstration 
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To unselect a reviewer, you must right-click it (Figure 13.2), and it will be unselected. 

 

Figure 13.2 Multiple Selection Issue – How To Fix 

 

 

Figure 13.3 Multiple Selection Issue Fixed 

NOTE: This issue will be fixed in the next release. 
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Glossary 

Position Paper - A position paper presents an arguable opinion about an issue. The goal of a Position 
Paper is to convince the audience that your opinion is valid and worthy to 
listen to, without needing to present completed research work and/or 
validated results. However, it is important to support your argument with 
evidence to ensure the validity of your claims. A Position Paper may be a short 
report and discussion of ideas, facts, situations, methods, procedures or results 
of scientific research (bibliographic, experimental, theoretical, or other) 
focused on one of the conference topic areas. The acceptance of a Position 
Paper is restricted to the categories of ‘short paper’ or ‘poster’, i.e. a Position 
Paper is not a candidate to acceptance as ‘full paper’. 

Regular Paper - A regular paper presents a work where the research is almost or completely finished. 
It does not necessarily mean that the acceptance is as a full paper. It may be 
accepted as a ‘full paper’ (30 min. oral presentation), a ‘short paper’ (20 min. 
oral presentation) or a ‘poster’.  
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