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AIM v5.0 Release Notes 
This document is intended as a quick start guide to installing AIM v5.0. You should read this entire document 

before proceeding with the installation. It also details some general information about the program that did not 

make it into the User’s Manual. 
 

If you need help with the installation or use of AIM, you should contact the System Support Office (SSO). 

Contact information can be found in the User’s Manual. 

Of Note 

With the release of AIM v5.0, we have combined the installation of both AIM I and AIM II into a single installer. 

On installation, AIM I and AIM II will be installed within the same directory. DO NOT MOVE THESE FILES. 

Bad things happen if you try that. By merging the installations into one directory, this will make it far easier for 
the user to keep their software up-to-date. 

 

After installing AIM on your computer, you will notice an icon called AIM v5.0 on your desktop. When you 
select this, you will be prompted whether you want to run AIM I or AIM II. If you choose one or the other, the 

AIM v5.0 icon will, in the future, launch the product you select. If you choose both, you will be given two new 

icons on your desktop, one for each product. Note: This selection only affects what action the desktop icon 

performs. You can still access either version of AIM from the AIM v5.0 folder under the Start menu. 

Warnings 

If you are running SQL Server, make sure you don’t update your SQL Server database if you plan on continuing 

to use AIM v4.0. Contact the AIM SSO for details on how to use both AIM v4.0 and v5.0 on the same computer 
when connected to SQL Server. 

 

Before converting your database to be used with v5.0, make sure you have a working backup of the entire 

database folder (including sub-folders for Graphics, IETMs, and Media). 
 

If you are using SQL Server, make sure you have a working backup copy of the SQL Server database before you 

convert to v5.0. Due to the way the software works, if the conversion were to fail in the middle of the process, the 
database will become unusable and will need to be restored from backup. 

AIM v5.0 exports/archives of traditional AIM content is not backward compatible with AIM v4.0 or earlier (i.e. 

you cannot export a Course from v5.0 and import it into v4.0). As such, if you plan on creating/editing Courses in 
AIM and passing them to other users, you either need to perform this in AIM v4.0 or make sure all users getting 

your content are also running AIM v5.0. 

 

SCORM exports of Learning Objects from AIM v5.0 can be imported into v4.0. However, data specific to v5.0 
will be lost in the process. 

Installation Quick-Start 

Before you install AIM, you should: 
1. Make sure there is a recent backup of your existing AIM database (if you already have a version of AIM 

installed). 

2. Write down the location of the AIM directory on the network, if you run AIM from a server (not installed 

on your local machine). 
3. Write down the location of the current AIM database folder. If you do not have an existing database, 

determine where you want to place it (on the network or on your local machine).  

 
Warning: If you are installing AIM v5.0 and plan on keeping a previous version, you will need to 

make a copy of your existing Database directory to use with v5.0. If you select your existing 
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v4.0 database to be used with v5.0, AIM will convert it to v5.0 format, and it will no longer 

work with the v4.0 software. 

 

To install AIM v5.0, follow these steps: 
1. Insert the AIM v5.0 installation CD into your CD-ROM drive of your computer, or, if you downloaded 

the installer, open the folder that contains the AIM v5.0 installation program. If you received the installer 

on floppy disks, please contact the SSO. 
2. For CD installs, if the AIM v5.0 installer does not start up automatically, double-click the My Computer 

icon on the desktop, double-click the CD drive icon to display the contents of the CD. 

3. Double-click the Setup.exe icon (if your system does not display extensions of files, then the file will be 
called just Setup). 

 

Note: Depending on what operating system and software that is already installed on your computer, the 

installation program may prompt you to reboot your computer one or more times before the 
installation program actually runs. This is normal, as it is installing certain key system files 

required for it to run correctly. 

 
4. Click the Next button to navigate past the Introduction screen. 

5. The next screen displays the Read Me file for the installer. Make sure you read it through before 

continuing. It will look surprisingly like this file. 
6. The next screen displays the Customer Information screen. You can enter your Name and Company into 

the appropriate fields. You will also see an option to install it for all users or just the current user. Choose 

All Users if you want any user on that computer to be able to use the software. 

7. The next screen will prompt you for the directory to install the AIM software. Click the Change button to 
select another directory. If AIM will be run from a network server, select the directory where the AIM 

software is located. Then click Next. 

8. Finally you need to select which type of installation you want to perform. There are three options: 

 Typical: Choose this option if you are updating AIM, installing AIM on your local drive, or 

installing it on a server for others to use. This will install all the required elements for AIM to run. 

 Minimal: Choose this option if you are planning on running AIM from a server. This will install 

on your local machine just the software needed to run an existing copy of AIM v5.0 already 

installed on a network directory. 

 Custom: Choose this option if you want to install some of the optional components, for example, 

the NAVEDTRA 131B manuals in PDF format. 
 

Note: If you are installing the software on a computer running Windows 2003 or 2008 Server and you 

select Custom, do not check the box reading Data Access. The software will not install with that 
checked. It is unchecked on the typical install. 

 

9. Once you’ve made a selection, click on Next. If you chose the Custom option, you will now be displayed 
a list of AIM components to install. Make your selections, then click Next one last time. 

10. Finally, you’ve reached the installation summary screen. This summarizes your selections from the 

previous screens. If you want to change any selection, click Back. If all the settings seem correct, click on 

Finish. 
 

The installation will now commence. When it is finished, it may ask you to reboot your computer one last time. 

Once installed, you can run AIM by double-clicking the icon on the desktop, or by going to the Start Menu and 
choosing Programs->AIM v5.0.  

 

Installation Comments: 

 AIM has been tested under Windows XP, Vista, and 7 (32- and 64-bit). For best results and security, you 

should make sure you’re running with the latest Service Packs and patches. 
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Known Issues: 

 Due to the installation of several system files, administrative rights are required on the local machine in 

order to install AIM v5.0. 

 Due to the way AIM works, you cannot install multiple copies of AIM v5.0 on one system. However, you 

can make a copy of the AIM directory, delete the AIM.INI file, and choose another database to use as 

your AIM database (this can be done so you have AIM icons for a local database and a networked 
database).  

 Even if you do keep two AIM directories on one system, when you launch an AIM module (like LP or 

Admin), it will be launched from the directory in which AIM was originally installed. Therefore, if you 

try to put product updates into the copied directory, the updated software will not be used. It will need to 
be installed in the original directory. 

Running AIM for the First Time 

As mentioned above, you will notice an icon called AIM v5.0 on your desktop. When you select this, you will be 

prompted whether you want to run AIM I or AIM II. If you choose one or the other, the AIM v5.0 icon will, in the 
future, launch the product you select. If you choose both, you will be given two new icons on your desktop, one 

for each product. Note: This selection only affects what action the desktop icon performs. You can still access 

either version of AIM from the AIM v5.0 folder under the Start menu. 
 

The first time you run either AIM I or AIM IIv5.0, AIM will perform the following actions: 

 
1. If you used the Minimal option when you installed AIM, it will set up AIM to allow it to run from the 

server. 

 

2. If no AIM.INI file exists in the AIM directory, you will be prompted to specify the database, graphics and 
media directories. If you already have an existing database, enter the path to that directory. If you do not 

have an existing database, enter the path where you would want to create one (or leave the default settings 

as is). If the directory you specify does not contain an AIM database, one will be created for you. 
 

Note: The installer will never overwrite an existing database with a new one.  

 
3. If the database needs to be converted to the latest version of AIM, you will be stepped through the process 

of converting it to v5.0 format.  

 

Note: You will need to have permissions to create and delete files to both the AIM and database 
directories in order to convert the database. If you do not have these permissions, see your 

Network Administrator.  

 
Warning: Once you’ve converted your database to v5.0 format, it can no longer be used with any 

previous versions of AIM. If you still want to use a previous version of AIM, you will need 

to make a copy of your AIM database directory and select that new directory when setting 

up the database. 
 

4. If you have Microsoft Word installed on your machine, you will be prompted to enable macros in Word. 

AIM uses Word macros to allow you to add graphics to your Sheets from the AIM Graphics library.  
 

a. If you have Word 2000 or greater, you will be prompted to accept the digital certificate attached to 

the macros. The macros used by AIM are signed to verify the author of the macros. If you accept the 
certificate (by checking the “Always trust macros from this source” box), Word will not prompt you 

about macros in AIM documents.  

 

Once these are done, the AIM login screen will display. 
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AIM Comments: 

 The AIM documentation is in PDF format. If you don’t already have it installed, the installer for the free 

Adobe Reader can be downloaded from adobe.com. You can also use other third-party PDF readers as 

you wish. 

 The Help menu on the main AIM screen allows access to the On-line help as well as PDF versions of the 

AIM User’s manual, a list of changes made to AIM v5.0, and a set of Frequently Asked Questions.  

 If at any time you want to connect to a different database, just exit AIM and delete your AIM.INI file. 

The next time you run AIM, it will notice that the AIM.INI is missing and again step you through 

selecting a database directory. 

 AIM now supports use of 2000/2005/2008 as the database engine. SQL Server offers better stability and 

scalability than the Microsoft Access database engine used by AIM. If you want to upgrade your AIM 

database to SQL Server, read the file Migrating AIM to a SQL Server Database.pdf found in the 

Documentation folder. 

 

Known Issues: 

 If you’re using Word for editing TG Sheets, and the AIM Graphic or IMI buttons (or associated menu 

items under the Insert menu) within Word cause errors to appear, you may need to update Office with the 

latest Service Packs. These can be found on the installation CD. If you do not have permission to install 
the updates, changing your security setting to Medium or Low should also work. To change your security 

settings, open Word and go to the Tools->Macros->Security menu. 

 It is highly recommended that you run the latest Service Packs for your version of Microsoft Word. 

 
 


