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Warning notice system 
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DANGER  
indicates that death or severe personal injury will result if proper precautions are not taken. 

 

WARNING  
indicates that death or severe personal injury may result if proper precautions are not taken. 

 

CAUTION  
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label devices, systems and circuits in accordance with established safety practices and standards. 

Proper use of Siemens products 
Note the following: 

WARNING  
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
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Preface 1
Purpose of this documentation   

This documentation provides you with detailed information on the Windows Automation 
Center 2008 for Multi Panel or simply WinAC MP 2008. 

 

 
Tip 
In the following pages WINAC MP 2008 will be referred to as WINAC MP. 

 

WinAC MP is an S7 software PLC for the MP 177, MP 277 and MP 377 Multi Panels. 
WinAC MP runs under Windows CE.    
WinAC MP can be operated on the following Multi Panel HMI device types: 
● MP 177 6" Touch 
● MP 277 8" Touch and Key 
● MP 277 10" Touch and Key 
● MP 377 12" Touch and Key 
● MP 377 15" Touch 
● MP 377 19" Touch 

Required basic knowledge    
General knowledge about automation engineering and process communication is needed to 
understand this documentation. 
In addition, the following knowledge is required: 
● Comprehensive knowledge of WinCC flexible 
● Comprehensive knowledge of STEP 7 

Validity of the documentation    
This documentation is valid for WinAC MP 2008.  

Requirement for installation 
WinCC flexible 2008 SP1 should be installed. 

Location of documentation    
When you install WinAC MP, the documentation is stored on the configuration PC. 
The PDF file: You can open the WinAC_MP_en.pdf file on the configuration PC with the 
menu command: Start > SIMATIC > Documentation > English > WinAC MP 2008 
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Upgrade from WinAC MP 2007 to WinAC MP 2008 
If you already have WinAC MP 2007 you can download a free upgrade from the Internet. 
To confirm that you are authorized to download this free upgrade, please state the license 
number of your original WIN MP 2007 (customs and shipping costs may arise outside the 
EU). For details of the license number valid for your product, please refer to your software 
product certificate. 
For additional information about this upgrade, refer to Internet 
(http://support.automation.siemens.com/WW/view/en/31929448): 

Getting Started Video with image and sound, duration: approx. 6 minutes (D/E) 
The Getting Started Video shows: 
● the advantages of the WinAC MP software PLC 
● how easy it is to configure WinAC MP 
You will find the Getting Started Video on the Internet 
(http://support.automation.siemens.com/WW/view/en/32010673)  

Conventions   
Configuration and runtime software have different names as follows:   
● "WinCC flexible 2008 SP1" denotes the configuration software. 

The term "WinCC flexible" is used in a general context. The full name, for example, 
"WinCC flexible 2008 SP1", is always used when it is necessary to differentiate between 
different versions of the configuration software.   

● "WinCC flexible Runtime" refers to the runtime software that can run on the HMI device.  
Please observe notes labeled as follows: 

 

 Note 
Notes contain important information concerning the product, its use or a specific section of 
the documentation to which you should pay particular attention. 

 

● "WinAC MP" is the name of a software PLC that can run on the Multi Panel HMI device 
types listed above along with WinCC flexible 2008 SP1. 

http://support.automation.siemens.com/WW/view/en/31929448
http://support.automation.siemens.com/WW/view/en/32010673
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Registered trademarks   
Names labeled with a ® symbol are registered trademarks of the Siemens AG. Other names 
used in this documentation may be trademarks, the use of which by third parties for their 
own purposes could violate the rights of the owner.   
● SIMATIC® 
● STEP 7® 
● WinAC® 
● HMI® 
● SIMATIC HMI® 
● SIMATIC ProTool® 
● SIMATIC WinCC® 
● SIMATIC WinCC flexible® 
● SIMATIC MP 177® 
● SIMATIC MP 277® 
● SIMATIC MP 377® 
● SIMATIC Multi Panel® 

Standards 
WinAC MP complies with the requirements and criteria of IEC 61131-3.   
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Position in the information landscape    
This documentation is part of the SIMATIC and SIMATIC HMI documentation. This 
documentation describes all the information specifically relating to WinAC MP. You will find 
more information in the following manuals:    
● STEP 7 - Programming with STEP 7 

Provides basic information on designing and programming a STEP 7 user program. This 
manual is available on a PC with STEP 7. 

● STEP 7 - System and Standard Functions for S7-300 and S7-400 
Describes the system functions, organization blocks and loadable standard functions 
available for programming a STEP 7 user program. This manual is available on a PC with 
STEP 7. 

● STEP 7 - Getting Started with STEP 7 
Explains the use and functions of the STEP 7 automation software, the procedures during 
configuration and the development of STEP 7 user programs. This manual is available on 
a PC with STEP 7. 

● STEP 7 - Statement List for S7-300 and S7-400 
Provides a full list of the statements that can be used for WinAC MP. This manual is 
available on a PC with STEP 7.  

● Operating instructions for SIMATIC HMI devices 
– MP 177 
– MP 277 
– MP 377 

● WinCC flexible Compact/Standard/Advanced User's Manual 
Describes basic principles of configuration using the WinCC flexible Compact 
/WinCC flexible Standard/WinCC flexible Advanced engineering systems. 

● WinCC flexible Runtime User Manual 
Describes how to commission and operate your runtime project on a PC. 

● WinCC flexible Migration User's Manual 
– Describes how to convert an existing ProTool project to WinCC flexible. 
– Describes how to convert an existing WinCC project to WinCC flexible. 
– Describes how to convert an existing ProTool project including a change of HMI 

device, for example, from OP3 to OP 73. 
– Describes how to convert an existing ProTool project including a change from a 

graphics device to a Windows CE device. 
● Communication User's Manual 

– Communication Part 1 describes the connection of the HMI device to SIMATIC PLCs. 
– Communication Part 2 describes the connection of the HMI device to third-party PLCs. 

● Getting started 
– WinCC flexible, Getting Started - First Time User 

Based on an example project, this is a step-by-step introduction to the basics of 
configuring screens, alarms, recipes and screen navigation. 

– WinCC flexible, Getting Started - Power User 
Based on an example project, this is a step-by-step introduction to the basics of 
configuring logs, project reports, scripts, user management, multilingual projects and 
integration in STEP 7. 

– WinCC flexible, Getting Started - Options 
Based on an example project, this is a step-by-step introduction to the basics of 
configuring the WinCC flexible Sm@rtService, Sm@rtAccess and OPC server options. 
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Guide to the manual   
This documentation contains the following aids that will allow you to find the specific 
information you need quickly: 
● At the beginning of the documentation you will find a full table of contents. 
● Following the appendix, you will find a glossary with definitions of the most important 

terminology. 
● At the end of the documentation, there is a comprehensive index with which you can 

locate the information you are looking for. 

Additional support   
If you have any questions about the products described in this manual, please contact your 
Siemens representative. 
You will find your contact person (http://www.siemens.com/automation/partner) here. 
You will find a guide to the technical documents for the various SIMATIC products and 
systems (http://www.siemens.com/simatic-tech-doku-portal) on the Internet. 
Here, you will find the online catalog and the online ordering system 
(https://mall.automation.siemens.com/en/guest/). 

Training center   
We offer various courses for newcomers to the SIMATIC S7 automation system. Contact 
your regional Training Center, or the central Training Center in D-90327 Nuremberg, 
Germany.  
● Additional information can be found on the Internet (http://www.sitrain.com)  

Technical support   
You can contact Technical Support for all A&D products by means of the Web form 
(http://www.siemens.com/automation/service)  
You can find more information on our technical support 
(http://www.siemens.com/automation/service) on the Internet. 

Service & Support on the Internet   
In addition to our documentation, we offer our complete knowledge base at the Internet 
address (http://www.siemens.com/automation/service&support). 
There you can find: 
● Our newsletter containing up-to-date information on your products. 
● The documents you need via our Search function in Service & Support. 
● A forum for global information exchange by users and specialists. 
● Your local Automation & Drives representative. 
● Information about on-site service, repairs, spare parts, and more. 

http://www.siemens.com/automation/partner
http://www.siemens.com/simatic-tech-doku-portal
https://mall.automation.siemens.com/en/guest/
http://www.sitrain.com/
http://www.siemens.com/automation/service
http://www.siemens.com/automation/service
http://www.siemens.com/automation/service&support
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Product overview 2
2.1 Product overview 

Definition of embedded   
An embedded system: 
● is a combination of hardware and software providing the flexibility of software with the 

performance of rugged hardware. 
● has precisely defined tasks; it forms a functional software and hardware unit that only 

performs predefined tasks. 

Embedded automation with WinAC MP   
SIMATIC Embedded Automation combines SIMATIC control technology  
(WinAC MP) and WinCC flexible visualization on the Multi Panels.  
These are based on Windows CE and have no hard disks, making them extremely rugged 
platforms.  
The Multi Panels have an operating system intended for embedded applications that needs 
little user memory and meets real-time and deterministic demands. 
● WinAC MP is the cost-effective solution for small and medium-sized applications and 

automation tasks  
● The Multi Panels are ideal for use in harsh industrial environments thanks to their 

ruggedness and compact design. 

 
Figure 2-1 Embedded automation with WinAC MP 2008 
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Programming   
WinAC MP is programmed and configured with STEP 7 and the SIMATIC engineering tools 
for production engineering. This means that all SIMATIC programming languages are also 
available for WinAC MP. 

 

 Note 
Program modules programmed for SIMATIC S7 controllers can be reused for WinAC MP 
without any changes being necessary, provided they have not been tailored to specific 
properties of a SIMATIC S7 CPU. 

 

Visualization with WinCC flexible 
WinCC flexible projects for the Multi Panels are edited with WinCC flexible integrated in 
STEP 7. In integrated projects, you access the configuration data of STEP 7 and can use the 
SIMATIC Manager as the central coordinator for creating, editing and managing WinAC in 
the SIMATIC HMI station and the WinCC Flexible projects for the Multi Panels.   

Communication   
Communication with the I/O is handled via the integrated PROFIBUS-DP master that allows 
the connection of DP slaves. 
Information from the automation level is acquired over the PROFIBUS-DP interface and 
forwarded by WinAC MP 2008 via the Industrial Ethernet interface integrated in the HMI 
device. Data are transferred via Industrial Ethernet and S7 communication to a central PC, 
for example, to WinCC, WinCC flexible, or to the SIMATIC NET OPC server.  

Released FM modules for communication on the PROFIBUS 
The following FM modules are released, in addition to standard I/O modules, on PROFIBUS 
on an ET 200M. 
● FM 350-1 function module 
● FM 350-2, 8-channel counter module 
● FM 351 positioning module 
● FM 352 electronic cam controller 
● FM 353 positioning module - stepdrive 
● FM 354 positioning module - servodrive 
● FM 355 control module - PID controller 
● FM 355-2 temperature controller 
● FM 352-5 boolean processor 
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2.2 Scope of delivery 

Overview of the components supplied 
The following components ship with the product: 
● CD with: 

– WinAC MP 2008 
– Electronic operating instructions in PDF format 

Languages: German, English, French 
● USB stick with: 

– Single license for WinAC MP 2008 
● Software Product (Certificate of License) 

WinCC flexible System Library 
The WinAC MP scope of delivery includes a WinCC flexible system library that contains two 
screens. These screens are taken over during the installation in the WinCC flexible system 
library and are available for use there. 
The WinCC flexible system library includes the following Screens:  
● Home Screen 
● Tuning Screen 

Further Information 
The following sections of the manual provide you with a detailed description of the screens: 
● Description of the Home Screen (Page 59) 
● Description of the Tuning Screen (Page 61) 
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2.3 Essential system characteristics of WinAC MP 2008 
● New software PLC WinAC MP 177 for MP 177 6'' Touch 
● Improved time behavior through conversion to "HMI Enable Time" 
● With WinAC MP, you can configure retentive data for bit memory, S7 timers, S7 counters 

and data blocks. 
Even if there is a power down while WinAC MP is running, the current values of the 
retentive DBs or bit memory, timers and counters are not lost. When you restart WinAC 
MP again, you can access the last saved values of these retentive memory bits, timers, 
counters and DBs. 

● B-Send / B-Receive now available in WinAC MP 2008. 
● The performance during online monitoring via PROFINET has been improved for WinAC 

MP 2008. 
● New screen forms integrated into WinCC flexible system library. 
● A new parameter has been added in WinAC MP 2008 to specify the file path for system 

functions Archive and Restore. 
● WinAC MP supports time synchronization between the HMI device and the WinAC MP 

installed on it.  
● Routing with S7 communication is possible with WinAC MP. 
● You configure WinAC MP in STEP 7 as an HMI station and not as a PC station. 
● WinAC MP supports only the OB 35 as cyclic interrupt. 
● Expansion of the IO address area from 2k to 4k for MP 277 
● SCL / CFC programming 
Additional technical specifications are available in the in the section "Technical specifications 
(Page 93)" in the operating instructions for WinAC MP 2008. 
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Steps for installing and removing 3
3.1 Requirements for installation 

Installing and working with WinAC MP    
Before you can use WinAC MP, there are several installation and development steps you 
need to work through on the configuration PC prior to transferring the required components 
to the HMI device. You will need to perform the following tasks:   
 
Step Task For more information, refer to the 

section ... 
1 Check that your HMI and configuration device 

meets the system requirements. 
Hardware and software 
requirements (Page 16)  

2 Install WinAC MP on the configuration PC. Installing WinAC MP (Page 18)  
3 Transfer the WinAC MP Runtime files from the 

configuration PC to the HMI device with ProSave. 
Transferring WinAC MP to the HMI 
device (Page 26)  

4 Transfer the License Key to the HMI device. Licensing WinAC MP on the HMI 
device (Page 27)  

5 Develop a STEP 7 user program to control your 
process with WinAC MP on the HMI device. 

Creating a STEP 7 project for 
WinAC MP (Page 34)  

6 Develop a WinCC flexible project so that the HMI 
device is available as the interface to WinAC MP 
and to your process. You have the following 
options:   
• Use the supplied WinCC flexible System Library 
• Create your own WinCC flexible sample project 

for your application. 

Working with WinCC flexible 
(Page 79)  

You will find information on using the functions of WinAC MP with WinCC flexible in the 
section WinAC MP functions (Page 80). 

See also 
Setting the communication functions for the configuration PC (Page 47) 
Integrating the WinAC MP System Library (Page 57) 
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3.2 Hardware and software requirements 

Installation sequence 
To be able to use WinAC MP on the HMI device, it is mandatory that you keep to the 
following sequence during installation on the configuration PC: 
1. Install STEP 7 V5.4 SP 4 or higher 
2. Install WinCC flexible 2008 SP1 
3. Install WinAC MP 2008 

 

 

 
Tip 
If older versions of STEP7, WinCC flexible and WinAC MP have already been installed, 
you will have to uninstall them first.  
Once the programs have been uninstalled, you will have to observe the installation 
sequence listed above. 

 

HMI device hardware requirements    
WinAC MP is installed on a reserved area of the flash memory. The  
memory area reserved for HMI applications is not reduced by this. 
WinAC MP runs on the following HMI devices: 
● SIMATIC MP 177 6" Touch (6AV6 642-0EA01-3AX0) 
● SIMATIC MP 277 8" Touch (6AV6 643-0CB01-1AX1) 
● SIMATIC MP 277 8" Key (6AV6 643-0DB01-1AX1) 
● SIMATIC MP 277 10" Touch (6AV6 643-0CD01-1AX1) 
● SIMATIC MP 277 10" Key (6AV6 643-0DD01-1AX1) 
● SIMATIC MP 377 12" Touch (6AV6 644-0AA01-2AX0) 
● SIMATIC MP 377 12" Key (6AV6 644-0BA01-2AX0) 
● SIMATIC MP 377 15" Touch (6AV6 644-0AB01-2AX0) 
● SIMATIC MP 377 19" Touch (6AV6 644-0AC01-2AX0) 
To find out if successor Multi Panels are supported, refer to the Internet 
(http://www.siemens.com/automation/service&support). 

HMI device software requirements    
To install WinAC MP 2008 on the HMI device, you require:  
● WinCC flexible runtime 2008 SP1 
● current image of the HMI device from WinCC flexible 2008 SP1 

Notes on updating the HMI device image are available in the respective documentation.  

http://www.siemens.com/automation/service&support
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Configuration PC hardware requirements    
To install WinAC MP on the configuration PC, you require 
● At least 40 MB of free space on the hard disk 
● The requirements of STEP 7 and WinCC flexible must also be supported 

Configuration PC software requirements    
To install WinAC MP on the configuration PC, you require 
● Microsoft Windows XP Professional, Service Pack 2 or higher  
● STEP 7 V 5.4 with Service Pack 4 or higher 
● WinCC flexible 2008 SP1 

And... 
You need: 
● An Ethernet or PROFIBUS connection between the configuration PC and HMI device 
● or a Serial RS232/PPI Multi Master cable for serial transfer (for example to load the 

MP 177 and MP 277 the first time) between the configuration PC and HMI device (order 
no. of the cable: 6ES7 9013CB30-0XA0). 

● SIMATIC NET if you want to use Ethernet communication (SIMATIC NET CD V7.0 or 
V7.1).  

● Devices necessary for process control connected to your HMI device using 
PROFIBUS DP (for example, ET 200). 

● The Adobe Reader, to read the supplied electronic manuals. You can obtain the latest 
version of Acrobat Reader at www .Adobe.com. 
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3.3 Installation steps 

3.3.1 Installing WinAC MP 

Requirements 
Prior to installing WinAC MP, read the requirements in the section:  Hardware and software 
requirements (Page 16) 

 

 Note 
You must first uninstall any already installed WinAC MP version. 

Installing WinAC MP on the configuration PC   
The WinAC MP software includes a setup program that automatically performs the 
installation. 
The installation program leads you step by step through the installation operation. You can 
go to the next step or back to the previous step at any time.  
To start the installation program, proceed as follows: 
1. Insert the CD "WinAC MP 2008" in the CD drive of the configuration PC. 
2. Double-click on the "setup.exe" file in the "\WinAC" folder. 
3. Follow the instructions that appear on the next screen. 

 
4. Confirm the dialog and follow the instructions on the screen. 

Result: A message is displayed when the installation is completed successfully. 
5. You should restart your computer after installation has completed. 
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Installing WinAC MP on the HMI device 
1. Installing the options by means of ProSave. 
2. Installing the product-specific license (License Key) using Automation Single License 

Manager. 

Further installation 
Install SIMATIC NET if you want to use Industrial Ethernet communication. 

See also 
Hardware and software requirements (Page 16) 
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3.3.2 Connecting the configuration computer to the HMI device 

3.3.2.1 Basics of transfers 

Transfer   
Transfer is the process of sending the installation and project files between the configuration 
PC and the HMI device. 
The HMI devices must be connected to the configuration PC to transfer the installation and 
project files. 

Basic procedure 
There are several ways in which you can transfer installation and project files: 
● Transfer over Industrial Ethernet (direct or networked connection) 
● Transfer via PROFIBUS DP 
● Transfer over USB (no STEP 7 user program) 

 

 
 Note 

USB connection parameters 
To use the USB connection, you require a master-master cable. Install the supplied 
"BULK driver" and not "Standard".  
You will find information on installing the "BULK driver" under the entry ID 
(http://support.automation.siemens.com/WW/view/en/19142034)  

 
Figure 3-1 WinAC MP transfer 

http://support.automation.siemens.com/WW/view/en/19142034
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3.3.2.2 Transfer over Industrial Ethernet 

Connection over Industrial Ethernet 
Direct connection: Connect the configuration PC to the HMI device using a crossover cable. 
Networked connection over LAN: Connect the configuration PC and the HMI device to the 
LAN with a 1:1 or direct cable. 

Settings on the HMI device 
1. Open the Control Panel to set the network configuration. You can open the Control Panel 

either in the Loader or with Start > Settings > Control Panel.   
2. Double-click "Network and Dial-up Connections". 
3. Double-click on: 
● LAN9115 for MP 177 
● LAN90001 for MP 277 
● ERTEC400 for MP 377 

Enter the IP address and, if necessary, the subnet mask of the HMI device. Confirm with 
"OK". 

 

 
 

Note 
Specifying a gateway address 
If you need to specify a gateway address, contact your network administrator. 

 

1. Then double-click "Transfer". 
2. Under Channel 2, select the "Ethernet" option in the list box, select "Enable Channel" and 

confirm with "OK". 
 

WARNING  
 

Entering a static IP address  
Do not use DHCP (Dynamic Host Configuration Protocol) to assign the TCP/IP address 
on the HMI device. 
With DHCP, there is no guarantee that the same IP address will always be assigned 
when a node is turned on. If the IP address is changed, nodes in Industrial Ethernet may 
lose their connection or be connected to the wrong node. This can result in unexpected 
process and machine behavior that can cause death, serious injury and/or damage to 
equipment. 
Always enter a static IP address for the HMI device or if you use DHCP, make sure that 
there are at least lease reservations. Contact your network administrator when 
assigning addresses. 
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Setting on the configuration PC 
Take the following steps on the configuration PC either in ProSave or in WinCC flexible: 
 
Step Connecting ProSave Connecting WinCC flexible 
1 Open the "General" tab in ProSave. Open the project you want to transfer in 

WinCC flexible. 
2 Select your HMI device from the "Device 

type" list box. 
Select your HMI device via Project > 
Change Device Type. 

3 -- Change to Project > Transfer > Transfer 
Settings in WinCC flexible. 

4 Select the "Ethernet" option in the 
"Connection" list box. 

Select the "Ethernet" option in the "Mode" 
list box. 

5 In "Connection Parameters", enter the IP 
address or the computer name of the HMI 
device. 

Under "Computer Name" or "IP Address", 
enter the computer name or the IP address 
of the HMI device. 

6 -- Confirm your entries with "Apply". 
7 Close ProSave or change to the "Options" 

tab to transfer the WinAC MP runtime files.  
Please make sure that the correct path is 
set. 

Change to Project > Transfer > Options in 
WinCC flexible to transfer the WinAC MP 
runtime files.  
Please make sure that the correct path is 
set. 

8 Click the ">>" button. Click the ">>" button. 
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3.3.2.3 Transfer over PROFIBUS 

Connection over PROFIBUS    
The configuration PC must have a PROFIBUS port, such as a CP 5611, and the relevant 
drivers must already be installed. 
Connect the configuration PC with the HMI device over the DP interface using a PROFIBUS 
cable. 

Requirements 
WinAC MP must be running when you transfer data over PROFIBUS to WinCC flexible 
Runtime. 

Settings on the HMI device 
1. Open the Control Panel in the Loader.   
2. Double-click "Transfer". 
3. Go to "Channel 2", select "MPI/PROFIBUS/S7 Ethernet" and select "Enable Channel". 
4. Click "OK" to close the "Transfer Settings" dialog. 

 

 
 

Note 
You set the PROFIBUS address of the HMI device in STEP 7 HW Config and not on the 
HMI device! The default PROFIBUS address after installing WinAC is 2. 

 

Setting on the configuration PC 
Take the following steps on the configuration PC either in ProSave or in WinCC flexible: 
 
Step Connecting ProSave Connecting WinCC flexible 
1 Open the "General" tab in ProSave. Open the project you want to transfer in 

WinCC flexible. 
2 Select your HMI device from the "Device 

type" list box. 
Select your HMI device via Project > 
Change Device Type. 

3 -- Change to Project > Transfer > Transfer 
Settings in WinCC flexible. 

4 Select the "MPI / PROFIBUS-DP" option in 
the "Connection" list box. 

Select the "MPI/DP" option in the "Mode" 
list box. 

5 In "Connection Parameters", enter the OP 
address of the HMI device. 
(The OP address is the PROFIBUS address 
of the HMI device). 

Enter the station address of the HMI 
device.  
(The OP address is the PROFIBUS 
address of the HMI device). 

6 -- Confirm your entries with "Apply". 
7 Close ProSave or change to the "Options" 

tab to transfer the WinAC MP runtime files.  
Please make sure that the correct path is 
set. 

Change to Project > Transfer > Options in 
WinCC flexible to transfer the WinAC MP 
runtime files.  
Make sure that the correct path is set. 

8 Click the ">>" button. Click the ">>" button. 
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3.3.2.4 Transfer via USB 

Connecting over USB    
Connect the USB port of the configuration PC with the USB port of the HMI device using a 
USB cable.  

 

 Note 
USB connection parameters 
To use the USB connection, you require a master-master cable. Install the included "BULK 
driver" and not "Standard".  
You will find information on installing the "BULK driver" under the entry ID 
(http://support.automation.siemens.com/WW/view/en/19142034) 

 

Settings on the HMI device 
1. Open the Control Panel in the Loader.   
2. Double-click "Transfer". 
3. Under Channel 2, select "USB", select "Enable Channel" and  

confirm with "OK". 

Setting on the configuration PC 
Take the following steps on the configuration PC either in ProSave or in WinCC flexible: 
 
Step Connecting ProSave Connecting WinCC flexible 
1 Open the "General" tab in ProSave. Open the project you want to transfer in 

WinCC flexible. 
2 Select your HMI device from the "Device 

type" list box. 
Select your HMI device by selecting 
Project > Change Device Type. 

3 -- Change to Project > Transfer > Transfer 
Settings in WinCC flexible. 

4 Select the "USB" option in the "Connection" 
list box. 

Select the "USB" option in the "Mode" list 
box. 

5 -- Confirm your entries with "Apply". 
6 Close ProSave or change to the "Options" 

tab to transfer the WinAC MP Runtime files.  
Make sure that the correct path is set. 

Change to Project > Transfer > Options in 
WinCC flexible to transfer the WinAC MP 
Runtime files.  
Make sure that the correct path is set. 

7 Click the ">>" button. Click the ">>" button. 

http://support.automation.siemens.com/WW/view/en/19142034
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3.3.2.5 Transfer using automatic transfer detection 

Application 
Using automatic transfer detection, you can transfer projects from the configuration computer 
to the HMI device without needing to change the HMI device to transfer mode. Automatic 
transfer detection is useful when the configuration computer and the HMI device are located 
at some distance apart. 

 

WARNING  
Death, serious injury and/or damage to equipment possible 
If you select "Automatic transfer detection", you transfer the files while WinAC MP is 
operating! 
If WinAC MP is connected to inputs/outputs, an interruption in the operation of WinAC MP 
can lead to death, serious injury and/or damage to equipment. 
Make sure of the following when transferring: 
• Only qualified personnel have access to the configuration computer! 
• All devices must be in a safe state before the transfer is started. 
• Always install an EMERGENCY STOP circuit for your machine or process. 

 

Prerequisites for automatic transfer detection  
● WinCC flexible Runtime must be running on the HMI device. The HMI device cannot 

automatically toggle to "automatic transfer detection" if WinCC flexible Runtime is not 
running. 

● All dialogs on the HMI device must be closed. 

Settings on the HMI device 
Make the following settings in the Control Panel on the HMI device: 
 
Step Settings in the Transfer 
1 Select "Channel 2", the type of connection, and then select "Enable Channel" and 

"Remote Control". 
2 Confirm with "OK" and start WinCC flexible Runtime on the HMI device. 
3 Start the transfer with WinCC flexible on the configuration computer. 

Once the transfer has started, WinCC flexible Runtime is automatically closed on the HMI 
device and then restarted. 

Further Information 
For more information on working with the functions in WinCC flexible, refer to the 
documentation on WinCC flexible. 
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3.3.3 Transferring WinAC MP to the HMI device 

Transferring WinAC MP Runtime files   
To be able to operate WinAC MP on the HMI device, you will need to download the 
WinAC MP option from the configuration PC to the HMI device.  
To do so, follow these steps: 
1. Boot your HMI device and press the "Transfer" button in the Loader. 

Result: The message "Connecting to host" appears on the HMI device. 
 

NOTICE 
 

 

In the Control Panel, make sure that you have enabled the transfer for the interface you 
intend to use. 
This is explained step-by-step in the sections: 
• Transfer over Industrial Ethernet (Page 21)  
• Transfer over PROFIBUS (Page 23)  
• Transfer via USB (Page 24)  
• Transfer using automatic transfer detection (Page 25)  

2. Open ProSave on the configuration PC. 
3. Select the type of HMI device in the "General" tab in ProSave. 
4. In the "Connection" list box, select the connection type: 

– Ethernet 
– MPI/PROFIBUS-DP 
– USB 

5. Enter the connection parameters: 
– Ethernet: IP address or computer name; recommendation: as the fastest and most 

flexible connection 
– PROFIBUS: OP address (same as the PROFIBUS address) 
– USB 

 

 
 Note 

USB connection parameters 
To use the USB connection, you require a master-master cable. Install the included 
"BULK driver" and not "Standard".  
You will find information on installing the "BULK driver" under the entry ID 
(http://support.automation.siemens.com/WW/view/en/19142034)  

6. Go to the "Options" tab and click "Device status". 
Result: The communication connection is checked.  
– If "WinAC MP" is not shown in the box with the available options, check the path in 

"Selection".  
You will find the application in: 
...\Programs\Mutual Files\Siemens\PTProSave\AddOn\WinAC MP 2008 

7. Select the required folder. 
8. Click the download button ">>" to transfer the option to the HMI device (you will see any 

options that are already installed in the "Installed Options" box). 
9. After the transfer was completed, a dialog opens on the HMI device requesting you to 

reboot. Reboot the HMI device. 
Result: WinAC MP is now installed on the HMI device.  

To obtain an operator interface to the HMI device, you still need to download (transfer) a 
WinCC flexible project. 

http://support.automation.siemens.com/WW/view/en/19142034
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See also 
Basics of transfers (Page 20) 

3.3.4 Licensing WinAC MP on the HMI device 

Software license   
WinAC MP requires a product-specific License Key that you install with Automation License 
Manager. 

 

 Note 
The product-specific License Key of WinAC MP 2007 V4.0 is compatible with 
WinAC MP 2008 V4.1. 

 

Transferring a License Key 
With the Automation License Manager, you can transfer a License Key from a computer to 
an HMI device.  
When transferring License Keys between different locations (media), you have the following 
options:  
● Transferring the license from the configuration PC to the HMI device with the Automation 

License Manager 
● using drag-and-drop 
● Cut and paste 
● The License Key > Transfer menu command. 

Transferring the license from the configuration PC to the HMI device with the Automation License 
Manager    

1. Open the Automation License Manager with Start > SIMATIC > License Management > 
Automation License Manager. 
Result: The Automation License Manager opens. 

2. Select Edit > Connect Target Systems > Connect HMI Device to open the "Connect 
Target System" dialog. Select the HMI device and the type of connection. 

3. In the Automation License Manager, select the license you want to transfer and  
select "Transfer..." with the right mouse button. 

4. Select the HMI device to which you want to transfer the license as the target computer. 
Result: The license for WinAC MP is on the HMI device 
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Transferring a License Key with drag-and-drop 
1. Select the view with the View > Manage menu command. 
2. Open the storage location on your own computer or on a connected computer from which 

you want to remove the License Key. 
3. Select the License Key, hold down the left mouse button and drag the License Key to the 

target location. 
Result: The License Key is transferred. 

Transferring the License Key with cut and paste 
1. Select the view with the View > Manage menu command. 
2. Open the storage location on your own computer or on a connected computer from which 

you want to remove the License Key. 
3. Select the License Key you want to transfer. 
4. Select Edit > Cut. 
5. Open the storage location on your own computer or on a connected computer to which 

you want to transfer the License Key. 
6. Select the Edit > Paste menu command. 

Result: The License Key is transferred. 

Transferring the License Key with the License Key > Transfer menu command: 
1. Select the License Key you want to transfer to another storage location. 
2. Open the "Transfer License Key" dialog with the License Key > Transfer menu command. 
3. Select the target drive from the drop-down list box. 
4. Click "OK" to confirm the selection. 
5. Click the "Network..." button if the target drive is on another connected computer. 

The "Connect Computer" dialog opens. 
6. Enter the computer name or select the required computer from the drop-down list box or 

– Click the "Browse..." button to access the "Find Computer" dialog. 
– Click "Entire Network" and then "Microsoft Windows Network". 
– If the computer is in a domain, select the domain. 
– Then select the required computer and click "OK" to confirm your selection. Please 

remember that the Automation License Manager must also be installed on the 
computer you select. 

 

 
 

Note 
The backup function saves all data of the panel to the specified external storage 
medium. The data in retentive memory is excluded. 
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Further Information 
For more information on this, please refer to the following Online Help: 
● Automation License Manager 
● ProSave 

3.4 Steps when removing 

3.4.1 Retransferring license keys 

Transferring a License Key 
With the Automation License Manager, you can transfer a License Key from a computer to 
an HMI device.  
To transfer License Keys between different locations (media), you have the following 
options:  
● using drag-and-drop 
● Cut and paste 
● The License Key > Transfer menu command. 

Transferring a License Key with drag-and-drop 
1. Select the view with the View > Manage menu command. 
2. Open the storage location on your own computer or on a connected computer from which 

you want to remove the License Key. 
3. Select the License Key, hold down the left mouse button and drag the License Key to the 

target location. 
Result: The License Key is transferred. 

Transferring the License Key with cut and paste 
1. Select the view using the View > Manage menu command. 
2. Open the storage location on your own or on the connected computer from which you 

want to remove the License Key. 
3. Select the License Key you want to transfer. 
4. Select Edit > Cut. 
5. Open the storage location on your own computer or on a connected computer to which 

you want to transfer the License Key. 
6. Select the Edit > Paste menu command. 

Result: The License Key is transferred. 
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Transferring the License Key using the License Key > Transfer menu command: 
1. Select the License Key you want to transfer to another storage location. 
2. Open the "Transfer License Key" dialog by selecting the License Key > Transfer menu 

command. 
3. Select the target drive from the drop-down list box. 
4. Click "OK" to confirm the selection. 
5. Click the "Network..." button if the target drive is on another connected computer. 

The "Connect Computer" dialog opens. 
6. Enter the computer name or select the required computer from the drop-down list box 

– Or click the "Browse..." button to access the "Find Computer" dialog. 
– Click "Entire Network" and then "Microsoft Windows Network". 
– If the computer is in a domain, select the domain. 
– Select the required computer and click "OK" to confirm your selection. Please 

remember that the Automation License Manager must also be installed on the 
computer you select. 

7. Click "OK" to confirm your selection and to close the dialogs. 

Retrieving the License Key if the hard disk is defective 
If a fault has occurred on the hard disk or the USB containing your License Key file, contact 
your Siemens representative (http://support.automation.siemens.com). Make sure you have 
your license certificate to hand when you contact this representative. 

http://support.automation.siemens.com/
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3.4.2 Uninstalling WinAC MP on the HMI device 

Notes on removing 
After having removed WinAC MP, you must reboot the HMI device. 

Removing   
To uninstall WinAC MP Runtime files on the HMI device, follow the steps below: 
1. Exit WinCC flexible Runtime. 
2. Select transfer mode in the "Loader" dialog box on the HMI device. 
3. Open the "Options" tab in ProSave on the configuration PC. 
4. Select the "Device Status" button in the "Options" tab to read the WinAC MP Runtime 

files on the HMI device. The Runtime files are displayed in the right-hand pane "Installed 
Options". 

5. In the right-hand pane "Available Options", select the WinAC MP option and click the "<<" 
button to remove the WinAC MP Runtime files from the installed options for the HMI 
device. The WinAC MP Runtime files are then deleted on the HMI device. 

6. Answer the prompt to restart on the HMI device (select "Yes" if you want to restart 
immediately, select "No" if you want to restart later). 

Once you have uninstalled the WinAC MP Runtime files on the HMI device, you can exit 
ProSave.  

 

 Note 
WinAC MP cannot be removed from the HMI device via PROFIBUS. 

3.4.3 Uninstalling WinAC MP on the configuration PC 

Removing 
To uninstall WinAC MP on the configuration PC, follow these steps: 
1. Open the Control Panel with Start > Settings > Control Panel in the Start menu of the 

configuration PC. 
2. Double-click on "Add or Remove Programs" in the detailed view. 
3. Select the "SIMATIC WinAC MP 2008 V4.1.1" entry. 
4. Click the "Remove" button. 
5. Confirm that you want to uninstall by clicking "Yes". 
6. Click "OK when the software has been uninstalled. 
Result: WinAC MP has been uninstalled on the configuration PC. 
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STEP 7 configuration and communication options 4
4.1 Standard procedure for communication with WinAC MP 

Overview 
The section below shows how to configure WinAC MP in a SIMATIC HMI station using a 
configuration PC on which STEP 7 and WinCC flexible are installed. 
The configuration PC and WinAC MP in a SIMATIC HMI station are interconnected via 
PROFIBUS DP. Configuration via Ethernet is also possible. You will find the description of 
the procedure in the section Configuring an Ethernet connection for routing functionality over 
the HMI device (Page 47). 
You can integrate DP slaves for WinAC MP in the STEP 7 project as shown in the figure. 

 

Procedure 
The basic steps are as follows: 
1. Configuring WinAC MP in STEP 7 
2. Creating a connection between WinAC MP and WinCC flexible Runtime 
3. In STEP 7, download the configuration to the WinAC MP 
4. Configuring (visualization) HMI objects with WinCC flexible. 
5. Download the visualization configuration (for example, visualization with histogram) from 

WinCC flexible to the HMI device. 
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See also 
Setting the communication functions for the configuration PC (Page 47) 

4.2 Creating a STEP 7 project for WinAC MP 

4.2.1 Configuring the SIMATIC HMI station and the PROFIBUS-DP network 
To see how easy it is to configure WinAC MP, view the short info film on the Internet 
(http://support.automation.siemens.com/WW/view/en/32010673). 

Configuring a SIMATIC HMI station     
To create a new project for WinAC MP, proceed as follows: 
1. Select File > New in the SIMATIC Manager and enter a project name. 
2. Select your project and create an HMI station with Insert > Station > SIMATIC HMI 

Station. 
 

 

http://support.automation.siemens.com/WW/view/en/32010673
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3. In the "Properties - WinCC flexible RT" dialog box that then opens, select the Multi Panel 
you are using and confirm with "OK". 
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4. Double-click the SIMATIC HMI station in the SIMATIC Manager. The configuration is then 
displayed in the right-hand pane. 

5. Double-click "Configuration". Result: HW Config opens. 

 
6. Delete "HMI IE" and "IF1B MPI/DP". 

 
7. In the hardware catalog, go to the SIMATIC HMI Station > Controller > WinAC MP folder 

and, depending on the Multi Panel selected under item 3, select: 
– WinAC MP 177->6ES7 671-4EE00-0YA0->V4.1 for WinAC MP 177, or 
– WinAC MP 277->6ES7 671-5EF01-0YA0->V4.1 for WinAC MP 277, or 
– WinAC MP 377->6ES7 671-7EG01-0YA0->V4.1 for WinAC MP 377 

8. Drag WinAC MP to slot 2. 
Result: The "Properties - Ethernet Interface" dialog opens. 
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9. Enter the IP address and subnet mask. 
10. Create a new subnet and close the dialogs. 

Result: The "Properties – PROFIBUS interface DP" dialog opens. 
11. If necessary, change the PROFIBUS address of WinAC MP and create a new subnet. 

 
12. Set the transmission speed in the network settings. Close the dialogs. 
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13. Save in HW Config with Station > Save and Compile. 

 
14. Close HW Config. 
You have now created the SIMATIC HMI station with WinAC MP in your STEP 7 project.  

See also 
Communication options with WinAC MP (Page 53) 
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4.2.2 Creating a connection between WinAC MP and WinCC flexible Runtime on the 
HMI device 

Creating a connection between WinAC MP and WinCC flexible RT 
Follow the steps outlined below to create a connection between WinAC MP and WinCC 
flexible Runtime: 
1. Right-click WinCC flexible RT in SIMATIC Manager and select: Object > Open 

Result: WinCC flexible opens. 

 
2. Double-click "Connections" in the WinCC flexible project window. 

Result: The "Connections" editor opens. 
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3. Change the value to "On" in the "Active" column. 
Result: A local connection between WinCC flexible RT and WinAC MP is created. 

 
4. Save and compile the WinCC flexible project. Close WinCC flexible. 

 

 
 

Note 
Always configure the connections (local and routing) between WinCC flexible RT and 
WinAC MP or other controllers (e.g. S7-300/400) in the "Connections" editor of 
WinCC flexible. 
Connections between WinAC MP and other controllers (e.g. S7-300/400) are always 
configured in NetPro of SIMATIC Manager. 

 

See also 
Transferring WinAC MP to the HMI device (Page 26) 
Licensing WinAC MP on the HMI device (Page 27) 
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4.2.3 Time synchronization WinAC MP 

Time synchronization 
You can synchronize the WinAC MP time with the operating system of the HMI device. 
How to set time synchronization in HW Config: 
1. Select WinAC MP x77 in the SIMATIC HMI station. 
2. Open the object properties with the right mouse button. 
3. Go to the "Diagnostics/Clock" tab. 
4. To synchronize the WinAC MP time with the HMI device, set the synchronization mode 

on the AS to "As slave". 
5. Confirm with "OK". 

 
 

 
 

Note 
When synchronization is enabled, the time is compared at a fixed interval of one second. 
If the difference between the Panel time and the WinAC MP time is more than 0.5 
seconds, WinAC MP takes the time of the Panel. 

 

Further Information 
For more information on the tabs, refer to the STEP 7 online help and the documentation on 
the standard CPUs. 
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4.2.4 Configuring retentive data 

 Retentive data 
Data is kept in retentive memory following POWER OFF and restart or a warm restart.  
You can set the retentivity of bit memory, timers, counters and data blocks. The next time 
you start WinAC MP or following a power outage on the HMI device, the buffered data is 
available again. 

Behavior following image update   
After an OS update or backup/restore on the MP 177, MP 277, or MP 377 with 
WinAC MP installed, the retentive data areas of WinAC MP are completely deleted. 

Configuring retentivity for memory bytes, S7 timers, S7 counters     
 

 Note 
With MP 177, MP 277 and MP 377, all bit memories, timers and counters can be saved 
retentively. 

 

Follow the steps below to configure the retentive data for WinAC MP: 
1. Select WinAC MP x77 in the SIMATIC HMI station. 
2. Open the object properties with the right mouse button. 
3. Go to the "Retentive Memory" tab. 
4. Enter the number of memory bytes starting at MB 0, S7 timers starting at T0 and S7 

counters starting at C0 that you want to be retentive. 
5. Confirm with "OK". 

 
Figure 4-1 Properties of memory bytes, S7 timers, S7 counters 
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Configuring retentivity for data blocks  
 

 Note 
With MP 177, MP 277 and MP 377, you have the following memory available for retentive 
DBs:   
• MP 177: 64 KB 
• MP 277: 128 KB 
• MP 377: 256 KB 

 

The content of data blocks is always retentive unless it was created with SFC 85.  
You can change the retentivity in the properties of the data block in STEP 7 using the "Non-
Retain" check box. A data block with the "Non-Retain" property is not stored in the retentive 
memory and is therefore reset to the initial load values following every power cycle and cold 
or warm restart and following every change from STOP to RUN.  
A data block with the "Non-Retain" property occupies work memory as usual but takes up no 
retentive memory. 

 
Figure 4-2 Data block properties 

Further Information 
For more information on the tabs, refer to the STEP 7 online help and the documentation on 
the standard CPUs. 
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4.2.5 WinCC flexible direct keys in WinAC MP 

Definition   
Direct keys on the HMI device are used to set bits in the I/O area of the controller. 

WinCC flexible direct keys in WinAC MP 2008   
WinCC flexible supports: 
● Direct keys for key input, required, for example for inching mode 
● LED displays with short reaction times 
It is not necessary to configure the direct keys for WinAC MP.  
The direct key bits are always available through I/O direct accesses to the I/O area, 
beginning with address 4000H or 16384D. 
The following table lists the direct key ranges:   

 
 Input range 

Hexadecimal 
Input range 

decimal 
Output range 
Hexadecimal 

Output range 
decimal 

MP 177 6"Touch 4000H – 4003H 16384 - 16387 -- -- 
MP 277 8" Key 4000H – 4004H 16384 - 16388 4000H – 4004H 16384 - 16388 
MP 277 8" Touch 4000H – 4004H 16384 - 16388 -- -- 
MP 277 10" Key 4000H – 4004H 16384 - 16388 4000H – 4004H 16384 - 16388 
MP 277 10" Touch 4000H – 4004H 16384 - 16388 -- -- 
MP 377 12" Key 4000H – 4004H 16384 - 16388 4000H – 4004H 16384 - 16388 
MP 377 12" Touch 4000H – 4004H 16384 - 16388 -- -- 
MP 377 15" Touch 4000H – 4004H 16384 - 16388 -- -- 
MP 377 19" Touch 4000H – 4004H 16384 - 16388 -- -- 
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Input/output assignment for MP 277-8" (key) 

 

Input/output assignment for MP 277-10" (key) 

 

Input/output assignment for MP 377 (key) 

 

Input/output assignment for MP 177 6" Touch 
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Input/output assignment for MP 277 8" touch, MP 277 10" touch, MP 377 touch 

 
 

WARNING  
Triggering the system function "DirectKey" by mistake leads to the endangerment of 
persons or damage to the machine. 
In order to avoid this danger, the following must be observed: 
When configuring the process screen, the button with the system function "DirectKey" must 
not be covered by a screen object. 
The dynamic positioning or display (enable) of a screen object dependent on process 
values must not lead to the button with the system function "DirectKey" being overlapped in 
runtime. 
Please observe this guideline during configuration. Check also existing configurations and 
adjust them immediately. 

 

WARNING  
If you set the connection to WinAC MP "offline" using the "SetConnectionMode" system 
function, the communication connection to WinAC MP is disconnected. The DP direct keys 
are still active in this case. If you press a key with the "DirectKey" system function in 
"offline" mode or press the direct key on a key device, the corresponding bit is set in WinAC 
MP. 

 

Further Information 
Further information: 
● You can find more information in the Operating Instructions of the MP 177, MP 277 and 

MP 377 HMI devices in the section: Bit assignment of the direct keys 
● in the User Manual Communication Part 1 
● in the STEP 7 online help 



 STEP 7 configuration and communication options 
 4.3 Configuring an Ethernet connection for routing functionality over the HMI device 

WinAC MP 2008 
Operating Instructions, 03/2009, A5E00981151-02 47 

4.3 Configuring an Ethernet connection for routing functionality over the 
HMI device 

4.3.1 Setting the communication functions for the configuration PC 

Communication settings 
You have the following communication options for connecting STEP 7 on the configuration 
computer with the HMI device: 
● Industrial Ethernet 
● PROFIBUS 
No serial communication or USB communication is possible with STEP 7. 

See also 
Transfer over Industrial Ethernet (Page 21) 
Transfer over PROFIBUS (Page 23) 
The following settings are necessary if you want to use routing. 

Configuring hardware   
If you work with an Ethernet connection (TCP/IP), you will need to take additional steps in 
HW Config. Follow the steps below to set a static IP address for TCP/IP communication 
between STEP 7 and the HMI device:   
1. Click on your project in the SIMATIC Manager and select Insert > Station > PG/PC. 

Result: A new PG/PC station is inserted. 

 
2. Double-click on "PG/PC". 

Result: The "Properties PG/PC" dialog opens. 
3. Click the "Interface" tab to open it and click on "New". 

Result: The "New Interface - Type Selection" dialog opens. 
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4. In the "New Interface - Type Selection" dialog, select the type "Industrial Ethernet" and 
confirm with "OK". 
Result: The "Properties - Ethernet Interface" dialog is displayed. 

 
5. Enter the IP address of the configuration PC in the "IP address" box. 
6. Select an Ethernet subnet as the subnet. If this does not already exist, select "New". The 

"Properties - New subnet Industrial Ethernet" dialog box opens. Select "OK". A new 
Ethernet subnet is created. 

7. Select "OK" to complete the configuration of the Ethernet interface. 
Result: The subnet is now selected in the "Properties - Ethernet Interface" dialog. 
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8. Confirm with "OK". 
Result: The "Properties - PG/PC" dialog appears again. 

 
9. Click "OK" to close the "Properties PG/PC" dialog. 

Further Information 
For more information on Ethernet communication and setting up Ethernet networks, refer to 
the SIMATIC NET Ethernet User Manual.  

4.4 Checking and downloading a STEP 7 project to WinAC MP 

4.4.1 Checking the WinAC MP online connection 

Checking the connection with STEP 7 
Once you have completed the network configuration, check whether the connection between 
STEP 7 and WinAC MP is functioning. You can do this by selecting View > Online or PLC > 
Display Accessible Nodes in the SIMATIC Manager. 
If the network configuration is not online, review the network configuration steps described in 
the sections above and correct any errors you may have made. 
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4.4.2 Downloading the configurations 

Downloading hardware configuration   
To download the hardware configuration to WinAC MP, you first set the PG/PC interface  
for the connection on the configuration PC:  
PROFIBUS or Ethernet (TCP/IP). 

Setting the PG/PC interface   
Follow the steps outlined below to set the PG/PC interface: 
1. In the SIMATIC Manager, select Options > Set PG/PC Interface from the menu. 
2. Check that the required type of connection is entered in the "Interface parameter 

assignment used" box. If necessary, select the required interface from the list box. You 
can choose between the TCP/IP option or a CP with a PROFIBUS DP bus profile (for 
example CP5611). 

3. Set the properties for the interface parameter assignment to match your type of 
connection: 
– Industrial Ethernet (TCP/IP): Recommendation: the fastest and most flexible 

connection 
– PROFIBUS: Set the transmission rate for the first download to 1.5 Mbps and use a DP 

interface. This is the default for the HMI device. 
4. Confirm the setting with "OK". 

Check the following points before you download the configuration: 
– Make sure that WinAC MP has started on the HMI device. Start  

WinCC flexible Runtime and WinAC MP. 

Setting up a subnet for Industrial Ethernet   
Before WinAC MP can communicate over Industrial Ethernet, you will need to set up a 
subnet.  
You do this by configuring the SIMATIC HMI station, as follows: 
1. In the "Parameters" tab of the "Properties - PROFIBUS Ind. Ethernet" dialog, enter the  

IP address. The subnet mask is preset. 
 

 
 

Note 
Closed "Properties - Ind. Ethernet" dialog 
If this dialog is closed, double-click the "Ind. Ethernet" field in the SIMATIC station. Click 
the "Properties" button to open the "Properties Ethernet Interface" dialog box. 

 

2. Click "New" in the "Parameters" tab. 
3. Click "OK" three times to confirm. 
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Setting up a subnet for PROFIBUS DP   
To allow WinAC MP to communicate with the distributed I/O, you will need to set up a 
PROFIBUS/DP subnet. Configure the SIMATIC HMI station as a  
DP master: 
1. In the "Parameters" tab of the "Properties - PROFIBUS Interface DP" dialog, enter the 

node address for WinAC MP. The default address for the DP master is 2. Each node in 
the network must have a unique node address between 1 and 126. 

 

 
 

Note 
Closed "Properties - PROFIBUS Interface DP" dialog 
STEP 7 displayed the "Properties - PROFIBUS interface DP" dialog when you dragged 
WinAC MP to slot 2.  
If this dialog is closed, double-click the "DP" field in the SIMATIC station. Click the 
"Properties" button to open the "Properties DP" dialog box. 

 

2. Click "New" in the "Parameters" tab. 
3. Open the "Network Settings" tab. Check the following settings and make any changes 

necessary: 
– Highest PROFIBUS address: This can be set lower to increase the query rate if you 

are sure that you will not exceed a certain number of stations. 
– Transmission rate: The default is 1.5 Mbps, but up to 12 Mbps are possible depending 

on the requirements and application. 
– Profile: The default is DP. 

4. Click "OK" three times to confirm. 

Downloading WinAC MP   
To download the WinAC MP configuration to the HMI device, follow these steps: 
1. Select PLC > Download to Module in HW Config on the configuration PC to download the 

configuration of the STEP 7 project. 
2. In the "Select target module" dialog box, select WinAC MP x77 and confirm with "OK". 
3. Select the station address. 
4. When using PROFIBUS connections, enter the node address of the HMI device: The 

default address of the HMI device is PROFIBUS 2. 
If you are using Ethernet connections, make sure that the IP address of the HMI device is 
correct and confirm with "OK". 
Result: STEP 7 downloads the hardware configuration to WinAC MP and sets 
PROFIBUS DP on the HMI device for the PROFIBUS interface. A dialog box is displayed 
indicating whether or not the download was successful. 

If you have used an Industrial Ethernet connection to the HMI device, you can continue to 
download to the HMI device over Ethernet and do not need to make any changes in  
"Set PG/PC interface" in STEP 7. 
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Downloading WinCC flexible Runtime   
To download the WinCC flexible runtime configuration to the HMI device, follow the steps 
below: 
1. Click on your project in WinCC flexible. 
2. Select Project > Transfer > Transfer Settings. 
3. Select the target and communication connection and confirm with "Transfer". 

 
Figure 4-3 Selecting transfer 

Further Information 
For more information on PROFIBUS communication and setting up  
PROFIBUS networks, refer to the SIMATIC NET PROFIBUS User Manual. 
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4.5 Communication options with WinAC MP 

Definition of routing   
If there are stations in an automation system that are not connected to the same bus, these 
stations cannot be accessed directly online. To establish a connection to these devices, a 
router must be included between them.  
An MP x77 HMI device with WinAC MP can function as the router. As a router, it connects 
the Ethernet and PROFIBUS networks. 
You can use routing, for example, to do the following: 
● Download STEP 7 user programs 
● Download a hardware configuration 
● Run debugging and diagnostic functions. 

Definition: Softbus   
Virtual bus that allows a data exchange between WinCC flexible runtime and WinAC MP. 
This bus is installed when you install WinCC flexible. After installing WinAC MP, S7 
connections from WinCC flexible Runtime to external stations on PROFIBUS or Ethernet are 
routed over Softbus. 
Prior to installation of WinAC MP (without Softbus) 
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After installation of WinAC MP (with Softbus) 

 

Routing from Ethernet to PROFIBUS DP with WinAC MP 
With STEP 7 on Industrial Ethernet, you can access all nodes on PROFIBUS DP from the 
HMI device. 
With WinCC flexible, you can access the HMI device but not the nodes connected over 
PROFIBUS DP. 
If the configuration PC is not connected directly to PROFIBUS DP, the nodes on PROFIBUS 
can nevertheless be reached because the MP x77 HMI device serves as a router. 

 
Figure 4-4 Routing from Ethernet to PROFIBUS DP with WinAC MP 
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Routing from PROFIBUS DP to Ethernet with WinAC MP 
With STEP 7 on PROFIBUS DP, you can access all nodes on Industrial Ethernet from the 
HMI device. With WinCC flexible on PROFIBUS DP, you have access to the HMI device and 
to OPs connected over PROFIBUS DP.  

 
Figure 4-5 Routing with WinAC MP over PROFIBUS 

Visualization over WinAC MP 
Visualization over the HMI device between Industrial Ethernet and PROFIBUS DP is 
possible with WinCC flexible. 
It is not necessary to program the communication links. A PC serves as the visualization 
platform. 

 
Figure 4-6 Visualization over WinAC MP 



STEP 7 configuration and communication options  
4.5 Communication options with WinAC MP 

 WinAC MP 2008 
56 Operating Instructions, 03/2009, A5E00981151-02 

CPU-CPU communication over WinAC MP 
CPU-CPU communication is possible with the HMI device. 

 
Figure 4-7 CPU-CPU communication over WinAC MP 

See also 
Configuring the SIMATIC HMI station and the PROFIBUS-DP network (Page 34) 
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Controlling a process with WinAC MP 5
5.1 Integrating the WinAC MP System Library 
 

 Note 
The screens from the system library are optimized for 6'' displays with a resolution of 320 x 
240. If using a display with a different size you can adjust the screens accordingly in WinCC 
flexible. 

 

Integrating the new WinAC System Library 
To create a WinACMP project with the help of WinAC MP System Library you must take the 
following steps: 
1. Configure the SIMATIC HMI station and the PROFIBUS-DP network. 

Corresponding procedures is described in chapter: Configuring the SIMATIC HMI station 
and the PROFIBUS-DP network (Page 34)  

2. Open the project in STEP 7 by selecting File > Open 
3. To open WinCC flexible, go to SIMATIC Manager, select "WinCC flexible RT" and right-

click "Open Object". 
4. Open Tools > Library. 
5. In the work space of the library window, right-click: Library... > Open 

 
6. The "Open global library" dialog box opens. 
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7. Navigate to the following path: 
C:\Programs\SIEMENS\SIMATIC WinCC flexible\WinCC flexible Support\Libraries\ 
system libraries or click the system libraries icon on the left side in order to access the 
directory. 

 
8. Select the WinCC flexible library "WinAC_MP_2008.wlf". 

Result: The library objects "WinAC_MP_Home" and WinAC_MP_Tuning" were created 
within Library -> View tools. 

9. Drag the library object from the work space of the library window to the position where 
you want to insert it in the work space. 

 
10. To open the screen for editing, go to the WinCC flexible project window. 
11. Select a project: Project > Screens > WinAC_MP_Home or 

Project > Screens > WinAC_MP_Tuning 
12. Double-click the screen or select "Open editor" from the shortcut menu. 

Result: The screen is opened for editing in the work space. 
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5.2 Description of the Home Screen and the Tuning Screen 

5.2.1 Description of the Home screen 

Display of the Home Screens   

 
Figure 5-1 Home Screen 
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The Home Screen contains the following elements: 
● Buttons for the operating functions of the WinAC MP 

– Start: Start 
– Shutdown: Closing and exiting 
– Autostart: if the autostart function is enabled, WinAC MP changes after startup (e.g. 

the start-up of the HMI device) to the RUN or STOP mode where it was prior to closing 
– StartAtBoot: autostart at the startup of the MP device 
– Restore: Restore 
– Archive: archiving the STEP 7 user program and WinAC MP system configuration 

● Buttons for functions 
– Tuning >>: Changing to the Tuning screen 
– Exit: is freely configurable with WinCC flexible functions (e.g. hotkeys), e.g. return to 

start screen 
● Mode selector switch (RUN, STOP) 
● Status indicators for WinAC MP 
● MRES button for CPU memory reset 
● Display of the WinAC MP version 

Multi Panel variants 
● MP x77 Touch: You work in the screen by pressing the buttons in the display. 
● MP x77 Key: Each function key can be configured with a hotkey. 

Further information 
For more detailed information on the buttons, refer to the Assignment of the function keys 
(Page 63) section  
For information on how to configure the Hotkeys for WINAC MP, refer to the Operating 
WinAC MP with hotkeys (Page 63) section. 
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5.2.2 Description of the Tuning screen 

Tuning Screen   
You can find histogram information on the cycle time of WinAC MP in the Tuning Screen 
screen. The histogram shows the percentage distribution of the measured cycle times. To 
acquire these values, WinAC MP measures the cycle time after each cycle and counts the 
frequency with which the individual values occur. Each measured cycle time is displayed as 
a percentage relative to the total number of measured cycle times. The range around the 
average cycle time is always displayed. 
Based on the histogram, you can see the extent of the jitter. Multiple bars mean high jitter 
and indicate unsuitable settings for the HMI Enable Time. A bar with 100% is ideal. 

 
Figure 5-2 Tuning Screen 
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Tuning screen 
The Tuning Screen contains the following elements: 
● Buttons for the operating functions of WinAC MP 

– Clear: the recording of the cycle times is restarted 
● Buttons for functions 

– Home >>: Changing to the Home screen 
– Exit: freely configurable with WinCC flexible functions (e.g. hotkeys), e.g. return to 

start screen 
● Setting the HMI Enable Time in ms for the HMI device - HMI Enable Time 

Default setting: 50 ms 
● Display of the cycle time - Cycle Time [ms] 

– Last: Last cycle time 
– Avg: Average cycle time 
– Max: Maximum cycle time 
– Min: Minimum cycle time  

● Cycle time information (histogram) 

Further information 
For information on how to configure the Hotkeys for WINAC MP, refer to the Operating 
WinAC MP with hotkeys (Page 63) section. 
 

See also 
Composition of the cycle time  (Page 72) 
Setting the "HMI enable time" (Page 73) 
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5.3 Function key assignment based on the WinAC system library 

5.3.1 Operating the WinAC MP with hotkeys 

Introduction 
A hotkey specifies a key or key combination that can be used to actuate the button. 
You can assign different functions to the hotkeys for each one of the screens. This 
assignment applies only to the screen in which you have defined the button. 

 

NOTICE 
 If a screen of an alarm view or an alarm window is overlapped, then the function keys are 

still active in runtime. 

Requirement 
● The screen in which you want to assign a button is open. 
● The Properties window in WinCC flexible is open. 

Specify hotkey  
To do so, follow these steps: 
1. Select the desired button, for example STOP. 
2. Click on the "General" group in the Properties window. 
3. In the selection list in the "Hotkey" area, select a key or key combination for the hotkey 

with which the button will be actuated. 

 
4. If necessary, configure the button in the Properties window: 
Result: The button is assigned accordingly in the selected screen. 
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5.3.2 Starting WinAC MP - Start 

Requirements   
The following conditions must be met to start WinAC MP on the HMI device: 
● You have transferred the WinCC flexible Runtime project from the configuration PC to the 

HMI device and the project contains the two screens from the WinAC MP system library. 
● You have the option of transferring WinAC MP and the License Key from the 

configuration PC to the HMI device. 

Starting WinCC flexible Runtime on the HMI device 
1. Check that the HMI device is turned on. 
2. Press "Start" in the Loader. 

Result: WinCC flexible Runtime opens with the Home Screen on the HMI device. 

Starting WinAC MP 
The "StartAtBoot" function is enabled by default for WinAC MP and WinAC MP starts 
automatically after startup of the HMI device.  
If the "StartAtBoot" function is not selected, start WinAC MP as follows: 
1. To start WinAC MP, press "Start".  

Result: WinAC MP is running. 

5.3.3 Automatic WinAC MP startup - Autostart 
WinAC MP provides you with an Autostart function. When this is enabled, it allows the 
controller to be started in the same mode it was in before it was shut down:  
● Autostart = blue: Function activated: After WinAC MP starts up, WinAC MP changes to 

mode it was in before it was shut down.   
● Autostart = gray: Function not activated: WinAC MP remains in STOP when it starts up. 
 
WinAC MP mode on shut down Autostart Mode after starting 

No (gray) STOP STOP 
Yes (blue) STOP 
No (gray) STOP RUN 
Yes (blue) RUN 
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5.3.4 Automatic WinAC MP start when the HMI device boots - StartAtBoot 

Sequence from switching on the HMI device until WinAC MP changes to RUN   
The following screens show the sequence between power on of the HMI device and  
WinAC MP entering the RUN state.  

 

 Note 
Note on the "Autostart" function for the successive screen  
If autostart is enabled WinAC MP changes after startup either to RUN, or to STOP mode, 
wherever it was prior to closing. 

 

Basic sequence after turning on the HMI device 
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Detailed sequence after turning on the HMI device 
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Automatic WinAC MP start when the HMI device boots (StartAtBoot) 
You can configure WinAC MP so that it starts automatically once the HMI device has booted. 
To do this, click StartAtBoot. 
● StartAtBoot = blue: WinAC MP is started automatically when the HMI device boots 
● StartAtBoot = gray: WinAC MP is not started automatically when the HMI device boots 

To start WinAC MP manually, you first start the WinCC flexible project on the HMI device 
so that the Home Screenopens. Then click "Start" to confirm. 

See also 
Automatic WinAC MP startup - Autostart (Page 64) 

5.3.5 RUN and STOP modes 

Mode selectorh   
You can switch operating modes as follows using the mode selector: 
● RUN 
● STOP 
The mode selector switch on the WinAC MP Home Screen works similar to the manual 
mode selector switch on an S7 hardware controller.  

Control operating mode 
The mode describes the state of the CPU at any point of time. 
To control the operating mode, you have the following options: 
● Mode selector switch 
● Operation using STEP 7 

 

 
 

Note 
Status indicator shows a different mode than the mode selector switch 
Just as with a hardware CPU, the status indicators RUN and STOP show the current 
mode of WinAC MP.  
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Permissible functions during RUN or STOP  
The following table shows which functions are permitted during RUN or STOP: 
 
Switch setting    
RUN   • Downloading a STEP 7 user program to WinAC MP 

• Downloading individual blocks to WinAC MP. 
• Using STEP 7 to modify program variables. 
• Changing the operating state using STEP 7. 
• Memory reset using the Home Screen or using STEP 7 

 (if you reset WinAC MP memory, WinAC MP automatically changes to 
STOP). 

STOP   • Downloading a STEP 7 user program to WinAC MP 
• Downloading individual blocks to WinAC MP. 
• Using STEP 7 to modify program variables. 
• Memory reset using the Home Screen or using STEP 7. 
• Archiving and restoring a STEP 7 user program. 

Prohibited functions during RUN or STOP  
The following table shows which functions are prohibited during RUN or STOP: 
 
Switch setting    
RUN • Archiving and restoring a STEP 7 user program. 

STOP • It is not possible to change the operating mode with STEP 7. The mode 
selector switch has highest priority. 

 
 

NOTICE  
Priority of the operating modes 
If the mode selector switch has been used to change the mode to "STOP", you cannot use 
STEP 7 to change the mode to "RUN". 
⇒ The mode selector switch in "STOP" has highest priority.  
 
If the mode selector switch has been used to change the mode to "RUN", you can  use 
STEP 7 to change the mode to "STOP". 
⇒ The "STOP" mode has highest priority. 
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5.3.6 Memory reset with MRES 

How a memory reset works   
MRES works in the same way as a memory reset of a hardware CPU - all the WinAC MP 
settings are reset to the defaults:   
● The STEP 7 user program is deleted in the work memory and the load memory (OBs, 

DBs, FCs, FBs and system data). 
● The content of the memory areas (I, Q, M, T, and C) is reset to 0. 
● System settings are reset to their default values (for example, the size of process image 

areas and the size of the diagnostic buffer). 
● Deletes all active communications jobs and all open communications. 
● All online connections are disconnected, for example, STEP 7, WinCC, WinCC flexible, 

PROFIBUS or S7 communication. 

When do you need to reset memory? 
You should reset WinAC MP memory before you download a new STEP 7 user program to 
WinAC MP. 
You must perform a memory reset if the STOP indicator in the Home Screen is flashing.  
Possible causes are: 
● Errors have been detected in the work memory, for example, the size of the STEP 7 user 

program exceeds that of the work memory. 
● WinAC MP was turned off and on again as a result of an error. 

How do I reset memory? 
There are several ways of resetting WinAC MP memory: 
● In the "Home Screen", press the "MRES" button . 

 

 
 

Note 
After having pressed the MRES button on the HMI device, you are requested confirm the 
CPU memory reset. Confirm this dialog. 

 

● Reset memory from the SIMATIC Manager of STEP 7. 
The STOP display flashes during the memory reset.  
Result: WinAC MP has been reset to its initial status. 
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5.3.7 Status indicators 

Meaning of the status indicators   
The status displays on the Home Screen indicate the current operating state and support 
troubleshooting. These status indicators correspond to the LED displays on an S7 hardware 
PLC. 
You cannot change the status of WinAC MP by touching the status indicators. 

Status indicators 
 
Display  Description 
ON   Lit when WinAC MP has started up (Start).  

Not lit if WinAC MP was switched off (Shutdown). 
INTF   Internal error 

This display lights up when an error condition occurs in WinAC MP, for example, a 
programming error, arithmetic error, timer error or counter error. 
If the STEP 7 user program handles the error by executing OB 80 or OB 121, the INTF 
indicator goes off after 3 seconds if there is no follow-on error condition. 

EXTF   External fault. 
This display lights up when a fault or error condition occurs outside of WinAC MP, for 
example, a hardware fault, parameter error, communication error or I/O fault. 
If the STEP 7 user program handles the error by executing OB 122, the EXTF indicator 
goes off after 3 seconds if there is no follow-on error condition. 

BUSF   Bus fault 
This indicator flashes if there is an error in communication with the distributed 
PROFIBUS I/O. 

RUN    Lights up according to the operating mode (RUN or STOP). 
STOP When RUN is flashing and STOP is lit (steady), the control program has reached a 

breakpoint (RUN flashes) or the control is starting up. 
Note: The displays RUN and STOP show the actual operating mode of the controller. 
The RUN and STOP mode selector positions show the selected mode (similar to the 
mode selector position on an S7 CPU front panel). This can differ from the current 
operating mode. Example: Changing the operating mode with STEP 7 causes the 
status indicators to change, but the mode selector does not change. 
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Flashing RUN and STOP status indicators 
 

Display Description 
RUN STOP  

Flashes Flashes WinAC MP is in DEFECT mode. All status indicators flash (see next 
paragraph) 

Flashes On • The STEP 7 user program has stopped at a breakpoint. 
• A warm restart or cold restart is in progress. RUN flashes until startup 

has been completed. The time required for the restart operation 
depends on the time required to execute the startup OB. 

OFF Flashes • WinAC MP memory reset is required (MRES button). 
• A WinAC MP memory reset is active. 

All status indicators flash   
If all the status indicators flash at the same time, WinAC MP is in an error status that cannot 
be eliminated by resetting memory with MRES.  
To recover from this condition, you must perform the following steps: 
1. Turn off WinAC MP (Shutdown) 
2. Restart WinAC MP (Start). 

Result: The STOP status indicator flashes, RUN is off. 
3. Reset WinAC MP memory by pressing the MRES button. 
4. Download the hardware configuration with STEP 7 and the STEP 7 user program or 

restore an archived user STEP 7 user program. 
If the problem is not eliminated by turning WinAC MP off and on again, restart the HMI 
device. 
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5.3.8 Composition of the cycle time 

Composition of the cycle time   
The cycle time is comprised of the following execution times: 
● OB1 execution time 
● HMI Enable Time 

– HMI runtime 
– Communication 
– Options 

The OB1 execution time is executed with highest priority. When the execution has been 
completed, a configurable "HMI Enable Time" is available to the HMI device. You can use 
this to control how much HMI runtime execution time is available to the communication and 
the options. 
Time data on configurable "HMI Enable Time": 
● Default setting: 50 ms 
● Minimum: 1 ms 

Time-critical applications 
When they occur, interrupt OBs (OB 35 and OB 40) interrupt the execution of the OB 1 or 
the HMI Enable Time. 
The following screen shows an example of the events triggering interrupt OB 35 and OB 40. 

 

How the "HMI Enable Time" influences the cycle time   
A small "HMI Enable Time" shortens the cycle time The next call OB 1 takes less time.  

 

 Note 
"Selecting a sufficiently large HMI Enable Time" 
Long interruptions of the HMI Enable Time reduce performance of the HMI device. The 
execution times of the interrupt OBs reduce the HMI Enable Time(1:1). For this reason you 
have to select a sufficiently large "HMI Enable Time". 
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5.3.9 Setting the "HMI enable time" 

Options for setting the "HMI Enable Time" 
1. Using the supplied user interface in the figure "Tuning Screen" to set the HMI enable 

time: 
You can set the HMI Enable Time in the range from 1 ms to 5999 ms in the 
"HMI Enable Time" input field of the tuning screen. The default is 50 ms. 

2. Configuring the "HMI Enable Time" with a system function: 
The "HMI Enable Time" can be configured in WinCC flexible using the 
"SetHMIEnableTime" system function. 

3. For additional information, refer to the chapters: Examples of configuring objects 
(Page 83) and WinAC MP functions (Page 80) 

 

 
 

Note 
Selecting a sufficiently large HMI Enable Time  
Set an appropriate HMI Enable Time at the beginning of your configuration and 
commissioning phase. Observe the screen change and refresh times during operation of 
the panel.  
Reduce the HMI Enable Time in small steps and continue to observe the screen change 
and refresh times. If the screen change and refresh times deteriorate, increase the HMI 
Enable Time again. Application-related time interrupts (e.g. 0B35) or block calls can lead 
to other negative effects which can be corrected by extending the HMI Enable Time . 
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5.4 Archiving and restoring STEP 7 user programs 

5.4.1 Conditions for archiving and restoring 

Definition: Archive file   
The archive for WINAC MP functions like a S7-CPU micro memory card. 
You use an archive file to archive the STEP 7 user program of WinAC MP or to restore the 
STEP 7 user program after a WinAC MP memory reset.   
WinAC MP uses two types of archive file:  
● The archive file has the ending .wld. The file is created generated using the "Archive" call 

and restored with "Restore". The path name of the file is specified as a parameter at both 
calls. 
The actual values of the project in Runtime are saved to the archive file: 
– Current STEP 7 user program 
– Current system configuration 
– Current values of the DBs 

● WinAC MP saves the current user program, including the initial values and configuration 
data, to a file with the ending .waf . 
The file is saved with device backup and restored with "restore": 
– with ProSave on the configuration PC 
– with backup/restore in the Control Panel on the HMI device 

 

 
 

Note 
WinAC is closed automatically for the backup. After backup it is necessary to restart 
WinAC, e.g. with reboot. 
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Additional information 
For more information about the backup and restore functions, refer to the Multi Panels 
MPx77 and WinCC flexible manuals. 

 

Requirements 
The following constraints apply to WLD archive files: 
● The WinAC MP system functions "Archive"" and "Restore" can only be used with S7 user 

programs requiring up to a specific size of load memory. 
● To archive or restore an archive file, WinAC MP must be in STOP mode. 
● An archive file works similar to the memory card of an S7-CPU.  

Only exception: After a memory reset, WinAC MP does not load the archive file 
automatically and must be loaded manually. 

For information about the sizes of the various characteristics, refer to section Technical 
specifications (Page 94). 

 

 Note 
Retentive data are not archived. 
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5.4.2 Creating an archive file - Archive 

Requirement 
The Archive system function is assigned a valid file name and storage location for the 
archive file at the "FilePath:" parameter. 

Optional storage locations for the archive file 
● MP 177: internal Flash memory, Storage Card MMC, Storage Card USB and Network 
● MP 277: internal Flash memory, Storage Card MMC, Storage Card USB and Network 
● MP 377: internal Flash memory, Storage Card MMC, Storage Card USB, Storage Card 

CF and Network 

Creating an archive file on the HMI device 
1. Press STOP to set WinAC MP to STOP mode. 
2. Press the Archive button. 
Result: The archive file is set up with the default name Default.wld in the default path: 
\Flash\AddOn\WinACMP\. 

Creating an archive file in SIMATIC Manager 
As an alternative, you can also create the archive file in SIMATIC Manager in STEP 7:  
1. Select File > Memory Card File > New in SIMATIC Manager. 
2. Enter a name for the archive file. 
3. Select the storage location for the archive file and confirm with "OK": 
Result: The archive file is created with the *.wld extension. 
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5.4.3 Restoring an archive file - Restore 

Requirements 
● The storage medium (MMC, USB, ...) with the archive file is plugged in. 
● The Restore system function is assigned a valid file name and storage location for the 

archive file at the "FilePath:" parameter. 

Restoring configuration data from WLD archive file 
1. Press the "STOP" button to change WinAC MP to STOP mode. 
2. Press the Restore button.    
3. Wait until the archive file "Restore" has been restored. 
4. Switch WinAC MP to RUN to start the STEP 7 user program. 

Result 
WinAC MP starts with the new project data at the next RUN command. 

5.5 Exit WinAC MP on the HMI device - Shutdown 

Exiting WinAC MP 
To exit WinAC MP, press the "Shutdown WinAC MP" button.    
Result: WinAC MP is closed and all status indicators are reset. WinCC flexible Runtime 
remains active. 
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Setting up WinAC MP for your application 6
6.1 Working with WinCC flexible 

WinCC flexible   
The WinCC flexible configuration software is used to create your configuration on the 
configuration PC (PC or PG) operating on a Windows platform. 

WinCC flexible Runtime   
WinCC flexible Runtime is an easy-to-use, high-performance software for the visualization of 
processes in projects you created with the WinCC flexible configuration software.  
WinCC flexible Runtime is designed for visualization and control of machines and small 
plants. The Runtime software has a window-based pixel-graphics user interface. Due to its 
short response times, the software features secure process operation, jogging at the 
machine and secure data acquisition.  

WinAC MP system library   
 

 
Tip 
To use all the functions of WinAC MP, make sure that the WinAC MP option is installed on 
the configuration PC. 

 

The WinAC system library for the Multi Panels are included in the scope of delivery of 
WinAC MP. The library contains the follows screens: Home Screen and Tuning Screen. 
You can use the screens without needing to make any changes. You can, however, also 
adapt the screens to your needs in WinCC flexible or create a new project. 
When you install WinAC MP, all WinAC MP functions are integrated in WinCC flexible. In 
WinCC flexible, you can copy pictures and picture objects to other projects. 
Open WinCC flexible with Start > SIMATIC > WinCC flexible 2008 > WinCC flexible. 

Further information 
For information on Integrating a WinAC system library, refer to the WinAC system library 
(Page 57) section. 
For more information on creating pictures and working with the functions in WinCC flexible, 
refer to the documentation on WinCC flexible. 
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6.2 WinAC MP functions 
The following table shows all functions and objects with which functions can be configured 
that are available for visualization of WinAC MP in WinCC flexible. 

System functions WinCC flexible   
Use the following system functions in WinCC flexible:  
● UpdateTags, to read or update values 
● SetValue, to set or change values in WinAC MP 

Overview of Objects   
The objects whose functions can be parameterized are organized as follows: 

 
Abbreviatio
n  

Object Event 

Variable Variable Changed value, High limit violation, Low limit violation 
Screen Screen Loaded, Cleared 
Scr obj Screen object Press, Release, Click, Change, Switch on, Switch off, Activate, Deactivate 
Function Function key global/local Press, Release 
System System key global/local Press, Release 
Script *  Usable in the script  
* Abbreviation "Script" is not available for the configuring for MP 177 

Overview of the additional objects for WinAC MP 2008   
 
Function name Description Parameters Action Abbreviati

on 

SetHMIEnableTime   Sets the value of the 
HMIEnableTimeof WinAC MP 
(in ms). 

HMIEnableTime : (input) - Variable 
Scr obj 
Function 
System 

UpdateHMIEnableTime *)   Updates the value of the 
HMIEnableTime of WinAC MP 
(in ms) 

HMIEnableTime : (output) Switch off 
Switch on 

Screen 

*) For explanation, see the end of the next table. 
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Overview of Objects 
 
Function name Description Parameters Action Abbreviati

on 

Archive   Stores the current STEP 7 user 
program, the current system 
configuration and the current 
values of the DBs in an archive 
file. 

File path:  - Scr obj 
Function 
System 

ClearCycleTimeBuffer   Deletes the cycle time data of 
the histogram. 

- - Variable 
Scr obj 
Function 
System 

ControlWinACMP   Starts or closes WinAC MP. WinAC : (input) 
0 = Shutdown WinACMP 
1 = Start WinACMP 

- Variable 
Scr obj 
Function 
System 

GetWinACMPStartMode *)   Reads the WinAC MP 'desired' 
operating mode after the HMI 
device has started up. 

StartMode: (output) Switch off 
Switch on 

Variable 
Screen 
Scr obj 
Function 
System 

GetWinACMPVersion *)   Reads the value of the version 
number from WinAC MP. 

Version : (output) Switch off 
Switch on 

Variable 
Screen 
Scr obj 
Function 
System 
Script 

Restore   Loads the STEP 7 user 
program, system configuration 
and DBs from an archive file. 

File path: - Scr obj 
Function 
System 

SetKeySwitch   Sets the mode selector switch to 
RUN or STOP and is also used 
for memory reset. 

Key Switch : (input) 
0 = MRES 
1 = STOP 
3 = RUN 

- Variable 
Scr obj 
Function 
System 

SetRestartMethod   Sets the restart mode, either 
cold restart (CRST) or warm 
start (WRST) 

Action : (input) 
0 = WarmRestart 
1= ColdRestart 

 Variable 
Scr obj 
Function 
System 

SetSleepTime   Sets the value of the 
HMIEnableTimeof WinAC MP (in 
ms). 

SleepTime : (input) - Variable 
Scr obj 
Function 
System 

SetWinACStartAtBoot   Sets whether WinAC MP starts 
automatically after the HMI 
device boots. 

StartAtBoot : (input) 
0 = StartAtBootOff 
1 = StartAtBootOn 

- Variable 
Scr obj 
Function 
System 
Script 

SetWinACMPStartMode   Sets WinAC MP to the 'desired' 
operating mode after the HMI 
device has started up. 

Action : (input) 
0 = AutoStartOff 
1 = AutoStartOn  

 Variable 
Scr obj 
Function 
System 
Script 

StartHistogramm *)   Starts the cyclic sending of 
histogram values. (this function 
is called in WinCC flexible with 
Events > Loaded) 

Percent[n]: (output) 
CycleTime[n]: (output) 
Y-Axis bounds[n]: (output) 
RegisterID[n]: (output) 

Switch off 
Switch on 

Screen 
Scr obj 
Function 
System 
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Function name Description Parameters Action Abbreviati
on 

StopHistogramm   Stops the cyclic sending of 
histogram data (this function is 
called in WinCC flexible with 
Events > Cleared) 

RegisterID: (input) - Screen 
Scr obj 
Function 
System 

UpdateAverageCycleTime *)   Updates the display of the 
average cycle time (in ms). 

CycleTime : (output) Switch off 
Switch on 

Screen 

UpdateAverageExecTime *)   Updates the display of the 
average OB 1 execution time (in 
ms). 

CycleTime : (output) Switch off 
Switch on 

Screen 

UpdateBUSF1LEDVariable *)   Updates the status indicator of 
the LED variable BUSF1. 

BUSF1 : (output)  
Switch off 
Switch on 

Screen 

UpdateBUSF2LEDVariable *) 
No function in WinAC MP V4.0/4.1.1   

Updates the status indicator of 
the LED variable BUSF2. 

BUSF2 : (output) Switch off 
Switch on 

Screen 

UpdateControllerForStartAtBoot *)   Reads whether WinAC MP has 
started automatically after the 
HMI device booted. 

StartAtBoot : (output) Switch off 
Switch on 

Screen 

UpdateEXTFLEDVariable *)   Updates the status indicator of 
the LED variable EXTF. 

EXTF : (output) Switch off 
Switch on 

Screen 

UpdateINTFLEDVariable *)   Updates the status indicator of 
the LED variable INTF. 

INTF : (output) Switch off 
Switch on 

Screen 

UpdateKeySwitchSetting *)   Updates the status indicator for 
the position of the mode selector 
switch. 

KeySwitch : (output) 
0= MRES 
1 = STOP 
2 = RUN 

Switch off 
Switch on 

Screen 

UpdateLastCycleTime *)   Updates the display of the last 
cycle time (in ms). 

CycleTime : (output) Switch off 
Switch on 

Screen 

UpdateMaximumCycleTime *)   Updates the display of the 
longest cycle time (in ms). 

CycleTime : (output) Switch off 
Switch on 

Screen 

UpdateMinimumCycleTime *)   Updates the display of the 
shortest cycle time (in ms). 

CycleTime : (output) Switch off 
Switch on 

Screen 

UpdatePowerLEDVariable *)   Updates the status indicator of 
the LED variable ON. 

Power : (output) Switch off 
Switch on 

Screen 

UpdateRUNLEDVariable *)   Updates the status indicator of 
the LED variable RUN. 

Run : (output) Switch off 
Switch on 

Screen 

UpdateSleep Time *)   Updates the value of the 
HMIEnableTime of WinAC MP 
(in ms) 

SleepTime : (output) Switch off 
Switch on 

Screen 

UpdateSTOPLEDVariable *)   Updates the status indicator of 
the LED variable STOP. 

STOP : (output) Switch off 
Switch on 

Screen 

*) The configuration of all WinAC MP update functions is permitted only once per screen. 
The WinAC MP update function must be configured for the "Screen loaded" event with the 
Action parameter "SwitchOn". The WinAC MP update function must be configured for the 
"Screen unloaded" event with the Action parameter "SwitchOff". If a function is called more 
than once with different variables in one screen, only the variable activated last is updated. 
You should therefore only use identical variables as parameters of the functions within a 
screen. 
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Examples of configuring objects 7
7.1 Configuration of the RUN button with corresponding LED display using 

WinCC flexible 

Introduction 
The following example shows you how to configure a RUN button with integrated LED 
indicator. 
Objective: 
The button "RUN" will change WinAC MP to RUN mode. The vector graphic shows an 
"LED". The color will always represent the current mode RUN or STOP. 

Basic design 
 
Step 1 Click Events > "SetKeySwitch" function, "KeySwitch" parameter. RUN > RUN WinAC MP  
Step 2 Internal variable "RUNLED" data type INT < UpdateRUNLEDVariable function, Action: Switch ON < events 

loaded (screen object) < feedback: Value 3 = RUN ; Value 0 = STOP 
Step 3 UpdateRUNLEDVariable function, Action: Switch OFF < events cleared (screen object) 
Step 4 Internal variable "RUNLED" data type INT > Animations background color Value 3 = Green;  

Value 0 = Red 
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Configuration 
1. Create a new project in WinCC flexible with the option Create an empty project. 
2. In the next dialog "Device selection", select the Multi Panel you are using. In our example, 

we are using the MP 277 10" Key. Confirm with "OK". 

 
3. Open Toolbox > Simple Objects and design the "RUN" button and LED as a "circle" 

vector graphic as shown in the figure below. 

 
4. Assign a switching function to the RUN button: Select the RUN button and click on 

Events > Click in the lower area of WinCC flexible. 
5. Configure System Functions > WinAC MP > SetKeySwitch. 
6. Select "RUN" as the function for "KeySwitch". 

 
7. Click on an empty position in the screen object. 
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8. Select the events > Loaded > UpdateRUNLEDVariable 

 
9. For the parameter "RUN: (output)" of the "UpdateRUNLEDVariable" function, configure 

the internal variable "RUNLED" of the data type INT. 
10. For the "Action" parameter of the "UpdateRUNLEDVariable" function, select the value 

"Switch On". 

 
11. Click on an empty position in the screen object. 
12. Select Events > Cleared > UpdateRUNLEDVariable. 
13. For the parameter "RUN: (output)" of the "UpdateRUNLEDVariable" function, configure 

the internal variable "RUNLED" of the data type INT. 
14. For the "Action" parameter of the "UpdateRUNLEDVariable" function, select the value 

"Switch OFF". 
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15. Configure the variable with the "circle" vector graphic in Animations > Appearance. 

 
16. Save your project with Project > Save. 
17. Download your project to the Multi Panel with Project > Transfer. 

7.2 Configuring a histogram 

Introduction  
The following example shows you how to configure a histogram: 
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Basic design 
 
Step 1 Events loaded (screen object) > "StartHistogramm" function with parameter Action: SwitchON  

> WinAC MP supplies histogram data 
Step 2 Internal array variable PERCENT, CYCLE_TIME, Y_AXIS and REGISTER_ID < feedback 
Step 3 StopHistogramm parameter "RegisterID" < events cleared (screen object) 
Step 4 Internal array variable CYCLE_TIME[0] to [6] > IO field_1 to IO field_7> Process > Variable 
Step 5 Internal array variable Y_AXIS[1] > Bar_1 > maximum value > variable and internal 

array variable PERCENT[0] > Bar_1 > Process > Variable 
Step 6 Internal array variable Y_AXIS[0] > Bar_2 to Bar_8 > maximum value > variable and internal array variable 

PERCENT[0] to [6] > Bar_2 to Bar_8 > Process > Variable 

Creating the objects 
1. Create a new project in WinCC flexible with Create an empty project. 
2. In the next dialog "Device selection", select the Multi Panel you are using. In our example, 

we are using the MP 277 10" Key. Confirm with "OK". 
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3. Open Toolbox > Simple Objects and define the area using a rectangle. 

 
4. You create the Y axis with a bar (Bar_1) from the simple objects: 

 
5. You create the bars (Bar_2 to Bar_8) in the histogram display with a total of 7 bars  

from the simple objects: 
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6. Disable the "Display scale" property for the seven bars. 

 
7. Below the 7 bars, configure an IO field with the "Output" property. 

 

Assigning the tags 
1. In WinCC flexible, click on Project >HMI Station > Communication > Tags. 
2. Create the tags based on the figure below using the right mouse button and "Add Tag". 
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Assigning the events 
1. In WinCC flexible, click on Project >HMI Station > Screens > Bild_1. 
2. Complete the function list for Events > Loaded based on the following figure: 

 
3. Complete the function list for Events > Cleared based on the following figure: 
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Assign limits and tags to the X axis, Y axis and bars 
1. Click on the first I/O field on the X axis and assign the tags based on the following figure: 

 
2. In the same way, assign the elements of the array variable CYCLE_TIME to the 

remaining 6 IO fields. Make sure that the CYCLE_TIME variable is incremented by 1 in 
each case. 
– Process variable = CYCLE_TIME [n]; n = 0 ... 

3. Click on the Y axis and assign the variables based on the following figure: 
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4. Click on the first bar in the histogram (Bar_2) and assign the variables based on the 
following figure: 
– Maximum value variable = Y_AXIS[0] 
– Process variable = PERCENT[n]; n = 0 ... 

 
5. In the same way, assign the tags to the remaining 6 bars. Make sure that each element of 

the PERCENT array variable is incremented by the count of 1. 

Saving and transferring a project 
1. Save your project with Project > Save. 
2. Download your project to the Multi Panel with Project > Transfer. 



 

WinAC MP 2008 
Operating Instructions, 03/2009, A5E00981151-02 93 

Performance features and technical specifications A
A.1 Performance features 

Summary of the performance features of WinAC MP 
Below, you will find a brief outline of the main performance features of WinAC MP: 
● 4 accumulators (accumulator 1 to 4) 
● Communication as PROFIBUS-DP master complying with DPV1 
● Only distributed I/O - no integrated inputs and outputs 

WinAC MP communicates with the distributed I/O as a PROFIBUS-DP master. As a DP 
master, WinAC MP can communicate with up to 32 DP slaves. 

A.2 Specifications 

A.2.1 Order numbers 

Order numbers 
WinAC MP 177: 6ES7 671-4EE00-0YA0     
WinAC MP 277: 6ES7 671-5EF01-0YA0 
WinAC MP 377: 6ES7 671-7EG01-0YA0 
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A.2.2 Technical specifications 

Technical specifications 
 
 WinAC MP 177 WinAC MP 277 WinAC MP 377 
MLFB 6ES7671-4EE00-0YA0 6ES7671-5EF01-0YA0 6ES7671-7EG01-0YA0 
Associated programming package STEP 7 V 5.4 + SP4 STEP 7 V 5.4 + SP4 STEP 7 V 5.4 + SP4 
Firmware version V4.1.1 V4.1.1 V4.1.1 
Memory    
Working memory    
• Integrated 128 KB 256 KB 512 KB 

• Expandable No No No 

Blocks    
DB    
• Number, max. 512 

(FBs+FCs+DBs=512) 
1024 
(FBs+FCs+DBs=1024) 

2048 
(FBs+FCs+DBs=2048) 

• Size, max. 64 KB 64 KB 64 KB 

FB    
• Number, max. 512 

(FBs+FCs+DBs=512) 
1024 
(FBs+FCs+DBs=1024) 

2048  
(FBs+FCs+DBs=2048) 

• Size, max. 64 KB 64 KB 64 KB 

FC    
• Number, max. 512 

(FBs+FCs+DBs=512) 
1024 
(FBs+FCs+DBs=1024) 

2048  
(FBs+FCs+DBs=2048) 

• Size, max. 64 KB 64 KB 64 KB 

OB    
• Number, max. 18 18 18 

• Size, max. 64 KB 64 KB 64 KB 

Nesting depth    
• Per Priority Class 8 8 16 

• Error OBs 2 2 2 

Timers /counters / retentivity:    
S7 counters    
• Number 128 256 512 

• Retentivity    

• - configurable Yes Yes Yes 

• - Preset 8 8 8 

• Counting range    

• - Lower Limit 0 0 0 

• - Upper Limit 999 999 999 
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 WinAC MP 177 WinAC MP 277 WinAC MP 377 
IEC counters    
• Included Yes 

( SFB 0, SFB 1, SFB 2) 
Yes 
( SFB 0, SFB 1, SFB 2) 

Yes 
( SFB 0, SFB 1, SFB 2) 

S7 timers    
• Number 128 256 512 

• Retentivity    

• - configurable Yes Yes Yes 

• - default 0 0 0 

• Time range    

• - Lower Limit 10 ms  10 ms 10 ms 

• - Upper Limit 9990 s 9990 s 9990 s 

IEC timers    
• Included Yes 

( SFB 3, SFB 4, SFB 5) 
Yes 
( SFB 3, SFB 4, SFB 5) 

Yes 
( SFB 3, SFB 4, SFB 5) 

Retentivity    
Retentivity total 64 KB 128 KB 256 KB 
Bit memories    
• Number, max. 2 KB 2 KB 4 KB 

• Retentivitiy present Yes Yes Yes 

Data blocks    
• Number, max. 512 1024 2048 

• Size, max. 64 KB 64 KB 64 KB 

• Retentivity configurable Yes (max. 64 KB) Yes (max. 128 KB) Yes (max. 256 KB) 

Local data    
• per priority class, max. configurable, 16384 bytes 

for all execution levels  
configurable, 16384 bytes 
for all execution levels 

configurable, 16384 bytes 
for all execution levels 

Address area    
I/O address area    
• Inputs 2 KB 4 KB 8 KB 

• Outputs 2 KB 4 KB 8 KB 

• Distributed of this    

• - Inputs 2 KB 4 KB 8 KB 

• - Outputs 2 KB 4 KB 8 KB 

Process image    
• Inputs 1 KB 2 KB 2 KB 

• Outputs 1 KB 2 KB 2 KB 

• Inputs, adjustable 1 KB 2 KB 2 KB 

• Outputs, adjustable 1 KB 2 KB 2 KB 

• Inputs, preset 512 bytes 512 bytes 512 bytes 
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 WinAC MP 177 WinAC MP 277 WinAC MP 377 
• Outputs, preset 512 bytes 512 bytes 512 bytes 

• Consistent Data, max. 32 bytes 32 bytes 32 bytes 

Hardware Configuration    
Number of DP masters    
• Integrated 1 1 1 

Time    
Operating Hours Counter    
• Number 8 8 8 

• Number range 0 to 7 0 to 7 0 to 7 

S7 message functions    
Process diagnostics messages Yes Yes Yes 
Test and startup functions    
Status/control    
• Status/modify variable Yes 

(status blocks, single 
step, breakpoint) 

Yes 
(status blocks, single 
step, breakpoint) 

Yes 
(status blocks, single step, 
breakpoint) 

Force    
• Force No No No 

Diagnostic buffer    
• Included Yes Yes Yes 

• No. of entries, max. 1000 1000 1000 

• Number of entries, preset 120 120 120 

• Configurable Yes Yes Yes 

Communications functions    
Number of logical connections 8 16 32 
PG/OP communication Yes Yes Yes 
Routing Yes Yes Yes 
Global data communication    
• supported No No No 

S7 basic communication    
• supported No No No 

S7 Communication    
• supported Yes (PUT/GET, 

BSEND/BRCV, 
USEND/URCV) 

Yes (PUT/GET, 
BSEND/BRCV, 
USEND/URCV) 

Yes (PUT/GET, 
BSEND/BRCV, 
USEND/URCV) 

• As server Yes Yes Yes 

• As client Yes Yes Yes 

• User data per job, max. 480 bytes 480 bytes 480 bytes 

Number of connections    
• Total 8 (DP max. 4, remainder 

PROFINET) 
16 (DP max. 8, remainder 
PROFINET) 

32 (DP max. 8, remainder 
PROFINET) 
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• Reserved for PG communication 1 1 1 

• Reserved for OP communication 1 1 1 

• Usable for routing 6 14 30 

1st interface    
DP master    
• Maximum number of connections 4 8 8 

• Services    

• - PG/OP Communication Yes Yes Yes 

• - Routing Yes Yes Yes 

• - Global Data Communication No No No 

• - S7 basic communication No No No 

• - S7 Communication Yes Yes Yes 

• - Equidistant Mode Support No No No 

• - SYNC / FREEZE Yes Yes Yes 

• - Activation/deactivation of DP 
slaves 

Yes Yes Yes 

• - DPV1 Yes Yes Yes 

• Transmission rates, max. 12 Mbit/s 12 Mbit/s 12 Mbit/s 

• Number of DP slaves, max. 32 32 32 

• Address area    

• - Inputs, max. 2 KB 4 KB 8 KB 

• - Outputs, max. 2 KB 4 KB 8 KB 

CPU/Programming    
Configuration software    
• WinCC flexible Compact Yes No No 

• WinCC flexible Standard Yes Yes Yes 

• WinCC flexible Advanced Yes Yes Yes 

Programming language    
• LAD Yes Yes Yes 

• FBD Yes Yes Yes 

• STL Yes Yes Yes 

• SCL Yes Yes Yes 

• CFC Yes Yes Yes 

Operating systems    
• Windows CE Yes (version 5.0 or 

higher) 
Yes (version 5.0 or 
higher) 

Yes (version 5.0 or higher)

Online language    
Number 1 (English) 1 (English) 1 (English) 
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A.3 Supported OBs 

A.3.1 OBs for the main cycle of the program and for cold and warm restarts 

OB 1   
WinAC MP executes OB 1 at cyclic intervals: When OB1 has been executed, the 
HMI Enable Time starts. The operating system then starts to execute OB 1 again. Cyclic 
execution of OB 1 starts when startup is complete. You can call function blocks (FBs, SFBs) 
or functions (FCs, SFCs) in OB 1. 

Definition: Warm restart   
WinAC MP executes OB 100 before the free cycle (OB 1) is started. A warm restart clears 
the inputs of the distributed I/O (PII) and sets the outputs of the distributed I/O (PIQ) to a 
predefined safe state (default setting is 0). A warm restart retains the current values of the 
retentive memory areas of bit memories (M), timers (T), counters (C), and data blocks (DBs). 
All non-retentive memory areas are then set to "0". 

Definition: Cold restart   
WinAC MP executes OB 102 before the free cycle (OB 1) is started. Like a warm restart, a 
cold restart resets the inputs of the distributed I/O (PII) and sets the outputs of the distributed 
I/O (POI) to a pre-defined safe state (default is 0). A cold restart resets the retentive memory 
(M, T, and C) or sets it to its default setting (DB). All non-retentive memory areas are then 
also set to "0". 
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A.3.2 Supported organization blocks (OBs) 

Organization blocks (OBs) supported by WinAC MP 2008 
 
OB Description Priority class 
OB 1 Cyclic program 1 
OB 10 Time-of-day interrupt 2 to 24 
OB 20 Time-delay interrupt 2 to 24 
OB 35 Cyclic interrupt 2 to 24 
OB 40 Hardware interrupt 2 to 24 
OB 55 Status interrupt 2 to 24 
OB 56 Update interrupt 2 to 24 
OB 57 Manufacturer-specific interrupt 2 to 24 
OB 80 Time error 26 
OB 82 Diagnostic interrupt 24 to 26 (or 28)* 
OB 83 Insert/remove interrupt 24 to 26 (or 28)* 
OB 85 Program execution error 24 to 26 (or 28)* 
OB 86 Rack failure 24 to 26 (or 28)* 
OB 88 Processing interrupt 28 
OB 100 Warm restart 27 
OB 102 Cold restart 27 
OB 121  Programming error Priority class of the OB causing the error 
OB 122 I/O access error Priority class of the OB that was interrupted 
* Priority classes 27 and 28 are valid in the priority class model of the startup. 

For detailed information, refer to the STEP 7 Online Help. 
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A.4 Supported SFCs 

Definition of system function (SFC)   
A system function (SFC) is a function that is integrated in the operating system of the CPU 
and can be called in the STEP 7 user program, when necessary. 

System functions (SFCs) 
WinAC MP supports the following SFCs: 
 
SFC Name Description 
SFC0 SET_CLK Sets the system clock. 
SFC1 READ_CLK Reads the system clock. 
SFC2 SET_RTM Sets the runtime meter. 
SFC3 CTRL_RTM Starts or stops the runtime meter. 
SFC 4 READ_RTM Reads the runtime meter. 
SFC 5 GADR_LGC Queries the logical address of a channel. 
SFC 6 RD_SINFO Reads the start information of an OB. 
SFC 9 EN_MSG Enables block-related and symbol-related messages as well as group 

status messages. 
SFC 11 DPSYC_FR Synchronizes groups of DP slaves. 
SFC 12 D_ACT_DP Deactivates and activates DP slaves. 
SFC 13 DPNRM_DG Reads the diagnostic data of a DP slave. 

Tested DP configuration: One ET 200M slave with one 8-input/8-output 
module and one 16-output module. 

SFC 14 DPRD_DAT Reads the consistent data from a DP slave. 
SFC 15 DPWR_DAT Writes the consistent data to a DP slave. 
SFC 17 ALARM_SQ Generates a block-related message that can be acknowledged. 
SFC 18 ALARM_S Generates a block-related message that can be permanently 

acknowledged. 
SFC 19  ALARM_SC Queries the acknowledgement status for the last message (SFC 17 or 

SFC 18). 
SFC 20 BLKMOV Copies memory areas. 
SFC 21 FILL Initializes a memory area. 

1 word 
50 words 
100 words 

SFC 22 CREAT_DB Creates a retentive data block in the work memory. 
The current values of the DB are saved after a warm restart. 

SFC 23 DEL_DB Deletes a data block.  
WinAC MP allows an application to delete a non-sequence-relevant 
data block. 

SFC 24 TEST_DB Provides information about a data block. 
In WinAC MP, SFC 24 can return the DB length and write-protection 
flags for non-sequence-relevant data blocks, although it returns error 
code 80B2 for non-sequence-relevant data blocks.  

SFC 26 UPDAT_PI Updates the process input image. 
SFC 27 UPDAT_PO Updates the process output image. 
SFC 28 SET_TINT Sets the time-of-day interrupt (OB 10). 
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SFC Name Description 
SFC 29 CAN_TINT Cancels the time-of-day interrupt (OB 10). 
SFC 30 ACT_TINT Activates the time-of-day interrupt (OB 10). 
SFC 31 QRY_TINT Queries the time-of-day interrupt (OB 10). 
SFC 32  SRT_DINT Starts the time-delay interrupt (OB 20). 
SFC 33 CAN_DINT Cancels the time-delay interrupt (OB 20). 
SFC 34  QRY_DINT Queries the time-delay interrupt (OB 20). 
SFC 36 MSK_FLT Masks synchronous errors. 
SFC 37 DMSK_FLT Unmasks synchronous errors. 
SFC 38 READ_ERR Reads the error register. 
SFC 39 DIS_IRT Disables the processing of new interrupt events. 
SFC 40 EN_IRT Enables the processing of new interrupt events. 
SFC 41 DIS_AIRT Delays higher priority interrupts and asynchronous errors. 
SFC 42 EN_AIRT Enables the processing of new interrupt events with higher priority than 

the current OB. 
SFC 43 RE_TRIGR Retriggers cycle time monitoring. 
SFC 44 REPL_VAL Transfers a substitute value to ACCU1 (Accumulator 1). 
SFC 46 STP Changes the operating mode to STOP mode. 
SFC 47 WAIT Delays the execution of the STEP 7 user program by the specified 

number of microseconds, rounded up to the next millisecond. 
SFC 49 LGC_GADR Queries the module slot belonging to a logical address. 
SFC 50 RD_LGADR Queries all of the logical addresses of a module. 
SFC 51 RDSYSST Reads all or part of a system status list. 
SFC 52 WR_USMSG Writes a user-defined diagnostic event to the diagnostics buffer. 
SFC 54 RD_DPARM Reads the defined parameter. 
SFC 55 WR_PARM Writes the dynamic parameters. 
SFC 56 WR_DPARM Writes the default parameters. 
SFC 57 PARM_MOD Assigns the parameters to a module. 
SFC 58 WR_REC Writes a data record. 
SFC 59 RD_REC Reads a data record. 
SFC 62 CONTROL Checks the connection status of an SFB instance. 
SFC 64 TIME_TCK Reads the system time. 
SFC 78 OB_RT Reports OB runtime information with a resolution to the nearest 

microsecond. 
SFC 79 SET Sets a range of outputs. 
SFC 80 RESET Resets a range of outputs. 
SFC 82 CREA_DBL Creates a data block in the load memory. 
SFC 83 READ_DBL Copies data from a block in the load memory. 
SFC 84 WRIT_DBL Writes to a load memory block, so that the data are stored 

immediately. 
Load memory blocks that are used to recover from an abnormal 
termination can be updated while the program is running. Use SFC 84 
only for larger segments of a database, not for frequent variable 
processing. 

SFC 85 CREA_DB Creates a retentive or non-retentive DB, depending on the input 
parameter: 
If retentive, the current values of the DB are retained after a warm 
restart (OB100). 
If non-retentive, the current values of the DB are reset to their initial 
values after a warm restart (OB100). 

SFC 87 C_DIAG Determines the current status of all S7 connections. 
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Running asynchronous SFCs concurrently   
WinAC MP 2008 restricts the number of asynchronous OBs that can be running concurrently 
according to the following rules: 
● A maximum of 5 instances of the asynchronous system function SFC 51 (index B1, B3) 

may run in WinAC MP 2008. 
● A maximum of 20 asynchronous SFCs of the following SFCs may run in WinAC MP 2008: 

SFC 11, SFC 13, SFC 55, SFC 56, SFC 57, SFC 58 and SFC 59. 
● A maximum of 32 asynchronous SFCs in any combination from the following SFCs may 

run in WinAC MP 2008: SFC 82, SFC 83 and SFC 84. 

SFCs that can cause the cycle time to vary (jitter) 
The following SFCs can cause the cycle time to vary (jitter): 
● SFC 22 (CREAT_DB) 
● SFC 23 (DEL_DB) 
● SFC 52 (WR_USMG) 
● SFC 85 (CREA_DB) 

Considerations for SFC 82, SFC 83 and SFC 84 
WinAC MP 2008 supports a synchronous interface for SFC 82, SFC 83 and SFC 84 during 
startup. WinAC MP 2008 allows both the first call (with REQ = 1) and the second call (with 
REQ = 0) in STARTUP so that the action can be completed during STARTUP. 
The normal STEP 7 error codes are valid for SFC 82, SFC 83 and SFC 84. The error code 
80C3 is also returned. These SFCs return the error code 80C3, if WinAC MP 2008 exceeds 
the limit of 32 outstanding SFC 82, SFC 83 and SFC 84 jobs. 

Further Information 
Detailed information on the SFCs can be found in the STEP 7 online help or in the STEP 7 
System Software for S7-300 and S7-400 System and Standard Functions Reference 
Manual. 
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A.5 Supported SFBs 

Definition of system function block (SFB) 
System function blocks (SFB) are integrated in the CPU operating system and can be called 
in the STEP 7 user program. 

System function blocks (SFBs) 
WinAC MP supports the following SFBs: 
 
SFB Name Description 
SFB 0 CTU Counts up. 
SFB 1 CTD Counts down. 
SFB 2 CTUD Counts up/down. 
SFB 3 TP Generates a pulse. 
SFB 4 TON Generates an ON delay. 
SFB 5 TOF Generates an OFF delay. 
SFB 8 USEND Sends a data packet of CPU-specific length (two-

way), uncoordinated with receiving partner. 
SFB 9 URCV Asynchronously receives a data packet of CPU-

specific length (two-way). 
SFB 12 BSEND Sends a segmented data block of up to 64 Kbytes 

(two-way). 
SFB 13 BRCV Receives a segmented data block of up to 64 

Kbytes (two-way). 
SFB 14 GET Reads data up to a CPU-specific maximum length 

(one-way) from a remote CPU. 
SFB 15 PUT Writes data up to a CPU-specific maximum length 

(one-way) to a remote CPU. 
SFB 22 STATUS Queries the status of a remote device. 
SFB 23 USTATUS Receives the status of a remote device. 
SFB 32 DRUM Implements a sequencer. 
SFB 52 RDREC Reads a data record. 
SFB 53 WRREC Writes a data record. 
SFB 54 RALRM Receives alarm data for a DP slave. 

Further Information 
Detailed information on the SFBs can be found in the STEP 7 online help or in the STEP 7 
System Software for S7-300/400 System and Standard Functions Reference Manual. 
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A.6 System status list (SSL) 

Using SFC 51 to read the system status list (SSL)  
STEP 7 stores read-only information about WinAC in the system status list (SSL) as a set of 
sublists. 
You use SFC 51 (RDSYSST) to access the entries in the SSL. You supply the input 
parameters SSL_ID and Index to access the data records in the sublist. SFC 51 returns a 
two-word header and a sublist or partial sublist.  
The header provides the following information for the sublist: 
● The first word defines the length (in bytes) of a data record for the sublist. 
● The second word defines the number of data records in the sublist. 
The requested information follows the header. The size of the sublist (in bytes) is the data 
record length multiplied by the number of data records. 

 

 Note 
Representation of the values in the SSL 
The SSL_ID and Index values are represented as hexadecimal (16#) numbers. 

 

SSL_ID 0x11 (module identification) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#0111 Module-specific information 0001: Order number, module type and version 

0007: Firmware version 

SSL_ID 0x12 (CPU characteristics ) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#0012 All characteristics MC7 processor unit, time system, system 

response and MC7 language description 
W#16#0112 Specific group of characteristics 0000: MC7 processor 

0100: Time system 
0200: System response 
0300: MC7 language description 

W#16#0F12 Header information only  
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SSL_ID 0x13 (memory areas) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#0113 Specific memory area 0001: User memory 

0002: Load memory integrated 
0003: Load memory inserted  
0004: Maximum insertable load memory 
0005: Size of backup memory 
0006: Peer-to-peer memory (shadow memory) 

SSL_ID 0x14 (system areas) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#0014 All system areas  
W#16#0F14 Header information only  

SSL_ID 0x15 (block types) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#0015 All block types  

SSL_ID 0x19 (LED status) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#0019 All LEDs  
W#16#0F19 Header information only  

SSL_ID 0x1C (component identification) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#001C All information of a component  
W#16#011C Specific elements for the 

component 
0001: Name of the controller 
0002: Name of the module 
0003: Module tag 
0004: Copyright entry 
0005: Serial number 
0007: Module type 
0009: Manufacturer and profile identification 
000B: Location designation (LID) of a module 

W#16#0F1C Header information only  
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SSL_ID 0x22 (interrupt status) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#0222 Start event for a specific OB OB number: Start event and time for the 

requested OB 

SSL_ID 0x25 (process image partition) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#25 All process image partitions Process image partitions for all OBs that have 

been loaded into the module 
W#16#125 Process image partition of a 

specific OB 
Partition number: for the partition of the 
configured OB 

W#16#0225 OBs that have been assigned to a 
specific process image partition 

OB number: Partition that has been assigned to 
the OB 

W#16#0F25 Header information only  

SSL_ID 0x32 (communications status) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#0132 Parameters of the specified 

communication types 
0005: Diagnostics 
0008: Time system  

W#16#0232 Parameters of a redundant system 
(H-CPU) 

0004: Protection level and position of the 
operator switch settings  

SSL_ID 0x74 (LED status) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#0174 Specific LED 0002: INTF internal error 

0003: EXTF external error 
0004: RUN  
0005: STOP 
0006: Point-to-point status data 
0008: Time system  
000B: BUSF1 bus fault 
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SSL_ID 0x90 (DP master system) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#0090 All DP masters configured on the 

network and downloaded to the 
module 

DP master identifier, address and attributes for 
all DP masters 

W#16#0190 Specific DP master DP master identifier, address and attributes 
W#16#0F90 Header information only  

SSL_ID 0x91 (module status)  
 
SSL_ID Sublist Index and contents of the data record 
W#16#0591 Module status information of all 

submodules of the host module 
INDEX is irrelevant 

W#16#0991 Module status information of a DP 
master system 

Rack or DP master system ID 

W#16#0C91 Specific module, identified by the 
logical base address 

Logical base address: Functions and 
parameters of the specified module 

W#16#0D91 Specific station, identified either by 
the rack/station, by DP master 
identifier or the DP master identifier 
with station number 

Station identifier: Features and parameters for 
all the modules of the specified station 

W#16#0E91 Module status information of all 
configured modules (central, 
distributed, PROFIBUS DP or 
PROFINET IO) 

INDEX is irrelevant 

SSL_ID 0x92 (rack and station status) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#0092 Expected status of stations in a DP 

master system 
0: Local DP master 
DP master identifier: Specific DP master 

W#16#0192 Activation status of the stations of 
an ID of a DP master system 

0: Local DP master 
DP master identifier: Specific DP master 

W#16#0292 Actual status of the stations of a 
DP master 

0: Local DP master 
DP master identifier: Specific DP master 

W#16#0692 OK status of the stations of a DP 
master 

0: Local DP master 
DP master identifier: Specific DP master 
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SSL_ID 0x95 (expanded DP master system) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#0195 Specific DP master DP master identifier: Properties of the stations 

of the specified DP master (for example, DP 
mode, equidistant mode and cycle, clock 
synchronization and transmission rate) 

W#16#0F95 Header information only  

SSL_ID 0xA0 (diagnostic buffer) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#00A0 All entries in the diagnostic buffer Event information for all events listed in the 

diagnostic buffer 
W#16#01A0 Most recent entries in the 

diagnostic buffer 
Number: Event information for the specified 
number of entries in the diagnostic buffer 

W#16#0FA0 Header information only  

SSL_ID 00B1, 00B3, 00B4 (module diagnostics) 
 
SSL_ID Sublist Index and contents of the data record 
W#16#00B1 Diagnostic information (4 bytes) for 

a specific module identified by the 
logical base address 

Logical base address: First 4 bytes of the 
diagnostic information 

W#16#00B3 All diagnostic information for a 
specific module identified by the 
logical base address 

Logical base address: Complete diagnostic 
information 

W#16#00B4 Specific DP slave identified by the 
configured diagnostic address 

Diagnostic address: Standard diagnostic 
information for a DP station 

Further Information 
You will find detailed information on the system status lists: 
● In the STEP 7 online help 
● In the System and Standard Functions for S7-300/400 reference manual 

If you want to call up the manual on a PC on which STEP 7 is installed, select Start > 
SIMATIC > Documentation > English and double-click "STEP 7 - System and standard 
functions for S7-300 and S7-400". 
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Glossary 

"Transfer" mode 
"Transfer" mode is the operating mode of the HMI device in which a run-capable project is 
transferred from the configuration PC to an HMI device.  

Automation system 
An automation system is a controller of the SIMATIC S7 series, such as a SIMATIC S7-300 

Bit memories 
Bit memory is part of the CPU system memory. It is used to store interim results. Bit-, byte-, 
word-, or double word-access of bit memory is possible 

Boot loader 
The boot loader is used to start the operating system and is automatically started when the 
HMI device is switched on. After the operating system has been loaded, the Loader opens.  

Bootstrapping 
Bootstrapping is a function used, for example, when updating the operating system. When a 
functional operating system is available, updates can be performed without bootstrapping. 
Otherwise, updating with bootstrapping is necessary. In this case, the configuration PC 
communicates with the HMI device by means of the HMI device bootloader. 

Cold restart 
The controller executes OB 102 before the free cycle (OB 1) is started. Like a warm restart, 
a cold restart resets the process input image (PII) and places the process output image 
(PIQ) into a pre-defined safe state (default is 0). However, retentive memory (M, T, C, or DB) 
is reset to defaults during a cold restart. 

Configuration 
Configuration refers to the combination of individual modules to form an automation system. 

Configuration PC 
A configuration PC is a programming device or PC on which plant projects are created using 
configuration software. 
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Control Panel 
In the Control Panel, you can make settings on the HMI device. 

Controller 
A controller is a general term for devices and systems with which the HMI device 
communicates, such as SIMATIC S7. 

Counter 
Counters are part of the CPU system memory. The content of "counter cells" can be 
modified by STEP 7 instructions (for example, count up/down). 

CP 
Communications processor: Communication processors are modules used for point-to-point 
and bus topologies. 

CPU 
A central processing unit is the main processing unit of the automation system with a 
processor, arithmetic unit, memory, operating system, and interface for the programming 
device. 

Cycle 
The cycle includes writing to the outputs, reading the inputs, executing OB 1 and all other 
OBs, and satisfying the sleep time requirement. 

Cycle time 
The cycle time includes the OB 1 execution time (S7 user program) and the 
HMI Enable Time. 

Data Block 
Data blocks (DBs) are parts of the user program that contain user data. Global data blocks 
can be accessed by all logic blocks while instance data blocks are assigned to a specific FB 
call. 

Default setting 
The default setting is a sensible basic setting that is used whenever no other value is 
specified (assigned). 
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DPV1 
The designation DPV1 means extension of the functionality of the acyclical services (to 
include new interrupts, for example) provided by the DP protocol. The DPV1 functionality has 
been incorporated into IEC 61158/EN 50170, volume 2, PROFIBUS. 

Engineering software 
The configuration software is used to create projects for process visualization. 
WinCC flexible is an example of configuring software.  

Flash memory 
Flash memory is non-volatile memory with EEPROM chips, used as a mobile storage 
medium or as a memory module installed permanently on the motherboard. 

Function block 
According to IEC 1131-3, a function block (FB) is a logic block containing static data. An FB 
allows the user program to pass parameters. Function blocks are therefore suitable for 
programming frequently recurring, complex functions, e.g., closed-loop controls, mode 
selection. 

Function key 
A function key is a key on the HMI device that supports user-specific functions. A function is 
assigned to the key in the configuration. The assignment of the function keys can vary 
according to the displayed screen or be independent of the displayed screen. 

Histogram 
Graphic representation of the cycle time behavior of WinAC MP. 

HMI device 
An HMI device is a device used for the operation and monitoring of machines and plants. 
The statuses of the machine or plant are indicated by means of graphic elements or by 
indicator lamps on the HMI device. The operator controls of the HMI device allow the 
operator to intervene in the processes of the machine or plant. 

HMI Enable Time 
Die HMI Enable Time is a component of the cycle time on WinAC MP.  
It includes the execution times for: 
● HMI runtime 
● Communication 
● Options 
● OBs that are higher priority than OB 1 
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HMI station  
Representation of a software-based virtual rack that defines a PC-based automation system. 

Home screen 
The Home Screen provides the same options as the front panel of an S7 hardware CPU. 
The Home Screen includes the following elements for operator control and for status 
functions: 
● Buttons for operator control of the WinAC MP (for example, starting and exiting WinAC 

MP, automatic startup when booting, autostart and archiving/restoring) 
● Buttons for functions (changing to the Tuning Screen, returning to the start screen) 
● Mode selector switch (RUN, STOP) 
● Status indicators for WinAC MP 
● MRES button for memory reset 

Hotkey 
A hotkey specifies a key or key combination that can be used to actuate the button. 

Index 
In the context of hardware configuration: A numbered slot in the HMI station or virtual rack 
that represents a PC-based automation system. The controller occupies one index. Other 
components can occupy other index slots. 

Industrial Ethernet 
Physical communications layer for communication with STEP 7, S7 CPUs, PGs, OPs and S7 
applications. 

Interface, multi-point 
MPI 

Jitter 
Jitter occurs when there is a delay starting or ending the OB. Example: The execution time 
can vary in the millisecond range from cycle to cycle or the start of an interrupt OB can be 
delayed. 

Load memory 
The load memory is part of the CPU and is the memory area (RAM) for all blocks 
downloaded from STEP 7 except for the symbol table and comments.  
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Loader 
Transfer, Start, Control Panel and Taskbar can be called in the Loader on the HMI device. 

Mains 
In terms of communication, a network is the interconnection of several CPUs and other end 
devices -- for example, a programming device -- by means of connecting cables. Data 
exchange is performed between the connected devices over the network. 

Mode 
SIMATIC S7 automation systems can adopt the following operating modes: STOP, 
STARTUP, RUN, memory reset and STOP. 

Mode selector 
The mode selector switch is used to set the mode you require on the CPU. 

MP 
Multi Panel 

MPI 
Multi-Point Interface is the programming device interface of SIMATIC S7. It allows multiple-
node operation (PGs, text-based displays, OPs) on one or several CPUs. Each station is 
identified by its unique (MPI) address. 

Nesting depth 
A block can be called from another by means of a block call. Nesting depth means the 
number of simultaneously called logic blocks. 

Node address 
The node number represents the "number" of a CPU, the programming device, or other 
intelligent I/O module if they communicate with one another over a network. The node 
address is assigned with the STEP 7 software. 

Object 
An object is a component of a project, e.g., a screen or message. Objects are used to view 
or enter texts and values on the HMI device.  

OP 
Operator Panel 
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Organization block (OB) 
Interface between the operating system and the STEP 7 user program. They are called from 
the operating system and control cyclic and interrupt-triggered program execution, the restart 
behavior of the controller and error handling. 

PG/OP communication 
Communication between the controller and other S7 applications such as programming 
devices, operator panels, and S7 automation systems. WinAC MP supports PROFIBUS and 
Industrial Ethernet for PG/OP communication. 

Process image 
At the start of a cycle, the signal states at the input modules are written to the process input 
image. At the end of the cycle, the process image of the outputs is transferred as a signal 
state to the output modules. 

Process visualization 
Process visualization is the display of technical processes by means of text and graphic 
elements. Configured plant screens allow operators to intervene in active plant processes by 
inputting and outputting information. 

PROFIBUS 
Physical communications layer for PROFIBUS-DP communication with inputs/outputs or for 
S7 communication with STEP 7, S7 CPUs and S7 applications. 

PROFIBUS-DP 
Protocol for the communication with the distributed IOs in the network. PROFIBUS-DP 
complies with EN 50 170 Volume 2, PROFIBUS. 

Programmable (logic) controller 
Programmable logic controllers (PLCs) are electronic controllers whose function is saved as 
a program in the control unit. Therefore, the configuration and wiring of the device does not 
depend on the controller function. The programmable logic controller has the structure of a 
computer; it consists of a CPU with memory, I/O modules and an internal bus system. The 
I/O and the programming language are oriented to control engineering needs. 

Programming device (PG) 
Basically speaking, programming devices are compact, portable PCs suitable for industrial 
applications. Their distinguishing feature is the special hardware and software for SIMATIC 
programmable logic controllers. 



 Glossary 
  

WinAC MP 2008 
Operating Instructions, 03/2009, A5E00981151-02 115 

Project 
A project is the result of a configuration using configuring software. The project normally 
contains several screens with embedded system-specific objects, basic settings and alarms. 
The project file of a project configured in WinCC flexible is saved under the file name 
extension *.hmi. 
You need to distinguish between the project on a configuration PC and the run-capable 
project on an HMI device. A project may be available in more languages on the configuration 
PC than can be managed on the HMI device. The project on the configuration PC can also 
be set up for different HMI devices. However, only the run-capable project that has been 
generated for the respective HMI device can be transferred to it. 

Project file 
A project file is a file generated from the executable file for use on the HMI device. The 
project file is normally not transferred and remains on the configuration PC.  
The file name extension of a project file is *.hmi. 

ProSave 
The ProSave service tool ships with WinCC flexible. It provides all the functions needed to 
transfer data between the configuration PC and HMI device. These include: 
● Backing up data 
● Restoring data 
● Updating the operating system 
● Load / delete options 
● Load / delete UCL keys 

Restart method 
The restart method determines which startup OB is executed whenever the controller 
changes from STOP mode to RUN mode. The startup OB allows you to initialize your 
STEP 7 user program and variables. The restart methods are: Cold restart (OB 102) and 
warm restart (OB 100). 

Retentive data 
This retentive data is not lost even if the power supply to the HMI device fails. With STEP 7, 
you can decide which areas should be retentive. The amount of retentive data is limited for 
WinAC MP! 

Runtime software 
WinCC flexible Runtime refers to the runtime software that can run on the HMI device.  
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S7 Communication 
Communication between hardware and software controllers on the network using the S7 
communication functions. 

S7 routing 
Communication between S7 automation systems, S7 applications or PC stations in various 
subnets using one or more network nodes that act as router. The configuration is created in 
NetPro. 

Shared data 
Shared data can be addressed from any logic block (FC, FB, OB). Specifically, these are bit 
memories (M), inputs (I), outputs (Q), timers (T), counters (C) and data blocks (DB). Shared 
data can be accessed via absolute or symbolic addressing. 

Softbus 
Virtual bus that allows a data exchange between WinCC flexible runtime and WinAC MP. 
This bus is installed when you install WinAC MP. After installing WinAC MP, S7 connections 
from WinCC flexible Runtime to external stations on PROFIBUS or Ethernet are routed over 
Softbus. 

STARTUP 
A STARTUP routine is executed at the transition from STOP to RUN mode. It can be 
initiated by the mode selector switch, after a Power On, or through an operator input on the 
programming device. 

STEP 7 user program 
Application program created with STEP 7 and downloaded to the controller for execution. It 
includes all organization blocks (e.g., OB 1 or OB 35) and the other logic blocks that are 
called, including functions (FCs), system functions (SFCs), function blocks (FBs) and system 
function blocks (SFBs). 

STEP 7 
STEP 7 is the programming software for the SIMATIC S7, SIMATIC C7 and 
SIMATIC WinAC controllers. 

System function (SFC) 
A system function (SFC) is a function that is integrated in the operating system of the CPU 
and can be called in the STEP 7 user program, when necessary. 
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System function block (SFB) 
Function block integrated as part of the operating system of the controller and not loaded as 
part of the STEP 7 user program. Like a function block (FB), an SFB is a block "with 
memory". You must also create an instance data block (DB) for the SFB. The instance DB is 
then loaded as part of the STEP 7 user program into the controller. 

System memory 
The system memory is integrated on the CPU and implemented as RAM. System memory 
contains the address areas (for example, timers, counters, bit memories) and data areas that 
are required internally by the operating system (for example, communication buffers). 

Timer 
See Timers 

Timers 
Timers are part of the CPU system memory. The content of timer cells is automatically 
updated by the operating system, asynchronously to the user program. STEP 7 instructions 
are used to define the precise function of the timer cell (for example, ON delay) and to 
initiate its execution (for example, Start). 

Transfer 
Transfer of a run-capable project from the configuration PC to the HMI device. 

Tuning screen 
In the Tuning screen, you will find histogram information on the cycle time of WinAC MP. 

Variable 
A tag is a defined memory area for read and write access to values. This access can occur 
from the controller or via the HMI device. Based on whether or not the tag is interconnected 
with the controller, we distinguish between external tags (process tags) and internal tags. 

Warm restart 
When the CPU starts up (for example, after changing the mode selector switch from STOP 
to RUN or after a Power ON), organization block OB 100 (warm restart) is executed before 
cyclic program processing (OB 1). On a warm restart, the process input image is read in and 
the STEP  7 user program is executed, starting at the first command in OB 1. 
Type of restart where the controller executes OB 100 before the free cycle (OB 1) is started. 
A warm restart resets the process input image (PII) and places the process output image 
(PIQ) into a predefined safe state (default is 0). During a warm restart, the current values of 
the retentive memory areas for the bit memory (M), timers (T), counters (C), and data blocks 
(DBs) are retained. 
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Working memory 
Memory area (RAM) allocated for the blocks used at runtime. 
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