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EU Declaration of Conformity 
 We declare that the accompanying product, identified with the  mark, complies 

with requirements of the Electromagnetic Compatibility Directive, 89/336/EEC and 
the Low Voltage Directive 73/23/EEC. 

 Model Number: KEP Series, a Knife Edge Profiler 

Year  mark affixed: 2002 

Type of Equipment: 
Information Technology Equipment 

Standards Applied: 
Compliance was demonstrated to the following standards to the extent applicable: 

 
• EN 55022 : “Limits and methods of radio interference characteristics of 

information technology equipment; Generic emission standard”, Part 1. 
Residential, Commercial and Light Industry. 
 

• EN 50024 : “Electromagnetic Compatibility (EMC); generic immunity standard”,  
Part 1: “Residential, commercial and light industry”. 

 
 

  

 

 

 Alain Danielo     Dan Dunahay 
VP European Operations   Director of Quality Systems 
Zone Industrielle    1791 Deere Avenue 
45340 Beaune-la-Rolande, France  Irvine, Ca. USA 
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Warranty 
Newport Corporation warrants that this product will be free from defects in material 
and workmanship and will comply with Newport’s published specifications at the time 
of sale for a period of one year from date of shipment. If found to be defective during 
the warranty period, the product will either be repaired or replaced at Newport’s 
option. 
To exercise this warranty, write or call your Newport office or representative, or 
contact Newport headquarters in Irvine, California. You will be given prompt 
assistance and return instructions. Send the product, freight prepaid, to the indicated 
service facility. Repairs will be made and the instrument returned freight prepaid. 
Repaired products are warranted for the reminder of the original warranty period or 
90 days, whichever first occurs. 
 
Limitation of Warranty 
 
The above warranties do not apply to products which have been repaired or modified 
without Newport’s written approval, or products subjected to unusual physical, 
thermal or electrical stress, improper installation, misuse, abuse, accident or 
negligence in use, storage, transportation or handling. This warranty also does not 
apply to fuses, batteries, or damage from battery leakage. 
THIS WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES, EXPRESSED OR 
IMPLIED, INCLUDING ANY IMPLIED WARRANTY OF MERCHNATABILITY OR 
FITNESS FOR A PARTICULAR USE. NEWPORT CORPORATION SHALL NOT BE 
LIABLE FOR ANY INDIRECT, SPECIAL, OR CONSEQUENTIAL DAMAGES 
RESULTING FROM THE PURCHASE OR USE OF ITS PRODUCTS. 
 
First printing 2006  
 
© 2006 by Newport Corporation, Irvine, CA. All rights reserved. No part of this 
manual may be reproduced or copied without the prior written approval of Newport 
Corporation. 
This manual has been provided for information only and product specifications are 
subject to change without notice. Any change will be reflected in future printings. 
 
Newport Corporation 
1791 Deere Avenue 
Irvine, CA 92606 
USA 
 
P/N 44762-01  Rev. A 
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Confidentiality & Proprietary Rights 
 

Reservation of Title: 
The Newport programs and all materials furnished or produced in connection with them 
(“Related Materials”) contain trade secrets of Newport and are for use only in the manner 
expressly permitted. Newport claims and reserves all rights and benefits afforded under 
law in the Programs provided by Newport Corporation. 

Newport shall retain full ownership of Intellectual Property Rights in and to all 
development, process, align or assembly technologies developed and other derivative 
work than may be developed by Newport. Customer shall not challenge, or cause any 
third party to challenge the rights of Newport. 

Preservation of Secrecy and Confidentiality and Restrictions to Access: 

Customer shall protect the Newport Programs and Related Materials as trade secrets of 
Newport, and shall devote its best effects to ensure that all its personnel protect the 
Newport Programs as trade secrets of Newport Corporation. Customer shall not at any 
time disclose Newport’s trade secrets to any other person, firm, organization, or employee 
than does not need (consistent with Customer’s right of use hereunder) to obtain access 
to the Newport Programs and Related Materials. These restrictions shall not apply to 
information (1) generally known to the public or obtainable from public source; (2) readily 
apparent from the keyboard operation, visual display, or output reports of the Programs; 
(3) previously in the possession of Customer or subsequently developed or acquired 
without reliance on the Newport Programs; or (4) approved by Newport for release without 
restriction. 

Service Information 

This section contains information regarding factory service for the source. The user 
should not attempt any maintenance or service of the system or optional equipment 
beyond the procedures outlined in this manual. Any problem that cannot be resolved 
should be referred to Newport Corporation. 
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Technical Support Contacts 
 
 North America & Asia    Europe 

Newport Corporation Service Dept.  Micro-Controle Spectra-Physics S.A. 
1791 Deere Ave.     Zone Industrielle 
Irvine, CA 92606      45340 Beaune la Rolande. France 
Telephone: (949) 253-1694    Telephone: (33) 02 38 40 51 49 

Telephone: (800) 222-6440 x31694 

 

 Asia – Newport Opto-Electronics Technologies 

253 Aidu Road, Bold #3, Flr 3, Sec C, 

Shanghai 200131, China 

Telephone: +86-21-5046 2300 

Fax: +86-21-5046 2323 

 

Newport Corporation Calling Procedure 

If there are any defects in material or workmanship or a failure to meet specifications, 
promptly notify Newport’s Returns Department by calling 1-800-222-6440 or by visiting our 
website at www.newport.com/returns within the warranty period to obtain a Return Material 
Authorization Number (RMA#). Return the product to Newport Corporation, freight prepaid, 
clearly marked with the RMA# and  we will repair or replace it at our discretion. Newport is 
not responsible for damage occurring in transit and is not obligated to accept products 
returned without an RMA#. 

E-mail: rma.service@newport.com 

When calling Newport Corporation, please provide the customer care representative with the 
following information: 

- Your Contact Information 
- Serial number or original order number 
- Description of problem (i.e., hardware or software) 

 
To help our Technical Support Representative diagnose your problem, please note the 

following conditions: 
- Is the system used for manufacturing or research and development? 
- What was the state of the system right before the problem? 
- Have you seen this problem before? If so, how often? 
- Can the system continue to operate with this problem? Or is the system non-operational? 
- Can you identify anything that was different before this problem occurred? 
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 Introduction 
 
Welcome to the Knife-Edge Profiler! 

The Knife-Edge Profiler is a beam 
diagnostics measurement system for real-time measurement and display of CW lasers, fiber-optic 
and laser diode beam profiles. The Knife-Edge Profiler is designed to provide maximum flexibility, 
speed, and user-friendliness for a variety of beam measurements.   Measurements include; beam 
width, shape, position, power, and intensity profiles. Some of the applications include; beam 
alignment, on-line monitoring, gaussian fit analysis, beam position measurement, laser beam 
optimization and quality control. 
The Knife-Edge Profiler Interface card and software can be integrated into a variety of compatible 
PC computer platforms running under a Windows operating system. The Knife-Edge Profiler 
system will meet a wide range of automated laser analysis requirements in the laboratory, factory 
and field. 
 
 
Theory of Operation 
The Knife-Edge Profiler measures beam intensity profiles, widths, position, power and the basic 
beam shape of CW lasers. The detector head utilizes multiple knife-edges to scan across the 
beam and capture the intensity distribution of the laser. 
A simplification of a Knife-Edge Profiler detector head is shown below. 

The rotating drum contains multiple knife-edge 
apertures, (only one is shown in this diagram). As an aperture passes between the laser beam 
and the stationary power sensor, there is a period where the entire beam is allowed to reach the 
sensor. At this point, the Knife-Edge Profiler can measure the total power of the beam. As the 
aperture is scanned across the beam, the knife-edge blocks off an increasingly larger portion of 
the beam power. The power sensor measures this change in power versus knife-edge position 
creating a power vs position plot as shown below. 
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Knife Edge Position

Power

Change in measured
power with position.

Measured Power as knife edge cuts the beam

 
The analog power reading is digitized with a high speed A/D (Analog to Digital) converter. At the 
same time the exact position of the knife-edge is monitored so that beam width information can 
be determined. The beam profile for each knife-edge is then obtained in software by taking the 
derivative of the measured power curve. The beam profile is perpendicular to the knife-edge and 
each point of the profile is the sum of all intensities along the axis of the knife-edge at that knife-
edge position. The digitized beam profiles are then stored in memory. 

Knife Edge
 

The Knife-Edge Profiler obtains profiles from multiple knife-edges at different orientations and has 
the ability to use this information to create 2D and 3D plots of the beam. The mathematical 
reconstruction process is known as "Reconstructive Tomography". The same type of process is 
used by X-ray systems to create X-ray images. A larger number of knife-edges will create better 
detail on non-gaussian beams. For a beam distribution that is significantly non-gaussian, the 
standard seven knife-edge system can reconstruct a plot that closely matches the real beam. 

 
There are two primary knife-edges used for the main profile display. These knife-edges generate 
profiles referred to as W and V.  These knife-edges are set perpendicular to each other and are 
oriented at 45 degrees in relation to the base of the head. These profiles are used to provide 
beam width, position and gaussian fit analysis. The other knife-edges are used for Reconstructive 
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Tomography. 
To increase the usable power range of the Silicon heads to the NG4 (~10% transmission) and 
NG9 (~0.5% transmission) filters can be inserted between the knife-edge and the sensor. This 
location will prevent the attenuation from distorting the beam. 
The data is combined with user-selected graphics and calculated analysis results for display in a 
user-controlled window. A wide variety of system functions also provide the ability to print 
information, perform pass/fail testing, control capture rates, and log data. 
 
 
 
 
Overview 
 

   
 
A basic Knife-Edge Profiler system includes the following items: 

A detector head... 
 KEP-3-IR, a three knife-edge head for the 800-1800 nm wavelength range. 
 KEP-3-SL, a three knife-edge head for the 350-1100 nm wavelength range. 
 KEP-3-UV, a three knife-edge head for the 190-1100 nm wavelength range. 
 KEP-7-IR, a seven knife-edge head for the 800-1800 nm wavelength range. 
 KEP-7-SL, a seven knife-edge head for the 350-1100 nm wavelength range. 
 KEP-7-UV, a seven knife-edge head for the 190-1100 nm wavelength range. 

32 bit PCI Interface Board 
The Interface Board is a 1/2 length PCI card used for connecting the various detector heads to 
the computer. 

Windows Software 
The Knife-Edge Profiler software is contained on the installation CD. The CD also contains the 
user manual in .pdf format, readme.txt file and all of the required support files. 

Printed Manual 
The printed manual contains the same information as the On-line Help in the software. A 
README.TXT on the installation CD may have corrections to the manual and the on-line help. 

Filter Kit 
The KEP-7 and KEP-3 Silicon heads come with neutral density filters. The NG4 & NG9 filters are 
provided to extend the power range of the head from 5 mW to 1W. The NG4 filter comes 
preinstalled and provides 10% transmission at 633 nm. The NG9 is in a protective filter case and 
provides 0.5% transmission at 633 nm.  The filter kit also includes a hex wrench utilized for 
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swapping the filters, a filter blank for 100% transmission and filter transmission data.  

Mounting Post 
The mounting post is 105 mm long with an M4 thread. The post is utilized for mounting the 
detector head. 
 

 
 
Knife-Edge Profiler and Beam Diagnostics 
Two general types of instruments measure laser beam intensity. The following paragraphs 
explain the strengths and weaknesses of both measurement techniques. The Knife-Edge Profiler 
bridges the gap between these techniques. 

CCD Array Camera Diagnostics 
CCD array camera based diagnostics use an array of sensor pixels to measure the intensity over 
the face of the entire laser beam simultaneously. This allows them to capture data from pulsed 
lasers and display the data in 2D contour plots and 3D views. The pixels are of finite size (8 - 12 
µm) and the smallest measurable beam size is typically 40 times larger than the pixel. CCD 
camera based diagnostics are very sensitive and require high optical density laser grade filters to 
prevent saturation and beam distortion. In some cases, this is not desirable or practical. 

Scanning Aperture Diagnostics 
Scanning Aperture Diagnostics operate with either knife-edges or slits. The knife-edge method is 
described in “Theory of Operation”. The Slit method is similar but uses a very narrow slit instead 
of a knife-edge. These systems usually obtain one or two high-resolution beam profiles from 
which accurate measurements can be made. The resolution along the scanned profiles is very 
high compared to camera systems, enabling resolution in "tenths of microns" instead of "tens of 
microns" in a camera system. Consequently, they can measure beam widths down to several 
microns. Their dynamic range is much larger than CCD camera systems enabling measurement 
at relatively high power. They are unable to provide true representative 2D intensity contour plots 
of the beam. They are unable to measure pulsed lasers but offers measuring capabilities at 
wavelengths where the CCD cameras cannot work, utilizing sensors other than silicon. 

Knife-Edge Profiler 
The Knife-Edge Profiler bridges the gap between CCD and scanning aperture beam diagnostics. 
The Knife-Edge Profiler is based on Scanning Aperture technology so it has all the benefits of a 
Scanning Aperture System, but it is enhanced with a patented multiple scanning knife-edge 
system. Unlike standard Scanning Aperture systems the seven scanning knife-edges and a 
mathematical process called "Reconstructive Tomography", provides 2D and 3D reconstructions 
of CW laser beams. Because the Knife-Edge Profiler uses knife-edges as opposed to slits, it can 
measure laser power. Knife-Edge Profiler can measure beams up to 1 Watt with its ability to 
insert filters behind the scanning knife-edge thus prevent distortion of the beam measurement. 
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Quick Start 
To begin using the Knife-Edge Profiler:  

 The warranty will be void if a surge-protected outlet is not used with the 
Knife-Edge Profiler system. A surge-protector will guard against high voltage 
spikes, power fluctuations, and power surges.  

 

1. Check “Hardware Requirements”. 

2. Follow “Installing the PCI Interface Board”. 

3. Follow “Connecting the Detector”. 

4. Perform “Software Installation”, (if not done already). 
5. Setup software settings, “Configuring Software”. 
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 Setup 
These topics cover the basic procedures for installation, setup and configuration of the Knife-
Edge Profiler. 

Hardware Installation 

 Before installing the Knife-Edge Profiler hardware into the computer, make sure 
that the PC computer system meets the Knife-Edge Profiler Hardware Requirements. 

 Computer should be off before installing hardware into any computer. 

 The Knife-Edge Profiler contains static sensitive electronic components. The Knife-
Edge Profiler hardware should be handled with the same care as other computer 
hardware. Care should be taken to avoid accidental electrostatic discharge when 
connecting any cables to the Knife-Edge Profiler hardware. 

 The Knife-Edge Profiler warranty is void if a power-protection outlet (surge 
protector) is not used. A surge protector will protect the Knife-Edge Profiler from high-
voltage spikes, power fluctuations, and surges associated with laser laboratory 
equipment. 

 

Care & Handling 
Detector Head 

  The detector head is a precision instrument and should be handled with care. If the head is 
dropped it may be damaged. Do not plug the detector head into the interface card while the 
computer is on. Damage to the electronics may result. When not in use, keep the cap over 
the aperture to prevent dust from accumulating on the sensor and the knife-edges. The knife-
edges are delicate and will be damaged if they hit any object. The filters, (if provided) are the 
only objects that may be safely inserted into the detector head. Please do not remove the 
covers, since the internal systems are delicate and can easily be damaged. 

 
Interface Board 
The interface board is a static sensitive electronic item. Keep it in an anti-static bag when not 
installed in a computer. Avoid temperature and moisture extremes. The board should only be 
installed when computer power is OFF. 

 
Filters 
Filters are provided with the silicon versions of the detector heads. These filters have been 
precisely calibrated to a particular Knife-Edge Profiler head. Therefore, they share the same 
serial number. Dust, scratches and other types of contamination will degrade the accuracy of 
the system. Please keep unused filters in the storage case. Please be gentle when handling 
these fragile items. See “Selecting a Filter” for more information. 
Laser Safety 

 Please comply with all relevant Laser safety procedures and precautions when using this 
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device. The instrument will reflect a portion of the laser light. The resulting diffuse and 
specular reflections may be dangerous. 

 

 
  
Hardware Requirements  

      To run the Knife-Edge Profiler, the computer system must meet the following minimum 
requirements. Where helpful we provide system recommendations: 

 
 Min. Requirement Recommended 

 
CPU: Pentium II Pentium III 
System RAM: 32 Megabytes 128 Megabytes  
Floppy disk: 
CD Drive: 
 

3.5" 1.44 Megabyte 
x16 

 
x50 

Hard disk: 20 Megabytes Free 200 Megabytes Free 
 

Operating System: Windows 98,Me,NT4.0, 
2000, XP 
 

 

Mouse: Microsoft mouse or 
compatible pointing 
device 

 

VGA: 4 Megabytes Memory 
16bit color 

8 Megabyte AGP Bus 
Video card 

Expansion Slot: One free ½ length 32-bit 
PCI bus slot 
 

 

 
 
 
Installing the PCI Interface Board 

 The interface board is used by Knife-Edge Profiler to capture and digitize the beam 
profiles from the detector head. The Knife-Edge Profiler label identifies the interface 
board. 

 

Knife-Edge Profiler Interface Board 

The interface board is a static-sensitive electronic device. It should be handled with 
care to avoid exposure to static voltages. See “Care and Handling”. 
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Installation for Windows 98/Me/2000/XP 
1. Insert the Knife-Edge Profiler card into the PCI slot of the computer. Restart computer. 

The following message is displayed: 

 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 2. Insert the CD disk to the CD drive. Press Next button. 
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 The following message appears now, follow the on-screen instructions. 
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3. After completion of PCI card installation, when the device is configured successfully 
one can check in System Properties, Device Manager Tab and see that “DAS 
Components” now contains the “DO-DASBM” device. 

  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 
Installation for Windows NT 4.0 

 The Knife-Edge Profiler is automatically detected by Windows 98, Me, 2000 and XP. 
With Windows NT 4.0 Plug-and-Play boards need to be installed manually, since NT 4.0 
does not support Plug-and-Play. 
1. Insert the Knife-Edge Profiler card into the PCI slot of the computer. Restart the 

computer. 
2. Run software installation: SETUP.EXE from the CD ROM.  

 
 

 � Software Installation 
 To install the software put the CD disk into the CD ROM drive and run SETUP.EXE. 

In Windows 98, Me, NT4.0, 2000, XP: 
1. Insert CD Disk in the CD drive. 

2. From the Windows desktop select Start, and choose Run. 

3. Type D:\SETUP and then press Enter (where "D" is the CD ROM drive). 

During installation the system prompts the user to provide the SN. Please check the 
detector head and CD Calibration Files folder for the valid SN. 
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Uninstall is performed via Add/Remove Program under Windows Control Panel. 

 

 
Connecting the Detector 
The detector head has a cable with a 15-pin connector. The detector cable is connected 
to the corresponding 15 pin connector on the interface board. 

 

 WARNING; do not plug the detector head into the interface card while the 
computer is on. It may damage the electronics! 

 The KEP-3/KEP-7 switch is used to select the type of head that is connected. This 
switch is set at the factory to match the head that is purchased. It can be moved only 
when power is off! 

 
Selecting a Filter 
When a Silicon head is ordered with a Knife-Edge Profiler, it will come with two filters. This 
section will help determine which filter to use. Here is the general guideline: 
No filter: Power up to 5 mW 
NG4 filter: Power up to 50 mW 
NG9 filter: Power up to 1 W 
The actual filter transmission is dependent on Wavelength and can also vary from batch to 
batch. The transmission values for a particular wavelength can be found in the filter files 
included with the software. (NG4.FLT and NG9.FLT). 

  Focused Spot 
When measuring a focused beam the system will usually need attenuation. A convenient 
way to determine the correct attenuation is to first measure the power of the beam before 
focusing. Focus and measure the power with the detector head using the NG4 10%. If the 
power reading is lower than 10% of the unfocused reading, use the NG9 0.5% filter.  The 
power densities associated with focused beams can easily saturate the silicon detector.  A 
saturated detector output will result in a low power reading. 

  To install the filters: 
1. Remove the blank filter plate with the supplied Allen wrench. 

2. Carefully insert the desired filter 

3. Secure the new filter with the Allen wrench. 

 Dust, scratches and other types of contamination will degrade the accuracy of the 
filters. Please keep unused filters in the storage case. 
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Custom Filters & Power Calibration 
A custom Filter file can be made to accommodate other filters for absolute power calibration. 
See help for “Create Filter File” under the File menu. 

 
 

 Running the Software 
 To run the software simply click on the Knife-Edge Profiler Icon. 

 In Windows system Click Start, select Programs and then choose Knife-Edge Profiler: 
Several common symptoms result from an interface board conflict. If your symptoms match 
one of those presented below, proceed to the suggested section. The possible symptoms 
include: 
System Locks-up during software startup 

See “Operating Errors” to resolve conflict 
"Hardware failure" error in the toolbar 

See “System Errors” to resolve conflict 
If the Knife-Edge Profiler software was working at one time and has now stopped working, try 
reinstalling the interface board in a different expansion slot and see if that solves the problem. 
If it has no affect and no new software of any kind has been installed since the Knife-Edge 
Profiler last worked and the computer has not been moved, read “Contacting Newport” for 
immediate support. It is unlikely that these instructions will help. 

 
 
 
 
 

Configuring Software 
Before capturing data, configure the following settings in the software to insure a successful 
first run of the Knife-Edge Profiler. 

 
From the System menu select Hardware Setup. 

 Verify the Plug-in Address and IRQ settings. 
 

From the System menu select System Setup. 
 Enter the wavelength of the test source. 
 Choose an industry standard Clip level, 13.5% or 50%. 
 You may increase averaging if values vary more than desired. 
 Select High resolution if beam is < 100 µm 
 Run mode captures continuously and is best for general operation. Step mode captures 

data when a user clicks a button. 
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Operation 
This section covers the basic layout of the Knife-Edge Profiler software. 
When the Knife-Edge Profiler application is started, the main Knife-Edge Profiler window appears. 
The Knife-Edge Profiler window consists of display and control elements similar to most Windows 
applications along with elements specific to Knife-Edge Profiler interface. 
The main elements of the Knife-Edge Profiler window interface are as follows: 

 
Title Bar 
The Title Bar displays the name, "Newport KEP" followed by the detector head type and serial 
number. The Windows operating system provides special controls in the title bar of a window. 
From the title bar the main window can be closed, moved, sized, minimized to icon form or 
maximized to fill the screen. For more information on these controls see the Windows manual or 
find the Windows Tour program. 
 
Menu Bar 
The Menu Bar lists menus available for the Knife-Edge Profiler software. The menus listed in the 
Menu Bar contain items that allow specific actions to be performed.  Sub-menus or dialog boxes 
may result from a menu item selection.  These secondary items provide various controls of such 
functions as graphics, analysis, configuration setup, etc. 
 
Tool Bar 
The Tool Bar consists of various icon buttons. These buttons correspond to small symbols 
providing quick access alternatives to using menus or keyboard equivalent commands. To use a 
smart icon button, move the mouse cursor over the icon and click with the left mouse button. To 
view the function of any icon button, place the cursor on the icon and wait momentarily, a brief 
function description will appear near the icon. 

 
Window Area 
The Window Area is utilized for the graphical display windows. The Knife-Edge Profiler windows 
can be arranged in any configuration. The Windows can show beam profiles, position diagrams, 
2D and 3D contours, charts and a power meter. Interactive mouse control of each window allows 
a variety of customized configurations.  The number of windows available in High-Resolution 
mode are restricted.   
 
Status Bar 
The status bar is located at the bottom of the Knife-Edge Profiler window. It indicates the current 
status of key system measurement, configuration and operational parameters. 
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� Keyboard Operation 
The keyboard can be used to enter text data entry or control most Knife-Edge Profiler functions 
utilizing keyboard shortcuts. 

Help 
Press F1 to obtain Help on the active window. 

Selection of menus 
 Press ALT and then the arrow keys then Enter, to select a menu item. 

- OR -  
 Hold down the ALT key and press the underlined letter (hot key) in the desired menu 

item. 
- OR -  

 Press a shortcut key combination. Shortcuts are available for some menu items and are 
displayed next to the menu item. 

Close Menu 
 Press the ESC key. 

Dialog Boxes 
 Text Entry - Select the text box you wish to change. Use the keyboard to enter the 

desired text. When the correct text has been entered, press the [TAB] key to finish data 
entry and move to the next control in the dialog box. If an error is made while typing text, 
pressing the [BACKSPACE] key will remove the character to the left of the text cursor and 
move the cursor to the erased location. See also “Value Entry Box” for changing spin 
buttons. 

 [ESC] This key is used to select the "Cancel" button in a dialog box. This function resets 
settings to their previous values before the dialog box was opened. 

 [ENTER] This key is used to select the "OK" button in a dialog box. 
 [TAB] This key moves the input focus to the next control in a dialog box. 

 
The table below summarizes all the software shortcuts and control keys: 

Command  Description   Shortcut  Icon 
Load Configuration File  Displays Open dialog to load a (*.ini) 

configuration file 
Ctrl+O 

Save Configuration File Displays Save dialog to save a (*.ini) 
configuration file 

Ctrl+S 

View File Displays Open dialog to view a Log File Ctrl+V 

Create Filter File Starts the Create Filter file process Ctrl+F 
Print Text File Displays and Open dialog to load and print 

any saved Knife-Edge Profiler file in text 
format 

Ctrl+P 

Print BMP File Displays and Open dialog to load and print 
any saved Knife-Edge Profiler file in .bmp or 
.jpg format 

Ctrl+B 

Log Setup  Displays the Log Setup Dialog  
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Start Log Starts the Log Process  
Print Screen Prints the Entire Screen Ctrl+F12 
Exit Exits the Knife-Edge Profiler Software Ctrl+X 
Low Resolution Sets the System to Low Resolution Mode Ctrl+L 
High Resolution Sets the System to High Resolution Mode Ctrl+H 
Add Detector Head Add detector head dialog Ctrl+D 
Start Link Starts the RS-232 Link Communication Ctrl+K 
Slave Mode Activates the Slave Communication Mode Ctrl+M 
Help Active Window Displays Help Information on Current Active 

Window 
F1 

View Power Displays Power Window  F2 

Profile V Displays Profile V Window F3 

Profile W Displays Profile W Window F4 

Position Displays Position Window in Low Resolution 
Mode 

F5 

Projection Displays 2D or 3D Projection in Low 
Resolution Mode 

F6 

Plot Displays the Power Plot Window F7 

Chart Displays Chart Window in Low Resolution 
Mode 

F8 

Step Increments the Step Display if the System is 
in Step Mode 

F9 

Test Opens the Test Window  

Server Mode Start TCP/IP remote control  
 

Print Window Prints the Current Active Window F12 
ToolBar Toggles the Tool Bar On and Off Shift+Insert
Status Bar Toggles the Status Bar On and Off Ctrl+Insert 
Close All Windows Closes all Active Windows Ctrl+W 
About Displays the Knife-Edge Profiler About 

Dialog 
Shift+F1 

Search for Help for Activates the Knife-Edge Profiler Help 
Search Function 

Ctrl+F1 

 
 
Tool Bar 
The tool bar is a collection of shortcut buttons that are used frequently. Each shortcut is 
represented with a special icon (picture) called a tool button. 

� To activate a tool button, place the mouse over the button and click the LEFT mouse 
button. The button will change both color and shadow to designate that the function is 
active. 
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Buttons available on the Tool Bar: 

 
 

Inactive Tool buttons 
If a tool is not available it will be displayed in a gray outline form. The Log button requires setup 
information to be available. The Step button will not be available unless the system is set in Step 
Mode.   

 Start Log (disabled) 

 Step (disabled - so system is in RUN mode) 

Toggle Tool Buttons 
The toggle group of tool buttons will turn display windows On and Off. These tool buttons act as a 
toggle switch. When the corresponding window is active the button will appear to be pushed 
down.  When the corresponding window is not active the button appears in the UP position. 

 W profile ON 

 W profile OFF 

Hide the Tool Bar 
See “Tool Bar Command”. 

Date & Time 
The current Date and time is presented on the right side of the tool bar. System errors are also 
displayed in the date and time location when necessary. 
 
 
Tool Bar Command 
The Tool Bar can be hidden or shown by selecting Tool Bar from the View menu or using the 
keyboard shortcut Shift+Insert. 
This option enables the user to toggle between the Show Tool Bar and Hide Tool Bar. 
When the Tool Bar is selected there is an additional line on top of the window containing Tools 
(picture shortcuts to some of the most common used system functions) along with date/time 
information. 
When this option is not selected, the Tool Bar line disappears. In this case the user has to 
activate the various system functions from the menu or keyboard shortcuts. 

 
 
Window Area 
This area is utilized to display the graphical data windows. The Knife-Edge Profiler windows can 
be arranged in any configuration. The Windows can show beam profiles, position diagrams, 2D 
and 3D contours, charts and a power meter. Interactive mouse control of each window allows a 
variety of customized configurations. These customized configurations can be saved for later use. 

Arranging Windows 
Several special commands for arranging windows can be found under the Windows menu. 
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Status Bar 
The status bar provides information on various Knife-Edge Profiler settings and operational 
conditions. 
If the Knife-Edge Profiler system is not operating as intended, the Status bar provides a quick 
summary of why it is not functioning properly. For example, the laser being used may have a 
different wavelength. The status bar is a valuable aid in diagnosing unexpected results and can 
quickly help you get back to desired operation. 

 
 

Status Bar 

 The Status Bar also provides quick access to System setup parameters. Double 
click the current Wavelength value to access the System setup.  Toggle between 
Run/Step modes by double clicking the current mode on the Status Bar. 

 Status Bar Panels: 
Wavelength – This panel will display the current wavelength. See “Wavelength”. 

System Clip level – The clip level displayed on the status bar corresponds to the System Clip 
Level.  The System Clip Level is utilized to calculate beam diameter on the Chart Window etc. 
See “System Clip Level”. 
Average – The displayed Average value corresponds to the number of samples averaged 
before calculation and display. See “Average”. 

HeadTilt – The Head Tilt value corresponds to the user entered value for the current detector 
head azimuth rotation. See “HeadTilt”. 
Run/Step – The Run/Step display indicates the current mode of data collection.  If the screen 
does not appear to update, verify that the system is not set to Step Mode. See “Run Mode”. 
Resolution – The resolution display indicates the current acquisition mode.  If you are not 
able to display the 3D mode, check that the Status Bar is not indicating High Resolution. See 
“High Resolution” and “Low Resolution”. 

Filter – The current filter selection is indicated. 

Power – The Power reading display is indicated.  

 

To Hide or Show the Status Bar, see: “Status Bar Command”. 

 

Status Bar Command 
The Status Bar can be hidden or displayed by selecting Status Bar from the View menu or 
using the keyboard shortcut Ctrl+Insert. 
This option enables the user to toggle between Show Status Bar and Hide Status Bar. 
When Status Bar is active there is an additional line appearing at the bottom of the window. 
This line contains panels displaying general system information and user settings.  
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Methods of Data Entry 
 
Check box 
To turn an option on, use the following selection method: 

 
A check box is utilized in cases when there is a need to toggle a parameter ON or OFF. When the 
parameter is active, a check mark (a) is displayed inside the box. 

� Place the mouse cursor at the option box and click the mouse LEFT button. Click the 
mouse LEFT button again to deactivate the selection. The check mark is than removed 
from inside the box. 

� Highlight the required parameter box by pressing the TAB key. Press the SPACEBAR 
key to toggle the check box parameter. 

 
Radio Button 
To select a value from a short list of options, use this typical radio button entry: 
 

 

� Move the mouse cursor and place it at the required option. Click the mouse LEFT button 
once to select the option.  

� Move the cursor to the required option, either by moving the mouse or by pressing the 
TAB key, until the cursor is within the option list zone. Press the arrow keys to select the 
option from the list. 

 
Using the Value Entry Box 
To set a digital value parameter, use the Value Entry Box: 

 

� Place the mouse cursor at either the Up or Down arrow buttons displayed to the right of 
this box, and click its LEFT button to change values for the selected parameter. 

� Move the cursor to the required data box either by moving the mouse or by pressing 
the TAB key. Type the desired value.  The Enter key may change the value to meet the 
system requirements. 
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Colors 
The color option enables the user to set the background color, data color and plot colors for the 
various windows. Select the desired color from the standard Windows color pallet. Custom colors 
are also available with the appropriate video card and Windows color setting.  
The Position and Profiles window will allow the selection background color, data color and plot 
color. The Power and Projection windows allow for the selection of background and data color. In 
Plot and Chart windows allow for the selection of background and plot color.  
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Menus and Commands 
The following Command Menus are available on the Knife-Edge Profiler Menu Bar: 

 
 

File Menu 
 The File menu allows the user to perform many file operations. The following commands and 

menu items are available from this Menu: 
 
 
Note that the keyboard shortcuts are listed to the 
right of the feature. These shortcuts may be 
activated from the Main Window by pressing the 
appropriate keyboard combination. 
 

 

 

 

 

 
 View File... 

View File can be selected from the File menu. The keyboard shortcut is Ctrl+V, or click the tool 
button.  
This option provides the user with the ability to view any stored file including: Data Log, Power 
Plot, Width/Position strip chart, Test, Profile Snapshots, and .ini files. 

 

To view a file: 
1. Select View File from the File menu. 

2. Select the "File Type" for the file to be viewed; 

 

3. The dialog will default to the Knife-Edge Profiler directory where the files are typically 
located. 

4. Click on a file from the list on the left. 
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5. Click OK. The file can now be displayed in the notepad application. 
 

 
Create Filter File 
Create Filter File is selected from the File menu. The keyboard shortcut is Ctrl+A. 
This option enables the user to define a new optic filter file. Because silicon detectors saturate 
easily, it is frequently necessary to insert one or more filters in front of the detector to attenuate 
the beam and prevent saturation. The wavelength response of these filters is not flat, so it is 
necessary to install the transmission properties of the filter in the software to obtain proper power 
measurement and gain setting for the detector amplifier. 

The Filter file contains: 
The Filter file contains a table with two columns. The first column is the wavelength (in 1 nm steps 
or larger steps). The second column is the known transmission of the filter for the corresponding 
wavelength. The Knife-Edge Profiler software uses straight-line interpolation to determine 
transmission values for wavelengths that lie between wavelengths listed in the file. 

Absolute Power Calibration 
A Filter file can be created to provide absolution power calibration. First measure the power of the 
beam with a calibrated power meter. Then measure the reported power with the Knife-Edge 
Profiler Power Window, with the Filter option OFF. Now perform the following calculation and 
use the % transmission value obtained when creating the Filter file. 

 

% Transmission Value = (Real Power / KEP Power) * 100 

Creating a new Filter file 
1. Select Create Filter File from the File menu. 

 

2. There are 3 Value Entry boxes, each for line number (no.), Wavelength (nm), 
Transmission value (%). The data box labeled as "No" starts with the line number value 
of "1". 

3. Type a value for wavelength, or change it from the arrow keys of this data box. If a 
wavelength outside the operating range of the detector head is entered a warning will be 
displayed. 

4. Type the percent transmission, or change it from the arrow keys if this data box. 

5. Press NEXT button to insert the next data line into the Filter file. The data box labeled as 
"No" will display the value of "2", go back and perform steps 3, 4 and 5 until all the 
desired wavelength/transmission points have been entered. 

6. Press COMPLETE button, when you are done with the filter creating procedure. Knife-
Edge Profiler will then display a file storage dialog. Press CANCEL button to cancel the 
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attenuation data file creation. 

7. In the file dialog there is no need to change the "File Type" because FLT is the default. 
8. The Knife-Edge Profiler data files are located in the “Data” folder in the Knife-Edge 

Profiler directory. The Knife-Edge Profiler directory is located in “Program Files” by 
default.    

9. Type a filename for the filter file in the box below the word "File name". The filename 
must be less than 9 characters and contain no spaces. There is no need to have the file 
name end in .FLT as the program will automatically save the file with that extension. 

10. Click OK. 

 

 

 Print... 

Print... can be selected from the File menu, or via the button  on the ToolBar. 
 

  
 
Print... allows the user to print an entire saved data file.  Saved data files include a pre-saved text 
file or a pre-saved BMP file.  
To select and setup a specific printer, select Print Setup from the File menu.  The printer must 
be selected prior to selecting Print... 
 
Print...  allows the user to print an entire saved data file. The data is printed in the same format as 
shown on-window utilizing the View File option. 
To select and setup a specific printer, select Print Setup from the File menu prior to selecting 
Print… 

To print a text file: 
1. Select Print... from the File menu. Then select "Text file". A standard Windows file dialog 

is displayed. Alternatively, press the keyboard buttons: Ctrl+P. 
2. Select the "File Type" for the file to be printed; 

 

3. The Knife-Edge Profiler data files are located in the “Data” folder in the Knife-Edge 
Profiler directory. The Knife-Edge Profiler directory is located in “Program Files” by 
default.    

4. Click on the desired file from the file list on the left. 

5. Click OK. 
To print an Image file: 

1. Select Print... from the File menu. Then select "Image file". A standard Windows file 
dialog is displayed. Alternatively, press the keyboard buttons: Ctrl+I 
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2. Select the "File Type" for the file to be printed; 

 
3. There should be no need to change the directory, data files should be stored in the Knife-

Edge Profiler directory, (the default). 

4. Click on a file from the file list on the left. 

5. Click OK. 

 

 
Print Window 
 
Print Window enables an immediate printing of the active window.  The colored title bar indicates 
the current active window. 
Print Window can be selected from the File menu, or the keyboard shortcut F12. 
 
A message box "Printing..." is displayed when the window graphics is being transferred from the 
program to the printer via the Windows Print Manager. 
 
To select and setup a specific printer select Print Setup from the File menu prior to activating 
Print Window.  
 

 The time required for printing graphics screens in Windows environment is dependent on 
the computer resources 

 
 
Print Screen 
 
Print Screen enables an immediate printing of the current full screen display. 
Print Screen can be selected from the File menu, or the keyboard shortcut Ctrl+F12. 
 
A message box "Printing..." is displayed as long as the screen graphics are being transferred 
from the program to the printer via the Windows Print Manager. 
 
To select and setup a specific printer, select Print Setup from the File menu prior to selecting 
Print Window.  

 The time required for printing graphics screens in Windows environment is dependent on 
the computer resources. 

 
 
 
Print Setup 
Print Setup is selected from the File menu. 
This option enables the user to load the appropriate printer driver, set the orientation and paper 
size. Make sure the appropriate printer driver is selected prior to activating Print File. 
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 Start Log 
Start Log is selected from the Options menu, or the Tool Bar. 

Start Log is disabled until the following parameters are configured in Log Setup; 
 The duration of the experiment,  
 The rate of data logging  
 The Log file name. 

When the data saving process is active a Log banner is displayed in the top corner of the 
Window area.  
During data collection the Start Log menu item and tool bar icon will change to Stop Log. 
 
 

 Stop Log 

Stop Log is selected from the Options menu, or the Tool Bar . 
A Log operation can be terminated early by activating Stop Log. If data collection is not stopped, 
the data collection operation will automatically end after the user specified Duration. 
The data collection will save data according to the parameters set through the Setup Log. 
 

 Log Setup 
The Data Collection Setup is selected from the Tool Bar Options menu. 

This setup window allows the user to 
customize the Log operation. The 
data collection rate and the data 
filename can be entered from 
Settings tab. Data can be saved 
either to a Log file or Excel format 
for further analysis. 

LogType: - Select the desired file 
type: Log file or Excel file.  The Log 
file is saved in a standard text format.  
The Excel file is saved as an Excel 
Workbook.   

File Name: - Click the Browse 
button to assign a File name and 
location for the data file. 
 
Note:  When LOG file type was 
selected, all data collected will be 
saved with the file extension *.log. 

The .log extension designates the data as a text file and can be imported into other programs. 
When the Excel file type is selected the data will be saved as the file name *.xls. 
 
Log settings 

LogMode:This mode selection determines the method of data collection.  The Time mode 
selection allows data collection at a rate resulting from the interval and duration settings.  
The Points mode sets data collection to the specified number of points. 
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Interval: The time interval determines the time between consecutive data points. 
Duration: The total amount of time required to complete the data collection.  

 
When the desired setup parameters 
are selected, click the OK button.  
The data collection process (Log file) 
is initiated by selecting the Start Log 
menu item. 
 
The end of each Log file contains a 
statistics summary, including: 
Minimum value, Maximum value, 
Mean value and Standard deviation 
value for each parameter. 
The *.log file can be imported into 
other programs. See Importing Files 
into Excel. 

 The Log setup is disabled 
when data collection is in 
progress. 

 
 
 
Start/Stop Link 
The Start/Stop Link is selected from the System Menu. The keyboard shortcut for Start Link is 
Ctrl+K. 
The Start Link command provides the capability to operate an RS-232 or TCP/IP communication 
channel for serial data transmission. Any displayed data or pre-saved file can be transmitted from 
Start Link. Typically this feature is used to transfer real time data from the Knife-Edge Profiler 
system to another computer over a null-modem serial cable. The other computer can receive the 
data using a program that can communicate over a COM port like the Windows HyperTerminal 
program. 

To transmit a file over RS-232: 
1. Connect the Knife-Edge Profiler system to another computer using a null-modem cable, 

See Making a Null Modem Cable. 

2. Before using Start Link, set the Link parameters in Link Setup. Each link parameter must 
be configured to match the communications protocol of both computers receiving data. 

3. Enable the receiving program to receive the data. 

4. Select Start Link from the System Menu. A standard Windows File box is displayed. 

5. Select the "File Type" for the file to be sent; 
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6. There should be no need to change the directory because most files should be stored in 
the Knife-Edge Profiler directory. 

7. Click on a file from the file list on the left. 

8. Click OK. A link status will be displayed in the upper left-hand corner of the Window area: 

 
The file is transmitted in the Background while Knife-Edge Profiler continues to capture 
data. When finished the Linking status message will disappear. To stop a Link in 
progress, select Stop Link from the System menu. 

 

 
Link Setup 
Link Setup is selected from the System Menu. The keyboard shortcut for Link Setup is Ctrl+K. 
The Link Setup allows the user to configure the system for a particular set of parameters needed 
for the RS-232 transmission. The default values are typical for this kind of transmission, are 
shown below. 

 
Port: The COM port setting selects the port utilized for 

RS-232 transmission from the Knife-Edge Profiler based 
computer.   

Transmit: The Transmit radio button selection toggles 
the transmission type between transmit a file or real-time 
data. 
 
 
 
 
 
 
 
 

 
Set RS-232 serial parameters: 

Bits per second: The Bits per second selection 
determines the transmission rate (baud rate) of the data 
transmission. 

Parity Bit: The Parity Bit selection determines the 
Parity Bit utilized for robust serial communication. 

Data Bit: The Data Bit selection determines the  
number of data bits utilized for transmission. 

Stop Bit: The Stop Bit selection determines the  
number of stop bits utilized for transmission. 
 
Press OK to confirm the selection or CANCEL to restore 
previous settings. 
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Port 
The Port selection option is accessed from Link Setup. This setting should only be changed 
when utilizing the RS-232 link communications. 
The Port setting is utilized to set the computer communication (COM) port for RS-232 data 

transmission. 
 
The possible values for Link transmission port are: "1" 
(COM 1) and "2" (COM 2), "3" (COM 3) and "4" (COM 4). 

 
 Choose a COM port that does not conflict with the 

COM port being used.  
 

 
 

 
Transmit 
The transmit option is accessed from Link Setup. This setting should only be changed when 
setting the RS-232 link communication. 
 

The possible values for Link transmission port, are: File and Data. 
Selections are made with Radio Buttons. 
The Transmit setting is selected for either on-line transmission of live Data or transmission of a 
static pre-saved text File. When Data is selected, the system will send the following data 
depending on the active window: 
 

 
Low Resolution mode: 

$ Time (x.x) Power (x.xxx) PositionX (x.x) PositionY (x.x) WidthV (x.x)  WidthW (x.x)  
  WaveValue ClipLevel Average FilterName SystemNumber 
For example: 
 $ 2.4 0.375 230.5 400.1 1234.4 2345.5 633 13.5 4 NG4.FLT 6715 
 
High Resolution mode: 

$ Time (x.x) Power (x.xxx)  WidthV_I Widhtv_II WidthV_III  WidthW_I WidthW_II 
WidthW_III WaveValue ClipLevel_I  ClipLevel_II ClipLevel_III Average FilterName 
SystemNumber 

 
For example (Profile V mode): 
 $ 2.4 0.375 1234.4 765.3 234.5 0.0 0.0 0.0 633 13.5 50.0 80.0 4 NG4.FLT 6715 

 To stop a Link in progress, select Stop Link from the System Menu. 
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Bits per second/Baud Rate 
The Bits per second/Baud Rate setting is accessed from Link Setup. 

Bits per second, (or Baud Rate), is the transmission rate for the RS-232 link. The possible values 
are: 110, 300, 600, 1200, 2400, 4800, 9600, 19200, 38400, 57600 and 115200. 

 
 
 
 
 
This setting must match the corresponding setting on the 
receiving computer. 
 

 

 

 

 
 

Parity Bit 
The Parity Bit option is accessed from Link Setup. This setting should only be changed when 
utilizing the RS-232 communication link. 

 
 
 
The Parity Bit determines whether or not a parity bit is to be 
transmitted. The possible values are: None, Odd, Even, 
Space and Mark. 
 
This value must match the corresponding setting on the 
receiving computer. 
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Data Bit 
The RS-232 data bit selection is accessed from Link Setup. 

 
 
 
 
The Data Bit setting determines the number of bits utilized 
for the RS-232 transmission. The possible values are 4,5,6,7 
and 8. 
This setting must match the receiving computer setting. 
 
 
 
 
 

 
 
 
Stop Bit 
The Stop Bit option is accessed from Link Setup. This setting should only be changed when 
setting the RS-232 link parameters. 

 
 
 
Stop Bit determines the number of stop bits to be 
transmitted.  
The possible values are 1 or 2. 
This setting must match the same setting on the receiving 
computer. 
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Slave Mode 
 
After selecting the Link Setup parameters the user can activate the Slave Mode option from the 
System menu. The keyboard shortcut for Slave Mode is Ctrl+M. Transmit parameter should be 
selected as Data. 
 

  
 
After selecting the Slave Mode option, a status window will be displayed in the upper left-hand 
corner of the Windows area.  
 

  
In order to receive transmitted data on the master computer it is necessary to press button ‘d’ on 
the keyboard or send the Knife-Edge Profiler program an ASCII code for ‘d’. To terminate Slave 
Mode it is necessary to unselect this option in System menu (terminate the Slave Mode from 
Knife-Edge Profiler program end). The user can terminate Slave Mode from the master computer 
by pressing the button ‘s’, (or sending the slave computer an ASCII code ‘s’). 
The receiving program at the master computer is not provided with the Knife-Edge Profiler 
product; It should be written according to the user’s application needs. 
 
 
 
 
 
Making a Null Modem Cable 
A null modem cable can be made from a standard RS-232 cable by connecting the pins on one 
end of the cable to the pins on the other end as shown below. 

Null-modem with 25 pins on both sides 
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Null-modem with 9 pins on one side and 25 pins on the other side 

 

Null-modem with 9 pins on both sides 

 
 

 

 
Exit 
 
The Exit function is selected from the File menu. The keyboard shortcut is Ctrl+X. 
Use this option to terminate the Knife-Edge Profiler application. 
The following dialog is shown when you exit the program and Save Settings on Exit is not 
enabled. It is a reminder to save the current setup parameters. 

 
Select Yes to exit and save current user settings. 
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View Menu 
The View menu operates the functional windows. The following commands and menu items are 
available: 

 
 
The corresponding keyboard shortcuts are shown to the left of the corresponding item. These 
shortcuts may be activated from the Main Window by pressing the appropriate keyboard 
combination. 
A check mark in front of a menu item indicates that that function is active. 
If a menu item is gray it indicates that item is unavailable. Conditions or Setup parameters may 
be required for the item to be active.  Review the user manual text or help associated with the 
gray item for additional setup information. 

 When in Low Resolution, all display windows are available and can be activated 
at the same time. 

 When in High Resolution, the Position Window is not available and only one 
Profile window can be open at once. This limitation is a result of a hardware limitation. 

 

 

 Power 
The Power Window can be turned ON and OFF by choosing Power from the View menu.  The 

keyboard shortcut is F2, or click the Power icon in the Tool Bar  
The Power selection activates the power 
meter display window. The display shows 
real-time power as a needle graph or a 
digital value. Several buttons provide 
easy and quick control of the Power 
functionality. 
 
Placing the mouse cursor over the Power 
display and pressing the mouse left hand 
button twice changes the position 
window to a graphical presentation only 
without the measurement data display on 
the right hand side of the window. 
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Placing the mouse cursor over the Power display and pressing the mouse left hand button twice 
changes the modified position window back to its original size and shape. 
 
The power units can be selected by clicking on the units displayed in the Power Window.  Each 
mouse click will cycle to the next unit (uW, mW and dBm). 
 

Power Buttons: 
 Null: The Null button will Activate or deactivate the ambient-light suppression. 
 Filter: The Filter button will Load or unload a pre-defined filter transmission file for power 

calculations. 
 Power Setup: The Setup button will display the Power Setup dialog containing various 

power related settings. 

 To get help on this window press F1 when Window is active. The Active window is 
the window with the highlighted title bar. 

 
Filter 
The Filter button is accessed from the Power window. 

 This button is not available when Knife-Edge Profiler is used with the InGaAs or 
detector head. 

Because silicon detectors can saturate very easily, it is frequently necessary to insert a filter in 
front of the detector.  The filter will attenuate the beam and prevent saturation. Since the 
wavelength response of the filter is not flat, it is necessary to install the transmission properties of 
the filter in the software to obtain a proper power measurement. The proper gain settings for the 
detector amplifier are also determined by the actual sensor output. The Filter option allows the 
user to load or remove any pre-defined filter transmission file to be utilized by the power 
measurement function. 

Choose a Filter file: 
The silicon detector heads come with 2 pre-defined Filter files, (NG4 and NG9). See Selecting a 
Filter. A custom filter file can be created through the Create Filter File command in the File 
menu. This is helpful if you want to calibrate the Knife-Edge Profiler system for accurate power 
measurement relative to a known instrument at a specified wavelength. 

Select the Filter File 

To inform Knife-Edge Profiler, which filter is installed in the 
detector head, click on the Load button in the Power Setup dialog. A file list is displayed, 
presenting all the available filter files. Select the desired filter file and confirm with the  OK button. 

 
Using the Filter 
 

Physically install the selected filter into the Knife-Edge Profiler head. (see Care and 
Handling) Click the filter button on the power meter panel display to activate the selected Filter 
file. The power measuring function will calculate power utilizing the selected Filter file. A banner 
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containing the selected filter filename will appear in the power display. (for  example ). 
Click the Filter button on the power meter panel display again to deactivate the 

selected Filter. Physically remove the Filter from the detector head. 
 
Null 
The Null button is accessed directly from the Power window. 
This button provides for ambient-light suppression to permit accurate analysis of the light source. 
When Null is not active, the value displayed in the Power window is the total power incident on 
the detector surface. When Null is active, the value displayed Power value is a result of the 
desired input only. 

� To Activate or Deactivate Null, place mouse cursor over the Null button and click the 
LEFT mouse button. 

Suppressing Ambient Light 
When activating Null, a message box 
appears, instructing the user to remove 
the light source and press OK. 
The system now measures the ambient 
light level. The OK button will cause the 
software to subtract the measured level 
from the subsequent measurements. 
 

The final prompt will indicate when the measurement has taken 
place and the laser can be turned on again.  The OK button will 
activate the Null.  A "Null" banner appears in the power display 
with the calculated value of ambient light displayed underneath. 

 
 

 
Power Setup 
Power Setup is selected from the Setup button in the Power window. 
Power Setup allows the user to configure the power measurement capability of the Power 
window. 
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 Units: Select the appropriate units for the power meter display. (mW, uW and dBm) 
 Filter: The Load filter button will display a Windows open dialog.  This dialog will allow 

the user to select the .flt file corresponding to the installed filter. 
 Display: The Display Radio Buttons allow the user to select the desired presentation. 
 Status Power: Toggle between displaying the power reading at the Status Bar and 

disable the power reading display. 
 

Units 
The Power Units are selected from the Power Setup dialog. 
The Units option enables changing the units on the power meter display. The possible values are: 
mW, µW and dBm. 
Both the needle scale and the numerical power display are updated accordingly. 
Set the desired power units with the Radio Button. The units can also be selected by clicking on 
the units displayed in the Power Window.  Each mouse click will cycle to the next unit (uW, mW 
and dBm). 
 
Power Display 
The Display option is selected from the Power Setup window. 
This option provides three types of presentations for the power meter: 

1. A graphical needle graph and a small digital presentation for the measured power. 

2. A large digital presentation for better visibility at a distance. 

3. A bar graph presentation of the measured power. 
 
For the appropriate display check the Radio Button. 
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 Power Range: The Power Range selection allows the user to specify the display range.  

Select the values appropriate to the current laser input power. 
 Alarm limits: The On/Off box must be checked to access the Alarm Limit values.  Set 

the desired values for visual alarm indicators in the Power Window.  A Computer beep 
will also be active if the Sound box is checked. The numerical power value is turned in to 
red indicating the power value is exceeded. 

 
 

Power Range 
The Power Range is selected from the Power Setup window. 
The Power Range magnifies the beam power display. The needle graph display is affected 
accordingly. 
This is a useful feature when monitoring small changes in beam power. 
Define the Zoom area by setting the minimum and maximum power levels from Min or Max box 
utilizing the Value Entry Box. 
 
 
 
Alarm Limits 
The Alarm Limits are selected from the Power Setup dialog. 

The limits are defined by the area within the needle graph display.   
Audible and visual indicators will warn the user if the power drifts 
outside the user specified zone. The allowed zones are marked in 
black color, while non-permitted operation zones are marked in 
red on the needle graph.  When the On/Off box is checked, visual 
indicators will be provided when the user specified limits have 
been exceeded.  The Beep box will provide additional audio 
beeps when the specified limits have been exceeded. 

Alarm Limits Options: 
 On: Set Alarm Limits ON or OFF using the Check Box. 
 Sound On: The Sound option is used for generating an audible warning in case the 

measured power exceeds the preset Alarm Limits levels 
 Min: The Min option is used for setting the minimum range value for Alarm Limits 

 



 

Knife-Edge Profiler Manual   47 

 Max: The Max option is used for setting the maximum range value for Alarm Limits 

 The minimum value set for Alarm Limits should be bigger/equal the minimum value 
set for Range. The maximum value set for Alarm Limits should be smaller/equal the 
maximum value set for Range. 

 
Sound On 
Sound On is selected from the Power Setup dialog. 
Use this option to enable an audible warning when power drifts outside the pre-set Max and Min 
alarm limits. Toggle between Sound On and Sound Off using the Check Box. 
 
 
Max  
Max is selected in the Power Setup dialog.  The max setting is displayed in the “Range and 
Limits” tab.   
The maximum setting corresponds to a user selected maximum power level.  The Max setting in 
the Range dialog section will set the maximum value displayed on the power scale.  The Max 
setting in the Alarm Limits dialog section will be displayed appropriately on the Power Window.   

 When the Alarm is active and the appropriate Min/Max levels are set, the user will 
be notified when these limits are exceeded. 

 
 
Min 
Min is selected in the Power Setup dialog. The min setting is displayed in the “Range and Limits” 
tab.   
The minimum setting corresponds to a user selected minimum power level.  The Min setting in 
the Range dialog section will set the minimum value displayed on the power scale.  The Min 
setting in the Alarm Limits dialog section will be displayed appropriately on the Power Window.   

 When the Alarm is active and the appropriate Min/Max levels are set, the user will 
be notified when these limits are exceeded. 
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 Colors: The Colors tab allows the user to specify colors for the Power Window.  A 

standard Windows color pallet is available. 
Upon selecting the required parameter value, press OK to confirm the selection, press Cancel to 
restore the previous settings. Alternatively, press System button to reach the System Setup. 

 

 

 V  Profile 
The V Profile window can be turned ON and OFF from the View menu. The keyboard shortcut is 

F3, or click the Tool Bar button.  

 
The Profile Window 
graphically displays 
details of the beam’s 
intensity profile along the 
V axis. In addition to the 
profile information, there 
is a display of beam 
width at three different 
clip levels. The three 
levels (80%, 50% &13.5) 
of the Clip Levels may 
be changed using the 
Setup button. The third 
clip level (13.5%) is the 
System Clip level and it 

can be modified from System Setup in the System menu. 
 
Placing the mouse cursor over the Profile display and pressing the mouse left hand button twice 
changes the position window to a graphical presentation without the measurement data display. 
Placing the mouse cursor over the Profile display and pressing the mouse left hand button twice 
changes the modified position window back to its original size and shape. 

Profile Buttons: 
 Gaussian The Gaussian selection compares the displayed profile to an ideal Gaussian in 
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real time. 
 Zoom The Zoom selection is available only in High-Resolution mode. The Zoom function 

increases or reduces the displayed X-Axis range. (spatial resolution) The profile peak will 
remain centered on the display when the Zoom is changed. 

 Setup The Setup selection provides access to the profile settings including: background 
color, grid lines, auto-scaling of the profile peak and clip level adjustment. 

 To get help on this window press F1 when the Window is active. The Active 
window is designated with the highlighted title bar. 

 
 
Gaussian 
The Gaussian button is selected from the Profile window. 
This function determines how closely the measured beam profile matches a theoretical Gaussian 
profile. When the Gaussian button is activated, a Gaussian profile is overlaid on top of the current 
measured profile in real time. The gaussian fit profile is in red. The percent correlation and width 
comparisons utilize the currently selected clip levels. The comparison data is displayed adjacent 
to the profile data.   The comparison data includes data about the ideal Gaussian profile beam 
width as well as the deformation from the ideal Gaussian beam. 
 
 

 
To turn Gaussian Off press the 
Gaussian button again.  
 
 
 
 
 
 
 
 

 
Profile Zoom 
Profile Zoom buttons are selected from the Profile windows. 
This option allows the displayed X-axis range (spatial resolution) High-Resolution Profile, to 
Zoom In or Zoom Out, by a factor of two. The Knife-Edge Profiler software will maintain the 
display with the peak centered on the window. 

 
Each time the Up / Down arrow key button is clicked, the profile displayed area is increased / 
decreased by a factor of two. 

 This button is not available when Knife-Edge Profiler is used in Low Resolution 
mode. 
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Profile Setup 
The Profile Setup button is selected from the Profile window. 

Autoscale: The Auto-Scale 
selection forces the profile to be 
displayed utilizing the full height of 
the profile window. 

Grid: The Grid selection displays 
a grid pattern behind the profile. The 
grid is used to provide a visual point 
of reference on the displayed profile. 

Gaussian:  The Gaussian 
selection will provide a pure 
Gaussian reference overlay on the 
displayed profile.  The Gaussian 
selection also provides a numeral 

Gaussian reference value. 
 Digital: The Digital selection will display the current measurement results as digital 

values only. 
 Levels (%): The Level selection defines the clip levels for the three beam width 

measurements. 
 

Auto-Scale 
Profile Auto-Scale is accessed with the Profile Setup button in the display window. 
This option enables the user to toggle Auto-Scale On and Off.  
To turn Auto-Scale ON, use the Check Box. When Auto-Scale is ON the beam intensity profile is 
always normalized to fit 100% of display window. 

 Auto-Scale must be ON for the clip level bars to be visible. 

When Auto-Scale is OFF the beam intensity profile is not normalized to 100% of the display 
window and the beam peak is observed as it changes. This function is helpful during a focusing 
process. The peak intensity changes may be observed as a function of the focus, showing the 
variations in beam’s peak with respect to the changes in beam size. 

 This function affects only the graphical presentation on window. 
 
 
Profile Grid 
The Profile Grid is set from the Profile Setup dialog. 
The Profile Grid option turns on the grid pattern displayed in the profile window. 
Use the Check Box to toggle the grid ON. 

 
Clip Levels 
The Clip Levels are adjusted from the Profile Setup dialog. 
The three Clip Levels are utilized to display beam diameter information on the Profile and 
Projection windows.  

 A clip level defines the percentage of the peak intensity profile at which beam is 
measured. For example, a clip level of 50% indicates that the beam is to be measured 
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at its full width at half maximum (FWHM), whereas a clip level of 13.5% measures the 
beam at a point which is 13.5% of the peak of the profile. The 13.5% level corresponds 
to the 1/e2 point of a Gaussian profile. 

Both the V and W profile windows display the width of the beam at three clip levels 
simultaneously. If Autoscale is ON, there will be three clip levels represented by solid horizontal 
lines superimposed on the profile. The default clip levels are 80%, 50% and 13.5%. The top two 
clip levels are the Supplementary Clip Levels. The System clip level is on the bottom. 

To Change Clip Levels from Profile Setup Window: 
Change the Clip Level value for each one of them with the Value 
Entry Box. The clip levels may be set in 0.1% increments.  

 

 

 

To Change Clip Levels on the Profile Window: 
Place the mouse cursor just above or below the width level bar to be changed, then press the 
mouse LEFT button and drag it up or down, while watching the change in Clip Level setting on 
the profile presentation. The clip level can be moved vertically to a new clip level in 0.3% 
increments. When performing this operation it is helpful to size the Profile Window as large as 
possible. 

 
 

Colors:  The Colors selection tab will provide 
the ability to set desired colors for the 
Background, Plot and numerical data.  A 
standard windows color pallet is available for 
color selection.  

 All settings work independently in both the 
W and the V profiles. Auto-scale could be ON 
for one profile window and OFF in the other 
profile window. 

 
 
 
 

 W Profile 
The W Profile Window can be turned ON and OFF from the View menu. The keyboard shortcut is 

F4, or click the Tool Bar Button.  
Review the functions associated with the V profile Window for additional information. 
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 Position 
The Position Window can be turned ON and OFF from the View menu. The keyboard shortcut is 

F5, or click the Tool Bar button.  

 This window is not available in High Resolution mode. 

The Position function provides 
a real-time display of the beam 
centroid position, as well as a 
beam foot print. This window 
can be used to align the 
detector head with the 
incoming laser beam. Settings 
can also be customized by 
clicking the Setup button. 
In the main window area, the 
detecting area of the sensor is 
represented by a 9x9 mm 
square for the KEP-7-SL Head, 
by a 5 mm diameter circle for 
the KEP-3-SL version, and by a 
3 mm diameter circle for the 
KEP-3-IR version. Review the 
current head specifications for 
input aperture values not 

previously given. 
The solid cross hair target appears within the main display area will represent the local Earth 
reference frame. This reference display will remain fixed. The intersection of these two solid lines 
is the center of the detector. The diagonal lines labeled V and W are the axes along which the 
measurements are made and displayed. 
When a laser beam enters the aperture of the head, it is represented as a dotted ellipse. If the 
beam is circularly symmetric, a dotted circle will appear. This ellipse indicates the "footprint" of 
the beam in the plane of the rotating knife-edges. The ellipse will change shape and orientation 
as the beam expands and contracts in different directions. A small cross indicates the location of 
the center of the beam. The X and Y coordinates of this cross are shown in µm units under the 
title "Centroid". A display box contains an estimated size of the major and minor axes of the 
ellipse, as well as the angle of orientation (under the title: Ellipse Data) 
 
Placing the mouse cursor over the Position display and pressing the mouse left hand button twice 
changes the position window to a graphical presentation only without the measurement data 
display on the right hand side of the window. 
Placing the mouse cursor over the Position display and pressing the mouse left hand button twice 
changes the modified position window back to its original size and shape. 
 

 These values are merely estimates and are less accurate than width 
measurements made in the Profiles functions. 

 To get help on this window press F1 when the Window is active. The Active 
window is the window with the highlighted title bar. 
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Position Setup 
The Position Setup is selected from the Position window. 

Zoom: The Zoom selection 
activates the zooming capability of 
the position display.  Small beams 
are enlarged and centered on the 
plot. 

Grid: The Grid selection enables a 
grid pattern on the position display. 

Digital: The Digital selection 
displays the position data as a digital 
display only. 
 
 
 

Position Zoom 
The Position Zoom is adjusted from the Position Setup window. 
The Position Zoom is used to view the footprint of small beams more clearly. It is recommended 
that this option be activated for beam widths of less than 300u. Once activated, the area 
immediately surrounding the beam is magnified to show the footprint in the greatest possible 
detail. The size of this region is automatically scaled up or down as the beam changes size. 
The "ZOOM ON" message is displayed inside the position screen area. 
Toggle between Zoom Position On and Off with the Check Box. 
 
Position Grid 
The Position Grid is selected from the Position Setup window. 
The Grid option turns on the grid pattern displayed in the position plot area. 
Use the Check Box to turn the Grid ON. 
 
 

 
Colors: The Colors tab allows the selection of 

various plot colors.  Each color selection uses 
the typical Windows color pallet for selection. 
Upon selecting the required parameter value, 
press OK to confirm the selection, or press 
Cancel to restore previous settings. 
Alternatively, press System button to reach the 
System Setup.   
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 Projection 
 
The Projection Window can be turned ON and OFF from the View menu. The keyboard shortcut 

is F6, or click the Tool Bar button  
The 3D image can be rotated 
along the vertical and 
horizontal axes using the 
following routine: 
 1.  Place the mouse 
cursor over the 3D image. 
 2.  Hold the left mouse 
button down (note that the 
mouse cursor shape has 
changed) 
 3.  Drag the mouse while 
pressing the left mouse 
button. You can move the 
cursor up/down or left/right. 
The image will rotate 
accordingly. 

 
Placing the mouse cursor over the Projection display and pressing the mouse left hand button 
twice changes the window to a graphical presentation only without the measurement data 
displayed on the right hand side of the window. 
 
Placing the mouse cursor over the Projection display and pressing the mouse left hand button 
twice changes the modified position window back to its original size and shape. 

 The Projection window uses a time intensive calculation. When Projection is ON 
the update rate may slow down.  

 This window is not available in High Resolution mode. 

The Projection function provides either a two-dimensional or a three-dimensional view of the 
beam intensity profile. 
The Projection Window has a Projection Setup dialog for setting the parameters associated with 
this presentation. 
The Projection is created using a mathematical process called "Reconstructive Tomography". 
The displayed resolution is 32x32 regardless of beam size. This same type of process is used by 
X-ray systems to create X-ray images. More knife-edges will yield a greater the level of detail. For 
a beam distribution that is significantly non-gaussian the standard seven knife-edge system can 
reconstruct a plot that closely matches the real beam. When examining near-gaussian beams 
three knife-edges can give an accurate intensity distribution. 

 To get help on this window press F1 when it is active. The Active window is 
indicated with the highlighted title bar. 
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Projection Setup 
The Projection Setup button is selected from the Projection window. 
 

Axes: The Axes selection 
activates axis orientation symbol. 

Grid: The Grid selection activates 
the 2D window Grid. 

Digital: The Digital selection 
displays the measurement results 
as a digital display only. 

Dimension: The Dimension Radio 
Button selection toggles between 
2D and 3D displays. 
 
 
 

 
 
Axes 

The Axes Direction indicators are selected from the Projection Setup 
dialog. This dialog can be accessed with the Setup button in the 
Projection window. 
When activated, this function displays the orientation of the V and W axes.   
Turn the Axes legend ON and OFF with the Check Box. 

 
 
Projection Grid 
The Projection Grid is toggled from the Projection Setup dialog. 
This selection toggles the grid pattern in the position plot area. This setting is only available for 
the 2D projection. 
Use the Check Box to turn the grid ON. 
 
Dimension 
Dimension setting is selected from Projection Setup window. 
The Projection Window can display the beam intensity profile in two dimensions or three. This 
function toggles between the 2D and 3D representations utilizing the radio buttons. 

 The fastest update rate is achieved with the 2D selection. 

Both the 2D and 3D views are mathematical constructions based on profile information obtained 
from the knife-edges. 
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An example of High resolution 2D 

 

An example of Medium Wire Density 3D 

 

 

3D Features Setup 

 
 

 Rotation: The Rotation function affects 
the optical axis or azimuth of the 3D display 
Adjust the viewing angle using the Value 
Entry Box. The possible values for the 
Rotation Angle are 0 through 360 
degrees. The Rotate Angle value can only 
be changed when the Auto Rotate box is 
not selected.  The projection can be made 
to rotate automatically with a selected step 
interval by utilizing the Auto-Rotate Check 
Box.  When the Auto Rotate box is 

selected the step increment can be set to the desired value.   
Tilt – The Tilt function selects the tilt angle of the 3D plot. The 3D plot can be viewed at 

horizontal tilt angles form 0 to 90 degrees in 1degree increments. The horizontal tilt angle can be 
entered with Value Entry Box. 
 

  Free adjustment of rotation and tilt angle is accomplished by placing the cursor over the 
graphical 3D display while holding the left mouse button down.  Movement with the left mouse 
button down will adjust the tilt and rotation simultaneously. 
 

Wire density – The wire density selection determines the number of wires utilized to construct 
the 3D plot.  The high-density setting can affect the update rate of the displayed 3D profile, based 
on the performance of the computer system and video card.  
When all of the desired parameters are set, click OK to confirm the selection, click Cancel to 
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return previous settings. 
 
 
 
Rotation Angle 
Rotation is adjusted from the Projection Setup dialog. 
The Rotation function is used to change the viewing angle of the 3D projection. The rotation takes 
place about the optic axis or azimuth of the 3D display 

Adjust the rotation angle with the Value Entry Box. The possible 
values for the Rotation angle are 0 through 360 degrees. When 
Auto-Rotate is On the user can set Step increment between 1 and 
30 degrees.  The Auto-Rotate function will rotate the 3D display 
continuously at the user specified step increment.  When Auto-
Rotate is Off the user can set Rotation Angle to any desired value 
between 0 through 360 degrees. 

 Place the mouse cursor over the currently displayed 3D Plot and hold the left mouse 
button down.  Drag the mouse cursor to display the 3D plot the desired rotation and tilt angle. 
 
The projection can be made to rotate automatically in 5-degree increments by selecting the Auto 
check box. 
 

 
Color Resolution: This options toggles 

between a 16 Color and a 256 Color 
presentation. 
Upon completing the desired setup click OK 
to confirm the selection. Click Cancel to 
restore the previous settings. Alternatively, 
press the System button to reach the System 
Setup. 
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 Plot Power 
The Power Plot Window can be selected from the View menu. The keyboard shortcut is F7, or 

click the Tool Bar button . 

 
Power Plot window provides a graphical display of beam Power versus Time. The graph 
presentation includes the temporal power fluctuations and provides a way to observe long-term 
power fluctuations. The Power Plot window also displays the number of points accumulated, 
elapsed time clock and the exact Time/Division partition. 

Plot Buttons: 
 Pause: The Pause button is used to temporarily stop power logging. Press the button 

again to continue. 
 Reset: The Reset button is used to reset all accumulated data.  (History displayed in the 

current session) 
 Save: The Save button is used to save current or most recent 500 measurements 

displayed. 
 Setup: The Setup button is used to set the relevant Plot Setup parameters. 

 To get help on this window press F1 when it is active. The Active window is the 
window with the highlighted title bar. 

 
Reset 
The Rest button is accessed from the Plot or Chart windows. 
The Reset option enables the user to reset all accumulated data for the Plot / Chart functions in 
the current session. 
To activate Reset place the mouse cursor at this button and click its LEFT button once. The Plot / 
Chart graph will redraw after the Reset.  The currently accumulated data points are discarded. 
 
Save Plot 
The Save button is accessed from the Plot window. 
This option enables the user to save up to 500 data points. Several Plot files can be saved during 
the same session. 
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Data is saved as text in a file named *.plt, where "*" is composed of the date and time as follows: 
ddhhmmss.PLT 

Where dd = day, hh = hour, mm = minutes, ss = seconds. 
The default file name can be changed later.  This process will allow for uninterrupted data 
collection. 

Plot file Format: 
The data is stored in TEXT file format and contains the following data: 

 General details like system name, date, etc. 
 A table of time values paired with the displayed Power values in milliwatts. 

 

 
Plot Setup 
Plot Setup is selected from the Setup button in the Plot window. 

 
 
 
 
 
 

Range: The Range tab provides controls to allow 
the user to specify the vertical plot scale. 
 
 
 

 
 

Plot Range 
The Plot Range is selected from the Plot Setup window.  The Plot Setup window is accessed 
with the Setup button in the window then select the “Range” tab. 
The vertical scale of the Plot graph can either be automatically scaled (check the AutoRange 
option), or held at a user specified value. 
When Auto-Range is active the system continuously adjusts both the minimum and maximum 
limits of the Plot. The Auto-Range is designed to display the greatest amount of detail in the 
window. 
When Auto-Range is turned off, the system leaves the scale at the last auto-scale setting and 
manual control of the scale can be introduced. Use the Min and Max Value Entry Boxes for the 
appropriate scale adjustment.  When adjusting the Min and Max values avoid a situation where 
large measurement fluctuations may go beyond the maximum and minimum vertical scale.  The 
Off-Scale values will be displayed as flat lines at the top or bottom of the scale. 
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Time Scale: The Time control allows the user to 
specify the rate of data collection. 
 

Units: The unit selection control works in conjunction 
with the Range selection for vertical scale selection. 
 
 
 
 
 
 

Time Scale 
The Time Scale is selected from the Plot Setup or Chart Setup dialog. 
The rate at which the Knife-Edge Profiler software plots the data is controlled with this setting. Set 
the desired Sec/Div value with the Value Entry Box. 
The Time Scale will change the horizontal scale of the Strip Chart. The value can be changed in 
one second increments. The fastest possible rate of display is 0.2 sec, which corresponds to the 
maximum 5 Hz update rate.  The displayed data corresponds to a 5 Hz collection rate even 
though the display may not update at that rate. The higher the value of this scale, the slower the 
graph will scroll. 
 
 
Units Plot 
The Units are selected from the Plot Setup dialog. 
The user can toggle between mW and µW units for the Plot presentation. 
Select the units with the Radio Buttons. 

 
Colors: The Colors tab allows the selection of various 

plot colors.  Each color selection uses the typical 
Windows color pallet for selection. 
A complete windows color pallet is available for the 
desired color selection. 
Press OK to confirm the selection or CANCEL to restore 
previous settings. Alternatively, press System button to 
reach the System Setup to change global system 
parameters. 
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 Chart Width/Position 
The Chart Window can be selected from the View menu, the keyboard shortcut F8, or the 

following Tool Bar button.  

 This window is not available in High Resolution mode. 

The Width/Position Chart window 
provides a real-time strip chart 
display of beam position (X,Y) 
versus time, or beam width of V 
and W profiles measured at the 
System Clip Level. 
These charts enable the user to 
observe beam position stability, 
or beam width variations. The 
Chart Window graphically 
displays the absolute position or 
width versus Time, the number 
of points accumulated, elapsed 
time clock and the exact 

Time/Division scale increment. The setup button is used to set chart scaling and color options. 
The data can also be saved as a text file for external analysis. 

Chart Buttons: 
 Pause: Click the Pause button to interrupt the data collection.  The current data is not 

lost when you use this function.  When the Pause button is selected, it changes to a 
continue button to resume data collection. 

 Reset: Click the Reset button to clear the current data.   
 Save: Click the Save button to save the current data up to the most recent 500 points 

collected.  The Save function automatically assigns a file name corresponding the current 
date and time with a .CHT file extension.  The data file will be located in the Knife-Edge 
Profiler data folder.  

 Setup: Click the Setup button to access all of the Chart Setup parameters.  The setup 
parameters allow the user to set the data collection interval, vertical chart scale and 
colors.   

 To get help on this window press F1 when it is the active Window. The Active 
window is the window in the window area with the highlighted title bar. 

 
Reset 
The Rest button is accessed from the Plot or Chart windows. 
The Reset option enables the user to reset all accumulated data for the Plot / Chart functions in 
the current session. 
To activate Reset place the mouse cursor at this button and click its LEFT button once. The Plot / 
Chart graph will redraw after the Reset.  The currently accumulated data points are discarded. 
 
 
Save Chart 
The Save Chart button is selected from the Chart window. 
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This option enables the user to save up to 500 data points from the current session. The user can 
save several Chart files during the same session. 
Data is saved in a file named *.CHT file as a text file, where "*" is composed of the date and time 
as follows: 

ddhhmmss.CHT 
Where dd = day, hh = hour, mm = minutes, ss = seconds. 
The default file name can be changed later.  This process will allow for uninterrupted data 
collection. 

Chart file Format: 
The data is stored in TEXT file format and contains the following information: 

 General details: system name, date, etc. 
 Time values paired with the displayed X & Y Position values.   Or, 
 A table of time values paired with the displayed V & W  Width values. 
 All dimension values are in microns. 

An example Chart file: 
Chart File Data 
Knife-Edge Profiler, Version 1.00 
 
File:  C:\Program Files\KEP1035\10160540.cht 
Date:  10 Mar 2005 
Time:  16:05:40 
 
S/N:          1035 
 
Average:      1 
Wavelength:   1300(nm) 
Clip Level:   13.5% 
 
Time          Width W       Width V 
(sec)         (µm)          (µm) 
 
0.0           1682.566      2215.905 
1.1           1661.088      2248.827 

etc... 
 
 
 
Chart Setup 
Chart Setup is selected from the Setup button in the Chart window. The Chart Setup dialog 
contains the following tabs. 
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Range: Select a range for the Y axis on the Chart.  

The Auto-Zoom box will control the Y axis mode.  
When the box is checked the chart Y axis is 
automatically scaled by the software.  When the Auto-
Zoom box is not check, the user can set the Y scale 
with the minimum and maximum value entry boxes in 
the dialog.  Data that occurs outside of the user 
entered manual scale settings will be plotted as a 
straight line at the top, or bottom of the scale, as 
appropriate.   
 

Options: Selects either Position or Width versus 
Time Charts. The position selection will graphically 
display the absolute position data vs time in a strip 
chart form.  The Width selection will graphically 
display the beam width vs time in a strip chart form.  
Please verify the range selection before exiting the 
Chart Setup screen.   
 

Time scale: The Time selection will set the 
horizontal scale on the Strip Chart.  The horizontal 
scale contains 20 divisions.  Multiply the Time value 
by 20 to determine the amount of time utilized for a 
complete chart display.   
 

Colors: The Colors tab allows the selection of 
various plot colors.  Each color selection uses the 
typical Windows color pallet for selection.   
Utilize the Preview button to view the desired 
selection before exiting the Chart Setup screen.  If the 
selected color is not desired, click the Cancel button 
or select a new color.   
When you are satisfied with all of the selections 
utilizing each tab, press OK to confirm the settings. 
Click Cancel to exit the Chart Setup screen and revert 
to the previous settings.  
 

 
 
 
 
Status Bar Command 
The Status Bar can be hidden or displayed by selecting Status Bar from the View menu or using 
the keyboard shortcut Ctrl+Insert. 
This option enables the user to toggle between Show Status Bar and Hide Status Bar. 
When Status Bar is active there is an additional line appearing at the bottom of the window. This 
line contains panels displaying general system information and user settings.  
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Tool Bar Command 
The Tool Bar can be hidden or shown by selecting Tool Bar from the View menu or using the 
keyboard shortcut Shift+Insert. 
This option enables the user to toggle between the Show Tool Bar and Hide Tool Bar. 
When the Tool Bar is selected there is an additional line on top of the window containing Tools 
(picture shortcuts to some of the most common used system functions) along with date/time 
information. 
When this option is not selected, the Tool Bar line disappears. In this case the user has to 
activate the various system functions from the menu or keyboard shortcuts. 
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Options Menu 
The following items are available from the this Menu: 

 
 
A check mark in front of a menu item indicates that the 
function is active. 
If a menu item is gray it means that item is currently 
unavailable. A gray item indicates that additional conditions 
must be met for this item to be active. Review the manual 
text associated with the gray item for required setup 
information.  For example to start data collection the 
appropriate data collection setup parameters must be set. 
 
 
 
 

 
 

 Load Configuration File 
 Load Configuration File can be selected from the File menu.  The keyboard shortcut is   

Ctrl+O, or click the tool button  
 This option allows the user to load a configuration file containing the system setup    

parameters. The configuration files have the extension ".ini". 

    To load a pre-saved configuration file: 
1. Select Load Configuration File from the File menu. 

2. There is no need to change the "File Type" because .ini is the default. 
3. The Knife-Edge Profiler data files are located in the “Data” folder in the Knife-Edge 

Profiler directory. The Knife-Edge Profiler directory is located in “Program Files” by 
default.    

4. Click on the desired .ini file from the file list on the left. 

5. Click OK to load the file. The Knife-Edge Profiler software will update all windows with 
the new configuration. 

 Automatic Configuration 
The Knife-Edge Profiler software will automatically save the current configuration each time it 
is closed. The Save Settings on Exit condition is active by default.  The user can deactivate 
this condition from the Options menu. When this option is enabled, the Knife-Edge Profiler 
software will store the current configuration into the default configuration file, ($$$.ini) upon 
exit. When the software is started, it will automatically load the $$$.ini file. A file named 
Default.ini is the default configuration of the Knife-Edge Profiler software, it enables the user 
to restore factory defaults. 
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 Save Configuration File 
 Save Configuration File can be selected from the File menu. The keyboard shortcut is 

Ctrl+S, or click tool bar button . 
  This option allows the user to save the current Knife-Edge Profiler software settings. These 

configuration files have the extension ".ini". 

To save the current configuration: 
1. Select Save Configuration File from the File menu. 

2. There is no need to change the "File Type" because .ini is the default. 
3. The Knife-Edge Profiler data files are located in the “Data” folder in the Knife-Edge 

Profiler directory. The Knife-Edge Profiler directory is located in “Program Files” by 
default.    

4. Type a filename for the configuration file in the box below the word "File name". The file 
saving process will automatically attach the .ini file extension. 

5. Click OK. The configuration file can now be loaded at any time using Load 
Configuration File command in the File menu. 

Automatic Configuration 
 To have the Knife-Edge Profiler automatically save the current configuration each time Knife-

Edge Profiler software exits, select Save Settings on Exit from the Option menu. When this 
option is enabled, the Knife-Edge Profiler software will store the current configuration into the 
default configuration file, ($$$.ini). When the Knife-Edge Profiler software starts again it will 
automatically load the $$$.ini file. 
 

Configuration File Contents 
The following information is stored in a Configuration (INI) file. 

 System serial number 
 System resolution, (High/Low) 
 System wavelength setting 
 System clip level setting 
 Setting for averaging 
 Setting for headtilt 
 Setting for system beep 
 Active windows size & position 
 Setup parameters for each window 
 Test setup parameters 

 The configuration file does not include hardware settings. If the hardware settings are 
changed, the previously stored configuration files will work. The "System I/O address", 
and "System interrupt(IRQ)" are stored separately in a Newport KEP Series.cfg file. 

 
 
Save Image as... 
The Save Image as function is selected from the Options Menu.  
This function is used to save the screen presentation as a *.bmp or *.jpg file. 
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To save a file: 

1. Select Save Image As... from the Options menu. 

2. Select the "File Type" .bmp or jpg. 

3. Select the desired file directory. 

4. Type a filename for the image file in the box below the word "File name". The file saving 
process will automatically attach the appropriate file extension. 

5. Click OK. 
 

 
 

Save Snapshot 
 
The Save Snapshot as function is selected from the Options Menu.  
The snapshot image is captured as soon as you select the Save Snapshot option. You then save 
the snapshot image as an .SNP file. The snapshot file is saved in binary format and can only be 
processed by this application. 
 
To save a file: 

1. Open the Options menu and select Save Snapshot. The Save Snapshot File window 
displays. 

2. Enter a filename for the snapshot file.  

3. Click OK. 
 

 
View Snapshot 
 
To view a snapshot file: 
  

1. Open the Options menu and select View Snapshot. The Load Snapshot File window 
displays. 

2. Select a snapshot file.  

3. Click Open. The snapshot file displays. 
To close a Snapshot file, open the Options menu and unselect View Snapshot. The Knife-Edge 
Profiler restores real-time measurement displays, or click  in the upper right corner of the image 
window. 
 

 
Save Data in Text file... 
Save Data in Text file is selected from the File menu. 
The Save Data file function is used to save the profiles or projection data displayed. The default 
file extension is *.txt. The data is saved in a text file format for analysis with other programs. 
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 Profile Snapshots cannot be loaded back into the Knife-Edge Profiler software. 

To save a profile Snapshot: 
1. Select Save Snapshot File from the File menu. 

2. There is no need to change the "File Type" because .snp is the default. 
3. The Knife-Edge Profiler data files are located in the “Data” folder in the Knife-Edge 

Profiler directory. The Knife-Edge Profiler directory is located in “Program Files” by 
default.    

4. Type a filename in the box below the word "File name". The .snp file extension will 
automatically be attached during the saving process. 

5. Click OK. 

 
 
Importing Files into Excel 
All of the Knife-Edge Profiler files are stored in ASCII file format for easy printing, viewing and 
analysis. Loading any of data files directly into Excel will activate the import wizard. A "fixed 
width" or "space delineated" file format works best when using the import wizard. 
This graph was created in less than 5 minutes by importing a snapshot file into Excel. 
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 Start/Stop Test 
Start Test (or Stop Test if the Test Window is open) is found under the Options menu. This 

option can also be selected with the Tool Bar button.  This function is used to start and stop 
automatic online Pass/Fail testing for user-selected parameters.  

 
 
 
Parameters that are not specified 
in Test Setup are marked as 
Skipped in the Test window. 

 

 

 

 

 

Test buttons 
Pause: The Pause button temporarily stops testing. Press the button again to continue. 

Print: The Print button prints the test results directly to the default Windows printer. 

Save: The Save button saves the current test results in a file named *.tst. See Importing 
Files into Excel for information on creating charts from test files. 

Setup: The Setup button will display the configuration window utilized to set the test 
parameters. 

To close the Test window, select Stop Test under the Options menu. You can also click the Test 

button  on the Tool Bar. 

 To get help on this window press F1 when it is active. The Active window is 
indicated with the highlighted title bar. 
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Test Setup 
Test Setup is selected from the Test Window. This Setup window is used to enter general 
information about the Test and to activate any one of the nine parameters. When first configured, 
the Min and Max values will be based on the current detector head limits. 

 

 
User Name, User Data: The User 

Name / User Data lines are available 
to enter information associated with 
the test. 

Measurements: Any one of the 
listed 9 parameters can be activated 
by placing the mouse cursor at the 
option box and clicking its LEFT 
button once. Each active parameter 
requires a minimum and maximum 
level setting. 
 
Click OK to confirm the setting or click 
Cancel to abort. 

 
 

 
 

 
 

 Step 
Access the Step command to by selecting Step from the Options menu. The keyboard shortcut 

is F9 or you can click the icon  on the Tool Bar. 

 The Step tool bar button will be disabled unless the system is in Step mode. To enter Step 
mode, select System Setup from the Setup menu and toggle from Run Mode. 

To take the next measurement either: click on the Step sign  in tool bar, press F9 or select 
Step from the Options menu. 
 
 
 
Server Mode 
 
This option is provided to enable a remote operation of the application program. 

Press the Server Icon  at the ToolBar or select Server Mode from Options Menu.  
 
The following blinking icon now appears at the ToolBar adjacent to the Time field. 
Resting the mouse cursor at the blinking icon the Server Host Address is displayed (for 
identification of the Client computer via TCP/IP protocol.) 
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At the remote computer (Client) there is a need to install the software from the same system CD 
disk, and start the program. The following message will be displayed: 

“Hardware Error #XX: Knife-Edge Profiler system cannot be started. Please contact your 
Provider.” Press OK. 

The following message will be displayed: 

“ Would you like to initiate a remote client application?” press Yes. 

The following screen will be displayed: 

 
There is a need to input the Host Address name of the Server computer. After pressing OK, a 
Test Hardware routine will be performed. From this stage and on, the remote client computer will 
be running the same software and all measurements and analysis functions performed will be 
done as if it was the main computer which hosts the hardware.  
 
 
User Data 
 
The User Data enables the user to insert information required during the measurement session.  
The User Data string is limited to 60 characters. 
User Data can be selected from Options menu. 
 

  
After inserting the user data information and pressing OK button, the information be displayed in 
the Title Bar. 



 

Knife-Edge Profiler Manual   72 

 
Close All Windows 
This function is selected from Options Menu, or by pressing the Ctrl+W shortcut key. 
When this item is selected, all open windows are closed. 
 
 
 
Save Settings on Exit 
Save Settings on Exit is found in the Options menu. 
This option allows the user to save the current software settings in a default configuration file 
($$$.ini). When the software is started it will automatically load this saved configuration file. 
A check mark in front of the Save Settings on Exit menu item indicates that this function is active. 
The default setting is enabled. 
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Settings Menu 
The following commands and menu items are available from this Menu: 

 
 
The available keyboard shortcuts are displayed on the right side of the menu. These shortcuts 
may be activated from the Main Window by pressing the corresponding keyboard combination. 
A check mark in front of a menu item indicates that the function is active. 
A gray menu item indicates that the item is currently unavailable. For example to start data 
collection it has to be set up first. 

 

 
Low Resolution 
Low Resolution is selected from the System menu. The keyboard shortcut for Low Resolution is 
Ctrl+L, or click on the Tool Bar button .  
The current resolution setting is displayed at the Status Bar and the Title Bar in the displayed 
profile. 
In Low Resolution mode the system automatically normalizes the profile presentation to the peak 
power intensity. The profile sample area is equal to 3 times the beam width at the 13.5% Clip 
Level. The data is provided from about 500 sampled points at a rate of 5 Hz. The actual display 
rate is dependent on computer configuration. See Speed Issues. 
The Low Resolution mode of operation enables the system to simultaneously display both profiles 
(V & W), as well as Power and Position information.  
When more data points are required across a single axis use High Resolution.  High Resolution 
mode is utilized for beams less than 100um and non-Gaussian beam structures. 

 When switching from High to Low Resolution all of the display windows will be 
automatically closed. If any windows are open the current window configuration will be 
lost. 

 
High Resolution  
High Resolution is selected from the System menu. The keyboard shortcut for High Resolution is 
Ctrl+H, or click on the Tool Bar button . 
The current resolution setting is displayed at the Status Bar. 
High Resolution mode automatically locates the profile and the hardware samples the beam and 
vicinity utilizing 8000 points. Typically 4 points out of the 8000 points are filtered to create one 
point. Typically the resulting profile would include about 2000 points. When the beam is large, (~9 
mm) all points are utilized for the beam profile. When the beam is smaller, the system 
automatically locates the beam and samples the surrounding area with a typical resolution of 
about 2000 points. The beam and the surrounding area can be 6 times larger than the beam size 
at the 13.5% clip level. 
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The High Resolution profile displays typically 2 - 3 times better resolution than Low Resolution 
mode. Maximum resolution is physically limited to 0.1 micron.  
The High Resolution function is especially effective when dealing with beams that are far from 
Gaussian in shape or smaller than 100 microns. 
High-Resolution mode utilizes all of the on-board memory (total of 8K) for sampling one profile. 
This memory limitation allows the system to display one High-Resolution profile at a time. The 
Position and Projection windows are not supported in High-Resolution mode. 

 When switching from High to Low Resolution all of the display windows are 
automatically closed. If any windows are open the current window configuration will be 
lost. 

 

 
System Setup 
System Setup can be accessed with the System button in each operation window or from the 
System menu. The System Setup can also be accessed by double clicking the current 
Wavelength display in the status bar.  System Setup allows Knife-Edge Profiler to be configured 
to suit a particular set of test needs. 

 
 

Operational modes of the system: 
Wavelength 
Clip Level 
Average 
HeadTilt 
Mode 
Beep 
 
 
 
 
 

The current System Setup parameters are displayed in the Status Bar. 
Confirm the settings by clicking OK button or restore the previous settings with the Cancel button. 

 
Wavelength 
This setting is accessed from the System Setup dialog. The Wavelength value is utilized to 
calculate the current Power Reading. 
Wavelength should be set to match the laser source. Knife-Edge Profiler detectors have response 
curves that are dependent on the wavelength. These response curves have been corrected within 
the calibration file. Therefore it is important to enter the correct wavelength to obtain a correct 
power measurement. 
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The wavelength can be entered in 1-nanometer increments from 
the Value Entry Box. The current wavelength value will be displayed in the Status Bar. 

Possible values for wavelengths are... 
190 - 1100 nm for the silicon-UV version,  
400 - 1100 nm for the silicon version,  
800 - 1800 nm for the InGaAs version. 

 

 
System Clip Level 
This setting is accessed from the System Setup dialog. 
The System Clip Level sets the clip level where most of the system calculations are performed.  
These calculations include: Beam Width, Gaussian Fit, and Elliptical measurements. 

 A clip level defines the percentage of the peak intensity profile at which beam is 
measured. For example, a clip level of 50% indicates that the beam is to be measured 
at its full width at half maximum (FWHM), whereas a clip level of 13.5% measures the 
beam at a point that is 13.5% of the peak of the profile. The 13.5% level corresponds to 
the 1/e2 point of a Gaussian profile. 

In each Profile window Knife-Edge Profiler displays the width of the beam at three clip levels 
simultaneously. The clip levels appear in the profile window as solid lines that are superimposed 
on the profile. The three clip levels can be changed in the Profile Setup dialog. The lowest clip 
level is the typically the System Clip Level at 13.5%. 

To change the System Clip Level 

 
Select a value for the System Clip Level from the Value Entry Box. The selected value will be 
displayed on the Status Bar. 
 
 
Average 
The Average setting is accessed from the System Setup dialog. The System Setup dialog can 
be accessed from the System Menu or by clicking on the current wavelength in the status bar. 
 
The Average function provides a successive averaging feature which smoothes the Position, 
Profile and Power displays. Average can be set to integer values between 1 and 20. A value of 1 
corresponds to no averaging. When a value of 10 is chosen, ten successive measurements are 
averaged and the result is displayed. When an eleventh measurement is taken, the first 
measurement value is dropped and the second through the eleventh are averaged, etc. 
The selected value determines the number of successive measurements that will be averaged. A 
successive averaging technique results in an update rate that is not affected. 
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Select an Average value from the Value Entry Box. The 
selected value is displayed on the Status Bar. 
 
Head Tilt 
Head Tilt is accessed through the System Settings in System Menu. 
The Head Tilt option is utilized to input the actual orientation of the head. This option will orient 
the on-screen view to match physical reality. This option is utilized in a situation where the 
measured width of a laser beam does not coincide exactly with either the V or W axes defined by 
the Knife-Edge Profiler. 
 
The Head Tilt feature is especially important when analyzing elliptical beams. When the knife-
edges are not properly oriented with respect to the major and minor axes of the ellipse, the width 
measurements along V and W will not reflect the true maximum and minimum widths of the 
beam. If the beam cannot be rotated, it is necessary to physically rotate the measuring head 
about the optic axis of the laser beam.   
 

  Review the list of available accessories for the addition of Head Tilt capability. 

 
 
Run Mode 
This setting is accessed from the System Setup dialog. 
The Run Mode function is used to switch between a real-time mode (Run) and a manually 
activated mode (Step). 

 In Run mode the window display is updated continuously in real-time. 

 In Step mode the last measurement is displayed and the window is frozen. A single new set 
of measurements will be made only when a Step command is selected. The Step function is 

selected by clicking the tool bar button  or by pressing F9.  A Step menu item is also available 
in the Options menu.  The Step function allows a detailed examination to be made on each profile 
captured. 

 
Toggle between these two options using the radio button. The mode selected is displayed on 
the Status Bar. 

 

 
Beep 
This setting is accessed from the System Setup dialog. The System Setup dialog can be 
accessed from the System menu or by clicking on the current wavelength value in the status bar.   
The Beep option controls whether Knife-Edge Profiler will produce the default system beep when 
a Tool Bar error occurs. For example, when Beep is turned ON and the laser source is OFF, the 
"Low Power" Tool Bar error will be displayed while the system beeps. 
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Select Beep using the Option box. 
 
 
 
Add Detector Head 
 
     The Add Detector Head function is selected from the System Menu. 
     This function allows the user to configure an additional detector head. 
 

New Connections tab 
The currently selected file is displayed at the following screen: 

 
Pressing Load opens up a selection menu with all available calibration files for Knife-Edge 
Profiler, which are present at the system working directory. 

 
�Load This option enables identifying the detector head serial number which is currently 
being connected to the system, or selecting any required detector serial number from the 
calibration file list. Press Ok button to confirm setting, or Cancel button to abort. 

 
 Place the mouse at the required calibration file and press Open to confirm the selection. 
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Note: When switching the type of measuring head from BM3 to BM7, or vice versa, 
please make sure you set the slide switch and set it at the right position, otherwise the 
following error message is displayed. 

 

 
 
 

Add Calibration Files 
Copy all calibration 
files from the CD disk 
(or floppy disk) 
provided with the 
sensor head to the 
current Knife-Edge 
Profiler working 
directory. 
Upon activating this 
option, a data entry 
box is displayed. Input 
the detector Serial 
Number, then 
appropriate drive 
where the disk was 
inserted. Press Copy 
to confirm the 
selection, Cancel to 

abandon. 
During the copying operation, a message box is displayed, presenting the name of the 
file being copied to Knife-Edge Profiler working directory and the amount of data copied 
(in percentages). The Copy operation can be aborted any time by pressing the Abort 
button. 
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Windows Menu 
The following commands and menu items are available from the this Menu: 
 

 

Cascade: This command will attempt arrange all open windows on top of each other, but slightly 
Null for ease of selection. 

Tile Vertical: This command will attempt to tile the open windows horizontally along the top of the 
window area. It works well with two open windows. When more windows are active they will 
overlap. The overlap results when the window size cannot be reduced to a level to fit the 
available area. 

Tile Horizontal: This command will attempt to tile the open windows vertically along the left edge 
of the window area. It works well with two open windows. When more windows are active 
they will overlap. The overlap results when the window size cannot be reduced to a level to fit 
the available area.  Higher windows screen resolutions may help. 

Arrange Icons: When a window is minimized it is reduced to an icon representation and stacked 
along the bottom of the window area. These Icons can be moved around with the mouse. To 
return a nicely ordered group of icons along the bottom of the window area, select this 
function. This is useful if the icon has been covered up with another window. Higher windows 
screen resolutions may help. 
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Help Menu 
 
When a Help subject is displayed, additional help can be displayed by pressing the F1 key. 
The following commands and menu items are available from the Help Menu: 

  
 
The list of key combinations on the right side of the menu, indicate the corresponding keyboard 
shortcut for that feature. These shortcuts may be activated from the Main Window by pressing the 
keyboard combination. 
 

 
Contents 
Press the F1 key to access Help information on the current active window.   
To access the on-line Knife-Edge Profiler Manual, select Contents form the Help menu. The 
Contents topics are organized into chapters. To find information on a desired topic, click on the 
displayed chapter heading. 
You can return to the Table of Contents by clicking Contents. 
To find specific information fast use the Search for Help On menu item under the Help menu. 

 
 
Search for Help On 
Additional help can be displayed on the current subject by pressing F1. 
 
To find help information quickly, select Search for Help On from the Help menu. This option will 
bring up a list of all the topics. Type the first few letters of the topic. The search engine will 
automatically select any topic that matches the entry. If no entries match your topic scroll through 
the list to find a related topic you may also click the Find tab. Windows will compile a cross-
reference list of all the word used in the Help file. Using Find will often pinpoint the exact topics of 
interest. 
 
Active Window 
The Active Window can be identified by a colored title bar background.  A depressed tool bar 
button indicates the windows available for selection.  Activate a window by clicking on any part of 
the window.  To get context-sensitive help on the active window select F1 or select Active 
Window from the Help menu. This will bring up the help topic for the current active Window. 

 
 
Newport on the Web… 
The Website item in the Help menu will start the default browser and connect to the 
http://www.newport.com. 
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About 
The About box is selected from the Help menu. 
The About screen provides the current software version, detector head serial number, Newport 
contact information, and Copyrights.  The OK button will clear the About information from the 
screen.   
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Hardware 
The Knife-Edge Profiler uses an interface board to digitize the incoming video signal. This chapter 
covers the various technical specifications for the supplied detector heads and the interface card. 
There are six detector head options available for the Knife-Edge Profiler. The following topics are 
detailed specifications for each detector: 
 

Note: All heads conform to all applicable CE Mark standards. 
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KEP-3-IR Detector Head 
 

 
 
Spectral Response 

800-1800 

Number of knife-edges 3 
Sensor Input Aperture 5 mm Circular (active area Ø3) 
Dimensions 35.2 mm (W) x 105 mm (H) x 87.5 mm (L) 
Weight 22 oz. 
Minimum Detectable Power 10 µW 
Maximum Power  Power up to 5 mW 
Relative Power Measurement 0.1 µW resolution 
Power Measurement 
Accuracy 

±10% 

Damage Threshold 1 W/mm² with total power less than 5 mW at sensor 
Optical Dynamic Range 10 µW/cm² to 10 W/mm², (no filter) 
Beam Size Range (at 1/e²) 3 mm to 3 µm 
Beam Width Resolution width < 100 µm: 0.1 µm 

width >= 100 µm: 1.0 µm 
Beam Position Resolution 1 µm 
Beam Position Accuracy ± 15 µm 
Distance to Image Plane 5.4 ± 0.1 mm back from front surface of Head. 

0.5 + 0.18 mm back from internal front surface of 
entrance hole. 

Maximum Update Rate 5 Hz (see Speed Issues) 
Cable 2.5 m long attached to the head. 
Filters The InGaAs head does use filters due to mechanical 

constraints. 
We allow blade eccentricity of +/- 15 µm for the KEP-3. 



 

Knife-Edge Profiler Manual   84 

KEP-3-SL Detector Head 
 

 
Spectral Response 350-1100 
Number of knife-edges 3 
Sensor Input Aperture 5 mm Circular 
Dimensions 35.2 mm (W) x 105 mm (H) x 87.5 mm (L) 
Weight 22 oz. 
Minimum Detectable Power 10 µW 
Maximum Power @633nm No filter: Power up to 5 mW 

NG4 filter: Power up to 50 mW 
NG9 filter: Power up to 1 W 

Relative Power Measurement 0.1 µW resolution 
Power Measurement 
Accuracy 

±5% 

Damage Threshold 200 W/mm² with total power less than 5 mW at sensor 
Optical Dynamic Range 10 µW/cm² to 10 W/mm², (no filter) 
Beam Size Range (at 1/e²) 5 mm to 3 µm 
Beam Width Resolution width < 100 µm: 0.1 µm 

width >= 100 µm: 1.0 µm 
Beam Position Resolution 1 µm 
Beam Position Accuracy ± 15 µm 
Distance to Image Plane 5.5 ± 0.08 mm back from front surface of Head. 

0.5 + 0.18 mm back from internal front surface of 
entrance hole. 

Maximum Update Rate 5 Hz (see Speed Issues) 
Cable 2.5 m long attached to the head 
Filters NG4 & NG9. See filter files NG4.FLT & NG9.FLT for a 

Text format transmission table. 
We allow blade eccentricity of +/- 15 µm for the KEP-3.  
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KEP-3-UV Detector Head 
 

 
Spectral Response 190-1100 
Number of knife-edges 3 
Sensor Input Aperture 5 mm Circular 
Dimensions 35.2 mm (W) x 105 mm (H) x 87.5 mm (L) 
Weight 22 oz. 
Minimum Detectable Power 10 µW 
Maximum Power @633nm No filter: Power up to 5 mW 

NG4 filter: Power up to 50 mW 
NG9 filter: Power up to 1 W 

Relative Power Measurement 0.1 µW resolution 
Detector Type UV-Enhanced Si 10*10mm 
Damage Threshold 200 W/mm² with total power less than 5 mW at sensor 
Optical Dynamic Range 10 µW/cm² to 10 W/mm², (no filter) 
Beam Size Range (at 1/e²) 5 mm to 3 µm 
Beam Width Resolution width < 100 µm: 0.1 µm 

width >= 100 µm: 1.0 µm 
Beam Position Resolution 1 µm 
Beam Position Accuracy ± 15 µm 
Distance to Image Plane 5.5 ± 0.08 mm back from front surface of Head. 

0.5 + 0.18 mm back from internal front surface of 
entrance hole. 

Maximum Update Rate 5 Hz (see Speed Issues) 
Cable 2.5 m long attached to the head 
Filters NG4 & NG9 can be used for the range 400-1100nm. 

See filter files NG4.FLT & NG9.FLT for a Text format 
transmission table. 

We allow blade eccentricity of +/- 15 µm for the KEP-3. 
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KEP-7-IR Detector Head 

 
Spectral Response 800-1800, calibrated range: 800-1720nm 
Number of knife-edges 7 
Sensor Input Aperture 9 mm Square (active area Ø 3) 
Dimensions 35.2 mm (W) x 105 mm (H) x 87 mm (L) 
Weight 22 oz. 
Minimum Detectable Power 10 µW 
Relative Power Measurement 0.1 µW resolution 
Maximum Power Power up to 5 mW (>0.1 mm diam) 
Power Measurement 
Accuracy 

± 10% 

Damage Threshold 200 W/mm² with total power less than 5 mW at sensor 
Optical Dynamic Range 10 µW/cm² to 10 W/mm², (no filter) 
Beam Size Range (at 1/e²) 3 mm to 10 µm 
Beam Width Resolution width < 100 µm: 0.1 µm 

width >= 100 µm: 1.0 µm 
Beam Position Resolution 1 µm 
Beam Position Accuracy ± 15 µm 
Distance to Image Plane 5.5 ± 0.08 mm back from front surface of Head. 

0.5 + 0.18 mm back from internal front surface of 
entrance hole. 

Maximum Update Rate 5 Hz (see Speed Issues) 
Cable 2.5 m long attached to the head 
Filters The InGaAs head does not use filters due to mechanical 

constrains. 
We allow blade eccentricity of +/-30 µm for the KEP-7. 
(*) Optional: InGaAs 5mm diameter detector is also available (model KEP-7-IR5) 

This head conforms to all applicable CE Mark standards. 
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KEP-7-SL Detector Head 
 

 
Spectral Response 350-1100 
Number of knife-edges 7 
Sensor Input Aperture 9 mm Square 
Dimensions 35.2 mm (W) x 105 mm (H) x 87 mm (L) 
Weight 22 oz. 
Minimum Detectable Power 10 µW 
Relative Power Measurement 0.1 µW resolution 
Maximum Power @633nm No filter: Power up to 5 mW (>0.1 mm diam) 

NG4 filter: Power up to 50 mW 
NG9 filter: Power up to 1 W 

Power Measurement 
Accuracy 

± 5% 

Damage Threshold 200 W/mm² with total power less than 5 mW at sensor 
Optical Dynamic Range 10 µW/cm² to 10 W/mm², (no filter) 
Beam Size Range (at 1/e²) 9 mm to 15 µm 
Beam Width Resolution width < 100 µm: 0.1 µm 

width >= 100 µm: 1.0 µm 
Beam Position Resolution 1 µm 
Beam Position Accuracy ± 15 µm 
Distance to Image Plane 3.5 ± 0.08 mm back from front surface of Head. 

0.7 + 0.18 mm back from internal front surface of 
entrance hole. 

Maximum Update Rate 5 Hz (see Speed Issues) 
Cable 2.5 m long attached to the head 
Filters NG4 & NG9. See filter files NG4.FLT & NG9.FLT for a 

Text format transmission table. 
We allow blade eccentricity of +/-30 µm for the KEP-7. 
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KEP-7-UV Detector Head 
 

 
Spectral Response 190-1100 
Number of knife-edges 7 
Sensor Input Aperture 9 mm Square 
Dimensions 35.2 mm (W) x 105 mm (H) x 87 mm (L) 
Weight 22 oz. 
Minimum Detectable Power 10 µW 
Relative Power Measurement 0.1 µW resolution 
Maximum Power @633nm No filter: Power up to 5 mW (>0.1 mm diam) 

NG4 filter: Power up to 50 mW 
NG9 filter: Power up to 1 W 

Detector Type UV-Enhanced Si 10*10mm 
Damage Threshold 200 W/mm² with total power less than 5 mW at sensor 
Optical Dynamic Range 10 µW/cm² to 10 W/mm², (no filter) 
Beam Size Range (at 1/e²) 9 mm to 15 µm 
Beam Width Resolution width < 100 µm: 0.1 µm 

width >= 100 µm: 1.0 µm 
Beam Position Resolution 1 µm 
Beam Position Accuracy ± 15 µm 
Distance to Image Plane 3.5 ± 0.08 mm back from front surface of Head. 

0.7 + 0.18 mm back from internal front surface of 
entrance hole. 

Maximum Update Rate 5 Hz (see Speed Issues) 
Cable 2.5 m long attached to the head 
Filters NG4 & NG9 filters can be used for the 400-1100nm. See 

filter files NG4.FLT & NG9.FLT for a Text format 
transmission table. 

We allow blade eccentricity of +/-30 µm for the KEP-7. 
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PCI Interface Board 
 
The Knife-Edge Profiler uses a plug-in interface board to digitize and store the information from 
the detector head. 

 
PCI Interface Board 

 The interface board is a static-sensitive electronic device and should be handled 
with care to avoid exposure to static voltages. 

• Size: 1/2 card length PCI. 
• Bus: 32 bit PCI Bus. 
• Weight: 0.42 lbs. 
• Dimensions: 7.33 inches long x 4.26 inches tall. 
• Power input requirements (typical):  

Running software: +5V @ 0.6 A, +12V @ 0.08 A, -12V @ 0.12 A, +3.3V @ 0.5A. 
No software running: +5V @ 0.32 A, +12V @ 0.075 A, -12V @ 0.13 A, +3.3V @0.1A 

• Power consumption: 
Running software: 7.3 Watts Typical. 
No software running: 4.3 Watts Typical. 

• Ambient Operating Temperature: 10 - 70°C 
• A/D Converter: 20 MHz sample rate at 8 bits per pixel. 
• Storage Memory: 8 KB. 
• CE Mark: Conforms to all applicable CE Mark standards. 

PCI Interface Board Card Edge: 
There are two connectors on the back bracket of the interface board; a 15 pin and a circular 8 pin. 
The 15-pin connector is connected to the detector head. The Auxiliary connector is used for 
future devices. 

 
The slide switch is used to select the type of head that is connected. This switch is set at the 
factory to match the detector head purchased. This switch should only be moved when power is 
off! 
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Calculations Summary 
This topic provides a brief description of the beam analysis calculations performed by the Knife-
Edge Profiler.  

Please be aware of Accuracy issues that can affect these calculations. 

 
Accuracy 
The following topics provide information on how to optimize the Knife-Edge Profiler to achieve the 
highest measurement accuracy. 
The accuracy of all calculations will be affected by beam peak intensity, centering, size, and 
background noise. To insure optimum measurement accuracy the following items should be 
properly maintained: 

• The beam spot size should not exceed the recommended minimum or maximum beam 
diameter for the detector head being used (see Detector Heads). See Resolution for 
issues about the number of data points used in the calculations. 

• The beam position should be centered in the sensor area with no beam area overlapping 
the edge of the input aperture on the detector head. 

• The beam incidence should be normal to the face of the detector head. 
• The background noise in the beam image can affect the calculated results. Ensure that 

all sources of background noise have been eliminated if possible. (See Background 
Noise). 

• When measuring beams smaller than 100 microns or beams that are far from Gaussian 
shape, High Resolution can be especially effective. 

• The successive Averaging feature can also be used to smooth noise and beam 
variations. 

 
 
Background Noise 
Several sources of background noise can contribute to the overall noise level in the system. A 
brief discussion of the most common noise sources follows. 
Electronic noise can be a concern with instruments being used in association with lasers. The 
Knife-Edge Profiler has passed CE Mark tests indicating that it is resistant to most EMI radiation. 
Still, Intense High frequency sources can induce noise into the cables and detector head 
electronics. Avoid grounding the detector head and Knife-Edge Profiler chassis with the laser or 
its power supply in a manner that could make them susceptible to ground loops. Severe damage 
to the detector head and electronics may result. It is also recommended that the Knife-Edge 
Profiler system power supply be surge protected and isolated from the laser power source.  
Background Light noise seen by the detector head is another problem that should be closely 
monitored. This noise comes from sunlight, room lights, flashlamps, and instrumentation lights. 
One of the Filter filters can be used to reduce background light. The Power Null feature can be 
used to remove the ambient light from the power reading. 
Thermal noise can also affect the long-term stability of the Knife-Edge Profiler. Drift in detector 
head voltage and A/D converter circuits due to large changes in room and instrumentation 
temperatures can contribute to background noise. The system should be allowed to reach a 
stable operating temperature each time it is used. This can take as much as 15 to 20 minutes. 
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Relative Total Power 
The rotating drum in the detector head contains multiple knife-edge apertures. As an aperture 
passes between the laser beam and the stationary power sensor, there is a period of time where 
the entire beam is allowed to reach the sensor. At this point the Knife-Edge Profiler can measure 
the total power of the beam. 
The power reading is adjusted based on the system Wavelength setting and the wavelength 
response curve for the detector and the transmission of the current filter. 
For details on minimum detectable power, measurement resolution, maximum power and 
damage threshold limits see the appropriate detector head specifications. 

Power Accuracy 
The silicon detectors are calibrated with and without the filters for power accuracy at 633 and 830 
nm. The InGaAs detector is checked for power accuracy at 830 nm. The system is designed for ± 
10% accuracy at the specified wavelengths. Accuracy at other wavelengths is unverified. 
Therefore the Knife-Edge Profiler does not provide absolute power accuracy at this time. Please 
consider the Power reading to be Relative. 
If absolute power accuracy is desired, the Knife-Edge Profiler power reading can be hand 
calibrated using a power meter. If the Knife-Edge Profiler reading needs to be adjusted, a Filter 
file can be created that provides the necessary correction at the given wavelength. 

 

Beam Width 
The Beam Width is measured at a clip level. 

A clip level defines the percentage of the peak intensity profile at which beam is 
measured. For example, a clip level of 50% indicates that the beam is to be measured 
at its full width at half maximum (FWHM).  A clip level of 13.5% measures the beam at a 
point that is 13.5% of the peak of the profile. The 13.5% level corresponds to the 1/e2 
point of a Gaussian profile. 

The Knife-Edge Profiler obtains the beam profile information as outlined in the Theory of 
operation. 
The profile peak is found and set to 100%. The Profile is searched to find the points most closely 
matching the clip level. The distance between the specified clip level points is the beam width. 
If no point matches the clip level exactly linear interpolation is used to find the edge precisely. 
If the profile crosses the clip level more than 2 times, the system picks the edges closest to the 
beam profile center of gravity, (typically the main lobe). 
If the edge of the beam is cut off because it intersects the edge of the aperture, the profile will 
appear truncated on that edge. 

 

 

Beam Centroid Location 
Before each blade there is a "start-of-scan" signal acting as an indicator for the beam location on 
the detector surface. Each system is calibrated relative to the start-of-scan. The system 
calculates the time from start-of-scan to the "center of gravity" of the profile. The "center of 
gravity" is determined for the W axis with the following calculation:  

W = SUM [w * p(w)]/I 
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Where: 
w = location along W axis 

 p(w) = intensity at location w on W axis  
 I = total intensity of W profile. 
 W = center position of W axis. 
Simple axis translation is then used to present the data in X-Y coordinates. 

The affect of background ambient light 
The profiles are obtained by performing a derivation on the digitized power curve. Ambient light is 
suppressed since it is constant over the detector surface resulting in a derivative of zero. 
However, if a low power large area beam is examined, then it is very important to suppress 
background illumination as much as possible. 

 

Gaussian Fit 
The Gaussian Fit is a least-squares fit of a Gaussian equation to the cross section beam profiles. 
The correlation coefficient is the normalized sum of the fit residuals. 
The following equation is used to determine the Gaussian Fit: 

I = Ve^[-(x-c)/σ]² 
where I = the intensity of a pixel at location x. 

In performing a least squares fit to this equation, the following terms are derived: 
V = the maximum intensity of the fitted Gaussian curve (Peak Intensity). 
C = the center of the Gaussian fit peak (Centroid). 
σ = the radius of the Gaussian fit curve at the 1/e2 intensity level (Diameter). 
 
 
 
Gaussian Fit Diameter 
The Gaussian Diameter is the width of the Gaussian fit at the clip level specified. 
 
 
 
Gaussian Correlation Coefficient 
The Gaussian correlation coefficient is calculated as follows: 
Given a theoretical Gaussian curve (G) and a set of data points from a beam profile (P), as 
shown below: 
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Gaussian Curve (G)
Data Points (P)

0 j N
 

Each data set is composed of points for j = 0, 1, 2, ... N. The correlation coefficient is derived from 
the following steps: 

1. S, the Integration of the squared differences between the two curves is found. 

S = Integral [(P-G)²] 

2. The deformation at each point from the average, Dj, is then determined. 

So = Integral [(G)²] 

3. The fit coefficient, C, is a percentage defined with the following formula: 

C = 100 * {1 - [SQRT (3/S-So)] 

 

 
Ellipticity 
Elliptical measurements are calculated utilizing data from 3 blades. The actual calculation is in 
accordance with standard formulas for ellipse calculations utilizing 3 chords. 

1. The major and minor axes of the fit are calculated by determining the distance from the 
centroid to the ellipse. 

2. Orientation (Theta θ) is a measure of the orientation of the major axes. Theta is 
measured from the positive X-axis and varies between +90º and -90º. 

 

 

 

Speed Issues 
The motor speed limits the maximum update rate to 5 Hz. The software can acquire data at 5 Hz 
by starting a Log file when all graphic screens are closed.  
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When several windows are opened the system may slow down, especially when using the 3D 
feature. High performance computers can display the data faster. The update rate of a particular 
computer will be influenced by a variety of factors; CPU Speed, Computer RAM, Video Card, 
Video RAM, Screen resolution, Screen color depth and Operating System being used. 
Benchmark data has been compiled form two different computer systems. System "A" is a 
Pentium III 450MHz 64 Megabytes Windows Me Screen resolution 768x1024x16bit (AGP card 
with 4 Megabyte) machine. 

 
Computer System:                    
One Profile                   5   Hz      
Two Profiles                  5   Hz      
Two Profiles+Power            5   Hz      
Two profiles+Position         5   Hz      
Two profiles+Position+Power   5   Hz      
All screens without 3D        5   Hz      
3D only                       2.5 Hz      
2D only                       2.5 Hz      
All screens with 3D           2.5 Hz      
All screens with 2D           2.5 Hz      
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Troubleshooting 
The following sections will list common problems and probable solutions. 
 

 After reading these sections and the relevant portions of the help system, you may still have 
a question.  Please refer to Customer Support. 

Error Categories: 
System Errors - Displayed on the right hand of the tool bar. 
Operating Errors  - Error messages or lock-ups 
Analysis Errors - Results or plots that do not appear correct. 

 
 
System Errors   

System Errors are displayed on the right hand side of the tool bar. 
They indicate a problem with the hardware or detector head. When these errors are displayed all 
results are removed from the window. 

"Low power" 
This message means that insufficient light is available on the detector.  This error will occur if less 
than 10uW of energy is detected. Verify that the laser light is reaching the sensor. If it appears 
that the message is incorrect, treat it as a "Hardware Failure" message. 

"Hardware Failure"  
A Hardware Failure message indicates that a problem exists with the Interface Board.  One of the 
following solutions could resolve this problem.   

1.  The interface board settings do not match the software setup parameters. See Installing 
the PCI Interface Board. 
2. The detector head is not connected or the cable is loose. See Connecting the detector. 

3. The KEP-7 / KEP-3 switch on the Interface Board is not in the correct position.  See 
Connecting the detector. 

4. There is no measurement taken during 2 - 4 drum rotations. This might be due to some 
problem in head or plug in card electronics. 

"Power adjusting" 
This message is normal and can occur when: 

1. There is a sudden change in laser power. 

2. The user has just completed setting the Hardware or System Setup parameters. 

"Laser Power Exceed Limit" 
This message indicates that the detector is collecting an excessive amount of light. Check the 
input power level with a power meter to ensure the device is being used within the recommended 
operating limits. With small beams this error can occur before the published power limit. See 
Hardware for the published limits. If it appears that the message is in error treat it as a "Hardware 
Failure" message. 
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Operating Errors  
When Knife-Edge Profiler is running and I am in another Windows application it runs slow, 

or appears to get interrupted. 
 The Knife-Edge Profiler must constantly collect and analyze data and may not work well 

with all Windows applications. If you want to use another application while the Knife-Edge 
Profiler is running, select About from the Help menu. This will cause the Knife-Edge 
Profiler to pause it's data collection. With the About box on the screen, switch to the other 
application. 

System Locks-up during software startup 
 Treat this as a Hardware Failure.  Review System Errors to resolve this conflict. 

 Because the program is locking up it may be impossible to change the software 
setting to match the Interface board. In this case you will need to run the Windows 
NOTEPAD application and open the Newport KEP Series.CFG file in the Knife-Edge 
Profiler directory. The two hardware settings are stored in this file and can be edited to 
match the desired values. 

"Input past end of file" Error on startup 
After pressing OK the Knife-Edge Profiler application is 
automatically closed. This error can occur when installing the 
Knife-Edge Profiler over the top of an old installation. Try 
deleting the $$$.ini file in the Knife-Edge Profiler directory. Start 
the application again. 
 
 

 
Analysis Errors  
Analysis errors are associated with calculations and data collection. 

Small beam display on the Position Screen 
The Position window does not automatically zoom for small beams. To enable zoom mode, 
select the setup button and enable the zoom feature. The zoom function will scale the position 
display relative to the current beam diameter. 

Display update rate is slow 
The display update rate is dependent on several variables. See Speed Issues. 

Power is not correct 
Check that the correct wavelength is entered into the System Setup dialog. Make sure the Filter 
installed in the detector head matches the Filter selected in the software.  Ensure that the sensor 
is not saturated, (see input specifications for Detector Heads). If using a small spot, check that 
the power density levels (see Selecting a Filter). The relative power reading should be within ± 
10% of the actual power level. If absolute power reading is required, setup a custom Filter file. 
A custom Filter file allows the user to enter a power a correction factor.  This factor will be 
multiplied by the transmission value at the specified wavelength. 

Calculation Issues 
See the section on Accuracy. 
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Knife-Edge Profiler Head Accessories & Drawings 
This section provides information about the Knife-Edge Profiler head accessories, as well as data 
about critical internal head dimensions (which are sometimes required for an optical design of the 
beam path). 
 
KEP-MNT (Knife-Edge Profiler Rotation Mount)  
 

 
 The Rotation Mount is designed to 
attach to the M4 holes at the Knife-
Edge Profiler head and provide 
precise rotation of the head about 
the optical axis. 
It is sometimes necessary to rotate 
the Knife-Edge Profiler head about 
the optical axis. Each head is 
provided with three M4 threaded 
mounting holes on its rear plate for 
this purpose. 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

Knife-Edge Profiler Manual   98 

 

KEP-FC (Fiber Adapter) 
The fiber adapter is provided with an FC connector and is designed to just fit onto the aperture of 
the Knife-Edge Profiler detector head. The fiber adapter can firmly hold an optical fiber with FC 
connector end quite close to the detector knife-edge plane for measurement of its output beam 
profile. 
Dimensions are in mm. 
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Knife-Edge Profiler head types and their critical internal 
dimensions 
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ActiveX Control 
 
Introduction 

 
As mentioned in previous chapters, Knife-Edge Profiler is a full capture and analysis application 
with sophisticated capabilities. However, many customers have special analysis demands and 
tools, yet are lacking data collection capabilities. In order to meet this demand, the Knife-Edge 
Profiler can act as an ActiveX server. This allows system integrators to integrate the Knife-Edge 
Profiler’s data capture capabilities with legacy analysis packages. 
 
This has been tested in LabVIEW 7.0 (National Instruments) as well as Visual Basic 6.0 
(Microsoft). In practice, these controls can be used in any environment that allows interaction with 
ActiveX servers (although it hasn’t been tested with tools other than those mentioned). 

 
 

Registration 
 

The ActiveX controls will be registered the first time that the Knife-Edge Profiler software 
application is run. 

 
 
 
Examples 
 
Examples of a LabVIEW and a Visual Basic application are provided with the installation CD disk. 
All examples assume a rudimentary knowledge of the respective development platforms. 
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Active X Details  
 
Types 

1) kepUpdated 
a. Flag used to inform calling application if camera has made a new measurement 

(used with the DataUpdated property). Also used on startup to inform calling 
application that the camera has been initialized (used with the SettingsUpdated 
property) 

b. Values 
i. kepNotUpdated  = 0  (Settings/Data not yet updated) 
ii. kepUpdatedSusccessful = 1  (Settings/Data have been updated) 
iii. kepFailed = -1   (Failed to set up initial settings) 

 
 
Events (in Visual Basic only) 
 
Note: Events can only be used in Visual Basic applications. In order to use events, the 
EventsEnabled property (described below) must be set to TRUE. 
 

1) DataUpdated: Knife-Edge Profiler has made a new measurement 
2) ErrorMessage: Knife-Edge Profiler is reporting an operational error (as a code and as a 

text message).  
 
 
 
Properties 
 

1) ClipLevel 
a. Used to get or set the Clip Levels of the profiles 

2) EnableEvents 
a. Used to enable Visual Basic events. This is compatible with Visual Basic 

applications that used simple broadcast events.  
b. Default is set to FALSE (no Visual Basic events) 

3) SettingsUpdated 
a. Used on startup to inform the calling application that the Knife-Edge Profiler 

(KEP) has finished its initialization 
b. Used with the ccdUpdated type described above 

4) DataUpdated 
a. Used by non-Visual Basic applications. 
b. Set to 0 by calling application to request new measurement from the KEP 
c. Set to 1 by KEP to inform calling application that a new measurement has been 

made and processed 
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Methods 
 

1) HideForm 
a. When launched, the KEP window is displayed. This property allows the window 

to be hidden without affecting measurements, thereby freeing the screen for the 
calling application. 

2) ShowForm 
a. Allows KEP window to be displayed 

3) GetCentroid 
a. Returns horizontal and vertical centroid in a 2 elements array 
b. Values are in microns 

4) GetBeamWidths 
a. Returns array of horizontal and vertical beamwidths at all 3 clip levels 
b. First 3 elements are horizontal beamwidths at clip levels 1,2, and 3 
c. Second 3 elements are vertical beamwidths at clip levels 1,2, and 3 
d. Values are in microns 

5) GetGaussWidths 
a. Returns array of horizontal and vertical gaussian widths at all 3 clip levels 
b. First 3 elements are horizontal gaussian widths at clip levels 1,2, and 3 
c. Second 3 elements are vertical gaussian widths at clip levels 1,2, and 3 
d. Values are in microns 

6) GetGaussCorrelation 
a. Returns horizontal and vertical correlation in a 2 elements array 
b. Values are in percent 

7) GetAmplitudeVectorX 
a. Returns horizontal profile as array with values from 0.0 to 100.0 
b. Array length is a function of capture size 

8) GetAmplitudeVectorY 
a. Returns vertical profile as array with values from 0.0 to 100.0 
b. Array length is a function of capture size 

9) GetMatrix 
a. Returns input matrix array from KEP detector with values from 0 to 255 
b. Array length is a function of capture size 

10) GetPower 
a. Returns power measured in milliwatts 
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