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INTRODUCTION 

Introduction 
1&1 Control Panel Login • Other Sources of Information 
This manual is for 1&1 customers using: 
Microsoft® Home package 
Microsoft® Business package 
Microsoft® Developer package 

It provides in depth background information about the 1&1 Control Panel including 
domain and e-mail management, and other web hosting related services. 

1&1 Control Panel Login 
To reach the Control Panel directly, you can enter https://admin.1and1.com in the address 
bar of your browser. Or, go to 1&1's website http://1and1.com and click on 'Customer 
Login' > '1&1 Control Panel'.  

On the Control Panel login page, enter your customer ID or domain name and the 
password you chose when ordering. The button 'Login' brings you to the first page of 
your 1&1 Control Panel.  

If you forgot your password, click on 'Forgot Your Password?'. Next enter your customer 
ID. We will then immediately send your password to the e-mail address in our files. 

Other Sources of Information 
 

 Need Help? section 
Under the left navigation bar in the Control Panel, this section provides information on 
the section you are in. Click on 'Show More Help' to read more about a topic. 

 Easy Setup Guide  
Step-by-step instructions with detailed screenshots to help you quickly setup your 1&1 
package. Click on 'Downloads' in the Control Panel to find the PDF files. 

 FAQs  
Answers to frequently asked questions (FAQs). To browse the FAQs, use the 'Search' 
function. Click on 'FAQs' in the Control Panel or find them at faq.1and1.com. 

 'Help & Contact'  
FAQ articles grouped by topic. If you cannot find an answer, click on 'Contact Form' to 
send support a question. Click on 'Help & Contact' in the Need Help? section.  

Or, you can write an e-mail to support@1and1.com. When writing to us directly, please 
provide your customer ID and domain name. Be as specific as possible regarding any error 
messages or problems to speed up the handling of your questions. 

You can also call our customer service at 1-877-HELP AT 1 AND 1 (1-877-435-7281). Our 
customer service is available to you 24 hours a day, 7 days a week. 

Please enable JavaScript in your browser to use 1&1 Help. 
 

https://admin.1and1.com/
http://1and1.com/
http://faq.1and1.com/
mailto:support@1and1.com
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THE 1&1 CONTROL PANEL: SYSTEM REQUIREMENTS 

The 1&1 Control Panel 
1 System Requirements • 2 1&1 Control Panel Structure • 3 Using the 1&1 Control 
Panel 
 

The 1&1 Control Panel is a user-friendly interface that places you in control of the 
complete range of features and products included in each of your packages, all from 
one central point. Everything included in your package can be set up in the Control 
Panel. So, you do not have to use different tools or interfaces to manage domains, 
e-mail, or FTP account information. 

1 System Requirements 
 

For the 1&1 Control Panel you need Internet access, a fourth generation or higher web 
browser (ex. Internet Explorer® or Netscape Navigator® version 4), and your login data. 
 

The 1&1 Control Panel is SSL-encrypted to ensure maximum security for your personal data. 

2 1&1 Control Panel Structure 
 

2.1 General Setup • 2.2 Your Customer Account: My Account • 2.3 Your Package: 
Package Administration 
The Control Panel's structure is clearly defined providing different areas to configure and 
manage all aspects of your package and to control your 1&1 customer account. 

The first page of your Control Panel is the Package Overview page in the My Account area. 
In the overview table you can find the package's name, contract ID, and its status. You can 
have more than one package in the same Control Panel. These will be listed in separate 
rows. 

Click on the name of the package you would like to work on. This brings you to the 
Package Administration area.  

The Control Panel is available before all the features of your Hosting package have been fully 
set up. You can begin by viewing the status of your domain.  

2.1 General Setup 
 

Your Control Panel comprises two areas — the customer based My Account area and the 
Package Administration area for each package.  
 

Use the top tabs 'My Account' and 'Package Administration', and the menu items in the 
left navigation bar to move around within the Control Panel. The "You are here" navigation 
path at the top of the page shows your current location in the Control Panel. 
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THE 1&1 CONTROL PANEL: 1&1 CONTROL PANEL STRUCTURE  

 

Information concerning your account is under 'Messages' in the left navigation bar. The 
quickbar offers direct access to the most used and popular applications of your package. 
To the right of the quickbar, you can click on 'Order' to see additional offers. 

In the top section, you can log out of the Control Panel, by clicking on the 'Logout' 
button.  

When you need help, the Need Help? section contains: instant on-topic, answers to 
frequently asked questions (FAQs), manuals, easy setup guides, and ways to contact 
support. The Need Help? section is located under the left navigation bar. 

2.2 Your Customer Account: My Account Area 
 

You can access the important user settings, billing information and aids, our Affiliate 
Program, messages, and general product news from the left navigation bar in the My 
Account area. Clicking on 'My Account' will bring you to the Package Overview table, 
where you can select the package you would like to work on.  

 
Figure 1: My Account's Package Overview page and the left navigation bar for customer settings. 
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THE 1&1 CONTROL PANEL: 1&1 CONTROL PANEL STRUCTURE 

 

2.3 Your Package: Package Administration Area 
 

Package Administration gives you access to the package's features, tools, programs, and 
management areas. Use the left navigation bar to reach them. 

 
Figure 2: Package Administration's menu page and the left navigation bar for package settings. 

The following menu items are in the left navigation bar and can be accessed with one 
mouse click: 'Domains', 'E-mail', 'Web Space/Access', and 'Applications'. Clicking on 
an item in the left navigation bar brings you to an overview page ('Domains' and 'E-mail') 
or to a menu page ('Web Space/Access' and 'Applications'). An overview page has an 
overview table with an all-in-one toolbar. A menu page explains what you can find under 
each menu point. Select the feature, process, program, or tool you would like to work on 
by clicking on it. 

The general package topics 'Billing', 'Software & Licenses', 'Order', and 'Upgrade 
Package' are in the lower half of the left navigation bar. 
 

You must adhere to our license agreement and that of the software producers' license 
agreement in order to use fully licensed software. 

 

If you find that you have outgrown your Microsoft® Home and Microsoft® Business 
packages, you switch to a more powerful package by going to the 'Upgrade Package' 
menu item in the left navigation bar. 

Always log out of the Control Panel when you are finished, using 'Logout' in the upper 
right corner, to prevent unauthorized access. This is especially important if you accessed 
the Control Panel from a computer that other people use, for example in an Internet cafe. 
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THE 1&1 CONTROL PANEL: USING THE 1&1 CONTROL PANEL  

3 Using the 1&1 Control Panel 
 

The Control Panel has been created with you in mind — for you to enjoy maximum user-
friendliness. Depending on your proficiency level and personal preferences, you can 
navigate and manage all features in your package in different ways in the Control Panel. 

To find what you are looking for or to see what the Control Panel has to offer, you can 
click on: 

 Left navigation bar 
Click on a menu point to reach an overview page or a menu page. From there you can 
select the feature, process, program, or tool you would like to work on. 

 Menu page 
Some menu items in the left navigation bar open to a menu page where all the sections 
are explained. You can read a short explanation and then decide from there what you 
would like to do next. 

 Overview page 
The Domain Overview page and the E-mail Overview page both are central 
administration platforms. Each of them comprises all functions related to the respective 
area (i.e., domains and e-mail). To open them, select a package and then click on 
'Domains' or 'E-mail' in the left navigation bar or on the menu page. 

 Quickbar icons 
The icon quickbar in the brown bar at the top of package administration section of the 
Control Panel offers shortcuts to some applications included in your package. 

 

This manual will explain how to reach each section with the left navigation bar. No matter 
which kind of navigation method you prefer, they will all lead you to the same pages. Should 
you get lost, you can always orientate yourself by looking at the navigation path at the top of 
the page. This manual uses a shortened annotation to direct you to the respective features 
and processes: For example, 'New' > 'Forward' to indicate that first click on 'New' and then 
'Forward'. 
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THE 1&1 CONTROL PANEL: USING THE 1&1 CONTROL PANEL 

 

This is an example of how to use the Control Panel to reach and configure a feature. 

To set up an e-mail address that forwards e-mail to an existing account: 

1. Look in the left navigation bar for the area you would like to work on. In this case, select 
'E-mail'.  

2. Locate the process you would like to work on. In this case, setting up a new E-mail address, 
you would click on the arrow next to 'New' in the toolbar. Then from the drop-down 
menu that opens, select 'Forward'.  

3. On the next page you will find a text field labelled "E-mail address". Fill in the name you 
would like to use and choose the domain part from the drop-down menu. Continue the 
process by clicking on 'Next' and filling in further required information, such as the delivery 
address.  

4. Click on 'Save'. 

If you need help during any step of this process, refer to the Need Help? section in the box 
underneath the left navigation bar. 
 

For security reasons, always use the menu items to navigate within the Control Panel. Avoid 
using the 'Back' and 'Forward' browser buttons; otherwise you might receive an error 
message. 
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PACKAGE ADMINISTRATION: DOMAINS  

Package Administration 
1 Domains • 2 E-mail • 3 FTP, Web Space, and Access • 4 34.1 WebsiteCreator •4.2 
WebStatistics • 4.3 WebElements • 4.4 WebDatabase • 4.5 Newsletter Tool • 4.6 
in2site Live Dialogue • 4.7 Basic CGIs • 4.8 MS SQL Administration • • 5 Software 
Licenses 
 

The Package Administration area gives you access to your package's features, tools, 
programs, and management areas.  

1 Domains 
1.1 Domain Overview Page • 1.2 Add-On-a-Domain Process • 1.3 Change Domain 
Contact Details (Reg-C, Admin-C, and Tech-C) • 1.4 FrontPage® Server Extensions • 
1.5 Setting Up Different Home Directories • 1.6 Domain Forward • 1.7 Subdomains 
• 1.8 Shared Secure Socket Layer (SSL) Encryption • 1.9 Dedicated Secure Socket 
Layer (SSL) Certificate 
 

A domain name is part of a full Internet address (also known as URL). The domain name 
consists of two parts: the top level domain (TLD) and the second level domain. For example, 
the Internet address http://www.domain-of-your-choice.com consists of the TLD ".com" and 
the second level domain "domain-of-your-choice". "www" is the typical default subdomain 
and stands for World Wide Web. 

 

http://www.domain-of-your-choice.com/
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PACKAGE ADMINISTRATION: DOMAINS 

 

1.1 Domain Overview Page 
 

The Domain Overview page makes it easy for you to manage your domains quickly from 
one overview table. To reach the Domain Overview select the package from the Package 
Overview in the My Account area. Then in the Package Administration area click on 
'Domains'. 

 
Figure 3: Domain Overview page with an all-in-one toolbar for convenient domain management. 

The overview table lists all domains and subdomains that you have added to your package. 
The Domain Overview page has a toolbar with different editing functions. Click on the 
arrow next to an item in the toolbar for a drop-down menu containing the choices which 
allow you to select and edit existing domain settings. 
 

If a domain name is followed by (DNS), it indicates that editing some features may not 
produce the expected results. It takes up to 48 hours for changes to the DNS settings to be 
propagated through the entire system.  

After that time, check if your domain's settings are what you intended them to be by clicking 
on 'DNS check' from the drop-down 'DNS' menu in the toolbar of the Overview table. If you 
would like the settings to be returned to the default, choose 'Edit DNS Settings' and click on 
'Reset'. 

 

We recommend the modification of DNS settings for advanced users only. For more 
information on DNS see Advanced Option: Change Your Domain Name System (DNS) Settings 
page 12. 
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PACKAGE ADMINISTRATION: DOMAINS  

 

Use the toolbar to set up new domains or edit the listed domains. Mark the box to the left 
of the domain name you wish to edit and then click on one of the following options: 

 'New' 
If you would like to add a domain to this package, click on 'New'. This will bring you to 
the first step of the add-on-a-domain process. You will be able to order a domain (  
Order a New Domain (Register a Domain) page 10), transfer an existing domain (  
Transfer of Registrar page 11), or point your existing domain to 1&1 domain name 
servers (  Advanced Option: Change Your Domain Name System (DNS) Settings page 
12).  

 'Destination' 
You can assign your domain to a specific home directory or to display the content of 
another website by forwarding your domain to it. 

 'Contact' 
These are your domain contact details as they appear in the WHOIS records. Change the 
registrant contact, administrative contact, and technical contact of a domain to 
determine who is responsible for registration, administration, and technical questions. 

 'DNS' 
The records concerning your domain name are in the domain name system (DNS) so that 
your domain can be found on the Internet. DNS allows you to change or view DNS 
settings of a domain, such as the name servers, the A record, and the mail servers.  

 'Lock/Unlock' 
Unlock your domain only for transferring it to another registrar. If your domain is 
unlocked, we will allow transfers to registrars on their demand without further notice. By 
default, your domain is locked. 

 'Delete Subdomain' 
With this menu item, you can delete any subdomains you no longer need. For technical 
reasons, it is not possible to delete the default subdomain s12345678.onlinehome.us 
included in each package. 

 'Info' 
You can see how your domain is set up in your package by selecting a domain name 
from your list by ticking the box beside it and then clicking 'Info'. 

Below the overview table on the Domain Overview page, you can find a few extras that 
can be ordered for your domains.  

 1&1 Dedicated SSL Certificate 
Order or apply an SSL certificate for your package to ensure that unauthorized parties 
cannot interfere with sensitive data 

 Shared SSL Encryption 
Specify which domain should be used for encrypted data transmission and use the proxy 
SSL server with this domain. 
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PACKAGE ADMINISTRATION: DOMAINS 

 

Search and Sorting Features  
 

Search and sorting make the overview easier to handle, especially when you have a lot of 
domains in your package. 
 

If you would like to find the "domain-of-your-choice.com" domain in the overview, type 
"choice" in the search filter text field. Click on the right arrow to display all domains in the 
overview containing the word "choice". 

 

The Advanced Filter Settings view lets you set additional criteria to search by and clicking 
on 'Simplify Filter Settings' returns the filter to normal. 

Sorting arrows allow you to sort the domains you have by category in ascending or 
descending order. These are found next to the title of each column in the table. 

The sort function also sorts filtered results. Click on the 'Remove Filter' button to see the 
full list again. 
 

Depending on your package, you can choose to assign your domain to WebsiteCreator 
(WSC). WSC is a content management system (  WebsiteCreator page 38). Domains 
currently assigned to WSC are marked with "/wsc" followed by a WSC ID number in the 
Destination column. WSC blocks the reconfiguration of all DNS settings. 

 

1.2 Add-On-a-Domain Process 
 

A domain can be ordered for or transferred to your package from within the Control 
Panel. To add more domains to a package you already have, on the Domain Overview 
page click on 'New' in the toolbar. 
 

If you run a business, and want to use the Internet as an eCommerce platform, it makes sense 
to use either your business's name, or the name of the main product or service as a second 
level domain name. 

If you want to present your family tree and aspects of your family life in the Internet, you can 
choose your last name as second level domain. 
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PACKAGE ADMINISTRATION: DOMAINS  

 

Order a New Domain (Register a Domain) 
 

Ordering or registering means that you buy the rights to the domain name for the 
registration period. To order or register a domain name you need to go through an 
accredited registrar of your choice (such as 1&1 Internet Group).The domain name is then 
listed in a registry such as VeriSign or Affilias.  

If you register a domain name with you as the owner, then you will also be allowed to 
extend your ownership by renewing your registration. For any domains hosted with 1&1, 
renewal of the domain is done automatically unless you cancel it explicitly.  

When you have your domain registered with 1&1 Internet Group, you can regard any 
letters from registrars asking you to renew your domain to avoid it being released and your 
domain being transferred to them, as "renewal spam" which you do not need to react to. 
 
 

Top Level Domains 

You can register a top level domain (TLD), such as ".com" for commercial, ".net" for 
network, ".org" for organizational, ".info" for informational or ".name" for name, and now 
".us" for USA domains. See http://1and1.com to find out which TLDs you can register. 

How to Register a Domain in the 1&1 Control Panel 
 

You can add on domains to your 1&1 package any time. When logged on to the 
1&1 Control Panel, and on the Domain Overview page click on 'New' in the toolbar. To 
check that the domain name you want is still available, type the name in the text field 
labelled "Domain name". When typing the domain name, make sure to include a top level 
domain (TLD), which is a domain suffix such as .us, .com, .net, .org, .name, or .info, and 
follow the instructions. 

If the domain name is still available, you will be required to determine the registrant data 
for it, thus choosing who shall appear in the WHOIS records as registrant (reg-c) and 
administrative contact (admin-c) (  Change Domain Contact Details (Reg-C, Admin-C, and 
Tech-C) page 16). Use your own name with your 1&1 user data or that of any other person 
of your choice.  
 

Make sure to check the exact spelling prior to submitting your order for a domain name. No 
changes can be made to the domain name once a domain has successfully been registered. If 
you would like a different name, you will be charged for the new registration. 

How Long Does it Take? 
 

It takes 24 hours to register a domain. In some cases, it could take longer due to technical 
difficulties or errors with your registration. To check the status of your registration log on 
to the 1&1 Control Panel, and go to 'Domains'.  

The domain name will take around 48 hours to become fully visible by all computers on 
the Internet. This is due to the DNS propagation. 
 

 

 

http://1and1.com/
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PACKAGE ADMINISTRATION: DOMAINS 

Transfer of Registrar 
 

A transfer of registrar means that you move one or more domain names you already have 
with one registrar to another registrar, in this case to 1&1 Internet Group. A registrar 
offers registration services for your domain, providing information to be entered into the 
Registry database so it can be correctly propagated through the Internet. 

There may be several reasons for a transfer of registrar. You may want to initiate a transfer 
if you are no longer satisfied with the service or conditions of your current registrar, or if 
you would like to have all the web hosting related tasks conveniently handled by one 
organization. 
 

A registrar may be but is not necessarily your Internet Service Provider (ISP) or web host. A 
transfer of registrar does not imply that you automatically change your ISP or web host. 

How to Transfer Your Registrar in the 1&1 Control Panel 

Choose 'New' > 'Add On a Domain' from the toolbar on the Domain Overview page. 
Enter your domain name in the "Domain name" text field and click on 'Next'. Once our 
system finds that the domain name is already registered, it offers a "Transfer of Registrar 
to 1&1" option. Follow the instructions in each step of the add-on-a-domain process to 
complete the transfer. Enter the registrant data for the transferred domain, thus choosing 
who shall appear in the WHOIS records as registrant (reg-c) and administrative contact 
(admin-c) (  Change Domain Contact Details (Reg-C, Admin-C, and Tech-C) page 16). Use 
your own name with your 1&1 user data or other data.  

You will then receive an e-mail message informing you of the next steps to take. Check 
the status of your domain transfer by clicking on 'Domain Transfer Status' found under 
the Domain Overview table. 
 

In order to have your domain transferred, you — the owner of the domain — must explicitly 
initiate the transfer. 

How Long Does it Take? 

It takes seven to ten days for a transfer of registrar. 
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PACKAGE ADMINISTRATION: DOMAINS  

 

Troubleshooting: Transfer of Registrar 
 

Automatic Transfer of Other Websites Alongside the Domain Name? 

When a domain transfer is initiated, the website that the domain was formerly pointing at is 
not transferred along with the site. The data (i.e. the pages, the graphics, etc.) of the site is 
held on the servers of the previous host. Only the domain is transferred to our servers. You 
will need to perform another upload of your site onto our servers for your website to appear 
under your domain. 

Errors During a Domain Transfer 

A domain name transfer may be refused for various different reasons. To find out the exact 
reason, please consult your current or the gaining registrar or both. 1&1 will help you as best 
it can to locate the reason and find a solution for the problem. 

Transfer an External Subdomain? 

External subdomains cannot be transferred to 1&1 servers. You can only use subdomains 
created in your 1&1 account. 

It is possible to transfer the domain name of that subdomain to 1&1. To do so, use the add-
on-a-domain process (  Add-On-a-Domain Process page 9). Alternatively, you can point the 
DNS of your external subdomain to 1&1 (  Add On an External Domain (Point DNS to 1&1) 
page 12). 

Advanced Option: Change Your Domain Name System (DNS) Settings 
  

If you are an advanced user, you may want to fine tune your 1&1 package. For example, 
you may want to keep your domains registered with your current registrar but would them 
hosted with 1&1 — a web host that guarantees 99.9% uptime. Alternatively, you can 
registrar your domain with the 1&1 Internet Group but have the name servers pointed to 
another web host. 
 

Changing the DNS settings with insufficient expertise may lead to irreversible misdirection of 
your domains or e-mail addresses, and loss of data! 1&1 strongly recommends DNS settings 
be modified by advanced users only.  

Add On an External Domain (Point DNS to 1&1) 
  

If you would like to use 1&1 domain name servers for a domain, which is registered 
externally (with a non-1&1 registrar), you can point your domain name to 1&1 name 
servers. By pointing your domain name servers, you add an external domain to your 1&1 
package. However, your domain remains registered with your current registrar, and your 
current registrar will continue to charge you. In order to get the attractive 1&1 domain 
rates or to set up a domain included in your package for free, transfer your domain to 1&1 
(  How to Transfer Your Registrar in the 1&1 Control Panel page 11). 
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Set Up an External Domain (Point a Domain to 1&1) in the 1&1 Control Panel 

 Point Your Domain Name Servers to 1&1 
Select 'New' > 'Add On a Domain' from the toolbar on the Domain Overview page. 
Enter the domain name including the top level domain (TLD) in the "Domain name" text 
field and click on 'Next'. Once our system finds that the domain name is already 
registered, it offers a "Point Your Domain to 1&1 Name Servers and Keep Your Current 
Registrar" option. This choice allows your domain name to be recorded in our systems 
and you can set up e-mail and web space for this domain. You can point your domain to 
1&1 DNS, no matter which TLD you have. 

After you have placed a request for the name servers to be changed by your current 
registrar and the process has been initiated, it will take the information between 24 and 
48 hours to propagate in the domain name system. In the meantime we recommend 
uploading your website onto our web servers. This way, your website will have no down 
time. 

 

To make sure your domain name servers are pointed correctly and fully operable with 1&1 
services, ask your current registrar to set up ONLY and EXACTLY the two 1&1 name servers 
you are given when adding on your domain by pointing it to 1&1 in the Control Panel. If you 
have any other name servers set up or fail to use both name servers, the situation could result 
in misdirection of requests for your domain. 

This information appears later under the Domain Overview toolbar's menu item 'DNS'. Select 
the domain in question by ticking the box beside it. Click on the 'DNS' arrow and from the 
drop-down menu that opens select 'DNS Check'. 

 

 Set up 1&1 Mail Servers for your External Domain 
Your mail server records (MX records) are special resource records for mail routing. An 
MX record specifies a domain name and an associated server, the "mail server", which is 
able to deliver e-mail to an e-mail address with that domain name. 

You can point your MX records to 1&1 if you would like to use our mail servers. When 
logged on to the Control Panel, click on 'DNS' in the Domain Overview toolbar. Select 
the external domain for which you would like to modify the mail servers. To point your 
MX records to 1&1, select "1&1 mail server". 

Point Your DNS away from 1&1 
 

With our advanced DNS management options, you can also point your 1&1 domain name 
servers, your mail server (MX records), or your IP address (A record) to another web host 
provided that your desired web host supports this option. To change your DNS settings 
accordingly, log on to the 1&1 Control Panel and click on 'DNS' in the Domain Overview 
toolbar. 

 Point Your Domain Name Servers Away from 1&1 
You can point your domain name server away from 1&1 to use other name servers. Use 
up to four name servers of your choice. In case you have only one name server available, 
please use a 1&1 name server as secondary, since at least two name servers are required 
by the registry. 
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When logged on to the Control Panel, click on 'DNS' in the Domain Overview toolbar. 
Select the domain. Select "Other name server" from the drop-down menu. Enter your 
name servers. A minimum of two name servers is required. 

Once you have changed your name server, 1&1 hosting services are no longer available 
and 1&1 has no more influence over your mail servers and IP settings, since these are 
manifested in the name servers. 

If you use your own name servers and would like to point them back to your 1&1 web 
space via IP address (A record), please be aware that the IP addresses may change. 
Therefore we cannot guarantee proper functionality of this arrangement. 

 Point Your Mail Exchange Records Away from 1&1 
Your mail server records (MX records) are special resource records for mail routing. An 
MX record specifies a domain name and an associated computer, the "mail server", 
which is able to deliver e-mail to an e-mail address with this domain name. 

To differentiate the MX records, each has a priority (lower the number, higher the 
priority). The MX record with the highest priority is the target computer where mailboxes 
are located. The other MX records designate the backup computers in case the target 
computer is not accessible. They store the e-mail temporarily and periodically attempt to 
redirect e-mail to the target computer. 

To change your MX records settings, when logged on to the Control Panel, click on 
'DNS' in the Domain Overview toolbar. Select the domain. To set up different MX 
records, select "Other mail server". 

Enter the MX record (ex. mx01.test.com) in the first text field. In the second text field 
enter the priority. Priority can be set in deca-digits (10, 20, 30, etc. — the lower the 
digit, the higher the priority). If you have one or two mail servers, select "Backup mail 
server", and if you have more than two, select "Other mail server". Further backups are 
set to 1&1 mail servers. They have the lowest priority. 

 

If you choose non-1&1 mail servers, 1&1 e-mail services cannot be used anymore. You can 
use 1&1 mail servers as your backup servers. 

 

 Point Your IP Address (A Record) Away from 1&1 
When logged on to the Control Panel, go to 'DNS' in the Domain Overview toolbar. Select 
the domain whose IP address you wish to point away. To set up a different IP address, 
select "Other IP address". 
 

If you choose to change your A record, you can still use our mail servers, but your website and 
features will not be connected any longer. 
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Troubleshooting: DNS Settings 
 

Restore Your Name and Mail Servers to Default Settings 

If you would like to return to the default settings of your 1&1 package, log on to the Control 
Panel, and click on 'DNS' > 'Show DNS Settings' in the Domain Overview toolbar and click 
on 'Reset'. This will restore the default settings. 

Losing E-mail (While Setting Up External Domains or Changing MX Records) 

During DNS propagation there is also a risk of losing e-mail, since some e-mail sent to your 
domain name may be misdirected. 1&1 helps you avoid this risk by checking the current 
e-mail settings ("mail server" or "MX records") of your domain name while you set it up as 
an external domain name. You will then have the choice of switching directly to 1&1 or 
keeping your old mail servers until the new name servers have been distributed in the domain 
name system. 1&1 strongly recommends that you choose to keep your old mail servers during 
the propagation period, and change to your new mail servers only AFTER this period. After 
the propagation, you will receive an e-mail to the e-mail address you provided in your user 
data. The domain name system will need up to 48 hours to propagate the new mail servers. 
During this time you should check the POP3 accounts with both your old provider and 1&1.  

Finally, you can cancel your e-mail settings with the old provider and fully use your domain 
name with 1&1 Internet Inc. — without any loss of information. 

Moving Domains from One 1&1 Package to Another 
 

You can move one or more domain names from one package to another. Transferring a 
domain internally will take up to 48 hours, after the domain transfer has been approved. 

Moving Domains in the 1&1 Control Panel 
 

When logged on to the Control Panel and having chosen the package you would like to 
work on, on the Package Administration page choose 'Domains'. In the Domain Overview 
toolbar, click on the 'New' arrow. From the drop-down menu that opens choose 'Add on 
a Domain'. On the page that opens, enter the domain name you would like to add to this 
package, and click on 'Next'.  

The system automatically recognizes that the domain is registered and displays the owner 
data. Accept the Terms and Conditions for a transfer of registrar, and again click on 
'Next'.  

On the following page, check your user data, change it if necessary, and proceed to the 
next page. Double-check that the data of your request for a transfer of registrar is correct 
and submit it. 
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After that, go back to your My Account page to select the package that the domain is to 
be moved away from. If you happen to have this package under a different customer ID 
log on to the Control Panel with that customer ID. On the Package Administration page, 
choose 'Domains'. On the Domain Overview page, open the 'Domain Transfer Status' 
to see the status of the domain transfer. Choose 'Edit' from the table which is displayed 
next to the domain. On the Approve Domain Transfer page, read the information. If you 
accept the release of the domain, then tick the box next to "Release domain" and click on 
'Next'. Finally, confirm the domain transfer by clicking on 'Send'. 

If the domain transfer has been successful, you will receive a confirmation e-mail and your 
domain will be moved to the new package. 

1.3 Change Domain Contact Details (Reg-C, Admin-C, and Tech-C) 
  

During the add-on-a-domain process you are required to provide the registrant contact 
(reg-c, owner of the domain) for the domain. You can choose to give further information 
concerning a registered domain. 

In the administrative contact (admin-c) section insert the name of the person responsible 
for administrative (nontechnical) questions such as rights, changes of ownership, etc. 
Admin-c can be the same person as or a representative of the registrant. 

The tech-c is the technical contact person for all technical questions that deal with the 
registered domain. By default this is 1&1 as your provider, but you can change this 
information to any other person you wish. To change the current contact details click on 
'Contact' in the toolbar on the Domain Overview page in your Control Panel. 

If your information changes, you can update both your user data and your domain contact 
details any time. The contact information of all respective domains will be automatically 
updated. 
 

Contact updates only apply to full domains registered through 1&1 Internet Group. This 
function is not applicable for subdomains. For external domains this information can only be 
changed by the respective registrar. Contact your registrar for the necessary updates. 

1.4 FrontPage® Server Extensions 
  

Microsoft® FrontPage® Server Extensions (FPSE) are a set of programs that run on 1&1's 
web servers which you can use to maintain and author your web presence easily as well as 
add functionality to it. FPSE is compatible with FrontPage® 98, 2000, and 2003. As an 
alternative to FTP, you can use FPSE to upload files to your web presence with any FPSE 
client, such as Microsoft® FrontPage® itself. With Microsoft® Office® applications (version 
2000 or higher) you can directly store and edit files on the web server. Any changes you 
make to your website using FPSE are uploaded directly to the server and are immediately 
visible online. 
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Once you have activated FPSE you cannot use any FTP programs and vice versa. If in doubt, 
check your FPSE settings, and if needed, activate/deactivate FPSE prior to proceeding with 
your web space administration. 

 

You can enable FPSE your domains any time. When you create a website with FrontPage®, 
you can use its publishing function to get your site online. To set up your domain for use 
with FrontPage®, on the Domain Overview page in the Microsoft FrontPage Extensions 
Status section, click on 'Activate'. This will activate FPSE for ALL domains in your package. 

FrontPage® Server Extensions only work when the domain points to your web space. 

1.5 Setting Up Different Home Directories 
 

Different home directories for each of your websites allows you to assign a part of your 
web space to each of your domains. This allows you to have different websites. The web 
space is the physical hard disk space that has been reserved for your 1&1 package on our 
web servers. All domains included in your package access this web space. By default, all 
domains point to the root directory, which is identified by a slash and a dot "/.". 

To create a new directory, on the Domain Overview page select which domains you would 
like to work on and click on 'Destination' in the toolbar. The destination is where 
requests for your domain lead to. You can set the directory under "Home Directory". From 
the list of existing directories choose the one that you would like to assign the chosen 
domain to. Or create a new home directory to assign the selected domain to. 

The web space reserved for your 1&1 package will be divided dynamically between all the 
home directories you assign to your domains. However, the sum of the web space used 
cannot exceed the maximum amount of web space included in your package. If you need 
more space you can upgrade to a larger package. Click on 'Upgrade'  if this option is 
available. 

Domains cannot be edited while assigned to WebsiteCreator (WSC), being used with 
in2site Live Dialogue, or having Microsoft® FrontPage® Server Extensions enabled. 

 Disable WSC 
Click on 'Applications' > 'WebsiteCreator' and then on 'Assign Domain'. Select 
"None/Unassign". You can later reassign WSC in the same place. 

 Disable in2site 
Click on 'Applications' > 'in2site Live Dialogue' and then on 'Disable' next to that 
domain. You can later re-enable in2site in the same place.  

 Disable FrontPage® Server Extensions 
Click on 'Domains', select the domain, and at the bottom of the page click on 
'Disable'. You can later reactivate FrontPage® Server Extensions in the same place. 



 

18 

Windows® Hosting Manual, 1&1 Internet Inc. 

PACKAGE ADMINISTRATION: DOMAINS  

 
 

1.6 Domain Forward 
  

If you already have an established website but would like to use your 1&1 domain name 
for it, instead of creating a whole new website or having to upload it, you can forward 
your 1&1 domain name to the existing website. 

In your Control Panel, on the Domain Overview page select which domains you would like 
to work on and click on 'Destination' > 'Edit Destination' in the toolbar. 

After selecting to forward your domain name, fill in the complete web address (URL) you 
would like your visitors to be forwarded to, and a title which will be displayed along the 
top of the browser window. You may also enter "Meta" information in both the "Meta 
description" and the "Meta keywords" fields if you would like search engines to index 
your page. Follow the instructions to complete the setup of the domain forward. 

1.7 Subdomains 
   

You can set up subdomains for your existing domains. This clearly organizes your domains 
to be used for specific, different parts of your business, different sections of your website, 
or various user groups. For example, set up subdomains to divide your web content into 
different topics or to mark a domain as ftp or www directory. Examples for subdomains 
may be: www.domain-of-your-choice.com (for domain-of-your-choice.com web content 
designed for the WWW), info.domain-of-your-choice.com (for information site(s) 
contained in your domain web content), etc. 

When logged on to the Control Panel, on the Domain Overview page select 'New' > 
'Create a Subdomain' from the toolbar. Here, you will find an overview of your present 
subdomains and their status, along with a text field for registering additional subdomains. 
You can create and delete subdomains in this section. 

1.8 Shared Secure Socket Layer (SSL) Encryption 
  

Depending on the 1&1 package you chose, you can enable encrypted data transfer by 
configuring the Secure Socket Layer (SSL) proxy server for a domain or subdomain. 
Transfer sensitive data securely using 128-bit encryption, which prevents monitoring and 
manipulation attempts. 

The SSL proxy server encrypts your transactions without you having to buy your own SSL 
certificate. Your website can be reached under https://domain-of-your-choice.com. Once 
the website opens, it will be redirected to the proxy server's address, ex. 
https://ssl-perfora.net/domain-of-your-choice.com. 

From below the table on the Domain Overview page select 'Shared SSL Encryption' and 
follow the instructions to apply, edit or remove SSL to one or more domains. A newly 
setup encryption may take a few hours and a modification or deletion of the shared SSL 
encryption may take up to 30 minutes to become effective. 

No forwarding destination may be set for domains using SSL proxy server encryption. 
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1.9 Dedicated Secure Socket Layer (SSL) Certificate 
    

Secure Socket Layer (SSL) presents an encryption process which enables safe and private 
communication between computers (using 128-bit encoding) within a public network. 
Using SSL, sensitive data can be protected during transfer from attempts at spying or 
manipulation. SSL Certificates are used to secure a site using SSL technology. 1&1 offers 
the option to obtain and set up your own Dedicated SSL Certificate from GeoTrust with 
only one domain name per package. The Dedicated SSL Certificate corresponds to 
GeoTrust's Quick SSL Premium. Choose this option, if you would like to avoid your 
domain's URL appearing in connection with an SSL proxy server name. 

From below the table on the Domain Overview page, select 'Dedicated SSL Certificate' 
to create a Dedicated SSL Certificate in your 1&1 Control Panel and follow the instructions. 

To find out more information on GeoTrust, please visit www.geotrust.com. 
 

Forwarding an encoded transfer to an external URL is not possible. No forwarding destination 
may be set for a domain with a dedicated SSL Certificate. 

http://www.geotrust.com/
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2 E-mail 
 

2.1 E-mail Overview Page • 2.2 Set Up a New E-mail Address in the Control Panel • 
2.3 Auto-responder • 2.4 Virus Protection • 2.5 Catch-all Account • 2.6 Delete 
E-mail Addresses • 2.7 Reading or Collecting E-mail From Your Mailbox • 2.8 Local 
Mail Programs (Microsoft® Outlook® Express, Netscape®, Eudora®) • 2.9 1&1 
WebMail • 2.10 Activate Your E-mail for External Domain Names 
E-mail, short for electronic mail, is a way to send messages electronically from one 
computer to another. E-mail transmission uses a variety of protocols (the language 
computers use to speak with each other). Principally, these are the Simple Mail Transport 
Protocol (SMTP) to send them out from your client computer via the Internet to the mail 
server, and the Post Office Protocol version 3 (POP3) to retrieve e-mail from the server with 
your client. 

In order to use e-mail you need an e-mail address, for example your.name@domain-of-
your-choice.com. The part in front of the "@" sign (the local part) is the name or term of 
your choice. The part after the "@" sign (the domain part) is the computer address. This 
can be the domain name you have already set up (  Domains page 6). 

Just like domain names e-mail addresses are easy for people to remember. To promote 
your website, you can create an individual e-mail address — made with your domain 
name. This not only allows you to communicate with others, but it makes others aware of 
your website. If you use your.name@domain-of-your-choice.com as an e-mail address, 
your e-mail recipients may look to see if there is a website under domain-of-your-
choice.com. 

2.1 E-mail Overview Page 
 

You can set up, edit, and delete e-mail addresses directly by using the functions found in 
the toolbar. Each e-mail address you create will be added to this overview table.  

 
Figure 4: E-mail Overview Page with an all-in-one toolbar for convenient e-mail management 

To reach the E-mail Overview page click on 'E-mail' in the Package Administration area. 
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Click on 'New' to create a new e-mail address. Once you have e-mail addresses set up you 
can mark the box to the left of the ones you wish to edit and then click on one of the 
following options: 

 'Settings' 
Go directly to the setting to rename an e-mail address, change or add new e-mail 
delivery targets, or turn your auto-responder on or off.  

 'Delete' 
Select an e-mail address and then use this button to delete the address. 

 'Virus Protection' 
Enable, disable, or order more Virus Protection for your e-mail accounts. 

 'WebMail' 
Log on to WebMail to be able to read your e-mail from anywhere you have an Internet 
connection. 

Search and Sorting Features 
 

To make the overview easier to handle, especially when you have a lot of e-mail addresses 
in your package, the following search and sorting features can help. 
 

If you would like to find the e-mail address "info@domain-of-your-choice.com" in the 
overview table, type "info" in the filter text field. Click on the right arrow to display all the 
e-mail addresses in the overview containing the word "info". 

 

The Advanced Filter Settings view lets you set additional criteria to search by and clicking 
on 'Simplify Filter Settings' returns the search filter to normal. 

Sorting arrows allow you to sort the e-mail addresses you have by category in ascending or 
descending order. These are found next to the title of each column in the table. 

The sort function also sorts filtered results. Click on the 'Remove Filter' button to see the 
full list again. 
 

To increase the number of e-mail addresses, it may be possible to upgrade your package. 
Click on 'Upgrade' in the left navigation bar, if this option is available.  

2.2 Set Up a New E-mail Address in the Control Panel 
 

When setting up a new address you can decide where the e-mail sent to that address 
should be delivered. 

To set up a new e-mail address, click on 'E-mail' in the Package Administration area. This 
brings you to the E-mail Overview page. Open the drop-down menu for 'New' in the 
toolbar. Select whether to set the primary delivery target as a mailbox or forward. 
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Then decide where you would like your e-mail delivered to. A delivery target tells the mail 
server where to send the e-mail messages received for that address. You can select up to 
three delivery targets for each e-mail address. That means e-mail sent to an e-mail address 
will be delivered to all three targets. 

E-mail Delivery Targets: Mailbox (E-mail Account) vs. E-mail Forward 
 

1&1 offers two different types of e-mail addresses: an e-mail mailbox and a forwarding 
e-mail address. The addresses have different delivery targets and therefore different uses. 

Example 

You may find it useful to create up to three delivery targets for one e-mail address. If there 
are 3 managers in a company — each with their own e-mail account — who would like to 
retrieve e-mail sent to the e-mail address management@domain-of-your-choice.com. Set up 
the address "management@domain-of-your-choice.com" as a forward with the three 
managers' mailboxes as the delivery targets. 

Mailbox 
(   

E-mail mailboxes allow you to retrieve messages directly from the mail server for example, 
using Post Office Protocol version 3 (POP3). E-mail sent to test@domain-of-your-
choice.com is held on one of our mail servers. The e-mail is stored there until you retrieve it 
with your e-mail program. You can set up a local e-mail program such as Microsoft® 
Outlook Express® or Eudora® to use. Or you can use 1&1 WebMail. 
 

It depends on your mail program settings whether e-mail you have retrieved from the mail 
server is deleted immediately or not. 

 Set Up a Mailbox  
In the Control Panel select the package you would like to work on. Then select 'E-mail' 
from the Package Administration page to open the E-mail Overview page. 

If you do not have any e-mail addresses yet, click on the link 'Set Up New E-mail 
Address' and follow the instructions.  

To set up additional e-mail addresses, in the E-mail Overview table toolbar click on 
'New'. On the next page that opens, type in a name in the "E-mail Address" text field 
and choose the domain name from the drop-down menu. As delivery target choose 
"Mailbox" and click on 'Next'. On the next page, choose a password between 6-8 
characters for your mailbox and repeat it. Be sure to make a note of it and your mailbox 
name to use when setting up your local e-mail program (  Set Up a New E-mail Address 
in the Control Panel page 21). You can then set up more delivery targets. Make sure to 
save your settings. 

 

Your e-mail password will not be displayed in the Control Panel. Please make sure to make a 
note of it. If you later forget your password, you can return to the 1&1 Control Panel and 
change your mailbox password. 
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 Edit a Mailbox  
You can edit existing e-mail addresses. Select the addresses you would like to work on 
by ticking the box beside it in the E-mail Overview table. Click on 'Settings' > 'Show 
Settings' in the table's toolbar. 

On the Settings page choose whether to edit the e-mail address, the delivery targets, or 
other options concerning the e-mail address (such as Virus Protection) by clicking on 
'Edit' and making your changes. 

If you edited or created a mailbox for your e-mail address, take a moment to write down 
the mailbox name (starting with an "m" followed by an eight digit number) and the 
password you chose. You will need the information for configuring your local mail 
program (  Set Up a New E-mail Address in the Control Panel page 21). 1&1 keeps your 
e-mail on its mail server until you collect it through your e-mail program. 

 

Every mailbox has a quota of 50 MB. A single e-mail, however, cannot be larger than 20 MB.  

 

Unretrieved e-mail messages are stored on our mail servers for three months at the most. 

 

 Change Your Mailbox Password 
Select the e-mail address by ticking the box next to it and click on 'Settings' > 'Delivery 
Targets' in the table's toolbar. On the E-mail Delivery Target page select the option to 
change the mailbox password. Editing the password allows you to change the address's 
delivery targets as well. 

 

To continue to receive your e-mail locally, remember to make a note of your new password, 
and to change it in the settings of your local e-mail program. 

E-mail Forward 
 

An e-mail forwarding address automatically redirects e-mail to another address. If you 
already have an e-mail account that you check and would like to have separate addresses 
for business and personal use, then you can create new addresses and have them 
forwarded. That way, you can only have to check one account for all your e-mail. 

 Set Up an E-mail Forwarding Address  
If you do not have an e-mail address yet, click on the link 'Set Up New E-mail Address' 
and follow the instructions.  

To set up additional e-mail addresses, in the E-mail Overview table toolbar click on 
'New'. On the next page that opens, type in a name in the "E-mail Address" text field 
and choose the domain name from the drop-down menu.  As a delivery target choose 
"Forward" and click on 'Next'. On the next page, enter the target e-mail address that 
messages should be forwarded to. You can then set up more delivery targets. Make sure 
to save your settings. 
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 Edit an E-mail Forwarding Address  
You can edit existing e-mail addresses. Select the addresses you would like to work on 
by ticking the box beside it in the E-mail Overview table. Click on 'Settings' > 'Show 
Settings' in the table's toolbar. 

On the Settings page choose whether to edit the e-mail address, the delivery targets, or 
other options concerning the e-mail address (such as Virus Protection) by clicking on 
'Edit' and making your changes. 

Delete E-mail Delivery Targets 
 

To delete a delivery target log in to the Control Panel and select the package containing 
the e-mail address. Select 'E-mail' from the Package Administration page menu. Select the 
e-mail address you would like to delete and then click on 'Settings' > 'Delivery Targets' 
in the toolbar. From the drop-down menu choose "None/Delete". 
 

If you report mail you receive to your 1&1 e-mail address to spamcop.net by forwarding it, it 
may result in spamcop.net blacklisting 1&1 mail servers instead of the originating mail server. 

2.3 Auto-responder 
  

Decide whether you would like to activate the auto-responder. This sends the same 
prepared e-mail to every e-mail message it receives. For example, use it for sending out-of-
office replies while you are on vacation. 

Open the E-mail Overview page in the Control Panel and select the package you would like 
to work on. Select 'E-mail' from the Package Administration menu page. First mark the 
e-mail address in the overview table, and then, in the toolbar, click on the 'Settings' 
arrow to open the drop-down menu. From the menu select 'Auto-responder'. Follow the 
instructions to activate or deactivate the auto-responder. 
 

The text for the auto-responder message cannot exceed 1,020 characters. 
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2.4 Virus Protection 
  

1&1 and Symantec work together to bring you a comprehensive Virus Protection. 

To add virus protection log in to the Control Panel and select the package containing the 
e-mail address. Select 'E-mail' from the Package Administration page menu. Select the 
e-mail address you would like to work on and then click on 'Virus Protection' in the 
toolbar. Follow the instructions to enable Virus Protection for your e-mail account 
(mailbox). 

The number of Virus Protection modules varies depending on the individual 1&1 package 
you have. To order additional Virus Protection modules, click on 'Order'. 

2.5 Catch-all Account 
  

You can create a catch-all account, that "catches all" e-mail which is addressed to your 
e-mail domain part. Instead of the e-mail being returned to the sender as undeliverable 
due to typing errors, you will receive all e-mail sent to the domain part of your e-mail 
address. 

*@domain-of-your-choice.com catches all e-mail that is addressed to "domain-of-your-
choice.com". You will receive all e-mail addressed to any local parts (names or terms 
before the "@") which you have not explicitly defined as e-mail addresses. The catch-all 
account only receives e-mail messages that are not addressed to an existing account. 

To create a catch-all account, follow the instructions under Set Up a New E-mail Address in 
the Control Panel page 21. But instead of a name for the local part, place an asterisk in the 
left text field.  
 

You have set up info@domain-of-your-choice.com and *@domain-of-your-choice.com.  

E-mail addressed to info@domain-of-your-choice.com will be delivered to info@domain-of-
your-choice.com.  E-mail addressed to ifno@domain-of-your-choice.com, inf@domain-of-
your-choice.com, and customer.name@domain-of-your-choice.com will be delivered to 
*@domain-of-your-choice.com.  

2.6 Delete E-mail Addresses 
 

Deleting an e-mail address is easy, but be aware that the deletion is permanent. 

Go to 'E-mail', and in the E-mail Overview table, select one or more e-mail addresses you 
would like to delete. Click on 'Delete' on the toolbar. 
 

Once you have deleted an e-mail address, it cannot be restored. If the e-mail address was a 
POP3 account, the messages on the mail server are erased immediately. 
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2.7 Reading or Collecting E-mail From Your Mailbox 
 

To collect the e-mail which arrive on your e-mail account (or mailbox) from our mail server, 
and to read and write e-mail, you can use any mail program, such as Microsoft® Outlook 
Express®, Netscape® Messenger, Eudora® etc. 

To read and write e-mail quickly (directly on the mail server) you can also use WebMail 
https://webmail.1and1.com. This Internet mail client is useful when you are travelling or do 
not have your own computer to store your e-mail locally (  1&1 WebMail page 28). 
 

WebMail is not available for use with forwarding e-mail addresses. 
 

2.8 Local Mail Programs (Microsoft® Outlook® Express, Netscape®, 
Eudora®) 

 

Set up a mail client of your choice locally on your computer to manage your e-mail. 

Microsoft® Outlook® Express 

  

Open Outlook® Express. From the menu bar of the program, choose 'Tools' > 'Accounts'. 
Click on 'Add' and select "Mail" from the list that opens. Follow the instructions 
throughout the setup process, using the following information as you go along: 

1. "Your Name": 

Enter the name you would like to appear in the "From" field of your e-mail message. 

2. "Internet E-mail Address": 

Enter the e-mail address of the account you have set up with 1&1 (ex. your.name@domain-
of-your-choice.com). 

3. "E-mail Server Names": Choose "POP" 

Incoming mail server (POP3): Enter "pop.1and1.com" 

Outgoing mail server (SMTP): Enter "smtp.1and1.com" 

4. "Internet Mail Logon" 

Enter the mailbox name (an "m" followed by an eight-digit number) and the password you 
set and made a note of, when creating up your e-mail account (mailbox) in the 
1&1 Control Panel. 

 

If you have forgotten to note your password, return to the 1&1 Control Panel and change 
your mailbox password — make a note of the new password and the mailbox name. See 
Mailbox page 22 on how to change your mailbox password. 

 

 

http://webmail.1and1.com/


 

27 

Windows® Hosting Manual, 1&1 Internet Inc.  

PACKAGE ADMINISTRATION: E-MAIL 

 

Finally, configure your e-mail account for the SMTP-Auth feature, to ensure that all e-mail 
messages sent from your 1&1 account will be accepted. Go back into the 'Tool' menu 
item in Outlook Express®. Click on 'Accounts' > 'Mails' > 'Properties' > 'Servers' and 
select "Server requires authentication". Under 'Settings' select the option "Use same 
settings as my incoming mail server in the Log on Information panel", and apply it. 

Netscape® 

  

Go to 'Programs' > 'Netscape' > 'Mail and Newsgroups' on your Windows® system. If 
you have not set up an account already, the Netscape® Account Wizard appears 
automatically. If an account already exists, the Account Wizard does not appear 
automatically when the Netscape® Mail window opens. Instead, after opening the Mail 
window, go to 'File' > 'New' > 'Account'. Follow the instructions using the following 
information: 

1. "Your Name" 

Enter the name you would like to appear in the "From" field of your e-mail messages. 

2. "E-mail Address" 

Enter the e-mail address of the account you have set up with 1&1 (ex. your.name@domain-
of-your-choice.com). 

3. "Server Information": Select "POP". 

Incoming server (POP3): Enter "pop.1and1.com" 

Outgoing server (SMTP): Enter "smtp.1and1.com" 

4. "User Name" 

Enter the mailbox name (an "m" followed by an eight-digit number) which was assigned to 
your e-mail address when you set it up. 

5. "Account Name" 

Choose the name your account should appear with in the Netscape® Mail program. 

Once the setup process is complete and you would like to send or receive e-mail, you will 
be prompted to enter your mailbox password to do so. Use the password you set and 
made a note of when creating your e-mail account (mailbox) in the 1&1 Control Panel. 
 

If you have forgotten to note your password, return to the 1&1 Control Panel and change 
your mailbox password — make a note of the new password and mailbox name. See Mailbox 
page 22 on how to change your mailbox password. 
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2.9 1&1 WebMail 
 

WebMail is 1&1's Internet-based mail system, which you can use to read and write e-mail 
from anywhere and makes a local mail program redundant. If you access you e-mail 
account via WebMail, you keep your e-mail messages on the mail server. 

1&1 WebMail communication is protected by Secure Socket Layer (SSL) encryption. 
 

Only an e-mail address set up as a mailbox can be accessed through WebMail, while 
forwarded addresses cannot. 

 
 

WebMail is especially useful when you are travelling or do not have your own computer to 
check you mailbox and store your e-mail locally. With this tool, you can access your e-mail 
from anywhere on the Internet. 
 

WebMail accounts are automatically created or deleted when you create or delete a mailbox 
in the Control Panel. You cannot create or delete accounts in the WebMail program. 

Accessing WebMail 
Call up WebMail under https://webmail.1and1.com. 

Full WebMail Access 

Log on using a domain name and your 1&1 Control Panel password. Using this login gives 
you access to all accounts. You can change passwords, create or change signatures, and 
have full access to all WebMail address books. 

Single Mailbox/E-mail Address WebMail Access 

Log on using a mailbox name or an e-mail address and its mailbox password. This opens 
the mailbox that belongs to that e-mail address. 

Or you can access a single mailbox in WebMail from the Control Panel. In the Package 
Administration area, click on 'E-mail' and click on 'WebMail' in the toolbar. 

 

 

https://webmail.1and1.com/
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Figure 5: 1&1 WebMail can be reached from anywhere you have Internet access. 

Check Your E-mail Inbox 
 

In the left navigation bar or on the WebMail Overview page, choose 'E-mail Inbox' and 
Select the e-mail you would like to read, answer, or delete. 
 

You cannot view or modify e-mail in WebMail which you have previously downloaded with a 
local mail program. 
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Write and Send an E-mail 
 

In the left navigation bar or on the WebMail Overview page choose 'Write E-mail'. 

 
Figure 6: Write and send e-mail using WebMail. 

1. Enter the address of the person you wish to send the mail to in the "To" field. 

2. Enter additional addresses in the optional "CC" and/or the "BCC" fields. 

3. Enter the subject of the message in the "Subject" field. 

4. Enter the message in the text area named "Body Text". 

5. Attach files using "Attach Document to E-mail". 

6. Check that the required fields are filled in. 

7. Send your e-mail. 
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When attaching files, remember that outgoing e-mail messages may not exceed 5 MB. 1&1 
WebMail can only receive e-mail messages with attachments of 1 MB or smaller in size. If you 
would like to receive e-mail with larger attachments, we recommend you use an e-mail client, 
such as Microsoft® Outlook Express®. 

Send an E-mail to Multiple Addresses 
 

To send e-mail to multiple addresses simultaneously type the addresses in the "To" field. 
Make sure to separate them with a comma or a semicolon (it does not matter whether you 
leave a blank space or not). For example, To: support@domain-of-your-choice.com, 
info@domain-of-your-choice.com. 

E-mail Signature in WebMail 
 

To set up or change a signature, in the left navigation bar on the WebMail Overview page 
choose 'Change Signature'. Insert your signature in the text field. 

WebMail Address Book 
 

To manage the address book in WebMail select 'Manage Address Book' from the left 
navigation bar on the WebMail Overview page. In the "New Contact" window enter the 
person's name and in the "E-mail Address" field enter the e-mail address. Repeat the 
process for each address you would like to add. 
 

It is not possible to import the addresses from local mail programs into WebMail. Addresses 
you would like to include have to be added manually. 

Leave WebMail 
 

For security reasons, always click on 'Log out' to exit your WebMail session. 
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2.10 Activate Your E-mail for External Domain Names 
 

Set your MX records to 1&1 to use the 1&1 mail system with an external domain name.  

On the Domain Overview page select the external domain from the table by clicking on the 
box beside it. Then, on the table's toolbar click on 'DNS' > 'Edit DNS Settings'. To point 
your MX records to 1&1, select "default mail server" and save your settings. 

If you have set up an external domain name via DNS pointing ( Add On an External 
Domain (Point DNS to 1&1) page 9), we recommend keeping your old mail servers for a 
transition phase during which you can set up the same e-mail address in the 1&1 Control 
Panel. For more information see Troubleshooting: DNS Settings page 15.  

Troubleshooting: E-mail 
 

Cannot Send/Receive E-mail 

When setting up a local mail client, use the mailbox name (an "m" followed by an eight-digit 
number) and the password you created when setting up the mailbox in the 1&1 Control 
Panel. Do not use your 1&1 customer ID and Control Panel password. To retrieve this login 
information, log on to the Control Panel, select the package with the e-mail address in it, and 
then go to 'E-mail'. Select the address from the table and then click on 'Settings' found on 
the toolbar. If you do not remember the password, click on 'Edit', enter a new password and 
make a note of it. 

E-mail Program Cannot Connect to 1&1 Mail Server 

If you try to send e-mail and your local e-mail program returns the error message "Can't 
connect to mail server" your Internet Service Provider (ISP) may be blocking connections to 
mail servers other than their own. In this case, you should contact your ISP and find out if they 
are blocking port 25 access to servers. 

Should your ISP refuse to lift this restriction on your account, you will have to use your ISP's 
mail server for sending e-mail and the 1&1 mail server for receiving e-mail. 
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3 FTP, Web Space, and Access 
  

3.1 FTP Login Data • 3.2 Connecting to Your Web Space Using WISE FTP® • 3.3 
Connecting to Your Web Space Using WS_FTP® • 3.4 Transfer Website Data to 
Your Web Space Using a Browser • 3.5 Protected Directories  
File Transfer Protocol (FTP) is one of the most commonly used Internet services for 
transferring data. FTP is a client server protocol which enables you to transfer files between 
your computer and another computer. 
 

When you manage your web content and upload content files to your web space, first decide 
whether you would like to use an FTP program or FrontPage® Server Extensions (FPSE). If you 
decide to use FPSE you first have to activate them in the 1&1 Control Panel (  FrontPage® 
Server Extensions page 16).  

 

In order to use FTP, you need to have an FTP program (sometimes called an FTP client). 
You can choose between various shareware and freeware programs (ex. WS_FTP®), or 
simply use the FTP program called WISE FTP® included in your 1&1 package. WISE FTP® is 
available in the 'Downloads' section of your Control Panel and on the Website Tuner CD 
you received when you ordered your package. 
 

Once you have activated FPSE you cannot use any FTP programs and vice versa. In case of 
doubt, check your FPSE settings, and if needed, activate/deactivate FPSE prior to proceeding 
with your web space administration. 

 

Using FTP allows you to transfer your website from your computer to your web space 
directory on the 1&1 servers, making your website available to other Internet users. You 
can also use an FTP program to show directory content, create directories, or delete files. 

You can use various methods to get to your website onto your web space. However you 
will always need the following FTP access information: 

 Your host name 
Your FTP host name is your domain name. If your domain name is http://www.domain-
of-your-choice.com, your FTP host name will be domain-of-your-choice.com 

 Your FTP user name found in the 1&1 Control Panel, (  below) 
 Your FTP password found in the 1&1 Control Panel, (  below) 

Most web-authoring programs have an FTP program built into them. If you have such a 
program (ex. Dreamweaver®, NetObjects Fusion®, etc.) you can usually get your website 
online by selecting to publish it and entering the host name, your FTP user name and your 
FTP password when prompted. 

However, if no FTP program is built in, you can use a separate program such as WISE FTP®, 
WS_FTP®, CuteFTP®, etc. Alternatively, you can use any Internet browser to access your FTP 
directory. 
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3.1 FTP Login Data 
 

Your FTP account makes content upload and management possible.  

Similar to your e-mail account, your FTP account uses a password to prevent unauthorized 
access. To find your FTP login information go to 'Web Space/Access' > 'FTP Account'. 
On the FTP Account page click on the 'Change' button next to the FTP account's user 
name. On the next page shows your FTP user name and password. There you can make 
changes to your user data. Write down this information for reference. To delete an FTP 
account, click on 'Delete' next to it on the FTP Account page. 
 

The FTP main user cannot be deleted. You can only change the password. 

 

It is possible to set up more than one FTP accounts. However, you can only assign one 
directory per FTP user. All subdirectories of this directory can then be accessed by that user. 
So, if you assign the root directory ("/."), then the FTP user can access all files and 
directories in your web space. 

3.2 Connecting to Your Web Space Using WISE FTP® 
 

Set up WISE FTP® to connect to your web space. Download WISE FTP® from the 
'Downloads' section of the Control Panel, or install it using the 1&1 Software CD, which 
you may have received when you ordered your package. 

Prior to creating a set connection via WISE FTP®, please ensure you have your host name, 
FTP user name and password available (  above). 

Load your WISE FTP® program, got to 'File' > 'Connect To'. In the window that opens, 
click on the 'New Site' button to proceed. 

Follow the instructions and enter the required information during the setup process in the 
following order: 

1. Enter a directory name of your choice (ex. My Domain) 

2. Enter your host name (ex. domain-of-your-choice.com) 

3. Enter your user ID (the user name) to be found in the 1&1 Control Panel (  above) 

4. Enter your password found in the 1&1 Control Panel (  above). Decide whether you 
would like the password to be remembered. 

5. Mark the "Passive" box. This activates passive transfer which is necessary to enable firewall 
and DSL or cable compatibility. 

Now you are ready to transfer files between your local computer and your web space. 
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As a 1&1 customer, you may automatically import your FTP account login data as a simple 
alternative to the manual setup. To connect to your 1&1 web space, select 'File' > 'Connect 
To'. In the "Site Manager" window click on 'FTP Import' and in the Import FTP Accounts 
window insert your 1&1 access data and specify the file you would like to import. 

3.3 Connecting to Your Web Space Using WS_FTP® (Pro) 
 

WS_FTP® (Pro) is a Windows® based program that will let you transfer files from your 
computer to another server, browse the contents of that server, delete files from the server 
and transfer them back to your computer again if necessary. It also enables you to access 
other free FTP ports, and download a host of free trial and shareware software (pre-
configured FTP sites are available with this FTP client, please ensure that the content you 
are downloading is coming from a reliable source). Provided, the target Internet address is 
valid and contains a valid FTP server program, WS_FTP® (Pro) can connect to it. 

Prior to creating a set connection via WS_FTP® (Pro), please ensure you have your host 
name, FTP user name and FTP password available (  above). 

Open WS_FTP® and choose 'New' to set up a new FTP site. With a configured FTP site you 
can revisit you web space without having reenter the connection data. Enter the required 
information during the setup process in the following order: 

1. Create an FTP site and name it (ex. My Domain). 

2. Enter your host name (ex. domain-of-your-choice.com). 

3. Enter your user ID (the user name) found in the 1&1 Control Panel (  above). 

4. Enter your password found in the 1&1 Control Panel (  above). Choose to have your 
password remembered. 

 

You should save the password for automatic login only if your computer is secure from 
unauthorized access by others. 

 

When you are finished setting up the new FTP site, go to 'Properties' and under 
'Advanced' activate "Passive transfers". This is necessary to enable firewall and DSL or 
cable compatibility. Now you are ready to transfer files back and forth between your local 
computer and your web space. 

Connect to Your Web Space and Transfer Your Website Using WS_FTP® (Pro) 
 

Choose your 1&1 FTP site from the list of FTP sites and click on 'OK'. WS_FTP® (Pro) will 
connect to your web space. 

On left side of the WS_FTP® window you see your local directory, where your files are 
placed. On the right side of the WS_FTP® window you see your 1&1 web space, Navigate 
through your local directory structure and highlight the files you would like to transfer. 
Next use the arrows in the center of the WS_FTP® window to transfer the files. 
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Once the file has been transferred it appears on the right side of the WS_FTP® (Pro) 
window. It is now on your web space. 
 

The small box at the bottom of the window shows the connection status. Connection 
problems are reported there. Please see Troubleshooting: File Transfer with WS_FTP® (Pro)  
page 36 for possible reasons. 

 

Create a Directory in Your Web Space Using WS_FTP® (Pro) 
Connect to your web space (choose your 1&1 FTP site from the list of FTP sites and click on 
'OK'. WS_FTP® will connect to your web space). On the right side of the WS_FTP® (Pro) 
window choose 'Mkdir' and enter the name of the new directory (folder) you want to set 
up on your web space. 

Troubleshooting: File Transfer with WS_FTP® (Pro)  
 

Connection Problems 

Most failures of connection are caused by small typos of the user name, password, or host 
address. Checking that these are correct will usually resolve the matter. 

When loading WS_FTP® (Pro), the small grey box at the bottom of the WS_FTP® (Pro) window 
shows the status of the FTP connection. Any problems in connecting to your web space will 
be shown here. Below shows the most likely causes of any error messages received: 

If you receive the message "Logon failure, so quitting", then FTP access to that web space has 
been blocked. This is usually due to a billing matter or an error in the account's permission 
settings. Please contact support@1and1.com to have the matter resolved. 

The error message "!530 Login incorrect" is more common. This is due to an invalid FTP user 
name/password being entered by mistake. The user name/password is case sensitive and will 
affect the connection if entered incorrectly, if you go back to the accounts page in the 
configuration menu and copy/paste the details there should be no problem in accessing your 
web space. 

The error message "!Connection failed domain-of-your.choice.com. Can't get domain-of-
your.choice.com host entry" is received only when you have entered an incorrect host name 
in the setup of this connection. So that specific web space cannot be accessed. 

 

mailto:support@1and1.com
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3.4 Transfer Website Data to Your Web Space Using a Browser 
  

As an alternative to FTP programs, you can upload files from your computer to your 1&1 
web space using any Internet browser, such as Internet Explorer®. 

Prior to creating connection, please ensure you have your host name, FTP user name, and 
password available (  above). 

In order to establish an FTP connection successfully, activate passive FTP transfer first. 

Open Internet Explorer® and choose 'Tools' > 'Internet Options' the menu. Select the 
'Advanced' tab. Next, check "Use Passive FTP". This is necessary to enable firewall and 
DSL or cable compatibility. Now you are ready to transfer files back and forth between 
your local computer and your web space. 

To set up an FTP connection type ftp://username@domain-of-your-choice.com in the 
address bar of your browser. Next, type in your user name and the password when 
prompted. 

This will give you full access to your 1&1 web space to upload files from any computer that 
is connected to the Internet. 

3.5 Protected Directories 
  

Protected directories are your website directories that cannot be viewed without a valid 
user name and password. You can restrict access to those files to selected user groups (ex. 
customers) for a nonpublic area of your website. 

You can protect directories by clicking on 'Web Space/Access' > 'Protected Directories' 
in the left navigation bar of the Control Panel. The overview lists existing protected 
directories with the assigned user name. Use 'Edit' to create a protected directory or to 
change the settings of an existing one. Click 'Create', and follow the instructions. Use the 
'Delete' button to delete a user. This makes your directory unprotected. 

The main user cannot be edited or deleted. 

 

 

You can create new directories with your FTP program (WISE FTP® for example).  

To create a new directory, connect to the FTP server (  Connecting to Your Web Space Using 
WISE FTP® page 34) and choose the folder to place the new directory in. Then select 
'Commands' > 'New directory' in the WISE FTP® window and name the new directory. 
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4 Applications 
4.1 WebsiteCreator •4.2 WebStatistics • 4.3 WebElements • 4.4 WebDatabase • 4.5 
Newsletter Tool • 4.6 in2site Live Dialogue • 4.7 Basic CGIs • 4.8 MS SQL 
Administration • 4.9 Webfiles 
You can use the many useful applications included in your package to help set up your 
website, to have more functionality and features, and to evaluate your website. 

4.1 WebsiteCreator 
 

WebsiteCreator (WSC) is a user-friendly, server-side Content Management System (CMS). 
WSC includes more than 100 professionally designed templates. In addition to the 
templates, you can use the editor to insert content and images.  

WebsiteCreator (WSC) gives you fast and impressive results and can be upgraded easily if 
needed. Since it is reachable through your 1&1 Control Panel and you do not need to 
install any software to use it, you can use WSC from anywhere on the Internet without an 
additional user name or password. Plus, you do not need any HTML programming skills to 
use it.  

Examples of WSC Websites 
 

 
Figure 7: A business website created and maintained with WebsiteCreator. 
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Figure 8: Use the WebsiteCreator for making your own informational site. 

Whether for business or private website authoring, WSC gives you fast and good-looking 
results. 

Your website is automatically saved while you are working on it. Each time you exit 
WebsiteCreator, the changes you have made are saved automatically. 

Launch WebsiteCreator in the 1&1 Control Panel 

System Requirements 
 

WebsiteCreator (WSC) requires Internet Explorer® 6 or higher, Netscape® 7.1 or higher, or 
Mozilla® 1.4 in order to function smoothly. You can download a current version of Internet 
Explorer® or Netscape® for free under the 'Downloads' section in the 1&1 Control Panel. 
For Mac® users we recommend to use a latest generation Mozilla® version for MacOS® to 
get full WSC functionality. 
 

When using Netscape® or Mozilla®, make sure that pop-up windows are not blocked for the 
server perfora.net. Go to 'Edit' > 'Preferences'. Open 'Privacy & Security' > 'Popup 
Windows' and check if pop-up windows are blocked. You can keep the blocker on as long 
as you make an exception for perfora.net. Click on 'Allowed Site' and add this address. 

Google® bar users need to turn off the Google® bar pop-up blocker to use WSC. 
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Set Up WebsiteCreator 
To reach the WebsiteCreator (WSC) overview page, click on 'Applications' > 
'WebsiteCreator' in the Package Administration area of the Control Panel. The first time 
you use WSC, click on 'Assign Domain' in the list shown on the page. 
 

Make sure that you have not enabled FrontPage® Server Extensions, otherwise 
WebsiteCreator cannot be used. 

Assign WebsiteCreator to a Domain 
 

You can assign WebsiteCreator (WSC) to as many domains as you like, but you can only 
create one website per WSC. This domain points to a WSC directory, which is 
automatically created. The domain you assign to this WSC directory is the WSC Root 
domain. Click on 'Assign Domain' to select which domain you would like to have as the 
root domain.  
 

The WSC Root domain's settings can only have limited changes made to it. If you would like 
to change settings, such as the DNS settings, please unassign WSC to the domain before 
doing so. None of your website's content will be lost. 

Launch WebsiteCreator 
 

You can only launch WebsiteCreator (WSC) via the Control Panel. This allows you to use 
the program without having to remember an additional user name or password. 

Log on to your 1&1 Control Panel and select your package. Next go to 'Applications' > 
'WebsiteCreator' and launch the WSC domain you would like to work on by clicking on 
the WebsiteCreator ID. 

The first time you launch WSC, a welcome window asks if you would like to set up a 
personal or a business website. Based on your choice, it creates a basic website structure 
that you can change or add to.  

Type the name you would like to call your website, and proceed to WSC. Next, the 5 Easy 
Step Wizard will guide you through a quick setup of your website (for a step-by-step guide 
through this wizard, please consult our Web Hosting Easy Setup Guide). If you prefer to 
take time to set up your website, close the wizard, and have a look at the different menu 
items in the WSC. 

The maximum number of pages included in your WSC varies depending on the 1&1 
package you ordered. You can order WebsiteCreator Plus (WSC Plus), with unlimited 
pages, for another website with another domain. Or you can upgrade your current copy to 
WSC Plus. You get a free basic WSC when you do. 
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Using WebsiteCreator  
 

 
Figure 9: WebsiteCreator has a wizard to help you create a website and it is easy to update 

information, too. 

On the WebsiteCreator (WSC) main page, you can choose to add new pages, edit the 
basic structure of your pages, see a preview of your website, change the settings, and 
publish your website. WSC is easy to navigate using the left navigation bar after selecting 
menu items. 

Manage Pages in WebsiteCreator  
 
 

 Get Started: Create Web Pages 
To create new pages for your website, on the WebsiteCreator (WSC) main page go to 
'Manage Pages' > 'Add new page'. 

 Edit Web Pages 

To edit pages of your website, on the WSC main page go to 'Manage Pages' > 'Edit 
page content'. Go to 'Open editor to manage page content' to use an editor for 
writing or editing the content of your existing pages. 

 Rename Web Pages 

To change page names of your website, on the WSC main page go to 'Manage Pages' 
> 'Rename pages' to rename one or more web pages. 
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 View and Modify the Website's Structure 
You can modify the website's structure in different ways, by moving pages from one 
place to another, or by deleting pages completely. 

To move pages within your website, go to 'Manage Pages' > 'Move pages' on the 
WSC main page, to re-structure your website by changing the position of your web 
pages. 

To delete pages from your website, go to 'Manage Pages' > 'Delete pages' on the 
WSC main page. 

To view the suggested page structure, on the WSC main page go to 'Manage Pages' > 
'Show suggested page structure'. Doing this is useful, especially if you are not sure 
which pages to include on your website. Choose from various pre-defined categories for 
individual pages or choose the complete structure for your web pages from pre-defined 
selection. 

Manage Layout in WebsiteCreator (WSC) 
 

Select a Website Layout 
 

 Modify Homepage Title 

To modify the title of your website, go to 'Manage Pages' > 'Change your homepage 
title' on the WebsiteCreator (WSC) main page. Enter or edit the title of your website 
here. 

 Change Website Layout 
To select one of the pre-defined layouts (templates) to create or change the layout of 
your website, go to 'Manage Pages' > 'Change layout template' on the WSC main 
page. 

 Edit Website Layout Details (Key Visuals, Text Color, Buttons, Font, Logo) 

To edit layout details, go to 'Manage Pages' > 'Edit layout details' on the WSC main 
page and select or change additional layout details for your website, such as key visual, 
text color, buttons, font or logo. 

 

Images will not be displayed correctly, if the file names contain blanks or special characters. 
Change the names and put replace blanks with underscores and delete any alphanumeric 
characters (ex. "Our last vacation.jpg" should be changed to "our_last_vacation.jpg"). 

Configure Bonus Features in WebsiteCreator (WSC) 
 

If required, add further elements to your website, such as an opening animation, a 
counter, a feedback form, a guest book, a voting survey, an online forum, or a map. Plus, 
you can determine search engine details and set a time zone for your website. 
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Some of this features are only available in WebsiteCreator Plus (  WebsiteCreator Plus (WSC 
Plus) page 45). 

 

 Setting Up a Flash Intro 

To set up a Flash intro, on the WSC main page go to 'Manage Pages' > 'Select 
opening animation'. Select a Flash animation from a list of eight pre-defined Flash 
intros as an opening screen for your website. Enter a headline and a slogan (a 
catchphrase) you would like to appear in the Flash intro to sum up your website. 

 Meta Information 
If you would like to increase the chances of people finding your website in search 
engines such as Google, you can enter special "Meta" information which many search 
engines will use to index your website. On the WSC main page, go to 'Manage Pages' 
> 'Search engine details', and enter a Meta description and Meta keywords which best 
describe the contents of your website. 

 Visitor Counter 

To include a visitor counter, go to 'Manage Pages' > 'Manage counter' on the WSC 
main page. 

 Feedback Form 

To include a feedback form, go to 'Manage Pages' > 'Manage feedback forms' on 
the WSC main page and create, edit, or delete feedback forms for your website. 

 Guest Book 

To include a guest book, go to 'Manage Pages' > 'Manage guest book' on the WSC 
main page. Add a guest book to your website and manage (show or delete) its entries. 

 Voting Survey in WSC Plus  

To include a voting survey, go to 'Manage Pages' > 'Manage voting' on the WSC Plus 
main page. Create, activate/deactivate or delete voting surveys. 

 Forum in WSC Plus  

To include a forum, go to 'Manage Pages' > 'Manage forums' on the WSC Plus main 
page and create new forums, or edit or delete existing forums and their contributions 
(posts). 

 Location Map in WSC Plus  

To set up a map, go to 'Manage Pages' > 'Set up map' on the WSC Plus main page. 
Create a map showing how to reach your address. 

 Time Zone 
You can set a time zone for your website. To set a time zone, on the WSC main page, 
go to 'Manage Pages' > 'Set time zone'. Set the time zone corresponding to your 
location. 
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Photo Albums in WebsiteCreator Plus  
 

If you would like to include one or more photo albums on your website, WebsiteCreator 
Plus (WSC Plus) offers you this terrific possibility. 

Create a Photo Album 

To create a photo album, on the WSC Plus main page, go to 'Manage Pages' > 'Create 
new photo album'. 
 

Edit a Photo Album 

To edit a photo album, on the WSC Plus main page, go to 'Manage Pages' > 'Edit photo 
album'. Insert new images in your photo album and edit the images. 

Delete a Photo Album 

To delete one or more photo albums, on the WSC Plus main page, go to 'Manage Pages' 
> 'Delete photo albums'. 
 

You cannot delete the sample album via the 'Manage pages' menu item. To delete the 
sample album go to the menu item 'Photo album' and follow the instructions. 

Preview Your Website 
 

If you would like to see a preview of your website before you publish it, go to 'Show 
preview'. You will find this menu item on the WSC main page, as well as in the left 
navigation bar. 

Publish Your Website 
 

When you are finished setting up your website, go to 'Publish content'. You will find 
this menu item on the WSC main page, as well as in the left navigation bar. Your 
website and the web pages will instantly go online. 

 

If you experience problems transferring images to your web space, you may have already used 
up your available web space. There will be no space left for images. Check your web space 
and consider whether you could delete some files to free up space. Or, you can also upgrade 
your package to get not only more web space, but more features as well. 
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WebsiteCreator Plus (WSC Plus) 
 

The number of pages included in your WebsiteCreator (WSC) depends on the package you 
have chosen. If you find you need more pages, you can upgrade your WSC. When you are 
on the WebsiteCreator Overview page in the 1&1 Control Panel, click on the 'Upgrade' 
button. This will upgrade the current basic WSC. 

If you decide to upgrade your WSC account to WebsiteCreator Plus (WSC Plus), the pages 
you already have created will be saved. You will find them again in the WSC Plus and can 
continue working on them. 

Alternatively, you can purchase additional copies of WSC Plus to create another website. In 
this case, either click on 'Order' in your Control Panel and choose WSC Plus, or, if you are 
on the WebsiteCreator Overview page, click on 'Order' and follow the instructions. A new 
copy is completely separate from existing WSC accounts and does not allow you to use 
any existing WSC pages from another WSC module. 
 

If you upgrade your basic version of the WebsiteCreator included in your package, then a 
basic WSC account is created for you, which you can use at no extra cost. 

 

Apart from an unlimited number of pages, WSC Plus offers you Photo albums, Voting 
survey, Forum, and a Location Map. 

Troubleshooting: Using WebsiteCreator  
 

Display Problems when Editing WebsiteCreator (WSC) Accounts Sequentially 

With several WebsiteCreator (WSC) accounts sometimes when launching a new WSC account 
after editing another WSC account that the content of the first account is displayed on your 
screen. Since the previous data was saved in your browser's cache it is then shown to you. To 
avoid this, set the cache settings of your browser to a lower value.  

In Internet Explorer®, go to 'Tools' > 'Internet Options' > 'General'. In the section 
"Temporary Internet files folder" go to 'Settings…'. Under "Check for newer versions of 
stored pages" check the box beside "Every visit to the page". Also set the "Amount of disk 
space to use" controller to a lower value. After changing the settings, restart Internet 
Explorer®. Additionally, after using the first WSC account close the browser and restart it to 
make sure that the cache is empty. You should now see the content of the other WSC on 
your screen. 
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Timeout Message/Empty Window 

With each launch of WebsiteCreator (WSC), a session ID is created in the background which is 
valid for an hour. If you relaunch the WSC shortly afterwards, this session is stored in the 
browser cache (depending on the browser cache configuration there could be several saved 
sessions) and the browser tries to reload the WSC session from the cache. Thereby timeout 
problems occur since the browser attempts to access an expired session. 

Set the browser cache as low as possible. In Internet Explorer®, go to 'Tools' > 'Internet 
Options' > 'General'. In the section "Temporary Internet files folder" go to 'Settings…'. 
Under "Check for newer versions of stored pages" check the box beside "Every visit to the 
page". Also set the "Amount of disk space to use" controller to a lower value. After changing 
the settings, restart Internet Explorer®. Additionally, after using WSC close the browser 
completely and restart it to make sure that the cache is empty. 

Integrate HTML Code or Banners into Your Website 

WebsiteCreator (WSC) offers a wide variety of pre-defined designs for customers without 
HTML skills. Therefore, it is not possible to integrate additional HTML code, insert further 
frames etc. in WSC websites. Instead, we recommend creating and managing your website 
using other design applications (ex. NetObjects Fusion®, Dreamweaver®, or FrontPage®). 

Insert a Link into Your Website 

Go to 'Manage Pages' > 'Edit Page Content' > 'Open editor to manage page content' 
in WebsiteCreator (WSC). This will open the WSC editor. Enter the link or a reference text you 
would like it to appear in your content. Highlight it with your mouse. Next, go to 'Edit' > 
'Link' and enter the link when prompted. Choose "External" since the file or image is part of 
your web space. 

Include Images for Download into Your Website 

Go to 'Manage Pages' > 'Edit Page Content' > 'Open editor to manage page content' 
in WebsiteCreator (WSC). This will open the WSC editor. Click on the point where you would 
like the image to appear in your content. Next, go to 'Image' > 'Insert Image'. This will open 
a dialog window, where you can upload your image, and move it into a directory. Next 
choose an image that you want to include (click on it) and then choose "Insert image in text". 
The image will be included in your content. 

Integrate Music Files into Your Pages 

It is not possible to insert audio files (MIDI or similar) into individual pages. 
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Remove WebsiteCreator (WSC) and Install Your Own Pages 

If you find that your needs outgrow WebsiteCreator (WSC), you can disable the program. 
When logged on to your Control Panel, go to 'Applications' > 'WebsiteCreator'. Then click 
on 'Assign Domain' beside the WSC domain you would like to disable. On the following 
page, select "None Unassign (WSC)" from the drop-down menu labelled "Assigned domain". 
Click on 'Submit' to save your changes.  

Next, determine a new home directory (ex. the main directory "/.") for the domain that you 
just disabled WSC from. You can do this under 'Domains' on the Domain Overview page. 
Select the domain you would like to work on and then click on destination in the toolbar. It 
will take up to an hour for the changes to take effect. 

Your WSC generated website will go offline and you will no longer be able to access or edit 
it. However, if you decide to re-assign your domain to WSC, your WSC website will be 
restored. 

Error Message is Displayed at Launch or During Editing 

When error messages such as "A script or runtime error occurred" or "This feature or method 
is not supported by the object" are displayed, proceed as follows:  

On your Internet browser go to 'Tools' > 'Internet Options…'  

Select the 'Advanced' tab  

From this tab check the option "Disable script debugging" 

Image Editing with WebsiteCreator (WSC) 

You can edit images after you have uploaded them in the WSC media database. Upon the 
upload, in the media database choose the image file to work on. Edit, resize, crop, filter and 
save your images in the image editor as needed. You can also reach the media database 
when you are in the WSC editor (  Manage Pages in WebsiteCreator  page 41). 

Editing WebsiteCreator (WSC) Pages Offline Using a Different Editor 

WSC is an application designed to allow user access to a system, independent of the users' 
location. Pursuant to the license terms and conditions it is prohibited to download pages 
created using WSC. 
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4.2 WebStatistics 
 

1&1 WebStatistics is a professional analysis tool that provides graphical analyses of your 
website. Using WebStatistics, you can analyze the behavior of your visitors with regard to 
the following aspects: 

 How many visitors come to your website (number of visits)? 
 How often do they visit the various pages successfully (page impressions)? 
 How many pages does the individual visitor view? 
 Which pages do the visitors go to and when? 
 Which pages are visited most often? 

 

Also, you can use WebStatistics to trace the ways in which your visitors find your website, 
find out what software they are using to view your website, and where they are located. 
Also, you can check which pages of your website did not load successfully. 

When you set up your website — whether for private or professional use — you defined 
clearly which target group you were designing it for and what its objective should be. 
Once you have published your website, it is important to find out if the way visitors 
respond to it, really corresponds with your initial goals. 

Regularly looking at your website statistics gives you important insight into how well your 
website's performance compares to the goals you set. Use the information to optimize 
your site to be better received by your target viewing group. 1&1 WebStatistics shows 
which parts of your web presence work well and where there is room for improvement. It 
analyzes your website’s data and presents the results in graphs and tables. 

You can set the statistical analysis for different time periods (days, weeks, months and 
years). 

 
Figure 10: WebStatistics can show different time periods for precise analysis of data. 

Depending on what is being evaluated, the data can be presented as a pie chart or a bar 
graph. Along with each graph, you will be able to see the data in a table. 
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Figure 11: WebStatistics results for one week shown in a pie chart. 

 
Figure 12: WebStatistics results for one week shown in a bar graph. 

 
Figure 13: WebStatistics results for one week shown in a table. 
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Once you know the pattern and interests of your visitors, you can fine tune your website. If 
you find that visitors ignore information provided in deeply embedded links, you can 
consider either moving this information to a more prominent place or changing the 
navigation structure altogether. Since you can call up 1&1 WebStatistics as often as you 
like and will receive statistical output for the last 24 hours, you can check right away if 
your changes have been successful. 

Start WebStatistics in the 1&1 Control Panel 
 

On the Package Administration page, go to 'Applications' > 'WebStatistics' in the 
1&1 Control Panel and launch WebStatistics in a new browser window. 

Basic Settings 
 

Prior to using 1&1 WebStatistics, you can define some default settings for the initial report 
shown in each statistical evaluation. You can set the domain name, the time frame to be 
analyzed, and several display options. 
 

You cannot use WebStatistics to analyze domains assigned to WebsiteCreator. 

 

 Set a domain name 
Select if you would like to first see a report on an individual domain, a domain set, or all 
domains using the drop-down menu. 

 Set a period 
Decide if you would like to see the data analyzed by day, week, month, or year. 

 Set a filter display 
Specify whether the time period selection should be done using a simple or an advanced 
view. 

 Set the page content display 
Show or hide charts, tables, and explanations on the report pages. 

 Set table entries display 
Determine the number of entries to be shown in the table overview. 

Statistical Evaluations 
 

Most of the evaluations are based on the concept of "page impressions" and "unique 
visits". A page impression is a successful page view of fully loaded web page. A unique 
visit is the complete process of calling up a whole web page. Calling up single images, 
files, or damaged web pages does not count as a unique visit. A unique visitor is a user 
who visits your website, calls up more than one web page. During a unique visit, viewing 
individual web pages cannot take longer than 30 minutes. 

The menu item 'Statistical Evaluations' provides in-depth analyses of the data collected, 
presented through clear visuals and informative tables. The first results you see in any 
analysis are based on your default settings. 
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Regardless to the default settings you have made in WebStatistics under 'Basic Settings', 
you can still view results from all domains, individual domains, or various time periods for 
the individual analysis pages by adjusting the settings on these pages. 

Printer-friendly graphs and charts open in a new window, when you click on the printer 
icon on each page. 

In the graphs displayed, the blue bars show results per selected time periods. To find the 
exact value, position your cursor directly on the bar. When viewing the statistics for 
referrers, geography, technology and pages, you can also see the results in a pie chart by 
choosing 'Show Pie Chart'. 

In the tables displayed, there may be many entries split over several pages (depending on 
the period you evaluate and the popularity of your web presence). The arrow icons allow 
you to browse backwards and forwards. You can also adjust the view with the 5, 10, 20, 
or 50 interval icons. 
 
 

All evaluations use statistical methods interpreting automatically generated log files. Due to 
technically unavoidable inaccuracies, some of the information may not be thoroughly 
acquired. For this reason, 1&1 WebStatistics cannot deliver any legally binding basis, for 
example, for settlement purposes. 

View Statistics about Your Visitors (Page Impressions, Unique Visits, Pages per Visit) 
 

Under 'Statistical Evaluations' > 'Visitors' you will see the number of viewed pages 
(page impressions), unique visits, and page views per visitor. 

To get the statistics on successful pages views (page impressions) go to 'Statistical 
Evaluations' > 'Visitors' > 'Page Views'. 

The statistics shown here will inform you about all successful page views, commonly called 
"page impressions", and the time they were made. Only fully loaded pages are counted. 
Individual images and components are not included. 

From this information you can determine how your website was used, and at which times 
it was visited (peak times). This gives you a general idea of the overall traffic generated by 
your website. You could, for example use this information to include ads or information at 
peak times and this way make sure that a majority of your visitors will see it. 

To find out how many unique visits were made to your site, go to 'Statistical 
Evaluations' > 'Visitors' > 'Unique Visits'. 

The analysis summarizes multiple page impressions of an individual visitor into unique 
visits. A visitor is counted as a "unique visitor" only when the visitor calls up more than 
one page on your website. During a unique visit, viewing individual web pages cannot take 
longer than 30 minutes.  



 

52 

Windows® Hosting Manual, 1&1 Internet Inc. 

PACKAGE ADMINISTRATION: APPLICATIONS  

 

The statistical unit "unique visitor" tells you how many "real" visitors your website 
currently attracts, and at which times. For example, if you have an informational website 
on a highly specialized topic, the history of staples, you may expect to receive limited 
attention. In this case you can still see at what time those few dedicated staple lovers 
prefer to visit your website. If you offer a lot of general information on your website, (ex. a 
lot of links to other sites, various differing topics) it could be the case that you will not 
receive a lot of unique visits either. 

It may not be your intention to receive a lot of unique visits, but if you do not receive 
enough, you may think about ways to change your website. 

To see the number of pages viewed in relation to unique visits go to 'Statistical 
Evaluations' > 'Visitors' > 'Pages per Visit'. 

These statistics determine the number of pages opened during a unique visit. Only fully 
loaded pages and unique visits are counted. This information tells you how many pages 
your visitors open per visit, and to help you adapt your Internet offerings accordingly. 

View Statistics on Referrers (Referrer URLs, Referrer Domains) 
 

Under 'Statistical Evaluations' > 'Referrer' you can find out how your visitors found 
your website by viewing the referrer data. To find out about the referrer URLs (the 
complete paths) that led your visitors to your website go to 'Statistical Evaluations' > 
'Referrer' > 'Referrer URLs'. 

 
Figure 14: Referrer URLs can tell you how visitors came to your website. 

The analysis shows the Internet pages along with the complete path from which the user 
was referred to your website. You find out who has links to your pages and can visit the 
websites yourself. This allows you to easily determine the success of ads or entries in 
search engines. 
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Figure 15: Referrer Domains can help you pinpoint what links your visitors are clicking on to get to 

your site. 

To see the domains in which your visitors found a link to your website, go to 'Statistical 
Evaluations' > 'Referrer' > 'Referrer Domains'. The statistics shows domains referring 
to your site. Subpages are summarized under the main domain. 

This allows you to recognize larger providers or directory services, for example. You may 
want to use this information for advertising purposes. 

View Statistics on Geography (Internet Providers, Top Level Domains) 
 

Under 'Statistical Evaluations' > 'Geography' you can analyze the location of your 
visitors using geography clues. To see the provider most frequently used by your visitors go 
to 'Statistical Evaluations' > 'Geography' > 'Internet Providers'. 

 
Figure 16: Internet Providers tells you how your customers access the Internet. 

This analysis shows the visitors' domains which they used to access the Internet. The 
domains used to access the Internet usually denote the visitors' Internet providers. From 
this you can see which provider your visitors use. This is either valuable background 
information or may be useful for advertising purposes. 
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To learn which countries your visitors come from by top level domain (TLD) statistics, go to 
'Statistical Evaluations' > 'Geography' > 'Top Level Domains'. 

 
Figure 17: Top Level Domains can help you see what country your visitors are in. 

The breakdown sorts the visitors' TLDs by country. Some generic domains, such as .com, 
.net, .org, .biz, and .info cannot be assigned geographically.  

You find out from which countries your visitors TLDs originate. Check whether these are 
the parts of the world you wanted to reach or whether they come from elsewhere. As a 
result, you can optimize your website for your intended target group or enhance your 
website for new target groups or both. 

View Statistics on Technology (Operating System Types and Versions, Browser Types and 
Versions) 
 

Go to 'Statistical Evaluations' > 'Technology' to find out which browser and operating 
system (OS) technology your visitors use. To see which of the major browser types your 
visitors use go to 'Statistical Evaluations' > 'Technology' > 'Browser Types'. 

 
Figure 18: Statistics about your customer's browsers can help you optimize your website. 

The statistics, sorted by type, will inform you of the browsers your customers used to view 
your website. This can help you optimize your website for a specific type of browser. 
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To get the statistics about the specific browser versions your visitors use, go to 'Statistical 
Evaluations' > 'Technology' > 'Browser Versions'. The statistics show the browser 
version used by people visiting your site. You can then fine tune the web technology of 
your website accordingly. 

To learn which family of operating system (OS) your visitors are using go to 'Statistical 
Evaluations' > 'Technology' > 'OS Types'. 

 
Figure 19: Statistics about your customer's operating systems can help you optimize your website. 

This analysis informs you of the OS your visitors use, sorted by vendor. Optimize your 
website according to the OS used if necessary.  

To see which versions of their OS your visitors have, go to 'Statistical Evaluations' > 
'Technology' > 'OS Versions'. The statistics show the OS used by people visiting your 
site, along with its OS version number. For interactive offers, you can then fine tune the 
technology of your website more precisely. 

View Statistics on the Pages of Your Website (Popular Pages, Error Pages) 
 

Under 'Statistical Evaluations' > 'Pages' you can learn exactly what your visitors look at 
and how they navigate through your website from an in-depth page impressions analysis. 
To see the most frequently requested pages of your website go to 'Statistical 
Evaluations' > 'Pages' > 'Popular Pages'. 
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Figure 20: Statistics that tell you which pages in your website your visitors visit. 

These statistics show you the pages, which are looked at most frequently, and you can see 
which pages were most popular. You can see if these pages correspond to the pages you 
intended to be of central interest and try to enhance less popular pages. 

To investigate which page requests were unsuccessful and the specific errors they had, 
click on 'Statistical Evaluations' > 'Pages' > 'Error Pages'. 

 
Figure 21: These statistics show you what pages caused the most error messages. 
The pages that could not be completely loaded by visitors are shown in this analysis. You learn which pages did not reach your visitors, and find any missing or faulty pages in this way. 



 

57 

Windows® Hosting Manual, 1&1 Internet Inc.  

PACKAGE ADMINISTRATION: APPLICATIONS 

 

Original Log Files 
 

Original log files are created daily and hold all the information received from website 
requests. These files can be viewed using your own statistical programs. 

To access the original log files via FTP, go to 'Original Log Files' in 1&1 WebStatistics. 
Retrieve your FTP access data from this page and proceed to the FTP directory. You will be 
prompted to enter the FTP access data. 

In order to be able to access the FTP directory via your Internet browser, you need to 
enable passive FTP. 

For Internet Explorer® (IE) users: Open IE and choose 'Tools' > 'Internet Options' from 
the menu. Select the 'Advanced' tab. Next, check "Use Passive FTP". This is necessary to 
enable firewall and DSL or cable compatibility. Now you are ready to transfer files back and 
forth between your local computer and your web space. 
 

The original log files are deleted after three months due to data protection regulations. 

 

Statistical evaluations cannot be performed for domains pointing to an external destination 
(domain forwarding). At least one domain in your package should be set up pointing to your 
web space. 

 

Troubleshooting: WebStatistics 
 

Current Date Not Included in the Analysis 

Currently, the analysis of WebStatistics is restricted to midnight of the previous day. 

"Hits" Are Not Counted 

In the beginning, web statistics focused on counting "hits". Calling up each single file or 
component on a web server constitutes a "hit" that can be counted. Nowadays, this 
information is no longer regarded as vital, since modern websites consist of a vast number of 
separate images, files, and components. For this reason, the "page impression", (i.e. 
successful page views of fully loaded pages) is defined as the smallest entity in 
1&1 WebStatistics. 

Total in Separate Analyses is Smaller than the Number of Page Impressions/Unique Visitors 

It may happen that page impressions or unique visitors can be recognized, but they offer no 
additional information. This happens due to wrong or fudged data generated by the browsers 
of some of your visitors. 
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Websites that Include Framesets or Flash 

At this point, WebStatistics cannot recognize complex framesets or Flash animations reliably. 

Results of an External Statistics Program differ from WebStatistics Results 

1&1 WebStatistics uses statistical methods to recognize page impressions or unique visitors. 
Since the data in the log files can be unclear, WebStatistics relies on assumptions in order to 
be able to produce results. 

4.3 WebElements 
 

1&1 WebElements makes it easy to create, customize, and integrate web forms. Your 
visitors can fill in these forms to order, contact you, register, give you feedback, and tell-a-
friend about your website.  

Normally, the person offering the form needs to program it themselves. Or they can use 
already made CGI scripts, which cannot be easily adapted without programming 
knowledge. But with WebElements, you can create any form from combining the available 
field types. You can link one form to another and even customize the buttons. You select 
the colors and fonts that appear in your form. If you do not want to start completely from 
scratch use the templates and adapt them.  

Different Types of Forms 
The following examples show how combining text and text fields can be used to make 
forms for many purposes.  

Order Form 
 

An order form is an ideal solution to sell a small range of products. 

 
Figure 22: This order form lets the customer choose the items and quantity. 
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Contact Form 
 

This form allows your visitor to send you a note. You can ask users to leave their name and 
details for you to contact them. 

 
Figure 23: A contact form created with WebElements. 

Event Registration Form 
 

If you plan an event, your website visitors can RSVP for it online. You can set up the form 
to be sent to your e-mail account. 

 
Figure 24: An event registration form created with WebElements. 
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Tell-a-friend Form 
 

Include a tell-a-friend form to generate traffic to your website. Your visitors will use the 
form to recommend your website to their friends. The sender can also write a short note 
to tell them what they found interesting. 

 
Figure 25: A tell-a-friend form created with WebElements. 
 

Voting Form 
 

Use WebElements to create web surveys. Let your visitors vote on questions. Use it for fun 
or to gain important insight –- you will receive the answers as soon as they are submitted. 

 
Figure 26: A survey created with WebElements. 
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Request Information Form 
 

Your visitors may have some questions they would like to ask you. A request information 
form enables them to ask you questions on specified topics and provide you with the 
contact information to reply to. 

 
Figure 27: A request information form created with WebElements. 
 

How to Use WebElements in the 1&1 Control Panel 
 

In the 1&1 Control Panel, go to 'Applications' > 'WebElements' in the left navigation 
bar. Launch WebElements in a new window. If you are not sure if WebElements is included 
in your package, please check your package under our website http://1and1.com. If it is 
not included in your current package then you can upgrade your package using the 
Control Panel to a package that contains WebElements. 

Set Up a New Form 
 

In WebElements, go to 'New Form' and type in any name you would like for the form 
(this name is for your use only and will not be seen by your website's visitors). Then choose 
from the drop-down menu whether to create a form from scratch or select a template you 
can use as a basis for a new form. The form will be created and can be found under 'Form 
Overview'. 

http://1and1.com/
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Customize an Existing Form 
 

Go to 'Form Overview' in WebElements. Go through the subsequent menu items in the 
left navigation bar to customize the new form or template you have set up. The order of  
Prior to editing, on each subsequent menu page make sure to choose the form you would 
like to work on from the drop-down menu. 

Adjust the following aspects according to your needs: under 'Form Overview' > 'Field 
Setup' use the  icon beside each listed field to edit it. The text used to label each field is 
called the "field name". This will appear to the left of each field. Choose from the 
available "field types" described below: 

 Input field 
Provide a space for the visitor to fill in information. Further define the type of 
information you wish to receive by limiting the valid entities. By choosing "Digits only", 
your input field will only accept numbers. You can also have the input field be set up 
with the function of e-mail sender or recipient. That means only e-mail addresses can be 
entered in this field. 

 

An e-mail content input area must also be in the completed form in order to use the 
sender/recipient functions. 

 

 Image 
Integrates an image with an existing URL (web address) into your form. 

 HTML 
Creates an area in the form where you can use HTML code. To format text, bold for 
example, you can add the HTML tags <b></b> around the word you would like to 
appear bolded. For example, the sentence "1&1 offers the best in Web Hosting." coded 
with HTML "1&1 offers the <b>best</b> in Web Hosting." would appear as "1&1 offers 
the best in Web Hosting." when it is shown online in your form. 

 

The field name assigned to an HTML field will only be shown in the overview; the name will 
not be seen in the form. The HTML field is for text that cannot be changed by your visitors. 

 

 Input area 
Select "Input area" to create a larger space for your visitors' messages. This must be 
present and set to e-mail content in order to have e-mail sender and recipient fields in 
your form. 

 Selection 
Set "Selection" fields to let your visitors choose from predefined lists. The selection 
method can be a multiple selection (checkboxes), choose one selection (radio buttons), 
or a list selection (a drop-down menu). 
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Under 'Form Overview' > 'Button Setup' choose which buttons to use for your form or 
which to leave out. Additionally, you can specify the labels of each button. 

Use buttons to perform the following operations: 

 'Delete' 
All data entered into form fields will be deleted to allow new entries. 

 'Cancel' 
The form data will not be submitted. The operation is cancelled and the page entered in 
the "Forwarding" field is shown. 

 'Back' 
With this button the user can go back to the previous form. 

 'Next' 
With this button the user can to the next form selected on the drop-down menu. 

 'Submit' 
The entered form data is sent and the page specified in the "Forwarding" field shown. 
You can optionally set receipt confirmation and e-mail notification. 

Under 'Form Overview' > 'Design Setup' choose which design to use for your form. 
Click on the  icon to get more design options and edit the design. Look at and choose a 
predefined color scheme to apply to your form. The pixel size refers to the size of the form. 

View or Delete Entries of an Existing Form 
 

Under 'Form Overview' > 'Entries Overview' you can find your visitor's entries, which 
they created when using the form on your website. You can see the feedback from 
active forms and delete individual entries one at a time, or you can delete them all at 
once. 

Show Statistics 
 

Under 'Form Overview' > 'Show Statistics' shows the statistics from polls and surveys 
that you have created. 

Integrate a Form into Your Website 
 

Under 'Form Overview' > 'Integrate Form' you can integrate or build your form into 
your website with the link provided. 

1. Using an HTML editor (ex., NetObjects Fusion®) open the web page you would like to place 
the link in. A selection of such tools can be found in the 'Downloads' section of the 
1&1 Control Panel. 

2. To copy the link, select it with your mouse by clicking and dragging while holding down 
the left mouse button. Right click the marked section and select 'Copy'; the link is now on 
the clipboard. 
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3. Using the HTML editor, insert the link by right clicking in the place you would like to insert 
it. Select 'Paste'. The following example shows how to insert the link and a reference text, 
for example "Go to the form": 

4. <a href="Enter the link here."> Go to the form. </a> 

5. Save the file and upload it to your website. The link to the form is now active and can be 
clicked on by people visiting your site. 

 

Delete a Form 

Under 'Form Overview' use the  icon beside each listed form to delete it. 

4.4 WebDatabase 
 

1&1 WebDatabase is a collection of templates that you can set up, customize, maintain 
and evaluate your own professional databases.  

If you want to present large amounts of up-to-date information on the Internet, you may 
want to use a database on your website. For example, if you have a number of links to 
share, an address book, a list of activities, or would like to swap recipes. You can define 
your own structure for the database easily and without programming skills by using 
WebDatabase. With the help of templates, the design of your database is yours to select. 
 

A database organizes and stores large amounts of data, which can be easily searched for and 
retrieved.  
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Database Examples 
 

Recipe Database 
 

Use the recipe database on your website to share your favorite recipes with your visitors 
and encourage them to publish their favorites. 

 
Figure 28: A WebDatabase database that is used to 

exchange recipes. 

News Database 
 

Include this database to share the latest product news, press releases, events, or website 
news with your readers. 

 
Figure 29: A WebDatabase database that is used for posting news. 
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Calendar Database 
 

This is a useful tool to put on your website if you would like to keep track of the 
appointments with your customers, friends and family, and provide them with a contact 
point to keep track of their appointments. It may be useful to put this database in a non-
public area. 

 
Figure 30: A WebDatabase database that is used for coordinating schedules. 

Link List 
 

Give your visitors the opportunity to share with you the best links on a topic, product, or 
service. 

 
Figure 31: A WebDatabase database that is used for presenting links. 
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How to Use WebDatabase in the 1&1 Control Panel 
 

In the 1&1 Control Panel, go to 'Applications' > 'WebDatabase' in the left navigation 
bar. Launch WebDatabase in a new window. If you are not sure if WebDatabase is 
included in your 1&1 package, please check your package at http://1and1.com. If it is not 
included in your current package, then you can upgrade your package in the Control Panel 
to a package that contains WebDatabase. 
 

You cannot insert WebDatabase forms into websites which have been designed with 
WebsiteCreator. 

Set Up a New Database 
 

In WebDatabase, go to 'New Database' and type in any name you would like for the 
form (this name is for your use only and will not be seen by your website's visitors). Then 
choose from the drop-down menu whether to create a database from scratch or select a 
template that you can use as a basis for a database you would like to create. The database 
will be created and can be found under 'Database Overview'. 

Customize an Existing Database 
 

Go to 'Database Overview' in WebDatabase to check if your new database has been set 
up. Go through the menu items in the left navigation bar to customize the new form or 
template you have set up. On each menu page, make sure to choose the database you 
would like to work on from the drop-down menu, prior to editing, 

Adjust the following aspects according to your needs: under 'Database Overview' > 
'Field Setup' use the  icon to edit a field. The text used to label each field is called the 
"field name". This will appear to the left of each field. Next, choose from the available 
"field types" described below: 

 Input field 
These provide space for the visitor to fill in information. You can control the type of 
information you wish to receive by limiting the valid entries. For example, by choosing 
'Digits only', your input field will only accept numbers. This is useful for a telephone 
number field. 

 Image 
Integrates an image with an existing URL (web address) into your database. 

 Input area 
Select "Input area" to create a larger space for your visitors' messages. 

 Selection 
Set "Selection" fields to let your visitors choose from predefined lists. The selection 
method can be a multiple selection (checkboxes), choose one selection (radio buttons), 
or a selection list (a drop-down menu). 

http://1and1.com/


 

68 

Windows® Hosting Manual, 1&1 Internet Inc. 

PACKAGE ADMINISTRATION: APPLICATIONS  

 

Under 'Database Overview' > 'Button Setup' choose which buttons to use for your 
database. 

Determine which buttons should appear on your database. Also, you can relabel the 
buttons. Use buttons to perform the following operations: 

 'Delete' 
Data in the fields will be erased to allow new entries. 

 'Cancel' 
The data on the page will not be submitted to the database. The user will be returned to 
the designated "Forwarding" page. 

 'Submit' 
The data entered is sent and saved in the database as a data record. The user will be 
brought to the output page. 

View, Search or Delete Data Entries in a Database 
 

Under 'Database Overview' > 'Data Record Overview' you can view, search or 
delete your visitor's entries. Any content entered in the database on the website is 
automatically saved in the database. To search quickly use the sorting features. 

Edit Database Design and HTML Fields 
 

Under 'Database Overview' > 'Design Setup' choose which design and which HTML 
fields to use for your database. 

In the Design Options section click on the  icon for more design options. Choose a 
color scheme to apply to your form. The pixel size refers to the size of the form. 

In the section HTML Areas click on the  icon to edit or integrate specific HTML fields in 
your database. 
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Integrate a Database into Your Website 
 

Under 'Database Overview' > 'Integrate Database' you can integrate or build your 
database into your website with the link provided.  

1. Using an HTML editor (ex., NetObjects Fusion®) open the web page you would like to place 
the link in. A selection of such tools can be found in the 'Downloads' section of the 
1&1 Control Panel. 

2. To copy the link, select it with your mouse by clicking and dragging while holding down 
the left mouse button. Right click the marked section and select 'Copy'; the link is now on 
the clipboard. 

3. Using the HTML editor, insert the link by right clicking at the desired position and selecting 
'Paste'. The following example shows how to insert the link and a reference text, for 
example "Go to the database": 

4. <a href="Enter the link here"> Go to the database. </a> 

5. Save the file and upload it to your website. The link to the database is now active and can 
be clicked on by people visiting your site. 

Delete a Database 
 

Under 'Database Overview' use the  icon to delete a database permanently. 

4.5 Newsletter Tool 
 
 

Coming Soon to your Package — 1&1 Newsletter Tool!  

Soon you'll be able to use these wonderful features:  

 

 1000 free e-mails per month.  
 Unlimited e-mails after the first 1000 for $.99/1000 e-mails.  
 Send your newsletter in HTML or text format.  
 Layout choices and templates to easily create your newsletter.  
 Statistics on the mailing of your newsletter.  
 A form for your visitors to subscribe/unsubscribe to your newsletter. 

 

You can see news on this product and others under 'News'.  

1&1 is committed to providing you with all the tools you need to build professional, 
interactive websites. 

Newsletters can be sent to subscribers to periodically inform them about certain topics. 

Use newsletters to: 

 Inform customers about new products offers 
 Announce updates of your website to your subscribers 
 Communicate events to members of your local club 
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Figure 32: Create and send out a newsletter with the Newsletter Tool. 

Using a newsletter offers several advantages as a means of news distribution. You inform 
your subscribers in almost real-time about product news, events, or information. You can 
use your subscriber database for easy distribution. After creating the first newsletter you 
can use it as a template. For each issue you can make a copy of the previous one, rename 
it, and change the content. 
 

Newsletters are different from spam because they are sent out by request only (  Bulk E-mail 
/Spam page i). As newsletter administrator, you are responsible for complying with this rule. 
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General Information 
Use the 1&1 Newsletter Tool to send personalized newsletters to your subscriber list. 

 
Figure 33: The Newsletter Tool is set up like the Control Panel. 

The 1&1 Newsletter Tool offers: 

 A wizard for easily creating and distributing your newsletter.  
 An address book for managing your subscription list. You can also use a Comma 

Separated Value format (CSV) files to import a lot of address at the same time. 
 A subscription link so visitors to your site can sign themselves up for the newsletter.  
 An elaborate address database for managing addresses including blocking unwanted 

subscribers. 
 A sophisticated editor for creating and rewriting newsletters.  
 An archive with room for up to 50 newsletters. 
 A generous e-mail allotment included per billing period with the possibility to purchase 

extra allotments. 

System Requirements 
 

Before creating a newsletter with the 1&1 Newsletter Tool please make sure that you have 
set up at least one e-mail account as described in Set Up a New E-mail Address in the 
Control Panel page 21. 

To use the Newsletter Tool, all you need is a new generation browser, for example Internet 
Explorer® version 5.5 or higher, Mozilla® 1.3, or Netscape® 7.1. You may only build tables 
using Mozilla® 1.5 or higher. 

We offer you the latest Microsoft® Internet Explorer® and Netscape® which support the 
Newsletter Tool's functions. You can download them for free in the 1&1 Control Panel 
from the 'Downloads' section (the software is also included on the 1&1 Tuner CD which 
you received together with the Easy Setup Guide when you ordered your package). 
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Using the Newsletter Tool 
 

Managing Addresses in the Address Overview 
 

There are several ways to add people to your address database. 

If you already have a mailing list you can import these addresses using a Comma Separated 
Value (CSV) file (  Creating or Importing New Addresses (Menu Item 'Address Overview') 
page 72). 

Give people the chance to sign themselves up for your newsletter by integrating a 
subscription box into your website. Use "Subscription Forms" to create a form and copy 
the link into the source text of your website (  Setting Up Subscription Forms page 84). 

Enter a new address manually. Go to 'Newsletter' > 'New Address' in the left navigation 
bar of the Newsletter Tool and follow the instructions. 

Creating a Newsletter (Menu Item 'New Newsletter') 
 

The newsletter wizard makes creating a newsletter a simple process with professional 
results. To begin go to 'Newsletter' > 'New Newsletter' on the Newsletter Tool page. 
The wizard takes you through these steps: 

1. Settings 

The basic settings of your newsletter are the title, the sender's e-mail address, the subject 
of the newsletter e-mail, and the format to create and send it in. Decide whether you 
would like an HTML or text newsletter or both. We have created an editor that will help 
you with the process. 

1. Layout (optional) 

There are over 10 different designs to choose from. These can only be used with HTML 
format. 

2. Images (optional) 

Upload images you have on your computer to use in your newsletter. These can only be 
used with HTML format. 

3. Content 

Enter your text into the editor. Insert uploaded images into the text. 

4. Test Newsletter 

Send a test e-mail to a selected recipients group. Preview the results. Proofread and make 
changes. 

5. Mailing List 

Choose the recipients that will make up the newsletter's mailing list. 
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For the next steps, go to 'Newsletter' > 'Newsletter Overview'. On the Newsletter Overview 
page select the newsletter you would like to work on. 

 

If you have just created a new newsletter it can take a few minutes until it can be seen in the 
Newsletter Overview. 

1. Distribution 

When you are finished with the newsletter, schedule it for distribution. A newsletter 
cannot be distributed unless you have tested it at least once. 

2. Statistics 

After the distribution, check the statistics using the  icon in Newsletter Overview. To do 
this, the status in the Newsletter Overview must show "Distribution completed". 

3. Summary 

To view the details of the newsletter creation process at any time, check the summary 

using the  icon in the Newsletter Overview. 
 

During the testing phase or once released for distribution, newsletters cannot be edited. 

Settings Section 

To create a newsletter, specify the following: 

 "Title" 
The title is your way of identifying the newsletter and is shown in the overview. 

 "From" 
Allows you to choose from which e-mail account you would like to send the newsletter 
e-mail. You can create a new e-mail address under 'E-mail'. 

 "Allow replies?" 
If you would like to receive replies to your newsletter you can allow this by choosing yes 
and then selecting the e-mail address the replies should be sent to. Choosing no will 
automatically discard any replies sent to the newsletter. 

 

If you choose "Yes" to allow replies to your newsletter, 1&1 recommends that you create a 
specific account meant only for replies to your newsletter. This will avoid flooding your 
mailbox with replies, for example automatically generated out-of-office responses. 

 

 "Subject" 
This field is mandatory and will appear in the subject line of your newsletter e-mail. 

 "Format" 
Choose whether to write your newsletter text using plain text or using HTML code. 
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Which format you choose depends on your preferences and the target group you are 
addressing. We recommend you choose plain text format, as many mail programs may not 
display HTML coded text correctly. 

 

 "Unsubscribe link target" 
Later, when you edit the newsletter content, insert a link which brings your subscribers 
to an unsubscribe form, so that they may cancel their subscription to your newsletter. 
The unsubscribe link will lead to the domain you have selected here. The requests will 
automatically be applied to your subscriber database. 

You can store up to 50 newsletters. After reaching this limit, you need to delete some 
newsletters from the Newsletter Overview to free up space for creating new ones. 

Layout Section 

Select a design template for the HTML version of the newsletter. Choose from over ten 
different designs. You will be able to write your own text and add images to it, to 
customize your newsletter. 
 

Graphic design templates are only available for HTML newsletters. 

Images Section 

If you want to integrate logos, screenshots, or other images into the HTML version of your 
newsletter (you cannot use this feature with plain text newsletter), you can upload these 
from your local directory. You cannot edit the images after upload. Please keep in mind 
that the size of each image may not exceed 100 Kbytes and may not be wider than 540 
pixels to keep the newsletter size within reasonable limits. Additionally, each newsletter is 
limited to 30 images. Allowed image formats are .jpg, .gif, or .png. 

Content Section (Newsletter Editor) 

After having selected a suitable design template, in the content section enter the desired 
text for your newsletter. If you want to send both HTML and text versions, fill in the 
content into the HTML template and then click on the button 'Text version'. This will 
automatically copy the content into the text version of the newsletter. 
 

If you decide to change your design template, you will have to re-enter the content. 1&1 
recommends that you make a copy of your newsletter text before changing the design 
template. 
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The Newsletter Editor 
 

With the help of the newsletter editor you can create a professional newsletter in HTML 
using familiar word processing tools and commands. In the editor's preview window, you 
can see how the newsletter looks as you work on it. For control over the final result, you 
can also use the HTML source text mode, which allows you to work directly on the HTML 
code. 

 
Figure 34: The Newsletter Tool editor is easy to use to create and format a newsletter. 

The editor provides the following basic text formatting tools: 

 Text formatting (fonts, size, style, and colors) 
 Paragraph formatting (align left, align right, and center) 
 Increasing and decreasing block indent 
 Redo and Undo 
 Lists (bulleted which are known in HTML as ordered lists and numbered lists which are 

known as unordered lists) 
You can cut, copy, and paste text from other programs using the clipboard. The shortcuts 
are the same as in other programs: [Ctrl]+[C] to copy, [Ctrl]+[X] to cut, and [Ctrl]+[V] to 
paste. These shortcuts can be used in the source text mode and in the preview mode. You 
can fill in existing HTML or also HTML source code. 
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To use the Newsletter Editor, all you need is a new generation browser, for example 
Internet Explorer® version 5.5 and higher, everything from Mozilla® 1.3 and higher based 
browser will support the Newsletter Editor, as well as Netscape® 7.1. You may only build 
tables using Mozilla® 1.5 or higher. 

To build a table, use the 'Insert Table' icon. In the fields marked rows and columns fill in 
the desired number of each. Also, you can state the table width in percentage of the 
available space or in pixels. In the table border field you can set the width of the table 
frame in pixels. Under spacing, both cell spacing and cell padding are given in pixels. Cell 
spacing sets the space between each of the table's cells in relation to each other whereas, 
cell padding defines the distance between the cell's content in relation to the edge of the 
cell. 
 

To avoid the line spacing becoming too large when displaying your newsletter in Internet 
Explorer®, use [Shift]+[Enter] when using the editor with the Internet Explorer®. This way you 
will get just a simple line break, instead of creating a new paragraph. When you hit [Enter], it 
automatically starts a new paragraph by filling in an empty line. 
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 Variables 
 

In the newsletter editor you can include variables in your message text. These variables 
will be substituted by the values (names or addresses, etc.) in the copy your customer 
receives. 

If you decided to build an HTML newsletter, these variables are listed in a drop-down 
menu in the editor's task bar. In a text newsletter, you can use these as well by typing 
them in. 

Name Variable 

Unsubscribe URL $UNSUBSCRIBEURL$ 

E-mail address  $EMAIL$ 

Company  $COMPANY$ 

Title $TITLE$ 

First name $FIRSTNAME$ 

Last name $NAME$ 

Address $STREET1$ 

Address 2 $STREET2$ 

City  $CITY$ 

State  $STATE$ 

Zip code  $ZIPCODE$ 

Country  $COUNTRY$ 

Telephone  $PHONE$ 

Fax  $FAX$ 

Cell phone $CELLULAR$ 

any word $CUSTOM1$ 

Table 1: List of Variables 
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Test Newsletter Section 
 

It is important to see the finished product before your customers do. Before you release it 
for distribution do a test run to see how the e-mail looks when it arrives. We recommend 
sending a test e-mail to yourself or a selected subscriber group (these could be friends or 
colleagues). The test run is limited to ten recipients and can only use addresses which are 
designated as test addresses. 

Set up an address for testing your newsletter either by choosing it as one when creating 

the address or by clicking on the  icon next to that e-mail address in the Address 
Overview to reach the configuration page and then choosing it as a test address. 
 

The e-mail messages sent for testing are counted as part of the free e-mail allotment allowed 
per billing period. 

Mailing List Section 

When you are satisfied with the results of your test e-mail, choose the recipients of your 
finished newsletter by creating a mailing list. The number of the recipients included on 
your list is shown at the bottom of the page. If you would like to send the newsletter to all 
the addresses in your address book, click on 'Save' at the bottom of the page. 
Alternatively, you can use the Filter recipients function to specify a particular group of 
recipients for your mailing list. 

Working on Existing Newsletters (Menu Item 'Newsletter Overview') 
 

The first step in working on existing newsletters, is to go to 'Newsletter' > 'Newsletter 
Overview'. There you will see a list with the title, subject, and the status of each 
newsletter. 

Find the newsletter you would like to work on, using the navigation icons, the sorting 
arrows and the Filter function. Once you have located the newsletter you would like to 
work on, you can: 

 Edit a newsletter before sending it out. During the testing phase or once released for 
distribution newsletters cannot be edited. 

 Copy a newsletter, and change only parts of it to update it and send it out again or 
perhaps to make a few changes to customize it for different mailing groups. 

 

Although you can create an unlimited number of newsletters, the maximum number of 
newsletters shown to you on the overview page is set to 50. We therefore recommend 
that if you have 50 newsletters in your list you select and delete some before you create 
new ones. 
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The status column on the Newsletter Overview page tells you what stage of production 
your newsletters are in: 

  "Untested" 
At this point you have started creating a newsletter and before it can be sent out it must 
be tested. 

If you would like to test the newsletter, click on the  icon to edit or click on the title 
of the newsletter and you will be brought to the Test Newsletter page. 

 "Newsletter in test queue — please wait…" 
The newsletter will shortly be sent out for a test. Wait a few moments. Press the 
'Reload' button to see if the status has changed. 

 "Test running –- please wait…" 
It takes a few minutes until the test distribution is completed. As soon as you have 
received the test e-mail in your account, take a moment to proofread your newsletter to 
make sure that the content is correct. You can update the status using the 'Reload' 
button. 

 "Testing complete" 
As soon as this status is shown you can set a mailing list for the newsletter's distribution. 

 "Newsletter tested, no distribution scheduled" 
To specify the release date, click on the title of the newsletter. You will be automatically 
taken to the correct page. 

 "Newsletter released, distribution starts on…" 
At this point the newsletter can no longer be edited. To prevent it from being 
distributed, you can delete it and create a new one. 

Before deleting you can also click on the  icon to copy the newsletter so that you do 
not have to start from scratch. 

 "Distributing – please wait…" 
You can still stop the newsletter while sending, but the e-mail messages which have 
already been sent are counted.  

 "Distribution completed" 

As soon as the newsletter has been sent you can either use the  icon to edit it or click 
on the newsletter title in the first column to view the distribution statistics.  

Use the 'Reload' button to update the status column. 
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Statistics Section 

After the successful distribution of a newsletter, find out the statistics generated in 

Newsletter Overview by clicking on the  icon or on the title of the newsletter. 

The statistics track the following: 

 The time the newsletter was sent. 
 The number of recipients the newsletter was sent to. 
 The number of newsletters that arrived. 
 The number of newsletters that could not be delivered. 
 The number of people that cancelled their subscriptions. 

 

Summary Section 

The Summary page comprises all the current information (Settings, Layout, Images, 
Content, Test, Mailing List, Distribution, and Statistics) in a concise overview. View each 
section, and if the newsletter has not been sent yet, jump directly to each step of the 

newsletter wizard using the  icon to edit a specific step of the newsletter. 
 

Changing the design template of an HTML newsletter will erase any previous work, as the 
content cannot be carried over. The text must be re-entered. Please make sure you have a 
copy of your text before choosing to change the template. 

Creating or Importing New Addresses (Menu Item 'Address Overview') 
 
  

To create a mailing list before sending out a newsletter, go to 'Newsletter' > 'Address 
Overview' in the Newsletter Tool. The mailing list is automatically generated from all the 
addresses listed in the Address Overview. To only send the newsletter to a selected group 
of recipients on this list, use the "Filter recipients" function. Your address database can 
hold up to 25,000 unique addresses. 

You can add new addresses to be listed in the Address Overview in either of the following 
ways: 

 Create a New Address 
Use 'New E-mail Address' to manually add addresses to your recipients list in the 
Address Overview page. Alternatively, you can reach the same form via the left 
navigation bar. Choose 'Newsletter' > 'New Address' and insert the address 
information. When you are creating a new address, you can specify whether you want to 
use it as a test address. You can then use it for test runs before a newsletter is released 
for distribution. 

 Import Addresses 
If you already have a mailing list you can simply import these addresses using a Comma 
Separated Value (CSV) file. 

 

The import file size may not exceed 500 addresses. 
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Arrange the addresses of your CSV file according to the following order: 

1. Company 

2. Title 

3. First name 

4. Last name 

5. Address 

6. Address (additional info) 

7. Country 

8. State 

9. Zip code 

10. City 

11. Phone 

12. Fax 

13. Cell phone 

14. E-mail 

15. Sales tax 

16. Customer number 

17. Customer group 

18. Discount level 

19. Additional information 1 

20. Additional information 2 

21. Additional information 3 

22. Additional information 4 

23. Additional information 5 

Enter two quotation marks if there are no details available for a field. Do not leave it empty 
or skip it. Skipped or empty fields are not allowed. An e-mail address must be included in 
each entry. Write each subscriber to be imported in a separate row. 
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Example: 

If you have 3 pieces of information (the subscriber's first name, last name, and e-mail address) 
the correct CSV file order is: 

"","","First name","Last name","","","","","","","","","","name@domain-of-your-
choice.com","","","","","","","","","" 

 

Under 'Newsletter' > 'Database Administration' > 'Import Address List', select which 
separator you used in your CSV file to separate the individual details. You can use either a 
comma or a semicolon. 

Click on 'Import' to upload the file and import the information into the Newsletter Tool 
address database. 

Managing Addresses 

Go to 'Newsletter' > 'Address Overview' in your Newsletter Tool to view your address 
database and edit or delete addresses already created. 
 

Determine Addresses for Testing Your Newsletter 

A test run is necessary before you release a newsletter for distribution. 

By clicking on the  icon next to the address, you can set an address as a test address. 
Only addresses selected as test addresses will be shown when you choose who to send 
your test newsletter to. Test addresses can also be included in the mailing list for your 
finished newsletter distribution. 
 

The e-mail sent for testing are counted as part of the free e-mail allotment allowed per billing 
period. 

Show Bounced Status 
 

When you edit an address (by clicking on it or on the  icon next to it) you will see the 
"Bounced Status". This status informs you on how many newsletters have not reached the 
recipient. If newsletters frequently cannot be delivered to this address you should remove it 
from your recipients list since we do charge you for undeliverable e-mail. Depending on 
available additional details you can try to get in touch with the recipient. As soon as the 
e-mail address has been corrected, we recommend resetting the status to 0. 
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Blacklist 
 

The blacklist is a filter allowing you to specify which subscriber e-mail addresses should not 
receive newsletters. Each subscriber on the blacklist is automatically ignored when sending 
newsletters. It is also not possible for this blacklisted subscriber to sign up again. 

You can create your personal blacklist under 'Newsletter' > 'Database Administration' 
> 'Add to Blacklist'. 

To block a group of e-mail addresses quickly use the "%" placeholder. 

A few examples of blacklist entries: 

john.smith@domain-of-your-choice.com 
Precisely one subscriber is blocked. If this subscriber is already in your address database no 
further newsletters will be sent to them. If the subscriber is not in the address database, 
then they cannot subscribe using the subscription form. 

%@domain-of-your-choice.com 
The "%" character in front of the "@" blocks all requests from an e-mail address under 
domain-of-your-choice.com. However, addresses from a subdomain are not blocked. 
"john.smith@my.domain-of-your-choice.com" for example will be accepted. 

%.domain-of-your-choice.com 
The "%" character in front of the period followed by the domain name blocks all requests 
from an e-mail address with any subdomain of domain-of-your-choice.com. 

%domain-of-your-choice.com 
Caution! The "%" character in front of the domain name not only blocks all people with 
an e-mail address with domain-of-your-choice.com and all subdomains, but also all other 
domains and subdomains which end with the text "domain-of-your-choice.com". For 
example, "john@your-domain-of-your-choice.com" will then be blacklisted as well. 
 

If you would like to exclude a domain with its subdomains. 1&1 recommends that you specify 
two filter rules following the scheme above. Otherwise you may overshoot the mark. 

 

%@domain% 
All people whose e-mail address contains the word "domain" will be blacklisted. 

To edit or delete your blacklist entries go to 'Newsletter' > 'Database Administration' > 
'Blacklist Overview'. 
 

Blacklisted names will still be listed in your Address Overview, unless you delete them from 
your address list. They are only blocked from receiving a newsletter. 
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Customizing Additional Fields 
 

Set up additional fields to request specific information from your website's visitors who are 
interested in receiving your newsletter. 

Visitors to your website can subscribe to your newsletter by filling in the form you provide. 
When creating a form under 'Newsletter' > 'Subscription Form' > 'New Form', you can 
already use a number of fields to request subscriber data, which can be designated as 
show, do not show, or show as mandatory. Only the "E-mail" field is mandatory in every 
subscription form. 

When you use additional fields, they allow you to better manage the data you receive from 
subscribers. Use 'Newsletter' > 'Database Administration' > 'Customize Fields' and 
then add them to a subscription form. 

Setting Up Subscription Forms 
 

 Subscription Forms 

Create a new subscription form under the menu item 'Newsletter' > 'Subscription 
Form' > 'New Form'. As a result of the creation process, you will receive a link to the 
form you created which you can copy and paste into the source code of your website. 
Visitors to your website can use this subscription form to sign up to receive newsletters. 
Once they sign up their names are automatically entered into your database and can be 
seen in the Address Overview. 

Select the fields which you would like included in your form. "E-mail" is the only 
mandatory field and is automatically placed into your subscription form. You can choose 
to designate the other fields as mandatory or optional. 

Decide on whether the sign-up process automatically accepts every subscription (except 
those on your blacklist) or, as an extra service to offer your visitors, you can provide a 
confirmation e-mail. A confirmation e-mail is sent to the e-mail address after the person 
has signed up. Before the person can actively receive your newsletter, they must first 
reply to the confirmation e-mail to confirm that they did indeed sign up. If someone else 
had entered the e-mail address and the person does not want to subscribe, they can 
simply delete the e-mail and the e-mail address will not be entered into your address 
database. 

View a list of all the forms you have created under 'Newsletter' > 'Subscription Form' 
> 'Form Overview'. Here, you can choose to integrate them into your website. You will 
then be provided with a link, which you can copy and paste into your website. 

Launch your web editor. If your program provides this function, change to HTML source 
code view. Insert the link by highlighting it, copying and pasting it into the desired 
position in your website. Use a reference text or an image to use the link with. 

For example, insert your reference text "Click here to subscribe to our Newsletter" in the 
following way: <a href="Insert the link here">Insert the reference text 
here</a>. 

 

 Unsubscribe Option 
Allow your visitors to unsubscribe from your newsletter mailing list by integrating a link 
in your newsletter. 
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When creating a newsletter under the menu item 'Newsletter' > 'New Newsletter', 
first specify which page to direct those to who wish to unsubscribe by selecting the 
appropriate domain as the "Unsubscribe link target" under New Newsletter and in the 
section Settings. 

Next choose to add an unsubscribe link, or an unsubscribe URL in the section Content. 
Fill in a link with a reference text, or alternatively, include an unsubscribe URL to your 
unsubscribe form by choosing it from the variables drop-down menu in the editor. 

Bulk E-mail /Spam 
  

Newsletters differ from bulk e-mail or spam in that they are being sent out by request only. 
As a serious information provider or Internet trader you must give your target group the 
possibility to decide if they would like to receive your newsletter or not. That means you 
must provide a subscribe/unsubscribe option both on your website and in the newsletter 
itself (  Setting Up Subscription Forms page 84). Sending out newsletters without the 
addressee's consent (unsolicited e-mail) is considered as "spam". Spamming is illegal. 
 

According to 1&1's Terms and Conditions under http://order.1and1.com/xml/order/Gtc you 
may not use the Newsletter Tool to transmit any unsolicited commercial or bulk e-mail. You 
may not engage in any activity known or considered to be "spamming" or "mail bombing" 
and you may not carry out any "denial of service" attacks on any other website or Internet 
service. 

4.6 in2site Live Dialogue 
 

in2site is an innovative tool for interactive Internet communication in real time. in2site 
notifies you as soon as someone visits your website. You can open a dialog box, so you 
can talk to your visitors while they are looking at your website, thus offering real-time 
support. 

in2site offers the following functions and communication options: 

 Visitor notification 
You receive optical or acoustic notification as soon as someone visits your site. 

 Visitor monitoring 
Use in2site to accompany your visitors as they browse your website and find out how it 
is used. You can then use this information to optimize your website accordingly. 

 Interactive communication 
Once you activate in2site and enable visitor interaction, a pop-up window with your 
welcome text appears on your visitor's screen, inviting your visitor to get into contact 
with you. If your visitor agrees, they can write a reply in the window. 

 Sales tool 
Use in2site for consulting and support dialogs, thus propelling your sales results. Address 
your customers as soon as they visit your website and offer help. In2site facilitates 
feedback in real-time — as opposed to time-consuming e-mail communication. 

http://order.1and1.com/xml/order/Gtc
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Figure 35: in2site can be used to speak directly to your customers while they are visiting your 

website. 

Using in2site has many advantages: 

 Help your visitors to register 
 Support customers while they are shopping on your website by offering individual advice 
 Explain your services to your customers directly 
 Keep interested shoppers on your pages through real-time communication 
 Present yourself as a well organized business by using this tool. 

If you are private user you can use in2site to surprise your visitors, keep interested 
newcomers on your website through real-time communication and establish new contacts, 
or chat with your friends or family. 

Apart from the chat functions, you can use in2site to watch how your visitors browse your 
pages. From that you can learn where it makes sense to advertise your website and how to 
optimize it. 
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How to Use In2site in the 1&1 Control Panel 
 

When logged on to the 1&1 Control Panel go to 'Applications' > 'in2site Live Dialogue' 
and choose 'Enable' to set up your in2site account and obtain the required authorization. 
The status will change to "setup". 

Once the status has changed to "ready", choose 'Edit' to select the domain for which you 
want to use in2site and determine a password. A user name is generated automatically. 
You receive your access data when you click on 'Next'. Please make a note of it. 
 

Once your in2site account is set up, you can find or change your password information under 
'Applications' > 'in2site Live Dialogue' by clicking on 'Edit'. 

 

To install the in2site client software on your computer, download it from 'Applications' > 
'in2site Live Dialogue' first. In the in2site Live Dialogue Client Software section click on 
'Download & Save'. For a Plus version, in the left navigation bar, click on 'Order' and 
order in2site Dialogue Plus. Then launch the program by entering the access data you were 
given (  above). 

For further information on in2site, please consult the in2site context help. 

In2site Live Dialogue Plus 
 

If you find that your needs outgrow the in2site basic version, you can upgrade to in2site 
Live Dialogue Plus. Go to 'Applications' > 'in2site Live Dialogue' and upgrade your 
current version in the Additional in2site Live Dialogue Plus Modules section. Or, download 
the software from the 'Order' section in the 1&1 Control Panel. 

in2site Live Dialogue Plus offers the following additional features: 

 A remote browser control to guide users to particular pages of your website. 
 An optional chat button for visitors enables users to launch a chat. 
 A user database with which you can create and manage visitor contact details. 
 A chat log for the last chat can be sent to the visitors by e-mail. 
 Prepared responses to answer frequently asked questions. 
 Up to five simultaneous chats (instead of one). 
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4.7 Basic CGIs (CGI Library) 
 

1&1 offers "Basic CGIs" to help you make your website dynamic and interactive. "Basic 
CGIs" are a selection of commonly used Common Gateway Interface (CGI) scripts 
including the HTML templates for the forms. 

Common Gateway Interface (CGI) scripts are a set of instructions that a web server can use 
to process the information filled in to HTML forms (guest books, discussion boards, etc.) 
These are on your web server and the visitor's browser call them up when needed (server 
side technology). 

Your visitors view your website using a browser. If they use any HTML forms on your 
website, the information they enter is bundled by their browser. CGI scripts collect this 
bundled data from the browser and process it to the web server, and if applicable, return 
further HTML forms or an acknowledgement page in HTML format. 

Using Basic CGIs will increase the interactivity of your website, and attract more traffic to 
it. You can use the CGIs we offer to produce a dynamic and interactive website are guest 
books, forums, feedback forms, counters and date or time displays. These are the Basic 
CGIs 1&1 provides you with. 

How to Use Basic CGI in the 1&1 Control Panel 
 

When logged on to the Control Panel, go to 'Applications' > 'Basic CGIs'. This will open 
the Basic CGI overview page. Here, you will find a selection of basic CGIs.  

Choose a CGI and click on 'Set Up' to start the assistant that will take you though the 
process step by step. The assistants for each of the CGI scripts are very similar to one 
another to make them easy to use. Once you have created a counter your can go back and 
create a guestbook. 

Guest Books, Forums, Feedback Forms 
 

A guest book is for your visitors' comments. The comments they make will then be shown 
on your website as guest book entries, unless you decide to delete them. This is a useful 
source of feedback. 

Discussion forums allow your visitors to post a question, share ideas, opinions and 
information quickly and easily. Forums are usually organized by topics in an easy-to-follow 
format, and are designed so you can quickly locate information, find other knowledgeable 
users and participate in conversations. 

A feedback form is an interactive web form where your visitors can send their feedback to 
you. This form serves as a communication channel between individual website visitors and 
you as the website operator and is not meant to be published on your website. 
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 Set Up a Guest Book, a Forum or a Feedback Form 

Choose 'Set Up' beside the guest book, the forum or the feedback form to launch the 
assistant. The assistants for guest books, forum, and feedback forms work similarly 
concerning options and order of setup unless indicated otherwise. 

In the first instance enter an e-mail address and the name of a moderator. See how your 
form will look by choosing 'Refresh Browser Preview' to save the entries for preview. 
Then click on 'Browser Preview'. 

In your CGIs you can set: 

 Moderator contact details 
(This feature does not apply to feedback forms.) A moderator is the contact person for 
the guest book, forum, or feedback form. With guest books or forums the moderator 
checks that the entries made are not of any offensive or illegal nature or nonsense 
entries, before they are published. While this ensures a high standard of the content 
published, it only makes sense if the moderator appointed has the time to look after the 
entries regularly. 

 

As the website operator you are responsible for the content of your website, including 
postings of any kind, regardless if it is moderated or not. You are obliged to make sure that 
the entries to your guest book or forum have no offensive, criminal, or illegal character. If 
they do, you are responsible for deleting them immediately from your website. 

 
 

 Feedback forms only: Whether the name should be a mandatory field, i.e., whether you 
oblige your visitors to enter a name when writing a feedback to you; 

 Feedback forms only: Whether a valid e-mail address should be a mandatory field, i.e., 
whether you oblige your visitors to enter a valid e-mail address when writing a feedback 
to you; 

 Feedback forms only: The address and request input fields which should be available to 
your visitors; 

 The e-mail format (HTML or plain text) that is used for your moderator. This option 
depends on the kind of e-mail program your moderator uses, as well as on the type of 
visitors you expect to e-mail with. If your assumed visitors are by and large Microsoft® 
users, they may be able to post and receive e-mail in HTML format (using Outlook®), 
while Linux® or UNIX® users may experience problems. To find out about the usage of 
your visitors have a look at your WebStatistics (  WebStatistics page 48). 

 Whether visitors receive confirmation e-mail after submitting an entry. Depending on 
your web content, your visitors may feel taken more seriously if you choose to send them 
a reply; 

 Whether HTML should be allowed in comment fields. Allowing HTML widens the 
possibilities of your users but may lead to undesired formats or styles; 

 The number of messages displayed per page. Choose how many messages you would 
like to be displayed on your website. 

Once you have filled in the information required, choose 'Refresh Browser Preview' to save the entries for preview. To preview the work that you have done so far, click on 'Browser Preview'. This can be used on every page. Click on 'Next' to save the changes. 
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Next choose between two designs. Click on 'Next' to continue.  

Set a link back to your website, when asked to do so. This link will be included so visitors 
can go back to your website from the guest book, forum or feedback form page. Set the 
background color (wallpaper, determines the background appearance of the guest book, 
forum or feedback form), the background custom color (determines the appearance of 
text fields and markers), and the font you would like to use. 

Once you have filled out the information required click on 'Next' to continue.  

Write a header to welcome your visitors to your guest book, forum, or feedback form. 
Choose a welcome header, the border color for messages, the heading background and 
text color, the color for special commands when the page is in admin mode, and the 
border color of scroll bars and buttons. Click on 'Next' to continue.  

Enter a header requesting your visitors to make a contribution to your guest book, forum, 
or feedback form. Again you can determine the colors that you wish to use. You can write 
the reply text for a successful entry that your visitor receives. Click on 'Next' to continue.  

Once you are finished save your changes. 

Setting up your guest book, forum, or feedback form has been successful. Now you can 
use the link(s) listed to integrate your guest book, forum, or feedback form into your 
website. If you want to see what the different guest book, forum, or feedback form pages 
look like, click on 'Show'. 

Visitor Counters and Date/Time Displays 
 

 Visitor Counters 
These are only a few examples of the kind of web counters you can include in your 
website. There are many different ways to display the information but it all serves the 
same purpose, which is to count how many times the information has been called up 
(counting the "hits"). Every visit is counted automatically. 

"You are visitor number  to the page" 

or 

"This page has been accessed  
times since 3rd March 1998" 

 Date/Time Displays 
The examples give you an idea of the different date or time displays which you can 
include in your website. 
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 Set Up a Visitor Counter 
Choose 'Set Up' beside the visitor counter. This will open the assistant. Next, choose the 
type of counter from the selection offered, and proceed to the next page. 

Adjust the font, the border width and the border color according to your liking. You can 
choose 'Refresh' to update the preview before proceeding to the next page. 

Decide the maximum number of digits to be displayed, whether to show zeros or not, 
and if you would like to display a thousands separator.  

 Set Up a Date/Time Display 
Choose 'Set Up' beside the date/time display. This will open the assistant. Next, choose 
whether you would like to create a date or time display, and proceed to the next page. 

Adjust the font, the border width and the border color according to your liking. You can 
choose 'Refresh' to update the preview before proceeding to the next page. 

Next select the time zone.  

Integrate Basic CGIs into Your Website 
Using an HTML editor, open the file you would like to integrate the link or links to your 
CGIs. Use your own HTML editor or, depending on the 1&1 package you chose, 
NetObjects Fusion®. This software can be found under the 'Downloads' section in your 
1&1 Control Panel or on the 1&1 Internet Tuner CD you received when you ordered the 
package. 

To copy a link, highlight it using your mouse and then right click in the marked section. 
From the menu that appears select 'Copy'. The link is now on your clipboard. 

Go to your HTML editor with the open file, and insert the link by right clicking on the 
desired position. When the menu pops up, select 'Paste'. 

Insert the link along with the following attributes and a reference text for the visitor (such 
as "To the guest book") as shown in the example below: 

<a href="Enter the link to the guest book here"> To the guest book. </a> 

Save the file and upload it to your website. The links to the respective forms are now active 
and can be clicked after loading the file in a browser. 
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4.8 MS SQL Administration 
 

Setting Up the MS SQL Server 
 

Log in to the 1&1 Control Panel, and on the My Account page choose the package you 
would like to work on by clicking on it. This will bring you to the Package Administration 
page. There, go to 'Applications' > 'MS SQL Administration'.  

 
Figure 36: The page looks like this before you activate a database. 

Click on 'Set Up' to set up the database. The setup process will take about three hours. 

Accessing Your MS SQL Database via the 1&1 Control Panel 
 

Log in to the 1&1 Control Panel, and on the My Account page choose the package you 
would like to work on by clicking on it. This will bring you to the Package Administration 
page. Either retrieve your MS SQL Database access data from 'Web Space/Access' > 'FTP 
Account' or from 'Domains' in the section "Microsoft FrontPage Extensions Status". (This 
depends on whether you have activated FrontPage® Server Extensions, see also 
FrontPage® Server Extensions page 16). 

Make a note of your User ID and password, since you will need it to log in to the database 
administration. 
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Next, choose 'Applications' > 'MS SQL Administration'.  

 
Figure 37: The page looks like this after you activate a database. 

To access the database, click on 'Admin'. When prompted enter your user name and 
password which you retrieved previously. 

 
Figure 38: Your SQL Server Administration page. 

Now you can set up new tables in or make queries throughout your database. 
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4.9 Webfiles 
 

Use 1&1 Webfiles to administer access and viewing permissions of various directories of 
your website.  

When logged on to the 1&1 Control Panel, on the My Account page choose the package 
you would like to work on. This will bring you to the Package Administration page. On this 
page, either retrieve you Webfile access data from 'Web Space/Access' > 'FTP Account' 
or from 'Domains' in the section "Microsoft FrontPage Extensions Status". (where to find 
your access data depends on whether you have activated FrontPage® Server Extensions, 
see FrontPage® Server Extensions page 16). 

Make a note of your User ID and password, since you will need it to log in to Webfiles. 

Next, choose 'Applications' > 'Webfiles' and enter the access data.  

In the Webfiles window, right-click on the folder or file and select 'Rights Management' 
from the drop-down menu. 

 

Define the permissions as needed, and click on 'Set'.  
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Repeat the process for all the folders and directories needed. 
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5 Software Licenses 
 

The 1&1 Website Tuner CD contains useful applications which help you design your 
website and get more use out of your package. After ordering, the status of your software 
bundle may be viewed under this menu item. 

To order the software CD that is included in many packages, log on to the Control Panel 
and select your package. Click on 'Software & Licenses' in the left navigation bar. 

We also offer a section to download software for free. You can find this clicking on 
'Downloads' found in the left navigation bar of the Control Panel. 

In either case, during the installation of many of these applications, a serial or license 
number will be requested. Click on 'Request License' on the Software & Licenses page to 
display the number. The number will remain available here for future reference. Enter this 
serial number into the prompt field of the respective software you are about to install. 
Only one license number can be retrieved for each application. 
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My Account 
1 User Settings • 2 Billing • 3 Affiliate Program • 4 Messages • 5 News 
 

The My Account page leads you to all the important user settings, billing information 
and aids, our Affiliate Program, messages, and general product news. 

1 User Settings 
  

1.1 User Data • 1.2 Password • 1.3 Credit Card Details • 1.4 Newsletter Settings 
Your customer details, which you provided when ordering your 1&1 package, are stored in 
1&1's database. 

You can view and modify them on the My Account page under 'User Settings'. The 
submenu items allow you to modify your address and e-mail address under 'User Data', 
change your password under 'Password', update your payment details under 'Credit 
Card Details', and subscribe to receive our 1&1 newsletter under 'Newsletter Settings'. 

1.1 User Data 
 

You can change your e-mail address, address, phone number, and fax number. It takes just 
a few minutes for our database to be updated. 
 

Your name and your company name cannot be changed online. If you would like to make 
changes, please send us a request by fax or mail to: 

1&1 Billing 
701 Lee Road  
Suite 300  
Chesterbrook PA 19087 
Fax: 1-610-560-1501 

 

If this information is used for your domain contact details, the information will be updated 
automatically at the respective registries. If you chose other information for your domains, 
please make sure to update that information in order to keep your WHOIS records up-to-
date. WHOIS records are set in the Package Administration area, under  'Domains' > 
'Contact'. 

1.2 Password 
  

Change your current password as often as needed. Make sure your chosen password 
contains between 6 and 8 alphanumeric characters. 
 

Keep your password in a secure place; you will need it for logging on to the Control Panel. 
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1.3 Credit Card Details 
 

Enter your credit card information, such as type, number and verification code, and 
expiration date. 

You will be asked to enter your card verification code (CVC). The CVC is a security feature 
used for credit card transactions made over the phone or Internet. This three or four digit 
code provides the card holder with an extra level of security.  

Card verification codes can be found:  

 On American Express cards, the code (known as the CID) is a four digit number on the 
front of the card written above the account number.  

 The code on Visa (known as the CVV2), MasterCard (known as the CVC2), and Discover 
(known as the CID) is a three digit number that appears at the end of the account 
number on the back of the card.  

If you have any further questions about the location of this number please call your credit 
card issuer for assistance.  

1.4 Newsletter Settings 
 

Our 1&1 newsletter e-mail keeps you informed about important developments regarding 
the Internet, new products and packages from 1&1, package rate changes, and other 
related news. 

You can subscribe to the 1&1 newsletter. You can also unsubscribe from the mailing list. If 
you later change your mind, you can resubscribe. 

When subscribing, choose whether you would like to receive the newsletter as a plain text 
e-mail or as an HTML formatted e-mail, and the e-mail address it should be sent to. If no 
other address is stated, the newsletter will be sent to the e-mail provided in your user data. 

Using a different e-mail address to receive the newsletter, will not alter your customer contact 
e-mail address (user data). 

 



 

99 

Windows® Hosting Manual, 1&1 Internet Inc.  

MY ACCOUNT: BILLING 

 

2 Billing 
 

2.1 Billing Overview • 2.2 Expense Tracker • 2.3 Expense Notifier 

Everything that you need to stay informed about your account with 1&1 is available under 
the Billing section. 

2.1 Billing Overview 
'Billing Overview' contains all invoices for your account under your customer ID. View 
your invoices or, if you would like to check up on a specific invoice, search for the invoice 
ID using the "Search" field on the overview page. 
 

The invoices displayed via this overview are purely informative. The bill relevant for tax 
purposes will be sent to you as a .pdf file by e-mail. 

2.2 Expense Tracker 
  

The Expense Tracker provides you with a daily summary of services you have used since the 
last billing date, including mailing lists and data transfer charges. 
 

The stated amounts do not include sales tax. The details are provisionally valid. The invoice 
issued at the end of every billing period is binding. 

2.3 Expense Notifier 
  

To specify the maximum amount you would like to spend for that billing period in a 
package, you can set up an expense notifier for each billing period for each package. 
When you reach 90% of this amount, you will be notified by e-mail that you are nearing 
your set expense limit.  

You will be notified by e-mail as soon as the set limit is reached. These e-mail messages 
will be sent to the e-mail address you specified under 'User Settings' > 'User Data'. 
 

The Expense Notifier does not block the services or features in any way. This is a service 
provided to help you keep track of your spending. 
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3 Affiliate Program 
  

3.1 Program Information • 3.2 Affiliate Link and Banners • 3.3 Sales Statistics 

To earn money as our affiliate, choose one of the available banners under 'Link & 
Banners' and include it in your website, or include your personal affiliate link in your 
e-mail. With our statistically reliable Affiliate Program, we can confirm without question if 
a new customer was gained directly through your banner or link. You will be paid a 
commission if a new customer comes through your link and then on that visit orders from 
our website. 

3.1 Program Information 
 

For the Terms and Conditions of this program, as well as, for the commissions, refer to 
'Affiliate Program' > 'Program Information' on the My Account page in your Control 
Panel. 

3.2 Affiliate Link and Banners 
  

Choose whether to add a link or a banner to your website. 

Affiliate Link 
Copy and paste your affiliate link into your e-mail signature. Show this link in e-mail, 
newsletters, or on your website. We will credit you with the commission, when a user 
clicks on the link, comes to our site, and orders a package. 

Banner Selection 
Select a banner to insert into your website by copying the HTML link and pasting it into a 
web page of your website. When a visitor to your website clicks on the banner and then 
places an order for a 1&1 product, you will receive a commission. 
 

WebsiteCreator (WSC) users cannot place this link in their websites, since it is not possible to 
edit the HTML code of a WSC websites. 

 

Double check that you have correctly entered the HTML code of your link or the link for the 
banner without any mistakes. In case the code is altered or partially omitted, 1&1 has no way 
of confirming that customers have come via your banner and cannot pay a commission. 
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3.3 Sales Statistics 
 

You can view your generated Affiliate Program sales on the Sales Statistics page. The 
statistics are updated continuously as you generate sales. 
 

This information can only be viewed after the first generated sale. Make sure that your banner 
or link is correctly built into your website. This is the only way that 1&1 records your sales 
generated from your affiliate link or banner. 

4 Messages 
 

Under this menu item, you will find customer ID messages, and messages concerning each 
package specifically. 

5 News 
  

Under this menu item, you will find additional product information on new products or 
features and special offers. 
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Microsoft® Script Languages  
1 Active Server Pages (ASP) • 2 Active Server Pages .NET (ASP.NET) 

1 Active Server Pages (ASP) 
 

1.1 Sending E-mail from ASP Pages Using AspMail • 1.2 Sending E-mail from ASP 
Pages Using CDOSYS • 1.3 Uploading Files with ASP (Soft Artisans™ FileUp) • 1.4 
Programming a Counter with ASP 
1&1 supports ASP (Active Server Pages) for all Microsoft® Hosting packages. ASP is a 
server-side scripting technology which is widely spread on Microsoft® platforms based on 
Internet Information Server (IIS). It is regarded as the counterpart to CGI scripts coded in 
Perl, or to PHP scripts, both used widely on UNIX® platforms.  

Using ASP enables you to easily combine web pages, script commands, and COM 
components to create interactive web pages or web-based applications. While ASP web 
applications may be programmed with any text editor, there are many tools such as 
Microsoft® FrontPage® which support ASP and provide convenient handling. For example, 
if you integrate an Microsoft® Access® database in your website using Microsoft® 
FrontPage®, it provides a readymade ASP script for the database query. You can find many 
free ASP example applications on the Internet which are ready to be used within your 
solution.  

1.1 Sending E-mail from ASP Pages Using AspMail  
 

AspMail is an Active Server Component designed to send e-mail from an Active Server 
Page. This component is installed on our servers. Below is a sample ASP script that uses the 
AspMail component to send information from a feedback form to an e-mail address. You 
can edit the following script to your requirements. 

For more information on AspMail please refer to the URL 
http://www.serverobjects.com/comp/Aspmail3.htm.  

forminfo.asp: 
<% @LANGUAGE="VBSCRIPT" CODEPAGE="1252"%> 
<html> 
<head> 
<title></title> 
<meta http-equiv="Content-Type" content="text/html; charset=iso-
8859-1"> 
</head>  
<body>  
<%  
Set Mail = Server.CreateObject("SMTPsvg.Mailer") 'create an AspMail 
component. 
Mail.FromName   = "1&1 Test" 
Mail.FromAddress= Request.Form("email") 

http://www.serverobjects.com/comp/Aspmail3.htm
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Mail.RemoteHost = "mrelay.perfora.net" ' The mail server you have to 
use with AspMail 
Mail.AddRecipient "ABCDE Company", "hello@domain-of-your choice.com" 
Mail.Subject    = "Website - Info Request" 
Mail.BodyText   = Request.Form("info") 
if Mail.SendMail then 
 Response.Write "Your mail has already been sent..." 
else 
 Response.Write "Mail send failure. Error was " & Mail.Response 
end if  
%>  
 
<body>  
<p>Thank You!!<br> 
</body> 
</html> 

 

Highlighted code contains crucial information. 

Sample Feedback Form: 
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> 
<html> 
<head> 
<title>AspMail Test Page</title> 
<meta http-equiv="Content-Type" content="text/html; charset=iso-
8859-1"> 
</head> 
<body background=""> 
<table width="100%" border="0" align="center"> 
  <tr class="medium">  
    <td width="54%" align="center" valign="top">  
     <form onSubmit="return ValidateForm()" method="post" 
action="forminfo.asp"> 
       Email Address:: <input name="email" type="text" id="email" 
size="41"></p> 
       Comments:: <textarea name="info" cols="35" 
rows="10"></textarea></p> 
       <input class="fancybut" type="submit" name="Submit" 
value="Submit Form"> 
       <input class="fancybut" type="reset" name="Submit2" 
value="Reset Form"></p> 
      </form></td> 
    <td width="16%" align="right" valign="top"></td> 
  </tr> 
  </table> 
</body> 
</html> 
 

Highlighted code contains crucial information. 

<form onSubmit="return ValidateForm()" name="form1" method="post" 
action="forminfo.asp">: 
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The action field should contain the name of the AspMail component. 

Mail.FromAddress= Request.Form("email")  
This line gets the e-mail address entered in the form.  

Mail.BodyText = Request.Form("info")  
The line gets the comments from the form.  

Mail.AddRecipient "ABCDE Company", "hello@domain-of-your-choice.com"  

 

An email will be sent to hello@domain-of-your-choice.com 

1.2 Sending E-mail from ASP Pages Using CDOSYS 
 

As standard ASP e-mail component you can use Windows® CDO (CDO 2.0 or CDOSYS). 
Use it for example to send e-mail from an ASP page in order to receive order or feedback 
messages.  

Here is a simple example: 

<!--METADATA TYPE="typelib"  
UUID="CD000000-8B95-11D1-82DB-00C04FB1625D"  
NAME="CDO for Windows 2000 Library" --> 
<!--METADATA TYPE="typelib"  
UUID="00000205-0000-0010-8000-00AA006D2EA4"  
NAME="ADODB Type Library" --> 
<% 
Dim objMail  
Set objMail = Server.CreateObject("CDO.Message")  
Set objConfig = Server.CreateObject("CDO.Configuration")  
'Configuration:  
objConfig.Fields(cdoSendUsingMethod) = cdoSendUsingPort 
objConfig.Fields(cdoSMTPServer)="smtp.1and1.com"  
objConfig.Fields(cdoSMTPServerPort)=25  
objConfig.Fields(cdoSMTPAuthenticate)=cdoBasic  
objConfig.Fields(cdoSendUserName) = "mxxxxxxxx-x" 
objConfig.Fields(cdoSendPassword) = "xxxxxxxx" 
'Update configuration  
objConfig.Fields.Update  
Set objMail.Configuration = objConfig  
objMail.From ="info@justonedomain.com"  
objMail.To = "support@1and1.com"  
objMail.Subject ="Information"  
objMail.TextBody="This is a test for CDO.message"  
objMail.Send  
If Err.Number = 0 Then 
  Response.Write("Mail sent!") 
Else 
  Response.Write("Error sending mail. Code: " & Err.Number) 
  Err.Clear 
End If 
Set objMail=Nothing  
Set objConfig=Nothing  
%> 
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Highlighted code contains crucial information. 

objConfig.Fields(cdoSMTPServer)="smtp.1and1.com"  
This line defines the outgoing server. 

objConfig.Fields(cdoSendUserName) = "mxxxxxxxx-x"  
This line specifies your e-mail user name. You find in your Control Panel on the 
Package Administration page under 'E-mail'.  

objConfig.Fields(cdoSendPassword) = "xxxxxxxx"  
This line contains the e-mail address's password which you have previously defined 
in the Control Panel and made a note of (  Set Up a New E-mail Address in the 
Control Panel page 21). 

1.3 Uploading Files with ASP (Soft Artisans™ FileUp)  
 

Soft Artisans™ FileUp enables you to use ASP to transmit files in any format from your local 
system to a Microsoft® IIS web server via a web browser. Before using FileUp, define the 
path the component is supposed to use when uploading. This means you specify the 
destination the files are being uploaded (saved) to. 

In the following example FileUp uploads the file to the path uploads\data. 

Make sure you set the write permission to the respective subdirectory (here: \data). If the 
write permission is not set appropriately, a "permission error" message will be returned 
when running the FileUp script.  

To learn how to set write permissions, refer to Webfiles page 94 in this manual. 

For more information on this component please refer to the URL 
http://support.softartisans.com/docs/FileUpV4/.  

upload_file.asp: 
<% @Language=VBScript %> 
<HTML> 
<HEAD> 
<TITLE>FileUp Upload Simple Sample</TITLE> 
</HEAD> 
<BODY> 
<% 
Dim oFileUp              
'--- Instantiate the FileUp object 
Set oFileUp = Server.CreateObject("SoftArtisans.FileUp") 
'--- Set the Path property to the location you wish to temporarily 
cache the incoming file before saving 
oFileUp.Path = Server.MapPath("uploads\data") 
'--- Check if a file was selected (myFile is coming from the html 
code) 
'--- If so, continue processing 
If Not oFileUp.Form("myFile").IsEmpty Then 
'--- Save the file 

http://support.softartisans.com/docs/FileUpV4/
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oFileUp.Form("myFile").Save 
'--- The file is saved, display a confirmation message 
Response.Write ("<B>File saved successfully on the server 
as:</B><BR>") 
'--- The ServerName() property is the full path of the file where it 
was saved on the server 
Response.Write(oFileUp.Form("myFile").ServerName) 
Else 
Response.Write("Error: There was no file submitted for upload.") 
End If 
'--- Destroy objects 
Set oFileUp = Nothing 
%> 
</BODY> 
</HTML> 

Sample Upload Form (upload_file_form.html) 
<HTML> 
<HEAD> 
<TITLE>FileUp Simple Upload Sample</TITLE> 
</HEAD> 
<BODY> 
<H3 ALIGN=center>&nbsp;</H3>  
<H3 ALIGN=center>Asp FileUp Upload Sample</H3>  
<p ALIGN=center>&nbsp;</p> 
<FORM ACTION="fileUp.asp" ENCTYPE="MULTIPART/FORM-DATA" 
METHOD="POST"> 
 <TABLE WIDTH="100%"> 
<TR> 
<TD ALIGN="RIGHT" VALIGN="TOP">Enter Filename:</TD> 
<!-- 
Note: Notice this form element is of TYPE="FILE" 
-->  
<TD ALIGN="LEFT"><INPUT TYPE="FILE" NAME="myFile" size="20"><BR> 
Please click Browse to select a file.</TD> 
</TR> 
<TR> 
<TD ALIGN="RIGHT">&nbsp;</TD> 
<TD ALIGN="LEFT"><INPUT TYPE="SUBMIT" VALUE="Upload File"></TD> 
</TR> 
</TABLE> 
</FORM> 
</BODY> 
</HTML> 
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1.4 Programming a Counter with ASP 
 

The following ASP script is an example how you can easily program a simple counter: 

<% 
counter_file = Server.MapPath("test.txt") 
Set fs = CreateObject("Scripting.FileSystemObject") 
Set a = fs.OpenTextFile(counter_file) 
counter = Clng(a.ReadLine) 
if Session("counter") = "" then 
Session("ct") = counter 
ccounter = counter + 1 
a.close 
Set a = fs.CreateTextFile(counter_file, True) 
a.WriteLine(counter) 
end if  
a.Close 
Response.Write counter 
%> 

 

Highlighted code contains crucial information. 

test.txt  
This file contains the counter data. 

2 Active Server Pages .NET (ASP.NET) 
 

2.1 Tools for Creating ASP.NET Applications • 2.2 Tips for Creating ASP.NET 
Applications • 2.3 Restrictions in Hosting ASP.NET Applications • 2.4 Sending 
E-mail Using ASP.Net • 2.5 Redirecting to a Different Website or Folder Using 
ASP.NET • 2.6 Creating 404 Error Pages in .NET 
Depending on the Windows® Hosting package you chose, Active Server Pages .NET 
(ASP.NET) is included as well. ASP.NET is the efficient successor technology to ASP which 
allows the creation of dynamic and interactive web contents. 

The main advantages of ASP.NET are enhanced performance, better tool support and 
greater flexibility, as well as high scalability, security and availability. ASP.NET web 
applications can be written in many programming languages, for example VB.NET, C++, 
C#, J#, etc. You can develop ASP.NET web applications either with a simple text editor, or 
with elaborate tools such as the free Web Matrix or Visual Studio.NET to design the 
application visually without tampering functionality. ASP.NET is state-of-the-art and best 
choice for all kinds of web-based applications in the Microsoft® Shared Hosting package. 
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2.1 Tools for Creating ASP.NET Applications  
 

Use any text or HTML editor to create ASP.NET applications. For the programming of more 
complex web applications however, we recommend the use of an integrated development 
environment, allowing you to comfortably use advanced .NET Framework features. 
Microsoft® offers two development environments for this purpose.  

 Freeware: Web Matrix (http://www.asp.net/webmatrix/default.aspx) 
 Commercial development environment: Visual Studio .NET 

(http://msdn.microsoft.com/vstudio/). 
Web Matrix is exclusively designed to create ASP.NET applications. Among other things, 
the tool includes a graphic designer and database support.  

Visual Studio .NET is also suitable for creating classical Windows applications and includes 
advanced features for ASP.NET such as CodeBehind (i.e. clear separation from code and 
design).  

For most online applications the free Web Matrix is quite sufficient, particularly since apart 
from the tool you can also download the Microsoft® Database Engine (MSDE). With the 
combination of these two tools you already possess a well coordinated development 
platform for all 1&1 Windows packages.  

Alternatively to the tools offered by Microsoft, you can use also the open source 
development tool SharpDevelop 
(http://www.icsharpcode.net/OpenSource/SD/Default.aspx). 

2.2 Tips for Creating ASP.NET Applications  
 

During the development phase, it is usually helpful to set within the configuration file 
web.config the value <customErrors mode="Off" /> in order to receive a 
detailed error message when problems arise. The default value for this option reads 
<customErrors mode="RemoteOnly" /> (see NET Framework SDK documentation). 
However, when operating your application the detailed error messages should be switched 
off again for safety reasons, otherwise in case of an occurring error, safety-relevant 
information — for example database passwords — may be displayed.  

By default, we configure in the IIS (Internet Information Server, web server) an application, 
which points to your home directory. Such an application is necessary to make an ASP.NET 
application executable at all.  

If you intend to publish with Visual Studio .NET directly on the server (menu item 'Project' 
> 'Copy Project'), you first need to activate FrontPage® Server Extensions for your package 
(  FrontPage® Server Extensions page 16) in the 1&1 Control Panel. If you define a 
subdirectory for publishing (ex. http://www.domain-of-your-choice.com/application1), 
Visual Studio .NET creates a further application for your project in each case. 

http://www.asp.net/webmatrix/default.aspx
http://msdn.microsoft.com/vstudio/
http://www.icsharpcode.net/OpenSource/SD/Default.aspx
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When using Visual Studio .NET make sure in the 1&1 Control Panel's Domain Overview that 
your domain points to the home directory. If the Domain points to a subdirectory, FrontPage 
and Visual Studio .NET will not work properly.  

 

Troubleshooting: Visual Studio .NET  

Problems may occur when copying the application into a subdirectory (ex. /application2) via 
FTP. Then a separate application is not automatically created in the IIS. When using 
CodeBehind (either produced by Visual Studio .NET, or compiled manually), sometimes a .DLL 
referenced in the ASPX page cannot be found. This produces the error message "Could not 
load type... ".  

The ASPX engine cannot find the referenced DLLs, because the server searches for them 
directly under the application path (usually your directory) in the subdirectory /bin and not 
under /application2/bin, where files usually are after an FTP upload. Copy the files in the 
directory /bin to solve this problem. 

2.3 Restrictions in Hosting ASP.NET Applications  
 

As web host, we need to make sure that the resources on our systems are distributed fairly 
and that no single application has a negative effect on the other applications or on the 
whole system. Therefore, we have defined a "trust level" for the use of ASP.NET 
applications that restricts certain features of the .NET Framework.  

For instance, no ASP.NET application may access the registry or carry out file accesses 
outside a particular user directory. Also, the execution of "unmanaged code" (i.e. code 
that is not administrated by the .NET Framework and which, for instance, carries out its 
own storage administration) is not permitted. 

You will not be able to access a Microsoft® Access® database via ODBC or OLEDB because 
these procedures still contain such "unmanaged code". If you want to run ASP.NET 
applications with a database, use Microsoft’s SQL server and the corresponding 
classifications in the .NET Framework (System.Data.SqlClient) instead.  

The other restrictions set by the trust level are of little relevance to the majority of ASP.NET 
applications. They include the non-availability of IsolatedStorage and the barring of the 
system’s environment variables. For safety and performance reasons, server-sided tracing 
or debugging of ASP.NET applications is not permitted. Any non-present or non-accessible 
backend services such as MessageQueues, DirectoryServices, Printing or 
PerformanceCounter cannot be addressed via an ASP.NET application. 
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Other restrictions concern: 

 Accessing the .NET Framework's isolated storage 
 Using the local printers 
 Controlling the security relevant infrastructure like ControlAppDomain, ControlEvidence, 

RemotingConfiguration, UnmanagedCode and others 
 Accessing the registry 
 Accessing confidential environment variables 
 Creating or opening network sockets 
 Accessing the system event log 
 Accessing system performance counters 
 Using the .NET Framework Data Provider for OLEDB and ODBC 

2.4 Sending E-mail Using ASP.Net  
 

In order to be able to send e-mail using ASP.NET, you have to use the namespace 
System.Web.Mail and the appropriate class MailMessage  

For example: 

<% @Import Namespace="System.Web.Mail" %> 
<script language="vb" runat="server"> 
 
Sub contactUS_Click(sender as Object, e as EventArgs) 
 
  'Create an instance of the MailMessage class 
  Dim objMM as New MailMessage() 
 
  objMM.To = "info@1and1.com" 
  objMM.From = email.Text 
 
  'If you want to CC this email to someone else 
  'objMM.Cc = "support@1and1.com" 
 
  'email format. Can be Text or Html 
  objMM.BodyFormat = MailFormat.Text 
 
  'Set the priority - options are High, Low, and Normal 
  objMM.Priority = MailPriority.Normal 
 
  'Set the subject 
  objMM.Subject = "1&1 Contact US" 
 
  'Set the body 
  objMM.Body = message.Text 
  
  'Smtp Server 
  SmtpMail.SmtpServer = "mrelay.perfora.net" 
   
  'Send the message 
  SmtpMail.Send(objMM) 
  panelSendEmail.Visible = false 
  panelMailSent.Visible = true 
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End Sub 
</script> 
<html> 
<body> 
  <asp:panel id="panelSendEmail" runat="server"> 
    <form runat="server"> 
      <h2>CONTACT US FORM</h2> 
 
      <b>Your Name:</b> 
      <asp:textbox id="name" runat="server" /> 
      <br> 
 
      <b>Your Email Address:</b> 
      <asp:textbox id="email" runat="server" /> 
      <p> 
 
      <b>Your Message:</b><br> 
      <asp:textbox id="message" TextMode="MultiLine" 
                      Columns="40" Rows="10" runat="server" /> 
      <p> 
      <asp:button runat="server" id="contact_us" Text="Contact" 
OnClick="contactUS_Click" /> 
    </form> 
  </asp:panel> 
  <asp:panel id="panelMailSent" runat="server" Visible="False"> 
    An email has been sent. We will contact you soon! 
  </asp:panel> 
</body> 
</html> 

2.5 Redirecting to a Different Website or Folder Using ASP.NET  
 

The following example redirects s12312312.onlinehome.us to http://1and1.com and usa-
test.com to usa-test.com/www/index.htm (redirecting to a different folder): 

<script runat="server" Language="c#"> 
public void Page_Init(Object Src, EventArgs E) 
{ 
 switch((Request.ServerVariables["HTTP_HOST"]).Replace("www.","")) 
  { 
   case "s12312312.onlinehome.us": 
    Response.Redirect("http://1and1.com"); 
    break; 
  case "usa-test.com": 
    Response.Redirect("http://usa-
test.com/www/index.htm"); 
    break; 
  default: 
   Response.Redirect("http://1and1.com"); 
   break; 
 } 
} 
</script> 

http://1and1.com/
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2.6 Creating 404 Error Pages in .NET 
 

To create your own 404 error pages insert the following code in your web.config file or 
create a new file containing this code in your home directory: 

<configuration> 
  <system.web> 
    <customErrors mode="On"> 
      <error statusCode="404" redirect="error404.htm"/> 
    </customErrors> 
  </system.web> 
</configuration> 
 

Substitute the status code and, if needed, the redirect file which should be referred to 
when the defined error occurs. In this example, an error 404 (Page not found) is referred 
to error404.htm. Of course, a dynamic error page is the preferable solution, for example to 
bring broken links to the webmaster's attention by e-mail.  

An according ASP.NET page may look like this: 

<%@ Page Language="C#" Debug="false" ContentType="text/html" 
ResponseEncoding="iso-8859-1" %> 
<% @Import Namespace="System.Web.Mail" %> 
<script runat="server" Language="c#"> 
public void Page_Load(Object Src, EventArgs E) 
{ 
    string httpHost = Request.ServerVariables["HTTP_HOST"]; 
 
    MailMessage mail = new MailMessage(); 
    mail.To = "webmaster@" + httpHost; 
    mail.From =  "webmaster@" + httpHost; 
    mail.Subject = "A broken link was found at " + httpHost; 
    mail.Body = "The page " + = 
     Request.QueryString.Get("aspxerrorpath") + " could " + 
DateTime.Now.ToString("d") + " at " + 
     DateTime.Now.ToString("t") + " on " + httpHost + " not be 
found."; 
    SmtpMail.SmtpServer = "mrelay.perfora.net"; 
    SmtpMail.Send(mail); 
} 
</script> 
 
<html> 
 
<head> 
<meta http-equiv="Content-Language" content="en"> 
<meta http-equiv="Content-Type" content="text/html; 
=charset=windows-1252"> 
<title>Error 404</title> 



 

113 

Windows® Hosting Manual, 1&1 Internet Inc.  

MICROSOFT® SCRIPT LANGUAGES: ACTIVE SERVER PAGES .NET (ASP.NET) 

</head> 
 
<body> 
 
<p align="center"> 
 <font size="1" face="Verdana, Arial, Helvetica, sans-
serif"> 
 <b><font color="#999999" size="7" face="Arial">Error 
404</font><br></b> 
 <font color="#999999"> The requested File<% 
Response.Write(" <b><i>" 
+ Request.QueryString.Get("aspxerrorpath") + "</i></b>"); %> 
 was not found<% Response.Write(" on " + 
Request.ServerVariables["HTTP_HOST"]); %>.<br> 
 
 <b>Back to <a href="../../default.aspx"> 
    <font color="#999999">Homepage</b></font></a> 
    </font> 
</p> 
 
</body> 
 
</html> 
 

In this example, the webmaster automatically is sent an e-mail, whenever the error page 
(ex. error404.aspx) is called up. Since the script sends an e-mail to the webmaster each 
time the error page is called up, the detected file which is no longer existent should be 
intermediately saved to avoid the webmaster receiving the same message several times. 
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Microsoft® Databases 
1 Microsoft® Access® • 2 Microsoft® SQL Server 

1 Microsoft® Access® 
 

1.1 Connecting to Access® Database Using ASP Script • 1.2 Add or Update a 
Database Record Using ASP 

Microsoft® Access® is an easy-to-use database that provides many powerful capabilities. 
Uploading the database to the hosting server is easy. This can be used immediately with 
common SQL commands. Microsoft® Access® is suitable for many purposes. Use it for a 
simple product catalog to maintain product data such as product name, product ID, 
description, and price in relational tables. Customers see and order products from this 
catalog on your website. If you use Microsoft® FrontPage® for web authoring, it is 
especially easy to connect one or more Microsoft® Access® databases to your website. 
Besides ActiveX® Data Object (ADO) we support the Object Linking & Embedding (OLE) 
database data access provider. OLE DB provides a flexible database architecture offering 
efficient access to Microsoft® data stores and is only available in ASP.  

1.1 Connecting to Access® Database Using ASP Script  
 

<title>Database query using ASP</title> 
<body bgcolor="FFFFFF"> 
<h2>Query table <b>Products</b> with ASP</h2> 
<% 
DSN = "DRIVER={Microsoft Access Driver (*.mdb)};DBQ=" & 
Server.Mappath("../db/products.mdb") & ";" 
Set OBJdbConnection = Server.CreateObject("ADODB.Connection") 
OBJdbConnection.Open(DSN) 
SQLQuery = "SELECT * FROM PRODUCTS" 
Set RS = OBJdbConnection.Execute(SQLQuery) 
%> 
<% 
Do While Not RS.EOF 
%> 
<%=RS("name")%>, <%=RS("description")%>, <%=RS("price")%> DM 
<p> 
<% 
RS.MoveNext 
Loop 
RS.Close 
Set RS = Nothing 
OBJdbConnection.Close 
Set OBJdbConnection = Nothing 
%> 
</body> 
</html> 
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In order to make a query to a database, you need a connection. The target address is the 
"Data Source Name" (DSN) on the server.  

DSN = "DRIVER={Microsoft Access Driver (*.mdb)};DBQ=" & 
Server.Mappath("../db/products.mdb") & ";"  

 

Server.Mappath is the most important one. By default all 1&1 Windows packages have a 
"db" folder. Place your databases (.mdb) in that folder only! 
 

The database is also set up as an ODBC interface under this name, so it can also be reached 
under this name.  

 

The example given is just one of many different ways of creating a connection to an ODBC 
database. As far as performance is concerned, there is not much difference between the 
various methods, so the final choice is a matter of personal preference. 

Set OBJdbConnection = Server.CreateObject("ADODB.Connection") 
OBJdbConnection.Open(DSN)  

 

These statements open a connection to the database. You can now query the database. 
The connection can stay open for as long as queries are being asked.  

OBJdbConnection.Close 
Set OBJdbConnection = Nothing  

 

Make sure to close the connection once you are done querying the database. Only then 
will the memory resources be released. It is always good to have as few connections as 
possible open at one time. 
 

Troubleshooting: Connecting to Access® with ASP  

Never under any circumstances do the following to determine the number of lines received: 

Do While Not RS.EOF  
i = i + 1 
RS.MoveNext 
Loop 
RS.MoveFirst  

The system will have to go through the entire record and all its columns without using any of 
the data in there. This takes time, the page takes longer to load, and the database connection 
is open for longer (remember, there is a limit to the number of connections that can be open 
at the same time). 

To get the number of lines received, you can issue the database's own command: 
strQuery = "SELECT Count(name) FROM exampletable WHERE name = 
'John'"RS_2.Open strQuery  

RS_2(0) then issues the number of lines. 
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Client Cursor  
"client cursor" can be set up using the feature RS.CursorLocation. This instantly copies all 
of the data that is required in the Recordset. The cursor is then put on the client rather 
than, as is usual, on the server. This way, the connection can be closed immediately after 
the query, but it may slow down the performance a little. So if it is not absolutely essential, 
the cursor really should stay on the server (default). 

Arranging Several Queries  
If you use several queries or Recordsets (ideally with the same connection) in a page, make 
sure to close the various queries as promptly as possible instead of closing the Recordsets 
at the end of the final query. The web server does not process your page as a whole, but 
rather in lines. 

Buffer Variables  
The most efficient way of working is to write database output (records) in variables at the 
outset so they can be read later. Buffers such as these can really save a lot of time, even 
with smaller charts of less than 10 lines. Often the database connection can be closed 
before the web server sends even a single character to the client. For instance, the 
functions RS.GetRows (data in a two-dimensional array) or RS.Save (Recordset as a Stream 
or FileObject).  
 

For safety reasons it is not possible to access an Access® database using ODBC or OLEDB. If 
you liked to operate ASP.NET applications with database, you need to use the MS SQL server 
and the associated classes of the .NET Framework (System.Data.SqlClient) instead. In the 
1&1 Control Panel we offer an Access® database import option into the SQL server. 

1.2 Add or Update a Database Record Using ASP  
 

The following is an example script used to insert new values in the database. 

Before you execute this script, change the permissions of your database to have "write" 
permissions set (  Webfiles page 94). 

<html> 
<title>Database query using ASP</title> 
<body bgcolor="FFFFFF"> 
<h2>Query table <b>Products</b> with ASP</h2> 
<% 
DSN = "DRIVER={Microsoft Access Driver (*.mdb)};DBQ=" & 
Server.Mappath("../db/products.mdb") & ";" 
Set OBJdbConnection = Server.CreateObject("ADODB.Connection") 
OBJdbConnection.Open(DSN) 
SQLQuery = "Insert into products values ('item2', 'good product', 
'300', 4)" 
OBJdbConnection.Execute(SQLQuery) 
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OBJdbConnection.Close 
Set OBJdbConnection = Nothing 
%> 
</body> 
</html> 

 

The following is an example script used to update the records in the database. 

<html> 
<title>Database query using ASP</title> 
<body bgcolor="FFFFFF"> 
<h2>Query table <b>Products</b> with ASP</h2> 
<% 
DSN = "DRIVER={Microsoft Access Driver (*.mdb)};DBQ=" & 
Server.Mappath("../db/products.mdb") & ";" 
Set OBJdbConnection = Server.CreateObject("ADODB.Connection") 
OBJdbConnection.Open(DSN) 
SQLQuery = "UPDATE products SET price = '100' where id =1" 
OBJdbConnection.Execute(SQLQuery) 
 
OBJdbConnection.Close 
Set OBJdbConnection = Nothing 
%> 
</body> 
</html> 
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2 Microsoft® SQL Server 
 

2.1 Accessing Your MS SQL Database Using ASP Script • 0  
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Accessing Your MS SQL Database Using ASP.NET • 2.2 Importing Access® 
Databases into Your MS SQL Database • 2.3 Stored Procedures in MSSQL • 2.4 
Event-Controlled Procedures (Trigger) 

Depending on the Windows® Hosting package you chose, Microsoft® SQL Server is 
included. With Microsoft® SQL Server 1&1 offers you a powerful database server providing 
state-of-the-art features. It is therefore recommended for any larger website and 
demanding web applications with greater amounts of data or higher data exchange. On 
Microsoft® platforms SQL Server is the best choice regarding performance and scalability. 
The Microsoft®  SQL Server has extensive XML support and also provides advanced 
programming technologies like stored procedures database trigger, or Full Text Indexes.  
 

For security reasons, 1&1 offers ASP.NET in combination with a Microsoft® SQL Server 
database only. 

 

If you exceed the 150 MB limit, you cannot add anymore data unless you remove old data 
first.  

 

To keep your data secure, access to the MS SQL server is only possible through the 
1&1 Control Panel, ASP, or ASP.NET scripts that run on 1&1 servers.  

2.1 Accessing Your MS SQL Database Using ASP Script 
 

Log in to the 1&1 Control Panel, and on the My Account page choose the package you 
would like to work on by clicking on it. This will bring you to the Package Administration 
page. There, go to 'Applications' > 'MS SQL Administration' and retrieve the following 
access data: 

 database name 
 user name 
 host name 
 password. 

Make a note of this information. Use the following ASP script to connect to your SQL 
database and query a table. 
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Sample ASP Script  
<html> 
<title>Queries from the MS-SQL database with ASP</title> 
<body bgcolor="FFFFFF"> 
<h2>Query from table <b>products</b> with ASP</h2> 
<% 
Set conn = Server.CreateObject("ADODB.Connection") 
conn.open "PROVIDER=SQLOLEDB;DATA 
SOURCE=mssqxxx.1and1.com;UID=dboxxxxxxxxx;PWD=xxxxxxxx;DATABASE=dbxx
xxxxxxx" 
'This code block will create a recordset 
Set rs = Server.CreateObject("ADODB.Recordset") 
SQL = "select * from products" 
rs.open SQL, conn 
'will iterate to display the records got from the database 
While Not rs.EOF 
  response.write(rs("id") & " " & rs("price")) 
  rs.MoveNext 
Wend 
'closes the connection 
rs.close 
conn.close 
Set rs = Nothing 
Set conn = Nothing 
%> 
</body> 
</html> 

Highlighted code contains crucial information: 

DATA SOURCE is the hostname. 

UID is the user name. 

PWD is the password. 

DATABASE is the database name. 

 

Memory resources on the server will only be released with the corresponding directives: 

rs.close, conn.close, Set rs = Nothing, Set conn = Nothing 

Access® to MS SQL databases is only possible with ASP scripts. For security reasons, you 
cannot access the database servers directly through the Internet.  

Please note that under no circumstances may the database be used for log evaluation processes (ex. ivw), add-clicks, chat systems, banner rotations or any other applications that put high loads on the database.  
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Accessing Your MS SQL Database Using ASP.NET 
 

 (This option is not supported for all packages.) 

Log in to the 1&1 Control Panel, and on the My Account page choose the package you 
would like to work on by clicking on it. This will bring you to the Package Administration 
page. There, go to 'Applications' > 'MS SQL Administration' and retrieve the following 
access data: 

 database name 
 user name 
 host name 
 password. 

Make a note of this information. Use the following script to connect to your SQL database 
and query a table. 

<%@ Page Language="VB" %> 
<script runat="server"> 
    Sub Page_Data 
     Dim oDR as System.Data.SQLClient.SQLDataReader 
        Dim oCom As System.Data.SQLClient.SqlCommand 
        Dim oConn as System.Data.SQLClient.SQLConnection 
        try 
            oConn = New System.Data.SQLClient.SQLConnection  
("server=mssqlxxx.1and1.com; initial 
catalog=dbxxxxxxxxx;uid=dboxxxxxxxxx;pwd=xxxxxxxx") 
   oConn.Open() 
   oCom = New System.Data.SQLClient.SqlCommand() 
   oCom.Connection = oConn 
   oCom.CommandText = "SELECT * FROM products" 
   oDR = oCom.ExecuteReader() 
   While oDR.Read 
       Response.Write(oDR.Item("id") & ", " & 
oDR.Item("price")) 
       Response.Write("<BR/>") 
      End While 
        catch 
            Response.Write("Error:" & err.Description) 
        Finally 
         oDR = Nothing 
         oCom = Nothing 
         oConn.Close() 
         oConn = Nothing 
        end try 
    End Sub 
</script> 
<html> 
<title>Queries from the MS-SQL database with ASP</title> 
<body bgcolor="FFFFFF"> 
<h2>Query from table <b>products</b> with ASP.NET</h2> 
<%Page_Data()%> 
</body> 
</html> 

 

Highlighted code contains crucial information: 
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server is the hostname. 

initial catalog is the database name. 

uid is the user name. 

pwd is the password. 

2.2 Importing Access® Databases into Your MS SQL Database 
 

Once your MS SQL database has been set up in the Control Panel you can import your 
Access® database into it.  

Import Preliminaries 
First, check whether your database structure complies to the rules specified below. If you 
adhered to the fundamental database design, an import into the MS SQL database is 
possible without any problems for both Access® 97 and Access® 2000/XP databases. The 
MS SQL server will adopt defined relations accordingly. If you are not sure whether the 
restrictions indicated below apply to your database, simply try to import the database — 
you will be notified whether the procedure was successful or not. 
 

To test whether your database can be imported into the MS SQL database correctly, we 
recommend you use an empty database (i.e., only the database structure). This way, you do 
not need to spend time uploading the complete database each time. Repair and compress 
your database in Access® before the upload.  

 

Start the import procedure in your Control Panel by clicking on the button 'Import'. After 
about two hours you recognize in the list of your Access® databases whether the 
procedure was successful or not. If the import procedure was not successful, you will be 
notified, which table contained an error.  
 

Repair and compress your database in Access® before the upload.  

Import Restrictions 
Since Access® differs from the SQL server in some aspects, the following characteristics of 
your Access® database cannot be adopted. Therefore, we recommend you check your 
database for these aspects before importing it.  

 User rights and groups 
User rights, user and group definitions as defined in Access® are not supported by the 
SQL database. If your database is currently attached to its own user group file, reverse 
this as follows: First, set up a new database. Next, import all tables from the 
protected database into it. Relations are taken over. 

 Included tables and queries are generally not adopted.  
 Indices on yes/no fields on SQL servers will not work and are ignored. 
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 Hyperlinks are not defined on SQL servers. Therefore, the import tool takes over columns 
defined as hyperlink as normal text and delimits them using the following format: 
#<hyperlink> #.  

 All function call-ups within the table definition are ignored. In the table definition, only 
defined validity rules and messages as well as defined default values are adopted, which 
do not need a function call-up (i.e. expressions as for example?=date()? are not seized).  

Importing Several Access® Databases 
If needed you can import several Access® databases into your SQL server database. But 
when doing so, consider the following: 
 

Any existing tables in the SQL server database are overwritten without further inquiry by 
tables of the same name of the Access® database you are importing! Therefore, make sure 
you do not import two tables of the same name from different Access® databases. If you do, 
an already existing table of the same name is deleted without further inquiry.  

 

A storage location of 150 MB is reserved for the MS SQL server tables. MS SQL databases can 
be accessed only via CGIs and ASP scripts, which are implemented on your website. For 
security reasons, you cannot access the database servers directly via Internet.  

 

The database may under no circumstances be used for log evaluation procedures (ex. ivw), 
add-clicks, chat systems, banner rotations or the similar demanding applications producing 
too much load on the servers. 
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Importing Access® Databases into the MS SQL Server 
Upload the Access® (.mdb) files in the _db_import folder. To do this, establish an FTP 
connection ( FTP, Web Space, and Access page 33) or a FrontPage® connection (  
FrontPage® Server Extensions page 16). 

The files have to be uploaded prior to importing the database structure! 

Next, log in to the 1&1 Control Panel, and on the My Account page choose the package 
you would like to work on by clicking on it. This will bring you to the Package 
Administration page. There, go to 'Applications' > 'MS SQL Administration'. On the 
page that opens select 'Import'.  

 
Figure 39: Select 'Import' on the MS SQL Database Overview page. 
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Figure 40: Select the database from the drop-down menu. Click on 'Import' again. 

Clicking on 'Import' will start the import process. You can view the status of the import 
on the MS SQL Administration page. 

 
Figure 41: The import status is shown on the Import Progress page. 
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2.3 Stored Procedures in MSSQL  
 

Stored procedures are SQL command sequences, which by pre-compilation and caching on 
the server can be implemented considerably faster than normal command batches. 
Compared to normal SQL commands traffic between database servers and web servers can 
be substantially reduced with the abbreviated call-up of a stored procedure. 

Send MSSQL procedures using the SQL command you find in your 1&1 Control Panel 
under 'Applications' > 'MSSQL Administration'. Click on 'Admin' and enter the FTP or 
FrontPage access data (see chapter...). This will connect you to your MS SQL server. Click 
on the link 'Send SQL command'. In order to see a list of your existing procedures, 
including corresponding code, use the following syntax. 
 

Make sure the tick box "Statement returns data (Query)" is checked! 

SELECT name, text FROM sysobjects LEFT JOIN syscomments ON 
sysobjects.id = syscomments.id WHERE type = 'P' AND category = 0  

 

The following example provides a procedure with the name "ProcedureName". In the third 
line the actual SQL command is defined which adds a data record in the table 
"TargetTable", whereby in the field "TargetField" the value "InsertValue" is set. 

CREATE PROCEDURE ProcedureName 
as 
INSERT INTO TargetTable (TargetField) VALUES('InsertValue') 

 

With the following syntax the procedure can be carried out:  

EXECUTE ProcedureName  
 

You can abbreviate EXECUTE as EXEC. In order to make changes to a stored procedure, 
proceed as follows:  

OLD PROCEDURE ProcedureName  
as  
INSERT INTO TargetTable (TargetField)  
VALUES('OtherInsertValue') 

 

For deleting a stored procedure, the syntax is almost identical to that for creating and 
changing it:  

DROP PROCEDURE ProcedureName  
 

Of course, you can hand over parameters when calling up a procedure, for example to 
accordingly adapt the SQL commands connected with the procedure and thus also the 
results resulting from it.  
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For example: 

Script 6: Creating Procedure 

CREATE PROCEDURE ProcedureName 
@zfid int 
as 
SELECT TargetField FROM TargetTable where TargetField = @zfid 
 

Script 7: Calling Up Procedure 

Call EXEC ProcedureName 99  
It is not possible to receive an output of this example in the Control Panel's "SQL Server 
Administration". For further information on Stored Procedures visit 
http://msdn.microsoft.com/library/default.asp?url=/library/en-
us/createdb/cm_8_des_07_31vb.asp. 

2.4 Event-Controlled Procedures (Trigger)  
 

Triggers are event-controlled procedures, which are released with an action defined before 
(ex. with an update of a specific table).  

Script 1: Creating Triggers  

CREATE TRIGGER TriggerName ON TargetTable FOR INSERT 
as 
INSERT INTO Table (Column1) VALUES('Value1') 
 

With this syntax, a trigger with the name "TriggerName" is created, which executes with 
each INSERT command in the table "TargetTable" the SQL command "INSERT INTO table 
(Column1) VALUES('Value1')"; this in return results in an INSERT in the second table 
(perhaps to create a detail data record, etc.).  

Script 2: Deleting Triggers  

DROP TRIGGER TriggerName 
 

Script 3: Changing Triggers  

ALTER TRIGGER TriggerName ON TargetTable FOR INSERT 
as 
INSERT INTO Table (Column1) VALUES('Value1') 
 

In order to receive a list of all available triggers of the current database including SQL 
commands, enter the following command:  

SELECT name, text FROM sysobjects LEFT JOIN syscomments ON 
sysobjects.id =  
 
syscomments.id WHERE type = 'tr'  
 

 

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/createdb/cm_8_des_07_31vb.asp
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/createdb/cm_8_des_07_31vb.asp
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We hope you enjoy working with your Windows® Hosting package and that you found the 
contents of this manual helpful.  

Do not hesitate to contact us with any problems or issues concerning your &1 package. 
You can also find our contact information on our website http://1and1.com and in the 
Need Help? section of the Control Panel.  

 

1&1 Internet Inc. 
701 Lee Road 
Suite 300 
Chesterbrook, PA 19087 
 

www.1and1.com  

 

1. Edition — August 2004 

 

http://1and1.com/
http://www.1and1.com/


 

129 

Windows® Hosting Manual, 1&1 Internet Inc.  

INDEX 

Index 
A 
Access...................See Microsoft databases: 

Access 
Active Server Pages ............................... 107 
Active Server Pages .NET ....................... 112 
Add-on-a-domain-process...........................  

See Domains: Add-on-a-domain process 
admin-c .......... See Domains:Contact details 
Affiliate link and banners ............................  

See My account: Affiliate Program 
Affiliate Program.........................................  

See My account: Affiliate Program 
ASP....................................................... 107 

AspMail ........................................... 107 
Counter ........................................... 112 
Feedback form................................. 107 
Sending e-mail................................. 107 
Sending e-mail (CDOSYS) ................ 109 
Uploading files................................. 110 

ASP.NET................................................ 112 
Creating 404 error pages................. 117 
Hosting restrictions .......................... 114 
Redirecting addresses....................... 116 
Sending e-mails ............................... 115 
Tips for creating applications ........... 113 
Tools................................................ 113 

Auto-responder ..........................................  
See E-mail: E-mail: Auto-.responder 

B 
Basic CGIs ............................................... 93 

Guest book, forum,feedback form..... 93 
Use in Control Panel .......................... 93 
Visitor counters,date/time displays ..... 95 

Billing (Control Panel)..................................  
See My account: Billing 

Bul E-mail....................................................  
See Newsletter Tool: Bulk E-mail/Spam 

C 
Catch-all account........................................  

See E-mail: Catch-all account 
CDOSYS......................................................  

See ASP:Sending e-mail (CDOSYS) 

Comma separated value (CSV) files.............  
See Newsletter Tool: Importing addresses 

Control Panel............................................ 6 
Structure.............................................. 6 

General........................................... 6 
My account................................. 7, 8 

System requirements............................ 6 
Usage .................................................. 9 

Credit card details (Control Panel)...............  
See My account: User settings:  
Credit card details 

CSV files .....................................................  
See Newsletter Tool: Importing addresses 

D 
Dedicated Secure Socket Layer (SSL) 

certificate...............................................  
See Domains: Dedicated Secure Socket 
Layer (SSL) certificate 

DNS pointing ..............................................  
See Domains: Point DNS away,  
See Domains: Add on external domain 

DNS Settings...............................................  
See Domains: Changing DNS settings 

Domain forward .........................................  
See Domains: Domain forward 

Domain name system (DNS) settings ...........  
See Domains:Changing DNS settings 

Domains 
Add on external domain .................... 17 
Add-on-a-domain process.................. 14 
Changing DNS settings ...................... 17 
Contact details................................... 21 
Dedicated Secure Socket Layer (SSL) 

certificate...................................... 24 
DNS settings 

Troubleshooting ........................... 20 
Domain forward ................................ 23 
Domain Overview Page...................... 12 
Filter features..................................... 14 
FrontPage server extensions ............... 21 
Home directory .................................. 22 
Moving domains from one package to 

another......................................... 20 
Moving internal domains ................... 20 
Order a new domain.......................... 15 
Point DNS away ................................. 18 



 

130 

Windows® Hosting Manual, 1&1 Internet Inc. 

INDEX  

Registration ........................................15 
Registration time ................................15 
Search features...................................14 
Shared Secure Socket Layer (SSL) 

encryption .....................................23 
Sorting features..................................14 
Subdomains .......................................23 
Top level domains...............................15 
Transfer of registrar ............................16 

Troubleshooting ............................17 

E 
E-mail ......................................................25 

Account .............................................27 
Auto-responder ..................................29 
Catch-all account ...............................30 
Delete delivery targets ........................29 
Delete e-mail addresses ......................30 
Delivery targets...................................27 
External domain names ......................37 
Filter and sorting features...................26 
Forward..............................................28 
Incoming messages ............................31 
Local mail programs ...........................31 

Netscape .......................................32 
Outlook Express.............................31 

Mailbox ..............................................27 
New e-mail address ............................26 
Overview page ...................................25 
POP3 mailbox .....................................27 
Search features...................................26 
Sorting features..................................26 
Troubleshooting .................................37 
Virus protection..................................30 
WebMail ............................................33 

error 404 pages........................................... 
See ASP.NET:Creating 404 error pages 

Event-controlled procedures ........................ 
See Microsoft databases:SQL server: 
Event-controlled procedures 

Expense notifier (Control Panel) ................... 
See My account: Exense notifier 

Expense tracker (Control Panel) ................... 
See My account: Expense tracker 

External domain .......................................... 
See Domains: Add on external domain 

F 
File transfer protocol................................38 
File transfer protocol login data ...............39 
FileUp..................... See ASP:Uploading files 

FPSE ............................................................  
See Domains: FrontPage server extensions 

FrontPage server extensions.........................  
See Domains: FrontPage server extensions 

FTP ..........................................................38 
Troubleshooting 

WS_FTP .........................................41 
WISE-FTP ............................................39 
WS_FTP ..............................................40 
WS_FTP Pro ........................................40 

FTP login data..........................................39 

G 
Geotrust ......................................................  

See Domains: Dedicated Secure Socket 
Layer (SSL) certificate 

H 
Help ........................................................... i 

Contact ................................................. i 
FAQs ..................................................... i 

Home directory............................................  
See Domains: Home directory 

I 
Importing Access databases.........................  

See Microsoft databases:SQL 
server:Importing Access databases 

in2site .....................................................90 
Use in Control Panel ...........................92 

in2site Live Dialogue Plus.........................92 
Internal domains..........................................  

See Domains: Moving internal domains 
Internet browser 

Transfer website data .........................42 

L 
Log files............. See WebStatistics: Log files 

M 
Messages (Control Panel).............................  

See My account: Messages 
Microsoft Access .........................................  

See Microsoft databases:Access 
Microsoft databases 

Access ..............................................119 
Connecting with ASP ..................119 
Editing database records with ASP121 

Connecting to Access with ASP 



 

131 

Windows® Hosting Manual, 1&1 Internet Inc.  

INDEX 

Troubleshooting.......................... 120 
SQL server........................................ 123 

Connecting with ASP.................. 123 
Connecting with ASP.NET........... 125 
Event-controlled procedures ....... 131 
Importing Access databases ........ 126 
Stored procedures ...................... 130 

Microsoft Outlook Express ..........................  
See E-mail: Local mail programs: Outlook 
Express 

MS SQL Database ................................... 97 
Access via Control Panel .................... 97 
Setup SQL server................................ 97 

MSSQL server..............................................  
See Microsoft databases:SQL server 

My account 
Affiliate Program.............................. 105 

Information................................. 105 
Link and banners ........................ 105 
Sales statistics ............................. 106 

Billing .............................................. 104 
Expense notifier ............................... 104 
Expense Tracker ............................... 104 
User settings .................................... 102 

Credit card details....................... 103 
Newsletter settings ..................... 103 
Password .................................... 102 
User data .................................... 102 

My account........................................... 102 
My account 

Messages......................................... 106 
My account 

News ............................................... 106 

N 
Netscape.....................................................  

See E-mail: Local mail programs: Netscape 
News (Control Panel) ..................................  

See My account: News 
Newsletter settings (Control Panel) .............  

See My account: User settings: Newsletter 
settings 

Newsletter Tool....................................... 74 
Addresses .......................................... 77 
Blacklist ............................................. 88 
Bounced e-mails ................................ 87 
Bulk E-mail/Spam............................... 90 
Creating addresses............................. 85 
Customizing additional fields ............. 89 
Editing newsletters............................. 83 
Importing addresses........................... 85 

Newsletter creation............................ 77 
Newsletter editor ............................... 80 
Newsletter test................................... 83 
Subscription forms............................. 89 
System requirements.......................... 76 
Usage ................................................ 77 
Variables............................................ 82 

P 
Package administration ........................... 11 
Password (Control Panel) ............................  

See My account: User settings: Password 
POP3..................See E-mail: E-mail: Mailbox 
Protected directories ...................................  

See Web access: Protected directories 

R 
reg-c ............... See Domains:Contact details 

S 
Shared Secure Socket Layer (SSL) encryption

See Domains: Shared Secure Socket Layer 
(SSL) encryption 

Software licenses .................................. 101 
SpamSee Newsletter Tool: Bulk E-mail/Spam 
SQL server...................................................  

See Microsoft databases:SQL server 
SSL certificate .............................................  

See Domains: Dedicated Secure Socket 
Layer (SSL) certificate 

SSL encryption ............................................  
See Domains: Shared Secure Socket Layer 
(SSL) encryption  

Stored procedures.......................................  
See Microsoft databases:SQL server:Stored 
procedures 

Subdomains........See Domains: Subdomains 

T 
tech-c ............. See Domains:Contact details 
Transfer of registrar ....................................  

See Domains: Transfer of registrar 
TriggersSee Microsoft databases:SQL server: 

Event-controlled procedures 

U 
User data (Control Panel) ............................  

See My account: User settings: User data 



 

132 

Windows® Hosting Manual, 1&1 Internet Inc. 

INDEX  

User settings (Control Panel)........................ 
See My account: User settings 

V 
Virus protection........................................... 

See E-mail: E-mail: Virus protection 
Visual Studio .NET 

Troubleshooting ...............................114 

W 
Web access........................................38, 42 

Protected directories...........................42 
Web space.........................................38, 42 

Protected directories...........................42 
WebDatabase..........................................69 

Calendar database..............................71 
Customize a database ........................72 
Delete database..................................74 
Design and HTML fields ......................73 
Examples ............................................70 
Integrate database..............................74 
Link list ...............................................71 
News database ...................................70 
Recipe database .................................70 
Set up a database...............................72 
Use in Control Panel ...........................72 
View, search, delete entries ................73 

WebElements ..........................................63 
Contact form......................................64 
Control Panel .....................................66 
Customize form..................................67 
Delete form ........................................69 
Event registration form.......................64 
Integrate form ....................................68 
New form...........................................66 
Order form .........................................63 
Request information form ..................66 
Show statistics....................................68 
Tell-a-friend form ...............................65 
View or delete entries.........................68 
Voting form........................................65 

Webfiles ..................................................99 
WebMail..................................................33 

Address book .....................................36 
Check inbox .......................................34 
Log out ..............................................36 

Send message to multiple addresses...36 
Signature............................................36 
Write e-mails ......................................35 

WebsiteCreator (WSC 
Bonus features) ..................................47 

WebsiteCreator (WSC).............................43 
Assign to domain ...............................45 
Examples ............................................43 
Launch ...............................................45 
Manage layout ...................................47 
Manage pages....................................46 
Preview ..............................................49 
Publish ...............................................49 
System requirements ..........................44 
Troubleshooting .................................50 
Usage.................................................46 

WebsiteCreator (WSC) Plus......................50 
Photo albums .....................................49 

WebStatistics...........................................53 
Basic settings......................................55 
Geography statistics ...........................58 
Launch in Control Panel......................55 
Log files..............................................62 
Pages statistics....................................60 
Referrer statistics ................................57 
Statistical evaluations..........................55 
Technology statistics...........................59 
Troubleshooting .................................62 
Visitor statistics...................................56 

WISE-FTP .................................................39 
WS_FTP ...................................................40 
WS_FTP Pro .............................................40 
WSC........................................................43 

Assign to domain ...............................45 
Bonus features ...................................47 
Examples ............................................43 
Launch ...............................................45 
Manage layout ...................................47 
Manage pages....................................46 
Preview ..............................................49 
Publish ...............................................49 
System requirements ..........................44 
Troubleshooting .................................50 
Usage.................................................46 

WSC Plus.................................................50 
Photo albums .....................................49 

 



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Gray Gamma 2.2)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.1000
  /ColorConversionStrategy /sRGB
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Remove
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
    /Arial-Black
    /Arial-BlackItalic
    /Arial-BoldItalicMT
    /Arial-BoldMT
    /Arial-ItalicMT
    /ArialMT
    /ArialNarrow
    /ArialNarrow-Bold
    /ArialNarrow-BoldItalic
    /ArialNarrow-Italic
    /ArialUnicodeMS
    /CenturyGothic
    /CenturyGothic-Bold
    /CenturyGothic-BoldItalic
    /CenturyGothic-Italic
    /CourierNewPS-BoldItalicMT
    /CourierNewPS-BoldMT
    /CourierNewPS-ItalicMT
    /CourierNewPSMT
    /Georgia
    /Georgia-Bold
    /Georgia-BoldItalic
    /Georgia-Italic
    /Impact
    /LucidaConsole
    /Tahoma
    /Tahoma-Bold
    /TimesNewRomanMT-ExtraBold
    /TimesNewRomanPS-BoldItalicMT
    /TimesNewRomanPS-BoldMT
    /TimesNewRomanPS-ItalicMT
    /TimesNewRomanPSMT
    /Trebuchet-BoldItalic
    /TrebuchetMS
    /TrebuchetMS-Bold
    /TrebuchetMS-Italic
    /Verdana
    /Verdana-Bold
    /Verdana-BoldItalic
    /Verdana-Italic
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 150
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 150
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.76
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /ColorImageDict <<
    /QFactor 0.76
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 15
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 15
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 150
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 150
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.76
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /GrayImageDict <<
    /QFactor 0.76
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 15
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 15
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects true
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile (None)
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName ()
  /PDFXTrapped /False

  /Description <<
    /CHS <FEFF4f7f75288fd94e9b8bbe5b9a521b5efa7684002000410064006f006200650020005000440046002065876863900275284e8e55464e1a65876863768467e5770b548c62535370300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c676562535f00521b5efa768400200050004400460020658768633002>
    /CHT <FEFF4f7f752890194e9b8a2d7f6e5efa7acb7684002000410064006f006200650020005000440046002065874ef69069752865bc666e901a554652d965874ef6768467e5770b548c52175370300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c4f86958b555f5df25efa7acb76840020005000440046002065874ef63002>
    /DAN <>
    /ESP <>
    /FRA <>
    /ITA (Utilizzare queste impostazioni per creare documenti Adobe PDF adatti per visualizzare e stampare documenti aziendali in modo affidabile. I documenti PDF creati possono essere aperti con Acrobat e Adobe Reader 5.0 e versioni successive.)
    /JPN <>
    /KOR <FEFFc7740020c124c815c7440020c0acc6a9d558c5ec0020be44c988b2c8c2a40020bb38c11cb97c0020c548c815c801c73cb85c0020bcf4ace00020c778c1c4d558b2940020b3700020ac00c7a50020c801d569d55c002000410064006f0062006500200050004400460020bb38c11cb97c0020c791c131d569b2c8b2e4002e0020c774b807ac8c0020c791c131b41c00200050004400460020bb38c11cb2940020004100630072006f0062006100740020bc0f002000410064006f00620065002000520065006100640065007200200035002e00300020c774c0c1c5d0c11c0020c5f40020c2180020c788c2b5b2c8b2e4002e>
    /NLD (Gebruik deze instellingen om Adobe PDF-documenten te maken waarmee zakelijke documenten betrouwbaar kunnen worden weergegeven en afgedrukt. De gemaakte PDF-documenten kunnen worden geopend met Acrobat en Adobe Reader 5.0 en hoger.)
    /NOR <>
    /PTB <>
    /SUO <>
    /SVE <>
    /ENU (Use these settings to create Adobe PDF documents suitable for reliable viewing and printing of business documents.  Created PDF documents can be opened with Acrobat and Adobe Reader 5.0 and later.)
    /DEU <>
  >>
>> setdistillerparams
<<
  /HWResolution [600 600]
  /PageSize [612.000 792.000]
>> setpagedevice


