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Introduction 

Welcome to AC3D 
 
 
AC3D is designed to make the construction of 3d objects fast and easy to do.  It 
is used to create 3D models for games, rendering ray-traced images, and for 
scientific and general data visualisation. 
 

 
 
AC3D runs on a wide range of standard hardware and is available across a 
number of popular platforms. 

AC3D terminology 
 
Vertex 
A vertex is a single point in 3d space.  It’s specified by three coordinates x, y 
and z.   More than one vertex can occupy the same position in 3d space.  A 
vertex is always owned by a single object, they cannot be shared between 
objects.  A vertex is usually part of a Surface, but need not be. 
 
Surface 
A surface in AC3D is a list of vertices.  Surfaces are one of three types; 
polygons, lines or polygon outlines.  The type of a surface can be easily 
changed.  A surface normal specifies the direction a surface is facing.  Normals 
are used in lighting calculations.  Surface normals are automatically calculated 
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by AC3D.  A surface is facing the viewer if the vertices can be seen in an anti-
clockwise direction.  If a surface is set to be single sided, it will only be visible 
from the front.  Two sided surfaces will be visible from both sides.  It is more 
efficient to draw single sided surfaces and makes more sense when used as part 
of an object such as a sphere (where you can’t see the other side of the 
surfaces).  Surfaces have a material attribute, which defines the color and 
quality (for lighting purposes).  Each vertex referenced in a surface has an 
associated texture coordinate.  Vertices can be shared between surfaces in the 
same object. 
 
Object 
An AC3D object is a list of vertices, and surfaces that use these vertices.  It also 
has other attributes such as a name and texture.  
 
Group 
A group is a special object that has no surfaces or vertices but has other objects 
as children. Groups are created by selecting two or more objects and selecting 
‘Group’ from the edit menu, or toolbar. 
 
Material 
A material defines the color of a surface and also the attributes that define the 
way it will react to light e.g. shininess. 
 
Texture 
Graphical images can be mapped onto the surfaces of an object.  The images 
are usually from graphics files such as gif, jpg, bmp etc. 
 
Texture coordinates 
When the vertex of a surface is drawn, a texture coordinate specifies the 
position of a texture to map to that point.  A texture coordinate is a two 
dimensional (u,v) value. 
 
Bounding box 
When you make a selection of objects or vertices, a green box outlines it.  You 
can drag, resize or rotate this box to adjust the contents 

 

Windows/Views 
 
AC3D has a control panel, on the left, plus 4 other windows - three 2D 
orthographic views and a 3D view. There’s also the menu and toolbar at the top 
and an information bar along the bottom. 
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Control Panel 

This is where the main controls over the selection and draw 
modes are located.  It also contains the surface-type controls, 
the palette of materials and the object name field. 
 
The top of the control panel shows information about the current 
selection.  When the mouse is being used to interact with 
models, this area will also display current positions, distances 
moved and other related information. 

 

Toolbar 
This contains buttons for some of the most commonly used functions. 
 

 
 
All – select everything. 
None – clear the selection. 
Del – delete the selected objects/surfaces or vertices. 
Dup – duplicate the selection. 
Cut, Copy, Paste – uses AC3D’s internal clipboard. 
Group, Ungroup – put selected objects into a group/remove the group object 
Flip XYZ – flip the section about this axis 
200%/50%/+10%/-10% - scale the selection. 
XY/ZY/XZ/3D/ALL – Maximise a single view or view ALL together 

Orthographic views 
 
The orthographic views consist of three 2 dimensional windows.  These windows 
allow selection and model manipulation (moving and resizing).  Each 
orthographic view shows a two dimensional view of the 3d world (front, side, 
plan).  Although it’s useful sometimes to work in a single view, seeing all the 
windows at once can be very helpful when positioning objects and laying out 
scenes.   
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The dividers between the 4 view windows can be dragged to resize the views.  
Individual views are maximized by clicking on the view buttons at the top right of 
the main window (alternately, the F1-F5 keys can be pressed to switch between 
the different view configurations).  
 
The main window size/position and other settings are saved when exit AC3D. 
 
The items on the ‘Orth’ menu control how the windows are drawn and what 
components are visible. 
 
The grids 

In the orthographic windows, there are two grids - the draw grid and the snap 
grid. Both can be set from 'File->settings' and can be toggled by pressing the 
switches at the bottom of the control panel.  

The draw grid displays visual guide lines in the orthographic windows.  

The snap grid (if on) will snap moving/resizing/creating mouse movements to 
nearest grid points. The Snap grid is shown by thin grid lines, the draw grid uses 
thicker lines.  

Both grids don't need to be set the same but they can be. 

 
Using Background Images 

 
Each of the orthographic (2D) windows can 
display a background image.  This can be 
very useful for tracing shapes or laying out 
objects in relation to some scanned image 
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e.g. a map.  Background images are set and unset from the View menu.   All the 
image formats that are supported by AC3D's texture loaders can be used.  
 
The view menu contains items to Load and clear background images. 
 
Background images will scale and 
move with the views.  By default, the 
image will be centred on the origin.  
The scale and position of the 
background image is by adjusted using 
alt and the cursor keys.  Alt and the 
cursor keys, reposition the image, whilst 
Alt+Shift plus cursor up/down scale the 
image. 

 
Details of background images are not 
saved with models or when AC3D exits. 
 

The 3D view 
The 3D view displays the current model in three dimensions and changes instantly 
when any modifications are made to the current model. The 3D window is 
primarily for viewing your models but also allows selection of objects, surfaces 
and vertices (depending on the current Select-mode) by holding down the control 
key and clicking/dragging. 
 
Two navigation modes are available in this window – ‘spin’ and ‘walk’. These can 
be switched in the 3D menu or by pressing the ‘1’ or ‘2’ keys whilst the pointer is 
in the 3D window. 

A 3d grid is available - toggle with 'g'. The grid is lies on the XZ plane (floor).   

Press 'w' to toggle between wireframe and filled drawing, 't' toggles textures. 'l' 
toggles the fixed light.  See the 3D menu for more viewing options. 

Getting help 

User interface components in AC3D have 
‘balloon help’.  Small ‘tooltip’ windows will 
popup when the mouse pointer rests over a 
button or field label. 

When browsing through the menu items, the 
function on each item is described in the 
message text at the bottom of the AC3D window. 
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Creating AC3D objects 

AC3D Surfaces 
Objects in AC3D consist of a list of vertices and 
a number of surfaces that reference those 
vertices.  A surface may be one of three types; 
Polygon, Polyline or Line. A polygon is a filled 
area, a Polyline is a wire-frame outline of the 
polygon (a loop that joins the start vertex to the end), a line has a specific start 
and end.  
   

Surface type is changed by pressing a button 
on the control panel. The Surface-type buttons 
are located at the bottom of the control panel 
(Poly, Polyline, Line):  

This panel also contains controls to set surfaces to be smooth ‘SM’ or flat ‘FL’. This 
determines the way that a polygon is drawn (it has no effect on lines or 
polylines):  

If a surface is flat-shaded, the colour across 
the surface will be constant. If it is shaded then 
the colour will be 'graded' depending on 
lighting conditions.  

Vertices can be shared between surfaces (i.e. 
one or more surfaces use the same vertex).  If these surface types are set to 
‘smooth’, the effect is of one continuous 'smooth' surface. The vertices MUST be 
shared for two surfaces to be smoothed together. This method of shading allows 
smooth looking objects to be created from relatively simple shapes.  

The '1S' and '2S' buttons select how many sides a surface has (one-sided or two-
sided). If a surface is single sided, it will only be visible from one side. The 
following pictures aims to demonstrate this:  

     

In this simple model, there are three objects - a green rectangle, a red rectangle 
and a blue ellipse (made by creating an ellipse object and setting the surface 
type to be POLY). The red rectangle has been set to be single-sided '1S'. This 
means that it is visible from the 'front' but not from the back (the second image 
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shows the whole model rotated). Objects such as spheres and cubes, which do not 
have any interior surfaces visible, benefit from a speed optimization when being 
drawn with the surfaces single-sided.  

Surface normals 

The direction a surface is facing is determined by its 'Normal' (indicated by 
arrows in the above diagram). This is a 3D graphics term for a line at right 
angles to the surface that indicates a direction. ).  Normals are used to calculate 
surface colors and shading when the objects in AC3D are drawn. For smooth 
shading, vertex normals are automatically calculated by averaging normals of 
all connected surfaces. 

Normals can be visualised in both the orthographic and 3d views (‘Normals’ on 
the ‘orth’ and ‘3d‘menus).  This preview is useful for solving problems where, for 
example, some surfaces in an object are the wrong way around (this can cause 
surfaces to appear missing if they are one-sided, or the smoothing can appear 
uneven.  Viewing the normals is also useful for use with the extrude function and 
can help determine the extrude settings that ensure that new surfaces face in the 
correct direction. 

This picture shows two spheres.  The sphere on the left shows correct normals (i.e. 
all facing outwards).  The sphere on the right shows some surfaces facing in the 
wrong direction.  Notice how 
the shading is not consistent.   

AC3D automatically 
calculates the normals (both 
surface and vertex). 

To flip the direction of a 
surface, use Surface->Flip 
normal. (This actually reverses the order of the vertices in the surface so that the 
automatically generated normal faces the opposite way).   

 
 

Creating new objects 
The AC3D control panel contains a number 
of 2D and 3D object shapes that can be 
created: 
 
New objects are created by selecting one of 
these buttons and clicking/dragging in one 
of the orth. windows.  
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Polys/polylines/lines 

To create a poly/polyline/line, click to position each point and either double-
click or press the middle or right mouse button to end. The surface type can be 
altered later from the control panel if you need a different type.  

These objects consist of a list of vertices and a single surface.  The surfaces from 
more than one of these objects can be collected together into a single object by 
using the Object->Merge function. 

Polygons should be 3 or more points.  Concave polygons are handled by AC3D. 
They can be converted to triangles by using the Surface->triangulate function. 

It is possible to draw a line or poly in different windows - creating a non-planar 
object. This makes sense with lines but is not correct for a polygon which should 
have all it's points on the same plane.   Invalid polygons i.e. polygons that have 
less than three vertices or have crossing edges are displayed in a cyan color.   

To draw shapes that have vertices in the same position as an existing shape, use 
the ‘nearsnap’ function.  The switch at the bottom of the AC3D window is used to 
control this.  When this is on, the next point drawn will ‘snap’ to the nearest 
existing vertex (when there is a vertex within a certain range). 

Spheres, boxes etc. 

 

 

Creating a 3D object by dragging the mouse in a window specifies two of the 
dimensions for the new object - the third dimension is an average of the original 
two. The location of the object in the third dimension is specified by the 3D 
cursor.  The 3D cursor is shown in the orthographics views by a cross.  This is 
repositioned by holding down the Alt key and dragging the mouse. Most people 
rarely use this because it is very easy to 
create an object and position it later.  

Some object types allow parameters to be set 
before creating the object. E.g. spheres and 
Meshes can be made from triangles or quads.  
Controls for any available parameters will appear in the control panel 
underneath the mode box. 
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When created, AC3D Objects are 
automatically named. The object name box 
is at the bottom of the control panel and 
allows these names to be set. 

Object names can only be edited/set in 
Group or Object select mode.  Object names need not be unique and can be the 
same across multiple objects.  This can be useful for selecting or finding 
particular objects with the Edit->select-by-name function (e.g. to select all 
objects named ‘chair’). Object names are used in some of the file formats 
exported by AC3D. 

If AC3D is being used to generate VRML or Dive files, URLs and other text can 
be associated with objects. This text is used in a number of the export file 
formats that AC3D generates.  The names, text and urls are saved in the .ac 
AC3D files.  Text attached to each object is entered into the field on the Tools-
>Object Data window.   Object names can also be set in the same dialog. 

Creating other objects 

It is very easy to create other objects from these shapes.   E.g. to make a torus 
shape (‘donut’), create an ellipse and select the Object->revolve menu. 

A cone can be made in a number of ways. Create a cylinder; select one end (in 
vertex mode) and select Vertex->snap-together. A cone made this way will have 
the texture coordinates set correctly. For a simpler cone (fewer vertices), no 
texture map), optimize the vertices with Object->Optimize-vertices. This means 
that the centre-point of the cone will be a single vertex which is shared with all 
the sides. Some other ways of making cones are - make a 'disk' and pull the 
centre point up; revolve a line around an axis. To add a  base to the cone, select 
the bottom vertices and select the menu item: 'Vertex->Create surface/object'.  

‘Extrude’ is used to add extra parts to objects or to give 2d shapes depth.  
Objects can be cut into pieces and specific surfaces deleted. 
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Lights 
Lights have no associated geometry and represent a ‘point light’. 
Lights are represented by this symbol:  
 
This symbol is not shown in the 3D window but the effects of the light on other 
objects in the scene will be noticeable.  

Lights are fixed brightness white lights.  Lights are selected and repositioned in 
Group or Object select mode.  

Lights are generated in POV files and RIB files.  The generated files can be 
edited to alter the lighting attributes.  

This image shows a green sphere with two lights 
(indicated by white spheres) - the main headlight 
is off. (The headlight in the 3D window is toggled 
on and off with the 'l' key, or from the ‘3D’ menu). 
If the headlight is on when POV or RIB files are 
generated, a light will be added to information in 
the file.  

 

Text 
Tools->Add-Text is a function that 
creates text from a special AC3D file. 
An AC3D font file contains a set of 
objects that are treated in a similar way 
to a text font. The font file can be 
viewed by simply loading it in to AC3D. 
Objects are named to be letters in the 
alphabet (and other symbols too). Add-Text takes a string (e.g. your name) and 
duplicates these objects, laying them out next to each other. The text is created 
at the origin (0, 0, 0) and will usually be facing so that it's viewable in the XY 
(side) window. This text can be selected and moved, resized, or rotated just like 
other AC3D objects.  The Extrude function can be used to make this text three-
dimensional. 
 
  
 

Making your own fonts 

A file for use with Tools->Add-Text is a normal AC3D file with named objects. - 
Objects have their centres (origins) ‘minimized’ (set using the Object->Minimum 
centre function). To view object-centres, ensure that the '+' button is on (at the 
bottom of the control panel). This point is used when lining up text objects. The 
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point is taken as the start of the 'character' and the width of the object is 
measured so that the next character can be placed the correct distance along 
the line, without overlapping. The font file should be designed to be viewed from 
the front in the XY window, since these coordinates are used for positioning the 
font objects.  

The Add text function can be useful for storing a library of objects e.g. furniture. 
Each object can only be indexed by a single character.  

To create accurate 3D text objects from TrueType fonts (as used by Windows 
etc), use Font3D to generate DXF files and import them into AC3D. Font 3D is 
free to download from http://www.checkpoint.net/font3d/ 

 
Registered users benefit from a special Font3D plugin.  

 

http://www.checkpoint.net/font3d/
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Selecting, resizing and moving 
In AC3D the manipulation of 3D objects 
works in a very similar way to a 2D drawing 
program. I.e. the selection is shown 
highlighted and ‘handles’ can be moved to 
reshape the section. 
 
The majority of selection and manipulation is 
done through the orthographic windows 
although selection is possible via the 3D view. 
 
Selected components (surface, vertices) are shown in a different colour and are 
surrounded by a ‘bounding box’ (usually green).  
 

 
 

Selection is possible in mode/size, rotate 
and extrude modes.  The default mode is 
move/size. 
 
Note that the extrude button is disabled in this picture – it’s enabled only in 
surface select mode. 
 

Selecting  

 

The Select-mode defines the granularity of 
selection i.e. it determines if selections will 
affect objects, groups or vertices.  To select 
in AC3D, either click the left mouse button or use the left mouse button to drag a 
box over an area. When something is selected, the Bounding-Box that appears 
can be dragged or resized directly affecting the points/surfaces/objects.  
 
In Vertex mode, vertices are selected by a single click on a single vertex or by 
dragging a box over a number of vertices. In Surface-mode, a surface is 
selected by a click or dragging a box over an area.  In Object-mode, selecting 
any part of an object causes the whole object to be selected. In Group-mode, a 
group of objects can be selected by highlighting any part of a single object that 
belongs to a group. 
 
There is an important difference between a click-select and a drag select.  Click 
selects are used for selecting single entities e.g. one object, one surface, one 
vertex.  A click select will select the nearest entity underneath the pointer.  A 
drag-select will select everything within the drawn box that lies underneath the 
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region. Click-select is useful, for example, when selecting a single surface of a 
sphere (where a drag select will always select more than one surface). 
 
Selections are preserved between changes of select modes.  Changing from 
vertex to surface select-mode means that any surfaces that have all vertices 
selected will remain selected in surface-mode.   

Moving 

The green bounding box is dragged with the 
left mouse button to reposition the selection.  
Holding the control key down whilst dragging, 
constrains movement to up/down or left/right 
only.  

 

Resizing 

Drag the ‘handles’ in the corners of the 
bounding box using the left mouse-button, to 
resize the selection.  On the edge handles, 
hold the control key down whilst moving the 
mouse to resize opposite edges.   

Note that it is possible to resize a selection 
down to zero width.   This is useful for lining up 
vertices.  

   

Extending/Negating the selection 

Holding down the shift key whilst selecting with the left mouse button, extends the 
selection (adds new entities) and pressing shift whilst selecting with 2nd (or 3rd) 
mouse button to negate (subtract) items from the current selection.  

Extend and negate selection work in all select modes.  

This picture shows the top and bottom of a sphere selected. This is done by first 
selecting the top vertices with a drag.  Holding down 
the shift key and dragging across the bottom of the 
sphere. 
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Clearing the selection 

Clicking the outside the area of the bounding box will cause everything to 
become unselected 

The selection can also be cleared by pressing the ‘None’ button in the toolbar or 
from the menu Edit->select-nothing. 

Selecting in the 3D window 

This works in the same way as selecting/extending and negating in the orth 
windows, but requires the control key to be held down. 

Hiding objects 

Hiding allows objects to be temporarily 
removed from the views.   The current 
selection, or objects that are not selected, can 
be hidden from view. The 'unhide' button ensures that all objects are visible. The 
'3d' toggle determines if the hidden objects are visible in the 3d window.  Hiding 
is useful when access is needed to work on obscured objects. 

 

Locking objects 

This is useful for temporarily disabling objects 
that are obscuring others.  When objects are 
locked, it’s not possible to select them. 

Locking also helps with the speed performance when editing large models. It 
works in a similar way hiding, only that locked objects are drawn in grey 
wireframe. Wireframe surfaces take less time to draw compared to filled 
surfaces.  

Note that if objects are hidden (or locked) and the model is saved/exported, 
hidden/locked objects are included in the file.  
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Navigation and viewing 

Moving and zooming the orthographic views 
 

 
Dragging the mouse when holding down the middle button ‘pans’ the window. 
The right mouse-button zooms (magnifies and minifies).  Alternatively, holding 
down the control key and using the right mouse button will pan the view. 
 
The views in the orthographic windows can also be repositioned with the cursor 
keys. Pressing shift with the cursors keys moves in larger steps. To zoom in and 
out, use control and the cursor keys (or 'z' to zoom-in, 'x' to zoom out).  
 
The window zoom can be set to be the same for all 2D windows from the settings 
dialog (File->edit settings menu), otherwise windows will have independent zoon 
settings.  
 

Navigation in the 3D window 

There are two viewing modes accessible by pressing '1' and '2' in the 3d window 
(or by selecting the menu items in the '3d' menu):  

Spin mode 

In 'spin' mode, holding down the left mouse button and dragging the mouse 
rotates the view. Holding down the right mouse button and dragging the mouse 
vertically zooms (scales) the view. Middle mouse button dragging will ‘pan’ the 
view. Alternatively, holding down the control key and using the right mouse 
button will also pan the view. 

The cursor keys can also be used to control the spin (control plus up/down zoom 
in/out). 

Walk mode 

In ‘walk’ mode, the cursor keys work in a similar way to 'Doom/Quake'. The '2' 
key switches into this mode ('1' switches back to spin mode). Cursor up/down 
moves forwards/backwards, cursor keys left/right turn. Pressing control with the 
cursor keys up/down tilts the view position and alt moves (pans) left, right, up, 
down.   

Walking can also be controlled with the mouse - the left button turns and moves 
forward and backward, the right button controls up/down/left/right movement.  

 



AC3D User Manual 21 

Resetting views  

Press the 'space' key to center that windows about the origin and reset the zoom 
levels.  

Viewing the selection 

Press 'f' to fit the current selection into the current window. 'F' fits the selection to 
all windows. Control-F fits the whole model into all views.  Use 'g' to 'goto' the 
current selection - the window will centre about the centre of the selection. 'G' 
centres all windows.   These options are also in the View menu.  

Three functions available from the View menu allow you to centre the 3D view 
about the selection, the cursor (that is positioned with ALT-click in the 2D 
windows), and reset to view the origin.  
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Model manipulation 

Operations on objects 
These operations are on the ‘Object’ menu and act upon one or more selected 
objects. 
 
Revolving 

Revolving makes copies of the selected objects, rotating each copy, then creating 
surfaces between the copies. It’s recommended that this function be used to 
revolve 2D outlines of shapes rather than filled-polygon objects. Any revolved 
line objects are automatically removed after the revolution. The axis to perform 
the revolution about can be altered.  

To create a torus - make a circle in 
the Front window:  

 

Select 'Object->Revolve…'  

 

Set the axis to Y and click 
Revolve. You should see 
something like this: 

 

 

 

Select the 
'smooth' surface 
type (near the 
bottom of the 
control panel) to 
make it appear 
rounded  
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The degrees of revolution can also be altered 1-360 degrees: 

 

 

     

If there are points that need to be in the centre of the final revolved object - 
(e.g. the start and end points of the cup profile above) then these points must lie 
exactly on the axis. Drawing the line with ‘gridsnap’ can ensure this.  
Alternatively, snapping the points to the grid (Vertex->snap to grid) or by using 
the control panel Move-to function to ensure that two of the values are zero. If 
these points are not exactly on the axis, a small hole or possibly overlapping 
surfaces will be created. If this happens, the 'Vertex->snap together' function 
and optimize vertices can be used to remove duplicate points.  

Optimize Vertices 

This function removes duplicate vertices from each selected object. For vertices to 
be removed, an object must own the vertices and they much match the same 
position exactly. The function will share one vertex between each connected 
point. This means that vertex normals can be calculated if smooth shading is 
required. This function also removes duplicate vertex references from the surface 
- something that might cause a bad polygon.  If vertices do not match the same 
position, Vertex->snap-together or Vertex->snap-together-by-distance can be 
used to move them to the same point.  

Optimize Surfaces 

This function removes any duplicate surfaces and any polygons that consist of 1 
or 2 vertices (these may exist if vertices have been deleted from an object). 
AC3D highlights invalid polygons by displaying them as cyan lines. 
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Re-centre 

Object centres define the local origin of AC3D objects.  Object centres can be 
seen by switching on the '+' button at the bottom of the control panel. This 
function re-centres this origin at the objects centre of gravity. This can be useful 
for specifying where the pivot points or local-origin of an object are.  

Minimum-centre 

This function sets the object's origin to the minimum xyz of the object. It is used to 
create AC3D fonts for the Tools->Add-Text function.  

Fragment 

Fragment creates one object per surface of the original 
object so that each object contains only one surface and 
the necessary vertices.  This image shows a sphere that 
has been fragmented.  The new objects have been moved 
apart. Notice that the surfaces are no longer 'smoothed' 
together - this is because each surface is now a separate 
object and vertices cannot be shared across objects.  

Merge 

This function places all of the surfaces from the selected objects into one single 
object. This does not optimize the vertices so that they are shared. (select 
'optimise vertices after merging to create a more efficient object and/or get 
smooth shading across adjacent surfaces) 

Explode 

This is similar to fragment, but each new object is moved 
forward (in the direction the surface is facing) by a specified 
amount. This picture shows an exploded cube. 

Subdivide surfaces 

This function is used to ‘smooth’ the edges of an object.  This picture shows four 
cubes.  The first is a standard box; the others have had surface subdivision 
applied one two and three times. 
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The same objects with their surface set to ‘Smooth’ (SM button on control panel): 

 

Note that this function always creates triangles.  Each subdivision quadruples the 
number of triangles in an object. 

Reduce 

This function reduces the number of vertices (and polygons) whilst trying to retain 
as much of an objects original shape as possible.  This is useful for saving on 
storage space and for speeding up the rendering of complicated objects.  This 
function can be used to create different objects that will be shown at different 
distances (LOD – level of detail).  E.g. a car object should be viewed close up 
with all polygons but from a distance, a more simple shape is adequate and can 
save drawing time. 

 

A target percentage specifies the proportion of vertices that are to remain.  E.g. 
If an object has 100 vertices and 80% is entered, the final object will contain 80 
vertices.   

The original object can remain in the model, or it can be replaced with the new 
object.  If the original object is kept, the new object will be created in the same 
position and will be selected. 
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An example: 

 

732 surfaces, 376 vertices 

 

Reduced by to 40% gives: 

 

276 surfaces, 150 vertices – A saving of 456 polygons. 

The reduce window remains visible so that different reductions can be tried (use 
Edit->Undo to revert to the previous state). 

 

 

Operations on surfaces 
 
Extruding 

Extruding works only in surface select-mode.  Pressing the extrude button on the 
control panel when there are one or more surfaces selected, enables the function.  
The actual extrude is done after the selection is dragged.  
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Extruding is a very powerful function that can be used for a number of tasks.  It 
works by making new surfaces at the edges of the current selection. The original 
selection can be removed and/or copied to the end of the new surfaces. 
 

 
 
Selecting one of more surfaces and 
selecting the extrude button on the 
control panel, brings up the extrude 
parameters: 
 
Here the number of sections to produce is 
specified.  The end of new object can be capped 
with a copy of the original selection.  New 
surfaces can have their normals reversed.  
Removal of the original surfaces is also an option. 
 
After setting these parameters, bounding box is 
dragged in the desired direction.  (if the control 
key is held down movements of the mouse are  constrained to either horizontal or 
vertical.) 
 
The extrude function is best demonstrated with some examples.  (This star is 
made by creating a 10-sided disk, selecting alternate vertices and shrinking the 
selection, using the –10% toolbar button a few times). 
 

 
 

 
 
The magenta lines shown here represent the 
normals.  Normals can be displayed by 
switching on ‘Show normals’ from the Orth and 
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3D menus.  Displaying the normals is used here to help determine the direction to 
extrude the object.  In the extrusion, if the selection is dragged in the same 
direction as the normals, the resulting shape will hide the front of the original 
surfaces.  This is good if you are, for example, extending one side of a box, but 
in this case we want the original surfaces to be on the outside of the final shape.  
This means that we want to drag the surfaces in the opposite direction that the 
normals face. Because we are doing this, we need to ‘flip new surfaces’ so that 
all the new surfaces face outwards. 
 
This is what happens when we drag the selection up in the plan window. 
 

 
If we ticked ‘remove original’ here then the star that we are dragging will be 
deleted: 
 

 
Here you can see that the original surfaces have been removed to leave a start 
shaped box (without a lid).  If we’d un-ticked ‘cap end’ then we’d be able to see 
right through the star shape. 
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This picture shows what happens when sections is set to 4. 
 
 
If you need to extend an existing set of surfaces, you may not want to keep the 
existing surfaces inside the new object. 
 
Here is a cube that has had a single ‘Surface->divide’.  Two of the surfaces are 
selected. 

 
 
We can extend these surfaces without keeping 
the original surfaces (since they will not be 
visible because they are inside the shape.  We 
use these settings: 
 

 
 
To perform the extrusion, we drag the bounding 
box to the left (in either the front or plan window), holding down the Control-key 
as we drag to ensure that the new surfaces are square to the original. This gives: 
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When extruding lines, you will probably want to ensure that remove original is 
ticked and cap end is un-ticked.  This ensures that no lines remain in the new 
surfaces. 
 

  
It’s useful to switch on the display of normals when extruding so check that the 
resultant surfaces are facing in the correct direction.  If they are not, use surface-
>flip normals. 
 
Flip normal 

This effectively reverses the list of the vertices in each selected surface.  This 
reverses the way that a poly 'faces'.  A polygon is defined as 'facing' if the 
vertices appear anti-clockwise to the viewer.  If a polygon is set to be one-sided 
(by pressing the '1S' button on the control panel) then it will only be viewable 
from one direction - the direction it is facing.  You can switch on the display of 
normals in the orth and 3D windows – this can help determine if any surfaces are 
facing in undesired directions. 
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Change vertex order 

This changes the order that the surface vertices are drawn, by moving the first 
vertex to the end of the vertex list.  This can be used to change where the break 
in a line is.  It can also be used to fix bad polygon, which has the first three 
vertices in a non anti-clockwise order - causing the normal (used for lighting) to 
be incorrectly calculated.   If a polygon appears all black, this function may 
need executing (possibly repeatedly) until it appears correctly. 

Divide 

Divide works on triangles and quads. It makes one 
triangle into three surfaces (new vertex at centre) and 
splits a quad into four smaller quads. 

e.g. divide run twice on a box: 

  

 

Spline 

This is sseful for smoothing out a 'line' object and for rounding off polygons. New 
points are interpolated between existing points.  

       

Spike 

This creates a 'spike' in place of each 
quad or triangle selected. The 'spike 
factor' in the dialog that pops up - this 
defines the distance that the apex of the 
spike will be away from the original 
surface.  
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Make hole 

This function creates a hole in each selected surface. 

 

This image shows 4 objects that have had holes made in them - An Ellipse (set to 
poly surface-type), a sphere, a cube and a disk. Notice how the insides of the 
sphere and cube are not visible through the holes- this is because the default 
surfaces for these objects are single-sided and face outwards. To see the insides 
though the holes, these surfaces need to be made two-sided by pressing '2S' on 
the control panel.  

Some concave polygons may have overlapping surfaces after making holes. 

The size of the hole is specified as a percentage and can be adjusted in File-
>settings. 

Bevel 

Bevel works on each selected surface and creates another 
surface, which is smaller than the original, moved away 
slightly and joined by more new surfaces around the edge. 
The original surface is discarded. The distance that the new 
surface is moved and indented is specified in File->settings 
(Bevel size). Bevelling a concave polygon can result in new 
points being positioned incorrectly and these may need to 
be repositioned. 

Triangulate 

This spits non-triangles (i.e. polygons with more than 3 sides) into more surfaces, 
each new surface being a triangle. This operation can fail if it is given a 'bad' 
polygon - i.e. one that has overlapping edges or duplicate vertices.  
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Cut away object 

This function takes all of the selected surfaces and 
vertices and puts them into a new object. This can be 
useful for extracting parts of objects. e.g. splitting a 
sphere into two.  

 
  

Remap texture coors 

see texturing section.  

Remove surface only 

This deletes any whole surfaces selected.  The vertices will remain.  

 
   

Operations on Vertices 
 
The functions on the Vertex menu are available when the Surface or Vertex 
select mode is on and one or more vertices are selected.  
 

Snap-together 

This sets all selected vertices to the same location.  The vertices can be in 
separate objects or the same object.  The point that they are snapped to is the 
average of all selected points.  

Snap-together-by-distance 

This function moves vertices together that lie within the specified distance.  This is 
useful for example, to join two halves of an object together. 

e.g. This picture shows a close-up of an object where 
two halves have been positioned together.  Notice 
that there is a visible seam along the top.  This is 
because the two halves are separate objects.  Once 
the two halves have been merged together into a 
single object (Object->merge), the vertices need to 
be shared in order 
for this seam to 
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disappear.  If Object->optimize does not remove duplicate vertices then it 
means that the vertices are in very slightly different positions. The solution is to 
select the vertices along the join and Vertex->snap-together-by-distance. The 
Object->optimize will remove the duplicate vertices and allow the surface to 
appear smooth. 

 

 

Snap-to-grid 

Moves each selected vertex to the nearest grid position.  This may or may not be 
the visible grid.  The snap grid is defined by 'snap grid' in settings and may be 
different to the 'draw grid' (which is the visible grid).  

Snap-objects-by-vertices 

This is for aligning two objects. One vertex in each of two separate objects 
should be selected before executing this function. The objects will be moved 
together, so that the two selected vertices are in the same location.  
   

Unshare 

This creates new vertices so that each surface will access a unique vertex in the 
same object.  New vertices will be created in the same location as the originals. 

Insert Vertex 

This function inserts a new vertex between each selected 
pair of vertices.  Insert-vertex is useful for adding extra 
points into a line. One example is to create a grid object 
(which is made from lines) in a power of 2 dimensions e.g. 
8. Press 'Insert vertex' 3 times (2^3=8). You should now 
have a grid where you can lift each point and create a 
3d graph.  

Create convex surface/object 

This function uses a technique called 'convex hull' to create a new object that 
surrounds the vertices that are selected.  This is very useful for joining complex 
objects together or for simplifying the creation of some complex shapes.  
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These two pictures show the function being used to join a cylinder to a cube.  The 
new object will always be flat shaded but it can be set it to smooth by pressing 
the "sm" button on the control panel.  Note that because this function makes a 
new object, the vertices are not shared with the old objects. If the whole shape 
needs to be smooth then the objects must be merged together with(object-
>merge) and then have the duplicate vertices removed with (object->optimize-
vertices)  
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A second example uses a number of simple objects, which are 'shrink-wrapped' 
by this function.  In this case we are creating the fuselage of an aircraft.  The 
objects are ellipses and a single red box.  Any AC3D objects can be used this 
way, either lines or polygons.  

 

To get a more accurate outline, these shapes could have be made by placing 
background images of a real aircraft onto the views and building the shapes on 
top of those images. 

After Surface->Create surface-object menu function has been selected: 
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This picture shows the fuselage object created from the simple shapes.  It’s been 
dragged to the side of the original objects, which still remain in the scene. 

It’s important to note that the hull created is ‘convex’.  This means that if there 
had been an object that was totally ‘inside’ the encompassing hull, the new hull 
object would not have any vertices created at the points on that object.   

This function will also create 2 dimensional convex hulls, as long as all of the 
selected vertices lie on the same plane.  If they are not, a 3d object will be 
created. 

Create ordered surface 

This function creates a surface using the individual vertices that are selected. The 
vertices should be selected in the correct order and in an anticlockwise direction. 
This function works by creating a new surface and adding vertices in the order 
they were selected. If vertices are not selected in exactly the correct order, a 
bad surface (crossing edges or non-planar) may be created.  

Create 2D mesh 

This function uses a technique called ‘Delaunay triangulation’ to calculate 
triangles between a set of points.  When this function is selected, a plane is 
specified.  This treats the points as 2D so that a mesh can be laid out over the 
points. 
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e.g. here are a number of vertices in front window.    

 

After Vertex->create 2D Mesh->Front is applied: 

 

To make vertices specifically for this function, create a line, placing each point at 
the desired location.  Select the line and Surface->remove-surface-only.  This 
removes the surface and leaves the vertices.  Note that this function works 
convexly. 
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Texturing 
Each AC3D object can have one texture. A texture 
is set from the object->texture menu.  

 
 
 

 
Setting a texture 

 
Each AC3D object can have one texture 
applied to its surfaces.  After selecting 
an object (or objects), use the menu 
Object->texture->load-texture to set a 
texture. 
 
AC3D loads a number of different 
picture file formats as textures.  These include .gif, jpeg etc.  More image file 
formats are available as plugins.  To view which formats AC3D can load, see the 
load texture dialog. 
 
Note that some export formats (or rather the programs that load the files) do 
not support all the texture file types that AC3D supports.  You should ensure that 
you are using the correct format texture for the correct export file type e.g. .jpg 
or gif for VRML.  

 

Changing the mapping 
Texture coordinates determine how a texture is mapped onto the surfaces of an 
object.  All AC3D objects have default texture coordinates applied to them when 
they are created.    For example a cube has mapping set so that one instance of 
the texture will appear on each face. 
 
Some file formats do not contain texture coordinates and some AC3D operations 
may cause these coordinates to become disturbed, in these cases, it it necessary 
to remap the texture coordinates. 
 
Remapping the texture coordinates 

Surface->remap-texture-coors->(front, side, plan) maps the selected surfaces by 
axis. It finds the bounding rectangle of the selection and uses this for the edge of 
the texture mapping.   Spherical mapping ‘wraps’ the image around a ball and 
shrinks it onto the selection. For more powerful texture mapping control, use 
AC3D’s Texture Coordinate Editor. 
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Changing the texture repeat and offsets 

The texture repeat and texture offset for an object can be modified in Object-
>Texture->set texture repeat/offset. The texture repeat indicates the number of 
times the texture is to be fitted in to that dimension. 
 
E.g. a cube with texture repeats set to 1, 1 (the default): 

 
 
 
 
Object->texture->set-texture-
repeats/offsets and repeats 
set to 2, 2: 
 
 
 
The texture offset determines how far across the texture, the mapping should 
start. 
 
 
Texture repeat set to 1,1 and 
Texture offsets set to 0.5,0.5: 
 
 

 
If more than one texture is required on a single object (e.g. a different image on 
each side of a cube), the object should be split up into parts (e.g. use Surface-
>cut away object) and different texture mapped on to each of the sub-objects.   
 
Alternatively, it is more efficient to create a single texture image (i.e. a single 
picture file containing all the required images) and use AC3D’s Texture 
Coordinate Editor to map parts of the object. 
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Tools 
This section describes AC3D’s integrated tools.  Other tools are available as 
plugins.  Tools are accessed from the Tools menu. 
 

Model Information 
This displays information about the current model. 
 

 
 
This shows the information for a single cube.  Note that the total number of 
objects shown is actually two.  This is because the ‘World’ object is included in 
this count.  The internal world object is the top-level container object.  This 
window can remain visible but if any changes occur to the current AC3D model, 
the ‘refresh’ button need to be pressed in order to update the displayed 
information. 
 

Render 
This menu item starts up an external renderer or other linked program.  See the 
rendering section for more information on how this is configured. 
 

Object hierarchy 
This window shows the structure of the current model but also allows control over 
the structure of the hierarchy. 
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Clicking on one of the items in the list can select or unselect objects.  This selection is 
sensitive to the current select mode being used e.g. in Group select mode, it is only 
possible to select top-level groups.  To select individual objects, switch to Object select 
mode (using the main AC3D control panel). 
 
As well as controlling selection and grouping of objects, a right click on an object item 
will reveal a popup menu: 
 

 
 
This allows control over hiding, a more detailed properties viewer, editing object data 
and the option of moving an object to the head of the children list. 
 

Edit Object Data 
Every AC3D object can have a url (web link address) and text data attached to 
it.  This is a string of text.  This data is saved in the AC3D file, along with the 
object geometry information.   
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This interface shows that the current object is named ‘goto_entrance_button1’ and the 
object has a URL attached.  Some export data formats supported by AC3D use this 
URL and object data. e.g. objects in VRML files will have a link generated around them 
if a URL is present, and Povray objects can include object data text at the end of each 
object description (allowing custom povray commands to be added). 
 

The Texture Coordinate Editor 
 

 
 
AC3D’s integrated Texture Coordinate Editor (TCE) allows full control over the 
texture coordinates that are applied to all surfaces in AC3D objects. 
 
To start the TCE select: Tools->Texture-Coordinate-Editor. 
 
To edit the texture coordinates of an object, select a single object, or surfaces 
from a single object should be first selected (in the main AC3D windows).  The 
TCE runs in conjunction with the main AC3D program so you can switch between 



AC3D User Manual 44 

the windows, selecting the surfaces and objects you wish to edit.  Note that if a 
group object is selected (which has textured children) then nothing will appear in 
the TCE.  In this case, switch to Object select-mode and select a single object. 
 
The surfaces selected in AC3D will appear in the TCE according to their texture 
coordinates.  All AC3D primitive objects (those created from the control panel) 
have default texture coordinates e.g. 
 
 

 
Mesh 

 
Disk 

 

 
Cylinder 

 
Sphere 

 
It’s important to realise that the pictures here represent the coordinates that are 
attached to each vertex reference in each surface, and have no relation to the 
layout of the actual object vertices. 
 
Note that the pictures above show the texture mapping for objects that have no 
textures applied.  If there is a texture, it will be shown in the window.  
 
Selecting and manipulating 

When surfaces are selected in AC3D and the TCE is visible, the texture 
coordinates of those surfaces are all visualized.  The TCE allows editing of all or 
a subset of the texture coordinates. 
 
The TCE has two modes of selection, Surface and Vertex.  In Surface select 
mode, the texture coordinates are selected, moved and size by manipulating 
individual surfaces.  Vertex select mode allows individual texture coordinates to 
be manipulated. 
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Surface select mode  

Vertex select mode 
 
 
Manipulation in the TCE is similar to the main AC3D 2D views.  After a selection 
is made, the green bounding box can be moved; the handles can be dragged to 
resize the selection and the selection can be extended and negated (shift-left 
mouse, shift right mouse).  The selection can also be rotated using the mouse.  
When the mouse pointer is over the edge of the bounding box, the pointer 
changes to indicate that if the left mouse button is dragged the selection will be 
rotated. 
  

 
Resizing 

 
Moving 

 
Rotating 

 
 
The Flip buttons mirror the selection either horizontally or vertically. 
 

 
 

 
e.g. flipped horizontally 
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Remapping the selection 

 
The ‘remap’ buttons on the TCE perform the same function as the 
Surface->remap-texture-coors menu items in AC3D.  The ‘Front’, 
‘Side’, ‘Top’ buttons ‘project’ the texture onto the surfaces in the 
specified axis.  The bounding size of the selected surfaces determines 
the boundaries of the mapping.  The ‘Spherical’ button cause the 
texture coordinates to be ‘wrapped’ around selected surfaces. 
 
 
 
It is possible that after starting the 
TCE and selecting an object, the 
window appears blank.  It’s likely 
that the object has zero value 
texture coordinates e.g. each 
surface-vertex reference has 0.0, 
0.0 as a coordinate.  In a case like 
this, a ‘Select all’ in the TCE would 
reveal that all of the coordinates 
are set to 0, 0. 
 
In this case, you will need to make 
sensible coordinates for your 
model, probably in groups.  Do this 
by selecting a number of surfaces 
(from within AC3D) and using the 
remap buttons to assign a mapping to the texture coordinates.  You can then 
reposition and size the surfaces in the TCE and map them onto a texture. 
 
 
 

Replicator 

 
The replicator allows multiple copies of the selection to be created.  Each copy can be 
moved, rotated and scaled. 
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Materials and the palette 
The scrolling window of buttons near the bottom 
of the control panel represents the 
colours/materials available. The default colour 
for an object is palette entry 1 (usually white)  

The colored buttons are pressed to change the 
material on the currently selected objects/surfaces. Setting the material of 
surfaces works in all selection modes but for a surface to change color in Vertex 
mode it must have all vertices selected.  

Note that the colour on the palette button represents only the diffuse RGB values 
for that material.  

New palette buttons are appended to the list when a file (containing extra 
materials is loaded.  

When surfaces have a texture as well as a material, that material can affect the 
way the texture appears.  To make a texture to appear as the original coloured 
image then the surface color should be white.  

To find the material index of an existing polygon, select that surface and the 
message at the bottom of the AC3D window will display the material number. 

Editing Palette entries 

Pressing the right mouse button on a 
palette button pops-up a menu. The 
options are to edit a colour or add a new 
one (a copy of the selected material will 
be added to the end of the list).  

If the ‘realtime update’ option is selected, 
the AC3D view windows to be redrawn 
every time a change to the edited 
material is altered.  

Transparency is supported in the palette 
but for purposes of speed, the surfaces 
are not sorted when they are rendered 
into the views. 
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Loading and saving files  
An AC3D file (usually named <something>.ac) is a text file describing the 
geometry of a model.  AC3D files retain all available information about a 
model built with AC3D e.g. textures, surface settings, materials, object data etc. 
Other file formats exported by AC3D may not retain all of this information.  
Models should always be saved in this format to ensure that no detail is lost. 
 
Developers can view a description of the file format on the AC3D home page.  
 
AC3D files are loaded by selecting File->Open.  This will replace the current 
model.  To load models in addition to the current model, use File->Merge. 
 
A list of the most recently opened files appears on the File menu. Selecting one 
of these causes it to be loaded. 

  

Importing other formats  

See the File->Import menu for a list of file types that AC3D cam import.  

Full versions of AC3D come with a number of extra Import/Export plugins that 
handle more file formats.  

The following formats may be useful for importing your own model data. 

Triangle files 

The format of triangle file is: each line contains 9 floating point numbers and one 
hex value e.g.: 0.0 0.0 0.0 1.0 0.0 0.0 1.0 1.0 0.0 0xffffff represents 3 vertices 
of a triangle. hex value is 0xRRGGBB col - in this case white duplicate vertices 
are aggregated when loaded.  

Vector files 

This is another simple format for importing 2D vector data. Each line should 
consist of a number of vertices followed by the same number x/y coordinate 
pairs e.g.  

3 0.5 0.5 2.5 2.5 10 5 
This represents a line with 3 vertices (0.5, 0.5)(2.5, 2.5)(10, 5)  

Exporting files 
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AC3D can generate output files for many different formats.  Support for extra 
file formats are added by installing AC3D plugins.  See File->export for a list of 
the output files supported. Not all are mentioned here. 
 
VRML 1 

Object URLs (set from the object data dialog) are used so that objects will be 
selectable in the appropriate browser. The output of normals and textures can 
be switched on/off in the File->settings window.  

VRML 2 

Output of normals and textures is switchable via Settings.  

DIVE 

Dive files will handle textures. The Dive generation will include the dive data (if 
you have input any) this is usually TCL code. If an object has a URL then the 
object will be a dive gateway. See www.sics.se/dive for more info about the 
Dive VR system.  

MASSIVE 

Massive is a distributed VR tele-conferencing system written by Chris Greenhalgh 
at Nottingham University in the UK. It runs on SGI and Sun platforms. For more 
details, see: http://www.crg.cs.nott.ac.uk/~csm/massive.html  

RENDERMAN 

These files are used in a raytracer. See http://www.bmrt.org for a good 
rendering tool (BMRT) and other pointers to Renderman related stuff. The eye 
viewpoint is defined by your view position in the 3D window (approx). Note that 
lines will not be output. Any polygons that need triangulating (breaking up into 
triangles) will be triangulated.  

POVRAY 

Povray is a very popular raytracer see www.povray.org for more info. The eye 
viewpoint is defined by your view position in the 3D window.  (In Spin mode the 
viewpoint will be approximate, for a more accurate viewpoint position, switch to 
walk-mode in the 3d window). The colour palette is output at the top of the file 
(each entry has the same number as the AC3D material). The properties can be 
altered easily to provide different surface types and textures (you might need to 
add some #includes to get external definitions). The light is output at the end of 
the file. The lights position is the same as the viewers. The POV-Ray output is 
based on triangles - lines will be ignored and polygons with > 3 vertices will be 
triangulated automatically.   

http://www.sics.se/dive
http://www.crg.cs.nott.ac.uk/~csm/massive.html
http://www.bmrt.org
http://www.povray.org
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Tools->edit object data can be use to attach information to objects which is then 
generated in the povray file.  You need to tick the setting (File->settings) for 
‘Use object data in POV files’.  You will probably want to enter a POVray 
include command in to the settings ‘POV header’ e.g. #include "glass.inc". 

See the Rendering section for an example.  

Triangle files 

see loading triangle files for a description of this format. This format is very 
simple and is easy to parse.  
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Rendering  
The "Render" button in the tools menu can be configured to automatically launch 
your favourite renderer. The command executed when the button is pressed is 
entered in the settings.  

The command is actually a TCL string. TCL commands are separated by ';'. by 
default, AC3D is configured to generate a POV file, then execute povray. An 
example command for POV is:  

ac3d write_POV ac3dpovfile.pov ; ac3d execute {"C:\Program Files\POV-Ray for Windows 
v3.5\bin\pvengine.exe"  /RENDER ac3dpovfile.pov } 
 
you may need to edit this command and set the correct location of the povray 
program. 
 
and for BMRT:  
 
ac3d write_rib /tmp/ac3dribfile.rib ; ac3d execute { rendrib -d /tmp/ac3dribfile.rib &} 
 
The first part sends a message to AC3D to write a POV file. The second part 
sends a message to AC3D to execute the povray program. This will only work if 
povray is somewhere on the default search path - you might need to specify a 
full pathname to the binary program. The execute command must be surrounded 
by {} NOT quotes (").  

Under WINDOWS it's slightly different:  
ac3d write_POV ac3dpovfile.pov ; ac3d execute {"C:\Program Files\POV-Ray 
for Windows\bin\pvengine.exe" /RENDER ac3dpovfile.pov }  

For other renderers - the other AC3D write_ commands are:  

write_dive 
write_vrml 
write_massive 
write_rib 
write_POV 
 

A POVray example 

Povray is a very popular raytracer-see www povray.org.  

This example shows a very simple model consisting of a mesh, a sphere and a 
cube that’s been divided a couple of times (with Surface->divide) then had a 
Surface->make-hole.  There’s also an extra light. 
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The sphere has had a pov texture specified using the Tools->edit object data 
(the appearance of the object in AC3D will be unaffected by this): 

 

The settings in file->settings were: 

  

And the render command (also in File->settings) was: 

ac3d write_POV ac3dpovfile.pov ; ac3d execute {"C:\Program Files\POV-Ray for Windows 
v3.5\bin\pvengine.exe"  +W300 +H300 +A /RENDER ac3dpovfile.pov } 
 
Selecting Tools->render gives: 
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The Povray exporter supports bitmap-textured objects.  You should ensure that 
the format of the texture picture files you use are compatible with POV-ray. 
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Appendix 

Performance tips 
Rendering more polygons takes more time.  As a larger number and more 
detailed objects are edited, the rendering will take longer. Here are some tips 
to help edit larger models more effectively. 
 
Switch to wireframe viewing. This is much faster to render. 
 
Use object hiding and locking.  This reduces the graphics load. 
 
Edit in only one maximised view.  This prevents all views from being updated 
every time you make a change. 
 
If surfaces can only be viewed from one side, set them to single-sided. This is 
slightly faster to draw. 
 
Switch on move-wireframe in both the orth and 3d menus. This temporarily sets 
the drawing to wireframe when being panned or zoomed using the mouse – 
much faster. 
 
Use Object->reduce to reduce the number of vertices/polygons in an object. 
 

Keypresses 
 
Key shortcuts for menu items are shown on the menus.  Other keys can be used:  
   

In orthographic (2D) windows: 
Key  Function  
Cursor-keys  move view  
Shift-Cursor  move view faster  
Control-up  zoom in  
Control-down  zoom out  
Shift-Control-up  zoom in with larger step 
Shift-Control-
down  zoom out with larger step 

Alt-Cursor move background image 
Alt-shift-cursor 
up/down Scale background image 
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Backspace/Delete  delete current selection  

Space  home windows to origin and reset zoom 
in each window  

t Toggle textures  
o set select mode to OBJECT  
v set select mode to VERTEX  
s Set select mode to SURFACE 

m  set drag mode to MOVE  
R Set drag mode to ROTATE 
e set drag mode to EXTRUDE 
f fit selection to window  

F/control-f  fit selection to all views   (Control f fits 
everything to all views) 

G  centre window at centre of selection  
H  hide selected objects 
z zoom in 
x zoom out 
  

   

Some of the keys for the 3D window have equiv. menu item in the 3D menu.  
   

In the 3D view: 
Key Function 
W Wireframe/filled toggle 
T toggle textures 
L toggle headlight 
G toggle 3d grid 
f fit to window 
Space Reset view to origin at the default scale 

Cursor-keys - spin model in 'spin-mode', control viewpoint in a similar way to 
'quake' in walk mode e.g. left, right, forward back, alt-up/down move up/down, 
control-up/down tilt.  

Preferences/settings 

The settings in File->settings are saved automatically when you exit AC3D. 
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This automatic saving can be switched off (you must save the settings with this off 
for the change to be remembered).  Some settings such as the background 
colours of the windows can be adjusted in the settings file but beware – 
changing values that you don’t know about could cause AC3D to behave 
unexpectedly or crash. 

Under Unix, the settings are saved to $HOME/.ac3dprefs.  Under Windows, 
they are saved to the users home directory as ac3dprefs.txt. 

 

 


