
QUICK START GUIDE 
FOR CBECC-RES 2013 

CBECC-Res 2013 Version 3b 

For additional tips and information, download the CBECC-Res FAQs at 
www.bwilcox.com/BEES/BEES.html  
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Overview 
The California Building Energy Code Compliance 2013 Residential Standards compliance software 
(CBECC-Res 2013) is a public domain software program developed by the California Energy Commission 
for use in complying with the 2013 update to the Residential Building Energy Efficiency Standards.  

This Quick Start Guide provides brief descriptions of the software program’s major features. It’s a good 
idea to review the Quick Start Guide before using the program for the first time or if you have questions 
while using the program. Additional Help features will be added to future versions of the program. 
There is also a CBECC-Res User's Manual available through the software’s Help menu, and an FAQ 
document that can be downloaded from the project website at www.bwilcox.com/BEES/BEES.html.   

http://www.bwilcox.com/BEES/BEES.html�
http://www.bwilcox.com/BEES/BEES.html�
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CBECC-Res 2013 Version 3b has the following capabilities:  

Compliance Scope 
1. Newly constructed single and multi-family buildings, full compliance 
2. Existing plus Additions plus Alterations, full compliance 
3. Addition alone, full compliance 

Site/Building 
1. Include identifying information 
2. Include other general information required for performance compliance forms  
3. Include location information 
4. Identify climate zone  
5. Use the 2013 Standards’ 16 Climate Zone weather files in the hourly building energy simulations 

performed by the software, mapped from a climate zone entry by the user 

Envelope 
1. Model the effects of conductive, convective and radiative heat and mass transfer through the 

building envelope, including ventilation and infiltration air flow 
2. Model walls, floors, roofs and ceilings as separate heat transfer surfaces 
3. Model conditioned zones, attics, crawlspaces and garages as separate space types  
4. Have an adequate list of accurately described opaque materials used in typical residential 

construction 
5. Combine materials into constructions 
6. Describe fenestration performance properties via the simplified approach (U-value, SHGC) 
7. Assign opaque constructions and fenestration to the Standard Design that meets the 

prescriptive requirements by climate zone  
8. Include shading effects on fenestration from overhangs and fins in the Proposed Design 
9. Adjust excess (> 20%) user model fenestration to Standard Design maximum area per floor 

space as defined in the Residential ACM Reference Manual 

HVAC 
1. Model the following heating and cooling equipment: 

a. Central Gas Furnace 
b. Central Split or Package System air conditioning 
c. Air Source Heat Pumps with electric resistance backup 
d. Air to Water Source Heat Pumps 
e. Ground Source Heat Pumps 
f. Combined hydronic heating, limited to small storage water heating as source for space 

heating 
g. Electric resistance heating 
h. Non-ducted heating and cooling equipment 
i. Ventilative cooling equipment 
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j. Evaporative condensers 
2. Model the following heating and cooling systems: 

a. Ducted central system 
b. Ducted zonal system 
c. Ductless zonal system 
d. Whole house fans 

3. Model the Indoor Air Quality ventilation supply or exhaust fans 
4. Model ducts installed in any building zone including attics, crawlspaces and conditioned space 
5. Use the heating thermostat setpoint schedules published in the ACM Reference Manual for 

conditioned, living and sleeping zones 

Domestic Water Heating 
1. Model the following water heater types 

a. Small Storage  
i. Gas 

ii. Electric 
iii. Oil 
iv. Heat Pump 

b. Small Instantaneous  
i. Gas 

ii. Electric 
iii. Oil 

c. Large Storage  
i. Gas 

ii. Electric 
iii. Oil 

d. Large Instantaneous, Indirect Gas, Hot Water Boilers 
2. Apply the ACM rules for distribution system multipliers, hourly adjusted recovery load, load 

dependent energy factors, hourly hot water consumption, solar water heating, and multi-family 
recirculation systems 

Lighting and Appliances 
1. Use the operational schedules for lighting and appliances specified in the HERS Technical 

Manual (HTM) to compute and report annual energy use for these end uses. The energy use 
assumptions for these end uses are fixed, as specified in the HTM, and there is no compliance 
credit provided. 

2. Use these same operational schedules to determine typical internal gains, and include the 
effects of these internal gains in both the Proposed and Standard Designs. Additionally, consider 
the latent component of these internal gains (latent heat gains are currently not included in the 
HTM). 

Output 
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1. Report simulation errors and warnings 
2. Report site energy consumption by fuel and end-use 
3. Report TDV energy by end-use, including lighting and appliances 
4. Report TDV energy comparison of Proposed and Standard Design, including Compliance Margin 
5. Generate compliance forms from the Tools menu item 
6. Three Building Summary reports are now available for each building modeled in CBECC-Res —

the building as entered by the user, the Proposed Design for the building, and the Standard 
Design for the building. These Building Summary reports can be generated from the Tools menu 
item and are saved as comma-delimited data files in the CBECC-Res Project directory. 

Interface 
1. Ability to access and modify parameters needed to simulate the above 
2. Option to perform simulations in two modes:  

a. Proposed Only (applies rules and simulates the Proposed Design) 
b. Proposed and Standard (applies rules and simulates the Proposed and Standard Designs) 

3. CBECC-Res Quick Start Guide available from “Help” tab 
4. CBECC-Res software license available from “Help” tab 
5. CBECC-Res User's Manual available from “Help” tab 

Capabilities Not Implemented Yet 
The following capabilities will be included in future versions: 

• Fast, non compliance, analysis mode 
• Insulated crawlspaces with reduced ventilation 
• Sealed and mechanically ventilated crawlspaces 
• Sealed (unvented) attics 
• User input attic vent areas 
• Boilers and evaporative coolers 
• Steel frame ceiling and floor constructions 
• Insulated roof tile 
• Multi-family common area zone type 

 

New Features and Fixed Problems in this Release 
1. Enabled multiple attic zones with different characteristics and Standard Designs for existing 

zones, altered zones and garage zones. 
2. Revised the sizing of heat pump systems to include heating load in climate zones with low 

cooling loads 
3. Additional HVAC equipment  types including room air conditioners and heat pumps 
4. Enabled analyses with below grade floors and walls 
5. Removed limit of 48 zones 
6. Enabled use of an existing HVAC system when modelling an addition alone 
7. Corrected calculations for furred insulation layers on mass walls and enabled walls >12” 
8. Corrected multi-family IAQ rules and DHW equipment and distribution issues  
9. Added Standard Design rules using prescriptive interior insulation for mass walls 
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10. Improved the Building Summary Reports 
11. Clarified reporting and HERS requirements for multi-family HVAC  
12. Added a report for the California Advanced Home Program 
13. Updated Users Manual 
14. New FAQs and example files 

Known Issues with this Release 
The following issues are being worked on: 

• Duplexes and town homes need to be modelled as multiple single family homes 

Example Input Files are all Rev 16 (installed along with CBECC-Res in the Projects 
directory) 

1. 1StoryExample17.ribd. Based on the Energy Commission’s 2,100 ft2 single floor prototype 
with slab-on-grade floors, a tile roof, an attached garage, window dimension inputs, 
overhangs, with the garage modeled as a fin (providing shading to windows). 

2. 1StoryExample17Cathedral.ribd. Same as above with cathedral ceilings. 
3. 1StoryExample17Crawl.ribd. Same as above with a crawl space. 
4. 1StoryExample17CrawlMW.ribd. Same as above with a crawl space and with several wall 

types in the construction library (including concrete, ICF, Log, SIPs, below grade mass). 
5. 1StoryExample17BelowGrade.ribd. Same as above with a 750 ft2 below grade conditioned 

zone.  
6. 1StoryExample17EvapCond.ribd. Same as above with an evaporatively cooled condenser. 
7. 1StoryExample17HVAC.ribd. Same as above with mini-split, ground source, and air-to-water 

heat pumps defined in the mechanical system library. 
8. 2StoryExample17.ribd. Based on the CEC 2,700 ft2 two-story prototype, set in climate zone 

14, with asphalt shingle roof. This file has window dimension inputs, Compliance 2015, and 
a photovoltaic power compliance credit.  

9. 2StoryExample17CombHydNoCool. Based on the CEC 2,700 ft2 two-story prototype, set in 
climate zone 3, with a combined hydronic system with a boiler as the source of 
heating/water heating, and no cooling.  

10. 2Story2ZoneExample17.ribd. Same building type as above but zoned 1st and 2nd story, 
each with its own HVAC system. 

11. 2StoryZonalExample17. Same building type as above with a zonally controlled HVAC 
system. 

12. EAAExample 17.ribd. An existing plus addition input file. 
13. AAExample 17.ribd. An addition alone input file. 
14. MFexample17.ribd. An eight-unit, two-story, multi-family 6,960 ft2 building with each story 

as a separate zone with four dwelling units in each zone, served by individual water heaters. 
15. MFexample17CentralSolarDHW.ribd. An eight-unit, two-story, multi-family 6,960 ft2 

building with each story as a separate zone with four dwelling units in each zone, served by 
central water heating with 35% solar contribution.  

How to Get Support or Report a Problem  
If you have questions about the software or run into a problem, there a number of resources where you 
can find help:  

• This Quick Start Guide  
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• The CBECC-Res FAQ document, which can be downloaded from 
www.bwilcox.com/BEES/BEES.html 

•  The User's Manual available through the software’s Help menu and the Program Files 
directory; it can also be downloaded from www.bwilcox.com/BEES/BEES.html 

• The Residential ACM Reference Manual can be downloaded from 
www.energy.ca.gov/title24/2013standards/ 

If you have a question that is not covered by one of these documents or if you think CBECC-Res is not 
operating correctly, send an email to CBECC-Res Support <cbecc.res@gmail.com> and we'll answer your 
question as soon as possible. 

If you are reporting a CBECC-Res crash or error, please include as much of the following as possible 
(copy and paste this template into your email):  

CBECC-Res version (Help: About): CBECC-Res 2013-??  

Describe the error, using as much detail as possible. 

List the steps taken to produce the error, using as much detail as possible. 

1. 
2. etc. 
 
If there is an error message, what is the message? If possible, take a screenshot of the error 
message and attach it to the email as a file. 

Please attach your <ProjectName>.ribd file. This is the file you open and save from inside CBECC-
Res. By default, this file is located in the C:\Users\<your username>\My Documents\CBECC-Res- 
2013-?? Projects directory. 

We appreciate your willingness to help us improve CBECC-Res by taking the extra time to document and 
report issues in a way that will help us fix them quickly. If you include your name and phone number, we 
may call you to clarify the problem or ask for more details. We will not share your name, phone number 
or email address with anyone outside the CBECC-Res development team or use it for any purpose other 
than responding to your report. 

Return to Quick Start Topics Menu 

Updates and Project Website 
Updates to CBECC-Res will be posted to the project website: www.bwilcox.com/BEES/BEES.html.  

Analysis Types  
Proposed Only: Simulates the building input by the user with the 2013 compliance rules. 

Proposed and Standard: In addition to simulating the Proposed Design, simulates the Standard Design 
building which complies with the 2013 Prescriptive Standards and establishes the energy budget for 
compliance. 

http://www.bwilcox.com/BEES/BEES.html�
http://www.bwilcox.com/BEES/BEES.html�
http://www.energy.ca.gov/title24/2013standards/�
mailto:cbecc.res@gmail.com�
http://www.bwilcox.com/BEES/BEES.html�
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Menu Bar 
This section explains the program features you access by clicking on the options on the menu bar at the 
top of the screen. 

File – The File menu contains the standard functions for file management, loading recently used files, 
and exiting the program. 

Edit – In addition to the standard Windows™ Cut, Copy, and Paste commands, the Edit menu contains 
several commands for editing building descriptions. They are: 

• Edit Component 
• Create Component 
• Delete Component 

These menus allow you to edit all building components, including components that are not displayed on 
the tree control. Use this method to edit components like schedules and performance curves. 

Ruleset – Enables you to switch between different compliance rulesets in the future. CBECC-Res 2013 is 
designed to support multiple rulesets that implement the requirements in different codes. However, 
note that different codes can require different information, therefore there is no guarantee that a 
building description developed under one code will execute without modification under another. 

View – Enables you to toggle the display of the Tool Bar and the Status Bar on and off.  

Tools – The Tools menu contains the following options of interest to end-users:  

• Check Building Database – Reviews the building descriptions to make sure a performance 
analysis can be completed. 

• Perform Analysis – Performs a compliance check based on the current building description. 
• Building Summary Reports – Produces diagnostic reports summarizing the Proposed and 

Standard Design. 
• Review Analysis Results – Recalls the last analysis results for this file. 
• Generate Title-24 Compliance Report – Produces a CF1R report. 

Help – Various Help tools are available under the Help menu. [Note: Help Topics feature is not 
available.] 

Return to Quick Start Topics Menu 

Tool Bar 
This section explains the program features you access by clicking on the icons on the tool bar at the top 
of the screen. 

 New File  

 This button closes the current file (if one is open) and opens a new file. 
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Open Existing File  

  This button closes the current file (if one is open) and launches the Open dialog to enable you to 
select an existing file to open. 

Save File 

  This button saves the file under its current name or, if you have not named the file, launches the 
Save As dialog to enable you to provide a new file name. 

Copy Selected Item 

  This button enables you to copy the selected item on the tree control (along with any child 
components) to the Windows clipboard. The Copy button is not available from within program dialogs, 
but you can use the keyboard equivalent, Ctrl+C, to copy selected text. 

Paste Contents of Clipboard 

  This button enables you to paste components copied from the tree control to the selected location 
in the tree control (provided that location is compatible with the stored component). The Paste button 
is not available from within program dialogs, but you can use the keyboard equivalent, Ctrl+V, to paste 
text from the Windows clipboard to the selected input field. 

Perform Analysis 

  This button enables you to launch a compliance analysis using the currently loaded building 
description. You must save the current building description before performing the analysis. 

About CBECC-Res 2013 

  This button enables you to view program license and version information. 

Return to Quick Start Topics Menu 

Main Screen 
The main screen of the CBECC-Res 2013 program is used primarily for editing building descriptions. 
There are two folder tabs at the top of the main screen—Envelope and Mechanical. These tabs provide 
different views of the building description and provide access to two different subsets of the building 
description data. 

Right Mouse Button Menu Options 
The CBECC-Res 2013 program makes extensive use of menus accessible by clicking the right mouse 
button. The functions available through these menus depend on whether you are on the main screen or 
in an input dialog window. 

Main Screen Right Mouse Menu. When clicked over a building component, the following choices are 
available: 
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 Edit – Opens the input dialog window for the selected component 
 Rename – Enables you to rename the selected component 
 Delete – Deletes the selected component 
 Copy – Copies the selected component with all of its child components 
 Paste – Adds copied components and their children to the selected component 
 Expand/contract – Expands or contracts the list of children components attached to a selected 

component  
 Move up/down in list – Allows the ability to change the placement of a wall or window under 

the parent component. 
 Create – Enables you to create new child components for the selected component 

Input Dialog Right Mouse Menu. When clicked over an input value in the window, the following choices 
are available: 

 Item Help – Accesses Help information applicable to the selected input field [Feature currently 
not available.] 

 Topic Help – Accesses Help information applicable to the selected component [Feature currently 
not available.] 

 Restore Default – Returns the value of the field to its default value (if applicable) 
 Critical Default Comment – Opens a dialog enabling you to enter a justification for overriding 

values designated by the Code as critical defaults, i.e., a value that should only be overridden 
with special justification. [This feature is not yet implemented.] 

Return to Quick Start Topics Menu 

Building Tree Controls (Parent/Child Relationships) 
In order to analyze a building's energy use, it is necessary to track relationships among building 
components. CBECC-Res 2013 displays these relationships using the familiar tree control, found in 
Windows™ Explorer and many other applications. For example, under the Envelope tab, exterior walls 
are shown as parents to windows (windows are connected to exterior walls and appear underneath 
walls) and children to spaces. The tree controls vary in the components they display depending on which 
folder tab is currently selected. 

Use the Tree Control for Rapid Editing 

The tree control can be used to move and copy components or groups of components. To move a 
component, just drag and drop. If an association isn’t allowed, the program will prevent the move from 
being carried out. To copy a component, select the component, copy, and paste. It is advisable to 
rename copied components to maintain readability. Whenever parents are moved, copied, or deleted, 
child components are included. 

Components shown on the tree can be moved using a drag-and-drop technique to other components 
provided it results in a compatible parent-child relationship. For example, you can drag a window onto a 
different wall, but not vice versa. 

A set of right mouse menu edit commands can be used with the tree control. These are described in the 
Right Mouse Button Menu Options section. Double-clicking on any component on the tree opens its 
input dialog window. 
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Input Dialog Windows 
The attributes of each building component can be edited by opening the input dialog window for the 
component. The dialog can be opened by double-clicking on the component on the tree control, using 
the Edit option on the right mouse menu, or using the Edit Component option on the Edit menu. (The 
tree control does not appear until you have created a project description using the wizard or loaded an 
existing project file [Ctrl+O]). 

In keeping with good practice for use of any software, we recommend that you save your building 
description often and revise the file name once you have substantial effort invested in editing the 
description under the current file name. 

Background Colors 

The following background color convention has been used in displaying data on the dialogs: 

 White background = available for user input 
 Gray background = not user editable 

For information on editing features available from the input dialog windows, see the Right Mouse 
Button Menu Options section. 

To understand what information you are required to enter, see the Status Bar section. 

 
Tip: Input Units 
The input screens show the units for numerical inputs. For example, furnace AFUE is input as a % like 80, 
not as a fraction like 0.8. The latter will give heating energy 100 times too big. 

 

Return to Quick Start Topics Menu 

Status Bar 
The status bar at the bottom of the screen provides useful information about each input field you select. 
There are three panes on the status bar that provide context-sensitive information. This same 
information is displayed in the ToolTips if you allow your mouse pointer to linger over an input field. 

1. Input Description Pane – Concise descriptions of the selected input field are displayed at the 
far left of the status bar. 

2. Input Classification Pane – The next pane to the right on the status bar displays a set of 
labels that indicates which inputs you are required to provide, which are optional, and 
which are unavailable for input. The input classification labels are explained in the table 
below. 

3. Data Source Pane – The pane at the far right of the status bar displays a set of labels that 
identify the source of the information (if any) contained in the field. This can help you 
distinguish between information that is dictated by the compliance checking process and 
the information you have entered and for which you are responsible. The data source labels 
are explained below. 
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Input Classification Explanations 

No field selected No building data field is currently selected. 

Input is compulsory You are required to enter data in the selected field; the program 
cannot perform a compliance analysis unless you do. 

Input is required You are required to enter data in the selected field if the field is 
applicable to your project. 

Input is optional You may enter data in the selected field if the field is applicable to 
your project, but you are not required to do so. If the field 
contains a default value, you are permitted to simply use that 
value without considering its suitability for your project. 

Input is crit. default You may overwrite the data in the selected field with an entry 
more appropriate for your project than the default. However, if 
you do overwrite this "critical default" value, you must be 
prepared to provide documentation substantiating the value you 
have chosen. 

Field is not editable You cannot enter data in the selected field. The data in this field 
are defined by the compliance rule set or a supporting process. In 
some cases, the field may also be an intermediate calculated 
parameter or one that is not applicable to the currently selected 
compliance rule set. 

Navigation input The purpose of the selected field is to enable you to select a 
component for editing without having to exit the current 
component and choose the next component from the tree  

 

Data Source Explanations 

No field selected No building data field is currently selected. 

Value from user The data shown have been defined by the user either directly 
through a user input or indirectly through wizard selections. 

Value from simulation The data shown have been defined by an energy simulation. 

Value undefined No data have yet been defined for the field. 

Value from program The data in this field have been defined by the program either to 
implement requirements and procedures specified in the energy 
code or to conform with building energy modeling conventions. 

 

Return to Quick Start Topics Menu 
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Defining New Components 
There are two main ways to define new components (e.g., walls or equipment) in the main program 
interface.  

Define a New Physical Component 

To define a new physical component, follow these steps from the Main Program Screen: 

 Right-click on the component on the tree control to which you want to add the new component. 
 Select Create, then the type of object you want to add. (Only applicable component types will 

appear on the list.) 
 Accept the default name, parent, and existing component to copy from or edit these fields and 

click OK. 
 Edit the input fields with white backgrounds to describe the new component, then click OK. 

Return to Quick Start Topics Menu 

Deleting Project Files 
If you have created multiple projects under different project names, you may want to delete project files 
to free up hard disk space on your computer. By default, project files are stored in the C:\Users\<your 
username>\My Documents\CBECC-Res-2013 Projects folder, although where the files are stored may 
differ on your computer depending upon where you installed the program and if you selected a different 
location for storing files. 

In the Projects folder, you will find several files with the same project name you used but with differing 
file extensions. If you have no further use for information on a project, delete all files using the primary 
file name. If you would like to retain a project but store it as efficiently as possible, delete all files using 
the primary file name EXCEPT for two files: the one named *.ribd (residential input building design) file 
extension, and * - AnalysisResults-BEES.xml (file for uploading to HERS provider). These files should be 
retained for projects that were completed. The other project files are recreated when an analysis is 
performed. There are also folders containing very large files that can be deleted.  

License Agreement 
Copyright © 2012–2014, California Energy Commission 

Copyright © 2012–2014, Wrightsoft Corporation 

All rights reserved. 

Redistribution and use in source and binary forms, with or without modification, are permitted provided 
that the following conditions are met: 

• Redistributions of source code must retain the above copyright notice, this list of conditions and 
the following disclaimer. 

• Redistributions in binary form must reproduce the above copyright notice, this list of conditions, 
the following disclaimer in the documentation and/or other materials provided with the 
distribution. 
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• Neither the name of the California Energy Commission nor the names of its contributors may be 
used to endorse or promote products derived from this software without specific prior written 
permission. 

DISCLAIMER: THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND 
CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT 
NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A 
PARTICULAR PURPOSE AND NON-INFRINGEMENT ARE DISCLAIMED. IN NO EVENT SHALL 
CALIFORNIA ENERGY COMMISSION, WRIGHTSOFT CORPORATION, ITRON, INC. OR ANY 
OTHER AUTHOR OR COPYRIGHT HOLDER OF THIS SOFTWARE (COLLECTIVELY, THE 
"AUTHORS") BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. EACH LICENSEE AND SUBLICENSEE OF 
THE SOFTWARE AGREES NOT TO ASSERT ANY CLAIM AGAINST ANY OF THE AUTHORS 
RELATING TO THIS SOFTWARE, WHETHER DUE TO PERFORMANCE ISSUES, TITLE OR 
INFRINGEMENT ISSUES, STRICT LIABILITY OR OTHERWISE.  

Return to Quick Start Topics Menu 
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