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Overview of ProperSync 

What is ProperSync 
ProperSync is an Outlook add-in that exposes SharePoint custom fields within Outlook. ProperSync 

supports the following items connected to Outlook 

 SharePoint Calendars 

 SharePoint Tasks 

 SharePoint Contacts 

What’s new in ProperSync 1.3 
 New Sync Engine 

a. Fixes Outlook conflict issues with items 

 Sync directly to any Outlook Contact, Calendar or Task folder 

a. Sync your team calendar to your personal calendar 

b. Sync your contacts to your team SharePoint CRM 
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Getting Started 

Installing ProperSync 
For individual users, ProperSync has one simple installer. To install ProperSync:  

1) Close Microsoft Outlook 

2) Open the ProperSync zip file downloaded from http://www.propersync.com/downloads.aspx  

3) Run the setup.exe file 

4) Click Next from the main screen 

 
5) Read the License Agreement, if you agree with the terms, click on the I Agree radio button, then 

click Next 

http://www.propersync.com/downloads.aspx
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6) Verify the Install Folder is correct, use the Browse button if you wish to correct it, then click 

Next 
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7) When ready to Install ProperSync, click Next on the Confirm Installation page 

 
8) The ProperSync installer will complete the installation of ProperSync on your machine. When 

the installation is complete the ProperSync Information screen will appear 
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9) Click Next after reading the ProperSync ReadMe information 
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10) The installation is now complete. Press Close to close the installer 

Activating ProperSync 
ProperSync can be activated directly within an Outlook appointment item or task. It can also be 

activated within the ProperSync settings area.  

To activate ProperSync within an Outlook appointment or task item 

1) Open Microsoft Outlook 

2) Browse to a SharePoint calendar or task list within Outlook 

3) Open an item from the list or select New Item from the Outlook menu 

4) On top of the ProperSync Pane, click the Activate Now link on the top of the ProperSync Fields 

pane (if this link is not present, then ProperSync is already activated) 

 
5) The ProperSync Activation window will open. Enter your license key in the Activation/License 

Key box, then press Activate. 

 
6) Once the key is properly activated, a response will be appear in the blank space 
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7) Click Close to close the ProperSync Activation dialog box 

To Activate ProperSync from Add-in Options 

Outlook 2007 

1) Open Microsoft Outlook 2007 

2) From the Tools menu select Options 

 
3) From the Options dialog box select the ProperSync tab 

4) From the ProperSync tab select View License Details 

 
5) The ProperSync Activation window will open. Enter your license key in the Activation/License 

Key box, then press Activate. 
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6) Once the key is properly activated, a response will be appear in the blank space 

 
7) Click Close to close the ProperSync Activation dialog box 

Outlook 2010 

1) Open Microsoft Outlook 2010 

2) Click on the File button 

 
3) From the File menu select Options 
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4) From the Options dialog box select Add-ins 

 
5) From the Add-ins sections select Add-in Options… 
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6) From the Add-ins Options dialog box select the ProperSync tab 

7) From the ProperSync tab press the View License Details button 

 
8) The ProperSync Activation window will open. Enter a license key in the Activation/License Key 

box, then press Activate. 

 
9) Once the key is properly activated, a response will be appear in the blank space 
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10) Click Close to close the ProperSync Activation dialog box 

Uninstalling ProperSync 
To uninstall ProperSync, use the default Windows uninstall process 

Windows 7 & Vista Users 

1) Close Microsoft Outlook 

2) Click the Start Menu and select Control Panel 

 
3) From the Control Panel select Uninstall a Program 
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4) From the list of installed programs select ProperSync 

 
5) From the menu select Uninstall 

 
6) From the dialog box press Yes 
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7) ProperSync will be uninstalled from the system 

Windows XP Users 

1) Close Microsoft Outlook 

2) From the Start Menu select Control Panel 

 
3) From the Control Panel select Add or Remove Programs 
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4) From the Add or Remove Programs windows select ProperSync and press Remove 

 
5) From the dialog box press Yes 

 
6) ProperSync will be uninstalled from the machine 
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Basics 

Manage Outlook & SharePoint Connections 
Users with Microsoft Outlook can attach any SharePoint calendar or task list they have permission to 

see. This is a simple client side operation that brings the functionality of SharePoint directly to your 

desktop.  

Why connect SharePoint calendars and tasks to your Outlook client? 

 Reminders on team events from team calendars in SharePoint 

 SharePoint tasks appear in the Outlook to-do list 

 Reminders on tasks from SharePoint tasks lists 

 Bring your SharePoint calendars and tasks offline 

 View/Update your team calendars directly from Outlook, no need to open a browser 

 Drag and drop calendar items  

 Copy items to your personal calendar 

Connect a SharePoint 2007 or 2010 List to Microsoft Outlook 

To connect a SharePoint calendar or task list to Microsoft Outlook 

1. Open a web browser and browse to your SharePoint calendar 

2. Copy the entire URL from the browser address bar (including the .aspx page) 

 
3. Open Microsoft Outlook, browse to your calendar. 

4. Right click on Calendar and choose New Calendar from the context menu 
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5. Give the new calendar a name (e.g. Team Calendar). Press OK. 

 
6. Right click on the new calendar (e.g. Team Calendar) and select Add ProperSync source… 
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7. Paste the URL in to the Add Source box 

 
8. Press Add  
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9. Choose the sync option for the list 

 
10. Press OK 

The following steps can be used for Tasks and Contacts as well. Simply browse to your task or contact list 

in a web browser, copy the link, switch to your Outlook task or contact area and follow the steps above. 

Remove Connection to a SharePoint List 

To remove a connection to a SharePoint list: 

1) Right click on the Outlook folder, in which the connection should be removed 

2) Click on Properties in the context menu 
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3) Click on the ProperSync tab in the window that appears 

 
4) Select the connection to remove 

5) Press Remove to remove the connection 

6) Press  OK to save the settings 

Modify a Connection on an Outlook folder 

To modify a current connection on an Outlook folder: 

1) Right click on the Outlook folder, in which the connection should be removed 

2) Click on Properties in the context menu 
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3) Click on the ProperSync tab in the window that appears 

a.  
4) Select the connect to modify then press Settings 

5) In the Settings dialog box, modify the settings, then press OK 
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a.  
6) Press OK in the Properties dialog box to save the settings 

Viewing ProperSync Fields in Outlook 

To view the custom columns on a SharePoint list, simply open a task or appointment from a SharePoint 

list, after ProperSync has been installed.  

ProperSync pane in an appointment item: 
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ProperSync pane in a task item: 

 

 

Supported ProperSync Field Types 
The ProperSync 1.3 supports the following field types:  

 Single Line of Text 

 Multiple Lines of Text (Plain Text) 

 Choice (Drop Down) 

 Choice (Radio Buttons) 

 Choice (Checkboxes) 

 Number 

 Number (Percentage) 

 Currency 

 Lookup 

 Date/Time 

 User & Groups - Users Only 

 Calculated Columns 

Required Fields in Outlook 
ProperSync will enforce required fields within the Outlook item. Required fields are indicated with a red 

text. If a user tries to save the item without filling out the required information ProperSync will alert the 

user of the required fields. 
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Required fields in the ProperSync Pane: 

 

ProperSync prompt for missing fields: 

 

Note: ProperSync only enforces the required fields that appear in Outlook. The fields that appear in 

Outlook can be controlled by list administrators. If a list administrator hides a required field from 

ProperSync, ProperSync cannot enforce the field. To control which fields are provided to ProperSync, 

refer to Controlling Fields in Outlook, later in this documentation. 
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Customizing ProperSync 

Sync Options Explained 
There are a few different sync options available for ProperSync 1.3. Please see the definitions below: 

 Download All Items (Full Sync) 

o Checking this box will download all items from the SharePoint list. Modifications made 

to those items will be updated in SharePoint. The new item must exist in SharePoint, 

new Outlook items will not be updated in this mode 

 Allow Adding New Items Locally 

o This allows users to publish some or all of their items to the SharePoint list. To publish to 

the connected SharePoint list, open the item and click on the Link To Remote button in 

the ribbon. 

 Automatically add new items – will not prompt. 

o This will sync all items on your calendar with SharePoint. All the information will be 

show in the list.  

Example Sync Scenarios 

 Only download SharePoint Items 

o Check Download All Items (Full Sync)  only 

 Only upload some of my items 

o Check Allow Adding New Items Locally only 

 Only upload all my items 

o Check both Allow Adding New Items Locally & Automatically add new items – will not 

prompt 

 Synchronize my entire calendar with SharePoint 

o Check all boxes 

Controlling Fields in Outlook 
There are two ways to control what fields are displayed on the ProperSync pane within Outlook. For 

each connected list, one of these approaches can be taken to control the ProperSync fields. 

Without any customizations, ProperSync will refer to the default view on the SharePoint list. ProperSync 

will show the selected columns in the order provided by the view. 

List administrators have the option of creating a special view for ProperSync. If a list has a view with the 

term “[propersync]” (including square brackets) in the name, ProperSync will use that view instead of 

the default view on the list.  

Notes: 

 All users connected to the list with ProperSync will see the same fields 

 Updates to the list view will propagate to all users within ten minutes of the change (users must 

be online) 
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 ProperSync only shows custom fields on a list. Default columns will be ignored, as they are 

already in the Outlook form 

 ProperSync only supports the selected columns and column order on a view. It does not 

currently support any other properties of the view (e.g. sort, filter, etc…). Future updates will 

improve upon this functionality 

Using the Default View of the List 

SharePoint 2007 

1) Open a web browser and browse to the SharePoint list 

2) From the Settings menu, select List Settings (if the settings menu is not present,  the current 

user does not have correct permission to the list) 

 
3) Scroll to the bottom of the page to see the Views on the list. The default view will be 

indicated with a checkmark 

 
4) Click on the default view to see the selected columns  
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5) The columns that are checked are the columns in the view. Any custom columns selected 

will appear in the ProperSync pane, in the order specified. 

6) Update and press OK to save the view.  

SharePoint 2010 

1) Open a web browser and browse to the SharePoint list 

2) Select List (or Calendar) tab from the SharePoint ribbon 

 
 

 
3) In the Settings section, click on List Settings 

 
4) Scroll to the bottom of the page to see the Views on the list. The default view will be indicated 

with a checkmark 
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5) Click on the default view to see the selected columns  

 
6) The columns that are checked are the columns in the view. Any custom columns selected will 

appear in the ProperSync pane, in the order specified. 

7) Update and press OK to save the view.  

Creating a [propersync] View 

SharePoint 2007 

1) Open a web browser and browse to the SharePoint list 

2) From the Settings menu, select Create View (if the settings menu is not present,  the 

current user does not have correct permission to the list) 
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3) From the Choose a view format list, select Standard View 

 
4) Give the view any name, but make sure to include the term “[propersync]” (including square 

brackets) 

 
5) Check the columns to appear on the ProperSync pane. Reminder: ProperSync will only show 

custom columns on the list. Any selected standard columns will be ignored. 
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6) Select the order in which you would like the columns to appear on the ProperSync pane 

 
7) Press OK to save the list view 

SharePoint 2010 

1) Open a web browser and browse to the SharePoint list 

2) Select List (or Calendar) tab from the SharePoint ribbon 
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3) In the Manage Views section, click on Create View 

 
4) From the Choose a view format list, select Standard View 

 
5) Give the view any name, but make sure to include the term “[propersync]” (including square 

brackets) 
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6) Check the columns to appear on the ProperSync pane. Reminder: ProperSync will only show 

custom columns on the list. Any selected standard columns will be ignored. 

 
7) Select the order in which you would like the columns to appear on the ProperSync pane 

 
8) Press OK to save the list view 
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ProperSync Options 

Enabling Logging 

Outlook 2007 

1) Open Microsoft Outlook 2007 

2) From the Tools menu select Options 

 
3) From the Options dialog box select the ProperSync tab 

4) From the ProperSync tab use the Log Level dropdown to choose the type of logging you require.  

a.  
5) Once the logging level has been set, press OK to apply the settings 
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Outlook 2010 

1) Open Microsoft Outlook 2010 

2) Click on the File button 

 
3) From the File menu select Options 

 
4) From the Options dialog box select Add-ins 
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5) From the Add-ins sections select Add-in Options… 

 
6) From the Add-ins Options dialog box select the ProperSync tab 

7) From the ProperSync tab use the Log Level dropdown to choose the type of logging you require.  
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a.  
8) Once the logging level has been set, press OK to apply the settings 

 

Updating/Changing Activation Key 

Outlook 2007 

8) Open Microsoft Outlook 2007 

9) From the Tools menu select Options 

 
10) From the Options dialog box select the ProperSync tab 

11) From the ProperSync tab select View License Details 
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12) The ProperSync Activation window will open. Enter the new or updated license key in the 

Activation/License Key box, then press Activate. 

 
13) Once the key is properly activated, a response will be appear in the blank space 

 
14) Click Close to close the ProperSync Activation dialog box 

Outlook 2010 

11) Open Microsoft Outlook 2010 

12) Click on the File button 

 
13) From the File menu select Options 
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14) From the Options dialog box select Add-ins 

 
15) From the Add-ins sections select Add-in Options… 
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16) From the Add-ins Options dialog box select the ProperSync tab 

17) From the ProperSync tab press the View License Details button 

 
18) The ProperSync Activation window will open. Enter the new or updated license key in the 

Activation/License Key box, then press Activate. 

 
19) Once the key is properly activated, a response will be appear in the blank space 
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20) Click Close to close the ProperSync Activation dialog box 


