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UM1480
User manual

STM8SVLDISCOVERY
quick start guide

Introduction
The STM8SVLDISCOVERY, based on the STM8S003K3T6, is a quick-start evaluation 
board for the 8-bit mainstream line of MCUs. It is the cheapest and quickest way to discover 
the STM8S Value line features and performance, to program and use the device, and to 
build and debug applications using the embedded debugger ST-LINK.

Simply connect the STM8SVLDISCOVERY to a PC through a standard USB cable, and run 
the pre-programmed example. Once the debugger is open, you can see the real-time 
execution of the code. Applications are provided to allow you to learn, reuse and modify their 
source code. This can be used for a quick proof-of-concept, evaluation or demonstration 
prototype.

The STM8SVLDISCOVERY is ideal for hobbyists, developers, students and support teams. 
By using this document as a guide and trying out the application examples, you can quickly 
familiarize yourself with the STM8SVLDISCOVERY and all its possibilities.

Visit www.st.com/stm8svldiscovery to access all related user manuals and application 
notes.

Reference documents
■ STM8SVLDISCOVERY user manual (UM1482)

■ Developing and debugging your STM8S-DISCOVERY application code (UM0834)

■ ST Visual Develop (STVD) user manual (UM0036)

■ Adjustable LED blinking speed using STM8SVLDISCOVERY (AN3996)

■ STM8S reference manual (RM0016)

■ STM8S003 datasheet

www.st.com

www.BDTIC.com/ST

http://www.st.com
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1 Getting started

The present document provides a quick overview on how to get started with your STM8S 
Value line application.

For all details on application development and debugging refer to the user manual 
Developing and debugging your STM8S-DISCOVERY application code (UM0834).

Note: UM0834 is pertinent to the STM8S-DISCOVERY and may require adaptation to be used 
with the STM8SVLDISCOVERY.

1.1 System prerequisites
Before using the STM8SVLDISCOVERY, the following material is required:

● A Windows PC (XP, Vista, 7)

● A USB type A to B cable

1.2 Discover demo
The STM8SVLDISCOVERY comes pre-programmed with the Discover demo. This self-
teaching demo makes LD1 LED blink at different speeds when the user push button is 
pressed. 

1. Simply connect the STM8SVLDISCOVERY to your PC using a USB cable.

2. The application immediately starts and LD1 starts toggling slowly (every second). 

3. Each time a user push button event is detected, LD1 blinking speed increases until:

4. The third time the button is pressed results in the LED being switched off. 

5. You can then restart a blinking cycle from the 200ms blinking speed state (see Table 1). 

For demo details, download application note AN3996 on www.st.com/stm8svldiscovery.

For details about the board, refer to STM8SVLDISCOVERY user manual UM1482.

         

1.3 Quick start tutorial (less than 20 minutes)
This tutorial explains how to start running one of the STM8SVLDISCOVERY application 
examples from scratch in less than 20 minutes.

Table 1. Application

Push button  LED1  Period

At application start-up (only) Toggle 1 sec

1st press Toggle 200 ms

2nd press Toggle 100 ms

3rd press Switched off N/A

www.BDTIC.com/ST
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1.3.1 Software environment (optional)

1. Download your free software environment (IDE). Choose between:

a) IAR Embedded Workbench® for STM8 available on www.iar.com, which includes 
its own compiler, 

b) STMicroelectronics MCU toolset composed of ST Visual Develop (STVD) and ST 
Visual Programer (STVP) available on http://www.st.com.
STVD requires either Cosmic or Raisonance freeware compilers:
- Cosmic for STM8 available on http://www.cosmicsoftware.com/download.php 
- Raisonance 32K for STM8 available on www.mcu-raisonance.com To install the 
Raisonance compiler, download both Ride7 and the Raisonance kit RKit-STM8 
and follow the installation wizard instructions

Note: 1 A free license is required to use the compilers. You will receive the license file by e-mail, this 
procedure is not automatic so it may take a few hours or a few days (after the week-end), 
depending on your location and time zone, before you receive your license file.

2 For installation details of your IDE and/or your compilers, read Chapter 2 of UM0834 
available on www.st.com/stm8s-discovery.

1.3.2 Running the STM8SVLDISCOVERY application examples

The STM8SVLDISCOVERY is provided with some application examples available on 
www.st.com/stm8svldiscovery.

Ensure your free software environment is correctly installed. 

1. Download one of the application examples and its associated application note 
(available on www.st.com/stm8svldiscovery) and extract the directory 
STM8SVLDISCOVERY_Example on your PC.

2. Run the IDE of your choice: STVD or IAR.

If you chose STVD

1. Select File -> Open Workspace and browse for the Example.stw project that you 
intend to run:

– Cosmic: 
STM8SVLDISCOVERY_Example/Project/Example/STVD/Cosmic/Example.stw.

– Raisonance: 
STM8SVLDISCOVERY_Example/Project/Example/STVD/Raisonance/
Example.stw.

2. Configure STVD to use ST-LINK as the debug instrument:

a) Click Debug Instrument -> Target Settings.

b) Select target Swim ST-LINK in the target list.

3. Click Build -> Rebuild All to build your application.

4. Click Debug -> Start Debugging to download your application to the STM8S program 
memory and start the debug session.

5. Run the application code in Debug or Stand-alone mode:

a) Click Debug -> Run to run your application in debug mode.

b) Click Debug -> Stop Debugging to disconnect the debugger; then the application 
starts running immediately in stand-alone mode.

www.BDTIC.com/ST
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If you chose IAR

1. Select File -> Open -> Workspace and browse for the Example.eww project that you 
intend to run: 
STM8SVLDISCOVERY_Example/Project/Example/EWSTM8/Cosmic/Example.eww

2. Configure EWSTM8 to use ST-LINK as the debug instrument:

a) Right-click on the project name Example in the Workspace window and select 
Options...

b) In Category Debugger, select target ST-LINK in the menu Driver.

3. Click Project -> Rebuild All to build your application

4. Click Project -> Download and Debug to download your application to the STM8S 
program memory and start the debug session

5. Run the application code in Debug or Stand-alone mode:

a) Click Debug -> Go to run your application in debug mode

b) Click Debug -> Stop Debugging to disconnect the debugger; then the application 
starts running immediately in stand-alone mode.

Once the selected application is running in one of the above IDEs, check whether it 
operates as described in the application note associated with the example.

Note: Some of the examples require additional components to work properly. See the application 
note associated with the example to find out more.

1.3.3 Developing your own application

1. Ensure the free software environment of your choice (IDE and/or compilers) is correctly 
installed. If this is not already done, refer to Section 1.3.1.

2. Install one of the STM8SVLDISCOVERY application examples:

a) Download ANxxxx.zip from www.st.com/stm8svldiscovery (zip file available 
together with this ANxxxx) and extract the directory structure on your PC.

b) Duplicate the project_template directory and rename it (My_own_project).

3. Run the Integrated Development Environment of your choice.

4. Select File -> Open Workspace.

5. Open the project My_own_project following the procedure explained in section 
Section 1.3.2:

– STVD with Cosmic: 
STM8SVLDISCOVERY_My_own_project/Project/My_own_project/STVD/
Cosmic/STVD_workspace.stw

– STVD with Raisonance: 
STM8SVLDISCOVERY_My_own_project/Project/My_own_project/STVD/
Raisonance/STVD_workspace.stw

– IAR Embedded Workbench (EWSTM8):
STM8SVLDISCOVERY_My_own_project/Project/My_own_project/STVD/
EWSTM8/workspace.eww

www.BDTIC.com/ST
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If you chose STVD

1. Check that appropriate MCU is selected:

a) Go to Projects>Settings>MCU and check that STM8S003K3 is displayed in the 
selected MCU field. 

b) If not already done, select it from the MCU list and ensure that this MCU is 
displayed in the selected MCU field before clicking OK.

2. Add your project files to the STVD workspace windows then build and debug your 
application code.

If you chose IAR with IAR Embedded Workbench for STM8

1. Check that appropriate MCU is selected:

a) Right-click on the project name My_own_project in the Workspace window and 
select Options...

b) In General Options category, select STM8S003K3U as Target Device.

2. Check that all the path of your project include directories are defined

a) Right-click on the project name My_own_project in the Workspace window and 
select Options...

b) In C/C++ Compile Category, select Preprocessor tab.

c) If not already set, add your relative include directory paths using $PROJ_DIR$ key 
world as follow for instance:

– $PROJ_DIR$\..\inc

– $PROJ_DIR$\..\..\..\Libraries\STM8S_StdPeriph_Driver\inc

3. Add your project files to the IAR EWSTM8 workspace window then build and debug 
your application code.

This procedure provides for a prestructured project workspace and simplifies your project 
design.

Detailed instructions on project creation are provided in the user manual UM0834, 
Developing and debugging your STM8S-Discovery application code, available for download 
from www.st.com/stm8s-discovery.

www.BDTIC.com/ST



Support UM1480

8/10 Doc ID 022385 Rev 1

2 Support

For support go to www.st.com, select the Support button and choose either:

– ST e2e Communities and visit our STM8SVLDISCOVERY forum (or access 
directly from www.st.com/e2e).

– Online Support, and contact our technical support.

www.BDTIC.com/ST
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3 Revision history

         

Table 2. Document revision history

Date Revision Changes

24-Nov-2011 1 Initial release.
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Please Read Carefully:

Information in this document is provided solely in connection with ST products. STMicroelectronics NV and its subsidiaries (“ST”) reserve the
right to make changes, corrections, modifications or improvements, to this document, and the products and services described herein at any
time, without notice.

All ST products are sold pursuant to ST’s terms and conditions of sale.

Purchasers are solely responsible for the choice, selection and use of the ST products and services described herein, and ST assumes no
liability whatsoever relating to the choice, selection or use of the ST products and services described herein.

No license, express or implied, by estoppel or otherwise, to any intellectual property rights is granted under this document. If any part of this
document refers to any third party products or services it shall not be deemed a license grant by ST for the use of such third party products
or services, or any intellectual property contained therein or considered as a warranty covering the use in any manner whatsoever of such
third party products or services or any intellectual property contained therein.

UNLESS OTHERWISE SET FORTH IN ST’S TERMS AND CONDITIONS OF SALE ST DISCLAIMS ANY EXPRESS OR IMPLIED
WARRANTY WITH RESPECT TO THE USE AND/OR SALE OF ST PRODUCTS INCLUDING WITHOUT LIMITATION IMPLIED
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE (AND THEIR EQUIVALENTS UNDER THE LAWS
OF ANY JURISDICTION), OR INFRINGEMENT OF ANY PATENT, COPYRIGHT OR OTHER INTELLECTUAL PROPERTY RIGHT.

UNLESS EXPRESSLY APPROVED IN WRITING BY TWO AUTHORIZED ST REPRESENTATIVES, ST PRODUCTS ARE NOT
RECOMMENDED, AUTHORIZED OR WARRANTED FOR USE IN MILITARY, AIR CRAFT, SPACE, LIFE SAVING, OR LIFE SUSTAINING
APPLICATIONS, NOR IN PRODUCTS OR SYSTEMS WHERE FAILURE OR MALFUNCTION MAY RESULT IN PERSONAL INJURY,
DEATH, OR SEVERE PROPERTY OR ENVIRONMENTAL DAMAGE. ST PRODUCTS WHICH ARE NOT SPECIFIED AS "AUTOMOTIVE
GRADE" MAY ONLY BE USED IN AUTOMOTIVE APPLICATIONS AT USER’S OWN RISK.

Resale of ST products with provisions different from the statements and/or technical features set forth in this document shall immediately void
any warranty granted by ST for the ST product or service described herein and shall not create or extend in any manner whatsoever, any
liability of ST.

ST and the ST logo are trademarks or registered trademarks of ST in various countries.

Information in this document supersedes and replaces all information previously supplied.

The ST logo is a registered trademark of STMicroelectronics. All other names are the property of their respective owners.

© 2011 STMicroelectronics - All rights reserved

STMicroelectronics group of companies

Australia - Belgium - Brazil - Canada - China - Czech Republic - Finland - France - Germany - Hong Kong - India - Israel - Italy - Japan - 
Malaysia - Malta - Morocco - Philippines - Singapore - Spain - Sweden - Switzerland - United Kingdom - United States of America
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