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OLYMPUS

LICENSE AGREEMENT between END USER and OLYMPUS SOFT
IMAGING SOLUTIONS regarding the OSIS cell*M/cell"R SOFTWARE
PRODUCT.

IMPORTANT-READ CAREFULLY: Below you will find the contractual
agreements governing the use of the OSIS cell*M/cell"R SOFTWARE
PRODUCT. These conditions apply to you, the user, and to
OLYMPUS SOFT IMAGING SOLUTIONS. With any of the following
actions you explicitly agree to be bound by the conditions of this
contract: purchasing the software, opening the package, breaking of
one of the seals or using the software.

In case you do not agree with any of the conditions of this contract,
please return all parts of the product including manuals and the
software protection key before using and without delay. Remove all
software installations of the product from any computer you might
have installed it on. Return all electronic media of the product or
completely destroy all electronic media of the product and send proof
that this has been accomplished. For a refund, please return every-
thing to where you purchased the product.

§ 1. Scope

(1) This License agreement explicitly covers only the software disk-
ettes or other media you received with the purchase and the software
stored on these media, the manuals, as far as they were developed
and produced by OLYMPUS SOFT IMAGING SOLUTIONS.

§ 2. User rights

(1) OLYMPUS SOFT IMAGING SOLUTIONS permits the User, for the
duration of this contract, to use the software on a single computer
and a single terminal on that computer. This license is explicitly non-
exclusive, i.e., the User does not have an exclusive right to use the
software. As a licensed user you can copy the software from one
computer to another by using a computer network or other storage
devices, as long as it is assured, that the software can only be used
on a single computer or terminal at any time and that the conditions
set forth under § 4 are observed.

(2) The User has the right to produce a copy of the software only for
backup purposes.

§ 8. Additional user rights

Only if OLYMPUS SOFT IMAGING SOLUTIONS provides the User
with permission in written form the User can incorporate parts of the
software into other software developed by the User. A distribution of
the software can only be made in compiled form as part of the soft-
ware developed by the User under strict observation of the conditions
set forth in the written permission to the User. The User must include
the OSIS cell*M/cell"R SOFTWARE PRODUCT copyright notification
with the User's software. The User has to make sure, that OLYMPUS
SOFT IMAGING SOLUTIONS cannot be held liable for any damages
or injuries resulting from the use of the User's software, that include
parts of the OSIS cell*M/cell®R SOFTWARE PRODUCT.

§ 4. Copyright

(1) OLYMPUS SOFT IMAGING SOLUTIONS or its subsidiaries remain
owners of the software and it's documentation. With the purchase,
the User obtains ownership of the diskettes or other physical storage

devices (excluding the software and other data contained thereon),
the manuals, and the software protection key.

(2) OLYMPUS SOFT IMAGING SOLUTIONS reserves the right to all
publications, duplication, editing, and marketing of the software and
the software documentation.

Without prior written permission the User may not:

- change, translate, de-compile or de-assemble the software,

— copy any of the written or printed documentation of the software,
—rent, lease, or license the software to a third party,

— use the software protection different than described in this contract.
(3) The license, property, and user rights to the OLYMPUS SOFT
IMAGING SOLUTIONS software, disks, and manuals may only be sold
or transferred to a third party on a permanent basis, if the third party
agrees to abide by the conditions in this contract.

(4) OLYMPUS SOFT IMAGING SOLUTIONS is the legal owner of all
copyrights and trademarks of the OSIS cell*M/cell®"R SOFTWARE
PRODUCT and documentation. Copyrights and trademarks are
protected by national and international law. OLYMPUS SOFT
IMAGING SOLUTIONS reserves all rights, which are not explicitly
expressed in written form.

§ 5. Warranty

(1) OLYMPUS SOFT IMAGING SOLUTIONS guarantees for the period
of 12 months after the date of purchase, that the software works in all
major aspects according to the descriptions in the manuals.
OLYMPUS SOFT IMAGING SOLUTIONS, as the producer of the
software, provides this warranty. It does not replace or restrict other
warranties or liabilities provided to the User by local or other sales
people or organizations. OLYMPUS SOFT IMAGING SOLUTIONS
does not guarantee that the software is defect free; that the software
fulfills the specific requirements of the User, or that the OBS
cell"M/cell"R  SOFTWARE PRODUCT works with other software
provided by the User.

(2) OLYMPUS SOFT IMAGING SOLUTIONS further guarantees, that
the software storage devices (floppy disks, CD-ROMs, etc.) and the
manuals are free of material defects. Defective storage devices or
manuals will be replace free of charge, if they are returned to
OLYMPUS SOFT IMAGING SOLUTIONS within 90 days of purchase
and accompanied by a proof of purchase.

§ 6. Liability

(1) OLYMPUS SOFT IMAGING SOLUTIONS or their sales organiza-
tions cannot be held liable for damages or injuries resulting from the
use of the software or the lack of capabilities of the software, unless
the User can show gross negligence on the part of OLYMPUS SOFT
IMAGING SOLUTIONS. This applies, without exceptions, also to
losses of productivity or profit, interruptions in the flow of business or
manufacture, loss of information, and other financial losses. Without
exceptions the possible liability of OLYMPUS SOFT IMAGING
SOLUTIONS is limited to the amount that the User paid for the
product. These limitations on the liability do not influence claims for
reasons of product liability.

§ 7. Contract duration, legal consequences of violating the license

(1) The contract is deemed to be in force for an unspecified period.
The User rights are automatically terminated if one of the conditions
of the contracts has been violated.



(2) In case of a contract violation the User has to return the original
storage devices and all copies thereof including all modified copies,
all printed and written documentation, and the software protection
key to OLYMPUS SOFT IMAGING SOLUTIONS, or the User has to
destroy these items.

OLYMPUS

() In addition OLYMPUS SOFT IMAGING SOLUTIONS reserves the
right to file a lawsuit to claim reparations for damages, non-
compliance, or removal of the software in case of license violations.
The following laws and/or conditions are in effect: the conditions of
this contract, copyright laws, and the laws of the civil code.
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1 Introduction

Thank you very much for purchasing Olympus' state of art cellM or cell*R Imaging Station and for
your confidence in our products and service. It is Olympus' main objective to provide you with solu-
tions able to meet your experimental demands and thus pave the way to your scientific success.
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Introduction

The concept and technology of cell*M / cell*R introduces the next generation of imaging worksta-
tions. cellM / cell*R is designed as a modular imaging system for a broad range of life science
experiments that supports the Olympus microscopes of the IX and BX series. Hallmarks of the
systems are:

e The unique all-in-one lllumination System MT10 or MT20 for fast wavelength switch and at-
tenuation to meet the experimental requirements for fast real-time acquisition by highly sensitive
digital cameras.

e cell*R: The Real-Time Controller, a hyper-precision control board to synchronize the all the
hardware devices and modules. This additional independent plug-in CPU board assures highest
accuracy in experiment timing (temporal resolution: 1 ms; precision < 0.01 ms). In practice this
ensures that illumination of the specimen can be strongly limited to the acquisition of the image.
As a consequence bleaching and photo damage of the specimen can be minimized.

e cell*M: The System Coordinator, a control board to synchronize the all the hardware devices
and modules (temporal resolution: 1 ms). It carries out all the tasks that cell*R's Real-Time Con-
troller does, but lacks its timing precision and ability to run all tasks in parallel.

e The sophisticated cell*R / cell®M imaging software is a powerful all-embracing platform that
features an intuitive and user-friendly graphical drag-and-drop interface, the Experiment Man-
ager, for setting up and executing even the most complex experiments in a convenient and con-
cise way. A structured database for multi-dimensional data handling (xyz, time, color) is also
included, as well as tools for image processing, image analyses, and more complex analysis,
like rationing, AF/F, FRET, and spectral unmixing. The integrated Imaging C Module and Macro
Recorder gives the opportunity for advanced users to customize applications and automate
functions.

This manual is the complete documentation necessary for using the Olympus imaging station
cell*M / cell*R correctly and efficiently.

Special care has been undertaken for this manual to guarantee correct and accurate information,
although this is subject to changes due to further development of the imaging station cell*M /
cell*R. Thus, the manufacturer cannot assume liability for any possible errors. We would appreciate
reports of any mistakes as well as suggestions or criticism.

If you find any information missing in this manual or you need additional support, please contact
your local Olympus dealer.
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2 System Overview

The following chapter gives you a short overview of the basic cell®M / cell®R system components
(without additional peripherals). The system consists of different hardware and software devices,
which are full integrated.
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2.1 System Chart

The system chart shown exemplifies the different components of a standard cell*R system and
how they are interconnected.
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2.2 Hardware

The hardware devices of the cell*M / cell*R imaging station are listed below:
¢ Olympus microscope of the IX or BX series, according to your specification.

e CCD camera: SIS F-Viewll-T, Hamamatsu ORCA2-AG or others. General features are high reso-
lution CCD cameras, mostly 1.3.Megapixels on a 2/3” chip, latest generation interline transfer
chip with high quantum efficiency, 12 bit data output via IEEE-1394 (FireWire™) interface, selec-
tion of sub-frames, and on-chip binning.

e lllumination System MT10 / MT20, bearing the arc burner (150W Xe or 150W Xe/Hg), the motor-
ized filter wheel (8 positions), attenuator (14 levels) and shutter.

e cell*M System Coordinator / cell*R Real-Time Controller for multi-task acquisition: bears an 1/0
panel with three BNC plugs to trigger peripherals, and RS-232 sockets to integrate external de-
vices such as motorized microscope controllers (UCB), piezo objective movers (PIFOC).

e Computer: latest generation PC with all standard features, modified for hardware control and
peripherals integration, monitor.

¢ System-specific accessories (filter sets etc.).

221 Motorized Microscope Modules

Both cell*M and cell*R support the following motorized IX2 and BX2 microscope components:
e z-drive

¢ fluorescence filter turret

¢ transmission condenser

e ocular-to-camera switch

e bottom-to-side port switch

e observation filter wheel

e transmission shutter
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2.3 Software

cellAM / cell*R Configuration Software to configure the lllumination System MT10 / MT20.

cell*M / cell*R Imaging Software integrating the Experiment Manager for planning and execut-
ing experiments, Viewport, Viewport Manager, and Image Manager for managing and displaying
the images on the desktop, Image and Graph Analysis tools to analyze the acquired data, and a
database for storing and archiving the images.

cellM / cell*R software updates only: Update Software for the cellM System Coordinator /
cell*R Real-time Controller and the MT10 / MT20 electronics
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3 Brief Introduction to the
Software and First Steps

The following sections explain the basic cell®M / cell*R features and functions. They also introduce
the most important terms used in the software and in this manual and thus should help you to get
started.

For you to follow the contents of this chapter it is necessary that the system (hardware and software)
has been installed and properly configured. For a detailed description of the system installation and
configuration read Chapter 15, cell®M / cell*R Configuration, of this manual carefully as well as the
Hardware Manual, especially Chapter 7, System Assembly and Adjustment.

3.1 The cell®M / cell*R User Interface .......cccoecceeeeeiieneeiieeeceee e 8
3.1.1  The Image Manager ......cccuuoioeeiiieeei e 9
3.1.2  The Viewport Manager.........ooccuueeiieeiiiieiieeeeee e 10
3.1.3  The VIEWPOI ..ceiiiii ittt 10
3.2  Simple Image ACQUISITION ....cc.ioeiiiiiiiiei e 12
3.3 Saving Images — The Database ........cccccvieiieiiiiieiiicceeeeee s 13
3.4 Loading IMAJES ....ceeiieriiieeiee e 14
3.5 Conducting Experiments with the Experiment Manager ................. 14
3.6  Displaying Multi-Color IMages.........ccceeraeiierieniie e 16

3.7  Displaying SEQUENCES .......cceiiiiiiiiiiiiieie e e sssvrree e s e sanes 17

7
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cellrR screenshots are being displayed throughout this manual. cell®M screenshots
are identical but for the label in the upper left corner of the main window.

3.1 The cell®M / cell*R User Interface
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To start the cell*M / cell*R software double-click the cell*M / cell*R icon on your desktop or open
it via Start » Programs » cell®R(M). The screenshot below shows the program's graphical user
interface (GUI). It is composed of:

a
b

«Q

e

Menu bar: access to pull-down menus with assorted commands.

Tool bar: direct access to the most important commands for image acquisition, processing and
analysis.

Status bar: shows the connected CCD camera and displays information depending on the ac-
tive functions.

Viewport Manager (top left below button bars): shows a thumbnail of the active image; a red
rectangle indicates the current zoomed-in sector of the image in the Viewport. The rectangle
can be mouse-dragged across the thumbnail to bring a different area into display.

Image Manager (underneath the Viewport Manager): consists of two parts:

— the Operand Box, an operational area to determine source and destination buffers for
image processing
— the Image Buffer Box listing the currently loaded images or graphs. Four tabs are
available:
1 The List View that lists the names, the XY size and the bit depth of the images.
2 The Gallery View that shows thumbnails of the images.
3 The Graph View that shows thumbnails of loaded graphs.
4 The Measurement View that lists the results of area and length measurements in
images.
Documents Area which always contains:
Viewport: displays the active image or a selection of currently loaded images.
Graph document: the currently active graph (if a corresponding analysis has been carried out).
It is minimized when cell*R is started.
Additionally the Documents Area may contain:
Database Documents
Data Sheets

Text Documents and Macros

3.1.1 The Image Manager

In the Image Manager different image types, like single color images, multi-color images, or the
various image sequences (z-stack; time-lapse, etc.), are represented by different symbols.

The highlighted image frame in the Image Manager field is active and displayed in the Viewport
Manager and the Viewport.
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2 ctack multi-color Z-stack

single-color image multi-color image
e
]

= single-color time-lapse | multi-color time-lapse

E single-color Z-stacks in time-lapse 13 multi-color Z-stacks in time-lapse

3.1.2 The Viewport Manager

The image in the Viewport Manager in the top left corner of the cell*R / cellAM window shows a red
rectangle. It represents the region of the image currently displayed in the Viewport - if the image is
zoomed to an extent that is larger than the Viewport. The rectangle is interactive: It can be freely
moved within the Viewport Manager to display different areas in the Viewport. It can also be resized
by mouse drag to change the zoom factor in the Viewport display.

3.1.3 The Viewport

The Viewport window allows displaying one image or a number of images at the same time. The
number of Viewports to be displayed and their arrangement can be set using the Arrange View-
ports button in the toolbar of the Image window. Just mark the columns and rows by moving the
mouse cursor over the schematic Viewport, which opens with 4x4 image icons symbolizing inde-
pendent image areas. The maximum number of images that can be shown at one time is 16 (4x4)
by default.

This setting can be increased to 5x5 as maximum via the Display Properties. Right-click on the
Viewport Manager to open the Display Properties window and change the Viewport limit entry
accordingly.
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3.2

Simple Image Acquisition

= s
T | Live View, = | Snapshot, | Camera Control, =% | lllumination Settings

The most important tools for simple image acquisition are the Live View and Snapshot buttons
and the control boxes that are opened by the Camera Control and lllumination Settings buttons;
all can be found in the Acquisition toolbar.

In the following a typical procedure for the acquisition of a fluorescence image will briefly be de-
scribed. For detailed explanations, see Chapter 4, Image Acquisition and lllumination Control.

Make sure to select the correct objective and fluorescence filter and place your sample on the
stage. The usage of the microscope will not be explained here.

Click lllumination Settings to open the lllumination system MT20 / MT10 control box.

Click Main switch / Burner ON to ignite the burner. (For a stable light output, wait about
10 min.)

Click on one of the Excitation filter buttons to select an illumination color.

Click Camera Control to open the corresponding window. Reasonable starting settings
are:
— Binning 2x2
— Exposure time 50 ms
—  Brightness adjustment automatic
These settings have to be adjusted in the course of the working session.

Direct the light path of the microscope to the camera. (Of course, focusing can be done
via the ocular, but this will not be explained here.)

Click Shutter in the lllumination System MT20 / MT10 control box to illuminate the
specimen.

5] 1
il |
'-|H 2.
3.
=4
5.
5 | 6.
e 7

Click Acquire in the Acquisition toolbar or the Camera Control window. The following
happens:
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— The camera starts acquiring images at maximal speed. None is stored; instead, the
newest image overwrites the previous one in the temporary buffer.

- The current image is displayed in the active Viewport.

— A single image icon appears in the Image Buffer Box.

Focus your sample with the microscope Z-drive. (Even if the optional PIFOC is available
for focus change, its total range may be too narrow to find the focus at the beginning.
For this reason it is usually better to start with the Z-drive.)

If necessary, change the Binning factor in the Camera Control window: 1x1 in order to
get highest spatial resolution, larger factors increase the signal intensity at the cost of
resolution.

10.

Adjust the Exposure time for a good signal-to-noise ratio.

. Click Snapshot in the Acquisition toolbar or the Camera Control window to stop the

Live View. The very last image is being stored as a Snapshot in the Image Buffer Box
and displayed in the Viewport.

If’i 12.

Click Shutter in the MT20 / MT10 control box to stop the illumination.

13.

Save your image as described in the next chapter.

o Select an empty buffer in the Image Manager if you want to acquire a new image, oth-
erwise the current image will be overwritten and lost: snapshots are only stored tempo-
rarily and need to be saved.

3.3

Saving Images - The Database

To save a snapshot in the most basic way select File » Save from the menu bar or use the short cut
<Ctrl + s>. The snapshot will be stored in a 16-bit tiff format by default. Other data types can be
chosen as usual in the Save Image As window. As with other files, you have to give a name and
select the destination (path) of the storage.

cell*R / cellM features a database module for the storage of images and entire experiments in-
cluding Experiment Plans, data sets, analyses and so on. The module is explained in detail in
Chapter 12, Database.

13
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The command Open Database... to load an existing one can be found redundantly in the menus
File, Acquisition and Database. Database files carry the extension *.apl. New databases can be
created with the command New Database..., to be found in the same menus.

In order to be able to store your images in the database, first you have to create an experiment
folder via Database » Insert » Experiment... (or use an existing one). To store an image in the
database just drag it from the Image Buffer Box into the experiment folder. You will be asked in a
dialog box to give it a name.

o Images acquired via the Experiment Manager will be stored automatically in a data-
base.

3.4 Loading Images

To load images that are not stored in a database and to display them in the Viewport use the com-
mand File » Open (short-cut <Ctrl + 0>) or click on the Open button in the toolbar. As usually you
have to navigate to the storage folder of the file and select it.

Open the experiment folder in the database to load an image or an image sequence from it (see
previous chapter 3.3). In the Structure Strip on the left hand side of the database window you will
find the Image Icon and in the Gallery Field — the Image Thumbnail. Drag either the icon or the
thumbnail into the Viewport or the Image Manager to load the image set.

3.5 Conducting Experiments with the Experiment
Manager

28 | Experiment Manager

In general, most imaging applications in life science are rather complex and go beyond taking sim-
ple snapshots, for example, multi-color imaging, time-lapse imaging, ion imaging with ratiometric
fluorescence dyes, multi-dimensional imaging, etc. The cell*R / cell®M Imaging Software includes
the Experiment Manager, an easy-to-use and intuitive tool to plan, configure and execute even
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the most complex experiments without any programming knowledge. The Experiment Manager is
explained in every detail in chapter 5. In the following only a brief introduction will be given.

To open the Experiment Manager click the Experiment Manager button in the acquisition toolbar.
Experiment Plans are set-up by assembling and connecting diverse command icons and frames.
The most frequent ones can be selected via buttons in the Standard Command toolbar and
placed into the editing area by drag&drop.

Standard Commands

CImEmy e

Image Acquisition, Multi-Color, Z-Stack and Time Loop

A Properties page to specify certain settings accompanies each command icon that is placed into
the editing area. In case of Image Acquisition, for example, parameters such as exposure time
and excitation filter have to be set.

The scheme below is just one example of an experiment plan. It shows the command icons that
define a multi-color time-lapse experiment. There are three Image Acquisition icons, each with a
different excitation filter, surrounded by a multi-color frame for combination of the three Image
Types (monochrome images) to one multi-color image. The outer frame represents a Time Loop to
repeat all commands contained a certain number of times.

| | |
My - — 'ﬂ — - 3 »
Dapi lﬁ' Fitc W‘ TxRed lﬁ'

30x1,50s

The Experiment Manager is not only a tool to design the experiments, but also the command center
to acquire the images according to the Experiment Plan. The necessary icons are grouped in the
Control Center toolbar.

ontrol Center [

v B I

Check!, System Ready!, Start!, Pause and Stop

The execution of an Experiment Plan involves three steps:

1. Check!: The system verifies if the execution of the Experiment Plan is feasible or if there
are invalid parameters or logical faults.

2. System Ready!: The Experiment Plan is downloaded to the Real-Time Controller and
data storage space is allocated on the hard disk.
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3. The experiment itself is started, paused and stopped with Start!, Pause, and Stop.

o Any image or image sequence acquired with the Experiment Manager is automatically
stored on the hard disk in a cell*R / cell*M database.

3.6 Displaying Multi-Color Images

2 - i - I_
&l Color Channels

v 1 Fura340
v 2 Fura3so

Seleck Transmission. ..

Select Intensity Modulation, ., Select Color Channel

Multi-color cell*R / cell®M images consist of several color channels — in principle the number is
unlimited. Each channel contains a monochrome image of predefined color resulting from one Im-
age Acquisition command in the Experiment Plan. When loaded from an archive all color channels
are displayed together in an overlay resulting in a color image. The Select Color Channel button in
the Navigation toolbar provides a tool to navigate easily through all color channels and to display
selected ones.

| Display Intensity

Adjusting the single color intensities with the dialog box of the Display Intensity command can
optimize the look of the multi-color image. For details, see Chapter 6.2.2, Adjust Display.
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3.7 Displaying Sequences

i - = - T B bl

Navigation

Time-Lapse experiments and Z-stack acquisitions generate series of images that are all stored
together within one file. The individual images can be accessed with the navigation buttons (First,
Previous, Next, Last) in the Navigation toolbar. The number in the Go To field represents the
actual frame displayed in the Viewport.

An additional feature enables the user to animate image sequences and play it as a movie. Pressing
the Animate button opens the Animate Image Stack window.

Animate Image Stack @

4 » o B

J

ly Animate

Here you find the buttons to start (Play) the animation, to Stop it and to play it in the Reverse
mode.

LlLILI Reverse, Stop and Play

For a detailed description of the navigation tools see Chapter 6.3, Image Navigation.

17
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4

Image Acquisition and
Hardware Control

Chapter 4 — Image Acquisition and Hardware Control

The following chapters explain how to take snapshots or live images, what camera parameters have
to be adjusted for good quality and how to use the illumination system with the excitation filters and

the motorized parts of the microscope.

4.1
411
4.1.2
4.2
4.3
4.4
4.5
4.51
4.5.2
4.5.3
4.6
4.6.1
4.6.2

Simple Image ACQUISITION .....ccooiiiiiiie e 20
Snapshot and LiVe VIEW........ceeeviiieiiiiiieeic it 20
AVIRECOIEN .....eeiiieiee e 21

Camera CONtrOl ....cooiceeeee e 21

HlumMination CONTrOL......coo e e 25

MicrosSCOpPe CONLION ......oueeiiiieiee ettt 26

Motorized Stage CoNntrol ........c.ceoi i 29
Defining @ POSItions LiSt.....ccuiiiiiiiiiiiiiiiiecciiiieee e 29
Correcting a PoSitions LiSt.....ccccooiiiiiiiiieiiiieciiiiieeeeeieeee e 30
Calibrating the Motorized Stage .......ccccceeviieeiiiiieee e 32

AULOTOCUS. ...ttt 34
AULOfOCUS OPLIONS. .. weiiiiiiiieeee e 35

Executing an AutofOCUS SCaN .....ccooiiiiiiiiiien e 36
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4.1 Simple Image Acquisition

411 Snapshot and Live View

e Snapshot, T Live View

There are two ways to achieve simple image acquisition. The first one is the acquisition of a single
image with the Snapshot button in the Acquisition toolbar or the Camera Control (or Acquisi-
tion » Snapshot). The second one is the live view started with the neighboring Live View button (or
Acquisition » Live). Here the displayed image is updated continuously (and the previous image
discarded). Pressing the Snapshot button stops the Live View image display; thus a final snapshot
is taken, which remains in the image memory.

Snapshots are displayed with the false color defined for the currently active Image Type; see
Chapter 4.4, Microscope Control.

The Live View image is displayed in gray scale unless the option Image » Image Dis-
play » Fluorescence Color is activated. In that case the false color defined for the currently active
Image Type is used.

cell*R / cell®M uses the current camera control and display settings for image acquisition. It re-
members the settings from your last session after program shutdown and restart. Please be aware
that in case the properties of your object (dye, intensity, background etc.) have changed signifi-
cantly, it might be necessary to adjust the camera control and display settings accordingly before
you can see a reasonable image. This is explained in the following chapters.

The following settings should be checked or corrected before the image acquisition is started:

e Exposure time (Camera Control)

¢ Binning factor (Camera Control)

e Brightness adjustment (Camera Control)

¢ Image size, i.e., full frame or area of interest/partial frame (Camera Control)

¢ Excitation filter (lllumination Control)

e Light intensity (lllumination Control)

o By default, snapshots are not being stored and also a new snapshot overwrites the
older one. These settings can be changed, however, see Chapter 13.5.1 The Prefer-
ences »Image Tab.
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4.1.2 AVI Recorder

This function is not active after a standard installation of the cell*M/cell*R software. Execute Spe-
cial » Add-In Manger. Click Add in the corresponding window and navigate to the cell*M/cell*R
program folder. Open AviRec.dIx. Close the Add-In Manger window and restart the program. The
Acquisition toolbar now contains the Start/Stop Avi recording button.

i Start/Stop Avi recording

Click the Start/Stop AVI recording button to have the current live image be acquired as a video.
During the acquisition, the settings in the Acquire » AVl Recording Options dialog will be used.

Click on the Start/Stop AVI recording button once more or the Snapshot button to end the acqui-
sition process.

The results of the acquisition will be saved on your hard disk in the form of a video file (AVI file).
You can edit the name and storage location in the AVl Recorder Options dialog box. In the image
document you will still see the live image.

@ The video file that you create can become very large. Make sure that there is sufficient
free space on your hard disk before you begin the acquisition and use a suitable com-
pressor.

4.2 Camera Control

=
| Camera Control

The Camera Control button (or Acquisition » Camera settings...) opens the window to set the
acquisition parameters Exposure time, Binning factor and Subframe as well as the principal im-
age display parameters. The Camera Control window can be moved freely across the screen.

The cell*R / cell®M Imaging Software provides the unique possibility to change all the above men-
tioned parameters during Live View, which makes it very convenient to adjust the acquisition for
each experiment.

The Camera Control window contains the same Snapshot and Live View buttons as the Acquisi-
tion toolbar described in Chapter 4.1, Simple image Acquisition.
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Binning. The CCD chip is composed of many light-sensitive units (pixels). These pixels can be read
out individually (binning = 1x1) or the signal of neighboring pixels can be combined electronically
on the CCD chip (binning > 1x1). Binning reduces the spatial resolution but increases the sensitivity
and thus reduces the exposure time required for a good signal-to-noise ratio. It further reduces the
amount of data and consequently increases the readout speed. Therefore binning is recommended
if weak signals have to be detected at high acquisition rates or if spatial resolution is of minor im-
portance. .

Exposure Time. The exposure time determines the period of time during which the CCD-chip is
sensitive to incoming light, in other words, during which photons are collected and converted into
charges to be read out afterwards. The exposure time can be changed by 1 ms increments using
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either the slider or the mouse scroll wheel or by directly typing the value into the Exposure time
box. The slider limit can be selected via its context menu (right click).

Exposure time
= Adjuzt with binning
k4 [ Show saturation
J wls
10s
Standard | Extended s

Brightness adjustment

Adjust with binning. This feature automatically adapts the exposure time if the binning is changed.
(See also: http://www.olympus-europa.com/medical/39_MicroGlossary.cfm.)

Show saturation. This applies a Cold-Warm-Hot lookup table to the live image; see Chapter 6.2.9,
False Color. It is only really useful if the Automatic brightness adjustment option (see below) is
NOT activated. In this case saturated pixels will be displayed red, close to saturated pixels green
and very dim pixels blue. All others remain in gray scale.

Standard tab
Brightness adjustment

After a snapshot acquisition or during live view the image on the monitor is displayed in gray scale
according to the current Brightness adjustment. You have the possibility to change the brightness
of the displayed image manually with the Min. and Max. sliders or to use the Automatic adjust-
ment.

For further optimization, you may adapt the intensity clipping values Min. % and Max. %, respec-
tively representing the percentage of the darkest and brightest pixels which are set to black (value
of 0) or white (value of 255) and are not scaled linearly by the automatic adjustment. The effect of
the brightness adjustment can be viewed directly in the Live View mode.

o If an image appears either too dim or too bright make sure to control the minimum and
maximum intensities in the Min and Max field before judging that the exposure time is
respectively too short or too long. The appearance might be due to improper settings if
the Automatic option is deselected.

Online histogram. This option opens the Histogram window that allows judgment of the intensity
distribution in live images at a glance.

Subframe

cell*R / cell*M offers the possibility to readout only a sub-frame instead of the entire image cap-
tured by the camera (around 1376x1024 pixels in standard CCD cameras). The size of readout
frame can be customized by moving the slider at each side of the frame that represents the field of
view of the camera. The advantage of sub-frame readout is a reduced amount of data and an in-
crease in possible acquisition speed (with most cameras, an exception is the VF2T).
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Define. It is very convenient to define the sub-frame via a region-of-interest either in snapshots or
live images. When the button is clicked, a rectangle-drawing tool appears in the Viewport. It can be
moved freely and the size can be adjusted via mouse drag. A right-click defines the ROI and the
sub-frame settings are set accordingly in the Camera control window.

Reset. This function sets the readout back to full frame; it is also possible to double-click on the
frame selection area.

Extended tab
The availability of the functions on this tab depends on the camera.

Gain. The gain factor in CCD imaging defines how many photon-generated electrons of each indi-
vidual CCD pixel are converted into one intensity count by the A/D converter. Usually the system
gain is set so that with gain factor 1 the full well capacity matches the full range of the converter.
With a gain factor larger than 1, fewer electrons are converted into one count causing the image
brightness to increase — and the noise as well. Set the value by using the slider or type in a number.

Offset. Images captured by CCD cameras usually have a certain offset, that means, even pixels of
images taken in the absence of light and with the shortest possible exposure time (where any pos-
sible dark current does not come into play) have a set intensity larger than 0. Often it is around 128
counts. The Offset option allows to automatically subtract the value set in the Offset box from
each pixel intensity. Set the value by using the slider or type in a number.

Color control. These functions are available for color cameras only.

R, G and B gain values. These functions are available during Live View image acquisition only and
allow setting the gain value for each color individually to adjust the color balance. Set the values by
using the R, G and B sliders or type in the numbers.

White Balance. This function is available for color cameras only. It is primarily useful in brightfield
imaging to provide accurate color rendition regardless of illumination variations. Upon clicking the
button, a snapshot is taken automatically, the color balance is analyzed and the appropriate color
adjustments are being conducted (the R, G and B gain values are changed). Finally, another snap-
shot is taken using the new settings.

WBalance ROI. For many specimens, better white balance adjustment may be achieved by manu-
ally selecting a white or neutral gray area for reference within the specimen image area. Clicking on
the button allows setting a region-of-interest first. Once this is done, the color adjustments are
carried out as described above.

Shutter. If this option is activated, the shutter opens and closes in synchronization with the camera
exposure. If it is deactivated, the shutter has to be opened by clicking the Shutter button in the
lllumination control window before an image is taken and closed again in the same way after-
wards.

By default the image acquisition rate in the Live View mode is as fast as possible in dependence of
exposure time, binning, image size and camera type. The slider (that is only active if the Shutter
option is selected) allows reducing the acquisition rate in the Live View mode. This is a useful fea-
ture in case of light sensitive specimens because the overall photo-exposure is reduced corre-
spondingly.
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4.3 lHlumination Control

ol
“# | lllumination Settings

To adjust the parameters of the illumination open the control window with the lllumination Set-
tings button (or via Acquisition » lllumination settings...). The lllumination system MT20 / MT10
window can be moved freely across the screen to your convenience.

v Illumination System MT g|§| g|

A Main Swikch
i Burner ON [ OFF

Shutter

a

Intensity [%%]

Pifoc
A
50,00 prm
v
=
Burner type: MT_ARCYE
150%W Xenon
Burner hours: 63
Burner .
Sample illumination ®

Main switch: In this control window you find the Main switch Burner ON / OFF button to ignite
the arc burner or switch it off again. At the front of the lllumination System MT20 / MT10 housing
the green LED labeled BURNER ON indicates that the burner is turned on.
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Shutter. The shutter can be opened and closed by pressing the Shutter button to start and stop
the fluorescence illumination of the microscope.

Excitation filter buttons. The lllumination System MT20 / MT10 has a built-in filter wheel with eight
positions for different excitation filters. To select a specific excitation filter, click on the respective
button. The color of the buttons and their connection with the respective excitation filters and filter
positions in the MT20 / MT10 is set in the cell*R / cellM Configuration Software (see Chapter 15,
cell’R / cell"M Configuration).

Intensity. The MT20's / MT10's built-in attenuator controls the brightness of the illumination. 14,
respectively seven levels are available between about 1% and 100%. The intensity can be adjusted
by moving the Intensity slider. Once this is active after a mouse click, it can be moved by the scroll
wheel of the mouse as well.

PIFOC. If your cell*R / cell®M imaging Station is equipped with an objective PIFOC or nosepiece
PIFOC that has been configured in the cellR / cell"M Configuration Software (see Chapter 15,
cell"R / cell"M Configuration), the lllumination system MT20 / MT10 window features the PIFOC
field. The position of the objective can be adjusted by moving the slider or by typing in a position
(height) value.

Information field. In the lowest part of the window you find information about the Burner type. The
Burner hours counter tells you for how many hours the burner has already been used. A bright
green circle behind Burner indicates that the burner is on; dark green indicates it is off. Similarly, a
bright or dark green circle behind Sample illumination indicates that the shutter is open or closed.
This information field can be closed to save space on the screen and reopened again by pressing
the arrowhead on the top right corner.

4.4 Microscope Control

ﬂ Microscope Control

The cell*R / cell®M Imaging Software features a module for the easy control and efficient usage of
the automated microscopes IX81 and BX61. Its use will be described in this chapter. The IX and the
BX modules are similar: any differences between the two will be mentioned in detail.

Use the Microscope Control button to open the control panel of the microscope.

The control of the IX81 (BX61) is fully electronic via the Microscope dialog window and/or via the
hand switch keys and frame keys on the microscope. The Z-drive has a rotation knob (on both
sides of the microscope) that enables you to manually adjust the focus as well.
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o The Microscope dialog window features only those modules that have been config-
ured with the ObsConfig software, see Chapter 15.3, Configuring the Microscope.
Thus, the contents of the dialog window may differ from setup to setup.

The Microscope dialog window renders a permanent status overview of the microscope (indicated
by the icons of the toggle buttons and by the optical elements listed in the boxes) that is updated
several times per minute. Thus, if the user makes changes directly at the microscope, the dialog
box will display these changes.

Z-drive control. A slider control for adjusting the Z-position is displayed together with the current
position if the microscope frame features a motorized Z-drive. Once the slider is activated after a
mouse click, it can be moved with the scroll wheel of the mouse as well.

o This slider does NOT control a piezo-electric objective mover or nosepiece mover
(PIFOC, see Chapter 4.3, lllumination Control).

ﬁ* Objective. Select an objective from the pick list; the nosepiece moves automatically into the
corresponding position.
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Note. If a piezo-electric objective mover PIFOC is installed the nosepiece might not
necessarily use the shortest way to move from one objective to the next in order to
avoid the winding up of the PIFOC cables.

Magnification Changer. The default setting is 1 X and has to remain activated if the manually op-
erated (!) optional magnification changer slide on the right side of the IX81 microscope is not used.
If, however, the changer is used to increase the magnification by 60%, the option 1.6 X in the dia-
log box has to be selected to ensure a correct size calibration of the images.

e

&, , - '
“*| Fluorescence turret. Select a fluorescence filter cube from the pick list; the filter turret moves

automatically into the corresponding position.

55
“*#| Condenser (for IX81 microscopes only). Select an insert of the Phase Contrast Optical Ele-
ments Turret of the transmission condenser from the pick list.

ﬂ " Lamp on / off. Use this toggle button to switch the transmission lamp on and off. Moving
the slider changes the transmission light intensity.

—= IEWCamera / Ocular (for IX81 microscopes only): This toggle button directs the image of the
specimen either to the ocular or to the camera.

e BE
% " Transmission shutter open and close: This toggle button opens and closes the (op-
tional) transmission shutter and complements the function of the Lamp on/off button and the in-
tensity slider.

% IY% Side port / Bottom port: This toggle button directs the image of the specimen either to a
camera mounted at the side port or at the bottom port.

W W_l Image Type buttons. These buttons set all microscope and illumination mod-
ules (excitation filters, filter cubes, shutters) as defined for the different image types; see Chapter
15.3, Definition of Image Types.
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4.5 Motorized Stage Control

The cell*R / cell®M Imaging Software features a module for the easy control and efficient usage of
motorized microscopes stages by Marzhduser GmbH and Prior Scientific Instruments Ltd in imag-
ing experiments via the Experiment Manager (see also Chapter 5.3.2.5, The Stage Frame, and
Chapter 5.3.3.8, Experiments with image acquisitions at different stage positions). While simple
movements of the stage are conveniently done via joystick, automated experiments require posi-
tion lists. This chapter describes how to define these and how to calibrate the stage.

o Proper operation of the stage via software is only possible if the stage is calibrated.
See Chapter 4.5.3 for details.

4.5.1 Defining a Positions List

j Motorized Stage

A click on the Motorized Stage button opens the Stage dialog window. The last Positions list
used will be loaded automatically and can be modified at will. To create a new one, select <New
List> from the short list. To load an existing list, select it from the shortlist. To delete a list, load it
and then click Delete.

To add stage positions to the list, move the stage to the desired position using the joystick, focus
and click Add.

Positions can be deleted, copied and pasted with the usual MSWindows commands and moved
within the list via <Alt + up/down>.

Once the list is complete, type in a name in the List box and click Save.
All positions list are saved in one file called OBSPOSLISTS. XML in the cell*R / cell*M folder.

To move the stage to one of the positions in the list, select the position via mouse click, then click
Go to - or simply double-click the position.
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4.5.2 Correcting a Positions List

It is possible to automatically correct all positions of an existing positions list. This may be conven-
ient if a focus drift is observed, if the microscope was shaken causing the sample to move or if a
sample was removed and is put back onto the stage. Corrections can be carried out in the XY
plane and in Z.

Lateral List Correction.

If there were a lateral shift of the sample on the stage, you can correct the list by doing the follow-

ing:

1.

Go to any list position and correct the position of the stage.

Right-click the position in the list to open the context menu and select Lateral List Cor-
rection.

A message like the one below will appear:

Click Yes and the X and Y coordinates of all positions in the list will be adjusted by the
amounts given in the message.
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copy
Cut

Delete

Set Current Position As Reference

Olympus O¥100

Lateral List Correction

Focus List Correction.
If you observe a focus drift, do the following:

1. Go to any list position and correct the focus.

2. Right-click the position in the list to open the context menu and click Set Current Posi-
tion As Reference. A green letter R will appear to the left of the position number in the
list and the command Focus List Correction in the context menu will become enabled.

4. Click Yes and the Z coordinates of all positions in the list will be adjusted by the amount
given in the message.

Correction of a tilt of the sample

If the sample is tilt relative to when the positions list was defined, a simple focus correction will not
help. In that case setting three reference points defines a reference plane. With the help of this
plane the software determines individual focus corrections for each position in the list.

1. Go to any list position and correct the focus.
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Right-click the position in the list to open the context menu and click Set Current Posi-
tion As Reference.
A green letter R will appear to the left of the position number in the list.

Define two more reference positions by repeating steps 1 and 2 at two other positions in
the list.

-44312, -39488, 667031
-45875, -37290, 626431
-45897, = G626,31

Execute the command Focus List Correction in the context menu. A message like the
following will appear:

Olympus O¥100

4.5.3

5. Click Yes and the Z coordinates of all positions in the list will be adjusted by the amount

given in the message.

Calibrating the Motorized Stage

o In case the Stage dialog box does not show the calibration commands, click on the

button with the arrowhead pointing downwards in the bottom right corner.

Loading an existing positions list to use it anew is only practical if it is known where the
origin of the coordinate system was set at the time the list was generated. If, for exam-
ple, the same slides are used routinely, it is commended to set the origin always at the
same spot on the slide.

Set Origin. Upon clicking this button the current stage and Z-device position will become the origin
of the coordinate system with the X/Y/Z values 0/0/0. The red status box Not calibrated turns
green and states Calibrated.
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Auto Calibrate. Upon clicking this button the stage will always move to a certain corner position
and set this as origin of the coordinate system. The red status box Not calibrated turns green and

states Calibrated.

Set Limits. This command opens the Stage limits window. If no limits have been set previously the
four limit position buttons will be marked by a blue question mark.

?
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?
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Cancel

To set limits, move the stage with the joystick, for example, to the leftmost position of your sample

and click X1. The blue question mark will disappear.
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Once all four limits are set, a green cross appears in the center of the four buttons. A red dot indi-
cates the current stage position.

Any position in the positions list outside the limits will be labeled with a red diamond symbol. A
reference position outside the limits will be labeled with a red R.

3 45875, -37290. 6264.31
R 4 45897,  -36640. 6626.31
s 47974, -35775, 5729,58 §

In order to widen the limits so that all positions in the list remain in bounds, right-click the positions
list to open the positions list context menu and select Adapt Corner Limits.

o The limits do not affect the function of the joystick. However, the Experiment Manager
checks if all positions in the selected list are within the limits. Otherwise a warning
message is generated.

4.6 Autofocus

CHERL AN
w Autofocus normal

Autofocus Fine
Aukofocus very fine

Autofocus options, Autofocus

o The Autofocus function is only available if the system contains either a motorized mi-
croscope Z-drive or piezo-electric objective mover or nosepiece mover (PIFOC). The
Autofocus button will appear in the Acquisition button bar only if any of these devices
is configured in the ObsConfig software, see Chapter 15, cell*R / cell"M Configuration.

The Autofocus function automatically finds the mounted specimen by acquiring images at different
Z-positions and analyzes the focality (sharpness) of the image contents. The time required for the
Autofocus to find the focus depends on the Autofocus options settings (see below) and the dis-
tance of the focus from the starting position.
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The focal position may not be found if the signal-to-noise ratio is too low, in other words, the cam-
era settings Exposure time and Binning are not suitable, see Chapter 4.2, Camera Control. Also,
quite obviously, the focus cannot be found if it is outside the set range.

The Autofocus is a two-step procedure. First an Autofocus scan is performed according to the
settings and analyzed. The found focal position will be used as reference position for a second
Autofocus scan that uses a finer step size to improve the focus. The resulting position of best fo-
cus will be used as focal position.

4.6.1 Autofocus options...

Z-device. If more than one Z-device is installed, select the one to be used for the Autofocus from
the shortlist.

Range. Set here the range of Z-positions to be scanned during the Autofocus process in the
Autofocus normal mode (see below). The range is centered on the current Z-position. The nar-
rower the range, the shorter will be the time required for the Autofocus scan to finish. However, the
focus cannot be found if it is outside the range. Thus, certain cautiousness is necessary when set-
ting the range.

Autofocus Options @

Z-device Z-Drive v

Range 33,33
Big Step 4,17
Fine Step 1,00

Use entire range ]
Displayy
Use ROI O

Low Signal mode  []

Big Step. Set here the step width to be made between neighboring Z-positions during the first of
the two Autofocus scans. Whenever the Range is newly set, a default step size is being set in
dependence of it.

Fine Step. Set here the step width to be made between neighboring Z-positions during the second
of the two Autofocus scans. Whenever the Range is newly set, a default step size is being set in
dependence of it.
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Use entire range. If this box is NOT checked, the following will be done: if the focality initially in-
creases during an Autofocus scan and then worsens again, the process will be terminated and the
found focality maximum will be set as reference position for the second, finer, scan.

If the box is checked, however, the process will not be terminated after a local focality maximum is
determined, but the entire range will be examined. Obviously, this causes the Autofocus scan to
last longer, but reduces the possibility that a wrong focal position is being detected.

Display. If this option is checked, online images of the Autofocus scan will be displayed.

Use ROL. In case of thicker specimens it may be that structures are brought into focus that are not
the ones of interest for the user. In such a case an ROI can be defined that will be considered ex-
clusively in the focality analysis of the Autofocus scan.

If the option is activated and one clicks the Autofocus button to execute an Autofocus scan, first a
red rectangular ROI drawing tool will appear in the active image to enable the user to define an
autofocus ROI via mouse drag and confirmation with a right click (compare Chapter 10.4.2, Draw-
ing ROIs). Once this is done, the Autofocus scan will be carried out automatically.

Low Signal mode. If this option is checked, a Mean filter (see Chapter 8.2.8) will be applied on
each image before evaluation of the sharpness.

4.6.2 Executing an Autofocus Scan

First of all, an Autofocus mode needs to be selected from the Autofocus button shortlist.
The selected mode will be executed upon clicking the Autofocus button.

If the Use ROI option in the Autofocus options is active, an ROI has to be defined before the
Autofocus scan is carried out (see previous chapter).

Autofocus normal. In this mode, the Range and Step parameters set in the Autofocus options
(see previous chapter) are used. This is the default mode and mostly the one of choice if a sample
is newly placed onto the microscope and is found to be totally out of focus.

Autofocus fine. In this mode, the range set in the Autofocus options (see previous chapter) is
divided by three and the step size is adjusted by default. This mode can be used if the sample is
already relatively close to the specimen. In this case the settings of the Autofocus normal mode
would probably first move the specimen way out of focus and it would cause an unnecessary loss
of time to bring it back into focus again. With the Autofocus fine mode, the user does not have to
reduce manually the range in the Autofocus options.

Autofocus very fine. In this mode, the range set in the Autofocus options (see previous chapter)
is divided by five and the step size is adjusted by default. Similar arguments as for the Autofocus
fine mode apply. The Autofocus fine mode can be useful, for example, if a slight loss of focus is
caused due to a movement of the specimen with the microscope stage.
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5

Experiment Manager

The Experiment Manager is a universal and easy-to-use tool for planning, preparing, and executing
experiments with the Imaging Station cell*R / cell®M. This chapter explains the general concept of
setting up experiments, lines out how the different system modules are integrated into experiments,
describes different types of experiments and guides through the system preparation and the execu-
tion of experiment.
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5.1 A Graphical Tool

The Experiment Manager is a universal and easy-to-use tool for planning, preparing, and executing
experiments with the Imaging Station cell*R / cell*M.

Planning an experiment:

Your experiment may, for example, require capturing fluorescence images of a multi-labeled sam-
ple and to display and archive them as composite multi-color images. Or it may be more complex
and involve acquisition of precisely timed image sequences in multiple fluorescence channels and
on multiple focus levels. With the Experiment Manager any such experiment can be defined in an
easy graphical way by setting up an “Experiment Plan”. Once defined, an Experiment Plan can be
saved as an independent file. Each user can thus define a set of Experiment Plans for repeated
experimental runs. Experiment Plans can be transferred and executed on any other cell*R / cell*M
imaging station, however, if the system configurations differ certain changes might be required.
Also, the plans are stored together with the image data in the database after execution of an ex-
periment.

Preparing an experiment:

Depending on the variability of your samples, it may be necessary to individually adjust certain
parameters of an Experiment Plan for each sample; for example, it might be necessary to optimize
the exposure times according to the quality of the staining. Such parameters are variables in an
Experiment Plan and can be changed easily.

Executing an experiment:

The same Experiment Plan can be executed as often as necessary. During execution of an experi-
ment the acquired images can be displayed live on the monitor allowing online observation of the
sample in one or several fluorescence channels. User interference during experiment execution is
possible via the Experiment Manager’s control field: The experiment may be paused / continued or
stopped. It is also possible to interactively set markers, for example, to indicate external events
such as the application of an agonist to the sample.

Data storage:

The images acquired during an experiment are automatically sorted, arranged and transferred to a
structured database from where they can be easily retrieved.
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5.2 Concept of Usage

ﬂ Experiment Manager

Open the Experiment Manager with the Experiment Manager button in the toolbar or via the menu
Acquisition » Experiment Manager.

Close the Experiment Manager in the same way or with the Close button or via the menu
File » Close in the Experiment Manager window. The Experiment Manager always opens in the
state and configuration in which it has been closed the last time.

5.2.1 Experiment Manager Components

N Experiment Manager

File Edit View Options Help
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The Experiment Manager consists of different components used to configure the different stages of
an experiment (planning, preparing, executing). In the default configuration of the Experiment Man-
ager these components are arranged in the following way:

The Experiment Manager window — in the default settings — consists of the following elements:

a The Menu bar contains functions for file handling (e.g. Save and Load Experiment Plans), edit-
ing and configuration of the Experiment Manager.

b The Standard Commands toolbar (left), the Analysis Commands toolbar (second from left)
and the Additional Commands toolbar (middle) contain the command icons for setting up Ex-
periment Plans. Further commands can be found on the MT20 commands, Microscope com-
mands and CCD Cameras Commands toolbars, to be made visible via selection in the View
menu.

¢ The Control Center toolbar (right) contains the icons to verify the experiment plan, to prepare
the hardware, and to start, pause, continue or abort an experiment.

d On the graphical editing surface the diverse command icons and frames are arranged and inter-
connected to define the Experiment Plan.

e The Properties page is a context-sensitive page where the parameters of the active commands
are set.

f At the bottom there is the Status bar with information about the progress of a running experi-
ment.

5.2.2 Arrangement and Customization

5.2.2.1 Opening and closing components

The two Command toolbars, the Properties page and the Control Center field can be closed via
the View menu independently from each other. The open state is indicated by a tick mark in the list
of components. Clicking on its "x" button in the top right corner also closes the properties page.

5.2.2.2 Detaching and repositioning components

It is possible to detach the toolbars and the property page from the Experiment Manager’s win-
dow and position them anywhere on the screen or to re-arrange them according to your personal
preferences within the Experiment Manager’s main window.

To detach a toolbar point with the mouse tip on the double line at its left side and drag&drop it to
the new position. To detach the properties page click on its title bar and than drag&drop it to a new
position. Afterwards the size of the new independent toolbar window or properties window has to
be adjusted via mouse drag.
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To reposition a detached component to the original location double-click on the title bar or
drag&drop the window back into position.

5.2.2.3 Minimizing the Experiment Manager

The Experiment Manager window can be minimized with the standard MSWindows Minimize but-
ton or by clicking on the Experiment Manager button in the cell*R / cell*M toolbar or in the
MSWindows task bar. This is often desirable during image acquisition or experiment execution
when the monitor space is required for the display of images in the Viewport. The Experiment Man-
ager window can be reopened by pressing the Experiment Manager button in the cell*R / cell"M
toolbar or the MSWindows task bar again.

e Closing the Experiment Manager instead of minimizing it will not cause the loss of the
plan; it will reappear upon opening the Experiment Manager again.

5.2.2.4 Minimized view: The cell*R / cell®*M Execution Center

J Minimize and Maximize button

The cell*R / cell®M Execution Center, accessible via View » Execution Center, <Ctrl+e> or the
Minimize button, is a minimized version of the Experiment Manager window that features only the
Control Center button bar, the Maximize button and the status bar. These are the only compo-
nents that may be of use while an experiment is carried out. However, they are not available if the
entire Experiment Manager is minimized. The cell*R / cell*M Execution Center is especially use-
ful during experiments with online display of images because the Experiment Manager window
blocks a large area of the screen. Click on the Enlarge button on the right side to re-enlarge the
view.

A Execution Center.

B W ™ oo L =

00:00:00,00 Frames Acquired: 0 Stored: 0 Total: 0
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5.3 Setting Up Experiment Plans

To set up new experiments you can either change an existing Experiment Plan or start from scratch
with an "empty“ editor surface. To obtain an empty editor surface use the Experiment Manager
menu File » New. If the current Experiment Plan has not yet been saved a dialog will appear asking
whether it should be saved.

Experiment plans are set up in a simple graphical manner without the necessity of any program-
ming knowledge. Icons that symbolize commands or series of commands have to be placed, or-
dered and connected on the editor surface and certain parameters have to be set in context
sensitive Properties pages; either by typing in values or by reading in current settings from the
cell"R / cell"M software.

5.3.1 Types of Graphical Icons and the General Principles of Usage

..‘. —
EI. . E:E:Z] {F | E | (Standard) icons to drop

LIS E B 0 rames to drag

There are two types of buttons in the Standard Commands and Additional Commands toolbars
to be used when setting up an Experiment Plan: one sort serves to place command icons into the
editing surface and the other enables dragging command frames around groups of icons.

To place a drop icon, activate the respective button via mouse click and place it on the editor sur-
face by clicking at its designated position. Frames are used to encircle one or more icons — similar
to a bracket in a mathematical function. To draw a frame, activate the button and click in the des-
ignated top left corner and then drag the frame towards the designated bottom left corner.

When a new icon is placed or a frame drawn the corresponding Properties Pages opens immedi-
ately. This will be explained in detail in the following chapters. The blue squares on the left and right
side of (inactivated) icons and frames are connection nodes; their use is explained below. Frames
and icons can be activated via mouse click. Activation is indicated by black dots on the icon frame
as shown on the right side of the following image:
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L [ 251

Fe [20] | Fie, [20) ymage Acquisition, deactivated (left) and active (right)

Icons can simply be moved by drag&drop. Frames can be enlarged or diminished by dragging the
black knots at the corners and sides that appear upon activation. Both can be deleted by activation
via mouse click and Edit » Cut or by pressing the Del key. They can be copied and pasted via
Edit » Copy and Edit » Paste or <Ctrl+c> and <Ctri+v>.

In order to generate an unequivocal Experiment Plan the icons and frames have to be intercon-
nected to give the order of execution of the commands. To specify the sequence connect the blue
connecting node (arrow head) on the right side of a command symbol with the blue node on the left
side of the successive one. When pointing with the mouse tip over a right-sided connection node
the mouse tip turns from an arrow (or the symbol you selected in the MSWindows settings) into a
cross. Press the left mouse button, drag the mouse tip to the blue arrowhead on the left side of the
successive command icon and release the left mouse button. The two commands are now con-
nected with an arrow indicating the succession of the commands; see the image below. Arrows
can be deleted after activation as above.

¥ BEETE R RN

Dapi WI Part 1 | 100 ms | Part 1 |

o The time axis within Experiment Plans runs always from left to right, i.e., commands
cannot be connected from right to left (that is, from a left-sided blue node to a right-
sided one).

If a command symbol is activated connections cannot be drawn, the mouse tip does
not turn into a cross. To deactivate a symbol, click on an empty area of the editor sur-
face.

In a valid Experiment Plan all commands need to be connected.

5.3.2 The Command Symbols and Their Properties Pages

5.3.2.1 Image acquisition

\El. Image Acquisition, » #2§ » command icon: color and subtitle depend on the Image Type,
the exposure time is displayed in the little box on the right.)

43



44  Chapter 5 — Experiment Manager OLYMPUS

Use for the acquisition of an image.
Execution of this command in an experiment will cause the following actions:

1. The illumination of the sample is switched on by opening the shutter.

2. Immediately afterwards image acquisition starts (upon a trigger pulse to the camera).

3. Immediately after image acquisition is terminated, the illumination of the sample is
switched off by closing the shutter.

4. The acquired image data are transferred to the PC RAM and eventually to the database
on the hard disk.

Properties, Image

Properties [X] @ Properties %] § Properties =

Image | Frame | Display Image | Frame | Display Image | Frame | Display
ImagsTyp= | Dapi v Binning v Display

Brightness
Light Intenzity 100 | % Frame # |0 S| wEE o

(%) Autornap

= .

Objective PLAPO 60x v T @ H |t O Mapfivedfiom |0 to (4095
Contrast Inzert Do nat change A Caloring

() Giray Scale

Exposure Time 40 ms

43

(®) Image type colar

() Pseudo color [LUT)
Acquisition time 121 ms

Marne Dapi

Get Current Camera Settings

Image Type. Select the type of image to be acquired from a list of pre-defined types, specified in
the Image type dialog box of the cell*R / cell®M Configuration Software (see Chapter 15, cell"R /
cell"M Configuration). This selection determines the excitation filter (and thus controls the filter
wheel of the Illlumination System MT20 / MT10) used for acquisition. Depending on the Image type
chosen, the icon is displayed in a predefined color, the same color used afterwards to display the
image on the screen.

Light Intensity. Adjust the intensity of the incoming light by selecting the percentage of transmitted
light from the list of 14 intensities. This selection sets the attenuator wheel of the lllumination Sys-
tem MT20 / MT10.
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Objective. This function appears only if a motorized microscope is configured. Select an objective
from the pick list.

Contrast Insert. This function appears only if a motorized microscope is configured. Select an
insert from the pick list.

Exposure Time. Control the image intensity range by selecting an appropriate exposure time. Ex-
posure time adjustment can easily be done under visual control while acquiring images in Live
mode (see Chapter 4, Image Acquisition and Hardware Control). The exposure time also deter-
mines the opening and closing of the shutter of the lllumination System MT20 / MT10.

Acquisition time. This read-only information gives the time necessary for the system to acquire the
image according to the selected parameters and transfer the data to the cell*R / cell®M Imaging
PC.

Name. Specify the name for the acquired image. The image will be stored under this name in the
database. If this image becomes one of the color bands of a multi-color image (upon usage of a
color frame, see next Chapter 5.3.2.2), this will be the name of the band. The default name is the
name of the image type.

Get Current Camera Settings. Click this button to read in the exposure time, the binning factor
and the ROI settings as currently set in the Camera Control dialog box (see Chapter 4.2, Camera
Control). This is only necessary when modifying an Experiment Plan. If an Image Acquisition icon
is newly added to the Experiment Plan the current settings are used by default.

Properties, Frame

By default the current settings in the Camera Control dialog box (see Chapter 4.2, Camera Con-
trol) are read in at the time of placing the icon. See the same chapter for a description of these
parameters.

Binning. The factor can be changed by selection from the pull-down list.

Frame. A sub-frame, that is, a Region-of-Interest (ROI) to be read out from the camera, can be
defined by setting the X and Y coordinate of the top left corner and the width (W) and the height
(H). However, it is much more convenient to define the ROI in the Camera Control dialog box and
read it in via Get Current Camera Settings in the Properties » Image page.

Properties, Display

Display. If this option is selected, an on-line image will be displayed and constantly updated on the
Viewport during the experiment (for example, a time-lapse or a Z-stack acquisition). In this case the
Image Acquisition icon shows a monitor symbol.

F—‘
’ .lﬂ ’

ke Image Acquisition with on-line display

If this option is deselected, no images are displayed on the Viewport during the experiment. The
following controls are not required in this case and are disabled.
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On-line display is only possible in time-lapse or Z-stack experiments. If the option is
activated in single image experiments, an error message is generated prior to the ex-
periment execution.

Brightness. This mapping function is mainly used to adjust the brightness of the image display on
the computer monitor. Note that mapping does not change the image data.
You have two options to define which mapping applies to your online image display:

e Automap: The mapping range (min. to max. values) is automatically determined according to
the minimal and maximal intensity values of the acquired image.

e Map fixed from ... to: Predefine the mapping range (min. to max. values) manually.

Coloring. This specifies the coloring of the online image display during image acquisition within the
previously defined intensity range.

¢ Gray Scale: The image intensities are displayed in a linear gray scale.

¢ Image type color: The image intensities are displayed using the Fluorescence color defined in
the Image type dialog box of the cell*R / cell*M Configuration Software (see Chapter 15, cell*R
/ cell"M Configuration). For example, it may be set so that GFP images will be displayed in
green scale.

5.3.2.2 The Multi-Color Frame

|[]| Multi-Color Frame

Use for the acquisition of multi-color images of multi-labeled specimen or samples with dual exci-
tation or dual emission dyes (e.g. Fura-2, Indo).

This command causes the storage of the acquired images of different Image Type (coded by dif-

ferent Image Acquisition icons encircled by the multi-color frame) within one file in the database:

¢ Any number of single images within the Multi-Color Frame is combined into one multi-color
image.

e Each image within the multi-color frame will make up entirely and exclusively one color channel
of the resulting multi-color image.

o The multi-color frame can only be used if all Image Acquisition commands inside the
frame have the same binning factor and ROI settings (Frame properties). Otherwise an
error message will be generated upon execution of the Check! command.

Properties, Multicolor. The only parameter to be set here is the Name to be given to the multi-
color image set in the folder of the current experiment in the database. If no name is given it will be
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stored under a default name. Each color band will carry the name set in the corresponding Image
Properties page; see the previous Chapter 5.3.2.1, Image Acquisition.

Properties, Display. If this option is selected, an on-line image with a color channels will be dis-
played and constantly updated on the Viewport during the experiment (for example, a time-lapse or
a Z-stack acquisition). In this case the Multicolor frame shows a monitor symbol. For further de-
tails see previous Chapter 5.3.2.1, Image Acquisition.

5.3.2.3 The Z-Stack Frame

j___g_ Z-Stack frame

Use for subsequent acquisition of images at different focus (Z-) levels.

Execution of this command will cause the following:
¢ The commands within the 3-D box are repeated on subsequent focus (Z-) levels.
e The images will be stored as Z-stacks.

e Multi-color Z-stacks can be acquired if the Z-Stack Frame contains a Multi-Color Frame with
more than one Image Acquisition icon.

o The command can only be executed, when a PIFOC or a motorized Z-Drive is avail-
able.

Properties

Z Device. If both a PIFOC and a motorized Z-Drive are available you have to select the targeted
device from the pick list.

Absolute Movement.
Current pos. This read-only information displays the current position of the selected Z-device.

Set top. This parameter sets the highest position (focal plane) the selected Z-device will reach
during the acquisition of the Z-stack. It can either be typed in or the current position of the selected
Z-device can be read in by clicking on the Set top button. Clicking on the arrow buttons next to the
box changes the position in increments of 10 nm.

Set bottom. This parameter sets the starting position of the selected Z-device during the acquisi-
tion of the Z-stack; it is the lowest focal plane. It can be set as above.

Top layer slider and bottom layer slider. These two sliders in the center of the page can be used
as well to change the respective positions.

Height. This read-only information lists the total height of the Z-stack to be acquired.
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Properties 5]
Z-Stack |
Absolute Movement

Set bottom Step \Width

-~
-

=
o
]
=

pm

pm

OLYMPUS

Layers. The total number of layers to be acquired can be typed in or changed by clicking on the

arrow buttons next to the box.

Step Width. The distance between successive image levels in the stack can be typed in or

changed in increments of 10 nm by clicking on the arrow buttons next to the box.

If the set values are not reasonable, for example if the bottom layer has a higher number than the

top position, the pale green background of the dialog boxes turns into pale red.

number of Layers.

o The above parameters are not independent. A subset of them can be defined freely and
the remaining parameters are changed accordingly automatically. The parameters bot-
tom level and top level have the highest priority, which means, they restrict the parame-
ters Layers and Step Width.

PIFOC usage: For technical reasons the PIFOCs move in multiples of their inherent
minimal step size (about 6.1 nm in case of an objective PIFOC). The software will
automatically adjust the Height according to the best-matching Step Width times

Once the top and bottom positions are defined any change in the number of Layers will automati-
cally lead to a corresponding change of the Step Width and vice versa so that the Height is main-
tained. In case of an arithmetic mismatch between Step Width, number of Layers and Height
(caused by the step size limits of the selected Z-device a fit of the bottom and top positions will be

done automatically with minimal possible changes.
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This is a convenient way to set the top and bottom position:

wu| 1. Start aLive View acquisition (see Chapter 4.1, Simple Image Acquisition).

2. Move the selected Z-device - either with the PIFOC slider in the lllumination system
MT20 / MT10 window (see Chapter 4.3, lllumination Control) or the Z-drive slider in the
Microscope window (see Chapter 4.4, Microscope Control) until the desired position is
reached.

3. Transfer the settings to the Experiment Manager with the Set top or Set bottom button
in the Z-stack Properties page, respectively.

i | 4. Stop the Live View acquisition by clicking the Snapshot button.

53.24 The Time Loop Frame

l] Time Loop frame.

Use for time-lapse experiments

Execution of this command will cause the following:

e The commands within the Time-Loop Frame are repeated a specified number of times with a
specified time interval.

e The images are arranged into time sequences and stored as one file.
e Time sequences may consist of single or multi-color images or entire z-stacks.

Properties
Time Lapse
Fepeat 25 : litnas
Cycle time 1 sils I
Total loop duration 00:00: 25,000
Approximate minimal cycle e 350 ms
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A Time-Lapse sequence is defined by the number of times the commands will be repeated and the
time a single cycle lasts.

Repeat. This determines the number of times the set of commands within the Time Loop Frame
has to be executed.

Cycle time. This parameter sets the repetition time and its unit. If this time is larger than the sum of
the duration of the commands within one cycle, the system automatically adds a delay between the
end of the last command of one cycle and the first command of the next one.

The Total loop duration is the cycle time multiplied with the number of repeats and displayed as
read-only information.

Approximate minimal cycle time. This read-only parameter informs you about the minimal possi-
ble duration of a single cycle. The minimal cycle time depends on the time requirements of all
commands in the Time-loop frame.

5.3.2.5 The Stage Frame

% stage frame

Use for experiments that are to be repeated at different stage positions.

Execution of this command will cause the following:

¢ The commands within the Stage Frame are executed at the first position of a specified posi-
tions list and then repeated at each other position.

e The image sets are stored in separate files for each position but within the same experiment
folder. The sets have the same name but carry the stage position number as prefix.

Properties

Stage

Position List:
List 1 w

(@) all positions in one display
() Each position in separate display

Position List. Select the positions list (see Chapter 4.5, Motorized Stage Control) from the shortlist.

The following options are only relevant if the online Display option is chosen for the Image Acqui-
sition commands within the stage loop, see Chapter 5.3.2.1, Image acquisition.
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All positions in one display. Select this option if you want to have just one online Viewport that
always shows the most recently acquired image of the respective image type. If a stage loop con-
tains more than one Image Acquisition command, each of them will have its own Viewport.

Each position. Select this option if you prefer to have the online images for each stage position
displayed in individual Viewport.

o The Images window is limited to 4x4 Viewports by default. (This setting can be in-
creased to 5x5 as maximum, see Chapter 3.1.3, The Viewport). If the Experiment Plan
calls for more Viewports, for example if the positions list contains ten positions and the
Stage frame three Image Acquisition commands, an error message that states Could
not allocate requested number of displays will be generated upon experiment evalua-
tion (see Chapter 5.4.2, Executing an Experiment).

5.3.2.6 Online ratio image

g
S
gt -
. Ratio, mcommand icon (with store option activated)

Use for the calculation of the ratio image of two images acquired during one cycle of the experi-
ment.

This function is mostly used for calcium ratio imaging with the calcium sensitive dye FURA-2 and
images acquired with 340 nm and 380 nm excitation wavelength. For more details see Chapter
10.8, Ratio Analysis.

Properties, Ratio

Background Subtraction. Three different modes are available: a constant, a background image or
the average intensity of a ROI can be subtracted. See Chapter 10.5.2, Subtracting the Image Back-
ground for more details.

Thresholds and Output Scaling. See Chapter 10.8.2, Generating a Ratio Sequence for details.
Properties, Calibration

See Chapter 10.8.2, Generating a Ratio Sequence for details.

Properties, Store

If the option Store is marked - this is indicated by the storage symbol in the top right corner of the
icon — the ratio sequence that is being calculated online will be stored on the hard disk after the
experiment has been finished otherwise it will be trashed.

Properties, Display

For a description, see Chapter 5.3.2.1, Image Acquisition.
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Properties 5]

Ratio | Calibration | Store | Display
Background Subtraction
() Subtract a constant
() Subtract an image
(®) Subtract a RO
From Image [Blimage 5 w
For Channel 1 (1ROl 1 v
For Channel 2 (1RO 1 v
Thresholds
For Chanrel 1 30 =
For Channel 2 30 e
Output Scaling
Scaling Factar 1000,00 e

o The calculation of a ratio images — and their online display - is a time consuming com-
mand for the PC processor. The software estimates the additional CPU usage and
changes the minimal cycle in dependence of online analyses. However, in rather fast
and complex experiments it still may happen that the acquisition of image pairs is
faster than the calculation of the ratio images by the PC - especially for 1x1 binning
and full frames with online display. In such a case the image acquisition timing has the
highest priority and the analysis will remain incomplete. That means, while certain ratio
images will be missing, all images will be acquired as designed in the Experiment Plan
and stored in the database. The ratio calculation has then to be repeated offline.

5.3.2.7 Online kinetics

- 3

Eﬂ. Kinetics, Mcommand icon (with store option activated)

Use for the online quantification of fluorescence intensity changes within ROIls over time and their
display as a graph. See also Chapter 10.6, Intensity Kinetics in Time and Z.
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Properties, Kinetic
Properties

Kinetic | Stare

Use ROIs From Image v
Z-Stack layer 1

Stage Pozition 1

Use ROIs From Image. The ROIs have to be drawn into a snapshot (or any image of the same XY
dimension as the image to be acquired) before the start of the experiment. Choose this snapshot
from the list in this box.

Z Stack layer. In a 3-D Time-Lapse series only one Z-layer can be chosen for the online calculation
of a kinetic. Set this layer here.

Stage Position. An online kinetics analysis is possible only for one of the stage positions in an
experiment to be carried out at different positions. Set this position here.

Properties, Store

If the option Store is marked - this is indicated by the storage symbol in the top right corner of the
icon — the kinetics graph that is being calculated online will be stored on the hard disk after the
experiment has been finished otherwise it will be trashed.

o The display of the online kinetics is automatic and does not need to be activated as in
case of the online ratio image calculation. It is possible to analyze several image sets in
one experiment (in other words, to connect Online Kinetics commands to several Im-
age Acquisition commands in one Experiment Plan). However, same as for the offline
analysis, only one graph (with several ROI curves) of one image set can be displayed at
a time. The graph to be displayed can be chosen and changed in the Graph gallery of
the Image Manager box at the left side of the user interface during the experiment.

The calculation of a kinetics analysis is a time consuming command for the PC proces-
sor. The software estimates the additional CPU usage and might change the minimal
cycle in dependence of online analyses. However, in rather fast and complex experi-
ments it still may happen that the image acquisition is faster than the generation of
online analysis results by the PC. In such a case the image acquisition timing has the
highest priority and the analysis will remain incomplete. That means, while certain data
points will be missing in the graph, all images will be acquired as designed in the Ex-
periment Plan and stored in the database. The analysis has then to be repeated offline.
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5.3.2.8 The digital port switch commands: TTL Out ON and TTL Out OFF

e
r | Digital Port, | | |

O SO S T S ," r command icons — with and without
pot1 | [ pot1 | PthSl?l Pﬂft5123| (right) conditional option activated

Use for respectively switching on trigger pulses to external devices that are connected to the 3
plugs on the computer front panel — or switching them off.

The pulses mentioned are called TTL Out pulses. TTL stands for transistor-to-transistor logic; Out
refers to the pulse going from the controller to a peripheral device.

The command icon changes in dependence of the selected pulses. The icons in the four examples
above indicate the following:

— Port 1 high

— Port1 low

— Port 1 and Port 2 low

— Port 1 low, Port 2 high, Port 3 low, conditional option selected

Properties

Properkies @ Properties @

Multi Digital Fort | Candition

Mulki Digital Part | Condition

Port 1 Enable
() High level @ once &t
() Low level 10 Cycle
() Every Mth
[part 2
[part 3

Multi Digital Port

Port 1 / 2/ 3. Select one or more of the three BNC ports at the front of the cell*R / cell*M imaging
computer: They are labeled 1, 2 and 3.

High level. This command ("TTL out ON") sets a voltage of >2.4 V to the selected port.
Low level. This command ("TTL out OFF") sets the voltage of the port back to the default of 0 V.
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Condition

Enabile. If this option is selected - this is indicated by the traffic light symbol in the icon —one can
set the cycle or cycles during which the trigger command shall be executed.

Once At. The command is executed only in the cycle set in the Cycle field.

Every Nth. Set the interval between triggers in the Cycle field if cycles with and without triggers
shall alternate.

5.3.2.9 The Wait command

Z

- 3

Z | Wait, | 1ooms | command icon

Use for interrupting the experiment for a specified time before execution of the next command.

cell*R / cell*M is a real-time system and thus the timer (elapsed / remaining time) continues to
count during the pause.

Properties

Delay time. This parameter sets the delay before the execution of the subsequent command.

5.3.2.10 The Autofocus command

AF_L @

=/ Autofocus, * » command icon (The color indicates the Image Type to be used,
the exposure time is displayed in the little box on the right.)

Use to automatically find the focus during an experiment

The Autofocus is a very useful feature in many experiments, especially in those where a) thermal
focus shifts are to be expected over time and b) a motorized stage is used to image the sample at
different stage positions. In the latter, case it cannot be expected that the focal position will be the
same over the entire sample.

For general explanations of the Autofocus, see Chapter 4.6, Autofocus. As explained there, the
initial Autofocus scan will always be followed by a second, finer one.

Properties: Autofocus

Z-device. If more than one Z-device is installed, select the one to be used for the Autofocus from
the shortlist.

Range. Set here the range of Z-positions to be scanned during the Autofocus process. The range
is centered on the current Z-position or — in case the Experiment Plan features a Stage loop- the Z
position defined in the positions list. The narrower the range, the shorter will be the time required
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for the Autofocus scan to finish. However, the focus cannot be found if it is outside the range.
Thus, certain cautiousness is necessary when setting the range.

Properties E]

Autofocus | Image || Frame || Display

Z Device

Range 20,00 pri
Big Step 333 urm
Firne Step 1.00 wm
|ge ertire range: |
Ensure constant time F
Low Signal made |

Big Step. Set here the step width to be made between neighboring Z-positions during the first of
the two Autofocus scans. Whenever the Range is newly set, a default step size is being set in
dependence of it.

Fine Step. Set here the step width to be made between neighboring Z-positions during the second
of the two Autofocus scans. Whenever the Range is newly set, a default step size is being set in
dependence of it.

Use entire range. If this box is NOT checked, the following will be done: if the focality initially in-
creases during an Autofocus scan and then worsens again, the process will be terminated and the
found focality maximum will be set as reference position for the second, finer, scan.

If the box is checked, however, the process will not be terminated after a local focality maximum is
determined, but the entire range will be examined. Obviously, this causes the Autofocus scan to
last longer, but reduces the possibility that a wrong focal position is being detected.

Ensure constant time. It is not always possible to foretell how many positions will be examined
during an Autofocus scan. Consequently, the time required for it is unsure to a certain degree as
well. If the subsequent command in the Experiment Plan is to be executed immediately after the
focus is found, the exact point in time cannot be told in advance. As a result, the acquired images
will not be equidistant. If the option Ensure constant time is checked, the Experiment Manager
will calculate the maximal time for an Autofocus scan and add a delay if the scan terminates before
the maximal time is expired. Thus the timing of the experiment is fixed, however, at the cost of a
certain loss in speed.

Low Signal mode. If this option is checked, a Mean filter (see Chapter 8.2.8) will be applied on
each image before evaluation of the sharpness.
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5.3.2.11  The Z-drift Compensation (ZDC) command

» Il oo
Il i
1% ZDC, L2 | command icon

Use to avoid loss of focus due to microscope Z-drifts.

It is possible, especially in long experiments, that focus is lost, for example due to thermal instabili-
ties. The ZDC is an optional, IR laser-based device for IX81 microscopes that detects the absolute
position of interfaces of differing refractive index. In case of oil-immersion objects this is the cover
slip-to-specimen interface; in case of water-immersion objectives it is any of the two water-to-glass
interfaces and in case of air objectives it is the air-to-glass interface. If the ZDC detects any drift of
the said interface position during an experiment, the motorized Z-drive will compensate it.

Properties

Properties 5]

ZDiZ

Range 200,00 pm
Sample offset 20,00 i g::)
Objective UPLAPC 60x v

Range. Set here the scan range the ZDC may use when searching for the interface. The larger it is,
the longer will the detection take. Make sure, however, that the range is larger than any expected
Z-drift.

Sample offset. This is the absolute difference between the interface and the focus position of the
sample. It is set automatically by the software. To determine the offset, focus the specimen and
then click the Determine Offset button in the properties window. The system will start a ZDC scan
and set the value accordingly.

Objective. Select the objective to be used by the ZDC from the shortlist.

5.3.212 Additional "atomic" commands - the Microscope Commands toolbar

Microscope

19 3 o bo B G 0 3 BEL I G Jo

Microscope Commands
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Microscope command icons

Command icon Action Parameter to set
16 l 16 l move PIFOC relative movement (left icon) or
up 2,00 pm | |pos. 35,00 | movement to absolute position
Lo move stage relative movement or movement to
S;jq’e absolute position
e, switch filter filter
Filkerwhee]
v e o switch filter cube filter cube
DapiFitcTx
X :#: l | l open or close shutter status
Ref. close | Ref. open |
S switch transmission contrast | contrast insert (selection displayed
Fh3 insert in icon)
| l L l switch transmission lamp on/off | intensity (voltage displayed in icon)
Trooov | [T 1zov |
| gt{} l LA l switch camera port (for 1X81 | status
Bkt port | Side port | only)
L bl l ! -'E"-i't l move DSU in or out status
ostin | | Dsuout
- l i EE l switch between camera and | status
camera || ocuar | ocular (for IX81 only)
X :ﬁ: l | B l open or close transmission | status
Tran, close | Tran. open shutter
L e ) switch nosepiece position objective
PLAPO 60
16 l i \.;# l move Z-drive relative movement or absolute
up 2,00 prn | pos, 967,0 | pOSItIOI’]
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5.3.2.13 Additional "atomic" commands - the MT20 and CCD Cameras Commands tool-
bars

CCD Cameras @

MT20 Commands, CCD Cameras

Additional "atomic" command icons

Command icon Action Parameter to set
i -_‘ | change attenuation light intensity
75 %
, B, switch excitation filter filter cube
403 DAPL
| l QS l open or close shutter of | status
MT open | MT close | MT20/MT10
| l | ﬂ_:}ki l open or close shutter trig- | status
e | .
TIRF Zope | [TRF 1cos| | 9€red via TTL port
L@ | acquire image binning, ROI, exposure time, syn-
Acquisition chronization, display

Acquisition, Not synchronous. This option causes the camera to operate without each image
being triggered. The advantage of this mode is that camera exposure occurs while the data of the
previous image are being read-out. The cycle time can thus be reduced to the read-out time.

o This mode is only supported by certain cameras and available only for monochromatic
experiments. It does not make sense to combine this command with any other com-
mand because they will not be synchronized.
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5.3.3 Types of Experiments

5.3.3.1 Single images — monochromatic or in multiple colors

E\ Monochromatic single image

The Image Manager indicates a single monochromatic image by a "black&white" cell symbol.

The simplest possible Experiment Plan consists of a single Image Acquisition icon. Obviously, the
result would be a single image file taken with a certain excitation filter, intensity and exposure time
— the camera exposure being synchronized with the MT20 / MT10 shutter.

Of course, with cell*R / cell*M it is easy to acquire images subsequently with different excitation,
illumination settings, exposure times and even different ROIs and binning factors. Such an Experi-
ment Plan would consist of a series of Image Acquisition icons, connected with arrows to indicate
the order; see the example below. The result would be three monochromatic image files respec-
tively named "Dapi", "Fitc and "TxRed".

| | |
' - b =l - r
Dapi WI Fitc WI TxRed W‘

o This simple Experiment Plan of three icons codes for a quite long list of commands and
actions. They shall be listed here as an example. (cell*R is able to execute some ac-
tions in parallel to minimize idle times. This is not possible in cell*M; here the actions
are executed consecutively.) The train of commands is based on the usage of a triple
band fluorescence filter cube that is already in position. If not in a first step the filter tur-
ret would move the cube into position. If three single band filter cubes would be used
the movement of the filter turret would be executed automatically as well without any
further commands in the Experiment Plan.

1. In parallel (cell*R only):
— filter wheel moves the DAPI filter into position
— attenuator sets intensity

2. Shutter opens

3. Camera gets exposed and acquires the image

4. Shutter closes
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5. In parallel (cell*R only):
— camera reads out the DAPI image data
— filter wheel moves into FITC filter into position
- attenuator sets intensity

6. Shutter opens

7. Camera gets exposed and acquires the image

8. Shutter closes

9. In parallel (cell*R only):
— camera reads out the FITC image data
— filter wheel moves into TxRed filter into position
— attenuator sets intensity

10. Shutter opens

11. Camera gets exposed and acquires the image

12. Shutter closes

13. Camera reads out the TxRed image data

Multi-color single image

The Image Manager indicates a single multi-color image by a colored cell icon.

In order to store the images together in one multi-color file the icons have to be framed by a Multi-
color Frame; see below. In this case the ROI selection and the binning factor have to be identical
for all images. The other settings, that is, exposure time and intensity, can differ. A colored cell icon
in the Image Manager indicates a multi-color single image.

| | |
o - — 2 - T 4
Dapi WI Fitc IE‘ TxRed W‘
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o Once an Image Acquisition command has been placed and defined on the editor sur-
face outside the Multi-Color Frame it cannot be subsequently moved into the frame
and connected with another command placed in there. It would be necessary to delete
the frame, connect the icons and redraw the frame. Similarly, the commands within a
multi-color frame cannot be connected with commands outside. However, it is possible
to add an Image Acquisition icon to an existing multi-color frame or to draw an empty
multi-color frame into the editor surface and subsequently fill it with Image Acquisition
commands.

5.3.3.2 Single images - transmission

Transmission light is usually much less intense and less harmful than fluorescence excitation light.
For this reason microscopes often do not feature any electronic shutter in the transmission light
path. In such setups transmission imaging in praxis cannot be combined with fluorescence imaging
in one experiment because the transmission illumination causes such a strong background that any
fluorescence would be largely or entirely overpowered.

If, however, the system is equipped with a transmission shutter and the software is correctly con-
figured (compare Chapter 15.3, Configuring the Microscope, and Chapter 15.4, Definition of Image
Types) the acquisition of a transmission image will be preceded automatically by the opening and
succeeded by the closing of the transmission shutter. In other words, it is not required to consider
the shutter movements when setting up an Experiment Plan. Such a system allows combining
transmission and fluorescence imaging in one experiment.

5.3.3.3 Z-Stack acquisition - monochromatic or in multiple colors

To setup a Z-stack acquisition a Z-Stack Frame has to be drawn around one - or several — Image
Acquisition icons; see the examples below. The result will be data files (one — or several, respec-
tively) that contain all the images taken at the different focal planes.

g Monochromatic Z-stack

The Image Manager indicates a Z-stack acquired with a single excitation wavelength with a
"black&white" stack icon.

s

Dapi

21 % 0,50 pm

E | | |
ST - — ey - » »
E Dapi WI Fitc IEI TxRed WI

21 % 0,50 pum

The order of image acquisitions in the triple-color experiment plan is the following: First a DAPI
image is taken at the lowest stack position, then a FITC image at the same position, then a Texas
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Red image. Afterwards, while the TxRed image data are still readout from the camera the PIFOC or
motorized Z-drive moves to the second lowest position. Once the system is ready again a DAPI
image is taken first, then a FITC and finally a TxRed image. This sequence is repeated for each
layer. After the last image of the last layer — the top position of the stack - is acquired the PIFOC or
motorized Z-drive moves back to the position it was at before the experiment started with the first
layer.

If it is desired that the stacks of different color are stored together within one four-dimensional data
set (XYZ + color) so that the colors are displayed together as multi-color images for each layer, a
Color Frame has to be drawn around the Image Acquisition icons. The experiment will be the
same as above but for the way of data storage.

2 Multi-color Z-stack

The Image Manager indicates a Z-stack acquired with a multiple excitation wavelengths with a
colored stack icon.

| | |
b - e - » »
= | Dapi W Fitc W TxRed W‘ 1

21 = 0,50 pm

o It is not possible to interchange the order of frames, that is, to have the Multi-Color
Frame as outer and the Z-Stack Frame as inner frame. Upon Plan Verification (see
5.4.2, Executing an Experiment) an error message will be generated: 'A "Time-Lapse"
or "Stack" command must not be inside a "Multi-Color" command.'

5.3.3.4 Time-lapse experiments - monochromatic or in multiple colors

A time-lapse Experiment Plan is similar to that of a Z-Stack Plan: here a Time Loop Frame has to
be drawn around one - or several — Image Acquisition icons, see the examples below. The result
will be data files (one — or several, respectively) that contain all the images taken at the different
time points.

Eﬁi Monochromatic time sequence

The Image Manager a time sequences acquired with a single excitation wavelength with a film
stripe icon containing a "black&white" cell.
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S ml i @m - m=m! B

3 [
Dapi WI Fitc lﬁl TxRed WI

20 % 30,00 5

20 % 30,00 5

In a multi-color time sequence the cell*R / cell*M system will perform the following. Images will be
taken subsequently: first with DAPI illumination, then with FITC and finally with TxRed illumination;
if desired with different exposure times, illumination intensities, binning factors and sub-frame
readout regions. Each image capture is synchronized with the opening and closing of the shutter to
minimize photo-bleaching. This series of acquisitions will be repeated over and over again as often
as defined in the Time Loop Properties and at exactly specified points in time. Let's imagine the
capture and readout of the three images and the movement of the filter wheel from the TxRed posi-
tion back to the DAPI position (to be ready for the next cycle) take a total of 500 ms and the Cycle
Time is set to 2000 ms. In this case the system will be idle for 1500 ms before the next cycle starts
with a DAPI image acquisition.

In most cases, it will be convenient to store the images of different color within one multi-color data
set. In order to do this - same as for multi-color Z-stacks — a Multi-Color Frame has to be drawn
around the Image Acquisition icons. Similar to the Z-stack acquisition described in the previous
chapter, the Multi-Color Frame must be placed inside the Time Loop Frame - not vice versa — or
the same error message as above will result upon Plan Verification (see Chapter 5.4, Conducting
Experiments / Data Acquisition).

Eﬁi Multi-color time sequence

The Image Manager indicates a multi-color time sequences with a film stripe icon containing a
colored cell.

| | |
s - — 2 - ’
Dapi W‘ Fikc WI T:xRed WI 1

EREEREREREREREERERRERRRER
)

ERRERERREENRERRERDERDE
R

20 30,005

It is also possible that a Time Loop frame contains another Time Loop frame. The result will be a
time-lapse sequence that contains blocks of equidistant images. These blocks result from the "in-
ner" Time Loop frame and are separated by the time-lapse resulting from the loop duration set for
the "outer" Time Loop frame.
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5.3.3.5 3-D Time-lapse experiments - acquisition of series of Z-stacks

In so-called 3-D time-lapse experiments the acquisition of Z-stacks is repeatedly carried out. To set
this up in an Experiment Plan, a Time Loop Frame has to be drawn around a Z-Stack Frame. The
latter may contain a single Image Acquisition icon or several — combined with a Multi-Color
Frame or not. For the color management the same principles apply as in the chapters above, they
will not be repeated here. A typical multi-color 3-D time-lapse Experiment Plan is shown in the
example below.

E Monochromatic and E multi-color 3-D Time-lapse sequence

The Image Manager indicates monochromatic 3-D time-lapse data sets with a monochromatic
stack within film stripes. For multi-color data sets it is a colored stack within film stripes.

2l m ! =

| |
Dapi WI Fitc lﬁl TxzRed

T
Bl
r—

21 = 0,50 pm

EEEEREEEREERERRERERRERRE
!
-
ERERRERERERERERERERENERERRREREREDREREDRDR
*

20 % 30,00 5

5.3.3.6 Experiments with online analyses

The cell*R / cell*M software allows to calculate a ratio image and an intensity kinetic online during
the execution of an experiment.

The Ratio commands can only be placed after a Multi-Color Frame containing exactly two Image
Acquisition commands. In other cases a corresponding error message will be generated upon
verification of the Experiment Plan.

A Kinetics command can be placed either behind an Image Acquisition or a Ratio command; the
calculation will be done for this very command.

The example below shows an Experiment Plan for a Fura-2 calcium ratio time series with online
display of the images acquired with 340 nm excitation, online calculation, display and storage of
the (340 nm : 380 nm) ratio images and online calculation, display (by default) and storage of the
intensity kinetics of the ratio image.
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[% m

[ — 3
|Fura34lil WI Fura3sn IE‘ R.atio | kinetic

— 05— |>

50 % 500,00 ms

EREERERERERENRERERRERREDR
-

5.3.3.7

Complex experiments with trigger pulses and several time loops

The Experiment Manager is powerful and flexible enough to set up much more complex experi-
ments than in the examples above. As an example, let's imagine the following ratiometric calcium
experiment.

1.

First, a series of Fura images at the two ratio wavelengths 340 nm and 380 nm is to be
acquired for a certain time at moderate speed. In the Experiment Plan this will be a Time
Loop Frame containing the Image Acquisition icons within a Multi-Color Frame.

2.

Second, an agonist will be injected automatically with a micro-injector device that is able
to receive trigger pulses from the cell*R Real-Time Controller / cell"M System Coordina-
tor via the Digital I/O interface at the front of the cell*R / cell*M imaging computer. To
set this up in the Experiment Plan, a TTL Out ON icon and a TTL Out OFF icon will fol-
low the Time Loop Frame. The switching of a trigger port is very fast, if the two icons
immediately follow each other in the Experiment Plan, the entire pulse lasts about 50 us
(in case of cell*R only, the cell®M System Coordinator causes a jitter of 10 — 20 ms). In
case such a pulse is too short for the connected device to read it, a Wait command that
lasts, say, 20 ms can be inserted between the two trigger commands.

3.

Third, after the injection the image acquisition shall continue, but with an increased
speed. In the Experiment Plan a Time Loop Frame similar to the first one will follow the
trigger commands, however, with a shorter Cycle Time.

The entire Experiment Plan would look like this:

B —
= .- =

[4 3 4 3
Fura40 WI Fura3gn IEI

F—‘ ar—
»»»—-

*_r — E — *-L b 3
|Fura34tl W‘ Furazsn lﬁ'

Part 1 10,00 ms Pork 1

(4 3

10 x 500,00 ms

500 500,00 ms
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o It is not necessary to draw the second time-lapse acquisition part of the Experiment
Plan anew. Pressing the <shift> key and simultaneously clicking with the mouse into
the frame can entirely mark the first part. Then it can be copied and pasted (<Ctl+c>
and <Ctrl+v>). Another mouse click places the new frame in the desired position. Af-
terwards only the connection between the TTL Out OFF icon and the new frame has to
be drawn and the two image acquisition commands have to be connected as well (the
connection is lost upon copy and paste).

The result of this experiment would be two dual-color time sequences, one resulting
from the first loop, the other from the second loop. The sequences can afterwards be
combined into one dual-color time sequence with the Combine command (using the
Combine button or Image » Combine...).

5.3.3.8 Experiments with image acquisitions and different stage positions

If the cell*R / cell®M imaging station contains a motorized stage it is possible to automatically exe-
cute experiments at different stage positions that have to be defined in a positions list beforehand
(see Chapter 4.5.1, Defining a Positions List).

An example would be to acquire z-stacks with two different Image Types at each stage position -
the Stage frame has to be drawn around the Z-stack frame — and this has to be repeated several
times — the Time Loop frame has to be the outmost one. The Experiment Plan would look like
shown below. Within the same experiment folder in the database, individual dual-color 3-D time-
lapse series will be stored for each stage position.

Both the positions list of the stage and the Z-stack properties (see Chapter 5.2.3.2, The Z-Stack
Frame) contain parameters for the Z-positioning of the system. In order to avoid conflicts in an
experiment like the one above the absolute position information for the top and bottom position in
the Z-stack properties will be ignored. The relevant information is the Height of the Z-stack as
defined in the Z-stack properties. The center position of the Z-stack of this height to be acquired at
each stage position, is the Z value set for each position in the positions list.

— —
— —
= I 8 C
- | S Ll | o
= 31 B
— e Ll | —
: R‘,c- 'j-»" :
: R | | ' :
- BEPERCEN. BT - y Mk = 2 b
= 1) - 2 =
= Fitc  [20 TxRed [40 = |2
= L 7 B
= | T Ll | —
= -
E - o, ™
- .:c« 21 0,50 pm 5-; -
- -
= | - ™ -
= -
= -

20 30,00 min
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A Stage frame can also be drawn around a Time Loop frame. In that case, a time-lapse sequence
is first acquired entirely at the first stage position, then the stage moves to the second position
where another time-lapse sequence is acquired and so on.

It is also possible that a Time Loop frame contains a Stage frame that again contains another,
“inner" Time Loop frame. For each stage position the result will be a time-lapse sequence that
contains blocks of equidistant images. These blocks result from the "inner" Time Loop frame and
are separated by the time-lapse resulting from one loop through all stage positions.

5.3.3.9 Experiments with autofocus

Long lasting experiments always carry the risk of focal shifts over time. It is not uncommon that,
say, after a few hours the specimen is out of focus, for example because of temperature drifts. This
can be avoided by inserting an autofocus scan after certain intervals during the experiment. For the
setup of the Experiment Plan it is convenient that the cell*M / cell*R Experiment manager supports
the placement of time loops within time loops.

The Experiment Plan shown below defines a long time-lapse experiment with an image acquisition
once a minute and autofocus scans once every hour.

— —
— —
: £ 1 B
— - - —
F — —
E 3 A = » = 'ﬂ |P : 3 EP
4 |autoforu 5] o | Fic [50] & B
- -
= - ) - =
- o 600 1,00min = -
o o
= 20 1,00 h =

Experiments that use a motorized microscope stage for image acquisitions at different XY positions
would be problematic without the possibility of an autofocus scan at each position. In most every
case, the focal position will be different at each stage position, at least if larger stage areas are
included.

vz LM L L o | W
-

»
Autofocu|§1 Fitc IEI TxRed [60

n\v.l 'Z%\" Kn‘:‘ Kn\.

T
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a
o
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60 x 10,00 min
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The Experiment Plan above describes an experiment with dual-color image acquisitions at different
stage positions. At each position first an autofocus scan will be performed. The entire stage loop
will be repeated every 10 minutes.

5.4 Conducting Experiments / Data Acquisition

5.4.1 Opening a Database

Before the start of image acquisition with the Experiment Manager, it is necessary to open a cell*R
/ cellM database. There are two possibilities: to open an already existing cell*R / cell*M database
or to create a new one.

To open a database, select Database » Open... in the Database menu of the main window. In the
Open Database window select a cell*R / cell®M database with the extension *.apl and click the
Open button. Recently opened databases can be selected from a list at the bottom of the Data-
base menu.

Laok in: | [0 LifeScienceDema ~ 3 ¥ £ 0

|20 4%560858_DocurmentFiles

Filz name:; LifeSciencelemoSTAR. apl
Files of type: | Database [*.apl] v

To create a new cell*R / cell®M database, select New Database... in the Database menu. Type a
name in the Database name field of the New Database window and click on the (now enabled)
Next > button. In the following dialog box select Finish to create the new database with the high-
lighted parameters.
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New Database

Databaze nare:
test

Select Finish' to let the database assistant create a database with the
Databasze files [* apl): following settings:

| [i:\Archivehtest | [ Browsze. .

¢Back || Finish |[ Cancel

5.4.2 Executing an Experiment

Control Center

B o 0 FH £

Control Center

Use these commands to run an experiment.
Execution of an Experiment Plan compiled with the Experiment Manager involves three steps:
1. Check!

2. System Ready!

3. Start!
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5.4.2.1 Check!

-é' | Check!

Before an Experiment Plan can be executed, the Experiment Plan needs to be validated. The sys-
tem has to check whether all interconnections of the commands are consistent, the parameter
settings reasonable, etc. If the experiment plan passes the check, the System Ready ! button
changes to the enabled state. Once validated, an opened Experiment Plan may be repeated several
times without additional checking.

o Loading an Experiment Plan from the database requires validation before execution,
even if the plan had been used before (and, consequently, was valid).

5.4.2.2 System Ready!

g}. System Ready!

Press the System Ready ! button to “arm” the system. This downloads the Experiment Plan to the
cell"R Real-Time Controller / cellAM System Coordinator and sets the parameter for the camera.
Also, the memory required for image acquisition is allocated on the hard disk. The arming of the
system may take several seconds depending on the amount of data to be acquired. Once the sys-
tem is ready, the Start ! button will be enabled.

If no cell*R / cellM database is open, the following dialog window will appear:

Experiment Manager

2 There is no open database or the open database cannot be used.
*-‘\/ Flease open or create a cell~Family database.

[ Mew DB... ] E%pen DB... | [ Cancel ]

Open or create a cell*R / cell®M database (see above) . Once this is done the System Ready !
command will be continued.

o If the Experiment Plan includes online display of images, the Viewport is automatically
rearranged at this point. The images will be arranged one above the other by default,
the first one to be acquired being displayed in the top position. The arrangement can
be changed as usual via the Arrange Viewport button.
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5.4.2.3 Experiment start

I Start!

Once the Start ! button is enabled the information Prepared is displayed in the status bar at the
bottom of the Experiment Manager window. Upon pressing the button, the experiment starts im-
mediately. In order not to slow down the data transfer, only a limited number of user interactions,
which might be required for online data inspection, are allowed during the course of the experi-
ment. These include:

¢ Viewport settings: all functions in the Viewport toolbar.

e Display settings: all functions in the Image Analysis » Image Display dialog box of cell*R /
cellAM Likewise, the two buttons in the Image Display toolbar (Display Intensity and False-
Color) remain active.

All other functions as well as all other programs are blocked during the course of image acquisition.

The status bar of the Experiment Manager window displays information about the acquisition
status. After starting the experiment the second field from the left in the status bar shows the in-
formation Running, indicating that images are acquired. The field in the middle displays the experi-
ment time (hh:mm:ss.ms). Information about the actual number of Frames Acquired and Stored and
the Total number of frames of the experiment is shown in the right field of the status bar.

l ] Y |[Running  |[00:00:13.69  [[Frames Acquired: 27 Stored: 26 Total: 100 ||

5.4.2.4 Pausing an experiment

I | Pause

To interrupt an experiment, press the Pause button. As a consequence, experiment execution will
be interrupted immediately. If the Pause button is pressed while the system is taking an image the
interruption will take place after the process is completed. In the paused state, the experiment can
also be aborted (see below).

To resume the experiment, press the Start button.

o The experiment time will continue to elapse during an interruption, meaning that:

e The total experiment time will increase by the duration of the interruption. If the ex-
periment is interrupted during acquisition of an image sequence (Time-Lapse
command) the cycle time of the current loop as well as the total loop time will in-
crease by the duration of the interruption.
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o e The time information attached to the image data will reflect the interruption. There-
fore, the break will be reflected also in post-acquisition temporal analysis of the im-
ages.

e The experiment time display in the status bar continues counting.

5.4.25 Setting markers during an experiment

ﬁc. Set markers

To mark a certain event during the course of an experiment (e.g. the application of a substance to
your sample during a time-lapse experiment), press the Set Marker button in the Control Center
field. You can mark several events during an experiment. A time trace of all markers (numbers) will
be stored in the experiment folder of the database. The markers can be displayed in all offline
analyses (if the Image Analysis » Display Markers and the Graph Analysis » Markers and La-
bels » Display Markers options are selected).

o Setting a marker does not interrupt the experiment.

5.4.2.6 Aborting an experiment

= Stop!

To abort an experiment, use the Abort button. After abortion all image data acquired during the
experiment as well as the Experiment Plan and event markers are automatically transferred to the
database and will not be lost.

o Even in the worst case that a hardware malfunction error occurs during experiment
execution all the data acquired so far will be stored and not lost.
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5.4.3 Data Storage

Images acquired in experiments via the Experiment Manager — unlike snapshots or live images -
are stored automatically in the active database in a folder that is generated automatically and car-
ries the name of the experiment. The folder will contain at least two objects afterwards: the Experi-
ment Plan and a set of images. The number of image sets depends on the experiment set-up. For
example, an Experiment Plan with two time loops with each containing a color loop with several
acquisition commands will result in two image sets (see Chapter 5.3.3.7, Complex experiments with
trigger pulses and several time loops).

If the Experiment Plan contains a Ratio Image command (connected to a color frame with two
acquisition commands, see Chapter 5.3.3.6, Experiments with online analyses) with activated Store
option, the ratio data will be stored as child object of the parent image data — one level lower in the
data hierarchy, see the screen shot below.

Online Kinetics with activated Store option are stored as child objects of the image set that was
being analyzed. Additionally, the image used to predefine the ROIs of the kinetics will be stored
(Tv1 in the screenshot below).

fe online
= [l 340Fura, 350Fura,
{ E- (@ Ratio of 340Fura, 380Fura,
- Kinetics of Fatio of 340Fura, 330Fura,

- Bl Tv1

LifesciencebemoSTAR | Hela cells with Fura
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6 Image Display and Navigation

The software interface features a special window, the Viewport, to display up to 16 images. Raw
images usually need a little touching up in the display to look appealing; contrast, brightness and
color can be adjusted. Images series created in multi-dimensional experiment may contain dozens
or even hundreds of individual images taken at different points in time, different Z-positions or with
different excitation wavelengths. Such data sets require tools for navigation and animation. All this is
explained in the following sections.

6.1 The VIEWPOI ...t 76
6.2 IMAGE DiSPIAY ..eeeiiiiiiieie e 78
(2 B 1= o 1= - SRR 78
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6.1 The Viewport

Image(s) acquired with the Experiment Manager or loaded from a database are displayed onscreen
in Viewport(s) within the Image window. This window features a number of buttons, the functions
of which will be explained below.

Em: v |
L) ] | L]
Cancel
Arrange Viewports

You can set the number of Viewports to be displayed and their arrangement using the Arrange
Viewports button in the toolbar of the Image window. Just mark the columns and rows by moving
the mouse cursor over the schematic grid with 16 Viewports that open. The selected Viewport dis-
play will be shown in the field beneath the grid (2 x 2 Images in the example).

O | Single View/Tile View

The favored images to be displayed can be selected via drag-and-drop from the Image Manager.
You can easily switch between the display of a single Viewport or the tiled display of all selected
Viewports by pressing the Single View/Tile View button.

A |Zoom In, A | Zoom Out

Clicking on the Zoom In button doubles the size of the displayed image while the Zoom Out but-
ton reduces the size by half.
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Zoom Factor

From the shortlist you can adjust the size of the displayed images, given as % of the original image
size. If you select Auto the image size is automatically adjusted to fit into the size of the Viewport.

A | Adjust Zoom

This allows adjusting the zoom factor to the current Viewport size. It has the same function as Auto
in the Zoom Factor shortlist.

| Adjust Window

This function fits the Viewport size to the size of the displayed image. This command is only avail-
able in the single view mode.

4 Images (8), 3-D Time-lapse T(5/20) Z{1/11) (150/%) Viewport title bar

Some basic information is given here about the active data set. From left to right it lists:

The Viewport number (here: 8), the name of the data set (here: 3-D Time-Lapse), the current point in
time out of a total number of time points (here: T(5/20)) in case of a time sequence, the current layer
out of a total number of layers (here: Z(1/11)) and the magnification (here: 150%).

L | Full Screen

This function generates a full screen view of the active image. Additionally the Menu bar, the Full
Screen button bar, the Acquisition toolbar and the button bar of the active document (Viewport,
database or graph) remain available.
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File Edit Database Acquire [mage Process Measy

BEppe va ]3]

3
Close Full Screen: returns to standard view.

ﬂ Select previous buffer: displays the image in the

ol

& Image Manager buffer atop the current image.

1)

i @ Select next buffer: displays the image in the Image

Manager buffer below the current image.

N

@ Select a document: displays - via selection from the
pick list — any other open document, for example, the data-

=T base or the graph window.

Show additional components: displays — via selection
from the pick list — the Image Manager or Viewport Manager.

R €

6.2 Image Display

6.2.1 General

The commands in the Image » Image Display menu are image-processing functions that do not
alter the image data. Only the appearance of an image on the screen, the image's display, will be
changed while the original image parameters remain untouched in the source image buffer.

6.2.2 Adjust Display...

| Display Intensity

Use this command to adjust the onscreen display of image sets (without changing the data).

General. A 16 bit gray-value image consists of gray values ranging from 0 to 65535. A (nx16) bit
image sets has (potentially) the same amount of intensity levels in each and every color channel.
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Most monitors can only display 256 gray values (8 bit), which is already far beyond the number of
gray levels the human eye can differentiate. Color monitors generate colors by mixing the three
existing color channels, red, green, and blue, with different intensities. Each channel is able to pro-
vide 256 levels of intensity (8 bit each). The result is a (3x8) bit image composed of more than 16
million possible colors. This is the so-called true color format.

6.2.2.1 The Adjust Display tab

Adjust Display E|

Adjust Display | Detaill Mapping

D @ D EI All color channels

(= o) D D O

I3 o y
261 4095
Clip

Min: < > Min: | 0,00 ||3)%

Max < ¥ may: | 0,00 |2

[ Close ] [ Reset ] [ Help ] [ Auto ]

Using the Adjust Display dialog box you can define which range of intensity values of the data is to
be displayed on the monitor for each channel the images consist of — using the 256 available
brightness values per channel of the monitor. What you’re actually doing is defining a so-called
display palette or LUT (lookup table). This palette correlates intensity values of the data with color
intensities on the screen. Its range goes from the minimum value (the lowest displayable intensity
value) to the maximum value (the highest displayable intensity value).

Color channels field (top).

This field contains colored Display Channel buttons to select channels to be displayed and narrow
Adjust Channel buttons underneath to select channels to be adjusted.

Display Channel buttons. The white button causes the display of all color channels while the col-
ored toggle buttons select or deselect the corresponding color channel for display. To display a
single channel in a three-color image, deselect the two other channels.
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D @ D @ Display Channel (colored squares)
SEE Dapi (1% Adjust Channel (bars below)
Load LUT, Edit Fluorescence Color

Adjust Channel buttons. These buttons select the corresponding channel for individual adjustment
when more than one channel is being displayed. The histogram of the selected channel is moved to
the foreground.

Load LUT. This is the same command as in the Image Display toolbar; see Chapter 6.2.9, False
Color.

Edit Fluorescence Color. This is command is described in detail in Chapter 6.2.8, Edit Fluores-
cence Color.

Histograms field. Here the intensity histograms - the distribution of pixel intensities — of the cur-
rently active channels are displayed. The scaling is automatically set so that it encompasses only
the range between dimmest and brightest pixels.

If a single channel is being displayed or if one channel has been selected for adjustment with its
Adjust Channel button, vertical lines indicate the lower and upper thresholds of each channel:
Min and Max, respectively. Every value below the Min and above the Max will be displayed with
the dimmest (most often black) or brightest (most often the pure spectral) color of the channel's
palette, respectively.

281 4095

Min / Max. For a single active channel, the minimum and maximum values are set either by drag-
ging the vertical lines in the histogram, by typing the values in the respective fields, or via the Min
and Max scroll bars.

Auto. Click here for an automatic adjustment of the active channels. The software checks each
channel for the minimum and maximum intensities and scales linearly in between — under consid-
eration of the Clip values.

Clip. This group is available if a single channel is active. To make automatic scaling more effective
when noise or bright impurities are present, you can define how many pixels (as a percentage of
the total number of pixels) will be displayed with maximum or minimum brightness. The intensity of
the remaining range of pixels will then be scaled linearly according to the selected color palette.
Percentage values can be anywhere between 0% and 50%. 0.1% is usually a good value to start
with — a slight increase in contrast and brightness results.
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Dol dalya Brightness, Contrast and Gamma Correction

These bars become active if one channel is activated. The values can be increased or decreased
by increments of 0.1 by respectively clicking into the bar above or below the sliders.

Brightness. Values above 50 increase the overall brightness by reducing both the Min and the
Max value, values below 50 cause the opposite.

Contrast. Values above 50 increase the contrast by reducing the span between Min and Max,
values below 50 cause the opposite.

The Gamma Correction allows a non-linear adjustment of the display. Values above 1.0 increase
the middle intensities while values below 1.0 decrease them.

6.2.2.2 Detail Mapping

Use this function for non-linear intensity adjustments. The field shows the histogram of the selected
channel and its intensity-scaling curve. The shape of the curve can be changed by mouse drag or
by clicking into the field — the curve will be fitted to reach the point that was clicked.

Adjust Display §|

Adjust Display | Cetail Mapping

L () () H &

472 4095

[ Close ][ Reset ][ Linear ]

Linear. Click here to get back to a linear scaling from Min to Max.

Reset. Click here to get back to the scaling that was active before the Adjust Display window was
opened.
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6.2.3 Auto Adjust Display

| Auto Adjust Display

This is a quick way to adjust the channel intensities of multi-dimensional image sets. The entire
data set — not just the current image — is checked for the brightest and the dimmest pixel and their
intensity is used to set the minimum and maximum values of the display. Additionally, the current
clipping settings in the Adjust Display dialog are considered.

6.2.4 White Balance

Many cameras tend to adulterate (falsify) image colors at acquisition. This kind of color displace-
ment can be corrected retroactively. To do so, you need to have an image that has an area where
you know it should be white. Instead, it looks, for example, yellowish. This yellowish tinge — the
color tinge — can be corrected throughout the whole image.

Available. This function is only available for single images of the RGB format and not for (n x 16) bit
images acquired with the Experiment Manager.
In microscopy it is only useful for transmission images acquired with a color camera.

o This command does not affect the image data, it only alters the on-screen display.

To apply the white-balance, a circular image area has to be defined where it is not that the pixels
should be white, black or gray - but at present are tinged. Afterwards, three correction factors will
be calculated based on the pixels within this circle — one each for the three color components.
These correction factors are defined such that the pixels within the circle will be gray on average.
Using these correction factors, the whole image will be corrected.

This is the procedure:

1. Select Image » Image Display » White-Balance.

2. Left-click within the image. A red circle will appear in the overlay.

3. Position this circle with the mouse. To resize it, keep the left mouse button pressed as
you move the mouse.
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4. Right-click to confirm the circle and apply the white-balance.

6.2.5 Black Balance

This function is similar to the white balance. That difference is that here a dark image area can be
defined that should be displayed in black. All other colors will then be corrected with the same
correction value.

Available. This function is only available for single images of the RGB format and not for (n x 16) bit
images acquired with the Experiment Manager.

In microscopy it is only useful for transmission images acquired with a color camera.

o This command does not affect the image data, it only alters the on-screen display.

The execution of the command Image » Image Display » Black Balance is done in the very same
way as the white balance described above.

6.2.6 Gray Scale

This command turns a false-color image display back into the original gray-value image display.
The image’s false-color palette will be deleted from the Viewport. It will be lost if the palette itself is
not part of the provided library and has not been saved as a separate file.

Available. This command is only available for single-channel 8 bit or 16 bit false-color images.

o This command does not affect the image data, it only alters the on-screen display.
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6.2.7 Fluorescence Color

This command is used for displaying single-channel images or individual channels of a multi-
channel image with the monochrome palette defined in the cell*R / cell*M Configuration Soft-
ware (see Chapter 15, cell*R / cell*M Configuration) for the corresponding filter of the Illlumination
System MT20 / MT10 used for acquisition (for more details, see Part B Hardware Manual).

Available. This command is only available for single-channel 8 bit or 16 bit images and for (n*16)
bit images in the single-channel display mode (via the Select Color Channel button).

o This command does not affect the image data, it only alters the on-screen display.

6.2.8 Edit Fluorescence Color...

Images acquired via the Experiment Manger are automatically displayed in the color defined with
the Image Type in the cell*R / cellAM Configuration Software (ObsConfig.exe), see Chapter 15.4,
Definition of Image Types. Snapshots, however, are displayed with a gray palette.

Use the Edit Fluorescence Color... command to modify the color of snapshots or of individual
color bands of multi-color images.

Edit Fluorescence Color @
Hue a _'|
Saturation | 1000 _'|
Brightness | 1000 J
&40 nim
Ok | [ Cancel ]

Hue. This parameter sets the color tone (spectral color).
Wavelength. Instead of changing the Hue you may type in the desired wavelength.

Saturation. Reducing this parameter adds "whiteness" to the color. In the RGB color space this
corresponds to linearly increased intensity in the non-saturated channels.

Brightness. Reducing this parameter adds black to the color. In the RGB color space this corre-
sponds to linearly decreased intensity in all channels.
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6.2.9 False-Color...

@ False-Color button

Use this command (or Image » Image Display » Load LUT...) to select a color palette from the list
in the dialog box RGB Lookup Tables of Color Channel '<...>'.

The library of palette files provided with cell*R / cell*M is stored in ...\Cell*R(M)\LUT.

Available. This command is available for all image types; however, the false-color palette will only
be used if a single color channel of the image is being displayed.

False-color palettes or lookup tables (LUTs) enable to display gray-value images or individual color
channels of (n*16) bit images in predefined "false" colors, also called pseudo-colors. This is done in
that the palette assigns each gray value of the image a certain color. For example, in an 8 bit image
with the Rainbow3 palette (see below) the intensity 23, which is a near-black gray in the standard
linear black-to-white gray palette, is displayed as blackish blue, while 226, otherwise a very light
gray, is displayed in an orange tone.

& RGB Lookup Tables of Color ... |:|@@
R ainbows s
R ainbow3
S emnif ainbow]
SemiFainbow?
Solaris
Thernal
Joarm 3

False-color palettes are often used to increase contrast. This is because the human eye distin-
guishes only about 50 different gray values but many more colors. Another application is to high-
light certain intensity values.

Bed | Green | Blue |4
184 | 0 255 43
185 0 255 37
186 0 255 30
187 | 0 255 24
188 0 255 18
189 0 265 12
190 0 255 B
191 i 285 a
192 5 255 1]
193 11 255 1]
194 ] 17 255 1]
195 | 23 255 0
196 | 29 255 0

197 | 34 255 0]+
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The intensity values (counts) of monochrome images’ pixels comprise the palette’s input — e.g., 0 -
255 for 8 bit images. These intensity values are listed according to their respective line (number) —
(see the example table below). Each intensity value is assigned to a certain intensity of the three
colors Red, Green and Blue. The three color intensities put together ‘add up' to the color that all
pixels of that particular intensity value are displayed in on the monitor. If all three color components
have the same intensity (R = G = B), the pixels are displayed in a shade of gray.

Possible Colors. If all intensity values and combinations thereof are used, each pixel can be dis-
played on the monitor in one of (256*256*256 =) 16,777,216 colors. Pixels of false color images (8
bit or 16 bit, in contrast to (3x8) bit true-color images) are restricted to one of (2° =) 256 different
colors - this is a limitation of the false-color palettes. These 256 can, however, be selected from all
16,777,216 colors.

Using palettes to alter gray-value images. An image’s palette only defines how gray values of an
image are displayed onscreen. The original gray values (‘under’ the palette) remain unchanged.

The collection of palettes. The palettes Blue, Cyan, Green, Magenta, Red and Yellow are sim-
ple, linear monochrome black-to-color palettes. Polaris, Solaris, Thermal, Gamma3 and Dither
are kind of standards that are probably of limited use in fluorescence imaging.

1618 1931 1618 1331 1618

176 152 176 192 176

The Rainbow1/2/3 palettes (first, second and third from left, respectively) shown above are espe-
cially useful for contrast enhancement. The most appealing one might be Rainbow3 that begins
with a black-to-blue gradient. SemRainbow1 and 2 (fourth and fifth from left, respectively) with
their inherent dark-to-light gradient are particularly nice for displaying small features on a black
background.

The ColdHot palettes below are designed to highlight extremes in intensity, i.e. the dimmest and
brightest features of the image. They also allow judging optically the dynamic ranges of image ar-
eas. ColdHot4 (fourth from left) with a rather narrow gray center was designed to easily distinguish
— if scaled accordingly — areas of increasing and decreasing signal intensities in AF/F plots.

The palette currently loaded is marked with a tag in the menu Image » Image Display and in the
shortlist of the Select Color Channel button.
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1618 1618 1618 2218

178 17E

6.2.9.1 The palette bar - displaying the current LUT

It is possible to have the current lookup table (LUT) of displayed in the Viewport. To do so open the
Scale Bar Properties window via Image » Scale Bar » Properties... and select the Palette bar
check box.

This function can be used for 8-bit and 16-bit gray-value images and false-color images. In case of
multi-color images the palette bar will be displayed only, if just one of the color channels is being
displayed in the Viewport. This can be done via selection from the pull-down menu of the Select
Color Channel button; see Chapter 6.3.2, Multi-Color Images.

As soon as the Viewport becomes smaller than a certain size, the palette will disappear.

6.2.10 Edit False-Color...

Use the command Image » Image Display » Edit LUT... to edit an existing color palette or to cre-
ate a new one. The library of palette files provided together with cell*R / cell*M Imaging Software
is stored in the folder ...\Cell®R(M)\LUT on the hard disk.

Available. This command is available for all image types with the exception of (3x8) bit true-color
images.

False-color palettes or lookup-tables (LUTs) make it possible to display gray-value images as well
as individual color channels of (nx16) bit images in color. This is done by the palette assigning a
certain color to each gray value of the image. (For details see previous section 6.17.5)

Different palette types. There are three different ways to define palettes, these includes:

o Type all palette values directly into a sheet.
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e Generate palettes interactively by defining polygons.
e Use formulae to have the palette computed.

The Edit False-Color... command opens a dialog box, which provides tabs for each of the above-
mentioned methods. Each of the three methods generates a different palette file format, *.LUT,
*.LUP and *.LUF, respectively.

In effect, you are editing a separate palette in each of the three tabs (see below) in the Edit LUT
dialog box, i.e., each time you go to another tab, you will not only switch to a different editing
method, but also to an altogether different palette of the image itself. In general it is not feasible to
automatically convert between the three palette editing methods. In fact, there are only a few ex-
ceptions where this would make any sense. There is, however, one important exception: if you
switch from either the Polygon or Formula method to the Sheet tab, the palette you have defined
in the former will be inserted into the sheet. This exception enables you, for example, to have a
whole palette generated using a formula, and then to edit individual values in the sheet.

@ A switch to the Sheet tab deletes the sheet values of the previous palette. You always
should save (see below) any palette you have defined before you switch to another tab.

Imaging C functions can only use the LUT format to alter the lookup table of an image.
Therefore it becomes necessary, that all LUTs originally saved in the polygon or for-
mula format are saved as *.LUT files as well (see below). Furthermore, only *.LUT files
are listed in the False-Color... dialog box (see above).

Saving/Loading palettes. A palette can be saved as a separate file, independent of its image. This
allows reloading the file at a later time and using the palette on the same image or transferring it to
another image. To do this, click on the File... button (contained by all three tabs).

6.2.10.1 The Sheet tab

Sheet. You can edit sheet values manually. Click into the sheet field and select any particular field
using the mouse or the cursor keys. The input can be terminated by the <Tab> key, moving you on
to the next horizontal field, or by the <Enter> key, which will move you to the next row. Click within
the left column with the cross-shaped cursor if you wish to select one or more rows. You can copy
the contents of the rows using <Ctrl+c> and <Ctrl+v>. Use the clipboard to copy these contents
into other applications.

The Red, Green and Blue scrollbars will be available if one or more rows have been selected. Use
these scrollbars to define specific value(s) for all selected rows. Please note that only the fields
corresponding to the relevant color are changed. All changes will be displayed on the monitor im-
mediately.

File... Click on the File... button to open the standard dialog box to open and load files. Files will be
saved using the LUT format.

Linear. When you click on the Linear button, the values of the linear standard LUT will be inserted
into the sheet.
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Edit LUT X
Sheet | Polygon| Formula
Enter walues for lookup table
Red | Green | Blue |~ Red
184 0 255 43
185 0 78 7 S
186 1] 2585 30 Green
187 0 255 24 ¢ 5
188 0 255 18
189 I 12 pe
190 a 285 g < 3
191 1] 255 0
192 5 255 0
193 11 255 0 Cheet
194 17 255 0
195 23 255 0
196 29 2585 0
197 34 255 0]+
[ ok ] [ Cancel ] [ Help ]

Interval... When you click this button, the Set Thresholds dialog box will open. Here’s where you
can define a gray value interval for the definition of LUT values. When you exit the Set Threshold
dialog box via OK, the corresponding interval in the sheet will be selected. Then you have to set the
color for the selected rows manually with the Red, Green and Blue scrollbars.

Set Thresholds El
b anual
Phase v Low AlE Prewviev
Calar High: o
Diagram
.I_l | Smooth;
x 1 @
[ u] 4 ] [ Cancel ] [ Help ]

Fill down. When you click on the Fill down button (in the Edit LUT dialog box), all values of the
first selected row will be transferred to the other selected rows. Using this command, you can enter
new values into one row and then have them copied to successive rows.

Sheet. Click on the Sheet button to generate a separate sheet document using the dialog box’s
current LUT. The columns of the sheet are: Index, Red, Green and Blue. Such a sheet can, for ex-
ample, be exported in the Excel format via File » Save As....
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6.2.10.2 The Polygon tab

Diagram. Within the diagram, lines (or "polygons") of the respective colors represent the three
primary colors of the LUT. The horizontal axis represents gray values from 0 — 255. The vertical axis
represents LUT entries, i.e., color intensities from 0 — 255.

Sheet| Palvgon | Formula

Linear

Calor Folygon paoints
® Red Count: |3 I

-

O Green Maonachrome
Otr s

[ Ok ][ Cancel H Help ]

Mouse Functions. A LUT polygon is defined by its points, which are represented by small white
squares joined by lines. There will always be at least two points at the left or right edge of the dia-
gram that cannot be shifted horizontally.

To add a new point to the polygon, simply click on any arbitrary point within the diagram. If you
move the mouse cursor over any point of a polygon, the cursor will turn into a hand. Then, pixel
value and corresponding intensity of this point will be displayed at the right edge of the diagram.

If you keep the left mouse key pressed, you can alter the position of this polygon point. All changes
made in the diagram will be displayed on the monitor immediately. A polygon point can be shifted
between the two neighboring points (to the right and left of the point in question). This makes it
easy to define a rectangular or saw-tooth-shaped polygon.

Right-click on any point of a polygon to delete it.

<Shift> and <Ctrl> keys. If it is necessary to define a point of a polygon with greater precision:
keep the <Shift> key pressed while positioning the mouse — you will only be able to move the cur-
sor vertically; to be able to move it only horizontally keep the <Ctrl> key pressed while positioning
the mouse.

Color. Select the color you want to change here. The polygon representing this color will be placed
in the foreground — not covered by the other polygons.

Count and Define. Define here the number of points your polygon will contain. First you enter the
number into the Count field. Then click on the Define button. All polygon points will be plotted
equidistantly (with respect to the x-axis). Up to 32 points can be defined for a single polygon.
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Monochrome. If you select the Monochrome check box, the polygon will become yellow. All
changes will be applied to all three colors simultaneously, thus enabling you to define a mono-
chrome gray value LUT.

File.... Click on the File... button to open the standard dialog box for the opening and loading of
files. Files will be saved using the LUP format.

Linear. This function sets the polygon of the active color back to linear (0 — 255).

o The LUP format cannot be used by Imaging C functions to alter the lookup table of an
image. As a consequence, you should save the LUP-type palettes as LUT files as well
(see above). Additionally, only the LUT files but not the LUPs will be listed in the False-
Color... dialog box (see above).

6.2.10.3 The Formula tab

Red, Green, Blue check box. If the check box on the left side is not selected, the corresponding
LUT will be given a constant value of "0". Otherwise, enter the formula, which defines the function
of the corresponding palette in the fields Red, Green and Blue.

Sheet | Polygon| Fomula
[+] Ried 255" pow( n, .3333)/ pow(255..33 Lirriit
Green |[n] Lt
[W]Blue | 255°paw n, 31/ pow(255.3) Lirriit
[ Ok, ] [ Cancel ] [ Help ]

Writing a Formula. The pixel value n is the variable for the X-axis. If you change a formula, the
function will be computed with all values between 0 and 255 and the result displayed in the dia-
gram. Simultaneously, the image is continuously updated on the monitor using this palette. You
can use all expressions allowed in Imaging C. Note the following guidelines:

¢ In case all constants in the formula are whole numbers (without decimal point) all results will be
treated as integers instead of floating point numbers, i.e., the digits after the decimal point will
be ignored. The result may be steps instead of smooth curves. Thus, all constants should be
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provided with a point (e.g., 100. or 100.0) to enable calculations with the precision of floating
decimal point operations.

e Multiplication and division operations will be performed before addition and subtraction. If nec-
essary, use brackets.

e n may have a value of "0". Thus you should avoid using n as a denominator. You could divide by
(n+1) instead.

e Take note of any error messages that appear in the status bar of the cell*R / cell®M window
after you’ve completed inputting your formula. Messages appearing while writing the formula
can be ignored.

¢ You can also use Imaging C expressions such as the operators "%", "&" and "?"

e The pixel value n, normally an integer ("long" format), can be converted into a decimal number
("double" format) by typing (double)n.

Examples.

Power: n to the power of three = pow(n, 3.)

Square root: sqrt(n)

Logarithm: log(n)

Use the following examples for applying the "%", "&", and "?" operators to create some typical

curves:

e (n & 64) * 4: rectangular signal (in binary format, all bits of n that are not identical to those of the
constant will be ignored)

e (n % 64) * 4: sawtooth signal (the constant, here 64, will be subtracted from n multiple times as
long as no negative value results)

e n/32* 32: step function (unless the divisor is converted into a floating point number by typing a
decimal point, see above)

e (n<128) ? 0: (n-128)*2: different formulas, section-wise (read: if n < 128 then set to 0, other-
wise...)

Limit. Select the Limit check box to have your result set to "255" in case of an overflow and to "0"
in case of an underflow. If Limit is not marked, the values over 255 will all be set to "0". Values
below "0" will be set to "255".

File... Click on the File... button to open the standard dialog box for the opening and loading of
files. Files will be saved using the LUF format.

Linear. When you click on the Linear button, all formulas will be reset to n. This corresponds to the
linear standard LUT coordinates of (0,0) and (255,255).

o The LUF format cannot be used by Imaging C functions to alter the lookup table of an
image. Therefore, it is necessary to save LUF-type palettes as LUT files as well (see
above). Again, only LUT files but not the LUFs will be listed in the False-Color... dialog
box (see above).
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6.3 Image Navigation

6.3.1 General

In most cases the acquired images are multi-dimensional, i.e., they consist of image stacks of dif-
ferent color channels, time sequences or z-stacks. With the commands in the Navigation toolbar
you can easily select single images out of an acquired image sequence to be displayed in the
Viewport.

Image MNavigator

e -l=-Hd- K 3 OM b R

6.3.2 Multi-Color Images

Multi-color images consist of sequentially acquired images with different illumination settings.

For example: A sample is labeled with three different fluorochromes. The resulting multi-color im-
age acquired with three different excitation filters is displayed as an overlay of the three different
color bands.

f5 *| Select Color Channel

To view the individual color bands, click with the left mouse button on the arrowhead of the Select
Color Channel button and select from the shortlist that opens. To select additional color bands,
use <Shift> + left-click. The currently displayed color channels are marked in the shortlist. The
selected color bands will be displayed exclusively in the Viewport; the other channels will be hid-
den.
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6.3.3 Displaying Different Color Bands in the Tile View Mode

It is possible to individually display all color bands of a multi-color image at the same time in differ-
ent Viewports. To do so a suitable Viewport arrangement has to be chosen with the Arrange View-
ports button in the Viewport button bar (see Chapter 6.1, The Viewport). Consider a triple-color
image: a 2x2 Viewport arrangement could be useful. The image can be displayed in each Viewport
via drag&drop selection from the Image Manager list. Then the All Color Channels view can be
selected for one Viewport while each of the individual channels can be selected in one of the three
others.

o If more than one Viewport is activated via <Shift> + click, navigation through time and
Z — as explained in the next chapters — will be carried out for all Viewports simultane-
ously.

6.3.4 Time-Lapse Sequences

HH Navigate Time

In time-lapse experiments the images are subsequently acquired, according to the parameters
defined in the time-lapse properties page, and stored as an image stack. Selection of a time se-
quence in the Image Manager enables the Navigate Time button in the Navigation toolbar.

KR8 o First, Previous, Next and Last

With the Previous and Next buttons in the Navigation toolbar, you can navigate frame by frame
backward or forward, respectively, through the time sequence. The First and Last buttons can be
used to display the first and the last image, respectively, of the acquired time series. The number
within the field represents the number of the currently displayed frame. You can directly go to a
specific frame by typing the respective number into the Go to field and pressing the Return key.
Alternatively you can click with the mouse into the Viewport to update the image displayed.
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| Animate

An additional feature enables the user to animate the acquired image sequence. Pressing the Ani-
mate button opens the Animate Image Stack window.

4 LI T T T TR, S

LILILI Reverse, Stop and Play

Here you find the buttons to start (Play) the animation, to Stop it and to play it in the Reverse
mode.

4]« ¥ ™ First Frame, Previous Frame, Next Frame and Last Frame

Alternatively you can navigate frame by frame through the image stack, or go directly to the first
and the last frame, respectively.

= =] Mark In and Mark Out

The slider displayed at the bottom of the window indicates the position of the currently displayed
frame within the sequence. Furthermore, the Animation tool gives you the possibility to mark a
subset of frames within the image stack to be animated. To do so, move the slider to the desired
starting frame position and click on the Mark In button. Then move the slider to a subsequent
frame and click on the Mark Out button to set the end frame for the slide show. The selected frame
scan range will be marked in the scale bar underneath the slider.

Options

The parameters for the animated slide show are defined in the Options of the Animate Image
Stack window. To open this dialogue, press the Options button. Here you can set the parameters,
which define how the image stack is animated.

Frame rate. In the field you can adjust the number of frames displayed per second.

Loops. In this dialog box you can choose how often the image stack is to be played. Choosing
Play, you can define how many time(s) the loop is played. Selecting the Auto Repeat button, the
image stack animation is continuously repeated until stopped.
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Direction. In this field you can select the direction of the animation. Choose here whether the stack
is to be animated uni-directionally (=) or meandering back and forth (¥=).

Options §|

Frarme rate

10 | Frameds

& timels)

Direction

O e
=

[ Ok l [ Cancel

6.3.5 Z-Stacks

Navigate Z

In Z (3D) experiments stacks of images are acquired at different focal planes. If a Z-stack is in the
active Viewport the Navigate Z button is enabled in the Navigation toolbar.

You can navigate and animate the Z-Stack in the same way as described for time-lapse experi-
ments in the previous chapter.

6.3.6 Multi-dimensional Sequences

mage Navigator

M-o= -0

Navigate Time selected

Data sets are not limited to three dimensions in the cell*R / cell*M Imaging Software. You can
acquire image sequences with up to five dimensions: the three spatial dimensions plus time and
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color. The Navigation toolbar allows selecting through which dimension to navigate: either time or
Z. If the Navigate Time button is activated, the navigation tools work with respect to the time axis.
If Navigate z button is activated, they work with respect to the Z-axis. The Select Color Channel
button is always active to enable the selection of individual color channels.

6.3.7 Parallel Navigation in Multiple Viewports

o The data dimensions have to match for this operation. For example, one cannot navi-
gate through a Z-stack and a time-series simultaneously. However, it is not necessary
that the dimensions present in the data sets have the same size in X, Y, Z and time. It
thus is possible, for example, to navigate through a short and a long time series at the
same time — up to the last frame of the short series.

If a multiple Viewport arrangement is selected (see Chapter 6.1, The Viewport), it is possible to
navigate through several data sets (or different color band selections of the same set) in different
Viewports simultaneously. To do so more than one Viewport has to be active. Multiple activation is
achieved via <Shift> + click.

6.4 Projections and Extended Focal Imaging

6.4.1 Projections Along the Z and Time Axes

Projections are a means to condense the information of an entire Z-stack or time series into a sin-
gle image. Most useful, probably, is the Maximum Intensity projection. The algorithm checks each
single image of a stack or series for the brightest intensity at any given X/Y position and uses this
for the projection. The Minimum Intensity projection and Average Intensity projection are calcu-
lated analogously. The functions can be selected from the pick lists of the Navigate Z and Navi-
gate Time buttons.
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OLYMPUS

= -0 - K al M |-

I Single z-Laver

Mazimurn Inkensity Projection
Minirmum Intensity Projection
Mean Intensity Projection

Extended Focus

|w Single time Frame

Maxirnurn Intensity Projection
Minirmurn Intensity Projection
Mean Intensity Prajection

Measure (araph  Special

Inkensity 4
Adjust Colors 3

Window 7

%l | s

Set Thresholds, ..
Binarize:

Define Shading Correction. ..
Shading Correction
Background Subtraction. ..

Projection
Define Filker k
Filker 3

Arithretic Operations ...

Image Geometry 4
R5E-Skudio »
30-Images 3

Mazimurn Inkensity T
Minirmum Intensity T
Mean Intensity T

Mazimurn Inkensity 2
Minirurn Inkensity 2
Mean Intensity 2

Extended Focus Image
EFI Options. ..

o The projection functions in the pick lists of the Navigate Z and Navigate Time buttons
do not create a new image. The projections are only displayed temporarily.

In order to generate new projection image data choose the projection commands from
the Process » Projection menu.

6.4.2

EFI - Extended Focal Imaging

The EFI function can be regarded as "sharpness projection" for Z-stacks (time sequences are not
accepted as source files). The algorithm extracts the image features with the sharpest contrast
from all layers of the stack and merges them into a single image. To execute the command select
Processing » Extended Focus Projection.

o EFI works well for transmission images and deconvolved fluorescence data. However,
the out-of-focus blur in fluorescence widefield images often impedes useful results.
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6.5 Fluorescence and Transmission Image Overlay

The selective fluorescence labeling of sub-cellular structures causes — consequently — that often a
cell is not visible entirely. To see where the fluorescent structures are located in the cell, it is possi-
ble to overlay fluorescence and transmission images — possibly taken with contrast enhancing
methods - in the display. This requires identical X/Y dimensions of both images. Multi-dimensional
image sets can be overlaid either with single images (snapshots) or with multi-dimensional image
sets that have the identical number of time points and Z-layers. The procedure is straightforward:

1. Activate the fluorescence image; it can be monochromatic or multi-colored.

#lz|-| 2. Open the short-list of the Select Color Channel button and choose Select Transmis-
sion. A dialog box opens that lists the images that would fit for an overlay.

3. Choose the desired image and click OK. The Viewport shows the resulting overlay im-
age.

4. Deselect the option Overlay Transmission in the shortlist mentioned above to remove
the overlay.

o The overlaid image is not a new data set; it only exists on-screen. No new file is written
into the database. To create an overlaid image as new data set use Edit » Copy and
Edit » Paste (<Ctrl+c> and <Ctrl+p>) and store the new image. This image is a (3x8)
bit RGB image, not a (nx16) bit image.
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6.6 Intensity Modulated Display

Images sets that are created by pixel-by-pixel division of source images or color channels, most
significantly those resulting from Delta F / F or Ratio calculations (Chapter 10.7, Delta F / F (AF/F)
Analysis, and 10.8, Ratio Analysis) have one disadvantage: they do not reveal if a certain ratio re-
sults from an area of originally rather intense or rather dim fluorescence. The ratio of two small
numbers may, after all, be similar to that of two large numbers. This effect often causes a loss of
structural information in the ratio images.

To give an example, the Intensity Modulated Display allows modulating the intensity of a false-
color ratio image (middle image below), may be one with a Rainbow palette (Chapter 6.2.9, False-
Color...), with the brightness information of the original image (left image below). The resulting in-
tensity modulated ratio image is on the right and has an appearance that is much more similar to
that of the original image than the standard ratio image.
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Chapter 7 — Image Data Handling

If the system is configured thoroughly all images will have the correct size calibration automatically.
Nevertheless, here it is explained how to adjust the calibration. The software offers the possibility to
show a scale bar and a color palette bar in an image overlay. Objects and texts can be added
manually to an image overlay. It is possible to extract sub-sequences out of multi-dimensional image

sets or to combine images.
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7.1 Calibrate Images

7.1.1 Why Calibrate Images?

Without a proper image and input calibration you cannot expect to obtain correct distance measur-
ing results when using the commands of the Image » Measurement menu. Even drawing the scale
bar into the image assumes correct image calibration. Sometimes it is necessary to recalibrate an
image, e.g., after loading third party images, or if the system calibration is no longer valid but the
dimensions of specific structures in the image are known. If the system does not have a communi-
cation link to the microscope, it is the user's responsibility to adjust the magnification to corre-
spond to the true magnification. The term magnification can be defined as the ratio of original
specimen size / hard copy or original specimen size / screen display or some other standard. This
has to be decided by the user and will reflect the application.

7.1.2 Calibrating the Camera Channel

It is very convenient to calibrate the channel with a magnification of 1. Thus, if the magnification of
the different objectives is set correctly in the OBS Configuration software, see Chapter 15.3.3, Con-
figuration of the Objectives, all images acquired will automatically have the correct XY-calibration
(ignoring certain slight variations in the magnification of individual objectives due to the
manufacturing process). In order to do the calibration the camera CCD chip pixel size has to be
known. Both for the F-Viewl/-T and the Orca ER camera the pixel size is 6.45 microns.
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1.

Configure Input E|
Macra Chantel Dizplay
Info #y Calibration | M agnific:ation Image Intensity

Magnification:
# calibration: prn/P
¥ calibration: prndP
KA ratio: [¥] Fixed
Calibration

(3 Arbitrary

? | © Harizartal

O Vertical

Calibration length: 1]
[ ar ] [ Cancel ] [ Help ]
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Open the XY Calibration tab in the Acquisition » Camera Configuration dialog window.

2. Click the Unit button to open the Set Unit dialog window and select m as Basic unit

and p as Scale and confirm with OK.

Set Unit [‘S__<|
pm
Scale
v
-
4 =
hd [ Beciprocal
l u] 4 H Cancel ] [ Help ]

3. Back in the Configure Input dialog window set Magnification to 1 and X calibration

and Y calibration to 6.45.

4. Click Save to open the Magnification Table.

103



104 Chapter 7 — Image Data Handling OLYMPUS

Magnification Table E|
M agrification Pixel width Pixel height
pr pm
1.00000 £.45000 6.45000

Delete &)1

Tipinel widthe @ | D

5. Click Add to load the new settings. The following message will appear; it refers to the
default settings. Click Yes to accept.

cell’R [X]

P | Themagrification  1,00000 is alveady defined in the table,
k—‘\/ Do ywou want ta replace the existing entry?

6. Click OK to confirm the new Magnification Table.

7. Click OK to confirm the new XY Calibration settings.

7.1.3 XY-Calibration

Using the Image » Calibrate Image dialog box you can recalibrate the image of the active image
buffer. The XY-Calibration tab is designed like the corresponding tab of the Configure Input dia-
log box described in the previous chapter.

If the exact magnification of the objective is known (there is a certain tolerance here caused by the
manufacturing process) calibration is straightforward. Image pixel size is CCD chip pixel size (as
specified by the manufacturer) divided by magnification. If the magnification is not known a calibra-
tion specimen of known size can be used.

Example. The cameras F-View/l and Hamamatsu Orca ER both have CCD pixels size of 6.45x6.45
microns. In case of a 60x objective, an image pixel size of 6.45/60 = 0.1075 microns in X and Y
results.
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How to calibrate the active image with a fixed X/Y ratio and unknown pixel size:

1. Select the image.

2. Execute the Image » Calibrate Image... command to open the corresponding window.

Calibrate Image

% Calibration | Z Calibration

Magnification:
# calibration: P
¥ calibration: P

=M ration [#] Fixed

LCalibration

(&) Avbitrary
) Harizontal
O Wertical
Calibration length:

—r

[ Ok, ] [ Cancel ] [ Help

]

3. Set the magnification in the Magnification box, if known.

4. Click on Unit... and select an appropriate Basic unit (usually meter) and Scale (usually

micro) in the Set Unit dialog box.

Set Unit [‘S__<|
pm
Scale
v
R -
4 =
_ [ Beciprocal
l ul H Cancel ] [ Help ]

5. Select the Fixed check box and enter the X-to-Y axis ratio in the X/Y ratio field, most

always it will be 1.
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6. If the calculated value (CCD pixel size/magnification) is sufficiently accurate, type it into
the X calibration box. The Y calibration value will be automatically set. Exit with Ok.

7. Otherwise enter the Calibration length for the length of the calibration object or struc-
ture.

8. Check the box Horizontal or Vertical or Arbitrary.

9. Start the calibration with the Calibrate button.

10. Select the beginning of the calibration structure with the line cursor and click; select the
end of the calibration structure with the second line cursor and click again.

11. Click on OK to confirm the calibration.

7.1.4 Z-Calibration

Calibrate Image g|
s Calibration| £ Calibration
Calibration of the plane
Unit...
Scale ¥ 0,108 P
Scale ' 0,108 P

Calibration of the Z-range

Frames: 21
Z-Offset: 46000 |3 pm
Z-Spacing: 0134 |5 pm
[ Ok l [ Cancel ] [ Help ]

Z-Offset. This parameter refers to the absolute position of the lowest layer Z-stack and is of minor
importance. It is read in automatically when loading cell*R / cell*M data.
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Z-Spacing. This is the step width between two neighboring layers of a stack. It is read in automati-
cally when loading cell*R / cell*M data.

Unit... This function opens the same Set Unit dialog box as in XY Calibration tab.

7.2 Scale Bar

Process Measure Graph  Special  Window

Image Display » % % E:‘D [
Calibrate Image...
Scale Bar Properties..,

v Showin Viewport  Shift+F4
Draw inta Cverlay

Orwverlay Bar

Shrwe Markers

7.2.1 General

In all scientific reports, the calibration of an image must be specified which can be done with this
command. This tool is useful for making video prints, hard copies, or exporting images to word
processing applications, because the inherent calibration is visualized in the image. It may be nec-
essary to choose a different location or a specific length for the scale bar. Both can be defined in
the Scale Bar Properties dialog box. The scale is part of the overlay plane (see Chapter 7.5.1,
Overlays — General) and does not interfere with the image data, thus it can be activated and deacti-
vated any time.

7.2.2 Setting the Scale Bar Properties

Open the Properties dialog for the Scale Bar via Image » Scale Bar » Properties....
Display

Scale bar Selection field. Here you select if a Horizontal and/or a Vertical Scale Bar are to be
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shown. A Palette bar depicts the color/gray scale coding of the light intensities and is especially
useful for images displayed with a pseudo-color palette.

Scale Bar Properties gl

Display | Format | Size

Scale bar selection
Harizontal scale bar
[(Nertical zzale bar
Palette bar

[ 1alze colar palettes anly

Show gzale bar for
Wiewport
Llipboard

[ ak. ] [ Cancel ] [ Apply ] [ Help ]

Show scale bar for field. In case images are to be printed or exported to the clipboard with the
scale the respective boxes have to be checked.

Format and Size

Here the style and size of the bar and the dimension units can be set.

7.2.3 Show in Viewport

Activate and deactivate the display of the scale bar by clicking on Image » Scale Bar » Show in
Viewport or using the short cut <Shift+F4>. The same can be done in the Show scale bar for
Viewport box on Image » Scale Bar » Properties... » Display.

7.24 Draw into Overlay

As opposed to the Show in Viewport option, with the Draw into Overlay option in Image Analy-
sis » Scale Bar the Scale Bar is shown only in the currently active image.
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7.3 Show Markers, Time and Z Information

The Experiment Manager allows the user to set markers by hand (mouse click) during the execution
of an experiment. This is useful to mark certain actions that are carried out or events that happen
during an experiment.

While the markers are always shown in a Kinetics graph, they are displayed in the images only if the
option Image » Show Markers is activated by mouse click.

With this option activated, the time and Z information of the displayed image will be shown at the
bottom left corner as well.

7.4 Grid...

Use the command Measure » Grid to place a measuring grid — of arbitrary size — over an image.

This command for determining the size of the grid frames and the color of the grid lines opens a
dialog box (see below).

Image size. The Image size field contains the size of the active image in the calibration unit.

Grid size. Determine the size of grid frames in the Grid size field. Enter the width and height of the
grid frames in the Horizontal and Vertical fields — in the unit of image calibration. Values between a
minimum of 10 pixels and a maximum of the image size can be selected. The minimum value of 10
pixels will be calculated automatically if you type 0. The grid size is displayed in the upper left cor-
ner of the overlay, as long as the Label fields check box has not been selected.

Normally one digit after the decimal is displayed. If you would like more than one, make the follow-
ing entry in the ANALYSIS.INI file in the cell*R / cell®M program folder on the hard disk for as many
places as desired - e.g., 2:

[SYSTEM]
MesGridDigits=2
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Imagesize:  B.60 mm = 5,16 mm
Gridsize

Horizontal; |1 = mm
]
Yertical: |1 | mm
Optionz
uze stértlng paint
Label fieldz
Automatic gridsize

minimurn af |5 ||| fields

Colors

Girid: Text:
C i (N~
Options group.

Use starting point. Select the Use starting point check box — along with the Interactive button - to
determine grid frame position in the image. If you clear the check box, the grid will always start in
the upper-left corner of the image at the coordinates 0,0.

Label fields. Select the Label fields check box to have grid frames numbered in the overlay: Rows
are designated by the letters A, B, C, ... AA, AB, AC,... WW; columns by the numbers 1, 2, 3, ... 99.
Each frame can be precisely identified, e.g., CF12. Grid frames are not numbered, if the text does not
fit into the frames. To have grid frames labeled, the grid frames will have to be in that case enlarged. If
you select the Label fields check box the grid size will not be displayed.

Automatic grid size. Select the Automatic grid size check box to have height and width of grid
frames automatically adjusted to fit the minimum number of grid frames. Enter this value in the
minimum of fields box. This number is based on the width of the whole image. The lowest value
possible is 2 frames, the highest 50. With the Automatic grid size, the grid frames’ shape will cor-
respond to the X/Y proportions of image calibration. An X/Y proportion of 1 results in square grid
frames. The current values for height and width are displayed in the Grid size group. Not all ad-
justments to the minimum number (of fields) result in a differing frame size because height and
width are restricted to standard sizes such as 1, 2, 5, 10, 20 in the unit of image calibration and so
on. For example, an image of 125 mm in width will have frames of 20 mm width if the minimum
value entered is 3-6. For values between 7-12, the frames will be 10 mm wide.

Colors group. Here you can determine the color of the grid and the overlay text.

Draw button. Click on the Draw button to have the grid at its current settings drawn into the over-
lay. In addition, cell size or alternatively numeration of the grid frames will be written into the over-
lay, depending whether the Label fields check box has been selected or not. The dialog box will
remain open so that various settings can be tried and immediately checked on screen. Each new
setting will delete the previous grid and its settings. Depending on the position of the dialog box, it
may have to be moved per mouse to be able to view results of setting changes in the image docu-
ment.

Interactive button. Click on the Interactive button to be able to determine grid frame size and
position interactively within the image document. A red rectangle will appear in the overlay display-



cell™ z cell® software Manual Chapter 7 - Image Data Handling

ing the dialog box settings. If a grid has been written into the overlay it will be deleted when you
click Interactive. Keeping the left mouse button pressed, move the mouse to enlarge or diminish
the rectangle to set the size of the grid frames. If the Use starting point check box has been se-
lected, the starting grid frame, — i.e., the red rectangle — can be positioned as desired within the
image. The grid will then start not in the upper left corner but rather where the red rectangle has
been positioned. Right-click to have the grid drawn as defined and to return to the dialog box. The
current values for height and width are displayed in the Grid size group.

7.5 Overlays

7.5.1 General

The Overlay is used to add information in form of text, markers, or other graphical elements to an
image. Although image and overlay form a unit, the data are stored independently on the com-
puter’s hard disk. Imagine the overlay as a transparent foil covering the image. Drawing and chang-
ing the overlay does not affect the image data. Moreover, you can fade out or delete the overlay at
any time. So you can be sure to get the true data if you compute a histogram or if you measure the
pixel values of your image, even though you have overlay elements present.

Overlays are vector graphics. Images are stored in a bitmap-like format that contains information
about each individual pixel. In contrast to the image, the overlay is stored as a vector graphic. A
line, e.g., is characterized by a starting point, an ending point and a color. This vector graphic is
then converted to a scanned graphic to be displayed with the image on the screen. Exceptions are
the overlay elements Image and Symbol. These are bitmaps added to the overlay.

7.5.2 Activating the Overlay Toolbar

abl ] O~ W o E £

W o A A S BB DR

Activate the toolbar by selection in the pick list that appears when right-clicking on any button bar
or via Image » Overlay Toolbar.
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7.5.3 Creating and Editing Overlays

E Edit Overlay

This button allows you to select an existing object in an overlay. Upon clicking the button the cur-
sor automatically moves into the image and is confined to this area until a right mouse click termi-
nates the Edit function. Any object active at this point can be edited with the overlay tools. Clicking
into an empty area of the overlay while being in the Edit mode deactivates any active object. Once
active you can change size and shape of objects by mouse drag. To select more than one object
use the shift button while clicking.

@ Select All, ﬂ Select None

A mouse click toggles between the two buttons used to select or deselect all objects.

ﬁ Object Properties

Object Properties

Object Properties

Text | Font | Col d Li
| L e angnes - Object Properties
Text | Font | Colors and Lines
< New text > T Agency FB - Colors and Lines |
Al BT

L Alego Fil
T Anial Baltic Colar: ||
H Agial Black m =
T fial CE e

| T A CYA AaBbCclll o

[ Autosize bound B Asial Greek e

['word wrap Effects Dashed: weight: |§|

[ Center westically Zoom withimagq | | []0utine [ Shadow
[J5tikeouwt  [H] Smoath Color T
[ Underline [ Uze 2 default B egin shyle: End shyle:

C o [ e ] [ ] [

[ Ok H Cancel ]

[ Ok ][ Cancel ]

This button opens the corresponding dialog, which is different for Text, Lines and Highlight fields.
The tools are self-explaining and similar to those in other common software programs and need not
be explained here.
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# =
® Image And Overlay
Image COnly
Civerlay Cnly

& All Lavers
Annokation Layer
Daka Laver

v Lock Data Layer
Layer

This button opens a pull down menu with the following commands:

Image And Overlay. Use this command to display the image and the overlay simultaneously.

@ Warning: This is a global setting, i.e., this flag determines the display of the image
overlay for all images loaded. It is recommended to remove this flag only at specific
times and for particular purposes.

Image Only. Use this command to show the image without the overlay. When this command has
been selected, only the current image will be displayed on the screen without any overlay. This is a
global setting, i.e., this flag determines the display of the image overlay for all images loaded.

Effect on other commands: The overlay display mode has an effect on the following functions: If
the Only Image display mode is active, all images will be printed without overlays. The image only
will be copied into the clipboard, i.e., if you paste the contents of the clipboard into another appli-
cation, the image will be inserted without overlay. Use the Copy command (in the Edit menu) or the
<Crtl+c> keys to copy the image into the clipboard.

Overlay Only. Use this command to show only the overlay (without the image). When this command
is selected the defined overlay will be displayed without any background image. You will see the
overlay superimposed on a black screen. Warning: This is a global setting, i.e., this flag determines
the display of the image overlay for all images loaded. The overlay display mode has an effect on
the following functions: If the display mode Overlay Only is active, cell*R / cell*M will only print
image overlays.

ﬂ Burn Overlay

This function is currently disabled.

ﬂ Delete Layers

This command deletes the entire overlay. The command Image » Delete Overlay has the same
function.
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Load Objects

This command enables you to load a previously stored overlay file (*.ovl) from a storage medium.
Other object types that can be loaded are bitmaps (*.bmp), icons (*.ico) and enhanced meta files
(*.emf).

E Save Objects

This command stores all objects selected into an overlay file (*.ovl). The button remains disabled if
no object is active.

& B Cut Objects, Copy Objects, Paste Objects

These commands work only on the overlay objects but otherwise have the same functions as in
any common software. The typical key combinations <Ctrl+x>, <Ctrl+c>, <Ctrl+p> do NOT work
here but start the Cut, Copy and Paste commands, respectively, for texts and single images. If no
object is selected the entire overlay will be cut or copied.

Eﬂ Lh Lo Bring to Front, Send to Back, Bring Forward, Send Backward

If several layers of overlays exist, positions can be changed with these commands in case of over-
laps. This only applies if several objects have been loaded. Objects created with the overlay draw-
ing tools are always located in the same layer.

abl| Text

This command allows writing a text into the overlay. Initially a rectangle is displayed on the image
to indicate the size and position of the text. This box has to be positioned by mouse. With the
pressed left button the size can be adjusted by dragging. A right mouse click opens the Object
Properties dialogs for Text where the text can be typed in and the fonts, colors etc. chosen.

g Rectangle

Enables rectangular boxes to be drawn. Position the top left corner of the rectangle as desired,
then depress the left mouse button to create a rectangle of the desired size. Right-click to super-
impose the box.
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g Ellipse

Enables ellipses to be drawn. Position the top left corner of the rectangle that describes the ellipse
as desired, then depress the left mouse button to create an ellipse of the desired size. Right-click
to superimpose the box.

ﬂ Line

Enables straight lines to be drawn. Position the mouse cursor at one end of the desired line, left- or
right-click, and move the cursor to the opposite end, then click again.

ﬂ Arrow

Enables variable arrows to be drawn. Position the mouse cursor at the desired start position of the
arrow. Pressing the left or right mouse button and moving the mouse, the arrow length and its di-
rection can be varied. Click the mouse button again to superimpose the arrow.

2 Polyline

Click on this button to draw a polyline into the overlay. Keep the left mouse button pressed and
move the mouse to draw freehand. Define the polygon point by point by clicking the left mouse
button on each point. Straight lines then connect points automatically. Right-click to confirm the

polygon.

Q Polygon

Click on this button to draw a polygon into the overlay. Keep the left mouse button pressed and
move the mouse to draw freehand. Define the polygon point by point by clicking the left mouse
button on each point. Straight lines then connect points automatically. Right-click to connect the
end points of the drawn line automatically to form the polygon.

Z Highlighter

Click on this button to place a colored transparent foil on an image section. Using this option you
may effectively emphasize special image features. Drawing is done as for Rectangles. If you
choose "Invert" instead of a color in the Object Properties dialog for a highlighter, the highlighted
image section will be inverted.
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7.6 Separate

Separate Color Channels

Extract...

Zombing. ..
-

The Image » Separate... commands allow dividing a multi-dimensional data set into several inde-
pendent subsets within one dimension (time, Z or color).

Available. The commands for dimensions not contained in the data set are disabled, like Z-Layers
in the screenshot above.

Color Channel. This command decomposes a data set into its color bands.
Z-Layers. This command decomposes a data set into its Z-layers.

Time. This command decomposes a data set into its time points. For example, a series of Z-stacks
will be separated into the individual Z-stacks.

7.7 Extract...

U] Extract

The Image » Extract... command enables you to extract a subset of data out of a multi-
dimensional data set.

The ROIs tab

It is possible to crop a single image or an image set in the XY plane. The area to be cropped is
defined via an ROI (see Chapter 10.4, Regions of Interest — ROIs). If the image contains already
ROlIs select one from the list. Otherwise define a ROI with the ROI drawing tools (via the Define
button; it has the same function as the ROIs button of the Complex Analysis toolbar). If an ellipti-
cal or free-hand ROI is used a rectangular area that circumscribes the ROI will be used for the

cropping.
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®

Dimensions | ROls Dimensions | ROIs

Color Channels

[WIFiras40 Selected ROIs:

[¥IFura3an ROT 1 [ Fullframe |
RO Z -
ROI 4

Z-Lavers

Time-Frames

From | 1 e [ 2| step [1 = Border [pixel]:

[ a4 ][ Cancel ][ Help ] [ oK ][ Cancel ][ Help ]

To enlarge the cropping area by a number of pixels in the £X and £Y directions type a value into the
Border [pixel] box.

Execute the cropping by clicking OK.
The Dimensions tab

Here you have to define the Color Channels and range (From / to) of Z-Layers and time points
(Time-Frames) to be extracted. By setting a step size higher than 1 you can opt to extract only
every 2", 3" and so forth layer or frame.

Execute the cropping by clicking OK.

7.8 Combine...

7.8.1 General

cell*R / cell*M allows to fuse individual data sets within the color, time and z dimensions to gener-
ate larger data sets. Prerequisite for such an operation is that the data sets have the same size in
the two other dimensions and in X and Y (width and height). For example, it is possible to combine
two full frame time sequences of 50 images each into one sequence of 100 images as long as both
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contain the same number of color channels. On the other hand - let's assume the two series are
monochrome — a combined time series of 50 dual color images could likewise be generated.

7.8.2 Combining Data Sets

The Combine window is opened with the Combine button or via Image » Combine...

5:4| Ccombine

Combine Mode field: Determine here in which dimension the combination is to be performed. For
example, to create a multi-color image out of several snapshots, select Color.

Feasible image objects field: All loaded data sets with the same frame size as the active data set
and the same size in the two dimension that are not chosen in the "Combine Mode" field, are listed
here. For example, sequences with different number of images cannot be combined into a series of
z-stacks. By default no data set is selected. The data sets to be combined with the active data set
have to be selected by mouse click. The active data set will become the first part of the new set
with the other sources being merged according to their data slot number.

Combine E|
Combine Mode Feasible image objects
; (1) Twl
B
(B) Twd

Sort according to real time / z-position: Imagine the combination of several time sequences to
one long sequence. If the sorting option is not selected the active sequence will be become the first
part of the combined sequence and the others will be added in order of the Feasible image ob-
jects list. If the sorting option is selected the software will check the time information of each se-
quence and combine the sequences chronologically. Analogously, in case of the combination of Z-
stacks the Z-position will determine the final order if the option is activated.
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7.9 Convert Image

7.9.1 General

The Image » Convert... command opens a submenu containing the commands for increasing or
reducing the number of bits per pixel — i.e., bit depth. This might be necessary if you wish to use
images in other application programs.

Images acquired with cell*R / cell®M are stored and handled in a proprietary (nx16) bit format.
Other application programs often are only able to read a certain bit depth. (3x8) bit ("true color") is
the standard bit depth for many graphical and image processing software’s. Here 8 bit of informa-
tion is stored in each of the three color channels red, green and blue. The interplay of the three
channels generates the colors displayed on a computer screen.

Another use for reducing the bit depth is to reduce an image’s bit depth to save memory. When
you do this, however, you generally loose image information.

Canvert To 5-Bit
3

Separate Ta RGE

Extract...

7.9.2 To 8-Bit

Use this command to convert cell*R's / cell®M's proprietary (nx16) bit multi-color images into (nx8)
bit multi-color images (with up to 256 colors per channel) or 16 bit gray-value images into 8 bit
gray-value images (with up to 256 shades of gray).
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7.9.3 To 16-Bit

Use this command to convert (nx8) bit multi-color images into (nx16) bit multi-color images or 8 bit
gray-value images into 16 bit gray-value images. This might be important if you want to carry out
certain arithmetic operations.

o This conversion doubles the required storage space.

7.9.4 To RGB (3x8-Bit)

This command converts all other image types into the standard 24-bit (true color) RGB format. This
might be necessary for the export of data because many other software programs can only read
this format and 8-bit gray scale images.

o In certain cases there is a different result between a conversion into (nx8) bit format
where n=3 with the To 8-Bit command and a conversion into RGB ((3x8) bit) format.
For example: consider a (nx16) bit image with a cyan, a yellow and a red channel. With
the To 8-Bit command the result is an (nx8) bit [here (3x8) bit)] image with a cyan, a yel-
low and red channel. With the To RGB (3x8-Bit) command, however, the data of the
three original channels are distributed after rescaling into the red, the green and the
blue channel so that the display remains the same (seemingly a combination of cyan,
yellow and red). The contents of the three RGB channels, however, are not identical to
the contents of the three channels resulting in the other case.

7.9.5 Invert

Use this command to generate a negative of the original image.

Available. This command is available for all types of images. It is, however, only available for false-
color images if the False Color Images check box has been selected in the Image tab (in the Pref-
erences dialog box, in the Special menu).
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Transfer function. If the greatest number for gray value display is G, and G, stands for a pixel’s
gray value in the resulting image, then, this pixel’s gray value will have the following value in the
resulting image:

G = Gmax_ GO

What will happen... For 8 bit images, G __, equals 255. For 16 bit images, G, equals 65535. In
binary images, the white areas will become black and vice versa.

7.10 Image Information

Use this dialog box to change the name of the active image buffer, to enter an image comment,
and/or to have image information displayed.

General | Dimensions | Markers General| Dimensions | Markers
[mege e Dirmengions
Color Channels: 2
File name: |D:\archive'\LifeScienceDemot4x560858_Do
Image buffer: 3 Frame: 1/ 81 Time-Frames:  B1
Memony size: 26094 KB
File size:
Created: 05.06.2003, 11:30 Colar Channels:
;hannel: Name Color Attenuator | Exp. [ms] | Bin..  Bir
Magnification: B0 [ 1= NA 1] Fura®4i [ 100.00 1300 2 2
Resolution: 353 % 310% 16 Fora38i I | FE et P i
Width: 38,12 pm
Height: 33,48 pm
Image intensity: Gray Value
Comment:
< >
[ Ok ] [ Cancel ] [ Help ] u] ] [ Cancel ] [ Help ]

How to open the Image Information dialog box:

Double-clicking on the image manager. Double-click on any image buffer within the image man-
ager to view information on that image - you can also alter this information. Double-clicking on an
image buffer will automatically activate that image buffer.

¢ <Alt+Enter> key. Use these keys to view information on the image within the active image
buffer.
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Image Manager context menu. Right-click on any image buffer to open the corresponding con-
text menu and then click on Image Information... The information then displayed refers to the
image you right-clicked on — it doesn't have to be the active one.

Viewport Manager context menu. Once an image is being displayed on the monitor, simply right-
click on the relevant Viewport within the Viewport Manager to open the corresponding context
menu and then click on Image Information... The information then displayed refers to the image
you right-clicked on — it doesn't have to be the active one.

Image Document context menu. Once an image is being displayed on the Windows monitor,
simply right-click on the relevant Viewport within the image document to open the corresponding
context menu and then click on Image Information...

Besides basic image information — i.e., gray or color-values — you will see other information having
to do with the image as well. This includes, for example, calibration data and/or any comments you
may have made concerning the image. All this information is saved along with the image. You can
access it via the Image Information dialog box.

7.10.1 The General Tab

The General tab contains general image information. This tab is accessible for any image loaded.
The kind of information you get will depend on where you got the image from, and its file format.

Image name. The name can be changed; it can be up to 31 digits long.

File name. When you load an image, the File name field will contain that image file's complete
path. An image you've processed in cell*R / cell®M will retain the file name of the original image —
as long as the processed image has not been saved under its own name. When acquiring an image
using cell*R / cell*M this field will be blank — until you have saved the image.

File names can be copied into the clipboard. Select the complete file name — using the mouse -
and use the <Shift+Delete> keys. Use the <Shift+Insert> keys to get the file name from the clip-
board - and put it, e.g., into a text document. This can be quite useful if you wish to refer to an
image within a document.

When saving an image, cell*R / cellAM will automatically suggest the image name for use as the
name of the file.

Warning. Image name and file name are not the same within cell*R / cell®M. For example, say you
name an image "yeast 02.25.2003 image 23" (its image name); you can save this same image un-
der a file name such as "02250323.tif". Then, when you later re-load this image, the original image
name will appear within the image buffer.

Image buffer. The Image buffer field displays the number of the image buffer currently containing
the image. This number will of course change when you, for example, put the image into another
image buffer.
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Memory size displays the size of the computer memory used by the image.
File size gives the information about the file size if the image is stored as a file.

Frame. The Frame field displays the number of the current image and the total number of images
of a data set.

Created. The Created field displays the time and date at which cell*R / cell®M images were cre-
ated - the date and time an image file was last altered will be displayed for other (non-cell*R /
cell"M) images.

Channel. The Channel field displays the camera used to acquire a cell*R / cell®M image. This field
will be blank for images not acquired via cell*R / cell*M.

Magnification. The Magnification field displays the magnification used when the image was ac-
quired via cell*R / cell*M. For some microscopes, cell*R / cell*M can directly read out the magni-
fication from the microscopes' remote control. Magnifications of images acquired in other
application programs will always be defined as 1. Use the Image » Calibrate Image... command to
adjust the magnification of an image acquired in another application program.

Resolution. The Resolution field displays image size (in pixels) and information depth (bits/pixel).
For example, an entry of 768 x 576 x 16 would mean that the image width is 768 pixels; the image
height is 576 pixels; and the image can have up to 2" different color values per channel.

Width, Height. The Width and Height fields display absolute dimensions of cell*R / cellM images.
These values are determined using the current image calibration.
For other (non-cell*R / cell®M) images, these fields will simply display image width and height (in
pixels).

Comment. The Comment field is for any comments you wish to make on an image.

7.10.2 The Dimensions and Markers Tabs

The General tab contains general image information. This tab is accessible for any image loaded.
The kind of information you get will depend on where you got the image from, and its file format.

Dimensions field. Here the extension of a multi-dimensional data set in the dimension Time, Z,
and Color are listed: number of points in time, number of layers and number of color channels.

Color Channels. The table lists the channels by name as well as wavelength (WL) in nm, exposure
time during acquisition (Exp.) in ms and the binning factors in X and Y.

Markers. In case markers were set during the execution of an experiment they are listed here with
Start and End times in ms and the given comments.
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8

Image Processing

Chapter 8 — Image Processing

The following sections explain how images can be improved by data manipulation. This is in differ-
ence to the display adjustments explained in the previous chapter. The shading correction corrects
for regular intensity gradients. A host of arithmetical filters is available to reduce noise, enhance
contrast or sharpen object edges. Deblurring algorithms filter out-of-focus haze.

8.1
8.1.1
8.1.2
8.1.3
8.2
8.2.1
8.2.2
8.2.3
8.2.4
8.2.5
8.2.6
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8.2.19
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8.1 Shading Correction...

8.1.1 General

Gradual noise and sensitivity variations across the CCD chip and the corresponding inherent inten-
sity gradients in the images are termed shading. The cause is a gradual mismatch of photodiodes
and on-chip microlenses. Shading correction is a type of background correction in an image meant
to compensate for irregular illumination effects.

8.1.2 Define Shading Correction

The Define Shading Correction dialog box is opened via Process » Define Shading Correction
and used to set the parameters for a shading correction.
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Define Shading Correction |
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Assumed Deterioration

In the Assumed Deterioration field you can define the appropriate correction method for the as-
sumed cause of shading.

Multiplicative. Check here if it is assumed that the shading results from a multiplicative effect. The
shading correction will divide the current image by a correction image, the Source for shading

image.

Additive. Check here if it is assumed that the shading results from an additive effect. The shading
correction will subtract the correction image from the current image. A new field will appear (in the
lower center of the dialog box). Select the Invert check box to have the resulting image intensity-
inverted after filtering, i.e., to get a negative image. Enter a gray value to be added to each pixel in
the resulting image in the Offset field. This may help to adjust the display nicely afterwards, espe-
cially in case of transmission images.

Define Shading Correction |

Agzumed deterioration

() Multiplicative
©

Source for shading image
() Source 1
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MxM average filker
Iterations: 1

4

Size: A1

4

Freparation of shading image

(%) MM average filker
() Interactive zero-level
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Source for shading image

In this field you determine which image is to be used as correction image. This can be either the
image itself that is being corrected itself (Source 1), or it can be a reference image from the Src 2
image buffer in the Image Manager (Source 2).

L] @ [3] [2] [28)

Src Jx Dest Srcz Mask,

Preparation of shading image

Define here how the how the correction image, the Source for shading image, is to be preproc-
essed before the correction.

o Use this option, if a reference image for correction has been acquired and does not
need further processing. Such an image might either be taken without a sample or
without illumination. The Source 1 option is disabled in case of this option because
otherwise the active image would either be divided by itself or subtracted from itself re-
sulting in empty images consisting entirely of pixels with the value 1 or 0, respectively.

NxN average filter. The NxN filter is a smoothing filter to eliminate noise as explained in Chapter
8.2.15. It averages the pixel values in a square area — defined by the value in the Size field — around
each pixel and assigns the result to it. This process can be repeated several times depending on
the number set in the Iterations box. The resulting shading correction is also known as unsharp
masking.

Muk average filker
Iterations: 1

LEmERS

Size: 1]

Interactive zero-level. This is a useful option if obvious illumination gradient is visible in an image,
for example due to the illumination not being centered correctly; see the left cell image below as a
typical example.

What will happen?

This method allows the user to select three background areas — called Hotspots here - in the raw
image. The algorithm determines the average intensities in these areas and temporarily generates a
background image with a corresponding regular intensity gradient and uses this for the correction.
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How to use this method:

1.

Select the Additive mode in the Assumed deterioration field of the Define Shading
Correction dialog for this kind of shading correction.

Select the Interactive zero-level option, the Define interactive zero-level field will ap-
pear in the lower-left corner of the dialog box.

Define interactive zero-level

Hotzpat radivs: |8 13

Set the size of the Hotspot radius (from 1 — 64).

Execute the Processing » Shading correction command. The mouse cursor will carry a
red cross surrounded by a red circle of the size set above.

Click in to a background region. The circle will be fixed in the image overlay.

Repeat this step twice in other background areas.

After the third Hotspot is set, the shading corrected image will be generated automati-
cally.

Select the Polynomial fit option to have the correction image calculated based on a two-
dimensional fit of the original image ("least-square fit"). If this option has been selected, a new
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group will appear in the lower left corner of the dialog box in the Polynomial fit group. This is
where you determine whether the two-dimensional fit is Linear, Square or Cubic.

Polynomial fit
(&) Linear
() Square
) Cubic

8.1.3 Executing a Shading Correction

The Shading Correction is executed via Process » Shading Correction. The shading correction
as defined under Define Shading correction will be applied.

In case of multi-dimensional images the Dimensions dialog box opens. Here you can choose the
range of images in the different dimensions (Color Channels, Z-Layers and Time-Frames) for
which the analysis shall be performed in case only a subset of the data is of interest. By default the
entire data set is selected. With the option Step in Z-Layers and Time-Frames you can select
every second, third, fourth image and so on to be analyzed.

Shading Correction g|
Dimensions
Color Channels
[w]Furaz40
[¥]Fura3a0n
Z-Lavers
Time-Frames
From | 1 wl ko |81 | step |1 i
o J [ cancel
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8.2 Filters

8.2.1 General

A Filter modifies the intensity of each pixel according to the intensity of neighboring pixels.

Why filter images? Filters can be used to prepare the actual image analysis, for example by cor-
rection of image errors resulting from acquisition. Filter operations have the following possible ap-
plications:

e correction of image interference due to statistical noise,

¢ reduction of acquisition errors, e.g., CCD cameras sometimes provide erroneous gray values for
individual pixels,

¢ restoration of poorly-focused images,
e suppression or accentuation of minute image detail,
e accentuation of basic structures such as gray value edges.

Convolution filters. Many of the filters in this menu are convolution filters. A convolution filter is
defined using a filter matrix. A matrix can be described as a geometrical array of positive or nega-
tive whole numbers that serve as a mask placed over individual pixels. Any pixel that is to be re-
calculated is situated at the center of the filter matrix. Most filters employ a 3x3 matrix. In this case
the intensity of a pixel will be influenced by 8 of its neighboring pixels. Every pixel within a 3x3 ma-
trix will be multiplied by the matrix element above it — by the so-called weight factor. For the filter-
ing of the whole image the filter matrix will be shifted across the original image and the gray value
of each pixel will be recalculated.

Image Matrix
11] 1z |ls W[ Wz W3
la 15|18 * Wa| Ws| Wes
17| 1a |ls W7[Wa|We
What will happen? W,, ... \W, are the weight factors of a 3x3 filter matrix. |, ... , |, are the original

intensities of an image area comprising 3x3 pixels. The intensity of the central pixel, |,, after filter-
ing, is calculated as follows:
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Wyl +# Wyl + o+ Wy
normalization factor

filtering(lg) = 9 + offset

Normalization. In order for the filter operation not to alter average image brightness the result can
be divided by a normalization factor. Normalization usually consists of the division of the sum of all
weight factors, |W,|+|W,|+ ... + |W,|. If the result is negative it will be set to a gray value of "0" [i.e.,
black]. Negative weight factors in the filter matrix will yield negative intermediate results. When an
offset is added, negative values will be displayed in the resulting image. If the result turns out to be
greater than 255, it will be set to 255 [white].

Example. The application of a filter for a numerical example is calculated as follows:

Gray values of Gray values of

the original image Matrix the filtered image
o|-1|0 20 & 29
* (1 ]02]|0 10 53 32
o|ofo0 0 27 B0

Filter classes. The various types of filters can be divided into various classes. This division has
more to do with the application of the filters than their mathematical realization.

Derivative filters. Negative weight factors are admitted in the filter matrix of derivative filters and
the sum of the weight factors equals zero. The result for homogeneous gray value areas is 0: a
black area. On the other hand side, gray-value edges - i.e., the edges of objects within an image -
and intensity gradients become accentuated. These filters can aid you as far as edge extraction is
concerned. The occurrence of differential terms will however increase image noise.

Rank Filters. The Rank Filters comprise a filter class of their own. An environment of the central
pixel is defined here — with the filter matrix — specifying the adjacent pixels to be included in the
rank operation. All gray values of the area surrounding the central pixel will be sorted according to
magnitude — in descending order. The various rank filters differ as to which element of the ordered
sequence is to replace the central pixel. The adjacent area in the following example consists of 5
pixels arranged in the shape of a cross. The rank filter then generates an ordered sequence and
assigns the mean value of that sequence to each central pixel. The Sigma filter is for filtering out
statistical noise. Individual pixels of gray values which deviate greatly from their surrounding area
will, however, not be affected by the Sigma filter.
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Gray values of . Sorted sequence Gray values of
the original image Matrx 9 the filtered image

80 108 120 x | x| x | =50 85 104 109 120 =P

72 104 [I88[E

Smoothing filters. The Smoothing filters class comprises filters for averaging gray values sur-
rounding a pixel. This eliminates minor gray value peaking as well as statistical noise. At the same
time, any gray-value differences that contain image information will be flattened out. The resulting
image will thus seem somewhat blurry due to this type of filtering.

Applications of various smoothing filters. The diagram below comparatively shows the effects of
various filters used for smoothing purposes. The original image consists of a simple rectangle of
light shading upon a dark background. The image has strong noise amplitude interference. In addi-
tion, the image contains so-called ‘shot-noise’ — i.e., individual pixels have an intensity deviating
strongly above and below the image’s average gray value. Each image has its intensity profile dis-
played superimposed on the rectangle within the image. The Mean filter and the NxN filter broaden
the structure of the rectangle. The more powerful the smoothing effect, the more noticeably will the
morphology of the object within the image be altered. Shot-Noise will not be removed, rather these
noise pixels will simply be broadened and their intensity will be adapted to the image’s average
intensity. The extent to which the NxN filter broadens edges will depend on

Original A 2 A NxN
image Iterations =
o 150— —150 528=10
E =2
g g
2 100l 00 &
5 100 100 &
50— — 50
0 : 0
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@ 150 = =150 g
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[+
= =
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the parameters set. The Median filter reduces noise without broadening the rectangle and elimi-
nates Shot-Noise completely.

Filter parameter. There is a distinction between predefined and (user-) definable filters. Parameters
of definable filters can be set, thus allowing you to adjust the filter’s effect.

In the following chapters the available filters will be explained in detail. Before using the User Filter
and the NxN filter certain parameters have to be set in the respective Define dialog boxes, other-
wise the settings of the last usage will be taken by default.

Sharpen I Define Filter User Filker...

Sharpen 11 Filter 3 M. ..

Differentiake ¥ i i i Pseudo...
Arithmetic Operations ...

Arithmetic Operations ...

Image Geometry 3 Differentiate ¥ Reimer,..
RGE-Studio k| Laplace I Image Geometry ¥ Edge Enhance...
Laplace IT RGE-Studio ¥ Rark...

Mean Sigma...

Median 30-Images »
Pseudo
Sobel
Roberts
Reimer

30-Images 3

User Filker
T

Lowpass

Edge Enhance
Rank

Sigma

8.2.2 Sharpen |

Application. Detail emphasis

The Sharpen | filter belongs to the class of derivative filters and amplifies the central pixel relative to
the X- and Y-axes. Image details become emphasized by an enhanced contrast. Thus the image
the will seem to have increased focus. The Sharpen | filter enhances, however, noise as well.

Matrix. oO(-1]0
1|5 | -1
o|-1]0

Comparison. The overall effect is opposite to that of a smoothing filter.
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8.2.3 Sharpen Il

Application. Detail emphasis
Matrix. -1 -1] A1
119 |1
111

Comparison. This filter is similar to the Sharpen | filter but has a more pronounced effect.

8.2.4 Differentiate X

Application. Extraction of gray value edges in the Y dimension

Use this derivative filter to detect gray value edges parallel to the Y-axis; gray-value modulations
will be enhanced horizontally while they become filtered out vertically. Image noise should be rather
limited as this filter is susceptible to image interference.

Matrix. o|l0}|O
21-2|0
o|0}|O0

Comparison. If you wish to extract all edges of an object then select a Laplace filter.

8.2.5 Differentiate Y

Application. Extraction of gray value edges in the X dimension
Matrix. 0|j2]|0
0(-2|0
0(0]|O0
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Comparison. This filter is analogous to the Differentiate X filter but enhances edges parallel to the
X-axis.

8.2.6 Laplace |

Application. Extraction of gray value edges

The Laplace | derivative filter accentuates edges and smaller image structures in both the X and Y
dimension. It enhances, however, noise as well as.

Matrix. 0|-1(0
-1 4 | -1
oO|-1]0

Comparison. If you wish to have image edges accentuated only along one axis, then select the
either the Differentiate X or the Differentiate Y filter. Compare the Sobel filter as well.

8.2.7 Laplace Il

Application. Extraction of gray value edges
Matrix. -1 -1 -1
-1] 8 | -1
1] -1 -1

Comparison. This filter is similar to the Laplace | filter but has a more pronounced effect.
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8.2.8 Mean

Application. Smoothing

The Mean filter replaces every pixel with the arithmetical mean of that pixel and its eight neighbor-
ing pixels. This results in noise reduction. Abrupt gray-value transitions will also be smoothed over
however, thus appearing blurry after averaging. The Mean filter is a particular NxN filter based on a
3x3 neighboring pixel area.

Matrix. 1 1 1
1 1 1
1 1 1

8.2.9 Median

Application. Removal of "bad" pixels

The Median filter removes isolated — "bad" — pixels with intensities that differ strongly from the sur-
rounding pixels. Neighboring constant gray-value ranges (to these pixels) as well as edges remain
untouched. The filtered image thus loses none of its original sharpness.

What will happen? The Median filter is a smoothing filter from the rank filter class. A pixel’s value
as well as the values of its eight neighbors will be ranked according to their magnitudes. The mid-
dle value - the 5th one out of nine — will be assigned to the central pixel. Extreme gray values will
always be located either at the top or bottom of this listing - and will thus never be assigned to any
of the pixels. They thus disappear from the image. This suppresses noise points — and non-extreme
unevenness will be smoothed out.

Comparison. The Median and Mean filters are directly comparable. When neighboring pixels’ gray
values are distributed symmetrically with respect to the average value, both filters will yield the
same results; asymmetrical gray value distribution will yield varying results with the two filters. The
Median filter is numerically more stable - i.e., it reacts less sensitively to individual, greatly deviating
values.
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8.2.10 Pseudo Filter

This command is based on the definitions set in the Processing » Define Filter » Pseudo dialog
box.

Application. Relief-like appearance with "shadows"

Filtered images will appear topographical as if a relief-like surface is illuminated by an oblique light
source. Dark objects will appear as depressions, and light objects as elevations. This 'pseudo’
three-dimensional display of image structure gives the filter its name.

Matrix. oO(-1]0
-1 2|0 |+128
0|00

The Pseudo filter registers transitions from light to dark pixels. Transitions going from light to dark
are considered positive and transitions going from dark to light negative. The image will be normal-
ized such that the zero level is assigned to the value 128. This means that gray values between -
127 and +128 are available.

Comparison. The pseudo filter is a derivative filters but not be compared with the other derivative
filters Sharpen, Differentiate and Laplace filters.

Define Pseudo: Contrast. Set a contrast factor (0.01 — 100) — this will be multiplied by the weight
factors of the filter matrix. The preset value is 2. The larger the factor, the larger is the 3-D effect.

Define Pseudo @
Contrast: A=

[ Preview

Preview. If this option is selected, the image will show sub-frame window with a preview of the
filter result. The sub-frame can be set with the Window function.
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8.2.11 Sobel

Application. Edge detection

The Sobel filter is a genuine edge detector and does not react so sensitively to noise effects. This
is because differentiation is conducted using the lines and columns beyond the next-immediate
ones. Thus any interference in lines and columns directly next to the central pixel cannot influence
the results.

What will happen... The Sobel filter employs a non-linear method for edge enhancement. This filter
is comprised of a set of differentiation filters. Gray value modulations that are either horizontal or
vertical will be especially enhanced. The Sobel filter generally yields the magnitude and direction of
the most significant intensity gradient.

Matrix. | -1 | 0 | 1 112 |1
2102 |5a; 00|00 |=b= /a2+b2
110 |1 -11-2 -1

Two matrices are applied independently and then their geometric mean is taken.

Comparison. The results are comparable to those of the Laplace filters. Laplace Il leads to a
clearer accentuation of edges but increases the noise.

8.2.12 Roberts

Application. Rapid edge detection.

What will happen? The Roberts filter employs a non-linear method for edge enhancement and
registers transitions from light to dark pixels. This filter is comprised of two basic differentiation
matrices. Of importance is the difference in brightness in the diagonal of the four upper-left values.
Large differences result in high values; areas with small gradients will be suppressed. Due to the
low number of computations, this filter functions well as a rapid edge filter.

Matrix. [ 1] 0] O o] 1] o
ol -1 0|~ 4 1] o] 0|=b;=lal+]b|
o of o o of o

Comparison. The results are comparable to those of the Sobel and the Laplace filters but some-
what less precise, however, faster to compute.
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8.2.13 Reimer

This command is based on the definitions set in the Processing » Define Filter » Reimer dialog
box.

What will happen? The Reimer filter subdivides the entire image into areas of pixels with the same
intensity within a certain tolerance range. The borderlines between the areas are displayed in white,
all the rest in black. It results an image that resembles the isobars in a weather chart — a so-called
equidensitometric image of the second order.

Why the Reimer Filter? The Reimer filter is able to subdivide continuous gray value ranges within
an image, which the naked eye alone has difficulties to distinguish. Superimposing the filtered im-
age and the original helps determine areas of similar intensities.

Original

Original + Filtered Image

Define Parameter » Interval. The Interval sets the gray value tolerance range (1-254) for pixels to
be grouped into one area. The preset interval value is 32. The lower the selected interval, the more
image details are visible in the filtered image.

Define Reimer EI
Interval: |EE =

[ Preview
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8.2.14 User Filter

This command is based on the definitions set in the Processing » Define Filter » User Filter dialog
box.

Application. A user-defined filter provides you with the opportunity to select all filter parameters
yourself. A user-defined filter can be used, e.g., for combining different filters. This is done by add-
ing the weight factors of the individual factors. Another application is modification of existing filters.
This is done by increasing the mean image brightness by adding an offset.

What will happen? If you apply the user filter the following operation will be applied to each image
pixel:

Wyl + o+ Wyt + W, - |

Normalization factor " + Offset
where | = intensity of the central pixel in the original image
I~ = intensity of neighboring pixels in the original image
W.,-W_ = matrix elements or weight factors of the user filter
Define User Filter E|
S OFid  OSx5 O O
[ Preview
0 1 1]
1 5 1
0 -1 1]
Sum: 1 MNommalization: |1 | Difset: |0 4| [JHex. lattice

Define Parameters

Size. To determine the size of the editable matrix field select one of the following options: 3x3, 5x5,
7x7 or 9x9. For hexagonal matrices the numbers define the number of fields in the middle matrix
line.

Filter matrix. You can enter the individual weight factors [via keyboard] into the fields in the middle
of the dialog box. Positive or negative whole numbers are permissible.
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Sum field. The sum adds up all matrix current elements. Use this sum as a scale for the brightness
of the resulting image: "0" will mean your image is quite dark. Mean brightness will not have
changed if your sum is "1".

The value in the Normalization field determines the range of gray values of the resulting image
(according to the above-mentioned formula). Positive whole numbers greater than zero are permis-
sible. The sum of all weight factors is used for image normalization when user-defined filters are in

use.
XXX
Fiede
.a‘:a‘:b‘
KXX
Square Hexagonal

lattice lattice

Image row 2n+1

(...
f:i: '

The value in the Offset field determines the gray value to be added to the resulting image.

When you select the Hex. lattice check box, the square matrix will be replaced by a hexagonal
matrix. The diagram above shows determination of neighboring pixels using either a square or hex-
agonal filter matrix.

8.2.15 NxN

This filter is based on the definitions set in the Processing » Define Filter » NxN dialog box.
Application. Reduction of statistical noise

What will happen? The NxN filter averages the gray values of all pixels surrounding a central pixel
and assigns them to that central pixel. The name of the filter refers to the size of the image area
whose pixels’ gray values are average.

When determining filter size "N" you should keep generally the following in mind: the smaller the
matrix, the finer the details you can edit. These details can include artifacts or interference. Larger
matrices suppress these effects but yield blurrier resulting images — mean value filters smooth out
gray-value peaks. The higher the number of iterations, the greater is this smoothing effect will be.
You may end up blurring edges.

Comparison. The NxN filter, a smoothing filter, is most closely related to the Mean filter. The NxN
filter permits you to determine the size of the averaging area, and thus the extent averaging is to
take - this is not possible with the Mean filter.



cell™ z cell® software Manual Chapter 8 - Image Processing

Define NxN.

Define NxN

terations:| 3|2

Size: 512
CFreview

Iterations. Enter the number of times the filter is to be applied successively to the image. Select an
entry between 1 and 25. The preset value is 3. The greater the number of iterations, the greater is
the extent of the averaging.

Size. Enter filter matrix size into the Size field. The preset matrix size is 51. If you choose to make
your matrix very large, the filter will affect large image structures.

The number of iterations and matrix size also determine the time required to complete
the filter operation.

8.2.16 Lowpass

Application. A Lowpass filter transmits space frequency in a highly unadulterated form. High space
frequencies — generally image noise or fixed pattern camera noise- will be suppressed and strong
contrasts will be smoothed. Low space frequencies, which generally carry the actual image infor-
mation, pass the filter.

8.2.17 Edge Enhance

This filter is based on the definitions set in the Processing » Define Filter » Edge Enhance dialog
box.

Application. Edge enhancement
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The term "edge" refers here to an image area in which gray values either rise or fall sharply. This
filter can be used as pre-procession before particle detection. However, noise may also be en-
hanced.

What will happen? The filter examines the gray values of all pixels within an image area comprising
NxN pixels and determines if the central pixel of the matrix is within a certain percentage range of
either the minimum or the maximum value of its neighboring pixels using the following algorithm:
I > {l a5 — (Percent/100)* (1 oy = i)} = 1= Iax
| < {lnax — (Percent/100)*(l oy = L)t = 1= 13
where | = intensity of the central pixel

Imax = maximum intensity inside the NxN pixel area

lin = minimum intensity inside the NxN pixel area
Define Edge Enhance
Size. Enter the dimensions of the NxN pixel area (3 — 9). The larger the area, the less detailed the
resulting image will be. The preset size is 5.

Define Edge Enhance @

Size: (==
Percent: |60 ||3
0

Percent. The Percent (1 — 99) field defines the threshold for the central pixel to the assigned either
the minimum or maximum value of the surrounding pixels. With a lower percentage, darker gray
values of the original image will predominate while a higher percentage will result in the predomina-
tion of lighter gray values. The preset percentage is 50%.

8.2.18 Rank

This filter is based on the definitions set in the Processing » Define Filter » Rank dialog box.
Application. Image smoothing

It primarily filters out isolated pixels with gray values, which differ greatly from their immediate sur-
roundings. Rather homogeneous gray value areas and edges are retained. In contrast to filtering
with a median filter, the filtered image loses none of its original clarity.
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Define Rank Filter.

Define Rank Filter ]

Size: E =
Rank Order: 60|52
[ Preview

Size. Enter the radius of the area to be considered. You can select radii from 1 to 11 at intervals of
0.5. The preset value is 3.

Rank. The pixel intensities within the area are ranked. Enter the rank in percent with which the
central pixel is to be replaced. When Rank is 0%, central pixels will always be replaced with the
lowest gray value of the surrounding pixel area, when Rank is 100%, by the highest gray value.
With the preset rank of 50%, the central pixel will be set to the median gray value of the rank se-
quence.

8.2.19 Sigma

This filter is based on the definitions set in the Processing » Define Filter » Sigma dialog box.
Application: statistical noise filtering

Assumption. Local noise in an image follows a Gaussian distribution. The Gaussian curve can be
described by its half width 2c. A small ¢ indicates a narrow curve with high maximum; this is the
intensity distribution in a homogeneous object with low noise. A large ¢ indicates a flat and wide
shape; this is the intensity distribution in a homogeneous object with high noise.

What will happen? The algorithm examines all pixels within an area of a set size and calculates the
average value of all those pixels, which are within a certain intensity range (I ..., + 20) relative to the
central pixel. All pixels with gray values outside this intensity range very likely belong to another set
of object information and are therefore ignored. If the number of pixels within the intensity range is
less than or equal to half the square root of the number of all neighbors the central pixel will be

replaced by the mean value of the four directly adjacent pixels.

Comparison. Unlike the Median filter, the Sigma filter does not remove isolated — "bad" - pixels
with intensities that differ strongly from the surrounding pixels.
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Define Sigma Filter

Define Sigma Filter 3]

Size: E =
Sigra: =
[ Preview

Size. Enter the radius of the area to be considered. You can select radii from 1 to 11 at intervals of
0.5. The preset value is 3.

Sigma. Enter the value that defines the intensity range to be considered.

8.2.20 DCE - Differential Contrast Enhancement

This filter is based on the definitions set in the Processing » Define Filter » DCE dialog box.
Application: selective enhancement of weak differences in contrast

What will happen? The DCE filter renders image structures visible that are barely distinguishable
from one another in the original image. Resulting images are thus more detailed and appear more
focused.

Most images are comprised of greater and lesser gray value modulations. Greater gray value
modulations are significant, clearly-visible gray value differences. Lesser gray value modulations
are minimal, barely-visible gray value differences.

The lesser gray-value modulations are what define differential contrast. The DCE filter separates the
two image components in order to selectively enhance the lesser gray value modulations.

The situation is comparable for color values. When true-color images are involved, the intensity
component of color values is what defines differential contrast. Minimal fluctuations in intensity will
be enhanced such that the image’s original coloring will remain unchanged.

Define DCE filter.

Bandwidth defines the range of gray values belonging to the lesser gray value modulations. Enter a
whole number between 0 and 100 into the Bandwidth field or do the same using the scroll bar.

The bandwidth parameter defines the range of gray values/intensity the lesser gray value modula-
tions are comprised of. When the bandwidth is narrow, gray value modulations of a minimal dy-
namic range will be strongly-enhanced. This means that low bandwidth values result in greater
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image detail via a suppression of high-amplitude contrast modulations. Broad bandwidths result in
greater contrast but also contain less image detail.

Define DCE '

X

Bandwidh: | 20/ € =
Enbancement | 80| < 3
[ Quality Devenflow
[ Ramp optimize 0.08) [ %
Preview
[ Preview

Enhancement indicates the factor by which lesser gray value modulations are to be enhanced.
Enter a whole number between 0 and 100 into the Enhancement field or do the same using the
scroll bar. The Enhancement parameter determines the factor by which lesser gray value/intensity
modulations are to be enhanced. Which value is the most suitable for differential contrast will de-
pend on the bandwidth selected. Employing a narrow bandwidth in conjunction with strong en-
hancement will yield the greatest differential contrast. Image detail will be accentuated whereas
larger image structures will ‘take a step back’ into the background.

o The result of the DCE filter depends on the size of the image area in which you apply it.
This means that the image area in the smaller Preview window may look different than
the completely filtered resulting image. This difference will be even greater if the image
areas not shown in the preview window have very light or very dark pixels.

Quality. Select this check box to have image artifacts of the DCE filter reduced. This will lengthen
the time required to apply the filter.

The DCE filter can produce image artifacts that appear to be ‘scratches’. These are only found
within larger solid-color image areas. They are most noticeable when broad bandwidths and strong
enhancement are in use.

Ramp optimize. Select this check box to completely eliminate image artifacts resulting from the
DCE filter.

This check box can be used as a kind of supplement to the Quality check box. What will happen,
however, is that all contrast either large in area or strong in intensity will be completely suppressed.

Overflow. Enter the percentage of dark pixels to be set to black, and of light pixels to be set to
white into the field.

The last step involved with DCE filter calculation is a spreading of gray/color values applied to the
whole gray/color value range. This is why you can enhance image contrast in the resulting image by
simply clipping off gray/color values located at either the higher or lower extremities (of the
gray/color value range) and setting them to 0 or 255 respectively (for 8-bit images). These
gray/color values are available for spreading the remaining gray/intensity values. Percentages be-
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tween 0.05and 50.00 can be entered. When you select 50%, a gray value image will look very simi-
lar to a binary image: colors will be either white or black.

8.2.21 Separator

This filter is based on the definitions set in the Processing » Define Filter » Separator dialog box.
Application: separating objects such as connected particles or such as various intensity regions.

Define Separator filter

Define Separator gl
Boundary shape
v (O] _JrL ) Bright _I_ O Step -
Result
Execut
Siama O Black
File...
o
3¢
Fine / Coarse: () Bun black
2l (O Burh white

General usage procedure. The separator is adjusted to special image properties with the Smooth
and Fine / Coarse slide controls. To ensure correct setting of the filter parameters, the Preview
function should be used to continuously check the quality of separation. Start with low values for
the Smooth and Fine / Coarse slide controls. With this setting too many separation lines are gen-
erally drawn in. Now increase the Fine / Coarse parameter until you are close to the correct set-
ting. If some outlines can no longer be recognized, then increase the Smooth parameter and then
reduce the Fine / Coarse parameter. You will quickly achieve the best results with a few iterative
changes to these parameters.

Boundary shape

The separator affects light or dark lines dividing objects of the same color — or affects objects dis-
tinguishable from the background due to their intensity value.

Dark. Select this option if light objects have a dark outline.

Bright. Select this option if dark objects have a light outline.
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Step. Select this option if the individual objects are distinguishable by their varying intensity values.
Select this option when you wish to separate particles distinguishable from the background due to
their gray value.

Sigma = 0. The image can be preprocessed using a mean filter before separation. In the Sigma
field you enter the half-width values of the Gaussian distribution used. The greater the half-width
value, the greater the averaging effect - i.e., fewer separation lines will be found. A Sigma value of
0 means the mean filter is a binominal filter.

Smooth. Use the scroll bar to define the extent of smoothing for the binominal filter. Set a value of
0 to use an untouched original image as the basis for separation. The greater the value you set, the
more the image will be averaged. The influence of any local brightness fluctuation will be greatly
reduced by smoothing, thus increasing the probability of finding 'true’ separation lines.

Sigma > 0. the mean filter is a sigma filter for Sigma values greater than 0.

Smooth. You can change the diameter of the pixel neighborhood in which averaging takes place
via the Smooth value. The greater the smoothing value, the greater the area in which the sigma
filter averages. A smoothing value of 0 means that no averaging takes place at all. The Sigma field
will not be available.

Fine / Coarse. Adjust the scroll bar such that the filter suits your needs. The lower the value, the
more separation lines will be found. Higher values result in minimal gray value fluctuations being
ignored.

Result

The result provided by the separator is an image containing the outlines of the objects to be sepa-
rated. The width of the separation lines is one pixel. You can decide whether these lines are white
(255 intensity) or black (0 intensity). You can decide whether the image background is either black
or white accordingly, meaning the resulting image will be a binary image. Or you may take the im-
age background from the original image. In this case, the image type of the resulting image remains
the same. When using white separation lines, any pixels that were originally white will be reas-
signed an intensity value of 254 so that only the separation lines have an intensity value of 255.
When using black separation lines, any pixels originally black will be given an intensity value of 1.
This makes it possible to differentiate between separation lines and the actual image objects when
setting thresholds.

o After separating objects, the resulting image is the ideal basis for automatic particle de-
tection. As the separation lines are only one pixel wide, you must set fourfold connec-
tivity in the Define Detection dialog box so that the separation lines will actually
separate the particles. For eight-fold connectivity, the particles will be interconnected
via the pixels positioned diagonally to each other and as such will be detected as a
single particle.

Black. Select this option to have object outlines shown in black on a white background.

White. Select this option to have object outlines shown in white on a black back-ground.
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Burn black. Select this option to have black object outlines superimposed over the original image.
Black pixels within the original image are reassigned 1 as intensity value.

Burn white. Select this option to have white object outlines superimposed on the original image.
White pixels within the original image are reassigned 254 as intensity value.

Edit. Click this button to be able to edit the resulting image interactively after separation. This
opens the Edit Lines dialog box.

Edit Lines

As soon as you click the Edit button of the Define Separator dialog box, the separator will be ap-
plied to the image according to its current parameters. The Define Separator dialog box will be
closed and the Edit dialog box will be opened. You will see the result in the overlay of the original
image. If you have set a global frame you will only see the image area selected. A global frame is
set using the Image » Set Frame command. Do not confuse the global frame with the Preview
window you set in the Define Separator dialog box. The area defined by the Preview window has
absolutely nothing to do with editing.

o When editing, be sure to use a zoom factor of 100%.

OK Click here to confirm the current overlay and to execute separation using the settings in the
Define Separator: Result group.

Cancel. Click this button to return to the Define Separator dialog box. Any alterations you’ve
made in the edit mode to the computed lines of separation will be lost.

Erase All. Click this button to have all lines of separation erased from the overlay.

Set All. Click this button to reconstruct all lines of separation that you’d erased since opening the
Edit Lines dialog box. All lines either computed by the separator and/or drawn in by yourself inter-
actively will reappear in the overlay.

Erase. Click this button to erase individual lines of separation from the overlay. You can define a
circular image area interactively. All lines of separation within this circle will then be deleted as well
as all lines that intersect with the circle. A line segment is defined as a line between two points of
intersection. Until you confirm deletion by right-clicking, all deletion of outlines can be reversed -
one step at a time. To do so, press [Shift] and right-click simultaneously.

Trace. Click this button to select specific outlines. Before using this function, we would recom-
mend you click the Erase All button.

Polygon. Click this button to be able to add missing outlines ‘freehand’. Draw the arbitrary polygo-
nal figures desired within the image. Right-click to return to the Edit Lines dialog box.
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8.3

Arithmetic Operations...

Chapter 8 — Image Processing

This command opens a dialog box containing commands to execute various predefined arithmeti-

cal functions.
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What happens if there’s a pixel value overflow? Commands execute the arithmetical operations
one pixel at a time, thus processing all gray values. 8-bit channels have values between 0 and 255;
16-bit channels have values between 0 and 65535. When applying addition, subtraction, multiplica-
tion or division, the gray value range of the result(s) may be greater than that of the original im-
age(s). When the 8-bit or 16-bit value range is exceeded that gray value will be displayed as 255 or
65535, respectively. Negative values will be set to 0. To avoid this effect, we recommend you re-
duce the gray value range of the sources first, for example by dividing by suitable factor.

Boolean Operators. The operators AND, OR and XOR work on images bit by bit. For each bit of
gray value, the corresponding logical operation will be carried out. For gray-value images, the bi-
nary representation of 8 or 16 bit numbers must be taken into consideration.

Arithmetic Operations

Addition. A Constant or the Source 2 image (set) will be added to the active image (Source 1).
Overflow clipping will be performed at 65535 for 16 bit data and at 255 for 8 bit data.
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AND. Pixel values in binary form are compared bit by bit. If the bit is 1 for both images the result
will be 1, otherwise it will be 0.

Example (8-bit). Source 1 =170 = 10101010, Source 2 = 15 = 00001111, Result = 00001010 = 10.

Division. The active image (Source 1) will be divided by a Constant or by the Source 2 image
(set). Digits after the decimal sign will be clipped.

Maximum. The images in the source and the source 2 image buffers will be compared and the
greater pixel value selected from the respective image. The resulting image will thus have maximum
intensity.

Minimum. The images in the source and the source 2 image buffers will be compared and the
lesser pixel value selected from the respective image. The resulting image will thus have minimum
intensity.

Multiplication. The active image (Source 1) will be multiplied with a Constant or with the Source 2
image (set). Overflow clipping will be performed at 65535 for 16 bit data and at 255 for 8 bit data.

OR. Pixel values in binary form are compared bit by bit. If a bit is 1 for either of the sources the
result will be 1.

Example (8-bit). Source 1 = 170 = 10101010, Source 2 = 15 = 00001111, Result = 10101111 =
175.

Subtraction. A Constant or the Source 2 image (set) will be subtracted from the active image
(Source 1). Negatives will be set to 0.

XOR ("exclusive OR"). Pixel values in binary form are compared bit by bit. If the bits differ the result
is 1, if the bits are identical, the result is 0.

Example (8 bit): Source 1 = 170 = 10101010, Source 2 = 15 = 00001111, Result = 10100101 =
165.

8.4 Image Geometry

8.4.1 Resize

The function Process » Image Geometry » Resize creates a copy of different size of the active
image without cutting of parts like the Extract ROI cropping function does (see Chapter 7.7, Ex-
tract...). The original data remain untouched.

Factor. Set here the resizing factor for the spatial dimensions X, Y and - in case of Z-stacks — Z
can be set. The corresponding Size will be set automatically.
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Size. Alternatively, set the resulting size in the spatial dimensions X, Y, and - in case of Z-stacks -
Z. The corresponding Factor will be set automatically.

Ratio.

Maintain XY-ratio. If this option is selected, a change of the X Factor or X Size causes automati-
cally a corresponding setting of the Y Factor or Y Size and vice versa.

Zoom axes independently. If this option is selected, it is possible to set, for example, different Fac-
tors for X and Y. Doing so leads to a distortion of the resulting image.

Zoom axes homogeneously. This option is available for Z-stacks only. Here all three Factors X, Y
and Z will always have the same size.

Interpolation

Resizing images will result in a reduction in image quality. This is because the color of each original
pixel must be redistributed across a different number of pixels and the result will be less precise
than the original. There will be an inevitable loss of sharpness, regardless of whether the image is
enlarged or made smaller.

Nearest Neighbor. This method doubles or removes pixels. The appearance of the new image
may be somewhat coarse.

Trilinear. This method interpolates the color of the original pixels to come to the new pixels.

Bicubic (XY), Linear (Z). This method interpolates the color of the original pixels to come to the
new pixels using a different algorithm in the X and Y dimensions as compared to the trilinear
method. The appearance of the resized image will be slightly less blurry.
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8.4.2 Rotate

The function Process » Image Geometry » Rotate allows rotating single images and entire data
sets in the XY plane. By doing so it creates a new data set so that the original images remain un-
touched.
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Angle. Set the rotation angle in this box.

Set Angle. This command allows setting the rotation angle interactively using two lines initializing
from the same point.

1. After clicking the button, position the mouse cursor at the origin of the angle and left-
click.

2. Position the mouse cursor onto a point of the angle’s ’first’ arm. A straight line will ap-
pear in the overlay.

3. Left-click to fix the first arm. It will be drawn into the overlay.

4. A second arm will appear starting from the initial point of the first arm upon movement of
the mouse. Draw the second arm in the same way.
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5. The Rotate window will open again with the interactively defined angle set in the Angle
box.

6. Continue with setting the Direction and the Options.

7. Execute the rotation by clicking OK.

Direction. Chose between a left (counterclockwise) and right (clockwise) rotation.

Interpolation. If this option is selected, pixel colors may be created by mixing the colors of
neighboring original pixels. This will give the rotated image a smoother appearance (middle image
below). If the option is not selected, the result may make the features look coarse (right image).

However, in case of biological samples, the interpolation effect will hardly ever be visible. It is of
greater importance in case of graphics with sharp borders between areas of different colors (left
image below).

Il 47 #

8.4.3 Mirror
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The function Process » Image Geometry » Mirror allows to reflect single images and entire data
sets at four predefined axes of choice: the central Vertical, the central Horizontal or any of the two
Diagonal axes. Check the radio button of the desired axes and then click OK.

8.4.4 Align

The Process » Image Geometry » Align function performs a rotational alignment of the Source 1
image relative to the Source 2 image. Make sure that the Source images are set correctly in the
Operand box of the Imager Manager. After starting the function set the first reference point by
mouse click in the active image (Source 1). Upon doing so, source 2 becomes active automatically.
Set the corresponding reference point there. Source 1 becomes active again for you to set the
second reference point. Again Source 2 becomes active again for you to set the corresponding
second reference point. You may continue setting reference points or finish the process by a right
click. Upon finishing a rotated copy of Source 1 will be generated with its reference points lined up
as good as possible with those of Source 2.

8.4.5 Auto Align Z

Especially in long-term time-lapse experiments it may happen that the sample is moved in the XY
plane. This may be caused by an accidental push of the microscope or the table or upon intention-
ally manipulating the sample, may be after injection of an agonist. Such a movement makes certain
analyses difficult, for example intensity kinetics. An ROI defined in the first image will no longer
contain the same structural features after the movement and the resulting numbers may become
meaningless.

The Process » Image Geometry » Auto Align Z function performs an object detection and detects
movements of the objects in X and Y from one image to the next. It then corrects the movement by
shifting the images so that the objects are positioned in the same XY position again. The resulting
images are smaller than the original ones because the areas vacated by the shift are cut off.
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8.4.6 Shift Correction

Use this function to move individual color bands interactively in multi-color image sets in X and Y
relative to the other bands. A new image is generated, the original data remain unchanged.

The Shift Correction is useful when multi-color images are acquired with several single band filter
sets (instead of multi-band filter sets). It may be that the dichroic mirrors in different cubes do not
have exactly the same angle relative to the optical path. As a consequence, the resulting images
may be slightly shifted relative to each other. The function is also especially useful for dual-
emission images acquired with the beam-splitting device DualView Microlmager™.
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The use of the Display Channel, Adjust Channel, Load LUT, The Adjust Display tab buttons is
described in Chapter 6.2.2.1, The Adjust Display tab.

Horizontal / Vertical Shift. Use the arrow buttons to shift the selected channel relative to the oth-
ers.

Center. Use this button to move the active channel back to the original position.

Save values for other uses. If this option is selected, the values of the current shift settings will be
loaded automatically when the command is executed the next time and can simply be confirmed
with OK.
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8.5 Thresholds and Binarization

8.5.1 Set Thresholds

This command sets thresholds of one or more phases for the images.

A number of image-processing functions are only available for use on binary images. If your image
isn’t binary already, you will need to convert it - i.e., ‘binarize’ it. A binary image has only 2 gray
values - ‘0’ and ‘255’.

The way this binarization takes place, is dependent on the type of image, i.e. whether dealing with
gray-scale, color or multidimensional images. Due to this, the command and the dialog boxes differ
accordingly.

o Currently, there is no mechanism for setting thresholds for multidimensional images. If
you need to binarize multidimensional images, you have to convert the image into a set
of standard images first. This is achieved with the Image » Separate command, see
Chapter 7.6, Separate. The resulting gray-scale images can be analyzed in the same
way as any other gray-scale images.

Gray-scale Images

To convert a gray-value image into a binary image, you must define which pixels — of your original
image - are to be assigned to which gray value (i.e., between ‘0’ or ‘255’) in the binary image. This
information appears in the form of a gray value range. Any pixels whose gray values are within this
gray value range, are considered ‘set’ and will appear as the ‘foreground’ within the binary image.
All remaining pixels - considered ‘not set’ - and will appear as the ‘background’ (the background is
usually displayed black). You do have the option of defining more than one gray value range.

The Set Threshold dialog box sports two tabs.
The Manual tab...
...defines interactively the gray value ranges for your active image.

You can define several gray value ranges for an image. Each of these gray value ranges is called a
phase. Phases, or gray value ranges, must be continuous - i.e., there cannot be any gray value
‘gaps’ within the ranges you define.
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The thresholds you define represent the upper and lower ‘limits’ of a phase. A phase having its
thresholds at ‘0’ and ‘100’ is comprised of all gray values (G) between ‘0’and ‘100’: this can be
expressed in the following way: 0<=G<=100.

Click the New button to define another gray value range. After clicking on the button, a new entry
will be added to the Phase list. This new phase entry comprises the standard phase name plus its
number. This new gray value range will now be comprised of all gray values not yet assigned to a
specific phase. Because gray value ranges have to be continuous, the lower gray values will be
assigned phases first.

All gray value ranges you have defined already can be found in the Phase list.
¢ Select a Phase from this list that you wish to edit.

¢ You can alter the standard phase name as you like. To do so, simply click on the phase’s pre-
sent name, and then you can enter a new, suitable name for this gray value range. The name
you give the phase will be used in the phase analysis result sheet. This phase name can also be
used as a particle parameter in an automatic particle detection.

Enter the upper and lower thresholds for the active phase in their respective fields — High and Low.
The lower threshold represents the lowest gray value belonging to this phase - the upper threshold
the highest gray value. Thresholds can also be set directly by using a histogram. Using the mouse,
simply move the red and blue lines (representing the higher and lower thresholds) to where you
want them on the histogram. The values in the High and Low fields will reflect the current position
of these lines - even as you move the lines.

Click the Include Pixel button to expand the active phase’s gray value range. Once you have
clicked on this button, you will be able to use the mouse cursor to adjust the phase thresholds
onscreen. When you then move the mouse cursor to a position where the gray value is beyond one
of the active phase’s thresholds (High or Low), the relevant threshold will be adjusted to that at the
mouse cursor’s position. The Preview will continually be updated to display your adjustments.

The Zoom function (i.e., the buttons showing a lens with a + and a - sign, respectively)is for
spreading a histogram on the x axis — or reversing this spreading. Zooming is essential when work-
ing with 16-bit images because any gray value range of interest is often quite small in comparison
to the total number of possible gray values.
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Possible spread factors for 8-bit images are 2x and 4x. 16-bit images can in addition be spread to
8x, 16x, 32x, 64x, 128x and 256x. The current spread factor is displayed on the left of the dialog
box - next to the scroll bar. Use the X scroll bar to spread a histogram on the x axis.

The Diagram list has 4 different options you can choose from: Histogram, Smoothing,1st Deriva-
tion and 2nd Derivation.

The 1st Derivation displays the local maximums and minimums through the zero crossing.

Use the Smooth list to define to what degree the function displayed in your diagram is to be
smoothed. The higher the value you enter here, the smoother the curve will be displayed. Smooth-
ing is useful with regard to derivatives because a derivative (curve) often has irregularities that make
it difficult to make out the main path of the curve.

Smoothing will affect the display of the following functions: Smoothing, 1st Derivation and 2nd
Derivation. A Histogram is always displayed without smoothing.

Select a color for your active phase from the Color list. This color will be displayed in the diagram’s
color bar — indicating where this phase is. The gray values belonging to this phase can then be
displayed in this color in your image. The color you select here will also be used for phase color
coding (Measure » Phase Color Coding command).

Use the options located in the Preview group to ‘keep an eye on’ the effect the thresholds you
select have on the image. In preview — whether you have set a frame or not — your selections will be
applied to the whole image.

Select the None option to turn off the preview. None of the phases defined will be displayed in
color within the image.

Select Current to have the phase’s currently-active gray values displayed (in color)in your image.
The preview display will be continuously updated - this enables you to judge whether the image
structures you’re looking for are being covered by the thresholds you set.

There are 2 color displays available to choose from:

¢ Normally, all pixels within the gray value range of the active phase will be displayed in the color
selected in the Color list.

¢ Select the Transparent check box to get a false-color display of the phase’s gray value range.
Select All to have the colors of all phases displayed simultaneously in your image.

Select Background to have those gray value ranges displayed in color that haven’t been assigned
to a phase.

There are 2 color displays available to choose from:

¢ Normally, the background will be displayed red.

¢ Select the Transparent check box to get a false-color display of the phase’s gray value range.
Select the Transparent check box to have the active phase displayed using a special LUT. Dark
image areas will be appear green to light yellow. This type of coloring has the advantage of ena-

bling you to look at both gray value range and image structure at the same time - allowing you to
define thresholds with even greater precision.
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This check box is only available in conjunction with the Current and Background check boxes.
Click the File... button to open the standard dialog box for the opening and loading of files. This is
where you can save threshold settings — or load threshold settings you have already defined (and
saved).

Click the Auto button to use automatically calculated thresholds. Parameters used for the auto-
matic calculation of thresholds are taken from the settings in the Auto Settings tab.

To set automatic thresholds you have to click the Auto button before you exit the dialog box by
clicking on OK.

Select a gray value range - i.e., a phase — from the Phase list and then click the Delete button if
you wish to delete this phase. This button is available as long as there is still at least one phase
existent.

The Auto Settings tabs

Sets the parameters used to automatically calculate thresholds.
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The diagram in this dialog box displays a histogram of the image. Histogram calculation is based
on the portion of the image you have defined via the Set ROI button. When you first call up this tab,
histogram calculation will be based on the whole image.

Enter the number of gray value ranges - i.e., phases — you wish to have into the No. of phases
field. When working with 16-bit images you will be limited to 2 phases plus background or 3 phases
without background.

Decide whether image structures are to be light or dark in the Background group.

Select the Low option if image structures are light, and the background dark. The automatic
threshold setting will then divide the image’s whole gray value range - for 8-bit images 0-255 - into
n+1 ranges (n= the number of phases desired). The lower gray value range will not be assigned a
phase - it will be considered part of the background.

Select the High option if image structures are dark and the background light.
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Select the None option if you wish the whole gray value range to be divided up into n phases (n=
the number of phases desired).

Select the Preview check box to have the phases displayed in color. The phases will be displayed
in the standard colors as shown in the color bar beneath the diagram.

Defining the portion of the image to be used in histogram calculation, is done in the Histogram
limits group. You can exclude gray values from either the upper or lower end of the histogram.

Select the Dynamic option to have the relevant gray value range calculated for each image indi-
vidually. The values in Underflow and Overflow are for you to define what percentage of an im-
age’s pixels — at the upper and lower end of the image’s histogram - are to be excluded from the
threshold-setting procedure.

Select the Fixed option to have your thresholds set within a fixed gray value range. The values you
enter into Lower limit and Upper limit define this fixed gray value range.

For the calculation of your thresholds, enter the lower gray value into the Lower limit field. Any
gray values lesser than this value will be ignored for threshold calculation. This value is an absolute
value and is independent of the image histogram.

Enter the highest gray value - for the calculation of your thresholds — into the Upper limit field.

Enter the percentage of dark gray values that are to be ignored during threshold calculation into the
Underflow field. If you enter "1%" here, the program will ignore1% of the darkest pixels when cal-
culating your thresholds. The lowest gray values(to be ignored during threshold calculation) vary
from image to image and are thus calculated anew for each image — based on its histogram.

Enter the percentage of light gray values that are to be ignored during threshold calculation into the
Overflow field.

Click the Set ROI button to define the portion of the image to be used for automatic threshold cal-
culation. Define the rectangular area interactively using the mouse. This frame is only used for
automatic threshold calculation.

Click the File... button to open the standard dialog box for the opening and loading of files. This is
where you can save parameters for automatic threshold calculation — or load previously saved pa-
rameters.

OK is not available when the Auto Settings tab is active.

o To set automatic thresholds, you have to switch over to the Manual tab first and click
on the Auto button there. Then you can exit the dialog box by clicking on OK.
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8.5.2 Set Color Thresholds

Sets color thresholds using the RGB or HSI color space.

Thresholds cannot be set for a single image or image buffer. They apply to all images you currently
have loaded.

To convert a color image into a binary one, you must define a range for each of the channels of the
image; either Red, Green, and Blue, or Hue, Saturation, and Intensity. During binarization, a pixel
will be assigned the gray value '255' if all of its components fall into the valid range.

The Set Color Threshold dialog box offers two tabs.
The RGB tab...
... sets thresholds based on the RGB model.
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The Phase list contains all color ranges that have already been defined.
e Select a phase from this list that you wish to edit.

e You can alter the standard phase name as you like. To do so, simply click on that phase’s field
and then enter the name of your choice.

o Be sure to give each phase a specific name. If you do not — and continue using the
standard phase names — then when you delete a phase, the phase name and the actual
phase itself will no longer correspond to each other. If you use specific phase names,
name and phase correspondence will remain unchanged.

Color ranges are defined separately for each color channel. The Red, Green and Blue fields indi-
cate where the lower and upper limits of each channel are. Each color channel can be located
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anywhere between the values 0 and 255. The easiest way to define color ranges is to go right into
the image and select a portion of the picture containing the color desired. To do this, first click on
the New button (located in the Include pixel group).

Select a color for your active phase from the Color list. This color will be displayed in the diagram’s
color bar - indicating where this phase is. Use the Preview to have portions of the image belonging
to a phase displayed in the phase’s color.

Click the New button to define a new color range - i.e., phase. After clicking on the button, a new
entry will be added to the Phase list. This new phase entry comprises the standard phase name
plus its number. This new color range always includes the values 0 - 127 (for all three colors).

Select a color range - i.e., phase - from the Phase list. Then click on the Delete button to delete
the phase selected. This button is available as long as there is still at least one phase existent.

o If you are using the standard phase names, the correspondence between an actual
phase and its standard name may get changed around. When you, for example, delete
‘Phase 2', 'Phase 3' will then become 'Phase 2', 'Phase 4' will then be'Phase3', and so
on. A Phase that has been deleted will not be entirely forgotten until you close the dia-
log box. Until you do that, you can retrieve any ‘deleted’ phases by simply clicking on
the New button.

The diagram in this dialog box displays the histogram of each of the color channels. The red curve,
for example, represents the distribution of red color values in the image. The whole image is used
for histogram calculation - no matter whether you have set a global frame or not.

Use the Y scroll bar to spread a histogram on the Y axis. This enables you to evaluate the progres-
sion of the curve even when the number of pixels at a particular point on the curve is quite low.

The color bars below the histogram represent each of the color channels. Color bars display
phases that have already been defined. Each bar displays its corresponding color range - in the
same color as in the Preview. Activate any of these color channels for a particular phase by simply
left-clicking on the color bar of that channel.

The Red, Green and Blue fields display the current thresholds for the active phase.

Two lines demarcate the active color channel within the histogram. The blue line represents the
lower threshold, the red line, the upper threshold.

Thresholds can be adjusted within the histogram. To do so, simply move your mouse cursor over
one of the two lines. Once the mouse cursor changes shape - into a ‘double-arrow’ - simply pull
the line (keeping the left mouse button depressed) to the position desired. You have to activate one
of the color channels before you can adjust any thresholds.

Left-click on one of the phases in the color bar. Keeping the left mouse button pressed, you can
move both thresholds simultaneously.

Use the buttons located in the Include pixel group to define color ranges within the image interac-
tively. Select a color range within the image in the color of your choice. Your program will then take
the pixels belonging to that part of the image and deter-mine minimum and maximum color values.
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Use the options located in the Preview group to see whether all the image structures you’re inter-
ested in have been included. If need be, simply correct the thresholds by adjusting them directly in
the histogram.

When you click the New button, the color thresholds that had been set for the active phase will
become obsolete. New color thresholds will be defined within the image. Use the mouse to define
circular image area(s) containing the colors within the active phase. All pixels located within the
circular areas so defined will be the basis for color threshold calculation.

1. Left-click to have a circle appear around the mouse cursor.

2. Keeping the left mouse button pressed, you can alter the radius of this circle.

3. Confirm the size and position of this circle by right-clicking.

4. You can select several image areas in this way. To return to the dialog box, simply dou-
ble-click using the right mouse button.

Click the Include button to add color values to the current color values comprising the active
phase. This will enlarge the color range the phase covers.

Click the Exclude button to reduce the color range of the active phase.

Use the options in the Preview group to check the thresholds you have selected. To speed up your
checking, the thresholds will only be shown in a special window (that must be defined for this pur-
pose).

Select the None option to turn off the preview. None of the phases defined will be displayed in
color within the image.

Select the Current option to have image areas - belonging to the active phase — displayed in the
color selected. The preview display will be continuously updated - this enables you to judge
whether the image structures you’re looking for are being covered by the thresholds you set.

Select All to have the colors of all phases displayed simultaneously in your image.

To have image areas not yet assigned a phase displayed in color, select the Background option.
The image background will then be displayed in the color of the phase currently active.

Click the Window button to define the preview window. The mouse cursor will then automatically
appear within the image and a frame will appear in the overlay. Keeping the left mouse button de-
pressed, you can adjust the frame’s size and position as you wish. To set the frame, right-click.

Click the File... button to open the standard dialog box for the opening and loading of files. Here’s
where you can save and/or load color threshold settings.

The Undo and Redo buttons can be used to reproduce all previously set threshold settings — as
long as this dialog box is open. These buttons refer to the settings located in the RGB and HSI
tabs.

Click the Undo button to ‘undo’ a previously-set threshold setting one step at a time.
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The Redo button will only become available once you’ve ‘undone’ a threshold setting. Click this
button to reproduce a threshold setting you had undone.

The HIS tab...
... sets thresholds based on the HSI (Hue, Saturation, Intensity) model.

The RGB and HSI tabs both have the same structure. Below is a description of only those controls
that have a function differing from that in the RGB tab.
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[ 0K ][ Cancel ][ Help

Curve Color used in diagram
Color value magenta

Saturation light blue

Intensity black

Every color is made up of the color value itself, saturation, and intensity. To define a phase, you
have to enter a range between 0 and 255 for both saturation and intensity. For Hue (color tone),
you can enter values between 0° and 360° — steps of 0.5° are acceptable. The Hue, Sat. (satura-
tion) and Int. (intensity) fields indicate the upper and lower limits for the respective hue, saturation
and intensity channels. The easiest way to define color ranges is to go right into the image and
select a portion of the picture containing the color desired. To do this, first click on the New button
(located in the Include pixel group).

The diagram in this dialog box displays only one curve at a time - this is less confusing. The dia-
gram plots the number of pixels versus color, saturation or intensity. The saturation curve the dis-
tribution of color saturation in the image. The whole image area is used to calculate these curves -
no matter whether a global frame has been set or not.

Use the Y scroll bar to have the curve displayed spread on the Y axis. This enables you to evaluate
the progression of the curve even when the number of pixels at a particular point on the curve is
quite low.

The color bars below the histogram represent each of the color channels. Color bars display
phases that have already been defined. Each bar displays its corresponding color range — in the
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same color as in the Preview. Activate any of these color channels for a particular phase by simply
left-clicking on the color bar of that channel. If you switch back and forth between channels the
curve’s progression displayed in the diagram will, of course change accordingly.

The Hue, Sat. and Int. fields display the current thresholds for the active phase.

Two lines demarcate the active color channel within the histogram. The blue line represents the
lower threshold, the red line, the upper threshold.

Thresholds can be adjusted within the histogram. To do so, simply move your mouse cursor over
one of the two lines. Once the mouse cursor changes shape - into a ‘double-arrow’ - simply pull
the line (keeping the left mouse button depressed) to the position desired. You have to activate one
of the color channels before you can adjust any thresholds.

Left-click on one of the phases in the color bar. Keeping the left mouse button pressed, you can
move both thresholds simultaneously.

8.5.3 Binarize

The Binarize... command is context-sensitive. It changes to Binarize Color Image...if the active
image buffer contains a 24-bit color image.

Multi-dimensional images. At present you cannot binarize multi-dimensional images. If you need
to binarize multidimensional images, you have to convert the image into a set of standard images
first. This is achieved with the Image » Separate command, see Chapter 7.6, Separate. The result-
ing gray-scale images can be handled in the same way as any other gray-scale images.

Why binarize images?

Some image analytical functions can only operate with binary images. A binary image is composed
of two different gray values only, i.e., each pixel has one of two possible values: set (white) or not
set (black). In order to improve the processing speed of image analysis functions, a binary image
has a data depth of 8 bits. The two possible binary status values are coded through the gray values
of either 0 (black) or255 (white).

Which gray values become white, and which black?

To transform a gray-value image into a binary image, it has to be known which pixels(of the original
image) are to be displayed in black, and which ones in white. This is determined via one or more
gray value intervals. Any pixels having gray values within the gray value interval(s) will be displayed
white, all others black.

Defining gray value intervals

Use the Process » Set Thresholds... command to define these gray value intervals — which is done
by defining one or more phases.
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Binarize

If only one phase has been defined currently, the Binarize command will automatically use the
phase’s left and right threshold to generate a binary image.

If several phases are currently defined, the Binarize command will open the dialog box of the same
name. This is where you can select one phase whose gray values are to be displayed in white — or
you can select all the phases.

Binarize

Phase: |Phase oK,

Phaze 2 _

Select al

Select a phase whose gray values are to be binarized white from the Phase list. Gray values of all
other phases, and the background, will be binarized black.

Select the Select all check box to assign the color 'white' to the gray values of all defined phases.
This is a way to have gray value areas — that are not next to one another — displayed in white.

Binarize Color Image

If only one phase has been defined currently, the Binarize Color Image command will automatically
use the three pairs of color thresholds (of the three channels RGB or HIS) of this phase to generate
a binary image. All color values within the phase’s limits will appear white in the resulting image -
all other color values will appear black. If several phases are defined currently, the Binarize Color
Image... command will open the Binarize dialog box, see above.



cell™ s cell® software Manual Chapter 8 — Image Processing 169

8.6 Deblurring and Deconvolution

8.6.1 General

Deblurring and deconvolution both are software tools to remove out-of-focus light from images to
sharpen the contours of the imaged structures. They should, however, not be confused with each
other.

i
=] 3D-Deconvolution

3-D deconvolution is an image restoration method, which moves out-of-focus light from each slice
of a Z-stack back into the slice where it originates. It thus conserves all light information of the Z-
stack, sharpens the resolution, improves the signal-to-background ratio and allows and improves
quantitative intensity analyses.

Deblurring, however, is not a restoration method but works subtractive and doesn't allow any
meaningful quantitative analysis afterwards but should be regarded as a purely cosmetic method.
Side effects are increased background intensity, increased noise, decreased signal-to-background
ratio and possible sharpening of out-of-focus structures.

8.6.2 No Neighbor

The No Neighbor algorithm is the faster algorithm as compared to Nearest Neighbors. As a trade-
off in order to achieve this speed, it is less accurate. It works by deblurring one image slice at a
time.

The principle. An unsharpened image of the image that is being processed (source image) is cre-
ated and then subtracted from the source image. The unsharpened image is taken as an approxi-
mation of the out-of-focus information. Thus, the unsharp image contents are being removed while
the sharp contents remain.

Available. All cell*R / cell®M image types can be deblurred: single images, time series, Z-stacks
and 3-D time-lapse series, all either monochromatic or multi-colored.
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8.6.3 Nearest Neighbors

The principle. The two neighboring layers (one above and one below) of the Z-stack layer that is
being processed are temporarily unsharpened and then subtracted from the layer that is being
processed. Similar to the No Neighbor approach the unsharp images are approximations of the
out-of-focus information. However, in the Nearest Neighbors algorithm the supposed out-of-focus
information in fact stems from out-of-focus layers and is thus considered as a superior input for the
calculation.

Available: Z-stacks and 3-D time-lapse series, both either monochromatic or multi-colored.

8.6.4 Deblurring Images

Requirements. The images need to be calibrated in the X, Y and Z dimensions, see Chapter 7.1,
Calibrate Image; otherwise an error message will be generated.

Channel Settings

Click the Deblurring button (or select Process » 3D-Images » Deblurring). If deblurring was not
applied before on the active image the Channel Settings dialog will open.

Channel Settings for Deconvolution g]
Calibration
Scale ¥: 0108 = um
Scale ¥: 0108 = um
Scale Z: 0194 = um

Microzcope Parameters

Emigsive Wave Length: 485 il

LARERS

MNurnerical Aperture: 1

Befractive Index: Air (1.0 v

o (oo ]

Color Channel. Select the channels one after the other in order to set their Microscope Parame-
ters.

Calibration. This field lists the scaling in the three spatial dimensions as set in Chapter 7.1, Cali-
brate Image. If necessary the settings can be changed in the Scale X/X/Z boxes.
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Emission Wavelength. This is the maximum intensity wavelength of the light emitted from the
specimen but also dependent on the transmission properties of the emission filter in the fluores-
cence cube of the microscope. If running a brightfield setup, enter 540 nm.

Numerical Aperture. This parameter is printed on the objective. It determines the light gathering
capacity and resolution of the objective. The (theoretical) upper limit of is the Refractive Index.

Refractive Index. This is an optical characteristic of the immersion medium and can be selected
from the pick list for each Color Channel.

OK. Confirm the settings and return to the Deblurring dialog window.

3D Deconvolution: Filter Selection. Select either No Neighbor or Nearest Neighbor from the
Filter Selection shortlist.

o In case of single images and time series only No Neighbor is available.

3D-Deconvolution E]

Filters | Projection

Filter Selection

Haze Removal Factor [%]: Fila)

4

SubVolume Overlap:

Microzcope

[ Transmitted Brightfield

[ LChannel Settings.. ] [ File... ]
[ u] ] [ Cancel ] [ Help ]

Haze Removal Factor (%).. This parameter is expressed as a percentage value and determines
the power of the deblurring. The higher the number, the more blurring is removed from the images.
The effect will hardly be visible with values below 50 while the default of 85 gives moderate results.
Very high values like 98 or more result in rather grainy images with very pronounced contrasts and
can introduce artifacts. Be sure to carefully check the results.

Transmitted Brightfield. Mark the check box if you use a brightfield setup. The check box Phase
Object becomes available.

Phase Object. Mark the check box, if the specimen is a phase object. A phase object is any
specimen with little light absorption, e.g. living Mitochondria, chromosomes, bacteria, or cyto-
plasm.
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Execute. This button in the Deblurring dialog window starts the calculation. A window opens that
shows the progress of the calculation.

OK. Exit the Deblurring dialog after the calculation is finished.

8.6.5 Inverse Filter

The Inverse Filter is a one step non-iterative deconvolution method based on inverse-filtering the-
ory. It utilizes optimal linear filtering and is a simple deconvolution method. It is very useful for ob-
taining quick results, but is not as accurate as Blind Deconvolution (as offered, for example, in the
AutoDeblur software package by AutoQuant). Inverse Filtering is typically more robust than the
Nearest Neighbor or No Neighbors deconvolution methods. The execution speed of the Inverse
Filter is between that of Nearest Neighbors and Blind Deconvolution.

Available: Z-stacks and 3-D time-lapse series, both either monochromatic or multi-colored.

Requirements. The images need to be calibrated in the X, Y and Z dimensions, see Chapter 7.1,
Calibrate Image; otherwise an error message will be generated.

JD-Deconvolution @

Filters | Projection

Filter Selection

Inverse Filter v

Filter Parameters

Moize Level: Medium A4

43

Subolume Overlap: 10

Noise Level. The picklist offers the Auto, Low and Medium options. Select the option according
to the level of noise in your image stack. In most cases, the Auto parameter produces very good
results. Should, however, the convolution only be faintly visible, results with the Low or Medium
options can be better.

Tiling. The algorithm produces huge temporary data, the size of which will easily exceed the com-
puter RAM, even with Z-stacks of only moderate size. Tiling allows the application to subdivide the
large datasets into a size the processing computer’s RAM can handle. The advantage of larger
subdivisions of data being processed is the increase in processing speed and therefore a decrease
in the amount of time it takes to deconvolve a dataset.

Sub-Volume Overlap (Pixels). Tiling often results in clearly visible, rectangular artifacts at the bor-
ders of the sub-volumes. Increasing the Overlap of the sub-volumes can reduce this side effect.
This, however, increases the processing time. The sub-volume overlap setting determines the
number of pixels that the montaged sub-volumes will overlap. The possible values are integers
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from 0 to N/2, where N is the width or height of the XY field in pixels whichever is smaller. An over-
lap of 10 or 25 pixels usually works best. If the result of the deconvolution with a value of 10 con-
tains artifacts having rigid lines, edges or an obvious grid structure, start with a value of 10, then
increase this number. Overlapping regions are deconvolved twice, so making this number too large
(e.g. 100) will increase the deconvolution time.

8.6.6 3D-Blind Deconvolution

This feature is part of the deconvolution module SW_CELL_3DB_WF of the cell"M /
cell*R software and not available in the basic software packages.

3D-Deconvolution E|

Filters | Projection

Filter Selection

3D-Blind D econvolution

Filter Parameters

Iterations: 10

SmERS

Subolume Overlap: 10

Microzcope

widefield Fluorescence v

[ LChannel Settings.. ] [ File... ]

[ u] H Cancel H Help ]

This is a true, intensity restoring deconvolution method. The algorithm removes out-of-focus inten-
sity from each Z-stack layer and adds it to the layer of origin. Thus, the image resolution is strongly
enhanced and the overall fluorescence intensity within the z-stack conserved. At the same time, the
signal-to-background intensity is improved.

Because the global intensity is conserved, the deconvolved images are especially well suitable for
quantitative intensity analyses.

Available: Z-stacks, either monochromatic or multi-colored.

Requirements. The images need to be calibrated in the X, Y and Z dimensions, see Chapter 7.1,
Calibrate Image; otherwise an error message will be generated. For meaningful results a back-
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ground subtraction has to be carried out before the calculation, see Chapter 10.5, Background
Subtraction.

Iterations. The higher the number of iterations the better will be the result. Mind however, that this
method is time-consuming in general. 10 iterations are a good starting point that usually renders
considerably improved data. After about 50 or 100 iterations, improvements will hardly be visible
with further iterations.

Sub-Volume Overlap. See Chapter 8.4.5, Inverse Filter.
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Measurements

Chapter 9 - Measurements

For length and area measurements the cell*R / cell®M software provides a designated environment
for length and area measurements with its own button bar and the Measurement View in the Image
Manager. All measurements become linked with the parent image and are automatically stored as
part of it and can be displayed and modified at will.
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9.1 Measurements Toolbar

List I @ G... I G.. r‘rl;_ e
Ready Measurements

Measurements

Click on the Measurements button at the bottom of the Image manager to open the Measure-
ments View.

Select Measurement » Measurements Bar or press <Alt+4> to open the measurement button
bar. The measurement functions of the button bar and the different analyses in the menu are ex-
plained in the following chapters.

3 Points Angle
-4 Points Angle
Rectangle
Rotated Rectangle
3 Points Circle
Circle with Center and Radius
Ellipse

Measurements E

i TG AL DOOC QOO0 EEEISN T B BE

Create Measurement Sheet
Delete Measurement from Image

Polyline Move Origin
Arbitrary Line Magic Wand
Horizontal Line Free Hand Polygon
Vertical Line : Fitted Polygon
Touch Count Interpolated Polygon
Point Closed Polygon

All the measurement functions can be found on the Measurements button bar. There is one button
for each function. Begin a measurement by clicking on the button with the desired measurement
function. You can measure as many values on the image as you like. You end the measurement by
a right-click or the <Esc> key. Several measurements can be conducted successively. The results
will be displayed in the overlay and written into a sheet, which will be generated automatically.
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If you do not want the results to be shown in the overlay select Show labels » None in Spe-
cial » Preferences » Measure (or Measurement Properties button in the Measurement View or
key F8).

9.2 Drawing Tools for Length and Area Measure-
ments

9.2.1 Point

j Point

Use this command to measure parameters of single pixels. With each left mouse click a colored
cross "+" is drawn in the overlay. The XY coordinates of pixels are measured by default. The X
coordinate is then shown in the images overlay while the X and Y coordinates are displayed in the
measurement display in the Image Manager. To determine further positions click left. A right-click
lets you exit the Point function. The results are displayed in the overlay. One can then start to count

a second set of objects or terminate the command with another right-click.

9.2.2 Touch Count

% Touch Count

Use this command to count objects in an image. Several measurement series can be conducted
successively to count objects of various classes.

With each left mouse click a colored cross "+" is drawn in the overlay at the position of the tool tip
and the count is increased by 1. A right-click stops the counting. The result is displayed in the over-
lay and written into a sheet generated automatically. One can then start to count a second set of
objects or terminate the command with another right-click.
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9.2.3 Length

9.2.3.1 Vertical line

g Vertical line

Use this command to measure a vertical distance between two horizontal lines.

Measurement Results. The distance to be measured will be denoted by a vertical line labeled with
the length by default. This vertical distance will also be listed in the measurement display.

How to define a vertical distance:

1. Upon clicking the button a horizontal red line appears at the mouse cursor. Position it at
the horizontal distance’s starting point.

2. Left-click and the red line will be drawn in the overlay.

3. A second vertical line will appear at the mouse cursor. Position it at the horizontal dis-
tance’s end point.

4. Left-click and a vertical line representing the distance measured will be fixed in the over-
lay and labeled with the length.
The fixed horizontal line will vanish.
The remaining horizontal line at the mouse cursor can be used for a new measurement.

5. Continue the measurement in the same way.

6. Terminate the measurement with a right click.

9.2.3.2 Horizontal line

ﬂ Horizontal line

Use this command to measure a horizontal distance between two vertical lines.

Measurement Results. The distance to be measured will be denoted in the overlay by a horizontal
line labeled with the length by default. This horizontal distance will also be listed in the measure-
ment display.
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How to define a vertical distance:

A horizontal measurement is done using the same steps as for the vertical distance.

9.2.3.3 Arbitrary line

ﬂ Arbitrary line

Use this command to measure distances between two parallel lines of arbitrary orientation.

Measurement Results: The distance to be measured will be denoted by a straight line labeled with
the length by default. This "arbitrary distance" will be listed in the measurement display.

How to define a vertical distance:

The measurement is done using the same steps as for the Horizontal Distance command.

9.2.3.4 Polyline

E Polyline

This command allows determining the length of irregular structures of an image. The distance to be
measured will be denoted by a polygonal line made up of straight-line segments in the overlay
labeled with the length by default.

1. Position the mouse cursor at the starting point of the distance to be measured and left-
click. A red line will appear in the overlay between the starting point and the moving
mouse cursor.

2. Move the mouse and left-click at the corner positions to draw a multi-segment line.
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3. In case corrections are necessary, keeping the <Shift> key pressed, left-click to delete
previous figure segments one by one from the overlay.

4. Right-click to finish the line. Its length will be displayed in the overlay and written into the
measurement display.

5. Draw a second line or click <Esc> to terminate the measurement.

9.2.4 Angle

9.2.4.1 3 Points Angle

‘A 3 Points Angle

Use this command to measure an arbitrary angle using two lines initializing from the same point. It
is called 3 Points Angle because each line has a separate end point but the same starting point.
The angle will be displayed in the overlay and listed in the measurement display. cell*R / cell"M
measures angles clockwise between the angle’s first and second arm. Thus the order of drawing is
decisive.

1. Position the mouse cursor at the origin of the angle and left-click.

2. Position the mouse cursor onto a point of the angle’s ’first’ arm. A straight line will ap-
pear in the overlay.

3. Left-click to fix the first arm. It will be drawn into the overlay.

4. A second arm will appear starting from the initial point of the first arm upon movement of
the mouse. Draw the second arm in the same way.

5. Right-click to terminate the measurement.

o Note again that the angle is measured clockwise exclusively and does not depend on a
clockwise or counter-clockwise movement of the cursor.
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9.24.2 4 Points Angle

ﬂ 4 Points Angle

Use this command to measure the angle between two lines. It is called 4 points because each line
has a separate starting and end point. The intersection divides each line into two segments. The
angle is measured clockwise between the longer segment of the first and the longer segment of the
second line. Thus the order of drawing and the length of the lines are decisive. The angle will be
displayed in the overlay and listed in the measurement display.

1. Position the mouse cursor at the origin of the first line and left-click.

2. Move the mouse cursor; a straight line will appear in the overlay.

3. Left-click at the end of the first line.

4. Draw the second arm in the same way, starting at any given point.

5. Right-click to terminate the measurement.

o Note again that the angle is defined according to the length of the line segments and
measured clockwise exclusively.

9.2.5 Area

9.2.5.1 Rectangle

g Rectangle

Use this command to measure a rectangular object. Default measurements are area and perimeter.
Several measurement series can be conducted successively.

As soon as the button is clicked a red rectangle appears in the image overlay.

1. Drag the mouse to move the rectangle.
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2. Drag the mouse with the left button pressed to change the size and shape of the rectan-
gle.

3. To fix the rectangle right-click, and a new rectangle will appear. Proceed as before.

4. To exit the measurement press <ESC>.

The result will be displayed in the overlay and listed in the measurement display.

9.2.5.2 Rotated Rectangle

Q Rotated Rectangle

Use this command to measure a rectangular object of arbitrary orientation. Default measurements
are area and perimeter. Several measurement series can be conducted successively.

As soon as the button is clicked a red rectangle will appear in the image overlay. The left mouse
button toggles between the Move and the Rotate modes, indicated by the crosshair and the circu-
lar arrow, respectively, in one corner. Dragging without a mouse button clicked performs the mov-
ing and rotating. In either mode a left button drag changes size and shape. The best way to draw is
the following:

1. Open a rectangle at any position and switch to Rotate with a single click (on the corner
of the rectangle).

2. Rotate the rectangle so that the edges are parallel to the desired position.

3. Change to Move with another single click (on the corner of the rectangle) and position
the corner opposite to the crosshair to its final position.

4. Finally adjust the size of the rectangle via left button mouse drag.

5. To exit the measurement press <ESC>.

The result will be displayed in the overlay and listed in the measurement display.
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9.2.5.3 3 Points Circle

23 Points Circle

Use this command to measure a circular object by selecting 3 points on the arc of the circle. De-
fault measurements are area and perimeter. Several measurement series can be conducted suc-
cessively.

1. Mark a point at the arc of the circle of interest with a left-click; an x will appear.

2. Select a second point at the arc of the circle of interest with a left-click; another x will
mark this position

3. Move the mouse and a circle passing through the two marks will be displayed.

4. To fix the circle select a third arc point with a left click.

5. Continue by drawing a second circle or exit via right-click or <ESC>.

The result will be displayed in the overlay and listed in the measurement display.

9.2.5.4 Circle with Center and Radius

g Circle with Center and Radius

Use this command to measure a circular object by selecting the circle's center and one point of the
arc. Default measurements are area and perimeter. Several measurement series can be conducted
successively.

1. Select the center of the circle with a left-click, an x in the center and a circle will appear.

2. To adjust the size, move the mouse. Fix the circle by clicking on a point at the arc of the
circle of interest.

3. To fix the circle right-click when desired size has been achieved. A new circle appears
with the sizes of the previous one. Proceed as before.

4. Proceed as before or exit with <ESC>.

The result will be displayed in the overlay and listed in the measurement display.
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9.2.5.5 Ellipse

Q Ellipse

Use this command to measure an elliptical region of arbitrary orientation. Default measurements
are area and perimeter. Several measurement series can be conducted successively.

As soon as the button is clicked a blue ellipse circumscribed by a red rectangle between four blue
lines will appear in the image overlay. The left mouse button toggles between the Move and the
Rotate mode, indicated by the crosshair and the circular arrow, respectively, in one corner. Drag-
ging without a mouse button clicked performs the moving and rotating. In either mode a left button
drag changes size and shape. The best way to draw is the following:

1. Click the Ellipse button to open an ellipse and move it roughly to the desired position.

2. Adjust the size by dragging with the left mouse-button pressed.

3. Switch to Rotate by a single left-click.

4. Rotate the ellipse to the desired position.

5. Switch back to Move by another single left-click.

6. Adjust the size of the ellipse via left button mouse drag.

7. Fix the ellipse with a right-click. A new ellipse with rectangle will appear.

8. Proceed as before or exit with press <ESC>.

The result will be displayed in the overlay and listed in the measurement display.

9.2.5.6 Closed Polygon

g Closed Polygon

Use this command to measure an irregular area with straight border segments. Default measure-
ments are area and perimeter. Several measurement series can be conducted successively.

1. Left-click on a point at the border of the area. A red line will appear in the overlay be-
tween the starting point and the moving mouse cursor.
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Move the mouse and left-click at the corner positions of the area to draw a multi-
segment line.

Drag the mouse with the left button pressed to draw a freehand line or left-click at the
corner positions to draw a multi-segment line.

In case corrections are necessary, keeping the <Shift> key pressed, left-click to delete
previous figure segments one by one from the overlay.

Right-click to automatically draw a line to close the polygon.

6.

Draw a second polygon or click <Ese> to terminate the measurement.

The result will be displayed in the overlay and listed in the measurement display.

9.2.5.7

Interpolated Polygon

@ Interpolated Polygon

Use this command to measure an irregular object with rounded corners. Default measurements are
area and perimeter. Several measurement series can be conducted successively.

1.

Left-click on the border of the area. A red line will appear in the overlay between the
starting point and the moving mouse cursor.

Mark two more border points relatively close by. A red triangle circumscribed with a blue
interpolated line appears.

Continue by marking more border points.

Right-click to automatically draw a line to close the structure.

5.

Draw a second polygon or click <Ese> to terminate the measurement.

The result will be displayed in the overlay and listed in the measurement display.
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9.2.5.8 Fitted Polygon

@ Fitted Polygon

This command is identical to the Interpolated Polygon command with the difference that the
segmented polygon will circumscribe the interpolated line instead of vice versa. A right-click auto-
matically draws a line to close the structure.

9.2.5.9 Free Hand Polygon

ﬂ Free Hand Polygon

This command is identical to the Interpolated Polygon command with the difference that the out-
line of the area has to be drawn freehand with the left mouse button pressed. A right-click auto-
matically draws a line to close the structure.

9.3 Magic Wand

M Magic Wand

Use this command to measure objects defined based on similarities in intensities or colors of
neighboring pixels. Default measurements are area and perimeter. Several measurement series can
be conducted successively.

1. Click on an image point. The software determines its intensity and color and compares it
with the neighboring pixels. Pixels with values that match the selection criterion (see next
chapter) will be included into the selected area.

2. Right-click to confirm the selected area.

3. Select another area or terminate the measurement via right-click or <Esc>.

The result will be displayed in the overlay and listed in the measurement display.
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9.3.1 Magic Wand Options

Measurement Properties (in the Measurement View)

The Magic Wand Options are part of the Measure Preferences, to be found on the Measure tab
in Special » Preferences. Shortcuts to these options are the F8 key and the Measurement Prop-
erties button in Measurement Display of the Image Manager.

Tolerance. This parameter decides de degree of similarity to the origin that a pixel must have to be
selected. The match has to very good in case of low values: a small number of pixels will be se-
lected. For high values the similarity can be rather remote and a large area will result.

Smoothing. Depending on the dynamic range and the evenness of labeling within the selected
image object the borders of the area selected by the magic wand can be raggedy. A smoothing
factor larger than 1 will effect the selection of objects with more regular shape.

Color Space. The color space used determines the general criterion for the pixel selection with
respect to color and intensity.

il RGB

RGB. Monitor colors and images acquired with color cameras are composed of the three primary
colors red, green and blue in different intensities. Multi-color images acquired with cell*R / cell*M
may contain channels of different colors but are converted into RGB images upon display. With the
RGB space the similarity criterion has to be fulfilled in all three channels for pixels to be selected.
This color space is especially useful for multi-color fluorescence images.

El HSI

HSI. This is a more abstract color space than RGB. Hue, the color tone, is explained below. Satu-
ration can be seen as the difference between a set color and white. Similarly, Intensity is the dif-
ference to black. Selected areas may differ considerably in multi-color fluorescence images as
compared to the RGB selection.

El Hue

Hue. Hue is the color tone in a scale of pure "rainbow" colors ranging from red over yellow, green,
cyan, blue to magenta and back to red. Onscreen these colors are composed of binary mixtures
with different proportions of the monitor colors red, green and blue. These conditions are often
visualized by a colored ring with red at 12 o'clock (0°), green at 8 o'clock (120°) and blue at 4
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o'clock (240°). With hue as similarity criterion artifacts may result in fluorescence images because
the pixel intensity is not considered at all.

il Intensity

Intensity. Here the similarity criterion is the overall pixel intensity added up from all color channels.
In other words, the image is analyzed as if it was a monochromatic (black&white) image.

9.4 Results

9.4.1 Move Origin

@ Move Origin

Use this command to change the origin of the coordinate system. By default, the origin of the co-
ordinate system can be found in the upper left corner of the image. Click the Move Origin button to
move the coordinates origin to a desired position on the image. All values already measured are
adapted to the new origin.

1. As soon as the Move Origin button is clicked the mouse cursor will move to the red co-
ordinate arrows on the left top of the image overlay.

2. The arrows color will change to yellow indicating the ability to move them.

3. Move the arrows to the desired location and left-click to set the new coordinates. The
function terminates automatically.
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9.4.2 Create Measurement Sheet

E Create Measurement Sheet

All executed measurements create an entry in the measurement display. These results remain
linked to the image after the image has been saved. Additionally it is possible to list the measure-
ment results in a spreadsheet. Such a sheet can then be exported in different formats via
File » Save as....

Click on the Create Measurement Sheet button located in the measurement button bar to open
the Create Measurement Sheet dialog box.

Create Measurement Sheet @

Select the images whose measurements will be included in
the sheet:

Image

1:Tvl
dz:tvz
Oa:Te3

Cancel

Select Al
Unselect All

Show image name in the first column
[IGenerate statistics of the sheet(s)

Help

[1one sheet per image

[ create separate column for each type of measurement

Image. All images are listed that contain any measurement objects. Select the images the meas-
urements of which are to be converted into sheets.

Show image name in the first column. This option is useful if the measurement results of several
images are to be combined in one sheet.

Generate statistics of the sheet(s). This function is currently disabled.

One sheet per image. Select this option if the results of several images are to be combined in one
sheet.

o The unit of the measurement values in the measurement sheet corresponds to the unit
in which the image has been calibrated. To change this unit, use the Image » Calibrate
Image... command, for details see Chapter 7.1, Calibrate Image.

Editing sheets. Several editing functions are available in the Sheet Context Menu that can be
opened by right-clicking on a sheet:
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Cuk Chrl+-%
Copy Chrl+iC
Delete Delete

Edit Column Header . ..
Sort Ascending

Sort Descending
Create Copy
Autofilter

Create Graph...

Define Statistics. ..
Statistics

Define Context Menw, ..

9.4.3 Deleting Measurement Results

E Delete Measurement from Image

Use this command to delete individual objects and their measurements interactively.

1. Click the Delete Measurement from Image button and select the object to be them in the
image overlay.

2. Delete another object or terminate the function via right-click or <Esc>.

o Selecting them in the measurement display and pressing the <Del> key can also delete
objects and their measurements.

ﬂ Delete Measurement button

Use this command to delete the entire measurement results of the active image.
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94.4 Image Link

@ Image Link

Use this command to locate measurement values in the Measurement display by selecting them in
the image overlay. This command is useful when many measurements have been taken.

1. Click the Image Link button located in the Measurement Display. The pointer moves to
the image window.

2. Click on any measurement object in the image overlay.

3. The respective measurement value becomes highlighted in gray in the Measurement
Display.

4. Terminate the function with the <Esc>.

9.4.5 Show/Hide Statistic

"% | show/Hide Statistics

Use the Show/Hide Statistics toggle button to hide or show the Statistics field in the lower part of
the Measurement Display. See also Chapter 9.4.7, Define Statistics.

9.4.6 Select Measurements

For the different types of measurement objects different measurement functions are available. By
default different measurement functions are selected for each type, for example, Area and Perime-
ter for 2D objects (rectangles, circles, polygons etc.), Length for Lines. Use the Select Measure-
ments function to open the respective dialog window.
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@ Select Measurements

M Select Measurements M=1E3
= Al | Measurements Type ~
2D-Object . B irea Area
. P [ 28 Aspect Ratio Shape
roup of points . .
Line o/ stector Irnrer b an Distarice Get Default
Paint O d Bisector Inner Max 0., Angle
[1 ./ Bizector Inner Mean Diztance
[ ./ Bizectar Inner Min Distance
[1 /" Bizector Duter Max Distance
O d Bizector Outer Max ... Angle
[/ Bizector Duter Mean  Distance
Selected Measurements Object Type ~
Paint Faint 4+
Length Line
Angle +
Perimeter 2D-Object v x
The area of a measured object is [number of pisels of the meazured object] imes
[calibration Factors in # and v direction).

Tree View. It is located in the upper left hand part of the dialog box and lists the different types of
measurement objects. Click on any type to list all measurements possible for this type in the
Measurement Parameters list.

Measurement Parameters list. Add new measurements to the Selected Measurements list by
marking the respective check box or remove measurements by unmarking the check box.

Selected Measurements list. Click on a measurement function in the list to show the description
and a schematic drawing in the dialog box. Move the selection up or down with help of the Arrow
Up or Arrow Down buttons on the right or deselect the measurement by clicking the Delete but-
ton. It can be added anew to the list any time.

ﬂ Delete

If changes are made the Measurement Display becomes updated automatically upon closing the
dialog with OK.
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9.4.7 Define Statistics

Chapter 9 — Measurements

@ Define Statistics

This button opens the Define Statistics window.

Define Statistics g
Awailable: Curent:
Average Deviation ok,
Delta Max. Mean -
Delta Min, Minimunm
Furtogis Maximum
Median Standard Deviation
Skewness
Sum
Dawn
Dezcription:
The total nurnber of all values.
[ Mean is known a prior [N-\ariance)
LColor rows of result sheet

= I Line
=- 1 Line
= | Line
= j| Line
=] Line
= | Line

Length: 19,64 pm
Length: 14,33 prm
Length: 18,19 pm
Length: 28,98 pm

Length: 33,65 pm

1 bl: BT 97

Statizhics for 'Length’

Mame

Count

Mean

Minimum

M arimunm

Standard Deviation

Value
124
24,04 pm
1047 pm
87,32 pm
1223 pm

[ Statistics on all images

(] List ‘G JG (i Me...

Available. All available statistics parameters that are not yet selected are listed here.

Current. All statistics parameters to be shown in the Statistics field of the Image Manager are

listed here.

Add >>. Select a parameter from the Available list and click this button to add the parameter to the

Current list.

<< Remove. Select a parameter from the Current list and click this button to remove the parame-

ter from the list.

Description. This gives and explanation of the parameter currently selected.
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9.4.8 The Preferences » Measure Tab

Measurement Properties

Use this function to open the Preferences » Measure Tab. For a detailed description refer to
Chapter 13.5.4, The Preferences » Measure Tab.

The Magic Wand Options are described in Chapter 9.3.1, Magic Wand Options.



cell™ & cell® Software Manual Chapter 10 - Intensity Analyses

10 Intensity Analyses

The analysis features explained in this chapter are very important for cell biological applications.
Line intensity profiles illustrate intensity changes along arbitrary lines within an image. Commonly
regions of interest are defined to determine average intensities and follow their changes through
image series to quantify dynamic processes and display the results in graphs and sheets. Meaning-
ful quantification usually requires background subtraction. Special image ratio algorithms are used to
quantify ion-imaging experiments. Spectral bleed-through in multi-labeled specimen skews quantita-
tive analyses but can be corrected with spectral unmixing. The enhanced chromatic resolution pro-
vided by this technique also allows clearly distinguishing spectrally very similar fluorochromes.

101 PiXElI VAIUE ot 196
10.2  HiIStOGram oo 197
10.3 Line Profiles: INteNSity.......coeiiiiiii e 198
10.3.1 Horizontal Line Profile .........cceevieiiiiiiiee e 198
10.3.2 Vertical Lin€ Profile ........coviieiiiieee e 199
10.3.3 Arbitrary Line Profile.........ueeeeiiiiiiiiiee e 199
10.3.4 Average Intensity of Neighboring Pixels ........ccccooiiiiiriiniinenn. 200
10.4 Regions of Interest — ROIS.........cooiiiiiiiiiiei e 201
1041 GENEIAL....iiieie et 201
10.4.2 Drawing ROIS .....uuiiiiiiiiciteeee ettt 201
10.4.3 ROI Measurements (2-D).....cuuueeeeeeeemmmemeeeeeieeeeeeeeeeeeeeeseeeeeeeeeeennnne 204
10.5 Background Subtraction.......ccccccoeeecieiiiieiiiiieieee e 205
LRI B € T=Y o 1= = | SR 205
10.5.2 Subtracting the Image Background...........cccccereiiiiiniiiinieninenn. 205
10.6 Intensity Kinetics in Time and Z.........cccccceiiiiiiiiiiieeeeeeeee e 207
10.7 DeltaF / F (AF/F) AN@lYSIS.....uuuiiiiiiiiiiiiiiieeie e esreieeee e sssveneee e 208
T0.7.1  GENEIAL...ciiiieee e 208
10.7.2 Generating a (AF/F) SEQUENCE.........ueiireiiiiiiiiiiieee e 208
10.8  Ratio ANAIYSIS ... 210

O < T B €= o 1= = 210

195



196 Chapter 10 - Intensity Analyses OLYMPUS

10.8.2 Generating a Ratio SequeNCe.........ccceviriiiiiriiiei e 211
10.9  Spectral UnmiXing ......oceeeeeieeereeeieeeeiie e ereeee e 212
10.9.17  APPLICATION ...ttt 212
10.9.2 The Problem ... 213
10.9.3 The SOIULION.....eeiee e 214
10.9.4 How DOES it WOIK?.....oiiieeiie et 215
10.9.5 Spectral Unmixing with cell*R / cell’M......ccoccoiiiiiiiiiiiiieneen, 216
10.9.6  Calibration .........ooi i 217
10.9.7  UNMIXING . ciiiiiiiiieieiieeiiirie e e e e s s sssreee e e s s s s sssssreeeeeesessnnnnes 218
10.9.8 Unmixing of Color Camera Images ........cccceveeeeriiriiiieeieenee e 220
10.10 Phase Color Coding and ANalySiS.....ccc.eueecerreeeenieesiieeeeeeeeeeenaees 221
10.10.1 Phase Color COAINgG ....ccccueerreerrreeriireereeesreeesree e e e 221
10.10.2 Phase ANalYSiS.......ceeiuuerieeiiieeeeree e e e 222
10.11 ColOCaAliZAtION. .......eeeei ettt e 222
10.12 The FRET Software Module ..........ccocceeiiiiiiiniiee e 224
10.12.1 Image ACQUISITION .......ueiiiiiiii et 224
10.12.2 FRET Image Correction FacCtOrs .........ooeecuveeiieeiiiieiiiieeeeee e 226
10.12.3 FRET ANAIYSIS ... eieiieieeeeeieieeeeeiieeeeetie e e sseee e e e seee e e s sneeeeessneeeeennes 228

Image Analysis
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Image Analysis

The analysis features explained in this chapter are very important for cell biological applications;
many can be called with the buttons in the Image Analysis toolbar.

10.1 Pixel Value

Use the command Measure » Pixel Value to determine coordinates, and measure gray or color
value(s) of a single pixel.

Shortcut. Right-click an image and select Pixel Value from the context menu that pops up.

Checking the values on the flight. Right-click on the image and click on Pixel Value in the ap-
pearing Context Menu. The status bar in the lower left corner of the cell*R / cell*M window dis-
plays the gray value for each color channel at the current mouse cursor position.

Stop. You can terminate the action by opening the respective dialog with a right mouse click.
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Hela stack K

List Gall..

Measurement Results. Mark the pixels whose coordinates and gray values you wish to determine.
A cross in the overlay will denote each pixel marked. The pixel’s X/Y coordinates and the gray value
of each color channel will be listed in the sheet.

i Sheet1 - Fura

% Coord. Y Coord. Fura34d Fura3gd *~

prn prn
1 702 1058 239 364

2 1966 10,48 251 393

3 19,33 19.98 241 335

4 2290 %35 236 ¥’
< o I o T

Pixel Measurement Settings. Select the Show Labels: Numbering check box in the Measure tab
of the Special » Preferences dialog window to numerate each pixel measured. This way the pixels
in the overlay will clearly correspond to the values in the sheet.

10.2 Histogram

Use the command Measure » Histogram to have an image’s gray-value distribution calculated and
plotted in a graph.

Definition. The Histogram is an X/Y diagram in which an image’s gray-value distribution is dis-
played in a graph —i.e., number of pixels per gray value versus the gray value itself.

Results. The histogram will appear as a graph.

o The graph will be written by default into the first slot of Graph View in the Image Man-
ager. To avoid overwriting an existing graph, just click into an empty slot before calcu-
lating the histogram.
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10.3 Line Profiles: Intensity

10.3.1 Horizontal Line Profile

Use the Measure » Intensity Profile » Horizontal command to determine the gray value intensity
along a horizontal line.

How to measure a horizontal intensity profile:

1. Select the Horizontal command. A horizontal red line will appear in the overlay.

2. Position the red line where you wish to measure gray-value intensity, and then left-click.
The line will be drawn into the overlay.

3. If you drag the mouse, another red line will appear and can be placed as wanted.

4. Terminate the command with a right click and confirm yes.
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The line profiles of all color channels will be drawn into a separate graph for each of the lines drawn
into the image overlay.

o This command works currently only on the active frame, not on an entire multi-
dimensional image set.

10.3.2 Vertical Line Profile

Use the Measure » Intensity Profile » Vertical command to determine the gray value intensity
along a vertical line.

Conduct the measurement as with the Horizontal Intensity command.

o This command works currently only on the active frame, not on an entire multi-
dimensional image set.

10.3.3 Arbitrary Line Profile

Use the Measure » Intensity Profile » Arbitrary command to determine the gray value intensity
along a line of arbitrary orientation.

How to measure an arbitrary intensity profile:

1. Select the Arbitrary command.

2. Left-click on the starting position of the line to be drawn.

3. Move the mouse toward the end position. A blue line marks the current length and orien-
tation of the line being drawn. At each end an orthogonal red line is displayed.

4. Left-click on the end position.
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5. Continue with drawing another line or terminate the command with a right click and con-

firm yes.

o This command works currently only on the active frame, not on an entire multi-
dimensional image set.

10.3.4

Average Intensity of Neighboring Pixels

Use this command to set a line of arbitrary orientation and determine the mean gray value intensity
of the neighboring pixels within a certain range on both sides of it.

How to measure an intensity profile of a line of arbitrary orientation and thickness:

1.

Select the Average command. A blue double-cross with a central rectangle appears. In
its center is a pink arrow indicating the direction of the line to be drawn.
Note that the left mouse button toggles between the Resize and the Rotate modes, in-
dicated by the crosshair and the circular arrow, respectively, in one corner.

Roughly place the end of the pink arrow to the designated starting point of the line.

Left-click to activate the Rotate mode and re-orientate the arrow.

Left-click to activate the Resize mode and drag the mouse cursor with the left button
clicked. Adjust the length of the pink arrow as desired. The width of the red rectangle de-
termines the range that will be averaged.

Repeat the rotating and resizing actions until position, length and thickness are as re-
quired.

Right-click to fix this line. A graph with the intensity profile will be created.

Draw another line by continuing with step 2) or terminate the action with the Esc button.
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10.4 Regions of Interest — ROls

10.4.1 General

Regions of Interest or ROIs are parts of images that are defined by the user for subsequent analy-
ses. The ROIs do not become part of the images even if being displayed, that is, they do not
change the data and can be removed at will.

10.4.2 Drawing ROIs

8 Ro

Open the Define ROIs dialog window with the ROI button or via Image » ROI...

I Define ROIs
i Close
| 0
Color:
I | (] Automatic D
Active ROl Toals:

| @@
[ 1RO I

Mero: g < ©
EELLE 1 O

5 g
+ X

Label: By default, i.e., if no name is typed into the box, the ROlIs are labeled "ROIl <consecutive
number>". ROIs with identical names will likewise be numbered consecutively. Labels can be de-
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leted or changed by clicking on the respective commands in the sub-dialog that is opened with the
arrow adjacent to the Label box.

Color. ROIs are colored differently by default. The color can be changed by selection from the pull-
down palette prior to drawing. To change the color of an existing ROl use the respective command
in the sub-dialog that is opened with the arrow adjacent to the Label box.

Active ROIs. This list displays the current ROIs. Clicking on the check box deactivates individual
ROls. Such ROls are not displayed.

Tools. These buttons activate different drawing tools and close the dialog box. ROIs are drawn
with the left mouse button using the first six tools. With the right mouse button the two ends of
polygon-defining lines are connected to generate closed polygons, the drawing command is termi-
nated and the dialog box reopens.

g Polygon

Polygon. Mark the corner points of a polygon; straight lines then connect the corners.

@ Interpolating polygon

Interpolating polygon. Mark the corner points of a polygon and the software automatically gener-
ates a perimeter curve around it.

ﬁl Freehand polygon

Freehand polygon. Delineate the ROl by marking its boundaries by continuously dragging the
MOouse Cursor.

g Ellipse

Ellipse. Mark the center of the ellipse and adjust size and form by dragging the mouse. Additionally
press the Shift key to draw a circle. After releasing the left mouse button the position can be
changed. By clicking anew the shape can be adjusted again. As always, a right mouse click termi-
nates the command.

g Rectangle

Rectangle. A rectangle opens, the size and shape of which can be adjusted by dragging with the
left mouse button.
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g Rotated rectangle

Rotated rectangle. With this command rectangles of arbitrary orientation can be drawn. The left
mouse button toggles between the Move and the Rotate modes, indicated by the crosshair and the
circular arrow, respectively, in one corner. Dragging without a mouse button clicked performs the
moving and rotating. In either mode a left button drag changes size and shape. The best way to
draw is to open a rectangle at any position and rotate it so that the edges are parallel to the desired
position. Then change to Move mode and position the corner opposite to the crosshair to its final
position and finally adjust the size of the rectangle via left button mouse drag.

ﬂ Virtual

Virtual. This button is currently without function.

% From Particle

From Particle. This button is currently without function.

“ Magic wand

Magic wand. See Chapter 9.3, Magic Wand, for details.

‘& Magic wand options

Magic wand options. See Chapter 9.3, Magic Wand Options, for details.

ﬂ Move

Move. This enables to move any ROI highlighted in the "Active ROI" list.

ﬂ Delete

Delete. This removes the ROI highlighted in the "Active ROI" list
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10.4.3 ROI Measurements (2-D)

o If the ROIs are already drawn when any of the measurement commands is called you
have to select the ROIs to be measured by mouse click. If no ROls drawn the start of
any of the commands will automatically open the Define ROIls dialog described in the
previous chapter.

10.4.3.1 Area

Measure » ROl » Area. Use this command to measure the area of a Region of Interest. The line
that defines the border of a ROl is counted as part of it. The results are listed in a sheet that is gen-
erated. The area unit depends on the image calibration; see Chapter 7.1, Image Calibration.

10.4.3.2 Perimeter

Measure » ROl » Perimeter. The area unit depends on the image calibration; see Chapter 7.1,
Image Calibration.

10.4.3.3 Average Intensity

Measure » ROl » Average Intensity. Use this command to determine the average intensity of all
pixels within a Region of Interest (including the pixels that define the border of it). Pixels with 0
intensity are ignored because they result from thresholding (background subtraction) processes
and would skew the result in a meaningless way. This avoids having to be extremely careful when
drawing a ROI close to the border of a cell, for example in a ratio image. The measurement results
are listed in a sheet that is generated.

10.4.3.4 Average Value

Measure » ROI » Average Value. This is the same function as Average Intensity with the excep-
tion that, for example, in ratio images the actual ratio value will be given instead of the scaled dis-
play intensity which depends on the Scaling Factor used in the ratio calculation; see Chapter
10.8.2, Generating a Ratio Sequence.
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10.5 Background Subtraction...

10.5.1 General

Background intensity is unavoidable in wide-field fluorescence spectroscopy. Working in a dark
room can eliminate environmental light, but there will always be a certain amount of excitation light
that reaches the camera. Causes are imperfect filter sets and the reflection of light at interfaces, the
cover slip and the specimen. Background intensity reduces the contrast of the image and conse-
quently background subtraction should be a routine operation.

10.5.2 Subtracting the Image Background

% | Background

Open the Background dialog window with the Background button or via Process » Background
Subtraction...

Background E|

{| Dimensions

Background Subtraction Background Subtraction
() Constant O Constant Select ROIs From Image
| SR o I ey (2) Fura: 3ROIs v
Oror t ol
Select ROL
Otmage ROT1:ROL 1 v

EBackground Subtraction

O constant Select Background Image

(3) Fura v

[e]4 l [ Cancel ] [ Help
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o This function will create a new data set. The original (source) data remain untouched.

Background Settings tab

Constant. This option subtracts a fixed value from all pixel intensities in all images of all channels.
The constant has to be typed into the box or can be changed by using the adjacent scroll arrows.

ROI. The most useful way is to mark a ROI in an image area that contains only background inten-
sity and use the average intensity in this ROl as background value. This value is determined indi-
vidually in each image of each channel.

Image. This option allows subtracting a predetermined background image set from each of the
images of the data set. The background image has to have the same X/Y size and the same num-
ber of channels as the data set to be corrected. It can be either a single image or a time series or Z-
stack as long as it has the same number of frames respectively layers as the data set of interest.

Background E]
Background Settings | Dimensions
Color Channels
Fura340
Fura3ao
Z-layers
Time-Frames
From | 1 =t |6l Slstep |1 |5
[ Ok l [ Cancel ] [ Help

Dimensions tab

In the fields Color Channels, Z-Layers and Time-Frames you can choose the range of images in
the different dimensions for which the analysis shall be performed in case only a subset of the data
is of interest. By default the entire data set is selected. With the option Step in Z-Layers and Time-
Frames you can select every second, third, fourth image and so on to be analyzed.

Copy non-processed data: If this option is NOT selected the newly created data set will contain
only the selected subset of the source data. If the option is selected a copy of the original (source)
data will be created in which the selected subset range is processed (background subtracted) while
the rest is identical to the source data.
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10.6 Intensity Kinetics in Time and Z

le:1 | Kinetics

Open the Kinetics dialog window with the Kinetics button or via Measure » Kinetics...

This tool is used to quantify the changes of fluorescence intensity within ROIs over time or within a
Z-stack and display the results graphically.

Kinetics g]

Intensity Profiles | Dimensions

Parameters

Select ROIs from Image:

(2)Fura : 3 ROIs w
fvailable ROLs

ROI1ROIA

ROIZ:ROIZ
ROI3:ROIS

Sheet Highlight selected ROIs

[ (o] 4 H Cancel H Help

Intensity Profiles tab

In case of a multi-dimensional data set you have to select in the Direction field if the intensity
changes are to be calculated over Time (Kinetics) or as a Z-Profile. For "simple" time series or z-
stacks no choice is necessary. The software recognizes the dimensions automatically.

In the Parameters field you have to select from which data set the ROIs shall be taken and for
which ones the analysis shall be performed. If the option Highlight selected ROls is activated,

those ROls are shown with bold lines. If Sheet is activated, in addition to the graph also the corre-
sponding spreadsheet is generated.

Dimensions tab: See the description in Chapter 10.5, Background Subtraction.
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10.7 DeltaF / F (AF/F) Analysis

10.7.1 General

While few fluorochromes allow the determination of absolute ion concentrations via ratiometric
methods, the majority of ion sensitive dyes only allow the qualitative observation of changes in
concentration. A convenient way to monitor such changes is to relate each image of a time series
to the state at the beginning of the experiment and to analyze dynamic processes with a (AF/F) plot
(pronounced "Delta F over F"). The actual algorithm is rather (AF/F * const1 + const2). Here F refers
to the reference fluorescence intensity (usually the first image or the average of the first couple of
images). AF is the difference between the current intensity and the reference (F .. — F). The ratio is
usually normalized (const1 = const2 = 100 or 1000) so that changes in intensity are given in percent
or tenth of percent, respectively, with a value of 100% or 1000 %/10 at the start.

Why (AF/F)? The advantage of this plot is that it often more clearly displays the change of signal
intensities regardless of the absolute value of the fluorescence. Hence, it makes it easier to com-
pare the variations in weak and bright parts of the sample. A graphical analysis (kinetics) of the raw
data will often clearly show changes in the intensive parts while shifts in dimmer structures, al-
though relatively of the same magnitude, might be overlooked. A side effect of this type of plot,
however, is often the loss of structural details.

10.7.2 Generating a (AF/F) sequence

h: | Delta F/F

Open the Delta F dialog window with the Delta F button or via Measure » DeltaF / F...
Delta Settings tab

Output field. The selection of the options Image and Kinetics determine if a AF/F image sequence
and/or a graph is generated.

Background Subtraction field. The option None is of limited value because the unavoidable
background intensity leads to skewed results when dividing pixel values. If Constant is selected a
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fixed background value is subtracted from all pixel intensities in all images. The constant is set in
the box that is only visible if this option is chosen. ROI: The typical approach to background sub-
traction is to mark a ROI in an image area that contains only background intensity and use the av-
erage intensity in this ROl as background value. This value is determined individually in each image
of each channel. Image: The last option is to subtract a predetermined background image from
each of the images of the data set.

Delta F ]
Delta Settings | Dimensions
Cuakpuk
Images
EBackground Subkraction
Select ROIs from Image
O Mone
) Constant (2) Fura: 3 ROIs L
®RoI Seleck ROT
O1mage ROI1:ROI1 v
Kinetic

Select ROIs from Image:
(2)Fura: 3ROIs v

Available ROIs

ROI1:ROI 1L
ROIZ:ROIZ
ROI3:ROI3

Sheet Highlight selected ROIs

Reference Image

Start: Frame: 1

LIRS

Mumber of frames: 1

Thresholds
Threshald: 0

4

Scaling
Offset: | 1000 % | Scale Factor: | 1000 =

[ Ok l [ Cancel ] [ Help ]

Kinetic field. This field is only active if the Output option Kinetics has been marked. Here you have
to select from which data set the ROIs shall be taken and for which ones the analysis shall be per-
formed. If the option Highlight selected ROIs is activated, those ROIs are shown with bold lines. If
Sheet is activated, in addition to the graph also the corresponding spreadsheet is generated.

Reference image field. Here you determine the range of images that will be averaged and taken as
the reference for the analysis. For example, if the Start frame is set to 1 and Number of frames to
5, the first 5 images of the sequence are intensity averaged. The resulting average image is the F in
AF/F ratios.
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Thresholds field. The thresholding is performed to prevent low-signal areas and background areas
from resulting in areas of pronounced noise in the AF/F sequence (the reason being the division of
small values by other small values). The threshold is set in the respective box. For any pixel with an
intensity value below the threshold the ratio value will be set to -1 (the lowest possible value) so
that it appears black in any standard false-color display.

Output Scaling field. Digital images displayed on computer screens are based on integer numbers
representing intensities. Division of two of such integers generates so-called floating point num-
bers, which cannot be displayed (e.g., (438-316):316=0.3869759). These numbers have to be mul-
tiplied by a Scale Parameter with the positions after the decimal point being clipped. With a factor
of 1000 (which is the default) the above number would give 387. However, in case of a decreasing
signal a negative number, which again cannot be displayed, would result. Thus an offset is added
to each resulting value, usually 1000. A pixel value of 1000 thus stands for 100%. In the example,
1387 results indicating a signal increase of 38.7%.

Dimensions tab:

See the description in Chapter 10.5, Background Subtraction.

10.8 Ratio Analysis

10.8.1 General

This analysis tool is used for ion imaging with dual-excitation or dual-emission fluorochromes, the
fluorescence intensity of which is dependent on the ion concentration. Calcium imaging with the
dual-excitation dye Fura-2 as in the example in this chapter, is probably the most common such
technique. The principle is that the sample is imaged "simultaneously" at two different illumination
wavelengths, typically at 340 nm and 380 nm. "Simultaneously" means here that the two images of
a pair are acquired immediately one after the other. Afterwards a background correction is per-
formed and then the intensity values of the 340 nm image are divided by those of the 380 nm im-
age pixel by pixel. The result is a new image, the ratio image. Any change of intensity in a time
sequence of ratio images is directly correlated to a change in calcium concentration.



cell™ & cell® Software Manual Chapter 10 - Intensity Analyses

10.8.2 Generating a Ratio Sequence

e
! Ratio

Open the Ratio dialog window with the Ratio button or via Measure » Ratio...

Ratio g]
Settings | Dimensions | Calibration
Cutpuk
Image g_! [calibrated
Background Subkraction
(O Mone Select ROIs From Image
(2) Fura: 3ROIs L
O Constant Fura340:
@ rot ROI1:ROIL v
Fura3ai:
ROI1:ROIL R
Kinetic
Select ROIs from Image:
(2)Fura: 3 ROIs -
Available ROLs
ROI1:ROTL
ROIZ:ROIZ
ROI3:ROIZ
sheet Highlight selected ROIs
Threshalds
Fura340: Fura3so:
50 A 50 -
Cubput Scaling
Scale Factar: 1000 i
[ [s]4 l [ Cancel ] [ Help

Ratio Settings tab

Output field: The selection of the options Image, Kinetics and Calibrated determine if a ratio im-
age sequence, a graph or a calcium concentration image sequence are generated. Any assortment
of selections is possible.

Background Subtraction field. The option None is of limited value because the unavoidable
background intensity leads to skewed results when dividing pixel values. If Constant is selected a
fixed background value is subtracted from all pixel intensities in all images of the two channels. The
constant for the two channels (340 nm and 380 nm) is set in the respective boxes Value 1 and
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Value 2. ROI: The typical approach to background subtraction is to mark a ROI in an image area
that contains only background intensity and use the average intensity in this ROl as background
value. This value is determined individually in each image of each channel. The last option is to
subtract a predetermined background image from each of the images of the data set.

Kinetic field. This field is only active if the Output option Kinetics has been marked. Here you have
to select from which data set the ROIs shall be taken and for which the analysis shall be performed.
If the option Highlight selected ROIs is activated, those ROls are shown with bold lines. If Sheet
is activated, in addition to the graph also the corresponding spreadsheet is generated.

Thresholds field. The thresholds for the two bands can be set in the respective boxes. For any
pixel with an intensity value below the threshold the ratio value will be set to 0. The thresholding is
performed to prevent low-signal areas in the original channels from resulting in areas of pro-
nounced noise in the ratio sequence (the reason being the division of small values by other small
values).

Output Scaling field. Digital images displayed on computer screens are based on integer numbers
representing intensities. Division of two of such integers generates so-called floating point num-
bers, which cannot be displayed (e.g., 769 : 845 = 0.9100591). These numbers have to be multi-
plied by a Scale Factor with the positions after the decimal point being clipped. With a factor of
1000 (which is the default) the above number would give 910. With this factor a pixel value above
1000 means signal increase and a smaller value a decrease.

Dimensions tab: See the description in Chapter 10.5, Background Subtraction.
Calibration tab

It is possible to calculate the calcium concentration out of FURA-2 ratio images if the imaging sys-
tem is calibrated following a procedure described in the literature. The calibration parameters have
to be entered into this Properties page. A calibration protocol can be downloaded from the Molecu-
lar Probes homepage: http://www.probes.com/media/pis/mp03008.pdf.

10.9 Spectral Unmixing

10.9.1 Application

Having the genome of more and more species been elucidated, the next challenge of modern biol-
ogy will be to investigate the functional outcome of the genes - the proteins - and their role in
physiology and disease conditions.

The development of computerized microscopes capable of acquiring spectral information, together
with the development of new life cell fluorescence dyes and new color variants of fluorescent pro-
teins opens new possibilities for the modern cell biologist. Multi-dimensional fluorescence micros-
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copy offers the possibility to visualize the spatio-temporal behavior of cellular, sub-cellular, and
molecular structures. In order to simultaneously visualize different structures, labels with different
spectral properties have to be used.

10.9.2 The Problem

A major problem in live cell imaging arises from the use of different fluorochromes with overlapping
spectra in one multi-labeled sample, impairing a number of applications. The considerable overlap
of excitation and emission spectra of different fluorochromes is exemplified by the spectra of en-
hanced green fluorescence protein (€GFP) and enhanced yellow fluorescent protein (eYFP), two
commonly used variants of the green fluorescent protein (Fig. 1).

Even with the use of high quality optical filters it is not satisfactorily possible to separate the spec-
tral information (see Figure 2). The consequence is the excitation and imaging of YFP-labeled struc-
tures with a GFP filter set and vice versa.

eGFP  eYFP
£ UNNEN /- \

emission

1
450 500 550 nm

Figure 1. Absorption and emission spectra of eGFP and eYFP

The Hela cells shown in Figure 2 are transfected with eGFP fused with H2B histone protein and
with eYFP-tubulin fusion protein. Ideally eGFP should be exclusively distributed in the nucleus and
eYFP should be localized in the cytosol. However, it is evident from the images in Figure 2 that
there is a significant contribution of the YFP-labeled structures to the GFP image. Similarly you can
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see a relatively strong, but undesired fluorescence of the nucleus upon YFP-excitation. This phe-
nomenon, known as 'bleed-through’, strongly reduces color resolution and constrains scientific
conclusions.

10.9.3 The Solution

cell”R / cell*M is the first imaging system to implement Spectral Imaging and Linear Unmixing, a
technique adapted from satellite imaging, into widefield fluorescence microscopy. With this tech-
nique it is possible to separate and resort the contribution of different fluorochromes to the total
signal in each color channel.

Figure 2. Images of a GFP/YFP double-labeled sample (GFP fused with H2B histone protein and YFP with tubulin)
taken with YFP dichroic and emitter. Left: GFP exciter, right: YFP exciter.



cell™ & cell® Software Manual Chapter 10 - Intensity Analyses

10.9.4 How Does it Work?

The principles of the method can easily be explained considering the example shown in Figure 2.
To ‘unmix’ the spectral information of the fluorochromes with strongly overlapping emission spec-
tra, it is necessary to determine the spectral properties of the individual fluorochromes under the
same imaging conditions used for the multi-labeled samples: the system has to be calibrated for
each fluorochrome. This is performed by taking reference images of single labeled samples with
these fluorochromes using the same filter set (excitation filters, dichroic mirror and emission filter)
as for the later images of double (or triple) labeled specimen. This means, in our example, that GFP
and YFP reference images have to be taken for both the eGFP (Figure 3) and the eYFP (Figure 4)
samples.

The ratio of the average intensities of labeled structures (ROIs) measured at the two excitation
wavelengths after background correction gives a constant that is specific for each fluorochrome
under the given experimental conditions. These two ratios are the prerequisite for the unmixing of
the images of double-labeled samples.

YFP exciter

dichroic

GFP exciter

*

emitter
observed
K emission
eGFP exci-
tation eGFP
emission
ol
450 500 550 nm

Figure 3, left: spectral match between eGFP fluorescence and optical filters (HQ480/40x, HQ500/20x, Q515LP and
HQ535m); right: reference images of an eGFP sample.

o The reference images have to be taken only once for each fluorochrome in a given ex-
perimental set-up (e.g., filter set, labeling method, cell type).
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Now the system is set to examine samples labeled with both fluorochromes. The intensity meas-
ured at 450-490 nm excitation is composed of fluorescence due to eGFP plus fluorescence due to
eYFP.

YFP exciter dichroic

L. emitter

observed
emission

450 500 550 nm

Figure 4. Left: Spectral match between eYFP fluorescence and optical filters (HQ480/40x, HQ500/20x, Q515LP and
HQ535m); right: reference images of an eYFP sample

10.9.5 Spectral Unmixing with cell*R / cell®M

cell’R / cell®M provides a software module named Unmixing that gives you a powerful tool to
separate information from strongly overlapping emission spectra of two or three fluorochromes.

Spectral unmixing is composed of two steps, Calibration and Unmixing. It is currently possible to
separate two or three different color channels.
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10.9.6

Calibration

The first step is to calibrate the contribution of the fluorochromes to the different color channels.
Depending on the number of different fluorochromes to be analyzed, different reference samples
stained with only one fluorochrome have to be prepared.

) | Calibration

1.

Acquire multi-color reference images of the reference samples under the same imaging
conditions as used later for the experiments with your multi-labeled samples.

o It is possible to use multi-labeled specimen for reference purposes in case mono-
labeled structures are clearly resolved in the images.

For example, the following filters have to be used to unmix CFP and YFP:

CFP exciter (for one color channel)

YFP exciter (for the other color channel)
dual-band dichroic mirror

dual-band emitter

Load the acquired reference images into the image buffer and click on the Calibration
button. This opens the Measure Ratio (Unmixing) dialog window.

Measure Ratio (Unmixing) @

Please define two ROIs, ROI 1 should be an area where the
fFluorochrome is visible, ROI 2 should be a {dark) background area,

Computed ratiofs): 0,52

Select or type label:

GFP v Save ] [ Cancel

Press Define ROIls to open the respective dialog box in order to define two ROls. The
first one has to be within an area where the fluorochrome is visible while the second ROI
is used for background correction. The ROIs are set in the same way as in the Im-
age » Define ROls... menu (Chapter 10.4, Regions of Interest — ROIs).
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4. Afterwards close the Define ROIs window. The ratio of the average intensities within in
the first ROI after background subtraction (see chapter 10.5) is computed automatically
and its value displayed in the dialog box.

5. Label the ratio (e.g., GFP) in the respective box and then saved it using the Save button.
Depending on the number of different fluorochromes the ratios are respectively stored in
the folder cell*R(M)\Unmixing\ratio2 or ratio3.

This procedure has to be repeated for each of the fluorochromes used, that is, for all reference
images.

10.9.7 Unmixing

ﬂ Unmixing

Based on the calibration for the different fluorochromes the ‘unmixing’ of a multi-labeled sample
can be performed.

B

Oukpuk Cukpuk
() One image per charinel (&) single image () One image per charnel
Background Subtraction Background Subtrackion
O Conskank O Constant
Oror fron 3 o 3
Ratio data Ratio data
1. Fluarochrome: | GFP v 1. Fluorochrome: | dapi -
2, Fluorachrome: | yFP w 2. Fluorochrome: | fitc w
3. Fluorochrome: | bxred w
] (oo




cell™ & cell® Software Manual Chapter 10 - Intensity Analyses 219

1. Acquire a multi-color image of a multi-labeled sample using the same filters that were
used for the calibration described above.

2. Load the multi-color image of a multi-labeled sample into the active image buffer. Our
example image is a two-channel image of a GFP-YFP labeled specimen taken with the
GFP and the YFP excitation filters.

3. Press the Unmixing button to open the respective dialog. The cell*R / cell"M Software
automatically recognizes the number of color channels, and the dialog will have two or
three fluorochromes to be selected.

4. Select the ratio data for the different fluorochromes from the respective pick lists.

5. Before performing the linear unmixing, it is additionally necessary to define a ROI for
background correction. To do so press the ROl Background button to open the Define
ROI dialog. Draw a ROI as usual to determine the background intensity.

6. Afterwards close the Define ROIls window.

Figure 5. Images of a GFP/YFP double-labeled sample (GFP fused with H2B histone protein and YFP with tubulin)
taken with GFP exciter, YFP exciter, YFP dichroic and emitter. Left: original, right: after spectral unmixing.
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7. Press the OK button to start the unmixing algorithms. The processed image is automati-
cally loaded into the current destination image buffer.

Acknowledgement. The images were acquired and unmixed with a cell*R Imaging Station and
kindly provided by Dr. Paulo Magalhaes and Prof. Dr. Tullio Pozzan, University of Padua, Italy.

10.9.8 Unmixing of Color Camera Images

It is possible to unmix color images taken with a color camera in a very similar way. System re-
quirements are dual- or triple-band filter sets including dual- or triple-band excitation filters.

Calibration

RGB images of the mono-labeled reference specimen have to be acquired always using the same
filter set. The calibration is identical to the procedure described in steps 2 — 5 in Chapter 10.9.6,
Calibration.

o The unmixing of a color image, which is a three-channel image, requires three sets of
calibration ratio data even if the specimen contains only two labels. In such a case per-
form a dummy calibration as a third measurement by using any of the two reference
images and setting the first ROI (which usually marks a labeled area) in the calibration
step into a background or auto-fluorescence area.

Unmixing

The multi-labeled specimen has to be imaged using the same filter set as used for the calibration.
The unmixing is identical to steps 2 — 11 in Chapter 10.9.7, Unmixing. In the Unmixing dialog win-
dow (step 4) be sure to use the red calibration as input for 1. Fluorochrome, green for the 2.
Fluorochrome and blue for the 3. Fluorochrome.
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10.10 Phase Color Coding and Analysis

10.10.1 Phase Color Coding

This command colors image regions according to the threshold settings.

This command is only available for 8- or 16-bit gray-value images, and for binary images, as well -
not for 24-bit true-color images. It is available for 8-bit false-color images only then if the Allow
operations on false color images check box within the Special » Preferences » Image tab is
selected.

Phase Color Coding is a false-color display of homogeneous gray-value or color areas.

Image areas you wish to have displayed in color must first be defined. You define the image areas
by setting threshold values in the image's histogram. The gray-value, respectively the intensity
range between the threshold values defines a phase.

Objects in gray-value images are defined with the Process » Set Thresholds... command; see
Chapter 8.5, Thresholds and Binarization. Up to eight phases can be selected. For each phase, a
color for display is selected. Gray-value areas not assigned to a phase will remain uncolored.

Objects in true-color images to be displayed in false color are defined with the Process » Set
Color Thresholds... command. Low and up thresholds for the three color parameters are set here,
and depending on whether you are working with the RGB or HSI system, the six thresholds will be
assigned a phase. Thresholds can also be set interactively within the image. To do this, one or
several circular image areas are selected. Their RGB or HSI color values define a phase. For each
phase, a color for display is selected. Image areas not assigned a phase will be displayed in black.

Phase Color Coding will only be applied to the image area within a frame - if a frame has been set.

Phase Color Coding will only be applied to the image areas which lie under the white areas of a
mask — if a mask has been set.

This command generates an 8-bit false-color image in the destination image buffer. All gray-value
areas assigned a phase will be colored according to that phase. A color display of various gray-
value areas enables you to, e.g., have selected image structures accentuated. For true-color im-
ages, you can have objects located in selected color ranges displayed in any false color.
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10.10.2 Phase Analysis

This command evaluates area fractions according to the threshold settings.

This command is only available for 8- or 16-bit gray-value images, and for binary images, as well —
not for 24-bit true-color images. It is available for 8-bit false-color images only then if the Allow
operations on false color images check box within the Special » Preferences » Image tab is
selected.

Phase Analysis is the quantitative analysis of the area(s) of various gray-value ranges — called
phases. Chapter 8.5, Thresholds and Binarization, explains in detail how to set thresholds to define
phases.

The Phase Analysis command generates a measurement sheet that contains the absolute areas of
the gray-value phases, as well as the area of each phase relative distributed by percentage to ei-
ther the total image area or the area within the active frame. Sheet column headers contain phase
name and lower and upper thresholds. The column header’s color corresponds to its respective
phase. Phase analysis of various gray-value ranges will enable you to, e.g. determine the surface
area distributed by percentage of a particular material on a background. Surface area can be calcu-
lated in true-color images using selected color ranges.

Phase Analysis can be applied to other images and/or other areas within the same image, using
the same thresholds. Measurements taken will be appended to the measurement sheet. This inser-
tion will take place automatically as long as you do not open the Set Thresholds... dialog box
between measurements. As soon as you adjust the thresholds, your image analysis program will
generate a new sheet.

10.11 Colocalization

Colocalization

e e

Colocalization toolbar

Colocalization refers to two or more different fluorescent labels being in close proximity in a multi-
labeled specimen - often due to binding to the same sub-cellular structures — resulting in image
areas (pixels) that display intensities (above background) in two or more color channels. This should
not be confused with artifacts due to channel bleed-through as explained in Chapter 10.9, Spectral
Unmixing.
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Colocalization is of great interest in certain applications because it may, for example, indicate that
the different molecules bind to the same target. Thus, qualitative and quantitative analysis is of
importance.

The analysis is available for dual-color images as well as for multi-color images if only the two
channels of interest are being displayed; see Chapter 6.3.2, Multi-Color Images. The procedure
consists of four steps to be executed with the four buttons of the toolbar (from left to right):

1. Thresholding of the first color channel

2. Thresholding of the second color channel

3. Generating a new image that contains the binarized channels of the source image as well
as a channel displaying the colocalization areas

4. Generating a sheet with a statistical analysis of the areas above threshold in the new, bi-
narized image

Thresholding of the first color channel

Click on the Define Threshold 1st button to open the Set Threshold dialog window. Set the bi-
narization threshold for the first color channel. This and thresholding in general is explained in detail
in Chapter 8.5.1, Set Thresholds.

Thresholding of the second color channel
Click on the Define Threshold 2nd button to open the Set Threshold dialog window. Set the bi-
narization threshold for the second color channel.

Binarized image with Colocalization channel

Click on the Colocalization button to generate a new image. It contains the two color channels -
now binarized using the two threshold settings — as well as the binarized colocalization channel.
The latter shows all image areas that have intensities above threshold in both color channels of the
original. Binarization is explained in detail in Chapter 8.5.3, Binarization.

Statistical analysis

Activate the new, binarized image and click on the Create Sheet button to generate a sheet that
lists a statistical analysis of the image areas that are above threshold in the three channels of the
binarized image.
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10.12 The FRET Software Module

FRET (Foerster Resonance Energy Transfer) studies are based on the observation at different
wavelengths, which can be performed conveniently with the fast switching filter wheel U_FFWO
(see the U_-FFWO Instruction Manual for installation and configuration).

A second option is the Dual-View™ Micro-Imager beam-splitting device that allows the simultane-
ous acquisition of two chromatically separated fluorescence images of half frame size. The Micro-
Imager splits the camera field of view into two halves. They cover identical specimen areas but
show different spectral contents. Depending on the alignment, the split may be horizontal or verti-
cal. The cell*M / cell*R software is able to overlay the two image halves into one dual-color image.
To do so, certain settings in the ObsConfig software are necessary; see Chapter 15.9, The Configu-
ration of the Dual-View™ Micro-Imager.

The FRET software add-on to the cellAM and cell*R imaging software provides different analysis
algorithms (Ratio, MicroFRET, FRETN, N...,). See also the original papers:

MicroFRET: D.C. Youvan et al. (1997) Biotechnology 3:1-18
FRETN: G.W. Gordon et al. (1998) Biophysical Journal 74:2702-2713
N..: Z. Xia, Y. Liu (2001) Biophysical Journal 81:2395-2402

FRET*

10.12.1 Image Acquisition

10.12.1.1 Snapshots and Live View with the Dual-View™ Micro-Imager

1:0 - 511:500

|

J

[ Define ] [ Reset ]

Image split
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The Camera Control window features the option Enable image split (as long as the Dual-View™
Micro-Imager is configured in the ObsConfig software as described in Chapter 15.9, The Configura-
tion of the Dual-View™ Micro-Imager.). When this option is enabled, the software will automatically
create a dual-color overlay image out of each image captured by the camera in Snapshot or Live
mode. This is done by splitting the image into two halves and using one half as the first and the
other one as the second channel of the overlay. The color of the channels and whether the split is
done vertically or horizontally depends on the settings in the ObsConfig software.

10.12.1.2 Dual Emission Experiments with the Dual-View™ Micro-Imager

The Experiment Manager treats the acquisition of images through the Dual-View™ Micro-Imager
like any other image acquisition (see Chapter 5.3.3.4, Time-lapse experiments — monochromatic or
in multiple colors) with the difference that it creates an automatic image split and overlay as de-
scribed above. The resulting time-lapse series contain dual-color images of half-frame size.

It is possible to calculate online a ratio image sequence out of the overlay as well as kinetics of
intensity changes, see Chapter 5.3.2.6, Online ratio image, Chapter 5.3.3.6, Experiments with online
analyses, and Chapter 10.8, Ratio Analysis. An Experiment Plan would look like this, for example:

EREREERRENRERER
ERERERERENERREREREDR
*

» —F S0 —b »
|crpyvreEa| Ratio | Kinetic |
100 1,00

10.12.1.3 Dual Emission Experiments with an Observation Filter Wheel

In case an observation filter wheel is used to monitor the two channels, a standard dual-color im-
age acquisition Experiment Plan has to be setup see Chapter 5.3.3.4, Time-lapse experiments —
monochromatic or in multiple colors.

Again it is possible to calculate online a ratio image sequence out of the overlay or a kinetic of in-
tensity changes, see Chapter 5.3.2.6, Online ratio image, Chapter 5.3.3.6, Experiments with online
analyses, and Chapter 10.8, Ratio Analysis. An Experiment Plan would look like this, for example:
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10.12.2 FRET Image Correction Factors

FRET Correction

The analysis of FRET image series becomes complicated by signal bleed through — or excitation
cross talk — that is common for typical donor/acceptor pairs. The excitation characteristics of the
fluorophores usually cause a certain direct excitation of the acceptor when the donor excitation
filter is used and vice versa. This excitation is not caused by energy transfer from one fluorophore
to the other and has to be corrected for before a meaningful quantitative analysis is possible.

Two reference samples are necessary, one labeled exclusively with the donor and one exclusively
with the acceptor. They are used to determine the channel bleed-through. The practical approach
is somewhat similar to that used for spectral unmixing, see Chapter 10.9, Spectral Unmixing. How-
ever, while in the latter dual-excitation images are taken exclusively, here a dual-emission image of
the donor and a dual-excitation image of the acceptor are taken.

10.12.2.1 First correction factor: donor emission

This calibration determines the distribution of the donor emission between the two channels, that
is, the fraction of the donor fluorescence transmits through the acceptor emission filter.

A dual-emission image of the donor-only reference sample has to be acquired using the FRET
equipment — either the observation filter wheel or the Dual-View™ Micro-lImager — as described
above. The following filters have to be used:

— donor exciter

— dual band dichroic mirror

— donor emitter (Fdon channel)

— acceptor emitter (Ffret channel)

&= 1. Activate the donor sample image and click the FRET Correction button.

2. Make sure that the Ffret and Fdon channels are selected correctly on the Donor Sam-
ple tab of the FRET Correction window.

3. Two ROIs have to be defined. The first one has to be within an area where the fluoro-
chrome is visible while the second ROI is used for background correction. To do so
press Define ROIs to open the respective dialog box.
The ROlIs are set in the same way as in the Image » Define ROls... menu (Chapter 10.4,
Regions of Interest — ROIs). Afterwards close the Define ROls window.

4. The ratio of the average intensities within the first ROI after background subtraction (see
chapter 10.5) is computed automatically and its value displayed in the dialog box.
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ERET Correction E|

Donor Sample | Acceptor Sarmple

Ffret Channel {31 CFP-only) FFRET- wfp-em w

(Don. exc., Acc. emiss,)

Fdon Channel 3: CFP-only) FDon - cfp-em v

(Don. exc., Don. emiss.)

Please define 2 ROIs, ROI 1 should be an area where the Fluoro-
chrome is visible, ROI 2 should be a (dark) backaground area.

Defing ROIS ...

Computed Ratios: 0.697060
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Select or bype label:

10.12.2.2 Second correction factor: acceptor excitation

This calibration determines how strongly the donor excitation light excites the acceptor as com-
pared to the acceptor excitation light.

A dual-excitation image of the acceptor-only reference sample has to be acquired using the
FRET equipment — either the observation filter wheel or the Dual-View™ Micro-lmager — as de-
scribed above. The following filters have to be used:

— donor exciter (Ffret channel)

— acceptor exciter (Facc channel)
— dual-band dichroic mirror

— acceptor emitter

5. Continue from step 4. Go to the Acceptor Sample tab, activate the acceptor sample im-
age and make sure that the Ffret and Facc channels are selected correctly.

If a Dual-View™ Micro-Imager is used, only the long wavelength channels of the two
resulting split images are needed for the calculation. This means, the Ffret and Facc
channels have to be selected from different source images.

6. Define two ROls as described above for the first correction factor.

7. The calculated ratios are displayed as Computed Ratios.

8. Enter a name in the Select or type label box and Save the ratios.
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ERET Correction El

Donor Sample | Scceptor Sample

Ffret Channel (21 wfp-only cfp-exc) FFRET - yfp-em

(Dan. exc., Acc, emiss.)

(1: wfp-only yfp-exc) FAce - wfp-em  »

(Acc. exc., Acc. emiss.)

Please define 2 ROIs. ROI 1 should be an area where the fluoro-
chrome is visible, ROI 2 should be a (dark) background area.

Define ROIS ...

Computed Ratios: 0.697060 0.031351

Select or bype label:

A [Save ] [Delete] [ Close l

9. Exit with Close.

10.12.3 FRET Analysis

4| FRET Analysis

The cell®M / cell®R FRET module offers four different methods for the calculation of FRET images.
The simplest is the Ratio Method that does not correct for the channel bleed-through and relies
exclusively on images acquired with the donor excitation filter. It is the only single wavelength exci-
tation method; only images taken with the donor exciter are needed. The three other methods re-
quire images taken with two excitation filters and differ in the way of correction and normalization.
They require single-labeled donor and acceptor samples for calibration.

A click on the FRET Analysis button opens the dialog box.

10.12.3.1 Ratio Method

This method performs the same pixel-by-pixel intensity division to create a ratio image used for ion
ratio imaging, see Chapter 10.8, Ratio Analysis. No channel bleed-through correction is being ap-
plied.

Dual-emission images have to be acquired using Experiment Plans as described in Chapter
10.10.1.2, Dual Emission Experiments with the Dual-View™ Micro-Imager, or Chapter 10.10.1.3,
Dual Emission Experiments with an Observation Filter Wheel.
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The following filters are needed:
— Donor exciter
— Dual band dichroic mirror
— Donor emitter (Fdon channel)
— Acceptor emitter (Ffret channel)

Create a ratio image as follows:

1. Select the dual-emission image.

ﬂ 2. Click on the FRET Analysis button to open the dialog window.

FRET Analysis X

2ettings | Dimensions | Info

Method

(3) Ratio

(O MFRET (Youvan, 1997)
() FRETR {Gardon, 1998)
(O MfFret (xia, 2001)

Correction Factors

Input Images)/Channels Selection

(4: FRET - cfp-gxc) FDon - cf »

{4: FRET - cfp-exc) FFRET - + %

EBackground Subtraction

() Mone Select ROIs From Image
() Constant (4) FRET - cfprexc: 11 %
®ro1 Select ROI
O 1mage ROTL: ROTL v
Threshalds
Threshold 1: Threshold 2:
TR = 1|2

Qubput Scaling
Srale Fackar: 1000 =

[ (o] 4 H Cancel H Help

3. Select the Method Ratio.

4. Make sure that the Fdon and Ffret channels are selected correctly.
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5. The Background Subtraction, Thresholds and Output Scaling functions are described
in Chapter 10.8.2, Generating a Ratio Sequence.

6. Confirmation with OK creates an Ffret/Fdon ratio image.

e Note that such a ratio image itself has little meaning. Only an increase of the ratio by a
decrease of the Fdon signal along with an increase of the Ffret signal may hint at the
occurrence of FRET processes.

10.12.3.2 MicroFRET: Quantification According to Youvan

FRET Analysis X
Settings | Dimensions | Info

Method
O Ratio
@
(O FRETR {Gordon, 1998)
(O MfFret (xia, 2001)

Correction Factors
Ratio & (Fdon): 0.697060

CFPJYFP
Ratio B (Facc): 0.031351

Input ImagesiChannels Selection

(4 FRET - cfp-gxc) FDon - of »
(5: FRET - yfp-gxc) FACC - wf »
{4: FRET - cfp-exc) FFRET -1

Background Subtraction

(O Mone Select ROIs from Image
() Constant (4)FRET - cfp-exc: 11
®Rrot Select ROI
Olmage ROIL:ROI 1 v
Thresholds
Threshold 1: Threshold 2:

Output Scaling
Scale Factor:

[ (o] 4 l [ Cancel ] [ Help ]

The method described by Youvan is a subtractive method. The correction factors generated as
described in Chapter 10.10.4, FRET Image Correction Factors, are used to estimate the contribu-
tion of the channel bleed-through to the signal in the FRET channel (acceptor emission caused by
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donor excitation). The bleed-though contribution is then subtracted from the pixel intensities to
generate a new image where the intensities result exclusively from energy transfer processes.

Images (or image channels) have to be taken with three different filter combinations, all using the
dual band dichroic mirror:

— Donor exciter & donor emitter (Fdon channel)
— Donor exciter & acceptor emitter (Ffret channel)
— Acceptor exciter & acceptor emitter (Facc channel)

10.12.3.3 MicroFRET Experiments with an Observation Filter Wheel

In case an observation filter wheel is used to monitor the two emission wavelengths, a standard
triple-color image acquisition Experiment Plan has to be setup; see Chapter 5.3.3.4, Time-lapse
experiments — monochromatic or in multiple colors. For this it is necessary that three Image Types
with the three different filter combinations be defined in the ObsConfig software. An example is
shown below; see also Chapter 15.3, Definition of Image Types, and Chapter 15.2.6, Configuration
of the Filters of a Filter Wheel.

Image Tvpe Tlurnination Shutter Filker Cube Ohservation  Fluorescence

Excitation Filker Emission Filker Color
CFP 430 CFP v CFRIYFP v || cFra70 v (
CFP=VFR 430 CFP ~ CFRIYFR ~ | | YFP 535 hd y—g/ Ffret

YFP 500 YFP v CFRIYFP v || vFP 538 “[ E

Fdon

As usually it is possible to calculate online kinetics of one or several channels; see Chapter 5.3.3.6,
Experiments with online analyses. An Experiment Plan would look like this, for example:

*

— —
- b m — —— 02 M6
CFP W‘ CFP Y W| Kinetic | VPR [Z0

ERRERERERERERRERRERLRRR
W
-
ERRERRERRERRERREERRE

100% 1,00 5

The image taken with the donor exciter and the acceptor emitter is the FRET channel. However, its
signal is contaminated by two factors:

— One is the donor emission that passes the acceptor emission filter. This contribution is
calculated by multiplying the image taken with the donor exciter and donor emitter with
the first correction factor.

— The other is the acceptor fluorescence caused by direct excitation with the donor excita-
tion light. This contribution is calculated by multiplying the image taken with the acceptor
exciter and acceptor emitter with the second correction factor.
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The algorithm performs the following calculation:
MicroFRET = Ffret — a*Fdon - b*Facc.

Create a "purified" FRET image as follows:

ﬂ 1. Click on the FRET Analysis button to open the dialog window.

2. Select the Method NFRET.

3. Make sure that the Fdon, Facc and Ffret channels are selected correctly.

4. The Background Subtraction, Thresholds and Output Scaling functions are described
in Chapter 10.8.2, Generating a Ratio Sequence.

5. Confirmation with OK creates a corrected FRET image.

10.12.3.4 MicroFRET Experiments with a Dual-View™ Micro-Imager

In case a Dual-View™ Micro-Imager is used to monitor the two emission wavelengths, a dual ac-
quisition Experiment Plan with two split images — one with each excitation filter — has to be setup.
For this it is necessary that two Image Types with the different filter combinations be defined in the
ObsConfig software. An example is shown below; see also Chapter 15.3, Definition of Image Types,
and Chapter 15.2.6, Configuration of the Dual-View™ Micro-Imager.

Image Tvpe Tllurnination Shutker Filker Cube Cbservation  Fluorescence
Exritation Filker Ennission Filkar Calor Fdon & Ffret
CFP split 430 CFP w CFPYFP w || Image Splitker s

YEP split 500 YFP v CFRjYFP + || Image Splitter  ~ ]/

As usually it is possible to calculate online kinetics and ratios of one or both images; see Chapter
5.3.2.6, Online ratio image, Chapter 5.3.3.6, Experiments with online analyses, and Chapter 10.8,
Ratio Analysis. An Experiment Plan would look like this, for example:

L

[.—‘ “
1 G+ B B

[ 4 b 4 [ 4
|CFP splitlﬁ‘ Ratio | Kinetic | VFP splitlﬁl

100 1,005

It is not possible to combine two split images with a multi-color frame with the intention
to generate a four-channel image.
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The image acquired with the acceptor exciter (500 YFP in the example) contains a channel that is
without use for the analysis: the short wavelength channel with the acceptor fluorescence (blue
channel of the second image in the example). The three relevant channels in the FRET Analysis
window have to be selected as follows:

— Fdon: the short wavelength channel of the donor exciter image (blue channel of the first
image in the example)

— Facc: the long wavelength channel of the acceptor exciter image (yellow channel of the
second image in the example)

— Ffret: the long wavelength channel of the donor exciter image (yellow channel of the first
image in the example)

The other steps of the analysis (1, 2, 4 and 5) are the same as described for the observation filter
wheel images in the previous chapter.

10.12.3.5 FRETN: Normalized Quantification According to Gordon

This method is based on the Youvan method described above. It involves the same correction
factors and requires the same image types. The difference is an additional normalization of the
image resulting from the Youvan algorithm for the concentrations of donor and acceptor:

FRETN = MicroFRET / (Fdon * Facc)

Select the Method FRETnN in the FRET Analysis window and continue as described for the Youvan
method.

10.12.3.6 Normalized Quantification According to Xia

This method is similar to the Gordon method but normalizes with the geometric mean of the donor
and acceptor images:

Nfret = MicroFRET / sqrt (Fdon * Facc)

Select the Method N/fret in the FRET Analysis window and continue as described for the Youvan
method.
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11 Graph Display and Graph
Analysis

The previous chapter lined out how changes in intensity, for example in time-lapse experiments,
can be quantified and plotted in graphs. In the following section you will means to modify and fur-
ther analyze these graphs and the underlying data spread sheets.

The Kinetics tool (Chapter 10.6, Intensity Kinetics in Time and Z) and the line profile tools (Chapter
10.3, Line Profiles: Intensity) of cell®R / cell®M generate analytical results of fluorescence intensity
changes in form of graphs (and spread sheets). They can be either exported into other programs
such as MS Excel or further analyzed within cell*R / cell*M.

11.1  Graph DOCUMENTS ....cooiiiiiiiieiee ettt 236
11.2  The Graph WINAOW ....c.ooiecuiiiiieiis e 237
11.2.1  The Cursor: Changing the XY Scaling in the Diagram................. 237
11.2.2 The Cursor: Measuring Individual Graph Points...........ccccccee... 238
11.2.3 The Graphs BUtton Bar..........coooeiiiiieiiiie e 238
11.3  The Graph MENU ... ...coiiiiiiie ettt 242
11.3.1 Markers and Labels............ccoeiiiiiiiiiiiieee e 242
11.3.2 Protecting and Deleting a Graph.......cccccevveviiiiiieiniiicnciiiieeeeeen 245
11.8.83 Graph Information... ......ccceeeiiiiiiiiiiiiieiiiieeeeeeee e 245

11.8.4 Sheet ..o 246
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o Several functions do not work on Kinetics graphs.

11.1  Graph Documents

For displaying and processing one-dimensional data, cell*R / cellM contains an additional docu-
ment format, the graph document. Similar to images, newly generated Graph documents or those
loaded from an archive are accessible in the Graph page of the Image Manager that automatically
opens if a Graph window is activated.

Image Manager

(33 @ [2] [ [s]

Gc Fx  Dest Stc2  Mask

i

Histagram of Dapi. ...

s

bRt et hibny

e

Kinetics of chip_ow... 2

Bt | [l 6. [AdGm. |5 M.

The elements Src (Source), Dest (Destination) and Src2 (Source 2) of the Operands Box now refer
to the corresponding graph buffer. The destination graph buffer is used for all graph-operating
functions creating a new graph. The Source2 graph buffer is needed for graph operations with two
source graphs, for example, for the addition of two graphs. The Graph page closes again if the
Viewport or the List or Gallery pages of the Image Manager are activated.

Graph windows are located in the document area - just like the Viewport. They contain special
buttons for setting the graph display; see Chapter 11.2.3, The Graphs Button Bar.
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11.2 The Graph Window

Graphs (1), Kinetics of Ratio, Image Fura [2]
o e 15 31“41« QD-C oyo1E :gDvILl,Iellowﬂ

Ralo Kirnetics of Ratic, Image Fura [2]
Ratio , 7= 0,00 ym

ROI2
ROI3

nkenslly

Wi 39,003 5, ¥: 1,01e+003 , 9,808+002 , 9,93e-+002 , 1,02e-+003 Ratio

Upon start of the cell*R / cell®M Imaging Software the Graph window is minimized and located in
the bottom left corner of the document area. If not minimized it might be hidden behind the View-
port but will be brought to the front if the Graph tab of the Image Manager is activated. To display
a graph select the corresponding graph buffer.

If the mouse cursor is moved over the diagram area it changes into a horizontal double-headed
arrow on top of a vertical line.

11.2.1  The Cursor: Changing the XY Scaling in the Diagram

$

Upon a left mouse click on the graph diagram the cursor changes its shape to a double-arrow
cross. Moving the cursor up and down stretches or compresses the Y scaling. Moving it right or left
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stretches or compresses the X scaling. Alternatively, the scaling buttons of the Graphs button bar
can be used; this is explained in detail in Chapter 11.2.3, The Graphs Button Bar.

Upon zooming in, scroll bars appear at the right side and at the bottom of the diagram to shift the
graph along the axes without a change in the axis scale.

11.2.2 The Cursor: Measuring Individual Graph Points

If the mouse cursor is located over the diagram’s area, the X value of the current cursor position
and the corresponding Y value (where the black horizontal line crosses the curve) are given in the
status bar of the graph document (at the bottom left corner).

|'\-
Ix: 39,003 5, ¥: 1,01e+003 ,

11.2.3 The Graphs Button Bar

The button bar at the top of the graph document is used to change the displayed X and Y range
and to edit graph overlays. The different buttons are arranged in functional groups.

11.2.3.1  Scaling the X axis

E Zoom In

Click the Zoom In button to decrease the displayed X range, i.e., to stretch the graph in the X di-
rection.
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E Zoom Out

Click the Zoom Out button to increase the displayed X range, i.e., to compress the graph in the X
direction.

Scale X

Click the Scale X button to enlarge any X segment of the displayed graph to full axis size. Mark the
left and the right margins by mouse click. The first click generates a blue vertical line, the second a
green one. Both can be moved via mouse drag. While doing so, the current X position of the line is
continuously shown on the status bar. Right-click to accept the new scale. The two margins remain
visible as long as the button remains pressed; once the button is depressed they are deleted.

11.23.2 Y Scale

|I‘ Zoom Up

Click the Zoom Up button to decrease the displayed Y range, i.e., to stretch the graph in the Y
direction.

|I‘ Zoom Down

Click the Zoom Down button to increase the displayed Y range, i.e., to compress the graph in the
Y direction.

Scale Y

Click the Scale Y button to enlarge any X segment of the displayed graph to full axis size. Mark the
left and the right margins by mouse click. The first click generates a blue vertical line, the second a
green one. Both can be moved via mouse drag. While doing so, the current X position of the line is
continuously shown on the status bar. Right-click to accept the new scale. The two margins remain
visible as long as the button remains pressed; once the button is depressed they are deleted.

[&] max. Y

Click the Max. Y button to autoscale the Y range from the minimum to the maximum Y value of the
displayed graph segment.
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Auto. Max Y

This is the dynamic analog of Max. Y: The scaling is automatically updated when moving the graph
in the X direction by using the scroll bar at the bottom of the graph document.

11.2.3.3  Further zooming and scaling functions

@ Define Display Area

Click the Define Display Area button to zoom up a rectangular area of the current graph docu-
ment. Clicking the button opens the Define Display Area dialog box. Click the Set button to draw
a rectangle into the graph. Use the mouse to resize and move the rectangle to the interesting part
of the graph. Click the right mouse button to return to the Define Display Area dialog box. Alterna-
tively, you may enter the absolute X and Y-limits of the graph area into the fields of the dialog box.
Click the OK button to zoom the selected area of the graph to the whole graph window.

Default Size

Click the Default Size button to rescale the graph so that the total range is visible.

Log X

Click the Log X button to change the X-axis scale type from linear to logarithmic.

LogyY

Click the Log Y button to change the Y-axis scale type from linear to logarithmic.

11.2.3.4 Diverse functions

Delete All Labels

Click the Delete All Labels button to delete all text labels in the current graph.

Window Mode

The Window Mode button is currently without function.
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=1 Show Legend

Click the Show Legend button to display legends of the individual curves in a graph containing the
kinetics of more than one image ROI or more than one line profile.

11.2.3.5 Overlay Functions

o These functions do not work on Kinetics graphs.

The remaining elements of the button bar refer to overlay functions. The display of more than one
curve in a graph document is termed overlay. Use the Graph Analysis » Overlay Selection...
command to create such an overlay graph.

W Overlay Mode

If the Overlay Mode switch is set, the scroll bars and all buttons of the button bar concerning the
axis scale apply only to the selected curve. These functions can now be used for alignment of the
overlaid curve relative to the original graph for purposes of comparison. For example, this function
may be useful in cases where one of the graphs has an X or Y offset.

[iblue: 7] Line profie 1 of =] Qyerlay

Use the Overlay list to select one of the overlaid curves. The original graph cannot be activated
because it always remains fixed with respect to the X and Y-axes. The active overlay is affected by
the overlay operations explained below.

i

Click the Fit button to adjust the Y scale of the overlay to the scale of the actual graph. This func-
tion is a quick and convenient method for the direct comparison of two graphs whose Y ranges are
very different. The highest Y value of the overlay is adjusted to the maximum Y value of the graph in
the displayed X range. You should keep in mind, that after clicking this button the labels of the Y-
axis refer only to the actual graph and no longer refer to the overlay.
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11.3 The Graph Menu

The Graph menu contains special commands for graph processing; they do not work on images.
Theses commands are described in the following.

11.3.1 Markers and Labels

11.3.1.1 Display markers

Use Graph » Markers and Labels » Display Markers to display the markers set during image
acquisition in the graph document.

11.3.1.2 Set labels...

Use the Graph » Markers and labels » Set Labels... command to add and position annotations to
the active graph. Alternatively, right click within a graph document to open the context menu and
then click Set Labels....

Show Markers in Graph

Set Labels...

Graph Information

Convert ko Sheet

Define Context Meny, ..
Graph context menu

It is convenient to change the display of the graph so that the interesting region of the
graph is completely displayed in the graph document before you use this command.

Label text. In the Label text field enter the text for the annotations. The amount of text is limited to
116 signs. Click the Set button to position the text frame in the graph document. Note that the text
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frame can only be positioned in the visible part of the graph. You cannot scroll or zoom the graph
while you set the labels.

Anchor text. Check this box to position the text frame at a fixed position of the graph document.
The position of the text frame in the graph area thus remains fixed upon changing the zoom factor
or scaling.

Label text:

Anchaor ket Centered text

Data pazition

[ Cancel ] [ Help ]

Clear the Anchor text check box to position the text frame at a certain XY position of the graph.
When you shift the graph or change the zoom factor the position of the text frame inside the graph
area will change accordingly.

Centered text. Use the Centered text check box to format the text in the text frame. When the
dialog box is opened the text frame is indicated in the graph document by a rectangle.

Clear the Centered text check box to left-align the text in the text frame. Select the check box to
center the text.

Data position. Use the features in this group to set a label to a defined X position of the graph. The
options are disabled if the Anchor text position is deselected.

Position. Set the X position where the label shall be placed at in this field. The minimal and maxi-
mal X values that can be entered are the left and right margins of the current graph display.

Set and Align. Click the Set button to set the X position interactively. A dashed line connects the
text frame (which is initially placed in the center) and the X position of the cursor. Left-click to con-
firm the setting and return to the Set Labels window. The new X value has been transferred into the
Position field. To fix the label at the new position click the Align button. To move the text frame in
the vertical direction click the Set button next to the Label text field (not the Set button of the Data
position group).

Draw line. Select the Draw line check box to connect the text frame and the X position on the X-
axis by a line.

Draw arrow. Select the Draw arrow check box to connect the text frame and the X position on the
X-axis by an arrow.
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11.3.1.3  Modify...

Use the Graph » Markers and labels » Modify... command to change the text and/or the position
of the previously set annotations in the active graph. Alternatively, right-click within a graph docu-
ment to open the context menu and then click Modify Labels....

Labels. Select the label to be modified from the pick list in the Labels field.
Delete. Use this command to delete the label currently listed in the Labels field.

Delete all. Click this command to delete all labels in the active graph. Alternatively, select Data
Analysis » Markers and Labels » Delete All from the file menu, or use the respective command in
the context menu of the graph document.

Label text. In the Label text field enter the new text for the annotations. The amount of text is lim-
ited to 116 signs. Click the Set button to position the text frame in the graph document.

Mo dify Labels X
Labels:
Delete &l
Label text:
Trigger et
Anchor texst Lentered text
Relative position
[ Ok | [ Cancel ] [ Help ]

Anchor text, Centered text, and the commands within the Relative position field have the same
function as described above for Set Labels... (see chapter 11.3.1.2).

11.3.1.4 Copy

Use Graph » Markers and Labels » Copy command to copy the labels of the active graph docu-
ment into the subsequent graph document (or the graph set as dest buffer) in the Operands Box
of the Image Manager.

This tool is very useful to set labels in a series of graphs derived from one experiment at the same
position.

o The labels can only be copied if the graph in the dest buffer has the same X-axis scal-
ing as the graph of the src buffer.
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o This command is deactivated for graphs resulting from a Kinetics calculation.

11.3.2 Protecting and Deleting a Graph

Use Graph Analysis » Protect Graph or click on the Protect Graph button in the Standard toolbar
to protect the graph from being deleted or overwritten unintentionally.

Use Graph Analysis » Delete Graph to delete the currently displayed graph document. Alterna-
tively, an active graph document can be deleted by pressing the Del key.

11.3.3 Graph Information...

Use this dialog box to change the name of the active graph buffer, to enter a graph comment,
and/or to have graph information displayed.

How to open the Graph Information dialog box:

e Double-click on any graph buffer within the Image Manager to view information on that graph.

¢ <Alt+Return> keys: use these keys to view information on the active graph.

o Image Manager context menu: right-click on any graph buffer to open the corresponding con-
text menu and then click on Graph Information... to see the information of this particular graph
without making it the active one (displaying it).

e Graph Document context menu: right-click on the graph window to open the corresponding
context menu and then click on Graph Information...

11.3.3.1 The General tab

This tab contains general Graph information.

Title displays the title of the graph document. The title can be changed. It can be up to 39 charac-
ters long.

Date displays the date the graph was created.
Time displays the time the graph was created.

Comment. Use this field to add any comments concerning the graph. The comment can be up to
114 characters long.
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X-axis and Y-axis: Displays the title (legend) and the unit of the X and Y-axis, respectively. The
parameters can be changed. The changes will be displayed in the graph document.

All this graph information can be changed by the user and will be stored along with the graph.

Graph Information E|
General
Title: Finetics of Ratio, Image Fura [2 Graph data
Date; 20,0208 Graph start: 19,003 =
i - Graph end: 73,003 s
fioe 1388 Charinel width: 10 ¢
User Graph range: EDO =
Camment: Components: 4
Channels: E1
Data type:
Wersion: 4.15.1653
# aniz Y amis
Title: Time Title: Inkensity
Unit: 3 Unit: R atio
[ 0k l [ Cancel ] [ Help ]

Graph data field. Here information about the active graph parameters is displayed.

Graph start displays the start point together with the unit of the abscissa.

Graph end displays the end point together with the unit of the abscissa.

Channel width displays the interval and unit between single data points on the X coordinate.
Graph range displays the total range and unit of the abscissa.

Components gives the number of graphs displayed in the graph document.

Channels displays the number of data points on the X coordinate.

11.3.4 Sheet

Image analysis done with the analysis tools from the Image Analysis menu automatically creates a
graph but no data sheet. To create data sheets for graphs, use Graph » Convert to » Sheet. Data
sheets can be edited with the commands in the Sheet context menu (to be opened via right-click).
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i Sheet9 - Graph, GB[2]: Kinetics of Ratio, Image Fura [2] =13
N

Cuk Chrl+3
Ratin]  copy Chrl+C

Delete Delete

Edit Column Header...
Sort Ascending

Sort Descending
Create Copy
Autofilter

el

Create Graph...

Define Statistics. ..
Skatistics

Define Context Menu,..

11.3.4.1 Edit Column Header

Use Sheet context menu » Edit Column Header... to change the title/header of the highlighted
sheet column. The header is limited to 31 characters.

Edit Column Header

Lolurmn Header:

Help

11.3.4.2 Sort Ascending

Use Sheet context menu » Sort Ascending to rearrange the data in the highlighted column(s) in an
ascending order.

11.3.4.3 Sort Descending

Use Sheet context menu » Sort Descending to rearrange the data in the highlighted column(s) in a
descending order.

11.3.4.4 Create Copy

Use Sheet context menu » Create Copy to create a copy of the currently displayed sheet.

11.3.4.5 Autofilter

Use Sheet context menu » Autofilter to activate the autofilter function. If activated, the Autofilter
command in the menu shows a check mark, and the column headers in the sheet feature pull down
menus. You can select some predefined functions from a pull down menu to filter the data within
the respective column, e.g., select Top 10 to display the 10 sheet cells with the highest value.
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Sheet9 - Graph, GB[2]: Kinetics of Ratio, Image Fura [2] =13
Time = ROIZ -l ROI4 || ROIE | ”
s Ratio Ratio
1 19,003 |Empty 718,23 598,06
7 20,003 | Mot empty 717 71 595,59
3 21,003 |ser defined... 716,93 599,25
4 22 003 QSI%E?na 717,18 £98,70
5 23,003 [\iot Sigma 716,23 B35 52
B 24003 | ot 2°Sigma 715,10 596 53 B
7 a5 NN Stnng TIE A2 [t [ )
= Top 10...

User defined... Use this command to define the lower and upper end of an interval for the rows to
be displayed. If Exclude rows is checked, the rows within the interval will be excluded.

User, defined: ROI 2

Display rows with walues in intersal:
Lower end Upper end
= o C |
& |5 [roosa |7
Hel
[ Exclude rows —s

String... Use this command to define a string to display only those rows that contain this string. If
Exclude rows is checked, the rows containing the string will be excluded. For example, if
"40?7?,?7?" is set as a string for the sheet above, only entries higher than 4000 will be listed.

Search String: ROI 2

Dizplay only rows containing
—
[ Exclude raws

Usge ? to represent any single character
Use * to represent any series of characters

11.3.4.6 Create Graph...

The command Sheet context menu » Create Graph... is active only if a column of the sheet is acti-
vated (via click on the header). Use this command to make a new graph from the active column.
From the dialog box you can edit the Title, and select the X and Y-axis for the newly created
graph.
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Create Graph, from Sheet g|
Title: : Kinetics of Ratio, Image Fura [2
X axis
C |
S ==l
Uit 5 b

Start walue: |19

Increment: |1

Y aiz
Title: ROI2

Urit: Fiatio

11.3.4.7 Convert to Sheet

Use Graph Analysis » Convert to Sheet to convert the coordinates of the displayed graph into a
new datasheet.

11.3.4.8 cell*R / cell®*M and Excel

ExcelDDE  [¥]

ExcelDDE toolbar

Use the Start Excel button (left) to open the spreadsheet program Excel, if it is installed on your
Imaging computer.

Use the New Workbook button (center) to open a new workbook in Excel. This command can only
be performed if Excel has already been started. Otherwise an error message will be displayed.

Use the Transfer Data button (center) to transfer the data from the data sheet to the Excel work-
sheet.
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The database is an integral part of the cell*R / cell®M Imaging Software. It allows an organized stor-
age of all acquired images, created graphs and documents like sheets, diagrams and texts. The
design of the database facilitates an easy and fast access to even a huge data stock. The database

is fully network-compatible and can be used simultaneously by different users.
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12.1 Directories for Data Storage

How to specify the directories for data storage:

1. Select Special » Preferences... from the menu bar or alternatively press <F8>.

2. Select the tab Database.

Preferences g]
Image | Yiew File | Measure| Module|| Graph | Database | Repart
Thumbnail display size: Small v

Database defaults

Thurmnbnail creation size: | Small v

Save images

File type: LCompression:  Mone

tif v Force TIF type for documents

Locations
Databaze files: D:Marchive E]
Lf;?g:;w SELE D:varchivehTmpStorageDin E]
Backup volume capacity: 500 | M
Fec
[ &uto Record Name
Format;
[ Ok ] [ Cancel ] [ Help ]

3. Specify a default directory to store all database files in the Database files box. Make
sure to use a large partition of the hard disk for storage; the D partition should be used in
an Olympus Soft Imaging Solutions imaging PC.

4. Specify a directory in the Temporary storage directory box. This directory is used as a
temporary storage during data storage and archiving of the database and should like-
wise be on a large partition of the hard disk.

5. Check the preset Backup volume capacity.
— When archiving the database on a CD, adjust backup volume capacity in accordance
to the size of the volume, e.g., 600.
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— When the system administrator stores the network database, the value for the backup
volume capacity should be set to ‘0’.

o On principle it is possible to use network databases or write directly to CD. However,
this is strongly not recommended, problems might occur at least in case of large and
complex experiments.

12.2 Open Database...

cell*R / cell*M offers a number of possibilities for opening an already existing database. Select
Open Database... in the File, Acquisition or Database menus or in the pull-down pick list of the
Open button of the standard toolbar to open the Open Database dialog. Navigate to the desired
database file (*.apl) and press Open. A recently used database can also be selected from the file
list at the end of the Database menu.

Open Database E@
Look jn: | £ FRET “Q F = E-
|)45vaaZF _DocumentFiles
YFRET.apl
Files of type: | Database [* apl] -

Mark the Exclusive control box to set or change for example the password for the database, to
change the database settings, to execute a SQL statement or to delete a database. Furthermore
the commands Delete Database..., Execute SQL..., Recreate Thumbnail Image, Change Data-
base Password..., and Settings... in the Database » Administration menu become enabled.

To close an open database select Database » Close Database or press the standard MS Window
Close button.
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The Exclusive option is only possible if the database is currently not opened by an-
other user. On the other hand, if the database is opened in the Exclusive mode, no
other user has access to it.

12.3 New Database...

A database assistant makes it easy to create a new database.

Select Finish' to et the database assistant create a database with the
following settings:

Database name:

Databasze files [* apl);

| D:\archivehexample

| [ Browsze...

Mext >

[ <Back || Finish |[ Cancel ]

1. Select New Database... in the Database » Administration menu to open the New Da-
tabase... dialog box.

2. Write the name of the new database into the Database name field. The database will be
created by default in the directory specified in the preferences, see Chapter 12.1, Direc-
tories for Data Storage. To select a different directory press the Browse... button.

3. Click Next > and then Finish if you accept the settings displayed in the dialog.
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12.4 The Database Features

o Images acquired in experiments via the Experiment Manager- unlike snapshots or live
images — are stored automatically in the active database in a folder carrying the name
of the experiment. Likewise stored are online analysis results — if the store option is se-
lected. For details, see Chapter 5.4.3. Data Storage.

12.4.1 General Remarks

When looking at the database window you will recognize features that you are familiar with: but-
tons, thumbnails and, last not least, icons in a tree structure somewhat similar to the MS Windows
Explorer software. However, you will not find the data files on the computer or the storage medium
under the same names as displayed in the database window. Internally the data are stored as files
with cryptic default names created by the cell*R / cell*M software. For example, an image time
series resulting from an experiment called CFP-YFP in the Experiment Plan, acquired by the system
and stored in a database named FRET, for example, will be found on the hard disk as a file named
something like 4E55H85C_F00000021.tif in the folder .\FRET\4E55H85C_DocumentFiles. Easy and
intuitive access to the image and analysis data is only possible from within the cell*R / cell*M
software. The "cryptic" file names are listed if the option Table View for the database window is
selected in the Database » View » Choose View... dialog, see Chapter 12.4.3, Adjusting the Data-
base Window.

Database folder

A database folder is a term for a folder in the tree structure of the cell*R / cellAM database. This
folder is no file folder on the level of the system software and thus is only visible in the data base
window but not in a file manager program, like MS Windows Explorer. Database folders are created
automatically when an Experiment Plan is executed and carry the name of the experiment. They
can also be created via Database » Insert » Experiment....

Database fields

The database fields are entries in the table of parameters and information listed for the active
document in the Form view of the database window, see next chapter.
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Organizational fields

An organizational field is a database field associated to a database folder and thus to all data re-
cords within that database folder as well. The organizational field has the same value for all records
created in a respective database folder.

The cell*R / cell*M template database has the predefined organizational fields Experiment Name,
Experiment Comment, Date and Time. They are automatically stored with each data record.

Organizational ID

This is the name of the database folder, i.e., the Experiment Name. The other Organizational fields
cannot be chosen as Organizational ID.

12.4.2 The Database Window

After opening or creation of a new database, the database window will be displayed. The title bar
shows the name of the database: *.apl. Important database commands are accessible via the But-
ton bar of the database window. The lower border displays the Status bar with information about
the active folder or file. By default the database window is displayed in Full view subdivided into
four areas: Preview, Tree view, Gallery, and Form. The size of the four areas can be freely ad-
justed by mouse dragging of the borders. The mouse cursor, when on top of an area border,
changes from the typical arrow to a double-arrow crossed by two bars to indicate the dragging
possibility.

& tricolor.apl
@ - o EEE ME &8

kidney_008 kidney © | | Dapi Fite T: R@ |eP9pi' Fitc, TxR... €
dz tricolar, apl A
@ (3 kidney_00z
: g ::::Y‘ggi Field name Field value
i Experiment Mame kidney_005
Date 31.05,2005
Tirne 14:57

Experiment Cornment

Form view

tricolor | kidney_008 Sel: 1 (0 kB)
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Preview. This area in the upper left corner shows a thumbnail of the currently active item in the
Tree view.

Tree view. The Tree view in the lower left corner resembles the structure known from file man-
agement programs like Windows Explorer. However, only the database "folder" itself, called <data-
base name>.apl, in the top-most level, appears as such in a standard file manager program. The
main entries, that is, the folders in the second level in the hierarchy, represent the experiments and
are usually created automatically by the Experiment Manager. They contain the image data, ex-

periment plans, graphs and other documents. Double-click an entry to expand or to reduce the
active level.

Gallery. If an experiment folder is the active entry in the Tree view, the Gallery field on top right
displays thumbnails of the items contained.

Form. The Form view in the lower right part displays a table with information details of the currently
active item; in case of image data, for example, all relevant acquisition parameters are listed.

12.4.3 Adjusting the Database Window

Arrange fields...

Use the command Arrange fields... in the Database » View menu or the context menu (the pick-

list that appears upon a right-click on the database window) to open the Arrange fields dialog
window.

Arrange Fields g|
Wigmd T upe: Aywailable: LCurrent: +
=198, Info window Audio File P
(31 Experiment Calibration Uit Sample / Preparation
g Document Files Size Document Creation Date
Graph Document Insertion D ate Document Creation Time
Docurnent Documnent Insertion Time Image Dimension v
Data Document Modification D Color Channelz
L - Documnent Modification Ti Z-Layers
Fom V'e"\.‘ Experiment Comrment Time Frames Set ta all of this b
[_3 Experiment ; ; etioalal s ype
Experiment M arne X-Size
el File Mame T-Size Get Dref ault
Graph Frames Bitz per Pixel =
zy Graph Comment Birning
gotcument Height Exposure _Time
ata D Z-5tep Width
able Wiew Image Comment Markers
& Print Image Marme v Regions OF Interest [ROlz »
5 Query by Example < ¥ < ¥
i
+- [ Inzert

The dialog allows to add, to remove, or to change the entries listed in
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¢ the information table of the Form area

¢ the Info Window

¢ the optional Table View display of the database window

¢ the Query by Example dialog box

¢ the Insert dialog box

in the currently active database.

View » Type lists all available views and data types, Current lists all possible parameters for the

active view or data types and Available lists all further parameters that are not yet in the Current
list.

To add a new entry to the Current list, select it from the Available list and then press the Add>>
button. To remove an entry from the Current list select it and press <<Remove.

The order in which the entries are displayed can easily be changed. To do so select the entry that is
to be moved and click the Up or Down arrow button.

Press Get Default to use the default settings for the different views and data types.

To use the same settings for a specific data type for all views, press Set to all of this type.

o In the Info Window the number of data fields is limited to seven. Therefore the Add>>
button becomes disabled when seven entries are listed. To add a new field it would be
necessary to remove another entry first.

Choose View...

Use the command Choose View... in the Database » View menu or the context menu (the pick-list
that appears upon a right-click on the database window) to open the Choose View dialog window.

Choose View EI
(&) Gallery View
() Horizontal Gallery View
O Namow Yiew
() Stucture Stip
() Gallery Strip

Six different views are available for the database window. By default the database window opens
with the Full View » Gallery View — the one shown in the previous chapter. Two other alternative
displays for the Full View can be selected.
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In the Table View the thumbnails of the Gallery is converted into a table with icons instead of
thumbnails. Additionally it lists the "cryptic" default names under which the files are stored and
appear in disk management programs, see Chapter 12.4.1, General Remarks.

When the Horizontal Gallery View is selected, the gallery is displayed as a scrollable single row of
thumbnails. Thus more space remains for the Form view.

In the Narrow View the Form view is removed and the Gallery displayed as a single column. The
database window is attached to the Image Manager and Viewport Manager windows but can be
moved freely at will.

[o|=] - (o] -
Full View, Narrow View

The Full View and Narrow View buttons allow toggling between these two view options.
In the Structure Strip mode only the Tree view and the Preview are displayed.

Select Gallery Strip to reduce the database window to the Gallery view in form of a single column
of thumbnails.

& Update Views

Select the command Database » View » Update Views, use the key <F5>, or press the Update
Views button in the button bar of the database window to refresh the display of the database win-
dow.

e Info; ﬂ, @ Pin

Info Window. Select the command Database » View » Info Window or click on the Info symbol on
the bottom right corner of a thumbnail in the Gallery to open the Info Window.

Info
4=

Record Hame: Drapi, Fite, TxRed,
Sample / Preparation:
Document Creation ... 31.05.2005

Document Creation ... 14:57

Image Type: Fulti Dimengion
Binning: 1
File Size: 8583474

The information displayed can be defined in the dialog Arrange fields » Info Window. Usually the
window closes if a different icon or document is activated. To prevent this press the Pin button in
the Info Window, the button turns into a counter-sunk pin. Now the window remains open showing
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the information about the active item. The Info Window can be closed as usual with the Close but-
ton.

12.5 Working with the Database

12.5.1 Loading Documents

Any document contained in a database can simply be loaded by a double-click on the thumbnail in
the Gallery. However, this does not work for the icons in the Tree view. Image data and graphs
can also be loaded by drag&drop into slots of the Viewport Manager or Graph Manager.

12.5.2 Inserting Documents

Images acquired via the Experiment Manager and the Experiment Plans used for the acquisition are
stored automatically in the database. Snapshots, processed images and analyses, however, are
not stored automatically. To store these documents within the database the Insert function has to
be used. The Save as... function leads to data export.

i Insert Image

The active image set can be inserted into the active folder of the database with the Insert Image
button. Alternatively, an image can be inserted by dragging it from the Image Manager into a data-
base folder. More than one image can be selected by using <Shift> + click or <Ctrl> + click. A
dialog box opens where the Record Name and Sample / Preparation can be given and a Com-
ment can be added. Upon clicking Insert the image set will be moved from the temporary folder to
the database.

For all other types of data the menu Database » Insert has to be used.
Database » Insert » Experiment...

This command creates a new Database folder in the active database.
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Database » Insert » Image...
This has the same function as the Insert Image button.
Database » Insert » Images...

This command allows inserting a series of images from the Image Manager into the currently
opened database folder. Select the images to be added from the Insert Images window that
opens. If the option Always is selected in the Prompt for data input field, the insert dialog will
appear every time before an image is inserted.

Insert Images g|
[J..1. Dapi, Fite:, TsRed, aK.
[] 2. Drapi. Fite, TxRed unmized
Select all
Unzelect All
Frompt for data inpuk
® aways O Once

Database » Insert » Image File...
This command imports stored image files, for example from the hard disk, into the database.
Database » Insert » Data...

This command opens a dialog box that enables the user to add a comment to the database folder.
This comment is not an independent document but is an entry in the Field table.

Database » Insert » Documents...

This command inserts Graphs, Sheets or Text documents/Macros into a database folder. Select
the documents to be added from the Insert Document window.

Insert Documents g|
Sheet: Sheetd - Fura 1] 4
Sheet: Sheet2 - Graph, GB[2]: Kinetics of Fura Fura
Sheet: Sheetl - Graph, GB[1]: Kinetics of Fura Fura
Graph(1]: Kinetics of Fura
Graph[2]: Kinetics of Fura Gelect Al

Unzelect Al

] Prompt for file narmes
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Database » Insert » Document File...

The command allows to import stored document files, e.g. from MSWord, MSExcel, etc., into a
database folder.

12.5.3 Query

al Query (by Example...)

Database » Query by Example...

The database architecture of cell*R / cell*M allows to search the contents of a database for docu-
ments that match certain criteria. Click the Query button or use Database » Query by Example...
to open the search mask. The fields in the dialog box are listed by default but can be changed as
explained in the next Chapter 12.5.4, Administration: Defining Organizational and Database Fields.

Query by Example g|
Fields 1-6
Record Mame
pietiane
Cancel
Image Type
Bits per Pixel
#-Resolution
*-Resolution
Data type Select Al
[_A Expetiment
(& Image Unselect Al
Graph
Dacurent
Data

Type in search parameters and click Search. The results will be listed in the database in a new
folder called Query results and indicated by the query icon. Name fragments can be searched - as
common in other programs as well — if the fragment entry is framed by asterisks, e.g., *<name>*.
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o If the active entry in the database is a folder, the query will only scan the contents of
this folder. Activate the database icon in the Tree view to search the entire database.

A query can be further refined by marking data types in the Advanced >> view of the
dialog box. Documents that do not match the selected types will not be considered in
the search.

To find the location of an entry in the database first mark the thumbnail, then right-click
to open the context menu and select the command Goto Record.

A database can contain only one Query results folder. If a new query is carried out the
contents will be actualized.

Database » Query by Free Filter...
This command allows to perform queries with several criteria combined with AND or OR links.
Database » Query by SQL...

This command enables the usage of the SQL database language to define search criteria.

12.5.4 Administration: Defining Organizational and Database Fields

Create a new database or open a database in the Exclusive mode and select the command Data-
base » Administration » Define fields... to open the Define fields window.

It contains only a few active control elements when you have set up a new database and you use
this command for the first time.

Field list. All predefined database fields in a new database appear in the Field list. You cannot edit,
rename or delete predefined database fields or the entries in them. The one exception is the data-
base field Record Name, an entry in this field can be changed when you insert an image or when
you edit records.

New button. Click here to define your own database fields. The Add New Field window will open
where you have to set the Field properties.

Field properties
Edit. Click here to edit the field properties. The Edit Field Properties window will open, it has the
same features as the Add New Field window.

Input required. Mark this check box to make an entry mandatory when you insert data in the data-
base. This database field will be identified in the Insert Image dialog box by an exclamation mark
on its left side.
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Define Fields ]
. a4 K Field properties
FEdlEy - Mame: E xperiment Comment
~
[rata bype:  Texk
Input required
ﬁ Colar Channels
ﬁ Comment . Ficklist
ﬁ Exposure Time: =
ﬁ Graph Comment
ﬁ Image Dimension
ﬁ Markers
ﬁ Regions OF Interest (ROIs)
ﬁ Sample | Preparation
ﬁ Time Frames
€ u-size
ﬁ f-Size Default
£ z-Layers (®) value of last input
€3 Z-Step Width
O
- v

Organizational field. Mark this check box to identify a database field as an organizational field.
The content of an organizational field identifies all of the data, files and documents that belong to
this organizational element.

Picklist

Edit. Click here to open the Edit Picklist window. Here you can define a list of possible entries for
the user defined database field. When inserting images, select the desired entry from this list.

Default.

Value of last input. Select this to indicate that the field entry entered with the last inserted record
is to be used. This option is the default setting.

Choose the second option of this group if you do not want to define a default value for the active
database field. The database field will then be empty each time you insert data, and has to be filled
out again.
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13 The Special Menu and the

Window Menu

Macros are little programs that allow repeating series of processing and analysis steps upon a click
of a button. Here we explain how such macros can be generated. Also you will find in detail how

personal preferences for the software user interface can be set.

1S T E 1Y, F= Vo] o 13RS 266
B S T I B € 7= o 1= = | TR 266
13.1.2 RECOId MACKO ....cceeeiieeieeeeeeeee ettt e e e e e e e e ee e e e e e 266
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13.1.6  SINGIE SEEP ... 269
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13.1.8 Set as Default-Macro .........cuuuieeeiiiiiiiicieeeee et 271
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13.1 Macros

13.1.1  General

OLYMPUS

Macros and C modules (commands under Special » Recorder and Special » C Module, respec-
tively) are similar. In general, macros and C modules fulfill the same tasks. C modules are often
complex and make use of all elements of a programming language. Macros, on the other hand, are
supposed to handle simpler tasks. They are mainly used to combine available internal functions
with C modules, together forming a sort of chain-link fence of mutually dependent elements - e.g.,
linking a frequently used series of functions into one single function. Whereas C modules are more
loosely integrated into a configuration (remaining independent files), a macro will fully become part
of the configuration itself.

13.1.2

Record Macro

Recorder

= B &

Recorder toolbar

Use the Record Macro command (left button) to record a series of commands in the macro lan-
guage, Imaging C, while you are executing the commands. These recorded series of commands
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can then be used as the basis for developing your own macros. Macros take several steps and
integrate them into one macro.

Application. Certain image analysis processes frequently require series of commands that are
repeated over and over again. The macro recorder enables you to record these commands and
subsequently have them all run automatically instead of having them execute one at a time — again
and again.

General settings. Select Special » Preferences... or press <F8>. The Module tab contains the
Macro recorder field. The selectable settings have to do with the recording of argument names
and image buffers.

What will happen?
¢ After activating the Record Macro command, the Recorder button bar will appear.
e This menu command’s function will be changed — to Stop Macro Recorder.

e cell*R / cellM will generally open a new text document at this stage. If a text document is al-
ready open, you can append the commands you’re recording at the end of this text. To do so,
activate the text document before activating the Execute Macro command.

e All operations you execute within cell*R / cell®M will now be recorded in this text document.
Each step will result in one or more functions being recorded in the text document. If you’d like,
you can have the image buffer selection in the Image Manager recorded - this has to be preset
in the Special » Preferences... » Module tab.

e Stop the recording with the Stop Macro button.

Saving macros. Use the Save command (in the File menu) to save the recorded macro. Now you
will be able to re-load, modify or add this macro in cell*R / cell*M.

13.1.3 Executing Macros

There are a variety of ways to execute macros:
e Activate the text document containing the macro. Start up the macro with <F5>.

e Activate the text via the macro. Use the Special » Recorder » Set as Default-Macro command
(in the menu, see below). Now the macro can be executed anytime pressing <F5> — even if the
text document isn’t active.

e Select the Special » Define Macros... command to integrate the macro into a particular con-
figuration as button, menu command or key combination. This is explained below.

e The macro can then be integrated into an Imaging-C module and will thus be available as a
button function. To do this, you can use, e.g., the settings shown in the Special » C Mod-
ule » New Module dialog box. Set a name and click on OK to generate a sfm document that
has a sample program in it already. Simply substitute your macro text for the following line (the
third last line in the document):
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digOutput('Hello World™);

and then compile your module using the Build Module command (in the Special » C Module
menu, see Chapter 14.7, Build Module). A new button that allows to execute the macro/module
will appear in the main user interface to.

Editing macros. If you wish to alter a macro, be aware of the subsequent points:

Opening dialog boxes. The macro recorder records many commands so that linked dialog boxes
will not be opened when you execute the macro. To change this, all you need to do is append a
dollar sign [$] to the names of the functions within the recorded macro.

Example. Use the Image » Filter » Define Filter » NxN command to open the corresponding dia-
log box. The macro recorder will record the following entry, e.g.:

DefineNxN(Iterations:=3, Size:=10);

If you accept the command as recorded, the dialog box will not be opened and selected parame-
ters will always remain the same. To open the dialog box, you just have to modify the entry as fol-
lows:

DefineNxN S () ;

Now, when you activate the macro, the Define NxN dialog box will be opened and you can adjust
the parameters.

Logging dialog box parameters. When you call up a dialog box there are two ways to log the
entered parameters during recording of the macro:

Command window output: Anytime you like you can have values within a macro output in the
command window. Use the ? operator to do this.

Working with loops. Quite often you want to apply a recorded function series to more than one
image. This can be easily achieved by supplementing the macro with a basic for loop.

Example. Select the Horizontal Distance command in the Measurements toolbar. The macro re-
corder will record the following entry:

HorizontalDistance () ;

Let’s suppose you wish to conduct this analysis for 10 similar images. The images are in image
buffers 1-10. To solve this task, set a for loop around the commands recorded:
int i; //Variable i is defined
for(i=1;i<11;1i++)
{
Op.Display=i; //Image buffer is set
HorizontalDistance() ;

}

Imaging C Online Help. To get a precise description of the recorded commands use the Imaging
C online help. Select a command in the macro text and then press <F1>. The Imaging C online help
for this command will automatically be opened.



cell™ & cell® Software Manual Chapter 13 — The Special Menu and the Window Menu 269

13.1.4 Stop Macro Recorder

Click on the second button in the Recorder toolbar (or select Special » Recorder » Stop Macro
Recorder) after you have executed all commands or image analysis steps to be included in the
macro.

13.1.5 Run Macro

Click on the right button in the Recorder toolbar (or select Special » Recorder » Stop Macro Re-
corder or press the <F5>) to execute the commands in the active text document or the selection in
the active text document as a macro.

What will happen? The exact function of the Run Macro command will depend on the current
context.

Text document. The active document is a text document containing a macro text. cell*R / cell"M
is not in the debug mode and the active text document does not contain a selection: in this case
the entire text document will be interpreted as an Imaging C program and executed in the inter-
preter mode. Before doing so, the interpreter will be reset. This means that all variables and func-
tions defined in the interpreter mode are internally reset. They remain however in the text.

Text document and selection. The active document is a text document containing a macro text.
cell*R / cell®M is not in the debug mode and the active text document does contain a selection: In
this case the interpreter will not be reset. Only the commands selected will be executed.

Debug mode. If cell*R / cell*M is in the debug mode (Special » C Module » Quick Watch..., see
below), the program will continue with the next command independently from the active docu-
ment’s type.

Syntax error. If a syntax error is found in the macro text, the first incorrect line will be selected and
a warning indicating the type of error will be displayed.

13.1.6 Single Step

Use the Special » Recorder » Single Step command or the <F10> key to execute a macro one
step at a time.
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The Single Step and the Run Macro command are similar. Single Step, however, executes the
macro one step at a time — under user control.

Application. This command is very useful for running a systematic error search in a new macro.
You can follow the flow of the program and have the content of variables and expressions dis-
played simultaneously.

What will happen? The exact function of Single Step will depend on the current context.

Text document. If cell*R / cellM is not in the debug mode and the active text document does not
contain a selection, the entire text document will be interpreted as an Imaging C module and exe-
cuted stepwise in the interpreter mode. Before doing so, the interpreter will be reset. This means
that all variables and functions defined in the interpreter mode will be internally reset, but remain in
the text. The Debug toolbar is displayed and the mouse cursor will be transformed into the shape
of a hand. The first executable step will be indicated by the footprints symbol at the beginning of
the text document line.

Debug
» BB G m o E M

Debug toolbar

Text document and selection. If cell®R / cell*M is not in the debug mode and the active text
document does contain a selection, the interpreter will not be reset. Only commands that have
been selected will be executed. The Debug button bar is displayed and the mouse cursor will be
transformed into the shape of a hand. The first executable step will be indicated by the footprints
symbol at the beginning of the text document line.

Debug mode. If cell*R / cell*M is in the debug mode, the program will continue with the next
command, independently from the active document’s type. The line containing the command will
be indicated by the footprints symbol.

Syntax error. If a syntax error is found in the macro text, the first incorrect line will be selected and
a warning indicating the type of error will be displayed.

13.1.7 Reset Interpreter

Use this command to re-initialize the macro interpreter.

Definition. Each time a command is executed it is compiled in the interpreter mode. cell*R / cell*M
makes use of this mode when a command is executed via the command window, when the text of
a window is interpreted by the Run Macro command or when a macro is defined using the Define
Macro... command.
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What will happen? All variables and functions defined in the interpreter mode will be deleted inter-
nally but not in the text document.

13.1.8 Set as Default-Macro

Use this command to define the active text document as the default macro.

What will happen? Using the Run Macro command will have the active text document executed
as a macro. Execution is not possible if the image document is active. The Set as Default-Macro
command defines a text document that will then be executed when the command Run Macro is
selected. This permits the execution of the associated macro even if a non-text document is the
active document.

13.1.9 Define Macros...

Use this command to add new macros to the configuration. The corresponding dialog box opens.

Define Macros
Macros: Macro description;
ok

Cancel

d

Delete

ddald.

Help

Macro text:

Define as macro function

[ Beset interpreter
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@ All macros that are integrated into the cell*R / cell®M Graphical User Interface using
the Define Macros... command must be saved in a user configuration. Use the Spe-
cial » Configuration » Save... command to save the configuration.

Macros. Name your macro in the Macros field.

Add. Click on the Add button after entering the name of the macro into the Macros field. The name
will be added to the existing macros list.

Warning. A macro it must be added to the list in order to be defined. It is not sufficient to exit the
dialog box by clicking on OK.

Delete. To delete a macro from the list - select it and then press Delete.

Macro description. In the Macro description field you can insert a brief description of your
macro.

Macro text. Enter the program code of your macro into the Macro text field. Normally you first
record and test a macro in a text document. Use the Copy and Paste commands (in the File menu)
to copy the macro text into this field. A macro text can be no longer than 1000 characters.

Definition of more comprehensive macros. If you wish to define a longer macro, you should
remove the macro text for safe storage in a file via the #include command (see below) — or have
the macro implemented via a C module. To do this, first save the program code of the macro, e.g.,
in a file named ‘C:\cellR\macro\MyMacro.sfm’. Enter the following line into the Macro text field:

#include<C:\cellR\macro\MyMacro.sfm>

When you use the #include command within a macro function you’ll have to reset the interpreter
every time you make an alteration to the file (linked to the macro) in order to have the function re-
defined. To do this, use the Reset Interpreter command (in the Special menu). The interpreter will
be automatically reset when you exit the Define Macros dialog box via OK.

Define as macro function. If the Define as macro function check box has been selected, a
macro function will automatically be defined using precisely the same name with which it was en-
tered into the Macros field. You may then use this new function within other macros or you may
activate it directly from the command window. For example, if the macro name is ‘MyMacro', you
can activate it by entering

MyMacro () ;

into the command window. This check box is only available if your program version includes the C
Module menu.

Reset Interpreter. If the Reset Interpreter check box has been selected cell*R / cell®M will reset
the interpreter before running the macro. This means that all definitions made in the interpreter
mode (e.g., variable definitions, function definitions, etc) will become invalid. This ensures that
macro definitions will not conflict with previous definitions. This check box is only available if your
program version includes the C-Module menu.
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13.2 Add-In Manager...

Use this command to add/load optional extensions to the cell*R / cell*M standard configuration.

]

Add-In Manager

Available add-ins:

[#]&udia suppart ~ s
Black Balance
C]cMa
Calacalization
Excel Dynamic Data Exchange Bemave
Experiment Manager
Extended Focal Imaging
[1Grainz

Graph Processing » Help

Add

il

* Restart the application to enable/dizable the add-in.

30-Dreconvolution

File: D:hcel"Rtdecon.dix

Yersion: 2.5.463

Copuright: @ Soft Imaging System GmbH 2005 [BD)

D ezcription: Blind Drecorvolution, |rverse Filker, and Deblur Filkers for 3-D

Definition. The range of functions cell*R / cell*M provides can be extended as much as you like.
An Add-In is an additional program developed for special tasks that you can integrate into your
program using the Add-In-Manager. All add-ins are optional - i.e., cell*R / cell®M does not require
any add-ins to be fully functional.

Add-ins can be Imaging C modules (SXU) as well as program libraries (DLX).

Available add-ins. The Available add-ins list displays all add-ins available in your program pack-
age. These add-ins are automatically a part of the program when you install it. They are not, how-
ever, automatically activated.

Activating add-ins. Select the check box next to the name of the program to activate the add-in. A
number of add-ins can only be used after you re-start cell*R / cell*M. If this is the case, you’ll re-
ceive a message to this effect.

Some of the available add-ins will already have been activated as they make up essential compo-
nents of cell*R / cellAM. Take the image database, for example - it’s an add-in. If you clear the
check box next to the entry Graph Processing, the whole Graph Analysis menu will be gone the
next time you start up cell*R / cell*M.
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Add-ins that have not yet been activated remain on offer. We recommend however, that you acti-
vate only those add-ins that you really need. Otherwise, you’ll have too many superfluous button
bars or commands making the appearance of the Graphical User Interface unnecessarily complex.

Add-in information. Select an entry in the list of add-ins to view a brief description of that pro-
gram. It will be displayed in the lower field of the dialog box.

Close. Click on the Close button to close the dialog box and to save any alterations you’ve made.

Add... Click on the Add... button to insert an add-in to the list of available add-ins. The standard
dialog box for loading files will be opened. The file types available to you are the following add-in
formats: SXU and DLX. Generally you’ll only need to insert add-ins in two cases: either you had
deleted existent add-ins, or an additional add-in has been purchased.

Remove: Click on the Remove button to remove an entry from the list of available add-ins. This
button only removes the entry from the dialog box. The add-in file will not be deleted. Any add-in
you’ve removed can thus be re-added at any time. However, you need to know the corresponding
*.sxu or *.dIx file name.

13.3 Define Menu Bar...

Use this command to alter the configuration of the menu bar or context menu.

Define Menu Bar g]
Menu: [ ds:
e —
Bhoquie | [ L
¥ ance
%S napshot bo odule$
&Camera Contral... '”':’
Camera Chonfiguratior Acqu!n?t_mage
Set binput.. ddDiconnfoT sBuf [ nset subs men
e badntaneges
Autofocus Options... P
............... - . gg Ez:g}?ﬁ;g}:wla}' LCommand groups:
&F‘arfocahty Carrectior AdjustDisplayéuto = &l Groups
I&lumination Settings.. % gg us::magz&v’mdow Macras
Al L:f Mmage-oom MAP| Configuration
Show Main Menu Apgl.ﬁ.ctivateWindow Programs
ApltddRecardd +- All C-Modulesz
Apltdd-hIFields$ +- Internal Functions
AplarchiveluenResults§
Aplérchiving$
AplarangeFields$
AplChangePazsword bl 1SS 4
Drezcription
Starts continuous acquisition uzing active input device
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@ Any alterations you make to menu definitions via the Define Menu Bar... command
and integrate into the cell*R / cell®M Graphical User Interface have to be saved in a
user configuration. Use the Special » Configuration » Save... command to save the
configuration.

Explanation. Menus are organized hierarchically. Main menu entries contain commands and sub-
menus. An arrowhead to the right of an entry denotes a submenu. Submenus contain further com-
mands. Three dots behind a command indicate that a dialog box will open.

Menu. The contents in the Menu list can be toggled with the Show Main Menu and Show Sub
Menu buttons. As soon as you select an entry in this list, that entry will appear in the field above
the list. This entry is the menu element ready for editing. You can, e.g., alter a name in the list of all
main menu entries. Commands can be removed from or submenus can be added to the list of all
menu commands.

Show Sub Menu. Click on the Show Sub Menu button to move down a level in the menu hierar-
chy display. This button is only available if you’ve selected a menu or submenu entry. When, for
example, the main menu is being shown, you can select an entry and then click on the Show Sub
Menu button to have a look at all commands belonging to the entry selected. Then once all com-
mands of a specific menu are being shown you can select a submenu and then click on this button
to have a look at all the commands contained by that submenu. An easy alternative is simply to
double-click on the entry in the Menu list.

Show Main Menu. Click on the Show Main Menu button to move up a level in the menu hierarchy
in the Menu list. This button will not be active when the main menu is being shown in the list (you
cannot go any higher...!). This button will become available when you click on the Show Sub Menu
button, moving you down a level in the menu hierarchy.

Command groups. Specific groups of commands can be selected from the Command groups
list. If you select, e.g., All Groups, all available commands will be displayed.

Commands. The Commands list shows available commands depending on which group of com-
mands was selected in the Command groups list.

Description. The Description field provides a brief description of the menu or command selected.

Up or Down. After you have selected an entry from the Menu list you can adjust the position of the
element by clicking on either the Up or Down buttons. A main menu will be moved either to the left
or right within the menu bar; a command will be moved up or down within its menu.

Delete. Click on the Delete button to remove the menu element shown in the Menu field. Individual
commands can be removed from a menu, or you can remove a whole menu.

o Deleting a command in this case does not mean that this command is no longer avail-
able to you. Any command you’ve ‘deleted’ can be re-inserted into a menu anytime
from the list of commands.
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Modify (Add). Click on the Modify button to alter the name of a menu or command. When you’ve
selected an entry in the Menu list you can alter the name of the entry in the Menu field. As soon as
you’ve entered the new name, the Add button’s function will be changed to Modify.

Insert sub menu. Select the Insert sub menu check box to be able to use the Add button to insert
a new menu. Enter the name of this menu into the Menu field. The new menu will be located at the
same menu hierarchy level as current entries in the Menu list. So if you wish, e.g., to insert a new
main menu, do it when the list of main menus is being shown.

Add. Click on the Add button to

e Create a new menu:

1.

Select the Define Menu Bar... command in the Special menu.

Enter the desired menu name into the Menu field, e.g., ‘&Name’.

At the same time, you can also define a short cut for opening the menu more quickly: en-
ter the ‘&’ sign along with a letter, e.g., ‘&N...”. This means you’ll be able to open the
menu using <Alt+n>.

Select the Insert sub menu check box.

Click on the Add button.

The new menu will be appended to the Menu list.

The new menu entry will be selected in the Menu list.

Click on the Up button to move the new menu into the menu bar position desired.

Click on the Show Sub Menu button.

10.

Select the first command for the new menu.

11.

Click on the Add button.

12.

Repeat the above two steps until your menu is complete.

13.

Click OK.
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e Create a sub-menu:

1.

Select the Define Menu Bar... command in the Special menu.

Double-click on the name of the menu for which you wish to create a submenu.

Enter the name of the submenu into the Menu field.

Select the Insert sub menu check box.

Click on the Add button.

Double-click on the name of the new submenu in the Menu list.

Select the commands desired for the new menu and click each time on the Add button.

8.

Click OK.

e Create a command:

1.

Select the Define Menu Bar... command in the Special menu.

Double-click on a menu.

Add a new command or delete an existing command.

13.4

Click on OK.

GUI Configuration

Select Special » Configuration to open a sub menu containing the three commands Reset,
Load..., and Save....

Definition. The term Configuration refers to the appearance and functions of the Graphical User

Interface (GUI). A configuration consists of the following elements:

e User-defined menus or an altered pre-defined menu using the Special » Define Menu Bar...
command.
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e Macros generated using the Special » Macros » Define Macros... command.

The configuration does not include the settings for the Viewport Manager or the Image Manager.
Settings of individual dialog boxes are not part of the configuration either.

Information about the loaded modules is not part of a configuration file. This means that after load-
ing the standard configuration no modules will be removed. Modules that are part of a configura-
tion file are those whose MAPI functions, e.g., are used in the configuration’s menus. These
modules will be automatically loaded along with the respective configuration.

If cellAR / cell*M is being used alternatively by various users or for varying tasks it makes sense to
set up individual workspaces. The configuration of the relevant workspace used last will be auto-
matically loaded along with many other settings when you start up cell*R / cell*M.

13.4.1 Reset

Use this command to restore the original standard configuration.

What will happen? Once you have modified a menu or a button bar, or after you have integrated mac-
ros and programs into the system, selecting Reset returns you to the original standard configuration.
This is helpful when you no longer need the current configuration or when you want to create further
configurations based on the standard configuration.

Saving current configuration. If you have made alterations to a particular configuration — which
have not yet been saved - before the standard configuration is loaded, you’ll be given the opportu-
nity to save your altered, current configuration.

13.4.2 Load...

Use this command to load a previously saved configuration.

Available. If you’ve already created and saved your own configuration, you can activate it using the
Load... command, making it your current configuration.

If you load a configuration that was created with an older cell*R / cell*M version, the Update Con-
figuration: *.scy dialog box will open.

Cancel. If you exit this dialog box via Cancel, the older configuration will not be loaded.

Use standard configuration... If the configuration you wish to load contains essential user-defined
functions you would be well advised to load that configuration using the Use standard configuration
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and include functions defined in selected configuration option. In most cases, this option will get
you the desired result.

Update Configuration: temp.scy g]

2 You are trying to load & configuration which was previously defined

& J inan older version of this program. Choose how to update the
“'-/ configuration:

(®) Use standard configuration and include functions defined in selected configuration

(O No update: ignore nesw functions of this program version

No update. If the configuration you wish to load is however a reduced version of an older standard
configuration, you would do better to use the No update: ignore new functions of this program
version option. In this case, the configuration will be loaded precisely as it is.

e Any commands that are exclusive to the current program version are not part of the
older configuration. Thus these commands will not be available. If you want to use
them, it will be necessary to add them manually to the configuration using update
commands, e.g., the Specials » Define Menu Bar... command. This option should be
used in cases where you simply do not know in what way the older configuration differs
from the current configuration.

If necessary repeat loading of a configuration to achieve the result desired using an-
other option. If you’re happy with the results of your loading of an older configuration
then save this now current configuration using the Configuration... » Save... command
(in the Special menu). The next time you load this configuration, you’ll be able to load it
without any further queries.

13.4.3 Save...

Use this command to save the current configuration.

Application. Select the Save Configuration... command to save your individual configuration. You
can recall this configuration at any time. Configurations can be designed for different tasks and/or
users, and saved as individual settings.

File format. A user-configuration file is saved using the *.scy file name extension.
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13.5 Preferences...

OLYMPUS

Use this command for setting preferences within cell*R / cell*M. The Preferences dialog box can
alternatively be opened with <F8>.

13.5.1

The settings on this tab apply the handling of images.

X

Preferences

Image | ‘iew File | Measure | Module | Graph | Database| Report

Imaging functions

Confirm operations

The Preferences » Image Tab

Ay ailable image buffers: £4 = Drag & Drop:
Circular switch [ Delete image
[ &llews operationg o false color images [ Copy image
Overlay:
Image acquisition ] Delete averlay
Sequence:
Nome 7 Burn overlay
3 H | b Tab:
Prefi for images: Tw D= WleTr=E=l U Gl
List
Incremental number: 4| oL
() Gallery
(® EBath
Ok l [ Cancel ] [ Help
Overview

You can adjust the number of available image buffers in the image manager.
You can activate the circular switch and set the cycle width.

You can select whether you want to receive a query message when you delete or copy images
from the image buffer via drag & drop.

You define whether most of the menu commands are also allowed for false color images.
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e You can predefine the image name automatically set for image acquisition.
Imaging functions

The settings in this group are relevant for image processing operations, for altering gray or color
values of an image.

Available image buffers. Enter the desired number of image buffers to be available in the image
buffer box of the Image Manager into the Available image buffers field. You can select between

16 and 200 image buffers. Any change in the number of image buffers only becomes effective after
you restart cell*R / cell"M.

Circular switch. Select the Circular switch check box to activate the circular switch. As a conse-
quence the destination image buffer will automatically be different from the source image buffer,
i.e., the active image cannot be overwritten during image operations.

Destination image buffer and circular switch. The image buffer used as destination buffer depends
on various settings:

a the number of Viewports displayed in the image document,
b whether the image buffer is protected, and
¢ the circular switch settings.

Single view: If you only have one Viewport displayed in the image document, the destination image
buffer will be set to the next-highest image buffer after each image operation. The highest image
buffer available represents the limit of the range of the circular switch. At this point, the destination
image buffer will be set back to image buffer 1. If you set the range of the circular switch at, e.g., 8,
the destination image buffer will be raised successively to the 8th image buffer, and then go back
to image buffer 1.

Multiple view: In this case, the circular switch range is meaningless. If you’re working with several
Viewports, the destination image buffer will be set to the next respective Viewport. If, for example,
you’re working with four Viewports - assigned respectively to image buffers 2, 6, 3 and 8 - the des-
tination image buffer will be successively set to 6, 3, 8 and then 2 again. If you’re working with two
Viewports, for example, which are currently assigned to image buffers 7 and 8, the destination
image buffer will switch back and forth between image buffers 7 and 8.

Write-protected image buffers. If the next image buffer is write-protected, the one after that one will
become the destination image buffer.

Allow operations on false color images. Select this check box to apply image operations that
change the gray values of an image to the false-color images as well.

Several image operations applied to the gray-value image, do not affect the displayed false-color
image - i.e., the resulting image has altered gray values, although the lookup table remains the
same. For this reason image operations applied to false-color images may yield unexpected re-
sults.

Image acquisition

Sequence. The option chosen here determines where a newly acquired snapshot will be placed in
the Image Manager and whether it will be stored in the active database or not.
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None. A newly taken snapshot will always be placed into the active buffer in the Image Manager
overwriting the any image currently being place there.

Image buffers (All). A newly taken snapshot will always be placed into the next buffer in the Image
Manager overwriting the any image currently being place there.

Image buffers (Circular Switch). A newly taken snapshot will always be placed into the next free
buffer in the Image Manager unless all buffers are occupied. In that case the last one to filed will
overwritten again and again.

Prefix for images. This setting applies to the standard names cell*R / cell*M provides when you
acquire an image using the Acquire » Snapshot command. Enter the prefix of an image name into
the Prefix for images field. A prefix consists of up to 8 characters of upper- or lowercase letters,
numbers or special symbols. Each new image you acquire will then be given automatically this
prefix. The default is Tv.

Incremental number. This setting applies to the standard names cell*R / cell®M provides when
you acquire an image using the Acquire » Snapshot command. In the Incremental number list,
select the number to be given to the next snapshot to be acquired. Each successive image’s num-
ber is raised by 1. This value is a whole number with a maximum of eight digits. The lowest value
available is 1. This number will automatically be reset to 1 every time you start up.

Confirm operations

Drag & Drop. Decide whether you wish or not to receive a query message when you Copy image
or Delete image in the image manager using drag & drop. To select these options set the tick
marks in the respective small boxes. These queries apply only to the dragging & dropping of im-
ages. You will not receive a query when using the Edit » Delete Image and Edit » Copy com-
mands.

Overlay. Decide whether you wish or not to receive a query message by selecting the check box
Delete overlay. If you select Burn overlay the overlays will be saved together with the image, thus
it will change the image data.

Image Manager tabs

Select here whether the Image Manager should list all loaded images as a list with name entries,
as thumbnail gallery or both.

13.5.2 The Preferences » View Tab

The settings of this tab apply to the cell*R / cell*M Graphical User Interface.

Overview
e Choose the font size for cell*R / cell®M image overlays and sheets in this tab.
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¢ Decide whether the mouse cursor is to be transformed into the shape of an arrowhead or of cross-
hairs during interactive measuring.

e Decide whether the name of a function is to appear along with a brief description of the com-
mand in the status bar.

¢ Indicate whether you’re working with a general or individual workspace.

¢ Align the image document along with all other document windows when you use the commands of
the Window menu to sort the document windows of the Graphical User Interface (GUI).

Preferences g]
Image | Wiew File | Measure|| Module|| Graph | Databaze| Repart
Overlay Sheet
Font gize: |9 Font: | Arial w

43| |43

Pen size: |Auto Font size: (10 ||| Decimal places: (2 ||3

Mouse cursor

Style: Prirnary: Auwiliary: Mavigatar:
ron Y Y

General

[ Shaw function names & arguments in status bar
[ Startup with user dependent zettings

Allova tiling and cascading of image window

Button Bars
[ Auta-Arrange Button Bars

0k, ][ Cancel ][ Help

Overlay

Set the Font size for texts in the overlay and the Pen size (line thickness) for the overlay drawing
tools.

Sheet

Determine sheet font and font size for sheets in the Sheet group. Arial is the default font set in the
Font list; the Font size is automatically set to 10. Select the settings from the pull-down lists ac-
cordingly to change the Font or the Font size. The settings apply to the values in the sheets them-
selves as well as the column headers and the first sheet column, containing the row numbers. Any
alterations you make to the settings here apply to any open sheet document. Set the number of
Decimal places of the values displayed in the sheets.

Mouse cursor

Style. Determine the shape of the mouse cursor. This applies only to interactive commands like
drawing ROIls, measurements and overlay drawings. You have three choices: an Arrowhead, a
Small crosshair or a Large crosshair (which covers the entire image).

Primary. Determine the temporary color, for example, of a ROl while drawing it. After terminating
the action the color switches to the designated (permanent) color.

283



284 Chapter 13 — The Special Menu and the Window Menu OLYMPUS

Auxiliary. Determine the temporary secondary color, for example, of the distance to be measured.
After terminating the action the color switches to the designated (permanent) color.

Navigator. Determine the color of the frame indicating the current image cutout in the Viewport
manager.

General

Show function names & arguments in status bar. If selected, function name and arguments of a
command will be shown in the status bar (lower right corner of the cell*R / cellAM window) in addi-
tion to a brief description. To view the respective status bar information, simply select the com-
mand of interest. To see the information about buttons in the tool bar, simply position the mouse
cursor on the button of interest.

Startup with user dependent settings. If selected, on startup your own individual workspace will
be displayed. If this check box has already been selected, clear the check box and then select it
once more to enable startup with your own workspace. To load the general workspace for all users
clear this check box.

Allow tiling and cascading of image window. If selected, the image document will be aligned as
well when you have all document windows in the Graphical User Interface (GUI) aligned. This set-
ting applies to the Cascade, Tile Vertical and Tile Horizontal commands of the Window menu.

13.5.3 The Preferences » File Tab

The settings of this tab apply to various options for saving images and sheets.

Overview. On this tab you decide
¢ the default method of compression for TIFF images and quality of JPEG images,

e whether the active configuration is automatically saved when you shut down cell*R / cell*M or
whether you are to receive a query message,

e whether an automatic back-up of the previous text file is made when saving the current version
of the respective text document,

¢ the default file type for saving and opening images and documents, and

¢ how many entries are to be listed in the recent file list.

Save image files

Here you can set defaults for saving images in the TIFF, JPEG, JPEG200 and LEAD formats.

Tagged Image Format (*.tif). The TIFF format is the standard image format in cell*R / cell*M.
Select another image format only if you wish to export images to another application program -
which cannot read the TIFF format. The TIFF format enables you to save additional information
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along with the image itself. In cell*R / cell*M this non-image information refers to, e.g., calibration
data, image comments and overlays.

Image | “iew File | Measure|| Module | Graph | Database | Repart
Save image files Sheet format

Tagged Image Format [“tif Standard v
O geplace blanks
Decimal symbal:

FCD-Format List separator;

TESx 512 A Usze Windows regional settings

Gereral

Save configuration on exit without confimation
Lreate backup when zaving textfiles

Keep file type i file input/output dialogs

g

Humber of entriez in recent file list:

[ Ok ][ Cancel ][ Help ]

JPEG (JFIF, *.jpg), JPEG200 (*.jp2), LEAD Compression (*.cmp). In order to achieve a stronger
data reduction you may choose to export images using these formats. However, they go along with
loss of quantitative information in dependence of the compression quality.

JPEG does result in information lost - i.e., an image you had saved using the JPEG method is no
longer 100% identical to the original image. A compressed image is no longer of any use for pre-
cise quantitative analysis. You may have trouble making out the difference with the naked eye —
depending on the degree of image compression. Some image information loss may be acceptable
for applications where the most important thing is the visual appearance of the image.

JPEG compression provides fine results for gray value and true-color images of a photographic
quality. For applications where color- or gray value distribution is important, we recommend to
avoid JPEG compression. JPEG compression is not suitable for synthetic images or for images
containing fine lines or inscriptions (which are in the image itself, and not in an overlay). This is
because JPEG-compressed images do not reproduce abrupt gray value transitions satisfactorily.

In fact, false-color images cannot be directly JPEG compressed. This is why cell*R / cell*M will
transform false-color images into (3x8) bit true-color RGB images before saving along with JPEG
compression. If there is an overlay, it will be burned automatically before conversion.

@ Warning. Try to avoid compression in general. Compression always results in image
artifacts (an exception being the png format). Images should only be compressed after
the analysis is completed.

Options. This opens the context-sensitive Save Image Options dialog box.
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Save Image Options g]
AP Save Image Options g]
Preprocessing
[ Corwert 16-bit images ta 8-bit JPEG
[ Burn overlay inta image Comprezzion
LComprezsion ®..N.. at O Lossless
Qualy: |85 I
MHaone v
[ Progressive
Passes:
Output Farrmat
Standard w Color space
[ Corwert inta packed FIGE @244 O422 O417
[ u] ] [ Cancel ] [ Help ] [ OF. ] [ Cancel ] [ Help ]

TIFF / Preprocessing. Before saving the image you can adjust whether the image should be Con-
verted form 16-bit to 8-bit and whether the Burn overlay into image should be done, by clicking
the respective check boxes.

TIFF / Compression. The TIFF format also supports a series of compression methods (Packed
Bits, JPEG, JPEG 2000) for reducing the file size of an image you are saving. The methods can be
selected from the list in the Compression field. This allows you to save more images than you
could without compression — an important point as far as image archiving is concerned. Compres-
sion can be relevant as far as long-distance image data transmission is concerned — transmission
time is reduced due to smaller file size, thus reducing costs. To return to the default settings — no
Preprocessing and no Compression - press the Default button.

TIFF / Output Format. Select Standard to have all additional information possible in the TIF format
included in the file.

Select Copy of Image Display to convert the image as shown in the image document to a standard
24 bit TIF image. All additional information is lost in the process.

Select Cell*R 1.1 to allow third party applications to import 16-bit TIFF images.

JPEG / Compression. Here you can define the options for saving the image as JPEG format. The
file size of the image file generated is inversely proportional to image quality. If you’re dealing with
realistic images and you enter a quality value of 85% — you won’t be able to distinguish the com-
pressed image from the original onscreen. At 75%, there is minimal deviation; at less than 50%
you’ll be able to see the loss in quality. You'll notice this loss in quality at higher values when work-
ing with synthetic images. The image quality set should in the main depend on the properties of the
available output device. Say you print out a gray-value image on a 600-dpi printer at a 10 cm width
— even at a quality value of 25; you will hardly be able to distinguish the compressed image print
out from a print out of the original. But keep in mind the effects compression has on various image
processing functions.
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Sheet format

Decide which file format the system will offer by default for your use when you save. This format is
a pre-set file type - i.e., you are free to alter the actual format of a sheet anytime you like. To make
an alteration select the desired file format in the Files of type list in the File » Save As... dialog box.
The above-mentioned pre-set format in this tab is only relevant for new sheets - i.e., those sheets
for which there is as yet no existing file. These pre-sets will only be relevant for the ‘file-less sheets’
if you've cleared the Keep file type in file input/output dialogs check box in the General group.

When to use which sheet format? The standard format must be used if you later wish to be able
to read in and continue work on sheet data in cell*R / cell*M. Use other formats if you wish to
export data into other application programs.

Standard. Select the Standard option to save sheets using the cell*R / cellM sheet format whose
file name extension is SFS. Any sheets you later wish to load and continue work on in cell*R /
cell"M must be saved using this format.

Microsoft Excel. Select the Microsoft Excel option to save sheets in the XLS file format. These
sheets can be loaded into and further processed in the MS Excel sheet calculation program. cell*R
/ cell*M is not able to read this file format.

Lotus123. Select the Lotus123 option to save sheets in the WKS3 file format. These sheets can be
loaded into and further processed in the Lotus123 sheet calculation program. cell”R / cell*M is not
able to read this file format.

Text. Select the Text option to save sheets in the TXT format. Sheets will be saved as text. Semico-
lons will separate data within individual columns from one another. Each text line represents a
sheet row. This text file can be read by any text editor or word-processing program. The advantage
here is that sheet data can then be read into many other application programs. This file will be
opened as a text document in cell*R / cell*M - not as a sheet document.

Replace blanks. Select the Replace blanks check box to automatically have all spaces replaced
with an underscore symbol ("_") when saving sheet data in the TXT format. This check box is for
making the reading of sheet data from text files in other application programs much easier: When
reading in strings, it’s generally easier to deal with underscores than with spaces.

Use Windows regional settings. If this box is checked the Decimal symbol and the List separa-
tor will be used as corresponds to the regional settings of the operating system of your computer.
If you deactivate this option you may choose between dot and comma for the Decimal symbol and
between comma and semicolon for List separator.

o Certain programs may not read your data properly if you choose not to use the regional
settings.

General

Save configuration on exit without confirmation. A configuration file contains the structure and
content of menus and button bars, as well as the assignment of accelerator combinations (key
code short-cuts). Select the Save configuration on exit without confirmation check box to have any

287



288 Chapter 13 — The Special Menu and the Window Menu OLYMPUS

user-defined cell*R / cell*M configuration saved automatically upon shut down. A configuration will
only be saved if you’ve made alterations to it. The current configuration will be saved in the corre-
sponding configuration file, thus overwriting the previous version of the configuration. Clear this
check box to receive a query message each time you’ve made alterations to a user-defined con-
figuration and shut down cell*R / cell*M. You’ll be asked whether you wish to save the current
configuration. Selecting Yes will open up the Save Configuration dialog box. This dialog box is
structured like the standard Windows dialog box for saving files. The file type at the top of the list is
the one for configuration files: *.scy. Now you can create a new configuration file or overwrite an
existing configuration file.

@ It's a good idea to clear this check box to ensure that you do not unintentionally over-
write an existing configuration file.

Create backup when saving text files. Select the Create backup when saving text files check box
to have a backup saved automatically when you save text files. This second file — the backup -
contains the version of the text file as was last saved - not the current text file. This backup will be
created when you overwrite the previous version of the text file. The first time you save a text no
backup will be created.

What you’ll have is two files containing two different versions of a text document: the current ver-
sion will be saved in the file format selected in the Files of type list of the File » Save As... dialog
box - e.g., report.txt. The previous version will be saved in the so-called *.bak file format - e.g.,
report.bak.

Loading backups: bak files can be loaded in cell*R / cell*M. To do this, select the All (*.*) entry
from the Files of type list of the File » Open... dialog box. Now the bak files will be shown as well.
They will not be shown via the Text Formats entry, however. Click on the Open button in this dialog
box. The Load File dialog box will be opened. Click on Yes to open the bak file in a separate text
document.

When do | need a backup? Primarily backups make sense for macros. You'll still have the previous
version of the macro if it turns out that the new version is causing you problems - such as crashes,
for example.

Keep file type in file input/output dialogs. Select this check box to have the file type you last
used offered to you the next time you save or open a file. This check box affects the standard Win-
dows dialog box for opening and saving files (in the File menu). Keep in mind that the file type of-
fered to you will depend on the document you wish to save or open.

Examples. If you have saved, for example, your latest new sheet document in the x/s format - the
next time you wish to save a new sheet, the xIs format will be offered to you. Say that the last time
you opened a text document you used the All (*.*) format — the next time you wish to open a text
document you’ll be shown all files of the currently-set directory.

Preselect file type 'All Formats' in Open dialog. If this box is checked all files of all formats will
be shown in the File » Open... dialog. Otherwise only the files of the most recently chosen format
will be shown.
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Number of entries in recent file list. Here you can select how many of the recently used files are
displayed in the file list within the File and Database menu.

13.5.4 The Preferences » Measure Tab

The settings in this tab are mainly concerned with interactive measurement functions of the Meas-
urements toolbar.

Image | “iew File | Measure | Module | Graph | Database | Report

General Label style

[ Use alternating colors

[ Use irverted ¥ axis Inactive color: Active color:
Show abels | IS
(O None Background:
O Humbeig ]
(®) Measurement result
e et I agic "+ and options
; Tal : 50 =
Decimal places: |2 i b e >
Srnoathing: a =
Scale: Auto v BT as

L lepp=i=}
LColor space: | & | & 2 0

Label fant
[1Zoom text with image

u] H Cancel H Help

General

Continuous Measurement. If this option is not marked the selected measurement tool becomes
disabled after each measurement and has to be selected anew for another measurement. Other-
wise several measurements of the same time can be executed one after the other and the function
has to be terminated with the <Esc> key.

Use inverted Y axis. Conventionally in imaging the origin of the X/Y coordinate system is the upper
left corner. Mark this option to set the origin to the bottom left corner with rising Y axis.

Show labels

None. If this option is chosen, measurement objects such as lines and 'x's will not be labeled in the
overlay.
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Numbering. If selected, individual measurements conducted within a series of measurements will
be numerated in the overlay. When you select this check box the Measurement results option will
be cleared - you cannot display numbers and measurements simultaneously in the overlay.

Measurement results. Select this option to label each object being measured with the measure-
ment result and the relevant unit of measurement.

Include name. Check here to have the name of the method displayed with each measurement.

Decimal places. Here you determine how many decimal places will be displayed. This field is only
active if the Measurement results option is selected.

Scale. Select the scale of the unit from the picklist.

Label font

Zoom text with image. Mark this option if the label text shall be zoomed together with the image.
Label style

Use alternating colors. Select this check box to have different colors automatically assigned to
different measurement objects or series of measurements. This color appears in visualization of
interactive measurements, and in the corresponding labeling and sheet entries. Colors will be as-
signed cyclically to the various measurements - their sequence is red, green, yellow, blue, ma-
genta, cyan and then back to red. This sequence is preset. After finishing a measurement (series)
and then beginning another, color assignment will start with red again.

o These settings do not affect the colors of ROls.

Inactive Color and Active Color. If the Use alternating colors check box is deselected, you can
choose one of the 16 MSWindows colors to mark the currently active measurements objects in the
overlays in one color of choice and the inactive measurement objects in another.
Color selection applies to:

— Display of interactive measurement elements such as lines and ‘X’s.

—The corresponding labeling of measurement objects or series of measurements of objects
being measured.

— Corresponding sheet entries.
Background. This sets the color of choice of the background underneath the labels of the overlay

objects. Without such background they would easily be overlooked in non-gray scale images —
depending on the color.

o This field is inactive when the option Show labels / None is selected.

Magic Wand options
See Chapter 9.3.1, Magic Wand Options, for details.
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13.5.5 The Preferences » Module Tab

The settings in this tab apply to users who wish to create their own macros or Imaging C modules
for use in cell*R / cell"M.

Preferences g]

Image | View | File | Measure| Module | Graph | Database| Report

ad
Reload on startup

Mawimurn number of modules: |20 I

Language version: | Auto hd
Debug made
Carnrard window Macro recorder
Activate on output Mamed arguments
[ Display string pointer values [ Image buffer arguments

[ 1ssue error message for invalid pointers

0k, ][ Cancel ][ Help

Modules

Auto save on build. When selected, the text document is automatically saved — using the Run
macro command — when you start up your macro. When compiling a C module using the Build
Module command, or using the identical function Build in the Module Manager dialog box, all files
used in the C module will automatically be saved. For this to happen, however, each of the compo-
nent files must have been saved at least once already — in order for files to be saved automatically
they must have an existing file name or path name. A source text does not necessarily have to be
saved to run a macro - however, this is obligatory for running a C module.

Background: When a C module is created, only the text documents that have already been saved
will be compiled. Thus to avoid problems, we recommend you generally to select this check box.

The header of the active text document indicates whether that document has been saved or not. If
you’ve made alterations to the active text document and these have not yet been saved, an aster-
isk [*] will appear next to the name of the document.

Reload on startup. Select this option to have all C modules — that were loaded when you shut
down cell*R / cell®M - reloaded when you start cell*R / cell*M again.

Debug mode. Having selected the Debug mode, you can use the Assert and Verify Imaging C
functions for the development of your own Imaging C modules. Both functions can be used for
tracking down errors in Imaging C modules.
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Maximum number of modules. Enter the maximum number of C modules you wish to have
loaded simultaneously. The standard value here is 20. You should only increase this number if you
really need all those modules - in order not to occupy more system capacity than necessary.

Language version. When programming, C modules function names will be shown in either English
or German - depending on which language you’ve selected in the Language list. This setting also
determines what language is to be used by the macro recorder for recording menu functions.

Command window

Activate on output. C modules and macros are able to write results into the command window.
Select this option to have the command window opened automatically, or placed in the foreground
(if it was already open). When working with macros, keep in mind that due to an output, for exam-
ple, using the ? operator, or the printf function, the active document will lose its ‘active’ status - the
command window will be activated in correlation with this check box. A macro that refers to an
active sheet document, for example, will locate the command window instead and thus can no
longer continue working correctly.

Display string pointer values. Tick mark this option to have not only strings displayed at output in
the command window, but the corresponding address as well.

Example. Select the check box. Enter the following two lines into a text document; run the sample
macro by pressing <F5>.

char szInfo[20] = "Example";

? szlInfo;
The following line will be output in the command window:
0x59b7:0x000c -> Example

This check box is not selected in the standard setting of the program - strings are used frequently
and having addresses included all the time makes them more difficult to read.

Macro recorder

Named arguments. Select this option to record the argument names together with the invoked
functions with the macro recorder.

Image buffer arguments. Tick-mark this check box to have the macro recorder record the index of
image buffers involved (absolute image-buffer address). If the check box is deselected, the re-
corded functions will refer to the current values for the source and destination image buffers (rela-
tive image buffer address). In this case the macro recorder will record every interactive image buffer
selection (i.e. every click within the Image Manager).

Issue error message for invalid pointers. When this option is selected and you use a pointer
variable, you will get an error message in case the value it contains is not valid.
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13.5.6 The Preferences » Graph Tab

The settings on this tab apply to the handling of graphs.

Preferences g]

Image | “iew File | Measure| Module| Graph | Database | Report
Graph functions

-
>

Available graph buffers: 20

Dirag & Drop in graph manager
[ Canfirm delete
[ Confirm copy

Background pattem

Ok ][ Cancel ][ Help

Overview

¢ You can adjust the number of available graph buffers in the image manager.

¢ You can determine whether the graphs are displayed in the list view.

¢ You can select whether you want to receive a query message when you delete or copy graphs
from the graph buffer via drag & drop.

Graph functions

Available graph buffers. Enter the desired number of graph buffers to be available in the graph
buffer box of the Image Manager. You can select values between 12 and 100 graph buffers. Any
change in the number of image buffers only becomes effective after a cell*R / cell*M restart.

Display as list view. This check box is not activated by default and the graph buffer box appears
like the Gallery buffer box with graph thumbnails. If you activate this check box the graph buffer
box will look similar to the images list buffer box without thumbnails.

Drag & drop in the Graph Manager

Confirm delete, copy. Decide whether you wish or not to receive a query message when you copy
or delete graphs in the graph manager. These queries apply only to the dragging & dropping of
graphs. You will not receive a query when using the Edit » Copy command.

Background pattern. When activated, the graph window and the graph thumbnails in the graph
buffer box of the Image Manager will have a background pattern of diagonal stripes.
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13.5.7 The Preferences » Database Tab

Use this tab to define presets for a database you wish to create. See also Chapter 12.1, Directories
for Data Storage.

Preferences E]

Image | View | Fie | Measure| Module| Graph| Databaze | Repart

Thumbnail display size: Small v
D atabase defaults
Thumbnail creation zize: | Small v
Save images

tif »
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gfen;?;ﬁw SHEES [v:ArchivesTrpStorageDin E]
Backup volume capacity: 500 | Me
Record name
Synchronize with image name [ wto Record Mame
Format:
u] ] [ Cancel ] [ Help ]

Overview.

On this tab you can decide
¢ the current size of the thumbnail display for all database documents, and

o the preferences for new databases. These settings comprise actual thumbnail size, the standard
image format, maximum size of image drive or directory, compression method and the paths for
system files and images.

To adjust the actual Thumbnail display size you can select between the predefined sizes Smaill,
Medium, and Large from the pull down list.

Database defaults
You can set the preferences for new databases.

Thumbnail creation size. You can adjust the size of newly created thumbnails from the pull down
list to Small, Medium, and Large.

In the Save images field you can preselect from the pull down list the File type for saving images
acquired in the database. Selecting Force TIF type for documents, inserts images as documents
with the TIF format. The read only information Compression indicates if and which compression
method you have selected. The Options... button has the same function as the one on the File tab
(for details see Chapter 13.5.3.1, Save image files).
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We recommend you to use the TIF format as default for the reasons already described
in Chapter 13.5.3, The File Tab.

In the Location field you can determine the pathname for the Database files and the Temporary
storage directory, as well as the Backup volume capacity.

13.6 Window

13.6.1  Minimize All

Use this command to minimize all open documents and arrange the document icons.

What will happen? Document icons will be aligned along the lower edge of the documents area.
Using this command can help you keep track of all the documents you’re working with. This com-
mand is for text, sheet, diagram and database documents as well as for the Image Document.

13.6.2 Close All

Use this command or the short cut <Ctrl+d> to close all (open) documents.

This command is for text and sheet documents. It does not affect Image or Graph Documents, or
any images within the image buffer box. Database documents will not be affected either.

13.6.3 Document Manager...

Use this command to open the Document Manager dialog window. This is helpful in case your
workspace contains many open and/or minimized windows.

As an alternative, you can open this dialog window using the short cut <Alt+3>.
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M Document Manager @

B _oax BE0 5 2

Documnent Mame
@ Sheet Sheet] - Graph, GB[1]: Kinetics of ...
Image Tw3
Graph Kinetics of Fura
@ Databasze Life5cienceD emoSTAR . apl
@ Databaze tricolor.apl
B Activate

Activate. This button activates the window selected in the Document/Name list. The same com-
mand can be executed with a double-click on the window.

= - . - - .
- 0O x Minimize, Maximize, Restore, Close

Minimize, Maximize, Restore, Close. These buttons represent standard Windows commands and
can be executed on the presently active documents, with the exception that the Image and Graph
documents cannot be closed.

BB Cascade, Tile Horizontal, Tile Vertical

Cascade. Use this button to have all selected text, sheet, diagram and database documents ar-
ranged - staggered - one atop the other.

What will happen? The order in which the documents are arranged will depend on which one was
most recently active. The currently active document will be the one displayed in front. Title lines
containing the names of all documents will remain visible — so that you can easily activate any of
them — they will then appear in the foreground.

Tile Horizontal. Use this button to have all open text, sheet, diagram and database documents
arranged horizontally, and above and below each other.

What will happen? All open documents will be displayed at the same level and in the same size,
using up the whole documents area. Document windows will be enlarged or reduced as needed. If
up to three documents are selected they will be displayed one above the other. With four and more,
they'll be arranged in rows and columns — so that windows will tend to be rather squatty and broad.
Title lines containing the documents’ names will remain visible — you can thus easily activate any of
the open documents.

Tile Vertical. Use this button to have all open text, sheet, diagram and database documents ar-
ranged vertically, next to each other.



cell™ & cell® software Manual Chapter 13 — The Special Menu and the Window Menu 297

What will happen? All open documents will be displayed at the same level and in the same size,
using up the whole documents area. Document windows will be enlarged or reduced as needed. If
up to three documents are selected they will be displayed next to each other. With four and more,
they will be arranged in columns and rows — so that windows will tend to be rather long and narrow.
Title lines containing the documents’ names will remain visible — you can thus easily activate any of
the open documents.

5 Close All

Close All. Use this button to close all Text and Sheet documents. It does not affect Image and
Graph documents, or any images within the image buffer box.

13.6.4 Viewport Manager

Use this command to turn the Viewport Manager On or Off. You may also use the short cut
<Alt + 1>.

What is the Viewport Manager? The Viewport Manager also displays the image of the active
Viewport. Additionally, the Viewport Manager is surrounded by a red rectangle. The size and posi-
tion of this rectangle can by changed using the left mouse button. The area within this rectangle is
displayed in the Viewport. Thus you can use this rectangle to zoom into an area of interest.

Application. You can turn off both Viewport Manager and Image Manager to temporarily enlarge
the documents area. This will give you, e.g., more space for displaying images within the Image
Document.

What will happen? A tick will appear next to this command when the Viewport Manager is ’on’.

13.6.5 Image Manager

Use this command to turn the Image Manager On or Off. You may also use the short cut <Alt + 2>.

What is the Image Manager? The Image Manager contains the Operands Box with the source and
destination image buffers and the image buffer box with the List, Gallery and Graph views.

Application. You can turn off both Viewport Manager and Image Manager to temporarily enlarge
the documents area. This will give you, e.g., more space for displaying images within the Image
Document.
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What will happen? A tick will appear next to this command when the Image Manager is On.

13.6.6 Status Bar

Use this command to turn the Status Bar On or Off.

What is the Status Bar? The Status Bar is usually displayed at the bottom of the Graphical User
Interface (GUI). Among other things it displays a brief description of each cell*R / cell®M com-
mand, the name of the active input and position and size of the frame.

What will happen? A tick will appear next to this command when the Status Bar is On.

13.6.7 Command Window

Use this command to open the Command text window — or to activate it. You may also simply use
the short-cut <Alt+F2>.

Application. This command will open a text window for writing Imaging C and Macro functions.
Subsequently, these functions can be executed directly. Furthermore the window can be used as a
calculator. Simply preface any mathematical task with a question mark. The result will appear in the
next line of the Command Window.

Example. Entering ? 5*log(43.5)+100; will yield the result 178.863804690473.

Editing Command Lines, Executing Function. A ’greater than’ (>) sign at the left border indicates
the beginning of a command line. You can only edit the last current command line. Any lines pre-
ceding this last one can no longer be edited. Anything you’ve got in the clipboard can also only be
pasted into the last current command line. Command lines are ended with a semicolon. Press En-
ter to have the function of the current line executed. cell*R / cell®M will execute that function im-
mediately. The result(s) of any calculation will then be written in the next line of the Command
Window. You will receive an error message, e.g., if you have made a syntax error writing the Imag-
ing C function, if the function has too few parameters, or if the semicolon is missing at the end.

Pasting Preceding Command Lines. Preceding command lines can be neither edited nor exe-
cuted, but they can be pasted into the current line (for editing and execution). This can be useful,
e.g. if you've received an error message and you would like to make a correction. Simply position
the cursor at the relevant preceding command line. This line will be then selected in its entirety.
Then press Enter to have this line pasted into the current command line. After editing the incorrect
entry, you can re-execute the function.
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Saving Command Lines. In contrast to other document windows, the contents of the Command
Window cannot be saved using the Save As command. However, you can circumvent this prob-
lem, therefore, open a new standard text document and simply paste the desired command lines
via the clipboard into this text document. The text document can now be saved using the Save As
command.

o You can determine whether the Command Window is to be automatically activated by
an Imaging C output. Select Special » Preferences... or press <F8>. In the displayed
dialog box select the Module tab, and mark Activate on output in the Command
window field. This ensures that no output goes unnoticed - e.g., because another
document is covering it up. On the other hand, some Macros or C Modules use the ac-
tive sheet document for their calculations. If the Command Window is activated by an
output, this can interfere with the running of your program — because instead of a sheet
document being active, a text document is actually active. In this case, it’s sensible to
turn this automatic activation off.
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cell*R / cellM has its own macro or programming language: Imaging C. It is a variation of the

ANSI C standard, which has been expanded by a number of functions.

Why program in Imaging C? Imaging C offers the possibility of automating processes you use over
and over as well as expanding cell*R / cell®M by adding new image processing functions. You can
program your own macros using the integrated Imaging C Interpreter. This allows you to adapt im-
age-processing functions to your particular application needs. If you are experienced in using mod-
ern programming languages, especially Standard C, programming with Imaging C will not cause you
any difficulties. This way cell®R / cell®M can serve as a development platform for developing prob-
lem-oriented application(s). The new macros can be integrated into the graphical user interface and

used just like any of the other functions in cell*R / cell*M.
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14.1 General

The Special » C-Module menu contains commands for the administration of Imaging C modules. A
C module provides one or more C module functions. C modules are written using the macro lan-
guage Imaging C, translated so that the computer is able to understand it, and stored as files ex-
ecutable by cell*R / cell®M (extension SXU). C module functions enhance the functionality of
cell"R / cellAM and are seamlessly integrated into the user interface. It is not necessary to learn
Imaging C if you want to profit from C modules. There are a large number of ready-made C mod-
ules, which can be integrated into cell*R / cell*M without your having to know they are in fact C
module functions and not internal functions.

A C module consists of one or more files. The files are compiled, which means that they are proc-
essed in such a way that an executable C module (SXU) is created. Before generating this executa-
ble C module a Make-File (MKU) is necessary. A make file contains — among other things - a list of
the files comprising the C module.

The following file types are part of a C module:

File types
File name extensions meaning
sfm, ¢ source code
sft, h header (definition of variables and constants)
rc, dig resource (definition of dialog boxes)
mku make file
SXu executable file
SCX module configuration

Definition. Imaging C expressions will always be compiled automatically in the Interpreter Mode
when the expression is executed. cell*R / cell®M makes use of this mode in the following situa-
tions:

¢ when an expression is executed from the command window,
¢ when you use the macro commands Define Macro and Run Macro (in the Special menu).
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14.2 New Module...

Use Special » C Module » New Module... to create a new C module.

New Module E]
Madule
Current directory:
D:eell"RAM odule!
Directon,...
ot
Create sub directary
[ "Main" function
[ "Exit" function

MAP "Sample'" function
] "Onlritdenu’ function
Auto configuration
[ String table
[] Dialog box function

What will happen? The New Module... command lightens your workload when you wish to gener-
ate a new directory, then set up a source file (SFM) there and then have this file integrated into a
make file (MKU). The text of the source file (SFM) will be opened in its own text window within the
Graphical User Interface (GUI). The new module will automatically be compiled into an executable
file (SXU), then loaded and made into an active module.

What’s it for? The New Module dialog box is where you determine which key segments of the
new module source text are to be ‘givens’:

e the "Main" function,

e the "Exit" function,

e one of various MAPI 'Sample’ functions with varying properties (MAPI functions are the only
ones that can be used as menu commands).

o The various settings available in the New Module dialog box generate different source
texts. We recommend that you should try using these source texts when you first try
programming a C module - these can serve as examples.
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Adding source files to a new module

If the Create sub-directory check box is the only check box that has been selected, the Edit Mod-
ule dialog box will be opened. Here is where you can have files added to a C module. This allows
you to integrate existing source and definition files into a new C module.

Create sub directory, Current directory

When you have selected the Create sub directory check box, a sub-directory of the current direc-
tory will be created using the module’s name. You will see the current directory name displayed in
the Current directory field.

Directory...

The Directory... button is for opening a standard Windows dialog box where you can select an-
other current directory. In addition you can create a new directory or delete one you no longer
need.

"Main" Function

If you have selected the "Main" Function check box, the new C module will contain an initialization
function of this same name. The Main function of a C module is used when loading the C module.
If this function returns a value of -1, the loading procedure will be interrupted and the C module
closed. In general however, Main is used for the correct initialization of a C module. If an initializa-
tion of the C module is not necessary you can skip this function - i.e., the function does not even
have to be present.

Example Imaging C Code

int Main ()

{

return (TRUE) ;

}

"Exit" Function

If you have selected the "Exit" Function check box, the new C module will contain a de-
initialization function of this same name. The Exit function of a C module is used when a C module
is exited. If a de- initialization of the C module is not necessary, you can skip this function - i.e., the
function does not even have to be present.

Example Imaging C Code

int Exit ()

{

return (TRUE) ;

}
MAPI "Sample" Function

If you have selected the MAPI "Sample" Function check box, the new C module will contain a
MAPI function of the same name - i.e., Sample function.
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Various functions can be defined within a C module. It is only the MAPI functions however that can
be used as menu commands or inserted into a button bar. You can assign the description of the
MAPI function (which will appear in the status bar when the function is selected) to the respective
function description string. The first thing you enter into a MAPI function’s Function description is
the MAPI constant. This function description is located between the ‘head’ and ‘foot’ of a function.
It is enclosed by the following symbols: '<' and '>":

Example Imaging C Code

export UINT SampleFunction ()
<MAPI, IDM_SAMPLE, "Info in status bar", "Sample &function"s>

dlgOutput ("Hello World") ;
return IDOK;
}

Available. The check boxes beneath the MAPI “Sample® Function check box are only available
when the MAPI “Sample“ Function check box has been selected.

"OnlInitMenu" function

If you have selected the "OnInitMenu" function check box, the new C module will contain a func-
tion of this same name. The OnlInitMenu function of a C module is used when the program needs
to know whether a certain MAPI function is valid or not. This is important for MAPI functions that
have been integrated into a menu. If OninitMenu gives you MENU_DISABLE concerning this MAPI
function, the corresponding command is not available (will appear gray).

Example Imaging C Code

WORD OnInitMenu (WORD wMenulD)

switch (wMenulD)

{

case IDM_ SAMPLE:
return (MENU_ ENABLE) ;

}

return (MENU_ ENABLE) ;

Additional Constants

To make the availability of MAPI functions controllable using the OnInitMenu you’ll need to put the
constant MAPI_IDLECHECK at the 5th position within the definition instruction of the MAPI func-
tion:

Example Imaging C Code

export UINT SampleFunction ()
<MAPI, IDM_SAMPLE, "Info in status bar", "Sample &Function",
MAPI IDLECHECK>
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Auto configuration

If you have selected the Auto configuration check box, the new C module will contain a source file
(having the file name extension SFM) as well as a C-module configuration file SCX. This configura-
tion file contains the definition for a button bar of the same name as the module as well as contain-
ing the ‘T’ button. The MAPI function Sample function can be activated by clicking on this button.
When the new C module is closed the button bar will automatically vanish. It will reappear at its
previous location when the C-Module is loaded once again.

o If you desire to change the name of the MAPI function SampleFunction after the C
module has been generated, be sure not to forget to change the assignment of the
SampleFunction’s ‘T’ button as well.

String Table

Select the String table check box if you wish the new C module to support different languages. In
this case, the source text will contain the @-Operator instead of strings, and followed by a con-
stant, e.g., @ DM_SAMPLE in place of "Info in the status bar".

Example Imaging C Code

export UINT SampleFunction ()
<MAPI, IDM_ SAMPLE, @IDM_SAMPLE, @ (IDM_SAMPLE+1l) >

{

dlgOutput ( @IDS_MESSAGE) ;
return IDOK;

}

Dialog box Function
Screen shot Sample Dialog

Select the Dialog box function check box if you wish to have a look at sample programming of a
dialog box using Imaging C. What will happen is that a sample dialog box will be created, when you
activate SampleFunction.

Example Imaging C Code

#define IDD BEEP 100
#define IDD CHECKBOX 101
#define IDD_EDIT 102

MYDIALOG DIALOG 130, 72, 186, 76
STYLE DS MODALFRAME | WS POPUP | WS _VISIBLE | WS _CAPTION | WS_SYSMENU
CAPTION "Sample Dialog"
FONT 8, "MS Sans Serif"
BEGIN
DEFPUSHBUTTON "OK", IDOK, 133, 12, 48, 14
PUSHBUTTON "Cancel", IDCANCEL, 133, 30, 48,14
PUSHBUTTON "&Beep", IDD BEEP, 133, 50, 48, 14
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LTEXT "§Edit- Control:", -1, 6, 20, 51, 8
EDITTEXT IDD EDIT,60,18,54,12,ES AUTOHSCROLL
CONTROL "&Checkbox-Control", IDD CHECKBOX,
"Button",BS AUTOCHECKBOX,WS TABSTOP,10,41,71,10
END

/*"Callback" function of the dialog box*/
BOOL SampleDlgProc (HWND hDlg, UINT uMsg, WPARAM wParam, LPARAM lParam)

{

BOOL DbEnable;
switch (uMsg)
{
case WM_INITDIALOG:
dlgCenter (hD1lg) ;
CheckDlgButton (hDlg, IDD CHECKBOX, bCheck) ;
SetDlgItemText (hDlg, IDD EDIT, szText);
EnableDlgItem (hDlg, IDD BEEP, bCheck) ;
break;
case WM COMMAND:
switch (LOWORD (wParam))
{
case IDD_BEEP:
MessageBeep (MB_ ICONQUESTION) ;
break;
case IDD_CHECKBOX:
bEnable = IsDlgButtonChecked (hDlg, IDD CHECKBOX) ;
EnableDlgItem (hDlg, IDD_ BEEP, bEnable) ;
break;
case IDOK:
bCheck = IsDlgButtonChecked (hDlg, IDD CHECKBOX) ;
GetDlgItemText (hDlg, IDD EDIT, szText, sizeof (szText));
case IDCANCEL:
EndDialog (hDlg, LOWORD (wParam)) ;
break;
default:
return FALSE;
} // switch wParam
break;
default:
return FALSE;
} // switch uMsg
return TRUE;

}

o If you have set the language to German - before initiating the Module New... com-
mand - all comments of the source file of the new C module will be in German. Lan-
guage is selected in Preferences, in the Module tab (in the Special menu.)
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OK. Click on the OK button in the New Module dialog box to open a text document containing the
source code of the text.

How to assign a new MAPI function to the 'T’ button:

You have generated a new Imaging C module called "New" using the New Module... command.
You’ve selected the Auto configuration check box in the dialog box. This means that there is a new
button bar containing the "T" button — the SampleFunction can be initiated via this button. Within
the source text of the module you have defined a new function called "An_other".

1. To compile the new C-module use the Build Module (<F7>) command.

2. Select the Edit Button Bars... command (in the Special menu).

3. Select the module name in the Button Bars list. Then click on the Edit... button.

s 21.02. 2006
#define IDM_SAMPLE (IDM_USER + 1)

s
COMMENTS:
The Add-In manager browse= for this function to
di=play a long and a short description of this
nodule.

void ModuleComment ()
L
Version: St1.0. 100N
Copyvright ~tbo21.02 2006
Description: ~t",

"Imaging C Hodule 'exzample'"
*
{3

s
Created:
Changed:
Comnent : Sample MAPT function

-

export UINT SampleFunction ()
<HAPT, IDM_SAWPIE. "Info in status bar". "Sample &function":

{
dlgQutput("Hello World"):
return IDOK:

+ v

4. Select the "New" C module from the Command groups list. The Commands list will
now contain the SampleFunction entry as well as the name of the new function called
"An_other".

5. Select the "T" button in the New Button field.

6. Select "An_other" in the Commands fields.
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7. Click on the Modify button.

8. Once you click on OK the T button will be connected to the name of the new function.

9. Use the Save Module Configuration command to save this altered module configura-
tion.

Using this command will result in the previous module configuration being overwritten.

10. Use the Build Module (<F7>) command to now compile the C module again. When you
do this, any alterations made in the C-module configuration file SCX will be included in
the actual SXU of the C module.

e If you change the function description of a MAPI function, the configuration file does
not have to be adapted accordingly. All you need to do is have the C module re-
compiled using the Build Module (<F7>) command.

14.3 Open Module...

Open Module @E|
Look in: | [ ExcelDDE w o ¥ -
5 :
L |=¢

My Recent
Documents

Deskiop

"}

My Documents

-
My Computer  Fioe of types Module Formats v
"-;-'] [ &2dd madule to module s=arch path Info... ] [ Help ]
2

by Metwork.
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Use Special » C Module » Open Modaule... to load and activate a C module.

Application. The standard Windows dialog box for opening and saving files will be opened. Select
the path of the module desired in this dialog box. You can use either the MKU make file or the SXU
executable file to load and activate the module.

You may also use the Module Manager command to load and/or activate a module.
Definition
The reason you load a module is so that its functions are available to you in cell*R / cell*M.

Which modules do | have loaded? The modules you’ve already loaded are listed in the Loaded
list in the Module Manager.

What will happen? The module will be included in the Loaded list in the Module Manager. All
global and static variables of the C module will be initiated as well as the C module’s main function.
If this function results in a value of -1, the loading of the C module will be stopped. The C module
will be closed.

Definition. To be able to apply the following menu commands to the module, activate the module:
(the commands are) Edit Module..., Save Module Configuration, Add to Module, Build Module,
Close Module and Module Info.

Which module is the active one? Although several C modules can be loaded at the same time,
only one can be active. To check which one is currently active, have a look in the Active field of the
module manager or use the Module Info... command.

What will happen? The Open Module command will deactivate the C module that had been active
and will close it. This means that the previously active module is no longer loaded. The module will
be withdrawn from the Loaded list in the Module Manager and placed in the Other list.

If you use the Open button of the Module Manager however, the currently active module will not be
closed - it will simply be deactivated.

Activating a module without having to load. A module can be activated without actually having
to load it. To do this, simply use the <Ctrl+Shift> keys while clicking on the Open button in the
Open Module dialog box.

File name. The Module Formats file format is preset. This list contains the formats of the make files
(MKU) and of the executable files (SXU).

Adding module to module search path. If you’ve selected the Add module to module search
path check box, the directory name of the module will be added to the directories used for the
administration of the module manager. We recommend selecting this check box if you’re working
with a particular module frequently.

Info... Click on the Info... button to view information on creation date, which version and a brief
description of the module. The Module Info dialog box will be opened.
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14.4 Add to Module

Use Special » C Module » Add to Module... to add the active text document to the active module.

Available. This command is only available...

e when a C module is active,

o if there is a MKU make file for this module, and if
¢ atext document is open and active.

Before you use this command. Activate the module in question in the module manager. Then you
can check and see whether the module has a MKU make file using the Open... button in the Open
Module dialog box. Then activate the text document that you wish to add.

What’s it for? This command is for adding a text document to the active module - e.g., another
source text.

What will happen? If the document has already been saved as a file, the file will be inserted into
the list of C module files. If not, the Save Text as dialog box will be opened where you can enter a
name for the file. If the file is already in a module, a message informing you of this will be displayed.

14.5 Save Module Configuration

Use Special » Imaging C » Save Module Configuration to save the current configuration of the
Graphical User Interface (GUI) in the active C module.

Available. This command is only available...

¢ when a C module is active,

o if there is a MKU make file for this module, and if

e the current configuration contains a MAPI function of the active module.

Before you use this command activate the module in question in the module manager. Then you

can check and see whether the module has a MKU make file using the Open... button in the Open
Module dialog box.

Configuration file. The configuration of the Graphical User Interface (GUI) will be saved in the SCX
configuration file of the C module.
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Save Shared Configuration. Keep the <Shift> key depressed while you call up the menu. This
command will then turn into the Save Shared Configuration command. The information on which
MAPI functions of other modules will be included in the current Graphical User Interface (GUI) con-
figuration will be saved in the SCX file of the active C module. This will result in commands and
buttons of the active module being arranged in the correct order with regard to the commands and
buttons of the other modules. This is relevant for example if you have two modules sharing the
same button bar.

Definition. The term Configuration refers to the appearance and functions contained in the Graphi-
cal User Interface (GUI):

e menus and menu commands,

e Dbutton bars and buttons contained therein,

¢ key functions of the keyboard,

e macros and

e external programs.

On the other hand, the configuration does not contain the settings of the Viewport Manager or the

Image Manager. Individual dialog box settings and which modules are currently loaded are not part
of the configuration.

What’s it for? Use the command Save Module Configuration to assign a configuration to the cur-
rent module, or to replace the module configuration with the current configuration — if a configura-
tion has already been assigned.

Loading a C module. When loading a module, the MAPI module functions contained by the mod-
ule configuration will be added to the current configuration. The C-module will have to be recom-
piled in order for the alterations to the module configuration to be considered when you load the C
module.

Just as with all other alterations made on C module files, you will have to recompile the
C module so that these alterations will be considered when you load the C module.

Closing a C module. When you close a C module all functions of the C module contained by the
current configuration will be removed. This will happen if you have not cleared the On close remove
module functions from configuration check box - in the Module Info dialog box.
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14.6 Edit Module...
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Use Special » C Module » Edit Module... to define the make file of the active C module.

Available. This command is only available when...

e a C module is active and if
e there is a MKU make file for this module.

Edit Module - example.mku @E|
Lock i | £ example ¥ O & e E-

example, sfm

File name:
Filez of types | Macra [ sfm) -
Header files:
: 0 n:nl.lEeEe:-:arn nEeEe:-:arn nEe.:s:frn

“hizel odulebexamplehexample. sox

Before you use this command activate the module in question in the module manager. Then you
can check and see whether the module has a MKU make file using the Open... button in the Open

Module dialog box.

What's it for? This dialog box is for adding or subtracting files to the list of C module files. You can

also load files from the module list into the text editor.

Files of type, Add, Header files, Source files, Up, and Down. To add a file to the C module, first
select the file type (located in the Files of Type list) to appear in the Look in field. Select the file to
be added to the module from the file list and then click on the Add button — or simply double-click
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on the file in the file list. If the file has a file name extension of SFT, H or DLG it is considered a
source file and will thus be appended to the Header files list. If the file has another file name ex-
tension, it will be treated as a function source file and thus appended to the Source files list. If the
list position of the appended file is to be changed, you can adjust it using the Up and Down but-
tons.

Remove. To remove a file from the module, select that file and click on the Remove button. In this
case, Remove simply refers to the file being removed from the list. The file has not been deleted
from the disk.

Edit. To edit a module file select that file from either the Header files field or from the Source files
field and then press the Edit button. Or - you can simply double-click on the file in the list.

14.7 Build Module

Use this command to compile the active module.

Available. This command is only available when...
e a C module is active and if
e there is a MKU make file for this module.

You may also press the <F7> key.

Before you use this command activate the module in question in the module manager. Then you
can check and see whether the module has a MKU make file using the Open... button in the Open
Module dialog box.

What will happen? All files of the active module will be compiled. After the build process has been
completed without errors, an executable file will be stored on the hard disk with the same base
name as the modules make file and with the extension SXU. It will be stored in the same directory
as the make file (MKU) of the module. If no errors are reported, the build has been successful. All
functions, constants, types, and variables that are exported from the module can now be tested
from the Command Window or can be included in a configuration, e.g., in the button bar.

Canceling compiling. To interrupt compilation, use the <Curl> keys.
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14.8 Close Module

Use this command to close the active C module.
Available. This command is only available, if a C module is active.
Before you use this command activate the module in the module manager.

What will happen? If the module contains an Exit function, it will be executed. Values of all vari-
ables will be reset. MAPI functions will be removed from menus and button bars. These functions
can then no longer be executed via the command window.

Effect on other modules. Data and functions of other modules remain unaffected by this com-
mand.

Reloading modules. To reload the module, use the Open Module... command or the Module
Manager.

14.9 About Module

Use this command to view information on the active C module. Further, you can set whether mod-
ule functions are to be removed from the Graphical User Interface (GUI) configuration (or not) when
you close the module.

About Module E]

FEile name: D:cell "R M odulehexampletexample. mku

Application: analySIS

Last change: 21.02.2008, 15:33
Hel
TOOL wersion:  2.60.3 - 05.10.2005, &:44
Imaging C Module ‘example’
File: D:hcell " RAModulebexamplehexample. sxu
Wersion: 1.0.100
Copyright: 21.02 2006
Description:

On close remaowve module functions from configuration

Available. The command is only available when a C module is active.
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Before you use this command activate the module in the module manager.

On close remove module functions from configuration. This check box is only available if the C
module contains a configuration (file SCX) and there is a MKU make file.

Select this check box to have C module functions automatically removed from the Graphical User
Interface (GUI) configuration when you close the C module.

@ Any alterations you made will only become effective once you’'ve compiled the module.

14.10 Module Manager...

Use this command to manage C modules. You may also use the <Ctrl+Shift+F5> keys.

When do | use the Add-In Manager? The Module Manager command is for developers of Imaging
C modules. If you wish to load finished C modules then use the Add-In Manager command (in the
Special menu).

What’s it for? Both dialog box lists show all C modules. All these modules can be either loaded or
closed. Modules can be activated or deactivated. The following functions are available: Open
Module..., Build Module, Edit Module..., Add to Module, Module Info and Close Module. In
addition, you can enter the names of directories containing modules to be included in the two lists
in the Define search path for modules dialog box.

_* Module Manager, @

Loaded: Other:

EMOLIb ~ AsklmgSave »~
Autodatabase

ExcelDDE CleanReport
Black Dicam
efi Graing
tia b MIClass b
Directories... ] [ Abaut...

Module: D:\cell Ry oduleUnmising' U nmixing, sxu
File:

Active:

Dialog box description. This dialog box is non-modal - meaning that it can be kept open while you
use other commands.
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Loaded. All loaded modules are listed in the Loaded list. All functions of these modules are cur-
rently available to you. To load modules from the Other list, use the Load button. To load executa-
ble SXU module files, use the Open... button — or use the Open Module... command.

o Most modules can also be loaded and closed in the Add-In Manager. Some modules
will be automatically loaded: for example, when you load a configuration, use user-
defined measurement or statistical parameters or activate an image import filter. These
modules will be shown in the Loaded list, too.

Other. All modules fundamentally available to you for use are listed in the Other list - these mod-
ules are however closed. The functions of these modules are not available to you currently. To
close modules, click on the Close button or use the Close Module command.

The following modules are displayed in the lists:

e the active module

¢ all loaded modules

e all modules whose directories you’ve selected - using the Directories... button - in the Define
search path for modules dialog box

¢ all modules contained by the current configuration

¢ all modules registered in the Add-In Manager

e all user-defined modules (containing measurement and statistic parameters) registered in the
Install Modules with Statistics Parameters or Install Modules with Measurement Parameters dia-
log boxes

Remove. Click on the Remove button to close the module selected. After clicking on this button,
the functions of this module will no longer be available to you. This module will then be removed
from the Loaded list and placed in the Other list — if the module is included in a search path or
comes under one of the above list of criteria.

This button is only available if you've selected a module from the Loaded list.

Remove All. Click on the Remove All button to close all modules. Module functions will not yet be
available to you. All modules will then be removed from the Loaded list and placed in the Other list
- if the module is included in a search path or comes under one of the above list of criteria.

Load. Click on the Load button to load the module you’ve selected. The module’s functions will be
currently available. The module will be moved from the Other list into the Loaded list.

This button is only available if you have selected a module in the Other list.

Directories... Click on the Directories... button to include more modules from other directories in
the Other list. The Define search path for modules dialog box will be opened.

Open... Click on the Open... button to load a C module and activate it. The Open Module dialog
box will be opened.

Using the Open... button, however, the previously active C module will be only deactivated and not
closed.



318 Chapter 14 — Imaging C OLYMPUS

Build. Click on the Build button to compile the module selected. The button’s function corre-
sponds to the Build Module... command.

This button is only available if you have selected a module in either the Loaded or the Other lists.
Furthermore, there has to be a MKU make file for this module.

To interrupt compiling, simply use the <Ctrl+c> keys.

Files... Click on the Files... button to edit the module you’ve selected. The Edit Module dialog box
will be opened.

This button is only available if you have selected a module in either the Loaded or Other lists. Fur-
thermore, there has to be a MKU make file for this module.

Add File. Click on the Add File button to add the active text document to the module selected. The
File field indicates which text document is active.

The text can comprise for example another source text and contain definitions and/or a description
of module functions.

This button is only available if you have selected a module in either the Loaded or Other lists. Fur-
thermore, there has to be a MKU make file for this module. A text document has to be open and
active in the Graphical User Interface (GUI).

Module Info... Click on the Module Info... button to view information on the module selected. The
Module Info dialog box will be opened.

This button is only available if you've selected a module in either the Loaded or the Other lists.

Activate. Click on the Activate button to activate the module selected. The previously active mod-
ule will be deactivated.

This button is only available if you’ve selected a module in either the Loaded or the Other lists.

Deactivate. Click on the Deactivate button to deactivate the active module. The Active field indi-
cates which module is active. This module is the one you had either recently activated or opened -
it does not necessarily have to have been selected in one of the two lists. After you deactivate a
module, no C module will be currently active.

This button is only active when a C module is active.

Module. The Module field indicates the path of the module currently selected in either the Loaded
or the Other lists.

File. The File field indicates the path of the active text document. Using the Add button you can
add this text document to the selected module.

Active. The Active field indicates the path of the active module. Only one module can be active at
atime.
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14.10.1 The Define Search Path for Modules Dialog Box

Use this dialog box to have other modules — from other directories — shown in the module manager.

Look in: | ) example v Q9 ¥ = m,
e D - cell "R aduleb erample]
Add ] [ Delete Drown ] [ Help ]

Selected directories:

D:heell "R
D heel "R odule’,

What'’s it for? This is where you set up a list of directories containing the C modules cell*R /
cell*M is to search for. The directory itself and all sub-directories will be searched. All modules will
be shown in the Other list in the module manager. That’s where you can load, activate, edit and/or
compile modules.

Look in. Select the directory you want included in the Selected directories list from the Look in list
and field.

Folder name. The Folder name field shows the directory, meaning the complete path of the direc-
tory you have selected in the Look in field. You can keep the directory or enter another directory.
The complete path of this directory can be added to the Selected directories list.

Selected directories. The Selected directories list contains the paths of all directories whose
modules are shown in the module manager.

Add. Click on the Add button to add the path in the Folder name field to the Selected directories
list.

Delete. Click on the Delete button to remove the selected directory from the Selected directories
list.
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14.11 Browser...

Use this command in the Special » C-Module menu to obtain an overview of the symbols defined
in Imaging C. You may also use the <Alt+F12> keys.

The Browser dialog box is non-modal - i.e., you can continue working with other commands with-
out having to close this dialog box.

B Browser E]
Query
|
Type: | Function -
Symbol: w
Range: | Exported by Toal w
- N
[iescription
Tupe:
Defined ir:
Query

The Query group is where you enter the symbol you’re looking for. Select the type of symbol you're
looking for from the Type list (e.g., ’Function’, ’Internal Function’, ’Object Function’ etc). Enter the
name of the symbol you’re looking for into the Symbol field. You can use wild cards (™', ’?’) here.
Select where you are to find the desired symbol from the Range list (e.g., 'Exported by Loaded
Modules’). This list will then disappear and replaced by the German function names check box - if
you’ve selected the ’Internal Function’ type of symbol.

Definition. A Symbol can be a function, a structure, a union, an object, a variable, a dialog or a
constant.

Type. The Type list contains various types of symbols: ’Internal Function’, ’Function’, 'Structure
Type’, 'Union’, ’Object Type’, 'Variable’, 'Dialog’, ‘Constant’, and "All’.

Symbol. Enter the name of the symbol you're looking for into the Symbol field. If you only know a
part of the symbol’s name you can substitute an asterisk "’ for unknown text and for unknown
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letters substitute a question mark ’?’. Upper and lower case are not relevant when searching for a
symbol.

Range. The Range list contains the following search ranges for symbols: 'Callable in Interpreter
Mode’, ’Exported by Tool’, ’Exported by loaded modules’, ’Exported by Active Module’, 'Defined in
Active Module’, ’Defined in Interpreter Mode’. If you have selected the ’Internal Function’ type of
symbol the list will not appear. The ’Exported by Tool’ range, for example, searches for predefined
symbols.

Result. The Result field indicates the number of symbols found according to the settings of the
Query group. This list contains the names of the symbol(s).

Example
The ’Internal Function’ type and the "’ symbol will result in all internal menu functions.
Description

The Description group displays more detailed information on the symbols selected in the Result
list.

Edit. The Edit button is only available if you've selected a symbol from the Result list - this symbol
must have a source file. Click on this button to load the source file of the selected symbol in cell*R
/ cellAM. This file will be opened in a separate text document window. The cursor will appear right
at the spot in the text where the symbol is defined - and - the name of the symbol will be selected.

Copy & Paste. The Copy & Paste button is only available if a symbol has been selected in the
Result list. Click on this button to insert the name of the selected symbol into the active text docu-
ment. This name will be written into the text where the cursor is.

14.12 Find Symbol

Use this command to access the complete name of a symbol in the active text document.

Available. This command is available when a text document is open and active. You may also use
the <Ctrl+F12> keys.

What'’s it for? This command is for use when you’re programming in Imaging C and you don’t
know the precise name of a symbol — or the symbol’s name is extremely long. What you would do
in this case would be to, e.g., enter the first few letters of the symbol name you’re looking for and
then use the <Ctrl+F12> keys. A symbol name with these letters at its beginning will be written into
the text document. If the symbol name written into your text is not the one you were looking for,
use the above-mentioned keys once more (<Ctrl+F12>). Then, the next symbol name with these
letters at its beginning will be written into the text document. If you still haven’t found what you’re
looking for, simply continue to use the above-mentioned key combination - until you do find what
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you were seeking. You may want to try using other letters if you still cannot locate the desired
symbol name.

Where are symbol names searched for? Firstly, symbols are searched for among the symbols
defined in the interpreter mode. After that, the active C module will be searched. Lastly, the prede-
fined symbols in the ’Exported by Tool’ range are searched.

Upper/Lower case, Wild cards. When making a search request upper or lower case is of no rele-
vance. Any parts of a symbol’s name you don’t know can be substituted with an asterisk [*]; letters
you don’t know can be substituted with a question mark [?].

14.13 Goto Definition

Use this command to view the definition of a symbol.

Available. This command is available when a text document is open and active. You may also use
the <F12> key.

What'’s it for? This command can give you rapid access to the definition of a symbol when you're
programming in Imaging C. To do this, position the cursor within the symbol’s name in the text
document and then press <F12>. The source file will be opened in a separate text document win-
dow. The cursor will appear at the spot within the text where the symbol is defined — and the sym-
bol name will be selected. Nothing will happen if cell*R / cell®M does not find the source file. Just
as when using the Find Symbol command, all you have to do is enter the letters the symbol name
begins with - say, if you don’t know the precise name of the symbol or if the name of the symbol is
extremely long. Continue pressing <F12> until the definition of the symbol you're looking for is
shown.

Where are symbol names searched for? Firstly, symbols are searched for among the symbols
defined in the interpreter mode. After that, the active C module will be searched. Lastly, the prede-
fined symbols in the ’Exported by Tool’ range are searched.

Upper/lower case, Wild cards. When making a search request upper or lower case is of no rele-
vance. Any parts of a symbol’s name you don’t know can be substituted with an asterisk [*]; letters
you don’t know can be substituted with a question mark [?].
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14.14 Quick Watch...

Use this command to determine the value of the selected expression or variable during an error
search (i.e., debugging).

Available. This command is available when a text document is open and active. You may also use
the <Shift+F9> keys.

Before you use this command open the source text of the Imaging C module or macro. Position
the cursor on the variable whose value you wish to view. Use the Toggle Breakpoint command to
set a breakpoint within that line. Then initiate the function containing the expression or variable in
question: Imaging C functions of modules and programs are executed by you via a corresponding
MAPI function - e.g., use the menu command of the MAPI function. Execute macros using the Run
Macro command (in the Special menu) — or just press <F5> — or using the Single Step command (in
the Special menu) — or just press <F10>. cell*R / cell®M will move into the debug mode.

When is the debug mode active? As far as Imaging C programs are concerned, cell*R / cell*M
will switch over to the debug mode when it is executing a function and it encounters a breakpoint.
With regard to macros, cell*R / cell®M will also switch over to the debug mode if you execute the
macro using the Single Step command - instead of the Run Macro command. You’ll know the
debug mode has begun when the mouse cursor transforms into the shape of a hand.

What'’s it for? When you execute the function or the macro the expression will be selected in the
line containing the breakpoint. Now — to have a look at the value of the expression or variable — use
the Quick Watch command or simply press <Shift+F9>. You can then set another breakpoint and
continue execution of the program by pressing <F10>. To have a look at the value of that expres-
sion simply press again <Shift+F9>. The above is how you can work through the source text of
Imaging C programs and macros and be able to follow what values an expression occupies while
the program is being executed. It’s how to find programming errors.

The specified expression and its current value

If the expression selected consists of a variable, the current value of this variable will be shown. If a
value is undefined the following will appear: ’???’. This will apply, e.g., to the value of a non-
initialized pointer variable.

QuickWatch

Cloze
Add...

The gpecified expreszion and itz current value: Command...
{ digOutput] Hella Warld"L} = Taken ' Syntax ermor. Help
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Add... Use the Add... button to add the expression to the Expression list in the Watch Variables
dialog box. The Watch Variables dialog box will be opened if it wasn’t already. This dialog box is
non-modal, meaning that it can remain open during debugging. This enables you to track a vari-
able’s current value during the error search.

Command... Use the Command... button to compute the results of expressions and the values of
variables. The Command dialog box will be opened.

What’s it for? This dialog box is for reading out expressions and variables of the '?' operator - e.g.,
for converting a value into hexadecimal format.

Command

Expression:

Besult:

Symbol P Undefined variable

Expression, Execute, Result

The Execute button will execute the Imaging C expression in the Expression field. Do not put a
semicolon at the end of the expression. The value of the expression will be displayed in the Result

field.
Example
File types
Expression Oxff Hex (42) sin(P1/2) Imagel[1].Protect Image[2].Name
Result 255 2A 1.0000000 0 Aulabel

14.15 Watch Variables

Use this command to track the value of variables and expressions while searching for errors. You
may also click on the Add button in the Quick Watch dialog box.

How to add expressions in the dialog box. Expressions and variables can be either entered di-
rectly into the Expression field in the dialog box — or added via the clipboard (copy/paste) from the
source text when you’re looking for errors in this text. The easiest thing to do is to open the Watch
Variables dialog box first and add the expression in the Quick Watch dialog box (using the Add
button) to the Watch Variables dialog box.
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B Watch Variables @
Expreszion:

Expression Jist:

This dialog box is non-modal, meaning it can be kept open during debugging. This enables you to
track a variable’s current value during the debugging.

Expression, Add, Expression list

The Add button will evaluate the Imaging C expression entered into the Expression field and will
add the expression and its value to the Expression list. Do not put a semicolon at the end of the
expression. If a value is undefined the following will appear: '???’. This will apply, e.g., to the value
of a non-initialized pointer variable.

The Add button is only available if the Expression field contains an entry.

When will values be calculated? If the Watch Variables... dialog box is not closed and the de-
bugging process continues, the values of the expressions in the Expression list field will be recal-
culated once execution is halted (due to a breakpoint or due to single-step execution).

Delete. Clicking on the Delete button will delete the selected entry in the Expression list field. This
button is only available if the Expression list field contains an entry.

Delete All. Clicking on the Delete All button deletes all expressions from this list.

Command... Clicking on the Command... button will give you access to any expressions you
might need. The Command dialog box will be opened.

14.16 Toggle Breakpoint

Use this command to set or delete a breakpoint in the active text document. You may also use the
<F9> key.

Available. This command is available as long as a text document is opened and active.

0 Breakpoint
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In a text window, the symbol of a hand at the beginning of a line indicates a breakpoint.

Definition. When a command, for which a breakpoint has been defined, is executed the execution
of the Imaging C program or module will be interrupted. The definition at the location of the break-
point will be displayed and the Debug button bar will appear. The source text will appear in gray.
The mouse cursor will be transformed into the shape of a hand. The breakpoint icon will be trans-
formed into footprints.

e

In the Debug mode, this footprint icon will always appear in the line to be executed next. This en-
ables you to either view the value of a variable or to continue execution in single steps.

Possible breakpoint positions. Breakpoints can be set in any line. A breakpoint can however be
invalid. In this case, the breakpoint will be skipped and ignored. To locate invalid breakpoints have
a look in the Edit Breakpoints dialog box: a minus sign denotes an invalid breakpoint.

Valid breakpoints. Breakpoints are valid where Imaging C statement are executed - e.g.:

¢ initializations

o if, else, do, while, for

e closing brackets "}"

¢ lines ending in a semicolon if a statement comprises several lines

Skipping breakpoints. Here are the exceptions:
¢ pure definitions, such as the definition of a variable without a simultaneous initialization

e if an expression has not yet been translated by the Imaging C interpreter (not applicable to
loaded C modules)

e the closing bracket of functions
¢ if lines are to be skipped upon execution of the program

e if you’ve selected a condition (in the Condition dialog box) whereby breakpoints are to be
skipped

Moving on to next breakpoint. Using the Bookmark, Next command (in the Edit menu) or pressing
<F2>, you’ll move on to the next breakpoint. To move to the previous breakpoint use the Book-
mark, Previous command - or press <Shift+F2>.

Maintaining breakpoints after closing text(s). You do not lose breakpoints within a text as long
as you don’t close cell*R / cell®M - if there’s a source file. A source text document along with its
breakpoints can be closed, and then the source file can be reopened, at a later time. Breakpoints
will continue to be displayed.

If you save the source text, breakpoints will not be saved. The next time you open cell*R / cell*M,
all breakpoints will have been removed.
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@ Debugging must be terminated before you can close cell*R / cell*M. If you cannot
close the Imaging C program proper, then click on the Stop Execution button in the
Debug button bar.

You cannot terminate debugging by closing the source text’s document window, nor
by turning ‘off’ the Debug button bar.

14.17 Edit Breakpoints

Use this command to edit the currently set breakpoints. You may also simply press <Ctrl+b>.
Defining a breakpoint. Use the Toggle Breakpoints command to set a breakpoint.

What will happen at a breakpoint? When you execute an Imaging C program or module and
come to an expression where a breakpoint has been defined, execution will be interrupted. The
Debug button bar will be displayed, and the mouse cursor will be transformed into the shape of a
hand. The value of a variable can be tracked or execution can be continued in single steps.

Breakpoint list. The Breakpoint list displays all breakpoints defined using the Toggle Breakpoint
command. Breakpoints can belong to varying source texts. Once you close a source text its break-
points will remain undeleted only if the text has a source file.

Edit Breakpoints

Breakpoint list:
-E: D:heell "R oduletexampletexample. sfm, 1

The list shows the following on each breakpoint:
e breakpoint status

¢ path of the corresponding source file — if there is one — otherwise the name of the corresponding
text window

e line number of the breakpoint within the text document.
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Status
Status Meaning: breakpoint is
+ valid
- invalid
E enabled (active)
D disabled (not active)

Delete All. Click on the Delete All button to delete all breakpoints from the Breakpoint list and
from source texts. Deletion is not reversible.

Available. The following buttons are only available if you have selected a breakpoint.

Go To. Click on the Go To button to go to the breakpoint (you’ve selected in the dialog box) in the
source text. The text document will be opened if it had been closed. The line containing the break-
point will be colored.

Condition... Click on the Condition... button to determine a condition under which a selected
breakpoint is valid and when it is to be skipped.

Condition

Ok

Stop at breakpoint, when following
- o Cancel
expression is TRUE:

Example
Imaging C Code

If a breakpoint is, e.g., to only be valid if the value of variable "i" is greater than 10, and the value of

variable "j" is less than 10, the condition will have to be as follows:

(i>10) && (§<10)

Disable. Click on the Disable button to skip the selected breakpoint when executing the function.
The breakpoint will be turned ‘off’ (i.e., disabled) in the text document. The status of the breakpoint
in the Breakpoint list will go from E to D. As needed, you can reactivate the breakpoint.

Enable. The Enable button activates a deactivated breakpoint. The status of the breakpoint in the
Breakpoint list will go from D to E.

Delete. Click on the Delete button to delete the break point selected from both the list and the text
document.
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15 cell*M / cell*R Configuration

A special cell*M / cell*R Configuration Software, ObsConfig, is provided for the configuration of
the cell®M / cell*R Imaging Station components: for the lllumination System MT20 / MT10, the
motorized microscope components and for the optional PIFOC z-drives.

We recommend to use the cell*M / cell*R Configuration Software also for the optical alignment of
the arc burner and the illumination coupling to the microscope. Optical alignment with the cell*M /
cell*R Configuration Software is described in detail in Part B: Hardware Manual.

If your cell*M / cell*R imaging station is equipped with a motorized Olympus BX or IX series micro-
scope, please note that the configuration of the motorized microscope components is carried out
within the cell*M / cell*R imaging software as described in this chapter.

15.1  The lllumination System MT20 / MT10..ccccooiiiiiiiiieeiieeieeeee e 330
15.1.1  Configuring the Excitation Filters..........ccccovviiiiiiiieniieeeceeee 330
15.1.2 Burner Configuration..........ccoceeeeeeieenieeeeeee e 332
15.1.3 Using MT20 / MT10 without the Imaging Software .................... 333
15.2 Configuring the MIiCrOSCOPE ....ccevivuvriiiiiei e 333
15.2.1  General Configuration .........ccccvieeciiiiiiees e 333
15.2.2 Z-Drive Configuration..........cccceuieeeiiiiiiieiieeeririeee e 335
15.2.3 Configuration of the ObjJectives .........cocvereiiriiie i, 336
15.2.4 Configuration of the Fluorescence Filter Turret .........ccccceeeueeee.. 337
15.2.5 Configuration of the Transmission Contrast Inserts ................... 338
15.2.6 Configuration of the Filters of a Filter Wheel...........ccccccvveeeennnn. 339
15.3 Definition of IMage TYPES ...uuvieiiiiiiiiiiiiieeee e 340
15.4 Configuration of Additional Shutters .......c.ceeviiiiieiiiiiiiiiiieee, 342
15.5 Configuration of the PIFOC ..........cccciiiiiiiieneeeee e 343
15.6 Configuration of the Motorized Stage .......cc.cccvvveviieeiiiieeeceeee, 344
15.7 The UCB Control Box Light Panel ..........ccccooeiiiiiiiiiiiceeeeee 345
15.8 Parfocality Correction of Objectives.....cccccovecuiiiiieiiiiiccciiieeee e, 346
15.9 Configuration of the Dual-View™ Micro-Imager .........cccccvveeerrnne. 347
15.9.1  Configuring the Emission Filters .......cccccooiiiiiiiieiiiieciciieeeeeen 347

15.9.2 Configuring the Image TYPeS .....cccvvieeriieiiee e 349
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15.1 The lllumination System MT20 / MT10

15.1.1  Configuring the Excitation Filters

The excitation: filters are mounted in the filter wheel of the lllumination System MT20 / MT10 which
is accessible via the filter flap on the right side of the illumination system housing. The filter wheel
has 8 slots for different excitation filters and can be rotated so that each filter slot is accessible via
the filter flap.

Filter exchange and configuration of the excitation filters with the OBS System Configuration soft-
ware is described in detail in Chapter 7.3.3, Filter Exchange, of the Hardware Manual (Part B).

2% ObsConfig.exe

I oBs System Configuration

[ % Hlumination System | M Fiterwheel
General Excitation Filker Colar
% Excitation Filters ]
Burner 1: | 403 DAPI v| ] ,@
Full Contral —
Errars 2 | 492FITC v| | )
Microscope E £ __
Image Types a 3 |57 TxRed ~| L)
Shutter 2 o __
Image Splitter E‘ 4: 340 Fura : - &
Pifoc qE | -
stage I 5w § [ ©
2
E <] | W |
T 340 Fura
7 |380 Fura
403 DAPL
430 CFP
8 |470 GFP
492 FITC
500 YFP
572 TxRed
|
Ok ] [ Cancel
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In brief, start the cell*M / cell*R configuration software by clicking the ObsConfig.exe button and
go to the lllumination System » Excitation filter page. A gray arrow in the list of program pages
on the left hand side indicates the selection.

With the vertical slider bar shown in the dialog below you can rotate the filter wheel so that any of
the 8 filter wheel positions of the MT20 / MT10 light source is in the exchange position.

o It is not possible to run the cell®M / cell*R Configuration Software and the cellM /
cell*R Imaging Software at the same time

Open the filter flap on the right side of the illumination system's housing. The flap has a magnetic
closure, no tools are required for opening / closing. The filter slot 6 points to the flap opening in the
example above. The filter position number is labeled right above the filter opening. In case an exci-
tation filter in this filter slot has to be exchanged this can be done easily without any tools: the filter
is clamped with a metal clip onto the filter wheel. Pull out the filter with your hand while taking care
not to touch the filter's glass surface.

o Only optical filters with a diameter of 25 mm may be inserted into the filter wheel. All fil-
ters purchased from Olympus Soft Imaging Solutions are suitable. There are templates
on the inside of the filter flap, which can be used to check the appropriate size of an
optical filter.

Insert the new excitation filter into the filter wheel simply by pushing it underneath the
metal clips. This can also be done by hand. Again, be careful not to touch the filter's
glass surface.

The correct orientation of the filter with respect to the direction of the light path is in
most cases marked with a little arrow on the frame of the filter. The arrow has to point
in direction of the light fiber.

Excitation filter. In the configuration dialog select the inserted excitation filter from the drop list of
the current filter wheel position. The list offers many standard excitation filters provided by Olym-
pus Soft Imaging Solutions . If the inserted excitation filter is a special filter not listed here or if you
want to use a different name for the filter, you may just enter or change the filter name by clicking
into the edit field and typing the desired filter name. The filter name defined here will appear on the
respective switch button of the lllumination system MT20 / MT10 dialog in the cell®M / cell*R
Imaging Software (see Chapter 4.3, lllumination Control).

Color. The rectangular field adjacent to the filter name box shows the color of the switch button in
the lllumination system MT20 / MT10 dialog that will move the respective filter into the illumina-
tion path. Each standard excitation filter, which can be selected from the drop list, has a predefined
default color setting. You can change / define the switch button color by clicking on the color pal-
ette button to the right of the color field.

With the three slider bars you can adjust the Hue, the Saturation and the Brightness of the switch
button color, respectively. The Hue values can be set in a range between —60 and 280. Following

331
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the conventions, 0 corresponds to red, 180 to cyan. Each value has a corresponding wavelength,
indicated below the quadratic color field. The saturation and the intensity can be set between 0 and
1000 on an arbitrary scale. A Brightness of 0 results in the color black while a Saturation of 0
causes the color to be in a shade of gray. It is advisable to select the switch button color according
to the filter properties, i.e. according to the effective sample illumination color.

Edit Fluorescence Colon E|
N N — 4
Saturation | 1000 J
Brightness | 1000 J
[ 487mm
C o ] [ coea ]

Example. The selected GFP filter has a center transmission wavelength of 492 nm and thus trans-
mits excitation light of turquoise color. Set the hue to a value of 185. The corresponding wave-
length will be 492 nm and the switch button will be cyan.

Before the filter wheel can be rotated via software to another position to exchange / insert addi-
tional filters the filter flap needs to be closed. After closing the filter flap, the filter wheel is initialized
(this takes approx. 5 sec). After this is done the green STATUS diode on the MT20 / MT10 front is
turned on. Then the filter wheel can be rotated into the next position for insertion / exchange of
another filter as described above.

15.1.2 Burner Configuration

The lllumination System » Burner dialog is used for configuration and optical alignment of the
burner after installation and/or exchange. This is described in detail in chapters 7.3.1 and 7.3.2 of
the Hardware Manual (Part B).

Display message. You can activate a display warning message, which reminds you that the burner
is still turned on, if you want to exit the cell*R / cell®M Imaging software.

Display warning message if user is logging out and
burner | lightsource is still switched on
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15.1.3 Using MT20 / MT10 without the Imaging Software

You can operate the lllumination System MT20 / MT10 with the dialog box lllumination System
» Full control without using the cell*R / cell”M Imaging Software, that is, you can switch the
burner on and off, change the excitation filter and the illumination intensity.

15.2 Configuring the Microscope

In case the microscope is not listed in the OBS System Configuration window right-click on the
ObsConfig symbol in the upper left corner and select Components in the context menu that opens
and then click on the Microscope check box in the Select components... window that pops up.
The microscope configuration is required for the operation of the motorized microscopes IX81 and
BX61 via the cell*R / cell*M software. For the non-motorized microscopes it is recommended to
configure the objectives here as well.

Select components... @l

o LightSource
Components Microscope

Imagetype

Shutter

Mave [ tmanesplitter

[ Pifoc

- Minimize Stage

[ optiGrid

X Close Alt+F4

) Ok l [ Cancel
About ObsConfig. ..

15.2.1  General Configuration

Type. Select the type of microscope from the shortlist.

Connectivity. In case of a motorized microscope (IX81 or BX61) select the serial port of the imag-
ing PC that is connected with the universal microscope control box (UCB) from the shortlist.
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% 0Bs System Configuration

Ilumination gys.tem.f Type
General Fa =
Excitation Filters 1 &5
Hllcner Conneckivity
Full Contral
el [comt v/
& Microscope L |
% General chutter
Z-Dirive
Objectives Transmitted :#: [Creflected 1
Filker Cubes
Contrast Inserts Lightpath
Filbars: | [ ) e
Image Types Bottom Port 4., Prism 2o [t
Shutter
Image Splitter e
pioc .| T
Stage Transmission Lamp L;'J
[ Ok ] [ Cancel ]

Shutter. If the transmission light path of an 1X51/71/81 microscope is equipped with a shutter se-
lect Transmitted. This is not available for the upright microscopes BX51/61. cell*R and cell*M do
not feature a reflected light shutter at the microscope frame. The corresponding shutter is integral
part of the illumination system MT20 / MT10. Consequently the option

Reflected should remain deselected. The selected shutters can be operated with the respective
buttons.

Lightpath. In the IX81 microscope it is possible to switch the image light path between a standard
camera side port and a camera bottom port. To activate this option select Bottom port here. Like-
wise in the IX81 it is possible to switch electronically between the camera and the ocular. To acti-
vate this option select Prism here. The selected modules can be operated with the respective
buttons.

Lamp. The transmission lamp can be switched on here by clicking on the button without having to
start the cell*R / cell*M software; the intensity can be set by moving the slider.
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15.2.2 Z-Drive Configuration

I oBs System Configuration

Illumination System | Z-Drive

General Z-Drive Available Limits Full
Excitation Filters Range Range
Burner ~ ~
Full Control
o
% Microscope

General M
Objectives
Filter Cubes
Conkrast Inserts Z 3
Filters L

Shutter Limits

Image Splitter Lpper Limit: | 30000.0 | prm [Set Current Pgsitign]

Image Types

Pifoc Lower Limit: | 0.0 [ Set Current Position
Stage
Full Range

70C
[z available

[ k. l [ Cancel ]

Z-Drive available. Activate the motorized Z-drive by checking the box if the microscope is
equipped with one.

Position box and range sliders. The box displays the current Z-drive position. You can move the
Z-drive by typing in a new position or by using the sliders. The Z-drive can be operated within the
set limits (see below) with the Limits range slider. The dark gray bars to both sides of the Full
range slider indicate the current range. If the Full range slider is moved beyond the limits the fol-
lowing message will appear:

ObsConfig,

1 'j ¥ou are going to exceed the limits? Do wou wank to extend the limit?
-

| es |[ Mo ]

Limits. The screenshot shows typical settings for an IX81. The values have to be optimized for
each individual setup.
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o By carefully setting the stage limits one can avoid driving the objective accidentally into
the specimen. In case of an inverted microscope, for example, the topmost position of
the Z-drive should not lift an oil-immersion objective with short working distance more
than a fraction of a millimeter above the level of the stage. Otherwise damage to the
objective and the specimen could result. If the upper limit is too low, however, focus
cannot be reached.

In case of the IX81 the nosepiece is the moving part, in case of the BX61 it is the stage.
For both the lower limit is uncritical while the upper limit has to be set carefully. For the
BX61WI with fixed stage the moving part is the nosepiece and the situation is vice
versa: the lower limit is the critical parameter.

Lower Limit. For both the inverted microscope IX81 and the upright BX61 the lowest possible
position, 1, can be set without causing any problems, see the note above. In case of the fixed stage
upright microscope BX61 the value has to be set so that focusing is possible but the objective
cannot be driven into the specimen.

Upper Limit. For both the IX81 and BX61 this value has to be set carefully, see above, so that fo-
cusing is possible but possible damage to the objective is avoided. For the BX61WI the highest
possible position can be set without causing any problems.

ZDC Available. Click here f a Z-Drive Compensation (ZDC) device is part of the system.

15.2.3 Configuration of the Objectives

Nosepiece. Check here if a Motorized nosepiece is available to be able to use it via the cell*R /
cell"M software.

Objectives slider. You can use the slider to move any of the mounted objectives into position with-
out having to start the cell*R / cell*M software.

Magnification. Set the objective magnification by selecting from the shortlist.
Name. Select the objective name from the shortlist or type in a name.

N.A. Type in the numerical aperture of the objective. If a standard objective is used, the N.A. will be
set automatically once Magnification and Name have been set.

Correction. If a camera mount with optics that change the magnification is used type in the correc-
tion factor here. By default the value is 1.0.

Magnification changer. The IX71 and IX81 microscopes have a manual () slider in the frame that
allows increasing the objective magnification by a factor of 1.6. Check the 1x / 1.6x option if this
feature is available.
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= 0BS System Configuration

Mosepiece

General Motorized Mosepiece Available

Excitation Filkers

Burner Ohbjectives

Full Contral Magrnification  Mame M.A. Refraction  Correction

Ertors 1[e0 | [PLaro 7 [ta ] [0 ] [to ]

% Microscope ¥

ceneral 2 |40 v| |uaro v [133 | |10 | |10 |

Z-Drive L

O S S
“eruhes 3|20 v| |uPLapo v| |07 | [1.0 | |t |

Contrast Inserts

Filters 4100 v| [PLAPO vl |14 | |10 | [to |
Image Types e i ad: SR o
Shutter 5 |Skp v | | |
Image Splitter
Pifoc & [Skip | | | | L _|
Stage B
OptiGrid Magnification Changer

) Mone Elxfl6x
Ok ] [ Cancel

15.2.4 Configuration of the Fluorescence Filter Turret

Fluorescence Turret. If a motorized fluorescence turret is available, select it from the shortlist to
be able to use it via the cell*R / cell*M software.

Shutter. This button is available only if the IX2_FRFACA is selected. It moves the turret to a shutter
position and back.

Filter cubes slider. You can use the slider to move any of the mounted fluorescence filter cubes
into position without having to start the cell*R / cell*M software.

Filter cube names. Type in a name for each mounted filter cube or select a name from the shortlist.
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% 0Bs System Configuration

Ilumination System | Fluorescence Turret
General | Turret (1x2_FRFACA) v|  shutter :#_
Excitation Filkers :
Burner Filker Cubes
Full Contral L | DapiFiccT:Red v |
Errars
% Microscope
General
Z-Drive
Objectives
B8 Filker Cubes
Contrast Inserts :
Filkers 5 | Skip v |
Image Types
Shutter & | Skip ~|
Image Splitter
Pifoc
Stage

Ok ] [ Cancel

15.2.5 Configuration of the Transmission Contrast Inserts

Condenser. Check here if a Motorized condenser is available to be able to use it via the cell*R /
cell*M software.

Contrast inserts slider. You can use the slider to move any of the mounted contrast inserts into
position without having to start the cell*R / cell*M software.

Contrast insert names. Type in a name for each mounted contrast insert or select a name from the
shortlist.
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B2 0BS System Configuration

Illumination System Condenser
General Matarized Condenser Awvailable
Excitation Filkers

Eurner Contrast Inserts

Full Contral . 1 [ph3 I |
Eirors | et _ |
% Microscope 2 | Phz 3|

General I S
Z-Drive 3 | Darkfield |
Ohijectives L - _'\
Filter Cubes 4 | free ¥

L@ _ontrast Inserts —
Filters 5 | Skip ¥

Image Types r

Shutter | i _Sk.ip ¥|

Image Splitter

Pifoc

Stage

Ok ] [ Cancel

15.2.6 Configuration of the Filters of a Filter Wheel

Filterwheel. Select here if an additional filter wheel is available to be able to use it via the cell*R /
cell*M software. The illumination system MT20 / MT10 features an integrated filter wheel and no
additional filter wheel is necessary in the Reflected light path. If a transmission light filter wheel (not
to be confused with the contrast inserts turret) is mounted select Transmitted from the shortlist. If
an emission filter wheel is mounted select Observation from the shortlist.

Filters slider. You can use the slider to move any of the mounted filters into position without having
to start the cell*R / cell*M software.

Filters names. Type in a name for each mounted filter or select a name from the shortlist.
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I oBs System Configuration

Illumination System | Filterwheel
General
Excitation Filkers
Eurner
Full Contral
Etvars

% Microscope
General

| Observation (L_FFO) v
Filters Hat used

Z-Drive 3 | U-IFss0 v|
Ohjectives ;
Filker Cubes 4 | Skip |
Contrast Inserts =
¥ Filers 5 | Skip v
Image Types
Shutter & | Skip ¥
Image Splitter
pifoc % (B2 |
Stage - 1
8 | skip ¥

Ok ] I Cancel J

15.3 Definition of Image Types

The definition of image types corresponding to certain excitation wavelengths is important for the
set-up of experiments with the Experiment Manager and for the display of images onscreen.

Image Type. The Experiment Manager will use the names given in the Image Type fields of the
dialog box. Also, the resulting color bands of multi-color images will have the image type name.

lllumination / Excitation Filter. An image type has always to be connected with one of the excita-
tion filters defined in the lllumination System » Excitation Filters page, see Chapter 15.2.1, Con-
figuring the Excitation Filters. If, to follow the example in the screenshot, a TxRed image icon is set
in an experiment plan, the filter wheel automatically moves to position 3, which holds the corre-
sponding filter named 572 TxRed, before the image acquisition starts during the execution of the
experiment. An exception, obviously, is the image type Transmission, which does not rely on the
fluorescence illumination system MT20 / MT10 and any excitation filter.

Shutter. Image types based on the usage of the illumination system MT20 / MT10 automatically
result in the opening of the shutter before the image acquisition and its closing immediately after-
wards. The MT Shutter will be set by default in the Shutter field in these cases. However, if the
transmission light path of the microscope is, for example, equipped with a shutter it has to be se-
lected from the pick list here.
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B2 0BS System Configuration

Hlumination System |  Image Type Turrination Shutter Filter Cube Observation  Fluorescence
I | Excitation Filker Emission Filker Color
eneral : ; 3
Excitation Filers Dapi 403DAFT v |[MTshutter || DapFitcTaRed v || empty vl & @~
Burner I o -
Full Control | Fite | | 492 FITC ~ || MT Shutker w | | DapiFitcTsRed s | | empty w | @
Eorors | i - B L
"eposcope TxRed |[s7zTared  v|[MTstutter v [DapFi I N
piFitcTxRed  w | | empty v (73]
General : 11 L I 11 : J E
2-Drive i il I &l
Indo40s Indo * || MT Shutker + || Indo v | | Indo405 w (73]
Chjectives L 1 L L s J E
Filter Cubes 1 I 1
Indo485 Indo v | | Indo W | | Indo485 v |
Contrast Inserts 1L - | BREEG . = L - - @ m
Filkers T Tem — T — -
4 Image Types |TIRFGFF || fres || TIRF 1 (|| TIRF GFP || empty v |
Shutter el e = L .
Image Splitter TIRF Cy5 free v ||TRF 2 ||| TIRF cys || empty | e T
Pifoc i =i i 2 £
Stage Trans Transmission | [ Mic Shutter Trar » | | empty ~l | empky | @ 'ﬂm‘ v
[ Ok ] [ Cancel ]

Filter Cube. This column is active only if the microscope features a motorized fluorescence filter
turret and if it has been configured on page Microscope » Filter Cubes. The fluorescence filter
cube that matches the excitation filter of the image type has to be selected here so that it will be
moved automatically into position for the image acquisition.

Observation / Emission Filter. This column is active only if the microscope features a motorized
observation filter wheel and if it has been configured on page Microscope » Filters. The emission
filter that matches the excitation filter and filter cube of the image type has to be selected here so
that it will be moved automatically into position for the image acquisition.

Fluorescence color. The Fluorescence Color, which can be defined in the exact same way as
described for Excitation filters (see Chapter 15.2.1, Configuring the Excitation Filters), determines
the color of the image acquisition command icon in the Experiment Manager and, more important,
the color with which, here, TxRed images (or color channels) will be displayed onscreen. In the
example a black-to-dark orange color palette will be used. If no color is selected a black&white
(gray scale) display will be used.
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15.4 Configuration of Additional Shutters

Additional shutters, which are not integral parts of the IX81 or BX61 frames (those are configured
on the Microscope » General page, see chapter 15.3.1), have to be configured here.

B oBs System Configuration

Illumination System
General
Excitation Filkers
Eurner
Full Contral
Errars
Microscope
General
Z-Drive
Objectives
Filker Cubes
Zonkrast Inserts £ 4 25
Filkers TIRF 2 TTL Part 2 b OPEM = low v
Image Types ] i
'S
Image Splitter
Pifoc
Stage

Shutter Type Connection Palarity Transmission

| TIRF 1 | |TTLPort 1 ~| | OPEN=low ~|

[ Ok ] [ Cancel ]

Shutter Type. Type the name of the first additional shutter in the first available slot. The first shutter
slot automatically lists the shutter of the illumination system MT20 / MT10 if it is selected on the
lllumination System » General page; the first entry row is not accessible. If a shutter has been
configured on the Microscope » General page (see chapter 15.3.1), it will automatically be listed in
the second shutter slot; the first entry row is not accessible in that case.

Connection. Select the trigger port (on the imaging PC front panel) that is connected with the shut-
ter via a BNC cable.

Polarity. If the shutter is triggered to open with a TTL high pulse select OPEN = high, otherwise
select OPEN = low. If in doubt check the specifications of the manufacturer.

Transmission. Check here to make the shutter available for image types with Transmission as
setting in the lllumination / Excitation Filter column in the Image Types page, see previous chap-
ter.
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15.5 Configuration of the PIFOC

Use the PIFOC dialog for the configuration of an optional piezo-electric objective drive or nose-
piece drive called PIFOC ("piezo focus").

E oBs System Configuration

Illumination System | General

Gen.erafl 3 Pifoc Available
Ez::eartlon et (O Upright Microscope
Full Contral (®) Inverted Microscope
Errors B=noe
Microscope Masdmumn Limit; | 100.00 i
General L
g;z:;ves Step width: | 0.50 | m
Filter Cubes Mave
Contrast Inserts
Filkers Current Position
Image Types 0.00 i
Shutter 1 |
Image Splitter !
e pifoc | | | rounts
Stage

[ Ok ] [ Cancel ]

General. First you have to select if a PIFOC is available and whether an upright microscope or an
inverted microscope is used. The selection determines the convention of the objective movement.
This means for an inverted microscope that an upward movement of the objective is displayed as a
positive movement.

Range. The Maximum limit defines the maximum traverse path and the Step width of the PIFOC.
A standard obijective drive has a range of 100 nm while a nosepiece drive has 80 nm.

Step width. This parameter defines the step size when the respective slider is moved in the lllumi-
nation Control window upon mouse click, see Chapter 4.3.

Move. The scroll bar represents the traverse path of the PIFOC. You can move the PIFOC within
these limits either stepwise by clicking on the arrows or via mouse scrolling.
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15.6 Configuration of the Motorized Stage

cell*R / cell®M currently support a number of motorized stages by Marzhduser GmbH and Prior
Scientific Instruments Ltd, see the screenshot below. In order to address a stage via software, it
needs to be configured by use of the Stage dialog.

% 0Bs System Configuration

Illumination System | T¥Pe
General
Exccitation Filkers =0 : e aaneaal
Burner
Full Control
Errars

Microscope .
General (el D | 24 s
Z-Drive
Objectives Acceleration S04 sz
Filker Cubes
Contrast Inserts Calibration
Filkers

Image Types

Shutter

Image Splitter

Pifoc Position Loop Z-device

g 5tage | 5l

Speed

Z-Drive

[ Ok ] [ Cancel ]

Type. Select the stage type from the shortlist. If the stage is properly connected, this will be stated
as Connected in the box on the right side. Otherwise it will show Disconnected.

Priot Pro Scan I1: *H 107" 1% > G

Mone

_ |Corvus: Maerzhaeuser "Scan IM" Ix
Corvus: Maerzhasuser "Scan 100x80" B
Corvus: Maerzhasuser "Scan & Slides" BX —

mmy's

Jerahon . ——— J | L mmys?

Speed. The maximum possible Velocity and Acceleration the selected stage can deliver will be
set by default. However, for certain applications it might be advantageous to decrease these set-
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tings, for example, to minimize vibrations. This can be done by using the sliders or typing the new
values into the corresponding boxes.

@ The Velocity and Acceleration settings do not affect the joystick and are relevant only
for experiments carried out with the Experiment Manager.

Calibration. The calibration of the origin of the stage coordinate system and limits can also be
done in the cell*R / cell®M software and is described in Chapter 4.5.3, Calibrating the Motorized
Stage, in detail.

Position loop Z-device. It is possible that a cell*R / cellAM imaging station contains more than
one motorized Z-device, for example, an objective PIFOC or a nosepiece PIFOC. Select the device
from the shortlist that shall be used for the change in Z-position when using the Stage loop com-
mand in the Experiment Manager.

15.7 The UCB Control Box Light Panel

The light panel on the UCB control box indicates the functioning of the various components. It can
provide valuable information in case of difficulties. For a detailed description of the single LED’s,
please see the Olympus user’s manual.

Green signifies OK; blinking signifies a problem. A LED that is not switched on signifies the ab-
sence or incorrectness of the component. The red ERR ("error") light indicates that a component
has been incorrectly plugged in.

An orange RMT ("remote") light signifies control by the PC. If it blinks the PC connection cannot
be established.

Please check the status on the light panel of the UCB in case of software problems for an appro-
priate diagnosis.

1. Exit the software and shut off the UCB controller.

2. Switch on the UCB controller box ONLY.

3. Check the status of the light panel. Any problems indicated by blinking lights are of
physical nature on the microscope itself. Please refer to the respective Olympus manuals
(IX2-UCB2 or BX-UCB) to troubleshoot such microscope problems.

4. If the light panel displays no error, then start up the software.
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5. Click on the Log On button in the IX (BX) button bar and login.

6. Check the microscope configuration and compare the entries with the components pre-
sent on the microscope; correct if necessary.

7. Check the definition of the key configuration; adjust where necessary.

8. Now you may continue working with the microscope via software control.

15.8 Parfocality Correction of Objectives

Parfocality Correction (z) E]

C To calibrate the focus difference between your
\}) microscope objectives:

1) Select any objective

2] Use the Live mode and focus your sample

3 Press the "Read” buttan

) Repeat the abowve steps for all remaining objectives

Objective Correction Position

The absolute position of the focal plane will always slightly differ from one objective to the next. In case of
microscopes with motorized z-drives and nosepieces it is possible to automatically correct the individual
offset. Once done, the objective can be switched without loosing focus. This function is available in the
cell*M /cell"R software, not in the configuration software ObsConfig.exe.

1. Select Acquire » Parfocality Correction (z)... in the cell®M / cell*R software. The Par-
focality Correction (z) window will open.
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Start the camera Live mode and focus the sample.

Press the <<Read button. The current z-drive position will be set in the Position box.

Click the next Objective button in the window Parfocality Correction (z). The nosepiece
will move this objective into position.

Focus again.

Press the <<Read button. The new z-drive position will be set in the Position box of the
chosen objective.

7.

Press OK when the correction is completed for all objectives.

The set differences in parfocality will be considered in experiments involving the switch of objectives.

15.9

Configuration of the Dual-View™
Micro-Imager

This optional device may not be part of your cell®M / cell*R Imaging Station.

15.9.1

Configuring the Emission Filters

Open the ObsConfig software and go to page Image Splitter.

The empty square button gives the default setting for systems without Micro-Imager. The beam-
splitting function in the cell*M / cell*R software is disabled.

Vertical split. Click this button if the Dual-View™ Micro-lmager is aligned relative to the camera so
that the image is split into a left and a right half.
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OLYMPUS

I oBs System Configuration

Tllumination System | T¥PE
o LIIHEH
Excitation Filters
Burner
Full Control
Errars

Microscope

Image Types

Shutter

% Image Splitter

Tvpe

OmEH

Filters

Configuration 1

Inda 405 Indol 2 @ 485 Indod I | @

Configuration 2

Horizontal split. Click this button if the Dual-View™ Micro-Imager is aligned relative to the camera
so that the image is split into an upper and a lower half.

Type

OmeEHs

Filkers

Configuration 1

CFRVFP 470 CFP v |: )
535 YFR ~ |:

Filters. Select a filter from the shortlist or type in a filter name and select a color for each image half
as described in Chapter 15.1.1, Configuring the Excitation Filters. This color will be used for the
display of the corresponding color channel in the dual-color image resulting from the overlay of the
two halves.

Quatro Split. This button is needed to configure a Quad-View™ Micro-Imager.
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15.9.2

1. Make sure that the necessary excitation filters and the filter cube are defined on the Ex-

Configuring the Image Types

Chapter 15 - cell®M / cell*R Configuration

citation Filter and Filter Cube pages, respectively.

2. Go to page Image Types.

3. Create Image Types for the acquisition of images containing the two emission channels

generated by the Dual-View™ Micro-Imager.

4. Select the correct lllumination / Excitation Filter and Filter Cube.

5. Select Image Splitter as Observation / Emission Filter and confirm the settings with

6. OK.

General
Excitation Filkers
Burner
Full Contral
Errars
Microscope
General
Z-Drrive
Ohjectives
Filker Cubes
Contrast Inserts
Filters
s
Shutter
Image Splitter
Pifoc
Stage
OptiGrid

Image Type Illumination Shutter Filter Cube Cbservation  Fluorescence
Excitation Filter Emission Filker Calor
[ Dapi |[403Dar1 v ||mTshuter v || DapFitcTaRed v || empty vl & o+
[ Fite |l4szFmc |[MTshuter  v||DapFtcTaRed || empty v/ 9| @
| TxRed | | 572 TxRed v | |MT shutter v_| | DapiFitcTxRed | w | | empty v i- _@J “@_J
[crrspic || 4a0crp [T shuerer || crRivEP v || crepvep v|— |
[vFpspit || 500 v | [mr shueeer || cRRivEP v || crrrvre v — | @

[ 1]
[ 1

— 2l 5
— =l 8
el

Ok ] [ Cancel
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Installing the cell*M / cell*R

The cell’R / cellM Imaging Station will be delivered with the software installed. However, in case of
software updates a new installation is necessary. Several administrative requirements have to be

fulfilled for the system to function without problems.

16.1 Updating the cell*M / cell*R Software.............
16.2 Updating the cell*M / cell*R Hardware Control
16.3 Selecting the Camera........cccccveeeiiiiiiiiiieeneeen,
16.4 Single-User Systems (Administrator Users) .....
16.5 Multi-User Systems .......ccccveeiieiieiiieeeeeeeee
16.6 PC-to-Controller Network Connection..............
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o Usually cell*M / cell*R is installed on the hard disk's large D:\ partition where the ar-
chive for the image data sets is located by default as well.

In case you want to install a virus scan software on the cell*M / cell*R imaging PC,
be sure that tiff format files are not scanned. Otherwise the performance of the system
will be considerably hampered because the new images generated in an experiment
are tiff files and to scan them is very time-consuming.

16.1 Updating the cell*M / cell*R Software

o It is not necessary to uninstall the older version first! However, if you decide to un-
install the software, first start the OBS System Configuration software (ObsCon-
fig.exe), go to the burner page and deactivate the option Display warning message if
user is logging out and burner / light source is still switched on. Otherwise the un-
installation will not be completed because an active dll file will be detected.
Make a back-up copy of the ObsConfig.xml (in the cell*M / cell*R folder) before start-
ing the software un-installation. Use it to replace the blank ObsConfig.xml created
when installing anew. You thus avoid having to reconfigure the entire hardware.

1. Run the Setup.exe that is to be found on the cell®M / cell*R 3.0 DVD. Use the existing
cell*M / cell”R folder on the hard disk (usually on the large D: partition) as destination for
the installation.

2. Select Install software in the setup window.

3. Accept the License Agreement in the next window by clicking Yes.

4. Select cell®M / cell*R in the Package Selection window and click Next >.

5. The setup routine will detect an existing cellM /cell*R program. You can choose be-
tween Update and New Installation. The Update installs new files and new versions of
existing files but keeps unchanged files. The New Installation overwrites all existing
files.



cell™ & cell® software Manual Chapter 16 - Installing the cell®M / cell*R Software 353

S Olympus Cell Setup Q@@
Software

Documentation

Acrobat Reader

Network software protection key
Explore this CD

Quit

o If you select New Installation make a back-up copy of the software configuration file
ObsConfig.xml that contains the information about excitation filters, image types etc.
Thus you avoid having to go through parts of the configuration steps described in
Chapter 15.2, The Illlumination System MT20 / MT10 anew.

6. Next, you have to fill in the customer information and confirm it.

7. In the Display Device Selection window you have two options:
a Single Screen (Windows Display).
Use this option if the system features only one monitor.
You can also use it in case of two monitors. The cell*R / cell*M interface window can
simply be dragged open to cover both screens. Together they behave as if they were
one big screen. It is convenient, in this case, to place the Viewport in the second
monitor while all control windows and the database remain in the first.

b Dual Screen (Dual Screen Win). If the system has two monitors, you may choose this
option. The second monitor will then be filled out entirely and unchangeable with a
second Viewport. The Viewport Manager allows switching focus from one to the other
Viewport via mouse click.

8. Click Next > and decide if you want the Life Science Demo database from the second
CD to be installed. Click Next >. This database has not changed in the new version and
there is no need to install it anew.

9. In the following three windows choose the Destination Folders where the program files
are to be written, image files are to be stored and image databases are to be saved. The
setup will suggest the existing folders, probably D:\cell*R(M), D:\cell*R(M)\Images and
D:\Archive. It is most convenient to accept each time and simply continue with Next >.
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10. In the next window, choose in which group program shortcuts for Start » Programs are
to be added. The setup will suggest the folder cell*R(M). It is most convenient to accept
this and simply continue with Next >. The installation will be executed.

16.2 Updating the cell*M / cell*R Hardware Control

(2
. obsUpdate.exe

The cell®M System Coordinator / cell®R Real-Time Controller in the imaging PC and the proces-
sors of the MT20 / MT10 electronics run their own software (so-called firmware), which need to be
updated for version 3.0 as well. Before doing this, switch on the MT20 / MT10 and wait a few sec-
onds for it to initialize. Then execute the obsUpdate.exe that can be found in the cellAM / cell*R
folder or under Start » Programs » cell®M/cell*R. The software checks the current firmware ver-
sions and opens a dialog box listing the current status. If the necessity of an update is indicated,
click the Start Update button.

A Make sure the MT10 / MT20 illumination system is switched on.

B obsUpdate E|
Component | Current version | Update wersion | Status |
CTR_M (PC104) 27 27.2.1 Update required
CTR_M (PIC) 1,22 1.22 ok
MT10 246 246 Ok

'E Al least one connected device requires an update!
L

Start update Cancel

Carefully read the warning message that appears and follow its instructions. Then click
the Start firmware update now button. Do not use the computer or any of the periph-
erals for other tasks during the update process and do not unplug any connection ca-
bles.
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Warning g|

The Firmware update process will take a few

! E minutes. This process must not be interrupted,
otherwise the Firrmwmare might be corrupked.
Close all ather applications. Do not use the
computer, any of its peripherals or unplug any
connection cable until the update process is
finished.

| Skart Firmware update now Cancel |

The update lasts few minutes. Once it is completed, a window with the confirmation appears.

B obsUpdate §|
Component | Current version | Update version | Skakus |
CTR_M (PC104) 2.7.2.1 2.7.2.1 Ok
CTR_M {PIC) 1.z2 1.2z k.

MT10 Z.48 2,45 Ok,

\E) All connected devices are up ko date!

Ok

Switch off the MT10 / MT20 illumination system after the update. Switch it on again af-
ter about 5 seconds. This is necessary for a complete re-initialization of the electronics.
The illumination system will not be fully functional otherwise.

16.3 Selecting the Camera

o This is not necessary after an update to the new software version.

1. Press <F6> (or select Acquisition » Select Camera) to open the Set Input dialog win-
dow.

ﬁl 2. Click the New Channel button to open the Select Channel dialog window.
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— )
= Set Input
@ . —_— Available devices:
= ? Bl OB Genenic
OBS Dumm =0 085 Dummy
=Tl e __y 20 0BS Megaview
OBSGenetic % OBS Orca
W= 0BS CC12
& 0BS Andaor
1= 0BS DP30
= OBS DPFO
1= 0BS Roper
[ Use calibration of active channel

3. In case of a F-Viewl/-T camera select OBS MegaView.
In case of an Orca ER or DBH1 camera select OBS Orca.
In case of a CC12 camera select OBS CC12.

4. Exit with OK.

5. Calibrate the camera pixel size as described in Chapter 7.1, Calibrate Images.

16.4 Single-User Systems (Administrator Users)

If the system is used exclusively with Administrator rights (by one or several users) the following
has to be observed.

By default the hard disk of the cell*R / cell®M computer has two partitions:

e Partition C, the smaller one, contains the operating system, standard software and enough
space to install additional programs.

e Partition D, the large one, contains the cell*R / cell*M software and the folder Archive, where
the databases are usually created.

The archival path can be changed in cell*R / cell*M via Special » Preferences » Database in the
field Database files. The path should not be set to C, otherwise memory problems will occur soon
while using the system. The corresponding error message would be "Could not reserve enough
memory".

Make sure that the Temporary storage directory — to be set in the same dialog box - is on the
same disk partition as the database directory, otherwise problems might arise at least in case of
fast data acquisition.
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16.5 Multi-User Systems

Note the following if user accounts in addition to the Administrator are to be installed
on the cell*R / cell*M computer.

There are two main differences between operating systems in this context:
¢ MSWindows 2000 requires administrator user rights for cell*R / cell*M to function properly.
e Standard user accounts can be installed in case of MSWindows XP.

How to run cell*R / cell®M in a "normal" user account under MSWindows 2000:

1. Log on as Administrator.

2. Create a new user using Settings » Control Panel » Users and passwords from the
Start menu.

3. Select Add... to open the assistant for editing a new user. Fill the required fields. In the
Level of Access dialogue, you have to select Administrator from the Other pick-list.

4. Check that the newly created user has permission to write into the Archive directory
where the databases are created when working with cell*R / cell*M. To check the secu-
rity of a directory/file the Security tab in the Properties dialog (to be opened via right-
click) has to be made visible.

To check the security settings of the Archive use the Windows Explorer and do the fol-
lowing:

Select the Archive directory.

Right-click and select File » Properties.

Select the Security tab.

Click Add, select the group or the name from the list "Group or user names" and exit

with OK.

Check that the permissions for the user include: Modify, Read&Execute, List Folder

Contents, Read and Write.

Q0T

]
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5. Check that the Environment variables for the user are set to D:\Temp by doing the fol-

lowing:

a Open Settings » Control Panel » System from the Start menu.

b Select the Advanced tab.

¢ Check that the User variables Temp and tmp are set to D:\Temp. Otherwise change
the variables to D:\Temp by selecting Edit.

How to run cell*R / cell®M in a "normal" user account under MSWindows XP:

1.

Log on as Administrator

To create a new user using the Computer Management click Run... in the MSWindows
Start menu. In the command line of the window that appears type mmc
c:\windows\system32\compmgmt.msc and click OK.

Select Local Users and Groups » Users and Action » New User and fill the required
fields. The new user is member of the group "Users" only.

Check that the newly created user has permission to write into the Archive directory

where the databases are created when working with cell*R / cell*M. To check the secu-

rity of a directory/file the Security tab in the Properties dialog (to be opened via right-

click) has to be made visible.

a Start the Control Panel.

b Open Folder Options.

¢ Select the View tab and make sure that the option Use simple filesharing is NOT
selected.

To check the security settings of the Archive use the Windows Explorer and do the fol-

lowing:

Select the Archive directory.

Right-click and select File » Properties.

Select the Security tab.

Click Add, write the name of the new user under Enter the object names to select and

exit with OK.

The user is added to the list "Group or user names".

e Check that the permissions for the user include: Modify, Read&Execute, List Folder
Contents, Read and Write.

00 T

Check that the user has the permission to Increase scheduling priority.

Click Run... in the MSWindows Start menu. In the command line of the window that ap-
pears type mmc c:\windows\system32\secpol.msc and click OK.
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8. Select Local Policies » User Rights Assignment.

9. Select the item Increase scheduling priority on the list on the right side.

10. Select Action » Properties.

11. Click Add user or group, write the name of the new user under Enter the object names
to select and exit with OK and confirm the changes with Apply.

16.6 PC-to-Controller Network Connection

Communication between the MSWindows imaging PC and the cell®M System Coordinator / cell*R
Real-time Controller is realized through an ordinary, albeit internal, network connection via a net-
work card.

The MSWindows status bar features an icon showing two little monitors. If the system works prop-
erly you will see the mouse-over message shown in the screenshot below:

CTR_R
Speed: 10.0 Mbps
| obatus: Connected

EN & 2 2, ) @ 11:10

When double-clicking on the icon the CTR Status window will open. The Activity field counts the
data Packets being Sent and Received.

It is important that the configuration of the PC-to-controller network connection remains un-
changed. Otherwise the system may become disabled.

1. To control the settings, click on the Properties button in the CTR Status window to
open the CTR Properties window.

2. Select the Internet Protocol (TCP/IP) connection and click on the Properties button to
open the Internet Protocol (TCP/IP) Properties window.

3. The Use the following IP address has to be activated.

4. The IP Address must be 42 42 42 17.

5. The Subnet Mask must be 255 255 255 0.
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- CTR_R Status

-4 CTR_R Properties

General | Support General | Authentication | Advanced
Caonhection Conhect using:
Status: Connected ‘ B8 FRealtek RTLE139/810x Family Fast ‘
Cruration: 00:56:49
Speed: 10.0 Mbps This connection uges the following items:
E’, Client for Microzoft Networks
.
Activity
Sent Received Install..
' 3 Descrinti
("} escripl ?on.
Transmizsion Contral Protocol/lnternet Protocol. The default
Packets: E.248 E.353 wide area network pratocol that provides communication
across diverse interconnected networks.
Shaw icoh in notification area when connected
- - [ Matify me when this connection has limited or no connectivity
| Properties | [ Dizable
ak ] [ Cancel ]

Internet Protocol (TCP/IP) Properties

Realtek RTLB139/810x Family Fast Ethernet NIC #2 P... [?(X]

General | General| Advanced |Driver Rezources | Power b anagement

You can get IP settings assigned automatically if pour network supports

The following properties are available for this network adapter. Click.
thiz capability. Othenwize, vou need to ask your network, administrator for the property you wank to change on the left, and then select its value
the appropriate IP settings. or the right.

Froperty: Walue;
() Obtain an IP address automatically

Link Diowin Poweer Saving

@

[10Mbps/Ful Duples ~|

|P address: 42 4z . 42 17 Optimal Performance T T
Feceive Buffer Size 1 JHIf 'l ""
Subnet mask: WiakeUp on ARF/PING e ke
‘wiakellp on Link Change uto Negotiation
Default gateway: l:l ‘wiakellp uzing APM Mode

() Use the following DNS server addresses:

Preferred DNS zerver:

Alternate DMS zerver: l:l

[ 0K H Cancel ]

u]. l [ Cancel

6. Return to the CTR Properties window with OK.
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7. Click on the Configure button and go to the Advanced tab of the Realtek window that
opens.

8. Select the Property Link Speed/Duplex Mode and then the Value 10Mbps/Full Duplex
from the shortlist. Confirm with OK.

Additionally, it is important the PC-to-controller network connection is NOT protected by a firewall.

1. To control this, go to the Advanced tab of the CTR Properties window and click on the
Settings button.

2. Make sure that Off (not recommended) is activated in the Windows Firewall window.

o The PC-to-controller network connection is not a computer safety risk and there is no
reason for a firewall protection. This internal network connection is used only for the
system commands traffic and not a gateway to the internet or intranet.

= Windows Firewall

General | Exceptions | Advanced

-i. CTR_R Properties

General | Authentication | Advanced

‘windows Firewall helps protect vour computer by preventing unauthonized users

) . from gaining access to pour computer through the Internet or a nebwork,
‘windows Firewall

Protect my computer and network by limiting
of preventing access to this computer from 2 O On [recommended)
the Internet

This zetting blacks all outzide sources from connacting to this

computer, with the exception of those selected on the Exceptions tab.
Internet Connection Sharing

[ Allows other network. users to connect through this
computer's Intermet connection

Select this when vou connect to public networks in less secure
locations, such as aipports. You will not be notified when Windows
Firewall blocks programsz. Selections on the Exceptions tab will be
ignored.

Learn more sbout Intermet Connection @ ®

Sharing.

Avoid using thiz setting. Turning off Windaws Firewall may make thiz
cormputer more vulnerable to viruzes and intruders.

If pou're not sure how to et these properties, use
the Metwork Setup 'Wizard instead. What elze should | know about Windoves Fireweal ?

ok ] [ Cancel Ok l [ Cancel
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