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1 Welcome
Congratulations on selecting the SoilVision soils database system. You have chosen a powerful, easy-to-use
environment for managing your soils data. With SoilVision you can point-and-click your way to the latest
theoretical estimations or powerful statistics based on laboratory data. Over 45 pre-created reports and 20
theoretical estimations of soil behavior form the basis for powerful soil property management.

For the corporate environment, SoilVision provides the perfect data warehouse for valuable soils data. With
SoilVision you can take advantage of a globally-standardized database format that may be viewed through the
streamlined SoilVision user interface. All corporate data is open to you, the client, and will allow you to create
your own custom reports. Unlock the full potential of you soils data with the SoilVision knowledge based
database system.

1.1 Technical Support

To help you get the most out of our products, we offer professional services that include technical support,
training, consulting and web-based resources. Just visit our web page at 
http://www.soilvision.com/products_support.html. Our support page contains contact information, software
utilities and articles detailing the use of SoilVision.

If you cannot find an answer to your questions in the support page, call technical support at (306) 477-3324
between 8:30 am and 5:30 pm (CST), M-F. Before you call technical support, you should have the following
information ready:

· Serial number and product version, which you can find by clicking About in the Help

menu.

· Operating system version, and service pack version if applicable.

· A description of what you did before the problem occurs.

· The exact wording of any error message you see.

1.2 About This Reference Manual

This manual assumes that you are proficient in the use of Windows 95, Windows 98, Windows NT 4.0,
Windows Me, Windows 2000 or Windows XP. If you need help using these operating systems, consult their
respective user documentation.

This user’s manual is divided into two sections. The first section provides a general overview of the software.
The second sections deals with the operation of the SoilVision software. Detailed explanations of the theory
may be found in the journal papers referenced in this manual.
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2 Setup
The following chapter includes instructions for the setup of the SoilVision software on an IBM-compatible
hardware platform.

2.1 Operating System Considerations

SoilVision version 4.0 is designed to run under Microsoft Windows 95/98/NT/Me/2000/XP. Installation of
the SoilVision software is the same for the aforementioned operating systems. 

2.2 Installing the Software

Refer to the SoilVision Installation Manual document or visit www.soilvision.com for complete installation
instructions.
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3 Getting Started
Once the SoilVision software is installed, the user must perform the following steps to enable the software.
These steps need only be performed the very first time the software is run.

Attach hardware security device (Ignore this step for the demo version)
Open appropriate files – this dialog allows specification of the location of files for the correct operation of the
SoilVision software. These files need only be opened the first time the software is run.
Enter authorization code – this code should be located on the CD cover of your installation CD. An
authorization code may also be obtained from the web address http://www.soilvision.com/authorization.

3.1 Opening Files

Opening files is only necessary the first time SoilVision is run. Soil data input by the user must be entered
once the user is linked to the blank database distributed with the SoilVision software. The user may enter as
many soils as desired and is free to develop a database of laboratory test data. The blank database is not
protected so the user has full access to the data outside the SoilVision software. The data is stored in standard
Access data format and may be viewed by anyone with a commercial version of Access 97 or newer. The
unprotected format allows great flexibility with the SoilVision system. Searches and methods of viewing the
data not included in the distributed version of SoilVision may be developed in-house. 

Another side-effect of this design is that the application must be told the location of the data the first time the
application is run. The following databases must be attached to the SoilVision application for it to function
properly.

It is important to realize that purpose of attachments in SoilVision. When database files are attached to the
SoilVision application, links are established between the SoilVision application and the data. Data remains in
the database file being attached. If soils data is added or edited, it is changed in the file to which SoilVision is
attached. Soils data is not stored in the SoilVision application file.

3.1.1   Search Database
The database contains tables storing searches created by the user during the operation of SoilVision. These
searches are managed in the Search Wizard. Searches may be thought of as views of the data. The search
database stores these views so the user can develop a list of more frequently used views of the database. The
Search Database, named SVSearch.mdb, is essential for the correct operation of SoilVision. 

3.1.2   SoilVision Database
The SoilVision database contains the soil data entered into the SoilVision application. Three soil database
files are distributed with the SoilVision application. They are identical in structure and vary only in the soils

data and the security placed on the database file. The soils database is essential for the correct operation of the
SoilVision application. The soils database files distributed with the SoilVision application are described
below:

· SVSoils_Demo.mdb: This file is an unsecured database that contains example information of a
soil. The information contained in this database is designed to showcase the features of the
SoilVision database only. It is not recommended that the user add soils to this database as the
soils may be confused with the demo soils information. New soils information can be added to
the client database described below.

· SVSoils_MyData.mdb: The client database is an unsecured file that is used to enter soils data.
The structure of this database is the same as the _Demo, and _Data databases, but is initially
empty. The user enters new soils information into this file. 
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· SVSoils_Data.mdb: The data database is a secured file that contains data on over 6000 soils
collected by SoilVision Systems Ltd. The format of this database is identical to the Demo and
Client database files. This database is provided in a read-only format to users of the full version
of SoilVision. New information should not be added to the database.

3.1.3   Correlation Database
The Correlation Database contains correlations commonly used in the practice of geotechnical engineering.
The correlations are referenced to journal papers and textbooks they are published in. The correlation database
is only available with the full version of SoilVision.

3.1.4   Settings Database
The Settings Database contains settings specific to the users application of SoilVision. For example, the
settings include minimum and maximum grain-size distribution boundaries for the design of road base
materials. Please refer to the grain-size section of this user’s manual for a detailed description of entering and
displaying minimum and maximum grain-size distributions.

3.2 Backing Up Your Data

It is highly recommended that the user back up their soils data at regular intervals. Backing up soils data is
accomplished by making a copy of the SVSoils_MyData.mdb file. 

Any searches created by the user in the Search Wizard are stored in the SVSearch.mdb file. Soils data is not
stored in this file but the specifications for all searches are stored here. The search database should be backed
up at regular intervals.

The settings database contains specifications of grain-size distribution minimums and maximums. Backing up
the specifications file at regular intervals is recommended to preserve all specifications entered into
SoilVision. In summary, it is recommended that the following files be backed up at regular intervals.

SVSoils_MyData.mdb
SVSearch.mdb
SVSettings.mdb
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4 Basic Windows Skills
The following will provide you with some directions on the overall operation of forms and menus within
SoilVision.

4.1 Windows Fundamentals

SoilVision adopts many of the standards that have been implemented with Windows. One of the standards in
windows is to provide the user with a “tool tip” for every command button. SoilVision has also adopted this
standard. The tool tip is accessible by holding the mouse over the command button for a few seconds. A “tool
tip” will appear giving a description for the command button. It is also standard to duplicate all of the
command buttons with an option in a drop down menu. The menu options are required to allow the software
to be fully functional with the use of the keyboard.

Forms within SoilVision that contain both an OK and a Cancel button should be used in the following manner.
When the form is open you will be updating the information contained in a form. If you are finished with the
form and would like the changed information to become current you will want to choose the OK option. This
can be done by either clicking on the button with the mouse or by pressing ALT+O on the keyboard. If you are
finished on the form but you do not want the changes made to become current you will want to choose Cancel.
This will cause the form to close but the changes you made will not be saved. 

4.2 Locating Files and Directories

The ability to locate files and directories is essential to operating SoilVision. The following is a standard
dialogue used by Windows to locate files on you computer:

To open a file from this dialogue you can do any one of the following:

· Type the name of the file in the “File name” control and then click “open”. You may want to
include the path to the file if the file name is not currently displayed in the window.

· Select a file from the window by clicking on it and then click the “open” button.
· Open a file by double clicking on it in the window.

4.3 System Messages

Within windows it is the standard that if a program encounters an action that it can not perform it will provide
you with a system message that will allow you to try and continue with the desired action or cancel it all
together.

SoilVision has adopted the same standard and will provide you with detailed messages if the program
encounters an action it cannot perform, or if you have not supplied enough information to perform a specific
task.

4.4 Menu Structure

SoilVision uses a standard menu structure. The standardized menu greatly simplifies the user interface and
allows the full functionality of the SoilVision software to be quickly accessible. The following sections
present a brief overview of the menu divisions common to every form in SoilVision. 

Each form in the SoilVision application has a menu of it’s own. The menu options when the Grain-size form is
active will appear different that when the Soils form is active. This allows functions specific to each aspect of
soil behavior to be appropriately grouped.
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4.5 File

Allows the current record to be saved, or closed. Saving of the current record also occurs when the user
proceeds to another record.

4.6 Records

The records menu provides the necessary functions for adding/deleting and editing records in the database.

4.7 Edit

WindowsÔ standard functions for cutting and pasting data.

4.8 Search

This menu function provides functions for selection of a subset of data contained in the current form. Access
is also provided to the Search Wizard that may be used to perform general, free form searches of all data in the
current database.

4.9 Tools

The tools menu provides general functions that are relevant to the current form. Access is provided to the
correlation database that will automatically select correlations relevant to the current form topic (i.e.,
compression).

4.10 Preferences

The preferences dialog box is provided for the user to adjust the way soil property functions are displayed. The
preferences dialog box may be accessed on the Tools > Preferences menu option of the Soils form or the Soil

Searching and Summary form.

Settings such as the minimum and maximum values, the number of points and the units displayed on each
graph may be adjusted. The settings entered in Preferences only affect the way graphs are displayed under the
Graph menu options and the output to the clipboard under the Report menu option.

The Hydrometer Method field specifies the default methodology used when performing grain-size
calculations. The calculation method can still be changed in the Grain-size form at the time of data entry.
Modifying this field will not alter any data previously calculated and saved in the database.

The output of all reports and equations is unaffected by the settings in the Preferences dialog box.

The options in the Preferences dialog box do not affect or alter laboratory data that was entered into the
SoilVision database. Modifying the unit fields alters the way data is displayed but does not change or in any
other way alter the way data is stored in the database.

Adjusting the number of points generated on theoretical curves is especially useful when
displaying three-dimensional graphs. The generation of points on theoretical surfaces for
three-dimensional graphs requires significant computation time. Reducing the number of points
generated on a particular curve can significantly reduce the time required to generate a graph.
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4.11 Estimate

The estimate menu provides access to algorithms used to estimate various soil properties. The estimation
algorithms available are dependent upon the form that currently has the focus. Estimation algorithms are also

called Pedo-Transfer Functions. Pedo-Transfer Functions is a soil science term which was originally
introduced by Bouma, (1989).

A brief description of the theory behind each estimation may be found in the SoilVision Theory Manual.

4.11.1   Pedo-Transfer Functions
A pedo-transfer function (Bouma, 1989) is a function that has as its arguments basic data describing the soil
such as grain-size distribution, dry density, and porosity, and yields as a result a soil property function. This
term is used in SoilVision to refer to theoretical estimations of soil behavior. Examples of such estimations are
the theoretical estimations of the soil-water characteristic curve and the permeability curve.

The pedo-transfer functions available for a particular soil property may be observed under the Estimate menu
option.

4.12 Apply Fit

These commands initiate a nonlinear least squares regression algorithm to fit an equation to experimental data.
The Search submenu allows fitting of all soils in the current search. Please refer to the SoilVision Theory
Manual for a description of each individual fit.

4.13 Graph

Functions are provided to allow graphing of data relevant to the current form. The Search submenu allows
graphing of all soils in the current search.

4.13.1   Editing Graphs
It is often useful to modify some of the properties of the graphs produced by the SoilVision software. The First
ImpressionÔ graphing module allows detailed modification of the fonts, axis properties, colors, and marker
types used in building each graph. 

A list of all the functions available to the user may be displayed by right-clicking on the First ImpressionÔ
graph. Right-clicking will bring up the following list.

First ImpressionÔ graphs may be cut and pasted to other Windows programs such as MS Word and MS
Excel. It is recommended, however, that graphs be saved as WMF files and then inserted into other Windows
applications. Saving the graph first as a WMF file and then importing the file into another application
increases the reliability of the transfer process. The Chart Designer and Wizard allow changes to be made in
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the type of graph which is displayed. It is recommended that the user edit individual items within a graph by
the method presented below.

Individual chart items such as axis labels, legends, and data format may be changed by double-clicking on the
object that the user desires to change. This will bring up a dialog box  which will allow the user access to
editing the various aspects of the current graph object.

Any changes made to the graph may be applied to the graph by clicking on the OK or the Apply button.

4.13.2   Graph Defaults
Implemented in SoilVision is a standardized form which will brink up default properties of topic-specific
graphs within SoilVision. The topic-specific nature of this form means that only graph properties which relate
to the current topic are presented. For example, if Graph > Graph Defaults… is chosen while in the Grain-size

form, the defaults for all grain-size graphs will be selected and presented in the Graph Defaults form. Any of
the grey-colored fields may be adjusted and become the new default for the appropriate graph. The defaults are
stored with the SoilVision application file and will therefore not be retained when the SoilVision application
is updated to a newer version.

4.13.2.1   Report

This menu item controls the production of SoilVision reports. Standardized ASTM laboratory reports may be
produced as well as summaries of various fits and/or estimations of soil properties. The graphing options or
display properties of reports may not be modified once the report has been generated. 

Printing options (such as margins) of each report may be modified under the File menu.

4.13.3   Laboratory
The Laboratory menu contains reports which report on raw laboratory data. The menus are topic-specific so
the Laboratory menu of the Grain-size form will differ from the Laboratory menu of the Compression form.

4.13.4   Fits
The Fits menu contains reports detailing the equations and equation parameters used to fit laboratory data. 

4.13.5   PTFs
The PTFs menu contains reports summarizing details of estimations. The reports are typically named
according to the estimation performed.

4.13.6   Curve Points
The Curve Points menu contains options for outputting any particular soil property function as X – Y data.

4.13.7   Equations
The Equations menu allows output of fit equations as a text string. This function is useful if equations are
being cut and pasted into finite element software or into Microsoft ExcelÔ for spreadsheet calculations.
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4.14 Window

Standard WindowsÔ functions relating to the sizing of forms

4.15 Help

Menu functions are provided for technical support available for the SoilVision software. The user’s manual
for the SoilVision software is currently not provided with the software in a help file format. It is distributed
only in hardcopy format or electronically as a PDF document which may be read with the Adobe Acrobat
Reader.
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5 General Operation
The main switchboard can be considered the control center for the SoilVision Knowledge-Based Database
System. The input of information specific to your company as well as establishing the proper linkages to data
sources is necessary. Input of company information allows reports generated within SoilVision to be
automatically identified with your company’s name, location, and logo. The main switchboard presents the
user with the main choices available in SoilVision.

The SoilVision database is distributed as a front end/back end application. The front end application file
contains the user interface and the code necessary for the graphing, fitting, searching, etc. of the data. The
back end includes data files including soils information and other related information required for the correct
operation of SoilVision. Pressing the SoilVision Database… button on the main switchboard form allows the
user to view soils data in the soils database to which the application is currently opened. 

5.1 Form Composition

A standard method of presenting information was adopted in the design of SoilVision. Data representation
was grouped into objects representing related information called forms. These forms represented experimental
data, theoretical data, predictive algorithms, curve-fitting algorithms, and general knowledge related to a
specific soil property. The use of a standard grouping method will help the geotechnical engineer or scientist
access information quickly and efficiently with a minimized training time. Forms also make use of Windows ‘
intuitive’ feel to further ease operation. 

The following points may be noted:

· Forms allow the user to see the data in the database organized in a logical format
· SoilVision maintains a one-to-one correlation between tables and forms
· Each form in SoilVision corresponds to a matching table
· The user may get a feel of the organization of data by browsing through the available forms
· Viewing data in tables attached to the Soils table is accomplished through the Properties page

of the Soils form
· Form links are laid out in a visually logical manner
· Linked forms may also be reached through the menu
· User changeable fields are displayed as indented
· Calculated, non-modifiable fields are given a raised look
· Each fitting method or pedo-transfer function is given a tab description

Forms organize the data contained in the database and present it to users in a clear and coherent manner. In
general database systems, access to certain data can be restricted or locked. The SoilVision system allows
access to all data with the exception of the database distributed with the SoilVision application.

In a multi-user system, certain records may be in use by another user. While one user is editing a record, it
remains locked for all other users.

It is important to note that SoilVision is a database application and therefore automatically saves and manages
information. An edited record is saved when the user advances to another record or executes an algorithm.

5.2 Pasting Subform Data

SoilVision allows access to Windows standard cut, copy, and paste functions with subform data. In particular,
it is often useful to paste data into the subforms from Excel or some other similar software. Data may be
pasted into subforms providing the titles of the data on the clipboard match the column titles shown on the
clipboard. A template which may be used for pasting data may be obtained by pressing the >>XLS button. The
steps for pasting data into a subform include 1) selecting the button beside the new record as shown below,
and, 2) selecting Paste from the Edit menu or pressing Ctrl-V.
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5.3 Deleting Subform Data

It is often desireable to delete laboratory data points which have been deleted in error. Such points may be
deleted by 1) selecting the point by depressing the button to the left of the point, and, 2) pressing the Delete

key on the keyboard. Groups of data may also be deleted in this manner.

5.4 Standard Buttons

SoilVision implements the following standard buttons for use on forms:

Close: Close the current form

Delete: Delete the current record in the form

Help: Bring up help on the current topic

Add: Add a new record to the current table

          Save: Save the current record, it is important to note that each record will
automatically be saved when the user proceeds to a new record or closes the form.

Standardized buttons are also presented on each tab of the fitting and estimation tabs in the database. The
following is a description of these buttons and their function.

5.4.1   XLS button
This button copies the current data to an Excel spreadsheet. The spreadsheet is also useful as a template for
cutting and pasting data into the Laboratory data subform.

5.4.2   Graph button
This button graphs the current data associated with the tab on which the button is located.

5.4.3   Properties button
This button displays standard properties associated with the data / function on which it is placed. Graphing
properties may be changed here.

5.4.4   Apply Fit button
This button initiates the algorithm to fit the appropriate equation to laboratory data.

5.4.5   Estimate button
This button initiates the appropriate estimation algorithm to provide a theoretical estimation of the current soil
property function.

5.5 Data Organization

Soils information is organized in an efficient yet logical structure. The Soils table stores primary information
such as texture, volume-mass properties, reference and geographical information for a soil. Since it is rare to
find a soil containing experimental data for all properties, tables containing less common information were
linked to the Soils table allowing data to be stored in an efficient and organized fashion. A form has been
designed for each table to allow viewing and editing of information in the proper manner. 
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Information is grouped first by Project, then by Borehole, Soil information, primary subforms, and secondary
subforms. This structure may be seen below. Soils may be uniquely identified by the Soil_Counter field. All
soils, when first entered, are assigned a unique Soil_Counter value. The Soil_Counter field is a long integer that
may range between -111,111,111 and 999,999,999. 

 
Project 

Records 

Borehole 
Records 

Soils 
Records 

Primary 
Subtable 
Records 

i.e. Grain-size 
data 

Dataset 
Records 

Well 
Records 

Secondary 
Subtable 
Records 

i.e. Sieve data 

Forms containing soils properties related to each soil may be displayed by pressing the buttons on the 
Properties tab of the Soils form. 

The following points may be noted regarding the data structure:

· Soils data in SoilVision is represented in interconnected tables
· Information is grouped in tables according to topic
· For example, all information related to soils permeability is stored in it’s own table
· Columns in tables are referred to as fields

· Fields in SoilVision may be divided as either entered or calculated fields
· Only entered fields may be modified by the user
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· The most common soils data in SoilVision is stored in a main table entitled Soils

· Additional information in the database is then stored in sub-tables that are linked via the 
Soil_Counter field to the main Soils table

· The table structure is divided to allow for storage efficiency
· Grain-size distribution, SWCC, water content, shear strength, permeability, compression,

compaction, and shrinkage data is all stored in linked sub-tables
· It is unusual for experimental data to be available for all aspects of soil behavior

Soil information stored in the database is often not complete in the sense that all soil properties are not known
for every soil. It is unusual for information on shear strength, permeability, diffusion and thermal conductivity
to be known for a soil.

5.6 SoilVision Open Database Architecture

A common problem with previous customized database software programs is that the individual is dependent
upon a certain firm to fulfill their database design needs. The open unprotected format of the SoilVision
database alleviates this problem. For example, if a firm purchases the SoilVision software and develops a large
database of soils information, the database is open to the company and may be customized in any way.
SoilVision Systems Ltd. also provides customized database development. For a complete description of what
services SoilVision Systems Ltd. can offer please contact our office in Canada.

New blank databases may be built by copying and renaming the blank database file from the SoilVision
distribution CD.

Warning: There is potential danger in modifying the blank SoilVision database from outside the SoilVision
application! The correct functionality of the SoilVision software may be damaged if the structure of the soils
data is changed. The general rule is that fields and tables may be added but existing tables and fields should
not modified. Please contact SoilVision Systems Ltd. if you desire to make changes to the database structure. 

5.7 Units

SoilVision is capable of managing the entry and display of data in either Metric or English units. The entry of
data is handled in a different way, however, than the display of metric data. It is important for the user to
recognize the difference between entering English units and displaying English or other types of units. The
following sections outline these differences.

5.7.1   Data Entry
SoilVision allows data to be entered in either Metric or English units. The units of measurement for the Metric
and English systems have been selected based on the units most commonly used in practice. Entry of data in
either the Metric or English units is accomplished by typing values into the corresponding fields. Fields which
allow entry of English or Metric data are commonly placed beside each other on a form. Once data is entered
in one field, the other is automatically updated. 

It is important for the user to realize that the units used in the entry of data may not be changed from the units
implemented in each form. The units used in the entry of soils data are unaffected by any options selected in
the SoilVision software. 

It is also worthy of mention that the data model adopted for SoilVision primarily stores data in metric units.
When soils data is entered using English units, the data is typically converted to the Metric equivalent before
being stored in the database. This design is robust in that there is no confusion regarding the units in which
data is stored in the database. For the most part, the user need not concern themselves regarding the storage
format as SoilVision allows great flexibility in the entry and display of data in a variety of formats. 

It is important to note one aspect of the storage of soil data in SoilVision. The data is stored in metric format
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in the table structure. The user must therefore specify all search criteria created with the Search Wizard in the
metric format. Selecting all soils with an upper sample depth between 5.8 and 6.8 will always mean 5.8m and
6.8m.

Entry of data into subforms is handled in a slightly different manner. An example of data entry into a subform
may be the grain-size distribution form. The default metric format of the data entered is Particle Diameter
(mm) and Percent Passing. 

SoilVision allows the user to change this format to English units by selecting the dialog box under the Tools >

Units… menu item of the Soils form.

The entry of units under all forms will be changed accordingly. Changes to the units entered under the Unit
Specification dialog box will not take place until the subforms are closed and re-opened.

5.7.2   Data Display
SoilVision provides significant flexibility in the display of soils graphs and reports. The units displayed may
be selected under the Tools > Preferences dialog box in the menu of the soils form. This dialog box alters the
graphs, and reports, and clipboard output available under the Graph and Report menu options. It is important

to note that data stored in the database is not altered by any selections in this dialog box. The output of
equations under the Report menu is unaffected by the Preferences dialog box. Equations are always output in
metric format.

5.7.3   Unit Conversion Wizard
SoilVision implements a unit conversion wizard which allows the conversion of a single number or a column
of numbers from one unit of measurement to another. The unit conversion wizard may be found on the Tools >

Unit Conversion Wizard… menu option of most topics.
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6 Data
The detailed operation of SoilVision is covered in this chapter. A description of the data required and a short
development of the theory associated with each soil property is presented. Sufficient theory is presented to
provide a general understanding of the development of each function. A summary of the database fields
modified by each method is also presented.

Soil properties can be either best-fit with an equation or predicted using an analytical method. Soil grain-size
distribution, compression, and soil-water characteristic curve (SWCC) functions can be best-fit with
equations. The equations used are presented in the following sections along with verification of the
performance of the equations. A least-squared regression technique was used to determine the parameters of
an equation. The verification of grain-size, compression, and soil-water characteristic curve present the results
of fitting the equations to various experimental data.

The soil properties: hydraulic conductivity, water storage, shear strength, specific heat, unfrozen water
content, thermal conductivity, and diffusion can be analytically predicted. The theory related to each
respective estimation is presented in the following sections. 

6.1 Project Form

SoilVision requires that each borehole and soil entered into the database be organized under a project. The
project data present in the SoilVision database may be found under the Projects form. Data may be entered in
the projects form by clicking on one of the tabs (Project, Client, Phone, etc…) on the form. 

Project tab contains general fields related to the current project.

Client tab contains contact information for the client associated with the current project.

Phone tab allows entry of the phone contact information for the current client.

Client Address tab contains address information for the project client.

Contractor tab contains information related to the contractor for the current project.

Project Engineer tab contains contact information for the project engineer.

Recommended Minimum Input
Project ID

Project Name

Project Location

Once data is entered in the project form, the user may proceed to the Boreholes, Wells or Soil Summary and
Searching form using the commands in the toolbar choices shown below:

Note that when the toolbar choice is selected, all records in that table will be displayed in the form. For
example, if the Projects form is open with a particular project selected, and the Soils button on the toolbar
shown above is clicked, the Soil Summary and Searching form will open with all soils in the attached database
displayed. To view only the soils associated with that project, the user must first view the boreholes under the
current project, and then view the soils under that borehole.

The View menu provides an alternative to the toolbar to proceeding to these forms. In this menu, the Boreholes

by Project… command will open the Boreholes form displaying only the boreholes organized under the
currently selected project. In the same way, the Wells by Project… command brings up the well records
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organized under the currently selected project. The other commands in the View menu open the specified form
with all records displayed.

The user may also view all boreholes organized under the current project by double-clicking on any particular
project. Entering a new project is accomplished by pressing the new project button located at the bottom of the
project form. Please see Standard Buttons for a description of the buttons at the bottom of the project form.

6.2 Boreholes Form

Borehole information is contained in the borehole form. SoilVision requires that each soil be linked to a
specific borehole. SoilVision also requires that each borehole be categorized under a project. Grouping a
borehole under a project is accomplished by selecting a Project ID in the borehole form. Global positioning
system (GPS) coordinates are stored in this form to allow linkages to Global Information System (GIS)
products. Descriptions of the buttons at the bottom of the form may be found in the Standard Buttons section
of this manual.

Recommended Minimum Input

Project ID

Borehole ID

Drilling Method

Once the user has entered borehole information, they may proceed to the Soil Summary and Searching form
by pressing the Soils button on the toolbar, or by selecting either the Soils… or Soils by Borehole… commands
in the View menu. The user may also bring up all soils under a certain borehole by double-clicking on any
particular borehole in the borehole list box.

To view all borehole information currently in the database, select the All Boreholes command in the View

menu. The other commands in the View menu provide the user access to all other main data forms.

Borehole tab contains general information regarding the current borehole.

Location tab contains GIS information required to locate the current borehole when using ArcView or other
related global positioning software.

Comments tab contains general comments related to the current borehole.

6.2.1   SPT tab
The SPT tab collects information related to the Standard Penetration Test as defined by ASTM D1586-99. The
ASTM method describes the process for driving a split-barrel sampler to obtain a representative soil sample
and a measure of the resistance of the soil to penetration of the sampler. Please see Deleting Subform Points
for instructions on deleting errant data.

6.2.2   CPT tab
The CPT tab collects information related to the Cone Penetration Test as defined by ASTM D3441-98. The
ASTM method describes the determination of end bearing and side friction, the components of penetration
resistance that are developed during the steady slow penentration of a pointed rod into soil. This method is
sometimes referred to as the Dutch Cone Test as well as the Cone Penetration Test and therefore abbreviated
as CPT. Please see Deleting Subform Points for instructions on deleting errant data.

6.3 Wells Form

All information relative to the installation of wells (piezometers) is stored in the Wells form. SoilVision allows
the input of well segments and well water head readings. A list of all wells and the number of segments and
readings associated with each well is provided in the top window. Data entry begins with the input of the
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Project ID and Well ID fields to identify the project and borehole with which the well is associated. The Well
ID must be selected from the list of existing Borehole ID records. 

Wells tab contains general information regarding the current well.

Well Segments tab contains all information related to casing segments installed in the current well. Please see
Deleting Subform Points for instructions on deleting errant data.

Well Readings tab contains all water level readings taken with the current well. Please see Deleting Subform
Points for instructions on deleting errant data.

Minimum Recommended Input
Project ID

Well ID

The All Wells command in the View menu displays all well information in the current database.

The user may proceed back to the Projects form or the Boreholes form after data entry is complete.

6.4 Dataset Form

The dataset form contains information for each dataset record included in the SoilVision database. Soils
information stored within SoilVision was donated from a variety of sources. It is useful to tag each dataset
with information regarding the person or organization responsible for the integrity of the data. The Dataset ID

field provides a link to each soil. The grouping of soils by dataset is independent of the grouping based on
borehole and project information. The View > Datasets… menu option opens the dataset form.

Each dataset record provides fields identifying the date of import, the dataset lead (contact person), a
description of the dataset, and notes.

Dataset tab contains general information regarding the current dataset.

Description tab contains description information regarding the current dataset.

Minimum Recommended Input

Dataset ID

Dataset Name

The user may proceed to enter soils information after completion of entry of dataset information by selecting
the View > Soils or View > Soils by Dataset menu option. Note that the former command will display all soil
records in the database, while the latter command will display only soil records organized under the current
dataset.

6.5 Soil Summary and Searching

The soil summary and searching form attempts to make creating, browsing and searching soil records quick
and convenient, so that the user can get to the desired information easily. When a search is executed, the
results are displayed in this window along with a few of their basic properties. If the form has been opened
with no specific search, all soil records in the database will be displayed. These results can be sorted by any of
the visible fields or the date entered to help pinpoint a desired soil. Some of the most common searches are
available directly, and the Search Wizard provides more detailed searches. 

Search Type combo box provides direct access to a number of the most common searches. Selecting a search
type opens a dialog box, where the user can enter the search parameter(s). The Search Wizard can also be
selected to create more complex searches.
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Order By… button opens a dialog box where the user can select a field to sort the records by. A small blue
arrow will appear above the field sorted and indicate the sort direction, with the exception of the Date Entered
field which is not visible.

View All Soils button displays all soil information in the current database.

View SQL Statement button displays the SQL statement executed to find the soil records currently shown.

Minimum Recommended Input

When new soil records are created, the dialog box allows the user to enter a Soil Name and Sample ID.
However, the user should refer to this section under the Soils form to see which additional properties should
be entered once the complete soil record has been opened.

The detailed data for each soil record is viewed in the Soils form, which can be opened two different ways:
double-click the desired soil, or select the desired soil and use the View > Detailed Soil Information menu
option.

6.5.1   Searching
SoilVision includes the following methods for searching the information in the database. The following
methods are pre-defined searches in which the values only may be changed. For completely customizable
searches, please see the Search Wizard section. These methods are available in the Search Type combo box

and under the Search menu of the Soil Summary and Searching form.

Random Soils… allows the user to quickly see which boreholes are organized under each project, and also
which soils are organized under each borehole. The user can then select an assortment of individual soils to
view in the Soil Summary and Searching form.

Soil Counter… allows the user to search for any soil record which has been tagged with a particular
Soil_Counter value. Each soil sample is tagged with a unique Soil_Counter number at the time of entry.

Project ID… allows the user to search for any soil identified by a particular Project ID.

Sample ID… allows the user to search for any soil identified by a particular Sample ID.

Data Present… provides a search by which the user may search the database for all soils which contain data on
a certain topic. A typical example would be to search for all soils which have grain-size information present.
This search is useful due to the fact that it is unusual for a soil to have more than 1-4 particular tests run on
one sample. Soils may therefore be grouped based on the type of laboratory data present.

Texture… this search provides the user the ability to search the database for a certain USCS or USDA texture
description. Allowable texture descriptions are included in the pull-down portion of the combo boxes.

Soil Name… this search allows the user to search for all soils having a particular soil name. A full name or any
portion of a name may be entered. Wild card characters such as ‘*’ may be used. For example, if the user
desires to search for all soils in the database in which the soil name contains ‘silt’ then ‘*silt*’ would be
entered in the search field.

USDA Sieve Sizes… it is often useful to search the database for data based on the % clay, % silt, or % sand
sieve fields. This search allows the user to search the database for ranges of these soil properties.

USCS Sieve Sizes… this search is the same as the USDA search with the exception that the definitions of %
clay, % silt, and % sand are defined according to USCS standards.

Volume-Mass… this customized search allows the user to search for ranges of insitu volume-mass properties.
An example of this is that a user may want to search for all soils with a porosity ranging from 0.30 to 0.38.
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Contact… this search allows the user to search for all soils having a particular contact name. A full name or
any portion of a name may be entered. Wild card characters such as ‘*’ may be used. For example, if the user
desires to search for all soils in the database in which the contact name contains ‘Smith’ then ‘*Smith*’ or ‘
*Smith’ would be entered in the search field.

6.5.2   Graphing
The Graph menu provides access to a number of commonly used graphing options. These graphs run their
algorithm on all soils that are contained in the current search, unless specified otherwise. These graphs can
also be found when the Soils form or one of its subforms accessible from the Properties page is current, under
the Graph > Search menu.

6.6 Soils

The main Soils form is used in SoilVision for the managing of soils data. The most general fields associated
with each soil sample may be recorded in the Soils form. Detailed fields associated with individual soil tests
are stored in linked tables that may be viewed through forms accessible from the Properties page of the Soils

form. The Soils form displays or provides access to the detailed information about one single soil. In order to
browse to a different soil, the Soils form can be closed to reveal the Soil Summary and Searching form.

The following sections describe the soils data which may be input under each tab of the Soils form. The soil
data that may be recorded in linked tables under the Properties page will also be described. 

6.6.1   Texture Tab
The texture tab of the Soils form provides fields for the description of the soil. 

Input of the USDA Texture and USCS Texture fields is optional. It is recommended that they be automatically
determined using the classification algorithms present in SoilVision. The algorithms are activated when the
user clicks on the Classify buttons to the right of the texture fields or when a fitting algorithm is initiated for
the grain-size distribution. It is suggested that the user first input the grain-size distribution and proceed to
initiate either the unimodal or bimodal fit of the grain-size distribution. The soil will then be automatically
classified using the best of the two fits by the USDA and the USCS methods. The USCS method also requires
the input of Atterberg Limits. Abbreviations for each soil textural classification are presented to the right of
the soil texture.

Minimum Recommended Input
USDA Texture

USCS Texture

Contact

Soil Name

Soil Description

Geologic Description

Notes

Additional fields are provided in the Texture tab to comply with database fields standard for the representation
of soil science data. The fields are optional and are listed below.

Family

Soil Series

Texture Modifier

Structure Grade

Structure Size

Structure Type
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SoilVision also allows input of a bitmap picture of the soil. The picture may be pasted into the box to the right
of the logo using the Edit > Paste command.

6.6.1.1   Munsell Soil Color

The color of the current soil may also be specified according to the Munsell color system. Hue, Value, and
Chroma fields may be input and an approximation of the soil color will show in the box to the right as well as
a textural description of the color. The color displayed on the screen is an approximation only and should not

be taken as accurate. Colors should be read off a Munsell color book. The Munsell color system is
implemented in SoilVision according to the ASTM standard D1535-97.

6.6.1.2   Soil Classification

Proper classification of a soil requires the percentages of clay, silt, and sand that make up a soil. The
percentage of coarse, sand, silt and clay of a soil require that particle size limits be defined. For example,
clay-size particles are typically assumed to be particles with a diameter of less than 0.002 mm. The percentage
of coarse, sand, silt and clay depend on the particle size divisions that are assumed for each soil category.
SoilVision incorporates two definitions of particle size boundaries to account for this variation.

The two definitions of particle size limits are proposed by the USCS (Unified Soil Classification System) and
the USDA (United States Department of Agriculture) methods of soil classification. The USCS method of
classification is also the standard method of classification adopted by ASTM D 2487. The definition of
particle-size limits used by each method are shown below.

USCS (ASTM D 2487) USDA
Clay < 0.002 mm < 0.002 mm
Silt 0.002 < x < 0.074 mm 0.002 < x < 0.05 mm
Sand 0.074 < x < 4.75 mm 0.05 < x < 2 mm
Coarse 4.75 < x < 300 mm 2 < x < 300 mm

A USDA and USCS (ASTM) textural classification is automatically determined each time the grain-size
distribution is fit with an equation. % clay, % silt, % sand, % coarse, D10, D20, D30, D50, and D60 variables
are also automatically calculated from the fit of the grain-size distribution. The equation (unimodal or
bimodal) used to calculate the aforementioned variables depends on the accuracy (R2) of the fit. SoilVision
automatically bases classification and calculations on the equation that best represents the grain-size
distribution.

6.6.1.2.1  USDA

The USDA method of classification is used to provide a textural description of the soil. A grain-size
distribution is all that is required to perform classification by the USDA method. More specifically, the USDA
% sand and USDA % clay properties of a particular soil obtained from the Soils form under the Grain-size tab
are used as the basis for the classification. The USDA classification method is implemented as presented in the
following paper:

Soil Survey Staff. 1975. Soil taxonomy: A basic system of soil classification for making
and interpreting soil surveys. USDA-SCS Agric. Handb. 436. U.S. Gov. Print. Office,
Washington, DC.

The following textural categories and their abbreviations are shown below.
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Texture Abbreviation

Sand Sa

Loamy sand L Sa

Sandy loam Sa L

Loam L

Silt loam Si L

Silt Si

Sandy clay loam Sa C L

Clay loam C L

Silty clay loam Si C L

Sandy clay Sa C

Silty clay Si C

Clay C

6.6.1.2.2  USCS

SoilVision implemented the USCS method of soil classification as presented by ASTM D 2487. 

The primary difference between the USDA and USCS methods is that the USCS method requires Atterberg
Limits to properly classify a soil. SoilVision will inform the user if additional information is required to
classify the soil by the USCS method. 

The textural categories and their corresponding abbreviations for the USCS method are as follows:
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6.6.2   Volume-Mass Tab
An important component of SoilVision is the ability to calculate basic volume-mass properties once any three
volume-mass properties are known. This is done by rearranging the equations describing the volume-mass
properties of an unsaturated soil. Once any three volume-mass properties are known, the geotechnical engineer
may “lock” the properties. This indicates that the properties were measured and should not be changed by
further calculations. This is necessary to ensure data integrity. The Calculate button may then be selected to
calculate the remaining volume-mass properties from the three “locked” properties. 

An example showing the calculation of volume-mass properties is shown below. A soil is obtained and the
properties are as follows:

Volumetric water content, qw 0.35
Porosity, n 38%

Specific Gravity, Gs 2.63

The above properties are entered into the appropriate fields under the Volume-Mass tab of the main soil form
and locked by checking the check boxes to the right of the soil volume-mass property. Selecting the Calculate

button calculates the following properties:

Degree of Saturation: 92.11%
Void Ratio: 0.613

(Gravimetric) Water Content: 21.46%
Dry Density: 1630.6

Total Density: 1980.6
Total Unit Weight: 19.42

The calculation algorithm may also be initiated by selecting Tools > Volume Mass > Calculate Properties.

SoilVision contains an algorithm which allows for calculation of remaining volume-mass properties based on
almost any combination of three initial properties. SoilVision will inform the user if a particular combination
of volume-mass properties will not allow calculation of remaining properties. If the calculation of
volume-mass insitu properties is successful, the field Volume Mass Completed is set to ‘Yes’. It is therefore
possible to search the database based on the Volume Mass Completed field to search for all soils on which the
calculation algorithm has been run. 

The algorithm that calculates the remaining volume-mass properties from three starting properties may be run
on a group of soils. Selecting Tools > Search > Volume-Mass > Calculate Properties will initiate the algorithm
to run the calculation algorithm on all soils contained in the current search. The number of soils selected in the
current search is displayed at the bottom of the Soil Summary and Searching form. To clarify, the soils

contained in the current search are displayed in the Soil Summary and Searching form. 

The graphing volume-mass state may also be represented graphically as originally presented by Fredlund
(1993). A typical plot illustrating the volume-mass states of a group of soils may be seen here. The plot may
be obtained under the Graph > Volume-Mass or the Graph > Search > Volume-Mass command of the Soils

form menu, or Graph > Soils > Volume-Mass from the Soil Summary and Searching form menu.

Minimum Recommended Input

Porosity

Dry Density

Specific Gravity

Initial State

Experimentally Determined
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6.6.2.1   Specific Gravity button

SoilVision allows data reduction of laboratory data as collected from the specific gravity of soil solids test
described by ASTM D854. The standard units of ml, g, and degrees C may not be changed. Please see 
Deleting Subform Points for instructions on deleting errant data.

Minimum Recommended Input
Test Method

Technician

Specimen ID

Test Date

Copy Average Specific Gravity button copies the average specific gravity calculated from the test back to the
Volume-Mass tab of the Soils form.

6.6.2.2   Water Content button

SoilVision allows data reduction of laboratory data as collected from the water content test described by
ASTM D2216. The standard units of grams may not be changed. Please see Deleting Subform Points for
instructions on deleting errant data.

Minimum Recommended Input

Test Method

Technician

Specimen ID

Test Date

Copy Average Water Content button copies the average water content as determined by the laboratory test(s)
back to the Volume-Mass tab of the Soils form.

6.6.2.3   Display

SoilVision provides a display button located on the Volume-Mass tab of the Soils form. The purpose of this
button is to bring up a text description of the current insitu volume-mass state of the soil. The description may
then be cut to the clipboard and pasted into any other program.

6.6.2.4   Lock Properties

Locking volume-mass properties is a feature provided within SoilVision to prevent changes to laboratory
measured volume-mass information. Volume-mass information may be found on the Volume-Mass page of
the Soils form. Up to three properties may be locked. Locking more than three properties results in a soil state
that is over-defined.

The Lock Properties function examines the current soil information. If fewer than four volume-mass properties
have been entered, it is assumed that the properties represent a soil state and are locked.  The locked soil
properties may then be used as the basis for completing the volume-mass calculations.

If more than three volume-mass properties are present, the soil is considered over-defined and no properties
are locked.

If less than three properties are already locked, additional volume-mass properties are locked until a total of
three properties are locked.

The function does not perform any action if three properties are already locked.

The Lock Properties function may be run on all soils in the current search using the Tools > Search >
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Volume-Mass > Lock Properties command.

6.6.2.5   Fill Missing Properties

SoilVision will permit there to be less than three available volume-mass properties in the Soils form. Relevant
data may exist in the sub-forms of the database. For example, the following soil property functions provide
information relating to the initial state of the soil:

Soil-water characteristic curve wo

Compression curve eo

Shrinkage curve eo or wo

The Fill Missing Properties function checks these soil properties for experimental data that can provide an
initial volume-mass property.  For example, a void ratio may not be present in the Soils form. Fill Missing

Properties will look for an experimental initial void ratio in the compression or shrinkage curves.

6.6.2.6   Update Links

The primary function of the Update Links command is to refresh the fields in the Soils table which indicate the
presence of data in related tables. This allows the proper buttons to be colored to indicate the presence of data
in related tables. This function need not be run except after the import of soils information where the proper
links may not have been set. This function does not modify laboratory data in any manner. The Update Links
function may also be run on all soils in the current database using the command under the Global Functions
submenu.

6.6.2.7   Global Functions

The following functions relate to procedures in SoilVision which are set to run on a group of soils. 

6.6.2.7.1  View Global Events

The View Global Events table records which processes are run on the current dataset. For example, if the user
ran a global procedure to fit all soils in the current database with the van Genuchten equation a note regarding
this event would be recorded in this table.

6.6.2.7.2  View Batch Mode Messages

Messages normally output to the user are directed to this table when a global function is run. The messages
ouput from a global run may then be viewed by the user at a later time and will not interrupt the running of the
global function.

6.6.2.7.3  Update Laboratory Count

The update Laboratory Count is used to update the fields which contain a count of the records in the tables
beneath them. For example, the Sieve Count field in the Grain-size form records the number of data points
recorded in the sieve table. The Update Laboratory Count function globally updates all count fields so they are
current.

6.6.2.7.4  Update English Units

This function updates the internal recording of English units on certain tables. Initiating this function is
recommended after the import of large amounts of data.
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6.6.3   Atterberg and Misc. Tab
The Atterberg and Misc. tab stores a variety of soils information as described in the following sections.
Descriptions of each field may be found by clicking on each field independently. The field descriptions are
displayed at the bottom of the SoilVision window.

6.6.3.1   Atterberg Limits

Atterberg Limits may be entered in the Soils form under the Atterberg and Misc. tab. The Activity and
Plasticity Index are calculated automatically after the input of the Liquid Limit and the Plastic Limit. Data
reduction of data from the Atterberg Limits laboratory test as described by ASTM D4318 has also been
implemented into SoilVision and is described in the following section.

6.6.3.1.1  Atterberg Limits button

SoilVision allows for the reduction of Atterberg Limits data as generated by the ASTM D4318 laboratory test.
The tare sample weights and blow counts are recorded to allow the Plastic Limits and Liquid Limits to be
automatically calculated.

Copy Average PL and LL button allows the average plastic and liquid limits as entered to be copied back into
the Atterberg and Misc. tab of the Soils form.

Liquid Limit tab allows entry of all information relating to the liquid limit ASTM test.

Plastic Limit tab allows entry of all information related to the plastic limit ASTM test.

Liquid Limit Graph tab allows for graphic visualization of the interpretation of the liquid limit blow counts. The
appropriate water content is read off the graph corresponding to a blow count of 25.

Refresh Graph button regenerates the blow count graph according to the most recent data entered under the
Liquid Limit tab.

Minimum Recommended Input
Test Method

Technician

Specimen ID

Test Date

6.6.3.2   Hveem – Carmany Test

The Hveem-Carmany (ASTM D2844-69) test has been implemented in the SoilVision software. The purpose
of this test, as stated in the ASTM standard guide, is for testing both treated and untreated laboratory
compacted soils or aggregates with the stabilometer and expansion pressure devices to obtain results indicative
of performance when placed in the base, subbase, or subgrade of a road subjected to traffic.

6.6.3.3   Miscellaneous Properties

The miscellaneous properties area of the page allows the user to record extra data regarding the current soil
test. Clicking on each respective field will bring up a one-line description of the input required.

6.6.3.4   Filter Paper Test

The filter paper section allows the user to record the results of a filter paper measurement on a soil sample.
The filter paper method is typically performed as an economic method of measuring soil suction. The user
merely enters the wet and dry weights of the filter paper and enters the filter paper type. SoilVision then
automatically calculates the resulting soil suction based on the calibration curve for the type of filter paper
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used in the test. A complete description of the theory involved in the measurement of soil suction using the
filter paper method may be found in the SoilVision Theory Manual.

6.6.4   Location Tab
The Location tab of the Soils form is used to describe the location from which the soil sample was taken. The
fields are intended to describe a general location. A specific location (referenced to a GIS system) may be
found in the borehole form. Five fields that may be used to store extra information are also provided in this
tab.

The Country field drop-down contains countries from a pre-stored list of countries. The Province, Region, and
Site fields drop-downs provide a search of the variation of each field in the current database. For example,
pressing the drop-down menu for the Province field will compile a list of all the provinces currently entered in
the attached soils database.

Field 1-5 are additional fields provided in SoilVision which may be used to store any extra data required by
the user.

6.6.5   Origin Tab
The Origin tab of the Soils form contains information specific to the insitu state of the soil. General fields such
as the land use and drainage conditions as well as specific fields relating to the soil strata which was sampled.
Horizon specification is implemented according to standards developed in the field of geology and soil
science. 

Help may be obtained for the Horizon Code field by pressing the Help button to the right of the field. 

Sample Depth Upper and Sample Depth Lower are fields significant for the locating of the current soil sample
in the borehole. Entry of these fields is essential for the correct display of the borehole log.

6.6.6   Publisher Tab
The Publisher tab of the Soils form contains fields necessary for identifying the publication in which the
current soil originated. Many of the soils included in the SoilVision database have been digitized from data
presented in conference and journal publications. Where possible, the reference information has been included
in the SoilVision database. The publisher information is useful because it allows the user to search for data
relating to a certain publication. An example of this is searching for all data presented in papers by a certain
author. SoilVision is the only commercial database application that records publisher information.

6.6.7   Mineralogy Tab
The Mineralogy tab of the Soils form is designed to record the mineralogical composition of the current soil.
There are currently about 30 soils in the SoilVision database with mineralogy data recorded. These soils may
be selected using a pre-defined search entitled “Soils with mineralogy”. The search is included in the
pre-defined searches distributed in the Search Wizard. Please see Deleting Subform Points for instructions on
deleting errant data.

Mineralogy data is entered by specifying the mineral and it’s percentage in the structure of the entire soil. A
pie chart showing the percentage composition of the current soil may be generated under the Graph >

Mineralogy > Pie Chart menu option.

6.6.8   Properties Tab
The Properties tab of the Soils form provides buttons that link with the various laboratory tests typically
performed on a soil. SoilVision will color the text on each respective button the color blue if data is present
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for the current soil. The check boxes beside each button also indicate if data is present.

The buttons are arranged in a manner which is representative of the relations between soil properties. For
example, soil permeability button is shown under the soil-water characteristic curve button because soil
permeability is directly related to the amount of water present in the soil pores.

6.6.8.1   Data Presence

The majority of soils contained in the SoilVision database do not have more than two or three tests performed
on them. It is often useful, therefore, to search the database for all soils which contain experimental data on a
certain soil property. An example of this is searching the database for all soils with soil-water characteristic
curve data and permeability data. SoilVision provides two ways of selecting this data.

The first way involves the use of a pre-made search form provided by SoilVision. The search form is displayed
under the Search > Data Present menu option or the Search Type combo box of the Soil Search and Summary
form. The user may then click on the soil properties to select from the database.

The Search Wizard may also be used to select soil properties. The check boxes stored beside the buttons on
the Properties page are fields stored in the SoilVision database. The user may select certain soil properties by
setting a criteria asking SoilVision to display all records where the field is true. 

The field names relating to whether or not certain soil properties are present in the database are shown below:

Grainsize_Present

SWCC_Drying_Present

SWCC_Wetting_Present

Permeability_Present

kVoid_Present

Shear_Strength_Present

Compression_Present

Compaction_Present

Specific_Heat_Present

Thermal_Present

Unfrozen_Present

Diffusion_Present

Shrinkage_Present

Geochemistry_Present

The following sections describe the soil properties referenced from the Properties tab in more detail. The
following forms are presented:

Grain-size Distribution Form
Drying SWCC Form
Wetting SWCC Form
Permeability Form
Permeability vs. Void Ratio Form
Oedometer Compression Form
Triaxial Compression Form
Compaction Form
Shrinkage Form
Direct Shear Form
Shear Triaxial Form
Specific Heat Form
Thermal Conductivity Form
Unfrozen Water Content Form
Diffusion Form
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6.6.8.2   Grain-size Form

The purpose of the Grain-size form is to store information related to the particle-size distribution of a soil. The
laboratory data for the sieve or hydrometer analysis is stored under the Sieve Data, Hydrometer Details and
Hydrometer Datasheet tabs of the Grain-size form. The % sand, % silt, % clay, and % coarse values are stored
for both the USDA and the USCS methods of classification.

General tab contains information such as the technician, test method and laboratory notes which should be
entered before sieve or hydrometer data. The date of the laboratory test should also be entered. 

Sieve Data tab contains all information related to the recording of a sieve analysis on a soil sample. The
Grainsize Sieve Specimen ID field is provided to uniquely identify the soil specimen. The specimen field is 
optional and is intended to be subsiduaries of the Sample ID field contained in the Soils form. Sieve data may
be entered in terms of particle diameter and percent passing. The cumulative weight and phi fields are then
calculated. Please refer to the SoilVision Theory Guide for a description of the phi parameter. Test data is
recorded according to the ASTM D422-54T testing standard. Descriptions of standard buttons found on most
tabs may be found in the Standard Buttons section. Updating the Count field may be accomplished through
the Tools > Global Functions > Update Laboratory Count command of the Soils form. Please see Deleting
Subform Points for instructions on deleting errant data.

% Passing > Weight Retained button calculates the weight retained on each sieve size based on the total
sample weight and the percent passing data.

% Passing > Cumulative Weight button calculates the cumulative weight retained on each sieve size based on
the total sample weight and the percent passing data.

Cumulative > Weight Retained button calculates the weight retained on each sieve size based on the cumulative
weight.

Cumulative > Percent Passing button calculates the percent passing based on the total sample weight and the
cumulative weight.

ASTM button opens a form which displays all ASTM defined sieve sizes.

Hydrometer Details tab contains information related to the hydrometer test as specified by ASTM test standard
D422-54T or SSSA Methodology 2.4.3.5. Descriptions of standard buttons found on most tabs may be found
in the Standard Buttons section. Updating the Count field may be accomplished through the Tools > Global
Functions > Update Laboratory Count command of the Soils form. Please see Deleting Subform Points for
instructions on deleting errant data.

Hydrometer Datasheet tab contains the experimental results from the hydrometer testing indicated in the
Hydrometer Details tab.

ASTM button opens a form which displays all ASTM defined sieve sizes.

Percentages tab is used to store the % coarse, % sand, % silt, and % clay values for both the USDA and
USCS methods of classification.

Stats tab contains all statistical calculations based on the grain-size distribution. The effective grain diameter
is calculated according to the formula presented by Zamarin for the Zamarin estimation of saturated
permeability. Please refer to the SoilVision Theory Guide for a description of the theory associated with the
calculation of these statistics.

Calculate button initiates calculation of the statistics. A prerequisite for the calculations is that the grain-size
distribution curve must be fit with either the unimodal or bimodal equation. The equation which provides the
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best fit of the grain-size distribution will be used as the basis for all calculations.

Unimodal Fit tab contains all information related to the fit of the grain-size distribution with the unimodal
equation. Please refer to the SoilVision Theory Guide for a description of the theory involved with the
unimodal equation.

Bimodal Fit tab contains all information related to the fit of the grain-size distribution with the bimodal
equation. Please refer to the SoilVision Theory Guide for a description of the theory involved with the
bimodal equation.

6.6.8.2.1  Load % Clay, D10, etc.

If % clay, % silt, % sand, % coarse, D10, D20, D30, D50, or D60 information is entered in the main Grain-size form,
it is possible to translate this information to points on the grain-size distribution curve. Execution of this
function will perform this translation and automatically add the points to the grain-size distribution
experimental points. The points will be added to the appropriate Sieve Data or Hydrometer Datasheet table.
The cutoff between sieve and hydrometer data is the #200 sieve (0.075 mm). Particle diameters >= 0.075 mm
are placed in the Sieve Data table. All remaining points are placed in the Hydrometer Datasheet table. The
Load % Clay, D10, etc. command may be initiated under the Tools > Load % Clay, D10, etc. menu option.

6.6.8.2.2  Update ASTM Sieves

This command will back-calculate all sieve descriptions in the current database based on particle diameter. For
example, if a sieve diameter of 101.6 mm has been entered, the Sieve No. field would be updated to 4”. The
Sieve No. field is the only fields updated. The Particle Diameter and Percent Passing fields are not modified in
any way. The command may be found under the Tools > Update ASTM Sieves menu option.

6.6.8.2.3  ASTM Sieve Sizes

This menu option displays the ASTM sieve numbers and their corresponding screen (passing) sizes. 

6.6.8.2.4  Specification Manager

The specification manager allows the user to enter and maintain a separate list of minimum and maximum
specifications or boundaries for the grain-size distribution. This functionality is useful when running tests on
grain-size distributions that must fall within certain limits. An example of this is the upper and lower
specification limits in pavement subgrade design.

The specification manager may be found under the Tools > Specification Manager menu option in the
Grain-size form. 

Specifications may be entered in the subform provided. It is important to note that each specification contains
only a minimum or maximum specification and not both. A typical specification would consist of two entries;
one for the minimum and one for the maximum specification.

Selecting the View field of the specification manager will cause the current specification to be displayed on
ALL generated grain-size graphs and reports. 

The specifications are stored in tables in the specification database that is linked to at the start of SoilVision
operation. The specifications are therefore stored outside the SoilVision application and are unaffected by
subsequent installations of upgrades of the SoilVision software.

6.6.8.2.5  Fitting the Grain-size Distribution

Please refer to the SoilVision Theory Guide for a description of the fitting methods currently available in
SoilVision.
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6.6.8.2.6  Calculations Following the Fit of the Grain-size Distribution

Two algorithms are initiated following the fitting of the grain-size equation to experimental data. The first
calculates % clay, % silt, % sand, % coarse, D10, D20, D30, D50, and D60 based on the equation representing the
grain-size distribution. The second algorithm re-classifies the soil based on the equation of the grain-size
equation. 

The unimodal or the bimodal equations may be used as the basis for these calculations. The fit used as the
basis for these calculations is determined by selecting the fit with the highest R2 value. 

· Calculation of % clay, % silt, % sand, % coarse, D10, D20, D30, D50, and D60

One of the benefits of the two grain-size equations presented in this chapter is that conventional physical
variables can be computed from the curves. The most commonly used variables are percent clay, percent
sand, and percent silt. Also used are diameter variables such D10, D20, D30, D50, and D60. The equations
presented are of the form, Pp(d) where d is particle diameter (mm). The percent clay, percent silt, and
percent sand may therefore be a read off of the curve by substituting in the appropriate diameters. The
diameters used depend upon the criteria associated with the various classification methods. For example,
the USDA classification boundaries are 0.002, 0.05, and 2.0 mm for percent clay, percent silt, and
percent sand, respectively. The USCS classification uses boundaries of 0.002, 0.075, and 4.75 mm for
percent clay, percent silt, and percent sand, respectively. The divisions can be determined for any
classification method by substituting into the equations the appropriate diameters as shown in Figure 1.

Figure 1 Determination of the soil fractions (i.e., % clay, % silt, and % sand) when using the unimodal equation

The diameter variables must be read off of the curve in an inverse manner. The particle size diameter
answers to the question,”What particle diameter has 10 percent of the total mass smaller than this size?”.
Taking the inverse of either the unimodal or bimodal equation is difficult. A half-length algorithm was
therefore used to read diameters off the grain size curve. An initial guess diameter was selected and the
correction distance was progressively halved until the iteration process yielded a minimal error. The
results of this process can be seen in Figure 2. 
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Figure 2 Determination of the percent passing for any particle size, d, for a unimodal grain-size distribution

· Classification
The current soil is automatically classified following the fit of the grain-size distribution with an
equation. The % clay, % silt, % sand, % coarse, D10, D20, D30, D50, and D60 variables calculated from the
best-fit equation are used as the basis to classify the soil by the USCS and the USDA methods. Whether
the unimodal or bimodal equation is used as the basis for the classification is determined by the equation
with the highest R2 value.

Please refer to the Soil Classification section for a detailed description of the USCS and USDA
classification methods.

6.6.8.3   Drying Soil-Water Characteristic Curve (SWCC) Form

Classical soil mechanics has emphasized specific types of soils (e.g., saturated sands, silts, and clays and dry
sands). Research has covered the theories related to these types of soils in a completely dry or a completely
saturated condition. However, many soils do not fall into these common categories. A large portion of these
soils can be classified as unsaturated soils. Unsaturated soils have often been avoided in engineering practice
due to the complexity of their behavior. Central to the behavior of an unsaturated soil is the relationship
between the amount of water and air as the soil desaturates. This relationship is described by the Soil-Water
Characteristic Curve (SWCC). Laboratory studies have shown that there is a relationship between the
soil-water characteristic curve and the properties of an unsaturated soil (Fredlund and Rahardjo, 1993b). 

Data tab contains a subtab control containing all options regarding the recording of laboratory data.

General tab contains general information specific to each test. It is recommended that this information be input
first.

Soil State tab calculates a theoretical initial state of the soil based on insitu volume-mass properties. It is
assumed that the soil, previously at the insitu state, has been exposed to water and allowed to swell and
become saturated. The theoretical initial state of the soil-water characteristic curve soil sample is therefore
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calculated according to the following method. 

Laboratory Data tab contains laboratory data in the form of gravimetric water content versus soil suction.
Updating the Count field may be accomplished through the Tools > Global Functions > Update Laboratory
Count command of the Soils form. Please see Deleting Subform Points for instructions on deleting errant data.

Fitting tab contains all the methods currently implemented in SoilVision for the fitting of laboratory data using
mathematical equations. A description of these methods may be found in the SoilVision Theory Guide.
Descriptions of standard buttons found on most tabs may be found in the Standard Buttons section.

Estimations tab contains all methods currently implemented in SoilVision for the estimating of the soil-water
characteristic curve from simple lab data such as grain-size information. A description of these methods may
be found in the SoilVision Theory Guide. Descriptions of standard buttons found on most tabs may be found
in the Standard Buttons section.

6.6.8.3.1  Apply Fit > Fredlund and Wilson PTF

The Fredlund and Wilson estimation of the soil-water characteristic curve requires the input of a Packing

Porosity. Typically the Packing Porosity is provided through the use of a neural net. It is often useful, however,
if laboratory data exists for the soil-water characteristic curve to back-calculate what the Packing Porosity

should be. SoilVision implements a back-calculation half-distance trial and error algorithm to calculate the
optimal Packing Porosity when soil-water characteristic curve laboratory data is present. 

6.6.8.3.2  SWCC Graph Wizard

SoilVision makes use of a wizard to handle a significant number of combinations of graphs possible for the
soil-water characteristic curve. The wizard makes it simple for the user to compare several different fits of the
SWCC or compare the experimental data from a number of different soils. The options for the SWCC Graph
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Wizard are outlined in the following paragraphs.

The user must select if the generated plot is to contain a single soil or all soils selected in the current search. If
single soils are selected, the plot will only contain fits, estimations or experimental data from the current soil.
If the “all soils in current search” option is selected, the plot will draw data from all soils in the current search.
The soils in the current search are the soils currently selected in the Soils form

The user is prompted as to whether they want to plot the wetting curve, the drying curve or both curves.

Step 3 involves the solution of the appropriate curves to plot.  More than one selection may be made. The
abbreviations of PTF and PDF respectively stand for Pedo-transfer function and the probability density
function. Pedo-transfer functions are estimation functions that estimate the SWCC from simple soil data.
Probability density functions are the derivatives of the normalized fits of the SWCC.

The Graph Wizard is able to perform calculations that modify the representation of the soil-water
characteristic curve in terms of porosity or volumetric water content rather than the native gravimetric water
content format.

Laboratory data is entered in terms of gravimetric water content. Sieve gravimetric water content is a mass
representation, conversion to volumetric representations requires an indication of the volume change of the
soil during the drying process. SoilVision provides the user with two options of accounting for volume change
during drying.

The first option is to assume that very little volume change took place during the drying of the soil sample.
This assumption is usually accurate for sand-dominated soils but may not be true for clay dominated soils.

The second option is to provide a measurement of the volume change of a soil during drying by entering the
shrinkage curve. The shrinkage curve will provide volumetric data for a soil as it dries and therefore allow
calculations of volumetric properties for the SWCC. The shrinkage curve must be fit with the hyperbolic
equation to allow these calculations to proceed.

A complete description of the theory used to calculate volume-mass properties as a function of soil suctions
may be found in the SoilVision Theory Guide.

The user is now finished with the selection of graph options. The graph may be created by clicking the Finish

button. 

6.6.8.4   Wetting Soil-Water Characteristic Curve (SWCC) Form

SoilVision implements a form for the storage of information relating to the wetting of the soil-water
characteristic curve.

General tab contains all general information fields related to the SWCC wetting laboratory test. It is
recommended that these fields be entered first.

Laboratory Data tab contains data undergoing a wetting cycle in the form of gravimetric water content versus
soil suction. Descriptions of standard buttons found on most tabs may be found in the Standard Buttons
section. Updating the Count field may be accomplished through the Tools > Global Functions > Update
Laboratory Count command of the Soils form. Please see Deleting Subform Points for instructions on deleting
errant data.

Fredlund and Xing tab contains details of fitting the wetting curve with the Fredlund and Xing equation. A
description of this method may be found in the SoilVision Theory Guide.

van Genuchten tab contains details of fitting the wetting curve with the van Genuchten equation. A description
of this method may be found in the SoilVision Theory Guide.
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Brooks and Corey tab contains details of fitting the wetting curve with the Brooks and Corey equation. A
description of this method may be found in the SoilVision Theory Guide.

Minimum Recommended Input
SWCCW Test Method

SWCCW Technician

SWCCW Test Date

6.6.8.5   Saturated Permeability Form

Knowing the coefficient of permeability (hydraulic conductivity) of a soil is vital for field management of
resources and maintenance of environmental quality. Much effort has been expended to develop computer
models capable of analyzing seepage through soils. The problem is further complicated by the fact that
seepage through an unsaturated soil varies according to the degree of saturation of the soil. The determination
of hydraulic properties of a soil is also time consuming and expensive. Many measurements must be made at
various degrees of saturation to provide confidence in the hydraulic properties. It is, therefore, of value to
utilize simplified theoretical methods for the prediction of the hydraulic conductivity of soils.

SoilVision has implemented the management of saturated permeability data as well as a number of methods of
estimating the saturated permeability of a soil.

Data tab contains general information as determined in the laboratory. A field or laboratory determined
saturated permeability may be recorded.

Estimations tab contains all the methods of estimating saturated permeability currently implemented in the
SoilVision software. A description of these methods may be found in the SoilVision Theory Guide.

Minimum Recommended Input
ksat Test Method

ksat Technician

Laboratory ksat

ksat Test Date

ksat Specimen ID

6.6.8.5.1  Estimate > Inverse Hazen’s Constant

This function allows inverse calculation of Hazen’s constant when a laboratory ksat value is present.

6.6.8.5.2  Estimate > Inverse Kozeny Constant

This function allows inverse calculation of the Kozeny constant when a laboratory ksat value is present.

6.6.8.6   Unsaturated Permeability Form

Knowledge of the unsaturated properties of a soil is critical when solving seepage problems. Morover, the
function of permeability is theoretically related to the soil-water characteristic curve and estimation of the
unsaturated permeability curve should be based on the soil-water characteristic curve. SoilVision provides the
ability to both store unsaturated soil data as well as estimate unsaturated soil permeability as a function of soil
suction.

Data tab contains information related to the laboratory testing of unsaturated permeability.

Soil State tab contains the suggested theoretical initial state of the unsaturated permeability test.

Laboratory Data tab allows entry of the data regarding the unsaturated permeability test as a function of
permeability versus soil suction. Updating the Count field may be accomplished through the Tools > Global
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Functions > Update Laboratory Count command of the Soils form. Please see Deleting Subform Points for
instructions on deleting errant data.

Field Data tab allows entry of the data regarding field measurement of unsaturated permeability as a function
of soil suction.

Fitting tab contains all methods by which SoilVision allows fitting of mathematical equations to laboratory
data. A description of the theory associated with these methods may be found in the SoilVision Theory Guide.
Descriptions of standard buttons found on most tabs may be found in the Standard Buttons section.

Estimations tab contains all methods by which SoilVision allows estimation of the unsaturated permeability
curve. A description of the theory associated with these methods may be found in the SoilVision Theory
Guide. Descriptions of standard buttons found on most tabs may be found in the Standard Buttons section.

Minimum Recommended Input

Permeability Test Method

Permeability Technician

Permeability Test Date

6.6.8.6.1  Apply Fit > Leong Parameter

This function allows inverse calculation of the Leong estimation parameter when laboratory data is present. A
half-distance trial and error algorithm is used to calculate the Leong parameter.

6.6.8.7   Permeability vs. Void Ratio Form

The ability of water to flow through a soil is dependent on the size of the water-filled pores in a soil. As a soil
undergoes compression, the pores decrease and the ability of the soil to allow the flow of water is restricted.
The representation of this process is necessary when modeling the consolidation of a soil. The typical method
of representing this behavior is a relationship between permeability and void ratio. SoilVision provides the
ability to both manage laboratory data as well as mathematically represent the relationship. The permeability
vs. void ratio form may be displayed by pressing the Permeability vs. Void Ratio button in the Properties tab of
the Soils form. 

General tab contains information related to identifying of the current test. The Laboratory ksat field is pulled
from the Saturated Permeability form.

Soil State tab describes the estimated theoretical intitial state of the soil at the beginning of the permeability
versus void ratio test. This state is theoretical only and does not affect any future calculations regarding this
test. The Soil State is calculated according to the same criteria as the Soil State at the beginning of the
soil-water characteristic curve test.

Laboratory data tab allows the user to enter laboratory data in the form of permeability versus void ratio.
Descriptions of standard buttons found on most tabs may be found in the Standard Buttons section. Updating
the Count field may be accomplished through the Tools > Global Functions > Update Laboratory Count
command of the Soils form. Please see Deleting Subform Points for instructions on deleting errant data.

Taylor Estimation tab allows the user to estimate the relationship between permeability and void ratio by the
Taylor method. A description of the theory of this method may be found in the SoilVision Theory Guide.

Minimum Recommended Input
kVoid Test Method

kVoid Technician

kVoid Test Date

kVoid Specimen ID
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6.6.8.8   Oedometer Compression Form

The compression form provides information on the variance of the void ratio with changes in net normal
stress. This relationship is typically determined in the laboratory from a compression (or consolidation)
oedometer test as described by ASTM D4546. The compression curve, like the soil-water characteristic curve,
forms the basis for the prediction of volume change relations in a soil. 

General tab contains general information necessary for each run of the oedometer test.

Laboratory Data tab contains laboratory data in the form of net normal stress versus void ratio. Compression
and rebound information are entered separately to allow fitting of either curve. If the user does not desire to fit
an equation to the compression curve, all data may be entered in the compression subform. Descriptions of
standard buttons found on most tabs may be found in the Standard Buttons section. Updating the Count field
may be accomplished through the Tools > Global Functions > Update Laboratory Count command of the Soils

 form. Please see Deleting Subform Points for instructions on deleting errant data.

Two Slope Fit tab contains the equation parameters necessary to mathematically represent the compression
curve with the Two Slope equation. SoilVision also implements a two-slope equation capable of providing a
smooth representation of compression and rebound laboratory data. The two slope equation has the advantage
in that it uses the common Compression Index, Cc, Preconsolidation Pressure, Pp, and other such variables to
represent the compression curve. These variables are familiar to geotechnical engineers. A description of the
theory may be found in the SoilVision Theory Guide.

Fredlund Fit tab contains all parameters needed to fit the compression curve with the Fredlund equation. To
allow the compression curve to be used as the basis for theoretical calculations, the experimental data must be
best-fit with an equation. A modified Fredlund & Xing (1994) equation along with a fitting algorithm was
used to best-fit the experimental compression data. This provides a reasonable method of empirically
describing the compression curve. A description of the theory may be found in the SoilVision Theory Guide.

Two-Slope Generation tab allows the user to enter any initial void ratio and the rest of the compression curve
will be generated based on existing soil parameters of Cc, Cs, and Pp. The generated curve’s sole purpose is
for the interest of the user.

FHA tab contains information relating to an FHA (Federal Housing Administration) swell test. The test method
was first published in May, 1960 by T. William Lambe in “The Character and Identification of Expansive
Soils”, A Report completed for the Technical Studies Program of the Federal Housing Administration.

Minimum Recommended Input

Compression Test Method

Compression Technician

Compression Test

Compression History

Compression Test Date

Soil State tab contains the theoretical initial soil state at the beginning of the compression test is presented on
the Soil State tab of the Compression form. The theoretical initial state of the compression soil sample is
calculated according to the following method:

The water content before, after as well as the compression dry density recorded on this page are primarily for
comparison purposes. It allows the user to compare between the water contents and dry densities measured in
the laboratory and the theoretically calculated volume-mass properties.
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6.6.8.9   Triaxial Compression Form

An alternate method of determining the compression curve is through the isotropic compression test. The
isotropic compression test is primarily performed when using a critical state analysis of the volume-change
behavior of a soil.

General tab contains general information related to the isotropic triaxial test. It is recommended that this
information be input prior to laboratory data.

Soil State tab contains the theoretical initial state of the triaxial test. It is a theoretical initial state only and is
intended only as a suggested initial state. Details of the calculation of the soil state are the same as those
described in the soil state of the oedometer compression test.

Laboratory Data tab allows entry of the compression and rebound curves in the form of void ratio versus net
normal stress. Descriptions of standard buttons found on most tabs may be found in the Standard Buttons
section. Updating the Count field may be accomplished through the Tools > Global Functions > Update
Laboratory Count command of the Soils form.

Triaxial Two Slope Fit tab contains information related to the fitting of the Two Slope equation to laboratory
data as entered into SoilVision. A description of the theory of the Two Slope curve may be found in the
SoilVision Theory Guide.

Minimum Recommended Input

Iso Test Method

Iso Technician

Iso History
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Iso Test Date

Iso Specimen ID

6.6.8.10   Compaction and CBR Form

Compaction data is routinely collected in the practice of geotechnical engineering. It is often used to describe
the state of soils in the sub-base material used in the construction of roads. The compaction laboratory test is
described by the ASTM D-698 standard and is used to describe the relationship between gravimetric water
content and the dry density of a soil.

The SoilVision application accommodates the storage of laboratory data related to the compaction test. The
test method, technician, test data, specimen ID, and initial state of the soil may all be recorded for each test.
The input of al least one field in the compaction form is required before the user may proceed to the input of
water content and dry density data.

SoilVision provides functionality to estimate the compaction curve and the ability to fit several equations to
experimental data. The fits of the compaction curve provide a smooth and continuous representation of the
compaction curve. The fits also allow the added benefit of allowing the user to select groups of soils with
similar compaction curves based on the parameters used in the fit equation.

General tab contains information specific to each compaction test. It is recommended that this information be
entered prior to the entry of laboratory data.

Laboratory data tab stores information related to the standard or modified compaction test as defined by
ASTM D698. Data is entered in the form of water content versus dry density. Descriptions of standard buttons
found on most tabs may be found in the Standard Buttons section. Updating the Count field may be
accomplished through the Tools > Global Functions > Update Laboratory Count command of the Soils form.
Please see Deleting Subform Points for instructions on deleting errant data.

Quadratic Fit tab contains information related to the fit of the laboratory data by the quadratic equation. Theory
regarding this fit may be found in the SoilVision Theory Guide.

Woods Estimation tab contains information related to the Woods estimation of the compaction curve based on
one or two ponts on the compaction curve.

Li and Sego Fit tab provides parameters related to the fitting of the compaction curve by the Li and Sego
equation. Theory regarding this fit may be found in the SoilVision Theory Guide.

CBR tab contains information related to the CBR test as defined by ASTM D1883.

Minimum Recommended Input

Compaction Test Method

Compaction Technician

Compaction Test Date

Compaction Specimen ID

Compaction Initial State

6.6.8.11   Shrinkage Form

The shrinkage soil property function describes the volume change that occurs in soils during the drying
process. A description of the shrinkage of a soil is necessary when calculating potential volume decreases
under houses, buildings, roads and other similar structures. The laboratory test for measuring the shrinkage of
a soil is ASTM D-427 and the resulting laboratory data describes the relationship between gravimetric water
content and void ratio.

General tab allows input of the fields associated with each shrinkage test. It is recommended that these fields
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be entered prior to the entry of laboratory data.

Laboratory Data tab allows the input of data in the form of gravimetric water content versus void ratio as
determined by the ASTM D427 test method. Descriptions of standard buttons found on most tabs may be
found in the Standard Buttons section. Updating the Count field may be accomplished through the Tools >
Global Functions > Update Laboratory Count command of the Soils form. Please see Deleting Subform Points
 for instructions on deleting errant data.

Fredlund and Fredlund PTF tab contains all data associated with the estimation of the shrinkage curve by the
Fredlund and Fredlund method. A description of the theory involved in the estimation of the shrinkage curve
by this method may be found in the SoilVision Theory Guide.

Hyperbolic Fit tab contains all information related to the fitting of the shrinkage curve with a hyperbolic
equation.

Shrinkage Limit tab contains information related to the determination of the shrinkage limit of a soil using the
ASTM D427 test method.

Minimum Recommended Input

Shrinkage Test Method

Shrinkage Technician

Shrinkage Test Date

Shrinkage Specimen ID

Soil State tab contains the theoretical initial state of a soil at the start of the shrinkage test is presented in the
Soil State tab of the Shrinkage form. The soil state tab is meant only as a theoretical suggested starting point
for the shrinkage curve test. Matching the beginning theoretical soil state is only important when calculating
constitutive soil properties. The theoretical initial state of the shrinkage soil sample is calculated according to
the following method:

6.6.8.12   Shear Triaxial Form

The shear triaxial form manages data as recorded from a triaxial test performed according to the ASTM
D4767-95 or D2850-95 standards. Recorded data includes pore-air pressure as well as pore-water pressure
data to include unsaturated soils data. Standard graphing and reporting methods are also implemented.

General tab allows input of the data specific to the traixial test.

Mohr-Coulomb Envelope tab contains the cohesion and effective angle data. This data may be entered by the
user or calculated from laboratory data. The cohesion and effective angle may be calculated based on
experimental data using the Tools > Triaxial > Calculate Mohr-Coulomb Envelope command. The Tools >

Triaxial > Search > Calculate Mohr-Coulomb Envelope command may also be used to calculate the cohesion
and effective angle for every soil in the current search.

Laboratory Data tab contains the readings of major and minor principal stresses. A specimen ID is included in
each line to allow data to be recorded from multiple runs at varying stress conditions. The multiple
Mohr-Coulomb circles may then be combined to calculate the overall Mohr-Coulomb failure envelope.
Descriptions of standard buttons found on most tabs may be found in the Standard Buttons section. Updating
the Count field may be accomplished through the Tools > Global Functions > Update Laboratory Count
command of the Soils form. Please see Deleting Subform Points for instructions on deleting errant data.

6.6.8.12.1  Calculate Mohr-Coulomb Envelope

SoilVision has implemented an algorithm which can calculate the effective cohesion and the effective angle of
internal friction, f, from laboratory data. The calculation algorithm may be initiated with the Tools > Calculate

Mohr-Coulomb Envelope. The user may also calculate the Mohr-Coulomb parameters on all soils in the current
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database using the Tools > Search > Calculate Mohr-Coulomb Envelope command.

The algorithm will perform linear interpolation on all shear failure conditions on the zero suction plane. The
results of the algorithm are placed in the Mohr-Coulomb Envelope tab on the Shear Strength form. The
algorithm may be run on all soils in the current search by selecting the search option. If there is insufficient
data to perform the linear interpolation, the existing values of cohesion and friction angle are not modified.

6.6.8.13   Direct Shear Form

The direct shear form manages data recorded from a direct shear test performed according to the ASTM
D3080-98 standard. Allowances have been made to manage both unsaturated and saturated direct shear data.
The Mohr-Coulomb saturated envelope or unsaturated surface may be calculated based on laboratory data.

A theoretical framework for unsaturated soil mechanics has been firmly established over the past couple of
decades.  The constitutive equations for volume change, shear strength and flow for unsaturated soil have
become generally accepted in geotechnical engineering (Fredlund and Rahardjo, 1993a).  The measurement of
soil parameters for the unsaturated soil constitutive models, however, remains a demanding laboratory
process. 

SoilVision provides engineers with a means of estimating the shear strength function for an unsaturated soil
from the soil-water characteristic curve by using the saturated shear strength parameters as the starting values
along with the soil-water characteristic curve. The theory was developed from work done by the author along
with D.G. Fredlund, A. Xing, and S.L. Barbour (1996).

SoilVision is the only commercially available database product which will allow the storage of unsaturated
soil properties. This is particularly useful in the area of the shear strength of unsaturated soils. The degree of
saturation of a soil has a significant effect on the shear strength. 

General tab allows input of test-specific information. It is recommended that this information be entered prior
to the entry of laboratory data.

Mohr-Coulomb Envelope tab contains the cohesion and effective shear strength angle parameters. These
parameters may be entered by the user or calculated based on laboratory data. The method of calculation is
described in the Calculate Mohr-Coulomb Envelope section.

Laboratory Data tab contains a subform where laboratory data may be entered. Descriptions of standard
buttons found on most tabs may be found in the Standard Buttons section. Updating the Count field may be
accomplished through the Tools > Global Functions > Update Laboratory Count command of the Soils form.
Please see Deleting Subform Points for instructions on deleting errant data.

Soil suction may be input in it’s separate components of pore-air pressure and pore-water pressure. Soil
suction is related to these two components by the following equation:

y=(ua-uw) [ 1 ]

where:
y  = soil suction,
ua  = pore-air pressure, and

uw  = pore-water pressure.

If a zero or positive soil suction is desired, the water pressure must be equal to or greater than the air pressure.

Fredlund and Xing PTF tab controls the calculation of the unsaturated Mohr-Coulomb shear strength envelope
by the Fredlund and Xing method. A description of the theory used in this calculation may be found in the
SoilVision Theory Guide.
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6.6.8.13.1  Calculate Mohr-Coulomb Envelope

SoilVision has implemented an algorithm which can calculate the effective cohesion and the effective angle of
internal friction, f, from laboratory data. The calculation algorithm may be initiated with the Tools > Calculate

Mohr-Coulomb Envelope. The user may also calculate the Mohr-Coulomb parameters on all soils in the current
database using the Tools > Search > Calculate Mohr-Coulomb Envelope command.

The algorithm will perform linear interpolation on all shear failure conditions on the zero suction plane. The
results of the algorithm are placed in the Mohr-Coulomb Envelope tab on the Shear Strength form. The
algorithm may be run on all soils in the current search by selecting the search option. If there is insufficient
data to perform the linear interpolation, the existing values of cohesion and friction angle are not modified.

6.6.8.14   Specific Heat Form

Modeling thermal changes in a soil requires knowledge of the specific heat of a soil. The specific heat of a soil
is not constant for an unsaturated soil but varies depending upon the degree of saturation. Often, saturated or
dry specific heat capacities are used during numerical modeling but this is not satisfactory for an unsaturated
soil. The Farouki (1981) method has been selected in SoilVision that combines soil-water characteristic curve
information with the mass specific heat of the soil solids in order to predict the volumetric specific heat
capacity of the soil for all degrees of saturation. SoilVision does not impliment any methods for the
establishing of the saturated specific heat of the soil.

SoilVision does not provide fields for the storage of laboratory specific heat data due to the rarity of this data.

General tab contains information relating to the person supervising estimation of the specific heat. Most
importantly is input of the saturated specific heat of the soil. Descriptions of standard buttons found on most
tabs may be found in the Standard Buttons section.

Farouki PTF tab contains information related to the estimation of the unsaturated specific heat of a soil as a
function of soil suction.

Minimum Recommended Input

Specific Technician

Specific Heat of Soil

6.6.8.15   Thermal Conductivity Tab

Estimation of the thermal conductivity of a soil is necessary for predicting heat flow. Experimental
measurements of this property are, once again, difficult to obtain. As a result, the estimation of thermal
conductivity has often been used for heat flow analysis. The water contents of a soil can vary significantly and
change the thermal conductivity of the soil. SoilVision provides a continuous function to describe the thermal
conductivity at all degrees of saturation. Johansen (1975) developed a method of predicting thermal
conductivity. The method required the input of soil state, soil gradation, quartz content, and a soil-water
characteristic curve. The method then provided a continuous equation describing the thermal conductivity as
a function of soil suction.

General tab provides access to general information entered at the start of a thermal conductivity test. 

Laboratory Data tab contains data in the form of thermal conductivity versus soil suction. Descriptions of
standard buttons found on most tabs may be found in the Standard Buttons section. Updating the Count field
may be accomplished through the Tools > Global Functions > Update Laboratory Count command of the Soils

 form. Please see Deleting Subform Points for instructions on deleting errant data.

Quartz Content tab contains information relating to managing the quartz content of the current soil.
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Johansen PTF tab contains information relating to the estimation of the unsaturated thermal conductivity by
the Johansen method. A description of the theory behind this method may be found in the SoilVision Theory
Guide.

Fredlund Fit tab contains information relating to the fitting of the thermal conductivity form. A description of
the theory behind this method may be found in the SoilVision Theory Guide.

Minimum Recommended Input
Thermal Test Method

Thermal Technician

Thermal Test Date

Thermal Specimen ID

6.6.8.16   Unfrozen Water Content Form

The modeling of heat flow processes in frozen soils is a relatively common geotechnical problem. As a result,
there is a need for a relationship between unfrozen volumetric water content and temperature for a soil. Such a
relationship can be measured in the laboratory using equipment such as a pulsed nuclear magnetic resonance
(PNMR). Since equipment is costly, methods have been developed for the estimation of the unfrozen
volumetric water content soil functions. The soil-water characteristic curves can be used to predict unfrozen
water content of a soil as a function of temperature and negative pore-water pressure (Miller, 1973). This has
led to a formulation allowing the unfrozen volumetric water content curve to be predicted from the soil-water
characteristic curve (Black, 1989). SoilVision has selected this technology to allow the estimation of unfrozen
water content curves. SoilVision also allows the warming or cooling water content curves to be represented by
a smooth mathematical function.

General tab contains general information related to the unfrozen volumetric water content test. It is
recommended that this data be entered before the entry of laboratory cooling or warming data. Descriptions of
standard buttons found on most tabs may be found in the Standard Buttons section.

Laboratory Cooling Data tab contains laboratory data in the form of unfrozen volumetric water content versus
temperature where temperature is in degrees Celcius below freezing. Updating the Count field may be
accomplished through the Tools > Global Functions > Update Laboratory Count command of the Soils form.
Please see Deleting Subform Points for instructions on deleting errant data.

Laboratory Warming Data tab contains laboratory data in the form of unfrozen volumetric water content versus
temperature where temperature is in degrees Celcius below freezing. Updating the Count field may be
accomplished through the Tools > Global Functions > Update Laboratory Count command of the Soils form.
Please see Deleting Subform Points for instructions on deleting errant data.

Black PTF tab contains information related to the estimation of the unfrozen water content curve by the Black
method. A description of the theory behind this method may be found in the SoilVision Theory Guide.

Cooling Fit tab contains information related to the fitting of an equation to laboratory cooling data. A
description of the theory behind this method may be found in the SoilVision Theory Guide.

Warming Fit tab contains information related to the fitting of an equation to laboratory warming data. A
description of the theory behind this method may be found in the SoilVision Theory Guide.

Minimum Recommended Input

Unfrozen Test Method

Unfrozen Technician

Unfrozen Specimen ID
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6.6.8.17   Diffusion Form

Studies have shown that diffusion can be the dominant mechanism governing the movement of contaminants
in fine-grained soils (Lim, 1996). Low hydraulic conductivities can result in diffusion becoming a significant
transport mechanism. Diffusion coefficients are readily available for most chemicals assuming the diffusion is
through distilled water. Complications arise when applying these diffusion coefficients to a soil. The difficulty
arises due to the tortuosity of the diffusion path around the particles composing the soil. An added difficulty
arises due to changes in the degree of saturation of a soil that may change over time. As the degree of
saturation decreases, a significant reduction in the coefficient of diffusion has been noted (Lim, 1996).
SoilVision has therefore selected a method consistent with Lim’s (1996) data for predicting the variation in
the coefficient of diffusion for a soil as the volumetric water content (or the degree of saturation) of a soil
varies.

General tab contains general information related to the diffusion test. It is recommended that this data be
entered before data under the Laboratory Data tab be entered.

Laboratory Data tab contains data from the unsaturated laboratory test in the form of diffusion coefficient
versus soil suction. Descriptions of standard buttons found on most tabs may be found in the Standard Buttons
 section. The Count field represents the number of data points entered for the current laboratory test. Updating
the Count field may be accomplished through the Tools > Global Functions > Update Laboratory Count
command of the Soils form. Please see Deleting Subform Points for instructions on deleting errant data.

Lim and Barbour PTF tab contains information related to the estimation of the unsaturated diffusion curve by
the method proposed by Lim and Barbour. Details of this estimation technique may be found in the SoilVision
Theory Guide.

Drying Fit tab contains all information pertaining to the fitting of the diffusion curve. A description of the
theory behind the fitting may be found in the SoilVision Theory Guide.

Wetting Fit tab contains all information pertaining to the fitting of the diffusion curve. A description of the
theory behind the fitting may be found in the SoilVision Theory Guide.

Minimum Recommended Input

Diffusion Test Method

Diffusion Technician

Diffusion Test Date

Diffusion Specimen ID

DS

Cf
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7 Search Wizard
SoilVision has implemented two general methods for searching the data in the SoilVision database:

Customized searches, and 
Search Wizard

Customized searches allow the user to search the database based on a specific field or group of fields. For
example, customized searches implemented in SoilVision allow the user to search the database by soil texture.
Customized searches are implemented into SoilVision to allow the user to quickly search the database for
commonly used fields. The main limitation of customized searches is that the user is restricted to
pre-determined fields. To overcome this limitation, SoilVision has implemented the Search Wizard.

The Search Wizard is a complete and powerful search management system. It allows the user to design and
save searches based on any combination of database tables, fields, sorting order, and criteria. The Wizard
allows the user complete control over the selection of soils based on any imaginable criteria. The following
sections describe in detail the use of the Search Wizard. Examples of searches are also distributed with the
SoilVision product and may be used as templates by the user.

The Search Wizard is built on the standard Structured Query Language (SQL) method of extracting data from
databases. Structured query language is by far the most popular non-procedural data access language today on
computers of all sizes (Litwin, 1997).  SQL forms the basis for Microsoft Access to retrieve data from a
database. Unfortunately, SQL can be difficult to learn and slow to type in commands. The Search Wizard
provides a complete system to develop and organize searches based on a set of Access tables. Its user-friendly
interface allows people unfamiliar with the operation of searches or SQL to retrieve data from the database.
The development of new searches in the organization of existing searches is made easy with the Search
Wizard.

7.1 Main Search Form

The main search form shows an itemized list of the searches available for the selection of data in the current
database. Searches can be added or deleted based on the user’s preference.

To view the properties of a specific search, click on the particular search then, select the appropriate property
by clicking one of the buttons on the bottom of the form.

All search forms are synchronized to the search selected in the main search form. If a different search is
selected in the main form all related forms will be appropriately updated.

A search may be applied to the current database by pressing the Search! button at the bottom of the main
search form. This action will cause the selection of all data that meets the criteria of the currently selected
search, and will display the results in the Soil Summary and Searching form.

A user may desire to view all data currently available. This can be accomplished by clicking on the view All

Records button at the bottom of the main search form. This feature is also useful for canceling the effect of a
previous search.

The Search Wizard allows sorting of the currently stored searches by pressing the buttons at the top of the
respective columns of data. For example, pressing Search Name will cause all searches to be sorted according
to the search name. The default display is to sort all searches based on their creation date. The most recently
created searches are displayed at the top of the list.

The search details fields (Creator, Keyword, Comments, and Display top) are used to categorize the current
search. Once the user has created a significant number of searches, it is useful to categorize searches based on
the detail fields. For example, selecting all searches based on a certain user or a certain key word. The Creator

and Keyword detail fields at the top of the Search Wizard allow such selection. All searches in their original
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order may be viewed by pressing the All button at the top of the Search Wizard form.

Only the search name is required as a minimum for a new search.

7.2 Search Tables

The tables included in the current search is the first step in building a search. The tables selected in the current
search must be indicated before any fields can be specified in the Criteria or Sorting sections of the search. A
description of the fields associated with each table may be found in the Data Definition documentation
provided by SoilVision Systems Ltd. The tables outlined in this form also correspond to the forms in
SoilVision. For example, to build a search accessing the Laboratory ksat field in the permeability form, the
Permeability table must be selected in the search.

Relationships between each selected table are determined automatically based on specifications created in the
database.

The tables form corresponds to the FROM clause in SQL syntax. The details of the corresponding SQL
statement can be seen at the bottom of the form.

There is a relationship between the tables selected and the fields available in the search criteria section. A table
corresponding to each field specified in the criteria section must be present. The search engine will
automatically enforce this relationship. If a table is removed from a search, all criteria containing fields from the
deleted table will also be deleted.

7.3 Search Sorting

The Sorting form controls the order of the returned records. This order may be specified as ascending or
descending. 

Each search may only be sorted based on tables included in the current search. The tables included in the
current search may be viewed in the Search Tables form. New sort orders may be added or deleted by pressing
the buttons at the bottom of the form.

7.4 Search Criteria

The criteria form is the heart of search creation. It allows a subset of information to be selected from the
overall dataset.  The logic controlling this selection process is specified in the criteria form. 

The criteria specifications included in the Search Wizard are designed to duplicate all the features of the
Microsoft Access search interface. Great flexibility has been included to simulate the Microsoft system.

The criterion(s) may be created by selecting options from the criteria editing fields.

The fields available for criteria selection are determined by the tables selected in the current search. Once a
field is selected, an operator must be specified. The field after the operation field may be specified to be either
another field in the database, a formula, or a value. Care must be taken to make sure the data types of the value
specified must match the data types of the selected field.

The bridge field specifies the operator to be used between individual criteria. The order that criteria are
incorporated into the SQL statement can be controlled by the up and down buttons at the side of the criteria
list box.

The layer field allows the nesting of certain criteria one within another. Criteria are nested from lowest to
highest layer. A maximum of 5 layers is permitted.

The following points should be noted when creating search criteria:
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· While SoilVision allows laboratory readings and data to be entered and plotted in a wide
variety of units, the units specified in the Search Criteria form must be in Metric only.

· SoilVision automatically determines the type of field used in the current criteria and
automatically adds quotes to the Value One and Value Two fields if the the current field type is
a text field.

· The asterisk ‘*’ character acts as a wild card when specifying searches. This means that
specifying the criteria of all USDA_Textures like “*sand*” will select not only Sand but Sandy
Loams, Sandy Clays, etc.

· Not all data is present for every soil. It is therefore useful to specify that blank or null fields be
left out of a current search. This may be accomplished by selecting the “Blank” or “Not Blank”
operators in a search criteria. An example of this is selecting all soils where the
Laboratory_ksat field is Not Blank.
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8 Statistical Calculations
Statistical functions are useful when used in conjunction with soils data to calculate confidence limits, check
correlations, and determine if relationships exist between soil parameters. SoilVision allows free-form
statistics to be calculated based on any field preset in the database. SoilVision also allows statistical functions
to be calculated based on any particular subset of the data set as selected by the Search Wizard.

SoilVision implements many basic statistical functions used in the field of geostatistics. Statistical tools may
be selected under the Tools menu options when in the Search Wizard. The geostatistics module will only work
with searches defined in the Search Wizard.

It is not the purpose of this user manual to provide a complete description of geostatistics. The functions
provided in SoilVision are described in geostatistics textbooks. A more in-depth description of the theory
behind the statistical calculations may be found in the SoilVision Theory Guide.
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9 Correlation Manager
The correlation manager provides access to a database of correlations commonly used in the practice of
geotechnical engineering. The correlations along with the references are included under the Tools menu of
most forms in SoilVision. Pressing Tools > Correlation Manager… will automatically search the correlations
database for any information related to the current location of the user in the SoilVision package. For example,
pressing Tools > Correlation Manager… while in the Compression form will pull all correlations in the
database related to the compression aspect of soil behavior. 

SoilVision Systems Ltd. is constantly looking for ways to improve our service to our users. If you have
correlations that you would like to donate for use in the SoilVision database, please contact us.
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10 The SoilVision Dataset
SoilVision  is the only software database system that provides you with an existing dataset of detailed
information on over 6000 soils. Whether you are looking for an estimate of soil dry density, the compression
index, the compaction characteristics or the soil-water characteristic curve, SoilVision allows for complex
searching of the included dataset.

Since much of the data included in SoilVision is from research publications, the reference to the original
journal paper the data was published in is included. This allows for selection of soil data by author, journal,
year of publication.

The SoilVision application allows the user to search the database of over 6000 soil-water characteristic curves,
2500 saturated permeabilities, 600 permeabilitycurves, 100 compression curves, 50 shrinkage curves, 30
compaction curves, 25 unsaturated direct shear tests, etc. for approximate parameters. All soils contained in
the database have been automatically classified by the USDA and USCS (ASTM) systems to ensure proper
grouping.

Develop your own database! SoilVision provides full database capabilities for the importing of your company’
s dataset. This allows development of your own company’s dataset to optimize the value of your data.

Data exists for the following 33 countries:

Australia Mexico Switzerland 
Belgium Netherlands The Netherlands 
Brazil New Zealand Trinidad and Tobago 
Canada Niger Tunisia 
Denmark Papua New Guinea United Kingdom 
France Philippines United States 
Germany Poland Vietnam 
Hong Kong Portugal W. Bengal India 
Israel Russia West Germany 
Italy Scotland West Indies
Ivory Coast Senegal 
Japan Singapore 
Kenya Spain 

Data is also available for the following 33 states:

Alabama Iowa New York
Alaska Louisiana North Carolina 
Arizona Maine North Dakota 
California Massachusetts  Ohio 
Colorado Michigan Oklahoma
Florida Minnesota South Carolina
Georgia Missouri South Dakota 
Hawaii Montana Virginia 
Idaho Nebraska Tennessee
Illinois New Jersey Texas 
Indiana New Mexico Washington State

Wisconsin
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Figure 3 Growth of the SoilVision dataset over time.

10.1 Acquisition of existing databases

Existing experimental data was needed to test the design of SoilVision. Once a sample database of soils
information was acquired, statistical calculations were performed to check the validity of theoretical
estimations as well as to provide an estimation of the reasonableness of current soil properties. The design of
the knowledge-based system allows for soil data to be continually added to the system. Hundreds of research
publications containing soil-water characteristic curves were reviewed and compiled by Sillers (1996) into a
database of soils information. Other information was compiled from various other sources. All information is
fully referenced by publication and dataset should the user want to check the credibility of any particular
dataset.

SoilVision offers the world’s largest database of detailed soils information currently available. No other
database system offers you physical data to test the range of your soil properties. Soils may be grouped and
typical behavior examined. Access to this database of over 6000 soils allows the user unprecedented
opportunity for soil analysis. 

10.2 Methodology for Imported Soils Data

Soils data was typically received in the form of long ASCII text files. A procedure was then developed to
ensure the data was correctly imported and implemented into the database. Data integrity is of great
importance and will affect the ability of the database to present reasonable calculations and correlations. 

Text files were typically organized in a table-type format. Data values were separated by knowing the number
of characters present in each field. This format allowed easy importing of information into ExcelÔ by import
functions provided by the program. Manual verification of the data was then performed in ExcelÔ to ensure
correct importing of data. Data was then imported into the database. SoilVision also performed checks on data
to determine if the field type was correct (e.g. a numeric field did not contain characters) and that the field was
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within the allowable range predefined for that field. An example of using predefined limits was that the
allowable range for porosity must be greater than zero and less than 100%. If a soil contained fields outside
allowable limits, the soil was regarded as erroneous and discarded.

Spot checks were then performed on the data. Soils were picked at random and checked against original text
files to check for errors. If any errors were found, the current soils information was deleted and the import
process was repeated. 

Volume-mass calculations were then completed. Soils information obtained typically contained three
volume-mass properties such as porosity, volumetric water content, and specific gravity. Using these three
properties, the remaining volume-mass properties were calculated. Once the remaining volume-mass
properties were calculated, the properties were checked for reasonableness. Soils with unreasonable
volume-mass properties were discarded.
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11 Importing Data
The most simplistic method of moving soil data into the SoilVision database is through manual data entry.
This method is often adequate if the end-user has fewer than 20 soils to enter. If the user has large amounts
data contained in spreadsheet tables then manual data entry can be a tedious task. SoilVision has implemented
a standardized import form to allow users to cut and paste large amounts of data into the SoilVision database. 

The import form may be found under the Tools menu option of each respective area of SoilVision. For
example, the grain-size menu contains the import form for importing data into the Grainsize table, the Sieve
table and the Hydrometer table.

First and foremost, data must be imported into SoilVision in a top-down fashion. In other words, the import of
data must proceed according to the following sequence:

Table Name Index

Project Project_ID

Boreholes Borehole_ID

Soils Soil_Counter

Subtable (i.e., Grain-size) Soil_Counter

Subsubtable (i.e., Sieve) Soil_Counter

The import form contains raw table data. With this in mind, the following points must be noted.

All data must be imported in Metric format according to the definition in the SoilVision Data Definition guide
(contact us if you do not have this guide).
Theoretical and calculated data may not be imported, only raw laboratory data.
Index fields (i.e., Project_ID, Borehole_ID, and Soil_Counter) must be present in the parent table. For
example, all borehole records imported must have a Borehole_ID field defined as well as a Project_ID which
already has been imported into the database.
Project_ID and Borehole_ID index fields may be characters but the Soil_Counter field must be an integer.
It is recommended that random checks be performed on the data to ensure proper importation.
the >> XLS button may be used to export a template of the proper column headings to an ExcelÔ spreadsheet.

Please contact SoilVision Systems Ltd. at support@soilvision.com for further information regarding the
import process.

11.1 Importing Data from SoilVision Data Format E

Data may be imported from another database which contains data in the SoilVision database E format. The file
may contain a single soil or multiple soil records. All data in the target database will be imported. The
command may be found under the Tools > Import > Import format E database… menu command of the Projects

 form. Indexes of the database must remain unique, however, so it is important to note the following when
importing soils data.

Preservation of the index values in all tables is maintained. This means that if project ‘PR2332’ exists in your
current database and you try to import data from a format E database which contains a project record with a
Project ID value of ‘PR2332’, the import of the project record will fail. Importation will continue on with
other records which do not conflict with existing values. This problem can be alleviated by deleting
conflicting records prior to the import process.
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12 Exporting Data
There are several ways of moving data out of the SoilVision database. SoilVision has adopted an Open
Database Architecture which allows full access to all soils data from anyone with a commercial version of MS
Access 97. The soils database file (i.e., SVSoils_Client.mdb) may be opened in Access and the data may be
exported on a variety of formats. This ensures that data is not tied to the SoilVision application in the future.

SoilVision also allows data from a single soil to be exported to a database file. This file may then be attached
to an E-mail and sent to another person using the SoilVision database. This feature is extremely useful for
people transferring soil test data.

SoilVision has also implemented the export of data on the British AGS format. The export process for the
AGS format is described in the following section.

12.1 Exporting and E-mailing SoilVision 4.x Data

SoilVision provides the ability to export data for a single soil to an .MDB database file. This file may then be
attached to an E-mail and sent to another person for import into their SoilVision database. This feature greatly
simplifies the exchange of soils data. The command may be found under the Tools > Export > SoilVision 4.x

Soil Data menu command of the Soils form. This command is not available when the user is attached to the
SoilVision distributed database of pre-existing data.

12.2 Exporting a Customized Table

SoilVision provides the ability for the user to export a customized table of soils information. Selected fields
from one or more tables may be combined into a single table and displayed in table format. The table may then
be cut and pasted to other Windows programs such as Excel.

Exporting of a customized table may be accomplished under the Search Wizard by pressing the Make Table

button. The Make Table button is visible when the user has the MyData or Demo databases open. The Make

Table button is not available when the user has the Data soils database open.

The user begins by creating a search in the same way as described in the Search Wizard section of this User’s
Manual. Fields, tables, criteria, and a sorting order must be specified. Once the search is created, the Make

Table button may be pressed and a datasheet will appear containing the data as specified. Data may be selected
and cut or copied by selecting the buttons down the left side of the datasheet.

It should be noted that raw data will be exported. The units on all data stored in SoilVision are metric units.
Exact unit descriptions of each field may be found in the SoilVision Data Definition.

12.3 Exporting Borehole Surface Data

Exporting borehole surface data may be accomplished through the Borehole Export Wizard located on the
Tools > Export > Borehole Export Wizard which may be found on the menu of the Boreholes form. The wizard
allows the export of soil geometry so that it may be viewed with related software such as ArcViewÔ or Surfer
Ô. ArcView allows borehole information to be located on a topological map while the Surfer software allows
kriging of soil information for 3D representation of soil layers.

The first stage of the Borehole Export Wizard is to select the boreholes that contain information to export.
Boreholes are selected by clicking on the borehole and pressing the arrow button to move them to the Selected
Boreholes list. The number of soil samples which are entered for the currently selected boreholes may be
found by pressing the Refresh button.

The next step involves the selection of the type of GPS coordinates to use. SoilVision allows entry of three
types of GPS coordinates and either format may be selected.
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A method of identifying soil layers must next be selected. SoilVision allows a number of ways of selecting the
soil layer.

The Borehole Export Wizard then requires the selection of a field to use as an appropriate z coordinate value.
It should be noted that the selected fields represent a depth reading. The z coordinate is therefore calculated as
the surface elevation minus the depth field.

The final page of the Borehole Export Wizard allows the user to specify the type of file which will be created
with the specified output.

Once the file has been created, it may be imported into the appropriate software for visualization. Please refer
to the user’s manual of related software for import procedures.

12.4 British AGS Format

Data within SoilVision may be exported on the British AGS data standard. This was implemented to ensure
compatibility with the AGS standard as used in Europe and other parts of the world. The standard is
implemented and maintained according to the standards presented on the http://www.ags.org.uk/ web site.

The AGS Export module may be found under the Tools > Export > AGS menu option of either the Projects or
Boreholes form. Please contact us for a complete description of the fields which are mapped from the
SoilVision data structure to the AGS data structure. This command is not available when the user is attached
to the SoilVision distributed database of pre-existing data.

12.4.1   WinLoG Export Wizard
The WinLoG Export Wizard is used to export borehole information stored in the SoilVision data structure to
the WinLoG software. This allows the SoilVision database to act as a data warehouse for your soil data.
Laboratory data may then be exported to WinLoG templates to create a variety of borehole logs. The WinLoG
Export Wizard is designed to work with WinLoG version 3.0.

12.4.1.1   Minimum Data Requirements

Before starting this Wizard, you should familiarize yourself with the templates that exist in WinLoG. For each
soil in SoilVision, the minimum data requirements include Horizon Depth, Sample Depth, Soil Description,
and a texture from one of the classification systems. The wizard disallows exporting of any soil record that
does not contain this information. Any graph information on the selected template must also be exported from
SoilVision. The WinLoG Export Wizard only exports data in metric form.

12.4.1.2   WinLoG Wizard

The Wizard is located in the Tools > Export > WinLoG menu of the Projects form. In the course of exporting to
WinLoG, you will need to select the path to the WinLoG Master Projects and borehole databases.

Any buttons that have been grayed out indicates that the button will not work until you have met certain
preconditions. To meet the preconditions you will have to make selections from the drop down boxes,
command buttons, or option buttons. These conditions exist to ensure that the minimum data requirements are
met.

12.4.1.3   Borehole Selection

The first step is to select the borehole that is to be exported. The drop down box will contain all the boreholes
that contain at least one soil in the current SoilVision database. 
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12.4.1.4   Project Creation

The next step is to choose between adding borehole information to an existing WinLoG Project, or create a
new WinLoG Project.

12.4.1.4.1  Add To Existing Project

If you choose to add borehole information to an existing project, you will have to select the path of the Master
Project database. The default location of this database is C:\Program
Files\GAEA\WinLoG\database\gaeaproject.mdb. 

Once the path is selected, it will be displayed in the text box adjacent to the Get Path button. Now you will be
able to select the project to which you want to add borehole information in the drop down box. Once you
choose a project, you will need to select the path of the Borehole Project database. The default path of the
Borehole Project database is a sub-folder off the Master folder. A typical path would be C:\Program
Files\GAEA\WinLoG\database. The name of the sub-folder will have the same name as the project. The name
of the Borehole Project Database is the name of the project combined with the word “winlog”. 

12.4.1.4.2  Create New Project

If you choose to create a new project, you will need to select the path of the Master Project database. The
default location of this database is C:\Program Files\GAEA\WinLoG\database\gaeaproject.mdb. The
sub-folder and the project database, which will store the borehole information, will automatically be created
for you.

12.4.1.5   WinLoG Template Path

You will need to select a WinLoG borehole template so that the imported borehole geometry can be displayed
in WinLoG. To view a list of existing WinLoG templates, must select the Template database. To do this, click
on the Get Path button.  The default location of this database is C:\Program
Files\GAEA\WinLoG\database\winlog.mdb. 

The default name of the Template database is “winlog”. To select the path move through folders until the
desired database is displayed, then double-click on the database. 

12.4.1.6   WinLoG Template

Once the correct database is selected, the export Wizard will load the names of all the templates in the drop
down box adjacent to the Get Path button. To select a template, choose that template from the drop down box.

12.4.1.7   Graph Selection

You now need to choose if there are graphs on the template exclusive of the Water Content Graph. The Water
Content Graph is selected separately from the Graph selection because Water Content information is treated
differently by the WinLoG software. 

If the user chooses yes, a button will appear on the form labeled Select Graph Data. Clicking the Select Graph

Data button will take you to the Soil Property Selection form. If there are no graphs on the template then you
can go straight to the Water Content Graph Selection.

12.4.1.8   Soil Property Selection

There are three kinds of graphs; Single, Double, and Bar. The Single graph displays data from one soil
property; each data point is shown as a symbol and is joined to the next data point by a straight line. A Double
graph is the same as a Single graph except the graph displays data from two soil properties. The Bar graph
displays data from one soil property as a bar graph. 
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At the top of the form is the name of the template that you have selected. The first step is to choose the Graph
Type.

You will now have to select the soil property to be displayed. There are three categories of soil properties;
Borehole, Volume Mass and Grainsize, and Environmental. You can use the toggle buttons on top of the Soil
Property list box to cause the list box to display specific categories of soil properties. Once you have selected a
Soil Property, a matching property must be selected in the WinLoG Template. If the soil property that is
selected is an environmental property then you must select a unit measurement from the units list box. 

If there is no data in the SoilVision database for the selected environmental property, a message box will
appear stating there are no records for that soil property in the database.

The list of graphs in the Template list box is the total number of graphs that will be displayed on the WinLoG
template. Once the required selections for each graph have been made, the Next button will become enabled,
letting you to select properties for the next graph. If mistakes were made on previous selections, these can be
corrected by clicking on the Prev button. When you have selected all the graphs for the WinLoG Template,
then click on the close button. You will then be returned to the WinLoG Export Wizard. Clicking on the
WinLoG Template box after graph data has been selected, or choosing No, that there are no graphs on the
template, will cause information entered in the WinLoG Graph Selection form to be deleted.

12.4.1.9   Water Content Selection

Choose Yes if you wish to include a Water Content Graph on the selected template. Water Content is handled
differently due to the inclusion of the Liquid Limit and Plastic Limit fields.

12.4.1.10   Soil Texture Classification

The Soil Texture, along with the soil description, are used to label horizons (or soil layers) on the WinLoG
template. The only choices are currently between the USCS Texture or the USDA Texture classifications.

12.4.1.11   Export Borehole

The Borehole is now ready to be exported. Clicking on the Export Borehole button will export data from
SoilVision to the WinLoG file system.

A message will appear, asking you if you want to Export to WinLoG. Click Yes, and the Borehole will be
exported to the existing WinLoG databases. Click No, and the Export to WinLoG is cancelled.

12.4.1.12   WinLoG

Viewing the exported borehole requires that WinLoG 3.0 be installed on your system. Complete the following
steps to view an exported borehole:

1. Start-up WinLoG. 
2. Open the project selected in the SoilVision export. 
3. Open the Borehole previously exported. 

The borehole log will be lacking some information. Any graphical representations that are on the template will
not be shown. The following information is not exported from SoilVision and must be added in the WinLoG
software:

· Well Data
· Well graphical representation
· Core Log Data
· Remarks
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· Headers
· Footers
· Lines and Arrows
· Bitmaps (Soil texture patterns)
· Rectangles
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