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JT Maps  
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A step-by-step guide towards a Simplified GIS 



Overview 

Overview 
 
JT Maps User Manual is intended for those who want to know how JT Maps is used for GIS and 
Image Processing operations. It includes explanations and action procedures to work with JT 
Maps. 
 
The JT Maps User Manual provides stepwise detail of how to use JT Maps. For those interested 
in further reading on GIS and Image Processing, can refer the Additional Reading section. 
 
We recommend you to follow the JT Maps User Manual, as it describes the fundamentals of 
GIS with reference to the operations of JT Maps.  
 
The JT Maps User Manual consists of 12 Chapters. They are: 
 

• Chapter 1 Introduction to GIS (6) 
This chapter introduces you to the concepts of GIS, its functionalities and usage. 
 

• Chapter 2: JT Maps User Interface (8) 

This chapter introduces you to various user interfaces of JT Maps. 

 

• Chapter 3: Maps and Layers (6) 

This chapter provides an insight of what is a map layer and how to create a map layer. 

 

• Chapter 4: Map Viewing (16) 

This chapter covers the ways to view a map and how to use the options associated 

with  “Layer Control”. 

 

• Chapter 5: Selecting Objects (5) 

This chapter explains the various selection features with JT Maps and gives explanation 

on how one can perform these operations. 

 

• Chapter 6: Georeferencing (3) 

Instructions on how the georeferencing module can be used for assign the coordinates 

to the digital image. 

 

• Chapter 7: Editing Spatial Objects (7) 

This chapter explains the spatial data creation and editing of spatial objects using JT 

Maps.  

 

• Chapter 8: Image Processing (5) 

This chapter describes the features supported by the Image Processing module of JT 

Maps  
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• Chapter 9: Query and Data Manipulation (4) 

This chapter explains the operations related to non-spatial/attribute data, including 

query analysis on spatial and non-spatial data. 

 

• Chapter 10: Thematic Mapping (5) 

Functionality to create thematic maps through ranges, bar & pie charts have been 

explained here 

 

• Chapter 11: Buffer & Overlay (5) 

Creation of buffer and options under overlay analysis, supported by JT Maps has been 

explained here in this chapter. 

 

• Chapter 12: Network Analysis (4) 

 

• Chapter 13: Data Exchange 

 

• Chapter 14: Map Composition 

 

• Chapter 15: Projection Transformation 

 
 

What JT Maps has to offer 
 
JT Maps is comprehensive and easy to use GIS software. An integrated system incorporating 
image processing, digitization and analysis, will help you work both quickly and efficiently. Built 
in accordance with industry standards it provides exceptional, yet intuitive capabilities.  
 
Designed from ground up, JT Maps provides a level of functionality that has never been seen 
before in a GIS product. Key features include: 
 

• Image processing which supports a range of satellite data formats 

• Data Creation 

• Analysis: Spatial Analysis, Network Analysis  

• SQL support 

• External Database connectivity 

• Export-Import compatible with industry standard data formats. 

• Projection Transformation 
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JT Maps - Prerequisites 
 
Software 
The desktop PC where you will be installing JT Maps should have: 

• Windows 2000(with SP4)/Windows XP(with SP1) or above 
 
Hardware 
Minimum configuration required for running JT Maps is: 

• PIII 933MHz with 128MB Ram 
 
Recommended hardware 

• PIV with 256MB Ram 
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Introduction to GIS 

Introduction to GIS 
 
Definition  
 
Geographic Information System (GIS) is a computer based integrated technology where 
geographic data along with it’s attributes from various sources are fed into a system for 
storage, retrieval, manipulation and display. There are many definitions of GIS with each 
definition reflecting an individual perception of GIS and the type of problem statement he is 
addressing to. 
 
These activities reflect the larger context in which people carry out their work. 
 
Elements of GIS 
 
GIS can be broadly segregated into four different classes as shown below 
  

 
Hardware – PC, 

Mainframe, Laptops, 
Plotters, Printers 

Software –GIS Image 
Processing packages 

and Operating systems 

 
 
 
 
 
 
 

 
 
 
 
 

 
Data – Maps, 

Imageries, Attribute 
data 

 

an
t

 
 
 
 
 
 
 
 
 
 
Functions of GIS 

 
Data Input/Output 
 

GIS accepts data from different sources in different 
of GIS data are digital / analog maps, aerial photog
survey. Once the data is stored it can be manip
particular conclusion.  

 
Data Management 
 

Data management is a process in which the stored
and allows proper retrieval of data. 
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Analysis 
 

Analysis is an important function of GIS, which answers the queries, based the 
geographical feature, their location with respect to other features in association with 
attribute data. 

 
 
Need for GIS 
 

GIS integrates spatial and other kinds of information within a single system as it offers 
a consistent framework for analyzing geographical data by putting maps and other 
kinds of spatial information into digital form. GIS allows us to manipulate and display 
geographical data in new and exciting ways. The major advantages of GIS is that it 
allows you to identifies the spatial relationship with the map features .GIS gives a clear 
picture of what exists on earth in relation to non-spatial attribute. GIS stores the data, 
which can be utilized in different ways to serve the different purposes. 

 
Organizing data 
 

GIS software enables you to access, manage, analyze, and present the data with ease. 
It provides systematic organization of spatial database with corresponding map layers, 
to provide rapid access to data elements required for geographic analysis.  

 
Data integration 
   

GIS allows integration of different layers of data sets (both spatial & non-spatial) 
where each layer represents a particular type of geographic data. A typical example is 
shown in the figure below. 
 

 

Residential Area 

Road Network 

Sewerage Pipeline 

Open Space 

Vegetative Cover  

Fig: Different layers with specific data 
 
Such a combination of data allows the user to identify areas of allocation for various 
purpose, besides helping them to carry overlay analysis, generate buffer zones and 
proximity analysis. 

 
Making Data Presentable 
 

GIS enables presentation of spatial data in different ways. For e.g. thematic map 
displays only selected kinds of information relating to specific themes, such as soil, 
land-use, population density and so on.  
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Type of Data in GIS 
 
GIS mainly consists of two types of data spatial and attribute data. Spatial data consists of the 
geographical features and attribute data compromises of the numeric data. 
 
Spatial data  

Spatial data contains coordinates and identifies information for various map features. 
Spatial data means data pertaining to the location of geographical entities together 
with their spatial dimensions. Spatial data are classified as point, line, area or surface 
to describe particular features on maps like buildings, streets, or cities as points line or 
area.  

 
Points 
Points represents any features that can be described as an x, y 
location on the face of the earth, such as shopping centers, 
electricity poles, banks, and house. 

           Fig: Houses as points 
 
Lines 
 
A line represents anything having length, such as streets, 
highways, and rivers. 

       Fig: River or Road as line     
 
Areas or Polygons 
  
Areas or polygons are closed figures that represent the shape 
and location of homogeneous features such as states, countries, 
soil types or land use zones and cities. 
     

Fig: An Area as polygon  
 
 
Attribute Data  

The second type of data used in a GIS is attribute data. An attribute data represents a 
set of information, representative of spatial data. For instance, the spatial data might 
represent a country and contain information for city boundaries, streets, and attribute 
data giving information about the population, area in sq mts and so on. 
 

 
  

Spatial data 

Attribute data 
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Types of GIS 
 
GIS can be divided into two main types, each having different methods of displaying and using 
maps and the data associating data with them. 
 
Raster GIS  
 

A raster is a grid of cells overlaid on a map or picture. On a computer display this is a 
matrix/grid of pixels. Each cell location has a value.  Raster data comprises of satellite 
imagery, aerial photographs, scanned images etc. It is bulky and requires a large 
storage capacity. Data are stored in a grid or matrix like structure as a set of rows and 
column. Each cell within this grid contains a number representing a particular 
geographic feature, such as soil type, land use, etc.  
 
A raster is a grid of cells overlaid on a map or picture. On a computer display this is a 
matrix/grid of pixels. Each cell's location is identified and has a value.  

 
Vector GIS  
 

Vector data records spatial information as (x, y) coordinates in a rectangular (planar) 
coordinate system. Point features are recorded as single (x, y) locations. Line features, 
including the outlines of polygons, are recorded as an ordered series of (x, y) 
coordinates. 
 
Vector data is suitable for recording the location of discrete geographic features with 
precise locations like streets, boundaries, streams, telephone poles, etc. In the vector 
data model, features on the earth are represented as: 

• Points  
• Lines / route 
• Polygons / regions 

 
 
 
Co-ordinate System and Map Projection in GIS 
 
A coordinate system specifies the units used to locate features in two-dimensional space and 
the origin point of those units. The most common being latitude and longitude coordinate 
system often called the "geographic" coordinate system. An intersection of both these values 
(in degrees, minutes & seconds) gives the location of geographic feature on the earth surface. 
The Prime Meridian and the Equator are the reference planes used to define longitude and 
latitude respectively.  
 
Prime Meridian is referred to the zero degree line that runs from North Pole to South Pole. 
Every country has its own prime meridian and when the sun shines overhead these prime 
meridians the country observes twelve o’clock in the noon. 
 
Equator is the zero degree parallel that runs east to west dividing the earth into two similar 
hemispheres. It is also called zero degree latitude.  
 
Latitude of a point is the angle from the equatorial plane to the vertical direction of a line 
normal to the reference ellipsoid. These are the lines running parallel to equator. 
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Longitude of a point is the angle between a reference plane and a plane passing through the 
point, both planes being perpendicular to the equatorial plane.  
 
 
 
 
 

Longitude 

Equator 

Southe

 
 
 
Maps and Projection Technique 
 
Maps are representation of the surface o
relative position of the parts represented
earth features on a sheet of paper in cont
exact location on the earth. 
 
A map projection is a process to translate
map. In other words it’s an attempt to port
on maps. There are five methods of pr
Stereoscopic and Orthoscopic 
 
All Earth’s features are represented on the 
 

Point  – features like pos
Line  – representative o
Polygon - representative o

districts etc 
 
Note: depending on the scale of the
feature. E.g. A post office can be a p
reduced to a point in a scale of 1:250,
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 features on the globe onto the flat surface of your 
ray the surface of the earth or a portion of the earth 
ojections. They are Cylindrical, Conical, Mercator, 

map in terms of the following: - 

t office, telephone poles etc 
f features like roads, streets, rivers etc 
f features like an open area, forests, agricultural 

 map a polygon feature can become a point 
olygon if depicted on a scale of 1:500, but is 
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Benefits of GIS 
 
GIS as a technology can be applied to discipline like watershed management, network analysis 
of roads and waterways, public health care monitoring, vehicle routing and many more. 
Analysis of spatial and non-spatial data becomes easy and supports querying, overlay and 
buffer analysis. One can combine data in new ways to analyze patterns and trends not evident 
in separate databases. Such an analysis can lead to predictive tools for hazards management, 
better decision support system and optimizing sales and services for different sectors. Thus the 
use of GIS technologies helps empower people to make better decisions by increasing access 
to different dataset in its spatial context. 
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JT Maps User Interface 
 
 
 
 

 

Status Bar

Menu Bar   Tool Bar

Title Bar 

Active Window 

 
 
 

 

Interface Element Description 
Toolbar All major functionalities of JT Maps are logically grouped together 

into Button Pads 
Menu Bar All Functions provided by JT Maps are grouped together in 

appropriate menus 
Title Bar Operation title in progress 
Status Bar Miscellaneous information associated with the active and main 

window 
Active Window The window the user is currently working on.  
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JT Maps > File  
 
 
            
 

 

 

Creates a new layer 
Opens an existing layer 
Saves a layer 

Saves the current layer with a 
different name 
Opens the workspace 
Saves the map layer order, scale and 
other information as a project 
workspace 
Closes the active layer 
Closes all the opened Layer 

Opens print layout window 
Quits the application 

 
 
 
 
 
 
 
JT Maps > View 
 
 
 
       
 

 

 
Shows Layer Control Dialog 
Shows Legend Window 

Shows the Navigator Window 
Opens Info Dialog Box of the Active 
Layer 
Zooms in on an area of map window 

Zooms out of an Area of Map 
Window 
Fits all layers into the map window 
Zooms the selected area on a map 
Zooms in by a factor 

Zooms in by a percentage 

Zooms in or out to a given scale 
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JT Maps > View 
 
 
 
       
 

 

 
Shows Layer Control Dialog 
Shows Legend Window 

Shows the Navigator Window 
Opens Info Dialog Box of the Active 
Layer 
Zooms in on an Area of Map Window 

Zooms out of an Area of Map 
Window 
Fits the Map to Window 
Zooms the Selected Area on a Map 
Zooms in by a Chosen Factor 

Zooms in by a Chosen Percentage 

Zooms in or out to a Chosen Scale 
 

 
 
 
 
 
 
 
 
 
JT Maps > Raster  

 
 

 

 

 

Provides the option to alter the band 
combination of a multispectral image 
Displays the information for the image 

Creates transparency of an image 

Opens JT Spectral module for Image 
Processing 

 
 
 
        
  
 
 
 
 
 

JT Maps User Manual                                                                              Chapter 2 / Page 3 



JT Maps User Interface 

JT Maps > Digitization  
  
 
 
 
 

 

 
 
 

To set the pen/brush setting 
of a point, line or polygon 
feature 
Opens the dialog box where 
you can select the layer to be 
edited 
Stops editing 
Shows nodes of the object in 
an editable layer 
Option to add nodes to an 
object 
Snaps a node to the nearest 
existing node. 
Completes the object creation 
in the given layer 

 
 
 

    
JT Maps > Editing  

 
 
 
 

 
 
 

 

  

Rollback the last change on the editable 
layer 
Copies selected object to an editable layer 
Cuts the selected object 
Pastes the object to an editable layer 

Clears the selected object 
Combine selected Objects 
Splits second object with respect to the first 
selected object 
Creates a common area object between 
two selected objects  
Erases the common area from the second 
selected object with respect to the first 
selected object 
Conversion from Line to Polygon & vice 
versa 
Create a grid on a map 

 
JT Maps > Data  
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Opens non-spatial data window of one of 
the opened layer 
Open query dialog 

External database link 

Opens the interface for changing the non-
spatial table structure of one of the layer 
opened 

JT Maps > Select  
 
 

 

  

Selects all the objects of one of the opened 
layer 
Activates point select tool to select an 
object 
Rectangle select tool 

Radial select tool 
Polygon select tool 
Opens query dialog box  

  
JT Maps > Analysis 
 
 

 

 
Create a thematic map over the current 
layer 
Create a buffer from a selection 

Polygon overlay 

To perform network analysis on layer 

 
 
JT Maps > Tool  
 
 

 
 

 

Opens JT Maps File Translator 

Opens Projection Transformation Dialog 
Box 

Opens Unit Converter Dialog Box 

 
JT Maps > Help 
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Opens JT Maps User Manual 

Opens keyboard instruction for operation 

Connects to JT Maps web site 

Display information about JT Maps 

JT Maps Toolbars Reference 
 
 
 
 
 
 
 
 
 
 
 
 
  

Main Toolbar 
 

9    Creates a New Layer 
 

9    Opens an Existing Layer 
 

9    Closes a Layer  
 

9    Saves the Layer 
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Select Toolbar 
 

9    Select Tool 
 

9   Line Select 
 

9 Rectangle Select

Map Toolbar 
 

9   Zoom-In 
 

9   Zoom-Out  
 

9   Grabber to pan on Map Window 
 

9  Information Tool 
 

9   Fixed Zoom in  
 

9   Fixed Zoom out 
 

9   Full Extent button to view complete map  
 

  Distance measuring tool 
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Drawing Toolbar 
 
 

9   Editing button to start editing 
 

9  Create point data 
 

9  Create polylines 
 

9   Create polygon 
 

9   Node select 
 

9   Add node to a an object 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Miscellaneous Toolbar 
 

9   Opens SQL Query dialog box 
 

9   Theme Creation 
 

9   Opens “Create Link” dialog 
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2.3 JT Maps Shortcut-Keys Reference 
 

Keyboard Action 
   

Key 

File Options  

New File Ctrl + N 
Open File Ctrl + O 
Save File Ctrl + S 
Close File Shift + Ctrl + F4 
Open Workspace Ctrl + W 
Print Ctrl + N 
View Options  
View Layer Control Ctrl + L 
View Full Extent of Map F8 
Zoom to Selection F12 
Zoom to Scale  F9 
Mouse Wheel Options  
Change Wheel Behaviour F7 
Wheel Up F5 
Wheel Down F6 
Digitization & Editing  
Start Editing Ctrl + E 
Finish Object Ctrl + F 
Undo  Ctrl + Z 
Cut  Ctrl + X 
Copy  Ctrl + C 
Paste Ctrl + V 
Graticule  Ctrl + G 
Data Options  
Browse Data Ctrl + D 
Selection Options  
Select Layer Ctrl + A 
SQL Select Ctrl + Q 
Analysis Options  
Thematic Map  Ctrl + T 
Buffer Ctrl + B 
Overlay  Ctrl + Y 
External Applications  
Image Processing Ctrl + I 
File Translator  Ctrl + F1 
Projection Tranformation Ctrl + F2 
Unit Converter Ctrl + F3 
Help Option  
Contents F1 
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Maps and Layers 

Features present on the earth surface like rivers, forests, trees, houses etc are represented on 
a map through the combination of points, lines and polygons. GIS enables the user to store 
data in different set of layers for specific needs 

By using different colors, widths, patterns, and symbols, the features can be distinguished from 
each other and information can be conveyed about what each point, line, or area represents. 
Geographic features shown on a map are composed of two types of data: 
 
 

• Geographical features or Spatial 
data  

 

• Attributes of these geographical 
features or non-spatial data  

 
 
 
 
 
 
 
 
 
Opening and Closing Layers 
 
 
JT Maps stores all its data as .jtv files. Data in other formats needs to be converted into JT 
Maps file format before using with JT Maps software. JT Maps provides tools for importing data 
from different format as well as export data to other formats. See Data Exchange Chapter with 
JT Maps for more information. 
 
 
To Open a Map:  
 
Click on the File menu, and select the Open Layer command  
 
 

It can be also accessed be clicking the open button on the Main Toolbar   
 
 

In the open layer dialog, go to the directory where the map is stored, (In this case 
IND_state.jtv) select it and click the Open button. 
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The above shown step opens the map window with the layer selected. 
 
 
 
 
 
 
 
 
 

 

To minimize/maximize and close 
the Map Window 

 
 
To Close a Map: 

Close the map window by clicking the  button 
OR 
Click go to the File menu, and select Close Layer command 
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OR 
File > Close. Highlight the layer to be closed, in this case IND_state and click OK button. 

 
If you want to close multiple layers simultaneously use the menu option File > Close All Layer.  
 
 
Creating New Layers 
 
 
Click on the File menu, and select the New   or simply press Ctrl+N 

 

OR clicking the new button on the Main Toolbar   
 
 

The New File dialog box open, which has two tab windows.  
 
 Layer Tab: The Layer Tab is for specifying the type of the layer to be created. The choice is 
between Point, Line and Polygon. It also provides options to specify the drawing settings of the 
layer. 
 

 

1

3

2

 
 
 
 

1 Specify the type of layer. Only one type can be chosen at a time. 
2 Specify the location of the new file. 
3 Specify the setting for drawing the object. 
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Settings 
 
You can change the drawing settings for each layer type. This corresponds to the way the 
objects of the type will be drawn on the layer. 
 
Layer Tab: The Layer Tab is for specifying the type of layer. The choice is between Line, 
Polygon and Point. It also provides options to specify the settings for drawing that 
corresponding object. 
 
 
 
 
 

 

1

3

2

 
 
 
 
 
 

1 Specify the type of layer. Only one type can be chosen at a time. 
2 Specify the location of the new file. 
3 Specify the setting for drawing the object. 
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Table Tab: The table tab provides facility to create the fields for the non-spatial record-set to 
be associated with the new layer.  

 
 

1

2

4 65

3

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1 Displays the field names in the non-spatial record-set. Default field is Spatial_id. 
2 Enter the name of new field. 
3 Enter data type for new field 
4 Buttons to add or delete fields from the record set. 
5 Buttons to alter the position of fields.  
6 Enter size for new field. This is applicable only if the data type is character. 

 
 
 
Example. Suppose you want to add a new field by the name of Population, follow the following 
steps: 
 

Click on the Field text box. When you see a blinking cursor type in the name of the field  
 

 
 
 

Click the  button to add the field. Type of the field can be defined from the drop 
down menu bar. 

 
 
The final screen looks like: 
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Saving Changes on Layer 
 
Saving New or Modified Layer 
 
To save changes made on a layer, click on the File menu, and select Save Layer command or 
simply press Ctrl+S 
 
Note: This options is enabled only when you make changes on a open layer and incase 
multiple layers are open, this command saves changes to only the editable layer. 
 
Concept of Editable Layer 
 
JT Maps allows the user to open more than one layer at a time. But it allows editing or 
modification of only one layer at a time. To modify an existing layer, make the layer editable.  
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Map Viewing 
 
JT Maps provides easy access to various commands from toolbar. This chapter provides the 
instructions on viewing maps and moving around a map in JT Maps. 
 
 

 
 

 
The map shown in the figure is in Full Extent mode i.e. the size of the map is best fit in the 
given window. It provides visibility to all the objects of the layer.  
 
If required to enlarge a portion of the map for better viewing, JT Maps provides various options 
to zoom-in the map. 
 
Zoom In: Some of the ways to zoom-in on a map are:  

 
Zoom-in by a factor  
Zoom in percentage   
Elastic Zoom. Here you provide your own variable area for zooming. 
Fixed zoom in 
 
 

For fixed zoom-in click on View menu, and select the  icon.  
 

It can be also accessed be clicking the icons on the View Toolbar  
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To zoom-in by specifying your own area, select the  button on the View Toolbar. Keeping 
your finger pressed on the mouse button, “drag” a box over an area on the Map Window 
then release the mouse button to finish off. 
 
 

 
 
Zoom Out: It is opposite of zoom in. Ways to zoom-out on a map are to either zoom-out by a 
factor or provide your own variable area for zooming out. 
 

To fix zoom-out click on View menu, and select the  icon.  
 
It can be also accessed be clicking the Zoom-out button on the View Toolbar 
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To zoom-out by specifying your own area, select the  button on the View Toolbar. Keeping 
your finger pressed “drag” a box over an area on the Map Window. Release the mouse 
button to finish off the operation. 
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Zoom by Factor: This feature allows to zoom-in or zoom-out on the map by factor of your 
choice. Its useful when you know to what extent you want to view the map. 
 

To zoom in on the layer by a factor, select View->Zoom By Factor    or use the 
shortcut key Ctrl + R 

 
The screenshot below shows the extent of map when 
we zoom by a factor of 3 

  
 
 
 
 
 
 
 

 
 

 
 
 
 
Zoom by Percentage: This feature allows zooming on the map by a percentage. 
 

To zoom in on the layer by percentage value. Select View Menu > Zoom to Percentage. 
 

 

 

The screenshot below shows the extent of map when 
zoomed by 200% 
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Zoom to Select: This feature allows to zoom to the selected region on the map.  
 

Click the select   on the drawing toolbar   
 
Select an object 

 
To zoom in on the object, select View->Zoom to select 
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Zoom to Layer: Whenever more than one layer is open, select the layer on which to operate 
zoom function. The example below has two layers (World Map & India Map). To zoom to a 
specific layer select the layer as shown in “Select Layer” dialog box below. 
 
 

 
 
 

To zoom to a specific layer, select View->Zoom to Layer 
 
 
 
 
 
 
 
 
 
 
 
  
Select INDSTATE and click “Ok”. The INDSTATE map is now displayed on the map window as 
shown. 
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Full Extent: This feature scales the map to an extent where it is possible to view all objects in 
the layer. 
 

To zoom to a level where it is possible to view all objects in the Layer that is active, 
select View->Full Extent     
OR 

Click the full extent button  from the toolbar.   
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Pan: This feature refers to moving around the map. Its useful when you have zoomed-in on 
the map and want move around at the same extent. 
 

To move the viewing window up, down or sideways to display areas that lie outside the 

window, select the Grabber  from the view toolbar   
     OR        

 
Select View > Pan      

 
Hold the mouse button down and click and drag the map around. 
 

 
Navigator 
 
This feature includes a small navigator window, which constantly provides a visual 
representation of where you are on a map via a Black Cross Bar. It consists of a small 
window showing the map currently displayed on the map window in full extent. The size of the 
rectangle depends on the current zoom extent of the map and encloses whatever is displayed 
on the map. Thus in full extent, it encloses the whole map as shown below.   
Select View->Navigator  
 
 
 

 
 

Moving on the Map Using Navigator: Take the cursor over cross hair on the navigator 
window. Click and Drag the cross hair to any location on the map. The map also moves in the 
same direction. 
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Zoom on Map and Navigate: When zoom in operation is active, the navigator window 
display the map in full extent to locate the position. For navigation to an area of interest on the 
map shift the cross bar to that position.  
 
 

 
 
 
 
 
Layer Control And Layer Options 
 
A Map Window may have one or more layers open to represent the spatial data appropriately. 
With this concept of layering, the Layer Control provides a way for the user to specify how 
the various layers are ordered and various options of controlling the behavior of a layer.  
 
The Layer Control gets active only when there is at least one layer open. It gives the user a 
collection of layers currently open and all options available to control a layer’s behavior. 
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Select View->Layer Control or simply right click on the map View > Layer Control 
 
Layer Control Dialog Box opens as shown below 
 

 
 
In the above screenshot, you see a list of layers open at a time. There are 2 layers opened 
simultaneously. 
 
Layer Control Interface 
 

 
 
 
 53

1

2

4
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The various control options 
for a layer. 
 
 
 
 
 
 
 
 
Layer Control Option 

1 The various options available for a layer. 
2 Buttons to toggle the position of a layer.  
3 Deletes the highlighted Layer 
4 Refreshes all Layers. 
5 Provides options to Label, Control Theme & define 

Selection Setting options. 

 

 Visible: Indicates visibility of a layer. All layers are visible by 
default. 
 

 Editable: Indicates whether a layer is editable. Only one layer is 
editable at a time. 
 

 Selectable: Selects a Particular Layer 
 

 Show Label: Displays Label information on for the layer. By default 
labels are off for all layers. 
 

 Transparent: Indicates whether a layer is transparent. By default all 
layers are transparent. 
 

 Show Node: Makes visible the Nodes of the active layer 
 

 Remove Layer: This will remove the layer. 
 

 Indicates that the options is open (on) 
 

 Indicates that the options is locked (off) 
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Map Viewing 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Settings for Layer Options 
 
 
 
Selection Settings: To change the way objects are selected on the layer. 
 
Select the layer in the layer control and click the selection button. The following dialog opens. 
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Map Viewing 

 
 
 

2

3

1

 
 
 
 

 

1 This is for Brush Settings. Color drop down box allows you to select the colour. Patter 
indicates whether the object to be opaque, transparent, striped etc.  

2 Provides Pen Setting Options – Set the colour, Pattern allows to choose the type of line 
and Size indicates the thickness of line.                                 

3 This toggles the status of preview of the objects in then layer. If off, the preview cannot 
be seen and vice-versa. Default state is on. 

JT Maps User Manual                                                                        Chapter 4 / Page 13  



Map Viewing 

 
Label Settings: This specifies where the labels will be placed with respect to every object. 
Select the layer in the layer control and click the Label button. The following dialog opens. 
 
 

 

1

2

3

5

4

6

 
 

 

1 It’s a combo box to specify the field in the record-set to be used as a label for each 
object. The default field is Spatial_id 

2 The offset specifies how far the label will further move from the current position 
3 Will specify the orientation of the Line Label 
4 It toggles the display of labels. Default state is off. 
5 Specifies the orientation of label within an object. Default is Center 
6 To set Font Parameters – Type, Style and Size 

 
By Default the labels are displayed in the center and are based on the spatial_id. As 
shown below. 
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Map Viewing 

 
Changing the Settings:  
 

1. Click the drop down menu and select a different field name.  
 
 
 
 
 

2. Change the orientation for the label to top 
 
 
 
 
 
 

3. Change the offset to 2. This will further move the label above by 4. The new label 
display is as follows: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Points to be noted: 
 

• Always select the layer before changing the settings for any option. 
• Make sure the option is switched on to view the changes on the layer. 
• Whenever you toggle the status of an option in its dialog, notice the corresponding 

visibility icon turns to  as it opens that layer. 
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Map Viewing 

Theme Settings: This specifies which Themes are visible on the map. It is applicable only 
when you have applied 1 or more thematic analysis on a map. It then provides options of 
viewing all, one or none of the themes on the map. It also provides options to changes settings 
for each individual theme. 
 
Select the layer in the layer control and click the Themes button. The following dialog opens. 

2

3

4

1 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 1 To remove the theme 

2 To make the theme visible 

3 To change Theme Settings 

4 To toggle the position of selected theme 

 
 
 
 
 
 
Changing Settings for a Theme: You can change the settings for a particular theme. The 
dialog provides options to changes the color for the various theme fields. It also provides 
options to show the legend of the theme in the legend Window. 
 
Select the layer in the layer control and click the Settings button on the Theme Dialog. The 
following dialog opens. It allows the user to change minimum/maximum value of colour and 
select options like displaying the “Label” etc. 
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Selecting Objects 

Selecting Objects 
 
Selection is an important tool, which provides information to the software as to what the user 
wants to act upon. It is one of the fundamental tools that the user must know.  
 
Concept of Selectable Layer: A user can perform operations on an object in the layer only if 
it is highlighted. To do this, open the Layer Control, select the layer and toggle the selectable 
option for the layer. Only one layer can be selected at a given time. 
 
 

 
 
 
JT Maps provides various selection options. One can access the different select options from 
the Select Menu       
                               

 

  

Opens Dialog Box to Select a Layer to Open 
Activates Select Tool to Select a Feature 

Rectangle Select Tool 

Radial Select Tool 
Polygon Select Tool 
Opens Query Dialog Box  

 
 

These options are also available on the Select toolbar    
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Selecting Objects 

Single Select 
 

The Single Select icon highlights one object at a time. Click the  on the select toolbar, 
and click on the corresponding map to select the area of interest. The map below shows 
the selected state of Madhya Pradesh. 
 

 
 

9 To Deselect all click  from  toolbar.   
 
 
Rectangle Select 
 

This type draws a selection box and selects all within the box. Click  on the toolbar or 
Select->Rectangle. Click and Drag to select objects.  
 

  
 
 
Note. The selected portions are highlighted by blue colour 
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Selecting Objects 

 
 
Radial Select 
 

This type draws a circle and selects all within the box. Just click  on the toolbar or Select-
>Radial. Click and Drag to select objects. 
 

 
  
 
 
Polygon Select 
 

This type draws a region and selects all within the box. Just click  on the toolbar or Select 
> Polygon.  Click to mark the region and double-click to finish. 
 
 

 
 
 
Note. The selected portions are highlighted by Pink colour 
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Selecting Objects 

 
 
Selection of objects based on Centroid: In JT Maps, objects are selected only when their 
centroids lie within the selected region in the case of Rectangle, Polygon and Radial Select. 
Thus even if the rectangle includes a part of an object but as its centroid is outside the box, it 
will not be selected. For e.g. observe the following case of a Rectangle Select. 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

Notice these regions though 
within the rectangle are not 
selected as shown in the map.
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Selecting Objects 

 
 
SQL Select 
 
This type selects objects based on a SQL query on the non-spatial attributes of the layer. 
Select->SQL Select  
 

 
 
Once the query criteria is fulfilled click “Execute” button. The State with an 
80,000 Sq.kms gets highlighted as depicted on the map below. 
 

JT Maps User Manual          
        
Selects the Layer for Query 

Select the field to perform the query on 

Select the arithmetic operator. 

Select the mathematical operation 

Selects various Query functions 
area greater than 
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Geo Referencing 

Geo Referencing. 
 
To register or to georeference an image, open the image, which is to be geo- referenced.  
 
Spectral > Raster > Georeferencing 
 

 
Fig.1  
 
Click on raster in the tool bar and select the option of Geo-referencing (Fig.1).  
 
A dialogue window will appear which has the details about the projection types, datum types, 
units of projection etc. (Fig.2) 
 
        

    
Fig.2 
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Geo Referencing 

 
The user can select the type of projection to be used from the list of projections in the drop-
down menu (Fig.3)  
 

 
Fig.3       
 
 
User can also select the Datum you want to apply in the Image that is to be Geo-referenced 
from the list of datums supported by the software (Fig.4) 

 
Fig. 4 
    
The desired unit in which the user wants the output image can be selected from the various 
options available in the drop-down menu. (Fig.5). 
 

 
Fig.5  
 
Once all the relevant information has been filled in the dialogue box, the user can proceed on 
to registering the image by marking the co-ordinates or points on the image. To register a 
point on the image, the user has to click on the tab-New on the dialogue window, the shape of 
the cursor will change and thus you can mark the relevant point on the image by taking the 
cursor to that point and clicking there. (Fig.6). another dialogue window will appear in which 
the user has to feed the coordinate values. after feeding the coordinate values click O.K. and 
the point will be registered and can be seen in the table. 
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Geo Referencing 

  
Fig.6 
 
 
Similarly the user can select the next point, which is to be registered and feed its relevant 
values in the table. (Fig.7). Once all the values have been fed and all the points have been 
registered, the user can make corrections, if any, in the location of the registered points by 
selecting that point in the table and clicking on –FOCUS. 
 
The selected point will automatically be zoomed into the center of the screen. (Fig.8) 
 
 

  
Fig.7      Fig.8 
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Geo Referencing 

 
When the selected point is zoomed into the center of the screen, the user can make the 
correction in the location of the point by clicking on GO TO and specifying the correct location 
where the user wants to shift that point. The point will automatically shift from its current 
position to the new specified position. (Fig.9). 
 

 
 
 
Once all the corrections have been made the user can proceed on to next step by clicking O.K. 
on the table menu bar(Fig.10). When the user clicks on the O.K. button, the registered image 
will be saved automatically in the same folder and with the same name in .JTV file format. Now 
the user can proceed on to the process of data creation using the registered image in JT Maps. 
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Editing Spatial Objects 

Editing Spatial Objects 
 
 
When working with spatial objects, we need to edit the existing object or create new objects in 
a given layer.  
 
JT Maps provides techniques for data creation and editing, which involves conversion of data in 
analog form, such as maps and satellite images, into vector form and doing data manipulation.  
 
Concept of Editable Layer: Only one layer can be edited at a time. To make a layer editable, 
turn on the editable option for the layer on the layer control dialog box. To do this 
 

Right Click > View > Layer Control. Open the Layer Control, select the layer and toggle 
the selectable option for the layer. Only one layer can be made editable at a given 
time. 

 
 

 
 
 
 

OR go to Digitization Menu > Start Editing option and select the layer. 
 

This option is also available by clicking the  in the drawing toolbar 

 
 Click the select button and choose the feature you want to edit. 
 
 
Stop Editing 
 
To stop editing, choose Digitization > Stop Editing option. Dialog box will prompt whether to 
save the changes made to the layer.  
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Editing Spatial Objects 

Editing Objects on Layer 
 
Showing Nodes on an Object 

To show nodes on an object, Select the object and click  button in the drawing toolbar.  
 

 

Object showing 
nodes. 

 
 
 
 
 
 
 
 
 
 
Snap Tool 
The Snap tool indicates the presence of a node on an object. It does this by changing the 
mouse cursor to a crosshair whenever the mouse cursor hovers over a node. This helps in 
pinpointing the location of a node and thus you can select it or drag as per our requirement. 

The cross-hair cursor
showing presence of a
node 

 
 
 
 
 
 
 
 
 
 
 
 
You can activate the snap tool by checking the Snap option in the Digitization menu or by 
simply pressing the Shortcut key  
 
Moving an Object 
 
To move an object, select the object using select tool. Keeping the mouse button pressed drag 
the object to the new location and release the button. 
 
 
 
 
 
 
 
 
 
 
 
 
 

JT Maps User Manual                                                                              Chapter 7 / Page 2 



Editing Spatial Objects 

Resizing an Object 
 
Select the object to be resized, note the four edit handles, click and drag on any of the four-
edit handles to increase/decrease the size of the object. 
 

 

Click on any handle
and drag inside or
outside to increase
or decrease size
respectively. 

Edit Handles 

 
Reshaping an object 
 

To reshape an object, select the object. Then click the Show Nodes  icon from the Drawing 
Toolbar to allow display of nodes. Click and drag on the nodes to reshape the object 
 
 
 
 
 
 
 
 
 
 
 
Note: Show Nodes will display nodes only if a single object is selected. However if more than 

one object is selected, the nodes will disappear automatically as shown below. 
 

Nodes disappear on multiple select
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Editing Spatial Objects 

Adding a Node to an Object 
 

Select the object. Click the Add node  icon from the drawing tool bar  
And click on the location for the new node. 
 
 
 
 
 
 
 
 
 
 
 

 
 

When you click the add node button, the cursor changes to . Click on the new location to 
add the new node.  

New Node Added between
the two existing nodes. 

Snap Tool Showing
location of a node. This
gives an idea of where
you could want your
new node to be. 

 
 
 
 
 
 
 
 
 
 
 
Cut, Copy And Paste Operations 
 
Cut, Copy and Paste commands are available with the Editing Menu. It is important to make 
the layer editable prior to execution of these functions. 
 
These options are also available on Right Click pop-up menu. Select the object and perform the 
operation as shown in the figure below. 
 
To Undo or Redo the changes made on a layer, use the Undo and Redo options from Editing 
Menu 
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Editing Spatial Objects 

 
 
 
Combining two polygons 
 
This feature provides facility to combine two overlapping polygons into a single polygon. Select 
the polygons to be combines (using shift and click). Choose Editing->Combine.  
 
In the example below, there are two polygons A and B. The intersection is marked as C. When 
combining the polygons the result is a single polygon with no intersection region. 
 

 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 

 
 

A 

C 

B
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Editing Spatial Objects 

Polygon Intersection 
 
 
This feature provides facility to extract the intersection region between any two polygons 
without modifying the two polygons. Select the polygons to be combined Choose Editing > 
Intersection 
 
 
In the example below the intersection is marked as C. When the operation is executed, the 
polygon C can be obtained as a separate object. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Splitting Polygons 
 
 
This feature provides the facility to split overlapping polygons i.e. it separates the intersection 
region between two polygons but cut this region from the polygon at the bottom. Select the 
polygons to be combined (using shift and click). Choose Editing->Split 
 
In the example below, we have 2 polygons A and B (as seen, B is on top and A at the bottom). 
The intersection is marked as C. When we run the operation, we get the polygon C as separate 
but observe that this region is removed from polygon A, which was the bottom one. 

B 

A 

C 

A 

C

A 

B 

A 

C 

C 

B 

A 

B 
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Editing Spatial Objects 

Difference in Polygons 
 
This feature is slightly different from splitting the polygons. In Place of creating a new polygon 
from the common region, it removes this region from the bottom polygon and separates the 
one on the top. Select the polygons to be combined (using shift and click). Choose Editing-
>Difference 
 
In the example below, we have 2 polygons A and B (as seen, B is on top and A at the bottom). 
The intersection is marked as C. When we run the operation, we get the polygon B as separate 
but observe, that region C is removed from polygon A, which was the bottom one as is now 
only a part of B 
 
 

C

A 

B

A

B 

 
 
 
 
 
 
 
 
 
 
 
Transparency 
 
Concept of Transparent Layer: To do this, Right Click > Layer Control, select the layer and 
enable the transparent option for the layer by clicking. . More than one layer can be made 
Transparent at a given time. The “tick mark” indicates that the layer transparency is enabled. 
 

 
 
 

The Streets layer becomes transparent
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Image Processing 

Image Processing 
 
Image Processing is used for data processing to analyze, enhance, interpret or display satellite 
images or aerial photographs. It has the feature of processing high-resolution imagery into 
quality raster data products. The enhancement techniques are employed to increase the 
contrast/brightness of an image. Therefore, the distinction of features in the scene can easily 
be performed by visualization. This augments the efficiency of image for interpretation.  
 
JT Maps permit Image Processing through its in-built module called “JT Spectral”. Run the JT 
Maps software and once JT Maps window opens Go To Raster > Image Processing OR press 

Ctrl + I. JT Spectral window opens. File Menu > Open or Click  icon from tool bar and 
select the image to open. JT Spectral supports various formats like *.tiff, *.img, *.bmp, *.Jpeg, 
IRS-1C/1D, Spot and LISS image. 
 
 
Image Enhancement  
 
JT Spectral allows user to apply Layer Combination (Red, Green , Blue), change brightness and 
contrast property of the image for better clarity. Example below depicts the same.  
 

To applying layer combination, go to View menu > Layer Combination or click  icon 
from toolbar. The following dialog box appears. 
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Image Processing 

 
 

 
 

 
 

Notice the difference in image quality with different Layer Combination. Above left
image has Red color as Layer 1, Green as Layer 3, and Blue as Layer 2. The one on
the right has Red, Green and Blue as Layer 1,2,and 3 respectively. 

 
 

Effecting Brightness and Contrast property 
 
Raster Menu > Brightness/Contrast. Apply settings for best image. The image on the right has 
the best brightness and contrast combination. 
 
 

 
 
  

The figure above has the best combination of
brightness and contrast. Relish the quality of the
image. 

 
 
 
 
 
 
 
 

JT
The dialog box shows two screens. The
one on the left depicts the original and the
one on the right previews the change in
both these properties to the user before he
can apply the new settings. Notice the blur
ness. 
 Maps User Manual                                                                               Chapter 8 / Page 2 



Image Processing 

 
 
JT Spectral extends the feature of applying various Filters to the image. To apply filters go to 
Raster Menu > Filters. You get various filter choices like Linear, Statistical and Custom. 
Images can also be sharpened to remove blur ness as shown in the image below. 
 
 

 
Sharpened Image. Notice the clarity. 
Ripple marks on water clearly visib e. l

     Blurred Image. 
 
 
The software also facilitates generation of negative image of any given imagery as and when 
the user needs it. 
 
Go to Raster Menu > Negative 
 

 

Original Image      Generated Negative 
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Image Processing 

Information Display of Raster Data 
 
A raster data (satellite imagery, aerial photographs, etc) contains various types of information. 
To retrieve information of the opened image Click on Information Menu and select between 
any three option. The following example shows the same.  
 

For image Information. Information Menu > Image Info or click    icon on the 
toolbar 

 

 
 

For Layer Information. go to  Information menu > Layer Info or click  icon on 
the toolbar 

 

 

The Histogram
button 
generates 
histogram of
the said image. 
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Image Processing 

To generate histogram click on the “Histogram” button as shown above. The resulting 
histogram is shown below. 
 

 
 

For Pixel Information, go to  Information menu > Pixel Info or click  icon from the 
toolbar 
 

The cursor changes to . Choose a point on the image and click. Pixel information of the 
selected pixel is displayed in tabular form as shown below. 

. 
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Query and Data Manipulation 

Query and Data Manipulation 
 
JT Maps provides functionalities for the user to analyze, view, manipulate attribute data and 
maintain a database. The software provides query tool for viewing and manipulating data on a 
dataset by applying conditions as provided by Structured Query Language.  
 
Browsing the non-spatial data 
 

To browse the data, choose Data->Browse or press Ctrl+D. Select the layer for which data 
is to be displayed and Press OK 

 

 

Note. A browser window appears detailing non-spatial data for all the state. The
selected state is highlighted on the India map (blue color) with corresponding non-
spatial data shown in tabular form and highlighted with Yellow color. 
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Query and Data Manipulation 

SQL Query 
 
JT Maps permits the user to make Structured Query on any layer of data and display the same 
in both spatial and non spatial context. Follow the simple step mentioned below to attain that. 
It provides stepwise guideline to the user making query analysis. Go to Data Menu > SQL 
Query. The “Select Query” dialog box pops up. 
 
 

 

1

2

3

4

7

5 6

 
 

1 Select the layer to perform the select query 
on. 

2 Select the field to perform the query on. 
3 Select the arithmetic operator. 
4 Specify the condition 
5 Details the query result 
6 Display the result on the map. 
7 Displays the computed result 
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Query and Data Manipulation 

Result of the above query where the states have an area greater than 100,000 sq. mts is 
displayed in a tabular form and highlighted (blue color) on the map. 
 

 
 

 
Advanced Query using SQL query like SQL ORDER BY, SQL BETWEEN…AND, SQL DROP etc. 
can be made to furthermore filter the desired result within huge database. Select Menu > SQL 

Query or simply click  icon from the toolbar. The dialog box contains advanced options with 
drop down menu as shown below. 
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Query and Data Manipulation 

Altering a Table 
 
JT Maps also provides the facility of altering the structure of the non-spatial records. Thus, if 
required, you can delete fields from the record set that are no longer needed. 
 
Choose Data->Alter Tabel  

 

 

1. Fields in the table structure. 

2. Type of field. Double click to

go through the       drop

down menu to select the

type. 

3. Delete a particular field. 

4. Add a new field 

2

3

4

1

 
Changing a field 
 
To change a field, Double-Click on the field . The field turns to text mode. When an insertion 
cursor appears type in the new field. Look the example below. The new field added as “abcd”. 
To add a field click the “Add” button. To delete a field, select the field to be deleted and then 
click the “Delete” button 
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Thematic Maps 

Thematic Maps 
 
Thematic maps are those maps that show the distribution of a single attribute (characteristic) 
or the relationship between several attributes. Thematic maps can cover a variety of 
characteristics from soil types to climate to population density. GIS helps display the correct 
distribution or the relationship between the various attributes either on map, in tabular form or 
both. Normally the creation of a thematic map involves a process of compilation, which 
includes the collection, and manipulation of data from a variety of sources to produce a new 
product. 

Scaling of thematic maps depends on the data types and accuracy. With better availability of 
data thematic maps can be made with a larger scale to show more accurate spatial 
information. What makes a good thematic map is its accomplishment mainly with the marks 
and symbols that one uses to represent the data.  

Creating Thematic Maps  

To initiate theme, choose Analysis > Thematic Map or select  icon from toolbar. The 
following dialog box opens 
 

      

  

2

3

1

 
1 Select the layer on which to create the thematic map. 
2 Select the type of theme to be generated. 
3 Select the theme options. These are specific for the various theme types. 
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Thematic Maps 

 
 
 
 
 
Themes provided by JT Maps 
 
 

Ranges Displays your data according to ranges you set. The ranges theme divides 
the data on the basis of number of ranges defined. The user can specify 
the colors to be used with each particular range unit.  
Equal Ranges: The entire range is divided into equal spaced sections 
and the theme is created on the basis of it.  
Equal Count: the total numbers of units, which are being considered for 
creating the theme, are divided into equal sized groups and the theme is 
generated on the basis of that.  
Quantile: The entire data set is divided into quantile groups and the 
ranging is done on the basis of it. 
 

Bar Charts Bar Chart theme generator creates bars corresponding to each specified 
field of theme creation. This type of theme can be used to analyze 
multiple variables per record on the map. An instant comparison can be 
made between the sizes of the bars in each chart to obtain information 
about records in the data set. 
 

Pie Charts On specifying the chart theme type to pie chart the theme generator 
creates a pie with each specified field forming a part of the pie. This kind 
of theme is generally used when comparing values and observing the 
amount of share each field has in the entire group. 
 

Graduated Graduated Theme generates a symbol for each record in your table, the 
size of which is directly proportional to your data values. Thus, size of the 
symbol is a clear indication of the data value in the record. 
 

Dot 
Density 

Dot Density gives a raw account of the field values. In this theme every 
dot represents a value and the total number of dots are equal to the total 
data value of the field. 
 

Unique 
Value 

The unique value theme is used to create themes where each unique 
value is given to color. This kind of thematic maps are used when 
mapping a large dataset and trying to find out similar values. For e.g. you 
can generate this theme if you want to find out which Districts in India 
have a Hospital. 
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Thematic Maps 

 
Display Maps by Ranges 
 
Lets generate a Thematic map on Indian State on Range Value. Select the Range option 
from the Create Thematic Map dialog box. Set the Range parameters and follow the 
instructions. The result below is the generated Thematic Map. 
 
Displays your data according to ranges you set. The ranges theme divides the data on the 
basis of number of ranges defined. The user can specify the colors to be used with each 
particular range unit. To view Legend “Right Click” > View > Legend 
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Thematic Maps 

 
Bar Chart 
 
Similarly to create Bar Chart go to Analysis Menu > Thematic Map. Choose “Bar” option. 
Highlight the field on which bar chart need to be created on a particular layer.  
 
 
 

 

3

2

1

1. Select the field
parameters, either
AREA, POINTS etc in
this case. 
2. Option to select
color scheme as per
user requirement.  
3. Preview of the bar 

 
 
 
The software will itself guide you to “Bar Chart Settings” options. Set the parameters and click 
“OK” button. The example below shows bar chart on area of different Indian States. 
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Thematic Maps 

 
 
Figure below shows Bar Chart for Area for different States of India. To view Legend “Right 
Click” > View > Legend 
 
 
 

 
 
 
 
Thus we see that generating Thematic Maps with different set of themes becomes easy using 
JT Maps. The above-mentioned steps can be followed to generate Thematic Maps using other 
theme options provided by the software. 
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Buffer and Overlay  

Buffer and Overlay 
 
Functions of GIS not only helps generating Thematic Maps (ranged colour maps or symbol 
maps to denote intensity of a mapped variable) or overlaying of different pieces of information, 
but also helps creating buffer areas around selected features. In this chapter we take a look at 
how JT Maps helps generate buffer zones and assist in overlay analysis. 
 
Among the simpler GIS applications, buffering is a process of identifying objects within a 
specified distance of a reference object. The reference object may be a point location, a line, or 
a polygon. It creates a new polygon around the reference object. The user specifies a distance 
that the buffer is to extend from the feature, and the GIS create a polygon that encompasses 
all the points within the specified distance of the feature.  
 
Creating Buffer Zones 
 
Buffer analysis is used for identifying areas surrounding geographic features. The process 
involves generating a buffer (A zone of a specified distance around coverage features. Both 
constant and variable width buffers can be generated for a set of coverage features based on 
each features attribute values) around existing geographic features and then identifying or 
selecting features based on whether they fall inside or outside the boundary of the buffer. 
 
To create buffer zones follow these simple steps 
 

1. Open the Layer on which to create buffer. 

2. Select the object or objects around which you want to create the buffer. 

3. Go to Analysis Menu > Buffer or press Ctrl+B. the following dialog box opens. 

 

 

 

1

2

3

4

5

6

7
Dialog Box to set Buffer Parameters. 
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Buffer and Overlay  

 
 
 
 
 
 
 
 
 
 
 
 
 
 

1. Select the measuring unit 

2. Specify the value of buffer zone 

3. Select Attribute value 

4. Select Segment parameter 

5. Toggle between radio buttons to define the       type of buffer zones. 

6. Browse, define the path and save the new layer as a separate file. 

7. Click the “Generate” button to create buffer zone. 

 
Figure below shows buffer zone (indicated in red color) around the state of Madhya Pradesh 
with above depicted buffer parameter. 
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Buffer and Overlay  

Generating Multiple Buffers 
 
 
Select more than one object on which buffer zones to be created. Rest of the steps is same as 
defined above. Examples below suggest the same. 
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Overlay Analysis 
 

The process of overlaying usually involves taking two layers and combining them by 
some mathematical operation. Layers can be added, subtracted, multiplied, or divided 
according to the values of certain attributes. Buffering is especially powerful when 
combined with overlaying to extract information.  

 
To perform Overlay analysis following steps are required 
 

1. Open the Layers on which to perform Overlay. 

2. Go to Analysis Menu > Overlay or press Ctrl+Y. the following dialog box 

opens. 

 
 
Overlay analysis using dissolve themes 

 
                          

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

1 2 3 4 5 6

1. Choose an Overlay Operation among the Radio Buttons

2. Select the Layer to Perform Overlay 

3. Select field  

4. Select Output File Path 

5. Option to Add the Generated Layer to the Map 

6. Click the “Generate” Button to Perform Overlay. 
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To perform the Overlay operations select the dissolve themes from the overlay 
operation. Select layer to dissolve from the various layers opened in the map window. 
Select field to dissolve from the different fields in the attached database. Specify the 
output file name and the path in the output box. Click on generate button to get the 
desired result as shown below.  
 
Similar operations are performed for Clip themes and Append themes options.  
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Network Analysis 
 
There are a variety of services available in the real world which depend on the establishment of 
relationships between one point and another and finding optimal solutions for traversal 
between these objects, it is clear that these utility services use a set of connected linear 
features called 'network'. Hence it can be said that a network forms one of the primary 
infrastructures of the modern world. The form and shape of the Network influences the 
capacity and the efficiency of the system and how well it will respond to real-life situations. JT 
Maps provides several advanced analysis tools for planning and operations and one such tool is 
Network Analysis which mainly plans, manages and optimizes the utility of man-made 
resources such as transportation networks, allocation and distribution of resources like natural 
gas and water, sewer disposal, location of servicing plants etc. 
 
Using JT Maps, analysis can be performed on the network, once a network has been created 
and its attributes defined. The analysis of the network will depend upon the characteristics of 
the utility under study and its requirements. The software  has a variety of configurable options 
within the network analysis module, which makes it a comprehensive and highly flexible 
system. The user has the option of attaching weights and impedances to the elements of the 
network, it can specify the direction of flow within the network as well as indicate those 
elements which are temporarily out of service. These options are very helpful in depicting and 
emulating real-world situations, like traffic blockades on road networks etc. 
 
Using this tool the user can perform analysis of various forms like finding shortest path, 
obtaining directions and estimating optimal route. 
 
To start using Network Analysis the user would require a clean polyline dataset, the data has to 
be clean to ensure correct result are reflected upon analysis. After loading the layers the 
following set of steps must be performed. 
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1. Select Analysis from Menu bar >Network  > Start or press Ctrl+ K. Dialog box opens to 

set Network Parameters. 
  

 
 

2. The user is required to fill in the required set of parameters for building a topology, 
which will further be used for conducting the network analysis. The parameters 
included are: 

a. Layer on which the network analysis and topology creation will take place. 
b. The weight field will define the weight of each object in the network 
c. The impedance field defines the impedance associated with traveling on that 

object, this impedance is defined as a relationship with the weight of the 
object. 

d. Relationship field defines the relationship between the weight of the object and 
its corresponding Impedance. 

For e.g. if we consider a standard road network with three categories of 
road, A, B and C. We give the values of 1, 2 and 3 to A, B and C 
respectively. We have a field defined that contains the length of the line 
segment of the network. Now when defining the network parameters we 
will assign the weight as the length of the road, the impedance as the 
category of the road namely, 1, 2 or 3 and the relationship may be 
multiplication (*). This way a road of category A of length 10 km’s will 
be preferred over a road of category B of 6 kilometers. 
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e. The one-way will define any object, which can only be traversed in one 
direction; this field will be used in evaluating possible roads that may not be 
used when traveling from one direction. 

f. The Network Direction parameters define the fields which will be used to 
create the driving direction instruction set. The fields required are: 

i. Name of the object 
ii. Major landmarks, used for defining change in direction 
iii. The unit of the weight of the object. 

g. The check box with the name Rebuild should be checked if the user is aware 
that the same parameters have been used for previously defining the topology 
but the user would like to force the rebuilding of the network. 

 
3. The user will then click the “Build Network” button to create the topology and prepare 

the system for the network analysis. Once the network is created the user has the 
option of clicking the destination points on the map using the mouse or using a pre-
existing point dataset for defining the destinations. 

 
4. The nodes clicked can be manipulated by the following set of buttons on the node add 

dialog window 
 

 

Add a Node 

Move a particular Node one step above the current location.

Move a particular Node one step above the current location.

Select and delete an existing Node 
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5. Once the nodes have been selected, using either of the two sets of options given, the 

user will click the “Calculate” button on the dialog box to initiate the network analysis. 
The shortest route from Node – 1 to Node – 4 is indicated on the map as a blue line. 
The dialog box details information on distance between each node as shown below 
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To know the direction of travel from the first point to the last point click the “Direction” button 
on the dialog box. A new window opens giving the direction to be taken to travel from starting 
point to the destination point. The figure below confirms the result. 
 

 
 
In this manner the system can perform a variety of network related activities. The set of 
configurable options allow the system to be highly flexible and at the same applicable in a large 
set of areas of operation. 
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Map Composition 
 
For printing maps the Map Composition module supports functionalities to create print layouts. 
To access the print layout window select the menu option: 
 
File > Map Composition or  
 
press Ctrl+P.  
 
 
Composition Window 
 
Composition Widow provides some options for the user to prepare the layout for printing the 
map. It enables the user to make the map explanatory by adding relevant information about 
the map like its orientation & legend.  
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Various options accessible with Map Composition window are available through the toolbar 
shown below: 
 

 
 
 

 Page Set Up Tool: Helps adjust the size, orientation and margin of the paper 

 Print Tool: Takes you to standard print option 

 Select an Object Tool: Enable to select any object  

 Deselect Tool: Undo the previous operation 

 Move: Click on the icon and select an object. It makes the selected object movable. 

 Add/Modify Tool: Click on the icon and select the the text to modify or add a new 
one.  

 Modify Text Attribute: Helps to change Font, Text colour and its orientation. 

 Insert/Modify Tool: It enables insertion of new Picture or modify an existing one. 

 Map Margin Tool: Toggle it to display or hide the Map margin 

 Legend Display Tool: Toggel it to make the legend of the map visible or hidden. 

 Zoom in: Click on the icon to zoom the map window 

 Zoom out: Click on the icon to zoon out of the map window 
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File Translator 
 
Geographic Information System incorporates data from various sources; hence it becomes 
imperative that data files with different format need to be imported or exported for 
compatibility. JT Maps supports data import of different format other than .jtv thus rendering it 
compatible with JT Maps software. Once imported the data becomes editable for user to effect 
changes or manipulate as per the requirement. We take a look at these options to understand 
the way its been done. 
 
Data Import and Export 
 
Import allows user to bring in data of different formats to a single format. JT Maps supports 
importing of data formats (other than .jtv files) into .jtv formats. To import data, Tools Menu > 
File Translator. The following dialog box appears. 
 
 
 
 

 

1

2

3

1. List the details of files to be 

imported. 

2. Radio buttons to specify a 

choice. In this case “Import” 

3. Specify the output source. 

Where to store the imported 

files. 

4. List the status 

(done/undone) of 

import/Export process 
4
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To import file(s) go to Tools Menu > File Translator. Choose the file format to be imported. 
Ensure to “tick” on import radio button. Now Click the Add Files button. It opens the browser 
box. Select the files to be imported. Tick on the “Specify” option to browse the location for 
storage of imported file(s). Click the “Convert” button to initiate the import process. Status 
area shows the successful importing of the selected file. 
 

 
 

Data Export 
 
Following the above described steps user can “Export” the file(s) to other formats. The export 
radio button need to be activated and destination directory to be defined. Follow the steps as 
mentioned. The status bar will indicate successful export of file(s). 
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Projection Transformation 
 
JT Maps allows user the facility for either file transformation or Co-ordinate transformation. To 
achieve the purpose go to Tools Menu bar > Projection Transformation or press Ctrl + F2. The 
Tab Strip Window opens.  Set the parameters and press the “Convert” button. 
 

 
Transformation Window 

 

 
 
   Transformation Parameter Window 
 
Transformation parameter window allows user to choose “Projection Parameters” 
(Lat/Long, Mercator etc.) and select the “Datum” for layers. 
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Unit Converter 
 
Another tool provided by JT Maps is the “Unit Converter” tool. It helps the user to convert an 
input data with a specified unit to equal values in other unit. To get a feel of the same click 
Tools from Menu bar. Go to Unit Converter OR press Ctrl+F3. The following Tab Strip window 
opens. 
 

 
 

The above example reflects conversion of 1 Kilogram/Square to Megapascal. 
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XIV Glossary  
 
 

Keyword Description 
  
Attribute 
 
 

A characteristic of a geographic feature described by numbers, 
characters, images and CAD drawings, typically stored in tabular 
format and linked to the feature by a user-assigned identifier (e.g., 
the attributes of a well might include depth and gallons per 
minute). 

  
Azimuth The horizontal direction of a vector, measured clockwise in degrees 

of rotation from the positive Y-axis, for example, degrees on a 
compass. 

  
Axis A reference line in a coordinate system. 
  
Area A closed figure (polygon) bounded by one or more lines enclosing a 

homogenous area and usually represented only in two dimensions. 
Examples are provinces, lakes, census tracts and forest stands. 

  
Byte A memory and data storage unit composed of contiguous bits, 

usually eight. For example, file sizes are measured in bytes or 
megabytes (one million bytes). Bytes contain values of 0 to 255 
and most often represent integer numbers or ASCII characters 
(e.g., a byte with an ASCII value of 77 represents a capital M). A 
collection of bytes (often 4 or 8 bytes) represents real numbers and 
integers larger than 255. 

  
Coordinate System A reference system used to measure horizontal and vertical 

distances on a plan metric map. A coordinate system is usually 
defined by a map projection, a spheroid of reference, a datum, one 
or more standard parallels, a central meridian, and possible shifts in 
the x- and y- directions to locate x,y positions of point, line, and 
area features. 

  
Coordinate Data Data digitized by recording Cartesian coordinates, which define 

boundary locations. Also called polygon, line or point based data. 
  
Database A logical collection of interrelated information, managed and stored 

as a unit, usually on some form of mass-storage system such as 
magnetic tape or disk. A GIS database includes data about the 
spatial location and shape of geographic features recorded as 
points, lines, areas, pixels, grid cells, or tins, as well as their 
attributes. 

 
 
Data Set A named collection of logically related data items arranged in a 

prescribed manner. 
  
Datum A set of parameters and control points used to accurately define 

the three-dimensional shape of the Earth (e.g., as a spheroid). The 
datum is the basis for a planar coordinate system. For example, the 
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North American Datum for 1983 (NAD83) is the datum for map 
projections and coordinates within the United States and 
throughout North America. 

  
Digitize 1. To encode geographic features in digital form as x,y coordinates. 

2. The process of using a digitizer to encode the locations of 
geographic features by converting their map positions to a series of 
x, y coordinates stored in computer files. Pushing a digitizer button 
records an x, y coordinate. A digitized line is created by recording a 
series of x, y coordinates. 

  
Double-Precision Refers to a level of coordinate accuracy based on the possible 

number of significant digits that can be stored for each coordinate. 
Whereas single-precision coverages can store up to 7 significant 
digits for each coordinate and thus retain a precision of 1 metre in 
an extent of 1,000,000 metres, double precision coverages can 
store up to 15 significant digits per coordinate (typically 13-14 
significant digits) and therefore retain the accuracy of much less 
than 1 metre at a global extent. 

  
Easting The x-coordinates in a plane coordinate system; see northings. 
  
Feature An object or aspect of the earth's surface, such as a road, 

vegetation, or town site. On a map, a "map feature". 
 

Format The arrangement of data in record or file. 
  
Index Special data structure used in a database to speed searching for 

records in tables or spatial features in geographic data sets. 
  
Layer Layers organize a database or map library by subject matter (e.g., 

soils, roads, and wells). Conceptually, layers in a database or map 
library environment are exactly like coverages. 

  
Line A set of ordered coordinates that represents the shape of a 

geographic entity too narrow to be displayed as an area (e.g., 
contours, roads, and streams). A digital line begins and ends with a 
node. 
 A line on a map (e.g., a neat line). 

  
Longitude Angular distance, in degrees, minutes, and seconds, of a point east 

or west of the Greenwich meridian. 
  
Latitude Angular distance, in degrees, minutes, and seconds, of a point 

north or south of the Equator. 
  
Map Extend 1. The rectangular limits (x min, y min and x max, y max) of the 

area of the Earth's surface displayed. Map extent is specified in the 
coordinate system of the coverage or other geographic data set 
used. Typically, the extent of the geographic database (or a portion 
of it defined by a zoomed-in view) defines the map extent for 
display. 
 
2. The geographic extent of a geographic data set specified by the 
minimum-bounding rectangle (i.e., x min, y min and x max, y max).
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Map Projection A mathematical model that transforms the locations of features on 

the Earth's surface to locations on a two-dimensional surface. 
Because the Earth is three-dimensional, some method must be 
used to depict a map in two dimensions. Some projections preserve 
shape; others preserve accuracy of area, distance, or direction. See 
also coordinate system. 
Map projections project the Earth's surface onto a flat plane. 
However, any such representation distorts some parameter of the 
Earth's surface be it distance, area, shape, or direction. 

  
Nothings The y-coordinates in a plane-coordinate system 
  
Point 1. A single x, y coordinate that represents a geographic feature too 

small to be displayed as a line or area; for example, the location of 
a mountain peak or a building location on a small- scale map. 
2. A coverage feature class used to represent point features or to 
identify polygons. It is not possible to have point and polygon 
features in the same coverage. When representing point features, 
the x,y location of the label point describes the location of the 
feature. When identifying polygons, the label point can be located 
anywhere within the polygon. Attributes for points are stored in a 
PAT 

 
 
Polygon A coverage feature class used to represent areas. A polygon is 

defined by the arcs that make up its boundary and a point inside 
its boundary for identification. Polygons have attributes (PAT) that 
describe the geographic feature they represent. 

  
Parallel A property of two or more lines that are separated at all points by 

the same distance. 
A horizontal line encircling the earth at constant latitude. The 
equator is a parallel whose latitude is 0 degrees. Digital measures 
of latitude are positive up to 90 degrees above the equator and 
negative below. On maps they are identified by degrees N or S 
from the equator 

  
Region A coverage feature class used to represent a spatial feature as 

one or more polygons. Many regions can be defined in a single 
coverage. Regions have attributes (PAT) that describe the 
geographic feature they represent. 

  
Skew Distortion from the true or symmetrical form. A term often used in 

remote sensing to denote distortion of a digital image due to the 
earth's rotation, or due to the movement of a satellite along its 
path. 

  
Spatial Data Information about the location and shape of, and relationships 

among, geographic features, usually stored as coordinates and 
topology. 

  
Spline A mathematical curve used to smoothly represent spatial 

variation. A spline operation inserts vertices to create a curve in 
an arc. See also grain tolerance and density. 
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Symbol A graphic pattern used to represent a feature. For example, line 

symbols represent arc features; marker symbols, points; shades 
symbols, polygons; and text symbols, annotation. Many 
characteristics define symbols, including color, size, angle, and 
pattern. See also text symbol, marker symbol, shade symbol, and 
line symbol. 

  
Symbol Table Tables, which contain information about a database, such as the 

data dictionary and database transactions. 
  
Vector A coordinate-based data structure commonly used to represent 

linear geographic features. Each linear feature is represented as 
an ordered list of vertices. Traditional vector data structures 
include double-digitized polygons and arc-node models. 
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