|
GETTING STARTED GUIDE

NI-DAQ"mx Base 3.x

This guide describes how to install and configure the NI-DAQmx Base 3.x
software and a data acquisition (DAQ) device. This guide also describes
how to verify that the device is operating properly.

@ Note For information about NI-DAQmx Base for Linux and Mac OS X, refer to
ni.com/info and enter BaseGSGML.
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The following conventions are used in this guide:

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.
This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take

to avoid injury, data loss, or a system crash. When this symbol is marked
on the device, refer to the Read Me First: Safety and Radio-Frequency
Interference document that shipped with the device, for precautions to take.

Bold text denotes items that you must select or click in the software, such
as menu items and dialog box options. Bold text also denotes parameter
names.

Italic text denotes variables, emphasis, a cross-reference, or an introduction
to a key concept. Italic text also denotes text that is a placeholder for a word
or value that you must supply.
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monospace Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames, and extensions.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value
that you must supply.

Related Documentation

The following documents contain information you might find helpful as
you read this guide:

¢  Software documentation

NI-DAQmx Base Help

NI-DAQmx Base C Function Reference Help
NI-DAQmx Base 3.x Readme

NI-DAQmx Help

Getting Started with the LabVIEW Mobile Module, available in
PDF format by selecting Start»Programs»National
Instruments»LabVIEW 8.6»LabVIEW Manuals and selecting
Mobile_Getting Started.pdf

LabVIEW Help, available by selecting Help»Search the
LabVIEW Help

LabVIEW Fundamentals, available in PDF format by selecting
Start»Programs»National Instruments»LabVIEW 8.6»
LabVIEW Manuals and selecting LV_Fundamentals.pdf

e Hardware documentation

NI CF-6004 User Guide and Specifications

NI USB-6008/6009 User Guide and Specifications
NI USB-6501 User Guide and Specifications

E Series User Manual

NI USB-621x User Manual

NI USB-621x Specifications

NI USB-9211/9211A User Guide and Specifications
NI USB-9215 Series User Guide and Specifications
NI USB-9233 User Guide and Specifications

NI USB-9234 User Guide and Specifications

*  Documentation for your Mobile device

© National Instruments Corporation
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Overview

National Instruments measurement devices are packaged with NI-DAQmx
or NI-DAQmzx Base driver software. NI-DAQmx includes an extensive
library of VIs and ANSI C functions that you can call from your application
software, such as LabVIEW or NI LabWindows™/CVI™, to program all the
features of your NI measurement devices. The NI-DAQmzx Base driver
software has an application programming interface (API), which is a
library of VIs and ANSI C functions for creating applications for your
device.

NI-DAQmx Base

NI-DAQmx Base is a driver that allows you to build applications that
run using a Mobile device and Windows. NI-DAQmzx Base includes the
following features:

¢ NI-DAQmx Base is a subset of the NI-DAQmx API and is similar
in functionality to NI-DAQmx.

¢ NI-DAQmx Base consists of a LabVIEW VI framework, which allows
you to customize the driver, if needed, when using LabVIEW.

¢ NI-DAQmx Base provides a high-level interface on the
LabVIEW 8.6 Mobile Module and Windows Vista/XP/2000.

@ Note If you are familiar with NI-DAQmx, refer to the NI-DAQmx Base 3.x Readme for
information about the differences between NI-DAQmx Base and NI-DAQmx.

Device Support

NI-DAQmx Base 3.x supports the following devices under the
LabVIEW 8.6 Mobile Module:

* NICF-6004 e NIUSB-9215A"/USB-9215A BNC*
* NI DAQCard-6024E * NIUSB-9233"

* NI DAQCard-6036E * NI USB-9234"

* NI DAQCard-6062E ¢ NIUSB-6210"

e NI USB-6008/USB-6008 OEM * NIUSB-6211"/USB-6211 OEM*

e NI USB-6009/USB-6009 OEM * NIUSB-6215*

* NI USB-6501/USB-6501 OEM ¢ NIUSB-6218"/USB-6218 OEM*

e NIUSB-9211A"

* This product is only supported with dynamic tasks in NI-DAQmxBase. Go to ni . com/info and
enter code DMXBTask for more information.
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Operating System, Application Software, Programming
Language, and Device Support in NI-DAQmx Base 3.x

Operating System Support

NI-DAQmzx Base 3.x supports Windows Vista/XP/2000 and
Windows Vista x86/x64. The development environment for devices
using the LabVIEW 8.6 Mobile Module or Touch Panel Module is
supported on Windows Vista/XP/2000.

@ Note Only one version of NI-DAQmx Base (such as NI-DAQmx Base 3.2) can be
installed on the same computer at the same time.

Install Application Software

Install the NI application software, including LabVIEW,

NI LabWindows/CVI, and NI Measurement Studio. Mobile Module or
Touch Panel Module users must use LabVIEW 8.6 Mobile Module or
LabVIEW 8.6 Touch Panel Module with NI-DAQmx Base 3.2. Refer to the
Operating System, Application Software, Programming Language, and
Device Support in NI-DAQmx Base 3.x section for more information. Also,
refer to Getting Started with the LabVIEW Mobile Module for more
information by selecting Start»Programs»National Instruments»
LabVIEW 8.6»LabVIEW Manuals and selecting

Mobile_Getting Started.pdf.

@ Note Mobile Module or Touch Panel Module users should make sure that LabVIEW 8.6

Mobile Module or LabVIEW 8.6 Touch Panel Module is completely installed and
configured before continuing.

Step 1. Install the NI-DAQmx Base Software

The following sections describe how to install the NI-DAQmx Base

software.
Insert the CD
@ Note Install your driver software before installing new hardware devices, or the operating
system might not detect your device, and you might see warnings asking you to install the

driver.

Inserting the CD launches the NI-DAQmzx Base install window.

© National Instruments Corporation 5 NI-DAQmx Base Getting Started Guide



If the NI-DAQmx Base install window does not open automatically,

complete the following steps:
1. Select Start»Run.

2. Enter x:\setup.exe, where x is the letter of the CD drive.
3. Click Install NI-DAQmx Base.

Install Support Files

The NI-DAQmzx Base installer detects the NI software installed on the
operating system and automatically selects the latest versions of the driver,
application software, and language support files from the CD.

The NI-DAQmx Base installer displays which features will be installed on
your computer, as shown in the following figure.

Features
Select the features to install
S =] -I M- B 2
=) =| LabWIE' 8.2 Windows Support
=3 ~| LabVWIEW 8.5 Windows Suppart
= =D =| LabWIEW 8.6 Windows Support
= -| Examples
=3 ~| PDA or Touch Panel Support
= ] "I C Support
= -| Examples
= =| NI-vI54 4.4
= =| Ml Measurement & Automation Explorer 4.5

< IE
Directory for MI-DAQmx Baze 3.2

MNATIONAL
'FIHSIRIJMENTS'

MI-Dalms Baze 3.2 Device Diiver.
B
=
Thiz feature will be installed on the local hard drive.

Thiz feature and itz selected subcompaonents may
reguire up to 244 ME of disk space.

’Hgstole Defaultsl lQisk Costl ’

< Back " Mest »> l ’ LCancel

Complete the following steps to install NI-DAQmx Base.

1. In the Features window, shown in the previous figure, verify that the
installer detected and selected the correct support files and the correct
version number of the application software.

2. Click the + next to the feature to expand the list of feature
subcomponents, as shown in the previous figure. You can select
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additional options to install the support files, examples, and
documentation.

Follow the software prompts.

Click Finish and wait for the installer to complete. NI-DAQmx Base
might require you to reboot your computer to complete installation.

Step 2. Run the Setup Utility

After running the NI-DAQmzx Base installation, you must copy the driver
files to the device. Complete the following steps to run the Pocket PC
Driver Installation utility:

1.

Select Start»Programs»National Instruments»NI-DAQmx Base»
Utilities.
Launch the Driver Installation utility that corresponds to your device.

Check the device screen to see if any additional steps are requested,
such as replacing an older driver.

If there are no error messages, you have successfully completed the steps
to install the driver files on the device.

Step 3. Unpack the Devices, Accessories, and Cables

Your device ships in an antistatic package to prevent electrostatic discharge
(ESD) damage to the device. ESD can damage several components on
the device.

A Caution Never touch the exposed pins of connectors.

To avoid such damage, take the following precautions:

Ground yourself using a grounding strap or by touching a grounded
object.

Touch the antistatic package to a metal part of the computer chassis
before removing the device from the package.

Remove the device from the package and inspect the device for loose
components or any sign of damage. Notify NI if the device appears
damaged in any way. Do not install a damaged device in the computer,
Mobile device, or PXI chassis.

Store the device in the antistatic package when the device is not in use.

For safety and compliance information, refer to the device documentation
packaged with your device.

© National Instruments Corporation
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Step 4. Install the Devices, Accessories, and Cables

NI PCMCIA Device Installation

A Caution Follow proper ESD precautions to ensure you are grounded before installing the
hardware.

The NI PCMCIA device supports hot insertion on a Mobile device, which
means the NI PCMCIA device can be installed and removed without
rebooting the Mobile device. You can install an NI PCMCIA device in any
available Type II PC Card slot.

1 Mobile Device 3 Expansion Pack 6 Accessory
With Type Il PC Card Slot 4 NI PCMCIA Device 7 1/O Signals
2 Type Il PC Card Socket 5 1/0O Cable

To install the NI PCMCIA device, refer to the previous figure while
completing the following steps.

1. Attach the Type II PC cardsleeve or expansion pack to the Mobile
device, if necessary.

2. NI PCMCIA devices have two connectors: a 68-pin PCMCIA bus
connector on one end and an I/O connector on the other end. The
NI PCMCIA device is keyed so that you can only insert it one way.
Insert the NI PCMCIA device in the slot until the connector is firmly
seated.
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é Caution Always grasp the cable by the connector you are inserting or removing.
Never pull directly on the I/O cable to unplug it from the PCMCIA device.

3. Attach the I/O cable. Be careful not to put strain on the I/O cable when
inserting or removing the cable connector.

NI USB Device Installation

A Caution Follow proper ESD precautions to ensure you are grounded before installing the
hardware.

The NI USB devices support hot insertion on a Mobile device, which
means you can install and remove the NI USB device without rebooting the
Mobile device. You can install an NI USB device into any USB port that
supports USB host controller capabilities.

1 USB Cable 2 USB Adapter Cable 3 Synchronization Port

1. Connect the USB adapter cable to the synchronization port on
the Mobile device.

2. Connect the USB device to the adapter cable with the USB cable.

@ Note If you are using the USB device on a computer with Windows Vista/XP/2000 and
NI-DAQmzx 7.5 or later installed on it, make sure the correct firmware is installed on the
device. Go to ni.com/info and enter code USBFirmware for more information.

@ Note Before connecting the USB device to a Mobile device for the first time, you must
connect the USB device to a computer with NI-DAQmx Base 3.x installed on it in order to
install the appropriate firmware on the USB device. Go to ni.com/info and enter code
USBFirmware for more information.
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NI CompactFlash Device Installation

A Caution Follow proper ESD precautions to ensure you are grounded before installing the
hardware.

The NI CompactFlash device supports hot insertion on a Mobile device,
which means you can install and remove the NI CompactFlash device
without rebooting the Mobile device. You can install an NI CompactFlash
device in any available Type II CompactFlash slot.

To install the NI CompactFlash device, refer to the following figure while
completing the following steps:

1 Mobile Device With Type Il CompactFlash Slot 3 1/O Cable 5 1/O Signals
2 NI CompactFlash Device 4 Accessory

1. NI CompactFlash devices have two connectors: a 50-pin
CompactFlash bus connector on one end, and an I/O connector on the
other. The NI CompactFlash device is keyed so that you can insert it
only one way. Insert the NI CompactFlash device in the slot until the
connector is firmly seated.

A Caution Always grasp the device by the connectors you are inserting or removing.
Never pull directly on the I/O to unplug it from the NI CompactFlash device.

2. Attach the I/O cable. Be careful not to put strain on the I/O cable when
inserting or removing the cable connector.
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Accessories and PCI/PXI Devices

Install accessories and/or terminal blocks according to the instructions in
their user guides. Install PCI and PXI devices according to the instructions
included with your device.

Step 5. Confirm That Your Device Is Recognized

The following section discusses how to confirm that your device is
recognized.

Devices Using the LabVIEW 8.6 Mohile Module

Mobile devices only indicate whether a hardware installation error
occurred. If there are no error messages, you have successfully installed the
features and the device is recognized by the NI-DAQmx Base driver. If you
receive an Unknown Device error message, you have not correctly installed
NI-DAQmx Base on the Mobile device. Refer to Step 1. Install the
NI-DAQmx Base Software for more information about how to install the
Mobile device features of the NI-DAQmx Base driver.

Step 6. Create and Configure Static Tasks

A task, an important concept for NI-DAQmx and NI-DAQmzx Base, is

a collection of one or more channels with timing, triggering, and other
properties. Conceptually, a task represents a measurement or generation
you want to perform. You can set up and save all configuration information
in a task and use the task in an application.

Using the NI-DAQmx Base Task Configuration Utility

The NI-DAQmx Base Configuration Utility is used to create static tasks
only. The following sections describe how to use the NI-DAQmx Base
Task Configuration Utility.

@ Note Not all NI data acquisition devices support static tasks in NI-DAQmx Base 3.x.
Go to ni.com/info and enter code DMXBTask for more information.

Devices Using the LabVIEW 8.6 Mobhile Module

In NI-DAQmx Base 3.2, static task information is embedded in the built
application. Prior to building and downloading your VI to the Mobile
device, you must configure and save the static tasks you want to use.
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To use the Task Configuration Utility, complete the following steps:
1. Open LabVIEW.
2. Select Tools»NI-DAQmx Base Task Configuration Utility.

NI-DAQmx Base Task Configuration Utility

DAGmyx Base Tasks

ai finite dig trig
ai cont mulki

ai cont buffered
ctr simple event
dio read port
dio write port

4

x

Task Configuration Parameters

Analog Input Voltage Task

Refresh Devices

Device

MI B062E: "Devl" {on Mobile Device)

Channel List imi iggeri
Creats Mow Task | Task Timing | Task Triggering | Adwanced
Scan List
Delete Task. Morﬂchannel (ain Polarity ChannelType
||D | [1 v | [Bipolar | [differential 1+ |
Channel Gain Polarity ChannelType
Trpart Task List o 1 Eipolar differential
Channel Gain Polarity ChannelType
Export Task List 0 1 Eipolar differential

Save & Exit

NI-DAQmx Base Getting Started Guide

Create, Modify, and Configure a Static Task in
NI-DAQmx Base

Create a new task or modify an existing static task in the Task
Configuration Utility task list. The pre-installed tasks are configured to
work with the examples without modifications. To modify an existing
static task, select it in the static task list. To create a new static task,
complete the following steps:

1. Click Create New Task. The Create New Task.vi window opens.

Create Mew DACM: Base Task
Task Mamne

Mews Task |

Device

MI 60GZE: "Devl” {on Mobile Device)

\Acquisition Type
E} Analog Inpuk

OF, l [ Cancel ]
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2. Enter a name for the new static task.

Select the device. For devices using the LabVIEW 8.6 Mobile Module,
select the device that matches your installed hardware.

Select the acquisition type. Click OK when finished.

5. Each acquisition type contains a set of tabbed dialog boxes for
configuring the task. Configure all options specific to your task.

Analog Input Voltage Task
Device
NI 606ZE; "Devl" {on Mobile Cevice)
Channel List | Task Timing | Task Triggering | advanced
Skart Trigger Reference Trigger Analog Trigger
Trigger Polarity Pretrigger Scans Analog Trig Mode
Rising w 0 -~ Mone w
Trigger Source Trigger Polarity Analog Hi Ref
Mone W Rising v 0 -
PreTrigger Source Analog Low Ref
Mone ' i} e
@ Tip You can view context help for the Task Configuration Utility by pressing <Ctrl-H>.
=

6. Click Save & Exit when you are finished configuring your tasks.
The task configuration is automatically saved into LabVIEW global
variables. You do not need to explicitly save the configuration.

To transfer the task configuration to other computers, click Export
Configuration and save the tasks to a file. You then can use Import
Configuration to import the task configuration.

@ Note The Import Configuration and Export Configuration options operate on the entire set
of tasks shown in the Task Configuration Utility. Importing a configuration replaces any
existing tasks, including the predefined tasks for the example programs.

Devices Using the LabVIEW 8.6 Mohile Module

When you are using devices that use the LabVIEW 8.6 Mobile Module,
static task configuration is built into the target application. You cannot
retrieve the static task information after it is embedded in a built
application. Exporting the configuration allows you to preserve the task in
case of accidental deletion when using the Task Configuration Utility.
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Using Static Tasks in an Application
To use a static task in your application, complete the following steps:
1. Right-click the task/channels in terminal on a NI-DAQmx Base VI.
2. Select Create»Control or Create»Constant.
3. Type the name of the task in the control or constant.
4

To set the value as the default for the control, right-click the control and
select Data Operations»Make Current Value Default.

Documentation

The NI-DAQmx Base software kit includes online documentation for
supported devices and accessories, including PDF and help files describing
device terminals, specifications, features, and operation.

After installation, the documents are accessible from Start»Programs»
National Instruments»NI-DAQmx Base»Documentation.

Note You must have Internet Explorer version 5.0 or later to use some features of the
NI-DAQmx Base documentation, including the help system.

Getting Started Developing an Application

Examples

Each API includes a collection of programming examples to help you start
developing an application. You can modify example code and save it in an
application. You can use examples to develop a new application or add
example code to an existing application. NI-DAQmx Base examples

are accessible from Start»Programs»National Instruments»
NI-DAQmx Base»Examples.
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The following figure illustrates a typical NI-DAQmx Base application
in LabVIEW. The pictured task uses a static task to acquire and display a
finite number of points for multiple channels.

[ True ~pf

task/channels in — M easurement
i firite: buffered || 10,00

]
_“@“ i

Analog 20 DBL
S amples per Channel MNChar MSamp
[I52 )

Creating Applications with NI LabVIEW 8.6 Mobile
Module

Refer to Getting Started with the LabVIEW Mobile Module for more
information about how to create a Mobile application.

Obtaining Information about Measurement Applications and Devices

Each application software package and driver includes information about
writing applications for taking measurements and controlling measurement
devices. The following references assume you have NI-DAQmzx Base and,
where applicable, LabVIEW installed on your computer.

LabVIEW

If you are a new user, complete Getting Started with LabVIEW to
get acquainted with LabVIEW. Select Start»Programs»National
Instruments»LabVIEW»LabVIEW Manuals and open
LV_Getting Started.pdf.

The LabVIEW NI-DAQmx Base Help describes the LabVIEW VIs and
properties. In LabVIEW, select Help»Search the LabVIEW Help and the
VI reference help section for NI-DAQmx Base.

ANSI C

The NI-DAQmx Base C Function Reference Help contains an API
overview. Select Start»Programs»National Instruments»
NI-DAQmx Base C Function Reference Help.

© National Instruments Corporation 15 NI-DAQmx Base Getting Started Guide



Training Courses

National Instruments offers training courses for those interested in
receiving more help developing an application with NI products. To enroll
in a course or obtain a detailed course outline, refer to ni . com/training.

Where to Go for Support

The National Instruments Web site is your complete resource for technical
support. At ni.com/support you have access to everything from
troubleshooting and application development self-help resources to email
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at

11500 North Mopac Expressway, Austin, Texas, 78759-3504.

National Instruments also has offices located around the world to help
address your support needs. For telephone support in the United States,
create your service request at ni . com/support and follow the calling
instructions or dial 512 795 8248. For telephone support outside the United
States, contact your local branch office:

Australia 1800 300 800, Austria 43 662 457990-0,

Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599,

Canada 800 433 3488, China 86 21 5050 9800,

Czech Republic 420 224 235 774, Denmark 45 45 76 26 00,

Finland 358 (0) 9 725 72511, France 01 57 66 24 24,

Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737,
Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400,
Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710,

Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466,

New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60,

Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851,
Singapore 1800 226 5886, Slovenia 386 3 425 42 00,

South Africa 27 0 11 805 8197, Spain 34 91 640 0085,

Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151,

Taiwan 886 02 2377 2222, Thailand 662 278 6777,

Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 5235455

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation.
Refer to the Terms of Use section on ni . com/legal for more information about National
Instruments trademarks. Other product and company names mentioned herein are trademarks or trade
names of their respective companies. For patents covering National Instruments products, refer to the
appropriate location: Help»Patents in your software, the patents . txt file on your media, or
ni.com/patents.
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