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1 Driver installation for the Debugger

Connect the Debugger and PC with USB cable, and then the ‘new hardware search window’ will open
as figure 1.1 below.

Select ‘Automatically setup the software (I)” and click the Next (N) button.

Welcome to the Found New
Hardware Wizard
This wizard helps you install zoftware for:

USE <-» Serial

Z'\.':;l If pour hardware came with an installation CD
=i or floppy disk. insert it now.

WWihat do you want the wizard to do?

(%) Inztall the software automatically [Fecommended)
() Install from a list or specific location [Advanced)

Click Mext to continue,

[ M et = ] [ Cancel

[Fig.1.1] The new hardware search window 1
If it is not automatically installed, select the ‘Install from a list or specific location (Advanced) and set

our attached driver as below.

7]

aelect the Folder that conkains drivers For wour hardware,

Pleaze choose vour s

(%) Search for the besl| ._’] R =3
UJze the check boy # B ComparyWork
pathz and remonval = & Debugger
|:| Search rem = | DM 2,04, 16 WHOL Certified
. ) amdad
v ;
Include this 0 3t6
o £ | leeys
| H | & MP3
) Dan't search. | willl + | MPKI
Choosze thiz option| = O_Fﬁcezm? bat
the driver you chod ) wizISP_compack_werl 0 b
To view any subfolders, click a plus sign above,
[ QK ] [ Cancel ] T

[Fig.1.2] The new hardware search window 2

Wait for searching the device driver of the Debugger. When the device driver installation is completed,
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click the END button to finish.

¢ Completing the Found New
Q‘ Hardware Wizard
The wizard haz finizhed inztaling the software for:
% USE Serial Converter
Click. Finizh ta cloze the wizard.
1

Completing the Found New
Hardware Wizard

y IISE Senal Port
r—’

Click, Finizh to cloze the wizard.

The wizard has finished installing the software for:

[Fig.1.3] Completing the new hardware searching #2
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2 Connect the Debugger

This section will explain how the Debugger is connected with iIMCU7100EVB. Connect the
Debugger to the DTAG of IMCU7100EVB.

[Fig.2.2] W7100A /7 W7100 Debugger

Connect the other DTAG cable between the Debugger and iMCU7100EVB. The red line of
DTAG cable must be connected to line number 1 of iIMCU7100A DTAG socket. Also connect the
USB cable between the Debugger and PC. Next, insert the power cable to the IMCU7100EVB,
and push the EVB reset button as figure 2.1. Then, push the debugger reset button of the
Debugger. Confirm the LED5 (RUN LED) after pushing these reset button.

© Copyright 2012 WIZnet Co., Inc. All rights reserved. Ver. 1.1
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If the Debugger successfully recognizes the W7100A / W7100, the LED5 (RUN LED) will turn
on. But if the LED5 is not turned on, it means that W7100A / W7100 is not recognized. Check
the connecting cable or try to reset the IMCU7100EVB and the Debugger. The LED5 should be
turned on before using the W7100A / W7100 Debugger.
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3 Installation of the W7100A / W7100 Debugger

In this section, the installation of W7100A / W7100 Debugger is explained. First, run the
W7100A / W7100 Debugger install file.

4 g‘."?tmDDLEhLIQ er.Elxg .
M Getup Launcher Unicode
D 121

[Fig.3.1] The W7100A / W7100 Debugger install file

Then the installation of iMCU7100EVB debugger is started. Push the Next button to setup.

Wil00Debugger - In hield Wizard

Welcome to the InstallShield Wizard for
W7100Debugger

| The Installshield(R) Wizard will allow vou ko madify, repair, or
remove W7100Debugger. To continue, click MNesxt,

[Fig.3.2] Setup the W7100A / W7100 Debugger
I'.'I'.'I_|"1|:||:||::|Ei:l ugger - in [ ihiE!IEI Wiza n:i

InstallShield Wizard Completed

| The Installshield Wizard has successfully installed
W7100Debuager. Click Finish to exit the wizard,

i Einis

[Fig.3.3] End of debugger installation
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4 KEIL Project

Projects that are supported by the W7100A / W7100 debugger are as below.
® Keil uVision2 project
® Keil uVision3 project
® Only hex file (Restricted symbol function)

% The W7100A /7 W7100 Debugger don’t support the KEIL pVision4 or upper version project. But user
can easily convert the pVision4 to pVision3 project as shown in the figure 4.1 to use the W7100A /

W7100 debugger.

File Edit View [Project | Flash Debug Peripherals Tools SVCS Window Help

NE || HNew WVision Project... & ﬁ|| Xy
S E e New Multi-Project Warkspace...
= Open Project...
Project
—— orec  [.] SERIALH (&3]
=533 Target 1 I
B-£3 Source ¢ Export I3 Save Project to pVision3 format

~[ESTAR  manage » Save Multi-Project Workspace to pVision3 |
delay I

led.c Select Device for Target Target 1.

loopt Remove File ‘wizmemepy.c'
main

il /% | e R e Save Project to pVision3 format

socke Clean target

&r B TCPH (5 suia target Save Multi-Project Workspace to pVision3 format

e
WIET 48 Rebuild all target files

ason, wrong operation cc

& BatchBuild... [r 1t's not to be compiled " _ SERIAL UNUSED Block"

<Fig.4.1> Save Project to pVision3 format
% Caution on W7100A / W7100A Lock function
The W7100A / W7100A has the memory lock function. If the lock was set, user cannot use
the W7100A / W7100 debugger because it cannot read anything from W7100A / W7100A
memory. So user should unlock to use the W7100A / W7100 debugger properly. It is easy to
unlock using the WizISP program. As shown in the figure 4.2, clear the check box and click the
“Lock” button. Whole memory will be erased after the unlocking so user should re-write the
firmware again.
Please refer to the Wiz ISP user manual for more detailed information about WizISP. wizISP

program and user manual are available on the WIZnet website.
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@ WIizISP (v2.0.0.0)

2] (= )

Flash Operation Mode
@ Code © Data
Code [#] Data

Auto Task Selection
1. Flash Erase
2, Blank Check
3, Program

4, Verify

L T R S TR

foo P (=1

File  Device QOptions Help
Load HexToBin | Edit Save | Erase Blank
COM Port Configuration Hewx Editar
5 Addrss (Hex) 00
A S| —
FE
= FF
Baud: |115200 FF

FE:
EE

Program

01
FF
FF
FF
FF

Read Werify Auto

02 03 04 05 06 07 08 09 OA OB OC OD OE OF 01234567894ABCDEF
FF: FF FF FF FF- FF FF FF FF FF FF -FF FF FE . ............... -

BQO.

&

Run

@0

Help  Exit

T X Flash Operation Mode

@ Code

7 Data

Set

FF FF -FE FF FE
FF FF -FE FF FF
FF FF FF FF FE
FF FF -FE FF FF
FF FF FF FF FE

<Fig.4.2> Unlock the W7100A / W7100A using WizISP program

The W7100A / W7100 debugger cannot recognize multi directory structure of KEIL project

so all project file and source file must be placed in same directory to use W7100A / W7100

debugger.

And the ‘make hex file’ option and ‘make symbol” option should be activated in

the KEIL project. If they are not activated, the W7100A / W7100 debugger cannot find the hex

file to load. Also, an error message could appear even if it finds the hex file.

Since the W7100A / W7100 debugger use slower clock than normal running clock, running

speed under the debugging mode is very slow. So we recommend that don’t use a delay

function or something like that.

First, open the KEIL project.

Click “Project’ => “‘Options for Target ‘Target name’ menu.

© Copyright 2012 WIZnet Co., Inc. All rights reserved.
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k£ Test_Driver - ision3

=1of |

File Edit “iew [Profect] Debug Flash Peripherals Tools SYCS Window Help

BsH @ BR[| EE % %% B

«»> @ 2 qBEloe e m

223 Source Group |

] STARTUP, &51
farmemcpy.c
main,c
serial.c
socketc
wi100,c

BlsElalw|® |

S e X W K [Targetd am =
|Project Workspace - x|
=824 Target 1

|| ¢a|

E
s
E‘l 14 I 4 I PI NI'\Build f"\. Command }\ Find in Files !“ ” 4 I PI
A
[Fig.4.3] Open the KEIL project
Check the ‘Create HEX File’ option from the ‘Output’ tap as figure 4.2.
x|

Device | Target Output |Listing| User | C51 | 451 | BL51 Locate | BLS1 Misc | Debug | Utilities |

Select Folder for Objects. .. | Mame of Executable: ITESLD Tiver

% Create Executable; 9T est Driver

¥ Debug Information V' Brawse Information

I Create HEXFile  jpw Fomat [HEX-80 -

¢~ Create Library: ' Test_Driver.LIB

[T Creats Batch Fils

Ok || Cancel || Defaults I

© Copyright 2012 WIZnet Co., Inc. All rights reserved.
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[Fig.4.4] Output tap of the ‘Options for Target’ window

Select the ‘Listing” tap and check the ‘Symbols’ option of the ‘C Compiler Listing” region.

Options for Target "Target 1° x|

Device | Target| Output Listing |User | C51 | A51 | BLS! Locate | BLS! Misc | Debug | Utilities |

Select Folder for Listings. .. | Page 'width: |1 20 _l: Page Length: ISE _l;

W C Compiler Listing: ¥ lst
v Conditional

[ Hinclude Files [ Azsembly Code

[ CPreprocessor Listing: 5. ‘

IV Azsembler Listing: 4 Ist

[+ Conditional v Symbalz Macros: IFinaI expanzion anly ‘l [ Cross Reference

¥ Lirker Listing: T est_Driver.m51

vV Memary Map [V Public Spmbols V' Line Numbers [ Cross Beference

¥ Local Symbalz ¥ Comment Records W Generated Symbols
¥ Library Symbols

[0]4 I Cancel | Defaults | Help |

[Fig.4.5] Listing tap of the ‘Options for Target’ window

Also check the ‘Symbols’ option of the “‘Assembler Listing’ region. The ‘Assembler Listing’ is optional.

Click the “OK’ button to finish, and compile the KEIL project.

Confirm the HEX file in the project directory after compiling.

© Copyright 2012 WIZnet Co., Inc. All rights reserved. Ver. 1.1
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& C:\LOOPBACK_TCP

File  Edit Help

eBack & '\) Eﬁ pSearch [E:‘ Falders

View Favories  Tools

Address | C:\LOOPBACK_TCP

= B T

File and Folder Tasks

loopback.

LOOPBACK

loopback.

Iﬂ Renarne this file

@ Mowe this file:

Copy this file

e Publish this fil ko the Web
@ E-rail this File

¥ Delete this file

LOOPBACK LOOPEACK LOOPBACK hex

Other Places

wge Local Disk (C:)
[EJ My Docurnents
|3 Shared Documents
a My Cornputer

g Iy Metwark Places

loopback.LST LOOPEACK. MAP LOOPBACK.OpE

Details

=

LOOPBACK

LOOPBACK. Inp

LOOPBACK_Opt.Bak

[Fig.4.6] Hex file of the KEIL project

If the KEIL project includes the assembly code such as xxx.SRC file, the ‘Generate Assemble

SRC File’ and ‘Assembler SRC File’ options must be checked.

First, open the Options for File ‘xxx.c’ that uses the Assemble code.

Bl File Edit View Project Debug Flash Peripherals Tools SVCS Window Help

=N I - & %% % Y [ Za# - =0 S @ [BE o e m

&S X K Target 1 MR
Project Workspace - x| U1EI( ! =
02 [ (cICOPYRIGHT WiZnet Inc. ALL RIGHT RESERYED =
E1-433 Target 1
03 Y7o d
163 Seurce Group 1 0 Ak /
STARTUP.ASL Eg fx
delay.c 07 wiznencpy.c

led.c 08

@file

@hrief Define memory copy function between MCU mewory and TCPIPCore memory
-

+/

§inc}uga “wi00.h" i
13 #include "wizmemcpy h”
s g 14 #include "TCRIPCore. h"
TCPIPCore.c 15

7 [ 18 | #dafine REHFRAL 40P
Options for Fi i

ile y.c'

Open #wizmemepy Ist

Open Map File

Open wizmemcpy.c
£ Rebuild all target files

Remove File 'wizmemcpy.c'

Include Dependencies

2 EA = Edback

43 DPX0 = tnp_DPXO;

44

45 #else

|7 /
L |

_E\WP{HQ\ delay.c Wizmem‘,“

[Fig.4.7] Open the Options for File ‘xxx.c’
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Then, check the ‘Generate Assembler SRC File” and ‘Assemble SRC File’ options.

Options for File "wizmemcpy.c' @
Propetties ]CEI |
Path: |D:WWIZnetW__PurpIeWWNDDW__WNDD-.‘-‘«ppIicatiDn_Note_IntegratedVer‘v\J‘AppIicatiunSWTCF‘WTCPS
File Type: [C Source file = arget B
Size: [2019 Bytes [7 Always Build
last change: |Fri Apr 22 1015:26 2011 ¥ Generate Assembler SRC Fil
v Assemble SRC File
[l [ Link Publics Only
|| Code Bank:
Stop on Exit Cade: Mot specified |
Select Modules
0 Always
Include:
Custorn Argurments: |
EHI B Defaults TEY

[Fig.4.8] Setting the Options for File ‘xxx.c’
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5 Debugger menu

5.1 Open project

The W7100A / W7100 debugger can debug the KEIL project or the hex file. To debug the

KEIL project or the hex file, run the W7100A / W7100 debugger and open the hex file.

Open Project.

The Open Project command is used to open a project.

Click the ﬁ icon of the toolbar. It can also be done by clicking Project Menu => Open or

pushing the short key Ctrl + O

The file open browser is opened as figure 5.2 ‘File open browser.’

Search

Assembly

ar

|Register

== A
®2 Z

Register

RO
il
R
R3
Rd
RE
RE
R7

&
[=

B Default Registers -
=00

Walue

000
0x00
000
000
000
000
0x00
000

i j

| 4ssembly ~| [Search El
o3&
Marne | Walue | Type | Addres: ~
W
| £ >
s @, ("o [@s. [FEr. @e. @ &Ec. |
Ready NU

[Fig.5.3] Open project
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. W7100 Debugger

Project  Help
llg2l|® & T3
.| @ *

I EEEs3EEEEa =,

+ 121 projec Laak in: IBLDDPBAEK_TEP j & &5 El-
__._.-E LOOPBACK. hex
My Recent
Documents
Desktop

=

e
o Sl
€
| = L

El

1]

=1

=

by Computer

&

My Network File name: LOOPBALCK, A Open
Flaces I J 4'
Filesaftype:  |[HEX Flle [* hex) -l Cancel |

[Fig.5.2] File open browser
If the user opens the project that is consisted only with a HEX file, the Debugger will show

a caution message. And it shows only ‘Assembly window’.

W7100 Debugge RTUR, &51

2 G TTH s 3EEEED .,
% @MIOS »aE(z=(=,

LS (@ MAING | (€] FARMEMCPY.C | [c] STARTUP.AST x 2
project : Test_Driver |Hegister j

- [= Source Files 117  ?8TACK SEGMENT  IDATA Al s
& MAIN,C aLalfE) i Z
& FARMEMCPY.C Akaks] | REEG ?ETACK Register Value
&4 STARTUP, A51 1z0 pE] 1 B Default Registers 7
izt RO 000
1z2 { EXTRN CODE (?C_START) Rl 000
i i i i | PUBLIC ?C_ STARTUP Re (00
124 - R3 000
125 i1 17 icsEe AT 00000H fid U=00
126 0p7C STARTUE: LIMP STARTUEL A5 U=00
o R8 0400
128 P b b insEe 7¢_CS51STARTUR 'T g:gg
129 =1 [ ﬂ
130 STARTUPL:
gl Pob b ANL OFFH, #07FH v
< >
Azzembly Search
| Assembly | |search =
)
126 : 2C_STARTUE: Lomr srarmn”| [Name [ Value [ Tupe | Address [~
0y 0x0000 0ZOOLE LJME LOOOL
0x000b 020126 LIME LOOOOD
0x001b  0ZO15E LIME LOOOOD
131 : ANL OFFH, #07FH
0x001e GS3FFTF LO0OL: AL OFFh #7Fh | v
134 : wv  pogrplv| E4%e. Ello.. (&Gl & sy.. [Eve. @ Ex. @ F.. [ co.. |
Ready MU

[Fig.5.3] Complete opening the project
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*Note: When the user open the project and have the error message like shown below, the user must
delete the xxx.SRC file in project directory, and check both the ‘Generate Assembler SRC File’ and
‘Assemble SRC File’ options to avoid error on the W7100A / W7100 debugger.

For a more detailed solution, please refer to section4 ‘KEIL Project’.

W7100 Debugger

' O'E‘tiun arror! uVision Project Workspace—-» FARMEMCPY, C file-» Click right mouse button -» Select "Option for File
FARMEMUCPY C" -» Check 'Generate &ssembler SRC file and "Assemble SRC file' in Properies tab

[Fig.5.4] Open error message

Reload project
The Reload command is used to reload a project. When the loaded project is changed, click
the reload toolbar button [#] to reload the project. It can also be done by clicking ‘Project’

=> “‘Reload’ or pushing the short key F4.

Close project
The Close project command is used to close a project. Select ‘Project’ => ‘Close’ or push
the short key Ctrl + Q.

*Note: While using the W7100A / W7100 debugger, the user must use the ‘stop’ command in

order to close the debugger.

5.2 Initialize the W7100A / W7100 Debugger

This section is for initialization of the debugger and iMCU7100EVB
o W00 Debugger - STARTUR, A51

EE 36 TTH 88s33EE808.
S D WMIPOP| » @ FE(==E(F

[Fig.5.5] Initialize menu

W
Il

-

Debugger and board reset
The Debugger and board reset command is used to reset the debugger and board
simultaneously. If breakpoints were set, all initialized breakpoints will be removed.
To reset, click the E]; button on the toolbar, or select “Tool menu’ => ‘Init Debugger and

Board reset’ menu. Then the Debugger and board will reset.

© Copyright 2012 WIZnet Co., Inc. All rights reserved. Ver. 1.1
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Board reset only
The Board reset command only is used to reset the board only. If breakpoints were set, they
will be maintained. To reset the board, click the |2} button of the toolbar or select the

‘Debug menu’ => “‘Board reset’. It can also be done by short key F2.

Image load

The Image load command is used to load an image.

Write the HEX image for debugging to the Flash memory.

Click the H‘E, button or select Debug menu => Image Load menu to execute ‘Image Load.’
It can also be done by short key F3.

If the image writing and verifying is successful, ‘Write OK” message will show.

Note: If there is a mismatch between the board image file and present HEX file, the error

message is shown when execute the ‘Debugger commands’ such as ‘Continue, Step, Next’.

1=

W00 Debugger

!E Errorl! Load Image mismatch, please reload Image,
L

[Fig.5.6] Load image mismatch
Debugging

The W7100A / W7100 Debugger serves ‘Debug’ and ‘Tool” menu and Toolbar button for
debugging.

W00 Debugger - STARTUR, &51

FE @3 TTHH S eEEpsdEEEEI F.
s BHeO L » wm=(=50==]

[Fig.5.7] Deugging menu

Go to Source Line
The Go to Source Line command is used to move the cursor to the wanted source line. To use this

function, select the “Tool’ menu => “‘Go to Source Line’ or use short key Ctrl + G.

Find
The Find command is used to find some words on the source window. To use this function, select the

‘Tool” menu => ‘Find’ or use short key Ctrl + F.

© Copyright 2012 WIZnet Co., Inc. All rights reserved. Ver. 1.1
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5.3 Run and Stop

This section will explain how to use commands like step in, out, next, and more

Continue

The Continue command runs the program until the Break point is met. To use this command,
click the |[¢ button on the toolbar or select the Debug menu => Continue. It can also be
done by short key F5.

During the Continuing state, user cannot use the debugging menu. In order to use the

debugging menu, execute the Stop command.

Stop

The Stop command is used to stop the running program. To use this command, click the

. button on the toolbar or select the Debug menu => Stop. It can also be done by short
key F6.

The debugging commands (Search, memory view, break point, etc.) are executed only in the Stop state.

Step
The step command is used to run only one specific line among all lines. The Step command is executed
in units of one line of the C code. If there is a Function call, the Step command will enter into the
related Function. After the execution, the debugger is stopped and waits for the next command.
To use this command, click the button on the toolbar or select the Debug menu => Step. It

can also be done by short key F11. ™= If the user has only the HEX file to debug, the

Step command executes one instruction, just like the Stepi command.

Next

The Next command is basically the same as the Step command. The Next command is executed in units
of one line of the C code. But if there is a Function call, the Next command does not enter into the
Function. After the execution, the debugger is stopped and waits for the next command.

To use this command, click the button on the toolbar or select the Debug menu => Next. It
can also be done by short key [Z= F10. If the user has only the HEX file to debug, the

Step command executes one instruction, just like the Nexti command.

Stepi
The Stepi command executes only one instruction. If the instruction is a Function call, the command

enters into the related Function. After the execution, the debugger is stopped and waits for the next

command.
To use this command click the button on the toolbar or select the Debug menu => Stepi. It

can also be done by short key F7.

© Copyright 2012 WIZnet Co., Inc. All rights reserved. Ver. 1.1
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Nexti

The Nexti command executes one instruction. But the command does not enter into the related
Function even if the instruction is a Function call. After its execution, the debugger is stopped and waits
for next command.

To use this command click the [;E button or select the Debug menu => Nexti.

It can also be done by short key F6.

Run to cursor line

The “‘Run to cursor line’ command executes the code until the cursor on the debugger source window is
met.

To use this command, select the push the mouse right button => select ‘Run To Cursor Line(n)’ or
select the Debug Menu => Run To Cursor Line.

1= (===

] w7ionc | [c] sockeT.c | [c] SERIALC | [c]MAINLC x| [] FAF

-

55

56 uintl =xdata txsize [MAX S0OCE NUM
57 uintf =xdata rxsize[MAX SOCE_NUM
S8

Eg while= 1% -

60 Goto Source Line(L)

61 Set Break(B) tialize 4
2 Ingert Yariable Windowiy)

63 Run To Cursor Line(M)

o4 setSHER mac];

85 setGRR (gw) ;

1) 22tSUER (=2n) ;

Loy | A~ TTTT f 2l .

[Fig.5.8] Run To Cursor Line command

Sometimes the ‘Run To Cursor Line” command continues when the cursor is not properly set.

If that is the case, execute the Stop command to stop it.

© Copyright 2012 WIZnet Co., Inc. All rights reserved. Ver. 1.1
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5.4

Break Point

This section will explain how to set/clear and find breakpoints. The breakpoint can be set

only when the debugger is not being used. If the user was using the debugger, use the Stop

command to stop in order to set the breakpoint.

Project | Debug | Tool Window Environment Help

EEH & TTH fedEps3EEEEE &,

b @SE[ESE(E=E.

S [ wrioo | [c) SockeT.e | ] SERIALC | [ MAINLC x

} ] FARMEMCPY,C | ] STARTUP, 451

0x006c 7801
0x006e T7E00
0x0070 7E0E

0x0072 120350

MOV R1 #0D1h
MOV Ré& #0h
MOV R7 #8h

LCALL L0016

project ! test_driver - Register 2
EfaL_‘;Suurce Files // uint8 xdata tmp[&] = {0,0,0,0,0,0}; A ‘__gAl =
&4 W0,C =
&4 SOCKET.C uintd xdata ip[4] = {192,168,1,86}; /1 fo: Register Walue
<4 SERIAL.C uint8 xdata gw[4] = {1%2,168,1,1}; f/ £ B Default Registers -
] MAIN,C uint8 xdata sn[4] = {255, 255,255,0}; 144 RO (IS I
o4 FARMEMCPY.C uint8 xdata mac[&] = [0x00,0x08,0xDC,0x11,0x22,0x86}; ) F1 016
<] STARTUP. 451 RZ 0x0e -]
wintd xdata txsize[MAX_SOCE_NUM] = {2,2,2,2,2,2,2,2]; 3 A3 Oxtf
uintd xdata rxsize[MAX SOCK NUM] = {2,2,2,2,2,2,2,2}; gg Bmueu
%
RE 0x08
Tnit8051() ; // Initialize 8051 T gigg
iinchip inmit(); B 008
) 5P 061
SeTSHAR (mac) ; DPTRD 047700
SetGAR (gw) ; FC§ (Ox00de
setSUBR (=n) ; = PSW j
setSIPR(ip);
sysinit(txsize, rxsize); ~
< | >
1y 2 x | BreakPoint
Assembly x| |[BreskPaint -
oE % o=
Ux0053  T3C% WOV KL #0C9R A\ Wamz e 3
0x005k  7E00 MOV RE #0h IN,C, Line 74 main + 1
MAIN,C | Line : 52 main + 19
0x005d  7FOE MOV BT #2h AN, C | Line : 63 main + 3§
MAIN,C | Line : 54 main + 57
0x005f 120350 LCALL L0016 AN, C | Line : B6 main + 7
MAIN.C | Line : 57 main + 595
57 uinté xdata rxsizeMEX SOCK NUM] = (2,2,2,2,2,2,2,2} AN, C | Line : 67 main + 47
MAIN.C | Line : 57 main + 39
0x0062 7884 MOV RO #24h AN, C | Line : 67 main + 101
MAIN.C | Line : 57 main + 105
o0x0064 7CO0 MOV R4 #0h IMAIN.C | Line : 67 main + 103 T
020066 7001 MOV BS #lh
0x0068 TEEF MOV R3 #0FFh
0x006a 7AOE MOV B2 #0Eh

-jﬁreak‘,{aﬁeﬂmhlélDatamJﬂ Exter. | ] Flas... | [&] Glob... [[@code.. [ 52 Symbol E]Local. |

Ready

Set break point

To set the breakpoint
1. Click the shadowed region

. Locate the cursor and click the

[Fig.5.9] Break point

of the debugger

side of the source window

i# utton on the Toolbar

. Locate the cursor and click the Debug Menu => “‘Set Break’

. Double click the Assembly code line in the Assembly window

2
3
4. Double click the C code line in the source window
5
6

. Locate the cursor in the Assembly window and click the _3 he Assembly Toolbar

7. Short key F9

Set the breakpoint and execute the Continue command. Then the debugger will run until it

meets the breakpoint and will stop at the checked breakpoint. After that, the user can use
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other Debug commands. If the PC(program counter) can’t move to the breakpoint, the
debugger will keep running. If that is the case, the user should execute the Stop command to

stop it.

Clear Break
The Clear command is used to clear the breakpoint.
1. Click the checked breakpoint . region
2. Click the « _} button on the selected breakpoint line
3. Locate the cursor at the C code line and click the Debug Menu => Clear Break
4. Double click the breakpoint directly on the C code line
5. Double click the breakpoint directly on the Assembly code line
6. Select the breakpoint on the Assembly code line and click the [ button
on the Assembly Toolbar
7. Select the breakpoint on the C code line and select the 3 button on the Breakpoint
Toolbar
8. Short key F9

Clear All Breaks
The clear all breaks command will clear all breakpoints, both from the C code and Assembly
code. To clear all breakpoints,
® Click the _,‘:J' button on the Breakpoint Toolbar (Breakpoint window)
® Clickthe & button on the Toolbar

® Select the ‘Debug’ menu => ‘Clear All Breaks’

Goto Next Break Point

The Goto Next Break Point Command is used to move the cursor to the next break point.
To use this function,

Click the [z button on the Toolbar

Select the “Tool” menu => “‘Goto Next Break Point’

Goto Previous Break Point

The Goto Previous Break Point command will move the cursor to the previous break point. To use this
function,

Click the +ad button on the Toolbar

Select the “Tool”’ menu => ‘Goto Pre Break Point’
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Break Point Window
The Break Point Window command shows all checked breakpoints.
The break point Toolbar buttons are as below.
® if : Clear the selected breakpoint
° ‘9 : Clear all breakpoints

® 4| : Move to selected breakpoint

Source and Assembly window
In the Source window and Assembly window, user can see the source code and assembly
code. The user can also use Debug commands.

In the source window, user can check all variables and add it to the search window.

{71100 Debugger - STARTUP, A5

ZE aa TTH aa@asx3aE=a0x.
H BM@OP » @E(FCE (I

[Fig.5.10] Window menu

-

To use the Assembly window, click the —] button on the Toolbar or select the Window

Menu => Assembly menu. The Source window is always shown unless opening only HEX file.

Source Window

I['[g wrooc | &) sockeT.c | (€] SERIALC | [ MAIN.C x| [c] FARMEMCPY.C | (] STARTUR St

48 // uint8 sn_sr tmp, sn_mr tmp; L

45 // uint8 xdata tmp[€] = {0,0,0,0,0,0};

50

51 uint8 xdata ip[4] = {152,168,1,86}; S fo:

52 uint8 xdata gw([4] = {152,168,1,1}; Y ]

53. uint8 xzdata sn[4] = {255,255,255,0}; 7

54 . uint8 xzdata mac[&] = {0x00,0x08,0xDC, 0x1l1l, 0x22, 0x86};

55

s6 i uint8 xdata txsize[MBX SOCE NUM] = {2,2,2,2,2,2,2,2}; §

57 o> uintf xdata rxsize[MAEX SOCE NUM] = {2,2,2,2,2,2,2,2};

22 | Goto Source Line{L)

60 Initgos] SetBreakiB) 8051

61 iinchip Insert Wariable Windowd\)

G2 Run Tao Cursar Line(M)

63 setSHAR (mac) ;

64 3etGRR (gw) ;

65 =etSUBR (=n) ;

Y | setSIPR(ip) ;

&7 sysinit (txsize, rxsize);

68

Y | ButStringln | "====================================" ;

T0 PutStringln (" W7100 Net Config Information"); b
< | >

[Fig.5.11] Source Window menu

The Source window is shown in the figure 5.11.
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) L{} : indicates the PC (Program Counter) in the source code
° . : means Breakpoint is set on this line
) : the breakpoint can only be set on this shadowed line

Click the mouse right button in the Source window, user can see the Source window menu
as in the figure5.11.

® Goto source line: Move the cursor to the set line

® Set break: Set the breakpoint

® Insert Variable window: Add the variable to the Search window
)

Run To Cursor Line: Run the C code to cursor line

Moreover, the Source window can assist some functions as below.
® Can set the breakpoint by double clicking the C code.

® Show the indicated variable value when the mouse pointer on the variable.

Assembly window
The assembly window shows the currently running assembly code. Also if the user clicks the C code at
the source window, it shows the related assembly codes. If the user opens only the HEX file without Keil

project files, only the assembly window will be shown without the source window.

|Agsembly ]
33
0x0044 7TAOE MOV R2 #0Eh e
0x0046 79C3 MOV R1 #0C3h
0x0048 7EOO MOV RE #0h
0x004a 7FO& MOV R7 #&h
0x004c 12095D LCALL LOO1&
58 : uintf xdate txsize[MAX SOCK NUM] = [2,2,2,2,2,2,2,2};
I:) 0x004f 787C MOV RO #7Ch
. 0x0051 7C00 MOV R4 #0h
0x0053 7001 MOV RS #1h
0x0055 7BEF MOV R3 #0FFh
0x0057 TAO0E MOV B2 #0Eh
0x0059 79C9 MOV R1 #0CSh
0x005k TEQO MOV RE #0h
0x005d 7TF08 MOV R7 #&h
0x005f 12095D LCALL LOO1&

[Fig.5.12] Assembly window
In figure5.12,
) i}: Indicates the PC’s location of the instruction

) . : Indicates the break point

° _j‘r : Shows the assemble code with related C code
) _3 : Shows the break point
® double click: Sets or unsets the break point
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6 Search & Variable Window

The W7100A /7 W7100 debugger provides various windows to see the local variable, global

variable, and the register value.

® Global variable window: Shows the value of global variable in the project
® Local variable window: Shows the value of local variable at the PC(program counter)
now
Search window: Puts the variable name, then it shows the value at the PC now
Register window: Shows the value of registers at the PC now

Symbol window: Shows the all symbols and its values of the project

To activate each window, select the related window on the Window menu or click the

window button on the Toolbar.

W00 Debugger - STARTUR, A51

55 3s TTHZD8 g3 ase=dE]
& BMPOP| » WoE(=52(z-
[Fig.5.13] Search window

-

® Activate Search window: Click the r;'j or select the *Search Window’ on the Window
Menu

® Activate Local variable window: Click the _ﬂ or select the ‘Local Variable Window’
on the Window Menu

® Activate Global variable window: Click the ﬂ or select the ‘Global Variable
Window’ on the Window Menu

® Activate Symbol window: Click the ﬂ{:or select the “Global Variable Window’ on
the Window Menu

® Activate Register window: Click the f])' or select the ‘Register Window’ on the

Window Menu

6.1 Search Window

The search window shows the global variable, local variable, or the memory value,
depending on which ones the user registered. The global/local variable windows also show
the values of variables. But usually users want to see one or two variable values and
sometimes want to see both global and local variables simultaneously. In this case, just

register the variables on the search window.
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Zearch -
Marme | “alue | Tvpe | Address | -
00004 249, 42,14, 255 ARRAY
Ci0x00:4 2,18, 106, 120 ARRAY
#i0xBa0d 192, 166, 1,86  ARRAY £
5 4 J_CHAR 00000008
len 1] INT [0:0=000009
! [ |

W

[Fig.5.14] Search windows

To register the global/local variables, write down the register name on the name field of
the search window.

On the search window, user can not only confirm the variable but also can modify its value.
To modify the value of the variable, click the value field on the search window and write
down the value.

To see the memory value on the search window, write in the form, ‘memory type :
address : size.” The memory types are C, D, and X. (code memory, internal data memory and

external data memory).

Ex) Code memory => C:0x1000:5
Internal memory => D:0x30:2

External memory => E:0x000300:4

Local

|Search -
Mame | Value [ Type | Address | ~
5 1] I_CHAR D0 000008

fen [0 JIN]

i 1] U_CHAR BINARY (B} B
i 0 U_CHAR OCTAVD (0}

ip 192,168.1,86 ARRAAY

g 192°166.1.1 ARRAY DECIMAL (D)

El 256,256,255, ARRAY HE® ()

mac 0.8,22017.34.,,, ARRAY SARTOUTO

tusize 22222222 ARRAY e 00007C

tasize 22222222 ARRAY 000084

ha
%IData Memo,,,l E Global Vari,,,lﬂ@Symbol lECDde Memo,,,lﬂ External M,,, l E_F'_,]Local Varia,,,l@ Search ]
[Fig.6.1] Display format

User can select the display format by clicking the mouse right button on the search, local

and global window such as binary, octal, decimal and hexadecimal.
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6.2 Local Variable Window

The local variable window shows the value of the local variable in the PC located function.

Search -
Mame | Walue | Twpe | Address | ~
5 4 I_CH&R [ 0 000008
len 1] INT 00000009
i 1] U_CHAR [ 0= 00000E
ip 192.168.1.86 ARRAY #i0=000064
= 192,168,1.1 ARRAY 0= 00006E
=0y 266, 255,255.0 ARRAY #0w000072
mac 082201734, ARRAY #: 0= 000076
tesize 2222222 ARRAY #i 0= 00007C
rusize 22222222  ARRAY #:0=000084
W

[Fig.6.2] Local variable window
The local variable window has almost the same interface as the search window. But it is not

allowed to register a new variable or a memory address.

6.3 Global Variable Window

The global variable window shows all the global variables in the project. The global
variable window has the same interface as the local variable window.

Global Yariable -
Mame | Walue | Tvpe | Address |

data_buf 2a672 PTR [0 0=00005F

local_port 3823 U_NT #i0w 000099

read_addr_h B4 II_CHAR #i0w= 000063

read_addr_l 132 U_CH&R #i0= 000069

[Fig.6.3] Global variable window

6.4  Symbol window

The symbol window shows the information of all symbols in the project. It shows the class

type and the address of the related symbol.
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Syrnbol A
Hame | Class Type | Address | ~
-1 ?C_STARTUP
?C_STARTUP FUELIC C:0=000000
ACC SFRSYM D:0=x0000ED
B SFRSYM D:0=0000F0
DFH SFRSYH D:0=000083
DFL SFRSYH D:0x000082
IDATALOOFR SYMBOL C:0=00126D
FPAGE_SFR SFRSTM D:0=000040
&) 5P SFRSTM D:0=000081
STARTUP1 SYMBOL C:0=001264

+d
-1 MATH
_ICE_DUMMY SYMBOL C:0=000000
& o SFRSYH D:0x=000080
P1 SFRSYH D:0x=000090
& P2 SFRSYH D:0x00004D
& P3 SFRSYH D:0=0000E0
& IE SFRSYH D:0x=000048
& IP SFRSYH D:0=0000BE8
Te Ry PITRT Ti™ - A=-00nnn3 v

[Fig.6.4] Symbol window

6.5 Register window

In the register window, user can check or modify the value of the register. It shows the
default registers, PSW, and special function register (SFR). To modify the value of the register,
click the field of register value and write the new value. But if the register is read only, then

the value is not changed.

Register -
@z A
@ Z
Register Walue
= Default Registers -
RO 0:f9 ]
R1 022
Rz Ox0e
R3 Cssff
R4 O:x14
A5 O:04
RE Osdd
R O:x14
A Osf8
B 007
SP 061
DPTRO 00344
PC % 00211
B PSW
P 1
0
oy 0
A3 0
Fo 0
AC 1]
CY 1]
E Speicial Hegisters
PO Cssff —
DPL O:03
DFH O:dd
DPTR1 (20000
DPS 000
PCOM (080
TCOM Oxc0
THOD 020
TLO (200
TLI Oxfe
THO 000

[Fig.6.5] Register window
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7 Memory window

Notice: To read a memory value of IMCU7100EVB, a Keil project or HEX file should be
opened first. To read a memory value of iIMCU7100EVB, any Keil project or HEX file
should be opened first. But there are no differences between Keil project or HEX file
and image file which loaded to iMCU7100EVB.

The iIMCU7100API debugger supports below memory windows.
) IData memory window: Shows the value of internal data memory. Update the
value when stop state after the debugger command
External memory window: Shows the value of external data memory
Code memory window: Shows the value of code memory

Flash memory window: Shows the value of flash memory

To activate each window, use the ‘Window’ menu and Toolbar as in the figure7.1.
o W00 Debugger - STARTUR, A51

FE 3a TTH s@ER
BB PO®| »mE (===

[Fig.7.1] Memory window

-

-]

o Activate IData memory window: Click the _ button or select the “Window’
menu => ‘IData Memory Window’

() Activate External memory window: Click the ﬂ button or select the
‘Window’” menu => ‘External Memory Window’

o Activate Code memory window: Click the E button or select the *“Window’
menu => ‘Code Memory Window’

) Activate Flash memory window: Click the ﬂ button or select the ‘Window’

menu => ‘Flash Memory Window’
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7.1

The IData memory window can show the value of internal data memory (D:0x00 ~ D:0xFF)

IData Memory Window

or modify the value.

IData Memory »
tart Address. _ nd Address: _

2] (4] (3]

Address | 0123 | 4567 | g9aR | CDEF | A
0000000 F92A0EFF 14044414 04000000 0701138F

0000010 0o07000% 40004000 00000000 00000000

0000020 0ooooooo 00000000 00000000 00000000

0000030 0ooooooo 00000000 00000000 00000000

0000040 0ooooooo 00000000 00000000 00000000

0000050 0ooooooo 00000000 00000000 00000070

0000060 0ooo0202  C4193516 00000000 00000000

0000070 0ooooooo 00000000 00000000 00000000

0000080 FF610344 00000080  COZOOOFE  OOFCOL00

0000090 FFOO0DE00 00000000 50000000 00000000

0x0000a0 FFOO0O000 00000000 00000000 00000000

0x000050 FFOO0O0OOO0 00000000 00000000 00000000 v

apin9 1966ngad 00TLM / YOOT LM

[Fig.7.2] IData Memory window
To modify the value of internal data memory, click the value field of internal data memory
and write the new value. All memory windows can change into the display format, such as
2/4/8 byte display unit or CHAR/INT/LONG display format. It is shown in figure7.3.

IData Memary

Start Address: I:I End Address: I:I

2] [a]|[a]

Address | oiza | 4567 | 89aB | CDEF | ~
0x000000 62000000 00000100 00000000 00000000

0x000010 00000000 00000000 00000000 00000000

0x000020 00000000 00000000 00000000 00000000

0x000040 6l CHARIC)  EnGTing

0x000050 oooooooo o INTD 100000 00000000

0x000060 70000000 0 | QNG(L)y 000000 000aonoo

0x000070 00000000 Do 00000 00000000

0x000080 :  FFE2FBla 00000000 00000000 00000700

0x000090 :  FFOOO700 00000000 00000000 00000000

0x0000=0 :  FFOOOOOO0 00000000 00000000 00000000 =

ﬂlData Memo,,,l _}f] Global Vari,,,lﬂé‘:‘,Symbol IECDCIE Memo,,,lﬂ External Mlﬂ Local Varia,,,lﬂSearch ]

[Fig.7.3] Change the display format
If the internal data memory value updates and the debugger command is in stop state, it

updates the internal data memory value to the iMCU7100API board.

7.2

The external data memory window shows the value of external data memory (X:0x000000 ~
X:OxFFFFFF).

External Data Memory Window
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Address | o1zz | 4567 |  &9ae |  cDEF | ~
0=000000 :  OFFF07FF 07FFO0?PFF  O7FF07FF  O7FF07FF
0=000010 :  OFFFO07FF 07FFO?PFF  O7FFO7FF  O7FF07FF
0=000020 : 08000800 08000800 OS000B00 08000800
0=000030 : 08000800 08000800 OS000B00 08000800
0=000040 :  EF03217F 3C2665ES  COOD0OCRO0  DOOODEOO
0=000050 :  EOOOES00 FOOOFE00 SO008800 90009800
0=000060 :  AOODAS00 BOOOES00 36E4C0AS  0156COAR
0=000070 :  O101FFFF FFOOOOO8 DC112286 02020202
0=000080 : 02020202 02020202 02020202 01423DAC
0=000090 : 20008320 16270CEE  C4B41FFC  714B82EB4
0=0000=0 :  9600F98F 4E076809 4D28AB80  2124EFGE

[Fig.7.4] External Data memory window
The value of external data memory is not automatically updated. If the value of external
data memory updates on each debugging command, the speed of the debugger may be slower
due to the size of external data memory being larger than the internal data memory.
Therefore, the debugger has a button ﬂ for updating the value of external data memory.
As in section7.1 ‘IData Memory Window,” if the user changes the value of external data

memory in the debugger, the real value of iMCU7100API board will also change.

7.3 Code Memory Window

The code memory window shows the value of code memory (OxFFO000 ~ OXFFFFFF). This

window is for reading only, it cannot be modified.

Code Memory

tart Address:

2] a][e] 2

Address | niza | 4567 | §94E | CDEF | ~
Oz=000000 - 02126478 GAPCO07PD  O0O17EFF74  OE79E77E
0=000010 007F0412 095D786E  7C007D01 7EFF7AOQE
0000020 ; 79BE7EN0  7F041209 GDO7S8727C  O07D0O17E
0=000030 : FF7&0E79 BFFEODO0?F 04120950  7E7E7CO0
O=000040 - 7D017BFF  7A0E79C3 7EO07FO6  12095D78
0=000050 7C7C0070  017EFF7A  OE79C97E 007FO&L12
0=000060 ; 09507884  7CO07D01  7EFF7A0E  79D17EO00
0000070 ; 7F021209 SD121409 121AF07E 01740079
0000080 - 76121932 FEOL7A00 796E1719 E37E017A
0=000090 - 00797212  19F67BO1 7a00796&  1219CF7S
0=0000a0 OF017510 00751184  T7EOL7A00  797C1203

[Fig.7.5] Code Memory window

As in the section7.2 External Data Memory Window, the code memory window has a button for

3_ updating the value of code memory.

7.4  Flash Memory Window
7.4.1 Code Memory Domain

In the flash memory window, if the ‘Data memory’ option is unchecked, it will shows the
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value of code memory (0xFFO000 ~ OXFFFFFF). Basically it is same the ‘Code Memory Window’

but it can modify the value with flash write button.

Start Address: End Address: Data memory
Biojnj-y. |

Address 0123 4567 89AB CDEF
O=zff0000 : aooos0non 02112800 08FC9C14  20FEFE1E
O=zf£0010 : E0861AEC DCDC1D34 0OBEF941c0  EBEEDDOGOO
O=ff00z20 : DFO02CE0 FAFE94E2 FAET7FEFF SAFFATDE
O=f£0030 BEO3FF74 FF9FDACA  FFEDASFY AE3DBO9A
O=zf£0040 : 90EOEER2 91AF9ER7 72FDFFBS aF90FD90
O=zf£0050 : BEEYFF40  F98CC082 96CE9CEBC  EFA9ERI0
O=zf£0060 : FFDFSFFF  BeC4EZ00 EEFEEOD?  EeBDDD99
O0=ff0070 : FEB77298 00378124 DOEES028 86805480
O=zf£0080 DEFF848C  30EGAESSE 99FESEEE  ECFFCAFS
O=zf£0090 : SEBF7FD4  EYFBFFDG E4FD73E0  FFBEELF?
O=zff00a0 : 927EFF&E JF76FFE?  F9BDFEO4 16848 3EF
O=zf£00bO 1FF313BD E1EEEEO0& 9DFEC844 FDOOOADD
O=zff00=0 : CEC4BATE  BEGAY3AL JOF7D782 JEEEZELRE
0=ffoodo : SEFDD?FF ZEDDAFDEF 91F700Ce 70270000
O=zff00=0 82934012  ASFDOOID E0B9409F AFF430C2

Elsearch | &l Local v, | €] Global ., | &2 Symbol | [5]iData M., | [E] Externa..| (B Flash M., [&]Cade M.,

[Fig.7.6] Flash memory window for code memory
The basic interface of the flash memory window is the same as other memory windows. But
it has the flash write button ‘3 which writes the whole value of flash memory window to
the flash memory of iMCU7100API. Also it has a button E, for updating the value of flash

memory.

7.4.2 Data Memory Domain

Start Address: I:I End Address: I:I v Data memory
Bjninj-|

Address 0123 4567 894AB CDEF

O=f£0000 eooognon 02112800  08FC9ClA 20FEFBLS
Oxf£f0010 E0861AEC  DCDDID3E  (0EF94160  EBDDOGOD
O=f££0020 DFO0BCE0  FAFE94E2  FAEVFOFF  BAFFATDA
Oxf£f0030 Be03FF74 FF9FDACA FFEDE3F9 SE3IDE0SA
Oxff0040 90EQEEeZ2  91AF9EB? 72FDFFBS  8F30FD30
Oxf£0050 BBB7FF40 F93CC082 96C89CBC  SFASEE3D
Oxff0060 : FFDFSFFF  BeC4BB00 66FeBOD?  EGEDDDA9
Oxf£0070 FEB77293 00373124 DOBE9023  868DYASD
Oxf£00380 DeFF&48C  30EcAES8  99FESFEE  ECFFCAFS
Oxf£0090 8BBF7FD4 EBYFBFFDS  54FD73E0  FFEEELF?
Oxff00al : 927EFFe6  3IF76FFE?  F9EDFEO4  168AB3EF
Oxff00b0 : 1FF393BD EB1lEEBEZ23 9DFSCB8A4  FDOOOAOD
Oxff00c0 CeC4BATE  BoLA9344 7DF7D732  96EE3EGSS
O=zf££0040 SEFDD?FF  2EDDAFDEF  91F700Ce 70270000
Oxff00e0l : 82934012  ASFDO0O10  6O0B9409F  AEF430C2
Oxff00£0 : 00C77D04 081B2908  42C2BS00 00000000

Edsearch | E]Local .. | €] Global ., | & Symbol | [£]iData M. | [E] Externa... [E] Flash M., [€]Code M...

[Fig.7.6] Flash memory window for data memory
If the ‘Data memory’ option is checked, it will shows the value of flash data memory (0x00
~ OxFF). It can modify the value with flash write button. The basic interface of the flash
memory window is the same as other memory windows. But it has the flash write button
'E-, which writes the whole value of flash memory window to the flash memory of

iMCU7100API. Also it has a button 2. for updating the value of flash memory.
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