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An Introduction to ViewletBuilder6.2 Enterprise 
 
Qarbon welcomes you to the exciting world of Viewlet technology. 
 
People are natural visual learners, so a quick animated Viewlet gets the point across 
much more effectively than words on a page. And, with millions of presentations 
launched every month, Viewlets are one of the most popular ways of sharing 
information, providing support, presenting products and training staff. 
 
ViewletBuilder6.2 Enterprise, the authoring tool used to create Viewlets, allows anyone, 
regardless of technical or creative ability, to make compelling, animated online 
presentations with ease. Due to its versatility, intuitive interface and incredibly quick 
creation time, ViewletBuilder6.2 Enterprise is a standard content creation tool in 
corporations, governmental institutions and academic organizations throughout the 
world. 
 
ViewletBuilder6.2 Enterprise combines the power of ViewletBuilder6.2 Professional with 
the highly dynamic and interactive features found in ViewletQuiz3.2. This user manual is 
designed to introduce you to the world of Viewlet authoring and provide you with an 
overview of the most important ViewletBuilder6.2 Enterprise features you will need to 
know to create your own Viewlets. 
 
 
 
 

Important Note: 
As you read this user manual, you will discover that the instructions, 
examples and images were developed using ViewletBuilder6.2 Enterprise 
for Windows.  

Where possible, any significant supported feature differences between the 
Windows and the Mac program versions will be pointed out. However, the 
essential ViewletBuilder6.2 Enterprise authoring information is applicable 
to both the Windows and Mac platforms (with some slight differences in 
operating system-related terminology and where some features may be 
found from Windows to Mac). 
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New and Enhanced Features 
 
ViewletBuilder6.2 Enterprise introduces some long awaited new features and many 
enhancements, which include: 
 
 Preferences Proxy Tab (Auto Detect, No Proxy, Manually Configure) 
 Pair Links (View Menu Selection) 
 Drag and Drop Choice Text (Stylesheet Option) 
 Drop Area (Stylesheet Option) 
 Recording Options – Input Device (Sound Window) 
 Remove It Option (Warning for One Interactive Zone or Question Per Slide) 
 Drag and Drop (Quiz Project Question Type) 
 Click Map (Quiz Project Question Type) 
 Scale to Fit: Shapes, Images, Click Areas, Movies (Project Resize; Imported 

Slides) 
 Clear Incorrect Answers on Retry (Scoring Options) 
 PowerPoint Imported Slide Options (Select All, Select None) 
 Background Soundtrack (Loop at End, Pause During Zones and Questions) 
 Frame Rate Selection (Flash) 
 ViewletSkins w/Enhanced Table of Contents and No Audio Options 
 Social Networking (HTML Frame – ShareThis.qframe) 
 Secure Connection Option (Corporate ViewletCentral) 
 Passing Score in Manifest (SCORM Reporting Options) 
 “Send Score” and Lesson Status Selections (SCORM Reporting Options) 

 
 
To quickly spot new features or informative tips, scan the left margin for these icons: 
 

  Find out what’s new or enhanced with features and tools in 
ViewletBuilder6.2 Enterprise. 
 

  Review important Viewlet authoring tips provided by Viewlet masters. 
 
 

If you are interested in reviewing detailed information with regards to a specific 
ViewletBuilder6.2 Enterprise release (version number), please visit our web site and read 
through the version’s applicable “Release Notes”. 
 
 
If you have any questions, please contact us. Or, visit our web site (www.qarbon.com) 
for more information on all of Qarbon’s products. 
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Tech Specs 
 
The technical specifications, including minimum system requirements, for the effective 
use of ViewletBuilder6.2 Enterprise will depend on various factors, including your 
operating system. Go to the ViewletBuilder6.2 Enterprise product page (the link can be 
found on the Qarbon’s web site home page at www.qarbon.com). On the product page 
select the “Technical Specs” (or related) link for more information. 
 
If you have any questions after reviewing the technical specifications for 
ViewletBuilder6.2 Enterprise, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Download and Installation 
 
To download ViewletBuilder6.2 Enterprise, go to the Qarbon home page 
(www.qarbon.com). Click the “Downloads” link. On the “downloads” page, select 
ViewletBuilder6.2 Enterprise as the product you want to download. Follow the 
instructions on the rest of the web pages that display to download the installation file. 
 
 
Remember the file name and folder location of the installation file so you can find it when 
you are ready to install ViewletBuilder6.2 Enterprise. 
 
 
After downloading the installation file, close the browser window. Then, locate and 
double click the installation file to launch the installation wizard. Follow the prompts in 
the installation wizard’s windows to install ViewletBuilder6.2 Enterprise. 
 

 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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License Activation and Deactivation 
 
You must purchase a license to activate ViewletBuilder6.2 Enterprise. To purchase a 
license online, go to the Qarbon web site (www.qarbon.com) and click the “Store” link 
and select a pricing option. Or, you can contact the Qarbon Sales Team 
(sales@qarbon.com) for current pricing and related purchasing information. 
 
Once you purchase a license, you will receive a confirmation email with your license and 
purchase information. Keep this email for your records. 

License Activation 
To activate ViewletBuilder6.2 Enterprise: 
 Make sure your computer is connected to the Internet. 
 Open the ViewletBuilder6.2 Enterprise program. 
 Select Help > License Activation from the Menu bar. 

 

 
 

 Follow the instructions in the windows that display to complete the registration 
process. 

 
 

For best results, copy the license number directly from your email and paste it in the 
required field when registering ViewletBuilder6.2 Enterprise. 
 
 
To check license information: 
 Make sure your computer is connected to the Internet. 
 Open the ViewletBuilder6.2 Enterprise program. 
 Select Help > About ViewletBuilder6.2… from the Menu bar. 
 Review the information in the About ViewletBuilder6.2 Enterprise window that 

displays. 
 Click Close to exit the window. 
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License Deactivation 
There may be times when you will need to use your license on a different computer. To 
avoid any license abuse issues (such as registering a single use license on more than 
one machine at the same time, possibly resulting in your license being suspended), you 
can deactivate your license. The process is simple. 
 
To deactivate your ViewletBuilder6.2 Enterprise license: 
 Make sure your computer is connected to the Internet. 
 Open the ViewletBuilder6.2 Enterprise program. 
 Select Help > License Deactivation from the Menu bar. 

 

 
 

 Follow the instructions in the windows that display to complete the deactivation 
process. 

 Install ViewletBuilder6.2 Enterprise the other computer. 
 Follow the “license activation” steps to activate the license on the other 

computer. 
 
 

If you do not have Internet access or encounter firewall issues, go through the 
activation/deactivation wizard as usual. On the last screen, you will find troubleshooting 
instructions to resolve/complete the activation/deactivation process.  
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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GUI (Graphical User Interface) Overview 
 
It’s important to be comfortable when working in ViewletBuilder6.2 Enterprise. This 
chapter provides some quick snapshots of what the ViewletBuilder6.2 Enterprise 
program GUI (Graphical User Interface) “looks like” before you open a project and when 
a project is first opened. It also contains a brief description of the most common features 
and tools displayed in each scenario to give you a good “jump start” into using 
ViewletBuilder6.2 Enterprise. 
 
Example of ViewletBuilder6.2 Enterprise GUI – No Project Open 
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Example of ViewletBuilder6.2 GUI – Project Open 

 
 
 

Interface Features and Tools 
The ViewletBuilder6.2 Enterprise GUI includes: 
 
 Start View Panels: When ViewletBuilder6.2 Enterprise is launched the opening 

window displays a “Start View”, which is divided into individual “Panels”: 
 

o Start View – Actions Panel: Displays “action” links for New Project, Open 
Project and Check for Updates. 
 

o Start View – Recent Files Panel: Displays links for quick access to the 
most recent projects previously opened in ViewletBuilder6.2 Enterprise. 
 

o Start View – Help Panel: Displays links to help and training resources 
such as ViewletBuilder6.2 Help, User Guide and Webinars. A License 
Activation or License Deactivation “quick access link” is also available. 
 

o Start View – Publishing History Panel: Displays a list of Viewlets 
published to ViewletCentral. 
 

o Start View – Tutorials Panel: Displays links to various self-help Viewlet 
authoring tutorials. 
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o Start View – Start Panel: Dynamic (and fully customizable) page served 
from the Qarbon (or your company’s) server with important information 
regarding product updates (or information relevant to your company, if 
applicable). For a customized version of this page, contact 
sales@qarbon.com for more information. 
 

o Start View – Web Page Buttons Panel: Displays three buttons (left to 
right) to launch the Qarbon home page, the ViewletBuilder6.2 products 
page and/or the ViewletCentral home page. 

 
 Title Bar: This is the “bar” displayed at the top of the program window. 

Depending on whether the project is open or closed, it contains the program title, 
followed by the file name. It also includes three buttons to Minimize, Restore 
Down/Maximize and/or Close the program window. 
 

 Menu Toolbar: This toolbar “sits” below the Title Bar and contains menu titles 
that reveal additional drop-down menu options. The Menu bar offers access to: 
File, Edit, View, Insert, Project and Help operations. 
 

 Main Toolbar: This toolbar is below the Menu bar and displays a series of 
standard command buttons that offer quick “one-click” access to many tools in 
ViewletBuilder6.2 Enterprise. Many of these buttons on the Main Toolbar provide 
easier access to many options also available on the Menu bar. 
 

 Context Sensitive Toolbar: This toolbar displays when a project is open and is 
located below the Main Toolbar. The buttons displayed on this toolbar vary, 
depending on the current selection. This toolbar’s buttons change dynamically as 
you work within the project. 
 

 Tab Views: By default, different tabs for selected “views” (from the View menu) 
display to the left of or below the slide editing pane. Tab View selections include: 
Browser, Thumbnails, Stylesheets, Output, Timeline and Slide Notes. 
 

 Object Toolbar: Previously known as the “Tools Palette”, this toolbar displays to 
the right program window. It contains buttons for working with various objects 
such as: Balloons, Notes, Text Boxes, Cursors, Shapes, Images, Buttons, 
Movies, Pause Zones, Click Zones, Text Zones, Keystroke Zones and Questions 
while editing a project. 
 

 Slide Edit Area: This is the default panel view when a project is open. It displays 
the current slide for editing / viewing operations. The Slide Edit Area is hidden 
when any Tab View is maximized. 
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 Status Bar: Located at the bottom of the program window, this “bar” displays 
helpful information such as the number of the currently selected slide, the 
number of total slides in the project, the dimensions of the project, the “x” and “y” 
coordinates of your cursor as you work in the program window, the amount of 
system memory in use, and the zoom level currently selected. 

 
Each of these features and tools are discussed throughout this user manual. If you have 
any questions, contact us using the “Contact Us” or “Support” links on the home page 
(www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Mac GUI (Graphical User Interface) Key Points 
In ViewletBuilder6.2 Enterprise for Mac, the menu items are not part of the main 
ViewletBuilder6.2 Enterprise window. It is part of the standard OS X single menu across 
the top of the screen, which is typical for all OS X applications.  
 
 
Example of ViewletBuilder6.2 Enterprise for Mac – No Project Open 
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In Mac OS X, the first menu, named the same as the application, ViewletBuilder6 
Enterprise (in this instance) contains the following list of menu selections (some of 
these selections may vary on your computer): 
 
 About ViewletBuilder6 Enterprise 
 Preferences 
 Services 
 Hide ViewletBuilder6 Enterprise 
 Hide Others 
 Show All 
 Quit ViewletBuilder6 Enterprise 

 
 
The menu items shown in the image below may be different on your Mac system, but will 
include ViewletBuilder6.2 Enterprise options such as “About”, “Preferences”, “Quit”, etc. 
 

  
 
 
For more information on the ViewletBuilder6.2 GUI features, please see the previous 
chapter, GUI (Graphical User Interface) Overview, which has instructions and examples 
developed using ViewletBuilder6.2 Enterprise for Window. However, the essential 
authoring information is also applicable to ViewletBuilder6.2 Enterprise for Mac. 
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Program Preferences 
In ViewletBuilder6.2 Enterprise, you can set up program preferences for features such 
as language, spelling, proxy server, log files for error reporting, backup files and more. 
This chapter explains how to set up each of these global preferences for your Viewlet 
projects. 
 
 
You do not need to have a project open to set up program preferences. 
 
 
 
To access the program Preferences window: 
 Select Edit > Preferences from the Menu bar. 

 

 
 

 The Preferences window displays. Select the desired tab by clicking on it. 
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Accessing Preferences – Mac 
 
To access Preferences for ViewletBuilder6.2 Enterprise for Mac: 
 
 Select ViewletBuilder6 Enterprise from the single top menu. 
 Select Preferences. 

 

 
 

 In the window that displays, select the desired tab. 
 

The General Tab 
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Language 
The General tab allows you to specify the language that is used in the interface. By 
default, ViewletBuilder6.2 Enterprise will use your operating system’s default language 
preference, but you may switch to a different language for use in this program only. 
 
To select the default language to use in the ViewletBuilder6.2 Enterprise interface: 
 In the Preferences window, select the General tab. 
 In the Language area, click the Change Language button. 
 Select a language from the available list. 

 

 
 

 Click OK. 
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Recording 
You can select a countdown timer to display before each recording session when adding 
audio to slides, shapes, images or message objects. 
 
To set recording preferences: 
 In the Preferences window, select the General tab. 
 In the Recording area, select the Display Countdown Timer option. 
 Type the number of seconds for the countdown to display in the Countdown 

Duration field, or use the up/down areas to set this value. 
 
 
Message Editing Area 
In the Preferences window in the General tab, there is a new area called Message 
Editing. In this area, there are two options for editing message objects. Select one of 
these options to set as the default preference to use while working with notes, balloons 
and text boxes. 
 
To set a default message editing preference: 
 
 In the Preferences window, select the General tab. 

 
 In the Message Editing area, select either: 

 
o Edit in Place: When editing a message object, this selection allows you 

to edit text directly in the balloon, note or text box. And, you can use the 
message object’s Context Sensitive Toolbar to edit other message object 
properties. 
 
or 
 

o Use Message Editor: When editing a message object’s text, this 
selection opens the Message Editor window when double clicking a 
balloon, note or text box. This selection also allows you to edit other 
message object properties directly in the Message Editor window. 

 
 

It’s easy to switch between “message editing” options while working with message 
objects. Simply right click on the message object and, from the shortcut menu, select 
either “Open in Message Editor” to work in the “Message Editor” window, or select “Edit 
Message” to edit text directly in the message object. 
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The Spelling Tab 

  
 
In ViewletBuilder6.2 Enterprise, you can set preferences for the spell checker tool, which 
will automatically proof text in all of the message objects throughout your project.  
 
To select a default dictionary language to use in ViewletBuilder6.2 Enterprise: 
 In the Preferences window, select the Spelling tab. 
 In the Spell Checker area, select a language from the list to use as the default for 

the program’s spell checker tool. 
 
To select additional options for the spell checker: 
 In the Preferences window, select the Spelling tab. 
 Under the language list, select any additional options to use with the spell 

checker including: 
o Ignore words in UPPERCASE 
o Ignore words with numbers 
o Ignore domain names 

 
To enable/disable the spell checker tool, select “View” from the Menu bar. Then 
select/deselect the “Spelling Mistakes” option. 
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The Proxy Tab 
(Enhanced feature starting in ViewletBuilder6.2 Enterprise)  
 

 
 
There may be times when you encounter firewall issues while working with 
ViewletBuilder6.2 Enterprise. This may occur when activating your license or when 
updating the program. This is when a proxy server comes in handy, if your company has 
one available. The Proxy tab is where you can set up default proxy server information for 
the program to automatically use when encountering firewall issues. If, however, you do 
not know what a proxy server is, chances are you don’t need to worry about it. Some 
companies, however, actually require that software programs that access the Internet 
log on through a proxy server. In any case, there are several choices for proxy servers, 
but please contact your network or IT group for more information when working with this 
feature as needed. 
 
Auto Detect Proxy 
By default, the first option, Auto Detect Proxy, is selected. This feature will allow the 
program to search for and use a proxy server if required (for example, when a firewall 
prevents license activation or program updates). 
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No Proxy 
If you do not have access to a proxy server or do not want the program to search for it if 
firewall issues are encountered during license activation or program updates, select the 
No Proxy option. 
 
Manually Configure Proxy 
If your company requires you to use a proxy server for any reason, or if you encounter 
firewall issues while activating your license or obtaining program updates, select the 
Manually Configure Proxy option. Then, after obtaining the applicable information from 
your network or IT group: 
 
 Enter the proxy server Address in the field provided. 
 Enter the proxy server Port in the field provided. 

 
Click OK to apply changes made in the Preferences window. If any changes occur to the 
proxy server, a Warning will display, prompting you to restart the program. 
 

 
 
You must restart ViewletBuilder each time you change the proxy server settings in the 
“Preferences” window in order for the new settings to take effect. 
 
When you relaunch ViewletBuilder6.2 Enterprise, if you are using a proxy server, you 
may be required to enter in your proxy server login information.   
 

 
 
Contact your network or IT group for your Username and Password to log into your 
proxy server, if needed.   
 
Select the “Remember my password” option if you want ViewletBuilder to remember your 
proxy server password each time you are prompted to log in. 
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The Logging Tab 
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While ViewletBuilder6.2 Enterprise is running, it writes a log that describes in detail what 
is going on in the background. This is indispensable for tracking down software issues 
and making ViewletBuilder6.2 Enterprise as bug-free as possible. In the Logging tab, 
you can set program defaults for how ViewletBuilder6.2 handles logging reports and 
files. 
 
Output 
In the Output area of the Logging tab (Preferences window), you can set default options 
for the reporting of information in the Output tab, which can be viewed by selecting View 
> Output from the Menu bar.  
 
To select Output report options: 
 In the Preferences window, select the Logging tab. 

In the Output area, select an option from the Report list. These include: 
o Display Errors Only 
o Display Errors and Information 
o Display All Messages 

 

 
 
 

To clear the information in the Output tab: 
 In the Preferences window, select the Logging tab. 
 In the Output area, click the Clear Output Window button. 

 
 
Log File 
In the Log File area of the Logging tab (Preferences window), you can set default 
options for the size of the logging file and the location where ViewletBuilder6.2 
Enterprise will save the file. 
 
To enable the Logging feature for ViewletBuilder6.2 Enterprise: 
 In the Preferences window, select the Logging tab. 
 In the Log File area, select the Enabled option. This will allow ViewletBuilder6.2 

Enterprise to create a record of information to help Qarbon find and correct 
program errors. 

 
To set the log report’s maximum file size: 
 In the Preferences window, select the Logging tab. 
 In the Log File area, type a number in the Size Limit field. This will be the 

maximum size (in KB) allowable for the log file. 
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To clear the log file: 
 In the Preferences window, select the Logging tab. 
 In the Log File area, click the Clear Log File button. 

 
To set the default location where the log file will be saved: 
 In the Preferences window, select the Logging tab. 
 In the Log File area, type the path to where you want log files to be saved. Or, 

click the “yellow folder” next to the File field. 
 A Select Log File window displays. Browse to locate and select a new save 

location for the log file. 
 Click Open to apply and to return to the Preferences window. 

 

The Backup Tab 
 

 
 
The Backup tab allows you to set program preferences for creating backup files while 
working on your Viewlet project.  
 
Backup Files on Save 
When saving your project, ViewletBuilder6.2 Enterprise can create and update a backup 
file. This file can be used to restore a corrupted project from the last “known” good save. 
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To enable ViewletBuilder6.2 Enterprise to create a backup project file: 
 In the Preferences window, select the Backup tab. 
 In the Backup Files on Save area, select the Enable - .BAK appended 

extension option. 
 
 
ViewletBuilder6.2 Enterprise creates backup files that end in “.qvp.BAK”. To restore a 
project from a backup file, first rename the original project file’s extension to something 
like “.qvpOLD”. Then, simply remove the “.BAK” extension from the backup file so that the 
file ends in “.qvp”. It will become the new project file, which can be opened in 
ViewletBuilder6.2 Enterprise. 
 
 
To create backup files automatically as you work on the project: 
 In the Preferences window, select the Backup tab. 
 In the Backup Files on Save area, select the Backup Files on Automatic Save 

option. 
 
To save the backup files in the same folder where the original project file is saved: 
 In the Preferences window, select the Backup tab. 
 In the Backup Files on Save area, select the Store backups in local folder 

option. 
 
To select a location to save the backup file in (other than in the same folder as the 
original project file): 
 In the Preferences window, select the Backup tab. 
 Select the Store backups in common folder option. 
 Type the path where you want the backup file saved, or click the “yellow folder” 

button. In the Select Folder window, select a folder and click Open to save the 
new backup file location. 

 
Automatic Save 
ViewletBuilder6.2 Enterprise can create automatic backup files while you are working on 
your project. 
 
To enable ViewletBuilder6.2 Enterprise to create automatic backup files and to set the 
automatic save intervals while working on your project: 
 In the Preferences window, select the Backup tab. 
 In the Automatic Save area, select the Enable Automatic Save option.  

o Enter a number in the field provided for when the project is automatically 
saved. 
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The Advanced Tab 
 

 
 
The Advanced tab displays the current virtual memory usage settings allowable when 
ViewletBuilder6.2 Enterprise is in use. 
 
To view the current Java settings for ViewletBuilder6.2 Enterprise: 
 In the Preferences window, select the Advanced tab. 
 In the Java area, review the settings for initial and maximum memory allocations. 

 
 
To change the memory settings allowable for ViewletBuilder6.2 Enterprise: 
 In the Preferences window, select the Advanced tab. 
 In the Java area, click the Change Java Settings button. A Java Preferences 

window displays. 
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 In the Memory area (Java Preferences window): 
o Enter a number for the Initial memory to be used by ViewletBuilder6.2 

Enterprise in the field provided. 
o Enter a number for Maximum memory allowable in the field provided. 

 
 In the VM Options area (Java Preferences window), enter additional Virtual 

Memory options as needed. 
 

 Click OK to save the information and to close the Java Preferences window. 
 
Once you’ve set all your program preferences, click OK to save the settings and to close 
the Preferences window. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Creating a New Project Basics 
ViewletBuilder6.2 Enterprise, which combines ViewletBuilder6.2 Professional and 
ViewletQuiz3.2 into a single, all-encompassing Viewlet Authoring suite, offers five 
distinct options for creating new Viewlet projects. The new project types include: 
 
 Screen Capture Project: Capture an application as it runs on your computer to 

create a demonstration, simulation or a user training assessment. 
 

 Image Project: Create a presentation using one or more images (supported 
images: jpg, bmp, png, gif and tif). 
 

 PowerPoint Project: Import slides directly from a Microsoft PowerPoint project. 
 

 Quiz Project: Use this new project type to create a project of scored slides to 
test user, or create survey questions to gather information from your user base. 
 

 Blank Project: Start from scratch by creating a project containing one or more 
blank slides. 
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Each of the five new project types is covered in detail later in this user manual.  
 

New Project First Steps 
When creating your new project, the first few steps are common to all new projects. This 
chapter focuses on the “first steps” all authors will need to take when creating new 
projects. 
 
Step 1: Select a New Project Type: 
The first step when creating any new project is to decide what type of project you will be 
creating. As mentioned earlier in this chapter, there are five different new project types to 
choose from in ViewletBuilder6.2 Enterprise. 
 
 Select File > New from the Menu bar. Or, click the New Project link (from the 

Start View), or click the New button from the Main Toolbar. 
 

 The Create New Project window displays. Select a new project type from the list 
on the left side of the window by clicking it to highlight it.  

 
Step 2: Select the New Project’s Slide Size: 
Once you’ve select a new project type, the second step is to determine the size (width 
and height) for all the slides in your project. There are at least two slide size options 
available for all new project types: 
 
 Custom: Set a custom width and height. 
 Standards: Select from a list of standard resolutions, or create a new “standard” 

to add to the available list. 
 
If you select Screen Capture Project as your new project type, there are several more 
slide size options to choose from (in addition to the two listed above): 
 
 Application: Capture an open application and use its window size (width and 

height) as your new project’s slide size. 
 

 Area: Capture an area of the screen and use this area’s size (as determined by 
you prior to capturing screenshots) as your new project’s slide size. 
 

 Window: Select either an open application’s window or an open operating 
system window and use the selected window’s size as your new project’s slide 
size. 
 

 Full Screen: Capture everything visible on your computer’s screen and use the 
monitor’s resolution (that is used during the capture session) as the width and 
height for your new project’s slide size. 

 
When selecting a slide size for your project, remember, this is also going to be the size 
that the Viewlet will be played back at when your audience views it. So, if a viewer has to 
scroll to view parts of the Viewlet that are “off-screen” then you may need to use a smaller 
size for your Viewlet. 
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To select a slide size for your new project: 
 In the Create New Project window, make sure you’ve selected the desired New 

Project Type. 
 In the Slide Size area, select an option from the list of available slide sizes. 

 
 
Working with the Various Slide Size Options 
Each of the various slide size options have some additional selections, depending on 
which side size you choose. Following are instructions for working with each of the 
available slide size options. 
 
 Custom: Select this option to create a custom project size. 

 

 
 

o Enter a number in the Width field. 
o Enter a number in the Height field. 

 
 

 Standards: Select this option to: 
 

 
  
 

o Create a project size based on a “standard” (monitor) resolution: 
 Select a preset standard resolution for your project size from the 

available list. 
 

o Create a “new” Standard: 
 Select a preset Standard from the list. 

 Click the Add Standard    button. The Standard Resolution 
window displays. 
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 Enter a name for the new Standard in the field provided. 
 Enter a Width in the field provided. 
 Enter a Height in the field provided. 
 Click OK to save the settings and to close the Standard 

Resolution window. 
 

 
 

o Modify an existing Standard: 
 Select a Standard from the list. 

 Click the Modify Standard   button. The Standard Resolution 
window displays. 

 Make your edits as needed and click OK to save the settings and 
to close the window. 
 

o Delete an existing Standard: 
 Select the Standard you want to remove from the list. 

 Click the Delete Standard  button. A Delete Standard warning 
window displays. 
 

 
 

 Click Yes to confirm the deletion. Click No to cancel the deletion. 
  

 
 Application: Select this option to use an “active” program or operating system 

window as the baseline for your project size. 
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o Select an “active” program or operating system window from the list. 
 

o If the window you need is not in the list, launch the program or open the 
desired operating system window in the appropriate size. Then, click the 

Refresh Applications  button to refresh the list and make your 
selection from the list. 
 

o To resize the selected “active” window to a specific size for the capture 
session: 
 Select the Resize Application to: option. 
 Click the button next to the Resize Application to: option. The 

Application Size window displays: 
-Select Custom or Standards from the slide size list. 
-Complete the steps for the selected slide size (covered previously 
in this chapter) as needed. 
-Click OK to save the settings and to close the Application Size 
window. 
 

 
 

 
 
If you select “Application” (an active program or open operating system window) as your 
project’s slide size option, ViewletBuilder6.2 Enterprise will move this “window” to the top 
of all open windows when you initiate your capture session. 
 
 
 Area: Select this option to set a custom project size by drawing the specified 

screenshot area prior to the capture session. 
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 Window: Select this option to choose a program or operating system window 

prior to starting the capture session as the baseline for your project size. 
 

 
 

 

If you select “Window” as the slide size option for your project, you can also use this 
option to select a specific “portion” of a window (not just the entire window) prior to 
starting your capture session. 
 
 
 Full Screen: Select this option to capture everything visible on your computer’s 

screen during the screenshot session. 
 

 
 
 

o Select a Screen Resolution from the list. If the selection is different from 
your monitor’s current resolution, ViewletBuilder6.2 Enterprise will 
automatically change your monitor’s resolution to your selected resolution 
when you start your screenshot session. When you end your screenshot 
session, ViewletBuilder6.2 Enterprise will return your monitor’s resolution 
back to the setting it was prior to the capture session. 
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Step 3: Make the rest of your selections in the Create New Project window: 
After you complete the first two steps for creating a new project, the rest of the steps will 
differ depending on what you selected for your new project type. Please refer to the 
specific chapter for more information on creating a new project based on the type of new 
project you are creating. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Screen Capture Project 
ViewletBuilder6.2 Enterprise allows you to create a new project from a series of 
screenshots of an application running on your computer (or from various open operating 
system windows). Screen Capture projects can be captured using various “slide size” 
options based on custom sizes, active program / operating system windows, or screen 
resolutions. Each step of the process for creating a new Screen Capture Project follows. 
 

1. Select the Project Type and Slide Size 
 Select File > New from the menu option. Or, in Start View, click the New Project 

link, or click the New button from the Main Toolbar. 
 

 The Create New Project window displays. Select Screen Capture Project from 
the New Project list. Additional options for creating a new screen capture project 
will display in this window. 
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 In the Slide Size area of the Create New Project window, select a width and 
height for your Viewlet project. 

 
 
For more information on selecting a New Project Type or selecting a Slide Size for your 
new Viewlet project, please refer to the Creating a New Project Basics chapter. 
 
 

2. Capture Profiles 

Here’s some quick “QA’s” to get started working with capture profiles: 
 
What is a Capture Profile? 
It is a way to organize all the “capture options” chosen for either a “Smart Capture” 
(Windows only) or a “Manual Capture” screenshot recording session into one place or 
“profile”. 
 
Does the Capture Profile “title” signify anything? 
Yes and no. The “title” of the Capture Profile is like the title of a document. It just gives 
you an idea of what the profile would be used for. You can change the title of the profile 
at any time. 
 
Are Capture Profiles used for all new project types? If not, why not? 
No, Capture Profiles are only used when creating new Screen Capture Projects or when 
inserting new screenshots into existing projects. The reason for this is because a 
Capture Profile is simply a “collection” of capture options (stored in one profile) used 
during either a Smart Capture (Windows only) mode or Manual Capture mode 
screenshot recording session. 
 
What is the “basic” process for creating a “new” Capture Profile. 

1. In the “New Project” window, with the “Screen Capture Project” type selected, 
click the “Add” button to open the “Capture Options” dialog window. It will be in 
this window where you will select options for your screenshot recording session. 
And, these selections will be saved in your new Capture Profile. 
 

2. The next step is to decide what “capture mode” you want to use with this profile. 
The choice is either “Smart Capture” (Windows only), which automatically 
captures screenshots, or “Manual Capture”, which forces you to manually 
capture screenshots using a hotkey and or mouse click actions. The capture 
mode you select at this point determines what additional “tab options” display for 
additional selections for your Capture Profile. 
 

3. Make your selections in the tabs that display below your selected “capture 
mode”. These are the “additional” capture options that will be saved in your 
profile and used when taking screenshots using this Capture Profile. 
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a. If you selected “(available for ViewletBuilder6.2 Enterprise for Windows 
only) ” mode, seven tabs will display (General, Feedback, Mouse, Wheel, 
Keyboard, Annotations, Advanced). 
 

b. If you selected “Manual Capture” mode, four tabs will display (General, 
Feedback, Mouse, Advanced). 
 

4. Once you’ve read through and completed all the information in the Capture 
Options window (in all the tabs), click OK to create the new profile. 
 

5. Use this profile each time you want to create a new Screen Capture project or 
insert new screenshots using the selected capture mode (Smart Capture - 
Windows only) or Manual Capture) and additional capture options in this Capture 
Profile. 

 
Can Capture Profiles Be Modified? 
Yes, when you install ViewletBuilder6.2 Enterprise, you will see a short list of Capture 
Profiles already installed. The title of each profile suggests the “type” of project the 
Capture Profile might be good for and is further explained in the profile’s description. 
But, you can modify any of these profiles instead of creating a new one. 
 
 
When creating a new Screen Capture Project, ViewletBuilder6.2 Enterprise offers you 
several “prebuilt” capture profiles to help you easily create specific Viewlet projects, 
including: 
 
 Demonstration: Show how something is done. 
 Training Simulation: Train users how to do something. 
 Assessment: Evaluate training effectiveness. 
 Manual Capture: Capture screenshots and cursor animation manually. 
 Manual with Mouse Click Capture: Capture screenshots manually with hotkeys 

or mouse clicks. 
 Simple: Capture screenshots (without cursor animation) manually. 
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Each capture profile (added during the program installation) contains pre-selected 
“capture options” based on the specific profile. You can use the defaults for the selected 
profile, modify the selections in the profile, or create a new capture profile from scratch. 
 

Select a “Capture Profile” from the list. Then, click the “Modify”  button to open the 
“Capture Options” window where you can review and modify options as desired. 
 
To create a new Capture Profile: 

 In the Capture Profiles area, click the Add  button.  
 

 The Capture Options window displays. In the Capture Mode area, select a mode 
to use for the capture session: 
 

o Smart Capture (Windows only): This mode automatically captures all 
changes that occur on your computer’s screen during the screenshot 
session. 
 
or 
 

o Manual Capture: This mode allows you to use a hotkey to manually 
capture each screenshot during the capture session. 

 
 
The “Capture Mode” you select determines what tabs will display in the “Capture Options” 
window where you will make additional selections for your capture session. And, some of 
the options may vary in each of the tabs depending on your selected capture mode. 
 
Smart Capture  Mode tabs: (Windows only)  
General, Feedback, Mouse, Wheel, Keyboard, Annotations, Advanced 
 

 
 
 
Manual Capture Mode tabs: 
General, Feedback, Mouse, Advanced 
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 In the General tab (available for Smart Capture (Windows only) and Manual 

Capture): 
o In the Identification area, enter a: 

 Name for the profile. This name will display in the Capture 
Profiles list. 

 Description or a short summary for the profile. This will display 
below the profile title in the Capture Profiles list. 
 

 
 

o In the Timing area: 
 Select the Maintain Timing Links to maintain links between 

applicable objects (message objects, cursors, etc.) along the 
Timeline on each slide. For more information on “Timing Links”, 
please review the Timeline Tab chapter. 
 

 
 
 
For more information on “Timing Links”, please review the “Timeline Tab” chapter. 
 
 

 Enter the number (of seconds) for an Introductory Delay default 
before the first note or balloon is displayed on a slide. 

 

You can change the “Introductory Delay” for your project at any time by selecting 
“Project” then “Project Properties” from the Menu bar. In the “Project Properties” window, 
select “Timing” from the list and change the number in the “Introductory Delay” area. 
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o In the Hotkeys area, several hotkeys are available. To change a hotkey, 
click the applicable button next to the hotkey’s description and press the 
new hotkey(s) to be used for the desired hotkey option. 
 
Capture Hotkeys: 
 

 
 
-Capture Screenshot: Used to capture a screenshot manually. 
-Capture Background Frame: Used to capture an animation frame. 
-Pause Capture: Used to pause the capture session. 
-Stop Capture: Used to finish the capture session and convert 
screenshots to slides. 
-Cancel Capture: Used to cancel a capture session without converting 
screenshots to slides. 
 
 

 
 
If you click the “Pause” hotkey during a Smart Capture 
(Windows only) screenshot session, to resume the 
session, simply click the “Continue” button in the 
“Capture Status” window that displays over the 
system tray. 
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Use the “Pause” hotkey to display the ”Capture Status” window to change various capture 
options on-the-fly during an active capture session. 
 
 
 
 In the Feedback tab (available for Smart Capture - Windows only) and Manual 

Capture): 
 

o In the During Capture area, select / deselect (as needed): 
 Hide Tray Icon 
 Tray Icon Blinks 

 

 
 

o In the Play Sound area, select what sounds to play during the capture 
session, including: 
 On Screen Capture 
 On Background Frame Capture 
 On Key Capture 

 
And, for best “sound alert” performance during your capture session, 
select: 
 
 Use Microsoft DirectSound for Playback 

 

 
 

 In the Mouse tab (available for Smart Capture (Windows only) and Manual 
Capture): 
 
Smart Capture – Mouse Tab Options: (Windows only) 
 

o In the On Mouse Click – Add to Slide area, select: 
 
 Click Here Annotations: To enable ViewletBuilder6.2 Enterprise 

to automatically insert balloons for click instructions during the 
capture session. 
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 Cursor Simulation: To add various cursor animation effects to 
your project, which might include: 
 

 Mouse Click Sound 
 Drag to Here Annotations 
 Mouse Drag Animation 
 Curved Cursor Path 
 Transition Cursors 

 
 Click Zone Assessment: To automatically insert “Click Zones” to 

the project during the capture session. 
 

 Don’t Add Cursor Simulation or Click Zone: To disable all 
cursor simulation or Click Zone additions when clicking your 
mouse during the capture session. 
 

 
 
 

o In the Mouse Timing area, input the number (in seconds) for how long 
you want to “delay” for mouse click captures, to set the double click speed 
and to set the “delay” for drag captures. Options include: 
 
 Delay Before Click 
 Delay After Click 
 Double Click Speed 
 Delay After Drag 
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Manual Capture – Mouse Tab Options: 
 

o In the On Screen Capture – Add to Slide area: 
 
-Select the Cursor Simulation option to capture cursor movement during 
the recording session. And, to achieve more realistic cursor animation, 
select the Curved Cursor Path option. 
 
-Select the Don’t Add Cursor Simulation option if you do NOT want to 
capture cursor movement during the recording session. 
 

 
 

o In the Mouse Click Capture area: 
 
-Select the Mouse Clicks Capture Screenshots option if you want to a 
screenshot capture each time you click you mouse during a recording 
session. 
 
-Select the Include Right Mouse Button option to capture a screenshot 
each time you right click during a recording session. 
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 In the Wheel tab (for Smart Capture - Windows only): 
 

o In the On Mouse Wheel – Add to Slide area, select / deselect mouse 
wheel options for the capture session, including: 
 
 Scroll Wheel Up / Down Annotations 
 Mouse Wheel Simulation 
 Don’t Add Mouse Wheel Simulation 

 

 
 

o In the Wheel Timing area, enter a number for the: 
 
 Wheel Speed (for click per seconds) 
 Delay After Wheel (for capture delay in seconds) 

 

 
 
 

 In the Keyboard tab (for Smart Capture - Windows only): 
 

o In the On Text Entered – Add to Slide area, select: 
 
 Type Text Here Annotations: To enable ViewletBuilder6.2 

Enterprise to automatically add balloon instructions during text 
input in the capture session. 
 

 Typing Simulation: To add typing animation to your project. 
 

 Key Click Sound: To include sound effects with the typing 
animation. 
 

 Text Zone Assessment: To automatically add Text Zones to the 
project during the capture session (where applicable). 
 

 Don’t Add Typing Simulation or Text Zone: To disable all typing 
simulation or Text Zone additions to the project when typing 
during the capture session. 
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o In the On Text Entered – Add to Slide area, click the Modify  button 
next to the Completion Keys field: 
 
 The Completion Keys window displays. The Key list displays the 

keyboard keys that ViewletBuilder6.2 Enterprise will recognize as 
a “completion key” hotkey when text simulation is captured. 
Basically, after typing text, when one of these hotkeys is pressed, 
a new screenshot will be captured. 
 

 Click the Add  button to add a new Completion Key 
to the list. 

 Select a key and click the Delete  button to remove it 
from the list. 

 Select a key and click the Move Up  button to move 
it up in the list. 

 Select a key and click the Move Down  button to 
move it down in the list. 
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 Click OK to close the Completion Keys window. 
 

o In the Keyboard Timing area, enter a number for the: 
 
 Typing Speed (rate of capture in words per minute) 
 Typing Variability (percentage to be used to vary the typing 

effects during playback for the most realistic simulation) 
 Delay After Typing (number of seconds of delay after typing 

simulation is complete) 
 

  
 

 

Set the “Typing Variability” at or close to “0” for a more “robotic” typing simulation effect. 
Set the percentage closer at or close to “100” for a more “natural” and varied typing 
simulation effect. 
 
 
 In the Annotations tab (for Smart Capture - Windows only): 

 
o In the Annotation Language area, use the list to select the language to be 

used if enabling ViewletBuilder6.2 Enterprise to automatically create 
annotations (balloons) during the capture session. 
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o In the “default values” area, you can modify the default values for each of 
the annotations.  
 
For example, the Name column contains the “title of the action to occur” 
in order for the “data” in the Value column to be inserted in an annotation 
(balloon) during the capture session. 
 
To change the “data” (text) that will be inserted in a specific annotation: 
 
 Click the desired field in the Value column. 
 Type in the edits. 
 Press the Enter or Tab key to apply the edits. 

 

 
 

 

Use the “Annotations” list to customize automatic annotations for use during your Smart 
Capture (Windows only) session for all of your Viewlet projects. 
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o In the Modifiers area, select (as needed): 
 
 Prefix Click Annotations with Modifiers: If selected, this will add 

the text “[Ctrl]” or “[Shift]” (when the applicable key is pressed at 
the same time a left mouse click occurs) as a “Modifier” to the 
“Click Here” annotation. 
 

 Separator: Enter the letter to use between the “Modifier” 
and the “Annotation” (Click Here) text. 
 

 Highlight Variables in Bold: If selected, this will bold the variable 
text contained in the annotation. 
 

 
 

 

Customizing “Annotations” is pretty straight-forward once you get comfortable working 
with them. So, if you have any questions with this feature, contact training@qarbon.com 
for help on honing your annotation-authoring skills. 
 
 
 In the Advanced tab (certain options available for Manual Capture where noted): 

 
o In the Frame Rate area (for Smart Capture - Windows only), enter a 

number (Frames per Second) for the rate at which you want to capture 
screenshots during a mouse drag operation. 
 

 
 

 
The higher the number for mouse drag operations, the smoother the resulting animation. 
You can set a frame rate between 1 to 10 frames per second. 
 

o In the Screenshot Delay area (for Smart Capture – Windows only), enter 
a number (in seconds) for the amount of time ViewletBuilder6.2 
Enterprise will delay after a mouse click to take a screenshot. 
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o In the Capture Popups area (available for Smart Capture (Windows only) 
and Manual Capture), select the Capture Popups option to enable 
capture of such elements as tooltips, hints and popup menus. 
 

 
 

o In the Compress During Capture area (Smart Capture – Windows only) 
and Manual Capture), select the Compress During Capture option to 
compress captured images during the capture session. This option is 
useful for larger projects, but will reduce the number of frames that can be 
captured per second during the capture session. 
 

 
 

 
 Once all of the options are selected / edited in the Capture Options window, click 

OK to save the information and to close the window. You will be returned to the 
Create New Project window where you will see the new Capture Profile added to 
the list. 

 
 
To modify an existing Capture Profile: 
 
 Select the desired profile in the list. 

 

 Click the Modify  button.  
 

 The Capture Options window displays. Make your edits to the Capture Mode and 
in the various available tabs as needed. 
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 Click OK to save the edits and to close the Capture Options window. 
 
 
To organize the Capture Profiles in the list: 
 
 Select a profile in the list. 

 

 Click the Move Up  button to move the profile up in the list. 
 

 Click the Move Down  button to move the profile down in the list. 
 
 
To remove a Capture Profile from the list: 
 
 Select the desired profile in the list. 

 

 Click the Delete  button. 
 

 A Warning window will display. Click Yes to confirm the deletion, or click No to 
cancel the deletion. 
 

 
 
 
To select a Capture Profile to use for the screen capture session: 
 
 Click on a profile to highlight it to select it. This will be the profile that will be used 

during your capture session. 
 

3. Setting up the Screens Capture Session 
For the most part, each screen capture session starts the same way. After selecting a 
Capture Profile to use for the capture session, you click OK to start the actual recording 
session. But, did you know that after you click OK, what happens next depends on the 
selection made for the project’s slide size? 
 
This section focuses on what to expect and instructions for what you will need to do 
“right before” you actually start capturing screenshots (if applicable). 
 
Before “setting” the capture area, you can “back out” by pressing the Esc key.  
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To set up your capture session: 
 
 After selecting the Capture Profile to use for your capture session, click OK. The 

ViewletBuilder6.2 Enterprise GUI will hide in the background until the end of the 
capture session. 
 

 If you selected (for the project’s “Slide Size”): 
 

o Custom – Specify a custom height and width. 
 

 
 
Before beginning the capture session, a “bounding box” (dotted rectangle) 
will display on your screen in the size you specified when selecting a 
width and height for your project. This box denotes the capture area. 
Everything inside this box will be included in the screenshot. 
 
 To move the capture area, point your cursor over the bounding 

box. When the cursor changes to a “hand shape”  , hold 
down the left mouse button and drag to move the capture area to 
the desired location on your screen. 
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 To resize the capture area (if needed), point your cursor over one 
of the gnodes (grab handles) along the edge of the bounding box. 
Hold down your left mouse button and drag to resize.  
 

 
If you are using a “Custom” slide size for your project, do not resize the capture area 
unless absolutely necessary since the capture area dimensions (width and height) will 
become the slide size of your project. 
 

 To “set” the capture area, mouse your cursor inside the capture 
area and double click to set its size and position. (You are now 
ready to take screenshots.) 
 

o Standards – Select a standard window size. 
 

 
 
Before beginning the capture session, a “bounding box” (dotted rectangle) 
will display on your screen in the size you specified when selecting a 
width and height for your project. This box denotes the capture area. 
Everything inside this box will be included in the screenshot. 
 
 To move the capture area, point your cursor over the bounding 

box. When the cursor changes to a “hand shape”  , hold 
down the left mouse button and drag to move the capture area to 
the desired location on your screen. 
 

 To resize the capture area (if needed), point your cursor over one 
of the gnodes (grab handles) along the edge of the bounding box. 
Hold down your left mouse button and drag to resize. 
 

 To “set” the capture area, mouse your cursor inside the capture 
area and double click to set its size and position. (You are now 
ready to take screenshots.) 
 

o Application – Capture a running application window. 
 

 
 
The selected program or operating system window will launch on top of 
all other open windows on your computer’s screen and the screen 
capture session begins.  
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This “active” window, surrounded by a “bounding box” (dotted rectangle), 
indicates the capture area. Everything in the capture area (in this 
example, the “active” window) will be included in the screenshot. 

 
If you select “Application” for the slide size AND are using “Smart Capture” (Windows 
only) mode, right after you click “OK”, the selected program or operating system window 
will display on top of all other items on your screen and the automatic screen capture 
session will IMMEDIATELY begin. 
 
 

o Area – Capture an area of the screen. 
 

 
 

Before the capture session, the cursor changes to a “cross hair”  
shape. This means before the capture session can start, you must define 
the capture area. To do this:  
 
 Point the “cross hair” cursor to the point on the screen where you 

want to start drawing your capture area. 
 

 Hold down the left mouse button and drag to draw the capture 
area. As you drag the cursor, a “bounding box” (dotted rectangle) 
will start to form. This is the capture area. Everything inside the 
capture area will be included in the screenshot. 
 

 
 
 
 Let go of the left mouse button to “set” the capture area’s size and 

position. (You are now ready to take screenshots.) 



 
 
 

VB6.2 Enterprise User Manual Page 52 February 2010 

o Window – Select a window to capture. 
 

 
 
This option allows you to select an entire window (just like the “Active” 
slide size option) or a portion of an open window. The trick here is that 
you MUST have the window open (not minimized) BEFORE you click OK 
to set up the screen capture session. To do this: 
 
 Make sure the window you want to capture is open on your 

computer screen (underneath the ViewletBuilder6.2 Enterprise 
program) and all other program and operating system windows 
are closed or minimized. 
 

 Click OK to start the capture session. 
 

 A “red box” will display over the window that is displayed on your 
computer screen. Move the cursor around the window until the 
“red box” outlines the entire window (to capture the entire window) 
or a portion of the window (to capture a sub-section of the 
window). 
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 To “set” the capture area, double click inside the “red box”. The 
“red box” will change to a “Bounding Box” indicating that the 
capture area is set. (You are now ready to take screenshots.) 
 

 
 
 

 
o Full Screen – Capture the entire screen. 

 

 
 
When using the “Full Screen” slide size option, if you select a “screen 
resolution” different then what your monitor is set to when starting the 
screen capture session, after you click OK to start the capture session, 
ViewletBuilder6.2 Enterprise will automatically adjust your monitor’s 
resolution to what you selected for the slide size and, the screenshot 
capture session begins. 

 
If you select “Full Screen” for the project’s slide size AND are using “Smart Capture” 
(Windows only) mode, ViewletBuilder6.2 Enterprise will automatically adjust your 
monitor’s resolution (based on your selection) and IMMEDIATELY start the automatic 
capture session. If the selected “screen resolution” for the slide size is the same as your 
monitor’s resolution, no adjustments will be made and the automatic capture session will 
begin IMMEDIATELY after you click “OK” to begin the screenshot session. 
 

Everything visible on your screen will be included in the screenshots. 
Once the capture session is ended, the monitor’s resolution will return 
back to its settings prior to taking screenshots. 
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4. Capturing Screenshots (Smart Capture (Windows only) vs. Manual 
Capture) 
Once you’ve determined the slide size for your Screen Capture Project, have selected a 
Capture Profile to use during the capture session, click OK to begin the capture session, 
and (if applicable) “set up” the capture area—the screen capture session is “live”. At this 
point, depending on the capture mode you are using (Smart Capture (Windows only) or 
Manual Capture), you can start taking screenshots. 
 
To begin the capture session, if the capture mode you are using is: 
 
 Smart Capture (Windows only): Once the capture session is “live”, 

ViewletBuilder6.2 Enterprise will automatically start taking screenshots (based on 
the selections made in the Capture Profile you are using). Each time a 
screenshot is taken, you will hear a camera shutter sound (if the On Screen 
Capture option in the Feedback tab is selected). 
 

 Manual Capture: Once the capture session is “live”, use the Capture 
Screenshot hotkey to capture screenshots manually. 

 
 
To capture an “extra” animation during a Smart Capture (Windows only) session: 
 
 While a Smart Capture (Windows only) session is running, click the Capture 

Background Frame hotkey to manually capture any “extra” animation that 
displays on your screen that you think Smart Capture (Windows only) might not 
capture. 
 

 
To pause and resume a capture session, if the capture mode you are using is: 
 
 Smart Capture (Windows only): Click the Pause hotkey to temporarily pause the 

Smart Capture (Windows only) session without ending it. The Capture Status 
window will display (over the system tray). To resume the Smart Capture 
(Windows only) session, click the Continue button. 
 

 Manual Capture: Click the Pause hotkey to temporarily pause the Manual 
Capture session without ending it. The Capture Status window will display (over 
the system tray). To resume the Manual Capture session, click the Continue 
button. 
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Another way to temporarily “pause” a capture session is by pointing your mouse over the 
system tray and clicking on the ViewletBuilder6.2 Enterprise icon to display the “Capture 
Status” window. 
 
To switch between Smart Capture (Windows only) and Manual Capture modes during a 
capture session: 
 
 Click the Pause hotkey to temporarily pause the capture session. 

 
 The Capture Status window displays. Click the More button to expand the 

options available in the Capture Status window. 
 

 
 

 Select the desired Capture Mode from the list (at the top of the Capture Status 
window). 
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 Click Continue to resume the capture session, using the newly selected capture 
mode. 

 
 
To modify capture options during a “live” capture session: 
 
 Click the Pause hotkey to temporarily pause the capture session. 

 
 The Capture Status window displays. Click the More button to expand the 

window. 
 

 Select the desired Capture Mode from the list. 
 

 Select the applicable tab(s) and modify selections as needed. 
 

 Click the Less    button to collapse the Capture Status window. 
 

 Click the Continue button to resume the capture session using the modified 
capture settings. 

 
Be careful when modifying capture options “on-the-fly” during a live capture session. Any 
changes made in the “Capture Status” window will be updated in the selected “Capture 
Profile” being used for that capture session. 
 

5. Ending or Canceling the Screen Capture Session 
The last step to create a new Screen Capture Project is converting the screenshots 
taken during the capture session to the slides that will make up your new Viewlet project. 
To do this you must use the Stop Capture hotkey, or click the Stop button in the 
Capture Status window to properly end the “live” capture session. 
 
Ending a Capture Session 
To end a capture session using the Stop Capture hotkey: 
 Once all of your screenshots are captured, press the Stop Capture hotkey. This 

will end your capture session. 
 

 A progress bar may display briefly as the screenshots are converted to slides. 
Once complete, the new Screen Capture Project is displayed in 
ViewletBuilder6.2 Enterprise, ready for editing. 
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If using Smart Capture (Windows only) for your screen capture session, use the “Stop 
Capture” hotkey to end the “live” capture session (instead of clicking the “Cancel” button) 
to avoid unwanted screen captures or cursor animations being added at the end of the 
project. 
 
 
To end a capture session from the Capture Status window: 
 Once all of your screenshots are captured, move your mouse over the system 

tray where you will see a ViewletBuilder6.2 Enterprise  icon displayed. 
 

 Click the ViewletBuilder6.2 Enterprise icon. 
 

 The Capture Status window displays. Click the Stop button. 
 

 
 

 Depending on the number of screenshots captured, a progress bar may display 
briefly as the screenshots are converted to slides. Once complete, the new 
Screen Capture Project is displayed in ViewletBuilder6.2 Enterprise, ready for 
editing. 

 
 
 
Canceling a Capture Session 
You can “back out” of any “live” capture session by using the Cancel Capture hotkey. 
Or, click the Cancel button in the Capture Status window. When you cancel, this will end 
the active capture session without saving any screenshots. You will be returned to 
ViewletBuilder6.2 Enterprise’s “Start View” to start anew. 
 
To back out of a capture session using the Cancel Capture hotkey: 
 
 Click the Cancel Capture hotkey. This will end the active capture session. 

 
 No screenshots will be saved and you will be returned to the “Start View” of 

ViewletBuilder6.2 Enterprise. 
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To back out of a capture session from the Capture Status window: 
 
 Move your mouse over the system tray. 

 

 Click the ViewletBuilder6.2 Enterprise  icon that displays. 
 

 The Capture Status window displays. Click the Cancel button. 
 

 
 

 This will end the capture session and no screenshots will be saved. You will be 
returned to the “Start View” of ViewletBuilder6.2 Enterprise where you can start 
again. 

 
 
To change capture options during a “live” capture session: 
 
 Move your mouse over the system tray. 

 

 Click the ViewletBuilder6.2 Enterprise  icon that displays. 
 

 The Capture Status window displays. Click the More button. 
 

 The Capture Status window expands, allowing you access to the capture modes 
and related capture mode tabs. Make your changes as desired. 
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 Click the Less button once all of your changes are made to hide the Capture 
Status window. 
 

 Click Continue, Stop or Cancel as needed. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Mac Screen Capture Project - Key Points 
The previous chapter, Screen Capture Project, contains instructions and graphic 
examples developed while using ViewletBuilder6.2 for Windows. The essential authoring 
information, however, also pertains to ViewletBuilder6.2 for Mac.  
 
Currently, ViewletBuilder6.2 for Mac does not support Smart Capture. This capture 
mode is planned for a future release. When capturing screenshots, Manual Capture 
mode is available. 
 
In ViewletBuilder6.2 for Mac, in the New Project window, various capture profiles are 
available when creating a new Screen Capture Project. By default, these may include: 
 
 Manual Capture 
 Manual Capture with Mouse Click Capture 
 Simple 
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When creating a new Screen Capture project, you select a Capture Profile to use during 
your capture session. A Capture Profile is a way to organize all “capture options” chosen 
for a screenshot recording session into one place or “profile”. For more information, 
please review the section on Capture Profiles covered earlier in this guide. 
 
Manual Capture is the capture mode available for new Screen Capture projects in 
ViewletBuilder6.2 Enterprise for Mac. When creating or editing a Capture Profile, the 
Capture Options window displays. In this window, there are four tabs available with 
various options that you can select and store in your Capture Profile for your screenshot 
session. The Capture Options window includes these tabs: 
 
General tab Feedback tab 
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Mouse tab Advanced tab 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
For information on creating a new Screen Capture project and working with the various 
Capture Profile selections in the Capture Options window, please read the chapter 
Screen Capture Project, which covered these topics earlier in this guide. 
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Image Project 
ViewletBuilder6.2 Enterprise allows you to create a new project from one or more 
images on your system or from an available storage device. You can use images of 
different file formats and of varying sizes, combining them all into a single, standard size 
Viewlet project.  
 
Imported images are embedded on slides (one image per slide) as background frames. 
This chapter highlights the steps for creating a new Image Project. 
 

1. Select the Project Type and Slide Size 
 Select File > New from the menu option. Or, in Start View, click the New Project 

link, or click the New button from the Main Toolbar. 
 

 The Create New Project window displays. Select Image Project from the New 
Project list. Additional options for creating a new image project will display in this 
window. 
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 In the Slide Size area of the Create New Project window, select a width and 
height for your Viewlet project. 

 
For more information on selecting a New Project Type or selecting a Slide Size for your 
new Viewlet project, please refer to the Creating a New Project Basics chapter. 
 

2. Select Images 
Once the project type and slide size are selected for your new project, the next step is to 
select the image or images that will make up your new Image Project. Here’s a list of the 
various formats supported by ViewletBuilder6.2 Enterprise: 
 
 GIF: Graphics Interchange Format 
 JPG, JPEG: Joint Photographic Experts Group 
 PNG: Portable Network Graphics 
 BMP: Bitmap 
 TIF, TIFF: Tagged Image File Format 

 

Animated GIF images are not supported in ViewletBuilder6.2 Enterprise. If you import an 
animated GIF image into a project, it will display as a “static” image, showing the image’s 
first frame only. 

 
To select images for your new project: 
 
 In the Select Images area, click the Add button to search for image files. 

 

 
 

 In the Select Images File window that displays, select the files you want to 
import. 
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To select multiple image files, hold down the “Shift” key and click on the first and last file 
in a sequence to select all the files in the sequence, or hold down the “Ctrl” as you click to 
select multiple, non-adjacent files 
 
 
 After selecting the image files, click Open. Depending on the number and size of 

the image files selected, you may see a progress bar display on the screen 
indicating the status of the image files being imported into the Create New 
Project window. 
 

 
 

3. Preview and Select “Pre-Import” Image Options 
In the Select Images area (Create New Project window), the newly selected images 
display in a list. Before importing these images into a new project, you can preview each 
image, select its scaling option for the slide, change its position on the list and more. 
Let’s take a look at each of these options. 
 
To preview an image in the preview panel: 
 
 Click on the image in the list that you want to preview. 
 The selected image displays in the preview panel to the “right” of the list. While 

the image is displayed in the preview panel: 
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o Click the Rotate Left   button to rotate the image to the left. 
 

o Click the Rotate Right   button to rotate the image to the right. 
 

 
If you rotate the image prior to importing it into a new project, this is the “orientation” that 
will be used when it is embedded as a background frame on its applicable slide. 
 
 

o Below the “rotate buttons” view the selected image’s file Size and 
Dimensions. 

 
 
To add a new image to the list: 
 

 Click the Add  button. 
 

 In the Select Image Files window that displays, browse for and select the image 
files you want to import. 
 

 Click Open.  The newly selected images will be added at the bottom of the list. 
 
 
To move an image up or down in the list: 
 
 Select the desired image. 

 

 Click the Move Up  button. Each time you click this button, it will move the 
selected image one position “up” in the list. 
 

 Click the Move Down  button. Each time you click this button, it will move 
the selected image one position “down” in the list. 

 
 

The position of the images in the list determines their “slide” position in the project. The 
image at the “top” of the list will be converted to “slide 1”, the second from the top will 
become “slide 2” and so on down the list. 
 
 



 
 
 

VB6.2 Enterprise User Manual Page 67 February 2010 

To remove an image from the list: 
 
 Select the desired image. 

 

 Click the Delete  button. This will remove the image from the list only. It will 
NOT delete the original image file. 

 
 
To modify the “size” of the image prior to importing it into a project: 
 
 Select the desired image from the list. 

 
 Preview the Dimensions of the image below the “rotation buttons”. If the image 

width and height is: 
 

o Larger than the project’s slide size, you don’t need to do anything. The 
image will fill the entire background frame of the slide. 
 

o Smaller than the project’s slide size: 
 

 
 
-Click the check box in the Stretch column next to the desired image. This 
will scale (stretch) the image to fill the slide proportionally. What this 
means is that it will scale it to “best fit” the slide, so the image may not fill 
the entire slide. 
 
-Deselect the check box in the Stretch column next to the desired image. 
The image will remain its original size and be embedded as the 
background frame in the middle of the slide. 
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4. Convert Images Files to Slides 
Here are the last steps to perform in order to create your new Image Project: 
 
 In the Slide Size area, make sure the slide size you selected for your new project 

is the one you actually want to use. Though the slide size can be change after 
creating the project, it’s easier to select the proper size right at the beginning. 
 

 In the Select Images area: 
 

o Review the images list and make sure you have all the images you want 
listed. 
 

o Make sure the images are listed in the order you want the slides to be 
created. Though you can rearrange slides once the project is created, it 
will save you a lot of work to list them in desired order right at the start. 
 

o Rotate any images as needed. 
 

o Select the check box in the Stretch column next to any images you want 
to “stretch” to fit the slide (only applicable to images smaller then the 
project’s slide size). 
 

o Delete any images you do NOT want to include in your new project. 
 

 Once all your selections are complete, click OK to convert the images to slide 
background frames in your new Image Project. 
 

If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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PowerPoint Project 
ViewletBuilder6.2 Enterprise allows you to create a new project by directly importing 
slides from a Microsoft PowerPoint (.ppt) file while in the Create New Project window. 
This chapter walks through the steps for creating a new PowerPoint Project. 
 

1. Select the Project Type and Slide Size 
 Select File > New from the menu option. Or, in Start View, click the New Project 

link, or click the New button from the Main Toolbar. 
 

 The Create New Project window displays. Select PowerPoint Project from the 
New Project list. Additional options for creating a new PowerPoint project will 
display in this window. 

 

 
 
 In the Slide Size area of the Create New Project window, select a width and 

height for your Viewlet project. 
 
For more information on selecting a New Project Type or selecting a Slide Size for your 
new Viewlet project, please refer to the Creating a New Project Basics chapter. 
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2. Select the PowerPoint (.ppt) File 
Once you’ve selected the slide size for your new project, it’s time to browse for and 
select the PowerPoint presentation you want to covert to a Viewlet project. To do this: 
 
 In the Presentation area (Create New Project) window, click the Load PPT file 

button. 
 

 
 

 In the Open PowerPoint Presentation window, browse for and select the 
presentation file. 
 

 Click Open. You will be returned to the Create New Project window where you 
will see the presentation file listed in the Presentation area field. 
 

 
 

 

3. Preview and Select “Pre-Import” PowerPoint Slides Options 
In the Slides area (Create New Project area), the selected PowerPoint presentation 
slides display in a list. At this point, you can preview the slides one at a time, make final 
determinations which slides to import into your project, and select additional importing 
options. Let’s take a look at each. 
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To select / deselect the PowerPoint slides to import into your new Viewlet project: 
 
 Select the check box (to place a checkmark) next to each of the slides you want 

to include in your new project. 
 

 Deselect the check box (to remove the checkmark) next to each of the slides you 
do NOT want to include in your new project. 
 

 
To preview a slide prior to importing it into your new project: 
 
 Select the desired slide from the list. 

 
 In the Preview Pane (to the right of the list), preview the selected slide. 

 
 Follow these steps to preview each of the slides in the list. 

 
To select all or select none of the slides in the import list: 
(New in ViewletBuilder6.2 Enterprise) 
 
 To select all of the slides in the import list, click the Select All button. 
 To deselect all of the slides in the import list, click the Select None button. 
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To select additional “pre-import” options for your PowerPoint slides: 
 

 Click the Options  button. 
 

 The PowerPoint Options window displays. There are two tabs available: General 
and Fonts. Select the desired tab for additional options. 
 

 
 

 
General Tab 
 Select the General tab. The General tab contains options for setting slide 

durations for your new project and a Pause Zone to each slide. 
 

o In the Slide Duration area (General tab), enter a number in the field 
provided for the amount of time to display the slide in your new project. 
This will be the “baseline” slide duration for each of the slides in your 
Viewlet project. 
 

 
 

o In the Options area (General tab): 
 
 Select the Add pause to the slides to add a Pause Zone to each 

of the slides in your new project. 
 

 Deselect the Add pause to the slides if you do NOT want a 
Pause Zone added to each of the slides in your new project. 
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Fonts Tab 
 Select the Fonts tab. 

 
The Fonts tab allows you to select additional fonts for ViewletBuilder6.2 
Enterprise to use if the font used in the imported PowerPoint Presentation is not 
available for use on your system (or from within ViewletBuilder6.2 Enterprise). 
 

 
 
To select an alternate font from the list of available fonts: 
 

o Select the desired font from the Available Fonts list (on the left side of the 
Fonts tab). 
 

o Click the Add  button to add the selected font from the Available 
fonts to the list of Alternate fonts (on the right side of the Fonts tab).  
 

o Repeat the previous steps for each available font you want to add to the 
Alternate fonts list. 
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To move a font up or down in the Alternate fonts list: 
 

o Select the desired font you want to move in the Alternate fonts list. 
 

o Click the Move Up  button to move the font up in the list. Repeat as 
needed to continue moving the font up in the list. 
 

o Click the Move Down  button to move the font down in the list. 
Repeat as needed to continue moving the font down in the list. 

 
 
The order (top to bottom) of fonts in the Alternate fonts list is important. If 
ViewletBuilder6.2 Enterprise needs to use an alternate font for your project, it will start 
with the first one (top) in the list. 
 

 
To remove a font from the Alternate fonts list: 
 

o Select the desired font you want to remove from the Alternate fonts list. 
 

o Click the Delete    button. This action will remove the selected font 
from the Alternates fonts list only. 

 
 Once all options are selected in the PowerPoint Options window, click OK to 

save the information and to return to the previous window. 
 
 

4. Convert the PowerPoint Presentation to Viewlet Project Slides 
Here are the last steps to perform in order to create your new PowerPoint Project: 
 
 In the Slide Size area, make sure the slide size you selected for your new project 

is the one you actually want to use. Though the slide size can be change after 
creating the project, it’s easier to select the proper size right at the beginning. 
 

 In the Presentation area, review the PowerPoint file name to make sure it is the 
one you want to convert. 
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 In the Slides area: 
 

o Review the list of PowerPoint slides and select each of the slides you 
want to preview in the Preview Pane. 
 

o Select / deselect the check box next to each of the slides you want to 
include / not include in your new PowerPoint Project. 
 

o Click the Options button and review / modify choices in the PowerPoint 
Options window in both the General and Fonts tabs. 
 

 Once all your selections are complete, click OK to convert the selected 
PowerPoint slides to slide background frames in your new PowerPoint Project. 
 

 While the PowerPoint slides are being converted, you may see a Loading 
PowerPoint File window display as the new project slides are loading. Once the 
conversion is complete, your new PowerPoint Project displays and is ready for 
editing. 
 

 
 
 

If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Quiz Project 
 
The new Quiz Project type allows you to integrate scored slides and simple survey 
question slides into a single Viewlet project. Or, if you prefer, use the Quiz Project to 
create an entire quiz project (for testing purposes) or an entire survey project (for 
gathering information from a user base). 
 
When reviewing the Question Types (later in this chapter), check out the two new (Drag & 
Drop and Click Map) question types available for Quiz Projects. 
 
This chapter explains the steps for creating a Quiz Project (with scored and/or non-
scored question types). It also provides an overview of the various question types 
available for your Quiz Project. 
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1. Select the Project Type and Slide Size 
 Select File > New from the menu option. Or, in Start View, click the New Project 

link, or click the New button from the Main Toolbar. 
 

 The Create New Project window displays. Select Quiz Project from the New 
Project list. Additional options for creating a new Quiz Project will display in this 
window. 
 

 In the Slide Size area of the Create New Project window, select a width and 
height for your Viewlet project. 

 
For more information on selecting a New Project Type or selecting a Slide Size for your 
new Viewlet project, please refer to the Creating a New Project Basics chapter. 
 
 

2. Review Question Types 
(New Drag & Drop and Click Map Question Types in ViewletBuiler6.2 Enterprise) 
 
There are several common question types available for your Quiz Project. These 
question types can be scored or not, depending upon how you want to use them. The 
option to set a question type as a “quiz question” (scored) or a “survey question” (not 
scored) is covered later in this chapter. For now, let’s take a look at each of these 
question types. 
 

Short Answer – Fill in the Blank 
This question type requires the user to fill in the blank with a single answer. 
 

 
 

Short Answer – Selection from List 
This question type requires the user to select a single answer from a list. 
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Short Answer – Rating 
This question type requires the user to select a single rating from a given scale. 
 

 
 

Short Answer – Essay 
This question type allows the user to type in one or more words, sentences or 
paragraphs (essay style) to respond. 
 

 
 

Multiple Choice – Single Answer 
This question type requires the user to select a single answer from a list with two or 
more choices. 
 

 
 

Multiple Choice – Multiple Answers 
This question type requires the user to select a single or multiple answers from a list with 
two or more choices. 
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Multiple Choice – Fill in the Blanks 
This question type requires the user to type in a response in one or more “fill in the 
blank” entry fields. 
 

 
 

Multiple Choice – Selection from Lists 
This question type requires the user to select an answer from one or more lists. 
 

  
 

Multiple Choice – Rating 
This question type requires the user to select one or more ratings from a single or 
multiple rating scales. 
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Multiple Choice – True/False 
This question type requires the user to select an answer from one of only two possible 
choices. 
 

 
 

Likert Scale 
This question type requires the user to select an answer based on their specific level of 
agreement to a specific statement. 
 

 
 

Drag and Drop 
(New in ViewletBuilder6.2 Enterprise) 
 
This question type requires the user to match up items by dragging their response(s) 
across columns. 
 

 
 
Check out the New Quiz Project Question Types chapter for more information on 
working with Drag and Drop Question Types. 
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Click Map 
(New in ViewletBuilder6.2 Enterprise) 
 
This question type requires the user to click on one or more areas of the screen in order 
to respond. 
 

 
 
Check out the New Quiz Project Question Types chapter for more information on 
working with Click Map Question Types. 
 
Many of these question types can be used in quizzes or in surveys; the choice is up to 
you. 
 
 
A quiz requires a correct response (and is typically scored), whereas a survey does not 
require a correct response (and is not scored). 
 

3. Select Quiz Questions 
Make sure before you begin adding questions for your Quiz Project that you review the 
previous section so that you understand the different question types available for your 
project. This will help you determine what questions will work best for you. Once you feel 
comfortable with the various question types, you are ready to start building a list of 
questions for your project. 
 
To create a new question for your project: 

 In the Quiz Questions area (Create New Project window), click the Add  
button. 
 

 The Question window displays. Click on a question in the Question Type list to 
select it. 
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 Type a question in the field provided. 
 

 
 

 In the Scoring Mode area, select either Quiz or Survey. 
 

 
 

 
If you want to quiz a user, but do NOT want to score the questions, select “Quiz: Scored – 
Requires the user to provide a correct answer” for the “Scoring Mode”. Then, when you 
edit your project, in the “Score” window, set the “Points” value to “zero”. This way, the 
user will be required to answer correctly, but no score will be applied. 
 
 
 Click OK to apply and to close the Question window. The new question will 

display in the Quiz Questions list. 
 

 Repeat these steps for each additional question you want to create for your 
project. 
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To edit a question in the list: 
 
 Select the desired question in the list. 

 

 Click the Modify  button. 
 

 Make your edits in the Question window that displays. 
 

 Click OK to apply the changes and to close the Question window. 
 
 
To move a question up or down in the list: 
 
 Select the desired question in the list. 

 

 Click the Move Up  button to move the question up in the list. Repeat this 
step to continue moving the selected question up in the list. 
 

 Click the Move Down  button to move the question down in the list. Repeat 
this step to continue moving the selected question down in the list. 

 
 
The position of questions in the list determines the order in which they will appear in the 
project. For example, the question at the top of the list will become slide 1 in the project, 
the second from the top will become slide 2 and so on. You can reorganize your slides 
once your project is created, but to save time, organize the list of questions as needed 
BEFORE creating your new Quiz Project. 
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To remove a question from the list: 
 
 Select the desired question in the list. 

 

 Click the Delete  button. This will remove the selected question from the 
list. 

 

Be careful when deleting questions from the list. Once you delete them, you cannot 
“Undo” the deletion. Once deleted, the question must be recreated if you need to add it 
back to the list. 
 
 

4. Convert Questions to Slides 
Here are the last steps to perform to create your new Quiz Project: 
 
 In the Slide Size area, make sure the slide size you selected for your new project 

is the one you actually want to use. Though the slide size can be change after 
creating the project, it’s easier to select the proper size right at the beginning. 
 

 In the Quiz Questions area: 
 

o Review the list of questions and make sure they are in the order you want 
them to be when your new project is created. 
 

o Modify any of the questions as needed. 
 

o Delete any extra questions from the list so that unnecessary slides are 
not created. 

 
 Once all of your selections are made and questions created, click OK. This will 

converts the questions in the list to slides. Once this operation is complete, your 
project will display, ready for editing. 

 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Blank Project 
ViewletBuilder6.2 offers you the option of creating a new Blank Project containing one or 
more blank slides. This new project type is perfect for those not sure of what new project 
type to use or for those wanting to create a new project from scratch using a blank 
template. 
 

1. Select the Project Type and Slide Size 
 Select File > New from the menu option. Or, in Start View, click the New Project 

link, or click the New button from the Main Toolbar.  
 

 The Create New Project window displays. Select Blank Project from the New 
Project list. Additional options for creating a new Blank project will display in this 
window. 

 

 
 
 In the Slide Size area of the Create New Project window, select a width and 

height for your Viewlet project. 
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For more information on selecting a New Project Type or selecting a Slide Size for your 
new Viewlet project, please refer to the Creating a New Project Basics chapter. 
 

2. Select the Number of Slides 
Once you have set the options for the size of the slides for your new Blank Project, the 
next step is to decide the number of slides you would like to create for your new project. 
 
 In the Slide Count area, enter the number of slides you want to create for your 

new project in the field provided. 
 

o Click the Up Arrow  button to increase the number of slides. 
o Click the Down Arrow  button to decrease the number of slides. 

 

You may select from 1 to 999 slides for your new Blank Project. 
 
 
 

3. Create Blank Slides 
Here are the last steps to perform to create your new Blank Project: 
 
 In the Slide Size area, make sure the slide size you selected for your new project 

is the one you actually want to use. Though the slide size can be change after 
creating the project, it’s easier to select the proper size right at the beginning. 
 

 In the Slide Count area, make sure that the number you entered is the actual 
number of slides you want to initially use for the number of slides in your new 
Blank Project. 
 

 Click OK. The slides for your new project will display in ViewletBuilder6.2, ready 
for editing. 

 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
 



 
 
 

VB6.2 Enterprise User Manual Page 87 February 2010 

Workspace Features and Tab Views 
While working on a project in ViewletBuilder6.2 Enterprise, there are various 
“workspace” features and views available to help you optimize your Viewlet authoring 
tasks. This chapter provides a look at: 
 
 The View Menu – At a Glance 
 Organizing Tab Views and Workspace Areas 

 

The View Menu – At a Glance 
 

 
 
The View menu is divided into three main sections, with selections for use while working 
in your project. These include: 
 
 Slide Zoom: This section contains various slide zoom options to use while 

working on your project, including Zoom In, Zoom Out, Fit to Slide and various 
percentage zooms. 
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 Miscellaneous Tools: This section contains selections to enable / disable tools 
such as: 
 

o ToolTips: Displays a “hint” near the button the cursor hovers over. 
  

 
 
 

o Cursor Path: Displays a “dotted” line between cursors, indicating the path 
the cursor will travel from the current slide to the next slide. 
 

 
 

o Spelling Mistakes: Displays a “red underline” under words that are not 
recognized by the dictionary. 
 

 
 

o Event Icons: Displays a “lightning bolt” over objects that have an “event” 
attached to them. 
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o Attached Sound Icons: Displays a “speaker” near objects that have a 
sound file attached. 
 

 
 

o PauseZone Icons: Displays a “red icon” in the bottom right of a slide that 
contains a Pause Zone. This “red icon” will not display in the published 
Viewlet. 
 

 
 

o Timing Links: Displays a link connecting two or more objects along the 
Timeline. 
 

 
 

o Pair Links: (New in ViewletBuilder6.2 Enterprise) 
Displays a link between the Drag Choice and the Drop Area in a Drag and 
Drop question type.  
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o Status Bar: Displays at the bottom of the program window and displays 
various information about the project. 
 

 
 

 Tab Views: This section contains options called “Tab Views”. Each view can be 
displayed or hidden as desired and are used for specific operations. The list of 
Tab Views include: 
 

o Browser 
o Thumbnails 
o Stylesheets 
o Output 
o Timeline 
o Slide Notes 

 
Each of these Tab Views are discussed later in this manual, each in their own 
respective chapter. 
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Organizing Tab Views and Workspace Areas 
The project workspace area, by default, displays selected Tab Views to the left and 
below the slide edit area. The workspace can be reorganized as desired based on your 
authoring needs. 
 
To display / hide a Tab View from the View Menu: 
 Select View from the Menu bar. 
 To display a Tab View, select it from the list. When selected, a checkmark will 

display next to it. 
 To hide a Tab View, deselect it from the list to remove the checkmark next to it.  

 
By default, when first selected, the “Browser”, “Thumbnails” and “Stylesheets” Tab Views 
display to the left of the slide edit area. The “Output”, “Timeline” and “Slide Notes” Tab 
Views display below the slide edit area. 
 
 
Each Tab View contains buttons to expand or minimize / maximize the tab(s): 
 Select the Expand  button to expand the tab to full view. 
 Select the Minimize  button to minimize all active tabs. 
 Select the Maximize  button to restore all active tabs to their previous sizes. 
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To move between active Tab Views: 
 If multiple tabs are displayed, only one tab can be in view at a given time. Click 

on the tab you want to work on to bring it to the front of the active tabs. 
 Repeat this action to move between tabs. 

 
 
To close (hide) an active Tab View: 
 Select the desired tab to bring it to the front of the tabs. 
 Click the “X”    located at the right edge of the selected tab. This will close 

(hide) the Tab View, which must be reselected from the View menu to be 
displayed again. 

 

Instead of closing (hiding) a Tab View, click the “Minimize” button to neatly collapse it to 
the side (or bottom) of the workspace area. This way, it is out of the way, but can be easily 
accessed again when needed while working on the project. 
 
To move a Tab View from its default position: 
 Point your left mouse button over the desired Tab View. 
 Hold down your left mouse button and drag the Tab to the bottom or “opposite 

side” of the project workspace area. 
 When the area to where you are dragging the Tab View is surrounded by a 

“dotted rectangle”, let go of the left mouse button to drop it into place. 
 
If you move a Tab View to a new location on the screen, if you then close and reopen it, 
the Tab View will display in its last “remembered” location on the screen. 
 
 
To resize the “window area” of a Tab View: 
 Point your cursor over the right / left / top edge (whichever is applicable) until the 

cursor shape changes to a double arrow  shape.  
 Hold down the left mouse button and drag the edge of the Tab View window to 

resize it. 
 Let go of the left mouse button when done. 

 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Slide Edit Area and Zoom Tools 
In ViewletBuilder6.2 Enterprise, when a project is open, the workspace area consists of 
various toolbars, Tab Views and the traditional “Slide Edit” area. The Slide Edit area is 
where you directly add objects to a slide and edit them. This is also the areas where you 
will spend a majority of your time while working on your Viewlet project. 
 
As discussed in the previous chapter, when selected, Tab Views display (by default) to 
the left and below the Slide Edit area. These tabs can be minimized, repositioned or 
closed to allow more “working real estate” on the slide. When a Tab View is “maximized” 
the Slide Edit area is hidden from view until the active tab is resized, minimized or 
maximized. 
 

Zoom Tools 
While working on a slide, there may be times you want to zoom in or out on the slide. 
This can be done using the options from the View Menu or by clicking any of three 
“zoom” buttons along the Main Toolbar. 
 
To change the slide zoom level from the View Menu: 
 Select the desired slide. 
 Select View > Slide Zoom from the Menu bar. 
 Select the desired slide zoom from the available options. 
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To change the slide zoom using the zoom button on the Main Toolbar: 
 
 Select the desired slide. 

 

 Click the Zoom In  button to zoom in on a slide. 
 

 Click the Zoom Out  button to zoom out on a slide. 
 

 Click the Fit Slide  button to zoom the slide to fit to the size of the current 
Slide Edit area. 

 

Keep clicking the Zoom In or the Zoom Out button to continue zooming in or zooming out 
as desired on the selected slide. 
 
Other tasks, such as adding message objects, images, shapes, tweaking cursor 
animation, etc. will vary depending on the content of each project. These additional tasks 
performed in the Slide Edit area are covered in further detail throughout this user 
manual. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Browser Tab 
The Browser Tab allows you to easily organize access and manage the resources that 
are available to you while you author your Viewlets. You can open projects, drag and 
drop images and movies, add publishing targets, delete files or folders, and view 
statistics of your Viewlets published on ViewletCentral. This chapter highlights some of 
the features of the Browser Tab. 
 
To display the Browser Tab: 
 Select View from the Menu bar. 
 Select Browser. 

 

 
 
 
The Browser Tab contains a “tab” at the top of its window area with the title of “Browser” 
indicating what tab it is. A toolbar displays below the tab’s title with buttons applicable to 
tools available in this tab. 
 
To add a new “publishing target” from the Browser Tab: 
 
 Select the Browser Tab to make it the active tab. 

 

 Click the Add  button. 
 

 The publishing target options display. Select one from the list: 
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 In the additional windows that display, follow the instructions for creating the new 
publishing target. Please see the chapter on Publishing a Viewlet for more 
information on adding new and working with publishing targets. 

 
Publishing targets can also be added during the publishing process. 
 
 
To remove files or folders from the Browser Tab’s list: 
 
 Select the desired file or folder from the Browser Tab’s list. 

 

 Click the Delete  button.  
 

 A Delete window will display. Click Yes to confirm the deletion. Click No to 
cancel the deletion. 

 
Pay careful attention to the information in the “Delete” window that displays after you click 
the “Delete” button. In some cases, the deletion will NOT delete the actual file or folder (if 
it is a shortcut). In other cases, the deletion WILL delete the actual file or folder from not 
only the “Browser Tab” but also from your system. 
 
 
To navigate through files and folders in the Browser Tab’s list: 
 
 Select the desired file or folder to highlight it. 

 

 Click the Up One Level  button to move up to the next level in the list. 
 

 If a folder is selected and it contains a plus  symbol to the left of it, click this 
plus symbol to expand the list of files and additional folders contained in the 
folder. 
 

 If a folder contains a minus  symbol to the left of it, click this minus symbol to 
collapse the files and folders contained in the folder. 
 

 Click on a desired file or folder at any time to quickly navigate through the list. 
 
 
To refresh a selected folder in the Browser Tab: 
 
 Select the desired folder in the Browser Tab list. 

 

 Click the Refresh the current folder  button to refresh the list of files and 
folder contained in the selected folder. 
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The document “check in / out” and “undo document check out”    buttons on 
the Browser Tab’s button toolbar are only available when working with the “Self Hosted” 
version of ViewletCentral. Contact sales@qarbon.com for more information. 
 
  
To change how files and folders are displayed in the Browser Tab: 
 
 Select the Browser Tab to make it the active tab. 

 

 Click the Views  button on the toolbar. 
 

 The available view selections display. Select the: 
 

 
 

o Icon View: Displays an icon next to the file and folder in the lower portion 
of the Browser Tab. 
 

o Details View: Displays the file or folder name, type, number of slides, last 
modification date and file size. 

 
 
To sort files and folders displayed in the Browser Tab using the “Details View”, simply 
click the applicable column header.   
 

 
 
Available sorts include “Name” or “Description” columns. 
 
 

o Thumbnail View: Displays the file as a thumbnail. 
 
 
For more information on working with other Tab View options (such as expanding, 
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on 
Workspace Features and Tab Views. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Thumbnails Tab 
The Thumbnails Tab, when selected, displays (by default) to the left side of the Slide 
Edit area. This tab allows you to view all the slides in the entire project. Various tasks 
can be performed while viewing thumbnails including: navigating through the slides in 
the project, moving the order of slides, adding features to one or more slides at the same 
time, copying and / or deleting slides, zooming in and out on thumbnails and more. This 
chapter highlights the main features available while working in the Thumbnails Tab. 
 

 
 
To display the Thumbnail Tab: 
 Select View from the Menu bar. 
 Select Thumbnails from the list. 

 
The Thumbnails Tab contains a “tab” at the top of its window area with the title of 
“Thumbnails” indicating what tab it is. A toolbar displays below the tab’s title with buttons 
for additional features while working with thumbnails. 
 
 
To increase or decrease the zoom level of the thumbnails in the Thumbnail Tab: 
 

 To increase the size of the thumbnails, click the Zoom In  button. 
 

 To decrease the size of the thumbnails, click the Zoom Out  button. 
 
 
To update the thumbnail of a recently edited slide: 
 
 Select the desired thumbnail(s) from the list. 

 

 Click the Refresh Thumbnail  button to refresh the selected thumbnail. 
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To updated all of the thumbnails in the project: 
 
 Select the Thumbnails Tab to make it the active tab. 

 

 Click the Refresh All Thumbnails  button to refresh all thumbnails in the 
project. 

 
 
To move one or more slides within the project: 
 
 Select the Thumbnails Tab to make it the active tab. 

 
 Select one or more slide thumbnails by clicking on them to select them. 

 
 Hold down your left mouse button and drag the selected thumbnail(s) to the 

desired location. 
 

 Let go of the left mouse button to drop the selected thumbnail(s) into place. 
 
If you have to move slides within your project, click the “Expand” button in the 
Thumbnails Tab. This will expand the number of thumbnails viewable in your project and 
make moving slides (thumbnails) a lot easier. 
 
 
To copy one or more slides in the Thumbnails Tab: 
 
 Select the desired thumbnail(s) from the list of thumbnails. 

 
 Press Ctrl + C to copy the thumbnail(s). You can also select Edit > Copy from 

the Menu bar. Or, select the thumbnail(s) and right click then select Copy from 
the shortcut menu. 
 

 Select the thumbnail you want to use as the insertion point. Pasted thumbnails 
will be inserted “after” the selected thumbnail. 
 

 Press Ctrl + V to paste the copied thumbnail(s). You can also select Edit > 
Paste from the Menu bar, or right click on the “insertion point” thumbnail then 
select Paste from the shortcut menu. 
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To delete one or more slides from the Thumbnails Tab: 
 
 Select the desired thumbnail(s) from the list. 

 
 Press the Delete key from the keyboard. Or, select Edit > Delete from the Menu 

bar. Or, right click on the selected thumbnail(s) and select Delete from the 
shortcut menu. 

 
For more information on working with other Tab View options (such as expanding, 
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on 
Workspace Features and Tab Views. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Stylesheets Tab 
The Stylesheets Tab allows you to set properties of multiple objects using a template 
called a “stylesheet”.  A stylesheet can be used for new and existing projects and 
updated as needed. You can set up one or more stylesheets and then choose to apply 
to the entire project or just to a current selection.  Here’s an alphabetical list of the 
“properties” that can be set up in stylesheets: 
 

 Background Color: Set the background color of a slide or message object. 
 

 
 

 Button Style: Standardize the “look” of clickable buttons used in a project from 
a library of button images. 
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 Check Box Style: Set the “look” of check box selection fields used in question 
slides from a library of check box images. 
 

 
 

 
 ComboBox Style: Set the “look” used for combobox lists used in question 

slides from a library of combobox images. 
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 Message Style: Set the style used for message objects from a list of available 
“pre-defined” styles. 
 

 
 

 
 Message Type: Standardize the style and type of message objects such as 

notes, balloons and text boxes. 
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 Modify Click Area: Set the attributes of what happens when a user interacts 
with a Click Zone. 
 

 
 

 
 Radio Button Style: Set the “look” of radio buttons used with question slides 

from a library of radio button images. 
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 Rating Style: Standardize the “look” of survey question rating objects used on 
question slides from a library of rating style images. 
 

 
 

 
 Text Field Style: Set the “look” for text input fields on question slides from a 

library of text field images. 
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 Text Properties: Set text attributes, including: font, size, style, alignment and 
color for message objects. 
 

 
 
 
To display the Stylesheets Tab: 
 Select View from the Menu bar. 
 Select Stylesheets from the list. 
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ViewletBuilder6.2 Enterprise starts you off with a “default” stylesheet, which can be 
modified based on your needs. Each stylesheet contains objects whose properties can 
be standardized for use in your current or new projects. These stylesheet elements 
include: 
 
 Slide:  Used to set slide background color. 
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 Balloon: Used to set balloon message style, background color and text 
properties.  
 

 
 

 Note: Used to set note message style, background color and text properties. 
 

 
 

 Text Box: Used to set text properties (font, size, style, alignment, color) for text 
box. 
 

 
 

 Button: Used to set button style from a library of button images. 
 

 
 

 Correct Message: Used to set correct message type, background color and text 
properties (font, size, style, alignment, color). 
 

 
 

 



 
 
 

VB6.2 Enterprise User Manual Page 109 February 2010 

 Incomplete Message: Used to set incomplete message type, background color 
and text properties (font, size, style, alignment, color). 
 

 
 

 
 Incorrect Message: Used to set incorrect message type, background color and 

text properties (font, size, style, alignment, color). 
 

 
 

 
 Click Area:  Used to set Click Zone attributes, including enabling double click 

action. 
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 Question Text: Used to set question text message type, background color and 
text properties (font, size, style, alignment, color). 
 

 
 

 
 Question Choice Text: Used to set question choice text message type, 

background color and text properties (font, size, style, alignment, color). 
 

 
 

 
 Question Row Text: Used to set question row text message type, background 

color and text properties (font, size, style, alignment, color). 
 

 
 

 
 Question Column Text: Used to set question column text message type, 

background color and text properties (font, size, style, alignment, color). 
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 Question Component Style: Used to set question slide “input” component 
styles for text fields, radio buttons, check boxes, comboboxes, and ratings from a 
library of component images. 
 

 
 

 
 Drag and Drop Choice Text: (New in ViewletBuilder6.2 Enterprise) 

In Drag and Drop question types, used to set the message type, background 
color and text properties (font, size, style, alignment, color) for Drag Choices. 
 

 
 

 
 Drop Area: (New in ViewletBuilder6.2 Enterprise) 

In Drag and Drop question types, used to set Drop Area properties for its Normal, 
Rollover and Selected states. 
 

 
 

 
The Stylesheets Tab contains a “tab” at the top of its window area with the title of 
“Stylesheets” indicating what tab it is. A toolbar displays below the tab’s title with buttons 
applicable to tools available in this tab. 
 

Create your own custom stylesheets to standardize different objects within new and 
existing Viewlet projects. 
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To create a new stylesheet: 
 
 Select the Stylesheets Tab to make it the active tab. 

 

 Click the New Stylesheet  button on the tab’s toolbar. 
 

 The Stylesheet window displays. 
 

 
 

o Enter a title for the new stylesheet in the Name field. 
 

o Select the Password Protect option and enter a password in the field 
provided.  
 

 Click OK. The new stylesheet is added to the list of stylesheets. 
 
 
To select a stylesheet from the list: 
 
 Select the Stylesheet Tab to make it the active tab. 

 
 Make a selection from the Stylesheet drop-down list. 

 

 
 

 
 
To modify a stylesheet’s properties: 
 
 Select the Stylesheet Tab to make it the active tab. 

 
 Make a selection from the Stylesheet list. 

 

 Click the Modify Stylesheet  button on the tab’s toolbar. 
 

 The Stylesheet window displays. Make edits as needed and click OK to save the 
changes to the stylesheet’s properties. 
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To modify any of the elements (objects) in a stylesheet: 
 
 Select the Stylesheet Tab to make it the active tab. 

 
 Select the desired stylesheet from the list. 

 

 Click the arrow  button to the left of the object you want to modify. 
 

 The arrow changes position and points down  to reveal the object’s 
“properties’ that area available for editing. 
 

 Click on the icon next to each of the “properties” listed below the selected 
stylesheet’s object and follow the instructions in the window(s) that display to edit 
and save the changes. 

 
 
To apply a stylesheet to the entire project: 
 
 Select the desired stylesheet in the Stylesheet Tab. 

 

 Click the Apply Stylesheet to Project  button on the tab’s toolbar. 
 

 The Apply Stylesheet to Project window displays. Read the information and click 
Yes to apply the stylesheet to the project. 
 

 
  

 
 
To apply a stylesheet’s element to an object: 
 
 Select the desired stylesheet in the Stylesheet Tab. 

 
 Select the object to which you want to apply a stylesheet element. 

 
 Select the stylesheet object you want to use to apply to a selected slide object by 

clicking the icon to the left of the element on the stylesheet. 
 

 Click the Apply Stylesheet to Selection  button. The selected object will 
immediately be updated, based on the stylesheet’s settings. 
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To update a stylesheet’s element based on a selection: 
 
 Select the desired stylesheet in the Stylesheet Tab. 

 
 Select the desired object you want to use when updating the stylesheet element. 

 
 The applicable object on the stylesheet is automatically selected. Click the 

Update Stylesheet with Selection  button and the stylesheet is 
automatically updated. 

 
 
To remove a stylesheet from the list: 
 
 Select the desired stylesheet in the Stylesheet Tab. 

 

 Click the Delete Stylesheet  button from the tab’s toolbar. 
 

 A Delete Stylesheet window displays. Read the information in the window and 
click Yes to confirm the deletion. 
 

 
 

 
For more information on working with other Tab View options (such as expanding, 
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on 
Workspace Features and Tab Views. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Output Tab 
The Output Tab displays, by default, below the Slide Edit area at the bottom of the 
program window. This tab contains a record of information that can help Qarbon find and 
correct ViewletBuilder6.2 Enterprise programming errors. The information that is 
recorded in the Output Tab is determined by preferences set up for ViewletBuilder6.2 
Enterprise. 
 

 
 
To set preferences for the report information recorded in the Output Tab: 
 
 Select Edit > Preferences from the Menu bar. 

 
 The Preferences window displays. Select the Logging tab. 

 
 In the Output area, from the Reports list, select: 

 

 
 

o Display Errors Only 
o Display Errors and Information 
o Display All Messages 

 
 
 

ViewletBuilder6.2 Enterprise creates an external log file with the information in the Output 
Tab that can be sent to Qarbon when program issues arise. 
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To display the Output Tab: 
 

 Select View from the Menu bar. 
 

 Select Output from the list. 
 

 
 
 
 
 
You can quickly display Output tab options by right clicking anywhere within the Output 
tab and selecting an option from the shortcut menu. 
 

 
 
 
To locate the log file containing the information also displayed in the Output Tab: 
 
 Select Edit > Preferences from the Menu bar. 

 
 The Preferences window displays. Select the Logging tab. 

 
 In the Log File area, the path to where the log file is saved displays in the File 

field. If you can’t see the entire path to the file, click the Browse  button next 
to the File field. 
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 The Select Log File window displays, showing the log file, which end with the 
extension .log. To view the full path to where the file is located, click the down 
arrow next to the Look In list to see the entire path to the folder containing this 
log file. 
 

 
 
 

The location of the log file containing the report information also displayed in the Output 
Tab is determined when setting up ViewletBuilder6.2 Enterprise program preferences. 
 
 
To clear the report information displayed in the Output Tab: 
 
 Select Edit > Preferences from the Menu bar. 

 
 The Preferences window displays. Select the Logging tab. 

 

 In the Output area, click the Clear Output Window  button. 
 
 
For more information on working with other Tab View options (such as expanding, 
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on 
Workspace Features and Tab Views. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Timeline Tab 
The Timeline Tab displays, by default, below the Slide Edit area at the bottom of the 
program window. The Timeline allows you to manage the start and duration times of all 
elements on each slide in your project. In addition to working with objects directly on a 
slide, the Timeline provides more enhancement options for your project as you hide, 
view, modify, group, sort and lock / unlock layers in the Timeline. But, that’s not all.  
Using the Timeline’s playhead tool you can scrub the Timeline to view your project’s 
animations. You can also preview your project as it plays back, noting where actions 
occur along the Timeline, allowing you to “tweak” any part of the project exactly where it 
needs it.  
 
This chapter highlights the main features while working in the Timeline Tab. For more 
information on how ViewletBuilder6.2 Enterprise handles other timing aspects of a 
project’s elements, please see the Object Timing chapter. 
 
To display the Timeline Tab: 
 Select View from the Menu bar. 
 Select Timeline from the list. 
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The Timeline Tab contains the following elements: 
 

Layers 
The left side of the Timeline displays all the objects on the slide. Each object exists in a 
layer. These layers are “stacked” with “higher object layers” overlapping objects in lower 
layers. You can hide / unhide layers without deleting them from the project. You can lock 
layers to prevent them from being editing. You can also change the starting / ending 
points of objects as they display along the Timeline as well as their entire duration. You 
can work on single or multiple layers and group layers into one as needed. 
 
To expand / collapse layers: 
 Select the Timeline Tab. 

 On the left side of the Timeline, click the right arrow  next to the slide title. 
 The arrow now points down  indicating the layers are now expanded. 
 To collapse the layers, click the down arrow again. 

 
 
To select a single layer: 
 Select the Timeline Tab. 
 Expand the list of layers, if needed. 
 Click on the desired layer to select it. 

 
 
To select multiple layers: 
 For adjacent layers: 

o Click on the first layer to highlight it. 
o Hold down the Shift key. 
o Click on the last layer in the series of adjacent layers. This will select the 

first and last layers as well as all the layers in between them. 
 

 
 



 
 
 

VB6.2 Enterprise User Manual Page 120 February 2010 

 For non-adjacent layers: 
o Click on a layer to highlight it. 
o Hold down the Ctrl key while clicking on other layers to select them. 

 

 
 

 

Select multiple layers to temporarily group them to speed up various authoring tasks that 
can be applied to all of the selected layers at the same time. 
 
 
 
 
 
Arrange Layers via Drag and Drop Action  

ViewletBuilder6.2 Enterprise allows you to arrange one or more layers via a select and 
then drag and drop action. 
 
To drag (rearrange) a single layer up or down the stack in the Timeline: 
 
 Single click on the layer to select it. 

 
 Once the layer is highlighted, single click it again and hold down the left mouse 

button. 
 

 While holding down the left mouse button, drag the layer up or down in the stack. 
While dragging the layer, its icon will display. 
 

 Let go of the left mouse button to drop it into its new location in the stack. 
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While dragging a single layer, its icon is displayed until you drop the layer into its new 
location in the stack. 
 
 
To drag (rearrange) multiple layers up or down the stack in the Timeline: 
 
 Click on the desired layers while using the Shift or the Ctrl key to select multiple 

adjacent or nonadjacent layers to highlight them. 
 

 Once the layers are highlighted, single click on them again and hold down the left 
mouse button. 
 

 While holding down the left mouse button, drag the multiple layers up or down in 
the stack. While dragging the layers, their icons will display. 
 

 Let go of the left mouse button to drop the multiple layers into their new location 
in the stack. 
 

 
 
 

While dragging multiple layers, their icons will displayed “stacked” until you drop the 
layers into their new location in the stack. 
 
 
 
To hide / unhide a layer: 
 

 To hide a layer, click the Visible  button to hide the layer. This changes the 
“open eye” to a “closed eye” indicating the layer is hidden. 
 

 To unhide a layer, click the Hidden  button to display the layer. This changes 
the “closed eye” to an “open eye” indicating the layer is visible. 
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To lock / unlock a layer: 
 

 To lock a layer, click the Unlocked  button to lock the layer. This changes the 
“open padlock” to a “closed padlock” indicating the layer is locked. 
 

 To unlock a layer, click the Locked  button to unlock the layer. This changes 
the “closed padlock” to an “open padlock” indicating the layer is unlocked. 

 
 
To prevent a layer from being edited, click the open padlock to close it to lock the layer. 
 
 
 
To move an object to a new frame in the Timeline while working in its layer: 
 
 Point your cursor over the object’s rectangle (which indicates its position and 

duration along the frame in the Timeline). 
 

 Hold down your left mouse button to select the object’s rectangle and drag. 
 

 Let go of the left mouse button to drop the object into its new location in the 
Timeline. 
 

 
 

 
To increase or decrease an object’s duration in the Timeline while working in its layer: 
 
 Point your cursor over the left or right edge of the object’s rectangle. 

 

 When the cursor changes to a double arrow    hold down the left mouse 
button and drag to change the size (duration) of the rectangle. 
 

 
 
 

 Once the rectangle indicates the desired duration (by its new size) on the 
Timeline, let go of the left mouse button. 
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 If a Timing Rule window displays, read the information and click OK to complete 
the operation. 
 

 
 

 
To delete a layer: 
 Click on the layer to select it. 
 Press the Delete key on the keyboard, or right click and select Delete from the 

shortcut menu. 
 
 
If you accidentally delete a layer, try pressing “Ctrl + Z” to undo the action (if it was your 
last action) to restore the layer. 
 
 
 

Timing Links 
Timing Links are links that connect two or more objects in the Timeline. The benefit of 
this feature is that as you edit an object’s timing in the Timeline, the linked objects 
update accordingly. 
 
Timing Links are automatically added to notes, balloons and cursors as they are inserted 
in the Timeline if the Maintain Timing Links option is selected (Project Properties 
window > Timing section).  
 

 



 
 
 

VB6.2 Enterprise User Manual Page 124 February 2010 

For best practice purposes, by default, when notes are added to a slide, they display first 
in the Timeline. When balloons are added to a slide, they display after all of the notes. 
Cursors display after balloons. The reason for this is because it is assumed that a note 
introduces an action, a balloon points out the action, while cursor animation is an action. 
Of course, the position of any object can be change in the Timeline at any time. 
 
To automatically update Timing Links: 
 Open a Viewlet project. 
 Select Project > Project Properties from the Menu bar. 
 The Project Properties window displays. Select Timing from the list (on the left 

side of the window). 
 In the Timing Links area, select the Maintain Timing Links option. 

 

 
 
 
The default order that message objects are displayed in the Timeline are “Notes” first 
(Note #1, Note #2, etc.) followed by “Balloons” second (Balloon #1, Balloon #2) no matter 
when the new balloon or note is inserted o a slide. 
 
 
To add a Timing Link to two objects in the Timeline: 
 Select the first object in the Timeline. 
 Hold down the Ctrl key and click to select the second object in the Timeline. 

 
The order in which the objects are selected is the order in which the Timing Links will be 
added to the objects. 
 

 Click the Add Timing Links  button on the Timeline’s toolbar. 
 

 The Timing Links window displays. Select a Link Type from the list: 
 

 
 

o End to Start: Links end of first object to front of second object. 
o Start to End: Links front of first object to end of second object. 
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o Start to Start: Links front of first object to front of second object. 
o End to End: Links end of first object to end of second object. 

 
 
To remove a Timing Link: 
 
 Select an object on the Timeline. 

 
 Hold down the Ctrl key to when clicking to select the second object that shares a 

Timing Link with the first selected object. 
 

 Click the Remove Timing Links  button. 
 
 
 
To remove all Timing Links on a slide at the same time: 
 

 Select all of the objects on the slide. 
 

 Click the Remove Timing Links  button. 
 
 
There may be times when you will be prompted to change an object to “Manual Timing” to 
allow a Timing Link to be added. And, there are some objects, such as an object on the 
main Timeline and an object inside a Question Slide or Interactive Zone, which cannot be 
connected by Timing Links. 
 
 

Frames 
The Timeline Tab contains a “guide bar” known as a Frames Reference Guide. Along 
this guide bar, there are small “sections” known as frames Each frame is divided by 
tickmarks into 1/10 of second intervals. The main sections of the Timeline are divided 
into 1 second intervals.  Use this guide bar to position objects in the Timeline to 
determine when each will display and for how long when the project is played back. 
 

 
 
 
The Background Layer contains special “key frames” where a background frame is 
“painted” over the entire slide. This, in combination with the Background Layer’s “non-key 
frames” (which paint over a smaller, specific area on top of the key frame), can produce 
some dynamic and “attention-getting” effects.  If you are interested in learning more about 
this topic, “key frames” are covered in more detail in the “Background Frames” chapter. 
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To select a frame on the Timeline: 
 Click on the desired frame to select it. All objects that display in that frame in the 

Timeline will display on the slide. 
 
 
There is a phrase called “scrubbing the Timeline” that translates to dragging the 
playhead along the frames in the Timeline to preview actions that occur in the project. 
This is a useful “trick” to know if you want to manually preview specific sections of the 
project in the Timeline for intricate “tweaking”. 
 
 
To “scrub the Timeline” along specific frames within a single slide: 
 

 If the Current Slide   button is displayed on the Timeline Tab’s 

toolbar, click it so that it changes to All Slides   . This will change the 
Timeline view from “All Slides” to “Current Slide”. 
 

 Click on the frame where you want to begin. 
 

 A playhead displays on the selected frame with a line that intersects the 
Timeline below the playhead. Hold down your left mouse button and drag the 
playhead along the frames and watch the actions as you move it along the 
Timeline. 
 

 
 

 Once you reach the end of the frames contained for the current slide, you will no 
longer be able to move the playhead. If you want to “jump” to the next slide, click 
on a frame in the next slide to display the playhead and repeat these steps to 
scrub the Timeline again. 
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To “scrub the Timeline” along specific frames across multiple frames: 
 

 If the All Slides  button is displayed on the Timeline Tab’s toolbar, 

click it so that it changes to Current Slide    . This will change the 
Timeline view from “Current Slide” to “All Slides”. 
 

 Click on the frame where you want to begin. 
 

 A playhead displays on the selected frame with a line that intersects the 
Timeline below the playhead. Hold down your left mouse button and drag the 
playhead along the frames and watch the actions as you move it along the 
Timeline. 
 

 

Miscellaneous Timeline Features and Tools 
The Timeline Tab contains some status information and tools right above the Frames 
Reference Guide, which are useful when working in the Timeline. These include: 
 
 Slide Numbers: Indicates current slide and number of slides in the project. 

 

 
 

 Clock Feature: Indicates the duration of current slide in relation to overall project 
duration. 
 

 
 

 Slide Duration of Current Slide: Indicates the full playtime for the current slide 
displayed in the Timeline, which can be increased / decreased by clicking the 
up / down arrows. 
 

 
 

 Zoom: Signifies the current zoom of the Timeline. Use the up / down arrows to 
increase / decrease the zoom level of the Timeline. 
 

 
 

 Views: There are two different views that can be used while working in the 
Timeline: All Slides or Current Slide. When the All Slides button displays, the 
Timeline view is “current slide”. When the Current Slide button displays, the 
view is “all slides”. Click this button to toggle between these views. 
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 Player Buttons: The “VCR style” buttons are used to navigate to the first slide, 
previous slide, next slide and last slide of the project.  
 

 
 
 

 Preview Menu: Use this list to select from one of four project preview options. 
 

 
 
 

 Slide Titles: Along the top of the Frames Reference Guide are boxes containing 
the titles for each of the slides in the project. By default, the titles are the slide 
number. By dragging the edge of the “title box” you can increase / decrease the 
duration of the slide in the Timeline. 
 

 
 
 
For more information on working with other Tab View options (such as expanding, 
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on 
Workspace Features and Tab Views. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Object Timing 
Understanding how ViewletBuilder6.2 Enterprise handles the “timing aspects” of objects 
is essential to being able to effectively work in the Timeline or while setting the timing of 
objects through the use of dialog windows. There are two important “timing topics” that 
each Viewlet Author should review before creating any project: Timing Commands and 
Timing Rules. 
 
Timing Commands 
Timing commands can be applied to a single or multiple objects on a slide. An object’s 
timing will determine when it will display on a slide (or on the Timeline), how long it will 
remain displayed on a slide (or on the Timeline) and, if multiple objects display on the 
same slide, what timing command elements they may have in common. 
 
An object’s timing can be adjusted in two places, in its Properties window and while 
working directly in the Timeline. 
 
To adjust a message object’s timing in the Timeline: 
 
 Point your cursor over the left or right edge of the object’s rectangle in the 

Timeline. 
 

 When the cursor changes to a double arrow    hold down the left mouse 
button and drag to change the size (duration) of the rectangle. 
 

 
 
 

 Once the rectangle indicates the desired duration (by its new size) on the 
Timeline, let go of the left mouse button. 
 

 If a Timing Rule window displays, read the information and click OK to complete 
the operation. 
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To change an object’s timing using the object’s Properties window: 
 
 Click the desired object (from either the slide or in the Timeline) to select it. 

 

 Click the object’s Properties  button from the Context Sensitive Toolbar. 
 

 The object’s Properties window displays. In the Timing area, there are options for 
setting the object’s timing (there’s an additional selection for message objects). 
These include: 
 

o Reading Speed: Used (by default) for notes, balloons, and text boxes to 
display the message object from its set Start Time until the automatically 
calculated reading speed is reached. 
 

 
 
 

To set the default “Reading Speed” for ViewletBuilder6.2 Enterprise, select “Project > 
Project Properties” from the Menu bar. In the “Project Properties” window that displays, 
select “Timing” from the list (left side of window). In the “Reading Speed” area, enter a 
number for the “words per minute” reading speed. This value will be used when the 
program automatically calculates a message object’s reading speed based on the amount 
of text it contains. 
 
 

o Manual Timing:  Used to manually set the Start Time and Duration (in 
seconds) for the object.  
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o Until End of Slide: Used to display the object from its set Start Time (in 
seconds) until the end of the slide’s “play” time.  
 

 
 

 Select a Timing option for the object from the list. 
 

 Enter a number for the Start Time (in seconds). This will be the amount of time 
the object will be delayed before displaying on the slide. 
 

 For Manual Timing, enter a number for the Duration. This is the amount of time 
the object will display. 
 

 Click OK to apply the timing settings and to close the object’s Properties window. 
 
 
To synchronize timing for multiple objects on a slide: 
 
 Select the objects you want to synchronize the time of by clicking on each one 

while simultaneously holding down the Ctrl key. 
 
Be careful when selecting multiple objects for timing synchronization. The first object 
selected will be used as the “key object” from which the other times are calculated. 
 
 
 The Synchronization Context Sensitive Toolbar displays. Click one of the buttons 

to synchronize the selected objects timing: 
 

  Same Start Time: Set the same start time for selected objects. 

  Same End Time: Sets the same end time for selected objects. 

  Same Start and End Time: Sets the same start and end time for all 
objects based on the key object. 

  Display Until Last End Time: Sets the end time for all objects to object’s 
whose end time is the last on the slide (of those selected). 

  Sequence Times: Sets the objects to display sequentially based on the 
selection order. 
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To adjust timing for a “Display Object” action: 
 
 Select the desired object (note, balloon, text box, shape, image, etc.). 

 

 Click the Events  button on the Context Sensitive Toolbar. 
 

 The object’s Events widow displays. Select one of the three tabs: 
 

 
 

o On Click: Set actions to occur when user clicks the object. 
o On Rollover: Set actions to occur when user rolls mouse over object. 
o On Rollout: Set actions to occur when user rolls mouse off object. 

 

 Click the Add  button. 
 

 The Action window displays. Select Display Object from the Action Type list. 
 

 Select an object from the Select an object on the slide to display list. 
 

 In the Duration area, select a timing command.  
 

 Click OK to close the Action window. 
 

 Click OK to close the object’s Events window. 
 
 

Timing Rules 
Each object has a Timing Rule associated with it. Timing Rules automatically control 
how the timing for that object associated with it is calculated. Timing Rules differ from 
“timing synchronization commands” in that synchronization commands make a one-time 
adjustment where as Timing Rules are applied globally. 
 
To understand Timing Rules better, let’s take a look at an example. A simple timing rule 
is “Reading Speed”, which insures that the duration of a message object is calculated 
from the number of words in a message object and the reading speed set in the Project 
Properties window. This rule is automatically and globally applied to all message objects, 
so that each note, balloon and text box displays only as long as calculated reading 
speed allows.  
 
To help standardize object timing, there are several Timing Rules available (each 
described in the previous “Timing Commands” section of this chapter): 
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 Manual: An object’s timing is calculated manually, meaning the user has full 
control over the start time and duration. 
 

 Reading Speed: Applies to message objects (notes, balloons, text boxes), the 
duration is calculated based on the reading speed set in the Project Properties 
window and the number of words in the message object. The start time for the 
message object is adjustable without affecting this rule. 
 

 Until End of Slide: An object displays from a user-defined start time until the 
end of the slide. The start time is adjustable without affecting this rule. 
 

 Display Object Action: Used for objects displayed due to an event which 
triggers the “Display Object” action. You can use any “available” Timing Rule for 
the object that is to be displayed. 

 
Each time you attempt to change an object’s timing, a “Timing Rule Change” window will 
display if you are “breaking the rules” for the Timing Rule currently associated with the 
object. Read the information in the window carefully before proceeding. 
 
  
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Slide Notes Tab 
The Slide Notes tab displays, by default, below the Slide Edit area. In this tab, you can 
add presenter notes, which can be printed out for you and your audience. The Slide 
Notes tab can also be used as a collaboration tool by adding editing notes (not part of 
the actual slide) when working with a team of authors on the same project. These notes 
can be displayed or hidden inside ViewletBuilder6.2 Enterprise (and printed) as needed.  
 

 
 
 
Did you know that you can use Slide Notes in combination with ViewletBuilder6.2 
Enterprise’s JavaScript function to add a computer simulated voice-over to your project 
on a slide-per-slide basis? For more information, contact support@qarbon.com for more 
information on this advanced Viewlet authoring trick. 
 
 
 
To display the Slide Notes Tab: 
 Select View from the Menu bar. 
 Select Slide Notes from the list. 

 
 
To add text in the Slide Notes Tab: 
 Select the desired slide so that it displays in the Slide Edit area. 
 Select the Slide Notes Tab to make it the active tab. 
 Click inside the Slide Notes field and type text as needed. 
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To print Slide Notes with your slides: 
 
 Select File > Page Layout from the Menu bar. 

 
 The Page Layout window displays. In the Options area, select the Slide Notes 

option. 
 

 
 

 Click OK to save this option. Each time you print slides, the Slide Notes will be 
added below the image of each slide. 

 
For more information on working with other Tab View options (such as expanding, 
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on 
Workspace Features and Tab Views. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Cursor Management 
Cursor animation is a fundamental component of most Viewlet projects. Understanding 
the basics of how cursor movement is captured, the different parts that make up the 
actual slide-to-slide cursor animation and how to edit cursor movement is an important 
Viewlet authoring skill, which is essential for creating attention getting, dynamic Viewlets. 
 

The Mouse Tab 
The Mouse tab in the Capture Options window is available for Viewlet authors when 
setting up or modifying Capture Profile options for new Screen Capture Projects or 
when inserting new screenshots into existing projects. In the Mouse tab, you have 
options for capturing cursor movement during a screenshot session and also the option 
to capture screenshots on mouse click action. 
 

 
 
To access the Mouse tab for new Screen Capture Projects: 
 Select File > New from the Menu bar. 
 The Create New Project window displays. Select Screen Capture Project from 

the new project type list. 
 Select a profile from the list of Capture Profiles to use for the screenshot 

session. 

 Click the Modify  button. 
 The Capture Options window displays. Select the Mouse tab. 

 
 
You can access the “Mouse” tab to set up cursor options prior to creating a new Screen 
Capture Project or right before inserting new screenshots into an existing project by 
adding a new “Capture Profile” or by selecting an existing “Capture Profile” and clicking 
“Modify” to display the “Capture Options” window where the “Mouse” tab is located. 
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To capture cursor movement during a screenshot recording session: 
 
 In the Capture Options window (accessed when adding or modifying Capture 

Profiles), select the Mouse tab. 
 

 In the On Screen Capture – Add to Slide area: 
 

o Select the Cursor Simulation option. 
 

 
 

o If you want to allow the cursor to follow a curved path (for added visual 
interest during playback), select the Curved Cursor Path option. 
 

 Click OK to close the Capture Options window. 
 
 
 
To remove cursor movement during a screenshot session: 
 
 In the Capture Options window (accessed when adding or modifying Capture 

Profiles), select the Mouse tab. 
 

 In the On Screen Capture – Add to Slide area, select the Don’t Add Cursor 
Simulation option. 
 

 
 

 Click OK to close the Capture Options window. 
 
 

If you are using the “Manual Capture” mode for your screenshot session and do NOT want 
to include cursors, select the default “Simple” Capture Profile for your recording session. 
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To enable “mouse click” capture during a screenshot session: 
 
 In the Capture Options window (accessed when adding or modifying Capture 

Profiles), select the Mouse tab. 
 

 In the Mouse Click Capture area to:  
 

o Enable mouse click capture of screenshots during a capture session, 
select the Mouse Clicks Capture Screenshots. 
 

 
 

o Select the Include Right Mouse Button to enable additional right click 
mouse click of screenshots capability during the recording session. 
 

 Click OK to close the Capture Options window. 
 
 

Cursor Indicators (Red, Green, Blue) 
When you look at a slide that contains cursor movement, you will see cursors indicated 
by (at a minimum) a “green” circle and a “red” circle. These two cursor circle indicators 
are connected by a “dotted” line. And, there may be times when you see a “blue” circle 
along the dotted line connected the green and red circles. Let’s take a look at what these 
all mean: 
 

  Green Circle: A green circle around a cursor signifies the starting 
position of the cursor on a cursor path. 
 

  Red Circle: A red circle signifies the ending position of a cursor on a 
cursor path. 
 

  Blue Circle: A blue circle signifies the point on the cursor path will the 
cursor will change shape before it reaches its destination. 
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Cursor Path 
The “dotted line” between the green circle and the red circle is known as the “cursor 
path”. This is the path the cursor travels during its animation (while moving from one 
slide to the next slide). A basic path starts at the green circle and ends at the red circle. 
A more complicated path includes points along the cursor path where the cursor may 
change direction or cursor style. Elements of the cursor path may be edited. 
 

 
 
 
In some cases, there may be “points” along the cursor path. These points may be a 
“blue circle” cursor indicator where the cursor changes shape before it reaches the end 
of the cursor path. Or, the cursor path may contain “red points” that indicate a change in 
direction along the cursor path. You can edit these points by dragging them along the 
cursor path. Or, to change the direction the path takes, simply “pull” the point to change 
the cursor path’s direction. 
 
 
To move a green circle (starting cursor position) on the cursor path: 
 Click on the green circle. 
 While holding down your left mouse button, drag the green circle to where you 

want it to reside on the slide. 
 Let go of the left mouse button to drop it into place. 

 
 
To move a red circle (ending cursor position) on the cursor path: 
 Click on the red circle. 
 While holding down the left mouse button, drag the red circle to where you want 

it to reside on the slide. 
 Let go of the left mouse button to drop it into place. 
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To move a blue circle (where cursor changes shape on cursor path) on the cursor path: 
 Click on the blue circle. 
 While holding down the left mouse button, drag the blue circle to where you want 

the cursor to change its shape on the cursor path. 
 Let go of the left mouse button to drop it into place. 

 
 
To add a “red point” to the cursor path: 
 
 Click the green circle to select it. 

 Click the Add Point to Cursor Path  button on the Context Sensitive 
Toolbar. A “red point” will display on the cursor path, ready for editing. 

 
 
To move a “red point” along the cursor path: 
 Click on the red point. 
 Hold down the left mouse button and drag it along the cursor path. 
 Let go of the left mouse button to drop it into place. 

 
 
To change a single cursor path from straight to curved or curved to straight: 
 
 Click the green circle to select it. 

 
 To change the cursor path to straight, click the Move the cursor in a straight 

path  button on the Context Sensitive Toolbar. 
 

 To change the cursor path to curved, click the Move the cursor in a curved 

path  button on the Context Sensitive Toolbar. 
 
 
To globally change all cursor paths within the project to straight or curved: 
 

 Click the green circle to select it. 
 

 To change all cursor paths in the project to straight, click the Straight Path – All 

Slides  button on the Context Sensitive Toolbar. 
 

 To change all cursor paths in the project to curved, click the Curved Path – All 

Slides  button on the Context Sensitive Toolbar. 
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To remove a “red point” or “blue circle” from the cursor path: 
 Click on the “red point” or the “blue circle” to select it. 
 Press the Delete key on the keyboard to delete it. Or, right click and select 

Delete from the shortcut menu. 
 

Cursor Style 
ViewletBuilder6.2 Enterprise comes with a library of the most common cursor styles 
used in Viewlet projects. Cursor styles captured during screenshot sessions are added 
to the cursor style library. Once captured, cursors can be changed in a project as 
desired by selecting a different style from the cursor style library. 
 

 
 
 
To add cursors to a slide that does not contain a cursor: 
 

 Click the Insert Cursor  button from the Object Toolbar. Or, from the Insert 
Menu or right click shortcut menu, select Cursor. A cursor will display on the 
slide, ready for editing. 

 
 
To change the cursor style: 
 
 Click on the cursor to select it. 

 

 Click the Cursor Style  button from the Context Sensitive Toolbar. 
 

 The Cursor Style window displays. Click on a style to select it. 
 

 Click OK to apply the new cursor style. 
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To add a new cursor to the cursor library, select the cursor. Then, open the “Cursor Style” 
window and the selected cursor will be added to the library for future use. 
 
 
To a cursor from a slide: 
 
 Click the green circle to select the cursor. 

 
 Press the Delete key from the keyboard and the cursor, along with the cursor 

path, will be removed from the slide. 
 
 

The “Insert Cursor” button on the Object Toolbar acts like a “toggle switch”. If a cursor is 
displayed on the slide, click the “Insert Cursor” button to remove it. Click the button again 
to insert a cursor back on the slide. 
 
 
Cursor Path Layer 
If a slide contains cursor animation, then along the Timeline you will see a Cursor Path 
layer. This layer will always be the uppermost layer in the stack of layers and cannot be 
moved down in the stack. You can edit the green circle and any red points along the 
cursor path by selecting the appropriate section on this layer. And, you can use this layer 
to “tweak” the duration of the cursor animation as it plays to the next slide.  
 

 
 
 
You can move the cursor animation to any point within the slide’s Timeline; however, it is 
recommended for most projects that cursor animation occur at the end of the slide. 
Additionally, only ONE “Cursor Path” layer can be included on a slide at the any time. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Messages 
ViewletBuilder6.2 Enterprise allows you to add impact to your Viewlet projects with 
Messages. These Messages come in the form of notes, balloons and text boxes. The 
purpose of each Message object is ultimately determined by you, the Viewlet author, but 
here are some ideas for ways they are commonly used in a Viewlet: 
 
 Note: A note is used to “introduce” a topic or action that is about to occur. It is 

also used in situations when you want to make sure the viewer takes notice of 
some important content such as special information, a tip or trick, or even a 
“warning” of some type. 

 
 Balloon: A balloon is used to “point out” an area of the screen or an action. For 

example, a balloon may contain text that discusses different areas of the screen 
while using its “pointer” to point at the area being discussed. Or, more commonly, 
a balloon may point at a button or text entry field with instructions for the viewer 
to “interact” with the Viewlet. 

 
 Text Boxes: A text box is used to “seamlessly blend” text into its background, 

whether it be the slide itself, a shape or an image or even other text. Text boxes 
are also used as the “question” box for quiz and survey question types. 

 
 

Multiple Message objects may be added to the same slide. By default, however, no matter 
what order you insert them on a slide, the notes are added first along the Timeline 
followed by balloons. 
 
 
Now that you know the three different Message types available in ViewletBuilder6.2 
Enterprise, the next thing you should decide is the method you want to use when editing 
the text inside your Message object.  
 
To set the default message editing preference for ViewletBuilder6.2 Enterprise: 
 
 Select Edit > Preferences from the Menu bar. 
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 The Preferences window displays. Select the General tab. 
 

 In the Message Editing area, select an editing preference. 
 

 Click OK to close the Preferences window. 
 

Message Editing Methods 
There are two “message editing” methods available in ViewletBuilder6.2 Enterprise. You 
can decide the default method to use by selecting it when setting up program 
preferences. 
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Edit in Place  
This is the “classic” message editing method used in previous versions of 
ViewletBuilder6.2 Enterprise. This method allows you to edit text directly in the note, 
balloon, or text box (without opening a dialog window). It also allows you to change the 
Message objects attributes using various buttons on the object’s Context Sensitive 
Toolbar (when the object is selected and not in text editing mode). 
 
Message Editor 
The Message Editor offers an alternative way to editing message objects in 
ViewletBuilder6.2 Enterprise all within the same window. When the “Message Editor” 
option is used, an editor window displays when you are in text edit mode. Inside the 
Message Editor window, you can use the: 
 

 
 
 

 Message Type  button to change the object’s style and type. 
 

 Background Color  button to change the object’s fill color. 
 

 Font list and Font Size list to change the text font type and size. 
 

 Italic  , Underline  , or Bold   button to change text attributes. 
 

 Text Color  button to change selected text color. 
 

 One of the alignment buttons to Left Align  , Center Align  , or Right 

Align  selected text. 
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 Hyperlink  button to turn selected text into a clickable hyperlink. 
 

 Text edit field to select text to edit or to select text to apply any of the available 
text attributes (font, font size, italic, bold, underline, color, alignment, hyperlink). 
 

 OK button to save edits in the dialog window. 
 

 Cancel button to exit the dialog window without saving any changes. 
 

 Apply button to apply changes without exiting the dialog window. 
 
 
To open the “Message Editor” from the Context Sensitive Toolbar or “right click” menu: 
 
 Select the Message object you want to edit by single clicking it to select it. 

 
 Click the Message Editor button on the Context Sensitive Toolbar, 

 

 
 
OR 
 

 Right click on the Message object and select Open in Message Editor from the 
shortcut menu.  
 

 
 

 The Message Editor window displays. Make edits as needed and click OK to 
save changes and to close the window. 
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While working with Message objects, you will find the process and options used during 
the “editing” operation will be basically the same for each object whether it is a note, 
balloon or text box. 
 
To insert a Message object on a slide: 
 

Note: 

 Click the Insert Note  button on the Object Toolbar. 
 

 If you selected for “message editing”: 
 

o Edit in Place: A note object will display on the slide with a “blinking cursor” 
in side it. This indicates the note is ready for you to start typing in it. 
 

o Message Editor: The Message Editor window displays. Make your 
selections for the text using the available buttons (font, font size, etc.) and 
type your text in the “text edit” field. Click OK to save the information and 
the note will be inserted on the slide. 
 

Balloon: 

 Click the Insert Balloon   button on the Object Toolbar. 
 

 If you selected for “message editing”: 
 

o Edit in Place: A balloon object will display on the slide with a “blinking 
cursor” in side it. This indicates the balloon is ready for you to start typing 
in it. 
 

o Message Editor: The Message Editor window displays. Make your 
selections for the text using the available buttons (font, font size, etc.) and 
type your text in the “text edit” field. Click OK to save the information and 
the balloon will be inserted on the slide. 

 
Text Box: 

 Click the Insert Text Box  button on the Object Toolbar. 
 

 The cursor changes to a cross-hair  shape. Move the cursor over the slide 
and click where you want to “anchor” one corner of the text box. Hold down the 
left mouse button and draw the text box on the slide. 
 

 If you selected for “message editing”: 
 

o Edit in Place: A text box object (surrounding by a “bounding box” that 
looks like a “dotted rectangle” with gnodes (grab handles) for resizing the 
box) will display on the slide with a “blinking cursor” in side it. This 
indicates the text box is ready for you to start typing in it. 
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o Message Editor: The Message Editor window displays. Make your 
selections for the text using the available buttons (font, font size, etc.) and 
type your text in the “text edit” field. Click OK to save the information and 
the text box will be inserted on the slide. 

 
 
To exit “text edit mode” while using the “Edit in Place” method, simply click off the note, 
balloon or text box to deselect it. 
 
 
Message Styles and Type 
Once you insert a Message object on a slide, you can change its “style” and its “type” at 
any time without recreating it from scratch. The process for doing this is the same for all 
Message objects. 
 
To change a Message object’s style and / or type: 
 

Using “Edit in Place” message editing: 
 
 Single click the message object to select it. 

 

 Click the Message Type  button on the Context Sensitive Toolbar. 
 

 The Message Type window displays. Select: 
 

o A “message style” from the first list. 
 

 
 
 

o A “message type” from the second list. 
 

 
 

 Click OK to save and apply the selections. 
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Using “Message Editor” message editing: 
 
 Double click the Message object. 

 

 The Message Editor window displays. Click the Message Type  button. 
 

 The Message Type window displays. Select: 
 

o A “message style” from the first list. 
 

o A “message type” from the second list. 
 

 Click OK to save selections and to close the Message Type window. 
 

 Click OK to close the Message Editor window and to apply changes. 
 
 

Select a new message type in the Message Type window to change a Message object from 
a note to a balloon to a text box and so on as needed without recreating the Message 
object from scratch. 
 
 
Message Object’s Background Color 
You can change the background color of a note or balloon while the Message object is 
selected (using the “Edit in Place” message editing method) or from inside the Message 
Editor window. 
 
To edit a note or balloon object’s background color while using “Edit in Place”: 
 
 Single click the note or balloon to select it. 

 

 Click the Background Color  button on the Context Sensitive Toolbar. 
 

 The Background Color window displays. Move your cursor over the palette and 

when the cursor changes to a “pointing hand”  shape, click to select a color. 
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 Click OK to apply the selected color to the Message object. 
 
 
To edit a note or balloon object’s background color while using “Message Editor”: 
 
 Double click the note or balloon to open the Message Editor. 

 

 In the Message Editor window, click the Background Color   button. 
 

 The Background Color window displays. Move your cursor over the palette and 

when the cursor changes to a “pointing hand”  shape, click to select a color. 
 

 Click OK to save the selection and to close the Background Color window. 
 

 Click OK to close the Message Editor window and to apply the selected color. 
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Message Object Alignment Tools 
When the Message object is selected (not in text edit mode), three object “alignment” 
buttons display on the Context Sensitive Toolbar. These buttons can be used to align a 
selected Message object on the slide. 
 
To align a Message object on a slide: 
 

 Single click on the desired Message object. 
 

 Click the:  
 

o Center Horizontally   button to horizontally center the selected 
object on the slide. 
 

o Center Vertically  button to vertically center the selected object on 
the slide. 
 

o Center  button to center (both horizontally and vertically) the 
selected object on the slide. 
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Message Text Options 
While working with Message objects (notes, balloons, text boxes), you will want to 
customize the various attributes that can be applied to the textual content. Text options 
include: font, font size, attributes (italic, bold, underline), text color, text alignment within 
the Message object and hyperlink capability.  Each of these options is available while  
editing using: 
 
 Edit in Place: Double click the Message object so that a “blinking cursor” 

displays inside it. This indicates you are in “text edit” mode and a Context 
Sensitive Toolbar is available with various buttons for text editing options.  
 

 
 

 Message Editor: Double click the Message object to open the Message Editor 
window. The text option tools are available within this window (as shown in the 
image below). 
 

 
 
 
To edit text in a Message object: 
 
 Double click on the Message object. Depending on the “message editing” 

method used, either a Context Sensitive Toolbar (for “Edit in Place” message 
editing) or a Message Editor window (for “Message Editor” message editing) 
displays. 
 

 Highlight the text you want to edit (either in the Message object itself or within the 
text edit field in the Message Editor window). 
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You MUST highlight the text you want to edit BEFORE applying any changes. 
 
 Click the applicable option to make the desired text edit: 

 
o Font: Select a new font from the Font list. 

 

 
 

If the desired font does not display in the “Font” list, but it is a font available on your 
computer, scroll down to the bottom of the list and select the “Show All Fonts” option. 
 
 

o Font Size: Select a new text size from the Font Size list. 
 

 
 

o Italic: Click the Italic  button to set the selected text in italics. 
 

o Underline: Click the Underline  button to underline the selected 
text. 
 

o Bold: Click the Bold  button to bold the selected text. 
 

o Text Color: Click the Text Color  button. In the Text Color window, 
select a color by clicking on it and then click OK to close the window. 
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o Left Align: Click the Left Align  button to left align the text in the 
Message object. 
 

o Center Align: Click the Center Align  button to center the text in the 
Message object. 
 

o Right Align: Click the Right Align  button to right align the text in 
the Message object. 

 
 
You do NOT have to highlight text in order to apply an alignment option. However, you 
must apply an alignment option to each section of text separated by a “carriage return” 
(each time you hit the “Enter” key to start a new paragraph or line of text). 
 

o Hyperlink: Click the Hyperlink  button. In the Hyperlink window that 
displays, make your selections as required and click OK to close the 
window. 

 

See the chapter on “Hyperlinks” for more information on creating clickable text links. 
 
 To exit text edit mode while using the message editing option: 

 
o Edit in Place: Click off the Message object to deselect it. 

 
o Message Editor: Click OK to save the changes and to close the 

Message Editor window. 
 
  
 
Automatic Resize of Message Objects 
ViewletBuilder6.2 Enterprise offers an option on the message object’s context sensitive 
toolbar that allows you to automatically resize the message object as text is edited. This 
feature can be enabled / disabled at will. 
 
To enable “automatic” resizing of a Message object as you edit text: 
 
 Click on the Message object to load its Context Sensitive Toolbar. 

 

 Click the Automatically size message to fit when editing  button. 
 

 Double click to Message object to enter “text edit” mode. 
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 If you selected for “message editing”: 
 

o Edit in Place: As you edit text, the object automatically resize as you type 
directly in the Message object. 
 

o Message Editor: The Message Editor displays. Once you click Apply or 
OK to save the text edits, the Message object will be automatically 
resized. 

 
If enabled, you can quickly “turn off” the auto-resize Message object feature by clicking it 
to deselect it on the Context Sensitive Toolbar at any time while editing a Message object. 
 
 
To manually resize a Message object: 
 
 Single click on the Message object to select the object itself (not in text edit 

mode). A “bounding box” (dotted rectangle) will display around it. 
 

 
 

 Move your cursor over one of the gnodes (grab handles). When the cursor 
changes to a “double arrow” shape, hold down the left mouse button and drag to 
resize the Message object. 
 

 
 

If you manually resize a Message object, if enabled, the “auto-resize” Message object 
feature will be disabled for that Message object only until it is again selected. 
 
 
 Let go of the left mouse button to complete the resizing action. 
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To move a Message object on a slide: 
 
 Click the object to select it so that a “bounding box” (dotted rectangle) displays 

around it. 
 

 Point your cursor over the selected Message object. When the cursor changes to 

a “hand”  shape, hold down your left mouse button and drag the object to its 
new location on the slide. 
 

 
 

 Let go of the left mouse button to drop the object into place. 
 
 
 
To attach audio to a Message object: 
 
 Click the object to select it so that a “bounding box” (dotted rectangle) displays 

around it. 
 

 Click the applicable Attach Sound button on the Context Sensitive Toolbar. 
 

  Attach Sound to Note 
 

  Attach Sound to Balloon 
 

  Attach Sound to Text Box 
 

 In the Sound window that displays, insert or record a sound file. 
 

 Click OK to save the sound file and attach it to the Message object. 
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To remove a Message object from a slide: 
 
 Click on the Message object to select it. 

 

 Click the Delete  button on the Context Sensitive Toolbar. The selected 
object will be deleted. 

 
 
If you accidentally delete a Message object and this was the last action you performed, 
click the “Undo” button or press “Ctrl + Z” to undo the deletion. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Format Painter 
The Format Painter may be used to quickly change text properties in notes, balloons and 
text boxes. It can also be used to change properties of a shape object’s border (color, 
width) and fill color based on another shape.  
 

 
 
To use the Format Painter to apply text attributes from one message object to another: 
 Make your changes to text in your message object. 
 Click on the text (or click anywhere inside the text) that will be copied from. 
 Click the Format Painter. 
 Click on subsequent text objects to apply this formatting from the first selection. 
 Continue clicking on text on the current or any other slide to apply the formatting. 
 When you are finished, click the Format Painter to deselect it. 

 
 
To use the Format Painter to copy a shape’s attributes and apply them to other shapes: 
 Make your changes to the shape as desired and then make sure it is selected. 
 Click the Format Painter. 
 Click on subsequent shapes to apply the formatting. 
 When you are finished, click the Format Painter to deselect it. 

 
 

Use the Format Painter to quickly match the format of a selected object or shape across 
multiple slides. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Dictionary, Spell Check, Search and Replace 
ViewletBuilder6.2 Enterprise offers various tools to help you make sure that your content 
is accurate, typos are caught and corrected, and grammar rules are followed. These 
features include: 
 

 Dictionary: Set your dictionary to one of several languages. The dictionary 
helps you catch unwanted typos and allows you to build it for more complex 
content by adding custom words. 
 

 Spell Check: Enable the “Spelling Mistakes” option from the View menu to 
automatically check text in message objects against the selected dictionary. 
Incorrectly spelled words, or words not recognized by the dictionary, will be 
quickly identified by a red, squiggly underline. 
 

 Search and Replace: Use this tool to quickly search for and replace a specific 
word (or even a phrase) on a message by message basis or throughout the 
entire project. 

 
 
To set your dictionary and spell check preferences: 
 Select Edit > Preferences from the Menu bar. 
 Select the Spelling tab. 
 Select a language to use for the spell check dictionary from the list. 
 Select additional options for the spell check as needed. 

 
 
To enable or disable the Spell Check tool: 
 
 To enable the Spell Check tool, select View > Spelling Mistakes from the Menu 

bar. 
 

 
 

 When a word is incorrectly spelled or is not recognized by the selected 
dictionary, it will be designated with a “red squiggly underline”.  
 

 
 



 
 
 

VB6.2 Enterprise User Manual Page 160 February 2010 

 To disable the spell check tool, select View from the Menu bar. 
 

 If the Spelling Mistakes option has a checkmark next to it, click it to remove the 
checkmark to deselect the tool. 

 
 
To correct a typo using the right click menu: 
 
 Click anywhere in the text where the typo appears (as indicated by the red 

squiggly underline). 
 

 Right click to display the shortcut menu. 
 

 At the bottom of the shortcut menu, select the appropriate option: 
 

 
 

o Replace: Select this option to display a list of suggested words to use to 
replace the “selected” incorrect text. 
 

o Replace All: Select this option to display a listed of suggested words to 
use to replace all instances of the “selected” incorrect text throughout the 
entire project.  
 

o Ignore All: Select this option to ignore all instances of the “selected” 
incorrect text throughout the project. 
 

o Learn: Select this option to add the “selected” incorrect text to the 
dictionary. 

 
 

To add custom words not recognized by the Spell Check tool to the dictionary, select the 
“Learn” option from the shortcut menu. 
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To use the Search and Replace tool: 
 

 Click the Search and Replace   button on the Main Toolbar. 
 

 The Search and Replace window displays. Two tabs are available: Search and 
Replace.  
 

 
 

 To search for a specific word or phrase:  
 

o Select the Search tab if it is not already selected by default. 
 

o In the Text field, type in the word or phrase you want to search for. 
 

o Select the Case Sensitive option to narrow results. 
 

 
 

o In the Direction area, select Forwards to search from this point in the 
project forwards, or select Backwards to search from this point in the 
object backwards.  
 

 
 

o In the Slides area, select: 
 
-Current to search the current slide. 
-From and enter a number in each of the fields provided to search from a 
specific slide to a specific slide based. 
-All to search all slides within the project. 
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o Click the Find Next   button to start the search operation. 
 

 
 To replace a specific word or phrase: 

 
o Select the Replace tab. 

 
o In the Text field, type in the word or phrase you want to search for. 

 
o In the Replace With field, type in the word or phrase you want to use as 

the replacement text. 
 

o Select the Case Sensitive option to narrow results. 
 

 
  

o In the Direction area, select Forwards to search from this point in the 
project forwards, or select Backwards to search from this point in the 
object backwards.  
 

 
 

o In the Slides area, select: 
 
-Current to search the current slide. 
-From and enter a number in each of the fields provided to search from a 
specific slide to a specific slide based. 
-All to search all slides within the project. 
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o Once all the information is entered / selected in the Replace tab, click the: 
 

-Replace All  to search for and replace all instances of the 
text with the text provided. 
 

-Replace  to replace the currently “selected” text found after 
clicking the Find Next button. 
 

-Find Next  button to find the next instance of the desired 
word or phrase entered in the Text field. 
 

 Once you are finished using the Search and Replace tool, click the red “x”  to 
close the window. Or, click Cancel to end the search and replace operation. 

 
 
While performing a Search and Replace operation, use the “Replace All” button to quickly 
replace a single word or phrase throughout the entire project with a single click action. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Working with Slides 
ViewletBuilder6.2 Enterprise projects are made up of slides, so it’s important to 
understand how to work with the most common slide features while building your project. 
This chapter introduces some of the most common features available while working with 
slides within your Viewlet project. 

Slide Types 
There are essentially five types of slides that you may insert into existing projects: 
 
 Blank slides 
 Screenshot slides 
 Image slides 
 PowerPoint Slides 
 Question Slides 

 

 
 
 
You can insert new slides into existing projects by selecting “Insert” from the Menu bar. 
Or, right click on a slide and select “Insert” from the shortcut menu. Either way, once you 
select “Insert” you will see a list of available new slide options for your project. 
 
These slide types may seem familiar. This is because these slide types are also the 
same options that are available when creating new projects. 
 
To insert blank slides: 
 
 Select a thumbnail. The inserted slide will be inserted right after this slide. 

 
 Select Insert  > Blank Slide from the Menu bar. Repeat these steps to insert 

additional blank slides. 
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To insert screenshot slides: 
 
 Select a thumbnail. The new screenshot(s) will be inserted right after this slide. 

 
 Select Insert > Screenshots from the Menu bar. 

 
 The Insert Screenshots window displays. Make your selections as needed and in 

the windows that display, follow the prompts to select options for screenshots. 
 
 

 
 
In ViewletBuilder6.2 for Windows, both Smart Capture and Manual Capture modes are 
available when capturing screenshots. In ViewletBuilder6.2 for Mac, only Manual Capture 
mode is currently supported, but Smart Capture (for Mac) is planned for a future version of 
ViewletBuilder6.2 for Mac. 

 
 
 Take your screenshots during the recording session. 

 
 End your screenshot session and new screenshots will be converted to slides 

and inserted into your existing project. 
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To insert image slides: 
 
 Select a thumbnail. The new image(s) will be embedded onto slides right after 

this slide. 
 

 Select Insert > Image Slides from the Menu bar. 
 

 Follow the instructions in the Select Images to Import window that displays for 
locating and selecting your image files. 
 

 
 

 Once your images are selected, click OK to insert the new image slides into your 
existing project. 
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To insert PowerPoint slides: 
 
 Select a thumbnail. The new PowerPoint slides will be inserted right after this 

slide. 
 

 Select Insert > PowerPoint Slides from the Menu bar. 
 

 Follow the instructions in the Select PPT file to Import window and those that 
follow to locate and select your PowerPoint slides. 
 

 
 

 Once your presentation slides are selected, click the Options button. 
 

 In the Options window, review your selections as needed in the General and the 
Fonts tab. Then, click OK to return to the Select PPT file to Import window. 
 

 Click OK to insert the PowerPoint slides into your existing project. 
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To insert question slides: 
 
 Select a thumbnail. The Question slides will be inserted right after this slide. 

 
 Select Insert > Question Slides from the Menu bar. 

 
 In the Add Questions window, make your question selections as you would when 

creating a new quiz project. 
 

 
 

 Click OK to insert the new question slides into your project. 
 
 



 
 
 

VB6.2 Enterprise User Manual Page 169 February 2010 

To insert duplicate slides quickly: 
 
 Click on a slide so that it displays in slide edit view. 

 
 Press Ctrl + D on your keyboard, or select Edit > Duplicate Slide from the Menu 

bar. 
 

 
 

 

Slide Properties 
Slide properties can be set for each slide. These properties include the slide name, 
duration and whether to include the slide in the table of contents (for viewing purposes). 
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To access slide properties: 
 

▪ Right click on a slide. 
 

▪ Select Slide Properties from the shortcut menu. Or, double click directly on the 
slide to open the Slide Properties widow. 

 
 
To edit slide properties: 
 
 Select a slide by clicking on it. 

 

 Click the Slide Properties  button on the Context Sensitive Toolbar. 
 

 In the Slide Properties window, edit the: 
 

 
 
 

o Name: This is the title of the slide displayed at the top of the slide while in 
Thumbnail View and along the timeline. 
 

o Duration: The amount of time the slide displays. 
 

o Options: Select this option if you want it included in the Table of Contents 
when viewed as a Flash file. 
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Slide Color 
Slide color is applied directly to the slide and can be changed on one or multiple slides. 
The slide color appears behind slide objects and embedded images. The color chooser 
remembers recent and custom color selections and has buttons for adding and deleting 
custom colors to make that functionality easier to use. 
 

 
 
 
To change slide color: 
 
 Select the slide or slides you want to work with. 

 

 Click the Background Color  button from the toolbar. 
 

 In the Background Color window, select a color. 
 

 Click OK to apply it to the selected slide or slides. 
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Slide Background Frame 
You can embed an image directly to a slide background. In fact, you can do this to one 
or multiple slides using the same image. In addition, images can be aligned in various 
ways on the slide or stretched as needed. 
 

 
 
To add a background image to a slide or slides: 
 
 Select the slide or slides you want to work with. 

 
 Right click and select Background Frames. 

 

 In the Background Frames window, click Load Image  button. 
 

 Locate an image file, select it and click Open. 
 

 Select a Layout option. 
 

 Click OK. 
 
 
In the “Background Frames” window, click “Show Preview” to view a preview of the 
selected background frame image. 
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To delete a background frame: 
 
 Right click a slide and select Background Frames. 

 

 In the Background Frames window, click the Remove Background  button. 
 

 Click OK. 
 
 

Moving Slides 
There are various ways to move slides with in a project. The easiest way to do it is while 
working with thumbnails. 
 
To move slides using drop and drag: 
 
 Make sure the Thumbnails tab is displayed. You can work in this view or while it 

is expanded in full view so that only thumbnails are displayed. 
 

 Select the slide (or slides) you want to move by clicking on them. 
 

 Hold down the left mouse button and drag the slide(s) to the new location and 
drop into place. 

 
 
To move slides using cut and paste: 
 
 Make sure the Thumbnails tab is displayed. 

 
 Select the slide you want to move. 

 

 Click the Cut  button on the toolbar. 
 

 Click on the slide where you want to insert the “cut” slide next to. 
 

 Click the Paste  button on the toolbar. 
 

 

Click the “Undo”  button to immediately undo cut and paste operations. 
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Deleting Slides 
You can remove slides from a project while in Slide Edit view or while working with 
thumbnails. The choice is up to you. However, if you are deleting multiple slides at the 
same time, you will need to do this while working with in the Thumbnail tab. 
 
 
To delete a single slide: 
 
 Select the thumbnail or click on it while in slide edit view (so that it is the current 

slide). 
 

 Click the Delete  button on the toolbar. 
 

 A Delete warning window displays. Read the information in it and click the  

Yes  button to confirm and complete the deletion. 
 
 
 
To delete multiple slides: 
 
 Select the slides you want to delete while viewing thumbnails. 

 

 Click the Delete  button on the toolbar. 
 

 A Delete warning window displays. Read the information in it and click the  

Yes  button to confirm and complete the deletion. 
 
 

The Hidden Slide 
ViewletBuilder6.2 Enterprise offers you the option of hiding a slide instead of deleting it. 
This feature is handy because instead of deleting the slide, it will hide it so that it will not 
display while previewing or publishing the project, but can later be unhidden when 
needed. 
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The main features of working with hidden slides include: 
 
 The thumbnail for a hidden slide has an X in the lower left corner. 

 

 
 
 

 If you select a hidden slide in thumbnails, it will display in slide edit view at 50% 
opacity. 
 

 If you use slide navigation arrows to go from slide to slide, hidden slides are 
skipped. 
 

 The duration of hidden slides is ignored in the times in the Timeline. 
 
 
To hide or unhide a slide: 
 
 Click on the slide (while in slide edit view) or slides in thumbnail view. 

 

 To hide a slide, click the Hide Slide  button on the Context Sensitive 
Toolbar to hide the slide. 

 
 
Hidden slides will not display (or be heard) when previewing a project; however, they will 
remain in the slide count. 
 

 To display a slide, click the Show Slide  button on the Context Sensitive 
Toolbar to display the slide. 

 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Audio 
ViewletBuilder6.2 Enterprise allows you to add sound to your project. You can import 
sound files or record them directly while working in ViewletBuilder6.2 Enterprise. Audio 
files may be attached directly to a slide or various slide objects such as balloons, notes, 
text boxes and shapes. You may also export sound from projects. And, there is a feature 
that allows you to add a background sound track (independent of sound attached to 
slides or slide objects) to your project. 
 
In the Sound window, select the recording option to use when recording audio for slides 
or other slide objects. 
 
 

 
 
 
To attach an external audio file to a slide or a slide object: 
 
 Click on the slide or slide object to select it. 

 

 Click the Attach Sound  button on the Context Sensitive Toolbar.  
 

 In the Sound window, click the Load Sound  button. 
 

 Select a sound file and click Open to return to the Sound window. 
 

Supported sound file formats include MP3, RAW, AIF, WAV and AU. 
 
 
 
The RAW Audio File Format (New in ViewletBuilder6.2 Enterprise) 
ViewletBuilder6.2 Enterprise now supports the RAW audio format. A “raw” sound file can 
contain audio in any codec, but is usually used with PCM audio data. So, if you have 
“raw” audio files, you can now import them into your Viewlet projects. 
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 Click Open to return to the Sound window. 
 

 In the Sound window, click OK. 
 
To record sound inside ViewletBuilder6.2 Enterprise: 
 
 Click on the slide or slide object to select it. 

 

 Click the Attach Sound  button on the Context Sensitive Toolbar. The 
Sound window displays. 
 

 Optional: (New in ViewletBuilder6.2 Enterprise) 
Select the input device to use for your sound recording. To do this: 

o Select the Recording Options  button. 
o In the Recording Options window that displays, select the Input Device 

you want to use for recording audio from the list. 
 

 
 

o Click OK to apply the selection for the sound recording input device. 
 

 The Sound window displays. Click the Record   button. 
 

In order to record audio, your computer must have a sound card. ViewletBuilder6.2 
Enterprise records audio using the MP3 format. This reduces file sizes in projects 
containing audio. 
 
 Speak into your system’s microphone to record. 

 
 
A “Countdown Timer” will display prior to recording audio if you selected the “Display 
Countdown Timer” option when setting up program preferences (Edit > Preferences > 
General tab).  Start speaking after the timer countdown is complete. 
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 Press the Stop  button to end the recording. 
 

 Click OK to attach the recording to the slide or slide object. 
 
 
To preview a sound file in the Sound window: 
 

 In the Sound window, press the Play  button to listen to the sound file 
attached to the slide or slide object. 
 

 Click OK to close the Sound window. 
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You can listen to sound files attached directly to slides by clicking on a slide. Then, click 
the “Attach Sound to Slide” button. In the “Sound” window that displays, click the 

“Previous Sound”  button or the “Next Sound”  button. This will move you 
automatically to the applicable slide and the sound attached to it in the “Sound” window. 
Click “Play” to preview the sound. Repeat these steps while in the “Sound” window to 
listen to slide sounds throughout the project without closing the “Sound” window. 
 
 
To remove sound attached to a slide or slide object: 
 
 Click on the slide or slide object to select it. 

 
 Click the Attach Sound button on the Context Sensitive Toolbar. 

 

 In the Sound window, click the Delete Sound  button. 
 

 Click OK to close the Sound window. 
 
 
To export sounds from your project: 
 
 Before exporting any sound files from your project, create a folder outside of 

ViewletBuilder6.2 Enterprise to save your exported sound files in 
(recommended). 
 

 Select File > Export from the Menu bar. 
 

 Select Sounds. 
 In the Export Sounds window, select the slides to export: 
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o Current Slide: Only the sound attached to the current slide and any 
attached to slide objects will be exported. 
 

o From: Enter a starting slide number in the first field and an ending slide 
number in the second field. Sound attached to the slides (and objects on 
the slides) in this sequence will be exported. 
 

o All: All sound attached to slides and slide objects will be exported. 
 

 In the Save File In window, select a folder to save the exported audio files in. 
 

 Click Save. 
 

Exported sound files are saved in the same format (and with the same file name) as they 
have in the project prior to being exported. 

 

Events – Actions “Play Sound” Options 
When working with Events and Actions, you can add a “Play Sound” action to many 
different Events such as when a slide loads or unloads, when a mouse rolls over an 
object or area of the slide, when the user clicks and more. The “Play Sound” action has 
some synchronicity and concurrency features for ultimate sound control during Viewlet 
playback. 
 
Synchronicity (Play Sound Action) 
In the Action window, when the Action Type of Play Sound is selected you have the 
ability to determine when your sound file will end. 
 

 
 
In the Synchronicity area, select the Wait for the sound to complete before 
advancing to the next action or slide if desired. 
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Concurrency (Play Sound Action) (New in ViewletBuilder6.2 Enterprise) 
A new “Play Sound” action option includes selections for further controlling when the 
sound files plays along with other sounds on the slide. In the Concurrency area, select 
the desired option: 
 
 Concurrent Playback – Play concurrently with other sounds. 
 Privileged Playback – Stop all other event sounds. 
 Exclusive Playback – Stop all other sounds. 

 

 
 
 

Sound Quality for Published Project 
Please refer to the Project Properties chapter for information regarding how to set up 
sound quality options for your published project. 
 

Background Soundtrack 
As discussed previously in this chapter, audio may be attached directly to a slide as well 
as to other slide objects. You may also attach a background sound track to your 
published project. This sound track is independent of sound attached to slides and slide 
objects and plays in the background when the Viewlet is played. Please refer to the 
Project Properties chapter for more information on adding a background soundtrack to 
your Viewlet.  
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Images 
Images may be used in projects in a few different ways. One option is to create an entire 
project made up of image files. When creating image projects or when inserting image 
slides, images are embedded as slide background frames.  When used in this way, 
images cannot be moved around the slide. 
 
Multiple images may be used as part of a slide’s background frames. See the chapter on 
“Background Frames” for more information. 
 
You may also insert images onto slides as slide objects. When inserted on the slide, 
images may be resized, moved on the slide, converted to a hyperlink object, become a 
rollover event, have its transparency level modified and more. And, multiple images may 
be inserted on the same slide. 
 
Let’s look at some ways to work with images and slides. 
 
To insert an image on to a slide: 
 
 Select the slide you want to insert the image on. 

 

 Click the Insert Image  button on the Object Toolbar. 
 

 In the Insert an Image window, browse to locate the image file. 
 
 
Supported image file formats include JPEG, GIF, TIFF, JPG, TIF, PNG and BMP. 
 
 
 Select the image file and click Open. The image is inserted on the slide, ready 

for editing. 
 

 
To move an image on a slide: 
 
 Select the image by clicking on it. 

 
 Move your cursor over the image and when the cursor changes to a hand shape, 

hold down the left mouse button. 
  

Drag the image (while holding down the left mouse button) to its new location on 
the slide. 
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To resize an image on a slide: 
 
 Select an image by clicking on it. 

 
 Point your cursor over one of the grab handles. 

 
 When the cursor changes to an arrow, hold down your left mouse button. 

 

 
 

 Drag the grab handle (while holding down the left mouse button) to resize the 
image. 

 
 
 
To change an image’s opacity level: 
 
 Select an image by clicking on it. 

 
 Enter a value in the Opacity field on the Context Sensitive Toolbar. 

 

 
 

 Press enter to apply the new opacity level. 
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To layer images (and other objects): 
 
 Right click on the image. 

 
 Select Arrange from the shortcut menu. 

 
 Select an arrangement option from the fly-out menu. 
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To view and/or modify image properties: 
 
 Click on the image to select it. 

 

 Click the Image Properties  button on the Context Sensitive Toolbar. 
 

 In the Image Properties window, view/edit the Name, Location & Size and Timing 
as desired. 
 

 
 

 Click OK to close the Image Properties window. 
 
 
 
To create an image event: 
 
 Click on the image to select it. 

 

 Click the Events  button on the Context Sensitive Toolbar. 
 

 In the Image Events window, select an events tab and choose the desired action. 
 

 Click OK to apply. 
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To delete an image: 
 
 Select the image. 

 

 Click the Delete  button on the Context Sensitive Toolbar.  
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Background Frames 
The most popular Viewlet projects have slides that contain embedded images as part of 
the background. These background images are known as Background Frames. This 
chapter discusses how to work with single and multiple slide background frames, an 
important component of many Viewlet projects. 

 

Background Frames – Single Frame 

 

 

To access the Background Frames window: 

 Select the desired slide in slide or thumbnail view. 
 

 Right click and select Background Frames. The Background Frames window 
displays. 
 

 You can also double click on the frame along the Timeline to display the 
Background Frames window. 
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To add a background frame to a slide with detailed settings: 
 

 In the Background Frames window, click the Add Frame button.  
 

 
 

 The Background Frame window displays. Click the folder button to search for 
and select an image for the frame. 
 

 
 

 Set Options, Location & Duration settings as desired. 
 

 Click OK. 
 

 Click OK in the Background Frames window to load the selected frame. 
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To directly load a frame from the Background Frames window: 
 

 In the Background Frames window, select the Load Image button. 
 

 
 

 Browse for and select an image. 
 

 Click Open. 
 

 Click OK. 
 
 
To delete a background frame: 
 

 In the Background Frames window, click the Remove Background button. 
 

 
 

 Click OK to remove the background frame. 
 
 

If you accidentally delete a background frame from a slide (and this was your last action), 
simply press “Ctrl + Z” to undo this last action. 
 
 
To expand/collapse the Background Frames window: 
 

 In the Background Frames window, click Show Preview  button 
to expand the window. 
 

To collapse the window, click the Hide Preview  button. 
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To choose the layout for the frame: 
 

 In the Background Frames window, select an orientation for the image from the 
Layout list. 
 

 
 

 Click OK to close the Background Frames window. 
 
 
To change zoom selection of frame Preview: 
 

 To zoom in, click the Zoom In button. 
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 To zoom out, click the Zoom Out button. 
 

 
 

 To fit the image in the Preview panel, click the Scale to Fit button. 
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Background Frames – Multiple Frames 
Slides may be comprised of multiple background frames. This most commonly happens 
when creating projects using Smart Capture (Windows only). Slides containing multiple 
background frames are animated during playback on the slide itself (similar to an 
animated GIF file). To edit a slide with multiple background frames, you will use the 
same steps as you would with the steps outlined for modifying a slide with a single 
background frame. There are, of course, a few additional options since you are working 
with multiple frames. 
 
For instance, following is an example of what a typical Background Frames window 
looks like when working with a slide containing multiple background frames. 
 

 
Background Frames Window with Preview Hidden 
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Background Frames window with Preview Displayed 
 

Key Frame 
Frames added after the first frame may or may not be key frames. If marked as a key 
frame, the key frame will completely replace the previous image in the sequence. If a 
frame is not marked as a key frame, the frame is just “painted” on top of the previous key 
frame, like an additional image layered on top of it. 
 
After creating a Screen Capture Project or adding new screenshots using Smart Capture 
(Windows only), if you look at a slide that has multiple animation frames on it, you will 
see that all but the first frame are NOT key frames. 
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To enable/disable a Key Frame: 
 

 In the Background Frames window, double click a frame. 
  

 In the Background Frame window, select the Key Frame option. 
 

 
 

 Click OK. 
 
 
 
To move a frame up/down within the list: 
 

 Select the frame in the list. 
 

 Click the Move Up  button to move the frame up in the list. 
 

 Click the Move Down  button to move the frame down in the list. 
 
 

 
To add a frame to the list of frames: 
 

 Click the Add  button. 
 

 In the Background Frame window, click Browse.  
 

 
 
 

 The Select Frame Image window displays. Select and image file and click Open. 
 

 In the Background Frame window, make other selections as needed and click 
OK. 
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To edit a background frame: 
 

 Select a frame in the list. 
 

 Click the Modify  button. 
 

 In the Background Frame window, make selections as desired. 
 

 Click OK. 
 
 
To delete a frame: 
 

 Select a frame in the list. 
 

 Click the Delete  button. 
 

If you accidentally delete a background frame from a slide (and this was your last action), 
simply press “Ctrl + Z” to undo this last action. 
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Previewing Multiple Background Frames 
When working with multiple background frames there are a few different features for 
navigating the Preview in addition to the zoom features previously covered. Use the 
following tools to quickly navigate through background frames. 
 
To navigate through multiple background frames: 
 

 In the Background Frames window, select a frame in the list. 
 

 Click the Show Preview  button, if applicable. 
 

 Click the appropriate button (below the preview pane): 
 

 
 
 

o First Frame 
o Previous Frame 
o Preview Background Frames 
o Next Frame 
o Last Frame 
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To highlight a selected frame: 
 

 In the Background Frames window, select a frame in the list. 
 

 Under the preview pane, select the Highlight Selected Frame option. 
 

 
 

 

If the selected background frame is a “Key Frame” the entire image will be highlighted. If it 
is not a Key Frame, only the image that “sits on top of the Key Frame” will be highlighted. 
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Using the Timeline to Access Background Frames 
If you prefer to edit your project using the Timeline, you can also easily access the 
Background Frames window to modify your background frames. 
 
Here’s an example of what a slide containing multiple background frames looks like 
along the Timeline: 
 

 
 
In the illustration above, Slide 27 contains multiple animation background frames. In fact, 
it contains three frames (as designated in the layer called “Background: 1 of 3). Frame 1 
is the selected frame and, in this example, is a Key Frame. Frame 2 and Frame 3 are 
part of the background frames, but will not display until selected along the Timeline. In 
this example, they are not selected. 
 
If you click on a specific background frame in the Timeline, it will display it in the Slide 
Edit area. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Shapes 
You may insert one or more shapes onto slides. This chapter provides an overview of 
the four basic tools for creating shapes and how to edit them. 
 

The Rectangle Tool   
The rectangle tool allows you to draw rectangles and squares on a slide. 
 

 
 
 
To insert a rectangle: 

 Click the Insert Shape  button on the Object Toolbar. 
 

 Click the Rectangle Tool  button on the Context Sensitive Toolbar. 
 

 Move the cursor over the slide until the cursor changes to a cross-hair  
shape. 
 

 Click on the slide and hold down the left mouse button. 
 

 Continue to hold down the left mouse button and drag to draw the rectangular 
shape. 
 

 Let go of the left mouse button to complete the shape. 
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The Ellipse Tool 
The ellipse tool allows you to draw circles or ovals on a slide. 
 

 
 
 
To insert an ellipse: 
 

 Click the Insert Shape  on the Object Toolbar. 

 Click the Ellipse Tool  button on the Context Sensitive Toolbar. 
 

 Move the cursor over the slide until the cursor until the cursor changes to a 

cross-hair   shape. 
 

 Click on the slide and hold down the left mouse button. 
 

 Continue to hold down the left mouse button and drag to draw the elliptical 
shape. 
 

 Let go of the left mouse button to complete the shape. 
 



 
 
 

VB6.2 Enterprise User Manual Page 201 February 2010 

The Lasso Tool 
The lasso tool allows you to create free-form shapes. 
 

 
 
 
To create a free-form shape: 
 

 Click the Insert Shape  on the Object Toolbar. 
 

 Click the Lasso Tool  button on the Context Sensitive Toolbar. 
 

 Move the cursor over the slide until the cursor changes to a lasso  shape. 
 

 Hold down the left mouse button and draw your shape. 
 

 Let go of the left mouse button when the free-form shape is complete. 
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The Poly Lasso Tool 
The poly lasso tool allows you to create polygonal shapes. 
 

 
 
 
To create a polygonal shape: 
 

 Click the Insert Shape  button on the Object Toolbar. 
 

 Click the Poly Lasso Tool  button on the Context Sensitive Toolbar. 
 

 Move the cursor over the slide until the cursor changes to a poly lasso  
shape. 
 

 Click on the slide to insert the first “anchor” point. 
 

 Drag the cursor to form the first leg of the polygon. 
 

 Click again to insert the next anchor point. 
 

 Drag the cursor again to form the next leg of the polygon. 
 

 Continue repeating these steps until the polygon shape is formed. 
 
 
To close one of the lasso shapes, make sure to click back on the starting point. Or, double 
click when you are ready to close the shape. 
 



 
 
 

VB6.2 Enterprise User Manual Page 203 February 2010 

Miscellaneous Shape Tool Features 
Once shapes are created, you may move, resize, recolor, and arrange them to create 
custom effects. 
 
 
To move a shape on a slide: 
 
 Click the shape to select it. 

 

 Move your cursor over the shape until the cursor becomes a grab hand  
shape. 
 

 Hold down the left mouse button and drag the shape to move it. 
 
 
To resize a shape: 
 
 Click the shape to select it. 

 

 Move your cursor over one of the grab handles until the cursor changes to an  
arrow shape. 
 

 Hold down the left mouse button and drag to resize the shape. 
 
 
To arrange the shape in a stack: 
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 Click the shape to select it. 
 

 Right click and select Arrange from the shortcut menu. 
 

 Select one of the arrange options to move the shape to that position in the stack. 
 

 
To delete a shape from the slide: 
 
 Click the shape to select it. 

 

 Click the Delete  button on the toolbar. 
 
 

Use the shape tools in ViewletBuilder6.2 Enterprise to create custom slide effects for your 
Viewlet project. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Grouped Objects Alignment, Distribution and Sizing 
ViewletBuilder6.2 Enterprise offers various alignment, distribution and sizing tools when 
working with multiple objects. This chapter provides an overview of working with these 
options. 
 
Alignment Tools 
Alignment tools are available for selected objects. The alignment tools are divided into 
two sections: 
 

1. Aligning selected objects within the group’s “bounding” box (as indicated by the 
dotted rectangle surrounding the selected objects).  
 

2. Aligning selected objects on the slide. 
 

 
To align two or more selected objects within the group’s “bounding” box: 
 
 Click on the first object to select it. 

 
 Hold down the Ctrl key while clicking to select additional objects. A “bounding 

box” surrounds the selected objects. It will be inside this bounding box area that 
the alignment will occur. 
 

 Click the applicable “group alignment” button for the selected objects: 
 

 
 

  Align Left Edges 
 

  Align Top Edges 
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  Align Right Edges 
 

  Align Bottom Edges 
 

  Align Horizontal Center 
 

  Align Vertical Center 
 
 
To align a single or multiple objects on a slide: 
 

 Select the object to select it. 
 

 If selecting multiple objects, hold down the Ctrl key while clicking on additional 
objects to select them. 
 

 Click the applicable “slide alignment” button for the selected object(s). 
 

 
 

  Center Horizontally (on slide) 
 

  Center Vertically (on slide) 
 

  Center (horizontally and vertically on slide) 
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Distribution Tools 
Distribution tools are available for selected objects. In order to use the distribution tools, 
three or more objects must be selected. A “bounding box” (dotted rectangle) displays 
around the selected objects and it is inside the perimeter of this bounding box the 
distribution will be applied. 
 
To use the distribution tools: 
 
 Click on the first object to select it. 

 
 Hold down the Ctrl key when clicking to select the additional objects. 

 

Three or more objects must be selected in order to access the distribution tools. 
 
 
 A “bounding” box displays around the selected objects. Click the applicable 

“distribution” button on the Context Sensitive Toolbar to apply it to the object 
group. 
 

 
 

  Distribute Left Edges 
 

  Distribute Top Edges 
 

  Distribute Right Edges 
 

  Distribute Bottom Edges 
 

  Distribute Horizontal Center 



 
 
 

VB6.2 Enterprise User Manual Page 208 February 2010 

 

  Distribute Vertical Center 
 
 
Sizing Tools 
Sizing tools are available for two or more selected objects. Use this tool if you want to 
quickly set all objects within a selected group to the same size. 
 
To resize two or more selected objects: 
 
 Click on the first object to select it. 

 

The order that you select your objects is IMPORTANT. The objects will be “resized” based 
on the first object selected in the group. 
 
 Hold down the Ctrl key when clicking to select the additional objects. 

 
 A “bounding” box displays around the selected objects. Click the applicable 

“sizing” button on the Context Sensitive Toolbar to apply it to the object group. 
 

 
 

  Make Same Width 
 

  Make Same Height 
 

  Make Same Size 
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Events and Actions – An Introduction 
ViewletBuilder6.2 Enterprise offers a robust set of events and actions that may be 
associated with slides and slide objects such as shapes and images to produce greater 
dynamics and a higher user interactive experience than ever before. This chapter 
provides an introduction into ViewletBuilder6.2 Enterprise’s events and actions features. 

Events 
Events may be defined as what happens when a certain scenario occurs. For example, 
a slide event may be the “On Load” event. This means that when the slide “loads” or as 
it “loads” this “loading” is an event.  
 

 
 
To create a slide event: 
 

 
 
 Right click on a slide directly and select Events from the shortcut menu. 
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 In the Slide Events window, select a tab: 
 

 
 

o On Load: This is when a slide is loaded. 
o On Unload: This is when you leave the slide. 
o On Key Pressed: This is when a key is press while on a slide. 

 
 Select an action as desired. 

 
 
The selections you make for the selected “action” will depend upon the action you select. 
 
 
 Click OK. 

 
 
 
To create a shape event: 
 
 Right click on a shape. 

 
 Select Events from the shortcut menu. 

 
 In the Shape Events window, select a tab: 

 

 
 

o On Click: This is when the user clicks on the shape. 
o On Rollover: This is when the user moves the mouse over the shape. 
o On Rollout: This is when the user has moved the mouse off the shape. 

 
 Select an action as desired. 

 
 Click OK. 

 

Don’t forget, you can add multiple actions to an events tab! 
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To create image event: 
 
 Right click on an image. 

 
 Select Events from the shortcut menu. 

 
 In the Image Events window, select an events tab. 

 

 
 

o On Click: This is when the user clicks on the image. 
o On Rollover: This is when the user moves the mouse over the image. 
o On Rollout: This is when the user has moved the mouse off the image. 

 
 Select an action as desired. 

 
 Click OK. 

 

Actions 
Actions are associated with Events and are “what will take place” once a particular event 
occurs. For example, an “On Click” event may have a “Goto Slide” action attached to it. 
So, when a user clicks a shape, for example, the project will “go to” a predefined slide. 
 

 
 



 
 
 

VB6.2 Enterprise User Manual Page 212 February 2010 

To attach an action to an event: 
 

 Select a slide, shape, image or other object (that supports events). 
 

 Right click and select Events from the shortcut menu. 
 

 In the Events window, select an events tab. 
 

 In the tab, click the Add  button. 
 

 In the Action window, select an action from the list. If applicable, make additional 
selections for the selected action as needed. 
 

 Click OK to close the Action window to return to the Events window. 
 

 Click OK to close the Events window. 
 
 
To arrange multiple actions for a given event: 
 
 In the Events window, select an events tab. 

 
 If multiple actions are listed in that tab, click an action to highlight it. 

 

 Click the Move Up  button to move the selected action up in the list. 
 

 Click the Move Down  button to move the selected action down in the list. 
 

 Click OK. 
 
 
To edit an action: 
 
 In the Events window, select an events tab. 

 
 Select the action to edit. 

 

 Click the Modify  button. 
 

 In the Action window, modify the action as needed. 
 

 Click OK to close the Action window. 
 

 Click OK to close the Events window. 
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To delete an action: 
 
 In the Events window, select an events tab. 

 
 Select the action to delete. 

 

 Click the Delete  button. 
 

 Click OK to close the Events window. 
 
 
If an event has multiple actions associated with it, the actions will be performed in the 
order in which they are listed in the “Action” window (from top to bottom). 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Buttons 
Buttons may be used to increase user interactivity within your Viewlet project. For 
example, if you want to give your viewer the control to advance through your Viewlet at 
their own pace, you can create your own series of customized buttons for them to do 
this. Or, you might provide buttons that, when clicked, will allow the viewer to skips 
ahead or to different parts of your project instead of just progressing through it in a linear 
fashion. 
 

 
 
 
To insert a button on to a slide: 
 

 Select the Insert Button  button on the Object Toolbar. 
 

 A button is inserted on the slide ready for editing. 
 
 

Don’t forget to add a “Pause Zone” to a slide that contains a button. This will give the 
viewer a chance to click the button for further navigation in the Viewlet. 
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To view/modify button properties: 
 
 Right click a button and select Button Properties from the shortcut menu. 

 
 In the Button Properties window in the: 

 
o Name area: Enter a name for the button in the field provided. Enter the 

Text to be displayed on the button in the field provided. 
 

 
 

o Location & Size area: Enter values for its Left and Top margin. Enter 
values for the Width and Height of the button. 
 

 
 

o Timing area: Select a timing option for the button to display on the slide 
from the drop down list. Enter values for any Start/Duration times as 
applicable. 
 

 Click OK. 
 
 
To move a button on a slide: 
 
 Click a button to select it. 

 Point your cursor over the button and when the cursor changes to a hand   
shape, hold down your left mouse button. 
 

 Continue to hold down the left mouse button and drag the button to its new 
location. 
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To select a button style: 
 
 Right click on the button and select Button Style. 

 
 In the Button Style window, select a style from the list. 

 
 Click OK. 

 
 
To add an event and action(s) to the button: 
 
 Right click on the button. 

 
 Select Events from the shortcut menu. 

 

 In the Button Events window, in the On Click tab, click the Add  icon. 
 

 
 

 In the Action window, select an action from the list. Make additional selections as 
needed. 
 

 Click OK to close the Action window. 
 

 Click OK to close the Button Events window. 
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To delete a button: 
 
 Select a button to delete. 

 

 Click the Delete  button on the toolbar. 
 
 

Use multiple buttons on a slide for non-linear navigation within the Viewlet. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Hyperlinks 
A hyperlink allows a user, with a single click, to perform an action such as jump to 
another section of the project, open an email, go to a web page and more. In 
ViewletBuilder6.2 Enterprise, hyperlink functionality includes text links and the ability to 
make other objects work as “clickable” links. This chapter covers the basics steps for 
creating hyperlinks in your Viewlet projects. 
 

 
 

Message Hyperlinks 
While message objects themselves cannot be set up as a hyperlink, a portion or all of 
the text inside can. These types of hyperlinks are known as text links. 
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To create a text link within a message object: 
 
 Highlight the text you want to use for the link. 

 
 Right click the text and select Hyperlink from the shortcut menu. 

  
 In the Hyperlink window, make sure the On Click tab is selected. 

 

 Click the Add  button. 
 

 In the Action window, select an action from the list. Make additional selections as 
needed. 
 

 Click OK to close the Action window. 
 

 Click OK to close the Hyperlink window. 
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By default, a text hyperlink will be blue underlined text. Once a hyperlink is created, you 
can change the link’s text attributes as needed. 
 
 

Miscellaneous Hyperlinks 
Any object that requires the user to click may be considered a link of some sort. 
Message (text) hyperlinks work the same as when you are creating an Event/Action 
setup. Links can also be set up to occur when an image loads, etc. Please refer to the 
chapter on Events and Actions Overview.  
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Interactive Zones – Common Features 
Interactivity is key to acquiring and maintaining your viewer’s interest. And, with the use 
of interactive zones within your Viewlet, you can gain valuable input from your viewers 
for training, marketing and even product development purposes. The Interactive Zones 
are a staple of ViewletBuilder6.2 Enterprise and have been in almost all of the previous 
versions. They provide dynamic results like Events and Actions, but focus on specific 
purposes. 
 
ViewletBuilder6.2 Enterprise offers five Interactive Zones: 
 
 Click Zone 
 Text Zone 
 Keystroke Zone 
 Pause Zone 
 Questions 

 
For purposes of this chapter, we are not including Hyperlinks or Events/Actions since 
they have already been covered in the previous chapters. 
 
The Interactive Zones (with the exception of the Pause Zone) have many elements in 
common. These include: 
 
 Only one zone per slide. 
 An input field OR a clickable area or button. 
 Audio option. 
 Response to user input in the form of a message or some other object for when 

the user answers correctly or incorrectly or doesn’t complete a response. 
 Scoring with points, attempts and time for answering. 

 
Let’s review each of these elements separately. 
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The One Zone Per Slide Rule 
Unlike other dynamic elements, Interactive Zones serve a specific purpose and 
therefore, only one zone may be on the slide at a time. If you try to insert multiple slides, 
you will see a Warning window the will inform you what type of zone the slide already 
contains. It will offer you the following Options: 
 

 
 
 Remove it. (Enhanced feature starting in ViewletBuilder6.2) 
 Replace it with a [selected zone]. 
 Add the [selected zone] to a new empty slide. 
 Add the [selected zone] to a copy of this slide. 

 
Select one of these options and click OK. 
 

Zone Interactive Area 
Each of the zones contain some type of “input area” or “zone” that the user will interact 
with and these will vary, depending upon the zone: 
 
 Click Zone: Contains a click area that covers a portion of the slide. This area 

(transparent in the published project) is where the user must click to correctly 
respond. 
 

 Text Zone: Contains a text input field. The user must input the answer correctly 
into this field. 
 

 Keystroke Zone: Contains a zone that shows the Viewlet author (not the viewer) 
the keys that the viewer must press in the published file to answer correctly. This 
“zone” will not display in the published file. 
 

 Pause Zone: Though not technically a zone, when this zone is inserted on a 
slide, it will insert a red triangle (not viewable in the published file) in the bottom 
right corner of the slide and the slide will pause. 
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 Question: These slides will vary in look, but they will contain some type of input 
button, field or “object” to select, input or drag for the answer. These slides may 
also contain a button to “Submit” the input. 

 
You can attach audio to different parts of a zone. To see what parts support audio, click 
the object and look at the Context Sensitive Toolbar. If a “sound” button displays for the 
selection, then you can attach audio to it. 
 

Response to User Input 
When creating an Interactive Zone, you should offer some type of response to the user 
after they’ve completed their input. In its simplest form, this response may simply be a 
message object that informs the user they’ve answered correctly. Or, it may be as 
elaborate as a combination of a message that, when the user answers incorrectly, a 
message appears telling them this and directing them to click a link to launch a quick 
training movie before continuing or to just continue without this option, etc. The choice 
as to how simple or complex the response will be is up to you. You even have the option 
to remove all responses to user input as well, if you desire.  
 
 

 
 
Response objects will only display when the user submits a response or the zone has 
“timed out”. 
 
 
To create a response message object: 
 

 Insert an Interactive zone and, if applicable, three default response text 
messages will display. 
 

o Green message object: This will display if the user answers correctly. 
o Lime message object: This will display if the user did not complete the 

message. 
o Red message object: This will display if the user answers incorrectly. 

 
 Select a message object and edit as you would any other message object with 

regards to text and message type/style itself. 
 

 Move and stack the messages as desired on the slide. 
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To edit a response object: 
You may change a response object from a message to an image or shape or none at all. 
In addition, you may change how this response object responds in reaction to a certain 
user action and the duration a response displays on a slide. These features are part of 
ViewletBuilder6.2 Enterprise’s events/actions tools. 
 
 Click on the “zone” area for the Interactive Zone. 

 

 Click the Events  button on the Context Sensitive Toolbar. 
 

 In the Slide Events window, click the appropriate tab. For example, to change the 
response that will display when the user answers correctly, select the On Correct 
tab. 
 

 
 

 Select the action to modify and click the Modify  button. 
  

 In the Action window, edit as desired and click OK. 
 

 In the Slide Events window, select another tab and repeat this process as 
desired for each of the response objects. 
 

 When complete, click OK to close the Slide Events window. 
 
 
To delete a response object: 
 
 Click the response object. 

 
 Press Delete on your keyboard. 

 

Scoring Options 
Several of the Interactive Zones offer you the option of scoring user input. When 
available, these scoring options include points, attempts and time to complete an 
answer. 
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To set up scoring options for an Interactive Zone: 
 

 
 
 Click on the zone’s input or zone field. 

 

 Click the Scoring  button on the Context Sensitive Toolbar. 
 

 In the Score window, three scoring options are available. To set: 
 

o Points:  Enter a number that will be used for the point value if the user 
answers the question correctly. 
 

o Attempts: Enter a number of times the user has to answer the question 
correctly. After this number is reached and if the question is not answered 
correctly, it will be marked as incorrect and the Viewlet will continue. 
Select the option to allow the question to be reanswered if the user 
navigates backwards in the project, if desired.  
 

o Time: To limit the amount of time a user has to answer a question, select 
the Enable a time limit for the question check box. Then, enter the 
Hours/Minutes/Seconds as desired. 

o  
 Click OK to apply the scoring options and to close the Score window. 

 
For more information on working with Interactive Zone features covered in this chapter, 
please contact support@qarbon.com. 
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Click Zone 
The Click Zone is one of the most popular interactive zones used in ViewletBuilder6.2 
Enterprise. A Click Zone may be used to increase the effectiveness of your Viewlet, 
forcing the user to interact with it by clicking on a portion of the slide in order to continue. 
 

 
 
This chapter highlights the Click Zone, providing information on this zone not already 
covered in a previous chapter, Interactive Zones – Common Features. 
 
 
To create a Click Zone: 
 

 Click the Insert ClickZone  button on the Object Toolbar. 
 

 By default, a click zone area and three response message objects will be 
inserted on the slide. 
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To edit the click area properties: 
 
 Double click on the click area or right click it and select Modify Click Area from 

the shortcut menu. 
 

 In the Click Area window, you have three “states” to set up for the fill (bucket) 
color and for the border (pencil) color: 
 

o Normal: Enter a value for the fill and for the border when the mouse is 
NOT over the click area in the Viewlet. 
 

o Rollover: Enter a value for the fill and border when the cursor moves on 
to the click area in the Viewlet. 
 

o Selected: Enter a value for the fill and border when the click area is 
“clicked”. 
 

o Select the Double Click to Select opton if you want the user to double 
click (instead of the default single click) to respond correctly. 

 

When the number is zero for any of the values, the fill/border color will be transparent. 
 
 Click OK. 

 
 
To move a click area on a slide: 
 

 Select the click area. 
 

 Move your cursor over the click area until the cursor changes to a hand  
shape. 
 

 Hold down your left mouse button and drag the area to its new location. 
 
 
To resize a click area: 
 
 Select the click area. 

 
 Move your cursor over one of the grab handles until the cursor changes to a 

double arrow. 
 

 Hold down your left mouse button and resize the area as desired. 
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To delete a Click Zone: 
 
 Select the click area of the Click Zone. 

 
 Press Delete on your keyboard. 

 
 
Click Area “styles” are applied to new Click Zones. 
 
 

 
 
 
For additional Click Zone features, please review the Interactive Zones – Common 
Features chapter. Or, email support@qarbon.com with any questions you may have. 
 



 
 
 

VB6.2 Enterprise User Manual Page 229 February 2010 

Text Zone 
Text Zones are another popular interactive features used in Viewlets by Viewlet authors. 
These zones may be added to slides when you require the user to answer questions by 
inputting text responses into a field. 
 

 
 
This chapter highlights the Text Zone, providing information on this zone not already 
covered in a previous chapter, Interactive Zones – Common Features. 
 
 
To create a Text Zone: 

 Click the Insert TextZone  button on the Object Toolbar. 
 

 By default, a text input field and three response message objects are inserted on 
the slide. 

 
 
To modify the text zone input field: 
 
 Double click the text field or right click it and select Modify Text Field from the 

shortcut menu. 
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 In the Modify Text Field window, enter information as needed: 
 

o For Correct Answers – One Per Line: Input the correct answers in the 
field provided. This is what the user will need to type in the field in order 
to answer correctly. For multiple answers, press the Enter key between 
each correct entry. 
 

o Case Sensitive: By default, user may enter responses using caps or not 
and the answers, if input otherwise properly, will be considered to be 
correct. To force a user to use capital letters (for proper nouns, etc.), 
select the Case Sensitive check box. 
 

o Wrap Text: Select the Wrap Text option to allow text to wrap inside the 
text field. 
 

o Password Field: To encrypt the user input while typing in the text field, 
select the Password Field check box. 
 
 

The Submit Key 
After inputting text, the user clicks the Submit Key to submit the answer. If you do not 
want to require the user to press a button after typing in a response in the text field, use 
the Auto option. When selected, once the user types in a response, after approximately 
three seconds, the Viewlet will automatically “submit” the input and respond accordingly. 
 

 
 

o Submit Key: Make a selection from the list. This will be what will be used 
for the viewer to submit the response. 

 
 

To force users to click the “Submit” button in order to submit the response, select “None” 
from the “Submit Key” list. 
 
 
 
To move the text field on the slide: 
 
 Select the text field. 

Mouse your cursor over the text field until the cursor changes to a hand  
shape. 
 

 Hold down the left mouse button and move the text field to its new location. 
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To resize the text field: 
 Select the text field. 

 
 Mouse your cursor over one of the grab handles until the cursor changes to a 

double arrow shape. 
 

 Hold down your left mouse button and drag the grab handle to resize the text 
field. 

 
 
To delete a Text Zone: 
 
 Select the text field. 

 
 Press the Delete key on your keyboard. 

 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Keystroke Zone 
A Keystroke Zone may be inserted on a slide to force the user to press an individual or 
combination of keys in order to continue with the Viewlet. This chapter highlights the 
Keystroke Zone features not already covered in a previous chapter Interactive Zones – 
Common Features. 
 

 
 
 
 
To insert a Keystroke Zone: 

 Select Insert KeystrokeZone  button on the Object Toolbar. 
 

 By default, a keystroke “object” that indicates the current key the user needs to 
press in order to answer correct will display along with response messages. 
Double click the “keyboard key object”. 
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To define the keystroke: 
 
 Right click on the keystroke object and select Define Keystroke from the 

shortcut menu. 
 

 In the Define Keystroke window, follow the instructions for defining a new 
keystroke or keystroke combination. 
 

 
 

 Click OK to apply. 
 
 

If you define a keystroke combination that is not compatible with Flash, an error will 
display, warning you of the issue. 
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Keystroke Zones & International Users 

If you expect your Viewlet will be viewed by an audience whose native language differs 
from what you’ve used in your Viewlet, when defining Keystroke Zones, a Warning 
window will display when a keystroke combination possibly represents a different key 
combination on international keyboards. Along with this warning, you will be presented 
with a Safe Key List to help you select a safer and more appropriate keystroke 
combination for “all” your global users. 
 
 

 
 
 
For more information on applying other Keystroke Zone features, review the Interactive 
Zones – Common Features chapter. Or, email support@qarbon.com. 
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Pause Zone 
The Pause Zone is used to pause the Viewlet on a particular slide. These zones are 
easy to use on slide and are most commonly used on slides that contain hyperlinks or 
buttons that allow the user to click when they decide to continue to play the Viewlet. 
 

 
 
 
Did you know that you can Pause a published SWF Viewlet by pressing the “space bar”? 
To toggle back into “play mode”, simply press the space bar again. 
 
 
To insert a Pause Zone on a slide: 

 Click the Insert PauseZone  on the Object Toolbar. 
 

 A red triangle will be inserted in the bottom right corner of the slide. This triangle 
indicates the slide will pause, but this triangle will not display in the Viewlet. 

 
 
To move a Pause Zone in the Timeline: 
 
 Click the Pause Zone layer to select it. 

 
 Select the object’s “rectangle” in the Timeline by clicking on it. 

 
 Hold down your left mouse button and drag the zone. 

 
 Let go of the left mouse button to drop it into place. 
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 A Timing Rule Change window displays. Read the information and click OK to 
change the timing rule to manual timing. 
 

 
 

 
 
To remove a Pause Zone from a slide: 
 

 Click the Insert PauseZone   on the Object Toolbar. 
 

 In the Warning window, select the Remove It option. 
 

 
 

 Click OK. 
 
 

You must preview the project in a browser to view the results of the Pause Zone. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
 



 
 
 

VB6.2 Enterprise User Manual Page 237 February 2010 

Question 
Turn your Viewlet into a testing or survey tool by using Question Slides. This chapter 
highlights the Question, providing information on this feature not already covered in a 
previous chapter, Interactive Zones – Common Features. 
 
 
What is the difference between a quiz and a survey question? A quiz question normally 
requires the user to provide a correct response and is usually scored. A survey question 
does not normally require a correct response and is therefore usually not scored. 
 
To insert a Question on an existing slide: 
 

 Click the Insert Question  button on the Object Toolbar. 
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 In the Question window that displays: 
 

 
 

o Select a Question Type from the list. 
 

o Type your Question in the field provided. 
 

o In the Scoring Mode area, select either Quiz or Survey to use for the 
scoring mode for the new question. 
 

 Click OK to insert the question on the slide. 
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Question Elements 
The “question type” determines the default elements of the Question zone. These 
elements normally include a text box for the question, text boxes for answers in a list, 
some type of “input” object for the user to click on to respond, submit button to submit 
the response and response message (or image) objects. 
 

Use stylesheets to standardize the “elements” that make up each Question zone for your 
projects. 
 
Let’s take look at the different question types (in general) and their default elements. For 
more information on specific question types, please refer to the “Review Question 
Types” section of the Quiz Project chapter. 
 
 
Choice Lists 
This question type requires users to select answers from a list of choice by selecting a 
radio button or check box next to each text option. The user then clicks a Submit button. 
If the question is a quiz, it will be scored. If the question is a survey, it will not be scored. 
So, this question type’s elements (by default) include: 
 

 
 
 Text box for the question 
 Radio buttons for users to select an answer 
 Text boxes containing possible answers 
 Submit button the user clicks to submit the response 
 Response message objects 

 

You can customize the default elements of any Question to best fit your project’s needs. 
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To modify the text box containing the Question zone’s question: 
 
 Double click the text box. 

 
 Edit the text as you would in any other message object. 

 
 
To add additional choices: 

 Click the Add Choice  button on the Context Sensitive Toolbar. 
 

 Repeat the step above for to add each new choice. 
 
 
To delete a choice option: 
 
 Select the radio button / check box or the text box of the choice you want to 

delete. 
 

 Press the Delete key on your keyboard. 
 
 
To set the correct responses: 
 
 Select the radio button / check box next to the choice you want to set as the 

correct response. 
 

 Click the Modify Choice  button on the Context Sensitive Toolbar. 
 

 Repeat these steps for each choice you want to set as the correct response. 
 

 If a choice is set as the correct response, click the Modify Choice button again 
to deselect it as the correct response. 

 
Each Question can contain one or more correct responses. The choice is up to you. 
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To change the radio button style: 
 
 Click on any of the radio buttons to select one. 

 

 Click the Choice Type  button on the Context Sensitive Toolbar to display 
a menu of options. 
 

 Select Radio Button   option from the list. 
 
 

Use the “Check Box” option as an alternative Choice Type for the Radio Button. 
 
 
 The Radio Button Style window displays. Select a style for the radio button from 

the list. 
 

 Click OK to apply the new style. 
 
 
To modify an answer text box: 
 
 Double click the text box. 

 
 Edit the text as you would in any other message object. 

 
 
To modify the Submit button properties: 
 
 Select the Submit button. 

 

 Click the Button Properties  button on the Context Sensitive Toolbar. 
 

 In the Button Properties window, edit the information as required. 
 

 Click OK. 
 
Refer to the chapter on Buttons for more information on modifying the “Submit” button. 
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To delete a Question from the slide: 
 

 Click the Insert Question   button on the Object Toolbar. 
 

 In the Warning window, select the Remove It option. 
 

 
 

 Click OK 
 

 
Text Input Fields 
This question type requires the user to respond to a question by typing a response into a 
text input field. The response is then submitted either automatically or by the user 
clicking the Submit button. This question may (quiz) or may not (survey) be scored.  
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This question’s default elements include: 
 
 Text box for the question 
 Text input field for users type their responses in 
 Submit button the user clicks to submit the response 
 Response message objects 

 
 
To modify the text box containing the Question zone’s question: 
 
 Double click the text box. 

 
 Edit the text as you would in any other message object. 

 
 
 
To modify the text input field: 
 
 Double click the text input field. 

 
 The Modify Text Field window displays. Enter information or make selections as 

follows: 
 

 
 

o Correct Answers – One Per Line:  If this question requires a correct 
response, type it in this field. This is what the user will need to type in the 
text input field in order to answer correctly.  For multiple answers, press 
the Enter key between each correct entry. 

 
Leave the “Correct Answers – One Per Line” field blank if the Question is not scored (a 
survey question). 
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o Case Sensitive: By default, user may enter responses using caps or not 

and the answers, if input otherwise properly, will be considered to be 
correct. To force a user to use capital letters (for proper nouns, etc.), 
select the Case Sensitive check box. 
 

o Wrap Text: Select the Wrap Text option to allow text to wrap inside the 
text field. 
 

o Password Field: To encrypt the user input while typing in the text field, 
select the Password Field check box. 
 

o Submit Key: Make a selection from the list. This will be what will be used 
for the user to submit the response. 
 

The Submit Key 
After inputting text, the user clicks the Submit Key to submit the answer. If you do not 
want to require the user to press a button after typing in a response in the text field, use 
the Auto option. When selected, once the user types in a response, after approximately 
three seconds, the Viewlet will automatically “submit” the input and respond accordingly. 
 

 
 
 
To force users to click the “Submit” button in order to submit the response, select “None” 
from the “Submit Key” list. 
 
 
 
 
To move the text field on the slide: 
 
 Select the text field. 

 

 Mouse your cursor over the text field until the cursor changes to a hand   
shape. 
 

 Hold down the left mouse button and move the text field to its new location. 
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To resize the text field: 
 
 Select the text field. 

 
 Mouse your cursor over one of the grab handles until the cursor changes to a 

double arrow shape. 
 

 Hold down your left mouse button and drag the grab handle to resize the text 
field. 

 
 
To delete an input field: 
 
 Select the text field. 

 
 Press the Delete key on your keyboard. 

 
 
 
ComboBoxes 
This question type requires users to answer a question by selecting a single answer 
from a list of answers contained within a drop-down list. Then the user clicks the Submit 
button to submit the response. So, this question type’s elements (by default) include: 
 

 
 
 Text box for the question 
 ComboBox for users to select an answer from a drop-down list 
 Submit button the user clicks to submit the response 
 Response message objects 
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To modify the text box containing the Question zone’s question: 
 
 Double click the text box. 

 
 Edit the text as you would in any other message object. 

 
 
To modify a ComboBox style: 
 

 Click the Choice Type  button on the Context Sensitive Toolbar. 
 

 Select ComboBox  from the list that displays. 
 

 In the ComboBox Style window, select a style from the list. 
 

 
 

 Click OK. 
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To set up and manage the ComboBox’s options list: 
 
 Double click on the Combobox. 

 
 The Modify ComboBox window displays. In this window: 

 

 
  
 

o To insert an answer: 

-Click the Add  button. 
-Type a value in the list area. 
 

o To modify an answer: 
-Select a value in the list. 

-Click the Modify  button. 
-Edit the highlighted value. 
 

o To set an answer as “correct”: 
-Click on the check box  next to the desired value. 
-Deselect the checkbox to remove the checkmark. 
 

o To move an answer up or down in the list: 
-Select the desired value. 

-Click the Move Up  button to move it up in the list. 

-Click the Move Down  button to move it down in the list. 
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o To remove an answer from the list. 
-Select a value in the list. 

-Click the Delete  button. 
 

 Click OK to save the list and to close the window. 
 
 
 
Ratings 
This question type gathers information from a user by posing a question such as “What 
is your overall level of satisfaction?” In response, the user is required to click along a 
“rating” scale and then click a Submit button to submit the response. This type of 
question is for surveys only and not scored.  
 

 
 
The (default) elements for this question type include: 
 
 Text box for the question 
 Rating scale the user clicks on in response to the question 
 Submit button the user clicks to submit the response 

 
 
 
To modify the text box containing the Question zone’s question: 
 
 Double click the text box. 

 
 Edit the text as you would in any other message object. 
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To change a Rating scale’s style: 
 
 Select the Rating object to select it. 

 

 Click the Modify Choice  button on the Context Sensitive Toolbar. 
 

 Select Rating  from the list. 
 

 The Rating Style window displays. Select a new style from the list. 
 

 
 

 Click OK to apply it. 
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To increase / decrease the rating scale: 
 
 Double click on the Rating object. 

 
 The Modify Rating window displays. Enter a number in the field provided for the 

Maximum Rating desired. 
 

 
 

 Click OK. 
 
 
 
To remove a Question from a slide: 
 

 Click the Insert Question  button on the Object Toolbar. 
 

 When the Warning screen displays, select Remove It. 
 

 
 

 Click OK to remove the Question from the slide. 
 



 
 
 

VB6.2 Enterprise User Manual Page 251 February 2010 

New Quiz Project Question Types:  
Drag and Drop & Click Map 
(New in ViewletBuilder6.2 Enterprise) 
 
ViewletBuilder6.2 Enterprise offers more than a dozen Quiz Project question types for 
both quiz (scored) and survey (non-scored) questions. Starting in ViewletBuilder6.2 
Enterprise, two new question types are available: 
 

Drag and Drop Question Type 
The Drag and Drop question type requires the viewer to match up items by dragging 
responses across columns. This question type can be used as a quiz (scored) question 
or as a survey (non-scored) question.  
 
 

 
 
This chapter highlights the two new Quiz Project Question Types, providing information 
not already covered in a previous chapter, Interactive Zones – Common Features. 
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As with any feature in ViewletBuilder6.2 Enterprise, there are several ways to achieve the 
same results.  Remember, access to different features when working with the Drag and 
Drop and the Click Map question types are also available via Context Sensitive toolbars 
and via right click shortcut menus. 
 
 
To create a Drag and Drop question: 
 

 Click the Insert Question  button on the Object Toolbar. 
 

 A Question window displays. Scroll down the list of Question Types and select 
Drag and Drop from the list. 
 

 Type your Question or instructions for the question in the field provided. 
 

 In the Scoring Mode area, select Quiz if the question will be scored, or select 
Survey if the question will not be scored. 
 

 Click OK and a slide with the new Drag and Drop question type will be created. 
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Drag and Drop Question Properties 
By default, the Drag and Drop question contains various elements (all of which are 
editable) when first created including: 
 
 Question Text: A text box displays at the top of the question elements with text 

entered in the Question field in the Question window when selecting the question 
type. If no text is entered into the field prior to creating the question, the default 
text will be Enter Question Here. 
 

 
 
For more information on working with Question Text, see the instructions “To Edit 
the Question Text” steps. Or, since Question Text is simply a slide text message 
object, review the chapter on Messages (for details on working with message 
objects like notes, balloons and slide text). 
 

 Drag Choices: The first column contains three text boxes, which are the 
responses that the viewer is instructed to “drag and drop” on the Drop Areas in 
the second column in order to answer the question correctly. The Drag Choices 
are simply message objects, so its style, type and text can be modified just like 
any other note, balloon or slide text (message) object.  
 

 
 
For more information on working with Drag Choices, see the instructions “To 
work with Drag Choices” steps. Or, to edit a Drag Choice’s style, type or text, 
review the chapter on Messages. 
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 Drop Areas: The second column contains three Drop Areas that, by default, are 
linked to their respective Drag Choice. This is the area on the slide where the 
viewer drops the Drag Choice on in order to respond. You can modify the opacity 
level, name, etc. of this area. 
 

 
For more information on Drop Areas, see the instructions “To work with Drop 
Areas” steps. If you plan to add a message object (such as slide text) next to or 
on the Drop Area to provide “visible text” for the viewer to see and associate with 
each Drop Area, review the chapter on Messages as needed. 
 

 Links: A dotted line displays between each Drag Choice and its associated Drop 
Area, signifying they are “linked” together. Links can be removed and added 
between new “pairs” of Drag Choices and Drop Areas as desired. 
 

 
 
For more information on links, see the instructions “To link / unlink Drag and Drop 
pairs” steps. 

 

Even though the Drag Choices and the Drop Areas are, by default, placed initially in a two 
column spread, you can move them around anywhere on the slide as desired. 
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 Submit Button: Once all of the appropriate responses are “dragged and 
dropped”, the viewer clicks this button to submit the answers. 
 

 
 
The button’s look, text and “on click” action may be modified (but it is not 
recommended unless absolutely necessary). For more information of working 
with buttons, review the chapter on Buttons. 
 

 Response Messages: One of three text boxes display to the viewer, by default, 
based on how they respond. These response messages are used for correct, 
incorrect and incomplete responses and may be edited. 
 

 
 
For more information on working with Response Messages, review the 
“Response to User Input” section in the Interactive Zones – Common Features 
chapter. 

 
To edit the Question Text: 
 Double click on the text box to enter text edit mode. 
 Edit your text and its attributes as desired. 
 Deselect the text box and then single click it to select the object itself. 
 Resize and move the text box as needed. 

 
 

Since “Drag Choices” are essentially the same as a message object, you can quickly edit it 
as you would any other message object with regards to changing its style, text content 
and text attributes using the buttons along the context sensitive toolbar, if desired. 
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To work with Drag Choices (using the Drag and Drop window): 
 
 Click on a Drag Choice to select it. 

 

 Click on the Modify Question  button. 
 

 The Drag and Drop window displays. Select the Question tab. 
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 Various options for working with Drag Choices are available: 
 

o To add a new Drag Choice + Drop Area pair: 
 

 Click the Add  button.  
 

 Select Add Drag Drop Pair from the shortcut menu that displays. 
 

 
 

 A Drag and Drop Pair window displays. 
 

 Select a message Type from the list. 
 

 Type the Text for the Drag Choice in the field provided. 
 

 Accept the title for the Drop Area Name or type a new one 
in the field provided. 
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The text used in the “Name” field will display over the Drop Area. You will see this “text 
label” on the Drop Area while editing your source file INSIDE ViewletBuilder6 Enterprise 
(it is used to identify its respective Drop Area). However, after you publish the file, this 
text will NOT be visible to the viewer in the SWF file. If you want to have the Drop Area 
“labeled” with text that will be visible to the viewer, you must add a message object (such 
as slide text) on or near the Drop Area. 
 

 
 

 Click OK to create the new pair and add it to the list. 
 

 
To modify an existing Drag Choice: 
 
 Select a “choice” from the Drag Choices list. 

 

 Click the Modify  button. 
 

 In the window that displays, make your desired edits. 
 

 Click OK to apply the changes and to return to the 
previous window. 
 
 

 To link / unlink Drag and Drop Pairs: 
 

 To remove an existing link: 
o Select either item from one of the lists. 

 

o Click the Link  button. This will remove the 
link between the selected pair. 
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 To link an unlinked Drag Choice and Drop Area: 
o Start by clicking on the desired Drag Choice. 

 
o Then, click on the desired Drop Area that you want 

to link to the Drag Choice. 
 

o Click the Link  button. A link will display 
between the selections. 
 
 

 To move an item up or down within one of the lists: 
 

o Select a Drag Choice or a Drop Area. 
 

o Click the Move Up  button to move the 
selection up in the list. 
 

o Click the Move Down  button to move the 
selection down in the list. 
 
 

 To delete an item in one of the lists: 
 

o Select a Drag Choice or a Drop Area. 
 

o Click the Delete  button. The selection is 
removed from the list. 
 

 

Be careful when deleting a Drag Choice or Drop Area. If the selection is part of a “Drag and 
Drop Pair” (meaning it is linked), both the Drag Choice and its associated (linked) Drop 
Area (and visa versa) will be deleted. 

 
 Once all of the selections / edits are made in the Drag and Drop window, click 

OK to apply / save them. 
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To modify a Drag Choice (while editing directly on the slide): 
 
 To change the style, type or fill color of the Drag Choice, single click on it to 

select it. 
 

 When the context sensitive toolbar loads, use its buttons to modify the Drag 
Choice object just as you would any other message (note, balloon, slide text) 
object. 
 

 To edit the text within the Drag Choice, double click it to enter text edit mode. 
Edit the text as you would any other message object. 
 
For more information on working with message objects such as notes, balloons 
and slide text, please review the Messages chapter. 

 
 
To randomize (mix up) Drag Choices automatically: 
 
 Create and modify the Drag and Drop question on the slide as desired. 

 
 To mix up the Drag Choices (without affecting the position of their associated 

Drop Areas and slide text, if applicable), click on the slide itself to make sure the 
slide is selected. 
 

 Click the Randomize Drag Choices  button on the context sensitive 
toolbar. This will mix up the Drag Choices. 
 
 

 
 
 
 
 
 
 
To work with Drop Areas (using the Drag and Drop window): 
 
 Double click on a Drop Area. 

 
 The Drag and Drop window displays. The Question tab displays by default.  

 
 In the Question tab, make selections / modifications as desired. For more 

information on working in this tab, refer to the previous instructions when 
selecting the Question tab in the Drag and Drop window. 
 

 To change the attributes of the Drop Areas, select the Style tab. 
 

Note: When you use the “Randomize Drag Choices” button (feature) this will 
NOT randomize the Drag Choices in the published SWF file (this feature is 
planned for a future release). It will only “mix up” or randomize the Drag 
Choices each time you click the randomize button while editing the project in 
the source file. 
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The default “Style” of the Drop Areas will be 100% opacity (meaning no 
transparency is set) for the fill color and 1 point for the border. These settings can 
be edited in the stylesheet or on-the-fly. 
 

You have three “states” to set up for the fill (bucket) color and for the border 
(pencil) color: 
 

 Normal: The look of the area when the mouse is not over or 
clicked on it. 

 Rollover: The look of the area when the mouse is “over” but not 
clicked on it. 

 Selected: The look of the area when the mouse is clicked on it. 
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o To change the fill color for the area for any of these “states” click on the 
Background Color button. In the window that displays, select a color and 
click OK to return to the previous window. 
 

 
 

o To change the area’s border color for any of these “states” click on the 
Border Color button. In the window that displays, select a color and click 
OK. 
 

 
 
 
 

 Once your selections are made for the Drop Areas in the Style tab. Click OK to 
apply / save the selections. 

 
The text that you see on the Drop Area while working in your source file within 
ViewletBuilder6.2 Enterprise is used to identify its respective Drop Area. This text is only 
visible within ViewletBuilder6.2 Enterprise and will NOT be visible to the viewer in the 
published SWF file. If you want to use text to identify each Drop Area and have this text 
visible to the viewer in the published SWF file, you must add a message object (such as 
slide text) on or near each of the Drop Areas. 
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To add slide text next Drop Areas that will be visible to the viewer in the published SWF 
file: 
 
 Create and modify the Drag and Drop question as needed on the slide, including 

randomizing Drag Choices and Drop Areas as desired. 
 

 Click the Insert Text Box  button on the Objects Toolbar. 
 

 Draw the text box for the slide text on the slide where desired. 
 

 Input the slide text and modify its attributes as needed. For more information on 
working with message objects like slide text, please review the chapter on 
Messages.  
 

 Repeat these steps as needed for each slide text box you need to create for 
each Drop Area. 
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To resize / move a Drop Area: 
 
 Click on the Drop Area to select it. A “bounding box” displays around it. 

 
 Use the “grab handles” to drag and resize the Drop Area as desired. 

 
 To move the Drop Area, point your cursor over the object and hold down the left 

mouse button and drag it to a new location on the slide as desired. 
 
 
To remove a Drag and Drop question from the slide: 
 

 Click on the Insert Question  button on the Objects Toolbar. 
 

 A Warning window displays. Select the Remove It option. 
 

 
 

 Click OK to complete the deletion. 
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Click Map Question Type 
The Click Map question type requires the viewers to click on one or more areas of the 
screen in order to respond. This question type can be used as a quiz (scored) question 
or as a survey (non-scored) question.  
 
 

 
 
 
To create a Click Map question: 
 

 Click the Insert Question  button on the Object Toolbar. 
 

 A Question window displays. Scroll down the list of Question Types and select 
Click Map from the list. 
 

 Type your Question or instructions for the question in the field provided. 
 

 In the Scoring Mode area, select Quiz if the question will be scored, or select 
Survey if the question will not be scored. 
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 Click OK and a slide with the new Click Map question type will be created. 
 

 
 
 

Click Map Question Properties 
By default, the Click Map question contains various elements (all of which are editable) 
when first created including: 
 
 Question Text: A text box displays at the top of the question elements with text 

entered in the Question field in the Question window when selecting the question 
type. If no text is entered into the field prior to creating the question, the default 
text will be Enter Question Here. 
 

 
 
For more information on working with Question Text, see the instructions “To Edit 
the Question Text” steps. Or, since Question Text is simply a slide text message 
object, review the chapter on Messages (for details on working with message 
objects like notes, balloons and slide text). 
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 Click Areas: Similar to the classic “Click Zone”, the Click Map displays three 
“click areas” on the creation of a new question. You can delete or add click 
areas, redraw their shapes using any of the drawing tools, resize them and 
reposition them on the slide. You can also designate one or more “areas” as 
what the viewer needs to click on in order to respond correctly. 
 

 
For more information on Click Areas, see the instructions “To work with Click 
Areas” steps.  
 

 Submit Button: Once the appropriate selections are “clicked on”, the viewer (by 
default) clicks this button to submit the response. 
 

 
 
The button’s look, text and “on click” action may be modified (but it is not 
recommended unless absolutely necessary). For more information of working 
with buttons, review the chapter on Buttons. 
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If the viewer is only required to click on ONE click area, you can have the answer 
automatically submitted without use of the Submit button. To set this up, double click on a 
click area to open the “Click Map” window. Under “Options” select the “Submit on Click” 
option. This will automatically remove the “Submit” button from the slide. Keep in mind, 
this option will not be available if multiple click areas are designated as the correct 
response. 
 

 
 
 
 Response Messages: One of three text boxes display to the viewer, by default, 

based on how they respond. These response messages are used for correct, 
incorrect and incomplete responses and may be edited. 
 

 
 
For more information on working with Response Messages, review the 
“Response to User Input” section in the Interactive Zones – Common Features 
chapter. 
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To edit the Question Text: 
 Double click on the text box to enter text edit mode. 
 Edit your text and its attributes as desired. 
 Deselect the text box and then single click it to select the object itself. 
 Resize and move the text box as needed. 

 
 
To work with Click Areas: 
 
 Double click on any of the click areas. 

 
 The Click Map window displays. Two tabs are available: 

 
o Select the Question tab. 

 
 In the Click Map Zones area, click on an area in the list to work 

with it. 
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 Click the Add  button to add a new area to the list. 
After it displays in the list, edit its text as needed. 
 

 Click the Modify  button to edit the text of a selected 
area. 

 

 
 

 To move an item up or down in the list, click the Move Up  

 button to move the item up in the list. Click the Move 

Down  button to move the item down in the list. 
 

 Click the Delete  button to remove a selected area 
from the list. 
 
 

Note: The text entered in the field in the “Area” list displays on the Click 
Area, but will NOT display to the viewer in the published SWF file. If for any 
reason you want to have some type of “text” associated with or near the 
Click Area that is visible to the viewer, use a message object such as slide 
text. Please read the chapter on Messages for more information on working 
with message objects. 
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 In the Click Map Zones area, to set one or more areas as the 
correct response: 
 

 In the Correct column, click the check box next to the area 
you want designated as the correct “click area”. 
 

 Repeat the step above for each additional “correct” click 
area the viewer must click on in order to respond correctly. 
 

  
 

 To deselect a correct response, click on the check box 
containing the checkmark to remove (deselect) it as the 
correct response. 
 

Another way to designate a Click Area as the “Correct” response is to single click on the 
Click Area to select it (while editing directly on the slide). On the context sensitive toolbar 
that loads, click the “Mark Area Correct” button.  
 

 
 
 

 In the Options area, to specify “how the user needs to click” in 
order to respond correctly when clicking on selections: 
 

 
 

 Select the Multi Select option if multiple click areas are 
designated as correct responses, meaning the viewer must 
click multiple click areas in order to respond correctly. 
 

If designating multiple click areas as the correct response and selecting “Multi Select” as 
the click (select) option, the “Submit on Click” option will not be available. 
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 Select the Submit on Click option when only one click 
area is designated as the correct response. This will 
remove the Submit button from the slide and once the 
viewer clicks on any of the available click areas, the 
response will automatically be submitted right after 
clicking. 
 

If designating a single click area as the correct response and selecting “Submit on Click” 
as the click option, the “Submit” button will be removed from the slide. 
 

 Select the Double Click to Select option if you want the 
viewer to double click on one or more click areas in order 
to select and respond correctly. 

 
 

o Select the Style tab. 
 

 
 

 
The default “Style” of the Click Areas will be 0% opacity (meaning it is fully transparent) 
for the fill color and 0 point for the border. These settings can be edited in the Stylesheet 
or on-the-fly. 
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You have three “states” to set up for the fill (bucket) color and for the 
border (pencil) color: 
 

 Normal: The look of the area when the mouse is not over 
or clicked on it. 

 Rollover: The look of the area when the mouse is “over” 
but not clicked on it. 

 Selected: The look of the area when the mouse is clicked 
on it. 
 

 For any of these “states” click on the Background Color button. 
In the window that displays, select a color and click OK to return 
to the previous window. 
 

 
 

 For any of these “states” click on the Border Color button. In the 
window that displays, select a color and click OK. 
 

 
 
 
 

 Once your selections are made in the Click Map window, click OK to apply / save 
the selections. 
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To create a new Click Area: 
 

 
 
 Click the Create Area … button on the Context Sensitive toolbar. 

 
 Select one of the menu options to draw (create) the Drop Area: 

 
o Create Area with Rectangle Tool: Use this option to create a 

rectangular shaped Drop Area on the slide. 
 

o Create Area with Ellipse Tool: Use this option to create an elliptical 
(circle or oval) shaped Drop Area on the slide. 
 

o Create Area with Lasso Tool: Use this option to create a free-form 
shaped Drop Area on the slide. 
 

o Create Area with Poly Lasso Tool: Use this option to create a polygon 
shaped Drop Area on the slide. 

 

The “tools” used to draw Drop Areas are the same when creating shape objects. See the 
chapter on “Shapes” for more information on using the shape tools to draw the various 
shape areas. 
 
 When the cursor changes to a cross-hair, hold down the left mouse button on the 

area of the slide where you want to draw the Drop Area. Drag to draw the area. 
 

 Let go of the left mouse button to complete the Drop Area. 
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To “redraw” a Drop Area: 
 
 Click on the Drop Area you want to redraw to select it. 

 
 Click the Redraw Area button on the Context Sensitive toolbar. 

 

 
 
 

 Select one of the menu options to redraw the Drop Area: 
 

o Create Area with Rectangle Tool: Use this option to redraw a 
rectangular shaped Drop Area on the slide. 
 

o Create Area with Ellipse Tool: Use this option to redraw an elliptical 
(circle or oval) shaped Drop Area on the slide. 
 

o Create Area with Lasso Tool: Use this option to redraw a free-form 
shaped Drop Area on the slide. 
 

o Create Area with Poly Lasso Tool: Use this option to redraw a polygon 
shaped Drop Area on the slide. 

 
 

The “tools” used to redraw Drop Areas are the same when creating shape objects. See the 
chapter on “Shapes” for more information on using the shape tools to draw the various 
shape areas. 
 
 
To resize / move a Drop Area: 
 
 Click on the Drop Area to select it. A “bounding box” displays around it. 

 
 Use the “grab handles” to drag and resize the Drop Area as desired. 

 
 To move the Drop Area, point your cursor over the object and hold down the left 

mouse button and drag it to a new location on the slide as desired. 
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To remove a Drag and Drop question from the slide: 
 

 Click on the Insert Question  button on the Objects Toolbar. 
 

 A Warning window displays. Select the Remove It option. 
 

 
 

 Click OK to complete the deletion. 
 

 
 
For additional information on features pertaining to the Drag and Drop and the Click Map 
question types, please review the Interactive Zones – Common Features chapter. Or, 
email support@qarbon.com with any questions you may have. 
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Resize Project  
Have you ever worked for hours on end perfecting your Viewlet only to realize its 
dimensions were either too small or too big for your viewers needs?  ViewletBuilder6.2 
Enterprise offers a “Resize Project” tool that allows you to resize your current project. 
You can do this directly within the project, while inserting new screenshots, or even while 
importing slides from a project (whether or not the slides are the same size as the 
current project). Let’s take a look at how this works. 
 
 
Resizing the Current Project 
 
 Select Project > Resize Project from the Menu. 
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 The Project Resize window displays.  
 

o In the Current Project Size area, the project’s original size displays. 
Review this information.  
 

 
 

o In the New Project Size area: 
 
-Enter a number for the new Width and Height in the fields provided. 
 
-To maintain the correct ratio between the new width and height, select 
the Maintain Aspect Ratio option BEFORE entering a number in either 
the Width or the Height field.  
 

 
 

If the “Maintain Aspect Ratio” option is selected, just enter a number in either the “Width” 
or the “Height” field and press the “Enter” key and number for the “other” value will 
automatically be filled in the applicable field. 
 

o In the Scaling area, select one of the scaling options: 
 
 Scale to Fit: Scales the slide background image to “best fit” the 

new slide dimensions.  
 
(New in ViewletBuilder6.2 Enterprise) 
Additionally, to Scale a slide object, select the check box next to: 
 

 Shapes 
 Click Areas 
 Images 
 Movies 

 
Each of the selected slide objects will be scaled to fit in proportion 
to the new slide size. 
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 Align Slide: Maintains the current size of the slide’s background 
image and aligns it on the new slide based on the alignment 
selection. Normally used when the new project (slide) size is 
larger then the original project dimensions. After selecting this 
option, select an alignment option from the alignment menu. 
 

 
 
 
 

 Click OK to resize the project. 
 
 
If a “Warning” window displays after clicking “OK”, read the information in it and click 
“OK” to close the window. Then, back in the “Resize Project” window, edit the selections 
as instructed by the warning and click “OK” to resize the project. 
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Did you know the “Project Resize” feature also allows you to import slides from projects 
with dimensions “different” from the current, open project? For more information on this 
topic, review the “Importing Slides with Different Sizes” section of the “Export and Import 
Options” chapter. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Crop Project 

ViewletBuilder6.2 Enterprise offers you the ability to crop the dimensions of your 
project’s slide size. An alternative to the “Resize Project” feature, the “Crop Project” 
feature will crop the project’s slide without the need for scaling the background image. 
Let take a look at how this works. 
 
Cropping the project’s slide size 
 
The “Crop Project” operation cannot be undone, so make sure you create a backup copy 
of your project BEFORE you crop the original project’s slide size. 
 
 
 Select Project > Crop Project from the Menu bar. 
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 A Crop Project warning window displays. Read the information in the window and 
click Yes to continue with the cropping task. 
 

 
 

 In the “Slide Edit” area, four “shaded” sections surround the current slide. The 
area in the shaded portions of the slide will be “cropped” out and the areas of the 
slide that are NOT shaded will not be cropped. 
 

 
 

 To resize the “crop area”, point your cursor on one of the lines separating the 
shaded area and the unshaded slide area.  
 

 When your cursor changes to a “double arrow” shape, hold down the left mouse 
button and drag to resize the crop area. 
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 Let go of the left mouse button when you are finished resizing one of the edges 
of the crop area. 
 

 To view the current dimensions of the new slide size as you resize the crop area, 
look at the top of the slide area where the “Width” and the “Height” are displayed. 
 

 
 

 Once you’ve resized the crop area, click the Accept Crop  button. 
Depending on the size of the project, you may see a progress bar display the 
status of the cropping operation. 
 

 
 

 
If you decide you do not want to crop the project while viewing the shaded and unshaded 
slide areas, click the “Cancel” button. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Page Layout 
The Page Layout feature is an often overlooked option in ViewletBuilder6.2 Enterprise. 
The settings in the Page Layout window determine what your hardcopy and electronic 
“printed” materials will look like.  You can set print (page layout) options for the page 
header, the layout of images on each page, what slide elements to include, page 
numbers and the slides to print. 
 

 
 
To access Page Layout: 
 
 Select File > Page Layout from the Menu bar. 

 
 The Page Layout window displays. 
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To edit options for Page Layout: 
 
 Open the Page Layout window. 

 
 In the Header area (if desired):  

 

 
 

o Select the Title option and type a title in the field. 
o Select the Display date and time option to add a date signature. 
o Select the Display slide border to add a border around each slide. 

 
 In the Layout area: 

 

 
 

o Select Landscape orientation and enter a number for the number of rows 
(slides) to include per page. 
 
or 
 

o Select Portrait orientation and enter a number for the number of columns 
(slides) to include per page. 
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 In the Options area, select the elements you want to include on the print 
materials, including: 
 

 
 

o Hidden slides 
o Slide Title 
o Balloons 
o Slide Notes 
o Cursor 
o Cursor Path 
o Notes 

 
Previewing and Printing 
The Page Layout window offers a preview area for you to review your slides before 
printing. To navigate through the slides to preview: 
 
 In the Footer area, select/deselect if you want Page Numbers to display. 

 
 As you make selections, view the slide Preview area. Use the “VCR style” 

buttons (First, Back, Next, Last) to navigate through the slides preview. 
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 In the Slides area, select which slides to print. 
 

 
 

 
o Current Slide: Select this option to print the slide selected prior to 

opening the Page Layout window. 
 

o From: Select this option and enter the number of the first slide to the last 
slide (in the fields provided) for the “series” of slide you want to print. 
 

o All Slides: Select this option to print all the slides in the project. 
 

 Click OK to save these as the default options for this project. Or, click Print to 
open the Print window. 

 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Printing 
There may be times you want to print your slides for users to view or as reference 
materials. Before you print your slides, review the Page Layout chapter for setting up 
layout options for printing your slides.  
 
To print a hardcopy of your slides: 
 
 Select File > Print from the Menu bar. 

 

 
 

 The Print window displays. Select the options in this window for your print job as 
desired. 

 
 
The options available in the “Print” window will vary from computer to computer. 
 
 

 Click the Print  button to print the selected slides. 
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To print an electronic copy of your slides: 
 
 Select File > Export > PDF from the Menu. 

 

 
 
 

 The Export PDF window displays.  
 

 
 

o In the Options area: Select Slide Title and / or Page Numbers if you 
want to include these in the electronic document. 
 



 
 
 

VB6.2 Enterprise User Manual Page 290 February 2010 

o In the Slides area, select what slides to print: 
 
-Current Slide: Select this option to print the slide selected prior to 
opening the Page Layout window. 
 
-From: Select this option and enter the number of the first slide to the last 
slide (in the fields provided) for the “series” of slide you want to print. 
 
-All Slides: Select this option to print all the slides in the project. 
 

 Click the Export  button. 
 

 The Export PDF window displays. Select a folder to save the file in and give the 
file a name.  
 

 Click Save. Depending upon the size of your file, a progress bar may display. 
Once complete, you will be returned to your Viewlet project. 

 
 
Another way to print an electronic copy of your slides is by selecting a “PDF” printer from 
the “Print” window, if one is available on your system. 
 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Export and Import Options 
ViewletBuilder6.2 Enterprise offers various export and import options. These include: 
 

Export Options 
 

 
 
 Text for Translation 
 Sounds 
 PDF 
 Slides to Images 
 QuestionMark 
 Publishing Locations 

 
 
To export the project’s text for translation or other copywriting purposes: 
 
 Select File > Export > Text for Translation from the Menu bar. 
 
 In the Export Text window, select a location to save the file, which will be saved 

in “XML” format. 
 
Enter a name for the file and click Save. 
 

 If an Information window displays, click OK. 
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To export sounds from your project: 
 
 Create a folder outside of ViewletBuilder6.2 Enterprise to save the exported 

sound file in. 
 

 Select File > Export > Sounds from the Menu bar. 
 

 In the Export Sounds window, select what slides you want to export audio from. 
 

 Click Export. The sound files will be saved in the designated folder with the 
same file names and as the same files types as they exist in your project. 
 

For more information on exporting sound from your project, review the chapter on 
“Audio”. 

 
 

 
To export slides as a PDF file: 
 
 Select File > Export > PDF from the Menu bar. 

 
 In the Export PDF window, make selections for Options and for Slides 

. 
 Click Export. 
 In the second Export PDF window that displays, select a folder to save the file in. 

 
 Enter a name for the file and click Save. 
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To export slides as image files: 
 
 Select File > Export > Slides to Images from the Menu bar. 

 
 Select Slides to Images. 
 In the Export Slides to Images window in the: 

 

 
 
 

o File area: Enter a Prefix (used for beginning of file names); select an 
Extension from the drop down list (this will determine the type of image 
file that will be saved when slides are exported); and, if applicable, select 
the Quality (for JPG files) from the drop down list. 
 

o Options area: Select additional options as desired. 
 

o Slides area: Select which slides to export as images. 
 
 Current to search the current slide. 
 From and enter a number in each of the fields provided to search 

from a specific slide to a specific slide based. 
 All to search all slides within the project. 

 
 Click Export. 

 
 In the Save File In window, select a folder to save the image files in. 

 
 Click Save. 
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Publishing Locations 
In order to resolve possible conflicts that might occur when publishing the same project 
from different computers, ViewletBuilder6.2 Enterprise offers the ability to create a file 
(publish.dat) to list the publishing locations available for the project. This file can be 
“transported” with the source file when publishing from different computers. 
 
To create a publishing locations data file: 
 
 Select File > Export > Publishing Locations from the Menu bar. 

 
 In the Save File In window, select a folder to save the “publish.dat” file in. 

 
 Click Save. 

 
 An Information window displays. Read the information in it and click OK. 

 
 
When publishing your project from different computers, import the “publish.dat” file into 
the project while working the “different” computer. 
 
 
 

Import Options 
 

 
 
 Import Slides 
 Text for Translation 
 Publishing Locations 
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To import slides (from another qvp project): 
 
 Select a thumbnail as an insertion point for imported slides. Imported slides will 

be inserted after the selected slide. 
 

 Select File > Import > Import Slides from the Menu bar. 
 
 In the Import Slides window, click Browse. Locate and select a QVP file to load 

into the preview window. 
 

 Select the slide or slides to import. 
 
 

Importing Slides with Different Sizes 
ViewletBuilder6.2 Enterprise allows you to import slides from projects with different slide 
sizes. If ViewletBuilder6.2 Enterprise detects a difference in size, a Slide Alignment 
window displays with options for “matching up” the slide sizes for consistency when 
importing slides of a different size into your current project. 
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 If the slides you select to import are a different size, the Slide Alignment window 
displays requiring you to make some additional selections: 
 

o In the New Size area, select: 
 
 Project Size: This option will resize the imported slides to match 

the size of the current project. 
 

 Imported Slide Size: This option will resize the current project to 
match the size of the imported slides. 
 

o In the Imported Slides Alignment area, if you selected the Imported Slide 
Size option in the New Size area, select an alignment option for the 
imported slides: 
 

o Scale to Fit: This option will scale the imported slides to “best fit” the 
current project’s slide size and center the image on the slides. 
 
(New in ViewletBuilder6.2 Enterprise) 
Additionally, to Scale a slide object, select the check box next to: 
 

 Shapes 
 Click Areas 
 Images 
 Movies 

 
Each of the selected slide objects will be scaled to fit in proportion to the 
new slide size. 
 
 

You must use the “Scale to Fit” alignment option if the imported slides are “larger” then 
the slide size of the current project. 
 
 

-Align Slide: This option will retain the original size of the imported 
slides, but will align the image on the slide based on your alignment 
selection.  

 
 Click OK and the slides will be imported into the current project. 
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To import text for translation: 
 
 Select File > Import > Text for Translation from the Menu bar. 

 
 The Import Text window displays. Locate the text translation XML file. This is the 

file previously created from this Viewlet when using the “Export > Text for 
Translation” option. 
 

 Click Open. 
 

 If an Information window displays, click OK. 
 
In order to use the “Import > Text for Translation” option, you will have to create an XML 
file for this SAME Viewlet using the “Export > Text for Translation” option. 
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Publishing Locations 
In order to resolve possible conflicts that might occur when publishing the same project 
from different computers, ViewletBuilder6.2 Enterprise offers the ability to create a file 
(publish.dat) to list the publishing locations available for the project. (See the “Export 
Options” section of this chapter for information on creating a “publish.dat” file.) This file 
can be “transported” with the source file when publishing from different computers. 
 
 
To publish a project from a different computer using the publish.dat file: 
 
 Select File > Import > Publishing Locations from the Menu bar. 

 

 The Import Publishing Locations window displays. Click the Browse  button. 
 

 Locate the publish.dat file previously created when working on your project on 
the original computer used to publish it. 

 
In order to use the “Import > Publishing Locations” option, you must first create a 
“publish.dat” file on the computer the project was originally published from by using the 
“Export > Publishing Locations” option. 
 
 
 Click Open. 

 
 Back in the Import Publishing Locations window, a list of available publishing 

locations display. Select the publishing location to use to publish the project by 
clicking the check box next to the desired location. 
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 Click OK to import the selected publishing locations in ViewletBuilder6.2 
Enterprise to use for the current project. 

 
Once you’ve imported the desired publishing locations for your project, click the “Publish 
Viewlet” button and the selected publishing locations will be available in the “Location” 
list. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Project Properties 
ViewletBuilder6.2 Enterprise allows you to set up default properties for all of your Viewlet 
projects. These project properties may be modified on a project per project basis. The 
project properties set up in the Project Properties are used when the project is 
published.  
 

 
 
Project properties include: 
 
 Viewlet Profile 
 Sound Quality 
 Image Quality 
 Timing 
 Viewlet Options 
 Scoring Options 
 Packaging 
 Language 
 Flash 
 ViewletSkin 
 HTML Frame 

 
 
To set up project properties: 
 
 Select Project > Project Properties from the Menu bar. 

 
 In the Project Properties window, set up options for your project as needed. 

 
 
To save project properties as default settings: 
 
 Select Project > Project Properties from the Menu bar. 

 
 In the Project Properties window, edit the properties as desired. 

 

 Click the Save as Default Properties  button. 
 

 Click OK to close the Project Properties window. 
 

 
The ”Save As Default Properties” button does NOT save other changes to the project, only 
edits made in the “Project Properties” window. 
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Viewlet Profile – Project Properties 
Information entered in the Viewlet Profile section of the Project Properties window will be 
embedded into the Viewlet. 
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To set up Viewlet Profile details: 
 
 Select Project > Project Properties from the Menu bar. 

 
 Select Viewlet Profile from the left navigation menu. 

 
 
In the Viewlet area: 
 
 Enter a Title. This information will display in the browser’s title bar when the 

Viewlet is played back and will also be included in the Viewlet’s metatag 
information. 
 

 
 

 Enter a Description. This information will be included in the Viewlet’s metatag 
information. 

 
 
 
In the Author area: 
 
 Enter an author Name. 

 
 Enter an Email. 

 
 Enter additional Comments. 

 
 
Use the “Author” information to promote your Viewlet. The author’s name, email and 
comments display Viewlet’s information window. 
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In the Company area: 
 
 Enter a Company name. 

 
 Enter a Department. 

 
 Enter a company Web Site. 
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Sound Quality – Project Properties 
The sound quality selected in the Sound Quality section of the Project Properties window 
will be what is used when the Viewlet is published. 
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To select Sound Quality options: 
 
 Select Project > Project Properties from the Menu bar. 

 
 Select Sound Quality from the left navigation menu. 

 
 Select one of the sound quality options: 

 
o CD quality: Highest sound quality option, which is recommended for 

music and subtle audio effects. Results in biggest file size. 
 

o High quality: This is the second best sound quality choice, which is 
suitable for good qualify audio effects and high quality voice-overs. Best 
choice for viewers using high speed or network connections. 
 

o Standard quality:  This is the third best sound quality choice, which is 
recommended for average voice narration quality. Results in lowest file 
size possible (with projects containing audio) and is suitable for most 
bandwidths. 
 

o Strip all sounds: Removes all sound when publishing the project. 
 

o Use stereo sound (default): Publishes audio using “stereo” quality 
sound, if applicable. 

 
 
The sound quality selection you make in the “Project Properties” will not affect the sound 
in the “pre-published” source qvp file. 
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Image Quality – Project Properties 
The image quality select in the Image Quality section of the Project Properties window 
will be the setting used when the Viewlet is published. 
 

 
 
To select Image Quality options: 
 
 Select Project > Project Properties from the Menu bar. 

 
 Select Image Quality from the left navigation menu. 



 
 
 

VB6.2 Enterprise User Manual Page 307 February 2010 

 There are several image settings to choose from. Select the radio button next to 
the image quality of your choice: 
 

 
o Highest Quality:  This option is best suited for photographic quality 

images, but results in the biggest file size. 
 

o High Quality: This selection is recommended for images created in 
graphic design software and for lossless images.  Results in a file size 
best suited for high speed connections. 
 

o Medium Quality:  This is the default setting for all professional training 
and online help content. Acceptable file size for most connections. 
 

o Low Quality: This selection creates the smallest file size by reducing the 
image quality as much as possible. Not recommended for professional 
demonstrations, but is optimized for dial-up connections. 

 
The selection made for image quality in the “Project Properties” window will not affect the 
image quality of the source file. 
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Timing – Project Properties 
In the Timing section of the Project Properties window, you can set minimum defaults for 
timing features throughout your project. These settings serve as a baseline for your 
project and may be modified on a slide-per-slide or object-per-object basis, where 
applicable, as needed. 
 

 
 
To set up Timing options: 
 
 Select Project > Project Properties from the Menu bar. 

 
 Select Timing from the left navigation menu. 
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In the Minimum Slide Duration area: 
 
 Enter a value for the minimum number of seconds a slide will be displayed. 

 
In the Reading Speed area: 
 
 Enter a default reading speed (words per minute) for your project. 

 
 
Changing the reading speed maintains the timing on slides, including manual gaps added 
at the end of the slide. 
 
 
In the Cursor Speed area: 
 
 Select a default cursor speed from the drop down list. 

 
In the Introductory Delay area: 
 
 Enter a default delay (in seconds) before a message object is displayed. 

 
In the Timing Links area: 
 
 Select the Maintain Timing Links check box to automatically add and maintain 

timing between elements along the Timeline while editing a project. For more 
information on “Timing Links”, see the Timeline Tab chapter. 
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Viewlet Options – Project Properties 
In the Viewlet Options section of the Project Properties window, you may set up 
additional miscellaneous features for your published Viewlet. 
 

 
 
To set up Viewlet Options: 
 
 Select Project > Project Properties from the Menu bar. 

 
 Select Viewlet Options from the left navigation menu. 
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In the Login Options area: 
 
 Select the option to require viewers to login before viewing your Viewlet. 

 
 Select the password option and enter a password (that you will provide to 

viewers) in the password field. 
 
In the Display Options area: 
 
 Select the option to display Table of Contents when the Viewlet is viewed. 

 
 Select a Status Bar to be displayed as the Viewlet is playing. Select additional 

options for the status bar as desired: 
 

o Display Quiz Progress: Displays progress of the Viewlet as it plays. 
Requires at least one question slide. 
 

o Display Quiz Score: Displays the current score. Requires at least one 
scored question. 
 

o Display Time Remaining: If the Viewlet is set with a time limit, the 
remaining time displays. 
 

 Select the display score option if you want the “final” score displayed at the end 
of the Viewlet. 
 

 Select the options for when the hand shape cursor is displayed for OnClick 
Events and ClickZones 

 
 
In the Soundtrack area: 
 

 Click the Load Soundtrack  button to locate and select a sound file that will 
play in the background when the Viewlet plays. 
 

 Loop to End (New in ViewletBuilder6.2 Enterprise) 
If your soundtrack is shorter in duration then the playback time of your project, 
you can select the Loop to End option. This will make your background audio 
repeat until the Viewlet project is played through. 
 

 Pause During Zones and Questions (New in ViewletBuilder6.2 Enterprise) 
If you want the viewer to concentrate on Interactive Zones or questions in your 
Viewlet, you can temporarily pause the background soundtrack. Select the 
Pause During Zones and Questions option and when the Viewlet plays these 
slides, the background soundtrack will pause until the viewer responds and the 
Viewlet returns to play mode. 
 

 To remove a soundtrack, click the Delete Soundtrack  button. 
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Scoring Options – Project Properties 
The Scoring Options section of the Project Properties window offers scoring selections 
for your Viewlet project. 
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In the Scoring Options area: 
 
 Select a Pass / Fail percentage and its value in the field provided. 

 
 Limit the amount of time the viewer has to answer a question in the fields 

provided. 
 

 Select Allow Repeat if you will allow the viewer to play the Viewlet again. 
 

 (New in ViewletBuilder6.2 Enterprise) 
Select the Clear Incorrect Answers on Retry to have previously incorrect 
responses “cleared out” when the viewer retakes quiz questions. 

 
You can set a global “on time out” event by selecting an action to occur in the “Actions to 
perform when the Viewlet time limit is reached” area of the Scoring Options section. The 
action triggers when the Viewlet’s global time limit is reached. 
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Packaging – Project Properties 
The Packaging section of the Project Properties window offers additional publishing 
selections for your Viewlet project. 
 

 
 
To select additional Viewlet file Packaging options: 
 
 Select Project > Project Properties from the Menu bar. 

 
 Select Packaging from the left navigation menu. 
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In the Standalone Projector area: 
 
 Select options for creating “standalone Viewlets” that play in their own viewer 

(according to the operating system selected). 
 

 Select the Play executable file fullscreen if you want the standalone Viewlet to 
launch fullscreen (filling the entire viewing area of the user’s monitor) when 
played. 

 
 
In the Miscellaneous area: 
 
 Select the Create a zip file option to create a copy of the Viewlet files contained 

in a zip file. 
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Language – Project Properties 
In the Language section of the Project Properties window, you may set default language 
preferences for your Viewlet. 
 

 
 
To set up Language details: 
 
 Select Project > Project Properties from the Menu bar. 

 
 Select Language from the left navigation menu. 
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In the Viewlet language area: 
 
 By default, the compiling language used by ViewletBuilder6.2 Enterprise is the 

same as your computer’s operating system. To change it, select a new language 
from the list. 

 
To change default language or text details for various Viewlet panels: 
 
 Login Panel: If you require viewers to log into the Viewlet, you can change the 

text displayed in the login panel in the fields provided. 
 

 Table of Contents Panel: If you choose to display a Table of Contents with the 
Viewlet, you may edit this panel’s text in the fields provided. 
 

 Results Panel: If your Viewlet is scored, you may modify the text that displays in 
the results panel in the fields provided. 
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Flash – Project Properties 
In the Flash section of the Project Properties window, you may set up your default Flash 
settings for your Viewlet. 
 

 
 
To set up Flash defaults: 
 
 Select Project > Project Properties from the Menu bar. 

 
 Select Flash from the left navigation menu. 
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In the Size area: 
 
 Enter a value for the final Width and Height of your SWF file, or 

 
 Select the Scale to Fit Web Page option. 

 
In the Options area: 
 
 Select additional options for your Flash file including: 

 
o Compress Movie: Recommended for smaller file size. 

 
o Loop Mode: Recommended for tradeshow Viewlets to play continuously. 

 
o Reduce Flash Context Menus: Displays abbreviated right click Flash 

shortcut menu options. 
 

o Rapid Fading Effects on Messages: Fades message objects in / out on 
slides. 
 

o Local Access Mode: Allows Viewlet to have access to local files. 
 

o Disable JavaScript to Flash Interface: Select this option if your Viewlet 
contains JavaScript functions that might conflict with the Flash interface. 

 
In the Preloader area: 
 
 Select Display a waiting animation while the Viewlet is being loaded option 

is you want a Preloader animation to display while the Viewlet streams in the 
background. 
 

 If a Preloader is selected, select how long the Preloader will “wait” by selecting a 
radio button next to the desired option. 

 
 
In the Animated Extras area: 
 
 To display a SWF movie before the Viewlet plays and/or after the Viewlet is 

played, click the Load Movie  folder next to the Beginning and/or Ending 
field. Locate the SWF movie, select it and click Open. 
 

 To delete a Beginning and/or Ending SWF movie file, click the Delete Movie  
button next to the Beginning and/or Ending field. 
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In the Frame Rate area: (New in ViewletBuilder6.2 Enterprise) 
 
 Input the number of frames per second you want ViewletBuilder to use when 

compiling the qvp source file into a published Flash swf file. You can input the 
number in the field provided or click the up / down arrows to change it. 
 

 

The default “Frame Rate” is 30 frames per second.  The lower the number, the smaller the 
resulting file size, however, the smoothness of playback may be affected. 
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ViewletSkin – Project Properties 
 In the ViewletSkin section of the Project Properties window, you may select a wrapper 
that will display around your Viewlet. 
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To select a ViewletSkin: 
 
 Select Project > Project Properties from the Menu bar. 

 
 Select ViewletSkin from the left navigation menu. 

 
 Select a ViewletSkin from the list. Once a skin is selected, you may preview it in 

the preview area below the list. 
 
ViewletSkins Features (New in ViewletBuilder6.2 Enterprise) 
ViewletBuilder6.2 Enterprise offers several skins to publish with your Viewlet Flash file. 
New and enhanced skin features include: 
 
 Table of Contents: If you want to include a Table of Contents as a navigational 

element in your published video, ViewletBuilder6.2 offers several skins with 
enhanced Table of Contents. 

 
To include slides in a ViewletSkin with a TOC, remember to select the “Included in Table of 
Contents” option in the Slide Properties window. And, in the Project Properties window, in 
the Viewlet Options section, remember to select the “Display Table of Contents” check 
box. 
 
 
 Audio or No Audio Buttons: ViewletBuilder6.2 provides skins for Viewlet demos 

with audio buttons. But, if your Viewlet doesn’t have sound, select from several 
new skins that will publish a player bar without the audio button features. 

 
 
ViewletSkin Embedded Fonts 
To insure your Viewlet “looks” the same across multiple platforms, ViewletBuilder6.2 
Enterprise allows you to use “embedded fonts” in your ViewletSkin. This feature will 
standardize the look of your Viewlet across platforms, but will also significantly increase 
the size of your Viewlet file. 
 
To embed fonts in your ViewletSkin: 
 
 Select your ViewletSkin from the available list. 

 
 In the Options area, select the Use Embedded Fonts option to embed fonts in 

the selected ViewletSkin. 
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HTML Frame – Project Properties 
In the HTML Frame section of the Project Properties window, you may choose and 
modify the HTML Frame that is published with your Viewlet. 
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Social Networking for Your Flash Video (New in ViewletBuilder6.2) 
ViewletBuilder6.2 Enterprise features an HTML Frame that contains links below the 
Flash video that, when clicked, enable you to quickly publish your Viewlet to several of 
the most popular networking sites to share with others. 
 
To publish a Viewlet with Social Networking sharing links: 
 
 In the Project Properties window, select HTML Frame from the left navigation 

menu. 
 

 Select the ShareThis.qframe from the Select the HTML Frame that is published 
with your Viewlet list. 
 

 Publish the Viewlet. When previewing, click one of the links to your favorite social 
networking site displayed below the Viewlet to share your Viewlet with others at 
that site. 
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To select HTML Frame options: 
 
 Select Project > Project Properties from the Menu bar. 

 
 Select HTML Frame from the left navigation menu. 

 
 
To select the frame that is published with your project: 
 
 In the HTML Frame section of the Project Properties window, select a default 

frame from the list. 
 

 The frame will be added to the Files field area below the list. 
 
 
To add a custom frame: 

 In the HTML Frame section, click the Add  button.  
 

 In the HTML Frame Properties window, enter a Name for the new frame. 
 

 Click OK. 
 

 Double click inside the “coding” field area. In the Resource Properties window 
that displays, edit as needed. 
 

 Click OK. 
 
 
To edit or delete an HTML frame: 
 
 Select an HTML Frame from the list. 

 
 To modify an HTML Frame: 

 

o Click the Modify  button. 
  

o In the HTML Frame Properties window, edit the Name and click OK. 
 

o Double click in the “coding” field. 
 

o In the Resource Properties window, edit as needed and click OK. 
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 To delete an HTML Frame: 
 

o Select a frame from the list. 
 

o Click the Delete  button. 
 
 
A warning displays if the HTML Frame entry point is not set correctly. 
 
 
To Save Project Properties 
Once all of the options are set up in the Project Properties window, click OK. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Previewing a Viewlet 
There are various ways to preview your Viewlet project. For example, any place you see 
these buttons: 
 

 
 
 
You may use them to navigate through your project while inside ViewletBuilder6.2 
Enterprise. These buttons will allow you to go to the: 
 

 First Slide  
 

 Previous Slide  
 

 Next Slide  
 

 Last Slide  
 

 
You can preview the slide background soundtrack, audio attached to objects, cursor click 
sounds and key click background frame sounds within ViewletBuilder6.2 Enterprise 
without publishing the project. 
 
 
Additionally, you may access preview options: 
 
From the Timeline: 
 

 
 
 Click the Preview button at the top right of the Timeline to preview the project, or 

 
 Click the down arrow and select a preview option from the menu list. 
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From the Menu bar: 
 

 
 
 Select Project from the Menu bar. 

 
 Select a preview option: 

 
o Preview Current Slide: Plays the current slide inside ViewletBuilder6.2 

Enterprise. 
 

o Preview From Current Slide: Plays the project inside ViewletBuilder6.2 
Enterprise from the selected slide to the end of the project. 
 

o Preview All Slides: Plays the entire project while inside 
ViewletBuilder6.2 Enterprise. 
 

o Preview in Browser: Quickly compiles (publishes) the file to SWF 
(Flash) format and launches it (from a temp folder) in a browser. 

 
 

Displaying the informational “About” window during Viewlet playback pauses the Viewlet. 
Closing the window returns the Viewlet to play mode. 
 
 
After publishing a project: 
 
 Select Project > Publish Viewlet from the Menu bar. 

 
 Complete the information in the windows that display to publish your project. 

 
 In the last Publish Viewlet window, click the View button to preview the published 

Viewlet. 
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Outside of ViewletBuilder6.2 Enterprise: 
Once you’ve published a Viewlet file, a folder containing the published files is created. 
Locate this folder and open it. Double click the HTML or the SWF file to preview the 
Viewlet. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Publishing a Viewlet 
In order to create the final Flash Viewlet your audience will see, you must publish your 
Viewlet source (qvp) file. ViewletBuilder6.2 Enterprise allows you to publish your 
Viewlets to a several locations, some are preinstalled with the program while others you 
can add to the list. 
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To add a publishing location to the list: 
 

 Click the Add  button. 
 

 Select a location type from the menu list that displays: 
 

 
 
 

o Local or Network Folder: This includes your hard drive, a network drive, 
or any other external file storage device (such as a floppy disk, CD, jump 
drive, etc.). 
 

o FTP Server 
 

o Qarbon ViewletCentral 
 

o Corporate ViewletCentral 
 

 If, for the publishing location you select: 
 

o Add Local or Network Folder: This includes folders on your hard drive, 
a network drive or any other external file storage device (floppy disk, CD, 
jump drive, etc.). 
 
-In the Select Folder window, locate and select a folder from a local or 
network drive. 
 

-Click the Select Folder  button. You will be returned to 
the Publish Viewlet window and the new local or network folder will be 
displayed in the “Location” list. 
 

 
When selecting a publish folder, if an “Allow Publishing to Folder” window displays, read 
the information and click “Yes” to create the location. 
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o FTP Server: The FTP Server window displays. Make sure the required 
fields and selections are complete: 
 
-Name: This is the name that will display in the “Location” list for the FTP 
Server. 
 
-Server: This is the path to your FTP Server. (for example: 
ftp.qarbon.com). 
 
-Directory: This is the folder on the server where you will publish your 
files. 
 
-Login: Enter the login information for your server. 
 
-Password: Enter the password required to access your server. 
 
-Port: This is the port used by the server, by default it is “21”. 
 
-Passive: Select the Passive mode is required to get through some 
firewalls option is your server is behind a firewall. 

 
 
When configuring an FTP Server for a publishing location, click the “Text Connection” 
button. An information window will display letting you know if the connection passed. 
 

 
 

-Click OK to save the information. The FTP Server will be added to the 
“Location” list in the Publish Viewlet window. 
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o Qarbon ViewletCentral: The Qarbon ViewletCentral window displays. 
 

 
 
 
 In the Email Address field, type in the email address used when 

signing up for Qarbon ViewletCentral. 
 

 In the Password field, type in the applicable password to sign into 
ViewletCentral. 
 

 Click OK to save this information. The Qarbon ViewletCentral 
publishing location is added to the list in the Publish Viewlet 
window.  
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o Corporate ViewletCentral: The Corporate ViewletCentral window 
displays. This option is available to organizations who subscribed for a 
Self-Hosted ViewletCentral. Fill in the following fields with information 
provided by your ViewletCentral Administrator: 
 
 In the Name field, type in the name of the ViewletCentral account. 

 
 In the Server field, type in the server information. 

 
 In the Login field, type in the login used to access ViewletCentral. 

 
 In Password field, type in the password required to access 

ViewletCentral. 
 

 Secure Connection option (New in ViewletBuilder6.2): 
If your Corporate ViewletCentral Account is hosted on a secure 
server, select the check box next to Secure Connection. 
 

 
 

 Click OK to save the information. The Corporate ViewletCentral 
publishing location is added to the list in the Publish Viewlet 
window. 
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To edit a publishing location: 
 
 Select the desired location from the list. 

 

 Click the Modify  button. 
 

 Make edits in the windows that display as needed. 
 

 Click OK to save edits and to return to the Publish Viewlet window. 
 
 
 
To move a publishing location up or down in the list: 
 
 Select the desired publishing location. 

 

 Click the Move Up  button to move the selection up in the list. 
 

 Click the Move Down  button to move the selection down in the list. 
 
 
 
To remove a publishing location from the list: 
 
 Select the desired publishing location. 

 

 Click the Delete  button.  
 

 A Warning window displays. Read the information and click Yes to confirm the 
deletion. The selection is removed from the list. 
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If you remove all of your publishing locations, the next time you try to publish your 
project, you will be prompted to add a new publishing location. 
 

 
 
 
To publish a project to a local or network folder: 
 
 Make sure you’ve completed all your edits and save your file. 

 
 Select Project > Publish Viewlet from the Menu bar. 

 
 The Publish Viewlet window displays. Select a local or network publishing 

location from the “Location” list. 
 

 Click Next. 
 

 Select a “Reporting” or “Learning Management System” from the list:  
 

o None: Select this option if you do not have any reporting or LMS options.  
 

 
 

o Qarbon Email Reporting System: Select this option to have an email of 
Viewlet results sent to the email or emails specified. 
 
 Enter an email address in the field provided. 

 
 Select HTML Format to send the email results in HTML format. 

 

 
 



 
 
 

VB6.2 Enterprise User Manual Page 337 February 2010 

 
When using multiple email addresses, separate each email with a semi-colon. 
 

o SCORM 2004 Learning Management System:  Select this option to 
publish files to meet SCORM 2004 compliancy for your LMS. 
 

 
 

 Select the Create a zip file option to have ViewletBuilder6.2 
Enterprise create a zip file containing copies of all of the published 
files when using the SCORM 2004 LMS option. 
 

 Passing Score in Manifest (New in ViewletBuilder6.2 Enterprise): 
Select the check box next to Include passing score in the manifest 
if publishing a Quiz Viewlet to an LMS. 
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o SCORM 1.2 Learning Management System: Select this option to 
publish files to meet SCORM 1.2 compliancy for your LMS. 
 
 Select the Create a zip file option to create a zip file containing 

copies of all the published files when using the SCORM 1.2 LMS 
reporting option. 

 

 
 
 Send score to LMS as option:  

(New in ViewletBuilder6.2 Enterprise) 
 

 In the Send score to LMS as area, select the radio button 
next to Score or Percent. 
 

 Select the Do not send score if total points is zero … 
option if applicable. 
 

 Lesson Status: 
(New in ViewletBuilder6.2 Enterprise) 
 

 Always use Complete/Incomplete: Select this option to 
have the LMS use the ‘complete / incomplete’ reporting 
option for non-scored lessons. 
 

 Report Pass/Fail if applicable to report data: Select this 
option if the lesson is scored and the viewer is required to 
have a passing or failing score reported. 
 

 Passing Score in Manifest (New in ViewletBuilder6.2 Enterprise): 
Select the check box next to Include passing score in the 
manifest if publishing a Quiz Viewlet to an LMS. 
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o AICC Learning Management System:  Select this option to publish files 

to meet AICC compliancy requirements for your LMS. 
 

 
 
 

 Once you’ve selected a “Reporting” or “Learning Management System” option 
from the list, click Next. 
 

 In the Publish Viewlet window, a “Folder Publish Complete” information screen 
will display once the Viewlet has been successfully published. 
 

 
 

o Click the View button to view the Viewlet in your default browser. 
 

o Click the Browse button to view the published project files. 
 
If your computer displays the “path” to folder when displaying operating system windows, 
when you click the “Browse” button, a path to the folder containing the published project 
files displays. Use this information to quickly locate these files when needed. 
 
 

o Click Finish to close the Publish Viewlet window once publication is 
complete. 
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To publish a project to a Qarbon ViewletCentral or Corporate ViewletCentral account: 
 
 Make sure you’ve completed all the edits to your project and save the file. 

 
 Select Project > Publish Viewlet from the Menu bar. 

 
 The Publish Viewlet window displays. Select a “ViewletCentral” account from the 

publishing location list. 
 

 Click Next. 
 

 The “Reporting Options” screen displays. Keep the default selected and click 
Next. 
 

 The “ViewletCentral – Space Available” screen displays. Read the information 
about the space available in the ViewletCentral account. Then, click Next. 
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 Once the project a published, a “Publish Complete” screen displays.  
 

 
 

o In the Viewlet URL area, a path to the Flash file displays. Click the View 
button next to this field to launch the Viewlet in your default browser. 
 

o In The Viewlet statistics can be viewed at the following URL:  field, a path 
to an information page showing your Viewlet’s stats displays. Click the 
View button next to this field to go to your Viewlet’s stats’ page on 
ViewletCentral. 
 

o Click Finish to close the Publish Viewlet window. 
 
 

Each time you publish your project, as long as the file name remains the same, the Viewlet 
will be updated on ViewletCentral. 
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To view publishing information for your Viewlet: 
 
 Select Project > Display Publishing Profile from the Menu bar. 

 

 
 
 

 In the Publishing Profile window that displays: 
 

o In the Location area, select a publishing location from the publishing 
history list. 
 

 
 

o In the General area, review the Viewlet’s publishing information, including 
date of publishing, time of publishing and reporting type. 
 

 
 

o In the Viewlet URL area: 
 
 Click the View button to launch the Viewlet in the default browser. 
 Click the Browse button to open the folder containing the 

published files. 
 

o Click Close to close the Publishing Profile window. 
 
 

If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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ViewletCentral – General Information 
Are you looking for a solution for publishing your Viewlets on the Web? Why not check 
out Qarbon’s ViewletCentral. ViewletCentral is a server-based application that provides 
centralized reporting, management and deployment of your valuable Viewlets and other 
Flash-content files. 
 

 
 
To discover all the features of ViewletCentral, you can immediately open a Free account, 
which will give you ample disk space to store your Viewlets. For more information about 
ViewletCentral information, please visit our web site at: 
 
http://www.qarbon.com/presentation-software/viewletcentral/ 
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Viewlet Central Self-Hosted Server 
When you purchase a Self-Hosted ViewletCentral server license, you not only get all of 
the same features that the Qarbon-Hosted version has, but you gain the ability to 
perform account and project management activities easily and efficiently from one single 
location.  
 
http://www.qarbon.com/presentation-software/viewletcentral/host_server.php 
 
If you are interested in learning more about Self-Hosted ViewletCentral, please contact 
our sales group (sales@qarbon.com) or support (support@qarbon.com). 
 



 
 
 

VB6.2 Enterprise User Manual Page 345 February 2010 

Support and Self-Help Options 
Qarbon offers a support plan to fit your needs. Standard Support is offered to all 
customers at no charge. You can also purchase Platinum Membership, which is a 
software maintenance plan with enhanced support benefits. 
 
For more information on support plans and options available, visit us online at: 
 
http://www.qarbon.com/help/support_plans.php 
 
Qarbon also offers users online, self-help resources in the form of Viewlet tutorials, user 
manuals and FAQs. For access to these self-help aids, please visit our site at: 
 
http://www.qarbon.com/help/ 
 
You may also contact support@qarbon.com with any support questions you may have. 
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Webinars and Training Opportunities 
Take advantage of all the features in ViewletBuilder6.2 Enterprise by signing up for 
Qarbon’s training classes. Learn how to get the most out of your Viewlet authoring tool 
to create stunning Flash demonstrations and interactive movies in no time. For 
information on how to learn from the Viewlet experts, visit us online at: 
 
http://www.qarbon.com/services/webinars/index.php 
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Sales and General Customer Service 
Customer support is our top priority at Qarbon! Please feel free to contact our Sales or 
Support staff at any time if you have ANY ViewletBuilder6.2 Enterprise (or other product 
related) questions or concerns or for options to discuss additional training needs. 
 
For current contact information, visit our web site: 
 
http://www.qarbon.com/about_us/contact_us/ 
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Qarbon User Forum 
Want to share ideas on Viewlet Authoring? Are you hunting for a specific authoring trick 
to take your Viewlets to the next level? Qarbon offers a Viewlet user forum just for you. 
It’s free to join and free to use. It’s a great place to meet other Viewlet enthusiasts from 
across the globe and spotlight your own great Viewlet ideas too!  
 
Go to: http://forum.qarbon.com/ 
 
Sign up and join in the fun! 
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