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1. Introduction to the Bone Microarchitecture 
Analysis Add-on

The Bone Microarchitecture Analysis (BMA) module is a new add-on available for Analyze 12.0. The BMA 
add-on is a powerful pre-clinical research application designed for the evaluation of 3D CT and microCT 
image data. The module provides researchers the ability to process single whole bone specimens and 
isolated 3D samples of trabecular tissue. It generates an extensive set of bone morphometric indices as 
described by Bouxsein et al 1

The BMA add-on provides automatic and user-guided isolation of bone from non-bone tissue by means of 
a novel segmentation process. This process also provides for the separation of the cortical and trabecular 
bone in whole bone specimens. BMA uses the segmented regions to automatically drive the calculation 
of common bone morphometric indices that provide researchers with a quantitative description of bone 
microarchitecture. The microarchitectural characteristics of the trabecular and cortical bone are listed below 
(Tables 1 and 2). For further information about each bone measurement calculated please refer to section 3: 
Bone Microarchitecture Analysis Measurements.

Table 1. Trabecular Bone Morphometric Indices

Abbreviation Description Unit

TV Total Volume mm3 

BV Bone Volume mm3 

BS Bone Surface mm2 

BV/TV Bone Volume Fraction %

BS/TV Bone Surface Density mm2/mm3 

BS/BV Specific Bone Surface mm2/mm3 

Conn.D Connectivity Density 1/mm3

SMI Structure Model Index

Tb.N Trabecular Number 1/mm

Tb.Th Trabecular Thickness mm

Tb.Sp Trabecular Separation mm

Tb.Th.SD Standard Deviation of 
Trabecular Thickness

mm

Tb.Sp.SD Standard Deviation of 
Trabecular Separation

mm

DA Degree of Anisotropy

MIL Mean Intercept Length

Table 2. Cortical Bone Morphometric Indices

Abbreviation Description Unit

Tt.Ar Total Cross-Sectional Area mm2 

Ct.Ar Cortical Bone Area mm2 

Ma.Ar Medullary Area mm2 

Ct.Ar/Tt.Ar Cortical Area Fraction %

Ct.Th Average Cortical Thickness mm

Ps.Pm Periosteal perimeter mm

Ec.Pm Endocortical Perimeter mm

Iap
Moment of Inertia 
Anteroposterior Axis

mm4

Iml
Moment of Inertia 
Mediolateral Axis

mm4

Imax
Maximum Moment of Inertia mm4

Imin
Minimum Moment of Inertia mm4

J Polar Moment of Inertia mm4

Ct.Po Cortical Porosity %

Po.N Pore Number n

Po.V Total Pore Volume mm3 

AvgPo.V Average Pore Volume mm3 

Po.V.SD Standard Deviation of Pore 
Volume

mm3  

Po.Dn Pore Density 1/mm3 
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1.1 Bone Microarchitecture Analysis Workflow
The BMA workflow is divided into two sections: Data Preprocessing and Bone Microarchitecture Analysis. 
Data preprocessing is a prerequisite for analysis 
of data via the BMA add-on. An overview of the 
entire workflow is provided in Figure 1.1. 

1.1.1 Data Preprocessing Overview
The BMA add-on module requires that input 
bone specimens have isotropic voxels. If the 
image data contains multiple bones the bone 
of interest must be isolated and orientated 
into the correct anatomical orientation. Data 
Preprocessing also includes optional data 
subregioning (cropping) and filtering steps, 
to reduce data size and enhance initial object 
segmentation.

1.1.2 Bone Microarchitecture Analysis 
Overview
The second part of the Bone Microarchitecture 
Analysis workflow is conducted within the BMA 
add-on module and is separated into three steps:

1.	 Cortical Bone Segmentation: Once the image data is loaded the BMA add-on will conduct a 
preliminary segmentation which will allow the module to identify the cortical shell, cortical pores and 
trabecular tissue regions.

2.	 Trabecular Bone Segmentation: Upon user approval the add-on will complete the segmentation 
process by identifying the trabecular bone in the trabecular region. Two new regions, the trabecular 
bone and intra-trabecular space, will be derived.

3.	 Calculation of Bone Morphometric Indices: Measurements are automatically calculated for the 
trabecular and cortical bone and output 
in several comma-separated values 
(.csv) files. Files are saved to a user-
defined directory. 

1.1.3 Processing Single Bone 
Specimens
Image volumes that contain only a single bone 
do not require a pre-segmentation step to 
isolate the bone of interest. The workflow is 
summarized in Figure 1.2.

Figure 1.1. Diagram of BMA Workflow
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2. The Bone Microarchitecture Analysis Add-on 
Interface Overview

The BMA add-on is started from the Analyze 12.0 Apps Menu (Apps > BMA) (Figure 
2.1). To load a data set, select the data from the Analyze workspace and open the 
BMA add-on (Figure 2.2). Alternatively data sets can be dragged from the Analyze 
workspace and dropped onto the add-on module or loaded from disk directly into 
the add-on via the File > Load option; a copy of the data set will also be loaded to 
the current Analyze workspace.

Figure 2.1. Starting 
the BMA Add-On

Figure 2.2. Loading Data into the BMA Add-On Module
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2.1 The Main BMA Program Window
The main BMA program window (Figure 2.3) provides access to all functions and tools within the module.

Figure 2.3. The BMA Program Window

Menu

Toolbar

BMA 
Workflow
Tabs

Display Screen Rendering Window

Slice Display

BMD Scaling 
Parameters



8

2.2 Menu
The BMA menu provides access to the File, View, Other, and Help menus.

2.2.1 File
The File menu provides access to the Input/Output Ports, Load and Exit functions.

•	 Input/Output Ports: Selecting the File > Input/Output Ports option displays an area at the bottom of the 
Bone Microarchitecture Analysis window which facilitates the loading of image data via drag and drop 
from the Analyze workspace (Figure 2.4). Image data can also be dragged and dropped onto the display 
screen of the module without opening the Input/Output Ports option. 

•	 Load Volume: Choosing the Load option from the File menu within the BMA add-on module opens the 
Load module. This allows users to load data sets from disk that may not already be loaded into Analyze. 

•	 Exit: Selecting the Exit option closes the Bone Microarchitecture Analysis add-on module. 

2.2.2 View 
The View menu provides access to the Intensities and Size tools. 

•	 Intensities: When the Intensities option is selected the Intensity window (Figure 2.5) for the module 
opens. The Intensity window allows users to change the intensity display of the image data. Users also 
have the ability to choose the intensity processing type: Max/Min or Level/Width.

Figure 2.4 Loading Data Via Input/Output Ports

Figure 2.5. The Intensity Window
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•	 Size: When the Size option is selected the Size window (Figure 2.6) for the module opens. The window 
allows users to specify the display size of the 2D slices and 3D rendering (Table 2.1).

•	 Specified Factor: The Specified Factor option allows users to set the display size of the 2D slices 
and 3D Rendering. Selecting the Specified Factor radio button enables the X and Y fields below. 
Enter the desired value into these fields by double clicking on the current value and entering in the 
new value. X specifies the display width of the 2D slices and 3D Rendering.  Y specifies the display 
length of the 2D slices and height of the 3D volume. 

•	 Interpolate: When selected, specifies that the pixels displayed in the 2D slices will be interpolated 
rather than replicated (Figure 2.7), when scaling the slices for display.

2.2.3 Other 

•	 Options: When selected opens the Options window (Figure 2.8). 
This window allows users to specify window attributes for the 
module. 

•	 Threads: The Threads option allows users to specify the number 
of processing cores the multithreaded code can utilize. By default 
the threads option is set to the maximum number of processors 
on the system.

•	 PowerBar Editor: Opens the PowerBar Editor window. This window 
allows users to add or remove buttons from the Toolbar in the BMA 
module. 

Figure 2.6. The Size Window

Size Option Action

Quarter Sets slice and rendering display to 1/4 of 
actual size. 

Third Sets slice and rendering display to 1/3 of 
actual size. 

Halve Sets slice and rendering display to 1/2 of 
actual size.

Single Sets slice and rendering display to actual 
size.

Double Sets slice and rendering display to twice 
the actual size.

Triple Sets slice and rendering display to three 
times the actual size.

Quadruple Sets slice and rendering display to four 
times the actual size.

Table 2.1. Explanation of Size Options

Figure 2.7. Interpolated vs. Replicated Image Display

Figure 2.8. The Options Window
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2.2.4 Help

•	 About: The About option opens the Analyze 12.0 Bone Microarchitecture Analysis About window. The 
About window provides detailed information about the system and the Analyze 12.0 software. Selecting 
Done will close the About window. 

•	 User’s Guide: The User’s Guide option opens the software help documentation.  

2.3 Toolbar 
The BMA Toolbar provides quick access to several functions:

•	 Toggle Region Display: The Toggle Region Display option allows users to quickly switch between 
the display of the overlaying regions on the slice displays (Figure 2.10). The display options are: Filled 
Regions, Region Edges, and Regions Off. Note the keyboard shortcut to toggle region displays is the t 
key.

•	 Intensities: Shortcut to open the View > Intensities window (Figure 2.5). 	

•	 Double Display Size: Doubles the current slice and rendering display size.

•	 Halve Display Size: Halves the current slice and rendering display size.

•	 Exit: Closes the BMA add-on module.

Toggle Region Display Double Display Size Exit Module

Intensities Halve Display Size

Figure 2.10 Slice Display Showing the 3 Region Display Options: Filled Regions, Region Edges, and Regions Off
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2.4 Display Screen 
The display screen (Figure 2.11) is divided into quadrants, displaying the 2D slices in the transverse, coronal 
and sagittal orientations and the 3D rendering of the data. 

2.4.1 Slice Display 
The upper left quadrant displays the selected transverse image from 
the volume, the lower left the selected coronal image, and the lower 
right the selected sagittal image. 

Linked Cursor: A linked cursor identifies a single voxel in all three 
sectional images (Figure 2.12).  A left-click in one of the sectional 
images moves the cursor to that point and selects the other two 
sectional images displayed.  The left button may be held down in one 
of the sectional images to continuously scroll the cursor and the other 
two images. 

Arrow Keys: The arrow keys can also be used to move the linked 
cursor. The keys will move the linked cursor in the corresponding 
direction (up, down, left and right) for the active orientation. 

Page Up and Down Keys: The page up and page down keys can be 
used to move through the slices in the active orientation.

Figure 2.11 The BMA Display Screen
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Coronal Sagittal

Rendering

Figure 2.12 The Linked Cursor Tool
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Sliders: The sliders below each slice display quadrant can be used to navigate through the slices in that 
orientation. The middle mouse scroll button can also be used to move through the slices; this will provide the 
ability to scroll through slices in the active orientation. 

Right-Click Menu: Right-clicking on any of the slice display 
quadrants provides access to a size menu (Figure 2.13). The default 
Size option for the selected orientation is From Size Menu; this 
means the display size of the selected orientation is dictated to that 
set globally via the Size menu or the increase/decrease size buttons 
on the toolbar. The other options will apply the selected size action to 

the selected slice orientation only.

2.4.2 Rendering Window
The upper right quadrant is the rendering quadrant, which displays a 
3D rendering of the image volume. 

Linked Cursor: A left-click on this rendered surface (Figure 2.14) will move the linked cursor to that surface 
voxel and select all three sectional images.  

Rotating: Holding the middle mouse button down in the rendering quadrant will enable interactive rotation of 
the rendering viewpoint. For those users without a middle mouse button the ‘Ctrl’ key + left mouse button will 
enable interactive rotation of the rendering viewpoint.

Figure 2.13. Right-Click Size Menu

Figure 2.14. The Linked Cursor Tool
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Right-click menu: Right-clicking in the rendering quadrant will 
open the right-click menu (Figure 2.15). The right-click menu 
provides access to the following options:

•	 Reset Rotation: Provides the ability to reset the 
rendering display to one of the 6 orthogonal viewpoints 
(Front, Back, Left, Right, Top and Bottom).

•	 Size: When selected provides access to a Size menu for 
the Rendering quadrant. The default Size option is From 
Size Menu; this means the display size of the rendering 
is dictated to that set globally via the Size menu or the 
increase/decrease size buttons on the toolbar. The 
other options will apply the selected size action to the 
rendering only.   

•	 Interactive Rotate: Allows users to select between 
Visible Surface Only, useful for interactive rotation of 
extremely large image volumes, and Full Render.

•	 Transparency: The transparency option turns transparent rendering on or off. The transparency 
rendering mode is useful for visualizing objects contained within objects or objects with views obscured 
by other objects. 

•	 Background Color: Allows users to set the color of the rendering background. The option opens a 
Color selection window enabling selection of desired color. 

•	 Background Opacity: The Background Opacity option is only available when Transparency rendering 
is enabled. The option allows users to specify the background opacity in the transparency rendering 
(Figure 2.16). 

•	 Print: Opens the Print command window facilitating the selection of a printer for the printing of the 
current rendering quadrant. 

Figure 2.15. The Rendering Quadrant 
Right-Click Menu 

Figure 2.16. Background Color and Opacity Options
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2.5. BMD Scaling Parameters
A set of input fields has been provided for the user to enter a specific slope (SigmaCT) and offset (BetaCT) 
value to convert CT numbers (Hounsfield units) to bone mineral density (BMD) in units of mg/CC (Figure 2.17).

Generic values are provided, but the user may modify these values as required. Depending upon the vendor 
and scanning protocol these values may be available in the header information of the data (e.g. Scanco). For 
other data, such as that acquired from the PerkinElmer QuantumFX or the Rigaku R_mCT2 microCT scanner, 
these values need to be calculated. For information on how to determine the SigmaCT and BetaCT values for 
data acquired from these systems please refer to Section 6: BMD Calibration.

2.6. BMA Workflow Tabs
The BMA workflow tabs (Figure 2.18) provide access to the three 
processing steps in the BMA workflow: Segment Cortex, Segment 
Trabeculae, and Measure Bone. 

2.6.1 Segment Cortex 
The first step of the BMA workflow process is to segment the cortex from the trabecular bone and 
intertrabecular space (Figure 2.19). If the image volume is of sufficient resolution to reveal cortical pores, they 
will be identified at this stage.  

Figure 2.17. BMD Scaling Parameters

Figure 2.18. BMA Workflow Tabs

Figure 2.19. BMA - Segment Cortex



15

Cortex Thresholds: Provides access to a threshold slider bar to allow for segmentation of the cortex. Note 
that the module will automatically compute the minimum threshold value via histogram analysis, however this 
may be adjusted by the user before segmenting the cortex.

Threshold Rendering: This option turns on and off the interactive 3D rendering display as the threshold 
slider changes. It is useful to switch off this option if you are working with extremely large data sets and the 
interactive 3D update is slow. 

Use Initial Segmentation: If the image volume is a single bone, this option is not needed. If the image 
volume contains several bones, it must be pre-segmented by use of an object map to indicate the bone of 
interest.  This pre-segmentation will only be used to avoid segmenting and measuring the other bones in the 
image.  The cortex and trabecular bone will still be identified by the segmentation routines in the program. If 
the module finds an object map that has the same name as the input volume, the module will automatically 
set this option and the object map will be loaded.

Initial Object Map: Opens a file browser to allow users to navigate to and select the pre-segmentation object 
map for specimens containing multiple bones.

Bone Object: If the object map contains multiple objects the Bone Object drop down menu allows users to 
select objects corresponding to the bone of interest.

Segment Cortex: The Segment Cortex button begins the cortical segmentation process. Depending on the 
input data and the resources of the system this process could take several minutes. Segmentation progresses 
by transverse slice, and varies in speed by the characteristics of the section.  Mid-shaft sections are generally 
fastest, sections containing significant trabecular tissue and/or articulating surfaces are slower, and sections 
with cortical defects or traumatic damage can be slower to resolve.

2.6.2 Segment Trabeculae
The Segment Trabeculae tab is displayed at the end of the Segment Cortex procedure (Figure 2.20). The 
cortical segmentation algorithm has been designed to perform well on intact long bones, but it may make 
minor errors on unusually shaped bones or on complicated sections near the metaphysis or on sections 
containing cortical defects.  On this tab the user may save the cortical segmentation as an object map 
and use any of the manual segmentation tools in Analyze to correct regions believed to be inappropriately 
assigned. Likewise, this tab may be selected when starting the program and a corrected object map loaded 
to proceed. At this point, the trabecular bone and intertrabecular space are combined as a single object, as 
this is easier to correct than the detailed object map.
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Save Segmented Cortex Object Map: This option opens a save window, allowing the user to save the 
segmented cortex object map.

Load Segmented Cortex Object Map: This open opens a load window, allowing the user to load a corrected 
cortex object map.

Trabeculae Thresholds: The minimum threshold value is set from the Cortical Thresholds slider on the 
Segment Cortex tab.  This is usually the best threshold to use, but the user may adjust this slider if a different 
segmentation is desired within the trabecular compartment.  As the slider is adjusted, the sectional images 
show the resulting trabecular bone.

Object Map List: The list of objects shows the color associated with each object and whether the object 
is displayed in the rendering or not.  To turn off the display of an object, select the monitor icon next to the 
object name. To change the color of an object, select the color square next to the object name.

Segment Trabeculae: When pressed the Segment Trabeculae button commits the threshold decision to the 
object map, populating the Trabecular Bone object.

Figure 2.20. BMA - Segment Trabeculae
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2.6.3 Measure Bone
The Measure Bone tab (Figure 2.21) is displayed at the end of the Segment Trabeculae procedure. The final 
segmentation may be saved as an object map if corrections are desired, or the tab can be selected when 
data is loaded and a corrected final object map loaded. This tab allows the selection of the specific bone 
measurements desired (all measurements are selected by default) and initiates the measurement process.  

Each measurement group is saved to a comma-separated values (.csv) file named using the image volume 
name and an additional extension described below.  The first line of each .csv file contains the variable names 
of the measurements in the following row(s).  An additional .csv file named “VolumeName.csv” is also saved 
containing all of the measures calculated in a format including explicit units for all measurements.

Save Final Object Map:  This option opens a save window, allowing the user to save the final object map.

Load Final Object Map:  This open opens a load window, allowing the user to load a corrected final object map.

Measurement Data Directory: This is initially set to the OriginalDir value in the image header.

Directory: This option allows the user to set the measurement data directory, the location where the  
.csv files will be saved to. 

Figure 2.21. BMA - Measure Bone
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Measure Options: The Measure Options allow the user to specify groups of bone measurements to sample.  
Unchecking the checkbox to the left of the group name before a measurement excludes the measurement. 
For detailed information on each of the measurements generated please refer to section 3: Bone 
Microarchitecture Analysis Measurements.

•	 Bone Mineral Density: Means and standard deviations measured in the grayscale image volume under 
the various objects and converted by use of the SigmaCT and BetaCT to mg/cc units.  These are saved 
in a single file named “VolumeName_BMD.csv”.

•	 Volumes, Surface Areas and Ratios: Global values saved in a file named “VolumeName_VSR.csv”.  

•	 Cortical Porosity: Global values saved in a file named “VolumeName_CP.csv”.

•	 Cortical Moments: Values per transverse section saved in a file named “VolumeName_M.csv”.  

•	 3D Trabecular Thickness: This produces histograms of trabecular thickness and intertrabecular space 
over the entire 3D extent of the bone.  The histogram .csv files (“VolumeName_TTH.csv” for trabecular 
thickness and “VolumeName_TSP.csv” for intertrabecular space) declare the range of thicknesses 
(in mm) in each bin in the first line, and the values in the following lines are the volume of trabecular 
bone (or intertrabecular space) (in mm3) of that thickness.  The mean and standard deviation of these 
measurements are stored in “VolumeName_TrSt.csv”.

•	 3D Trabecular Structure and Connectivity: Two global characterizations of trabecular structure that 
are also stored in “VolumeName_TrSt.csv”.

•	 2D Characterization: Multiple values per transverse section in file “VolumeName_Ch2D.csv”.  

Note that detailed descriptions of each measurement generated for each group of bone measurements are 
provided in the next section: 3. Bone Microarchitecture Analysis Measurements.

Measure Bone: Begins the measurement process.  All the measurement groups selected will be performed.  
When complete the .csv file viewer will be displayed.

Show Measurements: If you dismiss the .csv file viewer it can be recalled using the Show  
Measurements button. 
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3. Bone Microarchitecture Analysis Measurements
 
Bone Mineral Density (BMD, mg/cm3) is an important measure in the evaluation of osteoporosis and other 
bone related conditions. The X-ray attenuation coefficients produced in μCT are converted to an equivalent 
BMD value. This conversion is accomplished by using phantoms (liquid K2HPO4 or solid resin-embedded 
hydroxyapatite) of known densities to generate a calibration line2,3. Low bone mineral density is a risk factor 
for fragility fracture, although many other factors also contribute to fracture risk and BMD alone should not 
be used to diagnose osteoporosis4,5. The World Health Organization has developed an algorithm called FRAX 
that takes multiple factors into account to evaluate fracture risk6–9. BMD has been shown to increase with 
parathyroid hormone treatment10.

3.1 Trabecular Bone Microarchitecture Measurements
Total volume (TV, mm3) is the volume of the region of interest. In the BMA module, this volume of interest 
includes the cortex, cortical pores, trabecular tissue and trabecular bone objects. TV is used to calculate 
the bone volume fraction and bone surface density indices below that allow comparison between bones of 
different patients or animals.

Bone volume (BV, mm3) is the volume of the region segmented as mineralized bone, including cortical and 
trabecular bone. BV is used in the calculation of bone volume fraction as defined below.

Bone surface (BS, mm2) is the surface area of the region segmented as mineralized bone, including 
trabecular and cortical bone. BS is used to calculate the bone surface density and specific bone surface as 
defined below.

Bone volume fraction (BV/TV, %) is the ratio of the segmented bone volume to the total volume of the region 
of interest. Trabecular BV/TV has been found to be lower in patients who have sustained vertebral fracture11,12. 
BV/TV decreases with age in both women and men, contributing to osteoporosis13,14. 

Bone surface density (BS/TV, mm2/mm3) is the ratio of the surface area of mineralized bone to the total 
volume as defined above. BS/TV decreases with aging—as bone volume decreases, so does bone surface 
area14. 

Specific bone surface (BS/BV, mm2/mm3) is the ratio of the bone surface area to the volume of mineralized 
bone. BS/BV remains constant with aging14, suggesting that the shape of trabecular microarchitecture  
(rod-like, plate-like, or a combination) does not change much with age.

Connectivity density (Conn.D, 1/mm3) is a measure of the degree of connectivity of trabeculae, normalized 
to the total volume. Conn.D contributes to bone strength and decreases significantly with age in the femoral 
neck and vertebra13. In women, the lower levels of estrogen associated with menopause lead to an increase 
in osteoclastic resorption, which causes the perforation of trabeculae and thus a decrease in Conn.D15. 
Trabecular disconnectivity due to various causes can also lead to vertebral fractures in men12.

Structure model index (SMI) is a dimensionless number ranging from 0 to 4 that describes the dominant 
trabecular structure. Perfect plates are represented by 0, perfect rods by 3, and perfect spheres by 41. Most 
real trabecular structures will lie somewhere between the ideal plate and ideal rod structure. At very high or 
low BV/TV values, the SMI may be outside of the defined range1. The SMI impacts the mechanical properties 
of trabecular tissue. In the femoral neck and vertebrae, the SMI increases significantly with age, moving 
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from a plate-like structure to a weaker rod-like structure as trabeculae undergo perforation and/or thinning 
mechanisms13. SMI has been shown to exhibit a strong negative correlation with BV/TV16. As bone volume 
fraction decreases, trabeculae tend to become more rod-like. Different bones tend to have different trabecular 
structure: the lumbar spine tends to be more rod-like, and the femoral head tends to be more plate-like, for 
example16.

Trabecular number (Tb.N, 1/mm) is the average number of trabeculae per unit length. Tb.N is calculated by 
finding the mean distance between mid-axes of the trabecular structures, then taking the inverse1. This mean 
distance is determined using a 3D sphere-fitting method1. Low Tb.N is significantly associated with vertebral 
fracture11 and the decrease in BV/TV with age13. Tb.N tends to be larger in the femoral head and smaller in the 
lumbar spine14. 

Trabecular thickness (Tb.Th, mm) is the mean thickness of trabeculae as determined by a 3D sphere-fitting 
method1,16. A decrease in strength of trabecular bone with aging in men is usually associated with a decrease 
in Tb.Th12. In women, Tb.Th does not generally decrease after menopause11. 

Trabecular separation (Tb.Sp, mm) is the mean distance between trabeculae as determined by a 3D  
sphere-fitting method1,16. Tb.Sp is sometimes called trabecular spacing. Higher Tb.Sp is associated with 
vertebral fracture12. Tb.Sp generally increases with age, exhibiting a linear dependence on age in the lumbar 
spine14. 

Standard deviation of trabecular thickness (Tb.Th.SD, mm) is a measure of the heterogeneity of trabecular 
thickness (Tb.Th, above). 

Standard deviation of trabecular separation (Tb.Sp.SD, mm) is a measure of the heterogeneity of 
trabecular separation (Tb.Sp, above).

Degree of anisotropy (DA) is a dimensionless variable defined as the length of the longest mean intercept 
length vector divided by the length of the shortest mean intercept length vector. For an isotropic (perfectly 
oriented) system, DA is equal to 1. As the system becomes more anisotropic (less well-oriented), the DA 
increases to some value greater than 11. DA is related to the directional dependence of the mechanical 
properties of trabecular bone17 and does not appear to vary with age13.

Mean intercept length (MIL) is a measure that is part of the algorithm used to determine the degree of 
anisotropy (DA, above)1.

3.2 Cortical Bone Morphology Measurements
Total cross-sectional area inside the periosteal envelope (Tt.Ar, mm2) is measured for each transverse 
section. Tt.Ar has been found to increase with age with continued periosteal apposition in both men and 
women at the distal radius and distal tibia; however, Tt.Ar increased more in men than in women at the distal 
radius with age18. Boys after the onset of puberty19 and young men18 have a larger Tt.Ar than girls and women 
of the same maturity. Cross-sectional area measurements characterize resistance to axial compression and 
tension20.

Cortical bone area (Ct.Ar, mm2) is calculated as the cortical volume (Ct.V) divided by the product of the 
number of slices times the thickness of each slice. The Ct.Ar is a separate measurement for each transverse 
section. Men have been found to have a greater Ct.Ar than women, and Ct.Ar has been found to have a weak 
negative correlation with age21. The Ct.Ar of the femoral midshaft was found to have a linear relationship with 
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weight bearing in mice22. Ct.Ar increased in rats receiving strontium ranelate23. Boys during and after puberty 
have been found to have a higher Ct.Ar than girls of the same maturity19. Further, Ct.Ar is greater in men than 
women and has a positive correlation with height and weight and a negative correlation with age24.

Medullary (or marrow) area (Ma.Ar, mm2) is the cross-sectional area of the medullary part of the bone on 
any given transverse section. Treatments that tend to increase total cross-sectional area Tt.Ar and cortical 
area Ct.Ar lead to a decrease in Ma.Ar, as an increase in bone area also increases the ratio of cortical 
to medullary bone. Two examples of such treatments include an increase in mechanical loading25 and a 
sclerostin inhibitor26. Sclerostin is a bone regulatory protein produced by osteocytes that inhibits bone 
formation27.

Cortical area fraction (Ct.Ar/Tt.Ar, %) is the ratio of cortical cross-sectional area to total cross-sectional 
area within a given transverse section. Ct.Ar/Tt.Ar has been found to significantly increase with a 25 mg/kg 
dose of sclerostin inhibitor in rats26.

Average cortical thickness (Ct.Th, mm) is the average thickness of the cortex in each transverse section. 
There have been conflicting results about the correlation of Ct.Th with the incidence of vertebral fracture. 
Ct.Th has been found by Ostertag et al. to be the same in patients with and without vertebral fracture12, while 
in a study by Qiu et al., Ct.Th was found to be an effective measure to discriminate between patients with 
and without vertebral fracture11. Vertebral Ct.Th has been demonstrated to vary along the length of the spine 
with higher values in the cervical and lumbar spine and lower values in the thoracic spine28. Vertebral Ct.Th 
decreases with age in the lower thoracic and lumbar spine28 and femoral neck13 but does not vary with gender 
and is lower in patients with osteoporosis than in a control group28. Mice receiving a sclerostin inhibitor27 and 
postmenopausal osteoporotic women receiving strontium ranelate29 experienced a significant increase in Ct.Th. 

Periosteal perimeter (Ps.Pm, mm) is the perimeter of the periosteum (the membrane around the outside of 
the cortex) and is calculated for each transverse section. Ps.Pm was found to increase as a result of jump 
training30 and strontium ranelate treatment in female rats23 and as a result of treadmill running in male mice31.

Endocortical perimeter (Ec.Pm, mm) is the perimeter of the endosteum (the membrane that forms the 
boundary between the cortex and medulla) and is calculated for each transverse section. Ec.Pm was found 
to increase along with periosteal perimeter (Ps.Pm, above) as a result of treadmill running in male mice, 
indicating endocortical resorption along with periosteal formation of bone31.

Moment of inertia about the anteroposterior axis (Iap, mm4) is a measure of how material is distributed 
about the anatomical anteroposterior (front to back) axis through the area centroid of each slice20. Area 
moments of inertia are also known as second moments of area, or SMAs, and characterize resistance to 
bending around a given axis20. Exercise has been shown to increase Iap in the tibia of male mice31.

Moment of inertia about the mediolateral axis (Iml, mm4) is a measure of how material is distributed about 
the anatomical mediolateral (left to right, or right to left) axis through the area centroid of each slice20. Area 
moments of inertia are also known as second moments of area, or SMAs, and characterize resistance to 
bending around a given axis20. Low Iml has been determined to be a risk factor for stress fracture in the tibia32.

Maximum moment of inertia (Imax, mm4) is a measure of how material is distributed about the major 
centroidal axis, which is orthogonal to the minor centroidal axis. Maximum moment of inertia correlates to the 
maximum bending strength of a bone33. Area moments of inertia are also known as second moments of area, 
or SMAs, and characterize resistance to bending around a given axis20.
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Minimum moment of inertia (Imin, mm4) is a measure of how material is distributed about the minor 
centroidal axis, which is orthogonal to the major centroidal axis. Minimum moment of inertia correlates to the 
minimum bending strength of a bone33. Area moments of inertia are also known as second moments of area, 
or SMAs, and characterize resistance to bending around a given axis20.

Polar moment of inertia (J, mm4) is the sum of any two perpendicular area moments of inertia (Iap + Iml or 
Imax + Imin) and characterizes resistance to torsion20. Polar moment of inertia has been found to increase with 
parathyroid hormone treatment in postmenopausal women with osteoporosis34,35. A reduction in weight 
bearing in female mice led to a reduction in polar moment of inertia22.

Cortical porosity (Ct.Po, %) is calculated as the pore volume Po.V divided by the total cortical compartment 
volume Ct.V. Ct.Po is negatively correlated with bone strength and is thought to increase during puberty 
(and is higher in boys than girls during puberty) because of increased calcium demands during growth 
spurts19. In adults, Ct.Po increases with age21,36, exponentially so in women after menopause18. The increase 
of porosity with age is understood to be caused by an increase in pore size, and not by a change in pore 
number13,24. Ct.Po can be increased by diseases and treatments such as kidney disease, hyperparathyroidism 
(or parathyroid hormone treatment), thyroid hormone treatment, or prostaglandins37,38. Ct.Po was higher in 
diabetic women exhibiting fragility fractures than in diabetic women not exhibiting fractures39, in the femoral 
neck of patients exhibiting a hip fracture36, in men with idiopathic osteoporosis exhibiting vertebral fractures36, 
and in osteopenic and osteoporotic postmenopausal women36. Ct.Po has been found to increase with chronic 
alcohol consumption in rats40,41 and decreased as a result of sclerostin inhibitor treatment in female rats42.

Pore number (Po.N, n) is a count of the number of cortical pores in a given volume. Po.N does not appear 
to increase with age; rather, the size of each pore increases, leading to an increase in overall porosity13,24. In 
rats chronically dosed with alcohol, pore number was increased, rather than pore size, indicating that chronic 
alcohol consumption increases porosity through a different mechanism than aging does40,41. 

Total pore volume (Po.V, mm3) is the total volume occupied by cortical pores in the volume of interest.

Average pore volume (AvgPo.V, mm3) is calculated as the total pore volume Po.V divided by the pore 
number Po.N. AvgPo.V is higher in postmenopausal than in premenopausal women36 and higher in women 
than in men13. Pore size has also been shown to be larger in diabetic postmenopausal women exhibiting 
fragility fractures39. As mentioned above, the increase of cortical porosity with aging is understood to be due 
to an increase in average pore volume rather than an increase in pore number13,24.

Standard deviation of pore volume (Po.V.SD, mm3) is a measure of the heterogeneity in size of cortical 
pores in the volume of interest. Diabetic postmenopausal women exhibiting fragility fractures had a higher 
variability in pore size39.

Pore density (Po.Dn, 1/mm3) is calculated as the pore number Po.N divided by the total cortical 
compartment volume Ct.V, giving the number of pores per unit volume in the cortex. 
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4. Bone Microarchitecture Analysis: PerkinElmer 
QuantumFX microCT Data Processing

4.1 Data Preprocessing

4.1.1 Data Loading
The BMA add-on module requires that input bone 
specimens have isotropic voxels. To ensure your 
image data is loaded with isotropic voxels, load 
the data using the Load As module and resample 
anisotropic data using the Resize option. 

1.	 Download data set BMA_PE_micro_CT.AVW 
from www.analyzedirect.com/data.

2.	 Open Analyze 12.0 and select  
File > Load As. 

3.	 In the Load As module use the File button to 
navigate to and select the BMA_PE_micro_
CT.AVW data set and then click Open. 

4.	 In the Load As window click on the Resize 
tab and then if the voxels are not isotropic, 
check the Force Cubic option (Figure 4.1).  

5.	 Select the Load button to load the data set 
into the Analyze workspace.

4.1.2 Data Reorientation
The BMA add-on also requires that the input bone specimens are 
orientated into the correct anatomical orientation (Figure 4.2). The 
Oblique Sections module provides the tools necessary to quickly 
reorientate the data. 

6.	 Select the BMA_PE_micro_CT data set from the Analyze 
workspace and open Display > Oblique Sections.

7.	 Select Tools > Orthogonal.

Figure 4.1. Load As Module

Figure 4.2. Correct Bone 
Orientation for BMA

www.analyzedirect.com/data
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8.	 Use the Interactive Perp Axis tool to draw a line down the center of the bone to be analyzed.  
To do this click on the image and drag the cursor to a new position; in this example this is done in the 
coronal orientation (Figure 4.3). An oblique plane (shown in yellow) will be defined perpendicular to the 
red line defined.

9.	 Next select Tools > Fly from the main Oblique Sections window. Use the Fly tool to roll the oblique 
plane to the correct position in the corresponding orientation.  Note that in this example the axis 
(shown in yellow) on the sagittal image (on right) should be rotated slightly in a clockwise direction 
(Figure 4.4); this is achieved using the Roll left button.

Figure 4.4. The Orthogonals Tool Showing Fly Adjustment

Figure 4.3. Definition of Oblique Plane in Coronal View
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10.	 To output the reformatted data open the File > Output option (Figure 4.5).

11.	 In the Output window set:

a.  The output Name to BMA_PE_micro_CT_reformat. 

b.  Method to Reformat Entire Volume and select Change to best fit data.

c.  Finally select Generate Slices. The reformatted data set will be saved to the Analyze workspace.

12.	 Close the Oblique Sections module.

4.1.3 Subregioning Data
The subregioning or cropping of the input image data 
set is an optional step; however, cropping the data 
to the bone of interest will reduce the total size of the 
volume and thus decrease processing time. 

13.	 Select the reformatted data, BMA_PE_micro_
CT_reformat, and open Process > Image 
Calculator.

14.	 Right-click on the Calculator interface and 
select Buttons. In the buttons window select the 
Region Pad button and drag it from the Palette 
to the Key Pad (Figure 4.6). Next select Apply, 
then Save and then Done.

Figure 4.6. The Image Calculator 
Button Configuration Tool

Figure 4.5. Oblique Sections Output Window
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15.	 From the main Image Calculator window click the Region Pad button; the Subregion window 
will open (Figure 4.7).

16.	 In the Subregion window click the Interactive button. 

17.	 In the Interactive window (Figure 4.8) set the yellow box around the bone of interest. Use the 
orientation buttons to navigate between views. 

18.	 Once the crop is set in all three orientations click Apply. When prompted select Save a Copy of the 
Loaded Data. The cropped data will be saved to the Analyze 12.0 workspace.

19.	 Close the Image Calculator module.  

20.	 Select the subregioned data set from the Analyze 12.0 workspace and then right-click and select 
Rename from the menu. Change the name of the data set from BME_PE_micro_reformat0 to 
BMA_PE_micro_reformat_sub.

Figure 4.7. Subregion Tool

Figure 4.8. Interactive Subregion Tool
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4.1.4 Filtering Data
The filtering of the image data set is another optional step. Image filtering can help improve the segmentation 
of the cortex and is often a necessary step for segmentation of data acquired on certain microCT systems.

21.	 Select the subregioned data set, BMA_PE_micro_reformat_sub, 
from the Analyze 12.0 workspace and open Process > Spatial 
Filters.

22.	 To visually review any filter applied to the image data prior 
to filtering open Generate > Preview Options; in the Preview 
Options window returned (Figure 4.9) set the following:  
	 a. Loaded and Preview Volumes.  
	 b. Slice to 233. 
	 c. Number to 1.

23.	 Next open Generate > Filters. In the Filters window set: 
	 a. Filter Type to Median. 
	 b. Set the Kernel size to 5 by 5 by 5.

24.	 Click the Preview button to review the original slice 233 and a copy of slice 233 with the selected filter 
and kernel size applied (Figure 4.10). 

25.	 Next click Filter to apply the filter to the entire data set. When prompted select ‘Change a Copy of the 
Loaded Volume’ (Figure 4.11). A filtered copy of the data set, named BMA_PE_micro_reformat_sub_
Med, will be saved to the current Analyze 12.0 workspace.

26.	 Close the Spatial Filters module.

Figure 4.11. Spatial Filters Save Option

Figure 4.9. Preview Options Window

Figure 4.10. Side-by-Side Display of Unfiltered and Median Filtered Image
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4.1.5 Data Presegmentation
This data set contains multiple bones, therefore it is necessary to conduct a preliminary segmentation to 
isolate the bone of interest. This will be used as an input in the BMA add-on module to guide the cortical 
segmentation process. 

27.	 Select the filtered data, BMA_PE_micro_reformat_sub_Med, and open Segment > Volume Edit.

28.	 In the Object control panel click the Add Object button and name the object Bone (Figure 4.12).

29.	 Next select the Semi-Automatic tab and choose the Region Grow option. 

30.	 Click on the bone of interest in any of the 3 orthogonal displays to set a seed (Figure 4.13), then use 
the threshold slider to define a global threshold range that represents bone. Now click Extract Object 
(Figure 4.14). All voxels that fall within the specified minimum and maximum threshold range and that 
are spatially connected to the seed will be assigned to the Bone object. For this data set a Min value 
of 3745 and a Max value of 9463 works well.

31.	 In the Object control panel add a new object and name it Extra. 

Figure 4.12. Volume Edit Object Control Panel

Figure 4.13. Region Grow Seed Point Figure 4.14. Volume Edit Semi-Automatic Tab
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32.	 From the Semi-Automatic tab select the Object Separator tool. Click on a bone that is not the bone 
of interest; this will set the first seed point location. Next click on the bone of interest; this will set the 
second seed point (Figure 4.15).

33.	 Click Separate to disconnect the two bone objects. The area of bone selected first should be 
disconnected from the main bone object and assigned to the Extra object (Figure 4.16).

34.	 Continue to disconnect any superfluous bones surrounding the bone of interest. 

35.	 Once all bones surrounding the bone of interest have been reassigned to the Extra object, delete the 
object by clicking on the trash can button (Figure 4.17). 

36.	 Select File > Save Object Map. Name the object map initial.obj . Close the Volume Edit module.

Figure 4.15. Object Separator Seed Points Figure 4.16. Rendering of the Separated Bone Objects

Figure 4.17. Volume Edit Segmented Bone of Interest
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4.2 BMA Processing
Once data preprocessing is complete the image data is ready for processing with the Bone Microarchitecture 
Analysis add-on module. 

4.2.1 Segment Cortex 
The first step in the BMA add-on module is the segmentation of the cortex. 

37.	 Select the BMA_PE_micro_reformat_sub data set from the Analyze 12.0 workspace and then open  
the BMA add-on module from the Apps menu.

38.	 As mentioned previously this data set contains multiple bones; to allow the module to distinguish 
between the bone it should process and all other bones, it is necessary to load the initial segmentation 
object map created using the Volume Edit module. To do this check the Use Initial Segmentation 
option (Figure 4.18) and then load the object map initial.obj saved in step 36.

39.	 Although an object map has been loaded it is necessary to specify a threshold range that identifies  

the bone in order for the cortex segmentation algorithm to function. Use the Cortex Thresholds slider 
to specify a min/max threshold range to segment the bone or leave the values calculated automatically 
by the module (Figure 4.19).

Figure 4.18. Initial Segmentation Option

Figure 4.19. BMA Module with Initial Segmentation Object Map Loaded
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40.	 Next select the Segment Cortex button. Note that the cortex segmentation algorithm is a 
computationally intense process and could take several minutes to complete.

41.	 Once processing is complete the module will automatically move to the Segment Trabeculae tab 
(Figure 4.20). The three orthogonal slices displayed will update to show the Cortex, Cortical Pores  
and Trabecular Tissue objects. 

42.	 At this point in the workflow the user will need to visually review the segmentation result to determine 
if the result is acceptable or not. If the result is acceptable then processing can continue and the user 
can proceed to the second step in the BMA processing workflow, Segment Trabeculae (step 62).  
 
If the segmentation result requires manual refinement then the user has the ability to output and refine 
the object map using Volume Edit available within Analyze 12.0. The steps neccasary for manual 
refinement are given in section 4.2.2. Examples of manual refinement that may be needed include the 
reassignment of incorrectly labeled bone structures and the filling of holes and gaps in the trabecular 
tissue region.  After object refinement is complete the modified object map can be reloaded into the 
BMA add-on module at this point in the workflow using the Load Segmented Cortex Object Map 
option.

43.	 Use the linked cursor tool to inspect the 3 orthogonal slice displays and the 3D rendering; review both 
the cortex and trabecular region segmentation results. 

44.	 To save the object map select the Save Segmented Cortex Object Map button. 

45.	 Name the object map Cortex.obj.

46.	 Minimize the BMA add-on module; do not close the module.

Figure 4.20. BMA Segment Trabeculae Tab
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4.2.2 Manual Refinement of Cortex Object Map using Volume Edit
The Volume Edit module provides all of the necessary semi-automatic and manual segmentation tools 
required to modify the cortex object map. Here we will review some common tools that can be applied 
to the manual adjustment of the object map to correct small regions 
of trabecular tissue identified as cortical bone and to fill holes in the 
trabecular region. Editing the object map will allow for greater accuracy 
in the measurements generated by the BMA add-on module.

47.	 With the BMA_PE_micro_reformat_sub data set selected open 
Segment > Volume Edit.

48.	 Select File > Load Object Map and load the Cortex object map 
saved in step 45. 

4.2.2.1 Reassigning Cortex to Trabecular Tissue

49.	 In the coronal orientation use the slice slider to navigate through 
the slice display. Note that there are a number of cortical regions 
(shown in red) that should be assigned to the trabecular object 
(shown in yellow) (Figure 4.21). 

50.	 Select the Trabecular Tissue object and then click on the Manual 
tab and choose the Draw tool  .  
 

51.	 Next click on the image and draw over the Cortex regions to be reassigned (Figure 4.22).

52.	 Continue moving through the slice data and correcting regions using this method. 

Figure 4.22. Steps to Reassign Incorrectly Labeled Regions Using the Draw Tool

Figure 4.21. Incorrectly Labeled 
Trabecular Tissue
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4.2.2.2 Filling Holes and Gaps in the Trabecular Tissue

53.	 The Fill Holes option in the Volume Edit module can be used to correct for smaller holes in the 
trabecular tissue. Select the Semi-Automatic tab and then select the Fill Holes tool then click on the 
Trabecular Tissue object to initiate the fill holes routine. Note that 
small holes and gaps will be resolved. 

54.	 To quickly correct larger holes in the Trabecular Tissue object 
(Figure 4.23) it may be necessary to utilize the Fill Holes 
morphological operation from the Objects menu.  

55.	 Select View > Objects to open the Objects window.

56.	 In the Objects window select the Morph object option from the 
button options to the right.

57.	 In the Morph Object window returned set the following 
parameters:

a.  Object to Trabecular Tissue

b.  Operation to Fill Holes

c.  Fill Type to 3 pass 2D

d.  Transverse 

e.  Connectivity to 4-connected

f.  Defined Object to Trabecular Tissue

58.	 Next click Morph (Figure 4.24). 

59.	 Larger holes and gaps in the Trabecular 
Tissue object are now filled and assigned 
to the Trabecular Tissue object. Note 
that this is also a quick way to reassign 
incorrectly identified regions of Cortex 
back to the Trabecular Tissue and could 
provide a utility for Cortex to Trabecular 
Tissue  reassignment without having to 
conduct any manual reassignment as 
described in the ‘Reassigning Cortex to 
Trabecular Tissue’ steps above. 

60.	 Once editing is complete use the File 
> Save Object Map option to save the 
object map as Cortex-edited.obj and then 
close the Volume Edit module.

61.	 In the BMA add-on module use the Load 
Segmented Cortex Object Map to load 
the Cortex-edited.obj map saved in step 60. 

Figure 4.24. The Morph Object Window

Figure 4.23. Hole in the  
Trabecular Tissue Object
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4.2.3 Segment Trabeculae
The second step of the BMA process provides for segmentation of the Trabecular region into Trabecular Bone 
and Intra-Trabecular Space. This segmentation is achieved via threshold-based segmentation.

62.	 To segment the Trabecular region into the Trabecular Bone and Intra-Trabecular Space objects set a 
threshold range using the Trabeculae Thresholds slider (Figure 4.25). 

Figure 4.25. Segment Trabeculae Tab with Thresholds Set to Segment Trabecular Bone
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63.	 Once the threshold has been specified click the Segment Trabeculae button. The voxels specified 
by the threshold range will be assigned to the Trabecular Bone object. The module will automatically 
proceed to the Measure Bone tab (Figure 4.26).

64.	 At this point in the workflow the user will again need to visually review the segmentation result 
to determine if the trabecular bone segmentation is acceptable or not. If the result is acceptable 
then processing can continue and the user can proceed to the Measure Bone step (step 76). If the 
segmentation result requires manual refinement the user has the option to output and modify the 
object map using the Volume Edit module available within Analyze 12.0. The steps neccasary for 
manual refinement are given in section 4.2.4.

65.	 Use the linked cursor tool to inspect the 3 orthogonal slice displays and the 3D rendering of the bone 
to review the trabecular bone region segmentation result.

66.	 To save the object map select the Save Final Object Map button. Name the object map Final.obj.

67.	 Minimize the BMA add-on module; do not close the module.

Figure 4.26. The Measure Bone Tab Showing the Segmented Trabecular Bone in Orange
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4.2.4 Manual Refinement of the Final Object Map using Volume Edit
Here we will review manual segmentation tools in the Volume Edit module that will allow for the correction of 
small regions of trabecular bone identified as cortex. Object map refinement will improve the accuracy of the 
measurements generated by the BMA add-on module.

68.	 With the BMA_PE_micro_reformat_sub data set selected open Segment > Volume Edit.

69.	 Select File > Load Object Map and load the Final object map saved in step 66.

70.	 In the Coronal orientation use the slice slider to navigate through the slice display. Note that there are 
a number of cortical regions (shown in red) that need to be assigned to the trabecular bone (shown in 
orange). 

71.	 Lock the Intra-Trabecular Space Tissue (yellow) object (Figure 4.27), then select the Trabecular Bone 
object and then click on the Manual tab and select the Trace tool.  

72.	 Draw around the regions of cortex to reassign them to the trabecular bone (Figure 4.28). 

73.	 Continue working through the slice data to correct regions in this manner. When completed select  
File > Save Object Map and save the object map as Final-edited.obj.

74.	 Close the Volume Edit module.

75.	 In the BMA add-on module use the Load Final Object Map to load the Final-edited.obj map  
saved in step 73.

Figure 4.28. Steps to Reassign Incorrectly Assigned Regions to the Trabecular Bone

Figure 4.27. Lock Intra-Trabecular Space
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4.2.5 Measure Bone 
The third and final step of the BMA processing workflow is the generation of the bone morphometric indices.

76.	 Specify the directory where all of the measurement 
data spreadsheets will be saved (Figure 4.29). 

77.	 By default all of the Measure Options will be 
checked. Uncheck any option you do not wish 
to generate statistics for. Note that data from the 
QuantumFX microCT scanner does not have 
sufficient resolution to derive cortical porosity 
measurements, therefore the Cortical Porosity 
option should be unchecked (Figure 4.30).  
 

78.	 Click the Measure Bone button 
to start the measurement process. Note that 
it could take several minutes to calculate all 
of the bone morphometric indices. Once the 
measurements have been generated they will be 
displayed in a new tabbed window (Figure 4.31). 
Each of the tabs provides access to a different set 
of measurements.

79.	 Right-clicking on a row or column will allow users to plot the row or column (when supported).

80.	 When the process is complete several .csv files will be saved to the location specified in step 76. The 
.csv files can be opened in MS Excel or any other stats analysis package. 

Figure 4.29. Directory Selector for 
Specification of Output Directory

Figure 4.30. Measurement Options

Figure 4.31. Measures Window
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5. Bone Microarchitecture Analysis: Scanco 
microCT Data Processing
5.1 Data Preprocessing

5.1.1 Data Load
The BMA add-on module requires that input bone specimens have isotropic voxels. To ensure your image 
data is loaded with isotropic voxels load the data using the Load As module and resample anisotropic data 
using the Resize option. 

1.	 Download data set BMA_SC_micro_CT.AVW from  
www.analyzedirect.com/data.

2.	 Open Analyze 12.0 and select File > Load As. 

3.	 In the Load As module use the File button to navigate to 
and select the BMA_SC_micro_CT.AVW data set.

4.	 In the Load As window click on the Resize tab, if the 
voxels are not isotropic, check the Force Cubic option 
(Figure 5.1).  

5.	 Now select the Intensities tab. 

6.	 Note that Scanco data imports with a float data type. To 
decrease the volume size and thus decrease processing 
time load the data set as signed 16-bit. Select Signed 
16-bit from the DataType drop down menu option under Output. The Output Maximum and Minimum 
values will be set to the default for the 16-bit signed: 32767 and -32768. Round the Maximum and 
Minimum values for the Input data and enter these values in the Output Maximum and Minimum fields 
(Figure 5.2). Note that in this example the data set size reduces from 92.72 Mb to 46.36 Mb.

7.	 Select the Load button to load the data set into the Analyze workspace.

Figure 5.1. Load As Module

Figure 5.2. Converting Float Data to Signed 16-bit Data

www.analyzedirect.com/data
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5.1.2 Data Reorientation
The BMA add-on requires that the input bone specimens are orientated into the correct anatomical orientation 
(Figure 5.3). The Oblique Sections module provides the tools necessary to quickly reorientate the data. 

8.	 Select the BMA_SC_micro_CT data set from the Analyze workspace and open  
Display > Oblique Sections.

9.	 Select Tools > Orthogonal.

10.	 Use the Interactive Perp Axis tool to draw a line down the center of the bone to be analyzed. To do this 
click on the image and drag the cursor to a new position; in this example this is done on the sagittal 
orientation (Figure 5.4). An oblique plane (shown in yellow) will be defined perpendicular to the red line.    

11.	 Note that the end of the bone we are interested in analyzing is at the 
bottom of this data set. To orientate this to the top of the data set open 
Tools > Fly from the main Oblique Sections window. Set the Fly Value to 
180 and then click the Pitch Up button once (Figure 5.5).

Figure 5.3. Correct Bone 
Orientation for BMA

Figure 5.4. The Orthogonal Tool

Figure 5.5. The Fly Tool 
Pitching 180 Degrees
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12.	 Now set the Fly value back to 10. Use the Fly tool to roll the oblique plane 
to the correct position in the corresponding orientation.  Note that in this 
example the axis (shown in yellow) on the coronal (middle) image should be 
rotated clockwise; this is achieved using the Roll left button (Figure 5.6). 

 
 

13.	 To output the reformatted data open the File > Output option (Figure 5.7).

14.	 In the Output window set:

a.  The output Name to BMA_SC_micro_CT_reformat. 

b.  Method to Reformat Entire Volume and select Change to best fit data.

c.  Finally select Generate Slices.  
The reformatted data set will be  saved to the Analyze workspace.

15.	 Close the Oblique Sections module.

5.1.3 Subregioning Data
The subregioning or cropping of the input image data set is an 
optional step; however, cropping the data to the bone of interest 
will reduce the total size of the volume and thus decrease 
processing time. 

16.	 Select the reformatted data, BMA_SC_micro_CT_
reformat, and open Process > Image Calculator.

17.	 Right-click on the Calculator interface and select 
Buttons. In the buttons window select the Region Pad 
button and drag it from the Palette to the Key Pad 
(Figure 5.8). Next select Apply, then Save and then Done. 

Figure 5.6 The Fly Tool 
Rolling Left 10 Degrees

Figure 5.7 Oblique Sections Output Window

Figure 5.8. The Image Calculator 
Button Configuration Tool
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18.	 From the main Image Calculator window click the  
Region Pad button ; the Subregion window will open (Figure 5.9). 
 

19.	 In the Subregion window click the Interactive button. 

20.	 In the Interactive window (Figure 5.10) set the yellow box around the bone 
of interest. Use the orientation buttons to navigate between views. 

21.	 Once the crop is set in all three orientations click Apply. When prompted 
select Save a Copy of the Loaded Data. The cropped data will be saved to 
the Analyze 12.0 workspace.

22.	 Close the Image Calculator module.  

23.	 Select the subregioned data set from the Analyze 12.0 workspace and then 
right-click and select Rename from the menu. Change the name of the data 
set from BMA_SC_micro_reformat0 to BMA_SC_micro_reformat_sub.

Figure 5.9. The Subregion Tool

Figure 5.10. The 
Interactive Tool
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5.1.4 Data Presegmentation
This data set contains multiple bones, therefore it is necessary to conduct a preliminary segmentation to 
isolate the bone of interest. This will be used as an input in the BMA add-on module to guide the cortical 
segmentation process. 

24.	 Select the subregioned data, BMA_SC_micro_reformat_sub, and open Segment > Volume Edit.

25.	 In the Object control panel click the Add Object button and name the object Bone (Figure 5.11). 

26.	 Next select the Semi-Automatic tab and choose the Region Grow option. 

27.	 Click on the bone of interest in any of the 3 orthogonal displays to set a seed (Figure 5.12), then use 
the threshold slider to define a global threshold range that represents bone. Now click Extract Object 
(Figure 5.13). All voxels that fall within the specified minimum and maximum threshold range and that 
are spatially connected to the seed will be assigned to the Bone object. For this data set a Min value 
of 3030 and a Max value of 9385 work well.

Figure 5.11. Volume Edit Object Control Panel

Figure 5.13. Volume Edit Semi-Automatic Region Grow Tool 

Figure 5.12. Region 
Grow Seed Point
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28.	 If necessary use the Object Separator tool to separate any bones connected to the bone of interest to 
a new object and then delete. For this data set this step is not required (Figure 5.14). 

29.	 Select File > Save Object Map. Name the object map initial.obj. 

Figure 5.14. Segmented Bone of Interest
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5.2 BMA Processing
Once data preprocessing is complete the image data is ready for processing with the Bone Microarchitecture 
Analysis add-on module. 

30.	 Select the BMA_SC_micro_reformat_sub data set from the Analyze workspace and then open the 
BMA add-on module from the Apps menu.

31.	 As mentioned previously this data set contains multiple bones; to allow the module to distinguish 
between the bone it should process and all other bones it is necessary to load the initial segmentation 
object map created using the Volume Edit module. To do this check the Use Initial Segmentation 
option (Figure 5.15) and then load the object map initial.obj saved in step 29.

32.	 Although an object map has been loaded it is necessary to specify a threshold range that identifies the 
bone in order for the cortex segmentation algorithm to function. Use the Cortex Thresholds slider to 
specify a min/max threshold range to segment the bone or leave the values calculated automatically 
by the module (Figure 5.16). For this data set a Minimum value of 2803 and a Maximum value of 9449 
work well. 

33.	 Next select the Segment Cortex button. Note that the cortex segmentation algorithm is a 
computationally intense process and could take several minutes to complete.

Figure 5.15. Initial Segmentation Option

Figure 5.16. BMA Module with Initial Segmentation Object Map Loaded
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34.	 Once processing is complete the module will automatically move to the Segment Trabeculae tab 
(Figure 5.17). The three orthogonal slices displayed will update to show the Cortex, Cortical Pores and 
Trabecular Tissue objects. 

35.	 At this point in the workflow the user will need to visually review the segmentation result to determine 
if the result is acceptable or not. If the result is acceptable then processing can continue and the user 
can proceed to the second step in the BMA processing workflow: Segment Trabeculae (step 55). If 
the segmentation result requires manual refinement then the user has the ability to output and refine 
the object map using the Volume Edit module available within Analyze 12.0. The steps neccasary for 
manual refinement are given in section 5.2.2. Examples of manual refinement that may be needed 
include the reassignment of incorrectly labeled bone structures and the filling of holes and gaps in the 
trabecular tissue region.  After object refinement is complete the modified object map can be reloaded 
into the BMA add-on module at this point in the workflow using the Load Segmented Cortex Object 
Map option.

36.	 Use the linked cursor tool to inspect the 3 orthogonal slice displays and the 3D rendering; review both 
the cortex and trabecular region segmentation results. 

37.	 Using the parameters specified in this exercise it will be necessary to refine the object map to correct 
for several regions in the object map at this point.

38.	 To save the object map select the Save Segmented Cortex Object Map button. Name the object 
map Cortex.obj.

39.	 Minimize the BMA add-on module; do not close the module.

Figure 5.17. BMA Segment Trabeculae Tab
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5.2.2  Manual Refinement of Cortex Object Map using Volume Edit
The Volume Edit module provides all of the necessary semi-automatic and manual segmentation tools 
required to modify the cortex object map. Here we will review some common tools that can be applied to 
the manual adjustment of the object map to correct small regions of trabecular tissue identified as cortical 
bone and to fill holes in the trabecular region. Editing the object map will allow for greater accuracy in the 
measurements generated by the BMA add-on module.

40.	 With the BMA_SC_micro_reformat_sub data set selected open  
Segment > Volume Edit.

41.	 Select File > Load Object Map and load the Cortex object map saved  
in step 38.

5.2.2.1 Reassigning Cortex to Trabecular Tissue

42.	 In the coronal orientation use the slice slider to navigate through the 
slice display. Note that there are a number of cortical regions (shown in 
red) that should be assigned to the trabecular object (shown in yellow) 
(Figure 5.18). 

43.	 Select the Trabecular Tissue object and then click on the Manual tab 
and choose the Draw tool  .  

44.	 Next click on the image and draw over the Cortex object to be reassigned (Figure 5.19). 

45.	 Continue moving through the slice data and correcting regions using this method.

Figure 5.19. Cortex Reassignment with the Volume Edit Draw Tool

Figure 5.18. Incorrectly  
Labeled Trabecular Tissue
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5.2.2.2 Filling Holes and Gaps in the Trabecular Tissue

46.	 The Fill Holes option in the Volume Edit module can be used to correct for smaller holes in the 
trabecular tissue. Select the Semi-Automatic tab and then select the Fill Holes tool then click on the 
Trabecular Tissue object to initiate the fill holes routine. Note that small holes and gaps will be resolved. 

47.	 To quickly correct larger holes in the Trabecular Tissue object it may be necessary to utilize the Fill 
Holes morphological operation from the Objects menu. 

48.	 Select View > Objects to open the Objects window.

49.	 In the Objects window select the Morph Object option from the button options to the right.

50.	 In the Morph Object window returned set the following parameters:

a.  Object to Trabecular Tissue

b.  Operation to Fill Holes

c.  Fill Type to 3 pass 2D

d.  Transverse 

e.  Connectivity to 4-connected

f.   Defined Object to Trabecular Tissue

51.	 Next click Morph (Figure 5.20). 

52.	 Larger holes and gaps in the Trabecular 
Tissue object are now filled and assigned 
to the Trabecular Tissue object. Note 
that this is also a quick way to reassign 
incorrectly identified regions of Cortex 
back to the Trabecular Tissue and could 
provide a utility for Cortex to Trabecular 
Tissue  reassignment without having to 
conduct any manual reassignment as 
described in the ‘Reassigning Cortex to 
Trabecular Tissue’ steps above. 

53.	 Once editing is complete use the File 
> Save Object Map option to save the 
object map as Cortex-edited.obj and 
then close the Volume Edit module.

54.	 In the BMA add-on module use the Load Segmented Cortex Object Map button to load the  
Cortex-edited.obj map saved in step 53. 

Figure 5.20. The Morph Object Window
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5.2.3 Segment Trabeculae
The second step of the BMA process provides for segmentation of the Trabecular region into Trabecular Bone 
and Intra-Trabecular Space. This segmentation is achieved via threshold-based segmentation. 

55.	 To segment the Trabecular region into the Trabecular Bone and Intra-Trabecular Space objects set a 
threshold range using the Trabeculae Thresholds slider (Figure 5.21). 

Figure 5.21. Segment Trabeculae Tab with Thresholds Set to Segment Trabecular Bone
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56.	 Once the threshold has been specified click the Segment Trabeculae button. The voxels specified 
by the threshold range will be assigned to the Trabecular Bone object. The module will automatically 
proceed to the Measure Bone tab (Figure 5.22).

57.	 At this point in the workflow the user will need to visually review the segmentation result to determine 
if the trabecular bone segmentation is acceptable or not. If the result is acceptable then processing 
can continue and the user can proceed to the Measure Bone step (step ). If the segmentation result 
requires manual refinement then the user has the ability to output and refine the object map using the 
Volume Edit module available within Analyze 12.0. The steps neccasary for manual refinement are 
given in section 5.2.4.

58.	 Use the linked cursor tool to inspect the 3 orthogonal slice displays and the 3D rendering of the bone 
to review the trabecular bone region segmentation result.

59.	 To save the object map select the Save Final Object Map button. Name the object map Final.obj.

60.	 Minimize the BMA add-on module; do not close the module.

Figure 5.22. The Measure Bone Tab Showing the Segmented Trabecular Bone in Orange
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5.2.4 Manual Refinement of the Final Object Map using Volume Edit
Here we will review manual segmentation tools in the Volume Edit module that will allow for the correction of 
small regions of trabecular bone identified as cortex. Object map refinement will improve the accuracy of the 
measurements generated by the module.

61.	 With the BMA_SC_micro_reformat_sub data set selected open Segment > Volume Edit.

62.	 Select File > Load Object Map and load the Final object map saved in step 59.

63.	 In the Coronal orientation use the slice slider to navigate through the slice display. Note that there are 
a number of cortical regions (shown in red) that need to be assigned to the trabecular bone (shown in 
orange). 

64.	 Lock the Intra-Trabecular Space (yellow) and Cortical Pores (green) objects, then select the Trabecular 
Bone object and then click on the Manual tab and select the Trace tool .  

65.	 Draw around the regions of cortex to reassign them to the trabecular bone (Figure 5.23). 

66.	 Note that locking the Cortical Pores and Intra-Trabecular Space objects (Figure 5.24) will allow you to 
only reassign cortex.

67.	 Continue working through the slice data to correct regions in this manner. When completed  
select File > Save Object Map and save the object map as Final-edited.obj.

68.	 Close the Volume Edit module.

69.	 In the BMA add-on module use the Load Final Object Map to load the Final-edited.obj map  
saved in step 67.

Figure 5.23. Steps to Reassign Incorrectly Assigned Regions to the Trabecular Bone

Figure 5.24. Locking Objects
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5.2.5 Measure Bone 
The third and final step of the BMA processing workflow is the generation of the bone morphometric indices.

70.	 Specify the directory where all of the measurement 
data spreadsheets will be saved (Figure 5.25). 

71.	 By default all of the Measure Options (Figure 5.26) 
will be checked. Uncheck any option you are not 
interested in.  
 

72.	 Click the Measure Bone 
button to start the measurement process. Note 
it could take  several minutes to calculate all 
of the bone morphometric indices. Once the 
measurements have been generated they will be 
displayed in a new tabbed window (Figure 5.27). 
Each of the tabs provides access to a different set 
of measurements.

73.	 Right-clicking on a row or column will allow users 
to plot the row or column (when supported).

74.	 When the process is complete several .csv files will 
be saved to the location specified in step 70. The 
.csv files can be opened in MS Excel or any other 
stats analysis package. 

Figure 5.25. Directory Selector for 
Specification of Output Directory

Figure 5.26. Measurement Options

Figure 5.27. Measures Window
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6. BMD Calibration
 
For certain vendor data it is necessary to calculate BMD scaling parameters for proper conversion of CT 
or grayscale numbers to BMD units (mg/CC). This requires that a QRM BMD phantom be scanned with the 
image data using the same acquisition protocol. This calibration exercise has been developed for microCT 
data acquired on the PerkinElmer QuantumFX and the R_mCT2 microCT scanner; however, the exercise 
methodology can be applied to microCT image data acquired using other microCT systems. 

6.1 Data Analysis

1.	 Scan your images and QRM BMD phantom with appropriate acquisition protocol.

2.	 Load the image data for the QRM phantom into Analyze. Ensure it was 
acquired using the same protocol used for the bone images.

3.	 Select the image and open Process > Spatial Filters. Apply a median filter to reduce noise.

Note, when using QuantumFX data: 
a. For the 30mm fast scan a median filter with an 11x11x11 kernel works well. 
b. For the 24mm fast scan a median filter with a 5x5x5 kernel works well.

4.	 Select the QRM BMD phantom data and open Measure > Region of Interest. 

5.	 Use the slice slider to navigate into the data set. Use the Oval tool to define a 
circular ROI over one of the inserts (Figure 6.1). Note there may not be contrast 
(insert) for ‘0’; in this case define the ROI anywhere in the phantom casing. 

6.	 Select the Copy ROI button and copy the ROI to the 4 remaining inserts (Figure 6.2).

 

Figure 6.2. Copy RegionsFigure 6.1. Defining Inserts in a BMD Phantom with ROI
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7.	 Go to View > Objects and 
rename objects with associated 
mg/CC values (Figure 6.3).

8.	 Determine last slice where 
objects should be defined 
then open Generate > Slice:

a.  Set ‘Slice’ to the current slice 
(first slice with objects).

b.  Set ‘Increment’ to number of 
slices between first slice and 
last desired slice.

9.	 Next click the ‘Copy Regions 
Forward’ button. 
 
 
 
 
 

10.	 Open Tools > Propagate Regions. Check all of the objects except 
Original. Then click the Propagate Regions button (Figure 6.4). The 
objects will be propagated to all slices between the first and last slice the 
objects are defined on. 

11.	 Next open Generate > Sample Options and  
set the following (Figure 6.5): 

•	 Sample Type = Object(s)

•	 Summing = On

•	 Auto Reset = On

•	 Sample = All Slices

•	 Sequence Display = Off

•	 Stat Type = Intensity

•	 Decimal Places = 4

•	 Log Stats = On

12.	 Click the Sample Images button and then save 
the generated .stats log file to disk.

Figure 6.3.  
Renaming  
Regions 

Figure 6.4. The ROI  
Propagate Regions Tool

Figure 6.5. The ROI Sample Options Window
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6.2 Calculation of SigmaCT and BetaCT

13.	 Import the measurements into MS 
Excel as a space-delimited file. 

14.	 Plot the grayscale value versus 
mineral density of the phantom.

15.	 Create a linear regression of measured 
grayscale value versus BMD (Figure 6.6).

16.	 Record the slope (SigmaCT) and  
offset (BetaCT) values. In the example 
shown (Figure 6.6), SigmaCT = 
1.0684 and BetaCT = 1023.2.

6.3 Conversion of CT numbers to Bone 
Mineral Density

17.	 Select the bone image data and open the BMA add-on module from the Apps menu. 

18.	 To calibrate the image data to BMD enter the slope (SigmaCT) and offset (BetaCT) values in the BMD 
Scaling Parameters in the lower left-hand corner of the BMA module interface (Figure 6.7). Note that 
these values can be entered at any time in the BMA process prior to calculation of bone measurements. 
For data sets previously sampled and not calibrated to BMD it is possible to resample the data if BMD 
calibration parameters were derived after initial sampling by going to the Measure Bone tab and loading 
the final object map and setting the SigmaCT and BetaCT values before taking the measurements.

Figure 6.6. Plot of the Grayscale Values vs. Mineral Density of Phantom

Figure 6.7. BMD Calibration Parameters
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