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Introduction  
Magic Denoiser is an amazing noise reduction, Photoshop-compatible, plug-in for the Windows 
Operating System designed by ImageSkill Software. The plug-in can also work with other 
commercial software products such as Adobe Photoshop Elements, Corel (Jasc) Paint Shop Pro, 
Microsoft Digital Image Suite and other free software like IrfanView and XnView. A new version 
1.5 of the Magic Denoiser has an improved user-friendly interface allowing users to adjust, if 
necessary, the automatic noise filtering result by changing the size and location of the noise 
pattern and the strength of the noise suppression. Also, new to version 1.5, an impulse noise 
removing option has been added. 

Everyone dealing with digital images knows how annoying noise is in a photograph and how long 
it takes to find optimal settings for a given noise reduction technique to produce an acceptable 
result. Magic Denoiser allows a user to dramatically improve the look of images by cleaning up 
the grainy noise nearly automatically and instantly, while keeping various image features and fine 
details unchanged. The user only needs to pick out a noise sample and location on an image, 
where noise is obvious, and Magic Denoiser cleans up the noise almost instantly. If required the 
user can tick the relevant check box and reduce impulse noise as well. 

When the sensor in the digital camera is small, as in all cameras below DSLR’s, or when a high 
ISO setting and/or long exposure is/are used, an efficient means of removing noise such as Magic 
Denoiser must be used. The plug-in is also very useful for noise reduction in a series of image 
shots, especially when the ISO camera setting and exposure times are fixed and produced nearly 
the same noise in each photo because the series of photographs may then be run as a batch.  

Magic Denoiser allows the user to obtain results that are comparable with those obtained with 
other noise reduction tools which have much more complex user interfaces and at a somewhat 
higher price.  

On the user interface there is also a section called ’Adjust fine details’ which, if the relevant check 
box is ticked, allows the Sharpness and Softness of the image to be adjusted.   

Finally, there is a section unique to Magic Denoiser, which allows the user to blend the cleaned up 
image with the original at infinitely variable amounts to achieve a more lifelike image. 

Features at a glance 
• Very simple and intuitive user interface with only a few controls  

• Very rapid image noise reduction 

• Easy way to create and use presets for specific noise patterns 

• Original high-speed denoising algorithm removing small, medium and large scale grainy 
noise 

• Removes impulse noise independently from grainy noise  

• Performs fine details adjustments viz sharpen and soften 

• Provides simple noise pattern size and location adjustment 

• Allows the strength of the noise reduction to be varied 

• Produces high quality, noise reduced images 

• Supports script (action) feature  

• Has 16-bit image support 
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Minimum System Requirements 
Computer  Pentium 400MHz 

Operation System  Win98, Win200, Win2003, Win XP, Win NT3, Win NT4m Win Vista 

Hard Drive  you must have about 3 Mb of free space 

RAM  64Mb 

Miscellaneous   mouse or other pointing device  

  You must have suitable graphic host software (see below) 

Registering ImageSkill Magic Denoiser 
You can order the full version of this plug-in via ShareIt and RegNow services (both of them 
accept PayPal). If you purchase Magic Denoiser through these services you receive a user name 
and an unlock key. Please enter them carefully without additional blanks. Use copy-paste method 
to avoid errors. 

If you have any trouble with your unlock key, please send an email to sales@imageskill.com

Registered users will receive our email newsletter containing information about new product 
releases and updates, free downloads, articles, tips, and special offers. 

At the moment, any upgrades to our products are given to registered customers free of charge. 

Getting Technical Support 
If you have any troubles with installation, questions, feature requests or notes, please contact us 
by one of the following ways: 

E-Mail: support@imageskill.com

Web site: http://forum.imageskill.com
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Getting Started 

Denoising overview 
 

Image noise - A random, usually unwanted, fluctuation of pixel values in an image. Image noise can originate in film 
grain, or in electronic noise in the input device (scanner or digital camera) sensor and circuitry, or in the unavoidable shot 
noise of an ideal photon detector.  

 From Wikipedia, the free encyclopedia. 

 

What is image noise? 

If a person is asked what noise is in a digital image, one answer is that noise is something 
appearing in it that is absent in the real scene. Noise is present in all digital camera images to a 
greater or lesser extent but only becomes really evident on enlarging the image. Look at the 
image below captured at sunset and at the fragment taken from the upper right corner. It is not so 
obvious that noise is present.  

 

 

 

But if we zoom in by a factor of 150% or higher (see the zoomed fragment below) noise, looking 
like a graininess, having nothing to do with the sky and clouds, becomes strongly visible. 

 

 

There are two main types of noise: chrominance noise and luminance noise. The former usually 
appears as small, off-coloured spots or specks in the image while the latter usually appears as 
small, dark spots that often look like film grain. Both types of noise degrade the image quality 
making the image unnatural. Unfortunately, noise is present in all physical processes. In 
particular, the physical process of recording an image on the CCD in a digital camera produces 
noise – electronic noise. Technical progress in CCD design can reduce the noise in an image but 
cannot remove it completely. It is present in all images even if the images are captured with a top 
end professional camera. Zoom sufficiently into any image, as was done above, and you will find 
some noise. It is, however, interesting to note that noise is more noticeable in some images than 
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others. Noise is more noticeable in uniform tonal areas, such as sky, compared with highly 
textured areas. It is important to say that striving for complete noise reduction in an image is not 
necessarily the best way to improve the visual impression. Psychophysical experimental data 
show that by leaving reasonable amount of noise in an image can make it more lifelike and 
pleasant for viewing. In fact, removing too much noise often leaves the image looking quite 
plasticy. 

 

Why the image appears noisy? 

Not so very long ago, all cameras used film of one form or another.  The properties of the different 
films were well known and the amount of noise or graininess in the resultant photographs could 
be easily anticipated.  Generally the faster the film the grainier the photograph and conversely the 
slower the film the less graininess was apparent in the final result.  With digital cameras it is 
somewhat less certain how noise will degrade the final image using different camera settings. 

 Why should this be? The problem is that the final digital image is the end product of a complex 
series of physical processes. Essentially, the light from an object is focussed by the lens onto the 
electronic detector – the CCD or Charge Coupled Device. The CCD consists of several 
megapixels. The light falling onto each pixel is converted to an electrical signal which is then 
amplified. The built in camera software then manipulates the amplified signal before it is stored on 
the memory card in the camera. The image is then transferred to a computer where further 
manipulation takes place. In general the manipulation of the image by the computer software 
gives better results than the software built into the camera. Any stage of this complex process 
generates its own form of noise. 

For the average photographer it is sufficient to know of the existence of noise and what can be 
done to alleviate the problem. 

.  

How do some digital camera characteristics and settings influence noise level? 

Sensor geometrical size 
The problem is that lots of manufacturers and consumers are fixated on megapixels assuming 
that a camera with more megapixels must take better pictures than ones with fewer. Unfortunately 
this is categorically not true. Actually an important camera factor affecting the quality of the final 
image is the image sensor/CCD size.  For small sensors as in point and shoot cameras the more 
megapixels a sensor has the smaller the individual pixel size and the more heat is generated and 
thus noise. Under these constraints, there is a tradeoff between spatial resolution and light 
sensitivity and optimal performance can be reached with much lower megapixels than you 
actually have. If however you are a stickler for megapixels then keep in mind that a bigger sensor 
gives a less noisy or grainy image. It is for this reason that full size DSLR cameras will always 
give the best resuls but noise never actually disappears.

 
ISO settings 
The camera's ISO settings describe the absolute light sensitivity of the camera's image sensor. 
They usually have the values 50, 100, 200, or 400 but go as high as 800, 1600, and even 3200 on 
some advanced models. This is similar to the ISO rating of the old films.  The principle here is 
very simple – the lower the ISO setting the slower the image sensor reaction will be to incoming 
light. It means that a photo at ISO 100 will take half as long to reach the same level of exposure 
as one taken at 50, other camera settings being equal. Naturally a lower ISO setting is used when 
capturing overly bright scenes, since it reduces the light sensitivity of the image sensor, and a 
higher ISO setting when shooting under dimmer conditions (cloudy days, indoors, etc.) since it 
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increases the light sensitivity of the image sensor. However the user must remember that 
increasing the ISO setting of a digital camera processor amplifies the electrical signal and thus 
increases the noise level. Unfortunately high sensitivity and noise are inseparable; one always 
accompanies the other. In most current consumer digital cameras noise becomes visible starting 
with ISO 200 and higher. It means that you should avoid using high ISO settings if possible even if 
they might be set automatically in your camera. But compromise is always possible when 
increased sensitivity can help you capture the scene. To learn more about actual noise level of 
your camera look at full size test images made under different luminance conditions and different 
ISO settings. You can make these experiments yourself or look at the relevant results at 
http://www.imaging-resource.com/MFR1.HTM?view= where various digital cameras of different 
manufacturers were tested.    

 

Some examples below illustrate how ISO settings affect the appearance of noise. 

 

Canon EOS 350D (sky’s fragments) 

ISO 100         ISO 800              ISO 100        ISO 400 

 

    
 

Canon Power Shot A630 (color patches, F number = 4, Exposure time = 1/125, EV = 11) 

ISO 200           ISO 400          ISO 800 
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Long exposure 
Long exposures (usually 1-2 seconds or more) may lead to the appearance of patterns of 
coloured dots (slightly larger than a single pixel), often referred to as "stuck pixels" or "hot pixel" 
noise. But sometimes you can get noticeable noise increase even if your exposure speed is lower. 
The example below illustrates such effects for the Olympus C740UZ capturing test image at ISO 
setting of 400 and nearly the same exposure value EV of 11.  

 

 
ISO = 400 (F number = 4, Exposure time = 1/125, EV = 11) 

 

 
ISO = 400 (F number = 8, Exposure time = 1/30, EV = 11) 

 

So to prevent the appearance of noise avoid long exposures. 

 
Sensor temperature 
It is known that the higher the sensor temperature is the higher noise level it creates. Fortunately 
normal digital camera usage does not generate excessive heating. But nevertheless keep your 
camera from external excessive heat and switch off when not in use. 

 
To learn more about various Digital Camera noise characteristics visit http://www.imaging-
resource.com/DIGCAM01.HTM

 
In spite of manufactures provide us with better and better sensor noise characteristics and built-in 
camera noise reduction capability there are still instances when we have to shoot at very high 
ISOs, or the camera that we are using has inherent limitations in this regard. Fortunately there are 
various computer noise reduction techniques available that can help us. 

Noise reduction techniques 

Simple denoising technique 
Just about the simplest method of reducing the effects of noise is to use Gaussian Blur. 

 

In Paint Shop Pro click Adjust->Blur-> Gaussian Blur 
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Try a Radius setting of 1 and click OK. For further enhancement Radius can take any value up 
100. 

 

Similarly in Photoshop click Filter->Blur->Gaussian Blur 

The effect of Gaussian Blur is to smooth out the blotchy noise. 

The main advantages of this method are its simple implementation and high calculation speed.   
The disadvantages are the tendency to lose the image’s fine details and the sharpness 
decreases. 

  

Advanced denoising techniques 
It is hard to compare various, advanced noise reduction techniques because they use different 
methods. Also the result much depends on the image to be denoised and the settings used by the 
user. Most of these techniques need to know the unique fingerprint of the noise characteristics 
that a particular model of camera produces at each different ISO setting. You can simply create a 
noise profile (this is discussed later) for your camera's major ISO settings you use or download 
the specific profile from the internet. Do a Google search for ‘Noise profiles’ and this will give you 
several sources of noise profiles. However, the absence of a pre-made noise profile does 
preclude the user from working directly on any new image. In that case the image must have a 
uniform area of a specific size depending on the technique chosen. If there is no appropriate area 
of that size in the image the user is nevertheless able to make the noise reduction but risks 
getting rather over-smooth result. 

 

There are several good noise reduction programs/plugins on the market but, in the main, they are 
significantly harder to learn and also rather more expensive.  Two of the more popular are Noise 
Ninja Professional and Neat Image Pro.  These tools have many settings and the user will have to 
be prepared to read the manual in detail and practice in order to acquire the necessary skills.  

If you do not want to read and understand a manual and tutorials then Magic Denoiser plug-in is 
especially for you.  

It has a simple and intuitive user interface with only a few controls and adjustments. 

It is very fast - almost instant processing. 

It allows the user to create and use presets for specific noise patterns. 

It processes 16-bit images. 

Most importantly, the Magic Denoiser plug-in produces excellent quality results. 

 

What kind of noise does the Magic Denoiser plug-in remove?  
The Magic Denoiser plug-in is designed to remove quasi-random noise in an image produced by 
sensor noise throughout the image. Examples of such noise were shown above. It can also cope 
with impulse noise independently of grainy noise reduction – this is the type of noise reduced 
using the Salt and Pepper filter in Paint Shop Pro and Photoshop. 

 
What kind of noise does the Magic Denoiser plug-in not remove?  
The Magic Denoiser plug-in does not cope with JPEG artifacts.  
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Installing and uninstalling 
Download and run the setup file. The installer finds all the suitable graphic hosts on your 
computer. Choose one of them from the list and then the installer automatically installs the plug-
in. If you want to install the plug-in in another folder, select item "Other path" and set the path. In 
this case you must set the "Plug-ins path" of your graphic host to setup folder. 

Plug-in’s installer automatically detects the following graphic host applications: 

• Adobe Photoshop 7, CS, CS2, CS3, CS4 

• Adobe Photoshop Elements 2, 3, 4, 5 

• Jasc Paint Shop Pro 7, 8, 9 

• Corel Paint Shop Pro (Photo) X, X1, X2 

• Corel Photo Paint 11,12 

• Xara Xtreme 

• Microsoft Digital Image Suite 2006 

• Macromedia Fireworks 2004, 8 

• Ulead PhotoImpact 8,9,10,11,12 

 

Plug-in can also work under the following graphics hosts 

• XnView 1.8 and older 

• IrfanView 

• Corel Painter  

 

This is not an exhaustive list.  The plug-in may be compatible with other graphic hosts as well. 

 

In order to uninstall the plug-in run uninstaller (file uninstall.exe) or use Add and Remove 
Programs item in the Control Panel or Start Menu.  
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How does the plug-in Magic Denoiser work?  

User interface 
Magic Denoiser has 4 main sections: 

A: Toolbar 

B: Grainy noise reduction controls 

C: Impulse noise reduction control 

D: Fine details adjustment 

Pressing the “OK” button causes any processing to be carried out on the full image and a return 
to the host program. 

Pressing the “Cancel” button causes a return to the graphic host leaving the source image 
unchanged. 

The “Help” button runs short HTML help. 

The plug-in processes image data automatically after changing any of the interface parameters in 
B, C and D.  

 

 
The current image zoom factor, the progress bar and the prompt line are placed at the bottom of 
main window. 
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A. Toolbar 

 

 

 

 

 

Zoom – zoom in and out 
of the image when 
working with fine details 

Pan – let you scroll image 
in any direction 

B. Noise reduction controls 

 

                                            

Click on Select noise 
pattern – allows you to 
place noise sampling 
box in the image in 
uniform areas. Clicking 
and dragging any of 
corners, you can adjust 
the box’s size 

Original/Processed – 
defines the extent of the 
processed image blending 
with the original image 

Noise suppression – 
defines the strength of the 
grainy noise reduction 

Clicking on the button “Select noise pattern” a reduced image copy appears in the preview 
window with the square box somewhere within it. The noise profile is obtained from this box. 
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The box has a size of 80x80 pixels by default but you can make it more or less by clicking and 
dragging any of the corners. By clicking and dragging with the left mouse button you can move 
this pattern to any place of the image where you think an appropriate noise profile might be 
located. We suggest choosing a clear sky or other quasi-uniform image area. Never place a noise 
sample in exactly black or exactly white areas of the image to avoid noise underestimation.  

Perhaps surprisingly Magic Denoiser is able to use noise estimation from only one selected noise 
pattern to make effective noise reduction throughout the image. 

The Noise suppression control allows the user to vary the amount of noise suppression as 
necessary. A zero setting corresponds to only the original image with no noise suppression, while 
a setting of 100 shows a strongly denoised image. We recommend using the default setting of 50 
as a good starting point and increasing this into the range of 70 to 90 for strong noise suppression 
as in the example above. 

The Original/Processed control blends the denoised image with the original one. It allows you to 
leave a certain amount of noise in the processed image, preventing it from unpleasant over-
smoothness and making it more lifelike. An Original/Processed zero setting corresponds to only 
the original image, while a setting of 100 shows solely the denoised image. We recommend using 
the default setting of 70 as a good starting point for setting this control and increasing this as 
necessary. 

C. Impulse noise reduction control 

Remove impulse noise control allows the user to remove speckles like the salt and pepper filter 
as in Paint Shop Pro etc. Moving the slider or editing the number in the edit box you can choose 
an appropriate size of speckles you would like to suppress.  

 

 

                                                            

Remove impulse noise – 
check this flag to clean up 
noise like the salt and 
pepper filter 

Size of speckles 
– defines the size 
of speckles like 
the salt and 
pepper filter

 

The result of impulse noise removing on the nose point from the image above is shown in the 
relevant resized fragments below. The left one was produced with unchecked Remove impulse 
noise while the right one was processed with this option checked and Size of speckles is set 
equal to 3. You can easily see the small line   in the left is absent in the right one. 
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D. Fine details adjustments 

Fine details adjustments give the user some flexibility in controlling the image sharpness during 
the process of noise reduction. Of course, sharpening is a matter of personal taste and this 
control contains Sharpen and Soften options that can make the resultant image sharper or 
softer. Both of these options are available when check box “Adjust fine details” is checked. The 
user can choose the desired options by clicking on the relevant radio button (Sharpen or 
Soften). 

 

 

                                                               

Adjust fine details – check 
this flag to make the radio 
buttons available 

 

 

 

 

 

Sharpen – clicking on 
this radio button allows 
the user to get a 
sharper image 

Soften – clicking on this 
radio button allows the 
user to achieve a softer 
image 

If you follow the manual you can easily adjust any of the interface parameters to get the result you 
want. We have chosen a rather noisy image below to show how Magic Denoiser works. Look at 
the original (left) and processed (right) images below and see the result. We are sure that you can 
make it better. Enjoy Magic Denoiser. 
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Plug-in Presets 
If you wish to remove the noise from an image where there is no uniform area larger than the 
minimum size sample box (currently 21x21 pixels) you can experiment by sampling various parts 
of the image until you find a suitable sample.  The alternative is to use Presets which are noise 
samples taken from typical images over time such as bright sky, dull sky, portrait, indoors etc. 

 

 
 

To prepare a given plug-in Preset, select a noise pattern on the image that has uniform color 
distribution. Then press the Save button and write the name of the preset and press OK button.  
We strongly recommend that you use meaningful names for presets and include the noise pattern 
origin (for example, blue sky noise), the ISO setting and the exposure time, as well as any camera 
settings for the image noise reduction or sharpening. The proper name allows you to apply that 
preset to other images created under the same conditions and avoid confusion trying to use a 
preset to process the images that were obtained under different conditions. 
 
When a given Preset is loaded the stored noise profile is used for the noise reduction and the 
relevant noise sample is shown on the button “Select noise pattern”. The obvious benefit of 
Presets is that they can be used to process images that contain nothing but texture, i.e. those 
images where uniform areas higher than 21x21 pixels are absent completely.  
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Working with Magic Denoiser 
All the following commands and image processing are valid for Corel Paint Shop Pro X. 

Source data 
The plug-in can process RGB and Grayscale images with 8 or 16 bits/channel only with or without 
transparency. If you have an image in another mode (CMYK, LAB etc) – Magic Denoiser will be 
disabled in “Effect” menu. See FAQs for another reason why all the plug-ins may be grayed out. 

Starting Magic Denoiser 
Run your graphic host; open an image. Now you can run the Magic Denoiser plug-in. 

Click Effects->Plugins->Image Skill->Magic Denoiser as below. 

 

 
 

ImageSkill Magic Denoiser now starts up.  
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Image denoising  
In order to denoise an image simply go through the steps below each of which were described in 
detail earlier 

• Select Noise pattern and adjust its size first or load relevant preset from plug-in Presets. 
Bear in mind that the noise reduction result strongly depends on what noise pattern you 
choose for noise estimates.  So the noise pattern must be appropriate for the particular 
image in question 

• Set the Noise suppression parameter defining the strength of the noise reduction. It 
varies from 0 to 100% where 0 corresponds to only the original image viewing, while a 
setting of 100 shows very strong image denoising. We recommend using the default 
setting of 50 as a good starting point for this control. 

• Set the Original/Processed parameter defining the extent of the blending the processed 
image with the original one. It varies from 0 to 100% and 0 setting corresponds to only the 
original image viewing, while a setting of 100 shows solely the denoised image. We 
recommend using the default setting of 70 as a good starting point for this control. 

• Check Remove impulse noise flag if you want to clean up speckle noise as with a salt 
and pepper filter and choose an appropriate size of speckle. 

• Check Adjust fine details flag and click on the Sharpen or Soften radio buttons to 
sharpen or soften the image. 

Scripting (Actions) feature 
Some graphic hosts support a scripting feature. In Corel (Jasc) Paint Shop Pro 8, 9, X, X1, X2 it is 
called “scripts”, in Adobe PhotoShop 6, 7, CS, CS2, CS3, CS4 – “actions”. 

Using this option you can batch process a few images which means you can create a series of 
actions to be taken on each of the images in the batch.  

You have to create the script (action) first. 

• Open an image.  

• Start script recording (“File->Script->Start Script Recording” or button on script tool bar).  

 

 
 

• Run Magic Denoiser plug-in (“Effects->Plugins->Image Skill->Magic Denoiser”) 

• Adjust plug-in parameters to achieve a desirable result. Press OK button. 

• Save script recording (“File->Script->Save Recording” or button on script tool bar). 
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Save script as “MagicDenoiser.PspScript” for example. 

 
 

Now you have the script that runs the Magic Denoiser plug-in.  By default this script is saved in 
“Script-Restricted” folder (see more detail in PSP help). You can now use this script for batch 
processing as many batches of images as you like.  You can also “Customize” your workspace by 
placing a button for this script in a toolbar. 

 

Batch Processing 
Run Batch Process command (“File->Batch Process”). 
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Select images to be 
processed using the 
“Browse” button.  

 

Choose “MagicDenoiser” 
as script. 

 

If you run script in “Silent” 
mode, then all images 
will be processed with 
the same plug-in 
parameters as used 
when the script was 
recorded. The plugin’s 
dialog will not appear. 

 

If you run script in 
“Interactive” mode, you 
will be able to adjust the 
plugin’s parameters in 
the plugin’s dialog. 

Result will be saved 
depending on chosen 
Save Mode option. 
Choose the Copy and set 
output folder. In this case 
the processed files will 
be saved in that folder 
with the same names. 

 

Press “Start” button. The 
selected files will be 
processed. 

 

 

Customize your workspace 
You can customize your workspace in Corel (JASC) Paint Shop Pro family.  

 

• Run “Customize” command (“View->Customize”) 

• Choose “Script” tab 

• Select “MagicDenoiser” script, select desirable icon from the thumbnails below 

• Press “Bind” button. 
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Now you can place this button on any toolbar for Magic Denoiser quick launch. 

 

 

NOTE: Adobe Photoshop 7, CS, CS2, CS3, CS4 have similar facilities for script creation and 
batch processing. For details see Abode Photoshop help. 
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FAQ and Troubleshooting 

I can’t find Magic Denoiser in my graphic host’s Effects menu.  
Check that the plug-in is in the graphic host’s Plug-Ins folder, or, if necessary, set the path to the 
plug-in using graphic host‘s “Preferences” option. To do this  

Click Preferences->File locations->Plug-ins and the following screen appears. Make sure the path 
is as shown. 

 

I can’t run Magic Denoiser or Magic Denoiser is greyed out in 
graphic host’s Effects menu.  
Graphic hosts disable the plug-in if the current image is not suitable for use with Magic Denoiser. 
The image must be in RGB or Grayscale format with 8 or 16 bit/channel. If image has CMYK, LAB 
or something other format, you will have to convert it to RGB or Grayscale. 

 

There is another possible reason for this, at least if you use Paint Shop Pro X. There appears to 
be a bug in PSP X such that on power up it sometimes does not recognise the existence of the 
plug-ins. Trial and error has shown that usually if you click through to the screen above and then 
select or deselect ‘Use sub folders’ the plug-ins are then available. Please note that this is not a 
fault with Magic Denoiser. 

NOTE:  
If you did not find the answer to your questions, send your questions to support@imageskill.com 
or send them to support forum http://forum.imageskill.com.   
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