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1 Installation

Before you install Revision Analyser, it is a good idea to first check the system requirements

and installation walkthrough in this chapter.

1.1 System requirements

Revision Analyser will run on any modern PC with Windows 7 or Vista installed. You will need
to have version 4.0 installed of the Microsoft .NET Framework. Some project types also
require the Java Runtime Environment to be installed. You may however decide to not install

these project types.

1.2 Installation walkthrough

We will now go through the installation process step-by-step. The setup will give an error
when .NET Framework 4.0 is not installed, so make sure to have it installed before you start.

i3 Setup - Revision Analyser |‘i‘_‘é]

Welcome to the Revision Analyser
Setup Wizard

This will install Revision Analyser version 1.0 on your
computer,

It is recommended that you dose all other applications before
continuing.

Click Mext to continue, or Cancel to exit Setup.

[ Mext> | | Cancel

Figure 1: Welcome dialog of the installation.

The installation starts with the screen shown in Figure 1. Just press Next to continue.
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i3 Setup - Revision Analyser Ii‘_‘éj

Select Destination Location
Where should Revision Analyser be installed?

] Setup will install Revision Analyser into the following folder.

To continue, dick Mext. If you would like to select a different folder, dick Browse,

Browse...

Atleast 22,4 MB of free disk space is reguired.

[ < Back ][ Mext = ][ Cancel

Figure 2: Select Destination Location dialog.

You should now select a destination location in which you want Revision Analyser to be
installed (Figure 2). You can just leave this to its default and press Next to continue.

‘[[E—,.l Setup - Revision Analyser

Select Components
Which companents should be installed?

Select the components you want to install; dear the components you do not want to
install. Click Next when you are ready to continue.,

:Application Files
SolidsX 2 - Required component for visualization.
User Manual - User manual for Revision Analyser (FDF file).
Recoder Plugin - Project type for Java/SVN analysis.
Sourcerer Plugin - Project type for the open-source project Sourcerer,

Current selection requires at least 22,4 MB of disk space.

[ < Back ][ Next > ][ Cancel

Figure 3: Select Components dialog.

The Select components screen (Figure 3) allows you to select the components you would like
to install. Please note that the SolidSX2 component can only be selected when it is not yet
installed on your computer. The Recorder Plugin component is only visible when you have

the Java Runtime Environment installed on your computer. Press Next to continue after you
made your selection.
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- —
15 Setup - e A —
Select Start Menu Folder
Where should Setup place the program's shortcuts?

= H Setup will create the program's shortcuts in the following Start Menu folder,

To continue, dick Mext. If you would like to select a different folder, dick Browse,

Revision Analyser Browse...

[ Don't create a Start Menu folder

[ < Back ][ Next = ][ Cancel

Figure 4: Select Start Menu Folder dialog.

In the Select Start Menu folder dialog (Figure 4) you can select the folder in which you want
the start menu icons to be placed. If you do not want these icons to be created, you can
check the “Don’t create a Start Menu folder” box. Press Next to continue.

i5 Setup - Revision Analyser Ii‘_lﬂ_hj

sSelect Additional Tasks
Which additional tasks should be performed?

Select the additional tasks you would like Setup to perform while installing Revision
Analyser, then dick Next.

Additional icons:

[T reate a desktop icors

[ < Back ][ Mext = ][ Cancel

Figure 5: Select Additional Tasks dialog.

You can also allow the installation to create a desktop icon for you. You can do this by

checking the “Create a desktop icon” box in the Select Additional Tasks window (Figure 5).
Press Next to continue.
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i3 Setup - Revision Analyser E‘_‘éj

Ready to Install
Setup is now ready to begin installing Revision Analyser on your computer,

Click Install to continue with the installation, or didk Badk if you want to review or
change any settings.

Destination location: -~
C:\Program Files (x86)\Revision Analyser

Setup type:
Custom

m

Selected components:
Application Files
SolidsX2 - Required component for visualization.
IUser Manual - User manual for Revision Analyser (PDF file).
Recoder Plugin - Project type for Java/SVM analysis.
Sourcerer Plugin - Project type for the open-source project Sourcerer,

[ < Back ]| Install |[ Cancel ]

o
I

Figure 6: Ready to Install dialog.

Finally, the Ready to Install dialog will be shown (Figure 6). It contains a review of the
settings you selected during the installation wizard. Press Install to start the installation. It
can take a few minutes before the installation is finished, depending on the options you

selected to install.
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2  Getting started

This chapter will guide you through the functionalities of Revision Analyser. After following
this guide you should have a good understanding of how the application works.

2.1 Creating a new project

We will start of by creating a new Revision Analyser project. After you started Revision
Analyser, click on File > New Project... or press Ctrl+N to create a new project (Figure 7).

e

| Mew Project...  Ctrl+N |

]|

Open Project...  Ctrl+0

Close Project

Exit Alt+Fd

Figure 7: New Project... menu.

This will show the New Project dialog (Figure 8). For this guide, we will create a Recoder
project. There might be other project types available as well, such as Sourcerer. Typeina
name for your project, select a location where the project files should be stored (this will be
automatically filled in by Revision Analyser), and press OK to create the project.

@ E g Recoder

Sourcerer Recoder is a Java framework for source
code metaprogramming aimed to deliver a
sophisticated infrastructure for many
kinds of Java analysis and transformation
tools.,

MName: RecoderProject

Location: C:\Users\Johan'Documents\Revision Analyser\R.ecoderProject

Figure 8: New Project dialog.
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The first time you create a project in Revision Analyser, you will get to see the Global
Variable screen shown in Figure 9. It will ask you for the location of the SolidSX2 executable.
Revision Analyser will try to automatically find the correct path for you (which is usually
C:\SolidSX\bin). Press OK to continue.

" Global Variable | |

The global variable 'SOLIDSX_PATH' is not yet configured. Please enter a value for it
below.

Mame: SOLIDSX_PATH

Value: C: \SolidSxbin|

Figure 9: Global Variable dialog.

If, for some reason, SolidSX2 does not start, you might want to check the licensing
information for this application. Close Revision Analyser and start SolidSX2 manually via Start
> Applications > SolidSource > SolidSX > SolidSX. You will get to see the License wizard
(Figure 10). Here you can buy a license for SolidSX or request a 30-day trial license. After you
registered a valid license file, you can restart Revision Analyser and continue with this guide.

SolidsX Choose license
"Explore your code” A license iz required to use Solid Software eXplorer. What do you

want to do?

I want to try Solid Software eXplorer.
I am going ko use Solid Software ekxplorer for the First time and 1
wank to use my 30-day krial period (requires an inkernet
conneckion],

I want to request another 30-day trial period.
Flease enter vour e-mail address and a new license will be sent ko
you;

@ 1 am done evaluating and want to buy Solid Software eXplorer.;
Buy a license on our website

Y —— .
e 4 —. .
SolidSource ﬁ () I want to use a network license server,

< Badk [ Mext = ] l Cancel

Figure 10: SolidSX2 License wizard.
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A Recorder project will show its own settings dialog after you create a project of this type
(Figure 11). In this dialog you can configure the URL, username and password of the SVN
server. You can test these settings right away by clicking on the ‘Test Connection’ button. In
the Recoder Project Settings dialog you can also add JAR libraries or paths containing JAR
files that are required for a proper analysis.

T

SVM JAR Libraries

Please specify the URL of the VM server below, If needed, you can also specify an
username and passward.

LIRL:
Username:

Password:

[7] show the password I typed

Test Connection

Figure 11: Recoder Project Settings dialog.

When the SVN server uses a SSL connection, you will get to see the dialog box in Figure 12
after you press ‘Test Connection’. Here you have to verify the SSL certificate. Press Yes to
accept it, or No to reject it. When you reject it, you will be unable to use this SVN server for
the project.

' Y
S5L certificate error l'L’-J

. Inorder to use this SVN server, you must accept the certificate and add
__Ié it as a thrusted certificate to the project. Do you want to continue?

Common name: *.ettema.nl

Izsuer: etterna-online nl

Valid from: Tue, 29 Mar 2011 17:5%:03 GMT
Valid to: Thu, 28 Mar 2013 17:59:03 GMT

Figure 12: SSL certificate error dialog.
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2.2 Manage revisions

Now that the SVN server is configured, we can start to fetch revisions from the revision
server. Open the Manage SVN Revisions dialog (Figure 13) by clicking on the Project >
Manage SVN Revisions... menu item or by pressing Ctrl + M.

r R
Manage SVN Revisions l B | eS|
Revision Author Date Message
0 4-10-2010 19:00:58
10 Mark 6-10-2010 23:12:39 - Added LEDs support
20 johan 11-10-2010 12:57:43 nieuwste versie
30 johan 12-10-2010 13:19:23
40 johan 17-10-2010 20:39:26
50 johan 19-10-2010 10:45:09
&0 johan 19-10-2010 12:54:39
70 Mark. 25-10-2010 12:20:37 Addsensor
80 johan 26-10-2010 10:46:02
390 johan 26-10-2010 23:37:54 minimize widget works!
o)
h

Figure 13: Manage SVN Revisions dialog.

2.2.1 Adding revisions

We will start off by adding revisions to the project. Press the ‘Add..." button in the Manage
SVN revisions dialog. This will open the Add SVN Revision(s) dialog (Figure 14).

r
Add SVN Revision(s) B EERS
Search Revisions
Revision Author Date Message

Figure 14: Add SVN Revision(s) dialog.
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In this dialog we can search for revisions on the SVN server. You can select a date range and
press Search to show revisions that were committed within that range. You might want to
limit the search results to a maximum of 100 (or more) to speed up the process. You can also
search using multiple date ranges by pressing the ‘Advanced...’ button. This will open the
Advanced Search dialog (Figure 15).

Advanced Search - @

You can add multiple date ranges to your search query below.

From: 13-10-2010 [Ev  To: is-10-2010 [E~

Start Date End Date
4-10-2010 §-10-2010
13-10-2010 15-10-2010

Limit search results:

Csma ) [ oo |

Figure 15: Advanced Search dialog.

After you have searched for SVN revisions, you must select the revisions that you want to
analyse. There are three selection methods available:

e Select All: this will select all SVN revisions for analysis.

e Select %: this will select a given percentage of SVN revisions (see Figure 16). By
default this is set to 10%, but you can change this yourself.

e Select None: this will remove all selections that you made.

r B |
Select Percentage ﬁ

Select the percentage of items you would like to evenly select from
the list of revisions.

rJ 10%

Figure 16: Select Percentage dialog.
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Figure 17 shows an example of how the selection might look like in the end. In this
screenshot, revision 5 is selected to be analysed. Revisions 0 and 10 were already analysed
before, and therefore have gray text and cannot be selected again. Press ‘Add’ to add the
revisions you selected to the Manage SVN Revisions dialog (Figure 13). Please note that the
‘Add’ button is only enabled after you have selected at least one revision. Press ‘OK’ in the
Manage SVN Revisions dialog to start the analysis.

Revision Author Date Message
[ o 4-10-2010 19:00:58
|:| 1 johan 4-10-2010 19:03:00 1e revisie
[z johan 4-10-2010 19:03:42 bin en obj hoeven niet op SVN
[ 3 johan 5-10-2010 12:36:16 Login functies enz.
! johan 5-10-2010 13:04:58 Admin gedeelte
5 johan 5-10-2010 18:30:18 Login fix
[ s johan 6-10-2010 13:10:41 added Divan and Netwonsoft, Json libraries
[ 7 johan 6-10-2010 13:12:02 added references to libraries
|:| 8 johan 6-10-2010 14:52:45
[ s Mark 6-10-2010 21:45:51 - SensorInterface Atmel software
T Mark 6-10-2010 23:12:39 - Added LEDs support
[ 11 johan 7-10-2010 14:08:32 Divan wordt nu nog gebruikt

Figure 17: Overview of the selected revisions.

2.2.2 Deleting revisions

If, for some reason, you would like to delete a revision, you can do this in the Manage SVN
Revisions dialog (Figure 17). Revisions that you added for analysis in the previous paragraph,
are noted with a green plus (+) sign in front of them. You can delete these revisions right
away by selecting them and pressing the ‘Delete’ button. Revisions that were already
analysed before, can also be deleted the same way, but will get a red minus (-) sign in front
of them. You can also revert this by pressing ‘Undelete’. Press ‘OK’ to apply the changes.

r ~
Manage SVN Revisions I. 1 S
Revision Author Date Message
o] 4-10-2010 19:00:53
10 Mark 6-10-2010 23:12:39 - Added LEDs support
20 johan 11-10-2010 12:57:48 nieuwste versie
30 johan 12-10-2010 13:19:23
40 johan 17-10-2010 20:39:25
@ s0 johan 19-10-2010 10:46:09
&0 johan 19-10-2010 12:54:39
70 Mark 25-10-2010 12:20:37 AddSensor
[-] =0 johan 26-10-2010 10:46:02
90 johan 26-10-2010 23:37:54 minimize widget works!
@ 5 johan 5-10-2010 18:30:18 Login fix
@ 7 johan 6-10-2010 13:12:02 added references to libraries
@ s johan 6-10-2010 14:52:45
@ 13 Mark 7-10-2010 18:55:43
[ Add... ] ’ Undelete ] O ] ’ Cancel
h

Figure 17: Deleting SVN revisions.
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2.2.3 Task log

Whenever you add or delete one or multiple revisions, you will get to see the Task Log

(Figure 18) after you press ‘OK’ in the Manage SVN Revisions dialog. In this Task Log you get

to see a detailed overview of the progress of the tasks that have to be performed. You can

only close the Task Log after all tasks have been completed.

Task Log

Task Log

This window shows a log of the tasks that have to be processed. After the tasks are finished, you may export it to a HTML file.

Working on task 3/7: —
Time Event
12:31:01 Starting RemoveTask (1/7)...
12:31:01 Removed SVN revision 50
12:31:01 Starting RemoveTask (2/7)...
12:31:01 Removed SVN revision 80
12:31:01 Starting AddTask (3/7)...
12:31:01 Checkout/Update started
12:31:03 Add: C:\Users\Johan\Documents'\Revision Analyser \RecoderProject\SVN\Architecture
12:31:06 Add: C:\Users\Johan\DocumentsRevision Analyser\RecoderProject\SVN Architecture\SensorViewArchitecture, pdf
12:31:07 Add: C:\Users\Johan'DocumentsRevision Analyser\RecoderProject\SVM\Architecture\SensorViewArchitecture. synctex.gz
12:31:07 Add: C:\Users\Johan'\Documents\Revision Analyser\RecoderProject\SVN\Architecture\SensarViewArchitecture. aux
12:31:08 Add: C:\Users\JohanDocumentsRevision Analyser\RecoderProject\SVNVArchitecture \tempfile, tmp
12:31:08 Add: C:\Users\Johan\DocumentsRevision Analyser\RecoderProject\SVNVArchitecture\SensorViewArchitecture. tex
12:31:08 Add: C:\Users\Johan\Documents\Revision Analyser\RecoderProject\SVYN\Architecture\SensorviewArchitecture.log
12:31:08 Add: C:\Users\JohanDocumentsRevision Analyser\RecoderProject\SVN Architecture \Visio
12:31:10 Add: C:\UsersJohan\DocumentsRevision Analyser\RecoderProject\SVN Architecture \Visio \MultiTier Architecture, pdf
12:31:11 Add: C:\Users\Johan\Documents\Revision Analyser\RecoderProject\SVN\ArchitectureVisio\DemoWeb. pdf

[ automatically dose this dialog after the tasks have been processed.

Figure 18: Task Log dialog.

2.3  Using the revision timeline

After you have added one or more revisions to the project, you can start using the revision

timeline. The revision timeline (shown in Figure 19) allows you to easily select a revision that

you want to show in the SolidSX2 component. You can do this by simply clicking near the

revision that you want to show. The application will automatically select the revision that is

the nearest to your mouse click.

Version 1.0

Figure 19: Revision timeline.
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3  Other functionalities

This chapter discusses functionalities that do not fit within the other chapters.

3.1 Application settings

The Tools > Options menu item in Revision Analyser will open the Options dialog (see Figure

20). Here you can add, edit or delete global variables used across project types. For example,

if you move SolidSX2 to another location, you will have to change the global variable for this.

{ Global Variables |
Name Value Add...
JAVA_PATH Ci\Windows\system32} =
SOLIDSX_PATH C:\SolidsX \bin =t

Delete

Figure 20: Options dialog.

3.2 View loaded plug-ins

You can view the currently loaded plugins by clicking on Help > About Revision Analyser. In

the About screen, press the ‘Plug-ins..." button to open the Plug-ins dialog (Figure 21). In this

dialog you can see the loaded plug-ins and more information for each of the plug-ins.

Loaded plug-ins:

Sourcerer

Plug-in information:

Name: -
Recoder

Description:

Recoder is a Java framework for source code
metaprogramming aimed to deliver a sophisticated
infrastructure for many kinds of Java analysis and
transformation tools.

Copyright:
© 2011 Johan van der Geest and Mark Ettema

Version:
1.0.0

| |

Figure 21: Plug-ins dialog.

Have you ever heard of the Konami code? Why not give it a try in the About dialog!
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