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1.0 General Information 

1.0 GENERAL INFORMATION 

1.1 System Overview 
 

iVision-HB Brinell Hardness Indentation Automatic Measurement 
System is used in automatically measuring the indentation diameters, 
calculating and reporting the hardness HB values in the Brinell 
hardness test and measurement.  The system includes one or 
two handheld USB cameras (optional) and the iVision-HB 
image acquisition and automatic measurement software. 
Plain USB camera head is also available for the cases of 
direct HB hardness measurement on the Brinell hardness 
tester. 

1.2 System Requirements 
 
System: IBM compatible PC with Windows XP, Windows Vista, or Windows 7 32-bit or 64-bit 
operating system. 1GHz CPU and 512MB RAM or higher are recommended due to the intensive 
calculation in image processing. At least two USB2.0 ports are required with one for the USB license key 
and another for the handheld USB camera. 
 
Supporting Software: In order to generate Word reporting, MS Office (2003 or higher) Excel and Word 
are needed. 

1.3 Main Features 

1.3.1 Automatic HB hardness measurement 
With a mouse click, or a keyboard press or a push on the camera snapshot button (Digital microscope 
camera only), iVision software automatically measures the indentation diameter and calculates the HB 
hardness value. The indentation diameters can range from less than 1mm up to 6mm. For small 
indentations with diameter less than 2mm, the system provides a second camera (optional) with higher 
magnification for better measurement accuracy. The system also allows convenient manual measurement 
or the correction on the automatic measurement results. 

1.3.2 Camera calibration 
iVision software provides two methods in calibrating the camera:  
1) Calibration with a standard sample with known HB value; 
2) Calibration on a calibration ruler or grid. 

1.3.3 Hardness conversion 
The measured HB value can be converted to the other hardness scales such as HV,HR etc . 

1.3.4 Statistics 
Statistical values such as average, standard deviation, Cp, Cpk etc are automatically generated, and off the 
limit values are automatically marked. 
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1.3.5 Reporting 
With a mouse click, iVision software automatically generates a Microsoft Word or Excel document that 
reports the measurement data, statistical information, and the measurement image. The Word or Excel 
document template can be customized to user’s requirements. 

1.4 Standard Features 

1.4.1 Geometric Measurement 
System provides the tools to draw and measure common geometric shapes such as lines, angles, 4-point 
angles (for missing or hidden vertexes), rectangles, circles, ellipses, and polygons.  Note that the 
measurement assumes the system is calibrated. 

1.4.2 Image Processing 
System provides a rich set of image processing tools for advanced users. The standard tools in the system 
include adjusting Brightness, Contrast, Gamma, and Histogram Level, and the Sharpen, Smooth, Invert, 
and Convert to Grey functions.  On grey scale images, system provides various advanced tools in 
filtering and finding edges, as well as some standard tools in morphological operations such as 
Open,Close,Dilation,Erosion, Skeletonize,and Flood Fill. 

1.4.3 Document Entry 
On an image, system provides a document editor to enter/edit documents with contents either in simple 
plain text format or in advanced HTML format with objects including tables, list, and images. 

1.4.4 Album Management 
System allows user manage multiple images in an album which can be saved to and opened from an 
album file. The images can have the standard geometric shapes and the documents as entered by user as 
described above. 

1.4.5 Printing With Specified Magnification 
System can print the image with user specified magnification if it is calibrated. 
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2.0 SOFTWARE INSTALLATION 

2.1 Installation Overview 
 
iVision software is modular in architecture. It consists of the application platform and upon which the 
application modules.  The following components are installed in iVision-HB: 1) Microsoft VC++ 
redistributable package since iVision is developed with MSVC; 2) iVision software platform; 3) USB 
camera driver and its DirectShow driver; 4) iVision-HB application modules including the main HB 
automatic measurement module. 

2.2 Installation Instructions 
 
Double-click the installer file iVision_v1.0.0_WIN32_XP_TZXXXXXX_installer.exe to start the 
installation process, and answer “Yes” at all the prompts in the camera driver installation, where 
TZXXXXXX is the USB license key ID.  Note to change the drive in installation directory if other than 
the default D: drive. Also note that if installation error message “II Camera 02 DirectX registration failed” 
shows up in the installation process, then it is necessary to manually register the camera DirectX driver 
after the installation process by running (double-clicking) the reg.bat in the iVision installation folder 
(D:\Intelligent Instruments\iVision_v1.0.0\Drivers\II_Camera_02\DirectX).
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3.0 GETTING STARTED 

3.1 Camera Setup 
It is necessary to set up the USB camera for the system at the first time use and these steps can be totally 
skipped at later use. 

3.1.1 Camera driver installation 
When the USB camera is plugged in at the first time use after iVision-HB is installed, depending on the 
computer operation system the computer may ask to install the camera driver either manually or 
automatically.  Answer “automatic” since the camera driver is already pre-installed during installation. 

3.1.2 Camera selection 
Open iVision, select menu Image Capture ->Open capture window to invoke the “Media Capture” 
window.  Then go to menu Devices and select the camera Digital microscope or II Camera 02 that 
comes with this application. Note that there may be other cameras that are installed on the PC. 

 

3.1.3 Camera resolution setup 
In the HB measurement, two image resolutions are set automatically in the application, one is 640X480 
( Digital microscope) or 640X512 (II Camera 02) (measuring indentation in 2mm-8mm range) while the 
other is double the width and height (the high resolution mode measuring in <1mm to 4mm range).  
Nevertheless, user may manually select the camera resolution in the other application GeoMeasure 
(geometry measurement). On Media Capture window, select menu Options -> Video Capture Pin… to 
bring up the camera video format setup Properties dialog and select resolution from Output Size(Digital 
microscope) or Video Format (II Camera 02). 
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Video format setup of (a) Digital microscope;    (b) II Camera 02. 

3.1.4 Camera parameter setup 
On Media Capture window, select menu Options -> Video Capture Filter… to bring up the camera 
parameters setup Properties dialog.  
 

 
 

(a) Digital microscope: Normally running in automatic mode, the camera parameters rarely need user 
setup. However user may manually change them if needed.  
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Select menu Options->Preview, video preview should appear on both the Media Capture window and the 
main window.  The Media Capture window can be closed if no more setup is needed. 
 
(b) II Camera 02: Under tab Plugin, click button Plugin, select menu Plugin Manager… to invoke the 
Plugin Manager dialog. Make sure all the plugin components are checked. 
 

   
 
Go back to Media Capture window, and select menu Preview, camera video preview should appear on 
both Media Capture window and iVision main window. Select menu Options -> Video Capture Filter… 
to bring up the camera parameters setup Properties dialog again and adjust the A/D -> Change Level 
under Capture tab, and the Shutter->Speed and the Gain->Gain parameters under Control tab for the 
best quality image capture. Exit iVision and the camera parameters should be saved for the next start. 
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3.2 Starting the application 

3.2.1 Graphical User Interface (GUI) setup 
Layouts: User may start the application iVision either by pushing the camera snapshot button or starting 
from the PC just for a regular PC program. At first startup, select menu HB -> HB measurement, the 
main interface of this application will appear. User may adjust the splitter dimensions and the table 
column widths to his/her preference, and the system will keep the GUI settings at next startup. 
 

 
 
Configurations: Many other GUI settings such as menu orders can be configured in the Configuration 
Settings dialog through menu File -> View/Edit configurations… 
 

 
 

Language: To choose a different GUI language, go to menu Help and select menu Language. Choose the 
new language and the application will exit.  After restarting the application the new language will take 
effect. 

3.2.2 Camera calibration 
In order to get quantitative geometry measurement (e.g., indentation diameter) from the camera image it 
is necessary to calibrate the camera to obtain the conversion from pixel locations to their object physical 
locations. There are two ways to calibrate the camera in the HB hardness measurement: 
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1) Calibration with a calibration sample with known HB value 
 
If no calibration is done and loaded in the system, then the system can derive the calibration based on the 
first measurement and the user input of the known HB value of the sample. 
 
Open iVision, go to the tab Settings at the lower right on the HB measurement GUI, make sure the High-
Resolution Measurement is unchecked since the calibration will be based on the normal resolution. 
 

   
 
Sample test parameter set up:  go to the tab Settings in the lower right, click on the Test Settings 

 button to bring up the HB Measurement Settings dialog, select F/D2 and the testing Ball Diameter 
of the sample and the indentation force will be automatically calculated. 
 
Video preview:  Under the tab Settings, make sure the High-Resolution Measurement is unchecked. 

Place the handheld camera on an indentation on the standard sample, and click the Video Preview  
button to start video preview. Move the camera head so that the indentation appears and shows clear edge. 

 
 

Calibration: Click on the Auto Measure  button to find and measure the indentation.  If the system 
is able to find the indentation, then the HB Measurement Settings dialog will prompt user to enter the 
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known HB value of the sample. If the found circle matches with the real indentation then enter the value, 
otherwise cancel the entry and manually drag the circle to match the indentation and then enter the value.  
If in any case the system could not find the indentation then user may manually draw and match the 
indentation on the image and the system will prompt the entry.  There are two methods to manually 

measure the indentation: 1) Measure by circle ;2) Measure by major-minor axes . In case of 
measurement by circle, mouse press on one end of the indentation diameter and drag to the other end. If 
the indentation shape is elliptical, then measurement by major-minor axes applies, mouse press on one 
end of the indentation major axis and drag to the other end, and then do the same on the minor axis.  
After the user input of the HB value the system is calibrated and ready for use. Note: the formula to 
calculate HB is: HB = 2 X F / (πX Db X (Db – (Db

2 – Di
2)1/2)), where F is the test force in Kg, Db is the 

indenter ball diameter in mm, and Di is the indentation diameter in mm. 
 

   
 

Note: If user wants to unload the calibration to make the system go back to the un-calibrated state, select 
menu Calibration->Calibration viewer to bring up the calibration selection dialog, and click the Unload 
button. 
 

 
 
Re-calibrate with sample average: For better accuracy, the system allows user to re-calibrate with the 
average of the HB values from calibration sample.  To do so, measure HB values on multiple 
indentations on the same sample to get the average, click on the Re-calibrate with sample average button 

 in the Settings tab and enter the sample HB value at the prompt.  The new calibration is activated 
and saved automatically. 
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2) Calibration on a calibration ruler or grid 
User may prefer to calibrate the camera directly with a standard ruler instead of a standard hardness 
sample, especially when the calibration is used in geometry measurement instead of hardness 
measurement. 
 
a) Manual calibration 
Manual calibration simply calculates the linear scale between the pixel distance and the physical distance 
of two points on image.  Place the calibration ruler or grid under the camera, start video preview by 
selecting menu Image Capture -> Preview, move the ruler or camera to make sure the lines are 
approximately aligned in preview and snap an image by selecting menu Image Capture -> Capture 
Image.  
 
Select menu Calibration -> Manual calibration, hold down the mouse and drag from one line to another 
line with known and adequate separation distance and then release mouse.  
 

 
 
A dialog will prompt user for the known physical distance between the dragged start and end lines and a 
name for the calibration.  After the manual calibration is done, system will prompt user whether to load 
the done calibration or not.  In any case user can load the named calibration by selecting menu 
Calibration->Calibration viewer and load the calibration from there. 
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b) Automatic calibration 
Automatic calibration is much more complex in process but more convenient in usage.  It automatically 
finds the cross points on the grid image, map them to their physically locations and obtain the true 2-D 
mapping between a physical location and its pixel location via interpolation. 
 
In stead of a calibration ruler, a calibration grid is needed to do the automatic calibration.  First select 
menu Calibration->Auto calibration settings to set up the X&Y line distance, unit etc.  If the lines in 
image will be darker than the background then Invert Image needs to be checked. Snap an image with the 
grid approximately aligned.  Select menu Calibration->Automatic calibration to perform the automatic 
calibration after which the system will locate and mark most of the cross points of the grid image. 
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3.2.3 Measurement settings 
Indentation force, ball diameter, and warning upper/lower limits etc are set in the HB Measurement 
Settings dialog (by clicking on menu HB ->HB measurement settings or by clicking on the Test 
Settings button under Settings tab). 

 
 
Note that in automatic measurement the limiting dimensions (e.g., min/max diameters, min/max center 
locations) can be set in this dialog.  
 
Two algorithms are developed in automatically measuring the indentation, one is Brightness (by 
indentation brightness on the image) which is default while the other is Edge (by indentation edge).  In 
special cases, if the image background and the indentation are all dark but the indentation edge is clear, 
then select Edge. In the below pictures, the left is by Brightness (default) while the right one has to be 
detected by Edge. User needs to select this Auto-measurement method in the settings depending on the 
camera lighting and sample surface conditions. 
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3.2.4 Measurement 

1) Auto measurement: Click on the Video Preview  button to start video preview and click on 

the Auto Measure  button to automatically measure the hardness HB.  For convenience, after 
video preview is started, system allows user to toggle video preview and auto measurement by 
pressing a keyboard key (except the ESC key and the Delete key) or by pressing the camera snapshot 
button. To exit the keyboard key toggle mode, press the ESC key. 
 
For small indentations (< 2.5mm), user may check the High-Resolution Measurement under 
Settings tab, and the camera will switch to high resolution mode for measurement with better 
accuracy. 

 
If there are multiple indentations appearing on the same video preview or on the same image, user can 

select and measure. First take the snapshot (clicking the Snap Image tool button) if in 
previewing, drag the mouse to select the area on the image that contains the indentation, then click the 

Auto Measure  button to automatically find and measure the HB of that indentation. 
 

   
 
Note that with the camera Digital microscope sometimes when switching between high-resolution and 
normal resolution, the video preview becomes very dark if the sample surface is highly reflective and 
the camera is in auto white balance.  When that occurs, simply go to Camera settings and press the 
default button to restore to normal. 

 
2) Manual correction: If the indentation label circle (in case of Measure by circle) or the major-minor 

axes (in case of Measure by major-minor axes) is off the real indentation, mouse click on the circle or 
the 4 vertices and move to align with the real indentation, and the new HB value will update 
automatically. 
 

3) Manual measurement: If user needs to manually measure indentation diameter and HB, click on the 
manual measurement button (either Measure by circle  or Measure by major-minor axes 

),In case of measurement by circle, mouse press on one end of the indentation diameter and drag 
to the other end. If the indentation shape is elliptical, then measurement by major-minor axes applies
mouse press on one end of the indentation major axis and drag to the other end, and then do the same 
on the minor axis. The measured HB will show in the table. 

, 

 
4) Delete measurement: Select the measurement rows in the table (by clicking on the vertical table 

header), and click on the Remove Measurements  button to remove the selected rows. 
 



 
3.0 Getting Started 

 

User’s Manual   Page 3-11 
 

5) New Sample: Click on the New Sample  button, all data in the data table will be cleared. 
 

6) HB conversion: Under HB Conversion tab in the HB measurement main interface, select the 
conversion table from Conversion Table and a conversion type from Converted Hardness, the 
converted hardness value will be displayed in a separate column in the table.  If the conversion data 

is not needed, just click on the Delete Converted Hardness  button to remove. If to update the 

conversion data, simply click on the Update  button. 
 

7) Validation: Under the Validation tab, click on the Update  button or the Delete Validation 

Columns  button to generate or to remove the validation columns.  The validation columns 
displays the columns Min Sample Thickness for minimum sample thickness, Min Indent Dist for 
minimum distance between indentations, and Min Indent-Edge Dist for minimum indentation to 
sample edge distance for all the measurements in the data table. 

 

3.2.5 Reporting 

Click on the Generate Report  button, the measurement data together with the statistical data and 
the measurement images will be reported in a Microsoft Word or Excel document depending on user’s 
specification. The Word or Excel document template can be customized to user’s requirements. 
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3.3 Appendix: Using the standard features 

3.3.1 Geometric Measurement 
Select any one of the sub-menus on the menu GeoMeasure, the geometric measurement main interface 
will appear.  Draw the standard geometric shapes on the image and their measurement results will be 
displayed on the data table on the right and on the shapes for some shape types.  User may edit a shape 
by click selecting the shape and mouse dragging on one of its control points, and the corresponding 
measurement results will be automatically updated. 
 

 
 

3.3.2 Image Processing 
Select menu Preprocess and its sub-menus to access the image processing tools. 

3.3.3 Document Entry 
Push on the Add text tool button, or select Add text sub-menu under GeoMeasure, then click on the 
image, enter text at the small text entry box. To edit the text or to enter complex HTML format 
documents, double click on the text to invoke the document editor. 
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To edit the text in HTML format, select HTML on Text type. To insert table, list, or image, click on the 
tool buttons at the right bottom.  The tool buttons to change font, text color, and text alignment lie at the 
left bottom. 

3.3.4 Album Management 
 To view the album, select menu View->Image Album. To change image display size in album, move 

the splitter.  Album can be docked in the main window and it can be floated also. 
 Double-click on the image will copy the image into the album, and conversely double-click on the 

image on the album will copy it to the image panel 
 To open/save album file go to menu File 
 To reorder the images in album, drag an image with its frame and drop it to position 
 To remove an image or images on album, click to select and press the Delete key 

 

 

3.3.5 Printing With Magnification 
Connect to the printer first and select menu File->Print… to bring up the printing dialog.  Select or 
enter the desired magnification at the bottom, the image print size will change accordingly in preview. 
User may enter text (can be in HTML format to include tables,lists,images etc) under user input and the 
text will be saved for next printing.  Analysis result tables and statistics summaries can be checked for 
printing. And all the above elements to be printed have options in printing locations in either top, 
bottom,left, and right.  The textbox widths can be limited by their width inputs. 
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